A propos de ce document

Ce document a été construit automatiquement à partir de la documentation HTML disponible sur java.sun.com. Il est périodiquement remis à jour, lorsque de nouvelles versions des documentations originales deviennent disponibles. Pour télécharger librement et gratuitement ces mises à jour, mais aussi d''autres documents Java au format HTMLHelp ou WinHelp, visitez le site de Franck Allimant :

http://javadoc.allimant.org/

Bonne utilisation !

Contact

Les remarques et les suggestions sont les bienvenues. Merci de les faire parvenir à Franck Allimant.

Notes

La documentation HTML originale est disponible sur java.sun.com. Merci de la consulter si vous avez des incertitudes à propos les informations présentées dans ce document.

La version HTMLHelp de cette documentation diffère par quelques points de la version HTML, à cause de certaines limitations de HTMLHelp.

1. Applets Java

Les applets Java 1 fonctionnent correctement dans HTMLHelp, pourvu que les classes Java ne soient pas embarquées dans le fichier d'aide (chm) lui-même. Elles sont stockées dans le répertoire applets, qui se trouve au même endroit que le fichier d'aide. Ce répertoire n'est pas nécessaire au fonctionnement de l'aide : s'il est absent, les applets ne seront pas affichées.

Le plugin Java n'est pas supporté par HTMLHelp. Les applets nécessitant une machine virtuelle Java 2 ne peuvent pas être exécutées.

2. Fichiers nécessitant un plugin

Le support des plugins n'est pas complet dans HTMLHelp. En fonction de la configuration de votre machine, certains problèmes peuvent survenir lors de la visualisation de ces fichiers, en particulier les documents PDF.

3. Occurrences multiples d'un mot-clef de l'index

Si un mot clef de l'index pointe vers plusieurs documents, une page listant toutes les occurrences trouvées est affichée. Cette page fournit le titre des documents dans lequel le mot clef apparaît, et s'il s'agit d'une méthode, les paramètres de cette méthode. Ce mode d'affichage très détaillé a été préféré à la boîte de dialogue "Rubriques Trouvées" proposées en standard par HTMLHelp, pour permettre une navigation plus efficace et plus rapide dans un grand nombre de documents.

Merci à...

a.do Consulting, pour offrir gratuitement un parser HTML écrit en Java aussi compact et efficace.

Doug Kramer, de Sun, qui a autorisé la distribution des documentations Java pour WinHelp et HTMLHelp.

Distribution

Ce logiciel est gratuit. Il ne peut être diffusé sur Internet ou dupliqué que dans des buts non commerciaux, pour usage privé exclusivement. Toute distribution par CD-ROM est soumise à une autorisation préalable [contact].

Toutes les restrictions de distribution imposées par Sun à la documentation originale sont applicables au présent document. Consultez cette page (en anglais) pour en prendre connaissance.

Copyright © 1997-2004, Franck Allimant


About this document

This document is built from the HTML documentations available at java.sun.com. It is regularly updated, when new versions of original documentations become available. To download updates and many other WinHelp and HTMLHelp Java documentations for free, visit Franck Allimant's web site :

http://javadoc.allimant.org/

Contact

Comments and suggestions are welcome. Feel free to send them to Franck Allimant.

Notes

The original HTML documentation is available at java.sun.com. Please refer to this original documentation if you're not confident with the present document.

Due to some HTMLHelp limitations, there are some differences between this help file and the original HTML version of the documentation.

1. Java Applets

In most cases, Java 1 applets are running inside the HTMLHelp viewer, provided they're not embedded in the help (chm) file. They are stored in the applets directory, located at the same level as the help file. This folder is not required for browsing help, but if it is missing, applets will not be displayed.

Java 2 applets require the Java Plugin, which is not supported by the HTMLHelp viewer. These applets will not be displayed.

2. Documents that require a plugin

Plugins are not fully supported by the HTMLHelp viewer. Depending on the configuration of your machine, some problems may occur when viewing these files, for example PDF documents.

3. Multiple occurrences of an index keyword

If an index keyword points to more than one document, a page that lists all found occurrences is displayed. This page shows the title of every document in which the keyword appears, and if this keyword is a method, the parameters of this method. This detailed display has been preferred to the standard HTMLHelp "Topics Found" dialog box, to provide a faster and more efficient browsing of a large number of documents.

Thanks to...

a.do Consulting, for HtmlStreamTokenizer™, a compact, efficient and free HTML parser written in Java.

Doug Kramer at Sun, who authorized the distribution of this document.

Distribution

This software is free. Permission to use, copy, and distribute this software for non-commercial purposes via the Internet without fee is hereby granted. Permission is not granted for any distribution in the form of CD-ROM [contact].

Sun's documentation redistribution policy is applicable to this document. Please see this page for details.

Copyright © 1997-2004, Franck Allimant


api

TM Platform, Enterprise Edition, v 5.0
API Specifications.">
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

JavaTM Platform, Enterprise Edition, v 5.0
API Specifications.

Java EE 5 Platform Packages
javax.activation | The JavaBeans(TM) Activation Framework is used by the JavaMail(TM) API to manage MIME data.
javax.annotation | This package defines the common annotations.
javax.annotation.security | This package contains the security common annotations.
javax.ejb | The javax.ejb package contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
javax.ejb.spi | The javax.ejb.spi package defines interfaces that are implemented by the EJB container.
javax.el | Provides the API for the Unified Expression Language shared by the JSP 2.1 and JSF 1.2 technologies.
javax.enterprise.deploy.model | Provides Tool Vendor implementation classes.
javax.enterprise.deploy.model.exceptions | Provides Tool Vendor exception implementation classes.
javax.enterprise.deploy.shared | Provides shared objects for Tool Vendor and Product Vendor implementation classes.
javax.enterprise.deploy.shared.factories | Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.
javax.enterprise.deploy.spi | Provides J2EE Product Vendor implementation classes.
javax.enterprise.deploy.spi.exceptions | Provides J2EE Product Vendor deployment exception implementation classes.
javax.enterprise.deploy.spi.factories | Provides J2EE Product Vendor deployment factory implementation classes.
javax.enterprise.deploy.spi.status | Provides J2EE Product Vendor deployment status implementation classes.
javax.faces | Top level classes for the JavaServer(tm) Faces API.
javax.faces.application | APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
javax.faces.component | Fundamental APIs for user interface components.
javax.faces.component.html | Specialized user interface component classes for HTML.
javax.faces.context | Classes and interfaces defining per-request state information.
javax.faces.convert | Contains classes and interfaces defining converters.
javax.faces.el | DEPRECATED Classes and interfaces for evaluating and processing reference expressions.
javax.faces.event | Interfaces describing events and event listeners, and concrete event implementation classes.
javax.faces.lifecycle | Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.
javax.faces.model | Standard model data beans for JavaServer Faces.
javax.faces.render | Classes and interfaces defining the rendering model.
javax.faces.validator | Interface defining the validator model, and concrete validator implementation classes.
javax.faces.webapp | Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
javax.interceptor | The javax.interceptor package contains classes and interfaces for use with EJB interceptors.
javax.jms | The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.
javax.jws |
javax.jws.soap |
javax.mail | Classes modeling a mail system.
javax.mail.event | Listeners and events for the JavaMail API.
javax.mail.internet | Classes specific to Internet mail systems.
javax.mail.search | Message search terms for the JavaMail API.
javax.mail.util | Utility classes.
javax.management.j2ee | Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.
javax.management.j2ee.statistics | Provides the standard interfaces for accessing performance data from J2EE managed objects Package Specification JSR 77, J2EE Management Related Documentation For overviews, tutorials, examples, guides, and tool documentation, please see: J2EE Tools


 All Classes
AbortProcessingException
AbstractMarshallerImpl
AbstractUnmarshallerImpl
AccessLocalException
ActionEvent
ActionListener
ActionSource
ActionSource2
ActionType
ActivationConfigProperty
ActivationDataFlavor
ActivationSpec
Address
AddressException
AddressStringTerm
AddressTerm
AndTerm
Application
ApplicationException
ApplicationFactory
ApplicationServerInternalException
AroundInvoke
ArrayDataModel
ArrayELResolver
Association
AssociationOverride
AssociationOverrides
AsyncHandler
AttachmentMarshaller
AttachmentPart
AttachmentUnmarshaller
Attribute
AttributeOverride
AttributeOverrides
AttributeTag
AuditableEvent
AuthenticationFailedException
Authenticator
Basic
BeanELResolver
BeanELResolver.BeanProperties
BeanELResolver.BeanProperty
BeanNotFoundException
BigDecimalConverter
BigDecimalHolder
BigIntegerConverter
BigIntegerHolder
Binder
Binding
BindingProvider
BindingType
BodyContent
BodyPart
BodyTag
BodyTagSupport
BodyTerm
BooleanConverter
BooleanHolder
BooleanWrapperHolder
BootstrapContext
BoundaryStatistic
BoundedRangeStatistic
BulkResponse
BusinessLifeCycleManager
BusinessQueryManager
ByteArrayDataSource
ByteArrayHolder
ByteConverter
ByteHolder
BytesMessage
ByteWrapperHolder
CalendarHolder
Call
CapabilityProfile
CascadeType
CharacterConverter
Characters
Classification
ClassificationScheme
ClassTransformer
ClientConfiguration
ClientExecuteException
CollapsedStringAdapter
Column
ColumnResult
CommandInfo
CommandMap
CommandObject
CommandType
Comment
CommException
ComparisonTerm
CompositeELResolver
Concept
ConcurrentAccessException
ConfigurationException
Connection
Connection
Connection
ConnectionAdapter
ConnectionConsumer
ConnectionEvent
ConnectionEvent
ConnectionEventListener
ConnectionFactory
ConnectionFactory
ConnectionFactory
ConnectionListener
ConnectionManager
ConnectionMetaData
ConnectionMetaData
ConnectionRequestInfo
ConnectionSpec
ContentDisposition
ContentType
ContextCallback
Converter
ConverterELTag
ConverterException
ConverterTag
Cookie
CountStatistic
CreateException
DataContentHandler
DataContentHandlerFactory
DataHandler
DataModel
DataModelEvent
DataModelListener
DataSource
DatatypeConverter
DatatypeConverterInterface
DateTerm
DateTimeConverter
DConfigBean
DConfigBeanRoot
DConfigBeanVersionType
DConfigBeanVersionUnsupportedException
DDBean
DDBeanCreateException
DDBeanRoot
DeclarativeQueryManager
DeclareRoles
DefaultValidationEventHandler
DeleteException
DeliveryMode
DenyAll
DeployableObject
DeploymentConfiguration
DeploymentFactory
DeploymentFactoryManager
DeploymentManager
DeploymentManagerCreationException
DeploymentStatus
DeserializationContext
Deserializer
DeserializerFactory
Destination
Detail
DetailEntry
DiscriminatorColumn
DiscriminatorType
DiscriminatorValue
Dispatch
DissociatableManagedConnection
DomHandler
DoubleConverter
DoubleHolder
DoubleRangeValidator
DoubleWrapperHolder
DTD
DuplicateKeyException
DynamicAttributes
EditableValueHolder
EISSystemException
EJB
EJBAccessException
EJBContext
EJBException
EJBHome
EJBLocalHome
EJBLocalObject
EJBMetaData
EJBMethodPermission
EJBObject
EJBRoleRefPermission
EJBs
EJBStats
EJBTransactionRequiredException
EJBTransactionRolledbackException
ELContext
ELContextEvent
ELContextListener
Element
ELException
ELException
ELParseException
ELResolver
EmailAddress
Embeddable
Embedded
EmbeddedId
EndDocument
EndElement
Endpoint
EnterpriseBean
Entity
EntityBean
EntityBeanStats
EntityContext
EntityDeclaration
EntityExistsException
EntityListeners
EntityManager
EntityManagerFactory
EntityNotFoundException
EntityReference
EntityResult
EntityTransaction
EnumConverter
Enumerated
EnumType
ErrorData
EvaluationException
EventFilter
EventReaderDelegate
ExceptionListener
ExcludeClassInterceptors
ExcludeDefaultInterceptors
ExcludeDefaultListeners
ExcludeSuperclassListeners
ExecutionContext
Expression
Expression
ExpressionEvaluator
ExpressionFactory
ExtensibleObject
ExternalContext
ExternalIdentifier
ExternalLink
ExtrinsicObject
FacesContext
FacesContextFactory
FacesEvent
FacesException
FacesListener
FacesMessage
FacesMessage.Severity
FacesServlet
FacetTag
FactoryConfigurationError
FactoryFinder
FederatedConnection
FetchProfile
FetchProfile.Item
FetchType
FieldResult
FileDataSource
FileTypeMap
Filter
FilterChain
FilterConfig
FinderException
FindException
FindQualifier
Flags
Flags.Flag
FlagTerm
FloatConverter
FloatHolder
FloatWrapperHolder
FlushModeType
Folder
FolderAdapter
FolderClosedException
FolderEvent
FolderListener
FolderNotFoundException
FromStringTerm
FromTerm
FunctionInfo
FunctionMapper
FunctionMapper
Generated
GeneratedValue
GenerationType
GenericCredential
GenericHandler
GenericServlet
Handle
HandleDelegate
Handler
Handler
HandlerChain
HandlerChain
HandlerInfo
HandlerRegistry
HandlerResolver
Header
HeaderTerm
HeaderTokenizer
HeaderTokenizer.Token
HeuristicCommitException
HeuristicMixedException
HeuristicRollbackException
HexBinaryAdapter
Holder
Holder
HomeHandle
HtmlColumn
HtmlCommandButton
HtmlCommandLink
HtmlDataTable
HtmlForm
HtmlGraphicImage
HtmlInputHidden
HtmlInputSecret
HtmlInputText
HtmlInputTextarea
HtmlMessage
HtmlMessages
HtmlOutputFormat
HtmlOutputLabel
HtmlOutputLink
HtmlOutputText
HtmlPanelGrid
HtmlPanelGroup
HtmlSelectBooleanCheckbox
HtmlSelectManyCheckbox
HtmlSelectManyListbox
HtmlSelectManyMenu
HtmlSelectOneListbox
HtmlSelectOneMenu
HtmlSelectOneRadio
HTTPBinding
HTTPException
HttpJspPage
HttpServlet
HttpServletRequest
HttpServletRequestWrapper
HttpServletResponse
HttpServletResponseWrapper
HttpSession
HttpSessionActivationListener
HttpSessionAttributeListener
HttpSessionBindingEvent
HttpSessionBindingListener
HttpSessionContext
HttpSessionEvent
HttpSessionListener
HttpUtils
Id
IdClass
IllegalStateException
IllegalStateException
IllegalWriteException
ImplicitObjectELResolver
IndexedRecord
Inheritance
InheritanceType
Init
InitParam
IntegerComparisonTerm
IntegerConverter
IntegerWrapperHolder
Interaction
InteractionSpec
Interceptors
InternationalString
InternetAddress
InternetHeaders
InternetHeaders.InternetHeader
IntHolder
InvalidClientIDException
InvalidDestinationException
InvalidModuleException
InvalidPropertyException
InvalidRequestException
InvalidSelectorException
InvalidTransactionException
InvocationContext
IterationTag
J2eeApplicationObject
JavaMailStats
JAXBContext
JAXBElement
JAXBElement.GlobalScope
JAXBException
JAXBIntrospector
JAXBResult
JAXBSource
JAXRException
JAXRPCException
JAXRResponse
JCAConnectionPoolStats
JCAConnectionStats
JCAStats
JDBCConnectionPoolStats
JDBCConnectionStats
JDBCStats
JMSConnectionStats
JMSConsumerStats
JMSEndpointStats
JMSException
JMSProducerStats
JMSSecurityException
JMSSessionStats
JMSStats
JoinColumn
JoinColumns
JoinTable
JspApplicationContext
JspContext
JspEngineInfo
JspException
JspFactory
JspFragment
JspIdConsumer
JspPage
JspTag
JspTagException
JspWriter
JTAStats
JVMStats
Key
LazyAssociatableConnectionManager
LazyEnlistableConnectionManager
LazyEnlistableManagedConnection
LengthValidator
Lifecycle
LifecycleFactory
LifeCycleManager
ListDataModel
ListELResolver
ListenerRegistration
Lob
Local
LocalHome
LocalizedString
LocalTransaction
LocalTransaction
LocalTransactionException
Location
LockModeType
LogicalHandler
LogicalMessage
LogicalMessageContext
LongConverter
LongHolder
LongRangeValidator
LongWrapperHolder
MailcapCommandMap
MailDateFormat
MailEvent
ManagedConnection
ManagedConnectionFactory
ManagedConnectionMetaData
Management
ManagementHome
ManyToMany
ManyToOne
MapELResolver
MapKey
MapMessage
MappedRecord
MappedSuperclass
MarshalException
Marshaller
Marshaller.Listener
Message
Message
Message.RecipientType
MessageAware
MessageChangedEvent
MessageChangedListener
MessageConsumer
MessageContext
MessageContext
MessageContext
MessageContext.Scope
MessageCountAdapter
MessageCountEvent
MessageCountListener
MessageDriven
MessageDrivenBean
MessageDrivenBeanStats
MessageDrivenContext
MessageEndpoint
MessageEndpointFactory
MessageEOFException
MessageFactory
MessageFormatException
MessageIDTerm
MessageListener
MessageListener
MessageNotReadableException
MessageNotWriteableException
MessageNumberTerm
MessageProducer
MessageRemovedException
MessagingException
MethodBinding
MethodExpression
MethodExpressionActionListener
MethodExpressionValidator
MethodExpressionValueChangeListener
MethodInfo
MethodNotFoundException
MethodNotFoundException
MethodNotSupportedException
MimeBodyPart
MimeHeader
MimeHeaders
MimeMessage
MimeMessage.RecipientType
MimeMultipart
MimePart
MimePartDataSource
MimeType
MimeTypeParameterList
MimeTypeParseException
MimetypesFileTypeMap
MimeUtility
ModuleType
Multipart
MultipartDataSource
Name
NamedNativeQueries
NamedNativeQuery
NamedQueries
NamedQuery
Namespace
NamespaceConstants
NamingContainer
NavigationHandler
NewsAddress
Node
NonUniqueResultException
NoResultException
NormalizedStringAdapter
NoSuchEJBException
NoSuchEntityException
NoSuchObjectLocalException
NoSuchProviderException
NotationDeclaration
NotIdentifiableEvent
NotIdentifiableEventImpl
NotSupportedException
NotSupportedException
NotTerm
NumberConverter
ObjectHolder
ObjectMessage
ObjectNotFoundException
OneToMany
OneToOne
Oneway
OperationUnsupportedException
OptimisticLockException
OrderBy
Organization
OrTerm
PageContext
PageData
ParameterList
ParameterMode
ParseConversionEvent
ParseConversionEventImpl
ParseException
Part
PasswordAuthentication
PasswordCredential
PermitAll
Persistence
PersistenceContext
PersistenceContexts
PersistenceContextType
PersistenceException
PersistenceProperty
PersistenceProvider
PersistenceUnit
PersistenceUnitInfo
PersistenceUnits
PersistenceUnitTransactionType
PersonName
PhaseEvent
PhaseId
PhaseListener
PolicyConfiguration
PolicyConfigurationFactory
PolicyContext
PolicyContextException
PolicyContextHandler
PortInfo
PostActivate
PostalAddress
PostConstruct
PostLoad
PostPersist
PostRemove
PostUpdate
PreDestroy
PreencodedMimeBodyPart
PrePassivate
PrePersist
PreRemove
PreUpdate
PrimaryKeyJoinColumn
PrimaryKeyJoinColumns
PrintConversionEvent
PrintConversionEventImpl
ProcessingInstruction
ProgressEvent
ProgressListener
ProgressObject
PropertyException
PropertyNotFoundException
PropertyNotFoundException
PropertyNotWritableException
PropertyResolver
ProtocolException
Provider
Provider
Provider
Provider.Type
QNameHolder
Query
Query
QueryHint
QueryManager
Queue
QueueBrowser
QueueConnection
QueueConnectionFactory
QueueReceiver
QueueRequestor
QueueSender
QueueSession
Quota
Quota.Resource
QuotaAwareStore
RangeStatistic
ReadOnlyFolderException
ReceivedDateTerm
RecipientStringTerm
RecipientTerm
Record
RecordFactory
Referenceable
ReferenceSyntaxException
RegistryEntry
RegistryException
RegistryObject
RegistryPackage
RegistryService
Remote
RemoteHome
Remove
RemoveException
Renderer
RenderKit
RenderKitFactory
RequestDispatcher
RequestWrapper
Resource
Resource.AuthenticationType
ResourceAdapter
ResourceAdapterAssociation
ResourceAdapterInternalException
ResourceAdapterMetaData
ResourceAllocationException
ResourceAllocationException
ResourceBundleELResolver
ResourceException
Resources
ResourceWarning
Response
ResponseStateManager
ResponseStream
ResponseWrapper
ResponseWriter
ResponseWriterWrapper
ResultDataModel
ResultSet
ResultSetDataModel
ResultSetInfo
RolesAllowed
RollbackException
RollbackException
RunAs
SAAJMetaFactory
SAAJResult
SaveException
ScalarDataModel
SchemaOutputResolver
ScopedAttributeELResolver
SearchException
SearchTerm
SecondaryTable
SecondaryTables
SecurityException
SelectItem
SelectItemGroup
SendFailedException
SentDateTerm
SequenceGenerator
SerializationContext
Serializer
SerializerFactory
ServerSession
ServerSessionPool
Service
Service
Service
Service
Service.Mode
ServiceBinding
ServiceDelegate
ServiceException
ServiceFactory
ServiceLifecycle
ServiceMode
Servlet
ServletConfig
ServletContext
ServletContextAttributeEvent
ServletContextAttributeListener
ServletContextEvent
ServletContextListener
ServletEndpointContext
ServletException
ServletInputStream
ServletOutputStream
ServletRequest
ServletRequestAttributeEvent
ServletRequestAttributeListener
ServletRequestEvent
ServletRequestListener
ServletRequestWrapper
ServletResponse
ServletResponseWrapper
ServletStats
Session
Session
SessionBean
SessionBeanStats
SessionContext
SessionSynchronization
SharedByteArrayInputStream
SharedFileInputStream
SharedInputStream
SharingViolationException
ShortConverter
ShortHolder
ShortWrapperHolder
SimpleTag
SimpleTagSupport
SingleThreadModel
SizeTerm
SkipPageException
Slot
SOAPBinding
SOAPBinding
SOAPBinding.ParameterStyle
SOAPBinding.Style
SOAPBinding.Use
SOAPBody
SOAPBodyElement
SOAPConnection
SOAPConnectionFactory
SOAPConstants
SOAPElement
SOAPElementFactory
SOAPEnvelope
SOAPException
SOAPFactory
SOAPFault
SOAPFaultElement
SOAPFaultException
SOAPFaultException
SOAPHandler
SOAPHeader
SOAPHeaderElement
SOAPMessage
SOAPMessageContext
SOAPMessageContext
SOAPMessageHandler
SOAPMessageHandlers
SOAPPart
SpecificationLink
SqlResultSetMapping
SqlResultSetMappings
StartDocument
StartElement
Stateful
StatefulSessionBeanStats
StateHolder
Stateless
StatelessSessionBeanStats
StateManager
StateManagerWrapper
StateType
Statistic
Stats
Status
Store
StoreClosedException
StoreEvent
StoreListener
Streamable
StreamFilter
StreamMessage
StreamReaderDelegate
StringHolder
StringTerm
Stub
SubjectTerm
Synchronization
SystemException
Table
TableGenerator
Tag
TagAdapter
TagAttributeInfo
TagData
TagExtraInfo
TagFileInfo
TagInfo
TagLibraryInfo
TagLibraryValidator
TagSupport
TagVariableInfo
Target
TargetException
TargetModuleID
TelephoneNumber
Temporal
TemporalType
TemporaryQueue
TemporaryTopic
Text
TextMessage
TimedObject
Timeout
Timer
TimerHandle
TimerService
TimeStatistic
Topic
TopicConnection
TopicConnectionFactory
TopicPublisher
TopicRequestor
TopicSession
TopicSubscriber
Transaction
TransactionAttribute
TransactionAttributeType
TransactionInProgressException
TransactionManagement
TransactionManagementType
TransactionManager
TransactionRequiredException
TransactionRequiredException
TransactionRequiredLocalException
TransactionRolledBackException
TransactionRolledbackException
TransactionRolledbackLocalException
TransactionSynchronizationRegistry
Transient
Transport
TransportAdapter
TransportEvent
TransportListener
TryCatchFinally
TypeConstraintException
TypeMapping
TypeMappingRegistry
UIColumn
UICommand
UIComponent
UIComponentBase
UIComponentBodyTag
UIComponentClassicTagBase
UIComponentELTag
UIComponentTag
UIComponentTagBase
UIData
UIDFolder
UIDFolder.FetchProfileItem
UIForm
UIGraphic
UIInput
UIMessage
UIMessages
UINamingContainer
UIOutput
UIPanel
UIParameter
UISelectBoolean
UISelectItem
UISelectItems
UISelectMany
UISelectOne
UIViewRoot
UnavailableException
UnavailableException
UnexpectedObjectException
UniqueConstraint
UnmarshalException
Unmarshaller
Unmarshaller.Listener
UnmarshallerHandler
UnsupportedCapabilityException
UnsupportedDataTypeException
URIValidator
URLDataSource
URLName
URLStats
User
UserTransaction
ValidatingManagedConnectionFactory
ValidationEvent
ValidationEventCollector
ValidationEventHandler
ValidationEventImpl
ValidationEventLocator
ValidationEventLocatorImpl
ValidationException
ValidationMessage
Validator
Validator
ValidatorELTag
ValidatorException
ValidatorTag
ValueBinding
ValueChangeEvent
ValueChangeListener
ValueExpression
ValueHolder
VariableInfo
VariableMapper
VariableResolver
VariableResolver
Version
Versionable
ViewExpiredException
ViewHandler
ViewHandlerWrapper
W3CDomHandler
WebEndpoint
WebFault
WebMethod
WebParam
WebParam.Mode
WebResourcePermission
WebResult
WebRoleRefPermission
WebService
WebServiceClient
WebServiceContext
WebServiceException
WebServicePermission
WebServiceProvider
WebServiceRef
WebServiceRefs
WebUserDataPermission
Work
WorkAdapter
WorkCompletedException
WorkEvent
WorkException
WorkListener
WorkManager
WorkRejectedException
XAConnection
XAConnectionFactory
XAException
XAQueueConnection
XAQueueConnectionFactory
XAQueueSession
XAResource
XASession
XATerminator
XATopicConnection
XATopicConnectionFactory
XATopicSession
Xid
XmlAccessOrder
XmlAccessorOrder
XmlAccessorType
XmlAccessType
XmlAdapter
XmlAnyAttribute
XmlAnyElement
XmlAttachmentRef
XmlAttribute
XmlElement
XmlElement.DEFAULT
XmlElementDecl
XmlElementDecl.GLOBAL
XmlElementRef
XmlElementRef.DEFAULT
XmlElementRefs
XmlElements
XmlElementWrapper
XmlEnum
XmlEnumValue
XMLEvent
XMLEventAllocator
XMLEventConsumer
XMLEventFactory
XMLEventReader
XMLEventWriter
XmlID
XmlIDREF
XmlInlineBinaryData
XMLInputFactory
XmlJavaTypeAdapter
XmlJavaTypeAdapter.DEFAULT
XmlJavaTypeAdapters
XmlList
XmlMimeType
XmlMixed
XmlNs
XmlNsForm
XMLOutputFactory
XmlRegistry
XMLReporter
XMLResolver
XmlRootElement
XmlSchema
XmlSchemaType
XmlSchemaType.DEFAULT
XmlSchemaTypes
XMLStreamConstants
XMLStreamException
XMLStreamReader
XMLStreamWriter
XmlTransient
XmlType
XMLType
XmlType.DEFAULT
XmlValue
XpathEvent
XpathListener


API Help

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Enums
  • Exceptions
  • Errors
  • Annotation Types

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Annotation Type

Each annotation type has its own separate page with the following sections:

  • Annotation Type declaration
  • Annotation Type description
  • Required Element Summary
  • Optional Element Summary
  • Element Detail

Enum

Each enum has its own separate page with the following sections:

  • Enum declaration
  • Enum description
  • Enum Constant Summary
  • Enum Constant Detail

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

Constant Field Values

The Constant Field Values page lists the static final fields and their values.

This help file applies to API documentation generated using the standard doclet.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Constant Field Values

Contents
  • javax.el.*
  • javax.faces.*
  • javax.jms.*
  • javax.mail.*
  • javax.resource.*
  • javax.servlet.*
  • javax.transaction.*
  • javax.xml.*
javax.el.*

javax.el.ELResolver
public static final String | RESOLVABLE_AT_DESIGN_TIME | "resolvableAtDesignTime"
public static final String | TYPE | "type"

javax.faces.*

javax.faces.FactoryFinder
public static final String | APPLICATION_FACTORY | "javax.faces.application.ApplicationFactory"
public static final String | FACES_CONTEXT_FACTORY | "javax.faces.context.FacesContextFactory"
public static final String | LIFECYCLE_FACTORY | "javax.faces.lifecycle.LifecycleFactory"
public static final String | RENDER_KIT_FACTORY | "javax.faces.render.RenderKitFactory"

javax.faces.application.FacesMessage
public static final String FACES_MESSAGES "javax.faces.Messages"

javax.faces.application.StateManager
public static final String | STATE_SAVING_METHOD_CLIENT | "client"
public static final String | STATE_SAVING_METHOD_PARAM_NAME | "javax.faces.STATE_SAVING_METHOD"
public static final String | STATE_SAVING_METHOD_SERVER | "server"

javax.faces.application.ViewHandler
public static final String | CHARACTER_ENCODING_KEY | "javax.faces.request.charset"
public static final String | DEFAULT_SUFFIX | ".jsp"
public static final String | DEFAULT_SUFFIX_PARAM_NAME | "javax.faces.DEFAULT_SUFFIX"

javax.faces.component.NamingContainer
public static final char SEPARATOR_CHAR 58

javax.faces.component.UIColumn
public static final String | COMPONENT_FAMILY | "javax.faces.Column"
public static final String | COMPONENT_TYPE | "javax.faces.Column"

javax.faces.component.UICommand
public static final String | COMPONENT_FAMILY | "javax.faces.Command"
public static final String | COMPONENT_TYPE | "javax.faces.Command"

javax.faces.component.UIData
public static final String | COMPONENT_FAMILY | "javax.faces.Data"
public static final String | COMPONENT_TYPE | "javax.faces.Data"

javax.faces.component.UIForm
public static final String | COMPONENT_FAMILY | "javax.faces.Form"
public static final String | COMPONENT_TYPE | "javax.faces.Form"

javax.faces.component.UIGraphic
public static final String | COMPONENT_FAMILY | "javax.faces.Graphic"
public static final String | COMPONENT_TYPE | "javax.faces.Graphic"

javax.faces.component.UIInput
public static final String | COMPONENT_FAMILY | "javax.faces.Input"
public static final String | COMPONENT_TYPE | "javax.faces.Input"
public static final String | CONVERSION_MESSAGE_ID | "javax.faces.component.UIInput.CONVERSION"
public static final String | REQUIRED_MESSAGE_ID | "javax.faces.component.UIInput.REQUIRED"
public static final String | UPDATE_MESSAGE_ID | "javax.faces.component.UIInput.UPDATE"

javax.faces.component.UIMessage
public static final String | COMPONENT_FAMILY | "javax.faces.Message"
public static final String | COMPONENT_TYPE | "javax.faces.Message"

javax.faces.component.UIMessages
public static final String | COMPONENT_FAMILY | "javax.faces.Messages"
public static final String | COMPONENT_TYPE | "javax.faces.Messages"

javax.faces.component.UINamingContainer
public static final String | COMPONENT_FAMILY | "javax.faces.NamingContainer"
public static final String | COMPONENT_TYPE | "javax.faces.NamingContainer"

javax.faces.component.UIOutput
public static final String | COMPONENT_FAMILY | "javax.faces.Output"
public static final String | COMPONENT_TYPE | "javax.faces.Output"

javax.faces.component.UIPanel
public static final String | COMPONENT_FAMILY | "javax.faces.Panel"
public static final String | COMPONENT_TYPE | "javax.faces.Panel"

javax.faces.component.UIParameter
public static final String | COMPONENT_FAMILY | "javax.faces.Parameter"
public static final String | COMPONENT_TYPE | "javax.faces.Parameter"

javax.faces.component.UISelectBoolean
public static final String | COMPONENT_FAMILY | "javax.faces.SelectBoolean"
public static final String | COMPONENT_TYPE | "javax.faces.SelectBoolean"

javax.faces.component.UISelectItem
public static final String | COMPONENT_FAMILY | "javax.faces.SelectItem"
public static final String | COMPONENT_TYPE | "javax.faces.SelectItem"

javax.faces.component.UISelectItems
public static final String | COMPONENT_FAMILY | "javax.faces.SelectItems"
public static final String | COMPONENT_TYPE | "javax.faces.SelectItems"

javax.faces.component.UISelectMany
public static final String | COMPONENT_FAMILY | "javax.faces.SelectMany"
public static final String | COMPONENT_TYPE | "javax.faces.SelectMany"
public static final String | INVALID_MESSAGE_ID | "javax.faces.component.UISelectMany.INVALID"

javax.faces.component.UISelectOne
public static final String | COMPONENT_FAMILY | "javax.faces.SelectOne"
public static final String | COMPONENT_TYPE | "javax.faces.SelectOne"
public static final String | INVALID_MESSAGE_ID | "javax.faces.component.UISelectOne.INVALID"

javax.faces.component.UIViewRoot
public static final String | COMPONENT_FAMILY | "javax.faces.ViewRoot"
public static final String | COMPONENT_TYPE | "javax.faces.ViewRoot"
public static final String | UNIQUE_ID_PREFIX | "j_id"

javax.faces.component.html.HtmlColumn
public static final String COMPONENT_TYPE "javax.faces.HtmlColumn"

javax.faces.component.html.HtmlCommandButton
public static final String COMPONENT_TYPE "javax.faces.HtmlCommandButton"

javax.faces.component.html.HtmlCommandLink
public static final String COMPONENT_TYPE "javax.faces.HtmlCommandLink"

javax.faces.component.html.HtmlDataTable
public static final String COMPONENT_TYPE "javax.faces.HtmlDataTable"

javax.faces.component.html.HtmlForm
public static final String COMPONENT_TYPE "javax.faces.HtmlForm"

javax.faces.component.html.HtmlGraphicImage
public static final String COMPONENT_TYPE "javax.faces.HtmlGraphicImage"

javax.faces.component.html.HtmlInputHidden
public static final String COMPONENT_TYPE "javax.faces.HtmlInputHidden"

javax.faces.component.html.HtmlInputSecret
public static final String COMPONENT_TYPE "javax.faces.HtmlInputSecret"

javax.faces.component.html.HtmlInputText
public static final String COMPONENT_TYPE "javax.faces.HtmlInputText"

javax.faces.component.html.HtmlInputTextarea
public static final String COMPONENT_TYPE "javax.faces.HtmlInputTextarea"

javax.faces.component.html.HtmlMessage
public static final String COMPONENT_TYPE "javax.faces.HtmlMessage"

javax.faces.component.html.HtmlMessages
public static final String COMPONENT_TYPE "javax.faces.HtmlMessages"

javax.faces.component.html.HtmlOutputFormat
public static final String COMPONENT_TYPE "javax.faces.HtmlOutputFormat"

javax.faces.component.html.HtmlOutputLabel
public static final String COMPONENT_TYPE "javax.faces.HtmlOutputLabel"

javax.faces.component.html.HtmlOutputLink
public static final String COMPONENT_TYPE "javax.faces.HtmlOutputLink"

javax.faces.component.html.HtmlOutputText
public static final String COMPONENT_TYPE "javax.faces.HtmlOutputText"

javax.faces.component.html.HtmlPanelGrid
public static final String COMPONENT_TYPE "javax.faces.HtmlPanelGrid"

javax.faces.component.html.HtmlPanelGroup
public static final String COMPONENT_TYPE "javax.faces.HtmlPanelGroup"

javax.faces.component.html.HtmlSelectBooleanCheckbox
public static final String COMPONENT_TYPE "javax.faces.HtmlSelectBooleanCheckbox"

javax.faces.component.html.HtmlSelectManyCheckbox
public static final String COMPONENT_TYPE "javax.faces.HtmlSelectManyCheckbox"

javax.faces.component.html.HtmlSelectManyListbox
public static final String COMPONENT_TYPE "javax.faces.HtmlSelectManyListbox"

javax.faces.component.html.HtmlSelectManyMenu
public static final String COMPONENT_TYPE "javax.faces.HtmlSelectManyMenu"

javax.faces.component.html.HtmlSelectOneListbox
public static final String COMPONENT_TYPE "javax.faces.HtmlSelectOneListbox"

javax.faces.component.html.HtmlSelectOneMenu
public static final String COMPONENT_TYPE "javax.faces.HtmlSelectOneMenu"

javax.faces.component.html.HtmlSelectOneRadio
public static final String COMPONENT_TYPE "javax.faces.HtmlSelectOneRadio"

javax.faces.context.ExternalContext
public static final String | BASIC_AUTH | "BASIC"
public static final String | CLIENT_CERT_AUTH | "CLIENT_CERT"
public static final String | DIGEST_AUTH | "DIGEST"
public static final String | FORM_AUTH | "FORM"

javax.faces.convert.BigDecimalConverter
public static final String | CONVERTER_ID | "javax.faces.BigDecimal"
public static final String | DECIMAL_ID | "javax.faces.converter.BigDecimalConverter.DECIMAL"
public static final String | STRING_ID | "javax.faces.converter.STRING"

javax.faces.convert.BigIntegerConverter
public static final String | BIGINTEGER_ID | "javax.faces.converter.BigIntegerConverter.BIGINTEGER"
public static final String | CONVERTER_ID | "javax.faces.BigInteger"
public static final String | STRING_ID | "javax.faces.converter.STRING"

javax.faces.convert.BooleanConverter
public static final String | BOOLEAN_ID | "javax.faces.converter.BooleanConverter.BOOLEAN"
public static final String | CONVERTER_ID | "javax.faces.Boolean"
public static final String | STRING_ID | "javax.faces.converter.STRING"

javax.faces.convert.ByteConverter
public static final String | BYTE_ID | "javax.faces.converter.ByteConverter.BYTE"
public static final String | CONVERTER_ID | "javax.faces.Byte"
public static final String | STRING_ID | "javax.faces.converter.STRING"

javax.faces.convert.CharacterConverter
public static final String | CHARACTER_ID | "javax.faces.converter.CharacterConverter.CHARACTER"
public static final String | CONVERTER_ID | "javax.faces.Character"
public static final String | STRING_ID | "javax.faces.converter.STRING"

javax.faces.convert.DateTimeConverter
public static final String | CONVERTER_ID | "javax.faces.DateTime"
public static final String | DATE_ID | "javax.faces.converter.DateTimeConverter.DATE"
public static final String | DATETIME_ID | "javax.faces.converter.DateTimeConverter.DATETIME"
public static final String | STRING_ID | "javax.faces.converter.STRING"
public static final String | TIME_ID | "javax.faces.converter.DateTimeConverter.TIME"

javax.faces.convert.DoubleConverter
public static final String | CONVERTER_ID | "javax.faces.DoubleTime"
public static final String | DOUBLE_ID | "javax.faces.converter.DoubleConverter.DOUBLE"
public static final String | STRING_ID | "javax.faces.converter.STRING"

javax.faces.convert.EnumConverter
public static final String | CONVERTER_ID | "javax.faces.Enum"
public static final String | ENUM_ID | "javax.faces.converter.EnumConverter.ENUM"
public static final String | ENUM_NO_CLASS_ID | "javax.faces.converter.EnumConverter.ENUM_NO_CLASS"

javax.faces.convert.FloatConverter
public static final String | CONVERTER_ID | "javax.faces.Float"
public static final String | FLOAT_ID | "javax.faces.converter.FloatConverter.FLOAT"
public static final String | STRING_ID | "javax.faces.converter.STRING"

javax.faces.convert.IntegerConverter
public static final String | CONVERTER_ID | "javax.faces.Integer"
public static final String | INTEGER_ID | "javax.faces.converter.IntegerConverter.INTEGER"
public static final String | STRING_ID | "javax.faces.converter.STRING"

javax.faces.convert.LongConverter
public static final String | CONVERTER_ID | "javax.faces.Long"
public static final String | LONG_ID | "javax.faces.converter.LongConverter.LONG"
public static final String | STRING_ID | "javax.faces.converter.STRING"

javax.faces.convert.NumberConverter
public static final String | CONVERTER_ID | "javax.faces.Number"
public static final String | CURRENCY_ID | "javax.faces.converter.NumberConverter.CURRENCY"
public static final String | NUMBER_ID | "javax.faces.converter.NumberConverter.NUMBER"
public static final String | PATTERN_ID | "javax.faces.converter.NumberConverter.PATTERN"
public static final String | PERCENT_ID | "javax.faces.converter.NumberConverter.PERCENT"
public static final String | STRING_ID | "javax.faces.converter.STRING"

javax.faces.convert.ShortConverter
public static final String | CONVERTER_ID | "javax.faces.Short"
public static final String | SHORT_ID | "javax.faces.converter.ShortConverter.SHORT"
public static final String | STRING_ID | "javax.faces.converter.STRING"

javax.faces.lifecycle.LifecycleFactory
public static final String DEFAULT_LIFECYCLE "DEFAULT"

javax.faces.render.RenderKitFactory
public static final String HTML_BASIC_RENDER_KIT "HTML_BASIC"

javax.faces.render.ResponseStateManager
public static final String | RENDER_KIT_ID_PARAM | "javax.faces.RenderKitId"
public static final String | VIEW_STATE_PARAM | "javax.faces.ViewState"

javax.faces.validator.DoubleRangeValidator
public static final String | MAXIMUM_MESSAGE_ID | "javax.faces.validator.DoubleRangeValidator.MAXIMUM"
public static final String | MINIMUM_MESSAGE_ID | "javax.faces.validator.DoubleRangeValidator.MINIMUM"
public static final String | NOT_IN_RANGE_MESSAGE_ID | "javax.faces.validator.DoubleRangeValidator.NOT_IN_RANGE"
public static final String | TYPE_MESSAGE_ID | "javax.faces.validator.DoubleRangeValidator.TYPE"
public static final String | VALIDATOR_ID | "javax.faces.DoubleRange"

javax.faces.validator.LengthValidator
public static final String | MAXIMUM_MESSAGE_ID | "javax.faces.validator.LengthValidator.MAXIMUM"
public static final String | MINIMUM_MESSAGE_ID | "javax.faces.validator.LengthValidator.MINIMUM"
public static final String | VALIDATOR_ID | "javax.faces.Length"

javax.faces.validator.LongRangeValidator
public static final String | MAXIMUM_MESSAGE_ID | "javax.faces.validator.LongRangeValidator.MAXIMUM"
public static final String | MINIMUM_MESSAGE_ID | "javax.faces.validator.LongRangeValidator.MINIMUM"
public static final String | NOT_IN_RANGE_MESSAGE_ID | "javax.faces.validator.LongRangeValidator.NOT_IN_RANGE"
public static final String | TYPE_MESSAGE_ID | "javax.faces.validator.LongRangeValidator.TYPE"
public static final String | VALIDATOR_ID | "javax.faces.LongRange"

javax.faces.validator.Validator
public static final String NOT_IN_RANGE_MESSAGE_ID "javax.faces.validator.NOT_IN_RANGE"

javax.faces.webapp.FacesServlet
public static final String | CONFIG_FILES_ATTR | "javax.faces.CONFIG_FILES"
public static final String | LIFECYCLE_ID_ATTR | "javax.faces.LIFECYCLE_ID"

javax.faces.webapp.UIComponentClassicTagBase
protected static final String UNIQUE_ID_PREFIX "j_id_"

javax.jms.*

javax.jms.DeliveryMode
public static final int | NON_PERSISTENT | 1
public static final int | PERSISTENT | 2

javax.jms.Message
public static final int | DEFAULT_DELIVERY_MODE | 2
public static final int | DEFAULT_PRIORITY | 4
public static final long | DEFAULT_TIME_TO_LIVE | 0L

javax.jms.Session
public static final int | AUTO_ACKNOWLEDGE | 1
public static final int | CLIENT_ACKNOWLEDGE | 2
public static final int | DUPS_OK_ACKNOWLEDGE | 3
public static final int | SESSION_TRANSACTED | 0

javax.mail.*

javax.mail.Folder
public static final int | HOLDS_FOLDERS | 2
public static final int | HOLDS_MESSAGES | 1
public static final int | READ_ONLY | 1
public static final int | READ_WRITE | 2

javax.mail.Part
public static final String | ATTACHMENT | "attachment"
public static final String | INLINE | "inline"

javax.mail.UIDFolder
public static final long LASTUID -1L

javax.mail.event.ConnectionEvent
public static final int | CLOSED | 3
public static final int | DISCONNECTED | 2
public static final int | OPENED | 1

javax.mail.event.FolderEvent
public static final int | CREATED | 1
public static final int | DELETED | 2
public static final int | RENAMED | 3

javax.mail.event.MessageChangedEvent
public static final int | ENVELOPE_CHANGED | 2
public static final int | FLAGS_CHANGED | 1

javax.mail.event.MessageCountEvent
public static final int | ADDED | 1
public static final int | REMOVED | 2

javax.mail.event.StoreEvent
public static final int | ALERT | 1
public static final int | NOTICE | 2

javax.mail.event.TransportEvent
public static final int | MESSAGE_DELIVERED | 1
public static final int | MESSAGE_NOT_DELIVERED | 2
public static final int | MESSAGE_PARTIALLY_DELIVERED | 3

javax.mail.internet.HeaderTokenizer
public static final String | MIME | "()<>@,;:\\\"\t []/?="
public static final String | RFC822 | "()<>@,;:\\\"\t .[]"

javax.mail.internet.HeaderTokenizer.Token
public static final int | ATOM | -1
public static final int | COMMENT | -3
public static final int | EOF | -4
public static final int | QUOTEDSTRING | -2

javax.mail.internet.MimeUtility
public static final int ALL -1

javax.mail.search.ComparisonTerm
public static final int | EQ | 3
public static final int | GE | 6
public static final int | GT | 5
public static final int | LE | 1
public static final int | LT | 2
public static final int | NE | 4

javax.resource.*

javax.resource.cci.InteractionSpec
public static final int | SYNC_RECEIVE | 2
public static final int | SYNC_SEND | 0
public static final int | SYNC_SEND_RECEIVE | 1

javax.resource.spi.ConnectionEvent
public static final int | CONNECTION_CLOSED | 1
public static final int | CONNECTION_ERROR_OCCURRED | 5
public static final int | LOCAL_TRANSACTION_COMMITTED | 3
public static final int | LOCAL_TRANSACTION_ROLLEDBACK | 4
public static final int | LOCAL_TRANSACTION_STARTED | 2

javax.resource.spi.work.WorkEvent
public static final int | WORK_ACCEPTED | 1
public static final int | WORK_COMPLETED | 4
public static final int | WORK_REJECTED | 2
public static final int | WORK_STARTED | 3

javax.resource.spi.work.WorkException
public static final String | INTERNAL | "-1"
public static final String | START_TIMED_OUT | "1"
public static final String | TX_CONCURRENT_WORK_DISALLOWED | "2"
public static final String | TX_RECREATE_FAILED | "3"
public static final String | UNDEFINED | "0"

javax.resource.spi.work.WorkManager
public static final long | IMMEDIATE | 0L
public static final long | INDEFINITE | 9223372036854775807L
public static final long | UNKNOWN | -1L

javax.servlet.*

javax.servlet.http.HttpServletRequest
public static final String | BASIC_AUTH | "BASIC"
public static final String | CLIENT_CERT_AUTH | "CLIENT_CERT"
public static final String | DIGEST_AUTH | "DIGEST"
public static final String | FORM_AUTH | "FORM"

javax.servlet.http.HttpServletResponse
public static final int | SC_ACCEPTED | 202
public static final int | SC_BAD_GATEWAY | 502
public static final int | SC_BAD_REQUEST | 400
public static final int | SC_CONFLICT | 409
public static final int | SC_CONTINUE | 100
public static final int | SC_CREATED | 201
public static final int | SC_EXPECTATION_FAILED | 417
public static final int | SC_FORBIDDEN | 403
public static final int | SC_FOUND | 302
public static final int | SC_GATEWAY_TIMEOUT | 504
public static final int | SC_GONE | 410
public static final int | SC_HTTP_VERSION_NOT_SUPPORTED | 505
public static final int | SC_INTERNAL_SERVER_ERROR | 500
public static final int | SC_LENGTH_REQUIRED | 411
public static final int | SC_METHOD_NOT_ALLOWED | 405
public static final int | SC_MOVED_PERMANENTLY | 301
public static final int | SC_MOVED_TEMPORARILY | 302
public static final int | SC_MULTIPLE_CHOICES | 300
public static final int | SC_NO_CONTENT | 204
public static final int | SC_NON_AUTHORITATIVE_INFORMATION | 203
public static final int | SC_NOT_ACCEPTABLE | 406
public static final int | SC_NOT_FOUND | 404
public static final int | SC_NOT_IMPLEMENTED | 501
public static final int | SC_NOT_MODIFIED | 304
public static final int | SC_OK | 200
public static final int | SC_PARTIAL_CONTENT | 206
public static final int | SC_PAYMENT_REQUIRED | 402
public static final int | SC_PRECONDITION_FAILED | 412
public static final int | SC_PROXY_AUTHENTICATION_REQUIRED | 407
public static final int | SC_REQUEST_ENTITY_TOO_LARGE | 413
public static final int | SC_REQUEST_TIMEOUT | 408
public static final int | SC_REQUEST_URI_TOO_LONG | 414
public static final int | SC_REQUESTED_RANGE_NOT_SATISFIABLE | 416
public static final int | SC_RESET_CONTENT | 205
public static final int | SC_SEE_OTHER | 303
public static final int | SC_SERVICE_UNAVAILABLE | 503
public static final int | SC_SWITCHING_PROTOCOLS | 101
public static final int | SC_TEMPORARY_REDIRECT | 307
public static final int | SC_UNAUTHORIZED | 401
public static final int | SC_UNSUPPORTED_MEDIA_TYPE | 415
public static final int | SC_USE_PROXY | 305

javax.servlet.jsp.JspWriter
public static final int | DEFAULT_BUFFER | -1
public static final int | NO_BUFFER | 0
public static final int | UNBOUNDED_BUFFER | -2

javax.servlet.jsp.PageContext
public static final String | APPLICATION | "javax.servlet.jsp.jspApplication"
public static final int | APPLICATION_SCOPE | 4
public static final String | CONFIG | "javax.servlet.jsp.jspConfig"
public static final String | EXCEPTION | "javax.servlet.jsp.jspException"
public static final String | OUT | "javax.servlet.jsp.jspOut"
public static final String | PAGE | "javax.servlet.jsp.jspPage"
public static final int | PAGE_SCOPE | 1
public static final String | PAGECONTEXT | "javax.servlet.jsp.jspPageContext"
public static final String | REQUEST | "javax.servlet.jsp.jspRequest"
public static final int | REQUEST_SCOPE | 2
public static final String | RESPONSE | "javax.servlet.jsp.jspResponse"
public static final String | SESSION | "javax.servlet.jsp.jspSession"
public static final int | SESSION_SCOPE | 3

javax.servlet.jsp.tagext.BodyTag
public static final int | EVAL_BODY_BUFFERED | 2
public static final int | EVAL_BODY_TAG | 2

javax.servlet.jsp.tagext.IterationTag
public static final int EVAL_BODY_AGAIN 2

javax.servlet.jsp.tagext.Tag
public static final int | EVAL_BODY_INCLUDE | 1
public static final int | EVAL_PAGE | 6
public static final int | SKIP_BODY | 0
public static final int | SKIP_PAGE | 5

javax.servlet.jsp.tagext.TagAttributeInfo
public static final String ID "id"

javax.servlet.jsp.tagext.TagInfo
public static final String | BODY_CONTENT_EMPTY | "empty"
public static final String | BODY_CONTENT_JSP | "JSP"
public static final String | BODY_CONTENT_SCRIPTLESS | "scriptless"
public static final String | BODY_CONTENT_TAG_DEPENDENT | "tagdependent"

javax.servlet.jsp.tagext.VariableInfo
public static final int | AT_BEGIN | 1
public static final int | AT_END | 2
public static final int | NESTED | 0

javax.transaction.*

javax.transaction.Status
public static final int | STATUS_ACTIVE | 0
public static final int | STATUS_COMMITTED | 3
public static final int | STATUS_COMMITTING | 8
public static final int | STATUS_MARKED_ROLLBACK | 1
public static final int | STATUS_NO_TRANSACTION | 6
public static final int | STATUS_PREPARED | 2
public static final int | STATUS_PREPARING | 7
public static final int | STATUS_ROLLEDBACK | 4
public static final int | STATUS_ROLLING_BACK | 9
public static final int | STATUS_UNKNOWN | 5

javax.transaction.xa.XAException
public static final int | XA_HEURCOM | 7
public static final int | XA_HEURHAZ | 8
public static final int | XA_HEURMIX | 5
public static final int | XA_HEURRB | 6
public static final int | XA_NOMIGRATE | 9
public static final int | XA_RBBASE | 100
public static final int | XA_RBCOMMFAIL | 101
public static final int | XA_RBDEADLOCK | 102
public static final int | XA_RBEND | 107
public static final int | XA_RBINTEGRITY | 103
public static final int | XA_RBOTHER | 104
public static final int | XA_RBPROTO | 105
public static final int | XA_RBROLLBACK | 100
public static final int | XA_RBTIMEOUT | 106
public static final int | XA_RBTRANSIENT | 107
public static final int | XA_RDONLY | 3
public static final int | XA_RETRY | 4
public static final int | XAER_ASYNC | -2
public static final int | XAER_DUPID | -8
public static final int | XAER_INVAL | -5
public static final int | XAER_NOTA | -4
public static final int | XAER_OUTSIDE | -9
public static final int | XAER_PROTO | -6
public static final int | XAER_RMERR | -3
public static final int | XAER_RMFAIL | -7

javax.transaction.xa.XAResource
public static final int | TMENDRSCAN | 8388608
public static final int | TMFAIL | 536870912
public static final int | TMJOIN | 2097152
public static final int | TMNOFLAGS | 0
public static final int | TMONEPHASE | 1073741824
public static final int | TMRESUME | 134217728
public static final int | TMSTARTRSCAN | 16777216
public static final int | TMSUCCESS | 67108864
public static final int | TMSUSPEND | 33554432
public static final int | XA_OK | 0
public static final int | XA_RDONLY | 3

javax.transaction.xa.Xid
public static final int | MAXBQUALSIZE | 64
public static final int | MAXGTRIDSIZE | 64

javax.xml.*

javax.xml.bind.JAXBContext
public static final String JAXB_CONTEXT_FACTORY "javax.xml.bind.context.factory"

javax.xml.bind.Marshaller
public static final String | JAXB_ENCODING | "jaxb.encoding"
public static final String | JAXB_FORMATTED_OUTPUT | "jaxb.formatted.output"
public static final String | JAXB_FRAGMENT | "jaxb.fragment"
public static final String | JAXB_NO_NAMESPACE_SCHEMA_LOCATION | "jaxb.noNamespaceSchemaLocation"
public static final String | JAXB_SCHEMA_LOCATION | "jaxb.schemaLocation"

javax.xml.bind.ValidationEvent
public static final int | ERROR | 1
public static final int | FATAL_ERROR | 2
public static final int | WARNING | 0

javax.xml.registry.FindQualifier
public static final String | AND_ALL_KEYS | "andAllKeys"
public static final String | CASE_SENSITIVE_MATCH | "caseSensitiveMatch"
public static final String | COMBINE_CLASSIFICATIONS | "combineClassifications"
public static final String | EXACT_NAME_MATCH | "exactNameMatch"
public static final String | OR_ALL_KEYS | "orAllKeys"
public static final String | OR_LIKE_KEYS | "orLikeKeys"
public static final String | SERVICE_SUBSET | "serviceSubset"
public static final String | SORT_BY_DATE_ASC | "sortByDateAsc"
public static final String | SORT_BY_DATE_DESC | "sortByDateDesc"
public static final String | SORT_BY_NAME_ASC | "sortByNameAsc"
public static final String | SORT_BY_NAME_DESC | "sortByNameDesc"
public static final String | SOUNDEX | "soundex"

javax.xml.registry.JAXRResponse
public static final int | STATUS_FAILURE | 2
public static final int | STATUS_SUCCESS | 0
public static final int | STATUS_UNAVAILABLE | 3
public static final int | STATUS_WARNING | 1

javax.xml.registry.LifeCycleManager
public static final String | ASSOCIATION | "Association"
public static final String | AUDITABLE_EVENT | "AuditableEvent"
public static final String | CLASSIFICATION | "Classification"
public static final String | CLASSIFICATION_SCHEME | "ClassificationScheme"
public static final String | CONCEPT | "Concept"
public static final String | EMAIL_ADDRESS | "EmailAddress"
public static final String | EXTERNAL_IDENTIFIER | "ExternalIdentifier"
public static final String | EXTERNAL_LINK | "ExternalLink"
public static final String | EXTRINSIC_OBJECT | "ExtrinsicObject"
public static final String | INTERNATIONAL_STRING | "InternationalString"
public static final String | KEY | "Key"
public static final String | LOCALIZED_STRING | "LocalizedString"
public static final String | ORGANIZATION | "Organization"
public static final String | PERSON_NAME | "PersonName"
public static final String | POSTAL_ADDRESS | "PostalAddress"
public static final String | REGISTRY_ENTRY | "RegistryEntry"
public static final String | REGISTRY_PACKAGE | "RegistryPackage"
public static final String | SERVICE | "Service"
public static final String | SERVICE_BINDING | "ServiceBinding"
public static final String | SLOT | "Slot"
public static final String | SPECIFICATION_LINK | "SpecificationLink"
public static final String | TELEPHONE_NUMBER | "TelephoneNumber"
public static final String | USER | "User"
public static final String | VERSIONABLE | "Versionable"

javax.xml.registry.Query
public static final int | QUERY_TYPE_EBXML_FILTER_QUERY | 2
public static final int | QUERY_TYPE_SQL | 0
public static final int | QUERY_TYPE_XQUERY | 1

javax.xml.registry.infomodel.AuditableEvent
public static final int | EVENT_TYPE_CREATED | 0
public static final int | EVENT_TYPE_DELETED | 1
public static final int | EVENT_TYPE_DEPRECATED | 2
public static final int | EVENT_TYPE_UNDEPRECATED | 5
public static final int | EVENT_TYPE_UPDATED | 3
public static final int | EVENT_TYPE_VERSIONED | 4

javax.xml.registry.infomodel.ClassificationScheme
public static final int | VALUE_TYPE_EMBEDDED_PATH | 1
public static final int | VALUE_TYPE_NON_UNIQUE | 2
public static final int | VALUE_TYPE_UNIQUE | 0

javax.xml.registry.infomodel.LocalizedString
public static final String DEFAULT_CHARSET_NAME "UTF-8"

javax.xml.registry.infomodel.RegistryEntry
public static final int | STABILITY_DYNAMIC | 0
public static final int | STABILITY_DYNAMIC_COMPATIBLE | 1
public static final int | STABILITY_STATIC | 2
public static final int | STATUS_APPROVED | 1
public static final int | STATUS_DEPRECATED | 2
public static final int | STATUS_SUBMITTED | 0
public static final int | STATUS_WITHDRAWN | 3

javax.xml.registry.infomodel.Slot
public static final String | ADDRESS_LINES_SLOT | "addressLines"
public static final String | AUTHORIZED_NAME_SLOT | "authorizedName"
public static final String | OPERATOR_SLOT | "operator"
public static final String | SORT_CODE_SLOT | "sortCode"

javax.xml.rpc.Call
public static final String | ENCODINGSTYLE_URI_PROPERTY | "javax.xml.rpc.encodingstyle.namespace.uri"
public static final String | OPERATION_STYLE_PROPERTY | "javax.xml.rpc.soap.operation.style"
public static final String | PASSWORD_PROPERTY | "javax.xml.rpc.security.auth.password"
public static final String | SESSION_MAINTAIN_PROPERTY | "javax.xml.rpc.session.maintain"
public static final String | SOAPACTION_URI_PROPERTY | "javax.xml.rpc.soap.http.soapaction.uri"
public static final String | SOAPACTION_USE_PROPERTY | "javax.xml.rpc.soap.http.soapaction.use"
public static final String | USERNAME_PROPERTY | "javax.xml.rpc.security.auth.username"

javax.xml.rpc.NamespaceConstants
public static final String | NSPREFIX_SCHEMA_XSD | "xsd"
public static final String | NSPREFIX_SCHEMA_XSI | "xsi"
public static final String | NSPREFIX_SOAP_ENCODING | "soapenc"
public static final String | NSPREFIX_SOAP_ENVELOPE | "soapenv"
public static final String | NSURI_SCHEMA_XSD | "http://www.w3.org/2001/XMLSchema"
public static final String | NSURI_SCHEMA_XSI | "http://www.w3.org/2001/XMLSchema-instance"
public static final String | NSURI_SOAP_ENCODING | "http://schemas.xmlsoap.org/soap/encoding/"
public static final String | NSURI_SOAP_ENVELOPE | "http://schemas.xmlsoap.org/soap/envelope/"
public static final String | NSURI_SOAP_NEXT_ACTOR | "http://schemas.xmlsoap.org/soap/actor/next"

javax.xml.rpc.ServiceFactory
public static final String SERVICEFACTORY_PROPERTY "javax.xml.rpc.ServiceFactory"

javax.xml.rpc.Stub
public static final String | ENDPOINT_ADDRESS_PROPERTY | "javax.xml.rpc.service.endpoint.address"
public static final String | PASSWORD_PROPERTY | "javax.xml.rpc.security.auth.password"
public static final String | SESSION_MAINTAIN_PROPERTY | "javax.xml.rpc.session.maintain"
public static final String | USERNAME_PROPERTY | "javax.xml.rpc.security.auth.username"

javax.xml.soap.SOAPConstants
public static final String | DEFAULT_SOAP_PROTOCOL | "SOAP 1.1 Protocol"
public static final String | DYNAMIC_SOAP_PROTOCOL | "Dynamic Protocol"
public static final String | SOAP_1_1_CONTENT_TYPE | "text/xml"
public static final String | SOAP_1_1_PROTOCOL | "SOAP 1.1 Protocol"
public static final String | SOAP_1_2_CONTENT_TYPE | "application/soap+xml"
public static final String | SOAP_1_2_PROTOCOL | "SOAP 1.2 Protocol"
public static final String | SOAP_ENV_PREFIX | "env"
public static final String | URI_NS_SOAP_1_1_ENVELOPE | "http://schemas.xmlsoap.org/soap/envelope/"
public static final String | URI_NS_SOAP_1_2_ENCODING | "http://www.w3.org/2003/05/soap-encoding"
public static final String | URI_NS_SOAP_1_2_ENVELOPE | "http://www.w3.org/2003/05/soap-envelope"
public static final String | URI_NS_SOAP_ENCODING | "http://schemas.xmlsoap.org/soap/encoding/"
public static final String | URI_NS_SOAP_ENVELOPE | "http://schemas.xmlsoap.org/soap/envelope/"
public static final String | URI_SOAP_1_2_ROLE_NEXT | "http://www.w3.org/2003/05/soap-envelope/role/next"
public static final String | URI_SOAP_1_2_ROLE_NONE | "http://www.w3.org/2003/05/soap-envelope/role/none"
public static final String | URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER | "http://www.w3.org/2003/05/soap-envelope/role/ultimateReceiver"
public static final String | URI_SOAP_ACTOR_NEXT | "http://schemas.xmlsoap.org/soap/actor/next"

javax.xml.soap.SOAPMessage
public static final String | CHARACTER_SET_ENCODING | "javax.xml.soap.character-set-encoding"
public static final String | WRITE_XML_DECLARATION | "javax.xml.soap.write-xml-declaration"

javax.xml.stream.XMLInputFactory
public static final String | ALLOCATOR | "javax.xml.stream.allocator"
public static final String | IS_COALESCING | "javax.xml.stream.isCoalescing"
public static final String | IS_NAMESPACE_AWARE | "javax.xml.stream.isNamespaceAware"
public static final String | IS_REPLACING_ENTITY_REFERENCES | "javax.xml.stream.isReplacingEntityReferences"
public static final String | IS_SUPPORTING_EXTERNAL_ENTITIES | "javax.xml.stream.isSupportingExternalEntities"
public static final String | IS_VALIDATING | "javax.xml.stream.isValidating"
public static final String | REPORTER | "javax.xml.stream.reporter"
public static final String | RESOLVER | "javax.xml.stream.resolver"
public static final String | SUPPORT_DTD | "javax.xml.stream.supportDTD"

javax.xml.stream.XMLOutputFactory
public static final String IS_REPAIRING_NAMESPACES "javax.xml.stream.isRepairingNamespaces"

javax.xml.stream.XMLStreamConstants
public static final int | ATTRIBUTE | 10
public static final int | CDATA | 12
public static final int | CHARACTERS | 4
public static final int | COMMENT | 5
public static final int | DTD | 11
public static final int | END_DOCUMENT | 8
public static final int | END_ELEMENT | 2
public static final int | ENTITY_DECLARATION | 15
public static final int | ENTITY_REFERENCE | 9
public static final int | NAMESPACE | 13
public static final int | NOTATION_DECLARATION | 14
public static final int | PROCESSING_INSTRUCTION | 3
public static final int | SPACE | 6
public static final int | START_DOCUMENT | 7
public static final int | START_ELEMENT | 1

javax.xml.ws.BindingProvider
public static final String | ENDPOINT_ADDRESS_PROPERTY | "javax.xml.ws.service.endpoint.address"
public static final String | PASSWORD_PROPERTY | "javax.xml.ws.security.auth.password"
public static final String | SESSION_MAINTAIN_PROPERTY | "javax.xml.ws.session.maintain"
public static final String | SOAPACTION_URI_PROPERTY | "javax.xml.ws.soap.http.soapaction.uri"
public static final String | SOAPACTION_USE_PROPERTY | "javax.xml.ws.soap.http.soapaction.use"
public static final String | USERNAME_PROPERTY | "javax.xml.ws.security.auth.username"

javax.xml.ws.Endpoint
public static final String | WSDL_PORT | "javax.xml.ws.wsdl.port"
public static final String | WSDL_SERVICE | "javax.xml.ws.wsdl.service"

javax.xml.ws.handler.MessageContext
public static final String | HTTP_REQUEST_HEADERS | "javax.xml.ws.http.request.headers"
public static final String | HTTP_REQUEST_METHOD | "javax.xml.ws.http.request.method"
public static final String | HTTP_RESPONSE_CODE | "javax.xml.ws.http.response.code"
public static final String | HTTP_RESPONSE_HEADERS | "javax.xml.ws.http.response.headers"
public static final String | INBOUND_MESSAGE_ATTACHMENTS | "javax.xml.ws.binding.attachments.inbound"
public static final String | MESSAGE_OUTBOUND_PROPERTY | "javax.xml.ws.handler.message.outbound"
public static final String | OUTBOUND_MESSAGE_ATTACHMENTS | "javax.xml.ws.binding.attachments.outbound"
public static final String | PATH_INFO | "javax.xml.ws.http.request.pathinfo"
public static final String | QUERY_STRING | "javax.xml.ws.http.request.querystring"
public static final String | SERVLET_CONTEXT | "javax.xml.ws.servlet.context"
public static final String | SERVLET_REQUEST | "javax.xml.ws.servlet.request"
public static final String | SERVLET_RESPONSE | "javax.xml.ws.servlet.response"
public static final String | WSDL_DESCRIPTION | "javax.xml.ws.wsdl.description"
public static final String | WSDL_INTERFACE | "javax.xml.ws.wsdl.interface"
public static final String | WSDL_OPERATION | "javax.xml.ws.wsdl.operation"
public static final String | WSDL_PORT | "javax.xml.ws.wsdl.port"
public static final String | WSDL_SERVICE | "javax.xml.ws.wsdl.service"

javax.xml.ws.http.HTTPBinding
public static final String HTTP_BINDING "http://www.w3.org/2004/08/wsdl/http"

javax.xml.ws.soap.SOAPBinding
public static final String | SOAP11HTTP_BINDING | "http://schemas.xmlsoap.org/wsdl/soap/http"
public static final String | SOAP11HTTP_MTOM_BINDING | "http://schemas.xmlsoap.org/wsdl/soap/http?mtom=true"
public static final String | SOAP12HTTP_BINDING | "http://www.w3.org/2003/05/soap/bindings/HTTP/"
public static final String | SOAP12HTTP_MTOM_BINDING | "http://www.w3.org/2003/05/soap/bindings/HTTP/?mtom=true"

javax.xml.ws.spi.Provider
public static final String JAXWSPROVIDER_PROPERTY "javax.xml.ws.spi.Provider"

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Deprecated List

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Deprecated API

Contents
  • Deprecated Interfaces
  • Deprecated Classes
  • Deprecated Exceptions
  • Deprecated Annotation Types
  • Deprecated Fields
  • Deprecated Methods
  • Deprecated Constructors
  • Deprecated Annotation Type Elements
Deprecated Interfaces
javax.servlet.jsp.el.FunctionMapper
As of JSP 2.1, replaced by FunctionMapper
javax.resource.spi.security.GenericCredential
The preferred way to represent generic credential information is via the org.ietf.jgss.GSSCredential interface in J2SE Version 1.4, which provides similar functionality.
javax.servlet.http.HttpSessionContext
As of Java(tm) Servlet API 2.1 for security reasons, with no replacement. This interface will be removed in a future version of this API.
javax.servlet.SingleThreadModel
As of Java Servlet API 2.4, with no direct replacement.
javax.xml.bind.Validator
since JAXB 2.0
javax.servlet.jsp.el.VariableResolver
As of JSP 2.1, replaced by ELResolver

Deprecated Classes
javax.faces.webapp.AttributeTag
The Faces implementation must now provide the implementation for this class.
javax.faces.webapp.ConverterTag
This has been partially replaced by ConverterELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ConverterTag.createConverter() method, is now an implementation detail.
javax.servlet.jsp.el.Expression
As of JSP 2.1, replaced by ValueExpression
javax.servlet.jsp.el.ExpressionEvaluator
As of JSP 2.1, replaced by ExpressionFactory
javax.servlet.http.HttpUtils
As of Java(tm) Servlet API 2.3. These methods were only useful with the default encoding and have been moved to the request interfaces.
javax.faces.el.MethodBinding
This has been replaced by MethodExpression.
javax.faces.el.PropertyResolver
This has been replaced by ELResolver.
javax.xml.soap.SOAPElementFactory
- Use javax.xml.soap.SOAPFactory for creating SOAPElements.
javax.faces.application.StateManager.SerializedView
This class was not marked Serializable in the 1.0 version of the spec. It was also not a static inner class, so it can't be made to be Serializable. Therefore, it is being deprecated in version 1.2 of the spec. The replacement is to use an implementation dependent Object.
javax.faces.webapp.UIComponentBodyTag
All component tags now implement BodyTag. This class has been replaced by UIComponentELTag.
javax.faces.webapp.UIComponentTag
Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.
javax.faces.webapp.ValidatorTag
This has been partially replaced by ValidatorELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ValidatorTag.createValidator() method, is now an implementation detail.
javax.faces.el.ValueBinding
This has been replaced by ValueExpression.
javax.faces.el.VariableResolver
This has been replaced by ELResolver when operating with a null base argument.

Deprecated Exceptions
javax.servlet.jsp.el.ELException
As of JSP 2.1, replaced by ELException
javax.servlet.jsp.el.ELParseException
As of JSP 2.1, replaced by ELException
javax.faces.el.EvaluationException
This has been replaced by ELException.
javax.faces.el.MethodNotFoundException
This has been replaced by MethodNotFoundException.
javax.faces.el.PropertyNotFoundException
This has been replaced by PropertyNotFoundException.
javax.faces.el.ReferenceSyntaxException
This has been replaced by ELException.

Deprecated Annotation Types
javax.jws.soap.InitParam
As of JSR-181 2.0 with no replacement.
javax.jws.soap.SOAPMessageHandler
As of JSR-181 2.0 with no replacement.
javax.jws.soap.SOAPMessageHandlers
As of JSR-181 2.0 with no replacement.

Deprecated Fields
javax.servlet.jsp.tagext.BodyTag.EVAL_BODY_TAG
As of Java JSP API 1.2, use BodyTag.EVAL_BODY_BUFFERED or IterationTag.EVAL_BODY_AGAIN.
javax.faces.validator.Validator.NOT_IN_RANGE_MESSAGE_ID
Use DoubleRangeValidator.NOT_IN_RANGE_MESSAGE_ID or LongRangeValidator.NOT_IN_RANGE_MESSAGE_ID instead.

Deprecated Methods
javax.xml.soap.SOAPElementFactory.create(Name)
Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
javax.xml.soap.SOAPElementFactory.create(String)
Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
javax.xml.soap.SOAPElementFactory.create(String, String, String)
Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
javax.faces.application.Application.createComponent(ValueBinding, FacesContext, String)
This has been replaced by Application.createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).
javax.faces.application.Application.createMethodBinding(String, Class[])
This has been replaced by calling Application.getExpressionFactory() then ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class, java.lang.Class[]).
javax.xml.bind.JAXBContext.createValidator()
since JAXB2.0
javax.faces.application.Application.createValueBinding(String)
This has been replaced by calling Application.getExpressionFactory() then ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class).
javax.enterprise.deploy.spi.DeploymentManager.distribute(Target[], InputStream, InputStream)
as of Java EE 5, replaced with DeploymentManager.distribute(Target[], ModuleType, InputStream, InputStream)
javax.faces.webapp.UIComponentClassicTagBase.encodeBegin()
No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
javax.faces.webapp.UIComponentClassicTagBase.encodeChildren()
No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
javax.faces.webapp.UIComponentClassicTagBase.encodeEnd()
No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
javax.servlet.http.HttpServletResponse.encodeRedirectUrl(String)
As of version 2.1, use encodeRedirectURL(String url) instead
javax.servlet.http.HttpServletResponse.encodeUrl(String)
As of version 2.1, use encodeURL(String url) instead
javax.faces.component.ActionSource.getAction()
This has been replaced by ActionSource2.getActionExpression().
javax.faces.component.UICommand.getAction()
This has been replaced by UICommand.getActionExpression().
javax.faces.component.ActionSource.getActionListener()
Use ActionSource.getActionListeners() instead.
javax.faces.component.UICommand.getActionListener()
Use UICommand.getActionListeners() instead.
javax.ejb.EJBContext.getCallerIdentity()
Use Principal getCallerPrincipal() instead.
javax.faces.render.ResponseStateManager.getComponentStateToRestore(FacesContext)
This method has been replaced by ResponseStateManager.getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.
javax.faces.application.StateManager.getComponentStateToSave(FacesContext)
the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
javax.ejb.EJBContext.getEnvironment()
Use the JNDI naming context java:comp/env to access enterprise bean's environment.
javax.xml.bind.Validator.getEventHandler()
since JAXB2.0
javax.servlet.jsp.JspContext.getExpressionEvaluator()
As of JSP 2.1, replaced by JspApplicationContext.getExpressionFactory()
javax.servlet.http.HttpSessionContext.getIds()
As of Java Servlet API 2.1 with no replacement. This method must return an empty Enumeration and will be removed in a future version of this API.
javax.resource.ResourceException.getLinkedException()
J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class..
javax.resource.cci.ResourceWarning.getLinkedWarning()
J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
javax.enterprise.deploy.model.DDBeanRoot.getModuleDTDVersion()
As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
javax.enterprise.deploy.model.DeployableObject.getModuleDTDVersion()
As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
javax.xml.bind.Validator.getProperty(String)
since JAXB2.0
javax.faces.application.Application.getPropertyResolver()
This has been replaced by Application.getELResolver().
javax.servlet.ServletRequest.getRealPath(String)
As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead.
javax.servlet.jsp.JspException.getRootCause()
As of JSP 2.1, replaced by Throwable.getCause()
javax.servlet.UnavailableException.getServlet()
As of Java Servlet API 2.2, with no replacement. Returns the servlet that is reporting its unavailability.
javax.servlet.ServletContext.getServlet(String)
As of Java Servlet API 2.1, with no direct replacement.

This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.

javax.servlet.ServletContext.getServletNames()
As of Java Servlet API 2.1, with no replacement.

This method was originally defined to return an Enumeration of all the servlet names known to this context. In this version, this method always returns an empty Enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

javax.servlet.ServletContext.getServlets()
As of Java Servlet API 2.0, with no replacement.

This method was originally defined to return an Enumeration of all the servlets known to this servlet context. In this version, this method always returns an empty enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

javax.servlet.http.HttpSessionContext.getSession(String)
As of Java Servlet API 2.1 with no replacement. This method must return null and will be removed in a future version of this API.
javax.servlet.http.HttpSession.getSessionContext()
As of Version 2.1, this method is deprecated and has no replacement. It will be removed in a future version of the Java Servlet API.
javax.faces.render.ResponseStateManager.getTreeStructureToRestore(FacesContext, String)
This method has been replaced by ResponseStateManager.getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.
javax.faces.application.StateManager.getTreeStructureToSave(FacesContext)
the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
javax.faces.component.EditableValueHolder.getValidator()
EditableValueHolder.getValidators() should be used instead.
javax.faces.component.UIInput.getValidator()
UIInput.getValidators() should be used instead.
javax.servlet.http.HttpSession.getValue(String)
As of Version 2.2, this method is replaced by HttpSession.getAttribute(java.lang.String).
javax.faces.component.UIComponent.getValueBinding(String)
This has been replaced by UIComponent.getValueExpression(java.lang.String).
javax.faces.component.UIComponentBase.getValueBinding(String)
This has been replaced by UIComponentBase.getValueExpression(java.lang.String).
javax.faces.component.UIGraphic.getValueBinding(String)
This has been replaced by UIGraphic.getValueExpression(java.lang.String).
javax.faces.component.UISelectBoolean.getValueBinding(String)
This has been replaced by UISelectBoolean.getValueExpression(java.lang.String).
javax.faces.component.UISelectMany.getValueBinding(String)
this has been replaced by UISelectMany.getValueExpression(java.lang.String).
javax.faces.component.EditableValueHolder.getValueChangeListener()
Use EditableValueHolder.getValueChangeListeners() instead.
javax.servlet.http.HttpSession.getValueNames()
As of Version 2.2, this method is replaced by HttpSession.getAttributeNames()
javax.faces.application.Application.getVariableResolver()
This has been replaced by Application.getELResolver().
javax.servlet.jsp.JspContext.getVariableResolver()
As of JSP 2.1, replaced by ELContext.getELResolver(), which can be obtained by jspContext.getELContext().getELResolver().
javax.ejb.EJBContext.isCallerInRole(Identity)
Use boolean isCallerInRole(String roleName) instead.
javax.servlet.http.HttpServletRequest.isRequestedSessionIdFromUrl()
As of Version 2.1 of the Java Servlet API, use HttpServletRequest.isRequestedSessionIdFromURL() instead.
javax.xml.bind.Unmarshaller.isValidating()
since JAXB2.0, please see Unmarshaller.getSchema()
javax.servlet.ServletContext.log(Exception, String)
As of Java Servlet API 2.1, use ServletContext.log(String message, Throwable throwable) instead.

This method was originally defined to write an exception's stack trace and an explanatory error message to the servlet log file.

javax.activation.ActivationDataFlavor.normalizeMimeType(String)
javax.activation.ActivationDataFlavor.normalizeMimeTypeParameter(String, String)
javax.servlet.http.HttpSession.putValue(String, Object)
As of Version 2.2, this method is replaced by HttpSession.setAttribute(java.lang.String, java.lang.Object)
javax.servlet.http.HttpSession.removeValue(String)
As of Version 2.2, this method is replaced by HttpSession.removeAttribute(java.lang.String)
javax.faces.application.StateManager.restoreComponentState(FacesContext, UIViewRoot, String)
the distinction between tree structure and component state is now an implementation detail. The default implementation does nothing.
javax.faces.application.StateManager.restoreTreeStructure(FacesContext, String, String)
the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
javax.faces.application.StateManager.saveSerializedView(FacesContext)
this has been replaced by StateManager.saveView(javax.faces.context.FacesContext). The default implementation returns null.
javax.faces.component.ActionSource.setAction(MethodBinding)
This has been replaced by ActionSource2.setActionExpression(javax.el.MethodExpression).
javax.faces.component.UICommand.setAction(MethodBinding)
This has been replaced by UICommand.setActionExpression(javax.el.MethodExpression).
javax.faces.component.ActionSource.setActionListener(MethodBinding)
This has been replaced by ActionSource.addActionListener(javax.faces.event.ActionListener).
javax.faces.component.UICommand.setActionListener(MethodBinding)
This has been replaced by UICommand.addActionListener(javax.faces.event.ActionListener).
javax.xml.bind.Validator.setEventHandler(ValidationEventHandler)
since JAXB2.0
javax.resource.ResourceException.setLinkedException(Exception)
J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
javax.resource.cci.ResourceWarning.setLinkedWarning(ResourceWarning)
J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
javax.xml.bind.Validator.setProperty(String, Object)
since JAXB2.0
javax.faces.application.Application.setPropertyResolver(PropertyResolver)
The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called Application.addELResolver(javax.el.ELResolver).
javax.servlet.http.HttpServletResponse.setStatus(int, String)
As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use setStatus(int), to send an error with a description use sendError(int, String). Sets the status code and message for this response.
javax.xml.bind.Unmarshaller.setValidating(boolean)
since JAXB2.0, please see Unmarshaller.setSchema(javax.xml.validation.Schema)
javax.faces.component.EditableValueHolder.setValidator(MethodBinding)
Use EditableValueHolder.addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.
javax.faces.component.UIInput.setValidator(MethodBinding)
Use UIInput.addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.
javax.faces.component.UIComponent.setValueBinding(String, ValueBinding)
This has been replaced by UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression).
javax.faces.component.UIComponentBase.setValueBinding(String, ValueBinding)
This has been replaced by UIComponentBase.setValueExpression(java.lang.String, javax.el.ValueExpression).
javax.faces.component.UIData.setValueBinding(String, ValueBinding)
This has been replaced by UIData.setValueExpression(java.lang.String, javax.el.ValueExpression).
javax.faces.component.UIGraphic.setValueBinding(String, ValueBinding)
This has been replaced by UIGraphic.setValueExpression(java.lang.String, javax.el.ValueExpression).
javax.faces.component.UISelectBoolean.setValueBinding(String, ValueBinding)
This has been replaced by UISelectBoolean.setValueExpression(java.lang.String, javax.el.ValueExpression).
javax.faces.component.UISelectMany.setValueBinding(String, ValueBinding)
This has been replaced by UISelectMany.setValueExpression(java.lang.String, javax.el.ValueExpression).
javax.faces.component.EditableValueHolder.setValueChangeListener(MethodBinding)
Use EditableValueHolder.addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.
javax.faces.component.UIInput.setValueChangeListener(MethodBinding)
Use UIInput.addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.
javax.faces.application.Application.setVariableResolver(VariableResolver)
The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called Application.addELResolver(javax.el.ELResolver).
javax.xml.bind.Validator.validate(Object)
since JAXB2.0
javax.xml.bind.Validator.validateRoot(Object)
since JAXB2.0
javax.faces.application.StateManager.writeState(FacesContext, StateManager.SerializedView)
This method has been replaced by StateManager.writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation of this method does nothing.
javax.faces.render.ResponseStateManager.writeState(FacesContext, StateManager.SerializedView)
This method has been replaced by ResponseStateManager.writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation of this method does nothing.

Deprecated Constructors
javax.servlet.UnavailableException(int, Servlet, String)
As of Java Servlet API 2.2, use UnavailableException.UnavailableException(String, int) instead.
javax.servlet.UnavailableException(Servlet, String)
As of Java Servlet API 2.2, use UnavailableException.UnavailableException(String) instead.

Deprecated Annotation Type Elements
javax.jws.HandlerChain.name
As of JSR-181 2.0 with no replacement.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For All Packages

Package Hierarchies:
javax.activation, javax.annotation, javax.annotation.security, javax.ejb, javax.ejb.spi, javax.el, javax.enterprise.deploy.model, javax.enterprise.deploy.model.exceptions, javax.enterprise.deploy.shared, javax.enterprise.deploy.shared.factories, javax.enterprise.deploy.spi, javax.enterprise.deploy.spi.exceptions, javax.enterprise.deploy.spi.factories, javax.enterprise.deploy.spi.status, javax.faces, javax.faces.application, javax.faces.component, javax.faces.component.html, javax.faces.context, javax.faces.convert, javax.faces.el, javax.faces.event, javax.faces.lifecycle, javax.faces.model, javax.faces.render, javax.faces.validator, javax.faces.webapp, javax.interceptor, javax.jms, javax.jws, javax.jws.soap, javax.mail, javax.mail.event, javax.mail.internet, javax.mail.search, javax.mail.util, javax.management.j2ee, javax.management.j2ee.statistics, javax.persistence, javax.persistence.spi, javax.resource, javax.resource.cci, javax.resource.spi, javax.resource.spi.endpoint, javax.resource.spi.security, javax.resource.spi.work, javax.security.jacc, javax.servlet, javax.servlet.http, javax.servlet.jsp, javax.servlet.jsp.el, javax.servlet.jsp.tagext, javax.transaction, javax.transaction.xa, javax.xml.bind, javax.xml.bind.annotation, javax.xml.bind.annotation.adapters, javax.xml.bind.attachment, javax.xml.bind.helpers, javax.xml.bind.util, javax.xml.registry, javax.xml.registry.infomodel, javax.xml.rpc, javax.xml.rpc.encoding, javax.xml.rpc.handler, javax.xml.rpc.handler.soap, javax.xml.rpc.holders, javax.xml.rpc.server, javax.xml.rpc.soap, javax.xml.soap, javax.xml.stream, javax.xml.stream.events, javax.xml.stream.util, javax.xml.ws, javax.xml.ws.handler, javax.xml.ws.handler.soap, javax.xml.ws.http, javax.xml.ws.soap, javax.xml.ws.spi

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.helpers.AbstractMarshallerImpl (implements javax.xml.bind.Marshaller)
    • javax.xml.bind.helpers.AbstractUnmarshallerImpl (implements javax.xml.bind.Unmarshaller)
    • javax.enterprise.deploy.shared.ActionType
    • javax.mail.Address (implements java.io.Serializable)
      • javax.mail.internet.InternetAddress (implements java.lang.Cloneable)
      • javax.mail.internet.NewsAddress
    • javax.faces.application.Application
    • javax.faces.application.ApplicationFactory
    • javax.xml.bind.attachment.AttachmentMarshaller
    • javax.xml.soap.AttachmentPart
    • javax.xml.bind.attachment.AttachmentUnmarshaller
    • javax.mail.Authenticator
    • javax.el.BeanELResolver.BeanProperties
    • javax.el.BeanELResolver.BeanProperty
    • javax.faces.convert.BigDecimalConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.BigDecimalHolder (implements javax.xml.rpc.holders.Holder)
    • javax.faces.convert.BigIntegerConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.BigIntegerHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.bind.Binder<XmlNode>
    • javax.mail.BodyPart (implements javax.mail.Part)
      • javax.mail.internet.MimeBodyPart (implements javax.mail.internet.MimePart)
        • javax.mail.internet.PreencodedMimeBodyPart
    • javax.faces.convert.BooleanConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.BooleanHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.BooleanWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.mail.util.ByteArrayDataSource (implements javax.activation.DataSource)
    • javax.xml.rpc.holders.ByteArrayHolder (implements javax.xml.rpc.holders.Holder)
    • javax.faces.convert.ByteConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.ByteHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ByteWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.CalendarHolder (implements javax.xml.rpc.holders.Holder)
    • javax.faces.convert.CharacterConverter (implements javax.faces.convert.Converter)
    • javax.activation.CommandInfo
    • javax.activation.CommandMap
      • javax.activation.MailcapCommandMap
    • javax.enterprise.deploy.shared.CommandType
    • javax.mail.event.ConnectionAdapter (implements javax.mail.event.ConnectionListener)
    • javax.xml.registry.ConnectionFactory
    • javax.mail.internet.ContentDisposition
    • javax.mail.internet.ContentType
    • javax.servlet.http.Cookie (implements java.lang.Cloneable)
    • java.awt.datatransfer.DataFlavor (implements java.lang.Cloneable, java.io.Externalizable)
      • javax.activation.ActivationDataFlavor
    • javax.activation.DataHandler (implements java.awt.datatransfer.Transferable)
    • javax.faces.model.DataModel
      • javax.faces.model.ArrayDataModel
      • javax.faces.model.ListDataModel
      • javax.faces.model.ResultDataModel
      • javax.faces.model.ResultSetDataModel
      • javax.faces.model.ScalarDataModel
    • javax.xml.bind.DatatypeConverter
    • javax.faces.convert.DateTimeConverter (implements javax.faces.convert.Converter, javax.faces.component.StateHolder)
    • javax.enterprise.deploy.shared.DConfigBeanVersionType
    • javax.xml.bind.helpers.DefaultValidationEventHandler (implements javax.xml.bind.ValidationEventHandler)
    • javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
    • javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
      • javax.xml.soap.SAAJResult
    • javax.faces.convert.DoubleConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.DoubleHolder (implements javax.xml.rpc.holders.Holder)
    • javax.faces.validator.DoubleRangeValidator (implements javax.faces.component.StateHolder, javax.faces.validator.Validator)
    • javax.xml.rpc.holders.DoubleWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.el.ELContext
    • javax.el.ELResolver
      • javax.el.ArrayELResolver
      • javax.el.BeanELResolver
      • javax.el.CompositeELResolver
      • javax.servlet.jsp.el.ImplicitObjectELResolver
      • javax.el.ListELResolver
      • javax.el.MapELResolver
      • javax.el.ResourceBundleELResolver
      • javax.servlet.jsp.el.ScopedAttributeELResolver
    • javax.xml.ws.Endpoint
    • javax.faces.convert.EnumConverter (implements javax.faces.convert.Converter, javax.faces.component.StateHolder)
    • javax.servlet.jsp.ErrorData
    • java.util.EventObject (implements java.io.Serializable)
      • javax.resource.spi.ConnectionEvent
      • javax.faces.model.DataModelEvent
      • javax.el.ELContextEvent
      • javax.faces.event.FacesEvent
        • javax.faces.event.ActionEvent
        • javax.faces.event.ValueChangeEvent
      • javax.servlet.http.HttpSessionEvent
        • javax.servlet.http.HttpSessionBindingEvent
      • javax.mail.event.MailEvent
        • javax.mail.event.ConnectionEvent
        • javax.mail.event.FolderEvent
        • javax.mail.event.MessageChangedEvent
        • javax.mail.event.MessageCountEvent
        • javax.mail.event.StoreEvent
        • javax.mail.event.TransportEvent
      • javax.faces.event.PhaseEvent
      • javax.enterprise.deploy.spi.status.ProgressEvent
      • javax.servlet.ServletContextEvent
        • javax.servlet.ServletContextAttributeEvent
      • javax.servlet.ServletRequestEvent
        • javax.servlet.ServletRequestAttributeEvent
      • javax.resource.spi.work.WorkEvent
    • javax.xml.stream.util.EventReaderDelegate (implements javax.xml.stream.XMLEventReader)
    • javax.resource.spi.work.ExecutionContext
    • javax.el.Expression (implements java.io.Serializable)
      • javax.el.MethodExpression
      • javax.el.ValueExpression
    • javax.servlet.jsp.el.Expression
    • javax.servlet.jsp.el.ExpressionEvaluator
    • javax.el.ExpressionFactory
    • javax.faces.context.ExternalContext
    • javax.faces.context.FacesContext
    • javax.faces.context.FacesContextFactory
    • javax.faces.application.FacesMessage (implements java.io.Serializable)
    • javax.faces.application.FacesMessage.Severity (implements java.lang.Comparable<T>)
    • javax.faces.webapp.FacesServlet (implements javax.servlet.Servlet)
    • javax.faces.FactoryFinder
    • javax.mail.FetchProfile
    • javax.mail.FetchProfile.Item
      • javax.mail.UIDFolder.FetchProfileItem
    • javax.activation.FileDataSource (implements javax.activation.DataSource)
    • javax.activation.FileTypeMap
      • javax.activation.MimetypesFileTypeMap
    • javax.mail.Flags (implements java.lang.Cloneable, java.io.Serializable)
    • javax.mail.Flags.Flag
    • javax.faces.convert.FloatConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.FloatHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.FloatWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.mail.Folder
    • javax.mail.event.FolderAdapter (implements javax.mail.event.FolderListener)
    • java.text.Format (implements java.lang.Cloneable, java.io.Serializable)
      • java.text.DateFormat
        • java.text.SimpleDateFormat
          • javax.mail.internet.MailDateFormat
    • javax.servlet.jsp.tagext.FunctionInfo
    • javax.el.FunctionMapper
    • javax.xml.rpc.handler.GenericHandler (implements javax.xml.rpc.handler.Handler)
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • javax.servlet.http.HttpServlet (implements java.io.Serializable)
    • javax.xml.rpc.handler.HandlerInfo (implements java.io.Serializable)
    • javax.mail.Header
      • javax.mail.internet.InternetHeaders.InternetHeader
    • javax.mail.internet.HeaderTokenizer
    • javax.mail.internet.HeaderTokenizer.Token
    • javax.xml.ws.Holder<T>
    • javax.servlet.http.HttpUtils
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.ByteArrayInputStream
        • javax.mail.util.SharedByteArrayInputStream (implements javax.mail.internet.SharedInputStream)
      • java.io.FilterInputStream
        • java.io.BufferedInputStream
          • javax.mail.util.SharedFileInputStream (implements javax.mail.internet.SharedInputStream)
      • javax.servlet.ServletInputStream
    • javax.faces.convert.IntegerConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.IntegerWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.mail.internet.InternetHeaders
    • javax.xml.rpc.holders.IntHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.bind.JAXBContext
    • javax.xml.bind.JAXBElement<T> (implements java.io.Serializable)
    • javax.xml.bind.JAXBElement.GlobalScope
    • javax.xml.bind.JAXBIntrospector
    • javax.servlet.jsp.JspContext
      • javax.servlet.jsp.PageContext
    • javax.servlet.jsp.JspEngineInfo
    • javax.servlet.jsp.JspFactory
    • javax.servlet.jsp.tagext.JspFragment
    • javax.faces.validator.LengthValidator (implements javax.faces.component.StateHolder, javax.faces.validator.Validator)
    • javax.faces.lifecycle.Lifecycle
    • javax.faces.lifecycle.LifecycleFactory
    • javax.faces.convert.LongConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.LongHolder (implements javax.xml.rpc.holders.Holder)
    • javax.faces.validator.LongRangeValidator (implements javax.faces.component.StateHolder, javax.faces.validator.Validator)
    • javax.xml.rpc.holders.LongWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.bind.Marshaller.Listener
    • javax.mail.Message (implements javax.mail.Part)
      • javax.mail.internet.MimeMessage (implements javax.mail.internet.MimePart)
    • javax.mail.Message.RecipientType (implements java.io.Serializable)
      • javax.mail.internet.MimeMessage.RecipientType
    • javax.mail.MessageContext
    • javax.mail.event.MessageCountAdapter (implements javax.mail.event.MessageCountListener)
    • javax.xml.soap.MessageFactory
    • javax.faces.el.MethodBinding
    • javax.faces.event.MethodExpressionActionListener (implements javax.faces.event.ActionListener, javax.faces.component.StateHolder)
    • javax.faces.validator.MethodExpressionValidator (implements javax.faces.component.StateHolder, javax.faces.validator.Validator)
    • javax.faces.event.MethodExpressionValueChangeListener (implements javax.faces.component.StateHolder, javax.faces.event.ValueChangeListener)
    • javax.el.MethodInfo
    • javax.xml.soap.MimeHeader
    • javax.xml.soap.MimeHeaders
    • javax.mail.internet.MimePartDataSource (implements javax.activation.DataSource, javax.mail.MessageAware)
    • javax.activation.MimeType (implements java.io.Externalizable)
    • javax.activation.MimeTypeParameterList
    • javax.mail.internet.MimeUtility
    • javax.enterprise.deploy.shared.ModuleType
    • javax.mail.Multipart
      • javax.mail.internet.MimeMultipart
    • javax.xml.rpc.NamespaceConstants
    • javax.faces.application.NavigationHandler
    • javax.faces.convert.NumberConverter (implements javax.faces.convert.Converter, javax.faces.component.StateHolder)
    • javax.xml.rpc.holders.ObjectHolder (implements javax.xml.rpc.holders.Holder)
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • javax.faces.context.ResponseStream
      • javax.servlet.ServletOutputStream
    • javax.servlet.jsp.tagext.PageData
    • javax.mail.internet.ParameterList
    • javax.xml.rpc.ParameterMode
    • javax.mail.PasswordAuthentication
    • javax.resource.spi.security.PasswordCredential (implements java.io.Serializable)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.xml.ws.WebServicePermission
      • javax.security.jacc.EJBMethodPermission (implements java.io.Serializable)
      • javax.security.jacc.EJBRoleRefPermission (implements java.io.Serializable)
      • javax.security.jacc.WebResourcePermission (implements java.io.Serializable)
      • javax.security.jacc.WebRoleRefPermission (implements java.io.Serializable)
      • javax.security.jacc.WebUserDataPermission (implements java.io.Serializable)
    • javax.persistence.Persistence
    • javax.faces.event.PhaseId (implements java.lang.Comparable<T>)
    • javax.security.jacc.PolicyConfigurationFactory
    • javax.security.jacc.PolicyContext
    • javax.faces.el.PropertyResolver
    • javax.xml.ws.spi.Provider
    • javax.mail.Provider
    • javax.mail.Provider.Type
    • javax.xml.rpc.holders.QNameHolder (implements javax.xml.rpc.holders.Holder)
    • javax.jms.QueueRequestor
    • javax.mail.Quota
    • javax.mail.Quota.Resource
    • javax.faces.render.Renderer
    • javax.faces.render.RenderKit
    • javax.faces.render.RenderKitFactory
    • javax.faces.render.ResponseStateManager
    • javax.xml.soap.SAAJMetaFactory
    • javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
      • javax.xml.bind.util.JAXBResult
    • javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
      • javax.xml.bind.util.JAXBSource
    • javax.xml.bind.SchemaOutputResolver
    • javax.mail.search.SearchTerm (implements java.io.Serializable)
      • javax.mail.search.AddressTerm
        • javax.mail.search.FromTerm
        • javax.mail.search.RecipientTerm
      • javax.mail.search.AndTerm
      • javax.mail.search.ComparisonTerm
        • javax.mail.search.DateTerm
          • javax.mail.search.ReceivedDateTerm
          • javax.mail.search.SentDateTerm
        • javax.mail.search.IntegerComparisonTerm
          • javax.mail.search.MessageNumberTerm
          • javax.mail.search.SizeTerm
      • javax.mail.search.FlagTerm
      • javax.mail.search.NotTerm
      • javax.mail.search.OrTerm
      • javax.mail.search.StringTerm
        • javax.mail.search.AddressStringTerm
          • javax.mail.search.FromStringTerm
          • javax.mail.search.RecipientStringTerm
        • javax.mail.search.BodyTerm
        • javax.mail.search.HeaderTerm
        • javax.mail.search.MessageIDTerm
        • javax.mail.search.SubjectTerm
    • javax.faces.model.SelectItem (implements java.io.Serializable)
      • javax.faces.model.SelectItemGroup
    • javax.xml.ws.Service
    • javax.mail.Service
      • javax.mail.Store
      • javax.mail.Transport
    • javax.xml.ws.spi.ServiceDelegate
    • javax.xml.rpc.ServiceFactory
    • javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
      • javax.servlet.http.HttpServletRequestWrapper (implements javax.servlet.http.HttpServletRequest)
    • javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)
    • javax.mail.Session
    • javax.faces.convert.ShortConverter (implements javax.faces.convert.Converter)
    • javax.xml.rpc.holders.ShortHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ShortWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.servlet.jsp.tagext.SimpleTagSupport (implements javax.servlet.jsp.tagext.SimpleTag)
    • javax.xml.soap.SOAPConnection
    • javax.xml.soap.SOAPConnectionFactory
    • javax.xml.soap.SOAPElementFactory
    • javax.xml.soap.SOAPFactory
    • javax.xml.soap.SOAPMessage
    • javax.xml.soap.SOAPPart (implements org.w3c.dom.Document, javax.xml.soap.Node)
    • javax.faces.application.StateManager
      • javax.faces.application.StateManagerWrapper
    • javax.faces.application.StateManager.SerializedView
    • javax.enterprise.deploy.shared.StateType
    • javax.xml.stream.util.StreamReaderDelegate (implements javax.xml.stream.XMLStreamReader)
    • javax.xml.rpc.holders.StringHolder (implements javax.xml.rpc.holders.Holder)
    • javax.servlet.jsp.tagext.TagAdapter (implements javax.servlet.jsp.tagext.Tag)
    • javax.servlet.jsp.tagext.TagAttributeInfo
    • javax.servlet.jsp.tagext.TagData (implements java.lang.Cloneable)
    • javax.servlet.jsp.tagext.TagExtraInfo
    • javax.servlet.jsp.tagext.TagFileInfo
    • javax.servlet.jsp.tagext.TagInfo
    • javax.servlet.jsp.tagext.TagLibraryInfo
    • javax.servlet.jsp.tagext.TagLibraryValidator
    • javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • javax.faces.webapp.AttributeTag
      • javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
      • javax.faces.webapp.ConverterELTag
      • javax.faces.webapp.ConverterTag
      • javax.faces.webapp.FacetTag
      • javax.faces.webapp.ValidatorELTag
      • javax.faces.webapp.ValidatorTag
    • javax.servlet.jsp.tagext.TagVariableInfo
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • javax.xml.stream.FactoryConfigurationError
      • java.lang.Exception
        • javax.enterprise.deploy.spi.exceptions.BeanNotFoundException
        • javax.enterprise.deploy.spi.exceptions.ClientExecuteException
        • javax.enterprise.deploy.spi.exceptions.ConfigurationException
        • javax.ejb.CreateException
          • javax.ejb.DuplicateKeyException
        • javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException
        • javax.enterprise.deploy.model.exceptions.DDBeanCreateException
        • javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException
        • javax.servlet.jsp.el.ELException
          • javax.servlet.jsp.el.ELParseException
        • javax.ejb.FinderException
          • javax.ejb.ObjectNotFoundException
        • javax.transaction.HeuristicCommitException
        • javax.transaction.HeuristicMixedException
        • javax.transaction.HeuristicRollbackException
        • javax.enterprise.deploy.spi.exceptions.InvalidModuleException
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.InvalidTransactionException
            • javax.transaction.TransactionRequiredException
            • javax.transaction.TransactionRolledbackException
          • javax.activation.UnsupportedDataTypeException
        • javax.xml.bind.JAXBException
          • javax.xml.bind.MarshalException
          • javax.xml.bind.PropertyException
          • javax.xml.bind.UnmarshalException
          • javax.xml.bind.ValidationException
        • javax.xml.registry.JAXRException (implements javax.xml.registry.JAXRResponse)
          • javax.xml.registry.InvalidRequestException
          • javax.xml.registry.RegistryException
            • javax.xml.registry.DeleteException
            • javax.xml.registry.FindException
            • javax.xml.registry.SaveException
          • javax.xml.registry.UnexpectedObjectException
          • javax.xml.registry.UnsupportedCapabilityException
        • javax.jms.JMSException
          • javax.jms.IllegalStateException
          • javax.jms.InvalidClientIDException
          • javax.jms.InvalidDestinationException
          • javax.jms.InvalidSelectorException
          • javax.jms.JMSSecurityException
          • javax.jms.MessageEOFException
          • javax.jms.MessageFormatException
          • javax.jms.MessageNotReadableException
          • javax.jms.MessageNotWriteableException
          • javax.jms.ResourceAllocationException
          • javax.jms.TransactionInProgressException
          • javax.jms.TransactionRolledBackException
        • javax.servlet.jsp.JspException
          • javax.servlet.jsp.JspTagException
          • javax.servlet.jsp.SkipPageException
        • javax.mail.MessagingException
          • javax.mail.AuthenticationFailedException
          • javax.mail.FolderClosedException
          • javax.mail.FolderNotFoundException
          • javax.mail.IllegalWriteException
          • javax.mail.MessageRemovedException
          • javax.mail.MethodNotSupportedException
          • javax.mail.NoSuchProviderException
          • javax.mail.internet.ParseException
            • javax.mail.internet.AddressException
          • javax.mail.ReadOnlyFolderException
          • javax.mail.search.SearchException
          • javax.mail.SendFailedException
          • javax.mail.StoreClosedException
        • javax.activation.MimeTypeParseException
        • javax.transaction.NotSupportedException
        • javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException
        • javax.security.jacc.PolicyContextException
        • javax.ejb.RemoveException
        • javax.resource.ResourceException
          • javax.resource.spi.ApplicationServerInternalException
          • javax.resource.spi.CommException
          • javax.resource.spi.EISSystemException
          • javax.resource.spi.IllegalStateException
          • javax.resource.spi.InvalidPropertyException
          • javax.resource.spi.LocalTransactionException
          • javax.resource.NotSupportedException
          • javax.resource.spi.ResourceAdapterInternalException
          • javax.resource.spi.ResourceAllocationException
          • javax.resource.cci.ResourceWarning
          • javax.resource.spi.SecurityException
          • javax.resource.spi.SharingViolationException
          • javax.resource.spi.UnavailableException
          • javax.resource.spi.work.WorkException
            • javax.resource.spi.work.WorkCompletedException
            • javax.resource.spi.work.WorkRejectedException
        • javax.transaction.RollbackException
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.AccessLocalException
            • javax.ejb.ConcurrentAccessException
            • javax.ejb.EJBAccessException
            • javax.ejb.EJBTransactionRequiredException
            • javax.ejb.EJBTransactionRolledbackException
            • javax.ejb.NoSuchEJBException
            • javax.ejb.NoSuchEntityException
            • javax.ejb.NoSuchObjectLocalException
            • javax.ejb.TransactionRequiredLocalException
            • javax.ejb.TransactionRolledbackLocalException
          • javax.el.ELException
            • javax.el.MethodNotFoundException
            • javax.el.PropertyNotFoundException
            • javax.el.PropertyNotWritableException
          • javax.faces.FacesException
            • javax.faces.event.AbortProcessingException
            • javax.faces.convert.ConverterException
            • javax.faces.el.EvaluationException
              • javax.faces.el.MethodNotFoundException
              • javax.faces.el.PropertyNotFoundException
              • javax.faces.el.ReferenceSyntaxException
            • javax.faces.validator.ValidatorException
            • javax.faces.application.ViewExpiredException
          • javax.xml.rpc.JAXRPCException
          • javax.persistence.PersistenceException
            • javax.persistence.EntityExistsException
            • javax.persistence.EntityNotFoundException
            • javax.persistence.NonUniqueResultException
            • javax.persistence.NoResultException
            • javax.persistence.OptimisticLockException
            • javax.persistence.RollbackException
            • javax.persistence.TransactionRequiredException
          • javax.xml.rpc.soap.SOAPFaultException
          • javax.xml.bind.TypeConstraintException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.http.HTTPException
              • javax.xml.ws.soap.SOAPFaultException
        • javax.xml.rpc.ServiceException
        • javax.servlet.ServletException
          • javax.servlet.UnavailableException
        • javax.xml.soap.SOAPException
        • javax.transaction.SystemException
        • javax.enterprise.deploy.spi.exceptions.TargetException
        • javax.transaction.xa.XAException
        • javax.xml.stream.XMLStreamException
    • javax.jms.TopicRequestor
    • javax.mail.event.TransportAdapter (implements javax.mail.event.TransportListener)
    • javax.faces.component.UIComponent (implements javax.faces.component.StateHolder)
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIColumn
          • javax.faces.component.html.HtmlColumn
        • javax.faces.component.UICommand (implements javax.faces.component.ActionSource2)
          • javax.faces.component.html.HtmlCommandButton
          • javax.faces.component.html.HtmlCommandLink
        • javax.faces.component.UIData (implements javax.faces.component.NamingContainer)
          • javax.faces.component.html.HtmlDataTable
        • javax.faces.component.UIForm (implements javax.faces.component.NamingContainer)
          • javax.faces.component.html.HtmlForm
        • javax.faces.component.UIGraphic
          • javax.faces.component.html.HtmlGraphicImage
        • javax.faces.component.UIMessage
          • javax.faces.component.html.HtmlMessage
        • javax.faces.component.UIMessages
          • javax.faces.component.html.HtmlMessages
        • javax.faces.component.UINamingContainer (implements javax.faces.component.NamingContainer)
        • javax.faces.component.UIOutput (implements javax.faces.component.ValueHolder)
          • javax.faces.component.html.HtmlOutputFormat
          • javax.faces.component.html.HtmlOutputLabel
          • javax.faces.component.html.HtmlOutputLink
          • javax.faces.component.html.HtmlOutputText
          • javax.faces.component.UIInput (implements javax.faces.component.EditableValueHolder)
            • javax.faces.component.html.HtmlInputHidden
            • javax.faces.component.html.HtmlInputSecret
            • javax.faces.component.html.HtmlInputText
            • javax.faces.component.html.HtmlInputTextarea
            • javax.faces.component.UISelectBoolean
              • javax.faces.component.html.HtmlSelectBooleanCheckbox
            • javax.faces.component.UISelectMany
              • javax.faces.component.html.HtmlSelectManyCheckbox
              • javax.faces.component.html.HtmlSelectManyListbox
              • javax.faces.component.html.HtmlSelectManyMenu
            • javax.faces.component.UISelectOne
              • javax.faces.component.html.HtmlSelectOneListbox
              • javax.faces.component.html.HtmlSelectOneMenu
              • javax.faces.component.html.HtmlSelectOneRadio
        • javax.faces.component.UIPanel
          • javax.faces.component.html.HtmlPanelGrid
          • javax.faces.component.html.HtmlPanelGroup
        • javax.faces.component.UIParameter
        • javax.faces.component.UISelectItem
        • javax.faces.component.UISelectItems
        • javax.faces.component.UIViewRoot
    • javax.faces.webapp.UIComponentTagBase (implements javax.servlet.jsp.tagext.JspTag)
      • javax.faces.webapp.UIComponentClassicTagBase (implements javax.servlet.jsp.tagext.BodyTag, javax.servlet.jsp.tagext.JspIdConsumer)
        • javax.faces.webapp.UIComponentELTag (implements javax.servlet.jsp.tagext.Tag)
        • javax.faces.webapp.UIComponentTag (implements javax.servlet.jsp.tagext.Tag)
          • javax.faces.webapp.UIComponentBodyTag
    • javax.xml.bind.Unmarshaller.Listener
    • javax.activation.URLDataSource (implements javax.activation.DataSource)
    • javax.mail.URLName
    • javax.xml.bind.util.ValidationEventCollector (implements javax.xml.bind.ValidationEventHandler)
    • javax.xml.bind.helpers.ValidationEventImpl (implements javax.xml.bind.ValidationEvent)
      • javax.xml.bind.helpers.NotIdentifiableEventImpl (implements javax.xml.bind.NotIdentifiableEvent)
      • javax.xml.bind.helpers.ParseConversionEventImpl (implements javax.xml.bind.ParseConversionEvent)
      • javax.xml.bind.helpers.PrintConversionEventImpl (implements javax.xml.bind.PrintConversionEvent)
    • javax.xml.bind.helpers.ValidationEventLocatorImpl (implements javax.xml.bind.ValidationEventLocator)
    • javax.servlet.jsp.tagext.ValidationMessage
    • javax.faces.el.ValueBinding
    • javax.servlet.jsp.tagext.VariableInfo
    • javax.el.VariableMapper
    • javax.faces.el.VariableResolver
    • javax.faces.application.ViewHandler
      • javax.faces.application.ViewHandlerWrapper
    • javax.xml.bind.annotation.W3CDomHandler (implements javax.xml.bind.annotation.DomHandler<ElementT,ResultT>)
    • javax.resource.spi.work.WorkAdapter (implements javax.resource.spi.work.WorkListener)
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • javax.servlet.jsp.JspWriter
        • javax.servlet.jsp.tagext.BodyContent
      • javax.faces.context.ResponseWriter
        • javax.faces.context.ResponseWriterWrapper
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
      • javax.xml.bind.annotation.adapters.CollapsedStringAdapter
      • javax.xml.bind.annotation.adapters.HexBinaryAdapter
      • javax.xml.bind.annotation.adapters.NormalizedStringAdapter
    • javax.xml.bind.annotation.XmlElement.DEFAULT
    • javax.xml.bind.annotation.XmlElementDecl.GLOBAL
    • javax.xml.bind.annotation.XmlElementRef.DEFAULT
    • javax.xml.stream.XMLEventFactory
    • javax.xml.stream.XMLInputFactory
    • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
    • javax.xml.stream.XMLOutputFactory
    • javax.xml.bind.annotation.XmlSchemaType.DEFAULT
    • javax.xml.rpc.encoding.XMLType
    • javax.xml.bind.annotation.XmlType.DEFAULT
    • javax.enterprise.deploy.model.XpathEvent

Interface Hierarchy

  • javax.faces.component.ActionSource
    • javax.faces.component.ActionSource2
  • javax.xml.ws.AsyncHandler<T>
  • javax.xml.ws.Binding
    • javax.xml.ws.http.HTTPBinding
    • javax.xml.ws.soap.SOAPBinding
  • javax.xml.ws.BindingProvider
    • javax.xml.ws.Dispatch<T>
  • javax.resource.spi.BootstrapContext
  • javax.xml.rpc.Call
  • javax.xml.registry.CapabilityProfile
  • javax.persistence.spi.ClassTransformer
  • java.lang.Cloneable
    • javax.resource.cci.Record (also extends java.io.Serializable)
      • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, java.io.Serializable)
      • javax.resource.cci.MappedRecord (also extends java.util.Map<K,V>, java.io.Serializable)
      • javax.resource.cci.ResultSet (also extends java.sql.ResultSet)
  • javax.activation.CommandObject
  • javax.resource.cci.Connection
  • javax.jms.Connection
    • javax.jms.QueueConnection
      • javax.jms.XAQueueConnection (also extends javax.jms.XAConnection)
    • javax.jms.TopicConnection
      • javax.jms.XATopicConnection (also extends javax.jms.XAConnection)
    • javax.jms.XAConnection
      • javax.jms.XAQueueConnection (also extends javax.jms.QueueConnection)
      • javax.jms.XATopicConnection (also extends javax.jms.TopicConnection)
    • javax.jms.XAQueueConnection (also extends javax.jms.QueueConnection, javax.jms.XAConnection)
    • javax.jms.XATopicConnection (also extends javax.jms.TopicConnection, javax.jms.XAConnection)
  • javax.xml.registry.Connection
    • javax.xml.registry.FederatedConnection
  • javax.jms.ConnectionConsumer
  • javax.jms.ConnectionFactory
    • javax.jms.QueueConnectionFactory
      • javax.jms.XAQueueConnectionFactory (also extends javax.jms.XAConnectionFactory)
    • javax.jms.TopicConnectionFactory
      • javax.jms.XATopicConnectionFactory (also extends javax.jms.XAConnectionFactory)
    • javax.jms.XAQueueConnectionFactory (also extends javax.jms.QueueConnectionFactory, javax.jms.XAConnectionFactory)
    • javax.jms.XATopicConnectionFactory (also extends javax.jms.TopicConnectionFactory, javax.jms.XAConnectionFactory)
  • javax.resource.cci.ConnectionMetaData
  • javax.jms.ConnectionMetaData
  • javax.resource.spi.ConnectionRequestInfo
  • javax.resource.cci.ConnectionSpec
  • org.xml.sax.ContentHandler
    • javax.xml.bind.UnmarshallerHandler
  • javax.faces.component.ContextCallback
  • javax.faces.convert.Converter
  • javax.activation.DataContentHandler
  • javax.activation.DataContentHandlerFactory
  • javax.activation.DataSource
    • javax.mail.MultipartDataSource
  • javax.xml.bind.DatatypeConverterInterface
  • javax.enterprise.deploy.spi.DConfigBean
    • javax.enterprise.deploy.spi.DConfigBeanRoot
  • javax.enterprise.deploy.model.DDBean
    • javax.enterprise.deploy.model.DDBeanRoot
  • javax.jms.DeliveryMode
  • javax.enterprise.deploy.model.DeployableObject
    • javax.enterprise.deploy.model.J2eeApplicationObject
  • javax.enterprise.deploy.spi.DeploymentConfiguration
  • javax.enterprise.deploy.spi.factories.DeploymentFactory
  • javax.enterprise.deploy.spi.DeploymentManager
  • javax.enterprise.deploy.spi.status.DeploymentStatus
  • javax.xml.rpc.encoding.DeserializationContext
  • javax.jms.Destination
    • javax.jms.Queue
      • javax.jms.TemporaryQueue
    • javax.jms.TemporaryQueue
    • javax.jms.TemporaryTopic
    • javax.jms.Topic
      • javax.jms.TemporaryTopic
  • javax.resource.spi.DissociatableManagedConnection
  • javax.xml.bind.annotation.DomHandler<ElementT,ResultT>
  • javax.servlet.jsp.tagext.DynamicAttributes
  • javax.ejb.EJBContext
    • javax.ejb.EntityContext
    • javax.ejb.MessageDrivenContext
    • javax.ejb.SessionContext
  • javax.ejb.EJBLocalHome
  • javax.ejb.EJBLocalObject
  • javax.ejb.EJBMetaData
  • javax.xml.bind.Element
  • javax.xml.registry.infomodel.EmailAddress
  • javax.persistence.EntityManager
  • javax.persistence.EntityManagerFactory
  • javax.persistence.EntityTransaction
  • javax.xml.stream.EventFilter
  • java.util.EventListener
    • javax.resource.spi.ConnectionEventListener
    • javax.mail.event.ConnectionListener
    • javax.faces.model.DataModelListener
    • javax.el.ELContextListener
    • javax.faces.event.FacesListener
      • javax.faces.event.ActionListener
      • javax.faces.event.ValueChangeListener
    • javax.mail.event.FolderListener
    • javax.servlet.http.HttpSessionActivationListener
    • javax.servlet.http.HttpSessionAttributeListener
    • javax.servlet.http.HttpSessionBindingListener
    • javax.servlet.http.HttpSessionListener
    • javax.mail.event.MessageChangedListener
    • javax.mail.event.MessageCountListener
    • javax.faces.event.PhaseListener (also extends java.io.Serializable)
    • javax.enterprise.deploy.spi.status.ProgressListener
    • javax.servlet.ServletContextAttributeListener
    • javax.servlet.ServletContextListener
    • javax.servlet.ServletRequestAttributeListener
    • javax.servlet.ServletRequestListener
    • javax.mail.event.StoreListener
    • javax.mail.event.TransportListener
    • javax.faces.validator.Validator
    • javax.resource.spi.work.WorkListener
  • javax.jms.ExceptionListener
  • javax.xml.registry.infomodel.ExtensibleObject
    • javax.xml.registry.infomodel.Association
    • javax.xml.registry.infomodel.AuditableEvent
    • javax.xml.registry.infomodel.Classification
    • javax.xml.registry.infomodel.ClassificationScheme
    • javax.xml.registry.infomodel.Concept
    • javax.xml.registry.infomodel.ExternalIdentifier
    • javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.RegistryObject, javax.xml.registry.infomodel.URIValidator)
    • javax.xml.registry.infomodel.ExtrinsicObject
    • javax.xml.registry.infomodel.Organization
    • javax.xml.registry.infomodel.PostalAddress
    • javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.RegistryObject, javax.xml.registry.infomodel.Versionable)
      • javax.xml.registry.infomodel.ClassificationScheme
      • javax.xml.registry.infomodel.ExtrinsicObject
      • javax.xml.registry.infomodel.RegistryPackage
      • javax.xml.registry.infomodel.Service
    • javax.xml.registry.infomodel.RegistryObject
      • javax.xml.registry.infomodel.Association
      • javax.xml.registry.infomodel.AuditableEvent
      • javax.xml.registry.infomodel.Classification
      • javax.xml.registry.infomodel.ClassificationScheme
      • javax.xml.registry.infomodel.Concept
      • javax.xml.registry.infomodel.ExternalIdentifier
      • javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.URIValidator)
      • javax.xml.registry.infomodel.ExtrinsicObject
      • javax.xml.registry.infomodel.Organization
      • javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.Versionable)
        • javax.xml.registry.infomodel.ClassificationScheme
        • javax.xml.registry.infomodel.ExtrinsicObject
        • javax.xml.registry.infomodel.RegistryPackage
        • javax.xml.registry.infomodel.Service
      • javax.xml.registry.infomodel.RegistryPackage
      • javax.xml.registry.infomodel.Service
      • javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.URIValidator)
      • javax.xml.registry.infomodel.SpecificationLink
      • javax.xml.registry.infomodel.User
    • javax.xml.registry.infomodel.RegistryPackage
    • javax.xml.registry.infomodel.Service
    • javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.RegistryObject, javax.xml.registry.infomodel.URIValidator)
    • javax.xml.registry.infomodel.SpecificationLink
    • javax.xml.registry.infomodel.User
  • javax.servlet.Filter
  • javax.servlet.FilterChain
  • javax.servlet.FilterConfig
  • javax.xml.registry.FindQualifier
  • javax.servlet.jsp.el.FunctionMapper
  • java.util.concurrent.Future<V>
    • javax.xml.ws.Response<T>
  • javax.resource.spi.security.GenericCredential
  • javax.ejb.spi.HandleDelegate
  • javax.xml.rpc.handler.Handler
  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.LogicalHandler<C>
    • javax.xml.ws.handler.soap.SOAPHandler<T>
  • javax.xml.ws.handler.HandlerResolver
  • javax.xml.rpc.holders.Holder
  • javax.servlet.http.HttpSession
  • javax.servlet.http.HttpSessionContext
  • javax.resource.cci.Interaction
  • javax.xml.registry.infomodel.InternationalString
  • javax.interceptor.InvocationContext
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.util.List<E>
        • javax.xml.rpc.handler.HandlerChain
        • javax.resource.cci.IndexedRecord (also extends javax.resource.cci.Record, java.io.Serializable)
  • java.util.Iterator<E>
    • javax.xml.stream.XMLEventReader
  • javax.management.j2ee.statistics.JavaMailStats
  • javax.xml.registry.JAXRResponse
    • javax.xml.registry.BulkResponse
  • javax.servlet.jsp.JspApplicationContext
  • javax.servlet.jsp.tagext.JspIdConsumer
  • javax.servlet.jsp.tagext.JspTag
    • javax.servlet.jsp.tagext.BodyTag
    • javax.servlet.jsp.tagext.IterationTag
      • javax.servlet.jsp.tagext.BodyTag
    • javax.servlet.jsp.tagext.SimpleTag
    • javax.servlet.jsp.tagext.Tag
      • javax.servlet.jsp.tagext.BodyTag
      • javax.servlet.jsp.tagext.IterationTag
        • javax.servlet.jsp.tagext.BodyTag
  • javax.xml.registry.infomodel.Key
  • javax.resource.spi.LazyAssociatableConnectionManager
  • javax.resource.spi.LazyEnlistableConnectionManager
  • javax.resource.spi.LazyEnlistableManagedConnection
  • javax.xml.registry.LifeCycleManager
    • javax.xml.registry.BusinessLifeCycleManager
  • javax.xml.registry.infomodel.LocalizedString
  • javax.resource.cci.LocalTransaction
  • javax.resource.spi.LocalTransaction
  • javax.xml.stream.Location
  • javax.xml.ws.LogicalMessage
  • javax.resource.spi.ManagedConnection
  • javax.resource.spi.ManagedConnectionMetaData
  • java.util.Map<K,V>
    • javax.resource.cci.MappedRecord (also extends javax.resource.cci.Record, java.io.Serializable)
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.LogicalMessageContext
      • javax.xml.ws.handler.soap.SOAPMessageContext
  • javax.xml.bind.Marshaller
  • javax.jms.Message
    • javax.jms.BytesMessage
    • javax.jms.MapMessage
    • javax.jms.ObjectMessage
    • javax.jms.StreamMessage
    • javax.jms.TextMessage
  • javax.mail.MessageAware
  • javax.jms.MessageConsumer
    • javax.jms.QueueReceiver
    • javax.jms.TopicSubscriber
  • javax.xml.rpc.handler.MessageContext
    • javax.xml.rpc.handler.soap.SOAPMessageContext
  • javax.resource.spi.endpoint.MessageEndpoint
  • javax.resource.spi.endpoint.MessageEndpointFactory
  • javax.resource.cci.MessageListener
  • javax.jms.MessageListener
  • javax.jms.MessageProducer
    • javax.jms.QueueSender
    • javax.jms.TopicPublisher
  • javax.xml.soap.Name
  • javax.faces.component.NamingContainer
  • org.w3c.dom.Node
    • org.w3c.dom.CharacterData
      • org.w3c.dom.Text
        • javax.xml.soap.Text (also extends javax.xml.soap.Node)
    • org.w3c.dom.Element
      • javax.xml.soap.SOAPElement (also extends javax.xml.soap.Node)
        • javax.xml.soap.Detail
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
    • javax.xml.soap.Node
      • javax.xml.soap.Detail
      • javax.xml.soap.DetailEntry
      • javax.xml.soap.SOAPBody
      • javax.xml.soap.SOAPBodyElement
        • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPElement (also extends org.w3c.dom.Element)
        • javax.xml.soap.Detail
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.SOAPEnvelope
      • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPFaultElement
        • javax.xml.soap.Detail
      • javax.xml.soap.SOAPHeader
      • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.Text (also extends org.w3c.dom.Text)
  • javax.mail.Part
    • javax.mail.internet.MimePart
  • javax.persistence.spi.PersistenceProvider
  • javax.persistence.spi.PersistenceUnitInfo
  • javax.xml.registry.infomodel.PersonName
  • javax.security.jacc.PolicyConfiguration
  • javax.security.jacc.PolicyContextHandler
  • javax.xml.ws.handler.PortInfo
  • javax.enterprise.deploy.spi.status.ProgressObject
  • javax.xml.ws.Provider<T>
  • javax.xml.registry.Query
  • javax.persistence.Query
  • javax.xml.registry.QueryManager
    • javax.xml.registry.BusinessQueryManager
    • javax.xml.registry.DeclarativeQueryManager
  • javax.jms.QueueBrowser
  • javax.mail.QuotaAwareStore
  • javax.resource.cci.RecordFactory
  • javax.naming.Referenceable
    • javax.resource.Referenceable
      • javax.resource.cci.ConnectionFactory (also extends java.io.Serializable)
  • javax.xml.registry.RegistryService
  • java.rmi.Remote
    • javax.ejb.EJBHome
      • javax.management.j2ee.ManagementHome
    • javax.ejb.EJBObject
      • javax.management.j2ee.Management
  • javax.servlet.RequestDispatcher
  • javax.resource.spi.ResourceAdapter
  • javax.resource.spi.ResourceAdapterAssociation
    • javax.resource.spi.ActivationSpec
  • javax.resource.cci.ResourceAdapterMetaData
  • java.sql.ResultSet
    • javax.resource.cci.ResultSet (also extends javax.resource.cci.Record)
  • javax.resource.cci.ResultSetInfo
  • java.lang.Runnable
    • javax.jms.Session
      • javax.jms.QueueSession
      • javax.jms.TopicSession
      • javax.jms.XAQueueSession
      • javax.jms.XASession
        • javax.jms.XAQueueSession
        • javax.jms.XATopicSession
      • javax.jms.XATopicSession
    • javax.resource.spi.work.Work
  • java.io.Serializable
    • javax.enterprise.deploy.spi.status.ClientConfiguration
    • javax.resource.cci.ConnectionFactory (also extends javax.resource.Referenceable)
    • javax.resource.spi.ConnectionManager
    • javax.xml.rpc.encoding.Deserializer
    • javax.xml.rpc.encoding.DeserializerFactory
    • javax.ejb.EnterpriseBean
      • javax.ejb.EntityBean
      • javax.ejb.MessageDrivenBean
      • javax.ejb.SessionBean
    • javax.ejb.Handle
    • javax.xml.rpc.handler.HandlerRegistry
    • javax.ejb.HomeHandle
    • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, javax.resource.cci.Record)
    • javax.resource.cci.InteractionSpec
    • javax.management.j2ee.ListenerRegistration
    • javax.resource.spi.ManagedConnectionFactory
    • javax.resource.cci.MappedRecord (also extends java.util.Map<K,V>, javax.resource.cci.Record)
    • javax.faces.event.PhaseListener (also extends java.util.EventListener)
    • javax.resource.cci.Record (also extends java.lang.Cloneable)
      • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, java.io.Serializable)
      • javax.resource.cci.MappedRecord (also extends java.util.Map<K,V>, java.io.Serializable)
      • javax.resource.cci.ResultSet (also extends java.sql.ResultSet)
    • javax.xml.rpc.encoding.Serializer
    • javax.xml.rpc.encoding.SerializerFactory
    • javax.ejb.TimerHandle
    • javax.xml.rpc.encoding.TypeMappingRegistry
  • javax.xml.rpc.encoding.SerializationContext
  • javax.jms.ServerSession
  • javax.jms.ServerSessionPool
  • javax.xml.rpc.Service
  • javax.xml.rpc.server.ServiceLifecycle
  • javax.servlet.Servlet
    • javax.servlet.jsp.HttpJspPage
    • javax.servlet.jsp.JspPage
      • javax.servlet.jsp.HttpJspPage
  • javax.servlet.ServletConfig
  • javax.servlet.ServletContext
  • javax.xml.rpc.server.ServletEndpointContext
  • javax.servlet.ServletRequest
    • javax.servlet.http.HttpServletRequest
  • javax.servlet.ServletResponse
    • javax.servlet.http.HttpServletResponse
  • javax.ejb.SessionSynchronization
  • javax.mail.internet.SharedInputStream
  • javax.servlet.SingleThreadModel
  • javax.xml.registry.infomodel.Slot
  • javax.xml.soap.SOAPConstants
  • javax.faces.component.StateHolder
  • javax.management.j2ee.statistics.Statistic
    • javax.management.j2ee.statistics.BoundaryStatistic
      • javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.RangeStatistic)
    • javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.BoundaryStatistic, javax.management.j2ee.statistics.RangeStatistic)
    • javax.management.j2ee.statistics.CountStatistic
    • javax.management.j2ee.statistics.RangeStatistic
      • javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.BoundaryStatistic)
    • javax.management.j2ee.statistics.TimeStatistic
  • javax.management.j2ee.statistics.Stats
    • javax.management.j2ee.statistics.EJBStats
      • javax.management.j2ee.statistics.EntityBeanStats
      • javax.management.j2ee.statistics.MessageDrivenBeanStats
      • javax.management.j2ee.statistics.SessionBeanStats
        • javax.management.j2ee.statistics.StatefulSessionBeanStats
        • javax.management.j2ee.statistics.StatelessSessionBeanStats
      • javax.management.j2ee.statistics.StatefulSessionBeanStats
      • javax.management.j2ee.statistics.StatelessSessionBeanStats
    • javax.management.j2ee.statistics.EntityBeanStats
    • javax.management.j2ee.statistics.JCAConnectionPoolStats
    • javax.management.j2ee.statistics.JCAConnectionStats
      • javax.management.j2ee.statistics.JCAConnectionPoolStats
    • javax.management.j2ee.statistics.JCAStats
    • javax.management.j2ee.statistics.JDBCConnectionPoolStats
    • javax.management.j2ee.statistics.JDBCConnectionStats
      • javax.management.j2ee.statistics.JDBCConnectionPoolStats
    • javax.management.j2ee.statistics.JDBCStats
    • javax.management.j2ee.statistics.JMSConnectionStats
    • javax.management.j2ee.statistics.JMSConsumerStats
    • javax.management.j2ee.statistics.JMSEndpointStats
      • javax.management.j2ee.statistics.JMSConsumerStats
      • javax.management.j2ee.statistics.JMSProducerStats
    • javax.management.j2ee.statistics.JMSProducerStats
    • javax.management.j2ee.statistics.JMSSessionStats
    • javax.management.j2ee.statistics.JMSStats
    • javax.management.j2ee.statistics.JTAStats
    • javax.management.j2ee.statistics.JVMStats
    • javax.management.j2ee.statistics.MessageDrivenBeanStats
    • javax.management.j2ee.statistics.ServletStats
    • javax.management.j2ee.statistics.SessionBeanStats
      • javax.management.j2ee.statistics.StatefulSessionBeanStats
      • javax.management.j2ee.statistics.StatelessSessionBeanStats
    • javax.management.j2ee.statistics.StatefulSessionBeanStats
    • javax.management.j2ee.statistics.StatelessSessionBeanStats
    • javax.management.j2ee.statistics.URLStats
  • javax.transaction.Status
  • javax.resource.cci.Streamable
  • javax.xml.stream.StreamFilter
  • javax.xml.rpc.Stub
  • javax.transaction.Synchronization
  • javax.enterprise.deploy.spi.Target
  • javax.enterprise.deploy.spi.TargetModuleID
  • javax.xml.registry.infomodel.TelephoneNumber
  • javax.ejb.TimedObject
  • javax.ejb.Timer
  • javax.ejb.TimerService
  • javax.transaction.Transaction
  • javax.transaction.TransactionManager
  • javax.transaction.TransactionSynchronizationRegistry
  • javax.servlet.jsp.tagext.TryCatchFinally
  • javax.xml.rpc.encoding.TypeMapping
  • javax.mail.UIDFolder
  • javax.xml.bind.Unmarshaller
  • javax.xml.registry.infomodel.URIValidator
    • javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.RegistryObject)
    • javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.RegistryObject)
  • javax.transaction.UserTransaction
  • javax.resource.spi.ValidatingManagedConnectionFactory
  • javax.xml.bind.ValidationEvent
    • javax.xml.bind.NotIdentifiableEvent
    • javax.xml.bind.ParseConversionEvent
    • javax.xml.bind.PrintConversionEvent
  • javax.xml.bind.ValidationEventHandler
  • javax.xml.bind.ValidationEventLocator
  • javax.xml.bind.Validator
  • javax.faces.component.ValueHolder
    • javax.faces.component.EditableValueHolder
  • javax.servlet.jsp.el.VariableResolver
  • javax.xml.registry.infomodel.Versionable
    • javax.xml.registry.infomodel.ClassificationScheme
    • javax.xml.registry.infomodel.ExtrinsicObject
    • javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.RegistryObject)
      • javax.xml.registry.infomodel.ClassificationScheme
      • javax.xml.registry.infomodel.ExtrinsicObject
      • javax.xml.registry.infomodel.RegistryPackage
      • javax.xml.registry.infomodel.Service
    • javax.xml.registry.infomodel.RegistryPackage
    • javax.xml.registry.infomodel.Service
  • javax.xml.ws.WebServiceContext
  • javax.resource.spi.work.WorkManager
  • javax.jms.XAConnectionFactory
    • javax.jms.XAQueueConnectionFactory (also extends javax.jms.QueueConnectionFactory)
    • javax.jms.XATopicConnectionFactory (also extends javax.jms.TopicConnectionFactory)
  • javax.transaction.xa.XAResource
  • javax.resource.spi.XATerminator
  • javax.transaction.xa.Xid
  • javax.xml.stream.util.XMLEventAllocator
  • javax.xml.stream.util.XMLEventConsumer
    • javax.xml.stream.XMLEventWriter
  • javax.xml.stream.XMLReporter
  • javax.xml.stream.XMLResolver
  • javax.xml.stream.XMLStreamConstants
    • javax.xml.stream.events.Attribute
      • javax.xml.stream.events.Namespace
    • javax.xml.stream.events.Characters
    • javax.xml.stream.events.Comment
    • javax.xml.stream.events.DTD
    • javax.xml.stream.events.EndDocument
    • javax.xml.stream.events.EndElement
    • javax.xml.stream.events.EntityDeclaration
    • javax.xml.stream.events.EntityReference
    • javax.xml.stream.events.Namespace
    • javax.xml.stream.events.NotationDeclaration
    • javax.xml.stream.events.ProcessingInstruction
    • javax.xml.stream.events.StartDocument
    • javax.xml.stream.events.StartElement
    • javax.xml.stream.events.XMLEvent
      • javax.xml.stream.events.Attribute
        • javax.xml.stream.events.Namespace
      • javax.xml.stream.events.Characters
      • javax.xml.stream.events.Comment
      • javax.xml.stream.events.DTD
      • javax.xml.stream.events.EndDocument
      • javax.xml.stream.events.EndElement
      • javax.xml.stream.events.EntityDeclaration
      • javax.xml.stream.events.EntityReference
      • javax.xml.stream.events.Namespace
      • javax.xml.stream.events.NotationDeclaration
      • javax.xml.stream.events.ProcessingInstruction
      • javax.xml.stream.events.StartDocument
      • javax.xml.stream.events.StartElement
    • javax.xml.stream.XMLStreamReader
  • javax.xml.stream.XMLStreamWriter
  • javax.enterprise.deploy.model.XpathListener

Annotation Type Hierarchy

  • javax.ejb.ActivationConfigProperty (implements java.lang.annotation.Annotation)
  • javax.ejb.ApplicationException (implements java.lang.annotation.Annotation)
  • javax.ejb.EJB (implements java.lang.annotation.Annotation)
  • javax.ejb.EJBs (implements java.lang.annotation.Annotation)
  • javax.ejb.Init (implements java.lang.annotation.Annotation)
  • javax.ejb.Local (implements java.lang.annotation.Annotation)
  • javax.ejb.LocalHome (implements java.lang.annotation.Annotation)
  • javax.ejb.MessageDriven (implements java.lang.annotation.Annotation)
  • javax.ejb.PostActivate (implements java.lang.annotation.Annotation)
  • javax.ejb.PrePassivate (implements java.lang.annotation.Annotation)
  • javax.ejb.Remote (implements java.lang.annotation.Annotation)
  • javax.ejb.RemoteHome (implements java.lang.annotation.Annotation)
  • javax.ejb.Remove (implements java.lang.annotation.Annotation)
  • javax.ejb.Stateful (implements java.lang.annotation.Annotation)
  • javax.ejb.Stateless (implements java.lang.annotation.Annotation)
  • javax.ejb.Timeout (implements java.lang.annotation.Annotation)
  • javax.ejb.TransactionAttribute (implements java.lang.annotation.Annotation)
  • javax.ejb.TransactionManagement (implements java.lang.annotation.Annotation)
  • javax.interceptor.AroundInvoke (implements java.lang.annotation.Annotation)
  • javax.interceptor.ExcludeClassInterceptors (implements java.lang.annotation.Annotation)
  • javax.interceptor.ExcludeDefaultInterceptors (implements java.lang.annotation.Annotation)
  • javax.interceptor.Interceptors (implements java.lang.annotation.Annotation)
  • javax.annotation.Generated (implements java.lang.annotation.Annotation)
  • javax.annotation.PostConstruct (implements java.lang.annotation.Annotation)
  • javax.annotation.PreDestroy (implements java.lang.annotation.Annotation)
  • javax.annotation.Resource (implements java.lang.annotation.Annotation)
  • javax.annotation.Resources (implements java.lang.annotation.Annotation)
  • javax.annotation.security.DeclareRoles (implements java.lang.annotation.Annotation)
  • javax.annotation.security.DenyAll (implements java.lang.annotation.Annotation)
  • javax.annotation.security.PermitAll (implements java.lang.annotation.Annotation)
  • javax.annotation.security.RolesAllowed (implements java.lang.annotation.Annotation)
  • javax.annotation.security.RunAs (implements java.lang.annotation.Annotation)
  • javax.xml.ws.BindingType (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RequestWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ResponseWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ServiceMode (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebEndpoint (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebFault (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceClient (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceProvider (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRef (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRefs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorOrder (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttachmentRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementDecl (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRefs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElements (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnum (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnumValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlID (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlIDREF (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlInlineBinaryData (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlList (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMimeType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMixed (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlNs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRegistry (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRootElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchema (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaTypes (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlTransient (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters (implements java.lang.annotation.Annotation)
  • javax.jws.HandlerChain (implements java.lang.annotation.Annotation)
  • javax.jws.Oneway (implements java.lang.annotation.Annotation)
  • javax.jws.WebMethod (implements java.lang.annotation.Annotation)
  • javax.jws.WebParam (implements java.lang.annotation.Annotation)
  • javax.jws.WebResult (implements java.lang.annotation.Annotation)
  • javax.jws.WebService (implements java.lang.annotation.Annotation)
  • javax.jws.soap.InitParam (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPBinding (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandler (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandlers (implements java.lang.annotation.Annotation)
  • javax.persistence.AssociationOverride (implements java.lang.annotation.Annotation)
  • javax.persistence.AssociationOverrides (implements java.lang.annotation.Annotation)
  • javax.persistence.AttributeOverride (implements java.lang.annotation.Annotation)
  • javax.persistence.AttributeOverrides (implements java.lang.annotation.Annotation)
  • javax.persistence.Basic (implements java.lang.annotation.Annotation)
  • javax.persistence.Column (implements java.lang.annotation.Annotation)
  • javax.persistence.ColumnResult (implements java.lang.annotation.Annotation)
  • javax.persistence.DiscriminatorColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.DiscriminatorValue (implements java.lang.annotation.Annotation)
  • javax.persistence.Embeddable (implements java.lang.annotation.Annotation)
  • javax.persistence.Embedded (implements java.lang.annotation.Annotation)
  • javax.persistence.EmbeddedId (implements java.lang.annotation.Annotation)
  • javax.persistence.Entity (implements java.lang.annotation.Annotation)
  • javax.persistence.EntityListeners (implements java.lang.annotation.Annotation)
  • javax.persistence.EntityResult (implements java.lang.annotation.Annotation)
  • javax.persistence.Enumerated (implements java.lang.annotation.Annotation)
  • javax.persistence.ExcludeDefaultListeners (implements java.lang.annotation.Annotation)
  • javax.persistence.ExcludeSuperclassListeners (implements java.lang.annotation.Annotation)
  • javax.persistence.FieldResult (implements java.lang.annotation.Annotation)
  • javax.persistence.GeneratedValue (implements java.lang.annotation.Annotation)
  • javax.persistence.Id (implements java.lang.annotation.Annotation)
  • javax.persistence.IdClass (implements java.lang.annotation.Annotation)
  • javax.persistence.Inheritance (implements java.lang.annotation.Annotation)
  • javax.persistence.JoinColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.JoinColumns (implements java.lang.annotation.Annotation)
  • javax.persistence.JoinTable (implements java.lang.annotation.Annotation)
  • javax.persistence.Lob (implements java.lang.annotation.Annotation)
  • javax.persistence.ManyToMany (implements java.lang.annotation.Annotation)
  • javax.persistence.ManyToOne (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKey (implements java.lang.annotation.Annotation)
  • javax.persistence.MappedSuperclass (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedNativeQueries (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedNativeQuery (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedQueries (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedQuery (implements java.lang.annotation.Annotation)
  • javax.persistence.OneToMany (implements java.lang.annotation.Annotation)
  • javax.persistence.OneToOne (implements java.lang.annotation.Annotation)
  • javax.persistence.OrderBy (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceContext (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceContexts (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceProperty (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceUnit (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceUnits (implements java.lang.annotation.Annotation)
  • javax.persistence.PostLoad (implements java.lang.annotation.Annotation)
  • javax.persistence.PostPersist (implements java.lang.annotation.Annotation)
  • javax.persistence.PostRemove (implements java.lang.annotation.Annotation)
  • javax.persistence.PostUpdate (implements java.lang.annotation.Annotation)
  • javax.persistence.PrePersist (implements java.lang.annotation.Annotation)
  • javax.persistence.PreRemove (implements java.lang.annotation.Annotation)
  • javax.persistence.PreUpdate (implements java.lang.annotation.Annotation)
  • javax.persistence.PrimaryKeyJoinColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.PrimaryKeyJoinColumns (implements java.lang.annotation.Annotation)
  • javax.persistence.QueryHint (implements java.lang.annotation.Annotation)
  • javax.persistence.SecondaryTable (implements java.lang.annotation.Annotation)
  • javax.persistence.SecondaryTables (implements java.lang.annotation.Annotation)
  • javax.persistence.SequenceGenerator (implements java.lang.annotation.Annotation)
  • javax.persistence.SqlResultSetMapping (implements java.lang.annotation.Annotation)
  • javax.persistence.SqlResultSetMappings (implements java.lang.annotation.Annotation)
  • javax.persistence.Table (implements java.lang.annotation.Annotation)
  • javax.persistence.TableGenerator (implements java.lang.annotation.Annotation)
  • javax.persistence.Temporal (implements java.lang.annotation.Annotation)
  • javax.persistence.Transient (implements java.lang.annotation.Annotation)
  • javax.persistence.UniqueConstraint (implements java.lang.annotation.Annotation)
  • javax.persistence.Version (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.ejb.TransactionAttributeType
      • javax.ejb.TransactionManagementType
      • javax.annotation.Resource.AuthenticationType
      • javax.xml.ws.Service.Mode
      • javax.xml.ws.handler.MessageContext.Scope
      • javax.xml.bind.annotation.XmlAccessOrder
      • javax.xml.bind.annotation.XmlAccessType
      • javax.xml.bind.annotation.XmlNsForm
      • javax.jws.WebParam.Mode
      • javax.jws.soap.SOAPBinding.Style
      • javax.jws.soap.SOAPBinding.Use
      • javax.jws.soap.SOAPBinding.ParameterStyle
      • javax.persistence.CascadeType
      • javax.persistence.DiscriminatorType
      • javax.persistence.EnumType
      • javax.persistence.FetchType
      • javax.persistence.FlushModeType
      • javax.persistence.GenerationType
      • javax.persistence.InheritanceType
      • javax.persistence.LockModeType
      • javax.persistence.PersistenceContextType
      • javax.persistence.TemporalType
      • javax.persistence.spi.PersistenceUnitTransactionType
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Index

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

A

AbortProcessingException - Exception in javax.faces.event
An exception that may be thrown by event listeners to terminate the processing of the current event.
AbortProcessingException() - Constructor for exception javax.faces.event.AbortProcessingException
Construct a new exception with no detail message or root cause.
AbortProcessingException(String) - Constructor for exception javax.faces.event.AbortProcessingException
Construct a new exception with the specified detail message and no root cause.
AbortProcessingException(Throwable) - Constructor for exception javax.faces.event.AbortProcessingException
Construct a new exception with the specified root cause.
AbortProcessingException(String, Throwable) - Constructor for exception javax.faces.event.AbortProcessingException
Construct a new exception with the specified detail message and root cause.
AbstractMarshallerImpl - Class in javax.xml.bind.helpers
Partial default Marshaller implementation.
AbstractMarshallerImpl() - Constructor for class javax.xml.bind.helpers.AbstractMarshallerImpl
AbstractUnmarshallerImpl - Class in javax.xml.bind.helpers
Partial default Unmarshaller implementation.
AbstractUnmarshallerImpl() - Constructor for class javax.xml.bind.helpers.AbstractUnmarshallerImpl
accept(XMLEvent) - Method in interface javax.xml.stream.EventFilter
Tests whether this event is part of this stream.
accept(XMLStreamReader) - Method in interface javax.xml.stream.StreamFilter
Tests whether the current state is part of this stream.
AccessLocalException - Exception in javax.ejb
An AccessLocalException is thrown to indicate that the caller does not have permission to call the method.
AccessLocalException() - Constructor for exception javax.ejb.AccessLocalException
Constructs an AccessLocalException with no detail message.
AccessLocalException(String) - Constructor for exception javax.ejb.AccessLocalException
Constructs an AccessLocalException with the specified detail message.
AccessLocalException(String, Exception) - Constructor for exception javax.ejb.AccessLocalException
Constructs an AccessLocalException with the specified detail message and a nested exception.
acknowledge() - Method in interface javax.jms.Message
Acknowledges all consumed messages of the session of this consumed message.
ActionEvent - Class in javax.faces.event
An ActionEvent represents the activation of a user interface component (such as a UICommand).
ActionEvent(UIComponent) - Constructor for class javax.faces.event.ActionEvent
Construct a new event object from the specified source component and action command.
ActionListener - Interface in javax.faces.event
A listener interface for receiving ActionEvents.
ActionSource - Interface in javax.faces.component
ActionSource is an interface that may be implemented by any concrete UIComponent that wishes to be a source of ActionEvents, including the ability to invoke application actions via the default ActionListener mechanism.
ActionSource2 - Interface in javax.faces.component
ActionSource2 extends ActionSource and provides a JavaBeans property analogous to the "action" property on ActionSource.
ActionType - Class in javax.enterprise.deploy.shared
Class ActionTypes defines enumeration values for the J2EE DeploymentStatus actions.
ActionType(int) - Constructor for class javax.enterprise.deploy.shared.ActionType
Construct a new enumeration value with the given integer value.
ActivationConfigProperty - Annotation Type in javax.ejb
ActivationDataFlavor - Class in javax.activation
The ActivationDataFlavor class is a special subclass of java.awt.datatransfer.DataFlavor.
ActivationDataFlavor(Class, String, String) - Constructor for class javax.activation.ActivationDataFlavor
Construct a DataFlavor that represents an arbitrary Java object.
ActivationDataFlavor(Class, String) - Constructor for class javax.activation.ActivationDataFlavor
Construct a DataFlavor that represents a MimeType.
ActivationDataFlavor(String, String) - Constructor for class javax.activation.ActivationDataFlavor
Construct a DataFlavor that represents a MimeType.
ActivationSpec - Interface in javax.resource.spi
This interface serves as a marker.
add(ELResolver) - Method in class javax.el.CompositeELResolver
Adds the given resolver to the list of component resolvers.
add(FetchProfile.Item) - Method in class javax.mail.FetchProfile
Add the given special item as one of the attributes to be prefetched.
add(String) - Method in class javax.mail.FetchProfile
Add the specified header-field to the list of attributes to be prefetched.
add(Flags.Flag) - Method in class javax.mail.Flags
Add the specified system flag to this Flags object.
add(String) - Method in class javax.mail.Flags
Add the specified user flag to this Flags object.
add(Flags) - Method in class javax.mail.Flags
Add all the flags in the given Flags object to this Flags object.
add(XMLEvent) - Method in interface javax.xml.stream.util.XMLEventConsumer
This method adds an event to the consumer.
add(XMLEvent) - Method in interface javax.xml.stream.XMLEventWriter
Add an event to the output stream Adding a START_ELEMENT will open a new namespace scope that will be closed when the corresponding END_ELEMENT is written.
add(XMLEventReader) - Method in interface javax.xml.stream.XMLEventWriter
Adds an entire stream to an output stream, calls next() on the inputStream argument until hasNext() returns false This should be treated as a convenience method that will perform the following loop over all the events in an event reader and call add on each event.
addActionListener(ActionListener) - Method in interface javax.faces.component.ActionSource
Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.
addActionListener(ActionListener) - Method in class javax.faces.component.UICommand
addAssociation(Association) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified Association to use this object as source.
addAssociations(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified Associations to use this object as source.
addAttachmentPart(AttachmentPart) - Method in class javax.xml.soap.SOAPMessage
Adds the given AttachmentPart object to this SOAPMessage object.
addAttribute(Name, String) - Method in interface javax.xml.soap.SOAPElement
Adds an attribute with the specified name and value to this SOAPElement object.
addAttribute(QName, String) - Method in interface javax.xml.soap.SOAPElement
Adds an attribute with the specified name and value to this SOAPElement object.
addBody() - Method in interface javax.xml.soap.SOAPEnvelope
Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
addBodyElement(Name) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
addBodyElement(QName) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
addBodyPart(BodyPart) - Method in class javax.mail.Multipart
Adds a Part to the multipart.
addBodyPart(BodyPart, int) - Method in class javax.mail.Multipart
Adds a BodyPart at position index.
addChild(UIComponent) - Method in class javax.faces.webapp.UIComponentClassicTagBase
addChild(UIComponent) - Method in class javax.faces.webapp.UIComponentTagBase
Add the component identifier of the specified UIComponent to the list of component identifiers created or located by nested UIComponentTags processing this request.
addChildConcept(Concept) - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Adds a child Concept.
addChildConcept(Concept) - Method in interface javax.xml.registry.infomodel.Concept
Adds a child Concept.
addChildConcepts(Collection) - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Adds a Collection of Concept children.
addChildConcepts(Collection) - Method in interface javax.xml.registry.infomodel.Concept
Adds a Collection of Concept children.
addChildElement(Name) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
addChildElement(QName) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
addChildElement(String) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
addChildElement(String, String) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
addChildElement(String, String, String) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
addChildElement(SOAPElement) - Method in interface javax.xml.soap.SOAPElement
Add a SOAPElement as a child of this SOAPElement instance.
addChildOrganization(Organization) - Method in interface javax.xml.registry.infomodel.Organization
Adds a child Organization.
addChildOrganizations(Collection) - Method in interface javax.xml.registry.infomodel.Organization
Adds a Collection of Organization children.
addClassification(Classification) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified Classification to this object.
addClassifications(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified Classifications to this object.
addComponent(String, String) - Method in class javax.faces.application.Application
Register a new mapping of component type to the name of the corresponding UIComponent class.
addConnectionEventListener(ConnectionEventListener) - Method in interface javax.resource.spi.ManagedConnection
Adds a connection event listener to the ManagedConnection instance.
addConnectionListener(ConnectionListener) - Method in class javax.mail.Folder
Add a listener for Connection events on this Folder.
addConnectionListener(ConnectionListener) - Method in class javax.mail.Service
Add a listener for Connection events on this service.
addConverter(String, String) - Method in class javax.faces.application.Application
Register a new mapping of converter id to the name of the corresponding Converter class.
addConverter(Class, String) - Method in class javax.faces.application.Application
Register a new converter class that is capable of performing conversions for the specified target class.
addCookie(Cookie) - Method in interface javax.servlet.http.HttpServletResponse
Adds the specified cookie to the response.
addCookie(Cookie) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to call addCookie(Cookie cookie) on the wrapped response object.
addDataModelListener(DataModelListener) - Method in class javax.faces.model.DataModel
Add a new DataModelListener to the set interested in notifications from this DataModel.
addDateHeader(String, long) - Method in interface javax.servlet.http.HttpServletResponse
Adds a response header with the given name and date-value.
addDateHeader(String, long) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to call addDateHeader(String name, long date) on the wrapped response object.
addDetail() - Method in interface javax.xml.soap.SOAPFault
Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
addDetailEntry(Name) - Method in interface javax.xml.soap.Detail
Creates a new DetailEntry object with the given name and adds it to this Detail object.
addDetailEntry(QName) - Method in interface javax.xml.soap.Detail
Creates a new DetailEntry object with the given QName and adds it to this Detail object.
addDocument(Document) - Method in interface javax.xml.soap.SOAPBody
Adds the root node of the DOM Document to this SOAPBody object.
ADDED - Static variable in class javax.mail.event.MessageCountEvent
The messages were added to their folder
addELContextListener(ELContextListener) - Method in class javax.faces.application.Application
Provide a way for Faces applications to register an ELContextListener that will be notified on creation of ELContext instances.
addELContextListener(ELContextListener) - Method in interface javax.servlet.jsp.JspApplicationContext
Registers a ELContextListeners so that context objects can be added whenever a new ELContext is created.
addELResolver(ELResolver) - Method in class javax.faces.application.Application
Cause an the argument resolver to be added to the resolver chain as specified in section 5.5.1 of the JavaServer Faces Specification.
addELResolver(ELResolver) - Method in interface javax.servlet.jsp.JspApplicationContext
Adds an ELResolver to affect the way EL variables and properties are resolved for EL expressions appearing in JSP pages and tag files.
addExternalIdentifier(ExternalIdentifier) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified ExternalIdentifier as an external identifier to this object.
addExternalIdentifiers(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified ExternalIdentifiers as an external identifiers to this object.
addExternalLink(ExternalLink) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified ExternalLink to this object.
addExternalLinks(Collection) - Method in interface javax.xml.registry.infomodel.RegistryObject
Adds specified ExternalLinks to this object.
addFacesListener(FacesListener) - Method in class javax.faces.component.UIComponent
Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent.
addFacesListener(FacesListener) - Method in class javax.faces.component.UIComponentBase
Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent.
addFacet(String) - Method in class javax.faces.webapp.UIComponentClassicTagBase
addFacet(String) - Method in class javax.faces.webapp.UIComponentTagBase
Add the facet name of the specified facet to the list of facet names created or located by nested UIComponentTags processing this request.
addFault() - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(Name, String, Locale) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(QName, String, Locale) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(Name, String) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(QName, String) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFaultReasonText(String, Locale) - Method in interface javax.xml.soap.SOAPFault
Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale.
addFolderListener(FolderListener) - Method in class javax.mail.Folder
Add a listener for Folder events on this Folder.
addFolderListener(FolderListener) - Method in class javax.mail.Store
Add a listener for Folder events on any Folder object obtained from this Store.
addFrom(Address[]) - Method in class javax.mail.internet.MimeMessage
Add the specified addresses to the existing "From" field.
addFrom(Address[]) - Method in class javax.mail.Message
Add these addresses to the existing "From" attribute
addHeader(String, String) - Method in class javax.mail.internet.InternetHeaders
Add a header with the specified name and value to the header list.
addHeader(String, String) - Method in class javax.mail.internet.MimeBodyPart
Add this value to the existing values for this header_name.
addHeader(String, String) - Method in class javax.mail.internet.MimeMessage
Add this value to the existing values for this header_name.
addHeader(String, String) - Method in interface javax.mail.Part
Add this value to the existing values for this header_name.
addHeader(String, String) - Method in interface javax.servlet.http.HttpServletResponse
Adds a response header with the given name and value.
addHeader(String, String) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to return addHeader(String name, String value) on the wrapped response object.
addHeader(String, String) - Method in class javax.xml.soap.MimeHeaders
Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.
addHeader() - Method in interface javax.xml.soap.SOAPEnvelope
Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
addHeaderElement(Name) - Method in interface javax.xml.soap.SOAPHeader
Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
addHeaderElement(QName) - Method in interface javax.xml.soap.SOAPHeader
Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
addHeaderLine(String) - Method in class javax.mail.internet.InternetHeaders
Add an RFC822 header line to the header store.
addHeaderLine(String) - Method in class javax.mail.internet.MimeBodyPart
Add a header line to this body part
addHeaderLine(String) - Method in class javax.mail.internet.MimeMessage
Add a raw RFC 822 header-line.
addHeaderLine(String) - Method in interface javax.mail.internet.MimePart
Add a raw RFC822 header-line.
addIntHeader(String, int) - Method in interface javax.servlet.http.HttpServletResponse
Adds a response header with the given name and integer value.
addIntHeader(String, int) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to call addIntHeader(String name, int value) on the wrapped response object.
addLifecycle(String, Lifecycle) - Method in class javax.faces.lifecycle.LifecycleFactory
Register a new Lifecycle instance, associated with the specified lifecycleId, to be supported by this LifecycleFactory.
addLocalizedString(LocalizedString) - Method in interface javax.xml.registry.infomodel.InternationalString
Adds a LocalizedString to this object.
addLocalizedStrings(Collection) - Method in interface javax.xml.registry.infomodel.InternationalString
Adds many LocalizedStrings to this object.
addMailcap(String) - Method in class javax.activation.MailcapCommandMap
Add entries to the registry.
addMessage(String, FacesMessage) - Method in class javax.faces.context.FacesContext
Append a FacesMessage to the set of messages associated with the specified client identifier, if clientId is not null.
addMessageChangedListener(MessageChangedListener) - Method in class javax.mail.Folder
Add a listener for MessageChanged events on this Folder.
addMessageCountListener(MessageCountListener) - Method in class javax.mail.Folder
Add a listener for MessageCount events on this Folder.
addMimeHeader(String, String) - Method in class javax.xml.soap.AttachmentPart
Adds a MIME header with the specified name and value to this AttachmentPart object.
addMimeHeader(String, String) - Method in class javax.xml.soap.SOAPPart
Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object.
addMimeTypes(String) - Method in class javax.activation.MimetypesFileTypeMap
Prepend the MIME type values to the registry.
addMtomAttachment(DataHandler, String, String) - Method in class javax.xml.bind.attachment.AttachmentMarshaller
Consider MIME content data for optimized binary storage as an attachment.
addMtomAttachment(byte[], int, int, String, String, String) - Method in class javax.xml.bind.attachment.AttachmentMarshaller
Consider binary data for optimized binary storage as an attachment.
addNamespaceDeclaration(String, String) - Method in interface javax.xml.soap.SOAPElement
Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management.j2ee.ListenerRegistration
Add a listener to a registered managed object.
addNotUnderstoodHeaderElement(QName) - Method in interface javax.xml.soap.SOAPHeader
Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
addParameter(String, QName, ParameterMode) - Method in interface javax.xml.rpc.Call
Adds a parameter type and mode for a specific operation.
addParameter(String, QName, Class, ParameterMode) - Method in interface javax.xml.rpc.Call
Adds a parameter type and mode for a specific operation.
addPhaseListener(PhaseListener) - Method in class javax.faces.component.UIViewRoot
addPhaseListener(PhaseListener) - Method in class javax.faces.lifecycle.Lifecycle
Register a new PhaseListener instance that is interested in being notified before and after the processing for standard phases of the request processing lifecycle.
addPort(QName, String, String) - Method in class javax.xml.ws.Service
Creates a new port for the service.
addPort(QName, String, String) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a new port for the service.
addProgressListener(ProgressListener) - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
Add a listener to receive Progress events on deployment actions.
addPropertyChangeListener(PropertyChangeListener) - Method in interface javax.enterprise.deploy.spi.DConfigBean
Register a property listener for this bean.
addProvider(Provider) - Method in class javax.mail.Session
Add a provider to the session.
addRecipient(Message.RecipientType, Address) - Method in class javax.mail.Message
Add this recipient address to the existing ones of the given type.
addRecipients(Message.RecipientType, Address[]) - Method in class javax.mail.internet.MimeMessage
Add the given addresses to the specified recipient type.
addRecipients(Message.RecipientType, String) - Method in class javax.mail.internet.MimeMessage
Add the given addresses to the specified recipient type.
addRecipients(Message.RecipientType, Address[]) - Method in class javax.mail.Message
Add these recipient addresses to the existing ones of the given type.
addRegistryObject(RegistryObject) - Method in interface javax.xml.registry.infomodel.RegistryPackage
Adds a child RegistryObject as member.
addRegistryObjects(Collection) - Method in interface javax.xml.registry.infomodel.RegistryPackage
Adds a Collection of RegistryObject children as members.
addRenderer(String, String, Renderer) - Method in class javax.faces.render.RenderKit
Register the specified Renderer instance, associated with the specified component family and rendererType, to the set of Renderers registered with this RenderKit, replacing any previously registered Renderer for this combination of identifiers.
addRenderKit(String, RenderKit) - Method in class javax.faces.render.RenderKitFactory
Register the specified RenderKit instance, associated with the specified renderKitId, to be supported by this RenderKitFactory, replacing any previously registered RenderKit for this identifier.
Address - Class in javax.mail
This abstract class models the addresses in a message.
Address() - Constructor for class javax.mail.Address
address - Variable in class javax.mail.internet.InternetAddress
address - Variable in class javax.mail.search.AddressTerm
The address.
ADDRESS_LINES_SLOT - Static variable in interface javax.xml.registry.infomodel.Slot
Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.
AddressException - Exception in javax.mail.internet
The exception thrown when a wrongly formatted address is encountered.
AddressException() - Constructor for exception javax.mail.internet.AddressException
Constructs an AddressException with no detail message.
AddressException(String) - Constructor for exception javax.mail.internet.AddressException
Constructs an AddressException with the specified detail message.
AddressException(String, String) - Constructor for exception javax.mail.internet.AddressException
Constructs an AddressException with the specified detail message and reference info.
AddressException(String, String, int) - Constructor for exception javax.mail.internet.AddressException
Constructs an AddressException with the specified detail message and reference info.
AddressStringTerm - Class in javax.mail.search
This abstract class implements string comparisons for Message addresses.
AddressStringTerm(String) - Constructor for class javax.mail.search.AddressStringTerm
Constructor.
AddressTerm - Class in javax.mail.search
This class implements Message Address comparisons.
AddressTerm(Address) - Constructor for class javax.mail.search.AddressTerm
addService(Service) - Method in interface javax.xml.registry.infomodel.Organization
Adds a child Service.
addServiceBinding(ServiceBinding) - Method in interface javax.xml.registry.infomodel.Service
Adds a child ServiceBinding.
addServiceBindings(Collection) - Method in interface javax.xml.registry.infomodel.Service
Adds a Collection of ServiceBinding children.
addServices(Collection) - Method in interface javax.xml.registry.infomodel.Organization
Adds a Collection of Service children.
addSlot(Slot) - Method in interface javax.xml.registry.infomodel.ExtensibleObject
Adds a Slot to this object.
addSlots(Collection) - Method in interface javax.xml.registry.infomodel.ExtensibleObject
Adds more Slots to this object.
addSpecificationLink(SpecificationLink) - Method in interface javax.xml.registry.infomodel.ServiceBinding
Adds a child SpecificationLink.
addSpecificationLinks(Collection) - Method in interface javax.xml.registry.infomodel.ServiceBinding
Adds a Collection of SpecificationLink children.
addStoreListener(StoreListener) - Method in class javax.mail.Store
Add a listener for StoreEvents on this Store.
addSwaRefAttachment(DataHandler) - Method in class javax.xml.bind.attachment.AttachmentMarshaller
Add MIME data as an attachment and return attachment's content-id, cid.
addTextNode(String) - Method in interface javax.xml.soap.SOAPElement
Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
addToExcludedPolicy(PermissionCollection) - Method in interface javax.security.jacc.PolicyConfiguration
Used to add excluded policy statements to this PolicyConfiguration.
addToExcludedPolicy(Permission) - Method in interface javax.security.jacc.PolicyConfiguration
Used to add a single excluded policy statement to this PolicyConfiguration.
addToRole(String, PermissionCollection) - Method in interface javax.security.jacc.PolicyConfiguration
Used to add permissions to a named role in this PolicyConfiguration.
addToRole(String, Permission) - Method in interface javax.security.jacc.PolicyConfiguration
Used to add a single permission to a named role in this PolicyConfiguration.
addToUncheckedPolicy(PermissionCollection) - Method in interface javax.security.jacc.PolicyConfiguration
Used to add unchecked policy statements to this PolicyConfiguration.
addToUncheckedPolicy(Permission) - Method in interface javax.security.jacc.PolicyConfiguration
Used to add a single unchecked policy statement to this PolicyConfiguration.
addTransformer(ClassTransformer) - Method in interface javax.persistence.spi.PersistenceUnitInfo
Add a transformer supplied by the provider that will be called for every new class definition or class redefinition that gets loaded by the loader returned by the PersistenceUnitInfo.getClassLoader() method.
addTransportListener(TransportListener) - Method in class javax.mail.Transport
Add a listener for Transport events.
addUpgradeHeaderElement(Iterator) - Method in interface javax.xml.soap.SOAPHeader
Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.
addUpgradeHeaderElement(String[]) - Method in interface javax.xml.soap.SOAPHeader
Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.
addUpgradeHeaderElement(String) - Method in interface javax.xml.soap.SOAPHeader
Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.
addUser(User) - Method in interface javax.xml.registry.infomodel.Organization
Adds a User.
addUsers(Collection) - Method in interface javax.xml.registry.infomodel.Organization
Adds a Collection of Users.
addValidator(String, String) - Method in class javax.faces.application.Application
Register a new mapping of validator id to the name of the corresponding Validator class.
addValidator(Validator) - Method in interface javax.faces.component.EditableValueHolder
Add a Validator instance to the set associated with this component.
addValidator(Validator) - Method in class javax.faces.component.UIInput
Add a Validator instance to the set associated with this UIInput.
addValueChangeListener(ValueChangeListener) - Method in interface javax.faces.component.EditableValueHolder
Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.
addValueChangeListener(ValueChangeListener) - Method in class javax.faces.component.UIInput
Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.
addVerbatimAfterComponent(UIComponentClassicTagBase, UIComponent, UIComponent) - Method in class javax.faces.webapp.UIComponentClassicTagBase
Add verbatim as a sibling of component in component in the parent's child list.
addVerbatimBeforeComponent(UIComponentClassicTagBase, UIComponent, UIComponent) - Method in class javax.faces.webapp.UIComponentClassicTagBase
Add verbatim as a sibling of component in component in the parent's child list.
addXpathListener(String, XpathListener) - Method in interface javax.enterprise.deploy.model.DDBean
Register a listener for a specific XPath.
addXpathListener(ModuleType, String, XpathListener) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Register a listener for changes in XPath that are related to this deployableObject.
afterBegin() - Method in interface javax.ejb.SessionSynchronization
The afterBegin method notifies a session Bean instance that a new transaction has started, and that the subsequent business methods on the instance will be invoked in the context of the transaction.
afterCompletion(boolean) - Method in interface javax.ejb.SessionSynchronization
The afterCompletion method notifies a session Bean instance that a transaction commit protocol has completed, and tells the instance whether the transaction has been committed or rolled back.
afterCompletion(int) - Method in interface javax.transaction.Synchronization
This method is called by the transaction manager after the transaction is committed or rolled back.
afterDelivery() - Method in interface javax.resource.spi.endpoint.MessageEndpoint
This is called by a resource adapter after a message is delivered.
afterMarshal(Object) - Method in class javax.xml.bind.Marshaller.Listener

Callback method invoked after marshalling source to XML.

afterPhase(PhaseEvent) - Method in interface javax.faces.event.PhaseListener
Handle a notification that the processing for a particular phase has just been completed.
afterUnmarshal(Object, Object) - Method in class javax.xml.bind.Unmarshaller.Listener

Callback method invoked after unmarshalling XML data into target.

ALERT - Static variable in class javax.mail.event.StoreEvent
Indicates that this message is an ALERT.
ALL - Static variable in class javax.mail.internet.MimeUtility
allocate(XMLStreamReader) - Method in interface javax.xml.stream.util.XMLEventAllocator
This method allocates an event given the current state of the XMLStreamReader.
allocate(XMLStreamReader, XMLEventConsumer) - Method in interface javax.xml.stream.util.XMLEventAllocator
This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in.
allocateConnection(ManagedConnectionFactory, ConnectionRequestInfo) - Method in interface javax.resource.spi.ConnectionManager
The method allocateConnection gets called by the resource adapter's connection factory instance.
ALLOCATOR - Static variable in class javax.xml.stream.XMLInputFactory
The property used to set/get the implementation of the allocator
AND_ALL_KEYS - Static variable in interface javax.xml.registry.FindQualifier
AndTerm - Class in javax.mail.search
This class implements the logical AND operator on individual SearchTerms.
AndTerm(SearchTerm, SearchTerm) - Constructor for class javax.mail.search.AndTerm
Constructor that takes two terms.
AndTerm(SearchTerm[]) - Constructor for class javax.mail.search.AndTerm
Constructor that takes an array of SearchTerms.
ANSWERED - Static variable in class javax.mail.Flags.Flag
This message has been answered.
ANY_PHASE - Static variable in class javax.faces.event.PhaseId
Identifier that indicates an interest in events, no matter which request processing phase is being performed.
appendFaultSubcode(QName) - Method in interface javax.xml.soap.SOAPFault
Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault.
appendMessages(Message[]) - Method in class javax.mail.Folder
Append given Messages to this folder.
Application - Class in javax.faces.application
Application represents a per-web-application singleton object where applications based on JavaServer Faces (or implementations wishing to provide extended functionality) can register application-wide singletons that provide functionality required by JavaServer Faces.
Application() - Constructor for class javax.faces.application.Application
APPLICATION - Static variable in class javax.servlet.jsp.PageContext
Name used to store ServletContext in PageContext name table.
APPLICATION_FACTORY - Static variable in class javax.faces.FactoryFinder
The property name for the ApplicationFactory class name.
APPLICATION_SCOPE - Static variable in class javax.servlet.jsp.PageContext
Application scope: named reference remains available in the ServletContext until it is reclaimed.
ApplicationException - Annotation Type in javax.ejb
Applied to an exception to denote that it is an application exception and should be reported to the client directly(i.e., unwrapped).
ApplicationFactory - Class in javax.faces.application
ApplicationFactory is a factory object that creates (if needed) and returns Application instances.
ApplicationFactory() - Constructor for class javax.faces.application.ApplicationFactory
ApplicationServerInternalException - Exception in javax.resource.spi
An ApplicationServerInternalException is thrown by an application server to indicate error conditions specific to an application server.
ApplicationServerInternalException() - Constructor for exception javax.resource.spi.ApplicationServerInternalException
Constructs a new instance with null as its detail message.
ApplicationServerInternalException(String) - Constructor for exception javax.resource.spi.ApplicationServerInternalException
Constructs a new instance with the specified detail message.
ApplicationServerInternalException(Throwable) - Constructor for exception javax.resource.spi.ApplicationServerInternalException
Constructs a new throwable with the specified cause.
ApplicationServerInternalException(String, Throwable) - Constructor for exception javax.resource.spi.ApplicationServerInternalException
Constructs a new throwable with the specified detail message and cause.
ApplicationServerInternalException(String, String) - Constructor for exception javax.resource.spi.ApplicationServerInternalException
Constructs a new throwable with the specified detail message and an error code.
APPLY_REQUEST_VALUES - Static variable in class javax.faces.event.PhaseId
Identifier that indicates an interest in events queued for the Apply Request Values phase of the request processing lifecycle.
AroundInvoke - Annotation Type in javax.interceptor
ArrayDataModel - Class in javax.faces.model
ArrayDataModel is a convenience implementation of DataModel that wraps an array of Java objects.
ArrayDataModel() - Constructor for class javax.faces.model.ArrayDataModel
Construct a new ArrayDataModel with no specified wrapped data.
ArrayDataModel(Object[]) - Constructor for class javax.faces.model.ArrayDataModel
Construct a new ArrayDataModel wrapping the specified array.
ArrayELResolver - Class in javax.el
Defines property resolution behavior on arrays.
ArrayELResolver() - Constructor for class javax.el.ArrayELResolver
Creates a new read/write ArrayELResolver.
ArrayELResolver(boolean) - Constructor for class javax.el.ArrayELResolver
Creates a new ArrayELResolver whose read-only status is determined by the given parameter.
asCharacters() - Method in interface javax.xml.stream.events.XMLEvent
Returns this event as Characters, may result in a class cast exception if this event is not Characters.
asEndElement() - Method in interface javax.xml.stream.events.XMLEvent
Returns this event as an end element event, may result in a class cast exception if this event is not a end element.
associateConnection(Object, ManagedConnectionFactory, ConnectionRequestInfo) - Method in interface javax.resource.spi.LazyAssociatableConnectionManager
This method is called by a resource adapter (that is capable of lazy connection association optimization) in order to lazily associate a connection object with a ManagedConnection instance.
associateConnection(Object) - Method in interface javax.resource.spi.ManagedConnection
Used by the container to change the association of an application-level connection handle with a ManagedConneciton instance.
Association - Interface in javax.xml.registry.infomodel
A RegistryObject instance may be associated with zero or more RegistryObject instances.
ASSOCIATION - Static variable in interface javax.xml.registry.LifeCycleManager
AssociationOverride - Annotation Type in javax.persistence
This annotation is used to override a many-to-one or one-to-one mapping of property or field for an entity relationship.
AssociationOverrides - Annotation Type in javax.persistence
This annotation is used to override mappings of multiple many-to-one or one-to-one relationship properties or fields.
asStartElement() - Method in interface javax.xml.stream.events.XMLEvent
Returns this event as a start element event, may result in a class cast exception if this event is not a start element.
AsyncHandler<T> - Interface in javax.xml.ws
The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.
AT_BEGIN - Static variable in class javax.servlet.jsp.tagext.VariableInfo
Scope information that scripting variable is visible after start tag.
AT_END - Static variable in class javax.servlet.jsp.tagext.VariableInfo
Scope information that scripting variable is visible after end tag.
ATOM - Static variable in class javax.mail.internet.HeaderTokenizer.Token
Token type indicating an ATOM.
attachFile(File) - Method in class javax.mail.internet.MimeBodyPart
Use the specified file to provide the data for this part.
attachFile(String) - Method in class javax.mail.internet.MimeBodyPart
Use the specified file to provide the data for this part.
ATTACHMENT - Static variable in interface javax.mail.Part
This part should be presented as an attachment.
AttachmentMarshaller - Class in javax.xml.bind.attachment
Enable JAXB marshalling to optimize storage of binary data.
AttachmentMarshaller() - Constructor for class javax.xml.bind.attachment.AttachmentMarshaller
AttachmentPart - Class in javax.xml.soap
A single attachment to a SOAPMessage object.
AttachmentPart() - Constructor for class javax.xml.soap.AttachmentPart
AttachmentUnmarshaller - Class in javax.xml.bind.attachment
Enables JAXB unmarshalling of a root document containing optimized binary data formats.
AttachmentUnmarshaller() - Constructor for class javax.xml.bind.attachment.AttachmentUnmarshaller
Attribute - Interface in javax.xml.stream.events
An interface that contains information about an attribute.
ATTRIBUTE - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is an attribute
attributeAdded(HttpSessionBindingEvent) - Method in interface javax.servlet.http.HttpSessionAttributeListener
Notification that an attribute has been added to a session.
attributeAdded(ServletContextAttributeEvent) - Method in interface javax.servlet.ServletContextAttributeListener
Notification that a new attribute was added to the servlet context.
attributeAdded(ServletRequestAttributeEvent) - Method in interface javax.servlet.ServletRequestAttributeListener
Notification that a new attribute was added to the servlet request.
AttributeOverride - Annotation Type in javax.persistence
The AttributeOverride annotation is used to override the mapping of a Basic (whether explicit or default) property or field or Id property or field.
AttributeOverrides - Annotation Type in javax.persistence
Is used to override mappings of multiple properties or fields.
attributeRemoved(HttpSessionBindingEvent) - Method in interface javax.servlet.http.HttpSessionAttributeListener
Notification that an attribute has been removed from a session.
attributeRemoved(ServletContextAttributeEvent) - Method in interface javax.servlet.ServletContextAttributeListener
Notification that an existing attribute has been removed from the servlet context.
attributeRemoved(ServletRequestAttributeEvent) - Method in interface javax.servlet.ServletRequestAttributeListener
Notification that an existing attribute has been removed from the servlet request.
attributeReplaced(HttpSessionBindingEvent) - Method in interface javax.servlet.http.HttpSessionAttributeListener
Notification that an attribute has been replaced in a session.
attributeReplaced(ServletContextAttributeEvent) - Method in interface javax.servlet.ServletContextAttributeListener
Notification that an attribute on the servlet context has been replaced.
attributeReplaced(ServletRequestAttributeEvent) - Method in interface javax.servlet.ServletRequestAttributeListener
Notification that an attribute was replaced on the servlet request.
AttributeTag - Class in javax.faces.webapp
Deprecated. The Faces implementation must now provide the implementation for this class.
AttributeTag() - Constructor for class javax.faces.webapp.AttributeTag
Deprecated.
AUDITABLE_EVENT - Static variable in interface javax.xml.registry.LifeCycleManager
AuditableEvent - Interface in javax.xml.registry.infomodel
AuditableEvent instances provide a long term record of events that effect a change of state in a RegistryObject.
AuthenticationFailedException - Exception in javax.mail
This exception is thrown when the connect method on a Store or Transport object fails due to an authentication failure (e.g., bad user name or password).
AuthenticationFailedException() - Constructor for exception javax.mail.AuthenticationFailedException
Constructor
AuthenticationFailedException(String) - Constructor for exception javax.mail.AuthenticationFailedException
Constructor
Authenticator - Class in javax.mail
The class Authenticator represents an object that knows how to obtain authentication for a network connection.
Authenticator() - Constructor for class javax.mail.Authenticator
AUTHORIZED_NAME_SLOT - Static variable in interface javax.xml.registry.infomodel.Slot
Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.
AUTO_ACKNOWLEDGE - Static variable in interface javax.jms.Session
With this acknowledgment mode, the session automatically acknowledges a client's receipt of a message either when the session has successfully returned from a call to receive or when the message listener the session has called to process the message successfully returns.
autoFlush - Variable in class javax.servlet.jsp.JspWriter
Whether the JspWriter is autoflushing.
available() - Method in class javax.mail.util.SharedFileInputStream
Returns the number of bytes that can be read from this input stream without blocking.

B

Basic - Annotation Type in javax.persistence
The Basic annotation is the simplest type of mapping to a database column.
BASIC_AUTH - Static variable in class javax.faces.context.ExternalContext
String identifier for BASIC authentication.
BASIC_AUTH - Static variable in interface javax.servlet.http.HttpServletRequest
String identifier for Basic authentication.
BCC - Static variable in class javax.mail.Message.RecipientType
The "Bcc" (blind carbon copy) recipients.
BEAN_ADDED - Static variable in class javax.enterprise.deploy.model.XpathEvent
Adding a DDBean
BEAN_CHANGED - Static variable in class javax.enterprise.deploy.model.XpathEvent
Changing a DDBean
BEAN_REMOVED - Static variable in class javax.enterprise.deploy.model.XpathEvent
Removing a DDBean
BeanELResolver - Class in javax.el
Defines property resolution behavior on objects using the JavaBeans component architecture.
BeanELResolver() - Constructor for class javax.el.BeanELResolver
Creates a new read/write BeanELResolver.
BeanELResolver(boolean) - Constructor for class javax.el.BeanELResolver
Creates a new BeanELResolver whose read-only status is determined by the given parameter.
BeanELResolver.BeanProperties - Class in javax.el
BeanELResolver.BeanProperties(Class<?>) - Constructor for class javax.el.BeanELResolver.BeanProperties
BeanELResolver.BeanProperty - Class in javax.el
BeanELResolver.BeanProperty(Class<?>, PropertyDescriptor) - Constructor for class javax.el.BeanELResolver.BeanProperty
BeanNotFoundException - Exception in javax.enterprise.deploy.spi.exceptions
This exception is to report that the bean is not a child of the parent bean.
BeanNotFoundException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.BeanNotFoundException
Creates an new BeanNotFoundException object.
beforeCompletion() - Method in interface javax.ejb.SessionSynchronization
The beforeCompletion method notifies a session Bean instance that a transaction is about to be committed.
beforeCompletion() - Method in interface javax.transaction.Synchronization
The beforeCompletion method is called by the transaction manager prior to the start of the two-phase transaction commit process.
beforeDelivery(Method) - Method in interface javax.resource.spi.endpoint.MessageEndpoint
This is called by a resource adapter before a message is delivered.
beforeMarshal(Object) - Method in class javax.xml.bind.Marshaller.Listener

Callback method invoked before marshalling from source to XML.

beforePhase(PhaseEvent) - Method in interface javax.faces.event.PhaseListener
Handle a notification that the processing for a particular phase of the request processing lifecycle is about to begin.
beforeUnmarshal(Object, Object) - Method in class javax.xml.bind.Unmarshaller.Listener

Callback method invoked before unmarshalling into target.

begin() - Method in interface javax.persistence.EntityTransaction
Start the resource transaction.
begin() - Method in interface javax.resource.cci.LocalTransaction
Begins a local transaction on an EIS instance.
begin() - Method in interface javax.resource.spi.LocalTransaction
Begin a local transaction
begin() - Method in interface javax.transaction.TransactionManager
Create a new transaction and associate it with the current thread.
begin() - Method in interface javax.transaction.UserTransaction
Create a new transaction and associate it with the current thread.
BigDecimalConverter - Class in javax.faces.convert
Converter implementation for java.math.BigDecimal values.
BigDecimalConverter() - Constructor for class javax.faces.convert.BigDecimalConverter
BigDecimalHolder - Class in javax.xml.rpc.holders
BigDecimalHolder() - Constructor for class javax.xml.rpc.holders.BigDecimalHolder
BigDecimalHolder(BigDecimal) - Constructor for class javax.xml.rpc.holders.BigDecimalHolder
BIGINTEGER_ID - Static variable in class javax.faces.convert.BigIntegerConverter
The message identifier of the FacesMessage to be created if the conversion to BigInteger fails.
BigIntegerConverter - Class in javax.faces.convert
Converter implementation for java.math.BigInteger values.
BigIntegerConverter() - Constructor for class javax.faces.convert.BigIntegerConverter
BigIntegerHolder - Class in javax.xml.rpc.holders
BigIntegerHolder() - Constructor for class javax.xml.rpc.holders.BigIntegerHolder
BigIntegerHolder(BigInteger) - Constructor for class javax.xml.rpc.holders.BigIntegerHolder
Binder<XmlNode> - Class in javax.xml.bind
Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.
Binder() - Constructor for class javax.xml.bind.Binder
Binding - Interface in javax.xml.ws
The Binding interface is the base interface for JAX-WS protocol bindings.
BindingProvider - Interface in javax.xml.ws
The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.
bindings - Variable in class javax.faces.component.UIComponent
BindingType - Annotation Type in javax.xml.ws
The BindingType annotation is used to specify the binding to use for a web service endpoint implementation class.
BODY_CONTENT_EMPTY - Static variable in class javax.servlet.jsp.tagext.TagInfo
Static constant for getBodyContent() when it is empty.
BODY_CONTENT_JSP - Static variable in class javax.servlet.jsp.tagext.TagInfo
Static constant for getBodyContent() when it is JSP.
BODY_CONTENT_SCRIPTLESS - Static variable in class javax.servlet.jsp.tagext.TagInfo
Static constant for getBodyContent() when it is scriptless.
BODY_CONTENT_TAG_DEPENDENT - Static variable in class javax.servlet.jsp.tagext.TagInfo
Static constant for getBodyContent() when it is Tag dependent.
bodyContent - Variable in class javax.faces.webapp.UIComponentClassicTagBase
The bodyContent for this tag handler.
BodyContent - Class in javax.servlet.jsp.tagext
An encapsulation of the evaluation of the body of an action so it is available to a tag handler.
BodyContent(JspWriter) - Constructor for class javax.servlet.jsp.tagext.BodyContent
Protected constructor.
bodyContent - Variable in class javax.servlet.jsp.tagext.BodyTagSupport
The current BodyContent for this BodyTag.
BodyPart - Class in javax.mail
This class models a Part that is contained within a Multipart.
BodyPart() - Constructor for class javax.mail.BodyPart
BodyTag - Interface in javax.servlet.jsp.tagext
The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.
BodyTagSupport - Class in javax.servlet.jsp.tagext
A base class for defining tag handlers implementing BodyTag.
BodyTagSupport() - Constructor for class javax.servlet.jsp.tagext.BodyTagSupport
Default constructor, all subclasses are required to only define a public constructor with the same signature, and to call the superclass constructor.
BodyTerm - Class in javax.mail.search
This class implements searches on a Message Body.
BodyTerm(String) - Constructor for class javax.mail.search.BodyTerm
Constructor
BOOLEAN_ID - Static variable in class javax.faces.convert.BooleanConverter
The message identifier of the FacesMessage to be created if the conversion to Boolean fails.
BooleanConverter - Class in javax.faces.convert
Converter implementation for java.lang.Boolean (and boolean primitive) values.
BooleanConverter() - Constructor for class javax.faces.convert.BooleanConverter
BooleanHolder - Class in javax.xml.rpc.holders
BooleanHolder() - Constructor for class javax.xml.rpc.holders.BooleanHolder
BooleanHolder(boolean) - Constructor for class javax.xml.rpc.holders.BooleanHolder
BooleanWrapperHolder - Class in javax.xml.rpc.holders
BooleanWrapperHolder() - Constructor for class javax.xml.rpc.holders.BooleanWrapperHolder
BooleanWrapperHolder(Boolean) - Constructor for class javax.xml.rpc.holders.BooleanWrapperHolder
BootstrapContext - Interface in javax.resource.spi
This provides a mechanism to pass a bootstrap context to a resource adapter instance when it is bootstrapped.
BoundaryStatistic - Interface in javax.management.j2ee.statistics
Specifies standard measurements of the upper and lower limits of the value of an attribute.
BoundedRangeStatistic - Interface in javax.management.j2ee.statistics
The BoundedRangeStatistic model aggregates the attributes of RangeStatistic and BoundaryStatistic and provides standard measurements of a range that has fixed limits.
broadcast(FacesEvent) - Method in class javax.faces.component.UICommand
In addition to to the default UIComponent.broadcast(javax.faces.event.FacesEvent) processing, pass the ActionEvent being broadcast to the method referenced by actionListener (if any), and to the default ActionListener registered on the Application.
broadcast(FacesEvent) - Method in class javax.faces.component.UIComponent
Broadcast the specified FacesEvent to all registered event listeners who have expressed an interest in events of this type.
broadcast(FacesEvent) - Method in class javax.faces.component.UIComponentBase
broadcast(FacesEvent) - Method in class javax.faces.component.UIData
Override the default UIComponentBase.broadcast(javax.faces.event.FacesEvent) processing to unwrap any wrapped FacesEvent and reset the current row index, before the event is actually broadcast.
bufferSize - Variable in class javax.servlet.jsp.JspWriter
The size of the buffer used by the JspWriter.
bufpos - Variable in class javax.mail.util.SharedFileInputStream
The file offset that corresponds to the first byte in the read buffer.
bufsize - Variable in class javax.mail.util.SharedFileInputStream
The normal size of the read buffer.
BulkResponse - Interface in javax.xml.registry
Contains the response of a method in the API that performs a bulk operation and returns a bulk response.
BusinessLifeCycleManager - Interface in javax.xml.registry
The BusinessLifeCycleManager interface, which is exposed by the Registry Service, implements the life cycle management functionality of the Registry as part of a business level API.
BusinessQueryManager - Interface in javax.xml.registry
The BusinessQueryManager interface, which is exposed by the Registry Service, implements the business style query interface.
BYTE_ID - Static variable in class javax.faces.convert.ByteConverter
The message identifier of the FacesMessage to be created if the conversion to Byte fails.
ByteArrayDataSource - Class in javax.mail.util
A DataSource backed by a byte array.
ByteArrayDataSource(InputStream, String) - Constructor for class javax.mail.util.ByteArrayDataSource
Create a ByteArrayDataSource with data from the specified InputStream and with the specified MIME type.
ByteArrayDataSource(byte[], String) - Constructor for class javax.mail.util.ByteArrayDataSource
Create a ByteArrayDataSource with data from the specified byte array and with the specified MIME type.
ByteArrayDataSource(String, String) - Constructor for class javax.mail.util.ByteArrayDataSource
Create a ByteArrayDataSource with data from the specified String and with the specified MIME type.
ByteArrayHolder - Class in javax.xml.rpc.holders
ByteArrayHolder() - Constructor for class javax.xml.rpc.holders.ByteArrayHolder
ByteArrayHolder(byte[]) - Constructor for class javax.xml.rpc.holders.ByteArrayHolder
ByteConverter - Class in javax.faces.convert
Converter implementation for java.lang.Byte (and byte primitive) values.
ByteConverter() - Constructor for class javax.faces.convert.ByteConverter
ByteHolder - Class in javax.xml.rpc.holders
ByteHolder() - Constructor for class javax.xml.rpc.holders.ByteHolder
ByteHolder(byte) - Constructor for class javax.xml.rpc.holders.ByteHolder
BytesMessage - Interface in javax.jms
A BytesMessage object is used to send a message containing a stream of uninterpreted bytes.
ByteWrapperHolder - Class in javax.xml.rpc.holders
ByteWrapperHolder() - Constructor for class javax.xml.rpc.holders.ByteWrapperHolder
ByteWrapperHolder(Byte) - Constructor for class javax.xml.rpc.holders.ByteWrapperHolder

C

calculateCharacterEncoding(FacesContext) - Method in class javax.faces.application.ViewHandler
Returns the correct character encoding to be used for this request.
calculateCharacterEncoding(FacesContext) - Method in class javax.faces.application.ViewHandlerWrapper
The default behavior of this method is to call ViewHandler.calculateCharacterEncoding(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
calculateLocale(FacesContext) - Method in class javax.faces.application.ViewHandler
Returns an appropriate Locale to use for this and subsequent requests for the current client.
calculateLocale(FacesContext) - Method in class javax.faces.application.ViewHandlerWrapper
The default behavior of this method is to call ViewHandler.calculateLocale(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
calculateRenderKitId(FacesContext) - Method in class javax.faces.application.ViewHandler
Return an appropriate renderKitId for this and subsequent requests from the current client.
calculateRenderKitId(FacesContext) - Method in class javax.faces.application.ViewHandlerWrapper
The default behavior of this method is to call ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
CalendarHolder - Class in javax.xml.rpc.holders
CalendarHolder() - Constructor for class javax.xml.rpc.holders.CalendarHolder
CalendarHolder(Calendar) - Constructor for class javax.xml.rpc.holders.CalendarHolder
Call - Interface in javax.xml.rpc
The javax.xml.rpc.Call interface provides support for the dynamic invocation of a service endpoint.
call(SOAPMessage, Object) - Method in class javax.xml.soap.SOAPConnection
Sends the given message to the specified endpoint and blocks until it has returned the response.
canBeRequestTime() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
Whether this attribute has been specified in the TLD as rtexprvalue.
cancel() - Method in interface javax.ejb.Timer
Cause the timer and all its associated expiration notifications to be cancelled.
CANCEL - Static variable in class javax.enterprise.deploy.shared.ActionType
A cancel operation is being preformed on the DeploymentManager action command.
cancel() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
(optional) A cancel request on an in-process operation stops all further processing of the operation and returns the environment to it original state before the operation was executed.
CapabilityProfile - Interface in javax.xml.registry
Provides information about the capabilities of a JAXR provider.
CAR - Static variable in class javax.enterprise.deploy.shared.ModuleType
The module is an Client Application archive.
CascadeType - Enum in javax.persistence
Defines the set of cascadable operations that are propagated to the associated entity.
CASE_SENSITIVE_MATCH - Static variable in interface javax.xml.registry.FindQualifier
cause - Variable in exception javax.xml.registry.JAXRException
CC - Static variable in class javax.mail.Message.RecipientType
The "Cc" (carbon copy) recipients.
CDATA - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is a CDATA section
CHARACTER_ENCODING_KEY - Static variable in class javax.faces.application.ViewHandler
The key, in the session's attribute set, under which the response character encoding may be stored and retrieved.
CHARACTER_ID - Static variable in class javax.faces.convert.CharacterConverter
The message identifier of the FacesMessage to be created if the conversion to Character fails.
CHARACTER_SET_ENCODING - Static variable in class javax.xml.soap.SOAPMessage
Specifies the character type encoding for the SOAP Message.
CharacterConverter - Class in javax.faces.convert
Converter implementation for java.lang.Character (and char primitive) values.
CharacterConverter() - Constructor for class javax.faces.convert.CharacterConverter
Characters - Interface in javax.xml.stream.events
This describes the interface to Characters events.
CHARACTERS - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is characters
Classification - Interface in javax.xml.registry.infomodel
The Classification interface is used to classify RegistryObject instances.
CLASSIFICATION - Static variable in interface javax.xml.registry.LifeCycleManager
CLASSIFICATION_SCHEME - Static variable in interface javax.xml.registry.LifeCycleManager
ClassificationScheme - Interface in javax.xml.registry.infomodel
A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances.
ClassTransformer - Interface in javax.persistence.spi
A persistence provider supplies an instance of this interface to the PersistenceUnitInfo.addTransformer method.
cleanup() - Method in interface javax.resource.spi.ManagedConnection
Application server calls this method to force any cleanup on the ManagedConnection instance.
clear() - Method in interface javax.persistence.EntityManager
Clear the persistence context, causing all managed entities to become detached.
clear() - Method in class javax.servlet.jsp.JspWriter
Clear the contents of the buffer.
clear() - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry
Removes all registered TypeMappings and encodingStyleURIs from this TypeMappingRegistry.
clearBody() - Method in interface javax.jms.Message
Clears out the message body.
clearBody() - Method in class javax.servlet.jsp.tagext.BodyContent
Clear the body without throwing any exceptions.
clearBuffer() - Method in class javax.servlet.jsp.JspWriter
Clears the current contents of the buffer.
clearContent() - Method in class javax.xml.soap.AttachmentPart
Clears out the content of this AttachmentPart object.
clearProperties() - Method in interface javax.jms.Message
Clears a message's properties.
clearWarnings() - Method in interface javax.resource.cci.Interaction
Clears all the warning reported by this Interaction instance.
CLIENT_ACKNOWLEDGE - Static variable in interface javax.jms.Session
With this acknowledgment mode, the client acknowledges a consumed message by calling the message's acknowledge method.
CLIENT_CERT_AUTH - Static variable in class javax.faces.context.ExternalContext
String identifier for CLIENT_CERT authentication.
CLIENT_CERT_AUTH - Static variable in interface javax.servlet.http.HttpServletRequest
String identifier for Client Certificate authentication.
ClientConfiguration - Interface in javax.enterprise.deploy.spi.status
The ClientConfiguration object installs, configures and executes an Application Client.
ClientExecuteException - Exception in javax.enterprise.deploy.spi.exceptions
This exception reports errors in setting up an application client for execution.
ClientExecuteException() - Constructor for exception javax.enterprise.deploy.spi.exceptions.ClientExecuteException
Creates new ClientExecuteException without detail message.
ClientExecuteException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.ClientExecuteException
Constructs an ClientExecuteException with the specified detail message.
clone() - Method in class javax.mail.Flags
Returns a clone of this Flags object.
clone() - Method in class javax.mail.internet.InternetAddress
Return a copy of this InternetAddress object.
clone() - Method in interface javax.resource.cci.Record
Creates and returns a copy of this object.
clone() - Method in class javax.servlet.http.Cookie
Overrides the standard java.lang.Object.clone method to return a copy of this cookie.
cloneWithWriter(Writer) - Method in class javax.faces.context.ResponseWriter
Create and return a new instance of this ResponseWriter, using the specified Writer as the output destination.
cloneWithWriter(Writer) - Method in class javax.faces.context.ResponseWriterWrapper
The default behavior of this method is to call ResponseWriter.cloneWithWriter(java.io.Writer) on the wrapped ResponseWriter object.
close() - Method in class javax.faces.context.ResponseWriterWrapper
The default behavior of this method is to call Writer.close() on the wrapped ResponseWriter object.
close() - Method in interface javax.jms.Connection
Closes the connection.
close() - Method in interface javax.jms.ConnectionConsumer
Closes the connection consumer.
close() - Method in interface javax.jms.MessageConsumer
Closes the message consumer.
close() - Method in interface javax.jms.MessageProducer
Closes the message producer.
close() - Method in interface javax.jms.QueueBrowser
Closes the QueueBrowser.
close() - Method in class javax.jms.QueueRequestor
Closes the QueueRequestor and its session.
close() - Method in interface javax.jms.Session
Closes the session.
close() - Method in class javax.jms.TopicRequestor
Closes the TopicRequestor and its session.
close(boolean) - Method in class javax.mail.Folder
Close this Folder.
close() - Method in class javax.mail.Service
Close this service and terminate its connection.
close() - Method in class javax.mail.util.SharedFileInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in interface javax.persistence.EntityManager
Close an application-managed EntityManager.
close() - Method in interface javax.persistence.EntityManagerFactory
Close the factory, releasing any resources that it holds.
close() - Method in interface javax.resource.cci.Connection
Initiates close of the connection handle at the application level.
close() - Method in interface javax.resource.cci.Interaction
Closes the current Interaction and release all the resources held for this instance by the resource adapter.
close() - Method in class javax.servlet.jsp.JspWriter
Close the stream, flushing it first.
close() - Method in interface javax.xml.registry.Connection
Closes a Connection when it is no longer needed.
close() - Method in class javax.xml.soap.SOAPConnection
Closes this SOAPConnection object.
close() - Method in class javax.xml.stream.util.EventReaderDelegate
close() - Method in class javax.xml.stream.util.StreamReaderDelegate
close() - Method in interface javax.xml.stream.XMLEventReader
Frees any resources associated with this Reader.
close() - Method in interface javax.xml.stream.XMLEventWriter
Frees any resources associated with this stream
close() - Method in interface javax.xml.stream.XMLStreamReader
Frees any resources associated with this Reader.
close() - Method in interface javax.xml.stream.XMLStreamWriter
Close this writer and free any resources associated with the writer.
close(MessageContext) - Method in interface javax.xml.ws.handler.Handler
Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime disptaching a message, fault or exception.
closed(ConnectionEvent) - Method in class javax.mail.event.ConnectionAdapter
CLOSED - Static variable in class javax.mail.event.ConnectionEvent
A connection was closed.
closed(ConnectionEvent) - Method in interface javax.mail.event.ConnectionListener
Invoked when a Store/Folder/Transport is closed.
coerceToType(Object, Class<?>) - Method in class javax.el.ExpressionFactory
Coerces an object to a specific type according to the EL type conversion rules.
CollapsedStringAdapter - Class in javax.xml.bind.annotation.adapters
Built-in XmlAdapter to handle xs:token and its derived types.
CollapsedStringAdapter() - Constructor for class javax.xml.bind.annotation.adapters.CollapsedStringAdapter
Column - Annotation Type in javax.persistence
Is used to specify a mapped column for a persistent property or field.
ColumnResult - Annotation Type in javax.persistence
References name of a column in the SELECT clause of a SQL query - i.e., column alias, if applicable.
COMBINE_CLASSIFICATIONS - Static variable in interface javax.xml.registry.FindQualifier
Maps to UDDI combineCategoryBags.
CommandInfo - Class in javax.activation
The CommandInfo class is used by CommandMap implementations to describe the results of command requests.
CommandInfo(String, String) - Constructor for class javax.activation.CommandInfo
The Constructor for CommandInfo.
CommandMap - Class in javax.activation
The CommandMap class provides an interface to a registry of command objects available in the system.
CommandMap() - Constructor for class javax.activation.CommandMap
CommandObject - Interface in javax.activation
JavaBeans components that are Activation Framework aware implement this interface to find out which command verb they're being asked to perform, and to obtain the DataHandler representing the data they should operate on.
CommandType - Class in javax.enterprise.deploy.shared
Class CommandTypes defines enumeration values for the DeploymentStatus object.
CommandType(int) - Constructor for class javax.enterprise.deploy.shared.CommandType
Construct a new enumeration value with the given integer value.
COMMENT - Static variable in class javax.mail.internet.HeaderTokenizer.Token
Token type indicating a comment.
Comment - Interface in javax.xml.stream.events
An interface for comment events
COMMENT - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is a comment
CommException - Exception in javax.resource.spi
This indicates errors related to failed or interrupted communication with an EIS instance.
CommException() - Constructor for exception javax.resource.spi.CommException
Constructs a new instance with null as its detail message.
CommException(String) - Constructor for exception javax.resource.spi.CommException
Constructs a new instance with the specified detail message.
CommException(Throwable) - Constructor for exception javax.resource.spi.CommException
Constructs a new throwable with the specified cause.
CommException(String, Throwable) - Constructor for exception javax.resource.spi.CommException
Constructs a new throwable with the specified detail message and cause.
CommException(String, String) - Constructor for exception javax.resource.spi.CommException
Constructs a new throwable with the specified detail message and an error code.
commit() - Method in interface javax.jms.Session
Commits all messages done in this transaction and releases any locks currently held.
commit() - Method in interface javax.jms.XASession
Throws a TransactionInProgressException, since it should not be called for an XASession object.
commit() - Method in interface javax.persistence.EntityTransaction
Commit the current transaction, writing any unflushed changes to the database.
commit() - Method in interface javax.resource.cci.LocalTransaction
Commits the current local transaction and release all locks held by the underlying EIS instance.
commit() - Method in interface javax.resource.spi.LocalTransaction
Commit a local transaction
commit(Xid, boolean) - Method in interface javax.resource.spi.XATerminator
Commits the global transaction specified by xid.
commit() - Method in interface javax.security.jacc.PolicyConfiguration
This method is used to set to "inService" the state of the policy context whose interface is this PolicyConfiguration Object.
commit() - Method in interface javax.transaction.Transaction
Complete the transaction represented by this Transaction object.
commit() - Method in interface javax.transaction.TransactionManager
Complete the transaction associated with the current thread.
commit() - Method in interface javax.transaction.UserTransaction
Complete the transaction associated with the current thread.
commit(Xid, boolean) - Method in interface javax.transaction.xa.XAResource
Commits the global transaction specified by xid.
compareTo(Object) - Method in class javax.faces.application.FacesMessage.Severity
Compare this FacesMessage.Severity instance to the specified one.
compareTo(Object) - Method in class javax.faces.event.PhaseId
Compare this PhaseId instance to the specified one.
compareValues(Object, Object) - Method in class javax.faces.component.UIInput
Return true if the new value is different from the previous value.
compareValues(Object, Object) - Method in class javax.faces.component.UISelectMany
Return true if the new value is different from the previous value.
comparison - Variable in class javax.mail.search.ComparisonTerm
The comparison.
ComparisonTerm - Class in javax.mail.search
This class models the comparison operator.
ComparisonTerm() - Constructor for class javax.mail.search.ComparisonTerm
COMPLETED - Static variable in class javax.enterprise.deploy.shared.StateType
The action operation has completed normally.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UIColumn
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UICommand
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UIData
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UIForm
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UIGraphic
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UIInput
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UIMessage
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UIMessages
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UINamingContainer
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UIOutput
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UIPanel
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UIParameter
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UISelectBoolean
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UISelectItem
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UISelectItems
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UISelectMany
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UISelectOne
The standard component family for this component.
COMPONENT_FAMILY - Static variable in class javax.faces.component.UIViewRoot
The standard component family for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlColumn
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlCommandButton
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlCommandLink
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlDataTable
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlForm
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlGraphicImage
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlInputHidden
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlInputSecret
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlInputText
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlInputTextarea
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlMessage
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlMessages
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlOutputFormat
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlOutputLabel
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlOutputLink
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlOutputText
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlPanelGrid
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlPanelGroup
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectBooleanCheckbox
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectManyCheckbox
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectManyListbox
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectManyMenu
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectOneListbox
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectOneMenu
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.html.HtmlSelectOneRadio
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UIColumn
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UICommand
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UIData
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UIForm
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UIGraphic
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UIInput
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UIMessage
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UIMessages
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UINamingContainer
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UIOutput
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UIPanel
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UIParameter
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UISelectBoolean
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UISelectItem
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UISelectItems
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UISelectMany
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UISelectOne
The standard component type for this component.
COMPONENT_TYPE - Static variable in class javax.faces.component.UIViewRoot
The standard component type for this component.
CompositeELResolver - Class in javax.el
Maintains an ordered composite list of child ELResolvers.
CompositeELResolver() - Constructor for class javax.el.CompositeELResolver
Concept - Interface in javax.xml.registry.infomodel
The Concept interface is used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy.
CONCEPT - Static variable in interface javax.xml.registry.LifeCycleManager
ConcurrentAccessException - Exception in javax.ejb
A ConcurrentAccessException indicates that the client has attempted an invocation on a stateful session bean while another invocation is in progress.
ConcurrentAccessException() - Constructor for exception javax.ejb.ConcurrentAccessException
Constructs an ConcurrentAccessException with no detail message.
ConcurrentAccessException(String) - Constructor for exception javax.ejb.ConcurrentAccessException
Constructs an ConcurrentAccessException with the specified detailed message.
ConcurrentAccessException(String, Exception) - Constructor for exception javax.ejb.ConcurrentAccessException
Constructs an ConcurrentAccessException with the specified detail message and a nested exception.
CONFIG - Static variable in class javax.servlet.jsp.PageContext
Name used to store ServletConfig in PageContext name table.
CONFIG_FILES_ATTR - Static variable in class javax.faces.webapp.FacesServlet
Context initialization parameter name for a comma delimited list of context-relative resource paths (in addition to /WEB-INF/faces-config.xml which is loaded automatically if it exists) containing JavaServer Faces configuration information.
ConfigurationException - Exception in javax.enterprise.deploy.spi.exceptions
This exception reports errors in generating a configuration bean.
ConfigurationException() - Constructor for exception javax.enterprise.deploy.spi.exceptions.ConfigurationException
Creates new ConfigurationException without detail message.
ConfigurationException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.ConfigurationException
Constructs an ConfigurationException with the specified detail message.
confirmAssociation(Association) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Confirms this Association by the User associated with the caller.
connect() - Method in class javax.mail.Service
A generic connect method that takes no parameters.
connect(String, String, String) - Method in class javax.mail.Service
Connect to the specified address.
connect(String, String) - Method in class javax.mail.Service
Connect to the current host using the specified username and password.
connect(String, int, String, String) - Method in class javax.mail.Service
Similar to connect(host, user, password) except a specific port can be specified.
Connection - Interface in javax.jms
A Connection object is a client's active connection to its JMS provider.
Connection - Interface in javax.resource.cci
A Connection represents an application-level handle that is used by a client to access the underlying physical connection.
Connection - Interface in javax.xml.registry
This class represents a connection between a JAXR client and a JAXR provider.
CONNECTION_CLOSED - Static variable in class javax.resource.spi.ConnectionEvent
Event notification that an application component has closed the connection
CONNECTION_ERROR_OCCURRED - Static variable in class javax.resource.spi.ConnectionEvent
Event notification that an error occurred on the connection.
ConnectionAdapter - Class in javax.mail.event
The adapter which receives connection events.
ConnectionAdapter() - Constructor for class javax.mail.event.ConnectionAdapter
connectionClosed(ConnectionEvent) - Method in interface javax.resource.spi.ConnectionEventListener
Notifies that an application component has closed the connection.
ConnectionConsumer - Interface in javax.jms
For application servers, Connection objects provide a special facility for creating a ConnectionConsumer (optional).
connectionErrorOccurred(ConnectionEvent) - Method in interface javax.resource.spi.ConnectionEventListener
Notifies a connection related error.
ConnectionEvent - Class in javax.mail.event
This class models Connection events.
ConnectionEvent(Object, int) - Constructor for class javax.mail.event.ConnectionEvent
Constructor
ConnectionEvent - Class in javax.resource.spi
The ConnectionEvent class provides information about the source of a connection related event.A ConnectionEvent instance contains the following information: Type of the connection event ManagedConnection instance that generated the connection event.
ConnectionEvent(ManagedConnection, int) - Constructor for class javax.resource.spi.ConnectionEvent
Construct a ConnectionEvent object.
ConnectionEvent(ManagedConnection, int, Exception) - Constructor for class javax.resource.spi.ConnectionEvent
Construct a ConnectionEvent object.
ConnectionEventListener - Interface in javax.resource.spi
The ConnectionEventListener interface provides an event callback mechanism to enable an application server to receive notifications from a ManagedConnection instance.
ConnectionFactory - Interface in javax.jms
A ConnectionFactory object encapsulates a set of connection configuration parameters that has been defined by an administrator.
ConnectionFactory - Interface in javax.resource.cci
ConnectionFactory provides an interface for getting connection to an EIS instance.
ConnectionFactory - Class in javax.xml.registry
This is the abstract base class for factory classes for creating a JAXR connection.
ConnectionFactory() - Constructor for class javax.xml.registry.ConnectionFactory
ConnectionListener - Interface in javax.mail.event
This is the Listener interface for Connection events.
ConnectionManager - Interface in javax.resource.spi
ConnectionManager interface provides a hook for the resource adapter to pass a connection request to the application server.
ConnectionMetaData - Interface in javax.jms
A ConnectionMetaData object provides information describing the Connection object.
ConnectionMetaData - Interface in javax.resource.cci
The interface ConnectionMetaData provides information about an EIS instance connected through a Connection instance.
ConnectionRequestInfo - Interface in javax.resource.spi
The ConnectionRequestInfo interface enables a resource adapter to pass its own request specific data structure across the connection request flow.
ConnectionSpec - Interface in javax.resource.cci
ConnectionSpec is used by an application component to pass connection request-specific properties to the ConnectionFactory.
contains(FetchProfile.Item) - Method in class javax.mail.FetchProfile
Returns true if the fetch profile contains given special item.
contains(String) - Method in class javax.mail.FetchProfile
Returns true if the fetch profile contains given header name.
contains(Flags.Flag) - Method in class javax.mail.Flags
Check whether the specified system flag is present in this Flags object.
contains(String) - Method in class javax.mail.Flags
Check whether the specified user flag is present in this Flags object.
contains(Flags) - Method in class javax.mail.Flags
Check whether all the flags in the specified Flags object are present in this Flags object.
contains(Object) - Method in interface javax.persistence.EntityManager
Check if the instance belongs to the current persistence context.
containsHeader(String) - Method in interface javax.servlet.http.HttpServletResponse
Returns a boolean indicating whether the named response header has already been set.
containsHeader(String) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to call containsHeader(String name) on the wrapped response object.
containsProperty(String) - Method in interface javax.xml.rpc.handler.MessageContext
Returns true if the MessageContext contains a property with the specified name.
content - Variable in class javax.mail.internet.MimeBodyPart
Byte array that holds the bytes of the content of this Part.
content - Variable in class javax.mail.internet.MimeMessage
Byte array that holds the bytes of this Message's content.
CONTENT_INFO - Static variable in class javax.mail.FetchProfile.Item
This item is for fetching information about the content of the message.
ContentDisposition - Class in javax.mail.internet
This class represents a MIME ContentDisposition value.
ContentDisposition() - Constructor for class javax.mail.internet.ContentDisposition
No-arg Constructor.
ContentDisposition(String, ParameterList) - Constructor for class javax.mail.internet.ContentDisposition
Constructor.
ContentDisposition(String) - Constructor for class javax.mail.internet.ContentDisposition
Constructor that takes a ContentDisposition string.
contentStream - Variable in class javax.mail.internet.MimeBodyPart
If the data for this body part was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this body part.
contentStream - Variable in class javax.mail.internet.MimeMessage
If the data for this message was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this message.
ContentType - Class in javax.mail.internet
This class represents a MIME ContentType value.
ContentType() - Constructor for class javax.mail.internet.ContentType
No-arg Constructor.
ContentType(String, String, ParameterList) - Constructor for class javax.mail.internet.ContentType
Constructor.
ContentType(String) - Constructor for class javax.mail.internet.ContentType
Constructor that takes a Content-Type string.
contentType - Variable in class javax.mail.Multipart
This field specifies the content-type of this multipart object.
ContextCallback - Interface in javax.faces.component
A simple callback interace that enables taking action on a specific UIComponent (either facet or child) in the view while preserving any contextual state for that component instance in the view.
contextCreated(ELContextEvent) - Method in interface javax.el.ELContextListener
Invoked when a new ELContext has been created.
contextDestroyed(ServletContextEvent) - Method in interface javax.servlet.ServletContextListener
Notification that the servlet context is about to be shut down.
contextInitialized(ServletContextEvent) - Method in interface javax.servlet.ServletContextListener
Notification that the web application initialization process is starting.
CONVERSION_MESSAGE_ID - Static variable in class javax.faces.component.UIInput
The message identifier of the FacesMessage to be created if a conversion error occurs, and neither the page author nor the ConverterException provides a message.
convertClientId(FacesContext, String) - Method in class javax.faces.render.Renderer
Convert the component generated client id to a form suitable for transmission to the client.
Converter - Interface in javax.faces.convert
Converter is an interface describing a Java class that can perform Object-to-String and String-to-Object conversions between model data objects and a String representation of those objects that is suitable for rendering.
CONVERTER_ID - Static variable in class javax.faces.convert.BigDecimalConverter
The standard converter id for this converter.
CONVERTER_ID - Static variable in class javax.faces.convert.BigIntegerConverter
The standard converter id for this converter.
CONVERTER_ID - Static variable in class javax.faces.convert.BooleanConverter
The standard converter id for this converter.
CONVERTER_ID - Static variable in class javax.faces.convert.ByteConverter
The standard converter id for this converter.
CONVERTER_ID - Static variable in class javax.faces.convert.CharacterConverter
The standard converter id for this converter.
CONVERTER_ID - Static variable in class javax.faces.convert.DateTimeConverter
The standard converter id for this converter.
CONVERTER_ID - Static variable in class javax.faces.convert.DoubleConverter
The standard converter id for this converter.
CONVERTER_ID - Static variable in class javax.faces.convert.EnumConverter
The standard converter id for this converter.
CONVERTER_ID - Static variable in class javax.faces.convert.FloatConverter
The standard converter id for this converter.
CONVERTER_ID - Static variable in class javax.faces.convert.IntegerConverter
The standard converter id for this converter.
CONVERTER_ID - Static variable in class javax.faces.convert.LongConverter
The standard converter id for this converter.
CONVERTER_ID - Static variable in class javax.faces.convert.NumberConverter
The standard converter id for this converter.
CONVERTER_ID - Static variable in class javax.faces.convert.ShortConverter
The standard converter id for this converter.
ConverterELTag - Class in javax.faces.webapp
ConverterELTag is a base class for all JSP custom actions that create and register a Converter instance on the ValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentClassicTagBase.
ConverterELTag() - Constructor for class javax.faces.webapp.ConverterELTag
ConverterException - Exception in javax.faces.convert
ConverterException is an exception thrown by the getAsObject() or getAsText() method of a Converter, to indicate that the requested conversion cannot be performed.
ConverterException() - Constructor for exception javax.faces.convert.ConverterException
Construct a new exception with no detail message or root cause.
ConverterException(String) - Constructor for exception javax.faces.convert.ConverterException
Construct a new exception with the specified detail message and no root cause.
ConverterException(Throwable) - Constructor for exception javax.faces.convert.ConverterException
Construct a new exception with the specified root cause.
ConverterException(String, Throwable) - Constructor for exception javax.faces.convert.ConverterException
Construct a new exception with the specified detail message and root cause.
ConverterException(FacesMessage) - Constructor for exception javax.faces.convert.ConverterException
Construct a new exception with the specified detail message and no root cause.
ConverterException(FacesMessage, Throwable) - Constructor for exception javax.faces.convert.ConverterException
Construct a new exception with the specified detail message and root cause.
ConverterTag - Class in javax.faces.webapp
Deprecated. This has been partially replaced by ConverterELTag. The remainder of the functionality, namely, the binding facility and the implementation of the ConverterTag.createConverter() method, is now an implementation detail.
ConverterTag() - Constructor for class javax.faces.webapp.ConverterTag
Deprecated.
Cookie - Class in javax.servlet.http
Creates a cookie, a small amount of information sent by a servlet to a Web browser, saved by the browser, and later sent back to the server.
Cookie(String, String) - Constructor for class javax.servlet.http.Cookie
Constructs a cookie with a specified name and value.
copyMessages(Message[], Folder) - Method in class javax.mail.Folder
Copy the specified Messages from this Folder into another Folder.
countAttachments() - Method in class javax.xml.soap.SOAPMessage
Gets a count of the number of attachments in this message.
CountStatistic - Interface in javax.management.j2ee.statistics
Specifies standard count measurements.
create(int) - Method in class javax.mail.Folder
Create this folder on the Store.
create() - Method in interface javax.management.j2ee.ManagementHome
Creates an MEJB session object which provides access to the J2EE Management Model
create(Name) - Method in class javax.xml.soap.SOAPElementFactory
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
create(String) - Method in class javax.xml.soap.SOAPElementFactory
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
create(String, String, String) - Method in class javax.xml.soap.SOAPElementFactory
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
create(Object) - Static method in class javax.xml.ws.Endpoint
Creates an endpoint with the specified implementor object.
create(String, Object) - Static method in class javax.xml.ws.Endpoint
Creates an endpoint with the specified binding type and implementor object.
create(URL, QName) - Static method in class javax.xml.ws.Service
Create a Service instance.
create(QName) - Static method in class javax.xml.ws.Service
Create a Service instance.
createAndPublishEndpoint(String, Object) - Method in class javax.xml.ws.spi.Provider
Creates and publishes an endpoint object with the specified address and implementation object.
createAssociation(RegistryObject, Concept) - Method in interface javax.xml.registry.LifeCycleManager
Creates an Association instance using the specified parameters.
createAttachmentPart() - Method in class javax.xml.soap.SOAPMessage
Creates a new empty AttachmentPart object.
createAttachmentPart(DataHandler) - Method in class javax.xml.soap.SOAPMessage
Creates an AttachmentPart object and populates it using the given DataHandler object.
createAttachmentPart(Object, String) - Method in class javax.xml.soap.SOAPMessage
Creates an AttachmentPart object and populates it with the specified data of the specified content type.
createAttribute(String, String, String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new Attribute
createAttribute(String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new Attribute
createAttribute(QName, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new Attribute
createBinder(Class<T>) - Method in class javax.xml.bind.JAXBContext
Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.
createBinder() - Method in class javax.xml.bind.JAXBContext
Creates a Binder for W3C DOM.
createBrowser(Queue) - Method in interface javax.jms.QueueSession
Creates a QueueBrowser object to peek at the messages on the specified queue.
createBrowser(Queue, String) - Method in interface javax.jms.QueueSession
Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
createBrowser(Queue) - Method in interface javax.jms.Session
Creates a QueueBrowser object to peek at the messages on the specified queue.
createBrowser(Queue, String) - Method in interface javax.jms.Session
Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
createBytesMessage() - Method in interface javax.jms.Session
Creates a BytesMessage object.
createCall(QName) - Method in interface javax.xml.rpc.Service
Creates a Call instance.
createCall(QName, QName) - Method in interface javax.xml.rpc.Service
Creates a Call instance.
createCall(QName, String) - Method in interface javax.xml.rpc.Service
Creates a Call instance.
createCall() - Method in interface javax.xml.rpc.Service
Creates a Call object not associated with specific operation or target service endpoint.
createCData(String) - Method in class javax.xml.stream.XMLEventFactory
Create a Characters event with the CData flag set to true
createCharacters(String) - Method in class javax.xml.stream.XMLEventFactory
Create a Characters event, this method does not check if the content is all whitespace.
createClassification(ClassificationScheme, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Classification instance for an external Classification using the specified String name and String value that identify a taxonomy element within the specified ClassificationScheme.
createClassification(ClassificationScheme, InternationalString, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Classification instance for an external Classification using the specified InternationalString name and String value that identify a taxonomy element within the specified ClassificationScheme.
createClassification(Concept) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Classification instance for an internal Classification using the specified Concept that identifies a taxonomy element within an internal ClassificationScheme.
createClassificationScheme(String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a ClassificationScheme given the specified String parameters.
createClassificationScheme(InternationalString, InternationalString) - Method in interface javax.xml.registry.LifeCycleManager
Creates a ClassificationScheme given the specified InternationalString parameters.
createClassificationScheme(Concept) - Method in interface javax.xml.registry.LifeCycleManager
Creates a ClassificationScheme from a Concept that has no ClassificationScheme or parent Concept.
createComment(String) - Method in class javax.xml.stream.XMLEventFactory
Create a comment
createComponent(String) - Method in class javax.faces.application.Application
Instantiate and return a new UIComponent instance of the class specified by a previous call to addComponent() for the specified component type.
createComponent(ValueBinding, FacesContext, String) - Method in class javax.faces.application.Application
Deprecated. This has been replaced by Application.createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).
createComponent(ValueExpression, FacesContext, String) - Method in class javax.faces.application.Application
Call the getValue() method on the specified ValueExpression.
createComponent(FacesContext, String) - Method in class javax.faces.webapp.UIComponentClassicTagBase
Create and return a new child component of the type returned by calling getComponentType().
createComponent(FacesContext, String) - Method in class javax.faces.webapp.UIComponentELTag
Create and return a new child component of the type returned by calling getComponentType().
createComponent(FacesContext, String) - Method in class javax.faces.webapp.UIComponentTag
Deprecated. Implement createComponent using Faces 1.1 EL API.
createConcept(RegistryObject, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Concept instance using the specified parameters, where the name is a String.
createConcept(RegistryObject, InternationalString, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Concept instance using the specified parameters, where the name is an InternationalString.
createConfiguration(DeployableObject) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Retrieve the object that provides server-specific deployment configuration information for the J2EE deployable component.
createConnection() - Method in interface javax.jms.ConnectionFactory
Creates a connection with the default user identity.
createConnection(String, String) - Method in interface javax.jms.ConnectionFactory
Creates a connection with the specified user identity.
createConnection() - Method in class javax.xml.registry.ConnectionFactory
Create a named connection.
createConnection() - Method in class javax.xml.soap.SOAPConnectionFactory
Create a new SOAPConnection.
createConnectionConsumer(Destination, String, ServerSessionPool, int) - Method in interface javax.jms.Connection
Creates a connection consumer for this connection (optional operation).
createConnectionConsumer(Queue, String, ServerSessionPool, int) - Method in interface javax.jms.QueueConnection
Creates a connection consumer for this connection (optional operation).
createConnectionConsumer(Topic, String, ServerSessionPool, int) - Method in interface javax.jms.TopicConnection
Creates a connection consumer for this connection (optional operation).
createConnectionFactory(ConnectionManager) - Method in interface javax.resource.spi.ManagedConnectionFactory
Creates a Connection Factory instance.
createConnectionFactory() - Method in interface javax.resource.spi.ManagedConnectionFactory
Creates a Connection Factory instance.
createConsumer(Destination) - Method in interface javax.jms.Session
Creates a MessageConsumer for the specified destination.
createConsumer(Destination, String) - Method in interface javax.jms.Session
Creates a MessageConsumer for the specified destination, using a message selector.
createConsumer(Destination, String, boolean) - Method in interface javax.jms.Session
Creates MessageConsumer for the specified destination, using a message selector.
createContainerEntityManagerFactory(PersistenceUnitInfo, Map) - Method in interface javax.persistence.spi.PersistenceProvider
Called by the container when an EntityManagerFactory is to be created.
createConverter(String) - Method in class javax.faces.application.Application
Instantiate and return a new Converter instance of the class specified by a previous call to addConverter() for the specified converter id.
createConverter(Class) - Method in class javax.faces.application.Application
Instantiate and return a new Converter instance of the class that has registered itself as capable of performing conversions for objects of the specified type.
createConverter() - Method in class javax.faces.webapp.ConverterELTag
Create and return a new Converter to be registered on our surrounding UIComponent.
createConverter() - Method in class javax.faces.webapp.ConverterTag
Deprecated. Create and return a new Converter to be registered on our surrounding UIComponent.
CREATED - Static variable in class javax.mail.event.FolderEvent
The folder was created.
createDataContentHandler(String) - Method in class javax.activation.CommandMap
Locate a DataContentHandler that corresponds to the MIME type.
createDataContentHandler(String, DataSource) - Method in class javax.activation.CommandMap
Locate a DataContentHandler that corresponds to the MIME type.
createDataContentHandler(String) - Method in interface javax.activation.DataContentHandlerFactory
Creates a new DataContentHandler object for the MIME type.
createDataContentHandler(String) - Method in class javax.activation.MailcapCommandMap
Return the DataContentHandler for the specified MIME type.
createDetail() - Method in class javax.xml.soap.SOAPFactory
Creates a new Detail object which serves as a container for DetailEntry objects.
createDispatch(QName, Class<T>, Service.Mode) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with objects of the users choosing.
createDispatch(QName, JAXBContext, Service.Mode) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with JAXB generated objects.
createDispatch(QName, Class<T>, Service.Mode) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with objects of the users choosing.
createDispatch(QName, JAXBContext, Service.Mode) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with JAXB generated objects.
createDTD(String) - Method in class javax.xml.stream.XMLEventFactory
Create a document type definition event This string contains the entire document type declaration that matches the doctypedecl in the XML 1.0 specification
createDurableConnectionConsumer(Topic, String, String, ServerSessionPool, int) - Method in interface javax.jms.Connection
Create a durable connection consumer for this connection (optional operation).
createDurableConnectionConsumer(Topic, String, String, ServerSessionPool, int) - Method in interface javax.jms.TopicConnection
Create a durable connection consumer for this connection (optional operation).
createDurableSubscriber(Topic, String) - Method in interface javax.jms.Session
Creates a durable subscriber to the specified topic.
createDurableSubscriber(Topic, String, String, boolean) - Method in interface javax.jms.Session
Creates a durable subscriber to the specified topic, using a message selector and specifying whether messages published by its own connection should be delivered to it.
createDurableSubscriber(Topic, String) - Method in interface javax.jms.TopicSession
Creates a durable subscriber to the specified topic.
createDurableSubscriber(Topic, String, String, boolean) - Method in interface javax.jms.TopicSession
Creates a durable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.
createElement(Element) - Method in class javax.xml.soap.SOAPFactory
Creates a SOAPElement object from an existing DOM Element.
createElement(Name) - Method in class javax.xml.soap.SOAPFactory
Creates a SOAPElement object initialized with the given Name object.
createElement(QName) - Method in class javax.xml.soap.SOAPFactory
Creates a SOAPElement object initialized with the given QName object.
createElement(String) - Method in class javax.xml.soap.SOAPFactory
Creates a SOAPElement object initialized with the given local name.
createElement(String, String, String) - Method in class javax.xml.soap.SOAPFactory
Creates a new SOAPElement object with the given local name, prefix and uri.
createEmailAddress(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an EmailAddress instance using an address as the parameter.
createEmailAddress(String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an EmailAddress instance using both an address and a type as parameters.
createEndDocument() - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of an EndDocument event
createEndElement(QName, Iterator) - Method in class javax.xml.stream.XMLEventFactory
Create a new EndElement
createEndElement(String, String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new EndElement
createEndElement(String, String, String, Iterator) - Method in class javax.xml.stream.XMLEventFactory
Create a new EndElement
createEndpoint(XAResource) - Method in interface javax.resource.spi.endpoint.MessageEndpointFactory
This is used to create a message endpoint.
createEndpoint(String, Object) - Method in class javax.xml.ws.spi.Provider
Creates an endpoint object with the provided binding and implementation object.
createEntityManager() - Method in interface javax.persistence.EntityManagerFactory
Create a new EntityManager.
createEntityManager(Map) - Method in interface javax.persistence.EntityManagerFactory
Create a new EntityManager with the specified Map of properties.
createEntityManagerFactory(String) - Static method in class javax.persistence.Persistence
Create and return an EntityManagerFactory for the named persistence unit.
createEntityManagerFactory(String, Map) - Static method in class javax.persistence.Persistence
Create and return an EntityManagerFactory for the named persistence unit using the given properties.
createEntityManagerFactory(String, Map) - Method in interface javax.persistence.spi.PersistenceProvider
Called by Persistence class when an EntityManagerFactory is to be created.
createEntityReference(String, EntityDeclaration) - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a EntityReference event
CreateException - Exception in javax.ejb
The CreateException exception must be included in the throws clauses of all create methods defined in an enterprise Bean's home interface.
CreateException() - Constructor for exception javax.ejb.CreateException
Constructs a CreateException with no detail message.
CreateException(String) - Constructor for exception javax.ejb.CreateException
Constructs a CreateException with the specified detail message.
createExternalIdentifier(ClassificationScheme, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an ExternalIdentifier instance using the specified parameters, where the name is a String.
createExternalIdentifier(ClassificationScheme, InternationalString, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an ExternalIdentifier instance using the specified parameters, where the name is an InternationalString.
createExternalLink(String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an ExternalLink instance using the specified parameters, where the description is a String.
createExternalLink(String, InternationalString) - Method in interface javax.xml.registry.LifeCycleManager
Creates an ExternalLink instance using the specified parameters, where the description is an InternationalString.
createExtrinsicObject(DataHandler) - Method in interface javax.xml.registry.LifeCycleManager
Creates an ExtrinsicObject instance using the specified parameters.
createFault(String, QName) - Method in class javax.xml.soap.SOAPFactory
Creates a new SOAPFault object initialized with the given reasonText and faultCode
createFault() - Method in class javax.xml.soap.SOAPFactory
Creates a new default SOAPFault object
createFederatedConnection(Collection) - Method in class javax.xml.registry.ConnectionFactory
Create a FederatedConnection.
createFilteredReader(XMLStreamReader, StreamFilter) - Method in class javax.xml.stream.XMLInputFactory
Create a filtered reader that wraps the filter around the reader
createFilteredReader(XMLEventReader, EventFilter) - Method in class javax.xml.stream.XMLInputFactory
Create a filtered event reader that wraps the filter around the event reader
createIgnorableSpace(String) - Method in class javax.xml.stream.XMLEventFactory
Create an ignorable space
createIndexedRecord(String) - Method in interface javax.resource.cci.RecordFactory
Creates a IndexedRecord.
createInteraction() - Method in interface javax.resource.cci.Connection
Creates an Interaction associated with this Connection.
createInternationalString() - Method in interface javax.xml.registry.LifeCycleManager
Creates an empty InternationalString instance.
createInternationalString(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an InternationalString instance using a String parameter and the default Locale.
createInternationalString(Locale, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an InternationalString instance using the specified Locale and String parameters.
createInternetHeaders(InputStream) - Method in class javax.mail.internet.MimeMessage
Create and return an InternetHeaders object that loads the headers from the given InputStream.
createInternetHeaders(InputStream) - Method in class javax.mail.internet.MimeMultipart
Create and return an InternetHeaders object that loads the headers from the given InputStream.
createJAXBIntrospector() - Method in class javax.xml.bind.JAXBContext
Creates a JAXBIntrospector object that can be used to introspect JAXB objects.
createKey(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Key instance from an ID.
createLocalizedString(Locale, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a LocalizedString instance using the specified Locale and String parameters.
createLocalizedString(Locale, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a LocalizedString instance using the specified Locale, String, and character set parameters.
createManagedConnection(Subject, ConnectionRequestInfo) - Method in interface javax.resource.spi.ManagedConnectionFactory
Creates a new physical connection to the underlying EIS resource manager.
createMapMessage() - Method in interface javax.jms.Session
Creates a MapMessage object.
createMappedRecord(String) - Method in interface javax.resource.cci.RecordFactory
Creates a MappedRecord.
createMarshaller() - Method in class javax.xml.bind.JAXBContext
Create a Marshaller object that can be used to convert a java content tree into XML data.
createMessage() - Method in interface javax.jms.Session
Creates a Message object.
createMessage() - Method in class javax.xml.soap.MessageFactory
Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
createMessage(MimeHeaders, InputStream) - Method in class javax.xml.soap.MessageFactory
Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
createMethodBinding(String, Class[]) - Method in class javax.faces.application.Application
Deprecated. This has been replaced by calling Application.getExpressionFactory() then ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class, java.lang.Class[]).
createMethodExpression(ELContext, String, Class<?>, Class<?>[]) - Method in class javax.el.ExpressionFactory
Parses an expression into a MethodExpression for later evaluation.
createMimeBodyPart(InternetHeaders, byte[]) - Method in class javax.mail.internet.MimeMultipart
Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
createMimeBodyPart(InputStream) - Method in class javax.mail.internet.MimeMultipart
Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
createMimeMessage(Session) - Method in class javax.mail.internet.MimeMessage
Create and return a MimeMessage object.
createName(String, String, String) - Method in interface javax.xml.soap.SOAPEnvelope
Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
createName(String) - Method in interface javax.xml.soap.SOAPEnvelope
Creates a new Name object initialized with the given local name.
createName(String, String, String) - Method in class javax.xml.soap.SOAPFactory
Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
createName(String) - Method in class javax.xml.soap.SOAPFactory
Creates a new Name object initialized with the given local name.
createNamedQuery(String) - Method in interface javax.persistence.EntityManager
Create an instance of Query for executing a named query (in the Java Persistence query language or in native SQL).
createNamespace(String) - Method in class javax.xml.stream.XMLEventFactory
Create a new default Namespace
createNamespace(String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new Namespace
createNativeQuery(String) - Method in interface javax.persistence.EntityManager
Create an instance of Query for executing a native SQL statement, e.g., for update or delete.
createNativeQuery(String, Class) - Method in interface javax.persistence.EntityManager
Create an instance of Query for executing a native SQL query.
createNativeQuery(String, String) - Method in interface javax.persistence.EntityManager
Create an instance of Query for executing a native SQL query.
createObject(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates instances of information model interfaces (factory method).
createObjectMessage() - Method in interface javax.jms.Session
Creates an ObjectMessage object.
createObjectMessage(Serializable) - Method in interface javax.jms.Session
Creates an initialized ObjectMessage object.
createOrganization(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates an Organization instance using the specified name, where the name is a String.
createOrganization(InternationalString) - Method in interface javax.xml.registry.LifeCycleManager
Creates an Organization instance using the specified name, where the name is an InternationalString.
createOutput(String, String) - Method in class javax.xml.bind.SchemaOutputResolver
Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.
createPersonName(String, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a PersonName instance using the specified first, middle, and last names.
createPersonName(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a PersonName instance using the specified full name.
createPostalAddress(String, String, String, String, String, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a PostalAddress instance using the specified parameters.
createProcessingInstruction(String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a processing instruction
createProducer(Destination) - Method in interface javax.jms.Session
Creates a MessageProducer to send messages to the specified destination.
createPublisher(Topic) - Method in interface javax.jms.TopicSession
Creates a publisher for the specified topic.
createQName(String, String) - Method in interface javax.xml.soap.SOAPElement
Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement.
createQuery(String) - Method in interface javax.persistence.EntityManager
Create an instance of Query for executing a Java Persistence query language statement.
createQuery(int, String) - Method in interface javax.xml.registry.DeclarativeQueryManager
Creates a Query object given a queryType (for example, QUERY_TYPE_SQL) and a String that represents a query in the syntax appropriate for queryType.
createQueue(String) - Method in interface javax.jms.QueueSession
Creates a queue identity given a Queue name.
createQueue(String) - Method in interface javax.jms.Session
Creates a queue identity given a Queue name.
createQueueConnection() - Method in interface javax.jms.QueueConnectionFactory
Creates a queue connection with the default user identity.
createQueueConnection(String, String) - Method in interface javax.jms.QueueConnectionFactory
Creates a queue connection with the specified user identity.
createQueueSession(boolean, int) - Method in interface javax.jms.QueueConnection
Creates a QueueSession object.
createQueueSession(boolean, int) - Method in interface javax.jms.XAQueueConnection
Creates an XAQueueSession object.
createReceiver(Queue) - Method in interface javax.jms.QueueSession
Creates a QueueReceiver object to receive messages from the specified queue.
createReceiver(Queue, String) - Method in interface javax.jms.QueueSession
Creates a QueueReceiver object to receive messages from the specified queue using a message selector.
createRegistryPackage(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a RegistryPackage instance using the specified name, where the name is a String.
createRegistryPackage(InternationalString) - Method in interface javax.xml.registry.LifeCycleManager
Creates a RegistryPackage instance using the specified name, where the name is an InternationalString.
createResponseStream(OutputStream) - Method in class javax.faces.render.RenderKit
Use the provided OutputStream to create a new ResponseStream instance.
createResponseWriter(Writer, String, String) - Method in class javax.faces.render.RenderKit
Use the provided Writer to create a new ResponseWriter instance for the specified (optional) content type, and character encoding.
createSender(Queue) - Method in interface javax.jms.QueueSession
Creates a QueueSender object to send messages to the specified queue.
createService(String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Service instance using the specified name, where the name is a String.
createService(InternationalString) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Service instance using the specified name, where the name is an InternationalString.
createService(URL, QName) - Method in class javax.xml.rpc.ServiceFactory
Create a Service instance.
createService(QName) - Method in class javax.xml.rpc.ServiceFactory
Create a Service instance.
createServiceBinding() - Method in interface javax.xml.registry.LifeCycleManager
Creates an empty ServiceBinding instance.
createServiceDelegate(URL, QName, Class) - Method in class javax.xml.ws.spi.Provider
Creates a service delegate object.
createSession(boolean, int) - Method in interface javax.jms.Connection
Creates a Session object.
createSession(boolean, int) - Method in interface javax.jms.XAConnection
Creates an Session object.
createSlot(String, String, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Slot instance using the specified parameters, where the value is a String.
createSlot(String, Collection, String) - Method in interface javax.xml.registry.LifeCycleManager
Creates a Slot instance using the specified parameters, where the value is a Collection of Strings.
createSpace(String) - Method in class javax.xml.stream.XMLEventFactory
Create a Characters event with the isSpace flag set to true
createSpecificationLink() - Method in interface javax.xml.registry.LifeCycleManager
Creates an empty SpecificationLink instance.
createStartDocument() - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a StartDocument event
createStartDocument(String, String, boolean) - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a StartDocument event
createStartDocument(String, String) - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a StartDocument event
createStartDocument(String) - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a StartDocument event
createStartElement(QName, Iterator, Iterator) - Method in class javax.xml.stream.XMLEventFactory
Create a new StartElement.
createStartElement(String, String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new StartElement.
createStartElement(String, String, String, Iterator, Iterator) - Method in class javax.xml.stream.XMLEventFactory
Create a new StartElement.
createStartElement(String, String, String, Iterator, Iterator, NamespaceContext) - Method in class javax.xml.stream.XMLEventFactory
Create a new StartElement.
createStreamMessage() - Method in interface javax.jms.Session
Creates a StreamMessage object.
createSubscriber(Topic) - Method in interface javax.jms.TopicSession
Creates a nondurable subscriber to the specified topic.
createSubscriber(Topic, String, boolean) - Method in interface javax.jms.TopicSession
Creates a nondurable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.
createTelephoneNumber() - Method in interface javax.xml.registry.LifeCycleManager
Creates an empty TelephoneNumber instance.
createTemporaryQueue() - Method in interface javax.jms.QueueSession
Creates a TemporaryQueue object.
createTemporaryQueue() - Method in interface javax.jms.Session
Creates a TemporaryQueue object.
createTemporaryTopic() - Method in interface javax.jms.Session
Creates a TemporaryTopic object.
createTemporaryTopic() - Method in interface javax.jms.TopicSession
Creates a TemporaryTopic object.
createTextMessage() - Method in interface javax.jms.Session
Creates a TextMessage object.
createTextMessage(String) - Method in interface javax.jms.Session
Creates an initialized TextMessage object.
createTimer(long, Serializable) - Method in interface javax.ejb.TimerService
Create a single-action timer that expires after a specified duration.
createTimer(long, long, Serializable) - Method in interface javax.ejb.TimerService
Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.
createTimer(Date, Serializable) - Method in interface javax.ejb.TimerService
Create a single-action timer that expires at a given point in time.
createTimer(Date, long, Serializable) - Method in interface javax.ejb.TimerService
Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.
createTimer() - Method in interface javax.resource.spi.BootstrapContext
Creates a new java.util.Timer instance.
createTopic(String) - Method in interface javax.jms.Session
Creates a topic identity given a Topic name.
createTopic(String) - Method in interface javax.jms.TopicSession
Creates a topic identity given a Topic name.
createTopicConnection() - Method in interface javax.jms.TopicConnectionFactory
Creates a topic connection with the default user identity.
createTopicConnection(String, String) - Method in interface javax.jms.TopicConnectionFactory
Creates a topic connection with the specified user identity.
createTopicSession(boolean, int) - Method in interface javax.jms.TopicConnection
Creates a TopicSession object.
createTopicSession(boolean, int) - Method in interface javax.jms.XATopicConnection
Creates an XATopicSession object.
createTypeMapping() - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry
Creates a new empty TypeMapping object.
createUniqueId() - Method in class javax.faces.component.UIViewRoot
Generate an identifier for a component.
createUnmarshalException(SAXException) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
Creates an UnmarshalException from a SAXException.
createUnmarshaller(ValidationEventHandler) - Method in interface javax.xml.bind.annotation.DomHandler
When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
createUnmarshaller(ValidationEventHandler) - Method in class javax.xml.bind.annotation.W3CDomHandler
createUnmarshaller() - Method in class javax.xml.bind.JAXBContext
Create an Unmarshaller object that can be used to convert XML data into a java content tree.
createUser() - Method in interface javax.xml.registry.LifeCycleManager
Creates an empty User instance.
createValidator(String) - Method in class javax.faces.application.Application
Instantiate and return a new Validator instance of the class specified by a previous call to addValidator() for the specified validator id.
createValidator() - Method in class javax.faces.webapp.ValidatorELTag
Create and return a new Validator to be registered on our surrounding UIComponent.
createValidator() - Method in class javax.faces.webapp.ValidatorTag
Deprecated. Create and return a new Validator to be registered on our surrounding UIComponent.
createValidator() - Method in class javax.xml.bind.JAXBContext
Deprecated. since JAXB2.0
createValueBinding(String) - Method in class javax.faces.application.Application
Deprecated. This has been replaced by calling Application.getExpressionFactory() then ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class).
createValueExpression(ELContext, String, Class<?>) - Method in class javax.el.ExpressionFactory
Parses an expression into a ValueExpression for later evaluation.
createValueExpression(Object, Class<?>) - Method in class javax.el.ExpressionFactory
Creates a ValueExpression that wraps an object instance.
createVerbatimComponent() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Use the Application instance to create a new component with the following characteristics.
createVerbatimComponentFromBodyContent() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Create a transient UIOutput component from the body content, of this tag instance or return null if there is no body content, the body content is whitespace, or the body content is a comment.
createView(FacesContext, String) - Method in class javax.faces.application.ViewHandler
Create and return a new UIViewRoot instance initialized with information from the argument FacesContext and viewId.
createView(FacesContext, String) - Method in class javax.faces.application.ViewHandlerWrapper
The default behavior of this method is to call ViewHandler.createView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
createXAConnection() - Method in interface javax.jms.XAConnectionFactory
Creates an XAConnection with the default user identity.
createXAConnection(String, String) - Method in interface javax.jms.XAConnectionFactory
Creates an XA connection with the specified user identity.
createXAQueueConnection() - Method in interface javax.jms.XAQueueConnectionFactory
Creates an XA queue connection with the default user identity.
createXAQueueConnection(String, String) - Method in interface javax.jms.XAQueueConnectionFactory
Creates an XA queue connection with the specified user identity.
createXAQueueSession() - Method in interface javax.jms.XAQueueConnection
Creates an XAQueueSession object.
createXASession() - Method in interface javax.jms.XAConnection
Creates an XASession object.
createXATopicConnection() - Method in interface javax.jms.XATopicConnectionFactory
Creates an XA topic connection with the default user identity.
createXATopicConnection(String, String) - Method in interface javax.jms.XATopicConnectionFactory
Creates an XA topic connection with the specified user identity.
createXATopicSession() - Method in interface javax.jms.XATopicConnection
Creates an XATopicSession object.
createXMLEventReader(Reader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a reader
createXMLEventReader(String, Reader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a reader
createXMLEventReader(XMLStreamReader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from an XMLStreamReader.
createXMLEventReader(Source) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a JAXP source.
createXMLEventReader(InputStream) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a java.io.InputStream
createXMLEventReader(InputStream, String) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a java.io.InputStream
createXMLEventReader(String, InputStream) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a java.io.InputStream
createXMLEventWriter(Result) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLEventWriter that writes to a JAXP result.
createXMLEventWriter(OutputStream) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLEventWriter that writes to a stream
createXMLEventWriter(OutputStream, String) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLEventWriter that writes to a stream
createXMLEventWriter(Writer) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLEventWriter that writes to a writer
createXMLStreamReader(Reader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a reader
createXMLStreamReader(Source) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a JAXP source.
createXMLStreamReader(InputStream) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a java.io.InputStream
createXMLStreamReader(InputStream, String) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a java.io.InputStream
createXMLStreamReader(String, InputStream) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a java.io.InputStream
createXMLStreamReader(String, Reader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a java.io.InputStream
createXMLStreamWriter(Writer) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLStreamWriter that writes to a writer
createXMLStreamWriter(OutputStream) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLStreamWriter that writes to a stream
createXMLStreamWriter(OutputStream, String) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLStreamWriter that writes to a stream
createXMLStreamWriter(Result) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLStreamWriter that writes to a JAXP result.
CURRENCY_ID - Static variable in class javax.faces.convert.NumberConverter
The message identifier of the FacesMessage to be created if the conversion to Number fails.

D

DataContentHandler - Interface in javax.activation
The DataContentHandler interface is implemented by objects that can be used to extend the capabilities of the DataHandler's implementation of the Transferable interface.
DataContentHandlerFactory - Interface in javax.activation
This interface defines a factory for DataContentHandlers.
DataHandler - Class in javax.activation
The DataHandler class provides a consistent interface to data available in many different sources and formats.
DataHandler(DataSource) - Constructor for class javax.activation.DataHandler
Create a DataHandler instance referencing the specified DataSource.
DataHandler(Object, String) - Constructor for class javax.activation.DataHandler
Create a DataHandler instance representing an object of this MIME type.
DataHandler(URL) - Constructor for class javax.activation.DataHandler
Create a DataHandler instance referencing a URL.
datalen - Variable in class javax.mail.util.SharedFileInputStream
The amount of data in this subset of the file.
DataModel - Class in javax.faces.model
DataModel is an abstraction around arbitrary data binding technologies that can be used to adapt a variety of data sources for use by JavaServer Faces components that support per-row processing for their child components (such as UIData.
DataModel() - Constructor for class javax.faces.model.DataModel
DataModelEvent - Class in javax.faces.model
DataModelEvent represents an event of interest to registered listeners that occurred on the specified DataModel.
DataModelEvent(DataModel, int, Object) - Constructor for class javax.faces.model.DataModelEvent
Construct an event object that is associated with the specified row index and associated data.
DataModelListener - Interface in javax.faces.model
DataModelListener represents an event listener that wishes to be notified of DataModelEvents occurring on a particular DataModel instance.
DataSource - Interface in javax.activation
The DataSource interface provides the JavaBeans Activation Framework with an abstraction of an arbitrary collection of data.
DatatypeConverter - Class in javax.xml.bind
The javaType binding declaration can be used to customize the binding of an XML schema datatype to a Java datatype.
DatatypeConverterInterface - Interface in javax.xml.bind
The DatatypeConverterInterface is for JAXB provider use only.
date - Variable in class javax.mail.search.DateTerm
The date.
DATE_ID - Static variable in class javax.faces.convert.DateTimeConverter
The message identifier of the FacesMessage to be created if the conversion to Date fails.
DateTerm - Class in javax.mail.search
This class implements comparisons for Dates
DateTerm(int, Date) - Constructor for class javax.mail.search.DateTerm
Constructor.
DATETIME_ID - Static variable in class javax.faces.convert.DateTimeConverter
The message identifier of the FacesMessage to be created if the conversion to DateTime fails.
DateTimeConverter - Class in javax.faces.convert
Converter implementation for java.util.Date values.
DateTimeConverter() - Constructor for class javax.faces.convert.DateTimeConverter
DConfigBean - Interface in javax.enterprise.deploy.spi
The DConfigBean is a deployment configuration bean (DConfigBean) that is associated with one or more deployment descriptor beans, (DDBean).
DConfigBeanRoot - Interface in javax.enterprise.deploy.spi
A J2EE component module consists of one or more deployment descriptor files and zero or more non-deployment descriptor XML instance documents.
DConfigBeanVersionType - Class in javax.enterprise.deploy.shared
Class DConfigBeanVersionTypes defines enumeration values for the J2EE Platform verion number.
DConfigBeanVersionType(int) - Constructor for class javax.enterprise.deploy.shared.DConfigBeanVersionType
Construct a new enumeration value with the given integer value.
DConfigBeanVersionUnsupportedException - Exception in javax.enterprise.deploy.spi.exceptions
This exception is to report that there is no support for the DConfigBean version requested.
DConfigBeanVersionUnsupportedException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException
Creates an new DConfigBeanVersionUnsupportedException object.
DDBean - Interface in javax.enterprise.deploy.model
An interface for beans that represent a fragment of a standard deployment descriptor.
DDBeanCreateException - Exception in javax.enterprise.deploy.model.exceptions
This exception reports errors in generating a DDBean.
DDBeanCreateException() - Constructor for exception javax.enterprise.deploy.model.exceptions.DDBeanCreateException
Creates new DDBeanCreateException without detail message.
DDBeanCreateException(String) - Constructor for exception javax.enterprise.deploy.model.exceptions.DDBeanCreateException
Constructs an DDBeanCreateException with the specified detail message.
DDBeanRoot - Interface in javax.enterprise.deploy.model
An interface that represents the root of a standard deployment descriptor.
debug - Variable in class javax.mail.Service
Debug flag for this service.
DECIMAL_ID - Static variable in class javax.faces.convert.BigDecimalConverter
The message identifier of the FacesMessage to be created if the conversion to BigDecimal fails.
DeclarativeQueryManager - Interface in javax.xml.registry
This interface provides the ability to execute declarative queries (e.g.
declaredType - Variable in class javax.xml.bind.JAXBElement
Java datatype binding for xml element declaration's type.
DeclareRoles - Annotation Type in javax.annotation.security
Used by application to declare roles.
decode(FacesContext) - Method in class javax.faces.component.UIComponent
Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.
decode(FacesContext) - Method in class javax.faces.component.UIComponentBase
decode(FacesContext) - Method in class javax.faces.component.UIInput
decode(FacesContext, UIComponent) - Method in class javax.faces.render.Renderer
Decode any new state of the specified UIComponent from the request contained in the specified FacesContext, and store that state on the UIComponent.
decode(InputStream, String) - Static method in class javax.mail.internet.MimeUtility
Decode the given input stream.
decodeText(String) - Static method in class javax.mail.internet.MimeUtility
Decode "unstructured" headers, that is, headers that are defined as '*text' as per RFC 822.
decodeWord(String) - Static method in class javax.mail.internet.MimeUtility
The string is parsed using the rules in RFC 2047 for parsing an "encoded-word".
DEFAULT_BUFFER - Static variable in class javax.servlet.jsp.JspWriter
Constant indicating that the Writer is buffered and is using the implementation default buffer size.
DEFAULT_CHARSET_NAME - Static variable in interface javax.xml.registry.infomodel.LocalizedString
The default name returned by getCharsetName if no other name has explicitly been set.
DEFAULT_DELIVERY_MODE - Static variable in interface javax.jms.Message
The message producer's default delivery mode is PERSISTENT.
DEFAULT_LIFECYCLE - Static variable in class javax.faces.lifecycle.LifecycleFactory
The lifecycle identifier for the default Lifecycle instance for this JavaServer Faces implementation.
DEFAULT_PRIORITY - Static variable in interface javax.jms.Message
The message producer's default priority is 4.
DEFAULT_SOAP_PROTOCOL - Static variable in interface javax.xml.soap.SOAPConstants
The default protocol: SOAP 1.1 for backwards compatibility.
DEFAULT_SUFFIX - Static variable in class javax.faces.application.ViewHandler
The value to use for the default extension if the webapp is using url extension mapping.
DEFAULT_SUFFIX_PARAM_NAME - Static variable in class javax.faces.application.ViewHandler
Allow the web application to define an alternate suffix for pages containing JSF content.
DEFAULT_TIME_TO_LIVE - Static variable in interface javax.jms.Message
The message producer's default time to live is unlimited; the message never expires.
DefaultValidationEventHandler - Class in javax.xml.bind.helpers
JAXB 1.0 only default validation event handler.
DefaultValidationEventHandler() - Constructor for class javax.xml.bind.helpers.DefaultValidationEventHandler
delete() - Method in interface javax.jms.TemporaryQueue
Deletes this temporary queue.
delete() - Method in interface javax.jms.TemporaryTopic
Deletes this temporary topic.
delete(boolean) - Method in class javax.mail.Folder
Delete this Folder.
delete() - Method in interface javax.security.jacc.PolicyConfiguration
Causes all policy statements to be deleted from this PolicyConfiguration and sets its internal state such that calling any method, other than delete, getContextID, or inService on the PolicyConfiguration will be rejected and cause an UnsupportedOperationException to be thrown.
deleteAssociations(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Deletes the Associations corresponding to the specified Keys.
deleteClassificationSchemes(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Deletes the ClassificationSchemes corresponding to the specified Keys.
deleteConcepts(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Deletes the Concepts corresponding to the specified Keys.
DELETED - Static variable in class javax.mail.event.FolderEvent
The folder was deleted.
DELETED - Static variable in class javax.mail.Flags.Flag
This message is marked deleted.
DeleteException - Exception in javax.xml.registry
A RegistryException that occurs during a delete action.
DeleteException() - Constructor for exception javax.xml.registry.DeleteException
Constructs a JAXRException object with no reason or embedded Throwable.
DeleteException(String) - Constructor for exception javax.xml.registry.DeleteException
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
DeleteException(String, Throwable) - Constructor for exception javax.xml.registry.DeleteException
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
DeleteException(Throwable) - Constructor for exception javax.xml.registry.DeleteException
Constructs a JAXRException object initialized with the given Throwable object.
deleteObjects(Collection) - Method in interface javax.xml.registry.LifeCycleManager
Deletes one or more previously submitted objects from the registry using the object keys.
deleteObjects(Collection, String) - Method in interface javax.xml.registry.LifeCycleManager
Deletes one or more previously submitted objects from the registry using the object keys and a specified objectType attribute.
deleteOrganizations(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Deletes the organizations corresponding to the specified Keys.
deletesAreDetected(int) - Method in interface javax.resource.cci.ResultSetInfo
deleteServiceBindings(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Deletes the ServiceBindings corresponding to the specified Keys.
deleteServices(Collection) - Method in interface javax.xml.registry.BusinessLifeCycleManager
Deletes the services corresponding to the specified Keys.
delistResource(XAResource, int) - Method in interface javax.transaction.Transaction
Disassociate the resource specified from the transaction associated with the target Transaction object.
DeliveryMode - Interface in javax.jms
The delivery modes supported by the JMS API are PERSISTENT and NON_PERSISTENT.
DenyAll - Annotation Type in javax.annotation.security
Specifies that no security roles are allowed to invoke the specified method(s) - i.e that the methods are to be excluded from execution in the J2EE container.
DeployableObject - Interface in javax.enterprise.deploy.model
The DeployableObject interface is an abstract representation of a J2EE deployable module (JAR, WAR, RAR, EAR).
DeploymentConfiguration - Interface in javax.enterprise.deploy.spi
An interface that defines a container for all the server-specific configuration information for a single top-level J2EE module.
DeploymentFactory - Interface in javax.enterprise.deploy.spi.factories
The DeploymentFactory interface is a deployment driver for a J2EE plaform product.
DeploymentFactoryManager - Class in javax.enterprise.deploy.shared.factories
The DeploymentFactoryManager class is a central registry for J2EE DeploymentFactory objects.
DeploymentManager - Interface in javax.enterprise.deploy.spi
The DeploymentManager object provides the core set of functions a J2EE platform must provide for J2EE application deployment.
DeploymentManagerCreationException - Exception in javax.enterprise.deploy.spi.exceptions
This exception is to report problems in returning a DeploymentManager object cause by such things as server down, unable to authenticate and the like.
DeploymentManagerCreationException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException
Creates an new DeploymentManagerCreationException object.
DeploymentStatus - Interface in javax.enterprise.deploy.spi.status
The DeploymentStatus interface provides information about the progress status of a deployment action.
deprecateObjects(Collection) - Method in interface javax.xml.registry.LifeCycleManager
Deprecates one or more previously submitted objects.
DeserializationContext - Interface in javax.xml.rpc.encoding
The javax.xml.rpc.encoding.DeserializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner.
Deserializer - Interface in javax.xml.rpc.encoding
The javax.xml.rpc.encoding.Deserializer interface defines a base interface for deserializers.
DeserializerFactory - Interface in javax.xml.rpc.encoding
The javax.xml.rpc.encoding.DeserializerFactory is a factory of deserializers.
Destination - Interface in javax.jms
A Destination object encapsulates a provider-specific address.
destroy() - Method in class javax.faces.webapp.FacesServlet
Release all resources acquired at startup time.
destroy() - Method in interface javax.resource.spi.ManagedConnection
Destroys the physical connection to the underlying resource manager.
destroy() - Method in interface javax.servlet.Filter
Called by the web container to indicate to a filter that it is being taken out of service.
destroy() - Method in class javax.servlet.GenericServlet
Called by the servlet container to indicate to a servlet that the servlet is being taken out of service.
destroy() - Method in interface javax.servlet.Servlet
Called by the servlet container to indicate to a servlet that the servlet is being taken out of service.
destroy() - Method in class javax.xml.rpc.handler.GenericHandler
The destroy method indicates the end of lifecycle for a Handler instance.
destroy() - Method in interface javax.xml.rpc.handler.Handler
The destroy method indicates the end of lifecycle for a Handler instance.
destroy() - Method in interface javax.xml.rpc.handler.HandlerChain
Indicates the end of lifecycle for a HandlerChain.
destroy() - Method in interface javax.xml.rpc.server.ServiceLifecycle
JAX-RPC runtime system ends the lifecycle of a service endpoint instance by invoking the destroy method.
detachNode() - Method in interface javax.xml.soap.Node
Removes this Node object from the tree.
Detail - Interface in javax.xml.soap
A container for DetailEntry objects.
DetailEntry - Interface in javax.xml.soap
The content for a Detail object, giving details for a SOAPFault object.
dh - Variable in class javax.mail.internet.MimeBodyPart
The DataHandler object representing this Part's content.
dh - Variable in class javax.mail.internet.MimeMessage
The DataHandler object representing this Message's content.
DIGEST_AUTH - Static variable in class javax.faces.context.ExternalContext
String identifier for DIGEST authentication.
DIGEST_AUTH - Static variable in interface javax.servlet.http.HttpServletRequest
String identifier for Digest authentication.
disconnected(ConnectionEvent) - Method in class javax.mail.event.ConnectionAdapter
DISCONNECTED - Static variable in class javax.mail.event.ConnectionEvent
A connection was disconnected (not currently used).
disconnected(ConnectionEvent) - Method in interface javax.mail.event.ConnectionListener
Invoked when a Store is disconnected.
DiscriminatorColumn - Annotation Type in javax.persistence
Is used to define the discriminator column for the SINGLE_TABLE and JOINED inheritance mapping strategies.
DiscriminatorType - Enum in javax.persistence
Defines supported types of the discriminator column.
DiscriminatorValue - Annotation Type in javax.persistence
Is used to specify the value of the discriminator column for entities of the given type.
dispatch(String) - Method in class javax.faces.context.ExternalContext
Dispatch a request to the specified resource to create output for this response.
dispatch(Object) - Method in class javax.mail.event.ConnectionEvent
Invokes the appropriate ConnectionListener method
dispatch(Object) - Method in class javax.mail.event.FolderEvent
Invokes the appropriate FolderListener method
dispatch(Object) - Method in class javax.mail.event.MailEvent
This method invokes the appropriate method on a listener for this event.
dispatch(Object) - Method in class javax.mail.event.MessageChangedEvent
Invokes the appropriate MessageChangedListener method.
dispatch(Object) - Method in class javax.mail.event.MessageCountEvent
Invokes the appropriate MessageCountListener method.
dispatch(Object) - Method in class javax.mail.event.StoreEvent
Invokes the appropriate StoreListener method.
dispatch(Object) - Method in class javax.mail.event.TransportEvent
Invokes the appropriate TransportListener method.
Dispatch<T> - Interface in javax.xml.ws
The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
DissociatableManagedConnection - Interface in javax.resource.spi
This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation.
dissociateConnections() - Method in interface javax.resource.spi.DissociatableManagedConnection
This method is called by an application server (that is capable of lazy connection association optimization) in order to dissociate a ManagedConnection instance from all of its connection handles.
DISTRIBUTE - Static variable in class javax.enterprise.deploy.shared.CommandType
The DeploymentManger action operation being processed is distribute.
distribute(Target[], File, File) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
distribute(Target[], InputStream, InputStream) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Deprecated. as of Java EE 5, replaced with DeploymentManager.distribute(Target[], ModuleType, InputStream, InputStream)
distribute(Target[], ModuleType, InputStream, InputStream) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
doAfterBody() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Perform any processing necessary to handle the content implications of CASE 4 in the class description.
doAfterBody() - Method in class javax.servlet.jsp.tagext.BodyTagSupport
After the body evaluation: do not reevaluate and continue with the page.
doAfterBody() - Method in interface javax.servlet.jsp.tagext.IterationTag
Process body (re)evaluation.
doAfterBody() - Method in class javax.servlet.jsp.tagext.TagSupport
Default processing for a body.
doCatch(Throwable) - Method in interface javax.servlet.jsp.tagext.TryCatchFinally
Invoked if a Throwable occurs while evaluating the BODY inside a tag or in any of the following methods: Tag.doStartTag(), Tag.doEndTag(), IterationTag.doAfterBody() and BodyTag.doInitBody().
doDelete(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Called by the server (via the service method) to allow a servlet to handle a DELETE request.
doEndTag() - Method in class javax.faces.webapp.AttributeTag
Deprecated.
doEndTag() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Perform any processing necessary to handle the content implications of CASE 3 in the class description.
doEndTag() - Method in class javax.servlet.jsp.tagext.BodyTagSupport
Default processing of the end tag returning EVAL_PAGE.
doEndTag() - Method in interface javax.servlet.jsp.tagext.Tag
Process the end tag for this instance.
doEndTag() - Method in class javax.servlet.jsp.tagext.TagAdapter
Must not be called.
doEndTag() - Method in class javax.servlet.jsp.tagext.TagSupport
Default processing of the end tag returning EVAL_PAGE.
doFilter(ServletRequest, ServletResponse, FilterChain) - Method in interface javax.servlet.Filter
The doFilter method of the Filter is called by the container each time a request/response pair is passed through the chain due to a client request for a resource at the end of the chain.
doFilter(ServletRequest, ServletResponse) - Method in interface javax.servlet.FilterChain
Causes the next filter in the chain to be invoked, or if the calling filter is the last filter in the chain, causes the resource at the end of the chain to be invoked.
doFinally() - Method in interface javax.servlet.jsp.tagext.TryCatchFinally
Invoked in all cases after doEndTag() for any class implementing Tag, IterationTag or BodyTag.
doGet(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Called by the server (via the service method) to allow a servlet to handle a GET request.
doHead(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Receives an HTTP HEAD request from the protected service method and handles the request.
doInitBody() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Prepare for evaluation of the body.
doInitBody() - Method in interface javax.servlet.jsp.tagext.BodyTag
Prepare for evaluation of the body.
doInitBody() - Method in class javax.servlet.jsp.tagext.BodyTagSupport
Prepare for evaluation of the body just before the first body evaluation: no action.
DomHandler<ElementT,ResultT extends Result> - Interface in javax.xml.bind.annotation
Converts an element (and its descendants) from/to DOM (or similar) representation.
doOptions(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Called by the server (via the service method) to allow a servlet to handle a OPTIONS request.
doPost(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Called by the server (via the service method) to allow a servlet to handle a POST request.
doPut(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Called by the server (via the service method) to allow a servlet to handle a PUT request.
doStartTag() - Method in class javax.faces.webapp.AttributeTag
Deprecated. Register the specified attribute name and value with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if this UIComponent does not already have a value for the specified attribute name.
doStartTag() - Method in class javax.faces.webapp.ConverterELTag
Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentClassicTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page.
doStartTag() - Method in class javax.faces.webapp.ConverterTag
Deprecated. Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page.
doStartTag() - Method in class javax.faces.webapp.FacetTag
Return EVAL_BODY_INCLUDE to cause nested body content to be evaluated.
doStartTag() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Perform any processing necessary to find (or create) the UIComponent instance in the view corresponding to this tag instance in the page and, if and only if a component was created, insert it into the tree at the proper location as expected by the page author.
doStartTag() - Method in class javax.faces.webapp.ValidatorELTag
Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page.
doStartTag() - Method in class javax.faces.webapp.ValidatorTag
Deprecated. Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page.
doStartTag() - Method in class javax.servlet.jsp.tagext.BodyTagSupport
Default processing of the start tag returning EVAL_BODY_BUFFERED.
doStartTag() - Method in interface javax.servlet.jsp.tagext.Tag
Process the start tag for this instance.
doStartTag() - Method in class javax.servlet.jsp.tagext.TagAdapter
Must not be called.
doStartTag() - Method in class javax.servlet.jsp.tagext.TagSupport
Default processing of the start tag, returning SKIP_BODY.
doTag() - Method in interface javax.servlet.jsp.tagext.SimpleTag
Called by the container to invoke this tag.
doTag() - Method in class javax.servlet.jsp.tagext.SimpleTagSupport
Default processing of the tag does nothing.
doTrace(HttpServletRequest, HttpServletResponse) - Method in class javax.servlet.http.HttpServlet
Called by the server (via the service method) to allow a servlet to handle a TRACE request.
DOUBLE_ID - Static variable in class javax.faces.convert.DoubleConverter
The message identifier of the FacesMessage to be created if the conversion to Double fails.
DoubleConverter - Class in javax.faces.convert
Converter implementation for java.lang.Double (and double primitive) values.
DoubleConverter() - Constructor for class javax.faces.convert.DoubleConverter
DoubleHolder - Class in javax.xml.rpc.holders
DoubleHolder() - Constructor for class javax.xml.rpc.holders.DoubleHolder
DoubleHolder(double) - Constructor for class javax.xml.rpc.holders.DoubleHolder
DoubleRangeValidator - Class in javax.faces.validator
DoubleRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values.
DoubleRangeValidator() - Constructor for class javax.faces.validator.DoubleRangeValidator
Construct a Validator with no preconfigured limits.
DoubleRangeValidator(double) - Constructor for class javax.faces.validator.DoubleRangeValidator
Construct a Validator with the specified preconfigured limit.
DoubleRangeValidator(double, double) - Constructor for class javax.faces.validator.DoubleRangeValidator
Construct a Validator with the specified preconfigured limits.
DoubleWrapperHolder - Class in javax.xml.rpc.holders
DoubleWrapperHolder() - Constructor for class javax.xml.rpc.holders.DoubleWrapperHolder
DoubleWrapperHolder(Double) - Constructor for class javax.xml.rpc.holders.DoubleWrapperHolder
doWork(Work) - Method in interface javax.resource.spi.work.WorkManager
Accepts a Work instance for processing.
doWork(Work, long, ExecutionContext, WorkListener) - Method in interface javax.resource.spi.work.WorkManager
Accepts a Work instance for processing.
DRAFT - Static variable in class javax.mail.Flags.Flag
This message is a draft.
ds - Variable in class javax.mail.internet.MimeMultipart
The DataSource supplying our InputStream.
DTD - Interface in javax.xml.stream.events
This is the top level interface for events dealing with DTDs
DTD - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is a DTD
DuplicateKeyException - Exception in javax.ejb
The DuplicateKeyException exception is thrown if an entity EJB object cannot be created because an object with the same key already exists.
DuplicateKeyException() - Constructor for exception javax.ejb.DuplicateKeyException
Constructs a DuplicateKeyException with no detail message.
DuplicateKeyException(String) - Constructor for exception javax.ejb.DuplicateKeyException
Constructs a DuplicateKeyException with the specified detail message.
DUPS_OK_ACKNOWLEDGE - Static variable in interface javax.jms.Session
This acknowledgment mode instructs the session to lazily acknowledge the delivery of messages.
DYNAMIC_SOAP_PROTOCOL - Static variable in interface javax.xml.soap.SOAPConstants
Used to create MessageFactory instances that create SOAPMessages whose concrete type is based on the Content-Type MIME header passed to the createMessage method.
DynamicAttributes - Interface in javax.servlet.jsp.tagext
For a tag to declare that it accepts dynamic attributes, it must implement this interface.

E

EAR - Static variable in class javax.enterprise.deploy.shared.ModuleType
The module is an EAR archive.
EditableValueHolder - Interface in javax.faces.component
EditableValueHolder is an extension of ValueHolder that describes additional features supported by editable components, including ValueChangeEvents and Validators.
EISSystemException - Exception in javax.resource.spi
An EISSystemException is used to indicate any EIS specific system-level error conditions.
EISSystemException() - Constructor for exception javax.resource.spi.EISSystemException
Constructs a new instance with null as its detail message.
EISSystemException(String) - Constructor for exception javax.resource.spi.EISSystemException
Constructs a new instance with the specified detail message.
EISSystemException(Throwable) - Constructor for exception javax.resource.spi.EISSystemException
Constructs a new throwable with the specified cause.
EISSystemException(String, Throwable) - Constructor for exception javax.resource.spi.EISSystemException
Constructs a new throwable with the specified detail message and cause.
EISSystemException(String, String) - Constructor for exception javax.resource.spi.EISSystemException
Constructs a new throwable with the specified detail message and an error code.
EJB - Annotation Type in javax.ejb
Indicates a dependency on the local or remote view of an Enterprise Java Bean.
EJB - Static variable in class javax.enterprise.deploy.shared.ModuleType
The module is an Enterprise Java Bean archive.
EJBAccessException - Exception in javax.ejb
This exception indicates that client access to a business method was denied.
EJBAccessException() - Constructor for exception javax.ejb.EJBAccessException
Constructs an EJBAccessException with no detail message.
EJBAccessException(String) - Constructor for exception javax.ejb.EJBAccessException
Constructs an EJBAccessException with the specified detailed message.
ejbActivate() - Method in interface javax.ejb.EntityBean
A container invokes this method when the instance is taken out of the pool of available instances to become associated with a specific EJB object.
ejbActivate() - Method in interface javax.ejb.SessionBean
The activate method is called when the instance is activated from its "passive" state.
EJBContext - Interface in javax.ejb
The EJBContext interface provides an instance with access to the container-provided runtime context of an enterprise Bean instance.
EJBException - Exception in javax.ejb
The EJBException exception is thrown by an enterprise Bean instance to its container to report that the invoked business method or callback method could not be completed because of an unexpected error (e.g. the instance failed to open a database connection).
EJBException() - Constructor for exception javax.ejb.EJBException
Constructs an EJBException with no detail message.
EJBException(String) - Constructor for exception javax.ejb.EJBException
Constructs an EJBException with the specified detailed message.
EJBException(Exception) - Constructor for exception javax.ejb.EJBException
Constructs an EJBException that embeds the originally thrown exception.
EJBException(String, Exception) - Constructor for exception javax.ejb.EJBException
Constructs an EJBException that embeds the originally thrown exception with the specified detail message.
EJBHome - Interface in javax.ejb
The EJBHome interface must be extended by all enterprise Beans' remote home interfaces.
ejbLoad() - Method in interface javax.ejb.EntityBean
A container invokes this method to instruct the instance to synchronize its state by loading it state from the underlying database.
EJBLocalHome - Interface in javax.ejb
The EJBLocalHome interface must be extended by all enterprise Beans' local home interfaces.
EJBLocalObject - Interface in javax.ejb
The EJBLocalObject interface must be extended by all enterprise Beans' local interfaces.
EJBMetaData - Interface in javax.ejb
The EJBMetaData interface allows a client to obtain the enterprise Bean's meta-data information.
EJBMethodPermission - Class in javax.security.jacc
Class for EJB method permissions.
EJBMethodPermission(String, String) - Constructor for class javax.security.jacc.EJBMethodPermission
Creates a new EJBMethodPermission with the specified name and actions.
EJBMethodPermission(String, String, String, String[]) - Constructor for class javax.security.jacc.EJBMethodPermission
Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodName, methodInterface, and methodParams.
EJBMethodPermission(String, String, Method) - Constructor for class javax.security.jacc.EJBMethodPermission
Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodInterface, and the Method object.
EJBObject - Interface in javax.ejb
The EJBObject interface is extended by all enterprise Beans' remote interfaces.
ejbPassivate() - Method in interface javax.ejb.EntityBean
A container invokes this method on an instance before the instance becomes disassociated with a specific EJB object.
ejbPassivate() - Method in interface javax.ejb.SessionBean
The passivate method is called before the instance enters the "passive" state.
ejbRemove() - Method in interface javax.ejb.EntityBean
A container invokes this method before it removes the EJB object that is currently associated with the instance.
ejbRemove() - Method in interface javax.ejb.MessageDrivenBean
A container invokes this method before it ends the life of the message-driven object.
ejbRemove() - Method in interface javax.ejb.SessionBean
A container invokes this method before it ends the life of the session object.
EJBRoleRefPermission - Class in javax.security.jacc
Class for EJB isCallerInRole (String reference) permissions.
EJBRoleRefPermission(String, String) - Constructor for class javax.security.jacc.EJBRoleRefPermission
Creates a new EJBRoleRefPermission with the specified name and actions.
EJBs - Annotation Type in javax.ejb
Declares multiple TYPE-level @EJB annotations.
EJBStats - Interface in javax.management.j2ee.statistics
Specifies statistics provided by all EJB component types.
ejbStore() - Method in interface javax.ejb.EntityBean
A container invokes this method to instruct the instance to synchronize its state by storing it to the underlying database.
ejbTimeout(Timer) - Method in interface javax.ejb.TimedObject
Invoked by the EJB container upon timer expiration.
EJBTransactionRequiredException - Exception in javax.ejb
This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.
EJBTransactionRequiredException() - Constructor for exception javax.ejb.EJBTransactionRequiredException
Constructs an EJBTransactionRequiredException with no detail message.
EJBTransactionRequiredException(String) - Constructor for exception javax.ejb.EJBTransactionRequiredException
Constructs an EJBTransactionRequiredException with the specified detailed message.
EJBTransactionRolledbackException - Exception in javax.ejb
This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back.
EJBTransactionRolledbackException() - Constructor for exception javax.ejb.EJBTransactionRolledbackException
Constructs an EJBTransactionRolledbackException with no detail message.
EJBTransactionRolledbackException(String) - Constructor for exception javax.ejb.EJBTransactionRolledbackException
Constructs an EJBTransactionRolledbackException with the specified detailed message.
EJBTransactionRolledbackException(String, Exception) - Constructor for exception javax.ejb.EJBTransactionRolledbackException
Constructs an EJBTransactionRolledbackException with the specified detail message and a nested exception.
ELContext - Class in javax.el
Context information for expression evaluation.
ELContext() - Constructor for class javax.el.ELContext
ELContextEvent - Class in javax.el
An event which indicates that an ELContext has been created.
ELContextEvent(ELContext) - Constructor for class javax.el.ELContextEvent
Constructs an ELContextEvent object to indicate that an ELContext has been created.
ELContextListener - Interface in javax.el
The listener interface for receiving notification when an ELContext is created.
Element - Interface in javax.xml.bind
This is an element marker interface.
ELException - Exception in javax.el
Represents any of the exception conditions that can arise during expression evaluation.
ELException() - Constructor for exception javax.el.ELException
Creates an ELException with no detail message.
ELException(String) - Constructor for exception javax.el.ELException
Creates an ELException with the provided detail message.
ELException(Throwable) - Constructor for exception javax.el.ELException
Creates an ELException with the given cause.
ELException(String, Throwable) - Constructor for exception javax.el.ELException
Creates an ELException with the given detail message and root cause.
ELException - Exception in javax.servlet.jsp.el
Deprecated. As of JSP 2.1, replaced by ELException
ELException() - Constructor for exception javax.servlet.jsp.el.ELException
Deprecated. Creates an ELException with no detail message.
ELException(String) - Constructor for exception javax.servlet.jsp.el.ELException
Deprecated. Creates an ELException with the provided detail message.
ELException(Throwable) - Constructor for exception javax.servlet.jsp.el.ELException
Deprecated. Creates an ELException with the given root cause.
ELException(String, Throwable) - Constructor for exception javax.servlet.jsp.el.ELException
Deprecated. Creates an ELException with the given detail message and root cause.
ELParseException - Exception in javax.servlet.jsp.el
Deprecated. As of JSP 2.1, replaced by ELException
ELParseException() - Constructor for exception javax.servlet.jsp.el.ELParseException
Deprecated. Creates an ELParseException with no detail message.
ELParseException(String) - Constructor for exception javax.servlet.jsp.el.ELParseException
Deprecated. Creates an ELParseException with the provided detail message.
ELResolver - Class in javax.el
Enables customization of variable and property resolution behavior for EL expression evaluation.
ELResolver() - Constructor for class javax.el.ELResolver
EMAIL_ADDRESS - Static variable in interface javax.xml.registry.LifeCycleManager
EmailAddress - Interface in javax.xml.registry.infomodel
Represents an email address.
Embeddable - Annotation Type in javax.persistence
Defines a class whose instances are stored as an intrinsic part of an owning entity and share the identity of the entity.
Embedded - Annotation Type in javax.persistence
Defines a persistent field or property of an entity whose value is an instance of an embeddable class.
EmbeddedId - Annotation Type in javax.persistence
Is applied to a persistent field or property of an entity class or mapped superclass to denote a composite primary key that is an embeddable class.
encode(OutputStream, String) - Static method in class javax.mail.internet.MimeUtility
Wrap an encoder around the given output stream.
encode(OutputStream, String, String) - Static method in class javax.mail.internet.MimeUtility
Wrap an encoder around the given output stream.
encodeActionURL(String) - Method in class javax.faces.context.ExternalContext
Return the input URL, after performing any rewriting needed to ensure that it will correctly identify an addressable action in the current application.
encodeAll(FacesContext) - Method in class javax.faces.component.UIComponent
If this component returns true from UIComponent.isRendered(), render this component and all its children that return true from isRendered(), regardless of the value of the UIComponent.getRendersChildren() flag.
encodeBegin(FacesContext) - Method in class javax.faces.component.UIComponent
If our rendered property is true, render the beginning of the current state of this UIComponent to the response contained in the specified FacesContext.
encodeBegin(FacesContext) - Method in class javax.faces.component.UIComponentBase
encodeBegin(FacesContext) - Method in class javax.faces.component.UIData
In addition to the default behavior, ensure that any saved per-row state for our child input components is discarded unless it is needed to rerender the current page with errors.
encodeBegin(FacesContext) - Method in class javax.faces.component.UIViewRoot
Override the default UIComponentBase.encodeBegin(javax.faces.context.FacesContext) behavior.
encodeBegin(FacesContext, UIComponent) - Method in class javax.faces.render.Renderer
Render the beginning specified UIComponent to the output stream or writer associated with the response we are creating.
encodeBegin() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Deprecated. No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
encodeChildren(FacesContext) - Method in class javax.faces.component.UIComponent
If our rendered property is true, render the child UIComponents of this UIComponent.
encodeChildren(FacesContext) - Method in class javax.faces.component.UIComponentBase
encodeChildren(FacesContext, UIComponent) - Method in class javax.faces.render.Renderer
Render the child components of this UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.
encodeChildren() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Deprecated. No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
encodedPersonal - Variable in class javax.mail.internet.InternetAddress
The RFC 2047 encoded version of the personal name.
encodeEnd(FacesContext) - Method in class javax.faces.component.UIComponent
If our rendered property is true, render the ending of the current state of this UIComponent.
encodeEnd(FacesContext) - Method in class javax.faces.component.UIComponentBase
encodeEnd(FacesContext) - Method in class javax.faces.component.UIViewRoot
Override the default UIComponentBase.encodeEnd(javax.faces.context.FacesContext) behavior.
encodeEnd(FacesContext, UIComponent) - Method in class javax.faces.render.Renderer
Render the ending of the current state of the specified UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.
encodeEnd() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Deprecated. No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
encodeNamespace(String) - Method in class javax.faces.context.ExternalContext
Return the specified name, after prefixing it with a namespace that ensures that it will be unique within the context of a particular page.
encodeRedirectURL(String) - Method in interface javax.servlet.http.HttpServletResponse
Encodes the specified URL for use in the sendRedirect method or, if encoding is not needed, returns the URL unchanged.
encodeRedirectUrl(String) - Method in interface javax.servlet.http.HttpServletResponse
Deprecated. As of version 2.1, use encodeRedirectURL(String url) instead
encodeRedirectURL(String) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to return encodeRedirectURL(String url) on the wrapped response object.
encodeRedirectUrl(String) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to return encodeRedirectUrl(String url) on the wrapped response object.
encodeResourceURL(String) - Method in class javax.faces.context.ExternalContext
Return the input URL, after performing any rewriting needed to ensure that it will correctly identify an addressable resource in the current application.
encodeText(String) - Static method in class javax.mail.internet.MimeUtility
Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.
encodeText(String, String, String) - Static method in class javax.mail.internet.MimeUtility
Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.
encodeURL(String) - Method in interface javax.servlet.http.HttpServletResponse
Encodes the specified URL by including the session ID in it, or, if encoding is not needed, returns the URL unchanged.
encodeUrl(String) - Method in interface javax.servlet.http.HttpServletResponse
Deprecated. As of version 2.1, use encodeURL(String url) instead
encodeURL(String) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to call encodeURL(String url) on the wrapped response object.
encodeUrl(String) - Method in class javax.servlet.http.HttpServletResponseWrapper
The default behavior of this method is to call encodeUrl(String url) on the wrapped response object.
encodeWord(String) - Static method in class javax.mail.internet.MimeUtility
Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.
encodeWord(String, String, String) - Static method in class javax.mail.internet.MimeUtility
Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.
encodingSet() - Method in interface javax.xml.stream.events.StartDocument
Returns true if CharacterEncodingScheme was set in the encoding declaration of the document
ENCODINGSTYLE_URI_PROPERTY - Static variable in interface javax.xml.rpc.Call
Standard property for encoding Style: Encoding style specified as a namespace URI.
end(Xid, int) - Method in interface javax.transaction.xa.XAResource
Ends the work performed on behalf of a transaction branch.
END_DOCUMENT - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is an end document
END_ELEMENT - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is an end element
endDocument() - Method in class javax.faces.context.ResponseWriter
Write whatever text should end a response.
endDocument() - Method in class javax.faces.context.ResponseWriterWrapper
The default behavior of this method is to call ResponseWriter.endDocument() on the wrapped ResponseWriter object.
EndDocument - Interface in javax.xml.stream.events
A marker interface for the end of the document
endElement(String) - Method in class javax.faces.context.ResponseWriter
Write the end of an element, after closing any open element created by a call to startElement().
endElement(String) - Method in class javax.faces.context.ResponseWriterWrapper
The default behavior of this method is to call ResponseWriter.endElement(String) on the wrapped ResponseWriter object.
EndElement - Interface in javax.xml.stream.events
An interface for the end element event.
Endpoint - Class in javax.xml.ws
A Web service endpoint.
Endpoint() - Constructor for class javax.xml.ws.Endpoint
ENDPOINT_ADDRESS_PROPERTY - Static variable in interface javax.xml.rpc.Stub
Standard property: Target service endpoint address.
ENDPOINT_ADDRESS_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider
Standard property: Target service endpoint address.
endpointActivation(MessageEndpointFactory, ActivationSpec) - Method in interface javax.resource.spi.ResourceAdapter
This is called during the activation of a message endpoint.
endpointDeactivation(MessageEndpointFactory, ActivationSpec) - Method in interface javax.resource.spi.ResourceAdapter
This is called when a message endpoint is deactivated.
enlistResource(XAResource) - Method in interface javax.transaction.Transaction
Enlist the resource specified with the transaction associated with the target Transaction object.
EnterpriseBean - Interface in javax.ejb
The EnterpriseBean interface must be implemented by every enterprise Bean class.
Entity - Annotation Type in javax.persistence
Specifies that the class is an entity.
ENTITY_DECLARATION - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates a Entity Declaration
ENTITY_REFERENCE - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is an entity reference
EntityBean - Interface in javax.ejb
The EntityBean interface is implemented by every entity enterprise Bean class.
EntityBeanStats - Interface in javax.management.j2ee.statistics
Specifies statistics provided by entity beans.
EntityContext - Interface in javax.ejb
The EntityContext interface provides an instance with access to the container-provided runtime context of an entity enterprise Bean instance.
EntityDeclaration - Interface in javax.xml.stream.events
An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
EntityExistsException - Exception in javax.persistence
Thrown by the persistence provider when EntityManager.persist(Object) is called and the entity already exists.
EntityExistsException() - Constructor for exception javax.persistence.EntityExistsException
Constructs a new EntityExistsException exception with null as its detail message.
EntityExistsException(String) - Constructor for exception javax.persistence.EntityExistsException
Constructs a new EntityExistsException exception with the specified detail message.
EntityExistsException(String, Throwable) - Constructor for exception javax.persistence.EntityExistsException
Constructs a new EntityExistsException exception with the specified detail message and cause.
EntityExistsException(Throwable) - Constructor for exception javax.persistence.EntityExistsException
Constructs a new EntityExistsException exception with the specified cause.
EntityListeners - Annotation Type in javax.persistence
Specifies the callback listener classes to be used for an entity or mapped superclass.
EntityManager - Interface in javax.persistence
Interface used to interact with the persistence context.
EntityManagerFactory - Interface in javax.persistence
The EntityManagerFactory interface is used by the application to obtain an application-managed entity manager.
EntityNotFoundException - Exception in javax.persistence
Thrown by the persistence provider when an entity reference obtained by EntityManager.getReference(Class,Object) is accessed but the entity does not exist.
EntityNotFoundException() - Constructor for exception javax.persistence.EntityNotFoundException
Constructs a new EntityNotFoundException exception with null as its detail message.
EntityNotFoundException(String) - Constructor for exception javax.persistence.EntityNotFoundException
Constructs a new EntityNotFoundException exception with the specified detail message.
EntityReference - Interface in javax.xml.stream.events
An interface for handling Entity events.
EntityResult - Annotation Type in javax.persistence
References an entity in the SELECT clause of a SQL query.
EntityTransaction - Interface in javax.persistence
The EntityTransaction interface is used to control resource transactions on resource-local entity managers.
entries() - Method in interface javax.enterprise.deploy.model.DeployableObject
Returns an enumeration of the module file entries.
ENUM_ID - Static variable in class javax.faces.convert.EnumConverter
The message identifier of the FacesMessage to be created if the conversion to Enum fails.
ENUM_NO_CLASS_ID - Static variable in class javax.faces.convert.EnumConverter
The message identifier of the FacesMessage to be created if the conversion to Enum fails and no target class has been provided.
EnumConverter - Class in javax.faces.convert
Converter implementation for java.lang.Enum (and enum primitive) values.
EnumConverter() - Constructor for class javax.faces.convert.EnumConverter
EnumConverter(Class) - Constructor for class javax.faces.convert.EnumConverter
Enumerated - Annotation Type in javax.persistence
Specifies that a persistent property or field should be persisted as a enumerated type.
EnumType - Enum in javax.persistence
Defines mapping for the enumerated types.
ENVELOPE - Static variable in class javax.mail.FetchProfile.Item
This is the Envelope item.
ENVELOPE_CHANGED - Static variable in class javax.mail.event.MessageChangedEvent
The message's envelope (headers, but not body) changed.
EOF - Static variable in class javax.mail.internet.HeaderTokenizer.Token
Token type indicating end of input.
EQ - Static variable in class javax.mail.search.ComparisonTerm
equals(DataFlavor) - Method in class javax.activation.ActivationDataFlavor
Compares the DataFlavor passed in with this DataFlavor; calls the isMimeTypeEqual method.
equals(Object) - Method in class javax.el.Expression
Determines whether the specified object is equal to this Expression.
equals(Object) - Method in class javax.faces.validator.DoubleRangeValidator
equals(Object) - Method in class javax.faces.validator.LengthValidator
equals(Object) - Method in class javax.faces.validator.LongRangeValidator
equals(Object) - Method in class javax.mail.Address
The equality operator.
equals(Object) - Method in class javax.mail.Flags
Check whether the two Flags objects are equal.
equals(Object) - Method in class javax.mail.internet.InternetAddress
The equality operator.
equals(Object) - Method in class javax.mail.internet.NewsAddress
The equality operator.
equals(Object) - Method in class javax.mail.search.AddressStringTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.AddressTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.AndTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.BodyTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.ComparisonTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.DateTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.FlagTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.FromStringTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.FromTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.HeaderTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.IntegerComparisonTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.MessageIDTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.MessageNumberTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.NotTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.OrTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.ReceivedDateTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.RecipientStringTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.RecipientTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.SentDateTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.SizeTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.StringTerm
Equality comparison.
equals(Object) - Method in class javax.mail.search.SubjectTerm
Equality comparison.
equals(Object) - Method in class javax.mail.URLName
Compares two URLNames.
equals(Object) - Method in interface javax.resource.cci.Record
Check if this instance is equal to another Record.
equals(Object) - Method in interface javax.resource.spi.ConnectionRequestInfo
Checks whether this instance is equal to another.
equals(Object) - Method in interface javax.resource.spi.ManagedConnectionFactory
Check if this ManagedConnectionFactory is equal to another ManagedConnectionFactory.
equals(Object) - Method in interface javax.resource.spi.security.GenericCredential
Deprecated. Tests if this GenericCredential instance refers to the same entity as the supplied object.
equals(Object) - Method in class javax.resource.spi.security.PasswordCredential
Compares this PasswordCredential with the specified object for equality.
equals(Object) - Method in class javax.security.jacc.EJBMethodPermission
Checks two EJBMethodPermission objects for equality.
equals(Object) - Method in class javax.security.jacc.EJBRoleRefPermission
Checks two EJBRoleRefPermission objects for equality.
equals(Object) - Method in class javax.security.jacc.WebResourcePermission
Checks two WebResourcePermission objects for equality.
equals(Object) - Method in class javax.security.jacc.WebRoleRefPermission
Checks two WebRoleRefPermission objects for equality.
equals(Object) - Method in class javax.security.jacc.WebUserDataPermission
Checks two WebUserDataPermission objects for equality.
ERROR - Static variable in interface javax.xml.bind.ValidationEvent
Conditions that correspond to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation
errorCode - Variable in exception javax.transaction.SystemException
The error code with which to create the SystemException.
errorCode - Variable in exception javax.transaction.xa.XAException
The error code with which to create the SystemException.
ErrorData - Class in javax.servlet.jsp
Contains information about an error, for error pages.
ErrorData(Throwable, int, String, String) - Constructor for class javax.servlet.jsp.ErrorData
Creates a new ErrorData object.
EVAL_BODY_AGAIN - Static variable in interface javax.servlet.jsp.tagext.IterationTag
Request the reevaluation of some body.
EVAL_BODY_BUFFERED - Static variable in interface javax.servlet.jsp.tagext.BodyTag
Request the creation of new buffer, a BodyContent on which to evaluate the body of this tag.
EVAL_BODY_INCLUDE - Static variable in interface javax.servlet.jsp.tagext.Tag
Evaluate body into existing out stream.
EVAL_BODY_TAG - Static variable in interface javax.servlet.jsp.tagext.BodyTag
Deprecated. As of Java JSP API 1.2, use BodyTag.EVAL_BODY_BUFFERED or IterationTag.EVAL_BODY_AGAIN.
EVAL_PAGE - Static variable in interface javax.servlet.jsp.tagext.Tag
Continue evaluating the page.
evaluate(VariableResolver) - Method in class javax.servlet.jsp.el.Expression
Deprecated. Evaluates an expression that was previously prepared.
evaluate(String, Class, VariableResolver, FunctionMapper) - Method in class javax.servlet.jsp.el.ExpressionEvaluator
Deprecated. Evaluates an expression.
evaluateExpressionGet(FacesContext, String, Class) - Method in class javax.faces.application.Application
Get a value by evaluating an expression.
EvaluationException - Exception in javax.faces.el
Deprecated. This has been replaced by ELException.
EvaluationException() - Constructor for exception javax.faces.el.EvaluationException
Deprecated. Construct a new exception with no detail message or root cause.
EvaluationException(String) - Constructor for exception javax.faces.el.EvaluationException
Deprecated. Construct a new exception with the specified detail message and no root cause.
EvaluationException(Throwable) - Constructor for exception javax.faces.el.EvaluationException
Deprecated. Construct a new exception with the specified root cause.
EvaluationException(String, Throwable) - Constructor for exception javax.faces.el.EvaluationException
Deprecated. Construct a new exception with the specified detail message and root cause.
EVENT_TYPE_CREATED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent
An event where a RegistryObject is created.
EVENT_TYPE_DELETED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent
An event where a RegistryObject is deleted.
EVENT_TYPE_DEPRECATED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent
An event where a RegistryObject is deprecated.
EVENT_TYPE_UNDEPRECATED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent
An event where a RegistryObject is undeprecated.
EVENT_TYPE_UPDATED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent
An event where a RegistryObject is updated.
EVENT_TYPE_VERSIONED - Static variable in interface javax.xml.registry.infomodel.AuditableEvent
An event where a RegistryObject is versioned.
EventFilter - Interface in javax.xml.stream
This interface declares a simple filter interface that one can create to filter XMLEventReaders
EventReaderDelegate - Class in javax.xml.stream.util
This is the base class for deriving an XMLEventReader filter.
EventReaderDelegate() - Constructor for class javax.xml.stream.util.EventReaderDelegate
Construct an empty filter with no parent.
EventReaderDelegate(XMLEventReader) - Constructor for class javax.xml.stream.util.EventReaderDelegate
Construct an filter with the specified parent.
EXACT_NAME_MATCH - Static variable in interface javax.xml.registry.FindQualifier
examineAllHeaderElements() - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.
examineHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor.
examineMustUnderstandHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.
EXCEPTION - Static variable in class javax.servlet.jsp.PageContext
Name used to store uncaught exception in ServletRequest attribute list and PageContext name table.
ExceptionListener - Interface in javax.jms
If a JMS provider detects a serious problem with a Connection object, it informs the Connection object's ExceptionListener, if one has been registered.
ExcludeClassInterceptors - Annotation Type in javax.interceptor
Used to exclude class-level interceptors for a business method.
ExcludeDefaultInterceptors - Annotation Type in javax.interceptor
Used to exclude default interceptors for a bean or a business method.
ExcludeDefaultListeners - Annotation Type in javax.persistence
Specifies that the invocation of default listeners is to be excluded for the entity class (or mapped superclass) and its subclasses.
ExcludeSuperclassListeners - Annotation Type in javax.persistence
Specifies that the invocation of superclass listeners is to be excluded for the entity class (or mapped superclass) and its subclasses.
excludeUnlistedClasses() - Method in interface javax.persistence.spi.PersistenceUnitInfo
Returns whether classes in the root of the persistence unit that have not been explicitly listed are to be included in the set of managed classes.
EXECUTE - Static variable in class javax.enterprise.deploy.shared.ActionType
The DeploymentManager action command is executing.
execute() - Method in interface javax.enterprise.deploy.spi.status.ClientConfiguration
This method performs an exec and starts the application client running in another process.
execute(FacesContext) - Method in class javax.faces.lifecycle.Lifecycle
Execute all of the phases of the request processing lifecycle, up to but not including the Render Response phase, as described in the JavaServer Faces Specification, in the specified order.
execute(InteractionSpec, Record, Record) - Method in interface javax.resource.cci.Interaction
Executes an interaction represented by the InteractionSpec.
execute(InteractionSpec, Record) - Method in interface javax.resource.cci.Interaction
Executes an interaction represented by the InteractionSpec.
executeQuery(Query) - Method in interface javax.xml.registry.DeclarativeQueryManager
Executes a query as specified by query parameter.
executeUpdate() - Method in interface javax.persistence.Query
Execute an update or delete statement.
ExecutionContext - Class in javax.resource.spi.work
This class models an execution context (transaction, security, etc) with which the Work instance must be executed.
ExecutionContext() - Constructor for class javax.resource.spi.work.ExecutionContext
exists() - Method in class javax.mail.Folder
Tests if this folder physically exists on the Store.
Expression - Class in javax.el
Base class for the expression subclasses ValueExpression and MethodExpression, implementing characterstics common to both.
Expression() - Constructor for class javax.el.Expression
Expression - Class in javax.servlet.jsp.el
Deprecated. As of JSP 2.1, replaced by ValueExpression
Expression() - Constructor for class javax.servlet.jsp.el.Expression
Deprecated.
ExpressionEvaluator - Class in javax.servlet.jsp.el
Deprecated. As of JSP 2.1, replaced by ExpressionFactory
ExpressionEvaluator() - Constructor for class javax.servlet.jsp.el.ExpressionEvaluator
Deprecated.
ExpressionFactory - Class in javax.el
Parses a String into a ValueExpression or MethodExpression instance for later evaluation.
ExpressionFactory() - Constructor for class javax.el.ExpressionFactory
expunge() - Method in class javax.mail.Folder
Expunge (permanently remove) messages marked DELETED.
expunged - Variable in class javax.mail.Message
True if this message has been expunged.
ExtensibleObject - Interface in javax.xml.registry.infomodel
An ExtensibleObject is one that allows itself to be extended by utilizing dynamically added Slots that add arbitrary attributes to the object on a per instance basis.
EXTERNAL_IDENTIFIER - Static variable in interface javax.xml.registry.LifeCycleManager
EXTERNAL_LINK - Static variable in interface javax.xml.registry.LifeCycleManager
ExternalContext - Class in javax.faces.context
This class allows the Faces API to be unaware of the nature of its containing application environment.
ExternalContext() - Constructor for class javax.faces.context.ExternalContext
ExternalIdentifier - Interface in javax.xml.registry.infomodel
ExternalIdentifier instances provide the additional identifier information to RegistryObjects such as DUNS number, Social Security Number, or an alias name of the organization.
ExternalLink - Interface in javax.xml.registry.infomodel
ExternalLink instances model a named URI to content that may reside outside the registry.
extractAllHeaderElements() - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.
extractContentAsDocument() - Method in interface javax.xml.soap.SOAPBody
Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.
extractHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.
EXTRINSIC_OBJECT - Static variable in interface javax.xml.registry.LifeCycleManager
ExtrinsicObject - Interface in javax.xml.registry.infomodel
ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).

F

FACES_CONTEXT_FACTORY - Static variable in class javax.faces.FactoryFinder
The property name for the FacesContextFactory class name.
FACES_MESSAGES - Static variable in class javax.faces.application.FacesMessage
ResourceBundle identifier for messages whose message identifiers are defined in the JavaServer Faces specification.
FacesContext - Class in javax.faces.context
FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
FacesContext() - Constructor for class javax.faces.context.FacesContext
FacesContextFactory - Class in javax.faces.context
FacesContextFactory is a factory object that creates (if needed) and returns new FacesContext instances, initialized for the processing of the specified request and response objects.
FacesContextFactory() - Constructor for class javax.faces.context.FacesContextFactory
FacesEvent - Class in javax.faces.event
FacesEvent is the base class for user interface and application events that can be fired by UIComponents.
FacesEvent(UIComponent) - Constructor for class javax.faces.event.FacesEvent
Construct a new event object from the specified source component.
FacesException - Exception in javax.faces
This class encapsulates general JavaServer Faces exceptions.
FacesException() - Constructor for exception javax.faces.FacesException
Construct a new exception with no detail message or root cause.
FacesException(String) - Constructor for exception javax.faces.FacesException
Construct a new exception with the specified detail message and no root cause.
FacesException(Throwable) - Constructor for exception javax.faces.FacesException
Construct a new exception with the specified root cause.
FacesException(String, Throwable) - Constructor for exception javax.faces.FacesException
Construct a new exception with the specified detail message and root cause.
FacesListener - Interface in javax.faces.event
A generic base interface for event listeners for various types of FacesEvents.
FacesMessage - Class in javax.faces.application
FacesMessage represents a single validation (or other) message, which is typically associated with a particular component in the view.
FacesMessage() - Constructor for class javax.faces.application.FacesMessage
Construct a new FacesMessage with no initial values.
FacesMessage(String) - Constructor for class javax.faces.application.FacesMessage
Construct a new FacesMessage with just a summary.
FacesMessage(String, String) - Constructor for class javax.faces.application.FacesMessage
Construct a new FacesMessage with the specified initial values.
FacesMessage(FacesMessage.Severity, String, String) - Constructor for class javax.faces.application.FacesMessage
Construct a new FacesMessage with the specified initial values.
FacesMessage.Severity - Class in javax.faces.application
Class used to represent message severity levels in a typesafe enumeration.
FacesServlet - Class in javax.faces.webapp
FacesServlet is a servlet that manages the request processing lifecycle for web applications that are utilizing JavaServer Faces to construct the user interface.
FacesServlet() - Constructor for class javax.faces.webapp.FacesServlet
FacetTag - Class in javax.faces.webapp
FacetTag is the JSP mechanism for denoting a UIComponent is to be added as a facet to the component associated with its parent.
FacetTag() - Constructor for class javax.faces.webapp.FacetTag
FactoryConfigurationError - Error in javax.xml.stream
An error class for reporting factory configuration errors.
FactoryConfigurationError() - Constructor for error javax.xml.stream.FactoryConfigurationError
Default constructor
FactoryConfigurationError(Exception) - Constructor for error javax.xml.stream.FactoryConfigurationError
Construct an exception with a nested inner exception
FactoryConfigurationError(Exception, String) - Constructor for error javax.xml.stream.FactoryConfigurationError
Construct an exception with a nested inner exception and a message
FactoryConfigurationError(String, Exception) - Constructor for error javax.xml.stream.FactoryConfigurationError
Construct an exception with a nested inner exception and a message
FactoryConfigurationError(String) - Constructor for error javax.xml.stream.FactoryConfigurationError
Construct an exception with associated message
FactoryFinder - Class in javax.faces
FactoryFinder implements the standard discovery algorithm for all factory objects specified in the JavaServer Faces APIs.
FAILED - Static variable in class javax.enterprise.deploy.shared.StateType
The action operation has failed.
FATAL_ERROR - Static variable in interface javax.xml.bind.ValidationEvent
Conditions that correspond to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation
FederatedConnection - Interface in javax.xml.registry
Represents a single logical connection to a federation or group of registry providers.
fetch(Message[], FetchProfile) - Method in class javax.mail.Folder
Prefetch the items specified in the FetchProfile for the given Messages.
FetchProfile - Class in javax.mail
Clients use a FetchProfile to list the Message attributes that it wishes to prefetch from the server for a range of messages.
FetchProfile() - Constructor for class javax.mail.FetchProfile
Create an empty FetchProfile.
FetchProfile.Item - Class in javax.mail
This inner class is the base class of all items that can be requested in a FetchProfile.
FetchProfile.Item(String) - Constructor for class javax.mail.FetchProfile.Item
Constructor for an item.
FetchType - Enum in javax.persistence
Defines strategies for fetching data from the database.
FieldResult - Annotation Type in javax.persistence
Is used to map the columns specified in the SELECT list of the query to the properties or fields of the entity class.
FileDataSource - Class in javax.activation
The FileDataSource class implements a simple DataSource object that encapsulates a file.
FileDataSource(File) - Constructor for class javax.activation.FileDataSource
Creates a FileDataSource from a File object.
FileDataSource(String) - Constructor for class javax.activation.FileDataSource
Creates a FileDataSource from the specified path name.
FileTypeMap - Class in javax.activation
The FileTypeMap is an abstract class that provides a data typing interface for files.
FileTypeMap() - Constructor for class javax.activation.FileTypeMap
The default constructor.
Filter - Interface in javax.servlet
A filter is an object that performs filtering tasks on either the request to a resource (a servlet or static content), or on the response from a resource, or both.
FilterChain - Interface in javax.servlet
A FilterChain is an object provided by the servlet container to the developer giving a view into the invocation chain of a filtered request for a resource.
FilterConfig - Interface in javax.servlet
A filter configuration object used by a servlet container to pass information to a filter during initialization.
finalize() - Method in class javax.mail.Folder
finalize() - Method in class javax.mail.Service
Stop the event dispatcher thread so the queue can be garbage collected.
finalize() - Method in class javax.mail.util.SharedFileInputStream
Force this stream to close.
find(Class<T>, Object) - Method in interface javax.persistence.EntityManager
Find by primary key.
findAncestorWithClass(JspTag, Class<?>) - Static method in class javax.servlet.jsp.tagext.SimpleTagSupport
Find the instance of a given class type that is closest to a given instance.
findAncestorWithClass(Tag, Class) - Static method in class javax.servlet.jsp.tagext.TagSupport
Find the instance of a given class type that is closest to a given instance.
findAssociations(Collection, String, String, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all Association objects that match all of the criteria specified by the parameters of this call.
findAttribute(String) - Method in class javax.servlet.jsp.JspContext
Searches for the named attribute in page, request, session (if valid), and application scope(s) in order and returns the value associated or null.
findCallerAssociations(Collection, Boolean, Boolean, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all Association objects owned by the caller that match all of the criteria specified by the parameters of this call.
findClassificationSchemeByName(Collection, String) - Method in interface javax.xml.registry.BusinessQueryManager
Finds a ClassificationScheme by name based on the specified find qualifiers and name pattern.
findClassificationSchemes(Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all ClassificationScheme objects that match all of the criteria specified by the parameters of this call.
findComponent(String) - Method in class javax.faces.component.UIComponent
Search for and return the UIComponent with an id that matches the specified search expression (if any), according to the algorithm described below.
findComponent(String) - Method in class javax.faces.component.UIComponentBase
findComponent(FacesContext) - Method in class javax.faces.webapp.UIComponentClassicTagBase
Find and return the UIComponent, from the component tree, that corresponds to this tag handler instance.
findConceptByPath(String) - Method in interface javax.xml.registry.BusinessQueryManager
Finds a Concept based on the path specified.
findConcepts(Collection, Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all Concept objects that match all of the criteria specified by the parameters of this call.
FinderException - Exception in javax.ejb
The FinderException exception must be included in the throws clause of every findMETHOD(...) method of an entity Bean's home interface.
FinderException() - Constructor for exception javax.ejb.FinderException
Constructs an FinderException with no detail message.
FinderException(String) - Constructor for exception javax.ejb.FinderException
Constructs an FinderException with the specified detail message.
FindException - Exception in javax.xml.registry
A RegistryException that occurs during a find action.
FindException() - Constructor for exception javax.xml.registry.FindException
Constructs a JAXRException object with no reason or embedded Throwable.
FindException(String) - Constructor for exception javax.xml.registry.FindException
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
FindException(String, Throwable) - Constructor for exception javax.xml.registry.FindException
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
FindException(Throwable) - Constructor for exception javax.xml.registry.FindException
Constructs a JAXRException object initialized with the given Throwable object.
findOrganizations(Collection, Collection, Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all Organization objects that match all of the criteria specified by the parameters of this call.
FindQualifier - Interface in javax.xml.registry
FindQualifier provides various constants that identify options that effect find method behavior.
findRegistryPackages(Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all RegistryPackage objects that match all of the criteria specified by the parameters of this call.
findServiceBindings(Key, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all ServiceBinding objects that match all of the criteria specified by the parameters of this call.
findServices(Key, Collection, Collection, Collection, Collection) - Method in interface javax.xml.registry.BusinessQueryManager
Finds all Service objects that match all of the criteria specified by the parameters of this call.
fireXpathEvent(XpathEvent) - Method in interface javax.enterprise.deploy.model.XpathListener
FLAGGED - Static variable in class javax.mail.Flags.Flag
This message is flagged.
FLAGS - Static variable in class javax.mail.FetchProfile.Item
This is the Flags item.
Flags - Class in javax.mail
The Flags class represents the set of flags on a Message.
Flags() - Constructor for class javax.mail.Flags
Construct an empty Flags object.
Flags(Flags) - Constructor for class javax.mail.Flags
Construct a Flags object initialized with the given flags.
Flags(Flags.Flag) - Constructor for class javax.mail.Flags
Construct a Flags object initialized with the given system flag.
Flags(String) - Constructor for class javax.mail.Flags
Construct a Flags object initialized with the given user flag.
flags - Variable in class javax.mail.internet.MimeMessage
The Flags for this message.
flags - Variable in class javax.mail.search.FlagTerm
Flags object containing the flags to test.
Flags.Flag - Class in javax.mail
This inner class represents an individual system flag.
FLAGS_CHANGED - Static variable in class javax.mail.event.MessageChangedEvent
The message's flags changed.
FlagTerm - Class in javax.mail.search
This class implements comparisons for Message Flags.
FlagTerm(Flags, boolean) - Constructor for class javax.mail.search.FlagTerm
Constructor.
FLOAT_ID - Static variable in class javax.faces.convert.FloatConverter
The message identifier of the FacesMessage to be created if the conversion to Float fails.
FloatConverter - Class in javax.faces.convert
Converter implementation for java.lang.Float (and float primitive) values.
FloatConverter() - Constructor for class javax.faces.convert.FloatConverter
FloatHolder - Class in javax.xml.rpc.holders
FloatHolder() - Constructor for class javax.xml.rpc.holders.FloatHolder
FloatHolder(float) - Constructor for class javax.xml.rpc.holders.FloatHolder
FloatWrapperHolder - Class in javax.xml.rpc.holders
FloatWrapperHolder() - Constructor for class javax.xml.rpc.holders.FloatWrapperHolder
FloatWrapperHolder(Float) - Constructor for class javax.xml.rpc.holders.FloatWrapperHolder
flush() - Method in class javax.faces.context.ResponseWriter
Flush any ouput buffered by the output method to the underlying Writer or OutputStream.
flush() - Method in class javax.faces.context.ResponseWriterWrapper
The default behavior of this method is to call ResponseWriter.flush() on the wrapped ResponseWriter object.
flush() - Method in interface javax.persistence.EntityManager
Synchronize the persistence context to the underlying database.
flush() - Method in class javax.servlet.jsp.JspWriter
Flush the stream.
flush() - Method in class javax.servlet.jsp.tagext.BodyContent
Redefined flush() so it is not legal.
flush() - Method in interface javax.xml.stream.XMLEventWriter
Writes any cached events to the underlying output mechanism
flush() - Method in interface javax.xml.stream.XMLStreamWriter
Write any cached data to the underlying output mechanism.
flushBuffer() - Method in interface javax.servlet.ServletResponse
Forces any content in the buffer to be written to the client.
flushBuffer() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to call flushBuffer() on the wrapped response object.
FlushModeType - Enum in javax.persistence
Flush mode setting.
fold(int, String) - Static method in class javax.mail.internet.MimeUtility
Fold a string at linear whitespace so that each line is no longer than 76 characters, if possible.
folder - Variable in class javax.mail.event.FolderEvent
The folder the event occurred on.
Folder - Class in javax.mail
Folder is an abstract class that represents a folder for mail messages.
Folder(Store) - Constructor for class javax.mail.Folder
Constructor that takes a Store object.
folder - Variable in class javax.mail.Message
The containing folder, if this message is obtained from a folder
FolderAdapter - Class in javax.mail.event
The adapter which receives Folder events.
FolderAdapter() - Constructor for class javax.mail.event.FolderAdapter
FolderClosedException - Exception in javax.mail
This exception is thrown when a method is invoked on a Messaging object and the Folder that owns that object has died due to some reason.
FolderClosedException(Folder) - Constructor for exception javax.mail.FolderClosedException
Constructor
FolderClosedException(Folder, String) - Constructor for exception javax.mail.FolderClosedException
Constructor
folderCreated(FolderEvent) - Method in class javax.mail.event.FolderAdapter
folderCreated(FolderEvent) - Method in interface javax.mail.event.FolderListener
Invoked when a Folder is created.
folderDeleted(FolderEvent) - Method in class javax.mail.event.FolderAdapter
folderDeleted(FolderEvent) - Method in interface javax.mail.event.FolderListener
Invoked when a folder is deleted.
FolderEvent - Class in javax.mail.event
This class models Folder existence events.
FolderEvent(Object, Folder, int) - Constructor for class javax.mail.event.FolderEvent
Constructor.
FolderEvent(Object, Folder, Folder, int) - Constructor for class javax.mail.event.FolderEvent
Constructor.
FolderListener - Interface in javax.mail.event
This is the Listener interface for Folder events.
FolderNotFoundException - Exception in javax.mail
This exception is thrown by Folder methods, when those methods are invoked on a non existent folder.
FolderNotFoundException() - Constructor for exception javax.mail.FolderNotFoundException
Constructs a MessagingException with no detail message.
FolderNotFoundException(Folder) - Constructor for exception javax.mail.FolderNotFoundException
Constructs a MessagingException with the specified folder.
FolderNotFoundException(Folder, String) - Constructor for exception javax.mail.FolderNotFoundException
Constructs a MessagingException with the specified folder and the specified detail message.
FolderNotFoundException(String, Folder) - Constructor for exception javax.mail.FolderNotFoundException
Constructs a MessagingException with the specified detail message and the specified folder.
folderRenamed(FolderEvent) - Method in class javax.mail.event.FolderAdapter
folderRenamed(FolderEvent) - Method in interface javax.mail.event.FolderListener
Invoked when a folder is renamed.
forget(Xid) - Method in interface javax.resource.spi.XATerminator
Tells the resource manager to forget about a heuristically completed transaction branch.
forget(Xid) - Method in interface javax.transaction.xa.XAResource
Tells the resource manager to forget about a heuristically completed transaction branch.
FORM_AUTH - Static variable in class javax.faces.context.ExternalContext
String identifier for FORM authentication.
FORM_AUTH - Static variable in interface javax.servlet.http.HttpServletRequest
String identifier for Form authentication.
format(Date, StringBuffer, FieldPosition) - Method in class javax.mail.internet.MailDateFormat
Formats the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.
forward(String) - Method in class javax.servlet.jsp.PageContext
This method is used to re-direct, or "forward" the current ServletRequest and ServletResponse to another active component in the application.
forward(ServletRequest, ServletResponse) - Method in interface javax.servlet.RequestDispatcher
Forwards a request from a servlet to another resource (servlet, JSP file, or HTML file) on the server.
FromStringTerm - Class in javax.mail.search
This class implements string comparisons for the From Address header.
FromStringTerm(String) - Constructor for class javax.mail.search.FromStringTerm
Constructor.
FromTerm - Class in javax.mail.search
This class implements comparisons for the From Address header.
FromTerm(Address) - Constructor for class javax.mail.search.FromTerm
Constructor
fullURL - Variable in class javax.mail.URLName
The full version of the URL
FunctionInfo - Class in javax.servlet.jsp.tagext
Information for a function in a Tag Library.
FunctionInfo(String, String, String) - Constructor for class javax.servlet.jsp.tagext.FunctionInfo
Constructor for FunctionInfo.
FunctionMapper - Class in javax.el
The interface to a map between EL function names and methods.
FunctionMapper() - Constructor for class javax.el.FunctionMapper
FunctionMapper - Interface in javax.servlet.jsp.el
Deprecated. As of JSP 2.1, replaced by FunctionMapper
functions - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo
An array describing the functions that are defined in this tag library.

G

GE - Static variable in class javax.mail.search.ComparisonTerm
Generated - Annotation Type in javax.annotation
The Generated annoation is used to mark source code that has been generated.
GeneratedValue - Annotation Type in javax.persistence
Provides for the specification of generation strategies for the values of primary keys.
generateSchema(SchemaOutputResolver) - Method in class javax.xml.bind.JAXBContext
Generates the schema documents for this context.
GenerationType - Enum in javax.persistence
Defines the types of primary key generation.
GenericCredential - Interface in javax.resource.spi.security
Deprecated. The preferred way to represent generic credential information is via the org.ietf.jgss.GSSCredential interface in J2SE Version 1.4, which provides similar functionality.
GenericHandler - Class in javax.xml.rpc.handler
The javax.xml.rpc.handler.GenericHandler class implements the Handler interface.
GenericHandler() - Constructor for class javax.xml.rpc.handler.GenericHandler
Default constructor
GenericServlet - Class in javax.servlet
Defines a generic, protocol-independent servlet.
GenericServlet() - Constructor for class javax.servlet.GenericServlet
Does nothing.
get(String) - Method in class javax.activation.MimeTypeParameterList
Retrieve the value associated with the given name, or null if there is no current association.
get(String) - Method in class javax.mail.internet.ParameterList
Returns the value of the specified parameter.
get(Object) - Method in class javax.xml.soap.SOAPConnection
Gets a message from a specific endpoint and blocks until it receives,
getAccept() - Method in class javax.faces.component.html.HtmlForm
Return the value of the accept property.
getAcceptcharset() - Method in class javax.faces.component.html.HtmlForm
Return the value of the acceptcharset property.
getAccesskey() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the accesskey property.
getAccesskey() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the accesskey property.
getAccesskey() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the accesskey property.
getAccesskey() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the accesskey property.
getAccesskey() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the accesskey property.
getAccesskey() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the accesskey property.
getAccesskey() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the accesskey property.
getAccesskey() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the accesskey property.
getAccesskey() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the accesskey property.
getAccesskey() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the accesskey property.
getAccesskey() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the accesskey property.
getAccesskey() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the accesskey property.
getAccesskey() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the accesskey property.
getAccesskey() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the accesskey property.
getAccessURI() - Method in interface javax.xml.registry.infomodel.ServiceBinding
Gets the URI that gives access to the service via this binding.
getAcknowledgeMode() - Method in interface javax.jms.Session
Returns the acknowledgement mode of the session.
getAction() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
Retrieve the deployment ActionType for this event.
getAction() - Method in interface javax.faces.component.ActionSource
Deprecated. This has been replaced by ActionSource2.getActionExpression().
getAction() - Method in class javax.faces.component.UICommand
Deprecated. This has been replaced by UICommand.getActionExpression().
getActionExpression() - Method in interface javax.faces.component.ActionSource2
Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
getActionExpression() - Method in class javax.faces.component.UICommand
getActionListener() - Method in class javax.faces.application.Application
Return the default ActionListener to be registered for all ActionSource components in this appication.
getActionListener() - Method in interface javax.faces.component.ActionSource
Deprecated. Use ActionSource.getActionListeners() instead.
getActionListener() - Method in class javax.faces.component.UICommand
Deprecated. Use UICommand.getActionListeners() instead.
getActionListeners() - Method in interface javax.faces.component.ActionSource
Return the set of registered ActionListeners for this ActionSource instance.
getActionListeners() - Method in class javax.faces.component.UICommand
getActions() - Method in class javax.security.jacc.EJBMethodPermission
Returns a String containing a canonical representation of the actions of this EJBMethodPermission.
getActions() - Method in class javax.security.jacc.EJBRoleRefPermission
Returns a canonical String representation of the actions of this EJBRoleRefPermission.
getActions() - Method in class javax.security.jacc.WebResourcePermission
Returns a canonical String representation of the actions of this WebResourcePermission.
getActions() - Method in class javax.security.jacc.WebRoleRefPermission
Returns a canonical String representation of the actions of this WebRoleRefPermission.
getActions() - Method in class javax.security.jacc.WebUserDataPermission
Returns a canonical String representation of the actions of this WebUserDataPermission.
getActionType(int) - Static method in class javax.enterprise.deploy.shared.ActionType
Return an object of the specified value.
getActionURL(FacesContext, String) - Method in class javax.faces.application.ViewHandler
Return a URL suitable for rendering (after optional encoding performed by the encodeActionURL() method of ExternalContext) that selects the specified view identifier.
getActionURL(FacesContext, String) - Method in class javax.faces.application.ViewHandlerWrapper
The default behavior of this method is to call ViewHandler.getActionURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
getActiveCount() - Method in interface javax.management.j2ee.statistics.JTAStats
Number of active transactions.
getActor() - Method in interface javax.xml.soap.SOAPHeaderElement
Returns the uri of the actor attribute of this SOAPHeaderElement.
getAdaptee() - Method in class javax.servlet.jsp.tagext.TagAdapter
Gets the tag that is being adapted to the Tag interface.
getAdapter(Class<A>) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
getAdapter(Class<A>) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
getAdapter(Class<A>) - Method in interface javax.xml.bind.Marshaller
Gets the adapter associated with the specified type.
getAdapter(Class<A>) - Method in interface javax.xml.bind.Unmarshaller
Gets the adapter associated with the specified type.
getAdapterName() - Method in interface javax.resource.cci.ResourceAdapterMetaData
Gets a tool displayable name of the resource adapter.
getAdapterShortDescription() - Method in interface javax.resource.cci.ResourceAdapterMetaData
Gets a tool displayable short desription of the resource adapter.
getAdapterVendorName() - Method in interface javax.resource.cci.ResourceAdapterMetaData
Gets the name of the vendor that has provided the resource adapter.
getAdapterVersion() - Method in interface javax.resource.cci.ResourceAdapterMetaData
Gets the version of the resource adapter.
getAddress() - Method in class javax.mail.internet.InternetAddress
Get the email address.
getAddress() - Method in class javax.mail.search.AddressTerm
Return the address to match with.
getAddress() - Method in interface javax.xml.registry.infomodel.EmailAddress
Returns the email address for this object.
getAfterPhaseListener() - Method in class javax.faces.component.UIViewRoot
getAllAttributes() - Method in interface javax.xml.soap.SOAPElement
Returns an Iterator over all of the attribute Name objects in this SOAPElement object.
getAllAttributesAsQNames() - Method in interface javax.xml.soap.SOAPElement
Returns an Iterator over all of the attributes in this SOAPElement as QName objects.
getAllCommands(String) - Method in class javax.activation.CommandMap
Get all the available commands for this type.
getAllCommands(String, DataSource) - Method in class javax.activation.CommandMap
Get all the available commands for this type.
getAllCommands() - Method in class javax.activation.DataHandler
Return all the commands for this type of data.
getAllCommands(String) - Method in class javax.activation.MailcapCommandMap
Get all the available commands in all mailcap files known to this instance of MailcapCommandMap for this MIME type.
getAllHeaderLines() - Method in class javax.mail.internet.InternetHeaders
Return all the header lines as an Enumeration of Strings.
getAllHeaderLines() - Method in class javax.mail.internet.MimeBodyPart
Get all header lines as an Enumeration of Strings.
getAllHeaderLines() - Method in class javax.mail.internet.MimeMessage
Get all header lines as an Enumeration of Strings.
getAllHeaderLines() - Method in interface javax.mail.internet.MimePart
Get all header lines as an Enumeration of Strings.
getAllHeaders() - Method in class javax.mail.internet.InternetHeaders
Return all the headers as an Enumeration of Header objects.
getAllHeaders() - Method in class javax.mail.internet.MimeBodyPart
Return all the headers from this Message as an Enumeration of Header objects.
getAllHeaders() - Method in class javax.mail.internet.MimeMessage
Return all the headers from this Message as an enumeration of Header objects.
getAllHeaders() - Method in interface javax.mail.Part
Return all the headers from this part as an Enumeration of Header objects.
getAllHeaders() - Method in class javax.xml.soap.MimeHeaders
Returns all the MimeHeaders in this MimeHeaders object.
getAllMimeHeaders() - Method in class javax.xml.soap.AttachmentPart
Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.
getAllMimeHeaders() - Method in class javax.xml.soap.SOAPPart
Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.
getAllRecipients() - Method in class javax.mail.internet.MimeMessage
Get all the recipient addresses for the message.
getAllRecipients() - Method in class javax.mail.Message
Get all the recipient addresses for the message.
getAlt() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the alt property.
getAlt() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the alt property.
getAlt() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the alt property.
getAlt() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the alt property.
getApplication() - Method in class javax.faces.application.ApplicationFactory
Create (if needed) and return an Application instance for this web application.
getApplication() - Method in class javax.faces.context.FacesContext
Return the Application instance associated with this web application.
getApplicationMap() - Method in class javax.faces.context.ExternalContext
Return a mutable Map representing the application scope attributes for the current application.
getAreaCode() - Method in interface javax.xml.registry.infomodel.TelephoneNumber
Gets the area code.
getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.BigDecimalConverter
getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.BigIntegerConverter
getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.BooleanConverter
getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.ByteConverter
getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.CharacterConverter
getAsObject(FacesContext, UIComponent, String) - Method in interface javax.faces.convert.Converter
Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.DateTimeConverter
getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.DoubleConverter
getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.EnumConverter
Convert the argument value to one of the enum constants of the class provided in our constructor.
getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.FloatConverter
getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.IntegerConverter
getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.LongConverter
getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.NumberConverter
getAsObject(FacesContext, UIComponent, String) - Method in class javax.faces.convert.ShortConverter
getAssociatedObjects() - Method in interface javax.xml.registry.infomodel.RegistryObject
Returns the collection of RegistryObject instances associated with this object.
getAssociations() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets all Associations where this object is source.
getAssociationType() - Method in interface javax.xml.registry.infomodel.Association
Gets the association type for this Association.
getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.BigDecimalConverter
getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.BigIntegerConverter
getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.BooleanConverter
getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.ByteConverter
getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.CharacterConverter
getAsString(FacesContext, UIComponent, Object) - Method in interface javax.faces.convert.Converter
Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.DateTimeConverter
getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.DoubleConverter
getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.EnumConverter
Convert the enum constant given by the value argument into a String.
getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.FloatConverter
getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.IntegerConverter
getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.LongConverter
getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.NumberConverter
getAsString(FacesContext, UIComponent, Object) - Method in class javax.faces.convert.ShortConverter
getAttachment(SOAPElement) - Method in class javax.xml.soap.SOAPMessage
Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
getAttachmentAsByteArray(String) - Method in class javax.xml.bind.attachment.AttachmentUnmarshaller
Retrieve the attachment identified by content-id, cid, as a byte[].
getAttachmentAsDataHandler(String) - Method in class javax.xml.bind.attachment.AttachmentUnmarshaller
Lookup MIME content by content-id, cid, and return as a DataHandler.
getAttachmentMarshaller() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
getAttachmentMarshaller() - Method in interface javax.xml.bind.Marshaller
getAttachments() - Method in class javax.xml.soap.SOAPMessage
Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.
getAttachments(MimeHeaders) - Method in class javax.xml.soap.SOAPMessage
Retrieves all the AttachmentPart objects that have header entries that match the specified headers.
getAttachmentUnmarshaller() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
getAttachmentUnmarshaller() - Method in interface javax.xml.bind.Unmarshaller
getAttribute(ObjectName, String) - Method in interface javax.management.j2ee.Management
Gets the value of a specific attribute of a named managed object.
getAttribute(String) - Method in interface javax.servlet.http.HttpSession
Returns the object bound with the specified name in this session, or null if no object is bound under the name.
getAttribute(String) - Method in class javax.servlet.jsp.JspContext
Returns the object associated with the name in the page scope or null if not found.
getAttribute(String, int) - Method in class javax.servlet.jsp.JspContext
Return the object associated with the name in the specified scope or null if not found.
getAttribute(String) - Method in class javax.servlet.jsp.tagext.TagData
The value of the attribute.
getAttribute(String) - Method in interface javax.servlet.ServletContext
Returns the servlet container attribute with the given name, or null if there is no attribute by that name.
getAttribute(String) - Method in interface javax.servlet.ServletRequest
Returns the value of the named attribute as an Object, or null if no attribute of the given name exists.
getAttribute(String) - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to call getAttribute(String name) on the wrapped request object.
getAttributeByName(QName) - Method in interface javax.xml.stream.events.StartElement
Returns the attribute referred to by this name
getAttributeCount() - Method in class javax.xml.stream.util.StreamReaderDelegate
getAttributeCount() - Method in interface javax.xml.stream.XMLStreamReader
Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE.
getAttributeLocalName(int) - Method in class javax.xml.stream.util.StreamReaderDelegate
getAttributeLocalName(int) - Method in interface javax.xml.stream.XMLStreamReader
Returns the localName of the attribute at the provided index
getAttributeName(int) - Method in class javax.xml.stream.util.StreamReaderDelegate
getAttributeName(int) - Method in interface javax.xml.stream.XMLStreamReader
Returns the qname of the attribute at the provided index
getAttributeNames() - Method in interface javax.enterprise.deploy.model.DDBean
Returns the list of attribute names associated with the XML element.
getAttributeNames() - Method in interface javax.servlet.http.HttpSession
Returns an Enumeration of String objects containing the names of all the objects bound to this session.
getAttributeNames() - Method in interface javax.servlet.ServletContext
Returns an Enumeration containing the attribute names available within this servlet context.
getAttributeNames() - Method in interface javax.servlet.ServletRequest
Returns an Enumeration containing the names of the attributes available to this request.
getAttributeNames() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getAttributeNames() on the wrapped request object.
getAttributeNamesInScope(int) - Method in class javax.servlet.jsp.JspContext
Enumerate all the attributes in a given scope.
getAttributeNamespace(int) - Method in class javax.xml.stream.util.StreamReaderDelegate
getAttributeNamespace(int) - Method in interface javax.xml.stream.XMLStreamReader
Returns the namespace of the attribute at the provided index
getAttributePrefix(int) - Method in class javax.xml.stream.util.StreamReaderDelegate
getAttributePrefix(int) - Method in interface javax.xml.stream.XMLStreamReader
Returns the prefix of this attribute at the provided index
getAttributes() - Method in class javax.faces.component.UIComponent
Return a mutable Map representing the attributes (and properties, see below) associated wth this UIComponent, keyed by attribute name (which must be a String).
getAttributes() - Method in class javax.faces.component.UIComponentBase
getAttributes(ObjectName, String[]) - Method in interface javax.management.j2ee.Management
Enables the values of several attributes of a named managed object.
getAttributes() - Method in class javax.servlet.jsp.tagext.TagData
Enumerates the attributes.
getAttributes() - Method in class javax.servlet.jsp.tagext.TagInfo
Attribute information (in the TLD) on this tag.
getAttributes() - Method in interface javax.xml.stream.events.StartElement
Returns an Iterator of non-namespace declared attributes declared on this START_ELEMENT, returns an empty iterator if there are no attributes.
getAttributesScope(String) - Method in class javax.servlet.jsp.JspContext
Get the scope where a given attribute is defined.
getAttributeString(String) - Method in class javax.servlet.jsp.tagext.TagData
Get the value for a given attribute.
getAttributeType(int) - Method in class javax.xml.stream.util.StreamReaderDelegate
getAttributeType(int) - Method in interface javax.xml.stream.XMLStreamReader
Returns the XML type of the attribute at the provided index
getAttributeValue(String) - Method in interface javax.enterprise.deploy.model.DDBean
Returns the string value of the named attribute.
getAttributeValue(Name) - Method in interface javax.xml.soap.SOAPElement
Returns the value of the attribute with the specified name.
getAttributeValue(QName) - Method in interface javax.xml.soap.SOAPElement
Returns the value of the attribute with the specified qname.
getAttributeValue(String, String) - Method in class javax.xml.stream.util.StreamReaderDelegate
getAttributeValue(int) - Method in class javax.xml.stream.util.StreamReaderDelegate
getAttributeValue(String, String) - Method in interface javax.xml.stream.XMLStreamReader
Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality
getAttributeValue(int) - Method in interface javax.xml.stream.XMLStreamReader
Returns the value of the attribute at the index
getAuditTrail() - Method in interface javax.xml.registry.infomodel.RegistryObject
Returns the complete audit trail of all requests that effected a state change in this object as an ordered Collection of AuditableEvent objects.
getAuthType() - Method in class javax.faces.context.ExternalContext
Return the name of the authentication scheme used to authenticate the current user, if any; otherwise, return null.
getAuthType() - Method in interface javax.servlet.http.HttpServletRequest
Returns the name of the authentication scheme used to protect the servlet.
getAuthType() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getAuthType() on the wrapped request object.
getAutocomplete() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the autocomplete property.
getAutocomplete() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the autocomplete property.
getAvailableModules(ModuleType, Target[]) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Retrieve the list of all J2EE application modules running or not running on the identified targets.
getBase64Content() - Method in class javax.xml.soap.AttachmentPart
Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.
getBaseType() - Method in class javax.activation.MimeType
Return a String representation of this object without the parameter list.
getBaseType() - Method in class javax.mail.internet.ContentType
Return the MIME type string, without the parameters.
getBaseURI() - Method in interface javax.xml.stream.events.EntityDeclaration
Get the base URI for this reference or null if this information is not available
getBean(CommandInfo) - Method in class javax.activation.DataHandler
A convenience method that takes a CommandInfo object and instantiates the corresponding command, usually a JavaBean component.
getBean() - Method in class javax.enterprise.deploy.model.XpathEvent
The bean being added/removed/changed.
getBeanProperty(String) - Method in class javax.el.BeanELResolver.BeanProperties
getBeforePhaseListener() - Method in class javax.faces.component.UIViewRoot
getBgcolor() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the bgcolor property.
getBgcolor() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the bgcolor property.
getBinding() - Method in interface javax.xml.ws.BindingProvider
Get the Binding for this binding provider.
getBinding() - Method in class javax.xml.ws.Endpoint
Returns the binding for this endpoint.
getBindingID() - Method in interface javax.xml.ws.handler.PortInfo
Gets the URI identifying the binding used by the port being accessed.
getBody() - Method in interface javax.xml.soap.SOAPEnvelope
Returns the SOAPBody object associated with this SOAPEnvelope object.
getBodyContent() - Method in class javax.faces.webapp.UIComponentClassicTagBase
getBodyContent() - Method in class javax.servlet.jsp.tagext.BodyTagSupport
Get current bodyContent.
getBodyContent() - Method in class javax.servlet.jsp.tagext.TagInfo
The bodycontent information for this tag.
getBodyLength() - Method in interface javax.jms.BytesMessage
Gets the number of bytes of the message body when the message is in read-only mode.
getBodyPart(int) - Method in class javax.mail.internet.MimeMultipart
Get the specified BodyPart.
getBodyPart(String) - Method in class javax.mail.internet.MimeMultipart
Get the MimeBodyPart referred to by the given ContentID (CID).
getBodyPart(int) - Method in class javax.mail.Multipart
Get the specified Part.
getBodyPart(int) - Method in interface javax.mail.MultipartDataSource
Get the specified Part.
getBoolean(String) - Method in interface javax.jms.MapMessage
Returns the boolean value with the specified name.
getBooleanProperty(String) - Method in interface javax.jms.Message
Returns the value of the boolean property with the specified name.
getBorder() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the border property.
getBorder() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the border property.
getBorder() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the border property.
getBorder() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the border property.
getBranchQualifier() - Method in interface javax.transaction.xa.Xid
Obtain the transaction branch identifier part of XID as an array of bytes.
getBufferSize() - Method in class javax.servlet.jsp.JspWriter
This method returns the size of the buffer used by the JspWriter.
getBufferSize() - Method in interface javax.servlet.ServletResponse
Returns the actual buffer size used for the response.
getBufferSize() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return getBufferSize() on the wrapped response object.
getBuilder() - Method in class javax.xml.bind.annotation.W3CDomHandler
getBulkResponse(String) - Method in interface javax.xml.registry.RegistryService
Returns the BulkResponse associated with specified requestId.
getBusinessLifeCycleManager() - Method in interface javax.xml.registry.RegistryService
Returns the BusinessLifeCycleManager object implemented by the JAXR provider.
getBusinessObject(Class<T>) - Method in interface javax.ejb.SessionContext
Obtain an object that can be used to invoke the current bean through the given business interface.
getBusinessQueryManager() - Method in interface javax.xml.registry.RegistryService
Returns the BusinessQueryManager object implemented by the JAXR provider.
getByte(String) - Method in interface javax.jms.MapMessage
Returns the byte value with the specified name.
getByteProperty(String) - Method in interface javax.jms.Message
Returns the value of the byte property with the specified name.
getBytes(String) - Method in interface javax.jms.MapMessage
Returns the byte array value with the specified name.
getCallerIdentity() - Method in interface javax.ejb.EJBContext
Deprecated. Use Principal getCallerPrincipal() instead.
getCallerPrincipal() - Method in interface javax.ejb.EJBContext
Obtain the java.security.Principal that identifies the caller.
getCalls(QName) - Method in interface javax.xml.rpc.Service
Gets an array of preconfigured Call objects for invoking operations on the specified port.
getCapabilityLevel() - Method in interface javax.xml.registry.CapabilityProfile
Gets the capability level supported by the JAXR provider.
getCapabilityProfile() - Method in interface javax.xml.registry.RegistryService
Returns the CapabilityProfile for the JAXR provider.
getCaptionClass() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the captionClass property.
getCaptionClass() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the captionClass property.
getCaptionStyle() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the captionStyle property.
getCaptionStyle() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the captionStyle property.
getCause() - Method in exception javax.faces.FacesException
Return the cause of this exception, or null if the cause is nonexistent or unknown.
getCause() - Method in exception javax.mail.MessagingException
Overrides the getCause method of Throwable to return the next exception in the chain of nested exceptions.
getCause() - Method in exception javax.xml.bind.JAXBException
getCause() - Method in exception javax.xml.registry.JAXRException
Returns the Throwable embedded in this JAXRException if there is one.
getCause() - Method in exception javax.xml.soap.SOAPException
Returns the Throwable object embedded in this SOAPException if there is one.
getCausedByException() - Method in exception javax.ejb.EJBException
Obtain the exception that caused the EJBException being thrown.
getCellpadding() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the cellpadding property.
getCellpadding() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the cellpadding property.
getCellspacing() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the cellspacing property.
getCellspacing() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the cellspacing property.
getChangeEvent() - Method in class javax.enterprise.deploy.model.XpathEvent
getChar(String) - Method in interface javax.jms.MapMessage
Returns the Unicode character value with the specified name.
getCharacterEncoding() - Method in class javax.faces.context.ResponseWriter
Return the character encoding (such as "ISO-8859-1") for this ResponseWriter.
getCharacterEncoding() - Method in class javax.faces.context.ResponseWriterWrapper
The default behavior of this method is to call ResponseWriter.getCharacterEncoding() on the wrapped ResponseWriter object.
getCharacterEncoding() - Method in interface javax.servlet.ServletRequest
Returns the name of the character encoding used in the body of this request.
getCharacterEncoding() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getCharacterEncoding() on the wrapped request object.
getCharacterEncoding() - Method in interface javax.servlet.ServletResponse
Returns the name of the character encoding (MIME charset) used for the body sent in this response.
getCharacterEncoding() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return getCharacterEncoding() on the wrapped response object.
getCharacterEncodingScheme() - Method in interface javax.xml.stream.events.StartDocument
Returns the encoding style of the XML data
getCharacterEncodingScheme() - Method in class javax.xml.stream.util.StreamReaderDelegate
getCharacterEncodingScheme() - Method in interface javax.xml.stream.XMLStreamReader
Returns the character encoding declared on the xml declaration Returns null if none was declared
getCharacterOffset() - Method in interface javax.xml.stream.Location
Return the byte or character offset into the input source this location is pointing to.
getCharset() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the charset property.
getCharset() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the charset property.
getCharsetName() - Method in interface javax.xml.registry.infomodel.LocalizedString
Gets the canonical name for the charset for this object.
getChildBean(String) - Method in interface javax.enterprise.deploy.model.DDBean
Return a list of DDBeans based upon the XPath.
getChildBean(String) - Method in interface javax.enterprise.deploy.model.DeployableObject
Return an array of standard beans representing the XML content returned based upon the XPath.
getChildBean(ModuleType, String) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return a list of DDBean based upon an XPath; all deployment descriptors of the specified type are searched.
getChildConceptCount() - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Gets number of children.
getChildConceptCount() - Method in interface javax.xml.registry.infomodel.Concept
Gets number of children.
getChildCount() - Method in class javax.faces.component.UIComponent
Return the number of child UIComponents that are associated with this UIComponent.
getChildCount() - Method in class javax.faces.component.UIComponentBase
getChildElements() - Method in interface javax.xml.soap.SOAPElement
Returns an Iterator over all the immediate child Nodes of this element.
getChildElements(Name) - Method in interface javax.xml.soap.SOAPElement
Returns an Iterator over all the immediate child Nodes of this element with the specified name.
getChildElements(QName) - Method in interface javax.xml.soap.SOAPElement
Returns an Iterator over all the immediate child Nodes of this element with the specified qname.
getChildOrganizationCount() - Method in interface javax.xml.registry.infomodel.Organization
Gets number of children.
getChildOrganizations() - Method in interface javax.xml.registry.infomodel.Organization
Gets all immediate children Organizations.
getChildren() - Method in class javax.faces.component.UIComponent
Return a mutable List representing the child UIComponents associated with this component.
getChildren() - Method in class javax.faces.component.UIComponentBase
getChildrenConcepts() - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Gets all immediate children Concepts.
getChildrenConcepts() - Method in interface javax.xml.registry.infomodel.Concept
Gets all immediate children Concepts.
getChildTargetModuleID() - Method in interface javax.enterprise.deploy.spi.TargetModuleID
Retrieve a list of identifiers of the children of this deployed module.
getCity() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the city.
getClassFromScope(String) - Method in interface javax.enterprise.deploy.model.DeployableObject
Retrieve the specified class from this deployable module.
getClassifications() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets the Classification instances that classify this object.
getClassificationScheme() - Method in interface javax.xml.registry.infomodel.Classification
Gets the ClassificationScheme that is used in classifying the object.
getClassificationScheme() - Method in interface javax.xml.registry.infomodel.Concept
Gets the ClassificationScheme that this Concept is a descendent of.
getClassifiedObject() - Method in interface javax.xml.registry.infomodel.Classification
Gets the Object that is being classified.
getClassLoader() - Method in interface javax.persistence.spi.PersistenceUnitInfo
Returns ClassLoader that the provider may use to load any classes, resources, or open URLs.
getClassName() - Method in class javax.mail.Provider
Returns name of the class that implements the protocol
getClassName() - Method in class javax.servlet.jsp.tagext.TagVariableInfo
The body of the <variable-class> element.
getClassName() - Method in class javax.servlet.jsp.tagext.VariableInfo
Returns the type of this variable.
getClientConfiguration(TargetModuleID) - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
Return the ClientConfiguration object associated with the TargetModuleID.
getClientId(FacesContext) - Method in class javax.faces.component.UIComponent
Return a client-side identifier for this component, generating one if necessary.
getClientId(FacesContext) - Method in class javax.faces.component.UIComponentBase
getClientId(FacesContext) - Method in class javax.faces.component.UIData
Return a client identifier for this component that includes the current value of the rowIndex property, if it is not set to -1.
getClientID() - Method in interface javax.jms.Connection
Gets the client identifier for this connection.
getClientIdsWithMessages() - Method in class javax.faces.context.FacesContext
Return an Iterator over the client identifiers for which at least one FacesMessage has been queued.
getCloseCount() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats
The number of connections closed
getCloseCount() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats
Number of connections closed.
getCollection() - Method in interface javax.xml.registry.BulkResponse
Get the Collection of objects returned as a response of a bulk operation.
getCols() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the cols property.
getColumnClasses() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the columnClasses property.
getColumnClasses() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the columnClasses property.
getColumnNumber() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl
getColumnNumber() - Method in interface javax.xml.bind.ValidationEventLocator
Return the column number if available
getColumnNumber() - Method in interface javax.xml.stream.Location
Return the column number where the current event ends, returns -1 if none is available.
getColumns() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the columns property.
getCommand(String, String) - Method in class javax.activation.CommandMap
Get the default command corresponding to the MIME type.
getCommand(String, String, DataSource) - Method in class javax.activation.CommandMap
Get the default command corresponding to the MIME type.
getCommand(String) - Method in class javax.activation.DataHandler
Get the command cmdName.
getCommand(String, String) - Method in class javax.activation.MailcapCommandMap
Get the command corresponding to cmdName for the MIME type.
getCommand() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
Retrieve the deployment CommandType of this event.
getCommandClass() - Method in class javax.activation.CommandInfo
Return the command's class name.
getCommandName() - Method in class javax.activation.CommandInfo
Return the command verb.
getCommandObject(DataHandler, ClassLoader) - Method in class javax.activation.CommandInfo
Return the instantiated JavaBean component.
getCommandType(int) - Static method in class javax.enterprise.deploy.shared.CommandType
Return an object of the specified value.
getComment() - Method in class javax.servlet.http.Cookie
Returns the comment describing the purpose of this cookie, or null if the cookie has no comment.
getCommittedCount() - Method in interface javax.management.j2ee.statistics.JTAStats
Number of committed transactions.
getCommonPropertyType(ELContext, Object) - Method in class javax.el.ArrayELResolver
If the base object is a Java language array, returns the most general type that this resolver accepts for the property argument.
getCommonPropertyType(ELContext, Object) - Method in class javax.el.BeanELResolver
If the base object is not null, returns the most general type that this resolver accepts for the property argument.
getCommonPropertyType(ELContext, Object) - Method in class javax.el.CompositeELResolver
Returns the most general type that this resolver accepts for the property argument, given a base object.
getCommonPropertyType(ELContext, Object) - Method in class javax.el.ELResolver
Returns the most general type that this resolver accepts for the property argument, given a base object.
getCommonPropertyType(ELContext, Object) - Method in class javax.el.ListELResolver
If the base object is a list, returns the most general type that this resolver accepts for the property argument.
getCommonPropertyType(ELContext, Object) - Method in class javax.el.MapELResolver
If the base object is a map, returns the most general type that this resolver accepts for the property argument.
getCommonPropertyType(ELContext, Object) - Method in class javax.el.ResourceBundleELResolver
If the base object is a ResourceBundle, returns the most general type that this resolver accepts for the property argument.
getCommonPropertyType(ELContext, Object) - Method in class javax.servlet.jsp.el.ImplicitObjectELResolver
If the base object is null, returns String.class.
getCommonPropertyType(ELContext, Object) - Method in class javax.servlet.jsp.el.ScopedAttributeELResolver
If the base object is null, returns String.class.
getComparison() - Method in class javax.mail.search.DateTerm
Return the type of comparison.
getComparison() - Method in class javax.mail.search.IntegerComparisonTerm
Return the type of comparison.
getComponent() - Method in class javax.faces.event.FacesEvent
Return the source UIComponent that sent this event.
getComponentInstance() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Return the UIComponent instance that is associated with this tag instance.
getComponentInstance() - Method in class javax.faces.webapp.UIComponentTagBase
Return the UIComponent instance that is associated with this tag instance.
getComponentStateToRestore(FacesContext) - Method in class javax.faces.render.ResponseStateManager
Deprecated. This method has been replaced by ResponseStateManager.getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.
getComponentStateToSave(FacesContext) - Method in class javax.faces.application.StateManager
Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
getComponentStateToSave(FacesContext) - Method in class javax.faces.application.StateManagerWrapper
The default behavior of this method is to call StateManager.getComponentStateToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.
getComponentType() - Method in class javax.faces.webapp.UIComponentTagBase
Return the component type for the component that is or will be bound to this tag.
getComponentTypes() - Method in class javax.faces.application.Application
Return an Iterator over the set of currently defined component types for this Application.
getConcept() - Method in interface javax.xml.registry.infomodel.Classification
Gets the Concept that is classifying the object.
getConnection() - Method in interface javax.resource.cci.ConnectionFactory
Gets a connection to an EIS instance.
getConnection(ConnectionSpec) - Method in interface javax.resource.cci.ConnectionFactory
Gets a connection to an EIS instance.
getConnection() - Method in interface javax.resource.cci.Interaction
Gets the Connection associated with the Interaction.
getConnection(Subject, ConnectionRequestInfo) - Method in interface javax.resource.spi.ManagedConnection
Creates a new connection handle for the underlying physical connection represented by the ManagedConnection instance.
getConnectionFactory() - Method in interface javax.management.j2ee.statistics.JCAConnectionStats
Returns the associated JCAConnectionFactory OBJECT_NAME
getConnectionHandle() - Method in class javax.resource.spi.ConnectionEvent
Get the connection handle associated with the Managed Connection instance.
getConnectionPools() - Method in interface javax.management.j2ee.statistics.JCAStats
Returns an array of JCAConnectionPool Stats that provide statistics about the connection pools associated with the referencing JCA resource statistics
getConnectionPools() - Method in interface javax.management.j2ee.statistics.JDBCStats
getConnections() - Method in interface javax.management.j2ee.statistics.JCAStats
Returns an array of JCAConnectionStats that provide statistics about the non-pooled connections associated with the referencing JCA resource statistics
getConnections() - Method in interface javax.management.j2ee.statistics.JDBCStats
getConnections() - Method in interface javax.management.j2ee.statistics.JMSStats
Returns an array of JMSConnectionStats that provide statistics about the connections associated with the referencing JMS resource.
getConsumers() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Returns an array of JMSConsumerStats that provide statistics about the message consumers associated with the referencing JMS session statistics.
getContainerClientId(FacesContext) - Method in class javax.faces.component.UIComponent
Allow components that implement NamingContainer to selectively disable prepending their clientId to their descendent's clientIds by breaking the prepending logic into a seperately callable method.
getContainerClientId(FacesContext) - Method in class javax.faces.component.UIForm
Override the UIComponent.getContainerClientId(javax.faces.context.FacesContext) to allow users to disable this form from prepending its clientId to its descendent's clientIds depending on the value of this form's UIForm.isPrependId() property.
getContent(DataSource) - Method in interface javax.activation.DataContentHandler
Return an object representing the data in its most preferred form.
getContent() - Method in class javax.activation.DataHandler
Return the data in its preferred Object form.
getContent() - Method in class javax.mail.internet.MimeBodyPart
Return the content as a java object.
getContent() - Method in class javax.mail.internet.MimeMessage
Return the content as a Java object.
getContent() - Method in interface javax.mail.Part
Return the content as a Java object.
getContent() - Method in class javax.xml.soap.AttachmentPart
Gets the content of this AttachmentPart object as a Java object.
getContent() - Method in class javax.xml.soap.SOAPPart
Returns the content of the SOAPEnvelope as a JAXP Source object.
getContentDescription() - Method in class javax.xml.soap.SOAPMessage
Retrieves a description of this SOAPMessage object's content.
getContentID() - Method in class javax.mail.internet.MimeBodyPart
Returns the value of the "Content-ID" header field.
getContentID() - Method in class javax.mail.internet.MimeMessage
Returns the value of the "Content-ID" header field.
getContentID() - Method in interface javax.mail.internet.MimePart
Get the Content-ID of this part.
getContentId() - Method in class javax.xml.soap.AttachmentPart
Gets the value of the MIME header whose name is "Content-ID".
getContentId() - Method in class javax.xml.soap.SOAPPart
Retrieves the value of the MIME header whose name is "Content-Id".
getContentLanguage() - Method in class javax.mail.internet.MimeBodyPart
Get the languages specified in the Content-Language header of this MimePart.
getContentLanguage() - Method in class javax.mail.internet.MimeMessage
Get the languages specified in the "Content-Language" header field of this message.
getContentLanguage() - Method in interface javax.mail.internet.MimePart
Get the language tags specified in the Content-Language header of this MimePart.
getContentLength() - Method in interface javax.servlet.ServletRequest
Returns the length, in bytes, of the request body and made available by the input stream, or -1 if the length is not known.
getContentLength() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getContentLength() on the wrapped request object.
getContentLocation() - Method in class javax.xml.soap.AttachmentPart
Gets the value of the MIME header whose name is "Content-Location".
getContentLocation() - Method in class javax.xml.soap.SOAPPart
Retrieves the value of the MIME header whose name is "Content-Location".
getContentMD5() - Method in class javax.mail.internet.MimeBodyPart
Return the value of the "Content-MD5" header field.
getContentMD5() - Method in class javax.mail.internet.MimeMessage
Return the value of the "Content-MD5" header field.
getContentMD5() - Method in interface javax.mail.internet.MimePart
Get the Content-MD5 digest of this part.
getContentStream() - Method in class javax.mail.internet.MimeBodyPart
Produce the raw bytes of the content.
getContentStream() - Method in class javax.mail.internet.MimeMessage
Produce the raw bytes of the content.
getContentType() - Method in class javax.activation.DataHandler
Return the MIME type of this object as retrieved from the source object.
getContentType() - Method in interface javax.activation.DataSource
This method returns the MIME type of the data in the form of a string.
getContentType() - Method in class javax.activation.FileDataSource
This method returns the MIME type of the data in the form of a string.
getContentType(File) - Method in class javax.activation.FileTypeMap
Return the type of the file object.
getContentType(String) - Method in class javax.activation.FileTypeMap
Return the type of the file passed in.
getContentType(File) - Method in class javax.activation.MimetypesFileTypeMap
Return the MIME type of the file object.
getContentType(String) - Method in class javax.activation.MimetypesFileTypeMap
Return the MIME type based on the specified file name.
getContentType() - Method in class javax.activation.URLDataSource
Returns the value of the URL content-type header field.
getContentType() - Method in class javax.faces.context.ResponseWriter
Return the content type (such as "text/html") for this ResponseWriter.
getContentType() - Method in class javax.faces.context.ResponseWriterWrapper
The default behavior of this method is to call ResponseWriter.getContentType() on the wrapped ResponseWriter object.
getContentType() - Method in class javax.mail.internet.MimeBodyPart
Returns the value of the RFC 822 "Content-Type" header field.
getContentType() - Method in class javax.mail.internet.MimeMessage
Returns the value of the RFC 822 "Content-Type" header field.
getContentType() - Method in class javax.mail.internet.MimePartDataSource
Returns the content-type of this DataSource.
getContentType() - Method in class javax.mail.Multipart
Return the content-type of this Multipart.
getContentType() - Method in interface javax.mail.Part
Returns the Content-Type of the content of this part.
getContentType() - Method in class javax.mail.util.ByteArrayDataSource
Get the MIME content type of the data.
getContentType() - Method in interface javax.servlet.ServletRequest
Returns the MIME type of the body of the request, or null if the type is not known.
getContentType() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getContentType() on the wrapped request object.
getContentType() - Method in interface javax.servlet.ServletResponse
Returns the content type used for the MIME body sent in this response.
getContentType() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return getContentType() on the wrapped response object.
getContentType() - Method in class javax.xml.soap.AttachmentPart
Gets the value of the MIME header whose name is "Content-Type".
getContext(Class) - Method in class javax.el.ELContext
Returns the context object associated with the given key.
getContext() - Method in class javax.faces.context.ExternalContext
Return the application environment object instance for the current appication.
getContext(String) - Static method in class javax.security.jacc.PolicyContext
This method may be used by a Policy provider to activate the PolicyContextHandler registered to the context object key and cause it to return the corresponding policy context object from the container.
getContext(String, Object) - Method in interface javax.security.jacc.PolicyContextHandler
This public method is used by the PolicyContext class to activate the handler and obtain from it the context object identified by the (case-sensitive) key.
getContext(String) - Method in interface javax.servlet.ServletContext
Returns a ServletContext object that corresponds to a specified URL on the server.
getContext() - Method in interface javax.xml.ws.Response
Gets the contained response context.
getContextData() - Method in interface javax.interceptor.InvocationContext
Returns the context data associated with this invocation or lifecycle callback.
getContextID() - Method in interface javax.security.jacc.PolicyConfiguration
This method returns this object's policy context identifier.
getContextID() - Static method in class javax.security.jacc.PolicyContext
This static method returns the value of the policy context identifier associated with the thread on which the accessor is called.
getContextPath() - Method in interface javax.servlet.http.HttpServletRequest
Returns the portion of the request URI that indicates the context of the request.
getContextPath() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getContextPath() on the wrapped request object.
getContextPath() - Method in interface javax.servlet.ServletContext
Returns the context path of the web application.
getConvertedValue(FacesContext, Object) - Method in class javax.faces.component.UIInput
Convert the submitted value into a "local value" of the appropriate data type, if necessary.
getConvertedValue(FacesContext, UIComponent, Object) - Method in class javax.faces.render.Renderer
Attempt to convert previously stored state information into an object of the type required for this component (optionally using the registered Converter for this component, if there is one).
getConverter() - Method in class javax.faces.component.UIOutput
getConverter() - Method in interface javax.faces.component.ValueHolder
Return the Converter (if any) that is registered for this UIComponent.
getConverterIds() - Method in class javax.faces.application.Application
Return an Iterator over the set of currently registered converter ids for this Application.
getConverterMessage() - Method in class javax.faces.component.UIInput
If there has been a call to UIInput.setConverterMessage(java.lang.String) on this instance, return the message.
getConverterTypes() - Method in class javax.faces.application.Application
Return an Iterator over the set of Class instances for which Converter classes have been explicitly registered.
getCookies() - Method in interface javax.servlet.http.HttpServletRequest
Returns an array containing all of the Cookie objects the client sent with this request.
getCookies() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getCookies() on the wrapped request object.
getCoords() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the coords property.
getCoords() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the coords property.
getCount() - Method in class javax.mail.internet.MimeMultipart
Return the number of enclosed BodyPart objects.
getCount() - Method in class javax.mail.Multipart
Return the number of enclosed BodyPart objects.
getCount() - Method in interface javax.mail.MultipartDataSource
Return the number of enclosed BodyPart objects.
getCount() - Method in interface javax.management.j2ee.statistics.CountStatistic
The count since the last reset.
getCount() - Method in interface javax.management.j2ee.statistics.TimeStatistic
Number of times the operation was invoked since the beginning of this measurement.
getCountry() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the country.
getCountryCode() - Method in interface javax.xml.registry.infomodel.TelephoneNumber
Gets the country code.
getCreateCount() - Method in interface javax.management.j2ee.statistics.EJBStats
Number of times create was called.
getCreateCount() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats
The number of connections created
getCreateCount() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats
Number of connections created.
getCreated() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Return true if we dynamically created a new component instance during execution of this tag.
getCreated() - Method in class javax.faces.webapp.UIComponentTagBase
Return true if we dynamically created a new component instance during execution of this tag.
getCreatedComponents() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Returns the List of UIComponent ids created or located by nested UIComponentTags while processing the current request.
getCreationTime() - Method in interface javax.servlet.http.HttpSession
Returns the time when this session was created, measured in milliseconds since midnight January 1, 1970 GMT.
getCredentialData() - Method in interface javax.resource.spi.security.GenericCredential
Deprecated. Gets security data for a specific security mechanism represented by the GenericCredential.
getCredentials() - Method in interface javax.xml.registry.Connection
Gets the credentials associated with this client.
getCurrencyCode() - Method in class javax.faces.convert.NumberConverter
Return the ISO 4217 currency code used by getAsString() with a type of currency.
getCurrencySymbol() - Method in class javax.faces.convert.NumberConverter
Return the currency symbol used by getAsString() with a type of currency.
getCurrent() - Method in interface javax.management.j2ee.statistics.RangeStatistic
The current value of this attribute.
getCurrentInstance() - Static method in class javax.faces.context.FacesContext
Return the FacesContext instance for the request that is being processed by the current thread, if any.
getCurrentLocale() - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Returns the active locale this implementation of javax.enterprise.deploy.spi subpackages is running.
getData() - Method in interface javax.xml.stream.events.Characters
Get the character data of this event
getData() - Method in interface javax.xml.stream.events.ProcessingInstruction
The data section of the processing instruction
getDataHandler() - Method in class javax.mail.internet.MimeBodyPart
Return a DataHandler for this body part's content.
getDataHandler() - Method in class javax.mail.internet.MimeMessage
Return a DataHandler for this Message's content.
getDataHandler() - Method in interface javax.mail.Part
Return a DataHandler for the content within this part.
getDataHandler() - Method in class javax.xml.soap.AttachmentPart
Gets the DataHandler object for this AttachmentPart object.
getDataModel() - Method in class javax.faces.component.UIData
Return the internal DataModel object representing the data objects that we will iterate over in this component's rendering.
getDataModel() - Method in class javax.faces.model.DataModelEvent
Return the DataModel that fired this event.
getDataModelListeners() - Method in class javax.faces.model.DataModel
Return the set of DataModelListeners interested in notifications from this DataModel.
getDataSource() - Method in class javax.activation.DataHandler
Return the DataSource associated with this instance of DataHandler.
getDate() - Method in class javax.mail.search.DateTerm
Return the Date to compare with.
getDateHeader(String) - Method in interface javax.servlet.http.HttpServletRequest
Returns the value of the specified request header as a long value that represents a Date object.
getDateHeader(String) - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getDateHeader(String name) on the wrapped request object.
getDateStyle() - Method in class javax.faces.convert.DateTimeConverter
Return the style to be used to format or parse dates.
getDConfigBean(DDBean) - Method in interface javax.enterprise.deploy.spi.DConfigBean
Return the JavaBean containing the server-specific deployment configuration information based upon the XML data provided by the DDBean.
getDConfigBean(DDBeanRoot) - Method in interface javax.enterprise.deploy.spi.DConfigBeanRoot
Return a DConfigBean for a deployment descriptor that is not the module's primary deployment descriptor.
getDConfigBeanRoot(DDBeanRoot) - Method in interface javax.enterprise.deploy.spi.DeploymentConfiguration
Returns the top level configuration bean, DConfigBeanRoot, associated with the deployment descriptor represented by the designated DDBeanRoot bean.
getDConfigBeanVersion() - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Returns the J2EE platform version number for which the configuration beans are provided.
getDConfigBeanVersionType(int) - Static method in class javax.enterprise.deploy.shared.DConfigBeanVersionType
Return an object of the specified value.
getDDBean() - Method in interface javax.enterprise.deploy.spi.DConfigBean
Return the JavaBean containing the deployment descriptor XML text associated with this DConfigBean.
getDDBeanRoot() - Method in interface javax.enterprise.deploy.model.DeployableObject
Return the top level standard bean representing the root of the deployment descriptor.
getDDBeanRoot(String) - Method in interface javax.enterprise.deploy.model.DeployableObject
Returns a DDBeanRoot object for the XML instance document named.
getDDBeanRootVersion() - Method in interface javax.enterprise.deploy.model.DDBeanRoot
Returns the version number of an XML instance document.
getDebug() - Method in class javax.mail.Session
Get the debug setting for this Session.
getDebugOut() - Method in class javax.mail.Session
Returns the stream to be used for debugging output.
getDeclaration() - Method in interface javax.xml.stream.events.EntityReference
Return the declaration of this entity.
getDeclarativeQueryManager() - Method in interface javax.xml.registry.RegistryService
Returns the DeclarativeQueryManager object implemented by the JAXR provider.
getDeclare() - Method in class javax.servlet.jsp.tagext.TagVariableInfo
The body of the <declare> element.
getDeclare() - Method in class javax.servlet.jsp.tagext.VariableInfo
Returns whether this is a new variable.
getDeclaredType() - Method in class javax.xml.bind.JAXBElement
Returns the Java binding of the xml element declaration's type attribute.
getDefaultCommandMap() - Static method in class javax.activation.CommandMap
Get the default CommandMap.
getDefaultDomain() - Method in interface javax.management.j2ee.Management
Returns the default domain name of this MEJB.
getDefaultFactory() - Static method in class javax.servlet.jsp.JspFactory
Returns the default factory for this implementation.
getDefaultFileTypeMap() - Static method in class javax.activation.FileTypeMap
Return the default FileTypeMap for the system.
getDefaultFolder() - Method in class javax.mail.Store
Returns a Folder object that represents the 'root' of the default namespace presented to the user by the Store.
getDefaultInstance(Properties, Authenticator) - Static method in class javax.mail.Session
Get the default Session object.
getDefaultInstance(Properties) - Static method in class javax.mail.Session
Get the default Session object.
getDefaultJavaCharset() - Static method in class javax.mail.internet.MimeUtility
Get the default charset corresponding to the system's current default locale.
getDefaultLocale() - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Returns the default locale supported by this implementation of javax.enterprise.deploy.spi subpackages.
getDefaultLocale() - Method in class javax.faces.application.Application
Return the default Locale for this application.
getDefaultPostalScheme() - Method in interface javax.xml.registry.RegistryService
Gets the default user-defined postal scheme for codifying the attributes of PostalAddress.
getDefaultRenderKitId() - Method in class javax.faces.application.Application
Return the renderKitId to be used for rendering this application.
getDefaultTypeMapping() - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry
Gets the registered default TypeMapping instance.
getDefaultUserName() - Method in class javax.mail.Authenticator
getDelegate() - Method in interface javax.persistence.EntityManager
Return the underlying provider object for the EntityManager, if available.
getDeletedMessageCount() - Method in class javax.mail.Folder
Get the number of deleted messages in this Folder.
getDeliveryMode() - Method in interface javax.jms.MessageProducer
Gets the producer's default delivery mode.
getDeployableObject() - Method in interface javax.enterprise.deploy.model.DDBeanRoot
Return the containing DeployableObject
getDeployableObject(String) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return the DeployableObject of the specified URI designator.
getDeployableObject() - Method in interface javax.enterprise.deploy.spi.DeploymentConfiguration
Returns an object that provides access to the deployment descriptor data and classes of a J2EE module.
getDeployableObjects(ModuleType) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return the all DeployableObjects of the specified type.
getDeployableObjects() - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return the all DeployableObjects in this application.
getDeploymentFactories() - Method in class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
Retrieve the lists of currently registered DeploymentFactories.
getDeploymentManager(String, String, String) - Method in class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
Retrieves a DeploymentManager instance to use for deployment.
getDeploymentManager(String, String, String) - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory
Return a connected DeploymentManager instance.
getDeploymentStatus() - Method in class javax.enterprise.deploy.spi.status.ProgressEvent
Retrieve the status information.
getDeploymentStatus() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
Retrieve the status of this activity.
getDescendantConcepts() - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Gets all descendant Concepts.
getDescendantConcepts() - Method in interface javax.xml.registry.infomodel.Concept
Gets all descendant Concepts.
getDescendantOrganizations() - Method in interface javax.xml.registry.infomodel.Organization
Gets all descendant Organizations.
getDescription() - Method in interface javax.enterprise.deploy.spi.Target
Retrieve other descriptive information about the target.
getDescription() - Method in class javax.faces.model.SelectItem
Return a description of this item, for use in development tools.
getDescription() - Method in class javax.mail.internet.MimeBodyPart
Returns the "Content-Description" header field of this body part.
getDescription() - Method in class javax.mail.internet.MimeMessage
Returns the "Content-Description" header field of this Message.
getDescription() - Method in interface javax.mail.Part
Return a description String for this part.
getDescription() - Method in interface javax.management.j2ee.statistics.Statistic
A human-readable description of the Statistic.
getDescription() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
Gets the description string of this tag attribute.
getDescription() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets the textual description for this object.
getDeserializer(Class, QName) - Method in interface javax.xml.rpc.encoding.TypeMapping
Gets the DeserializerFactory registered for the specified pair of Java type and XML data type.
getDeserializerAs(String) - Method in interface javax.xml.rpc.encoding.DeserializerFactory
Returns a Deserializer for the specified XML processing mechanism type.
getDestination() - Method in interface javax.jms.MessageProducer
Gets the destination associated with this MessageProducer.
getDestination() - Method in interface javax.management.j2ee.statistics.JMSProducerStats
Returns a string that encapsulates the identity of the message destination
getDetail() - Method in class javax.faces.application.FacesMessage
Return the localized detail text.
getDetail() - Method in exception javax.xml.rpc.soap.SOAPFaultException
Gets the detail element.
getDetail() - Method in interface javax.xml.soap.SOAPFault
Returns the optional detail element for this SOAPFault object.
getDetailEntries() - Method in interface javax.xml.soap.Detail
Gets an Iterator over all of the DetailEntrys in this Detail object.
getDir() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlForm
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlOutputFormat
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlOutputText
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the dir property.
getDir() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the dir property.
getDisabledClass() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the disabledClass property.
getDisabledClass() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the disabledClass property.
getDisabledClass() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the disabledClass property.
getDisabledClass() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the disabledClass property.
getDisabledClass() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the disabledClass property.
getDisabledClass() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the disabledClass property.
getDisableMessageID() - Method in interface javax.jms.MessageProducer
Gets an indication of whether message IDs are disabled.
getDisableMessageTimestamp() - Method in interface javax.jms.MessageProducer
Gets an indication of whether message timestamps are disabled.
getDisconnectedDeploymentManager(String) - Method in class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
Return a disconnected DeploymentManager instance.
getDisconnectedDeploymentManager(String) - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory
Return a disconnected DeploymentManager instance.
getDisplayName() - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory
Provide a string with the name of this vendor's DeploymentManager.
getDisplayName() - Method in class javax.servlet.jsp.tagext.TagInfo
Get the displayName.
getDisposition() - Method in class javax.mail.internet.ContentDisposition
Return the disposition value.
getDisposition() - Method in class javax.mail.internet.MimeBodyPart
Returns the value of the "Content-Disposition" header field.
getDisposition() - Method in class javax.mail.internet.MimeMessage
Returns the value of the "Content-Disposition" header field.
getDisposition() - Method in interface javax.mail.Part
Return the disposition of this part.
getDoAfterBodyValue() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Return the flag value that should be returned from the doAfterBody() method when it is called.
getDocumentTypeDeclaration() - Method in interface javax.xml.stream.events.DTD
Returns the entire Document Type Declaration as a string, including the internal DTD subset.
getDoEndValue() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Return the flag value that should be returned from the doEnd() method when it is called.
getDomain() - Method in class javax.servlet.http.Cookie
Returns the domain name set for this cookie.
getDoStartValue() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Return the flag value that should be returned from the doStart() method when it is called.
getDouble(String) - Method in interface javax.jms.MapMessage
Returns the double value with the specified name.
getDoubleProperty(String) - Method in interface javax.jms.Message
Returns the value of the double property with the specified name.
getDTDType() - Method in interface javax.xml.stream.events.Attribute
Gets the type of this attribute, default is the String "CDATA"
getDurableSubscriptionCount() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Number of durable subscriptions.
getEISProductName() - Method in interface javax.resource.cci.ConnectionMetaData
Returns product name of the underlying EIS instance connected through the Connection that produced this metadata.
getEISProductName() - Method in interface javax.resource.spi.ManagedConnectionMetaData
Returns Product name of the underlying EIS instance connected through the ManagedConnection.
getEISProductVersion() - Method in interface javax.resource.cci.ConnectionMetaData
Returns product version of the underlying EIS instance.
getEISProductVersion() - Method in interface javax.resource.spi.ManagedConnectionMetaData
Returns product version of the underlying EIS instance connected through the ManagedConnection.
getEJBHome() - Method in interface javax.ejb.EJBContext
Obtain the enterprise bean's remote home interface.
getEJBHome() - Method in interface javax.ejb.EJBMetaData
Obtain the remote home interface of the enterprise Bean.
getEJBHome() - Method in interface javax.ejb.EJBObject
Obtain the enterprise Bean's remote home interface.
getEJBHome() - Method in interface javax.ejb.HomeHandle
Obtain the home object represented by this handle.
getEJBLocalHome() - Method in interface javax.ejb.EJBContext
Obtain the enterprise bean's local home interface.
getEJBLocalHome() - Method in interface javax.ejb.EJBLocalObject
Obtain the enterprise Bean's local home interface.
getEJBLocalObject() - Method in interface javax.ejb.EntityContext
Obtain a reference to the EJB local object that is currently associated with the instance.
getEJBLocalObject() - Method in interface javax.ejb.SessionContext
Obtain a reference to the EJB local object that is associated with the instance.
getEJBMetaData() - Method in interface javax.ejb.EJBHome
Obtain the EJBMetaData interface for the enterprise Bean.
getEJBObject() - Method in interface javax.ejb.EntityContext
Obtain a reference to the EJB object that is currently associated with the instance.
getEJBObject() - Method in interface javax.ejb.Handle
Obtain the EJB object reference represented by this handle.
getEJBObject() - Method in interface javax.ejb.SessionContext
Obtain a reference to the EJB object that is currently associated with the instance.
getELContext() - Method in class javax.el.ELContextEvent
Returns the ELContext that was created.
getELContext() - Method in class javax.faces.context.FacesContext
Return the ELContext instance for this FacesContext instance.
getELContext() - Method in class javax.faces.webapp.UIComponentELTag
Return the ELContext for the FacesContext for this request.
getELContext() - Method in class javax.faces.webapp.UIComponentTagBase
Return the ELContext for the FacesContext for this request.
getELContext() - Method in class javax.servlet.jsp.JspContext
Returns the ELContext associated with this JspContext.
getELContextListeners() - Method in class javax.faces.application.Application
If no calls have been made to Application.addELContextListener(javax.el.ELContextListener), this method must return an empty array.
getElement(ResultT) - Method in interface javax.xml.bind.annotation.DomHandler
Once the portion is sent to the Result.
getElement(DOMResult) - Method in class javax.xml.bind.annotation.W3CDomHandler
getElementName(Object) - Method in class javax.xml.bind.JAXBIntrospector
Get xml element qname for jaxbElement.
getElementName() - Method in interface javax.xml.soap.SOAPElement
Returns the name of this SOAPElement object.
getElementQName() - Method in interface javax.xml.soap.SOAPElement
Returns the qname of this SOAPElement object.
getElementText() - Method in class javax.xml.stream.util.EventReaderDelegate
getElementText() - Method in class javax.xml.stream.util.StreamReaderDelegate
getElementText() - Method in interface javax.xml.stream.XMLEventReader
Reads the content of a text-only element.
getElementText() - Method in interface javax.xml.stream.XMLStreamReader
Reads the content of a text-only element, an exception is thrown if this is not a text-only element.
getELResolver() - Method in class javax.el.ELContext
Retrieves the ELResolver associated with this context.
getELResolver() - Method in class javax.faces.application.Application
Return the singleton ELResolver instance to be used for all EL resolution.
getEmailAddresses() - Method in interface javax.xml.registry.infomodel.User
Gets the email addresses for this User.
getEnabledClass() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the enabledClass property.
getEnabledClass() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the enabledClass property.
getEnabledClass() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the enabledClass property.
getEnabledClass() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the enabledClass property.
getEnabledClass() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the enabledClass property.
getEnabledClass() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the enabledClass property.
getEnclosingWriter() - Method in class javax.servlet.jsp.tagext.BodyContent
Get the enclosing JspWriter.
getEncoding() - Method in class javax.mail.internet.MimeBodyPart
Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.
getEncoding() - Method in class javax.mail.internet.MimeMessage
Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.
getEncoding() - Method in interface javax.mail.internet.MimePart
Get the transfer encoding of this part.
getEncoding(DataSource) - Static method in class javax.mail.internet.MimeUtility
Get the content-transfer-encoding that should be applied to the input stream of this datasource, to make it mailsafe.
getEncoding(DataHandler) - Static method in class javax.mail.internet.MimeUtility
Same as getEncoding(DataSource) except that instead of reading the data from an InputStream it uses the writeTo method to examine the data.
getEncoding() - Method in class javax.mail.internet.PreencodedMimeBodyPart
Returns the content transfer encoding specified when this object was created.
getEncoding() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
Convenience method for getting the current output encoding.
getEncoding() - Method in class javax.xml.stream.util.StreamReaderDelegate
getEncoding() - Method in interface javax.xml.stream.XMLStreamReader
Return input encoding if known or null if unknown.
getEncodingStyle() - Method in interface javax.xml.soap.SOAPElement
Returns the encoding style for this SOAPElement object.
getEnctype() - Method in class javax.faces.component.html.HtmlForm
Return the value of the enctype property.
getEngineInfo() - Method in class javax.servlet.jsp.JspFactory
called to get implementation-specific information on the current JSP engine.
getEntities() - Method in interface javax.xml.stream.events.DTD
Return a List containing the general entities, both external and internal, declared in the DTD.
getEntity() - Method in exception javax.persistence.OptimisticLockException
Returns the entity that caused this exception.
getEntry(String) - Method in interface javax.enterprise.deploy.model.DeployableObject
Returns the InputStream for the given entry name The file name must be relative to the root of the module.
getEnumeration() - Method in interface javax.jms.QueueBrowser
Gets an enumeration for browsing the current queue messages in the order they would be received.
getEnumValueTable() - Method in class javax.enterprise.deploy.shared.ActionType
Returns the enumeration value table for class ActionType
getEnumValueTable() - Method in class javax.enterprise.deploy.shared.CommandType
Returns the enumeration value table for class CommandType
getEnumValueTable() - Method in class javax.enterprise.deploy.shared.DConfigBeanVersionType
Returns the enumeration value table for class DConfigBeanVersionType
getEnumValueTable() - Method in class javax.enterprise.deploy.shared.ModuleType
Returns the enumeration value table for class ModuleType
getEnumValueTable() - Method in class javax.enterprise.deploy.shared.StateType
Returns the enumeration value table for class StateType
getEnvelope() - Method in class javax.xml.soap.SOAPPart
Gets the SOAPEnvelope object associated with this SOAPPart object.
getEnvironment() - Method in interface javax.ejb.EJBContext
Deprecated. Use the JNDI naming context java:comp/env to access enterprise bean's environment.
getErrorClass() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the errorClass property.
getErrorClass() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the errorClass property.
getErrorCode() - Method in exception javax.jms.JMSException
Gets the vendor-specific error code.
getErrorCode() - Method in exception javax.resource.ResourceException
Get the error code.
getErrorCode() - Method in exception javax.xml.bind.JAXBException
Get the vendor specific error code
getErrorCode() - Method in exception javax.xml.bind.TypeConstraintException
Get the vendor specific error code
getErrorData() - Method in class javax.servlet.jsp.PageContext
Provides convenient access to error information.
getErrorObjectKey() - Method in exception javax.xml.registry.RegistryException
Gets the Key to the first object that encountered an error in the registry.
getErrorStyle() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the errorStyle property.
getErrorStyle() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the errorStyle property.
getEventAllocator() - Method in class javax.xml.stream.XMLInputFactory
Gets the allocator used by streams created with this factory
getEventHandler() - Method in class javax.xml.bind.Binder
Return the current event handler or the default event handler if one hasn't been set.
getEventHandler() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
getEventHandler() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
Return the current event handler or the default event handler if one hasn't been set.
getEventHandler() - Method in interface javax.xml.bind.Marshaller
Return the current event handler or the default event handler if one hasn't been set.
getEventHandler() - Method in interface javax.xml.bind.Unmarshaller
Return the current event handler or the default event handler if one hasn't been set.
getEventHandler() - Method in interface javax.xml.bind.Validator
Deprecated. since JAXB2.0
getEvents() - Method in class javax.xml.bind.util.ValidationEventCollector
Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.
getEventType() - Method in interface javax.xml.registry.infomodel.AuditableEvent
Gets the type of this event.
getEventType() - Method in interface javax.xml.stream.events.XMLEvent
Returns an integer code for this event.
getEventType() - Method in class javax.xml.stream.util.StreamReaderDelegate
getEventType() - Method in interface javax.xml.stream.XMLStreamReader
Returns an integer code that indicates the type of the event the cursor is pointing to.
getException() - Method in class javax.resource.spi.ConnectionEvent
Get the exception.
getException() - Method in class javax.resource.spi.work.WorkEvent
Return the WorkException.
getException() - Method in class javax.servlet.jsp.PageContext
The current value of the exception object (an Exception).
getException() - Method in error javax.xml.stream.FactoryConfigurationError
Return the nested exception (if any)
getExceptionListener() - Method in interface javax.jms.Connection
Gets the ExceptionListener object for this connection.
getExceptions() - Method in interface javax.xml.registry.BulkResponse
Get the Collection of RegistryException instances in case of partial commit.
getExecutor() - Method in class javax.xml.ws.Endpoint
Returns the executor for this Endpointinstance.
getExecutor() - Method in class javax.xml.ws.Service
Returns the executor for this Serviceinstance.
getExecutor() - Method in class javax.xml.ws.spi.ServiceDelegate
Returns the executor for this Serviceinstance.
getExpectedType() - Method in class javax.el.ValueExpression
Returns the type the result of the expression will be coerced to after evaluation.
getExpectedTypeName() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
Returns the name of the expected type (as a String) of this deferred value attribute.
getExpiration() - Method in interface javax.xml.registry.infomodel.RegistryEntry
Gets expirationDate attribute of the RegistryEntry within the Registry.
getExpiredMessageCount() - Method in interface javax.management.j2ee.statistics.JMSEndpointStats
Number of messages that expired before delivery.
getExpiredMessageCount() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Number of expired messages.
getExpressionEvaluator() - Method in class javax.servlet.jsp.JspContext
Deprecated. As of JSP 2.1, replaced by JspApplicationContext.getExpressionFactory()
getExpressionFactory() - Method in class javax.faces.application.Application
Return the ExpressionFactory instance for this application.
getExpressionFactory() - Method in interface javax.servlet.jsp.JspApplicationContext
Returns a factory used to create ValueExpressions and MethodExpressions so that EL expressions can be parsed and evaluated.
getExpressionString() - Method in class javax.el.Expression
Returns the original String used to create this Expression, unmodified.
getExpressionString() - Method in class javax.faces.el.MethodBinding
Deprecated. Return the (possibly null) expression String, with leading and trailing delimiters, from which this MethodBinding was built.
getExpressionString() - Method in class javax.faces.el.ValueBinding
Deprecated. Return the (possibly null) expression String, including the delimiters, from which this ValueBinding was built.
getExtension() - Method in interface javax.xml.registry.infomodel.TelephoneNumber
Gets the internal extension.
getExternalContext() - Method in class javax.faces.context.FacesContext
Return the ExternalContext instance for this FacesContext instance.
getExternalIdentifiers() - Method in interface javax.xml.registry.infomodel.RegistryObject
Returns the ExternalIdentifiers associated with this object that are external identifiers for this object.
getExternalLinks() - Method in interface javax.xml.registry.infomodel.RegistryObject
Returns the ExternalLinks associated with this object.
getExternalURI() - Method in interface javax.xml.registry.infomodel.ExternalLink
Gets URI to the an external resource.
getFacesContext() - Method in class javax.faces.component.UIComponent
Convenience method to return the FacesContext instance for the current request.
getFacesContext() - Method in class javax.faces.component.UIComponentBase
getFacesContext(Object, Object, Object, Lifecycle) - Method in class javax.faces.context.FacesContextFactory
Create (if needed) and return a FacesContext instance that is initialized for the processing of the specified request and response objects, utilizing the specified Lifecycle instance, for this web application.
getFacesContext() - Method in class javax.faces.event.PhaseEvent
Return the FacesContext for the request being processed.
getFacesContext() - Method in class javax.faces.webapp.UIComponentClassicTagBase
getFacesContext() - Method in class javax.faces.webapp.UIComponentTagBase
Return the FacesContext instance for the current request.
getFacesJspId() - Method in class javax.faces.webapp.UIComponentClassicTagBase
If this method has been called before on this tag's useful lifetime (before UIComponentClassicTagBase.release() was called), return the previously returned value.
getFacesListeners(Class) - Method in class javax.faces.component.UIComponent
Return an array of registered FacesListeners that are instances of the specified class.
getFacesListeners(Class) - Method in class javax.faces.component.UIComponentBase
getFacesMessage() - Method in exception javax.faces.convert.ConverterException
Returns the FacesMessage associated with this exception; this will only be available if the converter that thew this exception instance placed it there.
getFacesMessage() - Method in exception javax.faces.validator.ValidatorException
Returns the FacesMessage associated with the exception.
getFacet(String) - Method in class javax.faces.component.UIComponent
Convenience method to return the named facet, if it exists, or null otherwise.
getFacet(String) - Method in class javax.faces.component.UIComponentBase
getFacetCount() - Method in class javax.faces.component.UIComponent
Return the number of facet UIComponents that are associated with this UIComponent.
getFacetCount() - Method in class javax.faces.component.UIComponentBase
getFacetName() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Return the facet name that we should be stored under, if any; otherwise, return null (indicating that we will be a child component).
getFacets() - Method in class javax.faces.component.UIComponent
Return a mutable Map representing the facet UIComponents associated with this UIComponent, keyed by facet name (which must be a String).
getFacets() - Method in class javax.faces.component.UIComponentBase
getFacetsAndChildren() - Method in class javax.faces.component.UIComponent
Return an Iterator over the facet followed by child UIComponents of this UIComponent.
getFacetsAndChildren() - Method in class javax.faces.component.UIComponentBase
getFactory(String) - Static method in class javax.faces.FactoryFinder
Create (if necessary) and return a per-web-application instance of the appropriate implementation class for the specified JavaServer Faces factory class, based on the discovery algorithm described in the class description.
getFamily() - Method in class javax.faces.component.UIColumn
getFamily() - Method in class javax.faces.component.UICommand
getFamily() - Method in class javax.faces.component.UIComponent
Return the identifier of the component family to which this component belongs.
getFamily() - Method in class javax.faces.component.UIData
getFamily() - Method in class javax.faces.component.UIForm
getFamily() - Method in class javax.faces.component.UIGraphic
getFamily() - Method in class javax.faces.component.UIInput
getFamily() - Method in class javax.faces.component.UIMessage
getFamily() - Method in class javax.faces.component.UIMessages
getFamily() - Method in class javax.faces.component.UINamingContainer
getFamily() - Method in class javax.faces.component.UIOutput
getFamily() - Method in class javax.faces.component.UIPanel
getFamily() - Method in class javax.faces.component.UIParameter
getFamily() - Method in class javax.faces.component.UISelectBoolean
getFamily() - Method in class javax.faces.component.UISelectItem
getFamily() - Method in class javax.faces.component.UISelectItems
getFamily() - Method in class javax.faces.component.UISelectMany
getFamily() - Method in class javax.faces.component.UISelectOne
getFamily() - Method in class javax.faces.component.UIViewRoot
getFatalClass() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the fatalClass property.
getFatalClass() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the fatalClass property.
getFatalStyle() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the fatalStyle property.
getFatalStyle() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the fatalStyle property.
getFault() - Method in interface javax.xml.soap.SOAPBody
Returns the SOAPFault object in this SOAPBody object.
getFault() - Method in exception javax.xml.ws.soap.SOAPFaultException
Gets the embedded SOAPFault instance.
getFaultActor() - Method in exception javax.xml.rpc.soap.SOAPFaultException
Gets the faultactor element.
getFaultActor() - Method in interface javax.xml.soap.SOAPFault
Gets the fault actor for this SOAPFault object.
getFaultCode() - Method in exception javax.xml.rpc.soap.SOAPFaultException
Gets the faultcode element.
getFaultCode() - Method in interface javax.xml.soap.SOAPFault
Gets the fault code for this SOAPFault object.
getFaultCodeAsName() - Method in interface javax.xml.soap.SOAPFault
Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object.
getFaultCodeAsQName() - Method in interface javax.xml.soap.SOAPFault
Gets the fault code for this SOAPFault object as a QName object.
getFaultNode() - Method in interface javax.xml.soap.SOAPFault
Returns the optional Node element value for this SOAPFault object.
getFaultReasonLocales() - Method in interface javax.xml.soap.SOAPFault
Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items.
getFaultReasonText(Locale) - Method in interface javax.xml.soap.SOAPFault
Returns the Reason Text associated with the given Locale.
getFaultReasonTexts() - Method in interface javax.xml.soap.SOAPFault
Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.
getFaultRole() - Method in interface javax.xml.soap.SOAPFault
Returns the optional Role element value for this SOAPFault object.
getFaultString() - Method in exception javax.xml.rpc.soap.SOAPFaultException
Gets the faultstring element.
getFaultString() - Method in interface javax.xml.soap.SOAPFault
Gets the fault string for this SOAPFault object.
getFaultStringLocale() - Method in interface javax.xml.soap.SOAPFault
Gets the locale of the fault string for this SOAPFault object.
getFaultSubcodes() - Method in interface javax.xml.soap.SOAPFault
Gets the Subcodes for this SOAPFault as an iterator over QNames.
getFeatureDescriptors(ELContext, Object) - Method in class javax.el.ArrayELResolver
Always returns null, since there is no reason to iterate through set set of all integers.
getFeatureDescriptors(ELContext, Object) - Method in class javax.el.BeanELResolver
If the base object is not null, returns an Iterator containing the set of JavaBeans properties available on the given object.
getFeatureDescriptors(ELContext, Object) - Method in class javax.el.CompositeELResolver
Returns information about the set of variables or properties that can be resolved for the given base object.
getFeatureDescriptors(ELContext, Object) - Method in class javax.el.ELResolver
Returns information about the set of variables or properties that can be resolved for the given base object.
getFeatureDescriptors(ELContext, Object) - Method in class javax.el.ListELResolver
Always returns null, since there is no reason to iterate through set set of all integers.
getFeatureDescriptors(ELContext, Object) - Method in class javax.el.MapELResolver
If the base object is a map, returns an Iterator containing the set of keys available in the Map.
getFeatureDescriptors(ELContext, Object) - Method in class javax.el.ResourceBundleELResolver
If the base object is a ResourceBundle, returns an Iterator containing the set of keys available in the ResourceBundle.
getFeatureDescriptors(ELContext, Object) - Method in class javax.servlet.jsp.el.ImplicitObjectELResolver
If the base object is null, and the property matches the name of a JSP implicit object, returns an Iterator containing FeatureDescriptor objects with information about each JSP implicit object resolved by this resolver.
getFeatureDescriptors(ELContext, Object) - Method in class javax.servlet.jsp.el.ScopedAttributeELResolver
If the base object is null, returns an Iterator containing FeatureDescriptor objects with information about each scoped attribute resolved by this resolver.
getFile() - Method in class javax.activation.FileDataSource
Return the File object that corresponds to this FileDataSource.
getFile() - Method in class javax.mail.URLName
Returns the file name of this URLName.
getFilename() - Method in interface javax.enterprise.deploy.model.DDBeanRoot
Returns the filename relative to the root of the module of the XML instance document this DDBeanRoot represents.
getFileName() - Method in class javax.mail.internet.MimeBodyPart
Get the filename associated with this body part.
getFileName() - Method in class javax.mail.internet.MimeMessage
Get the filename associated with this Message.
getFileName() - Method in interface javax.mail.Part
Get the filename associated with this part, if possible.
getFilterName() - Method in interface javax.servlet.FilterConfig
Returns the filter-name of this filter as defined in the deployment descriptor.
getFirst() - Method in class javax.faces.component.UIData
Return the zero-relative row number of the first row to be displayed.
getFirstName() - Method in interface javax.xml.registry.infomodel.PersonName
Gets the first name for this Person.
getFlags() - Method in class javax.mail.internet.MimeMessage
Return a Flags object containing the flags for this message.
getFlags() - Method in class javax.mail.Message
Returns a Flags object containing the flags for this message.
getFlags() - Method in class javax.mail.search.FlagTerm
Return the Flags to test.
getFloat(String) - Method in interface javax.jms.MapMessage
Returns the float value with the specified name.
getFloatProperty(String) - Method in interface javax.jms.Message
Returns the value of the float property with the specified name.
getFlushMode() - Method in interface javax.persistence.EntityManager
Get the flush mode that applies to all objects contained in the persistence context.
getFolder() - Method in class javax.mail.event.FolderEvent
Return the affected folder.
getFolder(String) - Method in class javax.mail.Folder
Return the Folder object corresponding to the given name.
getFolder() - Method in exception javax.mail.FolderClosedException
Returns the dead Folder object
getFolder() - Method in exception javax.mail.FolderNotFoundException
Returns the offending Folder object.
getFolder() - Method in class javax.mail.Message
Get the folder from which this message was obtained.
getFolder() - Method in exception javax.mail.ReadOnlyFolderException
Returns the dead Folder object.
getFolder(URLName) - Method in class javax.mail.Session
Get a closed Folder object for the given URLName.
getFolder(String) - Method in class javax.mail.Store
Return the Folder object corresponding to the given name.
getFolder(URLName) - Method in class javax.mail.Store
Return a closed Folder object, corresponding to the given URLName.
getFooter() - Method in class javax.faces.component.UIColumn
Return the footer facet of the column (if any).
getFooter() - Method in class javax.faces.component.UIData
Return the footer facet of this component (if any).
getFooterClass() - Method in class javax.faces.component.html.HtmlColumn
Return the value of the footerClass property.
getFooterClass() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the footerClass property.
getFooterClass() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the footerClass property.
getFor() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the for property.
getFor() - Method in class javax.faces.component.UIMessage
Return the client identifier of the component for which this component represents associated message(s) (if any).
getFormatId() - Method in interface javax.transaction.xa.Xid
Obtain the format identifier part of the XID.
getFrame() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the frame property.
getFrame() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the frame property.
getFreePoolSize() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats
The number of free connections in the pool
getFreePoolSize() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats
Number of free connections in the pool.
getFrom() - Method in class javax.mail.internet.MimeMessage
Returns the value of the RFC 822 "From" header fields.
getFrom() - Method in class javax.mail.Message
Returns the "From" attribute.
getFullName() - Method in class javax.mail.Folder
Returns the full name of this Folder.
getFullName() - Method in interface javax.xml.registry.infomodel.PersonName
Gets the fully formatted name for this person.
getFunction(String) - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
Get the FunctionInfo for a given function name, looking through all the functions in this tag library.
getFunctionClass() - Method in class javax.servlet.jsp.tagext.FunctionInfo
The class of the function.
getFunctionMapper() - Method in class javax.el.ELContext
Retrieves the FunctionMapper associated with this ELContext.
getFunctions() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
An array describing the functions that are defined in this tag library.
getFunctionSignature() - Method in class javax.servlet.jsp.tagext.FunctionInfo
The signature of the function.
getGlobalTransactionId() - Method in interface javax.transaction.xa.Xid
Obtain the global transaction identifier part of XID as an array of bytes.
getGroup(boolean) - Method in class javax.mail.internet.InternetAddress
Return the members of a group address.
getHandle() - Method in interface javax.ejb.EJBObject
Obtain a handle for the EJB object.
getHandle() - Method in interface javax.ejb.Timer
Get a serializable handle to the timer.
getHandlerChain(QName) - Method in interface javax.xml.rpc.handler.HandlerRegistry
Gets the handler chain for the specified service endpoint.
getHandlerChain() - Method in interface javax.xml.ws.Binding
Gets a copy of the handler chain for a protocol binding instance.
getHandlerChain(PortInfo) - Method in interface javax.xml.ws.handler.HandlerResolver
Gets the handler chain for the specified port.
getHandlerClass() - Method in class javax.xml.rpc.handler.HandlerInfo
Gets the Handler class
getHandlerConfig() - Method in class javax.xml.rpc.handler.HandlerInfo
Gets the Handler configuration
getHandlerKeys() - Static method in class javax.security.jacc.PolicyContext
This method may be used to obtain the keys that identify the container specific context handlers registered by the container.
getHandlerRegistry() - Method in interface javax.xml.rpc.Service
Returns the configured HandlerRegistry instance for this Service instance.
getHandlerResolver() - Method in class javax.xml.ws.Service
Returns the configured handler resolver.
getHandlerResolver() - Method in class javax.xml.ws.spi.ServiceDelegate
Returns the configured handler resolver.
getHeader() - Method in class javax.faces.component.UIColumn
Return the header facet of the column (if any).
getHeader() - Method in class javax.faces.component.UIData
Return the header facet of this component (if any).
getHeader(String) - Method in class javax.mail.internet.InternetHeaders
Return all the values for the specified header.
getHeader(String, String) - Method in class javax.mail.internet.InternetHeaders
Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
getHeader(String) - Method in class javax.mail.internet.MimeBodyPart
Get all the headers for this header_name.
getHeader(String, String) - Method in class javax.mail.internet.MimeBodyPart
Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
getHeader(String) - Method in class javax.mail.internet.MimeMessage
Get all the headers for this header_name.
getHeader(String, String) - Method in class javax.mail.internet.MimeMessage
Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
getHeader(String, String) - Method in interface javax.mail.internet.MimePart
Get the values of all header fields available for this header, returned as a single String, with the values separated by the delimiter.
getHeader(String) - Method in interface javax.mail.Part
Get all the headers for this header name.
getHeader(String) - Method in interface javax.servlet.http.HttpServletRequest
Returns the value of the specified request header as a String.
getHeader(String) - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getHeader(String name) on the wrapped request object.
getHeader(String) - Method in class javax.xml.soap.MimeHeaders
Returns all of the values for the specified header as an array of String objects.
getHeader() - Method in interface javax.xml.soap.SOAPEnvelope
Returns the SOAPHeader object for this SOAPEnvelope object.
getHeaderClass() - Method in class javax.faces.component.html.HtmlColumn
Return the value of the headerClass property.
getHeaderClass() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the headerClass property.
getHeaderClass() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the headerClass property.
getHeaderName() - Method in class javax.mail.search.HeaderTerm
Return the name of the header to compare with.
getHeaderNames() - Method in class javax.mail.FetchProfile
Get the names of the header-fields set in this profile.
getHeaderNames() - Method in interface javax.servlet.http.HttpServletRequest
Returns an enumeration of all the header names this request contains.
getHeaderNames() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getHeaderNames() on the wrapped request object.
getHeaders(String) - Method in interface javax.servlet.http.HttpServletRequest
Returns all the values of the specified request header as an Enumeration of String objects.
getHeaders(String) - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getHeaders(String name) on the wrapped request object.
getHeaders() - Method in class javax.xml.rpc.handler.GenericHandler
Gets the header blocks processed by this Handler instance.
getHeaders() - Method in interface javax.xml.rpc.handler.Handler
Gets the header blocks that can be processed by this Handler instance.
getHeaders() - Method in class javax.xml.rpc.handler.HandlerInfo
Gets the header blocks processed by this Handler.
getHeaders() - Method in interface javax.xml.ws.handler.soap.SOAPHandler
Gets the header blocks that can be processed by this Handler instance.
getHeaders(QName, JAXBContext, boolean) - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext
Gets headers that have a particular qualified name from the message in the message context.
getHeapSize() - Method in interface javax.management.j2ee.statistics.JVMStats
Size of the JVM's heap.
getHeight() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the height property.
getHighWaterMark() - Method in interface javax.management.j2ee.statistics.RangeStatistic
The highest value this attribute has held since the beginning of the measurement.
getHomeHandle() - Method in interface javax.ejb.EJBHome
Obtain a handle for the remote home object.
getHomeInterfaceClass() - Method in interface javax.ejb.EJBMetaData
Obtain the Class object for the enterprise Bean's remote home interface.
getHost() - Method in class javax.mail.internet.NewsAddress
Get the host.
getHost() - Method in class javax.mail.URLName
Returns the host of this URLName.
getHreflang() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the hreflang property.
getHreflang() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the hreflang property.
getHttpSession() - Method in interface javax.xml.rpc.server.ServletEndpointContext
The getHttpSession method returns the current HTTP session (as a javax.servlet.http.HTTPSession).
getHumanPresentableName() - Method in class javax.activation.ActivationDataFlavor
Return the Human Presentable name.
getId() - Method in interface javax.enterprise.deploy.model.DDBean
Returns a tool-specific reference for attribute ID on an element in the deployment descriptor.
getId() - Method in class javax.faces.component.UIComponent
Return the component identifier of this UIComponent.
getId() - Method in class javax.faces.component.UIComponentBase
getId() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Return the id value assigned by the page author.
getId() - Method in class javax.resource.spi.ConnectionEvent
Get the type of event
getId() - Method in interface javax.servlet.http.HttpSession
Returns a string containing the unique identifier assigned to this session.
getId() - Method in class javax.servlet.jsp.tagext.TagData
The value of the tag's id attribute.
getId() - Method in class javax.servlet.jsp.tagext.TagSupport
The value of the id attribute of this tag; or null.
getId() - Method in class javax.servlet.jsp.tagext.ValidationMessage
Get the jsp:id.
getId() - Method in interface javax.xml.registry.infomodel.Key
Returns the unique Id of this key.
getIdAttribute(TagAttributeInfo[]) - Static method in class javax.servlet.jsp.tagext.TagAttributeInfo
Convenience static method that goes through an array of TagAttributeInfo objects and looks for "id".
getIdentificationScheme() - Method in interface javax.xml.registry.infomodel.ExternalIdentifier
Gets the ClassificationScheme that is used as the identification scheme for identifying this object.
getIds() - Method in interface javax.servlet.http.HttpSessionContext
Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return an empty Enumeration and will be removed in a future version of this API.
getIgnoreCase() - Method in class javax.mail.search.StringTerm
Return true if we should ignore case when matching.
getImage() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the image property.
getImplementor() - Method in class javax.xml.ws.Endpoint
Returns the implementation object for this endpoint.
getIndexOfNextChildTag() - Method in class javax.faces.webapp.UIComponentClassicTagBase
getIndexOfNextChildTag() - Method in class javax.faces.webapp.UIComponentTagBase
Return the index of the next child to be added as a child of this tag.
getInfo() - Method in interface javax.ejb.Timer
Get the information associated with the timer at the time of creation.
getInfoClass() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the infoClass property.
getInfoClass() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the infoClass property.
getInfoString() - Method in class javax.servlet.jsp.tagext.TagInfo
The information string for the tag.
getInfoString() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
Information (documentation) for this TLD.
getInfoStyle() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the infoStyle property.
getInfoStyle() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the infoStyle property.
getInitParameter(String) - Method in class javax.faces.context.ExternalContext
Return the value of the specified application initialization parameter (if any).
getInitParameter(String) - Method in interface javax.servlet.FilterConfig
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.
getInitParameter(String) - Method in class javax.servlet.GenericServlet
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.
getInitParameter(String) - Method in interface javax.servlet.ServletConfig
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.
getInitParameter(String) - Method in interface javax.servlet.ServletContext
Returns a String containing the value of the named context-wide initialization parameter, or null if the parameter does not exist.
getInitParameterMap() - Method in class javax.faces.context.ExternalContext
Return an immutable Map whose keys are the set of application initialization parameter names configured for this application, and whose values are the corresponding parameter values.
getInitParameterNames() - Method in interface javax.servlet.FilterConfig
Returns the names of the filter's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the filter has no initialization parameters.
getInitParameterNames() - Method in class javax.servlet.GenericServlet
Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.
getInitParameterNames() - Method in interface javax.servlet.ServletConfig
Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.
getInitParameterNames() - Method in interface javax.servlet.ServletContext
Returns the names of the context's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the context has no initialization parameters.
getInitParameters() - Method in class javax.servlet.jsp.tagext.TagLibraryValidator
Get the init parameters data as an immutable Map.
getInputStream() - Method in class javax.activation.DataHandler
Get the InputStream for this object.
getInputStream() - Method in interface javax.activation.DataSource
This method returns an InputStream representing the data and throws the appropriate exception if it can not do so.
getInputStream() - Method in class javax.activation.FileDataSource
This method will return an InputStream representing the the data and will throw an IOException if it can not do so.
getInputStream() - Method in class javax.activation.URLDataSource
The getInputStream method from the URL.
getInputStream() - Method in class javax.mail.internet.MimeBodyPart
Return a decoded input stream for this body part's "content".
getInputStream() - Method in class javax.mail.internet.MimeMessage
Return a decoded input stream for this Message's "content".
getInputStream() - Method in class javax.mail.internet.MimePartDataSource
Returns an input stream from this MimePart.
getInputStream() - Method in interface javax.mail.Part
Return an input stream for this part's "content".
getInputStream() - Method in class javax.mail.util.ByteArrayDataSource
Return an InputStream for the data.
getInputStream() - Method in class javax.servlet.jsp.tagext.PageData
Returns an input stream on the XML view of a JSP page.
getInputStream() - Method in interface javax.servlet.ServletRequest
Retrieves the body of the request as binary data using a ServletInputStream.
getInputStream() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getInputStream() on the wrapped request object.
getInstance() - Static method in class javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
Retrieve the Singleton DeploymentFactoryManager
getInstance(Properties, Authenticator) - Static method in class javax.mail.Session
Get a new Session object.
getInstance(Properties) - Static method in class javax.mail.Session
Get a new Session object.
getInt(String) - Method in interface javax.jms.MapMessage
Returns the int value with the specified name.
getInteractionSpecsSupported() - Method in interface javax.resource.cci.ResourceAdapterMetaData
Returns an array of fully-qualified names of InteractionSpec types supported by the CCI implementation for this resource adapter.
getIntHeader(String) - Method in interface javax.servlet.http.HttpServletRequest
Returns the value of the specified request header as an int.
getIntHeader(String) - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getIntHeader(String name) on the wrapped request object.
getIntProperty(String) - Method in interface javax.jms.Message
Returns the value of the int property with the specified name.
getInvalidAddresses() - Method in class javax.mail.event.TransportEvent
Return the addresses to which this message could not be sent.
getInvalidAddresses() - Method in exception javax.mail.SendFailedException
Return the addresses to which this message could not be sent.
getInvalidConnections(Set) - Method in interface javax.resource.spi.ValidatingManagedConnectionFactory
This method returns a set of invalid ManagedConnection objects chosen from a specified set of ManagedConnection objects.
getInvalidPropertyDescriptors() - Method in exception javax.resource.spi.InvalidPropertyException
Get the list of invalid properties.
getInvokedBusinessInterface() - Method in interface javax.ejb.SessionContext
Obtain the business interface through which the current business method invocation was made.
getItemDescription() - Method in class javax.faces.component.UISelectItem
Return the description for this selection item.
getItemLabel() - Method in class javax.faces.component.UISelectItem
Return the localized label for this selection item.
getItems() - Method in class javax.mail.FetchProfile
Get the items set in this profile.
getItemValue() - Method in class javax.faces.component.UISelectItem
Return the server value for this selection item.
getJarFileUrls() - Method in interface javax.persistence.spi.PersistenceUnitInfo
Returns a list of URLs for the jar files or exploded jar file directories that the persistence provider must examine for managed classes of the persistence unit.
getJavaEncoding(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
Gets the corresponding Java encoding name from an IANA name.
getJAXBNode(XmlNode) - Method in class javax.xml.bind.Binder
Gets the JAXB object associated with the given XML element.
getJdbcDataSource() - Method in interface javax.management.j2ee.statistics.JDBCConnectionStats
Identifies the JDBC driver for the corresponding JDBCConnection.
getJMSCorrelationID() - Method in interface javax.jms.Message
Gets the correlation ID for the message.
getJMSCorrelationIDAsBytes() - Method in interface javax.jms.Message
Gets the correlation ID as an array of bytes for the message.
getJMSDeliveryMode() - Method in interface javax.jms.Message
Gets the DeliveryMode value specified for this message.
getJMSDestination() - Method in interface javax.jms.Message
Gets the Destination object for this message.
getJMSExpiration() - Method in interface javax.jms.Message
Gets the message's expiration value.
getJMSMajorVersion() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS major version number.
getJMSMessageID() - Method in interface javax.jms.Message
Gets the message ID.
getJMSMinorVersion() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS minor version number.
getJMSPriority() - Method in interface javax.jms.Message
Gets the message priority level.
getJMSProviderName() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS provider name.
getJMSRedelivered() - Method in interface javax.jms.Message
Gets an indication of whether this message is being redelivered.
getJMSReplyTo() - Method in interface javax.jms.Message
Gets the Destination object to which a reply to this message should be sent.
getJMSTimestamp() - Method in interface javax.jms.Message
Gets the message timestamp.
getJMSType() - Method in interface javax.jms.Message
Gets the message type identifier supplied by the client when the message was sent.
getJMSVersion() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS API version.
getJMSXPropertyNames() - Method in interface javax.jms.ConnectionMetaData
Gets an enumeration of the JMSX property names.
getJspApplicationContext(ServletContext) - Method in class javax.servlet.jsp.JspFactory
Obtains the JspApplicationContext instance associated with the web application for the given ServletContext.
getJspBody() - Method in class javax.servlet.jsp.tagext.SimpleTagSupport
Returns the body passed in by the container via setJspBody.
getJspContext() - Method in class javax.servlet.jsp.tagext.JspFragment
Returns the JspContext that is bound to this JspFragment.
getJspContext() - Method in class javax.servlet.jsp.tagext.SimpleTagSupport
Returns the page context passed in by the container via setJspContext.
getJspId() - Method in class javax.faces.webapp.UIComponentClassicTagBase
getJtaDataSource() - Method in interface javax.persistence.spi.PersistenceUnitInfo
Returns the JTA-enabled data source to be used by the persistence provider.
getKey() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets the key representing the universally unique ID (UUID) for this object.
getKeys() - Method in interface javax.security.jacc.PolicyContextHandler
This public method returns the keys identifying the context objects supported by the handler.
getLabel() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the label property.
getLabel() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the label property.
getLabel() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the label property.
getLabel() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the label property.
getLabel() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the label property.
getLabel() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the label property.
getLabel() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the label property.
getLabel() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the label property.
getLabel() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the label property.
getLabel() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the label property.
getLabel() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the label property.
getLabel() - Method in class javax.faces.model.SelectItem
Return the label of this item, to be rendered visibly for the user.
getLang() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlForm
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlOutputFormat
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlOutputText
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the lang property.
getLang() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the lang property.
getLargeIcon() - Method in class javax.servlet.jsp.tagext.TagInfo
Get the path to the large icon.
getLastAccessedTime() - Method in interface javax.servlet.http.HttpSession
Returns the last time the client sent a request associated with this session, as the number of milliseconds since midnight January 1, 1970 GMT, and marked by the time the container received the request.
getLastModified(HttpServletRequest) - Method in class javax.servlet.http.HttpServlet
Returns the time the HttpServletRequest object was last modified, in milliseconds since midnight January 1, 1970 GMT.
getLastName() - Method in interface javax.xml.registry.infomodel.PersonName
Gets the last name (surname) for this Person.
getLastSampleTime() - Method in interface javax.management.j2ee.statistics.Statistic
The time of the last measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.
getLayout() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the layout property.
getLayout() - Method in class javax.faces.component.html.HtmlPanelGroup
Return the value of the layout property.
getLayout() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the layout property.
getLayout() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the layout property.
getLifecycle(String) - Method in class javax.faces.lifecycle.LifecycleFactory
Create (if needed) and return a Lifecycle instance for the specified lifecycle identifier.
getLifecycleIds() - Method in class javax.faces.lifecycle.LifecycleFactory
Return an Iterator over the set of lifecycle identifiers supported by this factory.
getLifeCycleManager() - Method in interface javax.xml.registry.infomodel.RegistryObject
Returns the LifeCycleManager that created this object.
getLineCount() - Method in class javax.mail.internet.MimeBodyPart
Return the number of lines for the content of this Part.
getLineCount() - Method in class javax.mail.internet.MimeMessage
Return the number of lines for the content of this message.
getLineCount() - Method in interface javax.mail.Part
Return the number of lines in the content of this part.
getLineNumber() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl
getLineNumber() - Method in interface javax.xml.bind.ValidationEventLocator
Return the line number if available
getLineNumber() - Method in interface javax.xml.stream.Location
Return the line number where the current event ends, returns -1 if none is available.
getLinkedCause() - Method in exception javax.xml.rpc.JAXRPCException
Gets the Linked cause
getLinkedCause() - Method in exception javax.xml.rpc.ServiceException
Gets the Linked cause
getLinkedException() - Method in exception javax.jms.JMSException
Gets the exception linked to this one.
getLinkedException() - Method in exception javax.resource.ResourceException
Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class..
getLinkedException() - Method in class javax.xml.bind.helpers.ValidationEventImpl
getLinkedException() - Method in exception javax.xml.bind.JAXBException
Get the linked exception
getLinkedException() - Method in exception javax.xml.bind.TypeConstraintException
Get the linked exception
getLinkedException() - Method in interface javax.xml.bind.ValidationEvent
Retrieve the linked exception for this warning/error.
getLinkedObjects() - Method in interface javax.xml.registry.infomodel.ExternalLink
Gets the collection of RegistryObjects that are annotated by this ExternalLink.
getLinkedWarning() - Method in exception javax.resource.cci.ResourceWarning
Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
getListener() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
getListener() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
getListener() - Method in interface javax.xml.bind.Marshaller
Return Marshaller.Listener registered with this Marshaller.
getListener() - Method in interface javax.xml.bind.Unmarshaller
Return Unmarshaller.Listener registered with this Unmarshaller.
getListenerRegistry() - Method in interface javax.management.j2ee.Management
Returns the listener registry implementation for this MEJB.
getLocalAddr() - Method in interface javax.servlet.ServletRequest
Returns the Internet Protocol (IP) address of the interface on which the request was received.
getLocalAddr() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getLocalAddr() on the wrapped request object.
getLocalAddress(Session) - Static method in class javax.mail.internet.InternetAddress
Return an InternetAddress object representing the current user.
getLocale() - Method in class javax.el.ELContext
Get the Locale stored by a previous invocation to ELContext.setLocale(java.util.Locale).
getLocale() - Method in class javax.faces.component.UIViewRoot
Return the Locale to be used in localizing the response being created for this view.
getLocale() - Method in class javax.faces.convert.DateTimeConverter
Return the Locale to be used when parsing or formatting dates and times.
getLocale() - Method in class javax.faces.convert.NumberConverter
Return the Locale to be used when parsing numbers.
getLocale() - Method in interface javax.servlet.ServletRequest
Returns the preferred Locale that the client will accept content in, based on the Accept-Language header.
getLocale() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getLocale() on the wrapped request object.
getLocale() - Method in interface javax.servlet.ServletResponse
Returns the locale specified for this response using the ServletResponse.setLocale(java.util.Locale) method.
getLocale() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return getLocale() on the wrapped response object.
getLocale() - Method in interface javax.xml.registry.infomodel.LocalizedString
Get the Locale for this object.
getLocales() - Method in interface javax.servlet.ServletRequest
Returns an Enumeration of Locale objects indicating, in decreasing order starting with the preferred locale, the locales that are acceptable to the client based on the Accept-Language header.
getLocales() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getLocales() on the wrapped request object.
getLocalizedString(Locale, String) - Method in interface javax.xml.registry.infomodel.InternationalString
Gets the LocalizedString for the specified Locale and charsetName.
getLocalizedStrings() - Method in interface javax.xml.registry.infomodel.InternationalString
Returns the LocalizedStrings associated with this object.
getLocalName() - Method in interface javax.servlet.ServletRequest
Returns the host name of the Internet Protocol (IP) interface on which the request was received.
getLocalName() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getLocalName() on the wrapped request object.
getLocalName() - Method in interface javax.xml.soap.Name
Gets the local name part of the XML name that this Name object represents.
getLocalName() - Method in class javax.xml.stream.util.StreamReaderDelegate
getLocalName() - Method in interface javax.xml.stream.XMLStreamReader
Returns the (local) name of the current event.
getLocalPort() - Method in interface javax.servlet.ServletRequest
Returns the Internet Protocol (IP) port number of the interface on which the request was received.
getLocalPort() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getLocalPort() on the wrapped request object.
getLocalTransaction() - Method in interface javax.resource.cci.Connection
Returns an LocalTransaction instance that enables a component to demarcate resource manager local transactions on the Connection.
getLocalTransaction() - Method in interface javax.resource.spi.ManagedConnection
Returns an javax.resource.spi.LocalTransaction instance.
getLocalValue() - Method in class javax.faces.component.UIOutput
getLocalValue() - Method in interface javax.faces.component.ValueHolder
Return the local value of this UIComponent (if any), without evaluating any associated ValueExpression.
getLocation() - Method in interface javax.xml.stream.events.XMLEvent
Return the location of this event.
getLocation() - Method in class javax.xml.stream.util.StreamReaderDelegate
getLocation() - Method in exception javax.xml.stream.XMLStreamException
Gets the location of the exception
getLocation() - Method in interface javax.xml.stream.XMLStreamReader
Return the current location of the processor.
getLocator() - Method in class javax.xml.bind.helpers.ValidationEventImpl
getLocator() - Method in interface javax.xml.bind.ValidationEvent
Retrieve the locator for this warning/error.
getLogWriter() - Method in interface javax.resource.spi.ManagedConnection
Gets the log writer for this ManagedConnection instance.
getLogWriter() - Method in interface javax.resource.spi.ManagedConnectionFactory
Get the log writer for this ManagedConnectionFactory instance.
getLong(String) - Method in interface javax.jms.MapMessage
Returns the long value with the specified name.
getLongdesc() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the longdesc property.
getLongProperty(String) - Method in interface javax.jms.Message
Returns the value of the long property with the specified name.
getLowerBound() - Method in interface javax.management.j2ee.statistics.BoundaryStatistic
The lower limit of the value of this attribute.The upper limit of the value of this attribute.
getLowWaterMark() - Method in interface javax.management.j2ee.statistics.RangeStatistic
The lowest value this attribute has held since the beginning of the measurement.
getMajorVersion() - Method in interface javax.servlet.ServletContext
Returns the major version of the Java Servlet API that this servlet container supports.
getMajorVersion() - Method in interface javax.xml.registry.infomodel.Versionable
Gets the major revision number for this version of the Versionable object.
getManagedClassNames() - Method in interface javax.persistence.spi.PersistenceUnitInfo
Returns the list of the names of the classes that the persistence provider must add it to its set of managed classes.
getManagedConnectionFactory() - Method in interface javax.management.j2ee.statistics.JCAConnectionStats
Returns the associated JCAManagedConnectionFactory OBJECT_NAME
getManagedConnectionFactory() - Method in class javax.resource.spi.security.PasswordCredential
Gets the target ManagedConnectionFactory for which the user name and password has been set by the application server.
getMapNames() - Method in interface javax.jms.MapMessage
Returns an Enumeration of all the names in the MapMessage object.
getMappingFileNames() - Method in interface javax.persistence.spi.PersistenceUnitInfo
Returns the list of mapping file names that the persistence provider must load to determine the mappings for the entity classes.
getMatchingHeaderLines(String[]) - Method in class javax.mail.internet.InternetHeaders
Return all matching header lines as an Enumeration of Strings.
getMatchingHeaderLines(String[]) - Method in class javax.mail.internet.MimeBodyPart
Get matching header lines as an Enumeration of Strings.
getMatchingHeaderLines(String[]) - Method in class javax.mail.internet.MimeMessage
Get matching header lines as an Enumeration of Strings.
getMatchingHeaderLines(String[]) - Method in interface javax.mail.internet.MimePart
Get matching header lines as an Enumeration of Strings.
getMatchingHeaders(String[]) - Method in class javax.mail.internet.InternetHeaders
Return all matching Header objects.
getMatchingHeaders(String[]) - Method in class javax.mail.internet.MimeBodyPart
Return matching headers from this Message as an Enumeration of Header objects.
getMatchingHeaders(String[]) - Method in class javax.mail.internet.MimeMessage
Return matching headers from this Message as an Enumeration of Header objects.
getMatchingHeaders(String[]) - Method in interface javax.mail.Part
Return matching headers from this part as an Enumeration of Header objects.
getMatchingHeaders(String[]) - Method in class javax.xml.soap.MimeHeaders
Returns all the MimeHeader objects whose name matches a name in the given array of names.
getMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.AttachmentPart
Retrieves all MimeHeader objects that match a name in the given array.
getMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.SOAPPart
Retrieves all MimeHeader objects that match a name in the given array.
getMaxAge() - Method in class javax.servlet.http.Cookie
Returns the maximum age of the cookie, specified in seconds, By default, -1 indicating the cookie will persist until browser shutdown.
getMaxConnections() - Method in interface javax.resource.spi.ManagedConnectionMetaData
Returns maximum limit on number of active concurrent connections that an EIS instance can support across client processes.
getMaxFractionDigits() - Method in class javax.faces.convert.NumberConverter
Return the maximum number of digits getAsString() should render in the fraction portion of the result.
getMaximum() - Method in class javax.faces.validator.DoubleRangeValidator
Return the maximum value to be enforced by this Validator or Double.MAX_VALUE if it has not been set.
getMaximum() - Method in class javax.faces.validator.LengthValidator
Return the maximum length to be enforced by this Validator, or 0 if the maximum has not been set.
getMaximum() - Method in class javax.faces.validator.LongRangeValidator
Return the maximum value to be enforced by this Validator.
getMaximumSeverity() - Method in class javax.faces.context.FacesContext
Return the maximum severity level recorded on any FacesMessages that has been queued, whether or not they are associated with any specific UIComponent.
getMaxInactiveInterval() - Method in interface javax.servlet.http.HttpSession
Returns the maximum time interval, in seconds, that the servlet container will keep this session open between client accesses.
getMaxIntegerDigits() - Method in class javax.faces.convert.NumberConverter
Return the maximum number of digits getAsString() should render in the integer portion of the result.
getMaxlength() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the maxlength property.
getMaxlength() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the maxlength property.
getMaxTime() - Method in interface javax.management.j2ee.statistics.TimeStatistic
The maximum amount of time taken to complete one invocation of this operation since the beginning of this measurement.
getMBeanCount() - Method in interface javax.management.j2ee.Management
Returns the number of managed objects registered in the MEJB.
getMBeanInfo(ObjectName) - Method in interface javax.management.j2ee.Management
This method discovers the attributes and operations that a managed object exposes for management.
getMechanismType() - Method in interface javax.xml.rpc.encoding.Deserializer
Gets the type of the XML processing mechanism and representation used by this Deserializer.
getMechanismType() - Method in interface javax.xml.rpc.encoding.Serializer
Gets the type of the XML processing mechanism and representation used by this Serializer.
getMechType() - Method in interface javax.resource.spi.security.GenericCredential
Deprecated. Returns the mechanism type for the GenericCredential instance.
getMessage() - Method in exception javax.ejb.EJBException
Returns the detail message, including the message from the nested exception if there is one.
getMessage() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
Retrieve any additional information about the status of this event.
getMessage() - Method in exception javax.faces.application.ViewExpiredException
Return the message for this exception prepended with the view identifier if the view identifier is not null, otherwise, return the message.
getMessage() - Method in class javax.mail.event.MessageChangedEvent
Return the changed Message.
getMessage() - Method in class javax.mail.event.StoreEvent
Get the message from the Store.
getMessage() - Method in class javax.mail.event.TransportEvent
Get the Message object associated with this Transport Event.
getMessage(int) - Method in class javax.mail.Folder
Get the Message object corresponding to the given message number.
getMessage() - Method in class javax.mail.MessageContext
Return the Message that contains the content.
getMessage() - Method in exception javax.resource.ResourceException
Returns a detailed message string describing this exception.
getMessage() - Method in class javax.servlet.jsp.tagext.ValidationMessage
Get the localized validation message.
getMessage() - Method in class javax.xml.bind.helpers.ValidationEventImpl
getMessage() - Method in interface javax.xml.bind.ValidationEvent
Retrieve the text message for this warning/error.
getMessage() - Method in exception javax.xml.registry.JAXRException
Returns the detail message for this JAXRException object.
getMessage() - Method in interface javax.xml.rpc.handler.soap.SOAPMessageContext
Gets the SOAPMessage from this message context
getMessage() - Method in exception javax.xml.soap.SOAPException
Returns the detail message for this SOAPException object.
getMessage() - Method in error javax.xml.stream.FactoryConfigurationError
Report the message associated with this error
getMessage() - Method in interface javax.xml.ws.handler.LogicalMessageContext
Gets the message from this message context
getMessage() - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext
Gets the SOAPMessage from this message context.
getMessageBundle() - Method in class javax.faces.application.Application
Return the fully qualified class name of the ResourceBundle to be used for JavaServer Faces messages for this application.
getMessageByUID(long) - Method in interface javax.mail.UIDFolder
Get the Message corresponding to the given UID.
getMessageChangeType() - Method in class javax.mail.event.MessageChangedEvent
Return the type of this event.
getMessageContext() - Method in interface javax.ejb.SessionContext
Obtain a reference to the JAX-RPC MessageContext.
getMessageContext() - Method in class javax.mail.internet.MimePartDataSource
Return the MessageContext for the current part.
getMessageContext() - Method in interface javax.mail.MessageAware
Return the message context.
getMessageContext() - Method in interface javax.xml.rpc.server.ServletEndpointContext
The method getMessageContext returns the MessageContext targeted for this endpoint instance.
getMessageContext() - Method in interface javax.xml.ws.WebServiceContext
Returns the MessageContext for the request being served at the time this method is called.
getMessageCount() - Method in class javax.mail.Folder
Get total number of messages in this Folder.
getMessageCount() - Method in interface javax.management.j2ee.statistics.JMSEndpointStats
Number of messages sent or received.
getMessageCount() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Number of messages exchanged.
getMessageCount() - Method in interface javax.management.j2ee.statistics.MessageDrivenBeanStats
Number of messages received.
getMessageFactory() - Method in interface javax.xml.ws.soap.SOAPBinding
Gets the SAAJ MessageFactory instance used by this SOAP binding.
getMessageID() - Method in class javax.mail.internet.MimeMessage
Returns the value of the "Message-ID" header field.
getMessageListener() - Method in interface javax.jms.MessageConsumer
Gets the message consumer's MessageListener.
getMessageListener() - Method in interface javax.jms.Session
Returns the session's distinguished message listener (optional).
getMessageNumber() - Method in class javax.mail.Message
Get the Message number for this Message.
getMessages() - Method in class javax.faces.context.FacesContext
Return an Iterator over the FacesMessages that have been queued, whether or not they are associated with any specific client identifier.
getMessages(String) - Method in class javax.faces.context.FacesContext
Return an Iterator over the FacesMessages that have been queued that are associated with the specified client identifier (if clientId is not null), or over the FacesMessages that have been queued that are not associated with any specific client identifier (if clientId is null).
getMessages() - Method in class javax.mail.event.MessageCountEvent
Return the array of messages added or removed.
getMessages(int, int) - Method in class javax.mail.Folder
Get the Message objects for message numbers ranging from start through end, both start and end inclusive.
getMessages(int[]) - Method in class javax.mail.Folder
Get the Message objects for message numbers specified in the array.
getMessages() - Method in class javax.mail.Folder
Get all Message objects from this Folder.
getMessagesByUID(long, long) - Method in interface javax.mail.UIDFolder
Get the Messages specified by the given range.
getMessagesByUID(long[]) - Method in interface javax.mail.UIDFolder
Get the Messages specified by the given array of UIDs.
getMessageSelector() - Method in interface javax.jms.MessageConsumer
Gets this message consumer's message selector expression.
getMessageSelector() - Method in interface javax.jms.QueueBrowser
Gets this queue browser's message selector expression.
getMessageType() - Method in class javax.mail.event.StoreEvent
Return the type of this event.
getMessageWaitTime() - Method in interface javax.management.j2ee.statistics.JMSEndpointStats
Time spent by a message before being delivered.
getMessageWaitTime() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Time spent by a message before being delivered.
getMetaData() - Method in interface javax.jms.Connection
Gets the metadata for this connection.
getMetaData() - Method in interface javax.resource.cci.Connection
Gets the information on the underlying EIS instance represented through an active connection.
getMetaData() - Method in interface javax.resource.cci.ConnectionFactory
Gets metadata for the Resource Adapter.
getMetaData() - Method in interface javax.resource.spi.ManagedConnection
Gets the metadata information for this connection's underlying EIS resource manager instance.
getMetadata() - Method in class javax.xml.ws.Endpoint
Returns a list of metadata documents for the service.
getMethod() - Method in interface javax.interceptor.InvocationContext
Returns the method of the bean class for which the interceptor was invoked.
getMethod() - Method in interface javax.servlet.http.HttpServletRequest
Returns the name of the HTTP method with which this request was made, for example, GET, POST, or PUT.
getMethod() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getMethod() on the wrapped request object.
getMethodInfo(ELContext) - Method in class javax.el.MethodExpression
Evaluates the expression relative to the provided context, and returns information about the actual referenced method.
getMethodReadyCount() - Method in interface javax.management.j2ee.statistics.SessionBeanStats
Number of beans in the method-ready state.
getMethodSignature() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
Returns the expected method signature of this deferred method attribute.
getMiddleName() - Method in interface javax.xml.registry.infomodel.PersonName
Gets the middle name for this Person.
getMimeHeader(String) - Method in class javax.xml.soap.AttachmentPart
Gets all the values of the header identified by the given String.
getMimeHeader(String) - Method in class javax.xml.soap.SOAPPart
Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.
getMimeHeaders() - Method in class javax.xml.soap.SOAPMessage
Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.
getMimeType() - Method in class javax.activation.ActivationDataFlavor
Return the MIME type for this DataFlavor.
getMimeType(String) - Method in interface javax.servlet.ServletContext
Returns the MIME type of the specified file, or null if the MIME type is not known.
getMimeType() - Method in interface javax.xml.registry.infomodel.ExtrinsicObject
Gets the mime type associated with this object.
getMimeTypes() - Method in class javax.activation.CommandMap
Get all the MIME types known to this command map.
getMimeTypes() - Method in class javax.activation.MailcapCommandMap
Get all the MIME types known to this command map.
getMinFractionDigits() - Method in class javax.faces.convert.NumberConverter
Return the minimum number of digits getAsString() should render in the fraction portion of the result.
getMinimum() - Method in class javax.faces.validator.DoubleRangeValidator
Return the minimum value to be enforced by this Validator, or Double.MIN_VALUE if it has not been set.
getMinimum() - Method in class javax.faces.validator.LengthValidator
Return the minimum length to be enforced by this Validator, or 0 if the minimum has not been set.
getMinimum() - Method in class javax.faces.validator.LongRangeValidator
Return the minimum value to be enforced by this Validator.
getMinIntegerDigits() - Method in class javax.faces.convert.NumberConverter
Return the minimum number of digits getAsString() should render in the integer portion of the result.
getMinorVersion() - Method in interface javax.servlet.ServletContext
Returns the minor version of the Servlet API that this servlet container supports.
getMinorVersion() - Method in interface javax.xml.registry.infomodel.Versionable
Gets the minor revision number for this version of the Versionable object.
getMinTime() - Method in interface javax.management.j2ee.statistics.TimeStatistic
The minimum amount of time taken to complete one invocation of this operation since the beginning of this measurement.
getMode() - Method in class javax.mail.Folder
Return the open mode of this folder.
getModuleDTDVersion() - Method in interface javax.enterprise.deploy.model.DDBeanRoot
Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
getModuleDTDVersion() - Method in interface javax.enterprise.deploy.model.DeployableObject
Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
getModuleExtension() - Method in class javax.enterprise.deploy.shared.ModuleType
Return the file extension string for this enumeration.
getModuleID() - Method in interface javax.enterprise.deploy.spi.TargetModuleID
Retrieve the id assigned to represent the deployed module.
getModuleType(int) - Static method in class javax.enterprise.deploy.shared.ModuleType
Return an object of the specified value.
getModuleUris(ModuleType) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return the list of URIs of the designated module type.
getModuleUris() - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return the list of URIs for all modules in the application.
getMustUnderstand() - Method in interface javax.xml.soap.SOAPHeaderElement
Returns the boolean value of the mustUnderstand attribute for this SOAPHeaderElement.
getName() - Method in class javax.activation.DataHandler
Return the name of the data object.
getName() - Method in interface javax.activation.DataSource
Return the name of this object where the name of the object is dependant on the nature of the underlying objects.
getName() - Method in class javax.activation.FileDataSource
Return the name of this object.
getName() - Method in class javax.activation.URLDataSource
Calls the getFile method on the URL used to instantiate the object.
getName() - Method in class javax.el.MethodInfo
Returns the name of the method
getName() - Method in interface javax.enterprise.deploy.spi.Target
Retrieve the name of the target server.
getName() - Method in class javax.faces.component.UIParameter
Return the optional parameter name for this parameter.
getName() - Method in class javax.faces.webapp.FacetTag
Return the name to be assigned to this facet.
getName() - Method in class javax.mail.Folder
Returns the name of this Folder.
getName() - Method in class javax.mail.Header
Returns the name of this header.
getName() - Method in class javax.mail.internet.MimePartDataSource
DataSource method to return a name.
getName() - Method in class javax.mail.util.ByteArrayDataSource
Get the name of the data.
getName() - Method in interface javax.management.j2ee.statistics.Statistic
The name of this Statistic.
getName() - Method in interface javax.resource.spi.security.GenericCredential
Deprecated. Returns the name of the resource principal associated with a GenericCredential instance.
getName() - Method in class javax.servlet.http.Cookie
Returns the name of the cookie.
getName() - Method in class javax.servlet.http.HttpSessionBindingEvent
Returns the name with which the attribute is bound to or unbound from the session.
getName() - Method in class javax.servlet.jsp.tagext.FunctionInfo
The name of the function.
getName() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
The name of this attribute.
getName() - Method in class javax.servlet.jsp.tagext.TagFileInfo
The unique action name of this tag.
getName() - Method in class javax.servlet.ServletContextAttributeEvent
Return the name of the attribute that changed on the ServletContext.
getName() - Method in class javax.servlet.ServletRequestAttributeEvent
Return the name of the attribute that changed on the ServletRequest.
getName() - Method in class javax.xml.bind.JAXBElement
Returns the xml element tag name.
getName() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets the user-friendly name of this object.
getName() - Method in interface javax.xml.registry.infomodel.Slot
Gets the name for this Slot.
getName() - Method in class javax.xml.soap.MimeHeader
Returns the name of this MimeHeader object.
getName() - Method in interface javax.xml.stream.events.Attribute
Returns the QName for this attribute
getName() - Method in interface javax.xml.stream.events.EndElement
Get the name of this event
getName() - Method in interface javax.xml.stream.events.EntityDeclaration
The entity's name
getName() - Method in interface javax.xml.stream.events.EntityReference
The name of the entity
getName() - Method in interface javax.xml.stream.events.NotationDeclaration
The notation name.
getName() - Method in interface javax.xml.stream.events.StartElement
Get the name of this event
getName() - Method in class javax.xml.stream.util.StreamReaderDelegate
getName() - Method in interface javax.xml.stream.XMLStreamReader
Returns a QName for the current START_ELEMENT or END_ELEMENT event
getNamedDispatcher(String) - Method in interface javax.servlet.ServletContext
Returns a RequestDispatcher object that acts as a wrapper for the named servlet.
getNameFromAttribute() - Method in class javax.servlet.jsp.tagext.TagVariableInfo
The body of the <name-from-attribute> element.
getNameGiven() - Method in class javax.servlet.jsp.tagext.TagVariableInfo
The body of the <name-given> element.
getNames() - Method in class javax.activation.MimeTypeParameterList
Retrieve an enumeration of all the names in this list.
getNames() - Method in class javax.mail.internet.ParameterList
Return an enumeration of the names of all parameters in this list.
getNamespaceContext() - Method in interface javax.xml.stream.events.StartElement
Gets a read-only namespace context.
getNamespaceContext() - Method in class javax.xml.stream.util.StreamReaderDelegate
getNamespaceContext() - Method in interface javax.xml.stream.XMLEventWriter
Returns the current namespace context.
getNamespaceContext() - Method in interface javax.xml.stream.XMLStreamReader
Returns a read only namespace context for the current position.
getNamespaceContext() - Method in interface javax.xml.stream.XMLStreamWriter
Returns the current namespace context.
getNamespaceCount() - Method in class javax.xml.stream.util.StreamReaderDelegate
getNamespaceCount() - Method in interface javax.xml.stream.XMLStreamReader
Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE.
getNamespacePrefix(int) - Method in class javax.xml.stream.util.StreamReaderDelegate
getNamespacePrefix(int) - Method in interface javax.xml.stream.XMLStreamReader
Returns the prefix for the namespace declared at the index.
getNamespacePrefixes() - Method in interface javax.xml.soap.SOAPElement
Returns an Iterator over the namespace prefix Strings declared by this element.
getNamespaces() - Method in interface javax.xml.stream.events.EndElement
Returns an Iterator of namespaces that have gone out of scope.
getNamespaces() - Method in interface javax.xml.stream.events.StartElement
Returns an Iterator of namespaces declared on this element.
getNamespaceURI(String) - Method in interface javax.xml.soap.SOAPElement
Returns the URI of the namespace that has the given prefix.
getNamespaceURI() - Method in interface javax.xml.stream.events.Namespace
Gets the uri bound to the prefix of this namespace
getNamespaceURI(String) - Method in interface javax.xml.stream.events.StartElement
Gets the value that the prefix is bound to in the context of this element.
getNamespaceURI(String) - Method in class javax.xml.stream.util.StreamReaderDelegate
getNamespaceURI(int) - Method in class javax.xml.stream.util.StreamReaderDelegate
getNamespaceURI() - Method in class javax.xml.stream.util.StreamReaderDelegate
getNamespaceURI(String) - Method in interface javax.xml.stream.XMLStreamReader
Return the uri for the given prefix.
getNamespaceURI(int) - Method in interface javax.xml.stream.XMLStreamReader
Returns the uri for the namespace declared at the index.
getNamespaceURI() - Method in interface javax.xml.stream.XMLStreamReader
If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace.
getNativeCommands(String) - Method in class javax.activation.MailcapCommandMap
Get the native commands for the given MIME type.
getNavigationHandler() - Method in class javax.faces.application.Application
Return the NavigationHandler instance that will be passed the outcome returned by any invoked application action for this web application.
getNestedException() - Method in exception javax.xml.stream.XMLStreamException
Gets the nested exception.
getNewFolder() - Method in class javax.mail.event.FolderEvent
If this event indicates that a folder is renamed, (i.e, the event type is RENAMED), then this method returns the Folder object representing the new name.
getNewMessageCount() - Method in class javax.mail.Folder
Get the number of new messages in this Folder.
getNewsgroup() - Method in class javax.mail.internet.NewsAddress
Get the newsgroup.
getNewTempClassLoader() - Method in interface javax.persistence.spi.PersistenceUnitInfo
Return a new instance of a ClassLoader that the provider may use to temporarily load any classes, resources, or open URLs.
getNewValue() - Method in class javax.faces.event.ValueChangeEvent
Return the current local value of the source UIComponent.
getNextException() - Method in exception javax.mail.MessagingException
Get the next exception chained to this one.
getNextTimeout() - Method in interface javax.ejb.Timer
Get the point in time at which the next timer expiration is scheduled to occur.
getNode(Object) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
By default, the getNode method is unsupported and throw an UnsupportedOperationException.
getNode() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl
getNode(Object) - Method in interface javax.xml.bind.Marshaller
Get a DOM tree view of the content tree(Optional).
getNode() - Method in interface javax.xml.bind.ValidationEventLocator
Return a reference to the DOM Node if available
getNoLocal() - Method in interface javax.jms.TopicSubscriber
Gets the NoLocal attribute for this subscriber.
getNonJtaDataSource() - Method in interface javax.persistence.spi.PersistenceUnitInfo
Returns the non-JTA-enabled data source to be used by the persistence provider for accessing data outside a JTA transaction.
getNonMatchingHeaderLines(String[]) - Method in class javax.mail.internet.InternetHeaders
Return all non-matching header lines
getNonMatchingHeaderLines(String[]) - Method in class javax.mail.internet.MimeBodyPart
Get non-matching header lines as an Enumeration of Strings.
getNonMatchingHeaderLines(String[]) - Method in class javax.mail.internet.MimeMessage
Get non-matching header lines as an Enumeration of Strings.
getNonMatchingHeaderLines(String[]) - Method in interface javax.mail.internet.MimePart
Get non-matching header lines as an Enumeration of Strings.
getNonMatchingHeaders(String[]) - Method in class javax.mail.internet.InternetHeaders
Return all non-matching Header objects.
getNonMatchingHeaders(String[]) - Method in class javax.mail.internet.MimeBodyPart
Return non-matching headers from this Message as an Enumeration of Header objects.
getNonMatchingHeaders(String[]) - Method in class javax.mail.internet.MimeMessage
Return non-matching headers from this Message as an Enumeration of Header objects.
getNonMatchingHeaders(String[]) - Method in interface javax.mail.Part
Return non-matching headers from this envelope as an Enumeration of Header objects.
getNonMatchingHeaders(String[]) - Method in class javax.xml.soap.MimeHeaders
Returns all of the MimeHeader objects whose name does not match a name in the given array of names.
getNonMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.AttachmentPart
Retrieves all MimeHeader objects whose name does not match a name in the given array.
getNonMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.SOAPPart
Retrieves all MimeHeader objects whose name does not match a name in the given array.
getNonRunningModules(ModuleType, Target[]) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Retrieve the list of J2EE application modules distributed to the identified targets and that are currently not running on the associated server or servers.
getNoNSSchemaLocation() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
Convenience method for getting the current noNamespaceSchemaLocation.
getNotationName() - Method in interface javax.xml.stream.events.EntityDeclaration
The name of the associated notation.
getNotations() - Method in interface javax.xml.stream.events.DTD
Return a List containing the notations declared in the DTD.
getNumber() - Method in class javax.mail.search.IntegerComparisonTerm
Return the number to compare with.
getNumber() - Method in interface javax.xml.registry.infomodel.TelephoneNumber
Gets the telephone number suffix, not including the country or area code.
getObject(String) - Method in interface javax.jms.MapMessage
Returns the value of the object with the specified name.
getObject() - Method in interface javax.jms.ObjectMessage
Gets the serializable object containing this message's data.
getObject() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl
getObject() - Method in interface javax.xml.bind.ValidationEventLocator
Return a reference to the object in the Java content tree if available
getObjectProperty(String) - Method in interface javax.jms.Message
Returns the value of the Java object property with the specified name.
getObjectType() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets the object type that best describes the RegistryObject.
getOffset() - Method in class javax.enterprise.deploy.shared.ActionType
Returns the lowest integer value used by this enumeration value's enumeration class.
getOffset() - Method in class javax.enterprise.deploy.shared.CommandType
Returns the lowest integer value used by this enumeration value's enumeration class.
getOffset() - Method in class javax.enterprise.deploy.shared.DConfigBeanVersionType
Returns the lowest integer value used by this enumeration value's enumeration class.
getOffset() - Method in class javax.enterprise.deploy.shared.ModuleType
Returns the lowest integer value used by this enumeration value's enumeration class.
getOffset() - Method in class javax.enterprise.deploy.shared.StateType
Returns the lowest integer value used by this enumeration value's enumeration class.
getOffset() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl
getOffset() - Method in interface javax.xml.bind.ValidationEventLocator
Return the byte offset if available
getOldValue() - Method in class javax.faces.event.ValueChangeEvent
Return the previous local value of the source UIComponent.
getOnblur() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the onblur property.
getOnblur() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the onblur property.
getOnblur() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the onblur property.
getOnblur() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the onblur property.
getOnblur() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the onblur property.
getOnblur() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the onblur property.
getOnblur() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the onblur property.
getOnblur() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the onblur property.
getOnblur() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the onblur property.
getOnblur() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the onblur property.
getOnblur() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the onblur property.
getOnblur() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the onblur property.
getOnblur() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the onblur property.
getOnblur() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the onblur property.
getOnchange() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the onchange property.
getOnchange() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the onchange property.
getOnchange() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the onchange property.
getOnchange() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the onchange property.
getOnchange() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the onchange property.
getOnchange() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the onchange property.
getOnchange() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the onchange property.
getOnchange() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the onchange property.
getOnchange() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the onchange property.
getOnchange() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the onchange property.
getOnchange() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the onchange property.
getOnclick() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlForm
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the onclick property.
getOnclick() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the onclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlForm
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the ondblclick property.
getOndblclick() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the ondblclick property.
getOnfocus() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the onfocus property.
getOnfocus() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the onfocus property.
getOnfocus() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the onfocus property.
getOnfocus() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the onfocus property.
getOnfocus() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the onfocus property.
getOnfocus() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the onfocus property.
getOnfocus() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the onfocus property.
getOnfocus() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the onfocus property.
getOnfocus() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the onfocus property.
getOnfocus() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the onfocus property.
getOnfocus() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the onfocus property.
getOnfocus() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the onfocus property.
getOnfocus() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the onfocus property.
getOnfocus() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the onfocus property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlForm
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the onkeydown property.
getOnkeydown() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the onkeydown property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlForm
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the onkeypress property.
getOnkeypress() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the onkeypress property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlForm
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the onkeyup property.
getOnkeyup() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the onkeyup property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlForm
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the onmousedown property.
getOnmousedown() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the onmousedown property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlForm
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the onmousemove property.
getOnmousemove() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the onmousemove property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlForm
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the onmouseout property.
getOnmouseout() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the onmouseout property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlForm
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the onmouseover property.
getOnmouseover() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the onmouseover property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlForm
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the onmouseup property.
getOnmouseup() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the onmouseup property.
getOnreset() - Method in class javax.faces.component.html.HtmlForm
Return the value of the onreset property.
getOnselect() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the onselect property.
getOnselect() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the onselect property.
getOnselect() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the onselect property.
getOnselect() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the onselect property.
getOnselect() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the onselect property.
getOnselect() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the onselect property.
getOnselect() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the onselect property.
getOnselect() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the onselect property.
getOnselect() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the onselect property.
getOnselect() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the onselect property.
getOnselect() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the onselect property.
getOnsubmit() - Method in class javax.faces.component.html.HtmlForm
Return the value of the onsubmit property.
getOperationName() - Method in interface javax.xml.rpc.Call
Gets the name of the operation to be invoked using this Call instance.
getOrdinal() - Method in class javax.faces.application.FacesMessage.Severity
Return the ordinal value of this FacesMessage.Severity instance.
getOrdinal() - Method in class javax.faces.event.PhaseId
Return the ordinal value of this PhaseId instance.
getOrganization() - Method in interface javax.xml.registry.infomodel.User
Gets the Organization that this User is affiliated with.
getOrigin() - Method in interface javax.management.j2ee.statistics.JMSConsumerStats
Returns a string that encapsulates the identity of a message origin
getOut() - Method in class javax.servlet.jsp.JspContext
The current value of the out object (a JspWriter).
getOutputParams() - Method in interface javax.xml.rpc.Call
Returns a Map of {name, value} for the output parameters of the last invoked operation.
getOutputStream() - Method in class javax.activation.DataHandler
Get an OutputStream for this DataHandler to allow overwriting the underlying data.
getOutputStream() - Method in interface javax.activation.DataSource
This method returns an OutputStream where the data can be written and throws the appropriate exception if it can not do so.
getOutputStream() - Method in class javax.activation.FileDataSource
This method will return an OutputStream representing the the data and will throw an IOException if it can not do so.
getOutputStream() - Method in class javax.activation.URLDataSource
The getOutputStream method from the URL.
getOutputStream() - Method in class javax.mail.internet.MimePartDataSource
DataSource method to return an output stream.
getOutputStream() - Method in class javax.mail.util.ByteArrayDataSource
Return an OutputStream for the data.
getOutputStream() - Method in interface javax.servlet.ServletResponse
Returns a ServletOutputStream suitable for writing binary data in the response.
getOutputStream() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return getOutputStream() on the wrapped response object.
getOutputValues() - Method in interface javax.xml.rpc.Call
Returns a List values for the output parameters of the last invoked operation.
getPage() - Method in class javax.servlet.jsp.PageContext
The current value of the page object (In a Servlet environment, this is an instance of javax.servlet.Servlet).
getPageContext(Servlet, ServletRequest, ServletResponse, String, boolean, int, boolean) - Method in class javax.servlet.jsp.JspFactory
obtains an instance of an implementation dependent javax.servlet.jsp.PageContext abstract class for the calling Servlet and currently pending request and response.
getParameter(String) - Method in class javax.activation.MimeType
Retrieve the value associated with the given name, or null if there is no current association.
getParameter(String) - Method in class javax.mail.internet.ContentDisposition
Return the specified parameter value.
getParameter(String) - Method in class javax.mail.internet.ContentType
Return the specified parameter value.
getParameter(String) - Method in interface javax.servlet.ServletRequest
Returns the value of a request parameter as a String, or null if the parameter does not exist.
getParameter(String) - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getParameter(String name) on the wrapped request object.
getParameterList() - Method in class javax.mail.internet.ContentDisposition
Return a ParameterList object that holds all the available parameters.
getParameterList() - Method in class javax.mail.internet.ContentType
Return a ParameterList object that holds all the available parameters.
getParameterMap() - Method in interface javax.servlet.ServletRequest
Returns a java.util.Map of the parameters of this request.
getParameterMap() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getParameterMap() on the wrapped request object.
getParameterNames() - Method in interface javax.servlet.ServletRequest
Returns an Enumeration of String objects containing the names of the parameters contained in this request.
getParameterNames() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getParameterNames() on the wrapped request object.
getParameters() - Method in class javax.activation.MimeType
Retrieve this object's parameter list.
getParameters() - Method in interface javax.interceptor.InvocationContext
Returns the parameters that will be used to invoke the business method.
getParameterTypeByName(String) - Method in interface javax.xml.rpc.Call
Gets the XML type of a parameter by name
getParameterValues(String) - Method in interface javax.servlet.ServletRequest
Returns an array of String objects containing all of the values the given request parameter has, or null if the parameter does not exist.
getParameterValues(String) - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getParameterValues(String name) on the wrapped request object.
getParamTypes() - Method in class javax.el.MethodInfo
Returns the parameter types of the method
getParent() - Method in class javax.faces.component.UIComponent
Return the parent UIComponent of this UIComponent, if any.
getParent() - Method in class javax.faces.component.UIComponentBase
getParent() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Return the Tag that is the parent of this instance.
getParent() - Method in class javax.mail.BodyPart
Return the containing Multipart object, or null if not known.
getParent() - Method in class javax.mail.Folder
Returns the parent folder of this folder.
getParent() - Method in class javax.mail.Multipart
Return the Part that contains this Multipart object, or null if not known.
getParent() - Method in interface javax.servlet.jsp.tagext.SimpleTag
Returns the parent of this tag, for collaboration purposes.
getParent() - Method in class javax.servlet.jsp.tagext.SimpleTagSupport
Returns the parent of this tag, for collaboration purposes.
getParent() - Method in interface javax.servlet.jsp.tagext.Tag
Get the parent (closest enclosing tag handler) for this tag handler.
getParent() - Method in class javax.servlet.jsp.tagext.TagAdapter
Returns the parent of this tag, which is always getAdaptee().getParent().
getParent() - Method in class javax.servlet.jsp.tagext.TagSupport
The Tag instance most closely enclosing this tag instance.
getParent() - Method in interface javax.xml.registry.infomodel.Concept
Gets the parent Concept or ClassificationScheme for this object.
getParent() - Method in class javax.xml.stream.util.EventReaderDelegate
Get the parent of this instance.
getParent() - Method in class javax.xml.stream.util.StreamReaderDelegate
Get the parent of this instance.
getParentConcept() - Method in interface javax.xml.registry.infomodel.Concept
Gets the parent Concept or null if parent is a ClassificationScheme.
getParentElement() - Method in interface javax.xml.soap.Node
Returns the parent element of this Node object.
getParentOrganization() - Method in interface javax.xml.registry.infomodel.Organization
Gets the parent (container) organization.
getParentTargetModuleID() - Method in interface javax.enterprise.deploy.spi.TargetModuleID
Retrieve the identifier of the parent object of this deployed module.
getParentUIComponentClassicTagBase(PageContext) - Static method in class javax.faces.webapp.UIComponentClassicTagBase
Locate and return the nearest enclosing UIComponentClassicTagBase if any; otherwise, return null.
getParentUIComponentTag(PageContext) - Static method in class javax.faces.webapp.UIComponentTag
Deprecated. Locate and return the nearest enclosing UIComponentTag if any; otherwise, return null.
getPart() - Method in class javax.mail.MessageContext
Return the Part that contains the content.
getPassiveCount() - Method in interface javax.management.j2ee.statistics.StatefulSessionBeanStats
Number of beans that are in the passive state.
getPassword() - Method in class javax.mail.PasswordAuthentication
getPassword() - Method in class javax.mail.URLName
Returns the password of this URLName.
getPassword() - Method in class javax.resource.spi.security.PasswordCredential
Returns the user password.
getPasswordAuthentication() - Method in class javax.mail.Authenticator
Called when password authentication is needed.
getPasswordAuthentication(URLName) - Method in class javax.mail.Session
Return any saved PasswordAuthentication for this (store or transport) URLName.
getPath() - Method in class javax.servlet.http.Cookie
Returns the path on the server to which the browser returns this cookie.
getPath() - Method in class javax.servlet.jsp.tagext.TagFileInfo
Where to find the .tag file implementing this action.
getPath() - Method in interface javax.xml.registry.infomodel.Concept
Gets the canonical path representation for this Concept.
getPathInfo() - Method in interface javax.servlet.http.HttpServletRequest
Returns any extra path information associated with the URL the client sent when it made this request.
getPathInfo() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getPathInfo() on the wrapped request object.
getPathTranslated() - Method in interface javax.servlet.http.HttpServletRequest
Returns any extra path information after the servlet name but before the query string, and translates it to a real path.
getPathTranslated() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getPathTranslated() on the wrapped request object.
getPattern() - Method in class javax.faces.convert.DateTimeConverter
Return the format pattern to be used when formatting and parsing dates and times.
getPattern() - Method in class javax.faces.convert.NumberConverter
Return the format pattern to be used when formatting and parsing numbers.
getPattern() - Method in class javax.mail.search.StringTerm
Return the string to match with.
getPayload() - Method in interface javax.xml.ws.LogicalMessage
Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.
getPayload(JAXBContext) - Method in interface javax.xml.ws.LogicalMessage
Gets the message payload as a JAXB object.
getPendingMessageCount() - Method in interface javax.management.j2ee.statistics.JMSEndpointStats
Number of pending messages.
getPendingMessageCount() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Number of pending messages.
getPermanentFlags() - Method in class javax.mail.Folder
Get the permanent flags supported by this Folder.
getPersistenceProviderClassName() - Method in interface javax.persistence.spi.PersistenceUnitInfo
Returns the fully qualified name of the persistence provider implementation class.
getPersistenceUnitName() - Method in interface javax.persistence.spi.PersistenceUnitInfo
Returns the name of the persistence unit.
getPersistenceUnitRootUrl() - Method in interface javax.persistence.spi.PersistenceUnitInfo
Returns the URL for the jar file or directory that is the root of the persistence unit.
getPersonal() - Method in class javax.mail.internet.InternetAddress
Get the personal name.
getPersonalNamespaces() - Method in class javax.mail.Store
Return a set of folders representing the personal namespaces for the current user.
getPersonName() - Method in interface javax.xml.registry.infomodel.User
Returns the name of this User.
getPhaseId() - Method in class javax.faces.event.FacesEvent
Return the identifier of the request processing phase during which this event should be delivered.
getPhaseId() - Method in class javax.faces.event.PhaseEvent
Return the PhaseId representing the current request processing lifecycle phase.
getPhaseId() - Method in interface javax.faces.event.PhaseListener
Return the identifier of the request processing phase during which this listener is interested in processing PhaseEvent events.
getPhaseListeners() - Method in class javax.faces.lifecycle.Lifecycle
Return the set of registered PhaseListeners for this Lifecycle instance.
getPIData() - Method in class javax.xml.stream.util.StreamReaderDelegate
getPIData() - Method in interface javax.xml.stream.XMLStreamReader
Get the data section of a processing instruction
getPITarget() - Method in class javax.xml.stream.util.StreamReaderDelegate
getPITarget() - Method in interface javax.xml.stream.XMLStreamReader
Get the target of a processing instruction
getPolicyConfiguration(String, boolean) - Method in class javax.security.jacc.PolicyConfigurationFactory
This method is used to obtain an instance of the provider specific class that implements the PolicyConfiguration interface that corresponds to the identified policy context within the provider.
getPolicyConfigurationFactory() - Static method in class javax.security.jacc.PolicyConfigurationFactory
This static method uses a system property to find and instantiate (via a public constructor) a provider specific factory implementation class.
getPooledCount() - Method in interface javax.management.j2ee.statistics.EntityBeanStats
Number of beans in the pooled state.
getPoolSize() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats
The size of the connection pool
getPoolSize() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats
Size of the connection pool.
getPort() - Method in class javax.mail.URLName
Returns the port number of this URLName.
getPort(QName, Class) - Method in interface javax.xml.rpc.Service
The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.
getPort(Class) - Method in interface javax.xml.rpc.Service
The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.
getPort(QName, Class<T>) - Method in class javax.xml.ws.Service
The getPort method returns a stub.
getPort(Class<T>) - Method in class javax.xml.ws.Service
The getPort method returns a stub.
getPort(QName, Class<T>) - Method in class javax.xml.ws.spi.ServiceDelegate
The getPort method returns a stub.
getPort(Class<T>) - Method in class javax.xml.ws.spi.ServiceDelegate
The getPort method returns a stub.
getPortName() - Method in interface javax.xml.ws.handler.PortInfo
Gets the qualified name of the WSDL port being accessed.
getPorts() - Method in interface javax.xml.rpc.Service
Returns an Iterator for the list of QNames of service endpoints grouped by this service
getPorts() - Method in class javax.xml.ws.Service
Returns an Iterator for the list of QNames of service endpoints grouped by this service
getPorts() - Method in class javax.xml.ws.spi.ServiceDelegate
Returns an Iterator for the list of QNames of service endpoints grouped by this service
getPortTypeName() - Method in interface javax.xml.rpc.Call
Gets the qualified name of the port type.
getPos() - Method in exception javax.mail.internet.AddressException
Get the position with the reference string where the error was detected (-1 if not relevant).
getPosition() - Method in interface javax.mail.internet.SharedInputStream
Return the current position in the InputStream, as an offset from the beginning of the InputStream.
getPosition() - Method in class javax.mail.util.SharedByteArrayInputStream
Return the current position in the InputStream, as an offset from the beginning of the InputStream.
getPosition() - Method in class javax.mail.util.SharedFileInputStream
Return the current position in the InputStream, as an offset from the beginning of the InputStream.
getPostalAddress() - Method in interface javax.xml.registry.infomodel.Organization
Gets the Address for this Organization.
getPostalAddresses() - Method in interface javax.xml.registry.infomodel.User
Gets the postal address for this User.
getPostalCode() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the postal or zip code.
getPostalScheme() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns a user-defined postal scheme for codifying the attributes of PostalAddress.
getPreamble() - Method in class javax.mail.internet.MimeMultipart
Get the preamble text, if any, that appears before the first body part of this multipart.
getPreferredCommands(String) - Method in class javax.activation.CommandMap
Get the preferred command list from a MIME Type.
getPreferredCommands(String, DataSource) - Method in class javax.activation.CommandMap
Get the preferred command list from a MIME Type.
getPreferredCommands() - Method in class javax.activation.DataHandler
Return the preferred commands for this type of data.
getPreferredCommands(String) - Method in class javax.activation.MailcapCommandMap
Get the preferred command list for a MIME Type.
getPrefix() - Method in interface javax.xml.soap.Name
Returns the prefix that was specified when this Name object was initialized.
getPrefix() - Method in interface javax.xml.stream.events.Namespace
Gets the prefix, returns "" if this is a default namespace declaration.
getPrefix() - Method in class javax.xml.stream.util.StreamReaderDelegate
getPrefix(String) - Method in interface javax.xml.stream.XMLEventWriter
Gets the prefix the uri is bound to
getPrefix() - Method in interface javax.xml.stream.XMLStreamReader
Returns the prefix of the current event or null if the event does not have a prefix
getPrefix(String) - Method in interface javax.xml.stream.XMLStreamWriter
Gets the prefix the uri is bound to
getPrefixString() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
The prefix assigned to this taglib from the taglib directive
getPreviousOut() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Get the JspWriter from our BodyContent.
getPreviousOut() - Method in class javax.servlet.jsp.tagext.BodyTagSupport
Get surrounding out JspWriter.
getPrimaryContact() - Method in interface javax.xml.registry.infomodel.Organization
Gets the primary Contact for this Organization.
getPrimaryKey() - Method in interface javax.ejb.EJBLocalObject
Obtain the primary key of the EJB local object.
getPrimaryKey() - Method in interface javax.ejb.EJBObject
Obtain the primary key of the EJB object.
getPrimaryKey() - Method in interface javax.ejb.EntityContext
Obtain the primary key of the EJB object that is currently associated with this instance.
getPrimaryKeyClass() - Method in interface javax.ejb.EJBMetaData
Obtain the Class object for the enterprise Bean's primary key class.
getPrimaryType() - Method in class javax.activation.MimeType
Retrieve the primary type of this object.
getPrimaryType() - Method in class javax.mail.internet.ContentType
Return the primary type.
getPriority() - Method in interface javax.jms.MessageProducer
Gets the producer's default priority.
getProcessedDTD() - Method in interface javax.xml.stream.events.DTD
Returns an implementation defined representation of the DTD.
getProducers() - Method in interface javax.management.j2ee.statistics.JMSSessionStats
Returns an array of JMSProducerStats that provide statistics about the message producers associated with the referencing JMS session statistics.
getProductVersion() - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory
Provide a string identifying version of this vendor's DeploymentManager.
getProperties() - Method in class javax.mail.Session
Returns the Properties object associated with this Session
getProperties() - Method in interface javax.persistence.spi.PersistenceUnitInfo
Returns properties object.
getProperties() - Method in class javax.xml.registry.ConnectionFactory
Gets the Properties used during createConnection and createFederatedConnection calls.
getProperties() - Method in class javax.xml.ws.Endpoint
Returns the property bag for this Endpoint instance.
getProperty(String) - Method in class javax.mail.Session
Returns the value of the specified property.
getProperty(String) - Method in class javax.xml.bind.Binder
Get the particular property in the underlying implementation of Binder.
getProperty(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
Default implementation of the getProperty method handles the four defined properties in Marshaller.
getProperty(String) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
Default implementation of the getProperty method always throws PropertyException since there are no required properties.
getProperty(String) - Method in interface javax.xml.bind.Marshaller
Get the particular property in the underlying implementation of Marshaller.
getProperty(String) - Method in interface javax.xml.bind.Unmarshaller
Get the particular property in the underlying implementation of Unmarshaller.
getProperty(String) - Method in interface javax.xml.bind.Validator
Deprecated. since JAXB2.0
getProperty(String) - Method in interface javax.xml.rpc.Call
Gets the value of a named property.
getProperty(String) - Method in interface javax.xml.rpc.handler.MessageContext
Gets the value of a specific property from the MessageContext
getProperty(String) - Method in class javax.xml.soap.SOAPMessage
Retrieves value of the specified property.
getProperty(String) - Method in class javax.xml.stream.util.EventReaderDelegate
getProperty(String) - Method in class javax.xml.stream.util.StreamReaderDelegate
getProperty(String) - Method in interface javax.xml.stream.XMLEventReader
Get the value of a feature/property from the underlying implementation
getProperty(String) - Method in class javax.xml.stream.XMLInputFactory
Get the value of a feature/property from the underlying implementation
getProperty(String) - Method in class javax.xml.stream.XMLOutputFactory
Get a feature/property on the underlying implementation
getProperty(String) - Method in interface javax.xml.stream.XMLStreamReader
Get the value of a feature/property from the underlying implementation
getProperty(String) - Method in interface javax.xml.stream.XMLStreamWriter
Get the value of a feature/property from the underlying implementation
getPropertyNames() - Method in interface javax.jms.Message
Returns an Enumeration of all the property names.
getPropertyNames() - Method in interface javax.xml.rpc.Call
Gets the names of configurable properties supported by this Call object.
getPropertyNames() - Method in interface javax.xml.rpc.handler.MessageContext
Returns an Iterator view of the names of the properties in this MessageContext
getPropertyResolver() - Method in class javax.faces.application.Application
Deprecated. This has been replaced by Application.getELResolver().
getPropertyType() - Method in class javax.el.BeanELResolver.BeanProperty
getProtocol() - Method in class javax.mail.Provider
Returns the protocol supported by this Provider
getProtocol() - Method in class javax.mail.URLName
Returns the protocol of this URLName.
getProtocol() - Method in interface javax.servlet.ServletRequest
Returns the name and version of the protocol the request uses in the form protocol/majorVersion.minorVersion, for example, HTTP/1.1.
getProtocol() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getProtocol() on the wrapped request object.
getProvider(String) - Method in class javax.mail.Session
Returns the default Provider for the protocol specified.
getProviderMajorVersion() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS provider major version number.
getProviderMinorVersion() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS provider minor version number.
getProviders() - Method in class javax.mail.Session
This method returns an array of all the implementations installed via the javamail.
getProviderVersion() - Method in interface javax.jms.ConnectionMetaData
Gets the JMS provider version.
getProvidingOrganization() - Method in interface javax.xml.registry.infomodel.Service
Gets the Organization that provides this service.
getPublicId() - Method in interface javax.xml.stream.events.EntityDeclaration
The entity's public identifier, or null if none was given
getPublicId() - Method in interface javax.xml.stream.events.NotationDeclaration
The notation's public identifier, or null if none was given.
getPublicId() - Method in interface javax.xml.stream.Location
Returns the public ID of the XML
getQualifiedName() - Method in interface javax.xml.soap.Name
Gets the namespace-qualified name of the XML name that this Name object represents.
getQueryString() - Method in interface javax.servlet.http.HttpServletRequest
Returns the query string that is contained in the request URL after the path.
getQueryString() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getQueryString() on the wrapped request object.
getQueue() - Method in interface javax.jms.QueueBrowser
Gets the queue associated with this queue browser.
getQueue() - Method in interface javax.jms.QueueReceiver
Gets the Queue associated with this queue receiver.
getQueue() - Method in interface javax.jms.QueueSender
Gets the queue associated with this QueueSender.
getQueueName() - Method in interface javax.jms.Queue
Gets the name of this queue.
getQueueSession() - Method in interface javax.jms.XAQueueSession
Gets the queue session associated with this XAQueueSession.
getQuota(String) - Method in interface javax.mail.QuotaAwareStore
Get the quotas for the named quota root.
getRawContent() - Method in class javax.xml.soap.AttachmentPart
Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
getRawContentBytes() - Method in class javax.xml.soap.AttachmentPart
Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
getRawInputStream() - Method in class javax.mail.internet.MimeBodyPart
Return an InputStream to the raw data with any Content-Transfer-Encoding intact.
getRawInputStream() - Method in class javax.mail.internet.MimeMessage
Return an InputStream to the raw data with any Content-Transfer-Encoding intact.
getReader() - Method in class javax.servlet.jsp.tagext.BodyContent
Return the value of this BodyContent as a Reader.
getReader() - Method in interface javax.servlet.ServletRequest
Retrieves the body of the request as character data using a BufferedReader.
getReader() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getReader() on the wrapped request object.
getReadMethod() - Method in class javax.el.BeanELResolver.BeanProperty
getReadyCount() - Method in interface javax.management.j2ee.statistics.EntityBeanStats
Number of beans in the ready state.
getRealPath(String) - Method in interface javax.servlet.ServletContext
Returns a String containing the real path for a given virtual path.
getRealPath(String) - Method in interface javax.servlet.ServletRequest
Deprecated. As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead.
getRealPath(String) - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getRealPath(String path) on the wrapped request object.
getReceivedDate() - Method in class javax.mail.internet.MimeMessage
Returns the Date on this message was received.
getReceivedDate() - Method in class javax.mail.Message
Get the date this message was received.
getRecipients(Message.RecipientType) - Method in class javax.mail.internet.MimeMessage
Returns the recepients specified by the type.
getRecipients(Message.RecipientType) - Method in class javax.mail.Message
Get all the recipient addresses of the given type.
getRecipientType() - Method in class javax.mail.search.RecipientStringTerm
Return the type of recipient to match with.
getRecipientType() - Method in class javax.mail.search.RecipientTerm
Return the type of recipient to match with.
getRecordFactory() - Method in interface javax.resource.cci.ConnectionFactory
Gets a RecordFactory instance.
getRecordName() - Method in interface javax.resource.cci.Record
Gets the name of the Record.
getRecordShortDescription() - Method in interface javax.resource.cci.Record
Gets a short description string for the Record.
getRef() - Method in exception javax.mail.internet.AddressException
Get the string that was being parsed when the error was detected (null if not relevant).
getRef() - Method in class javax.mail.URLName
Returns the reference of this URLName.
getReference(Class<T>, Object) - Method in interface javax.persistence.EntityManager
Get an instance, whose state may be lazily fetched.
getRegisteredEncodingStyleURIs() - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry
Returns a list of registered encodingStyle URIs in this TypeMappingRegistry instance.
getRegistryObject() - Method in interface javax.xml.registry.infomodel.AuditableEvent
Gets the RegistryObject associated with this AuditableEvent.
getRegistryObject() - Method in interface javax.xml.registry.infomodel.ExternalIdentifier
Gets the parent RegistryObject for this ExternalIdentifier.
getRegistryObject(String, String) - Method in interface javax.xml.registry.QueryManager
Gets the RegistryObject specified by the Id and type of object.
getRegistryObject(String) - Method in interface javax.xml.registry.QueryManager
Gets the RegistryObject specified by the Id.
getRegistryObjects() - Method in interface javax.xml.registry.infomodel.RegistryPackage
Gets the collection of member RegistryObjects of this RegistryPackage.
getRegistryObjects(Collection) - Method in interface javax.xml.registry.QueryManager
Gets the specified RegistryObjects.
getRegistryObjects(Collection, String) - Method in interface javax.xml.registry.QueryManager
Gets the specified RegistryObjects.
getRegistryObjects() - Method in interface javax.xml.registry.QueryManager
Gets the RegistryObjects owned by the caller.
getRegistryObjects(String) - Method in interface javax.xml.registry.QueryManager
Gets the RegistryObjects owned by the caller, that are of the specified type.
getRegistryPackages() - Method in interface javax.xml.registry.infomodel.RegistryObject
Returns the Package associated with this object.
getRegistryService() - Method in interface javax.xml.registry.Connection
Gets the RegistryService interface associated with the Connection.
getRegistryService() - Method in interface javax.xml.registry.LifeCycleManager
Returns the parent RegistryService that created this object.
getRegistryService() - Method in interface javax.xml.registry.QueryManager
Returns the parent RegistryService that created this object.
getRel() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the rel property.
getRel() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the rel property.
getRelay() - Method in interface javax.xml.soap.SOAPHeaderElement
Returns the boolean value of the relay attribute for this SOAPHeaderElement
getReliableURN() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
The "reliable" URN indicated in the TLD (the uri element).
getRemainder() - Method in class javax.mail.internet.HeaderTokenizer
Return the rest of the Header.
getRemaining() - Method in class javax.servlet.jsp.JspWriter
This method returns the number of unused bytes in the buffer.
getRemoteAddr() - Method in interface javax.servlet.ServletRequest
Returns the Internet Protocol (IP) address of the client or last proxy that sent the request.
getRemoteAddr() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getRemoteAddr() on the wrapped request object.
getRemoteHost() - Method in interface javax.servlet.ServletRequest
Returns the fully qualified name of the client or the last proxy that sent the request.
getRemoteHost() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getRemoteHost() on the wrapped request object.
getRemoteInterfaceClass() - Method in interface javax.ejb.EJBMetaData
Obtain the Class object for the enterprise Bean's remote interface.
getRemotePort() - Method in interface javax.servlet.ServletRequest
Returns the Internet Protocol (IP) source port of the client or last proxy that sent the request.
getRemotePort() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getRemotePort() on the wrapped request object.
getRemoteUser() - Method in class javax.faces.context.ExternalContext
Return the login name of the user making the current request if any; otherwise, return null.
getRemoteUser() - Method in interface javax.servlet.http.HttpServletRequest
Returns the login of the user making this request, if the user has been authenticated, or null if the user has not been authenticated.
getRemoteUser() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getRemoteUser() on the wrapped request object.
getRemoveCount() - Method in interface javax.management.j2ee.statistics.EJBStats
Number of times remove was called.
getRenderer(FacesContext) - Method in class javax.faces.component.UIComponent
Convenience method to return the Renderer instance associated with this component, if any; otherwise, return null.
getRenderer(FacesContext) - Method in class javax.faces.component.UIComponentBase
getRenderer(String, String) - Method in class javax.faces.render.RenderKit
Return the Renderer instance most recently registered for the specified component family and rendererType, if any; otherwise, return null.
getRendererType() - Method in class javax.faces.component.UIComponent
Return the Renderer type for this UIComponent (if any).
getRendererType() - Method in class javax.faces.component.UIComponentBase
getRendererType() - Method in class javax.faces.webapp.UIComponentTagBase
Return the rendererType property that selects the Renderer to be used for encoding this component, or null to ask the component to render itself directly.
getRenderKit() - Method in class javax.faces.context.FacesContext
Return the RenderKit instance for the render kit identifier specified on our UIViewRoot, if there is one.
getRenderKit(FacesContext, String) - Method in class javax.faces.render.RenderKitFactory
Return a RenderKit instance for the specified render kit identifier, possibly customized based on dynamic characteristics of the specified FacesContext, if non-null.
getRenderKitId() - Method in class javax.faces.component.UIViewRoot
Return the render kit identifier of the RenderKit associated with this view.
getRenderKitIds() - Method in class javax.faces.render.RenderKitFactory
Return an Iterator over the set of render kit identifiers registered with this factory.
getRenderResponse() - Method in class javax.faces.context.FacesContext
Return true if the renderResponse() method has been called for the current request.
getRendersChildren() - Method in class javax.faces.component.UIComponent
Return a flag indicating whether this component is responsible for rendering its child components.
getRendersChildren() - Method in class javax.faces.component.UIComponentBase
getRendersChildren() - Method in class javax.faces.render.Renderer
Return a flag indicating whether this Renderer is responsible for rendering the children the component it is asked to render.
getReplacementText() - Method in interface javax.xml.stream.events.EntityDeclaration
The replacement text of the entity.
getReplyTo() - Method in class javax.mail.internet.MimeMessage
Return the value of the RFC 822 "Reply-To" header field.
getReplyTo() - Method in class javax.mail.Message
Get the addresses to which replies should be directed.
getRepositoryItem() - Method in interface javax.xml.registry.infomodel.ExtrinsicObject
Gets the repository item for this object.
getRepresentationClass() - Method in class javax.activation.ActivationDataFlavor
Return the representation class.
getRequest() - Method in class javax.faces.context.ExternalContext
Return the environment-specific object instance for the current request.
getRequest() - Method in class javax.servlet.jsp.PageContext
The current value of the request object (a ServletRequest).
getRequest() - Method in class javax.servlet.ServletRequestWrapper
Return the wrapped request object.
getRequestCharacterEncoding() - Method in class javax.faces.context.ExternalContext
Return the character encoding currently being used to interpret this request.
getRequestContentType() - Method in class javax.faces.context.ExternalContext
Return the MIME Content-Type for this request.
getRequestContext() - Method in interface javax.xml.ws.BindingProvider
Get the context that is used to initialize the message context for request messages.
getRequestContextPath() - Method in class javax.faces.context.ExternalContext
Return the portion of the request URI that identifies the web application context for this request.
getRequestCookieMap() - Method in class javax.faces.context.ExternalContext
Return an immutable Map whose keys are the set of cookie names included in the current request, and whose values (of type javax.servlet.http.Cookie) are the first (or only) cookie for each cookie name returned by the underlying request.
getRequestDispatcher(String) - Method in interface javax.servlet.ServletContext
Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.
getRequestDispatcher(String) - Method in interface javax.servlet.ServletRequest
Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.
getRequestDispatcher(String) - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getRequestDispatcher(String path) on the wrapped request object.
getRequestedSessionId() - Method in interface javax.servlet.http.HttpServletRequest
Returns the session ID specified by the client.
getRequestedSessionId() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getRequestedSessionId() on the wrapped request object.
getRequestHeaderMap() - Method in class javax.faces.context.ExternalContext
Return an immutable Map whose keys are the set of request header names included in the current request, and whose values (of type String) are the first (or only) value for each header name returned by the underlying request.
getRequestHeaderValuesMap() - Method in class javax.faces.context.ExternalContext
Return an immutable Map whose keys are the set of request header names included in the current request, and whose values (of type String[]) are all of the value for each header name returned by the underlying request.
getRequestId() - Method in exception javax.xml.registry.JAXRException
getRequestId() - Method in interface javax.xml.registry.JAXRResponse
Returns the unique id for the request that generated this response.
getRequestingPort() - Method in class javax.mail.Authenticator
getRequestingPrompt() - Method in class javax.mail.Authenticator
getRequestingProtocol() - Method in class javax.mail.Authenticator
Give the protocol that's requesting the connection.
getRequestingSite() - Method in class javax.mail.Authenticator
getRequestLocale() - Method in class javax.faces.context.ExternalContext
Return the preferred Locale in which the client will accept content.
getRequestLocales() - Method in class javax.faces.context.ExternalContext
Return an Iterator over the preferred Locales specified in the request, in decreasing order of preference.
getRequestMap() - Method in class javax.faces.context.ExternalContext
Return a mutable Map representing the request scope attributes for the current application.
getRequestParameterMap() - Method in class javax.faces.context.ExternalContext
Return an immutable Map whose keys are the set of request parameters names included in the current request, and whose values (of type String) are the first (or only) value for each parameter name returned by the underlying request.
getRequestParameterNames() - Method in class javax.faces.context.ExternalContext
Return an Iterator over the names of all request parameters included in the current request.
getRequestParameterValuesMap() - Method in class javax.faces.context.ExternalContext
Return an immutable Map whose keys are the set of request parameters names included in the current request, and whose values (of type String[]) are all of the values for each parameter name returned by the underlying request.
getRequestPathInfo() - Method in class javax.faces.context.ExternalContext
Return the extra path information (if any) included in the request URI; otherwise, return null.
getRequestServletPath() - Method in class javax.faces.context.ExternalContext
Return the servlet path information (if any) included in the request URI; otherwise, return null.
getRequestURI() - Method in interface javax.servlet.http.HttpServletRequest
Returns the part of this request's URL from the protocol name up to the query string in the first line of the HTTP request.
getRequestURI() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getRequestURI() on the wrapped request object.
getRequestURI() - Method in class javax.servlet.jsp.ErrorData
Returns the request URI.
getRequestURL() - Method in interface javax.servlet.http.HttpServletRequest
Reconstructs the URL the client used to make the request.
getRequestURL() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getRequestURL() on the wrapped request object.
getRequestURL(HttpServletRequest) - Static method in class javax.servlet.http.HttpUtils
Deprecated. Reconstructs the URL the client used to make the request, using information in the HttpServletRequest object.
getRequiredMessage() - Method in class javax.faces.component.UIInput
If there has been a call to UIInput.setRequiredMessage(java.lang.String) on this instance, return the message.
getRequiredVersion() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
A string describing the required version of the JSP container.
getResource(String) - Method in class javax.faces.context.ExternalContext
Return a URL for the application resource mapped to the specified path, if it exists; otherwise, return null.
getResource(String) - Method in interface javax.servlet.ServletContext
Returns a URL to the resource that is mapped to a specified path.
getResource(Object) - Method in interface javax.transaction.TransactionSynchronizationRegistry
Get an object from the Map of resources being managed for the transaction bound to the current thread at the time this method is called.
getResourceAdapter() - Method in interface javax.resource.spi.ResourceAdapterAssociation
Get the associated ResourceAdapter object.
getResourceAsStream(String) - Method in class javax.faces.context.ExternalContext
Return an InputStream for an application resource mapped to the specified path, if it exists; otherwise, return null.
getResourceAsStream(String) - Method in interface javax.servlet.ServletContext
Returns the resource located at the named path as an InputStream object.
getResourceBundle(FacesContext, String) - Method in class javax.faces.application.Application
Find a ResourceBundle as defined in the application configuration resources under the specified name.
getResourcePaths(String) - Method in class javax.faces.context.ExternalContext
Return the Set of resource paths for all application resources whose resource path starts with the specified argument.
getResourcePaths(String) - Method in interface javax.servlet.ServletContext
Returns a directory-like listing of all the paths to resources within the web application whose longest sub-path matches the supplied path argument.
getResourceURL(FacesContext, String) - Method in class javax.faces.application.ViewHandler
Return a URL suitable for rendering (after optional encoding perfomed by the encodeResourceURL() method of ExternalContext) that selects the specifed web application resource.
getResourceURL(FacesContext, String) - Method in class javax.faces.application.ViewHandlerWrapper
The default behavior of this method is to call ViewHandler.getResourceURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
getResponse() - Method in class javax.faces.context.ExternalContext
Return the environment-specific object instance for the current response.
getResponse() - Method in class javax.servlet.jsp.PageContext
The current value of the response object (a ServletResponse).
getResponse() - Method in class javax.servlet.ServletResponseWrapper
Return the wrapped ServletResponse object.
getResponseCharacterEncoding() - Method in class javax.faces.context.ExternalContext
Returns the name of the character encoding (MIME charset) used for the body sent in this response.
getResponseComplete() - Method in class javax.faces.context.FacesContext
Return true if the responseComplete() method has been called for the current request.
getResponseContentType() - Method in class javax.faces.context.ExternalContext
Return the MIME Content-Type for this response.
getResponseContext() - Method in interface javax.xml.ws.BindingProvider
Get the context that resulted from processing a response message.
getResponseStateManager() - Method in class javax.faces.render.RenderKit
Return an instance of ResponseStateManager to handle rendering technology specific state management decisions.
getResponseStream() - Method in class javax.faces.context.FacesContext
Return the ResponseStream to which components should direct their binary output.
getResponseWriter() - Method in class javax.faces.context.FacesContext
Return the ResponseWriter to which components should direct their character-based output.
getResult() - Method in interface javax.xml.bind.UnmarshallerHandler
Obtains the unmarshalled result.
getResult() - Method in class javax.xml.bind.util.JAXBResult
Gets the unmarshalled object created by the transformation.
getResult() - Method in class javax.xml.soap.SAAJResult
getResultList() - Method in interface javax.persistence.Query
Execute a SELECT query and return the query results as a List.
getResultSetInfo() - Method in interface javax.resource.cci.Connection
Gets the information on the ResultSet functionality supported by a connected EIS instance.
getResultTargetModuleIDs() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
Retrieve the list of TargetModuleIDs successfully processed or created by the associated DeploymentManager operation.
getReturnType() - Method in class javax.el.MethodInfo
Returns the return type of the method
getReturnType() - Method in interface javax.xml.rpc.Call
Gets the return type for a specific operation
getRev() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the rev property.
getRev() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the rev property.
getRole() - Method in interface javax.xml.soap.SOAPHeaderElement
Returns the value of the Role attribute of this SOAPHeaderElement.
getRoles() - Method in interface javax.xml.rpc.handler.HandlerChain
Gets SOAP actor roles registered for this HandlerChain at this SOAP node.
getRoles() - Method in interface javax.xml.rpc.handler.soap.SOAPMessageContext
Gets the SOAP actor roles associated with an execution of the HandlerChain and its contained Handler instances.
getRoles() - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext
Gets the SOAP actor roles associated with an execution of the handler chain.
getRoles() - Method in interface javax.xml.ws.soap.SOAPBinding
Gets the roles played by the SOAP binding instance.
getRollbackOnly() - Method in interface javax.ejb.EJBContext
Test if the transaction has been marked for rollback only.
getRollbackOnly() - Method in interface javax.persistence.EntityTransaction
Determine whether the current transaction has been marked for rollback.
getRollbackOnly() - Method in interface javax.transaction.TransactionSynchronizationRegistry
Get the rollbackOnly status of the transaction bound to the current thread at the time this method is called.
getRolledbackCount() - Method in interface javax.management.j2ee.statistics.JTAStats
Number of rolled-back transactions.
getRoot() - Method in interface javax.enterprise.deploy.model.DDBean
Return the root element for this DDBean.
getRootCause() - Method in exception javax.servlet.jsp.el.ELException
Deprecated. Returns the root cause.
getRootCause() - Method in exception javax.servlet.jsp.JspException
Deprecated. As of JSP 2.1, replaced by Throwable.getCause()
getRootCause() - Method in exception javax.servlet.ServletException
Returns the exception that caused this servlet exception.
getRootOrganization() - Method in interface javax.xml.registry.infomodel.Organization
Gets the root organization.
getRowClasses() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the rowClasses property.
getRowClasses() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the rowClasses property.
getRowCount() - Method in class javax.faces.component.UIData
Return the number of rows in the underlying data model.
getRowCount() - Method in class javax.faces.model.ArrayDataModel
If there is wrappedData available, return the length of the array.
getRowCount() - Method in class javax.faces.model.DataModel
Return the number of rows of data objects represented by this DataModel.
getRowCount() - Method in class javax.faces.model.ListDataModel
If there is wrappedData available, return the length of the list.
getRowCount() - Method in class javax.faces.model.ResultDataModel
If there is wrappedData available, return the length of the array returned by calling getRows() on the underlying Result.
getRowCount() - Method in class javax.faces.model.ResultSetDataModel
Return -1, since ResultSet does not provide a standard way to determine the number of available rows without scrolling through the entire ResultSet, and this can be very expensive if the number of rows is large.
getRowCount() - Method in class javax.faces.model.ScalarDataModel
If there is wrappedData available, return 1.
getRowData() - Method in class javax.faces.component.UIData
Return the data object representing the data for the currently selected row index, if any.
getRowData() - Method in class javax.faces.model.ArrayDataModel
If row data is available, return the array element at the index specified by rowIndex.
getRowData() - Method in class javax.faces.model.DataModel
Return an object representing the data for the currenty selected row index.
getRowData() - Method in class javax.faces.model.DataModelEvent
Return the object representing the data for the specified row index, or null for no associated row data.
getRowData() - Method in class javax.faces.model.ListDataModel
If row data is available, return the array element at the index specified by rowIndex.
getRowData() - Method in class javax.faces.model.ResultDataModel
If row data is available, return the SortedMap array element at the index specified by rowIndex of the array returned by calling getRows() on the underlying Result.
getRowData() - Method in class javax.faces.model.ResultSetDataModel
If row data is available, return a Map representing the values of the columns for the row specified by rowIndex, keyed by the corresponding column names.
getRowData() - Method in class javax.faces.model.ScalarDataModel
If wrapped data is available, return the wrapped data instance.
getRowIndex() - Method in class javax.faces.component.UIData
Return the zero-relative index of the currently selected row.
getRowIndex() - Method in class javax.faces.model.ArrayDataModel
getRowIndex() - Method in class javax.faces.model.DataModel
Return the zero-relative index of the currently selected row.
getRowIndex() - Method in class javax.faces.model.DataModelEvent
Return the row index for this event, or -1 for no specific row.
getRowIndex() - Method in class javax.faces.model.ListDataModel
getRowIndex() - Method in class javax.faces.model.ResultDataModel
getRowIndex() - Method in class javax.faces.model.ResultSetDataModel
getRowIndex() - Method in class javax.faces.model.ScalarDataModel
getRows() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the rows property.
getRows() - Method in class javax.faces.component.UIData
Return the number of rows to be displayed, or zero for all remaining rows in the table.
getRules() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the rules property.
getRules() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the rules property.
getRunningModules(ModuleType, Target[]) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Retrieve the list of J2EE application modules distributed to the identified targets and that are currently running on the associated server or servers.
getSchema() - Method in class javax.xml.bind.Binder
Gets the last Schema object (including null) set by the Binder.setSchema(Schema) method.
getSchema() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
getSchema() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
getSchema() - Method in interface javax.xml.bind.Marshaller
Get the JAXP 1.3 Schema object being used to perform marshal-time validation.
getSchema() - Method in interface javax.xml.bind.Unmarshaller
Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.
getSchemaLocation() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
Convenience method for getting the current schemaLocation.
getSchemaType() - Method in interface javax.xml.stream.events.XMLEvent
This method is provided for implementations to provide optional type information about the associated event.
getScheme() - Method in interface javax.servlet.ServletRequest
Returns the name of the scheme used to make this request, for example, http, https, or ftp.
getScheme() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getScheme() on the wrapped request object.
getScope() - Method in class javax.servlet.jsp.tagext.TagVariableInfo
The body of the <scope> element.
getScope() - Method in class javax.servlet.jsp.tagext.VariableInfo
Returns the lexical scope of the variable.
getScope() - Method in class javax.xml.bind.JAXBElement
Returns scope of xml element declaration.
getScope(String) - Method in interface javax.xml.ws.handler.MessageContext
Gets the scope of a property.
getSecure() - Method in class javax.servlet.http.Cookie
Returns true if the browser is sending cookies only over a secure protocol, or false if the browser can send cookies using any protocol.
getSelectedValues() - Method in class javax.faces.component.UISelectMany
Return the currently selected values, or null if there are no currently selected values.
getSelectItems() - Method in class javax.faces.model.SelectItemGroup
Return the set of subordinate SelectItems for this group.
getSender() - Method in class javax.mail.internet.MimeMessage
Returns the value of the RFC 822 "Sender" header field.
getSentDate() - Method in class javax.mail.internet.MimeMessage
Returns the value of the RFC 822 "Date" field.
getSentDate() - Method in class javax.mail.Message
Get the date this message was sent.
getSentMailCount() - Method in interface javax.management.j2ee.statistics.JavaMailStats
The number of mail messages sent.
getSeparator() - Method in class javax.mail.Folder
Return the delimiter character that separates this Folder's pathname from the names of immediate subfolders.
getSerializer(Class, QName) - Method in interface javax.xml.rpc.encoding.TypeMapping
Gets the SerializerFactory registered for the specified pair of Java type and XML data type.
getSerializerAs(String) - Method in interface javax.xml.rpc.encoding.SerializerFactory
Returns a Serializer for the specified XML processing mechanism type.
getServerInfo() - Method in interface javax.servlet.ServletContext
Returns the name and version of the servlet container on which the servlet is running.
getServerName() - Method in interface javax.servlet.ServletRequest
Returns the host name of the server to which the request was sent.
getServerName() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getServerName() on the wrapped request object.
getServerPort() - Method in interface javax.servlet.ServletRequest
Returns the port number to which the request was sent.
getServerPort() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return getServerPort() on the wrapped request object.
getServerSession() - Method in interface javax.jms.ServerSessionPool
Return a server session from the pool.
getServerSessionPool() - Method in interface javax.jms.ConnectionConsumer
Gets the server session pool associated with this connection consumer.
getService() - Method in interface javax.xml.registry.infomodel.ServiceBinding
Gets the parent service for which this is a binding.
getServiceBinding() - Method in interface javax.xml.registry.infomodel.SpecificationLink
Gets the parent ServiceBinding for this SpecificationLink.
getServiceBindings() - Method in interface javax.xml.registry.infomodel.Service
Gets all children ServiceBindings.
getServiceName() - Method in interface javax.xml.rpc.Service
Gets the name of this service.
getServiceName() - Method in interface javax.xml.ws.handler.PortInfo
Gets the qualified name of the WSDL service name containing the port being accessed.
getServiceName() - Method in class javax.xml.ws.Service
Gets the name of this service.
getServiceName() - Method in class javax.xml.ws.spi.ServiceDelegate
Gets the name of this service.
getServices() - Method in interface javax.xml.registry.infomodel.Organization
Gets all children Services.
getServiceTime() - Method in interface javax.management.j2ee.statistics.ServletStats
Execution times for the methods.
getServlet(String) - Method in interface javax.servlet.ServletContext
Deprecated. As of Java Servlet API 2.1, with no direct replacement.

This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.

getServlet() - Method in exception javax.servlet.UnavailableException
Deprecated. As of Java Servlet API 2.2, with no replacement. Returns the servlet that is reporting its unavailability.
getServletConfig() - Method in class javax.faces.webapp.FacesServlet
Return the ServletConfig instance for this servlet.
getServletConfig() - Method in class javax.servlet.GenericServlet
Returns this servlet's ServletConfig object.
getServletConfig() - Method in class javax.servlet.jsp.PageContext
The ServletConfig instance.
getServletConfig() - Method in interface javax.servlet.Servlet
Returns a ServletConfig object, which contains initialization and startup parameters for this servlet.
getServletContext() - Method in interface javax.servlet.FilterConfig
Returns a reference to the ServletContext in which the caller is executing.
getServletContext() - Method in class javax.servlet.GenericServlet
Returns a reference to the ServletContext in which this servlet is running.
getServletContext() - Method in interface javax.servlet.http.HttpSession
Returns the ServletContext to which this session belongs.
getServletContext() - Method in class javax.servlet.jsp.PageContext
The ServletContext instance.
getServletContext() - Method in interface javax.servlet.ServletConfig
Returns a reference to the ServletContext in which the caller is executing.
getServletContext() - Method in class javax.servlet.ServletContextEvent
Return the ServletContext that changed.
getServletContext() - Method in class javax.servlet.ServletRequestEvent
Returns the ServletContext of this web application.
getServletContext() - Method in interface javax.xml.rpc.server.ServletEndpointContext
The method getServletContext returns the ServletContext associated with the web application that contain this endpoint.
getServletContextName() - Method in interface javax.servlet.ServletContext
Returns the name of this web application corresponding to this ServletContext as specified in the deployment descriptor for this web application by the display-name element.
getServletInfo() - Method in class javax.faces.webapp.FacesServlet
Return information about this Servlet.
getServletInfo() - Method in class javax.servlet.GenericServlet
Returns information about the servlet, such as author, version, and copyright.
getServletInfo() - Method in interface javax.servlet.Servlet
Returns information about the servlet, such as author, version, and copyright.
getServletName() - Method in class javax.servlet.GenericServlet
Returns the name of this servlet instance.
getServletName() - Method in class javax.servlet.jsp.ErrorData
Returns the name of the servlet invoked.
getServletName() - Method in interface javax.servlet.ServletConfig
Returns the name of this servlet instance.
getServletNames() - Method in interface javax.servlet.ServletContext
Deprecated. As of Java Servlet API 2.1, with no replacement.

This method was originally defined to return an Enumeration of all the servlet names known to this context. In this version, this method always returns an empty Enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

getServletPath() - Method in interface javax.servlet.http.HttpServletRequest
Returns the part of this request's URL that calls the servlet.
getServletPath() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getServletPath() on the wrapped request object.
getServletRequest() - Method in class javax.servlet.ServletRequestEvent
Returns the ServletRequest that is changing.
getServlets() - Method in interface javax.servlet.ServletContext
Deprecated. As of Java Servlet API 2.0, with no replacement.

This method was originally defined to return an Enumeration of all the servlets known to this servlet context. In this version, this method always returns an empty enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

getSession(boolean) - Method in class javax.faces.context.ExternalContext
If the create parameter is true, create (if necessary) and return a session instance associated with the current request.
getSession() - Method in interface javax.jms.ServerSession
Return the ServerSession's Session.
getSession() - Method in interface javax.jms.XASession
Gets the session associated with this XASession.
getSession() - Method in class javax.mail.MessageContext
Return the Session we're operating in.
getSession(boolean) - Method in interface javax.servlet.http.HttpServletRequest
Returns the current HttpSession associated with this request or, if there is no current session and create is true, returns a new session.
getSession() - Method in interface javax.servlet.http.HttpServletRequest
Returns the current session associated with this request, or if the request does not have a session, creates one.
getSession(boolean) - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getSession(boolean create) on the wrapped request object.
getSession() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getSession() on the wrapped request object.
getSession() - Method in class javax.servlet.http.HttpSessionBindingEvent
Return the session that changed.
getSession(String) - Method in interface javax.servlet.http.HttpSessionContext
Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return null and will be removed in a future version of this API.
getSession() - Method in class javax.servlet.http.HttpSessionEvent
Return the session that changed.
getSession() - Method in class javax.servlet.jsp.PageContext
The current value of the session object (an HttpSession).
getSessionContext() - Method in interface javax.servlet.http.HttpSession
Deprecated. As of Version 2.1, this method is deprecated and has no replacement. It will be removed in a future version of the Java Servlet API.
getSessionMap() - Method in class javax.faces.context.ExternalContext
Return a mutable Map representing the session scope attributes for the current application.
getSessions() - Method in interface javax.management.j2ee.statistics.JMSConnectionStats
Returns an array of JMSSessionStats that provide statistics about the sessions associated with the referencing JMSConnectionStats.
getSeverity() - Method in class javax.faces.application.FacesMessage
Return the severity level.
getSeverity() - Method in class javax.xml.bind.helpers.ValidationEventImpl
getSeverity() - Method in interface javax.xml.bind.ValidationEvent
Retrieve the severity code for this warning/error.
getShape() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the shape property.
getShape() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the shape property.
getSharedNamespaces() - Method in class javax.mail.Store
Return a set of folders representing the shared namespaces.
getShort(String) - Method in interface javax.jms.MapMessage
Returns the short value with the specified name.
getShortName() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
The preferred short name (prefix) as indicated in the TLD.
getShortProperty(String) - Method in interface javax.jms.Message
Returns the value of the short property with the specified name.
getSingleResult() - Method in interface javax.persistence.Query
Execute a SELECT query that returns a single result.
getSize() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the size property.
getSize() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the size property.
getSize() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the size property.
getSize() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the size property.
getSize() - Method in class javax.mail.internet.MimeBodyPart
Return the size of the content of this body part in bytes.
getSize() - Method in class javax.mail.internet.MimeMessage
Return the size of the content of this message in bytes.
getSize() - Method in interface javax.mail.Part
Return the size of the content of this part in bytes.
getSize() - Method in class javax.xml.soap.AttachmentPart
Returns the number of bytes in this AttachmentPart object.
getSlot(String) - Method in interface javax.xml.registry.infomodel.ExtensibleObject
Gets the slot specified by slotName.
getSlots() - Method in interface javax.xml.registry.infomodel.ExtensibleObject
Returns the Slots associated with this object.
getSlotType() - Method in interface javax.xml.registry.infomodel.Slot
Gets the slotType for this Slot.
getSmallIcon() - Method in class javax.servlet.jsp.tagext.TagInfo
Get the path to the small icon.
getSOAPBody() - Method in class javax.xml.soap.SOAPMessage
Gets the SOAP Body contained in this SOAPMessage object.
getSOAPFactory() - Method in interface javax.xml.ws.soap.SOAPBinding
Gets the SAAJ SOAPFactory instance used by this SOAP binding.
getSOAPHeader() - Method in class javax.xml.soap.SOAPMessage
Gets the SOAP Header contained in this SOAPMessage object.
getSOAPPart() - Method in class javax.xml.soap.SOAPMessage
Gets the SOAP part of this SOAPMessage object.
getSourceObject() - Method in interface javax.xml.registry.infomodel.Association
Gets the Object that is the source of this Association.
getSpecificationLinks() - Method in interface javax.xml.registry.infomodel.ServiceBinding
Gets all children SpecificationLinks.
getSpecificationObject() - Method in interface javax.xml.registry.infomodel.SpecificationLink
Gets the specification object for this object.
getSpecificationVersion() - Method in class javax.servlet.jsp.JspEngineInfo
Return the version number of the JSP specification that is supported by this JSP engine.
getSpecVersion() - Method in interface javax.resource.cci.ResourceAdapterMetaData
Returns a string representation of the version of the connector architecture specification that is supported by the resource adapter.
getStability() - Method in interface javax.xml.registry.infomodel.RegistryEntry
Gets the stability indicator for the RegistryEntry within the Registry.
getStartDuration() - Method in class javax.resource.spi.work.WorkEvent
Return the start interval duration.
getStartTime() - Method in interface javax.management.j2ee.statistics.Statistic
The time of the first measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.
getState() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
Retrieve the StateType value.
getState() - Method in class javax.faces.application.StateManager.SerializedView
Deprecated.
getState(FacesContext, String) - Method in class javax.faces.render.ResponseStateManager
The implementation must inspect the current request and return an Object representing the tree structure and component state passed in to a previous invocation of ResponseStateManager.writeState(javax.faces.context.FacesContext,java.lang.Object).
getStateManager() - Method in class javax.faces.application.Application
Return the StateManager instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
getStateOrProvince() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the state or province.
getStateType(int) - Static method in class javax.enterprise.deploy.shared.StateType
Return an object of the specified value.
getStatistic(String) - Method in interface javax.management.j2ee.statistics.Stats
Get a Statistic by name.
getStatisticNames() - Method in interface javax.management.j2ee.statistics.Stats
Returns an array of Strings which are the names of the attributes from the specific Stats submodel that this object supports.
getStatistics() - Method in interface javax.management.j2ee.statistics.Stats
Returns an array containing all of the Statistic objects supported by this Stats object.
getStatus() - Method in interface javax.transaction.Transaction
Obtain the status of the transaction associated with the target Transaction object.
getStatus() - Method in interface javax.transaction.TransactionManager
Obtain the status of the transaction associated with the current thread.
getStatus() - Method in interface javax.transaction.UserTransaction
Obtain the status of the transaction associated with the current thread.
getStatus() - Method in interface javax.xml.registry.infomodel.RegistryEntry
Gets the life cycle status of the RegistryEntry within the registry.
getStatus() - Method in exception javax.xml.registry.JAXRException
getStatus() - Method in interface javax.xml.registry.JAXRResponse
Returns the status for this response.
getStatusCode() - Method in class javax.servlet.jsp.ErrorData
Returns the status code of the error.
getStatusCode() - Method in exception javax.xml.ws.http.HTTPException
Gets the HTTP status code.
getStore() - Method in class javax.mail.Folder
Returns the Store that owns this Folder object.
getStore() - Method in class javax.mail.Session
Get a Store object that implements this user's desired Store protocol.
getStore(String) - Method in class javax.mail.Session
Get a Store object that implements the specified protocol.
getStore(URLName) - Method in class javax.mail.Session
Get a Store object for the given URLName.
getStore(Provider) - Method in class javax.mail.Session
Get an instance of the store specified by Provider.
getStore() - Method in exception javax.mail.StoreClosedException
Returns the dead Store object
getStreet() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the street name.
getStreetNumber() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the street number.
getString(String) - Method in interface javax.jms.MapMessage
Returns the String value with the specified name.
getString() - Method in class javax.servlet.jsp.tagext.BodyContent
Return the value of the BodyContent as a String.
getStringProperty(String) - Method in interface javax.jms.Message
Returns the value of the String property with the specified name.
getStringTable() - Method in class javax.enterprise.deploy.shared.ActionType
Returns the string table for class ActionType
getStringTable() - Method in class javax.enterprise.deploy.shared.CommandType
Returns the string table for class CommandType
getStringTable() - Method in class javax.enterprise.deploy.shared.DConfigBeanVersionType
Returns the string table for class DConfigBeanVersionType
getStringTable() - Method in class javax.enterprise.deploy.shared.ModuleType
Returns the string table for class ModuleType
getStringTable() - Method in class javax.enterprise.deploy.shared.StateType
Returns the string table for class StateType
getStructure() - Method in class javax.faces.application.StateManager.SerializedView
Deprecated.
getStyle() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlForm
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlOutputFormat
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlOutputText
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlPanelGroup
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the style property.
getStyle() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the style property.
getStyleClass() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlForm
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlOutputFormat
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlOutputText
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlPanelGroup
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the styleClass property.
getStyleClass() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the styleClass property.
getSubject() - Method in class javax.mail.internet.MimeMessage
Returns the value of the "Subject" header field.
getSubject() - Method in class javax.mail.Message
Get the subject of this message.
getSubmittedValue() - Method in interface javax.faces.component.EditableValueHolder
Return the submittedValue value of this component.
getSubmittedValue() - Method in class javax.faces.component.UIInput
Return the submittedValue value of this UIInput component.
getSubmittingOrganization() - Method in interface javax.xml.registry.infomodel.RegistryObject
Gets the Organization that submitted this RegistryObject.
getSubType() - Method in class javax.activation.MimeType
Retrieve the subtype of this object.
getSubType() - Method in class javax.mail.internet.ContentType
Return the subType.
getSummary() - Method in class javax.faces.application.FacesMessage
Return the localized summary text.
getSummary() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the summary property.
getSummary() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the summary property.
getSupportedEncodings() - Method in interface javax.xml.rpc.encoding.TypeMapping
Returns the encodingStyle URIs (as String[]) supported by this TypeMapping instance.
getSupportedLocales() - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Returns an array of supported locales for this implementation.
getSupportedLocales() - Method in class javax.faces.application.Application
Return an Iterator over the supported Locales for this appication.
getSupportedMechanismTypes() - Method in interface javax.xml.rpc.encoding.DeserializerFactory
Returns a list of all XML processing mechanism types supported by this DeserializerFactory.
getSupportedMechanismTypes() - Method in interface javax.xml.rpc.encoding.SerializerFactory
Returns a list of all XML processing mechanism types supported by this SerializerFactory.
getSystemFlags() - Method in class javax.mail.Flags
Return all the system flags in this Flags object.
getSystemId() - Method in interface javax.xml.stream.events.EntityDeclaration
The entity's system identifier.
getSystemId() - Method in interface javax.xml.stream.events.NotationDeclaration
The notation's system identifier, or null if none was given.
getSystemId() - Method in interface javax.xml.stream.events.StartDocument
Returns the system ID of the XML data
getSystemId() - Method in interface javax.xml.stream.Location
Returns the system ID of the XML
getTabindex() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the tabindex property.
getTabindex() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the tabindex property.
getTabindex() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the tabindex property.
getTabindex() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the tabindex property.
getTabindex() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the tabindex property.
getTabindex() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the tabindex property.
getTabindex() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the tabindex property.
getTabindex() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the tabindex property.
getTabindex() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the tabindex property.
getTabindex() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the tabindex property.
getTabindex() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the tabindex property.
getTabindex() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the tabindex property.
getTabindex() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the tabindex property.
getTabindex() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the tabindex property.
getTag(String) - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
Get the TagInfo for a given tag name, looking through all the tags in this tag library.
getTagClassName() - Method in class javax.servlet.jsp.tagext.TagInfo
Name of the class that provides the handler for this tag.
getTagExtraInfo() - Method in class javax.servlet.jsp.tagext.TagInfo
The instance (if any) for extra tag information.
getTagFile(String) - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
Get the TagFileInfo for a given tag name, looking through all the tag files in this tag library.
getTagFiles() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
An array describing the tag files that are defined in this tag library.
getTagInfo() - Method in class javax.servlet.jsp.tagext.TagExtraInfo
Get the TagInfo for this class.
getTagInfo() - Method in class javax.servlet.jsp.tagext.TagFileInfo
Returns information about this tag, parsed from the directives in the tag file.
getTagLibrary() - Method in class javax.servlet.jsp.tagext.TagInfo
The instance of TabLibraryInfo we belong to.
getTagLibraryInfos() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
Returns an array of TagLibraryInfo objects representing the entire set of tag libraries (including this TagLibraryInfo) imported by taglib directives in the translation unit that references this TagLibraryInfo.
getTagName() - Method in class javax.servlet.jsp.tagext.TagInfo
The name of the Tag.
getTags() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
An array describing the tags that are defined in this tag library.
getTagVariableInfos() - Method in class javax.servlet.jsp.tagext.TagInfo
Get TagVariableInfo objects associated with this TagInfo.
getTarget() - Method in interface javax.enterprise.deploy.spi.TargetModuleID
Retrieve the name of the target server.
getTarget() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the target property.
getTarget() - Method in class javax.faces.component.html.HtmlForm
Return the value of the target property.
getTarget() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the target property.
getTarget() - Method in interface javax.interceptor.InvocationContext
Returns the target instance.
getTarget() - Method in interface javax.xml.stream.events.ProcessingInstruction
The target section of the processing instruction
getTargetBinding() - Method in interface javax.xml.registry.infomodel.ServiceBinding
Gets the next ServiceBinding in case there is a redirection from one service provider to another service provider.
getTargetEndpointAddress() - Method in interface javax.xml.rpc.Call
Gets the address of a target service endpoint.
getTargetModuleID() - Method in class javax.enterprise.deploy.spi.status.ProgressEvent
Retrieve the TargetModuleID for this event
getTargetObject() - Method in interface javax.xml.registry.infomodel.Association
Gets the Object that is the target of this Association.
getTargets() - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Retrieve the list of deployment targets supported by this DeploymentManager.
getTelephoneNumbers(String) - Method in interface javax.xml.registry.infomodel.Organization
Gets the telephone numbers for this User that match the specified telephone number type.
getTelephoneNumbers(String) - Method in interface javax.xml.registry.infomodel.User
Gets the telephone numbers for this User that match the specified telephone number type.
getTerm() - Method in class javax.mail.search.NotTerm
Return the term to negate.
getTerms() - Method in class javax.mail.search.AndTerm
Return the search terms.
getTerms() - Method in class javax.mail.search.OrTerm
Return the search terms.
getTestSet() - Method in class javax.mail.search.FlagTerm
Return true if testing whether the flags are set.
getText() - Method in interface javax.enterprise.deploy.model.DDBean
Returns the XML text for by this bean.
getText(String) - Method in interface javax.enterprise.deploy.model.DDBean
Return a list of text values for a given XPath in the deployment descriptor.
getText(String) - Method in interface javax.enterprise.deploy.model.DeployableObject
Return the XML content associated with the XPath from a deployment descriptor.
getText(ModuleType, String) - Method in interface javax.enterprise.deploy.model.J2eeApplicationObject
Return the text value from the XPath; search only the deployment descriptors of the specified type.
getText() - Method in interface javax.jms.TextMessage
Gets the string containing this message's data.
getText() - Method in interface javax.xml.stream.events.Comment
Return the string data of the comment, returns empty string if it does not exist
getText() - Method in class javax.xml.stream.util.StreamReaderDelegate
getText() - Method in interface javax.xml.stream.XMLStreamReader
Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD.
getTextCharacters(int, char[], int, int) - Method in class javax.xml.stream.util.StreamReaderDelegate
getTextCharacters() - Method in class javax.xml.stream.util.StreamReaderDelegate
getTextCharacters() - Method in interface javax.xml.stream.XMLStreamReader
Returns an array which contains the characters from this event.
getTextCharacters(int, char[], int, int) - Method in interface javax.xml.stream.XMLStreamReader
Gets the the text associated with a CHARACTERS, SPACE or CDATA event.
getTextLength() - Method in class javax.xml.stream.util.StreamReaderDelegate
getTextLength() - Method in interface javax.xml.stream.XMLStreamReader
Returns the length of the sequence of characters for this Text event within the text character array.
getTextStart() - Method in class javax.xml.stream.util.StreamReaderDelegate
getTextStart() - Method in interface javax.xml.stream.XMLStreamReader
Returns the offset into the text character array where the first character (of this text event) is stored.
getThrowable() - Method in class javax.servlet.jsp.ErrorData
Returns the Throwable that caused the error.
getTimer() - Method in interface javax.ejb.TimerHandle
Obtain a reference to the timer represented by this handle.
getTimeRemaining() - Method in interface javax.ejb.Timer
Get the number of milliseconds that will elapse before the next scheduled timer expiration.
getTimers() - Method in interface javax.ejb.TimerService
Get all the active timers associated with this bean.
getTimerService() - Method in interface javax.ejb.EJBContext
Get access to the EJB Timer Service.
getTimestamp() - Method in interface javax.xml.registry.infomodel.AuditableEvent
Gets the Timestamp for when this event occurred.
getTimeStyle() - Method in class javax.faces.convert.DateTimeConverter
Return the style to be used to format or parse times.
getTimeToLive() - Method in interface javax.jms.MessageProducer
Gets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.
getTimeZone() - Method in class javax.faces.convert.DateTimeConverter
Return the TimeZone used to interpret a time value.
getTitle() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlForm
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlOutputFormat
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlOutputText
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the title property.
getTitle() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the title property.
getTopic() - Method in interface javax.jms.TopicPublisher
Gets the topic associated with this TopicPublisher.
getTopic() - Method in interface javax.jms.TopicSubscriber
Gets the Topic associated with this subscriber.
getTopicName() - Method in interface javax.jms.Topic
Gets the name of this topic.
getTopicSession() - Method in interface javax.jms.XATopicSession
Gets the topic session associated with this XATopicSession.
getTotalTime() - Method in interface javax.management.j2ee.statistics.TimeStatistic
This is the sum total of time taken to complete every invocation of this operation since the beginning of this measurement.
getTransacted() - Method in interface javax.jms.Session
Indicates whether the session is in transacted mode.
getTransacted() - Method in interface javax.jms.XASession
Indicates whether the session is in transacted mode.
getTransaction() - Method in interface javax.persistence.EntityManager
Returns the resource-level transaction object.
getTransaction() - Method in interface javax.transaction.TransactionManager
Get the transaction object that represents the transaction context of the calling thread.
getTransactionKey() - Method in interface javax.transaction.TransactionSynchronizationRegistry
Return an opaque object to represent the transaction bound to the current thread at the time this method is called.
getTransactionStatus() - Method in interface javax.transaction.TransactionSynchronizationRegistry
Return the status of the transaction bound to the current thread at the time this method is called.
getTransactionTimeout() - Method in class javax.resource.spi.work.ExecutionContext
Get the transaction timeout value for a imported transaction.
getTransactionTimeout() - Method in interface javax.transaction.xa.XAResource
Obtains the current transaction timeout value set for this XAResource instance.
getTransactionType() - Method in interface javax.persistence.spi.PersistenceUnitInfo
Returns the transaction type of the entity managers created by the EntityManagerFactory.
getTransferData(DataFlavor, DataSource) - Method in interface javax.activation.DataContentHandler
Returns an object which represents the data to be transferred.
getTransferData(DataFlavor) - Method in class javax.activation.DataHandler
Returns an object that represents the data to be transferred.
getTransferDataFlavors() - Method in interface javax.activation.DataContentHandler
Returns an array of DataFlavor objects indicating the flavors the data can be provided in.
getTransferDataFlavors() - Method in class javax.activation.DataHandler
Return the DataFlavors in which this data is available.
getTransport() - Method in class javax.mail.Session
Get a Transport object that implements this user's desired Transport protcol.
getTransport(String) - Method in class javax.mail.Session
Get a Transport object that implements the specified protocol.
getTransport(URLName) - Method in class javax.mail.Session
Get a Transport object for the given URLName.
getTransport(Provider) - Method in class javax.mail.Session
Get an instance of the transport specified in the Provider.
getTransport(Address) - Method in class javax.mail.Session
Get a Transport object that can transport a Message to the specified address type.
getTreeStructureToRestore(FacesContext, String) - Method in class javax.faces.render.ResponseStateManager
Deprecated. This method has been replaced by ResponseStateManager.getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.
getTreeStructureToSave(FacesContext) - Method in class javax.faces.application.StateManager
Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
getTreeStructureToSave(FacesContext) - Method in class javax.faces.application.StateManagerWrapper
The default behavior of this method is to call StateManager.getTreeStructureToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.
getType(ELContext, Object, Object) - Method in class javax.el.ArrayELResolver
If the base object is an array, returns the most general acceptable type for a value in this array.
getType(ELContext, Object, Object) - Method in class javax.el.BeanELResolver
If the base object is not null, returns the most general acceptable type that can be set on this bean property.
getType(ELContext, Object, Object) - Method in class javax.el.CompositeELResolver
For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the CompositeELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.
getType(ELContext, Object, Object) - Method in class javax.el.ELResolver
For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the ELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.
getType(ELContext, Object, Object) - Method in class javax.el.ListELResolver
If the base object is a list, returns the most general acceptable type for a value in this list.
getType(ELContext, Object, Object) - Method in class javax.el.MapELResolver
If the base object is a map, returns the most general acceptable type for a value in this map.
getType(ELContext, Object, Object) - Method in class javax.el.ResourceBundleELResolver
If the base object is an instance of ResourceBundle, return null, since the resolver is read only.
getType(ELContext) - Method in class javax.el.ValueExpression
Evaluates the expression relative to the provided context, and returns the most general type that is acceptable for an object to be passed as the value parameter in a future call to the ValueExpression.setValue(javax.el.ELContext, java.lang.Object) method.
getType() - Method in interface javax.enterprise.deploy.model.DDBeanRoot
Return the ModuleType of deployment descriptor.
getType() - Method in interface javax.enterprise.deploy.model.DeployableObject
Return the ModuleType of deployment descriptor (i.e., EAR, JAR, WAR, RAR) this deployable object represents.
getType() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the type property.
getType() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the type property.
getType() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the type property.
getType() - Method in class javax.faces.convert.DateTimeConverter
Return the type of value to be formatted or parsed.
getType() - Method in class javax.faces.convert.NumberConverter
Return the number type to be used when formatting and parsing numbers.
getType(FacesContext) - Method in class javax.faces.el.MethodBinding
Deprecated. Return the Java class representing the return type from the method identified by this method binding expression.
getType(Object, Object) - Method in class javax.faces.el.PropertyResolver
Deprecated. Return the java.lang.Class representing the type of the specified property.
getType(Object, int) - Method in class javax.faces.el.PropertyResolver
Deprecated. Return the java.lang.Class representing the type of the specified index.
getType(FacesContext) - Method in class javax.faces.el.ValueBinding
Deprecated. Return the type of the property represented by this ValueBinding, relative to the specified FacesContext.
getType() - Method in class javax.mail.Address
Return a type string that identifies this address type.
getType() - Method in class javax.mail.event.ConnectionEvent
Return the type of this event
getType() - Method in class javax.mail.event.FolderEvent
Return the type of this event.
getType() - Method in class javax.mail.event.MessageCountEvent
Return the type of this event.
getType() - Method in class javax.mail.event.TransportEvent
Return the type of this event.
getType() - Method in class javax.mail.Folder
Returns the type of this Folder, that is, whether this folder can hold messages or subfolders or both.
getType() - Method in class javax.mail.internet.HeaderTokenizer.Token
Return the type of the token.
getType() - Method in class javax.mail.internet.InternetAddress
Return the type of this address.
getType() - Method in class javax.mail.internet.NewsAddress
Return the type of this address.
getType() - Method in class javax.mail.Provider
Returns the type of this Provider
getType() - Method in class javax.resource.spi.work.WorkEvent
Return the type of this event.
getType(ELContext, Object, Object) - Method in class javax.servlet.jsp.el.ImplicitObjectELResolver
If the base object is null, and the property matches the name of a JSP implicit object, returns null to indicate that no types are ever accepted to setValue().
getType(ELContext, Object, Object) - Method in class javax.servlet.jsp.el.ScopedAttributeELResolver
If the base object is null, returns Object.class to indicate that any type is valid to set for a scoped attribute.
getType() - Method in interface javax.xml.registry.infomodel.EmailAddress
Gets the type for this object.
getType() - Method in interface javax.xml.registry.infomodel.PostalAddress
Returns the type of address (for example, "headquarters") as a String.
getType() - Method in interface javax.xml.registry.infomodel.TelephoneNumber
The type of telephone number (for example, "fax").
getType() - Method in interface javax.xml.registry.infomodel.User
Gets the type for this User.
getType() - Method in interface javax.xml.registry.Query
Gets the type of Query (for example, QUERY_TYPE_SQL).
getTypeMapping(String) - Method in interface javax.xml.rpc.encoding.TypeMappingRegistry
Returns the registered TypeMapping for the specified encodingStyle URI.
getTypeMappingRegistry() - Method in interface javax.xml.rpc.Service
Gets the TypeMappingRegistry for this Service object.
getTypeName() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
The type (as a String) of this attribute.
getUID(Message) - Method in interface javax.mail.UIDFolder
Get the UID for the specified message.
getUIDValidity() - Method in interface javax.mail.UIDFolder
Returns the UIDValidity value associated with this folder.
getUnavailableSeconds() - Method in exception javax.servlet.UnavailableException
Returns the number of seconds the servlet expects to be temporarily unavailable.
getUnit() - Method in interface javax.management.j2ee.statistics.Statistic
The unit of measurement for this Statistic.
getUnmarshallerHandler() - Method in interface javax.xml.bind.Unmarshaller
Get an unmarshaller handler object that can be used as a component in an XML pipeline.
getUnreadMessageCount() - Method in class javax.mail.Folder
Get the total number of unread messages in this Folder.
getUpperBound() - Method in interface javax.management.j2ee.statistics.BoundaryStatistic
The upper limit of the value of this attribute.
getUpTime() - Method in interface javax.management.j2ee.statistics.JVMStats
Amount of time the JVM has been running.
getURI() - Method in class javax.servlet.jsp.tagext.TagLibraryInfo
The value of the uri attribute from the taglib directive for this library.
getURI() - Method in interface javax.xml.soap.Name
Returns the URI of the namespace for the XML name that this Name object represents.
getURL() - Method in class javax.activation.URLDataSource
Return the URL used to create this DataSource.
getUrl() - Method in class javax.faces.component.UIGraphic
Return the image URL for this UIGraphic.
getURL() - Method in class javax.mail.URLName
Constructs a URL from the URLName.
getURL() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl
getURL() - Method in interface javax.xml.bind.ValidationEventLocator
Return the name of the XML source as a URL if available
getUrl() - Method in interface javax.xml.registry.infomodel.TelephoneNumber
Gets the URL that can dial this number electronically.
getUrl() - Method in interface javax.xml.registry.infomodel.User
Gets the URL to the web page for this User.
getURLName() - Method in class javax.mail.Folder
Return a URLName representing this folder.
getURLName() - Method in class javax.mail.Service
Return a URLName representing this service.
getUsageDescription() - Method in interface javax.xml.registry.infomodel.SpecificationLink
Gets the description of usage parameters.
getUsageParameters() - Method in interface javax.xml.registry.infomodel.SpecificationLink
Gets any usage parameters.
getUsemap() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the usemap property.
getUser() - Method in interface javax.xml.registry.infomodel.AuditableEvent
Gets the User associated with this object.
getUserFlags() - Method in class javax.mail.Flags
Return all the user flags in this Flags object.
getUserName() - Method in class javax.mail.PasswordAuthentication
getUsername() - Method in class javax.mail.URLName
Returns the user name of this URLName.
getUserName() - Method in interface javax.resource.cci.ConnectionMetaData
Returns the user name for an active connection as known to the underlying EIS instance.
getUserName() - Method in interface javax.resource.spi.ManagedConnectionMetaData
Returns name of the user associated with the ManagedConnection instance.
getUserName() - Method in class javax.resource.spi.security.PasswordCredential
Returns the user name.
getUserNamespaces(String) - Method in class javax.mail.Store
Return a set of folders representing the namespaces for user.
getUserPrincipal() - Method in class javax.faces.context.ExternalContext
Return the Principal object containing the name of the current authenticated user, if any; otherwise, return null.
getUserPrincipal() - Method in interface javax.servlet.http.HttpServletRequest
Returns a java.security.Principal object containing the name of the current authenticated user.
getUserPrincipal() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return getUserPrincipal() on the wrapped request object.
getUserPrincipal() - Method in interface javax.xml.rpc.server.ServletEndpointContext
Returns a java.security.Principal instance that contains the name of the authenticated user for the current method invocation on the endpoint instance.
getUserPrincipal() - Method in interface javax.xml.ws.WebServiceContext
Returns the Principal that identifies the sender of the request currently being serviced.
getUsers() - Method in interface javax.xml.registry.infomodel.Organization
Gets the Collection of Users affiliated with this Organization.
getUserTransaction() - Method in interface javax.ejb.EJBContext
Obtain the transaction demarcation interface.
getUserVersion() - Method in interface javax.xml.registry.infomodel.Versionable
Gets the user-specified revision number for this version of the Versionable object.
getUseTime() - Method in interface javax.management.j2ee.statistics.JCAConnectionStats
Returns the time spent using a connection
getUseTime() - Method in interface javax.management.j2ee.statistics.JDBCConnectionStats
Time spent using a connection.
getValidateURI() - Method in interface javax.xml.registry.infomodel.URIValidator
Gets whether to do URI validation for this object.
getValidator() - Method in interface javax.faces.component.EditableValueHolder
Deprecated. EditableValueHolder.getValidators() should be used instead.
getValidator() - Method in class javax.faces.component.UIInput
Deprecated. UIInput.getValidators() should be used instead.
getValidatorIds() - Method in class javax.faces.application.Application
Return an Iterator over the set of currently registered validator ids for this Application.
getValidatorMessage() - Method in class javax.faces.component.UIInput
If there has been a call to UIInput.setRequiredMessage(java.lang.String) on this instance, return the message.
getValidators() - Method in interface javax.faces.component.EditableValueHolder
Return the set of registered Validators for this component instance.
getValidators() - Method in class javax.faces.component.UIInput
Return the set of registered Validators for this UIInput instance.
getValidSentAddresses() - Method in class javax.mail.event.TransportEvent
Return the addresses to which this message was sent succesfully.
getValidSentAddresses() - Method in exception javax.mail.SendFailedException
Return the addresses to which this message was sent succesfully.
getValidUnsentAddresses() - Method in class javax.mail.event.TransportEvent
Return the addresses that are valid but to which this message was not sent.
getValidUnsentAddresses() - Method in exception javax.mail.SendFailedException
Return the addresses that are valid but to which this message was not sent.
getValue(ELContext, Object, Object) - Method in class javax.el.ArrayELResolver
If the base object is a Java language array, returns the value at the given index.
getValue(ELContext, Object, Object) - Method in class javax.el.BeanELResolver
If the base object is not null, returns the current value of the given property on this bean.
getValue(ELContext, Object, Object) - Method in class javax.el.CompositeELResolver
Attempts to resolve the given property object on the given base object by querying all component resolvers.
getValue(ELContext, Object, Object) - Method in class javax.el.ELResolver
Attempts to resolve the given property object on the given base object.
getValue(ELContext, Object, Object) - Method in class javax.el.ListELResolver
If the base object is a list, returns the value at the given index.
getValue(ELContext, Object, Object) - Method in class javax.el.MapELResolver
If the base object is a map, returns the value associated with the given key, as specified by the property argument.
getValue(ELContext, Object, Object) - Method in class javax.el.ResourceBundleELResolver
If the base object is an instance of ResourceBundle, the provided property will first be coerced to a String.
getValue(ELContext) - Method in class javax.el.ValueExpression
Evaluates the expression relative to the provided context, and returns the resulting value.
getValue() - Method in class javax.enterprise.deploy.shared.ActionType
Returns this enumeration value's integer value.
getValue() - Method in class javax.enterprise.deploy.shared.CommandType
Returns this enumeration value's integer value.
getValue() - Method in class javax.enterprise.deploy.shared.DConfigBeanVersionType
Returns this enumeration value's integer value.
getValue() - Method in class javax.enterprise.deploy.shared.ModuleType
Returns this enumeration value's integer value.
getValue() - Method in class javax.enterprise.deploy.shared.StateType
Returns this enumeration value's integer value.
getValue() - Method in class javax.faces.component.UICommand
Returns the value property of the UICommand.
getValue() - Method in class javax.faces.component.UIData
Return the value of the UIData.
getValue() - Method in class javax.faces.component.UIGraphic
Returns the value property of the UIGraphic.
getValue() - Method in class javax.faces.component.UIOutput
getValue() - Method in class javax.faces.component.UIParameter
Returns the value property of the UIParameter.
getValue() - Method in class javax.faces.component.UISelectItem
Returns the value property of the UISelectItem.
getValue() - Method in class javax.faces.component.UISelectItems
Returns the value property of the UISelectItems.
getValue() - Method in interface javax.faces.component.ValueHolder
Gets the value of this UIComponent.
getValue(Object, Object) - Method in class javax.faces.el.PropertyResolver
Deprecated. Return the value of the specified property from the specified base object.
getValue(Object, int) - Method in class javax.faces.el.PropertyResolver
Deprecated. Return the value at the specified index of the specified base object.
getValue(FacesContext) - Method in class javax.faces.el.ValueBinding
Deprecated. Return the value of the property represented by this ValueBinding, relative to the specified FacesContext.
getValue() - Method in class javax.faces.model.SelectItem
Return the value of this item, to be delivered to the model if this item is selected by the user.
getValue() - Method in class javax.mail.Header
Returns the value of this header.
getValue() - Method in class javax.mail.internet.HeaderTokenizer.Token
Returns the value of the token just read.
getValue() - Method in class javax.mail.internet.InternetHeaders.InternetHeader
Return the "value" part of the header line.
getValue() - Method in class javax.servlet.http.Cookie
Returns the value of the cookie.
getValue(String) - Method in interface javax.servlet.http.HttpSession
Deprecated. As of Version 2.2, this method is replaced by HttpSession.getAttribute(java.lang.String).
getValue() - Method in class javax.servlet.http.HttpSessionBindingEvent
Returns the value of the attribute that has been added, removed or replaced.
getValue(ELContext, Object, Object) - Method in class javax.servlet.jsp.el.ImplicitObjectELResolver
If the base object is null, and the property matches the name of a JSP implicit object, returns the implicit object.
getValue(ELContext, Object, Object) - Method in class javax.servlet.jsp.el.ScopedAttributeELResolver
If the base object is null, searches the page, request, session and application scopes for an attribute with the given name and returns it, or null if no attribute exists with the current name.
getValue(String) - Method in class javax.servlet.jsp.tagext.TagSupport
Get a the value associated with a key.
getValue() - Method in class javax.servlet.ServletContextAttributeEvent
Returns the value of the attribute that has been added, removed, or replaced.
getValue() - Method in class javax.servlet.ServletRequestAttributeEvent
Returns the value of the attribute that has been added, removed or replaced.
getValue() - Method in class javax.xml.bind.JAXBElement
Return the content model and attribute values for this element.
getValue(Object) - Static method in class javax.xml.bind.JAXBIntrospector
Get the element value of a JAXB element.
getValue() - Method in interface javax.xml.registry.infomodel.Classification
Gets the taxonomy value for this Classification.
getValue() - Method in interface javax.xml.registry.infomodel.Concept
Gets the value (usually a code in a taxonomy) associated with this Concept.
getValue() - Method in interface javax.xml.registry.infomodel.ExternalIdentifier
Gets the value of an ExternalIdentifier.
getValue() - Method in interface javax.xml.registry.infomodel.InternationalString
Gets the String value for the Locale returned by Locale.getDefault().
getValue(Locale) - Method in interface javax.xml.registry.infomodel.InternationalString
Gets the String value for the specified Locale.
getValue() - Method in interface javax.xml.registry.infomodel.LocalizedString
Get the String value for this object.
getValue() - Method in class javax.xml.soap.MimeHeader
Returns the value of this MimeHeader object.
getValue() - Method in interface javax.xml.soap.Node
Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise.
getValue() - Method in interface javax.xml.stream.events.Attribute
Gets the normalized value of this attribute
getValueBinding(String) - Method in class javax.faces.component.UIComponent
Deprecated. This has been replaced by UIComponent.getValueExpression(java.lang.String).
getValueBinding(String) - Method in class javax.faces.component.UIComponentBase
Deprecated. This has been replaced by UIComponentBase.getValueExpression(java.lang.String).
getValueBinding(String) - Method in class javax.faces.component.UIGraphic
Deprecated. This has been replaced by UIGraphic.getValueExpression(java.lang.String).
getValueBinding(String) - Method in class javax.faces.component.UISelectBoolean
Deprecated. This has been replaced by UISelectBoolean.getValueExpression(java.lang.String).
getValueBinding(String) - Method in class javax.faces.component.UISelectMany
Deprecated. this has been replaced by UISelectMany.getValueExpression(java.lang.String).
getValueChangeListener() - Method in interface javax.faces.component.EditableValueHolder
Deprecated. Use EditableValueHolder.getValueChangeListeners() instead.
getValueChangeListener() - Method in class javax.faces.component.UIInput
getValueChangeListeners() - Method in interface javax.faces.component.EditableValueHolder
Return the set of registered ValueChangeListeners for this component instance.
getValueChangeListeners() - Method in class javax.faces.component.UIInput
Return the set of registered ValueChangeListeners for this UIInput instance.
getValueExpression(String) - Method in class javax.faces.component.UIComponent
Return the ValueExpression used to calculate the value for the specified attribute or property name, if any.
getValueExpression(String) - Method in class javax.faces.component.UIComponentBase

Return the ValueExpression used to calculate the value for the specified attribute or property name, if any.

getValueExpression(String) - Method in class javax.faces.component.UIGraphic
Return any ValueExpression set for value if a ValueExpression for url is requested; otherwise, perform the default superclass processing for this method.
getValueExpression(String) - Method in class javax.faces.component.UISelectBoolean
Return any ValueExpression set for value if a ValueExpression for selected is requested; otherwise, perform the default superclass processing for this method.
getValueExpression(String) - Method in class javax.faces.component.UISelectMany
Return any ValueExpression set for value if a ValueExpression for selectedValues is requested; otherwise, perform the default superclass processing for this method.
getValueNames() - Method in interface javax.servlet.http.HttpSession
Deprecated. As of Version 2.2, this method is replaced by HttpSession.getAttributeNames()
getValues() - Method in class javax.servlet.jsp.tagext.TagSupport
Enumerate the keys for the values kept by this tag handler.
getValues() - Method in interface javax.xml.registry.infomodel.Slot
Gets the values for this Slot.
getValueType() - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Gets the value type for this object.
getVar() - Method in class javax.faces.component.UIData
Return the request-scope attribute under which the data object for the current row will be exposed when iterating.
getVariableInfo(TagData) - Method in class javax.servlet.jsp.tagext.TagExtraInfo
information on scripting variables defined by the tag associated with this TagExtraInfo instance.
getVariableInfo(TagData) - Method in class javax.servlet.jsp.tagext.TagInfo
Information on the scripting objects created by this tag at runtime.
getVariableMapper() - Method in class javax.el.ELContext
Retrieves the VariableMapper associated with this ELContext.
getVariableResolver() - Method in class javax.faces.application.Application
Deprecated. This has been replaced by Application.getELResolver().
getVariableResolver() - Method in class javax.servlet.jsp.JspContext
Deprecated. As of JSP 2.1, replaced by ELContext.getELResolver(), which can be obtained by jspContext.getELContext().getELResolver().
getVarName() - Method in class javax.servlet.jsp.tagext.VariableInfo
Returns the name of the scripting variable.
getVendor() - Method in class javax.mail.Provider
Returns name of vendor associated with this implementation or null
getVersion() - Method in class javax.mail.Provider
Returns version of this implementation or null if no version
getVersion() - Method in class javax.servlet.http.Cookie
Returns the version of the protocol this cookie complies with.
getVersion() - Method in interface javax.xml.registry.CapabilityProfile
Gets the JAXR specification version supported by the JAXR provider.
getVersion() - Method in interface javax.xml.stream.events.StartDocument
Returns the version of XML of this XML stream
getVersion() - Method in class javax.xml.stream.util.StreamReaderDelegate
getVersion() - Method in interface javax.xml.stream.XMLStreamReader
Get the xml version declared on the xml declaration Returns null if none was declared
getViewHandler() - Method in class javax.faces.application.Application
Return the ViewHandler instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
getViewId() - Method in exception javax.faces.application.ViewExpiredException
Return the view identifier of this exception, or null if the view identifier is nonexistent or unknown.
getViewId() - Method in class javax.faces.component.UIViewRoot
Return the view identifier for this view.
getViewRoot() - Method in class javax.faces.context.FacesContext
Return the root component that is associated with the this request.
getVisibleNamespacePrefixes() - Method in interface javax.xml.soap.SOAPElement
Returns an Iterator over the namespace prefix Strings visible to this element.
getWaitingThreadCount() - Method in interface javax.management.j2ee.statistics.JCAConnectionPoolStats
The number of threads waiting for a connection
getWaitingThreadCount() - Method in interface javax.management.j2ee.statistics.JDBCConnectionPoolStats
Number of threads waiting for a connection.
getWaitTime() - Method in interface javax.management.j2ee.statistics.JCAConnectionStats
Returns the time spent waiting for a connection to be available
getWaitTime() - Method in interface javax.management.j2ee.statistics.JDBCConnectionStats
Time spent waiting for a connection to be available.
getWarnClass() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the warnClass property.
getWarnClass() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the warnClass property.
getWarnings() - Method in interface javax.resource.cci.Interaction
Gets the first ResourceWarning from the chain of warnings associated with this Interaction instance.
getWarnStyle() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the warnStyle property.
getWarnStyle() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the warnStyle property.
getWebURL() - Method in interface javax.enterprise.deploy.spi.TargetModuleID
If this TargetModulID represents a web module retrieve the URL for it.
getWidth() - Method in class javax.faces.component.html.HtmlDataTable
Return the value of the width property.
getWidth() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the width property.
getWidth() - Method in class javax.faces.component.html.HtmlPanelGrid
Return the value of the width property.
getWork() - Method in class javax.resource.spi.work.WorkEvent
Return the Work instance which is the cause of the event.
getWorkManager() - Method in interface javax.resource.spi.BootstrapContext
Provides a handle to a WorkManager instance.
getWrapped() - Method in class javax.faces.application.StateManagerWrapper
getWrapped() - Method in class javax.faces.application.ViewHandlerWrapper
getWrapped() - Method in class javax.faces.context.ResponseWriterWrapper
getWrappedData() - Method in class javax.faces.model.ArrayDataModel
getWrappedData() - Method in class javax.faces.model.DataModel
Return the object representing the data wrapped by this DataModel, if any.
getWrappedData() - Method in class javax.faces.model.ListDataModel
getWrappedData() - Method in class javax.faces.model.ResultDataModel
getWrappedData() - Method in class javax.faces.model.ResultSetDataModel
getWrappedData() - Method in class javax.faces.model.ScalarDataModel
getWriteMethod() - Method in class javax.el.BeanELResolver.BeanProperty
getWriter() - Method in interface javax.servlet.ServletResponse
Returns a PrintWriter object that can send character text to the client.
getWriter() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return getWriter() on the wrapped response object.
getWSDLDocumentLocation() - Method in interface javax.xml.rpc.Service
Gets the location of the WSDL document for this Service.
getWSDLDocumentLocation() - Method in class javax.xml.ws.Service
Gets the location of the WSDL document for this Service.
getWSDLDocumentLocation() - Method in class javax.xml.ws.spi.ServiceDelegate
Gets the location of the WSDL document for this Service.
getXAResource() - Method in interface javax.jms.XASession
Returns an XA resource to the caller.
getXAResource() - Method in interface javax.resource.spi.ManagedConnection
Returns an javax.transaction.xa.XAresource instance.
getXAResources(ActivationSpec[]) - Method in interface javax.resource.spi.ResourceAdapter
This method is called by the application server during crash recovery.
getXATerminator() - Method in interface javax.resource.spi.BootstrapContext
Provides a handle to a XATerminator instance.
getXid() - Method in class javax.resource.spi.work.ExecutionContext
getXMLNode(Object) - Method in class javax.xml.bind.Binder
Gets the XML element associated with the given JAXB object.
getXMLReader() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
Obtains a configured XMLReader.
getXMLReporter() - Method in class javax.xml.stream.XMLInputFactory
The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
getXMLResolver() - Method in class javax.xml.stream.XMLInputFactory
The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
getXpath() - Method in interface javax.enterprise.deploy.model.DDBean
Returns the original xpath string provided by the DConfigBean.
getXpath() - Method in interface javax.enterprise.deploy.model.DDBeanRoot
Return the XPath for this standard bean.
getXpaths() - Method in interface javax.enterprise.deploy.spi.DConfigBean
Return a list of XPaths designating the deployment descriptor information this DConfigBean requires.
GT - Static variable in class javax.mail.search.ComparisonTerm

H

Handle - Interface in javax.ejb
The Handle interface is implemented by all EJB object handles.
HandleDelegate - Interface in javax.ejb.spi
The HandleDelegate interface is implemented by the EJB container.
handleEvent(ValidationEvent) - Method in class javax.xml.bind.helpers.DefaultValidationEventHandler
handleEvent(ValidationEvent) - Method in class javax.xml.bind.util.ValidationEventCollector
handleEvent(ValidationEvent) - Method in interface javax.xml.bind.ValidationEventHandler
Receive notification of a validation warning or error.
handleFault(MessageContext) - Method in class javax.xml.rpc.handler.GenericHandler
The handleFault method processes the SOAP faults based on the SOAP message processing model.
handleFault(MessageContext) - Method in interface javax.xml.rpc.handler.Handler
The handleFault method processes the SOAP faults based on the SOAP message processing model.
handleFault(MessageContext) - Method in interface javax.xml.rpc.handler.HandlerChain
The handleFault method initiates the SOAP fault processing for this handler chain.
handleFault(C) - Method in interface javax.xml.ws.handler.Handler
The handleFault method is invoked for fault message processing.
handleMessage(C) - Method in interface javax.xml.ws.handler.Handler
The handleMessage method is invoked for normal processing of inbound and outbound messages.
handleNavigation(FacesContext, String, String) - Method in class javax.faces.application.NavigationHandler
Perform navigation processing based on the state information in the specified FacesContext, plus the outcome string returned by an executed application action.
handlePageException(Exception) - Method in class javax.servlet.jsp.PageContext
This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.
handlePageException(Throwable) - Method in class javax.servlet.jsp.PageContext
This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.
handleProgressEvent(ProgressEvent) - Method in interface javax.enterprise.deploy.spi.status.ProgressListener
Invoked when a deployment progress event occurs.
Handler - Interface in javax.xml.rpc.handler
The javax.xml.rpc.handler.Handler interface is required to be implemented by a SOAP message handler.
Handler<C extends MessageContext> - Interface in javax.xml.ws.handler
The Handler interface is the base interface for JAX-WS handlers.
HandlerChain - Annotation Type in javax.jws
Associates the Web Service with an externally defined handler chain.
HandlerChain - Interface in javax.xml.rpc.handler
The javax.xml.rpc.handler.HandlerChain represents a list of handlers.
handleRequest(MessageContext) - Method in class javax.xml.rpc.handler.GenericHandler
The handleRequest method processes the request SOAP message.
handleRequest(MessageContext) - Method in interface javax.xml.rpc.handler.Handler
The handleRequest method processes the request message.
handleRequest(MessageContext) - Method in interface javax.xml.rpc.handler.HandlerChain
The handleRequest method initiates the request processing for this handler chain.
handleResponse(MessageContext) - Method in class javax.xml.rpc.handler.GenericHandler
The handleResponse method processes the response message.
handleResponse(MessageContext) - Method in interface javax.xml.rpc.handler.Handler
The handleResponse method processes the response SOAP message.
handleResponse(MessageContext) - Method in interface javax.xml.rpc.handler.HandlerChain
The handleResponse method initiates the response processing for this handler chain.
handleResponse(Response<T>) - Method in interface javax.xml.ws.AsyncHandler
Called when the response to an asynchronous operation is available.
HandlerInfo - Class in javax.xml.rpc.handler
The javax.xml.rpc.handler.HandlerInfo represents information about a handler in the HandlerChain.
HandlerInfo() - Constructor for class javax.xml.rpc.handler.HandlerInfo
Default constructor
HandlerInfo(Class, Map, QName[]) - Constructor for class javax.xml.rpc.handler.HandlerInfo
Constructor for HandlerInfo
HandlerRegistry - Interface in javax.xml.rpc.handler
The javax.xml.rpc.handler.HandlerRegistry provides support for the programmatic configuration of handlers in a HandlerRegistry.
HandlerResolver - Interface in javax.xml.ws.handler
HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.
handlesURI(String) - Method in interface javax.enterprise.deploy.spi.factories.DeploymentFactory
Tests whether this factory can create a DeploymentManager object based on the specificed URI.
hasBinding() - Method in class javax.faces.webapp.UIComponentClassicTagBase
Return true if this component has a non-null binding attribute.
hasBinding() - Method in class javax.faces.webapp.UIComponentELTag
hasBinding() - Method in class javax.faces.webapp.UIComponentTag
Deprecated.
hasDetail() - Method in interface javax.xml.soap.SOAPFault
Returns true if this SOAPFault has a Detail subelement and false otherwise.
hasDynamicAttributes() - Method in class javax.servlet.jsp.tagext.TagInfo
Get dynamicAttributes associated with this TagInfo.
hasEvents() - Method in class javax.xml.bind.util.ValidationEventCollector
Returns true if this event collector contains at least one ValidationEvent.
hasFault() - Method in interface javax.xml.soap.SOAPBody
Indicates whether a SOAPFault object exists in this SOAPBody object.
hashCode() - Method in class javax.el.Expression
Returns the hash code for this Expression.
hashCode() - Method in class javax.faces.validator.DoubleRangeValidator
hashCode() - Method in class javax.faces.validator.LengthValidator
hashCode() - Method in class javax.faces.validator.LongRangeValidator
hashCode() - Method in class javax.mail.Flags
Compute a hash code for this Flags object.
hashCode() - Method in class javax.mail.internet.InternetAddress
Compute a hash code for the address.
hashCode() - Method in class javax.mail.internet.NewsAddress
Compute a hash code for the address.
hashCode() - Method in class javax.mail.search.AddressTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.AndTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.ComparisonTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.DateTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.FlagTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.HeaderTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.IntegerComparisonTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.NotTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.OrTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.RecipientStringTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.RecipientTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.search.StringTerm
Compute a hashCode for this object.
hashCode() - Method in class javax.mail.URLName
Compute the hash code for this URLName.
hashCode() - Method in interface javax.resource.cci.Record
Returns the hash code for the Record instance.
hashCode() - Method in interface javax.resource.spi.ConnectionRequestInfo
Returns the hashCode of the ConnectionRequestInfo.
hashCode() - Method in interface javax.resource.spi.ManagedConnectionFactory
Returns the hash code for the ManagedConnectionFactory
hashCode() - Method in interface javax.resource.spi.security.GenericCredential
Deprecated. Returns the hash code for this GenericCredential
hashCode() - Method in class javax.resource.spi.security.PasswordCredential
Returns the hash code for this PasswordCredential
hashCode() - Method in class javax.security.jacc.EJBMethodPermission
Returns the hash code value for this EJBMethodPermission.
hashCode() - Method in class javax.security.jacc.EJBRoleRefPermission
Returns the hash code value for this EJBRoleRefPermission.
hashCode() - Method in class javax.security.jacc.WebResourcePermission
Returns the hash code value for this WebResourcePermission.
hashCode() - Method in class javax.security.jacc.WebRoleRefPermission
Returns the hash code value for this WebRoleRefPermission.
hashCode() - Method in class javax.security.jacc.WebUserDataPermission
Returns the hash code value for this WebUserDataPermission.
hasName() - Method in class javax.xml.stream.util.StreamReaderDelegate
hasName() - Method in interface javax.xml.stream.XMLStreamReader
returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise
hasNewMessages() - Method in class javax.mail.Folder
Returns true if this Folder has new messages since the last time this indication was reset.
hasNext() - Method in class javax.xml.stream.util.EventReaderDelegate
hasNext() - Method in class javax.xml.stream.util.StreamReaderDelegate
hasNext() - Method in interface javax.xml.stream.XMLEventReader
Check if there are more events.
hasNext() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if there are more parsing events and false if there are no more events.
hasText() - Method in class javax.xml.stream.util.StreamReaderDelegate
hasText() - Method in interface javax.xml.stream.XMLStreamReader
Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE
Header - Class in javax.mail
The Header class stores a name/value pair to represent headers.
Header(String, String) - Constructor for class javax.mail.Header
Construct a Header object.
headerName - Variable in class javax.mail.search.HeaderTerm
The name of the header.
headers - Variable in class javax.mail.internet.InternetHeaders
The actual list of Headers, including placeholder entries.
headers - Variable in class javax.mail.internet.MimeBodyPart
The InternetHeaders object that stores all the headers of this body part.
headers - Variable in class javax.mail.internet.MimeMessage
The InternetHeaders object that stores the header of this message.
HeaderTerm - Class in javax.mail.search
This class implements comparisons for Message headers.
HeaderTerm(String, String) - Constructor for class javax.mail.search.HeaderTerm
Constructor.
HeaderTokenizer - Class in javax.mail.internet
This class tokenizes RFC822 and MIME headers into the basic symbols specified by RFC822 and MIME.
HeaderTokenizer(String, String, boolean) - Constructor for class javax.mail.internet.HeaderTokenizer
Constructor that takes a rfc822 style header.
HeaderTokenizer(String, String) - Constructor for class javax.mail.internet.HeaderTokenizer
Constructor.
HeaderTokenizer(String) - Constructor for class javax.mail.internet.HeaderTokenizer
Constructor.
HeaderTokenizer.Token - Class in javax.mail.internet
The Token class represents tokens returned by the HeaderTokenizer.
HeaderTokenizer.Token(int, String) - Constructor for class javax.mail.internet.HeaderTokenizer.Token
Constructor.
HeuristicCommitException - Exception in javax.transaction
This exception is thrown by the rollback operation on a resource to report that a heuristic decision was made and that all relevant updates have been committed.
HeuristicCommitException() - Constructor for exception javax.transaction.HeuristicCommitException
HeuristicCommitException(String) - Constructor for exception javax.transaction.HeuristicCommitException
HeuristicMixedException - Exception in javax.transaction
This exception is thrown to report that a heuristic decision was made and that some relevant updates have been committed and others have been rolled back.
HeuristicMixedException() - Constructor for exception javax.transaction.HeuristicMixedException
HeuristicMixedException(String) - Constructor for exception javax.transaction.HeuristicMixedException
HeuristicRollbackException - Exception in javax.transaction
This exception is thrown by the commit operation to report that a heuristic decision was made and that all relevant updates have been rolled back.
HeuristicRollbackException() - Constructor for exception javax.transaction.HeuristicRollbackException
HeuristicRollbackException(String) - Constructor for exception javax.transaction.HeuristicRollbackException
HexBinaryAdapter - Class in javax.xml.bind.annotation.adapters
XmlAdapter for xs:hexBinary.
HexBinaryAdapter() - Constructor for class javax.xml.bind.annotation.adapters.HexBinaryAdapter
Holder - Interface in javax.xml.rpc.holders
The java.xml.rpc.holders.Holder interface represents the base interface for both standard and generated Holder classes.
Holder<T> - Class in javax.xml.ws
Holds a value of type T.
Holder() - Constructor for class javax.xml.ws.Holder
Creates a new holder with a null value.
Holder(T) - Constructor for class javax.xml.ws.Holder
Create a new holder with the specified value.
HOLDS_FOLDERS - Static variable in class javax.mail.Folder
This folder can contain other folders
HOLDS_MESSAGES - Static variable in class javax.mail.Folder
This folder can contain messages
HomeHandle - Interface in javax.ejb
The HomeHandle interface is implemented by all home object handles.
host - Variable in class javax.mail.internet.NewsAddress
HTML_BASIC_RENDER_KIT - Static variable in class javax.faces.render.RenderKitFactory
The render kit identifier of the default RenderKit instance for this JavaServer Faces implementation.
HtmlColumn - Class in javax.faces.component.html
Represents a column that will be rendered in an HTML table element.
HtmlColumn() - Constructor for class javax.faces.component.html.HtmlColumn
HtmlCommandButton - Class in javax.faces.component.html
Represents an HTML input element for a button of type submit or reset.
HtmlCommandButton() - Constructor for class javax.faces.component.html.HtmlCommandButton
HtmlCommandLink - Class in javax.faces.component.html
Represents an HTML a element for a hyperlink that acts like a submit button.
HtmlCommandLink() - Constructor for class javax.faces.component.html.HtmlCommandLink
HtmlDataTable - Class in javax.faces.component.html
Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
HtmlDataTable() - Constructor for class javax.faces.component.html.HtmlDataTable
HtmlForm - Class in javax.faces.component.html
Represents an HTML form element.
HtmlForm() - Constructor for class javax.faces.component.html.HtmlForm
HtmlGraphicImage - Class in javax.faces.component.html
Represents an HTML img element, used to retrieve and render a graphical image.
HtmlGraphicImage() - Constructor for class javax.faces.component.html.HtmlGraphicImage
HtmlInputHidden - Class in javax.faces.component.html
Represents an HTML input element of type hidden.
HtmlInputHidden() - Constructor for class javax.faces.component.html.HtmlInputHidden
HtmlInputSecret - Class in javax.faces.component.html
Represents an HTML input element of type password.
HtmlInputSecret() - Constructor for class javax.faces.component.html.HtmlInputSecret
HtmlInputText - Class in javax.faces.component.html
Represents an HTML input element of type text.
HtmlInputText() - Constructor for class javax.faces.component.html.HtmlInputText
HtmlInputTextarea - Class in javax.faces.component.html
Represents an HTML textarea element.
HtmlInputTextarea() - Constructor for class javax.faces.component.html.HtmlInputTextarea
HtmlMessage - Class in javax.faces.component.html
By default, the rendererType property must be set to "javax.faces.Message".
HtmlMessage() - Constructor for class javax.faces.component.html.HtmlMessage
HtmlMessages - Class in javax.faces.component.html
By default, the rendererType property must be set to "javax.faces.Messages".
HtmlMessages() - Constructor for class javax.faces.component.html.HtmlMessages
HtmlOutputFormat - Class in javax.faces.component.html
Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.
HtmlOutputFormat() - Constructor for class javax.faces.component.html.HtmlOutputFormat
HtmlOutputLabel - Class in javax.faces.component.html
Represents an HTML label element, used to define an accessible label for a corresponding input element.
HtmlOutputLabel() - Constructor for class javax.faces.component.html.HtmlOutputLabel
HtmlOutputLink - Class in javax.faces.component.html
Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
HtmlOutputLink() - Constructor for class javax.faces.component.html.HtmlOutputLink
HtmlOutputText - Class in javax.faces.component.html
Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.
HtmlOutputText() - Constructor for class javax.faces.component.html.HtmlOutputText
HtmlPanelGrid - Class in javax.faces.component.html
Renders child components in a table, starting a new row after the specified number of columns.
HtmlPanelGrid() - Constructor for class javax.faces.component.html.HtmlPanelGrid
HtmlPanelGroup - Class in javax.faces.component.html
Causes all child components of this component to be rendered.
HtmlPanelGroup() - Constructor for class javax.faces.component.html.HtmlPanelGroup
HtmlSelectBooleanCheckbox - Class in javax.faces.component.html
Represents an HTML input element of type checkbox.
HtmlSelectBooleanCheckbox() - Constructor for class javax.faces.component.html.HtmlSelectBooleanCheckbox
HtmlSelectManyCheckbox - Class in javax.faces.component.html
Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
HtmlSelectManyCheckbox() - Constructor for class javax.faces.component.html.HtmlSelectManyCheckbox
HtmlSelectManyListbox - Class in javax.faces.component.html
Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
HtmlSelectManyListbox() - Constructor for class javax.faces.component.html.HtmlSelectManyListbox
HtmlSelectManyMenu - Class in javax.faces.component.html
Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
HtmlSelectManyMenu() - Constructor for class javax.faces.component.html.HtmlSelectManyMenu
HtmlSelectOneListbox - Class in javax.faces.component.html
Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
HtmlSelectOneListbox() - Constructor for class javax.faces.component.html.HtmlSelectOneListbox
HtmlSelectOneMenu - Class in javax.faces.component.html
Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
HtmlSelectOneMenu() - Constructor for class javax.faces.component.html.HtmlSelectOneMenu
HtmlSelectOneRadio - Class in javax.faces.component.html
Represents a single-selection component that is rendered as a set of HTML input elements of type radio.
HtmlSelectOneRadio() - Constructor for class javax.faces.component.html.HtmlSelectOneRadio
HTTP_BINDING - Static variable in interface javax.xml.ws.http.HTTPBinding
A constant representing the identity of the XML/HTTP binding.
HTTP_REQUEST_HEADERS - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: HTTP request headers.
HTTP_REQUEST_METHOD - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: HTTP request method.
HTTP_RESPONSE_CODE - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: HTTP response status code.
HTTP_RESPONSE_HEADERS - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: HTTP response headers.
HTTPBinding - Interface in javax.xml.ws.http
The HTTPBinding interface is an abstraction for the XML/HTTP binding.
HTTPException - Exception in javax.xml.ws.http
The HTTPException exception represents a XML/HTTP fault.
HTTPException(int) - Constructor for exception javax.xml.ws.http.HTTPException
Constructor for the HTTPException
HttpJspPage - Interface in javax.servlet.jsp
The HttpJspPage interface describes the interaction that a JSP Page Implementation Class must satisfy when using the HTTP protocol.
HttpServlet - Class in javax.servlet.http
Provides an abstract class to be subclassed to create an HTTP servlet suitable for a Web site.
HttpServlet() - Constructor for class javax.servlet.http.HttpServlet
Does nothing, because this is an abstract class.
HttpServletRequest - Interface in javax.servlet.http
Extends the ServletRequest interface to provide request information for HTTP servlets.
HttpServletRequestWrapper - Class in javax.servlet.http
Provides a convenient implementation of the HttpServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.
HttpServletRequestWrapper(HttpServletRequest) - Constructor for class javax.servlet.http.HttpServletRequestWrapper
Constructs a request object wrapping the given request.
HttpServletResponse - Interface in javax.servlet.http
Extends the ServletResponse interface to provide HTTP-specific functionality in sending a response.
HttpServletResponseWrapper - Class in javax.servlet.http
Provides a convenient implementation of the HttpServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.
HttpServletResponseWrapper(HttpServletResponse) - Constructor for class javax.servlet.http.HttpServletResponseWrapper
Constructs a response adaptor wrapping the given response.
HttpSession - Interface in javax.servlet.http
Provides a way to identify a user across more than one page request or visit to a Web site and to store information about that user.
HttpSessionActivationListener - Interface in javax.servlet.http
Objects that are bound to a session may listen to container events notifying them that sessions will be passivated and that session will be activated.
HttpSessionAttributeListener - Interface in javax.servlet.http
This listener interface can be implemented in order to get notifications of changes to the attribute lists of sessions within this web application.
HttpSessionBindingEvent - Class in javax.servlet.http
Events of this type are either sent to an object that implements HttpSessionBindingListener when it is bound or unbound from a session, or to a HttpSessionAttributeListener that has been configured in the deployment descriptor when any attribute is bound, unbound or replaced in a session.
HttpSessionBindingEvent(HttpSession, String) - Constructor for class javax.servlet.http.HttpSessionBindingEvent
Constructs an event that notifies an object that it has been bound to or unbound from a session.
HttpSessionBindingEvent(HttpSession, String, Object) - Constructor for class javax.servlet.http.HttpSessionBindingEvent
Constructs an event that notifies an object that it has been bound to or unbound from a session.
HttpSessionBindingListener - Interface in javax.servlet.http
Causes an object to be notified when it is bound to or unbound from a session.
HttpSessionContext - Interface in javax.servlet.http
Deprecated. As of Java(tm) Servlet API 2.1 for security reasons, with no replacement. This interface will be removed in a future version of this API.
HttpSessionEvent - Class in javax.servlet.http
This is the class representing event notifications for changes to sessions within a web application.
HttpSessionEvent(HttpSession) - Constructor for class javax.servlet.http.HttpSessionEvent
Construct a session event from the given source.
HttpSessionListener - Interface in javax.servlet.http
Implementations of this interface are notified of changes to the list of active sessions in a web application.
HttpUtils - Class in javax.servlet.http
Deprecated. As of Java(tm) Servlet API 2.3. These methods were only useful with the default encoding and have been moved to the request interfaces.
HttpUtils() - Constructor for class javax.servlet.http.HttpUtils
Deprecated. Constructs an empty HttpUtils object.

I

Id - Annotation Type in javax.persistence
Specifies the primary key property or field of an entity.
id - Variable in class javax.resource.spi.ConnectionEvent
Type of the event
ID - Static variable in class javax.servlet.jsp.tagext.TagAttributeInfo
"id" is wired in to be ID.
id - Variable in class javax.servlet.jsp.tagext.TagSupport
The value of the id attribute of this tag; or null.
IdClass - Annotation Type in javax.persistence
Specifies a composite primary key class that is mapped to multiple fields or properties of the entity.
ignoreCase - Variable in class javax.mail.search.StringTerm
Ignore case when comparing?
IllegalStateException - Exception in javax.jms
This exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation.
IllegalStateException(String, String) - Constructor for exception javax.jms.IllegalStateException
Constructs an IllegalStateException with the specified reason and error code.
IllegalStateException(String) - Constructor for exception javax.jms.IllegalStateException
Constructs an IllegalStateException with the specified reason.
IllegalStateException - Exception in javax.resource.spi
An IllegalStateException is thrown from a method if the callee (resource adapter or application server for system contracts) is in an illegal or inappropriate state for the method invocation.
IllegalStateException() - Constructor for exception javax.resource.spi.IllegalStateException
Constructs a new instance with null as its detail message.
IllegalStateException(String) - Constructor for exception javax.resource.spi.IllegalStateException
Constructs a new instance with the specified detail message.
IllegalStateException(Throwable) - Constructor for exception javax.resource.spi.IllegalStateException
Constructs a new throwable with the specified cause.
IllegalStateException(String, Throwable) - Constructor for exception javax.resource.spi.IllegalStateException
Constructs a new throwable with the specified detail message and cause.
IllegalStateException(String, String) - Constructor for exception javax.resource.spi.IllegalStateException
Constructs a new throwable with the specified detail message and an error code.
IllegalWriteException - Exception in javax.mail
The exception thrown when a write is attempted on a read-only attribute of any Messaging object.
IllegalWriteException() - Constructor for exception javax.mail.IllegalWriteException
Constructs a IllegalWriteException with no detail message.
IllegalWriteException(String) - Constructor for exception javax.mail.IllegalWriteException
Constructs a IllegalWriteException with the specified detail message.
IMMEDIATE - Static variable in interface javax.resource.spi.work.WorkManager
A constant to indicate timeout duration.
ImplicitObjectELResolver - Class in javax.servlet.jsp.el
Defines variable resolution behavior for the EL implicit objects defined in the JSP specification.
ImplicitObjectELResolver() - Constructor for class javax.servlet.jsp.el.ImplicitObjectELResolver
implies(Permission) - Method in class javax.security.jacc.EJBMethodPermission
Determines if the argument Permission is "implied by" this EJBMethodPermission.
implies(Permission) - Method in class javax.security.jacc.EJBRoleRefPermission
Determines if the argument Permission is "implied by" this EJBRoleRefPermission.
implies(Permission) - Method in class javax.security.jacc.WebResourcePermission
Determines if the argument Permission is "implied by" this WebResourcePermission.
implies(Permission) - Method in class javax.security.jacc.WebRoleRefPermission
Determines if the argument Permission is "implied by" this WebRoleRefPermission.
implies(Permission) - Method in class javax.security.jacc.WebUserDataPermission
Determines if the argument Permission is "implied by" this WebUserDataPermission.
in - Variable in class javax.mail.util.SharedFileInputStream
The file containing the data.
IN - Static variable in class javax.xml.rpc.ParameterMode
IN mode for parameter passing
INBOUND_MESSAGE_ATTACHMENTS - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: Map of attachments to a message for the inbound message, key is the MIME Content-ID, value is a DataHandler.
include(String) - Method in class javax.servlet.jsp.PageContext
Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.
include(String, boolean) - Method in class javax.servlet.jsp.PageContext
Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.
include(ServletRequest, ServletResponse) - Method in interface javax.servlet.RequestDispatcher
Includes the content of a resource (servlet, JSP page, HTML file) in the response.
INDEFINITE - Static variable in interface javax.resource.spi.work.WorkManager
A constant to indicate timeout duration.
IndexedRecord - Interface in javax.resource.cci
IndexedRecord represents an ordered collection of record elements based on the java.util.List interface.
info - Variable in class javax.servlet.jsp.tagext.TagLibraryInfo
Information (documentation) for this TLD.
Inheritance - Annotation Type in javax.persistence
Defines the inheritance strategy to be used for an entity class hierarchy.
InheritanceType - Enum in javax.persistence
Defines inheritance strategy options.
Init - Annotation Type in javax.ejb
Designates a method of a session bean that corresponds to the create method of an adapted Home interface or an adapted Local Home interface.
init(ServletConfig) - Method in class javax.faces.webapp.FacesServlet
Acquire the factory instances we will require.
init(FilterConfig) - Method in interface javax.servlet.Filter
Called by the web container to indicate to a filter that it is being placed into service.
init(ServletConfig) - Method in class javax.servlet.GenericServlet
Called by the servlet container to indicate to a servlet that the servlet is being placed into service.
init() - Method in class javax.servlet.GenericServlet
A convenience method which can be overridden so that there's no need to call super.init(config).
init(ServletConfig) - Method in interface javax.servlet.Servlet
Called by the servlet container to indicate to a servlet that the servlet is being placed into service.
init(HandlerInfo) - Method in class javax.xml.rpc.handler.GenericHandler
The init method to enable the Handler instance to initialize itself.
init(HandlerInfo) - Method in interface javax.xml.rpc.handler.Handler
The init method enables the Handler instance to initialize itself.
init(Map) - Method in interface javax.xml.rpc.handler.HandlerChain
Initializes the configuration for a HandlerChain.
init(Object) - Method in interface javax.xml.rpc.server.ServiceLifecycle
Used for initialization of a service endpoint.
initCause(Throwable) - Method in exception javax.xml.registry.JAXRException
Initializes the cause of this throwable to the specified value.
initCause(Throwable) - Method in exception javax.xml.soap.SOAPException
Initializes the cause field of this SOAPException object with the given Throwable object.
initialize(Servlet, ServletRequest, ServletResponse, String, boolean, int, boolean) - Method in class javax.servlet.jsp.PageContext
The initialize method is called to initialize an uninitialized PageContext so that it may be used by a JSP Implementation class to service an incoming request and response within it's _jspService() method.
InitParam - Annotation Type in javax.jws.soap
Deprecated. As of JSR-181 2.0 with no replacement.
initView(FacesContext) - Method in class javax.faces.application.ViewHandler
Initialize the view for the request processing lifecycle.
initView(FacesContext) - Method in class javax.faces.application.ViewHandlerWrapper
The default behavior of this method is to call ViewHandler.initView(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
INLINE - Static variable in interface javax.mail.Part
This part should be presented inline.
INOUT - Static variable in class javax.xml.rpc.ParameterMode
INOUT mode for parameter passing
insertsAreDetected(int) - Method in interface javax.resource.cci.ResultSetInfo
Indicates whether or not a visible row insert can be detected by calling ResultSet.rowInserted.
inService() - Method in interface javax.security.jacc.PolicyConfiguration
This method is used to determine if the policy context whose interface is this PolicyConfiguration Object is in the "inService" state.
inService(String) - Method in class javax.security.jacc.PolicyConfigurationFactory
This method determines if the identified policy context exists with state "inService" in the Policy provider associated with the factory.
INTEGER_ID - Static variable in class javax.faces.convert.IntegerConverter
The message identifier of the FacesMessage to be created if the conversion to Integer fails.
IntegerComparisonTerm - Class in javax.mail.search
This class implements comparisons for integers.
IntegerComparisonTerm(int, int) - Constructor for class javax.mail.search.IntegerComparisonTerm
IntegerConverter - Class in javax.faces.convert
Converter implementation for java.lang.Integer (and int primitive) values.
IntegerConverter() - Constructor for class javax.faces.convert.IntegerConverter
IntegerWrapperHolder - Class in javax.xml.rpc.holders
IntegerWrapperHolder() - Constructor for class javax.xml.rpc.holders.IntegerWrapperHolder
IntegerWrapperHolder(Integer) - Constructor for class javax.xml.rpc.holders.IntegerWrapperHolder
Interaction - Interface in javax.resource.cci
The javax.resource.cci.Interaction enables a component to execute EIS functions.
InteractionSpec - Interface in javax.resource.cci
An InteractionSpec holds properties for driving an Interaction with an EIS instance.
Interceptors - Annotation Type in javax.interceptor
Declares an ordered list of interceptors for a class or method.
INTERNAL - Static variable in exception javax.resource.spi.work.WorkException
Indicates an internal error condition.
INTERNATIONAL_STRING - Static variable in interface javax.xml.registry.LifeCycleManager
InternationalString - Interface in javax.xml.registry.infomodel
This interface represents a String that has been internationalized into several Locales.
InternetAddress - Class in javax.mail.internet
This class represents an Internet email address using the syntax of RFC822.
InternetAddress() - Constructor for class javax.mail.internet.InternetAddress
Default constructor.
InternetAddress(String) - Constructor for class javax.mail.internet.InternetAddress
Constructor.
InternetAddress(String, boolean) - Constructor for class javax.mail.internet.InternetAddress
Parse the given string and create an InternetAddress.
InternetAddress(String, String) - Constructor for class javax.mail.internet.InternetAddress
Construct an InternetAddress given the address and personal name.
InternetAddress(String, String, String) - Constructor for class javax.mail.internet.InternetAddress
Construct an InternetAddress given the address and personal name.
InternetHeaders - Class in javax.mail.internet
InternetHeaders is a utility class that manages RFC822 style headers.
InternetHeaders() - Constructor for class javax.mail.internet.InternetHeaders
Create an empty InternetHeaders object.
InternetHeaders(InputStream) - Constructor for class javax.mail.internet.InternetHeaders
Read and parse the given RFC822 message stream till the blank line separating the header from the body.
InternetHeaders.InternetHeader - Class in javax.mail.internet
An individual internet header.
InternetHeaders.InternetHeader(String) - Constructor for class javax.mail.internet.InternetHeaders.InternetHeader
Constructor that takes a line and splits out the header name.
InternetHeaders.InternetHeader(String, String) - Constructor for class javax.mail.internet.InternetHeaders.InternetHeader
Constructor that takes a header name and value.
IntHolder - Class in javax.xml.rpc.holders
IntHolder() - Constructor for class javax.xml.rpc.holders.IntHolder
IntHolder(int) - Constructor for class javax.xml.rpc.holders.IntHolder
invalid - Variable in class javax.mail.event.TransportEvent
invalid - Variable in exception javax.mail.SendFailedException
INVALID_MESSAGE_ID - Static variable in class javax.faces.component.UISelectMany
The message identifier of the FacesMessage to be created if a value not matching the available options is specified.
INVALID_MESSAGE_ID - Static variable in class javax.faces.component.UISelectOne
The message identifier of the FacesMessage to be created if a value not matching the available options is specified.
invalidate() - Method in interface javax.servlet.http.HttpSession
Invalidates this session then unbinds any objects bound to it.
InvalidClientIDException - Exception in javax.jms
This exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider.
InvalidClientIDException(String, String) - Constructor for exception javax.jms.InvalidClientIDException
Constructs an InvalidClientIDException with the specified reason and error code.
InvalidClientIDException(String) - Constructor for exception javax.jms.InvalidClientIDException
Constructs an InvalidClientIDException with the specified reason.
InvalidDestinationException - Exception in javax.jms
This exception must be thrown when a destination either is not understood by a provider or is no longer valid.
InvalidDestinationException(String, String) - Constructor for exception javax.jms.InvalidDestinationException
Constructs an InvalidDestinationException with the specified reason and error code.
InvalidDestinationException(String) - Constructor for exception javax.jms.InvalidDestinationException
Constructs an InvalidDestinationException with the specified reason.
InvalidModuleException - Exception in javax.enterprise.deploy.spi.exceptions
This exception is to report an invalid J2EE deployment module type.
InvalidModuleException(String) - Constructor for exception javax.enterprise.deploy.spi.exceptions.InvalidModuleException
Creates an new InvalidModuleException object.
InvalidPropertyException - Exception in javax.resource.spi
This exception is thrown to indicate invalid configuration property settings.
InvalidPropertyException() - Constructor for exception javax.resource.spi.InvalidPropertyException
Create a InvalidPropertyException.
InvalidPropertyException(String) - Constructor for exception javax.resource.spi.InvalidPropertyException
Create a InvalidPropertyException.
InvalidPropertyException(Throwable) - Constructor for exception javax.resource.spi.InvalidPropertyException
Constructs a new throwable with the specified cause.
InvalidPropertyException(String, Throwable) - Constructor for exception javax.resource.spi.InvalidPropertyException
Constructs a new throwable with the specified detail message and cause.
InvalidPropertyException(String, String) - Constructor for exception javax.resource.spi.InvalidPropertyException
Constructs a new throwable with the specified detail message and an error code.
InvalidRequestException - Exception in javax.xml.registry
This exception is thrown when a JAXR client attempts to invoke an API method that is not valid for some reason.
InvalidRequestException() - Constructor for exception javax.xml.registry.InvalidRequestException
Constructs a JAXRException object with no reason or embedded Throwable.
InvalidRequestException(String) - Constructor for exception javax.xml.registry.InvalidRequestException
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
InvalidRequestException(String, Throwable) - Constructor for exception javax.xml.registry.InvalidRequestException
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
InvalidRequestException(Throwable) - Constructor for exception javax.xml.registry.InvalidRequestException
Constructs a JAXRException object initialized with the given Throwable object.
InvalidSelectorException - Exception in javax.jms
This exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax.
InvalidSelectorException(String, String) - Constructor for exception javax.jms.InvalidSelectorException
Constructs an InvalidSelectorException with the specified reason and error code.
InvalidSelectorException(String) - Constructor for exception javax.jms.InvalidSelectorException
Constructs an InvalidSelectorException with the specified reason.
InvalidTransactionException - Exception in javax.transaction
This exception indicates that the request carried an invalid transaction context.
InvalidTransactionException() - Constructor for exception javax.transaction.InvalidTransactionException
InvalidTransactionException(String) - Constructor for exception javax.transaction.InvalidTransactionException
InvocationContext - Interface in javax.interceptor
Context information passed to AroundInvoke and Interceptor-class lifecycle callback methods.
invoke(ELContext, Object[]) - Method in class javax.el.MethodExpression
If a String literal is specified as the expression, returns the String literal coerced to the expected return type of the method signature.
invoke(FacesContext, Object[]) - Method in class javax.faces.el.MethodBinding
Deprecated. Return the return value (if any) resulting from a call to the method identified by this method binding expression, passing it the specified parameters, relative to the specified FacesContext.
invoke(ObjectName, String, Object[], String[]) - Method in interface javax.management.j2ee.Management
Invokes an operation on a managed object.
invoke(Writer) - Method in class javax.servlet.jsp.tagext.JspFragment
Executes the fragment and directs all output to the given Writer, or the JspWriter returned by the getOut() method of the JspContext associated with the fragment if out is null.
invoke(Object[]) - Method in interface javax.xml.rpc.Call
Invokes a specific operation using a synchronous request-response interaction mode.
invoke(QName, Object[]) - Method in interface javax.xml.rpc.Call
Invokes a specific operation using a synchronous request-response interaction mode.
invoke(T) - Method in interface javax.xml.ws.Dispatch
Invoke a service operation synchronously.
invoke(T) - Method in interface javax.xml.ws.Provider
Invokes an operation occording to the contents of the request message.
INVOKE_APPLICATION - Static variable in class javax.faces.event.PhaseId
Identifier that indicates an interest in events queued for the Invoke Application phase of the request processing lifecycle.
invokeAsync(T) - Method in interface javax.xml.ws.Dispatch
Invoke a service operation asynchronously.
invokeAsync(T, AsyncHandler<T>) - Method in interface javax.xml.ws.Dispatch
Invoke a service operation asynchronously.
invokeContextCallback(FacesContext, UIComponent) - Method in interface javax.faces.component.ContextCallback
This method will be called by an implementation of UIComponent.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) and must be passed the component with the clientId given as an argument to invokeOnComponent.
invokeOnComponent(FacesContext, String, ContextCallback) - Method in class javax.faces.component.UIComponent
Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.
invokeOnComponent(FacesContext, String, ContextCallback) - Method in class javax.faces.component.UIComponentBase

Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.

invokeOnComponent(FacesContext, String, ContextCallback) - Method in class javax.faces.component.UIData
Override behavior from UIComponentBase.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) to provide special care for positioning the data properly before finding the component and invoking the callback on it.
invokeOneWay(Object[]) - Method in interface javax.xml.rpc.Call
Invokes a remote method using the one-way interaction mode.
invokeOneWay(T) - Method in interface javax.xml.ws.Dispatch
Invokes a service operation using the one-way interaction mode.
IS_COALESCING - Static variable in class javax.xml.stream.XMLInputFactory
The property that requires the parser to coalesce adjacent character data sections
IS_NAMESPACE_AWARE - Static variable in class javax.xml.stream.XMLInputFactory
The property used to turn on/off namespace support, this is to support XML 1.0 documents, only the true setting must be supported
IS_REPAIRING_NAMESPACES - Static variable in class javax.xml.stream.XMLOutputFactory
Property used to set prefix defaulting on the output side
IS_REPLACING_ENTITY_REFERENCES - Static variable in class javax.xml.stream.XMLInputFactory
Requires the parser to replace internal entity references with their replacement text and report them as characters
IS_SUPPORTING_EXTERNAL_ENTITIES - Static variable in class javax.xml.stream.XMLInputFactory
The property that requires the parser to resolve external parsed entities
IS_VALIDATING - Static variable in class javax.xml.stream.XMLInputFactory
The property used to turn on/off implementation specific validation
isActive() - Method in interface javax.persistence.EntityTransaction
Indicate whether a transaction is in progress.
isAddEvent() - Method in class javax.enterprise.deploy.model.XpathEvent
Is this an add event?
isAppropriateListener(FacesListener) - Method in class javax.faces.event.ActionEvent
isAppropriateListener(FacesListener) - Method in class javax.faces.event.FacesEvent
Return true if this FacesListener is an instance of a listener class that this event supports.
isAppropriateListener(FacesListener) - Method in class javax.faces.event.ValueChangeEvent
isAttribute() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is an Attribute.
isAttributeSpecified(int) - Method in class javax.xml.stream.util.StreamReaderDelegate
isAttributeSpecified(int) - Method in interface javax.xml.stream.XMLStreamReader
Returns a boolean which indicates if this attribute was created by default
isAutoFlush() - Method in class javax.servlet.jsp.JspWriter
This method indicates whether the JspWriter is autoFlushing.
isAvailable() - Method in exception javax.xml.registry.JAXRException
Returns true if a response is available, false otherwise.
isAvailable() - Method in interface javax.xml.registry.JAXRResponse
Returns true if a response is available, false otherwise.
isCallerInRole(Identity) - Method in interface javax.ejb.EJBContext
Deprecated. Use boolean isCallerInRole(String roleName) instead.
isCallerInRole(String) - Method in interface javax.ejb.EJBContext
Test if the caller has a given security role.
isCancelSupported() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
Tests whether the vendor supports a cancel opertation for deployment activities.
isCData() - Method in interface javax.xml.stream.events.Characters
Returns true if this is a CData section.
isChangeEvent() - Method in class javax.enterprise.deploy.model.XpathEvent
Is this a change event?
isCharacters() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is Characters.
isCharacters() - Method in class javax.xml.stream.util.StreamReaderDelegate
isCharacters() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if the cursor points to a character data event
isClosed() - Method in interface javax.xml.registry.Connection
Indicated whether this Connection has been closed or not.
isComment() - Method in interface javax.xml.soap.Text
Retrieves whether this Text object represents a comment.
isCommitted() - Method in interface javax.servlet.ServletResponse
Returns a boolean indicating if the response has been committed.
isCommitted() - Method in class javax.servlet.ServletResponseWrapper
The default behavior of this method is to return isCommitted() on the wrapped response object.
isComplete() - Method in class javax.mail.internet.MimeMultipart
Return true if the final boundary line for this multipart was seen.
isCompleted() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
A convience method to report if the operation is in the completed state.
isConfirmed() - Method in interface javax.xml.registry.infomodel.Association
Determines whether an Association has been confirmed completely.
isConfirmedBySourceOwner() - Method in interface javax.xml.registry.infomodel.Association
Determines whether an Association has been confirmed by the owner of the source object.
isConfirmedByTargetOwner() - Method in interface javax.xml.registry.infomodel.Association
Determines whether an Association has been confirmed by the owner of the target object.
isConnected() - Method in class javax.mail.Service
Is this service currently connected?
isDataFlavorSupported(DataFlavor) - Method in class javax.activation.DataHandler
Returns whether the specified data flavor is supported for this object.
isDConfigBeanVersionSupported(DConfigBeanVersionType) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Returns 'true' if the configuration beans support the J2EE platform version specified.
isDefaultNamespaceDeclaration() - Method in interface javax.xml.stream.events.Namespace
returns true if this attribute declares the default namespace
isDeferredMethod() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
Returns true if this attribute is to be passed a MethodExpression so that expression evaluation can be deferred.
isDeferredValue() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
Returns true if this attribute is to be passed a ValueExpression so that expression evaluation can be deferred.
isDeliveryTransacted(Method) - Method in interface javax.resource.spi.endpoint.MessageEndpointFactory
This is used to find out whether message deliveries to a target method on a message listener interface that is implemented by a message endpoint will be transacted or not.
isDisabled() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the disabled property.
isDisabled() - Method in class javax.faces.component.html.HtmlCommandLink
Return the value of the disabled property.
isDisabled() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the disabled property.
isDisabled() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the disabled property.
isDisabled() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the disabled property.
isDisabled() - Method in class javax.faces.component.html.HtmlOutputLink
Return the value of the disabled property.
isDisabled() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the disabled property.
isDisabled() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the disabled property.
isDisabled() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the disabled property.
isDisabled() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the disabled property.
isDisabled() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the disabled property.
isDisabled() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the disabled property.
isDisabled() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the disabled property.
isDisabled() - Method in class javax.faces.model.SelectItem
Return the disabled flag for this item, which should modify the rendered output to make this item unavailable for selection by the user if set to true.
isElement(Object) - Method in class javax.xml.bind.JAXBIntrospector
Return true iff object represents a JAXB element.
isEmpty() - Method in class javax.activation.MimeTypeParameterList
Determine whether or not this list is empty.
isEndDocument() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is an EndDocument.
isEndElement() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a EndElement.
isEndElement() - Method in class javax.xml.stream.util.StreamReaderDelegate
isEndElement() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if the cursor points to an end tag (otherwise false)
isEntityReference() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is an EntityReference.
isEscape() - Method in class javax.faces.component.html.HtmlOutputFormat
Return the value of the escape property.
isEscape() - Method in class javax.faces.component.html.HtmlOutputLabel
Return the value of the escape property.
isEscape() - Method in class javax.faces.component.html.HtmlOutputText
Return the value of the escape property.
isEscape() - Method in class javax.faces.model.SelectItem
Getter for property escape.
isExpunged() - Method in class javax.mail.Message
Checks whether this message is expunged.
isExternal() - Method in interface javax.xml.registry.infomodel.Classification
Returns true if this is an external classification.
isExternal() - Method in interface javax.xml.registry.infomodel.ClassificationScheme
Determines whether this ClassificationScheme is an external ClassificationScheme or an internal ClassificationScheme.
isExtramural() - Method in interface javax.xml.registry.infomodel.Association
Determines whether an Association is extramural or not.
isFailed() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
A convience method to report if the operation is in the failed state.
isFormattedOutput() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
Convenience method for getting the formatted output flag.
isFragment() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
Whether this attribute is of type JspFragment.
isFragment() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
Convenience method for getting the fragment flag.
isGlobalOnly() - Method in class javax.faces.component.UIMessages
Return the flag indicating whether only global messages (that is, messages with no associated client identifier) should be rendered.
isGlobalScope() - Method in class javax.xml.bind.JAXBElement
Returns true iff this xml element declaration is global.
isGroup() - Method in class javax.mail.internet.InternetAddress
Indicates whether this address is an RFC 822 group address.
isGroupingUsed() - Method in class javax.faces.convert.NumberConverter
Return true if getAsString should include grouping separators if necessary.
isIdentical(EJBLocalObject) - Method in interface javax.ejb.EJBLocalObject
Test if a given EJB local object is identical to the invoked EJB local object.
isIdentical(EJBObject) - Method in interface javax.ejb.EJBObject
Test if a given EJB object is identical to the invoked EJB object.
isIgnorableWhiteSpace() - Method in interface javax.xml.stream.events.Characters
Return true if this is ignorableWhiteSpace.
isImmediate() - Method in interface javax.faces.component.ActionSource
Return a flag indicating that the default ActionListener provided by the JavaServer Faces implementation should be executed immediately (that is, during Apply Request Values phase of the request processing lifecycle), rather than waiting until the Invoke Application phase.
isImmediate() - Method in interface javax.faces.component.EditableValueHolder
Return the "immediate" state for this component.
isImmediate() - Method in class javax.faces.component.UICommand
isImmediate() - Method in class javax.faces.component.UIInput
isIntegerOnly() - Method in class javax.faces.convert.NumberConverter
Return true if only the integer portion of the given value should be returned from getAsObject().
isIsmap() - Method in class javax.faces.component.html.HtmlGraphicImage
Return the value of the ismap property.
isItemDisabled() - Method in class javax.faces.component.UISelectItem
Return the disabled setting for this selection item.
isItemEscaped() - Method in class javax.faces.component.UISelectItem
Return the escape setting for the label of this selection item.
isLiteralText() - Method in class javax.el.Expression
Returns whether this expression was created from only literal text.
isLocaleSupported(Locale) - Method in interface javax.enterprise.deploy.spi.DeploymentManager
Reports if this implementation supports the designated locale.
isLocalValueSet() - Method in interface javax.faces.component.EditableValueHolder
Return the "local value set" state for this component.
isLocalValueSet() - Method in class javax.faces.component.UIInput
Return the "local value set" state for this component.
isMimeType(String) - Method in class javax.mail.internet.MimeBodyPart
Is this Part of the specified MIME type?
isMimeType(String) - Method in class javax.mail.internet.MimeMessage
Is this Part of the specified MIME type?
isMimeType(String) - Method in interface javax.mail.Part
Is this Part of the specified MIME type?
isMimeTypeEqual(String) - Method in class javax.activation.ActivationDataFlavor
Is the string representation of the MIME type passed in equivalent to the MIME type of this DataFlavor.
isMTOMEnabled() - Method in interface javax.xml.ws.soap.SOAPBinding
Returns true if the use of MTOM is enabled.
isNamespace() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a Namespace.
isNew() - Method in interface javax.servlet.http.HttpSession
Returns true if the client does not yet know about the session or if the client chooses not to join the session.
isNil() - Method in class javax.xml.bind.JAXBElement
Returns true iff this element instance content model is nil.
isOpaque() - Method in interface javax.xml.registry.infomodel.ExtrinsicObject
Determines whether the ExtrinsicObject is opaque (not readable) by the registry operator.
isOpen() - Method in class javax.mail.Folder
Indicates whether this Folder is in the 'open' state.
isOpen() - Method in interface javax.persistence.EntityManager
Determine whether the EntityManager is open.
isOpen() - Method in interface javax.persistence.EntityManagerFactory
Indicates whether or not this factory is open.
isParameterAndReturnSpecRequired(QName) - Method in interface javax.xml.rpc.Call
Indicates whether addParameter and setReturnType methods are to be invoked to specify the parameter and return type specification for a specific operation.
isPartialResponse() - Method in interface javax.xml.registry.BulkResponse
Determines whether the response is a partial response due to large result set.
isPermanent() - Method in exception javax.servlet.UnavailableException
Returns a boolean indicating whether the servlet is permanently unavailable.
isPostback(FacesContext) - Method in class javax.faces.render.ResponseStateManager
Return true if the current request is a postback.
isPrependId() - Method in class javax.faces.component.UIForm
isProcessingInstruction() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a ProcessingInstruction.
isPropertyResolved() - Method in class javax.el.ELContext
Returns whether an ELResolver has successfully resolved a given (base, property) pair.
isPropertySupported(String) - Method in class javax.xml.stream.XMLInputFactory
Query the set of properties that this factory supports.
isPropertySupported(String) - Method in class javax.xml.stream.XMLOutputFactory
Query the set of properties that this factory supports.
isPublished() - Method in class javax.xml.ws.Endpoint
Returns true if the endpoint is in the published state.
isReadOnly(ELContext, Object, Object) - Method in class javax.el.ArrayELResolver
If the base object is a Java language array, returns whether a call to ArrayELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
isReadOnly() - Method in class javax.el.BeanELResolver.BeanProperty
isReadOnly(ELContext, Object, Object) - Method in class javax.el.BeanELResolver
If the base object is not null, returns whether a call to BeanELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
isReadOnly(ELContext, Object, Object) - Method in class javax.el.CompositeELResolver
For a given base and property, attempts to determine whether a call to CompositeELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
isReadOnly(ELContext, Object, Object) - Method in class javax.el.ELResolver
For a given base and property, attempts to determine whether a call to ELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
isReadOnly(ELContext, Object, Object) - Method in class javax.el.ListELResolver
If the base object is a list, returns whether a call to ListELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
isReadOnly(ELContext, Object, Object) - Method in class javax.el.MapELResolver
If the base object is a map, returns whether a call to MapELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
isReadOnly(ELContext, Object, Object) - Method in class javax.el.ResourceBundleELResolver
If the base object is not null and an instanceof ResourceBundle, return true.
isReadOnly(ELContext) - Method in class javax.el.ValueExpression
Evaluates the expression relative to the provided context, and returns true if a call to ValueExpression.setValue(javax.el.ELContext, java.lang.Object) will always fail.
isReadonly() - Method in class javax.faces.component.html.HtmlCommandButton
Return the value of the readonly property.
isReadonly() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the readonly property.
isReadonly() - Method in class javax.faces.component.html.HtmlInputText
Return the value of the readonly property.
isReadonly() - Method in class javax.faces.component.html.HtmlInputTextarea
Return the value of the readonly property.
isReadonly() - Method in class javax.faces.component.html.HtmlSelectBooleanCheckbox
Return the value of the readonly property.
isReadonly() - Method in class javax.faces.component.html.HtmlSelectManyCheckbox
Return the value of the readonly property.
isReadonly() - Method in class javax.faces.component.html.HtmlSelectManyListbox
Return the value of the readonly property.
isReadonly() - Method in class javax.faces.component.html.HtmlSelectManyMenu
Return the value of the readonly property.
isReadonly() - Method in class javax.faces.component.html.HtmlSelectOneListbox
Return the value of the readonly property.
isReadonly() - Method in class javax.faces.component.html.HtmlSelectOneMenu
Return the value of the readonly property.
isReadonly() - Method in class javax.faces.component.html.HtmlSelectOneRadio
Return the value of the readonly property.
isReadOnly(Object, Object) - Method in class javax.faces.el.PropertyResolver
Deprecated. Checks if the specified property is read-only.
isReadOnly(Object, int) - Method in class javax.faces.el.PropertyResolver
Deprecated. Checks if the specified index is read-only.
isReadOnly(FacesContext) - Method in class javax.faces.el.ValueBinding
Deprecated. Return true if the specified property of the specified property is known to be immutable; otherwise, return false.
isReadOnly(ELContext, Object, Object) - Method in class javax.servlet.jsp.el.ImplicitObjectELResolver
If the base object is null, and the property matches the name of a JSP implicit object, returns true to indicate that implicit objects cannot be overwritten.
isReadOnly(ELContext, Object, Object) - Method in class javax.servlet.jsp.el.ScopedAttributeELResolver
If the base object is null, returns false to indicate that scoped attributes are never read-only.
isRedeploySupported() - Method in interface javax.enterprise.deploy.spi.DeploymentManager
This method designates whether this platform vendor provides application redeployment functionality.
isRedisplay() - Method in class javax.faces.component.html.HtmlInputSecret
Return the value of the redisplay property.
isRegistered(ObjectName) - Method in interface javax.management.j2ee.Management
Checks whether a managed object, identified by its object name, is already registered with the MEJB.
isRegistered(Class, QName) - Method in interface javax.xml.rpc.encoding.TypeMapping
Checks whether or not type mapping between specified XML type and Java type is registered.
isRemoved() - Method in class javax.mail.event.MessageCountEvent
Indicates whether this event is the result of an explicit expunge by this client, or due to an expunge from external sources.
isRemoveEvent() - Method in class javax.enterprise.deploy.model.XpathEvent
Is this a remove event?
isRendered() - Method in class javax.faces.component.UIComponent
Return true if this component (and its children) should be rendered during the Render Response phase of the request processing lifecycle.
isRendered() - Method in class javax.faces.component.UIComponentBase
isRequestedSessionIdFromCookie() - Method in interface javax.servlet.http.HttpServletRequest
Checks whether the requested session ID came in as a cookie.
isRequestedSessionIdFromCookie() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return isRequestedSessionIdFromCookie() on the wrapped request object.
isRequestedSessionIdFromURL() - Method in interface javax.servlet.http.HttpServletRequest
Checks whether the requested session ID came in as part of the request URL.
isRequestedSessionIdFromUrl() - Method in interface javax.servlet.http.HttpServletRequest
Deprecated. As of Version 2.1 of the Java Servlet API, use HttpServletRequest.isRequestedSessionIdFromURL() instead.
isRequestedSessionIdFromURL() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return isRequestedSessionIdFromURL() on the wrapped request object.
isRequestedSessionIdFromUrl() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return isRequestedSessionIdFromUrl() on the wrapped request object.
isRequestedSessionIdValid() - Method in interface javax.servlet.http.HttpServletRequest
Checks whether the requested session ID is still valid.
isRequestedSessionIdValid() - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return isRequestedSessionIdValid() on the wrapped request object.
isRequired() - Method in interface javax.faces.component.EditableValueHolder
Return the "required field" state for this component.
isRequired() - Method in class javax.faces.component.UIInput
Return the "required field" state for this component.
isRequired() - Method in class javax.servlet.jsp.tagext.TagAttributeInfo
Whether this attribute is required.
isRowAvailable() - Method in class javax.faces.component.UIData
Return a flag indicating whether there is rowData available at the current rowIndex.
isRowAvailable() - Method in class javax.faces.model.ArrayDataModel
Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the length of the array.
isRowAvailable() - Method in class javax.faces.model.DataModel
Return a flag indicating whether there is rowData available at the current rowIndex.
isRowAvailable() - Method in class javax.faces.model.ListDataModel
Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the size of the list.
isRowAvailable() - Method in class javax.faces.model.ResultDataModel
Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the length of the array returned by calling getRows() on the underlying Result.
isRowAvailable() - Method in class javax.faces.model.ResultSetDataModel
Return true if there is wrappedData available, and the result of calling absolute() on the underlying ResultSet, passing the current value of rowIndex plus one (to account for the fact that ResultSet uses one-relative indexing), returns true.
isRowAvailable() - Method in class javax.faces.model.ScalarDataModel
Return true if there is wrappedData available, and the current value of rowIndex is zero.
isRunning() - Method in interface javax.enterprise.deploy.spi.status.DeploymentStatus
A convience method to report if the operation is in the running state.
isSameRM(XAResource) - Method in interface javax.transaction.xa.XAResource
This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
isSavingStateInClient(FacesContext) - Method in class javax.faces.application.StateManager
isSavingStateInClient(FacesContext) - Method in class javax.faces.application.StateManagerWrapper
The default behavior of this method is to call StateManager.isSavingStateInClient(javax.faces.context.FacesContext) on the wrapped StateManager object.
isSecure() - Method in interface javax.servlet.ServletRequest
Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.
isSecure() - Method in class javax.servlet.ServletRequestWrapper
The default behavior of this method is to return isSecure() on the wrapped request object.
isSelected() - Method in class javax.faces.component.UISelectBoolean
Return the local value of the selected state of this component.
isSession() - Method in interface javax.ejb.EJBMetaData
Test if the enterprise Bean's type is "session".
isSet(Flags.Flag) - Method in class javax.mail.internet.MimeMessage
Check whether the flag specified in the flag argument is set in this message.
isSet(Flags.Flag) - Method in class javax.mail.Message
Check whether the flag specified in the flag argument is set in this message.
isShowDetail() - Method in class javax.faces.component.UIMessage
Return the flag indicating whether the detail property of the associated message(s) should be displayed.
isShowDetail() - Method in class javax.faces.component.UIMessages
Return the flag indicating whether the detail property of the associated message(s) should be displayed.
isShowSummary() - Method in class javax.faces.component.UIMessage
Return the flag indicating whether the summary property of the associated message(s) should be displayed.
isShowSummary() - Method in class javax.faces.component.UIMessages
Return the flag indicating whether the summary property of the associated message(s) should be displayed.
isSpecified() - Method in interface javax.xml.stream.events.Attribute
A flag indicating whether this attribute was actually specified in the start-tag of its element, or was defaulted from the schema.
isStandalone() - Method in interface javax.xml.stream.events.StartDocument
Returns if this XML is standalone
isStandalone() - Method in class javax.xml.stream.util.StreamReaderDelegate
isStandalone() - Method in interface javax.xml.stream.XMLStreamReader
Get the standalone declaration from the xml declaration
isStartDocument() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a StartDocument.
isStartElement() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a StartElement.
isStartElement() - Method in class javax.xml.stream.util.StreamReaderDelegate
isStartElement() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if the cursor points to a start tag (otherwise false)
isStatelessSession() - Method in interface javax.ejb.EJBMetaData
Test if the enterprise Bean's type is "stateless session".
isStopSupported() - Method in interface javax.enterprise.deploy.spi.status.ProgressObject
Tests whether the vendor supports a stop opertation for deployment activities.
isSubmitted() - Method in class javax.faces.component.UIForm
Returns the current value of the submitted property.
isSubscribed() - Method in class javax.mail.Folder
Returns true if this Folder is subscribed.
isSuppressed() - Method in class javax.faces.webapp.UIComponentTag
Deprecated.
isSynchronous() - Method in interface javax.xml.registry.Connection
Indicates whether a client uses synchronous communication with JAXR provider or not.
isTooltip() - Method in class javax.faces.component.html.HtmlMessage
Return the value of the tooltip property.
isTooltip() - Method in class javax.faces.component.html.HtmlMessages
Return the value of the tooltip property.
isTransactional() - Method in interface javax.management.j2ee.statistics.JMSConnectionStats
Returns the transactional state of this JMS connection.
isTransient() - Method in interface javax.faces.component.StateHolder
If true, the Object implementing this interface must not participate in state saving or restoring.
isTransient() - Method in class javax.faces.component.UIComponentBase
isTransient() - Method in class javax.faces.convert.DateTimeConverter
isTransient() - Method in class javax.faces.convert.EnumConverter
isTransient() - Method in class javax.faces.convert.NumberConverter
isTransient() - Method in class javax.faces.event.MethodExpressionActionListener
isTransient() - Method in class javax.faces.event.MethodExpressionValueChangeListener
isTransient() - Method in class javax.faces.validator.DoubleRangeValidator
isTransient() - Method in class javax.faces.validator.LengthValidator
isTransient() - Method in class javax.faces.validator.LongRangeValidator
isTransient() - Method in class javax.faces.validator.MethodExpressionValidator
isTypeSubstituted() - Method in class javax.xml.bind.JAXBElement
Returns true iff this xml element instance's value has a different type than xml element declaration's declared type.
isUserInRole(String) - Method in class javax.faces.context.ExternalContext
Return true if the currently authenticated user is included in the specified role.
isUserInRole(String) - Method in interface javax.servlet.http.HttpServletRequest
Returns a boolean indicating whether the authenticated user is included in the specified logical "role".
isUserInRole(String) - Method in class javax.servlet.http.HttpServletRequestWrapper
The default behavior of this method is to return isUserInRole(String role) on the wrapped request object.
isUserInRole(String) - Method in interface javax.xml.rpc.server.ServletEndpointContext
Returns a boolean indicating whether the authenticated user for the current method invocation on the endpoint instance is included in the specified logical "role".
isUserInRole(String) - Method in interface javax.xml.ws.WebServiceContext
Returns a boolean indicating whether the authenticated user is included in the specified logical role.
isValid() - Method in interface javax.faces.component.EditableValueHolder
Return a flag indicating whether the local value of this component is valid (no conversion error has occurred).
isValid() - Method in class javax.faces.component.UIInput
isValid(TagData) - Method in class javax.servlet.jsp.tagext.TagExtraInfo
Translation-time validation of the attributes.
isValid(TagData) - Method in class javax.servlet.jsp.tagext.TagInfo
Translation-time validation of the attributes.
isValidating() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.
isValidating() - Method in interface javax.xml.bind.Unmarshaller
Deprecated. since JAXB2.0, please see Unmarshaller.getSchema()
isValueReference(String) - Static method in class javax.faces.webapp.UIComponentTag
Deprecated. Return true if the specified value conforms to the syntax requirements of a value binding expression.
isWhiteSpace(char) - Static method in class javax.xml.bind.annotation.adapters.CollapsedStringAdapter
returns true if the specified char is a white space character.
isWhiteSpace() - Method in interface javax.xml.stream.events.Characters
Returns true if this set of Characters is all whitespace.
isWhiteSpace() - Method in class javax.xml.stream.util.StreamReaderDelegate
isWhiteSpace() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if the cursor points to a character data event that consists of all whitespace
isWhiteSpaceExceptSpace(char) - Static method in class javax.xml.bind.annotation.adapters.NormalizedStringAdapter
Returns true if the specified char is a white space character but not 0x20.
isXOPPackage() - Method in class javax.xml.bind.attachment.AttachmentMarshaller
Read-only property that returns true if JAXB marshaller should enable XOP creation.
isXOPPackage() - Method in class javax.xml.bind.attachment.AttachmentUnmarshaller
Read-only property that returns true if JAXB unmarshaller needs to perform XOP processing.
itemExists(String) - Method in interface javax.jms.MapMessage
Indicates whether an item exists in this MapMessage object.
IterationTag - Interface in javax.servlet.jsp.tagext
The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.

J

J2eeApplicationObject - Interface in javax.enterprise.deploy.model
J2eeApplicationObject is an interface that represents a J2EE application (EAR); it maintains a DeployableObject for each module in the archive.
javaCharset(String) - Static method in class javax.mail.internet.MimeUtility
Convert a MIME charset name into a valid Java charset name.
JavaMailStats - Interface in javax.management.j2ee.statistics
Specifies the statistics provided by a JavaMail resource.
javax.activation - package javax.activation
The JavaBeans(TM) Activation Framework is used by the JavaMail(TM) API to manage MIME data.
javax.annotation - package javax.annotation
This package defines the common annotations.
javax.annotation.security - package javax.annotation.security
This package contains the security common annotations.
javax.ejb - package javax.ejb
The javax.ejb package contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.
javax.ejb.spi - package javax.ejb.spi
The javax.ejb.spi package defines interfaces that are implemented by the EJB container.
javax.el - package javax.el
Provides the API for the Unified Expression Language shared by the JSP 2.1 and JSF 1.2 technologies.
javax.enterprise.deploy.model - package javax.enterprise.deploy.model
Provides Tool Vendor implementation classes.
javax.enterprise.deploy.model.exceptions - package javax.enterprise.deploy.model.exceptions
Provides Tool Vendor exception implementation classes.
javax.enterprise.deploy.shared - package javax.enterprise.deploy.shared
Provides shared objects for Tool Vendor and Product Vendor implementation classes.
javax.enterprise.deploy.shared.factories - package javax.enterprise.deploy.shared.factories
Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.
javax.enterprise.deploy.spi - package javax.enterprise.deploy.spi
Provides J2EE Product Vendor implementation classes.
javax.enterprise.deploy.spi.exceptions - package javax.enterprise.deploy.spi.exceptions
Provides J2EE Product Vendor deployment exception implementation classes.
javax.enterprise.deploy.spi.factories - package javax.enterprise.deploy.spi.factories
Provides J2EE Product Vendor deployment factory implementation classes.
javax.enterprise.deploy.spi.status - package javax.enterprise.deploy.spi.status
Provides J2EE Product Vendor deployment status implementation classes.
javax.faces - package javax.faces
Top level classes for the JavaServer(tm) Faces API.
javax.faces.application - package javax.faces.application
APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.
javax.faces.component - package javax.faces.component
Fundamental APIs for user interface components.
javax.faces.component.html - package javax.faces.component.html
Specialized user interface component classes for HTML.
javax.faces.context - package javax.faces.context
Classes and interfaces defining per-request state information.
javax.faces.convert - package javax.faces.convert
Contains classes and interfaces defining converters.
javax.faces.el - package javax.faces.el
DEPRECATED Classes and interfaces for evaluating and processing reference expressions.
javax.faces.event - package javax.faces.event
Interfaces describing events and event listeners, and concrete event implementation classes.
javax.faces.lifecycle - package javax.faces.lifecycle
Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.
javax.faces.model - package javax.faces.model
Standard model data beans for JavaServer Faces.
javax.faces.render - package javax.faces.render
Classes and interfaces defining the rendering model.
javax.faces.validator - package javax.faces.validator
Interface defining the validator model, and concrete validator implementation classes.
javax.faces.webapp - package javax.faces.webapp
Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.
javax.interceptor - package javax.interceptor
The javax.interceptor package contains classes and interfaces for use with EJB interceptors.
javax.jms - package javax.jms
The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.
javax.jws - package javax.jws
javax.jws.soap - package javax.jws.soap
javax.mail - package javax.mail
Classes modeling a mail system.
javax.mail.event - package javax.mail.event
Listeners and events for the JavaMail API.
javax.mail.internet - package javax.mail.internet
Classes specific to Internet mail systems.
javax.mail.search - package javax.mail.search
Message search terms for the JavaMail API.
javax.mail.util - package javax.mail.util
Utility classes.
javax.management.j2ee - package javax.management.j2ee
Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.
javax.management.j2ee.statistics - package javax.management.j2ee.statistics
Provides the standard interfaces for accessing performance data from J2EE managed objects Package Specification JSR 77, J2EE Management Related Documentation For overviews, tutorials, examples, guides, and tool documentation, please see: J2EE Tools


Java EE 5 SDK

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Serialized Form

Package javax.activation

Class javax.activation.ActivationDataFlavor extends DataFlavor implements Serializable

Serialization Methods

readExternal

public void readExternal(ObjectInput arg0)
                  throws IOException,
                         ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeExternal

public void writeExternal(ObjectOutput arg0)
                   throws IOException
Throws:
IOException

Class javax.activation.MimeType extends Object implements Serializable

Serialization Methods

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
The object implements the readExternal method to restore its contents by calling the methods of DataInput for primitive types and readObject for objects, strings and arrays. The readExternal method must read the values in the same sequence and with the same types as were written by writeExternal.

Throws:
ClassNotFoundException - If the class for an object being restored cannot be found.
IOException

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException
The object implements the writeExternal method to save its contents by calling the methods of DataOutput for its primitive values or calling the writeObject method of ObjectOutput for objects, strings and arrays.

Throws:
IOException - Includes any I/O exceptions that may occur

Class javax.activation.MimeTypeParseException extends Exception implements Serializable

Class javax.activation.UnsupportedDataTypeException extends IOException implements Serializable

Package javax.ejb

Class javax.ejb.AccessLocalException extends EJBException implements Serializable

Class javax.ejb.ConcurrentAccessException extends EJBException implements Serializable

Class javax.ejb.CreateException extends Exception implements Serializable

Class javax.ejb.DuplicateKeyException extends CreateException implements Serializable

Class javax.ejb.EJBAccessException extends EJBException implements Serializable

Class javax.ejb.EJBException extends RuntimeException implements Serializable

Serialized Fields

causeException

Exception causeException

Class javax.ejb.EJBTransactionRequiredException extends EJBException implements Serializable

Class javax.ejb.EJBTransactionRolledbackException extends EJBException implements Serializable

Class javax.ejb.FinderException extends Exception implements Serializable

Class javax.ejb.NoSuchEJBException extends EJBException implements Serializable

Class javax.ejb.NoSuchEntityException extends EJBException implements Serializable

Class javax.ejb.NoSuchObjectLocalException extends EJBException implements Serializable

Class javax.ejb.ObjectNotFoundException extends FinderException implements Serializable

Class javax.ejb.RemoveException extends Exception implements Serializable

Class javax.ejb.TransactionRequiredLocalException extends EJBException implements Serializable

Class javax.ejb.TransactionRolledbackLocalException extends EJBException implements Serializable

Package javax.el

Class javax.el.ELContextEvent extends EventObject implements Serializable

Class javax.el.ELException extends RuntimeException implements Serializable

Class javax.el.Expression extends Object implements Serializable

Class javax.el.MethodExpression extends Expression implements Serializable

Class javax.el.MethodNotFoundException extends ELException implements Serializable

Class javax.el.PropertyNotFoundException extends ELException implements Serializable

Class javax.el.PropertyNotWritableException extends ELException implements Serializable

Class javax.el.ValueExpression extends Expression implements Serializable

Package javax.enterprise.deploy.model.exceptions

Class javax.enterprise.deploy.model.exceptions.DDBeanCreateException extends Exception implements Serializable

Package javax.enterprise.deploy.spi.exceptions

Class javax.enterprise.deploy.spi.exceptions.BeanNotFoundException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.ClientExecuteException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.ConfigurationException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.InvalidModuleException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException extends Exception implements Serializable

Class javax.enterprise.deploy.spi.exceptions.TargetException extends Exception implements Serializable

Package javax.enterprise.deploy.spi.status

Class javax.enterprise.deploy.spi.status.ProgressEvent extends EventObject implements Serializable

Serialized Fields

statuscode

DeploymentStatus statuscode

targetModuleID

TargetModuleID targetModuleID
Package javax.faces

Class javax.faces.FacesException extends RuntimeException implements Serializable

Serialized Fields

cause

Throwable cause

The underlying exception that caused this exception.

Package javax.faces.application

Class javax.faces.application.FacesMessage extends Object implements Serializable

serialVersionUID: -1180773928220076822L

Serialized Fields

severity

FacesMessage.Severity severity

summary

String summary

detail

String detail

Class javax.faces.application.ViewExpiredException extends FacesException implements Serializable

Serialized Fields

viewId

String viewId

The view identifier of the view that could not be restored.

Package javax.faces.convert

Class javax.faces.convert.ConverterException extends FacesException implements Serializable

Serialized Fields

facesMessage

FacesMessage facesMessage
Package javax.faces.el

Class javax.faces.el.EvaluationException extends FacesException implements Serializable

Class javax.faces.el.MethodNotFoundException extends EvaluationException implements Serializable

Class javax.faces.el.PropertyNotFoundException extends EvaluationException implements Serializable

Class javax.faces.el.ReferenceSyntaxException extends EvaluationException implements Serializable

Package javax.faces.event

Class javax.faces.event.AbortProcessingException extends FacesException implements Serializable

Class javax.faces.event.ActionEvent extends FacesEvent implements Serializable

Class javax.faces.event.FacesEvent extends EventObject implements Serializable

Serialized Fields

phaseId

PhaseId phaseId

Class javax.faces.event.PhaseEvent extends EventObject implements Serializable

Serialized Fields

context

FacesContext context

phaseId

PhaseId phaseId

Class javax.faces.event.ValueChangeEvent extends FacesEvent implements Serializable

Serialized Fields

oldValue

Object oldValue

The previous local value of the source UIComponent.

newValue

Object newValue

The current local value of the source UIComponent.

Package javax.faces.model

Class javax.faces.model.DataModelEvent extends EventObject implements Serializable

Serialized Fields

data

Object data

index

int index

Class javax.faces.model.SelectItem extends Object implements Serializable

serialVersionUID: 876782311414654999L

Serialized Fields

description

String description

disabled

boolean disabled

label

String label

value

Object value

escape

boolean escape
Holds value of property escape.

Class javax.faces.model.SelectItemGroup extends SelectItem implements Serializable

Serialized Fields

selectItems

SelectItem[] selectItems
Package javax.faces.validator

Class javax.faces.validator.ValidatorException extends FacesException implements Serializable

Serialized Fields

message

FacesMessage message
Package javax.faces.webapp

Class javax.faces.webapp.AttributeTag extends TagSupport implements Serializable

serialVersionUID: -7782950243436672334L

Serialized Fields

name

String name
Deprecated.

The name of the attribute to be created, if not already present.

value

String value
Deprecated.

The value to be associated with this attribute, if it is created.

Class javax.faces.webapp.ConverterELTag extends TagSupport implements Serializable

Class javax.faces.webapp.ConverterTag extends TagSupport implements Serializable

serialVersionUID: -5909792518081427720L

Serialized Fields

converterId

String converterId
Deprecated.

The identifier of the Converter instance to be created.

binding

String binding
Deprecated.

The ValueExpression that evaluates to an object that implements Converter.

Class javax.faces.webapp.FacetTag extends TagSupport implements Serializable

Serialized Fields

name

String name

The name of this facet. This will be used as the facet name for our UIComponentTag child in our UIComponentTag parent's facet list.

Class javax.faces.webapp.ValidatorELTag extends TagSupport implements Serializable

Class javax.faces.webapp.ValidatorTag extends TagSupport implements Serializable

serialVersionUID: -5562623615418158868L

Serialized Fields

validatorId

String validatorId
Deprecated.

The identifier of the Validator instance to be created.

binding

String binding
Deprecated.

The ValueExpression that evaluates to an object that implements Validator.

Package javax.jms

Class javax.jms.IllegalStateException extends JMSException implements Serializable

Class javax.jms.InvalidClientIDException extends JMSException implements Serializable

Class javax.jms.InvalidDestinationException extends JMSException implements Serializable

Class javax.jms.InvalidSelectorException extends JMSException implements Serializable

Class javax.jms.JMSException extends Exception implements Serializable

Serialized Fields

errorCode

String errorCode
Vendor-specific error code.

linkedException

Exception linkedException
Exception reference.

Class javax.jms.JMSSecurityException extends JMSException implements Serializable

Class javax.jms.MessageEOFException extends JMSException implements Serializable

Class javax.jms.MessageFormatException extends JMSException implements Serializable

Class javax.jms.MessageNotReadableException extends JMSException implements Serializable

Class javax.jms.MessageNotWriteableException extends JMSException implements Serializable

Class javax.jms.ResourceAllocationException extends JMSException implements Serializable

Class javax.jms.TransactionInProgressException extends JMSException implements Serializable

Class javax.jms.TransactionRolledBackException extends JMSException implements Serializable

Package javax.mail

Class javax.mail.Address extends Object implements Serializable

serialVersionUID: -5822459626751992278L

Class javax.mail.AuthenticationFailedException extends MessagingException implements Serializable

serialVersionUID: 492080754054436511L

Class javax.mail.Flags extends Object implements Serializable

serialVersionUID: 6243590407214169028L

Serialized Fields

system_flags

int system_flags

user_flags

Hashtable<K,V> user_flags

Class javax.mail.FolderClosedException extends MessagingException implements Serializable

serialVersionUID: 1687879213433302315L

Class javax.mail.FolderNotFoundException extends MessagingException implements Serializable

serialVersionUID: 472612108891249403L

Class javax.mail.IllegalWriteException extends MessagingException implements Serializable

serialVersionUID: 3974370223328268013L

Class javax.mail.Message.RecipientType extends Object implements Serializable

serialVersionUID: -7479791750606340008L

Serialization Methods

readResolve

protected Object readResolve()
                      throws ObjectStreamException
When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class. Subclasses must implement their own readResolve method that checks for their known instances before calling this super method.

Throws:
ObjectStreamException
Serialized Fields

type

String type
The type of recipient, usually the name of a corresponding Internet standard header.

Class javax.mail.MessageRemovedException extends MessagingException implements Serializable

serialVersionUID: 1951292550679528690L

Class javax.mail.MessagingException extends Exception implements Serializable

serialVersionUID: -7569192289819959253L

Serialized Fields

next

Exception next
The next exception in the chain.

Class javax.mail.MethodNotSupportedException extends MessagingException implements Serializable

serialVersionUID: -3757386618726131322L

Class javax.mail.NoSuchProviderException extends MessagingException implements Serializable

serialVersionUID: 8058319293154708827L

Class javax.mail.ReadOnlyFolderException extends MessagingException implements Serializable

serialVersionUID: 5711829372799039325L

Class javax.mail.SendFailedException extends MessagingException implements Serializable

serialVersionUID: -6457531621682372913L

Class javax.mail.StoreClosedException extends MessagingException implements Serializable

serialVersionUID: -3145392336120082655L

Package javax.mail.event

Class javax.mail.event.ConnectionEvent extends MailEvent implements Serializable

serialVersionUID: -1855480171284792957L

Serialized Fields

type

int type
The event type.

Class javax.mail.event.FolderEvent extends MailEvent implements Serializable

serialVersionUID: 5278131310563694307L

Serialized Fields

type

int type
The event type.

Class javax.mail.event.MailEvent extends EventObject implements Serializable

serialVersionUID: 1846275636325456631L

Class javax.mail.event.MessageChangedEvent extends MailEvent implements Serializable

serialVersionUID: -4974972972105535108L

Serialized Fields

type

int type
The event type.

Class javax.mail.event.MessageCountEvent extends MailEvent implements Serializable

serialVersionUID: -7447022340837897369L

Serialized Fields

type

int type
The event type.

removed

boolean removed
If true, this event is the result of an explicit expunge by this client, and the messages in this folder have been renumbered to account for this. If false, this event is the result of an expunge by external sources.

Class javax.mail.event.StoreEvent extends MailEvent implements Serializable

serialVersionUID: 1938704919992515330L

Serialized Fields

type

int type
The event type.

message

String message
The message text to be presented to the user.

Class javax.mail.event.TransportEvent extends MailEvent implements Serializable

serialVersionUID: -4729852364684273073L

Serialized Fields

type

int type
The event type.

Package javax.mail.internet

Class javax.mail.internet.AddressException extends ParseException implements Serializable

serialVersionUID: 9134583443539323120L

Serialized Fields

ref

String ref
The string being parsed.

pos

int pos
The index in the string where the error occurred, or -1 if not known.

Class javax.mail.internet.InternetAddress extends Address implements Serializable

serialVersionUID: -7507595530758302903L

Serialized Fields

address

String address

personal

String personal
The personal name.

encodedPersonal

String encodedPersonal
The RFC 2047 encoded version of the personal name.

This field and the personal field track each other, so if a subclass sets one of these fields directly, it should set the other to null, so that it is suitably recomputed.

Class javax.mail.internet.MailDateFormat extends SimpleDateFormat implements Serializable

serialVersionUID: -8148227605210628779L

Class javax.mail.internet.MimeMessage.RecipientType extends Message.RecipientType implements Serializable

serialVersionUID: -5468290701714395543L

Serialization Methods

readResolve

protected Object readResolve()
                      throws ObjectStreamException
Throws:
ObjectStreamException

Class javax.mail.internet.NewsAddress extends Address implements Serializable

serialVersionUID: -4203797299824684143L

Serialized Fields

newsgroup

String newsgroup

host

String host

Class javax.mail.internet.ParseException extends MessagingException implements Serializable

serialVersionUID: 7649991205183658089L

Package javax.mail.search

Class javax.mail.search.AddressStringTerm extends StringTerm implements Serializable

serialVersionUID: 3086821234204980368L

Class javax.mail.search.AddressTerm extends SearchTerm implements Serializable

serialVersionUID: 2005405551929769980L

Serialized Fields

address

Address address
The address.

Class javax.mail.search.AndTerm extends SearchTerm implements Serializable

serialVersionUID: -3583274505380989582L

Serialized Fields

terms

SearchTerm[] terms
The array of terms on which the AND operator should be applied.

Class javax.mail.search.BodyTerm extends StringTerm implements Serializable

serialVersionUID: -4888862527916911385L

Class javax.mail.search.ComparisonTerm extends SearchTerm implements Serializable

serialVersionUID: 1456646953666474308L

Serialized Fields

comparison

int comparison
The comparison.

Class javax.mail.search.DateTerm extends ComparisonTerm implements Serializable

serialVersionUID: 4818873430063720043L

Serialized Fields

date

Date date
The date.

Class javax.mail.search.FlagTerm extends SearchTerm implements Serializable

serialVersionUID: -142991500302030647L

Serialized Fields

set

boolean set
Indicates whether to test for the presence or absence of the specified Flag. If true, then test whether all the specified flags are present, else test whether all the specified flags are absent.

flags

Flags flags
Flags object containing the flags to test.

Class javax.mail.search.FromStringTerm extends AddressStringTerm implements Serializable

serialVersionUID: 5801127523826772788L

Class javax.mail.search.FromTerm extends AddressTerm implements Serializable

serialVersionUID: 5214730291502658665L

Class javax.mail.search.HeaderTerm extends StringTerm implements Serializable

serialVersionUID: 8342514650333389122L

Serialized Fields

headerName

String headerName
The name of the header.

Class javax.mail.search.IntegerComparisonTerm extends ComparisonTerm implements Serializable

serialVersionUID: -6963571240154302484L

Serialized Fields

number

int number
The number.

Class javax.mail.search.MessageIDTerm extends StringTerm implements Serializable

serialVersionUID: -2121096296454691963L

Class javax.mail.search.MessageNumberTerm extends IntegerComparisonTerm implements Serializable

serialVersionUID: -5379625829658623812L

Class javax.mail.search.NotTerm extends SearchTerm implements Serializable

serialVersionUID: 7152293214217310216L

Serialized Fields

term

SearchTerm term
The search term to negate.

Class javax.mail.search.OrTerm extends SearchTerm implements Serializable

serialVersionUID: 5380534067523646936L

Serialized Fields

terms

SearchTerm[] terms
The array of terms on which the OR operator should be applied.

Class javax.mail.search.ReceivedDateTerm extends DateTerm implements Serializable

serialVersionUID: -2756695246195503170L

Class javax.mail.search.RecipientStringTerm extends AddressStringTerm implements Serializable

serialVersionUID: -8293562089611618849L

Serialized Fields

type

Message.RecipientType type
The recipient type.

Class javax.mail.search.RecipientTerm extends AddressTerm implements Serializable

serialVersionUID: 6548700653122680468L

Serialized Fields

type

Message.RecipientType type
The recipient type.

Class javax.mail.search.SearchException extends MessagingException implements Serializable

serialVersionUID: -7092886778226268686L

Class javax.mail.search.SearchTerm extends Object implements Serializable

serialVersionUID: -6652358452205992789L

Class javax.mail.search.SentDateTerm extends DateTerm implements Serializable

serialVersionUID: 5647755030530907263L

Class javax.mail.search.SizeTerm extends IntegerComparisonTerm implements Serializable

serialVersionUID: -2556219451005103709L

Class javax.mail.search.StringTerm extends SearchTerm implements Serializable

serialVersionUID: 1274042129007696269L

Serialized Fields

pattern

String pattern
The pattern.

ignoreCase

boolean ignoreCase
Ignore case when comparing?

Class javax.mail.search.SubjectTerm extends StringTerm implements Serializable

serialVersionUID: 7481568618055573432L

Package javax.management.j2ee
Package javax.persistence

Class javax.persistence.EntityExistsException extends PersistenceException implements Serializable

Class javax.persistence.EntityNotFoundException extends PersistenceException implements Serializable

Class javax.persistence.NonUniqueResultException extends PersistenceException implements Serializable

Class javax.persistence.NoResultException extends PersistenceException implements Serializable

Class javax.persistence.OptimisticLockException extends PersistenceException implements Serializable

Serialized Fields

entity

Object entity
The object that caused the exception

Class javax.persistence.PersistenceException extends RuntimeException implements Serializable

Class javax.persistence.RollbackException extends PersistenceException implements Serializable

Class javax.persistence.TransactionRequiredException extends PersistenceException implements Serializable

Package javax.resource

Class javax.resource.NotSupportedException extends ResourceException implements Serializable

Class javax.resource.ResourceException extends Exception implements Serializable

Serialized Fields

errorCode

String errorCode
Vendor specific error code

linkedException

Exception linkedException
reference to another exception

Package javax.resource.cci

Class javax.resource.cci.ResourceWarning extends ResourceException implements Serializable

Package javax.resource.spi

Class javax.resource.spi.ApplicationServerInternalException extends ResourceException implements Serializable

Class javax.resource.spi.CommException extends ResourceException implements Serializable

Class javax.resource.spi.ConnectionEvent extends EventObject implements Serializable

Serialized Fields

exception

Exception exception
Exception associated with the ConnectionEvent instance.

id

int id
Type of the event

connectionHandle

Object connectionHandle

Class javax.resource.spi.EISSystemException extends ResourceException implements Serializable

Class javax.resource.spi.IllegalStateException extends ResourceException implements Serializable

Class javax.resource.spi.InvalidPropertyException extends ResourceException implements Serializable

Serialized Fields

invalidProperties

PropertyDescriptor[] invalidProperties

Class javax.resource.spi.LocalTransactionException extends ResourceException implements Serializable

Class javax.resource.spi.ResourceAdapterInternalException extends ResourceException implements Serializable

Class javax.resource.spi.ResourceAllocationException extends ResourceException implements Serializable

Class javax.resource.spi.SecurityException extends ResourceException implements Serializable

Class javax.resource.spi.SharingViolationException extends ResourceException implements Serializable

Class javax.resource.spi.UnavailableException extends ResourceException implements Serializable

Package javax.resource.spi.security

Class javax.resource.spi.security.PasswordCredential extends Object implements Serializable

Serialized Fields

userName

String userName

password

char[] password

mcf

ManagedConnectionFactory mcf
Package javax.resource.spi.work

Class javax.resource.spi.work.WorkCompletedException extends WorkException implements Serializable

Class javax.resource.spi.work.WorkEvent extends EventObject implements Serializable

Serialized Fields

type

int type
The event type.

work

Work work
The Work object on which the event occured.

exc

WorkException exc
The exception that occured during Work processing.

startDuration

long startDuration
The start delay duration (in milliseconds).

Class javax.resource.spi.work.WorkException extends ResourceException implements Serializable

Class javax.resource.spi.work.WorkRejectedException extends WorkException implements Serializable

Package javax.security.jacc

Class javax.security.jacc.EJBMethodPermission extends Permission implements Serializable

serialVersionUID: 1L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.

Throws:
IOException
Serialization Overview
The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

Serialized Fields

actions

String actions
the canonicalized actions string (as returned by getActions).

Class javax.security.jacc.EJBRoleRefPermission extends Permission implements Serializable

serialVersionUID: 1L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.

Throws:
IOException
Serialization Overview
The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

Serialized Fields

actions

String actions
the canonicalized actions string (as returned by getActions).

Class javax.security.jacc.PolicyContextException extends Exception implements Serializable

Class javax.security.jacc.WebResourcePermission extends Permission implements Serializable

serialVersionUID: 1L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.

Throws:
IOException
Serialization Overview
The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

Serialized Fields

actions

String actions
the canonicalized actions string (as returned by getActions).

Class javax.security.jacc.WebRoleRefPermission extends Permission implements Serializable

serialVersionUID: 1L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.

Throws:
IOException
Serialization Overview
The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

Serialized Fields

actions

String actions
the canonicalized actions string (as returned by getActions).

Class javax.security.jacc.WebUserDataPermission extends Permission implements Serializable

serialVersionUID: 1L

Serialization Methods

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
readObject reads the serialized fields from the input stream and uses them to restore the permission. This method need not be implemented if establishing the values of the serialized fields (as is done by defaultReadObject) is sufficient to initialize the permission.

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
writeObject is used to establish the values of the serialized fields before they are written to the output stream and need not be implemented if the values of the serialized fields are always available and up to date. The serialized fields are written to the output stream in the same form as they would be written by defaultWriteObject.

Throws:
IOException
Serialization Overview
The serialized fields of this permission are defined below. Whether or not the serialized fields correspond to actual (private) fields is an implementation decision.

Serialized Fields

actions

String actions
the canonicalized actions string (as returned by getActions).
Package javax.servlet

Class javax.servlet.GenericServlet extends Object implements Serializable

Class javax.servlet.ServletContextAttributeEvent extends ServletContextEvent implements Serializable

Serialized Fields

name

String name

value

Object value

Class javax.servlet.ServletContextEvent extends EventObject implements Serializable

Class javax.servlet.ServletException extends Exception implements Serializable

Serialized Fields

rootCause

Throwable rootCause

Class javax.servlet.ServletRequestAttributeEvent extends ServletRequestEvent implements Serializable

Serialized Fields

name

String name

value

Object value

Class javax.servlet.ServletRequestEvent extends EventObject implements Serializable

Serialized Fields

request

ServletRequest request

Class javax.servlet.UnavailableException extends ServletException implements Serializable

Serialized Fields

servlet

Servlet servlet

permanent

boolean permanent

seconds

int seconds
Package javax.servlet.http

Class javax.servlet.http.HttpServlet extends GenericServlet implements Serializable

Class javax.servlet.http.HttpSessionBindingEvent extends HttpSessionEvent implements Serializable

Serialized Fields

name

String name

value

Object value

Class javax.servlet.http.HttpSessionEvent extends EventObject implements Serializable

Package javax.servlet.jsp

Class javax.servlet.jsp.JspException extends Exception implements Serializable

Class javax.servlet.jsp.JspTagException extends JspException implements Serializable

Class javax.servlet.jsp.SkipPageException extends JspException implements Serializable

Package javax.servlet.jsp.el

Class javax.servlet.jsp.el.ELException extends Exception implements Serializable

Serialized Fields

mRootCause

Throwable mRootCause
Deprecated.

Class javax.servlet.jsp.el.ELParseException extends ELException implements Serializable

Package javax.servlet.jsp.tagext

Class javax.servlet.jsp.tagext.BodyTagSupport extends TagSupport implements Serializable

Serialized Fields

bodyContent

BodyContent bodyContent
The current BodyContent for this BodyTag.

Class javax.servlet.jsp.tagext.TagSupport extends Object implements Serializable

Serialized Fields

parent

Tag parent

values

Hashtable<K,V> values

id

String id
The value of the id attribute of this tag; or null.

pageContext

PageContext pageContext
The PageContext.

Package javax.transaction

Class javax.transaction.HeuristicCommitException extends Exception implements Serializable

Class javax.transaction.HeuristicMixedException extends Exception implements Serializable

Class javax.transaction.HeuristicRollbackException extends Exception implements Serializable

Class javax.transaction.InvalidTransactionException extends RemoteException implements Serializable

Class javax.transaction.NotSupportedException extends Exception implements Serializable

Class javax.transaction.RollbackException extends Exception implements Serializable

Class javax.transaction.SystemException extends Exception implements Serializable

Serialized Fields

errorCode

int errorCode
The error code with which to create the SystemException.

The error code for the exception

Class javax.transaction.TransactionRequiredException extends RemoteException implements Serializable

Class javax.transaction.TransactionRolledbackException extends RemoteException implements Serializable

Package javax.transaction.xa

Class javax.transaction.xa.XAException extends Exception implements Serializable

Serialized Fields

errorCode

int errorCode
The error code with which to create the SystemException.

The error code for the exception.
Package javax.xml.bind

Class javax.xml.bind.JAXBElement extends Object implements Serializable

serialVersionUID: 1L

Serialized Fields

name

QName name
xml element tag name

declaredType

Class<T> declaredType
Java datatype binding for xml element declaration's type.

scope

Class<T> scope
Scope of xml element declaration representing this xml element instance. Can be one of the following values: - JAXBElement.GlobalScope for global xml element declaration. - local element declaration has a scope set to the Java class representation of complex type defintion containing xml element declaration.

value

Object value
xml element value. Represents content model and attributes of an xml element instance.

nil

boolean nil
true iff the xml element instance has xsi:nil="true".

Class javax.xml.bind.JAXBException extends Exception implements Serializable

serialVersionUID: -5621384651494307979L

Serialized Fields

errorCode

String errorCode
Vendor specific error code

linkedException

Throwable linkedException
Exception reference

Class javax.xml.bind.MarshalException extends JAXBException implements Serializable

Class javax.xml.bind.PropertyException extends JAXBException implements Serializable

Class javax.xml.bind.TypeConstraintException extends RuntimeException implements Serializable

Serialized Fields

errorCode

String errorCode
Vendor specific error code

linkedException

Throwable linkedException
Exception reference

Class javax.xml.bind.UnmarshalException extends JAXBException implements Serializable

Class javax.xml.bind.ValidationException extends JAXBException implements Serializable

Package javax.xml.registry

Class javax.xml.registry.DeleteException extends RegistryException implements Serializable

Class javax.xml.registry.FindException extends RegistryException implements Serializable

Class javax.xml.registry.InvalidRequestException extends JAXRException implements Serializable

Class javax.xml.registry.JAXRException extends Exception implements Serializable

Serialized Fields

cause

Throwable cause

Class javax.xml.registry.RegistryException extends JAXRException implements Serializable

Serialized Fields

errorObjectKey

Key errorObjectKey

Class javax.xml.registry.SaveException extends RegistryException implements Serializable

Class javax.xml.registry.UnexpectedObjectException extends JAXRException implements Serializable

Class javax.xml.registry.UnsupportedCapabilityException extends JAXRException implements Serializable

Package javax.xml.rpc

Class javax.xml.rpc.JAXRPCException extends RuntimeException implements Serializable

Serialized Fields

cause

Throwable cause

Class javax.xml.rpc.ServiceException extends Exception implements Serializable

Serialized Fields

cause

Throwable cause
Package javax.xml.rpc.encoding
Package javax.xml.rpc.handler

Class javax.xml.rpc.handler.HandlerInfo extends Object implements Serializable

Serialized Fields

handlerClass

Class<T> handlerClass

config

Map<K,V> config

headers

Vector<E> headers
Package javax.xml.rpc.soap

Class javax.xml.rpc.soap.SOAPFaultException extends RuntimeException implements Serializable

Serialized Fields

faultcode

QName faultcode

faultstring

String faultstring

faultactor

String faultactor

detail

Detail detail
Package javax.xml.soap

Class javax.xml.soap.SOAPException extends Exception implements Serializable

Serialized Fields

cause

Throwable cause
Package javax.xml.stream

Class javax.xml.stream.FactoryConfigurationError extends Error implements Serializable

Serialized Fields

nested

Exception nested

Class javax.xml.stream.XMLStreamException extends Exception implements Serializable

Serialized Fields

nested

Throwable nested

location

Location location
Package javax.xml.ws

Class javax.xml.ws.ProtocolException extends WebServiceException implements Serializable

Class javax.xml.ws.WebServiceException extends RuntimeException implements Serializable

Class javax.xml.ws.WebServicePermission extends BasicPermission implements Serializable

serialVersionUID: -146474640053770988L

Package javax.xml.ws.http

Class javax.xml.ws.http.HTTPException extends ProtocolException implements Serializable

Serialized Fields

statusCode

int statusCode
Package javax.xml.ws.soap

Class javax.xml.ws.soap.SOAPFaultException extends ProtocolException implements Serializable

Serialized Fields

fault

SOAPFault fault

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


activation

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.activation

The JavaBeans(TM) Activation Framework is used by the JavaMail(TM) API to manage MIME data.

See:
Description

Interface Summary
CommandObject | JavaBeans components that are Activation Framework aware implement this interface to find out which command verb they're being asked to perform, and to obtain the DataHandler representing the data they should operate on.
DataContentHandler | The DataContentHandler interface is implemented by objects that can be used to extend the capabilities of the DataHandler's implementation of the Transferable interface.
DataContentHandlerFactory | This interface defines a factory for DataContentHandlers.
DataSource | The DataSource interface provides the JavaBeans Activation Framework with an abstraction of an arbitrary collection of data.

Class Summary
ActivationDataFlavor | The ActivationDataFlavor class is a special subclass of java.awt.datatransfer.DataFlavor.
CommandInfo | The CommandInfo class is used by CommandMap implementations to describe the results of command requests.
CommandMap | The CommandMap class provides an interface to a registry of command objects available in the system.
DataHandler | The DataHandler class provides a consistent interface to data available in many different sources and formats.
FileDataSource | The FileDataSource class implements a simple DataSource object that encapsulates a file.
FileTypeMap | The FileTypeMap is an abstract class that provides a data typing interface for files.
MailcapCommandMap | MailcapCommandMap extends the CommandMap abstract class.
MimeType | A Multipurpose Internet Mail Extension (MIME) type, as defined in RFC 2045 and 2046.
MimeTypeParameterList | A parameter list of a MimeType as defined in RFC 2045 and 2046.
MimetypesFileTypeMap | This class extends FileTypeMap and provides data typing of files via their file extension.
URLDataSource | The URLDataSource class provides an object that wraps a URL object in a DataSource interface.

Exception Summary
MimeTypeParseException | A class to encapsulate MimeType parsing related exceptions.
UnsupportedDataTypeException | Signals that the requested operation does not support the requested data type.

Package javax.activation Description

The JavaBeans(TM) Activation Framework is used by the JavaMail(TM) API to manage MIME data.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.activation Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.activation

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.activation.CommandInfo
    • javax.activation.CommandMap
      • javax.activation.MailcapCommandMap
    • java.awt.datatransfer.DataFlavor (implements java.lang.Cloneable, java.io.Externalizable)
      • javax.activation.ActivationDataFlavor
    • javax.activation.DataHandler (implements java.awt.datatransfer.Transferable)
    • javax.activation.FileDataSource (implements javax.activation.DataSource)
    • javax.activation.FileTypeMap
      • javax.activation.MimetypesFileTypeMap
    • javax.activation.MimeType (implements java.io.Externalizable)
    • javax.activation.MimeTypeParameterList
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • javax.activation.UnsupportedDataTypeException
        • javax.activation.MimeTypeParseException
    • javax.activation.URLDataSource (implements javax.activation.DataSource)

Interface Hierarchy

  • javax.activation.CommandObject
  • javax.activation.DataContentHandler
  • javax.activation.DataContentHandlerFactory
  • javax.activation.DataSource
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ActivationDataFlavor

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class ActivationDataFlavor

java.lang.Object
    extended by  java.awt.datatransfer.DataFlavor
        extended by  javax.activation.ActivationDataFlavor
All Implemented Interfaces:
Externalizable, Serializable, Cloneable
public class ActivationDataFlavor
extends DataFlavor

The ActivationDataFlavor class is a special subclass of java.awt.datatransfer.DataFlavor. It allows the JAF to set all three values stored by the DataFlavor class via a new constructor. It also contains improved MIME parsing in the equals method. Except for the improved parsing, its semantics are identical to that of the JDK's DataFlavor class.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.awt.datatransfer.DataFlavor
imageFlavor, javaFileListFlavor, javaJVMLocalObjectMimeType, javaRemoteObjectMimeType, javaSerializedObjectMimeType, plainTextFlavor, stringFlavor
Constructor Summary
ActivationDataFlavor(Class representationClass, String humanPresentableName)
Construct a DataFlavor that represents a MimeType.
ActivationDataFlavor(Class representationClass, String mimeType, String humanPresentableName)
Construct a DataFlavor that represents an arbitrary Java object.
ActivationDataFlavor(String mimeType, String humanPresentableName)
Construct a DataFlavor that represents a MimeType.
Method Summary
boolean | equals(DataFlavor dataFlavor) Compares the DataFlavor passed in with this DataFlavor; calls the isMimeTypeEqual method.
String | getHumanPresentableName() Return the Human Presentable name.
String | getMimeType() Return the MIME type for this DataFlavor.
Class | getRepresentationClass() Return the representation class.
boolean | isMimeTypeEqual(String mimeType) Is the string representation of the MIME type passed in equivalent to the MIME type of this DataFlavor.
protected String | normalizeMimeType(String mimeType) Deprecated.
protected String | normalizeMimeTypeParameter(String parameterName, String parameterValue) Deprecated.
void | setHumanPresentableName(String humanPresentableName) Set the human presentable name.
Methods inherited from class java.awt.datatransfer.DataFlavor
clone, equals, equals, getDefaultRepresentationClass, getDefaultRepresentationClassAsString, getParameter, getPrimaryType, getReaderForText, getSubType, getTextPlainUnicodeFlavor, hashCode, isFlavorJavaFileListType, isFlavorRemoteObjectType, isFlavorSerializedObjectType, isFlavorTextType, isMimeTypeEqual, isMimeTypeSerializedObject, isRepresentationClassByteBuffer, isRepresentationClassCharBuffer, isRepresentationClassInputStream, isRepresentationClassReader, isRepresentationClassRemote, isRepresentationClassSerializable, match, readExternal, selectBestTextFlavor, toString, tryToLoadClass, writeExternal
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ActivationDataFlavor

public ActivationDataFlavor(Class representationClass,
                            String mimeType,
                            String humanPresentableName)
Construct a DataFlavor that represents an arbitrary Java object. This constructor is an extension of the JDK's DataFlavor in that it allows the explicit setting of all three DataFlavor attributes.

The returned DataFlavor will have the following characteristics:

representationClass = representationClass
mimeType = mimeType
humanName = humanName

Parameters:
representationClass - the class used in this DataFlavor
mimeType - the MIME type of the data represented by this class
humanPresentableName - the human presentable name of the flavor

ActivationDataFlavor

public ActivationDataFlavor(Class representationClass,
                            String humanPresentableName)
Construct a DataFlavor that represents a MimeType.

The returned DataFlavor will have the following characteristics:

If the mimeType is "application/x-java-serialized-object;
class=", the result is the same as calling new
DataFlavor(Class.forName()) as above.

otherwise:

representationClass = InputStream

mimeType = mimeType

Parameters:
representationClass - the class used in this DataFlavor
humanPresentableName - the human presentable name of the flavor

ActivationDataFlavor

public ActivationDataFlavor(String mimeType,
                            String humanPresentableName)
Construct a DataFlavor that represents a MimeType.

The returned DataFlavor will have the following characteristics:

If the mimeType is "application/x-java-serialized-object; class=", the result is the same as calling new DataFlavor(Class.forName()) as above, otherwise:

representationClass = InputStream

mimeType = mimeType

Parameters:
mimeType - the MIME type of the data represented by this class
humanPresentableName - the human presentable name of the flavor
Method Detail

getMimeType

public String getMimeType()
Return the MIME type for this DataFlavor.

Overrides:
getMimeType in class DataFlavor
Returns:
the MIME type

getRepresentationClass

public Class getRepresentationClass()
Return the representation class.

Overrides:
getRepresentationClass in class DataFlavor
Returns:
the representation class

getHumanPresentableName

public String getHumanPresentableName()
Return the Human Presentable name.

Overrides:
getHumanPresentableName in class DataFlavor
Returns:
the human presentable name

setHumanPresentableName

public void setHumanPresentableName(String humanPresentableName)
Set the human presentable name.

Overrides:
setHumanPresentableName in class DataFlavor
Parameters:
humanPresentableName - the name to set

equals

public boolean equals(DataFlavor dataFlavor)
Compares the DataFlavor passed in with this DataFlavor; calls the isMimeTypeEqual method.

Overrides:
equals in class DataFlavor
Parameters:
dataFlavor - the DataFlavor to compare with
Returns:
true if the MIME type and representation class are the same

isMimeTypeEqual

public boolean isMimeTypeEqual(String mimeType)
Is the string representation of the MIME type passed in equivalent to the MIME type of this DataFlavor.

ActivationDataFlavor delegates the comparison of MIME types to the MimeType class included as part of the JavaBeans Activation Framework. This provides a more robust comparison than is normally available in the DataFlavor class.

Overrides:
isMimeTypeEqual in class DataFlavor
Parameters:
mimeType - the MIME type
Returns:
true if the same MIME type

normalizeMimeTypeParameter

protected String normalizeMimeTypeParameter(String parameterName,
                                            String parameterValue)
Deprecated.

Called on DataFlavor for every MIME Type parameter to allow DataFlavor subclasses to handle special parameters like the text/plain charset parameters, whose values are case insensitive. (MIME type parameter values are supposed to be case sensitive).

This method is called for each parameter name/value pair and should return the normalized representation of the parameterValue. This method is never invoked by this implementation.

Overrides:
normalizeMimeTypeParameter in class DataFlavor
Parameters:
parameterName - the parameter name
parameterValue - the parameter value
Returns:
the normalized parameter value

normalizeMimeType

protected String normalizeMimeType(String mimeType)
Deprecated.

Called for each MIME type string to give DataFlavor subtypes the opportunity to change how the normalization of MIME types is accomplished. One possible use would be to add default parameter/value pairs in cases where none are present in the MIME type string passed in. This method is never invoked by this implementation.

Overrides:
normalizeMimeType in class DataFlavor
Parameters:
mimeType - the MIME type
Returns:
the normalized MIME type
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


CommandInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class CommandInfo

java.lang.Object
    extended by  javax.activation.CommandInfo

public class CommandInfo
extends Object

The CommandInfo class is used by CommandMap implementations to describe the results of command requests. It provides the requestor with both the verb requested, as well as an instance of the bean. There is also a method that will return the name of the class that implements the command but it is not guaranteed to return a valid value. The reason for this is to allow CommandMap implmentations that subclass CommandInfo to provide special behavior. For example a CommandMap could dynamically generate JavaBeans. In this case, it might not be possible to create an object with all the correct state information solely from the class name.

Constructor Summary
CommandInfo(String verb, String className)
The Constructor for CommandInfo.
Method Summary
String | getCommandClass() Return the command's class name.
String | getCommandName() Return the command verb.
Object | getCommandObject(DataHandler dh, ClassLoader loader) Return the instantiated JavaBean component.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CommandInfo

public CommandInfo(String verb,
                   String className)
The Constructor for CommandInfo.

Parameters:
verb - The command verb this CommandInfo decribes.
className - The command's fully qualified class name.
Method Detail

getCommandName

public String getCommandName()
Return the command verb.

Returns:
the command verb.

getCommandClass

public String getCommandClass()
Return the command's class name. This method MAY return null in cases where a CommandMap subclassed CommandInfo for its own purposes. In other words, it might not be possible to create the correct state in the command by merely knowing its class name. DO NOT DEPEND ON THIS METHOD RETURNING A VALID VALUE!

Returns:
The class name of the command, or null

getCommandObject

public Object getCommandObject(DataHandler dh,
                               ClassLoader loader)
                        throws IOException,
                               ClassNotFoundException
Return the instantiated JavaBean component.

Begin by instantiating the component with Beans.instantiate().

If the bean implements the javax.activation.CommandObject interface, call its setCommandContext method.

If the DataHandler parameter is null, then the bean is instantiated with no data. NOTE: this may be useful if for some reason the DataHandler that is passed in throws IOExceptions when this method attempts to access its InputStream. It will allow the caller to retrieve a reference to the bean if it can be instantiated.

If the bean does NOT implement the CommandObject interface, this method will check if it implements the java.io.Externalizable interface. If it does, the bean's readExternal method will be called if an InputStream can be acquired from the DataHandler.

Parameters:
dh - The DataHandler that describes the data to be passed to the command.
loader - The ClassLoader to be used to instantiate the bean.
Returns:
The bean
Throws:
IOException
ClassNotFoundException
See Also:
Beans.instantiate(java.lang.ClassLoader, java.lang.String), CommandObject
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


CommandMap

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class CommandMap

java.lang.Object
    extended by  javax.activation.CommandMap
Direct Known Subclasses:
MailcapCommandMap
public abstract class CommandMap
extends Object

The CommandMap class provides an interface to a registry of command objects available in the system. Developers are expected to either use the CommandMap implementation included with this package (MailcapCommandMap) or develop their own. Note that some of the methods in this class are abstract.

Constructor Summary
CommandMap()
Method Summary
abstract DataContentHandler | createDataContentHandler(String mimeType) Locate a DataContentHandler that corresponds to the MIME type.
DataContentHandler | createDataContentHandler(String mimeType, DataSource ds) Locate a DataContentHandler that corresponds to the MIME type.
abstract CommandInfo[] | getAllCommands(String mimeType) Get all the available commands for this type.
CommandInfo[] | getAllCommands(String mimeType, DataSource ds) Get all the available commands for this type.
abstract CommandInfo | getCommand(String mimeType, String cmdName) Get the default command corresponding to the MIME type.
CommandInfo | getCommand(String mimeType, String cmdName, DataSource ds) Get the default command corresponding to the MIME type.
static CommandMap | getDefaultCommandMap() Get the default CommandMap.
String[] | getMimeTypes() Get all the MIME types known to this command map.
abstract CommandInfo[] | getPreferredCommands(String mimeType) Get the preferred command list from a MIME Type.
CommandInfo[] | getPreferredCommands(String mimeType, DataSource ds) Get the preferred command list from a MIME Type.
static void | setDefaultCommandMap(CommandMap commandMap) Set the default CommandMap.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CommandMap

public CommandMap()
Method Detail

getDefaultCommandMap

public static CommandMap getDefaultCommandMap()
Get the default CommandMap.

  • In cases where a CommandMap instance has been previously set to some value (via setDefaultCommandMap) return the CommandMap.
  • In cases where no CommandMap has been set, the CommandMap creates an instance of MailcapCommandMap and set that to the default, returning its value.

Returns:
the CommandMap

setDefaultCommandMap

public static void setDefaultCommandMap(CommandMap commandMap)
Set the default CommandMap. Reset the CommandMap to the default by calling this method with null.

Parameters:
commandMap - The new default CommandMap.
Throws:
SecurityException - if the caller doesn't have permission to change the default

getPreferredCommands

public abstract CommandInfo[] getPreferredCommands(String mimeType)
Get the preferred command list from a MIME Type. The actual semantics are determined by the implementation of the CommandMap.

Parameters:
mimeType - the MIME type
Returns:
the CommandInfo classes that represent the command Beans.

getPreferredCommands

public CommandInfo[] getPreferredCommands(String mimeType,
                                          DataSource ds)
Get the preferred command list from a MIME Type. The actual semantics are determined by the implementation of the CommandMap.

The DataSource provides extra information, such as the file name, that a CommandMap implementation may use to further refine the list of commands that are returned. The implementation in this class simply calls the getPreferredCommands method that ignores this argument.

Parameters:
mimeType - the MIME type
ds - a DataSource for the data
Returns:
the CommandInfo classes that represent the command Beans.
Since:
JAF 1.1

getAllCommands

public abstract CommandInfo[] getAllCommands(String mimeType)
Get all the available commands for this type. This method should return all the possible commands for this MIME type.

Parameters:
mimeType - the MIME type
Returns:
the CommandInfo objects representing all the commands.

getAllCommands

public CommandInfo[] getAllCommands(String mimeType,
                                    DataSource ds)
Get all the available commands for this type. This method should return all the possible commands for this MIME type.

The DataSource provides extra information, such as the file name, that a CommandMap implementation may use to further refine the list of commands that are returned. The implementation in this class simply calls the getAllCommands method that ignores this argument.

Parameters:
mimeType - the MIME type
ds - a DataSource for the data
Returns:
the CommandInfo objects representing all the commands.
Since:
JAF 1.1

getCommand

public abstract CommandInfo getCommand(String mimeType,
                                       String cmdName)
Get the default command corresponding to the MIME type.

Parameters:
mimeType - the MIME type
cmdName - the command name
Returns:
the CommandInfo corresponding to the command.

getCommand

public CommandInfo getCommand(String mimeType,
                              String cmdName,
                              DataSource ds)
Get the default command corresponding to the MIME type.

The DataSource provides extra information, such as the file name, that a CommandMap implementation may use to further refine the command that is chosen. The implementation in this class simply calls the getCommand method that ignores this argument.

Parameters:
mimeType - the MIME type
cmdName - the command name
ds - a DataSource for the data
Returns:
the CommandInfo corresponding to the command.
Since:
JAF 1.1

createDataContentHandler

public abstract DataContentHandler createDataContentHandler(String mimeType)
Locate a DataContentHandler that corresponds to the MIME type. The mechanism and semantics for determining this are determined by the implementation of the particular CommandMap.

Parameters:
mimeType - the MIME type
Returns:
the DataContentHandler for the MIME type

createDataContentHandler

public DataContentHandler createDataContentHandler(String mimeType,
                                                   DataSource ds)
Locate a DataContentHandler that corresponds to the MIME type. The mechanism and semantics for determining this are determined by the implementation of the particular CommandMap.

The DataSource provides extra information, such as the file name, that a CommandMap implementation may use to further refine the choice of DataContentHandler. The implementation in this class simply calls the createDataContentHandler method that ignores this argument.

Parameters:
mimeType - the MIME type
ds - a DataSource for the data
Returns:
the DataContentHandler for the MIME type
Since:
JAF 1.1

getMimeTypes

public String[] getMimeTypes()
Get all the MIME types known to this command map. If the command map doesn't support this operation, null is returned.

Returns:
array of MIME types as strings, or null if not supported
Since:
JAF 1.1
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


CommandObject

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Interface CommandObject

public interface CommandObject

JavaBeans components that are Activation Framework aware implement this interface to find out which command verb they're being asked to perform, and to obtain the DataHandler representing the data they should operate on. JavaBeans that don't implement this interface may be used as well. Such commands may obtain the data using the Externalizable interface, or using an application-specific method.

Method Summary
 void setCommandContext(String verb, DataHandler dh)
Initialize the Command with the verb it is requested to handle and the DataHandler that describes the data it will operate on.

Method Detail

setCommandContext

void setCommandContext(String verb,
                       DataHandler dh)
                       throws IOException
Initialize the Command with the verb it is requested to handle and the DataHandler that describes the data it will operate on. NOTE: it is acceptable for the caller to pass null as the value for DataHandler.

Parameters:
verb - The Command Verb this object refers to.
dh - The DataHandler.
Throws:
IOException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DataContentHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Interface DataContentHandler

public interface DataContentHandler

The DataContentHandler interface is implemented by objects that can be used to extend the capabilities of the DataHandler's implementation of the Transferable interface. Through DataContentHandlers the framework can be extended to convert streams in to objects, and to write objects to streams.

Applications don't generally call the methods in DataContentHandlers directly. Instead, an application calls the equivalent methods in DataHandler. The DataHandler will attempt to find an appropriate DataContentHandler that corresponds to its MIME type using the current DataContentHandlerFactory. The DataHandler then calls through to the methods in the DataContentHandler.

Method Summary
Object | getContent(DataSource ds) Return an object representing the data in its most preferred form.
Object | getTransferData(DataFlavor df, DataSource ds) Returns an object which represents the data to be transferred.
DataFlavor[] | getTransferDataFlavors() Returns an array of DataFlavor objects indicating the flavors the data can be provided in.
void | writeTo(Object obj, String mimeType, OutputStream os) Convert the object to a byte stream of the specified MIME type and write it to the output stream.

Method Detail

getTransferDataFlavors

DataFlavor[] getTransferDataFlavors()
Returns an array of DataFlavor objects indicating the flavors the data can be provided in. The array should be ordered according to preference for providing the data (from most richly descriptive to least descriptive).

Returns:
The DataFlavors.

getTransferData

Object getTransferData(DataFlavor df,
                       DataSource ds)
                       throws UnsupportedFlavorException,
                              IOException
Returns an object which represents the data to be transferred. The class of the object returned is defined by the representation class of the flavor.

Parameters:
df - The DataFlavor representing the requested type.
ds - The DataSource representing the data to be converted.
Returns:
The constructed Object.
Throws:
UnsupportedFlavorException - if the handler doesn't support the requested flavor
IOException - if the data can't be accessed

getContent

Object getContent(DataSource ds)
                  throws IOException
Return an object representing the data in its most preferred form. Generally this will be the form described by the first DataFlavor returned by the getTransferDataFlavors method.

Parameters:
ds - The DataSource representing the data to be converted.
Returns:
The constructed Object.
Throws:
IOException - if the data can't be accessed

writeTo

void writeTo(Object obj,
             String mimeType,
             OutputStream os)
             throws IOException
Convert the object to a byte stream of the specified MIME type and write it to the output stream.

Parameters:
obj - The object to be converted.
mimeType - The requested MIME type of the resulting byte stream.
os - The output stream into which to write the converted byte stream.
Throws:
IOException - errors writing to the stream
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DataContentHandlerFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Interface DataContentHandlerFactory

public interface DataContentHandlerFactory

This interface defines a factory for DataContentHandlers. An implementation of this interface should map a MIME type into an instance of DataContentHandler. The design pattern for classes implementing this interface is the same as for the ContentHandler mechanism used in java.net.URL.

Method Summary
 DataContentHandler createDataContentHandler(String mimeType)
Creates a new DataContentHandler object for the MIME type.

Method Detail

createDataContentHandler

DataContentHandler createDataContentHandler(String mimeType)
Creates a new DataContentHandler object for the MIME type.

Parameters:
mimeType - the MIME type to create the DataContentHandler for.
Returns:
The new DataContentHandler, or null if none are found.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DataHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class DataHandler

java.lang.Object
    extended by  javax.activation.DataHandler
All Implemented Interfaces:
Transferable
public class DataHandler
extends Object
implements Transferable

The DataHandler class provides a consistent interface to data available in many different sources and formats. It manages simple stream to string conversions and related operations using DataContentHandlers. It provides access to commands that can operate on the data. The commands are found using a CommandMap.

DataHandler and the Transferable Interface

DataHandler implements the Transferable interface so that data can be used in AWT data transfer operations, such as cut and paste and drag and drop. The implementation of the Transferable interface relies on the availability of an installed DataContentHandler object corresponding to the MIME type of the data represented in the specific instance of the DataHandler.

DataHandler and CommandMaps

The DataHandler keeps track of the current CommandMap that it uses to service requests for commands (getCommand, getAllCommands, getPreferredCommands). Each instance of a DataHandler may have a CommandMap associated with it using the setCommandMap method. If a CommandMap was not set, DataHandler calls the getDefaultCommandMap method in CommandMap and uses the value it returns. See CommandMap for more information.

DataHandler and URLs

The current DataHandler implementation creates a private instance of URLDataSource when it is constructed with a URL.

See Also:
CommandMap, DataContentHandler, DataSource, URLDataSource

Constructor Summary
DataHandler(DataSource ds)
Create a DataHandler instance referencing the specified DataSource.
DataHandler(Object obj, String mimeType)
Create a DataHandler instance representing an object of this MIME type.
DataHandler(URL url)
Create a DataHandler instance referencing a URL.
Method Summary
CommandInfo[] | getAllCommands() Return all the commands for this type of data.
Object | getBean(CommandInfo cmdinfo) A convenience method that takes a CommandInfo object and instantiates the corresponding command, usually a JavaBean component.
CommandInfo | getCommand(String cmdName) Get the command cmdName.
Object | getContent() Return the data in its preferred Object form.
String | getContentType() Return the MIME type of this object as retrieved from the source object.
DataSource | getDataSource() Return the DataSource associated with this instance of DataHandler.
InputStream | getInputStream() Get the InputStream for this object.
String | getName() Return the name of the data object.
OutputStream | getOutputStream() Get an OutputStream for this DataHandler to allow overwriting the underlying data.
CommandInfo[] | getPreferredCommands() Return the preferred commands for this type of data.
Object | getTransferData(DataFlavor flavor) Returns an object that represents the data to be transferred.
DataFlavor[] | getTransferDataFlavors() Return the DataFlavors in which this data is available.
boolean | isDataFlavorSupported(DataFlavor flavor) Returns whether the specified data flavor is supported for this object.
void | setCommandMap(CommandMap commandMap) Set the CommandMap for use by this DataHandler.
static void | setDataContentHandlerFactory(DataContentHandlerFactory newFactory) Sets the DataContentHandlerFactory.
void | writeTo(OutputStream os) Write the data to an OutputStream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataHandler

public DataHandler(DataSource ds)
Create a DataHandler instance referencing the specified DataSource. The data exists in a byte stream form. The DataSource will provide an InputStream to access the data.

Parameters:
ds - the DataSource

DataHandler

public DataHandler(Object obj,
                   String mimeType)
Create a DataHandler instance representing an object of this MIME type. This constructor is used when the application already has an in-memory representation of the data in the form of a Java Object.

Parameters:
obj - the Java Object
mimeType - the MIME type of the object

DataHandler

public DataHandler(URL url)
Create a DataHandler instance referencing a URL. The DataHandler internally creates a URLDataSource instance to represent the URL.

Parameters:
url - a URL object
Method Detail

getDataSource

public DataSource getDataSource()
Return the DataSource associated with this instance of DataHandler.

For DataHandlers that have been instantiated with a DataSource, this method returns the DataSource that was used to create the DataHandler object. In other cases the DataHandler constructs a DataSource from the data used to construct the DataHandler. DataSources created for DataHandlers not instantiated with a DataSource are cached for performance reasons.

Returns:
a valid DataSource object for this DataHandler

getName

public String getName()
Return the name of the data object. If this DataHandler was created with a DataSource, this method calls through to the DataSource.getName method, otherwise it returns null.

Returns:
the name of the object

getContentType

public String getContentType()
Return the MIME type of this object as retrieved from the source object. Note that this is the full type with parameters.

Returns:
the MIME type

getInputStream

public InputStream getInputStream()
                           throws IOException
Get the InputStream for this object.

For DataHandlers instantiated with a DataSource, the DataHandler calls the DataSource.getInputStream method and returns the result to the caller.

For DataHandlers instantiated with an Object, the DataHandler first attempts to find a DataContentHandler for the Object. If the DataHandler can not find a DataContentHandler for this MIME type, it throws an UnsupportedDataTypeException. If it is successful, it creates a pipe and a thread. The thread uses the DataContentHandler's writeTo method to write the stream data into one end of the pipe. The other end of the pipe is returned to the caller. Because a thread is created to copy the data, IOExceptions that may occur during the copy can not be propagated back to the caller. The result is an empty stream.

Returns:
the InputStream representing this data
Throws:
IOException - if an I/O error occurs
See Also:
DataContentHandler.writeTo(java.lang.Object, java.lang.String, java.io.OutputStream), UnsupportedDataTypeException

writeTo

public void writeTo(OutputStream os)
             throws IOException
Write the data to an OutputStream.

If the DataHandler was created with a DataSource, writeTo retrieves the InputStream and copies the bytes from the InputStream to the OutputStream passed in.

If the DataHandler was created with an object, writeTo retrieves the DataContentHandler for the object's type. If the DataContentHandler was found, it calls the writeTo method on the DataContentHandler.

Parameters:
os - the OutputStream to write to
Throws:
IOException - if an I/O error occurs

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
Get an OutputStream for this DataHandler to allow overwriting the underlying data. If the DataHandler was created with a DataSource, the DataSource's getOutputStream method is called. Otherwise, null is returned.

Returns:
the OutputStream
Throws:
IOException
See Also:
DataSource.getOutputStream(), URLDataSource

getTransferDataFlavors

public DataFlavor[] getTransferDataFlavors()
Return the DataFlavors in which this data is available.

Returns an array of DataFlavor objects indicating the flavors the data can be provided in. The array is usually ordered according to preference for providing the data, from most richly descriptive to least richly descriptive.

The DataHandler attempts to find a DataContentHandler that corresponds to the MIME type of the data. If one is located, the DataHandler calls the DataContentHandler's getTransferDataFlavors method.

If a DataContentHandler can not be located, and if the DataHandler was created with a DataSource (or URL), one DataFlavor is returned that represents this object's MIME type and the java.io.InputStream class. If the DataHandler was created with an object and a MIME type, getTransferDataFlavors returns one DataFlavor that represents this object's MIME type and the object's class.

Specified by:
getTransferDataFlavors in interface Transferable
Returns:
an array of data flavors in which this data can be transferred
See Also:
DataContentHandler.getTransferDataFlavors()

isDataFlavorSupported

public boolean isDataFlavorSupported(DataFlavor flavor)
Returns whether the specified data flavor is supported for this object.

This method iterates through the DataFlavors returned from getTransferDataFlavors, comparing each with the specified flavor.

Specified by:
isDataFlavorSupported in interface Transferable
Parameters:
flavor - the requested flavor for the data
Returns:
true if the data flavor is supported
See Also:
getTransferDataFlavors()

getTransferData

public Object getTransferData(DataFlavor flavor)
                       throws UnsupportedFlavorException,
                              IOException
Returns an object that represents the data to be transferred. The class of the object returned is defined by the representation class of the data flavor.

For DataHandler's created with DataSources or URLs:

The DataHandler attempts to locate a DataContentHandler for this MIME type. If one is found, the passed in DataFlavor and the type of the data are passed to its getTransferData method. If the DataHandler fails to locate a DataContentHandler and the flavor specifies this object's MIME type and the java.io.InputStream class, this object's InputStream is returned. Otherwise it throws an UnsupportedFlavorException.

For DataHandler's created with Objects:

The DataHandler attempts to locate a DataContentHandler for this MIME type. If one is found, the passed in DataFlavor and the type of the data are passed to its getTransferData method. If the DataHandler fails to locate a DataContentHandler and the flavor specifies this object's MIME type and its class, this DataHandler's referenced object is returned. Otherwise it throws an UnsupportedFlavorException.

Specified by:
getTransferData in interface Transferable
Parameters:
flavor - the requested flavor for the data
Returns:
the object
Throws:
UnsupportedFlavorException - if the data could not be converted to the requested flavor
IOException - if an I/O error occurs
See Also:
ActivationDataFlavor

setCommandMap

public void setCommandMap(CommandMap commandMap)
Set the CommandMap for use by this DataHandler. Setting it to null causes the CommandMap to revert to the CommandMap returned by the CommandMap.getDefaultCommandMap method. Changing the CommandMap, or setting it to null, clears out any data cached from the previous CommandMap.

Parameters:
commandMap - the CommandMap to use in this DataHandler
See Also:
CommandMap.setDefaultCommandMap(javax.activation.CommandMap)

getPreferredCommands

public CommandInfo[] getPreferredCommands()
Return the preferred commands for this type of data. This method calls the getPreferredCommands method in the CommandMap associated with this instance of DataHandler. This method returns an array that represents a subset of available commands. In cases where multiple commands for the MIME type represented by this DataHandler are present, the installed CommandMap chooses the appropriate commands.

Returns:
the CommandInfo objects representing the preferred commands
See Also:
CommandMap.getPreferredCommands(java.lang.String)

getAllCommands

public CommandInfo[] getAllCommands()
Return all the commands for this type of data. This method returns an array containing all commands for the type of data represented by this DataHandler. The MIME type for the underlying data represented by this DataHandler is used to call through to the getAllCommands method of the CommandMap associated with this DataHandler.

Returns:
the CommandInfo objects representing all the commands
See Also:
CommandMap.getAllCommands(java.lang.String)

getCommand

public CommandInfo getCommand(String cmdName)
Get the command cmdName. Use the search semantics as defined by the CommandMap installed in this DataHandler. The MIME type for the underlying data represented by this DataHandler is used to call through to the getCommand method of the CommandMap associated with this DataHandler.

Parameters:
cmdName - the command name
Returns:
the CommandInfo corresponding to the command
See Also:
CommandMap.getCommand(java.lang.String, java.lang.String)

getContent

public Object getContent()
                  throws IOException
Return the data in its preferred Object form.

If the DataHandler was instantiated with an object, return the object.

If the DataHandler was instantiated with a DataSource, this method uses a DataContentHandler to return the content object for the data represented by this DataHandler. If no DataContentHandler can be found for the the type of this data, the DataHandler returns an InputStream for the data.

Returns:
the content.
Throws:
IOException - if an IOException occurs during this operation.

getBean

public Object getBean(CommandInfo cmdinfo)
A convenience method that takes a CommandInfo object and instantiates the corresponding command, usually a JavaBean component.

This method calls the CommandInfo's getCommandObject method with the ClassLoader used to load the javax.activation.DataHandler class itself.

Parameters:
cmdinfo - the CommandInfo corresponding to a command
Returns:
the instantiated command object

setDataContentHandlerFactory

public static void setDataContentHandlerFactory(DataContentHandlerFactory newFactory)
Sets the DataContentHandlerFactory. The DataContentHandlerFactory is called first to find DataContentHandlers. The DataContentHandlerFactory can only be set once.

If the DataContentHandlerFactory has already been set, this method throws an Error.

Parameters:
newFactory - the DataContentHandlerFactory
Throws:
Error - if the factory has already been defined.
See Also:
DataContentHandlerFactory
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DataSource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Interface DataSource

All Known Subinterfaces:
MultipartDataSource
All Known Implementing Classes:
ByteArrayDataSource, FileDataSource, MimePartDataSource, URLDataSource
public interface DataSource

The DataSource interface provides the JavaBeans Activation Framework with an abstraction of an arbitrary collection of data. It provides a type for that data as well as access to it in the form of InputStreams and OutputStreams where appropriate.

Method Summary
String | getContentType() This method returns the MIME type of the data in the form of a string.
InputStream | getInputStream() This method returns an InputStream representing the data and throws the appropriate exception if it can not do so.
String | getName() Return the name of this object where the name of the object is dependant on the nature of the underlying objects.
OutputStream | getOutputStream() This method returns an OutputStream where the data can be written and throws the appropriate exception if it can not do so.

Method Detail

getInputStream

InputStream getInputStream()
                           throws IOException
This method returns an InputStream representing the data and throws the appropriate exception if it can not do so. Note that a new InputStream object must be returned each time this method is called, and the stream must be positioned at the beginning of the data.

Returns:
an InputStream
Throws:
IOException

getOutputStream

OutputStream getOutputStream()
                             throws IOException
This method returns an OutputStream where the data can be written and throws the appropriate exception if it can not do so. Note that a new OutputStream object must be returned each time this method is called, and the stream must be positioned at the location the data is to be written.

Returns:
an OutputStream
Throws:
IOException

getContentType

String getContentType()
This method returns the MIME type of the data in the form of a string. It should always return a valid type. It is suggested that getContentType return "application/octet-stream" if the DataSource implementation can not determine the data type.

Returns:
the MIME Type

getName

String getName()
Return the name of this object where the name of the object is dependant on the nature of the underlying objects. DataSources encapsulating files may choose to return the filename of the object. (Typically this would be the last component of the filename, not an entire pathname.)

Returns:
the name of the object.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FileDataSource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class FileDataSource

java.lang.Object
    extended by  javax.activation.FileDataSource
All Implemented Interfaces:
DataSource
public class FileDataSource
extends Object
implements DataSource

The FileDataSource class implements a simple DataSource object that encapsulates a file. It provides data typing services via a FileTypeMap object.

FileDataSource Typing Semantics

The FileDataSource class delegates data typing of files to an object subclassed from the FileTypeMap class. The setFileTypeMap method can be used to explicitly set the FileTypeMap for an instance of FileDataSource. If no FileTypeMap is set, the FileDataSource will call the FileTypeMap's getDefaultFileTypeMap method to get the System's default FileTypeMap.

See Also:
DataSource, FileTypeMap, MimetypesFileTypeMap

Constructor Summary
FileDataSource(File file)
Creates a FileDataSource from a File object.
FileDataSource(String name)
Creates a FileDataSource from the specified path name.
Method Summary
String | getContentType() This method returns the MIME type of the data in the form of a string.
File | getFile() Return the File object that corresponds to this FileDataSource.
InputStream | getInputStream() This method will return an InputStream representing the the data and will throw an IOException if it can not do so.
String | getName() Return the name of this object.
OutputStream | getOutputStream() This method will return an OutputStream representing the the data and will throw an IOException if it can not do so.
void | setFileTypeMap(FileTypeMap map) Set the FileTypeMap to use with this FileDataSource
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FileDataSource

public FileDataSource(File file)
Creates a FileDataSource from a File object. Note: The file will not actually be opened until a method is called that requires the file to be opened.

Parameters:
file - the file

FileDataSource

public FileDataSource(String name)
Creates a FileDataSource from the specified path name. Note: The file will not actually be opened until a method is called that requires the file to be opened.

Parameters:
name - the system-dependent file name.
Method Detail

getInputStream

public InputStream getInputStream()
                           throws IOException
This method will return an InputStream representing the the data and will throw an IOException if it can not do so. This method will return a new instance of InputStream with each invocation.

Specified by:
getInputStream in interface DataSource
Returns:
an InputStream
Throws:
IOException

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
This method will return an OutputStream representing the the data and will throw an IOException if it can not do so. This method will return a new instance of OutputStream with each invocation.

Specified by:
getOutputStream in interface DataSource
Returns:
an OutputStream
Throws:
IOException

getContentType

public String getContentType()
This method returns the MIME type of the data in the form of a string. This method uses the currently installed FileTypeMap. If there is no FileTypeMap explictly set, the FileDataSource will call the getDefaultFileTypeMap method on FileTypeMap to acquire a default FileTypeMap. Note: By default, the FileTypeMap used will be a MimetypesFileTypeMap.

Specified by:
getContentType in interface DataSource
Returns:
the MIME Type
See Also:
FileTypeMap.getDefaultFileTypeMap()

getName

public String getName()
Return the name of this object. The FileDataSource will return the file name of the object.

Specified by:
getName in interface DataSource
Returns:
the name of the object.
See Also:
DataSource

getFile

public File getFile()
Return the File object that corresponds to this FileDataSource.

Returns:
the File object for the file represented by this object.

setFileTypeMap

public void setFileTypeMap(FileTypeMap map)
Set the FileTypeMap to use with this FileDataSource

Parameters:
map - The FileTypeMap for this object.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FileTypeMap

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class FileTypeMap

java.lang.Object
    extended by  javax.activation.FileTypeMap
Direct Known Subclasses:
MimetypesFileTypeMap
public abstract class FileTypeMap
extends Object

The FileTypeMap is an abstract class that provides a data typing interface for files. Implementations of this class will implement the getContentType methods which will derive a content type from a file name or a File object. FileTypeMaps could use any scheme to determine the data type, from examining the file extension of a file (like the MimetypesFileTypeMap) to opening the file and trying to derive its type from the contents of the file. The FileDataSource class uses the default FileTypeMap (a MimetypesFileTypeMap unless changed) to determine the content type of files.

See Also:
FileTypeMap, FileDataSource, MimetypesFileTypeMap

Constructor Summary
FileTypeMap()
The default constructor.
Method Summary
abstract String | getContentType(File file) Return the type of the file object.
abstract String | getContentType(String filename) Return the type of the file passed in.
static FileTypeMap | getDefaultFileTypeMap() Return the default FileTypeMap for the system.
static void | setDefaultFileTypeMap(FileTypeMap map) Sets the default FileTypeMap for the system.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FileTypeMap

public FileTypeMap()
The default constructor.

Method Detail

getContentType

public abstract String getContentType(File file)
Return the type of the file object. This method should always return a valid MIME type.

Parameters:
file - A file to be typed.
Returns:
The content type.

getContentType

public abstract String getContentType(String filename)
Return the type of the file passed in. This method should always return a valid MIME type.

Parameters:
filename - the pathname of the file.
Returns:
The content type.

setDefaultFileTypeMap

public static void setDefaultFileTypeMap(FileTypeMap map)
Sets the default FileTypeMap for the system. This instance will be returned to callers of getDefaultFileTypeMap.

Parameters:
map - The FileTypeMap.
Throws:
SecurityException - if the caller doesn't have permission to change the default

getDefaultFileTypeMap

public static FileTypeMap getDefaultFileTypeMap()
Return the default FileTypeMap for the system. If setDefaultFileTypeMap was called, return that instance, otherwise return an instance of MimetypesFileTypeMap.

Returns:
The default FileTypeMap
See Also:
setDefaultFileTypeMap(javax.activation.FileTypeMap)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MailcapCommandMap

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class MailcapCommandMap

java.lang.Object
    extended by  javax.activation.CommandMap
        extended by  javax.activation.MailcapCommandMap

public class MailcapCommandMap
extends CommandMap

MailcapCommandMap extends the CommandMap abstract class. It implements a CommandMap whose configuration is based on mailcap files (RFC 1524). The MailcapCommandMap can be configured both programmatically and via configuration files.

Mailcap file search order:

The MailcapCommandMap looks in various places in the user's system for mailcap file entries. When requests are made to search for commands in the MailcapCommandMap, it searches mailcap files in the following order:

  1. Programatically added entries to the MailcapCommandMap instance.
  2. The file .mailcap in the user's home directory.
  3. The file <java.home>/lib/mailcap.
  4. The file or resources named META-INF/mailcap.
  5. The file or resource named META-INF/mailcap.default (usually found only in the activation.jar file).

Mailcap file format:

Mailcap files must conform to the mailcap file specification (RFC 1524, A User Agent Configuration Mechanism For Multimedia Mail Format Information). The file format consists of entries corresponding to particular MIME types. In general, the specification specifies applications for clients to use when they themselves cannot operate on the specified MIME type. The MailcapCommandMap extends this specification by using a parameter mechanism in mailcap files that allows JavaBeans(tm) components to be specified as corresponding to particular commands for a MIME type.

When a mailcap file is parsed, the MailcapCommandMap recognizes certain parameter signatures, specifically those parameter names that begin with x-java-. The MailcapCommandMap uses this signature to find command entries for inclusion into its registries. Parameter names with the form x-java-<name> are read by the MailcapCommandMap as identifying a command with the name name. When the name is content-handler the MailcapCommandMap recognizes the class signified by this parameter as a DataContentHandler. All other commands are handled generically regardless of command name. The command implementation is specified by a fully qualified class name of a JavaBean(tm) component. For example; a command for viewing some data can be specified as: x-java-view=com.foo.ViewBean.

When the command name is fallback-entry, the value of the command may be true or false. An entry for a MIME type that includes a parameter of x-java-fallback-entry=true defines fallback commands for that MIME type that will only be used if no non-fallback entry can be found. For example, an entry of the form text/*; ; x-java-fallback-entry=true; x-java-view=com.sun.TextViewer specifies a view command to be used for any text MIME type. This view command would only be used if a non-fallback view command for the MIME type could not be found.

MailcapCommandMap aware mailcap files have the following general form:

# Comments begin with a '#' and continue to the end of the line.
<mime type>; ; <parameter list>
# Where a parameter list consists of one or more parameters,
# where parameters look like: x-java-view=com.sun.TextViewer
# and a parameter list looks like:
text/plain; ; x-java-view=com.sun.TextViewer; x-java-edit=com.sun.TextEdit
# Note that mailcap entries that do not contain 'x-java' parameters
# and comply to RFC 1524 are simply ignored:
image/gif; /usr/dt/bin/sdtimage %s

Author:
Bart Calder, Bill Shannon

Constructor Summary
MailcapCommandMap()
The default Constructor.
MailcapCommandMap(InputStream is)
Constructor that allows the caller to specify an InputStream containing a mailcap file.
MailcapCommandMap(String fileName)
Constructor that allows the caller to specify the path of a mailcap file.
Method Summary
void | addMailcap(String mail_cap) Add entries to the registry.
DataContentHandler | createDataContentHandler(String mimeType) Return the DataContentHandler for the specified MIME type.
CommandInfo[] | getAllCommands(String mimeType) Get all the available commands in all mailcap files known to this instance of MailcapCommandMap for this MIME type.
CommandInfo | getCommand(String mimeType, String cmdName) Get the command corresponding to cmdName for the MIME type.
String[] | getMimeTypes() Get all the MIME types known to this command map.
String[] | getNativeCommands(String mimeType) Get the native commands for the given MIME type.
CommandInfo[] | getPreferredCommands(String mimeType) Get the preferred command list for a MIME Type.
Methods inherited from class javax.activation.CommandMap
createDataContentHandler, getAllCommands, getCommand, getDefaultCommandMap, getPreferredCommands, setDefaultCommandMap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MailcapCommandMap

public MailcapCommandMap()
The default Constructor.

MailcapCommandMap

public MailcapCommandMap(String fileName)
                  throws IOException
Constructor that allows the caller to specify the path of a mailcap file.

Parameters:
fileName - The name of the mailcap file to open
Throws:
IOException - if the file can't be accessed

MailcapCommandMap

public MailcapCommandMap(InputStream is)
Constructor that allows the caller to specify an InputStream containing a mailcap file.

Parameters:
is - InputStream of the mailcap file to open
Method Detail

getPreferredCommands

public CommandInfo[] getPreferredCommands(String mimeType)
Get the preferred command list for a MIME Type. The MailcapCommandMap searches the mailcap files as described above under Mailcap file search order.

The result of the search is a proper subset of available commands in all mailcap files known to this instance of MailcapCommandMap. The first entry for a particular command is considered the preferred command.

Specified by:
getPreferredCommands in class CommandMap
Parameters:
mimeType - the MIME type
Returns:
the CommandInfo objects representing the preferred commands.

getAllCommands

public CommandInfo[] getAllCommands(String mimeType)
Get all the available commands in all mailcap files known to this instance of MailcapCommandMap for this MIME type.

Specified by:
getAllCommands in class CommandMap
Parameters:
mimeType - the MIME type
Returns:
the CommandInfo objects representing all the commands.

getCommand

public CommandInfo getCommand(String mimeType,
                              String cmdName)
Get the command corresponding to cmdName for the MIME type.

Specified by:
getCommand in class CommandMap
Parameters:
mimeType - the MIME type
cmdName - the command name
Returns:
the CommandInfo object corresponding to the command.

addMailcap

public void addMailcap(String mail_cap)
Add entries to the registry. Programmatically added entries are searched before other entries.

The string that is passed in should be in mailcap format.

Parameters:
mail_cap - a correctly formatted mailcap string

createDataContentHandler

public DataContentHandler createDataContentHandler(String mimeType)
Return the DataContentHandler for the specified MIME type.

Specified by:
createDataContentHandler in class CommandMap
Parameters:
mimeType - the MIME type
Returns:
the DataContentHandler

getMimeTypes

public String[] getMimeTypes()
Get all the MIME types known to this command map.

Overrides:
getMimeTypes in class CommandMap
Returns:
array of MIME types as strings
Since:
JAF 1.1

getNativeCommands

public String[] getNativeCommands(String mimeType)
Get the native commands for the given MIME type. Returns an array of strings where each string is an entire mailcap file entry. The application will need to parse the entry to extract the actual command as well as any attributes it needs. See RFC 1524 for details of the mailcap entry syntax. Only mailcap entries that specify a view command for the specified MIME type are returned.

Returns:
array of native command entries
Since:
JAF 1.1
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MimeType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class MimeType

java.lang.Object
    extended by  javax.activation.MimeType
All Implemented Interfaces:
Externalizable, Serializable
public class MimeType
extends Object
implements Externalizable

A Multipurpose Internet Mail Extension (MIME) type, as defined in RFC 2045 and 2046.

See Also:
Serialized Form

Constructor Summary
MimeType()
Default constructor.
MimeType(String rawdata)
Constructor that builds a MimeType from a String.
MimeType(String primary, String sub)
Constructor that builds a MimeType with the given primary and sub type but has an empty parameter list.
Method Summary
String | getBaseType() Return a String representation of this object without the parameter list.
String | getParameter(String name) Retrieve the value associated with the given name, or null if there is no current association.
MimeTypeParameterList | getParameters() Retrieve this object's parameter list.
String | getPrimaryType() Retrieve the primary type of this object.
String | getSubType() Retrieve the subtype of this object.
boolean | match(MimeType type) Determine if the primary and sub type of this object is the same as what is in the given type.
boolean | match(String rawdata) Determine if the primary and sub type of this object is the same as the content type described in rawdata.
void | readExternal(ObjectInput in) The object implements the readExternal method to restore its contents by calling the methods of DataInput for primitive types and readObject for objects, strings and arrays.
void | removeParameter(String name) Remove any value associated with the given name.
void | setParameter(String name, String value) Set the value to be associated with the given name, replacing any previous association.
void | setPrimaryType(String primary) Set the primary type for this object to the given String.
void | setSubType(String sub) Set the subtype for this object to the given String.
String | toString() Return the String representation of this object.
void | writeExternal(ObjectOutput out) The object implements the writeExternal method to save its contents by calling the methods of DataOutput for its primitive values or calling the writeObject method of ObjectOutput for objects, strings and arrays.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MimeType

public MimeType()
Default constructor.

MimeType

public MimeType(String rawdata)
         throws MimeTypeParseException
Constructor that builds a MimeType from a String.

Parameters:
rawdata - the MIME type string
Throws:
MimeTypeParseException

MimeType

public MimeType(String primary,
                String sub)
         throws MimeTypeParseException
Constructor that builds a MimeType with the given primary and sub type but has an empty parameter list.

Parameters:
primary - the primary MIME type
sub - the MIME sub-type
Throws:
MimeTypeParseException - if the primary type or subtype is not a valid token
Method Detail

getPrimaryType

public String getPrimaryType()
Retrieve the primary type of this object.

Returns:
the primary MIME type

setPrimaryType

public void setPrimaryType(String primary)
                    throws MimeTypeParseException
Set the primary type for this object to the given String.

Parameters:
primary - the primary MIME type
Throws:
MimeTypeParseException - if the primary type is not a valid token

getSubType

public String getSubType()
Retrieve the subtype of this object.

Returns:
the MIME subtype

setSubType

public void setSubType(String sub)
                throws MimeTypeParseException
Set the subtype for this object to the given String.

Parameters:
sub - the MIME subtype
Throws:
MimeTypeParseException - if the subtype is not a valid token

getParameters

public MimeTypeParameterList getParameters()
Retrieve this object's parameter list.

Returns:
a MimeTypeParameterList object representing the parameters

getParameter

public String getParameter(String name)
Retrieve the value associated with the given name, or null if there is no current association.

Parameters:
name - the parameter name
Returns:
the paramter's value

setParameter

public void setParameter(String name,
                         String value)
Set the value to be associated with the given name, replacing any previous association.

Parameters:
name - the parameter name
value - the paramter's value

removeParameter

public void removeParameter(String name)
Remove any value associated with the given name.

Parameters:
name - the parameter name

toString

public String toString()
Return the String representation of this object.

Overrides:
toString in class Object

getBaseType

public String getBaseType()
Return a String representation of this object without the parameter list.

Returns:
the MIME type and sub-type

match

public boolean match(MimeType type)
Determine if the primary and sub type of this object is the same as what is in the given type.

Parameters:
type - the MimeType object to compare with
Returns:
true if they match

match

public boolean match(String rawdata)
              throws MimeTypeParseException
Determine if the primary and sub type of this object is the same as the content type described in rawdata.

Parameters:
rawdata - the MIME type string to compare with
Returns:
true if they match
Throws:
MimeTypeParseException

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException
The object implements the writeExternal method to save its contents by calling the methods of DataOutput for its primitive values or calling the writeObject method of ObjectOutput for objects, strings and arrays.

Specified by:
writeExternal in interface Externalizable
Parameters:
out - the ObjectOutput object to write to
Throws:
IOException - Includes any I/O exceptions that may occur

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
The object implements the readExternal method to restore its contents by calling the methods of DataInput for primitive types and readObject for objects, strings and arrays. The readExternal method must read the values in the same sequence and with the same types as were written by writeExternal.

Specified by:
readExternal in interface Externalizable
Parameters:
in - the ObjectInput object to read from
Throws:
ClassNotFoundException - If the class for an object being restored cannot be found.
IOException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MimeTypeParameterList

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class MimeTypeParameterList

java.lang.Object
    extended by  javax.activation.MimeTypeParameterList

public class MimeTypeParameterList
extends Object

A parameter list of a MimeType as defined in RFC 2045 and 2046. The Primary type of the object must already be stripped off.

See Also:
MimeType

Constructor Summary
MimeTypeParameterList()
Default constructor.
MimeTypeParameterList(String parameterList)
Constructs a new MimeTypeParameterList with the passed in data.
Method Summary
String | get(String name) Retrieve the value associated with the given name, or null if there is no current association.
Enumeration | getNames() Retrieve an enumeration of all the names in this list.
boolean | isEmpty() Determine whether or not this list is empty.
protected void | parse(String parameterList) A routine for parsing the parameter list out of a String.
void | remove(String name) Remove any value associated with the given name.
void | set(String name, String value) Set the value to be associated with the given name, replacing any previous association.
int | size() Return the number of name-value pairs in this list.
String | toString() Return a string representation of this object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MimeTypeParameterList

public MimeTypeParameterList()
Default constructor.

MimeTypeParameterList

public MimeTypeParameterList(String parameterList)
                      throws MimeTypeParseException
Constructs a new MimeTypeParameterList with the passed in data.

Parameters:
parameterList - an RFC 2045, 2046 compliant parameter list.
Throws:
MimeTypeParseException
Method Detail

parse

protected void parse(String parameterList)
              throws MimeTypeParseException
A routine for parsing the parameter list out of a String.

Parameters:
parameterList - an RFC 2045, 2046 compliant parameter list.
Throws:
MimeTypeParseException

size

public int size()
Return the number of name-value pairs in this list.

Returns:
the number of parameters

isEmpty

public boolean isEmpty()
Determine whether or not this list is empty.

Returns:
true if there are no parameters

get

public String get(String name)
Retrieve the value associated with the given name, or null if there is no current association.

Parameters:
name - the parameter name
Returns:
the parameter's value

set

public void set(String name,
                String value)
Set the value to be associated with the given name, replacing any previous association.

Parameters:
name - the parameter name
value - the parameter's value

remove

public void remove(String name)
Remove any value associated with the given name.

Parameters:
name - the parameter name

getNames

public Enumeration getNames()
Retrieve an enumeration of all the names in this list.

Returns:
an enumeration of all parameter names

toString

public String toString()
Return a string representation of this object.

Overrides:
toString in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MimeTypeParseException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class MimeTypeParseException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.activation.MimeTypeParseException
All Implemented Interfaces:
Serializable
public class MimeTypeParseException
extends Exception

A class to encapsulate MimeType parsing related exceptions.

See Also:
Serialized Form

Constructor Summary
MimeTypeParseException()
Constructs a MimeTypeParseException with no specified detail message.
MimeTypeParseException(String s)
Constructs a MimeTypeParseException with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MimeTypeParseException

public MimeTypeParseException()
Constructs a MimeTypeParseException with no specified detail message.

MimeTypeParseException

public MimeTypeParseException(String s)
Constructs a MimeTypeParseException with the specified detail message.

Parameters:
s - the detail message.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MimetypesFileTypeMap

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class MimetypesFileTypeMap

java.lang.Object
    extended by  javax.activation.FileTypeMap
        extended by  javax.activation.MimetypesFileTypeMap

public class MimetypesFileTypeMap
extends FileTypeMap

This class extends FileTypeMap and provides data typing of files via their file extension. It uses the .mime.types format.

MIME types file search order:

The MimetypesFileTypeMap looks in various places in the user's system for MIME types file entries. When requests are made to search for MIME types in the MimetypesFileTypeMap, it searches MIME types files in the following order:

  1. Programmatically added entries to the MimetypesFileTypeMap instance.
  2. The file .mime.types in the user's home directory.
  3. The file <java.home>/lib/mime.types.
  4. The file or resources named META-INF/mime.types.
  5. The file or resource named META-INF/mimetypes.default (usually found only in the activation.jar file).

MIME types file format:

# comments begin with a '#'
# the format is <mime type> <space separated file extensions>
# for example:
text/plain txt text TXT
# this would map file.txt, file.text, and file.TXT to
# the mime type "text/plain"

Author:
Bart Calder, Bill Shannon

Constructor Summary
MimetypesFileTypeMap()
The default constructor.
MimetypesFileTypeMap(InputStream is)
Construct a MimetypesFileTypeMap with programmatic entries added from the InputStream.
MimetypesFileTypeMap(String mimeTypeFileName)
Construct a MimetypesFileTypeMap with programmatic entries added from the named file.
Method Summary
void | addMimeTypes(String mime_types) Prepend the MIME type values to the registry.
String | getContentType(File f) Return the MIME type of the file object.
String | getContentType(String filename) Return the MIME type based on the specified file name.
Methods inherited from class javax.activation.FileTypeMap
getDefaultFileTypeMap, setDefaultFileTypeMap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MimetypesFileTypeMap

public MimetypesFileTypeMap()
The default constructor.

MimetypesFileTypeMap

public MimetypesFileTypeMap(String mimeTypeFileName)
                     throws IOException
Construct a MimetypesFileTypeMap with programmatic entries added from the named file.

Parameters:
mimeTypeFileName - the file name
Throws:
IOException

MimetypesFileTypeMap

public MimetypesFileTypeMap(InputStream is)
Construct a MimetypesFileTypeMap with programmatic entries added from the InputStream.

Parameters:
is - the input stream to read from
Method Detail

addMimeTypes

public void addMimeTypes(String mime_types)
Prepend the MIME type values to the registry.

Parameters:
mime_types - A .mime.types formatted string of entries.

getContentType

public String getContentType(File f)
Return the MIME type of the file object. The implementation in this class calls getContentType(f.getName()).

Specified by:
getContentType in class FileTypeMap
Parameters:
f - the file
Returns:
the file's MIME type

getContentType

public String getContentType(String filename)
Return the MIME type based on the specified file name. The MIME type entries are searched as described above under MIME types file search order. If no entry is found, the type "application/octet-stream" is returned.

Specified by:
getContentType in class FileTypeMap
Parameters:
filename - the file name
Returns:
the file's MIME type
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UnsupportedDataTypeException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class UnsupportedDataTypeException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.io.IOException
                extended by  javax.activation.UnsupportedDataTypeException
All Implemented Interfaces:
Serializable
public class UnsupportedDataTypeException
extends IOException

Signals that the requested operation does not support the requested data type.

See Also:
DataHandler, Serialized Form

Constructor Summary
UnsupportedDataTypeException()
Constructs an UnsupportedDataTypeException with no detail message.
UnsupportedDataTypeException(String s)
Constructs an UnsupportedDataTypeException with the specified message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnsupportedDataTypeException

public UnsupportedDataTypeException()
Constructs an UnsupportedDataTypeException with no detail message.

UnsupportedDataTypeException

public UnsupportedDataTypeException(String s)
Constructs an UnsupportedDataTypeException with the specified message.

Parameters:
s - The detail message.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


URLDataSource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.activation
Class URLDataSource

java.lang.Object
    extended by  javax.activation.URLDataSource
All Implemented Interfaces:
DataSource
public class URLDataSource
extends Object
implements DataSource

The URLDataSource class provides an object that wraps a URL object in a DataSource interface. URLDataSource simplifies the handling of data described by URLs within the JavaBeans Activation Framework because this class can be used to create new DataHandlers. NOTE: The DataHandler object creates a URLDataSource internally, when it is constructed with a URL.

See Also:
DataSource, DataHandler

Constructor Summary
URLDataSource(URL url)
URLDataSource constructor.
Method Summary
String | getContentType() Returns the value of the URL content-type header field.
InputStream | getInputStream() The getInputStream method from the URL.
String | getName() Calls the getFile method on the URL used to instantiate the object.
OutputStream | getOutputStream() The getOutputStream method from the URL.
URL | getURL() Return the URL used to create this DataSource.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

URLDataSource

public URLDataSource(URL url)
URLDataSource constructor. The URLDataSource class will not open a connection to the URL until a method requiring it to do so is called.

Parameters:
url - The URL to be encapsulated in this object.
Method Detail

getContentType

public String getContentType()
Returns the value of the URL content-type header field. It calls the URL's URLConnection.getContentType method after retrieving a URLConnection object. Note: this method attempts to call the openConnection method on the URL. If this method fails, or if a content type is not returned from the URLConnection, getContentType returns "application/octet-stream" as the content type.

Specified by:
getContentType in interface DataSource
Returns:
the content type.

getName

public String getName()
Calls the getFile method on the URL used to instantiate the object.

Specified by:
getName in interface DataSource
Returns:
the result of calling the URL's getFile method.

getInputStream

public InputStream getInputStream()
                           throws IOException
The getInputStream method from the URL. Calls the openStream method on the URL.

Specified by:
getInputStream in interface DataSource
Returns:
the InputStream.
Throws:
IOException

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
The getOutputStream method from the URL. First an attempt is made to get the URLConnection object for the URL. If that succeeds, the getOutputStream method on the URLConnection is returned.

Specified by:
getOutputStream in interface DataSource
Returns:
the OutputStream.
Throws:
IOException

getURL

public URL getURL()
Return the URL used to create this DataSource.

Returns:
The URL.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


annotation

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.annotation

This package defines the common annotations.

See:
Description

Enum Summary
Resource.AuthenticationType The two possible authentication types for a resource.

Annotation Types Summary
Generated | The Generated annoation is used to mark source code that has been generated.
PostConstruct | The PostConstruct annotation is used on a method that needs to be executed after dependency injection is done to perform any initialization.
PreDestroy | The PreDestroy annotation is used on methods as a callback notification to signal that the instance is in the process of being removed by the container.
Resource | The Resource annotation marks a resource that is needed by the application.
Resources | This class is used to allow multiple resources declarations.

Package javax.annotation Description

This package defines the common annotations.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.annotation Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.annotation

Package Hierarchies:
All Packages

Annotation Type Hierarchy

  • javax.annotation.Generated (implements java.lang.annotation.Annotation)
  • javax.annotation.PostConstruct (implements java.lang.annotation.Annotation)
  • javax.annotation.PreDestroy (implements java.lang.annotation.Annotation)
  • javax.annotation.Resource (implements java.lang.annotation.Annotation)
  • javax.annotation.Resources (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.annotation.Resource.AuthenticationType
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PostConstruct

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.annotation
Annotation Type PostConstruct

@Documented
@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface PostConstruct

The PostConstruct annotation is used on a method that needs to be executed after dependency injection is done to perform any initialization. This method MUST be invoked before the class is put into service. This annotation MUST be supported on all classes that support dependency injection. The method annotated with PostConstruct MUST be invoked even if the class does not request any resources to be injected. Only one method can be annotated with this annotation. The method on which the PostConstruct annotation is applied MUST fulfill all of the following criteria - - The method MUST NOT have any parameters except in the case of EJB interceptors in which case it takes an InvocationC ontext object as defined by the EJB specification. - The return type of the method MUST be void. - The method MUST NOT throw a checked exception. - The method on which PostConstruct is applied MAY be public, protected, package private or private. - The method MUST NOT be static except for the application client. - The method MAY be final. - If the method throws an unchecked exception the class MUST NOT be put into service except in the case of EJBs where the EJB can handle exceptions and even recover from them.

Since:
Common Annotations 1.0
See Also:
PreDestroy, Resource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PreDestroy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.annotation
Annotation Type PreDestroy

@Documented
@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface PreDestroy

The PreDestroy annotation is used on methods as a callback notification to signal that the instance is in the process of being removed by the container. The method annotated with PreDestroy is typically used to release resources that it has been holding. This annotation MUST be supported by all container managed objects that support PostConstruct except the application client container in Java EE 5. The method on which the PreDestroy annotation is applied MUST fulfill all of the following criteria - - The method MUST NOT have any parameters except in the case of EJB interceptors in which case it takes an InvocationContext object as defined by the EJB specification. - The return type of the method MUST be void. - The method MUST NOT throw a checked exception. - The method on which PreDestroy is applied MAY be public, protected, package private or private. - The method MUST NOT be static. - The method MAY be final. - If the method throws an unchecked exception it is ignored except in the case of EJBs where the EJB can handle exceptions.

Since:
Common Annotations 1.0
See Also:
PostConstruct, Resource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Generated

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.annotation
Annotation Type Generated

@Documented
@Retention(value=SOURCE)
@Target(value={PACKAGE,TYPE,ANNOTATION_TYPE,METHOD,CONSTRUCTOR,FIELD,LOCAL_VARIABLE,PARAMETER})
public @interface Generated

The Generated annoation is used to mark source code that has been generated. It can also be used to differentiate user written code from generated code in a single file. When used, the value element must have the name of the code generator. The recommended convention is to use the fully qualified name of the code generator in the value field . For example: com.company.package.classname. The date element is used to indicate the date the source was generated. The date element must follow the ISO 8601 standard. For example the date element would have the following value 2001-07-04T12:08:56.235-0700 which represents 2001-07-04 12:08:56 local time in the U.S. Pacific Time time zone. The comment element is a place holder for any comments that the code generator may want to include in the generated code.

Since:
Common Annotations 1.0

Required Element Summary
 String[] value
This is used by the code generator to mark the generated classes and methods.
Optional Element Summary
String | comments A place holder for any comments that the code generator may want to include in the generated code.
String | date Date when the source was generated.

Element Detail

value

public abstract String[] value
This is used by the code generator to mark the generated classes and methods.

date

public abstract String date
Date when the source was generated.

Default:
""

comments

public abstract String comments
A place holder for any comments that the code generator may want to include in the generated code.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Resource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.annotation
Annotation Type Resource

@Target(value={TYPE,FIELD,METHOD})
@Retention(value=RUNTIME)
public @interface Resource

The Resource annotation marks a resource that is needed by the application. This annotation may be applied to an application component class, or to fields or methods of the component class. When the annotation is applied to a field or method, the container will inject an instance of the requested resource into the application component when the component is initialized. If the annotation is applied to the component class, the annotation declares a resource that the application will look up at runtime.

Even though this annotation is not marked Inherited, deployment tools are required to examine all superclasses of any component class to discover all uses of this annotation in all superclasses. All such annotation instances specify resources that are needed by the application component. Note that this annotation may appear on private fields and methods of superclasses; the container is required to perform injection in these cases as well.

Since:
Common Annotations 1.0

Optional Element Summary
Resource.AuthenticationType | authenticationType The authentication type to use for this resource.
String | description Description of this resource.
String | mappedName A product specific name that this resource should be mapped to.
String | name The JNDI name of the resource.
boolean | shareable Indicates whether this resource can be shared between this component and other components.
Class | type The Java type of the resource.

name

public abstract String name
The JNDI name of the resource. For field annotations, the default is the field name. For method annotations, the default is the JavaBeans property name corresponding to the method. For class annotations, there is no default and this must be specified.

Default:
""

type

public abstract Class type
The Java type of the resource. For field annotations, the default is the type of the field. For method annotations, the default is the type of the JavaBeans property. For class annotations, there is no default and this must be specified.

Default:
java.lang.Object.class

authenticationType

public abstract Resource.AuthenticationType authenticationType
The authentication type to use for this resource. This may be specified for resources representing a connection factory of any supported type, and must not be specified for resources of other types.

Default:
CONTAINER

shareable

public abstract boolean shareable
Indicates whether this resource can be shared between this component and other components. This may be specified for resources representing a connection factory of any supported type, and must not be specified for resources of other types.

Default:
true

mappedName

public abstract String mappedName
A product specific name that this resource should be mapped to. The name of this resource, as defined by the name element or defaulted, is a name that is local to the application component using the resource. (It's a name in the JNDI java:comp/env namespace.) Many application servers provide a way to map these local names to names of resources known to the application server. This mapped name is often a global JNDI name, but may be a name of any form.

Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.

Default:
""

description

public abstract String description
Description of this resource. The description is expected to be in the default language of the system on which the application is deployed. The description can be presented to the Deployer to help in choosing the correct resource.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Resource.AuthenticationType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.annotation
Enum Resource.AuthenticationType

java.lang.Object
    extended by  java.lang.Enum<Resource.AuthenticationType>
        extended by  javax.annotation.Resource.AuthenticationType
All Implemented Interfaces:
Serializable, Comparable<Resource.AuthenticationType>
Enclosing class:
Resource
public static enum Resource.AuthenticationType
extends Enum<Resource.AuthenticationType>

The two possible authentication types for a resource.

Enum Constant Summary
APPLICATION
CONTAINER
Method Summary
static Resource.AuthenticationType | valueOf(String name) Returns the enum constant of this type with the specified name.
static Resource.AuthenticationType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

CONTAINER

public static final Resource.AuthenticationType CONTAINER

APPLICATION

public static final Resource.AuthenticationType APPLICATION
Method Detail

values

public static final Resource.AuthenticationType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(Resource.AuthenticationType c : Resource.AuthenticationType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static Resource.AuthenticationType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Resources

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.annotation
Annotation Type Resources

@Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface Resources

This class is used to allow multiple resources declarations.

Since:
Common Annotations 1.0
See Also:
Resource

Required Element Summary
 Resource[] value
Array used for multiple resource declarations.

Element Detail

value

public abstract Resource[] value
Array used for multiple resource declarations.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


security

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.annotation.security

This package contains the security common annotations.

See:
Description

Annotation Types Summary
DeclareRoles | Used by application to declare roles.
DenyAll | Specifies that no security roles are allowed to invoke the specified method(s) - i.e that the methods are to be excluded from execution in the J2EE container.
PermitAll | Specifies that all security roles are allowed to invoke the specified method(s) i.e that the specified method(s) are "unchecked".
RolesAllowed | Specifies the list of roles permitted to access method(s) in an application.
RunAs | Defines the identity of the application during execution in a J2EE container.

Package javax.annotation.security Description

This package contains the security common annotations.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DenyAll

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.annotation.security
Annotation Type DenyAll

@Documented
@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface DenyAll

Specifies that no security roles are allowed to invoke the specified method(s) - i.e that the methods are to be excluded from execution in the J2EE container.

Since:
Common Annotations 1.0
See Also:
RolesAllowed, PermitAll

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.annotation.security Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.annotation.security

Package Hierarchies:
All Packages

Annotation Type Hierarchy

  • javax.annotation.security.DeclareRoles (implements java.lang.annotation.Annotation)
  • javax.annotation.security.DenyAll (implements java.lang.annotation.Annotation)
  • javax.annotation.security.PermitAll (implements java.lang.annotation.Annotation)
  • javax.annotation.security.RolesAllowed (implements java.lang.annotation.Annotation)
  • javax.annotation.security.RunAs (implements java.lang.annotation.Annotation)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PermitAll

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.annotation.security
Annotation Type PermitAll

@Documented
@Retention(value=RUNTIME)
@Target(value={TYPE,METHOD})
public @interface PermitAll

Specifies that all security roles are allowed to invoke the specified method(s) i.e that the specified method(s) are "unchecked". It can be specified on a class or on methods. Specifying it on the class means that it applies to all methods of the class. If specified at the method level, it only affects that method. If the RolesAllowed is specified at the class level and this annotation is applied at the method level, the PermitAll annotation overrides the RolesAllowed for the specified method.

Since:
Common Annotations 1.0
See Also:
RolesAllowed, DenyAll

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DeclareRoles

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.annotation.security
Annotation Type DeclareRoles

@Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface DeclareRoles

Used by application to declare roles. It can be specified on a class.

Since:
Common Annotations 1.0

Required Element Summary
 String[] value

Element Detail

value

public abstract String[] value
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RolesAllowed

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.annotation.security
Annotation Type RolesAllowed

@Documented
@Retention(value=RUNTIME)
@Target(value={TYPE,METHOD})
public @interface RolesAllowed

Specifies the list of roles permitted to access method(s) in an application. The value of the RolesAllowed annotation is a list of security role names. This annotation can be specified on a class or on method(s). Specifying it at a class level means that it applies to all the methods in the class. Specifying it on a method means that it is applicable to that method only. If applied at both the class and methods level , the method value overrides the class value if the two conflict.

Since:
Common Annotations 1.0

Required Element Summary
 String[] value

Element Detail

value

public abstract String[] value
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RunAs

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.annotation.security
Annotation Type RunAs

@Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface RunAs

Defines the identity of the application during execution in a J2EE container. This allows developers to execute under a particular role. The role must map to the user / group information in the containers security realm. It's value is the name of a security role.

Since:
Common Annotations 1.0

Required Element Summary
 String value

Element Detail

value

public abstract String value
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ejb

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.ejb

The javax.ejb package contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

See:
Description

Interface Summary
EJBContext | The EJBContext interface provides an instance with access to the container-provided runtime context of an enterprise Bean instance.
EJBHome | The EJBHome interface must be extended by all enterprise Beans' remote home interfaces.
EJBLocalHome | The EJBLocalHome interface must be extended by all enterprise Beans' local home interfaces.
EJBLocalObject | The EJBLocalObject interface must be extended by all enterprise Beans' local interfaces.
EJBMetaData | The EJBMetaData interface allows a client to obtain the enterprise Bean's meta-data information.
EJBObject | The EJBObject interface is extended by all enterprise Beans' remote interfaces.
EnterpriseBean | The EnterpriseBean interface must be implemented by every enterprise Bean class.
EntityBean | The EntityBean interface is implemented by every entity enterprise Bean class.
EntityContext | The EntityContext interface provides an instance with access to the container-provided runtime context of an entity enterprise Bean instance.
Handle | The Handle interface is implemented by all EJB object handles.
HomeHandle | The HomeHandle interface is implemented by all home object handles.
MessageDrivenBean | The MessageDrivenBean interface is implemented by every message-driven enterprise Bean class.
MessageDrivenContext | The MessageDrivenContext interface provides access to the runtime message-driven context that the container provides for a message-driven enterprise Bean instance.
SessionBean | The SessionBean interface is implemented by every session enterprise Bean class.
SessionContext | The SessionContext interface provides access to the runtime session context that the container provides for a session enterprise Bean instance.
SessionSynchronization | The SessionSynchronization interface allows a session Bean instance to be notified by its container of transaction boundaries.
TimedObject | The TimedObject interface contains the callback method that is used to deliver timer expiration notifications.
Timer | The Timer interface contains information about a timer that was created through the EJB Timer Service.
TimerHandle | The TimerHandle interface is implemented by all EJB timer handles.
TimerService | The TimerService interface provides enterprise bean components with access to the container-provided Timer Service.

Enum Summary
TransactionAttributeType
TransactionManagementType

Exception Summary
AccessLocalException | An AccessLocalException is thrown to indicate that the caller does not have permission to call the method.
ConcurrentAccessException | A ConcurrentAccessException indicates that the client has attempted an invocation on a stateful session bean while another invocation is in progress.
CreateException | The CreateException exception must be included in the throws clauses of all create methods defined in an enterprise Bean's home interface.
DuplicateKeyException | The DuplicateKeyException exception is thrown if an entity EJB object cannot be created because an object with the same key already exists.
EJBAccessException | This exception indicates that client access to a business method was denied.
EJBException | The EJBException exception is thrown by an enterprise Bean instance to its container to report that the invoked business method or callback method could not be completed because of an unexpected error (e.g. the instance failed to open a database connection).
EJBTransactionRequiredException | This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.
EJBTransactionRolledbackException | This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back.
FinderException | The FinderException exception must be included in the throws clause of every findMETHOD(...) method of an entity Bean's home interface.
NoSuchEJBException | A NoSuchEJBException is thrown if an attempt is made to invoke a method on an object that no longer exists.
NoSuchEntityException | The NoSuchEntityException exception is thrown by an Entity Bean instance to its container to report that the invoked business method or callback method could not be completed because of the underlying entity was removed from the database.
NoSuchObjectLocalException | A NoSuchObjectLocalException is thrown if an attempt is made to invoke a method on an object that no longer exists.
ObjectNotFoundException | The ObjectNotFoundException exception is thrown by a finder method to indicate that the specified EJB object does not exist.
RemoveException | The RemoveException exception is thrown at an attempt to remove an EJB object when the enterprise Bean or the container does not allow the EJB object to be removed.
TransactionRequiredLocalException | This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.
TransactionRolledbackLocalException | This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back.

Annotation Types Summary
ActivationConfigProperty |
ApplicationException | Applied to an exception to denote that it is an application exception and should be reported to the client directly(i.e., unwrapped).
EJB | Indicates a dependency on the local or remote view of an Enterprise Java Bean.
EJBs | Declares multiple TYPE-level @EJB annotations.
Init | Designates a method of a session bean that corresponds to the create method of an adapted Home interface or an adapted Local Home interface.
Local | When used on the bean class, declares the local business interface(s) for a session bean.
LocalHome | Declares the Local Home or adapted Local Home interface for a session bean.
MessageDriven | Component-defining annotation for a message driven bean.
PostActivate | Designates a method to receive a callback after a stateful session bean has been activated.
PrePassivate | Designates a method to receive a callback before a stateful session bean is passivated.
Remote | Declares the remote business interface(s) for a session bean.
RemoteHome | Declares the Remote Home or adapted Remote Home interface for a session bean.
Remove | Applied to a business method of a stateful session bean class.
Stateful | Component-defining annotation for a stateful session bean.
Stateless | Component-defining annotation for a stateless session bean.
Timeout | Designates a method on a stateless session bean class or message driven bean class that should receive EJB timer expirations for that bean.
TransactionAttribute | When applied at the TYPE-level, designates the default transaction attribute for all business methods of the session or message driven bean.
TransactionManagement | Declares whether a session bean or message driven bean has container managed transactions or bean managed transactions.

Package javax.ejb Description

The javax.ejb package contains the Enterprise JavaBeans classes and interfaces that define the contracts between the enterprise bean and its clients and between the enterprise bean and the EJB container.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EnterpriseBean

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EnterpriseBean

All Superinterfaces:
Serializable
All Known Subinterfaces:
EntityBean, MessageDrivenBean, SessionBean
public interface EnterpriseBean
extends Serializable

The EnterpriseBean interface must be implemented by every enterprise Bean class. It is a common superinterface for the SessionBean, EntityBean and MessageDrivenBean interfaces.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.ejb Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.ejb

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.ejb.CreateException
          • javax.ejb.DuplicateKeyException
        • javax.ejb.FinderException
          • javax.ejb.ObjectNotFoundException
        • javax.ejb.RemoveException
        • java.lang.RuntimeException
          • javax.ejb.EJBException
            • javax.ejb.AccessLocalException
            • javax.ejb.ConcurrentAccessException
            • javax.ejb.EJBAccessException
            • javax.ejb.EJBTransactionRequiredException
            • javax.ejb.EJBTransactionRolledbackException
            • javax.ejb.NoSuchEJBException
            • javax.ejb.NoSuchEntityException
            • javax.ejb.NoSuchObjectLocalException
            • javax.ejb.TransactionRequiredLocalException
            • javax.ejb.TransactionRolledbackLocalException

Interface Hierarchy

  • javax.ejb.EJBContext
    • javax.ejb.EntityContext
    • javax.ejb.MessageDrivenContext
    • javax.ejb.SessionContext
  • javax.ejb.EJBLocalHome
  • javax.ejb.EJBLocalObject
  • javax.ejb.EJBMetaData
  • java.rmi.Remote
    • javax.ejb.EJBHome
    • javax.ejb.EJBObject
  • java.io.Serializable
    • javax.ejb.EnterpriseBean
      • javax.ejb.EntityBean
      • javax.ejb.MessageDrivenBean
      • javax.ejb.SessionBean
    • javax.ejb.Handle
    • javax.ejb.HomeHandle
    • javax.ejb.TimerHandle
  • javax.ejb.SessionSynchronization
  • javax.ejb.TimedObject
  • javax.ejb.Timer
  • javax.ejb.TimerService

Annotation Type Hierarchy

  • javax.ejb.ActivationConfigProperty (implements java.lang.annotation.Annotation)
  • javax.ejb.ApplicationException (implements java.lang.annotation.Annotation)
  • javax.ejb.EJB (implements java.lang.annotation.Annotation)
  • javax.ejb.EJBs (implements java.lang.annotation.Annotation)
  • javax.ejb.Init (implements java.lang.annotation.Annotation)
  • javax.ejb.Local (implements java.lang.annotation.Annotation)
  • javax.ejb.LocalHome (implements java.lang.annotation.Annotation)
  • javax.ejb.MessageDriven (implements java.lang.annotation.Annotation)
  • javax.ejb.PostActivate (implements java.lang.annotation.Annotation)
  • javax.ejb.PrePassivate (implements java.lang.annotation.Annotation)
  • javax.ejb.Remote (implements java.lang.annotation.Annotation)
  • javax.ejb.RemoteHome (implements java.lang.annotation.Annotation)
  • javax.ejb.Remove (implements java.lang.annotation.Annotation)
  • javax.ejb.Stateful (implements java.lang.annotation.Annotation)
  • javax.ejb.Stateless (implements java.lang.annotation.Annotation)
  • javax.ejb.Timeout (implements java.lang.annotation.Annotation)
  • javax.ejb.TransactionAttribute (implements java.lang.annotation.Annotation)
  • javax.ejb.TransactionManagement (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.ejb.TransactionAttributeType
      • javax.ejb.TransactionManagementType
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageDrivenContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface MessageDrivenContext

All Superinterfaces:
EJBContext
public interface MessageDrivenContext
extends EJBContext

The MessageDrivenContext interface provides access to the runtime message-driven context that the container provides for a message-driven enterprise Bean instance. The container passes the MessageDrivenContext interface to an instance after the instance has been created. The message-driven context remains associated with the instance for the lifetime of the instance.

Method Summary
Methods inherited from interface javax.ejb.EJBContext
getCallerIdentity, getCallerPrincipal, getEJBHome, getEJBLocalHome, getEnvironment, getRollbackOnly, getTimerService, getUserTransaction, isCallerInRole, isCallerInRole, lookup, setRollbackOnly

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PostActivate

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type PostActivate

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PostActivate

Designates a method to receive a callback after a stateful session bean has been activated.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PrePassivate

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type PrePassivate

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PrePassivate

Designates a method to receive a callback before a stateful session bean is passivated.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Timeout

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type Timeout

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface Timeout

Designates a method on a stateless session bean class or message driven bean class that should receive EJB timer expirations for that bean.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AccessLocalException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class AccessLocalException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.ejb.EJBException
                    extended by  javax.ejb.AccessLocalException
All Implemented Interfaces:
Serializable
public class AccessLocalException
extends EJBException

An AccessLocalException is thrown to indicate that the caller does not have permission to call the method. This exception is thrown to local clients.

See Also:
Serialized Form

Constructor Summary
AccessLocalException()
Constructs an AccessLocalException with no detail message.
AccessLocalException(String message)
Constructs an AccessLocalException with the specified detail message.
AccessLocalException(String message, Exception ex)
Constructs an AccessLocalException with the specified detail message and a nested exception.
Method Summary
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AccessLocalException

public AccessLocalException()
Constructs an AccessLocalException with no detail message.

AccessLocalException

public AccessLocalException(String message)
Constructs an AccessLocalException with the specified detail message.

AccessLocalException

public AccessLocalException(String message,
                            Exception ex)
Constructs an AccessLocalException with the specified detail message and a nested exception.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ActivationConfigProperty

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type ActivationConfigProperty

@Target(value={})
@Retention(value=RUNTIME)
public @interface ActivationConfigProperty

Required Element Summary
String | propertyName
String | propertyValue

Element Detail

propertyName

public abstract String propertyName

propertyValue

public abstract String propertyValue
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ApplicationException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type ApplicationException

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface ApplicationException

Applied to an exception to denote that it is an application exception and should be reported to the client directly(i.e., unwrapped).

Optional Element Summary
 boolean rollback
Indicates whether the container should cause the transaction to rollback when the exception is thrown.

rollback

public abstract boolean rollback
Indicates whether the container should cause the transaction to rollback when the exception is thrown.

Default:
false
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConcurrentAccessException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class ConcurrentAccessException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.ejb.EJBException
                    extended by  javax.ejb.ConcurrentAccessException
All Implemented Interfaces:
Serializable
public class ConcurrentAccessException
extends EJBException

A ConcurrentAccessException indicates that the client has attempted an invocation on a stateful session bean while another invocation is in progress.

See Also:
Serialized Form

Constructor Summary
ConcurrentAccessException()
Constructs an ConcurrentAccessException with no detail message.
ConcurrentAccessException(String message)
Constructs an ConcurrentAccessException with the specified detailed message.
ConcurrentAccessException(String message, Exception ex)
Constructs an ConcurrentAccessException with the specified detail message and a nested exception.
Method Summary
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ConcurrentAccessException

public ConcurrentAccessException()
Constructs an ConcurrentAccessException with no detail message.

ConcurrentAccessException

public ConcurrentAccessException(String message)
Constructs an ConcurrentAccessException with the specified detailed message.

ConcurrentAccessException

public ConcurrentAccessException(String message,
                                 Exception ex)
Constructs an ConcurrentAccessException with the specified detail message and a nested exception.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


CreateException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class CreateException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.ejb.CreateException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
DuplicateKeyException
public class CreateException
extends Exception

The CreateException exception must be included in the throws clauses of all create methods defined in an enterprise Bean's home interface.

This exception is used as a standard application-level exception to report a failure to create an EJB object.

See Also:
Serialized Form

Constructor Summary
CreateException()
Constructs a CreateException with no detail message.
CreateException(String message)
Constructs a CreateException with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CreateException

public CreateException()
Constructs a CreateException with no detail message.

CreateException

public CreateException(String message)
Constructs a CreateException with the specified detail message.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DuplicateKeyException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class DuplicateKeyException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.ejb.CreateException
                extended by  javax.ejb.DuplicateKeyException
All Implemented Interfaces:
Serializable
public class DuplicateKeyException
extends CreateException

The DuplicateKeyException exception is thrown if an entity EJB object cannot be created because an object with the same key already exists. This exception is thrown by the create methods defined in an entity Bean's home interface.

See Also:
Serialized Form

Constructor Summary
DuplicateKeyException()
Constructs a DuplicateKeyException with no detail message.
DuplicateKeyException(String message)
Constructs a DuplicateKeyException with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DuplicateKeyException

public DuplicateKeyException()
Constructs a DuplicateKeyException with no detail message.

DuplicateKeyException

public DuplicateKeyException(String message)
Constructs a DuplicateKeyException with the specified detail message.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJB

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type EJB

@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface EJB

Indicates a dependency on the local or remote view of an Enterprise Java Bean.

Optional Element Summary
Class | beanInterface Holds one of the following interface types of the target EJB : [ Local business interface, Remote business interface, Local Home interface, Remote Home interface ]
String | beanName The ejb-name of the Enterprise Java Bean to which this reference is mapped.
String | description
String | mappedName The product specific name of the EJB component to which this ejb reference should be mapped.
String | name The logical name of the ejb reference within the declaring component's (java:comp/env) environment.

name

public abstract String name
The logical name of the ejb reference within the declaring component's (java:comp/env) environment.

Default:
""

description

public abstract String description
Default:
""

beanName

public abstract String beanName
The ejb-name of the Enterprise Java Bean to which this reference is mapped. Only applicable if the target EJB is defined within the same application or stand-alone module as the declaring component.

Default:
""

beanInterface

public abstract Class beanInterface
Holds one of the following interface types of the target EJB : [ Local business interface, Remote business interface, Local Home interface, Remote Home interface ]

Default:
java.lang.Object.class

mappedName

public abstract String mappedName
The product specific name of the EJB component to which this ejb reference should be mapped. This mapped name is often a global JNDI name, but may be a name of any form. Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBAccessException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class EJBAccessException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.ejb.EJBException
                    extended by  javax.ejb.EJBAccessException
All Implemented Interfaces:
Serializable
public class EJBAccessException
extends EJBException

This exception indicates that client access to a business method was denied.

See Also:
Serialized Form

Constructor Summary
EJBAccessException()
Constructs an EJBAccessException with no detail message.
EJBAccessException(String message)
Constructs an EJBAccessException with the specified detailed message.
Method Summary
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EJBAccessException

public EJBAccessException()
Constructs an EJBAccessException with no detail message.

EJBAccessException

public EJBAccessException(String message)
Constructs an EJBAccessException with the specified detailed message.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EJBContext

All Known Subinterfaces:
EntityContext, MessageDrivenContext, SessionContext
public interface EJBContext

The EJBContext interface provides an instance with access to the container-provided runtime context of an enterprise Bean instance.

This interface is extended by the SessionContext, EntityContext, and MessageDrivenContext interfaces to provide additional methods specific to the enterprise interface Bean type.

Method Summary
 Identity getCallerIdentity()
Deprecated. Use Principal getCallerPrincipal() instead.
 Principal getCallerPrincipal()
Obtain the java.security.Principal that identifies the caller.
 EJBHome getEJBHome()
Obtain the enterprise bean's remote home interface.
 EJBLocalHome getEJBLocalHome()
Obtain the enterprise bean's local home interface.
 Properties getEnvironment()
Deprecated. Use the JNDI naming context java:comp/env to access enterprise bean's environment.
 boolean getRollbackOnly()
Test if the transaction has been marked for rollback only.
 TimerService getTimerService()
Get access to the EJB Timer Service.
 UserTransaction getUserTransaction()
Obtain the transaction demarcation interface.
 boolean isCallerInRole(Identity role)
Deprecated. Use boolean isCallerInRole(String roleName) instead.
 boolean isCallerInRole(String roleName)
Test if the caller has a given security role.
 Object lookup(String name)
Lookup a resource within the component's private naming context.
 void setRollbackOnly()
Mark the current transaction for rollback.

Method Detail

getEJBHome

EJBHome getEJBHome()
Obtain the enterprise bean's remote home interface.

Returns:
The enterprise bean's remote home interface.
Throws:
IllegalStateException - if the enterprise bean does not have a remote home interface.

getEJBLocalHome

EJBLocalHome getEJBLocalHome()
Obtain the enterprise bean's local home interface.

Returns:
The enterprise bean's local home interface.
Throws:
IllegalStateException - if the enterprise bean does not have a local home interface.

getEnvironment

Properties getEnvironment()
Deprecated. Use the JNDI naming context java:comp/env to access enterprise bean's environment.

Obtain the enterprise bean's environment properties.

Note: If the enterprise bean has no environment properties this method returns an empty java.util.Properties object. This method never returns null.

Returns:
The environment properties for the enterprise bean.

getCallerIdentity

Identity getCallerIdentity()
Deprecated. Use Principal getCallerPrincipal() instead.

Obtain the java.security.Identity of the caller. This method is deprecated in EJB 1.1. The Container is allowed to return alway null from this method. The enterprise bean should use the getCallerPrincipal method instead.

Returns:
The Identity object that identifies the caller.

getCallerPrincipal

Principal getCallerPrincipal()
Obtain the java.security.Principal that identifies the caller.

Returns:
The Principal object that identifies the caller. This method never returns null.
Throws:
IllegalStateException - The Container throws the exception if the instance is not allowed to call this method.

isCallerInRole

boolean isCallerInRole(Identity role)
Deprecated. Use boolean isCallerInRole(String roleName) instead.

Test if the caller has a given role.

This method is deprecated in EJB 1.1. The enterprise bean should use the isCallerInRole(String roleName) method instead.

Parameters:
role - The java.security.Identity of the role to be tested.
Returns:
True if the caller has the specified role.

isCallerInRole

boolean isCallerInRole(String roleName)
Test if the caller has a given security role.

Parameters:
roleName - The name of the security role. The role must be one of the security roles that is defined in the deployment descriptor.
Returns:
True if the caller has the specified role.
Throws:
IllegalStateException - The Container throws the exception if the instance is not allowed to call this method.

getUserTransaction

UserTransaction getUserTransaction()
                                   throws IllegalStateException
Obtain the transaction demarcation interface. Only enterprise beans with bean-managed transactions are allowed to to use the UserTransaction interface. As entity beans must always use container-managed transactions, only session beans or message-driven beans with bean-managed transactions are allowed to invoke this method.

Returns:
The UserTransaction interface that the enterprise bean instance can use for transaction demarcation.
Throws:
IllegalStateException - The Container throws the exception if the instance is not allowed to use the UserTransaction interface (i.e. the instance is of a bean with container-managed transactions).

setRollbackOnly

void setRollbackOnly()
                     throws IllegalStateException
Mark the current transaction for rollback. The transaction will become permanently marked for rollback. A transaction marked for rollback can never commit. Only enterprise beans with container-managed transactions are allowed to use this method.

Throws:
IllegalStateException - The Container throws the exception if the instance is not allowed to use this method (i.e. the instance is of a bean with bean-managed transactions).

getRollbackOnly

boolean getRollbackOnly()
                        throws IllegalStateException
Test if the transaction has been marked for rollback only. An enterprise bean instance can use this operation, for example, to test after an exception has been caught, whether it is fruitless to continue computation on behalf of the current transaction. Only enterprise beans with container-managed transactions are allowed to use this method.

Returns:
True if the current transaction is marked for rollback, false otherwise.
Throws:
IllegalStateException - The Container throws the exception if the instance is not allowed to use this method (i.e. the instance is of a bean with bean-managed transactions).

getTimerService

TimerService getTimerService()
                             throws IllegalStateException
Get access to the EJB Timer Service.

Throws:
IllegalStateException - The Container throws the exception if the instance is not allowed to use this method (e.g. if the bean is a stateful session bean)

lookup

Object lookup(String name)
Lookup a resource within the component's private naming context.

Parameters:
name - Name of the entry (relative to java:comp/env).
Throws:
IllegalArgumentException - The Container throws the exception if the given name does not match an entry within the component's environment.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class EJBException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.ejb.EJBException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AccessLocalException, ConcurrentAccessException, EJBAccessException, EJBTransactionRequiredException, EJBTransactionRolledbackException, NoSuchEJBException, NoSuchEntityException, NoSuchObjectLocalException, TransactionRequiredLocalException, TransactionRolledbackLocalException
public class EJBException
extends RuntimeException

The EJBException exception is thrown by an enterprise Bean instance to its container to report that the invoked business method or callback method could not be completed because of an unexpected error (e.g. the instance failed to open a database connection).

See Also:
Serialized Form

Constructor Summary
EJBException()
Constructs an EJBException with no detail message.
EJBException(Exception ex)
Constructs an EJBException that embeds the originally thrown exception.
EJBException(String message)
Constructs an EJBException with the specified detailed message.
EJBException(String message, Exception ex)
Constructs an EJBException that embeds the originally thrown exception with the specified detail message.
Method Summary
Exception | getCausedByException() Obtain the exception that caused the EJBException being thrown.
String | getMessage() Returns the detail message, including the message from the nested exception if there is one.
void | printStackTrace() Prints the composite message to System.err.
void | printStackTrace(PrintStream ps) Prints the composite message and the embedded stack trace to the specified stream ps.
void | printStackTrace(PrintWriter pw) Prints the composite message and the embedded stack trace to the specified print writer pw.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EJBException

public EJBException()
Constructs an EJBException with no detail message.

EJBException

public EJBException(String message)
Constructs an EJBException with the specified detailed message.

EJBException

public EJBException(Exception ex)
Constructs an EJBException that embeds the originally thrown exception.

EJBException

public EJBException(String message,
                    Exception ex)
Constructs an EJBException that embeds the originally thrown exception with the specified detail message.

Method Detail

getCausedByException

public Exception getCausedByException()
Obtain the exception that caused the EJBException being thrown.

getMessage

public String getMessage()
Returns the detail message, including the message from the nested exception if there is one.

Overrides:
getMessage in class Throwable

printStackTrace

public void printStackTrace(PrintStream ps)
Prints the composite message and the embedded stack trace to the specified stream ps.

Overrides:
printStackTrace in class Throwable
Parameters:
ps - the print stream

printStackTrace

public void printStackTrace()
Prints the composite message to System.err.

Overrides:
printStackTrace in class Throwable

printStackTrace

public void printStackTrace(PrintWriter pw)
Prints the composite message and the embedded stack trace to the specified print writer pw.

Overrides:
printStackTrace in class Throwable
Parameters:
pw - the print writer
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBHome

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EJBHome

All Superinterfaces:
Remote
All Known Subinterfaces:
ManagementHome
public interface EJBHome
extends Remote

The EJBHome interface must be extended by all enterprise Beans' remote home interfaces. An enterprise Bean's remote home interface defines the methods that allow a remote client to create, find, and remove EJB objects, as well as home business methods that are not specific to a bean instance (Session Beans do not have finders and home methods).

The remote home interface is defined by the enterprise Bean provider and implemented by the enterprise Bean container.

Method Summary
EJBMetaData | getEJBMetaData() Obtain the EJBMetaData interface for the enterprise Bean.
HomeHandle | getHomeHandle() Obtain a handle for the remote home object.
void | remove(Handle handle) Remove an EJB object identified by its handle.
void | remove(Object primaryKey) Remove an EJB object identified by its primary key.

Method Detail

remove

void remove(Handle handle)
            throws RemoteException,
                   RemoveException
Remove an EJB object identified by its handle.

Throws:
RemoveException - Thrown if the enterprise Bean or the container does not allow the client to remove the object.
RemoteException - Thrown when the method failed due to a system-level failure.

remove

void remove(Object primaryKey)
            throws RemoteException,
                   RemoveException
Remove an EJB object identified by its primary key.

This method can be used only for an entity bean. An attempt to call this method on a session bean will result in a RemoveException.

Throws:
RemoveException - Thrown if the enterprise Bean or the container does not allow the client to remove the object.
RemoteException - Thrown when the method failed due to a system-level failure.

getEJBMetaData

EJBMetaData getEJBMetaData()
                           throws RemoteException
Obtain the EJBMetaData interface for the enterprise Bean. The EJBMetaData interface allows the client to obtain information about the enterprise Bean.

The information obtainable via the EJBMetaData interface is intended to be used by tools.

Returns:
The enterprise Bean's EJBMetaData interface.
Throws:
RemoteException - Thrown when the method failed due to a system-level failure.

getHomeHandle

HomeHandle getHomeHandle()
                         throws RemoteException
Obtain a handle for the remote home object. The handle can be used at later time to re-obtain a reference to the remote home object, possibly in a different Java Virtual Machine.

Returns:
A handle for the remote home object.
Throws:
RemoteException - Thrown when the method failed due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBLocalHome

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EJBLocalHome

public interface EJBLocalHome

The EJBLocalHome interface must be extended by all enterprise Beans' local home interfaces. An enterprise Bean's local home interface defines the methods that allow local clients to create, find, and remove EJB objects, as well as home business methods that are not specific to a bean instance (session Beans do not have finders and home business methods).

The local home interface is defined by the enterprise Bean provider and implemented by the enterprise Bean container.

Method Summary
 void remove(Object primaryKey)
Remove an EJB object identified by its primary key.

Method Detail

remove

void remove(Object primaryKey)
            throws RemoveException,
                   EJBException
Remove an EJB object identified by its primary key.

This method can only be used by local clients of an entity bean. An attempt to call this method on a session bean will result in a RemoveException.

Throws:
RemoveException - Thrown if the enterprise Bean or the container does not allow the client to remove the object.
EJBException - Thrown when the method failed due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBLocalObject

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EJBLocalObject

public interface EJBLocalObject

The EJBLocalObject interface must be extended by all enterprise Beans' local interfaces. An enterprise Bean's local interface provides the local client view of an EJB object. An enterprise Bean's local interface defines the business methods callable by local clients.

The enterprise Bean's local interface is defined by the enterprise Bean provider and implemented by the enterprise Bean container.

Method Summary
EJBLocalHome | getEJBLocalHome() Obtain the enterprise Bean's local home interface.
Object | getPrimaryKey() Obtain the primary key of the EJB local object.
boolean | isIdentical(EJBLocalObject obj) Test if a given EJB local object is identical to the invoked EJB local object.
void | remove() Remove the EJB local object.

Method Detail

getEJBLocalHome

EJBLocalHome getEJBLocalHome()
                             throws EJBException
Obtain the enterprise Bean's local home interface. The local home interface defines the enterprise Bean's create, finder, remove, and home business methods that are available to local clients.

Returns:
A reference to the enterprise Bean's local home interface.
Throws:
EJBException - Thrown when the method failed due to a system-level failure.

getPrimaryKey

Object getPrimaryKey()
                     throws EJBException
Obtain the primary key of the EJB local object.

This method can be called on an entity bean. An attempt to invoke this method on a session Bean will result in an EJBException.

Returns:
The EJB local object's primary key.
Throws:
EJBException - Thrown when the method failed due to a system-level failure or when invoked on a session bean.

remove

void remove()
            throws RemoveException,
                   EJBException
Remove the EJB local object.

Throws:
RemoveException - The enterprise Bean or the container does not allow destruction of the object.
EJBException - Thrown when the method failed due to a system-level failure.

isIdentical

boolean isIdentical(EJBLocalObject obj)
                    throws EJBException
Test if a given EJB local object is identical to the invoked EJB local object.

Parameters:
obj - An object to test for identity with the invoked object.
Returns:
True if the given EJB local object is identical to the invoked object, false otherwise.
Throws:
EJBException - Thrown when the method failed due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBMetaData

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EJBMetaData

public interface EJBMetaData

The EJBMetaData interface allows a client to obtain the enterprise Bean's meta-data information.

The meta-data is intended for development tools used for building applications that use deployed enterprise Beans, and for clients using a scripting language to access the enterprise Bean.

Note that the EJBMetaData is not a remote interface. The class that implements this interface (this class is typically generated by container tools) must be serializable, and must be a valid RMI/IDL value type.

Method Summary
EJBHome | getEJBHome() Obtain the remote home interface of the enterprise Bean.
Class | getHomeInterfaceClass() Obtain the Class object for the enterprise Bean's remote home interface.
Class | getPrimaryKeyClass() Obtain the Class object for the enterprise Bean's primary key class.
Class | getRemoteInterfaceClass() Obtain the Class object for the enterprise Bean's remote interface.
boolean | isSession() Test if the enterprise Bean's type is "session".
boolean | isStatelessSession() Test if the enterprise Bean's type is "stateless session".

Method Detail

getEJBHome

EJBHome getEJBHome()
Obtain the remote home interface of the enterprise Bean.

Returns:
the remote home interface of the enterprise Bean.

getHomeInterfaceClass

Class getHomeInterfaceClass()
Obtain the Class object for the enterprise Bean's remote home interface.

Returns:
the Class object for the enterprise Bean's remote home interface.

getRemoteInterfaceClass

Class getRemoteInterfaceClass()
Obtain the Class object for the enterprise Bean's remote interface.

Returns:
the Class object for the enterprise Bean's remote interface.

getPrimaryKeyClass

Class getPrimaryKeyClass()
Obtain the Class object for the enterprise Bean's primary key class.

Returns:
the Class object for the enterprise Bean's primary key class.

isSession

boolean isSession()
Test if the enterprise Bean's type is "session".

Returns:
True if the type of the enterprise Bean is session bean.

isStatelessSession

boolean isStatelessSession()
Test if the enterprise Bean's type is "stateless session".

Returns:
True if the type of the enterprise Bean is stateless session.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBObject

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EJBObject

All Superinterfaces:
Remote
All Known Subinterfaces:
Management
public interface EJBObject
extends Remote

The EJBObject interface is extended by all enterprise Beans' remote interfaces. An enterprise Bean's remote interface provides the remote client view of an EJB object. An enterprise Bean's remote interface defines the business methods callable by a remote client.

The remote interface must extend the javax.ejb.EJBObject interface, and define the enterprise Bean specific business methods.

The enterprise Bean's remote interface is defined by the enterprise Bean provider and implemented by the enterprise Bean container.

Method Summary
EJBHome | getEJBHome() Obtain the enterprise Bean's remote home interface.
Handle | getHandle() Obtain a handle for the EJB object.
Object | getPrimaryKey() Obtain the primary key of the EJB object.
boolean | isIdentical(EJBObject obj) Test if a given EJB object is identical to the invoked EJB object.
void | remove() Remove the EJB object.

Method Detail

getEJBHome

EJBHome getEJBHome()
                   throws RemoteException
Obtain the enterprise Bean's remote home interface. The remote home interface defines the enterprise Bean's create, finder, remove, and home business methods.

Returns:
A reference to the enterprise Bean's home interface.
Throws:
RemoteException - Thrown when the method failed due to a system-level failure.

getPrimaryKey

Object getPrimaryKey()
                     throws RemoteException
Obtain the primary key of the EJB object.

This method can be called on an entity bean. An attempt to invoke this method on a session bean will result in RemoteException.

Returns:
The EJB object's primary key.
Throws:
RemoteException - Thrown when the method failed due to a system-level failure or when invoked on a session bean.

remove

void remove()
            throws RemoteException,
                   RemoveException
Remove the EJB object.

Throws:
RemoteException - Thrown when the method failed due to a system-level failure.
RemoveException - The enterprise Bean or the container does not allow destruction of the object.

getHandle

Handle getHandle()
                 throws RemoteException
Obtain a handle for the EJB object. The handle can be used at later time to re-obtain a reference to the EJB object, possibly in a different Java Virtual Machine.

Returns:
A handle for the EJB object.
Throws:
RemoteException - Thrown when the method failed due to a system-level failure.

isIdentical

boolean isIdentical(EJBObject obj)
                    throws RemoteException
Test if a given EJB object is identical to the invoked EJB object.

Parameters:
obj - An object to test for identity with the invoked object.
Returns:
True if the given EJB object is identical to the invoked object, false otherwise.
Throws:
RemoteException - Thrown when the method failed due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBs

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type EJBs

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface EJBs

Declares multiple TYPE-level @EJB annotations.

Required Element Summary
 EJB[] value

Element Detail

value

public abstract EJB[] value
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBTransactionRequiredException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class EJBTransactionRequiredException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.ejb.EJBException
                    extended by  javax.ejb.EJBTransactionRequiredException
All Implemented Interfaces:
Serializable
public class EJBTransactionRequiredException
extends EJBException

This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.

See Also:
Serialized Form

Constructor Summary
EJBTransactionRequiredException()
Constructs an EJBTransactionRequiredException with no detail message.
EJBTransactionRequiredException(String message)
Constructs an EJBTransactionRequiredException with the specified detailed message.
Method Summary
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EJBTransactionRequiredException

public EJBTransactionRequiredException()
Constructs an EJBTransactionRequiredException with no detail message.

EJBTransactionRequiredException

public EJBTransactionRequiredException(String message)
Constructs an EJBTransactionRequiredException with the specified detailed message.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBTransactionRolledbackException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class EJBTransactionRolledbackException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.ejb.EJBException
                    extended by  javax.ejb.EJBTransactionRolledbackException
All Implemented Interfaces:
Serializable
public class EJBTransactionRolledbackException
extends EJBException

This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back. Thus the requested operation either could not be performed or was not performed because further computation on behalf of the transaction would be fruitless

See Also:
Serialized Form

Constructor Summary
EJBTransactionRolledbackException()
Constructs an EJBTransactionRolledbackException with no detail message.
EJBTransactionRolledbackException(String message)
Constructs an EJBTransactionRolledbackException with the specified detailed message.
EJBTransactionRolledbackException(String message, Exception ex)
Constructs an EJBTransactionRolledbackException with the specified detail message and a nested exception.
Method Summary
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EJBTransactionRolledbackException

public EJBTransactionRolledbackException()
Constructs an EJBTransactionRolledbackException with no detail message.

EJBTransactionRolledbackException

public EJBTransactionRolledbackException(String message)
Constructs an EJBTransactionRolledbackException with the specified detailed message.

EJBTransactionRolledbackException

public EJBTransactionRolledbackException(String message,
                                         Exception ex)
Constructs an EJBTransactionRolledbackException with the specified detail message and a nested exception.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EntityBean

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EntityBean

All Superinterfaces:
EnterpriseBean, Serializable
public interface EntityBean
extends EnterpriseBean

The EntityBean interface is implemented by every entity enterprise Bean class. The container uses the EntityBean methods to notify the enterprise Bean instances of the instance's life cycle events.

Method Summary
void | ejbActivate() A container invokes this method when the instance is taken out of the pool of available instances to become associated with a specific EJB object.
void | ejbLoad() A container invokes this method to instruct the instance to synchronize its state by loading it state from the underlying database.
void | ejbPassivate() A container invokes this method on an instance before the instance becomes disassociated with a specific EJB object.
void | ejbRemove() A container invokes this method before it removes the EJB object that is currently associated with the instance.
void | ejbStore() A container invokes this method to instruct the instance to synchronize its state by storing it to the underlying database.
void | setEntityContext(EntityContext ctx) Set the associated entity context.
void | unsetEntityContext() Unset the associated entity context.

Method Detail

setEntityContext

void setEntityContext(EntityContext ctx)
                      throws EJBException,
                             RemoteException
Set the associated entity context. The container invokes this method on an instance after the instance has been created.

This method is called in an unspecified transaction context.

Parameters:
ctx - An EntityContext interface for the instance. The instance should store the reference to the context in an instance variable.
Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

unsetEntityContext

void unsetEntityContext()
                        throws EJBException,
                               RemoteException
Unset the associated entity context. The container calls this method before removing the instance.

This is the last method that the container invokes on the instance. The Java garbage collector will eventually invoke the finalize() method on the instance.

This method is called in an unspecified transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbRemove

void ejbRemove()
               throws RemoveException,
                      EJBException,
                      RemoteException
A container invokes this method before it removes the EJB object that is currently associated with the instance. This method is invoked when a client invokes a remove operation on the enterprise Bean's home interface or the EJB object's remote interface. This method transitions the instance from the ready state to the pool of available instances.

This method is called in the transaction context of the remove operation.

Throws:
RemoveException - The enterprise Bean does not allow destruction of the object.
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbActivate

void ejbActivate()
                 throws EJBException,
                        RemoteException
A container invokes this method when the instance is taken out of the pool of available instances to become associated with a specific EJB object. This method transitions the instance to the ready state.

This method executes in an unspecified transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbPassivate

void ejbPassivate()
                  throws EJBException,
                         RemoteException
A container invokes this method on an instance before the instance becomes disassociated with a specific EJB object. After this method completes, the container will place the instance into the pool of available instances.

This method executes in an unspecified transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbLoad

void ejbLoad()
             throws EJBException,
                    RemoteException
A container invokes this method to instruct the instance to synchronize its state by loading it state from the underlying database.

This method always executes in the transaction context determined by the value of the transaction attribute in the deployment descriptor.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbStore

void ejbStore()
              throws EJBException,
                     RemoteException
A container invokes this method to instruct the instance to synchronize its state by storing it to the underlying database.

This method always executes in the transaction context determined by the value of the transaction attribute in the deployment descriptor.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EntityContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface EntityContext

All Superinterfaces:
EJBContext
public interface EntityContext
extends EJBContext

The EntityContext interface provides an instance with access to the container-provided runtime context of an entity enterprise Bean instance. The container passes the EntityContext interface to an entity enterprise Bean instance after the instance has been created.

The EntityContext interface remains associated with the instance for the lifetime of the instance. Note that the information that the instance obtains using the EntityContext interface (such as the result of the getPrimaryKey() method) may change, as the container assigns the instance to different EJB objects during the instance's life cycle.

Method Summary
EJBLocalObject | getEJBLocalObject() Obtain a reference to the EJB local object that is currently associated with the instance.
EJBObject | getEJBObject() Obtain a reference to the EJB object that is currently associated with the instance.
Object | getPrimaryKey() Obtain the primary key of the EJB object that is currently associated with this instance.
Methods inherited from interface javax.ejb.EJBContext
getCallerIdentity, getCallerPrincipal, getEJBHome, getEJBLocalHome, getEnvironment, getRollbackOnly, getTimerService, getUserTransaction, isCallerInRole, isCallerInRole, lookup, setRollbackOnly

Method Detail

getEJBLocalObject

EJBLocalObject getEJBLocalObject()
                                 throws IllegalStateException
Obtain a reference to the EJB local object that is currently associated with the instance.

An instance of an entity enterprise Bean can call this method only when the instance is associated with an EJB local object identity, i.e. in the ejbActivate, ejbPassivate, ejbPostCreate, ejbRemove, ejbLoad, ejbStore, and business methods.

An instance can use this method, for example, when it wants to pass a reference to itself in a method argument or result.

Returns:
The EJB local object currently associated with the instance.
Throws:
IllegalStateException - if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method, or if the instance does not have a local interface.

getEJBObject

EJBObject getEJBObject()
                       throws IllegalStateException
Obtain a reference to the EJB object that is currently associated with the instance.

An instance of an entity enterprise Bean can call this method only when the instance is associated with an EJB object identity, i.e. in the ejbActivate, ejbPassivate, ejbPostCreate, ejbRemove, ejbLoad, ejbStore, and business methods.

An instance can use this method, for example, when it wants to pass a reference to itself in a method argument or result.

Returns:
The EJB object currently associated with the instance.
Throws:
IllegalStateException - Thrown if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method, or if the instance does not have a remote interface.

getPrimaryKey

Object getPrimaryKey()
                     throws IllegalStateException
Obtain the primary key of the EJB object that is currently associated with this instance.

An instance of an entity enterprise Bean can call this method only when the instance is associated with an EJB object identity, i.e. in the ejbActivate, ejbPassivate, ejbPostCreate, ejbRemove, ejbLoad, ejbStore, and business methods.

Note: The result of this method is that same as the result of getEJBObject().getPrimaryKey().

Returns:
The primary key currently associated with the instance.
Throws:
IllegalStateException - Thrown if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FinderException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class FinderException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.ejb.FinderException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ObjectNotFoundException
public class FinderException
extends Exception

The FinderException exception must be included in the throws clause of every findMETHOD(...) method of an entity Bean's home interface.

The exception is used as a standard application-level exception to report a failure to find the requested EJB object(s).

See Also:
Serialized Form

Constructor Summary
FinderException()
Constructs an FinderException with no detail message.
FinderException(String message)
Constructs an FinderException with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FinderException

public FinderException()
Constructs an FinderException with no detail message.

FinderException

public FinderException(String message)
Constructs an FinderException with the specified detail message.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Handle

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface Handle

All Superinterfaces:
Serializable
public interface Handle
extends Serializable

The Handle interface is implemented by all EJB object handles. A handle is an abstraction of a network reference to an EJB object. A handle is intended to be used as a "robust" persistent reference to an EJB object.

Method Summary
 EJBObject getEJBObject()
Obtain the EJB object reference represented by this handle.

Method Detail

getEJBObject

EJBObject getEJBObject()
                       throws RemoteException
Obtain the EJB object reference represented by this handle.

Returns:
the EJB object reference represented by this handle.
Throws:
RemoteException - The EJB object could not be obtained because of a system-level failure.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HomeHandle

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface HomeHandle

All Superinterfaces:
Serializable
public interface HomeHandle
extends Serializable

The HomeHandle interface is implemented by all home object handles. A handle is an abstraction of a network reference to a home object. A handle is intended to be used as a "robust" persistent reference to a home object.

Method Summary
 EJBHome getEJBHome()
Obtain the home object represented by this handle.

Method Detail

getEJBHome

EJBHome getEJBHome()
                   throws RemoteException
Obtain the home object represented by this handle.

Returns:
the home object represented by this handle.
Throws:
RemoteException - The home object could not be obtained because of a system-level failure.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Init

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type Init

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface Init

Designates a method of a session bean that corresponds to the create method of an adapted Home interface or an adapted Local Home interface.

Optional Element Summary
 String value
The name of the corresponding create method of the adapted Home/LocalHome interface.

value

public abstract String value
The name of the corresponding create method of the adapted Home/LocalHome interface. This value is used to disambiguate the case where there are multiple create methods on an adapted Home/LocalHome interface with the same signature as the annotated @Init method. If no value is specified, the create matching is based on signature only.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Local

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type Local

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Local

When used on the bean class, declares the local business interface(s) for a session bean. When used on an interface, designates that interface as a local business interface. In this case, no value() is provided.

Optional Element Summary
 Class[] value

value

public abstract Class[] value
Default:
{}
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LocalHome

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type LocalHome

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface LocalHome

Declares the Local Home or adapted Local Home interface for a session bean.

Required Element Summary
 Class value

Element Detail

value

public abstract Class value
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageDriven

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type MessageDriven

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface MessageDriven

Component-defining annotation for a message driven bean.

Optional Element Summary
ActivationConfigProperty[] | activationConfig Activation config properties.
String | description
String | mappedName A product specific name(e.g. global JNDI name of a queue) that this message-driven bean should be mapped to.
Class | messageListenerInterface Message-listener interface.
String | name ejb-name for this bean.

name

public abstract String name
ejb-name for this bean.

Default:
""

messageListenerInterface

public abstract Class messageListenerInterface
Message-listener interface.

Default:
java.lang.Object.class

activationConfig

public abstract ActivationConfigProperty[] activationConfig
Activation config properties.

Default:
{}

mappedName

public abstract String mappedName
A product specific name(e.g. global JNDI name of a queue) that this message-driven bean should be mapped to. Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.

Default:
""

description

public abstract String description
Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageDrivenBean

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface MessageDrivenBean

All Superinterfaces:
EnterpriseBean, Serializable
public interface MessageDrivenBean
extends EnterpriseBean

The MessageDrivenBean interface is implemented by every message-driven enterprise Bean class. The container uses the MessageDrivenBean methods to notify the enterprise Bean instances of the instance's life cycle events.

Method Summary
void | ejbRemove() A container invokes this method before it ends the life of the message-driven object.
void | setMessageDrivenContext(MessageDrivenContext ctx) Set the associated message-driven context.

Method Detail

setMessageDrivenContext

void setMessageDrivenContext(MessageDrivenContext ctx)
                             throws EJBException
Set the associated message-driven context. The container calls this method after the instance creation.

The enterprise Bean instance should store the reference to the context object in an instance variable.

This method is called with no transaction context.

Parameters:
ctx - A MessageDrivenContext interface for the instance.
Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.

ejbRemove

void ejbRemove()
               throws EJBException
A container invokes this method before it ends the life of the message-driven object. This happens when a container decides to terminate the message-driven object.

This method is called with no transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NoSuchEJBException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class NoSuchEJBException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.ejb.EJBException
                    extended by  javax.ejb.NoSuchEJBException
All Implemented Interfaces:
Serializable
public class NoSuchEJBException
extends EJBException

A NoSuchEJBException is thrown if an attempt is made to invoke a method on an object that no longer exists.

See Also:
Serialized Form

Constructor Summary
NoSuchEJBException()
Constructs a NoSuchEJBException with no detail message.
NoSuchEJBException(String message)
Constructs a NoSuchEJBException with the specified detail message.
NoSuchEJBException(String message, Exception ex)
Constructs a NoSuchEJBException with the specified detail message and a nested exception.
Method Summary
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoSuchEJBException

public NoSuchEJBException()
Constructs a NoSuchEJBException with no detail message.

NoSuchEJBException

public NoSuchEJBException(String message)
Constructs a NoSuchEJBException with the specified detail message.

NoSuchEJBException

public NoSuchEJBException(String message,
                          Exception ex)
Constructs a NoSuchEJBException with the specified detail message and a nested exception.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NoSuchEntityException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class NoSuchEntityException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.ejb.EJBException
                    extended by  javax.ejb.NoSuchEntityException
All Implemented Interfaces:
Serializable
public class NoSuchEntityException
extends EJBException

The NoSuchEntityException exception is thrown by an Entity Bean instance to its container to report that the invoked business method or callback method could not be completed because of the underlying entity was removed from the database.

This exception may be thrown by the bean class methods that implement the business methods defined in the bean's component interface; and by the ejbLoad and ejbStore methods.

See Also:
Serialized Form

Constructor Summary
NoSuchEntityException()
Constructs a NoSuchEntityException with no detail message.
NoSuchEntityException(Exception ex)
Constructs a NoSuchEntityException that embeds the originally thrown exception.
NoSuchEntityException(String message)
Constructs a NoSuchEntityException with the specified detailed message.
Method Summary
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoSuchEntityException

public NoSuchEntityException()
Constructs a NoSuchEntityException with no detail message.

NoSuchEntityException

public NoSuchEntityException(String message)
Constructs a NoSuchEntityException with the specified detailed message.

NoSuchEntityException

public NoSuchEntityException(Exception ex)
Constructs a NoSuchEntityException that embeds the originally thrown exception.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NoSuchObjectLocalException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class NoSuchObjectLocalException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.ejb.EJBException
                    extended by  javax.ejb.NoSuchObjectLocalException
All Implemented Interfaces:
Serializable
public class NoSuchObjectLocalException
extends EJBException

A NoSuchObjectLocalException is thrown if an attempt is made to invoke a method on an object that no longer exists.

See Also:
Serialized Form

Constructor Summary
NoSuchObjectLocalException()
Constructs a NoSuchObjectLocalException with no detail message.
NoSuchObjectLocalException(String message)
Constructs a NoSuchObjectLocalException with the specified detail message.
NoSuchObjectLocalException(String message, Exception ex)
Constructs a NoSuchObjectLocalException with the specified detail message and a nested exception.
Method Summary
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoSuchObjectLocalException

public NoSuchObjectLocalException()
Constructs a NoSuchObjectLocalException with no detail message.

NoSuchObjectLocalException

public NoSuchObjectLocalException(String message)
Constructs a NoSuchObjectLocalException with the specified detail message.

NoSuchObjectLocalException

public NoSuchObjectLocalException(String message,
                                  Exception ex)
Constructs a NoSuchObjectLocalException with the specified detail message and a nested exception.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ObjectNotFoundException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class ObjectNotFoundException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.ejb.FinderException
                extended by  javax.ejb.ObjectNotFoundException
All Implemented Interfaces:
Serializable
public class ObjectNotFoundException
extends FinderException

The ObjectNotFoundException exception is thrown by a finder method to indicate that the specified EJB object does not exist.

Only the finder methods that are declared to return a single EJB object use this exception. This exception should not be thrown by finder methods that return a collection of EJB objects (they should return an empty collection instead).

See Also:
Serialized Form

Constructor Summary
ObjectNotFoundException()
Constructs an ObjectNotFoundException with no detail message.
ObjectNotFoundException(String message)
Constructs an ObjectNotFoundException with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ObjectNotFoundException

public ObjectNotFoundException()
Constructs an ObjectNotFoundException with no detail message.

ObjectNotFoundException

public ObjectNotFoundException(String message)
Constructs an ObjectNotFoundException with the specified detail message.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Remote

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type Remote

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Remote

Declares the remote business interface(s) for a session bean. When used on an interface, designates that interface as a remote business interface. In this case, no value() is provided.

Optional Element Summary
 Class[] value

value

public abstract Class[] value
Default:
{}
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RemoteHome

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type RemoteHome

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface RemoteHome

Declares the Remote Home or adapted Remote Home interface for a session bean.

Required Element Summary
 Class value

Element Detail

value

public abstract Class value
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Remove

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type Remove

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface Remove

Applied to a business method of a stateful session bean class. Indicates that the stateful session bean is to be removed by the container after completion of the method.

Optional Element Summary
 boolean retainIfException
If true, the stateful session bean will not be removed if an exception is thrown from the designated method.

retainIfException

public abstract boolean retainIfException
If true, the stateful session bean will not be removed if an exception is thrown from the designated method.

Default:
false
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RemoveException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class RemoveException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.ejb.RemoveException
All Implemented Interfaces:
Serializable
public class RemoveException
extends Exception

The RemoveException exception is thrown at an attempt to remove an EJB object when the enterprise Bean or the container does not allow the EJB object to be removed.

See Also:
Serialized Form

Constructor Summary
RemoveException()
Constructs an RemoveException with no detail message.
RemoveException(String message)
Constructs an RemoveException with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RemoveException

public RemoveException()
Constructs an RemoveException with no detail message.

RemoveException

public RemoveException(String message)
Constructs an RemoveException with the specified detail message.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SessionBean

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface SessionBean

All Superinterfaces:
EnterpriseBean, Serializable
public interface SessionBean
extends EnterpriseBean

The SessionBean interface is implemented by every session enterprise Bean class. The container uses the SessionBean methods to notify the enterprise Bean instances of the instance's life cycle events.

Method Summary
void | ejbActivate() The activate method is called when the instance is activated from its "passive" state.
void | ejbPassivate() The passivate method is called before the instance enters the "passive" state.
void | ejbRemove() A container invokes this method before it ends the life of the session object.
void | setSessionContext(SessionContext ctx) Set the associated session context.

Method Detail

setSessionContext

void setSessionContext(SessionContext ctx)
                       throws EJBException,
                              RemoteException
Set the associated session context. The container calls this method after the instance creation.

The enterprise Bean instance should store the reference to the context object in an instance variable.

This method is called with no transaction context.

Parameters:
ctx - A SessionContext interface for the instance.
Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for applications written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbRemove

void ejbRemove()
               throws EJBException,
                      RemoteException
A container invokes this method before it ends the life of the session object. This happens as a result of a client's invoking a remove operation, or when a container decides to terminate the session object after a timeout.

This method is called with no transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbActivate

void ejbActivate()
                 throws EJBException,
                        RemoteException
The activate method is called when the instance is activated from its "passive" state. The instance should acquire any resource that it has released earlier in the ejbPassivate() method.

This method is called with no transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.

ejbPassivate

void ejbPassivate()
                  throws EJBException,
                         RemoteException
The passivate method is called before the instance enters the "passive" state. The instance should release any resources that it can re-acquire later in the ejbActivate() method.

After the passivate method completes, the instance must be in a state that allows the container to use the Java Serialization protocol to externalize and store away the instance's state.

This method is called with no transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB2.0 and higher specifications must throw the javax.ejb.EJBException instead of this exception.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SessionContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface SessionContext

All Superinterfaces:
EJBContext
public interface SessionContext
extends EJBContext

The SessionContext interface provides access to the runtime session context that the container provides for a session enterprise Bean instance. The container passes the SessionContext interface to an instance after the instance has been created. The session context remains associated with the instance for the lifetime of the instance.

Method Summary
<T> T
getBusinessObject(Class<T> businessInterface)
Obtain an object that can be used to invoke the current bean through the given business interface.
 EJBLocalObject getEJBLocalObject()
Obtain a reference to the EJB local object that is associated with the instance.
 EJBObject getEJBObject()
Obtain a reference to the EJB object that is currently associated with the instance.
 Class getInvokedBusinessInterface()
Obtain the business interface through which the current business method invocation was made.
 MessageContext getMessageContext()
Obtain a reference to the JAX-RPC MessageContext.
Methods inherited from interface javax.ejb.EJBContext
getCallerIdentity, getCallerPrincipal, getEJBHome, getEJBLocalHome, getEnvironment, getRollbackOnly, getTimerService, getUserTransaction, isCallerInRole, isCallerInRole, lookup, setRollbackOnly

Method Detail

getEJBLocalObject

EJBLocalObject getEJBLocalObject()
                                 throws IllegalStateException
Obtain a reference to the EJB local object that is associated with the instance.

An instance of a session enterprise Bean can call this method at anytime between the ejbCreate() and ejbRemove() methods, including from within the ejbCreate() and ejbRemove() methods.

An instance can use this method, for example, when it wants to pass a reference to itself in a method argument or result.

Returns:
The EJB local object currently associated with the instance.
Throws:
IllegalStateException - Thrown if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method, or if the instance does not have a local interface.

getEJBObject

EJBObject getEJBObject()
                       throws IllegalStateException
Obtain a reference to the EJB object that is currently associated with the instance.

An instance of a session enterprise Bean can call this method at anytime between the ejbCreate() and ejbRemove() methods, including from within the ejbCreate() and ejbRemove() methods.

An instance can use this method, for example, when it wants to pass a reference to itself in a method argument or result.

Returns:
The EJB object currently associated with the instance.
Throws:
IllegalStateException - Thrown if the instance invokes this method while the instance is in a state that does not allow the instance to invoke this method, or if the instance does not have a remote interface.

getMessageContext

MessageContext getMessageContext()
                                 throws IllegalStateException
Obtain a reference to the JAX-RPC MessageContext.

An instance of a stateless session bean can call this method from any business method invoked through its web service endpoint interface.

Returns:
The MessageContext for this web service invocation.
Throws:
IllegalStateException - Thrown if this method is invoked while the instance is in a state that does not allow access to this method.

getBusinessObject

<T> T getBusinessObject(Class<T> businessInterface)
                    throws IllegalStateException
Obtain an object that can be used to invoke the current bean through the given business interface.

Parameters:
businessInterface - One of the local business interfaces or remote business interfaces for this session bean.
Returns:
The business object corresponding to the given business interface.
Throws:
IllegalStateException - Thrown if this method is invoked with an invalid business interface for the current bean.

getInvokedBusinessInterface

Class getInvokedBusinessInterface()
                                  throws IllegalStateException
Obtain the business interface through which the current business method invocation was made.

Throws:
IllegalStateException - Thrown if this method is called and the bean has not been invoked through a business interface.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SessionSynchronization

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface SessionSynchronization

public interface SessionSynchronization

The SessionSynchronization interface allows a session Bean instance to be notified by its container of transaction boundaries.

An session Bean class is not required to implement this interface. A session Bean class should implement this interface only if it wishes to synchronize its state with the transactions.

Method Summary
void | afterBegin() The afterBegin method notifies a session Bean instance that a new transaction has started, and that the subsequent business methods on the instance will be invoked in the context of the transaction.
void | afterCompletion(boolean committed) The afterCompletion method notifies a session Bean instance that a transaction commit protocol has completed, and tells the instance whether the transaction has been committed or rolled back.
void | beforeCompletion() The beforeCompletion method notifies a session Bean instance that a transaction is about to be committed.

Method Detail

afterBegin

void afterBegin()
                throws EJBException,
                       RemoteException
The afterBegin method notifies a session Bean instance that a new transaction has started, and that the subsequent business methods on the instance will be invoked in the context of the transaction.

The instance can use this method, for example, to read data from a database and cache the data in the instance fields.

This method executes in the proper transaction context.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 and higher specifications should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB 2.0 and higher specifications must not throw the java.rmi.RemoteException.

beforeCompletion

void beforeCompletion()
                      throws EJBException,
                             RemoteException
The beforeCompletion method notifies a session Bean instance that a transaction is about to be committed. The instance can use this method, for example, to write any cached data to a database.

This method executes in the proper transaction context.

Note: The instance may still cause the container to rollback the transaction by invoking the setRollbackOnly() method on the instance context, or by throwing an exception.

Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 and higher specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB 2.0 and higher specifications must not throw the java.rmi.RemoteException.

afterCompletion

void afterCompletion(boolean committed)
                     throws EJBException,
                            RemoteException
The afterCompletion method notifies a session Bean instance that a transaction commit protocol has completed, and tells the instance whether the transaction has been committed or rolled back.

This method executes with no transaction context.

This method executes with no transaction context.

Parameters:
committed - True if the transaction has been committed, false if is has been rolled back.
Throws:
EJBException - Thrown by the method to indicate a failure caused by a system-level error.
RemoteException - This exception is defined in the method signature to provide backward compatibility for enterprise beans written for the EJB 1.0 specification. Enterprise beans written for the EJB 1.1 and higher specification should throw the javax.ejb.EJBException instead of this exception. Enterprise beans written for the EJB 2.0 and higher specifications must not throw the java.rmi.RemoteException.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


spi

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.ejb.spi

The javax.ejb.spi package defines interfaces that are implemented by the EJB container.

See:
Description

Interface Summary
HandleDelegate The HandleDelegate interface is implemented by the EJB container.

Package javax.ejb.spi Description

The javax.ejb.spi package defines interfaces that are implemented by the EJB container. These interfaces are not used by application components.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.ejb.spi Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.ejb.spi

Package Hierarchies:
All Packages

Interface Hierarchy

  • javax.ejb.spi.HandleDelegate
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HandleDelegate

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.ejb.spi
Interface HandleDelegate

public interface HandleDelegate

The HandleDelegate interface is implemented by the EJB container. It is used by portable implementations of javax.ejb.Handle and javax.ejb.HomeHandle. It is not used by EJB components or by client components. It provides methods to serialize and deserialize EJBObject and EJBHome references to streams.

The HandleDelegate object is obtained by JNDI lookup at the reserved name "java:comp/HandleDelegate".

Method Summary
EJBHome | readEJBHome(ObjectInputStream istream) Deserialize the EJBHome reference corresponding to a HomeHandle.
EJBObject | readEJBObject(ObjectInputStream istream) Deserialize the EJBObject reference corresponding to a Handle.
void | writeEJBHome(EJBHome ejbHome, ObjectOutputStream ostream) Serialize the EJBHome reference corresponding to a HomeHandle.
void | writeEJBObject(EJBObject ejbObject, ObjectOutputStream ostream) Serialize the EJBObject reference corresponding to a Handle.

Method Detail

writeEJBObject

void writeEJBObject(EJBObject ejbObject,
                    ObjectOutputStream ostream)
                    throws IOException
Serialize the EJBObject reference corresponding to a Handle.

This method is called from the writeObject method of portable Handle implementation classes. The ostream object is the same object that was passed in to the Handle class's writeObject.

Parameters:
ejbObject - The EJBObject reference to be serialized.
ostream - The output stream.
Throws:
IOException - The EJBObject could not be serialized because of a system-level failure.

readEJBObject

EJBObject readEJBObject(ObjectInputStream istream)
                        throws IOException,
                               ClassNotFoundException
Deserialize the EJBObject reference corresponding to a Handle.

readEJBObject is called from the readObject method of portable Handle implementation classes. The istream object is the same object that was passed in to the Handle class's readObject. When readEJBObject is called, istream must point to the location in the stream at which the EJBObject reference can be read. The container must ensure that the EJBObject reference is capable of performing invocations immediately after deserialization.

Parameters:
istream - The input stream.
Returns:
The deserialized EJBObject reference.
Throws:
IOException - The EJBObject could not be deserialized because of a system-level failure.
ClassNotFoundException - The EJBObject could not be deserialized because some class could not be found.

writeEJBHome

void writeEJBHome(EJBHome ejbHome,
                  ObjectOutputStream ostream)
                  throws IOException
Serialize the EJBHome reference corresponding to a HomeHandle.

This method is called from the writeObject method of portable HomeHandle implementation classes. The ostream object is the same object that was passed in to the Handle class's writeObject.

Parameters:
ejbHome - The EJBHome reference to be serialized.
ostream - The output stream.
Throws:
IOException - The EJBObject could not be serialized because of a system-level failure.

readEJBHome

EJBHome readEJBHome(ObjectInputStream istream)
                    throws IOException,
                           ClassNotFoundException
Deserialize the EJBHome reference corresponding to a HomeHandle.

readEJBHome is called from the readObject method of portable HomeHandle implementation classes. The istream object is the same object that was passed in to the HomeHandle class's readObject. When readEJBHome is called, istream must point to the location in the stream at which the EJBHome reference can be read. The container must ensure that the EJBHome reference is capable of performing invocations immediately after deserialization.

Parameters:
istream - The input stream.
Returns:
The deserialized EJBHome reference.
Throws:
IOException - The EJBHome could not be deserialized because of a system-level failure.
ClassNotFoundException - The EJBHome could not be deserialized because some class could not be found.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Stateful

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type Stateful

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Stateful

Component-defining annotation for a stateful session bean.

Optional Element Summary
String | description
String | mappedName A product specific name(e.g. global JNDI name) that this session bean should be mapped to.
String | name ejb-name for this bean.

name

public abstract String name
ejb-name for this bean.

Default:
""

mappedName

public abstract String mappedName
A product specific name(e.g. global JNDI name) that this session bean should be mapped to. Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.

Default:
""

description

public abstract String description
Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Stateless

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type Stateless

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Stateless

Component-defining annotation for a stateless session bean.

Optional Element Summary
String | description
String | mappedName A product specific name(e.g. global JNDI name) that this session bean should be mapped to.
String | name ejb-name for this bean.

name

public abstract String name
ejb-name for this bean.

Default:
""

mappedName

public abstract String mappedName
A product specific name(e.g. global JNDI name) that this session bean should be mapped to. Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.

Default:
""

description

public abstract String description
Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TimedObject

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface TimedObject

public interface TimedObject

The TimedObject interface contains the callback method that is used to deliver timer expiration notifications. It is implemented by an entity bean or stateless session bean or message-driven bean class.

Method Summary
 void ejbTimeout(Timer timer)
Invoked by the EJB container upon timer expiration.

Method Detail

ejbTimeout

void ejbTimeout(Timer timer)
Invoked by the EJB container upon timer expiration.

Parameters:
timer - timer whose expiration caused this notification.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Timer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface Timer

public interface Timer

The Timer interface contains information about a timer that was created through the EJB Timer Service.

Method Summary
void | cancel() Cause the timer and all its associated expiration notifications to be cancelled.
TimerHandle | getHandle() Get a serializable handle to the timer.
Serializable | getInfo() Get the information associated with the timer at the time of creation.
Date | getNextTimeout() Get the point in time at which the next timer expiration is scheduled to occur.
long | getTimeRemaining() Get the number of milliseconds that will elapse before the next scheduled timer expiration.

Method Detail

cancel

void cancel()
            throws IllegalStateException,
                   NoSuchObjectLocalException,
                   EJBException
Cause the timer and all its associated expiration notifications to be cancelled.

Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
EJBException - If this method could not complete due to a system-level failure.

getTimeRemaining

long getTimeRemaining()
                      throws IllegalStateException,
                             NoSuchObjectLocalException,
                             EJBException
Get the number of milliseconds that will elapse before the next scheduled timer expiration.

Returns:
the number of milliseconds that will elapse before the next scheduled timer expiration.
Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
EJBException - If this method could not complete due to a system-level failure.

getNextTimeout

Date getNextTimeout()
                    throws IllegalStateException,
                           NoSuchObjectLocalException,
                           EJBException
Get the point in time at which the next timer expiration is scheduled to occur.

Returns:
the point in time at which the next timer expiration is scheduled to occur.
Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
EJBException - If this method could not complete due to a system-level failure.

getInfo

Serializable getInfo()
                     throws IllegalStateException,
                            NoSuchObjectLocalException,
                            EJBException
Get the information associated with the timer at the time of creation.

Returns:
The Serializable object that was passed in at timer creation, or null if the info argument passed in at timer creation was null.
Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
EJBException - If this method could not complete due to a system-level failure.

getHandle

TimerHandle getHandle()
                      throws IllegalStateException,
                             NoSuchObjectLocalException,
                             EJBException
Get a serializable handle to the timer. This handle can be used at a later time to re-obtain the timer reference.

Returns:
a serializable handle to the timer.
Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
NoSuchObjectLocalException - If invoked on a timer that has expired or has been cancelled.
EJBException - If this method could not complete due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TimerHandle

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface TimerHandle

All Superinterfaces:
Serializable
public interface TimerHandle
extends Serializable

The TimerHandle interface is implemented by all EJB timer handles.

Method Summary
 Timer getTimer()
Obtain a reference to the timer represented by this handle.

Method Detail

getTimer

Timer getTimer()
               throws IllegalStateException,
                      NoSuchObjectLocalException,
                      EJBException
Obtain a reference to the timer represented by this handle.

Returns:
a reference to the timer represented by this handle.
Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
NoSuchObjectLocalException - If invoked on a handle whose associated timer has expired or has been cancelled.
EJBException - If this method could not complete due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TimerService

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Interface TimerService

public interface TimerService

The TimerService interface provides enterprise bean components with access to the container-provided Timer Service. The EJB Timer Service allows entity beans, stateless session beans, and message-driven beans to be registered for timer callback events at a specified time, after a specified elapsed time, or after a specified interval.

Method Summary
Timer | createTimer(Date initialExpiration, long intervalDuration, Serializable info) Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.
Timer | createTimer(Date expiration, Serializable info) Create a single-action timer that expires at a given point in time.
Timer | createTimer(long initialDuration, long intervalDuration, Serializable info) Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.
Timer | createTimer(long duration, Serializable info) Create a single-action timer that expires after a specified duration.
Collection | getTimers() Get all the active timers associated with this bean.

Method Detail

createTimer

Timer createTimer(long duration,
                  Serializable info)
                  throws IllegalArgumentException,
                         IllegalStateException,
                         EJBException
Create a single-action timer that expires after a specified duration.

Parameters:
duration - The number of milliseconds that must elapse before the timer expires.
info - Application information to be delivered along with the timer expiration notification. This can be null.
Returns:
The newly created Timer.
Throws:
IllegalArgumentException - If duration is negative
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
EJBException - If this method fails due to a system-level failure.

createTimer

Timer createTimer(long initialDuration,
                  long intervalDuration,
                  Serializable info)
                  throws IllegalArgumentException,
                         IllegalStateException,
                         EJBException
Create an interval timer whose first expiration occurs after a specified duration, and whose subsequent expirations occur after a specified interval.

Parameters:
initialDuration - The number of milliseconds that must elapse before the first timer expiration notification.
intervalDuration - The number of milliseconds that must elapse between timer expiration notifications. Expiration notifications are scheduled relative to the time of the first expiration. If expiration is delayed(e.g. due to the interleaving of other method calls on the bean) two or more expiration notifications may occur in close succession to "catch up".
info - Application information to be delivered along with the timer expiration. This can be null.
Returns:
The newly created Timer.
Throws:
IllegalArgumentException - If initialDuration is negative, or intervalDuration is negative.
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
EJBException - If this method could not complete due to a system-level failure.

createTimer

Timer createTimer(Date expiration,
                  Serializable info)
                  throws IllegalArgumentException,
                         IllegalStateException,
                         EJBException
Create a single-action timer that expires at a given point in time.

Parameters:
expiration - The point in time at which the timer must expire.
info - Application information to be delivered along with the timer expiration notification. This can be null.
Returns:
The newly created Timer.
Throws:
IllegalArgumentException - If expiration is null, or expiration.getTime() is negative.
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
EJBException - If this method could not complete due to a system-level failure.

createTimer

Timer createTimer(Date initialExpiration,
                  long intervalDuration,
                  Serializable info)
                  throws IllegalArgumentException,
                         IllegalStateException,
                         EJBException
Create an interval timer whose first expiration occurs at a given point in time and whose subsequent expirations occur after a specified interval.

Parameters:
initialExpiration - The point in time at which the first timer expiration must occur.
intervalDuration - The number of milliseconds that must elapse between timer expiration notifications. Expiration notifications are scheduled relative to the time of the first expiration. If expiration is delayed(e.g. due to the interleaving of other method calls on the bean) two or more expiration notifications may occur in close succession to "catch up".
info - Application information to be delivered along with the timer expiration. This can be null.
Returns:
The newly created Timer.
Throws:
IllegalArgumentException - If initialExpiration is null, or initialExpiration.getTime() is negative, or intervalDuration is negative.
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
EJBException - If this method could not complete due to a system-level failure.

getTimers

Collection getTimers()
                     throws IllegalStateException,
                            EJBException
Get all the active timers associated with this bean.

Returns:
A collection of javax.ejb.Timer objects.
Throws:
IllegalStateException - If this method is invoked while the instance is in a state that does not allow access to this method.
EJBException - If this method could not complete due to a system-level failure.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransactionAttribute

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type TransactionAttribute

@Target(value={METHOD,TYPE})
@Retention(value=RUNTIME)
public @interface TransactionAttribute

When applied at the TYPE-level, designates the default transaction attribute for all business methods of the session or message driven bean. When applied at the method-level, designates the transaction attribute for only that method.

Optional Element Summary
 TransactionAttributeType value

value

public abstract TransactionAttributeType value
Default:
REQUIRED
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransactionAttributeType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.ejb
Enum TransactionAttributeType

java.lang.Object
    extended by  java.lang.Enum<TransactionAttributeType>
        extended by  javax.ejb.TransactionAttributeType
All Implemented Interfaces:
Serializable, Comparable<TransactionAttributeType>
public enum TransactionAttributeType
extends Enum<TransactionAttributeType>

Enum Constant Summary
MANDATORY
NEVER
NOT_SUPPORTED
REQUIRED
REQUIRES_NEW
SUPPORTS
Method Summary
static TransactionAttributeType | valueOf(String name) Returns the enum constant of this type with the specified name.
static TransactionAttributeType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

MANDATORY

public static final TransactionAttributeType MANDATORY

REQUIRED

public static final TransactionAttributeType REQUIRED

REQUIRES_NEW

public static final TransactionAttributeType REQUIRES_NEW

SUPPORTS

public static final TransactionAttributeType SUPPORTS

NOT_SUPPORTED

public static final TransactionAttributeType NOT_SUPPORTED

NEVER

public static final TransactionAttributeType NEVER
Method Detail

values

public static final TransactionAttributeType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(TransactionAttributeType c : TransactionAttributeType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static TransactionAttributeType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransactionManagement

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.ejb
Annotation Type TransactionManagement

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface TransactionManagement

Declares whether a session bean or message driven bean has container managed transactions or bean managed transactions.

Optional Element Summary
 TransactionManagementType value

value

public abstract TransactionManagementType value
Default:
CONTAINER
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransactionManagementType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.ejb
Enum TransactionManagementType

java.lang.Object
    extended by  java.lang.Enum<TransactionManagementType>
        extended by  javax.ejb.TransactionManagementType
All Implemented Interfaces:
Serializable, Comparable<TransactionManagementType>
public enum TransactionManagementType
extends Enum<TransactionManagementType>

Enum Constant Summary
BEAN
CONTAINER
Method Summary
static TransactionManagementType | valueOf(String name) Returns the enum constant of this type with the specified name.
static TransactionManagementType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

CONTAINER

public static final TransactionManagementType CONTAINER

BEAN

public static final TransactionManagementType BEAN
Method Detail

values

public static final TransactionManagementType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(TransactionManagementType c : TransactionManagementType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static TransactionManagementType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransactionRequiredLocalException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class TransactionRequiredLocalException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.ejb.EJBException
                    extended by  javax.ejb.TransactionRequiredLocalException
All Implemented Interfaces:
Serializable
public class TransactionRequiredLocalException
extends EJBException

This exception indicates that a request carried a null transaction context, but the target object requires an active transaction.

See Also:
Serialized Form

Constructor Summary
TransactionRequiredLocalException()
Constructs a TransactionRequiredLocalException with no detail message.
TransactionRequiredLocalException(String message)
Constructs an TransactionRequiredLocalException with the specified detailed message.
Method Summary
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionRequiredLocalException

public TransactionRequiredLocalException()
Constructs a TransactionRequiredLocalException with no detail message.

TransactionRequiredLocalException

public TransactionRequiredLocalException(String message)
Constructs an TransactionRequiredLocalException with the specified detailed message.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransactionRolledbackLocalException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.ejb
Class TransactionRolledbackLocalException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.ejb.EJBException
                    extended by  javax.ejb.TransactionRolledbackLocalException
All Implemented Interfaces:
Serializable
public class TransactionRolledbackLocalException
extends EJBException

This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back. Thus the requested operation either could not be performed or was not performed because further computation on behalf of the transaction would be fruitless

See Also:
Serialized Form

Constructor Summary
TransactionRolledbackLocalException()
Constructs a TransactionRolledbackLocalException with no detail message.
TransactionRolledbackLocalException(String message)
Constructs a TransactionRolledbackLocalException with the specified detailed message.
TransactionRolledbackLocalException(String message, Exception ex)
Constructs a TransactionRolledbackLocalException with the specified detail message and a nested exception.
Method Summary
Methods inherited from class javax.ejb.EJBException
getCausedByException, getMessage, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionRolledbackLocalException

public TransactionRolledbackLocalException()
Constructs a TransactionRolledbackLocalException with no detail message.

TransactionRolledbackLocalException

public TransactionRolledbackLocalException(String message)
Constructs a TransactionRolledbackLocalException with the specified detailed message.

TransactionRolledbackLocalException

public TransactionRolledbackLocalException(String message,
                                           Exception ex)
Constructs a TransactionRolledbackLocalException with the specified detail message and a nested exception.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


el

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.el

Provides the API for the Unified Expression Language shared by the JSP 2.1 and JSF 1.2 technologies.

See:
Description

Interface Summary
ELContextListener The listener interface for receiving notification when an ELContext is created.

Class Summary
ArrayELResolver | Defines property resolution behavior on arrays.
BeanELResolver | Defines property resolution behavior on objects using the JavaBeans component architecture.
BeanELResolver.BeanProperties |
BeanELResolver.BeanProperty |
CompositeELResolver | Maintains an ordered composite list of child ELResolvers.
ELContext | Context information for expression evaluation.
ELContextEvent | An event which indicates that an ELContext has been created.
ELResolver | Enables customization of variable and property resolution behavior for EL expression evaluation.
Expression | Base class for the expression subclasses ValueExpression and MethodExpression, implementing characterstics common to both.
ExpressionFactory | Parses a String into a ValueExpression or MethodExpression instance for later evaluation.
FunctionMapper | The interface to a map between EL function names and methods.
ListELResolver | Defines property resolution behavior on instances of List.
MapELResolver | Defines property resolution behavior on instances of Map.
MethodExpression | An Expression that refers to a method on an object.
MethodInfo | Holds information about a method that a MethodExpression evaluated to.
ResourceBundleELResolver | Defines property resolution behavior on instances of ResourceBundle.
ValueExpression | An Expression that can get or set a value.
VariableMapper | The interface to a map between EL variables and the EL expressions they are associated with.

Exception Summary
ELException | Represents any of the exception conditions that can arise during expression evaluation.
MethodNotFoundException | Thrown when a method could not be found while evaluating a MethodExpression.
PropertyNotFoundException | Thrown when a property could not be found while evaluating a ValueExpression or MethodExpression.
PropertyNotWritableException | Thrown when a property could not be written to while setting the value on a ValueExpression.

Package javax.el Description

Provides the API for the Unified Expression Language shared by the JSP 2.1 and JSF 1.2 technologies.

The Expression Language (EL) is a simple language designed to satisfy the specific needs of web application developers. It is currently defined in its own specification document within the JavaServer Pages (tm) (JSP) 2.1 specification, but does not have any dependencies on any portion of the JSP 2.1 specification. It is intended for general use outside of the JSP and JSF specifications as well.

This package contains the classes and interfaces that describe and define the programmatic access to the Expression Language engine. The API is logically partitioned as follows:

  • EL Context
  • Expression Objects
  • Creation of Expressions
  • Resolution of Model Objects and their Properties
  • EL Functions
  • EL Variables

EL Context

An important goal of the EL is to ensure it can be used in a variety of environments. It must therefore provide enough flexibility to adapt to the specific requirements of the environment where it is being used.

Class ELContext is what links the EL with the specific environment where it is being used. It provides the mechanism through which all relevant context for creating or evaluating an expression is specified.

Creation of ELContext objects is controlled through the underlying technology. For example, in JSP, the JspContext.getELContext() factory method is used.

Some technologies provide the ability to add an ELContextListener so that applications and frameworks can ensure their own context objects are attached to any newly created ELContext.

Expression Objects

At the core of the Expression Language is the notion of an expression that gets parsed according to the grammar defined by the Expression Language.

There are two types of expressions defined by the EL: value expressions and method expressions. A ValueExpression such as "${customer.name}" can be used either as an rvalue (return the value associated with property name of the model object customer) or as an lvalue (set the value of the property name of the model object customer).

A MethodExpression such as "${handler.process}" makes it possible to invoke a method (process) on a specific model object (handler).

All expression classes extend the base class Expression, making them serializable and forcing them to implement equals() and hashCode(). Morevover, each method on these expression classes that actually evaluates an expression receives a parameter of class ELContext, which provides the context required to evaluate the expression.

Creation of Expressions

An expression is created through the ExpressionFactory class. The factory provides two creation methods; one for each type of expression supported by the EL.

To create an expression, one must provide an ELContext, a string representing the expression, and the expected type (ValueExpression) or signature (MethodExpression). The ELContext provides the context necessary to parse an expression. Specifically, if the expression uses an EL function (for example ${fn:toUpperCase(customer.name)}) or an EL variable, then FunctionMapper and VariableMapper objects must be available within the ELContext so that EL functions and EL variables are properly mapped.

Resolution of Model Objects and their Properties

Through the ELResolver base class, the EL features a pluggable mechanism to resolve model object references as well as properties of these objects.

The EL API provides implementations of ELResolver supporting property resolution for common data types which include arrays (ArrayELResolver), JavaBeans (BeanELResolver), Lists (ListELResolver), Maps (MapELResolver), and ResourceBundles (ResourceBundleELResolver).

Tools can easily obtain more information about resolvable model objects and their resolvable properties by calling method getFeatureDescriptors on the ELResolver. This method exposes objects of type java.beans.FeatureDescriptor, providing all information of interest on top-level model objects as well as their properties.

EL Functions

If an EL expression uses a function (for example ${fn:toUpperCase(customer.name)}), then a FunctionMapper object must also be specified within the ELContext. The FunctionMapper is responsible to map ${prefix:name()} style functions to static methods that can execute the specified functions.

EL Variables

Just like FunctionMapper provides a flexible mechanism to add functions to the EL, VariableMapper provides a flexible mechanism to support the notion of EL variables.

An EL variable does not directly refer to a model object that can then be resolved by an ELResolver. Instead, it refers to an EL expression. The evaluation of that EL expression gives the EL variable its value.

For example, in the following code snippet

<h:inputText value="#{handler.customer.name}"/>
handler refers to a model object that can be resolved by an EL Resolver.

However, in this other example:

<c:forEach var="item" items="#{model.list}">
   <h:inputText value="#{item.name}"/>
</c:forEach>
item is an EL variable because it does not refer directly to a model object. Instead, it refers to another EL expression, namely a specific item in the collection referred to by the EL expression #{model.list}.

Assuming that there are three elements in ${model.list}, this means that for each invocation of <h:inputText>, the following information about item must be preserved in the VariableMapper:

first invocation: item maps to first element in ${model.list}
second invocation: item maps to second element in ${model.list}
third invocation: item maps to third element in ${model.list}

VariableMapper provides the mechanisms required to allow the mapping of an EL variable to the EL expression from which it gets its value.

Overview   Package  Class  Tree  Deprecated  Index  Help
Java EE 5 SDK
 PREV PACKAGE   NEXT PACKAGE FRAMES    NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.el Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.el

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.el.BeanELResolver.BeanProperties
    • javax.el.BeanELResolver.BeanProperty
    • javax.el.ELContext
    • javax.el.ELResolver
      • javax.el.ArrayELResolver
      • javax.el.BeanELResolver
      • javax.el.CompositeELResolver
      • javax.el.ListELResolver
      • javax.el.MapELResolver
      • javax.el.ResourceBundleELResolver
    • java.util.EventObject (implements java.io.Serializable)
      • javax.el.ELContextEvent
    • javax.el.Expression (implements java.io.Serializable)
      • javax.el.MethodExpression
      • javax.el.ValueExpression
    • javax.el.ExpressionFactory
    • javax.el.FunctionMapper
    • javax.el.MethodInfo
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.el.ELException
            • javax.el.MethodNotFoundException
            • javax.el.PropertyNotFoundException
            • javax.el.PropertyNotWritableException
    • javax.el.VariableMapper

Interface Hierarchy

  • java.util.EventListener
    • javax.el.ELContextListener
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ArrayELResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.el
Class ArrayELResolver

java.lang.Object
    extended by  javax.el.ELResolver
        extended by  javax.el.ArrayELResolver

public class ArrayELResolver
extends ELResolver

Defines property resolution behavior on arrays.

This resolver handles base objects that are Java language arrays. It accepts any object as a property and coerces that object into an integer index into the array. The resulting value is the value in the array at that index.

This resolver can be constructed in read-only mode, which means that isReadOnly will always return true and setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always throw PropertyNotWritableException.

ELResolvers are combined together using CompositeELResolvers, to define rich semantics for evaluating an expression. See the javadocs for ELResolver for details.

Since:
JSP 2.1
See Also:
CompositeELResolver, ELResolver

Field Summary
Fields inherited from class javax.el.ELResolver
RESOLVABLE_AT_DESIGN_TIME, TYPE
Constructor Summary
ArrayELResolver()
Creates a new read/write ArrayELResolver.
ArrayELResolver(boolean isReadOnly)
Creates a new ArrayELResolver whose read-only status is determined by the given parameter.
Method Summary
 Class<?> getCommonPropertyType(ELContext context, Object base)
If the base object is a Java language array, returns the most general type that this resolver accepts for the property argument.
 Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
Always returns null, since there is no reason to iterate through set set of all integers.
 Class<?> getType(ELContext context, Object base, Object property)
If the base object is an array, returns the most general acceptable type for a value in this array.
 Object getValue(ELContext context, Object base, Object property)
If the base object is a Java language array, returns the value at the given index.
 boolean isReadOnly(ELContext context, Object base, Object property)
If the base object is a Java language array, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
 void setValue(ELContext context, Object base, Object property, Object val)
If the base object is a Java language array, attempts to set the value at the given index with the given value.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ArrayELResolver

public ArrayELResolver()
Creates a new read/write ArrayELResolver.

ArrayELResolver

public ArrayELResolver(boolean isReadOnly)
Creates a new ArrayELResolver whose read-only status is determined by the given parameter.

Parameters:
isReadOnly - true if this resolver cannot modify arrays; false otherwise.
Method Detail

getType

public Class<?> getType(ELContext context,
                        Object base,
                        Object property)
If the base object is an array, returns the most general acceptable type for a value in this array.

If the base is a array, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

Assuming the base is an array, this method will always return base.getClass().getComponentType(), which is the most general type of component that can be stored at any given index in the array.

Specified by:
getType in class ELResolver
Parameters:
context - The context of this evaluation.
base - The array to analyze. Only bases that are Java language arrays are handled by this resolver.
property - The index of the element in the array to return the acceptable type for. Will be coerced into an integer, but otherwise ignored by this resolver.
Returns:
If the propertyResolved property of ELContext was set to true, then the most general acceptable type; otherwise undefined.
Throws:
PropertyNotFoundException - if the given index is out of bounds for this array.
NullPointerException - if context is null
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getValue

public Object getValue(ELContext context,
                       Object base,
                       Object property)
If the base object is a Java language array, returns the value at the given index. The index is specified by the property argument, and coerced into an integer. If the coercion could not be performed, an IllegalArgumentException is thrown. If the index is out of bounds, null is returned.

If the base is a Java language array, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

Specified by:
getValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - The array to analyze. Only bases that are Java language arrays are handled by this resolver.
property - The index of the value to be returned. Will be coerced into an integer.
Returns:
If the propertyResolved property of ELContext was set to true, then the value at the given index or null if the index was out of bounds. Otherwise, undefined.
Throws:
IllegalArgumentException - if the property could not be coerced into an integer.
NullPointerException - if context is null.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

setValue

public void setValue(ELContext context,
                     Object base,
                     Object property,
                     Object val)
If the base object is a Java language array, attempts to set the value at the given index with the given value. The index is specified by the property argument, and coerced into an integer. If the coercion could not be performed, an IllegalArgumentException is thrown. If the index is out of bounds, a PropertyNotFoundException is thrown.

If the base is a Java language array, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value was set.

If this resolver was constructed in read-only mode, this method will always throw PropertyNotWritableException.

Specified by:
setValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - The array to be modified. Only bases that are Java language arrays are handled by this resolver.
property - The index of the value to be set. Will be coerced into an integer.
val - The value to be set at the given index.
Throws:
ClassCastException - if the class of the specified element prevents it from being added to this array.
NullPointerException - if context is null.
IllegalArgumentException - if the property could not be coerced into an integer, or if some aspect of the specified element prevents it from being added to this array.
PropertyNotWritableException - if this resolver was constructed in read-only mode.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

isReadOnly

public boolean isReadOnly(ELContext context,
                          Object base,
                          Object property)
If the base object is a Java language array, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

If the base is a Java language array, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

If this resolver was constructed in read-only mode, this method will always return true. Otherwise, it returns false.

Specified by:
isReadOnly in class ELResolver
Parameters:
context - The context of this evaluation.
base - The array to analyze. Only bases that are a Java language array are handled by this resolver.
property - The index of the element in the array to return the acceptable type for. Will be coerced into an integer, but otherwise ignored by this resolver.
Returns:
If the propertyResolved property of ELContext was set to true, then true if calling the setValue method will always fail or false if it is possible that such a call may succeed; otherwise undefined.
Throws:
PropertyNotFoundException - if the given index is out of bounds for this array.
NullPointerException - if context is null
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getFeatureDescriptors

public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                         Object base)
Always returns null, since there is no reason to iterate through set set of all integers.

The getCommonPropertyType(javax.el.ELContext, java.lang.Object) method returns sufficient information about what properties this resolver accepts.

Specified by:
getFeatureDescriptors in class ELResolver
Parameters:
context - The context of this evaluation.
base - The array to analyze. Only bases that are a Java language array are handled by this resolver.
Returns:
null.
See Also:
FeatureDescriptor

getCommonPropertyType

public Class<?> getCommonPropertyType(ELContext context,
                                      Object base)
If the base object is a Java language array, returns the most general type that this resolver accepts for the property argument. Otherwise, returns null.

Assuming the base is an array, this method will always return Integer.class. This is because arrays accept integers for their index.

Specified by:
getCommonPropertyType in class ELResolver
Parameters:
context - The context of this evaluation.
base - The array to analyze. Only bases that are a Java language array are handled by this resolver.
Returns:
null if base is not a Java language array; otherwise Integer.class.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BeanELResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class BeanELResolver

java.lang.Object
    extended by  javax.el.ELResolver
        extended by  javax.el.BeanELResolver

public class BeanELResolver
extends ELResolver

Defines property resolution behavior on objects using the JavaBeans component architecture.

This resolver handles base objects of any type, as long as the base is not null. It accepts any object as a property, and coerces it to a string. That string is then used to find a JavaBeans compliant property on the base object. The value is accessed using JavaBeans getters and setters.

This resolver can be constructed in read-only mode, which means that isReadOnly will always return true and setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always throw PropertyNotWritableException.

ELResolvers are combined together using CompositeELResolvers, to define rich semantics for evaluating an expression. See the javadocs for ELResolver for details.

Because this resolver handles base objects of any type, it should be placed near the end of a composite resolver. Otherwise, it will claim to have resolved a property before any resolvers that come after it get a chance to test if they can do so as well.

Since:
JSP 2.1
See Also:
CompositeELResolver, ELResolver

Nested Class Summary
protected static class | BeanELResolver.BeanProperties
protected static class | BeanELResolver.BeanProperty
Field Summary
Fields inherited from class javax.el.ELResolver
RESOLVABLE_AT_DESIGN_TIME, TYPE
Constructor Summary
BeanELResolver()
Creates a new read/write BeanELResolver.
BeanELResolver(boolean isReadOnly)
Creates a new BeanELResolver whose read-only status is determined by the given parameter.
Method Summary
 Class<?> getCommonPropertyType(ELContext context, Object base)
If the base object is not null, returns the most general type that this resolver accepts for the property argument.
 Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
If the base object is not null, returns an Iterator containing the set of JavaBeans properties available on the given object.
 Class<?> getType(ELContext context, Object base, Object property)
If the base object is not null, returns the most general acceptable type that can be set on this bean property.
 Object getValue(ELContext context, Object base, Object property)
If the base object is not null, returns the current value of the given property on this bean.
 boolean isReadOnly(ELContext context, Object base, Object property)
If the base object is not null, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
 void setValue(ELContext context, Object base, Object property, Object val)
If the base object is not null, attempts to set the value of the given property on this bean.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BeanELResolver

public BeanELResolver()
Creates a new read/write BeanELResolver.

BeanELResolver

public BeanELResolver(boolean isReadOnly)
Creates a new BeanELResolver whose read-only status is determined by the given parameter.

Parameters:
isReadOnly - true if this resolver cannot modify beans; false otherwise.
Method Detail

getType

public Class<?> getType(ELContext context,
                        Object base,
                        Object property)
If the base object is not null, returns the most general acceptable type that can be set on this bean property.

If the base is not null, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

The provided property will first be coerced to a String. If there is a BeanInfoProperty for this property and there were no errors retrieving it, the propertyType of the propertyDescriptor is returned. Otherwise, a PropertyNotFoundException is thrown.

Specified by:
getType in class ELResolver
Parameters:
context - The context of this evaluation.
base - The bean to analyze.
property - The name of the property to analyze. Will be coerced to a String.
Returns:
If the propertyResolved property of ELContext was set to true, then the most general acceptable type; otherwise undefined.
Throws:
NullPointerException - if context is null
PropertyNotFoundException - if base is not null and the specified property does not exist or is not readable.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getValue

public Object getValue(ELContext context,
                       Object base,
                       Object property)
If the base object is not null, returns the current value of the given property on this bean.

If the base is not null, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

The provided property name will first be coerced to a String. If the property is a readable property of the base object, as per the JavaBeans specification, then return the result of the getter call. If the getter throws an exception, it is propagated to the caller. If the property is not found or is not readable, a PropertyNotFoundException is thrown.

Specified by:
getValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - The bean on which to get the property.
property - The name of the property to get. Will be coerced to a String.
Returns:
If the propertyResolved property of ELContext was set to true, then the value of the given property. Otherwise, undefined.
Throws:
NullPointerException - if context is null.
PropertyNotFoundException - if base is not null and the specified property does not exist or is not readable.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

setValue

public void setValue(ELContext context,
                     Object base,
                     Object property,
                     Object val)
If the base object is not null, attempts to set the value of the given property on this bean.

If the base is not null, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value was set.

If this resolver was constructed in read-only mode, this method will always throw PropertyNotWritableException.

The provided property name will first be coerced to a String. If property is a writable property of base (as per the JavaBeans Specification), the setter method is called (passing value). If the property exists but does not have a setter, then a PropertyNotFoundException is thrown. If the property does not exist, a PropertyNotFoundException is thrown.

Specified by:
setValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - The bean on which to set the property.
property - The name of the property to set. Will be coerced to a String.
val - The value to be associated with the specified key.
Throws:
NullPointerException - if context is null.
PropertyNotFoundException - if base is not null and the specified property does not exist.
PropertyNotWritableException - if this resolver was constructed in read-only mode, or if there is no setter for the property.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

isReadOnly

public boolean isReadOnly(ELContext context,
                          Object base,
                          Object property)
If the base object is not null, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

If the base is not null, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value was set.

If this resolver was constructed in read-only mode, this method will always return true.

The provided property name will first be coerced to a String. If property is a writable property of base, false is returned. If the property is found but is not writable, true is returned. If the property is not found, a PropertyNotFoundException is thrown.

Specified by:
isReadOnly in class ELResolver
Parameters:
context - The context of this evaluation.
base - The bean to analyze.
property - The name of the property to analyzed. Will be coerced to a String.
Returns:
If the propertyResolved property of ELContext was set to true, then true if calling the setValue method will always fail or false if it is possible that such a call may succeed; otherwise undefined.
Throws:
NullPointerException - if context is null
PropertyNotFoundException - if base is not null and the specified property does not exist.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getFeatureDescriptors

public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                         Object base)
If the base object is not null, returns an Iterator containing the set of JavaBeans properties available on the given object. Otherwise, returns null.

The Iterator returned must contain zero or more instances of FeatureDescriptor. Each info object contains information about a property in the bean, as obtained by calling the BeanInfo.getPropertyDescriptors method. The FeatureDescriptor is initialized using the same fields as are present in the PropertyDescriptor, with the additional required named attributes "type" and "resolvableAtDesignTime" set as follows:

  • ELResolver.TYPE - The runtime type of the property, from PropertyDescriptor.getPropertyType().
  • ELResolver.RESOLVABLE_AT_DESIGN_TIME - true.

    • Specified by:
    getFeatureDescriptors in class ELResolver
    Parameters:
    context - The context of this evaluation.
    base - The bean to analyze.
    Returns:
    An Iterator containing zero or more FeatureDescriptor objects, each representing a property on this bean, or null if the base object is null.
    See Also:
    FeatureDescriptor

    getCommonPropertyType

    public Class<?> getCommonPropertyType(ELContext context,
                                      Object base)
    If the base object is not null, returns the most general type that this resolver accepts for the property argument. Otherwise, returns null.

    Assuming the base is not null, this method will always return Object.class. This is because any object is accepted as a key and is coerced into a string.

    Specified by:
    getCommonPropertyType in class ELResolver
    Parameters:
    context - The context of this evaluation.
    base - The bean to analyze.
    Returns:
    null if base is null; otherwise Object.class.
    Overview Package Class Tree Deprecated Index Help
            Java EE 5 SDK
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
    Submit a bug or feature

    Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BeanELResolver.BeanProperties

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class BeanELResolver.BeanProperties

java.lang.Object
    extended by  javax.el.BeanELResolver.BeanProperties
Enclosing class:
BeanELResolver
protected static final class BeanELResolver.BeanProperties
extends Object

Constructor Summary
BeanELResolver.BeanProperties(Class<?> baseClass)
Method Summary
 BeanELResolver.BeanProperty getBeanProperty(String property)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BeanELResolver.BeanProperties

public BeanELResolver.BeanProperties(Class<?> baseClass)
Method Detail

getBeanProperty

public BeanELResolver.BeanProperty getBeanProperty(String property)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BeanELResolver.BeanProperty

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class BeanELResolver.BeanProperty

java.lang.Object
    extended by  javax.el.BeanELResolver.BeanProperty
Enclosing class:
BeanELResolver
protected static final class BeanELResolver.BeanProperty
extends Object

Constructor Summary
BeanELResolver.BeanProperty(Class<?> baseClass, PropertyDescriptor descriptor)
Method Summary
Class | getPropertyType()
Method | getReadMethod()
Method | getWriteMethod()
boolean | isReadOnly()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BeanELResolver.BeanProperty

public BeanELResolver.BeanProperty(Class<?> baseClass,
                                   PropertyDescriptor descriptor)
Method Detail

getPropertyType

public Class getPropertyType()

isReadOnly

public boolean isReadOnly()

getReadMethod

public Method getReadMethod()

getWriteMethod

public Method getWriteMethod()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


CompositeELResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class CompositeELResolver

java.lang.Object
    extended by  javax.el.ELResolver
        extended by  javax.el.CompositeELResolver

public class CompositeELResolver
extends ELResolver

Maintains an ordered composite list of child ELResolvers.

Though only a single ELResolver is associated with an ELContext, there are usually multiple resolvers considered for any given variable or property resolution. ELResolvers are combined together using a CompositeELResolver, to define rich semantics for evaluating an expression.

For the getValue(javax.el.ELContext, java.lang.Object, java.lang.Object), getType(javax.el.ELContext, java.lang.Object, java.lang.Object), setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) and isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object) methods, an ELResolver is not responsible for resolving all possible (base, property) pairs. In fact, most resolvers will only handle a base of a single type. To indicate that a resolver has successfully resolved a particular (base, property) pair, it must set the propertyResolved property of the ELContext to true. If it could not handle the given pair, it must leave this property alone. The caller must ignore the return value of the method if propertyResolved is false.

The CompositeELResolver initializes the ELContext.propertyResolved flag to false, and uses it as a stop condition for iterating through its component resolvers.

The ELContext.propertyResolved flag is not used for the design-time methods getFeatureDescriptors(javax.el.ELContext, java.lang.Object) and getCommonPropertyType(javax.el.ELContext, java.lang.Object). Instead, results are collected and combined from all child ELResolvers for these methods.

Since:
JSP 2.1
See Also:
ELContext, ELResolver

Field Summary
Fields inherited from class javax.el.ELResolver
RESOLVABLE_AT_DESIGN_TIME, TYPE
Constructor Summary
CompositeELResolver()
Method Summary
 void add(ELResolver elResolver)
Adds the given resolver to the list of component resolvers.
 Class<?> getCommonPropertyType(ELContext context, Object base)
Returns the most general type that this resolver accepts for the property argument, given a base object.
 Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
Returns information about the set of variables or properties that can be resolved for the given base object.
 Class<?> getType(ELContext context, Object base, Object property)
For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.
 Object getValue(ELContext context, Object base, Object property)
Attempts to resolve the given property object on the given base object by querying all component resolvers.
 boolean isReadOnly(ELContext context, Object base, Object property)
For a given base and property, attempts to determine whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
 void setValue(ELContext context, Object base, Object property, Object val)
Attempts to set the value of the given property object on the given base object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CompositeELResolver

public CompositeELResolver()
Method Detail

add

public void add(ELResolver elResolver)
Adds the given resolver to the list of component resolvers.

Resolvers are consulted in the order in which they are added.

Parameters:
elResolver - The component resolver to add.
Throws:
NullPointerException - If the provided resolver is null.

getValue

public Object getValue(ELContext context,
                       Object base,
                       Object property)
Attempts to resolve the given property object on the given base object by querying all component resolvers.

If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

First, propertyResolved is set to false on the provided ELContext.

Next, for each component resolver in this composite:

  1. The getValue() method is called, passing in the provided context, base and property.
  2. If the ELContext's propertyResolved flag is false then iteration continues.
  3. Otherwise, iteration stops and no more component resolvers are considered. The value returned by getValue() is returned by this method.

If none of the component resolvers were able to perform this operation, the value null is returned and the propertyResolved flag remains set to false

.

Any exception thrown by component resolvers during the iteration is propagated to the caller of this method.

Specified by:
getValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - The base object whose property value is to be returned, or null to resolve a top-level variable.
property - The property or variable to be resolved.
Returns:
If the propertyResolved property of ELContext was set to true, then the result of the variable or property resolution; otherwise undefined.
Throws:
NullPointerException - if context is null
PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist or is not readable.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getType

public Class<?> getType(ELContext context,
                        Object base,
                        Object property)
For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method. The result is obtained by querying all component resolvers.

If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

First, propertyResolved is set to false on the provided ELContext.

Next, for each component resolver in this composite:

  1. The getType() method is called, passing in the provided context, base and property.
  2. If the ELContext's propertyResolved flag is false then iteration continues.
  3. Otherwise, iteration stops and no more component resolvers are considered. The value returned by getType() is returned by this method.

If none of the component resolvers were able to perform this operation, the value null is returned and the propertyResolved flag remains set to false

.

Any exception thrown by component resolvers during the iteration is propagated to the caller of this method.

Specified by:
getType in class ELResolver
Parameters:
context - The context of this evaluation.
base - The base object whose property value is to be analyzed, or null to analyze a top-level variable.
property - The property or variable to return the acceptable type for.
Returns:
If the propertyResolved property of ELContext was set to true, then the most general acceptable type; otherwise undefined.
Throws:
NullPointerException - if context is null
PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist or is not readable.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

setValue

public void setValue(ELContext context,
                     Object base,
                     Object property,
                     Object val)
Attempts to set the value of the given property object on the given base object. All component resolvers are asked to attempt to set the value.

If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value has been set.

First, propertyResolved is set to false on the provided ELContext.

Next, for each component resolver in this composite:

  1. The setValue() method is called, passing in the provided context, base, property and value.
  2. If the ELContext's propertyResolved flag is false then iteration continues.
  3. Otherwise, iteration stops and no more component resolvers are considered.

If none of the component resolvers were able to perform this operation, the propertyResolved flag remains set to false

.

Any exception thrown by component resolvers during the iteration is propagated to the caller of this method.

Specified by:
setValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - The base object whose property value is to be set, or null to set a top-level variable.
property - The property or variable to be set.
val - The value to set the property or variable to.
Throws:
NullPointerException - if context is null
PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist.
PropertyNotWritableException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property is not writable.
ELException - if an exception was thrown while attempting to set the property or variable. The thrown exception must be included as the cause property of this exception, if available.

isReadOnly

public boolean isReadOnly(ELContext context,
                          Object base,
                          Object property)
For a given base and property, attempts to determine whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail. The result is obtained by querying all component resolvers.

If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

First, propertyResolved is set to false on the provided ELContext.

Next, for each component resolver in this composite:

  1. The isReadOnly() method is called, passing in the provided context, base and property.
  2. If the ELContext's propertyResolved flag is false then iteration continues.
  3. Otherwise, iteration stops and no more component resolvers are considered. The value returned by isReadOnly() is returned by this method.

If none of the component resolvers were able to perform this operation, the value false is returned and the propertyResolved flag remains set to false

.

Any exception thrown by component resolvers during the iteration is propagated to the caller of this method.

Specified by:
isReadOnly in class ELResolver
Parameters:
context - The context of this evaluation.
base - The base object whose property value is to be analyzed, or null to analyze a top-level variable.
property - The property or variable to return the read-only status for.
Returns:
If the propertyResolved property of ELContext was set to true, then true if the property is read-only or false if not; otherwise undefined.
Throws:
NullPointerException - if context is null
PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getFeatureDescriptors

public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                         Object base)
Returns information about the set of variables or properties that can be resolved for the given base object. One use for this method is to assist tools in auto-completion. The results are collected from all component resolvers.

The propertyResolved property of the ELContext is not relevant to this method. The results of all ELResolvers are concatenated.

The Iterator returned is an iterator over the collection of FeatureDescriptor objects returned by the iterators returned by each component resolver's getFeatureDescriptors method. If null is returned by a resolver, it is skipped.

Specified by:
getFeatureDescriptors in class ELResolver
Parameters:
context - The context of this evaluation.
base - The base object whose set of valid properties is to be enumerated, or null to enumerate the set of top-level variables that this resolver can evaluate.
Returns:
An Iterator containing zero or more (possibly infinitely more) FeatureDescriptor objects, or null if this resolver does not handle the given base object or that the results are too complex to represent with this method
See Also:
FeatureDescriptor

getCommonPropertyType

public Class<?> getCommonPropertyType(ELContext context,
                                      Object base)
Returns the most general type that this resolver accepts for the property argument, given a base object. One use for this method is to assist tools in auto-completion. The result is obtained by querying all component resolvers.

The Class returned is the most specific class that is a common superclass of all the classes returned by each component resolver's getCommonPropertyType method. If null is returned by a resolver, it is skipped.

Specified by:
getCommonPropertyType in class ELResolver
Parameters:
context - The context of this evaluation.
base - The base object to return the most general property type for, or null to enumerate the set of top-level variables that this resolver can evaluate.
Returns:
null if this ELResolver does not know how to handle the given base object; otherwise Object.class if any type of property is accepted; otherwise the most general property type accepted for the given base.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ELContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class ELContext

java.lang.Object
    extended by  javax.el.ELContext

public abstract class ELContext
extends Object

Context information for expression evaluation.

To evaluate an Expression, an ELContext must be provided. The ELContext holds:

  • a reference to the base ELResolver that will be consulted to resolve model objects and their properties
  • a reference to FunctionMapper that will be used to resolve EL Functions.
  • a reference to VariableMapper that will be used to resolve EL Variables.
  • a collection of all the relevant context objects for use by ELResolvers
  • state information during the evaluation of an expression, such as whether a property has been resolved yet

The collection of context objects is necessary because each ELResolver may need access to a different context object. For example, JSP and Faces resolvers need access to a JspContext and a FacesContext, respectively.

Creation of ELContext objects is controlled through the underlying technology. For example, in JSP the JspContext.getELContext() factory method is used. Some technologies provide the ability to add an ELContextListener so that applications and frameworks can ensure their own context objects are attached to any newly created ELContext.

Because it stores state during expression evaluation, an ELContext object is not thread-safe. Care should be taken to never share an ELContext instance between two or more threads.

Since:
JSP 2.1
See Also:
ELContextListener, ELContextEvent, ELResolver, FunctionMapper, VariableMapper, JspContext

Constructor Summary
ELContext()
Method Summary
 Object getContext(Class key)
Returns the context object associated with the given key.
abstract  ELResolver getELResolver()
Retrieves the ELResolver associated with this context.
abstract  FunctionMapper getFunctionMapper()
Retrieves the FunctionMapper associated with this ELContext.
 Locale getLocale()
Get the Locale stored by a previous invocation to setLocale(java.util.Locale).
abstract  VariableMapper getVariableMapper()
Retrieves the VariableMapper associated with this ELContext.
 boolean isPropertyResolved()
Returns whether an ELResolver has successfully resolved a given (base, property) pair.
 void putContext(Class key, Object contextObject)
Associates a context object with this ELContext.
 void setLocale(Locale locale)
Set the Locale for this instance.
 void setPropertyResolved(boolean resolved)
Called to indicate that a ELResolver has successfully resolved a given (base, property) pair.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ELContext

public ELContext()
Method Detail

setPropertyResolved

public void setPropertyResolved(boolean resolved)
Called to indicate that a ELResolver has successfully resolved a given (base, property) pair.

The CompositeELResolver checks this property to determine whether it should consider or skip other component resolvers.

Parameters:
resolved - true if the property has been resolved, or false if not.
See Also:
CompositeELResolver

isPropertyResolved

public boolean isPropertyResolved()
Returns whether an ELResolver has successfully resolved a given (base, property) pair.

The CompositeELResolver checks this property to determine whether it should consider or skip other component resolvers.

Returns:
true if the property has been resolved, or false if not.
See Also:
CompositeELResolver

putContext

public void putContext(Class key,
                       Object contextObject)
Associates a context object with this ELContext.

The ELContext maintains a collection of context objects relevant to the evaluation of an expression. These context objects are used by ELResolvers. This method is used to add a context object to that collection.

By convention, the contextObject will be of the type specified by the key. However, this is not required and the key is used strictly as a unique identifier.

Parameters:
key - The key used by an @{link ELResolver} to identify this context object.
contextObject - The context object to add to the collection.
Throws:
NullPointerException - if key is null or contextObject is null.

getContext

public Object getContext(Class key)
Returns the context object associated with the given key.

The ELContext maintains a collection of context objects relevant to the evaluation of an expression. These context objects are used by ELResolvers. This method is used to retrieve the context with the given key from the collection.

By convention, the object returned will be of the type specified by the key. However, this is not required and the key is used strictly as a unique identifier.

Parameters:
key - The unique identifier that was used to associate the context object with this ELContext.
Returns:
The context object associated with the given key, or null if no such context was found.
Throws:
NullPointerException - if key is null.

getELResolver

public abstract ELResolver getELResolver()
Retrieves the ELResolver associated with this context.

The ELContext maintains a reference to the ELResolver that will be consulted to resolve variables and properties during an expression evaluation. This method retrieves the reference to the resolver.

Once an ELContext is constructed, the reference to the ELResolver associated with the context cannot be changed.

Returns:
The resolver to be consulted for variable and property resolution during expression evaluation.

getFunctionMapper

public abstract FunctionMapper getFunctionMapper()
Retrieves the FunctionMapper associated with this ELContext.

Returns:
The function mapper to be consulted for the resolution of EL functions.

getLocale

public Locale getLocale()
Get the Locale stored by a previous invocation to setLocale(java.util.Locale). If this method returns non null, this Locale must be used for all localization needs in the implementation. The Locale must not be cached to allow for applications that change Locale dynamically.

Returns:
The Locale in which this instance is operating. Used primarily for message localization.

setLocale

public void setLocale(Locale locale)
Set the Locale for this instance. This method may be called by the party creating the instance, such as JavaServer Faces or JSP, to enable the EL implementation to provide localized messages to the user. If no Locale is set, the implementation must use the locale returned by Locale.getDefault( ).

getVariableMapper

public abstract VariableMapper getVariableMapper()
Retrieves the VariableMapper associated with this ELContext.

Returns:
The variable mapper to be consulted for the resolution of EL variables.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ELContextEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class ELContextEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.el.ELContextEvent
All Implemented Interfaces:
Serializable
public class ELContextEvent
extends EventObject

An event which indicates that an ELContext has been created. The source object is the ELContext that was created.

Since:
JSP 2.1
See Also:
ELContext, ELContextListener, Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
ELContextEvent(ELContext source)
Constructs an ELContextEvent object to indicate that an ELContext has been created.
Method Summary
 ELContext getELContext()
Returns the ELContext that was created.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ELContextEvent

public ELContextEvent(ELContext source)
Constructs an ELContextEvent object to indicate that an ELContext has been created.

Parameters:
source - the ELContext that was created.
Method Detail

getELContext

public ELContext getELContext()
Returns the ELContext that was created. This is a type-safe equivalent of the EventObject.getSource() method.

Returns:
the ELContext that was created.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ELContextListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Interface ELContextListener

All Superinterfaces:
EventListener
public interface ELContextListener
extends EventListener

The listener interface for receiving notification when an ELContext is created.

Since:
JSP 2.1
See Also:
ELContext, ELContextEvent

Method Summary
 void contextCreated(ELContextEvent ece)
Invoked when a new ELContext has been created.

Method Detail

contextCreated

void contextCreated(ELContextEvent ece)
Invoked when a new ELContext has been created.

Parameters:
ece - the notification event.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ELException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class ELException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.el.ELException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
MethodNotFoundException, PropertyNotFoundException, PropertyNotWritableException
public class ELException
extends RuntimeException

Represents any of the exception conditions that can arise during expression evaluation.

Since:
JSP 2.1
See Also:
Serialized Form

Constructor Summary
ELException()
Creates an ELException with no detail message.
ELException(String pMessage)
Creates an ELException with the provided detail message.
ELException(String pMessage, Throwable pRootCause)
Creates an ELException with the given detail message and root cause.
ELException(Throwable pRootCause)
Creates an ELException with the given cause.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ELException

public ELException()
Creates an ELException with no detail message.

ELException

public ELException(String pMessage)
Creates an ELException with the provided detail message.

Parameters:
pMessage - the detail message

ELException

public ELException(Throwable pRootCause)
Creates an ELException with the given cause.

Parameters:
pRootCause - the originating cause of this exception

ELException

public ELException(String pMessage,
                   Throwable pRootCause)
Creates an ELException with the given detail message and root cause.

Parameters:
pMessage - the detail message
pRootCause - the originating cause of this exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ELResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class ELResolver

java.lang.Object
    extended by  javax.el.ELResolver
Direct Known Subclasses:
ArrayELResolver, BeanELResolver, CompositeELResolver, ImplicitObjectELResolver, ListELResolver, MapELResolver, ResourceBundleELResolver, ScopedAttributeELResolver
public abstract class ELResolver
extends Object

Enables customization of variable and property resolution behavior for EL expression evaluation.

While evaluating an expression, the ELResolver associated with the ELContext is consulted to do the initial resolution of the first variable of an expression. It is also consulted when a . or [] operator is encountered, except for the last such operator in a method expression, in which case the resultion rules are hard coded.

For example, in the EL expression ${employee.lastName}, the ELResolver determines what object employee refers to, and what it means to get the lastName property on that object.

Most methods in this class accept a base and property parameter. In the case of variable resolution (e.g. determining what employee refers to in ${employee.lastName}), the base parameter will be null and the property parameter will always be of type String. In this case, if the property is not a String, the behavior of the ELResolver is undefined.

In the case of property resolution, the base parameter identifies the base object and the property object identifies the property on that base. For example, in the expression ${employee.lastName}, base is the result of the variable resolution for employee and property is the string "lastName". In the expression ${y[x]}, base is the result of the variable resolution for y and property is the result of the variable resolution for x.

Though only a single ELResolver is associated with an ELContext, there are usually multiple resolvers considered for any given variable or property resolution. ELResolvers are combined together using CompositeELResolvers, to define rich semantics for evaluating an expression.

For the getValue(javax.el.ELContext, java.lang.Object, java.lang.Object), getType(javax.el.ELContext, java.lang.Object, java.lang.Object), setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) and isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object) methods, an ELResolver is not responsible for resolving all possible (base, property) pairs. In fact, most resolvers will only handle a base of a single type. To indicate that a resolver has successfully resolved a particular (base, property) pair, it must set the propertyResolved property of the ELContext to true. If it could not handle the given pair, it must leave this property alone. The caller must ignore the return value of the method if propertyResolved is false.

The getFeatureDescriptors(javax.el.ELContext, java.lang.Object) and getCommonPropertyType(javax.el.ELContext, java.lang.Object) methods are primarily designed for design-time tool support, but must handle invocation at runtime as well. The Beans.isDesignTime() method can be used to determine if the resolver is being consulted at design-time or runtime.

Since:
JSP 2.1
See Also:
CompositeELResolver, ELContext.getELResolver()

Field Summary
static String | RESOLVABLE_AT_DESIGN_TIME The attribute name of the named attribute in the FeatureDescriptor that specifies whether the variable or property can be resolved at runtime.
static String | TYPE The attribute name of the named attribute in the FeatureDescriptor that specifies the runtime type of the variable or property.
Constructor Summary
ELResolver()
Method Summary
abstract  Class<?> getCommonPropertyType(ELContext context, Object base)
Returns the most general type that this resolver accepts for the property argument, given a base object.
abstract  Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
Returns information about the set of variables or properties that can be resolved for the given base object.
abstract  Class<?> getType(ELContext context, Object base, Object property)
For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.
abstract  Object getValue(ELContext context, Object base, Object property)
Attempts to resolve the given property object on the given base object.
abstract  boolean isReadOnly(ELContext context, Object base, Object property)
For a given base and property, attempts to determine whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
abstract  void setValue(ELContext context, Object base, Object property, Object value)
Attempts to set the value of the given property object on the given base object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TYPE

public static final String TYPE

The attribute name of the named attribute in the FeatureDescriptor that specifies the runtime type of the variable or property.

See Also:
Constant Field Values

RESOLVABLE_AT_DESIGN_TIME

public static final String RESOLVABLE_AT_DESIGN_TIME

The attribute name of the named attribute in the FeatureDescriptor that specifies whether the variable or property can be resolved at runtime.

See Also:
Constant Field Values
Constructor Detail

ELResolver

public ELResolver()
Method Detail

getValue

public abstract Object getValue(ELContext context,
                                Object base,
                                Object property)
Attempts to resolve the given property object on the given base object.

If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

Parameters:
context - The context of this evaluation.
base - The base object whose property value is to be returned, or null to resolve a top-level variable.
property - The property or variable to be resolved.
Returns:
If the propertyResolved property of ELContext was set to true, then the result of the variable or property resolution; otherwise undefined.
Throws:
NullPointerException - if context is null
PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist or is not readable.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getType

public abstract Class<?> getType(ELContext context,
                                 Object base,
                                 Object property)
For a given base and property, attempts to identify the most general type that is acceptable for an object to be passed as the value parameter in a future call to the setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) method.

If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

This is not always the same as getValue().getClass(). For example, in the case of an ArrayELResolver, the getType method will return the element type of the array, which might be a superclass of the type of the actual element that is currently in the specified array element.

Parameters:
context - The context of this evaluation.
base - The base object whose property value is to be analyzed, or null to analyze a top-level variable.
property - The property or variable to return the acceptable type for.
Returns:
If the propertyResolved property of ELContext was set to true, then the most general acceptable type; otherwise undefined.
Throws:
NullPointerException - if context is null
PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist or is not readable.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

setValue

public abstract void setValue(ELContext context,
                              Object base,
                              Object property,
                              Object value)
Attempts to set the value of the given property object on the given base object.

If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value has been set.

Parameters:
context - The context of this evaluation.
base - The base object whose property value is to be set, or null to set a top-level variable.
property - The property or variable to be set.
value - The value to set the property or variable to.
Throws:
NullPointerException - if context is null
PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist.
PropertyNotWritableException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property is not writable.
ELException - if an exception was thrown while attempting to set the property or variable. The thrown exception must be included as the cause property of this exception, if available.

isReadOnly

public abstract boolean isReadOnly(ELContext context,
                                   Object base,
                                   Object property)
For a given base and property, attempts to determine whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

If this resolver handles the given (base, property) pair, the propertyResolved property of the ELContext object must be set to true by the resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

Parameters:
context - The context of this evaluation.
base - The base object whose property value is to be analyzed, or null to analyze a top-level variable.
property - The property or variable to return the read-only status for.
Returns:
If the propertyResolved property of ELContext was set to true, then true if the property is read-only or false if not; otherwise undefined.
Throws:
NullPointerException - if context is null
PropertyNotFoundException - if the given (base, property) pair is handled by this ELResolver but the specified variable or property does not exist.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getFeatureDescriptors

public abstract Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                                  Object base)
Returns information about the set of variables or properties that can be resolved for the given base object. One use for this method is to assist tools in auto-completion.

If the base parameter is null, the resolver must enumerate the list of top-level variables it can resolve.

The Iterator returned must contain zero or more instances of FeatureDescriptor, in no guaranteed order. In the case of primitive types such as int, the value null must be returned. This is to prevent the useless iteration through all possible primitive values. A return value of null indicates that this resolver does not handle the given base object or that the results are too complex to represent with this method and the getCommonPropertyType(javax.el.ELContext, java.lang.Object) method should be used instead.

Each FeatureDescriptor will contain information about a single variable or property. In addition to the standard properties, the FeatureDescriptor must have two named attributes (as set by the setValue method):

  • TYPE - The value of this named attribute must be an instance of java.lang.Class and specify the runtime type of the variable or property.
  • RESOLVABLE_AT_DESIGN_TIME - The value of this named attribute must be an instance of java.lang.Boolean and indicates whether it is safe to attempt to resolve this property at design-time. For instance, it may be unsafe to attempt a resolution at design time if the ELResolver needs access to a resource that is only available at runtime and no acceptable simulated value can be provided.

The caller should be aware that the Iterator returned might iterate through a very large or even infinitely large set of properties. Care should be taken by the caller to not get stuck in an infinite loop.

This is a "best-effort" list. Not all ELResolvers will return completely accurate results, but all must be callable at both design-time and runtime (i.e. whether or not Beans.isDesignTime() returns true), without causing errors.

The propertyResolved property of the ELContext is not relevant to this method. The results of all ELResolvers are concatenated in the case of composite resolvers.

Parameters:
context - The context of this evaluation.
base - The base object whose set of valid properties is to be enumerated, or null to enumerate the set of top-level variables that this resolver can evaluate.
Returns:
An Iterator containing zero or more (possibly infinitely more) FeatureDescriptor objects, or null if this resolver does not handle the given base object or that the results are too complex to represent with this method
See Also:
FeatureDescriptor

getCommonPropertyType

public abstract Class<?> getCommonPropertyType(ELContext context,
                                               Object base)
Returns the most general type that this resolver accepts for the property argument, given a base object. One use for this method is to assist tools in auto-completion.

This assists tools in auto-completion and also provides a way to express that the resolver accepts a primitive value, such as an integer index into an array. For example, the ArrayELResolver will accept any int as a property, so the return value would be Integer.class.

Parameters:
context - The context of this evaluation.
base - The base object to return the most general property type for, or null to enumerate the set of top-level variables that this resolver can evaluate.
Returns:
null if this ELResolver does not know how to handle the given base object; otherwise Object.class if any type of property is accepted; otherwise the most general property type accepted for the given base.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Expression

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class Expression

java.lang.Object
    extended by  javax.el.Expression
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
MethodExpression, ValueExpression
public abstract class Expression
extends Object
implements Serializable

Base class for the expression subclasses ValueExpression and MethodExpression, implementing characterstics common to both.

All expressions must implement the equals() and hashCode() methods so that two expressions can be compared for equality. They are redefined abstract in this class to force their implementation in subclasses.

All expressions must also be Serializable so that they can be saved and restored.

Expressions are also designed to be immutable so that only one instance needs to be created for any given expression String / FunctionMapper. This allows a container to pre-create expressions and not have to re-parse them each time they are evaluated.

Since:
JSP 2.1
See Also:
Serialized Form

Constructor Summary
Expression()
Method Summary
abstract boolean | equals(Object obj) Determines whether the specified object is equal to this Expression.
abstract String | getExpressionString() Returns the original String used to create this Expression, unmodified.
abstract int | hashCode() Returns the hash code for this Expression.
abstract boolean | isLiteralText() Returns whether this expression was created from only literal text.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Expression

public Expression()
Method Detail

getExpressionString

public abstract String getExpressionString()
Returns the original String used to create this Expression, unmodified.

This is used for debugging purposes but also for the purposes of comparison (e.g. to ensure the expression in a configuration file has not changed).

This method does not provide sufficient information to re-create an expression. Two different expressions can have exactly the same expression string but different function mappings. Serialization should be used to save and restore the state of an Expression.

Returns:
The original expression String.

equals

public abstract boolean equals(Object obj)
Determines whether the specified object is equal to this Expression.

The result is true if and only if the argument is not null, is an Expression object that is the of the same type (ValueExpression or MethodExpression), and has an identical parsed representation.

Note that two expressions can be equal if their expression Strings are different. For example, ${fn1:foo()} and ${fn2:foo()} are equal if their corresponding FunctionMappers mapped fn1:foo and fn2:foo to the same method.

Overrides:
equals in class Object
Parameters:
obj - the Object to test for equality.
Returns:
true if obj equals this Expression; false otherwise.
See Also:
Hashtable, Object.equals(java.lang.Object)

hashCode

public abstract int hashCode()
Returns the hash code for this Expression.

See the note in the equals(java.lang.Object) method on how two expressions can be equal if their expression Strings are different. Recall that if two objects are equal according to the equals(Object) method, then calling the hashCode method on each of the two objects must produce the same integer result. Implementations must take special note and implement hashCode correctly.

Overrides:
hashCode in class Object
Returns:
The hash code for this Expression.
See Also:
equals(java.lang.Object), Hashtable, Object.hashCode()

isLiteralText

public abstract boolean isLiteralText()
Returns whether this expression was created from only literal text.

This method must return true if and only if the expression string this expression was created from contained no unescaped EL delimeters (${...} or #{...}).

Returns:
true if this expression was created from only literal text; false otherwise.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ExpressionFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class ExpressionFactory

java.lang.Object
    extended by  javax.el.ExpressionFactory

public abstract class ExpressionFactory
extends Object

Parses a String into a ValueExpression or MethodExpression instance for later evaluation.

Classes that implement the EL expression language expose their functionality via this abstract class. There is no concrete implementation of this API available in this package. Technologies such as JavaServer Pages and JavaServer Faces provide access to an implementation via factory methods.

The createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class) method is used to parse expressions that evaluate to values (both l-values and r-values are supported). The createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class, java.lang.Class[]) method is used to parse expressions that evaluate to a reference to a method on an object.

Unlike previous incarnations of this API, there is no way to parse and evaluate an expression in one single step. The expression needs to first be parsed, and then evaluated.

Resolution of model objects is performed at evaluation time, via the ELResolver associated with the ELContext passed to the ValueExpression or MethodExpression.

The ELContext object also provides access to the FunctionMapper and VariableMapper to be used when parsing the expression. EL function and variable mapping is performed at parse-time, and the results are bound to the expression. Therefore, the ELContext, FunctionMapper, and VariableMapper are not stored for future use and do not have to be Serializable.

The createValueExpression and createMethodExpression methods must be thread-safe. That is, multiple threads may call these methods on the same ExpressionFactory object simultaneously. Implementations should synchronize access if they depend on transient state. Implementations should not, however, assume that only one object of each ExpressionFactory type will be instantiated; global caching should therefore be static.

The ExpressionFactory must be able to handle the following types of input for the expression parameter:

  • Single expressions using the ${} delimiter (e.g. "${employee.lastName}").
  • Single expressions using the #{} delimiter (e.g. "#{employee.lastName}").
  • Literal text containing no ${} or #{} delimiters (e.g. "John Doe").
  • Multiple expressions using the same delimiter (e.g. "${employee.firstName}${employee.lastName}" or "#{employee.firstName}#{employee.lastName}").
  • Mixed literal text and expressions using the same delimiter (e.g. "Name: ${employee.firstName} ${employee.lastName}").

The following types of input are illegal and must cause an ELException to be thrown:

  • Multiple expressions using different delimiters (e.g. "${employee.firstName}#{employee.lastName}").
  • Mixed literal text and expressions using different delimiters(e.g. "Name: ${employee.firstName} #{employee.lastName}").

Since:
JSP 2.1

Constructor Summary
ExpressionFactory()
Method Summary
abstract Object | coerceToType(Object obj, Class<?> targetType) Coerces an object to a specific type according to the EL type conversion rules.
abstract MethodExpression | createMethodExpression(ELContext context, String expression, Class<?> expectedReturnType, Class<?>[] expectedParamTypes) Parses an expression into a MethodExpression for later evaluation.
abstract ValueExpression | createValueExpression(ELContext context, String expression, Class<?> expectedType) Parses an expression into a ValueExpression for later evaluation.
abstract ValueExpression | createValueExpression(Object instance, Class<?> expectedType) Creates a ValueExpression that wraps an object instance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExpressionFactory

public ExpressionFactory()
Method Detail

createValueExpression

public abstract ValueExpression createValueExpression(ELContext context,
                                                      String expression,
                                                      Class<?> expectedType)
Parses an expression into a ValueExpression for later evaluation. Use this method for expressions that refer to values.

This method should perform syntactic validation of the expression. If in doing so it detects errors, it should raise an ELException.

Parameters:
context - The EL context used to parse the expression. The FunctionMapper and VariableMapper stored in the ELContext are used to resolve functions and variables found in the expression. They can be null, in which case functions or variables are not supported for this expression. The object returned must invoke the same functions and access the same variable mappings regardless of whether the mappings in the provided FunctionMapper and VariableMapper instances change between calling ExpressionFactory.createValueExpression() and any method on ValueExpression.

Note that within the EL, the ${} and #{} syntaxes are treated identically. This includes the use of VariableMapper and FunctionMapper at expression creation time. Each is invoked if not null, independent of whether the #{} or ${} syntax is used for the expression.

expression - The expression to parse
expectedType - The type the result of the expression will be coerced to after evaluation.
Returns:
The parsed expression
Throws:
NullPointerException - Thrown if expectedType is null.
ELException - Thrown if there are syntactical errors in the provided expression.

createValueExpression

public abstract ValueExpression createValueExpression(Object instance,
                                                      Class<?> expectedType)
Creates a ValueExpression that wraps an object instance. This method can be used to pass any object as a ValueExpression. The wrapper ValueExpression is read only, and returns the wrapped object via its getValue() method, optionally coerced.

Parameters:
instance - The object instance to be wrapped.
expectedType - The type the result of the expression will be coerced to after evaluation. There will be no coercion if it is Object.class,

createMethodExpression

public abstract MethodExpression createMethodExpression(ELContext context,
                                                        String expression,
                                                        Class<?> expectedReturnType,
                                                        Class<?>[] expectedParamTypes)
Parses an expression into a MethodExpression for later evaluation. Use this method for expressions that refer to methods.

If the expression is a String literal, a MethodExpression is created, which when invoked, returns the String literal, coerced to expectedReturnType. An ELException is thrown if expectedReturnType is void or if the coercion of the String literal to the expectedReturnType yields an error (see Section "1.16 Type Conversion").

This method should perform syntactic validation of the expression. If in doing so it detects errors, it should raise an ELException.

Parameters:
context - The EL context used to parse the expression. The FunctionMapper and VariableMapper stored in the ELContext are used to resolve functions and variables found in the expression. They can be null, in which case functions or variables are not supported for this expression. The object returned must invoke the same functions and access the same variable mappings regardless of whether the mappings in the provided FunctionMapper and VariableMapper instances change between calling ExpressionFactory.createMethodExpression() and any method on MethodExpression.

Note that within the EL, the ${} and #{} syntaxes are treated identically. This includes the use of VariableMapper and FunctionMapper at expression creation time. Each is invoked if not null, independent of whether the #{} or ${} syntax is used for the expression.

expression - The expression to parse
expectedReturnType - The expected return type for the method to be found. After evaluating the expression, the MethodExpression must check that the return type of the actual method matches this type. Passing in a value of null indicates the caller does not care what the return type is, and the check is disabled.
expectedParamTypes - The expected parameter types for the method to be found. Must be an array with no elements if there are no parameters expected. It is illegal to pass null.
Returns:
The parsed expression
Throws:
ELException - Thrown if there are syntactical errors in the provided expression.
NullPointerException - if paramTypes is null.

coerceToType

public abstract Object coerceToType(Object obj,
                                    Class<?> targetType)
Coerces an object to a specific type according to the EL type conversion rules.

An ELException is thrown if an error results from applying the conversion rules.

Parameters:
obj - The object to coerce.
targetType - The target type for the coercion.
Throws:
ELException - thrown if an error results from applying the conversion rules.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FunctionMapper

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class FunctionMapper

java.lang.Object
    extended by  javax.el.FunctionMapper

public abstract class FunctionMapper
extends Object

The interface to a map between EL function names and methods.

A FunctionMapper maps ${prefix:name()} style functions to a static method that can execute that function.

Since:
JSP 2.1

Constructor Summary
FunctionMapper()
Method Summary
abstract  Method resolveFunction(String prefix, String localName)
Resolves the specified prefix and local name into a java.lang.Method.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FunctionMapper

public FunctionMapper()
Method Detail

resolveFunction

public abstract Method resolveFunction(String prefix,
                                       String localName)
Resolves the specified prefix and local name into a java.lang.Method.

Returns null if no function could be found that matches the given prefix and local name.

Parameters:
prefix - the prefix of the function, or "" if no prefix. For example, "fn" in ${fn:method()}, or "" in ${method()}.
localName - the short name of the function. For example, "method" in ${fn:method()}.
Returns:
the static method to invoke, or null if no match was found.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ListELResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class ListELResolver

java.lang.Object
    extended by  javax.el.ELResolver
        extended by  javax.el.ListELResolver

public class ListELResolver
extends ELResolver

Defines property resolution behavior on instances of List.

This resolver handles base objects of type java.util.List. It accepts any object as a property and coerces that object into an integer index into the list. The resulting value is the value in the list at that index.

This resolver can be constructed in read-only mode, which means that isReadOnly will always return true and setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always throw PropertyNotWritableException.

ELResolvers are combined together using CompositeELResolvers, to define rich semantics for evaluating an expression. See the javadocs for ELResolver for details.

Since:
JSP 2.1
See Also:
CompositeELResolver, ELResolver, List

Field Summary
Fields inherited from class javax.el.ELResolver
RESOLVABLE_AT_DESIGN_TIME, TYPE
Constructor Summary
ListELResolver()
Creates a new read/write ListELResolver.
ListELResolver(boolean isReadOnly)
Creates a new ListELResolver whose read-only status is determined by the given parameter.
Method Summary
 Class<?> getCommonPropertyType(ELContext context, Object base)
If the base object is a list, returns the most general type that this resolver accepts for the property argument.
 Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
Always returns null, since there is no reason to iterate through set set of all integers.
 Class<?> getType(ELContext context, Object base, Object property)
If the base object is a list, returns the most general acceptable type for a value in this list.
 Object getValue(ELContext context, Object base, Object property)
If the base object is a list, returns the value at the given index.
 boolean isReadOnly(ELContext context, Object base, Object property)
If the base object is a list, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
 void setValue(ELContext context, Object base, Object property, Object val)
If the base object is a list, attempts to set the value at the given index with the given value.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ListELResolver

public ListELResolver()
Creates a new read/write ListELResolver.

ListELResolver

public ListELResolver(boolean isReadOnly)
Creates a new ListELResolver whose read-only status is determined by the given parameter.

Parameters:
isReadOnly - true if this resolver cannot modify lists; false otherwise.
Method Detail

getType

public Class<?> getType(ELContext context,
                        Object base,
                        Object property)
If the base object is a list, returns the most general acceptable type for a value in this list.

If the base is a List, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

Assuming the base is a List, this method will always return Object.class. This is because Lists accept any object as an element.

Specified by:
getType in class ELResolver
Parameters:
context - The context of this evaluation.
base - The list to analyze. Only bases of type List are handled by this resolver.
property - The index of the element in the list to return the acceptable type for. Will be coerced into an integer, but otherwise ignored by this resolver.
Returns:
If the propertyResolved property of ELContext was set to true, then the most general acceptable type; otherwise undefined.
Throws:
PropertyNotFoundException - if the given index is out of bounds for this list.
NullPointerException - if context is null
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getValue

public Object getValue(ELContext context,
                       Object base,
                       Object property)
If the base object is a list, returns the value at the given index. The index is specified by the property argument, and coerced into an integer. If the coercion could not be performed, an IllegalArgumentException is thrown. If the index is out of bounds, null is returned.

If the base is a List, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

Specified by:
getValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - The list to be analyzed. Only bases of type List are handled by this resolver.
property - The index of the value to be returned. Will be coerced into an integer.
Returns:
If the propertyResolved property of ELContext was set to true, then the value at the given index or null if the index was out of bounds. Otherwise, undefined.
Throws:
IllegalArgumentException - if the property could not be coerced into an integer.
NullPointerException - if context is null.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

setValue

public void setValue(ELContext context,
                     Object base,
                     Object property,
                     Object val)
If the base object is a list, attempts to set the value at the given index with the given value. The index is specified by the property argument, and coerced into an integer. If the coercion could not be performed, an IllegalArgumentException is thrown. If the index is out of bounds, a PropertyNotFoundException is thrown.

If the base is a List, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value was set.

If this resolver was constructed in read-only mode, this method will always throw PropertyNotWritableException.

If a List was created using Collections.unmodifiableList(java.util.List), this method must throw PropertyNotWritableException. Unfortunately, there is no Collections API method to detect this. However, an implementation can create a prototype unmodifiable List and query its runtime type to see if it matches the runtime type of the base object as a workaround.

Specified by:
setValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - The list to be modified. Only bases of type List are handled by this resolver.
property - The index of the value to be set. Will be coerced into an integer.
val - The value to be set at the given index.
Throws:
ClassCastException - if the class of the specified element prevents it from being added to this list.
NullPointerException - if context is null, or if the value is null and this List does not support null elements.
IllegalArgumentException - if the property could not be coerced into an integer, or if some aspect of the specified element prevents it from being added to this list.
PropertyNotWritableException - if this resolver was constructed in read-only mode, or if the set operation is not supported by the underlying list.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

isReadOnly

public boolean isReadOnly(ELContext context,
                          Object base,
                          Object property)
If the base object is a list, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

If the base is a List, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

If this resolver was constructed in read-only mode, this method will always return true.

If a List was created using Collections.unmodifiableList(java.util.List), this method must return true. Unfortunately, there is no Collections API method to detect this. However, an implementation can create a prototype unmodifiable List and query its runtime type to see if it matches the runtime type of the base object as a workaround.

Specified by:
isReadOnly in class ELResolver
Parameters:
context - The context of this evaluation.
base - The list to analyze. Only bases of type List are handled by this resolver.
property - The index of the element in the list to return the acceptable type for. Will be coerced into an integer, but otherwise ignored by this resolver.
Returns:
If the propertyResolved property of ELContext was set to true, then true if calling the setValue method will always fail or false if it is possible that such a call may succeed; otherwise undefined.
Throws:
PropertyNotFoundException - if the given index is out of bounds for this list.
NullPointerException - if context is null
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getFeatureDescriptors

public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                         Object base)
Always returns null, since there is no reason to iterate through set set of all integers.

The getCommonPropertyType(javax.el.ELContext, java.lang.Object) method returns sufficient information about what properties this resolver accepts.

Specified by:
getFeatureDescriptors in class ELResolver
Parameters:
context - The context of this evaluation.
base - The list. Only bases of type List are handled by this resolver.
Returns:
null.
See Also:
FeatureDescriptor

getCommonPropertyType

public Class<?> getCommonPropertyType(ELContext context,
                                      Object base)
If the base object is a list, returns the most general type that this resolver accepts for the property argument. Otherwise, returns null.

Assuming the base is a List, this method will always return Integer.class. This is because Lists accept integers as their index.

Specified by:
getCommonPropertyType in class ELResolver
Parameters:
context - The context of this evaluation.
base - The list to analyze. Only bases of type List are handled by this resolver.
Returns:
null if base is not a List; otherwise Integer.class.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MapELResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class MapELResolver

java.lang.Object
    extended by  javax.el.ELResolver
        extended by  javax.el.MapELResolver

public class MapELResolver
extends ELResolver

Defines property resolution behavior on instances of Map.

This resolver handles base objects of type java.util.Map. It accepts any object as a property and uses that object as a key in the map. The resulting value is the value in the map that is associated with that key.

This resolver can be constructed in read-only mode, which means that isReadOnly will always return true and setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always throw PropertyNotWritableException.

ELResolvers are combined together using CompositeELResolvers, to define rich semantics for evaluating an expression. See the javadocs for ELResolver for details.

Since:
JSP 2.1
See Also:
CompositeELResolver, ELResolver, Map

Field Summary
Fields inherited from class javax.el.ELResolver
RESOLVABLE_AT_DESIGN_TIME, TYPE
Constructor Summary
MapELResolver()
Creates a new read/write MapELResolver.
MapELResolver(boolean isReadOnly)
Creates a new MapELResolver whose read-only status is determined by the given parameter.
Method Summary
 Class<?> getCommonPropertyType(ELContext context, Object base)
If the base object is a map, returns the most general type that this resolver accepts for the property argument.
 Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
If the base object is a map, returns an Iterator containing the set of keys available in the Map.
 Class<?> getType(ELContext context, Object base, Object property)
If the base object is a map, returns the most general acceptable type for a value in this map.
 Object getValue(ELContext context, Object base, Object property)
If the base object is a map, returns the value associated with the given key, as specified by the property argument.
 boolean isReadOnly(ELContext context, Object base, Object property)
If the base object is a map, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.
 void setValue(ELContext context, Object base, Object property, Object val)
If the base object is a map, attempts to set the value associated with the given key, as specified by the property argument.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MapELResolver

public MapELResolver()
Creates a new read/write MapELResolver.

MapELResolver

public MapELResolver(boolean isReadOnly)
Creates a new MapELResolver whose read-only status is determined by the given parameter.

Parameters:
isReadOnly - true if this resolver cannot modify maps; false otherwise.
Method Detail

getType

public Class<?> getType(ELContext context,
                        Object base,
                        Object property)
If the base object is a map, returns the most general acceptable type for a value in this map.

If the base is a Map, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

Assuming the base is a Map, this method will always return Object.class. This is because Maps accept any object as the value for a given key.

Specified by:
getType in class ELResolver
Parameters:
context - The context of this evaluation.
base - The map to analyze. Only bases of type Map are handled by this resolver.
property - The key to return the acceptable type for. Ignored by this resolver.
Returns:
If the propertyResolved property of ELContext was set to true, then the most general acceptable type; otherwise undefined.
Throws:
NullPointerException - if context is null
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getValue

public Object getValue(ELContext context,
                       Object base,
                       Object property)
If the base object is a map, returns the value associated with the given key, as specified by the property argument. If the key was not found, null is returned.

If the base is a Map, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

Just as in Map.get(java.lang.Object), just because null is returned doesn't mean there is no mapping for the key; it's also possible that the Map explicitly maps the key to null.

Specified by:
getValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - The map to be analyzed. Only bases of type Map are handled by this resolver.
property - The key whose associated value is to be returned.
Returns:
If the propertyResolved property of ELContext was set to true, then the value associated with the given key or null if the key was not found. Otherwise, undefined.
Throws:
ClassCastException - if the key is of an inappropriate type for this map (optionally thrown by the underlying Map).
NullPointerException - if context is null, or if the key is null and this map does not permit null keys (the latter is optionally thrown by the underlying Map).
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

setValue

public void setValue(ELContext context,
                     Object base,
                     Object property,
                     Object val)
If the base object is a map, attempts to set the value associated with the given key, as specified by the property argument.

If the base is a Map, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller can safely assume no value was set.

If this resolver was constructed in read-only mode, this method will always throw PropertyNotWritableException.

If a Map was created using Collections.unmodifiableMap(java.util.Map), this method must throw PropertyNotWritableException. Unfortunately, there is no Collections API method to detect this. However, an implementation can create a prototype unmodifiable Map and query its runtime type to see if it matches the runtime type of the base object as a workaround.

Specified by:
setValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - The map to be modified. Only bases of type Map are handled by this resolver.
property - The key with which the specified value is to be associated.
val - The value to be associated with the specified key.
Throws:
ClassCastException - if the class of the specified key or value prevents it from being stored in this map.
NullPointerException - if context is null, or if this map does not permit null keys or values, and the specified key or value is null.
IllegalArgumentException - if some aspect of this key or value prevents it from being stored in this map.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.
PropertyNotWritableException - if this resolver was constructed in read-only mode, or if the put operation is not supported by the underlying map.

isReadOnly

public boolean isReadOnly(ELContext context,
                          Object base,
                          Object property)
If the base object is a map, returns whether a call to setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object) will always fail.

If the base is a Map, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

If this resolver was constructed in read-only mode, this method will always return true.

If a Map was created using Collections.unmodifiableMap(java.util.Map), this method must return true. Unfortunately, there is no Collections API method to detect this. However, an implementation can create a prototype unmodifiable Map and query its runtime type to see if it matches the runtime type of the base object as a workaround.

Specified by:
isReadOnly in class ELResolver
Parameters:
context - The context of this evaluation.
base - The map to analyze. Only bases of type Map are handled by this resolver.
property - The key to return the read-only status for. Ignored by this resolver.
Returns:
If the propertyResolved property of ELContext was set to true, then true if calling the setValue method will always fail or false if it is possible that such a call may succeed; otherwise undefined.
Throws:
NullPointerException - if context is null
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getFeatureDescriptors

public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                         Object base)
If the base object is a map, returns an Iterator containing the set of keys available in the Map. Otherwise, returns null.

The Iterator returned must contain zero or more instances of FeatureDescriptor. Each info object contains information about a key in the Map, and is initialized as follows:

  • displayName - The return value of calling the toString method on this key, or "null" if the key is null.
  • name - Same as displayName property.
  • shortDescription - Empty string
  • expert - false
  • hidden - false
  • preferred - true
    • In addition, the following named attributes must be set in the returned FeatureDescriptors:
  • ELResolver.TYPE - The return value of calling the getClass() method on this key, or null if the key is null.
  • ELResolver.RESOLVABLE_AT_DESIGN_TIME - true

    • Specified by:
    getFeatureDescriptors in class ELResolver
    Parameters:
    context - The context of this evaluation.
    base - The map whose keys are to be iterated over. Only bases of type Map are handled by this resolver.
    Returns:
    An Iterator containing zero or more (possibly infinitely more) FeatureDescriptor objects, each representing a key in this map, or null if the base object is not a map.
    See Also:
    FeatureDescriptor

    getCommonPropertyType

    public Class<?> getCommonPropertyType(ELContext context,
                                      Object base)
    If the base object is a map, returns the most general type that this resolver accepts for the property argument. Otherwise, returns null.

    Assuming the base is a Map, this method will always return Object.class. This is because Maps accept any object as a key.

    Specified by:
    getCommonPropertyType in class ELResolver
    Parameters:
    context - The context of this evaluation.
    base - The map to analyze. Only bases of type Map are handled by this resolver.
    Returns:
    null if base is not a Map; otherwise Object.class.
    Overview Package Class Tree Deprecated Index Help
            Java EE 5 SDK
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
    Submit a bug or feature

    Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MethodExpression

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class MethodExpression

java.lang.Object
    extended by  javax.el.Expression
        extended by  javax.el.MethodExpression
All Implemented Interfaces:
Serializable
public abstract class MethodExpression
extends Expression

An Expression that refers to a method on an object.

The ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class, java.lang.Class[]) method can be used to parse an expression string and return a concrete instance of MethodExpression that encapsulates the parsed expression. The FunctionMapper is used at parse time, not evaluation time, so one is not needed to evaluate an expression using this class. However, the ELContext is needed at evaluation time.

The getMethodInfo(javax.el.ELContext) and invoke(javax.el.ELContext, java.lang.Object[]) methods will evaluate the expression each time they are called. The ELResolver in the ELContext is used to resolve the top-level variables and to determine the behavior of the . and [] operators. For any of the two methods, the ELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object) method is used to resolve all properties up to but excluding the last one. This provides the base object on which the method appears. If the base object is null, a PropertyNotFoundException must be thrown. At the last resolution, the final property is then coerced to a String, which provides the name of the method to be found. A method matching the name and expected parameters provided at parse time is found and it is either queried or invoked (depending on the method called on this MethodExpression).

See the notes about comparison, serialization and immutability in the Expression javadocs.

Since:
JSP 2.1
See Also:
ELResolver, Expression, ExpressionFactory, Serialized Form

Constructor Summary
MethodExpression()
Method Summary
abstract MethodInfo | getMethodInfo(ELContext context) Evaluates the expression relative to the provided context, and returns information about the actual referenced method.
abstract Object | invoke(ELContext context, Object[] params) If a String literal is specified as the expression, returns the String literal coerced to the expected return type of the method signature.
Methods inherited from class javax.el.Expression
equals, getExpressionString, hashCode, isLiteralText
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MethodExpression

public MethodExpression()
Method Detail

getMethodInfo

public abstract MethodInfo getMethodInfo(ELContext context)
Evaluates the expression relative to the provided context, and returns information about the actual referenced method.

Parameters:
context - The context of this evaluation
Returns:
an instance of MethodInfo containing information about the method the expression evaluated to.
Throws:
NullPointerException - if context is null
PropertyNotFoundException - if one of the property resolutions failed because a specified variable or property does not exist or is not readable.
MethodNotFoundException - if no suitable method can be found.
ELException - if an exception was thrown while performing property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

invoke

public abstract Object invoke(ELContext context,
                              Object[] params)
If a String literal is specified as the expression, returns the String literal coerced to the expected return type of the method signature. An ELException is thrown if expectedReturnType is void or if the coercion of the String literal to the expectedReturnType yields an error (see Section "1.16 Type Conversion" of the EL specification). If not a String literal, evaluates the expression relative to the provided context, invokes the method that was found using the supplied parameters, and returns the result of the method invocation. Any parameters passed to this method is ignored if isLiteralText() is true.

Parameters:
context - The context of this evaluation.
params - The parameters to pass to the method, or null if no parameters.
Returns:
the result of the method invocation (null if the method has a void return type).
Throws:
NullPointerException - if context is null
PropertyNotFoundException - if one of the property resolutions failed because a specified variable or property does not exist or is not readable.
MethodNotFoundException - if no suitable method can be found.
ELException - if a String literal is specified and expectedReturnType of the MethodExpression is void or if the coercion of the String literal to the expectedReturnType yields an error (see Section "1.16 Type Conversion").
ELException - if an exception was thrown while performing property or variable resolution. The thrown exception must be included as the cause property of this exception, if available. If the exception thrown is an InvocationTargetException, extract its cause and pass it to the ELException constructor.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MethodInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class MethodInfo

java.lang.Object
    extended by  javax.el.MethodInfo

public class MethodInfo
extends Object

Holds information about a method that a MethodExpression evaluated to.

Since:
JSP 2.1

Constructor Summary
MethodInfo(String name, Class<?> returnType, Class<?>[] paramTypes)
Creates a new instance of MethodInfo with the given information.
Method Summary
String | getName() Returns the name of the method
Class<?>[] | getParamTypes() Returns the parameter types of the method
Class<?> | getReturnType() Returns the return type of the method
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MethodInfo

public MethodInfo(String name,
                  Class<?> returnType,
                  Class<?>[] paramTypes)
Creates a new instance of MethodInfo with the given information.

Parameters:
name - The name of the method
returnType - The return type of the method
paramTypes - The types of each of the method's parameters
Method Detail

getName

public String getName()
Returns the name of the method

Returns:
the name of the method

getReturnType

public Class<?> getReturnType()
Returns the return type of the method

Returns:
the return type of the method

getParamTypes

public Class<?>[] getParamTypes()
Returns the parameter types of the method

Returns:
the parameter types of the method
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MethodNotFoundException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class MethodNotFoundException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.el.ELException
                    extended by  javax.el.MethodNotFoundException
All Implemented Interfaces:
Serializable
public class MethodNotFoundException
extends ELException

Thrown when a method could not be found while evaluating a MethodExpression.

Since:
JSP 2.1
See Also:
MethodExpression, Serialized Form

Constructor Summary
MethodNotFoundException()
Creates a MethodNotFoundException with no detail message.
MethodNotFoundException(String message)
Creates a MethodNotFoundException with the provided detail message.
MethodNotFoundException(String pMessage, Throwable pRootCause)
Creates a MethodNotFoundException with the given detail message and root cause.
MethodNotFoundException(Throwable exception)
Creates a MethodNotFoundException with the given root cause.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MethodNotFoundException

public MethodNotFoundException()
Creates a MethodNotFoundException with no detail message.

MethodNotFoundException

public MethodNotFoundException(String message)
Creates a MethodNotFoundException with the provided detail message.

Parameters:
message - the detail message

MethodNotFoundException

public MethodNotFoundException(Throwable exception)
Creates a MethodNotFoundException with the given root cause.

Parameters:
exception - the originating cause of this exception

MethodNotFoundException

public MethodNotFoundException(String pMessage,
                               Throwable pRootCause)
Creates a MethodNotFoundException with the given detail message and root cause.

Parameters:
pMessage - the detail message
pRootCause - the originating cause of this exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PropertyNotFoundException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class PropertyNotFoundException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.el.ELException
                    extended by  javax.el.PropertyNotFoundException
All Implemented Interfaces:
Serializable
public class PropertyNotFoundException
extends ELException

Thrown when a property could not be found while evaluating a ValueExpression or MethodExpression.

For example, this could be triggered by an index out of bounds while setting an array value, or by an unreadable property while getting the value of a JavaBeans property.

Since:
JSP 2.1
See Also:
Serialized Form

Constructor Summary
PropertyNotFoundException()
Creates a PropertyNotFoundException with no detail message.
PropertyNotFoundException(String message)
Creates a PropertyNotFoundException with the provided detail message.
PropertyNotFoundException(String pMessage, Throwable pRootCause)
Creates a PropertyNotFoundException with the given detail message and root cause.
PropertyNotFoundException(Throwable exception)
Creates a PropertyNotFoundException with the given root cause.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PropertyNotFoundException

public PropertyNotFoundException()
Creates a PropertyNotFoundException with no detail message.

PropertyNotFoundException

public PropertyNotFoundException(String message)
Creates a PropertyNotFoundException with the provided detail message.

Parameters:
message - the detail message

PropertyNotFoundException

public PropertyNotFoundException(Throwable exception)
Creates a PropertyNotFoundException with the given root cause.

Parameters:
exception - the originating cause of this exception

PropertyNotFoundException

public PropertyNotFoundException(String pMessage,
                                 Throwable pRootCause)
Creates a PropertyNotFoundException with the given detail message and root cause.

Parameters:
pMessage - the detail message
pRootCause - the originating cause of this exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PropertyNotWritableException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class PropertyNotWritableException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.el.ELException
                    extended by  javax.el.PropertyNotWritableException
All Implemented Interfaces:
Serializable
public class PropertyNotWritableException
extends ELException

Thrown when a property could not be written to while setting the value on a ValueExpression.

For example, this could be triggered by trying to set a map value on an unmodifiable map.

Since:
JSP 2.1
See Also:
Serialized Form

Constructor Summary
PropertyNotWritableException()
Creates a PropertyNotWritableException with no detail message.
PropertyNotWritableException(String pMessage)
Creates a PropertyNotWritableException with the provided detail message.
PropertyNotWritableException(String pMessage, Throwable pRootCause)
Creates a PropertyNotWritableException with the given detail message and root cause.
PropertyNotWritableException(Throwable exception)
Creates a PropertyNotWritableException with the given root cause.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PropertyNotWritableException

public PropertyNotWritableException()
Creates a PropertyNotWritableException with no detail message.

PropertyNotWritableException

public PropertyNotWritableException(String pMessage)
Creates a PropertyNotWritableException with the provided detail message.

Parameters:
pMessage - the detail message

PropertyNotWritableException

public PropertyNotWritableException(Throwable exception)
Creates a PropertyNotWritableException with the given root cause.

Parameters:
exception - the originating cause of this exception

PropertyNotWritableException

public PropertyNotWritableException(String pMessage,
                                    Throwable pRootCause)
Creates a PropertyNotWritableException with the given detail message and root cause.

Parameters:
pMessage - the detail message
pRootCause - the originating cause of this exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResourceBundleELResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class ResourceBundleELResolver

java.lang.Object
    extended by  javax.el.ELResolver
        extended by  javax.el.ResourceBundleELResolver

public class ResourceBundleELResolver
extends ELResolver

Defines property resolution behavior on instances of ResourceBundle.

This resolver handles base objects of type java.util.ResourceBundle. It accepts any object as a property and coerces it to a java.lang.String for invoking ResourceBundle.getObject(java.lang.String).

This resolver is read only and will throw a PropertyNotWritableException if setValue is called.

ELResolvers are combined together using CompositeELResolvers, to define rich semantics for evaluating an expression. See the javadocs for ELResolver for details.

Since:
JSP 2.1
See Also:
CompositeELResolver, ELResolver, ResourceBundle

Field Summary
Fields inherited from class javax.el.ELResolver
RESOLVABLE_AT_DESIGN_TIME, TYPE
Constructor Summary
ResourceBundleELResolver()
Method Summary
Class<?> | getCommonPropertyType(ELContext context, Object base) If the base object is a ResourceBundle, returns the most general type that this resolver accepts for the property argument.
Iterator | getFeatureDescriptors(ELContext context, Object base) If the base object is a ResourceBundle, returns an Iterator containing the set of keys available in the ResourceBundle.
Class<?> | getType(ELContext context, Object base, Object property) If the base object is an instance of ResourceBundle, return null, since the resolver is read only.
Object | getValue(ELContext context, Object base, Object property) If the base object is an instance of ResourceBundle, the provided property will first be coerced to a String.
boolean | isReadOnly(ELContext context, Object base, Object property) If the base object is not null and an instanceof ResourceBundle, return true.
void | setValue(ELContext context, Object base, Object property, Object value) If the base object is a ResourceBundle, throw a PropertyNotWritableException.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResourceBundleELResolver

public ResourceBundleELResolver()
Method Detail

getValue

public Object getValue(ELContext context,
                       Object base,
                       Object property)
If the base object is an instance of ResourceBundle, the provided property will first be coerced to a String. The Object returned by getObject on the base ResourceBundle will be returned.

If the base is ResourceBundle, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

Specified by:
getValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - The ResourceBundle to analyze.
property - The name of the property to analyze. Will be coerced to a String.
Returns:
If the propertyResolved property of ELContext was set to true, then null if property is null; otherwise the Object for the given key (property coerced to String) from the ResourceBundle. If no object for the given key can be found, then the String "???" + key + "???".
Throws:
NullPointerException - if context is null
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getType

public Class<?> getType(ELContext context,
                        Object base,
                        Object property)
If the base object is an instance of ResourceBundle, return null, since the resolver is read only.

If the base is ResourceBundle, the propertyResolved property of the ELContext object must be set to true by this resolver, before returning. If this property is not true after this method is called, the caller should ignore the return value.

Specified by:
getType in class ELResolver
Parameters:
context - The context of this evaluation.
base - The ResourceBundle to analyze.
property - The name of the property to analyze.
Returns:
If the propertyResolved property of ELContext was set to true, then null; otherwise undefined.
Throws:
NullPointerException - if context is null

setValue

public void setValue(ELContext context,
                     Object base,
                     Object property,
                     Object value)
If the base object is a ResourceBundle, throw a PropertyNotWritableException.

Specified by:
setValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - The ResourceBundle to be modified. Only bases that are of type ResourceBundle are handled.
property - The String property to use.
value - The value to be set.
Throws:
NullPointerException - if context is null.
PropertyNotWritableException - Always thrown if base is an instance of ReasourceBundle.

isReadOnly

public boolean isReadOnly(ELContext context,
                          Object base,
                          Object property)
If the base object is not null and an instanceof ResourceBundle, return true.

Specified by:
isReadOnly in class ELResolver
Parameters:
context - The context of this evaluation.
base - The ResourceBundle to be modified. Only bases that are of type ResourceBundle are handled.
property - The String property to use.
Returns:
If the propertyResolved property of ELContext was set to true, then true; otherwise undefined.
Throws:
NullPointerException - if context is null

getFeatureDescriptors

public Iterator getFeatureDescriptors(ELContext context,
                                      Object base)
If the base object is a ResourceBundle, returns an Iterator containing the set of keys available in the ResourceBundle. Otherwise, returns null.

The Iterator returned must contain zero or more instances of FeatureDescriptor. Each info object contains information about a key in the ResourceBundle, and is initialized as follows:

  • displayName - The String key
  • name - Same as displayName property.
  • shortDescription - Empty string
  • expert - false
  • hidden - false
  • preferred - true
    • In addition, the following named attributes must be set in the returned FeatureDescriptors:
  • ELResolver.TYPE - String.class
  • ELResolver.RESOLVABLE_AT_DESIGN_TIME - true

    • Specified by:
    getFeatureDescriptors in class ELResolver
    Parameters:
    context - The context of this evaluation.
    base - The bundle whose keys are to be iterated over. Only bases of type ResourceBundle are handled by this resolver.
    Returns:
    An Iterator containing zero or more (possibly infinitely more) FeatureDescriptor objects, each representing a key in this bundle, or null if the base object is not a ResourceBundle.
    See Also:
    FeatureDescriptor

    getCommonPropertyType

    public Class<?> getCommonPropertyType(ELContext context,
                                      Object base)
    If the base object is a ResourceBundle, returns the most general type that this resolver accepts for the property argument. Otherwise, returns null.

    Assuming the base is a ResourceBundle, this method will always return String.class.

    Specified by:
    getCommonPropertyType in class ELResolver
    Parameters:
    context - The context of this evaluation.
    base - The bundle to analyze. Only bases of type ResourceBundle are handled by this resolver.
    Returns:
    null if base is not a ResourceBundle; otherwise String.class.
    Overview Package Class Tree Deprecated Index Help
            Java EE 5 SDK
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
    Submit a bug or feature

    Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValueExpression

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.el
Class ValueExpression

java.lang.Object
    extended by  javax.el.Expression
        extended by  javax.el.ValueExpression
All Implemented Interfaces:
Serializable
public abstract class ValueExpression
extends Expression

An Expression that can get or set a value.

In previous incarnations of this API, expressions could only be read. ValueExpression objects can now be used both to retrieve a value and to set a value. Expressions that can have a value set on them are referred to as l-value expressions. Those that cannot are referred to as r-value expressions. Not all r-value expressions can be used as l-value expressions (e.g. "${1+1}" or "${firstName} ${lastName}"). See the EL Specification for details. Expressions that cannot be used as l-values must always return true from isReadOnly().

The ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class) method can be used to parse an expression string and return a concrete instance of ValueExpression that encapsulates the parsed expression. The FunctionMapper is used at parse time, not evaluation time, so one is not needed to evaluate an expression using this class. However, the ELContext is needed at evaluation time.

The getValue(javax.el.ELContext), setValue(javax.el.ELContext, java.lang.Object), isReadOnly(javax.el.ELContext) and getType(javax.el.ELContext) methods will evaluate the expression each time they are called. The ELResolver in the ELContext is used to resolve the top-level variables and to determine the behavior of the . and [] operators. For any of the four methods, the ELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object) method is used to resolve all properties up to but excluding the last one. This provides the base object. At the last resolution, the ValueExpression will call the corresponding ELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object), ELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object), ELResolver.isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object) or ELResolver.getType(javax.el.ELContext, java.lang.Object, java.lang.Object) method, depending on which was called on the ValueExpression.

See the notes about comparison, serialization and immutability in the Expression javadocs.

Since:
JSP 2.1
See Also:
ELResolver, Expression, ExpressionFactory, Serialized Form

Constructor Summary
ValueExpression()
Method Summary
abstract Class<?> | getExpectedType() Returns the type the result of the expression will be coerced to after evaluation.
abstract Class<?> | getType(ELContext context) Evaluates the expression relative to the provided context, and returns the most general type that is acceptable for an object to be passed as the value parameter in a future call to the setValue(javax.el.ELContext, java.lang.Object) method.
abstract Object | getValue(ELContext context) Evaluates the expression relative to the provided context, and returns the resulting value.
abstract boolean | isReadOnly(ELContext context) Evaluates the expression relative to the provided context, and returns true if a call to setValue(javax.el.ELContext, java.lang.Object) will always fail.
abstract void | setValue(ELContext context, Object value) Evaluates the expression relative to the provided context, and sets the result to the provided value.
Methods inherited from class javax.el.Expression
equals, getExpressionString, hashCode, isLiteralText
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValueExpression

public ValueExpression()
Method Detail

getValue

public abstract Object getValue(ELContext context)
Evaluates the expression relative to the provided context, and returns the resulting value.

The resulting value is automatically coerced to the type returned by getExpectedType(), which was provided to the ExpressionFactory when this expression was created.

Parameters:
context - The context of this evaluation.
Returns:
The result of the expression evaluation.
Throws:
NullPointerException - if context is null.
PropertyNotFoundException - if one of the property resolutions failed because a specified variable or property does not exist or is not readable.
ELException - if an exception was thrown while performing property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

setValue

public abstract void setValue(ELContext context,
                              Object value)
Evaluates the expression relative to the provided context, and sets the result to the provided value.

Parameters:
context - The context of this evaluation.
value - The new value to be set.
Throws:
NullPointerException - if context is null.
PropertyNotFoundException - if one of the property resolutions failed because a specified variable or property does not exist or is not readable.
PropertyNotWritableException - if the final variable or property resolution failed because the specified variable or property is not writable.
ELException - if an exception was thrown while attempting to set the property or variable. The thrown exception must be included as the cause property of this exception, if available.

isReadOnly

public abstract boolean isReadOnly(ELContext context)
Evaluates the expression relative to the provided context, and returns true if a call to setValue(javax.el.ELContext, java.lang.Object) will always fail.

Parameters:
context - The context of this evaluation.
Returns:
true if the expression is read-only or false if not.
Throws:
NullPointerException - if context is null.
PropertyNotFoundException - if one of the property resolutions failed because a specified variable or property does not exist or is not readable.
ELException - if an exception was thrown while performing property or variable resolution. The thrown exception must be included as the cause property of this exception, if available. * @throws NullPointerException if context is null

getType

public abstract Class<?> getType(ELContext context)
Evaluates the expression relative to the provided context, and returns the most general type that is acceptable for an object to be passed as the value parameter in a future call to the setValue(javax.el.ELContext, java.lang.Object) method.

This is not always the same as getValue().getClass(). For example, in the case of an expression that references an array element, the getType method will return the element type of the array, which might be a superclass of the type of the actual element that is currently in the specified array element.

Parameters:
context - The context of this evaluation.
Returns:
the most general acceptable type; otherwise undefined.
Throws:
NullPointerException - if context is null.
PropertyNotFoundException - if one of the property resolutions failed because a specified variable or property does not exist or is not readable.
ELException - if an exception was thrown while performing property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getExpectedType

public abstract Class<?> getExpectedType()
Returns the type the result of the expression will be coerced to after evaluation.

Returns:
the expectedType passed to the ExpressionFactory.createValueExpression method that created this ValueExpression.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


VariableMapper

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.el
Class VariableMapper

java.lang.Object
    extended by  javax.el.VariableMapper

public abstract class VariableMapper
extends Object

The interface to a map between EL variables and the EL expressions they are associated with.

Since:
JSP 2.1

Constructor Summary
VariableMapper()
Method Summary
abstract ValueExpression | resolveVariable(String variable)
abstract ValueExpression | setVariable(String variable, ValueExpression expression) Assign a ValueExpression to an EL variable, replacing any previously assignment to the same variable.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VariableMapper

public VariableMapper()
Method Detail

resolveVariable

public abstract ValueExpression resolveVariable(String variable)
Parameters:
variable - The variable name
Returns:
the ValueExpression assigned to the variable, null if there is no previous assignment to this variable.

setVariable

public abstract ValueExpression setVariable(String variable,
                                            ValueExpression expression)
Assign a ValueExpression to an EL variable, replacing any previously assignment to the same variable. The assignment for the variable is removed if the expression is null.

Parameters:
variable - The variable name
expression - The ValueExpression to be assigned to the variable.
Returns:
The previous ValueExpression assigned to this variable, null if there is no previouse assignment to this variable.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


model

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.model

Provides Tool Vendor implementation classes.

See:
Description

Interface Summary
DDBean | An interface for beans that represent a fragment of a standard deployment descriptor.
DDBeanRoot | An interface that represents the root of a standard deployment descriptor.
DeployableObject | The DeployableObject interface is an abstract representation of a J2EE deployable module (JAR, WAR, RAR, EAR).
J2eeApplicationObject | J2eeApplicationObject is an interface that represents a J2EE application (EAR); it maintains a DeployableObject for each module in the archive.
XpathListener | The listener interface for receiving XpathEvents

Class Summary
XpathEvent An Event class describing ConfigBeans being added/subtracted from a server configuration.

Package javax.enterprise.deploy.model Description

Provides Tool Vendor implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.model Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.model

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.enterprise.deploy.model.XpathEvent

Interface Hierarchy

  • javax.enterprise.deploy.model.DDBean
    • javax.enterprise.deploy.model.DDBeanRoot
  • javax.enterprise.deploy.model.DeployableObject
    • javax.enterprise.deploy.model.J2eeApplicationObject
  • javax.enterprise.deploy.model.XpathListener
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DDBean

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.model
Interface DDBean

All Known Subinterfaces:
DDBeanRoot
public interface DDBean

An interface for beans that represent a fragment of a standard deployment descriptor. A link is provided to the J2EE application that includes this bean.

Method Summary
void | addXpathListener(String xpath, XpathListener xpl) Register a listener for a specific XPath.
String[] | getAttributeNames() Returns the list of attribute names associated with the XML element.
String | getAttributeValue(String attrName) Returns the string value of the named attribute.
DDBean[] | getChildBean(String xpath) Return a list of DDBeans based upon the XPath.
String | getId() Returns a tool-specific reference for attribute ID on an element in the deployment descriptor.
DDBeanRoot | getRoot() Return the root element for this DDBean.
String | getText() Returns the XML text for by this bean.
String[] | getText(String xpath) Return a list of text values for a given XPath in the deployment descriptor.
String | getXpath() Returns the original xpath string provided by the DConfigBean.
void | removeXpathListener(String xpath, XpathListener xpl) Unregister a listener for a specific XPath.

Method Detail

getXpath

String getXpath()
Returns the original xpath string provided by the DConfigBean.

Returns:
The XPath of this Bean.

getText

String getText()
Returns the XML text for by this bean.

Returns:
The XML text for this Bean.

getId

String getId()
Returns a tool-specific reference for attribute ID on an element in the deployment descriptor. This attribute is defined for J2EE 1.2 and 1.3 components.

Returns:
The XML text for this Bean or 'null' if no attribute was specifed with the tag.

getRoot

DDBeanRoot getRoot()
Return the root element for this DDBean.

Returns:
The DDBeanRoot at the root of this DDBean tree.

getChildBean

DDBean[] getChildBean(String xpath)
Return a list of DDBeans based upon the XPath.

Parameters:
xpath - An XPath string referring to a location in the same deployment descriptor as this standard bean.
Returns:
a list of DDBeans or 'null' if no matching XML data is found.

getText

String[] getText(String xpath)
Return a list of text values for a given XPath in the deployment descriptor.

Parameters:
xpath - An XPath.
Returns:
The list text values for this XPath or 'null' if no matching XML data is found.

addXpathListener

void addXpathListener(String xpath,
                      XpathListener xpl)
Register a listener for a specific XPath.

Parameters:
xpath - The XPath this listener is to be registered for.
xpl - The listener object.

removeXpathListener

void removeXpathListener(String xpath,
                         XpathListener xpl)
Unregister a listener for a specific XPath.

Parameters:
xpath - The XPath from which this listener is to be unregistered.
xpl - The listener object.

getAttributeNames

String[] getAttributeNames()
Returns the list of attribute names associated with the XML element.

Returns:
a list of attribute names on this element. Null is returned if there are no attributes.

getAttributeValue

String getAttributeValue(String attrName)
Returns the string value of the named attribute.

Returns:
a the value of the attribute. Null is returned if there is no such attribute.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DDBeanRoot

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.model
Interface DDBeanRoot

All Superinterfaces:
DDBean
public interface DDBeanRoot
extends DDBean

An interface that represents the root of a standard deployment descriptor. A DDBeanRoot is a type of DDBean.

Author:
gfink

Method Summary
 String getDDBeanRootVersion()
Returns the version number of an XML instance document.
 DeployableObject getDeployableObject()
Return the containing DeployableObject
 String getFilename()
Returns the filename relative to the root of the module of the XML instance document this DDBeanRoot represents.
 String getModuleDTDVersion()
Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
 ModuleType getType()
Return the ModuleType of deployment descriptor.
 String getXpath()
Return the XPath for this standard bean.
Methods inherited from interface javax.enterprise.deploy.model.DDBean
addXpathListener, getAttributeNames, getAttributeValue, getChildBean, getId, getRoot, getText, getText, removeXpathListener

Method Detail

getType

ModuleType getType()
Return the ModuleType of deployment descriptor.

Returns:
The ModuleType of deployment descriptor

getDeployableObject

DeployableObject getDeployableObject()
Return the containing DeployableObject

Returns:
The DeployableObject that contains this deployment descriptor

getModuleDTDVersion

String getModuleDTDVersion()
Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()

A convenience method to return the DTD version number. The DeployableObject has this information.

Returns:
a string containing the DTD version number This method is being deprecated. Two DD data formats are being used, DTD and XML Schema. DDBeanRoot.getDDBeanRootVersion should be used in its place.

getDDBeanRootVersion

String getDDBeanRootVersion()
Returns the version number of an XML instance document. This method is replacing the methods DDBeanRoot.getModuleDTDVersion and DeployableObject.getModuleDTDVersion. This method returns the version number of any J2EE XML instance document.

Returns:
a string that is the version number of the XML instance document. Null is returned if no version number can be found.

getXpath

String getXpath()
Return the XPath for this standard bean. The root XPath is "/".

Specified by:
getXpath in interface DDBean
Returns:
"/" this is the root standard bean.

getFilename

String getFilename()
Returns the filename relative to the root of the module of the XML instance document this DDBeanRoot represents.

Returns:
String the filename relative to the root of the module
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DeployableObject

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.model
Interface DeployableObject

All Known Subinterfaces:
J2eeApplicationObject
public interface DeployableObject

The DeployableObject interface is an abstract representation of a J2EE deployable module (JAR, WAR, RAR, EAR). A DeployableObject provides access to the module's deployment descriptor and class files.

Version:
0.1
Author:
gfink

Method Summary
 Enumeration entries()
Returns an enumeration of the module file entries.
 DDBean[] getChildBean(String xpath)
Return an array of standard beans representing the XML content returned based upon the XPath.
 Class getClassFromScope(String className)
Retrieve the specified class from this deployable module.
 DDBeanRoot getDDBeanRoot()
Return the top level standard bean representing the root of the deployment descriptor.
 DDBeanRoot getDDBeanRoot(String filename)
Returns a DDBeanRoot object for the XML instance document named.
 InputStream getEntry(String name)
Returns the InputStream for the given entry name The file name must be relative to the root of the module.
 String getModuleDTDVersion()
Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()
 String[] getText(String xpath)
Return the XML content associated with the XPath from a deployment descriptor.
 ModuleType getType()
Return the ModuleType of deployment descriptor (i.e., EAR, JAR, WAR, RAR) this deployable object represents.

Method Detail

getType

ModuleType getType()
Return the ModuleType of deployment descriptor (i.e., EAR, JAR, WAR, RAR) this deployable object represents. Values are found in DeploymentManager.

Returns:
The ModuleType of deployable object

getDDBeanRoot

DDBeanRoot getDDBeanRoot()
Return the top level standard bean representing the root of the deployment descriptor.

Returns:
A standard bean representing the deployment descriptor.

getChildBean

DDBean[] getChildBean(String xpath)
Return an array of standard beans representing the XML content returned based upon the XPath.

Parameters:
xpath - An XPath string identifying the data to be extracted from the deployment descriptor.
Returns:
a array of DDBeans or 'null' if no matching data found.

getText

String[] getText(String xpath)
Return the XML content associated with the XPath from a deployment descriptor.

Parameters:
xpath - An xpath string referring to a location in the deployment descriptor
Returns:
a list XML content or 'null' if no matching data found.

getClassFromScope

Class getClassFromScope(String className)
Retrieve the specified class from this deployable module.

One use: to get all finder methods from an EJB If the tool is attempting to package an module and retrieve a class from the package, the class request may fail. The class may not yet be available. The tool should respect the manifest cross-path entries.

Parameters:
className - Class to retrieve.
Returns:
Class representation of the class

getModuleDTDVersion

String getModuleDTDVersion()
Deprecated. As of version 1.1 replaced by DDBeanRoot.getDDBeanRootVersion()

Returns the DTD version number given in the XML DOCTYPE text provided in every standard J2EE module's deployment descriptor file.

Returns:
a string containing the DTD version number
 A module's deployment descriptor file always contains
 a document type identifier, DOCTYPE.  The DOCTYPE statement
 contains the module DTD version number in the label of the
 statement.

        The format of the DOCTYPE statement is:

        <!DOCTYPE root_element PUBLIC
        "-//organization//label//language" "location">

 root_element - is the name of the root document in the DTD.
 organization  - is the name of the organization responsible
                 for the creation and maintenance of the DTD
                 being referenced.
 label - is a unique descriptive name for the public text being
                 referenced.
 language - is the ISO 639 language id representing the natural
                 language encoding of th DTD.
 location - is the URL of the DTD.

 An example J2EE deployment descriptor DOCTYPE statement is:

   <!DOCTYPE application-client PUBLIC
   "-//Sun Microsystems, Inc.//DTD J2EE Application Client 1.3//EN"
   "http://java.sun.com/dtd/application-client_1_3.dtd">

 In this example the label is, "DTD J2EE Application Client 1.3",
 and the DTD version number is 1.3. A call to getModuleDTDVersion
 would return a string containing, "1.3".
This method is being deprecated. With the addition of multiple deployment descritors in components for J2EE 1.4 this method is being replaced by DDBeanRoot.getDDBeanRootVersion.

getDDBeanRoot

DDBeanRoot getDDBeanRoot(String filename)
                         throws FileNotFoundException,
                                DDBeanCreateException
Returns a DDBeanRoot object for the XML instance document named. This method should be used to return DDBeanRoot objects for non deployment descriptor XML instance documents such as WSDL files.

Returns:
a DDBeanRoot object for the XML data.
Throws:
java.io.FileNotFoundException, - if the named file can not be found
DDBeanCreateException - if an error is encountered creating the DDBeanRoot object.
FileNotFoundException

entries

Enumeration entries()
Returns an enumeration of the module file entries. All elements in the enumeration are of type String. Each String represents a file name relative to the root of the module.

Returns:
an enumeration of the archive file entries.

getEntry

InputStream getEntry(String name)
Returns the InputStream for the given entry name The file name must be relative to the root of the module.

Parameters:
name - the file name relative to the root of the module.
Returns:
the InputStream for the given entry name or null if not found.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


exceptions

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.model.exceptions

Provides Tool Vendor exception implementation classes.

See:
Description

Exception Summary
DDBeanCreateException This exception reports errors in generating a DDBean.

Package javax.enterprise.deploy.model.exceptions Description

Provides Tool Vendor exception implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.model.exceptions Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.model.exceptions

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.enterprise.deploy.model.exceptions.DDBeanCreateException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DDBeanCreateException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.model.exceptions
Class DDBeanCreateException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.enterprise.deploy.model.exceptions.DDBeanCreateException
All Implemented Interfaces:
Serializable
public class DDBeanCreateException
extends Exception

This exception reports errors in generating a DDBean.

Author:
gfink
See Also:
Serialized Form

Constructor Summary
DDBeanCreateException()
Creates new DDBeanCreateException without detail message.
DDBeanCreateException(String msg)
Constructs an DDBeanCreateException with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DDBeanCreateException

public DDBeanCreateException()
Creates new DDBeanCreateException without detail message.

DDBeanCreateException

public DDBeanCreateException(String msg)
Constructs an DDBeanCreateException with the specified detail message.

Parameters:
msg - the detail message.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


J2eeApplicationObject

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.model
Interface J2eeApplicationObject

All Superinterfaces:
DeployableObject
public interface J2eeApplicationObject
extends DeployableObject

J2eeApplicationObject is an interface that represents a J2EE application (EAR); it maintains a DeployableObject for each module in the archive.

Method Summary
void | addXpathListener(ModuleType type, String xpath, XpathListener xpl) Register a listener for changes in XPath that are related to this deployableObject.
DDBean[] | getChildBean(ModuleType type, String xpath) Return a list of DDBean based upon an XPath; all deployment descriptors of the specified type are searched.
DeployableObject | getDeployableObject(String uri) Return the DeployableObject of the specified URI designator.
DeployableObject[] | getDeployableObjects() Return the all DeployableObjects in this application.
DeployableObject[] | getDeployableObjects(ModuleType type) Return the all DeployableObjects of the specified type.
String[] | getModuleUris() Return the list of URIs for all modules in the application.
String[] | getModuleUris(ModuleType type) Return the list of URIs of the designated module type.
String[] | getText(ModuleType type, String xpath) Return the text value from the XPath; search only the deployment descriptors of the specified type.
void | removeXpathListener(ModuleType type, String xpath, XpathListener xpl) Unregister the listener for an XPath.
Methods inherited from interface javax.enterprise.deploy.model.DeployableObject
entries, getChildBean, getClassFromScope, getDDBeanRoot, getDDBeanRoot, getEntry, getModuleDTDVersion, getText, getType

Method Detail

getDeployableObject

DeployableObject getDeployableObject(String uri)
Return the DeployableObject of the specified URI designator.

Parameters:
uri - Describes where to get the module from.
Returns:
the DeployableObject describing the j2ee module at this uri or 'null' if there is not match.

getDeployableObjects

DeployableObject[] getDeployableObjects(ModuleType type)
Return the all DeployableObjects of the specified type.

Parameters:
type - The type of module to return.
Returns:
the list of DeployableObjects describing the j2ee module at this uri or 'null' if there are no matches.

getDeployableObjects

DeployableObject[] getDeployableObjects()
Return the all DeployableObjects in this application.

Returns:
the DeployableObject describing the j2ee module at this uri or 'null' if there are no matches.

getModuleUris

String[] getModuleUris(ModuleType type)
Return the list of URIs of the designated module type.

Parameters:
type - The type of module to return.
Returns:
the Uris of the contained modules or 'null' if there are no matches.

getModuleUris

String[] getModuleUris()
Return the list of URIs for all modules in the application.

Returns:
the Uris of the contained modules or 'null' if there are no matches.

getChildBean

DDBean[] getChildBean(ModuleType type,
                      String xpath)
Return a list of DDBean based upon an XPath; all deployment descriptors of the specified type are searched.

Parameters:
type - The type of deployment descriptor to query.
xpath - An XPath string referring to a location in the deployment descriptor
Returns:
The list of DDBeans or 'null' of there are no matches.

getText

String[] getText(ModuleType type,
                 String xpath)
Return the text value from the XPath; search only the deployment descriptors of the specified type.

Parameters:
type - The type of deployment descriptor to query.
xpath - An xpath string referring to a location in the deployment descriptor
Returns:
The text values of this xpath or 'null' if there are no matches.

addXpathListener

void addXpathListener(ModuleType type,
                      String xpath,
                      XpathListener xpl)
Register a listener for changes in XPath that are related to this deployableObject.

Parameters:
type - The type of deployment descriptor to query.
xpath - The xpath to listen for.
xpl - The listener.

removeXpathListener

void removeXpathListener(ModuleType type,
                         String xpath,
                         XpathListener xpl)
Unregister the listener for an XPath.

Parameters:
type - The type of deployment descriptor to query.
xpath - he XPath to listen for
xpl - The listener
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XpathEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.model
Class XpathEvent

java.lang.Object
    extended by  javax.enterprise.deploy.model.XpathEvent

public final class XpathEvent
extends Object

An Event class describing ConfigBeans being added/subtracted from a server configuration.

Field Summary
static Object | BEAN_ADDED Adding a DDBean
static Object | BEAN_CHANGED Changing a DDBean
static Object | BEAN_REMOVED Removing a DDBean
Constructor Summary
XpathEvent(DDBean bean, Object typ)
A description of a change in the ConfigBean tree.
Method Summary
DDBean | getBean() The bean being added/removed/changed.
PropertyChangeEvent | getChangeEvent()
boolean | isAddEvent() Is this an add event?
boolean | isChangeEvent() Is this a change event?
boolean | isRemoveEvent() Is this a remove event?
void | setChangeEvent(PropertyChangeEvent pce)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

BEAN_ADDED

public static final Object BEAN_ADDED
Adding a DDBean

BEAN_REMOVED

public static final Object BEAN_REMOVED
Removing a DDBean

BEAN_CHANGED

public static final Object BEAN_CHANGED
Changing a DDBean

Constructor Detail

XpathEvent

public XpathEvent(DDBean bean,
                  Object typ)
A description of a change in the ConfigBean tree.

Parameters:
bean - The ConfigBean being added/removed.
typ - Indicates an add/remove event.
Method Detail

getChangeEvent

public PropertyChangeEvent getChangeEvent()

setChangeEvent

public void setChangeEvent(PropertyChangeEvent pce)

getBean

public DDBean getBean()
The bean being added/removed/changed.

Returns:
The bean being added/removed/changed.

isAddEvent

public boolean isAddEvent()
Is this an add event?

Returns:
true if this is an add event.

isRemoveEvent

public boolean isRemoveEvent()
Is this a remove event?

Returns:
true if this is a remove event.

isChangeEvent

public boolean isChangeEvent()
Is this a change event?

Returns:
true if this is a change event.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XpathListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.model
Interface XpathListener

public interface XpathListener

The listener interface for receiving XpathEvents

Author:
gfink

Method Summary
 void fireXpathEvent(XpathEvent xpe)

Method Detail

fireXpathEvent

void fireXpathEvent(XpathEvent xpe)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


shared

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.shared

Provides shared objects for Tool Vendor and Product Vendor implementation classes.

See:
Description

Class Summary
ActionType | Class ActionTypes defines enumeration values for the J2EE DeploymentStatus actions.
CommandType | Class CommandTypes defines enumeration values for the DeploymentStatus object.
DConfigBeanVersionType | Class DConfigBeanVersionTypes defines enumeration values for the J2EE Platform verion number.
ModuleType | Class ModuleTypes defines enumeration values for the J2EE module types.
StateType | Class StateTypes defines enumeration values for the DeploymentStatus object.

Package javax.enterprise.deploy.shared Description

Provides shared objects for Tool Vendor and Product Vendor implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.shared Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.shared

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.enterprise.deploy.shared.ActionType
    • javax.enterprise.deploy.shared.CommandType
    • javax.enterprise.deploy.shared.DConfigBeanVersionType
    • javax.enterprise.deploy.shared.ModuleType
    • javax.enterprise.deploy.shared.StateType
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ActionType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.shared
Class ActionType

java.lang.Object
    extended by  javax.enterprise.deploy.shared.ActionType

public class ActionType
extends Object

Class ActionTypes defines enumeration values for the J2EE DeploymentStatus actions.

Author:
rsearls

Field Summary
static ActionType | CANCEL A cancel operation is being preformed on the DeploymentManager action command.
static ActionType | EXECUTE The DeploymentManager action command is executing.
static ActionType | STOP A stop operation is being preformed on the DeploymentManager action command.
Constructor Summary
protected ActionType(int value)
Construct a new enumeration value with the given integer value.
Method Summary
static ActionType | getActionType(int value) Return an object of the specified value.
protected ActionType[] | getEnumValueTable() Returns the enumeration value table for class ActionType
protected int | getOffset() Returns the lowest integer value used by this enumeration value's enumeration class.
protected String[] | getStringTable() Returns the string table for class ActionType
int | getValue() Returns this enumeration value's integer value.
String | toString() Return the string name of this ActionType or the integer value if outside the bounds of the table
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

EXECUTE

public static final ActionType EXECUTE
The DeploymentManager action command is executing.

CANCEL

public static final ActionType CANCEL
A cancel operation is being preformed on the DeploymentManager action command.

STOP

public static final ActionType STOP
A stop operation is being preformed on the DeploymentManager action command.

Constructor Detail

ActionType

protected ActionType(int value)
Construct a new enumeration value with the given integer value.

Parameters:
value - Integer value.
Method Detail

getValue

public int getValue()
Returns this enumeration value's integer value.

Returns:
the value

getStringTable

protected String[] getStringTable()
Returns the string table for class ActionType

getEnumValueTable

protected ActionType[] getEnumValueTable()
Returns the enumeration value table for class ActionType

getActionType

public static ActionType getActionType(int value)
Return an object of the specified value.

Parameters:
value - a designator for the object.

toString

public String toString()
Return the string name of this ActionType or the integer value if outside the bounds of the table

Overrides:
toString in class Object

getOffset

protected int getOffset()
Returns the lowest integer value used by this enumeration value's enumeration class.

The default implementation returns 0.

Returns:
the offset of the lowest enumeration value.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


CommandType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.shared
Class CommandType

java.lang.Object
    extended by  javax.enterprise.deploy.shared.CommandType

public class CommandType
extends Object

Class CommandTypes defines enumeration values for the DeploymentStatus object.

Author:
rsearls

Field Summary
static CommandType | DISTRIBUTE The DeploymentManger action operation being processed is distribute.
static CommandType | REDEPLOY The DeploymentManger action operation being processed is redeploy.
static CommandType | START The DeploymentManger action operation being processed is start.
static CommandType | STOP The DeploymentManger action operation being processed is stop.
static CommandType | UNDEPLOY The DeploymentManger action operation being processed is undeploy.
Constructor Summary
protected CommandType(int value)
Construct a new enumeration value with the given integer value.
Method Summary
static CommandType | getCommandType(int value) Return an object of the specified value.
protected CommandType[] | getEnumValueTable() Returns the enumeration value table for class CommandType
protected int | getOffset() Returns the lowest integer value used by this enumeration value's enumeration class.
protected String[] | getStringTable() Returns the string table for class CommandType
int | getValue() Returns this enumeration value's integer value.
String | toString() Return the string name of this CommandType or the integer value if outside the bounds of the table
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

DISTRIBUTE

public static final CommandType DISTRIBUTE
The DeploymentManger action operation being processed is distribute.

START

public static final CommandType START
The DeploymentManger action operation being processed is start.

STOP

public static final CommandType STOP
The DeploymentManger action operation being processed is stop.

UNDEPLOY

public static final CommandType UNDEPLOY
The DeploymentManger action operation being processed is undeploy.

REDEPLOY

public static final CommandType REDEPLOY
The DeploymentManger action operation being processed is redeploy.

Constructor Detail

CommandType

protected CommandType(int value)
Construct a new enumeration value with the given integer value.

Parameters:
value - Integer value.
Method Detail

getValue

public int getValue()
Returns this enumeration value's integer value.

Returns:
the value

getStringTable

protected String[] getStringTable()
Returns the string table for class CommandType

getEnumValueTable

protected CommandType[] getEnumValueTable()
Returns the enumeration value table for class CommandType

getCommandType

public static CommandType getCommandType(int value)
Return an object of the specified value.

Parameters:
value - a designator for the object.

toString

public String toString()
Return the string name of this CommandType or the integer value if outside the bounds of the table

Overrides:
toString in class Object

getOffset

protected int getOffset()
Returns the lowest integer value used by this enumeration value's enumeration class.

The default implementation returns 0.

Returns:
the offset of the lowest enumeration value.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DConfigBeanVersionType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.shared
Class DConfigBeanVersionType

java.lang.Object
    extended by  javax.enterprise.deploy.shared.DConfigBeanVersionType

public class DConfigBeanVersionType
extends Object

Class DConfigBeanVersionTypes defines enumeration values for the J2EE Platform verion number.

Author:
rsearls

Field Summary
static DConfigBeanVersionType | V1_3 J2EE Platform version 1.3
static DConfigBeanVersionType | V1_3_1 J2EE Platform version 1.3.1 THIS CONSTANT SHOULD NEVER BE USED.
static DConfigBeanVersionType | V1_4 J2EE Platform version 1.4
static DConfigBeanVersionType | V5 Java EE Platform version 5
Constructor Summary
protected DConfigBeanVersionType(int value)
Construct a new enumeration value with the given integer value.
Method Summary
static DConfigBeanVersionType | getDConfigBeanVersionType(int value) Return an object of the specified value.
protected DConfigBeanVersionType[] | getEnumValueTable() Returns the enumeration value table for class DConfigBeanVersionType
protected int | getOffset() Returns the lowest integer value used by this enumeration value's enumeration class.
protected String[] | getStringTable() Returns the string table for class DConfigBeanVersionType
int | getValue() Returns this enumeration value's integer value.
String | toString() Return the string name of this DConfigBeanVersionType or the integer value if outside the bounds of the table
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

V1_3

public static final DConfigBeanVersionType V1_3
J2EE Platform version 1.3

V1_3_1

public static final DConfigBeanVersionType V1_3_1
J2EE Platform version 1.3.1 THIS CONSTANT SHOULD NEVER BE USED. Use V1_3 instead.

V1_4

public static final DConfigBeanVersionType V1_4
J2EE Platform version 1.4

V5

public static final DConfigBeanVersionType V5
Java EE Platform version 5

Constructor Detail

DConfigBeanVersionType

protected DConfigBeanVersionType(int value)
Construct a new enumeration value with the given integer value.

Parameters:
value - Integer value.
Method Detail

getValue

public int getValue()
Returns this enumeration value's integer value.

Returns:
the value

getStringTable

protected String[] getStringTable()
Returns the string table for class DConfigBeanVersionType

getEnumValueTable

protected DConfigBeanVersionType[] getEnumValueTable()
Returns the enumeration value table for class DConfigBeanVersionType

getDConfigBeanVersionType

public static DConfigBeanVersionType getDConfigBeanVersionType(int value)
Return an object of the specified value.

Parameters:
value - a designator for the object.

toString

public String toString()
Return the string name of this DConfigBeanVersionType or the integer value if outside the bounds of the table

Overrides:
toString in class Object

getOffset

protected int getOffset()
Returns the lowest integer value used by this enumeration value's enumeration class.

The default implementation returns 0.

Returns:
the offset of the lowest enumeration value.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


factories

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.shared.factories

Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.

See:
Description

Class Summary
DeploymentFactoryManager The DeploymentFactoryManager class is a central registry for J2EE DeploymentFactory objects.

Package javax.enterprise.deploy.shared.factories Description

Provides shared factory manager object for Tool Vendor and Product Vendor implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.shared.factories Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.shared.factories

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.enterprise.deploy.shared.factories.DeploymentFactoryManager
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DeploymentFactoryManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.shared.factories
Class DeploymentFactoryManager

java.lang.Object
    extended by  javax.enterprise.deploy.shared.factories.DeploymentFactoryManager

public final class DeploymentFactoryManager
extends Object

The DeploymentFactoryManager class is a central registry for J2EE DeploymentFactory objects. The DeploymentFactoryManager retains references to DeploymentFactory objects loaded by a tool. A DeploymentFactory object provides a reference to a DeploymentManager. The DeploymentFactoryManager has been implemented as a singleton. A tool gets a reference to the DeploymentFactoryManager via the getInstance method. The DeploymentFactoryManager can return two types of DeploymentManagers, a connected DeploymentManager and a disconnected DeploymentManager. The connected DeploymentManager provides access to any product resources that may be required for configurations and deployment. The method to retrieve a connected DeploymentManager is getDeploymentManager. This method provides parameters for user name and password that the product may require for user authentication. A disconnected DeploymentManager does not provide access to a running J2EE product. The method to retrieve a disconnected DeploymentManager is getDisconnectedDeploymentManager. A disconnected DeploymentManager does not need user authentication information.

Method Summary
DeploymentFactory[] | getDeploymentFactories() Retrieve the lists of currently registered DeploymentFactories.
DeploymentManager | getDeploymentManager(String uri, String username, String password) Retrieves a DeploymentManager instance to use for deployment.
DeploymentManager | getDisconnectedDeploymentManager(String uri) Return a disconnected DeploymentManager instance.
static DeploymentFactoryManager | getInstance() Retrieve the Singleton DeploymentFactoryManager
void | registerDeploymentFactory(DeploymentFactory factory) Registers a DeploymentFactory so it will be able to handle requests.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getInstance

public static DeploymentFactoryManager getInstance()
Retrieve the Singleton DeploymentFactoryManager

Returns:
DeploymentFactoryManager instance

getDeploymentFactories

public DeploymentFactory[] getDeploymentFactories()
Retrieve the lists of currently registered DeploymentFactories.

Returns:
the list of DeploymentFactory objects or an empty array if there are none.

getDeploymentManager

public DeploymentManager getDeploymentManager(String uri,
                                              String username,
                                              String password)
                                       throws DeploymentManagerCreationException
Retrieves a DeploymentManager instance to use for deployment. The caller provides a URI and optional username and password, and all registered DeploymentFactories will be checked. The first one to understand the URI provided will attempt to initiate a server connection and return a ready DeploymentManager instance.

Parameters:
uri - The uri to check
username - An optional username (may be null if no authentication is required for this platform).
password - An optional password (may be null if no authentication is required for this platform).
Returns:
A ready DeploymentManager instance.
Throws:
DeploymentManagerCreationException - Occurs when the factory appropriate to the specified URI was unable to initialize a DeploymentManager instance (server down, unable to authenticate, etc.).

registerDeploymentFactory

public void registerDeploymentFactory(DeploymentFactory factory)
Registers a DeploymentFactory so it will be able to handle requests.

getDisconnectedDeploymentManager

public DeploymentManager getDisconnectedDeploymentManager(String uri)
                                                   throws DeploymentManagerCreationException
Return a disconnected DeploymentManager instance.

Parameters:
uri - identifier of the disconnected DeploymentManager to return.
Returns:
A DeploymentManager instance.
Throws:
DeploymentDriverException - occurs if the DeploymentManager could not be created.
DeploymentManagerCreationException
Overview  Package   Class  Tree  Deprecated  Index  Help
Java EE 5 SDK
 PREV CLASS   NEXT CLASS | FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ModuleType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.shared
Class ModuleType

java.lang.Object
    extended by  javax.enterprise.deploy.shared.ModuleType

public class ModuleType
extends Object

Class ModuleTypes defines enumeration values for the J2EE module types.

Author:
Rebecca Searls

Field Summary
static ModuleType | CAR The module is an Client Application archive.
static ModuleType | EAR The module is an EAR archive.
static ModuleType | EJB The module is an Enterprise Java Bean archive.
static ModuleType | RAR The module is an Connector archive.
static ModuleType | WAR The module is an Web Application archive.
Constructor Summary
protected ModuleType(int value)
Construct a new enumeration value with the given integer value.
Method Summary
protected ModuleType[] | getEnumValueTable() Returns the enumeration value table for class ModuleType
String | getModuleExtension() Return the file extension string for this enumeration.
static ModuleType | getModuleType(int value) Return an object of the specified value.
protected int | getOffset() Returns the lowest integer value used by this enumeration value's enumeration class.
protected String[] | getStringTable() Returns the string table for class ModuleType
int | getValue() Returns this enumeration value's integer value.
String | toString() Return the string name of this ModuleType or the integer value if outside the bounds of the table
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

EAR

public static final ModuleType EAR
The module is an EAR archive.

EJB

public static final ModuleType EJB
The module is an Enterprise Java Bean archive.

CAR

public static final ModuleType CAR
The module is an Client Application archive.

RAR

public static final ModuleType RAR
The module is an Connector archive.

WAR

public static final ModuleType WAR
The module is an Web Application archive.

Constructor Detail

ModuleType

protected ModuleType(int value)
Construct a new enumeration value with the given integer value.

Parameters:
value - Integer value.
Method Detail

getValue

public int getValue()
Returns this enumeration value's integer value.

Returns:
the value

getStringTable

protected String[] getStringTable()
Returns the string table for class ModuleType

getEnumValueTable

protected ModuleType[] getEnumValueTable()
Returns the enumeration value table for class ModuleType

getModuleExtension

public String getModuleExtension()
Return the file extension string for this enumeration.

getModuleType

public static ModuleType getModuleType(int value)
Return an object of the specified value.

Parameters:
value - a designator for the object.

toString

public String toString()
Return the string name of this ModuleType or the integer value if outside the bounds of the table

Overrides:
toString in class Object

getOffset

protected int getOffset()
Returns the lowest integer value used by this enumeration value's enumeration class.

The default implementation returns 0. If the enumeration class (a subclass of class EnumSyntax) uses integer values starting at other than 0, override this method in the subclass.

Returns:
the offset of the lowest enumeration value.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StateType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.shared
Class StateType

java.lang.Object
    extended by  javax.enterprise.deploy.shared.StateType

public class StateType
extends Object

Class StateTypes defines enumeration values for the DeploymentStatus object.

Author:
rsearls

Field Summary
static StateType | COMPLETED The action operation has completed normally.
static StateType | FAILED The action operation has failed.
static StateType | RELEASED The DeploymentManager is running in discommected mode.
static StateType | RUNNING The action operation is running normally.
Constructor Summary
protected StateType(int value)
Construct a new enumeration value with the given integer value.
Method Summary
protected StateType[] | getEnumValueTable() Returns the enumeration value table for class StateType
protected int | getOffset() Returns the lowest integer value used by this enumeration value's enumeration class.
static StateType | getStateType(int value) Return an object of the specified value.
protected String[] | getStringTable() Returns the string table for class StateType
int | getValue() Returns this enumeration value's integer value.
String | toString() Return the string name of this StateType or the integer value if outside the bounds of the table
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

RUNNING

public static final StateType RUNNING
The action operation is running normally.

COMPLETED

public static final StateType COMPLETED
The action operation has completed normally.

FAILED

public static final StateType FAILED
The action operation has failed.

RELEASED

public static final StateType RELEASED
The DeploymentManager is running in discommected mode.

Constructor Detail

StateType

protected StateType(int value)
Construct a new enumeration value with the given integer value.

Parameters:
value - Integer value.
Method Detail

getValue

public int getValue()
Returns this enumeration value's integer value.

Returns:
the value

getStringTable

protected String[] getStringTable()
Returns the string table for class StateType

getEnumValueTable

protected StateType[] getEnumValueTable()
Returns the enumeration value table for class StateType

getStateType

public static StateType getStateType(int value)
Return an object of the specified value.

Parameters:
value - a designator for the object.

toString

public String toString()
Return the string name of this StateType or the integer value if outside the bounds of the table

Overrides:
toString in class Object

getOffset

protected int getOffset()
Returns the lowest integer value used by this enumeration value's enumeration class.

The default implementation returns 0.

Returns:
the offset of the lowest enumeration value.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


spi

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.spi

Provides J2EE Product Vendor implementation classes.

See:
Description

Interface Summary
DConfigBean | The DConfigBean is a deployment configuration bean (DConfigBean) that is associated with one or more deployment descriptor beans, (DDBean).
DConfigBeanRoot | A J2EE component module consists of one or more deployment descriptor files and zero or more non-deployment descriptor XML instance documents.
DeploymentConfiguration | An interface that defines a container for all the server-specific configuration information for a single top-level J2EE module.
DeploymentManager | The DeploymentManager object provides the core set of functions a J2EE platform must provide for J2EE application deployment.
Target | A Target interface represents a single logical core server of one instance of a J2EE platform product.
TargetModuleID | A TargetModuleID interface represents a unique identifier for a deployed application module.

Package javax.enterprise.deploy.spi Description

Provides J2EE Product Vendor implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.spi Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.spi

Package Hierarchies:
All Packages

Interface Hierarchy

  • javax.enterprise.deploy.spi.DConfigBean
    • javax.enterprise.deploy.spi.DConfigBeanRoot
  • javax.enterprise.deploy.spi.DeploymentConfiguration
  • javax.enterprise.deploy.spi.DeploymentManager
  • javax.enterprise.deploy.spi.Target
  • javax.enterprise.deploy.spi.TargetModuleID
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DConfigBean

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi
Interface DConfigBean

All Known Subinterfaces:
DConfigBeanRoot
public interface DConfigBean

The DConfigBean is a deployment configuration bean (DConfigBean) that is associated with one or more deployment descriptor beans, (DDBean). A DConfigBean represents a logical grouping of deployment configuration data to be presented to the Deployer. A DConfigBean provides zero or more XPaths that identifies the XML information it requires. A DConfigBean may contain other DConfigBeans and regular JavaBeans. The top most DConfigBean is a DConfigBeanRoot object which represents a single XML instance document.

A DConfigBean is created by calling DConfigBean.getDConfigBean(DDBean) method, where DConfigBean is the object that provided the XPath which the DDBean represents.

A DConfigBean is a JavaBean component that presents the dynamic deployment configuration information for a J2EE plugin to the deployer. It is a JavaBean. The JavaBean architecture was chosen because of its versatility in providing both simple and complex components. JavaBeans also enable the development of property sheets and property editors, as well as sophisticated customization wizards.

It is expected that a plugin vendor will provide a Property Editor for any complex datatype in a DConfigBean that a deployer needs to edit through a property sheet. The Property Editor should be implemented and made available to a tool according to the guidelines defined in the JavaBeans API Specification version 1.01.

Method Summary
void | addPropertyChangeListener(PropertyChangeListener pcl) Register a property listener for this bean.
DConfigBean | getDConfigBean(DDBean bean) Return the JavaBean containing the server-specific deployment configuration information based upon the XML data provided by the DDBean.
DDBean | getDDBean() Return the JavaBean containing the deployment descriptor XML text associated with this DConfigBean.
String[] | getXpaths() Return a list of XPaths designating the deployment descriptor information this DConfigBean requires.
void | notifyDDChange(XpathEvent event) A notification that the DDBean provided in the event has changed and this bean or its child beans need to reevaluate themselves.
void | removeDConfigBean(DConfigBean bean) Remove a child DConfigBean from this bean.
void | removePropertyChangeListener(PropertyChangeListener pcl) Unregister a property listener for this bean.

Method Detail

getDDBean

DDBean getDDBean()
Return the JavaBean containing the deployment descriptor XML text associated with this DConfigBean.

Returns:
The bean class containing the XML text for this DConfigBean.

getXpaths

String[] getXpaths()
Return a list of XPaths designating the deployment descriptor information this DConfigBean requires. A given server vendor will need to specify some server-specific information. Each String returned by this method is an XPath describing a certain portion of the standard deployment descriptor for which there is corresponding server-specific configuration.

Returns:
a list of XPath Strings representing XML data to be retrieved or 'null' if there are none.

getDConfigBean

DConfigBean getDConfigBean(DDBean bean)
                           throws ConfigurationException
Return the JavaBean containing the server-specific deployment configuration information based upon the XML data provided by the DDBean.

Parameters:
bean - The DDBean containing the XML data to be evaluated.
Returns:
The DConfigBean to display the server-specific properties for the standard bean.
Throws:
ConfigurationException - reports errors in generating a configuration bean. This DDBean is considered undeployable to this server until this exception is resolved. A suitably descriptive message is required so the user can diagnose the error.

removeDConfigBean

void removeDConfigBean(DConfigBean bean)
                       throws BeanNotFoundException
Remove a child DConfigBean from this bean.

Parameters:
bean - The child DConfigBean to be removed.
Throws:
BeanNotFoundException - the bean provided is not in the child list of this bean.

notifyDDChange

void notifyDDChange(XpathEvent event)
A notification that the DDBean provided in the event has changed and this bean or its child beans need to reevaluate themselves.

Parameters:
event - an event containing a reference to the DDBean which has changed.

addPropertyChangeListener

void addPropertyChangeListener(PropertyChangeListener pcl)
Register a property listener for this bean.

Parameters:
pcl - PropertyChangeListener to add

removePropertyChangeListener

void removePropertyChangeListener(PropertyChangeListener pcl)
Unregister a property listener for this bean.

Parameters:
pcl - Listener to remove.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DConfigBeanRoot

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi
Interface DConfigBeanRoot

All Superinterfaces:
DConfigBean
public interface DConfigBeanRoot
extends DConfigBean

A J2EE component module consists of one or more deployment descriptor files and zero or more non-deployment descriptor XML instance documents. A module must contain a component-specific deployment descriptor file (see the component specification for details). It may contain one or more secondary deployment descriptor files that define extra functionality on the component and zero or more non-deployment descriptor XML instance documents (see the Web Services specification).

The DConfigBeanRoot object is a deployment configuration bean (DConfigBean) that is associated with the root of the component's deployment descriptor. It must be created by calling the DeploymentConfiguration.getDConfigBean(DDBeanRoot) method, where DDBeanRoot represents the component's deployment descriptor.

A DConfigBean object is associated with a deployment descriptor that extends a component's functionality. It must be created by calling the DConfigBeanRoot.getDConfigBean(DDBeanRoot) method. This DConfigBean object is a child of the compontent's DConfigBeanRoot object. The DDBeanRoot argument represents the secondary deployment descriptor. Deployment descriptor files such as webservice.xml and webserviceclient.xml are examples of secondary deployment descriptor files.

The server plugin must request a DDBeanRoot object for any non-deployment descriptor XML instance document data it requires. The plugin must call method DeployableObject.getDDBeanRoot(String) where String is the full path name from the root of the module to the file to be represented. A WSDL file is an example of a non-deployment descriptor XML instance document.

Author:
gfink

Method Summary
 DConfigBean getDConfigBean(DDBeanRoot ddBeanRoot)
Return a DConfigBean for a deployment descriptor that is not the module's primary deployment descriptor.
Methods inherited from interface javax.enterprise.deploy.spi.DConfigBean
addPropertyChangeListener, getDConfigBean, getDDBean, getXpaths, notifyDDChange, removeDConfigBean, removePropertyChangeListener

Method Detail

getDConfigBean

DConfigBean getDConfigBean(DDBeanRoot ddBeanRoot)
Return a DConfigBean for a deployment descriptor that is not the module's primary deployment descriptor. Web services provides a deployment descriptor in addition to the module's primary deployment descriptor. Only the DDBeanRoot for this catagory of secondary deployment descriptors are to be passed as arguments through this method. Web service has two deployment descriptor files, one that defines the web service and one that defines a client of a web service. See the Web Service specificiation for the details.

Parameters:
ddBeanRoot - represents the root element of a deployment descriptor file.
Returns:
a DConfigBean to be used for processing this deployment descriptor data. Null may be returned if no DConfigBean is required for this deployment descriptor.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DeploymentConfiguration

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi
Interface DeploymentConfiguration

public interface DeploymentConfiguration

An interface that defines a container for all the server-specific configuration information for a single top-level J2EE module. The DeploymentConfiguration object could represent a single stand alone module or an EAR file that contains several sub-modules.

Version:
0.1
Author:
gfink

Method Summary
DConfigBeanRoot | getDConfigBeanRoot(DDBeanRoot bean) Returns the top level configuration bean, DConfigBeanRoot, associated with the deployment descriptor represented by the designated DDBeanRoot bean.
DeployableObject | getDeployableObject() Returns an object that provides access to the deployment descriptor data and classes of a J2EE module.
void | removeDConfigBean(DConfigBeanRoot bean) Remove the root DConfigBean and all its children.
void | restore(InputStream inputArchive) Restore from disk to a full set of configuration beans previously stored.
DConfigBeanRoot | restoreDConfigBean(InputStream inputArchive, DDBeanRoot bean) Restore from disk to instantated objects all the DConfigBeans associated with a specific deployment descriptor.
void | save(OutputStream outputArchive) Save to disk the current set configuration beans created for this deployable module.
void | saveDConfigBean(OutputStream outputArchive, DConfigBeanRoot bean) Save to disk all the configuration beans associated with a particular deployment descriptor file.

Method Detail

getDeployableObject

DeployableObject getDeployableObject()
Returns an object that provides access to the deployment descriptor data and classes of a J2EE module.

Returns:
DeployableObject

getDConfigBeanRoot

DConfigBeanRoot getDConfigBeanRoot(DDBeanRoot bean)
                                   throws ConfigurationException
Returns the top level configuration bean, DConfigBeanRoot, associated with the deployment descriptor represented by the designated DDBeanRoot bean.

Parameters:
bean - The top level bean that represents the associated deployment descriptor.
Returns:
the DConfigBeanRoot for editing the server-specific properties required by the module.
Throws:
ConfigurationException - reports errors in generating a configuration bean

removeDConfigBean

void removeDConfigBean(DConfigBeanRoot bean)
                       throws BeanNotFoundException
Remove the root DConfigBean and all its children.

Parameters:
bean - the top leve DConfigBean to remove.
Throws:
BeanNotFoundException - the bean provides is not in this beans child list.

restoreDConfigBean

DConfigBeanRoot restoreDConfigBean(InputStream inputArchive,
                                   DDBeanRoot bean)
                                   throws ConfigurationException
Restore from disk to instantated objects all the DConfigBeans associated with a specific deployment descriptor. The beans may be fully or partially configured.

Parameters:
inputArchive - The input stream for the file from which the DConfigBeans should be restored.
bean - The DDBeanRoot bean associated with the deployment descriptor file.
Returns:
The top most parent configuration bean, DConfigBeanRoot
Throws:
ConfigurationException - reports errors in generating a configuration bean

saveDConfigBean

void saveDConfigBean(OutputStream outputArchive,
                     DConfigBeanRoot bean)
                     throws ConfigurationException
Save to disk all the configuration beans associated with a particular deployment descriptor file. The saved data may be fully or partially configured DConfigBeans. The output file format is recommended to be XML.

Parameters:
outputArchive - The output stream to which the DConfigBeans should be saved.
bean - The top level bean, DConfigBeanRoot, from which to be save.
Throws:
ConfigurationException - reports errors in generating a configuration bean

restore

void restore(InputStream inputArchive)
             throws ConfigurationException
Restore from disk to a full set of configuration beans previously stored.

Parameters:
inputArchive - The input stream from which to restore the Configuration.
Throws:
ConfigurationException - reports errors in generating a configuration bean

save

void save(OutputStream outputArchive)
          throws ConfigurationException
Save to disk the current set configuration beans created for this deployable module. It is recommended the file format be XML.

Parameters:
outputArchive - The output stream to which to save the Configuration.
Throws:
ConfigurationException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DeploymentManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi
Interface DeploymentManager

public interface DeploymentManager

The DeploymentManager object provides the core set of functions a J2EE platform must provide for J2EE application deployment. It provides server related information, such as, a list of deployment targets, and vendor unique runtime configuration information.

Method Summary
 DeploymentConfiguration createConfiguration(DeployableObject dObj)
Retrieve the object that provides server-specific deployment configuration information for the J2EE deployable component.
 ProgressObject distribute(Target[] targetList, File moduleArchive, File deploymentPlan)
The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
 ProgressObject distribute(Target[] targetList, InputStream moduleArchive, InputStream deploymentPlan)
Deprecated. as of Java EE 5, replaced with distribute(Target[], ModuleType, InputStream, InputStream)
 ProgressObject distribute(Target[] targetList, ModuleType type, InputStream moduleArchive, InputStream deploymentPlan)
The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.
 TargetModuleID[] getAvailableModules(ModuleType moduleType, Target[] targetList)
Retrieve the list of all J2EE application modules running or not running on the identified targets.
 Locale getCurrentLocale()
Returns the active locale this implementation of javax.enterprise.deploy.spi subpackages is running.
 DConfigBeanVersionType getDConfigBeanVersion()
Returns the J2EE platform version number for which the configuration beans are provided.
 Locale getDefaultLocale()
Returns the default locale supported by this implementation of javax.enterprise.deploy.spi subpackages.
 TargetModuleID[] getNonRunningModules(ModuleType moduleType, Target[] targetList)
Retrieve the list of J2EE application modules distributed to the identified targets and that are currently not running on the associated server or servers.
 TargetModuleID[] getRunningModules(ModuleType moduleType, Target[] targetList)
Retrieve the list of J2EE application modules distributed to the identified targets and that are currently running on the associated server or servers.
 Locale[] getSupportedLocales()
Returns an array of supported locales for this implementation.
 Target[] getTargets()
Retrieve the list of deployment targets supported by this DeploymentManager.
 boolean isDConfigBeanVersionSupported(DConfigBeanVersionType version)
Returns 'true' if the configuration beans support the J2EE platform version specified.
 boolean isLocaleSupported(Locale locale)
Reports if this implementation supports the designated locale.
 boolean isRedeploySupported()
This method designates whether this platform vendor provides application redeployment functionality.
 ProgressObject redeploy(TargetModuleID[] moduleIDList, File moduleArchive, File deploymentPlan)
(optional) The redeploy method provides a means for updating currently deployed J2EE applications.
 ProgressObject redeploy(TargetModuleID[] moduleIDList, InputStream moduleArchive, InputStream deploymentPlan)
(optional) The redeploy method provides a means for updating currently deployed J2EE applications.
 void release()
The release method is the mechanism by which the tool signals to the DeploymentManager that the tool does not need it to continue running connected to the platform.
 void setDConfigBeanVersion(DConfigBeanVersionType version)
Set the configuration beans to be used to the J2EE platform version specificed.
 void setLocale(Locale locale)
Set the active locale for this implementation of javax.enterprise.deploy.spi subpackages to run.
 ProgressObject start(TargetModuleID[] moduleIDList)
Start the application running.
 ProgressObject stop(TargetModuleID[] moduleIDList)
Stop the application running.
 ProgressObject undeploy(TargetModuleID[] moduleIDList)
Remove the application from the target server.

Method Detail

getTargets

Target[] getTargets()
                    throws IllegalStateException
Retrieve the list of deployment targets supported by this DeploymentManager.

Returns:
A list of deployment Target designators the user may select for application deployment or 'null' if there are none.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.

getRunningModules

TargetModuleID[] getRunningModules(ModuleType moduleType,
                                   Target[] targetList)
                                   throws TargetException,
                                          IllegalStateException
Retrieve the list of J2EE application modules distributed to the identified targets and that are currently running on the associated server or servers.

Parameters:
moduleType - A predefined designator for a J2EE module type.
targetList - A list of deployment Target designators the user wants checked for module run status.
Returns:
An array of TargetModuleID objects representing the running modules or 'null' if there are none.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.
TargetException - An invalid Target designator encountered.

getNonRunningModules

TargetModuleID[] getNonRunningModules(ModuleType moduleType,
                                      Target[] targetList)
                                      throws TargetException,
                                             IllegalStateException
Retrieve the list of J2EE application modules distributed to the identified targets and that are currently not running on the associated server or servers.

Parameters:
moduleType - A predefined designator for a J2EE module type.
targetList - A list of deployment Target designators the user wants checked for module not running status.
Returns:
An array of TargetModuleID objects representing the non-running modules or 'null' if there are none.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.
TargetException - An invalid Target designator encountered.

getAvailableModules

TargetModuleID[] getAvailableModules(ModuleType moduleType,
                                     Target[] targetList)
                                     throws TargetException,
                                            IllegalStateException
Retrieve the list of all J2EE application modules running or not running on the identified targets.

Parameters:
moduleType - A predefined designator for a J2EE module type.
targetList - A list of deployment Target designators the user wants checked for module not running status.
Returns:
An array of TargetModuleID objects representing all deployed modules running or not or 'null' if there are no deployed modules.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.
TargetException - An invalid Target designator encountered.

createConfiguration

DeploymentConfiguration createConfiguration(DeployableObject dObj)
                                            throws InvalidModuleException
Retrieve the object that provides server-specific deployment configuration information for the J2EE deployable component.

Parameters:
dObj - An object representing a J2EE deployable component.
Throws:
InvalidModuleException - The DeployableObject is an unknown or unsupport component for this configuration tool.

distribute

ProgressObject distribute(Target[] targetList,
                          File moduleArchive,
                          File deploymentPlan)
                          throws IllegalStateException
The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.

Parameters:
targetList - A list of server targets the user is specifying this application be deployed to.
moduleArchive - The file name of the application archive to be disrtibuted.
deploymentPlan - The XML file containing the runtime configuration information associated with this application archive.
Returns:
ProgressObject an object that tracks and reports the status of the distribution process.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.

distribute

ProgressObject distribute(Target[] targetList,
                          InputStream moduleArchive,
                          InputStream deploymentPlan)
                          throws IllegalStateException
Deprecated. as of Java EE 5, replaced with distribute(Target[], ModuleType, InputStream, InputStream)

The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.

Parameters:
targetList - A list of server targets the user is specifying this application be deployed to.
moduleArchive - The input stream containing the application archive to be disrtibuted.
deploymentPlan - The input stream containing the deployment configuration information associated with this application archive.
Returns:
ProgressObject an object that tracks and reports the status of the distribution process.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.

distribute

ProgressObject distribute(Target[] targetList,
                          ModuleType type,
                          InputStream moduleArchive,
                          InputStream deploymentPlan)
                          throws IllegalStateException
The distribute method performs three tasks; it validates the deployment configuration data, generates all container specific classes and interfaces, and moves the fully baked archive to the designated deployment targets.

Parameters:
targetList - A list of server targets the user is specifying this application be deployed to.
moduleType - The module type of this application archive.
moduleArchive - The input stream containing the application archive to be disrtibuted.
deploymentPlan - The input stream containing the deployment configuration information associated with this application archive.
Returns:
ProgressObject an object that tracks and reports the status of the distribution process.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.

start

ProgressObject start(TargetModuleID[] moduleIDList)
                     throws IllegalStateException
Start the application running.

Only the TargetModuleIDs which represent a root module are valid for being started. A root TargetModuleID has no parent. A TargetModuleID with a parent can not be individually started. A root TargetModuleID module and all its child modules will be started.

Parameters:
moduleIDList - A array of TargetModuleID objects representing the modules to be started.
Returns:
ProgressObject an object that tracks and reports the status of the start operation.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.

stop

ProgressObject stop(TargetModuleID[] moduleIDList)
                    throws IllegalStateException
Stop the application running.

Only the TargetModuleIDs which represent a root module are valid for being stopped. A root TargetModuleID has no parent. A TargetModuleID with a parent can not be individually stopped. A root TargetModuleID module and all its child modules will be stopped.

Parameters:
moduleIDList - A array of TargetModuleID objects representing the modules to be stopped.
Returns:
ProgressObject an object that tracks and reports the status of the stop operation.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.

undeploy

ProgressObject undeploy(TargetModuleID[] moduleIDList)
                        throws IllegalStateException
Remove the application from the target server.

Only the TargetModuleIDs which represent a root module are valid for undeployment. A root TargetModuleID has no parent. A TargetModuleID with a parent can not be undeployed. A root TargetModuleID module and all its child modules will be undeployed. The root TargetModuleID module and all its child modules must stopped before they can be undeployed.

Parameters:
moduleIDList - An array of TargetModuleID objects representing the root modules to be stopped.
Returns:
ProgressObject an object that tracks and reports the status of the stop operation.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.

isRedeploySupported

boolean isRedeploySupported()
This method designates whether this platform vendor provides application redeployment functionality. A value of true means it is supported. False means it is not.

Returns:
A value of true means redeployment is supported by this vendor's DeploymentManager. False means it is not.

redeploy

ProgressObject redeploy(TargetModuleID[] moduleIDList,
                        File moduleArchive,
                        File deploymentPlan)
                        throws UnsupportedOperationException,
                               IllegalStateException
(optional) The redeploy method provides a means for updating currently deployed J2EE applications. This is an optional method for vendor implementation. Redeploy replaces a currently deployed application with an updated version. The runtime configuration information for the updated application must remain identical to the application it is updating. When an application update is redeployed, all existing client connections to the original running application must not be disrupted; new clients will connect to the application update. This operation is valid for TargetModuleIDs that represent a root module. A root TargetModuleID has no parent. A root TargetModuleID module and all its child modules will be redeployed. A child TargetModuleID module cannot be individually redeployed. The redeploy operation is complete only when this action for all the modules has completed.

Parameters:
moduleIDList - An array of designators of the applications to be updated.
moduleArchive - The file name of the application archive to be disrtibuted.
deploymentPlan - The deployment configuration information associated with this application archive.
Returns:
ProgressObject an object that tracks and reports the status of the redeploy operation.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.
UnsupportedOperationException - this optional command is not supported by this implementation.

redeploy

ProgressObject redeploy(TargetModuleID[] moduleIDList,
                        InputStream moduleArchive,
                        InputStream deploymentPlan)
                        throws UnsupportedOperationException,
                               IllegalStateException
(optional) The redeploy method provides a means for updating currently deployed J2EE applications. This is an optional method for vendor implementation. Redeploy replaces a currently deployed application with an updated version. The runtime configuration information for the updated application must remain identical to the application it is updating. When an application update is redeployed, all existing client connections to the original running application must not be disrupted; new clients will connect to the application update. This operation is valid for TargetModuleIDs that represent a root module. A root TargetModuleID has no parent. A root TargetModuleID module and all its child modules will be redeployed. A child TargetModuleID module cannot be individually redeployed. The redeploy operation is complete only when this action for all the modules has completed.

Parameters:
moduleIDList - An array of designators of the applications to be updated.
moduleArchive - The input stream containing the application archive to be disrtibuted.
deploymentPlan - The input stream containing the runtime configuration information associated with this application archive.
Returns:
ProgressObject an object that tracks and reports the status of the redeploy operation.
Throws:
IllegalStateException - is thrown when the method is called when running in disconnected mode.
UnsupportedOperationException - this optional command is not supported by this implementation.

release

void release()
The release method is the mechanism by which the tool signals to the DeploymentManager that the tool does not need it to continue running connected to the platform. The tool may be signaling it wants to run in a disconnected mode or it is planning to shutdown. When release is called the DeploymentManager may close any J2EE resource connections it had for deployment configuration and perform other related resource cleanup. It should not accept any new operation requests (i.e., distribute, start stop, undeploy, redeploy. It should finish any operations that are currently in process. Each ProgressObject associated with a running operation should be marked as released (see the ProgressObject).

getDefaultLocale

Locale getDefaultLocale()
Returns the default locale supported by this implementation of javax.enterprise.deploy.spi subpackages.

Returns:
Locale the default locale for this implementation.

getCurrentLocale

Locale getCurrentLocale()
Returns the active locale this implementation of javax.enterprise.deploy.spi subpackages is running.

Returns:
Locale the active locale of this implementation.

setLocale

void setLocale(Locale locale)
               throws UnsupportedOperationException
Set the active locale for this implementation of javax.enterprise.deploy.spi subpackages to run.

Throws:
UnsupportedOperationException - the provide locale is not supported.

getSupportedLocales

Locale[] getSupportedLocales()
Returns an array of supported locales for this implementation.

Returns:
Locale[] the list of supported locales.

isLocaleSupported

boolean isLocaleSupported(Locale locale)
Reports if this implementation supports the designated locale.

Returns:
A value of 'true' means it is support and 'false' it is not.

getDConfigBeanVersion

DConfigBeanVersionType getDConfigBeanVersion()
Returns the J2EE platform version number for which the configuration beans are provided. The beans must have been compiled with the J2SE version required by the J2EE platform.

Returns:
a DConfigBeanVersionType object representing the platform version number for which these beans are provided.

isDConfigBeanVersionSupported

boolean isDConfigBeanVersionSupported(DConfigBeanVersionType version)
Returns 'true' if the configuration beans support the J2EE platform version specified. It returns 'false' if the version is not supported.

Parameters:
version - a DConfigBeanVersionType object representing the J2EE platform version for which support is requested.
Returns:
'true' if the version is supported and 'false if not.

setDConfigBeanVersion

void setDConfigBeanVersion(DConfigBeanVersionType version)
                           throws DConfigBeanVersionUnsupportedException
Set the configuration beans to be used to the J2EE platform version specificed.

Parameters:
version - a DConfigBeanVersionType object representing the J2EE platform version for which support is requested.
Throws:
DConfigBeanVersionUnsupportedException - when the requested bean version is not supported.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


exceptions

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.spi.exceptions

Provides J2EE Product Vendor deployment exception implementation classes.

See:
Description

Exception Summary
BeanNotFoundException | This exception is to report that the bean is not a child of the parent bean.
ClientExecuteException | This exception reports errors in setting up an application client for execution.
ConfigurationException | This exception reports errors in generating a configuration bean.
DConfigBeanVersionUnsupportedException | This exception is to report that there is no support for the DConfigBean version requested.
DeploymentManagerCreationException | This exception is to report problems in returning a DeploymentManager object cause by such things as server down, unable to authenticate and the like.
InvalidModuleException | This exception is to report an invalid J2EE deployment module type.
OperationUnsupportedException | This exception is to report that the method called is not supported by this implementation.
TargetException | This exception is to report bad target designators.

Package javax.enterprise.deploy.spi.exceptions Description

Provides J2EE Product Vendor deployment exception implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.spi.exceptions Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.spi.exceptions

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.enterprise.deploy.spi.exceptions.BeanNotFoundException
        • javax.enterprise.deploy.spi.exceptions.ClientExecuteException
        • javax.enterprise.deploy.spi.exceptions.ConfigurationException
        • javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException
        • javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException
        • javax.enterprise.deploy.spi.exceptions.InvalidModuleException
        • javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException
        • javax.enterprise.deploy.spi.exceptions.TargetException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BeanNotFoundException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class BeanNotFoundException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.enterprise.deploy.spi.exceptions.BeanNotFoundException
All Implemented Interfaces:
Serializable
public class BeanNotFoundException
extends Exception

This exception is to report that the bean is not a child of the parent bean.

See Also:
Serialized Form

Constructor Summary
BeanNotFoundException(String s)
Creates an new BeanNotFoundException object.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BeanNotFoundException

public BeanNotFoundException(String s)
Creates an new BeanNotFoundException object.

Parameters:
s - a string indicating what was wrong with the target.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ClientExecuteException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class ClientExecuteException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.enterprise.deploy.spi.exceptions.ClientExecuteException
All Implemented Interfaces:
Serializable
public class ClientExecuteException
extends Exception

This exception reports errors in setting up an application client for execution.

Author:
gfink
See Also:
Serialized Form

Constructor Summary
ClientExecuteException()
Creates new ClientExecuteException without detail message.
ClientExecuteException(String msg)
Constructs an ClientExecuteException with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ClientExecuteException

public ClientExecuteException()
Creates new ClientExecuteException without detail message.

ClientExecuteException

public ClientExecuteException(String msg)
Constructs an ClientExecuteException with the specified detail message.

Parameters:
msg - the detail message.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConfigurationException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class ConfigurationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.enterprise.deploy.spi.exceptions.ConfigurationException
All Implemented Interfaces:
Serializable
public class ConfigurationException
extends Exception

This exception reports errors in generating a configuration bean.

Author:
gfink
See Also:
Serialized Form

Constructor Summary
ConfigurationException()
Creates new ConfigurationException without detail message.
ConfigurationException(String msg)
Constructs an ConfigurationException with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ConfigurationException

public ConfigurationException()
Creates new ConfigurationException without detail message.

ConfigurationException

public ConfigurationException(String msg)
Constructs an ConfigurationException with the specified detail message.

Parameters:
msg - the detail message.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DConfigBeanVersionUnsupportedException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class DConfigBeanVersionUnsupportedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.enterprise.deploy.spi.exceptions.DConfigBeanVersionUnsupportedException
All Implemented Interfaces:
Serializable
public class DConfigBeanVersionUnsupportedException
extends Exception

This exception is to report that there is no support for the DConfigBean version requested.

See Also:
Serialized Form

Constructor Summary
DConfigBeanVersionUnsupportedException(String s)
Creates an new DConfigBeanVersionUnsupportedException object.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DConfigBeanVersionUnsupportedException

public DConfigBeanVersionUnsupportedException(String s)
Creates an new DConfigBeanVersionUnsupportedException object.

Parameters:
s - a string indicating what was wrong with the version request.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DeploymentManagerCreationException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class DeploymentManagerCreationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.enterprise.deploy.spi.exceptions.DeploymentManagerCreationException
All Implemented Interfaces:
Serializable
public class DeploymentManagerCreationException
extends Exception

This exception is to report problems in returning a DeploymentManager object cause by such things as server down, unable to authenticate and the like.

See Also:
Serialized Form

Constructor Summary
DeploymentManagerCreationException(String s)
Creates an new DeploymentManagerCreationException object.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DeploymentManagerCreationException

public DeploymentManagerCreationException(String s)
Creates an new DeploymentManagerCreationException object.

Parameters:
s - a string providing more information about the problem.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InvalidModuleException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class InvalidModuleException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.enterprise.deploy.spi.exceptions.InvalidModuleException
All Implemented Interfaces:
Serializable
public class InvalidModuleException
extends Exception

This exception is to report an invalid J2EE deployment module type.

See Also:
Serialized Form

Constructor Summary
InvalidModuleException(String s)
Creates an new InvalidModuleException object.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidModuleException

public InvalidModuleException(String s)
Creates an new InvalidModuleException object.

Parameters:
s - a string indicating what was wrong with the module type.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


OperationUnsupportedException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class OperationUnsupportedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.enterprise.deploy.spi.exceptions.OperationUnsupportedException
All Implemented Interfaces:
Serializable
public class OperationUnsupportedException
extends Exception

This exception is to report that the method called is not supported by this implementation.

See Also:
Serialized Form

Constructor Summary
OperationUnsupportedException(String s)
Creates an new OperationUnsupportedException object.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OperationUnsupportedException

public OperationUnsupportedException(String s)
Creates an new OperationUnsupportedException object.

Parameters:
s - a string indicating what was wrong with the target.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TargetException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.exceptions
Class TargetException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.enterprise.deploy.spi.exceptions.TargetException
All Implemented Interfaces:
Serializable
public class TargetException
extends Exception

This exception is to report bad target designators.

See Also:
Serialized Form

Constructor Summary
TargetException(String s)
Creates an new TargetException object.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TargetException

public TargetException(String s)
Creates an new TargetException object.

Parameters:
s - a string indicating what was wrong with the target.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


factories

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.spi.factories

Provides J2EE Product Vendor deployment factory implementation classes.

See:
Description

Interface Summary
DeploymentFactory The DeploymentFactory interface is a deployment driver for a J2EE plaform product.

Package javax.enterprise.deploy.spi.factories Description

Provides J2EE Product Vendor deployment factory implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.spi.factories Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.spi.factories

Package Hierarchies:
All Packages

Interface Hierarchy

  • javax.enterprise.deploy.spi.factories.DeploymentFactory
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DeploymentFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.factories
Interface DeploymentFactory

public interface DeploymentFactory

The DeploymentFactory interface is a deployment driver for a J2EE plaform product. It returns a DeploymentManager object which represents a connection to a specific J2EE platform product.

Each application server vendor must provide an implementation of this class in order for the J2EE Deployment API to work with their product.

The class implementing this interface should have a public no-argument constructor, and it should be stateless (two instances of the class should always behave the same). It is suggested but not required that the class have a static initializer that registers an instance of the class with the DeploymentFactoryManager class.

A connected or disconnected DeploymentManager can be requested. A DeploymentManager that runs connected to the platform can provide access to J2EE resources. A DeploymentManager that runs disconnected only provides module deployment configuration support.

See Also:
DeploymentFactoryManager

Method Summary
DeploymentManager | getDeploymentManager(String uri, String username, String password) Return a connected DeploymentManager instance.
DeploymentManager | getDisconnectedDeploymentManager(String uri) Return a disconnected DeploymentManager instance.
String | getDisplayName() Provide a string with the name of this vendor's DeploymentManager.
String | getProductVersion() Provide a string identifying version of this vendor's DeploymentManager.
boolean | handlesURI(String uri) Tests whether this factory can create a DeploymentManager object based on the specificed URI.

Method Detail

handlesURI

boolean handlesURI(String uri)
Tests whether this factory can create a DeploymentManager object based on the specificed URI. This does not indicate whether such an attempt will be successful, only whether the factory can handle the uri.

Parameters:
uri - The uri to check
Returns:
true if the factory can handle the uri.

getDeploymentManager

DeploymentManager getDeploymentManager(String uri,
                                       String username,
                                       String password)
                                       throws DeploymentManagerCreationException
Return a connected DeploymentManager instance.

Parameters:
uri - The URI that specifies the connection parameters
username - An optional username (may be null if no authentication is required for this platform).
password - An optional password (may be null if no authentication is required for this platform).
Returns:
A ready DeploymentManager instance.
Throws:
DeploymentManagerCreationException - occurs when a DeploymentManager could not be returned (server down, unable to authenticate, etc).

getDisconnectedDeploymentManager

DeploymentManager getDisconnectedDeploymentManager(String uri)
                                                   throws DeploymentManagerCreationException
Return a disconnected DeploymentManager instance.

Parameters:
uri - the uri of the DeploymentManager to return.
Returns:
A DeploymentManager disconnected instance.
Throws:
DeploymentManagerCreationException - occurs if the DeploymentManager could not be created.

getDisplayName

String getDisplayName()
Provide a string with the name of this vendor's DeploymentManager.

Returns:
the name of the vendor's DeploymentManager.

getProductVersion

String getProductVersion()
Provide a string identifying version of this vendor's DeploymentManager.

Returns:
the name of the vendor's DeploymentManager.
Overview  Package   Class  Tree  Deprecated  Index  Help
Java EE 5 SDK
 PREV CLASS   NEXT CLASS | FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


status

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.enterprise.deploy.spi.status

Provides J2EE Product Vendor deployment status implementation classes.

See:
Description

Interface Summary
ClientConfiguration | The ClientConfiguration object installs, configures and executes an Application Client.
DeploymentStatus | The DeploymentStatus interface provides information about the progress status of a deployment action.
ProgressListener | The listener interface for receiving deployment progress events.
ProgressObject | The ProgressObject interface tracks and reports the progress of the deployment activities, distribute, start, stop, undeploy.

Class Summary
ProgressEvent An event which indicates that a deployment status change has occurred.

Package javax.enterprise.deploy.spi.status Description

Provides J2EE Product Vendor deployment status implementation classes.

Package Specification

  • JSR 88, J2EE Application Deployment

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.enterprise.deploy.spi.status Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.enterprise.deploy.spi.status

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.enterprise.deploy.spi.status.ProgressEvent

Interface Hierarchy

  • javax.enterprise.deploy.spi.status.DeploymentStatus
  • java.util.EventListener
    • javax.enterprise.deploy.spi.status.ProgressListener
  • javax.enterprise.deploy.spi.status.ProgressObject
  • java.io.Serializable
    • javax.enterprise.deploy.spi.status.ClientConfiguration
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ClientConfiguration

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.status
Interface ClientConfiguration

All Superinterfaces:
Serializable
public interface ClientConfiguration
extends Serializable

The ClientConfiguration object installs, configures and executes an Application Client. This class resolves the settings for installing and running the application client.

Method Summary
 void execute()
This method performs an exec and starts the application client running in another process.

Method Detail

execute

void execute()
             throws ClientExecuteException
This method performs an exec and starts the application client running in another process.

Throws:
ClientExecuteException - when the configuration is incomplete.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DeploymentStatus

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.status
Interface DeploymentStatus

public interface DeploymentStatus

The DeploymentStatus interface provides information about the progress status of a deployment action.

Method Summary
ActionType | getAction() Retrieve the deployment ActionType for this event.
CommandType | getCommand() Retrieve the deployment CommandType of this event.
String | getMessage() Retrieve any additional information about the status of this event.
StateType | getState() Retrieve the StateType value.
boolean | isCompleted() A convience method to report if the operation is in the completed state.
boolean | isFailed() A convience method to report if the operation is in the failed state.
boolean | isRunning() A convience method to report if the operation is in the running state.

Method Detail

getState

StateType getState()
Retrieve the StateType value.

Returns:
the StateType object

getCommand

CommandType getCommand()
Retrieve the deployment CommandType of this event.

Returns:
the CommandType Object

getAction

ActionType getAction()
Retrieve the deployment ActionType for this event.

Returns:
the ActionType Object

getMessage

String getMessage()
Retrieve any additional information about the status of this event.

Returns:
message text

isCompleted

boolean isCompleted()
A convience method to report if the operation is in the completed state.

Returns:
true if this command has completed successfully

isFailed

boolean isFailed()
A convience method to report if the operation is in the failed state.

Returns:
true if this command has failed

isRunning

boolean isRunning()
A convience method to report if the operation is in the running state.

Returns:
true if this command is still running
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ProgressEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.status
Class ProgressEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.enterprise.deploy.spi.status.ProgressEvent
All Implemented Interfaces:
Serializable
public class ProgressEvent
extends EventObject

An event which indicates that a deployment status change has occurred.

See Also:
ProgressListener, ProgressObject, Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
ProgressEvent(Object source, TargetModuleID targetModuleID, DeploymentStatus sCode)
Creates a new object representing a deployment progress event.
Method Summary
DeploymentStatus | getDeploymentStatus() Retrieve the status information.
TargetModuleID | getTargetModuleID() Retrieve the TargetModuleID for this event
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ProgressEvent

public ProgressEvent(Object source,
                     TargetModuleID targetModuleID,
                     DeploymentStatus sCode)
Creates a new object representing a deployment progress event.

Parameters:
source - the object on which the Event initially occurred.
sCode - the object containing the status information.
Method Detail

getTargetModuleID

public TargetModuleID getTargetModuleID()
Retrieve the TargetModuleID for this event

Returns:
the object containing the TargetModuleID

getDeploymentStatus

public DeploymentStatus getDeploymentStatus()
Retrieve the status information.

Returns:
the object containing the status information.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ProgressListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.status
Interface ProgressListener

All Superinterfaces:
EventListener
public interface ProgressListener
extends EventListener

The listener interface for receiving deployment progress events.

Method Summary
 void handleProgressEvent(ProgressEvent event)
Invoked when a deployment progress event occurs.

Method Detail

handleProgressEvent

void handleProgressEvent(ProgressEvent event)
Invoked when a deployment progress event occurs.

Parameters:
event - the progress status event.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ProgressObject

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi.status
Interface ProgressObject

public interface ProgressObject

The ProgressObject interface tracks and reports the progress of the deployment activities, distribute, start, stop, undeploy.

This class has an optional cancel method. The support of the cancel function can be tested by the isCancelSupported method.

The ProgressObject structure allows the user the option of polling for status or to provide a callback.

Method Summary
void | addProgressListener(ProgressListener pol) Add a listener to receive Progress events on deployment actions.
void | cancel() (optional) A cancel request on an in-process operation stops all further processing of the operation and returns the environment to it original state before the operation was executed.
ClientConfiguration | getClientConfiguration(TargetModuleID id) Return the ClientConfiguration object associated with the TargetModuleID.
DeploymentStatus | getDeploymentStatus() Retrieve the status of this activity.
TargetModuleID[] | getResultTargetModuleIDs() Retrieve the list of TargetModuleIDs successfully processed or created by the associated DeploymentManager operation.
boolean | isCancelSupported() Tests whether the vendor supports a cancel opertation for deployment activities.
boolean | isStopSupported() Tests whether the vendor supports a stop opertation for deployment activities.
void | removeProgressListener(ProgressListener pol) Remove a ProgressObject listener.
void | stop() (optional) A stop request on an in-process operation allows the operation on the current TargetModuleID to run to completion but does not process any of the remaining unprocessed TargetModuleID objects.

Method Detail

getDeploymentStatus

DeploymentStatus getDeploymentStatus()
Retrieve the status of this activity.

Returns:
An object containing the status information.

getResultTargetModuleIDs

TargetModuleID[] getResultTargetModuleIDs()
Retrieve the list of TargetModuleIDs successfully processed or created by the associated DeploymentManager operation.

Returns:
a list of TargetModuleIDs.

getClientConfiguration

ClientConfiguration getClientConfiguration(TargetModuleID id)
Return the ClientConfiguration object associated with the TargetModuleID.

Returns:
ClientConfiguration for a given TargetModuleID or null if none exists.

isCancelSupported

boolean isCancelSupported()
Tests whether the vendor supports a cancel opertation for deployment activities.

Returns:
true if canceling an activity is supported by this platform.

cancel

void cancel()
            throws OperationUnsupportedException
(optional) A cancel request on an in-process operation stops all further processing of the operation and returns the environment to it original state before the operation was executed. An operation that has run to completion cannot be cancelled.

Throws:
OperationUnsupportedException - this optional command is not supported by this implementation.

isStopSupported

boolean isStopSupported()
Tests whether the vendor supports a stop opertation for deployment activities.

Returns:
true if canceling an activity is supported by this platform.

stop

void stop()
          throws OperationUnsupportedException
(optional) A stop request on an in-process operation allows the operation on the current TargetModuleID to run to completion but does not process any of the remaining unprocessed TargetModuleID objects. The processed TargetModuleIDs must be returned by the method getResultTargetModuleIDs.

Throws:
OperationUnsupportedException - this optional command is not supported by this implementation.

addProgressListener

void addProgressListener(ProgressListener pol)
Add a listener to receive Progress events on deployment actions.

Parameters:
pol - the listener to receive events
See Also:
ProgressEvent

removeProgressListener

void removeProgressListener(ProgressListener pol)
Remove a ProgressObject listener.

Parameters:
pol - the listener being removed
See Also:
ProgressEvent
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Target

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi
Interface Target

public interface Target

A Target interface represents a single logical core server of one instance of a J2EE platform product. It is a designator for a server and the implied location to copy a configured application for the server to access.

Method Summary
String | getDescription() Retrieve other descriptive information about the target.
String | getName() Retrieve the name of the target server.

Method Detail

getName

String getName()
Retrieve the name of the target server.

getDescription

String getDescription()
Retrieve other descriptive information about the target.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TargetModuleID

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.enterprise.deploy.spi
Interface TargetModuleID

public interface TargetModuleID

A TargetModuleID interface represents a unique identifier for a deployed application module. A deployable application module can be an EAR, JAR, WAR or RAR file. A TargetModuleID can represent a root module or a child module. A root module TargetModuleID has no parent. It represents a deployed EAR file or stand alone module. A child module TargetModuleID represents a deployed sub module of a J2EE application. A child TargetModuleID has only one parent, the super module it was bundled and deployed with. The identifier consists of the target name and the unique identifier for the deployed application module.

Method Summary
TargetModuleID[] | getChildTargetModuleID() Retrieve a list of identifiers of the children of this deployed module.
String | getModuleID() Retrieve the id assigned to represent the deployed module.
TargetModuleID | getParentTargetModuleID() Retrieve the identifier of the parent object of this deployed module.
Target | getTarget() Retrieve the name of the target server.
String | getWebURL() If this TargetModulID represents a web module retrieve the URL for it.
String | toString() Retrieve the identifier representing the deployed module.

Method Detail

getTarget

Target getTarget()
Retrieve the name of the target server. this module was deployed to.

Returns:
Target an object representing a server target.

getModuleID

String getModuleID()
Retrieve the id assigned to represent the deployed module.

getWebURL

String getWebURL()
If this TargetModulID represents a web module retrieve the URL for it.

Returns:
the URL of a web module or null if the module is not a web module.

toString

String toString()
Retrieve the identifier representing the deployed module.

Overrides:
toString in class Object

getParentTargetModuleID

TargetModuleID getParentTargetModuleID()
Retrieve the identifier of the parent object of this deployed module. If there is no parent then this is the root object deployed. The root could represent an EAR file or it could be a stand alone module that was deployed.

Returns:
the TargetModuleID of the parent of this object. A null value means this module is the root object deployed.

getChildTargetModuleID

TargetModuleID[] getChildTargetModuleID()
Retrieve a list of identifiers of the children of this deployed module.

Returns:
a list of TargetModuleIDs identifying the childern of this object. A null value means this module has no childern
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


faces

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.faces

Top level classes for the JavaServer(tm) Faces API.

See:
Description

Class Summary
FactoryFinder FactoryFinder implements the standard discovery algorithm for all factory objects specified in the JavaServer Faces APIs.

Exception Summary
FacesException This class encapsulates general JavaServer Faces exceptions.

Package javax.faces Description

Top level classes for the JavaServer(tm) Faces API. The most important class in the package is FactoryFinder, which is the mechanism by which users can override many of the key pieces of the implementation with their own.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.faces Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.faces

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.FactoryFinder
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


application

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.faces.application

APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces.

See:
Description

Class Summary
Application | Application represents a per-web-application singleton object where applications based on JavaServer Faces (or implementations wishing to provide extended functionality) can register application-wide singletons that provide functionality required by JavaServer Faces.
ApplicationFactory | ApplicationFactory is a factory object that creates (if needed) and returns Application instances.
FacesMessage | FacesMessage represents a single validation (or other) message, which is typically associated with a particular component in the view.
FacesMessage.Severity | Class used to represent message severity levels in a typesafe enumeration.
NavigationHandler | A NavigationHandler is passed the outcome string returned by an application action invoked for this application, and will use this (along with related state information) to choose the view to be displayed next.
StateManager | StateManager directs the process of saving and restoring the view between requests.
StateManagerWrapper | Provides a simple implementation of StateManager that can be subclassed by developers wishing to provide specialized behavior to an existing StateManager instance.
ViewHandler | ViewHandler is the pluggablity mechanism for allowing implementations of or applications using the JavaServer Faces specification to provide their own handling of the activities in the Render Response and Restore View phases of the request processing lifecycle.
ViewHandlerWrapper | Provides a simple implementation of ViewHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ViewHandler instance.

Exception Summary
ViewExpiredException Implementations must throw this FacesException when attempting to restore the view StateManager.restoreView(javax.faces.context.FacesContext, String, String) results in failure on postback.

Package javax.faces.application Description

APIs that are used to link an application's business logic objects to JavaServer Faces, as well as convenient pluggable mechanisms to manage the execution of an application that is based on JavaServer Faces. The main class in this package is Application.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.faces.application Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.faces.application

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.application.Application
    • javax.faces.application.ApplicationFactory
    • javax.faces.application.FacesMessage (implements java.io.Serializable)
    • javax.faces.application.FacesMessage.Severity (implements java.lang.Comparable<T>)
    • javax.faces.application.NavigationHandler
    • javax.faces.application.StateManager
      • javax.faces.application.StateManagerWrapper
    • javax.faces.application.StateManager.SerializedView
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.application.ViewExpiredException
    • javax.faces.application.ViewHandler
      • javax.faces.application.ViewHandlerWrapper
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Application

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.application
Class Application

java.lang.Object
    extended by  javax.faces.application.Application

public abstract class Application
extends Object

Application represents a per-web-application singleton object where applications based on JavaServer Faces (or implementations wishing to provide extended functionality) can register application-wide singletons that provide functionality required by JavaServer Faces. Default implementations of each object are provided for cases where the application does not choose to customize the behavior.

The instance of Application is created by calling the getApplication() method of ApplicationFactory. Because this instance is shared, it must be implemented in a thread-safe manner.

The application also acts as a factory for several types of Objects specified in the Faces Configuration file. Please see createComponent(java.lang.String), createConverter(java.lang.String), and createValidator(java.lang.String).

Constructor Summary
Application()
Method Summary
abstract  void addComponent(String componentType, String componentClass)
Register a new mapping of component type to the name of the corresponding UIComponent class.
abstract  void addConverter(Class targetClass, String converterClass)
Register a new converter class that is capable of performing conversions for the specified target class.
abstract  void addConverter(String converterId, String converterClass)
Register a new mapping of converter id to the name of the corresponding Converter class.
 void addELContextListener(ELContextListener listener)
Provide a way for Faces applications to register an ELContextListener that will be notified on creation of ELContext instances.
 void addELResolver(ELResolver resolver)
Cause an the argument resolver to be added to the resolver chain as specified in section 5.5.1 of the JavaServer Faces Specification.
abstract  void addValidator(String validatorId, String validatorClass)
Register a new mapping of validator id to the name of the corresponding Validator class.
abstract  UIComponent createComponent(String componentType)
Instantiate and return a new UIComponent instance of the class specified by a previous call to addComponent() for the specified component type.
abstract  UIComponent createComponent(ValueBinding componentBinding, FacesContext context, String componentType)
Deprecated. This has been replaced by createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).
 UIComponent createComponent(ValueExpression componentExpression, FacesContext context, String componentType)
Call the getValue() method on the specified ValueExpression.
abstract  Converter createConverter(Class targetClass)
Instantiate and return a new Converter instance of the class that has registered itself as capable of performing conversions for objects of the specified type.
abstract  Converter createConverter(String converterId)
Instantiate and return a new Converter instance of the class specified by a previous call to addConverter() for the specified converter id.
abstract  MethodBinding createMethodBinding(String ref, Class[] params)
Deprecated. This has been replaced by calling getExpressionFactory() then ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class, java.lang.Class[]).
abstract  Validator createValidator(String validatorId)
Instantiate and return a new Validator instance of the class specified by a previous call to addValidator() for the specified validator id.
abstract  ValueBinding createValueBinding(String ref)
Deprecated. This has been replaced by calling getExpressionFactory() then ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class).
 Object evaluateExpressionGet(FacesContext context, String expression, Class expectedType)
Get a value by evaluating an expression.
abstract  ActionListener getActionListener()
Return the default ActionListener to be registered for all ActionSource components in this appication.
abstract  Iterator<String> getComponentTypes()
Return an Iterator over the set of currently defined component types for this Application.
abstract  Iterator<String> getConverterIds()
Return an Iterator over the set of currently registered converter ids for this Application.
abstract  Iterator<Class> getConverterTypes()
Return an Iterator over the set of Class instances for which Converter classes have been explicitly registered.
abstract  Locale getDefaultLocale()
Return the default Locale for this application.
abstract  String getDefaultRenderKitId()
Return the renderKitId to be used for rendering this application.
 ELContextListener[] getELContextListeners()
If no calls have been made to addELContextListener(javax.el.ELContextListener), this method must return an empty array.
 ELResolver getELResolver()
Return the singleton ELResolver instance to be used for all EL resolution.
 ExpressionFactory getExpressionFactory()
Return the ExpressionFactory instance for this application.
abstract  String getMessageBundle()
Return the fully qualified class name of the ResourceBundle to be used for JavaServer Faces messages for this application.
abstract  NavigationHandler getNavigationHandler()
Return the NavigationHandler instance that will be passed the outcome returned by any invoked application action for this web application.
abstract  PropertyResolver getPropertyResolver()
Deprecated. This has been replaced by getELResolver().
 ResourceBundle getResourceBundle(FacesContext ctx, String name)
Find a ResourceBundle as defined in the application configuration resources under the specified name.
abstract  StateManager getStateManager()
Return the StateManager instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
abstract  Iterator<Locale> getSupportedLocales()
Return an Iterator over the supported Locales for this appication.
abstract  Iterator<String> getValidatorIds()
Return an Iterator over the set of currently registered validator ids for this Application.
abstract  VariableResolver getVariableResolver()
Deprecated. This has been replaced by getELResolver().
abstract  ViewHandler getViewHandler()
Return the ViewHandler instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
 void removeELContextListener(ELContextListener listener)
Remove the argument listener from the list of ELContextListeners.
abstract  void setActionListener(ActionListener listener)
Set the default ActionListener to be registered for all ActionSource components.
abstract  void setDefaultLocale(Locale locale)
Set the default Locale for this application.
abstract  void setDefaultRenderKitId(String renderKitId)
Set the renderKitId to be used to render this application.
abstract  void setMessageBundle(String bundle)
Set the fully qualified class name of the ResourceBundle to be used for JavaServer Faces messages for this application.
abstract  void setNavigationHandler(NavigationHandler handler)
Set the NavigationHandler instance that will be passed the outcome returned by any invoked application action for this web application.
abstract  void setPropertyResolver(PropertyResolver resolver)
Deprecated. The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called addELResolver(javax.el.ELResolver).
abstract  void setStateManager(StateManager manager)
Set the StateManager instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
abstract  void setSupportedLocales(Collection<Locale> locales)
Set the Locale instances representing the supported Locales for this application.
abstract  void setVariableResolver(VariableResolver resolver)
Deprecated. The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called addELResolver(javax.el.ELResolver).
abstract  void setViewHandler(ViewHandler handler)
Set the ViewHandler instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Application

public Application()
Method Detail

getActionListener

public abstract ActionListener getActionListener()

Return the default ActionListener to be registered for all ActionSource components in this appication. If not explicitly set, a default implementation must be provided that performs the following functions:

  • The processAction() method must first call FacesContext.renderResponse() in order to bypass any intervening lifecycle phases, once the method returns.
  • The processAction() method must next determine the logical outcome of this event, as follows:
    • If the originating component has a non-null action property, retrieve the MethodBinding from the property, and call invoke() on it. Convert the returned value (if any) to a String, and use it as the logical outcome.
    • Otherwise, the logical outcome is null.
  • The processAction() method must finally retrieve the NavigationHandler instance for this application and call NavigationHandler.handleNavigation(javax.faces.context.FacesContext, java.lang.String, java.lang.String) passing:
    • the FacesContext for the current request
    • If there is a MethodBinding instance for the action property of this component, the result of calling MethodBinding.getExpressionString() on it, null otherwise
    • the logical outcome as determined above

Note that the specification for the default ActionListener contiues to call for the use of a deprecated property (action) and class (MethodBinding). Unfortunately, this is necessary because the default ActionListener must continue to work with components that do not implement ActionSource2, and only implement ActionSource.

setActionListener

public abstract void setActionListener(ActionListener listener)

Set the default ActionListener to be registered for all ActionSource components.

Parameters:
listener - The new default ActionListener
Throws:
NullPointerException - if listener is null

getDefaultLocale

public abstract Locale getDefaultLocale()

Return the default Locale for this application. If not explicitly set, null is returned.

setDefaultLocale

public abstract void setDefaultLocale(Locale locale)

Set the default Locale for this application.

Parameters:
locale - The new default Locale
Throws:
NullPointerException - if locale is null

getDefaultRenderKitId

public abstract String getDefaultRenderKitId()

Return the renderKitId to be used for rendering this application. If not explicitly set, null is returned.

setDefaultRenderKitId

public abstract void setDefaultRenderKitId(String renderKitId)

Set the renderKitId to be used to render this application. Unless the client has provided a custom ViewHandler that supports the use of multiple RenderKit instances in the same application, this method must only be called at application startup, before any Faces requests have been processed. This is a limitation of the current Specification, and may be lifted in a future release.

getMessageBundle

public abstract String getMessageBundle()

Return the fully qualified class name of the ResourceBundle to be used for JavaServer Faces messages for this application. If not explicitly set, null is returned.

setMessageBundle

public abstract void setMessageBundle(String bundle)

Set the fully qualified class name of the ResourceBundle to be used for JavaServer Faces messages for this application. See the JavaDocs for the java.util.ResourceBundle class for more information about the syntax for resource bundle names.

Parameters:
bundle - Base name of the resource bundle to be used
Throws:
NullPointerException - if bundle is null

getNavigationHandler

public abstract NavigationHandler getNavigationHandler()

Return the NavigationHandler instance that will be passed the outcome returned by any invoked application action for this web application. If not explicitly set, a default implementation must be provided that performs the functions described in the NavigationHandler class description.

setNavigationHandler

public abstract void setNavigationHandler(NavigationHandler handler)

Set the NavigationHandler instance that will be passed the outcome returned by any invoked application action for this web application.

Parameters:
handler - The new NavigationHandler instance
Throws:
NullPointerException - if handler is null

getPropertyResolver

public abstract PropertyResolver getPropertyResolver()
Deprecated. This has been replaced by getELResolver().

Return a PropertyResolver instance that wraps the ELResolver instance that Faces provides to the unified EL for the resolution of expressions that appear programmatically in an application.

Note that this no longer returns the default PropertyResolver since that class is now a no-op that aids in allowing custom PropertyResolvers to affect the EL resolution process.

setPropertyResolver

public abstract void setPropertyResolver(PropertyResolver resolver)
Deprecated. The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called addELResolver(javax.el.ELResolver).

Set the PropertyResolver instance that will be utilized to resolve method and value bindings.

This method is now deprecated but the implementation must cause the argument to be set as the head of the legacy PropertyResolver chain, replacing any existing value that was set from the application configuration resources.

It is illegal to call this method after the application has received any requests from the client. If an attempt is made to register a listener after that time it must have no effect.

Parameters:
resolver - The new PropertyResolver instance
Throws:
NullPointerException - if resolver is null
IllegalStateException - if called after the first request to the FacesServlet has been serviced.

getResourceBundle

public ResourceBundle getResourceBundle(FacesContext ctx,
                                        String name)

Find a ResourceBundle as defined in the application configuration resources under the specified name. If a ResourceBundle was defined for the name, return an instance that uses the locale of the current UIViewRoot.

The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

Returns:
ResourceBundle for the current UIViewRoot, otherwise null
Throws:
FacesException - if a bundle was defined, but not resolvable
NullPointerException - if ctx == null || name == null
Since:
1.2

getVariableResolver

public abstract VariableResolver getVariableResolver()
Deprecated. This has been replaced by getELResolver().

Return the VariableResolver that wraps the ELResolver instance that Faces provides to the unified EL for the resolution of expressions that appear programmatically in an application. The implementation of the VariableResolvermust pass null as the base argument for any methods invoked on the underlying ELResolver.

Note that this method no longer returns the default VariableResolver, since that class now is a no-op that aids in allowing custom VariableResolvers to affect the EL resolution process.

setVariableResolver

public abstract void setVariableResolver(VariableResolver resolver)
Deprecated. The recommended way to affect the execution of the EL is to provide an <el-resolver> element at the right place in the application configuration resources which will be considered in the normal course of expression evaluation. This method now will cause the argument resolver to be wrapped inside an implementation of ELResolver and exposed to the EL resolution system as if the user had called addELResolver(javax.el.ELResolver).

Set the VariableResolver instance that will be consulted to resolve method and value bindings.

This method is now deprecated but the implementation must cause the argument to be set as the head of the legacy VariableResolver chain, replacing any existing value that was set from the application configuration resources.

It is illegal to call this method after the application has received any requests from the client. If an attempt is made to register a listener after that time it must have no effect.

Parameters:
resolver - The new VariableResolver instance
Throws:
NullPointerException - if resolver is null
IllegalStateException - if called after the first request to the FacesServlet has been serviced.

addELResolver

public void addELResolver(ELResolver resolver)

Cause an the argument resolver to be added to the resolver chain as specified in section 5.5.1 of the JavaServer Faces Specification.

It is not possible to remove an ELResolver registered with this method, once it has been registered.

It is illegal to register an ELResolver after the application has received any requests from the client. If an attempt is made to register a listener after that time, an IllegalStateException must be thrown. This restriction is in place to allow the JSP container to optimize for the common case where no additional ELResolvers are in the chain, aside from the standard ones. It is permissible to add ELResolvers before or after initialization to a CompositeELResolver that is already in the chain.

The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend Application.

Since:
1.2

getELResolver

public ELResolver getELResolver()

Return the singleton ELResolver instance to be used for all EL resolution. This is actually an instance of CompositeELResolver that must contain the following ELResolver instances in the following order:

  1. ELResolver instances declared using the <el-resolver> element in the application configuration resources.

  2. An implementation that wraps the head of the legacy VariableResolver chain, as per section VariableResolver ChainWrapper in Chapter 5 in the spec document.

  3. An implementation that wraps the head of the legacy PropertyResolver chain, as per section PropertyResolver ChainWrapper in Chapter 5 in the spec document.

  4. Any ELResolver instances added by calls to addELResolver(javax.el.ELResolver).

The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend Application.

Since:
1.2

getViewHandler

public abstract ViewHandler getViewHandler()

Return the ViewHandler instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle. If not explicitly set, a default implementation must be provided that performs the functions described in the ViewHandler description in the JavaServer Faces Specification.

setViewHandler

public abstract void setViewHandler(ViewHandler handler)

Set the ViewHandler instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.

Parameters:
handler - The new ViewHandler instance
Throws:
IllegalStateException - if this method is called after at least one request has been processed by the Lifecycle instance for this application.
NullPointerException - if handler is null

getStateManager

public abstract StateManager getStateManager()

Return the StateManager instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle. If not explicitly set, a default implementation must be provided that performs the functions described in the StateManager description in the JavaServer Faces Specification.

setStateManager

public abstract void setStateManager(StateManager manager)

Set the StateManager instance that will be utilized during the Restore View and Render Response phases of the request processing lifecycle.

Parameters:
manager - The new StateManager instance
Throws:
IllegalStateException - if this method is called after at least one request has been processed by the Lifecycle instance for this application.
NullPointerException - if manager is null

addComponent

public abstract void addComponent(String componentType,
                                  String componentClass)

Register a new mapping of component type to the name of the corresponding UIComponent class. This allows subsequent calls to createComponent() to serve as a factory for UIComponent instances.

Parameters:
componentType - The component type to be registered
componentClass - The fully qualified class name of the corresponding UIComponent implementation
Throws:
NullPointerException - if componentType or componentClass is null

createComponent

public abstract UIComponent createComponent(String componentType)
                                     throws FacesException

Instantiate and return a new UIComponent instance of the class specified by a previous call to addComponent() for the specified component type.

Parameters:
componentType - The component type for which to create and return a new UIComponent instance
Throws:
FacesException - if a UIComponent of the specified type cannot be created
NullPointerException - if componentType is null

createComponent

public abstract UIComponent createComponent(ValueBinding componentBinding,
                                            FacesContext context,
                                            String componentType)
                                     throws FacesException
Deprecated. This has been replaced by createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).

Wrap the argument componentBinding in an implementation of ValueExpression and call through to createComponent(javax.el.ValueExpression,javax.faces.context.FacesContext,java.lang.String).

Parameters:
componentBinding - ValueBinding representing a component value binding expression (typically specified by the component attribute of a custom tag)
context - FacesContext for the current request
componentType - Component type to create if the ValueBinding does not return a component instance
Throws:
FacesException - if a UIComponent cannot be created
NullPointerException - if any parameter is null

createComponent

public UIComponent createComponent(ValueExpression componentExpression,
                                   FacesContext context,
                                   String componentType)
                            throws FacesException

Call the getValue() method on the specified ValueExpression. If it returns a UIComponent instance, return it as the value of this method. If it does not, instantiate a new UIComponent instance of the specified component type, pass the new component to the setValue() method of the specified ValueExpression, and return it.

Parameters:
componentExpression - ValueExpression representing a component value expression (typically specified by the component attribute of a custom tag)
context - FacesContext for the current request
componentType - Component type to create if the ValueExpression does not return a component instance
Throws:
FacesException - if a UIComponent cannot be created
NullPointerException - if any parameter is null

A default implementation is provided that throws UnsupportedOperationException so that users that decorate Application can continue to function

.
Since:
1.2

getComponentTypes

public abstract Iterator<String> getComponentTypes()

Return an Iterator over the set of currently defined component types for this Application.

addConverter

public abstract void addConverter(String converterId,
                                  String converterClass)

Register a new mapping of converter id to the name of the corresponding Converter class. This allows subsequent calls to createConverter() to serve as a factory for Converter instances.

Parameters:
converterId - The converter id to be registered
converterClass - The fully qualified class name of the corresponding Converter implementation
Throws:
NullPointerException - if converterId or converterClass is null

addConverter

public abstract void addConverter(Class targetClass,
                                  String converterClass)

Register a new converter class that is capable of performing conversions for the specified target class.

Parameters:
targetClass - The class for which this converter is registered
converterClass - The fully qualified class name of the corresponding Converter implementation
Throws:
NullPointerException - if targetClass or converterClass is null

createConverter

public abstract Converter createConverter(String converterId)

Instantiate and return a new Converter instance of the class specified by a previous call to addConverter() for the specified converter id. If there is no such registration for this converter id, return null.

Parameters:
converterId - The converter id for which to create and return a new Converter instance
Throws:
FacesException - if the Converter cannot be created
NullPointerException - if converterId is null

createConverter

public abstract Converter createConverter(Class targetClass)

Instantiate and return a new Converter instance of the class that has registered itself as capable of performing conversions for objects of the specified type. If no such Converter class can be identified, return null.

To locate an appropriate Converter class, the following algorithm is performed, stopping as soon as an appropriate Converter class is found:

  • Locate a Converter registered for the target class itself.
  • Locate a Converter registered for interfaces that are implemented by the target class (directly or indirectly).
  • Locate a Converter registered for the superclass (if any) of the target class, recursively working up the inheritance hierarchy.

If the Converter has a single argument constructor that accepts a Class, instantiate the Converter using that constructor, passing the argument targetClass as the sole argument. Otherwise, simply use the zero-argument constructor.

Parameters:
targetClass - Target class for which to return a Converter
Throws:
FacesException - if the Converter cannot be created
NullPointerException - if targetClass is null

getConverterIds

public abstract Iterator<String> getConverterIds()

Return an Iterator over the set of currently registered converter ids for this Application.

getConverterTypes

public abstract Iterator<Class> getConverterTypes()

Return an Iterator over the set of Class instances for which Converter classes have been explicitly registered.

getExpressionFactory

public ExpressionFactory getExpressionFactory()

Return the ExpressionFactory instance for this application. This instance is used by the convenience method evaluateExpressionGet(javax.faces.context.FacesContext, java.lang.String, java.lang.Class).

The implementation must return the ExpressionFactory from the JSP container by calling JspFactory.getDefaultFactory().getJspApplicationContext(servletContext).getExpressionFactory().

An implementation is provided that throws UnsupportedOperationException so that users that decorate the Application continue to work.

Since:
1.2

evaluateExpressionGet

public Object evaluateExpressionGet(FacesContext context,
                                    String expression,
                                    Class expectedType)
                             throws ELException

Get a value by evaluating an expression.

Call getExpressionFactory() then call ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class) passing the argument expression and expectedType. Call FacesContext.getELContext() and pass it to ValueExpression.getValue(javax.el.ELContext), returning the result.

An implementation is provided that throws UnsupportedOperationException so that users that decorate the Application continue to work.

Throws:
ELException

createMethodBinding

public abstract MethodBinding createMethodBinding(String ref,
                                                  Class[] params)
                                           throws ReferenceSyntaxException
Deprecated. This has been replaced by calling getExpressionFactory() then ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class, java.lang.Class[]).

Call getExpressionFactory() then call ExpressionFactory.createMethodExpression(javax.el.ELContext, java.lang.String, java.lang.Class, java.lang.Class[]), passing the given arguments, and wrap the result in a MethodBinding implementation, returning it.

Parameters:
ref - Method binding expression for which to return a MethodBinding instance
params - Parameter signatures that must be compatible with those of the method to be invoked, or a zero-length array or null for a method that takes no parameters
Throws:
NullPointerException - if ref is null
ReferenceSyntaxException - if the specified ref has invalid syntax

getSupportedLocales

public abstract Iterator<Locale> getSupportedLocales()

Return an Iterator over the supported Locales for this appication.

setSupportedLocales

public abstract void setSupportedLocales(Collection<Locale> locales)

Set the Locale instances representing the supported Locales for this application.

Parameters:
locales - The set of supported Locales for this application
Throws:
NullPointerException - if the argument newLocales is null.

addELContextListener

public void addELContextListener(ELContextListener listener)

Provide a way for Faces applications to register an ELContextListener that will be notified on creation of ELContext instances. This listener will be called once per request.

An implementation is provided that throws UnsupportedOperationException so that users that decorate the Application continue to work.

Since:
1.2

removeELContextListener

public void removeELContextListener(ELContextListener listener)

Remove the argument listener from the list of ELContextListeners. If listener is null, no exception is thrown and no action is performed. If listener is not in the list, no exception is thrown and no action is performed.

An implementation is provided that throws UnsupportedOperationException so that users that decorate the Application continue to work.

Since:
1.2

getELContextListeners

public ELContextListener[] getELContextListeners()

If no calls have been made to addELContextListener(javax.el.ELContextListener), this method must return an empty array.

Otherwise, return an array representing the list of listeners added by calls to addELContextListener(javax.el.ELContextListener).

An implementation is provided that throws UnsupportedOperationException so that users that decorate the Application continue to work.

Since:
1.2

addValidator

public abstract void addValidator(String validatorId,
                                  String validatorClass)

Register a new mapping of validator id to the name of the corresponding Validator class. This allows subsequent calls to createValidator() to serve as a factory for Validator instances.

Parameters:
validatorId - The validator id to be registered
validatorClass - The fully qualified class name of the corresponding Validator implementation
Throws:
NullPointerException - if validatorId or validatorClass is null

createValidator

public abstract Validator createValidator(String validatorId)
                                   throws FacesException

Instantiate and return a new Validator instance of the class specified by a previous call to addValidator() for the specified validator id.

Parameters:
validatorId - The validator id for which to create and return a new Validator instance
Throws:
FacesException - if a Validator of the specified id cannot be created
NullPointerException - if validatorId is null

getValidatorIds

public abstract Iterator<String> getValidatorIds()

Return an Iterator over the set of currently registered validator ids for this Application.

createValueBinding

public abstract ValueBinding createValueBinding(String ref)
                                         throws ReferenceSyntaxException
Deprecated. This has been replaced by calling getExpressionFactory() then ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class).

Call getExpressionFactory() then call ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class), passing the argument ref, Object.class for the expectedType, and null, for the fnMapper.

Parameters:
ref - Value binding expression for which to return a ValueBinding instance
Throws:
NullPointerException - if ref is null
ReferenceSyntaxException - if the specified ref has invalid syntax
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ApplicationFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.application
Class ApplicationFactory

java.lang.Object
    extended by  javax.faces.application.ApplicationFactory

public abstract class ApplicationFactory
extends Object

ApplicationFactory is a factory object that creates (if needed) and returns Application instances. Implementations of JavaServer Faces must provide at least a default implementation of Application.

There must be one ApplicationFactory instance per web application that is utilizing JavaServer Faces. This instance can be acquired, in a portable manner, by calling:

   ApplicationFactory factory = (ApplicationFactory)
    FactoryFinder.getFactory(FactoryFinder.APPLICATION_FACTORY);

Constructor Summary
ApplicationFactory()
Method Summary
abstract Application | getApplication() Create (if needed) and return an Application instance for this web application.
abstract void | setApplication(Application application) Replace the Application instance that will be returned for this web application.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ApplicationFactory

public ApplicationFactory()
Method Detail

getApplication

public abstract Application getApplication()

Create (if needed) and return an Application instance for this web application.

setApplication

public abstract void setApplication(Application application)

Replace the Application instance that will be returned for this web application.

Parameters:
application - The replacement Application instance
Throws:
NullPointerException - if application is null.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FacesMessage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.application
Class FacesMessage

java.lang.Object
    extended by  javax.faces.application.FacesMessage
All Implemented Interfaces:
Serializable
public class FacesMessage
extends Object
implements Serializable

FacesMessage represents a single validation (or other) message, which is typically associated with a particular component in the view. A FacesMessage instance may be created based on a specific messageId. The specification defines the set of messageIds for which there must be FacesMessage instances.

The implementation must take the following steps when creating FacesMessage instances given a messageId:

    Call Application.getMessageBundle(). If non-null, locate the named ResourceBundle, using the Locale from the current UIViewRoot and see if it has a value for the argument messageId. If it does, treat the value as the summary of the FacesMessage. If it does not, or if Application.getMessageBundle() returned null, look in the ResourceBundle named by the value of the constant FACES_MESSAGES and see if it has a value for the argument messageId. If it does, treat the value as the summary of the FacesMessage. If it does not, there is no initialization information for the FacesMessage instance.

    In all cases, if a ResourceBundle hit is found for the {messageId}, look for further hits under the key {messageId}_detail. Use this value, if present, as the detail for the returned FacesMessage.

    Make sure to perform any parameter substitution required for the summary and detail of the FacesMessage.

See Also:
Serialized Form

Nested Class Summary
static class FacesMessage.Severity
Class used to represent message severity levels in a typesafe enumeration.
Field Summary
static String | FACES_MESSAGES ResourceBundle identifier for messages whose message identifiers are defined in the JavaServer Faces specification.
static FacesMessage.Severity | SEVERITY_ERROR Message severity level indicating that an error has occurred.
static FacesMessage.Severity | SEVERITY_FATAL Message severity level indicating that a serious error has occurred.
static FacesMessage.Severity | SEVERITY_INFO Message severity level indicating an informational message rather than an error.
static FacesMessage.Severity | SEVERITY_WARN Message severity level indicating that an error might have occurred.
static List | VALUES Immutable List of valid FacesMessage.Severity instances, in ascending order of their ordinal value.
static Map | VALUES_MAP Immutable Map of valid FacesMessage.Severity instances, keyed by name.
Constructor Summary
FacesMessage()
Construct a new FacesMessage with no initial values.
FacesMessage(FacesMessage.Severity severity, String summary, String detail)
Construct a new FacesMessage with the specified initial values.
FacesMessage(String summary)
Construct a new FacesMessage with just a summary.
FacesMessage(String summary, String detail)
Construct a new FacesMessage with the specified initial values.
Method Summary
String | getDetail() Return the localized detail text.
FacesMessage.Severity | getSeverity() Return the severity level.
String | getSummary() Return the localized summary text.
void | setDetail(String detail) Set the localized detail text.
void | setSeverity(FacesMessage.Severity severity) Set the severity level.
void | setSummary(String summary) Set the localized summary text.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FACES_MESSAGES

public static final String FACES_MESSAGES

ResourceBundle identifier for messages whose message identifiers are defined in the JavaServer Faces specification.

See Also:
Constant Field Values

SEVERITY_INFO

public static final FacesMessage.Severity SEVERITY_INFO

Message severity level indicating an informational message rather than an error.

SEVERITY_WARN

public static final FacesMessage.Severity SEVERITY_WARN

Message severity level indicating that an error might have occurred.

SEVERITY_ERROR

public static final FacesMessage.Severity SEVERITY_ERROR

Message severity level indicating that an error has occurred.

SEVERITY_FATAL

public static final FacesMessage.Severity SEVERITY_FATAL

Message severity level indicating that a serious error has occurred.

VALUES

public static final List VALUES

Immutable List of valid FacesMessage.Severity instances, in ascending order of their ordinal value.

VALUES_MAP

public static final Map VALUES_MAP

Immutable Map of valid FacesMessage.Severity instances, keyed by name.

Constructor Detail

FacesMessage

public FacesMessage()

Construct a new FacesMessage with no initial values. The severity is set to Severity.INFO.

FacesMessage

public FacesMessage(String summary)

Construct a new FacesMessage with just a summary. The detail is null, the severity is set to Severity.INFO.

FacesMessage

public FacesMessage(String summary,
                    String detail)

Construct a new FacesMessage with the specified initial values. The severity is set to Severity.INFO.

Parameters:
summary - Localized summary message text
detail - Localized detail message text
Throws:
IllegalArgumentException - if the specified severity level is not one of the supported values

FacesMessage

public FacesMessage(FacesMessage.Severity severity,
                    String summary,
                    String detail)

Construct a new FacesMessage with the specified initial values.

Parameters:
severity - the severity
summary - Localized summary message text
detail - Localized detail message text
Throws:
IllegalArgumentException - if the specified severity level is not one of the supported values
Method Detail

getDetail

public String getDetail()

Return the localized detail text. If no localized detail text has been defined for this message, return the localized summary text instead.

setDetail

public void setDetail(String detail)

Set the localized detail text.

Parameters:
detail - The new localized detail text

getSeverity

public FacesMessage.Severity getSeverity()

Return the severity level.

setSeverity

public void setSeverity(FacesMessage.Severity severity)

Set the severity level.

Parameters:
severity - The new severity level
Throws:
IllegalArgumentException - if the specified severity level is not one of the supported values

getSummary

public String getSummary()

Return the localized summary text.

setSummary

public void setSummary(String summary)

Set the localized summary text.

Parameters:
summary - The new localized summary text
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FacesMessage.Severity

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.application
Class FacesMessage.Severity

java.lang.Object
    extended by  javax.faces.application.FacesMessage.Severity
All Implemented Interfaces:
Comparable
Enclosing class:
FacesMessage
public static class FacesMessage.Severity
extends Object
implements Comparable

Class used to represent message severity levels in a typesafe enumeration.

Method Summary
int | compareTo(Object other) Compare this FacesMessage.Severity instance to the specified one.
int | getOrdinal() Return the ordinal value of this FacesMessage.Severity instance.
String | toString() Return a String representation of this FacesMessage.Severity instance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

compareTo

public int compareTo(Object other)

Compare this FacesMessage.Severity instance to the specified one. Returns a negative integer, zero, or a positive integer if this object is less than, equal to, or greater than the specified object.

Specified by:
compareTo in interface Comparable
Parameters:
other - The other object to be compared to

getOrdinal

public int getOrdinal()

Return the ordinal value of this FacesMessage.Severity instance.

toString

public String toString()

Return a String representation of this FacesMessage.Severity instance.

Overrides:
toString in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NavigationHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.application
Class NavigationHandler

java.lang.Object
    extended by  javax.faces.application.NavigationHandler

public abstract class NavigationHandler
extends Object

A NavigationHandler is passed the outcome string returned by an application action invoked for this application, and will use this (along with related state information) to choose the view to be displayed next.

A default implementation of NavigationHandler must be provided by the JSF implementation, which will be utilized unless setNavigationHandler() is called to establish a different one. This default instance will compare the view identifier of the current view, the specified action binding, and the specified outcome against any navigation rules provided in faces-config.xml file(s). If a navigation case matches, the current view will be changed by a call to FacesContext.setViewRoot(). Note that a null outcome value will never match any navigation rule, so it can be used as an indicator that the current view should be redisplayed.

Constructor Summary
NavigationHandler()
Method Summary
abstract  void handleNavigation(FacesContext context, String fromAction, String outcome)
Perform navigation processing based on the state information in the specified FacesContext, plus the outcome string returned by an executed application action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NavigationHandler

public NavigationHandler()
Method Detail

handleNavigation

public abstract void handleNavigation(FacesContext context,
                                      String fromAction,
                                      String outcome)

Perform navigation processing based on the state information in the specified FacesContext, plus the outcome string returned by an executed application action.

Parameters:
context - The FacesContext for the current request
fromAction - The action binding expression that was evaluated to retrieve the specified outcome, or null if the outcome was acquired by some other means
outcome - The logical outcome returned by a previous invoked application action (which may be null)
Throws:
NullPointerException - if context is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StateManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.application
Class StateManager

java.lang.Object
    extended by  javax.faces.application.StateManager
Direct Known Subclasses:
StateManagerWrapper
public abstract class StateManager
extends Object

StateManager directs the process of saving and restoring the view between requests. The StateManager instance for an application is retrieved from the Application instance, and thus cannot know any details of the markup language created by the RenderKit being used to render a view. The StateManager utilizes a helper object (ResponseStateManager), that is provided by the RenderKit implementation and is therefore aware of the markup language details.

Nested Class Summary
 class StateManager.SerializedView
Deprecated. This class was not marked Serializable in the 1.0 version of the spec. It was also not a static inner class, so it can't be made to be Serializable. Therefore, it is being deprecated in version 1.2 of the spec. The replacement is to use an implementation dependent Object.
Field Summary
static String | STATE_SAVING_METHOD_CLIENT Constant value for the initialization parameter named by the STATE_SAVING_METHOD_PARAM_NAME that indicates state saving should take place on the client.
static String | STATE_SAVING_METHOD_PARAM_NAME The ServletContext init parameter consulted by the StateManager to tell where the state should be saved.
static String | STATE_SAVING_METHOD_SERVER Constant value for the initialization parameter named by the STATE_SAVING_METHOD_PARAM_NAME that indicates state saving should take place on the server.
Constructor Summary
StateManager()
Method Summary
protected  Object getComponentStateToSave(FacesContext context)
Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
protected  Object getTreeStructureToSave(FacesContext context)
Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
 boolean isSavingStateInClient(FacesContext context)
protected  void restoreComponentState(FacesContext context, UIViewRoot viewRoot, String renderKitId)
Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation does nothing.
protected  UIViewRoot restoreTreeStructure(FacesContext context, String viewId, String renderKitId)
Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.
abstract  UIViewRoot restoreView(FacesContext context, String viewId, String renderKitId)
Restore the tree structure and the component state of the view for the specified viewId, in an implementation dependent manner, and return the restored UIViewRoot.
 StateManager.SerializedView saveSerializedView(FacesContext context)
Deprecated. this has been replaced by saveView(javax.faces.context.FacesContext). The default implementation returns null.
 Object saveView(FacesContext context)
Return an opaque Object containing sufficient information for this same instance to restore the state of the current UIViewRoot on a subsequent request.
 void writeState(FacesContext context, Object state)
Save the state represented in the specified state Object instance, in an implementation dependent manner.
 void writeState(FacesContext context, StateManager.SerializedView state)
Deprecated. This method has been replaced by writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation of this method does nothing.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

STATE_SAVING_METHOD_PARAM_NAME

public static final String STATE_SAVING_METHOD_PARAM_NAME

The ServletContext init parameter consulted by the StateManager to tell where the state should be saved. Valid values are given as the values of the constants: STATE_SAVING_METHOD_CLIENT or STATE_SAVING_METHOD_SERVER.

If this parameter is not specified, the default value is the value of the constant STATE_SAVING_METHOD_CLIENT.

See Also:
Constant Field Values

STATE_SAVING_METHOD_CLIENT

public static final String STATE_SAVING_METHOD_CLIENT

Constant value for the initialization parameter named by the STATE_SAVING_METHOD_PARAM_NAME that indicates state saving should take place on the client.

See Also:
Constant Field Values

STATE_SAVING_METHOD_SERVER

public static final String STATE_SAVING_METHOD_SERVER

Constant value for the initialization parameter named by the STATE_SAVING_METHOD_PARAM_NAME that indicates state saving should take place on the server.

See Also:
Constant Field Values
Constructor Detail

StateManager

public StateManager()
Method Detail

saveSerializedView

public StateManager.SerializedView saveSerializedView(FacesContext context)
Deprecated. this has been replaced by saveView(javax.faces.context.FacesContext). The default implementation returns null.

Return the tree structure and component state information for the view contained in the specified FacesContext instance as an object of type StateManager.SerializedView. If there is no state information to be saved, return null instead.

Components may opt out of being included in the serialized view by setting their transient property to true. This must cause the component itself, as well as all of that component's children and facets, to be omitted from the saved tree structure and component state information.

This method must also enforce the rule that, for components with non-null ids, all components that are descendants of the same nearest NamingContainer must have unique identifiers.

Parameters:
context - FacesContext for the current request
Throws:
IllegalStateException - if more than one component or facet within the same NamingContainer in this view has the same non-null component id

saveView

public Object saveView(FacesContext context)

Return an opaque Object containing sufficient information for this same instance to restore the state of the current UIViewRoot on a subsequent request. The returned object must implement java.io.Serializable. If there is no state information to be saved, return null instead.

Components may opt out of being included in the serialized view by setting their transient property to true. This must cause the component itself, as well as all of that component's children and facets, to be omitted from the saved tree structure and component state information.

This method must also enforce the rule that, for components with non-null ids, all components that are descendants of the same nearest NamingContainer must have unique identifiers.

For backwards compatability with existing StateManager implementations, the default implementation of this method calls saveSerializedView(javax.faces.context.FacesContext) and creates and returns a two element Object array with element zero containing the structure property and element one containing the state property of the SerializedView.

Parameters:
context - FacesContext for the current request
Throws:
IllegalStateException - if more than one component or facet within the same NamingContainer in this view has the same non-null component id
Since:
1.2

getTreeStructureToSave

protected Object getTreeStructureToSave(FacesContext context)
Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.

Convenience method, which must be called by saveSerializedView(), to construct and return a Serializable object that represents the structure of the entire component tree (including children and facets) of this view.

Components may opt-out of being included in the tree structure by setting their transient property to true. This must cause the component itself, as well as all of that component's children and facets, to be omitted from the saved tree structure information.

Parameters:
context - FacesContext for the current request

getComponentStateToSave

protected Object getComponentStateToSave(FacesContext context)
Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.

Convenience method, which must be called by saveSerializedView(), to construct and return a Serializable object that represents the state of all component properties, attributes, and attached objects, for the entire component tree (including children and facets) of this view.

Components may opt-out of being included in the component state by setting their transient property to true. This must cause the component itself, as well as all of that component's children and facets, to be omitted from the saved component state information.

Parameters:
context - FacesContext for the current request

writeState

public void writeState(FacesContext context,
                       Object state)
                throws IOException

Save the state represented in the specified state Object instance, in an implementation dependent manner.

This method will typically simply delegate the actual writing to the writeState() method of the ResponseStateManager instance provided by the RenderKit being used to render this view. This method assumes that the caller has positioned the ResponseWriter at the correct position for the saved state to be written.

For backwards compatability with existing StateManager implementations, the default implementation of this method checks if the argument is an instance of Object [] of length greater than or equal to two. If so, it creates a SerializedView instance with the tree structure coming from element zero and the component state coming from element one and calls through to writeState(javax.faces.context.FacesContext,javax.faces.application.StateManager.SerializedView). If not, does nothing.

Parameters:
context - FacesContext for the current request
state - the Serializable state to be written, as returned by saveSerializedView(javax.faces.context.FacesContext)
Throws:
IOException
Since:
1.2

writeState

public void writeState(FacesContext context,
                       StateManager.SerializedView state)
                throws IOException
Deprecated. This method has been replaced by writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation of this method does nothing.

Save the state represented in the specified SerializedView isntance, in an implementation dependent manner.

This method must consult the context initialization parameter named by the symbolic constant StateManager.STATE_SAVING_METHOD_PARAMETER_NAME to determine whether state should be saved on the client or the server. If not present, client side state saving is assumed.

If the init parameter indicates that client side state saving should be used, this method must delegate the actual writing to the writeState() method of the ResponseStateManager instance provided by the RenderKit being used to render this view. This method assumes that the caller has positioned the ResponseWriter at the correct position for the saved state to be written.

Parameters:
context - FacesContext for the current request
state - the serialized state to be written
Throws:
IOException

restoreView

public abstract UIViewRoot restoreView(FacesContext context,
                                       String viewId,
                                       String renderKitId)

Restore the tree structure and the component state of the view for the specified viewId, in an implementation dependent manner, and return the restored UIViewRoot. If there is no saved state information available for this viewId, return null instead.

This method must consult the context initialization parameter named by the symbolic constant StateManager.STATE_SAVING_METHOD_PARAMETER_NAME to determine whether state should be saved on the client or the server. If not present, client side state saving is assumed.

If the init parameter indicates that client side state saving should be used, this method must call the getTreeStructureToRestore() and (if the previous method call returned a non-null value) getComponentStateToRestore() methods of the ResponseStateManager instance provided by the RenderKit responsible for this view.

Parameters:
context - FacesContext for the current request
viewId - View identifier of the view to be restored
renderKitId - the renderKitId used to render this response. Must not be null.
Throws:
IllegalArgumentException - if renderKitId is null.

restoreTreeStructure

protected UIViewRoot restoreTreeStructure(FacesContext context,
                                          String viewId,
                                          String renderKitId)
Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation returns null.

Convenience method, which must be called by restoreView(), to construct and return a UIViewRoot instance (populated with children and facets) representing the tree structure of the component tree being restored. If no saved state information is available, return null instead.

Parameters:
context - FacesContext for the current request
viewId - View identifier of the view to be restored
renderKitId - the renderKitId used to render this response. Must not be null.
Throws:
IllegalArgumentException - if renderKitId is null.

restoreComponentState

protected void restoreComponentState(FacesContext context,
                                     UIViewRoot viewRoot,
                                     String renderKitId)
Deprecated. the distinction between tree structure and component state is now an implementation detail. The default implementation does nothing.

Convenience method, which must be called by restoreView(), to restore the attributes, properties, and attached objects of all components in the restored component tree.

Parameters:
context - FacesContext for the current request
viewRoot - UIViewRoot returned by a previous call to restoreTreeStructure()
renderKitId - the renderKitId used to render this response. Must not be null.
Throws:
IllegalArgumentException - if renderKitId is null.

isSavingStateInClient

public boolean isSavingStateInClient(FacesContext context)
Returns:
true if and only if the value of the ServletContext init parameter named by the value of the constant STATE_SAVING_METHOD_PARAM_NAME is equal to the value of the constant STATE_SAVING_METHOD_CLIENT. false otherwise.
Throws:
NullPointerException - if context is null.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StateManager.SerializedView

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.application
Class StateManager.SerializedView

java.lang.Object
    extended by  javax.faces.application.StateManager.SerializedView
Enclosing class:
StateManager
Deprecated. This class was not marked Serializable in the 1.0 version of the spec. It was also not a static inner class, so it can't be made to be Serializable. Therefore, it is being deprecated in version 1.2 of the spec. The replacement is to use an implementation dependent Object.

public class StateManager.SerializedView
extends Object

Convenience struct for encapsulating tree structure and component state. This is necessary to allow the API to be flexible enough to work in JSP and non-JSP environments.

Constructor Summary
StateManager.SerializedView(Object newStructure, Object newState)
Deprecated.
Method Summary
Object | getState() Deprecated.
Object | getStructure() Deprecated.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StateManager.SerializedView

public StateManager.SerializedView(Object newStructure,
                                   Object newState)
Deprecated.
Method Detail

getStructure

public Object getStructure()
Deprecated.

getState

public Object getState()
Deprecated.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StateManagerWrapper

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.application
Class StateManagerWrapper

java.lang.Object
    extended by  javax.faces.application.StateManager
        extended by  javax.faces.application.StateManagerWrapper

public abstract class StateManagerWrapper
extends StateManager

Provides a simple implementation of StateManager that can be subclassed by developers wishing to provide specialized behavior to an existing StateManager instance. The default implementation of all methods is to call through to the wrapped StateManager.

Usage: extend this class and override getWrapped() to return the instance we are wrapping.

Since:
1.2

Nested Class Summary
Nested classes/interfaces inherited from class javax.faces.application.StateManager
StateManager.SerializedView
Field Summary
Fields inherited from class javax.faces.application.StateManager
STATE_SAVING_METHOD_CLIENT, STATE_SAVING_METHOD_PARAM_NAME, STATE_SAVING_METHOD_SERVER
Constructor Summary
StateManagerWrapper()
Method Summary
protected  Object getComponentStateToSave(FacesContext context)
The default behavior of this method is to call StateManager.getComponentStateToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.
protected  Object getTreeStructureToSave(FacesContext context)
The default behavior of this method is to call StateManager.getTreeStructureToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.
protected abstract  StateManager getWrapped()
 boolean isSavingStateInClient(FacesContext context)
The default behavior of this method is to call StateManager.isSavingStateInClient(javax.faces.context.FacesContext) on the wrapped StateManager object.
protected  void restoreComponentState(FacesContext context, UIViewRoot viewRoot, String renderKitId)
The default behavior of this method is to call StateManager.restoreComponentState(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot, String) on the wrapped StateManager object.
protected  UIViewRoot restoreTreeStructure(FacesContext context, String viewId, String renderKitId)
The default behavior of this method is to call StateManager.restoreTreeStructure(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.
 UIViewRoot restoreView(FacesContext context, String viewId, String renderKitId)
The default behavior of this method is to call StateManager.restoreView(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.
 StateManager.SerializedView saveSerializedView(FacesContext context)
The default behavior of this method is to call StateManager.saveSerializedView(javax.faces.context.FacesContext) on the wrapped StateManager object.
 Object saveView(FacesContext context)
The default behavior of this method is to call StateManager.saveView(javax.faces.context.FacesContext) on the wrapped StateManager object.
 void writeState(FacesContext context, Object state)
The default behavior of this method is to call StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object) on the wrapped StateManager object.
 void writeState(FacesContext context, StateManager.SerializedView state)
The default behavior of this method is to call StateManager.writeState(javax.faces.context.FacesContext, javax.faces.application.StateManager.SerializedView) on the wrapped StateManager object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StateManagerWrapper

public StateManagerWrapper()
Method Detail

getWrapped

protected abstract StateManager getWrapped()
Returns:
the instance that we are wrapping.

saveSerializedView

public StateManager.SerializedView saveSerializedView(FacesContext context)

The default behavior of this method is to call StateManager.saveSerializedView(javax.faces.context.FacesContext) on the wrapped StateManager object.

Overrides:
saveSerializedView in class StateManager
Parameters:
context - FacesContext for the current request
Since:
1.2
See Also:
StateManager.saveSerializedView(javax.faces.context.FacesContext)

saveView

public Object saveView(FacesContext context)

The default behavior of this method is to call StateManager.saveView(javax.faces.context.FacesContext) on the wrapped StateManager object.

Overrides:
saveView in class StateManager
Parameters:
context - FacesContext for the current request
Since:
1.2
See Also:
StateManager.saveView(javax.faces.context.FacesContext)

getTreeStructureToSave

protected Object getTreeStructureToSave(FacesContext context)

The default behavior of this method is to call StateManager.getTreeStructureToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.

Overrides:
getTreeStructureToSave in class StateManager
Parameters:
context - FacesContext for the current request
Since:
1.2
See Also:
StateManager.getTreeStructureToSave(javax.faces.context.FacesContext)

getComponentStateToSave

protected Object getComponentStateToSave(FacesContext context)

The default behavior of this method is to call StateManager.getComponentStateToSave(javax.faces.context.FacesContext) on the wrapped StateManager object.

Overrides:
getComponentStateToSave in class StateManager
Parameters:
context - FacesContext for the current request
Since:
1.2
See Also:
StateManager.getComponentStateToSave(javax.faces.context.FacesContext)

writeState

public void writeState(FacesContext context,
                       Object state)
                throws IOException

The default behavior of this method is to call StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object) on the wrapped StateManager object.

Overrides:
writeState in class StateManager
Parameters:
context - FacesContext for the current request
state - the Serializable state to be written, as returned by StateManager.saveSerializedView(javax.faces.context.FacesContext)
Throws:
IOException
Since:
1.2
See Also:
StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object)

writeState

public void writeState(FacesContext context,
                       StateManager.SerializedView state)
                throws IOException

The default behavior of this method is to call StateManager.writeState(javax.faces.context.FacesContext, javax.faces.application.StateManager.SerializedView) on the wrapped StateManager object.

Overrides:
writeState in class StateManager
Parameters:
context - FacesContext for the current request
state - the serialized state to be written
Throws:
IOException
Since:
1.2
See Also:
StateManager.writeState(javax.faces.context.FacesContext, javax.faces.application.StateManager.SerializedView)

restoreView

public UIViewRoot restoreView(FacesContext context,
                              String viewId,
                              String renderKitId)

The default behavior of this method is to call StateManager.restoreView(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.

Specified by:
restoreView in class StateManager
Parameters:
context - FacesContext for the current request
viewId - View identifier of the view to be restored
renderKitId - the renderKitId used to render this response. Must not be null.
Since:
1.2
See Also:
StateManager.restoreView(javax.faces.context.FacesContext, String, String)

restoreTreeStructure

protected UIViewRoot restoreTreeStructure(FacesContext context,
                                          String viewId,
                                          String renderKitId)

The default behavior of this method is to call StateManager.restoreTreeStructure(javax.faces.context.FacesContext, String, String) on the wrapped StateManager object.

Overrides:
restoreTreeStructure in class StateManager
Parameters:
context - FacesContext for the current request
viewId - View identifier of the view to be restored
renderKitId - the renderKitId used to render this response. Must not be null.
Since:
1.2
See Also:
StateManager.restoreTreeStructure(javax.faces.context.FacesContext, String, String)

restoreComponentState

protected void restoreComponentState(FacesContext context,
                                     UIViewRoot viewRoot,
                                     String renderKitId)

The default behavior of this method is to call StateManager.restoreComponentState(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot, String) on the wrapped StateManager object.

Overrides:
restoreComponentState in class StateManager
Parameters:
context - FacesContext for the current request
viewRoot - UIViewRoot returned by a previous call to restoreTreeStructure()
renderKitId - the renderKitId used to render this response. Must not be null.
Since:
1.2
See Also:
StateManager.restoreComponentState(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot, String)

isSavingStateInClient

public boolean isSavingStateInClient(FacesContext context)

The default behavior of this method is to call StateManager.isSavingStateInClient(javax.faces.context.FacesContext) on the wrapped StateManager object.

Overrides:
isSavingStateInClient in class StateManager
Returns:
true if and only if the value of the ServletContext init parameter named by the value of the constant StateManager.STATE_SAVING_METHOD_PARAM_NAME is equal to the value of the constant StateManager.STATE_SAVING_METHOD_CLIENT. false otherwise.
Since:
1.2
See Also:
StateManager.isSavingStateInClient(javax.faces.context.FacesContext)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ViewExpiredException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.application
Class ViewExpiredException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.faces.FacesException
                    extended by  javax.faces.application.ViewExpiredException
All Implemented Interfaces:
Serializable
public class ViewExpiredException
extends FacesException

Implementations must throw this FacesException when attempting to restore the view StateManager.restoreView(javax.faces.context.FacesContext, String, String) results in failure on postback.

Since:
1.2
See Also:
Serialized Form

Constructor Summary
ViewExpiredException()
Construct a new exception with no detail message or root cause.
ViewExpiredException(String viewId)
Construct a new exception with the specified view identifier.
ViewExpiredException(String message, String viewId)
Construct a new exception with the specified detail message and no root cause.
ViewExpiredException(String message, Throwable cause, String viewId)
Construct a new exception with the specified detail message and root cause.
ViewExpiredException(Throwable cause, String viewId)
Construct a new exception with the specified root cause.
Method Summary
String | getMessage() Return the message for this exception prepended with the view identifier if the view identifier is not null, otherwise, return the message.
String | getViewId() Return the view identifier of this exception, or null if the view identifier is nonexistent or unknown.
Methods inherited from class javax.faces.FacesException
getCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ViewExpiredException

public ViewExpiredException()

Construct a new exception with no detail message or root cause.

ViewExpiredException

public ViewExpiredException(String viewId)

Construct a new exception with the specified view identifier.

Parameters:
viewId - The view identifier for this exception

ViewExpiredException

public ViewExpiredException(String message,
                            String viewId)

Construct a new exception with the specified detail message and no root cause.

Parameters:
message - The detail message for this exception
viewId - The view identifier for this exception

ViewExpiredException

public ViewExpiredException(Throwable cause,
                            String viewId)

Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

Parameters:
cause - The root cause for this exception
viewId - The view identifier for this exception

ViewExpiredException

public ViewExpiredException(String message,
                            Throwable cause,
                            String viewId)

Construct a new exception with the specified detail message and root cause.

Parameters:
message - The detail message for this exception
cause - The root cause for this exception
viewId - The view identifier for this exception
Method Detail

getViewId

public String getViewId()

Return the view identifier of this exception, or null if the view identifier is nonexistent or unknown.

getMessage

public String getMessage()

Return the message for this exception prepended with the view identifier if the view identifier is not null, otherwise, return the message.

Overrides:
getMessage in class Throwable
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ViewHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.application
Class ViewHandler

java.lang.Object
    extended by  javax.faces.application.ViewHandler
Direct Known Subclasses:
ViewHandlerWrapper
public abstract class ViewHandler
extends Object

ViewHandler is the pluggablity mechanism for allowing implementations of or applications using the JavaServer Faces specification to provide their own handling of the activities in the Render Response and Restore View phases of the request processing lifecycle. This allows for implementations to support different response generation technologies, as well as alternative strategies for saving and restoring the state of each view.

Please see StateManager for information on how the ViewHandler interacts the StateManager.

Field Summary
static String | CHARACTER_ENCODING_KEY The key, in the session's attribute set, under which the response character encoding may be stored and retrieved.
static String | DEFAULT_SUFFIX The value to use for the default extension if the webapp is using url extension mapping.
static String | DEFAULT_SUFFIX_PARAM_NAME Allow the web application to define an alternate suffix for pages containing JSF content.
Constructor Summary
ViewHandler()
Method Summary
 String calculateCharacterEncoding(FacesContext context)
Returns the correct character encoding to be used for this request.
abstract  Locale calculateLocale(FacesContext context)
Returns an appropriate Locale to use for this and subsequent requests for the current client.
abstract  String calculateRenderKitId(FacesContext context)
Return an appropriate renderKitId for this and subsequent requests from the current client.
abstract  UIViewRoot createView(FacesContext context, String viewId)
Create and return a new UIViewRoot instance initialized with information from the argument FacesContext and viewId.
abstract  String getActionURL(FacesContext context, String viewId)
Return a URL suitable for rendering (after optional encoding performed by the encodeActionURL() method of ExternalContext) that selects the specified view identifier.
abstract  String getResourceURL(FacesContext context, String path)
Return a URL suitable for rendering (after optional encoding perfomed by the encodeResourceURL() method of ExternalContext) that selects the specifed web application resource.
 void initView(FacesContext context)
Initialize the view for the request processing lifecycle.
abstract  void renderView(FacesContext context, UIViewRoot viewToRender)
Perform whatever actions are required to render the response view to the response object associated with the current FacesContext.
abstract  UIViewRoot restoreView(FacesContext context, String viewId)
Perform whatever actions are required to restore the view associated with the specified FacesContext and viewId.
abstract  void writeState(FacesContext context)
Take any appropriate action to either immediately write out the current state information (by calling StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object), or noting where state information should later be written.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CHARACTER_ENCODING_KEY

public static final String CHARACTER_ENCODING_KEY

The key, in the session's attribute set, under which the response character encoding may be stored and retrieved.

See Also:
Constant Field Values

DEFAULT_SUFFIX_PARAM_NAME

public static final String DEFAULT_SUFFIX_PARAM_NAME

Allow the web application to define an alternate suffix for pages containing JSF content. If this init parameter is not specified, the default value is taken from the value of the constant DEFAULT_SUFFIX.

See Also:
Constant Field Values

DEFAULT_SUFFIX

public static final String DEFAULT_SUFFIX

The value to use for the default extension if the webapp is using url extension mapping.

See Also:
Constant Field Values
Constructor Detail

ViewHandler

public ViewHandler()
Method Detail

calculateLocale

public abstract Locale calculateLocale(FacesContext context)

Returns an appropriate Locale to use for this and subsequent requests for the current client.

Parameters:
context - FacesContext for the current request
Throws:
NullPointerException - if context is null

calculateCharacterEncoding

public String calculateCharacterEncoding(FacesContext context)

Returns the correct character encoding to be used for this request.

The following algorithm is employed.

  • Examine the Content-Type request header. If it has a charset parameter, extract it and return that as the encoding.

  • If no charset parameter was found, check for the existence of a session by calling ExternalContext.getSession(boolean) passing false as the argument. If that method returns true, get the session Map by calling ExternalContext.getSessionMap() and look for a value under the key given by the value of the symbolic constant CHARACTER_ENCODING_KEY. If present, return the value, converted to String.

  • Otherwise, return null

calculateRenderKitId

public abstract String calculateRenderKitId(FacesContext context)

Return an appropriate renderKitId for this and subsequent requests from the current client. It is an error for this method to return null.

The default return value is RenderKitFactory.HTML_BASIC_RENDER_KIT.

Parameters:
context - FacesContext for the current request
Throws:
NullPointerException - if context is null

createView

public abstract UIViewRoot createView(FacesContext context,
                                      String viewId)

Create and return a new UIViewRoot instance initialized with information from the argument FacesContext and viewId.

If there is an existing ViewRoot available on the FacesContext, this method must copy its locale and renderKitId to this new view root. If not, this method must call calculateLocale(javax.faces.context.FacesContext) and calculateRenderKitId(javax.faces.context.FacesContext), and store the results as the values of the locale and renderKitId, proeprties, respectively, of the newly created UIViewRoot.

Throws:
NullPointerException - if context is null

getActionURL

public abstract String getActionURL(FacesContext context,
                                    String viewId)

Return a URL suitable for rendering (after optional encoding performed by the encodeActionURL() method of ExternalContext) that selects the specified view identifier.

Parameters:
context - FacesContext for this request
viewId - View identifier of the desired view
Throws:
IllegalArgumentException - if viewId is not valid for this ViewHandler.
NullPointerException - if context or viewId is null.

getResourceURL

public abstract String getResourceURL(FacesContext context,
                                      String path)

Return a URL suitable for rendering (after optional encoding perfomed by the encodeResourceURL() method of ExternalContext) that selects the specifed web application resource. If the specified path starts with a slash, it must be treated as context relative; otherwise, it must be treated as relative to the action URL of the current view.

Parameters:
context - FacesContext for the current request
path - Resource path to convert to a URL
Throws:
IllegalArgumentException - if viewId is not valid for this ViewHandler.
NullPointerException - if context or path is null.

initView

public void initView(FacesContext context)
              throws FacesException

Initialize the view for the request processing lifecycle.

This method must be called at the beginning of the Restore View Phase of the Request Processing Lifecycle. It is responsible for performing any per-request initialization necessary to the operation of the lifycecle.

The default implementation calls calculateCharacterEncoding(javax.faces.context.FacesContext) and passes the result, if non-null into the ExternalContext.setRequestCharacterEncoding(java.lang.String) method.

Throws:
FacesException - if a problem occurs setting the encoding, such as the UnsupportedEncodingException thrown by the underlying Servlet or Portlet technology when the encoding is not supported.

renderView

public abstract void renderView(FacesContext context,
                                UIViewRoot viewToRender)
                         throws IOException,
                                FacesException

Perform whatever actions are required to render the response view to the response object associated with the current FacesContext.

Parameters:
context - FacesContext for the current request
viewToRender - the view to render
Throws:
IOException - if an input/output error occurs
NullPointerException - if context or viewToRender is null
FacesException - if a servlet error occurs

restoreView

public abstract UIViewRoot restoreView(FacesContext context,
                                       String viewId)

Perform whatever actions are required to restore the view associated with the specified FacesContext and viewId. It may delegate to the restoreView of the associated StateManager to do the actual work of restoring the view. If there is no available state for the specified viewId, return null.

Parameters:
context - FacesContext for the current request
viewId - the view identifier for the current request
Throws:
NullPointerException - if context is null
FacesException - if a servlet error occurs

writeState

public abstract void writeState(FacesContext context)
                         throws IOException

Take any appropriate action to either immediately write out the current state information (by calling StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object), or noting where state information should later be written.

Parameters:
context - FacesContext for the current request
Throws:
IOException - if an input/output error occurs
NullPointerException - if context is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ViewHandlerWrapper

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.application
Class ViewHandlerWrapper

java.lang.Object
    extended by  javax.faces.application.ViewHandler
        extended by  javax.faces.application.ViewHandlerWrapper

public abstract class ViewHandlerWrapper
extends ViewHandler

Provides a simple implementation of ViewHandler that can be subclassed by developers wishing to provide specialized behavior to an existing ViewHandler instance. The default implementation of all methods is to call through to the wrapped ViewHandler.

Usage: extend this class and override getWrapped() to return the instance we are wrapping.

Since:
1.2

Field Summary
Fields inherited from class javax.faces.application.ViewHandler
CHARACTER_ENCODING_KEY, DEFAULT_SUFFIX, DEFAULT_SUFFIX_PARAM_NAME
Constructor Summary
ViewHandlerWrapper()
Method Summary
 String calculateCharacterEncoding(FacesContext context)
The default behavior of this method is to call ViewHandler.calculateCharacterEncoding(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
 Locale calculateLocale(FacesContext context)
The default behavior of this method is to call ViewHandler.calculateLocale(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
 String calculateRenderKitId(FacesContext context)
The default behavior of this method is to call ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
 UIViewRoot createView(FacesContext context, String viewId)
The default behavior of this method is to call ViewHandler.createView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
 String getActionURL(FacesContext context, String viewId)
The default behavior of this method is to call ViewHandler.getActionURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
 String getResourceURL(FacesContext context, String path)
The default behavior of this method is to call ViewHandler.getResourceURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
protected abstract  ViewHandler getWrapped()
 void initView(FacesContext context)
The default behavior of this method is to call ViewHandler.initView(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
 void renderView(FacesContext context, UIViewRoot viewToRender)
The default behavior of this method is to call ViewHandler.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot) on the wrapped ViewHandler object.
 UIViewRoot restoreView(FacesContext context, String viewId)
The default behavior of this method is to call ViewHandler.restoreView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.
 void writeState(FacesContext context)
The default behavior of this method is to call ViewHandler.writeState(javax.faces.context.FacesContext) on the wrapped ViewHandler object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ViewHandlerWrapper

public ViewHandlerWrapper()
Method Detail

getWrapped

protected abstract ViewHandler getWrapped()
Returns:
the instance that we are wrapping.

calculateCharacterEncoding

public String calculateCharacterEncoding(FacesContext context)

The default behavior of this method is to call ViewHandler.calculateCharacterEncoding(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

Overrides:
calculateCharacterEncoding in class ViewHandler
Since:
1.2
See Also:
ViewHandler.calculateCharacterEncoding(javax.faces.context.FacesContext)

calculateLocale

public Locale calculateLocale(FacesContext context)

The default behavior of this method is to call ViewHandler.calculateLocale(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

Specified by:
calculateLocale in class ViewHandler
Parameters:
context - FacesContext for the current request
Since:
1.2
See Also:
ViewHandler.calculateLocale(javax.faces.context.FacesContext)

calculateRenderKitId

public String calculateRenderKitId(FacesContext context)

The default behavior of this method is to call ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

Specified by:
calculateRenderKitId in class ViewHandler
Parameters:
context - FacesContext for the current request
Since:
1.2
See Also:
ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext)

createView

public UIViewRoot createView(FacesContext context,
                             String viewId)

The default behavior of this method is to call ViewHandler.createView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

Specified by:
createView in class ViewHandler
Since:
1.2
See Also:
ViewHandler.createView(javax.faces.context.FacesContext, String)

getActionURL

public String getActionURL(FacesContext context,
                           String viewId)

The default behavior of this method is to call ViewHandler.getActionURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

Specified by:
getActionURL in class ViewHandler
Parameters:
context - FacesContext for this request
viewId - View identifier of the desired view
Since:
1.2
See Also:
ViewHandler.getActionURL(javax.faces.context.FacesContext, String)

getResourceURL

public String getResourceURL(FacesContext context,
                             String path)

The default behavior of this method is to call ViewHandler.getResourceURL(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

Specified by:
getResourceURL in class ViewHandler
Parameters:
context - FacesContext for the current request
path - Resource path to convert to a URL
Since:
1.2
See Also:
ViewHandler.getResourceURL(javax.faces.context.FacesContext, String)

initView

public void initView(FacesContext context)
              throws FacesException

The default behavior of this method is to call ViewHandler.initView(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

Overrides:
initView in class ViewHandler
Throws:
FacesException - if a problem occurs setting the encoding, such as the UnsupportedEncodingException thrown by the underlying Servlet or Portlet technology when the encoding is not supported.
Since:
1.2
See Also:
ViewHandler.initView(javax.faces.context.FacesContext)

renderView

public void renderView(FacesContext context,
                       UIViewRoot viewToRender)
                throws IOException,
                       FacesException

The default behavior of this method is to call ViewHandler.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot) on the wrapped ViewHandler object.

Specified by:
renderView in class ViewHandler
Parameters:
context - FacesContext for the current request
viewToRender - the view to render
Throws:
IOException - if an input/output error occurs
FacesException - if a servlet error occurs
Since:
1.2
See Also:
ViewHandler.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot)

restoreView

public UIViewRoot restoreView(FacesContext context,
                              String viewId)

The default behavior of this method is to call ViewHandler.restoreView(javax.faces.context.FacesContext, String) on the wrapped ViewHandler object.

Specified by:
restoreView in class ViewHandler
Parameters:
context - FacesContext for the current request
viewId - the view identifier for the current request
Since:
1.2
See Also:
ViewHandler.restoreView(javax.faces.context.FacesContext, String)

writeState

public void writeState(FacesContext context)
                throws IOException

The default behavior of this method is to call ViewHandler.writeState(javax.faces.context.FacesContext) on the wrapped ViewHandler object.

Specified by:
writeState in class ViewHandler
Parameters:
context - FacesContext for the current request
Throws:
IOException - if an input/output error occurs
Since:
1.2
See Also:
ViewHandler.writeState(javax.faces.context.FacesContext)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


component

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.faces.component

Fundamental APIs for user interface components.

See:
Description

Interface Summary
ActionSource | ActionSource is an interface that may be implemented by any concrete UIComponent that wishes to be a source of ActionEvents, including the ability to invoke application actions via the default ActionListener mechanism.
ActionSource2 | ActionSource2 extends ActionSource and provides a JavaBeans property analogous to the "action" property on ActionSource.
ContextCallback | A simple callback interace that enables taking action on a specific UIComponent (either facet or child) in the view while preserving any contextual state for that component instance in the view.
EditableValueHolder | EditableValueHolder is an extension of ValueHolder that describes additional features supported by editable components, including ValueChangeEvents and Validators.
NamingContainer | NamingContainer is an interface that must be implemented by any UIComponent that wants to be a naming container.
StateHolder | This interface is implemented by classes that need to save their state between requests.
ValueHolder | ValueHolder is an interface that may be implemented by any concrete UIComponent that wishes to support a local value, as well as access data in the model tier via a value expression, and support conversion between String and the model tier data's native data type.

Class Summary
UIColumn | UIColumn is a UIComponent that represents a single column of data within a parent UIData component.
UICommand | UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action".
UIComponent | UIComponent is the base class for all user interface components in JavaServer Faces.
UIComponentBase | UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.
UIData | UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression).
UIForm | UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.
UIGraphic | UIGraphic is a UIComponent that displays a graphical image to the user.
UIInput | UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded.
UIMessage | This component is responsible for displaying messages for a specific UIComponent, identified by a clientId.
UIMessages | The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.
UINamingContainer | UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.
UIOutput | UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user.
UIPanel | UIPanel is a UIComponent that manages the layout of its child components.
UIParameter | UIParameter is a UIComponent that represents an optionally named configuration parameter for a parent component.
UISelectBoolean | UISelectBoolean is a UIComponent that represents a single boolean (true or false) value.
UISelectItem | UISelectItem is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of a SelectItem instance to the list of available options for the parent component.
UISelectItems | UISelectItems is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of one or more SelectItem instances to the list of available options in the parent component.
UISelectMany | UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options.
UISelectOne | UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options.
UIViewRoot | UIViewRoot is the UIComponent that represents the root of the UIComponent tree.

Package javax.faces.component Description

Fundamental APIs for user interface components.

For your convenience here is a UML class diagram of the classes in this package.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.faces.component Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.faces.component

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.component.UIComponent (implements javax.faces.component.StateHolder)
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIColumn
        • javax.faces.component.UICommand (implements javax.faces.component.ActionSource2)
        • javax.faces.component.UIData (implements javax.faces.component.NamingContainer)
        • javax.faces.component.UIForm (implements javax.faces.component.NamingContainer)
        • javax.faces.component.UIGraphic
        • javax.faces.component.UIMessage
        • javax.faces.component.UIMessages
        • javax.faces.component.UINamingContainer (implements javax.faces.component.NamingContainer)
        • javax.faces.component.UIOutput (implements javax.faces.component.ValueHolder)
          • javax.faces.component.UIInput (implements javax.faces.component.EditableValueHolder)
            • javax.faces.component.UISelectBoolean
            • javax.faces.component.UISelectMany
            • javax.faces.component.UISelectOne
        • javax.faces.component.UIPanel
        • javax.faces.component.UIParameter
        • javax.faces.component.UISelectItem
        • javax.faces.component.UISelectItems
        • javax.faces.component.UIViewRoot

Interface Hierarchy

  • javax.faces.component.ActionSource
    • javax.faces.component.ActionSource2
  • javax.faces.component.ContextCallback
  • javax.faces.component.NamingContainer
  • javax.faces.component.StateHolder
  • javax.faces.component.ValueHolder
    • javax.faces.component.EditableValueHolder
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ActionSource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Interface ActionSource

All Known Subinterfaces:
ActionSource2
All Known Implementing Classes:
HtmlCommandButton, HtmlCommandLink, UICommand
public interface ActionSource

ActionSource is an interface that may be implemented by any concrete UIComponent that wishes to be a source of ActionEvents, including the ability to invoke application actions via the default ActionListener mechanism.

Method Summary
 void addActionListener(ActionListener listener)
Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.
 MethodBinding getAction()
Deprecated. This has been replaced by ActionSource2.getActionExpression().
 MethodBinding getActionListener()
Deprecated. Use getActionListeners() instead.
 ActionListener[] getActionListeners()
Return the set of registered ActionListeners for this ActionSource instance.
 boolean isImmediate()
Return a flag indicating that the default ActionListener provided by the JavaServer Faces implementation should be executed immediately (that is, during Apply Request Values phase of the request processing lifecycle), rather than waiting until the Invoke Application phase.
 void removeActionListener(ActionListener listener)
Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.
 void setAction(MethodBinding action)
Deprecated. This has been replaced by ActionSource2.setActionExpression(javax.el.MethodExpression).
 void setActionListener(MethodBinding actionListener)
Deprecated. This has been replaced by addActionListener(javax.faces.event.ActionListener).
 void setImmediate(boolean immediate)
Set the "immediate execution" flag for this UIComponent.

Method Detail

getAction

MethodBinding getAction()
Deprecated. This has been replaced by ActionSource2.getActionExpression().

If the implementing class also implements ActionSource2, the implementation of this method must call through to ActionSource2.getActionExpression() and examine the result. If the result came from a previous call to setAction(javax.faces.el.MethodBinding), extract the MethodBinding from it and return it. Otherwise, wrap the returned MethodExpression in a MethodBinding implementation, and return it.

If the implementing class does not implement ActionSource2, return the MethodBindingpointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

setAction

void setAction(MethodBinding action)
Deprecated. This has been replaced by ActionSource2.setActionExpression(javax.el.MethodExpression).

If the implementing class also implements ActionSource2, the implementation of this method must wrap the argument action in a class that implements MethodExpression and call through to ActionSource2.setActionExpression(javax.el.MethodExpression), passing the wrapped action.

If the implementing class does not implement ActionSource2, set the MethodBinding pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

Any method referenced by such an expression must be public, with a return type of String, and accept no parameters.

Parameters:
action - The new MethodBinding expression

getActionListener

MethodBinding getActionListener()
Deprecated. Use getActionListeners() instead.

If setActionListener(javax.faces.el.MethodBinding) was not previously called for this instance, this method must return null. If it was called, this method must return the exact MethodBinding instance that was passed to setActionListener(javax.faces.el.MethodBinding).

The method to be invoked, if this UIComponent is activated by the user, will be called during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending upon the value of the immediate property.

setActionListener

void setActionListener(MethodBinding actionListener)
Deprecated. This has been replaced by addActionListener(javax.faces.event.ActionListener).

Wrap the argument actionListener in an implementation of ActionListener and store it in the internal data structure that backs the getActionListeners() method, taking care to over-write any instance that was stored by a previous call to setActionListener.

Any method referenced by such an expression must be public, with a return type of void, and accept a single parameter of type ActionEvent.

Parameters:
actionListener - The new method binding expression

isImmediate

boolean isImmediate()

Return a flag indicating that the default ActionListener provided by the JavaServer Faces implementation should be executed immediately (that is, during Apply Request Values phase of the request processing lifecycle), rather than waiting until the Invoke Application phase. The default value for this property must be false.

setImmediate

void setImmediate(boolean immediate)

Set the "immediate execution" flag for this UIComponent.

Parameters:
immediate - The new immediate execution flag

addActionListener

void addActionListener(ActionListener listener)

Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.

Parameters:
listener - The ActionListener to be added
Throws:
NullPointerException - if listener is null

getActionListeners

ActionListener[] getActionListeners()

Return the set of registered ActionListeners for this ActionSource instance. If there are no registered listeners, a zero-length array is returned.

removeActionListener

void removeActionListener(ActionListener listener)

Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.

Parameters:
listener - The ActionListener to be removed
Throws:
NullPointerException - if listener is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ActionSource2

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Interface ActionSource2

All Superinterfaces:
ActionSource
All Known Implementing Classes:
HtmlCommandButton, HtmlCommandLink, UICommand
public interface ActionSource2
extends ActionSource

ActionSource2 extends ActionSource and provides a JavaBeans property analogous to the "action" property on ActionSource. The difference is the type of this property is a MethodExpression rather than a MethodBinding. This allows the ActionSource concept to leverage the new Unified EL API.

Since:
1.2

Method Summary
MethodExpression | getActionExpression() Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
void | setActionExpression(MethodExpression action) Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
Methods inherited from interface javax.faces.component.ActionSource
addActionListener, getAction, getActionListener, getActionListeners, isImmediate, removeActionListener, setAction, setActionListener, setImmediate

Method Detail

getActionExpression

MethodExpression getActionExpression()

Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

Note that it's possible that the returned MethodExpression is just a wrapper around a MethodBinding instance whith was set by a call to ActionSource.setAction(javax.faces.el.MethodBinding). This makes it possible for the default ActionListener to continue to work properly with older components.

setActionExpression

void setActionExpression(MethodExpression action)

Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

Any method referenced by such an expression must be public, with a return type of String, and accept no parameters.

Parameters:
action - The new method expression
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ContextCallback

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Interface ContextCallback

public interface ContextCallback

A simple callback interace that enables taking action on a specific UIComponent (either facet or child) in the view while preserving any contextual state for that component instance in the view.

Method Summary
 void invokeContextCallback(FacesContext context, UIComponent target)
This method will be called by an implementation of UIComponent.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) and must be passed the component with the clientId given as an argument to invokeOnComponent.

Method Detail

invokeContextCallback

void invokeContextCallback(FacesContext context,
                           UIComponent target)

This method will be called by an implementation of UIComponent.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) and must be passed the component with the clientId given as an argument to invokeOnComponent. At the point in time when this method is called, the argument target is guaranteed to be in the proper state with respect to its ancestors in the View.

Parameters:
context - the FacesContext for this request.
target - the UIComponent that was located by clientId by a call to UIComponent.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback).
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EditableValueHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Interface EditableValueHolder

All Superinterfaces:
ValueHolder
All Known Implementing Classes:
HtmlInputHidden, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, HtmlSelectBooleanCheckbox, HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu, HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio, UIInput, UISelectBoolean, UISelectMany, UISelectOne
public interface EditableValueHolder
extends ValueHolder

EditableValueHolder is an extension of ValueHolder that describes additional features supported by editable components, including ValueChangeEvents and Validators.

Method Summary
 void addValidator(Validator validator)
Add a Validator instance to the set associated with this component.
 void addValueChangeListener(ValueChangeListener listener)
Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.
 Object getSubmittedValue()
Return the submittedValue value of this component.
 MethodBinding getValidator()
Deprecated. getValidators() should be used instead.
 Validator[] getValidators()
Return the set of registered Validators for this component instance.
 MethodBinding getValueChangeListener()
Deprecated. Use getValueChangeListeners() instead.
 ValueChangeListener[] getValueChangeListeners()
Return the set of registered ValueChangeListeners for this component instance.
 boolean isImmediate()
Return the "immediate" state for this component.
 boolean isLocalValueSet()
Return the "local value set" state for this component.
 boolean isRequired()
Return the "required field" state for this component.
 boolean isValid()
Return a flag indicating whether the local value of this component is valid (no conversion error has occurred).
 void removeValidator(Validator validator)
Remove a Validator instance from the set associated with this component, if it was previously associated.
 void removeValueChangeListener(ValueChangeListener listener)
Remove an existing ValueChangeListener (if any) from the set of listeners interested in being notified when ValueChangeEvents occur.
 void setImmediate(boolean immediate)
Set the "immediate" state for this component.
 void setLocalValueSet(boolean localValueSet)
Sets the "local value set" state for this component.
 void setRequired(boolean required)
Set the "required field" state for this component.
 void setSubmittedValue(Object submittedValue)
Set the submittedValue value of this component.
 void setValid(boolean valid)
Set a flag indicating whether the local value of this component is valid (no conversion error has occurred).
 void setValidator(MethodBinding validatorBinding)
Deprecated. Use addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.
 void setValueChangeListener(MethodBinding valueChangeMethod)
Deprecated. Use addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter, setValue

Method Detail

getSubmittedValue

Object getSubmittedValue()

Return the submittedValue value of this component. This method should only be used by the encodeBegin() and/or encodeEnd() methods of this component, or its corresponding Renderer.

setSubmittedValue

void setSubmittedValue(Object submittedValue)

Set the submittedValue value of this component. This method should only be used by the decode() and validate() method of this component, or its corresponding Renderer.

Parameters:
submittedValue - The new submitted value

isLocalValueSet

boolean isLocalValueSet()
Return the "local value set" state for this component. Calls to setValue() automatically reset this property to true.

setLocalValueSet

void setLocalValueSet(boolean localValueSet)
Sets the "local value set" state for this component.

isValid

boolean isValid()

Return a flag indicating whether the local value of this component is valid (no conversion error has occurred).

setValid

void setValid(boolean valid)

Set a flag indicating whether the local value of this component is valid (no conversion error has occurred).

Parameters:
valid - The new valid flag

isRequired

boolean isRequired()

Return the "required field" state for this component.

setRequired

void setRequired(boolean required)

Set the "required field" state for this component.

Parameters:
required - The new "required field" state

isImmediate

boolean isImmediate()

Return the "immediate" state for this component.

setImmediate

void setImmediate(boolean immediate)

Set the "immediate" state for this component. When set to true, the component's value will be converted and validated immediately in the Apply Request Values phase, and ValueChangeEvents will be delivered in that phase as well. The default value for this property must be false.

Parameters:
immediate - The new "immediate" state

getValidator

MethodBinding getValidator()
Deprecated. getValidators() should be used instead.

If setValidator(javax.faces.el.MethodBinding) was not previously called for this instance, this method must return null. If it was called, this method must return the exact MethodBinding instance that was passed to setValidator(javax.faces.el.MethodBinding).

This method will be called during the Process Validations or Apply Request Values phases (depending on the value of the immediate property).

setValidator

void setValidator(MethodBinding validatorBinding)
Deprecated. Use addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.

Wrap the argument validatorBinding in an implementation of Validator and store it in the internal data structure that backs the getValidators() method, taking care to over-write any instance that was stored by a previous call to setValidator.

The argument method will be called during the Process Validations or Apply Request Values phases (depending on the value of the immediate property).

Any method referenced by such an expression must be public, with a return type of void, and accept parameters of type FacesContext, UIComponent, and Object.

Parameters:
validatorBinding - The new MethodBinding instance

getValueChangeListener

MethodBinding getValueChangeListener()
Deprecated. Use getValueChangeListeners() instead.

If setValueChangeListener(javax.faces.el.MethodBinding) was not previously called for this instance, this method must return null. If it was called, this method must return the exact MethodBinding instance that was passed to setValueChangeListener(javax.faces.el.MethodBinding).

setValueChangeListener

void setValueChangeListener(MethodBinding valueChangeMethod)
Deprecated. Use addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.

Wrap the argument valueChangeMethod in an implementation of ValueChangeListener and store it in the internal data structure that backs the getValueChangeListeners() method, taking care to over-write any instance that was stored by a previous call to setValueChangeListener.

This argument method will be called during the Process Validations or Apply Request Values phases (depending on the value of the immediate property).

Any method referenced by such an expression must be public, with a return type of void, and accept a parameter of type ValueChangeEvent.

Parameters:
valueChangeMethod - The new method binding instance

addValidator

void addValidator(Validator validator)

Add a Validator instance to the set associated with this component.

Parameters:
validator - The Validator to add
Throws:
NullPointerException - if validator is null

getValidators

Validator[] getValidators()

Return the set of registered Validators for this component instance. If there are no registered validators, a zero-length array is returned.

removeValidator

void removeValidator(Validator validator)

Remove a Validator instance from the set associated with this component, if it was previously associated. Otherwise, do nothing.

Parameters:
validator - The Validator to remove

addValueChangeListener

void addValueChangeListener(ValueChangeListener listener)

Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.

Parameters:
listener - The ValueChangeListener to be added
Throws:
NullPointerException - if listener is null

getValueChangeListeners

ValueChangeListener[] getValueChangeListeners()

Return the set of registered ValueChangeListeners for this component instance. If there are no registered listeners, a zero-length array is returned.

removeValueChangeListener

void removeValueChangeListener(ValueChangeListener listener)

Remove an existing ValueChangeListener (if any) from the set of listeners interested in being notified when ValueChangeEvents occur.

Parameters:
listener - The ValueChangeListener to be removed
Throws:
NullPointerException - if listener is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


html

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.faces.component.html

Specialized user interface component classes for HTML.

See:
Description

Class Summary
HtmlColumn | Represents a column that will be rendered in an HTML table element.
HtmlCommandButton | Represents an HTML input element for a button of type submit or reset.
HtmlCommandLink | Represents an HTML a element for a hyperlink that acts like a submit button.
HtmlDataTable | Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.
HtmlForm | Represents an HTML form element.
HtmlGraphicImage | Represents an HTML img element, used to retrieve and render a graphical image.
HtmlInputHidden | Represents an HTML input element of type hidden.
HtmlInputSecret | Represents an HTML input element of type password.
HtmlInputText | Represents an HTML input element of type text.
HtmlInputTextarea | Represents an HTML textarea element.
HtmlMessage | By default, the rendererType property must be set to "javax.faces.Message".
HtmlMessages | By default, the rendererType property must be set to "javax.faces.Messages".
HtmlOutputFormat | Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result.
HtmlOutputLabel | Represents an HTML label element, used to define an accessible label for a corresponding input element.
HtmlOutputLink | Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.
HtmlOutputText | Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.
HtmlPanelGrid | Renders child components in a table, starting a new row after the specified number of columns.
HtmlPanelGroup | Causes all child components of this component to be rendered.
HtmlSelectBooleanCheckbox | Represents an HTML input element of type checkbox.
HtmlSelectManyCheckbox | Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.
HtmlSelectManyListbox | Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
HtmlSelectManyMenu | Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.
HtmlSelectOneListbox | Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.
HtmlSelectOneMenu | Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.
HtmlSelectOneRadio | Represents a single-selection component that is rendered as a set of HTML input elements of type radio.

Package javax.faces.component.html Description

Specialized user interface component classes for HTML.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.faces.component.html Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.faces.component.html

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.component.UIComponent (implements javax.faces.component.StateHolder)
      • javax.faces.component.UIComponentBase
        • javax.faces.component.UIColumn
          • javax.faces.component.html.HtmlColumn
        • javax.faces.component.UICommand (implements javax.faces.component.ActionSource2)
          • javax.faces.component.html.HtmlCommandButton
          • javax.faces.component.html.HtmlCommandLink
        • javax.faces.component.UIData (implements javax.faces.component.NamingContainer)
          • javax.faces.component.html.HtmlDataTable
        • javax.faces.component.UIForm (implements javax.faces.component.NamingContainer)
          • javax.faces.component.html.HtmlForm
        • javax.faces.component.UIGraphic
          • javax.faces.component.html.HtmlGraphicImage
        • javax.faces.component.UIMessage
          • javax.faces.component.html.HtmlMessage
        • javax.faces.component.UIMessages
          • javax.faces.component.html.HtmlMessages
        • javax.faces.component.UIOutput (implements javax.faces.component.ValueHolder)
          • javax.faces.component.html.HtmlOutputFormat
          • javax.faces.component.html.HtmlOutputLabel
          • javax.faces.component.html.HtmlOutputLink
          • javax.faces.component.html.HtmlOutputText
          • javax.faces.component.UIInput (implements javax.faces.component.EditableValueHolder)
            • javax.faces.component.html.HtmlInputHidden
            • javax.faces.component.html.HtmlInputSecret
            • javax.faces.component.html.HtmlInputText
            • javax.faces.component.html.HtmlInputTextarea
            • javax.faces.component.UISelectBoolean
              • javax.faces.component.html.HtmlSelectBooleanCheckbox
            • javax.faces.component.UISelectMany
              • javax.faces.component.html.HtmlSelectManyCheckbox
              • javax.faces.component.html.HtmlSelectManyListbox
              • javax.faces.component.html.HtmlSelectManyMenu
            • javax.faces.component.UISelectOne
              • javax.faces.component.html.HtmlSelectOneListbox
              • javax.faces.component.html.HtmlSelectOneMenu
              • javax.faces.component.html.HtmlSelectOneRadio
        • javax.faces.component.UIPanel
          • javax.faces.component.html.HtmlPanelGrid
          • javax.faces.component.html.HtmlPanelGroup
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlColumn

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlColumn

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIColumn
                extended by  javax.faces.component.html.HtmlColumn
All Implemented Interfaces:
StateHolder
public class HtmlColumn
extends UIColumn

Represents a column that will be rendered in an HTML table element.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIColumn
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlColumn()
Method Summary
String | getFooterClass() Return the value of the footerClass property.
String | getHeaderClass() Return the value of the headerClass property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setFooterClass(String footerClass) Set the value of the footerClass property.
void | setHeaderClass(String headerClass) Set the value of the headerClass property.
Methods inherited from class javax.faces.component.UIColumn
getFamily, getFooter, getHeader, setFooter, setHeader
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlColumn

public HtmlColumn()
Method Detail

getFooterClass

public String getFooterClass()

Return the value of the footerClass property.

Contents: Space-separated list of CSS style class(es) that will be applied to any footer generated for this column.

setFooterClass

public void setFooterClass(String footerClass)

Set the value of the footerClass property.

getHeaderClass

public String getHeaderClass()

Return the value of the headerClass property.

Contents: Space-separated list of CSS style class(es) that will be applied to any header generated for this column.

setHeaderClass

public void setHeaderClass(String headerClass)

Set the value of the headerClass property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlCommandButton

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlCommandButton

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UICommand
                extended by  javax.faces.component.html.HtmlCommandButton
All Implemented Interfaces:
ActionSource, ActionSource2, StateHolder
public class HtmlCommandButton
extends UICommand

Represents an HTML input element for a button of type submit or reset. The label text is specified by the component value.

By default, the rendererType property must be set to "javax.faces.Button". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UICommand
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlCommandButton()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
String | getAlt() Return the value of the alt property.
String | getDir() Return the value of the dir property.
String | getImage() Return the value of the image property.
String | getLabel() Return the value of the label property.
String | getLang() Return the value of the lang property.
String | getOnblur() Return the value of the onblur property.
String | getOnchange() Return the value of the onchange property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getOnselect() Return the value of the onselect property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTitle() Return the value of the title property.
String | getType() Return the value of the type property.
boolean | isDisabled() Return the value of the disabled property.
boolean | isReadonly() Return the value of the readonly property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setAlt(String alt) Set the value of the alt property.
void | setDir(String dir) Set the value of the dir property.
void | setDisabled(boolean disabled) Set the value of the disabled property.
void | setImage(String image) Set the value of the image property.
void | setLabel(String label) Set the value of the label property.
void | setLang(String lang) Set the value of the lang property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnchange(String onchange) Set the value of the onchange property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setOnselect(String onselect) Set the value of the onselect property.
void | setReadonly(boolean readonly) Set the value of the readonly property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTitle(String title) Set the value of the title property.
void | setType(String type) Set the value of the type property.
Methods inherited from class javax.faces.component.UICommand
addActionListener, broadcast, getAction, getActionExpression, getActionListener, getActionListeners, getFamily, getValue, isImmediate, queueEvent, removeActionListener, setAction, setActionExpression, setActionListener, setImmediate, setValue
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlCommandButton

public HtmlCommandButton()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getAlt

public String getAlt()

Return the value of the alt property.

Contents: Alternate textual description of the element rendered by this component.

setAlt

public void setAlt(String alt)

Set the value of the alt property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isDisabled

public boolean isDisabled()

Return the value of the disabled property.

Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

setDisabled

public void setDisabled(boolean disabled)

Set the value of the disabled property.

getImage

public String getImage()

Return the value of the image property.

Contents: Absolute or relative URL of the image to be displayed for this button. If specified, this "input" element will be of type "image". Otherwise, it will be of the type specified by the "type" property with a label specified by the "value" property.

setImage

public void setImage(String image)

Set the value of the image property.

getLabel

public String getLabel()

Return the value of the label property.

Contents: A localized user presentable name for this component.

setLabel

public void setLabel(String label)

Set the value of the label property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnchange

public String getOnchange()

Return the value of the onchange property.

Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

setOnchange

public void setOnchange(String onchange)

Set the value of the onchange property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getOnselect

public String getOnselect()

Return the value of the onselect property.

Contents: Javascript code executed when text within this element is selected by the user.

setOnselect

public void setOnselect(String onselect)

Set the value of the onselect property.

isReadonly

public boolean isReadonly()

Return the value of the readonly property.

Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

setReadonly

public void setReadonly(boolean readonly)

Set the value of the readonly property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

getType

public String getType()

Return the value of the type property.

Contents: Type of button to create. Valid values are "submit" and "reset". If not specified, or not a valid value, the default value is "submit".

setType

public void setType(String type)

Set the value of the type property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UICommand

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UICommand
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlCommandLink

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlCommandLink

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UICommand
                extended by  javax.faces.component.html.HtmlCommandLink
All Implemented Interfaces:
ActionSource, ActionSource2, StateHolder
public class HtmlCommandLink
extends UICommand

Represents an HTML a element for a hyperlink that acts like a submit button. This component must be placed inside a form, and requires JavaScript to be enabled in the client.

By default, the rendererType property must be set to "javax.faces.Link". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UICommand
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlCommandLink()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
String | getCharset() Return the value of the charset property.
String | getCoords() Return the value of the coords property.
String | getDir() Return the value of the dir property.
String | getHreflang() Return the value of the hreflang property.
String | getLang() Return the value of the lang property.
String | getOnblur() Return the value of the onblur property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getRel() Return the value of the rel property.
String | getRev() Return the value of the rev property.
String | getShape() Return the value of the shape property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTarget() Return the value of the target property.
String | getTitle() Return the value of the title property.
String | getType() Return the value of the type property.
boolean | isDisabled() Return the value of the disabled property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setCharset(String charset) Set the value of the charset property.
void | setCoords(String coords) Set the value of the coords property.
void | setDir(String dir) Set the value of the dir property.
void | setDisabled(boolean disabled) Set the value of the disabled property.
void | setHreflang(String hreflang) Set the value of the hreflang property.
void | setLang(String lang) Set the value of the lang property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setRel(String rel) Set the value of the rel property.
void | setRev(String rev) Set the value of the rev property.
void | setShape(String shape) Set the value of the shape property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTarget(String target) Set the value of the target property.
void | setTitle(String title) Set the value of the title property.
void | setType(String type) Set the value of the type property.
Methods inherited from class javax.faces.component.UICommand
addActionListener, broadcast, getAction, getActionExpression, getActionListener, getActionListeners, getFamily, getValue, isImmediate, queueEvent, removeActionListener, setAction, setActionExpression, setActionListener, setImmediate, setValue
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlCommandLink

public HtmlCommandLink()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getCharset

public String getCharset()

Return the value of the charset property.

Contents: The character encoding of the resource designated by this hyperlink.

setCharset

public void setCharset(String charset)

Set the value of the charset property.

getCoords

public String getCoords()

Return the value of the coords property.

Contents: The position and shape of the hot spot on the screen (for use in client-side image maps).

setCoords

public void setCoords(String coords)

Set the value of the coords property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isDisabled

public boolean isDisabled()

Return the value of the disabled property.

Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit.

setDisabled

public void setDisabled(boolean disabled)

Set the value of the disabled property.

getHreflang

public String getHreflang()

Return the value of the hreflang property.

Contents: The language code of the resource designated by this hyperlink.

setHreflang

public void setHreflang(String hreflang)

Set the value of the hreflang property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getRel

public String getRel()

Return the value of the rel property.

Contents: The relationship from the current document to the anchor specified by this hyperlink. The value of this attribute is a space-separated list of link types.

setRel

public void setRel(String rel)

Set the value of the rel property.

getRev

public String getRev()

Return the value of the rev property.

Contents: A reverse link from the anchor specified by this hyperlink to the current document. The value of this attribute is a space-separated list of link types.

setRev

public void setRev(String rev)

Set the value of the rev property.

getShape

public String getShape()

Return the value of the shape property.

Contents: The shape of the hot spot on the screen (for use in client-side image maps). Valid values are: default (entire region); rect (rectangular region); circle (circular region); and poly (polygonal region).

setShape

public void setShape(String shape)

Set the value of the shape property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTarget

public String getTarget()

Return the value of the target property.

Contents: Name of a frame where the resource retrieved via this hyperlink is to be displayed.

setTarget

public void setTarget(String target)

Set the value of the target property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

getType

public String getType()

Return the value of the type property.

Contents: The content type of the resource designated by this hyperlink.

setType

public void setType(String type)

Set the value of the type property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UICommand

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UICommand
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlDataTable

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlDataTable

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIData
                extended by  javax.faces.component.html.HtmlDataTable
All Implemented Interfaces:
NamingContainer, StateHolder
public class HtmlDataTable
extends UIData

Represents a set of repeating data (segregated into columns by child UIColumn components) that will be rendered in an HTML table element.

By default, the rendererType property must be set to "javax.faces.Table". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIData
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Fields inherited from interface javax.faces.component.NamingContainer
SEPARATOR_CHAR
Constructor Summary
HtmlDataTable()
Method Summary
String | getBgcolor() Return the value of the bgcolor property.
int | getBorder() Return the value of the border property.
String | getCaptionClass() Return the value of the captionClass property.
String | getCaptionStyle() Return the value of the captionStyle property.
String | getCellpadding() Return the value of the cellpadding property.
String | getCellspacing() Return the value of the cellspacing property.
String | getColumnClasses() Return the value of the columnClasses property.
String | getDir() Return the value of the dir property.
String | getFooterClass() Return the value of the footerClass property.
String | getFrame() Return the value of the frame property.
String | getHeaderClass() Return the value of the headerClass property.
String | getLang() Return the value of the lang property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getRowClasses() Return the value of the rowClasses property.
String | getRules() Return the value of the rules property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getSummary() Return the value of the summary property.
String | getTitle() Return the value of the title property.
String | getWidth() Return the value of the width property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setBgcolor(String bgcolor) Set the value of the bgcolor property.
void | setBorder(int border) Set the value of the border property.
void | setCaptionClass(String captionClass) Set the value of the captionClass property.
void | setCaptionStyle(String captionStyle) Set the value of the captionStyle property.
void | setCellpadding(String cellpadding) Set the value of the cellpadding property.
void | setCellspacing(String cellspacing) Set the value of the cellspacing property.
void | setColumnClasses(String columnClasses) Set the value of the columnClasses property.
void | setDir(String dir) Set the value of the dir property.
void | setFooterClass(String footerClass) Set the value of the footerClass property.
void | setFrame(String frame) Set the value of the frame property.
void | setHeaderClass(String headerClass) Set the value of the headerClass property.
void | setLang(String lang) Set the value of the lang property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setRowClasses(String rowClasses) Set the value of the rowClasses property.
void | setRules(String rules) Set the value of the rules property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setSummary(String summary) Set the value of the summary property.
void | setTitle(String title) Set the value of the title property.
void | setWidth(String width) Set the value of the width property.
Methods inherited from class javax.faces.component.UIData
broadcast, encodeBegin, getClientId, getDataModel, getFamily, getFirst, getFooter, getHeader, getRowCount, getRowData, getRowIndex, getRows, getValue, getVar, invokeOnComponent, isRowAvailable, processDecodes, processUpdates, processValidators, queueEvent, setDataModel, setFirst, setFooter, setHeader, setRowIndex, setRows, setValue, setValueBinding, setValueExpression, setVar
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, decode, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, isRendered, isTransient, processRestoreState, processSaveState, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlDataTable

public HtmlDataTable()
Method Detail

getBgcolor

public String getBgcolor()

Return the value of the bgcolor property.

Contents: Name or code of the background color for this table.

setBgcolor

public void setBgcolor(String bgcolor)

Set the value of the bgcolor property.

getBorder

public int getBorder()

Return the value of the border property.

Contents: Width (in pixels) of the border to be drawn around this table.

setBorder

public void setBorder(int border)

Set the value of the border property.

getCaptionClass

public String getCaptionClass()

Return the value of the captionClass property.

Contents: Space-separated list of CSS style class(es) that will be applied to any caption generated for this table.

setCaptionClass

public void setCaptionClass(String captionClass)

Set the value of the captionClass property.

getCaptionStyle

public String getCaptionStyle()

Return the value of the captionStyle property.

Contents: CSS style(s) to be applied when this caption is rendered.

setCaptionStyle

public void setCaptionStyle(String captionStyle)

Set the value of the captionStyle property.

getCellpadding

public String getCellpadding()

Return the value of the cellpadding property.

Contents: Definition of how much space the user agent should leave between the border of each cell and its contents.

setCellpadding

public void setCellpadding(String cellpadding)

Set the value of the cellpadding property.

getCellspacing

public String getCellspacing()

Return the value of the cellspacing property.

Contents: Definition of how much space the user agent should leave between the left side of the table and the leftmost column, the top of the table and the top of the top side of the topmost row, and so on for the right and bottom of the table. It also specifies the amount of space to leave between cells.

setCellspacing

public void setCellspacing(String cellspacing)

Set the value of the cellspacing property.

getColumnClasses

public String getColumnClasses()

Return the value of the columnClasses property.

Contents: Comma-delimited list of CSS style classes that will be applied to the columns of this table. A space separated list of classes may also be specified for any individual column. If the number of elements in this list is less than the number of columns specified in the "columns" attribute, no "class" attribute is output for each column greater than the number of elements in the list. If the number of elements in the list is greater than the number of columns specified in the "columns" attribute, the elements at the posisiton in the list after the value of the "columns" attribute are ignored.

setColumnClasses

public void setColumnClasses(String columnClasses)

Set the value of the columnClasses property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

getFooterClass

public String getFooterClass()

Return the value of the footerClass property.

Contents: Space-separated list of CSS style class(es) that will be applied to any footer generated for this table.

setFooterClass

public void setFooterClass(String footerClass)

Set the value of the footerClass property.

getFrame

public String getFrame()

Return the value of the frame property.

Contents: Code specifying which sides of the frame surrounding this table will be visible. Valid values are: none (no sides, default value); above (top side only); below (bottom side only); hsides (top and bottom sides only); vsides (right and left sides only); lhs (left hand side only); rhs (right hand side only); box (all four sides); and border (all four sides).

setFrame

public void setFrame(String frame)

Set the value of the frame property.

getHeaderClass

public String getHeaderClass()

Return the value of the headerClass property.

Contents: Space-separated list of CSS style class(es) that will be applied to any header generated for this table.

setHeaderClass

public void setHeaderClass(String headerClass)

Set the value of the headerClass property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getRowClasses

public String getRowClasses()

Return the value of the rowClasses property.

Contents: Comma-delimited list of CSS style classes that will be applied to the rows of this table. A space separated list of classes may also be specified for any individual row. Thes styles are applied, in turn, to each row in the table. For example, if the list has two elements, the first style class in the list is applied to the first row, the second to the second row, the first to the third row, the second to the fourth row, etc. In other words, we keep iterating through the list until we reach the end, and then we start at the beginning again.

setRowClasses

public void setRowClasses(String rowClasses)

Set the value of the rowClasses property.

getRules

public String getRules()

Return the value of the rules property.

Contents: Code specifying which rules will appear between cells within this table. Valid values are: none (no rules, default value); groups (between row groups); rows (between rows only); cols (between columns only); and all (between all rows and columns).

setRules

public void setRules(String rules)

Set the value of the rules property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getSummary

public String getSummary()

Return the value of the summary property.

Contents: Summary of this table's purpose and structure, for user agents rendering to non-visual media such as speech and Braille.

setSummary

public void setSummary(String summary)

Set the value of the summary property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

getWidth

public String getWidth()

Return the value of the width property.

Contents: Width of the entire table, for visual user agents.

setWidth

public void setWidth(String width)

Set the value of the width property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIData

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIData
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlForm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlForm

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIForm
                extended by  javax.faces.component.html.HtmlForm
All Implemented Interfaces:
NamingContainer, StateHolder
public class HtmlForm
extends UIForm

Represents an HTML form element. Child input components will be submitted unless they have been disabled.

By default, the rendererType property must be set to "javax.faces.Form". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIForm
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Fields inherited from interface javax.faces.component.NamingContainer
SEPARATOR_CHAR
Constructor Summary
HtmlForm()
Method Summary
String | getAccept() Return the value of the accept property.
String | getAcceptcharset() Return the value of the acceptcharset property.
String | getDir() Return the value of the dir property.
String | getEnctype() Return the value of the enctype property.
String | getLang() Return the value of the lang property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getOnreset() Return the value of the onreset property.
String | getOnsubmit() Return the value of the onsubmit property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTarget() Return the value of the target property.
String | getTitle() Return the value of the title property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccept(String accept) Set the value of the accept property.
void | setAcceptcharset(String acceptcharset) Set the value of the acceptcharset property.
void | setDir(String dir) Set the value of the dir property.
void | setEnctype(String enctype) Set the value of the enctype property.
void | setLang(String lang) Set the value of the lang property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setOnreset(String onreset) Set the value of the onreset property.
void | setOnsubmit(String onsubmit) Set the value of the onsubmit property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTarget(String target) Set the value of the target property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UIForm
getContainerClientId, getFamily, isPrependId, isSubmitted, processDecodes, processUpdates, processValidators, setPrependId, setSubmitted
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlForm

public HtmlForm()
Method Detail

getAccept

public String getAccept()

Return the value of the accept property.

Contents: List of content types that a server processing this form will handle correctly

setAccept

public void setAccept(String accept)

Set the value of the accept property.

getAcceptcharset

public String getAcceptcharset()

Return the value of the acceptcharset property.

Contents: List of character encodings for input data that are accepted by the server processing this form.

setAcceptcharset

public void setAcceptcharset(String acceptcharset)

Set the value of the acceptcharset property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

getEnctype

public String getEnctype()

Return the value of the enctype property.

Contents: Content type used to submit the form to the server. If not specified, the default value is "application/x-www-form-urlencoded".

setEnctype

public void setEnctype(String enctype)

Set the value of the enctype property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getOnreset

public String getOnreset()

Return the value of the onreset property.

Contents: Javascript code executed when this form is reset.

setOnreset

public void setOnreset(String onreset)

Set the value of the onreset property.

getOnsubmit

public String getOnsubmit()

Return the value of the onsubmit property.

Contents: Javascript code executed when this form is submitted.

setOnsubmit

public void setOnsubmit(String onsubmit)

Set the value of the onsubmit property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTarget

public String getTarget()

Return the value of the target property.

Contents: Name of a frame where the response retrieved after this form submit is to be displayed.

setTarget

public void setTarget(String target)

Set the value of the target property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlGraphicImage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlGraphicImage

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIGraphic
                extended by  javax.faces.component.html.HtmlGraphicImage
All Implemented Interfaces:
StateHolder
public class HtmlGraphicImage
extends UIGraphic

Represents an HTML img element, used to retrieve and render a graphical image.

By default, the rendererType property must be set to "javax.faces.Image". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIGraphic
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlGraphicImage()
Method Summary
String | getAlt() Return the value of the alt property.
String | getDir() Return the value of the dir property.
String | getHeight() Return the value of the height property.
String | getLang() Return the value of the lang property.
String | getLongdesc() Return the value of the longdesc property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTitle() Return the value of the title property.
String | getUsemap() Return the value of the usemap property.
String | getWidth() Return the value of the width property.
boolean | isIsmap() Return the value of the ismap property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAlt(String alt) Set the value of the alt property.
void | setDir(String dir) Set the value of the dir property.
void | setHeight(String height) Set the value of the height property.
void | setIsmap(boolean ismap) Set the value of the ismap property.
void | setLang(String lang) Set the value of the lang property.
void | setLongdesc(String longdesc) Set the value of the longdesc property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTitle(String title) Set the value of the title property.
void | setUsemap(String usemap) Set the value of the usemap property.
void | setWidth(String width) Set the value of the width property.
Methods inherited from class javax.faces.component.UIGraphic
getFamily, getUrl, getValue, getValueBinding, getValueExpression, setUrl, setValue, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlGraphicImage

public HtmlGraphicImage()
Method Detail

getAlt

public String getAlt()

Return the value of the alt property.

Contents: Alternate textual description of the element rendered by this component.

setAlt

public void setAlt(String alt)

Set the value of the alt property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

getHeight

public String getHeight()

Return the value of the height property.

Contents: Override for the height of this image.

setHeight

public void setHeight(String height)

Set the value of the height property.

isIsmap

public boolean isIsmap()

Return the value of the ismap property.

Contents: Flag indicating that this image is to be used as a server side image map. Such an image must be enclosed within a hyperlink ("a"). A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as ismap="ismap".

setIsmap

public void setIsmap(boolean ismap)

Set the value of the ismap property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getLongdesc

public String getLongdesc()

Return the value of the longdesc property.

Contents: URI to a long description of the image represented by this element.

setLongdesc

public void setLongdesc(String longdesc)

Set the value of the longdesc property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

getUsemap

public String getUsemap()

Return the value of the usemap property.

Contents: The name of a client side image map (an HTML "map" element) for which this element provides the image.

setUsemap

public void setUsemap(String usemap)

Set the value of the usemap property.

getWidth

public String getWidth()

Return the value of the width property.

Contents: Override for the width of this image.

setWidth

public void setWidth(String width)

Set the value of the width property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIGraphic

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIGraphic
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlInputHidden

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlInputHidden

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.html.HtmlInputHidden
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
public class HtmlInputHidden
extends UIInput

Represents an HTML input element of type hidden.

By default, the rendererType property must be set to "javax.faces.Hidden". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIInput
COMPONENT_FAMILY, CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlInputHidden()
Method Summary
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, compareValues, decode, getConvertedValue, getConverterMessage, getFamily, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate, validateValue
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlInputHidden

public HtmlInputHidden()
Method Detail

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIInput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIInput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlInputSecret

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlInputSecret

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.html.HtmlInputSecret
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
public class HtmlInputSecret
extends UIInput

Represents an HTML input element of type password. On a redisplay, any previously entered value will not be rendered (for security reasons) unless the redisplay property is set to true.

By default, the rendererType property must be set to "javax.faces.Secret". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIInput
COMPONENT_FAMILY, CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlInputSecret()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
String | getAlt() Return the value of the alt property.
String | getAutocomplete() Return the value of the autocomplete property.
String | getDir() Return the value of the dir property.
String | getLabel() Return the value of the label property.
String | getLang() Return the value of the lang property.
int | getMaxlength() Return the value of the maxlength property.
String | getOnblur() Return the value of the onblur property.
String | getOnchange() Return the value of the onchange property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getOnselect() Return the value of the onselect property.
int | getSize() Return the value of the size property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTitle() Return the value of the title property.
boolean | isDisabled() Return the value of the disabled property.
boolean | isReadonly() Return the value of the readonly property.
boolean | isRedisplay() Return the value of the redisplay property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setAlt(String alt) Set the value of the alt property.
void | setAutocomplete(String autocomplete) Set the value of the autocomplete property.
void | setDir(String dir) Set the value of the dir property.
void | setDisabled(boolean disabled) Set the value of the disabled property.
void | setLabel(String label) Set the value of the label property.
void | setLang(String lang) Set the value of the lang property.
void | setMaxlength(int maxlength) Set the value of the maxlength property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnchange(String onchange) Set the value of the onchange property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setOnselect(String onselect) Set the value of the onselect property.
void | setReadonly(boolean readonly) Set the value of the readonly property.
void | setRedisplay(boolean redisplay) Set the value of the redisplay property.
void | setSize(int size) Set the value of the size property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, compareValues, decode, getConvertedValue, getConverterMessage, getFamily, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate, validateValue
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlInputSecret

public HtmlInputSecret()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getAlt

public String getAlt()

Return the value of the alt property.

Contents: Alternate textual description of the element rendered by this component.

setAlt

public void setAlt(String alt)

Set the value of the alt property.

getAutocomplete

public String getAutocomplete()

Return the value of the autocomplete property.

Contents: If the value of this attribute is "off", render "off" as the value of the attribute. This indicates that the browser should disable its autocomplete feature for this component. This is useful for components that perform autocompletion and do not want the browser interfering. If this attribute is not set or the value is "on", render nothing.

setAutocomplete

public void setAutocomplete(String autocomplete)

Set the value of the autocomplete property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isDisabled

public boolean isDisabled()

Return the value of the disabled property.

Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

setDisabled

public void setDisabled(boolean disabled)

Set the value of the disabled property.

getLabel

public String getLabel()

Return the value of the label property.

Contents: A localized user presentable name for this component.

setLabel

public void setLabel(String label)

Set the value of the label property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getMaxlength

public int getMaxlength()

Return the value of the maxlength property.

Contents: The maximum number of characters that may be entered in this field.

setMaxlength

public void setMaxlength(int maxlength)

Set the value of the maxlength property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnchange

public String getOnchange()

Return the value of the onchange property.

Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

setOnchange

public void setOnchange(String onchange)

Set the value of the onchange property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getOnselect

public String getOnselect()

Return the value of the onselect property.

Contents: Javascript code executed when text within this element is selected by the user.

setOnselect

public void setOnselect(String onselect)

Set the value of the onselect property.

isReadonly

public boolean isReadonly()

Return the value of the readonly property.

Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

setReadonly

public void setReadonly(boolean readonly)

Set the value of the readonly property.

isRedisplay

public boolean isRedisplay()

Return the value of the redisplay property.

Contents: Flag indicating that any existing value in this field should be rendered when the form is created. Because this is a potential security risk, password values are not displayed by default.

setRedisplay

public void setRedisplay(boolean redisplay)

Set the value of the redisplay property.

getSize

public int getSize()

Return the value of the size property.

Contents: The number of characters used to determine the width of this field.

setSize

public void setSize(int size)

Set the value of the size property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIInput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIInput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlInputText

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlInputText

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.html.HtmlInputText
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
public class HtmlInputText
extends UIInput

Represents an HTML input element of type text.

By default, the rendererType property must be set to "javax.faces.Text". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIInput
COMPONENT_FAMILY, CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlInputText()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
String | getAlt() Return the value of the alt property.
String | getAutocomplete() Return the value of the autocomplete property.
String | getDir() Return the value of the dir property.
String | getLabel() Return the value of the label property.
String | getLang() Return the value of the lang property.
int | getMaxlength() Return the value of the maxlength property.
String | getOnblur() Return the value of the onblur property.
String | getOnchange() Return the value of the onchange property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getOnselect() Return the value of the onselect property.
int | getSize() Return the value of the size property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTitle() Return the value of the title property.
boolean | isDisabled() Return the value of the disabled property.
boolean | isReadonly() Return the value of the readonly property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setAlt(String alt) Set the value of the alt property.
void | setAutocomplete(String autocomplete) Set the value of the autocomplete property.
void | setDir(String dir) Set the value of the dir property.
void | setDisabled(boolean disabled) Set the value of the disabled property.
void | setLabel(String label) Set the value of the label property.
void | setLang(String lang) Set the value of the lang property.
void | setMaxlength(int maxlength) Set the value of the maxlength property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnchange(String onchange) Set the value of the onchange property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setOnselect(String onselect) Set the value of the onselect property.
void | setReadonly(boolean readonly) Set the value of the readonly property.
void | setSize(int size) Set the value of the size property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, compareValues, decode, getConvertedValue, getConverterMessage, getFamily, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate, validateValue
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlInputText

public HtmlInputText()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getAlt

public String getAlt()

Return the value of the alt property.

Contents: Alternate textual description of the element rendered by this component.

setAlt

public void setAlt(String alt)

Set the value of the alt property.

getAutocomplete

public String getAutocomplete()

Return the value of the autocomplete property.

Contents: If the value of this attribute is "off", render "off" as the value of the attribute. This indicates that the browser should disable its autocomplete feature for this component. This is useful for components that perform autocompletion and do not want the browser interfering. If this attribute is not set or the value is "on", render nothing.

setAutocomplete

public void setAutocomplete(String autocomplete)

Set the value of the autocomplete property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isDisabled

public boolean isDisabled()

Return the value of the disabled property.

Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

setDisabled

public void setDisabled(boolean disabled)

Set the value of the disabled property.

getLabel

public String getLabel()

Return the value of the label property.

Contents: A localized user presentable name for this component.

setLabel

public void setLabel(String label)

Set the value of the label property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getMaxlength

public int getMaxlength()

Return the value of the maxlength property.

Contents: The maximum number of characters that may be entered in this field.

setMaxlength

public void setMaxlength(int maxlength)

Set the value of the maxlength property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnchange

public String getOnchange()

Return the value of the onchange property.

Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

setOnchange

public void setOnchange(String onchange)

Set the value of the onchange property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getOnselect

public String getOnselect()

Return the value of the onselect property.

Contents: Javascript code executed when text within this element is selected by the user.

setOnselect

public void setOnselect(String onselect)

Set the value of the onselect property.

isReadonly

public boolean isReadonly()

Return the value of the readonly property.

Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

setReadonly

public void setReadonly(boolean readonly)

Set the value of the readonly property.

getSize

public int getSize()

Return the value of the size property.

Contents: The number of characters used to determine the width of this field.

setSize

public void setSize(int size)

Set the value of the size property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIInput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIInput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlInputTextarea

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlInputTextarea

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.html.HtmlInputTextarea
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
public class HtmlInputTextarea
extends UIInput

Represents an HTML textarea element.

By default, the rendererType property must be set to "javax.faces.Textarea". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIInput
COMPONENT_FAMILY, CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlInputTextarea()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
int | getCols() Return the value of the cols property.
String | getDir() Return the value of the dir property.
String | getLabel() Return the value of the label property.
String | getLang() Return the value of the lang property.
String | getOnblur() Return the value of the onblur property.
String | getOnchange() Return the value of the onchange property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getOnselect() Return the value of the onselect property.
int | getRows() Return the value of the rows property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTitle() Return the value of the title property.
boolean | isDisabled() Return the value of the disabled property.
boolean | isReadonly() Return the value of the readonly property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setCols(int cols) Set the value of the cols property.
void | setDir(String dir) Set the value of the dir property.
void | setDisabled(boolean disabled) Set the value of the disabled property.
void | setLabel(String label) Set the value of the label property.
void | setLang(String lang) Set the value of the lang property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnchange(String onchange) Set the value of the onchange property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setOnselect(String onselect) Set the value of the onselect property.
void | setReadonly(boolean readonly) Set the value of the readonly property.
void | setRows(int rows) Set the value of the rows property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, compareValues, decode, getConvertedValue, getConverterMessage, getFamily, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate, validateValue
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlInputTextarea

public HtmlInputTextarea()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getCols

public int getCols()

Return the value of the cols property.

Contents: The number of columns to be displayed.

setCols

public void setCols(int cols)

Set the value of the cols property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isDisabled

public boolean isDisabled()

Return the value of the disabled property.

Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

setDisabled

public void setDisabled(boolean disabled)

Set the value of the disabled property.

getLabel

public String getLabel()

Return the value of the label property.

Contents: A localized user presentable name for this component.

setLabel

public void setLabel(String label)

Set the value of the label property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnchange

public String getOnchange()

Return the value of the onchange property.

Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

setOnchange

public void setOnchange(String onchange)

Set the value of the onchange property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getOnselect

public String getOnselect()

Return the value of the onselect property.

Contents: Javascript code executed when text within this element is selected by the user.

setOnselect

public void setOnselect(String onselect)

Set the value of the onselect property.

isReadonly

public boolean isReadonly()

Return the value of the readonly property.

Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

setReadonly

public void setReadonly(boolean readonly)

Set the value of the readonly property.

getRows

public int getRows()

Return the value of the rows property.

Contents: The number of rows to be displayed.

setRows

public void setRows(int rows)

Set the value of the rows property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIInput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIInput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlMessage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlMessage

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIMessage
                extended by  javax.faces.component.html.HtmlMessage
All Implemented Interfaces:
StateHolder
public class HtmlMessage
extends UIMessage

By default, the rendererType property must be set to "javax.faces.Message". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIMessage
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlMessage()
Method Summary
String | getDir() Return the value of the dir property.
String | getErrorClass() Return the value of the errorClass property.
String | getErrorStyle() Return the value of the errorStyle property.
String | getFatalClass() Return the value of the fatalClass property.
String | getFatalStyle() Return the value of the fatalStyle property.
String | getInfoClass() Return the value of the infoClass property.
String | getInfoStyle() Return the value of the infoStyle property.
String | getLang() Return the value of the lang property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTitle() Return the value of the title property.
String | getWarnClass() Return the value of the warnClass property.
String | getWarnStyle() Return the value of the warnStyle property.
boolean | isTooltip() Return the value of the tooltip property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setDir(String dir) Set the value of the dir property.
void | setErrorClass(String errorClass) Set the value of the errorClass property.
void | setErrorStyle(String errorStyle) Set the value of the errorStyle property.
void | setFatalClass(String fatalClass) Set the value of the fatalClass property.
void | setFatalStyle(String fatalStyle) Set the value of the fatalStyle property.
void | setInfoClass(String infoClass) Set the value of the infoClass property.
void | setInfoStyle(String infoStyle) Set the value of the infoStyle property.
void | setLang(String lang) Set the value of the lang property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTitle(String title) Set the value of the title property.
void | setTooltip(boolean tooltip) Set the value of the tooltip property.
void | setWarnClass(String warnClass) Set the value of the warnClass property.
void | setWarnStyle(String warnStyle) Set the value of the warnStyle property.
Methods inherited from class javax.faces.component.UIMessage
getFamily, getFor, isShowDetail, isShowSummary, setFor, setShowDetail, setShowSummary
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlMessage

public HtmlMessage()
Method Detail

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

getErrorClass

public String getErrorClass()

Return the value of the errorClass property.

Contents: CSS style class to apply to any message with a severity class of "ERROR".

setErrorClass

public void setErrorClass(String errorClass)

Set the value of the errorClass property.

getErrorStyle

public String getErrorStyle()

Return the value of the errorStyle property.

Contents: CSS style(s) to apply to any message with a severity class of "ERROR".

setErrorStyle

public void setErrorStyle(String errorStyle)

Set the value of the errorStyle property.

getFatalClass

public String getFatalClass()

Return the value of the fatalClass property.

Contents: CSS style class to apply to any message with a severity class of "FATAL".

setFatalClass

public void setFatalClass(String fatalClass)

Set the value of the fatalClass property.

getFatalStyle

public String getFatalStyle()

Return the value of the fatalStyle property.

Contents: CSS style(s) to apply to any message with a severity class of "FATAL".

setFatalStyle

public void setFatalStyle(String fatalStyle)

Set the value of the fatalStyle property.

getInfoClass

public String getInfoClass()

Return the value of the infoClass property.

Contents: CSS style class to apply to any message with a severity class of "INFO".

setInfoClass

public void setInfoClass(String infoClass)

Set the value of the infoClass property.

getInfoStyle

public String getInfoStyle()

Return the value of the infoStyle property.

Contents: CSS style(s) to apply to any message with a severity class of "INFO".

setInfoStyle

public void setInfoStyle(String infoStyle)

Set the value of the infoStyle property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

isTooltip

public boolean isTooltip()

Return the value of the tooltip property.

Contents: Flag indicating whether the detail portion of the message should be displayed as a tooltip.

setTooltip

public void setTooltip(boolean tooltip)

Set the value of the tooltip property.

getWarnClass

public String getWarnClass()

Return the value of the warnClass property.

Contents: CSS style class to apply to any message with a severity class of "WARN".

setWarnClass

public void setWarnClass(String warnClass)

Set the value of the warnClass property.

getWarnStyle

public String getWarnStyle()

Return the value of the warnStyle property.

Contents: CSS style(s) to apply to any message with a severity class of "WARN".

setWarnStyle

public void setWarnStyle(String warnStyle)

Set the value of the warnStyle property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIMessage

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIMessage
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlMessages

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlMessages

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIMessages
                extended by  javax.faces.component.html.HtmlMessages
All Implemented Interfaces:
StateHolder
public class HtmlMessages
extends UIMessages

By default, the rendererType property must be set to "javax.faces.Messages". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIMessages
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlMessages()
Method Summary
String | getDir() Return the value of the dir property.
String | getErrorClass() Return the value of the errorClass property.
String | getErrorStyle() Return the value of the errorStyle property.
String | getFatalClass() Return the value of the fatalClass property.
String | getFatalStyle() Return the value of the fatalStyle property.
String | getInfoClass() Return the value of the infoClass property.
String | getInfoStyle() Return the value of the infoStyle property.
String | getLang() Return the value of the lang property.
String | getLayout() Return the value of the layout property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTitle() Return the value of the title property.
String | getWarnClass() Return the value of the warnClass property.
String | getWarnStyle() Return the value of the warnStyle property.
boolean | isTooltip() Return the value of the tooltip property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setDir(String dir) Set the value of the dir property.
void | setErrorClass(String errorClass) Set the value of the errorClass property.
void | setErrorStyle(String errorStyle) Set the value of the errorStyle property.
void | setFatalClass(String fatalClass) Set the value of the fatalClass property.
void | setFatalStyle(String fatalStyle) Set the value of the fatalStyle property.
void | setInfoClass(String infoClass) Set the value of the infoClass property.
void | setInfoStyle(String infoStyle) Set the value of the infoStyle property.
void | setLang(String lang) Set the value of the lang property.
void | setLayout(String layout) Set the value of the layout property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTitle(String title) Set the value of the title property.
void | setTooltip(boolean tooltip) Set the value of the tooltip property.
void | setWarnClass(String warnClass) Set the value of the warnClass property.
void | setWarnStyle(String warnStyle) Set the value of the warnStyle property.
Methods inherited from class javax.faces.component.UIMessages
getFamily, isGlobalOnly, isShowDetail, isShowSummary, setGlobalOnly, setShowDetail, setShowSummary
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlMessages

public HtmlMessages()
Method Detail

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

getErrorClass

public String getErrorClass()

Return the value of the errorClass property.

Contents: CSS style class to apply to any message with a severity class of "ERROR".

setErrorClass

public void setErrorClass(String errorClass)

Set the value of the errorClass property.

getErrorStyle

public String getErrorStyle()

Return the value of the errorStyle property.

Contents: CSS style(s) to apply to any message with a severity class of "ERROR".

setErrorStyle

public void setErrorStyle(String errorStyle)

Set the value of the errorStyle property.

getFatalClass

public String getFatalClass()

Return the value of the fatalClass property.

Contents: CSS style class to apply to any message with a severity class of "FATAL".

setFatalClass

public void setFatalClass(String fatalClass)

Set the value of the fatalClass property.

getFatalStyle

public String getFatalStyle()

Return the value of the fatalStyle property.

Contents: CSS style(s) to apply to any message with a severity class of "FATAL".

setFatalStyle

public void setFatalStyle(String fatalStyle)

Set the value of the fatalStyle property.

getInfoClass

public String getInfoClass()

Return the value of the infoClass property.

Contents: CSS style class to apply to any message with a severity class of "INFO".

setInfoClass

public void setInfoClass(String infoClass)

Set the value of the infoClass property.

getInfoStyle

public String getInfoStyle()

Return the value of the infoStyle property.

Contents: CSS style(s) to apply to any message with a severity class of "INFO".

setInfoStyle

public void setInfoStyle(String infoStyle)

Set the value of the infoStyle property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getLayout

public String getLayout()

Return the value of the layout property.

Contents: The type of layout markup to use when rendering error messages. Valid values are "table" (an HTML table) and "list" (an HTML list). If not specified, the default value is "list".

setLayout

public void setLayout(String layout)

Set the value of the layout property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

isTooltip

public boolean isTooltip()

Return the value of the tooltip property.

Contents: Flag indicating whether the detail portion of the message should be displayed as a tooltip.

setTooltip

public void setTooltip(boolean tooltip)

Set the value of the tooltip property.

getWarnClass

public String getWarnClass()

Return the value of the warnClass property.

Contents: CSS style class to apply to any message with a severity class of "WARN".

setWarnClass

public void setWarnClass(String warnClass)

Set the value of the warnClass property.

getWarnStyle

public String getWarnStyle()

Return the value of the warnStyle property.

Contents: CSS style(s) to apply to any message with a severity class of "WARN".

setWarnStyle

public void setWarnStyle(String warnStyle)

Set the value of the warnStyle property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIMessages

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIMessages
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlOutputFormat

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlOutputFormat

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.html.HtmlOutputFormat
All Implemented Interfaces:
StateHolder, ValueHolder
public class HtmlOutputFormat
extends UIOutput

Represents a component that looks up a localized message in a resource bundle, optionally uses it as a MessageFormat pattern string and substitutes in parameter values from nested UIParameter components, and renders the result. If the "dir" or "lang" attributes are present, render a span element and pass them through as attributes on the span.

By default, the rendererType property must be set to "javax.faces.Format". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIOutput
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlOutputFormat()
Method Summary
String | getDir() Return the value of the dir property.
String | getLang() Return the value of the lang property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTitle() Return the value of the title property.
boolean | isEscape() Return the value of the escape property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setDir(String dir) Set the value of the dir property.
void | setEscape(boolean escape) Set the value of the escape property.
void | setLang(String lang) Set the value of the lang property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UIOutput
getConverter, getFamily, getLocalValue, getValue, setConverter, setValue
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlOutputFormat

public HtmlOutputFormat()
Method Detail

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isEscape

public boolean isEscape()

Return the value of the escape property.

Contents: Flag indicating that characters that are sensitive in HTML and XML markup must be escaped. This flag is set to "true" by default.

setEscape

public void setEscape(boolean escape)

Set the value of the escape property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIOutput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIOutput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlOutputLabel

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlOutputLabel

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.html.HtmlOutputLabel
All Implemented Interfaces:
StateHolder, ValueHolder
public class HtmlOutputLabel
extends UIOutput

Represents an HTML label element, used to define an accessible label for a corresponding input element.

By default, the rendererType property must be set to "javax.faces.Label". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIOutput
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlOutputLabel()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
String | getDir() Return the value of the dir property.
String | getFor() Return the value of the for property.
String | getLang() Return the value of the lang property.
String | getOnblur() Return the value of the onblur property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTitle() Return the value of the title property.
boolean | isEscape() Return the value of the escape property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setDir(String dir) Set the value of the dir property.
void | setEscape(boolean escape) Set the value of the escape property.
void | setFor(String _for) Set the value of the for property.
void | setLang(String lang) Set the value of the lang property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UIOutput
getConverter, getFamily, getLocalValue, getValue, setConverter, setValue
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlOutputLabel

public HtmlOutputLabel()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isEscape

public boolean isEscape()

Return the value of the escape property.

Contents: Flag indicating that characters that are sensitive in HTML and XML markup must be escaped. If omitted, this flag is assumed to be "true".

setEscape

public void setEscape(boolean escape)

Set the value of the escape property.

getFor

public String getFor()

Return the value of the for property.

Contents: Client identifier of the component for which this element is a label.

setFor

public void setFor(String _for)

Set the value of the for property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIOutput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIOutput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlOutputLink

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlOutputLink

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.html.HtmlOutputLink
All Implemented Interfaces:
StateHolder, ValueHolder
public class HtmlOutputLink
extends UIOutput

Represents an HTML a (hyperlink) element that may be used to link to an arbitrary URL defined by the value property.

By default, the rendererType property must be set to "javax.faces.Link". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIOutput
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlOutputLink()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
String | getCharset() Return the value of the charset property.
String | getCoords() Return the value of the coords property.
String | getDir() Return the value of the dir property.
String | getHreflang() Return the value of the hreflang property.
String | getLang() Return the value of the lang property.
String | getOnblur() Return the value of the onblur property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getRel() Return the value of the rel property.
String | getRev() Return the value of the rev property.
String | getShape() Return the value of the shape property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTarget() Return the value of the target property.
String | getTitle() Return the value of the title property.
String | getType() Return the value of the type property.
boolean | isDisabled() Return the value of the disabled property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setCharset(String charset) Set the value of the charset property.
void | setCoords(String coords) Set the value of the coords property.
void | setDir(String dir) Set the value of the dir property.
void | setDisabled(boolean disabled) Set the value of the disabled property.
void | setHreflang(String hreflang) Set the value of the hreflang property.
void | setLang(String lang) Set the value of the lang property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setRel(String rel) Set the value of the rel property.
void | setRev(String rev) Set the value of the rev property.
void | setShape(String shape) Set the value of the shape property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTarget(String target) Set the value of the target property.
void | setTitle(String title) Set the value of the title property.
void | setType(String type) Set the value of the type property.
Methods inherited from class javax.faces.component.UIOutput
getConverter, getFamily, getLocalValue, getValue, setConverter, setValue
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlOutputLink

public HtmlOutputLink()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getCharset

public String getCharset()

Return the value of the charset property.

Contents: The character encoding of the resource designated by this hyperlink.

setCharset

public void setCharset(String charset)

Set the value of the charset property.

getCoords

public String getCoords()

Return the value of the coords property.

Contents: The position and shape of the hot spot on the screen (for use in client-side image maps).

setCoords

public void setCoords(String coords)

Set the value of the coords property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isDisabled

public boolean isDisabled()

Return the value of the disabled property.

Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit.

setDisabled

public void setDisabled(boolean disabled)

Set the value of the disabled property.

getHreflang

public String getHreflang()

Return the value of the hreflang property.

Contents: The language code of the resource designated by this hyperlink.

setHreflang

public void setHreflang(String hreflang)

Set the value of the hreflang property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getRel

public String getRel()

Return the value of the rel property.

Contents: The relationship from the current document to the anchor specified by this hyperlink. The value of this attribute is a space-separated list of link types.

setRel

public void setRel(String rel)

Set the value of the rel property.

getRev

public String getRev()

Return the value of the rev property.

Contents: A reverse link from the anchor specified by this hyperlink to the current document. The value of this attribute is a space-separated list of link types.

setRev

public void setRev(String rev)

Set the value of the rev property.

getShape

public String getShape()

Return the value of the shape property.

Contents: The shape of the hot spot on the screen (for use in client-side image maps). Valid values are: default (entire region); rect (rectangular region); circle (circular region); and poly (polygonal region).

setShape

public void setShape(String shape)

Set the value of the shape property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTarget

public String getTarget()

Return the value of the target property.

Contents: Name of a frame where the resource retrieved via this hyperlink is to be displayed.

setTarget

public void setTarget(String target)

Set the value of the target property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

getType

public String getType()

Return the value of the type property.

Contents: The content type of the resource designated by this hyperlink.

setType

public void setType(String type)

Set the value of the type property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIOutput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIOutput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlOutputText

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlOutputText

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.html.HtmlOutputText
All Implemented Interfaces:
StateHolder, ValueHolder
public class HtmlOutputText
extends UIOutput

Renders the component value as text, optionally wrapping in a span element if I18N attributes, CSS styles or style classes are specified.

By default, the rendererType property must be set to "javax.faces.Text". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIOutput
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlOutputText()
Method Summary
String | getDir() Return the value of the dir property.
String | getLang() Return the value of the lang property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTitle() Return the value of the title property.
boolean | isEscape() Return the value of the escape property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setDir(String dir) Set the value of the dir property.
void | setEscape(boolean escape) Set the value of the escape property.
void | setLang(String lang) Set the value of the lang property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UIOutput
getConverter, getFamily, getLocalValue, getValue, setConverter, setValue
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlOutputText

public HtmlOutputText()
Method Detail

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isEscape

public boolean isEscape()

Return the value of the escape property.

Contents: Flag indicating that characters that are sensitive in HTML and XML markup must be escaped. This flag is set to "true" by default.

setEscape

public void setEscape(boolean escape)

Set the value of the escape property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIOutput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIOutput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlPanelGrid

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlPanelGrid

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIPanel
                extended by  javax.faces.component.html.HtmlPanelGrid
All Implemented Interfaces:
StateHolder
public class HtmlPanelGrid
extends UIPanel

Renders child components in a table, starting a new row after the specified number of columns.

By default, the rendererType property must be set to "javax.faces.Grid". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIPanel
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlPanelGrid()
Method Summary
String | getBgcolor() Return the value of the bgcolor property.
int | getBorder() Return the value of the border property.
String | getCaptionClass() Return the value of the captionClass property.
String | getCaptionStyle() Return the value of the captionStyle property.
String | getCellpadding() Return the value of the cellpadding property.
String | getCellspacing() Return the value of the cellspacing property.
String | getColumnClasses() Return the value of the columnClasses property.
int | getColumns() Return the value of the columns property.
String | getDir() Return the value of the dir property.
String | getFooterClass() Return the value of the footerClass property.
String | getFrame() Return the value of the frame property.
String | getHeaderClass() Return the value of the headerClass property.
String | getLang() Return the value of the lang property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getRowClasses() Return the value of the rowClasses property.
String | getRules() Return the value of the rules property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getSummary() Return the value of the summary property.
String | getTitle() Return the value of the title property.
String | getWidth() Return the value of the width property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setBgcolor(String bgcolor) Set the value of the bgcolor property.
void | setBorder(int border) Set the value of the border property.
void | setCaptionClass(String captionClass) Set the value of the captionClass property.
void | setCaptionStyle(String captionStyle) Set the value of the captionStyle property.
void | setCellpadding(String cellpadding) Set the value of the cellpadding property.
void | setCellspacing(String cellspacing) Set the value of the cellspacing property.
void | setColumnClasses(String columnClasses) Set the value of the columnClasses property.
void | setColumns(int columns) Set the value of the columns property.
void | setDir(String dir) Set the value of the dir property.
void | setFooterClass(String footerClass) Set the value of the footerClass property.
void | setFrame(String frame) Set the value of the frame property.
void | setHeaderClass(String headerClass) Set the value of the headerClass property.
void | setLang(String lang) Set the value of the lang property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setRowClasses(String rowClasses) Set the value of the rowClasses property.
void | setRules(String rules) Set the value of the rules property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setSummary(String summary) Set the value of the summary property.
void | setTitle(String title) Set the value of the title property.
void | setWidth(String width) Set the value of the width property.
Methods inherited from class javax.faces.component.UIPanel
getFamily
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlPanelGrid

public HtmlPanelGrid()
Method Detail

getBgcolor

public String getBgcolor()

Return the value of the bgcolor property.

Contents: Name or code of the background color for this table.

setBgcolor

public void setBgcolor(String bgcolor)

Set the value of the bgcolor property.

getBorder

public int getBorder()

Return the value of the border property.

Contents: Width (in pixels) of the border to be drawn around this table.

setBorder

public void setBorder(int border)

Set the value of the border property.

getCaptionClass

public String getCaptionClass()

Return the value of the captionClass property.

Contents: Space-separated list of CSS style class(es) that will be applied to any caption generated for this table.

setCaptionClass

public void setCaptionClass(String captionClass)

Set the value of the captionClass property.

getCaptionStyle

public String getCaptionStyle()

Return the value of the captionStyle property.

Contents: CSS style(s) to be applied when this caption is rendered.

setCaptionStyle

public void setCaptionStyle(String captionStyle)

Set the value of the captionStyle property.

getCellpadding

public String getCellpadding()

Return the value of the cellpadding property.

Contents: Definition of how much space the user agent should leave between the border of each cell and its contents.

setCellpadding

public void setCellpadding(String cellpadding)

Set the value of the cellpadding property.

getCellspacing

public String getCellspacing()

Return the value of the cellspacing property.

Contents: Definition of how much space the user agent should leave between the left side of the table and the leftmost column, the top of the table and the top of the top side of the topmost row, and so on for the right and bottom of the table. It also specifies the amount of space to leave between cells.

setCellspacing

public void setCellspacing(String cellspacing)

Set the value of the cellspacing property.

getColumnClasses

public String getColumnClasses()

Return the value of the columnClasses property.

Contents: Comma-delimited list of CSS style classes that will be applied to the columns of this table. A space separated list of classes may also be specified for any individual column. If the number of elements in this list is less than the number of columns specified in the "columns" attribute, no "class" attribute is output for each column greater than the number of elements in the list. If the number of elements in the list is greater than the number of columns specified in the "columns" attribute, the elements at the posisiton in the list after the value of the "columns" attribute are ignored.

setColumnClasses

public void setColumnClasses(String columnClasses)

Set the value of the columnClasses property.

getColumns

public int getColumns()

Return the value of the columns property.

Contents: The number of columns to render before starting a new row.

setColumns

public void setColumns(int columns)

Set the value of the columns property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

getFooterClass

public String getFooterClass()

Return the value of the footerClass property.

Contents: Space-separated list of CSS style class(es) that will be applied to any footer generated for this table.

setFooterClass

public void setFooterClass(String footerClass)

Set the value of the footerClass property.

getFrame

public String getFrame()

Return the value of the frame property.

Contents: Code specifying which sides of the frame surrounding this table will be visible. Valid values are: none (no sides, default value); above (top side only); below (bottom side only); hsides (top and bottom sides only); vsides (right and left sides only); lhs (left hand side only); rhs (right hand side only); box (all four sides); and border (all four sides).

setFrame

public void setFrame(String frame)

Set the value of the frame property.

getHeaderClass

public String getHeaderClass()

Return the value of the headerClass property.

Contents: Space-separated list of CSS style class(es) that will be applied to any header generated for this table.

setHeaderClass

public void setHeaderClass(String headerClass)

Set the value of the headerClass property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getRowClasses

public String getRowClasses()

Return the value of the rowClasses property.

Contents: Comma-delimited list of CSS style classes that will be applied to the rows of this table. A space separated list of classes may also be specified for any individual row. Thes styles are applied, in turn, to each row in the table. For example, if the list has two elements, the first style class in the list is applied to the first row, the second to the second row, the first to the third row, the second to the fourth row, etc. In other words, we keep iterating through the list until we reach the end, and then we start at the beginning again.

setRowClasses

public void setRowClasses(String rowClasses)

Set the value of the rowClasses property.

getRules

public String getRules()

Return the value of the rules property.

Contents: Code specifying which rules will appear between cells within this table. Valid values are: none (no rules, default value); groups (between row groups); rows (between rows only); cols (between columns only); and all (between all rows and columns).

setRules

public void setRules(String rules)

Set the value of the rules property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getSummary

public String getSummary()

Return the value of the summary property.

Contents: Summary of this table's purpose and structure, for user agents rendering to non-visual media such as speech and Braille.

setSummary

public void setSummary(String summary)

Set the value of the summary property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

getWidth

public String getWidth()

Return the value of the width property.

Contents: Width of the entire table, for visual user agents.

setWidth

public void setWidth(String width)

Set the value of the width property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlPanelGroup

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlPanelGroup

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIPanel
                extended by  javax.faces.component.html.HtmlPanelGroup
All Implemented Interfaces:
StateHolder
public class HtmlPanelGroup
extends UIPanel

Causes all child components of this component to be rendered. This is useful in scenarios where a parent component is expecting a single component to be present, but the application wishes to render more than one.

By default, the rendererType property must be set to "javax.faces.Group". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UIPanel
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlPanelGroup()
Method Summary
String | getLayout() Return the value of the layout property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setLayout(String layout) Set the value of the layout property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
Methods inherited from class javax.faces.component.UIPanel
getFamily
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlPanelGroup

public HtmlPanelGroup()
Method Detail

getLayout

public String getLayout()

Return the value of the layout property.

Contents: The type of layout markup to use when rendering this group. If the value is "block" the renderer must produce an HTML "div" element. Otherwise HTML "span" element must be produced.

setLayout

public void setLayout(String layout)

Set the value of the layout property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" property on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlSelectBooleanCheckbox

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlSelectBooleanCheckbox

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.UISelectBoolean
                        extended by  javax.faces.component.html.HtmlSelectBooleanCheckbox
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
public class HtmlSelectBooleanCheckbox
extends UISelectBoolean

Represents an HTML input element of type checkbox. The checkbox will be rendered as checked, or not, based on the value of the value property.

By default, the rendererType property must be set to "javax.faces.Checkbox". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UISelectBoolean
COMPONENT_FAMILY
Fields inherited from class javax.faces.component.UIInput
CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlSelectBooleanCheckbox()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
String | getDir() Return the value of the dir property.
String | getLabel() Return the value of the label property.
String | getLang() Return the value of the lang property.
String | getOnblur() Return the value of the onblur property.
String | getOnchange() Return the value of the onchange property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getOnselect() Return the value of the onselect property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTitle() Return the value of the title property.
boolean | isDisabled() Return the value of the disabled property.
boolean | isReadonly() Return the value of the readonly property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setDir(String dir) Set the value of the dir property.
void | setDisabled(boolean disabled) Set the value of the disabled property.
void | setLabel(String label) Set the value of the label property.
void | setLang(String lang) Set the value of the lang property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnchange(String onchange) Set the value of the onchange property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setOnselect(String onselect) Set the value of the onselect property.
void | setReadonly(boolean readonly) Set the value of the readonly property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UISelectBoolean
getFamily, getValueBinding, getValueExpression, isSelected, setSelected, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, compareValues, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate, validateValue
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlSelectBooleanCheckbox

public HtmlSelectBooleanCheckbox()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isDisabled

public boolean isDisabled()

Return the value of the disabled property.

Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

setDisabled

public void setDisabled(boolean disabled)

Set the value of the disabled property.

getLabel

public String getLabel()

Return the value of the label property.

Contents: A localized user presentable name for this component.

setLabel

public void setLabel(String label)

Set the value of the label property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnchange

public String getOnchange()

Return the value of the onchange property.

Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

setOnchange

public void setOnchange(String onchange)

Set the value of the onchange property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getOnselect

public String getOnselect()

Return the value of the onselect property.

Contents: Javascript code executed when text within this element is selected by the user.

setOnselect

public void setOnselect(String onselect)

Set the value of the onselect property.

isReadonly

public boolean isReadonly()

Return the value of the readonly property.

Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

setReadonly

public void setReadonly(boolean readonly)

Set the value of the readonly property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIInput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIInput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlSelectManyCheckbox

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlSelectManyCheckbox

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.UISelectMany
                        extended by  javax.faces.component.html.HtmlSelectManyCheckbox
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
public class HtmlSelectManyCheckbox
extends UISelectMany

Represents a multiple-selection component that is rendered as a set of HTML input elements of type checkbox.

By default, the rendererType property must be set to "javax.faces.Checkbox". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UISelectMany
COMPONENT_FAMILY, INVALID_MESSAGE_ID
Fields inherited from class javax.faces.component.UIInput
CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlSelectManyCheckbox()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
int | getBorder() Return the value of the border property.
String | getDir() Return the value of the dir property.
String | getDisabledClass() Return the value of the disabledClass property.
String | getEnabledClass() Return the value of the enabledClass property.
String | getLabel() Return the value of the label property.
String | getLang() Return the value of the lang property.
String | getLayout() Return the value of the layout property.
String | getOnblur() Return the value of the onblur property.
String | getOnchange() Return the value of the onchange property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getOnselect() Return the value of the onselect property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTitle() Return the value of the title property.
boolean | isDisabled() Return the value of the disabled property.
boolean | isReadonly() Return the value of the readonly property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setBorder(int border) Set the value of the border property.
void | setDir(String dir) Set the value of the dir property.
void | setDisabled(boolean disabled) Set the value of the disabled property.
void | setDisabledClass(String disabledClass) Set the value of the disabledClass property.
void | setEnabledClass(String enabledClass) Set the value of the enabledClass property.
void | setLabel(String label) Set the value of the label property.
void | setLang(String lang) Set the value of the lang property.
void | setLayout(String layout) Set the value of the layout property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnchange(String onchange) Set the value of the onchange property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setOnselect(String onselect) Set the value of the onselect property.
void | setReadonly(boolean readonly) Set the value of the readonly property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UISelectMany
compareValues, getFamily, getSelectedValues, getValueBinding, getValueExpression, setSelectedValues, setValueBinding, setValueExpression, validateValue
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlSelectManyCheckbox

public HtmlSelectManyCheckbox()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getBorder

public int getBorder()

Return the value of the border property.

Contents: Width (in pixels) of the border to be drawn around the table containing the options list.

setBorder

public void setBorder(int border)

Set the value of the border property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isDisabled

public boolean isDisabled()

Return the value of the disabled property.

Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

setDisabled

public void setDisabled(boolean disabled)

Set the value of the disabled property.

getDisabledClass

public String getDisabledClass()

Return the value of the disabledClass property.

Contents: CSS style class to apply to the rendered label on disabled options.

setDisabledClass

public void setDisabledClass(String disabledClass)

Set the value of the disabledClass property.

getEnabledClass

public String getEnabledClass()

Return the value of the enabledClass property.

Contents: CSS style class to apply to the rendered label on enabled options.

setEnabledClass

public void setEnabledClass(String enabledClass)

Set the value of the enabledClass property.

getLabel

public String getLabel()

Return the value of the label property.

Contents: A localized user presentable name for this component.

setLabel

public void setLabel(String label)

Set the value of the label property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getLayout

public String getLayout()

Return the value of the layout property.

Contents: Orientation of the options list to be created. Valid values are "pageDirection" (list is laid out vertically), or "lineDirection" (list is laid out horizontally). If not specified, the default value is "lineDirection".

setLayout

public void setLayout(String layout)

Set the value of the layout property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnchange

public String getOnchange()

Return the value of the onchange property.

Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

setOnchange

public void setOnchange(String onchange)

Set the value of the onchange property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getOnselect

public String getOnselect()

Return the value of the onselect property.

Contents: Javascript code executed when text within this element is selected by the user.

setOnselect

public void setOnselect(String onselect)

Set the value of the onselect property.

isReadonly

public boolean isReadonly()

Return the value of the readonly property.

Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

setReadonly

public void setReadonly(boolean readonly)

Set the value of the readonly property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIInput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIInput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlSelectManyListbox

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlSelectManyListbox

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.UISelectMany
                        extended by  javax.faces.component.html.HtmlSelectManyListbox
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
public class HtmlSelectManyListbox
extends UISelectMany

Represents a multiple-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.

By default, the rendererType property must be set to "javax.faces.Listbox". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UISelectMany
COMPONENT_FAMILY, INVALID_MESSAGE_ID
Fields inherited from class javax.faces.component.UIInput
CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlSelectManyListbox()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
String | getDir() Return the value of the dir property.
String | getDisabledClass() Return the value of the disabledClass property.
String | getEnabledClass() Return the value of the enabledClass property.
String | getLabel() Return the value of the label property.
String | getLang() Return the value of the lang property.
String | getOnblur() Return the value of the onblur property.
String | getOnchange() Return the value of the onchange property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getOnselect() Return the value of the onselect property.
int | getSize() Return the value of the size property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTitle() Return the value of the title property.
boolean | isDisabled() Return the value of the disabled property.
boolean | isReadonly() Return the value of the readonly property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setDir(String dir) Set the value of the dir property.
void | setDisabled(boolean disabled) Set the value of the disabled property.
void | setDisabledClass(String disabledClass) Set the value of the disabledClass property.
void | setEnabledClass(String enabledClass) Set the value of the enabledClass property.
void | setLabel(String label) Set the value of the label property.
void | setLang(String lang) Set the value of the lang property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnchange(String onchange) Set the value of the onchange property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setOnselect(String onselect) Set the value of the onselect property.
void | setReadonly(boolean readonly) Set the value of the readonly property.
void | setSize(int size) Set the value of the size property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UISelectMany
compareValues, getFamily, getSelectedValues, getValueBinding, getValueExpression, setSelectedValues, setValueBinding, setValueExpression, validateValue
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlSelectManyListbox

public HtmlSelectManyListbox()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isDisabled

public boolean isDisabled()

Return the value of the disabled property.

Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

setDisabled

public void setDisabled(boolean disabled)

Set the value of the disabled property.

getDisabledClass

public String getDisabledClass()

Return the value of the disabledClass property.

Contents: CSS style class to apply to the rendered label on disabled options.

setDisabledClass

public void setDisabledClass(String disabledClass)

Set the value of the disabledClass property.

getEnabledClass

public String getEnabledClass()

Return the value of the enabledClass property.

Contents: CSS style class to apply to the rendered label on enabled options.

setEnabledClass

public void setEnabledClass(String enabledClass)

Set the value of the enabledClass property.

getLabel

public String getLabel()

Return the value of the label property.

Contents: A localized user presentable name for this component.

setLabel

public void setLabel(String label)

Set the value of the label property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnchange

public String getOnchange()

Return the value of the onchange property.

Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

setOnchange

public void setOnchange(String onchange)

Set the value of the onchange property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getOnselect

public String getOnselect()

Return the value of the onselect property.

Contents: Javascript code executed when text within this element is selected by the user.

setOnselect

public void setOnselect(String onselect)

Set the value of the onselect property.

isReadonly

public boolean isReadonly()

Return the value of the readonly property.

Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

setReadonly

public void setReadonly(boolean readonly)

Set the value of the readonly property.

getSize

public int getSize()

Return the value of the size property.

Contents: Number of available options to be shown at all times. If not specified, all available options are shown.

setSize

public void setSize(int size)

Set the value of the size property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIInput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIInput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlSelectManyMenu

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlSelectManyMenu

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.UISelectMany
                        extended by  javax.faces.component.html.HtmlSelectManyMenu
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
public class HtmlSelectManyMenu
extends UISelectMany

Represents a multiple-selection component that is rendered as an HTML select element, showing a single available option at a time.

By default, the rendererType property must be set to "javax.faces.Menu". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UISelectMany
COMPONENT_FAMILY, INVALID_MESSAGE_ID
Fields inherited from class javax.faces.component.UIInput
CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlSelectManyMenu()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
String | getDir() Return the value of the dir property.
String | getDisabledClass() Return the value of the disabledClass property.
String | getEnabledClass() Return the value of the enabledClass property.
String | getLabel() Return the value of the label property.
String | getLang() Return the value of the lang property.
String | getOnblur() Return the value of the onblur property.
String | getOnchange() Return the value of the onchange property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getOnselect() Return the value of the onselect property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTitle() Return the value of the title property.
boolean | isDisabled() Return the value of the disabled property.
boolean | isReadonly() Return the value of the readonly property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setDir(String dir) Set the value of the dir property.
void | setDisabled(boolean disabled) Set the value of the disabled property.
void | setDisabledClass(String disabledClass) Set the value of the disabledClass property.
void | setEnabledClass(String enabledClass) Set the value of the enabledClass property.
void | setLabel(String label) Set the value of the label property.
void | setLang(String lang) Set the value of the lang property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnchange(String onchange) Set the value of the onchange property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setOnselect(String onselect) Set the value of the onselect property.
void | setReadonly(boolean readonly) Set the value of the readonly property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UISelectMany
compareValues, getFamily, getSelectedValues, getValueBinding, getValueExpression, setSelectedValues, setValueBinding, setValueExpression, validateValue
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlSelectManyMenu

public HtmlSelectManyMenu()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isDisabled

public boolean isDisabled()

Return the value of the disabled property.

Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

setDisabled

public void setDisabled(boolean disabled)

Set the value of the disabled property.

getDisabledClass

public String getDisabledClass()

Return the value of the disabledClass property.

Contents: CSS style class to apply to the rendered label on disabled options.

setDisabledClass

public void setDisabledClass(String disabledClass)

Set the value of the disabledClass property.

getEnabledClass

public String getEnabledClass()

Return the value of the enabledClass property.

Contents: CSS style class to apply to the rendered label on enabled options.

setEnabledClass

public void setEnabledClass(String enabledClass)

Set the value of the enabledClass property.

getLabel

public String getLabel()

Return the value of the label property.

Contents: A localized user presentable name for this component.

setLabel

public void setLabel(String label)

Set the value of the label property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnchange

public String getOnchange()

Return the value of the onchange property.

Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

setOnchange

public void setOnchange(String onchange)

Set the value of the onchange property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getOnselect

public String getOnselect()

Return the value of the onselect property.

Contents: Javascript code executed when text within this element is selected by the user.

setOnselect

public void setOnselect(String onselect)

Set the value of the onselect property.

isReadonly

public boolean isReadonly()

Return the value of the readonly property.

Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

setReadonly

public void setReadonly(boolean readonly)

Set the value of the readonly property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIInput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIInput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlSelectOneListbox

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlSelectOneListbox

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.UISelectOne
                        extended by  javax.faces.component.html.HtmlSelectOneListbox
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
public class HtmlSelectOneListbox
extends UISelectOne

Represents a single-selection component that is rendered as an HTML select element, showing either all available options or the specified number of options.

By default, the rendererType property must be set to "javax.faces.Listbox". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UISelectOne
COMPONENT_FAMILY, INVALID_MESSAGE_ID
Fields inherited from class javax.faces.component.UIInput
CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlSelectOneListbox()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
String | getDir() Return the value of the dir property.
String | getDisabledClass() Return the value of the disabledClass property.
String | getEnabledClass() Return the value of the enabledClass property.
String | getLabel() Return the value of the label property.
String | getLang() Return the value of the lang property.
String | getOnblur() Return the value of the onblur property.
String | getOnchange() Return the value of the onchange property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getOnselect() Return the value of the onselect property.
int | getSize() Return the value of the size property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTitle() Return the value of the title property.
boolean | isDisabled() Return the value of the disabled property.
boolean | isReadonly() Return the value of the readonly property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setDir(String dir) Set the value of the dir property.
void | setDisabled(boolean disabled) Set the value of the disabled property.
void | setDisabledClass(String disabledClass) Set the value of the disabledClass property.
void | setEnabledClass(String enabledClass) Set the value of the enabledClass property.
void | setLabel(String label) Set the value of the label property.
void | setLang(String lang) Set the value of the lang property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnchange(String onchange) Set the value of the onchange property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setOnselect(String onselect) Set the value of the onselect property.
void | setReadonly(boolean readonly) Set the value of the readonly property.
void | setSize(int size) Set the value of the size property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UISelectOne
getFamily, validateValue
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, compareValues, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlSelectOneListbox

public HtmlSelectOneListbox()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isDisabled

public boolean isDisabled()

Return the value of the disabled property.

Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

setDisabled

public void setDisabled(boolean disabled)

Set the value of the disabled property.

getDisabledClass

public String getDisabledClass()

Return the value of the disabledClass property.

Contents: CSS style class to apply to the rendered label on disabled options.

setDisabledClass

public void setDisabledClass(String disabledClass)

Set the value of the disabledClass property.

getEnabledClass

public String getEnabledClass()

Return the value of the enabledClass property.

Contents: CSS style class to apply to the rendered label on enabled options.

setEnabledClass

public void setEnabledClass(String enabledClass)

Set the value of the enabledClass property.

getLabel

public String getLabel()

Return the value of the label property.

Contents: A localized user presentable name for this component.

setLabel

public void setLabel(String label)

Set the value of the label property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnchange

public String getOnchange()

Return the value of the onchange property.

Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

setOnchange

public void setOnchange(String onchange)

Set the value of the onchange property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getOnselect

public String getOnselect()

Return the value of the onselect property.

Contents: Javascript code executed when text within this element is selected by the user.

setOnselect

public void setOnselect(String onselect)

Set the value of the onselect property.

isReadonly

public boolean isReadonly()

Return the value of the readonly property.

Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

setReadonly

public void setReadonly(boolean readonly)

Set the value of the readonly property.

getSize

public int getSize()

Return the value of the size property.

Contents: Number of available options to be shown at all times. If not specified, all available options are shown.

setSize

public void setSize(int size)

Set the value of the size property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIInput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIInput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlSelectOneMenu

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlSelectOneMenu

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.UISelectOne
                        extended by  javax.faces.component.html.HtmlSelectOneMenu
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
public class HtmlSelectOneMenu
extends UISelectOne

Represents a single-selection component that is rendered as an HTML select element, showing a single available option at a time.

By default, the rendererType property must be set to "javax.faces.Menu". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UISelectOne
COMPONENT_FAMILY, INVALID_MESSAGE_ID
Fields inherited from class javax.faces.component.UIInput
CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlSelectOneMenu()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
String | getDir() Return the value of the dir property.
String | getDisabledClass() Return the value of the disabledClass property.
String | getEnabledClass() Return the value of the enabledClass property.
String | getLabel() Return the value of the label property.
String | getLang() Return the value of the lang property.
String | getOnblur() Return the value of the onblur property.
String | getOnchange() Return the value of the onchange property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getOnselect() Return the value of the onselect property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTitle() Return the value of the title property.
boolean | isDisabled() Return the value of the disabled property.
boolean | isReadonly() Return the value of the readonly property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setDir(String dir) Set the value of the dir property.
void | setDisabled(boolean disabled) Set the value of the disabled property.
void | setDisabledClass(String disabledClass) Set the value of the disabledClass property.
void | setEnabledClass(String enabledClass) Set the value of the enabledClass property.
void | setLabel(String label) Set the value of the label property.
void | setLang(String lang) Set the value of the lang property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnchange(String onchange) Set the value of the onchange property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setOnselect(String onselect) Set the value of the onselect property.
void | setReadonly(boolean readonly) Set the value of the readonly property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UISelectOne
getFamily, validateValue
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, compareValues, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlSelectOneMenu

public HtmlSelectOneMenu()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isDisabled

public boolean isDisabled()

Return the value of the disabled property.

Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

setDisabled

public void setDisabled(boolean disabled)

Set the value of the disabled property.

getDisabledClass

public String getDisabledClass()

Return the value of the disabledClass property.

Contents: CSS style class to apply to the rendered label on disabled options.

setDisabledClass

public void setDisabledClass(String disabledClass)

Set the value of the disabledClass property.

getEnabledClass

public String getEnabledClass()

Return the value of the enabledClass property.

Contents: CSS style class to apply to the rendered label on enabled options.

setEnabledClass

public void setEnabledClass(String enabledClass)

Set the value of the enabledClass property.

getLabel

public String getLabel()

Return the value of the label property.

Contents: A localized user presentable name for this component.

setLabel

public void setLabel(String label)

Set the value of the label property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnchange

public String getOnchange()

Return the value of the onchange property.

Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

setOnchange

public void setOnchange(String onchange)

Set the value of the onchange property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getOnselect

public String getOnselect()

Return the value of the onselect property.

Contents: Javascript code executed when text within this element is selected by the user.

setOnselect

public void setOnselect(String onselect)

Set the value of the onselect property.

isReadonly

public boolean isReadonly()

Return the value of the readonly property.

Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

setReadonly

public void setReadonly(boolean readonly)

Set the value of the readonly property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIInput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIInput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HtmlSelectOneRadio

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.component.html
Class HtmlSelectOneRadio

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.UISelectOne
                        extended by  javax.faces.component.html.HtmlSelectOneRadio
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
public class HtmlSelectOneRadio
extends UISelectOne

Represents a single-selection component that is rendered as a set of HTML input elements of type radio.

By default, the rendererType property must be set to "javax.faces.Radio". This value can be changed by calling the setRendererType() method.

Field Summary
static String COMPONENT_TYPE
The standard component type for this component.
Fields inherited from class javax.faces.component.UISelectOne
COMPONENT_FAMILY, INVALID_MESSAGE_ID
Fields inherited from class javax.faces.component.UIInput
CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
HtmlSelectOneRadio()
Method Summary
String | getAccesskey() Return the value of the accesskey property.
int | getBorder() Return the value of the border property.
String | getDir() Return the value of the dir property.
String | getDisabledClass() Return the value of the disabledClass property.
String | getEnabledClass() Return the value of the enabledClass property.
String | getLabel() Return the value of the label property.
String | getLang() Return the value of the lang property.
String | getLayout() Return the value of the layout property.
String | getOnblur() Return the value of the onblur property.
String | getOnchange() Return the value of the onchange property.
String | getOnclick() Return the value of the onclick property.
String | getOndblclick() Return the value of the ondblclick property.
String | getOnfocus() Return the value of the onfocus property.
String | getOnkeydown() Return the value of the onkeydown property.
String | getOnkeypress() Return the value of the onkeypress property.
String | getOnkeyup() Return the value of the onkeyup property.
String | getOnmousedown() Return the value of the onmousedown property.
String | getOnmousemove() Return the value of the onmousemove property.
String | getOnmouseout() Return the value of the onmouseout property.
String | getOnmouseover() Return the value of the onmouseover property.
String | getOnmouseup() Return the value of the onmouseup property.
String | getOnselect() Return the value of the onselect property.
String | getStyle() Return the value of the style property.
String | getStyleClass() Return the value of the styleClass property.
String | getTabindex() Return the value of the tabindex property.
String | getTitle() Return the value of the title property.
boolean | isDisabled() Return the value of the disabled property.
boolean | isReadonly() Return the value of the readonly property.
void | restoreState(FacesContext _context, Object _state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext _context) Gets the state of the instance as a Serializable Object.
void | setAccesskey(String accesskey) Set the value of the accesskey property.
void | setBorder(int border) Set the value of the border property.
void | setDir(String dir) Set the value of the dir property.
void | setDisabled(boolean disabled) Set the value of the disabled property.
void | setDisabledClass(String disabledClass) Set the value of the disabledClass property.
void | setEnabledClass(String enabledClass) Set the value of the enabledClass property.
void | setLabel(String label) Set the value of the label property.
void | setLang(String lang) Set the value of the lang property.
void | setLayout(String layout) Set the value of the layout property.
void | setOnblur(String onblur) Set the value of the onblur property.
void | setOnchange(String onchange) Set the value of the onchange property.
void | setOnclick(String onclick) Set the value of the onclick property.
void | setOndblclick(String ondblclick) Set the value of the ondblclick property.
void | setOnfocus(String onfocus) Set the value of the onfocus property.
void | setOnkeydown(String onkeydown) Set the value of the onkeydown property.
void | setOnkeypress(String onkeypress) Set the value of the onkeypress property.
void | setOnkeyup(String onkeyup) Set the value of the onkeyup property.
void | setOnmousedown(String onmousedown) Set the value of the onmousedown property.
void | setOnmousemove(String onmousemove) Set the value of the onmousemove property.
void | setOnmouseout(String onmouseout) Set the value of the onmouseout property.
void | setOnmouseover(String onmouseover) Set the value of the onmouseover property.
void | setOnmouseup(String onmouseup) Set the value of the onmouseup property.
void | setOnselect(String onselect) Set the value of the onselect property.
void | setReadonly(boolean readonly) Set the value of the readonly property.
void | setStyle(String style) Set the value of the style property.
void | setStyleClass(String styleClass) Set the value of the styleClass property.
void | setTabindex(String tabindex) Set the value of the tabindex property.
void | setTitle(String title) Set the value of the title property.
Methods inherited from class javax.faces.component.UISelectOne
getFamily, validateValue
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, compareValues, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values
Constructor Detail

HtmlSelectOneRadio

public HtmlSelectOneRadio()
Method Detail

getAccesskey

public String getAccesskey()

Return the value of the accesskey property.

Contents: Access key that, when pressed, transfers focus to this element.

setAccesskey

public void setAccesskey(String accesskey)

Set the value of the accesskey property.

getBorder

public int getBorder()

Return the value of the border property.

Contents: Width (in pixels) of the border to be drawn around the table containing the options list.

setBorder

public void setBorder(int border)

Set the value of the border property.

getDir

public String getDir()

Return the value of the dir property.

Contents: Direction indication for text that does not inherit directionality. Valid values are "LTR" (left-to-right) and "RTL" (right-to-left).

setDir

public void setDir(String dir)

Set the value of the dir property.

isDisabled

public boolean isDisabled()

Return the value of the disabled property.

Contents: Flag indicating that this element must never receive focus or be included in a subsequent submit. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as disabled="disabled".

setDisabled

public void setDisabled(boolean disabled)

Set the value of the disabled property.

getDisabledClass

public String getDisabledClass()

Return the value of the disabledClass property.

Contents: CSS style class to apply to the rendered label on disabled options.

setDisabledClass

public void setDisabledClass(String disabledClass)

Set the value of the disabledClass property.

getEnabledClass

public String getEnabledClass()

Return the value of the enabledClass property.

Contents: CSS style class to apply to the rendered label on enabled options.

setEnabledClass

public void setEnabledClass(String enabledClass)

Set the value of the enabledClass property.

getLabel

public String getLabel()

Return the value of the label property.

Contents: A localized user presentable name for this component.

setLabel

public void setLabel(String label)

Set the value of the label property.

getLang

public String getLang()

Return the value of the lang property.

Contents: Code describing the language used in the generated markup for this component.

setLang

public void setLang(String lang)

Set the value of the lang property.

getLayout

public String getLayout()

Return the value of the layout property.

Contents: Orientation of the options list to be created. Valid values are "pageDirection" (list is laid out vertically), or "lineDirection" (list is laid out horizontally). If not specified, the default value is "lineDirection".

setLayout

public void setLayout(String layout)

Set the value of the layout property.

getOnblur

public String getOnblur()

Return the value of the onblur property.

Contents: Javascript code executed when this element loses focus.

setOnblur

public void setOnblur(String onblur)

Set the value of the onblur property.

getOnchange

public String getOnchange()

Return the value of the onchange property.

Contents: Javascript code executed when this element loses focus and its value has been modified since gaining focus.

setOnchange

public void setOnchange(String onchange)

Set the value of the onchange property.

getOnclick

public String getOnclick()

Return the value of the onclick property.

Contents: Javascript code executed when a pointer button is clicked over this element.

setOnclick

public void setOnclick(String onclick)

Set the value of the onclick property.

getOndblclick

public String getOndblclick()

Return the value of the ondblclick property.

Contents: Javascript code executed when a pointer button is double clicked over this element.

setOndblclick

public void setOndblclick(String ondblclick)

Set the value of the ondblclick property.

getOnfocus

public String getOnfocus()

Return the value of the onfocus property.

Contents: Javascript code executed when this element receives focus.

setOnfocus

public void setOnfocus(String onfocus)

Set the value of the onfocus property.

getOnkeydown

public String getOnkeydown()

Return the value of the onkeydown property.

Contents: Javascript code executed when a key is pressed down over this element.

setOnkeydown

public void setOnkeydown(String onkeydown)

Set the value of the onkeydown property.

getOnkeypress

public String getOnkeypress()

Return the value of the onkeypress property.

Contents: Javascript code executed when a key is pressed and released over this element.

setOnkeypress

public void setOnkeypress(String onkeypress)

Set the value of the onkeypress property.

getOnkeyup

public String getOnkeyup()

Return the value of the onkeyup property.

Contents: Javascript code executed when a key is released over this element.

setOnkeyup

public void setOnkeyup(String onkeyup)

Set the value of the onkeyup property.

getOnmousedown

public String getOnmousedown()

Return the value of the onmousedown property.

Contents: Javascript code executed when a pointer button is pressed down over this element.

setOnmousedown

public void setOnmousedown(String onmousedown)

Set the value of the onmousedown property.

getOnmousemove

public String getOnmousemove()

Return the value of the onmousemove property.

Contents: Javascript code executed when a pointer button is moved within this element.

setOnmousemove

public void setOnmousemove(String onmousemove)

Set the value of the onmousemove property.

getOnmouseout

public String getOnmouseout()

Return the value of the onmouseout property.

Contents: Javascript code executed when a pointer button is moved away from this element.

setOnmouseout

public void setOnmouseout(String onmouseout)

Set the value of the onmouseout property.

getOnmouseover

public String getOnmouseover()

Return the value of the onmouseover property.

Contents: Javascript code executed when a pointer button is moved onto this element.

setOnmouseover

public void setOnmouseover(String onmouseover)

Set the value of the onmouseover property.

getOnmouseup

public String getOnmouseup()

Return the value of the onmouseup property.

Contents: Javascript code executed when a pointer button is released over this element.

setOnmouseup

public void setOnmouseup(String onmouseup)

Set the value of the onmouseup property.

getOnselect

public String getOnselect()

Return the value of the onselect property.

Contents: Javascript code executed when text within this element is selected by the user.

setOnselect

public void setOnselect(String onselect)

Set the value of the onselect property.

isReadonly

public boolean isReadonly()

Return the value of the readonly property.

Contents: Flag indicating that this component will prohibit changes by the user. The element may receive focus unless it has also been disabled. A value of false causes no attribute to be rendered, while a value of true causes the attribute to be rendered as readonly="readonly".

setReadonly

public void setReadonly(boolean readonly)

Set the value of the readonly property.

getStyle

public String getStyle()

Return the value of the style property.

Contents: CSS style(s) to be applied when this component is rendered.

setStyle

public void setStyle(String style)

Set the value of the style property.

getStyleClass

public String getStyleClass()

Return the value of the styleClass property.

Contents: Space-separated list of CSS style class(es) to be applied when this element is rendered. This value must be passed through as the "class" attribute on generated markup.

setStyleClass

public void setStyleClass(String styleClass)

Set the value of the styleClass property.

getTabindex

public String getTabindex()

Return the value of the tabindex property.

Contents: Position of this element in the tabbing order for the current document. This value must be an integer between 0 and 32767.

setTabindex

public void setTabindex(String tabindex)

Set the value of the tabindex property.

getTitle

public String getTitle()

Return the value of the title property.

Contents: Advisory title information about markup elements generated for this component.

setTitle

public void setTitle(String title)

Set the value of the title property.

saveState

public Object saveState(FacesContext _context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIInput

restoreState

public void restoreState(FacesContext _context,
                         Object _state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIInput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NamingContainer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Interface NamingContainer

All Known Implementing Classes:
HtmlDataTable, HtmlForm, UIData, UIForm, UINamingContainer
public interface NamingContainer

NamingContainer is an interface that must be implemented by any UIComponent that wants to be a naming container. Naming containers affect the behavior of the UIComponent.findComponent(java.lang.String) and UIComponent.getClientId(javax.faces.context.FacesContext) methods; see those methods for further information.

Field Summary
static char SEPARATOR_CHAR
The separator character used in component identifiers to demarcate navigation to a child naming container.

Field Detail

SEPARATOR_CHAR

static final char SEPARATOR_CHAR

The separator character used in component identifiers to demarcate navigation to a child naming container.

See Also:
Constant Field Values
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StateHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Interface StateHolder

All Known Implementing Classes:
DateTimeConverter, DoubleRangeValidator, EnumConverter, HtmlColumn, HtmlCommandButton, HtmlCommandLink, HtmlDataTable, HtmlForm, HtmlGraphicImage, HtmlInputHidden, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, HtmlMessage, HtmlMessages, HtmlOutputFormat, HtmlOutputLabel, HtmlOutputLink, HtmlOutputText, HtmlPanelGrid, HtmlPanelGroup, HtmlSelectBooleanCheckbox, HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu, HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio, LengthValidator, LongRangeValidator, MethodExpressionActionListener, MethodExpressionValidator, MethodExpressionValueChangeListener, NumberConverter, UIColumn, UICommand, UIComponent, UIComponentBase, UIData, UIForm, UIGraphic, UIInput, UIMessage, UIMessages, UINamingContainer, UIOutput, UIPanel, UIParameter, UISelectBoolean, UISelectItem, UISelectItems, UISelectMany, UISelectOne, UIViewRoot
public interface StateHolder

This interface is implemented by classes that need to save their state between requests.

An implementor must implement both saveState(javax.faces.context.FacesContext) and restoreState(javax.faces.context.FacesContext, java.lang.Object) methods in this class, since these two methods have a tightly coupled contract between themselves. In other words, if there is an ineritance hierarchy, it is not permissable to have the saveState(javax.faces.context.FacesContext) and restoreState(javax.faces.context.FacesContext, java.lang.Object) methods reside at different levels of the hierarchy.

An implementor must have a public no-args constructor.

Method Summary
boolean | isTransient() If true, the Object implementing this interface must not participate in state saving or restoring.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setTransient(boolean newTransientValue) Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

Method Detail

saveState

Object saveState(FacesContext context)

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Throws:
NullPointerException - if context is null

restoreState

void restoreState(FacesContext context,
                  Object state)

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Throws:
NullPointerException - if either context or state are null

isTransient

boolean isTransient()

If true, the Object implementing this interface must not participate in state saving or restoring.

setTransient

void setTransient(boolean newTransientValue)

Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

Parameters:
newTransientValue - boolean pass true if this Object will participate in state saving or restoring, otherwise pass false.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIColumn

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UIColumn

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIColumn
All Implemented Interfaces:
StateHolder
Direct Known Subclasses:
HtmlColumn
public class UIColumn
extends UIComponentBase

UIColumn is a UIComponent that represents a single column of data within a parent UIData component.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UIColumn()
Create a new UIColumn instance with default property values.
Method Summary
String | getFamily() Return the identifier of the component family to which this component belongs.
UIComponent | getFooter() Return the footer facet of the column (if any).
UIComponent | getHeader() Return the header facet of the column (if any).
void | setFooter(UIComponent footer) Set the footer facet of the column.
void | setHeader(UIComponent header) Set the header facet of the column.
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UIColumn

public UIColumn()

Create a new UIColumn instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent

getFooter

public UIComponent getFooter()

Return the footer facet of the column (if any). A convenience method for getFacet("footer").

setFooter

public void setFooter(UIComponent footer)

Set the footer facet of the column. A convenience method for getFacets().put("footer", footer).

Parameters:
footer - the new footer facet
Throws:
NullPointerException - if footer is null

getHeader

public UIComponent getHeader()

Return the header facet of the column (if any). A convenience method for getFacet("header").

setHeader

public void setHeader(UIComponent header)

Set the header facet of the column. A convenience method for getFacets().put("header", header).

Parameters:
header - the new header facet
Throws:
NullPointerException - if header is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UICommand

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UICommand

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UICommand
All Implemented Interfaces:
ActionSource, ActionSource2, StateHolder
Direct Known Subclasses:
HtmlCommandButton, HtmlCommandLink
public class UICommand
extends UIComponentBase
implements ActionSource2

UICommand is a UIComponent that represents a user interface component which, when activated by the user, triggers an application specific "command" or "action". Such a component is typically rendered as a push button, a menu item, or a hyperlink.

When the decode() method of this UICommand, or its corresponding Renderer, detects that this control has been activated, it will queue an ActionEvent. Later on, the broadcast() method will ensure that this event is broadcast to all interested listeners.

Listeners will be invoked in the following order:

  1. ActionListeners, in the order in which they were registered.
  2. The "actionListener" MethodExpression (which will cover the "actionListener" that was set as a MethodBinding).
  3. The default ActionListener, retrieved from the Application - and therefore, any attached "action" MethodExpression.

By default, the rendererType property must be set to "javax.faces.Button". This value can be changed by calling the setRendererType() method.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UICommand()
Create a new UICommand instance with default property values.
Method Summary
 void addActionListener(ActionListener listener)
Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.
 void broadcast(FacesEvent event)
In addition to to the default UIComponent.broadcast(javax.faces.event.FacesEvent) processing, pass the ActionEvent being broadcast to the method referenced by actionListener (if any), and to the default ActionListener registered on the Application.
 MethodBinding getAction()
Deprecated. This has been replaced by getActionExpression().
 MethodExpression getActionExpression()
Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
 MethodBinding getActionListener()
Deprecated. Use getActionListeners() instead.
 ActionListener[] getActionListeners()
Return the set of registered ActionListeners for this ActionSource instance.
 String getFamily()
Return the identifier of the component family to which this component belongs.
 Object getValue()
Returns the value property of the UICommand.
 boolean isImmediate()
Return a flag indicating that the default ActionListener provided by the JavaServer Faces implementation should be executed immediately (that is, during Apply Request Values phase of the request processing lifecycle), rather than waiting until the Invoke Application phase.
 void queueEvent(FacesEvent e)
Intercept queueEvent and, for ActionEvents, mark the phaseId for the event to be PhaseId.APPLY_REQUEST_VALUES if the immediate flag is true, PhaseId.INVOKE_APPLICATION otherwise.
 void removeActionListener(ActionListener listener)
Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.
 void restoreState(FacesContext context, Object state)
Perform any processing required to restore the state from the entries in the state Object.
 Object saveState(FacesContext context)
Gets the state of the instance as a Serializable Object.
 void setAction(MethodBinding action)
Deprecated. This has been replaced by setActionExpression(javax.el.MethodExpression).
 void setActionExpression(MethodExpression actionExpression)
Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.
 void setActionListener(MethodBinding actionListener)
Deprecated. This has been replaced by addActionListener(javax.faces.event.ActionListener).
 void setImmediate(boolean immediate)
Set the "immediate execution" flag for this UIComponent.
 void setValue(Object value)
Sets the value property of the UICommand.
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UICommand

public UICommand()

Create a new UICommand instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent

getAction

public MethodBinding getAction()
Deprecated. This has been replaced by getActionExpression().

If the implementing class also implements ActionSource2, the implementation of this method must call through to ActionSource2.getActionExpression() and examine the result. If the result came from a previous call to ActionSource.setAction(javax.faces.el.MethodBinding), extract the MethodBinding from it and return it. Otherwise, wrap the returned MethodExpression in a MethodBinding implementation, and return it.

If the implementing class does not implement ActionSource2, return the MethodBindingpointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

Specified by:
getAction in interface ActionSource

setAction

public void setAction(MethodBinding action)
Deprecated. This has been replaced by setActionExpression(javax.el.MethodExpression).

If the implementing class also implements ActionSource2, the implementation of this method must wrap the argument action in a class that implements MethodExpression and call through to ActionSource2.setActionExpression(javax.el.MethodExpression), passing the wrapped action.

If the implementing class does not implement ActionSource2, set the MethodBinding pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

Any method referenced by such an expression must be public, with a return type of String, and accept no parameters.

Specified by:
setAction in interface ActionSource
Parameters:
action - The new MethodBinding expression

getActionListener

public MethodBinding getActionListener()
Deprecated. Use getActionListeners() instead.

If ActionSource.setActionListener(javax.faces.el.MethodBinding) was not previously called for this instance, this method must return null. If it was called, this method must return the exact MethodBinding instance that was passed to ActionSource.setActionListener(javax.faces.el.MethodBinding).

The method to be invoked, if this UIComponent is activated by the user, will be called during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending upon the value of the immediate property.

Specified by:
getActionListener in interface ActionSource

setActionListener

public void setActionListener(MethodBinding actionListener)
Deprecated. This has been replaced by addActionListener(javax.faces.event.ActionListener).

Wrap the argument actionListener in an implementation of ActionListener and store it in the internal data structure that backs the ActionSource.getActionListeners() method, taking care to over-write any instance that was stored by a previous call to setActionListener.

Any method referenced by such an expression must be public, with a return type of void, and accept a single parameter of type ActionEvent.

Specified by:
setActionListener in interface ActionSource
Parameters:
actionListener - The new method binding expression

isImmediate

public boolean isImmediate()
Description copied from interface: ActionSource

Return a flag indicating that the default ActionListener provided by the JavaServer Faces implementation should be executed immediately (that is, during Apply Request Values phase of the request processing lifecycle), rather than waiting until the Invoke Application phase. The default value for this property must be false.

Specified by:
isImmediate in interface ActionSource

setImmediate

public void setImmediate(boolean immediate)
Description copied from interface: ActionSource

Set the "immediate execution" flag for this UIComponent.

Specified by:
setImmediate in interface ActionSource
Parameters:
immediate - The new immediate execution flag

getValue

public Object getValue()

Returns the value property of the UICommand. This is most often rendered as a label.

setValue

public void setValue(Object value)

Sets the value property of the UICommand. This is most often rendered as a label.

Parameters:
value - the new value

getActionExpression

public MethodExpression getActionExpression()
Description copied from interface: ActionSource2

Return the MethodExpression pointing at the application action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

Note that it's possible that the returned MethodExpression is just a wrapper around a MethodBinding instance whith was set by a call to ActionSource.setAction(javax.faces.el.MethodBinding). This makes it possible for the default ActionListener to continue to work properly with older components.

Specified by:
getActionExpression in interface ActionSource2

setActionExpression

public void setActionExpression(MethodExpression actionExpression)
Description copied from interface: ActionSource2

Set the MethodExpression pointing at the appication action to be invoked, if this UIComponent is activated by the user, during the Apply Request Values or Invoke Application phase of the request processing lifecycle, depending on the value of the immediate property.

Any method referenced by such an expression must be public, with a return type of String, and accept no parameters.

Specified by:
setActionExpression in interface ActionSource2
Parameters:
actionExpression - The new method expression

addActionListener

public void addActionListener(ActionListener listener)
Description copied from interface: ActionSource

Add a new ActionListener to the set of listeners interested in being notified when ActionEvents occur.

Specified by:
addActionListener in interface ActionSource
Parameters:
listener - The ActionListener to be added
Throws:
NullPointerException - if listener is null

getActionListeners

public ActionListener[] getActionListeners()
Description copied from interface: ActionSource

Return the set of registered ActionListeners for this ActionSource instance. If there are no registered listeners, a zero-length array is returned.

Specified by:
getActionListeners in interface ActionSource

removeActionListener

public void removeActionListener(ActionListener listener)
Description copied from interface: ActionSource

Remove an existing ActionListener (if any) from the set of listeners interested in being notified when ActionEvents occur.

Specified by:
removeActionListener in interface ActionSource
Parameters:
listener - The ActionListener to be removed
Throws:
NullPointerException - if listener is null

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase

broadcast

public void broadcast(FacesEvent event)
               throws AbortProcessingException

In addition to to the default UIComponent.broadcast(javax.faces.event.FacesEvent) processing, pass the ActionEvent being broadcast to the method referenced by actionListener (if any), and to the default ActionListener registered on the Application.

Overrides:
broadcast in class UIComponentBase
Parameters:
event - FacesEvent to be broadcast
Throws:
AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
IllegalArgumentException - if the implementation class of this FacesEvent is not supported by this component
NullPointerException - if event is null

queueEvent

public void queueEvent(FacesEvent e)

Intercept queueEvent and, for ActionEvents, mark the phaseId for the event to be PhaseId.APPLY_REQUEST_VALUES if the immediate flag is true, PhaseId.INVOKE_APPLICATION otherwise.

Overrides:
queueEvent in class UIComponentBase
Parameters:
e - FacesEvent to be queued
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIComponent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UIComponent

java.lang.Object
    extended by  javax.faces.component.UIComponent
All Implemented Interfaces:
StateHolder
Direct Known Subclasses:
UIComponentBase
public abstract class UIComponent
extends Object
implements StateHolder

UIComponent is the base class for all user interface components in JavaServer Faces. The set of UIComponent instances associated with a particular request and response are organized into a component tree under a UIViewRoot that represents the entire content of the request or response.

For the convenience of component developers, UIComponentBase provides the default behavior that is specified for a UIComponent, and is the base class for all of the concrete UIComponent "base" implementations. Component writers are encouraged to subclass UIComponentBase, instead of directly implementing this abstract class, to reduce the impact of any future changes to the method signatures.

Field Summary
protected  Map<String,ValueExpression> bindings
Constructor Summary
UIComponent()
Method Summary
protected abstract  void addFacesListener(FacesListener listener)
Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent.
abstract  void broadcast(FacesEvent event)
Broadcast the specified FacesEvent to all registered event listeners who have expressed an interest in events of this type.
abstract  void decode(FacesContext context)
Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.
 void encodeAll(FacesContext context)
If this component returns true from isRendered(), render this component and all its children that return true from isRendered(), regardless of the value of the getRendersChildren() flag.
abstract  void encodeBegin(FacesContext context)
If our rendered property is true, render the beginning of the current state of this UIComponent to the response contained in the specified FacesContext.
abstract  void encodeChildren(FacesContext context)
If our rendered property is true, render the child UIComponents of this UIComponent.
abstract  void encodeEnd(FacesContext context)
If our rendered property is true, render the ending of the current state of this UIComponent.
abstract  UIComponent findComponent(String expr)
Search for and return the UIComponent with an id that matches the specified search expression (if any), according to the algorithm described below.
abstract  Map<String,Object> getAttributes()
Return a mutable Map representing the attributes (and properties, see below) associated wth this UIComponent, keyed by attribute name (which must be a String).
abstract  int getChildCount()
Return the number of child UIComponents that are associated with this UIComponent.
abstract  List<UIComponent> getChildren()
Return a mutable List representing the child UIComponents associated with this component.
abstract  String getClientId(FacesContext context)
Return a client-side identifier for this component, generating one if necessary.
 String getContainerClientId(FacesContext context)
Allow components that implement NamingContainer to selectively disable prepending their clientId to their descendent's clientIds by breaking the prepending logic into a seperately callable method.
protected abstract  FacesContext getFacesContext()
Convenience method to return the FacesContext instance for the current request.
protected abstract  FacesListener[] getFacesListeners(Class clazz)
Return an array of registered FacesListeners that are instances of the specified class.
abstract  UIComponent getFacet(String name)
Convenience method to return the named facet, if it exists, or null otherwise.
 int getFacetCount()
Return the number of facet UIComponents that are associated with this UIComponent.
abstract  Map<String,UIComponent> getFacets()
Return a mutable Map representing the facet UIComponents associated with this UIComponent, keyed by facet name (which must be a String).
abstract  Iterator<UIComponent> getFacetsAndChildren()
Return an Iterator over the facet followed by child UIComponents of this UIComponent.
abstract  String getFamily()
Return the identifier of the component family to which this component belongs.
abstract  String getId()
Return the component identifier of this UIComponent.
abstract  UIComponent getParent()
Return the parent UIComponent of this UIComponent, if any.
protected abstract  Renderer getRenderer(FacesContext context)
Convenience method to return the Renderer instance associated with this component, if any; otherwise, return null.
abstract  String getRendererType()
Return the Renderer type for this UIComponent (if any).
abstract  boolean getRendersChildren()
Return a flag indicating whether this component is responsible for rendering its child components.
abstract  ValueBinding getValueBinding(String name)
Deprecated. This has been replaced by getValueExpression(java.lang.String).
 ValueExpression getValueExpression(String name)
Return the ValueExpression used to calculate the value for the specified attribute or property name, if any.
 boolean invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.
abstract  boolean isRendered()
Return true if this component (and its children) should be rendered during the Render Response phase of the request processing lifecycle.
abstract  void processDecodes(FacesContext context)
Perform the component tree processing required by the Apply Request Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
abstract  void processRestoreState(FacesContext context, Object state)
Perform the component tree processing required by the Restore View phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
abstract  Object processSaveState(FacesContext context)
Perform the component tree processing required by the state saving portion of the Render Response phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
abstract  void processUpdates(FacesContext context)
Perform the component tree processing required by the Update Model Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
abstract  void processValidators(FacesContext context)
Perform the component tree processing required by the Process Validations phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
abstract  void queueEvent(FacesEvent event)
Queue an event for broadcast at the end of the current request processing lifecycle phase.
protected abstract  void removeFacesListener(FacesListener listener)
Remove the specified FacesListener from the set of listeners registered to receive event notifications from this UIComponent.
abstract  void setId(String id)
Set the component identifier of this UIComponent (if any).
abstract  void setParent(UIComponent parent)
Set the parent UIComponent of this UIComponent.
abstract  void setRendered(boolean rendered)
Set the rendered property of this UIComponent.
abstract  void setRendererType(String rendererType)
Set the Renderer type for this UIComponent, or null for components that render themselves.
abstract  void setValueBinding(String name, ValueBinding binding)
Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).
 void setValueExpression(String name, ValueExpression binding)
Set the ValueExpression used to calculate the value for the specified attribute or property name, if any.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.StateHolder
isTransient, restoreState, saveState, setTransient

Field Detail

bindings

protected Map<String,ValueExpression> bindings
Constructor Detail

UIComponent

public UIComponent()
Method Detail

getAttributes

public abstract Map<String,Object> getAttributes()

Return a mutable Map representing the attributes (and properties, see below) associated wth this UIComponent, keyed by attribute name (which must be a String). The returned implementation must support all of the standard and optional Map methods, plus support the following additional requirements:

  • The Map implementation must implement the java.io.Serializable interface.
  • Any attempt to add a null key or value must throw a NullPointerException.
  • Any attempt to add a key that is not a String must throw a ClassCastException.
  • If the attribute name specified as a key matches a property of this UIComponent's implementation class, the following methods will have special behavior:
    • containsKey - Return false.
    • get() - If the property is readable, call the getter method and return the returned value (wrapping primitive values in their corresponding wrapper classes); otherwise throw IllegalArgumentException.
    • put() - If the property is writeable, call the setter method to set the corresponding value (unwrapping primitive values in their corresponding wrapper classes). If the property is not writeable, or an attempt is made to set a property of primitive type to null, throw IllegalArgumentException.
    • remove - Throw IllegalArgumentException.

getValueBinding

public abstract ValueBinding getValueBinding(String name)
Deprecated. This has been replaced by getValueExpression(java.lang.String).

Call through to getValueExpression(java.lang.String) and examine the result. If the result is an instance of the wrapper class mandated in setValueBinding(java.lang.String, javax.faces.el.ValueBinding), extract the ValueBinding instance and return it. Otherwise, wrap the result in an implementation of ValueBinding, and return it.

Parameters:
name - Name of the attribute or property for which to retrieve a ValueBinding
Throws:
NullPointerException - if name is null

setValueBinding

public abstract void setValueBinding(String name,
                                     ValueBinding binding)
Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).

Wrap the argument binding in an implementation of ValueExpression and call through to setValueExpression(java.lang.String, javax.el.ValueExpression).

Parameters:
name - Name of the attribute or property for which to set a ValueBinding
binding - The ValueBinding to set, or null to remove any currently set ValueBinding
Throws:
IllegalArgumentException - if name is one of id or parent
NullPointerException - if name is null

getValueExpression

public ValueExpression getValueExpression(String name)

Return the ValueExpression used to calculate the value for the specified attribute or property name, if any.

This method must be overridden and implemented for components that comply with JSF 1.2 and later.

Parameters:
name - Name of the attribute or property for which to retrieve a ValueExpression
Throws:
NullPointerException - if name is null
Since:
1.2

setValueExpression

public void setValueExpression(String name,
                               ValueExpression binding)

Set the ValueExpression used to calculate the value for the specified attribute or property name, if any.

The implementation must call Expression.isLiteralText() on the argument expression. If isLiteralText() returns true, invoke ValueExpression.getValue(javax.el.ELContext) on the argument expression and pass the result as the value parameter in a call to this.getAttributes().put(name, value) where name is the argument name. If an exception is thrown as a result of calling ValueExpression.getValue(javax.el.ELContext), wrap it in a FacesException and re-throw it. If isLiteralText() returns false, simply store the un-evaluated expression argument in the collection of ValueExpressions under the key given by the argument name.

This method must be overridden and implemented for components that comply with JSF 1.2 and later.

Parameters:
name - Name of the attribute or property for which to set a ValueExpression
binding - The ValueExpression to set, or null to remove any currently set ValueExpression
Throws:
IllegalArgumentException - if name is one of id or parent
NullPointerException - if name is null
Since:
1.2

getClientId

public abstract String getClientId(FacesContext context)

Return a client-side identifier for this component, generating one if necessary. The associated Renderer, if any, will be asked to convert the clientId to a form suitable for transmission to the client.

The return from this method must be the same value throughout the lifetime of the instance, unless the id property of the component is changed, or the component is placed in a NamingContainer whose client ID changes (for example, UIData). However, even in these cases, consecutive calls to this method must always return the same value. The implementation must follow these steps in determining the clientId:

Find the closest ancestor to this component in the view hierarchy that implements NamingContainer. Call getContainerClientId() on it and save the result as the parentId local variable. Call getId() on this component and save the result as the myId local variable. If myId is null, call context.getViewRoot().createUniqueId() and assign the result to myId. If parentId is non-null, let myId equal parentId + NamingContainer.SEPARATOR_CHAR + myId. Call Renderer.convertClientId(javax.faces.context.FacesContext, java.lang.String), passing myId, and return the result.

Parameters:
context - The FacesContext for the current request
Throws:
NullPointerException - if context is null

getContainerClientId

public String getContainerClientId(FacesContext context)

Allow components that implement NamingContainer to selectively disable prepending their clientId to their descendent's clientIds by breaking the prepending logic into a seperately callable method. See getClientId(javax.faces.context.FacesContext) for usage.

By default, this method will call through to getClientId(javax.faces.context.FacesContext) and return the result.

Throws:
NullPointerException - if context is null
Since:
1.2

getFamily

public abstract String getFamily()

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

getId

public abstract String getId()

Return the component identifier of this UIComponent.

setId

public abstract void setId(String id)

Set the component identifier of this UIComponent (if any). Component identifiers must obey the following syntax restrictions:

  • Must not be a zero-length String.
  • First character must be a letter or an underscore ('_').
  • Subsequent characters must be a letter, a digit, an underscore ('_'), or a dash ('-').

Component identifiers must also obey the following semantic restrictions (note that this restriction is NOT enforced by the setId() implementation):

  • The specified identifier must be unique among all the components (including facets) that are descendents of the nearest ancestor UIComponent that is a NamingContainer, or within the scope of the entire component tree if there is no such ancestor that is a NamingContainer.

Parameters:
id - The new component identifier, or null to indicate that this UIComponent does not have a component identifier
Throws:
IllegalArgumentException - if id is not syntactically valid

getParent

public abstract UIComponent getParent()

Return the parent UIComponent of this UIComponent, if any. A component must allow child components to be added to and removed from the list of children of this component, even though the child component returns null from getParent( ).

setParent

public abstract void setParent(UIComponent parent)

Set the parent UIComponent of this UIComponent. This method must never be called by developers; a UIComponent's internal implementation will call it as components are added to or removed from a parent's child List or facet Map.

Parameters:
parent - The new parent, or null for the root node of a component tree

isRendered

public abstract boolean isRendered()

Return true if this component (and its children) should be rendered during the Render Response phase of the request processing lifecycle.

setRendered

public abstract void setRendered(boolean rendered)

Set the rendered property of this UIComponent.

Parameters:
rendered - If true render this component; otherwise, do not render this component

getRendererType

public abstract String getRendererType()

Return the Renderer type for this UIComponent (if any).

setRendererType

public abstract void setRendererType(String rendererType)

Set the Renderer type for this UIComponent, or null for components that render themselves.

Parameters:
rendererType - Logical identifier of the type of Renderer to use, or null for components that render themselves

getRendersChildren

public abstract boolean getRendersChildren()

Return a flag indicating whether this component is responsible for rendering its child components. The default implementation in UIComponentBase.getRendersChildren() tries to find the renderer for this component. If it does, it calls Renderer.getRendersChildren() and returns the result. If it doesn't, it returns false. As of version 1.2 of the JavaServer Faces Specification, component authors are encouraged to return true from this method and rely on UIComponentBase.encodeChildren(javax.faces.context.FacesContext).

getChildren

public abstract List<UIComponent> getChildren()

Return a mutable List representing the child UIComponents associated with this component. The returned implementation must support all of the standard and optional List methods, plus support the following additional requirements:

  • The List implementation must implement the java.io.Serializable interface.
  • Any attempt to add a null must throw a NullPointerException
  • Any attempt to add an object that does not implement UIComponent must throw a ClassCastException.
  • Whenever a new child component is added, the parent property of the child must be set to this component instance. If the parent property of the child was already non-null, the child must first be removed from its previous parent (where it may have been either a child or a facet).
  • Whenever an existing child component is removed, the parent property of the child must be set to null.

getChildCount

public abstract int getChildCount()

Return the number of child UIComponents that are associated with this UIComponent. If there are no children, this method must return 0. The method must not cause the creation of a child component list.

findComponent

public abstract UIComponent findComponent(String expr)

Search for and return the UIComponent with an id that matches the specified search expression (if any), according to the algorithm described below.

For a method to find a component given a simple clientId, see invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback).

Component identifiers are required to be unique within the scope of the closest ancestor NamingContainer that encloses this component (which might be this component itself). If there are no NamingContainer components in the ancestry of this component, the root component in the tree is treated as if it were a NamingContainer, whether or not its class actually implements the NamingContainer interface.

A search expression consists of either an identifier (which is matched exactly against the id property of a UIComponent, or a series of such identifiers linked by the NamingContainer.SEPARATOR_CHAR character value. The search algorithm should operates as follows, though alternate alogrithms may be used as long as the end result is the same:

  • Identify the UIComponent that will be the base for searching, by stopping as soon as one of the following conditions is met:
    • If the search expression begins with the the separator character (called an "absolute" search expression), the base will be the root UIComponent of the component tree. The leading separator character will be stripped off, and the remainder of the search expression will be treated as a "relative" search expression as described below.
    • Otherwise, if this UIComponent is a NamingContainer it will serve as the basis.
    • Otherwise, search up the parents of this component. If a NamingContainer is encountered, it will be the base.
    • Otherwise (if no NamingContainer is encountered) the root UIComponent will be the base.
  • The search expression (possibly modified in the previous step) is now a "relative" search expression that will be used to locate the component (if any) that has an id that matches, within the scope of the base component. The match is performed as follows:
    • If the search expression is a simple identifier, this value is compared to the id property, and then recursively through the facets and children of the base UIComponent (except that if a descendant NamingContainer is found, its own facets and children are not searched).
    • If the search expression includes more than one identifier separated by the separator character, the first identifier is used to locate a NamingContainer by the rules in the previous bullet point. Then, the findComponent() method of this NamingContainer will be called, passing the remainder of the search expression.

Parameters:
expr - Search expression identifying the UIComponent to be returned
Returns:
the found UIComponent, or null if the component was not found.
Throws:
IllegalArgumentException - if an intermediate identifier in a search expression identifies a UIComponent that is not a NamingContainer
NullPointerException - if expr is null

invokeOnComponent

public boolean invokeOnComponent(FacesContext context,
                                 String clientId,
                                 ContextCallback callback)
                          throws FacesException

Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments. This method is similar to findComponent(java.lang.String) but it does not support the leading NamingContainer.SEPARATOR_CHAR syntax for searching from the root of the View.

The default implementation will first check if this.getClientId() is equal to the argument clientId. If so, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing through the FacesContext argument and passing this as the component argument. If an Exception is thrown by the callback, wrap it in a FacesException and re-throw it. Otherwise, return true.

Otherwise, for each component returned by getFacetsAndChildren(), call invokeOnComponent() passing the arguments to this method, in order. The first time invokeOnComponent() returns true, abort traversing the rest of the Iterator and return true.

When calling ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) the implementation of this method must guarantee that the state of the component passed to the callback correctly reflects the component's position in the View hierarchy with respect to any state found in the argument clientId. For example, an iterating component such as UIData will need to set its row index to correctly reflect the argument clientId before finding the appropriate child component backed by the correct row. When the callback returns, either normally or by throwing an Exception the implementation of this method must restore the state of the view to the way it was before invoking the callback.

If none of the elements from getFacetsAndChildren() returned true from invokeOnComponent(), return false.

Simple usage example to find a component by clientId.

private UIComponent found = null;

private void doFind(FacesContext context, String clientId) {
  context.getViewRoot().invokeOnComponent(context, clientId,
      new ContextCallback() {
         public void invokeOnComponent(FacesContext context,
                                       UIComponent component) {
           found = component;
         }
      });
}

Parameters:
context - the FacesContext for the current request
clientId - the client identifier of the component to be passed to the argument callback.
callback - an implementation of the Callback interface.
Returns:
true if the a component with the given clientId is found, the callback method was successfully invoked passing that component as an argument, and no Exception was thrown. Returns false if no component with the given clientId is found.
Throws:
NullPointerException - if any of the arguments are null
FacesException - if the argument Callback throws an Exception, it is wrapped in a FacesException and re-thrown.
Since:
1.2

getFacets

public abstract Map<String,UIComponent> getFacets()

Return a mutable Map representing the facet UIComponents associated with this UIComponent, keyed by facet name (which must be a String). The returned implementation must support all of the standard and optional Map methods, plus support the following additional requirements:

  • The Map implementation must implement the java.io.Serializable interface.
  • Any attempt to add a null key or value must throw a NullPointerException.
  • Any attempt to add a key that is not a String must throw a ClassCastException.
  • Any attempt to add a value that is not a UIComponent must throw a ClassCastException.
  • Whenever a new facet UIComponent is added:
    • The parent property of the component must be set to this component instance.
    • If the parent property of the component was already non-null, the component must first be removed from its previous parent (where it may have been either a child or a facet).
  • Whenever an existing facet UIComponent is removed:
    • The parent property of the facet must be set to null.

getFacetCount

public int getFacetCount()

Return the number of facet UIComponents that are associated with this UIComponent. If there are no facets, this method must return 0. The method must not cause the creation of a facet component map.

For backwards compatability with classes that extend UIComponent directly, a default implementation is provided that simply calls getFacets() and then calls the size() method on the returned Map. A more optimized version of this method is provided in UIComponentBase.getFacetCount().

Since:
1.2

getFacet

public abstract UIComponent getFacet(String name)

Convenience method to return the named facet, if it exists, or null otherwise. If the requested facet does not exist, the facets Map must not be created.

Parameters:
name - Name of the desired facet

getFacetsAndChildren

public abstract Iterator<UIComponent> getFacetsAndChildren()

Return an Iterator over the facet followed by child UIComponents of this UIComponent. Facets are returned in an undefined order, followed by all the children in the order they are stored in the child list. If this component has no facets or children, an empty Iterator is returned.

The returned Iterator must not support the remove() operation.

broadcast

public abstract void broadcast(FacesEvent event)
                        throws AbortProcessingException

Broadcast the specified FacesEvent to all registered event listeners who have expressed an interest in events of this type. Listeners are called in the order in which they were added.

Parameters:
event - The FacesEvent to be broadcast
Throws:
AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
IllegalArgumentException - if the implementation class of this FacesEvent is not supported by this component
NullPointerException - if event is null

decode

public abstract void decode(FacesContext context)

Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.

During decoding, events may be enqueued for later processing (by event listeners who have registered an interest), by calling queueEvent().

Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

encodeBegin

public abstract void encodeBegin(FacesContext context)
                          throws IOException

If our rendered property is true, render the beginning of the current state of this UIComponent to the response contained in the specified FacesContext.

If a Renderer is associated with this UIComponent, the actual encoding will be delegated to Renderer.encodeBegin(FacesContext, UIComponent).

Parameters:
context - FacesContext for the response we are creating
Throws:
IOException - if an input/output error occurs while rendering
NullPointerException - if context is null

encodeChildren

public abstract void encodeChildren(FacesContext context)
                             throws IOException

If our rendered property is true, render the child UIComponents of this UIComponent. This method will only be called if the rendersChildren property is true.

If a Renderer is associated with this UIComponent, the actual encoding will be delegated to Renderer.encodeBegin(FacesContext, UIComponent).

Parameters:
context - FacesContext for the response we are creating
Throws:
IOException - if an input/output error occurs while rendering
NullPointerException - if context is null

encodeEnd

public abstract void encodeEnd(FacesContext context)
                        throws IOException

If our rendered property is true, render the ending of the current state of this UIComponent.

If a Renderer is associated with this UIComponent, the actual encoding will be delegated to Renderer.encodeBegin(FacesContext, UIComponent).

Parameters:
context - FacesContext for the response we are creating
Throws:
IOException - if an input/output error occurs while rendering
NullPointerException - if context is null

encodeAll

public void encodeAll(FacesContext context)
               throws IOException

If this component returns true from isRendered(), render this component and all its children that return true from isRendered(), regardless of the value of the getRendersChildren() flag.

Throws:
IOException - if an input/output error occurs while rendering
NullPointerException - if context is null
Since:
1.2

addFacesListener

protected abstract void addFacesListener(FacesListener listener)

Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent. It is expected that UIComponent classes acting as event sources will have corresponding typesafe APIs for registering listeners of the required type, and the implementation of those registration methods will delegate to this method. For example:

 public class FooEvent extends FacesEvent { ... }

 public interface FooListener extends FacesListener {
   public void processFoo(FooEvent event);
 }

 public class FooComponent extends UIComponentBase {
   ...
   public void addFooListener(FooListener listener) {
     addFacesListener(listener);
   }
   public void removeFooListener(FooListener listener) {
     removeFacesListener(listener);
   }
   ...
 }

Parameters:
listener - The FacesListener to be registered
Throws:
NullPointerException - if listener is null

getFacesListeners

protected abstract FacesListener[] getFacesListeners(Class clazz)

Return an array of registered FacesListeners that are instances of the specified class. If there are no such registered listeners, a zero-length array is returned. The returned array can be safely be cast to an array strongly typed to an element type of clazz.

Parameters:
clazz - Class that must be implemented by a FacesListener for it to be returned
Throws:
IllegalArgumentException - if class is not, and does not implement, FacesListener
NullPointerException - if clazz is null

removeFacesListener

protected abstract void removeFacesListener(FacesListener listener)

Remove the specified FacesListener from the set of listeners registered to receive event notifications from this UIComponent.

Parameters:
listener - The FacesListener to be deregistered
Throws:
NullPointerException - if listener is null

queueEvent

public abstract void queueEvent(FacesEvent event)

Queue an event for broadcast at the end of the current request processing lifecycle phase. The default implementation in UIComponentBase must delegate this call to the queueEvent() method of the parent UIComponent.

Parameters:
event - FacesEvent to be queued
Throws:
IllegalStateException - if this component is not a descendant of a UIViewRoot
NullPointerException - if event is null

processRestoreState

public abstract void processRestoreState(FacesContext context,
                                         Object state)

Perform the component tree processing required by the Restore View phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

  • Call the processRestoreState() method of all facets and children of this UIComponent in the order determined by a call to getFacetsAndChildren().
  • Call the restoreState() method of this component.

This method may not be called if the state saving method is set to server.

Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processDecodes

public abstract void processDecodes(FacesContext context)

Perform the component tree processing required by the Apply Request Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

  • If the rendered property of this UIComponent is false, skip further processing.
  • Call the processDecodes() method of all facets and children of this UIComponent, in the order determined by a call to getFacetsAndChildren().
  • Call the decode() method of this component.
  • If a RuntimeException is thrown during decode processing, call FacesContext.renderResponse() and re-throw the exception.

Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processValidators

public abstract void processValidators(FacesContext context)

Perform the component tree processing required by the Process Validations phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

  • If the rendered property of this UIComponent is false, skip further processing.
  • Call the processValidators() method of all facets and children of this UIComponent, in the order determined by a call to getFacetsAndChildren().

Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processUpdates

public abstract void processUpdates(FacesContext context)

Perform the component tree processing required by the Update Model Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

  • If the rendered property of this UIComponent is false, skip further processing.
  • Call the processUpdates() method of all facets and children of this UIComponent, in the order determined by a call to getFacetsAndChildren().

Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processSaveState

public abstract Object processSaveState(FacesContext context)

Perform the component tree processing required by the state saving portion of the Render Response phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

  • consult the transient property of this component. If true, just return null.
  • Call the processSaveState() method of all facets and children of this UIComponent in the order determined by a call to getFacetsAndChildren(), skipping children and facets that are transient.
  • Call the saveState() method of this component.
  • Encapsulate the child state and your state into a Serializable Object and return it.

This method may not be called if the state saving method is set to server.

Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

getFacesContext

protected abstract FacesContext getFacesContext()

Convenience method to return the FacesContext instance for the current request.

getRenderer

protected abstract Renderer getRenderer(FacesContext context)

Convenience method to return the Renderer instance associated with this component, if any; otherwise, return null.

Parameters:
context - FacesContext for the current request
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIComponentBase

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UIComponentBase

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
All Implemented Interfaces:
StateHolder
Direct Known Subclasses:
UIColumn, UICommand, UIData, UIForm, UIGraphic, UIMessage, UIMessages, UINamingContainer, UIOutput, UIPanel, UIParameter, UISelectItem, UISelectItems, UIViewRoot
public abstract class UIComponentBase
extends UIComponent

UIComponentBase is a convenience base class that implements the default concrete behavior of all methods defined by UIComponent.

By default, this class defines getRendersChildren() to find the renderer for this component and call its getRendersChildren() method. The default implementation on the Renderer returns false. As of version 1.2 of the JavaServer Faces Specification, component authors are encouraged to return true from this method and rely on the implementation of encodeChildren(javax.faces.context.FacesContext) in this class and in the Renderer (Renderer.encodeChildren(javax.faces.context.FacesContext, javax.faces.component.UIComponent)). Subclasses that wish to manage the rendering of their children should override this method to return true instead.

Field Summary
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UIComponentBase()
Method Summary
protected  void addFacesListener(FacesListener listener)
Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent.
 void broadcast(FacesEvent event)
Broadcast the specified FacesEvent to all registered event listeners who have expressed an interest in events of this type.
 void decode(FacesContext context)
Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.
 void encodeBegin(FacesContext context)
If our rendered property is true, render the beginning of the current state of this UIComponent to the response contained in the specified FacesContext.
 void encodeChildren(FacesContext context)
If our rendered property is true, render the child UIComponents of this UIComponent.
 void encodeEnd(FacesContext context)
If our rendered property is true, render the ending of the current state of this UIComponent.
 UIComponent findComponent(String expr)
Search for and return the UIComponent with an id that matches the specified search expression (if any), according to the algorithm described below.
 Map<String,Object> getAttributes()
Return a mutable Map representing the attributes (and properties, see below) associated wth this UIComponent, keyed by attribute name (which must be a String).
 int getChildCount()
Return the number of child UIComponents that are associated with this UIComponent.
 List<UIComponent> getChildren()
Return a mutable List representing the child UIComponents associated with this component.
 String getClientId(FacesContext context)
Return a client-side identifier for this component, generating one if necessary.
protected  FacesContext getFacesContext()
Convenience method to return the FacesContext instance for the current request.
protected  FacesListener[] getFacesListeners(Class clazz)
Return an array of registered FacesListeners that are instances of the specified class.
 UIComponent getFacet(String name)
Convenience method to return the named facet, if it exists, or null otherwise.
 int getFacetCount()
Return the number of facet UIComponents that are associated with this UIComponent.
 Map<String,UIComponent> getFacets()
Return a mutable Map representing the facet UIComponents associated with this UIComponent, keyed by facet name (which must be a String).
 Iterator<UIComponent> getFacetsAndChildren()
Return an Iterator over the facet followed by child UIComponents of this UIComponent.
 String getId()
Return the component identifier of this UIComponent.
 UIComponent getParent()
Return the parent UIComponent of this UIComponent, if any.
protected  Renderer getRenderer(FacesContext context)
Convenience method to return the Renderer instance associated with this component, if any; otherwise, return null.
 String getRendererType()
Return the Renderer type for this UIComponent (if any).
 boolean getRendersChildren()
Return a flag indicating whether this component is responsible for rendering its child components.
 ValueBinding getValueBinding(String name)
Deprecated. This has been replaced by getValueExpression(java.lang.String).
 ValueExpression getValueExpression(String name)

Return the ValueExpression used to calculate the value for the specified attribute or property name, if any.

 boolean invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)

Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments.

 boolean isRendered()
Return true if this component (and its children) should be rendered during the Render Response phase of the request processing lifecycle.
 boolean isTransient()
If true, the Object implementing this interface must not participate in state saving or restoring.
 void processDecodes(FacesContext context)
Perform the component tree processing required by the Apply Request Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
 void processRestoreState(FacesContext context, Object state)
Perform the component tree processing required by the Restore View phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
 Object processSaveState(FacesContext context)
Perform the component tree processing required by the state saving portion of the Render Response phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
 void processUpdates(FacesContext context)
Perform the component tree processing required by the Update Model Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
 void processValidators(FacesContext context)
Perform the component tree processing required by the Process Validations phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.
 void queueEvent(FacesEvent event)
Queue an event for broadcast at the end of the current request processing lifecycle phase.
protected  void removeFacesListener(FacesListener listener)
Remove the specified FacesListener from the set of listeners registered to receive event notifications from this UIComponent.
static Object restoreAttachedState(FacesContext context, Object stateObj)
This method is called by UIComponent subclasses that need to restore the objects they saved using saveAttachedState(javax.faces.context.FacesContext, java.lang.Object).
 void restoreState(FacesContext context, Object state)
Perform any processing required to restore the state from the entries in the state Object.
static Object saveAttachedState(FacesContext context, Object attachedObject)
This method is called by UIComponent subclasses that want to save one or more attached objects.
 Object saveState(FacesContext context)
Gets the state of the instance as a Serializable Object.
 void setId(String id)
Set the component identifier of this UIComponent (if any).
 void setParent(UIComponent parent)
Set the parent UIComponent of this UIComponent.
 void setRendered(boolean rendered)
Set the rendered property of this UIComponent.
 void setRendererType(String rendererType)
Set the Renderer type for this UIComponent, or null for components that render themselves.
 void setTransient(boolean transientFlag)
Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
 void setValueBinding(String name, ValueBinding binding)
Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).
 void setValueExpression(String name, ValueExpression binding)

Set the ValueExpression used to calculate the value for the specified attribute or property name, if any.

Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId, getFamily
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UIComponentBase

public UIComponentBase()
Method Detail

getAttributes

public Map<String,Object> getAttributes()
Description copied from class: UIComponent

Return a mutable Map representing the attributes (and properties, see below) associated wth this UIComponent, keyed by attribute name (which must be a String). The returned implementation must support all of the standard and optional Map methods, plus support the following additional requirements:

  • The Map implementation must implement the java.io.Serializable interface.
  • Any attempt to add a null key or value must throw a NullPointerException.
  • Any attempt to add a key that is not a String must throw a ClassCastException.
  • If the attribute name specified as a key matches a property of this UIComponent's implementation class, the following methods will have special behavior:
    • containsKey - Return false.
    • get() - If the property is readable, call the getter method and return the returned value (wrapping primitive values in their corresponding wrapper classes); otherwise throw IllegalArgumentException.
    • put() - If the property is writeable, call the setter method to set the corresponding value (unwrapping primitive values in their corresponding wrapper classes). If the property is not writeable, or an attempt is made to set a property of primitive type to null, throw IllegalArgumentException.
    • remove - Throw IllegalArgumentException.

Specified by:
getAttributes in class UIComponent

getValueBinding

public ValueBinding getValueBinding(String name)
Deprecated. This has been replaced by getValueExpression(java.lang.String).

Call through to UIComponent.getValueExpression(java.lang.String) and examine the result. If the result is an instance of the wrapper class mandated in UIComponent.setValueBinding(java.lang.String, javax.faces.el.ValueBinding), extract the ValueBinding instance and return it. Otherwise, wrap the result in an implementation of ValueBinding, and return it.

Specified by:
getValueBinding in class UIComponent
Parameters:
name - Name of the attribute or property for which to retrieve a ValueBinding
Throws:
NullPointerException - if name is null

setValueBinding

public void setValueBinding(String name,
                            ValueBinding binding)
Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).

Wrap the argument binding in an implementation of ValueExpression and call through to UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression).

Specified by:
setValueBinding in class UIComponent
Parameters:
name - Name of the attribute or property for which to set a ValueBinding
binding - The ValueBinding to set, or null to remove any currently set ValueBinding
Throws:
IllegalArgumentException - if name is one of id or parent
NullPointerException - if name is null

getValueExpression

public ValueExpression getValueExpression(String name)

Return the ValueExpression used to calculate the value for the specified attribute or property name, if any.

This method must be overridden and implemented for components that comply with JSF 1.2 and later.

Overrides:
getValueExpression in class UIComponent
Parameters:
name - Name of the attribute or property for which to retrieve a ValueExpression
Throws:
NullPointerException - if name is null
Since:
1.2

setValueExpression

public void setValueExpression(String name,
                               ValueExpression binding)

Set the ValueExpression used to calculate the value for the specified attribute or property name, if any.

The implementation must call Expression.isLiteralText() on the argument expression. If isLiteralText() returns true, invoke ValueExpression.getValue(javax.el.ELContext) on the argument expression and pass the result as the value parameter in a call to this.UIComponent.getAttributes().put(name, value) where name is the argument name. If an exception is thrown as a result of calling ValueExpression.getValue(javax.el.ELContext), wrap it in a FacesException and re-throw it. If isLiteralText() returns false, simply store the un-evaluated expression argument in the collection of ValueExpressions under the key given by the argument name.

This method must be overridden and implemented for components that comply with JSF 1.2 and later.

Overrides:
setValueExpression in class UIComponent
Parameters:
name - Name of the attribute or property for which to set a ValueExpression
binding - The ValueExpression to set, or null to remove any currently set ValueExpression
Throws:
IllegalArgumentException - if name is one of id or parent
NullPointerException - if name is null
Since:
1.2

getClientId

public String getClientId(FacesContext context)
Description copied from class: UIComponent

Return a client-side identifier for this component, generating one if necessary. The associated Renderer, if any, will be asked to convert the clientId to a form suitable for transmission to the client.

The return from this method must be the same value throughout the lifetime of the instance, unless the id property of the component is changed, or the component is placed in a NamingContainer whose client ID changes (for example, UIData). However, even in these cases, consecutive calls to this method must always return the same value. The implementation must follow these steps in determining the clientId:

Find the closest ancestor to this component in the view hierarchy that implements NamingContainer. Call getContainerClientId() on it and save the result as the parentId local variable. Call UIComponent.getId() on this component and save the result as the myId local variable. If myId is null, call context.getViewRoot().createUniqueId() and assign the result to myId. If parentId is non-null, let myId equal parentId + NamingContainer.SEPARATOR_CHAR + myId. Call Renderer.convertClientId(javax.faces.context.FacesContext, java.lang.String), passing myId, and return the result.

Specified by:
getClientId in class UIComponent
Parameters:
context - The FacesContext for the current request
Throws:
NullPointerException - if context is null

getId

public String getId()
Description copied from class: UIComponent

Return the component identifier of this UIComponent.

Specified by:
getId in class UIComponent

setId

public void setId(String id)
Description copied from class: UIComponent

Set the component identifier of this UIComponent (if any). Component identifiers must obey the following syntax restrictions:

  • Must not be a zero-length String.
  • First character must be a letter or an underscore ('_').
  • Subsequent characters must be a letter, a digit, an underscore ('_'), or a dash ('-').

Component identifiers must also obey the following semantic restrictions (note that this restriction is NOT enforced by the setId() implementation):

  • The specified identifier must be unique among all the components (including facets) that are descendents of the nearest ancestor UIComponent that is a NamingContainer, or within the scope of the entire component tree if there is no such ancestor that is a NamingContainer.

Specified by:
setId in class UIComponent
Parameters:
id - The new component identifier, or null to indicate that this UIComponent does not have a component identifier
Throws:
IllegalArgumentException - if id is not syntactically valid
IllegalStateException

getParent

public UIComponent getParent()
Description copied from class: UIComponent

Return the parent UIComponent of this UIComponent, if any. A component must allow child components to be added to and removed from the list of children of this component, even though the child component returns null from getParent( ).

Specified by:
getParent in class UIComponent

setParent

public void setParent(UIComponent parent)
Description copied from class: UIComponent

Set the parent UIComponent of this UIComponent. This method must never be called by developers; a UIComponent's internal implementation will call it as components are added to or removed from a parent's child List or facet Map.

Specified by:
setParent in class UIComponent
Parameters:
parent - The new parent, or null for the root node of a component tree

isRendered

public boolean isRendered()
Description copied from class: UIComponent

Return true if this component (and its children) should be rendered during the Render Response phase of the request processing lifecycle.

Specified by:
isRendered in class UIComponent

setRendered

public void setRendered(boolean rendered)
Description copied from class: UIComponent

Set the rendered property of this UIComponent.

Specified by:
setRendered in class UIComponent
Parameters:
rendered - If true render this component; otherwise, do not render this component

getRendererType

public String getRendererType()
Description copied from class: UIComponent

Return the Renderer type for this UIComponent (if any).

Specified by:
getRendererType in class UIComponent

setRendererType

public void setRendererType(String rendererType)
Description copied from class: UIComponent

Set the Renderer type for this UIComponent, or null for components that render themselves.

Specified by:
setRendererType in class UIComponent
Parameters:
rendererType - Logical identifier of the type of Renderer to use, or null for components that render themselves

getRendersChildren

public boolean getRendersChildren()
Description copied from class: UIComponent

Return a flag indicating whether this component is responsible for rendering its child components. The default implementation in getRendersChildren() tries to find the renderer for this component. If it does, it calls Renderer.getRendersChildren() and returns the result. If it doesn't, it returns false. As of version 1.2 of the JavaServer Faces Specification, component authors are encouraged to return true from this method and rely on encodeChildren(javax.faces.context.FacesContext).

Specified by:
getRendersChildren in class UIComponent

getChildren

public List<UIComponent> getChildren()
Description copied from class: UIComponent

Return a mutable List representing the child UIComponents associated with this component. The returned implementation must support all of the standard and optional List methods, plus support the following additional requirements:

  • The List implementation must implement the java.io.Serializable interface.
  • Any attempt to add a null must throw a NullPointerException
  • Any attempt to add an object that does not implement UIComponent must throw a ClassCastException.
  • Whenever a new child component is added, the parent property of the child must be set to this component instance. If the parent property of the child was already non-null, the child must first be removed from its previous parent (where it may have been either a child or a facet).
  • Whenever an existing child component is removed, the parent property of the child must be set to null.

Specified by:
getChildren in class UIComponent

getChildCount

public int getChildCount()
Description copied from class: UIComponent

Return the number of child UIComponents that are associated with this UIComponent. If there are no children, this method must return 0. The method must not cause the creation of a child component list.

Specified by:
getChildCount in class UIComponent

findComponent

public UIComponent findComponent(String expr)
Description copied from class: UIComponent

Search for and return the UIComponent with an id that matches the specified search expression (if any), according to the algorithm described below.

For a method to find a component given a simple clientId, see UIComponent.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback).

Component identifiers are required to be unique within the scope of the closest ancestor NamingContainer that encloses this component (which might be this component itself). If there are no NamingContainer components in the ancestry of this component, the root component in the tree is treated as if it were a NamingContainer, whether or not its class actually implements the NamingContainer interface.

A search expression consists of either an identifier (which is matched exactly against the id property of a UIComponent, or a series of such identifiers linked by the NamingContainer.SEPARATOR_CHAR character value. The search algorithm should operates as follows, though alternate alogrithms may be used as long as the end result is the same:

  • Identify the UIComponent that will be the base for searching, by stopping as soon as one of the following conditions is met:
    • If the search expression begins with the the separator character (called an "absolute" search expression), the base will be the root UIComponent of the component tree. The leading separator character will be stripped off, and the remainder of the search expression will be treated as a "relative" search expression as described below.
    • Otherwise, if this UIComponent is a NamingContainer it will serve as the basis.
    • Otherwise, search up the parents of this component. If a NamingContainer is encountered, it will be the base.
    • Otherwise (if no NamingContainer is encountered) the root UIComponent will be the base.
  • The search expression (possibly modified in the previous step) is now a "relative" search expression that will be used to locate the component (if any) that has an id that matches, within the scope of the base component. The match is performed as follows:
    • If the search expression is a simple identifier, this value is compared to the id property, and then recursively through the facets and children of the base UIComponent (except that if a descendant NamingContainer is found, its own facets and children are not searched).
    • If the search expression includes more than one identifier separated by the separator character, the first identifier is used to locate a NamingContainer by the rules in the previous bullet point. Then, the findComponent() method of this NamingContainer will be called, passing the remainder of the search expression.

Specified by:
findComponent in class UIComponent
Parameters:
expr - Search expression identifying the UIComponent to be returned
Returns:
the found UIComponent, or null if the component was not found.
Throws:
NullPointerException - if expr is null

invokeOnComponent

public boolean invokeOnComponent(FacesContext context,
                                 String clientId,
                                 ContextCallback callback)
                          throws FacesException

Starting at this component in the View hierarchy, search for a component with a clientId equal to the argument clientId and, if found, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing the current FacesContext and the found component as arguments. This method is similar to UIComponent.findComponent(java.lang.String) but it does not support the leading NamingContainer.SEPARATOR_CHAR syntax for searching from the root of the View.

The default implementation will first check if this.getClientId() is equal to the argument clientId. If so, call the ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) method on the argument callback, passing through the FacesContext argument and passing this as the component argument. If an Exception is thrown by the callback, wrap it in a FacesException and re-throw it. Otherwise, return true.

Otherwise, for each component returned by UIComponent.getFacetsAndChildren(), call invokeOnComponent() passing the arguments to this method, in order. The first time invokeOnComponent() returns true, abort traversing the rest of the Iterator and return true.

When calling ContextCallback.invokeContextCallback(javax.faces.context.FacesContext, javax.faces.component.UIComponent) the implementation of this method must guarantee that the state of the component passed to the callback correctly reflects the component's position in the View hierarchy with respect to any state found in the argument clientId. For example, an iterating component such as UIData will need to set its row index to correctly reflect the argument clientId before finding the appropriate child component backed by the correct row. When the callback returns, either normally or by throwing an Exception the implementation of this method must restore the state of the view to the way it was before invoking the callback.

If none of the elements from UIComponent.getFacetsAndChildren() returned true from invokeOnComponent(), return false.

Simple usage example to find a component by clientId.

private UIComponent found = null;

private void doFind(FacesContext context, String clientId) {
  context.getViewRoot().invokeOnComponent(context, clientId,
      new ContextCallback() {
         public void invokeOnComponent(FacesContext context,
                                       UIComponent component) {
           found = component;
         }
      });
}

Overrides:
invokeOnComponent in class UIComponent
Parameters:
context - the FacesContext for the current request
clientId - the client identifier of the component to be passed to the argument callback.
callback - an implementation of the Callback interface.
Returns:
true if the a component with the given clientId is found, the callback method was successfully invoked passing that component as an argument, and no Exception was thrown. Returns false if no component with the given clientId is found.
Throws:
NullPointerException - if any of the arguments are null
FacesException - if the argument Callback throws an Exception, it is wrapped in a FacesException and re-thrown.
Since:
1.2

getFacets

public Map<String,UIComponent> getFacets()
Description copied from class: UIComponent

Return a mutable Map representing the facet UIComponents associated with this UIComponent, keyed by facet name (which must be a String). The returned implementation must support all of the standard and optional Map methods, plus support the following additional requirements:

  • The Map implementation must implement the java.io.Serializable interface.
  • Any attempt to add a null key or value must throw a NullPointerException.
  • Any attempt to add a key that is not a String must throw a ClassCastException.
  • Any attempt to add a value that is not a UIComponent must throw a ClassCastException.
  • Whenever a new facet UIComponent is added:
    • The parent property of the component must be set to this component instance.
    • If the parent property of the component was already non-null, the component must first be removed from its previous parent (where it may have been either a child or a facet).
  • Whenever an existing facet UIComponent is removed:
    • The parent property of the facet must be set to null.

Specified by:
getFacets in class UIComponent

getFacetCount

public int getFacetCount()
Description copied from class: UIComponent

Return the number of facet UIComponents that are associated with this UIComponent. If there are no facets, this method must return 0. The method must not cause the creation of a facet component map.

For backwards compatability with classes that extend UIComponent directly, a default implementation is provided that simply calls UIComponent.getFacets() and then calls the size() method on the returned Map. A more optimized version of this method is provided in getFacetCount().

Overrides:
getFacetCount in class UIComponent

getFacet

public UIComponent getFacet(String name)
Description copied from class: UIComponent

Convenience method to return the named facet, if it exists, or null otherwise. If the requested facet does not exist, the facets Map must not be created.

Specified by:
getFacet in class UIComponent
Parameters:
name - Name of the desired facet

getFacetsAndChildren

public Iterator<UIComponent> getFacetsAndChildren()
Description copied from class: UIComponent

Return an Iterator over the facet followed by child UIComponents of this UIComponent. Facets are returned in an undefined order, followed by all the children in the order they are stored in the child list. If this component has no facets or children, an empty Iterator is returned.

The returned Iterator must not support the remove() operation.

Specified by:
getFacetsAndChildren in class UIComponent

broadcast

public void broadcast(FacesEvent event)
               throws AbortProcessingException
Description copied from class: UIComponent

Broadcast the specified FacesEvent to all registered event listeners who have expressed an interest in events of this type. Listeners are called in the order in which they were added.

Specified by:
broadcast in class UIComponent
Parameters:
event - The FacesEvent to be broadcast
Throws:
AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
IllegalStateException
NullPointerException - if event is null

decode

public void decode(FacesContext context)
Description copied from class: UIComponent

Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.

During decoding, events may be enqueued for later processing (by event listeners who have registered an interest), by calling queueEvent().

Specified by:
decode in class UIComponent
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

encodeBegin

public void encodeBegin(FacesContext context)
                 throws IOException
Description copied from class: UIComponent

If our rendered property is true, render the beginning of the current state of this UIComponent to the response contained in the specified FacesContext.

If a Renderer is associated with this UIComponent, the actual encoding will be delegated to Renderer.encodeBegin(FacesContext, UIComponent).

Specified by:
encodeBegin in class UIComponent
Parameters:
context - FacesContext for the response we are creating
Throws:
NullPointerException - if context is null
IOException - if an input/output error occurs while rendering

encodeChildren

public void encodeChildren(FacesContext context)
                    throws IOException
Description copied from class: UIComponent

If our rendered property is true, render the child UIComponents of this UIComponent. This method will only be called if the rendersChildren property is true.

If a Renderer is associated with this UIComponent, the actual encoding will be delegated to Renderer.encodeBegin(FacesContext, UIComponent).

Specified by:
encodeChildren in class UIComponent
Parameters:
context - FacesContext for the response we are creating
Throws:
NullPointerException - if context is null
IOException - if an input/output error occurs while rendering

encodeEnd

public void encodeEnd(FacesContext context)
               throws IOException
Description copied from class: UIComponent

If our rendered property is true, render the ending of the current state of this UIComponent.

If a Renderer is associated with this UIComponent, the actual encoding will be delegated to Renderer.encodeBegin(FacesContext, UIComponent).

Specified by:
encodeEnd in class UIComponent
Parameters:
context - FacesContext for the response we are creating
Throws:
IOException - if an input/output error occurs while rendering
NullPointerException - if context is null

addFacesListener

protected void addFacesListener(FacesListener listener)

Add the specified FacesListener to the set of listeners registered to receive event notifications from this UIComponent. It is expected that UIComponent classes acting as event sources will have corresponding typesafe APIs for registering listeners of the required type, and the implementation of those registration methods will delegate to this method. For example:

 public class FooEvent extends FacesEvent {
   ...
   protected boolean isAppropriateListener(FacesListener listener) {
     return (listener instanceof FooListener);
   }
   protected void processListener(FacesListener listener) {
     ((FooListener) listener).processFoo(this);
   }
   ...
 }

 public interface FooListener extends FacesListener {
   public void processFoo(FooEvent event);
 }

 public class FooComponent extends UIComponentBase {
   ...
   public void addFooListener(FooListener listener) {
     addFacesListener(listener);
   }
   public void removeFooListener(FooListener listener) {
     removeFacesListener(listener);
   }
   ...
 }

Specified by:
addFacesListener in class UIComponent
Parameters:
listener - The FacesListener to be registered
Throws:
NullPointerException - if listener is null

getFacesListeners

protected FacesListener[] getFacesListeners(Class clazz)
Description copied from class: UIComponent

Return an array of registered FacesListeners that are instances of the specified class. If there are no such registered listeners, a zero-length array is returned. The returned array can be safely be cast to an array strongly typed to an element type of clazz.

Specified by:
getFacesListeners in class UIComponent
Parameters:
clazz - Class that must be implemented by a FacesListener for it to be returned
Throws:
IllegalArgumentException - if class is not, and does not implement, FacesListener
NullPointerException - if clazz is null

removeFacesListener

protected void removeFacesListener(FacesListener listener)

Remove the specified FacesListener from the set of listeners registered to receive event notifications from this UIComponent.

Specified by:
removeFacesListener in class UIComponent
Parameters:
listener - The FacesListener to be deregistered
Throws:
NullPointerException - if listener is null

queueEvent

public void queueEvent(FacesEvent event)
Description copied from class: UIComponent

Queue an event for broadcast at the end of the current request processing lifecycle phase. The default implementation in UIComponentBase must delegate this call to the queueEvent() method of the parent UIComponent.

Specified by:
queueEvent in class UIComponent
Parameters:
event - FacesEvent to be queued
Throws:
IllegalStateException - if this component is not a descendant of a UIViewRoot
NullPointerException - if event is null

processDecodes

public void processDecodes(FacesContext context)
Description copied from class: UIComponent

Perform the component tree processing required by the Apply Request Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

  • If the rendered property of this UIComponent is false, skip further processing.
  • Call the processDecodes() method of all facets and children of this UIComponent, in the order determined by a call to getFacetsAndChildren().
  • Call the decode() method of this component.
  • If a RuntimeException is thrown during decode processing, call FacesContext.renderResponse() and re-throw the exception.

Specified by:
processDecodes in class UIComponent
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processValidators

public void processValidators(FacesContext context)
Description copied from class: UIComponent

Perform the component tree processing required by the Process Validations phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

  • If the rendered property of this UIComponent is false, skip further processing.
  • Call the processValidators() method of all facets and children of this UIComponent, in the order determined by a call to getFacetsAndChildren().

Specified by:
processValidators in class UIComponent
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processUpdates

public void processUpdates(FacesContext context)
Description copied from class: UIComponent

Perform the component tree processing required by the Update Model Values phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

  • If the rendered property of this UIComponent is false, skip further processing.
  • Call the processUpdates() method of all facets and children of this UIComponent, in the order determined by a call to getFacetsAndChildren().

Specified by:
processUpdates in class UIComponent
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processSaveState

public Object processSaveState(FacesContext context)
Description copied from class: UIComponent

Perform the component tree processing required by the state saving portion of the Render Response phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

  • consult the transient property of this component. If true, just return null.
  • Call the processSaveState() method of all facets and children of this UIComponent in the order determined by a call to getFacetsAndChildren(), skipping children and facets that are transient.
  • Call the saveState() method of this component.
  • Encapsulate the child state and your state into a Serializable Object and return it.

This method may not be called if the state saving method is set to server.

Specified by:
processSaveState in class UIComponent
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processRestoreState

public void processRestoreState(FacesContext context,
                                Object state)
Description copied from class: UIComponent

Perform the component tree processing required by the Restore View phase of the request processing lifecycle for all facets of this component, all children of this component, and this component itself, as follows.

  • Call the processRestoreState() method of all facets and children of this UIComponent in the order determined by a call to getFacetsAndChildren().
  • Call the restoreState() method of this component.

This method may not be called if the state saving method is set to server.

Specified by:
processRestoreState in class UIComponent
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

getFacesContext

protected FacesContext getFacesContext()
Description copied from class: UIComponent

Convenience method to return the FacesContext instance for the current request.

Specified by:
getFacesContext in class UIComponent

getRenderer

protected Renderer getRenderer(FacesContext context)
Description copied from class: UIComponent

Convenience method to return the Renderer instance associated with this component, if any; otherwise, return null.

Specified by:
getRenderer in class UIComponent
Parameters:
context - FacesContext for the current request

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

isTransient

public boolean isTransient()
Description copied from interface: StateHolder

If true, the Object implementing this interface must not participate in state saving or restoring.

setTransient

public void setTransient(boolean transientFlag)
Description copied from interface: StateHolder

Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

Parameters:
transientFlag - boolean pass true if this Object will participate in state saving or restoring, otherwise pass false.

saveAttachedState

public static Object saveAttachedState(FacesContext context,
                                       Object attachedObject)

This method is called by UIComponent subclasses that want to save one or more attached objects. It is a convenience method that does the work of saving attached objects that may or may not implement the StateHolder interface. Using this method implies the use of restoreAttachedState(javax.faces.context.FacesContext, java.lang.Object) to restore the attached objects.

This method supports saving attached objects of the following type: Objects, null values, and Lists of these objects. If any contained objects are not Lists and do not implement StateHolder, they must have zero-argument public constructors. The exact structure of the returned object is undefined and opaque, but will be serializable.

Parameters:
context - the FacesContext for this request.
attachedObject - the object, which may be a List instance, or an Object. The attachedObject (or the elements that comprise attachedObject may implement StateHolder.
Throws:
NullPointerException - if the context argument is null.

restoreAttachedState

public static Object restoreAttachedState(FacesContext context,
                                          Object stateObj)
                                   throws IllegalStateException

This method is called by UIComponent subclasses that need to restore the objects they saved using saveAttachedState(javax.faces.context.FacesContext, java.lang.Object). This method is tightly coupled with saveAttachedState(javax.faces.context.FacesContext, java.lang.Object).

This method supports restoring all attached objects types supported by saveAttachedState(javax.faces.context.FacesContext, java.lang.Object).

Parameters:
context - the FacesContext for this request
stateObj - the opaque object returned from saveAttachedState(javax.faces.context.FacesContext, java.lang.Object)
Throws:
NullPointerException - if context is null.
IllegalStateException - if the object is not previously returned by saveAttachedState(javax.faces.context.FacesContext, java.lang.Object).
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIData

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UIData

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIData
All Implemented Interfaces:
NamingContainer, StateHolder
Direct Known Subclasses:
HtmlDataTable
public class UIData
extends UIComponentBase
implements NamingContainer

UIData is a UIComponent that supports data binding to a collection of data objects represented by a DataModel instance, which is the current value of this component itself (typically established via a ValueExpression). During iterative processing over the rows of data in the data model, the object for the current row is exposed as a request attribute under the key specified by the var property.

Only children of type UIColumn should be processed by renderers associated with this component.

By default, the rendererType property is set to javax.faces.Table. This value can be changed by calling the setRendererType() method.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIComponent
bindings
Fields inherited from interface javax.faces.component.NamingContainer
SEPARATOR_CHAR
Constructor Summary
UIData()
Create a new UIData instance with default property values.
Method Summary
 void broadcast(FacesEvent event)
Override the default UIComponentBase.broadcast(javax.faces.event.FacesEvent) processing to unwrap any wrapped FacesEvent and reset the current row index, before the event is actually broadcast.
 void encodeBegin(FacesContext context)
In addition to the default behavior, ensure that any saved per-row state for our child input components is discarded unless it is needed to rerender the current page with errors.
 String getClientId(FacesContext context)
Return a client identifier for this component that includes the current value of the rowIndex property, if it is not set to -1.
protected  DataModel getDataModel()
Return the internal DataModel object representing the data objects that we will iterate over in this component's rendering.
 String getFamily()
Return the identifier of the component family to which this component belongs.
 int getFirst()
Return the zero-relative row number of the first row to be displayed.
 UIComponent getFooter()
Return the footer facet of this component (if any).
 UIComponent getHeader()
Return the header facet of this component (if any).
 int getRowCount()
Return the number of rows in the underlying data model.
 Object getRowData()
Return the data object representing the data for the currently selected row index, if any.
 int getRowIndex()
Return the zero-relative index of the currently selected row.
 int getRows()
Return the number of rows to be displayed, or zero for all remaining rows in the table.
 Object getValue()
Return the value of the UIData.
 String getVar()
Return the request-scope attribute under which the data object for the current row will be exposed when iterating.
 boolean invokeOnComponent(FacesContext context, String clientId, ContextCallback callback)
Override behavior from UIComponentBase.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) to provide special care for positioning the data properly before finding the component and invoking the callback on it.
 boolean isRowAvailable()
Return a flag indicating whether there is rowData available at the current rowIndex.
 void processDecodes(FacesContext context)
Override the default UIComponentBase.processDecodes(javax.faces.context.FacesContext) processing to perform the following steps.
 void processUpdates(FacesContext context)
Override the default UIComponentBase.processUpdates(javax.faces.context.FacesContext) processing to perform the following steps.
 void processValidators(FacesContext context)
Override the default UIComponentBase.processValidators(javax.faces.context.FacesContext) processing to perform the following steps.
 void queueEvent(FacesEvent event)
Override the default UIComponentBase.queueEvent(javax.faces.event.FacesEvent) processing to wrap any queued events in a wrapper so that we can reset the current row index in broadcast().
 void restoreState(FacesContext context, Object state)
Perform any processing required to restore the state from the entries in the state Object.
 Object saveState(FacesContext context)
Gets the state of the instance as a Serializable Object.
protected  void setDataModel(DataModel dataModel)
Set the internal DataModel.
 void setFirst(int first)
Set the zero-relative row number of the first row to be displayed.
 void setFooter(UIComponent footer)
Set the footer facet of this component.
 void setHeader(UIComponent header)
Set the header facet of this component.
 void setRowIndex(int rowIndex)
Set the zero relative index of the current row, or -1 to indicate that no row is currently selected, by implementing the following algorithm.
 void setRows(int rows)
Set the number of rows to be displayed, or zero for all remaining rows in the table.
 void setValue(Object value)
Set the value of the UIData.
 void setValueBinding(String name, ValueBinding binding)
Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).
 void setValueExpression(String name, ValueExpression binding)
Set the ValueExpression used to calculate the value for the specified attribute or property name, if any.
 void setVar(String var)
Set the request-scope attribute under which the data object for the current row wil be exposed when iterating.
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, decode, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, isRendered, isTransient, processRestoreState, processSaveState, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UIData

public UIData()

Create a new UIData instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent

getFirst

public int getFirst()

Return the zero-relative row number of the first row to be displayed.

setFirst

public void setFirst(int first)

Set the zero-relative row number of the first row to be displayed.

Parameters:
first - New first row number
Throws:
IllegalArgumentException - if first is negative

getFooter

public UIComponent getFooter()

Return the footer facet of this component (if any). A convenience method for getFacet("footer").

setFooter

public void setFooter(UIComponent footer)

Set the footer facet of this component. A convenience method for getFacets().put("footer", footer).

Parameters:
footer - the new footer facet
Throws:
NullPointerException - if footer is null

getHeader

public UIComponent getHeader()

Return the header facet of this component (if any). A convenience method for getFacet("header").

setHeader

public void setHeader(UIComponent header)

Set the header facet of this component. A convenience method for getFacets().put("header", header).

Parameters:
header - the new header facet
Throws:
NullPointerException - if header is null

isRowAvailable

public boolean isRowAvailable()

Return a flag indicating whether there is rowData available at the current rowIndex. If no wrappedData is available, return false.

Throws:
FacesException - if an error occurs getting the row availability

getRowCount

public int getRowCount()

Return the number of rows in the underlying data model. If the number of available rows is unknown, return -1.

Throws:
FacesException - if an error occurs getting the row count

getRowData

public Object getRowData()

Return the data object representing the data for the currently selected row index, if any.

Throws:
FacesException - if an error occurs getting the row data
IllegalArgumentException - if now row data is available at the currently specified row index

getRowIndex

public int getRowIndex()

Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, return -1. This property is not enabled for value binding expressions.

Throws:
FacesException - if an error occurs getting the row index

setRowIndex

public void setRowIndex(int rowIndex)

Set the zero relative index of the current row, or -1 to indicate that no row is currently selected, by implementing the following algorithm. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

  • Save current state information for all descendant components (as described below).
  • Store the new row index, and pass it on to the DataModel associated with this UIData instance.
  • If the new rowIndex value is -1:
    • If the var property is not null, remove the corresponding request scope attribute (if any).
    • Reset the state information for all descendant components (as described below).
  • If the new rowIndex value is not -1:
    • If the var property is not null, call getRowData() and expose the resulting data object as a request scope attribute whose key is the var property value.
    • Reset the state information for all descendant components (as described below).

To save current state information for all descendant components, UIData must maintain per-row information for each descendant as follows:

  • If the descendant is an instance of EditableValueHolder, save the state of its localValue property.
  • If the descendant is an instance of EditableValueHolder, save the state of the localValueSet property.
  • If the descendant is an instance of EditableValueHolder, save the state of the valid property.
  • If the descendant is an instance of EditableValueHolder, save the state of the submittedValue property.

To restore current state information for all descendant components, UIData must reference its previously stored information for the current rowIndex and call setters for each descendant as follows:

  • If the descendant is an instance of EditableValueHolder, restore the value property.
  • If the descendant is an instance of EditableValueHolder, restore the state of the localValueSet property.
  • If the descendant is an instance of EditableValueHolder, restore the state of the valid property.
  • If the descendant is an instance of EditableValueHolder, restore the state of the submittedValue property.

Parameters:
rowIndex - The new row index value, or -1 for no associated row
Throws:
FacesException - if an error occurs setting the row index
IllegalArgumentException - if rowIndex is less than -1

getRows

public int getRows()

Return the number of rows to be displayed, or zero for all remaining rows in the table. The default value of this property is zero.

setRows

public void setRows(int rows)

Set the number of rows to be displayed, or zero for all remaining rows in the table.

Parameters:
rows - New number of rows
Throws:
IllegalArgumentException - if rows is negative

getVar

public String getVar()

Return the request-scope attribute under which the data object for the current row will be exposed when iterating. This property is not enabled for value binding expressions.

setVar

public void setVar(String var)

Set the request-scope attribute under which the data object for the current row wil be exposed when iterating.

Parameters:
var - The new request-scope attribute name

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase

getValue

public Object getValue()

Return the value of the UIData. This value must either be be of type DataModel, or a type that can be adapted into a DataModel. UIData will automatically adapt the following types:

  • Arrays
  • java.util.List
  • java.sql.ResultSet
  • javax.servlet.jsp.jstl.sql.Result

All other types will be adapted using the ScalarDataModel class, which will treat the object as a single row of data.

setValue

public void setValue(Object value)

Set the value of the UIData. This value must either be be of type DataModel, or a type that can be adapted into a DataModel.

Parameters:
value - the new value

setValueBinding

public void setValueBinding(String name,
                            ValueBinding binding)
Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).

If "name" is something other than "value", "var", or "rowIndex", rely on the superclass conversion from ValueBinding to ValueExpression.

Overrides:
setValueBinding in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to set a ValueBinding
binding - The ValueBinding to set, or null to remove any currently set ValueBinding
Throws:
IllegalArgumentException - if name is one of id, parent, var, or rowIndex
NullPointerException - if name is null

setValueExpression

public void setValueExpression(String name,
                               ValueExpression binding)

Set the ValueExpression used to calculate the value for the specified attribute or property name, if any. In addition, if a ValueExpression is set for the value property, remove any synthesized DataModel for the data previously bound to this component.

Overrides:
setValueExpression in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to set a ValueExpression
binding - The ValueExpression to set, or null to remove any currently set ValueExpression
Throws:
IllegalArgumentException - if name is one of id, parent, var, or rowIndex
NullPointerException - if name is null
Since:
1.2

getClientId

public String getClientId(FacesContext context)

Return a client identifier for this component that includes the current value of the rowIndex property, if it is not set to -1. This implies that multiple calls to getClientId() may return different results, but ensures that child components can themselves generate row-specific client identifiers (since UIData is a NamingContainer).

Overrides:
getClientId in class UIComponentBase
Parameters:
context - The FacesContext for the current request
Throws:
NullPointerException - if context is null

invokeOnComponent

public boolean invokeOnComponent(FacesContext context,
                                 String clientId,
                                 ContextCallback callback)
                          throws FacesException

Override behavior from UIComponentBase.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback) to provide special care for positioning the data properly before finding the component and invoking the callback on it. If the argument clientId is equal to this.getClientId() simply invoke the contextCallback, passing the context argument and this as arguments, and return true. Otherwise, attempt to extract a rowIndex from the clientId. For example, if the argument clientId was form:data:3:customerHeader the rowIndex would be 3. Let this value be called newIndex. The current rowIndex of this instance must be saved aside and restored before returning in all cases, regardless of the outcome of the search or if any exceptions are thrown in the process.

The implementation of this method must never return true if setting the rowIndex of this instance to be equal to newIndex causes this instance to return false from isRowAvailable().

Overrides:
invokeOnComponent in class UIComponentBase
Parameters:
context - the FacesContext for the current request
clientId - the client identifier of the component to be passed to the argument callback.
callback - an implementation of the Callback interface.
Returns:
true if the a component with the given clientId is found, the callback method was successfully invoked passing that component as an argument, and no Exception was thrown. Returns false if no component with the given clientId is found.
Throws:
NullPointerException - if any of the arguments are null
FacesException - if the argument Callback throws an Exception, it is wrapped in a FacesException and re-thrown. Also throws FacesException if any exception is thrown when deriving the rowIndex from the argument clientId.
Since:
1.2

queueEvent

public void queueEvent(FacesEvent event)

Override the default UIComponentBase.queueEvent(javax.faces.event.FacesEvent) processing to wrap any queued events in a wrapper so that we can reset the current row index in broadcast().

Overrides:
queueEvent in class UIComponentBase
Parameters:
event - FacesEvent to be queued
Throws:
IllegalStateException - if this component is not a descendant of a UIViewRoot
NullPointerException - if event is null

broadcast

public void broadcast(FacesEvent event)
               throws AbortProcessingException

Override the default UIComponentBase.broadcast(javax.faces.event.FacesEvent) processing to unwrap any wrapped FacesEvent and reset the current row index, before the event is actually broadcast. For events that we did not wrap (in queueEvent()), default processing will occur.

Overrides:
broadcast in class UIComponentBase
Parameters:
event - The FacesEvent to be broadcast
Throws:
AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
IllegalArgumentException - if the implementation class of this FacesEvent is not supported by this component
NullPointerException - if event is null

encodeBegin

public void encodeBegin(FacesContext context)
                 throws IOException

In addition to the default behavior, ensure that any saved per-row state for our child input components is discarded unless it is needed to rerender the current page with errors.

Overrides:
encodeBegin in class UIComponentBase
Parameters:
context - FacesContext for the current request
Throws:
IOException - if an input/output error occurs while rendering
NullPointerException - if context is null

processDecodes

public void processDecodes(FacesContext context)

Override the default UIComponentBase.processDecodes(javax.faces.context.FacesContext) processing to perform the following steps.

  • If the rendered property of this UIComponent is false, skip further processing.
  • Set the current rowIndex to -1.
  • Call the processDecodes() method of all facets of this UIData, in the order determined by a call to getFacets().keySet().iterator().
  • Call the processDecodes() method of all facets of the UIColumn children of this UIData.
  • Iterate over the set of rows that were included when this component was rendered (i.e. those defined by the first and rows properties), performing the following processing for each row:
    • Set the current rowIndex to the appropriate value for this row.
    • If isRowAvailable() returns true, iterate over the children components of each UIColumn child of this UIData component, calling the processDecodes() method for each such child.
  • Set the current rowIndex to -1.
  • Call the decode() method of this component.
  • If a RuntimeException is thrown during decode processing, call FacesContext.renderResponse() and re-throw the exception.

Overrides:
processDecodes in class UIComponentBase
Parameters:
context - FacesContext for the current request
Throws:
NullPointerException - if context is null

processValidators

public void processValidators(FacesContext context)

Override the default UIComponentBase.processValidators(javax.faces.context.FacesContext) processing to perform the following steps.

  • If the rendered property of this UIComponent is false, skip further processing.
  • Set the current rowIndex to -1.
  • Call the processValidators() method of all facets of this UIData, in the order determined by a call to getFacets().keySet().iterator().
  • Call the processValidators() method of all facets of the UIColumn children of this UIData.
  • Iterate over the set of rows that were included when this component was rendered (i.e. those defined by the first and rows properties), performing the following processing for each row:
    • Set the current rowIndex to the appropriate value for this row.
    • If isRowAvailable() returns true, iterate over the children components of each UIColumn child of this UIData component, calling the processValidators() method for each such child.
  • Set the current rowIndex to -1.

Overrides:
processValidators in class UIComponentBase
Parameters:
context - FacesContext for the current request
Throws:
NullPointerException - if context is null

processUpdates

public void processUpdates(FacesContext context)

Override the default UIComponentBase.processUpdates(javax.faces.context.FacesContext) processing to perform the following steps.

  • If the rendered property of this UIComponent is false, skip further processing.
  • Set the current rowIndex to -1.
  • Call the processUpdates() method of all facets of this UIData, in the order determined by a call to getFacets().keySet().iterator().
  • Call the processUpdates() method of all facets of the UIColumn children of this UIData.
  • Iterate over the set of rows that were included when this component was rendered (i.e. those defined by the first and rows properties), performing the following processing for each row:
    • Set the current rowIndex to the appropriate value for this row.
    • If isRowAvailable() returns true, iterate over the children components of each UIColumn child of this UIData component, calling the processUpdates() method for each such child.
  • Set the current rowIndex to -1.

Overrides:
processUpdates in class UIComponentBase
Parameters:
context - FacesContext for the current request
Throws:
NullPointerException - if context is null

getDataModel

protected DataModel getDataModel()

Return the internal DataModel object representing the data objects that we will iterate over in this component's rendering.

If the model has been cached by a previous call to setDataModel(javax.faces.model.DataModel), return it. Otherwise call getValue(). If the result is null, create an empty ListDataModel and return it. If the result is an instance of DataModel, return it. Otherwise, adapt the result as described in getValue() and return it.

setDataModel

protected void setDataModel(DataModel dataModel)

Set the internal DataModel. This UIData instance must use the given DataModel as its internal value representation from now until the next call to setDataModel. If the given DataModel is null, the internal DataModel must be reset in a manner so that the next call to getDataModel() causes lazy instantion of a newly refreshed DataModel.

Subclasses might call this method if they either want to restore the internal DataModel during the Restore View phase or if they want to explicitly refresh the current DataModel for the Render Response phase.

Parameters:
dataModel - the new DataModel or null to cause the model to be refreshed.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIForm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UIForm

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIForm
All Implemented Interfaces:
NamingContainer, StateHolder
Direct Known Subclasses:
HtmlForm
public class UIForm
extends UIComponentBase
implements NamingContainer

UIForm is a UIComponent that represents an input form to be presented to the user, and whose child components represent (among other things) the input fields to be included when the form is submitted.

By default, the rendererType property must be set to "javax.faces.Form". This value can be changed by calling the setRendererType() method.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIComponent
bindings
Fields inherited from interface javax.faces.component.NamingContainer
SEPARATOR_CHAR
Constructor Summary
UIForm()
Create a new UIForm instance with default property values.
Method Summary
String | getContainerClientId(FacesContext context) Override the UIComponent.getContainerClientId(javax.faces.context.FacesContext) to allow users to disable this form from prepending its clientId to its descendent's clientIds depending on the value of this form's isPrependId() property.
String | getFamily() Return the identifier of the component family to which this component belongs.
boolean | isPrependId()
boolean | isSubmitted() Returns the current value of the submitted property.
void | processDecodes(FacesContext context) Override UIComponent.processDecodes(javax.faces.context.FacesContext) to ensure that the form is decoded before its children.
void | processUpdates(FacesContext context) Override UIComponent.processUpdates(javax.faces.context.FacesContext) to ensure that the children of this UIForm instance are only processed if isSubmitted() returns true.
void | processValidators(FacesContext context) Override UIComponent.processValidators(javax.faces.context.FacesContext) to ensure that the children of this UIForm instance are only processed if isSubmitted() returns true.
void | setPrependId(boolean prependId)
void | setSubmitted(boolean submitted) If this UIForm instance (as opposed to other forms in the page) is experiencing a submit during this request processing lifecycle, this method must be called, with true as the argument, during the UIComponent.decode(javax.faces.context.FacesContext) for this UIForm instance.
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UIForm

public UIForm()

Create a new UIForm instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent

isSubmitted

public boolean isSubmitted()

Returns the current value of the submitted property. The default value is false. See setSubmitted(boolean) for details.

setSubmitted

public void setSubmitted(boolean submitted)

If this UIForm instance (as opposed to other forms in the page) is experiencing a submit during this request processing lifecycle, this method must be called, with true as the argument, during the UIComponent.decode(javax.faces.context.FacesContext) for this UIForm instance. If this UIForm instance is not experiencing a submit, this method must be called, with false as the argument, during the UIComponent.decode(javax.faces.context.FacesContext) for this UIForm instance.

The value of a UIForm's submitted property must not be saved as part of its state.

isPrependId

public boolean isPrependId()

setPrependId

public void setPrependId(boolean prependId)

processDecodes

public void processDecodes(FacesContext context)

Override UIComponent.processDecodes(javax.faces.context.FacesContext) to ensure that the form is decoded before its children. This is necessary to allow the submitted property to be correctly set.

Overrides:
processDecodes in class UIComponentBase
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processValidators

public void processValidators(FacesContext context)

Override UIComponent.processValidators(javax.faces.context.FacesContext) to ensure that the children of this UIForm instance are only processed if isSubmitted() returns true.

Overrides:
processValidators in class UIComponentBase
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processUpdates

public void processUpdates(FacesContext context)

Override UIComponent.processUpdates(javax.faces.context.FacesContext) to ensure that the children of this UIForm instance are only processed if isSubmitted() returns true.

Overrides:
processUpdates in class UIComponentBase
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

getContainerClientId

public String getContainerClientId(FacesContext context)

Override the UIComponent.getContainerClientId(javax.faces.context.FacesContext) to allow users to disable this form from prepending its clientId to its descendent's clientIds depending on the value of this form's isPrependId() property.

Overrides:
getContainerClientId in class UIComponent
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIGraphic

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UIGraphic

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIGraphic
All Implemented Interfaces:
StateHolder
Direct Known Subclasses:
HtmlGraphicImage
public class UIGraphic
extends UIComponentBase

UIGraphic is a UIComponent that displays a graphical image to the user. The user cannot manipulate this component; it is for display purposes only.

By default, the rendererType property must be set to "javax.faces.Image". This value can be changed by calling the setRendererType() method.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UIGraphic()
Create a new UIGraphic instance with default property values.
Method Summary
 String getFamily()
Return the identifier of the component family to which this component belongs.
 String getUrl()
Return the image URL for this UIGraphic.
 Object getValue()
Returns the value property of the UIGraphic.
 ValueBinding getValueBinding(String name)
Deprecated. This has been replaced by getValueExpression(java.lang.String).
 ValueExpression getValueExpression(String name)
Return any ValueExpression set for value if a ValueExpression for url is requested; otherwise, perform the default superclass processing for this method.
 void restoreState(FacesContext context, Object state)
Perform any processing required to restore the state from the entries in the state Object.
 Object saveState(FacesContext context)
Gets the state of the instance as a Serializable Object.
 void setUrl(String url)
Set the image URL for this UIGraphic.
 void setValue(Object value)
Sets the value property of the UIGraphic.
 void setValueBinding(String name, ValueBinding binding)
Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).
 void setValueExpression(String name, ValueExpression binding)
Store any ValueExpression specified for url under value instead; otherwise, perform the default superclass processing for this method.
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UIGraphic

public UIGraphic()

Create a new UIGraphic instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent

getUrl

public String getUrl()

Return the image URL for this UIGraphic. This method is a typesafe alias for getValue().

setUrl

public void setUrl(String url)

Set the image URL for this UIGraphic. This method is a typesafe alias for setValue().

Parameters:
url - The new image URL

getValue

public Object getValue()

Returns the value property of the UIGraphic. This will typically be rendered as an URL.

setValue

public void setValue(Object value)

Sets the value property of the UIGraphic. This will typically be rendered as an URL.

Parameters:
value - the new value

getValueBinding

public ValueBinding getValueBinding(String name)
Deprecated. This has been replaced by getValueExpression(java.lang.String).

Return any ValueBinding set for value if a ValueBinding for url is requested; otherwise, perform the default superclass processing for this method.

Overrides:
getValueBinding in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to retrieve a ValueBinding
Throws:
NullPointerException - if name is null

setValueBinding

public void setValueBinding(String name,
                            ValueBinding binding)
Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).

Store any ValueBinding specified for url under value instead; otherwise, perform the default superclass processing for this method. In all cases, the superclass is relied on to convert the ValueBinding to a ValueExpression.

Overrides:
setValueBinding in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to set a ValueBinding
binding - The ValueBinding to set, or null to remove any currently set ValueBinding
Throws:
NullPointerException - if name is null

getValueExpression

public ValueExpression getValueExpression(String name)

Return any ValueExpression set for value if a ValueExpression for url is requested; otherwise, perform the default superclass processing for this method.

Overrides:
getValueExpression in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to retrieve a ValueExpression
Throws:
NullPointerException - if name is null
Since:
1.2

setValueExpression

public void setValueExpression(String name,
                               ValueExpression binding)

Store any ValueExpression specified for url under value instead; otherwise, perform the default superclass processing for this method.

Overrides:
setValueExpression in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to set a ValueExpression
binding - The ValueExpression to set, or null to remove any currently set ValueExpression
Throws:
NullPointerException - if name is null
Since:
1.2

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIInput

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UIInput

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
Direct Known Subclasses:
HtmlInputHidden, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, UISelectBoolean, UISelectMany, UISelectOne
public class UIInput
extends UIOutput
implements EditableValueHolder

UIInput is a UIComponent that represents a component that both displays output to the user (like UIOutput components do) and processes request parameters on the subsequent request that need to be decoded. There are no restrictions on the data type of the local value, or the object referenced by the value binding expression (if any); however, individual Renderers will generally impose restrictions on the type of data they know how to display.

During the Apply Request Values phase of the request processing lifecycle, the decoded value of this component, usually but not necessarily a String, must be stored - but not yet converted - using setSubmittedValue(). If the component wishes to indicate that no particular value was submitted, it can either do nothing, or set the submitted value to null.

By default, during the Process Validators phase of the request processing lifecycle, the submitted value will be converted to a typesafe object, and, if validation succeeds, stored as a local value using setValue(). However, if the immediate property is set to true, this processing will occur instead at the end of the Apply Request Values phase.

During the Render Response phase of the request processing lifecycle, conversion for output occurs as for UIOutput.

When the validate() method of this UIInput detects that a value change has actually occurred, and that all validations have been successfully passed, it will queue a ValueChangeEvent. Later on, the broadcast() method will ensure that this event is broadcast to all interested listeners. This event will be delivered by default in the Process Validators phase, but can be delivered instead during Apply Request Values if the immediate property is set to true.

By default, the rendererType property must be set to "Text". This value can be changed by calling the setRendererType() method.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
static String | CONVERSION_MESSAGE_ID The message identifier of the FacesMessage to be created if a conversion error occurs, and neither the page author nor the ConverterException provides a message.
static String | REQUIRED_MESSAGE_ID The message identifier of the FacesMessage to be created if a required check fails.
static String | UPDATE_MESSAGE_ID The message identifier of the FacesMessage to be created if a model update error occurs, and the thrown exception has no message.
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UIInput()
Create a new UIInput instance with default property values.
Method Summary
 void addValidator(Validator validator)
Add a Validator instance to the set associated with this UIInput.
 void addValueChangeListener(ValueChangeListener listener)
Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.
protected  boolean compareValues(Object previous, Object value)
Return true if the new value is different from the previous value.
 void decode(FacesContext context)
Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.
protected  Object getConvertedValue(FacesContext context, Object newSubmittedValue)
Convert the submitted value into a "local value" of the appropriate data type, if necessary.
 String getConverterMessage()
If there has been a call to setConverterMessage(java.lang.String) on this instance, return the message.
 String getFamily()
Return the identifier of the component family to which this component belongs.
 String getRequiredMessage()
If there has been a call to setRequiredMessage(java.lang.String) on this instance, return the message.
 Object getSubmittedValue()
Return the submittedValue value of this UIInput component.
 MethodBinding getValidator()
Deprecated. getValidators() should be used instead.
 String getValidatorMessage()
If there has been a call to setRequiredMessage(java.lang.String) on this instance, return the message.
 Validator[] getValidators()
Return the set of registered Validators for this UIInput instance.
 MethodBinding getValueChangeListener()
If EditableValueHolder.setValueChangeListener(javax.faces.el.MethodBinding) was not previously called for this instance, this method must return null.
 ValueChangeListener[] getValueChangeListeners()
Return the set of registered ValueChangeListeners for this UIInput instance.
 boolean isImmediate()
Return the "immediate" state for this component.
 boolean isLocalValueSet()
Return the "local value set" state for this component.
 boolean isRequired()
Return the "required field" state for this component.
 boolean isValid()
Return a flag indicating whether the local value of this component is valid (no conversion error has occurred).
 void processDecodes(FacesContext context)
Specialized decode behavior on top of that provided by the superclass.
 void processUpdates(FacesContext context)
In addition to the standard processUpdates behavior inherited from UIComponentBase, calls updateModel().
 void processValidators(FacesContext context)
In addition to the standard processValidators behavior inherited from UIComponentBase, calls validate() if the immediate property is false (which is the default); if the component is invalid afterwards, calls FacesContext.renderResponse().
 void removeValidator(Validator validator)
Remove a Validator instance from the set associated with this UIInput, if it was previously associated.
 void removeValueChangeListener(ValueChangeListener listener)
Remove an existing ValueChangeListener (if any) from the set of listeners interested in being notified when ValueChangeEvents occur.
 void resetValue()
Convenience method to reset this component's value to the un-initialized state.
 void restoreState(FacesContext context, Object state)
Perform any processing required to restore the state from the entries in the state Object.
 Object saveState(FacesContext context)
Gets the state of the instance as a Serializable Object.
 void setConverterMessage(String message)
Override any ValueExpression set for the "converterMessage" with the literal argument provided to this method.
 void setImmediate(boolean immediate)
Set the "immediate" state for this component.
 void setLocalValueSet(boolean localValueSet)
Sets the "local value set" state for this component.
 void setRequired(boolean required)
Set the "required field" state for this component.
 void setRequiredMessage(String message)
Override any ValueExpression set for the "requiredMessage" with the literal argument provided to this method.
 void setSubmittedValue(Object submittedValue)
Set the submittedValue value of this UIInput component.
 void setValid(boolean valid)
Set a flag indicating whether the local value of this component is valid (no conversion error has occurred).
 void setValidator(MethodBinding validatorBinding)
Deprecated. Use addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.
 void setValidatorMessage(String message)
Override any ValueExpression set for the "validatorMessage" with the literal argument provided to this method.
 void setValue(Object value)
Set the value of this UIComponent (if any).
 void setValueChangeListener(MethodBinding valueChangeListener)
Deprecated. Use addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.
 void updateModel(FacesContext context)
Perform the following algorithm to update the model data associated with this UIInput, if any, as appropriate.
 void validate(FacesContext context)
Perform the following algorithm to validate the local value of this UIInput.
protected  void validateValue(FacesContext context, Object newValue)
Set the "valid" property according to the below algorithm.
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values

CONVERSION_MESSAGE_ID

public static final String CONVERSION_MESSAGE_ID

The message identifier of the FacesMessage to be created if a conversion error occurs, and neither the page author nor the ConverterException provides a message.

See Also:
Constant Field Values

REQUIRED_MESSAGE_ID

public static final String REQUIRED_MESSAGE_ID

The message identifier of the FacesMessage to be created if a required check fails.

See Also:
Constant Field Values

UPDATE_MESSAGE_ID

public static final String UPDATE_MESSAGE_ID

The message identifier of the FacesMessage to be created if a model update error occurs, and the thrown exception has no message.

See Also:
Constant Field Values
Constructor Detail

UIInput

public UIInput()

Create a new UIInput instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Overrides:
getFamily in class UIOutput

getSubmittedValue

public Object getSubmittedValue()

Return the submittedValue value of this UIInput component. This method should only be used by the decode() and validate() method of this component, or its corresponding Renderer.

Specified by:
getSubmittedValue in interface EditableValueHolder

setSubmittedValue

public void setSubmittedValue(Object submittedValue)

Set the submittedValue value of this UIInput component. This method should only be used by the decode() and validate() method of this component, or its corresponding Renderer.

Specified by:
setSubmittedValue in interface EditableValueHolder
Parameters:
submittedValue - The new submitted value

setValue

public void setValue(Object value)
Description copied from interface: ValueHolder

Set the value of this UIComponent (if any).

Specified by:
setValue in interface ValueHolder
Overrides:
setValue in class UIOutput
Parameters:
value - The new local value

resetValue

public void resetValue()

Convenience method to reset this component's value to the un-initialized state. This method does the following:

Call setValue(java.lang.Object) passing null.

Call setSubmittedValue(java.lang.Object) passing null.

Call setLocalValueSet(boolean) passing false.

Call setValid(boolean) passing true.

Upon return from this call if the instance had a ValueBinding associated with it for the "value" property, this binding is evaluated when UIOutput.getValue() is called. Otherwise, null is returned from getValue().

isLocalValueSet

public boolean isLocalValueSet()
Return the "local value set" state for this component. Calls to setValue() automatically reset this property to true.

Specified by:
isLocalValueSet in interface EditableValueHolder

setLocalValueSet

public void setLocalValueSet(boolean localValueSet)
Sets the "local value set" state for this component.

Specified by:
setLocalValueSet in interface EditableValueHolder

isRequired

public boolean isRequired()

Return the "required field" state for this component.

Specified by:
isRequired in interface EditableValueHolder

getRequiredMessage

public String getRequiredMessage()

If there has been a call to setRequiredMessage(java.lang.String) on this instance, return the message. Otherwise, call UIComponentBase.getValueExpression(java.lang.String) passing the key "requiredMessage", get the result of the expression, and return it. Any ELExceptions thrown during the call to getValue() must be wrapped in a FacesException and rethrown.

setRequiredMessage

public void setRequiredMessage(String message)

Override any ValueExpression set for the "requiredMessage" with the literal argument provided to this method. Subsequent calls to getRequiredMessage() will return this value;

Parameters:
message - the literal message value to be displayed in the event the user hasn't supplied a value and one is required.

getConverterMessage

public String getConverterMessage()

If there has been a call to setConverterMessage(java.lang.String) on this instance, return the message. Otherwise, call UIComponentBase.getValueExpression(java.lang.String) passing the key "converterMessage", get the result of the expression, and return it. Any ELExceptions thrown during the call to getValue() must be wrapped in a FacesException and rethrown.

setConverterMessage

public void setConverterMessage(String message)

Override any ValueExpression set for the "converterMessage" with the literal argument provided to this method. Subsequent calls to getConverterMessage() will return this value;

Parameters:
message - the literal message value to be displayed in the event conversion fails.

getValidatorMessage

public String getValidatorMessage()

If there has been a call to setRequiredMessage(java.lang.String) on this instance, return the message. Otherwise, call UIComponentBase.getValueExpression(java.lang.String) passing the key "requiredMessage", get the result of the expression, and return it. Any ELExceptions thrown during the call to getValue() must be wrapped in a FacesException and rethrown.

setValidatorMessage

public void setValidatorMessage(String message)

Override any ValueExpression set for the "validatorMessage" with the literal argument provided to this method. Subsequent calls to getValidatorMessage() will return this value;

Parameters:
message - the literal message value to be displayed in the event validation fails.

isValid

public boolean isValid()
Description copied from interface: EditableValueHolder

Return a flag indicating whether the local value of this component is valid (no conversion error has occurred).

Specified by:
isValid in interface EditableValueHolder

setValid

public void setValid(boolean valid)
Description copied from interface: EditableValueHolder

Set a flag indicating whether the local value of this component is valid (no conversion error has occurred).

Specified by:
setValid in interface EditableValueHolder
Parameters:
valid - The new valid flag

setRequired

public void setRequired(boolean required)

Set the "required field" state for this component.

Specified by:
setRequired in interface EditableValueHolder
Parameters:
required - The new "required field" state

isImmediate

public boolean isImmediate()
Description copied from interface: EditableValueHolder

Return the "immediate" state for this component.

Specified by:
isImmediate in interface EditableValueHolder

setImmediate

public void setImmediate(boolean immediate)
Description copied from interface: EditableValueHolder

Set the "immediate" state for this component. When set to true, the component's value will be converted and validated immediately in the Apply Request Values phase, and ValueChangeEvents will be delivered in that phase as well. The default value for this property must be false.

Specified by:
setImmediate in interface EditableValueHolder
Parameters:
immediate - The new "immediate" state

getValidator

public MethodBinding getValidator()
Deprecated. getValidators() should be used instead.

Return a MethodBinding pointing at a method that will be called during Process Validations phase of the request processing lifecycle, to validate the current value of this component.

Specified by:
getValidator in interface EditableValueHolder

setValidator

public void setValidator(MethodBinding validatorBinding)
Deprecated. Use addValidator(javax.faces.validator.Validator) instead, obtaining the argument Validator by creating an instance of MethodExpressionValidator.

Set a MethodBinding pointing at a method that will be called during Process Validations phase of the request processing lifecycle, to validate the current value of this component.

Any method referenced by such an expression must be public, with a return type of void, and accept parameters of type FacesContext, UIComponent, and Object.

Specified by:
setValidator in interface EditableValueHolder
Parameters:
validatorBinding - The new MethodBinding instance

getValueChangeListener

public MethodBinding getValueChangeListener()
Description copied from interface: EditableValueHolder

If EditableValueHolder.setValueChangeListener(javax.faces.el.MethodBinding) was not previously called for this instance, this method must return null. If it was called, this method must return the exact MethodBinding instance that was passed to EditableValueHolder.setValueChangeListener(javax.faces.el.MethodBinding).

Specified by:
getValueChangeListener in interface EditableValueHolder

setValueChangeListener

public void setValueChangeListener(MethodBinding valueChangeListener)
Deprecated. Use addValueChangeListener(javax.faces.event.ValueChangeListener) instead, obtaining the argument ValueChangeListener by creating an instance of MethodExpressionValueChangeListener.

Wrap the argument valueChangeMethod in an implementation of ValueChangeListener and store it in the internal data structure that backs the EditableValueHolder.getValueChangeListeners() method, taking care to over-write any instance that was stored by a previous call to setValueChangeListener.

This argument method will be called during the Process Validations or Apply Request Values phases (depending on the value of the immediate property).

Any method referenced by such an expression must be public, with a return type of void, and accept a parameter of type ValueChangeEvent.

Specified by:
setValueChangeListener in interface EditableValueHolder
Parameters:
valueChangeListener - The new method binding instance

processDecodes

public void processDecodes(FacesContext context)

Specialized decode behavior on top of that provided by the superclass. In addition to the standard processDecodes behavior inherited from UIComponentBase, calls validate() if the the immediate property is true; if the component is invalid afterwards or a RuntimeException is thrown, calls FacesContext.renderResponse().

Overrides:
processDecodes in class UIComponentBase
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processValidators

public void processValidators(FacesContext context)

In addition to the standard processValidators behavior inherited from UIComponentBase, calls validate() if the immediate property is false (which is the default); if the component is invalid afterwards, calls FacesContext.renderResponse(). If a RuntimeException is thrown during validation processing, calls FacesContext.renderResponse() and re-throw the exception.

Overrides:
processValidators in class UIComponentBase
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processUpdates

public void processUpdates(FacesContext context)

In addition to the standard processUpdates behavior inherited from UIComponentBase, calls updateModel(). If the component is invalid afterwards, calls FacesContext.renderResponse(). If a RuntimeException is thrown during update processing, calls FacesContext.renderResponse() and re-throw the exception.

Overrides:
processUpdates in class UIComponentBase
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

decode

public void decode(FacesContext context)
Description copied from class: UIComponent

Decode any new state of this UIComponent from the request contained in the specified FacesContext, and store this state as needed.

During decoding, events may be enqueued for later processing (by event listeners who have registered an interest), by calling queueEvent().

Overrides:
decode in class UIComponentBase
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

updateModel

public void updateModel(FacesContext context)

Perform the following algorithm to update the model data associated with this UIInput, if any, as appropriate.

  • If the valid property of this component is false, take no further action.
  • If the localValueSet property of this component is false, take no further action.
  • If no ValueExpression for value exists, take no further action.
  • Call setValue() method of the ValueExpression to update the value that the ValueExpression points at.
  • If the setValue() method returns successfully:
    • Clear the local value of this UIInput.
    • Set the localValueSet property of this UIInput to false.
  • If the setValue() method call fails:
    • Enqueue an error message by calling addMessage() on the specified FacesContext instance.
    • Set the valid property of this UIInput to false.

Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

validate

public void validate(FacesContext context)

Perform the following algorithm to validate the local value of this UIInput.

  • Retrieve the submitted value with getSubmittedValue(). If this returns null, exit without further processing. (This indicates that no value was submitted for this component.)
  • Convert the submitted value into a "local value" of the appropriate data type by calling getConvertedValue(javax.faces.context.FacesContext, java.lang.Object).
  • Validate the property by calling validateValue(javax.faces.context.FacesContext, java.lang.Object).
  • If the valid property of this component is still true, retrieve the previous value of the component (with getValue()), store the new local value using setValue(), and reset the submitted value to null. If the local value is different from the previous value of this component, fire a ValueChangeEvent to be broadcast to all interested listeners.

Application components implementing UIInput that wish to perform validation with logic embedded in the component should perform their own correctness checks, and then call the super.validate() method to perform the standard processing described above.

Parameters:
context - The FacesContext for the current request
Throws:
NullPointerException - if context is null

getConvertedValue

protected Object getConvertedValue(FacesContext context,
                                   Object newSubmittedValue)
                            throws ConverterException

Convert the submitted value into a "local value" of the appropriate data type, if necessary. Employ the following algorithm to do so:

  • If a Renderer is present, call getConvertedValue() to convert the submitted value.
  • If no Renderer is present, and the submitted value is a String, locate a Converter as follows:
    • If getConverter() returns a non-null Converter, use that instance.
    • Otherwise, if a value binding for value exists, call getType() on it.
      • If this call returns null, assume the output type is String and perform no conversion.
      • Otherwise, call Application.createConverter(Class) to locate any registered Converter capable of converting data values of the specified type.
  • If a Converter instance was located, call its getAsObject() method to perform the conversion. If conversion fails:
    • Enqueue an appropriate error message by calling the addMessage() method on the FacesContext.
    • Set the valid property on this component to false
  • Otherwise, use the submitted value without any conversion

This method can be overridden by subclasses for more specific behavior.

Throws:
ConverterException

validateValue

protected void validateValue(FacesContext context,
                             Object newValue)

Set the "valid" property according to the below algorithm.

  • If the valid property on this component is still true, and the required property is also true, ensure that the local value is not empty (where "empty" is defined as null or a zero-length String. If the local value is empty:
    • Enqueue an appropriate error message by calling the addMessage() method on the FacesContext instance for the current request. If the getRequiredMessage() returns non-null, use the value as the summary and detail in the FacesMessage that is enqueued on the FacesContext, otherwise use the message for the REQUIRED_MESSAGE_ID.
    • Set the valid property on this component to false.
  • If the valid property on this component is still true, and the local value is not empty, call the validate() method of each Validator registered for this UIInput, followed by the method pointed at by the validatorBinding property (if any). If any of these validators or the method throws a ValidatorException, catch the exception, add its message (if any) to the FacesContext, and set the valid property of this component to false.

compareValues

protected boolean compareValues(Object previous,
                                Object value)

Return true if the new value is different from the previous value.

Parameters:
previous - old value of this component (if any)
value - new value of this component (if any)

addValidator

public void addValidator(Validator validator)

Add a Validator instance to the set associated with this UIInput.

Specified by:
addValidator in interface EditableValueHolder
Parameters:
validator - The Validator to add
Throws:
NullPointerException - if validator is null

getValidators

public Validator[] getValidators()

Return the set of registered Validators for this UIInput instance. If there are no registered validators, a zero-length array is returned.

Specified by:
getValidators in interface EditableValueHolder

removeValidator

public void removeValidator(Validator validator)

Remove a Validator instance from the set associated with this UIInput, if it was previously associated. Otherwise, do nothing.

Specified by:
removeValidator in interface EditableValueHolder
Parameters:
validator - The Validator to remove

addValueChangeListener

public void addValueChangeListener(ValueChangeListener listener)

Add a new ValueChangeListener to the set of listeners interested in being notified when ValueChangeEvents occur.

Specified by:
addValueChangeListener in interface EditableValueHolder
Parameters:
listener - The ValueChangeListener to be added
Throws:
NullPointerException - if listener is null

getValueChangeListeners

public ValueChangeListener[] getValueChangeListeners()

Return the set of registered ValueChangeListeners for this UIInput instance. If there are no registered listeners, a zero-length array is returned.

Specified by:
getValueChangeListeners in interface EditableValueHolder

removeValueChangeListener

public void removeValueChangeListener(ValueChangeListener listener)

Remove an existing ValueChangeListener (if any) from the set of listeners interested in being notified when ValueChangeEvents occur.

Specified by:
removeValueChangeListener in interface EditableValueHolder
Parameters:
listener - The ValueChangeListener to be removed
Throws:
NullPointerException - if listener is null

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIOutput

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIOutput
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIMessage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UIMessage

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIMessage
All Implemented Interfaces:
StateHolder
Direct Known Subclasses:
HtmlMessage
public class UIMessage
extends UIComponentBase

This component is responsible for displaying messages for a specific UIComponent, identified by a clientId. The component obtains the messages from the FacesContext.

By default, the rendererType property must be set to "javax.faces.Message". This value can be changed by calling the setRendererType() method.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UIMessage()
Create a new UIMessage instance with default property values.
Method Summary
String | getFamily() Return the identifier of the component family to which this component belongs.
String | getFor() Return the client identifier of the component for which this component represents associated message(s) (if any).
boolean | isShowDetail() Return the flag indicating whether the detail property of the associated message(s) should be displayed.
boolean | isShowSummary() Return the flag indicating whether the summary property of the associated message(s) should be displayed.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setFor(String newFor) Set the client identifier of the component for which this component represents associated message(s) (if any).
void | setShowDetail(boolean showDetail) Set the flag indicating whether the detail property of the associated message(s) should be displayed.
void | setShowSummary(boolean showSummary) Set the flag indicating whether the summary property of the associated message(s) should be displayed.
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UIMessage

public UIMessage()

Create a new UIMessage instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent

getFor

public String getFor()

Return the client identifier of the component for which this component represents associated message(s) (if any).

setFor

public void setFor(String newFor)

Set the client identifier of the component for which this component represents associated message(s) (if any). This property must be set before the message is displayed.

Parameters:
newFor - The new client id

isShowDetail

public boolean isShowDetail()

Return the flag indicating whether the detail property of the associated message(s) should be displayed. Defaults to true.

setShowDetail

public void setShowDetail(boolean showDetail)

Set the flag indicating whether the detail property of the associated message(s) should be displayed.

Parameters:
showDetail - The new flag

isShowSummary

public boolean isShowSummary()

Return the flag indicating whether the summary property of the associated message(s) should be displayed. Defaults to false.

setShowSummary

public void setShowSummary(boolean showSummary)

Set the flag indicating whether the summary property of the associated message(s) should be displayed.

Parameters:
showSummary - The new flag value

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIMessages

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UIMessages

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIMessages
All Implemented Interfaces:
StateHolder
Direct Known Subclasses:
HtmlMessages
public class UIMessages
extends UIComponentBase

The renderer for this component is responsible for obtaining the messages from the FacesContext and displaying them to the user.

This component supports the Messages renderer-type.

By default, the rendererType property must be set to "javax.faces.Messages". This value can be changed by calling the setRendererType() method.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UIMessages()
Create a new UIMessages instance with default property values.
Method Summary
String | getFamily() Return the identifier of the component family to which this component belongs.
boolean | isGlobalOnly() Return the flag indicating whether only global messages (that is, messages with no associated client identifier) should be rendered.
boolean | isShowDetail() Return the flag indicating whether the detail property of the associated message(s) should be displayed.
boolean | isShowSummary() Return the flag indicating whether the summary property of the associated message(s) should be displayed.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setGlobalOnly(boolean globalOnly) Set the flag indicating whether only global messages (that is, messages with no associated client identifier) should be rendered.
void | setShowDetail(boolean showDetail) Set the flag indicating whether the detail property of the associated message(s) should be displayed.
void | setShowSummary(boolean showSummary) Set the flag indicating whether the summary property of the associated message(s) should be displayed.
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UIMessages

public UIMessages()

Create a new UIMessages instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent

isGlobalOnly

public boolean isGlobalOnly()

Return the flag indicating whether only global messages (that is, messages with no associated client identifier) should be rendered. Defaults to false.

setGlobalOnly

public void setGlobalOnly(boolean globalOnly)

Set the flag indicating whether only global messages (that is, messages with no associated client identifier) should be rendered.

Parameters:
globalOnly - The new flag value

isShowDetail

public boolean isShowDetail()

Return the flag indicating whether the detail property of the associated message(s) should be displayed. Defaults to false.

setShowDetail

public void setShowDetail(boolean showDetail)

Set the flag indicating whether the detail property of the associated message(s) should be displayed.

Parameters:
showDetail - The new flag

isShowSummary

public boolean isShowSummary()

Return the flag indicating whether the summary property of the associated message(s) should be displayed. Defaults to true.

setShowSummary

public void setShowSummary(boolean showSummary)

Set the flag indicating whether the summary property of the associated message(s) should be displayed.

Parameters:
showSummary - The new flag value

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UINamingContainer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UINamingContainer

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UINamingContainer
All Implemented Interfaces:
NamingContainer, StateHolder
public class UINamingContainer
extends UIComponentBase
implements NamingContainer

UINamingContainer is a convenience base class for components that wish to implement NamingContainer functionality.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIComponent
bindings
Fields inherited from interface javax.faces.component.NamingContainer
SEPARATOR_CHAR
Constructor Summary
UINamingContainer()
Create a new UINamingContainer instance with default property values.
Method Summary
 String getFamily()
Return the identifier of the component family to which this component belongs.
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UINamingContainer

public UINamingContainer()

Create a new UINamingContainer instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIOutput

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UIOutput

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
All Implemented Interfaces:
StateHolder, ValueHolder
Direct Known Subclasses:
HtmlOutputFormat, HtmlOutputLabel, HtmlOutputLink, HtmlOutputText, UIInput
public class UIOutput
extends UIComponentBase
implements ValueHolder

UIOutput is a UIComponent that has a value, optionally retrieved from a model tier bean via a value expression, that is displayed to the user. The user cannot directly modify the rendered value; it is for display purposes only.

During the Render Response phase of the request processing lifecycle, the current value of this component must be converted to a String (if it is not already), according to the following rules:

  • If the current value is not null, and is not already a String, locate a Converter (if any) to use for the conversion, as follows:
    • If getConverter() returns a non-null Converter, use that one, otherwise
    • If Application.createConverter(Class), passing the current value's class, returns a non-null Converter, use that one.
  • If the current value is not null and a Converter was located, call its getAsString() method to perform the conversion.
  • If the current value is not null but no Converter was located, call toString() on the current value to perform the conversion.

By default, the rendererType property must be set to "javax.faces.Text". This value can be changed by calling the setRendererType() method.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UIOutput()
Create a new UIOutput instance with default property values.
Method Summary
Converter | getConverter() Return the Converter (if any) that is registered for this UIComponent.
String | getFamily() Return the identifier of the component family to which this component belongs.
Object | getLocalValue() Return the local value of this UIComponent (if any), without evaluating any associated ValueExpression.
Object | getValue() Gets the value of this UIComponent.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setConverter(Converter converter) Set the Converter (if any) that is registered for this UIComponent.
void | setValue(Object value) Set the value of this UIComponent (if any).
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UIOutput

public UIOutput()

Create a new UIOutput instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent

getConverter

public Converter getConverter()
Description copied from interface: ValueHolder

Return the Converter (if any) that is registered for this UIComponent.

Specified by:
getConverter in interface ValueHolder

setConverter

public void setConverter(Converter converter)
Description copied from interface: ValueHolder

Set the Converter (if any) that is registered for this UIComponent.

Specified by:
setConverter in interface ValueHolder
Parameters:
converter - New Converter (or null)

getLocalValue

public Object getLocalValue()
Description copied from interface: ValueHolder

Return the local value of this UIComponent (if any), without evaluating any associated ValueExpression.

Specified by:
getLocalValue in interface ValueHolder

getValue

public Object getValue()
Description copied from interface: ValueHolder

Gets the value of this UIComponent. First, consult the local value property of this component. If non-null return it. If null, see if we have a ValueExpression for the value property. If so, return the result of evaluating the property, otherwise return null. Note that because the specification for UIComponent.setValueBinding(java.lang.String, javax.faces.el.ValueBinding) requires a call through to UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression), legacy tags will continue to work.

Specified by:
getValue in interface ValueHolder

setValue

public void setValue(Object value)
Description copied from interface: ValueHolder

Set the value of this UIComponent (if any).

Specified by:
setValue in interface ValueHolder
Parameters:
value - The new local value

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIPanel

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UIPanel

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIPanel
All Implemented Interfaces:
StateHolder
Direct Known Subclasses:
HtmlPanelGrid, HtmlPanelGroup
public class UIPanel
extends UIComponentBase

UIPanel is a UIComponent that manages the layout of its child components.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UIPanel()
Create a new UIPanel instance with default property values.
Method Summary
 String getFamily()
Return the identifier of the component family to which this component belongs.
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, restoreState, saveAttachedState, saveState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UIPanel

public UIPanel()

Create a new UIPanel instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIParameter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UIParameter

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIParameter
All Implemented Interfaces:
StateHolder
public class UIParameter
extends UIComponentBase

UIParameter is a UIComponent that represents an optionally named configuration parameter for a parent component.

Parent components should retrieve the value of a parameter by calling getValue(). In this way, the parameter value can be set directly on the component (via setValue()), or retrieved indirectly via the value binding expression.

In some scenarios, it is necessary to provide a parameter name, in addition to the parameter value that is accessible via the getValue() method. Renderers that support parameter names on their nested UIParameter child components should document their use of this property.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UIParameter()
Create a new UIParameter instance with default property values.
Method Summary
String | getFamily() Return the identifier of the component family to which this component belongs.
String | getName() Return the optional parameter name for this parameter.
Object | getValue() Returns the value property of the UIParameter.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setName(String name) Set the optional parameter name for this parameter.
void | setValue(Object value) Sets the value property of the\ UIParameter.
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UIParameter

public UIParameter()

Create a new UIParameter instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent

getName

public String getName()

Return the optional parameter name for this parameter.

setName

public void setName(String name)

Set the optional parameter name for this parameter.

Parameters:
name - The new parameter name, or null for no name

getValue

public Object getValue()

Returns the value property of the UIParameter.

setValue

public void setValue(Object value)

Sets the value property of the\ UIParameter.

Parameters:
value - the new value

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UISelectBoolean

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UISelectBoolean

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.UISelectBoolean
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
Direct Known Subclasses:
HtmlSelectBooleanCheckbox
public class UISelectBoolean
extends UIInput

UISelectBoolean is a UIComponent that represents a single boolean (true or false) value. It is most commonly rendered as a checkbox.

By default, the rendererType property must be set to "javax.faces.Checkbox". This value can be changed by calling the setRendererType() method.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIInput
CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UISelectBoolean()
Create a new UISelectBoolean instance with default property values.
Method Summary
 String getFamily()
Return the identifier of the component family to which this component belongs.
 ValueBinding getValueBinding(String name)
Deprecated. This has been replaced by getValueExpression(java.lang.String).
 ValueExpression getValueExpression(String name)
Return any ValueExpression set for value if a ValueExpression for selected is requested; otherwise, perform the default superclass processing for this method.
 boolean isSelected()
Return the local value of the selected state of this component.
 void setSelected(boolean selected)
Set the local value of the selected state of this component.
 void setValueBinding(String name, ValueBinding binding)
Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).
 void setValueExpression(String name, ValueExpression binding)
Store any ValueExpression specified for selected under value instead; otherwise, perform the default superclass processing for this method.
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, compareValues, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate, validateValue
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UISelectBoolean

public UISelectBoolean()

Create a new UISelectBoolean instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Overrides:
getFamily in class UIInput

isSelected

public boolean isSelected()

Return the local value of the selected state of this component. This method is a typesafe alias for getValue().

setSelected

public void setSelected(boolean selected)

Set the local value of the selected state of this component. This method is a typesafe alias for setValue().

Parameters:
selected - The new selected state

getValueBinding

public ValueBinding getValueBinding(String name)
Deprecated. This has been replaced by getValueExpression(java.lang.String).

Return any ValueBinding set for value if a ValueBinding for selected is requested; otherwise, perform the default superclass processing for this method.

Rely on the superclass implementation to wrap the returned ValueExpression in a ValueBinding.

Overrides:
getValueBinding in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to retrieve a ValueBinding
Throws:
NullPointerException - if name is null

setValueBinding

public void setValueBinding(String name,
                            ValueBinding binding)
Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).

Store any ValueBinding specified for selected under value instead; otherwise, perform the default superclass processing for this method.

Rely on the superclass implementation to wrap the argument ValueBinding in a ValueExpression.

Overrides:
setValueBinding in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to set a ValueBinding
binding - The ValueBinding to set, or null to remove any currently set ValueBinding
Throws:
NullPointerException - if name is null

getValueExpression

public ValueExpression getValueExpression(String name)

Return any ValueExpression set for value if a ValueExpression for selected is requested; otherwise, perform the default superclass processing for this method.

Overrides:
getValueExpression in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to retrieve a ValueExpression
Throws:
NullPointerException - if name is null
Since:
1.2

setValueExpression

public void setValueExpression(String name,
                               ValueExpression binding)

Store any ValueExpression specified for selected under value instead; otherwise, perform the default superclass processing for this method.

Overrides:
setValueExpression in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to set a ValueExpression
binding - The ValueExpression to set, or null to remove any currently set ValueExpression
Throws:
NullPointerException - if name is null
Since:
1.2
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UISelectItem

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UISelectItem

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UISelectItem
All Implemented Interfaces:
StateHolder
public class UISelectItem
extends UIComponentBase

UISelectItem is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of a SelectItem instance to the list of available options for the parent component. The contents of the SelectItem can be specified in one of the following ways:

  • The value attribute's value is an instance of SelectItem.
  • The associated ValueExpression points at a model data item of type SelectItem.
  • A new SelectItem instance is synthesized from the values of the itemDescription, itemDisabled, itemLabel, and itemValue attributes.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UISelectItem()
Create a new UISelectItem instance with default property values.
Method Summary
String | getFamily() Return the identifier of the component family to which this component belongs.
String | getItemDescription() Return the description for this selection item.
String | getItemLabel() Return the localized label for this selection item.
Object | getItemValue() Return the server value for this selection item.
Object | getValue() Returns the value property of the UISelectItem.
boolean | isItemDisabled() Return the disabled setting for this selection item.
boolean | isItemEscaped() Return the escape setting for the label of this selection item.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setItemDescription(String itemDescription) Set the description for this selection item.
void | setItemDisabled(boolean itemDisabled) Set the disabled value for this selection item.
void | setItemEscaped(boolean itemEscaped) Set the escape value for the label of this selection item.
void | setItemLabel(String itemLabel) Set the localized label for this selection item.
void | setItemValue(Object itemValue) Set the server value for this selection item.
void | setValue(Object value) Sets the value property of the UISelectItem.
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UISelectItem

public UISelectItem()

Create a new UISelectItem instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent

getItemDescription

public String getItemDescription()

Return the description for this selection item.

setItemDescription

public void setItemDescription(String itemDescription)

Set the description for this selection item.

Parameters:
itemDescription - The new description

isItemDisabled

public boolean isItemDisabled()

Return the disabled setting for this selection item.

setItemDisabled

public void setItemDisabled(boolean itemDisabled)

Set the disabled value for this selection item.

Parameters:
itemDisabled - The new disabled flag

isItemEscaped

public boolean isItemEscaped()

Return the escape setting for the label of this selection item.

setItemEscaped

public void setItemEscaped(boolean itemEscaped)

Set the escape value for the label of this selection item.

Parameters:
itemEscaped - The new disabled flag

getItemLabel

public String getItemLabel()

Return the localized label for this selection item.

setItemLabel

public void setItemLabel(String itemLabel)

Set the localized label for this selection item.

Parameters:
itemLabel - The new localized label

getItemValue

public Object getItemValue()

Return the server value for this selection item.

setItemValue

public void setItemValue(Object itemValue)

Set the server value for this selection item.

Parameters:
itemValue - The new server value

getValue

public Object getValue()

Returns the value property of the UISelectItem.

setValue

public void setValue(Object value)

Sets the value property of the UISelectItem.

Parameters:
value - the new value

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UISelectItems

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UISelectItems

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UISelectItems
All Implemented Interfaces:
StateHolder
public class UISelectItems
extends UIComponentBase

UISelectItems is a component that may be nested inside a UISelectMany or UISelectOne component, and causes the addition of one or more SelectItem instances to the list of available options in the parent component. The value of this component (set either directly, or acquired indirectly a ValueExpression, can be of any of the following types:

  • Single instance of SelectItem - This instance is added to the set of available options for the parent tag.
  • Array of SelectItem - This set of instances is added to the set of available options for the parent component, in ascending subscript order.
  • Collection of SelectItem - This set of instances is added to the set of available options for the parent component, in the order provided by an iterator over them.
  • Map - The keys of this object (once converted to Strings) are assumed to be labels, and the values of this object (once converted to Strings) are assumed to be values, of SelectItem instances that will be constructed dynamically and added to the set of available options for the parent component, in the order provided by an iterator over the keys.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UISelectItems()
Create a new UISelectItems instance with default property values.
Method Summary
String | getFamily() Return the identifier of the component family to which this component belongs.
Object | getValue() Returns the value property of the UISelectItems.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setValue(Object value) Sets the value property of the UISelectItems.
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processDecodes, processRestoreState, processSaveState, processUpdates, processValidators, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values
Constructor Detail

UISelectItems

public UISelectItems()

Create a new UISelectItems instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent

getValue

public Object getValue()

Returns the value property of the UISelectItems.

setValue

public void setValue(Object value)

Sets the value property of the UISelectItems.

Parameters:
value - the new value

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UISelectMany

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UISelectMany

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.UISelectMany
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
Direct Known Subclasses:
HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu
public class UISelectMany
extends UIInput

UISelectMany is a UIComponent that represents the user's choice of a zero or more items from among a discrete set of available options. The user can modify the selected values. Optionally, the component can be preconfigured with zero or more currently selected items, by storing them as an array in the value property of the component.

This component is generally rendered as a select box or a group of checkboxes.

By default, the rendererType property must be set to "javax.faces.Listbox". This value can be changed by calling the setRendererType() method.

The Renderer for this component must perform the following logic on getConvertedValue():

    Obtain the Converter using the following algorithm:

      If the component has an attached Converter, use it.

      If not, look for a ValueExpression for value (if any). The ValueExpression must point to something that is:

      • An array of primitives (such as int[]). Look up the registered by-class Converter for this primitive type.
      • An array of objects (such as Integer[] or String[]). Look up the registered by-class Converter for the underlying element type.
      • A java.util.List. Assume that the element type is java.lang.String, so no conversion is required.

      If for any reason a Converter cannot be found, assume the type to be a String array.

    Use the selected Converter (if any) to convert each element in the values array or list from the request to the proper type. If the component has a ValueBinding for value, create an array of the expected type to hold the converted values. If the component does not have a ValueBinding for value, create an array of type Object. Store the created array as the local value of the component, set the component's valid state to true and return.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
static String | INVALID_MESSAGE_ID The message identifier of the FacesMessage to be created if a value not matching the available options is specified.
Fields inherited from class javax.faces.component.UIInput
CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UISelectMany()
Create a new UISelectMany instance with default property values.
Method Summary
protected  boolean compareValues(Object previous, Object value)
Return true if the new value is different from the previous value.
 String getFamily()
Return the identifier of the component family to which this component belongs.
 Object[] getSelectedValues()
Return the currently selected values, or null if there are no currently selected values.
 ValueBinding getValueBinding(String name)
Deprecated. this has been replaced by getValueExpression(java.lang.String).
 ValueExpression getValueExpression(String name)
Return any ValueExpression set for value if a ValueExpression for selectedValues is requested; otherwise, perform the default superclass processing for this method.
 void setSelectedValues(Object[] selectedValues)
Set the currently selected values, or null to indicate that there are no currently selected values.
 void setValueBinding(String name, ValueBinding binding)
Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).
 void setValueExpression(String name, ValueExpression binding)
Store any ValueExpression specified for selectedValues under value instead; otherwise, perform the default superclass processing for this method.
protected  void validateValue(FacesContext context, Object value)
In addition to the standard validation behavior inherited from UIInput, ensure that any specified values are equal to one of the available options.
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values

INVALID_MESSAGE_ID

public static final String INVALID_MESSAGE_ID

The message identifier of the FacesMessage to be created if a value not matching the available options is specified.

See Also:
Constant Field Values
Constructor Detail

UISelectMany

public UISelectMany()

Create a new UISelectMany instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Overrides:
getFamily in class UIInput

getSelectedValues

public Object[] getSelectedValues()

Return the currently selected values, or null if there are no currently selected values. This is a typesafe alias for getValue().

setSelectedValues

public void setSelectedValues(Object[] selectedValues)

Set the currently selected values, or null to indicate that there are no currently selected values. This is a typesafe alias for setValue().

Parameters:
selectedValues - The new selected values (if any)

getValueBinding

public ValueBinding getValueBinding(String name)
Deprecated. this has been replaced by getValueExpression(java.lang.String).

Return any ValueBinding set for value if a ValueBinding for selectedValues is requested; otherwise, perform the default superclass processing for this method.

This method relies on the superclass to provide the ValueExpression to ValueBinding wrapping.

Overrides:
getValueBinding in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to retrieve a ValueBinding
Throws:
NullPointerException - if name is null

setValueBinding

public void setValueBinding(String name,
                            ValueBinding binding)
Deprecated. This has been replaced by setValueExpression(java.lang.String, javax.el.ValueExpression).

Store any ValueBinding specified for selectedValues under value instead; otherwise, perform the default superclass processing for this method.

This method relies on the superclass to wrap the argument ValueBinding in a ValueExpression.

Overrides:
setValueBinding in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to set a ValueBinding
binding - The ValueBinding to set, or null to remove any currently set ValueBinding
Throws:
NullPointerException - if name is null

getValueExpression

public ValueExpression getValueExpression(String name)

Return any ValueExpression set for value if a ValueExpression for selectedValues is requested; otherwise, perform the default superclass processing for this method.

Overrides:
getValueExpression in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to retrieve a ValueExpression
Throws:
NullPointerException - if name is null
Since:
1.2

setValueExpression

public void setValueExpression(String name,
                               ValueExpression binding)

Store any ValueExpression specified for selectedValues under value instead; otherwise, perform the default superclass processing for this method.

Overrides:
setValueExpression in class UIComponentBase
Parameters:
name - Name of the attribute or property for which to set a ValueExpression
binding - The ValueExpression to set, or null to remove any currently set ValueExpression
Throws:
NullPointerException - if name is null
Since:
1.2

compareValues

protected boolean compareValues(Object previous,
                                Object value)

Return true if the new value is different from the previous value. Value comparison must not be sensitive to element order.

Overrides:
compareValues in class UIInput
Parameters:
previous - old value of this component
value - new value of this component

validateValue

protected void validateValue(FacesContext context,
                             Object value)

In addition to the standard validation behavior inherited from UIInput, ensure that any specified values are equal to one of the available options. Before comparing each option, coerce the option value type to the type of this component's value following the Expression Language coercion rules. If the specified value is not equal to any of the options, enqueue an error message and set the valid property to false.

Overrides:
validateValue in class UIInput
Parameters:
context - The FacesContext for the current request
value - The converted value to test for membership.
Throws:
NullPointerException - if context is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UISelectOne

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UISelectOne

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIOutput
                extended by  javax.faces.component.UIInput
                    extended by  javax.faces.component.UISelectOne
All Implemented Interfaces:
EditableValueHolder, StateHolder, ValueHolder
Direct Known Subclasses:
HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio
public class UISelectOne
extends UIInput

UISelectOne is a UIComponent that represents the user's choice of zero or one items from among a discrete set of available options. The user can modify the selected value. Optionally, the component can be preconfigured with a currently selected item, by storing it as the value property of the component.

This component is generally rendered as a select box or a group of radio buttons.

By default, the rendererType property is set to "javax.faces.Menu". This value can be changed by calling the setRendererType() method.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
static String | INVALID_MESSAGE_ID The message identifier of the FacesMessage to be created if a value not matching the available options is specified.
Fields inherited from class javax.faces.component.UIInput
CONVERSION_MESSAGE_ID, REQUIRED_MESSAGE_ID, UPDATE_MESSAGE_ID
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UISelectOne()
Create a new UISelectOne instance with default property values.
Method Summary
String | getFamily() Return the identifier of the component family to which this component belongs.
protected void | validateValue(FacesContext context, Object value) In addition to the standard validation behavior inherited from UIInput, ensure that any specified value is equal to one of the available options.
Methods inherited from class javax.faces.component.UIInput
addValidator, addValueChangeListener, compareValues, decode, getConvertedValue, getConverterMessage, getRequiredMessage, getSubmittedValue, getValidator, getValidatorMessage, getValidators, getValueChangeListener, getValueChangeListeners, isImmediate, isLocalValueSet, isRequired, isValid, processDecodes, processUpdates, processValidators, removeValidator, removeValueChangeListener, resetValue, restoreState, saveState, setConverterMessage, setImmediate, setLocalValueSet, setRequired, setRequiredMessage, setSubmittedValue, setValid, setValidator, setValidatorMessage, setValue, setValueChangeListener, updateModel, validate
Methods inherited from class javax.faces.component.UIOutput
getConverter, getLocalValue, getValue, setConverter
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, encodeBegin, encodeChildren, encodeEnd, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, queueEvent, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.faces.component.ValueHolder
getConverter, getLocalValue, getValue, setConverter

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values

INVALID_MESSAGE_ID

public static final String INVALID_MESSAGE_ID

The message identifier of the FacesMessage to be created if a value not matching the available options is specified.

See Also:
Constant Field Values
Constructor Detail

UISelectOne

public UISelectOne()

Create a new UISelectOne instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Overrides:
getFamily in class UIInput

validateValue

protected void validateValue(FacesContext context,
                             Object value)

In addition to the standard validation behavior inherited from UIInput, ensure that any specified value is equal to one of the available options. Before comparing each option, coerce the option value type to the type of this component's value following the Expression Language coercion rules. If the specified value is not equal to any of the options, enqueue an error message and set the valid property to false.

Overrides:
validateValue in class UIInput
Parameters:
context - The FacesContext for the current request
value - The converted value to test for membership.
Throws:
NullPointerException - if context is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIViewRoot

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Class UIViewRoot

java.lang.Object
    extended by  javax.faces.component.UIComponent
        extended by  javax.faces.component.UIComponentBase
            extended by  javax.faces.component.UIViewRoot
All Implemented Interfaces:
StateHolder
public class UIViewRoot
extends UIComponentBase

UIViewRoot is the UIComponent that represents the root of the UIComponent tree. This component has no rendering, it just serves as the root of the component tree, and as a place to hang per-view PhaseListeners.

For each of the following lifecycle phase methods:

  • processDecodes(javax.faces.context.FacesContext)

  • processValidators(javax.faces.context.FacesContext)

  • processUpdates(javax.faces.context.FacesContext)

  • processApplication(javax.faces.context.FacesContext)

  • RenderResponse, via encodeBegin(javax.faces.context.FacesContext) and encodeEnd(javax.faces.context.FacesContext)

Take the following action regarding PhaseListeners.

    Initialize a state flag to false.

    If getBeforePhaseListener() returns non-null, invoke the listener, passing in the correct corresponding PhaseId for this phase.

    Upon return from the listener, call FacesContext.getResponseComplete() and FacesContext.getRenderResponse(). If either return true set the internal state flag to true.

    If or one or more listeners have been added by a call to addPhaseListener(javax.faces.event.PhaseListener), invoke the beforePhase method on each one whose PhaseListener.getPhaseId() matches the current phaseId, passing in the same PhaseId as in the previous step.

    Upon return from each listener, call FacesContext.getResponseComplete() and FacesContext.getRenderResponse(). If either return true set the internal state flag to true.

    Execute any processing for this phase if the internal state flag was not set.

    If getAfterPhaseListener() returns non-null, invoke the listener, passing in the correct corresponding PhaseId for this phase.

    If or one or more listeners have been added by a call to addPhaseListener(javax.faces.event.PhaseListener), invoke the afterPhase method on each one whose PhaseListener.getPhaseId() matches the current phaseId, passing in the same PhaseId as in the previous step.

Field Summary
static String | COMPONENT_FAMILY The standard component family for this component.
static String | COMPONENT_TYPE The standard component type for this component.
static String | UNIQUE_ID_PREFIX The prefix that will be used for identifiers generated by the createUniqueId() method.
Fields inherited from class javax.faces.component.UIComponent
bindings
Constructor Summary
UIViewRoot()
Create a new UIViewRoot instance with default property values.
Method Summary
void | addPhaseListener(PhaseListener newPhaseListener)
String | createUniqueId() Generate an identifier for a component.
void | encodeBegin(FacesContext context) Override the default UIComponentBase.encodeBegin(javax.faces.context.FacesContext) behavior.
void | encodeEnd(FacesContext context) Override the default UIComponentBase.encodeEnd(javax.faces.context.FacesContext) behavior.
MethodExpression | getAfterPhaseListener()
MethodExpression | getBeforePhaseListener()
String | getFamily() Return the identifier of the component family to which this component belongs.
Locale | getLocale() Return the Locale to be used in localizing the response being created for this view.
String | getRenderKitId() Return the render kit identifier of the RenderKit associated with this view.
String | getViewId() Return the view identifier for this view.
void | processApplication(FacesContext context) Broadcast any events that have been queued for the Invoke Application phase of the request processing lifecycle and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.
void | processDecodes(FacesContext context) Override the default UIComponentBase.processDecodes(javax.faces.context.FacesContext) behavior to broadcast any queued events after the default processing has been completed and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.
void | processUpdates(FacesContext context) Override the default UIComponentBase behavior to broadcast any queued events after the default processing has been completed and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.
void | processValidators(FacesContext context) Override the default UIComponentBase.processValidators(javax.faces.context.FacesContext) behavior to broadcast any queued events after the default processing has been completed and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.
void | queueEvent(FacesEvent event) Override the default UIComponentBase.queueEvent(javax.faces.event.FacesEvent) behavior to accumulate the queued events for later broadcaster.
void | removePhaseListener(PhaseListener toRemove)
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setAfterPhaseListener(MethodExpression newAfterPhase) Allow an arbitrary method to be called for the "afterPhase" event as the UIViewRoot runs through its lifecycle.
void | setBeforePhaseListener(MethodExpression newBeforePhase) Allow an arbitrary method to be called for the "beforePhase" event as the UIViewRoot runs through its lifecycle.
void | setLocale(Locale locale) Set the Locale to be used in localizing the response being created for this view.
void | setRenderKitId(String renderKitId) Set the render kit identifier of the RenderKit associated with this view.
void | setViewId(String viewId) Set the view identifier for this view.
Methods inherited from class javax.faces.component.UIComponentBase
addFacesListener, broadcast, decode, encodeChildren, findComponent, getAttributes, getChildCount, getChildren, getClientId, getFacesContext, getFacesListeners, getFacet, getFacetCount, getFacets, getFacetsAndChildren, getId, getParent, getRenderer, getRendererType, getRendersChildren, getValueBinding, getValueExpression, invokeOnComponent, isRendered, isTransient, processRestoreState, processSaveState, removeFacesListener, restoreAttachedState, saveAttachedState, setId, setParent, setRendered, setRendererType, setTransient, setValueBinding, setValueExpression
Methods inherited from class javax.faces.component.UIComponent
encodeAll, getContainerClientId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_TYPE

public static final String COMPONENT_TYPE

The standard component type for this component.

See Also:
Constant Field Values

COMPONENT_FAMILY

public static final String COMPONENT_FAMILY

The standard component family for this component.

See Also:
Constant Field Values

UNIQUE_ID_PREFIX

public static final String UNIQUE_ID_PREFIX

The prefix that will be used for identifiers generated by the createUniqueId() method.

See Also:
Constant Field Values
Constructor Detail

UIViewRoot

public UIViewRoot()

Create a new UIViewRoot instance with default property values.

Method Detail

getFamily

public String getFamily()
Description copied from class: UIComponent

Return the identifier of the component family to which this component belongs. This identifier, in conjunction with the value of the rendererType property, may be used to select the appropriate Renderer for this component instance.

Specified by:
getFamily in class UIComponent

getRenderKitId

public String getRenderKitId()

Return the render kit identifier of the RenderKit associated with this view. Unless explicitly set, as in ViewHandler.createView(javax.faces.context.FacesContext, java.lang.String), the returned value will be null.

setRenderKitId

public void setRenderKitId(String renderKitId)

Set the render kit identifier of the RenderKit associated with this view. This method may be called at any time between the end of Apply Request Values phase of the request processing lifecycle (i.e. when events are being broadcast) and the beginning of the Render Response phase.

Parameters:
renderKitId - The new RenderKit identifier, or null to disassociate this view with any specific RenderKit instance

getViewId

public String getViewId()

Return the view identifier for this view.

setViewId

public void setViewId(String viewId)

Set the view identifier for this view.

Parameters:
viewId - The new view identifier

getBeforePhaseListener

public MethodExpression getBeforePhaseListener()
Returns:
the MethodExpression that will be invoked before this view is rendered.

setBeforePhaseListener

public void setBeforePhaseListener(MethodExpression newBeforePhase)

Allow an arbitrary method to be called for the "beforePhase" event as the UIViewRoot runs through its lifecycle. This method will be called for all phases except PhaseId.RESTORE_VIEW. Unlike a true PhaseListener, this approach doesn't allow for only receiving PhaseEvents for a given phase.

The method must conform to the signature of PhaseListener.beforePhase(javax.faces.event.PhaseEvent).

Parameters:
newBeforePhase - the MethodExpression that will be invoked before this view is rendered.

getAfterPhaseListener

public MethodExpression getAfterPhaseListener()
Returns:
the MethodExpression that will be invoked after this view is rendered.

setAfterPhaseListener

public void setAfterPhaseListener(MethodExpression newAfterPhase)

Allow an arbitrary method to be called for the "afterPhase" event as the UIViewRoot runs through its lifecycle. This method will be called for all phases except PhaseId.RESTORE_VIEW. Unlike a true PhaseListener, this approach doesn't allow for only receiving PhaseEvents for a given phase.

The method must conform to the signature of PhaseListener.afterPhase(javax.faces.event.PhaseEvent).

Parameters:
newAfterPhase - the MethodExpression that will be invoked after this view is rendered.

removePhaseListener

public void removePhaseListener(PhaseListener toRemove)

addPhaseListener

public void addPhaseListener(PhaseListener newPhaseListener)

queueEvent

public void queueEvent(FacesEvent event)

Override the default UIComponentBase.queueEvent(javax.faces.event.FacesEvent) behavior to accumulate the queued events for later broadcaster.

Overrides:
queueEvent in class UIComponentBase
Parameters:
event - FacesEvent to be queued
Throws:
IllegalStateException - if this component is not a descendant of a UIViewRoot
NullPointerException - if event is null

processDecodes

public void processDecodes(FacesContext context)

Override the default UIComponentBase.processDecodes(javax.faces.context.FacesContext) behavior to broadcast any queued events after the default processing has been completed and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.

Overrides:
processDecodes in class UIComponentBase
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

encodeBegin

public void encodeBegin(FacesContext context)
                 throws IOException

Override the default UIComponentBase.encodeBegin(javax.faces.context.FacesContext) behavior. If getBeforePhaseListener() returns non-null, invoke it, passing a PhaseEvent for the PhaseId.RENDER_RESPONSE phase. If the internal list populated by calls to addPhaseListener(javax.faces.event.PhaseListener) is non-empty, any listeners in that list must have their PhaseListener.beforePhase(javax.faces.event.PhaseEvent) method called, passing the PhaseEvent. Any errors that occur during invocation of any of the the beforePhase listeners must be logged and swallowed. After listeners are invoked call superclass processing.

Overrides:
encodeBegin in class UIComponentBase
Parameters:
context - FacesContext for the response we are creating
Throws:
IOException - if an input/output error occurs while rendering

encodeEnd

public void encodeEnd(FacesContext context)
               throws IOException

Override the default UIComponentBase.encodeEnd(javax.faces.context.FacesContext) behavior. If getAfterPhaseListener() returns non-null, invoke it, passing a PhaseEvent for the PhaseId.RENDER_RESPONSE phase. Any errors that occur during invocation of the afterPhase listener must be logged and swallowed.

Overrides:
encodeEnd in class UIComponentBase
Parameters:
context - FacesContext for the response we are creating
Throws:
IOException - if an input/output error occurs while rendering

processValidators

public void processValidators(FacesContext context)

Override the default UIComponentBase.processValidators(javax.faces.context.FacesContext) behavior to broadcast any queued events after the default processing has been completed and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.

Overrides:
processValidators in class UIComponentBase
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processUpdates

public void processUpdates(FacesContext context)

Override the default UIComponentBase behavior to broadcast any queued events after the default processing has been completed and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.

Overrides:
processUpdates in class UIComponentBase
Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

processApplication

public void processApplication(FacesContext context)

Broadcast any events that have been queued for the Invoke Application phase of the request processing lifecycle and to clear out any events for later phases if the event processing for this phase caused FacesContext.renderResponse() or FacesContext.responseComplete() to be called.

Parameters:
context - FacesContext for the request we are processing
Throws:
NullPointerException - if context is null

createUniqueId

public String createUniqueId()

Generate an identifier for a component. The identifier will be prefixed with UNIQUE_ID_PREFIX, and will be unique within this UIViewRoot.

getLocale

public Locale getLocale()

Return the Locale to be used in localizing the response being created for this view.

Algorithm:

If we have a locale ivar, return it. If we have a value expression for "locale", get its value. If the value is null, return the result of calling ViewHandler.calculateLocale(javax.faces.context.FacesContext). If the value is an instance of java.util.Locale return it. If the value is a String, convert it to a java.util.Locale and return it. If there is no value expression for "locale", return the result of calling ViewHandler.calculateLocale(javax.faces.context.FacesContext).

Returns:
The current Locale obtained by executing the above algorithm.

setLocale

public void setLocale(Locale locale)

Set the Locale to be used in localizing the response being created for this view.

Parameters:
locale - The new localization Locale

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder
Overrides:
saveState in class UIComponentBase

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder
Overrides:
restoreState in class UIComponentBase
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValueHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.component
Interface ValueHolder

All Known Subinterfaces:
EditableValueHolder
All Known Implementing Classes:
HtmlInputHidden, HtmlInputSecret, HtmlInputText, HtmlInputTextarea, HtmlOutputFormat, HtmlOutputLabel, HtmlOutputLink, HtmlOutputText, HtmlSelectBooleanCheckbox, HtmlSelectManyCheckbox, HtmlSelectManyListbox, HtmlSelectManyMenu, HtmlSelectOneListbox, HtmlSelectOneMenu, HtmlSelectOneRadio, UIInput, UIOutput, UISelectBoolean, UISelectMany, UISelectOne
public interface ValueHolder

ValueHolder is an interface that may be implemented by any concrete UIComponent that wishes to support a local value, as well as access data in the model tier via a value expression, and support conversion between String and the model tier data's native data type.

Method Summary
Converter | getConverter() Return the Converter (if any) that is registered for this UIComponent.
Object | getLocalValue() Return the local value of this UIComponent (if any), without evaluating any associated ValueExpression.
Object | getValue() Gets the value of this UIComponent.
void | setConverter(Converter converter) Set the Converter (if any) that is registered for this UIComponent.
void | setValue(Object value) Set the value of this UIComponent (if any).

Method Detail

getLocalValue

Object getLocalValue()

Return the local value of this UIComponent (if any), without evaluating any associated ValueExpression.

getValue

Object getValue()

Gets the value of this UIComponent. First, consult the local value property of this component. If non-null return it. If null, see if we have a ValueExpression for the value property. If so, return the result of evaluating the property, otherwise return null. Note that because the specification for UIComponent.setValueBinding(java.lang.String, javax.faces.el.ValueBinding) requires a call through to UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression), legacy tags will continue to work.

setValue

void setValue(Object value)

Set the value of this UIComponent (if any).

Parameters:
value - The new local value

getConverter

Converter getConverter()

Return the Converter (if any) that is registered for this UIComponent.

setConverter

void setConverter(Converter converter)

Set the Converter (if any) that is registered for this UIComponent.

Parameters:
converter - New Converter (or null)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


context

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.faces.context

Classes and interfaces defining per-request state information.

See:
Description

Class Summary
ExternalContext | This class allows the Faces API to be unaware of the nature of its containing application environment.
FacesContext | FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response.
FacesContextFactory | FacesContextFactory is a factory object that creates (if needed) and returns new FacesContext instances, initialized for the processing of the specified request and response objects.
ResponseStream | ResponseStream is an interface describing an adapter to an underlying output mechanism for binary output.
ResponseWriter | ResponseWriter is an abstract class describing an adapter to an underlying output mechanism for character-based output.
ResponseWriterWrapper | Provides a simple implementation of ResponseWriter that can be subclassed by developers wishing to provide specialized behavior to an existing ResponseWriter instance.

Package javax.faces.context Description

Classes and interfaces defining per-request state information. The main class in this package is FacesContext, which is the access point for all per-request information, as well as the gateway to several other helper classes.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.faces.context Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.faces.context

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.context.ExternalContext
    • javax.faces.context.FacesContext
    • javax.faces.context.FacesContextFactory
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • javax.faces.context.ResponseStream
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • javax.faces.context.ResponseWriter
        • javax.faces.context.ResponseWriterWrapper
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ExternalContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.context
Class ExternalContext

java.lang.Object
    extended by  javax.faces.context.ExternalContext

public abstract class ExternalContext
extends Object

This class allows the Faces API to be unaware of the nature of its containing application environment. In particular, this class allows JavaServer Faces based appications to run in either a Servlet or a Portlet environment.

In the method descriptions below, paragraphs starting with Servlet: and Portlet: denote behavior that is specific to that particular environment.

Field Summary
static String | BASIC_AUTH String identifier for BASIC authentication.
static String | CLIENT_CERT_AUTH String identifier for CLIENT_CERT authentication.
static String | DIGEST_AUTH String identifier for DIGEST authentication.
static String | FORM_AUTH String identifier for FORM authentication.
Constructor Summary
ExternalContext()
Method Summary
abstract void | dispatch(String path) Dispatch a request to the specified resource to create output for this response.
abstract String | encodeActionURL(String url) Return the input URL, after performing any rewriting needed to ensure that it will correctly identify an addressable action in the current application.
abstract String | encodeNamespace(String name) Return the specified name, after prefixing it with a namespace that ensures that it will be unique within the context of a particular page.
abstract String | encodeResourceURL(String url) Return the input URL, after performing any rewriting needed to ensure that it will correctly identify an addressable resource in the current application.
abstract Map<String,Object> | getApplicationMap() Return a mutable Map representing the application scope attributes for the current application.
abstract String | getAuthType() Return the name of the authentication scheme used to authenticate the current user, if any; otherwise, return null.
abstract Object | getContext() Return the application environment object instance for the current appication.
abstract String | getInitParameter(String name) Return the value of the specified application initialization parameter (if any).
abstract Map | getInitParameterMap() Return an immutable Map whose keys are the set of application initialization parameter names configured for this application, and whose values are the corresponding parameter values.
abstract String | getRemoteUser() Return the login name of the user making the current request if any; otherwise, return null.
abstract Object | getRequest() Return the environment-specific object instance for the current request.
String | getRequestCharacterEncoding() Return the character encoding currently being used to interpret this request.
String | getRequestContentType() Return the MIME Content-Type for this request.
abstract String | getRequestContextPath() Return the portion of the request URI that identifies the web application context for this request.
abstract Map<String,Object> | getRequestCookieMap() Return an immutable Map whose keys are the set of cookie names included in the current request, and whose values (of type javax.servlet.http.Cookie) are the first (or only) cookie for each cookie name returned by the underlying request.
abstract Map<String,String> | getRequestHeaderMap() Return an immutable Map whose keys are the set of request header names included in the current request, and whose values (of type String) are the first (or only) value for each header name returned by the underlying request.
abstract Map<String,String[]> | getRequestHeaderValuesMap() Return an immutable Map whose keys are the set of request header names included in the current request, and whose values (of type String[]) are all of the value for each header name returned by the underlying request.
abstract Locale | getRequestLocale() Return the preferred Locale in which the client will accept content.
abstract Iterator<Locale> | getRequestLocales() Return an Iterator over the preferred Locales specified in the request, in decreasing order of preference.
abstract Map<String,Object> | getRequestMap() Return a mutable Map representing the request scope attributes for the current application.
abstract Map<String,String> | getRequestParameterMap() Return an immutable Map whose keys are the set of request parameters names included in the current request, and whose values (of type String) are the first (or only) value for each parameter name returned by the underlying request.
abstract Iterator<String> | getRequestParameterNames() Return an Iterator over the names of all request parameters included in the current request.
abstract Map<String,String[]> | getRequestParameterValuesMap() Return an immutable Map whose keys are the set of request parameters names included in the current request, and whose values (of type String[]) are all of the values for each parameter name returned by the underlying request.
abstract String | getRequestPathInfo() Return the extra path information (if any) included in the request URI; otherwise, return null.
abstract String | getRequestServletPath() Return the servlet path information (if any) included in the request URI; otherwise, return null.
abstract URL | getResource(String path) Return a URL for the application resource mapped to the specified path, if it exists; otherwise, return null.
abstract InputStream | getResourceAsStream(String path) Return an InputStream for an application resource mapped to the specified path, if it exists; otherwise, return null.
abstract Set<String> | getResourcePaths(String path) Return the Set of resource paths for all application resources whose resource path starts with the specified argument.
abstract Object | getResponse() Return the environment-specific object instance for the current response.
String | getResponseCharacterEncoding() Returns the name of the character encoding (MIME charset) used for the body sent in this response.
String | getResponseContentType() Return the MIME Content-Type for this response.
abstract Object | getSession(boolean create) If the create parameter is true, create (if necessary) and return a session instance associated with the current request.
abstract Map<String,Object> | getSessionMap() Return a mutable Map representing the session scope attributes for the current application.
abstract Principal | getUserPrincipal() Return the Principal object containing the name of the current authenticated user, if any; otherwise, return null.
abstract boolean | isUserInRole(String role) Return true if the currently authenticated user is included in the specified role.
abstract void | log(String message) Log the specified message to the application object.
abstract void | log(String message, Throwable exception) Log the specified message and exception to the application object.
abstract void | redirect(String url) Redirect a request to the specified URL, and cause the responseComplete() method to be called on the FacesContext instance for the current request.
void | setRequest(Object request) Set the environment-specific request to be returned by subsequent calls to getRequest().
void | setRequestCharacterEncoding(String encoding) Overrides the name of the character encoding used in the body of this request.
void | setResponse(Object response) Set the environment-specific response to be returned by subsequent calls to getResponse().
void | setResponseCharacterEncoding(String encoding) Sets the character encoding (MIME charset) of the response being sent to the client, for example, to UTF-8.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

BASIC_AUTH

public static final String BASIC_AUTH

String identifier for BASIC authentication.

See Also:
Constant Field Values

CLIENT_CERT_AUTH

public static final String CLIENT_CERT_AUTH

String identifier for CLIENT_CERT authentication.

See Also:
Constant Field Values

DIGEST_AUTH

public static final String DIGEST_AUTH

String identifier for DIGEST authentication.

See Also:
Constant Field Values

FORM_AUTH

public static final String FORM_AUTH

String identifier for FORM authentication.

See Also:
Constant Field Values
Constructor Detail

ExternalContext

public ExternalContext()
Method Detail

dispatch

public abstract void dispatch(String path)
                       throws IOException

Dispatch a request to the specified resource to create output for this response.

Servlet: This must be accomplished by calling the javax.servlet.ServletContext method getRequestDispatcher(path), and calling the forward() method on the resulting object.

Portlet: This must be accomplished by calling the javax.portlet.PortletContext method getRequestDispatcher(), and calling the include() method on the resulting object.

Parameters:
path - Context relative path to the specified resource, which must start with a slash ("/") character
Throws:
FacesException - thrown if a ServletException or PortletException occurs
IllegalArgumentException - if no request dispatcher can be created for the specified path
IllegalStateException - if this method is called in a portlet environment, and the current request is an ActionRequest instead of a RenderRequest
IOException - if an input/output error occurs
NullPointerException - if path is null

encodeActionURL

public abstract String encodeActionURL(String url)

Return the input URL, after performing any rewriting needed to ensure that it will correctly identify an addressable action in the current application.

Servlet: This must be the value returned by the javax.servlet.http.HttpServletResponse method encodeURL(url).

Portlet: This must be the value returned by the javax.portlet.PortletResponse method encodeURL(url).

Parameters:
url - The input URL to be encoded
Throws:
NullPointerException - if url is null

encodeNamespace

public abstract String encodeNamespace(String name)

Return the specified name, after prefixing it with a namespace that ensures that it will be unique within the context of a particular page.

Servlet: The input value must be returned unchanged.

Portlet: The returned value must be the input value prefixed by the value returned by the javax.portlet.RenderResponse method getNamespace().

Parameters:
name - Name to be encoded
Throws:
IllegalStateException - if this method is called in a portlet environment, and the current response is an ActionResponse instead of a RenderResponse
NullPointerException - if name is null

encodeResourceURL

public abstract String encodeResourceURL(String url)

Return the input URL, after performing any rewriting needed to ensure that it will correctly identify an addressable resource in the current application.

Servlet: This must be the value returned by the javax.servlet.http.HttpServletResponse method encodeURL(url).

Portlet: This must be the value returned by the javax.portlet.PortletResponse method encodeURL(url).

Parameters:
url - The input URL to be encoded
Throws:
NullPointerException - if url is null

getApplicationMap

public abstract Map<String,Object> getApplicationMap()

Return a mutable Map representing the application scope attributes for the current application. The returned Map must implement the entire contract for a modifiable map as described in the JavaDocs for java.util.Map. Modifications made in the Map must cause the corresponding changes in the set of application scope attributes. Particularly the clear(), remove(), put(), putAll(), and get() operations must take the appropriate action on the underlying data structure.

For any of the Map methods that cause an element to be removed from the underlying data structure, the following action regarding managed-beans must be taken. If the element to be removed is a managed-bean, and it has one or more public no-argument void return methods annotated with javax.annotation.PreDestroy, each such method must be called before the element is removed from the underlying data structure. Elements that are not managed-beans, but do happen to have methods with that annotation must not have those methods called on removal. Any exception thrown by the PreDestroy annotated methods must by caught and not rethrown. The exception may be logged.

Servlet: This must be the set of attributes available via the javax.servlet.ServletContext methods getAttribute(), getAttributeNames(), removeAttribute(), and setAttribute().

Portlet: This must be the set of attributes available via the javax.portlet.PortletContext methods getAttribute(), getAttributeNames(), removeAttribute(), and setAttribute().

getAuthType

public abstract String getAuthType()

Return the name of the authentication scheme used to authenticate the current user, if any; otherwise, return null. For standard authentication schemes, the returned value will match one of the following constants: BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, or FORM_AUTH.

Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getAuthType().

Portlet: This must be the value returned by the javax.portlet.http.PortletRequest method getAuthType().

getContext

public abstract Object getContext()

Return the application environment object instance for the current appication.

Servlet: This must be the current application's javax.servlet.ServletContext instance.

Portlet: This must be the current application's javax.portlet.PortletContext instance.

getInitParameter

public abstract String getInitParameter(String name)

Return the value of the specified application initialization parameter (if any).

Servlet: This must be the result of the javax.servlet.ServletContext method getInitParameter(name).

Portlet: This must be the result of the javax.portlet.PortletContext method getInitParameter(name).

Parameters:
name - Name of the requested initialization parameter
Throws:
NullPointerException - if name is null

getInitParameterMap

public abstract Map getInitParameterMap()

Return an immutable Map whose keys are the set of application initialization parameter names configured for this application, and whose values are the corresponding parameter values. The returned Map must implement the entire contract for an unmodifiable map as described in the JavaDocs for java.util.Map.

Servlet: This result must be as if it were synthesized by calling the javax.servlet.ServletContext method getInitParameterNames, and putting each configured parameter name/value pair into the result.

Portlet: This result must be as if it were synthesized by calling the javax.portlet.PortletContext method getInitParameterNames, and putting each configured parameter name/value pair into the result.

getRemoteUser

public abstract String getRemoteUser()

Return the login name of the user making the current request if any; otherwise, return null.

Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getRemoteUser().

Portlet: This must be the value returned by the javax.portlet.http.PortletRequest method getRemoteUser().

getRequest

public abstract Object getRequest()

Return the environment-specific object instance for the current request.

Servlet: This must be the current request's javax.servlet.http.HttpServletRequest instance.

Portlet: This must be the current request's javax.portlet.PortletRequest instance, which will be either an ActionRequest or a RenderRequest depending upon when this method is called.

setRequest

public void setRequest(Object request)

Set the environment-specific request to be returned by subsequent calls to getRequest(). This may be used to install a wrapper for the request.

The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

Since:
1.2

setRequestCharacterEncoding

public void setRequestCharacterEncoding(String encoding)
                                 throws UnsupportedEncodingException

Overrides the name of the character encoding used in the body of this request.

Calling this method after the request has been accessed will have no no effect, unless a Reader or Stream has been obtained from the request, in which case an IllegalStateException is thrown.

Servlet: This must call through to the javax.servlet.ServletRequest method setCharacterEncoding().

Portlet: This must call through to the javax.portlet.ActionRequest method setCharacterEncoding().

The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

Throws:
UnsupportedEncodingException - if this is not a valid encoding
Since:
1.2

getRequestContextPath

public abstract String getRequestContextPath()

Return the portion of the request URI that identifies the web application context for this request.

Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getContextPath().

Portlet: This must be the value returned by the javax.portlet.PortletRequest method getContextPath().

getRequestCookieMap

public abstract Map<String,Object> getRequestCookieMap()

Return an immutable Map whose keys are the set of cookie names included in the current request, and whose values (of type javax.servlet.http.Cookie) are the first (or only) cookie for each cookie name returned by the underlying request. The returned Map must implement the entire contract for an unmodifiable map as described in the JavaDocs for java.util.Map.

Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getCookies(), unless null was returned, in which case this must be a zero-length array.

Portlet: Ths must be an empty Map.

getRequestHeaderMap

public abstract Map<String,String> getRequestHeaderMap()

Return an immutable Map whose keys are the set of request header names included in the current request, and whose values (of type String) are the first (or only) value for each header name returned by the underlying request. The returned Map must implement the entire contract for an unmodifiable map as described in the JavaDocs for java.util.Map. In addition, key comparisons must be performed in a case insensitive manner.

Servlet: This must be the set of headers available via the javax.servlet.http.HttpServletRequest methods getHeader() and getHeaderNames().

Portlet: This must be the set of properties available via the javax.portlet.PortletRequest methods getProperty() and getPropertyNames(). As such, HTTP headers will only be included if they were provided by the portlet container, and additional properties provided by the portlet container may also be included.

getRequestHeaderValuesMap

public abstract Map<String,String[]> getRequestHeaderValuesMap()

Return an immutable Map whose keys are the set of request header names included in the current request, and whose values (of type String[]) are all of the value for each header name returned by the underlying request. The returned Map must implement the entire contract for an unmodifiable map as described in the JavaDocs for java.util.Map. In addition, key comparisons must be performed in a case insensitive manner.

Servlet: This must be the set of headers available via the javax.servlet.http.HttpServletRequest methods getHeaders() and getHeaderNames().

Portlet: This must be the set of properties available via the javax.portlet.PortletRequest methods getProperties() and getPropertyNames(). As such, HTTP headers will only be included if they were provided by the portlet container, and additional properties provided by the portlet container may also be included.

getRequestLocale

public abstract Locale getRequestLocale()

Return the preferred Locale in which the client will accept content.

Servlet: This must be the value returned by the javax.servlet.ServletRequest method getLocale().

Portlet: This must be the value returned by the javax.portlet.PortletRequest method getLocale().

getRequestLocales

public abstract Iterator<Locale> getRequestLocales()

Return an Iterator over the preferred Locales specified in the request, in decreasing order of preference.

Servlet: This must be an Iterator over the values returned by the javax.servlet.ServletRequest method getLocales().

Portlet: This must be an Iterator over the values returned by the javax.portlet.PortletRequest method getLocales().

getRequestMap

public abstract Map<String,Object> getRequestMap()

Return a mutable Map representing the request scope attributes for the current application. The returned Map must implement the entire contract for a modifiable map as described in the JavaDocs for java.util.Map. Modifications made in the Map must cause the corresponding changes in the set of request scope attributes. Particularly the clear(), remove(), put(), putAll(), and get() operations must take the appropriate action on the underlying data structure.

For any of the Map methods that cause an element to be removed from the underlying data structure, the following action regarding managed-beans must be taken. If the element to be removed is a managed-bean, and it has one or more public no-argument void return methods annotated with javax.annotation.PreDestroy, each such method must be called before the element is removed from the underlying data structure. Elements that are not managed-beans, but do happen to have methods with that annotation must not have those methods called on removal. Any exception thrown by the PreDestroy annotated methods must by caught and not rethrown. The exception may be logged.

Servlet: This must be the set of attributes available via the javax.servlet.ServletRequest methods getAttribute(), getAttributeNames(), removeAttribute(), and setAttribute().

Portlet: This must be the set of attributes available via the javax.portlet.PortletRequest methods getAttribute(), getAttributeNames(), removeAttribute(), and setAttribute().

getRequestParameterMap

public abstract Map<String,String> getRequestParameterMap()

Return an immutable Map whose keys are the set of request parameters names included in the current request, and whose values (of type String) are the first (or only) value for each parameter name returned by the underlying request. The returned Map must implement the entire contract for an unmodifiable map as described in the JavaDocs for java.util.Map.

Servlet: This must be the set of parameters available via the javax.servlet.ServletRequest methods getParameter() and getParameterNames().

Portlet: This must be the set of parameters available via the javax.portlet.PortletRequest methods getParameter() and getParameterNames().

getRequestParameterNames

public abstract Iterator<String> getRequestParameterNames()

Return an Iterator over the names of all request parameters included in the current request.

Servlet: This must be an Iterator over the values returned by the javax.servlet.ServletRequest method getParameterNames().

Portlet: This must be an Iterator over the values returned by the javax.portlet.PortletRequest method getParameterNames().

getRequestParameterValuesMap

public abstract Map<String,String[]> getRequestParameterValuesMap()

Return an immutable Map whose keys are the set of request parameters names included in the current request, and whose values (of type String[]) are all of the values for each parameter name returned by the underlying request. The returned Map must implement the entire contract for an unmodifiable map as described in the JavaDocs for java.util.Map.

Servlet: This must be the set of parameters available via the javax.servlet.ServletRequest methods getParameterValues() and getParameterNames().

Portlet: This must be the set of parameters available via the javax.portlet.PortletRequest methods getParameterValues() and getParameterNames().

getRequestPathInfo

public abstract String getRequestPathInfo()

Return the extra path information (if any) included in the request URI; otherwise, return null.

Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getPathInfo().

Portlet: This must be null.

getRequestServletPath

public abstract String getRequestServletPath()

Return the servlet path information (if any) included in the request URI; otherwise, return null.

Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getServletPath().

Portlet: This must be null.

getRequestCharacterEncoding

public String getRequestCharacterEncoding()

Return the character encoding currently being used to interpret this request.

Servlet: This must return the value returned by the javax.servlet.ServletRequest method getCharacterEncoding().

Portlet: This must return the value returned by the javax.portlet.ActionRequest method getCharacterEncoding().

The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

Since:
1.2

getRequestContentType

public String getRequestContentType()

Return the MIME Content-Type for this request. If not available, return null.

Servlet: This must return the value returned by the javax.servlet.ServletRequest method getContentType().

Portlet: This must return null.

The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

Since:
1.2

getResponseCharacterEncoding

public String getResponseCharacterEncoding()

Returns the name of the character encoding (MIME charset) used for the body sent in this response.

Servlet: This must return the value returned by the javax.servlet.ServletResponse method getCharacterEncoding().

Portlet: This must return null.

The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

Since:
1.2

getResponseContentType

public String getResponseContentType()

Return the MIME Content-Type for this response. If not available, return null.

Servlet: This must return the value returned by the javax.servlet.ServletResponse method getContentType().

Portlet: This must return null.

The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

Since:
1.2

getResource

public abstract URL getResource(String path)
                         throws MalformedURLException

Return a URL for the application resource mapped to the specified path, if it exists; otherwise, return null.

Servlet: This must be the value returned by the javax.servlet.ServletContext method getResource(path).

Portlet: This must be the value returned by the javax.portlet.PortletContext method getResource(path).

Parameters:
path - The path to the requested resource, which must start with a slash ("/" character
Throws:
MalformedURLException - if the specified path is not in the correct form
NullPointerException - if path is null

getResourceAsStream

public abstract InputStream getResourceAsStream(String path)

Return an InputStream for an application resource mapped to the specified path, if it exists; otherwise, return null.

Servlet: This must be the value returned by the javax.servlet.ServletContext method getResourceAsStream(path).

Portlet: This must be the value returned by the javax.portlet.PortletContext method getResourceAsStream(path).

Parameters:
path - The path to the requested resource, which must start with a slash ("/" character
Throws:
NullPointerException - if path is null

getResourcePaths

public abstract Set<String> getResourcePaths(String path)

Return the Set of resource paths for all application resources whose resource path starts with the specified argument.

Servlet: This must be the value returned by the javax.servlet.ServletContext method getResourcePaths(path).

Portlet: This must be the value returned by the javax.portlet.PortletContext method getResourcePaths(path).

Parameters:
path - Partial path used to match resources, which must start with a slash ("/") character
Throws:
NullPointerException - if path is null

getResponse

public abstract Object getResponse()

Return the environment-specific object instance for the current response.

Servlet: This is the current request's javax.servlet.http.HttpServletResponse instance.

Portlet: This is the current request's javax.portlet.PortletResponse instance, which will be either an ActionResponse or a RenderResponse depending upon when this method is called.

setResponse

public void setResponse(Object response)

Set the environment-specific response to be returned by subsequent calls to getResponse(). This may be used to install a wrapper for the response.

The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

Since:
1.2

setResponseCharacterEncoding

public void setResponseCharacterEncoding(String encoding)

Sets the character encoding (MIME charset) of the response being sent to the client, for example, to UTF-8.

Servlet: This must call through to the javax.servlet.ServletResponse method setCharacterEncoding().

Portlet: This method must take no action.

The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

Since:
1.2

getSession

public abstract Object getSession(boolean create)

If the create parameter is true, create (if necessary) and return a session instance associated with the current request. If the create parameter is false return any existing session instance associated with the current request, or return null if there is no such session.

Servlet: This must return the result of calling getSession(create) on the underlying javax.servlet.http.HttpServletRequest instance.

em>Portlet: This must return the result of calling getPortletSession(create) on the underlying javax.portlet.PortletRequest instance.

Parameters:
create - Flag indicating whether or not a new session should be created if there is no session associated with the current request

getSessionMap

public abstract Map<String,Object> getSessionMap()

Return a mutable Map representing the session scope attributes for the current application. The returned Map must implement the entire contract for a modifiable map as described in the JavaDocs for java.util.Map. Modifications made in the Map must cause the corresponding changes in the set of session scope attributes. Particularly the clear(), remove(), put(), and get() operations must take the appropriate action on the underlying data structure. Accessing attributes via this Map must cause the creation of a session associated with the current request, if such a session does not already exist.

For any of the Map methods that cause an element to be removed from the underlying data structure, the following action regarding managed-beans must be taken. If the element to be removed is a managed-bean, and it has one or more public no-argument void return methods annotated with javax.annotation.PreDestroy, each such method must be called before the element is removed from the underlying data structure. Elements that are not managed-beans, but do happen to have methods with that annotation must not have those methods called on removal. Any exception thrown by the PreDestroy annotated methods must by caught and not rethrown. The exception may be logged.

Servlet: This must be the set of attributes available via the javax.servlet.http.HttpServletSession methods getAttribute(), getAttributeNames(), removeAttribute(), and setAttribute().

Portlet: This must be the set of attributes available via the javax.portlet.PortletSession methods getAttribute(), getAttributeNames(), removeAttribute(), and setAttribute(). All session attribute access must occur in PORTLET_SCOPE scope within the session.

getUserPrincipal

public abstract Principal getUserPrincipal()

Return the Principal object containing the name of the current authenticated user, if any; otherwise, return null.

Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method getUserPrincipal().

Portlet: This must be the value returned by the javax.portlet.http.PortletRequest method getUserPrincipal().

isUserInRole

public abstract boolean isUserInRole(String role)

Return true if the currently authenticated user is included in the specified role. Otherwise, return false.

Servlet: This must be the value returned by the javax.servlet.http.HttpServletRequest method isUserInRole(role).

Portlet: This must be the value returned by the javax.portlet.http.PortletRequest method isUserInRole(role).

Parameters:
role - Logical role name to be checked
Throws:
NullPointerException - if role is null

log

public abstract void log(String message)

Log the specified message to the application object.

Servlet: This must be performed by calling the javax.servlet.ServletContext method log(String).

Portlet: This must be performed by calling the javax.portlet.PortletContext method log(String).

Parameters:
message - Message to be logged
Throws:
NullPointerException - if message is null

log

public abstract void log(String message,
                         Throwable exception)

Log the specified message and exception to the application object.

Servlet: This must be performed by calling the javax.servlet.ServletContext method log(String,Throwable).

Portlet: This must be performed by calling the javax.portlet.PortletContext method log(String,Throwable).

Parameters:
message - Message to be logged
exception - Exception to be logged
Throws:
NullPointerException - if message or exception is null

redirect

public abstract void redirect(String url)
                       throws IOException

Redirect a request to the specified URL, and cause the responseComplete() method to be called on the FacesContext instance for the current request.

Servlet: This must be accomplished by calling the javax.servlet.http.HttpServletResponse method sendRedirect().

Portlet: This must be accomplished by calling the javax.portlet.ActionResponse method sendRedirect().

Parameters:
url - Absolute URL to which the client should be redirected
Throws:
IllegalArgumentException - if the specified url is relative
IllegalStateException - if, in a portlet environment, the current response object is a RenderResponse instead of an ActionResponse
IllegalStateException - if, in a servlet environment, the current response has already been committed
IOException - if an input/output error occurs
Overview  Package   Class  Tree  Deprecated  Index  Help
Java EE 5 SDK
 PREV CLASS   NEXT CLASS | FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FacesContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.context
Class FacesContext

java.lang.Object
    extended by  javax.faces.context.FacesContext

public abstract class FacesContext
extends Object

FacesContext contains all of the per-request state information related to the processing of a single JavaServer Faces request, and the rendering of the corresponding response. It is passed to, and potentially modified by, each phase of the request processing lifecycle.

A FacesContext instance is associated with a particular request at the beginning of request processing, by a call to the getFacesContext() method of the FacesContextFactory instance associated with the current web application. The instance remains active until its release() method is called, after which no further references to this instance are allowed. While a FacesContext instance is active, it must not be referenced from any thread other than the one upon which the servlet container executing this web application utilizes for the processing of this request.

Constructor Summary
FacesContext()
Method Summary
abstract  void addMessage(String clientId, FacesMessage message)
Append a FacesMessage to the set of messages associated with the specified client identifier, if clientId is not null.
abstract  Application getApplication()
Return the Application instance associated with this web application.
abstract  Iterator<String> getClientIdsWithMessages()
Return an Iterator over the client identifiers for which at least one FacesMessage has been queued.
static FacesContext getCurrentInstance()
Return the FacesContext instance for the request that is being processed by the current thread, if any.
 ELContext getELContext()
Return the ELContext instance for this FacesContext instance.
abstract  ExternalContext getExternalContext()
Return the ExternalContext instance for this FacesContext instance.
abstract  FacesMessage.Severity getMaximumSeverity()
Return the maximum severity level recorded on any FacesMessages that has been queued, whether or not they are associated with any specific UIComponent.
abstract  Iterator<FacesMessage> getMessages()
Return an Iterator over the FacesMessages that have been queued, whether or not they are associated with any specific client identifier.
abstract  Iterator<FacesMessage> getMessages(String clientId)
Return an Iterator over the FacesMessages that have been queued that are associated with the specified client identifier (if clientId is not null), or over the FacesMessages that have been queued that are not associated with any specific client identifier (if clientId is null).
abstract  RenderKit getRenderKit()
Return the RenderKit instance for the render kit identifier specified on our UIViewRoot, if there is one.
abstract  boolean getRenderResponse()
Return true if the renderResponse() method has been called for the current request.
abstract  boolean getResponseComplete()
Return true if the responseComplete() method has been called for the current request.
abstract  ResponseStream getResponseStream()
Return the ResponseStream to which components should direct their binary output.
abstract  ResponseWriter getResponseWriter()
Return the ResponseWriter to which components should direct their character-based output.
abstract  UIViewRoot getViewRoot()
Return the root component that is associated with the this request.
abstract  void release()
Release any resources associated with this FacesContext instance.
abstract  void renderResponse()
Signal the JavaServer faces implementation that, as soon as the current phase of the request processing lifecycle has been completed, control should be passed to the Render Response phase, bypassing any phases that have not been executed yet.
abstract  void responseComplete()
Signal the JavaServer Faces implementation that the HTTP response for this request has already been generated (such as an HTTP redirect), and that the request processing lifecycle should be terminated as soon as the current phase is completed.
protected static void setCurrentInstance(FacesContext context)
Set the FacesContext instance for the request that is being processed by the current thread.
abstract  void setResponseStream(ResponseStream responseStream)
Set the ResponseStream to which components should direct their binary output.
abstract  void setResponseWriter(ResponseWriter responseWriter)
Set the ResponseWriter to which components should direct their character-based output.
abstract  void setViewRoot(UIViewRoot root)
Set the root component that is associated with this request.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FacesContext

public FacesContext()
Method Detail

getApplication

public abstract Application getApplication()

Return the Application instance associated with this web application.

Throws:
IllegalStateException - if this method is called after this instance has been released

getClientIdsWithMessages

public abstract Iterator<String> getClientIdsWithMessages()

Return an Iterator over the client identifiers for which at least one FacesMessage has been queued. If there are no such client identifiers, an empty Iterator is returned. If any messages have been queued that were not associated with any specific client identifier, a null value will be included in the iterated values. The elements in the Iterator must be returned in the order in which they were added with addMessage(java.lang.String, javax.faces.application.FacesMessage).

Throws:
IllegalStateException - if this method is called after this instance has been released

getELContext

public ELContext getELContext()

Return the ELContext instance for this FacesContext instance. This ELContext instance has the same lifetime and scope as the FacesContext instance with which it is associated, and may be created lazily the first time this method is called for a given FacesContext instance. Upon creation of the ELContext instance, the implementation must take the following action:

  • Call the ELContext.putContext(java.lang.Class, java.lang.Object) method on the instance, passing in FacesContext.class and the this reference for the FacesContext instance itself.

  • If the Collection returned by Application.getELContextListeners() is non-empty, create an instance of ELContextEvent and pass it to each ELContextListener instance in the Collection by calling the ELContextListener.contextCreated(javax.el.ELContextEvent) method.

The default implementation throws UnsupportedOperationException and is provided for the sole purpose of not breaking existing applications that extend this class.

Throws:
IllegalStateException - if this method is called after this instance has been released
Since:
1.2

getExternalContext

public abstract ExternalContext getExternalContext()

Return the ExternalContext instance for this FacesContext instance.

Throws:
IllegalStateException - if this method is called after this instance has been released

getMaximumSeverity

public abstract FacesMessage.Severity getMaximumSeverity()

Return the maximum severity level recorded on any FacesMessages that has been queued, whether or not they are associated with any specific UIComponent. If no such messages have been queued, return null.

Throws:
IllegalStateException - if this method is called after this instance has been released

getMessages

public abstract Iterator<FacesMessage> getMessages()

Return an Iterator over the FacesMessages that have been queued, whether or not they are associated with any specific client identifier. If no such messages have been queued, return an empty Iterator. The elements of the Iterator must be returned in the order in which they were added with calls to addMessage(java.lang.String, javax.faces.application.FacesMessage).

Throws:
IllegalStateException - if this method is called after this instance has been released

getMessages

public abstract Iterator<FacesMessage> getMessages(String clientId)

Return an Iterator over the FacesMessages that have been queued that are associated with the specified client identifier (if clientId is not null), or over the FacesMessages that have been queued that are not associated with any specific client identifier (if clientId is null). If no such messages have been queued, return an empty Iterator. The elements of the Iterator must be returned in the order in which they were added with calls to addMessage(java.lang.String, javax.faces.application.FacesMessage).

Parameters:
clientId - The client identifier for which messages are requested, or null for messages not associated with any client identifier
Throws:
IllegalStateException - if this method is called after this instance has been released

getRenderKit

public abstract RenderKit getRenderKit()

Return the RenderKit instance for the render kit identifier specified on our UIViewRoot, if there is one. If there is no current UIViewRoot, if the UIViewRoot does not have a specified renderKitId, or if there is no RenderKit for the specified identifier, return null instead.

getRenderResponse

public abstract boolean getRenderResponse()

Return true if the renderResponse() method has been called for the current request.

Throws:
IllegalStateException - if this method is called after this instance has been released

getResponseComplete

public abstract boolean getResponseComplete()

Return true if the responseComplete() method has been called for the current request.

Throws:
IllegalStateException - if this method is called after this instance has been released

getResponseStream

public abstract ResponseStream getResponseStream()

Return the ResponseStream to which components should direct their binary output. Within a given response, components can use either the ResponseStream or the ResponseWriter, but not both.

Throws:
IllegalStateException - if this method is called after this instance has been released

setResponseStream

public abstract void setResponseStream(ResponseStream responseStream)

Set the ResponseStream to which components should direct their binary output.

Parameters:
responseStream - The new ResponseStream for this response
Throws:
NullPointerException - if responseStream is null
IllegalStateException - if this method is called after this instance has been released

getResponseWriter

public abstract ResponseWriter getResponseWriter()

Return the ResponseWriter to which components should direct their character-based output. Within a given response, components can use either the ResponseStream or the ResponseWriter, but not both.

Throws:
IllegalStateException - if this method is called after this instance has been released

setResponseWriter

public abstract void setResponseWriter(ResponseWriter responseWriter)

Set the ResponseWriter to which components should direct their character-based output.

Parameters:
responseWriter - The new ResponseWriter for this response
Throws:
IllegalStateException - if this method is called after this instance has been released
NullPointerException - if responseWriter is null

getViewRoot

public abstract UIViewRoot getViewRoot()

Return the root component that is associated with the this request.

Throws:
IllegalStateException - if this method is called after this instance has been released

setViewRoot

public abstract void setViewRoot(UIViewRoot root)

Set the root component that is associated with this request. This method can only be called by the application handler (or a class that the handler calls), and only during the Invoke Application phase of the request processing lifecycle.

Parameters:
root - The new component UIViewRoot component
Throws:
IllegalStateException - if this method is called after this instance has been released
NullPointerException - if root is null

addMessage

public abstract void addMessage(String clientId,
                                FacesMessage message)

Append a FacesMessage to the set of messages associated with the specified client identifier, if clientId is not null. If clientId is null, this FacesMessage is assumed to not be associated with any specific component instance.

Parameters:
clientId - The client identifier with which this message is associated (if any)
message - The message to be appended
Throws:
IllegalStateException - if this method is called after this instance has been released
NullPointerException - if message is null

release

public abstract void release()

Release any resources associated with this FacesContext instance. Faces implementations may choose to pool instances in the associated FacesContextFactory to avoid repeated object creation and garbage collection. After release() is called on a FacesContext instance (until the FacesContext instance has been recycled by the implementation for re-use), calling any other methods will cause an IllegalStateException to be thrown.

The implementation must call setCurrentInstance(javax.faces.context.FacesContext) passing null to remove the association between this thread and this dead FacesContext instance.

Throws:
IllegalStateException - if this method is called after this instance has been released

renderResponse

public abstract void renderResponse()

Signal the JavaServer faces implementation that, as soon as the current phase of the request processing lifecycle has been completed, control should be passed to the Render Response phase, bypassing any phases that have not been executed yet.

Throws:
IllegalStateException - if this method is called after this instance has been released

responseComplete

public abstract void responseComplete()

Signal the JavaServer Faces implementation that the HTTP response for this request has already been generated (such as an HTTP redirect), and that the request processing lifecycle should be terminated as soon as the current phase is completed.

Throws:
IllegalStateException - if this method is called after this instance has been released

getCurrentInstance

public static FacesContext getCurrentInstance()

Return the FacesContext instance for the request that is being processed by the current thread, if any.

setCurrentInstance

protected static void setCurrentInstance(FacesContext context)

Set the FacesContext instance for the request that is being processed by the current thread.

Parameters:
context - The FacesContext instance for the current thread, or null if this thread no longer has a FacesContext instance.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FacesContextFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.context
Class FacesContextFactory

java.lang.Object
    extended by  javax.faces.context.FacesContextFactory

public abstract class FacesContextFactory
extends Object

FacesContextFactory is a factory object that creates (if needed) and returns new FacesContext instances, initialized for the processing of the specified request and response objects. Implementations may take advantage of the calls to the release() method of the allocated FacesContext instances to pool and recycle them, rather than creating a new instance every time.

There must be one FacesContextFactory instance per web application that is utilizing JavaServer Faces. This instance can be acquired, in a portable manner, by calling:

   FacesContextFactory factory = (FacesContextFactory)
    FactoryFinder.getFactory(FactoryFinder.FACES_CONTEXT_FACTORY);

Constructor Summary
FacesContextFactory()
Method Summary
abstract  FacesContext getFacesContext(Object context, Object request, Object response, Lifecycle lifecycle)
Create (if needed) and return a FacesContext instance that is initialized for the processing of the specified request and response objects, utilizing the specified Lifecycle instance, for this web application.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FacesContextFactory

public FacesContextFactory()
Method Detail

getFacesContext

public abstract FacesContext getFacesContext(Object context,
                                             Object request,
                                             Object response,
                                             Lifecycle lifecycle)
                                      throws FacesException

Create (if needed) and return a FacesContext instance that is initialized for the processing of the specified request and response objects, utilizing the specified Lifecycle instance, for this web application.

The implementation of this method must ensure that calls to the getCurrentInstance() method of FacesContext, from the same thread that called this method, will return the same FacesContext instance until the release() method is called on that instance.

Parameters:
context - In servlet environments, the ServletContext that is associated with this web application
request - In servlet environments, the ServletRequest that is to be processed
response - In servlet environments, the ServletResponse that is to be processed
lifecycle - The Lifecycle instance being used to process this request
Throws:
FacesException - if a FacesContext cannot be constructed for the specified parameters
NullPointerException - if any of the parameters are null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResponseStream

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.context
Class ResponseStream

java.lang.Object
    extended by  java.io.OutputStream
        extended by  javax.faces.context.ResponseStream
All Implemented Interfaces:
Closeable, Flushable
public abstract class ResponseStream
extends OutputStream

ResponseStream is an interface describing an adapter to an underlying output mechanism for binary output.

Constructor Summary
ResponseStream()
Method Summary
Methods inherited from class java.io.OutputStream
close, flush, write, write, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResponseStream

public ResponseStream()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResponseWriter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.context
Class ResponseWriter

java.lang.Object
    extended by  java.io.Writer
        extended by  javax.faces.context.ResponseWriter
All Implemented Interfaces:
Closeable, Flushable, Appendable
Direct Known Subclasses:
ResponseWriterWrapper
public abstract class ResponseWriter
extends Writer

ResponseWriter is an abstract class describing an adapter to an underlying output mechanism for character-based output. In addition to the low-level write() methods inherited from java.io.Writer, this class provides utility methods that are useful in producing elements and attributes for markup languages like HTML and XML.

Field Summary
Fields inherited from class java.io.Writer
lock
Constructor Summary
ResponseWriter()
Method Summary
abstract ResponseWriter | cloneWithWriter(Writer writer) Create and return a new instance of this ResponseWriter, using the specified Writer as the output destination.
abstract void | endDocument() Write whatever text should end a response.
abstract void | endElement(String name) Write the end of an element, after closing any open element created by a call to startElement().
abstract void | flush() Flush any ouput buffered by the output method to the underlying Writer or OutputStream.
abstract String | getCharacterEncoding() Return the character encoding (such as "ISO-8859-1") for this ResponseWriter.
abstract String | getContentType() Return the content type (such as "text/html") for this ResponseWriter.
abstract void | startDocument() Write whatever text should begin a response.
abstract void | startElement(String name, UIComponent component) Write the start of an element, up to and including the element name.
abstract void | writeAttribute(String name, Object value, String property) Write an attribute name and corresponding value, after converting that text to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered.
abstract void | writeComment(Object comment) Write a comment containing the specified text, after converting that text to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered.
abstract void | writeText(char[] text, int off, int len) Write text from a character array, after any performing any escaping appropriate for the markup language being rendered.
abstract void | writeText(Object text, String property) Write an object, after converting it to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered.
void | writeText(Object text, UIComponent component, String property) Write an object, after converting it to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered.
abstract void | writeURIAttribute(String name, Object value, String property) Write a URI attribute name and corresponding value, after converting that text to a String (if necessary), and after performing any encoding appropriate to the markup language being rendered.
Methods inherited from class java.io.Writer
append, append, append, close, write, write, write, write, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResponseWriter

public ResponseWriter()
Method Detail

getContentType

public abstract String getContentType()

Return the content type (such as "text/html") for this ResponseWriter. Note: this must not include the "charset=" suffix.

getCharacterEncoding

public abstract String getCharacterEncoding()

Return the character encoding (such as "ISO-8859-1") for this ResponseWriter. Please see the IANA for a list of character encodings.

flush

public abstract void flush()
                    throws IOException

Flush any ouput buffered by the output method to the underlying Writer or OutputStream. This method will not flush the underlying Writer or OutputStream; it simply clears any values buffered by this ResponseWriter.

Specified by:
flush in interface Flushable
Specified by:
flush in class Writer
Throws:
IOException

startDocument

public abstract void startDocument()
                            throws IOException

Write whatever text should begin a response.

Throws:
IOException - if an input/output error occurs

endDocument

public abstract void endDocument()
                          throws IOException

Write whatever text should end a response. If there is an open element that has been created by a call to startElement(), that element will be closed first.

Throws:
IOException - if an input/output error occurs

startElement

public abstract void startElement(String name,
                                  UIComponent component)
                           throws IOException

Write the start of an element, up to and including the
 element name.  Once this method has been called, clients can
 call the writeAttribute() or
 writeURIAttribute() methods to add attributes and
 corresponding values.  The starting element will be closed
 (that is, the trailing '>' character added)
 on any subsequent call to startElement(),
 writeComment(),
 writeText(), endElement(),
 endDocument(), close(),
 flush(), or write().

Parameters:
name - Name of the element to be started
component - The UIComponent (if any) to which this element corresponds
Throws:
IOException - if an input/output error occurs
NullPointerException - if name is null

endElement

public abstract void endElement(String name)
                         throws IOException

Write the end of an element, after closing any open element created by a call to startElement(). Elements must be closed in the inverse order from which they were opened; it is an error to do otherwise.

Parameters:
name - Name of the element to be ended
Throws:
IOException - if an input/output error occurs
NullPointerException - if name is null

writeAttribute

public abstract void writeAttribute(String name,
                                    Object value,
                                    String property)
                             throws IOException

Write an attribute name and corresponding value, after converting that text to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered. This method may only be called after a call to startElement(), and before the opened element has been closed.

Parameters:
name - Attribute name to be added
value - Attribute value to be added
property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated attribute corresponds
Throws:
IllegalStateException - if this method is called when there is no currently open element
IOException - if an input/output error occurs
NullPointerException - if name is null

writeURIAttribute

public abstract void writeURIAttribute(String name,
                                       Object value,
                                       String property)
                                throws IOException

Write a URI attribute name and corresponding value, after converting that text to a String (if necessary), and after performing any encoding appropriate to the markup language being rendered. This method may only be called after a call to startElement(), and before the opened element has been closed.

Parameters:
name - Attribute name to be added
value - Attribute value to be added
property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated attribute corresponds
Throws:
IllegalStateException - if this method is called when there is no currently open element
IOException - if an input/output error occurs
NullPointerException - if name is null

writeComment

public abstract void writeComment(Object comment)
                           throws IOException

Write a comment containing the specified text, after converting that text to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered. If there is an open element that has been created by a call to startElement(), that element will be closed first.

Parameters:
comment - Text content of the comment
Throws:
IOException - if an input/output error occurs
NullPointerException - if comment is null

writeText

public abstract void writeText(Object text,
                               String property)
                        throws IOException

Write an object, after converting it to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered. If there is an open element that has been created by a call to startElement(), that element will be closed first.

Parameters:
text - Text to be written
property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated text corresponds
Throws:
IOException - if an input/output error occurs
NullPointerException - if text is null

writeText

public void writeText(Object text,
                      UIComponent component,
                      String property)
               throws IOException

Write an object, after converting it to a String (if necessary), and after performing any escaping appropriate for the markup language being rendered. This method is equivalent to writeText(java.lang.Object,java.lang.String) but adds a component property to allow custom ResponseWriter implementations to associate a component with an arbitrary portion of text.

The default implementation simply ignores the component argument and calls through to writeText(java.lang.Object,java.lang.String)

Parameters:
text - Text to be written
component - The UIComponent (if any) to which this element corresponds
property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated text corresponds
Throws:
IOException - if an input/output error occurs
NullPointerException - if text is null
Since:
1.2

writeText

public abstract void writeText(char[] text,
                               int off,
                               int len)
                        throws IOException

Write text from a character array, after any performing any escaping appropriate for the markup language being rendered. If there is an open element that has been created by a call to startElement(), that element will be closed first.

Parameters:
text - Text to be written
off - Starting offset (zero-relative)
len - Number of characters to be written
Throws:
IndexOutOfBoundsException - if the calculated starting or ending position is outside the bounds of the character array
IOException - if an input/output error occurs
NullPointerException - if text is null

cloneWithWriter

public abstract ResponseWriter cloneWithWriter(Writer writer)

Create and return a new instance of this ResponseWriter, using the specified Writer as the output destination.

Parameters:
writer - The Writer that is the output destination
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResponseWriterWrapper

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.context
Class ResponseWriterWrapper

java.lang.Object
    extended by  java.io.Writer
        extended by  javax.faces.context.ResponseWriter
            extended by  javax.faces.context.ResponseWriterWrapper
All Implemented Interfaces:
Closeable, Flushable, Appendable
public abstract class ResponseWriterWrapper
extends ResponseWriter

Provides a simple implementation of ResponseWriter that can be subclassed by developers wishing to provide specialized behavior to an existing ResponseWriter instance. The default implementation of all methods is to call through to the wrapped ResponseWriter.

Usage: extend this class and override getWrapped() to return the instance we are wrapping.

Since:
1.2

Field Summary
Fields inherited from class java.io.Writer
lock
Constructor Summary
ResponseWriterWrapper()
Method Summary
 ResponseWriter cloneWithWriter(Writer writer)
The default behavior of this method is to call ResponseWriter.cloneWithWriter(java.io.Writer) on the wrapped ResponseWriter object.
 void close()
The default behavior of this method is to call Writer.close() on the wrapped ResponseWriter object.
 void endDocument()
The default behavior of this method is to call ResponseWriter.endDocument() on the wrapped ResponseWriter object.
 void endElement(String name)
The default behavior of this method is to call ResponseWriter.endElement(String) on the wrapped ResponseWriter object.
 void flush()
The default behavior of this method is to call ResponseWriter.flush() on the wrapped ResponseWriter object.
 String getCharacterEncoding()
The default behavior of this method is to call ResponseWriter.getCharacterEncoding() on the wrapped ResponseWriter object.
 String getContentType()
The default behavior of this method is to call ResponseWriter.getContentType() on the wrapped ResponseWriter object.
protected abstract  ResponseWriter getWrapped()
 void startDocument()
The default behavior of this method is to call ResponseWriter.startDocument() on the wrapped ResponseWriter object.
 void startElement(String name, UIComponent component)
The default behavior of this method is to call ResponseWriter.startElement(String, javax.faces.component.UIComponent) on the wrapped ResponseWriter object.
 void write(char[] cbuf, int off, int len)
The default behavior of this method is to call Writer.write(char[], int, int) on the wrapped ResponseWriter object.
 void writeAttribute(String name, Object value, String property)
The default behavior of this method is to call ResponseWriter.writeAttribute(String, Object, String) on the wrapped ResponseWriter object.
 void writeComment(Object comment)
The default behavior of this method is to call ResponseWriter.writeComment(Object) on the wrapped ResponseWriter object.
 void writeText(char[] text, int off, int len)
The default behavior of this method is to call ResponseWriter.writeText(char[], int, int) on the wrapped ResponseWriter object.
 void writeText(Object text, String property)
The default behavior of this method is to call ResponseWriter.writeText(Object, String) on the wrapped ResponseWriter object.
 void writeText(Object text, UIComponent component, String property)
The default behavior of this method is to call ResponseWriter.writeText(Object, UIComponent, String) on the wrapped ResponseWriter object.
 void writeURIAttribute(String name, Object value, String property)
The default behavior of this method is to call ResponseWriter.writeURIAttribute(String, Object, String) on the wrapped ResponseWriter object.
Methods inherited from class java.io.Writer
append, append, append, write, write, write, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResponseWriterWrapper

public ResponseWriterWrapper()
Method Detail

getWrapped

protected abstract ResponseWriter getWrapped()
Returns:
the instance that we are wrapping.

getContentType

public String getContentType()

The default behavior of this method is to call ResponseWriter.getContentType() on the wrapped ResponseWriter object.

Specified by:
getContentType in class ResponseWriter
Since:
1.2
See Also:
ResponseWriter.getContentType()

getCharacterEncoding

public String getCharacterEncoding()

The default behavior of this method is to call ResponseWriter.getCharacterEncoding() on the wrapped ResponseWriter object.

Specified by:
getCharacterEncoding in class ResponseWriter
Since:
1.2
See Also:
ResponseWriter.getCharacterEncoding()

flush

public void flush()
           throws IOException

The default behavior of this method is to call ResponseWriter.flush() on the wrapped ResponseWriter object.

Specified by:
flush in interface Flushable
Specified by:
flush in class ResponseWriter
Throws:
IOException
Since:
1.2
See Also:
ResponseWriter.flush()

startDocument

public void startDocument()
                   throws IOException

The default behavior of this method is to call ResponseWriter.startDocument() on the wrapped ResponseWriter object.

Specified by:
startDocument in class ResponseWriter
Throws:
IOException - if an input/output error occurs
Since:
1.2
See Also:
ResponseWriter.startDocument()

endDocument

public void endDocument()
                 throws IOException

The default behavior of this method is to call ResponseWriter.endDocument() on the wrapped ResponseWriter object.

Specified by:
endDocument in class ResponseWriter
Throws:
IOException - if an input/output error occurs
Since:
1.2
See Also:
ResponseWriter.endDocument()

startElement

public void startElement(String name,
                         UIComponent component)
                  throws IOException

The default behavior of this method is to call ResponseWriter.startElement(String, javax.faces.component.UIComponent) on the wrapped ResponseWriter object.

Specified by:
startElement in class ResponseWriter
Parameters:
name - Name of the element to be started
component - The UIComponent (if any) to which this element corresponds
Throws:
IOException - if an input/output error occurs
Since:
1.2
See Also:
ResponseWriter.startElement(String, javax.faces.component.UIComponent)

endElement

public void endElement(String name)
                throws IOException

The default behavior of this method is to call ResponseWriter.endElement(String) on the wrapped ResponseWriter object.

Specified by:
endElement in class ResponseWriter
Parameters:
name - Name of the element to be ended
Throws:
IOException - if an input/output error occurs
Since:
1.2
See Also:
ResponseWriter.endElement(String)

writeAttribute

public void writeAttribute(String name,
                           Object value,
                           String property)
                    throws IOException

The default behavior of this method is to call ResponseWriter.writeAttribute(String, Object, String) on the wrapped ResponseWriter object.

Specified by:
writeAttribute in class ResponseWriter
Parameters:
name - Attribute name to be added
value - Attribute value to be added
property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated attribute corresponds
Throws:
IOException - if an input/output error occurs
Since:
1.2
See Also:
ResponseWriter.writeAttribute(String, Object, String)

writeURIAttribute

public void writeURIAttribute(String name,
                              Object value,
                              String property)
                       throws IOException

The default behavior of this method is to call ResponseWriter.writeURIAttribute(String, Object, String) on the wrapped ResponseWriter object.

Specified by:
writeURIAttribute in class ResponseWriter
Parameters:
name - Attribute name to be added
value - Attribute value to be added
property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated attribute corresponds
Throws:
IOException - if an input/output error occurs
Since:
1.2
See Also:
ResponseWriter.writeURIAttribute(String, Object, String)

writeComment

public void writeComment(Object comment)
                  throws IOException

The default behavior of this method is to call ResponseWriter.writeComment(Object) on the wrapped ResponseWriter object.

Specified by:
writeComment in class ResponseWriter
Parameters:
comment - Text content of the comment
Throws:
IOException - if an input/output error occurs
Since:
1.2
See Also:
ResponseWriter.writeComment(Object)

writeText

public void writeText(Object text,
                      String property)
               throws IOException

The default behavior of this method is to call ResponseWriter.writeText(Object, String) on the wrapped ResponseWriter object.

Specified by:
writeText in class ResponseWriter
Parameters:
text - Text to be written
property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated text corresponds
Throws:
IOException - if an input/output error occurs
Since:
1.2
See Also:
ResponseWriter.writeText(Object, String)

writeText

public void writeText(Object text,
                      UIComponent component,
                      String property)
               throws IOException

The default behavior of this method is to call ResponseWriter.writeText(Object, UIComponent, String) on the wrapped ResponseWriter object.

Overrides:
writeText in class ResponseWriter
Parameters:
text - Text to be written
component - The UIComponent (if any) to which this element corresponds
property - Name of the property or attribute (if any) of the UIComponent associated with the containing element, to which this generated text corresponds
Throws:
IOException - if an input/output error occurs
Since:
1.2
See Also:
ResponseWriter.writeText(Object, String)

writeText

public void writeText(char[] text,
                      int off,
                      int len)
               throws IOException

The default behavior of this method is to call ResponseWriter.writeText(char[], int, int) on the wrapped ResponseWriter object.

Specified by:
writeText in class ResponseWriter
Parameters:
text - Text to be written
off - Starting offset (zero-relative)
len - Number of characters to be written
Throws:
IOException - if an input/output error occurs
Since:
1.2
See Also:
ResponseWriter.writeText(char[], int, int)

cloneWithWriter

public ResponseWriter cloneWithWriter(Writer writer)

The default behavior of this method is to call ResponseWriter.cloneWithWriter(java.io.Writer) on the wrapped ResponseWriter object.

Specified by:
cloneWithWriter in class ResponseWriter
Parameters:
writer - The Writer that is the output destination
Since:
1.2
See Also:
ResponseWriter.cloneWithWriter(java.io.Writer)

close

public void close()
           throws IOException

The default behavior of this method is to call Writer.close() on the wrapped ResponseWriter object.

Specified by:
close in interface Closeable
Specified by:
close in class Writer
Throws:
IOException
Since:
1.2
See Also:
Writer.close()

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException

The default behavior of this method is to call Writer.write(char[], int, int) on the wrapped ResponseWriter object.

Specified by:
write in class Writer
Throws:
IOException
Since:
1.2
See Also:
Writer.write(char[], int, int)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


convert

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.faces.convert

Contains classes and interfaces defining converters.

See:
Description

Interface Summary
Converter Converter is an interface describing a Java class that can perform Object-to-String and String-to-Object conversions between model data objects and a String representation of those objects that is suitable for rendering.

Class Summary
BigDecimalConverter | Converter implementation for java.math.BigDecimal values.
BigIntegerConverter | Converter implementation for java.math.BigInteger values.
BooleanConverter | Converter implementation for java.lang.Boolean (and boolean primitive) values.
ByteConverter | Converter implementation for java.lang.Byte (and byte primitive) values.
CharacterConverter | Converter implementation for java.lang.Character (and char primitive) values.
DateTimeConverter | Converter implementation for java.util.Date values.
DoubleConverter | Converter implementation for java.lang.Double (and double primitive) values.
EnumConverter | Converter implementation for java.lang.Enum (and enum primitive) values.
FloatConverter | Converter implementation for java.lang.Float (and float primitive) values.
IntegerConverter | Converter implementation for java.lang.Integer (and int primitive) values.
LongConverter | Converter implementation for java.lang.Long (and long primitive) values.
NumberConverter | Converter implementation for java.lang.Number values.
ShortConverter | Converter implementation for java.lang.Short (and short primitive) values.

Exception Summary
ConverterException ConverterException is an exception thrown by the getAsObject() or getAsText() method of a Converter, to indicate that the requested conversion cannot be performed.

Package javax.faces.convert Description

Contains classes and interfaces defining converters. The main class in this package is Converter.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.faces.convert Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.faces.convert

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.convert.BigDecimalConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.BigIntegerConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.BooleanConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.ByteConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.CharacterConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.DateTimeConverter (implements javax.faces.convert.Converter, javax.faces.component.StateHolder)
    • javax.faces.convert.DoubleConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.EnumConverter (implements javax.faces.convert.Converter, javax.faces.component.StateHolder)
    • javax.faces.convert.FloatConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.IntegerConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.LongConverter (implements javax.faces.convert.Converter)
    • javax.faces.convert.NumberConverter (implements javax.faces.convert.Converter, javax.faces.component.StateHolder)
    • javax.faces.convert.ShortConverter (implements javax.faces.convert.Converter)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.convert.ConverterException

Interface Hierarchy

  • javax.faces.convert.Converter
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BigDecimalConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class BigDecimalConverter

java.lang.Object
    extended by  javax.faces.convert.BigDecimalConverter
All Implemented Interfaces:
Converter
public class BigDecimalConverter
extends Object
implements Converter

Converter implementation for java.math.BigDecimal values.

Field Summary
static String | CONVERTER_ID The standard converter id for this converter.
static String | DECIMAL_ID The message identifier of the FacesMessage to be created if the conversion to BigDecimal fails.
static String | STRING_ID The message identifier of the FacesMessage to be created if the conversion of the BigDecimal value to String fails.
Constructor Summary
BigDecimalConverter()
Method Summary
Object | getAsObject(FacesContext context, UIComponent component, String value) Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
String | getAsString(FacesContext context, UIComponent component, Object value) Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONVERTER_ID

public static final String CONVERTER_ID

The standard converter id for this converter.

See Also:
Constant Field Values

DECIMAL_ID

public static final String DECIMAL_ID

The message identifier of the FacesMessage to be created if the conversion to BigDecimal fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

STRING_ID

public static final String STRING_ID

The message identifier of the FacesMessage to be created if the conversion of the BigDecimal value to String fails. The message format string for this message may optionally include the following placeholders:

  • {0} relaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

BigDecimalConverter

public BigDecimalConverter()
Method Detail

getAsObject

public Object getAsObject(FacesContext context,
                          UIComponent component,
                          String value)
Description copied from interface: Converter

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

Specified by:
getAsObject in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - String value to be converted (may be null)
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

public String getAsString(FacesContext context,
                          UIComponent component,
                          Object value)
Description copied from interface: Converter

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Specified by:
getAsString in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BigIntegerConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class BigIntegerConverter

java.lang.Object
    extended by  javax.faces.convert.BigIntegerConverter
All Implemented Interfaces:
Converter
public class BigIntegerConverter
extends Object
implements Converter

Converter implementation for java.math.BigInteger values.

Field Summary
static String | BIGINTEGER_ID The message identifier of the FacesMessage to be created if the conversion to BigInteger fails.
static String | CONVERTER_ID The standard converter id for this converter.
static String | STRING_ID The message identifier of the FacesMessage to be created if the conversion of the BigInteger value to String fails.
Constructor Summary
BigIntegerConverter()
Method Summary
Object | getAsObject(FacesContext context, UIComponent component, String value) Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
String | getAsString(FacesContext context, UIComponent component, Object value) Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONVERTER_ID

public static final String CONVERTER_ID

The standard converter id for this converter.

See Also:
Constant Field Values

BIGINTEGER_ID

public static final String BIGINTEGER_ID

The message identifier of the FacesMessage to be created if the conversion to BigInteger fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

STRING_ID

public static final String STRING_ID

The message identifier of the FacesMessage to be created if the conversion of the BigInteger value to String fails. The message format string for this message may optionally include the following placeholders:

  • {0} relaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

BigIntegerConverter

public BigIntegerConverter()
Method Detail

getAsObject

public Object getAsObject(FacesContext context,
                          UIComponent component,
                          String value)
Description copied from interface: Converter

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

Specified by:
getAsObject in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - String value to be converted (may be null)
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

public String getAsString(FacesContext context,
                          UIComponent component,
                          Object value)
Description copied from interface: Converter

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Specified by:
getAsString in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BooleanConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class BooleanConverter

java.lang.Object
    extended by  javax.faces.convert.BooleanConverter
All Implemented Interfaces:
Converter
public class BooleanConverter
extends Object
implements Converter

Converter implementation for java.lang.Boolean (and boolean primitive) values.

Field Summary
static String | BOOLEAN_ID The message identifier of the FacesMessage to be created if the conversion to Boolean fails.
static String | CONVERTER_ID The standard converter id for this converter.
static String | STRING_ID The message identifier of the FacesMessage to be created if the conversion of the Boolean value to String fails.
Constructor Summary
BooleanConverter()
Method Summary
Object | getAsObject(FacesContext context, UIComponent component, String value) Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
String | getAsString(FacesContext context, UIComponent component, Object value) Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONVERTER_ID

public static final String CONVERTER_ID

The standard converter id for this converter.

See Also:
Constant Field Values

BOOLEAN_ID

public static final String BOOLEAN_ID

The message identifier of the FacesMessage to be created if the conversion to Boolean fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

STRING_ID

public static final String STRING_ID

The message identifier of the FacesMessage to be created if the conversion of the Boolean value to String fails. The message format string for this message may optionally include the following placeholders:

  • {0} relaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

BooleanConverter

public BooleanConverter()
Method Detail

getAsObject

public Object getAsObject(FacesContext context,
                          UIComponent component,
                          String value)
Description copied from interface: Converter

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

Specified by:
getAsObject in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - String value to be converted (may be null)
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

public String getAsString(FacesContext context,
                          UIComponent component,
                          Object value)
Description copied from interface: Converter

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Specified by:
getAsString in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ByteConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class ByteConverter

java.lang.Object
    extended by  javax.faces.convert.ByteConverter
All Implemented Interfaces:
Converter
public class ByteConverter
extends Object
implements Converter

Converter implementation for java.lang.Byte (and byte primitive) values.

Field Summary
static String | BYTE_ID The message identifier of the FacesMessage to be created if the conversion to Byte fails.
static String | CONVERTER_ID The standard converter id for this converter.
static String | STRING_ID The message identifier of the FacesMessage to be created if the conversion of the Byte value to String fails.
Constructor Summary
ByteConverter()
Method Summary
Object | getAsObject(FacesContext context, UIComponent component, String value) Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
String | getAsString(FacesContext context, UIComponent component, Object value) Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONVERTER_ID

public static final String CONVERTER_ID

The standard converter id for this converter.

See Also:
Constant Field Values

BYTE_ID

public static final String BYTE_ID

The message identifier of the FacesMessage to be created if the conversion to Byte fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

STRING_ID

public static final String STRING_ID

The message identifier of the FacesMessage to be created if the conversion of the Byte value to String fails. The message format string for this message may optionally include the following placeholders:

  • {0} relaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

ByteConverter

public ByteConverter()
Method Detail

getAsObject

public Object getAsObject(FacesContext context,
                          UIComponent component,
                          String value)
Description copied from interface: Converter

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

Specified by:
getAsObject in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - String value to be converted (may be null)
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

public String getAsString(FacesContext context,
                          UIComponent component,
                          Object value)
Description copied from interface: Converter

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Specified by:
getAsString in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


CharacterConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class CharacterConverter

java.lang.Object
    extended by  javax.faces.convert.CharacterConverter
All Implemented Interfaces:
Converter
public class CharacterConverter
extends Object
implements Converter

Converter implementation for java.lang.Character (and char primitive) values.

Field Summary
static String | CHARACTER_ID The message identifier of the FacesMessage to be created if the conversion to Character fails.
static String | CONVERTER_ID The standard converter id for this converter.
static String | STRING_ID The message identifier of the FacesMessage to be created if the conversion of the Character value to String fails.
Constructor Summary
CharacterConverter()
Method Summary
Object | getAsObject(FacesContext context, UIComponent component, String value) Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
String | getAsString(FacesContext context, UIComponent component, Object value) Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONVERTER_ID

public static final String CONVERTER_ID

The standard converter id for this converter.

See Also:
Constant Field Values

CHARACTER_ID

public static final String CHARACTER_ID

The message identifier of the FacesMessage to be created if the conversion to Character fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

STRING_ID

public static final String STRING_ID

The message identifier of the FacesMessage to be created if the conversion of the Character value to String fails. The message format string for this message may optionally include the following placeholders:

  • {0} relaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

CharacterConverter

public CharacterConverter()
Method Detail

getAsObject

public Object getAsObject(FacesContext context,
                          UIComponent component,
                          String value)
Description copied from interface: Converter

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

Specified by:
getAsObject in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - String value to be converted (may be null)
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

public String getAsString(FacesContext context,
                          UIComponent component,
                          Object value)
Description copied from interface: Converter

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Specified by:
getAsString in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Converter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Interface Converter

All Known Implementing Classes:
BigDecimalConverter, BigIntegerConverter, BooleanConverter, ByteConverter, CharacterConverter, DateTimeConverter, DoubleConverter, EnumConverter, FloatConverter, IntegerConverter, LongConverter, NumberConverter, ShortConverter
public interface Converter

Converter is an interface describing a Java class that can perform Object-to-String and String-to-Object conversions between model data objects and a String representation of those objects that is suitable for rendering.

Converter implementations must have a zero-arguments public constructor. In addition, if the Converter class wishes to have configuration property values saved and restored with the component tree, the implementation must also implement StateHolder.

Starting with version 1.2 of the specification, an exception to the above zero-arguments constructor requirement has been introduced. If a converter has a single argument constructor that takes a Class instance and the Class of the data to be converted is known at converter instantiation time, this constructor must be used to instantiate the converter instead of the zero-argument version. This enables the per-class conversion of Java enumerated types.

If any Converter implementation requires a java.util.Locale to perform its job, it must obtain that Locale from the UIViewRoot of the current FacesContext, unless the Converter maintains its own Locale as part of its state.

Method Summary
Object | getAsObject(FacesContext context, UIComponent component, String value) Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
String | getAsString(FacesContext context, UIComponent component, Object value) Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Method Detail

getAsObject

Object getAsObject(FacesContext context,
                   UIComponent component,
                   String value)

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - String value to be converted (may be null)
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

String getAsString(FacesContext context,
                   UIComponent component,
                   Object value)

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConverterException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class ConverterException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.faces.FacesException
                    extended by  javax.faces.convert.ConverterException
All Implemented Interfaces:
Serializable
public class ConverterException
extends FacesException

ConverterException is an exception thrown by the getAsObject() or getAsText() method of a Converter, to indicate that the requested conversion cannot be performed.

See Also:
Serialized Form

Constructor Summary
ConverterException()
Construct a new exception with no detail message or root cause.
ConverterException(FacesMessage message)
Construct a new exception with the specified detail message and no root cause.
ConverterException(FacesMessage message, Throwable cause)
Construct a new exception with the specified detail message and root cause.
ConverterException(String message)
Construct a new exception with the specified detail message and no root cause.
ConverterException(String message, Throwable cause)
Construct a new exception with the specified detail message and root cause.
ConverterException(Throwable cause)
Construct a new exception with the specified root cause.
Method Summary
 FacesMessage getFacesMessage()
Returns the FacesMessage associated with this exception; this will only be available if the converter that thew this exception instance placed it there.
Methods inherited from class javax.faces.FacesException
getCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ConverterException

public ConverterException()

Construct a new exception with no detail message or root cause.

ConverterException

public ConverterException(String message)

Construct a new exception with the specified detail message and no root cause.

Parameters:
message - The detail message for this exception

ConverterException

public ConverterException(Throwable cause)

Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

Parameters:
cause - The root cause for this exception

ConverterException

public ConverterException(String message,
                          Throwable cause)

Construct a new exception with the specified detail message and root cause.

Parameters:
message - The detail message for this exception
cause - The root cause for this exception

ConverterException

public ConverterException(FacesMessage message)

Construct a new exception with the specified detail message and no root cause.

Parameters:
message - The detail message for this exception

ConverterException

public ConverterException(FacesMessage message,
                          Throwable cause)

Construct a new exception with the specified detail message and root cause.

Parameters:
message - The detail message for this exception
cause - The root cause for this exception
Method Detail

getFacesMessage

public FacesMessage getFacesMessage()

Returns the FacesMessage associated with this exception; this will only be available if the converter that thew this exception instance placed it there.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DateTimeConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class DateTimeConverter

java.lang.Object
    extended by  javax.faces.convert.DateTimeConverter
All Implemented Interfaces:
StateHolder, Converter
public class DateTimeConverter
extends Object
implements Converter, StateHolder

Converter implementation for java.util.Date values.

The getAsObject() method parses a String into a java.util.Date, according to the following algorithm:

  • If the specified String is null, return a null. Otherwise, trim leading and trailing whitespace before proceeding.
  • If the specified String - after trimming - has a zero length, return null.
  • If the locale property is not null, use that Locale for managing parsing. Otherwise, use the Locale from the UIViewRoot.
  • If a pattern has been specified, its syntax must conform the rules specified by java.text.SimpleDateFormat. Such a pattern will be used to parse, and the type, dateStyle, and timeStyle properties will be ignored.
  • If a pattern has not been specified, parsing will be based on the type property, which expects a date value, a time value, or both. Any date and time values included will be parsed in accordance to the styles specified by dateStyle and timeStyle, respectively.
  • If a timezone has been specified, it must be passed to the underlying DateFormat instance. Otherwise the "GMT" timezone is used.
  • In all cases, parsing must be non-lenient; the given string must strictly adhere to the parsing format.

The getAsString() method expects a value of type java.util.Date (or a subclass), and creates a formatted String according to the following algorithm:

  • If the specified value is null, return a zero-length String.
  • If the specified value is a String, return it unmodified.
  • If the locale property is not null, use that Locale for managing formatting. Otherwise, use the Locale from the UIViewRoot.
  • If a timezone has been specified, it must be passed to the underlying DateFormat instance. Otherwise the "GMT" timezone is used.
  • If a pattern has been specified, its syntax must conform the rules specified by java.text.SimpleDateFormat. Such a pattern will be used to format, and the type, dateStyle, and timeStyle properties will be ignored.
  • If a pattern has not been specified, formatting will be based on the type property, which includes a date value, a time value, or both into the formatted String. Any date and time values included will be formatted in accordance to the styles specified by dateStyle and timeStyle, respectively.

Field Summary
static String | CONVERTER_ID The standard converter id for this converter.
static String | DATE_ID The message identifier of the FacesMessage to be created if the conversion to Date fails.
static String | DATETIME_ID The message identifier of the FacesMessage to be created if the conversion to DateTime fails.
static String | STRING_ID The message identifier of the FacesMessage to be created if the conversion of the DateTime value to String fails.
static String | TIME_ID The message identifier of the FacesMessage to be created if the conversion to Time fails.
Constructor Summary
DateTimeConverter()
Method Summary
Object | getAsObject(FacesContext context, UIComponent component, String value) Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
String | getAsString(FacesContext context, UIComponent component, Object value) Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
String | getDateStyle() Return the style to be used to format or parse dates.
Locale | getLocale() Return the Locale to be used when parsing or formatting dates and times.
String | getPattern() Return the format pattern to be used when formatting and parsing dates and times.
String | getTimeStyle() Return the style to be used to format or parse times.
TimeZone | getTimeZone() Return the TimeZone used to interpret a time value.
String | getType() Return the type of value to be formatted or parsed.
boolean | isTransient() If true, the Object implementing this interface must not participate in state saving or restoring.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setDateStyle(String dateStyle) Set the style to be used to format or parse dates.
void | setLocale(Locale locale) Set the Locale to be used when parsing or formatting dates and times.
void | setPattern(String pattern) Set the format pattern to be used when formatting and parsing dates and times.
void | setTimeStyle(String timeStyle) Set the style to be used to format or parse times.
void | setTimeZone(TimeZone timeZone) Set the TimeZone used to interpret a time value.
void | setTransient(boolean transientFlag) Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
void | setType(String type) Set the type of value to be formatted or parsed.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONVERTER_ID

public static final String CONVERTER_ID

The standard converter id for this converter.

See Also:
Constant Field Values

DATE_ID

public static final String DATE_ID

The message identifier of the FacesMessage to be created if the conversion to Date fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

TIME_ID

public static final String TIME_ID

The message identifier of the FacesMessage to be created if the conversion to Time fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

DATETIME_ID

public static final String DATETIME_ID

The message identifier of the FacesMessage to be created if the conversion to DateTime fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

STRING_ID

public static final String STRING_ID

The message identifier of the FacesMessage to be created if the conversion of the DateTime value to String fails. The message format string for this message may optionally include the following placeholders:

  • {0} relaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

DateTimeConverter

public DateTimeConverter()
Method Detail

getDateStyle

public String getDateStyle()

Return the style to be used to format or parse dates. If not set, the default value, default, is returned.

setDateStyle

public void setDateStyle(String dateStyle)

Set the style to be used to format or parse dates. Valid values are default, short, medium, long, and full. An invalid value will cause a ConverterException when getAsObject() or getAsString() is called.

Parameters:
dateStyle - The new style code

getLocale

public Locale getLocale()

Return the Locale to be used when parsing or formatting dates and times. If not explicitly set, the Locale stored in the UIViewRoot for the current request is returned.

setLocale

public void setLocale(Locale locale)

Set the Locale to be used when parsing or formatting dates and times. If set to null, the Locale stored in the UIViewRoot for the current request will be utilized.

Parameters:
locale - The new Locale (or null)

getPattern

public String getPattern()

Return the format pattern to be used when formatting and parsing dates and times.

setPattern

public void setPattern(String pattern)

Set the format pattern to be used when formatting and parsing dates and times. Valid values are those supported by java.text.SimpleDateFormat. An invalid value will cause a ConverterException when getAsObject() or getAsString() is called.

Parameters:
pattern - The new format pattern

getTimeStyle

public String getTimeStyle()

Return the style to be used to format or parse times. If not set, the default value, default, is returned.

setTimeStyle

public void setTimeStyle(String timeStyle)

Set the style to be used to format or parse times. Valid values are default, short, medium, long, and full. An invalid value will cause a ConverterException when getAsObject() or getAsString() is called.

Parameters:
timeStyle - The new style code

getTimeZone

public TimeZone getTimeZone()

Return the TimeZone used to interpret a time value. If not explicitly set, the default time zone of GMT returned.

setTimeZone

public void setTimeZone(TimeZone timeZone)

Set the TimeZone used to interpret a time value.

Parameters:
timeZone - The new time zone

getType

public String getType()

Return the type of value to be formatted or parsed. If not explicitly set, the default type, date is returned.

setType

public void setType(String type)

Set the type of value to be formatted or parsed. Valid values are both, date, or time. An invalid value will cause a ConverterException when getAsObject() or getAsString() is called.

Parameters:
type - The new date style

getAsObject

public Object getAsObject(FacesContext context,
                          UIComponent component,
                          String value)
Description copied from interface: Converter

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

Specified by:
getAsObject in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - String value to be converted (may be null)
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

public String getAsString(FacesContext context,
                          UIComponent component,
                          Object value)
Description copied from interface: Converter

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Specified by:
getAsString in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder

isTransient

public boolean isTransient()
Description copied from interface: StateHolder

If true, the Object implementing this interface must not participate in state saving or restoring.

Specified by:
isTransient in interface StateHolder

setTransient

public void setTransient(boolean transientFlag)
Description copied from interface: StateHolder

Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

Specified by:
setTransient in interface StateHolder
Parameters:
transientFlag - boolean pass true if this Object will participate in state saving or restoring, otherwise pass false.
Overview  Package   Class  Tree  Deprecated  Index  Help
Java EE 5 SDK
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DoubleConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class DoubleConverter

java.lang.Object
    extended by  javax.faces.convert.DoubleConverter
All Implemented Interfaces:
Converter
public class DoubleConverter
extends Object
implements Converter

Converter implementation for java.lang.Double (and double primitive) values.

Field Summary
static String | CONVERTER_ID The standard converter id for this converter.
static String | DOUBLE_ID The message identifier of the FacesMessage to be created if the conversion to Double fails.
static String | STRING_ID The message identifier of the FacesMessage to be created if the conversion of the Double value to String fails.
Constructor Summary
DoubleConverter()
Method Summary
Object | getAsObject(FacesContext context, UIComponent component, String value) Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
String | getAsString(FacesContext context, UIComponent component, Object value) Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONVERTER_ID

public static final String CONVERTER_ID

The standard converter id for this converter.

See Also:
Constant Field Values

DOUBLE_ID

public static final String DOUBLE_ID

The message identifier of the FacesMessage to be created if the conversion to Double fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

STRING_ID

public static final String STRING_ID

The message identifier of the FacesMessage to be created if the conversion of the Double value to String fails. The message format string for this message may optionally include the following placeholders:

  • {0} relaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

DoubleConverter

public DoubleConverter()
Method Detail

getAsObject

public Object getAsObject(FacesContext context,
                          UIComponent component,
                          String value)
Description copied from interface: Converter

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

Specified by:
getAsObject in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - String value to be converted (may be null)
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

public String getAsString(FacesContext context,
                          UIComponent component,
                          Object value)
Description copied from interface: Converter

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Specified by:
getAsString in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EnumConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class EnumConverter

java.lang.Object
    extended by  javax.faces.convert.EnumConverter
All Implemented Interfaces:
StateHolder, Converter
public class EnumConverter
extends Object
implements Converter, StateHolder

Converter implementation for java.lang.Enum (and enum primitive) values.

Since:
1.2

Field Summary
static String | CONVERTER_ID The standard converter id for this converter.
static String | ENUM_ID The message identifier of the FacesMessage to be created if the conversion to Enum fails.
static String | ENUM_NO_CLASS_ID The message identifier of the FacesMessage to be created if the conversion to Enum fails and no target class has been provided.
Constructor Summary
EnumConverter()
EnumConverter(Class targetClass)
Method Summary
Object | getAsObject(FacesContext context, UIComponent component, String value) Convert the argument value to one of the enum constants of the class provided in our constructor.
String | getAsString(FacesContext context, UIComponent component, Object value) Convert the enum constant given by the value argument into a String.
boolean | isTransient() If true, the Object implementing this interface must not participate in state saving or restoring.
void | restoreState(FacesContext facesContext, Object object) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext facesContext) Gets the state of the instance as a Serializable Object.
void | setTransient(boolean b) Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONVERTER_ID

public static final String CONVERTER_ID

The standard converter id for this converter.

See Also:
Constant Field Values

ENUM_ID

public static final String ENUM_ID

The message identifier of the FacesMessage to be created if the conversion to Enum fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by one of the enum constants or the empty string if none can be found.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

ENUM_NO_CLASS_ID

public static final String ENUM_NO_CLASS_ID

The message identifier of the FacesMessage to be created if the conversion to Enum fails and no target class has been provided. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

EnumConverter

public EnumConverter()

EnumConverter

public EnumConverter(Class targetClass)
Method Detail

getAsObject

public Object getAsObject(FacesContext context,
                          UIComponent component,
                          String value)

Convert the argument value to one of the enum constants of the class provided in our constructor. If a target class argument has been provided to the constructor for this instance, call its getEnumConstants() method. For each element in the list of constants, call toString() and compare the string with the argument value. If they are equal, return the current element as the Object value. If none of the elements yield a match in this manner, or the length of the list returned from getEnumConstants() is zero, throw a ConverterException containing the ENUM_ID message with proper parameters. If no target class argument has been provided to the constructor of this instance, throw a ConverterException containing the ENUM_NO_CLASS_ID message with proper parameters.

Specified by:
getAsObject in interface Converter
Parameters:
context - the FacesContext for this request.
component - the UIComponent to which this value will be applied.
value - the String value to be converted to Object.
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

public String getAsString(FacesContext context,
                          UIComponent component,
                          Object value)

Convert the enum constant given by the value argument into a String. If a target class argument has been provided to the constructor for this instance, call its getEnumConstants() method. For each element in the list of constants, test for equality between the current element and the argument value. If they are equal, call toString() on the current element and return it. If none of the elements yield a match in this manner, or the length of the list returned from getEnumConstants() is zero, simply call toString() on the argument value and return it.

Specified by:
getAsString in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

restoreState

public void restoreState(FacesContext facesContext,
                         Object object)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder

saveState

public Object saveState(FacesContext facesContext)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder

setTransient

public void setTransient(boolean b)
Description copied from interface: StateHolder

Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

Specified by:
setTransient in interface StateHolder
Parameters:
b - boolean pass true if this Object will participate in state saving or restoring, otherwise pass false.

isTransient

public boolean isTransient()
Description copied from interface: StateHolder

If true, the Object implementing this interface must not participate in state saving or restoring.

Specified by:
isTransient in interface StateHolder
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FloatConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class FloatConverter

java.lang.Object
    extended by  javax.faces.convert.FloatConverter
All Implemented Interfaces:
Converter
public class FloatConverter
extends Object
implements Converter

Converter implementation for java.lang.Float (and float primitive) values.

Field Summary
static String | CONVERTER_ID The standard converter id for this converter.
static String | FLOAT_ID The message identifier of the FacesMessage to be created if the conversion to Float fails.
static String | STRING_ID The message identifier of the FacesMessage to be created if the conversion of the Float value to String fails.
Constructor Summary
FloatConverter()
Method Summary
Object | getAsObject(FacesContext context, UIComponent component, String value) Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
String | getAsString(FacesContext context, UIComponent component, Object value) Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONVERTER_ID

public static final String CONVERTER_ID

The standard converter id for this converter.

See Also:
Constant Field Values

FLOAT_ID

public static final String FLOAT_ID

The message identifier of the FacesMessage to be created if the conversion to Float fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

STRING_ID

public static final String STRING_ID

The message identifier of the FacesMessage to be created if the conversion of the Float value to String fails. The message format string for this message may optionally include the following placeholders:

  • {0} relaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

FloatConverter

public FloatConverter()
Method Detail

getAsObject

public Object getAsObject(FacesContext context,
                          UIComponent component,
                          String value)
Description copied from interface: Converter

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

Specified by:
getAsObject in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - String value to be converted (may be null)
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

public String getAsString(FacesContext context,
                          UIComponent component,
                          Object value)
Description copied from interface: Converter

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Specified by:
getAsString in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


IntegerConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class IntegerConverter

java.lang.Object
    extended by  javax.faces.convert.IntegerConverter
All Implemented Interfaces:
Converter
public class IntegerConverter
extends Object
implements Converter

Converter implementation for java.lang.Integer (and int primitive) values.

Field Summary
static String | CONVERTER_ID The standard converter id for this converter.
static String | INTEGER_ID The message identifier of the FacesMessage to be created if the conversion to Integer fails.
static String | STRING_ID The message identifier of the FacesMessage to be created if the conversion of the Integer value to String fails.
Constructor Summary
IntegerConverter()
Method Summary
Object | getAsObject(FacesContext context, UIComponent component, String value) Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
String | getAsString(FacesContext context, UIComponent component, Object value) Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONVERTER_ID

public static final String CONVERTER_ID

The standard converter id for this converter.

See Also:
Constant Field Values

INTEGER_ID

public static final String INTEGER_ID

The message identifier of the FacesMessage to be created if the conversion to Integer fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

STRING_ID

public static final String STRING_ID

The message identifier of the FacesMessage to be created if the conversion of the Integer value to String fails. The message format string for this message may optionally include the following placeholders:

  • {0} relaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

IntegerConverter

public IntegerConverter()
Method Detail

getAsObject

public Object getAsObject(FacesContext context,
                          UIComponent component,
                          String value)
Description copied from interface: Converter

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

Specified by:
getAsObject in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - String value to be converted (may be null)
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

public String getAsString(FacesContext context,
                          UIComponent component,
                          Object value)
Description copied from interface: Converter

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Specified by:
getAsString in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LongConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class LongConverter

java.lang.Object
    extended by  javax.faces.convert.LongConverter
All Implemented Interfaces:
Converter
public class LongConverter
extends Object
implements Converter

Converter implementation for java.lang.Long (and long primitive) values.

Field Summary
static String | CONVERTER_ID The standard converter id for this converter.
static String | LONG_ID The message identifier of the FacesMessage to be created if the conversion to Long fails.
static String | STRING_ID The message identifier of the FacesMessage to be created if the conversion of the Long value to String fails.
Constructor Summary
LongConverter()
Method Summary
Object | getAsObject(FacesContext context, UIComponent component, String value) Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
String | getAsString(FacesContext context, UIComponent component, Object value) Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONVERTER_ID

public static final String CONVERTER_ID

The standard converter id for this converter.

See Also:
Constant Field Values

LONG_ID

public static final String LONG_ID

The message identifier of the FacesMessage to be created if the conversion to Long fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

STRING_ID

public static final String STRING_ID

The message identifier of the FacesMessage to be created if the conversion of the Long value to String fails. The message format string for this message may optionally include the following placeholders:

  • {0} relaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

LongConverter

public LongConverter()
Method Detail

getAsObject

public Object getAsObject(FacesContext context,
                          UIComponent component,
                          String value)
Description copied from interface: Converter

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

Specified by:
getAsObject in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - String value to be converted (may be null)
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

public String getAsString(FacesContext context,
                          UIComponent component,
                          Object value)
Description copied from interface: Converter

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Specified by:
getAsString in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NumberConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class NumberConverter

java.lang.Object
    extended by  javax.faces.convert.NumberConverter
All Implemented Interfaces:
StateHolder, Converter
public class NumberConverter
extends Object
implements Converter, StateHolder

Converter implementation for java.lang.Number values.

The getAsObject() method parses a String into an java.lang.Double or java.lang.Long, according to the following algorithm:

  • If the specified String is null, return a null. Otherwise, trim leading and trailing whitespace before proceeding.
  • If the specified String - after trimming - has a zero length, return null.
  • If the locale property is not null, use that Locale for managing parsing. Otherwise, use the Locale from the UIViewRoot.
  • If a pattern has been specified, its syntax must conform the rules specified by java.text.DecimalFormat. Such a pattern will be used to parse, and the type property will be ignored.
  • If a pattern has not been specified, parsing will be based on the type property, which expects a currency, a number, or a percent. The parse pattern for currencies, numbers, and percentages is determined by calling the getCurrencyInstance(), getNumberInstance(), or getPercentInstance() method of the java.text.NumberFormat class, passing in the selected Locale.
  • If the integerOnly property has been set to true, only the integer portion of the String will be parsed. See the JavaDocs for the setParseIntegerOnly() method of the java.text.NumberFormat class for more information.

The getAsString() method expects a value of type java.lang.Number (or a subclass), and creates a formatted String according to the following algorithm:

  • If the specified value is null, return a zero-length String.
  • If the specified value is a String, return it unmodified.
  • If the locale property is not null, use that Locale for managing formatting. Otherwise, use the Locale from the FacesContext.
  • If a pattern has been specified, its syntax must conform the rules specified by java.text.DecimalFormat. Such a pattern will be used to format, and the type property (along with related formatting options described in the next paragraph) will be ignored.
  • If a pattern has not been specified, formatting will be based on the type property, which formats the value as a currency, a number, or a percent. The format pattern for currencies, numbers, and percentages is determined by calling the percentages is determined by calling the getCurrencyInstance(), getNumberInstance(), or getPercentInstance() method of the java.text.NumberFormat class, passing in the selected Locale. In addition, the following properties will be applied to the format pattern, if specified:
    • If the groupingUsed property is true, the setGroupingUsed(true) method on the corresponding NumberFormat instance will be called.
    • The minimum and maximum number of digits in the integer and fractional portions of the result will be configured based on any values set for the maxFractionDigits, maxIntegerDigits, minFractionDigits, and minIntegerDigits properties.
    • If the type is set to currency, it is also possible to configure the currency symbol to be used, using either the currencyCode or currencySymbol properties. If both are set, the value for currencyCode takes precedence on a JDK 1.4 (or later) JVM; otherwise, the value for currencySymbol takes precedence.

Field Summary
static String | CONVERTER_ID The standard converter id for this converter.
static String | CURRENCY_ID The message identifier of the FacesMessage to be created if the conversion to Number fails.
static String | NUMBER_ID The message identifier of the FacesMessage to be created if the conversion to Number fails.
static String | PATTERN_ID The message identifier of the FacesMessage to be created if the conversion to Number fails.
static String | PERCENT_ID The message identifier of the FacesMessage to be created if the conversion to Number fails.
static String | STRING_ID The message identifier of the FacesMessage to be created if the conversion of the Number value to String fails.
Constructor Summary
NumberConverter()
Method Summary
 Object getAsObject(FacesContext context, UIComponent component, String value)
Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
 String getAsString(FacesContext context, UIComponent component, Object value)
Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
 String getCurrencyCode()
Return the ISO 4217 currency code used by getAsString() with a type of currency.
 String getCurrencySymbol()
Return the currency symbol used by getAsString() with a type of currency.
 Locale getLocale()
Return the Locale to be used when parsing numbers.
 int getMaxFractionDigits()
Return the maximum number of digits getAsString() should render in the fraction portion of the result.
 int getMaxIntegerDigits()
Return the maximum number of digits getAsString() should render in the integer portion of the result.
 int getMinFractionDigits()
Return the minimum number of digits getAsString() should render in the fraction portion of the result.
 int getMinIntegerDigits()
Return the minimum number of digits getAsString() should render in the integer portion of the result.
 String getPattern()
Return the format pattern to be used when formatting and parsing numbers.
 String getType()
Return the number type to be used when formatting and parsing numbers.
 boolean isGroupingUsed()
Return true if getAsString should include grouping separators if necessary.
 boolean isIntegerOnly()
Return true if only the integer portion of the given value should be returned from getAsObject().
 boolean isTransient()
If true, the Object implementing this interface must not participate in state saving or restoring.
 void restoreState(FacesContext context, Object state)
Perform any processing required to restore the state from the entries in the state Object.
 Object saveState(FacesContext context)
Gets the state of the instance as a Serializable Object.
 void setCurrencyCode(String currencyCode)
Set the ISO 4217 currency code used by getAsString() with a type of currency.
 void setCurrencySymbol(String currencySymbol)
Set the currency symbol used by getAsString() with a type of currency.
 void setGroupingUsed(boolean groupingUsed)
Set the flag indicating whether getAsString() should include grouping separators if necessary.
 void setIntegerOnly(boolean integerOnly)
Set to true if only the integer portion of the given value should be returned from getAsObject().
 void setLocale(Locale locale)
Set the Locale to be used when parsing numbers.
 void setMaxFractionDigits(int maxFractionDigits)
Set the maximum number of digits getAsString() should render in the fraction portion of the result.
 void setMaxIntegerDigits(int maxIntegerDigits)
Set the maximum number of digits getAsString() should render in the integer portion of the result.
 void setMinFractionDigits(int minFractionDigits)
Set the minimum number of digits getAsString() should render in the fraction portion of the result.
 void setMinIntegerDigits(int minIntegerDigits)
Set the minimum number of digits getAsString() should render in the integer portion of the result.
 void setPattern(String pattern)
Set the format pattern to be used when formatting and parsing numbers.
 void setTransient(boolean transientFlag)
Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
 void setType(String type)
Set the number type to be used when formatting and parsing numbers.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONVERTER_ID

public static final String CONVERTER_ID

The standard converter id for this converter.

See Also:
Constant Field Values

CURRENCY_ID

public static final String CURRENCY_ID

The message identifier of the FacesMessage to be created if the conversion to Number fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

NUMBER_ID

public static final String NUMBER_ID

The message identifier of the FacesMessage to be created if the conversion to Number fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

PATTERN_ID

public static final String PATTERN_ID

The message identifier of the FacesMessage to be created if the conversion to Number fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

PERCENT_ID

public static final String PERCENT_ID

The message identifier of the FacesMessage to be created if the conversion to Number fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

STRING_ID

public static final String STRING_ID

The message identifier of the FacesMessage to be created if the conversion of the Number value to String fails. The message format string for this message may optionally include the following placeholders:

  • {0} relaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

NumberConverter

public NumberConverter()
Method Detail

getCurrencyCode

public String getCurrencyCode()

Return the ISO 4217 currency code used by getAsString() with a type of currency. If not set, the value used will be based on the formatting Locale.

setCurrencyCode

public void setCurrencyCode(String currencyCode)

Set the ISO 4217 currency code used by getAsString() with a type of currency.

Parameters:
currencyCode - The new currency code

getCurrencySymbol

public String getCurrencySymbol()

Return the currency symbol used by getAsString() with a type of currency. If not set, the value used will be based on the formatting Locale.

setCurrencySymbol

public void setCurrencySymbol(String currencySymbol)

Set the currency symbol used by getAsString() with a type of currency.

Parameters:
currencySymbol - The new currency symbol

isGroupingUsed

public boolean isGroupingUsed()

Return true if getAsString should include grouping separators if necessary. If not modified, the default value is true.

setGroupingUsed

public void setGroupingUsed(boolean groupingUsed)

Set the flag indicating whether getAsString() should include grouping separators if necessary.

Parameters:
groupingUsed - The new grouping used flag

isIntegerOnly

public boolean isIntegerOnly()

Return true if only the integer portion of the given value should be returned from getAsObject(). If not modified, the default value is false.

setIntegerOnly

public void setIntegerOnly(boolean integerOnly)

Set to true if only the integer portion of the given value should be returned from getAsObject().

Parameters:
integerOnly - The new integer-only flag

getMaxFractionDigits

public int getMaxFractionDigits()

Return the maximum number of digits getAsString() should render in the fraction portion of the result.

setMaxFractionDigits

public void setMaxFractionDigits(int maxFractionDigits)

Set the maximum number of digits getAsString() should render in the fraction portion of the result. If not set, the number of digits depends on the value being converted.

Parameters:
maxFractionDigits - The new limit

getMaxIntegerDigits

public int getMaxIntegerDigits()

Return the maximum number of digits getAsString() should render in the integer portion of the result.

setMaxIntegerDigits

public void setMaxIntegerDigits(int maxIntegerDigits)

Set the maximum number of digits getAsString() should render in the integer portion of the result. If not set, the number of digits depends on the value being converted.

Parameters:
maxIntegerDigits - The new limit

getMinFractionDigits

public int getMinFractionDigits()

Return the minimum number of digits getAsString() should render in the fraction portion of the result.

setMinFractionDigits

public void setMinFractionDigits(int minFractionDigits)

Set the minimum number of digits getAsString() should render in the fraction portion of the result. If not set, the number of digits depends on the value being converted.

Parameters:
minFractionDigits - The new limit

getMinIntegerDigits

public int getMinIntegerDigits()

Return the minimum number of digits getAsString() should render in the integer portion of the result.

setMinIntegerDigits

public void setMinIntegerDigits(int minIntegerDigits)

Set the minimum number of digits getAsString() should render in the integer portion of the result. If not set, the number of digits depends on the value being converted.

Parameters:
minIntegerDigits - The new limit

getLocale

public Locale getLocale()

Return the Locale to be used when parsing numbers. If this value is null, the Locale stored in the UIViewRoot for the current request will be utilized.

setLocale

public void setLocale(Locale locale)

Set the Locale to be used when parsing numbers. If set to null, the Locale stored in the UIViewRoot for the current request will be utilized.

Parameters:
locale - The new Locale (or null)

getPattern

public String getPattern()

Return the format pattern to be used when formatting and parsing numbers.

setPattern

public void setPattern(String pattern)

Set the format pattern to be used when formatting and parsing numbers. Valid values are those supported by java.text.DecimalFormat. An invalid value will cause a ConverterException when getAsObject() or getAsString() is called.

Parameters:
pattern - The new format pattern

getType

public String getType()

Return the number type to be used when formatting and parsing numbers. If not modified, the default type is number.

setType

public void setType(String type)

Set the number type to be used when formatting and parsing numbers. Valid values are currency, number, or percent. An invalid value will cause a ConverterException when getAsObject() or getAsString() is called.

Parameters:
type - The new number style

getAsObject

public Object getAsObject(FacesContext context,
                          UIComponent component,
                          String value)
Description copied from interface: Converter

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

Specified by:
getAsObject in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - String value to be converted (may be null)
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

public String getAsString(FacesContext context,
                          UIComponent component,
                          Object value)
Description copied from interface: Converter

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Specified by:
getAsString in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder

isTransient

public boolean isTransient()
Description copied from interface: StateHolder

If true, the Object implementing this interface must not participate in state saving or restoring.

Specified by:
isTransient in interface StateHolder

setTransient

public void setTransient(boolean transientFlag)
Description copied from interface: StateHolder

Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

Specified by:
setTransient in interface StateHolder
Parameters:
transientFlag - boolean pass true if this Object will participate in state saving or restoring, otherwise pass false.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ShortConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.convert
Class ShortConverter

java.lang.Object
    extended by  javax.faces.convert.ShortConverter
All Implemented Interfaces:
Converter
public class ShortConverter
extends Object
implements Converter

Converter implementation for java.lang.Short (and short primitive) values.

Field Summary
static String | CONVERTER_ID The standard converter id for this converter.
static String | SHORT_ID The message identifier of the FacesMessage to be created if the conversion to Short fails.
static String | STRING_ID The message identifier of the FacesMessage to be created if the conversion of the Short value to String fails.
Constructor Summary
ShortConverter()
Method Summary
Object | getAsObject(FacesContext context, UIComponent component, String value) Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.
String | getAsString(FacesContext context, UIComponent component, Object value) Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONVERTER_ID

public static final String CONVERTER_ID

The standard converter id for this converter.

See Also:
Constant Field Values

SHORT_ID

public static final String SHORT_ID

The message identifier of the FacesMessage to be created if the conversion to Short fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the unconverted value.
  • {1} replaced by an example value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

STRING_ID

public static final String STRING_ID

The message identifier of the FacesMessage to be created if the conversion of the Short value to String fails. The message format string for this message may optionally include the following placeholders:

  • {0} relaced by the unconverted value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

ShortConverter

public ShortConverter()
Method Detail

getAsObject

public Object getAsObject(FacesContext context,
                          UIComponent component,
                          String value)
Description copied from interface: Converter

Convert the specified string value, which is associated with the specified UIComponent, into a model data object that is appropriate for being stored during the Apply Request Values phase of the request processing lifecycle.

Specified by:
getAsObject in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - String value to be converted (may be null)
Returns:
null if the value to convert is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null

getAsString

public String getAsString(FacesContext context,
                          UIComponent component,
                          Object value)
Description copied from interface: Converter

Convert the specified model object value, which is associated with the specified UIComponent, into a String that is suitable for being included in the response generated during the Render Response phase of the request processing lifeycle.

Specified by:
getAsString in interface Converter
Parameters:
context - FacesContext for the request being processed
component - UIComponent with which this model object value is associated
value - Model object value to be converted (may be null)
Returns:
a zero-length String if value is null, otherwise the result of the conversion
Throws:
ConverterException - if conversion cannot be successfully performed
NullPointerException - if context or component is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


el

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.faces.el

DEPRECATED Classes and interfaces for evaluating and processing reference expressions.

See:
Description

Class Summary
MethodBinding | Deprecated. This has been replaced by MethodExpression.
PropertyResolver | Deprecated. This has been replaced by ELResolver.
ValueBinding | Deprecated. This has been replaced by ValueExpression.
VariableResolver | Deprecated. This has been replaced by ELResolver when operating with a null base argument.

Exception Summary
EvaluationException | Deprecated. This has been replaced by ELException.
MethodNotFoundException | Deprecated. This has been replaced by MethodNotFoundException.
PropertyNotFoundException | Deprecated. This has been replaced by PropertyNotFoundException.
ReferenceSyntaxException | Deprecated. This has been replaced by ELException.

Package javax.faces.el Description

DEPRECATED Classes and interfaces for evaluating and processing reference expressions. The main class in this package is ValueBinding, which is the runtime representation of a reference expression. ValueBinding provides methods to get and set the value of the expression.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.faces.el Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.faces.el

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.el.MethodBinding
    • javax.faces.el.PropertyResolver
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.el.EvaluationException
              • javax.faces.el.MethodNotFoundException
              • javax.faces.el.PropertyNotFoundException
              • javax.faces.el.ReferenceSyntaxException
    • javax.faces.el.ValueBinding
    • javax.faces.el.VariableResolver
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EvaluationException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.el
Class EvaluationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.faces.FacesException
                    extended by  javax.faces.el.EvaluationException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
MethodNotFoundException, PropertyNotFoundException, ReferenceSyntaxException
Deprecated. This has been replaced by ELException.

public class EvaluationException
extends FacesException

An exception reporting an error that occurred during the evaluation of an expression in a MethodBinding or ValueBinding.

See Also:
Serialized Form

Constructor Summary
EvaluationException()
Deprecated. Construct a new exception with no detail message or root cause.
EvaluationException(String message)
Deprecated. Construct a new exception with the specified detail message and no root cause.
EvaluationException(String message, Throwable cause)
Deprecated. Construct a new exception with the specified detail message and root cause.
EvaluationException(Throwable cause)
Deprecated. Construct a new exception with the specified root cause.
Method Summary
Methods inherited from class javax.faces.FacesException
getCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EvaluationException

public EvaluationException()
Deprecated.

Construct a new exception with no detail message or root cause.

EvaluationException

public EvaluationException(String message)
Deprecated.

Construct a new exception with the specified detail message and no root cause.

Parameters:
message - The detail message for this exception

EvaluationException

public EvaluationException(Throwable cause)
Deprecated.

Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

Parameters:
cause - The root cause for this exception

EvaluationException

public EvaluationException(String message,
                           Throwable cause)
Deprecated.

Construct a new exception with the specified detail message and root cause.

Parameters:
message - The detail message for this exception
cause - The root cause for this exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MethodBinding

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.el
Class MethodBinding

java.lang.Object
    extended by  javax.faces.el.MethodBinding
Deprecated. This has been replaced by MethodExpression.

public abstract class MethodBinding
extends Object

MethodBinding is an object that can be used to call an arbitrary public method, on an instance that is acquired by evaluatng the leading portion of a method binding expression via a ValueBinding. An immutable MethodBinding for a particular method binding expression can be acquired by calling the createMethodBinding() method of the Application instance for this web application.

Constructor Summary
MethodBinding()
Deprecated.
Method Summary
String | getExpressionString() Deprecated. Return the (possibly null) expression String, with leading and trailing delimiters, from which this MethodBinding was built.
abstract Class | getType(FacesContext context) Deprecated. Return the Java class representing the return type from the method identified by this method binding expression.
abstract Object | invoke(FacesContext context, Object[] params) Deprecated. Return the return value (if any) resulting from a call to the method identified by this method binding expression, passing it the specified parameters, relative to the specified FacesContext.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MethodBinding

public MethodBinding()
Deprecated.
Method Detail

invoke

public abstract Object invoke(FacesContext context,
                              Object[] params)
                       throws EvaluationException,
                              MethodNotFoundException
Deprecated.

Return the return value (if any) resulting from a call to the method identified by this method binding expression, passing it the specified parameters, relative to the specified FacesContext.

Parameters:
context - FacesContext for the current request
params - Array of parameters to be passed to the called method, or null for no parameters
Throws:
EvaluationException - if an exception is thrown by the called method (the thrown exception must be included as the cause property of this exception)
MethodNotFoundException - if no suitable method can be found
NullPointerException - if context is null

getType

public abstract Class getType(FacesContext context)
                       throws MethodNotFoundException
Deprecated.

Return the Java class representing the return type from the method identified by this method binding expression.

Parameters:
context - FacesContext for the current request
Throws:
MethodNotFoundException - if no suitable method can be found
NullPointerException - if context is null

getExpressionString

public String getExpressionString()
Deprecated.

Return the (possibly null) expression String, with leading and trailing delimiters, from which this MethodBinding was built. The default implementation returns null.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MethodNotFoundException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.el
Class MethodNotFoundException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.faces.FacesException
                    extended by  javax.faces.el.EvaluationException
                        extended by  javax.faces.el.MethodNotFoundException
All Implemented Interfaces:
Serializable
Deprecated. This has been replaced by MethodNotFoundException.

public class MethodNotFoundException
extends EvaluationException

An exception caused by a method name that cannot be resolved against a base object.

See Also:
Serialized Form

Constructor Summary
MethodNotFoundException()
Deprecated. Construct a new exception with no detail message or root cause.
MethodNotFoundException(String message)
Deprecated. Construct a new exception with the specified detail message and no root cause.
MethodNotFoundException(String message, Throwable cause)
Deprecated. Construct a new exception with the specified detail message and root cause.
MethodNotFoundException(Throwable cause)
Deprecated. Construct a new exception with the specified root cause.
Method Summary
Methods inherited from class javax.faces.FacesException
getCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MethodNotFoundException

public MethodNotFoundException()
Deprecated.

Construct a new exception with no detail message or root cause.

MethodNotFoundException

public MethodNotFoundException(String message)
Deprecated.

Construct a new exception with the specified detail message and no root cause.

Parameters:
message - The detail message for this exception

MethodNotFoundException

public MethodNotFoundException(Throwable cause)
Deprecated.

Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

Parameters:
cause - The root cause for this exception

MethodNotFoundException

public MethodNotFoundException(String message,
                               Throwable cause)
Deprecated.

Construct a new exception with the specified detail message and root cause.

Parameters:
message - The detail message for this exception
cause - The root cause for this exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PropertyNotFoundException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.el
Class PropertyNotFoundException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.faces.FacesException
                    extended by  javax.faces.el.EvaluationException
                        extended by  javax.faces.el.PropertyNotFoundException
All Implemented Interfaces:
Serializable
Deprecated. This has been replaced by PropertyNotFoundException.

public class PropertyNotFoundException
extends EvaluationException

An exception caused by a property name that cannot be resolved against a base object.

See Also:
Serialized Form

Constructor Summary
PropertyNotFoundException()
Deprecated. Construct a new exception with no detail message or root cause.
PropertyNotFoundException(String message)
Deprecated. Construct a new exception with the specified detail message and no root cause.
PropertyNotFoundException(String message, Throwable cause)
Deprecated. Construct a new exception with the specified detail message and root cause.
PropertyNotFoundException(Throwable cause)
Deprecated. Construct a new exception with the specified root cause.
Method Summary
Methods inherited from class javax.faces.FacesException
getCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PropertyNotFoundException

public PropertyNotFoundException()
Deprecated.

Construct a new exception with no detail message or root cause.

PropertyNotFoundException

public PropertyNotFoundException(String message)
Deprecated.

Construct a new exception with the specified detail message and no root cause.

Parameters:
message - The detail message for this exception

PropertyNotFoundException

public PropertyNotFoundException(Throwable cause)
Deprecated.

Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

Parameters:
cause - The root cause for this exception

PropertyNotFoundException

public PropertyNotFoundException(String message,
                                 Throwable cause)
Deprecated.

Construct a new exception with the specified detail message and root cause.

Parameters:
message - The detail message for this exception
cause - The root cause for this exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PropertyResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.el
Class PropertyResolver

java.lang.Object
    extended by  javax.faces.el.PropertyResolver
Deprecated. This has been replaced by ELResolver.

public abstract class PropertyResolver
extends Object

PropertyResolver represents a pluggable mechanism for accessing a "property" of an underlying Java object instance. Different PropertyResolver implementations can support property resolution on instances of different Java classes (such as introspection-based access to properties of a JavaBeans component, or get() and put() calls on a java.util.Map instance).

All implementations must respect the rules for JavaBeans component, java.util.Map, java.util.List and array instances defined for each method but are allowed to add custom semantics for other types.

Constructor Summary
PropertyResolver()
Deprecated.
Method Summary
abstract Class | getType(Object base, int index) Deprecated. Return the java.lang.Class representing the type of the specified index.
abstract Class | getType(Object base, Object property) Deprecated. Return the java.lang.Class representing the type of the specified property.
abstract Object | getValue(Object base, int index) Deprecated. Return the value at the specified index of the specified base object.
abstract Object | getValue(Object base, Object property) Deprecated. Return the value of the specified property from the specified base object.
abstract boolean | isReadOnly(Object base, int index) Deprecated. Checks if the specified index is read-only.
abstract boolean | isReadOnly(Object base, Object property) Deprecated. Checks if the specified property is read-only.
abstract void | setValue(Object base, int index, Object value) Deprecated. Set the value at the specified index of the specified base object.
abstract void | setValue(Object base, Object property, Object value) Deprecated. Set the specified value of the specified property on the specified base object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PropertyResolver

public PropertyResolver()
Deprecated.
Method Detail

getValue

public abstract Object getValue(Object base,
                                Object property)
                         throws EvaluationException,
                                PropertyNotFoundException
Deprecated.

Return the value of the specified property from the specified base object.

For a bean base object, the property is coerced to a String and used as the property name. For all other base object types (e.g., a Map), the property is used without any coercing.

Parameters:
base - The base object whose property value is to be returned
property - The property to be returned
Returns:
The property value, or null if base or property is null, or if the property doesn't exist and the base object is a Map instance
Throws:
EvaluationException - if an exception is thrown while getting the property value (the thrown exception must be included as the cause property of this exception)
PropertyNotFoundException - if the specified property for a bean base object does not exist or is not readable

getValue

public abstract Object getValue(Object base,
                                int index)
                         throws EvaluationException,
                                PropertyNotFoundException
Deprecated.

Return the value at the specified index of the specified base object.

Parameters:
base - The base object whose property value is to be returned
index - The index of the value to return
Returns:
The property value, or null if base is null, or if the index is out of bounds for the base object
Throws:
EvaluationException - if an exception is thrown while getting the property value (the thrown exception must be included as the cause property of this exception)
PropertyNotFoundException - if the index is out of bounds or if base is null

setValue

public abstract void setValue(Object base,
                              Object property,
                              Object value)
                       throws EvaluationException,
                              PropertyNotFoundException
Deprecated.

Set the specified value of the specified property on the specified base object.

For a bean base object, the property is coerced to a String and used as the property name. For all other base object types (e.g., a Map), the property is used without any coercing.

Parameters:
base - The base object whose property value is to be set
property - The property to be set
value - The value of the property to be set
Throws:
EvaluationException - if an exception is thrown while setting the property value (the thrown exception must be included as the cause property of this exception)
PropertyNotFoundException - if the specified bean base object property does not exist or is not writeable, or if base or name is null

setValue

public abstract void setValue(Object base,
                              int index,
                              Object value)
                       throws EvaluationException,
                              PropertyNotFoundException
Deprecated.

Set the value at the specified index of the specified base object.

Parameters:
base - The base object whose property value is to be set
index - The index of the value to set
value - The value to be set
Throws:
EvaluationException - if an exception is thrown while setting the property value (the thrown exception must be included as the cause property of this exception)
PropertyNotFoundException - if the index is out of bounds or if base is null

isReadOnly

public abstract boolean isReadOnly(Object base,
                                   Object property)
                            throws EvaluationException,
                                   PropertyNotFoundException
Deprecated.

Checks if the specified property is read-only.

For a bean base object, the property is coerced to a String and used as the property name. For all other base object types (e.g., a Map), the property is used without any coercing.

Parameters:
base - The base object whose property is to be analyzed
property - The property to be analyzed
Returns:
true if the specified property of the specified base object is known to be immutable; otherwise false
Throws:
EvaluationException - if an exception is thrown while testing the property (the thrown exception must be included as the cause property of this exception)
PropertyNotFoundException - if the specified bean base object property does not exist or if base or property is null

isReadOnly

public abstract boolean isReadOnly(Object base,
                                   int index)
                            throws EvaluationException,
                                   PropertyNotFoundException
Deprecated.

Checks if the specified index is read-only.

Parameters:
base - The base object whose property is to be analyzed
index - The index of the value whose type is to be returned
Returns:
true if the value at the specified index of the specified base object is known to be immutable; otherwise, false
Throws:
EvaluationException - if an exception is thrown while testing the property (the thrown exception must be included as the cause property of this exception)
PropertyNotFoundException - if the index is out of bounds or if base is null

getType

public abstract Class getType(Object base,
                              Object property)
                       throws EvaluationException,
                              PropertyNotFoundException
Deprecated.

Return the java.lang.Class representing the type of the specified property. An instance of any Object of that type my be set as the value of that property, as long as the property is not read-only. The actual value of the property, if non-null, is guaranteed to be an instance of this type, or an instance of a subclass of this type. This method is also useful for discovering the type of Objects that may be set as the value of the property.

For a bean base object, the property is coerced to a String and used as the property name. For all other base object types (e.g., a Map), the property is used without any coercing.

Parameters:
base - The base object whose property is to be analyzed
property - The property to be analyzed
Returns:
the java.lang.Class representing the type of the specified property of the specified base object, if it can be determined; otherwise null
Throws:
EvaluationException - if an exception is thrown while testing the property (the thrown exception must be included as the cause property of this exception)
PropertyNotFoundException - if the specified bean base object property does not exist or if base or property is null

getType

public abstract Class getType(Object base,
                              int index)
                       throws EvaluationException,
                              PropertyNotFoundException
Deprecated.

Return the java.lang.Class representing the type of the specified index.

Parameters:
base - The base object whose property is to be analyzed
index - The index of the value whose type is to be returned
Returns:
The java.lang.Class representing the type of value at the specified index of the specified base object, if it can be determined; otherwise null
Throws:
EvaluationException - if an exception is thrown while testing the property (the thrown exception must be included as the cause property of this exception)
PropertyNotFoundException - if the index is out of bounds or if base is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ReferenceSyntaxException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.el
Class ReferenceSyntaxException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.faces.FacesException
                    extended by  javax.faces.el.EvaluationException
                        extended by  javax.faces.el.ReferenceSyntaxException
All Implemented Interfaces:
Serializable
Deprecated. This has been replaced by ELException.

public class ReferenceSyntaxException
extends EvaluationException

An exception reporting a syntax error in a method binding expression or value binding expression.

See Also:
Serialized Form

Constructor Summary
ReferenceSyntaxException()
Deprecated. Construct a new exception with no detail message or root cause.
ReferenceSyntaxException(String message)
Deprecated. Construct a new exception with the specified detail message and no root cause.
ReferenceSyntaxException(String message, Throwable cause)
Deprecated. Construct a new exception with the specified detail message and root cause.
ReferenceSyntaxException(Throwable cause)
Deprecated. Construct a new exception with the specified root cause.
Method Summary
Methods inherited from class javax.faces.FacesException
getCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ReferenceSyntaxException

public ReferenceSyntaxException()
Deprecated.

Construct a new exception with no detail message or root cause.

ReferenceSyntaxException

public ReferenceSyntaxException(String message)
Deprecated.

Construct a new exception with the specified detail message and no root cause.

Parameters:
message - The detail message for this exception

ReferenceSyntaxException

public ReferenceSyntaxException(Throwable cause)
Deprecated.

Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

Parameters:
cause - The root cause for this exception

ReferenceSyntaxException

public ReferenceSyntaxException(String message,
                                Throwable cause)
Deprecated.

Construct a new exception with the specified detail message and root cause.

Parameters:
message - The detail message for this exception
cause - The root cause for this exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValueBinding

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.el
Class ValueBinding

java.lang.Object
    extended by  javax.faces.el.ValueBinding
Deprecated. This has been replaced by ValueExpression.

public abstract class ValueBinding
extends Object

ValueBinding is an object that can be used to access the property represented by an action or value binding expression. An immutable ValueBinding for a particular value binding can be acquired by calling the createValueBinding() method of the Application instance for this web application.

Constructor Summary
ValueBinding()
Deprecated.
Method Summary
String | getExpressionString() Deprecated. Return the (possibly null) expression String, including the delimiters, from which this ValueBinding was built.
abstract Class | getType(FacesContext context) Deprecated. Return the type of the property represented by this ValueBinding, relative to the specified FacesContext.
abstract Object | getValue(FacesContext context) Deprecated. Return the value of the property represented by this ValueBinding, relative to the specified FacesContext.
abstract boolean | isReadOnly(FacesContext context) Deprecated. Return true if the specified property of the specified property is known to be immutable; otherwise, return false.
abstract void | setValue(FacesContext context, Object value) Deprecated. Set the value of the property represented by this ValueBinding, relative to the specified FacesContext.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValueBinding

public ValueBinding()
Deprecated.
Method Detail

getValue

public abstract Object getValue(FacesContext context)
                         throws EvaluationException,
                                PropertyNotFoundException
Deprecated.

Return the value of the property represented by this ValueBinding, relative to the specified FacesContext.

Parameters:
context - FacesContext for the current request
Throws:
EvaluationException - if an exception is thrown while getting the value (the thrown exception must be included as the cause property of this exception)
NullPointerException - if context is null
PropertyNotFoundException - if a specified property name does not exist, or is not readable

setValue

public abstract void setValue(FacesContext context,
                              Object value)
                       throws EvaluationException,
                              PropertyNotFoundException
Deprecated.

Set the value of the property represented by this ValueBinding, relative to the specified FacesContext.

Parameters:
context - FacesContext for the current request
value - The new value to be set
Throws:
EvaluationException - if an exception is thrown while setting the value (the thrown exception must be included as the cause property of this exception)
NullPointerException - if context is null
PropertyNotFoundException - if a specified property name does not exist, or is not writeable

isReadOnly

public abstract boolean isReadOnly(FacesContext context)
                            throws EvaluationException,
                                   PropertyNotFoundException
Deprecated.

Return true if the specified property of the specified property is known to be immutable; otherwise, return false.

Parameters:
context - FacesContext for the current request
Throws:
EvaluationException - if an exception is thrown while getting the description of the property (the thrown exception must be included as the cause property of this exception)
NullPointerException - if context is null
PropertyNotFoundException - if a specified property name does not exist

getType

public abstract Class getType(FacesContext context)
                       throws EvaluationException,
                              PropertyNotFoundException
Deprecated.

Return the type of the property represented by this ValueBinding, relative to the specified FacesContext.

Parameters:
context - FacesContext for the current request
Throws:
EvaluationException - if an exception is thrown while getting the description of the property (the thrown exception must be included as the cause property of this exception)
NullPointerException - if context is null
PropertyNotFoundException - if a specified property name does not exist

getExpressionString

public String getExpressionString()
Deprecated.

Return the (possibly null) expression String, including the delimiters, from which this ValueBinding was built.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


VariableResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.el
Class VariableResolver

java.lang.Object
    extended by  javax.faces.el.VariableResolver
Deprecated. This has been replaced by ELResolver when operating with a null base argument.

public abstract class VariableResolver
extends Object

VariableResolver represents a pluggable mechanism for resolving a top-level variable reference at evaluation time.

Constructor Summary
VariableResolver()
Deprecated.
Method Summary
abstract  Object resolveVariable(FacesContext context, String name)
Deprecated. Resolve the specified variable name, and return the corresponding object, if any; otherwise, return null.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VariableResolver

public VariableResolver()
Deprecated.
Method Detail

resolveVariable

public abstract Object resolveVariable(FacesContext context,
                                       String name)
                                throws EvaluationException
Deprecated.

Resolve the specified variable name, and return the corresponding object, if any; otherwise, return null.

Parameters:
context - FacesContext against which to resolve this variable name
name - Name of the variable to be resolved
Throws:
EvaluationException - if an exception is thrown while resolving the variable name (the thrown exception must be included as the cause property of this exception)
NullPointerException - if context or name is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


event

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.faces.event

Interfaces describing events and event listeners, and concrete event implementation classes.

See:
Description

Interface Summary
ActionListener | A listener interface for receiving ActionEvents.
FacesListener | A generic base interface for event listeners for various types of FacesEvents.
PhaseListener | An interface implemented by objects that wish to be notified at the beginning and ending of processing for each standard phase of the request processing lifecycle.
ValueChangeListener | A listener interface for receiving ValueChangeEvents.

Class Summary
ActionEvent | An ActionEvent represents the activation of a user interface component (such as a UICommand).
FacesEvent | FacesEvent is the base class for user interface and application events that can be fired by UIComponents.
MethodExpressionActionListener | MethodExpressionActionListener is an ActionListener that wraps a MethodExpression.
MethodExpressionValueChangeListener | MethodExpressionValueChangeListener is a ValueChangeListener that wraps a MethodExpression.
PhaseEvent | PhaseEvent represents the beginning or ending of processing for a particular phase of the request processing lifecycle, for the request encapsulated by the specified FacesContext.
PhaseId | Typesafe enumeration of the legal values that may be returned by the getPhaseId() method of the FacesEvent interface.
ValueChangeEvent | A ValueChangeEvent is a notification that the local value of the source component has been change as a result of user interface activity.

Exception Summary
AbortProcessingException An exception that may be thrown by event listeners to terminate the processing of the current event.

Package javax.faces.event Description

Interfaces describing events and event listeners, and concrete event implementation classes. All events extend from FacesEvent and all listeners extend from FacesListener.

For your convenience here is a UML class diagram of the classes in this package.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FacesListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.event
Interface FacesListener

All Superinterfaces:
EventListener
All Known Subinterfaces:
ActionListener, ValueChangeListener
All Known Implementing Classes:
MethodExpressionActionListener, MethodExpressionValueChangeListener
public interface FacesListener
extends EventListener

A generic base interface for event listeners for various types of FacesEvents. All listener interfaces for specific FacesEvent event types must extend this interface.

Implementations of this interface must have a zero-args public constructor. If the class that implements this interface has state that needs to be saved and restored between requests, the class must also implement StateHolder.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.faces.event Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.faces.event

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.faces.event.FacesEvent
        • javax.faces.event.ActionEvent
        • javax.faces.event.ValueChangeEvent
      • javax.faces.event.PhaseEvent
    • javax.faces.event.MethodExpressionActionListener (implements javax.faces.event.ActionListener, javax.faces.component.StateHolder)
    • javax.faces.event.MethodExpressionValueChangeListener (implements javax.faces.component.StateHolder, javax.faces.event.ValueChangeListener)
    • javax.faces.event.PhaseId (implements java.lang.Comparable<T>)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.event.AbortProcessingException

Interface Hierarchy

  • java.util.EventListener
    • javax.faces.event.FacesListener
      • javax.faces.event.ActionListener
      • javax.faces.event.ValueChangeListener
    • javax.faces.event.PhaseListener (also extends java.io.Serializable)
  • java.io.Serializable
    • javax.faces.event.PhaseListener (also extends java.util.EventListener)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AbortProcessingException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.event
Class AbortProcessingException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.faces.FacesException
                    extended by  javax.faces.event.AbortProcessingException
All Implemented Interfaces:
Serializable
public class AbortProcessingException
extends FacesException

An exception that may be thrown by event listeners to terminate the processing of the current event.

See Also:
Serialized Form

Constructor Summary
AbortProcessingException()
Construct a new exception with no detail message or root cause.
AbortProcessingException(String message)
Construct a new exception with the specified detail message and no root cause.
AbortProcessingException(String message, Throwable cause)
Construct a new exception with the specified detail message and root cause.
AbortProcessingException(Throwable cause)
Construct a new exception with the specified root cause.
Method Summary
Methods inherited from class javax.faces.FacesException
getCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AbortProcessingException

public AbortProcessingException()

Construct a new exception with no detail message or root cause.

AbortProcessingException

public AbortProcessingException(String message)

Construct a new exception with the specified detail message and no root cause.

Parameters:
message - The detail message for this exception

AbortProcessingException

public AbortProcessingException(Throwable cause)

Construct a new exception with the specified root cause.

Parameters:
cause - The root cause for this exception

AbortProcessingException

public AbortProcessingException(String message,
                                Throwable cause)

Construct a new exception with the specified detail message and root cause.

Parameters:
message - The detail message for this exception
cause - The root cause for this exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ActionEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.event
Class ActionEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.faces.event.FacesEvent
            extended by  javax.faces.event.ActionEvent
All Implemented Interfaces:
Serializable
public class ActionEvent
extends FacesEvent

An ActionEvent represents the activation of a user interface component (such as a UICommand).

See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
ActionEvent(UIComponent component)
Construct a new event object from the specified source component and action command.
Method Summary
boolean | isAppropriateListener(FacesListener listener) Return true if this FacesListener is an instance of a listener class that this event supports.
void | processListener(FacesListener listener) Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate.
Methods inherited from class javax.faces.event.FacesEvent
getComponent, getPhaseId, queue, setPhaseId
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ActionEvent

public ActionEvent(UIComponent component)

Construct a new event object from the specified source component and action command.

Parameters:
component - Source UIComponent for this event
Throws:
IllegalArgumentException - if component is null
Method Detail

isAppropriateListener

public boolean isAppropriateListener(FacesListener listener)
Description copied from class: FacesEvent

Return true if this FacesListener is an instance of a listener class that this event supports. Typically, this will be accomplished by an "instanceof" check on the listener class.

Specified by:
isAppropriateListener in class FacesEvent
Parameters:
listener - FacesListener to evaluate

processListener

public void processListener(FacesListener listener)
Description copied from class: FacesEvent

Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate. Typically, this will be accomplished by calling an event processing method, and passing this FacesEvent as a paramter.

Specified by:
processListener in class FacesEvent
Parameters:
listener - FacesListener to send this FacesEvent to
Throws:
AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ActionListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.event
Interface ActionListener

All Superinterfaces:
EventListener, FacesListener
All Known Implementing Classes:
MethodExpressionActionListener
public interface ActionListener
extends FacesListener

A listener interface for receiving ActionEvents. A class that is interested in receiving such events implements this interface, and then registers itself with the source UIComponent of interest, by calling addActionListener().

Method Summary
 void processAction(ActionEvent event)
Invoked when the action described by the specified ActionEvent occurs.

Method Detail

processAction

void processAction(ActionEvent event)
                   throws AbortProcessingException

Invoked when the action described by the specified ActionEvent occurs.

Parameters:
event - The ActionEvent that has occurred
Throws:
AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FacesEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.event
Class FacesEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.faces.event.FacesEvent
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ActionEvent, ValueChangeEvent
public abstract class FacesEvent
extends EventObject

FacesEvent is the base class for user interface and application events that can be fired by UIComponents. Concrete event classes must subclass FacesEvent in order to be supported by the request processing lifecycle.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
FacesEvent(UIComponent component)
Construct a new event object from the specified source component.
Method Summary
UIComponent | getComponent() Return the source UIComponent that sent this event.
PhaseId | getPhaseId() Return the identifier of the request processing phase during which this event should be delivered.
abstract boolean | isAppropriateListener(FacesListener listener) Return true if this FacesListener is an instance of a listener class that this event supports.
abstract void | processListener(FacesListener listener) Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate.
void | queue() Convenience method to queue this event for broadcast at the end of the current request processing lifecycle phase.
void | setPhaseId(PhaseId phaseId) Set the PhaseId during which this event will be delivered.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FacesEvent

public FacesEvent(UIComponent component)

Construct a new event object from the specified source component.

Parameters:
component - Source UIComponent for this event
Throws:
IllegalArgumentException - if component is null
Method Detail

getComponent

public UIComponent getComponent()

Return the source UIComponent that sent this event.

getPhaseId

public PhaseId getPhaseId()

Return the identifier of the request processing phase during which this event should be delivered. Legal values are the singleton instances defined by the PhaseId class, including PhaseId.ANY_PHASE, which is the default value.

setPhaseId

public void setPhaseId(PhaseId phaseId)

Set the PhaseId during which this event will be delivered.

Throws:
IllegalArgumentException - phaseId is null.

queue

public void queue()

Convenience method to queue this event for broadcast at the end of the current request processing lifecycle phase.

Throws:
IllegalStateException - if the source component for this event is not a descendant of a UIViewRoot

isAppropriateListener

public abstract boolean isAppropriateListener(FacesListener listener)

Return true if this FacesListener is an instance of a listener class that this event supports. Typically, this will be accomplished by an "instanceof" check on the listener class.

Parameters:
listener - FacesListener to evaluate

processListener

public abstract void processListener(FacesListener listener)

Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate. Typically, this will be accomplished by calling an event processing method, and passing this FacesEvent as a paramter.

Parameters:
listener - FacesListener to send this FacesEvent to
Throws:
AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MethodExpressionActionListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.event
Class MethodExpressionActionListener

java.lang.Object
    extended by  javax.faces.event.MethodExpressionActionListener
All Implemented Interfaces:
EventListener, StateHolder, ActionListener, FacesListener
public class MethodExpressionActionListener
extends Object
implements ActionListener, StateHolder

MethodExpressionActionListener is an ActionListener that wraps a MethodExpression. When it receives a ActionEvent, it executes a method on an object identified by the MethodExpression.

Constructor Summary
MethodExpressionActionListener()
MethodExpressionActionListener(MethodExpression methodExpression)
Construct a ValueChangeListener that contains a MethodExpression.
Method Summary
boolean | isTransient() If true, the Object implementing this interface must not participate in state saving or restoring.
void | processAction(ActionEvent actionEvent) Invoked when the action described by the specified ActionEvent occurs.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setTransient(boolean newTransientValue) Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MethodExpressionActionListener

public MethodExpressionActionListener()

MethodExpressionActionListener

public MethodExpressionActionListener(MethodExpression methodExpression)

Construct a ValueChangeListener that contains a MethodExpression.

Method Detail

processAction

public void processAction(ActionEvent actionEvent)
                   throws AbortProcessingException
Description copied from interface: ActionListener

Invoked when the action described by the specified ActionEvent occurs.

Specified by:
processAction in interface ActionListener
Parameters:
actionEvent - The ActionEvent that has occurred
Throws:
NullPointerException
AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder

isTransient

public boolean isTransient()
Description copied from interface: StateHolder

If true, the Object implementing this interface must not participate in state saving or restoring.

Specified by:
isTransient in interface StateHolder

setTransient

public void setTransient(boolean newTransientValue)
Description copied from interface: StateHolder

Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

Specified by:
setTransient in interface StateHolder
Parameters:
newTransientValue - boolean pass true if this Object will participate in state saving or restoring, otherwise pass false.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MethodExpressionValueChangeListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.event
Class MethodExpressionValueChangeListener

java.lang.Object
    extended by  javax.faces.event.MethodExpressionValueChangeListener
All Implemented Interfaces:
EventListener, StateHolder, FacesListener, ValueChangeListener
public class MethodExpressionValueChangeListener
extends Object
implements ValueChangeListener, StateHolder

MethodExpressionValueChangeListener is a ValueChangeListener that wraps a MethodExpression. When it receives a ValueChangeEvent, it executes a method on an object identified by the MethodExpression.

Constructor Summary
MethodExpressionValueChangeListener()
MethodExpressionValueChangeListener(MethodExpression methodExpression)
Construct a ValueChangeListener that contains a MethodExpression.
Method Summary
boolean | isTransient() If true, the Object implementing this interface must not participate in state saving or restoring.
void | processValueChange(ValueChangeEvent valueChangeEvent) Invoked when the value change described by the specified ValueChangeEvent occurs.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setTransient(boolean newTransientValue) Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MethodExpressionValueChangeListener

public MethodExpressionValueChangeListener()

MethodExpressionValueChangeListener

public MethodExpressionValueChangeListener(MethodExpression methodExpression)

Construct a ValueChangeListener that contains a MethodExpression.

Method Detail

processValueChange

public void processValueChange(ValueChangeEvent valueChangeEvent)
                        throws AbortProcessingException
Description copied from interface: ValueChangeListener

Invoked when the value change described by the specified ValueChangeEvent occurs.

Specified by:
processValueChange in interface ValueChangeListener
Parameters:
valueChangeEvent - The ValueChangeEvent that has occurred
Throws:
NullPointerException
AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder

isTransient

public boolean isTransient()
Description copied from interface: StateHolder

If true, the Object implementing this interface must not participate in state saving or restoring.

Specified by:
isTransient in interface StateHolder

setTransient

public void setTransient(boolean newTransientValue)
Description copied from interface: StateHolder

Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

Specified by:
setTransient in interface StateHolder
Parameters:
newTransientValue - boolean pass true if this Object will participate in state saving or restoring, otherwise pass false.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PhaseEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.event
Class PhaseEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.faces.event.PhaseEvent
All Implemented Interfaces:
Serializable
public class PhaseEvent
extends EventObject

PhaseEvent represents the beginning or ending of processing for a particular phase of the request processing lifecycle, for the request encapsulated by the specified FacesContext.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
PhaseEvent(FacesContext context, PhaseId phaseId, Lifecycle lifecycle)
Construct a new event object from the specified parameters.
Method Summary
FacesContext | getFacesContext() Return the FacesContext for the request being processed.
PhaseId | getPhaseId() Return the PhaseId representing the current request processing lifecycle phase.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PhaseEvent

public PhaseEvent(FacesContext context,
                  PhaseId phaseId,
                  Lifecycle lifecycle)

Construct a new event object from the specified parameters. The specified Lifecycle will be the source of this event.

Parameters:
context - FacesContext for the current request
phaseId - Identifier of the current request processing lifecycle phase
lifecycle - Lifecycle instance
Throws:
NullPointerException - if context or phaseId or Lifecycleis null
Method Detail

getFacesContext

public FacesContext getFacesContext()

Return the FacesContext for the request being processed.

getPhaseId

public PhaseId getPhaseId()

Return the PhaseId representing the current request processing lifecycle phase.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PhaseId

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.event
Class PhaseId

java.lang.Object
    extended by  javax.faces.event.PhaseId
All Implemented Interfaces:
Comparable
public class PhaseId
extends Object
implements Comparable

Typesafe enumeration of the legal values that may be returned by the getPhaseId() method of the FacesEvent interface.

Field Summary
static PhaseId | ANY_PHASE Identifier that indicates an interest in events, no matter which request processing phase is being performed.
static PhaseId | APPLY_REQUEST_VALUES Identifier that indicates an interest in events queued for the Apply Request Values phase of the request processing lifecycle.
static PhaseId | INVOKE_APPLICATION Identifier that indicates an interest in events queued for the Invoke Application phase of the request processing lifecycle.
static PhaseId | PROCESS_VALIDATIONS Identifier that indicates an interest in events queued for the Process Validations phase of the request processing lifecycle.
static PhaseId | RENDER_RESPONSE Identifier for the Render Response phase of the request processing lifecycle.
static PhaseId | RESTORE_VIEW Identifier that indicates an interest in events queued for the Restore View phase of the request processing lifecycle.
static PhaseId | UPDATE_MODEL_VALUES Identifier that indicates an interest in events queued for the Update Model Values phase of the request processing lifecycle.
static List | VALUES List of valid PhaseId instances, in ascending order of their ordinal value.
Method Summary
int | compareTo(Object other) Compare this PhaseId instance to the specified one.
int | getOrdinal() Return the ordinal value of this PhaseId instance.
String | toString() Return a String representation of this PhaseId instance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ANY_PHASE

public static final PhaseId ANY_PHASE

Identifier that indicates an interest in events, no matter which request processing phase is being performed.

RESTORE_VIEW

public static final PhaseId RESTORE_VIEW

Identifier that indicates an interest in events queued for the Restore View phase of the request processing lifecycle.

APPLY_REQUEST_VALUES

public static final PhaseId APPLY_REQUEST_VALUES

Identifier that indicates an interest in events queued for the Apply Request Values phase of the request processing lifecycle.

PROCESS_VALIDATIONS

public static final PhaseId PROCESS_VALIDATIONS

Identifier that indicates an interest in events queued for the Process Validations phase of the request processing lifecycle.

UPDATE_MODEL_VALUES

public static final PhaseId UPDATE_MODEL_VALUES

Identifier that indicates an interest in events queued for the Update Model Values phase of the request processing lifecycle.

INVOKE_APPLICATION

public static final PhaseId INVOKE_APPLICATION

Identifier that indicates an interest in events queued for the Invoke Application phase of the request processing lifecycle.

RENDER_RESPONSE

public static final PhaseId RENDER_RESPONSE

Identifier for the Render Response phase of the request processing lifecycle.

VALUES

public static final List VALUES

List of valid PhaseId instances, in ascending order of their ordinal value.

Method Detail

compareTo

public int compareTo(Object other)

Compare this PhaseId instance to the specified one. Returns a negative integer, zero, or a positive integer if this object is less than, equal to, or greater than the specified object.

Specified by:
compareTo in interface Comparable
Parameters:
other - The other object to be compared to

getOrdinal

public int getOrdinal()

Return the ordinal value of this PhaseId instance.

toString

public String toString()

Return a String representation of this PhaseId instance.

Overrides:
toString in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PhaseListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.event
Interface PhaseListener

All Superinterfaces:
EventListener, Serializable
public interface PhaseListener
extends EventListener, Serializable

An interface implemented by objects that wish to be notified at the beginning and ending of processing for each standard phase of the request processing lifecycle.

Method Summary
void | afterPhase(PhaseEvent event) Handle a notification that the processing for a particular phase has just been completed.
void | beforePhase(PhaseEvent event) Handle a notification that the processing for a particular phase of the request processing lifecycle is about to begin.
PhaseId | getPhaseId() Return the identifier of the request processing phase during which this listener is interested in processing PhaseEvent events.

Method Detail

afterPhase

void afterPhase(PhaseEvent event)

Handle a notification that the processing for a particular phase has just been completed.

beforePhase

void beforePhase(PhaseEvent event)

Handle a notification that the processing for a particular phase of the request processing lifecycle is about to begin.

getPhaseId

PhaseId getPhaseId()

Return the identifier of the request processing phase during which this listener is interested in processing PhaseEvent events. Legal values are the singleton instances defined by the PhaseId class, including PhaseId.ANY_PHASE to indicate an interest in being notified for all standard phases.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValueChangeEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.event
Class ValueChangeEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.faces.event.FacesEvent
            extended by  javax.faces.event.ValueChangeEvent
All Implemented Interfaces:
Serializable
public class ValueChangeEvent
extends FacesEvent

A ValueChangeEvent is a notification that the local value of the source component has been change as a result of user interface activity. It is not fired unless validation of the new value was completed successfully.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
ValueChangeEvent(UIComponent component, Object oldValue, Object newValue)
Construct a new event object from the specified source component, old value, and new value.
Method Summary
Object | getNewValue() Return the current local value of the source UIComponent.
Object | getOldValue() Return the previous local value of the source UIComponent.
boolean | isAppropriateListener(FacesListener listener) Return true if this FacesListener is an instance of a listener class that this event supports.
void | processListener(FacesListener listener) Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate.
Methods inherited from class javax.faces.event.FacesEvent
getComponent, getPhaseId, queue, setPhaseId
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ValueChangeEvent

public ValueChangeEvent(UIComponent component,
                        Object oldValue,
                        Object newValue)

Construct a new event object from the specified source component, old value, and new value.

The default PhaseId for this event is PhaseId.ANY_PHASE.

Parameters:
component - Source UIComponent for this event
oldValue - The previous local value of this UIComponent
newValue - The new local value of thie UIComponent
Throws:
IllegalArgumentException - if component is null
Method Detail

getOldValue

public Object getOldValue()

Return the previous local value of the source UIComponent.

getNewValue

public Object getNewValue()

Return the current local value of the source UIComponent.

isAppropriateListener

public boolean isAppropriateListener(FacesListener listener)
Description copied from class: FacesEvent

Return true if this FacesListener is an instance of a listener class that this event supports. Typically, this will be accomplished by an "instanceof" check on the listener class.

Specified by:
isAppropriateListener in class FacesEvent
Parameters:
listener - FacesListener to evaluate

processListener

public void processListener(FacesListener listener)
Description copied from class: FacesEvent

Broadcast this FacesEvent to the specified FacesListener, by whatever mechanism is appropriate. Typically, this will be accomplished by calling an event processing method, and passing this FacesEvent as a paramter.

Specified by:
processListener in class FacesEvent
Parameters:
listener - FacesListener to send this FacesEvent to
Throws:
AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValueChangeListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.event
Interface ValueChangeListener

All Superinterfaces:
EventListener, FacesListener
All Known Implementing Classes:
MethodExpressionValueChangeListener
public interface ValueChangeListener
extends FacesListener

A listener interface for receiving ValueChangeEvents. A class that is interested in receiving such events implements this interface, and then registers itself with the source UIComponent of interest, by calling addValueChangeListener().

Method Summary
 void processValueChange(ValueChangeEvent event)
Invoked when the value change described by the specified ValueChangeEvent occurs.

Method Detail

processValueChange

void processValueChange(ValueChangeEvent event)
                        throws AbortProcessingException

Invoked when the value change described by the specified ValueChangeEvent occurs.

Parameters:
event - The ValueChangeEvent that has occurred
Throws:
AbortProcessingException - Signal the JavaServer Faces implementation that no further processing on the current event should be performed
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FacesException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces
Class FacesException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.faces.FacesException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AbortProcessingException, ConverterException, EvaluationException, ValidatorException, ViewExpiredException
public class FacesException
extends RuntimeException

This class encapsulates general JavaServer Faces exceptions.

See Also:
Serialized Form

Constructor Summary
FacesException()
Construct a new exception with no detail message or root cause.
FacesException(String message)
Construct a new exception with the specified detail message and no root cause.
FacesException(String message, Throwable cause)
Construct a new exception with the specified detail message and root cause.
FacesException(Throwable cause)
Construct a new exception with the specified root cause.
Method Summary
 Throwable getCause()
Return the cause of this exception, or null if the cause is nonexistent or unknown.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FacesException

public FacesException()

Construct a new exception with no detail message or root cause.

FacesException

public FacesException(String message)

Construct a new exception with the specified detail message and no root cause.

Parameters:
message - The detail message for this exception

FacesException

public FacesException(Throwable cause)

Construct a new exception with the specified root cause. The detail message will be set to (cause == null ? null : cause.toString()

Parameters:
cause - The root cause for this exception

FacesException

public FacesException(String message,
                      Throwable cause)

Construct a new exception with the specified detail message and root cause.

Parameters:
message - The detail message for this exception
cause - The root cause for this exception
Method Detail

getCause

public Throwable getCause()

Return the cause of this exception, or null if the cause is nonexistent or unknown.

Overrides:
getCause in class Throwable
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FactoryFinder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces
Class FactoryFinder

java.lang.Object
    extended by  javax.faces.FactoryFinder

public final class FactoryFinder
extends Object

FactoryFinder implements the standard discovery algorithm for all factory objects specified in the JavaServer Faces APIs. For a given factory class name, a corresponding implementation class is searched for based on the following algorithm. Items are listed in order of decreasing search precedence:

  • If the JavaServer Faces configuration file bundled into the WEB-INF directory of the webapp contains a factory entry of the given factory class name, that factory is used.
  • If the JavaServer Faces configuration files named by the javax.faces.CONFIG_FILES ServletContext init parameter contain any factory entries of the given factory class name, those factories are used, with the last one taking precedence.
  • If there are any JavaServer Faces configuration files bundled into the META-INF directory of any jars on the ServletContext's resource paths, the factory entries of the given factory class name in those files are used, with the last one taking precedence.
  • If a META-INF/services/{factory-class-name} resource is visible to the web application class loader for the calling application (typically as a result of being present in the manifest of a JAR file), its first line is read and assumed to be the name of the factory implementation class to use.
  • If none of the above steps yield a match, the JavaServer Faces implementation specific class is used.

If any of the factories found on any of the steps above happen to have a one-argument constructor, with argument the type being the abstract factory class, that constructor is invoked, and the previous match is passed to the constructor. For example, say the container vendor provided an implementation of FacesContextFactory, and identified it in META-INF/services/javax.faces.context.FacesContextFactory in a jar on the webapp ClassLoader. Also say this implementation provided by the container vendor had a one argument constructor that took a FacesContextFactory instance. The FactoryFinder system would call that one-argument constructor, passing the implementation of FacesContextFactory provided by the JavaServer Faces implementation.

If a Factory implementation does not provide a proper one-argument constructor, it must provide a zero-arguments constructor in order to be successfully instantiated.

Once the name of the factory implementation class is located, the web application class loader for the calling application is requested to load this class, and a corresponding instance of the class will be created. A side effect of this rule is that each web application will receive its own instance of each factory class, whether the JavaServer Faces implementation is included within the web application or is made visible through the container's facilities for shared libraries.

Field Summary
static String | APPLICATION_FACTORY The property name for the ApplicationFactory class name.
static String | FACES_CONTEXT_FACTORY The property name for the FacesContextFactory class name.
static String | LIFECYCLE_FACTORY The property name for the LifecycleFactory class name.
static String | RENDER_KIT_FACTORY The property name for the RenderKitFactory class name.
Method Summary
static Object getFactory(String factoryName)
Create (if necessary) and return a per-web-application instance of the appropriate implementation class for the specified JavaServer Faces factory class, based on the discovery algorithm described in the class description.
static void releaseFactories()
Release any references to factory instances associated with the class loader for the calling web application.
static void setFactory(String factoryName, String implName)
This method will store the argument factoryName/implName mapping in such a way that getFactory(java.lang.String) will find this mapping when searching for a match.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

APPLICATION_FACTORY

public static final String APPLICATION_FACTORY

The property name for the ApplicationFactory class name.

See Also:
Constant Field Values

FACES_CONTEXT_FACTORY

public static final String FACES_CONTEXT_FACTORY

The property name for the FacesContextFactory class name.

See Also:
Constant Field Values

LIFECYCLE_FACTORY

public static final String LIFECYCLE_FACTORY

The property name for the LifecycleFactory class name.

See Also:
Constant Field Values

RENDER_KIT_FACTORY

public static final String RENDER_KIT_FACTORY

The property name for the RenderKitFactory class name.

See Also:
Constant Field Values
Method Detail

getFactory

public static Object getFactory(String factoryName)
                         throws FacesException

Create (if necessary) and return a per-web-application instance of the appropriate implementation class for the specified JavaServer Faces factory class, based on the discovery algorithm described in the class description.

Parameters:
factoryName - Fully qualified name of the JavaServer Faces factory for which an implementation instance is requested
Throws:
FacesException - if the web application class loader cannot be identified
FacesException - if an instance of the configured factory implementation class cannot be loaded
FacesException - if an instance of the configured factory implementation class cannot be instantiated
IllegalArgumentException - if factoryName does not identify a standard JavaServer Faces factory name
IllegalStateException - if there is no configured factory implementation class for the specified factory name
NullPointerException - if factoryname is null

setFactory

public static void setFactory(String factoryName,
                              String implName)

This method will store the argument factoryName/implName mapping in such a way that getFactory(java.lang.String) will find this mapping when searching for a match.

This method has no effect if getFactory() has already been called looking for a factory for this factoryName.

This method can be used by implementations to store a factory mapping while parsing the Faces configuration file

Throws:
IllegalArgumentException - if factoryName does not identify a standard JavaServer Faces factory name
NullPointerException - if factoryname is null

releaseFactories

public static void releaseFactories()
                             throws FacesException

Release any references to factory instances associated with the class loader for the calling web application. This method should be called as apart of web application shutdown in a container where the JavaServer Faces API classes are part of the container itself, rather than being included inside the web application.

Throws:
FacesException - if the web application class loader cannot be identified
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


lifecycle

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.faces.lifecycle

Classes and interfaces defining lifecycle management for the JavaServer Faces implementation.

See:
Description

Class Summary
Lifecycle | Lifecycle manages the processing of the entire lifecycle of a particular JavaServer Faces request.
LifecycleFactory | LifecycleFactory is a factory object that creates (if needed) and returns Lifecycle instances.

Package javax.faces.lifecycle Description

Classes and interfaces defining lifecycle management for the JavaServer Faces implementation. The main class in this package is Lifecycle. Lifecycle is the gateway to executing the request processing lifecycle.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.faces.lifecycle Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.faces.lifecycle

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.lifecycle.Lifecycle
    • javax.faces.lifecycle.LifecycleFactory
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Lifecycle

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.lifecycle
Class Lifecycle

java.lang.Object
    extended by  javax.faces.lifecycle.Lifecycle

public abstract class Lifecycle
extends Object

Lifecycle manages the processing of the entire lifecycle of a particular JavaServer Faces request. It is responsible for executing all of the phases that have been defined by the JavaServer Faces Specification, in the specified order, unless otherwise directed by activities that occurred during the execution of each phase.

An instance of Lifecycle is created by calling the getLifecycle() method of LifecycleFactory, for a specified lifecycle identifier. Because this instance is shared across multiple simultaneous requests, it must be implemented in a thread-safe manner.

Constructor Summary
Lifecycle()
Method Summary
abstract void | addPhaseListener(PhaseListener listener) Register a new PhaseListener instance that is interested in being notified before and after the processing for standard phases of the request processing lifecycle.
abstract void | execute(FacesContext context) Execute all of the phases of the request processing lifecycle, up to but not including the Render Response phase, as described in the JavaServer Faces Specification, in the specified order.
abstract PhaseListener[] | getPhaseListeners() Return the set of registered PhaseListeners for this Lifecycle instance.
abstract void | removePhaseListener(PhaseListener listener) Deregister an existing PhaseListener instance that is no longer interested in being notified before and after the processing for standard phases of the request processing lifecycle.
abstract void | render(FacesContext context) Execute the Render Response phase of the request processing lifecycle, unless the responseComplete() method has been called on the FacesContext instance associated with the current request.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Lifecycle

public Lifecycle()
Method Detail

addPhaseListener

public abstract void addPhaseListener(PhaseListener listener)

Register a new PhaseListener instance that is interested in being notified before and after the processing for standard phases of the request processing lifecycle.

Parameters:
listener - The PhaseListener to be registered
Throws:
NullPointerException - if listener is null

execute

public abstract void execute(FacesContext context)
                      throws FacesException

Execute all of the phases of the request processing lifecycle, up to but not including the Render Response phase, as described in the JavaServer Faces Specification, in the specified order. The processing flow can be affected (by the application, by components, or by event listeners) by calls to the renderResponse() or responseComplete() methods of the FacesContext instance associated with the current request.

Parameters:
context - FacesContext for the request to be processed
Throws:
FacesException - if thrown during the execution of the request processing lifecycle
NullPointerException - if context is null

getPhaseListeners

public abstract PhaseListener[] getPhaseListeners()

Return the set of registered PhaseListeners for this Lifecycle instance. If there are no registered listeners, a zero-length array is returned.

removePhaseListener

public abstract void removePhaseListener(PhaseListener listener)

Deregister an existing PhaseListener instance that is no longer interested in being notified before and after the processing for standard phases of the request processing lifecycle. If no such listener instance has been registered, no action is taken.

Parameters:
listener - The PhaseListener to be deregistered
Throws:
NullPointerException - if listener is null

render

public abstract void render(FacesContext context)
                     throws FacesException

Execute the Render Response phase of the request processing lifecycle, unless the responseComplete() method has been called on the FacesContext instance associated with the current request.

Parameters:
context - FacesContext for the request being processed
Throws:
FacesException - if an exception is thrown during the execution of the request processing lifecycle
NullPointerException - if context is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LifecycleFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.lifecycle
Class LifecycleFactory

java.lang.Object
    extended by  javax.faces.lifecycle.LifecycleFactory

public abstract class LifecycleFactory
extends Object

LifecycleFactory is a factory object that creates (if needed) and returns Lifecycle instances. Implementations of JavaServer Faces must provide at least a default implementation of Lifecycle. Advanced implementations (or external third party libraries) MAY provide additional Lifecycle implementations (keyed by lifecycle identifiers) for performing different types of request processing on a per-request basis.

There must be one LifecycleFactory instance per web application that is utilizing JavaServer Faces. This instance can be acquired, in a portable manner, by calling:

   LifecycleFactory factory = (LifecycleFactory)
    FactoryFinder.getFactory(FactoryFinder.LIFECYCLE_FACTORY);

Field Summary
static String DEFAULT_LIFECYCLE
The lifecycle identifier for the default Lifecycle instance for this JavaServer Faces implementation.
Constructor Summary
LifecycleFactory()
Method Summary
abstract void | addLifecycle(String lifecycleId, Lifecycle lifecycle) Register a new Lifecycle instance, associated with the specified lifecycleId, to be supported by this LifecycleFactory.
abstract Lifecycle | getLifecycle(String lifecycleId) Create (if needed) and return a Lifecycle instance for the specified lifecycle identifier.
abstract Iterator<String> | getLifecycleIds() Return an Iterator over the set of lifecycle identifiers supported by this factory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_LIFECYCLE

public static final String DEFAULT_LIFECYCLE

The lifecycle identifier for the default Lifecycle instance for this JavaServer Faces implementation.

See Also:
Constant Field Values
Constructor Detail

LifecycleFactory

public LifecycleFactory()
Method Detail

addLifecycle

public abstract void addLifecycle(String lifecycleId,
                                  Lifecycle lifecycle)

Register a new Lifecycle instance, associated with the specified lifecycleId, to be supported by this LifecycleFactory. This method may be called at any time, and makes the corresponding Lifecycle instance available throughout the remaining lifetime of this web application.

Parameters:
lifecycleId - Identifier of the new Lifecycle
lifecycle - Lifecycle instance that we are registering
Throws:
IllegalArgumentException - if a Lifecycle with the specified lifecycleId has already been registered
NullPointerException - if lifecycleId or lifecycle is null

getLifecycle

public abstract Lifecycle getLifecycle(String lifecycleId)

Create (if needed) and return a Lifecycle instance for the specified lifecycle identifier. The set of available lifecycle identifiers is available via the getLifecycleIds() method.

Each call to getLifecycle() for the same lifecycleId, from within the same web application, must return the same Lifecycle instance.

Parameters:
lifecycleId - Lifecycle identifier of the requested Lifecycle instance
Throws:
IllegalArgumentException - if no Lifecycle instance can be returned for the specified identifier
NullPointerException - if lifecycleId is null

getLifecycleIds

public abstract Iterator<String> getLifecycleIds()

Return an Iterator over the set of lifecycle identifiers supported by this factory. This set must include the value specified by LifecycleFactory.DEFAULT_LIFECYCLE.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


model

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.faces.model

Standard model data beans for JavaServer Faces.

See:
Description

Interface Summary
DataModelListener DataModelListener represents an event listener that wishes to be notified of DataModelEvents occurring on a particular DataModel instance.

Class Summary
ArrayDataModel | ArrayDataModel is a convenience implementation of DataModel that wraps an array of Java objects.
DataModel | DataModel is an abstraction around arbitrary data binding technologies that can be used to adapt a variety of data sources for use by JavaServer Faces components that support per-row processing for their child components (such as UIData.
DataModelEvent | DataModelEvent represents an event of interest to registered listeners that occurred on the specified DataModel.
ListDataModel | ListDataModel is a convenience implementation of DataModel that wraps an List of Java objects.
ResultDataModel | ResultDataModel is a convenience implementation of DataModel that wraps a JSTL Result object, typically representing the results of executing an SQL query via JSTL tags.
ResultSetDataModel | ResultSetDataModel is a convenience implementation of DataModel that wraps a ResultSet of Java objects.
ScalarDataModel | ScalarDataModel is a convenience implementation of DataModel that wraps an individual Java object.
SelectItem | SelectItem represents a single item in the list of supported items associated with a UISelectMany or UISelectOne component.
SelectItemGroup | SelectItemGroup is a subclass of SelectItem that identifies a set of options that will be made available as a subordinate "submenu" or "options list", depending upon the requirements of the UISelectMany or UISelectOne renderer that is actually used.

Package javax.faces.model Description

Standard model data beans for JavaServer Faces.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.faces.model Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.faces.model

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.model.DataModel
      • javax.faces.model.ArrayDataModel
      • javax.faces.model.ListDataModel
      • javax.faces.model.ResultDataModel
      • javax.faces.model.ResultSetDataModel
      • javax.faces.model.ScalarDataModel
    • java.util.EventObject (implements java.io.Serializable)
      • javax.faces.model.DataModelEvent
    • javax.faces.model.SelectItem (implements java.io.Serializable)
      • javax.faces.model.SelectItemGroup

Interface Hierarchy

  • java.util.EventListener
    • javax.faces.model.DataModelListener
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ArrayDataModel

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.model
Class ArrayDataModel

java.lang.Object
    extended by  javax.faces.model.DataModel
        extended by  javax.faces.model.ArrayDataModel

public class ArrayDataModel
extends DataModel

ArrayDataModel is a convenience implementation of DataModel that wraps an array of Java objects.

Constructor Summary
ArrayDataModel()
Construct a new ArrayDataModel with no specified wrapped data.
ArrayDataModel(Object[] array)
Construct a new ArrayDataModel wrapping the specified array.
Method Summary
int | getRowCount() If there is wrappedData available, return the length of the array.
Object | getRowData() If row data is available, return the array element at the index specified by rowIndex.
int | getRowIndex() Return the zero-relative index of the currently selected row.
Object | getWrappedData() Return the object representing the data wrapped by this DataModel, if any.
boolean | isRowAvailable() Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the length of the array.
void | setRowIndex(int rowIndex) Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.
void | setWrappedData(Object data) Set the object representing the data collection wrapped by this DataModel.
Methods inherited from class javax.faces.model.DataModel
addDataModelListener, getDataModelListeners, removeDataModelListener
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ArrayDataModel

public ArrayDataModel()

Construct a new ArrayDataModel with no specified wrapped data.

ArrayDataModel

public ArrayDataModel(Object[] array)

Construct a new ArrayDataModel wrapping the specified array.

Parameters:
array - Array to be wrapped (if any)
Method Detail

isRowAvailable

public boolean isRowAvailable()

Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the length of the array. Otherwise, return false.

Specified by:
isRowAvailable in class DataModel
Throws:
FacesException - if an error occurs getting the row availability

getRowCount

public int getRowCount()

If there is wrappedData available, return the length of the array. If no wrappedData is available, return -1.

Specified by:
getRowCount in class DataModel
Throws:
FacesException - if an error occurs getting the row count

getRowData

public Object getRowData()

If row data is available, return the array element at the index specified by rowIndex. If no wrapped data is available, return null.

Specified by:
getRowData in class DataModel
Throws:
FacesException - if an error occurs getting the row data
IllegalArgumentException - if now row data is available at the currently specified row index

getRowIndex

public int getRowIndex()
Description copied from class: DataModel

Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, or no wrappedData is available, return -1.

Specified by:
getRowIndex in class DataModel
Throws:
FacesException - if an error occurs getting the row index

setRowIndex

public void setRowIndex(int rowIndex)
Description copied from class: DataModel

Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

If there is no wrappedData available when this method is called, the specified rowIndex is stored (and may be retrieved by a subsequent call to getRowData()), but no event is sent. Otherwise, if the currently selected row index is changed by this call, a DataModelEvent will be sent to the rowSelected() method of all registered DataModelListeners.

Specified by:
setRowIndex in class DataModel
Parameters:
rowIndex - The new zero-relative index (must be non-negative)
Throws:
FacesException - if an error occurs setting the row index
IllegalArgumentException - if rowIndex is less than -1

getWrappedData

public Object getWrappedData()
Description copied from class: DataModel

Return the object representing the data wrapped by this DataModel, if any.

Specified by:
getWrappedData in class DataModel

setWrappedData

public void setWrappedData(Object data)
Description copied from class: DataModel

Set the object representing the data collection wrapped by this DataModel. If the specified data is null, detach this DataModel from any previously wrapped data collection instead.

If data is non-null, the currently selected row index must be set to zero, and a DataModelEvent must be sent to the rowSelected() method of all registered DataModelListeners indicating that this row is now selected.

Specified by:
setWrappedData in class DataModel
Parameters:
data - Data collection to be wrapped, or null to detach from any previous data collection
Throws:
ClassCastException - if data is non-null and is not an array of Java objects.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DataModel

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.model
Class DataModel

java.lang.Object
    extended by  javax.faces.model.DataModel
Direct Known Subclasses:
ArrayDataModel, ListDataModel, ResultDataModel, ResultSetDataModel, ScalarDataModel
public abstract class DataModel
extends Object

DataModel is an abstraction around arbitrary data binding technologies that can be used to adapt a variety of data sources for use by JavaServer Faces components that support per-row processing for their child components (such as UIData.

The data collection underlying a DataModel instance is modeled as a collection of row objects that can be accessed by a zero-relative cursor (row index). The APIs provide mechanisms to position to a specified zero-relative row index, and to retrieve an object that represents the data that corresponds to the current row index.

A concrete DataModel instance is attached to a particular collection of underlying data by calling the setWrappedData() method. It can be detached from that underlying data collection by passing a null parameter to this method.

Concrete DataModel implementations must provide a public zero-arguments constructor that calls setWrappedData(null). A convenience constructor that takes a wrapped object of the appropriate type (and passes it on via a call to setWrappedData(), should also be provided.

Event listeners may be registered to receive notifications of when a new row index is selected.

Constructor Summary
DataModel()
Method Summary
void | addDataModelListener(DataModelListener listener) Add a new DataModelListener to the set interested in notifications from this DataModel.
DataModelListener[] | getDataModelListeners() Return the set of DataModelListeners interested in notifications from this DataModel.
abstract int | getRowCount() Return the number of rows of data objects represented by this DataModel.
abstract Object | getRowData() Return an object representing the data for the currenty selected row index.
abstract int | getRowIndex() Return the zero-relative index of the currently selected row.
abstract Object | getWrappedData() Return the object representing the data wrapped by this DataModel, if any.
abstract boolean | isRowAvailable() Return a flag indicating whether there is rowData available at the current rowIndex.
void | removeDataModelListener(DataModelListener listener) Remove an existing DataModelListener from the set interested in notifications from this DataModel.
abstract void | setRowIndex(int rowIndex) Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.
abstract void | setWrappedData(Object data) Set the object representing the data collection wrapped by this DataModel.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataModel

public DataModel()
Method Detail

isRowAvailable

public abstract boolean isRowAvailable()

Return a flag indicating whether there is rowData available at the current rowIndex. If no wrappedData is available, return false.

Throws:
FacesException - if an error occurs getting the row availability

getRowCount

public abstract int getRowCount()

Return the number of rows of data objects represented by this DataModel. If the number of rows is unknown, or no wrappedData is available, return -1.

Throws:
FacesException - if an error occurs getting the row count

getRowData

public abstract Object getRowData()

Return an object representing the data for the currenty selected row index. If no wrappedData is available, return null.

Throws:
FacesException - if an error occurs getting the row data
IllegalArgumentException - if now row data is available at the currently specified row index

getRowIndex

public abstract int getRowIndex()

Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, or no wrappedData is available, return -1.

Throws:
FacesException - if an error occurs getting the row index

setRowIndex

public abstract void setRowIndex(int rowIndex)

Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

If there is no wrappedData available when this method is called, the specified rowIndex is stored (and may be retrieved by a subsequent call to getRowData()), but no event is sent. Otherwise, if the currently selected row index is changed by this call, a DataModelEvent will be sent to the rowSelected() method of all registered DataModelListeners.

Parameters:
rowIndex - The new zero-relative index (must be non-negative)
Throws:
FacesException - if an error occurs setting the row index
IllegalArgumentException - if rowIndex is less than -1

getWrappedData

public abstract Object getWrappedData()

Return the object representing the data wrapped by this DataModel, if any.

setWrappedData

public abstract void setWrappedData(Object data)

Set the object representing the data collection wrapped by this DataModel. If the specified data is null, detach this DataModel from any previously wrapped data collection instead.

If data is non-null, the currently selected row index must be set to zero, and a DataModelEvent must be sent to the rowSelected() method of all registered DataModelListeners indicating that this row is now selected.

Parameters:
data - Data collection to be wrapped, or null to detach from any previous data collection
Throws:
ClassCastException - if data is not of the appropriate type for this DataModel implementation

addDataModelListener

public void addDataModelListener(DataModelListener listener)

Add a new DataModelListener to the set interested in notifications from this DataModel.

Parameters:
listener - The new DataModelListener to be registered
Throws:
NullPointerException - if listener is null

getDataModelListeners

public DataModelListener[] getDataModelListeners()

Return the set of DataModelListeners interested in notifications from this DataModel. If there are no such listeners, an empty array is returned.

removeDataModelListener

public void removeDataModelListener(DataModelListener listener)

Remove an existing DataModelListener from the set interested in notifications from this DataModel.

Parameters:
listener - The old DataModelListener to be deregistered
Throws:
NullPointerException - if listener is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DataModelEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.model
Class DataModelEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.faces.model.DataModelEvent
All Implemented Interfaces:
Serializable
public class DataModelEvent
extends EventObject

DataModelEvent represents an event of interest to registered listeners that occurred on the specified DataModel.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
DataModelEvent(DataModel model, int index, Object data)
Construct an event object that is associated with the specified row index and associated data.
Method Summary
DataModel | getDataModel() Return the DataModel that fired this event.
Object | getRowData() Return the object representing the data for the specified row index, or null for no associated row data.
int | getRowIndex() Return the row index for this event, or -1 for no specific row.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DataModelEvent

public DataModelEvent(DataModel model,
                      int index,
                      Object data)

Construct an event object that is associated with the specified row index and associated data.

Parameters:
model - The DataModel on which this event occurred
index - The zero relative row index for which this event occurred, or -1 for no specific row association
data - Representation of the data for the row specified by index, or null for no particular row data
Method Detail

getDataModel

public DataModel getDataModel()

Return the DataModel that fired this event.

getRowData

public Object getRowData()

Return the object representing the data for the specified row index, or null for no associated row data.

getRowIndex

public int getRowIndex()

Return the row index for this event, or -1 for no specific row.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DataModelListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.model
Interface DataModelListener

All Superinterfaces:
EventListener
public interface DataModelListener
extends EventListener

DataModelListener represents an event listener that wishes to be notified of DataModelEvents occurring on a particular DataModel instance.

Method Summary
 void rowSelected(DataModelEvent event)
Notification that a particular row index, with the associated row data, has been selected for processing.

Method Detail

rowSelected

void rowSelected(DataModelEvent event)

Notification that a particular row index, with the associated row data, has been selected for processing.

Parameters:
event - The DataModelEvent we are processing
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ListDataModel

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.model
Class ListDataModel

java.lang.Object
    extended by  javax.faces.model.DataModel
        extended by  javax.faces.model.ListDataModel

public class ListDataModel
extends DataModel

ListDataModel is a convenience implementation of DataModel that wraps an List of Java objects.

Constructor Summary
ListDataModel()
Construct a new ListDataModel with no specified wrapped data.
ListDataModel(List list)
Construct a new ListDataModel wrapping the specified list.
Method Summary
int | getRowCount() If there is wrappedData available, return the length of the list.
Object | getRowData() If row data is available, return the array element at the index specified by rowIndex.
int | getRowIndex() Return the zero-relative index of the currently selected row.
Object | getWrappedData() Return the object representing the data wrapped by this DataModel, if any.
boolean | isRowAvailable() Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the size of the list.
void | setRowIndex(int rowIndex) Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.
void | setWrappedData(Object data) Set the object representing the data collection wrapped by this DataModel.
Methods inherited from class javax.faces.model.DataModel
addDataModelListener, getDataModelListeners, removeDataModelListener
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ListDataModel

public ListDataModel()

Construct a new ListDataModel with no specified wrapped data.

ListDataModel

public ListDataModel(List list)

Construct a new ListDataModel wrapping the specified list.

Parameters:
list - List to be wrapped (if any)
Method Detail

isRowAvailable

public boolean isRowAvailable()

Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the size of the list. Otherwise, return false.

Specified by:
isRowAvailable in class DataModel
Throws:
FacesException - if an error occurs getting the row availability

getRowCount

public int getRowCount()

If there is wrappedData available, return the length of the list. If no wrappedData is available, return -1.

Specified by:
getRowCount in class DataModel
Throws:
FacesException - if an error occurs getting the row count

getRowData

public Object getRowData()

If row data is available, return the array element at the index specified by rowIndex. If no wrapped data is available, return null.

Specified by:
getRowData in class DataModel
Throws:
FacesException - if an error occurs getting the row data
IllegalArgumentException - if now row data is available at the currently specified row index

getRowIndex

public int getRowIndex()
Description copied from class: DataModel

Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, or no wrappedData is available, return -1.

Specified by:
getRowIndex in class DataModel
Throws:
FacesException - if an error occurs getting the row index

setRowIndex

public void setRowIndex(int rowIndex)
Description copied from class: DataModel

Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

If there is no wrappedData available when this method is called, the specified rowIndex is stored (and may be retrieved by a subsequent call to getRowData()), but no event is sent. Otherwise, if the currently selected row index is changed by this call, a DataModelEvent will be sent to the rowSelected() method of all registered DataModelListeners.

Specified by:
setRowIndex in class DataModel
Parameters:
rowIndex - The new zero-relative index (must be non-negative)
Throws:
FacesException - if an error occurs setting the row index
IllegalArgumentException - if rowIndex is less than -1

getWrappedData

public Object getWrappedData()
Description copied from class: DataModel

Return the object representing the data wrapped by this DataModel, if any.

Specified by:
getWrappedData in class DataModel

setWrappedData

public void setWrappedData(Object data)
Description copied from class: DataModel

Set the object representing the data collection wrapped by this DataModel. If the specified data is null, detach this DataModel from any previously wrapped data collection instead.

If data is non-null, the currently selected row index must be set to zero, and a DataModelEvent must be sent to the rowSelected() method of all registered DataModelListeners indicating that this row is now selected.

Specified by:
setWrappedData in class DataModel
Parameters:
data - Data collection to be wrapped, or null to detach from any previous data collection
Throws:
ClassCastException - if data is non-null and is not a List
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResultDataModel

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.model
Class ResultDataModel

java.lang.Object
    extended by  javax.faces.model.DataModel
        extended by  javax.faces.model.ResultDataModel

public class ResultDataModel
extends DataModel

ResultDataModel is a convenience implementation of DataModel that wraps a JSTL Result object, typically representing the results of executing an SQL query via JSTL tags.

Constructor Summary
ResultDataModel()
Construct a new ResultDataModel with no specified wrapped data.
ResultDataModel(javax.servlet.jsp.jstl.sql.Result result)
Construct a new ResultDataModel wrapping the specified Result.
Method Summary
 int getRowCount()
If there is wrappedData available, return the length of the array returned by calling getRows() on the underlying Result.
 Object getRowData()
If row data is available, return the SortedMap array element at the index specified by rowIndex of the array returned by calling getRows() on the underlying Result.
 int getRowIndex()
Return the zero-relative index of the currently selected row.
 Object getWrappedData()
Return the object representing the data wrapped by this DataModel, if any.
 boolean isRowAvailable()
Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the length of the array returned by calling getRows() on the underlying Result.
 void setRowIndex(int rowIndex)
Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.
 void setWrappedData(Object data)
Set the object representing the data collection wrapped by this DataModel.
Methods inherited from class javax.faces.model.DataModel
addDataModelListener, getDataModelListeners, removeDataModelListener
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResultDataModel

public ResultDataModel()

Construct a new ResultDataModel with no specified wrapped data.

ResultDataModel

public ResultDataModel(javax.servlet.jsp.jstl.sql.Result result)

Construct a new ResultDataModel wrapping the specified Result.

Parameters:
result - Result to be wrapped (if any)
Method Detail

isRowAvailable

public boolean isRowAvailable()

Return true if there is wrappedData available, and the current value of rowIndex is greater than or equal to zero, and less than the length of the array returned by calling getRows() on the underlying Result. Otherwise, return false.

Specified by:
isRowAvailable in class DataModel
Throws:
FacesException - if an error occurs getting the row availability

getRowCount

public int getRowCount()

If there is wrappedData available, return the length of the array returned by calling getRows() on the underlying Result. If no wrappedData is available, return -1.

Specified by:
getRowCount in class DataModel
Throws:
FacesException - if an error occurs getting the row count

getRowData

public Object getRowData()

If row data is available, return the SortedMap array element at the index specified by rowIndex of the array returned by calling getRows() on the underlying Result. If no wrapped data is available, return null.

Note that, if a non-null Map is returned by this method, it will contain the values of the columns for the current row, keyed by column name. Column name comparisons must be performed in a case-insensitive manner.

Specified by:
getRowData in class DataModel
Throws:
FacesException - if an error occurs getting the row data
IllegalArgumentException - if now row data is available at the currently specified row index

getRowIndex

public int getRowIndex()
Description copied from class: DataModel

Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, or no wrappedData is available, return -1.

Specified by:
getRowIndex in class DataModel
Throws:
FacesException - if an error occurs getting the row index

setRowIndex

public void setRowIndex(int rowIndex)
Description copied from class: DataModel

Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

If there is no wrappedData available when this method is called, the specified rowIndex is stored (and may be retrieved by a subsequent call to getRowData()), but no event is sent. Otherwise, if the currently selected row index is changed by this call, a DataModelEvent will be sent to the rowSelected() method of all registered DataModelListeners.

Specified by:
setRowIndex in class DataModel
Parameters:
rowIndex - The new zero-relative index (must be non-negative)
Throws:
FacesException - if an error occurs setting the row index
IllegalArgumentException - if rowIndex is less than -1

getWrappedData

public Object getWrappedData()
Description copied from class: DataModel

Return the object representing the data wrapped by this DataModel, if any.

Specified by:
getWrappedData in class DataModel

setWrappedData

public void setWrappedData(Object data)
Description copied from class: DataModel

Set the object representing the data collection wrapped by this DataModel. If the specified data is null, detach this DataModel from any previously wrapped data collection instead.

If data is non-null, the currently selected row index must be set to zero, and a DataModelEvent must be sent to the rowSelected() method of all registered DataModelListeners indicating that this row is now selected.

Specified by:
setWrappedData in class DataModel
Parameters:
data - Data collection to be wrapped, or null to detach from any previous data collection
Throws:
ClassCastException - if data is non-null and is not a Result
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResultSetDataModel

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.model
Class ResultSetDataModel

java.lang.Object
    extended by  javax.faces.model.DataModel
        extended by  javax.faces.model.ResultSetDataModel

public class ResultSetDataModel
extends DataModel

ResultSetDataModel is a convenience implementation of DataModel that wraps a ResultSet of Java objects. Note that the specified ResultSet MUST be scrollable. In addition, if input components (that will be updating model values) reference this object in value binding expressions, the specified ResultSet MUST be updatable.

Constructor Summary
ResultSetDataModel()
Construct a new ResultSetDataModel with no specified wrapped data.
ResultSetDataModel(ResultSet resultSet)
Construct a new ResultSetDataModel wrapping the specified ResultSet.
Method Summary
 int getRowCount()
Return -1, since ResultSet does not provide a standard way to determine the number of available rows without scrolling through the entire ResultSet, and this can be very expensive if the number of rows is large.
 Object getRowData()
If row data is available, return a Map representing the values of the columns for the row specified by rowIndex, keyed by the corresponding column names.
 int getRowIndex()
Return the zero-relative index of the currently selected row.
 Object getWrappedData()
Return the object representing the data wrapped by this DataModel, if any.
 boolean isRowAvailable()
Return true if there is wrappedData available, and the result of calling absolute() on the underlying ResultSet, passing the current value of rowIndex plus one (to account for the fact that ResultSet uses one-relative indexing), returns true.
 void setRowIndex(int rowIndex)
Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.
 void setWrappedData(Object data)
Set the object representing the data collection wrapped by this DataModel.
Methods inherited from class javax.faces.model.DataModel
addDataModelListener, getDataModelListeners, removeDataModelListener
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResultSetDataModel

public ResultSetDataModel()

Construct a new ResultSetDataModel with no specified wrapped data.

ResultSetDataModel

public ResultSetDataModel(ResultSet resultSet)

Construct a new ResultSetDataModel wrapping the specified ResultSet.

Parameters:
resultSet - ResultSet to be wrapped (if any)
Method Detail

isRowAvailable

public boolean isRowAvailable()

Return true if there is wrappedData available, and the result of calling absolute() on the underlying ResultSet, passing the current value of rowIndex plus one (to account for the fact that ResultSet uses one-relative indexing), returns true. Otherwise, return false.

Specified by:
isRowAvailable in class DataModel
Throws:
FacesException - if an error occurs getting the row availability

getRowCount

public int getRowCount()

Return -1, since ResultSet does not provide a standard way to determine the number of available rows without scrolling through the entire ResultSet, and this can be very expensive if the number of rows is large.

Specified by:
getRowCount in class DataModel
Throws:
FacesException - if an error occurs getting the row count

getRowData

public Object getRowData()

If row data is available, return a Map representing the values of the columns for the row specified by rowIndex, keyed by the corresponding column names. If no wrapped data is available, return null.

If a non-null Map is returned, its behavior must correspond to the contract for a mutable Map as described in the JavaDocs for AbstractMap, with the following exceptions and specialized behavior:

  • The Map, and any supporting objects it returns, must perform all column name comparisons in a case-insensitive manner. This case-insensitivity must be implemented using a case-insensitive Comparator, such as String.CASE_INSENSITIVE_ORDER.
  • The following methods must throw UnsupportedOperationException: clear(), remove().
  • The entrySet() method must return a Set that has the following behavior:
    • Throw UnsupportedOperationException for any attempt to add or remove entries from the Set, either directly or indirectly through an Iterator returned by the Set.
    • Updates to the value of an entry in this set must write through to the corresponding column value in the underlying ResultSet.
  • The keySet() method must return a Set that throws UnsupportedOperationException on any attempt to add or remove keys, either directly or through an Iterator returned by the Set.
  • The put() method must throw IllegalArgumentException if a key value for which containsKey() returns false is specified. However, if a key already present in the Map is specified, the specified value must write through to the corresponding column value in the underlying ResultSet.
  • The values() method must return a Collection that throws UnsupportedOperationException on any attempt to add or remove values, either directly or through an Iterator returned by the Collection.

Specified by:
getRowData in class DataModel
Throws:
FacesException - if an error occurs getting the row data
IllegalArgumentException - if now row data is available at the currently specified row index

getRowIndex

public int getRowIndex()
Description copied from class: DataModel

Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, or no wrappedData is available, return -1.

Specified by:
getRowIndex in class DataModel
Throws:
FacesException - if an error occurs getting the row index

setRowIndex

public void setRowIndex(int rowIndex)
Description copied from class: DataModel

Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

If there is no wrappedData available when this method is called, the specified rowIndex is stored (and may be retrieved by a subsequent call to getRowData()), but no event is sent. Otherwise, if the currently selected row index is changed by this call, a DataModelEvent will be sent to the rowSelected() method of all registered DataModelListeners.

Specified by:
setRowIndex in class DataModel
Parameters:
rowIndex - The new zero-relative index (must be non-negative)
Throws:
FacesException - if an error occurs setting the row index
IllegalArgumentException - if rowIndex is less than -1

getWrappedData

public Object getWrappedData()
Description copied from class: DataModel

Return the object representing the data wrapped by this DataModel, if any.

Specified by:
getWrappedData in class DataModel

setWrappedData

public void setWrappedData(Object data)
Description copied from class: DataModel

Set the object representing the data collection wrapped by this DataModel. If the specified data is null, detach this DataModel from any previously wrapped data collection instead.

If data is non-null, the currently selected row index must be set to zero, and a DataModelEvent must be sent to the rowSelected() method of all registered DataModelListeners indicating that this row is now selected.

Specified by:
setWrappedData in class DataModel
Parameters:
data - Data collection to be wrapped, or null to detach from any previous data collection
Throws:
ClassCastException - if data is not of the appropriate type for this DataModel implementation
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ScalarDataModel

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.model
Class ScalarDataModel

java.lang.Object
    extended by  javax.faces.model.DataModel
        extended by  javax.faces.model.ScalarDataModel

public class ScalarDataModel
extends DataModel

ScalarDataModel is a convenience implementation of DataModel that wraps an individual Java object.

Constructor Summary
ScalarDataModel()
Construct a new ScalarDataModel with no specified wrapped data.
ScalarDataModel(Object scalar)
Construct a new ScalarDataModel wrapping the specified scalar object.
Method Summary
int | getRowCount() If there is wrappedData available, return 1.
Object | getRowData() If wrapped data is available, return the wrapped data instance.
int | getRowIndex() Return the zero-relative index of the currently selected row.
Object | getWrappedData() Return the object representing the data wrapped by this DataModel, if any.
boolean | isRowAvailable() Return true if there is wrappedData available, and the current value of rowIndex is zero.
void | setRowIndex(int rowIndex) Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row.
void | setWrappedData(Object data) Set the object representing the data collection wrapped by this DataModel.
Methods inherited from class javax.faces.model.DataModel
addDataModelListener, getDataModelListeners, removeDataModelListener
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ScalarDataModel

public ScalarDataModel()

Construct a new ScalarDataModel with no specified wrapped data.

ScalarDataModel

public ScalarDataModel(Object scalar)

Construct a new ScalarDataModel wrapping the specified scalar object.

Parameters:
scalar - Scalar to be wrapped (if any)
Method Detail

isRowAvailable

public boolean isRowAvailable()

Return true if there is wrappedData available, and the current value of rowIndex is zero. Otherwise, return false.

Specified by:
isRowAvailable in class DataModel
Throws:
FacesException - if an error occurs getting the row availability

getRowCount

public int getRowCount()

If there is wrappedData available, return 1. If no wrappedData is available, return -1.

Specified by:
getRowCount in class DataModel
Throws:
FacesException - if an error occurs getting the row count

getRowData

public Object getRowData()

If wrapped data is available, return the wrapped data instance. Otherwise, return null.

Specified by:
getRowData in class DataModel
Throws:
FacesException - if an error occurs getting the row data
IllegalArgumentException - if now row data is available at the currently specified row index

getRowIndex

public int getRowIndex()
Description copied from class: DataModel

Return the zero-relative index of the currently selected row. If we are not currently positioned on a row, or no wrappedData is available, return -1.

Specified by:
getRowIndex in class DataModel
Throws:
FacesException - if an error occurs getting the row index

setRowIndex

public void setRowIndex(int rowIndex)
Description copied from class: DataModel

Set the zero-relative index of the currently selected row, or -1 to indicate that we are not positioned on a row. It is possible to set the row index at a value for which the underlying data collection does not contain any row data. Therefore, callers may use the isRowAvailable() method to detect whether row data will be available for use by the getRowData() method.

If there is no wrappedData available when this method is called, the specified rowIndex is stored (and may be retrieved by a subsequent call to getRowData()), but no event is sent. Otherwise, if the currently selected row index is changed by this call, a DataModelEvent will be sent to the rowSelected() method of all registered DataModelListeners.

Specified by:
setRowIndex in class DataModel
Parameters:
rowIndex - The new zero-relative index (must be non-negative)
Throws:
FacesException - if an error occurs setting the row index
IllegalArgumentException - if rowIndex is less than -1

getWrappedData

public Object getWrappedData()
Description copied from class: DataModel

Return the object representing the data wrapped by this DataModel, if any.

Specified by:
getWrappedData in class DataModel

setWrappedData

public void setWrappedData(Object data)
Description copied from class: DataModel

Set the object representing the data collection wrapped by this DataModel. If the specified data is null, detach this DataModel from any previously wrapped data collection instead.

If data is non-null, the currently selected row index must be set to zero, and a DataModelEvent must be sent to the rowSelected() method of all registered DataModelListeners indicating that this row is now selected.

Specified by:
setWrappedData in class DataModel
Parameters:
data - Data collection to be wrapped, or null to detach from any previous data collection
Throws:
ClassCastException - if data is not of the appropriate type for this DataModel implementation
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SelectItem

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.model
Class SelectItem

java.lang.Object
    extended by  javax.faces.model.SelectItem
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
SelectItemGroup
public class SelectItem
extends Object
implements Serializable

SelectItem represents a single item in the list of supported items associated with a UISelectMany or UISelectOne component.

See Also:
Serialized Form

Constructor Summary
SelectItem()
Construct a SelectItem with no initialized property values.
SelectItem(Object value)
Construct a SelectItem with the specified value.
SelectItem(Object value, String label)
Construct a SelectItem with the specified value and label.
SelectItem(Object value, String label, String description)
Construct a SelectItem instance with the specified value, label and description.
SelectItem(Object value, String label, String description, boolean disabled)
Construct a SelectItem instance with the specified property values.
SelectItem(Object value, String label, String description, boolean disabled, boolean escape)
Construct a SelectItem instance with the specified property values.
Method Summary
String | getDescription() Return a description of this item, for use in development tools.
String | getLabel() Return the label of this item, to be rendered visibly for the user.
Object | getValue() Return the value of this item, to be delivered to the model if this item is selected by the user.
boolean | isDisabled() Return the disabled flag for this item, which should modify the rendered output to make this item unavailable for selection by the user if set to true.
boolean | isEscape() Getter for property escape.
void | setDescription(String description) Set the description of this item, for use in development tools.
void | setDisabled(boolean disabled) Set the disabled flag for this item, which should modify the rendered output to make this item unavailable for selection by the user if set to true.
void | setEscape(boolean escape) Setter for property escape.
void | setLabel(String label) Set the label of this item, to be rendered visibly for the user.
void | setValue(Object value) Set the value of this item, to be delivered to the model if this item is selected by this user.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SelectItem

public SelectItem()

Construct a SelectItem with no initialized property values.

SelectItem

public SelectItem(Object value)

Construct a SelectItem with the specified value. The label property will be set to the value (converted to a String, if necessary), the description property will be set to null, and the disabled property will be set to false.

Parameters:
value - Value to be delivered to the model if this item is selected by the user
Throws:
NullPointerException - if value is null

SelectItem

public SelectItem(Object value,
                  String label)

Construct a SelectItem with the specified value and label. The description property will be set to null, and the disabled property will be set to false.

Parameters:
value - Value to be delivered to the model if this item is selected by the user
label - Label to be rendered for this item in the response
Throws:
NullPointerException - if value or label null

SelectItem

public SelectItem(Object value,
                  String label,
                  String description)

Construct a SelectItem instance with the specified value, label and description. This disabled property will be set to false.

Parameters:
value - Value to be delivered to the model if this item is selected by the user
label - Label to be rendered for this item in the response
description - Description of this item, for use in tools
Throws:
NullPointerException - if value or label is null

SelectItem

public SelectItem(Object value,
                  String label,
                  String description,
                  boolean disabled)

Construct a SelectItem instance with the specified property values.

Parameters:
value - Value to be delivered to the model if this item is selected by the user
label - Label to be rendered for this item in the response
description - Description of this item, for use in tools
disabled - Flag indicating that this option is disabled
Throws:
NullPointerException - if value or label is null

SelectItem

public SelectItem(Object value,
                  String label,
                  String description,
                  boolean disabled,
                  boolean escape)

Construct a SelectItem instance with the specified property values.

Parameters:
value - Value to be delivered to the model if this item is selected by the user
label - Label to be rendered for this item in the response
description - Description of this item, for use in tools
disabled - Flag indicating that this option is disabled
escape - Flag indicating that the text of this option should be escaped when rendered.
Throws:
NullPointerException - if value or label is null
Since:
1.2
Method Detail

getDescription

public String getDescription()

Return a description of this item, for use in development tools.

setDescription

public void setDescription(String description)

Set the description of this item, for use in development tools.

Parameters:
description - The new description

isDisabled

public boolean isDisabled()

Return the disabled flag for this item, which should modify the rendered output to make this item unavailable for selection by the user if set to true.

setDisabled

public void setDisabled(boolean disabled)

Set the disabled flag for this item, which should modify the rendered output to make this item unavailable for selection by the user if set to true.

Parameters:
disabled - The new disabled flag

getLabel

public String getLabel()

Return the label of this item, to be rendered visibly for the user.

setLabel

public void setLabel(String label)

Set the label of this item, to be rendered visibly for the user.

Parameters:
label - The new label
Throws:
NullPointerException - if label is null

getValue

public Object getValue()

Return the value of this item, to be delivered to the model if this item is selected by the user.

setValue

public void setValue(Object value)

Set the value of this item, to be delivered to the model if this item is selected by this user.

Parameters:
value - The new value

isEscape

public boolean isEscape()
Getter for property escape.

Returns:
Value of property escape.

setEscape

public void setEscape(boolean escape)
Setter for property escape.

Parameters:
escape - New value of property escape.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SelectItemGroup

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.model
Class SelectItemGroup

java.lang.Object
    extended by  javax.faces.model.SelectItem
        extended by  javax.faces.model.SelectItemGroup
All Implemented Interfaces:
Serializable
public class SelectItemGroup
extends SelectItem

SelectItemGroup is a subclass of SelectItem that identifies a set of options that will be made available as a subordinate "submenu" or "options list", depending upon the requirements of the UISelectMany or UISelectOne renderer that is actually used. In general, the value property of this instance will be ignored, and the label property of this instance will be used to label the submenu.

Although it is feasible to incorporate SelectItemGroup instances in he selectItems property of this instance (thereby creating a data structure suitable for cascading submenus), some renderers may place restrictions on the level of nesting they support. For example, HTML based renderers that create an <select> element will typically render this instance as an <optgroup> element, but the HTML 4.01 Specification disallows nested option groups.

See Also:
Serialized Form

Constructor Summary
SelectItemGroup()
Construct a SelectItemGroup with no initialized property values.
SelectItemGroup(String label)
Construct a SelectItemGroup with the specified label and no associated selectItems.
SelectItemGroup(String label, String description, boolean disabled, SelectItem[] selectItems)
Construct a SelectItemGroup with the specified properties.
Method Summary
SelectItem[] | getSelectItems() Return the set of subordinate SelectItems for this group.
void | setSelectItems(SelectItem[] selectItems) Set the set of subordinate SelectItems for this group.
Methods inherited from class javax.faces.model.SelectItem
getDescription, getLabel, getValue, isDisabled, isEscape, setDescription, setDisabled, setEscape, setLabel, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SelectItemGroup

public SelectItemGroup()

Construct a SelectItemGroup with no initialized property values.

SelectItemGroup

public SelectItemGroup(String label)

Construct a SelectItemGroup with the specified label and no associated selectItems. The value property will be set to a zero-length String, the description property will be set to null, and the disabled property will be set to false.

Parameters:
label - Label to be rendered for this group in the response
Throws:
NullPointerException - if label is false

SelectItemGroup

public SelectItemGroup(String label,
                       String description,
                       boolean disabled,
                       SelectItem[] selectItems)

Construct a SelectItemGroup with the specified properties. The value property will be set to a zero-length String.

Parameters:
label - Label to be rendered for this group in the response
description - Description of this group, for use in tools
disabled - Flag indicating that this group is disabled
selectItems - Array of SelectItem describing the items available in this group
Throws:
NullPointerException - if label or selectItems is false
Method Detail

getSelectItems

public SelectItem[] getSelectItems()

Return the set of subordinate SelectItems for this group.

setSelectItems

public void setSelectItems(SelectItem[] selectItems)

Set the set of subordinate SelectItems for this group.

Parameters:
selectItems - The new set of subordinate items
Throws:
NullPointerException - if selectItems is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


render

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.faces.render

Classes and interfaces defining the rendering model.

See:
Description

Class Summary
Renderer | A Renderer converts the internal representation of UIComponents into the output stream (or writer) associated with the response we are creating for a particular request.
RenderKit | RenderKit represents a collection of Renderer instances that, together, know how to render JavaServer Faces UIComponent instances for a specific client.
RenderKitFactory | RenderKitFactory is a factory object that registers and returns RenderKit instances.
ResponseStateManager | ResponseStateManager is the helper class to StateManager that knows the specific rendering technology being used to generate the response.

Package javax.faces.render Description

Classes and interfaces defining the rendering model. The main class in this package is RenderKit. RenderKit vends a set of Renderer instances which provide rendering capability for a specific client device type.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.faces.render Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.faces.render

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.render.Renderer
    • javax.faces.render.RenderKit
    • javax.faces.render.RenderKitFactory
    • javax.faces.render.ResponseStateManager
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Renderer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.render
Class Renderer

java.lang.Object
    extended by  javax.faces.render.Renderer

public abstract class Renderer
extends Object

A Renderer converts the internal representation of UIComponents into the output stream (or writer) associated with the response we are creating for a particular request. Each Renderer knows how to render one or more UIComponent types (or classes), and advertises a set of render-dependent attributes that it recognizes for each supported UIComponent.

Families of Renderers are packaged as a RenderKit, and together support the rendering of all of the UIComponents in a view associated with a FacesContext. Within the set of Renderers for a particular RenderKit, each must be uniquely identified by the rendererType property.

Individual Renderer instances will be instantiated as requested during the rendering process, and will remain in existence for the remainder of the lifetime of a web application. Because each instance may be invoked from more than one request processing thread simultaneously, they MUST be programmed in a thread-safe manner.

Constructor Summary
Renderer()
Method Summary
 String convertClientId(FacesContext context, String clientId)
Convert the component generated client id to a form suitable for transmission to the client.
 void decode(FacesContext context, UIComponent component)
Decode any new state of the specified UIComponent from the request contained in the specified FacesContext, and store that state on the UIComponent.
 void encodeBegin(FacesContext context, UIComponent component)
Render the beginning specified UIComponent to the output stream or writer associated with the response we are creating.
 void encodeChildren(FacesContext context, UIComponent component)
Render the child components of this UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.
 void encodeEnd(FacesContext context, UIComponent component)
Render the ending of the current state of the specified UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.
 Object getConvertedValue(FacesContext context, UIComponent component, Object submittedValue)
Attempt to convert previously stored state information into an object of the type required for this component (optionally using the registered Converter for this component, if there is one).
 boolean getRendersChildren()
Return a flag indicating whether this Renderer is responsible for rendering the children the component it is asked to render.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Renderer

public Renderer()
Method Detail

decode

public void decode(FacesContext context,
                   UIComponent component)

Decode any new state of the specified UIComponent from the request contained in the specified FacesContext, and store that state on the UIComponent.

During decoding, events may be enqueued for later processing (by event listeners that have registered an interest), by calling queueEvent() on the associated UIComponent.

Parameters:
context - FacesContext for the request we are processing
component - UIComponent to be decoded.
Throws:
NullPointerException - if context or component is null

encodeBegin

public void encodeBegin(FacesContext context,
                        UIComponent component)
                 throws IOException

Render the beginning specified UIComponent to the output stream or writer associated with the response we are creating. If the conversion attempted in a previous call to getConvertedValue() for this component failed, the state information saved during execution of decode() should be used to reproduce the incorrect input.

Parameters:
context - FacesContext for the request we are processing
component - UIComponent to be rendered
Throws:
IOException - if an input/output error occurs while rendering
NullPointerException - if context or component is null

encodeChildren

public void encodeChildren(FacesContext context,
                           UIComponent component)
                    throws IOException

Render the child components of this UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered. This method will only be called if the rendersChildren property of this component is true.

Parameters:
context - FacesContext for the response we are creating
component - UIComponent whose children are to be rendered
Throws:
IOException - if an input/output error occurs while rendering
NullPointerException - if context or component is null

encodeEnd

public void encodeEnd(FacesContext context,
                      UIComponent component)
               throws IOException

Render the ending of the current state of the specified UIComponent, following the rules described for encodeBegin() to acquire the appropriate value to be rendered.

Parameters:
context - FacesContext for the response we are creating
component - UIComponent to be rendered
Throws:
IOException - if an input/output error occurs while rendering
NullPointerException - if context or component is null

convertClientId

public String convertClientId(FacesContext context,
                              String clientId)

Convert the component generated client id to a form suitable for transmission to the client.

The default implementation returns the argument clientId unchanged.

Parameters:
context - FacesContext for the current request
clientId - the client identifier to be converted to client a specific format.
Throws:
NullPointerException - if context or clientId is null

getRendersChildren

public boolean getRendersChildren()

Return a flag indicating whether this Renderer is responsible for rendering the children the component it is asked to render. The default implementation returns false.

getConvertedValue

public Object getConvertedValue(FacesContext context,
                                UIComponent component,
                                Object submittedValue)
                         throws ConverterException

Attempt to convert previously stored state information into an object of the type required for this component (optionally using the registered Converter for this component, if there is one). If conversion is successful, the new value should be returned from this method; if not, a ConverterException should be thrown.

Parameters:
context - FacesContext for the request we are processing
component - UIComponent to be decoded.
submittedValue - a value stored on the component during decode.
Throws:
ConverterException - if the submitted value cannot be converted successfully.
NullPointerException - if context or component is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RenderKit

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.render
Class RenderKit

java.lang.Object
    extended by  javax.faces.render.RenderKit

public abstract class RenderKit
extends Object

RenderKit represents a collection of Renderer instances that, together, know how to render JavaServer Faces UIComponent instances for a specific client. Typically, RenderKits are specialized for some combination of client device type, markup language, and/or user Locale. A RenderKit also acts as a Factory for associated Renderer instances, which perform the actual rendering process for each component.

A typical JavaServer Faces implementation will configure one or more RenderKit instances at web application startup. They are made available through calls to the getRenderKit() methods of RenderKitFactory. Because RenderKit instances are shared, they must be implemented in a thread-safe manner. Due to limitations in the current specification having multiple RenderKit instances at play in the same application requires a custom ViewHandler instance that is aware of how to deal with this case. This limitation will be lifted in a future version of the spec.

The RenderKit instance must also vend a ResponseStateManager instance, which is used in the process of saving and restoring tree structure and state.

Constructor Summary
RenderKit()
Method Summary
abstract void | addRenderer(String family, String rendererType, Renderer renderer) Register the specified Renderer instance, associated with the specified component family and rendererType, to the set of Renderers registered with this RenderKit, replacing any previously registered Renderer for this combination of identifiers.
abstract ResponseStream | createResponseStream(OutputStream out) Use the provided OutputStream to create a new ResponseStream instance.
abstract ResponseWriter | createResponseWriter(Writer writer, String contentTypeList, String characterEncoding) Use the provided Writer to create a new ResponseWriter instance for the specified (optional) content type, and character encoding.
abstract Renderer | getRenderer(String family, String rendererType) Return the Renderer instance most recently registered for the specified component family and rendererType, if any; otherwise, return null.
abstract ResponseStateManager | getResponseStateManager() Return an instance of ResponseStateManager to handle rendering technology specific state management decisions.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RenderKit

public RenderKit()
Method Detail

addRenderer

public abstract void addRenderer(String family,
                                 String rendererType,
                                 Renderer renderer)

Register the specified Renderer instance, associated with the specified component family and rendererType, to the set of Renderers registered with this RenderKit, replacing any previously registered Renderer for this combination of identifiers.

Parameters:
family - Component family of the Renderer to register
rendererType - Renderer type of the Renderer to register
renderer - Renderer instance we are registering
Throws:
NullPointerException - if family or rendererType or renderer is null

getRenderer

public abstract Renderer getRenderer(String family,
                                     String rendererType)

Return the Renderer instance most recently registered for the specified component family and rendererType, if any; otherwise, return null.

Parameters:
family - Component family of the requested Renderer instance
rendererType - Renderer type of the requested Renderer instance
Throws:
NullPointerException - if family or rendererType is null

getResponseStateManager

public abstract ResponseStateManager getResponseStateManager()

Return an instance of ResponseStateManager to handle rendering technology specific state management decisions.

createResponseWriter

public abstract ResponseWriter createResponseWriter(Writer writer,
                                                    String contentTypeList,
                                                    String characterEncoding)

Use the provided Writer to create a new ResponseWriter instance for the specified (optional) content type, and character encoding.

Implementors are advised to consult the getCharacterEncoding() method of class ServletResponse to get the required value for the characterEncoding for this method. Since the Writer for this response will already have been obtained (due to it ultimately being passed to this method), we know that the character encoding cannot change during the rendering of the response.

Parameters:
writer - the Writer around which this ResponseWriter must be built.
contentTypeList - an "Accept header style" list of content types for this response, or null if the RenderKit should choose the best fit. As of the current version, the values accepted by the Standard render-kit for this parameter include any valid "Accept header style" String that includes the String text/html, application/xhtml+xml, application/xml or text/xml. This may change in a future version. The RenderKit must support a value for this argument that comes straight from the Accept HTTP header, and therefore requires parsing according to the specification of the Accept header. Please see Section 14.1 of RFC 2616 for the specification of the Accept header.
characterEncoding - such as "ISO-8859-1" for this ResponseWriter, or null if the RenderKit should choose the best fit. Please see the IANA for a list of character encodings.
Returns:
a new ResponseWriter.
Throws:
IllegalArgumentException - if no matching content type can be found in contentTypeList, no appropriate content type can be found with the implementation dependent best fit algorithm, or no matching character encoding can be found for the argument characterEncoding.

createResponseStream

public abstract ResponseStream createResponseStream(OutputStream out)

Use the provided OutputStream to create a new ResponseStream instance.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RenderKitFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.render
Class RenderKitFactory

java.lang.Object
    extended by  javax.faces.render.RenderKitFactory

public abstract class RenderKitFactory
extends Object

RenderKitFactory is a factory object that registers and returns RenderKit instances. Implementations of JavaServer Faces must provide at least a default implementation of RenderKit. Advanced implementations (or external third party libraries) may provide additional RenderKit implementations (keyed by render kit identifiers) for performing different types of rendering for the same components.

There must be one RenderKitFactory instance per web application that is utilizing JavaServer Faces. This instance can be acquired, in a portable manner, by calling:

   RenderKitFactory factory = (RenderKitFactory)
    FactoryFinder.getFactory(FactoryFinder.RENDER_KIT_FACTORY);

Field Summary
static String HTML_BASIC_RENDER_KIT
The render kit identifier of the default RenderKit instance for this JavaServer Faces implementation.
Constructor Summary
RenderKitFactory()
Method Summary
abstract void | addRenderKit(String renderKitId, RenderKit renderKit) Register the specified RenderKit instance, associated with the specified renderKitId, to be supported by this RenderKitFactory, replacing any previously registered RenderKit for this identifier.
abstract RenderKit | getRenderKit(FacesContext context, String renderKitId) Return a RenderKit instance for the specified render kit identifier, possibly customized based on dynamic characteristics of the specified FacesContext, if non-null.
abstract Iterator<String> | getRenderKitIds() Return an Iterator over the set of render kit identifiers registered with this factory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

HTML_BASIC_RENDER_KIT

public static final String HTML_BASIC_RENDER_KIT

The render kit identifier of the default RenderKit instance for this JavaServer Faces implementation.

See Also:
Constant Field Values
Constructor Detail

RenderKitFactory

public RenderKitFactory()
Method Detail

addRenderKit

public abstract void addRenderKit(String renderKitId,
                                  RenderKit renderKit)

Register the specified RenderKit instance, associated with the specified renderKitId, to be supported by this RenderKitFactory, replacing any previously registered RenderKit for this identifier.

Parameters:
renderKitId - Identifier of the RenderKit to register
renderKit - RenderKit instance that we are registering
Throws:
NullPointerException - if renderKitId or renderKit is null

getRenderKit

public abstract RenderKit getRenderKit(FacesContext context,
                                       String renderKitId)

Return a RenderKit instance for the specified render kit identifier, possibly customized based on dynamic characteristics of the specified FacesContext, if non-null. If there is no registered RenderKit for the specified identifier, return null. The set of available render kit identifiers is available via the getRenderKitIds() method.

Parameters:
context - FacesContext for the request currently being processed, or null if none is available.
renderKitId - Render kit identifier of the requested RenderKit instance
Throws:
IllegalArgumentException - if no RenderKit instance can be returned for the specified identifier
NullPointerException - if renderKitId is null

getRenderKitIds

public abstract Iterator<String> getRenderKitIds()

Return an Iterator over the set of render kit identifiers registered with this factory. This set must include the value specified by RenderKitFactory.HTML_BASIC_RENDER_KIT.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResponseStateManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.render
Class ResponseStateManager

java.lang.Object
    extended by  javax.faces.render.ResponseStateManager

public abstract class ResponseStateManager
extends Object

ResponseStateManager is the helper class to StateManager that knows the specific rendering technology being used to generate the response. It is a singleton abstract class, vended by the RenderKit. This class knows the mechanics of saving state, whether it be in hidden fields, session, or some combination of the two.

Field Summary
static String | RENDER_KIT_ID_PARAM The name of the request parameter used by the default implementation of ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext) to derive a RenderKit ID.
static String | VIEW_STATE_PARAM Implementations must use this value as the name and id of the client parameter in which to save the state between requests.
Constructor Summary
ResponseStateManager()
Method Summary
 Object getComponentStateToRestore(FacesContext context)
Deprecated. This method has been replaced by getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.
 Object getState(FacesContext context, String viewId)
The implementation must inspect the current request and return an Object representing the tree structure and component state passed in to a previous invocation of writeState(javax.faces.context.FacesContext,java.lang.Object).
 Object getTreeStructureToRestore(FacesContext context, String viewId)
Deprecated. This method has been replaced by getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.
 boolean isPostback(FacesContext context)
Return true if the current request is a postback.
 void writeState(FacesContext context, Object state)
 void writeState(FacesContext context, StateManager.SerializedView state)
Deprecated. This method has been replaced by writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation of this method does nothing.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

RENDER_KIT_ID_PARAM

public static final String RENDER_KIT_ID_PARAM

The name of the request parameter used by the default implementation of ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext) to derive a RenderKit ID.

See Also:
Constant Field Values

VIEW_STATE_PARAM

public static final String VIEW_STATE_PARAM

Implementations must use this value as the name and id of the client parameter in which to save the state between requests.

Since:
1.2
See Also:
Constant Field Values
Constructor Detail

ResponseStateManager

public ResponseStateManager()
Method Detail

writeState

public void writeState(FacesContext context,
                       Object state)
                throws IOException
Throws:
IOException

writeState

public void writeState(FacesContext context,
                       StateManager.SerializedView state)
                throws IOException
Deprecated. This method has been replaced by writeState(javax.faces.context.FacesContext,java.lang.Object). The default implementation of this method does nothing.

Take the argument state and write it into the output using the current ResponseWriter, which must be correctly positioned already.

If the StateManager.SerializedView is to be written out to hidden fields, the implementation must take care to make all necessary character replacements to make the Strings suitable for inclusion as an HTTP request paramater.

If the state saving method for this application is StateManager.STATE_SAVING_METHOD_CLIENT, the implementation may encrypt the state to be saved to the client. We recommend that the state be unreadable by the client, and also be tamper evident. The reference implementation follows these recommendations.

Parameters:
context - The FacesContext instance for the current request
state - The serialized state information previously saved
Throws:
IOException

getState

public Object getState(FacesContext context,
                       String viewId)

The implementation must inspect the current request and return an Object representing the tree structure and component state passed in to a previous invocation of writeState(javax.faces.context.FacesContext,java.lang.Object).

For backwards compatability with existing ResponseStateManager implementations, the default implementation of this method calls getTreeStructureToRestore(javax.faces.context.FacesContext, java.lang.String) and getComponentStateToRestore(javax.faces.context.FacesContext) and creates and returns a two element Object array with element zero containing the structure property and element one containing the state property of the SerializedView.

Parameters:
context - The FacesContext instance for the current request
viewId - View identifier of the view to be restored
Returns:
the tree structure and component state Object passed in to writeState. If this is an initial request, this method returns null.
Since:
1.2

getTreeStructureToRestore

public Object getTreeStructureToRestore(FacesContext context,
                                        String viewId)
Deprecated. This method has been replaced by getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.

The implementation must inspect the current request and return the tree structure Object passed to it on a previous invocation of writeState().

Parameters:
context - The FacesContext instance for the current request
viewId - View identifier of the view to be restored

getComponentStateToRestore

public Object getComponentStateToRestore(FacesContext context)
Deprecated. This method has been replaced by getState(javax.faces.context.FacesContext, java.lang.String). The default implementation returns null.

The implementation must inspect the current request and return the component state Object passed to it on a previous invocation of writeState().

Parameters:
context - The FacesContext instance for the current request

isPostback

public boolean isPostback(FacesContext context)

Return true if the current request is a postback. This method is leveraged from the Restore View Phase to determine if ViewHandler.restoreView(javax.faces.context.FacesContext, java.lang.String) or ViewHandler.createView(javax.faces.context.FacesContext, java.lang.String) should be called. The default implementation must return true if this ResponseStateManager instance wrote out state on a previous request to which this request is a postback, false otherwise.

The implementation if this method for the Standard HTML RenderKit must consult the ExternalContext's requestParameterMap and return true if and only if there is a key equal to the value of the symbolic constant VIEW_STATE_PARAM.

For backwards compatability with implementations of ResponseStateManager prior to JSF 1.2, a default implementation is provided that consults the ExternalContext's requestParameterMap and return true if its size is greater than 0.

Since:
1.2
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


validator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.faces.validator

Interface defining the validator model, and concrete validator implementation classes.

See:
Description

Interface Summary
Validator A Validator implementation is a class that can perform validation (correctness checks) on a EditableValueHolder.

Class Summary
DoubleRangeValidator | DoubleRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values.
LengthValidator | LengthValidator is a Validator that checks the number of characters in the String representation of the value of the associated component.
LongRangeValidator | LongRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values.
MethodExpressionValidator | MethodExpressionValidator is a Validator that wraps a MethodExpression, and it performs validation by executing a method on an object identified by the MethodExpression.

Exception Summary
ValidatorException A ValidatorException is an exception thrown by the validate() method of a Validator to indicate that validation failed.

Package javax.faces.validator Description

Interface defining the validator model, and concrete validator implementation classes.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.faces.validator Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.faces.validator

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.validator.DoubleRangeValidator (implements javax.faces.component.StateHolder, javax.faces.validator.Validator)
    • javax.faces.validator.LengthValidator (implements javax.faces.component.StateHolder, javax.faces.validator.Validator)
    • javax.faces.validator.LongRangeValidator (implements javax.faces.component.StateHolder, javax.faces.validator.Validator)
    • javax.faces.validator.MethodExpressionValidator (implements javax.faces.component.StateHolder, javax.faces.validator.Validator)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.faces.FacesException
            • javax.faces.validator.ValidatorException

Interface Hierarchy

  • java.util.EventListener
    • javax.faces.validator.Validator
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DoubleRangeValidator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.validator
Class DoubleRangeValidator

java.lang.Object
    extended by  javax.faces.validator.DoubleRangeValidator
All Implemented Interfaces:
EventListener, StateHolder, Validator
public class DoubleRangeValidator
extends Object
implements Validator, StateHolder

DoubleRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values. The following algorithm is implemented:

  • If the passed value is null, exit immediately.
  • If the current component value is not a floating point type, or a String that is convertible to double, throw a ValidatorException containing a TYPE_MESSAGE_ID message.
  • If both a maximum and minimum property has been configured on this Validator, check the component value against both limits. If the component value is not within this specified range, throw a ValidatorException containing a NOT_IN_RANGE_MESSAGE_ID message.
  • If a maximum property has been configured on this Validator, check the component value against this limit. If the component value is greater than the specified maximum, throw a ValidatorException containing a MAXIMUM_MESSAGE_ID message.
  • If a minimum property has been configured on this Validator, check the component value against this limit. If the component value is less than the specified minimum, throw a ValidatorException containing a MINIMUM_MESSAGE_ID message.

For all of the above cases that cause a ValidatorException to be thrown, if there are parameters to the message that match up with validator parameters, the values of these parameters must be converted using the Converter registered in the application under the converter id javax.faces.Number. This allows the values to be localized according to the current Locale.

Field Summary
static String | MAXIMUM_MESSAGE_ID The message identifier of the FacesMessage to be created if the maximum value check fails.
static String | MINIMUM_MESSAGE_ID The message identifier of the FacesMessage to be created if the minimum value check fails.
static String | NOT_IN_RANGE_MESSAGE_ID The message identifier of the FacesMessage to be created if the maximum or minimum value check fails, and both the maximum and minimum values for this validator have been set.
static String | TYPE_MESSAGE_ID The message identifier of the FacesMessage to be created if the current value of this component is not of the correct type.
static String | VALIDATOR_ID The standard converter id for this converter.
Constructor Summary
DoubleRangeValidator()
Construct a Validator with no preconfigured limits.
DoubleRangeValidator(double maximum)
Construct a Validator with the specified preconfigured limit.
DoubleRangeValidator(double maximum, double minimum)
Construct a Validator with the specified preconfigured limits.
Method Summary
boolean | equals(Object otherObj)
double | getMaximum() Return the maximum value to be enforced by this Validator or Double.MAX_VALUE if it has not been set.
double | getMinimum() Return the minimum value to be enforced by this Validator, or Double.MIN_VALUE if it has not been set.
int | hashCode()
boolean | isTransient() If true, the Object implementing this interface must not participate in state saving or restoring.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setMaximum(double maximum) Set the maximum value to be enforced by this Validator.
void | setMinimum(double minimum) Set the minimum value to be enforced by this Validator.
void | setTransient(boolean transientValue) Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
void | validate(FacesContext context, UIComponent component, Object value) Perform the correctness checks implemented by this Validator against the specified UIComponent.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

VALIDATOR_ID

public static final String VALIDATOR_ID

The standard converter id for this converter.

See Also:
Constant Field Values

MAXIMUM_MESSAGE_ID

public static final String MAXIMUM_MESSAGE_ID

The message identifier of the FacesMessage to be created if the maximum value check fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the configured maximum value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

MINIMUM_MESSAGE_ID

public static final String MINIMUM_MESSAGE_ID

The message identifier of the FacesMessage to be created if the minimum value check fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the configured minimum value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

NOT_IN_RANGE_MESSAGE_ID

public static final String NOT_IN_RANGE_MESSAGE_ID

The message identifier of the FacesMessage to be created if the maximum or minimum value check fails, and both the maximum and minimum values for this validator have been set. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the configured minimum value.
  • {1} replaced by the configured maximum value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

TYPE_MESSAGE_ID

public static final String TYPE_MESSAGE_ID

The message identifier of the FacesMessage to be created if the current value of this component is not of the correct type. The message format string for this message may optionally include a {0} placeholder that will be replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

DoubleRangeValidator

public DoubleRangeValidator()

Construct a Validator with no preconfigured limits.

DoubleRangeValidator

public DoubleRangeValidator(double maximum)

Construct a Validator with the specified preconfigured limit.

Parameters:
maximum - Maximum value to allow

DoubleRangeValidator

public DoubleRangeValidator(double maximum,
                            double minimum)

Construct a Validator with the specified preconfigured limits.

Parameters:
maximum - Maximum value to allow
minimum - Minimum value to allow
Method Detail

getMaximum

public double getMaximum()

Return the maximum value to be enforced by this Validator or Double.MAX_VALUE if it has not been set.

setMaximum

public void setMaximum(double maximum)

Set the maximum value to be enforced by this Validator.

Parameters:
maximum - The new maximum value

getMinimum

public double getMinimum()

Return the minimum value to be enforced by this Validator, or Double.MIN_VALUE if it has not been set.

setMinimum

public void setMinimum(double minimum)

Set the minimum value to be enforced by this Validator.

Parameters:
minimum - The new minimum value

validate

public void validate(FacesContext context,
                     UIComponent component,
                     Object value)
              throws ValidatorException
Description copied from interface: Validator

Perform the correctness checks implemented by this Validator against the specified UIComponent. If any violations are found, a ValidatorException will be thrown containing the FacesMessage describing the failure.

Specified by:
validate in interface Validator
Parameters:
context - FacesContext for the request we are processing
component - UIComponent we are checking for correctness
value - the value to validate
Throws:
NullPointerException - if context or component is null
ValidatorException - if validation fails

equals

public boolean equals(Object otherObj)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder

isTransient

public boolean isTransient()
Description copied from interface: StateHolder

If true, the Object implementing this interface must not participate in state saving or restoring.

Specified by:
isTransient in interface StateHolder

setTransient

public void setTransient(boolean transientValue)
Description copied from interface: StateHolder

Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

Specified by:
setTransient in interface StateHolder
Parameters:
transientValue - boolean pass true if this Object will participate in state saving or restoring, otherwise pass false.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LengthValidator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.validator
Class LengthValidator

java.lang.Object
    extended by  javax.faces.validator.LengthValidator
All Implemented Interfaces:
EventListener, StateHolder, Validator
public class LengthValidator
extends Object
implements Validator, StateHolder

LengthValidator is a Validator that checks the number of characters in the String representation of the value of the associated component. The following algorithm is implemented:

  • Convert the passed value to a String, if necessary, by calling its toString() method.
  • If a maximum property has been configured on this Validator, check the length of the converted String against this limit. If the String length is larger than the specified maximum, throw a ValidatorException containing a a MAXIMUM_MESSAGE_ID message.
  • If a minimum property has been configured on this Validator, check the length of the converted String against this limit. If the String length is less than the specified minimum, throw a ValidatorException containing a a MINIMUM_MESSAGE_ID message.

For all of the above cases that cause a ValidatorException to be thrown, if there are parameters to the message that match up with validator parameters, the values of these parameters must be converted using the Converter registered in the application under the converter id javax.faces.Number. This allows the values to be localized according to the current Locale.

Field Summary
static String | MAXIMUM_MESSAGE_ID The message identifier of the FacesMessage to be created if the maximum length check fails.
static String | MINIMUM_MESSAGE_ID The message identifier of the FacesMessage to be created if the minimum length check fails.
static String | VALIDATOR_ID The standard validator id for this validator.
Fields inherited from interface javax.faces.validator.Validator
NOT_IN_RANGE_MESSAGE_ID
Constructor Summary
LengthValidator()
Construct a Validator with no preconfigured limits.
LengthValidator(int maximum)
Construct a Validator with the specified preconfigured limit.
LengthValidator(int maximum, int minimum)
Construct a Validator with the specified preconfigured limits.
Method Summary
boolean | equals(Object otherObj)
int | getMaximum() Return the maximum length to be enforced by this Validator, or 0 if the maximum has not been set.
int | getMinimum() Return the minimum length to be enforced by this Validator, or 0 if the minimum has not been set.
int | hashCode()
boolean | isTransient() If true, the Object implementing this interface must not participate in state saving or restoring.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setMaximum(int maximum) Set the maximum length to be enforced by this Validator.
void | setMinimum(int minimum) Set the minimum length to be enforced by this Validator.
void | setTransient(boolean transientValue) Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
void | validate(FacesContext context, UIComponent component, Object value) Perform the correctness checks implemented by this Validator against the specified UIComponent.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

VALIDATOR_ID

public static final String VALIDATOR_ID

The standard validator id for this validator.

See Also:
Constant Field Values

MAXIMUM_MESSAGE_ID

public static final String MAXIMUM_MESSAGE_ID

The message identifier of the FacesMessage to be created if the maximum length check fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the configured maximum length.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

MINIMUM_MESSAGE_ID

public static final String MINIMUM_MESSAGE_ID

The message identifier of the FacesMessage to be created if the minimum length check fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the configured minimum length.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

LengthValidator

public LengthValidator()

Construct a Validator with no preconfigured limits.

LengthValidator

public LengthValidator(int maximum)

Construct a Validator with the specified preconfigured limit.

Parameters:
maximum - Maximum value to allow

LengthValidator

public LengthValidator(int maximum,
                       int minimum)

Construct a Validator with the specified preconfigured limits.

Parameters:
maximum - Maximum value to allow
minimum - Minimum value to allow
Method Detail

getMaximum

public int getMaximum()

Return the maximum length to be enforced by this Validator, or 0 if the maximum has not been set.

setMaximum

public void setMaximum(int maximum)

Set the maximum length to be enforced by this Validator.

Parameters:
maximum - The new maximum value

getMinimum

public int getMinimum()

Return the minimum length to be enforced by this Validator, or 0 if the minimum has not been set.

setMinimum

public void setMinimum(int minimum)

Set the minimum length to be enforced by this Validator.

Parameters:
minimum - The new minimum value

validate

public void validate(FacesContext context,
                     UIComponent component,
                     Object value)
              throws ValidatorException
Description copied from interface: Validator

Perform the correctness checks implemented by this Validator against the specified UIComponent. If any violations are found, a ValidatorException will be thrown containing the FacesMessage describing the failure.

Specified by:
validate in interface Validator
Parameters:
context - FacesContext for the request we are processing
component - UIComponent we are checking for correctness
value - the value to validate
Throws:
NullPointerException - if context or component is null
ValidatorException - if validation fails

equals

public boolean equals(Object otherObj)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder

isTransient

public boolean isTransient()
Description copied from interface: StateHolder

If true, the Object implementing this interface must not participate in state saving or restoring.

Specified by:
isTransient in interface StateHolder

setTransient

public void setTransient(boolean transientValue)
Description copied from interface: StateHolder

Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

Specified by:
setTransient in interface StateHolder
Parameters:
transientValue - boolean pass true if this Object will participate in state saving or restoring, otherwise pass false.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LongRangeValidator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.validator
Class LongRangeValidator

java.lang.Object
    extended by  javax.faces.validator.LongRangeValidator
All Implemented Interfaces:
EventListener, StateHolder, Validator
public class LongRangeValidator
extends Object
implements Validator, StateHolder

LongRangeValidator is a Validator that checks the value of the corresponding component against specified minimum and maximum values. The following algorithm is implemented:

  • If the passed value is null, exit immediately.
  • If the current component value is not a floating point type, or a String that is convertible to long, throw a ValidatorException containing a TYPE_MESSAGE_ID message.
  • If both a maximum and minimum property has been configured on this Validator, check the component value against both limits. If the component value is not within this specified range, throw a ValidatorException containing a NOT_IN_RANGE_MESSAGE_ID message.
  • If a maximum property has been configured on this Validator, check the component value against this limit. If the component value is greater than the specified maximum, throw a ValidatorException containing a MAXIMUM_MESSAGE_ID message.
  • If a minimum property has been configured on this Validator, check the component value against this limit. If the component value is less than the specified minimum, throw a ValidatorException containing a MINIMUM_MESSAGE_ID message.

For all of the above cases that cause a ValidatorException to be thrown, if there are parameters to the message that match up with validator parameters, the values of these parameters must be converted using the Converter registered in the application under the converter id javax.faces.Number. This allows the values to be localized according to the current Locale.

Field Summary
static String | MAXIMUM_MESSAGE_ID The message identifier of the FacesMessage to be created if the maximum value check fails.
static String | MINIMUM_MESSAGE_ID The message identifier of the FacesMessage to be created if the minimum value check fails.
static String | NOT_IN_RANGE_MESSAGE_ID The message identifier of the FacesMessage to be created if the maximum or minimum value check fails, and both the maximum and minimum values for this validator have been set.
static String | TYPE_MESSAGE_ID The message identifier of the FacesMessage to be created if the current value of this component is not of the correct type.
static String | VALIDATOR_ID The standard converter id for this converter.
Constructor Summary
LongRangeValidator()
Construct a Validator with no preconfigured limits.
LongRangeValidator(long maximum)
Construct a Validator with the specified preconfigured limit.
LongRangeValidator(long maximum, long minimum)
Construct a Validator with the specified preconfigured limits.
Method Summary
boolean | equals(Object otherObj)
long | getMaximum() Return the maximum value to be enforced by this Validator.
long | getMinimum() Return the minimum value to be enforced by this Validator.
int | hashCode()
boolean | isTransient() If true, the Object implementing this interface must not participate in state saving or restoring.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setMaximum(long maximum) Set the maximum value to be enforced by this Validator.
void | setMinimum(long minimum) Set the minimum value to be enforced by this Validator.
void | setTransient(boolean transientValue) Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
void | validate(FacesContext context, UIComponent component, Object value) Perform the correctness checks implemented by this Validator against the specified UIComponent.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

VALIDATOR_ID

public static final String VALIDATOR_ID

The standard converter id for this converter.

See Also:
Constant Field Values

MAXIMUM_MESSAGE_ID

public static final String MAXIMUM_MESSAGE_ID

The message identifier of the FacesMessage to be created if the maximum value check fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the configured maximum value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

MINIMUM_MESSAGE_ID

public static final String MINIMUM_MESSAGE_ID

The message identifier of the FacesMessage to be created if the minimum value check fails. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the configured minimum value.
  • {1} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

NOT_IN_RANGE_MESSAGE_ID

public static final String NOT_IN_RANGE_MESSAGE_ID

The message identifier of the FacesMessage to be created if the maximum or minimum value check fails, and both the maximum and minimum values for this validator have been set. The message format string for this message may optionally include the following placeholders:

  • {0} replaced by the configured minimum value.
  • {1} replaced by the configured maximum value.
  • {2} replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values

TYPE_MESSAGE_ID

public static final String TYPE_MESSAGE_ID

The message identifier of the FacesMessage to be created if the current value of this component is not of the correct type. The message format string for this message may optionally include a {0} placeholder that will be replaced by a String whose value is the label of the input component that produced this message.

See Also:
Constant Field Values
Constructor Detail

LongRangeValidator

public LongRangeValidator()

Construct a Validator with no preconfigured limits.

LongRangeValidator

public LongRangeValidator(long maximum)

Construct a Validator with the specified preconfigured limit.

Parameters:
maximum - Maximum value to allow

LongRangeValidator

public LongRangeValidator(long maximum,
                          long minimum)

Construct a Validator with the specified preconfigured limits.

Parameters:
maximum - Maximum value to allow
minimum - Minimum value to allow
Method Detail

getMaximum

public long getMaximum()

Return the maximum value to be enforced by this Validator.

setMaximum

public void setMaximum(long maximum)

Set the maximum value to be enforced by this Validator.

Parameters:
maximum - The new maximum value

getMinimum

public long getMinimum()

Return the minimum value to be enforced by this Validator.

setMinimum

public void setMinimum(long minimum)

Set the minimum value to be enforced by this Validator.

Parameters:
minimum - The new minimum value

validate

public void validate(FacesContext context,
                     UIComponent component,
                     Object value)
              throws ValidatorException
Description copied from interface: Validator

Perform the correctness checks implemented by this Validator against the specified UIComponent. If any violations are found, a ValidatorException will be thrown containing the FacesMessage describing the failure.

Specified by:
validate in interface Validator
Parameters:
context - FacesContext for the request we are processing
component - UIComponent we are checking for correctness
value - the value to validate
Throws:
NullPointerException - if context or component is null
ValidatorException - if validation fails

equals

public boolean equals(Object otherObj)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder

isTransient

public boolean isTransient()
Description copied from interface: StateHolder

If true, the Object implementing this interface must not participate in state saving or restoring.

Specified by:
isTransient in interface StateHolder

setTransient

public void setTransient(boolean transientValue)
Description copied from interface: StateHolder

Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

Specified by:
setTransient in interface StateHolder
Parameters:
transientValue - boolean pass true if this Object will participate in state saving or restoring, otherwise pass false.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MethodExpressionValidator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.validator
Class MethodExpressionValidator

java.lang.Object
    extended by  javax.faces.validator.MethodExpressionValidator
All Implemented Interfaces:
EventListener, StateHolder, Validator
public class MethodExpressionValidator
extends Object
implements Validator, StateHolder

MethodExpressionValidator is a Validator that wraps a MethodExpression, and it performs validation by executing a method on an object identified by the MethodExpression.

Field Summary
Fields inherited from interface javax.faces.validator.Validator
NOT_IN_RANGE_MESSAGE_ID
Constructor Summary
MethodExpressionValidator()
MethodExpressionValidator(MethodExpression methodExpression)
Construct a Validator that contains a MethodExpression.
Method Summary
boolean | isTransient() If true, the Object implementing this interface must not participate in state saving or restoring.
void | restoreState(FacesContext context, Object state) Perform any processing required to restore the state from the entries in the state Object.
Object | saveState(FacesContext context) Gets the state of the instance as a Serializable Object.
void | setTransient(boolean transientValue) Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.
void | validate(FacesContext context, UIComponent component, Object value) Perform the correctness checks implemented by this Validator against the specified UIComponent.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MethodExpressionValidator

public MethodExpressionValidator()

MethodExpressionValidator

public MethodExpressionValidator(MethodExpression methodExpression)

Construct a Validator that contains a MethodExpression.

Method Detail

validate

public void validate(FacesContext context,
                     UIComponent component,
                     Object value)
              throws ValidatorException
Description copied from interface: Validator

Perform the correctness checks implemented by this Validator against the specified UIComponent. If any violations are found, a ValidatorException will be thrown containing the FacesMessage describing the failure.

Specified by:
validate in interface Validator
Parameters:
context - FacesContext for the request we are processing
component - UIComponent we are checking for correctness
value - the value to validate
Throws:
NullPointerException - if context or component is null
ValidatorException - if validation fails

saveState

public Object saveState(FacesContext context)
Description copied from interface: StateHolder

Gets the state of the instance as a Serializable Object.

If the class that implements this interface has references to instances that implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.saveState(javax.faces.context.FacesContext) method on all those instances as well. This method must not save the state of children and facets. That is done via the StateManager

This method must not alter the state of the implementing object. In other words, after executing this code:

 Object state = component.saveState(facesContext);

component should be the same as before executing it.

The return from this method must be Serializable

Specified by:
saveState in interface StateHolder

restoreState

public void restoreState(FacesContext context,
                         Object state)
Description copied from interface: StateHolder

Perform any processing required to restore the state from the entries in the state Object.

If the class that implements this interface has references to instances that also implement StateHolder (such as a UIComponent with event handlers, validators, etc.) this method must call the StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object) method on all those instances as well.

Specified by:
restoreState in interface StateHolder

isTransient

public boolean isTransient()
Description copied from interface: StateHolder

If true, the Object implementing this interface must not participate in state saving or restoring.

Specified by:
isTransient in interface StateHolder

setTransient

public void setTransient(boolean transientValue)
Description copied from interface: StateHolder

Denotes whether or not the Object implementing this interface must or must not participate in state saving or restoring.

Specified by:
setTransient in interface StateHolder
Parameters:
transientValue - boolean pass true if this Object will participate in state saving or restoring, otherwise pass false.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Validator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.validator
Interface Validator

All Superinterfaces:
EventListener
All Known Implementing Classes:
DoubleRangeValidator, LengthValidator, LongRangeValidator, MethodExpressionValidator
public interface Validator
extends EventListener

A Validator implementation is a class that can perform validation (correctness checks) on a EditableValueHolder. Zero or more Validators can be associated with each EditableValueHolder in the view, and are called during the Process Validations phase of the request processing lifecycle.

Individual Validators should examine the value and component that they are passed, and throw a ValidatorException containing a FacesMessage, documenting any failures to conform to the required rules.

For maximum generality, Validator instances may be configurable based on properties of the Validator implementation class. For example, a range check Validator might support configuration of the minimum and maximum values to be used.

Validator implementations must have a zero-arguments public constructor. In addition, if the Validator class wishes to have configuration property values saved and restored with the view, the implementation must also implement StateHolder.

Field Summary
static String NOT_IN_RANGE_MESSAGE_ID
Deprecated. Use DoubleRangeValidator.NOT_IN_RANGE_MESSAGE_ID or LongRangeValidator.NOT_IN_RANGE_MESSAGE_ID instead.
Method Summary
 void validate(FacesContext context, UIComponent component, Object value)
Perform the correctness checks implemented by this Validator against the specified UIComponent.

Field Detail

NOT_IN_RANGE_MESSAGE_ID

static final String NOT_IN_RANGE_MESSAGE_ID
Deprecated. Use DoubleRangeValidator.NOT_IN_RANGE_MESSAGE_ID or LongRangeValidator.NOT_IN_RANGE_MESSAGE_ID instead.

The message identifier of the FacesMessage to be created if the maximum or minimum value check fails, and both the maximum and minimum values for this validator have been set. The message format string for this message may optionally include a {0} placeholder, which will be replaced by the configured minimum value, and a {1} placeholder, which will be replaced by the configured maximum value.

See Also:
Constant Field Values
Method Detail

validate

void validate(FacesContext context,
              UIComponent component,
              Object value)
              throws ValidatorException

Perform the correctness checks implemented by this Validator against the specified UIComponent. If any violations are found, a ValidatorException will be thrown containing the FacesMessage describing the failure.

Parameters:
context - FacesContext for the request we are processing
component - UIComponent we are checking for correctness
value - the value to validate
Throws:
ValidatorException - if validation fails
NullPointerException - if context or component is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValidatorException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.validator
Class ValidatorException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.faces.FacesException
                    extended by  javax.faces.validator.ValidatorException
All Implemented Interfaces:
Serializable
public class ValidatorException
extends FacesException

A ValidatorException is an exception thrown by the validate() method of a Validator to indicate that validation failed.

See Also:
Serialized Form

Constructor Summary
ValidatorException(FacesMessage message)
Construct a new exception with the specified message and no root cause.
ValidatorException(FacesMessage message, Throwable cause)
Construct a new exception with the specified detail message and root cause.
Method Summary
 FacesMessage getFacesMessage()
Returns the FacesMessage associated with the exception.
Methods inherited from class javax.faces.FacesException
getCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ValidatorException

public ValidatorException(FacesMessage message)

Construct a new exception with the specified message and no root cause.

Parameters:
message - The message for this exception

ValidatorException

public ValidatorException(FacesMessage message,
                          Throwable cause)

Construct a new exception with the specified detail message and root cause.

Parameters:
message - The detail message for this exception
cause - The root cause for this exception
Method Detail

getFacesMessage

public FacesMessage getFacesMessage()
Returns the FacesMessage associated with the exception.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


webapp

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.faces.webapp

Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

See:
Description

Class Summary
AttributeTag | Deprecated. The Faces implementation must now provide the implementation for this class.
ConverterELTag | ConverterELTag is a base class for all JSP custom actions that create and register a Converter instance on the ValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentClassicTagBase.
ConverterTag | Deprecated. This has been partially replaced by ConverterELTag.
FacesServlet | FacesServlet is a servlet that manages the request processing lifecycle for web applications that are utilizing JavaServer Faces to construct the user interface.
FacetTag | FacetTag is the JSP mechanism for denoting a UIComponent is to be added as a facet to the component associated with its parent.
UIComponentBodyTag | Deprecated. All component tags now implement BodyTag.
UIComponentClassicTagBase | UIComponentTagBase is the base class for all JSP tags that use the "classic" JSP tag interface that correspond to a UIComponent instance in the view.
UIComponentELTag | UIComponentELTag specializes its superclass to allow for properties that take their values from EL API expressions.
UIComponentTag | Deprecated. Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.
UIComponentTagBase | UIComponentTagBase is the base class for all JSP tags that correspond to a UIComponent instance in the view.
ValidatorELTag | ValidatorELTag is a base class for all JSP custom actions that create and register a Validator instance on the EditableValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentTag.
ValidatorTag | Deprecated. This has been partially replaced by ValidatorELTag.

Package javax.faces.webapp Description

Classes required for integration of JavaServer Faces into web applications, including a standard servlet, base classes for JSP custom component tags, and concrete tag implementations for core tags.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.faces.webapp Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.faces.webapp

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.faces.webapp.FacesServlet (implements javax.servlet.Servlet)
    • javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • javax.faces.webapp.AttributeTag
      • javax.faces.webapp.ConverterELTag
      • javax.faces.webapp.ConverterTag
      • javax.faces.webapp.FacetTag
      • javax.faces.webapp.ValidatorELTag
      • javax.faces.webapp.ValidatorTag
    • javax.faces.webapp.UIComponentTagBase (implements javax.servlet.jsp.tagext.JspTag)
      • javax.faces.webapp.UIComponentClassicTagBase (implements javax.servlet.jsp.tagext.BodyTag, javax.servlet.jsp.tagext.JspIdConsumer)
        • javax.faces.webapp.UIComponentELTag (implements javax.servlet.jsp.tagext.Tag)
        • javax.faces.webapp.UIComponentTag (implements javax.servlet.jsp.tagext.Tag)
          • javax.faces.webapp.UIComponentBodyTag
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AttributeTag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.webapp
Class AttributeTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.faces.webapp.AttributeTag
All Implemented Interfaces:
Serializable, IterationTag, JspTag, Tag
Deprecated. The Faces implementation must now provide the implementation for this class.

public class AttributeTag
extends TagSupport

Tag implementation that adds an attribute with a specified name and String value to the component whose tag it is nested inside, if the component does not already contain an attribute with the same name. This tag creates no output to the page currently being created.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
AttributeTag()
Deprecated.
Method Summary
int | doEndTag() Deprecated. Default processing of the end tag returning EVAL_PAGE.
int | doStartTag() Deprecated. Register the specified attribute name and value with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if this UIComponent does not already have a value for the specified attribute name.
void | release() Deprecated. Release references to any acquired resources.
void | setName(String name) Deprecated. Set the attribute name.
void | setValue(String value) Deprecated. Set the attribute value.
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
doAfterBody, findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AttributeTag

public AttributeTag()
Deprecated.
Method Detail

setName

public void setName(String name)
Deprecated.

Set the attribute name.

Parameters:
name - The new attribute name

setValue

public void setValue(String value)
Deprecated.

Set the attribute value.

Parameters:
value - The new attribute value

doStartTag

public int doStartTag()
               throws JspException
Deprecated.

Register the specified attribute name and value with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if this UIComponent does not already have a value for the specified attribute name.

Specified by:
doStartTag in interface Tag
Overrides:
doStartTag in class TagSupport
Returns:
SKIP_BODY
Throws:
JspException - if a JSP error occurs
See Also:
Tag.doStartTag()

doEndTag

public int doEndTag()
             throws JspException
Deprecated.
Description copied from class: TagSupport
Default processing of the end tag returning EVAL_PAGE.

Specified by:
doEndTag in interface Tag
Overrides:
doEndTag in class TagSupport
Returns:
EVAL_PAGE
Throws:
JspException - if an error occurs while processing this tag
See Also:
Tag.doEndTag()

release

public void release()
Deprecated.

Release references to any acquired resources.

Specified by:
release in interface Tag
Overrides:
release in class TagSupport
See Also:
Tag.release()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConverterELTag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.webapp
Class ConverterELTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.faces.webapp.ConverterELTag
All Implemented Interfaces:
Serializable, IterationTag, JspTag, Tag
public abstract class ConverterELTag
extends TagSupport

ConverterELTag is a base class for all JSP custom actions that create and register a Converter instance on the ValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentClassicTagBase. To avoid creating duplicate instances when a page is redisplayed, creation and registration of a Converter occurs only if the corresponding UIComponent was created (by the owning UIComponentTag) during the execution of the current page.

This class may be used as a base class for tag instances that support specific Converter subclasses.

Subclasses of this class must implement the createConverter() method, which creates and returns a Converter instance. Any configuration properties that specify behavior of this Converter must have been set by the createConverter() method. Generally, this occurs by copying corresponding attribute values on the tag instance.

This tag creates no output to the page currently being created. It is used solely for the side effect of Converter creation.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ConverterELTag()
Method Summary
protected abstract Converter | createConverter() Create and return a new Converter to be registered on our surrounding UIComponent.
int | doStartTag() Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentClassicTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page.
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
doAfterBody, doEndTag, findAncestorWithClass, getId, getParent, getValue, getValues, release, removeValue, setId, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConverterELTag

public ConverterELTag()
Method Detail

doStartTag

public int doStartTag()
               throws JspException

Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentClassicTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page.

Specified by:
doStartTag in interface Tag
Overrides:
doStartTag in class TagSupport
Returns:
SKIP_BODY
Throws:
JspException - if a JSP error occurs
See Also:
Tag.doStartTag()

createConverter

protected abstract Converter createConverter()
                                      throws JspException

Create and return a new Converter to be registered on our surrounding UIComponent.

Throws:
JspException - if a new instance cannot be created
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConverterTag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.webapp
Class ConverterTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.faces.webapp.ConverterTag
All Implemented Interfaces:
Serializable, IterationTag, JspTag, Tag
Deprecated. This has been partially replaced by ConverterELTag. The remainder of the functionality, namely, the binding facility and the implementation of the createConverter() method, is now an implementation detail.

public class ConverterTag
extends TagSupport

ConverterTag is a base class for all JSP custom actions that create and register a Converter instance on the ValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentTag. To avoid creating duplicate instances when a page is redisplayed, creation and registration of a Converter occurs only if the corresponding UIComponent was created (by the owning UIComponentTag) during the execution of the current page.

This class may be used directly to implement a generic converter registration tag (based on the converter-id specified by the converterId attribute), or as a base class for tag instances that support specific Converter subclasses. This converterId attribute must refer to one of the well known converter-ids, or a custom converter-id as defined in a faces-config.xml file.

Subclasses of this class must implement the createConverter() method, which creates and returns a Converter instance. Any configuration properties that specify behavior of this Converter must have been set by the createConverter() method. Generally, this occurs by copying corresponding attribute values on the tag instance.

This tag creates no output to the page currently being created. It is used solely for the side effect of Converter creation.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ConverterTag()
Deprecated.
Method Summary
protected Converter | createConverter() Deprecated. Create and return a new Converter to be registered on our surrounding UIComponent.
int | doStartTag() Deprecated. Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page.
void | release() Deprecated. Release references to any acquired resources.
void | setBinding(String binding) Deprecated. Set the expression that will be used to create a ValueExpression that references a backing bean property of the Converter instance to be created.
void | setConverterId(String converterId) Deprecated. Set the identifer of the Converter instance to be created.
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
doAfterBody, doEndTag, findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConverterTag

public ConverterTag()
Deprecated.
Method Detail

setConverterId

public void setConverterId(String converterId)
Deprecated.

Set the identifer of the Converter instance to be created.

Parameters:
converterId - The identifier of the converter instance to be created.

setBinding

public void setBinding(String binding)
                throws JspException
Deprecated.

Set the expression that will be used to create a ValueExpression that references a backing bean property of the Converter instance to be created.

Parameters:
binding - The new expression
Throws:
JspException - if a JSP error occurs

doStartTag

public int doStartTag()
               throws JspException
Deprecated.

Create a new instance of the specified Converter class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page.

Specified by:
doStartTag in interface Tag
Overrides:
doStartTag in class TagSupport
Returns:
SKIP_BODY
Throws:
JspException - if a JSP error occurs
See Also:
Tag.doStartTag()

release

public void release()
Deprecated.

Release references to any acquired resources.

Specified by:
release in interface Tag
Overrides:
release in class TagSupport
See Also:
Tag.release()

createConverter

protected Converter createConverter()
                             throws JspException
Deprecated.

Create and return a new Converter to be registered on our surrounding UIComponent.

Throws:
JspException - if a new instance cannot be created
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FacesServlet

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.webapp
Class FacesServlet

java.lang.Object
    extended by  javax.faces.webapp.FacesServlet
All Implemented Interfaces:
Servlet
public final class FacesServlet
extends Object
implements Servlet

FacesServlet is a servlet that manages the request processing lifecycle for web applications that are utilizing JavaServer Faces to construct the user interface.

Field Summary
static String | CONFIG_FILES_ATTR Context initialization parameter name for a comma delimited list of context-relative resource paths (in addition to /WEB-INF/faces-config.xml which is loaded automatically if it exists) containing JavaServer Faces configuration information.
static String | LIFECYCLE_ID_ATTR Context initialization parameter name for the lifecycle identifier of the Lifecycle instance to be utilized.
Constructor Summary
FacesServlet()
Method Summary
void | destroy() Release all resources acquired at startup time.
ServletConfig | getServletConfig() Return the ServletConfig instance for this servlet.
String | getServletInfo() Return information about this Servlet.
void | init(ServletConfig servletConfig) Acquire the factory instances we will require.
void | service(ServletRequest request, ServletResponse response) Process an incoming request, and create the corresponding response, by executing the request processing lifecycle.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONFIG_FILES_ATTR

public static final String CONFIG_FILES_ATTR

Context initialization parameter name for a comma delimited list of context-relative resource paths (in addition to /WEB-INF/faces-config.xml which is loaded automatically if it exists) containing JavaServer Faces configuration information.

See Also:
Constant Field Values

LIFECYCLE_ID_ATTR

public static final String LIFECYCLE_ID_ATTR

Context initialization parameter name for the lifecycle identifier of the Lifecycle instance to be utilized.

See Also:
Constant Field Values
Constructor Detail

FacesServlet

public FacesServlet()
Method Detail

destroy

public void destroy()

Release all resources acquired at startup time.

Specified by:
destroy in interface Servlet

getServletConfig

public ServletConfig getServletConfig()

Return the ServletConfig instance for this servlet.

Specified by:
getServletConfig in interface Servlet
Returns:
the ServletConfig object that initializes this servlet
See Also:
Servlet.init(javax.servlet.ServletConfig)

getServletInfo

public String getServletInfo()

Return information about this Servlet.

Specified by:
getServletInfo in interface Servlet
Returns:
a String containing servlet information

init

public void init(ServletConfig servletConfig)
          throws ServletException

Acquire the factory instances we will require.

Specified by:
init in interface Servlet
Parameters:
servletConfig - a ServletConfig object containing the servlet's configuration and initialization parameters
Throws:
ServletException - if, for any reason, the startup of this Faces application failed. This includes errors in the config file that is parsed before or during the processing of this init() method.
See Also:
UnavailableException, Servlet.getServletConfig()

service

public void service(ServletRequest request,
                    ServletResponse response)
             throws IOException,
                    ServletException

Process an incoming request, and create the corresponding response, by executing the request processing lifecycle.

If the request and response arguments to this method are not instances of HttpServletRequest and HttpServletResponse, respectively, the results of invoking this method are undefined.

This method must respond to requests that start with the following strings by invoking the sendError method on the response argument (cast to HttpServletResponse), passing the code HttpServletResponse.SC_NOT_FOUND as the argument.

/WEB-INF/
/WEB-INF
/META-INF/
/META-INF

Specified by:
service in interface Servlet
Parameters:
request - The servlet request we are processing
response - The servlet response we are creating
Throws:
IOException - if an input/output error occurs during processing
ServletException - if a servlet error occurs during processing
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FacetTag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.webapp
Class FacetTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.faces.webapp.FacetTag
All Implemented Interfaces:
Serializable, IterationTag, JspTag, Tag
public class FacetTag
extends TagSupport

FacetTag is the JSP mechanism for denoting a UIComponent is to be added as a facet to the component associated with its parent.

A FacetTag must have one and only one child. This child must be a UIComponentTag instance representing a single UIComponent instance.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
FacetTag()
Method Summary
int | doStartTag() Return EVAL_BODY_INCLUDE to cause nested body content to be evaluated.
String | getName() Return the name to be assigned to this facet.
void | release() Release any resources allocated by this tag instance.
void | setName(String name) Set the name to be assigned to this facet.
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
doAfterBody, doEndTag, findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FacetTag

public FacetTag()
Method Detail

getName

public String getName()

Return the name to be assigned to this facet.

setName

public void setName(String name)

Set the name to be assigned to this facet.

Parameters:
name - The new facet name

release

public void release()

Release any resources allocated by this tag instance.

Specified by:
release in interface Tag
Overrides:
release in class TagSupport
See Also:
Tag.release()

doStartTag

public int doStartTag()
               throws JspException

Return EVAL_BODY_INCLUDE to cause nested body content to be evaluated.

Specified by:
doStartTag in interface Tag
Overrides:
doStartTag in class TagSupport
Returns:
SKIP_BODY
Throws:
JspException - if an error occurs while processing this tag
See Also:
Tag.doStartTag()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIComponentBodyTag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.webapp
Class UIComponentBodyTag

java.lang.Object
    extended by  javax.faces.webapp.UIComponentTagBase
        extended by  javax.faces.webapp.UIComponentClassicTagBase
            extended by  javax.faces.webapp.UIComponentTag
                extended by  javax.faces.webapp.UIComponentBodyTag
All Implemented Interfaces:
BodyTag, IterationTag, JspIdConsumer, JspTag, Tag
Deprecated. All component tags now implement BodyTag. This class has been replaced by UIComponentELTag.

public abstract class UIComponentBodyTag
extends UIComponentTag

UIComponentBodyTag is a base class for all JSP custom actions, related to a UIComponent, that need to process their tag bodies.

Field Summary
Fields inherited from class javax.faces.webapp.UIComponentClassicTagBase
bodyContent, pageContext, UNIQUE_ID_PREFIX
Fields inherited from class javax.faces.webapp.UIComponentTagBase
log
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Constructor Summary
UIComponentBodyTag()
Deprecated.
Method Summary
Methods inherited from class javax.faces.webapp.UIComponentTag
createComponent, getParentUIComponentTag, hasBinding, isSuppressed, isValueReference, release, setBinding, setProperties, setRendered
Methods inherited from class javax.faces.webapp.UIComponentClassicTagBase
addChild, addFacet, addVerbatimAfterComponent, addVerbatimBeforeComponent, createVerbatimComponent, createVerbatimComponentFromBodyContent, doAfterBody, doEndTag, doInitBody, doStartTag, encodeBegin, encodeChildren, encodeEnd, findComponent, getBodyContent, getComponentInstance, getCreated, getCreatedComponents, getDoAfterBodyValue, getDoEndValue, getDoStartValue, getFacesContext, getFacesJspId, getFacetName, getId, getIndexOfNextChildTag, getJspId, getParent, getParentUIComponentClassicTagBase, getPreviousOut, setBodyContent, setId, setJspId, setPageContext, setParent, setupResponseWriter
Methods inherited from class javax.faces.webapp.UIComponentTagBase
getComponentType, getELContext, getRendererType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
doEndTag, doStartTag, getParent, setPageContext, setParent

Constructor Detail

UIComponentBodyTag

public UIComponentBodyTag()
Deprecated.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIComponentClassicTagBase

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.webapp
Class UIComponentClassicTagBase

java.lang.Object
    extended by  javax.faces.webapp.UIComponentTagBase
        extended by  javax.faces.webapp.UIComponentClassicTagBase
All Implemented Interfaces:
BodyTag, IterationTag, JspIdConsumer, JspTag, Tag
Direct Known Subclasses:
UIComponentELTag, UIComponentTag
public abstract class UIComponentClassicTagBase
extends UIComponentTagBase
implements JspIdConsumer, BodyTag

UIComponentTagBase is the base class for all JSP tags that use the "classic" JSP tag interface that correspond to a UIComponent instance in the view. In Faces 1.2, all component tags are BodyTag instances to allow for the execution of the page to build the component tree, but not render it. Rendering happens only after the component tree is completely built.

UIComponentTag extends UIComponentClassicTagBase to add support for properties that conform to the Faces 1.1 EL.

UIComponentELTag extends UIComponentClassicTagBase class to add support for properties that conform to the EL API.

The default implementation allows the proper interweaving of template text, non-Faces JSP tag output, and Faces component tag output in the same page, as expected by the page author.

The CASE markers in the following example will be cited in the method descriptions of this class.

  • CASE 1 describes template text and/or non-component custom tag output occurring as the child of a component tag, but before the first component tag child of that component tag.

  • CASE 2 describes template text and/or non-component custom tag output occurring between two sibling component tags.

  • CASE 3 describes template text and/or non-component custom tag output occurring as the child content of an <f:verbatim> tag at any point in the page.

  • CASE 4 describes template text and/or non-component custom tag output occurring between the last child component tag and its enclosing parent component tag's end tag.

    <h:panelGrid style="color:red" border="4" columns="2">
      CASE 1
      <h:outputText value="component 1"/>
      CASE 2
      <h:outputText value="component 2"/>
      <f:verbatim>CASE 3</f:verbatim>
      <c:out value="${pageScope.CASE4}" />
    </h:panelGrid>

The preceding arrangement of faces component tags, must yield markup that will render identically to the following (assuming that ${pageScope.CASE4} evaluates to "CASE 4" without the quotes).

<table border="4" style="color:red">

  <tbody>

    <tr><td>CASE 1</td></tr> <tr><td>component 1</td></tr>

    <tr><td>CASE 2</td> <tr><td>component 2</td></tr>

    <tr><td>CASE 3</td> <td>CASE 4</td></tr>

  </tbody>

</table>

Field Summary
protected BodyContent | bodyContent The bodyContent for this tag handler.
protected PageContext | pageContext The JSP PageContext for the page we are embedded in.
protected static String | UNIQUE_ID_PREFIX Used as the prefix for ids.
Fields inherited from class javax.faces.webapp.UIComponentTagBase
log
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
UIComponentClassicTagBase()
Method Summary
protected  void addChild(UIComponent child)
Add the component identifier of the specified UIComponent to the list of component identifiers created or located by nested UIComponentTags processing this request.
protected  void addFacet(String name)
Add the facet name of the specified facet to the list of facet names created or located by nested UIComponentTags processing this request.
protected  void addVerbatimAfterComponent(UIComponentClassicTagBase parentTag, UIComponent verbatim, UIComponent component)
Add verbatim as a sibling of component in component in the parent's child list.
protected  void addVerbatimBeforeComponent(UIComponentClassicTagBase parentTag, UIComponent verbatim, UIComponent component)
Add verbatim as a sibling of component in component in the parent's child list.
protected abstract  UIComponent createComponent(FacesContext context, String newId)
Create and return a new child component of the type returned by calling getComponentType().
protected  UIOutput createVerbatimComponent()
Use the Application instance to create a new component with the following characteristics.
protected  UIComponent createVerbatimComponentFromBodyContent()
Create a transient UIOutput component from the body content, of this tag instance or return null if there is no body content, the body content is whitespace, or the body content is a comment.
 int doAfterBody()
Perform any processing necessary to handle the content implications of CASE 4 in the class description.
 int doEndTag()
Perform any processing necessary to handle the content implications of CASE 3 in the class description.
 void doInitBody()
Prepare for evaluation of the body.
 int doStartTag()
Perform any processing necessary to find (or create) the UIComponent instance in the view corresponding to this tag instance in the page and, if and only if a component was created, insert it into the tree at the proper location as expected by the page author.
protected  void encodeBegin()
Deprecated. No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
protected  void encodeChildren()
Deprecated. No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
protected  void encodeEnd()
Deprecated. No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.
protected  UIComponent findComponent(FacesContext context)
Find and return the UIComponent, from the component tree, that corresponds to this tag handler instance.
 BodyContent getBodyContent()
 UIComponent getComponentInstance()
Return the UIComponent instance that is associated with this tag instance.
 boolean getCreated()
Return true if we dynamically created a new component instance during execution of this tag.
protected  List<String> getCreatedComponents()
Returns the List of UIComponent ids created or located by nested UIComponentTags while processing the current request.
protected  int getDoAfterBodyValue()
Return the flag value that should be returned from the doAfterBody() method when it is called.
protected  int getDoEndValue()
Return the flag value that should be returned from the doEnd() method when it is called.
protected  int getDoStartValue()
Return the flag value that should be returned from the doStart() method when it is called.
protected  FacesContext getFacesContext()
Return the FacesContext instance for the current request.
protected  String getFacesJspId()
If this method has been called before on this tag's useful lifetime (before release() was called), return the previously returned value.
protected  String getFacetName()
Return the facet name that we should be stored under, if any; otherwise, return null (indicating that we will be a child component).
protected  String getId()
Return the id value assigned by the page author.
protected  int getIndexOfNextChildTag()
Return the index of the next child to be added as a child of this tag.
 String getJspId()
 Tag getParent()
Return the Tag that is the parent of this instance.
static UIComponentClassicTagBase getParentUIComponentClassicTagBase(PageContext context)
Locate and return the nearest enclosing UIComponentClassicTagBase if any; otherwise, return null.
 JspWriter getPreviousOut()
Get the JspWriter from our BodyContent.
protected abstract  boolean hasBinding()
Return true if this component has a non-null binding attribute.
 void release()
Release any resources allocated during the execution of this tag handler.
 void setBodyContent(BodyContent bodyContent)
Set the bodyContent for this tag handler.
 void setId(String id)
Set the component identifier for our component.
 void setJspId(String id)
Defined on JspIdConsumer.
 void setPageContext(PageContext pageContext)
Set the PageContext of the page containing this tag instance.
 void setParent(Tag parent)
Set the Tag that is the parent of this instance.
protected abstract  void setProperties(UIComponent component)
Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set.
protected  void setupResponseWriter()
Set up the ResponseWriter for the current response, if this has not been done already.
Methods inherited from class javax.faces.webapp.UIComponentTagBase
getComponentType, getELContext, getRendererType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UNIQUE_ID_PREFIX

protected static final String UNIQUE_ID_PREFIX
Used as the prefix for ids. This is necessary to avoid uniqueness conflicts with the transient verbatim components.

See Also:
Constant Field Values

bodyContent

protected BodyContent bodyContent

The bodyContent for this tag handler.

pageContext

protected PageContext pageContext

The JSP PageContext for the page we are embedded in.

Constructor Detail

UIComponentClassicTagBase

public UIComponentClassicTagBase()
Method Detail

getDoStartValue

protected int getDoStartValue()
                       throws JspException

Return the flag value that should be returned from the doStart() method when it is called. Subclasses may override this method to return the appropriate value.

Throws:
JspException - to cause doStart() to throw an exception

getDoEndValue

protected int getDoEndValue()
                     throws JspException

Return the flag value that should be returned from the doEnd() method when it is called. Subclasses may override this method to return the appropriate value.

Throws:
JspException - to cause doEnd() to throw an exception

encodeBegin

protected void encodeBegin()
                    throws IOException
Deprecated. No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.

Delegate to the encodeBegin() method of our corresponding UIComponent. This method is called from doStartTag(). Normally, delegation occurs unconditionally; however, this method is abstracted out so that advanced tags can conditionally perform this call.

Throws:
IOException - if an input/output error occurs

encodeChildren

protected void encodeChildren()
                       throws IOException
Deprecated. No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.

Delegate to the encodeChildren() method of our corresponding UIComponent. This method is called from doStartTag(). Normally, delegation occurs unconditionally; however, this method is abstracted out so that advanced tags can conditionally perform this call.

Throws:
IOException - if an input/output error occurs

encodeEnd

protected void encodeEnd()
                  throws IOException
Deprecated. No encoding is done during JSP page execution. Encoding is deferred until the page has completed executing to allow the entire tree to be built before any encoding occurs.

Delegate to the encodeEnd() method of our corresponding UIComponent. This method is called from doStartTag(). Normally, delegation occurs unconditionally; however, this method is abstracted out so that advanced tags can conditionally perform this call.

Throws:
IOException - if an input/output error occurs

setPageContext

public void setPageContext(PageContext pageContext)

Set the PageContext of the page containing this tag instance.

Specified by:
setPageContext in interface Tag
Parameters:
pageContext - The enclosing PageContext

getParent

public Tag getParent()

Return the Tag that is the parent of this instance.

Specified by:
getParent in interface Tag
Returns:
the current parent, or null if none.
See Also:
TagSupport.findAncestorWithClass(javax.servlet.jsp.tagext.Tag, java.lang.Class)

setParent

public void setParent(Tag parent)

Set the Tag that is the parent of this instance.

Specified by:
setParent in interface Tag
Parameters:
parent - The new parent Tag

setupResponseWriter

protected void setupResponseWriter()

Set up the ResponseWriter for the current response, if this has not been done already.

@deprecated. ViewHandler.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot) is now responsible for setting up the response writer. This method is now a no-op.

findComponent

protected UIComponent findComponent(FacesContext context)
                             throws JspException

Find and return the UIComponent, from the component tree, that corresponds to this tag handler instance. If there is no such UIComponent, create one and add it as a child or facet of the UIComponent associated with our nearest enclosing UIComponentTag. The process for locating or creating the component is:

  1. If we have previously located this component, return it.
  2. Locate the parent component by looking for a parent UIComponentTag instance, and ask it for its component. If there is no parent UIComponentTag instance, this tag represents the root component, so get it from the current Tree and return it.
  3. If this UIComponentTag instance has the facetName attribute set, ask the parent UIComponent for a facet with this name. If not found, create one, call setProperties() with the new component as a parameter, and register it under this name. Return the found or created facet UIComponent.
  4. Determine the component id to be assigned to the new component, as follows: if this UIComponentTag has an id attribute set, use that value; otherwise, generate an identifier that is guaranteed to be the same for this UIComponent every time this page is processed (i.e. one based on the location of all UIComponentTag instances without an id attribute set).
  5. Ask the parent UIComponent for a child with this identifier. If not found, create one, call setProperties() with the new component as a parameter, and register it as a child with this identifier. Return the found or created child UIComponent.

When creating a component, the process is:

  1. Retrieve the component type by calling UIComponentTagBase.getComponentType()
  2. If the component has a binding attribute, create an expression from it, and call Application.createComponent(java.lang.String) with that expression, the FacesContext, and the component type. Store the expression using the key "binding".
  3. Otherwise, call Application.createComponent(java.lang.String) with only the component type.
  4. Call setProperties().
  5. Add the new component as a child or facet of its parent

Throws:
JspException

getParentUIComponentClassicTagBase

public static UIComponentClassicTagBase getParentUIComponentClassicTagBase(PageContext context)

Locate and return the nearest enclosing UIComponentClassicTagBase if any; otherwise, return null.

Parameters:
context - PageContext for the current page

getIndexOfNextChildTag

protected int getIndexOfNextChildTag()
Description copied from class: UIComponentTagBase

Return the index of the next child to be added as a child of this tag. The default implementation maintains a list of created components and returns the size of the list.

Specified by:
getIndexOfNextChildTag in class UIComponentTagBase

addChild

protected void addChild(UIComponent child)
Description copied from class: UIComponentTagBase

Add the component identifier of the specified UIComponent to the list of component identifiers created or located by nested UIComponentTags processing this request.

Specified by:
addChild in class UIComponentTagBase
Parameters:
child - New child whose identifier should be added

addFacet

protected void addFacet(String name)
Description copied from class: UIComponentTagBase

Add the facet name of the specified facet to the list of facet names created or located by nested UIComponentTags processing this request.

Specified by:
addFacet in class UIComponentTagBase
Parameters:
name - Facet name to be added

createVerbatimComponentFromBodyContent

protected UIComponent createVerbatimComponentFromBodyContent()

Create a transient UIOutput component from the body content, of this tag instance or return null if there is no body content, the body content is whitespace, or the body content is a comment.

createVerbatimComponent

protected UIOutput createVerbatimComponent()

Use the Application instance to create a new component with the following characteristics.

componentType is javax.faces.HtmlOutputText.

transient is true.

escape is false.

id is FacesContext.getViewRoot().createUniqueId()

addVerbatimBeforeComponent

protected void addVerbatimBeforeComponent(UIComponentClassicTagBase parentTag,
                                          UIComponent verbatim,
                                          UIComponent component)

Add verbatim as a sibling of component in component in the parent's child list. verbatim is added to the list at the position immediatly preceding component.

addVerbatimAfterComponent

protected void addVerbatimAfterComponent(UIComponentClassicTagBase parentTag,
                                         UIComponent verbatim,
                                         UIComponent component)

Add verbatim as a sibling of component in component in the parent's child list. verbatim is added to the list at the position immediatly following component.

doStartTag

public int doStartTag()
               throws JspException

Perform any processing necessary to find (or create) the UIComponent instance in the view corresponding to this tag instance in the page and, if and only if a component was created, insert it into the tree at the proper location as expected by the page author. Secondarily, cause a transient UIOutput component to be created and placed in the tree before the UIComponent instance for this tag. The value of this UIOutput component must include anything covered by CASE 1 or CASE 2 in the class description.

The default implementation, which is intended to be sufficient for most components, implements this secondary requirement by calling getParentUIComponentClassicTagBase(javax.servlet.jsp.PageContext), and calling createVerbatimComponentFromBodyContent() on the result. It then adds the returned component to the tree before the actual component for this tag instance instance by calling addVerbatimBeforeComponent(javax.faces.webapp.UIComponentClassicTagBase, javax.faces.component.UIComponent, javax.faces.component.UIComponent).

Before returning, the component is pushed onto the component stack for this response to enable the getParentUIComponentClassicTagBase(javax.servlet.jsp.PageContext) method to work properly.

The flag value to be returned is acquired by calling the getDoStartValue() method, which tag subclasses may override if they do not want the default value.

Specified by:
doStartTag in interface Tag
Returns:
EVAL_BODY_INCLUDE if the tag wants to process body, SKIP_BODY if it does not want to process it.
Throws:
JspException - if an error occurs
See Also:
BodyTag

doEndTag

public int doEndTag()
             throws JspException

Perform any processing necessary to handle the content implications of CASE 3 in the class description.

The default implementation, which is intended to be sufficient for most components, calls createVerbatimComponentFromBodyContent() on this instance and adds it as a child of the component for this tag's component at the end of the child list. In addition, the following housekeeping steps are taken.

  • Retrieve from the UIComponent the set of component ids of child components created by UIComponentTag instances the last time this page was processed (if any). Compare it to the list of children created during this page processing pass, and remove all children present in the old list but not the new. Save the new list as a component attribute so that it gets saved as part of the component's state.
  • Retrieve from the UIComponent the set of facet names of facets created by UIComponentTag instances the last time this page was processed (if any). Compare it to the list of facets created during this page processing pass, and remove all facets present in the old list but not the new. Save the new list as a component attribute so that it gets saved as part of the component's state.
  • Release all references to the component, and pop it from the component stack for this response, removing the stack if this was the outermost component.

The flag value to be returned is acquired by calling the getDoEndValue() method, which tag subclasses may override if they do not want the default value.

Specified by:
doEndTag in interface Tag
Returns:
indication of whether to continue evaluating the JSP page.
Throws:
JspException - if an error occurs

release

public void release()

Release any resources allocated during the execution of this tag handler.

Specified by:
release in interface Tag

getDoAfterBodyValue

protected int getDoAfterBodyValue()
                           throws JspException

Return the flag value that should be returned from the doAfterBody() method when it is called. Subclasses may override this method to return the appropriate value.

Throws:
JspException

setBodyContent

public void setBodyContent(BodyContent bodyContent)

Set the bodyContent for this tag handler. This method is invoked by the JSP page implementation object at most once per action invocation, before doInitiBody(). This method will not be invoked for empty tags or for non-empty tags whose doStartTag() method returns SKIP_BODY or EVAL_BODY_INCLUDE.

Specified by:
setBodyContent in interface BodyTag
Parameters:
bodyContent - The new BodyContent for this tag
See Also:
BodyTag.doInitBody(), IterationTag.doAfterBody()

getPreviousOut

public JspWriter getPreviousOut()

Get the JspWriter from our BodyContent.

getBodyContent

public BodyContent getBodyContent()

doInitBody

public void doInitBody()
                throws JspException

Prepare for evaluation of the body. This method is invoked by the JSP page implementation object after setBodyContent() and before the first time the body is to be evaluated. This method will not be invoked for empty tags or for non-empty tags whose doStartTag() method returns SKIP_BODY or EVAL_BODY_INCLUDE.

Specified by:
doInitBody in interface BodyTag
Throws:
JspException - if an error is encountered
See Also:
IterationTag.doAfterBody()

doAfterBody

public int doAfterBody()
                throws JspException

Perform any processing necessary to handle the content implications of CASE 4 in the class description.

Return result from getDoAfterBodyValue()

Specified by:
doAfterBody in interface IterationTag
Returns:
whether additional evaluations of the body are desired
Throws:
JspException - if an error is encountered

setId

public void setId(String id)

Set the component identifier for our component. If the argument begins with UIViewRoot.UNIQUE_ID_PREFIX throw an IllegalArgumentException

Specified by:
setId in class UIComponentTagBase
Parameters:
id - The new component identifier. This may not start with UIViewRoot.UNIQUE_ID_PREFIX.
Throws:
IllegalArgumentException - if the argument is non-null and starts with UIViewRoot.UNIQUE_ID_PREFIX.

getId

protected String getId()

Return the id value assigned by the page author.

getFacesJspId

protected String getFacesJspId()

If this method has been called before on this tag's useful lifetime (before release() was called), return the previously returned value. Otherwise, if getJspId() returns non-null, prepend UNIQUE_ID_PREFIX to the jspId and return the result.

getCreatedComponents

protected List<String> getCreatedComponents()
Returns the List of UIComponent ids created or located by nested UIComponentTags while processing the current request.

setJspId

public void setJspId(String id)

Defined on JspIdConsumer. This method is called by the container before doStartTag(). The argument is guaranteed to be unique within the page.

Specified by:
setJspId in interface JspIdConsumer
Parameters:
id - the container generated id for this tag, guaranteed to be unique within the page.

getJspId

public String getJspId()

setProperties

protected abstract void setProperties(UIComponent component)

Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set. This method must be called ONLY if the specified UIComponent was in fact created during the execution of this tag handler instance, and this call will occur BEFORE the UIComponent is added to the view.

Tag subclasses that want to support additional set properties must ensure that the base class setProperties() method is still called. A typical implementation that supports extra properties foo and bar would look something like this:

 protected void setProperties(UIComponent component) {
   super.setProperties(component);
   if (foo != null) {
     component.setAttribute("foo", foo);
   }
   if (bar != null) {
     component.setAttribute("bar", bar);
   }
 }

The default implementation overrides the following properties:

  • rendered - Set if a value for the rendered property is specified for this tag handler instance.
  • rendererType - Set if the getRendererType() method returns a non-null value.

Parameters:
component - UIComponent whose properties are to be overridden

createComponent

protected abstract UIComponent createComponent(FacesContext context,
                                               String newId)
                                        throws JspException

Create and return a new child component of the type returned by calling getComponentType(). If this UIComponentTag has a non-null binding attribute, this is done by call Application.createComponent(java.lang.String) with the expression created for the binding attribute, and the expression will be stored on the component. Otherwise, Application.createComponent(java.lang.String) is called with only the component type. Finally, initialize the components id and other properties.

Parameters:
context - FacesContext for the current request
newId - id of the component
Throws:
JspException

hasBinding

protected abstract boolean hasBinding()

Return true if this component has a non-null binding attribute. This method is necessary to allow subclasses that expose the binding property as an Faces 1.1 style EL property as well as subclasses that expose it as an EL API property.

getComponentInstance

public UIComponent getComponentInstance()

Return the UIComponent instance that is associated with this tag instance. This method is designed to be used by tags nested within this tag, and only returns useful results between the execution of doStartTag() and doEndTag() on this tag instance.

Specified by:
getComponentInstance in class UIComponentTagBase

getCreated

public boolean getCreated()

Return true if we dynamically created a new component instance during execution of this tag. This method is designed to be used by tags nested within this tag, and only returns useful results between the execution of doStartTag() and doEndTag() on this tag instance.

Specified by:
getCreated in class UIComponentTagBase

getFacesContext

protected FacesContext getFacesContext()
Description copied from class: UIComponentTagBase

Return the FacesContext instance for the current request. This value will be non-null only from the beginning of doStartTag() through the end of doEndTag() for each tag instance.

Specified by:
getFacesContext in class UIComponentTagBase

getFacetName

protected String getFacetName()

Return the facet name that we should be stored under, if any; otherwise, return null (indicating that we will be a child component).

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIComponentELTag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.webapp
Class UIComponentELTag

java.lang.Object
    extended by  javax.faces.webapp.UIComponentTagBase
        extended by  javax.faces.webapp.UIComponentClassicTagBase
            extended by  javax.faces.webapp.UIComponentELTag
All Implemented Interfaces:
BodyTag, IterationTag, JspIdConsumer, JspTag, Tag
public abstract class UIComponentELTag
extends UIComponentClassicTagBase
implements Tag

UIComponentELTag specializes its superclass to allow for properties that take their values from EL API expressions.

This tag is designed for use with Faces version 1.2 and JSP version 2.1 containers.

Field Summary
Fields inherited from class javax.faces.webapp.UIComponentClassicTagBase
bodyContent, pageContext, UNIQUE_ID_PREFIX
Fields inherited from class javax.faces.webapp.UIComponentTagBase
log
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Constructor Summary
UIComponentELTag()
Method Summary
protected  UIComponent createComponent(FacesContext context, String newId)
Create and return a new child component of the type returned by calling getComponentType().
protected  ELContext getELContext()
Return the ELContext for the FacesContext for this request.
protected  boolean hasBinding()
Return true if this component has a non-null binding attribute.
 void release()
Release any resources allocated during the execution of this tag handler.
 void setBinding(ValueExpression binding)
Set the value expression for our component.
protected  void setProperties(UIComponent component)
Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set.
 void setRendered(ValueExpression rendered)
Set an override for the rendered attribute.
Methods inherited from class javax.faces.webapp.UIComponentClassicTagBase
addChild, addFacet, addVerbatimAfterComponent, addVerbatimBeforeComponent, createVerbatimComponent, createVerbatimComponentFromBodyContent, doAfterBody, doEndTag, doInitBody, doStartTag, encodeBegin, encodeChildren, encodeEnd, findComponent, getBodyContent, getComponentInstance, getCreated, getCreatedComponents, getDoAfterBodyValue, getDoEndValue, getDoStartValue, getFacesContext, getFacesJspId, getFacetName, getId, getIndexOfNextChildTag, getJspId, getParent, getParentUIComponentClassicTagBase, getPreviousOut, setBodyContent, setId, setJspId, setPageContext, setParent, setupResponseWriter
Methods inherited from class javax.faces.webapp.UIComponentTagBase
getComponentType, getRendererType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
doEndTag, doStartTag, getParent, setPageContext, setParent

Constructor Detail

UIComponentELTag

public UIComponentELTag()
Method Detail

setBinding

public void setBinding(ValueExpression binding)
                throws JspException

Set the value expression for our component.

Parameters:
binding - The new value expression
Throws:
IllegalArgumentException - if the specified binding is not a valid value binding expression.
JspException

hasBinding

protected boolean hasBinding()
Description copied from class: UIComponentClassicTagBase

Return true if this component has a non-null binding attribute. This method is necessary to allow subclasses that expose the binding property as an Faces 1.1 style EL property as well as subclasses that expose it as an EL API property.

Specified by:
hasBinding in class UIComponentClassicTagBase

setRendered

public void setRendered(ValueExpression rendered)

Set an override for the rendered attribute.

Parameters:
rendered - The new value for rendered attribute

getELContext

protected ELContext getELContext()

Return the ELContext for the FacesContext for this request.

This is a convenience for getFacesContext().getELContext().

Overrides:
getELContext in class UIComponentTagBase

release

public void release()

Release any resources allocated during the execution of this tag handler.

Specified by:
release in interface Tag
Overrides:
release in class UIComponentClassicTagBase

setProperties

protected void setProperties(UIComponent component)

Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set. This method must be called ONLY if the specified UIComponent was in fact created during the execution of this tag handler instance, and this call will occur BEFORE the UIComponent is added to the view.

Tag subclasses that want to support additional set properties must ensure that the base class setProperties() method is still called. A typical implementation that supports extra properties foo and bar would look something like this:

 protected void setProperties(UIComponent component) {
   super.setProperties(component);
   if (foo != null) {
     component.setAttribute("foo", foo);
   }
   if (bar != null) {
     component.setAttribute("bar", bar);
   }
 }

The default implementation overrides the following properties:

  • rendered - Set if a value for the rendered property is specified for this tag handler instance.
  • rendererType - Set if the getRendererType() method returns a non-null value.

Specified by:
setProperties in class UIComponentClassicTagBase
Parameters:
component - UIComponent whose properties are to be overridden

createComponent

protected UIComponent createComponent(FacesContext context,
                                      String newId)
                               throws JspException

Create and return a new child component of the type returned by calling getComponentType(). If this UIComponentELTag has a non-null binding attribute, this is done by call Application.createComponent(java.lang.String) with the ValueExpression created for the binding attribute, and the ValueExpression will be stored on the component. Otherwise, Application.createComponent(java.lang.String) is called with only the component type. Finally, initialize the components id and other properties.

Specified by:
createComponent in class UIComponentClassicTagBase
Parameters:
context - FacesContext for the current request
newId - id of the component
Throws:
JspException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIComponentTag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.webapp
Class UIComponentTag

java.lang.Object
    extended by  javax.faces.webapp.UIComponentTagBase
        extended by  javax.faces.webapp.UIComponentClassicTagBase
            extended by  javax.faces.webapp.UIComponentTag
All Implemented Interfaces:
BodyTag, IterationTag, JspIdConsumer, JspTag, Tag
Direct Known Subclasses:
UIComponentBodyTag
Deprecated. Use of this class has been replaced with UIComponentELTag, which extends UIComponentClassicTagBase to add properties that use the EL API introduced as part of JSP 2.1.

public abstract class UIComponentTag
extends UIComponentClassicTagBase
implements Tag

UIComponentTag is the base class for all JSP custom actions that correspond to user interface components in a page that is rendered by JavaServer Faces.

In this version of the specification, UIComponentTag extends UIComponentClassicTagBase to add properties that use the Faces 1.1 Expression Language.

Field Summary
Fields inherited from class javax.faces.webapp.UIComponentClassicTagBase
bodyContent, pageContext, UNIQUE_ID_PREFIX
Fields inherited from class javax.faces.webapp.UIComponentTagBase
log
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Constructor Summary
UIComponentTag()
Deprecated.
Method Summary
protected UIComponent | createComponent(FacesContext context, String newId) Deprecated. Implement createComponent using Faces 1.1 EL API.
static UIComponentTag | getParentUIComponentTag(PageContext context) Deprecated. Locate and return the nearest enclosing UIComponentTag if any; otherwise, return null.
protected boolean | hasBinding() Deprecated. Return true if this component has a non-null binding attribute.
protected boolean | isSuppressed() Deprecated.
static boolean | isValueReference(String value) Deprecated. Return true if the specified value conforms to the syntax requirements of a value binding expression.
void | release() Deprecated. Release any resources allocated during the execution of this tag handler.
void | setBinding(String binding) Deprecated. Set the value binding expression for our component.
protected void | setProperties(UIComponent component) Deprecated. Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set.
void | setRendered(String rendered) Deprecated. Set an override for the rendered attribute.
Methods inherited from class javax.faces.webapp.UIComponentClassicTagBase
addChild, addFacet, addVerbatimAfterComponent, addVerbatimBeforeComponent, createVerbatimComponent, createVerbatimComponentFromBodyContent, doAfterBody, doEndTag, doInitBody, doStartTag, encodeBegin, encodeChildren, encodeEnd, findComponent, getBodyContent, getComponentInstance, getCreated, getCreatedComponents, getDoAfterBodyValue, getDoEndValue, getDoStartValue, getFacesContext, getFacesJspId, getFacetName, getId, getIndexOfNextChildTag, getJspId, getParent, getParentUIComponentClassicTagBase, getPreviousOut, setBodyContent, setId, setJspId, setPageContext, setParent, setupResponseWriter
Methods inherited from class javax.faces.webapp.UIComponentTagBase
getComponentType, getELContext, getRendererType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
doEndTag, doStartTag, getParent, setPageContext, setParent

Constructor Detail

UIComponentTag

public UIComponentTag()
Deprecated.
Method Detail

setBinding

public void setBinding(String binding)
                throws JspException
Deprecated.

Set the value binding expression for our component.

Parameters:
binding - The new value binding expression
Throws:
IllegalArgumentException - if the specified binding is not a valid value binding expression.
JspException

hasBinding

protected boolean hasBinding()
Deprecated.
Description copied from class: UIComponentClassicTagBase

Return true if this component has a non-null binding attribute. This method is necessary to allow subclasses that expose the binding property as an Faces 1.1 style EL property as well as subclasses that expose it as an EL API property.

Specified by:
hasBinding in class UIComponentClassicTagBase

setRendered

public void setRendered(String rendered)
Deprecated.

Set an override for the rendered attribute.

Parameters:
rendered - The new value for rendered attribute

isSuppressed

protected boolean isSuppressed()
Deprecated.

isValueReference

public static boolean isValueReference(String value)
Deprecated.

Return true if the specified value conforms to the syntax requirements of a value binding expression. Such expressions ` * may be used on most component tag attributes to signal a desire for deferred evaluation of the attribute or property value to be set on the underlying UIComponent.

Parameters:
value - The value to evaluate
Throws:
NullPointerException - if value is null

release

public void release()
Deprecated.

Release any resources allocated during the execution of this tag handler.

Specified by:
release in interface Tag
Overrides:
release in class UIComponentClassicTagBase

setProperties

protected void setProperties(UIComponent component)
Deprecated.
Description copied from class: UIComponentClassicTagBase

Override properties and attributes of the specified component, if the corresponding properties of this tag handler instance were explicitly set. This method must be called ONLY if the specified UIComponent was in fact created during the execution of this tag handler instance, and this call will occur BEFORE the UIComponent is added to the view.

Tag subclasses that want to support additional set properties must ensure that the base class setProperties() method is still called. A typical implementation that supports extra properties foo and bar would look something like this:

 protected void setProperties(UIComponent component) {
   super.setProperties(component);
   if (foo != null) {
     component.setAttribute("foo", foo);
   }
   if (bar != null) {
     component.setAttribute("bar", bar);
   }
 }

The default implementation overrides the following properties:

  • rendered - Set if a value for the rendered property is specified for this tag handler instance.
  • rendererType - Set if the getRendererType() method returns a non-null value.

Specified by:
setProperties in class UIComponentClassicTagBase
Parameters:
component - UIComponent whose properties are to be overridden

createComponent

protected UIComponent createComponent(FacesContext context,
                                      String newId)
Deprecated.

Implement createComponent using Faces 1.1 EL API.

Specified by:
createComponent in class UIComponentClassicTagBase
Parameters:
context - FacesContext for the current request
newId - id of the component

getParentUIComponentTag

public static UIComponentTag getParentUIComponentTag(PageContext context)
Deprecated.

Locate and return the nearest enclosing UIComponentTag if any; otherwise, return null.

Parameters:
context - PageContext for the current page
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIComponentTagBase

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.webapp
Class UIComponentTagBase

java.lang.Object
    extended by  javax.faces.webapp.UIComponentTagBase
All Implemented Interfaces:
JspTag
Direct Known Subclasses:
UIComponentClassicTagBase
public abstract class UIComponentTagBase
extends Object
implements JspTag

UIComponentTagBase is the base class for all JSP tags that correspond to a UIComponent instance in the view. This base class allows a single view to be described in a JSP page consisting of both UIComponentELTag and UIComponentTag instances.

Field Summary
protected static Logger log
Constructor Summary
UIComponentTagBase()
Method Summary
protected abstract void | addChild(UIComponent child) Add the component identifier of the specified UIComponent to the list of component identifiers created or located by nested UIComponentTags processing this request.
protected abstract void | addFacet(String name) Add the facet name of the specified facet to the list of facet names created or located by nested UIComponentTags processing this request.
abstract UIComponent | getComponentInstance() Return the UIComponent instance that is associated with this tag instance.
abstract String | getComponentType() Return the component type for the component that is or will be bound to this tag.
abstract boolean | getCreated() Return true if we dynamically created a new component instance during execution of this tag.
protected ELContext | getELContext() Return the ELContext for the FacesContext for this request.
protected abstract FacesContext | getFacesContext() Return the FacesContext instance for the current request.
protected abstract int | getIndexOfNextChildTag() Return the index of the next child to be added as a child of this tag.
abstract String | getRendererType() Return the rendererType property that selects the Renderer to be used for encoding this component, or null to ask the component to render itself directly.
abstract void | setId(String id) Set the component identifier for the component corresponding to this tag instance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

protected static Logger log
Constructor Detail

UIComponentTagBase

public UIComponentTagBase()
Method Detail

getFacesContext

protected abstract FacesContext getFacesContext()

Return the FacesContext instance for the current request. This value will be non-null only from the beginning of doStartTag() through the end of doEndTag() for each tag instance.

getELContext

protected ELContext getELContext()

Return the ELContext for the FacesContext for this request.

This is a convenience for getFacesContext().getELContext().

addChild

protected abstract void addChild(UIComponent child)

Add the component identifier of the specified UIComponent to the list of component identifiers created or located by nested UIComponentTags processing this request.

Parameters:
child - New child whose identifier should be added

addFacet

protected abstract void addFacet(String name)

Add the facet name of the specified facet to the list of facet names created or located by nested UIComponentTags processing this request.

Parameters:
name - Facet name to be added

setId

public abstract void setId(String id)

Set the component identifier for the component corresponding to this tag instance. If the argument begins with UIViewRoot.UNIQUE_ID_PREFIX throw an IllegalArgumentException

Parameters:
id - The new component identifier. This may not start with UIViewRoot.UNIQUE_ID_PREFIX.
Throws:
IllegalArgumentException - if the argument is non-null and starts with UIViewRoot.UNIQUE_ID_PREFIX.

getComponentType

public abstract String getComponentType()

Return the component type for the component that is or will be bound to this tag. This value can be passed to Application.createComponent(java.lang.String) to create the UIComponent instance for this tag. Subclasses must override this method to return the appropriate value.

getRendererType

public abstract String getRendererType()

Return the rendererType property that selects the Renderer to be used for encoding this component, or null to ask the component to render itself directly. Subclasses must override this method to return the appropriate value.

getComponentInstance

public abstract UIComponent getComponentInstance()

Return the UIComponent instance that is associated with this tag instance. This method is designed to be used by tags nested within this tag, and only returns useful results between the execution of doStartTag() and doEndTag() on this tag instance.

getCreated

public abstract boolean getCreated()

Return true if we dynamically created a new component instance during execution of this tag. This method is designed to be used by tags nested within this tag, and only returns useful results between the execution of doStartTag() and doEndTag() on this tag instance.

getIndexOfNextChildTag

protected abstract int getIndexOfNextChildTag()

Return the index of the next child to be added as a child of this tag. The default implementation maintains a list of created components and returns the size of the list.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValidatorELTag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.faces.webapp
Class ValidatorELTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.faces.webapp.ValidatorELTag
All Implemented Interfaces:
Serializable, IterationTag, JspTag, Tag
public abstract class ValidatorELTag
extends TagSupport

ValidatorELTag is a base class for all JSP custom actions that create and register a Validator instance on the EditableValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentTag. To avoid creating duplicate instances when a page is redisplayed, creation and registration of a Validator occurs only if the corresponding UIComponent was created (by the owning UIComponentTagBase) during the execution of the current page.

This class must be used as a base class for tag instances that support specific Validator subclasses.

Subclasses of this class must implement the createValidator() method, which creates and returns a Validator instance. Any configuration properties that specify the limits to be enforced by this Validator must have been set by the createValidator() method. Generally, this occurs by copying corresponding attribute values on the tag instance.

This tag creates no output to the page currently being created. It is used solely for the side effect of Validator creation.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ValidatorELTag()
Method Summary
protected abstract Validator | createValidator() Create and return a new Validator to be registered on our surrounding UIComponent.
int | doStartTag() Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page.
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
doAfterBody, doEndTag, findAncestorWithClass, getId, getParent, getValue, getValues, release, removeValue, setId, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValidatorELTag

public ValidatorELTag()
Method Detail

doStartTag

public int doStartTag()
               throws JspException

Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTagBase instance, if the UIComponent instance was created by this execution of the containing JSP page.

Specified by:
doStartTag in interface Tag
Overrides:
doStartTag in class TagSupport
Returns:
SKIP_BODY
Throws:
JspException - if a JSP error occurs
See Also:
Tag.doStartTag()

createValidator

protected abstract Validator createValidator()
                                      throws JspException

Create and return a new Validator to be registered on our surrounding UIComponent.

Throws:
JspException - if a new instance cannot be created
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValidatorTag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.faces.webapp
Class ValidatorTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.faces.webapp.ValidatorTag
All Implemented Interfaces:
Serializable, IterationTag, JspTag, Tag
Deprecated. This has been partially replaced by ValidatorELTag. The remainder of the functionality, namely, the binding facility and the implementation of the createValidator() method, is now an implementation detail.

public class ValidatorTag
extends TagSupport

ValidatorTag is a base class for all JSP custom actions that create and register a Validator instance on the EditableValueHolder associated with our most immediate surrounding instance of a tag whose implementation class is a subclass of UIComponentTag. To avoid creating duplicate instances when a page is redisplayed, creation and registration of a Validator occurs only if the corresponding UIComponent was created (by the owning UIComponentTag) during the execution of the current page.

This class may be used directly to implement a generic validator registration tag (based on the validator-id specified by the id attribute), or as a base class for tag instances that support specific Validator subclasses. This id attribute must refer to one of the well known validator-ids, or a custom validator-id as defined in a faces-config.xml file.

Subclasses of this class must implement the createValidator() method, which creates and returns a Validator instance. Any configuration properties that specify the limits to be enforced by this Validator must have been set by the createValidator() method. Generally, this occurs by copying corresponding attribute values on the tag instance.

This tag creates no output to the page currently being created. It is used solely for the side effect of Validator creation.

See Also:
Serialized Form

Field Summary
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ValidatorTag()
Deprecated.
Method Summary
protected Validator | createValidator() Deprecated. Create and return a new Validator to be registered on our surrounding UIComponent.
int | doStartTag() Deprecated. Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page.
void | release() Deprecated. Release references to any acquired resources.
void | setBinding(String binding) Deprecated. Set the expression that will be used to create a ValueExpression that references a backing bean property of the Validator instance to be created.
void | setValidatorId(String validatorId) Deprecated. Set the identifer of the Validator instance to be created.
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
doAfterBody, doEndTag, findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValidatorTag

public ValidatorTag()
Deprecated.
Method Detail

setValidatorId

public void setValidatorId(String validatorId)
Deprecated.

Set the identifer of the Validator instance to be created.

Parameters:
validatorId - The new identifier of the validator instance to be created.

setBinding

public void setBinding(String binding)
                throws JspException
Deprecated.

Set the expression that will be used to create a ValueExpression that references a backing bean property of the Validator instance to be created.

Parameters:
binding - The new expression
Throws:
JspException - if a JSP error occurs

doStartTag

public int doStartTag()
               throws JspException
Deprecated.

Create a new instance of the specified Validator class, and register it with the UIComponent instance associated with our most immediately surrounding UIComponentTag instance, if the UIComponent instance was created by this execution of the containing JSP page.

Specified by:
doStartTag in interface Tag
Overrides:
doStartTag in class TagSupport
Returns:
SKIP_BODY
Throws:
JspException - if a JSP error occurs
See Also:
Tag.doStartTag()

release

public void release()
Deprecated.

Release references to any acquired resources.

Specified by:
release in interface Tag
Overrides:
release in class TagSupport
See Also:
Tag.release()

createValidator

protected Validator createValidator()
                             throws JspException
Deprecated.

Create and return a new Validator to be registered on our surrounding UIComponent.

Throws:
JspException - if a new instance cannot be created
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


interceptor

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.interceptor

The javax.interceptor package contains classes and interfaces for use with EJB interceptors.

See:
Description

Interface Summary
InvocationContext Context information passed to AroundInvoke and Interceptor-class lifecycle callback methods.

Annotation Types Summary
AroundInvoke |
ExcludeClassInterceptors | Used to exclude class-level interceptors for a business method.
ExcludeDefaultInterceptors | Used to exclude default interceptors for a bean or a business method.
Interceptors | Declares an ordered list of interceptors for a class or method.

Package javax.interceptor Description

The javax.interceptor package contains classes and interfaces for use with EJB interceptors.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AroundInvoke

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.interceptor
Annotation Type AroundInvoke

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface AroundInvoke

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ExcludeClassInterceptors

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.interceptor
Annotation Type ExcludeClassInterceptors

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface ExcludeClassInterceptors

Used to exclude class-level interceptors for a business method.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ExcludeDefaultInterceptors

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.interceptor
Annotation Type ExcludeDefaultInterceptors

@Target(value={TYPE,METHOD})
@Retention(value=RUNTIME)
public @interface ExcludeDefaultInterceptors

Used to exclude default interceptors for a bean or a business method.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.interceptor Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.interceptor

Package Hierarchies:
All Packages

Interface Hierarchy

  • javax.interceptor.InvocationContext

Annotation Type Hierarchy

  • javax.interceptor.AroundInvoke (implements java.lang.annotation.Annotation)
  • javax.interceptor.ExcludeClassInterceptors (implements java.lang.annotation.Annotation)
  • javax.interceptor.ExcludeDefaultInterceptors (implements java.lang.annotation.Annotation)
  • javax.interceptor.Interceptors (implements java.lang.annotation.Annotation)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Interceptors

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.interceptor
Annotation Type Interceptors

@Target(value={TYPE,METHOD})
@Retention(value=RUNTIME)
public @interface Interceptors

Declares an ordered list of interceptors for a class or method.

Required Element Summary
 Class[] value

Element Detail

value

public abstract Class[] value
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InvocationContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.interceptor
Interface InvocationContext

public interface InvocationContext

Context information passed to AroundInvoke and Interceptor-class lifecycle callback methods.

Method Summary
Map<String,Object> | getContextData() Returns the context data associated with this invocation or lifecycle callback.
Method | getMethod() Returns the method of the bean class for which the interceptor was invoked.
Object[] | getParameters() Returns the parameters that will be used to invoke the business method.
Object | getTarget() Returns the target instance.
Object | proceed() Proceed to the next entry in the interceptor chain.
void | setParameters(Object[] params) Sets the parameters that will be used to invoke the business method.

Method Detail

getTarget

Object getTarget()
Returns the target instance.

getMethod

Method getMethod()
Returns the method of the bean class for which the interceptor was invoked. For AroundInvoke methods, this is the business method on the bean class. For lifecycle callback methods, returns null.

getParameters

Object[] getParameters()
Returns the parameters that will be used to invoke the business method. If setParameters has been called, getParameters() returns the values to which the parameters have been set.

Throws:
IllegalStateException - if invoked within a lifecycle callback method.

setParameters

void setParameters(Object[] params)
Sets the parameters that will be used to invoke the business method.

Throws:
IllegalStateException - if invoked within a lifecycle callback method.

getContextData

Map<String,Object> getContextData()
Returns the context data associated with this invocation or lifecycle callback. If there is no context data, an empty Map object will be returned.

proceed

Object proceed()
               throws Exception
Proceed to the next entry in the interceptor chain. The proceed method returns the result of the next method invoked. If the method returns void, proceed returns null.

Throws:
Exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


jms

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.jms

The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

See:
Description

Interface Summary
BytesMessage | A BytesMessage object is used to send a message containing a stream of uninterpreted bytes.
Connection | A Connection object is a client's active connection to its JMS provider.
ConnectionConsumer | For application servers, Connection objects provide a special facility for creating a ConnectionConsumer (optional).
ConnectionFactory | A ConnectionFactory object encapsulates a set of connection configuration parameters that has been defined by an administrator.
ConnectionMetaData | A ConnectionMetaData object provides information describing the Connection object.
DeliveryMode | The delivery modes supported by the JMS API are PERSISTENT and NON_PERSISTENT.
Destination | A Destination object encapsulates a provider-specific address.
ExceptionListener | If a JMS provider detects a serious problem with a Connection object, it informs the Connection object's ExceptionListener, if one has been registered.
MapMessage | A MapMessage object is used to send a set of name-value pairs.
Message | The Message interface is the root interface of all JMS messages.
MessageConsumer | A client uses a MessageConsumer object to receive messages from a destination.
MessageListener | A MessageListener object is used to receive asynchronously delivered messages.
MessageProducer | A client uses a MessageProducer object to send messages to a destination.
ObjectMessage | An ObjectMessage object is used to send a message that contains a serializable object in the Java programming language ("Java object").
Queue | A Queue object encapsulates a provider-specific queue name.
QueueBrowser | A client uses a QueueBrowser object to look at messages on a queue without removing them.
QueueConnection | A QueueConnection object is an active connection to a point-to-point JMS provider.
QueueConnectionFactory | A client uses a QueueConnectionFactory object to create QueueConnection objects with a point-to-point JMS provider.
QueueReceiver | A client uses a QueueReceiver object to receive messages that have been delivered to a queue.
QueueSender | A client uses a QueueSender object to send messages to a queue.
QueueSession | A QueueSession object provides methods for creating QueueReceiver, QueueSender, QueueBrowser, and TemporaryQueue objects.
ServerSession | A ServerSession object is an application server object that is used by a server to associate a thread with a JMS session (optional).
ServerSessionPool | A ServerSessionPool object is an object implemented by an application server to provide a pool of ServerSession objects for processing the messages of a ConnectionConsumer (optional).
Session | A Session object is a single-threaded context for producing and consuming messages.
StreamMessage | A StreamMessage object is used to send a stream of primitive types in the Java programming language.
TemporaryQueue | A TemporaryQueue object is a unique Queue object created for the duration of a Connection.
TemporaryTopic | A TemporaryTopic object is a unique Topic object created for the duration of a Connection.
TextMessage | A TextMessage object is used to send a message containing a java.lang.String.
Topic | A Topic object encapsulates a provider-specific topic name.
TopicConnection | A TopicConnection object is an active connection to a publish/subscribe JMS provider.
TopicConnectionFactory | A client uses a TopicConnectionFactory object to create TopicConnection objects with a publish/subscribe JMS provider.
TopicPublisher | A client uses a TopicPublisher object to publish messages on a topic.
TopicSession | A TopicSession object provides methods for creating TopicPublisher, TopicSubscriber, and TemporaryTopic objects.
TopicSubscriber | A client uses a TopicSubscriber object to receive messages that have been published to a topic.
XAConnection | The XAConnection interface extends the capability of Connection by providing an XASession (optional).
XAConnectionFactory | The XAConnectionFactory interface is a base interface for the XAQueueConnectionFactory and XATopicConnectionFactory interfaces.
XAQueueConnection | An XAQueueConnection provides the same create options as QueueConnection (optional).
XAQueueConnectionFactory | An XAQueueConnectionFactory provides the same create options as a QueueConnectionFactory (optional).
XAQueueSession | An XAQueueSession provides a regular QueueSession, which can be used to create QueueReceiver, QueueSender, and QueueBrowser objects (optional).
XASession | The XASession interface extends the capability of Session by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional).
XATopicConnection | An XATopicConnection provides the same create options as TopicConnection (optional).
XATopicConnectionFactory | An XATopicConnectionFactory provides the same create options as a TopicConnectionFactory (optional).
XATopicSession | An XATopicSession provides a regular TopicSession.

Class Summary
QueueRequestor | The QueueRequestor helper class simplifies making service requests.
TopicRequestor | The TopicRequestor helper class simplifies making service requests.

Exception Summary
IllegalStateException | This exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation.
InvalidClientIDException | This exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider.
InvalidDestinationException | This exception must be thrown when a destination either is not understood by a provider or is no longer valid.
InvalidSelectorException | This exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax.
JMSException | This is the root class of all JMS API exceptions.
JMSSecurityException | This exception must be thrown when a provider rejects a user name/password submitted by a client.
MessageEOFException | This exception must be thrown when an unexpected end of stream has been reached when a StreamMessage or BytesMessage is being read.
MessageFormatException | This exception must be thrown when a JMS client attempts to use a data type not supported by a message or attempts to read data in a message as the wrong type.
MessageNotReadableException | This exception must be thrown when a JMS client attempts to read a write-only message.
MessageNotWriteableException | This exception must be thrown when a JMS client attempts to write to a read-only message.
ResourceAllocationException | This exception is thrown when a provider is unable to allocate the resources required by a method.
TransactionInProgressException | This exception is thrown when an operation is invalid because a transaction is in progress.
TransactionRolledBackException | This exception must be thrown when a call to Session.commit results in a rollback of the current transaction.

Package javax.jms Description

The Java Message Service (JMS) API provides a common way for Java programs to create, send, receive and read an enterprise messaging system's messages.

JMS Applications

A JMS application is composed of the following parts:

  • JMS Provider - a messaging system that implements the JMS API in addition to the other administrative and control functionality required of a full-featured messaging product
  • JMS Clients - the Java language programs that send and receive messages
  • Messages - objects that are used to communicate information between the clients of an application
  • Administered Objects - provider-specific objects that clients look up and use to interact portably with a JMS provider
  • Non-JMS Clients - clients that use a message system's native client API instead of the JMS API. If the application predated the availability of the JMS API, it is likely that it will include both JMS clients and non-JMS clients.

Administration

JMS providers differ significantly in their implementations of underlying messaging technology. There are also major differences in how a JMS provider's system is installed and administered.

For JMS clients to be portable, they must be isolated from these proprietary aspects of a provider. This is done by defining JMS administered objects that are created and customized by a provider's administrator and later used by clients. The client uses them through JMS interfaces that are portable. The administrator creates them using provider-specific facilities.

There are two types of JMS administered objects:

  • ConnectionFactory - the object a client uses to create a connection with a JMS provider
  • Destination - the object a client uses to specify the destination of messages it is sending and the source of messages it receives

Administered objects are placed in a Java Naming and Directory InterfaceTM (JNDI) namespace by an administrator. A JMS client typically notes in its documentation the JMS administered objects it requires and how the JNDI names of these objects should be provided to it.

Two Messaging Styles

The JMS specification defines two styles of messaging: the point-to-point (PTP) or the publish-and-subscribe (Pub/Sub). These styles can be combined in a single application, or a given application can use just one of these styles.

The JMS API defines these two styles because they represent two of the dominant approaches to messaging currently in use. While the domains have many similarities, they also have some differences. JMS provides a unified programming interface to allow the client programmer to easily send and receive message using either domain, but the client programmer must also be aware of the differences between the domains. The key differences relate to how message persistence is handled, and the meaning of certain message attributes.

JMS Interfaces

When programming an application client, the programmer may either program using the domain specific interfaces, or may use the common interfaces. The key interfaces are listed in the table below. The preferred model is to use the common interfaces. The advantage to using the common interfaces is that both point-to-point and pub/sub tasks can be combined in one session, allowing transactions to operate over both domains.

In earlier versions of JMS, there were separate class hierarchies for the pub/sub and point-to-point programming models that had to be used. These class hierarchies are retained to support backward compatibility with earlier versions of the JMS API, but client developers are encouraged to use the common interfaces.

Relationship of PTP and Pub/Sub interfaces
JMS Common | PTP Domain | Pub/Sub Domain
ConnectionFactory | QueueConnectionFactory | TopicConnectionFactory
Connection | QueueConnection | TopicConnection
Destination | Queue | Topic
Session | QueueSession | TopicSession
MessageProducer | QueueSender | TopicPublisher
MessageConsumer | QueueReceiver | TopicSubscriber

The following provides a brief definition of these JMS concepts. See the PTP and Pub/Sub chapters of the JMS specification for more information.

  • ConnectionFactory - an administered object used by a client to create a Connection
  • Connection - an active connection to a JMS provider
  • Destination - an administered object that encapsulates the identity of a message destination
  • Session - a single-threaded context for sending and receiving messages
  • MessageProducer - an object created by a Session that is used for sending messages to a destination
  • MessageConsumer - an object created by a Session that is used for receiving messages sent to a destination

The term consume is used in this document to mean the receipt of a message by a JMS client; that is, a JMS provider has received a message and has given it to its client. Since the JMS API supports both synchronous and asynchronous receipt of messages, the term consume is used when there is no need to make a distinction between them.

The term produce is used as the most general term for sending a message. It means giving a message to a JMS provider for delivery to a destination.

Developing a JMS Application

Broadly speaking, a JMS application is one or more JMS clients that exchange messages. The application may also involve non-JMS clients; however, these clients use the JMS provider's native API in place of the JMS API.

A JMS application can be architected and deployed as a unit. In many cases, JMS clients are added incrementally to an existing application.

The message definitions used by an application may originate with JMS, or they may have been defined by the non-JMS part of the application.

Developing a JMS Client

A typical JMS client executes the following setup procedure:

  • Use JNDI to find a ConnectionFactory object
  • Use JNDI to find one or more Destination objects
  • Use the ConnectionFactory to create a JMS Connection. At this point, message delivery is inhibited
  • Use the Connection to create one or more JMS Sessions
  • Use a Session and the Destinations to create the MessageProducers and MessageConsumers needed
  • Start message delivery for the Connection. Messages will be delivered to MessageConsumers

At this point a client has the basic setup needed to produce and consume messages.

Package Specification

Java Message Service Specification - Version 1.1

Related Documentation

Java Message Service Tutorial

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Destination

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface Destination

All Known Subinterfaces:
Queue, TemporaryQueue, TemporaryTopic, Topic
public interface Destination

A Destination object encapsulates a provider-specific address. The JMS API does not define a standard address syntax. Although a standard address syntax was considered, it was decided that the differences in address semantics between existing message-oriented middleware (MOM) products were too wide to bridge with a single syntax.

Since Destination is an administered object, it may contain provider-specific configuration information in addition to its address.

The JMS API also supports a client's use of provider-specific address names.

Destination objects support concurrent use.

A Destination object is a JMS administered object.

JMS administered objects are objects containing configuration information that are created by an administrator and later used by JMS clients. They make it practical to administer the JMS API in the enterprise.

Although the interfaces for administered objects do not explicitly depend on the Java Naming and Directory Interface (JNDI) API, the JMS API establishes the convention that JMS clients find administered objects by looking them up in a JNDI namespace.

An administrator can place an administered object anywhere in a namespace. The JMS API does not define a naming policy.

It is expected that JMS providers will provide the tools an administrator needs to create and configure administered objects in a JNDI namespace. JMS provider implementations of administered objects should implement the javax.naming.Referenceable and java.io.Serializable interfaces so that they can be stored in all JNDI naming contexts. In addition, it is recommended that these implementations follow the JavaBeansTM design patterns.

This strategy provides several benefits:

  • It hides provider-specific details from JMS clients.
  • It abstracts JMS administrative information into objects in the Java programming language ("Java objects") that are easily organized and administered from a common management console.
  • Since there will be JNDI providers for all popular naming services, JMS providers can deliver one implementation of administered objects that will run everywhere.

An administered object should not hold on to any remote resources. Its lookup should not use remote resources other than those used by the JNDI API itself.

Clients should think of administered objects as local Java objects. Looking them up should not have any hidden side effects or use surprising amounts of local resources.

Version:
1.0 - 3 August 1998
Author:
Mark Hapner, Rich Burridge
See Also:
Queue, Topic

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.jms Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.jms

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.jms.QueueRequestor
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.jms.JMSException
          • javax.jms.IllegalStateException
          • javax.jms.InvalidClientIDException
          • javax.jms.InvalidDestinationException
          • javax.jms.InvalidSelectorException
          • javax.jms.JMSSecurityException
          • javax.jms.MessageEOFException
          • javax.jms.MessageFormatException
          • javax.jms.MessageNotReadableException
          • javax.jms.MessageNotWriteableException
          • javax.jms.ResourceAllocationException
          • javax.jms.TransactionInProgressException
          • javax.jms.TransactionRolledBackException
    • javax.jms.TopicRequestor

Interface Hierarchy

  • javax.jms.Connection
    • javax.jms.QueueConnection
      • javax.jms.XAQueueConnection (also extends javax.jms.XAConnection)
    • javax.jms.TopicConnection
      • javax.jms.XATopicConnection (also extends javax.jms.XAConnection)
    • javax.jms.XAConnection
      • javax.jms.XAQueueConnection (also extends javax.jms.QueueConnection)
      • javax.jms.XATopicConnection (also extends javax.jms.TopicConnection)
  • javax.jms.ConnectionConsumer
  • javax.jms.ConnectionFactory
    • javax.jms.QueueConnectionFactory
      • javax.jms.XAQueueConnectionFactory (also extends javax.jms.XAConnectionFactory)
    • javax.jms.TopicConnectionFactory
      • javax.jms.XATopicConnectionFactory (also extends javax.jms.XAConnectionFactory)
  • javax.jms.ConnectionMetaData
  • javax.jms.DeliveryMode
  • javax.jms.Destination
    • javax.jms.Queue
      • javax.jms.TemporaryQueue
    • javax.jms.Topic
      • javax.jms.TemporaryTopic
  • javax.jms.ExceptionListener
  • javax.jms.Message
    • javax.jms.BytesMessage
    • javax.jms.MapMessage
    • javax.jms.ObjectMessage
    • javax.jms.StreamMessage
    • javax.jms.TextMessage
  • javax.jms.MessageConsumer
    • javax.jms.QueueReceiver
    • javax.jms.TopicSubscriber
  • javax.jms.MessageListener
  • javax.jms.MessageProducer
    • javax.jms.QueueSender
    • javax.jms.TopicPublisher
  • javax.jms.QueueBrowser
  • java.lang.Runnable
    • javax.jms.Session
      • javax.jms.QueueSession
      • javax.jms.TopicSession
      • javax.jms.XASession
        • javax.jms.XAQueueSession
        • javax.jms.XATopicSession
  • javax.jms.ServerSession
  • javax.jms.ServerSessionPool
  • javax.jms.XAConnectionFactory
    • javax.jms.XAQueueConnectionFactory (also extends javax.jms.QueueConnectionFactory)
    • javax.jms.XATopicConnectionFactory (also extends javax.jms.TopicConnectionFactory)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BytesMessage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface BytesMessage

All Superinterfaces:
Message
public interface BytesMessage
extends Message

A BytesMessage object is used to send a message containing a stream of uninterpreted bytes. It inherits from the Message interface and adds a bytes message body. The receiver of the message supplies the interpretation of the bytes.

The BytesMessage methods are based largely on those found in java.io.DataInputStream and java.io.DataOutputStream.

This message type is for client encoding of existing message formats. If possible, one of the other self-defining message types should be used instead.

Although the JMS API allows the use of message properties with byte messages, they are typically not used, since the inclusion of properties may affect the format.

The primitive types can be written explicitly using methods for each type. They may also be written generically as objects. For instance, a call to BytesMessage.writeInt(6) is equivalent to BytesMessage.writeObject(new Integer(6)). Both forms are provided, because the explicit form is convenient for static programming, and the object form is needed when types are not known at compile time.

When the message is first created, and when clearBody is called, the body of the message is in write-only mode. After the first call to reset has been made, the message body is in read-only mode. After a message has been sent, the client that sent it can retain and modify it without affecting the message that has been sent. The same message object can be sent multiple times. When a message has been received, the provider has called reset so that the message body is in read-only mode for the client.

If clearBody is called on a message in read-only mode, the message body is cleared and the message is in write-only mode.

If a client attempts to read a message in write-only mode, a MessageNotReadableException is thrown.

If a client attempts to write a message in read-only mode, a MessageNotWriteableException is thrown.

Version:
1.1 April 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createBytesMessage(), MapMessage, Message, ObjectMessage, StreamMessage, TextMessage

Field Summary
Fields inherited from interface javax.jms.Message
DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE
Method Summary
long | getBodyLength() Gets the number of bytes of the message body when the message is in read-only mode.
boolean | readBoolean() Reads a boolean from the bytes message stream.
byte | readByte() Reads a signed 8-bit value from the bytes message stream.
int | readBytes(byte[] value) Reads a byte array from the bytes message stream.
int | readBytes(byte[] value, int length) Reads a portion of the bytes message stream.
char | readChar() Reads a Unicode character value from the bytes message stream.
double | readDouble() Reads a double from the bytes message stream.
float | readFloat() Reads a float from the bytes message stream.
int | readInt() Reads a signed 32-bit integer from the bytes message stream.
long | readLong() Reads a signed 64-bit integer from the bytes message stream.
short | readShort() Reads a signed 16-bit number from the bytes message stream.
int | readUnsignedByte() Reads an unsigned 8-bit number from the bytes message stream.
int | readUnsignedShort() Reads an unsigned 16-bit number from the bytes message stream.
String | readUTF() Reads a string that has been encoded using a modified UTF-8 format from the bytes message stream.
void | reset() Puts the message body in read-only mode and repositions the stream of bytes to the beginning.
void | writeBoolean(boolean value) Writes a boolean to the bytes message stream as a 1-byte value.
void | writeByte(byte value) Writes a byte to the bytes message stream as a 1-byte value.
void | writeBytes(byte[] value) Writes a byte array to the bytes message stream.
void | writeBytes(byte[] value, int offset, int length) Writes a portion of a byte array to the bytes message stream.
void | writeChar(char value) Writes a char to the bytes message stream as a 2-byte value, high byte first.
void | writeDouble(double value) Converts the double argument to a long using the doubleToLongBits method in class Double, and then writes that long value to the bytes message stream as an 8-byte quantity, high byte first.
void | writeFloat(float value) Converts the float argument to an int using the floatToIntBits method in class Float, and then writes that int value to the bytes message stream as a 4-byte quantity, high byte first.
void | writeInt(int value) Writes an int to the bytes message stream as four bytes, high byte first.
void | writeLong(long value) Writes a long to the bytes message stream as eight bytes, high byte first.
void | writeObject(Object value) Writes an object to the bytes message stream.
void | writeShort(short value) Writes a short to the bytes message stream as two bytes, high byte first.
void | writeUTF(String value) Writes a string to the bytes message stream using UTF-8 encoding in a machine-independent manner.
Methods inherited from interface javax.jms.Message
acknowledge, clearBody, clearProperties, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

Method Detail

getBodyLength

long getBodyLength()
                   throws JMSException
Gets the number of bytes of the message body when the message is in read-only mode. The value returned can be used to allocate a byte array. The value returned is the entire length of the message body, regardless of where the pointer for reading the message is currently located.

Returns:
number of bytes in the message
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageNotReadableException - if the message is in write-only mode.
Since:
1.1

readBoolean

boolean readBoolean()
                    throws JMSException
Reads a boolean from the bytes message stream.

Returns:
the boolean value read
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readByte

byte readByte()
              throws JMSException
Reads a signed 8-bit value from the bytes message stream.

Returns:
the next byte from the bytes message stream as a signed 8-bit byte
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readUnsignedByte

int readUnsignedByte()
                     throws JMSException
Reads an unsigned 8-bit number from the bytes message stream.

Returns:
the next byte from the bytes message stream, interpreted as an unsigned 8-bit number
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readShort

short readShort()
                throws JMSException
Reads a signed 16-bit number from the bytes message stream.

Returns:
the next two bytes from the bytes message stream, interpreted as a signed 16-bit number
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readUnsignedShort

int readUnsignedShort()
                      throws JMSException
Reads an unsigned 16-bit number from the bytes message stream.

Returns:
the next two bytes from the bytes message stream, interpreted as an unsigned 16-bit integer
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readChar

char readChar()
              throws JMSException
Reads a Unicode character value from the bytes message stream.

Returns:
the next two bytes from the bytes message stream as a Unicode character
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readInt

int readInt()
            throws JMSException
Reads a signed 32-bit integer from the bytes message stream.

Returns:
the next four bytes from the bytes message stream, interpreted as an int
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readLong

long readLong()
              throws JMSException
Reads a signed 64-bit integer from the bytes message stream.

Returns:
the next eight bytes from the bytes message stream, interpreted as a long
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readFloat

float readFloat()
                throws JMSException
Reads a float from the bytes message stream.

Returns:
the next four bytes from the bytes message stream, interpreted as a float
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readDouble

double readDouble()
                  throws JMSException
Reads a double from the bytes message stream.

Returns:
the next eight bytes from the bytes message stream, interpreted as a double
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readUTF

String readUTF()
               throws JMSException
Reads a string that has been encoded using a modified UTF-8 format from the bytes message stream.

For more information on the UTF-8 format, see "File System Safe UCS Transformation Format (FSS_UTF)", X/Open Preliminary Specification, X/Open Company Ltd., Document Number: P316. This information also appears in ISO/IEC 10646, Annex P.

Returns:
a Unicode string from the bytes message stream
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of bytes stream has been reached.
MessageNotReadableException - if the message is in write-only mode.

readBytes

int readBytes(byte[] value)
              throws JMSException
Reads a byte array from the bytes message stream.

If the length of array value is less than the number of bytes remaining to be read from the stream, the array should be filled. A subsequent call reads the next increment, and so on.

If the number of bytes remaining in the stream is less than the length of array value, the bytes should be read into the array. The return value of the total number of bytes read will be less than the length of the array, indicating that there are no more bytes left to be read from the stream. The next read of the stream returns -1.

Parameters:
value - the buffer into which the data is read
Returns:
the total number of bytes read into the buffer, or -1 if there is no more data because the end of the stream has been reached
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageNotReadableException - if the message is in write-only mode.

readBytes

int readBytes(byte[] value,
              int length)
              throws JMSException
Reads a portion of the bytes message stream.

If the length of array value is less than the number of bytes remaining to be read from the stream, the array should be filled. A subsequent call reads the next increment, and so on.

If the number of bytes remaining in the stream is less than the length of array value, the bytes should be read into the array. The return value of the total number of bytes read will be less than the length of the array, indicating that there are no more bytes left to be read from the stream. The next read of the stream returns -1.

If length is negative, or length is greater than the length of the array value, then an IndexOutOfBoundsException is thrown. No bytes will be read from the stream for this exception case.

Parameters:
value - the buffer into which the data is read
length - the number of bytes to read; must be less than or equal to value.length
Returns:
the total number of bytes read into the buffer, or -1 if there is no more data because the end of the stream has been reached
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageNotReadableException - if the message is in write-only mode.

writeBoolean

void writeBoolean(boolean value)
                  throws JMSException
Writes a boolean to the bytes message stream as a 1-byte value. The value true is written as the value (byte)1; the value false is written as the value (byte)0.

Parameters:
value - the boolean value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeByte

void writeByte(byte value)
               throws JMSException
Writes a byte to the bytes message stream as a 1-byte value.

Parameters:
value - the byte value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeShort

void writeShort(short value)
                throws JMSException
Writes a short to the bytes message stream as two bytes, high byte first.

Parameters:
value - the short to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeChar

void writeChar(char value)
               throws JMSException
Writes a char to the bytes message stream as a 2-byte value, high byte first.

Parameters:
value - the char value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeInt

void writeInt(int value)
              throws JMSException
Writes an int to the bytes message stream as four bytes, high byte first.

Parameters:
value - the int to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeLong

void writeLong(long value)
               throws JMSException
Writes a long to the bytes message stream as eight bytes, high byte first.

Parameters:
value - the long to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeFloat

void writeFloat(float value)
                throws JMSException
Converts the float argument to an int using the floatToIntBits method in class Float, and then writes that int value to the bytes message stream as a 4-byte quantity, high byte first.

Parameters:
value - the float value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeDouble

void writeDouble(double value)
                 throws JMSException
Converts the double argument to a long using the doubleToLongBits method in class Double, and then writes that long value to the bytes message stream as an 8-byte quantity, high byte first.

Parameters:
value - the double value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeUTF

void writeUTF(String value)
              throws JMSException
Writes a string to the bytes message stream using UTF-8 encoding in a machine-independent manner.

For more information on the UTF-8 format, see "File System Safe UCS Transformation Format (FSS_UTF)", X/Open Preliminary Specification, X/Open Company Ltd., Document Number: P316. This information also appears in ISO/IEC 10646, Annex P.

Parameters:
value - the String value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeBytes

void writeBytes(byte[] value)
                throws JMSException
Writes a byte array to the bytes message stream.

Parameters:
value - the byte array to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeBytes

void writeBytes(byte[] value,
                int offset,
                int length)
                throws JMSException
Writes a portion of a byte array to the bytes message stream.

Parameters:
value - the byte array value to be written
offset - the initial offset within the byte array
length - the number of bytes to use
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeObject

void writeObject(Object value)
                 throws JMSException
Writes an object to the bytes message stream.

This method works only for the objectified primitive object types (Integer, Double, Long ...), String objects, and byte arrays.

Parameters:
value - the object in the Java programming language ("Java object") to be written; it must not be null
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageFormatException - if the object is of an invalid type.
MessageNotWriteableException - if the message is in read-only mode.
NullPointerException - if the parameter value is null.

reset

void reset()
           throws JMSException
Puts the message body in read-only mode and repositions the stream of bytes to the beginning.

Throws:
JMSException - if the JMS provider fails to reset the message due to some internal error.
MessageFormatException - if the message has an invalid format.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Connection

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface Connection

All Known Subinterfaces:
QueueConnection, TopicConnection, XAConnection, XAQueueConnection, XATopicConnection
public interface Connection

A Connection object is a client's active connection to its JMS provider. It typically allocates provider resources outside the Java virtual machine (JVM).

Connections support concurrent use.

A connection serves several purposes:

  • It encapsulates an open connection with a JMS provider. It typically represents an open TCP/IP socket between a client and the service provider software.
  • Its creation is where client authentication takes place.
  • It can specify a unique client identifier.
  • It provides a ConnectionMetaData object.
  • It supports an optional ExceptionListener object.

Because the creation of a connection involves setting up authentication and communication, a connection is a relatively heavyweight object. Most clients will do all their messaging with a single connection. Other more advanced applications may use several connections. The JMS API does not architect a reason for using multiple connections; however, there may be operational reasons for doing so.

A JMS client typically creates a connection, one or more sessions, and a number of message producers and consumers. When a connection is created, it is in stopped mode. That means that no messages are being delivered.

It is typical to leave the connection in stopped mode until setup is complete (that is, until all message consumers have been created). At that point, the client calls the connection's start method, and messages begin arriving at the connection's consumers. This setup convention minimizes any client confusion that may result from asynchronous message delivery while the client is still in the process of setting itself up.

A connection can be started immediately, and the setup can be done afterwards. Clients that do this must be prepared to handle asynchronous message delivery while they are still in the process of setting up.

A message producer can send messages while a connection is stopped.

Version:
1.1 - February 1, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
ConnectionFactory, QueueConnection, TopicConnection

Method Summary
void | close() Closes the connection.
ConnectionConsumer | createConnectionConsumer(Destination destination, String messageSelector, ServerSessionPool sessionPool, int maxMessages) Creates a connection consumer for this connection (optional operation).
ConnectionConsumer | createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages) Create a durable connection consumer for this connection (optional operation).
Session | createSession(boolean transacted, int acknowledgeMode) Creates a Session object.
String | getClientID() Gets the client identifier for this connection.
ExceptionListener | getExceptionListener() Gets the ExceptionListener object for this connection.
ConnectionMetaData | getMetaData() Gets the metadata for this connection.
void | setClientID(String clientID) Sets the client identifier for this connection.
void | setExceptionListener(ExceptionListener listener) Sets an exception listener for this connection.
void | start() Starts (or restarts) a connection's delivery of incoming messages.
void | stop() Temporarily stops a connection's delivery of incoming messages.

Method Detail

createSession

Session createSession(boolean transacted,
                      int acknowledgeMode)
                      throws JMSException
Creates a Session object.

Parameters:
transacted - indicates whether the session is transacted
acknowledgeMode - indicates whether the consumer or the client will acknowledge any messages it receives; ignored if the session is transacted. Legal values are Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, and Session.DUPS_OK_ACKNOWLEDGE.
Returns:
a newly created session
Throws:
JMSException - if the Connection object fails to create a session due to some internal error or lack of support for the specific transaction and acknowledgement mode.
Since:
1.1
See Also:
Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE

getClientID

String getClientID()
                   throws JMSException
Gets the client identifier for this connection.

This value is specific to the JMS provider. It is either preconfigured by an administrator in a ConnectionFactory object or assigned dynamically by the application by calling the setClientID method.

Returns:
the unique client identifier
Throws:
JMSException - if the JMS provider fails to return the client ID for this connection due to some internal error.

setClientID

void setClientID(String clientID)
                 throws JMSException
Sets the client identifier for this connection.

The preferred way to assign a JMS client's client identifier is for it to be configured in a client-specific ConnectionFactory object and transparently assigned to the Connection object it creates.

Alternatively, a client can set a connection's client identifier using a provider-specific value. The facility to set a connection's client identifier explicitly is not a mechanism for overriding the identifier that has been administratively configured. It is provided for the case where no administratively specified identifier exists. If one does exist, an attempt to change it by setting it must throw an IllegalStateException. If a client sets the client identifier explicitly, it must do so immediately after it creates the connection and before any other action on the connection is taken. After this point, setting the client identifier is a programming error that should throw an IllegalStateException.

The purpose of the client identifier is to associate a connection and its objects with a state maintained on behalf of the client by a provider. The only such state identified by the JMS API is that required to support durable subscriptions.

If another connection with the same clientID is already running when this method is called, the JMS provider should detect the duplicate ID and throw an InvalidClientIDException.

Parameters:
clientID - the unique client identifier
Throws:
JMSException - if the JMS provider fails to set the client ID for this connection due to some internal error.
InvalidClientIDException - if the JMS client specifies an invalid or duplicate client ID.
IllegalStateException - if the JMS client attempts to set a connection's client ID at the wrong time or when it has been administratively configured.

getMetaData

ConnectionMetaData getMetaData()
                               throws JMSException
Gets the metadata for this connection.

Returns:
the connection metadata
Throws:
JMSException - if the JMS provider fails to get the connection metadata for this connection.
See Also:
ConnectionMetaData

getExceptionListener

ExceptionListener getExceptionListener()
                                       throws JMSException
Gets the ExceptionListener object for this connection. Not every Connection has an ExceptionListener associated with it.

Returns:
the ExceptionListener for this connection, or null. if no ExceptionListener is associated with this connection.
Throws:
JMSException - if the JMS provider fails to get the ExceptionListener for this connection.
See Also:
setExceptionListener(javax.jms.ExceptionListener)

setExceptionListener

void setExceptionListener(ExceptionListener listener)
                          throws JMSException
Sets an exception listener for this connection.

If a JMS provider detects a serious problem with a connection, it informs the connection's ExceptionListener, if one has been registered. It does this by calling the listener's onException method, passing it a JMSException object describing the problem.

An exception listener allows a client to be notified of a problem asynchronously. Some connections only consume messages, so they would have no other way to learn their connection has failed.

A connection serializes execution of its ExceptionListener.

A JMS provider should attempt to resolve connection problems itself before it notifies the client of them.

Parameters:
listener - the exception listener
Throws:
JMSException - if the JMS provider fails to set the exception listener for this connection.

start

void start()
           throws JMSException
Starts (or restarts) a connection's delivery of incoming messages. A call to start on a connection that has already been started is ignored.

Throws:
JMSException - if the JMS provider fails to start message delivery due to some internal error.
See Also:
stop()

stop

void stop()
          throws JMSException
Temporarily stops a connection's delivery of incoming messages. Delivery can be restarted using the connection's start method. When the connection is stopped, delivery to all the connection's message consumers is inhibited: synchronous receives block, and messages are not delivered to message listeners.

This call blocks until receives and/or message listeners in progress have completed.

Stopping a connection has no effect on its ability to send messages. A call to stop on a connection that has already been stopped is ignored.

A call to stop must not return until delivery of messages has paused. This means that a client can rely on the fact that none of its message listeners will be called and that all threads of control waiting for receive calls to return will not return with a message until the connection is restarted. The receive timers for a stopped connection continue to advance, so receives may time out while the connection is stopped.

If message listeners are running when stop is invoked, the stop call must wait until all of them have returned before it may return. While these message listeners are completing, they must have the full services of the connection available to them.

Throws:
JMSException - if the JMS provider fails to stop message delivery due to some internal error.
See Also:
start()

close

void close()
           throws JMSException
Closes the connection.

Since a provider typically allocates significant resources outside the JVM on behalf of a connection, clients should close these resources when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

There is no need to close the sessions, producers, and consumers of a closed connection.

Closing a connection causes all temporary destinations to be deleted.

When this method is invoked, it should not return until message processing has been shut down in an orderly fashion. This means that all message listeners that may have been running have returned, and that all pending receives have returned. A close terminates all pending message receives on the connection's sessions' consumers. The receives may return with a message or with null, depending on whether there was a message available at the time of the close. If one or more of the connection's sessions' message listeners is processing a message at the time when connection close is invoked, all the facilities of the connection and its sessions must remain available to those listeners until they return control to the JMS provider.

Closing a connection causes any of its sessions' transactions in progress to be rolled back. In the case where a session's work is coordinated by an external transaction manager, a session's commit and rollback methods are not used and the result of a closed session's work is determined later by the transaction manager. Closing a connection does NOT force an acknowledgment of client-acknowledged sessions.

Invoking the acknowledge method of a received message from a closed connection's session must throw an IllegalStateException. Closing a closed connection must NOT throw an exception.

Throws:
JMSException - if the JMS provider fails to close the connection due to some internal error. For example, a failure to release resources or to close a socket connection can cause this exception to be thrown.

createConnectionConsumer

ConnectionConsumer createConnectionConsumer(Destination destination,
                                            String messageSelector,
                                            ServerSessionPool sessionPool,
                                            int maxMessages)
                                            throws JMSException
Creates a connection consumer for this connection (optional operation). This is an expert facility not used by regular JMS clients.

Parameters:
destination - the destination to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
sessionPool - the server session pool to associate with this connection consumer
maxMessages - the maximum number of messages that can be assigned to a server session at one time
Returns:
the connection consumer
Throws:
JMSException - if the Connection object fails to create a connection consumer due to some internal error or invalid arguments for sessionPool and messageSelector.
InvalidDestinationException - if an invalid destination is specified.
InvalidSelectorException - if the message selector is invalid.
Since:
1.1
See Also:
ConnectionConsumer

createDurableConnectionConsumer

ConnectionConsumer createDurableConnectionConsumer(Topic topic,
                                                   String subscriptionName,
                                                   String messageSelector,
                                                   ServerSessionPool sessionPool,
                                                   int maxMessages)
                                                   throws JMSException
Create a durable connection consumer for this connection (optional operation). This is an expert facility not used by regular JMS clients.

Parameters:
topic - topic to access
subscriptionName - durable subscription name
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
sessionPool - the server session pool to associate with this durable connection consumer
maxMessages - the maximum number of messages that can be assigned to a server session at one time
Returns:
the durable connection consumer
Throws:
JMSException - if the Connection object fails to create a connection consumer due to some internal error or invalid arguments for sessionPool and messageSelector.
InvalidDestinationException - if an invalid destination is specified.
InvalidSelectorException - if the message selector is invalid.
Since:
1.1
See Also:
ConnectionConsumer
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionConsumer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ConnectionConsumer

public interface ConnectionConsumer

For application servers, Connection objects provide a special facility for creating a ConnectionConsumer (optional). The messages it is to consume are specified by a Destination and a message selector. In addition, a ConnectionConsumer must be given a ServerSessionPool to use for processing its messages.

Normally, when traffic is light, a ConnectionConsumer gets a ServerSession from its pool, loads it with a single message, and starts it. As traffic picks up, messages can back up. If this happens, a ConnectionConsumer can load each ServerSession with more than one message. This reduces the thread context switches and minimizes resource use at the expense of some serialization of message processing.

Version:
1.1 February 8, 2002
Author:
Mark Hapner, Rich Burridge
See Also:
Connection.createConnectionConsumer(javax.jms.Destination, java.lang.String, javax.jms.ServerSessionPool, int),
Connection.createDurableConnectionConsumer(javax.jms.Topic, java.lang.String, java.lang.String, javax.jms.ServerSessionPool, int),
QueueConnection.createConnectionConsumer(javax.jms.Queue, java.lang.String, javax.jms.ServerSessionPool, int),
TopicConnection.createConnectionConsumer(javax.jms.Topic, java.lang.String, javax.jms.ServerSessionPool, int),
TopicConnection.createDurableConnectionConsumer(javax.jms.Topic, java.lang.String, java.lang.String, javax.jms.ServerSessionPool, int)

Method Summary
void | close() Closes the connection consumer.
ServerSessionPool | getServerSessionPool() Gets the server session pool associated with this connection consumer.

Method Detail

getServerSessionPool

ServerSessionPool getServerSessionPool()
                                       throws JMSException
Gets the server session pool associated with this connection consumer.

Returns:
the server session pool used by this connection consumer
Throws:
JMSException - if the JMS provider fails to get the server session pool associated with this consumer due to some internal error.

close

void close()
           throws JMSException
Closes the connection consumer.

Since a provider may allocate some resources on behalf of a connection consumer outside the Java virtual machine, clients should close these resources when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

Throws:
JMSException - if the JMS provider fails to release resources on behalf of the connection consumer or fails to close the connection consumer.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ConnectionFactory

All Known Subinterfaces:
QueueConnectionFactory, TopicConnectionFactory, XAQueueConnectionFactory, XATopicConnectionFactory
public interface ConnectionFactory

A ConnectionFactory object encapsulates a set of connection configuration parameters that has been defined by an administrator. A client uses it to create a connection with a JMS provider.

A ConnectionFactory object is a JMS administered object and supports concurrent use.

JMS administered objects are objects containing configuration information that are created by an administrator and later used by JMS clients. They make it practical to administer the JMS API in the enterprise.

Although the interfaces for administered objects do not explicitly depend on the Java Naming and Directory Interface (JNDI) API, the JMS API establishes the convention that JMS clients find administered objects by looking them up in a JNDI namespace.

An administrator can place an administered object anywhere in a namespace. The JMS API does not define a naming policy.

It is expected that JMS providers will provide the tools an administrator needs to create and configure administered objects in a JNDI namespace. JMS provider implementations of administered objects should be both javax.jndi.Referenceable and java.io.Serializable so that they can be stored in all JNDI naming contexts. In addition, it is recommended that these implementations follow the JavaBeansTM design patterns.

This strategy provides several benefits:

  • It hides provider-specific details from JMS clients.
  • It abstracts administrative information into objects in the Java programming language ("Java objects") that are easily organized and administered from a common management console.
  • Since there will be JNDI providers for all popular naming services, this means that JMS providers can deliver one implementation of administered objects that will run everywhere.

An administered object should not hold on to any remote resources. Its lookup should not use remote resources other than those used by the JNDI API itself.

Clients should think of administered objects as local Java objects. Looking them up should not have any hidden side effects or use surprising amounts of local resources.

Version:
1.1 - February 1, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Connection, QueueConnectionFactory, TopicConnectionFactory

Method Summary
Connection | createConnection() Creates a connection with the default user identity.
Connection | createConnection(String userName, String password) Creates a connection with the specified user identity.

Method Detail

createConnection

Connection createConnection()
                            throws JMSException
Creates a connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Returns:
a newly created connection
Throws:
JMSException - if the JMS provider fails to create the connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Since:
1.1

createConnection

Connection createConnection(String userName,
                            String password)
                            throws JMSException
Creates a connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Parameters:
userName - the caller's user name
password - the caller's password
Returns:
a newly created connection
Throws:
JMSException - if the JMS provider fails to create the connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Since:
1.1
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionMetaData

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ConnectionMetaData

public interface ConnectionMetaData

A ConnectionMetaData object provides information describing the Connection object.

Version:
1.0 - 13 March 1998
Author:
Mark Hapner, Rich Burridge

Method Summary
int | getJMSMajorVersion() Gets the JMS major version number.
int | getJMSMinorVersion() Gets the JMS minor version number.
String | getJMSProviderName() Gets the JMS provider name.
String | getJMSVersion() Gets the JMS API version.
Enumeration | getJMSXPropertyNames() Gets an enumeration of the JMSX property names.
int | getProviderMajorVersion() Gets the JMS provider major version number.
int | getProviderMinorVersion() Gets the JMS provider minor version number.
String | getProviderVersion() Gets the JMS provider version.

Method Detail

getJMSVersion

String getJMSVersion()
                     throws JMSException
Gets the JMS API version.

Returns:
the JMS API version
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getJMSMajorVersion

int getJMSMajorVersion()
                       throws JMSException
Gets the JMS major version number.

Returns:
the JMS API major version number
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getJMSMinorVersion

int getJMSMinorVersion()
                       throws JMSException
Gets the JMS minor version number.

Returns:
the JMS API minor version number
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getJMSProviderName

String getJMSProviderName()
                          throws JMSException
Gets the JMS provider name.

Returns:
the JMS provider name
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getProviderVersion

String getProviderVersion()
                          throws JMSException
Gets the JMS provider version.

Returns:
the JMS provider version
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getProviderMajorVersion

int getProviderMajorVersion()
                            throws JMSException
Gets the JMS provider major version number.

Returns:
the JMS provider major version number
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getProviderMinorVersion

int getProviderMinorVersion()
                            throws JMSException
Gets the JMS provider minor version number.

Returns:
the JMS provider minor version number
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.

getJMSXPropertyNames

Enumeration getJMSXPropertyNames()
                                 throws JMSException
Gets an enumeration of the JMSX property names.

Returns:
an Enumeration of JMSX property names
Throws:
JMSException - if the JMS provider fails to retrieve the metadata due to some internal error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DeliveryMode

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface DeliveryMode

public interface DeliveryMode

The delivery modes supported by the JMS API are PERSISTENT and NON_PERSISTENT.

A client marks a message as persistent if it feels that the application will have problems if the message is lost in transit. A client marks a message as non-persistent if an occasional lost message is tolerable. Clients use delivery mode to tell a JMS provider how to balance message transport reliability with throughput.

Delivery mode covers only the transport of the message to its destination. Retention of a message at the destination until its receipt is acknowledged is not guaranteed by a PERSISTENT delivery mode. Clients should assume that message retention policies are set administratively. Message retention policy governs the reliability of message delivery from destination to message consumer. For example, if a client's message storage space is exhausted, some messages may be dropped in accordance with a site-specific message retention policy.

A message is guaranteed to be delivered once and only once by a JMS provider if the delivery mode of the message is PERSISTENT and if the destination has a sufficient message retention policy.

Version:
1.0 - 7 August 1998
Author:
Mark Hapner, Rich Burridge

Field Summary
static int | NON_PERSISTENT This is the lowest-overhead delivery mode because it does not require that the message be logged to stable storage.
static int | PERSISTENT This delivery mode instructs the JMS provider to log the message to stable storage as part of the client's send operation.

Field Detail

NON_PERSISTENT

static final int NON_PERSISTENT
This is the lowest-overhead delivery mode because it does not require that the message be logged to stable storage. The level of JMS provider failure that causes a NON_PERSISTENT message to be lost is not defined.

A JMS provider must deliver a NON_PERSISTENT message with an at-most-once guarantee. This means that it may lose the message, but it must not deliver it twice.

See Also:
Constant Field Values

PERSISTENT

static final int PERSISTENT
This delivery mode instructs the JMS provider to log the message to stable storage as part of the client's send operation. Only a hard media failure should cause a PERSISTENT message to be lost.

See Also:
Constant Field Values
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ExceptionListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ExceptionListener

public interface ExceptionListener

If a JMS provider detects a serious problem with a Connection object, it informs the Connection object's ExceptionListener, if one has been registered. It does this by calling the listener's onException method, passing it a JMSException argument describing the problem.

An exception listener allows a client to be notified of a problem asynchronously. Some connections only consume messages, so they would have no other way to learn that their connection has failed.

A JMS provider should attempt to resolve connection problems itself before it notifies the client of them.

Version:
1.0 - 9 March 1998
Author:
Mark Hapner, Rich Burridge
See Also:
Connection.setExceptionListener(ExceptionListener)

Method Summary
 void onException(JMSException exception)
Notifies user of a JMS exception.

Method Detail

onException

void onException(JMSException exception)
Notifies user of a JMS exception.

Parameters:
exception - the JMS exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


IllegalStateException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class IllegalStateException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.jms.JMSException
                extended by  javax.jms.IllegalStateException
All Implemented Interfaces:
Serializable
public class IllegalStateException
extends JMSException

This exception is thrown when a method is invoked at an illegal or inappropriate time or if the provider is not in an appropriate state for the requested operation. For example, this exception must be thrown if Session.commit is called on a non-transacted session. This exception is also called when a domain inappropriate method is called, such as calling TopicSession.CreateQueueBrowser.

Version:
April 9, 2002
Author:
Rahul Sharma, Kate Stout
See Also:
Serialized Form

Constructor Summary
IllegalStateException(String reason)
Constructs an IllegalStateException with the specified reason.
IllegalStateException(String reason, String errorCode)
Constructs an IllegalStateException with the specified reason and error code.
Method Summary
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IllegalStateException

public IllegalStateException(String reason,
                             String errorCode)
Constructs an IllegalStateException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

IllegalStateException

public IllegalStateException(String reason)
Constructs an IllegalStateException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InvalidClientIDException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class InvalidClientIDException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.jms.JMSException
                extended by  javax.jms.InvalidClientIDException
All Implemented Interfaces:
Serializable
public class InvalidClientIDException
extends JMSException

This exception must be thrown when a client attempts to set a connection's client ID to a value that is rejected by a provider.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
InvalidClientIDException(String reason)
Constructs an InvalidClientIDException with the specified reason.
InvalidClientIDException(String reason, String errorCode)
Constructs an InvalidClientIDException with the specified reason and error code.
Method Summary
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidClientIDException

public InvalidClientIDException(String reason,
                                String errorCode)
Constructs an InvalidClientIDException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

InvalidClientIDException

public InvalidClientIDException(String reason)
Constructs an InvalidClientIDException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InvalidDestinationException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class InvalidDestinationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.jms.JMSException
                extended by  javax.jms.InvalidDestinationException
All Implemented Interfaces:
Serializable
public class InvalidDestinationException
extends JMSException

This exception must be thrown when a destination either is not understood by a provider or is no longer valid.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
InvalidDestinationException(String reason)
Constructs an InvalidDestinationException with the specified reason.
InvalidDestinationException(String reason, String errorCode)
Constructs an InvalidDestinationException with the specified reason and error code.
Method Summary
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidDestinationException

public InvalidDestinationException(String reason,
                                   String errorCode)
Constructs an InvalidDestinationException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

InvalidDestinationException

public InvalidDestinationException(String reason)
Constructs an InvalidDestinationException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InvalidSelectorException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class InvalidSelectorException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.jms.JMSException
                extended by  javax.jms.InvalidSelectorException
All Implemented Interfaces:
Serializable
public class InvalidSelectorException
extends JMSException

This exception must be thrown when a JMS client attempts to give a provider a message selector with invalid syntax.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
InvalidSelectorException(String reason)
Constructs an InvalidSelectorException with the specified reason.
InvalidSelectorException(String reason, String errorCode)
Constructs an InvalidSelectorException with the specified reason and error code.
Method Summary
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidSelectorException

public InvalidSelectorException(String reason,
                                String errorCode)
Constructs an InvalidSelectorException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

InvalidSelectorException

public InvalidSelectorException(String reason)
Constructs an InvalidSelectorException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JMSException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class JMSException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.jms.JMSException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
IllegalStateException, InvalidClientIDException, InvalidDestinationException, InvalidSelectorException, JMSSecurityException, MessageEOFException, MessageFormatException, MessageNotReadableException, MessageNotWriteableException, ResourceAllocationException, TransactionInProgressException, TransactionRolledBackException
public class JMSException
extends Exception

This is the root class of all JMS API exceptions.

It provides the following information:

  • A provider-specific string describing the error. This string is the standard exception message and is available via the getMessage method.
  • A provider-specific string error code
  • A reference to another exception. Often a JMS API exception will be the result of a lower-level problem. If appropriate, this lower-level exception can be linked to the JMS API exception.

Version:
1.0 - 5 Oct 1998
Author:
Mark Hapner, Rich Burridge
See Also:
Serialized Form

Constructor Summary
JMSException(String reason)
Constructs a JMSException with the specified reason and with the error code defaulting to null.
JMSException(String reason, String errorCode)
Constructs a JMSException with the specified reason and error code.
Method Summary
String | getErrorCode() Gets the vendor-specific error code.
Exception | getLinkedException() Gets the exception linked to this one.
void | setLinkedException(Exception ex) Adds a linked Exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JMSException

public JMSException(String reason,
                    String errorCode)
Constructs a JMSException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

JMSException

public JMSException(String reason)
Constructs a JMSException with the specified reason and with the error code defaulting to null.

Parameters:
reason - a description of the exception
Method Detail

getErrorCode

public String getErrorCode()
Gets the vendor-specific error code.

Returns:
a string specifying the vendor-specific error code

getLinkedException

public Exception getLinkedException()
Gets the exception linked to this one.

Returns:
the linked Exception, null if none

setLinkedException

public void setLinkedException(Exception ex)
Adds a linked Exception.

Parameters:
ex - the linked Exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JMSSecurityException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class JMSSecurityException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.jms.JMSException
                extended by  javax.jms.JMSSecurityException
All Implemented Interfaces:
Serializable
public class JMSSecurityException
extends JMSException

This exception must be thrown when a provider rejects a user name/password submitted by a client. It may also be thrown for any case where a security restriction prevents a method from completing.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
JMSSecurityException(String reason)
Constructs a JMSSecurityException with the specified reason.
JMSSecurityException(String reason, String errorCode)
Constructs a JMSSecurityException with the specified reason and error code.
Method Summary
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JMSSecurityException

public JMSSecurityException(String reason,
                            String errorCode)
Constructs a JMSSecurityException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

JMSSecurityException

public JMSSecurityException(String reason)
Constructs a JMSSecurityException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MapMessage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface MapMessage

All Superinterfaces:
Message
public interface MapMessage
extends Message

A MapMessage object is used to send a set of name-value pairs. The names are String objects, and the values are primitive data types in the Java programming language. The names must have a value that is not null, and not an empty string. The entries can be accessed sequentially or randomly by name. The order of the entries is undefined. MapMessage inherits from the Message interface and adds a message body that contains a Map.

The primitive types can be read or written explicitly using methods for each type. They may also be read or written generically as objects. For instance, a call to MapMessage.setInt("foo", 6) is equivalent to MapMessage.setObject("foo", new Integer(6)). Both forms are provided, because the explicit form is convenient for static programming, and the object form is needed when types are not known at compile time.

When a client receives a MapMessage, it is in read-only mode. If a client attempts to write to the message at this point, a MessageNotWriteableException is thrown. If clearBody is called, the message can now be both read from and written to.

MapMessage objects support the following conversion table. The marked cases must be supported. The unmarked cases must throw a JMSException. The String-to-primitive conversions may throw a runtime exception if the primitive's valueOf() method does not accept it as a valid String representation of the primitive.

A value written as the row type can be read as the column type.

 |        | boolean byte short char int long float double String byte[]
 |----------------------------------------------------------------------
 |boolean |    X                                            X
 |byte    |          X     X         X   X                  X
 |short   |                X         X   X                  X
 |char    |                     X                           X
 |int     |                          X   X                  X
 |long    |                              X                  X
 |float   |                                    X     X      X
 |double  |                                          X      X
 |String  |    X     X     X         X   X     X     X      X
 |byte[]  |                                                        X
 |----------------------------------------------------------------------

Attempting to read a null value as a primitive type must be treated as calling the primitive's corresponding valueOf(String) conversion method with a null value. Since char does not support a String conversion, attempting to read a null value as a char must throw a NullPointerException.

Version:
1.1 February 2, 002
Author:
Mark Hapner, Rich Burridge
See Also:
Session.createMapMessage(), BytesMessage, Message, ObjectMessage, StreamMessage, TextMessage

Field Summary
Fields inherited from interface javax.jms.Message
DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE
Method Summary
boolean | getBoolean(String name) Returns the boolean value with the specified name.
byte | getByte(String name) Returns the byte value with the specified name.
byte[] | getBytes(String name) Returns the byte array value with the specified name.
char | getChar(String name) Returns the Unicode character value with the specified name.
double | getDouble(String name) Returns the double value with the specified name.
float | getFloat(String name) Returns the float value with the specified name.
int | getInt(String name) Returns the int value with the specified name.
long | getLong(String name) Returns the long value with the specified name.
Enumeration | getMapNames() Returns an Enumeration of all the names in the MapMessage object.
Object | getObject(String name) Returns the value of the object with the specified name.
short | getShort(String name) Returns the short value with the specified name.
String | getString(String name) Returns the String value with the specified name.
boolean | itemExists(String name) Indicates whether an item exists in this MapMessage object.
void | setBoolean(String name, boolean value) Sets a boolean value with the specified name into the Map.
void | setByte(String name, byte value) Sets a byte value with the specified name into the Map.
void | setBytes(String name, byte[] value) Sets a byte array value with the specified name into the Map.
void | setBytes(String name, byte[] value, int offset, int length) Sets a portion of the byte array value with the specified name into the Map.
void | setChar(String name, char value) Sets a Unicode character value with the specified name into the Map.
void | setDouble(String name, double value) Sets a double value with the specified name into the Map.
void | setFloat(String name, float value) Sets a float value with the specified name into the Map.
void | setInt(String name, int value) Sets an int value with the specified name into the Map.
void | setLong(String name, long value) Sets a long value with the specified name into the Map.
void | setObject(String name, Object value) Sets an object value with the specified name into the Map.
void | setShort(String name, short value) Sets a short value with the specified name into the Map.
void | setString(String name, String value) Sets a String value with the specified name into the Map.
Methods inherited from interface javax.jms.Message
acknowledge, clearBody, clearProperties, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

Method Detail

getBoolean

boolean getBoolean(String name)
                   throws JMSException
Returns the boolean value with the specified name.

Parameters:
name - the name of the boolean
Returns:
the boolean value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getByte

byte getByte(String name)
             throws JMSException
Returns the byte value with the specified name.

Parameters:
name - the name of the byte
Returns:
the byte value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getShort

short getShort(String name)
               throws JMSException
Returns the short value with the specified name.

Parameters:
name - the name of the short
Returns:
the short value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getChar

char getChar(String name)
             throws JMSException
Returns the Unicode character value with the specified name.

Parameters:
name - the name of the Unicode character
Returns:
the Unicode character value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getInt

int getInt(String name)
           throws JMSException
Returns the int value with the specified name.

Parameters:
name - the name of the int
Returns:
the int value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getLong

long getLong(String name)
             throws JMSException
Returns the long value with the specified name.

Parameters:
name - the name of the long
Returns:
the long value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getFloat

float getFloat(String name)
               throws JMSException
Returns the float value with the specified name.

Parameters:
name - the name of the float
Returns:
the float value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getDouble

double getDouble(String name)
                 throws JMSException
Returns the double value with the specified name.

Parameters:
name - the name of the double
Returns:
the double value with the specified name
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getString

String getString(String name)
                 throws JMSException
Returns the String value with the specified name.

Parameters:
name - the name of the String
Returns:
the String value with the specified name; if there is no item by this name, a null value is returned
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getBytes

byte[] getBytes(String name)
                throws JMSException
Returns the byte array value with the specified name.

Parameters:
name - the name of the byte array
Returns:
a copy of the byte array value with the specified name; if there is no item by this name, a null value is returned.
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageFormatException - if this type conversion is invalid.

getObject

Object getObject(String name)
                 throws JMSException
Returns the value of the object with the specified name.

This method can be used to return, in objectified format, an object in the Java programming language ("Java object") that had been stored in the Map with the equivalent setObject method call, or its equivalent primitive settype method.

Note that byte values are returned as byte[], not Byte[].

Parameters:
name - the name of the Java object
Returns:
a copy of the Java object value with the specified name, in objectified format (for example, if the object was set as an int, an Integer is returned); if there is no item by this name, a null value is returned
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.

getMapNames

Enumeration getMapNames()
                        throws JMSException
Returns an Enumeration of all the names in the MapMessage object.

Returns:
an enumeration of all the names in this MapMessage
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.

setBoolean

void setBoolean(String name,
                boolean value)
                throws JMSException
Sets a boolean value with the specified name into the Map.

Parameters:
name - the name of the boolean
value - the boolean value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setByte

void setByte(String name,
             byte value)
             throws JMSException
Sets a byte value with the specified name into the Map.

Parameters:
name - the name of the byte
value - the byte value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setShort

void setShort(String name,
              short value)
              throws JMSException
Sets a short value with the specified name into the Map.

Parameters:
name - the name of the short
value - the short value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setChar

void setChar(String name,
             char value)
             throws JMSException
Sets a Unicode character value with the specified name into the Map.

Parameters:
name - the name of the Unicode character
value - the Unicode character value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setInt

void setInt(String name,
            int value)
            throws JMSException
Sets an int value with the specified name into the Map.

Parameters:
name - the name of the int
value - the int value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setLong

void setLong(String name,
             long value)
             throws JMSException
Sets a long value with the specified name into the Map.

Parameters:
name - the name of the long
value - the long value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setFloat

void setFloat(String name,
              float value)
              throws JMSException
Sets a float value with the specified name into the Map.

Parameters:
name - the name of the float
value - the float value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setDouble

void setDouble(String name,
               double value)
               throws JMSException
Sets a double value with the specified name into the Map.

Parameters:
name - the name of the double
value - the double value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setString

void setString(String name,
               String value)
               throws JMSException
Sets a String value with the specified name into the Map.

Parameters:
name - the name of the String
value - the String value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setBytes

void setBytes(String name,
              byte[] value)
              throws JMSException
Sets a byte array value with the specified name into the Map.

Parameters:
name - the name of the byte array
value - the byte array value to set in the Map; the array is copied so that the value for name will not be altered by future modifications
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
NullPointerException - if the name is null, or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setBytes

void setBytes(String name,
              byte[] value,
              int offset,
              int length)
              throws JMSException
Sets a portion of the byte array value with the specified name into the Map.

Parameters:
name - the name of the byte array
value - the byte array value to set in the Map
offset - the initial offset within the byte array
length - the number of bytes to use
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageNotWriteableException - if the message is in read-only mode.

setObject

void setObject(String name,
               Object value)
               throws JMSException
Sets an object value with the specified name into the Map.

This method works only for the objectified primitive object types (Integer, Double, Long ...), String objects, and byte arrays.

Parameters:
name - the name of the Java object
value - the Java object value to set in the Map
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
IllegalArgumentException - if the name is null or if the name is an empty string.
MessageFormatException - if the object is invalid.
MessageNotWriteableException - if the message is in read-only mode.

itemExists

boolean itemExists(String name)
                   throws JMSException
Indicates whether an item exists in this MapMessage object.

Parameters:
name - the name of the item to test
Returns:
true if the item exists
Throws:
JMSException - if the JMS provider fails to determine if the item exists due to some internal error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Message

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface Message

All Known Subinterfaces:
BytesMessage, MapMessage, ObjectMessage, StreamMessage, TextMessage
public interface Message

The Message interface is the root interface of all JMS messages. It defines the message header and the acknowledge method used for all messages.

Most message-oriented middleware (MOM) products treat messages as lightweight entities that consist of a header and a payload. The header contains fields used for message routing and identification; the payload contains the application data being sent.

Within this general form, the definition of a message varies significantly across products. It would be quite difficult for the JMS API to support all of these message models.

With this in mind, the JMS message model has the following goals:

  • Provide a single, unified message API
  • Provide an API suitable for creating messages that match the format used by provider-native messaging applications
  • Support the development of heterogeneous applications that span operating systems, machine architectures, and computer languages
  • Support messages containing objects in the Java programming language ("Java objects")
  • Support messages containing Extensible Markup Language (XML) pages

JMS messages are composed of the following parts:

  • Header - All messages support the same set of header fields. Header fields contain values used by both clients and providers to identify and route messages.
  • Properties - Each message contains a built-in facility for supporting application-defined property values. Properties provide an efficient mechanism for supporting application-defined message filtering.
  • Body - The JMS API defines several types of message body, which cover the majority of messaging styles currently in use.

Message Bodies

The JMS API defines five types of message body:

  • Stream - A StreamMessage object's message body contains a stream of primitive values in the Java programming language ("Java primitives"). It is filled and read sequentially.
  • Map - A MapMessage object's message body contains a set of name-value pairs, where names are String objects, and values are Java primitives. The entries can be accessed sequentially or randomly by name. The order of the entries is undefined.
  • Text - A TextMessage object's message body contains a java.lang.String object. This message type can be used to transport plain-text messages, and XML messages.
  • Object - An ObjectMessage object's message body contains a Serializable Java object.
  • Bytes - A BytesMessage object's message body contains a stream of uninterpreted bytes. This message type is for literally encoding a body to match an existing message format. In many cases, it is possible to use one of the other body types, which are easier to use. Although the JMS API allows the use of message properties with byte messages, they are typically not used, since the inclusion of properties may affect the format.

Message Headers

The JMSCorrelationID header field is used for linking one message with another. It typically links a reply message with its requesting message.

JMSCorrelationID can hold a provider-specific message ID, an application-specific String object, or a provider-native byte[] value.

Message Properties

A Message object contains a built-in facility for supporting application-defined property values. In effect, this provides a mechanism for adding application-specific header fields to a message.

Properties allow an application, via message selectors, to have a JMS provider select, or filter, messages on its behalf using application-specific criteria.

Property names must obey the rules for a message selector identifier. Property names must not be null, and must not be empty strings. If a property name is set and it is either null or an empty string, an IllegalArgumentException must be thrown.

Property values can be boolean, byte, short, int, long, float, double, and String.

Property values are set prior to sending a message. When a client receives a message, its properties are in read-only mode. If a client attempts to set properties at this point, a MessageNotWriteableException is thrown. If clearProperties is called, the properties can now be both read from and written to. Note that header fields are distinct from properties. Header fields are never in read-only mode.

A property value may duplicate a value in a message's body, or it may not. Although JMS does not define a policy for what should or should not be made a property, application developers should note that JMS providers will likely handle data in a message's body more efficiently than data in a message's properties. For best performance, applications should use message properties only when they need to customize a message's header. The primary reason for doing this is to support customized message selection.

Message properties support the following conversion table. The marked cases must be supported. The unmarked cases must throw a JMSException. The String-to-primitive conversions may throw a runtime exception if the primitive's valueOf method does not accept the String as a valid representation of the primitive.

A value written as the row type can be read as the column type.

 |        | boolean byte short int long float double String
 |----------------------------------------------------------
 |boolean |    X                                       X
 |byte    |          X     X    X   X                  X
 |short   |                X    X   X                  X
 |int     |                     X   X                  X
 |long    |                         X                  X
 |float   |                               X     X      X
 |double  |                                     X      X
 |String  |    X     X     X    X   X     X     X      X
 |----------------------------------------------------------

In addition to the type-specific set/get methods for properties, JMS provides the setObjectProperty and getObjectProperty methods. These support the same set of property types using the objectified primitive values. Their purpose is to allow the decision of property type to made at execution time rather than at compile time. They support the same property value conversions.

The setObjectProperty method accepts values of class Boolean, Byte, Short, Integer, Long, Float, Double, and String. An attempt to use any other class must throw a JMSException.

The getObjectProperty method only returns values of class Boolean, Byte, Short, Integer, Long, Float, Double, and String.

The order of property values is not defined. To iterate through a message's property values, use getPropertyNames to retrieve a property name enumeration and then use the various property get methods to retrieve their values.

A message's properties are deleted by the clearProperties method. This leaves the message with an empty set of properties.

Getting a property value for a name which has not been set returns a null value. Only the getStringProperty and getObjectProperty methods can return a null value. Attempting to read a null value as a primitive type must be treated as calling the primitive's corresponding valueOf(String) conversion method with a null value.

The JMS API reserves the JMSX property name prefix for JMS defined properties. The full set of these properties is defined in the Java Message Service specification. New JMS defined properties may be added in later versions of the JMS API. Support for these properties is optional. The String[] ConnectionMetaData.getJMSXPropertyNames method returns the names of the JMSX properties supported by a connection.

JMSX properties may be referenced in message selectors whether or not they are supported by a connection. If they are not present in a message, they are treated like any other absent property.

JMSX properties defined in the specification as "set by provider on send" are available to both the producer and the consumers of the message. JMSX properties defined in the specification as "set by provider on receive" are available only to the consumers.

JMSXGroupID and JMSXGroupSeq are standard properties that clients should use if they want to group messages. All providers must support them. Unless specifically noted, the values and semantics of the JMSX properties are undefined.

The JMS API reserves the JMS_vendor_name property name prefix for provider-specific properties. Each provider defines its own value for vendor_name. This is the mechanism a JMS provider uses to make its special per-message services available to a JMS client.

The purpose of provider-specific properties is to provide special features needed to integrate JMS clients with provider-native clients in a single JMS application. They should not be used for messaging between JMS clients.

Provider Implementations of JMS Message Interfaces

The JMS API provides a set of message interfaces that define the JMS message model. It does not provide implementations of these interfaces.

Each JMS provider supplies a set of message factories with its Session object for creating instances of messages. This allows a provider to use message implementations tailored to its specific needs.

A provider must be prepared to accept message implementations that are not its own. They may not be handled as efficiently as its own implementation; however, they must be handled.

Note the following exception case when a provider is handling a foreign message implementation. If the foreign message implementation contains a JMSReplyTo header field that is set to a foreign destination implementation, the provider is not required to handle or preserve the value of this header field.

Message Selectors

A JMS message selector allows a client to specify, by header field references and property references, the messages it is interested in. Only messages whose header and property values match the selector are delivered. What it means for a message not to be delivered depends on the MessageConsumer being used (see QueueReceiver and TopicSubscriber).

Message selectors cannot reference message body values.

A message selector matches a message if the selector evaluates to true when the message's header field values and property values are substituted for their corresponding identifiers in the selector.

A message selector is a String whose syntax is based on a subset of the SQL92 conditional expression syntax. If the value of a message selector is an empty string, the value is treated as a null and indicates that there is no message selector for the message consumer.

The order of evaluation of a message selector is from left to right within precedence level. Parentheses can be used to change this order.

Predefined selector literals and operator names are shown here in uppercase; however, they are case insensitive.

A selector can contain:

  • Literals:
    • A string literal is enclosed in single quotes, with a single quote represented by doubled single quote; for example, 'literal' and 'literal''s'. Like string literals in the Java programming language, these use the Unicode character encoding.
    • An exact numeric literal is a numeric value without a decimal point, such as 57, -957, and +62; numbers in the range of long are supported. Exact numeric literals use the integer literal syntax of the Java programming language.
    • An approximate numeric literal is a numeric value in scientific notation, such as 7E3 and -57.9E2, or a numeric value with a decimal, such as 7., -95.7, and +6.2; numbers in the range of double are supported. Approximate literals use the floating-point literal syntax of the Java programming language.
    • The boolean literals TRUE and FALSE.
  • Identifiers:
    • An identifier is an unlimited-length sequence of letters and digits, the first of which must be a letter. A letter is any character for which the method Character.isJavaLetter returns true. This includes '_' and '$'. A letter or digit is any character for which the method Character.isJavaLetterOrDigit returns true.
    • Identifiers cannot be the names NULL, TRUE, and FALSE.
    • Identifiers cannot be NOT, AND, OR, BETWEEN, LIKE, IN, IS, or ESCAPE.
    • Identifiers are either header field references or property references. The type of a property value in a message selector corresponds to the type used to set the property. If a property that does not exist in a message is referenced, its value is NULL.
    • The conversions that apply to the get methods for properties do not apply when a property is used in a message selector expression. For example, suppose you set a property as a string value, as in the following:
      myMessage.setStringProperty("NumberOfOrders", "2");
      The following expression in a message selector would evaluate to false, because a string cannot be used in an arithmetic expression:
      "NumberOfOrders > 1"
    • Identifiers are case-sensitive.
    • Message header field references are restricted to JMSDeliveryMode, JMSPriority, JMSMessageID, JMSTimestamp, JMSCorrelationID, and JMSType. JMSMessageID, JMSCorrelationID, and JMSType values may be null and if so are treated as a NULL value.
    • Any name beginning with 'JMSX' is a JMS defined property name.
    • Any name beginning with 'JMS_' is a provider-specific property name.
    • Any name that does not begin with 'JMS' is an application-specific property name.
  • White space is the same as that defined for the Java programming language: space, horizontal tab, form feed, and line terminator.
  • Expressions:
    • A selector is a conditional expression; a selector that evaluates to true matches; a selector that evaluates to false or unknown does not match.
    • Arithmetic expressions are composed of themselves, arithmetic operations, identifiers (whose value is treated as a numeric literal), and numeric literals.
    • Conditional expressions are composed of themselves, comparison operations, and logical operations.
  • Standard bracketing () for ordering expression evaluation is supported.
  • Logical operators in precedence order: NOT, AND, OR
  • Comparison operators: =, >, >=, <</CODE>, <=< /CODE="/CODE">, (not equal)
    • Only like type values can be compared. One exception is that it is valid to compare exact numeric values and approximate numeric values; the type conversion required is defined by the rules of numeric promotion in the Java programming language. If the comparison of non-like type values is attempted, the value of the operation is false. If either of the type values evaluates to NULL, the value of the expression is unknown.
    • String and boolean comparison is restricted to = and . Two strings are equal if and only if they contain the same sequence of characters.
  • Arithmetic operators in precedence order:
    • +, - (unary)
    • *, / (multiplication and division)
    • +, - (addition and subtraction)
    • Arithmetic operations must use numeric promotion in the Java programming language.
  • arithmetic-expr1 [NOT] BETWEEN arithmetic-expr2 AND arithmetic-expr3 (comparison operator)
    • "age BETWEEN 15 AND 19" is equivalent to "age >= 15 AND age <= 19"< /CODE="/CODE">
    • "age NOT BETWEEN 15 AND 19" is equivalent to "age < 15 OR age > 19"
  • identifier [NOT] IN (string-literal1, string-literal2,...) (comparison operator where identifier has a String or NULL value)
    • "Country IN (' UK', 'US', 'France')" is true for 'UK' and false for 'Peru'; it is equivalent to the expression "(Country = ' UK') OR (Country = ' US') OR (Country = ' France')"
    • "Country NOT IN (' UK', 'US', 'France')" is false for 'UK' and true for 'Peru'; it is equivalent to the expression "NOT ((Country = ' UK') OR (Country = ' US') OR (Country = ' France'))"
    • If identifier of an IN or NOT IN operation is NULL, the value of the operation is unknown.
  • identifier [NOT] LIKE pattern-value [ESCAPE escape-character] (comparison operator, where identifier has a String value; pattern-value is a string literal where '_' stands for any single character; '%' stands for any sequence of characters, including the empty sequence; and all other characters stand for themselves. The optional escape-character is a single-character string literal whose character is used to escape the special meaning of the '_' and '%' in pattern-value.)
    • "phone LIKE '12%3'" is true for '123' or '12993' and false for '1234'
    • "word LIKE 'l_se'" is true for 'lose' and false for 'loose'
    • "underscored LIKE '\_%' ESCAPE '\'" is true for '_foo' and false for 'bar'
    • "phone NOT LIKE '12%3'" is false for '123' or '12993' and true for '1234'
    • If identifier of a LIKE or NOT LIKE operation is NULL, the value of the operation is unknown.
  • identifier IS NULL (comparison operator that tests for a null header field value or a missing property value)
    • "prop_name IS NULL"
  • identifier IS NOT NULL (comparison operator that tests for the existence of a non-null header field value or a property value)
    • "prop_name IS NOT NULL"

    JMS providers are required to verify the syntactic correctness of a message selector at the time it is presented. A method that provides a syntactically incorrect selector must result in a JMSException. JMS providers may also optionally provide some semantic checking at the time the selector is presented. Not all semantic checking can be performed at the time a message selector is presented, because property types are not known.

    The following message selector selects messages with a message type of car and color of blue and weight greater than 2500 pounds:

    "JMSType = 'car' AND color = 'blue' AND weight > 2500"

    Null Values

    As noted above, property values may be NULL. The evaluation of selector expressions containing NULL values is defined by SQL92 NULL semantics. A brief description of these semantics is provided here.

    SQL treats a NULL value as unknown. Comparison or arithmetic with an unknown value always yields an unknown value.

    The IS NULL and IS NOT NULL operators convert an unknown value into the respective TRUE and FALSE values.

    The boolean operators use three-valued logic as defined by the following tables:

    The definition of the AND operator

     | AND  |   T   |   F   |   U
 +------+-------+-------+-------
 |  T   |   T   |   F   |   U
 |  F   |   F   |   F   |   F
 |  U   |   U   |   F   |   U
 +------+-------+-------+-------

    The definition of the OR operator

     | OR   |   T   |   F   |   U
 +------+-------+-------+--------
 |  T   |   T   |   T   |   T
 |  F   |   T   |   F   |   U
 |  U   |   T   |   U   |   U
 +------+-------+-------+-------

    The definition of the NOT operator

     | NOT
 +------+------
 |  T   |   F
 |  F   |   T
 |  U   |   U
 +------+-------

    Special Notes

    When used in a message selector, the JMSDeliveryMode header field is treated as having the values 'PERSISTENT' and 'NON_PERSISTENT'.

    Date and time values should use the standard long millisecond value. When a date or time literal is included in a message selector, it should be an integer literal for a millisecond value. The standard way to produce millisecond values is to use java.util.Calendar.

    Although SQL supports fixed decimal comparison and arithmetic, JMS message selectors do not. This is the reason for restricting exact numeric literals to those without a decimal (and the addition of numerics with a decimal as an alternate representation for approximate numeric values).

    SQL comments are not supported.

    Version:
    1.1 April 2, 2002
    Author:
    Mark Hapner, Rich Burridge, Kate Stout
    See Also:
    MessageConsumer.receive(), MessageConsumer.receive(long), MessageConsumer.receiveNoWait(), MessageListener.onMessage(Message), BytesMessage, MapMessage, ObjectMessage, StreamMessage, TextMessage

    Field Summary
    static int DEFAULT_DELIVERY_MODE
              The message producer's default delivery mode is PERSISTENT.
    static int DEFAULT_PRIORITY
              The message producer's default priority is 4.
    static long DEFAULT_TIME_TO_LIVE
              The message producer's default time to live is unlimited; the message never expires.

    Method Summary
     void acknowledge()
              Acknowledges all consumed messages of the session of this consumed message.
     void clearBody()
              Clears out the message body.
     void clearProperties()
              Clears a message's properties.
     boolean getBooleanProperty(String name)
              Returns the value of the boolean property with the specified name.
     byte getByteProperty(String name)
              Returns the value of the byte property with the specified name.
     double getDoubleProperty(String name)
              Returns the value of the double property with the specified name.
     float getFloatProperty(String name)
              Returns the value of the float property with the specified name.
     int getIntProperty(String name)
              Returns the value of the int property with the specified name.
     String getJMSCorrelationID()
              Gets the correlation ID for the message.
     byte[] getJMSCorrelationIDAsBytes()
              Gets the correlation ID as an array of bytes for the message.
     int getJMSDeliveryMode()
              Gets the DeliveryMode value specified for this message.
     Destination getJMSDestination()
              Gets the Destination object for this message.
     long getJMSExpiration()
              Gets the message's expiration value.
     String getJMSMessageID()
              Gets the message ID.
     int getJMSPriority()
              Gets the message priority level.
     boolean getJMSRedelivered()
              Gets an indication of whether this message is being redelivered.
     Destination getJMSReplyTo()
              Gets the Destination object to which a reply to this message should be sent.
     long getJMSTimestamp()
              Gets the message timestamp.
     String getJMSType()
              Gets the message type identifier supplied by the client when the message was sent.
     long getLongProperty(String name)
              Returns the value of the long property with the specified name.
     Object getObjectProperty(String name)
              Returns the value of the Java object property with the specified name.
     Enumeration getPropertyNames()
              Returns an Enumeration of all the property names.
     short getShortProperty(String name)
              Returns the value of the short property with the specified name.
     String getStringProperty(String name)
              Returns the value of the String property with the specified name.
     boolean propertyExists(String name)
              Indicates whether a property value exists.
     void setBooleanProperty(String name, boolean value)
              Sets a boolean property value with the specified name into the message.
     void setByteProperty(String name, byte value)
              Sets a byte property value with the specified name into the message.
     void setDoubleProperty(String name, double value)
              Sets a double property value with the specified name into the message.
     void setFloatProperty(String name, float value)
              Sets a float property value with the specified name into the message.
     void setIntProperty(String name, int value)
              Sets an int property value with the specified name into the message.
     void setJMSCorrelationID(String correlationID)
              Sets the correlation ID for the message.
     void setJMSCorrelationIDAsBytes(byte[] correlationID)
              Sets the correlation ID as an array of bytes for the message.
     void setJMSDeliveryMode(int deliveryMode)
              Sets the DeliveryMode value for this message.
     void setJMSDestination(Destination destination)
              Sets the Destination object for this message.
     void setJMSExpiration(long expiration)
              Sets the message's expiration value.
     void setJMSMessageID(String id)
              Sets the message ID.
     void setJMSPriority(int priority)
              Sets the priority level for this message.
     void setJMSRedelivered(boolean redelivered)
              Specifies whether this message is being redelivered.
     void setJMSReplyTo(Destination replyTo)
              Sets the Destination object to which a reply to this message should be sent.
     void setJMSTimestamp(long timestamp)
              Sets the message timestamp.
     void setJMSType(String type)
              Sets the message type.
     void setLongProperty(String name, long value)
              Sets a long property value with the specified name into the message.
     void setObjectProperty(String name, Object value)
              Sets a Java object property value with the specified name into the message.
     void setShortProperty(String name, short value)
              Sets a short property value with the specified name into the message.
     void setStringProperty(String name, String value)
              Sets a String property value with the specified name into the message.

    Field Detail

    DEFAULT_DELIVERY_MODE

    static final int DEFAULT_DELIVERY_MODE
    The message producer's default delivery mode is PERSISTENT.

    See Also:
    DeliveryMode.PERSISTENT, Constant Field Values

    DEFAULT_PRIORITY

    static final int DEFAULT_PRIORITY
    The message producer's default priority is 4.

    See Also:
    Constant Field Values

    DEFAULT_TIME_TO_LIVE

    static final long DEFAULT_TIME_TO_LIVE
    The message producer's default time to live is unlimited; the message never expires.

    See Also:
    Constant Field Values
    Method Detail

    getJMSMessageID

    String getJMSMessageID()
                       throws JMSException
    Gets the message ID.

    The JMSMessageID header field contains a value that uniquely identifies each message sent by a provider.

    When a message is sent, JMSMessageID can be ignored. When the send or publish method returns, it contains a provider-assigned value.

    A JMSMessageID is a String value that should function as a unique key for identifying messages in a historical repository. The exact scope of uniqueness is provider-defined. It should at least cover all messages for a specific installation of a provider, where an installation is some connected set of message routers.

    All JMSMessageID values must start with the prefix 'ID:'. Uniqueness of message ID values across different providers is not required.

    Since message IDs take some effort to create and increase a message's size, some JMS providers may be able to optimize message overhead if they are given a hint that the message ID is not used by an application. By calling the MessageProducer.setDisableMessageID method, a JMS client enables this potential optimization for all messages sent by that message producer. If the JMS provider accepts this hint, these messages must have the message ID set to null; if the provider ignores the hint, the message ID must be set to its normal unique value.

    Returns:
    the message ID
    Throws:
    JMSException - if the JMS provider fails to get the message ID due to some internal error.
    See Also:
    setJMSMessageID(String), MessageProducer.setDisableMessageID(boolean)

    setJMSMessageID

    void setJMSMessageID(String id)
                     throws JMSException
    Sets the message ID.

    JMS providers set this field when a message is sent. This method can be used to change the value for a message that has been received.

    Parameters:
    id - the ID of the message
    Throws:
    JMSException - if the JMS provider fails to set the message ID due to some internal error.
    See Also:
    getJMSMessageID()

    getJMSTimestamp

    long getJMSTimestamp()
                     throws JMSException
    Gets the message timestamp.

    The JMSTimestamp header field contains the time a message was handed off to a provider to be sent. It is not the time the message was actually transmitted, because the actual send may occur later due to transactions or other client-side queueing of messages.

    When a message is sent, JMSTimestamp is ignored. When the send or publish method returns, it contains a time value somewhere in the interval between the call and the return. The value is in the format of a normal millis time value in the Java programming language.

    Since timestamps take some effort to create and increase a message's size, some JMS providers may be able to optimize message overhead if they are given a hint that the timestamp is not used by an application. By calling the MessageProducer.setDisableMessageTimestamp method, a JMS client enables this potential optimization for all messages sent by that message producer. If the JMS provider accepts this hint, these messages must have the timestamp set to zero; if the provider ignores the hint, the timestamp must be set to its normal value.

    Returns:
    the message timestamp
    Throws:
    JMSException - if the JMS provider fails to get the timestamp due to some internal error.
    See Also:
    setJMSTimestamp(long), MessageProducer.setDisableMessageTimestamp(boolean)

    setJMSTimestamp

    void setJMSTimestamp(long timestamp)
                     throws JMSException
    Sets the message timestamp.

    JMS providers set this field when a message is sent. This method can be used to change the value for a message that has been received.

    Parameters:
    timestamp - the timestamp for this message
    Throws:
    JMSException - if the JMS provider fails to set the timestamp due to some internal error.
    See Also:
    getJMSTimestamp()

    getJMSCorrelationIDAsBytes

    byte[] getJMSCorrelationIDAsBytes()
                                  throws JMSException
    Gets the correlation ID as an array of bytes for the message.

    The use of a byte[] value for JMSCorrelationID is non-portable.

    Returns:
    the correlation ID of a message as an array of bytes
    Throws:
    JMSException - if the JMS provider fails to get the correlation ID due to some internal error.
    See Also:
    setJMSCorrelationID(String), getJMSCorrelationID(), setJMSCorrelationIDAsBytes(byte[])

    setJMSCorrelationIDAsBytes

    void setJMSCorrelationIDAsBytes(byte[] correlationID)
                                throws JMSException
    Sets the correlation ID as an array of bytes for the message.

    The array is copied before the method returns, so future modifications to the array will not alter this message header.

    If a provider supports the native concept of correlation ID, a JMS client may need to assign specific JMSCorrelationID values to match those expected by native messaging clients. JMS providers without native correlation ID values are not required to support this method and its corresponding get method; their implementation may throw a java.lang.UnsupportedOperationException.

    The use of a byte[] value for JMSCorrelationID is non-portable.

    Parameters:
    correlationID - the correlation ID value as an array of bytes
    Throws:
    JMSException - if the JMS provider fails to set the correlation ID due to some internal error.
    See Also:
    setJMSCorrelationID(String), getJMSCorrelationID(), getJMSCorrelationIDAsBytes()

    setJMSCorrelationID

    void setJMSCorrelationID(String correlationID)
                         throws JMSException
    Sets the correlation ID for the message.

    A client can use the JMSCorrelationID header field to link one message with another. A typical use is to link a response message with its request message.

    JMSCorrelationID can hold one of the following:

    • A provider-specific message ID
    • An application-specific String
    • A provider-native byte[] value

    Since each message sent by a JMS provider is assigned a message ID value, it is convenient to link messages via message ID. All message ID values must start with the 'ID:' prefix.

    In some cases, an application (made up of several clients) needs to use an application-specific value for linking messages. For instance, an application may use JMSCorrelationID to hold a value referencing some external information. Application-specified values must not start with the 'ID:' prefix; this is reserved for provider-generated message ID values.

    If a provider supports the native concept of correlation ID, a JMS client may need to assign specific JMSCorrelationID values to match those expected by clients that do not use the JMS API. A byte[] value is used for this purpose. JMS providers without native correlation ID values are not required to support byte[] values. The use of a byte[] value for JMSCorrelationID is non-portable.

    Parameters:
    correlationID - the message ID of a message being referred to
    Throws:
    JMSException - if the JMS provider fails to set the correlation ID due to some internal error.
    See Also:
    getJMSCorrelationID(),
getJMSCorrelationIDAsBytes(),
setJMSCorrelationIDAsBytes(byte[])

    getJMSCorrelationID

    String getJMSCorrelationID()
                           throws JMSException
    Gets the correlation ID for the message.

    This method is used to return correlation ID values that are either provider-specific message IDs or application-specific String values.

    Returns:
    the correlation ID of a message as a String
    Throws:
    JMSException - if the JMS provider fails to get the correlation ID due to some internal error.
    See Also:
    setJMSCorrelationID(String), getJMSCorrelationIDAsBytes(), setJMSCorrelationIDAsBytes(byte[])

    getJMSReplyTo

    Destination getJMSReplyTo()
                          throws JMSException
    Gets the Destination object to which a reply to this message should be sent.

    Returns:
    Destination to which to send a response to this message
    Throws:
    JMSException - if the JMS provider fails to get the JMSReplyTo destination due to some internal error.
    See Also:
    setJMSReplyTo(Destination)

    setJMSReplyTo

    void setJMSReplyTo(Destination replyTo)
                   throws JMSException
    Sets the Destination object to which a reply to this message should be sent.

    The JMSReplyTo header field contains the destination where a reply to the current message should be sent. If it is null, no reply is expected. The destination may be either a Queue object or a Topic object.

    Messages sent with a null JMSReplyTo value may be a notification of some event, or they may just be some data the sender thinks is of interest.

    Messages with a JMSReplyTo value typically expect a response. A response is optional; it is up to the client to decide. These messages are called requests. A message sent in response to a request is called a reply.

    In some cases a client may wish to match a request it sent earlier with a reply it has just received. The client can use the JMSCorrelationID header field for this purpose.

    Parameters:
    replyTo - Destination to which to send a response to this message
    Throws:
    JMSException - if the JMS provider fails to set the JMSReplyTo destination due to some internal error.
    See Also:
    getJMSReplyTo()

    getJMSDestination

    Destination getJMSDestination()
                              throws JMSException
    Gets the Destination object for this message.

    The JMSDestination header field contains the destination to which the message is being sent.

    When a message is sent, this field is ignored. After completion of the send or publish method, the field holds the destination specified by the method.

    When a message is received, its JMSDestination value must be equivalent to the value assigned when it was sent.

    Returns:
    the destination of this message
    Throws:
    JMSException - if the JMS provider fails to get the destination due to some internal error.
    See Also:
    setJMSDestination(Destination)

    setJMSDestination

    void setJMSDestination(Destination destination)
                       throws JMSException
    Sets the Destination object for this message.

    JMS providers set this field when a message is sent. This method can be used to change the value for a message that has been received.

    Parameters:
    destination - the destination for this message
    Throws:
    JMSException - if the JMS provider fails to set the destination due to some internal error.
    See Also:
    getJMSDestination()

    getJMSDeliveryMode

    int getJMSDeliveryMode()
                       throws JMSException
    Gets the DeliveryMode value specified for this message.

    Returns:
    the delivery mode for this message
    Throws:
    JMSException - if the JMS provider fails to get the delivery mode due to some internal error.
    See Also:
    setJMSDeliveryMode(int), DeliveryMode

    setJMSDeliveryMode

    void setJMSDeliveryMode(int deliveryMode)
                        throws JMSException
    Sets the DeliveryMode value for this message.

    JMS providers set this field when a message is sent. This method can be used to change the value for a message that has been received.

    Parameters:
    deliveryMode - the delivery mode for this message
    Throws:
    JMSException - if the JMS provider fails to set the delivery mode due to some internal error.
    See Also:
    getJMSDeliveryMode(), DeliveryMode

    getJMSRedelivered

    boolean getJMSRedelivered()
                          throws JMSException
    Gets an indication of whether this message is being redelivered.

    If a client receives a message with the JMSRedelivered field set, it is likely, but not guaranteed, that this message was delivered earlier but that its receipt was not acknowledged at that time.

    Returns:
    true if this message is being redelivered
    Throws:
    JMSException - if the JMS provider fails to get the redelivered state due to some internal error.
    See Also:
    setJMSRedelivered(boolean)

    setJMSRedelivered

    void setJMSRedelivered(boolean redelivered)
                       throws JMSException
    Specifies whether this message is being redelivered.

    This field is set at the time the message is delivered. This method can be used to change the value for a message that has been received.

    Parameters:
    redelivered - an indication of whether this message is being redelivered
    Throws:
    JMSException - if the JMS provider fails to set the redelivered state due to some internal error.
    See Also:
    getJMSRedelivered()

    getJMSType

    String getJMSType()
                  throws JMSException
    Gets the message type identifier supplied by the client when the message was sent.

    Returns:
    the message type
    Throws:
    JMSException - if the JMS provider fails to get the message type due to some internal error.
    See Also:
    setJMSType(String)

    setJMSType

    void setJMSType(String type)
                throws JMSException
    Sets the message type.

    Some JMS providers use a message repository that contains the definitions of messages sent by applications. The JMSType header field may reference a message's definition in the provider's repository.

    The JMS API does not define a standard message definition repository, nor does it define a naming policy for the definitions it contains.

    Some messaging systems require that a message type definition for each application message be created and that each message specify its type. In order to work with such JMS providers, JMS clients should assign a value to JMSType, whether the application makes use of it or not. This ensures that the field is properly set for those providers that require it.

    To ensure portability, JMS clients should use symbolic values for JMSType that can be configured at installation time to the values defined in the current provider's message repository. If string literals are used, they may not be valid type names for some JMS providers.

    Parameters:
    type - the message type
    Throws:
    JMSException - if the JMS provider fails to set the message type due to some internal error.
    See Also:
    getJMSType()

    getJMSExpiration

    long getJMSExpiration()
                      throws JMSException
    Gets the message's expiration value.

    When a message is sent, the JMSExpiration header field is left unassigned. After completion of the send or publish method, it holds the expiration time of the message. This is the sum of the time-to-live value specified by the client and the GMT at the time of the send or publish.

    If the time-to-live is specified as zero, JMSExpiration is set to zero to indicate that the message does not expire.

    When a message's expiration time is reached, a provider should discard it. The JMS API does not define any form of notification of message expiration.

    Clients should not receive messages that have expired; however, the JMS API does not guarantee that this will not happen.

    Returns:
    the time the message expires, which is the sum of the time-to-live value specified by the client and the GMT at the time of the send
    Throws:
    JMSException - if the JMS provider fails to get the message expiration due to some internal error.
    See Also:
    setJMSExpiration(long)

    setJMSExpiration

    void setJMSExpiration(long expiration)
                      throws JMSException
    Sets the message's expiration value.

    JMS providers set this field when a message is sent. This method can be used to change the value for a message that has been received.

    Parameters:
    expiration - the message's expiration time
    Throws:
    JMSException - if the JMS provider fails to set the message expiration due to some internal error.
    See Also:
    getJMSExpiration()

    getJMSPriority

    int getJMSPriority()
                   throws JMSException
    Gets the message priority level.

    The JMS API defines ten levels of priority value, with 0 as the lowest priority and 9 as the highest. In addition, clients should consider priorities 0-4 as gradations of normal priority and priorities 5-9 as gradations of expedited priority.

    The JMS API does not require that a provider strictly implement priority ordering of messages; however, it should do its best to deliver expedited messages ahead of normal messages.

    Returns:
    the default message priority
    Throws:
    JMSException - if the JMS provider fails to get the message priority due to some internal error.
    See Also:
    setJMSPriority(int)

    setJMSPriority

    void setJMSPriority(int priority)
                    throws JMSException
    Sets the priority level for this message.

    JMS providers set this field when a message is sent. This method can be used to change the value for a message that has been received.

    Parameters:
    priority - the priority of this message
    Throws:
    JMSException - if the JMS provider fails to set the message priority due to some internal error.
    See Also:
    getJMSPriority()

    clearProperties

    void clearProperties()
                     throws JMSException
    Clears a message's properties.

    The message's header fields and body are not cleared.

    Throws:
    JMSException - if the JMS provider fails to clear the message properties due to some internal error.

    propertyExists

    boolean propertyExists(String name)
                       throws JMSException
    Indicates whether a property value exists.

    Parameters:
    name - the name of the property to test
    Returns:
    true if the property exists
    Throws:
    JMSException - if the JMS provider fails to determine if the property exists due to some internal error.

    getBooleanProperty

    boolean getBooleanProperty(String name)
                           throws JMSException
    Returns the value of the boolean property with the specified name.

    Parameters:
    name - the name of the boolean property
    Returns:
    the boolean property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getByteProperty

    byte getByteProperty(String name)
                     throws JMSException
    Returns the value of the byte property with the specified name.

    Parameters:
    name - the name of the byte property
    Returns:
    the byte property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getShortProperty

    short getShortProperty(String name)
                       throws JMSException
    Returns the value of the short property with the specified name.

    Parameters:
    name - the name of the short property
    Returns:
    the short property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getIntProperty

    int getIntProperty(String name)
                   throws JMSException
    Returns the value of the int property with the specified name.

    Parameters:
    name - the name of the int property
    Returns:
    the int property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getLongProperty

    long getLongProperty(String name)
                     throws JMSException
    Returns the value of the long property with the specified name.

    Parameters:
    name - the name of the long property
    Returns:
    the long property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getFloatProperty

    float getFloatProperty(String name)
                       throws JMSException
    Returns the value of the float property with the specified name.

    Parameters:
    name - the name of the float property
    Returns:
    the float property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getDoubleProperty

    double getDoubleProperty(String name)
                         throws JMSException
    Returns the value of the double property with the specified name.

    Parameters:
    name - the name of the double property
    Returns:
    the double property value for the specified name
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getStringProperty

    String getStringProperty(String name)
                         throws JMSException
    Returns the value of the String property with the specified name.

    Parameters:
    name - the name of the String property
    Returns:
    the String property value for the specified name; if there is no property by this name, a null value is returned
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.
    MessageFormatException - if this type conversion is invalid.

    getObjectProperty

    Object getObjectProperty(String name)
                         throws JMSException
    Returns the value of the Java object property with the specified name.

    This method can be used to return, in objectified format, an object that has been stored as a property in the message with the equivalent setObjectProperty method call, or its equivalent primitive settypeProperty method.

    Parameters:
    name - the name of the Java object property
    Returns:
    the Java object property value with the specified name, in objectified format (for example, if the property was set as an int, an Integer is returned); if there is no property by this name, a null value is returned
    Throws:
    JMSException - if the JMS provider fails to get the property value due to some internal error.

    getPropertyNames

    Enumeration getPropertyNames()
                             throws JMSException
    Returns an Enumeration of all the property names.

    Note that JMS standard header fields are not considered properties and are not returned in this enumeration.

    Returns:
    an enumeration of all the names of property values
    Throws:
    JMSException - if the JMS provider fails to get the property names due to some internal error.

    setBooleanProperty

    void setBooleanProperty(String name,
                        boolean value)
                        throws JMSException
    Sets a boolean property value with the specified name into the message.

    Parameters:
    name - the name of the boolean property
    value - the boolean property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setByteProperty

    void setByteProperty(String name,
                     byte value)
                     throws JMSException
    Sets a byte property value with the specified name into the message.

    Parameters:
    name - the name of the byte property
    value - the byte property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setShortProperty

    void setShortProperty(String name,
                      short value)
                      throws JMSException
    Sets a short property value with the specified name into the message.

    Parameters:
    name - the name of the short property
    value - the short property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setIntProperty

    void setIntProperty(String name,
                    int value)
                    throws JMSException
    Sets an int property value with the specified name into the message.

    Parameters:
    name - the name of the int property
    value - the int property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setLongProperty

    void setLongProperty(String name,
                     long value)
                     throws JMSException
    Sets a long property value with the specified name into the message.

    Parameters:
    name - the name of the long property
    value - the long property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setFloatProperty

    void setFloatProperty(String name,
                      float value)
                      throws JMSException
    Sets a float property value with the specified name into the message.

    Parameters:
    name - the name of the float property
    value - the float property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setDoubleProperty

    void setDoubleProperty(String name,
                       double value)
                       throws JMSException
    Sets a double property value with the specified name into the message.

    Parameters:
    name - the name of the double property
    value - the double property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setStringProperty

    void setStringProperty(String name,
                       String value)
                       throws JMSException
    Sets a String property value with the specified name into the message.

    Parameters:
    name - the name of the String property
    value - the String property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageNotWriteableException - if properties are read-only

    setObjectProperty

    void setObjectProperty(String name,
                       Object value)
                       throws JMSException
    Sets a Java object property value with the specified name into the message.

    Note that this method works only for the objectified primitive object types (Integer, Double, Long ...) and String objects.

    Parameters:
    name - the name of the Java object property
    value - the Java object property value to set
    Throws:
    JMSException - if the JMS provider fails to set the property due to some internal error.
    IllegalArgumentException - if the name is null or if the name is an empty string.
    MessageFormatException - if the object is invalid
    MessageNotWriteableException - if properties are read-only

    acknowledge

    void acknowledge()
                 throws JMSException
    Acknowledges all consumed messages of the session of this consumed message.

    All consumed JMS messages support the acknowledge method for use when a client has specified that its JMS session's consumed messages are to be explicitly acknowledged. By invoking acknowledge on a consumed message, a client acknowledges all messages consumed by the session that the message was delivered to.

    Calls to acknowledge are ignored for both transacted sessions and sessions specified to use implicit acknowledgement modes.

    A client may individually acknowledge each message as it is consumed, or it may choose to acknowledge messages as an application-defined group (which is done by calling acknowledge on the last received message of the group, thereby acknowledging all messages consumed by the session.)

    Messages that have been received but not acknowledged may be redelivered.

    Throws:
    JMSException - if the JMS provider fails to acknowledge the messages due to some internal error.
    IllegalStateException - if this method is called on a closed session.
    See Also:
    Session.CLIENT_ACKNOWLEDGE

    clearBody

    void clearBody()
               throws JMSException
    Clears out the message body. Clearing a message's body does not clear its header values or property entries.

    If this message body was read-only, calling this method leaves the message body in the same state as an empty body in a newly created message.

    Throws:
    JMSException - if the JMS provider fails to clear the message body due to some internal error.
    Overview  Package   Class  Tree  Deprecated  Index  Help
            Java EE 5 SDK
     PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
    Submit a bug or feature

    Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageConsumer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface MessageConsumer

All Known Subinterfaces:
QueueReceiver, TopicSubscriber
public interface MessageConsumer

A client uses a MessageConsumer object to receive messages from a destination. A MessageConsumer object is created by passing a Destination object to a message-consumer creation method supplied by a session.

MessageConsumer is the parent interface for all message consumers.

A message consumer can be created with a message selector. A message selector allows the client to restrict the messages delivered to the message consumer to those that match the selector.

A client may either synchronously receive a message consumer's messages or have the consumer asynchronously deliver them as they arrive.

For synchronous receipt, a client can request the next message from a message consumer using one of its receive methods. There are several variations of receive that allow a client to poll or wait for the next message.

For asynchronous delivery, a client can register a MessageListener object with a message consumer. As messages arrive at the message consumer, it delivers them by calling the MessageListener's onMessage method.

It is a client programming error for a MessageListener to throw an exception.

Version:
1.0 - 13 March 1998
Author:
Mark Hapner, Rich Burridge
See Also:
QueueReceiver, TopicSubscriber, Session

Method Summary
void | close() Closes the message consumer.
MessageListener | getMessageListener() Gets the message consumer's MessageListener.
String | getMessageSelector() Gets this message consumer's message selector expression.
Message | receive() Receives the next message produced for this message consumer.
Message | receive(long timeout) Receives the next message that arrives within the specified timeout interval.
Message | receiveNoWait() Receives the next message if one is immediately available.
void | setMessageListener(MessageListener listener) Sets the message consumer's MessageListener.

Method Detail

getMessageSelector

String getMessageSelector()
                          throws JMSException
Gets this message consumer's message selector expression.

Returns:
this message consumer's message selector, or null if no message selector exists for the message consumer (that is, if the message selector was not set or was set to null or the empty string)
Throws:
JMSException - if the JMS provider fails to get the message selector due to some internal error.

getMessageListener

MessageListener getMessageListener()
                                   throws JMSException
Gets the message consumer's MessageListener.

Returns:
the listener for the message consumer, or null if no listener is set
Throws:
JMSException - if the JMS provider fails to get the message listener due to some internal error.
See Also:
setMessageListener(javax.jms.MessageListener)

setMessageListener

void setMessageListener(MessageListener listener)
                        throws JMSException
Sets the message consumer's MessageListener.

Setting the message listener to null is the equivalent of unsetting the message listener for the message consumer.

The effect of calling MessageConsumer.setMessageListener while messages are being consumed by an existing listener or the consumer is being used to consume messages synchronously is undefined.

Parameters:
listener - the listener to which the messages are to be delivered
Throws:
JMSException - if the JMS provider fails to set the message listener due to some internal error.
See Also:
getMessageListener()

receive

Message receive()
                throws JMSException
Receives the next message produced for this message consumer.

This call blocks indefinitely until a message is produced or until this message consumer is closed.

If this receive is done within a transaction, the consumer retains the message until the transaction commits.

Returns:
the next message produced for this message consumer, or null if this message consumer is concurrently closed
Throws:
JMSException - if the JMS provider fails to receive the next message due to some internal error.

receive

Message receive(long timeout)
                throws JMSException
Receives the next message that arrives within the specified timeout interval.

This call blocks until a message arrives, the timeout expires, or this message consumer is closed. A timeout of zero never expires, and the call blocks indefinitely.

Parameters:
timeout - the timeout value (in milliseconds)
Returns:
the next message produced for this message consumer, or null if the timeout expires or this message consumer is concurrently closed
Throws:
JMSException - if the JMS provider fails to receive the next message due to some internal error.

receiveNoWait

Message receiveNoWait()
                      throws JMSException
Receives the next message if one is immediately available.

Returns:
the next message produced for this message consumer, or null if one is not available
Throws:
JMSException - if the JMS provider fails to receive the next message due to some internal error.

close

void close()
           throws JMSException
Closes the message consumer.

Since a provider may allocate some resources on behalf of a MessageConsumer outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

This call blocks until a receive or message listener in progress has completed. A blocked message consumer receive call returns null when this message consumer is closed.

Throws:
JMSException - if the JMS provider fails to close the consumer due to some internal error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageEOFException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class MessageEOFException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.jms.JMSException
                extended by  javax.jms.MessageEOFException
All Implemented Interfaces:
Serializable
public class MessageEOFException
extends JMSException

This exception must be thrown when an unexpected end of stream has been reached when a StreamMessage or BytesMessage is being read.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
MessageEOFException(String reason)
Constructs a MessageEOFException with the specified reason.
MessageEOFException(String reason, String errorCode)
Constructs a MessageEOFException with the specified reason and error code.
Method Summary
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MessageEOFException

public MessageEOFException(String reason,
                           String errorCode)
Constructs a MessageEOFException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

MessageEOFException

public MessageEOFException(String reason)
Constructs a MessageEOFException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageFormatException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class MessageFormatException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.jms.JMSException
                extended by  javax.jms.MessageFormatException
All Implemented Interfaces:
Serializable
public class MessageFormatException
extends JMSException

This exception must be thrown when a JMS client attempts to use a data type not supported by a message or attempts to read data in a message as the wrong type. It must also be thrown when equivalent type errors are made with message property values. For example, this exception must be thrown if StreamMessage.writeObject is given an unsupported class or if StreamMessage.readShort is used to read a boolean value. Note that the special case of a failure caused by an attempt to read improperly formatted String data as numeric values must throw the java.lang.NumberFormatException.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
MessageFormatException(String reason)
Constructs a MessageFormatException with the specified reason.
MessageFormatException(String reason, String errorCode)
Constructs a MessageFormatException with the specified reason and error code.
Method Summary
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MessageFormatException

public MessageFormatException(String reason,
                              String errorCode)
Constructs a MessageFormatException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

MessageFormatException

public MessageFormatException(String reason)
Constructs a MessageFormatException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface MessageListener

public interface MessageListener

A MessageListener object is used to receive asynchronously delivered messages.

Each session must insure that it passes messages serially to the listener. This means that a listener assigned to one or more consumers of the same session can assume that the onMessage method is not called with the next message until the session has completed the last call.

Version:
1.0 - 13 March 1998
Author:
Mark Hapner, Rich Burridge

Method Summary
 void onMessage(Message message)
Passes a message to the listener.

Method Detail

onMessage

void onMessage(Message message)
Passes a message to the listener.

Parameters:
message - the message passed to the listener
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageNotReadableException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class MessageNotReadableException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.jms.JMSException
                extended by  javax.jms.MessageNotReadableException
All Implemented Interfaces:
Serializable
public class MessageNotReadableException
extends JMSException

This exception must be thrown when a JMS client attempts to read a write-only message.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
MessageNotReadableException(String reason)
Constructs a MessageNotReadableException with the specified reason.
MessageNotReadableException(String reason, String errorCode)
Constructs a MessageNotReadableException with the specified reason and error code.
Method Summary
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MessageNotReadableException

public MessageNotReadableException(String reason,
                                   String errorCode)
Constructs a MessageNotReadableException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

MessageNotReadableException

public MessageNotReadableException(String reason)
Constructs a MessageNotReadableException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageNotWriteableException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class MessageNotWriteableException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.jms.JMSException
                extended by  javax.jms.MessageNotWriteableException
All Implemented Interfaces:
Serializable
public class MessageNotWriteableException
extends JMSException

This exception must be thrown when a JMS client attempts to write to a read-only message.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
MessageNotWriteableException(String reason)
Constructs a MessageNotWriteableException with the specified reason.
MessageNotWriteableException(String reason, String errorCode)
Constructs a MessageNotWriteableException with the specified reason and error code.
Method Summary
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MessageNotWriteableException

public MessageNotWriteableException(String reason,
                                    String errorCode)
Constructs a MessageNotWriteableException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

MessageNotWriteableException

public MessageNotWriteableException(String reason)
Constructs a MessageNotWriteableException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageProducer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface MessageProducer

All Known Subinterfaces:
QueueSender, TopicPublisher
public interface MessageProducer

A client uses a MessageProducer object to send messages to a destination. A MessageProducer object is created by passing a Destination object to a message-producer creation method supplied by a session.

MessageProducer is the parent interface for all message producers.

A client also has the option of creating a message producer without supplying a destination. In this case, a destination must be provided with every send operation. A typical use for this kind of message producer is to send replies to requests using the request's JMSReplyTo destination.

A client can specify a default delivery mode, priority, and time to live for messages sent by a message producer. It can also specify the delivery mode, priority, and time to live for an individual message.

A client can specify a time-to-live value in milliseconds for each message it sends. This value defines a message expiration time that is the sum of the message's time-to-live and the GMT when it is sent (for transacted sends, this is the time the client sends the message, not the time the transaction is committed).

A JMS provider should do its best to expire messages accurately; however, the JMS API does not define the accuracy provided.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
TopicPublisher, QueueSender, Session.createProducer(javax.jms.Destination)

Method Summary
void | close() Closes the message producer.
int | getDeliveryMode() Gets the producer's default delivery mode.
Destination | getDestination() Gets the destination associated with this MessageProducer.
boolean | getDisableMessageID() Gets an indication of whether message IDs are disabled.
boolean | getDisableMessageTimestamp() Gets an indication of whether message timestamps are disabled.
int | getPriority() Gets the producer's default priority.
long | getTimeToLive() Gets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.
void | send(Destination destination, Message message) Sends a message to a destination for an unidentified message producer.
void | send(Destination destination, Message message, int deliveryMode, int priority, long timeToLive) Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live.
void | send(Message message) Sends a message using the MessageProducer's default delivery mode, priority, and time to live.
void | send(Message message, int deliveryMode, int priority, long timeToLive) Sends a message to the destination, specifying delivery mode, priority, and time to live.
void | setDeliveryMode(int deliveryMode) Sets the producer's default delivery mode.
void | setDisableMessageID(boolean value) Sets whether message IDs are disabled.
void | setDisableMessageTimestamp(boolean value) Sets whether message timestamps are disabled.
void | setPriority(int defaultPriority) Sets the producer's default priority.
void | setTimeToLive(long timeToLive) Sets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.

Method Detail

setDisableMessageID

void setDisableMessageID(boolean value)
                         throws JMSException
Sets whether message IDs are disabled.

Since message IDs take some effort to create and increase a message's size, some JMS providers may be able to optimize message overhead if they are given a hint that the message ID is not used by an application. By calling the setDisableMessageID method on this message producer, a JMS client enables this potential optimization for all messages sent by this message producer. If the JMS provider accepts this hint, these messages must have the message ID set to null; if the provider ignores the hint, the message ID must be set to its normal unique value.

Message IDs are enabled by default.

Parameters:
value - indicates if message IDs are disabled
Throws:
JMSException - if the JMS provider fails to set message ID to disabled due to some internal error.

getDisableMessageID

boolean getDisableMessageID()
                            throws JMSException
Gets an indication of whether message IDs are disabled.

Returns:
an indication of whether message IDs are disabled
Throws:
JMSException - if the JMS provider fails to determine if message IDs are disabled due to some internal error.

setDisableMessageTimestamp

void setDisableMessageTimestamp(boolean value)
                                throws JMSException
Sets whether message timestamps are disabled.

Since timestamps take some effort to create and increase a message's size, some JMS providers may be able to optimize message overhead if they are given a hint that the timestamp is not used by an application. By calling the setDisableMessageTimestamp method on this message producer, a JMS client enables this potential optimization for all messages sent by this message producer. If the JMS provider accepts this hint, these messages must have the timestamp set to zero; if the provider ignores the hint, the timestamp must be set to its normal value.

Message timestamps are enabled by default.

Parameters:
value - indicates if message timestamps are disabled
Throws:
JMSException - if the JMS provider fails to set timestamps to disabled due to some internal error.

getDisableMessageTimestamp

boolean getDisableMessageTimestamp()
                                   throws JMSException
Gets an indication of whether message timestamps are disabled.

Returns:
an indication of whether message timestamps are disabled
Throws:
JMSException - if the JMS provider fails to determine if timestamps are disabled due to some internal error.

setDeliveryMode

void setDeliveryMode(int deliveryMode)
                     throws JMSException
Sets the producer's default delivery mode.

Delivery mode is set to PERSISTENT by default.

Parameters:
deliveryMode - the message delivery mode for this message producer; legal values are DeliveryMode.NON_PERSISTENT and DeliveryMode.PERSISTENT
Throws:
JMSException - if the JMS provider fails to set the delivery mode due to some internal error.
See Also:
getDeliveryMode(), DeliveryMode.NON_PERSISTENT, DeliveryMode.PERSISTENT, Message.DEFAULT_DELIVERY_MODE

getDeliveryMode

int getDeliveryMode()
                    throws JMSException
Gets the producer's default delivery mode.

Returns:
the message delivery mode for this message producer
Throws:
JMSException - if the JMS provider fails to get the delivery mode due to some internal error.
See Also:
setDeliveryMode(int)

setPriority

void setPriority(int defaultPriority)
                 throws JMSException
Sets the producer's default priority.

The JMS API defines ten levels of priority value, with 0 as the lowest priority and 9 as the highest. Clients should consider priorities 0-4 as gradations of normal priority and priorities 5-9 as gradations of expedited priority. Priority is set to 4 by default.

Parameters:
defaultPriority - the message priority for this message producer; must be a value between 0 and 9
Throws:
JMSException - if the JMS provider fails to set the priority due to some internal error.
See Also:
getPriority(), Message.DEFAULT_PRIORITY

getPriority

int getPriority()
                throws JMSException
Gets the producer's default priority.

Returns:
the message priority for this message producer
Throws:
JMSException - if the JMS provider fails to get the priority due to some internal error.
See Also:
setPriority(int)

setTimeToLive

void setTimeToLive(long timeToLive)
                   throws JMSException
Sets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.

Time to live is set to zero by default.

Parameters:
timeToLive - the message time to live in milliseconds; zero is unlimited
Throws:
JMSException - if the JMS provider fails to set the time to live due to some internal error.
See Also:
getTimeToLive(), Message.DEFAULT_TIME_TO_LIVE

getTimeToLive

long getTimeToLive()
                   throws JMSException
Gets the default length of time in milliseconds from its dispatch time that a produced message should be retained by the message system.

Returns:
the message time to live in milliseconds; zero is unlimited
Throws:
JMSException - if the JMS provider fails to get the time to live due to some internal error.
See Also:
setTimeToLive(long)

getDestination

Destination getDestination()
                           throws JMSException
Gets the destination associated with this MessageProducer.

Returns:
this producer's Destination/
Throws:
JMSException - if the JMS provider fails to get the destination for this MessageProducer due to some internal error.
Since:
1.1

close

void close()
           throws JMSException
Closes the message producer.

Since a provider may allocate some resources on behalf of a MessageProducer outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

Throws:
JMSException - if the JMS provider fails to close the producer due to some internal error.

send

void send(Message message)
          throws JMSException
Sends a message using the MessageProducer's default delivery mode, priority, and time to live.

Parameters:
message - the message to send
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with a MessageProducer with an invalid destination.
UnsupportedOperationException - if a client uses this method with a MessageProducer that did not specify a destination at creation time.
Since:
1.1
See Also:
Session.createProducer(javax.jms.Destination), MessageProducer

send

void send(Message message,
          int deliveryMode,
          int priority,
          long timeToLive)
          throws JMSException
Sends a message to the destination, specifying delivery mode, priority, and time to live.

Parameters:
message - the message to send
deliveryMode - the delivery mode to use
priority - the priority for this message
timeToLive - the message's lifetime (in milliseconds)
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with a MessageProducer with an invalid destination.
UnsupportedOperationException - if a client uses this method with a MessageProducer that did not specify a destination at creation time.
Since:
1.1
See Also:
Session.createProducer(javax.jms.Destination)

send

void send(Destination destination,
          Message message)
          throws JMSException
Sends a message to a destination for an unidentified message producer. Uses the MessageProducer's default delivery mode, priority, and time to live.

Typically, a message producer is assigned a destination at creation time; however, the JMS API also supports unidentified message producers, which require that the destination be supplied every time a message is sent.

Parameters:
destination - the destination to send this message to
message - the message to send
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with an invalid destination.
UnsupportedOperationException - if a client uses this method with a MessageProducer that specified a destination at creation time.
Since:
1.1
See Also:
Session.createProducer(javax.jms.Destination), MessageProducer

send

void send(Destination destination,
          Message message,
          int deliveryMode,
          int priority,
          long timeToLive)
          throws JMSException
Sends a message to a destination for an unidentified message producer, specifying delivery mode, priority and time to live.

Typically, a message producer is assigned a destination at creation time; however, the JMS API also supports unidentified message producers, which require that the destination be supplied every time a message is sent.

Parameters:
destination - the destination to send this message to
message - the message to send
deliveryMode - the delivery mode to use
priority - the priority for this message
timeToLive - the message's lifetime (in milliseconds)
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with an invalid destination.
Since:
1.1
See Also:
Session.createProducer(javax.jms.Destination)
Overview  Package   Class  Tree  Deprecated  Index  Help
Java EE 5 SDK
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ObjectMessage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ObjectMessage

All Superinterfaces:
Message
public interface ObjectMessage
extends Message

An ObjectMessage object is used to send a message that contains a serializable object in the Java programming language ("Java object"). It inherits from the Message interface and adds a body containing a single reference to an object. Only Serializable Java objects can be used.

If a collection of Java objects must be sent, one of the Collection classes provided since JDK 1.2 can be used.

When a client receives an ObjectMessage, it is in read-only mode. If a client attempts to write to the message at this point, a MessageNotWriteableException is thrown. If clearBody is called, the message can now be both read from and written to.

Version:
1.0 - 6 August 1998
Author:
Mark Hapner, Rich Burridge
See Also:
Session.createObjectMessage(), Session.createObjectMessage(Serializable), BytesMessage, MapMessage, Message, StreamMessage, TextMessage

Field Summary
Fields inherited from interface javax.jms.Message
DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE
Method Summary
Serializable | getObject() Gets the serializable object containing this message's data.
void | setObject(Serializable object) Sets the serializable object containing this message's data.
Methods inherited from interface javax.jms.Message
acknowledge, clearBody, clearProperties, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

Method Detail

setObject

void setObject(Serializable object)
               throws JMSException
Sets the serializable object containing this message's data. It is important to note that an ObjectMessage contains a snapshot of the object at the time setObject() is called; subsequent modifications of the object will have no effect on the ObjectMessage body.

Parameters:
object - the message's data
Throws:
JMSException - if the JMS provider fails to set the object due to some internal error.
MessageFormatException - if object serialization fails.
MessageNotWriteableException - if the message is in read-only mode.

getObject

Serializable getObject()
                       throws JMSException
Gets the serializable object containing this message's data. The default value is null.

Returns:
the serializable object containing this message's data
Throws:
JMSException - if the JMS provider fails to get the object due to some internal error.
MessageFormatException - if object deserialization fails.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Queue

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface Queue

All Superinterfaces:
Destination
All Known Subinterfaces:
TemporaryQueue
public interface Queue
extends Destination

A Queue object encapsulates a provider-specific queue name. It is the way a client specifies the identity of a queue to JMS API methods. For those methods that use a Destination as a parameter, a Queue object used as an argument. For example, a queue can be used to create a MessageConsumer and a MessageProducer by calling:

  • Session.CreateConsumer(Destination destination)
  • Session.CreateProducer(Destination destination)

The actual length of time messages are held by a queue and the consequences of resource overflow are not defined by the JMS API.

Version:
1.1 February 2 - 2000
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createConsumer(Destination),
Session.createProducer(Destination),
Session.createQueue(String),
QueueSession.createQueue(String)

Method Summary
String | getQueueName() Gets the name of this queue.
String | toString() Returns a string representation of this object.

Method Detail

getQueueName

String getQueueName()
                    throws JMSException
Gets the name of this queue.

Clients that depend upon the name are not portable.

Returns:
the queue name
Throws:
JMSException - if the JMS provider implementation of Queue fails to return the queue name due to some internal error.

toString

String toString()
Returns a string representation of this object.

Overrides:
toString in class Object
Returns:
the provider-specific identity values for this queue
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


QueueBrowser

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface QueueBrowser

public interface QueueBrowser

A client uses a QueueBrowser object to look at messages on a queue without removing them.

The getEnumeration method returns a java.util.Enumeration that is used to scan the queue's messages. It may be an enumeration of the entire content of a queue, or it may contain only the messages matching a message selector.

Messages may be arriving and expiring while the scan is done. The JMS API does not require the content of an enumeration to be a static snapshot of queue content. Whether these changes are visible or not depends on the JMS provider.

A QueueBrowser can be created from either a Session or a QueueSession.

Version:
1.1 April 9, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createBrowser(javax.jms.Queue), QueueSession.createBrowser(javax.jms.Queue), QueueReceiver

Method Summary
void | close() Closes the QueueBrowser.
Enumeration | getEnumeration() Gets an enumeration for browsing the current queue messages in the order they would be received.
String | getMessageSelector() Gets this queue browser's message selector expression.
Queue | getQueue() Gets the queue associated with this queue browser.

Method Detail

getQueue

Queue getQueue()
               throws JMSException
Gets the queue associated with this queue browser.

Returns:
the queue
Throws:
JMSException - if the JMS provider fails to get the queue associated with this browser due to some internal error.

getMessageSelector

String getMessageSelector()
                          throws JMSException
Gets this queue browser's message selector expression.

Returns:
this queue browser's message selector, or null if no message selector exists for the message consumer (that is, if the message selector was not set or was set to null or the empty string)
Throws:
JMSException - if the JMS provider fails to get the message selector for this browser due to some internal error.

getEnumeration

Enumeration getEnumeration()
                           throws JMSException
Gets an enumeration for browsing the current queue messages in the order they would be received.

Returns:
an enumeration for browsing the messages
Throws:
JMSException - if the JMS provider fails to get the enumeration for this browser due to some internal error.

close

void close()
           throws JMSException
Closes the QueueBrowser.

Since a provider may allocate some resources on behalf of a QueueBrowser outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

Throws:
JMSException - if the JMS provider fails to close this browser due to some internal error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


QueueConnection

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface QueueConnection

All Superinterfaces:
Connection
All Known Subinterfaces:
XAQueueConnection
public interface QueueConnection
extends Connection

A QueueConnection object is an active connection to a point-to-point JMS provider. A client uses a QueueConnection object to create one or more QueueSession objects for producing and consuming messages.

A QueueConnection can be used to create a QueueSession, from which specialized queue-related objects can be created. A more general, and recommended, approach is to use the Connection object.

The QueueConnection object should be used to support existing code that has already used it.

A QueueConnection cannot be used to create objects specific to the publish/subscribe domain. The createDurableConnectionConsumer method inherits from Connection, but must throw an IllegalStateException if used from QueueConnection.

Version:
1.1 - April 9, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Connection, ConnectionFactory, QueueConnectionFactory

Method Summary
ConnectionConsumer | createConnectionConsumer(Queue queue, String messageSelector, ServerSessionPool sessionPool, int maxMessages) Creates a connection consumer for this connection (optional operation).
QueueSession | createQueueSession(boolean transacted, int acknowledgeMode) Creates a QueueSession object.
Methods inherited from interface javax.jms.Connection
close, createConnectionConsumer, createDurableConnectionConsumer, createSession, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop

Method Detail

createQueueSession

QueueSession createQueueSession(boolean transacted,
                                int acknowledgeMode)
                                throws JMSException
Creates a QueueSession object.

Parameters:
transacted - indicates whether the session is transacted
acknowledgeMode - indicates whether the consumer or the client will acknowledge any messages it receives; ignored if the session is transacted. Legal values are Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, and Session.DUPS_OK_ACKNOWLEDGE.
Returns:
a newly created queue session
Throws:
JMSException - if the QueueConnection object fails to create a session due to some internal error or lack of support for the specific transaction and acknowledgement mode.
See Also:
Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE

createConnectionConsumer

ConnectionConsumer createConnectionConsumer(Queue queue,
                                            String messageSelector,
                                            ServerSessionPool sessionPool,
                                            int maxMessages)
                                            throws JMSException
Creates a connection consumer for this connection (optional operation). This is an expert facility not used by regular JMS clients.

Parameters:
queue - the queue to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
sessionPool - the server session pool to associate with this connection consumer
maxMessages - the maximum number of messages that can be assigned to a server session at one time
Returns:
the connection consumer
Throws:
JMSException - if the QueueConnection object fails to create a connection consumer due to some internal error or invalid arguments for sessionPool and messageSelector.
InvalidDestinationException - if an invalid queue is specified.
InvalidSelectorException - if the message selector is invalid.
See Also:
ConnectionConsumer
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


QueueConnectionFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface QueueConnectionFactory

All Superinterfaces:
ConnectionFactory
All Known Subinterfaces:
XAQueueConnectionFactory
public interface QueueConnectionFactory
extends ConnectionFactory

A client uses a QueueConnectionFactory object to create QueueConnection objects with a point-to-point JMS provider.

QueueConnectionFactory can be used to create a QueueConnection, from which specialized queue-related objects can be created. A more general, and recommended, approach is to use the ConnectionFactory object.

The QueueConnectionFactory object can be used to support existing code that already uses it.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
ConnectionFactory

Method Summary
QueueConnection | createQueueConnection() Creates a queue connection with the default user identity.
QueueConnection | createQueueConnection(String userName, String password) Creates a queue connection with the specified user identity.
Methods inherited from interface javax.jms.ConnectionFactory
createConnection, createConnection

Method Detail

createQueueConnection

QueueConnection createQueueConnection()
                                      throws JMSException
Creates a queue connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called. .

Returns:
a newly created queue connection
Throws:
JMSException - if the JMS provider fails to create the queue connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.

createQueueConnection

QueueConnection createQueueConnection(String userName,
                                      String password)
                                      throws JMSException
Creates a queue connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Parameters:
userName - the caller's user name
password - the caller's password
Returns:
a newly created queue connection
Throws:
JMSException - if the JMS provider fails to create the queue connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


QueueReceiver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface QueueReceiver

All Superinterfaces:
MessageConsumer
public interface QueueReceiver
extends MessageConsumer

A client uses a QueueReceiver object to receive messages that have been delivered to a queue.

Although it is possible to have multiple QueueReceivers for the same queue, the JMS API does not define how messages are distributed between the QueueReceivers.

If a QueueReceiver specifies a message selector, the messages that are not selected remain on the queue. By definition, a message selector allows a QueueReceiver to skip messages. This means that when the skipped messages are eventually read, the total ordering of the reads does not retain the partial order defined by each message producer. Only QueueReceivers without a message selector will read messages in message producer order.

Creating a MessageConsumer provides the same features as creating a QueueReceiver. A MessageConsumer object is recommended for creating new code. The QueueReceiver is provided to support existing code.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createConsumer(Destination, String),
Session.createConsumer(Destination),
QueueSession.createReceiver(Queue, String),
QueueSession.createReceiver(Queue),
MessageConsumer

Method Summary
 Queue getQueue()
Gets the Queue associated with this queue receiver.
Methods inherited from interface javax.jms.MessageConsumer
close, getMessageListener, getMessageSelector, receive, receive, receiveNoWait, setMessageListener

Method Detail

getQueue

Queue getQueue()
               throws JMSException
Gets the Queue associated with this queue receiver.

Returns:
this receiver's Queue
Throws:
JMSException - if the JMS provider fails to get the queue for this queue receiver due to some internal error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


QueueRequestor

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class QueueRequestor

java.lang.Object
    extended by  javax.jms.QueueRequestor

public class QueueRequestor
extends Object

The QueueRequestor helper class simplifies making service requests.

The QueueRequestor constructor is given a non-transacted QueueSession and a destination Queue. It creates a TemporaryQueue for the responses and provides a request method that sends the request message and waits for its reply.

This is a basic request/reply abstraction that should be sufficient for most uses. JMS providers and clients are free to create more sophisticated versions.

Version:
1.0 - 8 July 1998
Author:
Mark Hapner, Rich Burridge
See Also:
TopicRequestor

Constructor Summary
QueueRequestor(QueueSession session, Queue queue)
Constructor for the QueueRequestor class.
Method Summary
void | close() Closes the QueueRequestor and its session.
Message | request(Message message) Sends a request and waits for a reply.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueueRequestor

public QueueRequestor(QueueSession session,
                      Queue queue)
               throws JMSException
Constructor for the QueueRequestor class.

This implementation assumes the session parameter to be non-transacted, with a delivery mode of either AUTO_ACKNOWLEDGE or DUPS_OK_ACKNOWLEDGE.

Parameters:
session - the QueueSession the queue belongs to
queue - the queue to perform the request/reply call on
Throws:
JMSException - if the JMS provider fails to create the QueueRequestor due to some internal error.
InvalidDestinationException - if an invalid queue is specified.
Method Detail

request

public Message request(Message message)
                throws JMSException
Sends a request and waits for a reply. The temporary queue is used for the JMSReplyTo destination, and only one reply per request is expected.

Parameters:
message - the message to send
Returns:
the reply message
Throws:
JMSException - if the JMS provider fails to complete the request due to some internal error.

close

public void close()
           throws JMSException
Closes the QueueRequestor and its session.

Since a provider may allocate some resources on behalf of a QueueRequestor outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

Note that this method closes the QueueSession object passed to the QueueRequestor constructor.

Throws:
JMSException - if the JMS provider fails to close the QueueRequestor due to some internal error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


QueueSender

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface QueueSender

All Superinterfaces:
MessageProducer
public interface QueueSender
extends MessageProducer

A client uses a QueueSender object to send messages to a queue.

Normally, the Queue is specified when a QueueSender is created. In this case, an attempt to use the send methods for an unidentified QueueSender will throw a java.lang.UnsupportedOperationException.

If the QueueSender is created with an unidentified Queue, an attempt to use the send methods that assume that the Queue has been identified will throw a java.lang.UnsupportedOperationException.

During the execution of its send method, a message must not be changed by other threads within the client. If the message is modified, the result of the send is undefined.

After sending a message, a client may retain and modify it without affecting the message that has been sent. The same message object may be sent multiple times.

The following message headers are set as part of sending a message: JMSDestination, JMSDeliveryMode, JMSExpiration, JMSPriority, JMSMessageID and JMSTimeStamp. When the message is sent, the values of these headers are ignored. After the completion of the send, the headers hold the values specified by the method sending the message. It is possible for the send method not to set JMSMessageID and JMSTimeStamp if the setting of these headers is explicitly disabled by the MessageProducer.setDisableMessageID or MessageProducer.setDisableMessageTimestamp method.

Creating a MessageProducer provides the same features as creating a QueueSender. A MessageProducer object is recommended when creating new code. The QueueSender is provided to support existing code.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
MessageProducer, Session.createProducer(Destination), QueueSession.createSender(Queue)

Method Summary
Queue | getQueue() Gets the queue associated with this QueueSender.
void | send(Message message) Sends a message to the queue.
void | send(Message message, int deliveryMode, int priority, long timeToLive) Sends a message to the queue, specifying delivery mode, priority, and time to live.
void | send(Queue queue, Message message) Sends a message to a queue for an unidentified message producer.
void | send(Queue queue, Message message, int deliveryMode, int priority, long timeToLive) Sends a message to a queue for an unidentified message producer, specifying delivery mode, priority and time to live.
Methods inherited from interface javax.jms.MessageProducer
close, getDeliveryMode, getDestination, getDisableMessageID, getDisableMessageTimestamp, getPriority, getTimeToLive, send, send, setDeliveryMode, setDisableMessageID, setDisableMessageTimestamp, setPriority, setTimeToLive

Method Detail

getQueue

Queue getQueue()
               throws JMSException
Gets the queue associated with this QueueSender.

Returns:
this sender's queue
Throws:
JMSException - if the JMS provider fails to get the queue for this QueueSender due to some internal error.

send

void send(Message message)
          throws JMSException
Sends a message to the queue. Uses the QueueSender's default delivery mode, priority, and time to live.

Specified by:
send in interface MessageProducer
Parameters:
message - the message to send
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with a QueueSender with an invalid queue.
UnsupportedOperationException - if a client uses this method with a QueueSender that did not specify a queue at creation time.
See Also:
MessageProducer.getDeliveryMode(),
MessageProducer.getTimeToLive(),
MessageProducer.getPriority()

send

void send(Message message,
          int deliveryMode,
          int priority,
          long timeToLive)
          throws JMSException
Sends a message to the queue, specifying delivery mode, priority, and time to live.

Specified by:
send in interface MessageProducer
Parameters:
message - the message to send
deliveryMode - the delivery mode to use
priority - the priority for this message
timeToLive - the message's lifetime (in milliseconds)
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with a QueueSender with an invalid queue.
UnsupportedOperationException - if a client uses this method with a QueueSender that did not specify a queue at creation time.
See Also:
Session.createProducer(javax.jms.Destination)

send

void send(Queue queue,
          Message message)
          throws JMSException
Sends a message to a queue for an unidentified message producer. Uses the QueueSender's default delivery mode, priority, and time to live.

Typically, a message producer is assigned a queue at creation time; however, the JMS API also supports unidentified message producers, which require that the queue be supplied every time a message is sent.

Parameters:
queue - the queue to send this message to
message - the message to send
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with an invalid queue.
See Also:
MessageProducer.getDeliveryMode(),
MessageProducer.getTimeToLive(),
MessageProducer.getPriority()

send

void send(Queue queue,
          Message message,
          int deliveryMode,
          int priority,
          long timeToLive)
          throws JMSException
Sends a message to a queue for an unidentified message producer, specifying delivery mode, priority and time to live.

Typically, a message producer is assigned a queue at creation time; however, the JMS API also supports unidentified message producers, which require that the queue be supplied every time a message is sent.

Parameters:
queue - the queue to send this message to
message - the message to send
deliveryMode - the delivery mode to use
priority - the priority for this message
timeToLive - the message's lifetime (in milliseconds)
Throws:
JMSException - if the JMS provider fails to send the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with an invalid queue.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


QueueSession

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface QueueSession

All Superinterfaces:
Runnable, Session
public interface QueueSession
extends Session

A QueueSession object provides methods for creating QueueReceiver, QueueSender, QueueBrowser, and TemporaryQueue objects.

If there are messages that have been received but not acknowledged when a QueueSession terminates, these messages will be retained and redelivered when a consumer next accesses the queue.

A QueueSession is used for creating Point-to-Point specific objects. In general, use the Session object. The QueueSession is used to support existing code. Using the Session object simplifies the programming model, and allows transactions to be used across the two messaging domains.

A QueueSession cannot be used to create objects specific to the publish/subscribe domain. The following methods inherit from Session, but must throw an IllegalStateException if they are used from QueueSession:

  • createDurableSubscriber
  • createTemporaryTopic
  • createTopic
  • unsubscribe

Version:
1.1 - April 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session, QueueConnection.createQueueSession(boolean, int), XAQueueSession.getQueueSession()

Field Summary
Fields inherited from interface javax.jms.Session
AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED
Method Summary
QueueBrowser | createBrowser(Queue queue) Creates a QueueBrowser object to peek at the messages on the specified queue.
QueueBrowser | createBrowser(Queue queue, String messageSelector) Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
Queue | createQueue(String queueName) Creates a queue identity given a Queue name.
QueueReceiver | createReceiver(Queue queue) Creates a QueueReceiver object to receive messages from the specified queue.
QueueReceiver | createReceiver(Queue queue, String messageSelector) Creates a QueueReceiver object to receive messages from the specified queue using a message selector.
QueueSender | createSender(Queue queue) Creates a QueueSender object to send messages to the specified queue.
TemporaryQueue | createTemporaryQueue() Creates a TemporaryQueue object.
Methods inherited from interface javax.jms.Session
close, commit, createBytesMessage, createConsumer, createConsumer, createConsumer, createDurableSubscriber, createDurableSubscriber, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createStreamMessage, createTemporaryTopic, createTextMessage, createTextMessage, createTopic, getAcknowledgeMode, getMessageListener, getTransacted, recover, rollback, run, setMessageListener, unsubscribe

Method Detail

createQueue

Queue createQueue(String queueName)
                  throws JMSException
Creates a queue identity given a Queue name.

This facility is provided for the rare cases where clients need to dynamically manipulate queue identity. It allows the creation of a queue identity with a provider-specific name. Clients that depend on this ability are not portable.

Note that this method is not for creating the physical queue. The physical creation of queues is an administrative task and is not to be initiated by the JMS API. The one exception is the creation of temporary queues, which is accomplished with the createTemporaryQueue method.

Specified by:
createQueue in interface Session
Parameters:
queueName - the name of this Queue
Returns:
a Queue with the given name
Throws:
JMSException - if the session fails to create a queue due to some internal error.

createReceiver

QueueReceiver createReceiver(Queue queue)
                             throws JMSException
Creates a QueueReceiver object to receive messages from the specified queue.

Parameters:
queue - the Queue to access
Throws:
JMSException - if the session fails to create a receiver due to some internal error.
InvalidDestinationException - if an invalid queue is specified.

createReceiver

QueueReceiver createReceiver(Queue queue,
                             String messageSelector)
                             throws JMSException
Creates a QueueReceiver object to receive messages from the specified queue using a message selector.

Parameters:
queue - the Queue to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
Throws:
JMSException - if the session fails to create a receiver due to some internal error.
InvalidDestinationException - if an invalid queue is specified.
InvalidSelectorException - if the message selector is invalid.

createSender

QueueSender createSender(Queue queue)
                         throws JMSException
Creates a QueueSender object to send messages to the specified queue.

Parameters:
queue - the Queue to access, or null if this is an unidentified producer
Throws:
JMSException - if the session fails to create a sender due to some internal error.
InvalidDestinationException - if an invalid queue is specified.

createBrowser

QueueBrowser createBrowser(Queue queue)
                           throws JMSException
Creates a QueueBrowser object to peek at the messages on the specified queue.

Specified by:
createBrowser in interface Session
Parameters:
queue - the Queue to access
Throws:
JMSException - if the session fails to create a browser due to some internal error.
InvalidDestinationException - if an invalid queue is specified.

createBrowser

QueueBrowser createBrowser(Queue queue,
                           String messageSelector)
                           throws JMSException
Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.

Specified by:
createBrowser in interface Session
Parameters:
queue - the Queue to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
Throws:
JMSException - if the session fails to create a browser due to some internal error.
InvalidDestinationException - if an invalid queue is specified.
InvalidSelectorException - if the message selector is invalid.

createTemporaryQueue

TemporaryQueue createTemporaryQueue()
                                    throws JMSException
Creates a TemporaryQueue object. Its lifetime will be that of the QueueConnection unless it is deleted earlier.

Specified by:
createTemporaryQueue in interface Session
Returns:
a temporary queue identity
Throws:
JMSException - if the session fails to create a temporary queue due to some internal error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResourceAllocationException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class ResourceAllocationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.jms.JMSException
                extended by  javax.jms.ResourceAllocationException
All Implemented Interfaces:
Serializable
public class ResourceAllocationException
extends JMSException

This exception is thrown when a provider is unable to allocate the resources required by a method. For example, this exception should be thrown when a call to TopicConnectionFactory.createTopicConnection fails due to a lack of JMS provider resources.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
ResourceAllocationException(String reason)
Constructs a ResourceAllocationException with the specified reason.
ResourceAllocationException(String reason, String errorCode)
Constructs a ResourceAllocationException with the specified reason and error code.
Method Summary
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResourceAllocationException

public ResourceAllocationException(String reason,
                                   String errorCode)
Constructs a ResourceAllocationException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

ResourceAllocationException

public ResourceAllocationException(String reason)
Constructs a ResourceAllocationException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServerSession

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ServerSession

public interface ServerSession

A ServerSession object is an application server object that is used by a server to associate a thread with a JMS session (optional).

A ServerSession implements two methods:

  • getSession - returns the ServerSession's JMS session.
  • start - starts the execution of the ServerSession thread and results in the execution of the JMS session's run method.

A ConnectionConsumer implemented by a JMS provider uses a ServerSession to process one or more messages that have arrived. It does this by getting a ServerSession from the ConnectionConsumer's ServerSessionPool; getting the ServerSession's JMS session; loading it with the messages; and then starting the ServerSession.

In most cases the ServerSession will register some object it provides as the ServerSession's thread run object. The ServerSession's start method will call the thread's start method, which will start the new thread, and from it, call the run method of the ServerSession's run object. This object will do some housekeeping and then call the Session's run method. When run returns, the ServerSession's run object can return the ServerSession to the ServerSessionPool, and the cycle starts again.

Note that the JMS API does not architect how the ConnectionConsumer loads the Session with messages. Since both the ConnectionConsumer and Session are implemented by the same JMS provider, they can accomplish the load using a private mechanism.

Version:
1.0 - 9 March 1998
Author:
Mark Hapner, Rich Burridge
See Also:
ServerSessionPool, ConnectionConsumer

Method Summary
Session | getSession() Return the ServerSession's Session.
void | start() Cause the Session's run method to be called to process messages that were just assigned to it.

Method Detail

getSession

Session getSession()
                   throws JMSException
Return the ServerSession's Session. This must be a Session created by the same Connection that will be dispatching messages to it. The provider will assign one or more messages to the Session and then call start on the ServerSession.

Returns:
the server session's session
Throws:
JMSException - if the JMS provider fails to get the associated session for this ServerSession due to some internal error.

start

void start()
           throws JMSException
Cause the Session's run method to be called to process messages that were just assigned to it.

Throws:
JMSException - if the JMS provider fails to start the server session to process messages due to some internal error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServerSessionPool

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface ServerSessionPool

public interface ServerSessionPool

A ServerSessionPool object is an object implemented by an application server to provide a pool of ServerSession objects for processing the messages of a ConnectionConsumer (optional).

Its only method is getServerSession. The JMS API does not architect how the pool is implemented. It could be a static pool of ServerSession objects, or it could use a sophisticated algorithm to dynamically create ServerSession objects as needed.

If the ServerSessionPool is out of ServerSession objects, the getServerSession call may block. If a ConnectionConsumer is blocked, it cannot deliver new messages until a ServerSession is eventually returned.

Version:
1.0 - 9 March 1998
Author:
Mark Hapner, Rich Burridge
See Also:
ServerSession

Method Summary
 ServerSession getServerSession()
Return a server session from the pool.

Method Detail

getServerSession

ServerSession getServerSession()
                               throws JMSException
Return a server session from the pool.

Returns:
a server session from the pool
Throws:
JMSException - if an application server fails to return a ServerSession out of its server session pool.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Session

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface Session

All Superinterfaces:
Runnable
All Known Subinterfaces:
QueueSession, TopicSession, XAQueueSession, XASession, XATopicSession
public interface Session
extends Runnable

A Session object is a single-threaded context for producing and consuming messages. Although it may allocate provider resources outside the Java virtual machine (JVM), it is considered a lightweight JMS object.

A session serves several purposes:

  • It is a factory for its message producers and consumers.
  • It supplies provider-optimized message factories.
  • It is a factory for TemporaryTopics and TemporaryQueues.
  • It provides a way to create Queue or Topic objects for those clients that need to dynamically manipulate provider-specific destination names.
  • It supports a single series of transactions that combine work spanning its producers and consumers into atomic units.
  • It defines a serial order for the messages it consumes and the messages it produces.
  • It retains messages it consumes until they have been acknowledged.
  • It serializes execution of message listeners registered with its message consumers.
  • It is a factory for QueueBrowsers.

A session can create and service multiple message producers and consumers.

One typical use is to have a thread block on a synchronous MessageConsumer until a message arrives. The thread may then use one or more of the Session's MessageProducers.

If a client desires to have one thread produce messages while others consume them, the client should use a separate session for its producing thread.

Once a connection has been started, any session with one or more registered message listeners is dedicated to the thread of control that delivers messages to it. It is erroneous for client code to use this session or any of its constituent objects from another thread of control. The only exception to this rule is the use of the session or connection close method.

It should be easy for most clients to partition their work naturally into sessions. This model allows clients to start simply and incrementally add message processing complexity as their need for concurrency grows.

The close method is the only session method that can be called while some other session method is being executed in another thread.

A session may be specified as transacted. Each transacted session supports a single series of transactions. Each transaction groups a set of message sends and a set of message receives into an atomic unit of work. In effect, transactions organize a session's input message stream and output message stream into series of atomic units. When a transaction commits, its atomic unit of input is acknowledged and its associated atomic unit of output is sent. If a transaction rollback is done, the transaction's sent messages are destroyed and the session's input is automatically recovered.

The content of a transaction's input and output units is simply those messages that have been produced and consumed within the session's current transaction.

A transaction is completed using either its session's commit method or its session's rollback method. The completion of a session's current transaction automatically begins the next. The result is that a transacted session always has a current transaction within which its work is done.

The Java Transaction Service (JTS) or some other transaction monitor may be used to combine a session's transaction with transactions on other resources (databases, other JMS sessions, etc.). Since Java distributed transactions are controlled via the Java Transaction API (JTA), use of the session's commit and rollback methods in this context is prohibited.

The JMS API does not require support for JTA; however, it does define how a provider supplies this support.

Although it is also possible for a JMS client to handle distributed transactions directly, it is unlikely that many JMS clients will do this. Support for JTA in the JMS API is targeted at systems vendors who will be integrating the JMS API into their application server products.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
QueueSession, TopicSession, XASession

Field Summary
static int | AUTO_ACKNOWLEDGE With this acknowledgment mode, the session automatically acknowledges a client's receipt of a message either when the session has successfully returned from a call to receive or when the message listener the session has called to process the message successfully returns.
static int | CLIENT_ACKNOWLEDGE With this acknowledgment mode, the client acknowledges a consumed message by calling the message's acknowledge method.
static int | DUPS_OK_ACKNOWLEDGE This acknowledgment mode instructs the session to lazily acknowledge the delivery of messages.
static int | SESSION_TRANSACTED This value is returned from the method getAcknowledgeMode if the session is transacted.
Method Summary
void | close() Closes the session.
void | commit() Commits all messages done in this transaction and releases any locks currently held.
QueueBrowser | createBrowser(Queue queue) Creates a QueueBrowser object to peek at the messages on the specified queue.
QueueBrowser | createBrowser(Queue queue, String messageSelector) Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.
BytesMessage | createBytesMessage() Creates a BytesMessage object.
MessageConsumer | createConsumer(Destination destination) Creates a MessageConsumer for the specified destination.
MessageConsumer | createConsumer(Destination destination, String messageSelector) Creates a MessageConsumer for the specified destination, using a message selector.
MessageConsumer | createConsumer(Destination destination, String messageSelector, boolean NoLocal) Creates MessageConsumer for the specified destination, using a message selector.
TopicSubscriber | createDurableSubscriber(Topic topic, String name) Creates a durable subscriber to the specified topic.
TopicSubscriber | createDurableSubscriber(Topic topic, String name, String messageSelector, boolean noLocal) Creates a durable subscriber to the specified topic, using a message selector and specifying whether messages published by its own connection should be delivered to it.
MapMessage | createMapMessage() Creates a MapMessage object.
Message | createMessage() Creates a Message object.
ObjectMessage | createObjectMessage() Creates an ObjectMessage object.
ObjectMessage | createObjectMessage(Serializable object) Creates an initialized ObjectMessage object.
MessageProducer | createProducer(Destination destination) Creates a MessageProducer to send messages to the specified destination.
Queue | createQueue(String queueName) Creates a queue identity given a Queue name.
StreamMessage | createStreamMessage() Creates a StreamMessage object.
TemporaryQueue | createTemporaryQueue() Creates a TemporaryQueue object.
TemporaryTopic | createTemporaryTopic() Creates a TemporaryTopic object.
TextMessage | createTextMessage() Creates a TextMessage object.
TextMessage | createTextMessage(String text) Creates an initialized TextMessage object.
Topic | createTopic(String topicName) Creates a topic identity given a Topic name.
int | getAcknowledgeMode() Returns the acknowledgement mode of the session.
MessageListener | getMessageListener() Returns the session's distinguished message listener (optional).
boolean | getTransacted() Indicates whether the session is in transacted mode.
void | recover() Stops message delivery in this session, and restarts message delivery with the oldest unacknowledged message.
void | rollback() Rolls back any messages done in this transaction and releases any locks currently held.
void | run() Optional operation, intended to be used only by Application Servers, not by ordinary JMS clients.
void | setMessageListener(MessageListener listener) Sets the session's distinguished message listener (optional).
void | unsubscribe(String name) Unsubscribes a durable subscription that has been created by a client.

Field Detail

AUTO_ACKNOWLEDGE

static final int AUTO_ACKNOWLEDGE
With this acknowledgment mode, the session automatically acknowledges a client's receipt of a message either when the session has successfully returned from a call to receive or when the message listener the session has called to process the message successfully returns.

See Also:
Constant Field Values

CLIENT_ACKNOWLEDGE

static final int CLIENT_ACKNOWLEDGE
With this acknowledgment mode, the client acknowledges a consumed message by calling the message's acknowledge method. Acknowledging a consumed message acknowledges all messages that the session has consumed.

When client acknowledgment mode is used, a client may build up a large number of unacknowledged messages while attempting to process them. A JMS provider should provide administrators with a way to limit client overrun so that clients are not driven to resource exhaustion and ensuing failure when some resource they are using is temporarily blocked.

See Also:
Message.acknowledge(), Constant Field Values

DUPS_OK_ACKNOWLEDGE

static final int DUPS_OK_ACKNOWLEDGE
This acknowledgment mode instructs the session to lazily acknowledge the delivery of messages. This is likely to result in the delivery of some duplicate messages if the JMS provider fails, so it should only be used by consumers that can tolerate duplicate messages. Use of this mode can reduce session overhead by minimizing the work the session does to prevent duplicates.

See Also:
Constant Field Values

SESSION_TRANSACTED

static final int SESSION_TRANSACTED
This value is returned from the method getAcknowledgeMode if the session is transacted. If a Session is transacted, the acknowledgement mode is ignored.

See Also:
Constant Field Values
Method Detail

createBytesMessage

BytesMessage createBytesMessage()
                                throws JMSException
Creates a BytesMessage object. A BytesMessage object is used to send a message containing a stream of uninterpreted bytes.

Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createMapMessage

MapMessage createMapMessage()
                            throws JMSException
Creates a MapMessage object. A MapMessage object is used to send a self-defining set of name-value pairs, where names are String objects and values are primitive values in the Java programming language.

Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createMessage

Message createMessage()
                      throws JMSException
Creates a Message object. The Message interface is the root interface of all JMS messages. A Message object holds all the standard message header information. It can be sent when a message containing only header information is sufficient.

Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createObjectMessage

ObjectMessage createObjectMessage()
                                  throws JMSException
Creates an ObjectMessage object. An ObjectMessage object is used to send a message that contains a serializable Java object.

Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createObjectMessage

ObjectMessage createObjectMessage(Serializable object)
                                  throws JMSException
Creates an initialized ObjectMessage object. An ObjectMessage object is used to send a message that contains a serializable Java object.

Parameters:
object - the object to use to initialize this message
Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createStreamMessage

StreamMessage createStreamMessage()
                                  throws JMSException
Creates a StreamMessage object. A StreamMessage object is used to send a self-defining stream of primitive values in the Java programming language.

Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createTextMessage

TextMessage createTextMessage()
                              throws JMSException
Creates a TextMessage object. A TextMessage object is used to send a message containing a String object.

Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

createTextMessage

TextMessage createTextMessage(String text)
                              throws JMSException
Creates an initialized TextMessage object. A TextMessage object is used to send a message containing a String.

Parameters:
text - the string used to initialize this message
Throws:
JMSException - if the JMS provider fails to create this message due to some internal error.

getTransacted

boolean getTransacted()
                      throws JMSException
Indicates whether the session is in transacted mode.

Returns:
true if the session is in transacted mode
Throws:
JMSException - if the JMS provider fails to return the transaction mode due to some internal error.

getAcknowledgeMode

int getAcknowledgeMode()
                       throws JMSException
Returns the acknowledgement mode of the session. The acknowledgement mode is set at the time that the session is created. If the session is transacted, the acknowledgement mode is ignored.

Returns:
If the session is not transacted, returns the current acknowledgement mode for the session. If the session is transacted, returns SESSION_TRANSACTED.
Throws:
JMSException - if the JMS provider fails to return the acknowledgment mode due to some internal error.
Since:
1.1
See Also:
Connection.createSession(boolean, int)

commit

void commit()
            throws JMSException
Commits all messages done in this transaction and releases any locks currently held.

Throws:
JMSException - if the JMS provider fails to commit the transaction due to some internal error.
TransactionRolledBackException - if the transaction is rolled back due to some internal error during commit.
IllegalStateException - if the method is not called by a transacted session.

rollback

void rollback()
              throws JMSException
Rolls back any messages done in this transaction and releases any locks currently held.

Throws:
JMSException - if the JMS provider fails to roll back the transaction due to some internal error.
IllegalStateException - if the method is not called by a transacted session.

close

void close()
           throws JMSException
Closes the session.

Since a provider may allocate some resources on behalf of a session outside the JVM, clients should close the resources when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

There is no need to close the producers and consumers of a closed session.

This call will block until a receive call or message listener in progress has completed. A blocked message consumer receive call returns null when this session is closed.

Closing a transacted session must roll back the transaction in progress.

This method is the only Session method that can be called concurrently.

Invoking any other Session method on a closed session must throw a JMSException.IllegalStateException. Closing a closed session must not throw an exception.

Throws:
JMSException - if the JMS provider fails to close the session due to some internal error.

recover

void recover()
             throws JMSException
Stops message delivery in this session, and restarts message delivery with the oldest unacknowledged message.

All consumers deliver messages in a serial order. Acknowledging a received message automatically acknowledges all messages that have been delivered to the client.

Restarting a session causes it to take the following actions:

  • Stop message delivery
  • Mark all messages that might have been delivered but not acknowledged as "redelivered"
  • Restart the delivery sequence including all unacknowledged messages that had been previously delivered. Redelivered messages do not have to be delivered in exactly their original delivery order.

Throws:
JMSException - if the JMS provider fails to stop and restart message delivery due to some internal error.
IllegalStateException - if the method is called by a transacted session.

getMessageListener

MessageListener getMessageListener()
                                   throws JMSException
Returns the session's distinguished message listener (optional).

Returns:
the message listener associated with this session
Throws:
JMSException - if the JMS provider fails to get the message listener due to an internal error.
See Also:
setMessageListener(javax.jms.MessageListener), ServerSessionPool, ServerSession

setMessageListener

void setMessageListener(MessageListener listener)
                        throws JMSException
Sets the session's distinguished message listener (optional).

When the distinguished message listener is set, no other form of message receipt in the session can be used; however, all forms of sending messages are still supported.

This is an expert facility not used by regular JMS clients.

Parameters:
listener - the message listener to associate with this session
Throws:
JMSException - if the JMS provider fails to set the message listener due to an internal error.
See Also:
getMessageListener(), ServerSessionPool, ServerSession

run

void run()
Optional operation, intended to be used only by Application Servers, not by ordinary JMS clients.

Specified by:
run in interface Runnable
See Also:
ServerSession

createProducer

MessageProducer createProducer(Destination destination)
                               throws JMSException
Creates a MessageProducer to send messages to the specified destination.

A client uses a MessageProducer object to send messages to a destination. Since Queue and Topic both inherit from Destination, they can be used in the destination parameter to create a MessageProducer object.

Parameters:
destination - the Destination to send to, or null if this is a producer which does not have a specified destination.
Throws:
JMSException - if the session fails to create a MessageProducer due to some internal error.
InvalidDestinationException - if an invalid destination is specified.
Since:
1.1

createConsumer

MessageConsumer createConsumer(Destination destination)
                               throws JMSException
Creates a MessageConsumer for the specified destination. Since Queue and Topic both inherit from Destination, they can be used in the destination parameter to create a MessageConsumer.

Parameters:
destination - the Destination to access.
Throws:
JMSException - if the session fails to create a consumer due to some internal error.
InvalidDestinationException - if an invalid destination is specified.
Since:
1.1

createConsumer

MessageConsumer createConsumer(Destination destination,
                               String messageSelector)
                               throws JMSException
Creates a MessageConsumer for the specified destination, using a message selector. Since Queue and Topic both inherit from Destination, they can be used in the destination parameter to create a MessageConsumer.

A client uses a MessageConsumer object to receive messages that have been sent to a destination.

Parameters:
destination - the Destination to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
Throws:
JMSException - if the session fails to create a MessageConsumer due to some internal error.
InvalidDestinationException - if an invalid destination is specified.
InvalidSelectorException - if the message selector is invalid.
Since:
1.1

createConsumer

MessageConsumer createConsumer(Destination destination,
                               String messageSelector,
                               boolean NoLocal)
                               throws JMSException
Creates MessageConsumer for the specified destination, using a message selector. This method can specify whether messages published by its own connection should be delivered to it, if the destination is a topic.

Since Queue and Topic both inherit from Destination, they can be used in the destination parameter to create a MessageConsumer.

A client uses a MessageConsumer object to receive messages that have been published to a destination.

In some cases, a connection may both publish and subscribe to a topic. The consumer NoLocal attribute allows a consumer to inhibit the delivery of messages published by its own connection. The default value for this attribute is False. The noLocal value must be supported by destinations that are topics.

Parameters:
destination - the Destination to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
NoLocal - - if true, and the destination is a topic, inhibits the delivery of messages published by its own connection. The behavior for NoLocal is not specified if the destination is a queue.
Throws:
JMSException - if the session fails to create a MessageConsumer due to some internal error.
InvalidDestinationException - if an invalid destination is specified.
InvalidSelectorException - if the message selector is invalid.
Since:
1.1

createQueue

Queue createQueue(String queueName)
                  throws JMSException
Creates a queue identity given a Queue name.

This facility is provided for the rare cases where clients need to dynamically manipulate queue identity. It allows the creation of a queue identity with a provider-specific name. Clients that depend on this ability are not portable.

Note that this method is not for creating the physical queue. The physical creation of queues is an administrative task and is not to be initiated by the JMS API. The one exception is the creation of temporary queues, which is accomplished with the createTemporaryQueue method.

Parameters:
queueName - the name of this Queue
Returns:
a Queue with the given name
Throws:
JMSException - if the session fails to create a queue due to some internal error.
Since:
1.1

createTopic

Topic createTopic(String topicName)
                  throws JMSException
Creates a topic identity given a Topic name.

This facility is provided for the rare cases where clients need to dynamically manipulate topic identity. This allows the creation of a topic identity with a provider-specific name. Clients that depend on this ability are not portable.

Note that this method is not for creating the physical topic. The physical creation of topics is an administrative task and is not to be initiated by the JMS API. The one exception is the creation of temporary topics, which is accomplished with the createTemporaryTopic method.

Parameters:
topicName - the name of this Topic
Returns:
a Topic with the given name
Throws:
JMSException - if the session fails to create a topic due to some internal error.
Since:
1.1

createDurableSubscriber

TopicSubscriber createDurableSubscriber(Topic topic,
                                        String name)
                                        throws JMSException
Creates a durable subscriber to the specified topic.

If a client needs to receive all the messages published on a topic, including the ones published while the subscriber is inactive, it uses a durable TopicSubscriber. The JMS provider retains a record of this durable subscription and insures that all messages from the topic's publishers are retained until they are acknowledged by this durable subscriber or they have expired.

Sessions with durable subscribers must always provide the same client identifier. In addition, each client must specify a name that uniquely identifies (within client identifier) each durable subscription it creates. Only one session at a time can have a TopicSubscriber for a particular durable subscription.

A client can change an existing durable subscription by creating a durable TopicSubscriber with the same name and a new topic and/or message selector. Changing a durable subscriber is equivalent to unsubscribing (deleting) the old one and creating a new one.

In some cases, a connection may both publish and subscribe to a topic. The subscriber NoLocal attribute allows a subscriber to inhibit the delivery of messages published by its own connection. The default value for this attribute is false.

Parameters:
topic - the non-temporary Topic to subscribe to
name - the name used to identify this subscription
Throws:
JMSException - if the session fails to create a subscriber due to some internal error.
InvalidDestinationException - if an invalid topic is specified.
Since:
1.1

createDurableSubscriber

TopicSubscriber createDurableSubscriber(Topic topic,
                                        String name,
                                        String messageSelector,
                                        boolean noLocal)
                                        throws JMSException
Creates a durable subscriber to the specified topic, using a message selector and specifying whether messages published by its own connection should be delivered to it.

If a client needs to receive all the messages published on a topic, including the ones published while the subscriber is inactive, it uses a durable TopicSubscriber. The JMS provider retains a record of this durable subscription and insures that all messages from the topic's publishers are retained until they are acknowledged by this durable subscriber or they have expired.

Sessions with durable subscribers must always provide the same client identifier. In addition, each client must specify a name which uniquely identifies (within client identifier) each durable subscription it creates. Only one session at a time can have a TopicSubscriber for a particular durable subscription. An inactive durable subscriber is one that exists but does not currently have a message consumer associated with it.

A client can change an existing durable subscription by creating a durable TopicSubscriber with the same name and a new topic and/or message selector. Changing a durable subscriber is equivalent to unsubscribing (deleting) the old one and creating a new one.

Parameters:
topic - the non-temporary Topic to subscribe to
name - the name used to identify this subscription
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
noLocal - if set, inhibits the delivery of messages published by its own connection
Throws:
JMSException - if the session fails to create a subscriber due to some internal error.
InvalidDestinationException - if an invalid topic is specified.
InvalidSelectorException - if the message selector is invalid.
Since:
1.1

createBrowser

QueueBrowser createBrowser(Queue queue)
                           throws JMSException
Creates a QueueBrowser object to peek at the messages on the specified queue.

Parameters:
queue - the queue to access
Throws:
JMSException - if the session fails to create a browser due to some internal error.
InvalidDestinationException - if an invalid destination is specified
Since:
1.1

createBrowser

QueueBrowser createBrowser(Queue queue,
                           String messageSelector)
                           throws JMSException
Creates a QueueBrowser object to peek at the messages on the specified queue using a message selector.

Parameters:
queue - the queue to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
Throws:
JMSException - if the session fails to create a browser due to some internal error.
InvalidDestinationException - if an invalid destination is specified
InvalidSelectorException - if the message selector is invalid.
Since:
1.1

createTemporaryQueue

TemporaryQueue createTemporaryQueue()
                                    throws JMSException
Creates a TemporaryQueue object. Its lifetime will be that of the Connection unless it is deleted earlier.

Returns:
a temporary queue identity
Throws:
JMSException - if the session fails to create a temporary queue due to some internal error.
Since:
1.1

createTemporaryTopic

TemporaryTopic createTemporaryTopic()
                                    throws JMSException
Creates a TemporaryTopic object. Its lifetime will be that of the Connection unless it is deleted earlier.

Returns:
a temporary topic identity
Throws:
JMSException - if the session fails to create a temporary topic due to some internal error.
Since:
1.1

unsubscribe

void unsubscribe(String name)
                 throws JMSException
Unsubscribes a durable subscription that has been created by a client.

This method deletes the state being maintained on behalf of the subscriber by its provider.

It is erroneous for a client to delete a durable subscription while there is an active MessageConsumer or TopicSubscriber for the subscription, or while a consumed message is part of a pending transaction or has not been acknowledged in the session.

Parameters:
name - the name used to identify this subscription
Throws:
JMSException - if the session fails to unsubscribe to the durable subscription due to some internal error.
InvalidDestinationException - if an invalid subscription name is specified.
Since:
1.1
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StreamMessage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface StreamMessage

All Superinterfaces:
Message
public interface StreamMessage
extends Message

A StreamMessage object is used to send a stream of primitive types in the Java programming language. It is filled and read sequentially. It inherits from the Message interface and adds a stream message body. Its methods are based largely on those found in java.io.DataInputStream and java.io.DataOutputStream.

The primitive types can be read or written explicitly using methods for each type. They may also be read or written generically as objects. For instance, a call to StreamMessage.writeInt(6) is equivalent to StreamMessage.writeObject(new Integer(6)). Both forms are provided, because the explicit form is convenient for static programming, and the object form is needed when types are not known at compile time.

When the message is first created, and when clearBody is called, the body of the message is in write-only mode. After the first call to reset has been made, the message body is in read-only mode. After a message has been sent, the client that sent it can retain and modify it without affecting the message that has been sent. The same message object can be sent multiple times. When a message has been received, the provider has called reset so that the message body is in read-only mode for the client.

If clearBody is called on a message in read-only mode, the message body is cleared and the message body is in write-only mode.

If a client attempts to read a message in write-only mode, a MessageNotReadableException is thrown.

If a client attempts to write a message in read-only mode, a MessageNotWriteableException is thrown.

StreamMessage objects support the following conversion table. The marked cases must be supported. The unmarked cases must throw a JMSException. The String-to-primitive conversions may throw a runtime exception if the primitive's valueOf() method does not accept it as a valid String representation of the primitive.

A value written as the row type can be read as the column type.

 |        | boolean byte short char int long float double String byte[]
 |----------------------------------------------------------------------
 |boolean |    X                                            X
 |byte    |          X     X         X   X                  X
 |short   |                X         X   X                  X
 |char    |                     X                           X
 |int     |                          X   X                  X
 |long    |                              X                  X
 |float   |                                    X     X      X
 |double  |                                          X      X
 |String  |    X     X     X         X   X     X     X      X
 |byte[]  |                                                        X
 |----------------------------------------------------------------------

Attempting to read a null value as a primitive type must be treated as calling the primitive's corresponding valueOf(String) conversion method with a null value. Since char does not support a String conversion, attempting to read a null value as a char must throw a NullPointerException.

Version:
1.0 - 6 August 1998
Author:
Mark Hapner, Rich Burridge
See Also:
Session.createStreamMessage(), BytesMessage, MapMessage, Message, ObjectMessage, TextMessage

Field Summary
Fields inherited from interface javax.jms.Message
DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE
Method Summary
boolean | readBoolean() Reads a boolean from the stream message.
byte | readByte() Reads a byte value from the stream message.
int | readBytes(byte[] value) Reads a byte array field from the stream message into the specified byte[] object (the read buffer).
char | readChar() Reads a Unicode character value from the stream message.
double | readDouble() Reads a double from the stream message.
float | readFloat() Reads a float from the stream message.
int | readInt() Reads a 32-bit integer from the stream message.
long | readLong() Reads a 64-bit integer from the stream message.
Object | readObject() Reads an object from the stream message.
short | readShort() Reads a 16-bit integer from the stream message.
String | readString() Reads a String from the stream message.
void | reset() Puts the message body in read-only mode and repositions the stream to the beginning.
void | writeBoolean(boolean value) Writes a boolean to the stream message.
void | writeByte(byte value) Writes a byte to the stream message.
void | writeBytes(byte[] value) Writes a byte array field to the stream message.
void | writeBytes(byte[] value, int offset, int length) Writes a portion of a byte array as a byte array field to the stream message.
void | writeChar(char value) Writes a char to the stream message.
void | writeDouble(double value) Writes a double to the stream message.
void | writeFloat(float value) Writes a float to the stream message.
void | writeInt(int value) Writes an int to the stream message.
void | writeLong(long value) Writes a long to the stream message.
void | writeObject(Object value) Writes an object to the stream message.
void | writeShort(short value) Writes a short to the stream message.
void | writeString(String value) Writes a String to the stream message.
Methods inherited from interface javax.jms.Message
acknowledge, clearBody, clearProperties, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

Method Detail

readBoolean

boolean readBoolean()
                    throws JMSException
Reads a boolean from the stream message.

Returns:
the boolean value read
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readByte

byte readByte()
              throws JMSException
Reads a byte value from the stream message.

Returns:
the next byte from the stream message as a 8-bit byte
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readShort

short readShort()
                throws JMSException
Reads a 16-bit integer from the stream message.

Returns:
a 16-bit integer from the stream message
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readChar

char readChar()
              throws JMSException
Reads a Unicode character value from the stream message.

Returns:
a Unicode character from the stream message
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid
MessageNotReadableException - if the message is in write-only mode.

readInt

int readInt()
            throws JMSException
Reads a 32-bit integer from the stream message.

Returns:
a 32-bit integer value from the stream message, interpreted as an int
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readLong

long readLong()
              throws JMSException
Reads a 64-bit integer from the stream message.

Returns:
a 64-bit integer value from the stream message, interpreted as a long
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readFloat

float readFloat()
                throws JMSException
Reads a float from the stream message.

Returns:
a float value from the stream message
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readDouble

double readDouble()
                  throws JMSException
Reads a double from the stream message.

Returns:
a double value from the stream message
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readString

String readString()
                  throws JMSException
Reads a String from the stream message.

Returns:
a Unicode string from the stream message
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.

readBytes

int readBytes(byte[] value)
              throws JMSException
Reads a byte array field from the stream message into the specified byte[] object (the read buffer).

To read the field value, readBytes should be successively called until it returns a value less than the length of the read buffer. The value of the bytes in the buffer following the last byte read is undefined.

If readBytes returns a value equal to the length of the buffer, a subsequent readBytes call must be made. If there are no more bytes to be read, this call returns -1.

If the byte array field value is null, readBytes returns -1.

If the byte array field value is empty, readBytes returns 0.

Once the first readBytes call on a byte[] field value has been made, the full value of the field must be read before it is valid to read the next field. An attempt to read the next field before that has been done will throw a MessageFormatException.

To read the byte field value into a new byte[] object, use the readObject method.

Parameters:
value - the buffer into which the data is read
Returns:
the total number of bytes read into the buffer, or -1 if there is no more data because the end of the byte field has been reached
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.
See Also:
readObject()

readObject

Object readObject()
                  throws JMSException
Reads an object from the stream message.

This method can be used to return, in objectified format, an object in the Java programming language ("Java object") that has been written to the stream with the equivalent writeObject method call, or its equivalent primitive writetype method.

Note that byte values are returned as byte[], not Byte[].

An attempt to call readObject to read a byte field value into a new byte[] object before the full value of the byte field has been read will throw a MessageFormatException.

Returns:
a Java object from the stream message, in objectified format (for example, if the object was written as an int, an Integer is returned)
Throws:
JMSException - if the JMS provider fails to read the message due to some internal error.
MessageEOFException - if unexpected end of message stream has been reached.
MessageFormatException - if this type conversion is invalid.
MessageNotReadableException - if the message is in write-only mode.
See Also:
readBytes(byte[] value)

writeBoolean

void writeBoolean(boolean value)
                  throws JMSException
Writes a boolean to the stream message. The value true is written as the value (byte)1; the value false is written as the value (byte)0.

Parameters:
value - the boolean value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeByte

void writeByte(byte value)
               throws JMSException
Writes a byte to the stream message.

Parameters:
value - the byte value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeShort

void writeShort(short value)
                throws JMSException
Writes a short to the stream message.

Parameters:
value - the short value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeChar

void writeChar(char value)
               throws JMSException
Writes a char to the stream message.

Parameters:
value - the char value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeInt

void writeInt(int value)
              throws JMSException
Writes an int to the stream message.

Parameters:
value - the int value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeLong

void writeLong(long value)
               throws JMSException
Writes a long to the stream message.

Parameters:
value - the long value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeFloat

void writeFloat(float value)
                throws JMSException
Writes a float to the stream message.

Parameters:
value - the float value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeDouble

void writeDouble(double value)
                 throws JMSException
Writes a double to the stream message.

Parameters:
value - the double value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeString

void writeString(String value)
                 throws JMSException
Writes a String to the stream message.

Parameters:
value - the String value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeBytes

void writeBytes(byte[] value)
                throws JMSException
Writes a byte array field to the stream message.

The byte array value is written to the message as a byte array field. Consecutively written byte array fields are treated as two distinct fields when the fields are read.

Parameters:
value - the byte array value to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeBytes

void writeBytes(byte[] value,
                int offset,
                int length)
                throws JMSException
Writes a portion of a byte array as a byte array field to the stream message.

The a portion of the byte array value is written to the message as a byte array field. Consecutively written byte array fields are treated as two distinct fields when the fields are read.

Parameters:
value - the byte array value to be written
offset - the initial offset within the byte array
length - the number of bytes to use
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

writeObject

void writeObject(Object value)
                 throws JMSException
Writes an object to the stream message.

This method works only for the objectified primitive object types (Integer, Double, Long ...), String objects, and byte arrays.

Parameters:
value - the Java object to be written
Throws:
JMSException - if the JMS provider fails to write the message due to some internal error.
MessageFormatException - if the object is invalid.
MessageNotWriteableException - if the message is in read-only mode.

reset

void reset()
           throws JMSException
Puts the message body in read-only mode and repositions the stream to the beginning.

Throws:
JMSException - if the JMS provider fails to reset the message due to some internal error.
MessageFormatException - if the message has an invalid format.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TemporaryQueue

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TemporaryQueue

All Superinterfaces:
Destination, Queue
public interface TemporaryQueue
extends Queue

A TemporaryQueue object is a unique Queue object created for the duration of a Connection. It is a system-defined queue that can be consumed only by the Connection that created it.

A TemporaryQueue object can be created at either the Session or QueueSession level. Creating it at the Session level allows to the TemporaryQueue to participate in transactions with objects from the Pub/Sub domain. If it is created at the QueueSession, it will only be able participate in transactions with objects from the PTP domain.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createTemporaryQueue(), QueueSession.createTemporaryQueue()

Method Summary
 void delete()
Deletes this temporary queue.
Methods inherited from interface javax.jms.Queue
getQueueName, toString

Method Detail

delete

void delete()
            throws JMSException
Deletes this temporary queue. If there are existing receivers still using it, a JMSException will be thrown.

Throws:
JMSException - if the JMS provider fails to delete the temporary queue due to some internal error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TemporaryTopic

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TemporaryTopic

All Superinterfaces:
Destination, Topic
public interface TemporaryTopic
extends Topic

A TemporaryTopic object is a unique Topic object created for the duration of a Connection. It is a system-defined topic that can be consumed only by the Connection that created it.

A TemporaryTopic object can be created either at the Session or TopicSession level. Creating it at the Session level allows the TemporaryTopic to participate in the same transaction with objects from the PTP domain. If a TemporaryTopic is created at the TopicSession, it will only be able participate in transactions with objects from the Pub/Sub domain.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createTemporaryTopic(), TopicSession.createTemporaryTopic()

Method Summary
 void delete()
Deletes this temporary topic.
Methods inherited from interface javax.jms.Topic
getTopicName, toString

Method Detail

delete

void delete()
            throws JMSException
Deletes this temporary topic. If there are existing subscribers still using it, a JMSException will be thrown.

Throws:
JMSException - if the JMS provider fails to delete the temporary topic due to some internal error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TextMessage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TextMessage

All Superinterfaces:
Message
public interface TextMessage
extends Message

A TextMessage object is used to send a message containing a java.lang.String. It inherits from the Message interface and adds a text message body.

This message type can be used to transport text-based messages, including those with XML content.

When a client receives a TextMessage, it is in read-only mode. If a client attempts to write to the message at this point, a MessageNotWriteableException is thrown. If clearBody is called, the message can now be both read from and written to.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createTextMessage(), Session.createTextMessage(String), BytesMessage, MapMessage, Message, ObjectMessage, StreamMessage, String

Field Summary
Fields inherited from interface javax.jms.Message
DEFAULT_DELIVERY_MODE, DEFAULT_PRIORITY, DEFAULT_TIME_TO_LIVE
Method Summary
String | getText() Gets the string containing this message's data.
void | setText(String string) Sets the string containing this message's data.
Methods inherited from interface javax.jms.Message
acknowledge, clearBody, clearProperties, getBooleanProperty, getByteProperty, getDoubleProperty, getFloatProperty, getIntProperty, getJMSCorrelationID, getJMSCorrelationIDAsBytes, getJMSDeliveryMode, getJMSDestination, getJMSExpiration, getJMSMessageID, getJMSPriority, getJMSRedelivered, getJMSReplyTo, getJMSTimestamp, getJMSType, getLongProperty, getObjectProperty, getPropertyNames, getShortProperty, getStringProperty, propertyExists, setBooleanProperty, setByteProperty, setDoubleProperty, setFloatProperty, setIntProperty, setJMSCorrelationID, setJMSCorrelationIDAsBytes, setJMSDeliveryMode, setJMSDestination, setJMSExpiration, setJMSMessageID, setJMSPriority, setJMSRedelivered, setJMSReplyTo, setJMSTimestamp, setJMSType, setLongProperty, setObjectProperty, setShortProperty, setStringProperty

Method Detail

setText

void setText(String string)
             throws JMSException
Sets the string containing this message's data.

Parameters:
string - the String containing the message's data
Throws:
JMSException - if the JMS provider fails to set the text due to some internal error.
MessageNotWriteableException - if the message is in read-only mode.

getText

String getText()
               throws JMSException
Gets the string containing this message's data. The default value is null.

Returns:
the String containing the message's data
Throws:
JMSException - if the JMS provider fails to get the text due to some internal error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Topic

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface Topic

All Superinterfaces:
Destination
All Known Subinterfaces:
TemporaryTopic
public interface Topic
extends Destination

A Topic object encapsulates a provider-specific topic name. It is the way a client specifies the identity of a topic to JMS API methods. For those methods that use a Destination as a parameter, a Topic object may used as an argument . For example, a Topic can be used to create a MessageConsumer and a MessageProducer by calling:

  • Session.CreateConsumer(Destination destination)
  • Session.CreateProducer(Destination destination)

Many publish/subscribe (pub/sub) providers group topics into hierarchies and provide various options for subscribing to parts of the hierarchy. The JMS API places no restriction on what a Topic object represents. It may be a leaf in a topic hierarchy, or it may be a larger part of the hierarchy.

The organization of topics and the granularity of subscriptions to them is an important part of a pub/sub application's architecture. The JMS API does not specify a policy for how this should be done. If an application takes advantage of a provider-specific topic-grouping mechanism, it should document this. If the application is installed using a different provider, it is the job of the administrator to construct an equivalent topic architecture and create equivalent Topic objects.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createConsumer(Destination),
Session.createProducer(Destination),
TopicSession.createTopic(String)

Method Summary
String | getTopicName() Gets the name of this topic.
String | toString() Returns a string representation of this object.

Method Detail

getTopicName

String getTopicName()
                    throws JMSException
Gets the name of this topic.

Clients that depend upon the name are not portable.

Returns:
the topic name
Throws:
JMSException - if the JMS provider implementation of Topic fails to return the topic name due to some internal error.

toString

String toString()
Returns a string representation of this object.

Overrides:
toString in class Object
Returns:
the provider-specific identity values for this topic
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TopicConnection

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TopicConnection

All Superinterfaces:
Connection
All Known Subinterfaces:
XATopicConnection
public interface TopicConnection
extends Connection

A TopicConnection object is an active connection to a publish/subscribe JMS provider. A client uses a TopicConnection object to create one or more TopicSession objects for producing and consuming messages.

A TopicConnection can be used to create a TopicSession, from which specialized topic-related objects can be created. A more general, and recommended approach is to use the Connection object.

The TopicConnection object should be used to support existing code.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Connection, ConnectionFactory, TopicConnectionFactory

Method Summary
ConnectionConsumer | createConnectionConsumer(Topic topic, String messageSelector, ServerSessionPool sessionPool, int maxMessages) Creates a connection consumer for this connection (optional operation).
ConnectionConsumer | createDurableConnectionConsumer(Topic topic, String subscriptionName, String messageSelector, ServerSessionPool sessionPool, int maxMessages) Create a durable connection consumer for this connection (optional operation).
TopicSession | createTopicSession(boolean transacted, int acknowledgeMode) Creates a TopicSession object.
Methods inherited from interface javax.jms.Connection
close, createConnectionConsumer, createSession, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop

Method Detail

createTopicSession

TopicSession createTopicSession(boolean transacted,
                                int acknowledgeMode)
                                throws JMSException
Creates a TopicSession object.

Parameters:
transacted - indicates whether the session is transacted
acknowledgeMode - indicates whether the consumer or the client will acknowledge any messages it receives; ignored if the session is transacted. Legal values are Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, and Session.DUPS_OK_ACKNOWLEDGE.
Returns:
a newly created topic session
Throws:
JMSException - if the TopicConnection object fails to create a session due to some internal error or lack of support for the specific transaction and acknowledgement mode.
See Also:
Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE

createConnectionConsumer

ConnectionConsumer createConnectionConsumer(Topic topic,
                                            String messageSelector,
                                            ServerSessionPool sessionPool,
                                            int maxMessages)
                                            throws JMSException
Creates a connection consumer for this connection (optional operation). This is an expert facility not used by regular JMS clients.

Parameters:
topic - the topic to access
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
sessionPool - the server session pool to associate with this connection consumer
maxMessages - the maximum number of messages that can be assigned to a server session at one time
Returns:
the connection consumer
Throws:
JMSException - if the TopicConnection object fails to create a connection consumer due to some internal error or invalid arguments for sessionPool and messageSelector.
InvalidDestinationException - if an invalid topic is specified.
InvalidSelectorException - if the message selector is invalid.
See Also:
ConnectionConsumer

createDurableConnectionConsumer

ConnectionConsumer createDurableConnectionConsumer(Topic topic,
                                                   String subscriptionName,
                                                   String messageSelector,
                                                   ServerSessionPool sessionPool,
                                                   int maxMessages)
                                                   throws JMSException
Create a durable connection consumer for this connection (optional operation). This is an expert facility not used by regular JMS clients.

Specified by:
createDurableConnectionConsumer in interface Connection
Parameters:
topic - the topic to access
subscriptionName - durable subscription name
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
sessionPool - the server session pool to associate with this durable connection consumer
maxMessages - the maximum number of messages that can be assigned to a server session at one time
Returns:
the durable connection consumer
Throws:
JMSException - if the TopicConnection object fails to create a connection consumer due to some internal error or invalid arguments for sessionPool and messageSelector.
InvalidDestinationException - if an invalid topic is specified.
InvalidSelectorException - if the message selector is invalid.
See Also:
ConnectionConsumer
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TopicConnectionFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TopicConnectionFactory

All Superinterfaces:
ConnectionFactory
All Known Subinterfaces:
XATopicConnectionFactory
public interface TopicConnectionFactory
extends ConnectionFactory

A client uses a TopicConnectionFactory object to create TopicConnection objects with a publish/subscribe JMS provider.

A TopicConnectionFactory can be used to create a TopicConnection, from which specialized topic-related objects can be created. A more general, and recommended approach is to use the ConnectionFactory object.

The TopicConnectionFactory object should be used to support existing code.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
ConnectionFactory

Method Summary
TopicConnection | createTopicConnection() Creates a topic connection with the default user identity.
TopicConnection | createTopicConnection(String userName, String password) Creates a topic connection with the specified user identity.
Methods inherited from interface javax.jms.ConnectionFactory
createConnection, createConnection

Method Detail

createTopicConnection

TopicConnection createTopicConnection()
                                      throws JMSException
Creates a topic connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Returns:
a newly created topic connection
Throws:
JMSException - if the JMS provider fails to create a topic connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.

createTopicConnection

TopicConnection createTopicConnection(String userName,
                                      String password)
                                      throws JMSException
Creates a topic connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Parameters:
userName - the caller's user name
password - the caller's password
Returns:
a newly created topic connection
Throws:
JMSException - if the JMS provider fails to create a topic connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TopicPublisher

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TopicPublisher

All Superinterfaces:
MessageProducer
public interface TopicPublisher
extends MessageProducer

A client uses a TopicPublisher object to publish messages on a topic. A TopicPublisher object is the publish-subscribe form of a message producer.

Normally, the Topic is specified when a TopicPublisher is created. In this case, an attempt to use the publish methods for an unidentified TopicPublisher will throw a java.lang.UnsupportedOperationException.

If the TopicPublisher is created with an unidentified Topic, an attempt to use the publish methods that assume that the Topic has been identified will throw a java.lang.UnsupportedOperationException.

During the execution of its publish method, a message must not be changed by other threads within the client. If the message is modified, the result of the publish is undefined.

After publishing a message, a client may retain and modify it without affecting the message that has been published. The same message object may be published multiple times.

The following message headers are set as part of publishing a message: JMSDestination, JMSDeliveryMode, JMSExpiration, JMSPriority, JMSMessageID and JMSTimeStamp. When the message is published, the values of these headers are ignored. After completion of the publish, the headers hold the values specified by the method publishing the message. It is possible for the publish method not to set JMSMessageID and JMSTimeStamp if the setting of these headers is explicitly disabled by the MessageProducer.setDisableMessageID or MessageProducer.setDisableMessageTimestamp method.

Creating a MessageProducer provides the same features as creating a TopicPublisher. A MessageProducer object is recommended when creating new code. The TopicPublisher is provided to support existing code.

Because TopicPublisher inherits from MessageProducer, it inherits the send methods that are a part of the MessageProducer interface. Using the send methods will have the same effect as using the publish methods: they are functionally the same.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createProducer(Destination), TopicSession.createPublisher(Topic)

Method Summary
Topic | getTopic() Gets the topic associated with this TopicPublisher.
void | publish(Message message) Publishes a message to the topic.
void | publish(Message message, int deliveryMode, int priority, long timeToLive) Publishes a message to the topic, specifying delivery mode, priority, and time to live.
void | publish(Topic topic, Message message) Publishes a message to a topic for an unidentified message producer.
void | publish(Topic topic, Message message, int deliveryMode, int priority, long timeToLive) Publishes a message to a topic for an unidentified message producer, specifying delivery mode, priority and time to live.
Methods inherited from interface javax.jms.MessageProducer
close, getDeliveryMode, getDestination, getDisableMessageID, getDisableMessageTimestamp, getPriority, getTimeToLive, send, send, send, send, setDeliveryMode, setDisableMessageID, setDisableMessageTimestamp, setPriority, setTimeToLive

Method Detail

getTopic

Topic getTopic()
               throws JMSException
Gets the topic associated with this TopicPublisher.

Returns:
this publisher's topic
Throws:
JMSException - if the JMS provider fails to get the topic for this TopicPublisher due to some internal error.

publish

void publish(Message message)
             throws JMSException
Publishes a message to the topic. Uses the TopicPublisher's default delivery mode, priority, and time to live.

Parameters:
message - the message to publish
Throws:
JMSException - if the JMS provider fails to publish the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with a TopicPublisher with an invalid topic.
UnsupportedOperationException - if a client uses this method with a TopicPublisher that did not specify a topic at creation time.
See Also:
MessageProducer.getDeliveryMode(),
MessageProducer.getTimeToLive(),
MessageProducer.getPriority()

publish

void publish(Message message,
             int deliveryMode,
             int priority,
             long timeToLive)
             throws JMSException
Publishes a message to the topic, specifying delivery mode, priority, and time to live.

Parameters:
message - the message to publish
deliveryMode - the delivery mode to use
priority - the priority for this message
timeToLive - the message's lifetime (in milliseconds)
Throws:
JMSException - if the JMS provider fails to publish the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with a TopicPublisher with an invalid topic.
UnsupportedOperationException - if a client uses this method with a TopicPublisher that did not specify a topic at creation time.

publish

void publish(Topic topic,
             Message message)
             throws JMSException
Publishes a message to a topic for an unidentified message producer. Uses the TopicPublisher's default delivery mode, priority, and time to live.

Typically, a message producer is assigned a topic at creation time; however, the JMS API also supports unidentified message producers, which require that the topic be supplied every time a message is published.

Parameters:
topic - the topic to publish this message to
message - the message to publish
Throws:
JMSException - if the JMS provider fails to publish the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with an invalid topic.
See Also:
MessageProducer.getDeliveryMode(),
MessageProducer.getTimeToLive(),
MessageProducer.getPriority()

publish

void publish(Topic topic,
             Message message,
             int deliveryMode,
             int priority,
             long timeToLive)
             throws JMSException
Publishes a message to a topic for an unidentified message producer, specifying delivery mode, priority and time to live.

Typically, a message producer is assigned a topic at creation time; however, the JMS API also supports unidentified message producers, which require that the topic be supplied every time a message is published.

Parameters:
topic - the topic to publish this message to
message - the message to publish
deliveryMode - the delivery mode to use
priority - the priority for this message
timeToLive - the message's lifetime (in milliseconds)
Throws:
JMSException - if the JMS provider fails to publish the message due to some internal error.
MessageFormatException - if an invalid message is specified.
InvalidDestinationException - if a client uses this method with an invalid topic.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TopicRequestor

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class TopicRequestor

java.lang.Object
    extended by  javax.jms.TopicRequestor

public class TopicRequestor
extends Object

The TopicRequestor helper class simplifies making service requests.

The TopicRequestor constructor is given a non-transacted TopicSession and a destination Topic. It creates a TemporaryTopic for the responses and provides a request method that sends the request message and waits for its reply.

This is a basic request/reply abstraction that should be sufficient for most uses. JMS providers and clients are free to create more sophisticated versions.

Version:
1.0 - 8 July 1998
Author:
Mark Hapner, Rich Burridge
See Also:
QueueRequestor

Constructor Summary
TopicRequestor(TopicSession session, Topic topic)
Constructor for the TopicRequestor class.
Method Summary
void | close() Closes the TopicRequestor and its session.
Message | request(Message message) Sends a request and waits for a reply.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TopicRequestor

public TopicRequestor(TopicSession session,
                      Topic topic)
               throws JMSException
Constructor for the TopicRequestor class.

This implementation assumes the session parameter to be non-transacted, with a delivery mode of either AUTO_ACKNOWLEDGE or DUPS_OK_ACKNOWLEDGE.

Parameters:
session - the TopicSession the topic belongs to
topic - the topic to perform the request/reply call on
Throws:
JMSException - if the JMS provider fails to create the TopicRequestor due to some internal error.
InvalidDestinationException - if an invalid topic is specified.
Method Detail

request

public Message request(Message message)
                throws JMSException
Sends a request and waits for a reply. The temporary topic is used for the JMSReplyTo destination; the first reply is returned, and any following replies are discarded.

Parameters:
message - the message to send
Returns:
the reply message
Throws:
JMSException - if the JMS provider fails to complete the request due to some internal error.

close

public void close()
           throws JMSException
Closes the TopicRequestor and its session.

Since a provider may allocate some resources on behalf of a TopicRequestor outside the Java virtual machine, clients should close them when they are not needed. Relying on garbage collection to eventually reclaim these resources may not be timely enough.

Note that this method closes the TopicSession object passed to the TopicRequestor constructor.

Throws:
JMSException - if the JMS provider fails to close the TopicRequestor due to some internal error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TopicSession

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TopicSession

All Superinterfaces:
Runnable, Session
public interface TopicSession
extends Session

A TopicSession object provides methods for creating TopicPublisher, TopicSubscriber, and TemporaryTopic objects. It also provides a method for deleting its client's durable subscribers.

A TopicSession is used for creating Pub/Sub specific objects. In general, use the Session object, and use TopicSession only to support existing code. Using the Session object simplifies the programming model, and allows transactions to be used across the two messaging domains.

A TopicSession cannot be used to create objects specific to the point-to-point domain. The following methods inherit from Session, but must throw an IllegalStateException if used from TopicSession:

  • createBrowser
  • createQueue
  • createTemporaryQueue

Version:
1.1 - April 9, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session,
Connection.createSession(boolean, int),
TopicConnection.createTopicSession(boolean, int),
XATopicSession.getTopicSession()

Field Summary
Fields inherited from interface javax.jms.Session
AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED
Method Summary
TopicSubscriber | createDurableSubscriber(Topic topic, String name) Creates a durable subscriber to the specified topic.
TopicSubscriber | createDurableSubscriber(Topic topic, String name, String messageSelector, boolean noLocal) Creates a durable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.
TopicPublisher | createPublisher(Topic topic) Creates a publisher for the specified topic.
TopicSubscriber | createSubscriber(Topic topic) Creates a nondurable subscriber to the specified topic.
TopicSubscriber | createSubscriber(Topic topic, String messageSelector, boolean noLocal) Creates a nondurable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.
TemporaryTopic | createTemporaryTopic() Creates a TemporaryTopic object.
Topic | createTopic(String topicName) Creates a topic identity given a Topic name.
void | unsubscribe(String name) Unsubscribes a durable subscription that has been created by a client.
Methods inherited from interface javax.jms.Session
close, commit, createBrowser, createBrowser, createBytesMessage, createConsumer, createConsumer, createConsumer, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createQueue, createStreamMessage, createTemporaryQueue, createTextMessage, createTextMessage, getAcknowledgeMode, getMessageListener, getTransacted, recover, rollback, run, setMessageListener

Method Detail

createTopic

Topic createTopic(String topicName)
                  throws JMSException
Creates a topic identity given a Topic name.

This facility is provided for the rare cases where clients need to dynamically manipulate topic identity. This allows the creation of a topic identity with a provider-specific name. Clients that depend on this ability are not portable.

Note that this method is not for creating the physical topic. The physical creation of topics is an administrative task and is not to be initiated by the JMS API. The one exception is the creation of temporary topics, which is accomplished with the createTemporaryTopic method.

Specified by:
createTopic in interface Session
Parameters:
topicName - the name of this Topic
Returns:
a Topic with the given name
Throws:
JMSException - if the session fails to create a topic due to some internal error.

createSubscriber

TopicSubscriber createSubscriber(Topic topic)
                                 throws JMSException
Creates a nondurable subscriber to the specified topic.

A client uses a TopicSubscriber object to receive messages that have been published to a topic.

Regular TopicSubscriber objects are not durable. They receive only messages that are published while they are active.

In some cases, a connection may both publish and subscribe to a topic. The subscriber NoLocal attribute allows a subscriber to inhibit the delivery of messages published by its own connection. The default value for this attribute is false.

Parameters:
topic - the Topic to subscribe to
Throws:
JMSException - if the session fails to create a subscriber due to some internal error.
InvalidDestinationException - if an invalid topic is specified.

createSubscriber

TopicSubscriber createSubscriber(Topic topic,
                                 String messageSelector,
                                 boolean noLocal)
                                 throws JMSException
Creates a nondurable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.

A client uses a TopicSubscriber object to receive messages that have been published to a topic.

Regular TopicSubscriber objects are not durable. They receive only messages that are published while they are active.

Messages filtered out by a subscriber's message selector will never be delivered to the subscriber. From the subscriber's perspective, they do not exist.

In some cases, a connection may both publish and subscribe to a topic. The subscriber NoLocal attribute allows a subscriber to inhibit the delivery of messages published by its own connection. The default value for this attribute is false.

Parameters:
topic - the Topic to subscribe to
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
noLocal - if set, inhibits the delivery of messages published by its own connection
Throws:
JMSException - if the session fails to create a subscriber due to some internal error.
InvalidDestinationException - if an invalid topic is specified.
InvalidSelectorException - if the message selector is invalid.

createDurableSubscriber

TopicSubscriber createDurableSubscriber(Topic topic,
                                        String name)
                                        throws JMSException
Creates a durable subscriber to the specified topic.

If a client needs to receive all the messages published on a topic, including the ones published while the subscriber is inactive, it uses a durable TopicSubscriber. The JMS provider retains a record of this durable subscription and insures that all messages from the topic's publishers are retained until they are acknowledged by this durable subscriber or they have expired.

Sessions with durable subscribers must always provide the same client identifier. In addition, each client must specify a name that uniquely identifies (within client identifier) each durable subscription it creates. Only one session at a time can have a TopicSubscriber for a particular durable subscription.

A client can change an existing durable subscription by creating a durable TopicSubscriber with the same name and a new topic and/or message selector. Changing a durable subscriber is equivalent to unsubscribing (deleting) the old one and creating a new one.

In some cases, a connection may both publish and subscribe to a topic. The subscriber NoLocal attribute allows a subscriber to inhibit the delivery of messages published by its own connection. The default value for this attribute is false.

Specified by:
createDurableSubscriber in interface Session
Parameters:
topic - the non-temporary Topic to subscribe to
name - the name used to identify this subscription
Throws:
JMSException - if the session fails to create a subscriber due to some internal error.
InvalidDestinationException - if an invalid topic is specified.

createDurableSubscriber

TopicSubscriber createDurableSubscriber(Topic topic,
                                        String name,
                                        String messageSelector,
                                        boolean noLocal)
                                        throws JMSException
Creates a durable subscriber to the specified topic, using a message selector or specifying whether messages published by its own connection should be delivered to it.

If a client needs to receive all the messages published on a topic, including the ones published while the subscriber is inactive, it uses a durable TopicSubscriber. The JMS provider retains a record of this durable subscription and insures that all messages from the topic's publishers are retained until they are acknowledged by this durable subscriber or they have expired.

Sessions with durable subscribers must always provide the same client identifier. In addition, each client must specify a name which uniquely identifies (within client identifier) each durable subscription it creates. Only one session at a time can have a TopicSubscriber for a particular durable subscription. An inactive durable subscriber is one that exists but does not currently have a message consumer associated with it.

A client can change an existing durable subscription by creating a durable TopicSubscriber with the same name and a new topic and/or message selector. Changing a durable subscriber is equivalent to unsubscribing (deleting) the old one and creating a new one.

Specified by:
createDurableSubscriber in interface Session
Parameters:
topic - the non-temporary Topic to subscribe to
name - the name used to identify this subscription
messageSelector - only messages with properties matching the message selector expression are delivered. A value of null or an empty string indicates that there is no message selector for the message consumer.
noLocal - if set, inhibits the delivery of messages published by its own connection
Throws:
JMSException - if the session fails to create a subscriber due to some internal error.
InvalidDestinationException - if an invalid topic is specified.
InvalidSelectorException - if the message selector is invalid.

createPublisher

TopicPublisher createPublisher(Topic topic)
                               throws JMSException
Creates a publisher for the specified topic.

A client uses a TopicPublisher object to publish messages on a topic. Each time a client creates a TopicPublisher on a topic, it defines a new sequence of messages that have no ordering relationship with the messages it has previously sent.

Parameters:
topic - the Topic to publish to, or null if this is an unidentified producer
Throws:
JMSException - if the session fails to create a publisher due to some internal error.
InvalidDestinationException - if an invalid topic is specified.

createTemporaryTopic

TemporaryTopic createTemporaryTopic()
                                    throws JMSException
Creates a TemporaryTopic object. Its lifetime will be that of the TopicConnection unless it is deleted earlier.

Specified by:
createTemporaryTopic in interface Session
Returns:
a temporary topic identity
Throws:
JMSException - if the session fails to create a temporary topic due to some internal error.

unsubscribe

void unsubscribe(String name)
                 throws JMSException
Unsubscribes a durable subscription that has been created by a client.

This method deletes the state being maintained on behalf of the subscriber by its provider.

It is erroneous for a client to delete a durable subscription while there is an active TopicSubscriber for the subscription, or while a consumed message is part of a pending transaction or has not been acknowledged in the session.

Specified by:
unsubscribe in interface Session
Parameters:
name - the name used to identify this subscription
Throws:
JMSException - if the session fails to unsubscribe to the durable subscription due to some internal error.
InvalidDestinationException - if an invalid subscription name is specified.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TopicSubscriber

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface TopicSubscriber

All Superinterfaces:
MessageConsumer
public interface TopicSubscriber
extends MessageConsumer

A client uses a TopicSubscriber object to receive messages that have been published to a topic. A TopicSubscriber object is the publish/subscribe form of a message consumer. A MessageConsumer can be created by using Session.createConsumer.

A TopicSession allows the creation of multiple TopicSubscriber objects per topic. It will deliver each message for a topic to each subscriber eligible to receive it. Each copy of the message is treated as a completely separate message. Work done on one copy has no effect on the others; acknowledging one does not acknowledge the others; one message may be delivered immediately, while another waits for its subscriber to process messages ahead of it.

Regular TopicSubscriber objects are not durable. They receive only messages that are published while they are active.

Messages filtered out by a subscriber's message selector will never be delivered to the subscriber. From the subscriber's perspective, they do not exist.

In some cases, a connection may both publish and subscribe to a topic. The subscriber NoLocal attribute allows a subscriber to inhibit the delivery of messages published by its own connection.

If a client needs to receive all the messages published on a topic, including the ones published while the subscriber is inactive, it uses a durable TopicSubscriber. The JMS provider retains a record of this durable subscription and insures that all messages from the topic's publishers are retained until they are acknowledged by this durable subscriber or they have expired.

Sessions with durable subscribers must always provide the same client identifier. In addition, each client must specify a name that uniquely identifies (within client identifier) each durable subscription it creates. Only one session at a time can have a TopicSubscriber for a particular durable subscription.

A client can change an existing durable subscription by creating a durable TopicSubscriber with the same name and a new topic and/or message selector. Changing a durable subscription is equivalent to unsubscribing (deleting) the old one and creating a new one.

The unsubscribe method is used to delete a durable subscription. The unsubscribe method can be used at the Session or TopicSession level. This method deletes the state being maintained on behalf of the subscriber by its provider.

Creating a MessageConsumer provides the same features as creating a TopicSubscriber. To create a durable subscriber, use of Session.CreateDurableSubscriber is recommended. The TopicSubscriber is provided to support existing code.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session.createConsumer(javax.jms.Destination), Session.createDurableSubscriber(javax.jms.Topic, java.lang.String), TopicSession, TopicSession.createSubscriber(javax.jms.Topic), MessageConsumer

Method Summary
boolean | getNoLocal() Gets the NoLocal attribute for this subscriber.
Topic | getTopic() Gets the Topic associated with this subscriber.
Methods inherited from interface javax.jms.MessageConsumer
close, getMessageListener, getMessageSelector, receive, receive, receiveNoWait, setMessageListener

Method Detail

getTopic

Topic getTopic()
               throws JMSException
Gets the Topic associated with this subscriber.

Returns:
this subscriber's Topic
Throws:
JMSException - if the JMS provider fails to get the topic for this topic subscriber due to some internal error.

getNoLocal

boolean getNoLocal()
                   throws JMSException
Gets the NoLocal attribute for this subscriber. The default value for this attribute is false.

Returns:
true if locally published messages are being inhibited
Throws:
JMSException - if the JMS provider fails to get the NoLocal attribute for this topic subscriber due to some internal error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransactionInProgressException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class TransactionInProgressException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.jms.JMSException
                extended by  javax.jms.TransactionInProgressException
All Implemented Interfaces:
Serializable
public class TransactionInProgressException
extends JMSException

This exception is thrown when an operation is invalid because a transaction is in progress. For instance, an attempt to call Session.commit when a session is part of a distributed transaction should throw a TransactionInProgressException.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
TransactionInProgressException(String reason)
Constructs a TransactionInProgressException with the specified reason.
TransactionInProgressException(String reason, String errorCode)
Constructs a TransactionInProgressException with the specified reason and error code.
Method Summary
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionInProgressException

public TransactionInProgressException(String reason,
                                      String errorCode)
Constructs a TransactionInProgressException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

TransactionInProgressException

public TransactionInProgressException(String reason)
Constructs a TransactionInProgressException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransactionRolledBackException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Class TransactionRolledBackException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.jms.JMSException
                extended by  javax.jms.TransactionRolledBackException
All Implemented Interfaces:
Serializable
public class TransactionRolledBackException
extends JMSException

This exception must be thrown when a call to Session.commit results in a rollback of the current transaction.

Version:
26 August 1998
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
TransactionRolledBackException(String reason)
Constructs a TransactionRolledBackException with the specified reason.
TransactionRolledBackException(String reason, String errorCode)
Constructs a TransactionRolledBackException with the specified reason and error code.
Method Summary
Methods inherited from class javax.jms.JMSException
getErrorCode, getLinkedException, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionRolledBackException

public TransactionRolledBackException(String reason,
                                      String errorCode)
Constructs a TransactionRolledBackException with the specified reason and error code.

Parameters:
reason - a description of the exception
errorCode - a string specifying the vendor-specific error code

TransactionRolledBackException

public TransactionRolledBackException(String reason)
Constructs a TransactionRolledBackException with the specified reason. The error code defaults to null.

Parameters:
reason - a description of the exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XAConnection

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XAConnection

All Superinterfaces:
Connection
All Known Subinterfaces:
XAQueueConnection, XATopicConnection
public interface XAConnection
extends Connection

The XAConnection interface extends the capability of Connection by providing an XASession (optional).

The XAConnection interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
XAQueueConnection, XATopicConnection

Method Summary
Session | createSession(boolean transacted, int acknowledgeMode) Creates an Session object.
XASession | createXASession() Creates an XASession object.
Methods inherited from interface javax.jms.Connection
close, createConnectionConsumer, createDurableConnectionConsumer, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop

Method Detail

createXASession

XASession createXASession()
                          throws JMSException
Creates an XASession object.

Returns:
a newly created XASession
Throws:
JMSException - if the XAConnection object fails to create an XASession due to some internal error.
Since:
1.1

createSession

Session createSession(boolean transacted,
                      int acknowledgeMode)
                      throws JMSException
Creates an Session object.

Specified by:
createSession in interface Connection
Parameters:
transacted - usage undefined
acknowledgeMode - usage undefined
Returns:
a Session object
Throws:
JMSException - if the XAConnection object fails to create an Session due to some internal error.
Since:
1.1
See Also:
Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XAConnectionFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XAConnectionFactory

All Known Subinterfaces:
XAQueueConnectionFactory, XATopicConnectionFactory
public interface XAConnectionFactory

The XAConnectionFactory interface is a base interface for the XAQueueConnectionFactory and XATopicConnectionFactory interfaces.

Some application servers provide support for grouping JTS capable resource use into a distributed transaction (optional). To include JMS API transactions in a JTS transaction, an application server requires a JTS aware JMS provider. A JMS provider exposes its JTS support using an XAConnectionFactory object, which an application server uses to create XAConnection objects.

XAConnectionFactory objects are JMS administered objects, just like ConnectionFactory objects. It is expected that application servers will find them using the Java Naming and Directory Interface (JNDI) API.

The XAConnectionFactory interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 April 4, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
XAQueueConnectionFactory, XATopicConnectionFactory

Method Summary
XAConnection | createXAConnection() Creates an XAConnection with the default user identity.
XAConnection | createXAConnection(String userName, String password) Creates an XA connection with the specified user identity.

Method Detail

createXAConnection

XAConnection createXAConnection()
                                throws JMSException
Creates an XAConnection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Returns:
a newly created XAConnection
Throws:
JMSException - if the JMS provider fails to create an XA connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Since:
1.1

createXAConnection

XAConnection createXAConnection(String userName,
                                String password)
                                throws JMSException
Creates an XA connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Parameters:
userName - the caller's user name
password - the caller's password
Returns:
a newly created XA connection
Throws:
JMSException - if the JMS provider fails to create an XA connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Since:
1.1
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XAQueueConnection

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XAQueueConnection

All Superinterfaces:
Connection, QueueConnection, XAConnection
public interface XAQueueConnection
extends XAConnection, QueueConnection

An XAQueueConnection provides the same create options as QueueConnection (optional). The only difference is that an XAConnection is by definition transacted.

The XAQueueConnection interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 February 2 - 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
XAConnection

Method Summary
QueueSession | createQueueSession(boolean transacted, int acknowledgeMode) Creates an XAQueueSession object.
XAQueueSession | createXAQueueSession() Creates an XAQueueSession object.
Methods inherited from interface javax.jms.XAConnection
createSession, createXASession
Methods inherited from interface javax.jms.Connection
close, createConnectionConsumer, createDurableConnectionConsumer, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop
Methods inherited from interface javax.jms.QueueConnection
createConnectionConsumer
Methods inherited from interface javax.jms.Connection
close, createConnectionConsumer, createDurableConnectionConsumer, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop

Method Detail

createXAQueueSession

XAQueueSession createXAQueueSession()
                                    throws JMSException
Creates an XAQueueSession object.

Returns:
a newly created XAQueueSession
Throws:
JMSException - if the XAQueueConnection object fails to create an XA queue session due to some internal error.

createQueueSession

QueueSession createQueueSession(boolean transacted,
                                int acknowledgeMode)
                                throws JMSException
Creates an XAQueueSession object.

Specified by:
createQueueSession in interface QueueConnection
Parameters:
transacted - usage undefined
acknowledgeMode - usage undefined
Returns:
a newly created XAQueueSession
Throws:
JMSException - if the XAQueueConnection object fails to create an XA queue session due to some internal error.
See Also:
Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XAQueueConnectionFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XAQueueConnectionFactory

All Superinterfaces:
ConnectionFactory, QueueConnectionFactory, XAConnectionFactory
public interface XAQueueConnectionFactory
extends XAConnectionFactory, QueueConnectionFactory

An XAQueueConnectionFactory provides the same create options as a QueueConnectionFactory (optional).

The XATopicConnectionFactory interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 - 8 April 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
QueueConnectionFactory, XAConnectionFactory

Method Summary
XAQueueConnection | createXAQueueConnection() Creates an XA queue connection with the default user identity.
XAQueueConnection | createXAQueueConnection(String userName, String password) Creates an XA queue connection with the specified user identity.
Methods inherited from interface javax.jms.XAConnectionFactory
createXAConnection, createXAConnection
Methods inherited from interface javax.jms.QueueConnectionFactory
createQueueConnection, createQueueConnection
Methods inherited from interface javax.jms.ConnectionFactory
createConnection, createConnection

Method Detail

createXAQueueConnection

XAQueueConnection createXAQueueConnection()
                                          throws JMSException
Creates an XA queue connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Returns:
a newly created XA queue connection
Throws:
JMSException - if the JMS provider fails to create an XA queue connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.

createXAQueueConnection

XAQueueConnection createXAQueueConnection(String userName,
                                          String password)
                                          throws JMSException
Creates an XA queue connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Parameters:
userName - the caller's user name
password - the caller's password
Returns:
a newly created XA queue connection
Throws:
JMSException - if the JMS provider fails to create an XA queue connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XAQueueSession

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XAQueueSession

All Superinterfaces:
Runnable, Session, XASession
public interface XAQueueSession
extends XASession

An XAQueueSession provides a regular QueueSession, which can be used to create QueueReceiver, QueueSender, and QueueBrowser objects (optional).

The XAQueueSession interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
XASession

Field Summary
Fields inherited from interface javax.jms.Session
AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED
Method Summary
 QueueSession getQueueSession()
Gets the queue session associated with this XAQueueSession.
Methods inherited from interface javax.jms.XASession
commit, getSession, getTransacted, getXAResource, rollback
Methods inherited from interface javax.jms.Session
close, createBrowser, createBrowser, createBytesMessage, createConsumer, createConsumer, createConsumer, createDurableSubscriber, createDurableSubscriber, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createQueue, createStreamMessage, createTemporaryQueue, createTemporaryTopic, createTextMessage, createTextMessage, createTopic, getAcknowledgeMode, getMessageListener, recover, run, setMessageListener, unsubscribe

Method Detail

getQueueSession

QueueSession getQueueSession()
                             throws JMSException
Gets the queue session associated with this XAQueueSession.

Returns:
the queue session object
Throws:
JMSException - if an internal error occurs.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XASession

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XASession

All Superinterfaces:
Runnable, Session
All Known Subinterfaces:
XAQueueSession, XATopicSession
public interface XASession
extends Session

The XASession interface extends the capability of Session by adding access to a JMS provider's support for the Java Transaction API (JTA) (optional). This support takes the form of a javax.transaction.xa.XAResource object. The functionality of this object closely resembles that defined by the standard X/Open XA Resource interface.

An application server controls the transactional assignment of an XASession by obtaining its XAResource. It uses the XAResource to assign the session to a transaction, prepare and commit work on the transaction, and so on.

An XAResource provides some fairly sophisticated facilities for interleaving work on multiple transactions, recovering a list of transactions in progress, and so on. A JTA aware JMS provider must fully implement this functionality. This could be done by using the services of a database that supports XA, or a JMS provider may choose to implement this functionality from scratch.

A client of the application server is given what it thinks is a regular JMS Session. Behind the scenes, the application server controls the transaction management of the underlying XASession.

The XASession interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
Session

Field Summary
Fields inherited from interface javax.jms.Session
AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED
Method Summary
void | commit() Throws a TransactionInProgressException, since it should not be called for an XASession object.
Session | getSession() Gets the session associated with this XASession.
boolean | getTransacted() Indicates whether the session is in transacted mode.
XAResource | getXAResource() Returns an XA resource to the caller.
void | rollback() Throws a TransactionInProgressException, since it should not be called for an XASession object.
Methods inherited from interface javax.jms.Session
close, createBrowser, createBrowser, createBytesMessage, createConsumer, createConsumer, createConsumer, createDurableSubscriber, createDurableSubscriber, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createQueue, createStreamMessage, createTemporaryQueue, createTemporaryTopic, createTextMessage, createTextMessage, createTopic, getAcknowledgeMode, getMessageListener, recover, run, setMessageListener, unsubscribe

Method Detail

getSession

Session getSession()
                   throws JMSException
Gets the session associated with this XASession.

Returns:
the session object
Throws:
JMSException - if an internal error occurs.
Since:
1.1

getXAResource

XAResource getXAResource()
Returns an XA resource to the caller.

Returns:
an XA resource to the caller

getTransacted

boolean getTransacted()
                      throws JMSException
Indicates whether the session is in transacted mode.

Specified by:
getTransacted in interface Session
Returns:
true
Throws:
JMSException - if the JMS provider fails to return the transaction mode due to some internal error.

commit

void commit()
            throws JMSException
Throws a TransactionInProgressException, since it should not be called for an XASession object.

Specified by:
commit in interface Session
Throws:
TransactionInProgressException - if the method is called on an XASession.
JMSException - if the JMS provider fails to commit the transaction due to some internal error.
TransactionRolledBackException - if the transaction is rolled back due to some internal error during commit.
IllegalStateException - if the method is not called by a transacted session.

rollback

void rollback()
              throws JMSException
Throws a TransactionInProgressException, since it should not be called for an XASession object.

Specified by:
rollback in interface Session
Throws:
TransactionInProgressException - if the method is called on an XASession.
JMSException - if the JMS provider fails to roll back the transaction due to some internal error.
IllegalStateException - if the method is not called by a transacted session.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XATopicConnection

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XATopicConnection

All Superinterfaces:
Connection, TopicConnection, XAConnection
public interface XATopicConnection
extends XAConnection, TopicConnection

An XATopicConnection provides the same create options as TopicConnection (optional). The Topic connections created are transactional.

The XATopicConnection interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 - February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
XAConnection

Method Summary
TopicSession | createTopicSession(boolean transacted, int acknowledgeMode) Creates an XATopicSession object.
XATopicSession | createXATopicSession() Creates an XATopicSession object.
Methods inherited from interface javax.jms.XAConnection
createSession, createXASession
Methods inherited from interface javax.jms.Connection
close, createConnectionConsumer, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop
Methods inherited from interface javax.jms.TopicConnection
createConnectionConsumer, createDurableConnectionConsumer
Methods inherited from interface javax.jms.Connection
close, createConnectionConsumer, getClientID, getExceptionListener, getMetaData, setClientID, setExceptionListener, start, stop

Method Detail

createXATopicSession

XATopicSession createXATopicSession()
                                    throws JMSException
Creates an XATopicSession object.

Returns:
a newly created XA topic session
Throws:
JMSException - if the XATopicConnection object fails to create an XA topic session due to some internal error.

createTopicSession

TopicSession createTopicSession(boolean transacted,
                                int acknowledgeMode)
                                throws JMSException
Creates an XATopicSession object.

Specified by:
createTopicSession in interface TopicConnection
Parameters:
transacted - usage undefined
acknowledgeMode - usage undefined
Returns:
a newly created XA topic session
Throws:
JMSException - if the XATopicConnection object fails to create an XA topic session due to some internal error.
See Also:
Session.AUTO_ACKNOWLEDGE, Session.CLIENT_ACKNOWLEDGE, Session.DUPS_OK_ACKNOWLEDGE
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XATopicConnectionFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XATopicConnectionFactory

All Superinterfaces:
ConnectionFactory, TopicConnectionFactory, XAConnectionFactory
public interface XATopicConnectionFactory
extends XAConnectionFactory, TopicConnectionFactory

An XATopicConnectionFactory provides the same create options as a TopicConnectionFactory (optional).

The XATopicConnectionFactory interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than use these XA interfaces directly.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
TopicConnectionFactory, XAConnectionFactory

Method Summary
XATopicConnection | createXATopicConnection() Creates an XA topic connection with the default user identity.
XATopicConnection | createXATopicConnection(String userName, String password) Creates an XA topic connection with the specified user identity.
Methods inherited from interface javax.jms.XAConnectionFactory
createXAConnection, createXAConnection
Methods inherited from interface javax.jms.TopicConnectionFactory
createTopicConnection, createTopicConnection
Methods inherited from interface javax.jms.ConnectionFactory
createConnection, createConnection

Method Detail

createXATopicConnection

XATopicConnection createXATopicConnection()
                                          throws JMSException
Creates an XA topic connection with the default user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Returns:
a newly created XA topic connection
Throws:
JMSException - if the JMS provider fails to create an XA topic connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.

createXATopicConnection

XATopicConnection createXATopicConnection(String userName,
                                          String password)
                                          throws JMSException
Creates an XA topic connection with the specified user identity. The connection is created in stopped mode. No messages will be delivered until the Connection.start method is explicitly called.

Parameters:
userName - the caller's user name
password - the caller's password
Returns:
a newly created XA topic connection
Throws:
JMSException - if the JMS provider fails to create an XA topic connection due to some internal error.
JMSSecurityException - if client authentication fails due to an invalid user name or password.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XATopicSession

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.jms
Interface XATopicSession

All Superinterfaces:
Runnable, Session, XASession
public interface XATopicSession
extends XASession

An XATopicSession provides a regular TopicSession. which can be used to create TopicSubscriber and TopicPublisher objects (optional).

The XATopicSession interface is optional. JMS providers are not required to support this interface. This interface is for use by JMS providers to support transactional environments. Client programs are strongly encouraged to use the transactional support available in their environment, rather than using these XA interfaces directly.

Version:
1.1 February 2, 2002
Author:
Mark Hapner, Rich Burridge, Kate Stout
See Also:
XASession, TopicSession

Field Summary
Fields inherited from interface javax.jms.Session
AUTO_ACKNOWLEDGE, CLIENT_ACKNOWLEDGE, DUPS_OK_ACKNOWLEDGE, SESSION_TRANSACTED
Method Summary
 TopicSession getTopicSession()
Gets the topic session associated with this XATopicSession.
Methods inherited from interface javax.jms.XASession
commit, getSession, getTransacted, getXAResource, rollback
Methods inherited from interface javax.jms.Session
close, createBrowser, createBrowser, createBytesMessage, createConsumer, createConsumer, createConsumer, createDurableSubscriber, createDurableSubscriber, createMapMessage, createMessage, createObjectMessage, createObjectMessage, createProducer, createQueue, createStreamMessage, createTemporaryQueue, createTemporaryTopic, createTextMessage, createTextMessage, createTopic, getAcknowledgeMode, getMessageListener, recover, run, setMessageListener, unsubscribe

Method Detail

getTopicSession

TopicSession getTopicSession()
                             throws JMSException
Gets the topic session associated with this XATopicSession.

Returns:
the topic session object
Throws:
JMSException - if an internal error occurs.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


jws

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.jws

Enum Summary
WebParam.Mode The direction in which the parameter flows

Annotation Types Summary
HandlerChain | Associates the Web Service with an externally defined handler chain.
Oneway | Indicates that the given @WebMethod has only an input message and no output.
WebMethod | Customizes a method that is exposed as a Web Service operation.
WebParam | Customizes the mapping of an individual parameter to a Web Service message part and XML element.
WebResult | Customizes the mapping of the return value to a WSDL part and XML element.
WebService | Marks a Java class as implementing a Web Service, or a Java interface as defining a Web Service interface.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.jws Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.jws

Package Hierarchies:
All Packages

Annotation Type Hierarchy

  • javax.jws.HandlerChain (implements java.lang.annotation.Annotation)
  • javax.jws.Oneway (implements java.lang.annotation.Annotation)
  • javax.jws.WebMethod (implements java.lang.annotation.Annotation)
  • javax.jws.WebParam (implements java.lang.annotation.Annotation)
  • javax.jws.WebResult (implements java.lang.annotation.Annotation)
  • javax.jws.WebService (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.jws.WebParam.Mode
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Oneway

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.jws
Annotation Type Oneway

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface Oneway

Indicates that the given @WebMethod has only an input message and no output. Typically, a oneway method returns the thread of control to the calling application prior to executing the actual business method. A 181 processor should report an error if an operation marked @Oneway has a return value or Holder parameters, or declares any checked exceptions.

Author:
Copyright (c) 2004 by BEA Systems, Inc. All Rights Reserved.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HandlerChain

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.jws
Annotation Type HandlerChain

@Retention(value=RUNTIME)
@Target(value={TYPE,METHOD,FIELD})
public @interface HandlerChain

Associates the Web Service with an externally defined handler chain. This annotation is typically used in scenarios where embedding the handler configuration directly in the Java source is not appropriate; for example, where the handler configuration needs to be shared across multiple Web Services, or where the handler chain consists of handlers for multiple transports. It is an error to combine this annotation with the @SOAPMessageHandlers annotation.

Author:
Copyright (c) 2004 by BEA Systems, Inc. All Rights Reserved.

Required Element Summary
 String file
Location of the handler chain file.
Optional Element Summary
 String name
Deprecated. As of JSR-181 2.0 with no replacement.

Element Detail

file

public abstract String file
Location of the handler chain file.

The location supports 2 formats:

  1. An absolute java.net.URL in externalForm (ex: http://myhandlers.foo.com/handlerfile1.xml).
  2. A relative path from the source file or class file (ex: bar/handlerfile1.xml).

name

@Deprecated
public abstract String name
Deprecated. As of JSR-181 2.0 with no replacement.

Name of the handler chain in the configuration file

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


soap

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.jws.soap

Enum Summary
SOAPBinding.ParameterStyle | The style of mapping parameters onto SOAP messages
SOAPBinding.Style | The SOAP binding style
SOAPBinding.Use | The SOAP binding use

Annotation Types Summary
InitParam | Deprecated. As of JSR-181 2.0 with no replacement.
SOAPBinding | Specifies the mapping of the Web Service onto the SOAP message protocol.
SOAPMessageHandler | Deprecated. As of JSR-181 2.0 with no replacement.
SOAPMessageHandlers | Deprecated. As of JSR-181 2.0 with no replacement.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.jws.soap Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.jws.soap

Package Hierarchies:
All Packages

Annotation Type Hierarchy

  • javax.jws.soap.InitParam (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPBinding (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandler (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandlers (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.jws.soap.SOAPBinding.Style
      • javax.jws.soap.SOAPBinding.Use
      • javax.jws.soap.SOAPBinding.ParameterStyle
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InitParam

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.jws.soap
Annotation Type InitParam

Deprecated. As of JSR-181 2.0 with no replacement.

@Deprecated
public @interface InitParam

An initialization parameter

Author:
Copyright (c) 2004 by BEA Systems, Inc. All Rights Reserved.

Required Element Summary
String | name Deprecated. Name of the initialization parameter
String | value Deprecated. Value of the initialization parameter

Element Detail

name

public abstract String name
Deprecated.
Name of the initialization parameter

value

public abstract String value
Deprecated.
Value of the initialization parameter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPBinding

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.jws.soap
Annotation Type SOAPBinding

@Retention(value=RUNTIME)
@Target(value={TYPE,METHOD})
public @interface SOAPBinding

Specifies the mapping of the Web Service onto the SOAP message protocol.

Author:
Copyright (c) 2004 by BEA Systems, Inc. All Rights Reserved.

Optional Element Summary
SOAPBinding.ParameterStyle | parameterStyle Determines whether method parameters represent the entire message body, or whether the parameters are elements wrapped inside a top-level element named after the operation
SOAPBinding.Style | style Defines the encoding style for messages send to and from the Web Service.
SOAPBinding.Use | use Defines the formatting style for messages sent to and from the Web Service.

style

public abstract SOAPBinding.Style style
Defines the encoding style for messages send to and from the Web Service.

Default:
DOCUMENT

use

public abstract SOAPBinding.Use use
Defines the formatting style for messages sent to and from the Web Service.

Default:
LITERAL

parameterStyle

public abstract SOAPBinding.ParameterStyle parameterStyle
Determines whether method parameters represent the entire message body, or whether the parameters are elements wrapped inside a top-level element named after the operation

Default:
WRAPPED
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPBinding.ParameterStyle

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.jws.soap
Enum SOAPBinding.ParameterStyle

java.lang.Object
    extended by  java.lang.Enum<SOAPBinding.ParameterStyle>
        extended by  javax.jws.soap.SOAPBinding.ParameterStyle
All Implemented Interfaces:
Serializable, Comparable<SOAPBinding.ParameterStyle>
Enclosing class:
SOAPBinding
public static enum SOAPBinding.ParameterStyle
extends Enum<SOAPBinding.ParameterStyle>

The style of mapping parameters onto SOAP messages

Enum Constant Summary
BARE
WRAPPED
Method Summary
static SOAPBinding.ParameterStyle | valueOf(String name) Returns the enum constant of this type with the specified name.
static SOAPBinding.ParameterStyle[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

BARE

public static final SOAPBinding.ParameterStyle BARE

WRAPPED

public static final SOAPBinding.ParameterStyle WRAPPED
Method Detail

values

public static final SOAPBinding.ParameterStyle[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(SOAPBinding.ParameterStyle c : SOAPBinding.ParameterStyle.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static SOAPBinding.ParameterStyle valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPBinding.Style

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.jws.soap
Enum SOAPBinding.Style

java.lang.Object
    extended by  java.lang.Enum<SOAPBinding.Style>
        extended by  javax.jws.soap.SOAPBinding.Style
All Implemented Interfaces:
Serializable, Comparable<SOAPBinding.Style>
Enclosing class:
SOAPBinding
public static enum SOAPBinding.Style
extends Enum<SOAPBinding.Style>

The SOAP binding style

Enum Constant Summary
DOCUMENT
RPC
Method Summary
static SOAPBinding.Style | valueOf(String name) Returns the enum constant of this type with the specified name.
static SOAPBinding.Style[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

DOCUMENT

public static final SOAPBinding.Style DOCUMENT

RPC

public static final SOAPBinding.Style RPC
Method Detail

values

public static final SOAPBinding.Style[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(SOAPBinding.Style c : SOAPBinding.Style.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static SOAPBinding.Style valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPBinding.Use

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.jws.soap
Enum SOAPBinding.Use

java.lang.Object
    extended by  java.lang.Enum<SOAPBinding.Use>
        extended by  javax.jws.soap.SOAPBinding.Use
All Implemented Interfaces:
Serializable, Comparable<SOAPBinding.Use>
Enclosing class:
SOAPBinding
public static enum SOAPBinding.Use
extends Enum<SOAPBinding.Use>

The SOAP binding use

Enum Constant Summary
ENCODED
LITERAL
Method Summary
static SOAPBinding.Use | valueOf(String name) Returns the enum constant of this type with the specified name.
static SOAPBinding.Use[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

LITERAL

public static final SOAPBinding.Use LITERAL

ENCODED

public static final SOAPBinding.Use ENCODED
Method Detail

values

public static final SOAPBinding.Use[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(SOAPBinding.Use c : SOAPBinding.Use.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static SOAPBinding.Use valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPMessageHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.jws.soap
Annotation Type SOAPMessageHandler

Deprecated. As of JSR-181 2.0 with no replacement.

@Deprecated
public @interface SOAPMessageHandler

A single SOAP message handler

Author:
Copyright (c) 2004 by BEA Systems, Inc. All Rights Reserved.

Required Element Summary
 String className
Deprecated. Name of the handler class.
Optional Element Summary
String[] | headers Deprecated. List of SOAP headers processed by the handler.
InitParam[] | initParams Deprecated. Array of name/value pairs that should be passed to the handler during initialization.
String | name Deprecated. Name of the handler.
String[] | roles Deprecated. List of SOAP roles/actors implemented by the handler

Element Detail

className

public abstract String className
Deprecated.
Name of the handler class.

name

public abstract String name
Deprecated.
Name of the handler. Defaults to the name of the handler class.

Default:
""

initParams

public abstract InitParam[] initParams
Deprecated.
Array of name/value pairs that should be passed to the handler during initialization.

Default:
{}

roles

public abstract String[] roles
Deprecated.
List of SOAP roles/actors implemented by the handler

Default:
{}

headers

public abstract String[] headers
Deprecated.
List of SOAP headers processed by the handler. Each element in this array contains a QName which defines the header element processed by the handler. The QNames are specified using the string notation described in the documentation for javax.xml.namespace.QName.valueOf(String qNameAsString)

Default:
{}
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPMessageHandlers

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.jws.soap
Annotation Type SOAPMessageHandlers

Deprecated. As of JSR-181 2.0 with no replacement.

@Retention(value=RUNTIME)
@Target(value=TYPE)
@Deprecated
public @interface SOAPMessageHandlers

Specifies a list of SOAP protocol handlers that run before and after business methods on the Web Service. These handlers are called in response to SOAP messages targeting the service.

The @SOAPMessageHandlers annotation is an array of SOAPMessageHandler types. The handlers are run in the order in which they appear in the annotation, starting with the first handler in the array.

Author:
Copyright (c) 2004 by BEA Systems, Inc. All Rights Reserved.

Required Element Summary
 SOAPMessageHandler[] value
Deprecated.

Element Detail

value

public abstract SOAPMessageHandler[] value
Deprecated.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebMethod

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.jws
Annotation Type WebMethod

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface WebMethod

Customizes a method that is exposed as a Web Service operation. The associated method must be public and its parameters return value, and exceptions must follow the rules defined in JAX-RPC 1.1, section 5. The method is not required to throw java.rmi.RemoteException.

Author:
Copyright (c) 2004 by BEA Systems, Inc. All Rights Reserved.

Optional Element Summary
String | action The action for this operation.
boolean | exclude Marks a method to NOT be exposed as a web method.
String | operationName Name of the wsdl:operation matching this method.

operationName

public abstract String operationName
Name of the wsdl:operation matching this method.

Default:
""

action

public abstract String action
The action for this operation.

For SOAP bindings, this determines the value of the soap action.

Default:
""

exclude

public abstract boolean exclude
Marks a method to NOT be exposed as a web method.

Used to stop an inherited method from being exposed as part of this web service. If this element is specified, other elements MUST NOT be specified for the @WebMethod.

This member-value is not allowed on endpoint interfaces.

Since:
2.0
Default:
false
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebParam

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.jws
Annotation Type WebParam

@Retention(value=RUNTIME)
@Target(value=PARAMETER)
public @interface WebParam

Customizes the mapping of an individual parameter to a Web Service message part and XML element.

Author:
Copyright (c) 2004 by BEA Systems, Inc. All Rights Reserved.

Optional Element Summary
boolean | header If true, the parameter is pulled from a message header rather then the message body.
WebParam.Mode | mode The direction in which the parameter is flowing (One of IN, OUT, or INOUT).
String | name Name of the parameter.
String | partName The name of the wsdl:part representing this parameter.
String | targetNamespace The XML namespace for the parameter.

name

public abstract String name
Name of the parameter.

If the operation is rpc style and @WebParam.partName has not been specified, this is name of the wsdl:part representing the parameter.
If the operation is document style or the parameter maps to a header, this is the local name of the XML element representing the parameter.

A name MUST be specified if the operation is document style, the parameter style is BARE, and the mode is OUT or INOUT.

Default:
""

partName

public abstract String partName
The name of the wsdl:part representing this parameter.

This is only used if the operation is rpc style or if the operation is document style and the parameter style is BARE.

Since:
2.0
Default:
""

targetNamespace

public abstract String targetNamespace
The XML namespace for the parameter.

Only used if the operation is document style or the paramater maps to a header. If the target namespace is set to “”, this represents the empty namespace.

Default:
""

mode

public abstract WebParam.Mode mode
The direction in which the parameter is flowing (One of IN, OUT, or INOUT).

The OUT and INOUT modes may only be specified for parameter types that conform to the definition of Holder types (JAX-WS 2.0 [5], section 2.3.3). Parameters that are Holder Types MUST be OUT or INOUT.

Default:
IN

header

public abstract boolean header
If true, the parameter is pulled from a message header rather then the message body.

Default:
false
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebParam.Mode

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.jws
Enum WebParam.Mode

java.lang.Object
    extended by  java.lang.Enum<WebParam.Mode>
        extended by  javax.jws.WebParam.Mode
All Implemented Interfaces:
Serializable, Comparable<WebParam.Mode>
Enclosing class:
WebParam
public static enum WebParam.Mode
extends Enum<WebParam.Mode>

The direction in which the parameter flows

Enum Constant Summary
IN
INOUT
OUT
Method Summary
static WebParam.Mode | valueOf(String name) Returns the enum constant of this type with the specified name.
static WebParam.Mode[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

IN

public static final WebParam.Mode IN

OUT

public static final WebParam.Mode OUT

INOUT

public static final WebParam.Mode INOUT
Method Detail

values

public static final WebParam.Mode[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(WebParam.Mode c : WebParam.Mode.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static WebParam.Mode valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebResult

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.jws
Annotation Type WebResult

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface WebResult

Customizes the mapping of the return value to a WSDL part and XML element.

Author:
Copyright (c) 2004 by BEA Systems, Inc. All Rights Reserved.

Optional Element Summary
boolean | header If true, the result is pulled from a message header rather then the message body.
String | name Name of return value.
String | partName The name of the wsdl:part representing this return value.
String | targetNamespace The XML namespace for the return value.

name

public abstract String name
Name of return value.

If the operation is rpc style and @WebResult.partName has not been specified, this is the name of the wsdl:part representing the return value.
If the operation is document style or the return value maps to a header, this is the local name of the XML element representing the return value.

Default:
""

partName

public abstract String partName
The name of the wsdl:part representing this return value.

This is only used if the operation is rpc style, or if the operation is document style and the parameter style is BARE.

Since:
2.0
Default:
""

targetNamespace

public abstract String targetNamespace
The XML namespace for the return value.

Only used if the operation is document style or the return value maps to a header. If the target namespace is set to “”, this represents the empty namespace.

Default:
""

header

public abstract boolean header
If true, the result is pulled from a message header rather then the message body.

Since:
2.0
Default:
false
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebService

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.jws
Annotation Type WebService

@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface WebService

Marks a Java class as implementing a Web Service, or a Java interface as defining a Web Service interface.

Author:
Copyright (c) 2004 by BEA Systems, Inc. All Rights Reserved.

Optional Element Summary
String | endpointInterface The complete name of the service endpoint interface defining the service’s abstract Web Service contract.
String | name The name of the Web Service.
String | portName The port name of the Web Service.
String | serviceName The service name of the Web Service.
String | targetNamespace If the @WebService.targetNamespace annotation is on a service endpoint interface, the targetNamespace is used for the namespace for the wsdl:portType (and associated XML elements).
String | wsdlLocation The location of a pre-defined WSDL describing the service.

name

public abstract String name
The name of the Web Service.

Used as the name of the wsdl:portType when mapped to WSDL 1.1.

Default:
""

targetNamespace

public abstract String targetNamespace
If the @WebService.targetNamespace annotation is on a service endpoint interface, the targetNamespace is used for the namespace for the wsdl:portType (and associated XML elements).

If the @WebService.targetNamespace annotation is on a service implementation bean that does NOT reference a service endpoint interface (through the endpointInterface attribute), the targetNamespace is used for both the wsdl:portType and the wsdl:service (and associated XML elements).

If the @WebService.targetNamespace annotation is on a service implementation bean that does reference a service endpoint interface (through the endpointInterface attribute), the targetNamespace is used for only the wsdl:service (and associated XML elements).

Default:
""

serviceName

public abstract String serviceName
The service name of the Web Service.

Used as the name of the wsdl:service when mapped to WSDL 1.1.

This member-value is not allowed on endpoint interfaces.

Default:
""

portName

public abstract String portName
The port name of the Web Service.

Used as the name of the wsdl:port when mapped to WSDL 1.1.

This member-value is not allowed on endpoint interfaces.

Since:
2.0
Default:
""

wsdlLocation

public abstract String wsdlLocation
The location of a pre-defined WSDL describing the service.

The wsdlLocation is a URL (relative or absolute) that refers to a pre-existing WSDL file. The presence of a wsdlLocation value indicates that the service implementation bean is implementing a pre-defined WSDL contract. The JSR-181 tool MUST provide feedback if the service implementation bean is inconsistent with the portType and bindings declared in this WSDL. Note that a single WSDL file might contain multiple portTypes and multiple bindings. The annotations on the service implementation bean determine the specific portType and bindings that correspond to the Web Service.

Default:
""

endpointInterface

public abstract String endpointInterface
The complete name of the service endpoint interface defining the service’s abstract Web Service contract.

This annotation allows the developer to separate the interface contract from the implementation. If this annotation is present, the service endpoint interface is used to determine the abstract WSDL contract (portType and bindings). The service endpoint interface MAY include JSR-181 annotations to customize the mapping from Java to WSDL.
The service implementation bean MAY implement the service endpoint interface, but is not REQUIRED to do so.
If this member-value is not present, the Web Service contract is generated from annotations on the service implementation bean. If a service endpoint interface is required by the target environment, it will be generated into an implementation-defined package with an implementation- defined name

This member-value is not allowed on endpoint interfaces.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


mail

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.mail

Classes modeling a mail system.

See:
Description

Interface Summary
MessageAware | An interface optionally implemented by DataSources to supply information to a DataContentHandler about the message context in which the data content object is operating.
MultipartDataSource | MultipartDataSource is a DataSource that contains body parts.
Part | The Part interface is the common base interface for Messages and BodyParts.
QuotaAwareStore | An interface implemented by Stores that support quotas.
UIDFolder | The UIDFolder interface is implemented by Folders that can support the "disconnected" mode of operation, by providing unique-ids for messages in the folder.

Class Summary
Address | This abstract class models the addresses in a message.
Authenticator | The class Authenticator represents an object that knows how to obtain authentication for a network connection.
BodyPart | This class models a Part that is contained within a Multipart.
FetchProfile | Clients use a FetchProfile to list the Message attributes that it wishes to prefetch from the server for a range of messages.
FetchProfile.Item | This inner class is the base class of all items that can be requested in a FetchProfile.
Flags | The Flags class represents the set of flags on a Message.
Flags.Flag | This inner class represents an individual system flag.
Folder | Folder is an abstract class that represents a folder for mail messages.
Header | The Header class stores a name/value pair to represent headers.
Message | This class models an email message.
Message.RecipientType | This inner class defines the types of recipients allowed by the Message class.
MessageContext | The context in which a piece of Message content is contained.
Multipart | Multipart is a container that holds multiple body parts.
PasswordAuthentication | The class PasswordAuthentication is a data holder that is used by Authenticator.
Provider | The Provider is a class that describes a protocol implementation.
Provider.Type | This inner class defines the Provider type.
Quota | This class represents a set of quotas for a given quota root.
Quota.Resource | An individual resource in a quota root.
Service | An abstract class that contains the functionality common to messaging services, such as stores and transports.
Session | The Session class represents a mail session and is not subclassed.
Store | An abstract class that models a message store and its access protocol, for storing and retrieving messages.
Transport | An abstract class that models a message transport.
UIDFolder.FetchProfileItem | A fetch profile item for fetching UIDs.
URLName | The name of a URL.

Exception Summary
AuthenticationFailedException | This exception is thrown when the connect method on a Store or Transport object fails due to an authentication failure (e.g., bad user name or password).
FolderClosedException | This exception is thrown when a method is invoked on a Messaging object and the Folder that owns that object has died due to some reason.
FolderNotFoundException | This exception is thrown by Folder methods, when those methods are invoked on a non existent folder.
IllegalWriteException | The exception thrown when a write is attempted on a read-only attribute of any Messaging object.
MessageRemovedException | The exception thrown when an invalid method is invoked on an expunged Message.
MessagingException | The base class for all exceptions thrown by the Messaging classes
MethodNotSupportedException | The exception thrown when a method is not supported by the implementation
NoSuchProviderException | This exception is thrown when Session attempts to instantiate a Provider that doesn't exist.
ReadOnlyFolderException | This exception is thrown when an attempt is made to open a folder read-write access when the folder is marked read-only.
SendFailedException | This exception is thrown when the message cannot be sent.
StoreClosedException | This exception is thrown when a method is invoked on a Messaging object and the Store that owns that object has died due to some reason.

Package javax.mail Description

Classes modeling a mail system. The javax.mail package defines classes that are common to all mail systems. The JavaMailTM API includes the javax.mail package and subpackages. The JavaMail API supports the following standard properties, which may be set in the Session object, or in the Properties object used to create the Session object. The properties are always set as strings; the Type column describes how the string is interpreted. For example, use

        props.put("mail.debug", "true");
to set the mail.debug property, which is of type boolean.

Name | Type | Description
mail.debug | boolean | The initial debug mode. Default is false.
mail.from | String | The return email address of the current user, used by the InternetAddress method getLocalAddress.
mail.mime.address.strict | boolean | The MimeMessage class uses the InternetAddress method parseHeader to parse headers in messages. This property controls the strict flag passed to the parseHeader method. The default is true.
mail.host | String | The default host name of the mail server for both Stores and Transports. Used if the mail.protocol.host property isn't set.
mail.store.protocol | String | Specifies the default message access protocol. The Session method getStore() returns a Store object that implements this protocol. By default the first Store provider in the configuration files is returned.
mail.transport.protocol | String | Specifies the default message access protocol. The Session method getTransport() returns a Transport object that implements this protocol. By default the first Transport provider in the configuration files is returned.
mail.user | String | The default user name to use when connecting to the mail server. Used if the mail.protocol.user property isn't set.
mail.protocol.class | String | Specifies the fully qualified class name of the provider for the specified protocol. Used in cases where more than one provider for a given protocol exists; this property can be used to specify which provider to use by default. The provider must still be listed in a configuration file.
mail.protocol.host | String | The host name of the mail server for the specified protocol. Overrides the mail.host property.
mail.protocol.port | int | The port number of the mail server for the specified protocol. If not specified the protocol's default port number is used.
mail.protocol.user | String | The user name to use when connecting to mail servers using the specified protocol. Overrides the mail.user property.

The JavaMail API also supports several System properties; see the javax.mail.internet package documentation for details.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.mail Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.mail

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.mail.Address (implements java.io.Serializable)
    • javax.mail.Authenticator
    • javax.mail.BodyPart (implements javax.mail.Part)
    • javax.mail.FetchProfile
    • javax.mail.FetchProfile.Item
      • javax.mail.UIDFolder.FetchProfileItem
    • javax.mail.Flags (implements java.lang.Cloneable, java.io.Serializable)
    • javax.mail.Flags.Flag
    • javax.mail.Folder
    • javax.mail.Header
    • javax.mail.Message (implements javax.mail.Part)
    • javax.mail.Message.RecipientType (implements java.io.Serializable)
    • javax.mail.MessageContext
    • javax.mail.Multipart
    • javax.mail.PasswordAuthentication
    • javax.mail.Provider
    • javax.mail.Provider.Type
    • javax.mail.Quota
    • javax.mail.Quota.Resource
    • javax.mail.Service
      • javax.mail.Store
      • javax.mail.Transport
    • javax.mail.Session
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.AuthenticationFailedException
          • javax.mail.FolderClosedException
          • javax.mail.FolderNotFoundException
          • javax.mail.IllegalWriteException
          • javax.mail.MessageRemovedException
          • javax.mail.MethodNotSupportedException
          • javax.mail.NoSuchProviderException
          • javax.mail.ReadOnlyFolderException
          • javax.mail.SendFailedException
          • javax.mail.StoreClosedException
    • javax.mail.URLName

Interface Hierarchy

  • javax.activation.DataSource
    • javax.mail.MultipartDataSource
  • javax.mail.MessageAware
  • javax.mail.Part
  • javax.mail.QuotaAwareStore
  • javax.mail.UIDFolder
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Address

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Address

java.lang.Object
    extended by  javax.mail.Address
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
InternetAddress, NewsAddress
public abstract class Address
extends Object
implements Serializable

This abstract class models the addresses in a message. Subclasses provide specific implementations. Subclasses will typically be serializable so that (for example) the use of Address objects in search terms can be serialized along with the search terms.

Author:
John Mani, Bill Shannon
See Also:
Serialized Form

Constructor Summary
Address()
Method Summary
abstract boolean | equals(Object address) The equality operator.
abstract String | getType() Return a type string that identifies this address type.
abstract String | toString() Return a String representation of this address object.
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Address

public Address()
Method Detail

getType

public abstract String getType()
Return a type string that identifies this address type.

Returns:
address type
See Also:
InternetAddress

toString

public abstract String toString()
Return a String representation of this address object.

Overrides:
toString in class Object
Returns:
string representation of this address

equals

public abstract boolean equals(Object address)
The equality operator. Subclasses should provide an implementation of this method that supports value equality (do the two Address objects represent the same destination?), not object reference equality. A subclass must also provide a corresponding implementation of the hashCode method that preserves the general contract of equals and hashCode - objects that compare as equal must have the same hashCode.

Overrides:
equals in class Object
Parameters:
address - Address object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AuthenticationFailedException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class AuthenticationFailedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
                extended by  javax.mail.AuthenticationFailedException
All Implemented Interfaces:
Serializable
public class AuthenticationFailedException
extends MessagingException

This exception is thrown when the connect method on a Store or Transport object fails due to an authentication failure (e.g., bad user name or password).

Author:
Bill Shannon
See Also:
Serialized Form

Constructor Summary
AuthenticationFailedException()
Constructor
AuthenticationFailedException(String message)
Constructor
Method Summary
Methods inherited from class javax.mail.MessagingException
getCause, getNextException, setNextException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AuthenticationFailedException

public AuthenticationFailedException()
Constructor

AuthenticationFailedException

public AuthenticationFailedException(String message)
Constructor

Parameters:
message - The detailed error message
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Authenticator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Authenticator

java.lang.Object
    extended by  javax.mail.Authenticator

public abstract class Authenticator
extends Object

The class Authenticator represents an object that knows how to obtain authentication for a network connection. Usually, it will do this by prompting the user for information.

Applications use this class by creating a subclass, and registering an instance of that subclass with the session when it is created. When authentication is required, the system will invoke a method on the subclass (like getPasswordAuthentication). The subclass's method can query about the authentication being requested with a number of inherited methods (getRequestingXXX()), and form an appropriate message for the user.

All methods that request authentication have a default implementation that fails.

Version:
1.8, 08/29/05
Author:
Bill Foote, Bill Shannon
See Also:
Authenticator, Session.getInstance(java.util.Properties, javax.mail.Authenticator), Session.getDefaultInstance(java.util.Properties, javax.mail.Authenticator), Session.requestPasswordAuthentication(java.net.InetAddress, int, java.lang.String, java.lang.String, java.lang.String), PasswordAuthentication

Constructor Summary
Authenticator()
Method Summary
protected String | getDefaultUserName()
protected PasswordAuthentication | getPasswordAuthentication() Called when password authentication is needed.
protected int | getRequestingPort()
protected String | getRequestingPrompt()
protected String | getRequestingProtocol() Give the protocol that's requesting the connection.
protected InetAddress | getRequestingSite()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Authenticator

public Authenticator()
Method Detail

getRequestingSite

protected final InetAddress getRequestingSite()
Returns:
the InetAddress of the site requesting authorization, or null if it's not available.

getRequestingPort

protected final int getRequestingPort()
Returns:
the port for the requested connection

getRequestingProtocol

protected final String getRequestingProtocol()
Give the protocol that's requesting the connection. Often this will be based on a URLName.

Returns:
the protcol
See Also:
URLName.getProtocol()

getRequestingPrompt

protected final String getRequestingPrompt()
Returns:
the prompt string given by the requestor

getDefaultUserName

protected final String getDefaultUserName()
Returns:
the default user name given by the requestor

getPasswordAuthentication

protected PasswordAuthentication getPasswordAuthentication()
Called when password authentication is needed. Subclasses should override the default implementation, which returns null.

Note that if this method uses a dialog to prompt the user for this information, the dialog needs to block until the user supplies the information. This method can not simply return after showing the dialog.

Returns:
The PasswordAuthentication collected from the user, or null if none is provided.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BodyPart

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class BodyPart

java.lang.Object
    extended by  javax.mail.BodyPart
All Implemented Interfaces:
Part
Direct Known Subclasses:
MimeBodyPart
public abstract class BodyPart
extends Object
implements Part

This class models a Part that is contained within a Multipart. This is an abstract class. Subclasses provide actual implementations.

BodyPart implements the Part interface. Thus, it contains a set of attributes and a "content".

Author:
John Mani, Bill Shannon

Field Summary
protected  Multipart parent
The Multipart object containing this BodyPart, if known.
Fields inherited from interface javax.mail.Part
ATTACHMENT, INLINE
Constructor Summary
BodyPart()
Method Summary
 Multipart getParent()
Return the containing Multipart object, or null if not known.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.mail.Part
addHeader, getAllHeaders, getContent, getContentType, getDataHandler, getDescription, getDisposition, getFileName, getHeader, getInputStream, getLineCount, getMatchingHeaders, getNonMatchingHeaders, getSize, isMimeType, removeHeader, setContent, setContent, setDataHandler, setDescription, setDisposition, setFileName, setHeader, setText, writeTo

Field Detail

parent

protected Multipart parent
The Multipart object containing this BodyPart, if known.

Since:
JavaMail 1.1
Constructor Detail

BodyPart

public BodyPart()
Method Detail

getParent

public Multipart getParent()
Return the containing Multipart object, or null if not known.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


event

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.mail.event

Listeners and events for the JavaMail API.

See:
Description

Interface Summary
ConnectionListener | This is the Listener interface for Connection events.
FolderListener | This is the Listener interface for Folder events.
MessageChangedListener | This is the Listener interface for MessageChanged events
MessageCountListener | This is the Listener interface for MessageCount events.
StoreListener | This is the Listener interface for Store Notifications.
TransportListener | This is the Listener interface for Transport events

Class Summary
ConnectionAdapter | The adapter which receives connection events.
ConnectionEvent | This class models Connection events.
FolderAdapter | The adapter which receives Folder events.
FolderEvent | This class models Folder existence events.
MailEvent | Common base class for mail events, defining the dispatch method.
MessageChangedEvent | This class models Message change events.
MessageCountAdapter | The adapter which receives MessageCount events.
MessageCountEvent | This class notifies changes in the number of messages in a folder.
StoreEvent | This class models notifications from the Store connection.
TransportAdapter | The adapter which receives Transport events.
TransportEvent | This class models Transport events.

Package javax.mail.event Description

Listeners and events for the JavaMail API. This package defines listener classes and event classes used by the classes defined in the javax.mail package.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.mail.event Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.mail.event

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.mail.event.ConnectionAdapter (implements javax.mail.event.ConnectionListener)
    • java.util.EventObject (implements java.io.Serializable)
      • javax.mail.event.MailEvent
        • javax.mail.event.ConnectionEvent
        • javax.mail.event.FolderEvent
        • javax.mail.event.MessageChangedEvent
        • javax.mail.event.MessageCountEvent
        • javax.mail.event.StoreEvent
        • javax.mail.event.TransportEvent
    • javax.mail.event.FolderAdapter (implements javax.mail.event.FolderListener)
    • javax.mail.event.MessageCountAdapter (implements javax.mail.event.MessageCountListener)
    • javax.mail.event.TransportAdapter (implements javax.mail.event.TransportListener)

Interface Hierarchy

  • java.util.EventListener
    • javax.mail.event.ConnectionListener
    • javax.mail.event.FolderListener
    • javax.mail.event.MessageChangedListener
    • javax.mail.event.MessageCountListener
    • javax.mail.event.StoreListener
    • javax.mail.event.TransportListener
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionAdapter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class ConnectionAdapter

java.lang.Object
    extended by  javax.mail.event.ConnectionAdapter
All Implemented Interfaces:
EventListener, ConnectionListener
public abstract class ConnectionAdapter
extends Object
implements ConnectionListener

The adapter which receives connection events. The methods in this class are empty; this class is provided as a convenience for easily creating listeners by extending this class and overriding only the methods of interest.

Author:
John Mani

Constructor Summary
ConnectionAdapter()
Method Summary
void | closed(ConnectionEvent e) Invoked when a Store/Folder/Transport is closed.
void | disconnected(ConnectionEvent e) Invoked when a Store is disconnected.
void | opened(ConnectionEvent e) Invoked when a Store/Folder/Transport is opened.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConnectionAdapter

public ConnectionAdapter()
Method Detail

opened

public void opened(ConnectionEvent e)
Description copied from interface: ConnectionListener
Invoked when a Store/Folder/Transport is opened.

Specified by:
opened in interface ConnectionListener

disconnected

public void disconnected(ConnectionEvent e)
Description copied from interface: ConnectionListener
Invoked when a Store is disconnected. Note that a folder cannot be disconnected, so a folder will not fire this event

Specified by:
disconnected in interface ConnectionListener

closed

public void closed(ConnectionEvent e)
Description copied from interface: ConnectionListener
Invoked when a Store/Folder/Transport is closed.

Specified by:
closed in interface ConnectionListener
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class ConnectionEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.mail.event.MailEvent
            extended by  javax.mail.event.ConnectionEvent
All Implemented Interfaces:
Serializable
public class ConnectionEvent
extends MailEvent

This class models Connection events.

Author:
John Mani
See Also:
Serialized Form

Field Summary
static int | CLOSED A connection was closed.
static int | DISCONNECTED A connection was disconnected (not currently used).
static int | OPENED A connection was opened.
protected int | type The event type.
Fields inherited from class java.util.EventObject
source
Constructor Summary
ConnectionEvent(Object source, int type)
Constructor
Method Summary
void | dispatch(Object listener) Invokes the appropriate ConnectionListener method
int | getType() Return the type of this event
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

OPENED

public static final int OPENED
A connection was opened.

See Also:
Constant Field Values

DISCONNECTED

public static final int DISCONNECTED
A connection was disconnected (not currently used).

See Also:
Constant Field Values

CLOSED

public static final int CLOSED
A connection was closed.

See Also:
Constant Field Values

type

protected int type
The event type.

Constructor Detail

ConnectionEvent

public ConnectionEvent(Object source,
                       int type)
Constructor

Parameters:
source - The source object
Method Detail

getType

public int getType()
Return the type of this event

Returns:
type

dispatch

public void dispatch(Object listener)
Invokes the appropriate ConnectionListener method

Specified by:
dispatch in class MailEvent
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Interface ConnectionListener

All Superinterfaces:
EventListener
All Known Implementing Classes:
ConnectionAdapter
public interface ConnectionListener
extends EventListener

This is the Listener interface for Connection events.

Author:
John Mani

Method Summary
void | closed(ConnectionEvent e) Invoked when a Store/Folder/Transport is closed.
void | disconnected(ConnectionEvent e) Invoked when a Store is disconnected.
void | opened(ConnectionEvent e) Invoked when a Store/Folder/Transport is opened.

Method Detail

opened

void opened(ConnectionEvent e)
Invoked when a Store/Folder/Transport is opened.

disconnected

void disconnected(ConnectionEvent e)
Invoked when a Store is disconnected. Note that a folder cannot be disconnected, so a folder will not fire this event

closed

void closed(ConnectionEvent e)
Invoked when a Store/Folder/Transport is closed.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FolderAdapter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class FolderAdapter

java.lang.Object
    extended by  javax.mail.event.FolderAdapter
All Implemented Interfaces:
EventListener, FolderListener
public abstract class FolderAdapter
extends Object
implements FolderListener

The adapter which receives Folder events. The methods in this class are empty; this class is provided as a convenience for easily creating listeners by extending this class and overriding only the methods of interest.

Author:
John Mani

Constructor Summary
FolderAdapter()
Method Summary
void | folderCreated(FolderEvent e) Invoked when a Folder is created.
void | folderDeleted(FolderEvent e) Invoked when a folder is deleted.
void | folderRenamed(FolderEvent e) Invoked when a folder is renamed.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FolderAdapter

public FolderAdapter()
Method Detail

folderCreated

public void folderCreated(FolderEvent e)
Description copied from interface: FolderListener
Invoked when a Folder is created.

Specified by:
folderCreated in interface FolderListener

folderRenamed

public void folderRenamed(FolderEvent e)
Description copied from interface: FolderListener
Invoked when a folder is renamed.

Specified by:
folderRenamed in interface FolderListener

folderDeleted

public void folderDeleted(FolderEvent e)
Description copied from interface: FolderListener
Invoked when a folder is deleted.

Specified by:
folderDeleted in interface FolderListener
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FolderEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class FolderEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.mail.event.MailEvent
            extended by  javax.mail.event.FolderEvent
All Implemented Interfaces:
Serializable
public class FolderEvent
extends MailEvent

This class models Folder existence events. FolderEvents are delivered to FolderListeners registered on the affected Folder as well as the containing Store.

Service providers vary widely in their ability to notify clients of these events. At a minimum, service providers must notify listeners registered on the same Store or Folder object on which the operation occurs. Service providers may also notify listeners when changes are made through operations on other objects in the same virtual machine, or by other clients in the same or other hosts. Such notifications are not required and are typically not supported by mail protocols (including IMAP).

Author:
John Mani, Bill Shannon
See Also:
Serialized Form

Field Summary
static int | CREATED The folder was created.
static int | DELETED The folder was deleted.
protected Folder | folder The folder the event occurred on.
protected Folder | newFolder The folder that represents the new name, in case of a RENAMED event.
static int | RENAMED The folder was renamed.
protected int | type The event type.
Fields inherited from class java.util.EventObject
source
Constructor Summary
FolderEvent(Object source, Folder oldFolder, Folder newFolder, int type)
Constructor.
FolderEvent(Object source, Folder folder, int type)
Constructor.
Method Summary
void | dispatch(Object listener) Invokes the appropriate FolderListener method
Folder | getFolder() Return the affected folder.
Folder | getNewFolder() If this event indicates that a folder is renamed, (i.e, the event type is RENAMED), then this method returns the Folder object representing the new name.
int | getType() Return the type of this event.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

CREATED

public static final int CREATED
The folder was created.

See Also:
Constant Field Values

DELETED

public static final int DELETED
The folder was deleted.

See Also:
Constant Field Values

RENAMED

public static final int RENAMED
The folder was renamed.

See Also:
Constant Field Values

type

protected int type
The event type.

folder

protected transient Folder folder
The folder the event occurred on.

newFolder

protected transient Folder newFolder
The folder that represents the new name, in case of a RENAMED event.

Since:
JavaMail 1.1
Constructor Detail

FolderEvent

public FolderEvent(Object source,
                   Folder folder,
                   int type)
Constructor.

Parameters:
source - The source of the event
folder - The affected folder
type - The event type

FolderEvent

public FolderEvent(Object source,
                   Folder oldFolder,
                   Folder newFolder,
                   int type)
Constructor. Use for RENAMED events.

Parameters:
source - The source of the event
oldFolder - The folder that is renamed
newFolder - The folder that represents the new name
type - The event type
Since:
JavaMail 1.1
Method Detail

getType

public int getType()
Return the type of this event.

Returns:
type

getFolder

public Folder getFolder()
Return the affected folder.

Returns:
the affected folder
See Also:
getNewFolder()

getNewFolder

public Folder getNewFolder()
If this event indicates that a folder is renamed, (i.e, the event type is RENAMED), then this method returns the Folder object representing the new name.

The getFolder() method returns the folder that is renamed.

Returns:
Folder representing the new name.
Since:
JavaMail 1.1
See Also:
getFolder()

dispatch

public void dispatch(Object listener)
Invokes the appropriate FolderListener method

Specified by:
dispatch in class MailEvent
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FolderListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Interface FolderListener

All Superinterfaces:
EventListener
All Known Implementing Classes:
FolderAdapter
public interface FolderListener
extends EventListener

This is the Listener interface for Folder events.

Author:
John Mani

Method Summary
void | folderCreated(FolderEvent e) Invoked when a Folder is created.
void | folderDeleted(FolderEvent e) Invoked when a folder is deleted.
void | folderRenamed(FolderEvent e) Invoked when a folder is renamed.

Method Detail

folderCreated

void folderCreated(FolderEvent e)
Invoked when a Folder is created.

folderDeleted

void folderDeleted(FolderEvent e)
Invoked when a folder is deleted.

folderRenamed

void folderRenamed(FolderEvent e)
Invoked when a folder is renamed.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MailEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class MailEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.mail.event.MailEvent
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ConnectionEvent, FolderEvent, MessageChangedEvent, MessageCountEvent, StoreEvent, TransportEvent
public abstract class MailEvent
extends EventObject

Common base class for mail events, defining the dispatch method.

Author:
Bill Shannon
See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
MailEvent(Object source)
Method Summary
abstract  void dispatch(Object listener)
This method invokes the appropriate method on a listener for this event.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MailEvent

public MailEvent(Object source)
Method Detail

dispatch

public abstract void dispatch(Object listener)
This method invokes the appropriate method on a listener for this event. Subclasses provide the implementation.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageChangedEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class MessageChangedEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.mail.event.MailEvent
            extended by  javax.mail.event.MessageChangedEvent
All Implemented Interfaces:
Serializable
public class MessageChangedEvent
extends MailEvent

This class models Message change events.

Author:
John Mani
See Also:
Serialized Form

Field Summary
static int | ENVELOPE_CHANGED The message's envelope (headers, but not body) changed.
static int | FLAGS_CHANGED The message's flags changed.
protected Message | msg The message that changed.
protected int | type The event type.
Fields inherited from class java.util.EventObject
source
Constructor Summary
MessageChangedEvent(Object source, int type, Message msg)
Constructor.
Method Summary
void | dispatch(Object listener) Invokes the appropriate MessageChangedListener method.
Message | getMessage() Return the changed Message.
int | getMessageChangeType() Return the type of this event.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

FLAGS_CHANGED

public static final int FLAGS_CHANGED
The message's flags changed.

See Also:
Constant Field Values

ENVELOPE_CHANGED

public static final int ENVELOPE_CHANGED
The message's envelope (headers, but not body) changed.

See Also:
Constant Field Values

type

protected int type
The event type.

msg

protected transient Message msg
The message that changed.

Constructor Detail

MessageChangedEvent

public MessageChangedEvent(Object source,
                           int type,
                           Message msg)
Constructor.

Parameters:
source - The folder that owns the message
type - The change type
msg - The changed message
Method Detail

getMessageChangeType

public int getMessageChangeType()
Return the type of this event.

Returns:
type

getMessage

public Message getMessage()
Return the changed Message.

Returns:
the message

dispatch

public void dispatch(Object listener)
Invokes the appropriate MessageChangedListener method.

Specified by:
dispatch in class MailEvent
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageChangedListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Interface MessageChangedListener

All Superinterfaces:
EventListener
public interface MessageChangedListener
extends EventListener

This is the Listener interface for MessageChanged events

Author:
John Mani

Method Summary
 void messageChanged(MessageChangedEvent e)
Invoked when a message is changed.

Method Detail

messageChanged

void messageChanged(MessageChangedEvent e)
Invoked when a message is changed. The change-type specifies what changed.

See Also:
MessageChangedEvent.FLAGS_CHANGED, MessageChangedEvent.ENVELOPE_CHANGED
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageCountAdapter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class MessageCountAdapter

java.lang.Object
    extended by  javax.mail.event.MessageCountAdapter
All Implemented Interfaces:
EventListener, MessageCountListener
public abstract class MessageCountAdapter
extends Object
implements MessageCountListener

The adapter which receives MessageCount events. The methods in this class are empty; this class is provided as a convenience for easily creating listeners by extending this class and overriding only the methods of interest.

Author:
John Mani

Constructor Summary
MessageCountAdapter()
Method Summary
void | messagesAdded(MessageCountEvent e) Invoked when messages are added into a folder.
void | messagesRemoved(MessageCountEvent e) Invoked when messages are removed (expunged) from a folder.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MessageCountAdapter

public MessageCountAdapter()
Method Detail

messagesAdded

public void messagesAdded(MessageCountEvent e)
Description copied from interface: MessageCountListener
Invoked when messages are added into a folder.

Specified by:
messagesAdded in interface MessageCountListener

messagesRemoved

public void messagesRemoved(MessageCountEvent e)
Description copied from interface: MessageCountListener
Invoked when messages are removed (expunged) from a folder.

Specified by:
messagesRemoved in interface MessageCountListener
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageCountEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class MessageCountEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.mail.event.MailEvent
            extended by  javax.mail.event.MessageCountEvent
All Implemented Interfaces:
Serializable
public class MessageCountEvent
extends MailEvent

This class notifies changes in the number of messages in a folder.

Note that some folder types may only deliver MessageCountEvents at certain times or after certain operations. IMAP in particular will only notify the client of MessageCountEvents when a client issues a new command. Refer to RFC 2060 http://www.ietf.org/rfc/rfc2060.txt for details. A client may want "poll" the folder by occasionally calling the getMessageCount or isConnected methods to solicit any such notifications.

Author:
John Mani
See Also:
Serialized Form

Field Summary
static int | ADDED The messages were added to their folder
protected Message[] | msgs The messages.
protected boolean | removed If true, this event is the result of an explicit expunge by this client, and the messages in this folder have been renumbered to account for this.
static int | REMOVED The messages were removed from their folder
protected int | type The event type.
Fields inherited from class java.util.EventObject
source
Constructor Summary
MessageCountEvent(Folder folder, int type, boolean removed, Message[] msgs)
Constructor.
Method Summary
void | dispatch(Object listener) Invokes the appropriate MessageCountListener method.
Message[] | getMessages() Return the array of messages added or removed.
int | getType() Return the type of this event.
boolean | isRemoved() Indicates whether this event is the result of an explicit expunge by this client, or due to an expunge from external sources.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ADDED

public static final int ADDED
The messages were added to their folder

See Also:
Constant Field Values

REMOVED

public static final int REMOVED
The messages were removed from their folder

See Also:
Constant Field Values

type

protected int type
The event type.

removed

protected boolean removed
If true, this event is the result of an explicit expunge by this client, and the messages in this folder have been renumbered to account for this. If false, this event is the result of an expunge by external sources.

msgs

protected transient Message[] msgs
The messages.

Constructor Detail

MessageCountEvent

public MessageCountEvent(Folder folder,
                         int type,
                         boolean removed,
                         Message[] msgs)
Constructor.

Parameters:
folder - The containing folder
type - The event type
removed - If true, this event is the result of an explicit expunge by this client, and the messages in this folder have been renumbered to account for this. If false, this event is the result of an expunge by external sources.
msgs - The messages added/removed
Method Detail

getType

public int getType()
Return the type of this event.

Returns:
type

isRemoved

public boolean isRemoved()
Indicates whether this event is the result of an explicit expunge by this client, or due to an expunge from external sources. If true, this event is due to an explicit expunge and hence all remaining messages in this folder have been renumbered. If false, this event is due to an external expunge.

Note that this method is valid only if the type of this event is REMOVED

getMessages

public Message[] getMessages()
Return the array of messages added or removed.

Returns:
array of messages

dispatch

public void dispatch(Object listener)
Invokes the appropriate MessageCountListener method.

Specified by:
dispatch in class MailEvent
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageCountListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Interface MessageCountListener

All Superinterfaces:
EventListener
All Known Implementing Classes:
MessageCountAdapter
public interface MessageCountListener
extends EventListener

This is the Listener interface for MessageCount events.

Author:
John Mani

Method Summary
void | messagesAdded(MessageCountEvent e) Invoked when messages are added into a folder.
void | messagesRemoved(MessageCountEvent e) Invoked when messages are removed (expunged) from a folder.

Method Detail

messagesAdded

void messagesAdded(MessageCountEvent e)
Invoked when messages are added into a folder.

messagesRemoved

void messagesRemoved(MessageCountEvent e)
Invoked when messages are removed (expunged) from a folder.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StoreEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class StoreEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.mail.event.MailEvent
            extended by  javax.mail.event.StoreEvent
All Implemented Interfaces:
Serializable
public class StoreEvent
extends MailEvent

This class models notifications from the Store connection. These notifications can be ALERTS or NOTICES. ALERTS must be presented to the user in a fashion that calls the user's attention to the message.

Author:
John Mani
See Also:
Serialized Form

Field Summary
static int | ALERT Indicates that this message is an ALERT.
protected String | message The message text to be presented to the user.
static int | NOTICE Indicates that this message is a NOTICE.
protected int | type The event type.
Fields inherited from class java.util.EventObject
source
Constructor Summary
StoreEvent(Store store, int type, String message)
Constructor.
Method Summary
void | dispatch(Object listener) Invokes the appropriate StoreListener method.
String | getMessage() Get the message from the Store.
int | getMessageType() Return the type of this event.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ALERT

public static final int ALERT
Indicates that this message is an ALERT.

See Also:
Constant Field Values

NOTICE

public static final int NOTICE
Indicates that this message is a NOTICE.

See Also:
Constant Field Values

type

protected int type
The event type.

message

protected String message
The message text to be presented to the user.

Constructor Detail

StoreEvent

public StoreEvent(Store store,
                  int type,
                  String message)
Constructor.

Parameters:
store - The source Store
Method Detail

getMessageType

public int getMessageType()
Return the type of this event.

Returns:
type
See Also:
ALERT, NOTICE

getMessage

public String getMessage()
Get the message from the Store.

Returns:
message from the Store

dispatch

public void dispatch(Object listener)
Invokes the appropriate StoreListener method.

Specified by:
dispatch in class MailEvent
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StoreListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Interface StoreListener

All Superinterfaces:
EventListener
public interface StoreListener
extends EventListener

This is the Listener interface for Store Notifications.

Author:
John Mani

Method Summary
 void notification(StoreEvent e)
Invoked when the Store generates a notification event.

Method Detail

notification

void notification(StoreEvent e)
Invoked when the Store generates a notification event.

See Also:
StoreEvent.ALERT, StoreEvent.NOTICE
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransportAdapter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class TransportAdapter

java.lang.Object
    extended by  javax.mail.event.TransportAdapter
All Implemented Interfaces:
EventListener, TransportListener
public abstract class TransportAdapter
extends Object
implements TransportListener

The adapter which receives Transport events. The methods in this class are empty; this class is provided as a convenience for easily creating listeners by extending this class and overriding only the methods of interest.

Author:
John Mani

Constructor Summary
TransportAdapter()
Method Summary
void | messageDelivered(TransportEvent e) Invoked when a Message is succesfully delivered.
void | messageNotDelivered(TransportEvent e) Invoked when a Message is not delivered.
void | messagePartiallyDelivered(TransportEvent e) Invoked when a Message is partially delivered.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TransportAdapter

public TransportAdapter()
Method Detail

messageDelivered

public void messageDelivered(TransportEvent e)
Description copied from interface: TransportListener
Invoked when a Message is succesfully delivered.

Specified by:
messageDelivered in interface TransportListener
Parameters:
e - TransportEvent

messageNotDelivered

public void messageNotDelivered(TransportEvent e)
Description copied from interface: TransportListener
Invoked when a Message is not delivered.

Specified by:
messageNotDelivered in interface TransportListener
Parameters:
e - TransportEvent
See Also:
TransportEvent

messagePartiallyDelivered

public void messagePartiallyDelivered(TransportEvent e)
Description copied from interface: TransportListener
Invoked when a Message is partially delivered.

Specified by:
messagePartiallyDelivered in interface TransportListener
Parameters:
e - TransportEvent
See Also:
TransportEvent
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransportEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Class TransportEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.mail.event.MailEvent
            extended by  javax.mail.event.TransportEvent
All Implemented Interfaces:
Serializable
public class TransportEvent
extends MailEvent

This class models Transport events.

Author:
John Mani, Max Spivak
See Also:
Transport, TransportListener, Serialized Form

Field Summary
protected Address[] | invalid
static int | MESSAGE_DELIVERED Message has been successfully delivered to all recipients by the transport firing this event. validSent[] contains all the addresses this transport sent to successfully. validUnsent[] and invalid[] should be null,
static int | MESSAGE_NOT_DELIVERED Message was not sent for some reason. validSent[] should be null.
static int | MESSAGE_PARTIALLY_DELIVERED Message was successfully sent to some recipients but not to all.
protected Message | msg
protected int | type The event type.
protected Address[] | validSent
protected Address[] | validUnsent
Fields inherited from class java.util.EventObject
source
Constructor Summary
TransportEvent(Transport transport, int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg)
Constructor.
Method Summary
void | dispatch(Object listener) Invokes the appropriate TransportListener method.
Address[] | getInvalidAddresses() Return the addresses to which this message could not be sent.
Message | getMessage() Get the Message object associated with this Transport Event.
int | getType() Return the type of this event.
Address[] | getValidSentAddresses() Return the addresses to which this message was sent succesfully.
Address[] | getValidUnsentAddresses() Return the addresses that are valid but to which this message was not sent.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

MESSAGE_DELIVERED

public static final int MESSAGE_DELIVERED
Message has been successfully delivered to all recipients by the transport firing this event. validSent[] contains all the addresses this transport sent to successfully. validUnsent[] and invalid[] should be null,

See Also:
Constant Field Values

MESSAGE_NOT_DELIVERED

public static final int MESSAGE_NOT_DELIVERED
Message was not sent for some reason. validSent[] should be null. validUnsent[] may have addresses that are valid (but the message wasn't sent to them). invalid[] should likely contain invalid addresses.

See Also:
Constant Field Values

MESSAGE_PARTIALLY_DELIVERED

public static final int MESSAGE_PARTIALLY_DELIVERED
Message was successfully sent to some recipients but not to all. validSent[] holds addresses of recipients to whom the message was sent. validUnsent[] holds valid addresses to which the message was not sent. invalid[] holds invalid addresses, if any.

See Also:
Constant Field Values

type

protected int type
The event type.

validSent

protected transient Address[] validSent

validUnsent

protected transient Address[] validUnsent

invalid

protected transient Address[] invalid

msg

protected transient Message msg
Constructor Detail

TransportEvent

public TransportEvent(Transport transport,
                      int type,
                      Address[] validSent,
                      Address[] validUnsent,
                      Address[] invalid,
                      Message msg)
Constructor.

Parameters:
transport - The Transport object
Method Detail

getType

public int getType()
Return the type of this event.

Returns:
type

getValidSentAddresses

public Address[] getValidSentAddresses()
Return the addresses to which this message was sent succesfully.

Returns:
Addresses to which the message was sent successfully or null

getValidUnsentAddresses

public Address[] getValidUnsentAddresses()
Return the addresses that are valid but to which this message was not sent.

Returns:
Addresses that are valid but to which the message was not sent successfully or null

getInvalidAddresses

public Address[] getInvalidAddresses()
Return the addresses to which this message could not be sent.

Returns:
Addresses to which the message sending failed or null

getMessage

public Message getMessage()
Get the Message object associated with this Transport Event.

Returns:
the Message object
Since:
JavaMail 1.2

dispatch

public void dispatch(Object listener)
Invokes the appropriate TransportListener method.

Specified by:
dispatch in class MailEvent
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransportListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.event
Interface TransportListener

All Superinterfaces:
EventListener
All Known Implementing Classes:
TransportAdapter
public interface TransportListener
extends EventListener

This is the Listener interface for Transport events

Author:
John Mani, Max Spivak
See Also:
Transport, TransportEvent

Method Summary
void | messageDelivered(TransportEvent e) Invoked when a Message is succesfully delivered.
void | messageNotDelivered(TransportEvent e) Invoked when a Message is not delivered.
void | messagePartiallyDelivered(TransportEvent e) Invoked when a Message is partially delivered.

Method Detail

messageDelivered

void messageDelivered(TransportEvent e)
Invoked when a Message is succesfully delivered.

Parameters:
e - TransportEvent

messageNotDelivered

void messageNotDelivered(TransportEvent e)
Invoked when a Message is not delivered.

Parameters:
e - TransportEvent
See Also:
TransportEvent

messagePartiallyDelivered

void messagePartiallyDelivered(TransportEvent e)
Invoked when a Message is partially delivered.

Parameters:
e - TransportEvent
See Also:
TransportEvent
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FetchProfile

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class FetchProfile

java.lang.Object
    extended by  javax.mail.FetchProfile

public class FetchProfile
extends Object

Clients use a FetchProfile to list the Message attributes that it wishes to prefetch from the server for a range of messages.

Messages obtained from a Folder are light-weight objects that typically start off as empty references to the actual messages. Such a Message object is filled in "on-demand" when the appropriate get*() methods are invoked on that particular Message. Certain server-based message access protocols (Ex: IMAP) allow batch fetching of message attributes for a range of messages in a single request. Clients that want to use message attributes for a range of Messages (Example: to display the top-level headers in a headerlist) might want to use the optimization provided by such servers. The FetchProfile allows the client to indicate this desire to the server.

Note that implementations are not obligated to support FetchProfiles, since there might be cases where the backend service does not allow easy, efficient fetching of such profiles.

Sample code that illustrates the use of a FetchProfile is given below:

  Message[] msgs = folder.getMessages();

  FetchProfile fp = new FetchProfile();
  fp.add(FetchProfile.Item.ENVELOPE);
  fp.add("X-mailer");
  folder.fetch(msgs, fp);

Author:
John Mani, Bill Shannon
See Also:
Folder.fetch(javax.mail.Message[], javax.mail.FetchProfile)

Nested Class Summary
static class FetchProfile.Item
This inner class is the base class of all items that can be requested in a FetchProfile.
Constructor Summary
FetchProfile()
Create an empty FetchProfile.
Method Summary
void | add(FetchProfile.Item item) Add the given special item as one of the attributes to be prefetched.
void | add(String headerName) Add the specified header-field to the list of attributes to be prefetched.
boolean | contains(FetchProfile.Item item) Returns true if the fetch profile contains given special item.
boolean | contains(String headerName) Returns true if the fetch profile contains given header name.
String[] | getHeaderNames() Get the names of the header-fields set in this profile.
FetchProfile.Item[] | getItems() Get the items set in this profile.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FetchProfile

public FetchProfile()
Create an empty FetchProfile.

Method Detail

add

public void add(FetchProfile.Item item)
Add the given special item as one of the attributes to be prefetched.

Parameters:
item - the special item to be fetched
See Also:
FetchProfile.Item.ENVELOPE, FetchProfile.Item.CONTENT_INFO, FetchProfile.Item.FLAGS

add

public void add(String headerName)
Add the specified header-field to the list of attributes to be prefetched.

Parameters:
headerName - header to be prefetched

contains

public boolean contains(FetchProfile.Item item)
Returns true if the fetch profile contains given special item.

contains

public boolean contains(String headerName)
Returns true if the fetch profile contains given header name.

getItems

public FetchProfile.Item[] getItems()
Get the items set in this profile.

Returns:
items set in this profile

getHeaderNames

public String[] getHeaderNames()
Get the names of the header-fields set in this profile.

Returns:
headers set in this profile
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FetchProfile.Item

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class FetchProfile.Item

java.lang.Object
    extended by  javax.mail.FetchProfile.Item
Direct Known Subclasses:
UIDFolder.FetchProfileItem
Enclosing class:
FetchProfile
public static class FetchProfile.Item
extends Object

This inner class is the base class of all items that can be requested in a FetchProfile. The items currently defined here are ENVELOPE, CONTENT_INFO and FLAGS. The UIDFolder interface defines the UID Item as well.

Note that this class only has a protected constructor, therby restricting new Item types to either this class or subclasses. This effectively implements a enumeration of allowed Item types.

See Also:
UIDFolder

Field Summary
static FetchProfile.Item | CONTENT_INFO This item is for fetching information about the content of the message.
static FetchProfile.Item | ENVELOPE This is the Envelope item.
static FetchProfile.Item | FLAGS This is the Flags item.
Constructor Summary
protected FetchProfile.Item(String name)
Constructor for an item.
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ENVELOPE

public static final FetchProfile.Item ENVELOPE
This is the Envelope item.

The Envelope is an aggregration of the common attributes of a Message. Implementations should include the following attributes: From, To, Cc, Bcc, ReplyTo, Subject and Date. More items may be included as well.

For implementations of the IMAP4 protocol (RFC 2060), the Envelope should include the ENVELOPE data item. More items may be included too.

CONTENT_INFO

public static final FetchProfile.Item CONTENT_INFO
This item is for fetching information about the content of the message.

This includes all the attributes that describe the content of the message. Implementations should include the following attributes: ContentType, ContentDisposition, ContentDescription, Size and LineCount. Other items may be included as well.

FLAGS

public static final FetchProfile.Item FLAGS
This is the Flags item.

Constructor Detail

FetchProfile.Item

protected FetchProfile.Item(String name)
Constructor for an item. The name is used only for debugging.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Flags

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Flags

java.lang.Object
    extended by  javax.mail.Flags
All Implemented Interfaces:
Serializable, Cloneable
public class Flags
extends Object
implements Cloneable, Serializable

The Flags class represents the set of flags on a Message. Flags are composed of predefined system flags, and user defined flags.

A System flag is represented by the Flags.Flag inner class. A User defined flag is represented as a String. User flags are case-independent.

A set of standard system flags are predefined. Most folder implementations are expected to support these flags. Some implementations may also support arbitrary user-defined flags. The getPermanentFlags method on a Folder returns a Flags object that holds all the flags that are supported by that folder implementation.

A Flags object is serializable so that (for example) the use of Flags objects in search terms can be serialized along with the search terms.

Warning: Serialized objects of this class may not be compatible with future JavaMail API releases. The current serialization support is appropriate for short term storage.

The below code sample illustrates how to set, examine and get the flags for a message.

 Message m = folder.getMessage(1);
 m.setFlag(Flags.Flag.DELETED, true); // set the DELETED flag

 // Check if DELETED flag is set of this message
 if (m.isSet(Flags.Flag.DELETED))
        System.out.println("DELETED message");

 // Examine ALL system flags for this message
 Flags flags = m.getFlags();
 Flags.Flag[] sf = flags.getSystemFlags();
 for (int i = 0; i < sf.length; i++) {
        if (sf[i] == Flags.Flag.DELETED)
            System.out.println("DELETED message");
        else if (sf[i] == Flags.Flag.SEEN)
            System.out.println("SEEN message");
      ......
      ......
 }

Author:
John Mani, Bill Shannon
See Also:
Folder.getPermanentFlags(), Serialized Form

Nested Class Summary
static class Flags.Flag
This inner class represents an individual system flag.
Constructor Summary
Flags()
Construct an empty Flags object.
Flags(Flags.Flag flag)
Construct a Flags object initialized with the given system flag.
Flags(Flags flags)
Construct a Flags object initialized with the given flags.
Flags(String flag)
Construct a Flags object initialized with the given user flag.
Method Summary
void | add(Flags.Flag flag) Add the specified system flag to this Flags object.
void | add(Flags f) Add all the flags in the given Flags object to this Flags object.
void | add(String flag) Add the specified user flag to this Flags object.
Object | clone() Returns a clone of this Flags object.
boolean | contains(Flags.Flag flag) Check whether the specified system flag is present in this Flags object.
boolean | contains(Flags f) Check whether all the flags in the specified Flags object are present in this Flags object.
boolean | contains(String flag) Check whether the specified user flag is present in this Flags object.
boolean | equals(Object obj) Check whether the two Flags objects are equal.
Flags.Flag[] | getSystemFlags() Return all the system flags in this Flags object.
String[] | getUserFlags() Return all the user flags in this Flags object.
int | hashCode() Compute a hash code for this Flags object.
void | remove(Flags.Flag flag) Remove the specified system flag from this Flags object.
void | remove(Flags f) Remove all flags in the given Flags object from this Flags object.
void | remove(String flag) Remove the specified user flag from this Flags object.
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Flags

public Flags()
Construct an empty Flags object.

Flags

public Flags(Flags flags)
Construct a Flags object initialized with the given flags.

Parameters:
flags - the flags for initialization

Flags

public Flags(Flags.Flag flag)
Construct a Flags object initialized with the given system flag.

Parameters:
flag - the flag for initialization

Flags

public Flags(String flag)
Construct a Flags object initialized with the given user flag.

Parameters:
flag - the flag for initialization
Method Detail

add

public void add(Flags.Flag flag)
Add the specified system flag to this Flags object.

Parameters:
flag - the flag to add

add

public void add(String flag)
Add the specified user flag to this Flags object.

Parameters:
flag - the flag to add

add

public void add(Flags f)
Add all the flags in the given Flags object to this Flags object.

Parameters:
f - Flags object

remove

public void remove(Flags.Flag flag)
Remove the specified system flag from this Flags object.

Parameters:
flag - the flag to be removed

remove

public void remove(String flag)
Remove the specified user flag from this Flags object.

Parameters:
flag - the flag to be removed

remove

public void remove(Flags f)
Remove all flags in the given Flags object from this Flags object.

Parameters:
f - the flag to be removed

contains

public boolean contains(Flags.Flag flag)
Check whether the specified system flag is present in this Flags object.

Returns:
true of the given flag is present, otherwise false.

contains

public boolean contains(String flag)
Check whether the specified user flag is present in this Flags object.

Returns:
true of the given flag is present, otherwise false.

contains

public boolean contains(Flags f)
Check whether all the flags in the specified Flags object are present in this Flags object.

Returns:
true if all flags in the given Flags object are present, otherwise false.

equals

public boolean equals(Object obj)
Check whether the two Flags objects are equal.

Overrides:
equals in class Object
Returns:
true if they're equal

hashCode

public int hashCode()
Compute a hash code for this Flags object.

Overrides:
hashCode in class Object
Returns:
the hash code

getSystemFlags

public Flags.Flag[] getSystemFlags()
Return all the system flags in this Flags object. Returns an array of size zero if no flags are set.

Returns:
array of Flags.Flag objects representing system flags

getUserFlags

public String[] getUserFlags()
Return all the user flags in this Flags object. Returns an array of size zero if no flags are set.

Returns:
array of Strings, each String represents a flag.

clone

public Object clone()
Returns a clone of this Flags object.

Overrides:
clone in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Flags.Flag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Flags.Flag

java.lang.Object
    extended by  javax.mail.Flags.Flag
Enclosing class:
Flags
public static final class Flags.Flag
extends Object

This inner class represents an individual system flag. A set of standard system flag objects are predefined here.

Field Summary
static Flags.Flag | ANSWERED This message has been answered.
static Flags.Flag | DELETED This message is marked deleted.
static Flags.Flag | DRAFT This message is a draft.
static Flags.Flag | FLAGGED This message is flagged.
static Flags.Flag | RECENT This message is recent.
static Flags.Flag | SEEN This message is seen.
static Flags.Flag | USER A special flag that indicates that this folder supports user defined flags.
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ANSWERED

public static final Flags.Flag ANSWERED
This message has been answered. This flag is set by clients to indicate that this message has been answered to.

DELETED

public static final Flags.Flag DELETED
This message is marked deleted. Clients set this flag to mark a message as deleted. The expunge operation on a folder removes all messages in that folder that are marked for deletion.

DRAFT

public static final Flags.Flag DRAFT
This message is a draft. This flag is set by clients to indicate that the message is a draft message.

FLAGGED

public static final Flags.Flag FLAGGED
This message is flagged. No semantic is defined for this flag. Clients alter this flag.

RECENT

public static final Flags.Flag RECENT
This message is recent. Folder implementations set this flag to indicate that this message is new to this folder, that is, it has arrived since the last time this folder was opened.

Clients cannot alter this flag.

SEEN

public static final Flags.Flag SEEN
This message is seen. This flag is implicitly set by the implementation when the this Message's content is returned to the client in some form. The getInputStream and getContent methods on Message cause this flag to be set.

Clients can alter this flag.

USER

public static final Flags.Flag USER
A special flag that indicates that this folder supports user defined flags.

The implementation sets this flag. Clients cannot alter this flag but can use it to determine if a folder supports user defined flags by using folder.getPermanentFlags().contains(Flags.Flag.USER).

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Folder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Folder

java.lang.Object
    extended by  javax.mail.Folder

public abstract class Folder
extends Object

Folder is an abstract class that represents a folder for mail messages. Subclasses implement protocol specific Folders.

Folders can contain Messages, other Folders or both, thus providing a tree-like hierarchy rooted at the Store's default folder. (Note that some Folder implementations may not allow both Messages and other Folders in the same Folder).

The interpretation of folder names is implementation dependent. The different levels of hierarchy in a folder's full name are separated from each other by the hierarchy delimiter character.

The case-insensitive full folder name (that is, the full name relative to the default folder for a Store) INBOX is reserved to mean the "primary folder for this user on this server". Not all Stores will provide an INBOX folder, and not all users will have an INBOX folder at all times. The name INBOX is reserved to refer to this folder, when it exists, in Stores that provide it.

A Folder object obtained from a Store need not actually exist in the backend store. The exists method tests whether the folder exists or not. The create method creates a Folder.

A Folder is initially in the closed state. Certain methods are valid in this state; the documentation for those methods note this. A Folder is opened by calling its 'open' method. All Folder methods, except open, delete and renameTo, are valid in this state.

The only way to get a Folder is by invoking the getFolder method on Store, Folder, or Session, or by invoking the list or listSubscribed methods on Folder. Folder objects returned by the above methods are not cached by the Store. Thus, invoking the getFolder method with the same folder name multiple times will return distinct Folder objects. Likewise for the list and listSubscribed methods.

The Message objects within the Folder are cached by the Folder. Thus, invoking getMessage(msgno) on the same message number multiple times will return the same Message object, until an expunge is done on this Folder.

Note that a Message's message number can change within a session if the containing Folder is expunged using the expunge method. Clients that use message numbers as references to messages should be aware of this and should be prepared to deal with situation (probably by flushing out existing message number references and reloading them). Because of this complexity, it is better for clients to use Message objects as references to messages, rather than message numbers. Expunged Message objects still have to be pruned, but other Message objects in that folder are not affected by the expunge.

Author:
John Mani, Bill Shannon

Field Summary
static int | HOLDS_FOLDERS This folder can contain other folders
static int | HOLDS_MESSAGES This folder can contain messages
protected int | mode The open mode of this folder.
static int | READ_ONLY The Folder is read only.
static int | READ_WRITE The state and contents of this folder can be modified.
protected Store | store The parent store.
Constructor Summary
protected Folder(Store store)
Constructor that takes a Store object.
Method Summary
 void addConnectionListener(ConnectionListener l)
Add a listener for Connection events on this Folder.
 void addFolderListener(FolderListener l)
Add a listener for Folder events on this Folder.
 void addMessageChangedListener(MessageChangedListener l)
Add a listener for MessageChanged events on this Folder.
 void addMessageCountListener(MessageCountListener l)
Add a listener for MessageCount events on this Folder.
abstract  void appendMessages(Message[] msgs)
Append given Messages to this folder.
abstract  void close(boolean expunge)
Close this Folder.
 void copyMessages(Message[] msgs, Folder folder)
Copy the specified Messages from this Folder into another Folder.
abstract  boolean create(int type)
Create this folder on the Store.
abstract  boolean delete(boolean recurse)
Delete this Folder.
abstract  boolean exists()
Tests if this folder physically exists on the Store.
abstract  Message[] expunge()
Expunge (permanently remove) messages marked DELETED.
 void fetch(Message[] msgs, FetchProfile fp)
Prefetch the items specified in the FetchProfile for the given Messages.
protected  void finalize()
 int getDeletedMessageCount()
Get the number of deleted messages in this Folder.
abstract  Folder getFolder(String name)
Return the Folder object corresponding to the given name.
abstract  String getFullName()
Returns the full name of this Folder.
abstract  Message getMessage(int msgnum)
Get the Message object corresponding to the given message number.
abstract  int getMessageCount()
Get total number of messages in this Folder.
 Message[] getMessages()
Get all Message objects from this Folder.
 Message[] getMessages(int[] msgnums)
Get the Message objects for message numbers specified in the array.
 Message[] getMessages(int start, int end)
Get the Message objects for message numbers ranging from start through end, both start and end inclusive.
 int getMode()
Return the open mode of this folder.
abstract  String getName()
Returns the name of this Folder.
 int getNewMessageCount()
Get the number of new messages in this Folder.
abstract  Folder getParent()
Returns the parent folder of this folder.
abstract  Flags getPermanentFlags()
Get the permanent flags supported by this Folder.
abstract  char getSeparator()
Return the delimiter character that separates this Folder's pathname from the names of immediate subfolders.
 Store getStore()
Returns the Store that owns this Folder object.
abstract  int getType()
Returns the type of this Folder, that is, whether this folder can hold messages or subfolders or both.
 int getUnreadMessageCount()
Get the total number of unread messages in this Folder.
 URLName getURLName()
Return a URLName representing this folder.
abstract  boolean hasNewMessages()
Returns true if this Folder has new messages since the last time this indication was reset.
abstract  boolean isOpen()
Indicates whether this Folder is in the 'open' state.
 boolean isSubscribed()
Returns true if this Folder is subscribed.
 Folder[] list()
Convenience method that returns the list of folders under this Folder.
abstract  Folder[] list(String pattern)
Returns a list of Folders belonging to this Folder's namespace that match the specified pattern.
 Folder[] listSubscribed()
Convenience method that returns the list of subscribed folders under this Folder.
 Folder[] listSubscribed(String pattern)
Returns a list of subscribed Folders belonging to this Folder's namespace that match the specified pattern.
protected  void notifyConnectionListeners(int type)
Notify all ConnectionListeners.
protected  void notifyFolderListeners(int type)
Notify all FolderListeners registered on this Folder and this folder's Store.
protected  void notifyFolderRenamedListeners(Folder folder)
Notify all FolderListeners registered on this Folder and this folder's Store about the renaming of this folder.
protected  void notifyMessageAddedListeners(Message[] msgs)
Notify all MessageCountListeners about the addition of messages into this folder.
protected  void notifyMessageChangedListeners(int type, Message msg)
Notify all MessageChangedListeners.
protected  void notifyMessageRemovedListeners(boolean removed, Message[] msgs)
Notify all MessageCountListeners about the removal of messages from this Folder.
abstract  void open(int mode)
Open this Folder.
 void removeConnectionListener(ConnectionListener l)
Remove a Connection event listener.
 void removeFolderListener(FolderListener l)
Remove a Folder event listener.
 void removeMessageChangedListener(MessageChangedListener l)
Remove a MessageChanged listener.
 void removeMessageCountListener(MessageCountListener l)
Remove a MessageCount listener.
abstract  boolean renameTo(Folder f)
Rename this Folder.
 Message[] search(SearchTerm term)
Search this Folder for messages matching the specified search criterion.
 Message[] search(SearchTerm term, Message[] msgs)
Search the given array of messages for those that match the specified search criterion.
 void setFlags(int[] msgnums, Flags flag, boolean value)
Set the specified flags on the messages whose message numbers are in the array.
 void setFlags(int start, int end, Flags flag, boolean value)
Set the specified flags on the messages numbered from start through end, both start and end inclusive.
 void setFlags(Message[] msgs, Flags flag, boolean value)
Set the specified flags on the messages specified in the array.
 void setSubscribed(boolean subscribe)
Subscribe or unsubscribe this Folder.
 String toString()
override the default toString(), it will return the String from Folder.getFullName() or if that is null, it will use the default toString() behavior.
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

store

protected Store store
The parent store.

mode

protected int mode
The open mode of this folder. The open mode is Folder.READ_ONLY, Folder.READ_WRITE, or -1 if not known.

Since:
JavaMail 1.1

HOLDS_MESSAGES

public static final int HOLDS_MESSAGES
This folder can contain messages

See Also:
Constant Field Values

HOLDS_FOLDERS

public static final int HOLDS_FOLDERS
This folder can contain other folders

See Also:
Constant Field Values

READ_ONLY

public static final int READ_ONLY
The Folder is read only. The state and contents of this folder cannot be modified.

See Also:
Constant Field Values

READ_WRITE

public static final int READ_WRITE
The state and contents of this folder can be modified.

See Also:
Constant Field Values
Constructor Detail

Folder

protected Folder(Store store)
Constructor that takes a Store object.

Parameters:
store - the Store that holds this folder
Method Detail

getName

public abstract String getName()
Returns the name of this Folder.

This method can be invoked on a closed Folder.

Returns:
name of the Folder

getFullName

public abstract String getFullName()
Returns the full name of this Folder. If the folder resides under the root hierarchy of this Store, the returned name is relative to the root. Otherwise an absolute name, starting with the hierarchy delimiter, is returned.

This method can be invoked on a closed Folder.

Returns:
full name of the Folder

getURLName

public URLName getURLName()
                   throws MessagingException
Return a URLName representing this folder. The returned URLName does not include the password used to access the store.

Returns:
the URLName representing this folder
Throws:
MessagingException
Since:
JavaMail 1.1
See Also:
URLName

getStore

public Store getStore()
Returns the Store that owns this Folder object. This method can be invoked on a closed Folder.

Returns:
the Store

getParent

public abstract Folder getParent()
                          throws MessagingException
Returns the parent folder of this folder. This method can be invoked on a closed Folder. If this folder is the top of a folder hierarchy, this method returns null.

Note that since Folder objects are not cached, invoking this method returns a new distinct Folder object.

Returns:
Parent folder
Throws:
MessagingException

exists

public abstract boolean exists()
                        throws MessagingException
Tests if this folder physically exists on the Store. This method can be invoked on a closed Folder.

Returns:
true if the folder exists, otherwise false
Throws:
MessagingException - typically if the connection to the server is lost.
See Also:
create(int)

list

public abstract Folder[] list(String pattern)
                       throws MessagingException
Returns a list of Folders belonging to this Folder's namespace that match the specified pattern. Patterns may contain the wildcard characters "%", which matches any character except hierarchy delimiters, and "*", which matches any character.

As an example, given the folder hierarchy:

    Personal/
       Finance/
          Stocks
          Bonus
          StockOptions
       Jokes
list("*") on "Personal" will return the whole hierarchy.
list("%") on "Personal" will return "Finance" and "Jokes".
list("Jokes") on "Personal" will return "Jokes".
list("Stock*") on "Finance" will return "Stocks" and "StockOptions".

Folder objects are not cached by the Store, so invoking this method on the same pattern multiple times will return that many distinct Folder objects.

This method can be invoked on a closed Folder.

Parameters:
pattern - the match pattern
Returns:
array of matching Folder objects. An empty array is returned if no matching Folders exist.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException
See Also:
listSubscribed(java.lang.String)

listSubscribed

public Folder[] listSubscribed(String pattern)
                        throws MessagingException
Returns a list of subscribed Folders belonging to this Folder's namespace that match the specified pattern. If the folder does not support subscription, this method should resolve to list. (The default implementation provided here, does just this). The pattern can contain wildcards as for list.

Note that, at a given level of the folder hierarchy, a particular folder may not be subscribed, but folders underneath that folder in the folder hierarchy may be subscribed. In order to allow walking the folder hierarchy, such unsubscribed folders may be returned, indicating that a folder lower in the hierarchy is subscribed. The isSubscribed method on a folder will tell whether any particular folder is actually subscribed.

Folder objects are not cached by the Store, so invoking this method on the same pattern multiple times will return that many distinct Folder objects.

This method can be invoked on a closed Folder.

Parameters:
pattern - the match pattern
Returns:
array of matching subscribed Folder objects. An empty array is returned if no matching subscribed folders exist.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException
See Also:
list(java.lang.String)

list

public Folder[] list()
              throws MessagingException
Convenience method that returns the list of folders under this Folder. This method just calls the list(String pattern) method with "%" as the match pattern. This method can be invoked on a closed Folder.

Returns:
array of Folder objects under this Folder. An empty array is returned if no subfolders exist.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException
See Also:
list(java.lang.String)

listSubscribed

public Folder[] listSubscribed()
                        throws MessagingException
Convenience method that returns the list of subscribed folders under this Folder. This method just calls the listSubscribed(String pattern) method with "%" as the match pattern. This method can be invoked on a closed Folder.

Returns:
array of subscribed Folder objects under this Folder. An empty array is returned if no subscribed subfolders exist.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException
See Also:
listSubscribed(java.lang.String)

getSeparator

public abstract char getSeparator()
                           throws MessagingException
Return the delimiter character that separates this Folder's pathname from the names of immediate subfolders. This method can be invoked on a closed Folder.

Returns:
Hierarchy separator character
Throws:
FolderNotFoundException - if the implementation requires the folder to exist, but it does not
MessagingException

getType

public abstract int getType()
                     throws MessagingException
Returns the type of this Folder, that is, whether this folder can hold messages or subfolders or both. The returned value is an integer bitfield with the appropriate bits set. This method can be invoked on a closed folder.

Returns:
integer with appropriate bits set
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException
See Also:
HOLDS_FOLDERS, HOLDS_MESSAGES

create

public abstract boolean create(int type)
                        throws MessagingException
Create this folder on the Store. When this folder is created, any folders in its path that do not exist are also created.

If the creation is successful, a CREATED FolderEvent is delivered to any FolderListeners registered on this Folder and this Store.

Parameters:
type - The type of this folder.
Returns:
true if the creation succeeds, else false.
Throws:
MessagingException
See Also:
HOLDS_FOLDERS, HOLDS_MESSAGES, FolderEvent

isSubscribed

public boolean isSubscribed()
Returns true if this Folder is subscribed.

This method can be invoked on a closed Folder.

The default implementation provided here just returns true.

Returns:
true if this Folder is subscribed

setSubscribed

public void setSubscribed(boolean subscribe)
                   throws MessagingException
Subscribe or unsubscribe this Folder. Not all Stores support subscription.

This method can be invoked on a closed Folder.

The implementation provided here just throws the MethodNotSupportedException.

Parameters:
subscribe - true to subscribe, false to unsubscribe
Throws:
FolderNotFoundException - if this folder does not exist.
MethodNotSupportedException - if this store does not support subscription
MessagingException

hasNewMessages

public abstract boolean hasNewMessages()
                                throws MessagingException
Returns true if this Folder has new messages since the last time this indication was reset. When this indication is set or reset depends on the Folder implementation (and in the case of IMAP, depends on the server). This method can be used to implement a lightweight "check for new mail" operation on a Folder without opening it. (For example, a thread that monitors a mailbox and flags when it has new mail.) This method should indicate whether any messages in the Folder have the RECENT flag set.

Note that this is not an incremental check for new mail, i.e., it cannot be used to determine whether any new messages have arrived since the last time this method was invoked. To implement incremental checks, the Folder needs to be opened.

This method can be invoked on a closed Folder that can contain Messages.

Returns:
true if the Store has new Messages
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException

getFolder

public abstract Folder getFolder(String name)
                          throws MessagingException
Return the Folder object corresponding to the given name. Note that this folder does not physically have to exist in the Store. The exists() method on a Folder indicates whether it really exists on the Store.

In some Stores, name can be an absolute path if it starts with the hierarchy delimiter. Otherwise, it is interpreted relative to this Folder.

Folder objects are not cached by the Store, so invoking this method on the same name multiple times will return that many distinct Folder objects.

This method can be invoked on a closed Folder.

Parameters:
name - name of the Folder
Returns:
Folder object
Throws:
MessagingException

delete

public abstract boolean delete(boolean recurse)
                        throws MessagingException
Delete this Folder. This method will succeed only on a closed Folder.

The recurse flag controls whether the deletion affects subfolders or not. If true, all subfolders are deleted, then this folder itself is deleted. If false, the behaviour is dependent on the folder type and is elaborated below:

  • The folder can contain only messages: (type == HOLDS_MESSAGES).
    All messages within the folder are removed. The folder itself is then removed. An appropriate FolderEvent is generated by the Store and this folder.

  • The folder can contain only subfolders: (type == HOLDS_FOLDERS).
    If this folder is empty (does not contain any subfolders at all), it is removed. An appropriate FolderEvent is generated by the Store and this folder.
    If this folder contains any subfolders, the delete fails and returns false.

  • The folder can contain subfolders as well as messages:
    If the folder is empty (no messages or subfolders), it is removed. If the folder contains no subfolders, but only messages, then all messages are removed. The folder itself is then removed. In both the above cases, an appropriate FolderEvent is generated by the Store and this folder.

    If the folder contains subfolders there are 3 possible choices an implementation is free to do:

    1. The operation fails, irrespective of whether this folder contains messages or not. Some implementations might elect to go with this simple approach. The delete() method returns false.
    2. Any messages within the folder are removed. Subfolders are not removed. The folder itself is not removed or affected in any manner. The delete() method returns true. And the exists() method on this folder will return true indicating that this folder still exists.
      An appropriate FolderEvent is generated by the Store and this folder.
    3. Any messages within the folder are removed. Subfolders are not removed. The folder itself changes its type from HOLDS_FOLDERS | HOLDS_MESSAGES to HOLDS_FOLDERS. Thus new messages cannot be added to this folder, but new subfolders can be created underneath. The delete() method returns true indicating success. The exists() method on this folder will return true indicating that this folder still exists.
      An appropriate FolderEvent is generated by the Store and this folder.

Returns:
true if the Folder is deleted successfully
Throws:
FolderNotFoundException - if this folder does not exist
IllegalStateException - if this folder is not in the closed state.
MessagingException
See Also:
FolderEvent

renameTo

public abstract boolean renameTo(Folder f)
                          throws MessagingException
Rename this Folder. This method will succeed only on a closed Folder.

If the rename is successful, a RENAMED FolderEvent is delivered to FolderListeners registered on this folder and its containing Store.

Parameters:
f - a folder representing the new name for this Folder
Returns:
true if the Folder is renamed successfully
Throws:
FolderNotFoundException - if this folder does not exist
IllegalStateException - if this folder is not in the closed state.
MessagingException
See Also:
FolderEvent

open

public abstract void open(int mode)
                   throws MessagingException
Open this Folder. This method is valid only on Folders that can contain Messages and that are closed.

If this folder is opened successfully, an OPENED ConnectionEvent is delivered to any ConnectionListeners registered on this Folder.

The effect of opening multiple connections to the same folder on a specifc Store is implementation dependent. Some implementations allow multiple readers, but only one writer. Others allow multiple writers as well as readers.

Parameters:
mode - open the Folder READ_ONLY or READ_WRITE
Throws:
FolderNotFoundException - if this folder does not exist.
IllegalStateException - if this folder is not in the closed state.
MessagingException
See Also:
READ_ONLY, READ_WRITE, getType(), ConnectionEvent

close

public abstract void close(boolean expunge)
                    throws MessagingException
Close this Folder. This method is valid only on open Folders.

A CLOSED ConnectionEvent is delivered to any ConnectionListeners registered on this Folder. Note that the folder is closed even if this method terminates abnormally by throwing a MessagingException.

Parameters:
expunge - expunges all deleted messages if this flag is true
Throws:
IllegalStateException - if this folder is not opened
MessagingException
See Also:
ConnectionEvent

isOpen

public abstract boolean isOpen()
Indicates whether this Folder is in the 'open' state.

Returns:
true if this Folder is in the 'open' state.

getMode

public int getMode()
Return the open mode of this folder. Returns Folder.READ_ONLY, Folder.READ_WRITE, or -1 if the open mode is not known (usually only because an older Folder provider has not been updated to use this new method).

Returns:
the open mode of this folder
Throws:
IllegalStateException - if this folder is not opened
Since:
JavaMail 1.1

getPermanentFlags

public abstract Flags getPermanentFlags()
Get the permanent flags supported by this Folder. Returns a Flags object that contains all the flags supported.

The special flag Flags.USER indicates that this Folder supports arbitrary user-defined flags.

The supported permanent flags for a folder may not be available until the folder is opened.

Returns:
permanent flags, or null if not known

getMessageCount

public abstract int getMessageCount()
                             throws MessagingException
Get total number of messages in this Folder.

This method can be invoked on a closed folder. However, note that for some folder implementations, getting the total message count can be an expensive operation involving actually opening the folder. In such cases, a provider can choose not to support this functionality in the closed state, in which case this method must return -1.

Clients invoking this method on a closed folder must be aware that this is a potentially expensive operation. Clients must also be prepared to handle a return value of -1 in this case.

Returns:
total number of messages. -1 may be returned by certain implementations if this method is invoked on a closed folder.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException

getNewMessageCount

public int getNewMessageCount()
                       throws MessagingException
Get the number of new messages in this Folder.

This method can be invoked on a closed folder. However, note that for some folder implementations, getting the new message count can be an expensive operation involving actually opening the folder. In such cases, a provider can choose not to support this functionality in the closed state, in which case this method must return -1.

Clients invoking this method on a closed folder must be aware that this is a potentially expensive operation. Clients must also be prepared to handle a return value of -1 in this case.

This implementation returns -1 if this folder is closed. Else this implementation gets each Message in the folder using getMessage(int) and checks whether its RECENT flag is set. The total number of messages that have this flag set is returned.

Returns:
number of new messages. -1 may be returned by certain implementations if this method is invoked on a closed folder.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException

getUnreadMessageCount

public int getUnreadMessageCount()
                          throws MessagingException
Get the total number of unread messages in this Folder.

This method can be invoked on a closed folder. However, note that for some folder implementations, getting the unread message count can be an expensive operation involving actually opening the folder. In such cases, a provider can choose not to support this functionality in the closed state, in which case this method must return -1.

Clients invoking this method on a closed folder must be aware that this is a potentially expensive operation. Clients must also be prepared to handle a return value of -1 in this case.

This implementation returns -1 if this folder is closed. Else this implementation gets each Message in the folder using getMessage(int) and checks whether its SEEN flag is set. The total number of messages that do not have this flag set is returned.

Returns:
total number of unread messages. -1 may be returned by certain implementations if this method is invoked on a closed folder.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException

getDeletedMessageCount

public int getDeletedMessageCount()
                           throws MessagingException
Get the number of deleted messages in this Folder.

This method can be invoked on a closed folder. However, note that for some folder implementations, getting the deleted message count can be an expensive operation involving actually opening the folder. In such cases, a provider can choose not to support this functionality in the closed state, in which case this method must return -1.

Clients invoking this method on a closed folder must be aware that this is a potentially expensive operation. Clients must also be prepared to handle a return value of -1 in this case.

This implementation returns -1 if this folder is closed. Else this implementation gets each Message in the folder using getMessage(int) and checks whether its DELETED flag is set. The total number of messages that have this flag set is returned.

Returns:
number of deleted messages. -1 may be returned by certain implementations if this method is invoked on a closed folder.
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException
Since:
JavaMail 1.3

getMessage

public abstract Message getMessage(int msgnum)
                            throws MessagingException
Get the Message object corresponding to the given message number. A Message object's message number is the relative position of this Message in its Folder. Messages are numbered starting at 1 through the total number of message in the folder. Note that the message number for a particular Message can change during a session if other messages in the Folder are deleted and the Folder is expunged.

Message objects are light-weight references to the actual message that get filled up on demand. Hence Folder implementations are expected to provide light-weight Message objects.

Unlike Folder objects, repeated calls to getMessage with the same message number will return the same Message object, as long as no messages in this folder have been expunged.

Since message numbers can change within a session if the folder is expunged , clients are advised not to use message numbers as references to messages. Use Message objects instead.

Parameters:
msgnum - the message number
Returns:
the Message object
Throws:
FolderNotFoundException - if this folder does not exist.
IllegalStateException - if this folder is not opened
IndexOutOfBoundsException - if the message number is out of range.
MessagingException
See Also:
getMessageCount(), fetch(javax.mail.Message[], javax.mail.FetchProfile)

getMessages

public Message[] getMessages(int start,
                             int end)
                      throws MessagingException
Get the Message objects for message numbers ranging from start through end, both start and end inclusive. Note that message numbers start at 1, not 0.

Message objects are light-weight references to the actual message that get filled up on demand. Hence Folder implementations are expected to provide light-weight Message objects.

This implementation uses getMessage(index) to obtain the required Message objects. Note that the returned array must contain (end-start+1) Message objects.

Parameters:
start - the number of the first message
end - the number of the last message
Returns:
the Message objects
Throws:
FolderNotFoundException - if this folder does not exist.
IllegalStateException - if this folder is not opened.
IndexOutOfBoundsException - if the start or end message numbers are out of range.
MessagingException
See Also:
fetch(javax.mail.Message[], javax.mail.FetchProfile)

getMessages

public Message[] getMessages(int[] msgnums)
                      throws MessagingException
Get the Message objects for message numbers specified in the array.

Message objects are light-weight references to the actual message that get filled up on demand. Hence Folder implementations are expected to provide light-weight Message objects.

This implementation uses getMessage(index) to obtain the required Message objects. Note that the returned array must contain msgnums.length Message objects

Parameters:
msgnums - the array of message numbers
Returns:
the array of Message objects.
Throws:
FolderNotFoundException - if this folder does not exist.
IllegalStateException - if this folder is not opened.
IndexOutOfBoundsException - if any message number in the given array is out of range.
MessagingException
See Also:
fetch(javax.mail.Message[], javax.mail.FetchProfile)

getMessages

public Message[] getMessages()
                      throws MessagingException
Get all Message objects from this Folder. Returns an empty array if the folder is empty. Clients can use Message objects (instead of sequence numbers) as references to the messages within a folder; this method supplies the Message objects to the client. Folder implementations are expected to provide light-weight Message objects, which get filled on demand.

This implementation invokes getMessageCount() to get the current message count and then uses getMessage() to get Message objects from 1 till the message count.

Returns:
array of Message objects, empty array if folder is empty.
Throws:
FolderNotFoundException - if this folder does not exist.
IllegalStateException - if this folder is not opened.
MessagingException
See Also:
fetch(javax.mail.Message[], javax.mail.FetchProfile)

appendMessages

public abstract void appendMessages(Message[] msgs)
                             throws MessagingException
Append given Messages to this folder. This method can be invoked on a closed Folder. An appropriate MessageCountEvent is delivered to any MessageCountListener registered on this folder when the messages arrive in the folder.

Folder implementations must not abort this operation if a Message in the given message array turns out to be an expunged Message.

Parameters:
msgs - array of Messages to be appended
Throws:
FolderNotFoundException - if this folder does not exist.
MessagingException - if the append failed.

fetch

public void fetch(Message[] msgs,
                  FetchProfile fp)
           throws MessagingException
Prefetch the items specified in the FetchProfile for the given Messages.

Clients use this method to indicate that the specified items are needed en-masse for the given message range. Implementations are expected to retrieve these items for the given message range in a efficient manner. Note that this method is just a hint to the implementation to prefetch the desired items.

An example is a client filling its header-view window with the Subject, From and X-mailer headers for all messages in the folder.

  Message[] msgs = folder.getMessages();

  FetchProfile fp = new FetchProfile();
  fp.add(FetchProfile.Item.ENVELOPE);
  fp.add("X-mailer");
  folder.fetch(msgs, fp);

  for (int i = 0; i < folder.getMessageCount(); i++) {
      display(msg[i].getFrom());
      display(msg[i].getSubject());
      display(msg[i].getHeader("X-mailer"));
  }

The implementation provided here just returns without doing anything useful. Providers wanting to provide a real implementation for this method should override this method.

Parameters:
msgs - fetch items for these messages
fp - the FetchProfile
Throws:
IllegalStateException - if this folder is not opened
MessagingException.
MessagingException

setFlags

public void setFlags(Message[] msgs,
                     Flags flag,
                     boolean value)
              throws MessagingException
Set the specified flags on the messages specified in the array. This will result in appropriate MessageChangedEvents being delivered to any MessageChangedListener registered on this Message's containing folder.

Note that the specified Message objects must belong to this folder. Certain Folder implementations can optimize the operation of setting Flags for a group of messages, so clients might want to use this method, rather than invoking Message.setFlags for each Message.

This implementation degenerates to invoking setFlags() on each Message object. Specific Folder implementations that can optimize this case should do so. Also, an implementation must not abort the operation if a Message in the array turns out to be an expunged Message.

Parameters:
msgs - the array of message objects
flag - Flags object containing the flags to be set
value - set the flags to this boolean value
Throws:
IllegalStateException - if this folder is not opened or if it has been opened READ_ONLY.
MessagingException
See Also:
Message.setFlags(javax.mail.Flags, boolean), MessageChangedEvent

setFlags

public void setFlags(int start,
                     int end,
                     Flags flag,
                     boolean value)
              throws MessagingException
Set the specified flags on the messages numbered from start through end, both start and end inclusive. Note that message numbers start at 1, not 0. This will result in appropriate MessageChangedEvents being delivered to any MessageChangedListener registered on this Message's containing folder.

Certain Folder implementations can optimize the operation of setting Flags for a group of messages, so clients might want to use this method, rather than invoking Message.setFlags for each Message.

The default implementation uses getMessage(int) to get each Message object and then invokes setFlags on that object to set the flags. Specific Folder implementations that can optimize this case should do so. Also, an implementation must not abort the operation if a message number refers to an expunged message.

Parameters:
start - the number of the first message
end - the number of the last message
flag - Flags object containing the flags to be set
value - set the flags to this boolean value
Throws:
IllegalStateException - if this folder is not opened or if it has been opened READ_ONLY.
IndexOutOfBoundsException - if the start or end message numbers are out of range.
MessagingException
See Also:
Message.setFlags(javax.mail.Flags, boolean), MessageChangedEvent

setFlags

public void setFlags(int[] msgnums,
                     Flags flag,
                     boolean value)
              throws MessagingException
Set the specified flags on the messages whose message numbers are in the array. This will result in appropriate MessageChangedEvents being delivered to any MessageChangedListener registered on this Message's containing folder.

Certain Folder implementations can optimize the operation of setting Flags for a group of messages, so clients might want to use this method, rather than invoking Message.setFlags for each Message.

The default implementation uses getMessage(int) to get each Message object and then invokes setFlags on that object to set the flags. Specific Folder implementations that can optimize this case should do so. Also, an implementation must not abort the operation if a message number refers to an expunged message.

Parameters:
msgnums - the array of message numbers
flag - Flags object containing the flags to be set
value - set the flags to this boolean value
Throws:
IllegalStateException - if this folder is not opened or if it has been opened READ_ONLY.
IndexOutOfBoundsException - if any message number in the given array is out of range.
MessagingException
See Also:
Message.setFlags(javax.mail.Flags, boolean), MessageChangedEvent

copyMessages

public void copyMessages(Message[] msgs,
                         Folder folder)
                  throws MessagingException
Copy the specified Messages from this Folder into another Folder. This operation appends these Messages to the destination Folder. The destination Folder does not have to be opened. An appropriate MessageCountEvent is delivered to any MessageCountListener registered on the destination folder when the messages arrive in the folder.

Note that the specified Message objects must belong to this folder. Folder implementations might be able to optimize this method by doing server-side copies.

This implementation just invokes appendMessages() on the destination folder to append the given Messages. Specific folder implementations that support server-side copies should do so, if the destination folder's Store is the same as this folder's Store. Also, an implementation must not abort the operation if a Message in the array turns out to be an expunged Message.

Parameters:
msgs - the array of message objects
folder - the folder to copy the messages to
Throws:
FolderNotFoundException - if the destination folder does not exist.
IllegalStateException - if this folder is not opened.
MessagingException
See Also:
appendMessages(javax.mail.Message[])

expunge

public abstract Message[] expunge()
                           throws MessagingException
Expunge (permanently remove) messages marked DELETED. Returns an array containing the expunged message objects. The getMessageNumber method on each of these message objects returns that Message's original (that is, prior to the expunge) sequence number. A MessageCountEvent containing the expunged messages is delivered to any MessageCountListeners registered on the folder.

Expunge causes the renumbering of Message objects subsequent to the expunged messages. Clients that use message numbers as references to messages should be aware of this and should be prepared to deal with the situation (probably by flushing out existing message number caches and reloading them). Because of this complexity, it is better for clients to use Message objects as references to messages, rather than message numbers. Any expunged Messages objects still have to be pruned, but other Messages in that folder are not affected by the expunge.

After a message is expunged, only the isExpunged and getMessageNumber methods are still valid on the corresponding Message object; other methods may throw MessageRemovedException

Returns:
array of expunged Message objects
Throws:
FolderNotFoundException - if this folder does not exist
IllegalStateException - if this folder is not opened.
MessagingException
See Also:
Message.isExpunged(), MessageCountEvent

search

public Message[] search(SearchTerm term)
                 throws MessagingException
Search this Folder for messages matching the specified search criterion. Returns an array containing the matching messages . Returns an empty array if no matches were found.

This implementation invokes search(term, getMessages()), to apply the search over all the messages in this folder. Providers that can implement server-side searching might want to override this method to provide a more efficient implementation.

Parameters:
term - the search criterion
Returns:
array of matching messages
Throws:
SearchException - if the search term is too complex for the implementation to handle.
FolderNotFoundException - if this folder does not exist.
IllegalStateException - if this folder is not opened.
MessagingException
See Also:
SearchTerm

search

public Message[] search(SearchTerm term,
                        Message[] msgs)
                 throws MessagingException
Search the given array of messages for those that match the specified search criterion. Returns an array containing the matching messages. Returns an empty array if no matches were found.

Note that the specified Message objects must belong to this folder.

This implementation iterates through the given array of messages, and applies the search criterion on each message by calling its match() method with the given term. The messages that succeed in the match are returned. Providers that can implement server-side searching might want to override this method to provide a more efficient implementation. If the search term is too complex or contains user-defined terms that cannot be executed on the server, providers may elect to either throw a SearchException or degenerate to client-side searching by calling super.search() to invoke this implementation.

Parameters:
term - the search criterion
msgs - the messages to be searched
Returns:
array of matching messages
Throws:
SearchException - if the search term is too complex for the implementation to handle.
IllegalStateException - if this folder is not opened
MessagingException
See Also:
SearchTerm

addConnectionListener

public void addConnectionListener(ConnectionListener l)
Add a listener for Connection events on this Folder.

The implementation provided here adds this listener to an internal list of ConnectionListeners.

Parameters:
l - the Listener for Connection events
See Also:
ConnectionEvent

removeConnectionListener

public void removeConnectionListener(ConnectionListener l)
Remove a Connection event listener.

The implementation provided here removes this listener from the internal list of ConnectionListeners.

Parameters:
l - the listener
See Also:
addConnectionListener(javax.mail.event.ConnectionListener)

notifyConnectionListeners

protected void notifyConnectionListeners(int type)
Notify all ConnectionListeners. Folder implementations are expected to use this method to broadcast connection events.

The provided implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered ConnectionListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

Parameters:
type - the ConnectionEvent type
See Also:
ConnectionEvent

addFolderListener

public void addFolderListener(FolderListener l)
Add a listener for Folder events on this Folder.

The implementation provided here adds this listener to an internal list of FolderListeners.

Parameters:
l - the Listener for Folder events
See Also:
FolderEvent

removeFolderListener

public void removeFolderListener(FolderListener l)
Remove a Folder event listener.

The implementation provided here removes this listener from the internal list of FolderListeners.

Parameters:
l - the listener
See Also:
addFolderListener(javax.mail.event.FolderListener)

notifyFolderListeners

protected void notifyFolderListeners(int type)
Notify all FolderListeners registered on this Folder and this folder's Store. Folder implementations are expected to use this method to broadcast Folder events.

The implementation provided here queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the FolderListeners registered on this folder. The implementation also invokes notifyFolderListeners on this folder's Store to notify any FolderListeners registered on the store.

Parameters:
type - type of FolderEvent
See Also:
notifyFolderRenamedListeners(javax.mail.Folder)

notifyFolderRenamedListeners

protected void notifyFolderRenamedListeners(Folder folder)
Notify all FolderListeners registered on this Folder and this folder's Store about the renaming of this folder. Folder implementations are expected to use this method to broadcast Folder events indicating the renaming of folders.

The implementation provided here queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the FolderListeners registered on this folder. The implementation also invokes notifyFolderRenamedListeners on this folder's Store to notify any FolderListeners registered on the store.

Parameters:
folder - Folder representing the new name.
Since:
JavaMail 1.1
See Also:
notifyFolderListeners(int)

addMessageCountListener

public void addMessageCountListener(MessageCountListener l)
Add a listener for MessageCount events on this Folder.

The implementation provided here adds this listener to an internal list of MessageCountListeners.

Parameters:
l - the Listener for MessageCount events
See Also:
MessageCountEvent

removeMessageCountListener

public void removeMessageCountListener(MessageCountListener l)
Remove a MessageCount listener.

The implementation provided here removes this listener from the internal list of MessageCountListeners.

Parameters:
l - the listener
See Also:
addMessageCountListener(javax.mail.event.MessageCountListener)

notifyMessageAddedListeners

protected void notifyMessageAddedListeners(Message[] msgs)
Notify all MessageCountListeners about the addition of messages into this folder. Folder implementations are expected to use this method to broadcast MessageCount events for indicating arrival of new messages.

The provided implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered MessageCountListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

notifyMessageRemovedListeners

protected void notifyMessageRemovedListeners(boolean removed,
                                             Message[] msgs)
Notify all MessageCountListeners about the removal of messages from this Folder. Folder implementations are expected to use this method to broadcast MessageCount events indicating removal of messages.

The provided implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered MessageCountListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

addMessageChangedListener

public void addMessageChangedListener(MessageChangedListener l)
Add a listener for MessageChanged events on this Folder.

The implementation provided here adds this listener to an internal list of MessageChangedListeners.

Parameters:
l - the Listener for MessageChanged events
See Also:
MessageChangedEvent

removeMessageChangedListener

public void removeMessageChangedListener(MessageChangedListener l)
Remove a MessageChanged listener.

The implementation provided here removes this listener from the internal list of MessageChangedListeners.

Parameters:
l - the listener
See Also:
addMessageChangedListener(javax.mail.event.MessageChangedListener)

notifyMessageChangedListeners

protected void notifyMessageChangedListeners(int type,
                                             Message msg)
Notify all MessageChangedListeners. Folder implementations are expected to use this method to broadcast MessageChanged events.

The provided implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to registered MessageChangedListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

finalize

protected void finalize()
                 throws Throwable
Overrides:
finalize in class Object
Throws:
Throwable

toString

public String toString()
override the default toString(), it will return the String from Folder.getFullName() or if that is null, it will use the default toString() behavior.

Overrides:
toString in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FolderClosedException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class FolderClosedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
                extended by  javax.mail.FolderClosedException
All Implemented Interfaces:
Serializable
public class FolderClosedException
extends MessagingException

This exception is thrown when a method is invoked on a Messaging object and the Folder that owns that object has died due to some reason.

Following the exception, the Folder is reset to the "closed" state. All messaging objects owned by the Folder should be considered invalid. The Folder can be reopened using the "open" method to reestablish the lost connection.

The getMessage() method returns more detailed information about the error that caused this exception.

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
FolderClosedException(Folder folder)
Constructor
FolderClosedException(Folder folder, String message)
Constructor
Method Summary
 Folder getFolder()
Returns the dead Folder object
Methods inherited from class javax.mail.MessagingException
getCause, getNextException, setNextException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FolderClosedException

public FolderClosedException(Folder folder)
Constructor

Parameters:
folder - the Folder

FolderClosedException

public FolderClosedException(Folder folder,
                             String message)
Constructor

Parameters:
folder - the Folder
message - the detailed error message
Method Detail

getFolder

public Folder getFolder()
Returns the dead Folder object

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FolderNotFoundException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class FolderNotFoundException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
                extended by  javax.mail.FolderNotFoundException
All Implemented Interfaces:
Serializable
public class FolderNotFoundException
extends MessagingException

This exception is thrown by Folder methods, when those methods are invoked on a non existent folder.

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
FolderNotFoundException()
Constructs a MessagingException with no detail message.
FolderNotFoundException(Folder folder)
Constructs a MessagingException with the specified folder.
FolderNotFoundException(Folder folder, String s)
Constructs a MessagingException with the specified folder and the specified detail message.
FolderNotFoundException(String s, Folder folder)
Constructs a MessagingException with the specified detail message and the specified folder.
Method Summary
 Folder getFolder()
Returns the offending Folder object.
Methods inherited from class javax.mail.MessagingException
getCause, getNextException, setNextException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FolderNotFoundException

public FolderNotFoundException()
Constructs a MessagingException with no detail message.

FolderNotFoundException

public FolderNotFoundException(Folder folder)
Constructs a MessagingException with the specified folder.

Parameters:
folder - the Folder
Since:
JavaMail 1.2

FolderNotFoundException

public FolderNotFoundException(Folder folder,
                               String s)
Constructs a MessagingException with the specified folder and the specified detail message.

Parameters:
folder - the Folder
s - the detail message
Since:
JavaMail 1.2

FolderNotFoundException

public FolderNotFoundException(String s,
                               Folder folder)
Constructs a MessagingException with the specified detail message and the specified folder.

Parameters:
s - the detail message
folder - the Folder
Method Detail

getFolder

public Folder getFolder()
Returns the offending Folder object.

Returns:
the Folder object. Note that the returned value can be null.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Header

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Header

java.lang.Object
    extended by  javax.mail.Header
Direct Known Subclasses:
InternetHeaders.InternetHeader
public class Header
extends Object

The Header class stores a name/value pair to represent headers.

Author:
John Mani

Field Summary
protected String | name The name of the header.
protected String | value The value of the header.
Constructor Summary
Header(String name, String value)
Construct a Header object.
Method Summary
String | getName() Returns the name of this header.
String | getValue() Returns the value of this header.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

protected String name
The name of the header.

Since:
JavaMail 1.4

value

protected String value
The value of the header.

Since:
JavaMail 1.4
Constructor Detail

Header

public Header(String name,
              String value)
Construct a Header object.

Parameters:
name - name of the header
value - value of the header
Method Detail

getName

public String getName()
Returns the name of this header.

Returns:
name of the header

getValue

public String getValue()
Returns the value of this header.

Returns:
value of the header
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


IllegalWriteException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class IllegalWriteException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
                extended by  javax.mail.IllegalWriteException
All Implemented Interfaces:
Serializable
public class IllegalWriteException
extends MessagingException

The exception thrown when a write is attempted on a read-only attribute of any Messaging object.

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
IllegalWriteException()
Constructs a IllegalWriteException with no detail message.
IllegalWriteException(String s)
Constructs a IllegalWriteException with the specified detail message.
Method Summary
Methods inherited from class javax.mail.MessagingException
getCause, getNextException, setNextException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IllegalWriteException

public IllegalWriteException()
Constructs a IllegalWriteException with no detail message.

IllegalWriteException

public IllegalWriteException(String s)
Constructs a IllegalWriteException with the specified detail message.

Parameters:
s - the detail message
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


internet

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.mail.internet

Classes specific to Internet mail systems.

See:
Description

Interface Summary
MimePart | The MimePart interface models an Entity as defined by MIME (RFC2045, Section 2.4).
SharedInputStream | An InputStream that is backed by data that can be shared by multiple readers may implement this interface.

Class Summary
ContentDisposition | This class represents a MIME ContentDisposition value.
ContentType | This class represents a MIME ContentType value.
HeaderTokenizer | This class tokenizes RFC822 and MIME headers into the basic symbols specified by RFC822 and MIME.
HeaderTokenizer.Token | The Token class represents tokens returned by the HeaderTokenizer.
InternetAddress | This class represents an Internet email address using the syntax of RFC822.
InternetHeaders | InternetHeaders is a utility class that manages RFC822 style headers.
InternetHeaders.InternetHeader | An individual internet header.
MailDateFormat | Formats and parses date specification based on the draft-ietf-drums-msg-fmt-08 dated January 26, 2000.
MimeBodyPart | This class represents a MIME body part.
MimeMessage | This class represents a MIME style email message.
MimeMessage.RecipientType | This inner class extends the javax.mail.Message.RecipientType class to add additional RecipientTypes.
MimeMultipart | The MimeMultipart class is an implementation of the abstract Multipart class that uses MIME conventions for the multipart data.
MimePartDataSource | A utility class that implements a DataSource out of a MimePart.
MimeUtility | This is a utility class that provides various MIME related functionality.
NewsAddress | This class models an RFC1036 newsgroup address.
ParameterList | This class holds MIME parameters (attribute-value pairs).
PreencodedMimeBodyPart | A MimeBodyPart that handles data that has already been encoded.

Exception Summary
AddressException | The exception thrown when a wrongly formatted address is encountered.
ParseException | The exception thrown due to an error in parsing RFC822 or MIME headers

Package javax.mail.internet Description

Classes specific to Internet mail systems. This package supports features that are specific to Internet mail systems based on the MIME standard (RFC 2045, RFC 2046, and RFC 2047). The IMAP, SMTP, and POP3 protocols use MimeMessages.

The JavaMail API specification requires support for the following properties, which must be set in the System properties. The properties are always set as strings; the Type column describes how the string is interpreted. For example, use (in J2SE 1.2 and newer)

        System.setProperty("mail.mime.address.strict", "false");
to set the mail.mime.address.strict property, which is of type boolean.

Name | Type | Description
mail.mime.address.strict | boolean | The mail.mime.address.strict session property controls the parsing of address headers. By default, strict parsing of address headers is done. If this property is set to "false", strict parsing is not done and many illegal addresses that sometimes occur in real messages are allowed. See the InternetAddress class for details.
mail.mime.charset | String | The mail.mime.charset System property can be used to specify the default MIME charset to use for encoded words and text parts that don't otherwise specify a charset. Normally, the default MIME charset is derived from the default Java charset, as specified in the file.encoding System property. Most applications will have no need to explicitly set the default MIME charset. In cases where the default MIME charset to be used for mail messages is different than the charset used for files stored on the system, this property should be set.
mail.mime.decodetext.strict | boolean | The mail.mime.decodetext.strict property controls decoding of MIME encoded words. The MIME spec requires that encoded words start at the beginning of a whitespace separated word. Some mailers incorrectly include encoded words in the middle of a word. If the mail.mime.decodetext.strict System property is set to "false", an attempt will be made to decode these illegal encoded words. The default is true.
mail.mime.encodeeol.strict | boolean | The mail.mime.encodeeol.strict property controls the choice of Content-Transfer-Encoding for MIME parts that are not of type "text". Often such parts will contain textual data for which an encoding that allows normal end of line conventions is appropriate. In rare cases, such a part will appear to contain entirely textual data, but will require an encoding that preserves CR and LF characters without change. If the mail.mime.encodeeol.strict System property is set to "true", such an encoding will be used when necessary. The default is false.
mail.mime.decodefilename | boolean | If set to "true", the getFileName method uses the MimeUtility method decodeText to decode any non-ASCII characters in the filename. Note that this decoding violates the MIME specification, but is useful for interoperating with some mail clients that use this convention. The default is false.
mail.mime.encodefilename | boolean | If set to "true", the setFileName method uses the MimeUtility method encodeText to encode any non-ASCII characters in the filename. Note that this encoding violates the MIME specification, but is useful for interoperating with some mail clients that use this convention. The default is false.
mail.mime.decodeparameters | boolean | If set to "true", non-ASCII parameters in a ParameterList, e.g., in a Content-Type header, will be encoded as specified by RFC 2231. The default is false.
mail.mime.encodeparameters | boolean | If set to "true", non-ASCII parameters in a ParameterList, e.g., in a Content-Type header, will be decoded as specified by RFC 2231. The default is false.
mail.mime.multipart. ignoremissingendboundary | boolean | Normally, when parsing a multipart MIME message, a message that is missing the final end boundary line is not considered an error. The data simply ends at the end of the input. Note that messages of this form violate the MIME specification. If the property mail.mime.multipart.ignoremissingendboundary is set to false, such messages are considered an error and a MesagingException will be thrown when parsing such a message.
mail.mime.multipart. ignoremissingboundaryparameter | boolean | If the Content-Type header for a multipart content does not have a boundary parameter, the multipart parsing code will look for the first line in the content that looks like a boundary line and extract the boundary parameter from the line. If this property is set to "false", a MessagingException will be thrown if the Content-Type header doesn't specify a boundary parameter. The default is true.

The following properties are supported by Sun's implementation of JavaMail, but are not currently a required part of the specification. As above, these must be set as System properties. The names, types, defaults, and semantics of these properties may change in future releases.

Name | Type | Description
mail.mime.base64.ignoreerrors | boolean | If set to "true", the BASE64 decoder will ignore errors in the encoded data, returning EOF. This may be useful when dealing with improperly encoded messages that contain extraneous data at the end of the encoded stream. Note however that errors anywhere in the stream will cause the decoder to stop decoding so this should be used with extreme caution. The default is false.
mail.mime.foldtext | boolean | If set to "true", header fields containing just text such as the Subject and Content-Description header fields, and long parameter values in structured headers such as Content-Type will be folded (broken into 76 character lines) when set and unfolded when read. The default is true.
mail.mime.setcontenttypefilename | boolean | If set to "true", the setFileName method will also set the name parameter on the Content-Type header to the specified filename. This supports interoperability with some old mail clients. The default is true.
mail.mime.setdefaulttextcharset | boolean | When updating the headers of a message, a body part with a text content type but no charset parameter will have a charset parameter added to it if this property is set to "true". The default is true.
mail.alternates | String | A string containing other email addresses that the current user is known by. The MimeMessage reply method will eliminate any of these addresses from the recipient list in the message it constructs, to avoid sending the reply back to the sender.
mail.replyallcc | boolean | If set to "true", the MimeMessage reply method will put all recipients except the original sender in the Cc list of the newly constructed message. Normally, recipients in the To header of the original message will also appear in the To list of the newly constructed message.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.mail.internet Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.mail.internet

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.mail.Address (implements java.io.Serializable)
      • javax.mail.internet.InternetAddress (implements java.lang.Cloneable)
      • javax.mail.internet.NewsAddress
    • javax.mail.BodyPart (implements javax.mail.Part)
      • javax.mail.internet.MimeBodyPart (implements javax.mail.internet.MimePart)
        • javax.mail.internet.PreencodedMimeBodyPart
    • javax.mail.internet.ContentDisposition
    • javax.mail.internet.ContentType
    • java.text.Format (implements java.lang.Cloneable, java.io.Serializable)
      • java.text.DateFormat
        • java.text.SimpleDateFormat
          • javax.mail.internet.MailDateFormat
    • javax.mail.Header
      • javax.mail.internet.InternetHeaders.InternetHeader
    • javax.mail.internet.HeaderTokenizer
    • javax.mail.internet.HeaderTokenizer.Token
    • javax.mail.internet.InternetHeaders
    • javax.mail.Message (implements javax.mail.Part)
      • javax.mail.internet.MimeMessage (implements javax.mail.internet.MimePart)
    • javax.mail.Message.RecipientType (implements java.io.Serializable)
      • javax.mail.internet.MimeMessage.RecipientType
    • javax.mail.internet.MimePartDataSource (implements javax.activation.DataSource, javax.mail.MessageAware)
    • javax.mail.internet.MimeUtility
    • javax.mail.Multipart
      • javax.mail.internet.MimeMultipart
    • javax.mail.internet.ParameterList
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.internet.ParseException
            • javax.mail.internet.AddressException

Interface Hierarchy

  • javax.mail.Part
    • javax.mail.internet.MimePart
  • javax.mail.internet.SharedInputStream
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AddressException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class AddressException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
                extended by  javax.mail.internet.ParseException
                    extended by  javax.mail.internet.AddressException
All Implemented Interfaces:
Serializable
public class AddressException
extends ParseException

The exception thrown when a wrongly formatted address is encountered.

Author:
Bill Shannon, Max Spivak
See Also:
Serialized Form

Field Summary
protected int | pos The index in the string where the error occurred, or -1 if not known.
protected String | ref The string being parsed.
Constructor Summary
AddressException()
Constructs an AddressException with no detail message.
AddressException(String s)
Constructs an AddressException with the specified detail message.
AddressException(String s, String ref)
Constructs an AddressException with the specified detail message and reference info.
AddressException(String s, String ref, int pos)
Constructs an AddressException with the specified detail message and reference info.
Method Summary
int | getPos() Get the position with the reference string where the error was detected (-1 if not relevant).
String | getRef() Get the string that was being parsed when the error was detected (null if not relevant).
String | toString() Override toString method to provide information on nested exceptions.
Methods inherited from class javax.mail.MessagingException
getCause, getNextException, setNextException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ref

protected String ref
The string being parsed.

pos

protected int pos
The index in the string where the error occurred, or -1 if not known.

Constructor Detail

AddressException

public AddressException()
Constructs an AddressException with no detail message.

AddressException

public AddressException(String s)
Constructs an AddressException with the specified detail message.

Parameters:
s - the detail message

AddressException

public AddressException(String s,
                        String ref)
Constructs an AddressException with the specified detail message and reference info.

Parameters:
s - the detail message

AddressException

public AddressException(String s,
                        String ref,
                        int pos)
Constructs an AddressException with the specified detail message and reference info.

Parameters:
s - the detail message
Method Detail

getRef

public String getRef()
Get the string that was being parsed when the error was detected (null if not relevant).

getPos

public int getPos()
Get the position with the reference string where the error was detected (-1 if not relevant).

toString

public String toString()
Description copied from class: MessagingException
Override toString method to provide information on nested exceptions.

Overrides:
toString in class MessagingException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ContentDisposition

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class ContentDisposition

java.lang.Object
    extended by  javax.mail.internet.ContentDisposition

public class ContentDisposition
extends Object

This class represents a MIME ContentDisposition value. It provides methods to parse a ContentDisposition string into individual components and to generate a MIME style ContentDisposition string.

Version:
1.8, 05/08/29
Author:
John Mani

Constructor Summary
ContentDisposition()
No-arg Constructor.
ContentDisposition(String s)
Constructor that takes a ContentDisposition string.
ContentDisposition(String disposition, ParameterList list)
Constructor.
Method Summary
String | getDisposition() Return the disposition value.
String | getParameter(String name) Return the specified parameter value.
ParameterList | getParameterList() Return a ParameterList object that holds all the available parameters.
void | setDisposition(String disposition) Set the disposition.
void | setParameter(String name, String value) Set the specified parameter.
void | setParameterList(ParameterList list) Set a new ParameterList.
String | toString() Retrieve a RFC2045 style string representation of this ContentDisposition.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ContentDisposition

public ContentDisposition()
No-arg Constructor.

ContentDisposition

public ContentDisposition(String disposition,
                          ParameterList list)
Constructor.

Parameters:
disposition - disposition
list - ParameterList
Since:
JavaMail 1.2

ContentDisposition

public ContentDisposition(String s)
                   throws ParseException
Constructor that takes a ContentDisposition string. The String is parsed into its constituents: dispostion and parameters. A ParseException is thrown if the parse fails.

Parameters:
s - the ContentDisposition string.
Throws:
ParseException - if the parse fails.
Since:
JavaMail 1.2
Method Detail

getDisposition

public String getDisposition()
Return the disposition value.

Returns:
the disposition
Since:
JavaMail 1.2

getParameter

public String getParameter(String name)
Return the specified parameter value. Returns null if this parameter is absent.

Returns:
parameter value
Since:
JavaMail 1.2

getParameterList

public ParameterList getParameterList()
Return a ParameterList object that holds all the available parameters. Returns null if no parameters are available.

Returns:
ParameterList
Since:
JavaMail 1.2

setDisposition

public void setDisposition(String disposition)
Set the disposition. Replaces the existing disposition.

Parameters:
disposition - the disposition
Since:
JavaMail 1.2

setParameter

public void setParameter(String name,
                         String value)
Set the specified parameter. If this parameter already exists, it is replaced by this new value.

Parameters:
name - parameter name
value - parameter value
Since:
JavaMail 1.2

setParameterList

public void setParameterList(ParameterList list)
Set a new ParameterList.

Parameters:
list - ParameterList
Since:
JavaMail 1.2

toString

public String toString()
Retrieve a RFC2045 style string representation of this ContentDisposition. Returns null if the conversion failed.

Overrides:
toString in class Object
Returns:
RFC2045 style string
Since:
JavaMail 1.2
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ContentType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class ContentType

java.lang.Object
    extended by  javax.mail.internet.ContentType

public class ContentType
extends Object

This class represents a MIME ContentType value. It provides methods to parse a ContentType string into individual components and to generate a MIME style ContentType string.

Version:
1.9, 05/08/29
Author:
John Mani

Constructor Summary
ContentType()
No-arg Constructor.
ContentType(String s)
Constructor that takes a Content-Type string.
ContentType(String primaryType, String subType, ParameterList list)
Constructor.
Method Summary
String | getBaseType() Return the MIME type string, without the parameters.
String | getParameter(String name) Return the specified parameter value.
ParameterList | getParameterList() Return a ParameterList object that holds all the available parameters.
String | getPrimaryType() Return the primary type.
String | getSubType() Return the subType.
boolean | match(ContentType cType) Match with the specified ContentType object.
boolean | match(String s) Match with the specified content-type string.
void | setParameter(String name, String value) Set the specified parameter.
void | setParameterList(ParameterList list) Set a new ParameterList.
void | setPrimaryType(String primaryType) Set the primary type.
void | setSubType(String subType) Set the subType.
String | toString() Retrieve a RFC2045 style string representation of this Content-Type.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ContentType

public ContentType()
No-arg Constructor.

ContentType

public ContentType(String primaryType,
                   String subType,
                   ParameterList list)
Constructor.

Parameters:
primaryType - primary type
subType - subType
list - ParameterList

ContentType

public ContentType(String s)
            throws ParseException
Constructor that takes a Content-Type string. The String is parsed into its constituents: primaryType, subType and parameters. A ParseException is thrown if the parse fails.

Parameters:
s - the Content-Type string.
Throws:
ParseException - if the parse fails.
Method Detail

getPrimaryType

public String getPrimaryType()
Return the primary type.

Returns:
the primary type

getSubType

public String getSubType()
Return the subType.

Returns:
the subType

getBaseType

public String getBaseType()
Return the MIME type string, without the parameters. The returned value is basically the concatenation of the primaryType, the '/' character and the secondaryType.

Returns:
the type

getParameter

public String getParameter(String name)
Return the specified parameter value. Returns null if this parameter is absent.

Returns:
parameter value

getParameterList

public ParameterList getParameterList()
Return a ParameterList object that holds all the available parameters. Returns null if no parameters are available.

Returns:
ParameterList

setPrimaryType

public void setPrimaryType(String primaryType)
Set the primary type. Overrides existing primary type.

Parameters:
primaryType - primary type

setSubType

public void setSubType(String subType)
Set the subType. Replaces the existing subType.

Parameters:
subType - the subType

setParameter

public void setParameter(String name,
                         String value)
Set the specified parameter. If this parameter already exists, it is replaced by this new value.

Parameters:
name - parameter name
value - parameter value

setParameterList

public void setParameterList(ParameterList list)
Set a new ParameterList.

Parameters:
list - ParameterList

toString

public String toString()
Retrieve a RFC2045 style string representation of this Content-Type. Returns null if the conversion failed.

Overrides:
toString in class Object
Returns:
RFC2045 style string

match

public boolean match(ContentType cType)
Match with the specified ContentType object. This method compares only the primaryType and subType . The parameters of both operands are ignored.

For example, this method will return true when comparing the ContentTypes for "text/plain" and "text/plain; charset=foobar". If the subType of either operand is the special character '*', then the subtype is ignored during the match. For example, this method will return true when comparing the ContentTypes for "text/plain" and "text/*"

Parameters:
cType - ContentType to compare this against

match

public boolean match(String s)
Match with the specified content-type string. This method compares only the primaryType and subType . The parameters of both operands are ignored.

For example, this method will return true when comparing the ContentType for "text/plain" with "text/plain; charset=foobar". If the subType of either operand is the special character '*', then the subtype is ignored during the match. For example, this method will return true when comparing the ContentType for "text/plain" with "text/*"

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HeaderTokenizer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class HeaderTokenizer

java.lang.Object
    extended by  javax.mail.internet.HeaderTokenizer

public class HeaderTokenizer
extends Object

This class tokenizes RFC822 and MIME headers into the basic symbols specified by RFC822 and MIME.

This class handles folded headers (ie headers with embedded CRLF SPACE sequences). The folds are removed in the returned tokens.

Version:
1.10, 05/08/29
Author:
John Mani

Nested Class Summary
static class HeaderTokenizer.Token
The Token class represents tokens returned by the HeaderTokenizer.
Field Summary
static String | MIME MIME specials
static String | RFC822 RFC822 specials
Constructor Summary
HeaderTokenizer(String header)
Constructor.
HeaderTokenizer(String header, String delimiters)
Constructor.
HeaderTokenizer(String header, String delimiters, boolean skipComments)
Constructor that takes a rfc822 style header.
Method Summary
String | getRemainder() Return the rest of the Header.
HeaderTokenizer.Token | next() Parses the next token from this String.
HeaderTokenizer.Token | peek() Peek at the next token, without actually removing the token from the parse stream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

RFC822

public static final String RFC822
RFC822 specials

See Also:
Constant Field Values

MIME

public static final String MIME
MIME specials

See Also:
Constant Field Values
Constructor Detail

HeaderTokenizer

public HeaderTokenizer(String header,
                       String delimiters,
                       boolean skipComments)
Constructor that takes a rfc822 style header.

Parameters:
header - The rfc822 header to be tokenized
delimiters - Set of delimiter characters to be used to delimit ATOMS. These are usually RFC822 or MIME
skipComments - If true, comments are skipped and not returned as tokens

HeaderTokenizer

public HeaderTokenizer(String header,
                       String delimiters)
Constructor. Comments are ignored and not returned as tokens

Parameters:
header - The header that is tokenized
delimiters - The delimiters to be used

HeaderTokenizer

public HeaderTokenizer(String header)
Constructor. The RFC822 defined delimiters - RFC822 - are used to delimit ATOMS. Also comments are skipped and not returned as tokens

Method Detail

next

public HeaderTokenizer.Token next()
                           throws ParseException
Parses the next token from this String.

Clients sit in a loop calling next() to parse successive tokens until an EOF Token is returned.

Returns:
the next Token
Throws:
ParseException - if the parse fails

peek

public HeaderTokenizer.Token peek()
                           throws ParseException
Peek at the next token, without actually removing the token from the parse stream. Invoking this method multiple times will return successive tokens, until next() is called.

Returns:
the next Token
Throws:
ParseException - if the parse fails

getRemainder

public String getRemainder()
Return the rest of the Header.

Returns:
String rest of header. null is returned if we are already at end of header
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HeaderTokenizer.Token

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class HeaderTokenizer.Token

java.lang.Object
    extended by  javax.mail.internet.HeaderTokenizer.Token
Enclosing class:
HeaderTokenizer
public static class HeaderTokenizer.Token
extends Object

The Token class represents tokens returned by the HeaderTokenizer.

Field Summary
static int | ATOM Token type indicating an ATOM.
static int | COMMENT Token type indicating a comment.
static int | EOF Token type indicating end of input.
static int | QUOTEDSTRING Token type indicating a quoted string.
Constructor Summary
HeaderTokenizer.Token(int type, String value)
Constructor.
Method Summary
int | getType() Return the type of the token.
String | getValue() Returns the value of the token just read.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ATOM

public static final int ATOM
Token type indicating an ATOM.

See Also:
Constant Field Values

QUOTEDSTRING

public static final int QUOTEDSTRING
Token type indicating a quoted string. The value field contains the string without the quotes.

See Also:
Constant Field Values

COMMENT

public static final int COMMENT
Token type indicating a comment. The value field contains the comment string without the comment start and end symbols.

See Also:
Constant Field Values

EOF

public static final int EOF
Token type indicating end of input.

See Also:
Constant Field Values
Constructor Detail

HeaderTokenizer.Token

public HeaderTokenizer.Token(int type,
                             String value)
Constructor.

Parameters:
type - Token type
value - Token value
Method Detail

getType

public int getType()
Return the type of the token. If the token represents a delimiter or a control character, the type is that character itself, converted to an integer. Otherwise, it's value is one of the following:
  • ATOM A sequence of ASCII characters delimited by either SPACE, CTL, "(", <"> or the specified SPECIALS
  • QUOTEDSTRING A sequence of ASCII characters within quotes
  • COMMENT A sequence of ASCII characters within "(" and ")".
  • EOF End of header

getValue

public String getValue()
Returns the value of the token just read. When the current token is a quoted string, this field contains the body of the string, without the quotes. When the current token is a comment, this field contains the body of the comment.

Returns:
token value
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InternetAddress

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class InternetAddress

java.lang.Object
    extended by  javax.mail.Address
        extended by  javax.mail.internet.InternetAddress
All Implemented Interfaces:
Serializable, Cloneable
public class InternetAddress
extends Address
implements Cloneable

This class represents an Internet email address using the syntax of RFC822. Typical address syntax is of the form "user@host.domain" or "Personal Name ".

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected String | address
protected String | encodedPersonal The RFC 2047 encoded version of the personal name.
protected String | personal The personal name.
Constructor Summary
InternetAddress()
Default constructor.
InternetAddress(String address)
Constructor.
InternetAddress(String address, boolean strict)
Parse the given string and create an InternetAddress.
InternetAddress(String address, String personal)
Construct an InternetAddress given the address and personal name.
InternetAddress(String address, String personal, String charset)
Construct an InternetAddress given the address and personal name.
Method Summary
Object | clone() Return a copy of this InternetAddress object.
boolean | equals(Object a) The equality operator.
String | getAddress() Get the email address.
InternetAddress[] | getGroup(boolean strict) Return the members of a group address.
static InternetAddress | getLocalAddress(Session session) Return an InternetAddress object representing the current user.
String | getPersonal() Get the personal name.
String | getType() Return the type of this address.
int | hashCode() Compute a hash code for the address.
boolean | isGroup() Indicates whether this address is an RFC 822 group address.
static InternetAddress[] | parse(String addresslist) Parse the given comma separated sequence of addresses into InternetAddress objects.
static InternetAddress[] | parse(String addresslist, boolean strict) Parse the given sequence of addresses into InternetAddress objects.
static InternetAddress[] | parseHeader(String addresslist, boolean strict) Parse the given sequence of addresses into InternetAddress objects.
void | setAddress(String address) Set the email address.
void | setPersonal(String name) Set the personal name.
void | setPersonal(String name, String charset) Set the personal name.
String | toString() Convert this address into a RFC 822 / RFC 2047 encoded address.
static String | toString(Address[] addresses) Convert the given array of InternetAddress objects into a comma separated sequence of address strings.
static String | toString(Address[] addresses, int used) Convert the given array of InternetAddress objects into a comma separated sequence of address strings.
String | toUnicodeString() Returns a properly formatted address (RFC 822 syntax) of Unicode characters.
void | validate() Validate that this address conforms to the syntax rules of RFC 822.
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

address

protected String address

personal

protected String personal
The personal name.

encodedPersonal

protected String encodedPersonal
The RFC 2047 encoded version of the personal name.

This field and the personal field track each other, so if a subclass sets one of these fields directly, it should set the other to null, so that it is suitably recomputed.

Constructor Detail

InternetAddress

public InternetAddress()
Default constructor.

InternetAddress

public InternetAddress(String address)
                throws AddressException
Constructor.

Parse the given string and create an InternetAddress. See the parse method for details of the parsing. The address is parsed using "strict" parsing. This constructor does not perform the additional syntax checks that the InternetAddress(String address, boolean strict) constructor does when strict is true. This constructor is equivalent to InternetAddress(address, false).

Parameters:
address - the address in RFC822 format
Throws:
AddressException - if the parse failed

InternetAddress

public InternetAddress(String address,
                       boolean strict)
                throws AddressException
Parse the given string and create an InternetAddress. If strict is false, the detailed syntax of the address isn't checked.

Parameters:
address - the address in RFC822 format
strict - enforce RFC822 syntax
Throws:
AddressException - if the parse failed
Since:
JavaMail 1.3

InternetAddress

public InternetAddress(String address,
                       String personal)
                throws UnsupportedEncodingException
Construct an InternetAddress given the address and personal name. The address is assumed to be a syntactically valid RFC822 address.

Parameters:
address - the address in RFC822 format
personal - the personal name
Throws:
UnsupportedEncodingException

InternetAddress

public InternetAddress(String address,
                       String personal,
                       String charset)
                throws UnsupportedEncodingException
Construct an InternetAddress given the address and personal name. The address is assumed to be a syntactically valid RFC822 address.

Parameters:
address - the address in RFC822 format
personal - the personal name
charset - the MIME charset for the name
Throws:
UnsupportedEncodingException
Method Detail

clone

public Object clone()
Return a copy of this InternetAddress object.

Overrides:
clone in class Object
Since:
JavaMail 1.2

getType

public String getType()
Return the type of this address. The type of an InternetAddress is "rfc822".

Specified by:
getType in class Address
Returns:
address type
See Also:
InternetAddress

setAddress

public void setAddress(String address)
Set the email address.

Parameters:
address - email address

setPersonal

public void setPersonal(String name,
                        String charset)
                 throws UnsupportedEncodingException
Set the personal name. If the name contains non US-ASCII characters, then the name will be encoded using the specified charset as per RFC 2047. If the name contains only US-ASCII characters, no encoding is done and the name is used as is.

Parameters:
name - personal name
charset - MIME charset to be used to encode the name as per RFC 2047
Throws:
UnsupportedEncodingException - if the charset encoding fails.
See Also:
setPersonal(String)

setPersonal

public void setPersonal(String name)
                 throws UnsupportedEncodingException
Set the personal name. If the name contains non US-ASCII characters, then the name will be encoded using the platform's default charset. If the name contains only US-ASCII characters, no encoding is done and the name is used as is.

Parameters:
name - personal name
Throws:
UnsupportedEncodingException - if the charset encoding fails.
See Also:
setPersonal(String name, String charset)

getAddress

public String getAddress()
Get the email address.

Returns:
email address

getPersonal

public String getPersonal()
Get the personal name. If the name is encoded as per RFC 2047, it is decoded and converted into Unicode. If the decoding or conversion fails, the raw data is returned as is.

Returns:
personal name

toString

public String toString()
Convert this address into a RFC 822 / RFC 2047 encoded address. The resulting string contains only US-ASCII characters, and hence is mail-safe.

Specified by:
toString in class Address
Returns:
possibly encoded address string

toUnicodeString

public String toUnicodeString()
Returns a properly formatted address (RFC 822 syntax) of Unicode characters.

Returns:
Unicode address string
Since:
JavaMail 1.2

equals

public boolean equals(Object a)
The equality operator.

Specified by:
equals in class Address
Parameters:
a - Address object

hashCode

public int hashCode()
Compute a hash code for the address.

Overrides:
hashCode in class Object

toString

public static String toString(Address[] addresses)
Convert the given array of InternetAddress objects into a comma separated sequence of address strings. The resulting string contains only US-ASCII characters, and hence is mail-safe.

Parameters:
addresses - array of InternetAddress objects
Returns:
comma separated string of addresses
Throws:
ClassCastException, - if any address object in the given array is not an InternetAddress object. Note that this is a RuntimeException.

toString

public static String toString(Address[] addresses,
                              int used)
Convert the given array of InternetAddress objects into a comma separated sequence of address strings. The resulting string contains only US-ASCII characters, and hence is mail-safe.

The 'used' parameter specifies the number of character positions already taken up in the field into which the resulting address sequence string is to be inserted. It is used to determine the line-break positions in the resulting address sequence string.

Parameters:
addresses - array of InternetAddress objects
used - number of character positions already used, in the field into which the address string is to be inserted.
Returns:
comma separated string of addresses
Throws:
ClassCastException, - if any address object in the given array is not an InternetAddress object. Note that this is a RuntimeException.

getLocalAddress

public static InternetAddress getLocalAddress(Session session)
Return an InternetAddress object representing the current user. The entire email address may be specified in the "mail.from" property. If not set, the "mail.user" and "mail.host" properties are tried. If those are not set, the "user.name" property and InetAddress.getLocalHost method are tried. Security exceptions that may occur while accessing this information are ignored. If it is not possible to determine an email address, null is returned.

Parameters:
session - Session object used for property lookup
Returns:
current user's email address

parse

public static InternetAddress[] parse(String addresslist)
                               throws AddressException
Parse the given comma separated sequence of addresses into InternetAddress objects. Addresses must follow RFC822 syntax.

Parameters:
addresslist - comma separated address strings
Returns:
array of InternetAddress objects
Throws:
AddressException - if the parse failed

parse

public static InternetAddress[] parse(String addresslist,
                                      boolean strict)
                               throws AddressException
Parse the given sequence of addresses into InternetAddress objects. If strict is false, simple email addresses separated by spaces are also allowed. If strict is true, many (but not all) of the RFC822 syntax rules are enforced. In particular, even if strict is true, addresses composed of simple names (with no "@domain" part) are allowed. Such "illegal" addresses are not uncommon in real messages.

Non-strict parsing is typically used when parsing a list of mail addresses entered by a human. Strict parsing is typically used when parsing address headers in mail messages.

Parameters:
addresslist - comma separated address strings
strict - enforce RFC822 syntax
Returns:
array of InternetAddress objects
Throws:
AddressException - if the parse failed

parseHeader

public static InternetAddress[] parseHeader(String addresslist,
                                            boolean strict)
                                     throws AddressException
Parse the given sequence of addresses into InternetAddress objects. If strict is false, the full syntax rules for individual addresses are not enforced. If strict is true, many (but not all) of the RFC822 syntax rules are enforced.

To better support the range of "invalid" addresses seen in real messages, this method enforces fewer syntax rules than the parse method when the strict flag is false and enforces more rules when the strict flag is true. If the strict flag is false and the parse is successful in separating out an email address or addresses, the syntax of the addresses themselves is not checked.

Parameters:
addresslist - comma separated address strings
strict - enforce RFC822 syntax
Returns:
array of InternetAddress objects
Throws:
AddressException - if the parse failed
Since:
JavaMail 1.3

validate

public void validate()
              throws AddressException
Validate that this address conforms to the syntax rules of RFC 822. The current implementation checks many, but not all, syntax rules. Note that even though the syntax of the address may be correct, there's no guarantee that a mailbox of that name exists.

Throws:
AddressException - if the address isn't valid.
Since:
JavaMail 1.3

isGroup

public boolean isGroup()
Indicates whether this address is an RFC 822 group address. Note that a group address is different than the mailing list addresses supported by most mail servers. Group addresses are rarely used; see RFC 822 for details.

Returns:
true if this address represents a group
Since:
JavaMail 1.3

getGroup

public InternetAddress[] getGroup(boolean strict)
                           throws AddressException
Return the members of a group address. A group may have zero, one, or more members. If this address is not a group, null is returned. The strict parameter controls whether the group list is parsed using strict RFC 822 rules or not. The parsing is done using the parseHeader method.

Returns:
array of InternetAddress objects, or null
Throws:
AddressException - if the group list can't be parsed
Since:
JavaMail 1.3
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InternetHeaders

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class InternetHeaders

java.lang.Object
    extended by  javax.mail.internet.InternetHeaders

public class InternetHeaders
extends Object

InternetHeaders is a utility class that manages RFC822 style headers. Given an RFC822 format message stream, it reads lines until the blank line that indicates end of header. The input stream is positioned at the start of the body. The lines are stored within the object and can be extracted as either Strings or Header objects.

This class is mostly intended for service providers. MimeMessage and MimeBody use this class for holding their headers.

A note on RFC822 and MIME headers

RFC822 and MIME header fields must contain only US-ASCII characters. If a header contains non US-ASCII characters, it must be encoded as per the rules in RFC 2047. The MimeUtility class provided in this package can be used to to achieve this. Callers of the setHeader, addHeader, and addHeaderLine methods are responsible for enforcing the MIME requirements for the specified headers. In addition, these header fields must be folded (wrapped) before being sent if they exceed the line length limitation for the transport (1000 bytes for SMTP). Received headers may have been folded. The application is responsible for folding and unfolding headers as appropriate.

Author:
John Mani, Bill Shannon
See Also:
MimeUtility

Nested Class Summary
protected static class InternetHeaders.InternetHeader
An individual internet header.
Field Summary
protected  List headers
The actual list of Headers, including placeholder entries.
Constructor Summary
InternetHeaders()
Create an empty InternetHeaders object.
InternetHeaders(InputStream is)
Read and parse the given RFC822 message stream till the blank line separating the header from the body.
Method Summary
void | addHeader(String name, String value) Add a header with the specified name and value to the header list.
void | addHeaderLine(String line) Add an RFC822 header line to the header store.
Enumeration | getAllHeaderLines() Return all the header lines as an Enumeration of Strings.
Enumeration | getAllHeaders() Return all the headers as an Enumeration of Header objects.
String[] | getHeader(String name) Return all the values for the specified header.
String | getHeader(String name, String delimiter) Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
Enumeration | getMatchingHeaderLines(String[] names) Return all matching header lines as an Enumeration of Strings.
Enumeration | getMatchingHeaders(String[] names) Return all matching Header objects.
Enumeration | getNonMatchingHeaderLines(String[] names) Return all non-matching header lines
Enumeration | getNonMatchingHeaders(String[] names) Return all non-matching Header objects.
void | load(InputStream is) Read and parse the given RFC822 message stream till the blank line separating the header from the body.
void | removeHeader(String name) Remove all header entries that match the given name
void | setHeader(String name, String value) Change the first header line that matches name to have value, adding a new header if no existing header matches.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

headers

protected List headers
The actual list of Headers, including placeholder entries. Placeholder entries are Headers with a null value and are never seen by clients of the InternetHeaders class. Placeholder entries are used to keep track of the preferred order of headers. Headers are never actually removed from the list, they're converted into placeholder entries. New headers are added after existing headers of the same name (or before in the case of Received and Return-Path headers). If no existing header or placeholder for the header is found, new headers are added after the special placeholder with the name ":".

Since:
JavaMail 1.4
Constructor Detail

InternetHeaders

public InternetHeaders()
Create an empty InternetHeaders object. Placeholder entries are inserted to indicate the preferred order of headers.

InternetHeaders

public InternetHeaders(InputStream is)
                throws MessagingException
Read and parse the given RFC822 message stream till the blank line separating the header from the body. The input stream is left positioned at the start of the body. The header lines are stored internally.

For efficiency, wrap a BufferedInputStream around the actual input stream and pass it as the parameter.

No placeholder entries are inserted; the original order of the headers is preserved.

Parameters:
is - RFC822 input stream
Throws:
MessagingException
Method Detail

load

public void load(InputStream is)
          throws MessagingException
Read and parse the given RFC822 message stream till the blank line separating the header from the body. Store the header lines inside this InternetHeaders object. The order of header lines is preserved.

Note that the header lines are added into this InternetHeaders object, so any existing headers in this object will not be affected. Headers are added to the end of the existing list of headers, in order.

Parameters:
is - RFC822 input stream
Throws:
MessagingException

getHeader

public String[] getHeader(String name)
Return all the values for the specified header. The values are String objects. Returns null if no headers with the specified name exist.

Parameters:
name - header name
Returns:
array of header values, or null if none

getHeader

public String getHeader(String name,
                        String delimiter)
Get all the headers for this header name, returned as a single String, with headers separated by the delimiter. If the delimiter is null, only the first header is returned. Returns null if no headers with the specified name exist.

Parameters:
name - header name
delimiter - delimiter
Returns:
the value fields for all headers with this name, or null if none

setHeader

public void setHeader(String name,
                      String value)
Change the first header line that matches name to have value, adding a new header if no existing header matches. Remove all matching headers but the first.

Note that RFC822 headers can only contain US-ASCII characters

Parameters:
name - header name
value - header value

addHeader

public void addHeader(String name,
                      String value)
Add a header with the specified name and value to the header list.

The current implementation knows about the preferred order of most well-known headers and will insert headers in that order. In addition, it knows that Received headers should be inserted in reverse order (newest before oldest), and that they should appear at the beginning of the headers, preceeded only by a possible Return-Path header.

Note that RFC822 headers can only contain US-ASCII characters.

Parameters:
name - header name
value - header value

removeHeader

public void removeHeader(String name)
Remove all header entries that match the given name

Parameters:
name - header name

getAllHeaders

public Enumeration getAllHeaders()
Return all the headers as an Enumeration of Header objects.

Returns:
Header objects

getMatchingHeaders

public Enumeration getMatchingHeaders(String[] names)
Return all matching Header objects.

Returns:
matching Header objects

getNonMatchingHeaders

public Enumeration getNonMatchingHeaders(String[] names)
Return all non-matching Header objects.

Returns:
non-matching Header objects

addHeaderLine

public void addHeaderLine(String line)
Add an RFC822 header line to the header store. If the line starts with a space or tab (a continuation line), add it to the last header line in the list. Otherwise, append the new header line to the list.

Note that RFC822 headers can only contain US-ASCII characters

Parameters:
line - raw RFC822 header line

getAllHeaderLines

public Enumeration getAllHeaderLines()
Return all the header lines as an Enumeration of Strings.

getMatchingHeaderLines

public Enumeration getMatchingHeaderLines(String[] names)
Return all matching header lines as an Enumeration of Strings.

getNonMatchingHeaderLines

public Enumeration getNonMatchingHeaderLines(String[] names)
Return all non-matching header lines

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InternetHeaders.InternetHeader

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class InternetHeaders.InternetHeader

java.lang.Object
    extended by  javax.mail.Header
        extended by  javax.mail.internet.InternetHeaders.InternetHeader
Enclosing class:
InternetHeaders
protected static final class InternetHeaders.InternetHeader
extends Header

An individual internet header. This class is only used by subclasses of InternetHeaders.

An InternetHeader object with a null value is used as a placeholder for headers of that name, to preserve the order of headers. A placeholder InternetHeader object with a name of ":" marks the location in the list of headers where new headers are added by default.

Since:
JavaMail 1.4

Field Summary
Fields inherited from class javax.mail.Header
name, value
Constructor Summary
InternetHeaders.InternetHeader(String l)
Constructor that takes a line and splits out the header name.
InternetHeaders.InternetHeader(String n, String v)
Constructor that takes a header name and value.
Method Summary
 String getValue()
Return the "value" part of the header line.
Methods inherited from class javax.mail.Header
getName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InternetHeaders.InternetHeader

public InternetHeaders.InternetHeader(String l)
Constructor that takes a line and splits out the header name.

InternetHeaders.InternetHeader

public InternetHeaders.InternetHeader(String n,
                                      String v)
Constructor that takes a header name and value.

Method Detail

getValue

public String getValue()
Return the "value" part of the header line.

Overrides:
getValue in class Header
Returns:
value of the header
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MailDateFormat

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MailDateFormat

java.lang.Object
    extended by  java.text.Format
        extended by  java.text.DateFormat
            extended by  java.text.SimpleDateFormat
                extended by  javax.mail.internet.MailDateFormat
All Implemented Interfaces:
Serializable, Cloneable
public class MailDateFormat
extends SimpleDateFormat

Formats and parses date specification based on the draft-ietf-drums-msg-fmt-08 dated January 26, 2000. This is a followup spec to RFC822.

This class does not take pattern strings. It always formats the date based on the specification below.

3.3 Date and Time Specification

Date and time occur in several header fields of a message. This section specifies the syntax for a full date and time specification. Though folding whitespace is permitted throughout the date-time specification, it is recommended that only a single space be used where FWS is required and no space be used where FWS is optional in the date-time specification; some older implementations may not interpret other occurrences of folding whitespace correctly.

date-time = [ day-of-week "," ] date FWS time [CFWS]

day-of-week = ([FWS] day-name) / obs-day-of-week

day-name = "Mon" / "Tue" / "Wed" / "Thu" / "Fri" / "Sat" / "Sun"

date = day month year

year = 4*DIGIT / obs-year

month = (FWS month-name FWS) / obs-month

month-name = "Jan" / "Feb" / "Mar" / "Apr" /
             "May" / "Jun" / "Jul" / "Aug" /
             "Sep" / "Oct" / "Nov" / "Dec"

day = ([FWS] 1*2DIGIT) / obs-day

time = time-of-day FWS zone

time-of-day = hour ":" minute [ ":" second ]

hour = 2DIGIT / obs-hour

minute = 2DIGIT / obs-minute

second = 2DIGIT / obs-second

zone = (( "+" / "-" ) 4DIGIT) / obs-zone

The day is the numeric day of the month. The year is any numeric year in the common era.

The time-of-day specifies the number of hours, minutes, and optionally seconds since midnight of the date indicated.

The date and time-of-day SHOULD express local time.

The zone specifies the offset from Coordinated Universal Time (UTC, formerly referred to as "Greenwich Mean Time") that the date and time-of-day represent. The "+" or "-" indicates whether the time-of-day is ahead of or behind Universal Time. The first two digits indicate the number of hours difference from Universal Time, and the last two digits indicate the number of minutes difference from Universal Time. (Hence, +hhmm means +(hh * 60 + mm) minutes, and -hhmm means -(hh * 60 + mm) minutes). The form "+0000" SHOULD be used to indicate a time zone at Universal Time. Though "-0000" also indicates Universal Time, it is used to indicate that the time was generated on a system that may be in a local time zone other than Universal Time.

A date-time specification MUST be semantically valid. That is, the day-of-the week (if included) MUST be the day implied by the date, the numeric day-of-month MUST be between 1 and the number of days allowed for the specified month (in the specified year), the time-of-day MUST be in the range 00:00:00 through 23:59:60 (the number of seconds allowing for a leap second; see [STD-12]), and the zone MUST be within the range -9959 through +9959.

Since:
JavaMail 1.2
Author:
Max Spivak
See Also:
Serialized Form

Nested Class Summary
Nested classes/interfaces inherited from class java.text.DateFormat
DateFormat.Field
Field Summary
Fields inherited from class java.text.DateFormat
AM_PM_FIELD, calendar, DATE_FIELD, DAY_OF_WEEK_FIELD, DAY_OF_WEEK_IN_MONTH_FIELD, DAY_OF_YEAR_FIELD, DEFAULT, ERA_FIELD, FULL, HOUR_OF_DAY0_FIELD, HOUR_OF_DAY1_FIELD, HOUR0_FIELD, HOUR1_FIELD, LONG, MEDIUM, MILLISECOND_FIELD, MINUTE_FIELD, MONTH_FIELD, numberFormat, SECOND_FIELD, SHORT, TIMEZONE_FIELD, WEEK_OF_MONTH_FIELD, WEEK_OF_YEAR_FIELD, YEAR_FIELD
Constructor Summary
MailDateFormat()
Method Summary
StringBuffer | format(Date date, StringBuffer dateStrBuf, FieldPosition fieldPosition) Formats the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.
Date | parse(String text, ParsePosition pos) Parses the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.
void | setCalendar(Calendar newCalendar) Don't allow setting the calendar
void | setNumberFormat(NumberFormat newNumberFormat) Don't allow setting the NumberFormat
Methods inherited from class java.text.SimpleDateFormat
applyLocalizedPattern, applyPattern, clone, equals, formatToCharacterIterator, get2DigitYearStart, getDateFormatSymbols, hashCode, set2DigitYearStart, setDateFormatSymbols, toLocalizedPattern, toPattern
Methods inherited from class java.text.DateFormat
format, format, getAvailableLocales, getCalendar, getDateInstance, getDateInstance, getDateInstance, getDateTimeInstance, getDateTimeInstance, getDateTimeInstance, getInstance, getNumberFormat, getTimeInstance, getTimeInstance, getTimeInstance, getTimeZone, isLenient, parse, parseObject, setLenient, setTimeZone
Methods inherited from class java.text.Format
format, parseObject
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MailDateFormat

public MailDateFormat()
Method Detail

format

public StringBuffer format(Date date,
                           StringBuffer dateStrBuf,
                           FieldPosition fieldPosition)
Formats the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.

Overrides:
format in class SimpleDateFormat
Parameters:
date - the Date object
dateStrBuf - the formatted string
fieldPosition - the current field position
Returns:
StringBuffer the formatted String
Since:
JavaMail 1.2

parse

public Date parse(String text,
                  ParsePosition pos)
Parses the given date in the format specified by draft-ietf-drums-msg-fmt-08 in the current TimeZone.

Overrides:
parse in class SimpleDateFormat
Parameters:
text - the formatted date to be parsed
pos - the current parse position
Returns:
Date the parsed date in a Date object
Since:
JavaMail 1.2

setCalendar

public void setCalendar(Calendar newCalendar)
Don't allow setting the calendar

Overrides:
setCalendar in class DateFormat

setNumberFormat

public void setNumberFormat(NumberFormat newNumberFormat)
Don't allow setting the NumberFormat

Overrides:
setNumberFormat in class DateFormat
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MimeBodyPart

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MimeBodyPart

java.lang.Object
    extended by  javax.mail.BodyPart
        extended by  javax.mail.internet.MimeBodyPart
All Implemented Interfaces:
MimePart, Part
Direct Known Subclasses:
PreencodedMimeBodyPart
public class MimeBodyPart
extends BodyPart
implements MimePart

This class represents a MIME body part. It implements the BodyPart abstract class and the MimePart interface. MimeBodyParts are contained in MimeMultipart objects.

MimeBodyPart uses the InternetHeaders class to parse and store the headers of that body part.

A note on RFC 822 and MIME headers

RFC 822 header fields must contain only US-ASCII characters. MIME allows non ASCII characters to be present in certain portions of certain headers, by encoding those characters. RFC 2047 specifies the rules for doing this. The MimeUtility class provided in this package can be used to to achieve this. Callers of the setHeader, addHeader, and addHeaderLine methods are responsible for enforcing the MIME requirements for the specified headers. In addition, these header fields must be folded (wrapped) before being sent if they exceed the line length limitation for the transport (1000 bytes for SMTP). Received headers may have been folded. The application is responsible for folding and unfolding headers as appropriate.

Author:
John Mani, Bill Shannon, Kanwar Oberoi
See Also:
Part, MimePart, MimeUtility

Field Summary
protected byte[] | content Byte array that holds the bytes of the content of this Part.
protected InputStream | contentStream If the data for this body part was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this body part.
protected DataHandler | dh The DataHandler object representing this Part's content.
protected InternetHeaders | headers The InternetHeaders object that stores all the headers of this body part.
Fields inherited from class javax.mail.BodyPart
parent
Fields inherited from interface javax.mail.Part
ATTACHMENT, INLINE
Constructor Summary
MimeBodyPart()
An empty MimeBodyPart object is created.
MimeBodyPart(InputStream is)
Constructs a MimeBodyPart by reading and parsing the data from the specified input stream.
MimeBodyPart(InternetHeaders headers, byte[] content)
Constructs a MimeBodyPart using the given header and content bytes.
Method Summary
void | addHeader(String name, String value) Add this value to the existing values for this header_name.
void | addHeaderLine(String line) Add a header line to this body part
void | attachFile(File file) Use the specified file to provide the data for this part.
void | attachFile(String file) Use the specified file to provide the data for this part.
Enumeration | getAllHeaderLines() Get all header lines as an Enumeration of Strings.
Enumeration | getAllHeaders() Return all the headers from this Message as an Enumeration of Header objects.
Object | getContent() Return the content as a java object.
String | getContentID() Returns the value of the "Content-ID" header field.
String[] | getContentLanguage() Get the languages specified in the Content-Language header of this MimePart.
String | getContentMD5() Return the value of the "Content-MD5" header field.
protected InputStream | getContentStream() Produce the raw bytes of the content.
String | getContentType() Returns the value of the RFC 822 "Content-Type" header field.
DataHandler | getDataHandler() Return a DataHandler for this body part's content.
String | getDescription() Returns the "Content-Description" header field of this body part.
String | getDisposition() Returns the value of the "Content-Disposition" header field.
String | getEncoding() Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.
String | getFileName() Get the filename associated with this body part.
String[] | getHeader(String name) Get all the headers for this header_name.
String | getHeader(String name, String delimiter) Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
InputStream | getInputStream() Return a decoded input stream for this body part's "content".
int | getLineCount() Return the number of lines for the content of this Part.
Enumeration | getMatchingHeaderLines(String[] names) Get matching header lines as an Enumeration of Strings.
Enumeration | getMatchingHeaders(String[] names) Return matching headers from this Message as an Enumeration of Header objects.
Enumeration | getNonMatchingHeaderLines(String[] names) Get non-matching header lines as an Enumeration of Strings.
Enumeration | getNonMatchingHeaders(String[] names) Return non-matching headers from this Message as an Enumeration of Header objects.
InputStream | getRawInputStream() Return an InputStream to the raw data with any Content-Transfer-Encoding intact.
int | getSize() Return the size of the content of this body part in bytes.
boolean | isMimeType(String mimeType) Is this Part of the specified MIME type?
void | removeHeader(String name) Remove all headers with this name.
void | saveFile(File file) Save the contents of this part in the specified file.
void | saveFile(String file) Save the contents of this part in the specified file.
void | setContent(Multipart mp) This method sets the body part's content to a Multipart object.
void | setContent(Object o, String type) A convenience method for setting this body part's content.
void | setContentID(String cid) Set the "Content-ID" header field of this body part.
void | setContentLanguage(String[] languages) Set the Content-Language header of this MimePart.
void | setContentMD5(String md5) Set the "Content-MD5" header field of this body part.
void | setDataHandler(DataHandler dh) This method provides the mechanism to set this body part's content.
void | setDescription(String description) Set the "Content-Description" header field for this body part.
void | setDescription(String description, String charset) Set the "Content-Description" header field for this body part.
void | setDisposition(String disposition) Set the "Content-Disposition" header field of this body part.
void | setFileName(String filename) Set the filename associated with this body part, if possible.
void | setHeader(String name, String value) Set the value for this header_name.
void | setText(String text) Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".
void | setText(String text, String charset) Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.
void | setText(String text, String charset, String subtype) Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype.
protected void | updateHeaders() Examine the content of this body part and update the appropriate MIME headers.
void | writeTo(OutputStream os) Output the body part as an RFC 822 format stream.
Methods inherited from class javax.mail.BodyPart
getParent
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

dh

protected DataHandler dh
The DataHandler object representing this Part's content.

content

protected byte[] content
Byte array that holds the bytes of the content of this Part.

contentStream

protected InputStream contentStream
If the data for this body part was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this body part. In this case, content will be null.

Since:
JavaMail 1.2

headers

protected InternetHeaders headers
The InternetHeaders object that stores all the headers of this body part.

Constructor Detail

MimeBodyPart

public MimeBodyPart()
An empty MimeBodyPart object is created. This body part maybe filled in by a client constructing a multipart message.

MimeBodyPart

public MimeBodyPart(InputStream is)
             throws MessagingException
Constructs a MimeBodyPart by reading and parsing the data from the specified input stream. The parser consumes data till the end of the given input stream. The input stream must start at the beginning of a valid MIME body part and must terminate at the end of that body part.

Note that the "boundary" string that delimits body parts must not be included in the input stream. The intention is that the MimeMultipart parser will extract each body part's bytes from a multipart stream and feed them into this constructor, without the delimiter strings.

Parameters:
is - the body part Input Stream
Throws:
MessagingException

MimeBodyPart

public MimeBodyPart(InternetHeaders headers,
                    byte[] content)
             throws MessagingException
Constructs a MimeBodyPart using the given header and content bytes.

Used by providers.

Parameters:
headers - The header of this part
content - bytes representing the body of this part.
Throws:
MessagingException
Method Detail

getSize

public int getSize()
            throws MessagingException
Return the size of the content of this body part in bytes. Return -1 if the size cannot be determined.

Note that this number may not be an exact measure of the content size and may or may not account for any transfer encoding of the content.

This implementation returns the size of the content array (if not null), or, if contentStream is not null, and the available method returns a positive number, it returns that number as the size. Otherwise, it returns -1.

Specified by:
getSize in interface Part
Returns:
size in bytes, or -1 if not known
Throws:
MessagingException

getLineCount

public int getLineCount()
                 throws MessagingException
Return the number of lines for the content of this Part. Return -1 if this number cannot be determined.

Note that this number may not be an exact measure of the content length and may or may not account for any transfer encoding of the content.

This implementation returns -1.

Specified by:
getLineCount in interface Part
Returns:
number of lines, or -1 if not known
Throws:
MessagingException

getContentType

public String getContentType()
                      throws MessagingException
Returns the value of the RFC 822 "Content-Type" header field. This represents the content type of the content of this body part. This value must not be null. If this field is unavailable, "text/plain" should be returned.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getContentType in interface Part
Returns:
Content-Type of this body part
Throws:
MessagingException
See Also:
DataHandler

isMimeType

public boolean isMimeType(String mimeType)
                   throws MessagingException
Is this Part of the specified MIME type? This method compares only the primaryType and subType. The parameters of the content types are ignored.

For example, this method will return true when comparing a Part of content type "text/plain" with "text/plain; charset=foobar".

If the subType of mimeType is the special character '*', then the subtype is ignored during the comparison.

Specified by:
isMimeType in interface Part
Throws:
MessagingException

getDisposition

public String getDisposition()
                      throws MessagingException
Returns the value of the "Content-Disposition" header field. This represents the disposition of this part. The disposition describes how the part should be presented to the user.

If the Content-Disposition field is unavailable, null is returned.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getDisposition in interface Part
Returns:
disposition of this part, or null if unknown
Throws:
MessagingException
See Also:
headers

setDisposition

public void setDisposition(String disposition)
                    throws MessagingException
Set the "Content-Disposition" header field of this body part. If the disposition is null, any existing "Content-Disposition" header field is removed.

Specified by:
setDisposition in interface Part
Parameters:
disposition - disposition of this part
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException
See Also:
Part.ATTACHMENT, Part.INLINE, Part.setFileName(java.lang.String)

getEncoding

public String getEncoding()
                   throws MessagingException
Returns the content transfer encoding from the "Content-Transfer-Encoding" header field. Returns null if the header is unavailable or its value is absent.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getEncoding in interface MimePart
Returns:
content-transfer-encoding
Throws:
MessagingException
See Also:
headers

getContentID

public String getContentID()
                    throws MessagingException
Returns the value of the "Content-ID" header field. Returns null if the field is unavailable or its value is absent.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getContentID in interface MimePart
Returns:
content-ID
Throws:
MessagingException

setContentID

public void setContentID(String cid)
                  throws MessagingException
Set the "Content-ID" header field of this body part. If the cid parameter is null, any existing "Content-ID" is removed.

Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException
Since:
JavaMail 1.3

getContentMD5

public String getContentMD5()
                     throws MessagingException
Return the value of the "Content-MD5" header field. Returns null if this field is unavailable or its value is absent.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getContentMD5 in interface MimePart
Returns:
content-MD5
Throws:
MessagingException

setContentMD5

public void setContentMD5(String md5)
                   throws MessagingException
Set the "Content-MD5" header field of this body part.

Specified by:
setContentMD5 in interface MimePart
Parameters:
md5 - the MD5 value
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException

getContentLanguage

public String[] getContentLanguage()
                            throws MessagingException
Get the languages specified in the Content-Language header of this MimePart. The Content-Language header is defined by RFC 1766. Returns null if this header is not available or its value is absent.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getContentLanguage in interface MimePart
Throws:
MessagingException

setContentLanguage

public void setContentLanguage(String[] languages)
                        throws MessagingException
Set the Content-Language header of this MimePart. The Content-Language header is defined by RFC 1766.

Specified by:
setContentLanguage in interface MimePart
Parameters:
languages - array of language tags
Throws:
IllegalWriteException - if the underlying implementation does not support modification
MessagingException

getDescription

public String getDescription()
                      throws MessagingException
Returns the "Content-Description" header field of this body part. This typically associates some descriptive information with this part. Returns null if this field is unavailable or its value is absent.

If the Content-Description field is encoded as per RFC 2047, it is decoded and converted into Unicode. If the decoding or conversion fails, the raw data is returned as is.

This implementation uses getHeader(name) to obtain the requisite header field.

Specified by:
getDescription in interface Part
Returns:
content description
Throws:
MessagingException

setDescription

public void setDescription(String description)
                    throws MessagingException
Set the "Content-Description" header field for this body part. If the description parameter is null, then any existing "Content-Description" fields are removed.

If the description contains non US-ASCII characters, it will be encoded using the platform's default charset. If the description contains only US-ASCII characters, no encoding is done and it is used as is.

Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

Specified by:
setDescription in interface Part
Parameters:
description - content description
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException - otherwise; an UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.

setDescription

public void setDescription(String description,
                           String charset)
                    throws MessagingException
Set the "Content-Description" header field for this body part. If the description parameter is null, then any existing "Content-Description" fields are removed.

If the description contains non US-ASCII characters, it will be encoded using the specified charset. If the description contains only US-ASCII characters, no encoding is done and it is used as is.

Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

Parameters:
description - Description
charset - Charset for encoding
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException - otherwise; an UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.

getFileName

public String getFileName()
                   throws MessagingException
Get the filename associated with this body part.

Returns the value of the "filename" parameter from the "Content-Disposition" header field of this body part. If its not available, returns the value of the "name" parameter from the "Content-Type" header field of this body part. Returns null if both are absent.

If the mail.mime.encodefilename System property is set to true, the MimeUtility.decodeText method will be used to decode the filename. While such encoding is not supported by the MIME spec, many mailers use this technique to support non-ASCII characters in filenames. The default value of this property is false.

Specified by:
getFileName in interface Part
Returns:
filename
Throws:
MessagingException

setFileName

public void setFileName(String filename)
                 throws MessagingException
Set the filename associated with this body part, if possible.

Sets the "filename" parameter of the "Content-Disposition" header field of this body part. For compatibility with older mailers, the "name" parameter of the "Content-Type" header is also set.

If the mail.mime.encodefilename System property is set to true, the MimeUtility.encodeText method will be used to encode the filename. While such encoding is not supported by the MIME spec, many mailers use this technique to support non-ASCII characters in filenames. The default value of this property is false.

Specified by:
setFileName in interface Part
Parameters:
filename - Filename to associate with this part
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException

getInputStream

public InputStream getInputStream()
                           throws IOException,
                                  MessagingException
Return a decoded input stream for this body part's "content".

This implementation obtains the input stream from the DataHandler. That is, it invokes getDataHandler().getInputStream();

Specified by:
getInputStream in interface Part
Returns:
an InputStream
Throws:
MessagingException
IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
See Also:
getContentStream(), DataHandler.getInputStream()

getContentStream

protected InputStream getContentStream()
                                throws MessagingException
Produce the raw bytes of the content. This method is used when creating a DataHandler object for the content. Subclasses that can provide a separate input stream for just the Part content might want to override this method.

Throws:
MessagingException
See Also:
content, MimeMessage.getContentStream()

getRawInputStream

public InputStream getRawInputStream()
                              throws MessagingException
Return an InputStream to the raw data with any Content-Transfer-Encoding intact. This method is useful if the "Content-Transfer-Encoding" header is incorrect or corrupt, which would prevent the getInputStream method or getContent method from returning the correct data. In such a case the application may use this method and attempt to decode the raw data itself.

This implementation simply calls the getContentStream method.

Throws:
MessagingException
Since:
JavaMail 1.2
See Also:
getInputStream(), getContentStream()

getDataHandler

public DataHandler getDataHandler()
                           throws MessagingException
Return a DataHandler for this body part's content.

The implementation provided here works just like the the implementation in MimeMessage.

Specified by:
getDataHandler in interface Part
Returns:
DataHandler for the content
Throws:
MessagingException
See Also:
MimeMessage.getDataHandler()

getContent

public Object getContent()
                  throws IOException,
                         MessagingException
Return the content as a java object. The type of the object returned is of course dependent on the content itself. For example, the native format of a text/plain content is usually a String object. The native format for a "multipart" content is always a Multipart subclass. For content types that are unknown to the DataHandler system, an input stream is returned as the content.

This implementation obtains the content from the DataHandler. That is, it invokes getDataHandler().getContent(); If the content is a Multipart or Message object and was created by parsing a stream, the object is cached and returned in subsequent calls so that modifications to the content will not be lost.

Specified by:
getContent in interface Part
Returns:
Object
Throws:
MessagingException
IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
See Also:
DataHandler.getContent()

setDataHandler

public void setDataHandler(DataHandler dh)
                    throws MessagingException
This method provides the mechanism to set this body part's content. The given DataHandler object should wrap the actual content.

Specified by:
setDataHandler in interface Part
Parameters:
dh - The DataHandler for the content
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException

setContent

public void setContent(Object o,
                       String type)
                throws MessagingException
A convenience method for setting this body part's content.

The content is wrapped in a DataHandler object. Note that a DataContentHandler class for the specified type should be available to the JavaMail implementation for this to work right. That is, to do setContent(foobar, "application/x-foobar"), a DataContentHandler for "application/x-foobar" should be installed. Refer to the Java Activation Framework for more information.

Specified by:
setContent in interface Part
Parameters:
o - the content object
type - Mime type of the object
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException

setText

public void setText(String text)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a MIME type of "text/plain". If the string contains non US-ASCII characters, it will be encoded using the platform's default charset. The charset is also used to set the "charset" parameter.

Note that there may be a performance penalty if text is large, since this method may have to scan all the characters to determine what charset to use.

If the charset is already known, use the setText method that takes the charset parameter.

Specified by:
setText in interface MimePart
Specified by:
setText in interface Part
Parameters:
text - the text content to set
Throws:
MessagingException - if an error occurs
See Also:
setText(String text, String charset)

setText

public void setText(String text,
                    String charset)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set the "charset" parameter.

Specified by:
setText in interface MimePart
Parameters:
text - the text content to set
charset - the charset to use for the text
Throws:
MessagingException - if an error occurs

setText

public void setText(String text,
                    String charset,
                    String subtype)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set the "charset" parameter.

Specified by:
setText in interface MimePart
Parameters:
text - the text content to set
charset - the charset to use for the text
subtype - the MIME subtype to use (e.g., "html")
Throws:
MessagingException - if an error occurs
Since:
JavaMail 1.4

setContent

public void setContent(Multipart mp)
                throws MessagingException
This method sets the body part's content to a Multipart object.

Specified by:
setContent in interface Part
Parameters:
mp - The multipart object that is the Message's content
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values.
IllegalStateException - if this body part is obtained from a READ_ONLY folder.
MessagingException

attachFile

public void attachFile(File file)
                throws IOException,
                       MessagingException
Use the specified file to provide the data for this part. The simple file name is used as the file name for this part and the data in the file is used as the data for this part. The encoding will be chosen appropriately for the file data.

Parameters:
file - the File object to attach
Throws:
IOException - errors related to accessing the file
MessagingException - message related errors
Since:
JavaMail 1.4

attachFile

public void attachFile(String file)
                throws IOException,
                       MessagingException
Use the specified file to provide the data for this part. The simple file name is used as the file name for this part and the data in the file is used as the data for this part. The encoding will be chosen appropriately for the file data.

Parameters:
file - the name of the file to attach
Throws:
IOException - errors related to accessing the file
MessagingException - message related errors
Since:
JavaMail 1.4

saveFile

public void saveFile(File file)
              throws IOException,
                     MessagingException
Save the contents of this part in the specified file. The content is decoded and saved, without any of the MIME headers.

Parameters:
file - the File object to write to
Throws:
IOException - errors related to accessing the file
MessagingException - message related errors
Since:
JavaMail 1.4

saveFile

public void saveFile(String file)
              throws IOException,
                     MessagingException
Save the contents of this part in the specified file. The content is decoded and saved, without any of the MIME headers.

Parameters:
file - the name of the file to write to
Throws:
IOException - errors related to accessing the file
MessagingException - message related errors
Since:
JavaMail 1.4

writeTo

public void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
Output the body part as an RFC 822 format stream.

Specified by:
writeTo in interface Part
Throws:
MessagingException
IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
See Also:
DataHandler.writeTo(java.io.OutputStream)

getHeader

public String[] getHeader(String name)
                   throws MessagingException
Get all the headers for this header_name. Note that certain headers may be encoded as per RFC 2047 if they contain non US-ASCII characters and these should be decoded.

Specified by:
getHeader in interface Part
Parameters:
name - name of header
Returns:
array of headers
Throws:
MessagingException
See Also:
MimeUtility

getHeader

public String getHeader(String name,
                        String delimiter)
                 throws MessagingException
Get all the headers for this header name, returned as a single String, with headers separated by the delimiter. If the delimiter is null, only the first header is returned.

Specified by:
getHeader in interface MimePart
Parameters:
name - the name of this header
delimiter - delimiter between fields in returned string
Returns:
the value fields for all headers with this name
Throws:
MessagingException

setHeader

public void setHeader(String name,
                      String value)
               throws MessagingException
Set the value for this header_name. Replaces all existing header values with this new value. Note that RFC 822 headers must contain only US-ASCII characters, so a header that contains non US-ASCII characters must be encoded as per the rules of RFC 2047.

Specified by:
setHeader in interface Part
Parameters:
name - header name
value - header value
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
See Also:
MimeUtility

addHeader

public void addHeader(String name,
                      String value)
               throws MessagingException
Add this value to the existing values for this header_name. Note that RFC 822 headers must contain only US-ASCII characters, so a header that contains non US-ASCII characters must be encoded as per the rules of RFC 2047.

Specified by:
addHeader in interface Part
Parameters:
name - header name
value - header value
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
See Also:
MimeUtility

removeHeader

public void removeHeader(String name)
                  throws MessagingException
Remove all headers with this name.

Specified by:
removeHeader in interface Part
Parameters:
name - the name of this header
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values

getAllHeaders

public Enumeration getAllHeaders()
                          throws MessagingException
Return all the headers from this Message as an Enumeration of Header objects.

Specified by:
getAllHeaders in interface Part
Returns:
enumeration of Header objects
Throws:
MessagingException

getMatchingHeaders

public Enumeration getMatchingHeaders(String[] names)
                               throws MessagingException
Return matching headers from this Message as an Enumeration of Header objects.

Specified by:
getMatchingHeaders in interface Part
Returns:
enumeration of Header objects
Throws:
MessagingException

getNonMatchingHeaders

public Enumeration getNonMatchingHeaders(String[] names)
                                  throws MessagingException
Return non-matching headers from this Message as an Enumeration of Header objects.

Specified by:
getNonMatchingHeaders in interface Part
Returns:
enumeration of Header objects
Throws:
MessagingException

addHeaderLine

public void addHeaderLine(String line)
                   throws MessagingException
Add a header line to this body part

Specified by:
addHeaderLine in interface MimePart
Throws:
IllegalWriteException - if the underlying implementation does not support modification
MessagingException

getAllHeaderLines

public Enumeration getAllHeaderLines()
                              throws MessagingException
Get all header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header line, containing both the "name" and "value" field.

Specified by:
getAllHeaderLines in interface MimePart
Throws:
MessagingException

getMatchingHeaderLines

public Enumeration getMatchingHeaderLines(String[] names)
                                   throws MessagingException
Get matching header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header line, containing both the "name" and "value" field.

Specified by:
getMatchingHeaderLines in interface MimePart
Throws:
MessagingException

getNonMatchingHeaderLines

public Enumeration getNonMatchingHeaderLines(String[] names)
                                      throws MessagingException
Get non-matching header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header line, containing both the "name" and "value" field.

Specified by:
getNonMatchingHeaderLines in interface MimePart
Throws:
MessagingException

updateHeaders

protected void updateHeaders()
                      throws MessagingException
Examine the content of this body part and update the appropriate MIME headers. Typical headers that get set here are Content-Type and Content-Transfer-Encoding. Headers might need to be updated in two cases:
- A message being crafted by a mail application will certainly need to activate this method at some point to fill up its internal headers.
- A message read in from a Store will have obtained all its headers from the store, and so doesn't need this. However, if this message is editable and if any edits have been made to either the content or message structure, we might need to resync our headers.
In both cases this method is typically called by the Message.saveChanges method.

Throws:
MessagingException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MimeMessage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MimeMessage

java.lang.Object
    extended by  javax.mail.Message
        extended by  javax.mail.internet.MimeMessage
All Implemented Interfaces:
MimePart, Part
public class MimeMessage
extends Message
implements MimePart

This class represents a MIME style email message. It implements the Message abstract class and the MimePart interface.

Clients wanting to create new MIME style messages will instantiate an empty MimeMessage object and then fill it with appropriate attributes and content.

Service providers that implement MIME compliant backend stores may want to subclass MimeMessage and override certain methods to provide specific implementations. The simplest case is probably a provider that generates a MIME style input stream and leaves the parsing of the stream to this class.

MimeMessage uses the InternetHeaders class to parse and store the top level RFC 822 headers of a message.

The mail.mime.address.strict session property controls the parsing of address headers. By default, strict parsing of address headers is done. If this property is set to "false", strict parsing is not done and many illegal addresses that sometimes occur in real messages are allowed. See the InternetAddress class for details.

A note on RFC 822 and MIME headers

RFC 822 header fields must contain only US-ASCII characters. MIME allows non ASCII characters to be present in certain portions of certain headers, by encoding those characters. RFC 2047 specifies the rules for doing this. The MimeUtility class provided in this package can be used to to achieve this. Callers of the setHeader, addHeader, and addHeaderLine methods are responsible for enforcing the MIME requirements for the specified headers. In addition, these header fields must be folded (wrapped) before being sent if they exceed the line length limitation for the transport (1000 bytes for SMTP). Received headers may have been folded. The application is responsible for folding and unfolding headers as appropriate.

Author:
John Mani, Bill Shannon, Max Spivak, Kanwar Oberoi
See Also:
MimeUtility, Part, Message, MimePart, InternetAddress

Nested Class Summary
static class MimeMessage.RecipientType
This inner class extends the javax.mail.Message.RecipientType class to add additional RecipientTypes.
Field Summary
protected byte[] | content Byte array that holds the bytes of this Message's content.
protected InputStream | contentStream If the data for this message was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this message.
protected DataHandler | dh The DataHandler object representing this Message's content.
protected Flags | flags The Flags for this message.
protected InternetHeaders | headers The InternetHeaders object that stores the header of this message.
protected boolean | modified A flag indicating whether the message has been modified.
protected boolean | saved Does the saveChanges method need to be called on this message?
Fields inherited from class javax.mail.Message
expunged, folder, msgnum, session
Fields inherited from interface javax.mail.Part
ATTACHMENT, INLINE
Constructor Summary
protected | MimeMessage(Folder folder, InputStream is, int msgnum) Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream.
protected | MimeMessage(Folder folder, int msgnum) Constructs an empty MimeMessage object with the given Folder and message number.
protected | MimeMessage(Folder folder, InternetHeaders headers, byte[] content, int msgnum) Constructs a MimeMessage from the given InternetHeaders object and content.
 | MimeMessage(MimeMessage source) Constructs a new MimeMessage with content initialized from the source MimeMessage.
 | MimeMessage(Session session) Default constructor.
 | MimeMessage(Session session, InputStream is) Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream.
Method Summary
void | addFrom(Address[] addresses) Add the specified addresses to the existing "From" field.
void | addHeader(String name, String value) Add this value to the existing values for this header_name.
void | addHeaderLine(String line) Add a raw RFC 822 header-line.
void | addRecipients(Message.RecipientType type, Address[] addresses) Add the given addresses to the specified recipient type.
void | addRecipients(Message.RecipientType type, String addresses) Add the given addresses to the specified recipient type.
protected InternetHeaders | createInternetHeaders(InputStream is) Create and return an InternetHeaders object that loads the headers from the given InputStream.
protected MimeMessage | createMimeMessage(Session session) Create and return a MimeMessage object.
Enumeration | getAllHeaderLines() Get all header lines as an Enumeration of Strings.
Enumeration | getAllHeaders() Return all the headers from this Message as an enumeration of Header objects.
Address[] | getAllRecipients() Get all the recipient addresses for the message.
Object | getContent() Return the content as a Java object.
String | getContentID() Returns the value of the "Content-ID" header field.
String[] | getContentLanguage() Get the languages specified in the "Content-Language" header field of this message.
String | getContentMD5() Return the value of the "Content-MD5" header field.
protected InputStream | getContentStream() Produce the raw bytes of the content.
String | getContentType() Returns the value of the RFC 822 "Content-Type" header field.
DataHandler | getDataHandler() Return a DataHandler for this Message's content.
String | getDescription() Returns the "Content-Description" header field of this Message.
String | getDisposition() Returns the value of the "Content-Disposition" header field.
String | getEncoding() Returns the content transfer encoding from the "Content-Transfer-Encoding" header field.
String | getFileName() Get the filename associated with this Message.
Flags | getFlags() Return a Flags object containing the flags for this message.
Address[] | getFrom() Returns the value of the RFC 822 "From" header fields.
String[] | getHeader(String name) Get all the headers for this header_name.
String | getHeader(String name, String delimiter) Get all the headers for this header name, returned as a single String, with headers separated by the delimiter.
InputStream | getInputStream() Return a decoded input stream for this Message's "content".
int | getLineCount() Return the number of lines for the content of this message.
Enumeration | getMatchingHeaderLines(String[] names) Get matching header lines as an Enumeration of Strings.
Enumeration | getMatchingHeaders(String[] names) Return matching headers from this Message as an Enumeration of Header objects.
String | getMessageID() Returns the value of the "Message-ID" header field.
Enumeration | getNonMatchingHeaderLines(String[] names) Get non-matching header lines as an Enumeration of Strings.
Enumeration | getNonMatchingHeaders(String[] names) Return non-matching headers from this Message as an Enumeration of Header objects.
InputStream | getRawInputStream() Return an InputStream to the raw data with any Content-Transfer-Encoding intact.
Date | getReceivedDate() Returns the Date on this message was received.
Address[] | getRecipients(Message.RecipientType type) Returns the recepients specified by the type.
Address[] | getReplyTo() Return the value of the RFC 822 "Reply-To" header field.
Address | getSender() Returns the value of the RFC 822 "Sender" header field.
Date | getSentDate() Returns the value of the RFC 822 "Date" field.
int | getSize() Return the size of the content of this message in bytes.
String | getSubject() Returns the value of the "Subject" header field.
boolean | isMimeType(String mimeType) Is this Part of the specified MIME type?
boolean | isSet(Flags.Flag flag) Check whether the flag specified in the flag argument is set in this message.
protected void | parse(InputStream is) Parse the InputStream setting the headers and content fields appropriately.
void | removeHeader(String name) Remove all headers with this name.
Message | reply(boolean replyToAll) Get a new Message suitable for a reply to this message.
void | saveChanges() Updates the appropriate header fields of this message to be consistent with the message's contents.
void | setContent(Multipart mp) This method sets the Message's content to a Multipart object.
void | setContent(Object o, String type) A convenience method for setting this Message's content.
void | setContentID(String cid) Set the "Content-ID" header field of this Message.
void | setContentLanguage(String[] languages) Set the "Content-Language" header of this MimePart.
void | setContentMD5(String md5) Set the "Content-MD5" header field of this Message.
void | setDataHandler(DataHandler dh) This method provides the mechanism to set this part's content.
void | setDescription(String description) Set the "Content-Description" header field for this Message.
void | setDescription(String description, String charset) Set the "Content-Description" header field for this Message.
void | setDisposition(String disposition) Set the "Content-Disposition" header field of this Message.
void | setFileName(String filename) Set the filename associated with this part, if possible.
void | setFlags(Flags flag, boolean set) Set the flags for this message.
void | setFrom() Set the RFC 822 "From" header field using the value of the InternetAddress.getLocalAddress method.
void | setFrom(Address address) Set the RFC 822 "From" header field.
void | setHeader(String name, String value) Set the value for this header_name.
void | setRecipients(Message.RecipientType type, Address[] addresses) Set the specified recipient type to the given addresses.
void | setRecipients(Message.RecipientType type, String addresses) Set the specified recipient type to the given addresses.
void | setReplyTo(Address[] addresses) Set the RFC 822 "Reply-To" header field.
void | setSender(Address address) Set the RFC 822 "Sender" header field.
void | setSentDate(Date d) Set the RFC 822 "Date" header field.
void | setSubject(String subject) Set the "Subject" header field.
void | setSubject(String subject, String charset) Set the "Subject" header field.
void | setText(String text) Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".
void | setText(String text, String charset) Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.
void | setText(String text, String charset, String subtype) Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype.
protected void | updateHeaders() Called by the saveChanges method to actually update the MIME headers.
protected void | updateMessageID() Update the Message-ID header.
void | writeTo(OutputStream os) Output the message as an RFC 822 format stream.
void | writeTo(OutputStream os, String[] ignoreList) Output the message as an RFC 822 format stream, without specified headers.
Methods inherited from class javax.mail.Message
addRecipient, getFolder, getMessageNumber, isExpunged, match, setExpunged, setFlag, setMessageNumber, setRecipient
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

dh

protected DataHandler dh
The DataHandler object representing this Message's content.

content

protected byte[] content
Byte array that holds the bytes of this Message's content.

contentStream

protected InputStream contentStream
If the data for this message was supplied by an InputStream that implements the SharedInputStream interface, contentStream is another such stream representing the content of this message. In this case, content will be null.

Since:
JavaMail 1.2

headers

protected InternetHeaders headers
The InternetHeaders object that stores the header of this message.

flags

protected Flags flags
The Flags for this message.

modified

protected boolean modified
A flag indicating whether the message has been modified. If the message has not been modified, any data in the content array is assumed to be valid and is used directly in the writeTo method. This flag is set to true when an empty message is created or when the saveChanges method is called.

Since:
JavaMail 1.2

saved

protected boolean saved
Does the saveChanges method need to be called on this message? This flag is set to false by the public constructor and set to true by the saveChanges method. The writeTo method checks this flag and calls the saveChanges method as necessary. This avoids the common mistake of forgetting to call the saveChanges method on a newly constructed message.

Since:
JavaMail 1.2
Constructor Detail

MimeMessage

public MimeMessage(Session session)
Default constructor. An empty message object is created. The headers field is set to an empty InternetHeaders object. The flags field is set to an empty Flags object. The modified flag is set to true.

MimeMessage

public MimeMessage(Session session,
                   InputStream is)
            throws MessagingException
Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream. The InputStream will be left positioned at the end of the data for the message. Note that the input stream parse is done within this constructor itself.

The input stream contains an entire MIME formatted message with headers and data.

Parameters:
session - Session object for this message
is - the message input stream
Throws:
MessagingException

MimeMessage

public MimeMessage(MimeMessage source)
            throws MessagingException
Constructs a new MimeMessage with content initialized from the source MimeMessage. The new message is independent of the original.

Note: The current implementation is rather inefficient, copying the data more times than strictly necessary.

Parameters:
source - the message to copy content from
Throws:
MessagingException
Since:
JavaMail 1.2

MimeMessage

protected MimeMessage(Folder folder,
                      int msgnum)
Constructs an empty MimeMessage object with the given Folder and message number.

This method is for providers subclassing MimeMessage.

MimeMessage

protected MimeMessage(Folder folder,
                      InputStream is,
                      int msgnum)
               throws MessagingException
Constructs a MimeMessage by reading and parsing the data from the specified MIME InputStream. The InputStream will be left positioned at the end of the data for the message. Note that the input stream parse is done within this constructor itself.

This method is for providers subclassing MimeMessage.

Parameters:
folder - The containing folder.
is - the message input stream
msgnum - Message number of this message within its folder
Throws:
MessagingException

MimeMessage

protected MimeMessage(Folder folder,
                      InternetHeaders headers,
                      byte[] content,
                      int msgnum)
               throws MessagingException
Constructs a MimeMessage from the given InternetHeaders object and content. This method is for providers subclassing MimeMessage.

Parameters:
folder - The containing folder.
headers - The headers
content - The message content
msgnum - Message number of this message within its folder
Throws:
MessagingException
Method Detail

parse

protected void parse(InputStream is)
              throws MessagingException
Parse the InputStream setting the headers and content fields appropriately. Also resets the modified flag.

This method is intended for use by subclasses that need to control when the InputStream is parsed.

Parameters:
is - The message input stream
Throws:
MessagingException

getFrom

public Address[] getFrom()
                  throws MessagingException
Returns the value of the RFC 822 "From" header fields. If this header field is absent, the "Sender" header field is used. If the "Sender" header field is also absent, null is returned.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getFrom in class Message
Returns:
Address object
Throws:
MessagingException
See Also:
headers

setFrom

public void setFrom(Address address)
             throws MessagingException
Set the RFC 822 "From" header field. Any existing values are replaced with the given address. If address is null, this header is removed.

Specified by:
setFrom in class Message
Parameters:
address - the sender of this message
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

setFrom

public void setFrom()
             throws MessagingException
Set the RFC 822 "From" header field using the value of the InternetAddress.getLocalAddress method.

Specified by:
setFrom in class Message
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

addFrom

public void addFrom(Address[] addresses)
             throws MessagingException
Add the specified addresses to the existing "From" field. If the "From" field does not already exist, it is created.

Specified by:
addFrom in class Message
Parameters:
addresses - the senders of this message
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getSender

public Address getSender()
                  throws MessagingException
Returns the value of the RFC 822 "Sender" header field. If the "Sender" header field is absent, null is returned.

This implementation uses the getHeader method to obtain the requisite header field.

Returns:
Address object
Throws:
MessagingException
Since:
JavaMail 1.3
See Also:
headers

setSender

public void setSender(Address address)
               throws MessagingException
Set the RFC 822 "Sender" header field. Any existing values are replaced with the given address. If address is null, this header is removed.

Parameters:
address - the sender of this message
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
Since:
JavaMail 1.3

getRecipients

public Address[] getRecipients(Message.RecipientType type)
                        throws MessagingException
Returns the recepients specified by the type. The mapping between the type and the corresponding RFC 822 header is as follows:
                Message.RecipientType.TO                "To"
                Message.RecipientType.CC                "Cc"
                Message.RecipientType.BCC               "Bcc"
                MimeMessage.RecipientType.NEWSGROUPS    "Newsgroups"

Returns null if the header specified by the type is not found or if its value is empty.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getRecipients in class Message
Parameters:
type - Type of recepient
Returns:
array of Address objects
Throws:
MessagingException - if header could not be retrieved
AddressException - if the header is misformatted
See Also:
headers, Message.RecipientType.TO, Message.RecipientType.CC, Message.RecipientType.BCC, MimeMessage.RecipientType.NEWSGROUPS

getAllRecipients

public Address[] getAllRecipients()
                           throws MessagingException
Get all the recipient addresses for the message. Extracts the TO, CC, BCC, and NEWSGROUPS recipients.

Overrides:
getAllRecipients in class Message
Returns:
array of Address objects
Throws:
MessagingException
See Also:
Message.RecipientType.TO, Message.RecipientType.CC, Message.RecipientType.BCC, MimeMessage.RecipientType.NEWSGROUPS

setRecipients

public void setRecipients(Message.RecipientType type,
                          Address[] addresses)
                   throws MessagingException
Set the specified recipient type to the given addresses. If the address parameter is null, the corresponding recipient field is removed.

Specified by:
setRecipients in class Message
Parameters:
type - Recipient type
addresses - Addresses
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
See Also:
getRecipients(javax.mail.Message.RecipientType)

setRecipients

public void setRecipients(Message.RecipientType type,
                          String addresses)
                   throws MessagingException
Set the specified recipient type to the given addresses. If the address parameter is null, the corresponding recipient field is removed.

Parameters:
type - Recipient type
addresses - Addresses
Throws:
AddressException - if the attempt to parse the addresses String fails
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
Since:
JavaMail 1.2
See Also:
getRecipients(javax.mail.Message.RecipientType)

addRecipients

public void addRecipients(Message.RecipientType type,
                          Address[] addresses)
                   throws MessagingException
Add the given addresses to the specified recipient type.

Specified by:
addRecipients in class Message
Parameters:
type - Recipient type
addresses - Addresses
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

addRecipients

public void addRecipients(Message.RecipientType type,
                          String addresses)
                   throws MessagingException
Add the given addresses to the specified recipient type.

Parameters:
type - Recipient type
addresses - Addresses
Throws:
AddressException - if the attempt to parse the addresses String fails
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
Since:
JavaMail 1.2

getReplyTo

public Address[] getReplyTo()
                     throws MessagingException
Return the value of the RFC 822 "Reply-To" header field. If this header is unavailable or its value is absent, then the getFrom method is called and its value is returned. This implementation uses the getHeader method to obtain the requisite header field.

Overrides:
getReplyTo in class Message
Returns:
addresses to which replies should be directed
Throws:
MessagingException
See Also:
headers

setReplyTo

public void setReplyTo(Address[] addresses)
                throws MessagingException
Set the RFC 822 "Reply-To" header field. If the address parameter is null, this header is removed.

Overrides:
setReplyTo in class Message
Parameters:
addresses - addresses to which replies should be directed
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
MethodNotSupportedException - if the underlying implementation does not support setting this attribute

getSubject

public String getSubject()
                  throws MessagingException
Returns the value of the "Subject" header field. Returns null if the subject field is unavailable or its value is absent.

If the subject is encoded as per RFC 2047, it is decoded and converted into Unicode. If the decoding or conversion fails, the raw data is returned as is.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getSubject in class Message
Returns:
Subject
Throws:
MessagingException
See Also:
headers

setSubject

public void setSubject(String subject)
                throws MessagingException
Set the "Subject" header field. If the subject contains non US-ASCII characters, it will be encoded using the platform's default charset. If the subject contains only US-ASCII characters, no encoding is done and it is used as-is. If the subject is null, the existing "Subject" field is removed.

The application must ensure that the subject does not contain any line breaks.

Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

Specified by:
setSubject in class Message
Parameters:
subject - The subject
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException. - An UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.
MessagingException

setSubject

public void setSubject(String subject,
                       String charset)
                throws MessagingException
Set the "Subject" header field. If the subject contains non US-ASCII characters, it will be encoded using the specified charset. If the subject contains only US-ASCII characters, no encoding is done and it is used as-is. If the subject is null, the existing "Subject" header field is removed.

The application must ensure that the subject does not contain any line breaks.

Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

Parameters:
subject - The subject
charset - The charset
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException. - An UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.
MessagingException

getSentDate

public Date getSentDate()
                 throws MessagingException
Returns the value of the RFC 822 "Date" field. This is the date on which this message was sent. Returns null if this field is unavailable or its value is absent.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getSentDate in class Message
Returns:
The sent Date
Throws:
MessagingException

setSentDate

public void setSentDate(Date d)
                 throws MessagingException
Set the RFC 822 "Date" header field. This is the date on which the creator of the message indicates that the message is complete and ready for delivery. If the date parameter is null, the existing "Date" field is removed.

Specified by:
setSentDate in class Message
Parameters:
d - the sent date of this message
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getReceivedDate

public Date getReceivedDate()
                     throws MessagingException
Returns the Date on this message was received. Returns null if this date cannot be obtained.

Note that RFC 822 does not define a field for the received date. Hence only implementations that can provide this date need return a valid value.

This implementation returns null.

Specified by:
getReceivedDate in class Message
Returns:
the date this message was received
Throws:
MessagingException

getSize

public int getSize()
            throws MessagingException
Return the size of the content of this message in bytes. Return -1 if the size cannot be determined.

Note that this number may not be an exact measure of the content size and may or may not account for any transfer encoding of the content.

This implementation returns the size of the content array (if not null), or, if contentStream is not null, and the available method returns a positive number, it returns that number as the size. Otherwise, it returns -1.

Specified by:
getSize in interface Part
Returns:
size of content in bytes
Throws:
MessagingException

getLineCount

public int getLineCount()
                 throws MessagingException
Return the number of lines for the content of this message. Return -1 if this number cannot be determined.

Note that this number may not be an exact measure of the content length and may or may not account for any transfer encoding of the content.

This implementation returns -1.

Specified by:
getLineCount in interface Part
Returns:
number of lines in the content.
Throws:
MessagingException

getContentType

public String getContentType()
                      throws MessagingException
Returns the value of the RFC 822 "Content-Type" header field. This represents the content-type of the content of this message. This value must not be null. If this field is unavailable, "text/plain" should be returned.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getContentType in interface Part
Returns:
The ContentType of this part
Throws:
MessagingException
See Also:
DataHandler

isMimeType

public boolean isMimeType(String mimeType)
                   throws MessagingException
Is this Part of the specified MIME type? This method compares only the primaryType and subType. The parameters of the content types are ignored.

For example, this method will return true when comparing a Part of content type "text/plain" with "text/plain; charset=foobar".

If the subType of mimeType is the special character '*', then the subtype is ignored during the comparison.

Specified by:
isMimeType in interface Part
Throws:
MessagingException

getDisposition

public String getDisposition()
                      throws MessagingException
Returns the value of the "Content-Disposition" header field. This represents the disposition of this part. The disposition describes how the part should be presented to the user.

If the Content-Disposition field is unavailable, null is returned.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getDisposition in interface Part
Returns:
disposition of this part, or null if unknown
Throws:
MessagingException
See Also:
Part.ATTACHMENT, Part.INLINE, Part.getFileName()

setDisposition

public void setDisposition(String disposition)
                    throws MessagingException
Set the "Content-Disposition" header field of this Message. If disposition is null, any existing "Content-Disposition" header field is removed.

Specified by:
setDisposition in interface Part
Parameters:
disposition - disposition of this part
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
See Also:
Part.ATTACHMENT, Part.INLINE, Part.setFileName(java.lang.String)

getEncoding

public String getEncoding()
                   throws MessagingException
Returns the content transfer encoding from the "Content-Transfer-Encoding" header field. Returns null if the header is unavailable or its value is absent.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getEncoding in interface MimePart
Returns:
content-transfer-encoding
Throws:
MessagingException

getContentID

public String getContentID()
                    throws MessagingException
Returns the value of the "Content-ID" header field. Returns null if the field is unavailable or its value is absent.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getContentID in interface MimePart
Returns:
content-ID
Throws:
MessagingException

setContentID

public void setContentID(String cid)
                  throws MessagingException
Set the "Content-ID" header field of this Message. If the cid parameter is null, any existing "Content-ID" is removed.

Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getContentMD5

public String getContentMD5()
                     throws MessagingException
Return the value of the "Content-MD5" header field. Returns null if this field is unavailable or its value is absent.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getContentMD5 in interface MimePart
Returns:
content-MD5
Throws:
MessagingException

setContentMD5

public void setContentMD5(String md5)
                   throws MessagingException
Set the "Content-MD5" header field of this Message.

Specified by:
setContentMD5 in interface MimePart
Parameters:
md5 - the MD5 value
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getDescription

public String getDescription()
                      throws MessagingException
Returns the "Content-Description" header field of this Message. This typically associates some descriptive information with this part. Returns null if this field is unavailable or its value is absent.

If the Content-Description field is encoded as per RFC 2047, it is decoded and converted into Unicode. If the decoding or conversion fails, the raw data is returned as-is

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getDescription in interface Part
Returns:
content-description
Throws:
MessagingException

setDescription

public void setDescription(String description)
                    throws MessagingException
Set the "Content-Description" header field for this Message. If the description parameter is null, then any existing "Content-Description" fields are removed.

If the description contains non US-ASCII characters, it will be encoded using the platform's default charset. If the description contains only US-ASCII characters, no encoding is done and it is used as-is.

Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

Specified by:
setDescription in interface Part
Parameters:
description - content-description
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException. - An UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.
MessagingException

setDescription

public void setDescription(String description,
                           String charset)
                    throws MessagingException
Set the "Content-Description" header field for this Message. If the description parameter is null, then any existing "Content-Description" fields are removed.

If the description contains non US-ASCII characters, it will be encoded using the specified charset. If the description contains only US-ASCII characters, no encoding is done and it is used as-is.

Note that if the charset encoding process fails, a MessagingException is thrown, and an UnsupportedEncodingException is included in the chain of nested exceptions within the MessagingException.

Parameters:
description - Description
charset - Charset for encoding
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException. - An UnsupportedEncodingException may be included in the exception chain if the charset conversion fails.
MessagingException

getContentLanguage

public String[] getContentLanguage()
                            throws MessagingException
Get the languages specified in the "Content-Language" header field of this message. The Content-Language header is defined by RFC 1766. Returns null if this field is unavailable or its value is absent.

This implementation uses the getHeader method to obtain the requisite header field.

Specified by:
getContentLanguage in interface MimePart
Returns:
value of content-language header.
Throws:
MessagingException

setContentLanguage

public void setContentLanguage(String[] languages)
                        throws MessagingException
Set the "Content-Language" header of this MimePart. The Content-Language header is defined by RFC 1766.

Specified by:
setContentLanguage in interface MimePart
Parameters:
languages - array of language tags
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getMessageID

public String getMessageID()
                    throws MessagingException
Returns the value of the "Message-ID" header field. Returns null if this field is unavailable or its value is absent.

The default implementation provided here uses the getHeader method to return the value of the "Message-ID" field.

Returns:
Message-ID
Throws:
MessagingException - if the retrieval of this field causes any exception.
Since:
JavaMail 1.1
See Also:
MessageIDTerm

getFileName

public String getFileName()
                   throws MessagingException
Get the filename associated with this Message.

Returns the value of the "filename" parameter from the "Content-Disposition" header field of this message. If it's not available, returns the value of the "name" parameter from the "Content-Type" header field of this BodyPart. Returns null if both are absent.

If the mail.mime.encodefilename System property is set to true, the MimeUtility.decodeText method will be used to decode the filename. While such encoding is not supported by the MIME spec, many mailers use this technique to support non-ASCII characters in filenames. The default value of this property is false.

Specified by:
getFileName in interface Part
Returns:
filename
Throws:
MessagingException

setFileName

public void setFileName(String filename)
                 throws MessagingException
Set the filename associated with this part, if possible.

Sets the "filename" parameter of the "Content-Disposition" header field of this message.

If the mail.mime.encodefilename System property is set to true, the MimeUtility.encodeText method will be used to encode the filename. While such encoding is not supported by the MIME spec, many mailers use this technique to support non-ASCII characters in filenames. The default value of this property is false.

Specified by:
setFileName in interface Part
Parameters:
filename - Filename to associate with this part
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getInputStream

public InputStream getInputStream()
                           throws IOException,
                                  MessagingException
Return a decoded input stream for this Message's "content".

This implementation obtains the input stream from the DataHandler, that is, it invokes getDataHandler().getInputStream().

Specified by:
getInputStream in interface Part
Returns:
an InputStream
Throws:
MessagingException
IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
See Also:
getContentStream(), DataHandler.getInputStream()

getContentStream

protected InputStream getContentStream()
                                throws MessagingException
Produce the raw bytes of the content. This method is used during parsing, to create a DataHandler object for the content. Subclasses that can provide a separate input stream for just the message content might want to override this method.

This implementation returns a SharedInputStream, if contentStream is not null. Otherwise, it returns a ByteArrayInputStream constructed out of the content byte array.

Throws:
MessagingException
See Also:
content

getRawInputStream

public InputStream getRawInputStream()
                              throws MessagingException
Return an InputStream to the raw data with any Content-Transfer-Encoding intact. This method is useful if the "Content-Transfer-Encoding" header is incorrect or corrupt, which would prevent the getInputStream method or getContent method from returning the correct data. In such a case the application may use this method and attempt to decode the raw data itself.

This implementation simply calls the getContentStream method.

Throws:
MessagingException
Since:
JavaMail 1.2
See Also:
getInputStream(), getContentStream()

getDataHandler

public DataHandler getDataHandler()
                           throws MessagingException
Return a DataHandler for this Message's content.

The implementation provided here works as follows. Note the use of the getContentStream method to generate the byte stream for the content. Also note that any transfer-decoding is done automatically within this method.

  getDataHandler() {
      if (dh == null) {
          dh = new DataHandler(new MimePartDataSource(this));
      }
      return dh;
  }

  class MimePartDataSource implements DataSource {
      public getInputStream() {
          return MimeUtility.decode(
                     getContentStream(), getEncoding());
      }

                ....
  }

Specified by:
getDataHandler in interface Part
Returns:
DataHandler for the content
Throws:
MessagingException

getContent

public Object getContent()
                  throws IOException,
                         MessagingException
Return the content as a Java object. The type of this object is dependent on the content itself. For example, the native format of a "text/plain" content is usually a String object. The native format for a "multipart" message is always a Multipart subclass. For content types that are unknown to the DataHandler system, an input stream is returned as the content.

This implementation obtains the content from the DataHandler, that is, it invokes getDataHandler().getContent(). If the content is a Multipart or Message object and was created by parsing a stream, the object is cached and returned in subsequent calls so that modifications to the content will not be lost.

Specified by:
getContent in interface Part
Returns:
Object
Throws:
MessagingException
IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
See Also:
Part, DataHandler.getContent()

setDataHandler

public void setDataHandler(DataHandler dh)
                    throws MessagingException
This method provides the mechanism to set this part's content. The given DataHandler object should wrap the actual content.

Specified by:
setDataHandler in interface Part
Parameters:
dh - The DataHandler for the content.
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

setContent

public void setContent(Object o,
                       String type)
                throws MessagingException
A convenience method for setting this Message's content.

The content is wrapped in a DataHandler object. Note that a DataContentHandler class for the specified type should be available to the JavaMail implementation for this to work right. i.e., to do setContent(foobar, "application/x-foobar"), a DataContentHandler for "application/x-foobar" should be installed. Refer to the Java Activation Framework for more information.

Specified by:
setContent in interface Part
Parameters:
o - the content object
type - Mime type of the object
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

setText

public void setText(String text)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a MIME type of "text/plain". If the string contains non US-ASCII characters. it will be encoded using the platform's default charset. The charset is also used to set the "charset" parameter.

Note that there may be a performance penalty if text is large, since this method may have to scan all the characters to determine what charset to use.

If the charset is already known, use the setText method that takes the charset parameter.

Specified by:
setText in interface MimePart
Specified by:
setText in interface Part
Parameters:
text - the text content to set
Throws:
MessagingException - if an error occurs
See Also:
setText(String text, String charset)

setText

public void setText(String text,
                    String charset)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set the "charset" parameter.

Specified by:
setText in interface MimePart
Parameters:
text - the text content to set
charset - the charset to use for the text
Throws:
MessagingException - if an error occurs

setText

public void setText(String text,
                    String charset,
                    String subtype)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set the "charset" parameter.

Specified by:
setText in interface MimePart
Parameters:
text - the text content to set
charset - the charset to use for the text
subtype - the MIME subtype to use (e.g., "html")
Throws:
MessagingException - if an error occurs
Since:
JavaMail 1.4

setContent

public void setContent(Multipart mp)
                throws MessagingException
This method sets the Message's content to a Multipart object.

Specified by:
setContent in interface Part
Parameters:
mp - The multipart object that is the Message's content
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

reply

public Message reply(boolean replyToAll)
              throws MessagingException
Get a new Message suitable for a reply to this message. The new Message will have its attributes and headers set up appropriately. Note that this new message object will be empty, i.e., it will not have a "content". These will have to be suitably filled in by the client.

If replyToAll is set, the new Message will be addressed to all recipients of this message. Otherwise, the reply will be addressed to only the sender of this message (using the value of the getReplyTo method).

The "Subject" field is filled in with the original subject prefixed with "Re:" (unless it already starts with "Re:"). The "In-Reply-To" header is set in the new message if this message has a "Message-Id" header. The ANSWERED flag is set in this message.

Specified by:
reply in class Message
Parameters:
replyToAll - reply should be sent to all recipients of this message
Returns:
the reply Message
Throws:
MessagingException

writeTo

public void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
Output the message as an RFC 822 format stream.

Note that, depending on how the messag was constructed, it may use a variety of line termination conventions. Generally the output should be sent through an appropriate FilterOutputStream that converts the line terminators to the desired form, either CRLF for MIME compatibility and for use in Internet protocols, or the local platform's line terminator for storage in a local text file.

This implementation calls the writeTo(OutputStream, String[]) method with a null ignore list.

Specified by:
writeTo in interface Part
Throws:
IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
MessagingException
See Also:
DataHandler.writeTo(java.io.OutputStream)

writeTo

public void writeTo(OutputStream os,
                    String[] ignoreList)
             throws IOException,
                    MessagingException
Output the message as an RFC 822 format stream, without specified headers. If the saved flag is not set, the saveChanges method is called. If the modified flag is not set and the content array is not null, the content array is written directly, after writing the appropriate message headers.

Throws:
MessagingException
IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
See Also:
DataHandler.writeTo(java.io.OutputStream)

getHeader

public String[] getHeader(String name)
                   throws MessagingException
Get all the headers for this header_name. Note that certain headers may be encoded as per RFC 2047 if they contain non US-ASCII characters and these should be decoded.

This implementation obtains the headers from the headers InternetHeaders object.

Specified by:
getHeader in interface Part
Parameters:
name - name of header
Returns:
array of headers
Throws:
MessagingException
See Also:
MimeUtility

getHeader

public String getHeader(String name,
                        String delimiter)
                 throws MessagingException
Get all the headers for this header name, returned as a single String, with headers separated by the delimiter. If the delimiter is null, only the first header is returned.

Specified by:
getHeader in interface MimePart
Parameters:
name - the name of this header
delimiter - separator between values
Returns:
the value fields for all headers with this name
Throws:
MessagingException

setHeader

public void setHeader(String name,
                      String value)
               throws MessagingException
Set the value for this header_name. Replaces all existing header values with this new value. Note that RFC 822 headers must contain only US-ASCII characters, so a header that contains non US-ASCII characters must have been encoded by the caller as per the rules of RFC 2047.

Specified by:
setHeader in interface Part
Parameters:
name - header name
value - header value
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
See Also:
MimeUtility

addHeader

public void addHeader(String name,
                      String value)
               throws MessagingException
Add this value to the existing values for this header_name. Note that RFC 822 headers must contain only US-ASCII characters, so a header that contains non US-ASCII characters must have been encoded as per the rules of RFC 2047.

Specified by:
addHeader in interface Part
Parameters:
name - header name
value - header value
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
See Also:
MimeUtility

removeHeader

public void removeHeader(String name)
                  throws MessagingException
Remove all headers with this name.

Specified by:
removeHeader in interface Part
Parameters:
name - the name of this header
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getAllHeaders

public Enumeration getAllHeaders()
                          throws MessagingException
Return all the headers from this Message as an enumeration of Header objects.

Note that certain headers may be encoded as per RFC 2047 if they contain non US-ASCII characters and these should be decoded.

This implementation obtains the headers from the headers InternetHeaders object.

Specified by:
getAllHeaders in interface Part
Returns:
array of header objects
Throws:
MessagingException
See Also:
MimeUtility

getMatchingHeaders

public Enumeration getMatchingHeaders(String[] names)
                               throws MessagingException
Return matching headers from this Message as an Enumeration of Header objects. This implementation obtains the headers from the headers InternetHeaders object.

Specified by:
getMatchingHeaders in interface Part
Returns:
enumeration of Header objects
Throws:
MessagingException

getNonMatchingHeaders

public Enumeration getNonMatchingHeaders(String[] names)
                                  throws MessagingException
Return non-matching headers from this Message as an Enumeration of Header objects. This implementation obtains the header from the headers InternetHeaders object.

Specified by:
getNonMatchingHeaders in interface Part
Returns:
enumeration of Header objects
Throws:
MessagingException

addHeaderLine

public void addHeaderLine(String line)
                   throws MessagingException
Add a raw RFC 822 header-line.

Specified by:
addHeaderLine in interface MimePart
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getAllHeaderLines

public Enumeration getAllHeaderLines()
                              throws MessagingException
Get all header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header-line, containing both the "name" and "value" field.

Specified by:
getAllHeaderLines in interface MimePart
Throws:
MessagingException

getMatchingHeaderLines

public Enumeration getMatchingHeaderLines(String[] names)
                                   throws MessagingException
Get matching header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header-line, containing both the "name" and "value" field.

Specified by:
getMatchingHeaderLines in interface MimePart
Throws:
MessagingException

getNonMatchingHeaderLines

public Enumeration getNonMatchingHeaderLines(String[] names)
                                      throws MessagingException
Get non-matching header lines as an Enumeration of Strings. A Header line is a raw RFC 822 header-line, containing both the "name" and "value" field.

Specified by:
getNonMatchingHeaderLines in interface MimePart
Throws:
MessagingException

getFlags

public Flags getFlags()
               throws MessagingException
Return a Flags object containing the flags for this message.

Note that a clone of the internal Flags object is returned, so modifying the returned Flags object will not affect the flags of this message.

Specified by:
getFlags in class Message
Returns:
Flags object containing the flags for this message
Throws:
MessagingException
See Also:
Flags

isSet

public boolean isSet(Flags.Flag flag)
              throws MessagingException
Check whether the flag specified in the flag argument is set in this message.

This implementation checks this message's internal flags object.

Overrides:
isSet in class Message
Parameters:
flag - the flag
Returns:
value of the specified flag for this message
Throws:
MessagingException
See Also:
Flags.Flag, Flags.Flag.ANSWERED, Flags.Flag.DELETED, Flags.Flag.DRAFT, Flags.Flag.FLAGGED, Flags.Flag.RECENT, Flags.Flag.SEEN

setFlags

public void setFlags(Flags flag,
                     boolean set)
              throws MessagingException
Set the flags for this message.

This implementation modifies the flags field.

Specified by:
setFlags in class Message
Parameters:
flag - Flags object containing the flags to be set
set - the value to be set
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException
See Also:
MessageChangedEvent

saveChanges

public void saveChanges()
                 throws MessagingException
Updates the appropriate header fields of this message to be consistent with the message's contents. If this message is contained in a Folder, any changes made to this message are committed to the containing folder.

If any part of a message's headers or contents are changed, saveChanges must be called to ensure that those changes are permanent. Otherwise, any such modifications may or may not be saved, depending on the folder implementation.

Messages obtained from folders opened READ_ONLY should not be modified and saveChanges should not be called on such messages.

This method sets the modified flag to true, the save flag to true, and then calls the updateHeaders method.

Specified by:
saveChanges in class Message
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

updateMessageID

protected void updateMessageID()
                        throws MessagingException
Update the Message-ID header. This method is called by the updateHeaders and allows a subclass to override only the algorithm for choosing a Message-ID.

Throws:
MessagingException
Since:
JavaMail 1.4

updateHeaders

protected void updateHeaders()
                      throws MessagingException
Called by the saveChanges method to actually update the MIME headers. The implementation here sets the Content-Transfer-Encoding header (if needed and not already set), the MIME-Version header and the Message-ID header. Also, if the content of this message is a MimeMultipart, it's updateHeaders method is called.

Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

createInternetHeaders

protected InternetHeaders createInternetHeaders(InputStream is)
                                         throws MessagingException
Create and return an InternetHeaders object that loads the headers from the given InputStream. Subclasses can override this method to return a subclass of InternetHeaders, if necessary. This implementation simply constructs and returns an InternetHeaders object.

Parameters:
is - the InputStream to read the headers from
Throws:
MessagingException
Since:
JavaMail 1.2

createMimeMessage

protected MimeMessage createMimeMessage(Session session)
                                 throws MessagingException
Create and return a MimeMessage object. The reply method uses this method to create the MimeMessage object that it will return. Subclasses can override this method to return a subclass of MimeMessage. This implementation simply constructs and returns a MimeMessage object using the supplied Session.

Parameters:
session - the Session to use for the new message
Returns:
the new MimeMessage object
Throws:
MessagingException
Since:
JavaMail 1.4
Overview  Package   Class  Tree  Deprecated  Index  Help
Java EE 5 SDK
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MimeMessage.RecipientType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MimeMessage.RecipientType

java.lang.Object
    extended by  javax.mail.Message.RecipientType
        extended by  javax.mail.internet.MimeMessage.RecipientType
All Implemented Interfaces:
Serializable
Enclosing class:
MimeMessage
public static class MimeMessage.RecipientType
extends Message.RecipientType

This inner class extends the javax.mail.Message.RecipientType class to add additional RecipientTypes. The one additional RecipientType currently defined here is NEWSGROUPS.

See Also:
Message.RecipientType, Serialized Form

Field Summary
static MimeMessage.RecipientType NEWSGROUPS
The "Newsgroup" (Usenet news) recipients.
Fields inherited from class javax.mail.Message.RecipientType
BCC, CC, TO, type
Constructor Summary
protected MimeMessage.RecipientType(String type)
Method Summary
protected  Object readResolve()
When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class.
Methods inherited from class javax.mail.Message.RecipientType
toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NEWSGROUPS

public static final MimeMessage.RecipientType NEWSGROUPS
The "Newsgroup" (Usenet news) recipients.

Constructor Detail

MimeMessage.RecipientType

protected MimeMessage.RecipientType(String type)
Method Detail

readResolve

protected Object readResolve()
                      throws ObjectStreamException
Description copied from class: Message.RecipientType
When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class. Subclasses must implement their own readResolve method that checks for their known instances before calling this super method.

Overrides:
readResolve in class Message.RecipientType
Throws:
ObjectStreamException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MimeMultipart

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MimeMultipart

java.lang.Object
    extended by  javax.mail.Multipart
        extended by  javax.mail.internet.MimeMultipart

public class MimeMultipart
extends Multipart

The MimeMultipart class is an implementation of the abstract Multipart class that uses MIME conventions for the multipart data.

A MimeMultipart is obtained from a MimePart whose primary type is "multipart" (by invoking the part's getContent() method) or it can be created by a client as part of creating a new MimeMessage.

The default multipart subtype is "mixed". The other multipart subtypes, such as "alternative", "related", and so on, can be implemented as subclasses of MimeMultipart with additional methods to implement the additional semantics of that type of multipart content. The intent is that service providers, mail JavaBean writers and mail clients will write many such subclasses and their Command Beans, and will install them into the JavaBeans Activation Framework, so that any JavaMail implementation and its clients can transparently find and use these classes. Thus, a MIME multipart handler is treated just like any other type handler, thereby decoupling the process of providing multipart handlers from the JavaMail API. Lacking these additional MimeMultipart subclasses, all subtypes of MIME multipart data appear as MimeMultipart objects.

An application can directly construct a MIME multipart object of any subtype by using the MimeMultipart(String subtype) constructor. For example, to create a "multipart/alternative" object, use new MimeMultipart("alternative").

The mail.mime.multipart.ignoremissingendboundary property may be set to false to cause a MessagingException to be thrown if the multipart data does not end with the required end boundary line. If this property is set to true or not set, missing end boundaries are not considered an error and the final body part ends at the end of the data.

The mail.mime.multipart.ignoremissingboundaryparameter System property may be set to false to cause a MessagingException to be thrown if the Content-Type of the MimeMultipart does not include a boundary parameter. If this property is set to true or not set, the multipart parsing code will look for a line that looks like a bounary line and use that as the boundary separating the parts.

Version:
1.41, 05/12/09
Author:
John Mani, Bill Shannon, Max Spivak

Field Summary
protected DataSource | ds The DataSource supplying our InputStream.
protected boolean | parsed Have we parsed the data from our InputStream yet?
Fields inherited from class javax.mail.Multipart
contentType, parent, parts
Constructor Summary
MimeMultipart()
Default constructor.
MimeMultipart(DataSource ds)
Constructs a MimeMultipart object and its bodyparts from the given DataSource.
MimeMultipart(String subtype)
Construct a MimeMultipart object of the given subtype.
Method Summary
protected InternetHeaders | createInternetHeaders(InputStream is) Create and return an InternetHeaders object that loads the headers from the given InputStream.
protected MimeBodyPart | createMimeBodyPart(InputStream is) Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
protected MimeBodyPart | createMimeBodyPart(InternetHeaders headers, byte[] content) Create and return a MimeBodyPart object to represent a body part parsed from the InputStream.
BodyPart | getBodyPart(int index) Get the specified BodyPart.
BodyPart | getBodyPart(String CID) Get the MimeBodyPart referred to by the given ContentID (CID).
int | getCount() Return the number of enclosed BodyPart objects.
String | getPreamble() Get the preamble text, if any, that appears before the first body part of this multipart.
boolean | isComplete() Return true if the final boundary line for this multipart was seen.
protected void | parse() Parse the InputStream from our DataSource, constructing the appropriate MimeBodyParts.
void | setPreamble(String preamble) Set the preamble text to be included before the first body part.
void | setSubType(String subtype) Set the subtype.
protected void | updateHeaders() Update headers.
void | writeTo(OutputStream os) Iterates through all the parts and outputs each Mime part separated by a boundary.
Methods inherited from class javax.mail.Multipart
addBodyPart, addBodyPart, getContentType, getParent, removeBodyPart, removeBodyPart, setMultipartDataSource, setParent
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ds

protected DataSource ds
The DataSource supplying our InputStream.

parsed

protected boolean parsed
Have we parsed the data from our InputStream yet? Defaults to true; set to false when our constructor is given a DataSource with an InputStream that we need to parse.

Constructor Detail

MimeMultipart

public MimeMultipart()
Default constructor. An empty MimeMultipart object is created. Its content type is set to "multipart/mixed". A unique boundary string is generated and this string is setup as the "boundary" parameter for the contentType field.

MimeBodyParts may be added later.

MimeMultipart

public MimeMultipart(String subtype)
Construct a MimeMultipart object of the given subtype. A unique boundary string is generated and this string is setup as the "boundary" parameter for the contentType field.

MimeBodyParts may be added later.

MimeMultipart

public MimeMultipart(DataSource ds)
              throws MessagingException
Constructs a MimeMultipart object and its bodyparts from the given DataSource.

This constructor handles as a special case the situation where the given DataSource is a MultipartDataSource object. In this case, this method just invokes the superclass (i.e., Multipart) constructor that takes a MultipartDataSource object.

Otherwise, the DataSource is assumed to provide a MIME multipart byte stream. The parsed flag is set to false. When the data for the body parts are needed, the parser extracts the "boundary" parameter from the content type of this DataSource, skips the 'preamble' and reads bytes till the terminating boundary and creates MimeBodyParts for each part of the stream.

Parameters:
ds - DataSource, can be a MultipartDataSource
Throws:
MessagingException
Method Detail

setSubType

public void setSubType(String subtype)
                throws MessagingException
Set the subtype. This method should be invoked only on a new MimeMultipart object created by the client. The default subtype of such a multipart object is "mixed".

Parameters:
subtype - Subtype
Throws:
MessagingException

getCount

public int getCount()
             throws MessagingException
Return the number of enclosed BodyPart objects.

Overrides:
getCount in class Multipart
Returns:
number of parts
Throws:
MessagingException
See Also:
Multipart.parts

getBodyPart

public BodyPart getBodyPart(int index)
                     throws MessagingException
Get the specified BodyPart. BodyParts are numbered starting at 0.

Overrides:
getBodyPart in class Multipart
Parameters:
index - the index of the desired BodyPart
Returns:
the Part
Throws:
MessagingException - if no such BodyPart exists

getBodyPart

public BodyPart getBodyPart(String CID)
                     throws MessagingException
Get the MimeBodyPart referred to by the given ContentID (CID). Returns null if the part is not found.

Parameters:
CID - the ContentID of the desired part
Returns:
the Part
Throws:
MessagingException

isComplete

public boolean isComplete()
                   throws MessagingException
Return true if the final boundary line for this multipart was seen. When parsing multipart content, this class will (by default) terminate parsing with no error if the end of input is reached before seeing the final multipart boundary line. In such a case, this method will return false. (If the System property "mail.mime.multipart.ignoremissingendboundary" is set to false, parsing such a message will instead throw a MessagingException.)

Returns:
true if the final boundary line was seen
Throws:
MessagingException
Since:
JavaMail 1.4

getPreamble

public String getPreamble()
                   throws MessagingException
Get the preamble text, if any, that appears before the first body part of this multipart. Some protocols, such as IMAP, will not allow access to the preamble text.

Returns:
the preamble text, or null if no preamble
Throws:
MessagingException
Since:
JavaMail 1.4

setPreamble

public void setPreamble(String preamble)
                 throws MessagingException
Set the preamble text to be included before the first body part. Applications should generally not include any preamble text. In some cases it may be helpful to include preamble text with instructions for users of pre-MIME software. The preamble text should be complete lines, including newlines.

Parameters:
preamble - the preamble text
Throws:
MessagingException
Since:
JavaMail 1.4

updateHeaders

protected void updateHeaders()
                      throws MessagingException
Update headers. The default implementation here just calls the updateHeaders method on each of its children BodyParts.

Note that the boundary parameter is already set up when a new and empty MimeMultipart object is created.

This method is called when the saveChanges method is invoked on the Message object containing this Multipart. This is typically done as part of the Message send process, however note that a client is free to call it any number of times. So if the header updating process is expensive for a specific MimeMultipart subclass, then it might itself want to track whether its internal state actually did change, and do the header updating only if necessary.

Throws:
MessagingException

writeTo

public void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
Iterates through all the parts and outputs each Mime part separated by a boundary.

Specified by:
writeTo in class Multipart
Throws:
IOException - if an IO related exception occurs
MessagingException

parse

protected void parse()
              throws MessagingException
Parse the InputStream from our DataSource, constructing the appropriate MimeBodyParts. The parsed flag is set to true, and if true on entry nothing is done. This method is called by all other methods that need data for the body parts, to make sure the data has been parsed.

Throws:
MessagingException
Since:
JavaMail 1.2

createInternetHeaders

protected InternetHeaders createInternetHeaders(InputStream is)
                                         throws MessagingException
Create and return an InternetHeaders object that loads the headers from the given InputStream. Subclasses can override this method to return a subclass of InternetHeaders, if necessary. This implementation simply constructs and returns an InternetHeaders object.

Parameters:
is - the InputStream to read the headers from
Throws:
MessagingException
Since:
JavaMail 1.2

createMimeBodyPart

protected MimeBodyPart createMimeBodyPart(InternetHeaders headers,
                                          byte[] content)
                                   throws MessagingException
Create and return a MimeBodyPart object to represent a body part parsed from the InputStream. Subclasses can override this method to return a subclass of MimeBodyPart, if necessary. This implementation simply constructs and returns a MimeBodyPart object.

Parameters:
headers - the headers for the body part
content - the content of the body part
Throws:
MessagingException
Since:
JavaMail 1.2

createMimeBodyPart

protected MimeBodyPart createMimeBodyPart(InputStream is)
                                   throws MessagingException
Create and return a MimeBodyPart object to represent a body part parsed from the InputStream. Subclasses can override this method to return a subclass of MimeBodyPart, if necessary. This implementation simply constructs and returns a MimeBodyPart object.

Parameters:
is - InputStream containing the body part
Throws:
MessagingException
Since:
JavaMail 1.2
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MimePart

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Interface MimePart

All Superinterfaces:
Part
All Known Implementing Classes:
MimeBodyPart, MimeMessage, PreencodedMimeBodyPart
public interface MimePart
extends Part

The MimePart interface models an Entity as defined by MIME (RFC2045, Section 2.4).

MimePart extends the Part interface to add additional RFC822 and MIME specific semantics and attributes. It provides the base interface for the MimeMessage and MimeBodyPart classes

A note on RFC822 and MIME headers

RFC822 and MIME header fields must contain only US-ASCII characters. If a header contains non US-ASCII characters, it must be encoded as per the rules in RFC 2047. The MimeUtility class provided in this package can be used to to achieve this. Callers of the setHeader, addHeader, and addHeaderLine methods are responsible for enforcing the MIME requirements for the specified headers. In addition, these header fields must be folded (wrapped) before being sent if they exceed the line length limitation for the transport (1000 bytes for SMTP). Received headers may have been folded. The application is responsible for folding and unfolding headers as appropriate.

Author:
John Mani
See Also:
MimeUtility, Part

Field Summary
Fields inherited from interface javax.mail.Part
ATTACHMENT, INLINE
Method Summary
void | addHeaderLine(String line) Add a raw RFC822 header-line.
Enumeration | getAllHeaderLines() Get all header lines as an Enumeration of Strings.
String | getContentID() Get the Content-ID of this part.
String[] | getContentLanguage() Get the language tags specified in the Content-Language header of this MimePart.
String | getContentMD5() Get the Content-MD5 digest of this part.
String | getEncoding() Get the transfer encoding of this part.
String | getHeader(String name, String delimiter) Get the values of all header fields available for this header, returned as a single String, with the values separated by the delimiter.
Enumeration | getMatchingHeaderLines(String[] names) Get matching header lines as an Enumeration of Strings.
Enumeration | getNonMatchingHeaderLines(String[] names) Get non-matching header lines as an Enumeration of Strings.
void | setContentLanguage(String[] languages) Set the Content-Language header of this MimePart.
void | setContentMD5(String md5) Set the Content-MD5 of this part.
void | setText(String text) Convenience method that sets the given String as this part's content, with a MIME type of "text/plain".
void | setText(String text, String charset) Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset.
void | setText(String text, String charset, String subtype) Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype.
Methods inherited from interface javax.mail.Part
addHeader, getAllHeaders, getContent, getContentType, getDataHandler, getDescription, getDisposition, getFileName, getHeader, getInputStream, getLineCount, getMatchingHeaders, getNonMatchingHeaders, getSize, isMimeType, removeHeader, setContent, setContent, setDataHandler, setDescription, setDisposition, setFileName, setHeader, writeTo

Method Detail

getHeader

String getHeader(String name,
                 String delimiter)
                 throws MessagingException
Get the values of all header fields available for this header, returned as a single String, with the values separated by the delimiter. If the delimiter is null, only the first value is returned.

Parameters:
name - the name of this header
delimiter - delimiter between fields in returned string
Returns:
the value fields for all headers with this name
Throws:
MessagingException

addHeaderLine

void addHeaderLine(String line)
                   throws MessagingException
Add a raw RFC822 header-line.

Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

getAllHeaderLines

Enumeration getAllHeaderLines()
                              throws MessagingException
Get all header lines as an Enumeration of Strings. A Header line is a raw RFC822 header-line, containing both the "name" and "value" field.

Throws:
MessagingException

getMatchingHeaderLines

Enumeration getMatchingHeaderLines(String[] names)
                                   throws MessagingException
Get matching header lines as an Enumeration of Strings. A Header line is a raw RFC822 header-line, containing both the "name" and "value" field.

Throws:
MessagingException

getNonMatchingHeaderLines

Enumeration getNonMatchingHeaderLines(String[] names)
                                      throws MessagingException
Get non-matching header lines as an Enumeration of Strings. A Header line is a raw RFC822 header-line, containing both the "name" and "value" field.

Throws:
MessagingException

getEncoding

String getEncoding()
                   throws MessagingException
Get the transfer encoding of this part.

Returns:
content-transfer-encoding
Throws:
MessagingException

getContentID

String getContentID()
                    throws MessagingException
Get the Content-ID of this part. Returns null if none present.

Returns:
content-ID
Throws:
MessagingException

getContentMD5

String getContentMD5()
                     throws MessagingException
Get the Content-MD5 digest of this part. Returns null if none present.

Returns:
content-MD5
Throws:
MessagingException

setContentMD5

void setContentMD5(String md5)
                   throws MessagingException
Set the Content-MD5 of this part.

Parameters:
md5 - the MD5 value
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

getContentLanguage

String[] getContentLanguage()
                            throws MessagingException
Get the language tags specified in the Content-Language header of this MimePart. The Content-Language header is defined by RFC 1766. Returns null if this header is not available.

Throws:
MessagingException

setContentLanguage

void setContentLanguage(String[] languages)
                        throws MessagingException
Set the Content-Language header of this MimePart. The Content-Language header is defined by RFC1766.

Parameters:
languages - array of language tags
Throws:
IllegalWriteException - if the underlying implementation does not support modification
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

setText

void setText(String text)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a MIME type of "text/plain". If the string contains non US-ASCII characters. it will be encoded using the platform's default charset. The charset is also used to set the "charset" parameter.

Note that there may be a performance penalty if text is large, since this method may have to scan all the characters to determine what charset to use.

If the charset is already known, use the setText method that takes the charset parameter.

Specified by:
setText in interface Part
Parameters:
text - the text content to set
Throws:
MessagingException - if an error occurs
See Also:
setText(String text, String charset)

setText

void setText(String text,
             String charset)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a MIME type of "text/plain" and the specified charset. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set "charset" parameter.

Parameters:
text - the text content to set
charset - the charset to use for the text
Throws:
MessagingException - if an error occurs

setText

void setText(String text,
             String charset,
             String subtype)
             throws MessagingException
Convenience method that sets the given String as this part's content, with a primary MIME type of "text" and the specified MIME subtype. The given Unicode string will be charset-encoded using the specified charset. The charset is also used to set the "charset" parameter.

Parameters:
text - the text content to set
charset - the charset to use for the text
subtype - the MIME subtype to use (e.g., "html")
Throws:
MessagingException - if an error occurs
Since:
JavaMail 1.4
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MimePartDataSource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MimePartDataSource

java.lang.Object
    extended by  javax.mail.internet.MimePartDataSource
All Implemented Interfaces:
DataSource, MessageAware
public class MimePartDataSource
extends Object
implements DataSource, MessageAware

A utility class that implements a DataSource out of a MimePart. This class is primarily meant for service providers.

Author:
John Mani
See Also:
MimePart, DataSource

Field Summary
protected  MimePart part
The MimePart that provides the data for this DataSource.
Constructor Summary
MimePartDataSource(MimePart part)
Constructor, that constructs a DataSource from a MimePart.
Method Summary
String | getContentType() Returns the content-type of this DataSource.
InputStream | getInputStream() Returns an input stream from this MimePart.
MessageContext | getMessageContext() Return the MessageContext for the current part.
String | getName() DataSource method to return a name.
OutputStream | getOutputStream() DataSource method to return an output stream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

part

protected MimePart part
The MimePart that provides the data for this DataSource.

Since:
JavaMail 1.4
Constructor Detail

MimePartDataSource

public MimePartDataSource(MimePart part)
Constructor, that constructs a DataSource from a MimePart.

Method Detail

getInputStream

public InputStream getInputStream()
                           throws IOException
Returns an input stream from this MimePart.

This method applies the appropriate transfer-decoding, based on the Content-Transfer-Encoding attribute of this MimePart. Thus the returned input stream is a decoded stream of bytes.

This implementation obtains the raw content from the Part using the getContentStream() method and decodes it using the MimeUtility.decode() method.

Specified by:
getInputStream in interface DataSource
Returns:
decoded input stream
Throws:
IOException
See Also:
MimeMessage.getContentStream(),
MimeBodyPart.getContentStream(),
MimeUtility.decode(java.io.InputStream, java.lang.String)

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
DataSource method to return an output stream.

This implementation throws the UnknownServiceException.

Specified by:
getOutputStream in interface DataSource
Returns:
an OutputStream
Throws:
IOException

getContentType

public String getContentType()
Returns the content-type of this DataSource.

This implementation just invokes the getContentType method on the MimePart.

Specified by:
getContentType in interface DataSource
Returns:
the MIME Type

getName

public String getName()
DataSource method to return a name.

This implementation just returns an empty string.

Specified by:
getName in interface DataSource
Returns:
the name of the object.

getMessageContext

public MessageContext getMessageContext()
Return the MessageContext for the current part.

Specified by:
getMessageContext in interface MessageAware
Since:
JavaMail 1.1
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MimeUtility

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class MimeUtility

java.lang.Object
    extended by  javax.mail.internet.MimeUtility

public class MimeUtility
extends Object

This is a utility class that provides various MIME related functionality.

There are a set of methods to encode and decode MIME headers as per RFC 2047. A brief description on handling such headers is given below:

RFC 822 mail headers must contain only US-ASCII characters. Headers that contain non US-ASCII characters must be encoded so that they contain only US-ASCII characters. Basically, this process involves using either BASE64 or QP to encode certain characters. RFC 2047 describes this in detail.

In Java, Strings contain (16 bit) Unicode characters. ASCII is a subset of Unicode (and occupies the range 0 - 127). A String that contains only ASCII characters is already mail-safe. If the String contains non US-ASCII characters, it must be encoded. An additional complexity in this step is that since Unicode is not yet a widely used charset, one might want to first charset-encode the String into another charset and then do the transfer-encoding.

Note that to get the actual bytes of a mail-safe String (say, for sending over SMTP), one must do

        byte[] bytes = string.getBytes("iso-8859-1");

The setHeader and addHeader methods on MimeMessage and MimeBodyPart assume that the given header values are Unicode strings that contain only US-ASCII characters. Hence the callers of those methods must insure that the values they pass do not contain non US-ASCII characters. The methods in this class help do this.

The getHeader family of methods on MimeMessage and MimeBodyPart return the raw header value. These might be encoded as per RFC 2047, and if so, must be decoded into Unicode Strings. The methods in this class help to do this.

Several System properties control strict conformance to the MIME spec. Note that these are not session properties but must be set globally as System properties.

The mail.mime.decodetext.strict property controls decoding of MIME encoded words. The MIME spec requires that encoded words start at the beginning of a whitespace separated word. Some mailers incorrectly include encoded words in the middle of a word. If the mail.mime.decodetext.strict System property is set to "false", an attempt will be made to decode these illegal encoded words. The default is true.

The mail.mime.encodeeol.strict property controls the choice of Content-Transfer-Encoding for MIME parts that are not of type "text". Often such parts will contain textual data for which an encoding that allows normal end of line conventions is appropriate. In rare cases, such a part will appear to contain entirely textual data, but will require an encoding that preserves CR and LF characters without change. If the mail.mime.encodeeol.strict System property is set to "true", such an encoding will be used when necessary. The default is false.

In addition, the mail.mime.charset System property can be used to specify the default MIME charset to use for encoded words and text parts that don't otherwise specify a charset. Normally, the default MIME charset is derived from the default Java charset, as specified in the file.encoding System property. Most applications will have no need to explicitly set the default MIME charset. In cases where the default MIME charset to be used for mail messages is different than the charset used for files stored on the system, this property should be set.

Version:
1.54, 05/08/29
Author:
John Mani, Bill Shannon

Field Summary
static int ALL
Method Summary
static InputStream | decode(InputStream is, String encoding) Decode the given input stream.
static String | decodeText(String etext) Decode "unstructured" headers, that is, headers that are defined as '*text' as per RFC 822.
static String | decodeWord(String eword) The string is parsed using the rules in RFC 2047 for parsing an "encoded-word".
static OutputStream | encode(OutputStream os, String encoding) Wrap an encoder around the given output stream.
static OutputStream | encode(OutputStream os, String encoding, String filename) Wrap an encoder around the given output stream.
static String | encodeText(String text) Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.
static String | encodeText(String text, String charset, String encoding) Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.
static String | encodeWord(String word) Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.
static String | encodeWord(String word, String charset, String encoding) Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.
static String | fold(int used, String s) Fold a string at linear whitespace so that each line is no longer than 76 characters, if possible.
static String | getDefaultJavaCharset() Get the default charset corresponding to the system's current default locale.
static String | getEncoding(DataHandler dh) Same as getEncoding(DataSource) except that instead of reading the data from an InputStream it uses the writeTo method to examine the data.
static String | getEncoding(DataSource ds) Get the content-transfer-encoding that should be applied to the input stream of this datasource, to make it mailsafe.
static String | javaCharset(String charset) Convert a MIME charset name into a valid Java charset name.
static String | mimeCharset(String charset) Convert a java charset into its MIME charset name.
static String | quote(String word, String specials) A utility method to quote a word, if the word contains any characters from the specified 'specials' list.
static String | unfold(String s) Unfold a folded header.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ALL

public static final int ALL
See Also:
Constant Field Values
Method Detail

getEncoding

public static String getEncoding(DataSource ds)
Get the content-transfer-encoding that should be applied to the input stream of this datasource, to make it mailsafe.

The algorithm used here is:

  • If the primary type of this datasource is "text" and if all the bytes in its input stream are US-ASCII, then the encoding is "7bit". If more than half of the bytes are non-US-ASCII, then the encoding is "base64". If less than half of the bytes are non-US-ASCII, then the encoding is "quoted-printable".
  • If the primary type of this datasource is not "text", then if all the bytes of its input stream are US-ASCII, the encoding is "7bit". If there is even one non-US-ASCII character, the encoding is "base64".

Parameters:
ds - DataSource
Returns:
the encoding. This is either "7bit", "quoted-printable" or "base64"

getEncoding

public static String getEncoding(DataHandler dh)
Same as getEncoding(DataSource) except that instead of reading the data from an InputStream it uses the writeTo method to examine the data. This is more efficient in the common case of a DataHandler created with an object and a MIME type (for example, a "text/plain" String) because all the I/O is done in this thread. In the case requiring an InputStream the DataHandler uses a thread, a pair of pipe streams, and the writeTo method to produce the data.

Since:
JavaMail 1.2

decode

public static InputStream decode(InputStream is,
                                 String encoding)
                          throws MessagingException
Decode the given input stream. The Input stream returned is the decoded input stream. All the encodings defined in RFC 2045 are supported here. They include "base64", "quoted-printable", "7bit", "8bit", and "binary". In addition, "uuencode" is also supported.

Parameters:
is - input stream
encoding - the encoding of the stream.
Returns:
decoded input stream.
Throws:
MessagingException

encode

public static OutputStream encode(OutputStream os,
                                  String encoding)
                           throws MessagingException
Wrap an encoder around the given output stream. All the encodings defined in RFC 2045 are supported here. They include "base64", "quoted-printable", "7bit", "8bit" and "binary". In addition, "uuencode" is also supported.

Parameters:
os - output stream
encoding - the encoding of the stream.
Returns:
output stream that applies the specified encoding.
Throws:
MessagingException

encode

public static OutputStream encode(OutputStream os,
                                  String encoding,
                                  String filename)
                           throws MessagingException
Wrap an encoder around the given output stream. All the encodings defined in RFC 2045 are supported here. They include "base64", "quoted-printable", "7bit", "8bit" and "binary". In addition, "uuencode" is also supported. The filename parameter is used with the "uuencode" encoding and is included in the encoded output.

Parameters:
os - output stream
encoding - the encoding of the stream.
filename - name for the file being encoded (only used with uuencode)
Returns:
output stream that applies the specified encoding.
Throws:
MessagingException
Since:
JavaMail 1.2

encodeText

public static String encodeText(String text)
                         throws UnsupportedEncodingException
Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.

The given Unicode string is examined for non US-ASCII characters. If the string contains only US-ASCII characters, it is returned as-is. If the string contains non US-ASCII characters, it is first character-encoded using the platform's default charset, then transfer-encoded using either the B or Q encoding. The resulting bytes are then returned as a Unicode string containing only ASCII characters.

Note that this method should be used to encode only "unstructured" RFC 822 headers.

Example of usage:

  MimePart part = ...
  String rawvalue = "FooBar Mailer, Japanese version 1.1"
  try {
    // If we know for sure that rawvalue contains only US-ASCII
    // characters, we can skip the encoding part
    part.setHeader("X-mailer", MimeUtility.encodeText(rawvalue));
  } catch (UnsupportedEncodingException e) {
    // encoding failure
  } catch (MessagingException me) {
   // setHeader() failure
  }

Parameters:
text - Unicode string
Returns:
Unicode string containing only US-ASCII characters
Throws:
UnsupportedEncodingException - if the encoding fails

encodeText

public static String encodeText(String text,
                                String charset,
                                String encoding)
                         throws UnsupportedEncodingException
Encode a RFC 822 "text" token into mail-safe form as per RFC 2047.

The given Unicode string is examined for non US-ASCII characters. If the string contains only US-ASCII characters, it is returned as-is. If the string contains non US-ASCII characters, it is first character-encoded using the specified charset, then transfer-encoded using either the B or Q encoding. The resulting bytes are then returned as a Unicode string containing only ASCII characters.

Note that this method should be used to encode only "unstructured" RFC 822 headers.

Parameters:
text - the header value
charset - the charset. If this parameter is null, the platform's default chatset is used.
encoding - the encoding to be used. Currently supported values are "B" and "Q". If this parameter is null, then the "Q" encoding is used if most of characters to be encoded are in the ASCII charset, otherwise "B" encoding is used.
Returns:
Unicode string containing only US-ASCII characters
Throws:
UnsupportedEncodingException

decodeText

public static String decodeText(String etext)
                         throws UnsupportedEncodingException
Decode "unstructured" headers, that is, headers that are defined as '*text' as per RFC 822.

The string is decoded using the algorithm specified in RFC 2047, Section 6.1.1. If the charset-conversion fails for any sequence, an UnsupportedEncodingException is thrown. If the String is not an RFC 2047 style encoded header, it is returned as-is

Example of usage:

  MimePart part = ...
  String rawvalue = null;
  String  value = null;
  try {
    if ((rawvalue = part.getHeader("X-mailer")[0]) != null)
      value = MimeUtility.decodeText(rawvalue);
  } catch (UnsupportedEncodingException e) {
      // Don't care
      value = rawvalue;
  } catch (MessagingException me) { }

  return value;

Parameters:
etext - the possibly encoded value
Throws:
UnsupportedEncodingException - if the charset conversion failed.

encodeWord

public static String encodeWord(String word)
                         throws UnsupportedEncodingException
Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.

The given Unicode string is examined for non US-ASCII characters. If the string contains only US-ASCII characters, it is returned as-is. If the string contains non US-ASCII characters, it is first character-encoded using the platform's default charset, then transfer-encoded using either the B or Q encoding. The resulting bytes are then returned as a Unicode string containing only ASCII characters.

This method is meant to be used when creating RFC 822 "phrases". The InternetAddress class, for example, uses this to encode it's 'phrase' component.

Parameters:
word - Unicode string
Returns:
Array of Unicode strings containing only US-ASCII characters.
Throws:
UnsupportedEncodingException - if the encoding fails

encodeWord

public static String encodeWord(String word,
                                String charset,
                                String encoding)
                         throws UnsupportedEncodingException
Encode a RFC 822 "word" token into mail-safe form as per RFC 2047.

The given Unicode string is examined for non US-ASCII characters. If the string contains only US-ASCII characters, it is returned as-is. If the string contains non US-ASCII characters, it is first character-encoded using the specified charset, then transfer-encoded using either the B or Q encoding. The resulting bytes are then returned as a Unicode string containing only ASCII characters.

Parameters:
word - Unicode string
charset - the MIME charset
encoding - the encoding to be used. Currently supported values are "B" and "Q". If this parameter is null, then the "Q" encoding is used if most of characters to be encoded are in the ASCII charset, otherwise "B" encoding is used.
Returns:
Unicode string containing only US-ASCII characters
Throws:
UnsupportedEncodingException - if the encoding fails

decodeWord

public static String decodeWord(String eword)
                         throws ParseException,
                                UnsupportedEncodingException
The string is parsed using the rules in RFC 2047 for parsing an "encoded-word". If the parse fails, a ParseException is thrown. Otherwise, it is transfer-decoded, and then charset-converted into Unicode. If the charset-conversion fails, an UnsupportedEncodingException is thrown.

Parameters:
eword - the possibly encoded value
Throws:
ParseException - if the string is not an encoded-word as per RFC 2047.
UnsupportedEncodingException - if the charset conversion failed.

quote

public static String quote(String word,
                           String specials)
A utility method to quote a word, if the word contains any characters from the specified 'specials' list.

The HeaderTokenizer class defines two special sets of delimiters - MIME and RFC 822.

This method is typically used during the generation of RFC 822 and MIME header fields.

Parameters:
word - word to be quoted
specials - the set of special characters
Returns:
the possibly quoted word
See Also:
HeaderTokenizer.MIME, HeaderTokenizer.RFC822

fold

public static String fold(int used,
                          String s)
Fold a string at linear whitespace so that each line is no longer than 76 characters, if possible. If there are more than 76 non-whitespace characters consecutively, the string is folded at the first whitespace after that sequence. The parameter used indicates how many characters have been used in the current line; it is usually the length of the header name.

Note that line breaks in the string aren't escaped; they probably should be.

Parameters:
used - characters used in line so far
s - the string to fold
Returns:
the folded string
Since:
JavaMail 1.4

unfold

public static String unfold(String s)
Unfold a folded header. Any line breaks that aren't escaped and are followed by whitespace are removed.

Parameters:
s - the string to unfold
Returns:
the unfolded string
Since:
JavaMail 1.4

javaCharset

public static String javaCharset(String charset)
Convert a MIME charset name into a valid Java charset name.

Parameters:
charset - the MIME charset name
Returns:
the Java charset equivalent. If a suitable mapping is not available, the passed in charset is itself returned.

mimeCharset

public static String mimeCharset(String charset)
Convert a java charset into its MIME charset name.

Note that a future version of JDK (post 1.2) might provide this functionality, in which case, we may deprecate this method then.

Parameters:
charset - the JDK charset
Returns:
the MIME/IANA equivalent. If a mapping is not possible, the passed in charset itself is returned.
Since:
JavaMail 1.1

getDefaultJavaCharset

public static String getDefaultJavaCharset()
Get the default charset corresponding to the system's current default locale. If the System property mail.mime.charset is set, a system charset corresponding to this MIME charset will be returned.

Returns:
the default charset of the system's default locale, as a Java charset. (NOT a MIME charset)
Since:
JavaMail 1.1
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NewsAddress

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class NewsAddress

java.lang.Object
    extended by  javax.mail.Address
        extended by  javax.mail.internet.NewsAddress
All Implemented Interfaces:
Serializable
public class NewsAddress
extends Address

This class models an RFC1036 newsgroup address.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected String | host
protected String | newsgroup
Constructor Summary
NewsAddress()
Default constructor.
NewsAddress(String newsgroup)
Construct a NewsAddress with the given newsgroup.
NewsAddress(String newsgroup, String host)
Construct a NewsAddress with the given newsgroup and host.
Method Summary
boolean | equals(Object a) The equality operator.
String | getHost() Get the host.
String | getNewsgroup() Get the newsgroup.
String | getType() Return the type of this address.
int | hashCode() Compute a hash code for the address.
static NewsAddress[] | parse(String newsgroups) Parse the given comma separated sequence of newsgroup into NewsAddress objects.
void | setHost(String host) Set the host.
void | setNewsgroup(String newsgroup) Set the newsgroup.
String | toString() Convert this address into a RFC 1036 address.
static String | toString(Address[] addresses) Convert the given array of NewsAddress objects into a comma separated sequence of address strings.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

newsgroup

protected String newsgroup

host

protected String host
Constructor Detail

NewsAddress

public NewsAddress()
Default constructor.

NewsAddress

public NewsAddress(String newsgroup)
Construct a NewsAddress with the given newsgroup.

Parameters:
newsgroup - the newsgroup

NewsAddress

public NewsAddress(String newsgroup,
                   String host)
Construct a NewsAddress with the given newsgroup and host.

Parameters:
newsgroup - the newsgroup
host - the host
Method Detail

getType

public String getType()
Return the type of this address. The type of a NewsAddress is "news".

Specified by:
getType in class Address
Returns:
address type
See Also:
InternetAddress

setNewsgroup

public void setNewsgroup(String newsgroup)
Set the newsgroup.

Parameters:
newsgroup - the newsgroup

getNewsgroup

public String getNewsgroup()
Get the newsgroup.

Returns:
newsgroup

setHost

public void setHost(String host)
Set the host.

Parameters:
host - the host

getHost

public String getHost()
Get the host.

Returns:
host

toString

public String toString()
Convert this address into a RFC 1036 address.

Specified by:
toString in class Address
Returns:
newsgroup

equals

public boolean equals(Object a)
The equality operator.

Specified by:
equals in class Address
Parameters:
a - Address object

hashCode

public int hashCode()
Compute a hash code for the address.

Overrides:
hashCode in class Object

toString

public static String toString(Address[] addresses)
Convert the given array of NewsAddress objects into a comma separated sequence of address strings. The resulting string contains only US-ASCII characters, and hence is mail-safe.

Parameters:
addresses - array of NewsAddress objects
Returns:
comma separated address strings
Throws:
ClassCastException, - if any address object in the given array is not a NewsAddress objects. Note that this is a RuntimeException.

parse

public static NewsAddress[] parse(String newsgroups)
                           throws AddressException
Parse the given comma separated sequence of newsgroup into NewsAddress objects.

Parameters:
newsgroups - comma separated newsgroup string
Returns:
array of NewsAddress objects
Throws:
AddressException - if the parse failed
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ParameterList

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class ParameterList

java.lang.Object
    extended by  javax.mail.internet.ParameterList

public class ParameterList
extends Object

This class holds MIME parameters (attribute-value pairs). The mail.mime.encodeparameters and mail.mime.decodeparameters System properties control whether encoded parameters, as specified by RFC 2231, are supported. By default, such encoded parameters are not supported.

Also, in the current implementation, setting the System property mail.mime.decodeparameters.strict to "true" will cause a ParseException to be thrown for errors detected while decoding encoded parameters. By default, if any decoding errors occur, the original (undecoded) string is used.

Version:
1.12, 05/08/29
Author:
John Mani, Bill Shannon

Constructor Summary
ParameterList()
No-arg Constructor.
ParameterList(String s)
Constructor that takes a parameter-list string.
Method Summary
String | get(String name) Returns the value of the specified parameter.
Enumeration | getNames() Return an enumeration of the names of all parameters in this list.
void | remove(String name) Removes the specified parameter from this ParameterList.
void | set(String name, String value) Set a parameter.
void | set(String name, String value, String charset) Set a parameter.
int | size() Return the number of parameters in this list.
String | toString() Convert this ParameterList into a MIME String.
String | toString(int used) Convert this ParameterList into a MIME String.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ParameterList

public ParameterList()
No-arg Constructor.

ParameterList

public ParameterList(String s)
              throws ParseException
Constructor that takes a parameter-list string. The String is parsed and the parameters are collected and stored internally. A ParseException is thrown if the parse fails. Note that an empty parameter-list string is valid and will be parsed into an empty ParameterList.

Parameters:
s - the parameter-list string.
Throws:
ParseException - if the parse fails.
Method Detail

size

public int size()
Return the number of parameters in this list.

Returns:
number of parameters.

get

public String get(String name)
Returns the value of the specified parameter. Note that parameter names are case-insensitive.

Parameters:
name - parameter name.
Returns:
Value of the parameter. Returns null if the parameter is not present.

set

public void set(String name,
                String value)
Set a parameter. If this parameter already exists, it is replaced by this new value.

Parameters:
name - name of the parameter.
value - value of the parameter.

set

public void set(String name,
                String value,
                String charset)
Set a parameter. If this parameter already exists, it is replaced by this new value. If the mail.mime.encodeparameters System property is true, and the parameter value is non-ASCII, it will be encoded with the specified charset, as specified by RFC 2231.

Parameters:
name - name of the parameter.
value - value of the parameter.
charset - charset of the parameter value.
Since:
JavaMail 1.4

remove

public void remove(String name)
Removes the specified parameter from this ParameterList. This method does nothing if the parameter is not present.

Parameters:
name - name of the parameter.

getNames

public Enumeration getNames()
Return an enumeration of the names of all parameters in this list.

Returns:
Enumeration of all parameter names in this list.

toString

public String toString()
Convert this ParameterList into a MIME String. If this is an empty list, an empty string is returned.

Overrides:
toString in class Object
Returns:
String

toString

public String toString(int used)
Convert this ParameterList into a MIME String. If this is an empty list, an empty string is returned. The 'used' parameter specifies the number of character positions already taken up in the field into which the resulting parameter list is to be inserted. It's used to determine where to fold the resulting parameter list.

Parameters:
used - number of character positions already used, in the field into which the parameter list is to be inserted.
Returns:
String
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ParseException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class ParseException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
                extended by  javax.mail.internet.ParseException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AddressException
public class ParseException
extends MessagingException

The exception thrown due to an error in parsing RFC822 or MIME headers

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
ParseException()
Constructs a ParseException with no detail message.
ParseException(String s)
Constructs a ParseException with the specified detail message.
Method Summary
Methods inherited from class javax.mail.MessagingException
getCause, getNextException, setNextException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ParseException

public ParseException()
Constructs a ParseException with no detail message.

ParseException

public ParseException(String s)
Constructs a ParseException with the specified detail message.

Parameters:
s - the detail message
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PreencodedMimeBodyPart

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Class PreencodedMimeBodyPart

java.lang.Object
    extended by  javax.mail.BodyPart
        extended by  javax.mail.internet.MimeBodyPart
            extended by  javax.mail.internet.PreencodedMimeBodyPart
All Implemented Interfaces:
MimePart, Part
public class PreencodedMimeBodyPart
extends MimeBodyPart

A MimeBodyPart that handles data that has already been encoded. This class is useful when constructing a message and attaching data that has already been encoded (for example, using base64 encoding). The data may have been encoded by the application, or may have been stored in a file or database in encoded form. The encoding is supplied when this object is created. The data is attached to this object in the usual fashion, by using the setText, setContent, or setDataHandler methods.

Since:
JavaMail 1.4

Field Summary
Fields inherited from class javax.mail.internet.MimeBodyPart
content, contentStream, dh, headers
Fields inherited from class javax.mail.BodyPart
parent
Fields inherited from interface javax.mail.Part
ATTACHMENT, INLINE
Constructor Summary
PreencodedMimeBodyPart(String encoding)
Create a PreencodedMimeBodyPart that assumes the data is encoded using the specified encoding.
Method Summary
String | getEncoding() Returns the content transfer encoding specified when this object was created.
protected void | updateHeaders() Force the Content-Transfer-Encoding header to use the encoding that was specified when this object was created.
void | writeTo(OutputStream os) Output the body part as an RFC 822 format stream.
Methods inherited from class javax.mail.internet.MimeBodyPart
addHeader, addHeaderLine, attachFile, attachFile, getAllHeaderLines, getAllHeaders, getContent, getContentID, getContentLanguage, getContentMD5, getContentStream, getContentType, getDataHandler, getDescription, getDisposition, getFileName, getHeader, getHeader, getInputStream, getLineCount, getMatchingHeaderLines, getMatchingHeaders, getNonMatchingHeaderLines, getNonMatchingHeaders, getRawInputStream, getSize, isMimeType, removeHeader, saveFile, saveFile, setContent, setContent, setContentID, setContentLanguage, setContentMD5, setDataHandler, setDescription, setDescription, setDisposition, setFileName, setHeader, setText, setText, setText
Methods inherited from class javax.mail.BodyPart
getParent
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PreencodedMimeBodyPart

public PreencodedMimeBodyPart(String encoding)
Create a PreencodedMimeBodyPart that assumes the data is encoded using the specified encoding. The encoding must be a MIME supported Content-Transfer-Encoding.

Method Detail

getEncoding

public String getEncoding()
                   throws MessagingException
Returns the content transfer encoding specified when this object was created.

Specified by:
getEncoding in interface MimePart
Overrides:
getEncoding in class MimeBodyPart
Returns:
content-transfer-encoding
Throws:
MessagingException
See Also:
MimeBodyPart.headers

writeTo

public void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
Output the body part as an RFC 822 format stream.

Specified by:
writeTo in interface Part
Overrides:
writeTo in class MimeBodyPart
Throws:
MessagingException
IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
See Also:
DataHandler.writeTo(java.io.OutputStream)

updateHeaders

protected void updateHeaders()
                      throws MessagingException
Force the Content-Transfer-Encoding header to use the encoding that was specified when this object was created.

Overrides:
updateHeaders in class MimeBodyPart
Throws:
MessagingException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SharedInputStream

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.internet
Interface SharedInputStream

All Known Implementing Classes:
SharedByteArrayInputStream, SharedFileInputStream
public interface SharedInputStream

An InputStream that is backed by data that can be shared by multiple readers may implement this interface. This allows users of such an InputStream to determine the current position in the InputStream, and to create new InputStreams representing a subset of the data in the original InputStream. The new InputStream will access the same underlying data as the original, without copying the data.

Note that implementations of this interface must ensure that the close method does not close any underlying stream that might be shared by multiple instances of SharedInputStream until all shared instances have been closed.

Since:
JavaMail 1.2
Version:
1.4, 05/08/29
Author:
Bill Shannon

Method Summary
long | getPosition() Return the current position in the InputStream, as an offset from the beginning of the InputStream.
InputStream | newStream(long start, long end) Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive).

Method Detail

getPosition

long getPosition()
Return the current position in the InputStream, as an offset from the beginning of the InputStream.

Returns:
the current position

newStream

InputStream newStream(long start,
                      long end)
Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive). start must be non-negative. If end is -1, the new stream ends at the same place as this stream. The returned InputStream will also implement the SharedInputStream interface.

Parameters:
start - the starting position
end - the ending position + 1
Returns:
the new stream
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Message

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Message

java.lang.Object
    extended by  javax.mail.Message
All Implemented Interfaces:
Part
Direct Known Subclasses:
MimeMessage
public abstract class Message
extends Object
implements Part

This class models an email message. This is an abstract class. Subclasses provide actual implementations.

Message implements the Part interface. Message contains a set of attributes and a "content". Messages within a folder also have a set of flags that describe its state within the folder.

Message defines some new attributes in addition to those defined in the Part interface. These attributes specify meta-data for the message - i.e., addressing and descriptive information about the message.

Message objects are obtained either from a Folder or by constructing a new Message object of the appropriate subclass. Messages that have been received are normally retrieved from a folder named "INBOX".

A Message object obtained from a folder is just a lightweight reference to the actual message. The Message is 'lazily' filled up (on demand) when each item is requested from the message. Note that certain folder implementations may return Message objects that are pre-filled with certain user-specified items. To send a message, an appropriate subclass of Message (e.g., MimeMessage) is instantiated, the attributes and content are filled in, and the message is sent using the Transport.send method.

Author:
John Mani, Bill Shannon, Max Spivak
See Also:
Part

Nested Class Summary
static class Message.RecipientType
This inner class defines the types of recipients allowed by the Message class.
Field Summary
protected boolean | expunged True if this message has been expunged.
protected Folder | folder The containing folder, if this message is obtained from a folder
protected int | msgnum The number of this message within its folder, or zero if the message was not retrieved from a folder.
protected Session | session The Session object for this Message
Fields inherited from interface javax.mail.Part
ATTACHMENT, INLINE
Constructor Summary
protected | Message() No-arg version of the constructor.
protected | Message(Folder folder, int msgnum) Constructor that takes a Folder and a message number.
protected | Message(Session session) Constructor that takes a Session.
Method Summary
abstract void | addFrom(Address[] addresses) Add these addresses to the existing "From" attribute
void | addRecipient(Message.RecipientType type, Address address) Add this recipient address to the existing ones of the given type.
abstract void | addRecipients(Message.RecipientType type, Address[] addresses) Add these recipient addresses to the existing ones of the given type.
Address[] | getAllRecipients() Get all the recipient addresses for the message.
abstract Flags | getFlags() Returns a Flags object containing the flags for this message.
Folder | getFolder() Get the folder from which this message was obtained.
abstract Address[] | getFrom() Returns the "From" attribute.
int | getMessageNumber() Get the Message number for this Message.
abstract Date | getReceivedDate() Get the date this message was received.
abstract Address[] | getRecipients(Message.RecipientType type) Get all the recipient addresses of the given type.
Address[] | getReplyTo() Get the addresses to which replies should be directed.
abstract Date | getSentDate() Get the date this message was sent.
abstract String | getSubject() Get the subject of this message.
boolean | isExpunged() Checks whether this message is expunged.
boolean | isSet(Flags.Flag flag) Check whether the flag specified in the flag argument is set in this message.
boolean | match(SearchTerm term) Apply the specified Search criterion to this message.
abstract Message | reply(boolean replyToAll) Get a new Message suitable for a reply to this message.
abstract void | saveChanges() Save any changes made to this message into the message-store when the containing folder is closed, if the message is contained in a folder.
protected void | setExpunged(boolean expunged) Sets the expunged flag for this Message.
void | setFlag(Flags.Flag flag, boolean set) Set the specified flag on this message to the specified value.
abstract void | setFlags(Flags flag, boolean set) Set the specified flags on this message to the specified value.
abstract void | setFrom() Set the "From" attribute in this Message.
abstract void | setFrom(Address address) Set the "From" attribute in this Message.
protected void | setMessageNumber(int msgnum) Set the Message number for this Message.
void | setRecipient(Message.RecipientType type, Address address) Set the recipient address.
abstract void | setRecipients(Message.RecipientType type, Address[] addresses) Set the recipient addresses.
void | setReplyTo(Address[] addresses) Set the addresses to which replies should be directed.
abstract void | setSentDate(Date date) Set the sent date of this message.
abstract void | setSubject(String subject) Set the subject of this message.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.mail.Part
addHeader, getAllHeaders, getContent, getContentType, getDataHandler, getDescription, getDisposition, getFileName, getHeader, getInputStream, getLineCount, getMatchingHeaders, getNonMatchingHeaders, getSize, isMimeType, removeHeader, setContent, setContent, setDataHandler, setDescription, setDisposition, setFileName, setHeader, setText, writeTo

Field Detail

msgnum

protected int msgnum
The number of this message within its folder, or zero if the message was not retrieved from a folder.

expunged

protected boolean expunged
True if this message has been expunged.

folder

protected Folder folder
The containing folder, if this message is obtained from a folder

session

protected Session session
The Session object for this Message

Constructor Detail

Message

protected Message()
No-arg version of the constructor.

Message

protected Message(Folder folder,
                  int msgnum)
Constructor that takes a Folder and a message number. Used by Folder implementations.

Parameters:
folder - containing folder
msgnum - this message's sequence number within this folder

Message

protected Message(Session session)
Constructor that takes a Session. Used for client created Message objects.

Parameters:
session - A Session object
Method Detail

getFrom

public abstract Address[] getFrom()
                           throws MessagingException
Returns the "From" attribute. The "From" attribute contains the identity of the person(s) who wished this message to be sent.

In certain implementations, this may be different from the entity that actually sent the message.

This method returns null if this attribute is not present in this message. Returns an empty array if this attribute is present, but contains no addresses.

Returns:
array of Address objects
Throws:
MessagingException

setFrom

public abstract void setFrom()
                      throws MessagingException
Set the "From" attribute in this Message. The value of this attribute is obtained from the property "mail.user". If this property is absent, the system property "user.name" is used.

Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.

setFrom

public abstract void setFrom(Address address)
                      throws MessagingException
Set the "From" attribute in this Message.

Parameters:
address - the sender
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.

addFrom

public abstract void addFrom(Address[] addresses)
                      throws MessagingException
Add these addresses to the existing "From" attribute

Parameters:
addresses - the senders
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MessagingException

getRecipients

public abstract Address[] getRecipients(Message.RecipientType type)
                                 throws MessagingException
Get all the recipient addresses of the given type.

This method returns null if no recipients of the given type are present in this message. It may return an empty array if the header is present, but contains no addresses.

Parameters:
type - the recipient type
Returns:
array of Address objects
Throws:
MessagingException
See Also:
Message.RecipientType.TO, Message.RecipientType.CC, Message.RecipientType.BCC

getAllRecipients

public Address[] getAllRecipients()
                           throws MessagingException
Get all the recipient addresses for the message. The default implementation extracts the TO, CC, and BCC recipients using the getRecipients method.

This method returns null if none of the recipient headers are present in this message. It may Return an empty array if any recipient header is present, but contains no addresses.

Returns:
array of Address objects
Throws:
MessagingException
See Also:
Message.RecipientType.TO, Message.RecipientType.CC, Message.RecipientType.BCC, getRecipients(javax.mail.Message.RecipientType)

setRecipients

public abstract void setRecipients(Message.RecipientType type,
                                   Address[] addresses)
                            throws MessagingException
Set the recipient addresses. All addresses of the specified type are replaced by the addresses parameter.

Parameters:
type - the recipient type
addresses - the addresses
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.

setRecipient

public void setRecipient(Message.RecipientType type,
                         Address address)
                  throws MessagingException
Set the recipient address. All addresses of the specified type are replaced by the address parameter.

The default implementation uses the setRecipients method.

Parameters:
type - the recipient type
address - the address
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values

addRecipients

public abstract void addRecipients(Message.RecipientType type,
                                   Address[] addresses)
                            throws MessagingException
Add these recipient addresses to the existing ones of the given type.

Parameters:
type - the recipient type
addresses - the addresses
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.

addRecipient

public void addRecipient(Message.RecipientType type,
                         Address address)
                  throws MessagingException
Add this recipient address to the existing ones of the given type.

The default implementation uses the addRecipients method.

Parameters:
type - the recipient type
address - the address
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values

getReplyTo

public Address[] getReplyTo()
                     throws MessagingException
Get the addresses to which replies should be directed. This will usually be the sender of the message, but some messages may direct replies to a different address.

The default implementation simply calls the getFrom method.

This method returns null if the corresponding header is not present. Returns an empty array if the header is present, but contains no addresses.

Returns:
addresses to which replies should be directed
Throws:
MessagingException
See Also:
getFrom()

setReplyTo

public void setReplyTo(Address[] addresses)
                throws MessagingException
Set the addresses to which replies should be directed. (Normally only a single address will be specified.) Not all message types allow this to be specified separately from the sender of the message.

The default implementation provided here just throws the MethodNotSupportedException.

Parameters:
addresses - addresses to which replies should be directed
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.
MethodNotSupportedException - if the underlying implementation does not support setting this attribute

getSubject

public abstract String getSubject()
                           throws MessagingException
Get the subject of this message.

Returns:
the subject
Throws:
MessagingException

setSubject

public abstract void setSubject(String subject)
                         throws MessagingException
Set the subject of this message.

Parameters:
subject - the subject
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.

getSentDate

public abstract Date getSentDate()
                          throws MessagingException
Get the date this message was sent.

Returns:
the date this message was sent
Throws:
MessagingException

setSentDate

public abstract void setSentDate(Date date)
                          throws MessagingException
Set the sent date of this message.

Parameters:
date - the sent date of this message
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this message is obtained from a READ_ONLY folder.

getReceivedDate

public abstract Date getReceivedDate()
                              throws MessagingException
Get the date this message was received.

Returns:
the date this message was received
Throws:
MessagingException

getFlags

public abstract Flags getFlags()
                        throws MessagingException
Returns a Flags object containing the flags for this message.

Modifying any of the flags in this returned Flags object will not affect the flags of this message. Use setFlags() to do that.

Returns:
Flags object containing the flags for this message
Throws:
MessagingException
See Also:
Flags, setFlags(javax.mail.Flags, boolean)

isSet

public boolean isSet(Flags.Flag flag)
              throws MessagingException
Check whether the flag specified in the flag argument is set in this message.

The default implementation uses getFlags.

Parameters:
flag - the flag
Returns:
value of the specified flag for this message
Throws:
MessagingException
See Also:
Flags.Flag, Flags.Flag.ANSWERED, Flags.Flag.DELETED, Flags.Flag.DRAFT, Flags.Flag.FLAGGED, Flags.Flag.RECENT, Flags.Flag.SEEN

setFlags

public abstract void setFlags(Flags flag,
                              boolean set)
                       throws MessagingException
Set the specified flags on this message to the specified value. Note that any flags in this message that are not specified in the given Flags object are unaffected.

This will result in a MessageChangedEvent being delivered to any MessageChangedListener registered on this Message's containing folder.

Parameters:
flag - Flags object containing the flags to be set
set - the value to be set
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values.
IllegalStateException - if this message is obtained from a READ_ONLY folder.
See Also:
MessageChangedEvent

setFlag

public void setFlag(Flags.Flag flag,
                    boolean set)
             throws MessagingException
Set the specified flag on this message to the specified value. This will result in a MessageChangedEvent being delivered to any MessageChangedListener registered on this Message's containing folder.

The default implementation uses the setFlags method.

Parameters:
flag - Flags.Flag object containing the flag to be set
set - the value to be set
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values.
IllegalStateException - if this message is obtained from a READ_ONLY folder.
See Also:
MessageChangedEvent

getMessageNumber

public int getMessageNumber()
Get the Message number for this Message. A Message object's message number is the relative position of this Message in its Folder. Note that the message number for a particular Message can change during a session if other messages in the Folder are deleted and expunged.

Valid message numbers start at 1. Messages that do not belong to any folder (like newly composed or derived messages) have 0 as their message number.

Returns:
the message number

setMessageNumber

protected void setMessageNumber(int msgnum)
Set the Message number for this Message. This method is invoked only by the implementation classes.

getFolder

public Folder getFolder()
Get the folder from which this message was obtained. If this is a new message or nested message, this method returns null.

Returns:
the containing folder

isExpunged

public boolean isExpunged()
Checks whether this message is expunged. All other methods except getMessageNumber() are invalid on an expunged Message object.

Messages that are expunged due to an explict expunge() request on the containing Folder are removed from the Folder immediately. Messages that are externally expunged by another source are marked "expunged" and return true for the isExpunged() method, but they are not removed from the Folder until an explicit expunge() is done on the Folder.

See the description of expunge() for more details on expunge handling.

See Also:
Folder.expunge()

setExpunged

protected void setExpunged(boolean expunged)
Sets the expunged flag for this Message. This method is to be used only by the implementation classes.

Parameters:
expunged - the expunged flag

reply

public abstract Message reply(boolean replyToAll)
                       throws MessagingException
Get a new Message suitable for a reply to this message. The new Message will have its attributes and headers set up appropriately. Note that this new message object will be empty, that is, it will not have a "content". These will have to be suitably filled in by the client.

If replyToAll is set, the new Message will be addressed to all recipients of this message. Otherwise, the reply will be addressed to only the sender of this message (using the value of the getReplyTo method).

The "Subject" field is filled in with the original subject prefixed with "Re:" (unless it already starts with "Re:").

The reply message will use the same session as this message.

Parameters:
replyToAll - reply should be sent to all recipients of this message
Returns:
the reply Message
Throws:
MessagingException

saveChanges

public abstract void saveChanges()
                          throws MessagingException
Save any changes made to this message into the message-store when the containing folder is closed, if the message is contained in a folder. (Some implementations may save the changes immediately.) Update any header fields to be consistent with the changed message contents. If any part of a message's headers or contents are changed, saveChanges must be called to ensure that those changes are permanent. If saveChanges is not called, any such modifications may or may not be saved, depending on the message store and folder implementation.

Messages obtained from folders opened READ_ONLY should not be modified and saveChanges should not be called on such messages.

Throws:
MessagingException
IllegalStateException - if this message is obtained from a READ_ONLY folder.
IllegalWriteException - if the underlying implementation does not support modification of existing values.

match

public boolean match(SearchTerm term)
              throws MessagingException
Apply the specified Search criterion to this message.

Parameters:
term - the Search criterion
Returns:
true if the Message matches this search criterion, false otherwise.
Throws:
MessagingException
See Also:
SearchTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Message.RecipientType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Message.RecipientType

java.lang.Object
    extended by  javax.mail.Message.RecipientType
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
MimeMessage.RecipientType
Enclosing class:
Message
public static class Message.RecipientType
extends Object
implements Serializable

This inner class defines the types of recipients allowed by the Message class. The currently defined types are TO, CC and BCC. Note that this class only has a protected constructor, thereby restricting new Recipient types to either this class or subclasses. This effectively implements an enumeration of the allowed Recipient types. The following code sample shows how to use this class to obtain the "TO" recipients from a message.

 Message msg = folder.getMessages(1);
 Address[] a = m.getRecipients(Message.RecipientType.TO);

See Also:
Message.getRecipients(javax.mail.Message.RecipientType),
Message.setRecipients(javax.mail.Message.RecipientType, javax.mail.Address[]),
Message.addRecipients(javax.mail.Message.RecipientType, javax.mail.Address[]),
Serialized Form

Field Summary
static Message.RecipientType | BCC The "Bcc" (blind carbon copy) recipients.
static Message.RecipientType | CC The "Cc" (carbon copy) recipients.
static Message.RecipientType | TO The "To" (primary) recipients.
protected String | type The type of recipient, usually the name of a corresponding Internet standard header.
Constructor Summary
protected Message.RecipientType(String type)
Constructor for use by subclasses.
Method Summary
protected Object | readResolve() When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class.
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

TO

public static final Message.RecipientType TO
The "To" (primary) recipients.

CC

public static final Message.RecipientType CC
The "Cc" (carbon copy) recipients.

BCC

public static final Message.RecipientType BCC
The "Bcc" (blind carbon copy) recipients.

type

protected String type
The type of recipient, usually the name of a corresponding Internet standard header.

Constructor Detail

Message.RecipientType

protected Message.RecipientType(String type)
Constructor for use by subclasses.

Method Detail

readResolve

protected Object readResolve()
                      throws ObjectStreamException
When deserializing a RecipientType, we need to make sure to return only one of the known static final instances defined in this class. Subclasses must implement their own readResolve method that checks for their known instances before calling this super method.

Throws:
ObjectStreamException

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageAware

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Interface MessageAware

All Known Implementing Classes:
MimePartDataSource
public interface MessageAware

An interface optionally implemented by DataSources to supply information to a DataContentHandler about the message context in which the data content object is operating.

Since:
JavaMail 1.1
See Also:
MessageContext, DataSource, DataContentHandler

Method Summary
 MessageContext getMessageContext()
Return the message context.

Method Detail

getMessageContext

MessageContext getMessageContext()
Return the message context.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class MessageContext

java.lang.Object
    extended by  javax.mail.MessageContext

public class MessageContext
extends Object

The context in which a piece of Message content is contained. A MessageContext object is returned by the getMessageContext method of the MessageAware interface. MessageAware is typically implemented by DataSources to allow a DataContentHandler to pass on information about the context in which a data content object is operating.

Since:
JavaMail 1.1
See Also:
MessageAware, DataSource, DataContentHandler

Constructor Summary
MessageContext(Part part)
Create a MessageContext object describing the context of the given Part.
Method Summary
Message | getMessage() Return the Message that contains the content.
Part | getPart() Return the Part that contains the content.
Session | getSession() Return the Session we're operating in.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MessageContext

public MessageContext(Part part)
Create a MessageContext object describing the context of the given Part.

Method Detail

getPart

public Part getPart()
Return the Part that contains the content.

Returns:
the containing Part, or null if not known

getMessage

public Message getMessage()
Return the Message that contains the content. Follows the parent chain up through containing Multipart objects until it comes to a Message object, or null.

Returns:
the containing Message, or null if not known

getSession

public Session getSession()
Return the Session we're operating in.

Returns:
the Session, or null if not known
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageRemovedException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class MessageRemovedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
                extended by  javax.mail.MessageRemovedException
All Implemented Interfaces:
Serializable
public class MessageRemovedException
extends MessagingException

The exception thrown when an invalid method is invoked on an expunged Message. The only valid methods on an expunged Message are isExpunged() and getMessageNumber().

Author:
John Mani
See Also:
Message.isExpunged(), Message.getMessageNumber(), Serialized Form

Constructor Summary
MessageRemovedException()
Constructs a MessageRemovedException with no detail message.
MessageRemovedException(String s)
Constructs a MessageRemovedException with the specified detail message.
Method Summary
Methods inherited from class javax.mail.MessagingException
getCause, getNextException, setNextException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MessageRemovedException

public MessageRemovedException()
Constructs a MessageRemovedException with no detail message.

MessageRemovedException

public MessageRemovedException(String s)
Constructs a MessageRemovedException with the specified detail message.

Parameters:
s - the detail message
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessagingException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class MessagingException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AuthenticationFailedException, FolderClosedException, FolderNotFoundException, IllegalWriteException, MessageRemovedException, MethodNotSupportedException, NoSuchProviderException, ParseException, ReadOnlyFolderException, SearchException, SendFailedException, StoreClosedException
public class MessagingException
extends Exception

The base class for all exceptions thrown by the Messaging classes

Author:
John Mani, Bill Shannon
See Also:
Serialized Form

Constructor Summary
MessagingException()
Constructs a MessagingException with no detail message.
MessagingException(String s)
Constructs a MessagingException with the specified detail message.
MessagingException(String s, Exception e)
Constructs a MessagingException with the specified Exception and detail message.
Method Summary
Throwable | getCause() Overrides the getCause method of Throwable to return the next exception in the chain of nested exceptions.
Exception | getNextException() Get the next exception chained to this one.
boolean | setNextException(Exception ex) Add an exception to the end of the chain.
String | toString() Override toString method to provide information on nested exceptions.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MessagingException

public MessagingException()
Constructs a MessagingException with no detail message.

MessagingException

public MessagingException(String s)
Constructs a MessagingException with the specified detail message.

Parameters:
s - the detail message

MessagingException

public MessagingException(String s,
                          Exception e)
Constructs a MessagingException with the specified Exception and detail message. The specified exception is chained to this exception.

Parameters:
s - the detail message
e - the embedded exception
See Also:
getNextException(),
setNextException(java.lang.Exception),
getCause()
Method Detail

getNextException

public Exception getNextException()
Get the next exception chained to this one. If the next exception is a MessagingException, the chain may extend further.

Returns:
next Exception, null if none.

getCause

public Throwable getCause()
Overrides the getCause method of Throwable to return the next exception in the chain of nested exceptions.

Overrides:
getCause in class Throwable
Returns:
next Exception, null if none.

setNextException

public boolean setNextException(Exception ex)
Add an exception to the end of the chain. If the end is not a MessagingException, this exception cannot be added to the end.

Parameters:
ex - the new end of the Exception chain
Returns:
true if this Exception was added, false otherwise.

toString

public String toString()
Override toString method to provide information on nested exceptions.

Overrides:
toString in class Throwable
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MethodNotSupportedException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class MethodNotSupportedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
                extended by  javax.mail.MethodNotSupportedException
All Implemented Interfaces:
Serializable
public class MethodNotSupportedException
extends MessagingException

The exception thrown when a method is not supported by the implementation

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
MethodNotSupportedException()
Constructs a MethodNotSupportedException with no detail message.
MethodNotSupportedException(String s)
Constructs a MethodNotSupportedException with the specified detail message.
Method Summary
Methods inherited from class javax.mail.MessagingException
getCause, getNextException, setNextException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MethodNotSupportedException

public MethodNotSupportedException()
Constructs a MethodNotSupportedException with no detail message.

MethodNotSupportedException

public MethodNotSupportedException(String s)
Constructs a MethodNotSupportedException with the specified detail message.

Parameters:
s - the detail message
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Multipart

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Multipart

java.lang.Object
    extended by  javax.mail.Multipart
Direct Known Subclasses:
MimeMultipart
public abstract class Multipart
extends Object

Multipart is a container that holds multiple body parts. Multipart provides methods to retrieve and set its subparts.

Multipart also acts as the base class for the content object returned by most Multipart DataContentHandlers. For example, invoking getContent() on a DataHandler whose source is a "multipart/signed" data source may return an appropriate subclass of Multipart.

Some messaging systems provide different subtypes of Multiparts. For example, MIME specifies a set of subtypes that include "alternative", "mixed", "related", "parallel", "signed", etc.

Multipart is an abstract class. Subclasses provide actual implementations.

Version:
1.14, 05/08/29
Author:
John Mani

Field Summary
protected String | contentType This field specifies the content-type of this multipart object.
protected Part | parent The Part containing this Multipart, if known.
protected Vector | parts Vector of BodyPart objects.
Constructor Summary
protected Multipart()
Default constructor.
Method Summary
void | addBodyPart(BodyPart part) Adds a Part to the multipart.
void | addBodyPart(BodyPart part, int index) Adds a BodyPart at position index.
BodyPart | getBodyPart(int index) Get the specified Part.
String | getContentType() Return the content-type of this Multipart.
int | getCount() Return the number of enclosed BodyPart objects.
Part | getParent() Return the Part that contains this Multipart object, or null if not known.
boolean | removeBodyPart(BodyPart part) Remove the specified part from the multipart message.
void | removeBodyPart(int index) Remove the part at specified location (starting from 0).
protected void | setMultipartDataSource(MultipartDataSource mp) Setup this Multipart object from the given MultipartDataSource.
void | setParent(Part parent) Set the parent of this Multipart to be the specified Part.
abstract void | writeTo(OutputStream os) Output an appropriately encoded bytestream to the given OutputStream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

parts

protected Vector parts
Vector of BodyPart objects.

contentType

protected String contentType
This field specifies the content-type of this multipart object. It defaults to "multipart/mixed".

parent

protected Part parent
The Part containing this Multipart, if known.

Since:
JavaMail 1.1
Constructor Detail

Multipart

protected Multipart()
Default constructor. An empty Multipart object is created.

Method Detail

setMultipartDataSource

protected void setMultipartDataSource(MultipartDataSource mp)
                               throws MessagingException
Setup this Multipart object from the given MultipartDataSource.

The method adds the MultipartDataSource's BodyPart objects into this Multipart. This Multipart's contentType is set to that of the MultipartDataSource.

This method is typically used in those cases where one has a multipart data source that has already been pre-parsed into the individual body parts (for example, an IMAP datasource), but needs to create an appropriate Multipart subclass that represents a specific multipart subtype.

Parameters:
mp - Multipart datasource
Throws:
MessagingException

getContentType

public String getContentType()
Return the content-type of this Multipart.

This implementation just returns the value of the contentType field.

Returns:
content-type
See Also:
contentType

getCount

public int getCount()
             throws MessagingException
Return the number of enclosed BodyPart objects.

Returns:
number of parts
Throws:
MessagingException
See Also:
parts

getBodyPart

public BodyPart getBodyPart(int index)
                     throws MessagingException
Get the specified Part. Parts are numbered starting at 0.

Parameters:
index - the index of the desired Part
Returns:
the Part
Throws:
IndexOutOfBoundsException - if the given index is out of range.
MessagingException

removeBodyPart

public boolean removeBodyPart(BodyPart part)
                       throws MessagingException
Remove the specified part from the multipart message. Shifts all the parts after the removed part down one.

Parameters:
part - The part to remove
Returns:
true if part removed, false otherwise
Throws:
MessagingException - if no such Part exists
IllegalWriteException - if the underlying implementation does not support modification of existing values

removeBodyPart

public void removeBodyPart(int index)
                    throws MessagingException
Remove the part at specified location (starting from 0). Shifts all the parts after the removed part down one.

Parameters:
index - Index of the part to remove
Throws:
MessagingException
IndexOutOfBoundsException - if the given index is out of range.
IllegalWriteException - if the underlying implementation does not support modification of existing values

addBodyPart

public void addBodyPart(BodyPart part)
                 throws MessagingException
Adds a Part to the multipart. The BodyPart is appended to the list of existing Parts.

Parameters:
part - The Part to be appended
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values

addBodyPart

public void addBodyPart(BodyPart part,
                        int index)
                 throws MessagingException
Adds a BodyPart at position index. If index is not the last one in the list, the subsequent parts are shifted up. If index is larger than the number of parts present, the BodyPart is appended to the end.

Parameters:
part - The BodyPart to be inserted
index - Location where to insert the part
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values

writeTo

public abstract void writeTo(OutputStream os)
                      throws IOException,
                             MessagingException
Output an appropriately encoded bytestream to the given OutputStream. The implementation subclass decides the appropriate encoding algorithm to be used. The bytestream is typically used for sending.

Throws:
IOException - if an IO related exception occurs
MessagingException

getParent

public Part getParent()
Return the Part that contains this Multipart object, or null if not known.

Since:
JavaMail 1.1

setParent

public void setParent(Part parent)
Set the parent of this Multipart to be the specified Part. Normally called by the Message or BodyPart setContent(Multipart) method. parent may be null if the Multipart is being removed from its containing Part.

Since:
JavaMail 1.1
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MultipartDataSource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Interface MultipartDataSource

All Superinterfaces:
DataSource
public interface MultipartDataSource
extends DataSource

MultipartDataSource is a DataSource that contains body parts. This allows "mail aware" DataContentHandlers to be implemented more efficiently by being aware of such DataSources and using the appropriate methods to access BodyParts.

Note that the data of a MultipartDataSource is also available as an input stream.

This interface will typically be implemented by providers that preparse multipart bodies, for example an IMAP provider.

Version:
1.7, 05/08/29
Author:
John Mani
See Also:
DataSource

Method Summary
BodyPart | getBodyPart(int index) Get the specified Part.
int | getCount() Return the number of enclosed BodyPart objects.
Methods inherited from interface javax.activation.DataSource
getContentType, getInputStream, getName, getOutputStream

Method Detail

getCount

int getCount()
Return the number of enclosed BodyPart objects.

Returns:
number of parts

getBodyPart

BodyPart getBodyPart(int index)
                     throws MessagingException
Get the specified Part. Parts are numbered starting at 0.

Parameters:
index - the index of the desired Part
Returns:
the Part
Throws:
IndexOutOfBoundsException - if the given index is out of range.
MessagingException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NoSuchProviderException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class NoSuchProviderException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
                extended by  javax.mail.NoSuchProviderException
All Implemented Interfaces:
Serializable
public class NoSuchProviderException
extends MessagingException

This exception is thrown when Session attempts to instantiate a Provider that doesn't exist.

Author:
Max Spivak
See Also:
Serialized Form

Constructor Summary
NoSuchProviderException()
Constructor.
NoSuchProviderException(String message)
Constructor.
Method Summary
Methods inherited from class javax.mail.MessagingException
getCause, getNextException, setNextException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoSuchProviderException

public NoSuchProviderException()
Constructor.

NoSuchProviderException

public NoSuchProviderException(String message)
Constructor.

Parameters:
message - The detailed error message
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Part

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Interface Part

All Known Subinterfaces:
MimePart
All Known Implementing Classes:
BodyPart, Message, MimeBodyPart, MimeMessage, PreencodedMimeBodyPart
public interface Part

The Part interface is the common base interface for Messages and BodyParts.

Part consists of a set of attributes and a "Content".

Attributes:

The JavaMail API defines a set of standard Part attributes that are considered to be common to most existing Mail systems. These attributes have their own settor and gettor methods. Mail systems may support other Part attributes as well, these are represented as name-value pairs where both the name and value are Strings.

Content:

The data type of the "content" is returned by the getContentType() method. The MIME typing system is used to name data types.

The "content" of a Part is available in various formats:

  • As a DataHandler - using the getDataHandler() method. The "content" of a Part is also available through a javax.activation.DataHandler object. The DataHandler object allows clients to discover the operations available on the content, and to instantiate the appropriate component to perform those operations.
  • As an input stream - using the getInputStream() method. Any mail-specific encodings are decoded before this stream is returned.
  • As a Java object - using the getContent() method. This method returns the "content" as a Java object. The returned object is of course dependent on the content itself. In particular, a "multipart" Part's content is always a Multipart or subclass thereof. That is, getContent() on a "multipart" type Part will always return a Multipart (or subclass) object.
Part provides the writeTo() method that streams out its bytestream in mail-safe form suitable for transmission. This bytestream is typically an aggregation of the Part attributes and its content's bytestream.

Message and BodyPart implement the Part interface. Note that in MIME parlance, Part models an Entity (RFC 2045, Section 2.4).

Author:
John Mani

Field Summary
static String | ATTACHMENT This part should be presented as an attachment.
static String | INLINE This part should be presented inline.
Method Summary
void | addHeader(String header_name, String header_value) Add this value to the existing values for this header_name.
Enumeration | getAllHeaders() Return all the headers from this part as an Enumeration of Header objects.
Object | getContent() Return the content as a Java object.
String | getContentType() Returns the Content-Type of the content of this part.
DataHandler | getDataHandler() Return a DataHandler for the content within this part.
String | getDescription() Return a description String for this part.
String | getDisposition() Return the disposition of this part.
String | getFileName() Get the filename associated with this part, if possible.
String[] | getHeader(String header_name) Get all the headers for this header name.
InputStream | getInputStream() Return an input stream for this part's "content".
int | getLineCount() Return the number of lines in the content of this part.
Enumeration | getMatchingHeaders(String[] header_names) Return matching headers from this part as an Enumeration of Header objects.
Enumeration | getNonMatchingHeaders(String[] header_names) Return non-matching headers from this envelope as an Enumeration of Header objects.
int | getSize() Return the size of the content of this part in bytes.
boolean | isMimeType(String mimeType) Is this Part of the specified MIME type?
void | removeHeader(String header_name) Remove all headers with this name.
void | setContent(Multipart mp) This method sets the given Multipart object as this message's content.
void | setContent(Object obj, String type) A convenience method for setting this part's content.
void | setDataHandler(DataHandler dh) This method provides the mechanism to set this part's content.
void | setDescription(String description) Set a description String for this part.
void | setDisposition(String disposition) Set the disposition of this part.
void | setFileName(String filename) Set the filename associated with this part, if possible.
void | setHeader(String header_name, String header_value) Set the value for this header_name.
void | setText(String text) A convenience method that sets the given String as this part's content with a MIME type of "text/plain".
void | writeTo(OutputStream os) Output a bytestream for this Part.

Field Detail

ATTACHMENT

static final String ATTACHMENT
This part should be presented as an attachment.

See Also:
getDisposition(), setDisposition(java.lang.String), Constant Field Values

INLINE

static final String INLINE
This part should be presented inline.

See Also:
getDisposition(), setDisposition(java.lang.String), Constant Field Values
Method Detail

getSize

int getSize()
            throws MessagingException
Return the size of the content of this part in bytes. Return -1 if the size cannot be determined.

Note that the size may not be an exact measure of the content size and may or may not account for any transfer encoding of the content. The size is appropriate for display in a user interface to give the user a rough idea of the size of this part.

Returns:
size of content in bytes
Throws:
MessagingException

getLineCount

int getLineCount()
                 throws MessagingException
Return the number of lines in the content of this part. Return -1 if the number cannot be determined. Note that this number may not be an exact measure of the content length and may or may not account for any transfer encoding of the content.

Returns:
number of lines in the content.
Throws:
MessagingException

getContentType

String getContentType()
                      throws MessagingException
Returns the Content-Type of the content of this part. Returns null if the Content-Type could not be determined.

The MIME typing system is used to name Content-types.

Returns:
The ContentType of this part
Throws:
MessagingException
See Also:
DataHandler

isMimeType

boolean isMimeType(String mimeType)
                   throws MessagingException
Is this Part of the specified MIME type? This method compares only the primaryType and subType. The parameters of the content types are ignored.

For example, this method will return true when comparing a Part of content type "text/plain" with "text/plain; charset=foobar".

If the subType of mimeType is the special character '*', then the subtype is ignored during the comparison.

Throws:
MessagingException

getDisposition

String getDisposition()
                      throws MessagingException
Return the disposition of this part. The disposition describes how the part should be presented to the user. (See RFC 2183.) The return value should be considered without regard to case. For example:

 String disp = part.getDisposition();
 if (disp == null || disp.equalsIgnoreCase(Part.ATTACHMENT))
        // treat as attachment if not first part

Returns:
disposition of this part, or null if unknown
Throws:
MessagingException
See Also:
ATTACHMENT, INLINE, getFileName()

setDisposition

void setDisposition(String disposition)
                    throws MessagingException
Set the disposition of this part.

Parameters:
disposition - disposition of this part
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of this header
IllegalStateException - if this Part is obtained from a READ_ONLY folder
See Also:
ATTACHMENT, INLINE, setFileName(java.lang.String)

getDescription

String getDescription()
                      throws MessagingException
Return a description String for this part. This typically associates some descriptive information with this part. Returns null if none is available.

Returns:
description of this part
Throws:
MessagingException

setDescription

void setDescription(String description)
                    throws MessagingException
Set a description String for this part. This typically associates some descriptive information with this part.

Parameters:
description - description of this part
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of this header
IllegalStateException - if this Part is obtained from a READ_ONLY folder

getFileName

String getFileName()
                   throws MessagingException
Get the filename associated with this part, if possible. Useful if this part represents an "attachment" that was loaded from a file. The filename will usually be a simple name, not including directory components.

Returns:
Filename to associate with this part
Throws:
MessagingException

setFileName

void setFileName(String filename)
                 throws MessagingException
Set the filename associated with this part, if possible. Useful if this part represents an "attachment" that was loaded from a file. The filename will usually be a simple name, not including directory components.

Parameters:
filename - Filename to associate with this part
Throws:
IllegalWriteException - if the underlying implementation does not support modification of this header
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

getInputStream

InputStream getInputStream()
                           throws IOException,
                                  MessagingException
Return an input stream for this part's "content". Any mail-specific transfer encodings will be decoded before the input stream is provided.

This is typically a convenience method that just invokes the DataHandler's getInputStream() method.

Returns:
an InputStream
Throws:
IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
MessagingException
See Also:
getDataHandler(), DataHandler.getInputStream()

getDataHandler

DataHandler getDataHandler()
                           throws MessagingException
Return a DataHandler for the content within this part. The DataHandler allows clients to operate on as well as retrieve the content.

Returns:
DataHandler for the content
Throws:
MessagingException

getContent

Object getContent()
                  throws IOException,
                         MessagingException
Return the content as a Java object. The type of the returned object is of course dependent on the content itself. For example, the object returned for "text/plain" content is usually a String object. The object returned for a "multipart" content is always a Multipart subclass. For content-types that are unknown to the DataHandler system, an input stream is returned as the content

This is a convenience method that just invokes the DataHandler's getContent() method

Returns:
Object
Throws:
MessagingException
IOException - this is typically thrown by the DataHandler. Refer to the documentation for javax.activation.DataHandler for more details.
See Also:
DataHandler.getContent()

setDataHandler

void setDataHandler(DataHandler dh)
                    throws MessagingException
This method provides the mechanism to set this part's content. The DataHandler wraps around the actual content.

Parameters:
dh - The DataHandler for the content.
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder

setContent

void setContent(Object obj,
                String type)
                throws MessagingException
A convenience method for setting this part's content. The part internally wraps the content in a DataHandler.

Note that a DataContentHandler class for the specified type should be available to the JavaMail implementation for this to work right. i.e., to do setContent(foobar, "application/x-foobar"), a DataContentHandler for "application/x-foobar" should be installed. Refer to the Java Activation Framework for more information.

Parameters:
obj - A java object.
type - MIME type of this object.
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

setText

void setText(String text)
             throws MessagingException
A convenience method that sets the given String as this part's content with a MIME type of "text/plain".

Parameters:
text - The text that is the Message's content.
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

setContent

void setContent(Multipart mp)
                throws MessagingException
This method sets the given Multipart object as this message's content.

Parameters:
mp - The multipart object that is the Message's content
Throws:
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder
MessagingException

writeTo

void writeTo(OutputStream os)
             throws IOException,
                    MessagingException
Output a bytestream for this Part. This bytestream is typically an aggregration of the Part attributes and an appropriately encoded bytestream from its 'content'.

Classes that implement the Part interface decide on the appropriate encoding algorithm to be used.

The bytestream is typically used for sending.

Throws:
IOException - if an error occurs writing to the stream or if an error is generated by the javax.activation layer.
MessagingException - if an error occurs fetching the data to be written
See Also:
DataHandler.writeTo(java.io.OutputStream)

getHeader

String[] getHeader(String header_name)
                   throws MessagingException
Get all the headers for this header name. Returns null if no headers for this header name are available.

Parameters:
header_name - the name of this header
Returns:
the value fields for all headers with this name
Throws:
MessagingException

setHeader

void setHeader(String header_name,
               String header_value)
               throws MessagingException
Set the value for this header_name. Replaces all existing header values with this new value.

Parameters:
header_name - the name of this header
header_value - the value for this header
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder

addHeader

void addHeader(String header_name,
               String header_value)
               throws MessagingException
Add this value to the existing values for this header_name.

Parameters:
header_name - the name of this header
header_value - the value for this header
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder

removeHeader

void removeHeader(String header_name)
                  throws MessagingException
Remove all headers with this name.

Parameters:
header_name - the name of this header
Throws:
MessagingException
IllegalWriteException - if the underlying implementation does not support modification of existing values
IllegalStateException - if this Part is obtained from a READ_ONLY folder

getAllHeaders

Enumeration getAllHeaders()
                          throws MessagingException
Return all the headers from this part as an Enumeration of Header objects.

Returns:
enumeration of Header objects
Throws:
MessagingException

getMatchingHeaders

Enumeration getMatchingHeaders(String[] header_names)
                               throws MessagingException
Return matching headers from this part as an Enumeration of Header objects.

Returns:
enumeration of Header objects
Throws:
MessagingException

getNonMatchingHeaders

Enumeration getNonMatchingHeaders(String[] header_names)
                                  throws MessagingException
Return non-matching headers from this envelope as an Enumeration of Header objects.

Returns:
enumeration of Header objects
Throws:
MessagingException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PasswordAuthentication

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class PasswordAuthentication

java.lang.Object
    extended by  javax.mail.PasswordAuthentication

public final class PasswordAuthentication
extends Object

The class PasswordAuthentication is a data holder that is used by Authenticator. It is simply a repository for a user name and a password.

Version:
1.5, 08/29/05
Author:
Bill Foote
See Also:
PasswordAuthentication, Authenticator, Authenticator.getPasswordAuthentication()

Constructor Summary
PasswordAuthentication(String userName, String password)
Initialize a new PasswordAuthentication
Method Summary
String | getPassword()
String | getUserName()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PasswordAuthentication

public PasswordAuthentication(String userName,
                              String password)
Initialize a new PasswordAuthentication

Parameters:
userName - the user name
password - The user's password
Method Detail

getUserName

public String getUserName()
Returns:
the user name

getPassword

public String getPassword()
Returns:
the password
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Provider

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Provider

java.lang.Object
    extended by  javax.mail.Provider

public class Provider
extends Object

The Provider is a class that describes a protocol implementation. The values typically come from the javamail.providers and javamail.default.providers resource files. An application may also create and register a Provider object to dynamically add support for a new provider.

Version:
1.10, 05/08/29
Author:
Max Spivak, Bill Shannon

Nested Class Summary
static class Provider.Type
This inner class defines the Provider type.
Constructor Summary
Provider(Provider.Type type, String protocol, String classname, String vendor, String version)
Create a new provider of the specified type for the specified protocol.
Method Summary
 String getClassName()
Returns name of the class that implements the protocol
 String getProtocol()
Returns the protocol supported by this Provider
 Provider.Type getType()
Returns the type of this Provider
 String getVendor()
Returns name of vendor associated with this implementation or null
 String getVersion()
Returns version of this implementation or null if no version
 String toString()
Overrides Object.toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Provider

public Provider(Provider.Type type,
                String protocol,
                String classname,
                String vendor,
                String version)
Create a new provider of the specified type for the specified protocol. The specified class implements the provider.

Parameters:
type - Type.STORE or Type.TRANSPORT
protocol - valid protocol for the type
classname - class name that implements this protocol
vendor - optional string identifying the vendor (may be null)
version - optional implementation version string (may be null)
Since:
JavaMail 1.4
Method Detail

getType

public Provider.Type getType()
Returns the type of this Provider

getProtocol

public String getProtocol()
Returns the protocol supported by this Provider

getClassName

public String getClassName()
Returns name of the class that implements the protocol

getVendor

public String getVendor()
Returns name of vendor associated with this implementation or null

getVersion

public String getVersion()
Returns version of this implementation or null if no version

toString

public String toString()
Overrides Object.toString()

Overrides:
toString in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Provider.Type

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Provider.Type

java.lang.Object
    extended by  javax.mail.Provider.Type
Enclosing class:
Provider
public static class Provider.Type
extends Object

This inner class defines the Provider type. Currently, STORE and TRANSPORT are the only two provider types supported.

Field Summary
static Provider.Type | STORE
static Provider.Type | TRANSPORT
Method Summary
 String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

STORE

public static final Provider.Type STORE

TRANSPORT

public static final Provider.Type TRANSPORT
Method Detail

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Quota

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Quota

java.lang.Object
    extended by  javax.mail.Quota

public class Quota
extends Object

This class represents a set of quotas for a given quota root. Each quota root has a set of resources, represented by the Quota.Resource class. Each resource has a name (for example, "STORAGE"), a current usage, and a usage limit. See RFC 2087.

Since:
JavaMail 1.4
Version:
1.6, 05/08/29
Author:
Bill Shannon

Nested Class Summary
static class Quota.Resource
An individual resource in a quota root.
Field Summary
String | quotaRoot The name of the quota root.
Quota.Resource[] | resources The set of resources associated with this quota root.
Constructor Summary
Quota(String quotaRoot)
Create a Quota object for the named quotaroot with no associated resources.
Method Summary
 void setResourceLimit(String name, long limit)
Set a resource limit for this quota root.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

quotaRoot

public String quotaRoot
The name of the quota root.

resources

public Quota.Resource[] resources
The set of resources associated with this quota root.

Constructor Detail

Quota

public Quota(String quotaRoot)
Create a Quota object for the named quotaroot with no associated resources.

Parameters:
quotaRoot - the name of the quota root
Method Detail

setResourceLimit

public void setResourceLimit(String name,
                             long limit)
Set a resource limit for this quota root.

Parameters:
name - the name of the resource
limit - the resource limit
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Quota.Resource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Quota.Resource

java.lang.Object
    extended by  javax.mail.Quota.Resource
Enclosing class:
Quota
public static class Quota.Resource
extends Object

An individual resource in a quota root.

Since:
JavaMail 1.4

Field Summary
long | limit The usage limit for the resource.
String | name The name of the resource.
long | usage The current usage of the resource.
Constructor Summary
Quota.Resource(String name, long usage, long limit)
Construct a Resource object with the given name, usage, and limit.
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

public String name
The name of the resource.

usage

public long usage
The current usage of the resource.

limit

public long limit
The usage limit for the resource.

Constructor Detail

Quota.Resource

public Quota.Resource(String name,
                      long usage,
                      long limit)
Construct a Resource object with the given name, usage, and limit.

Parameters:
name - the resource name
usage - the current usage of the resource
limit - the usage limit for the resource
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


QuotaAwareStore

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Interface QuotaAwareStore

public interface QuotaAwareStore

An interface implemented by Stores that support quotas. The getQuota and setQuota methods support the quota model defined by the IMAP QUOTA extension. Refer to RFC 2087 for more information.

Since:
JavaMail 1.4

Method Summary
Quota[] | getQuota(String root) Get the quotas for the named quota root.
void | setQuota(Quota quota) Set the quotas for the quota root specified in the quota argument.

Method Detail

getQuota

Quota[] getQuota(String root)
                 throws MessagingException
Get the quotas for the named quota root. Quotas are controlled on the basis of a quota root, not (necessarily) a folder. The relationship between folders and quota roots depends on the server. Some servers might implement a single quota root for all folders owned by a user. Other servers might implement a separate quota root for each folder. A single folder can even have multiple quota roots, perhaps controlling quotas for different resources.

Parameters:
root - the name of the quota root
Returns:
array of Quota objects
Throws:
MessagingException - if the server doesn't support the QUOTA extension

setQuota

void setQuota(Quota quota)
              throws MessagingException
Set the quotas for the quota root specified in the quota argument. Typically this will be one of the quota roots obtained from the getQuota method, but it need not be.

Parameters:
quota - the quota to set
Throws:
MessagingException - if the server doesn't support the QUOTA extension
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ReadOnlyFolderException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class ReadOnlyFolderException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
                extended by  javax.mail.ReadOnlyFolderException
All Implemented Interfaces:
Serializable
public class ReadOnlyFolderException
extends MessagingException

This exception is thrown when an attempt is made to open a folder read-write access when the folder is marked read-only.

The getMessage() method returns more detailed information about the error that caused this exception.

Author:
Jim Glennon
See Also:
Serialized Form

Constructor Summary
ReadOnlyFolderException(Folder folder)
Constructs a MessagingException with the specified folder.
ReadOnlyFolderException(Folder folder, String message)
Constructs a MessagingException with the specified folder and the specified detail message.
Method Summary
 Folder getFolder()
Returns the dead Folder object.
Methods inherited from class javax.mail.MessagingException
getCause, getNextException, setNextException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ReadOnlyFolderException

public ReadOnlyFolderException(Folder folder)
Constructs a MessagingException with the specified folder.

Parameters:
folder - the Folder
Since:
JavaMail 1.2

ReadOnlyFolderException

public ReadOnlyFolderException(Folder folder,
                               String message)
Constructs a MessagingException with the specified folder and the specified detail message.

Parameters:
folder - the Folder
message - the detailed error message
Since:
JavaMail 1.2
Method Detail

getFolder

public Folder getFolder()
Returns the dead Folder object.

Since:
JavaMail 1.2
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


search

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.mail.search

Message search terms for the JavaMail API.

See:
Description

Class Summary
AddressStringTerm | This abstract class implements string comparisons for Message addresses.
AddressTerm | This class implements Message Address comparisons.
AndTerm | This class implements the logical AND operator on individual SearchTerms.
BodyTerm | This class implements searches on a Message Body.
ComparisonTerm | This class models the comparison operator.
DateTerm | This class implements comparisons for Dates
FlagTerm | This class implements comparisons for Message Flags.
FromStringTerm | This class implements string comparisons for the From Address header.
FromTerm | This class implements comparisons for the From Address header.
HeaderTerm | This class implements comparisons for Message headers.
IntegerComparisonTerm | This class implements comparisons for integers.
MessageIDTerm | This term models the RFC822 "MessageId" - a message-id for Internet messages that is supposed to be unique per message.
MessageNumberTerm | This class implements comparisons for Message numbers.
NotTerm | This class implements the logical NEGATION operator.
OrTerm | This class implements the logical OR operator on individual SearchTerms.
ReceivedDateTerm | This class implements comparisons for the Message Received date
RecipientStringTerm | This class implements string comparisons for the Recipient Address headers.
RecipientTerm | This class implements comparisons for the Recipient Address headers.
SearchTerm | Search criteria are expressed as a tree of search-terms, forming a parse-tree for the search expression.
SentDateTerm | This class implements comparisons for the Message SentDate.
SizeTerm | This class implements comparisons for Message sizes.
StringTerm | This class implements the match method for Strings.
SubjectTerm | This class implements comparisons for the Message Subject header.

Exception Summary
SearchException The exception thrown when a Search expression could not be handled.

Package javax.mail.search Description

Message search terms for the JavaMail API. This package defines classes that can be used to construct a search expression to search a folder for messages matching the expression; see the search method on javax.mail.Folder. See SearchTerm.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.mail.search Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.mail.search

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.mail.search.SearchTerm (implements java.io.Serializable)
      • javax.mail.search.AddressTerm
        • javax.mail.search.FromTerm
        • javax.mail.search.RecipientTerm
      • javax.mail.search.AndTerm
      • javax.mail.search.ComparisonTerm
        • javax.mail.search.DateTerm
          • javax.mail.search.ReceivedDateTerm
          • javax.mail.search.SentDateTerm
        • javax.mail.search.IntegerComparisonTerm
          • javax.mail.search.MessageNumberTerm
          • javax.mail.search.SizeTerm
      • javax.mail.search.FlagTerm
      • javax.mail.search.NotTerm
      • javax.mail.search.OrTerm
      • javax.mail.search.StringTerm
        • javax.mail.search.AddressStringTerm
          • javax.mail.search.FromStringTerm
          • javax.mail.search.RecipientStringTerm
        • javax.mail.search.BodyTerm
        • javax.mail.search.HeaderTerm
        • javax.mail.search.MessageIDTerm
        • javax.mail.search.SubjectTerm
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.mail.MessagingException
          • javax.mail.search.SearchException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AddressStringTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class AddressStringTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.StringTerm
            extended by  javax.mail.search.AddressStringTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
FromStringTerm, RecipientStringTerm
public abstract class AddressStringTerm
extends StringTerm

This abstract class implements string comparisons for Message addresses.

Note that this class differs from the AddressTerm class in that this class does comparisons on address strings rather than Address objects.

Since:
JavaMail 1.1
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
protected AddressStringTerm(String pattern)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
protected boolean | match(Address a) Check whether the address pattern specified in the constructor is a substring of the string representation of the given Address object.
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, hashCode, match
Methods inherited from class javax.mail.search.SearchTerm
match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AddressStringTerm

protected AddressStringTerm(String pattern)
Constructor.

Parameters:
pattern - the address pattern to be compared.
Method Detail

match

protected boolean match(Address a)
Check whether the address pattern specified in the constructor is a substring of the string representation of the given Address object.

Note that if the string representation of the given Address object contains charset or transfer encodings, the encodings must be accounted for, during the match process.

Parameters:
a - The comparison is applied to this Address object.
Returns:
true if the match succeeds, otherwise false.

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class StringTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AddressTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class AddressTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.AddressTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
FromTerm, RecipientTerm
public abstract class AddressTerm
extends SearchTerm

This class implements Message Address comparisons.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  Address address
The address.
Constructor Summary
protected AddressTerm(Address address)
Method Summary
boolean | equals(Object obj) Equality comparison.
Address | getAddress() Return the address to match with.
int | hashCode() Compute a hashCode for this object.
protected boolean | match(Address a) Match against the argument Address.
Methods inherited from class javax.mail.search.SearchTerm
match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

address

protected Address address
The address.

Constructor Detail

AddressTerm

protected AddressTerm(Address address)
Method Detail

getAddress

public Address getAddress()
Return the address to match with.

match

protected boolean match(Address a)
Match against the argument Address.

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class Object

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AndTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class AndTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.AndTerm
All Implemented Interfaces:
Serializable
public final class AndTerm
extends SearchTerm

This class implements the logical AND operator on individual SearchTerms.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  SearchTerm[] terms
The array of terms on which the AND operator should be applied.
Constructor Summary
AndTerm(SearchTerm[] t)
Constructor that takes an array of SearchTerms.
AndTerm(SearchTerm t1, SearchTerm t2)
Constructor that takes two terms.
Method Summary
boolean | equals(Object obj) Equality comparison.
SearchTerm[] | getTerms() Return the search terms.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) The AND operation.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

terms

protected SearchTerm[] terms
The array of terms on which the AND operator should be applied.

Constructor Detail

AndTerm

public AndTerm(SearchTerm t1,
               SearchTerm t2)
Constructor that takes two terms.

Parameters:
t1 - first term
t2 - second term

AndTerm

public AndTerm(SearchTerm[] t)
Constructor that takes an array of SearchTerms.

Parameters:
t - array of terms
Method Detail

getTerms

public SearchTerm[] getTerms()
Return the search terms.

match

public boolean match(Message msg)
The AND operation.

The terms specified in the constructor are applied to the given object and the AND operator is applied to their results.

Specified by:
match in class SearchTerm
Parameters:
msg - The specified SearchTerms are applied to this Message and the AND operator is applied to their results.
Returns:
true if the AND succeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class Object

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BodyTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class BodyTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.StringTerm
            extended by  javax.mail.search.BodyTerm
All Implemented Interfaces:
Serializable
public final class BodyTerm
extends StringTerm

This class implements searches on a Message Body. All parts of the message that are of MIME type "text/*" are searched.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
BodyTerm(String pattern)
Constructor
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BodyTerm

public BodyTerm(String pattern)
Constructor

Parameters:
pattern - The String to search for
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - The pattern search is applied on this Message's body
Returns:
true if the pattern is found; otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class StringTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ComparisonTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class ComparisonTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.ComparisonTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
DateTerm, IntegerComparisonTerm
public abstract class ComparisonTerm
extends SearchTerm

This class models the comparison operator. This is an abstract class; subclasses implement comparisons for different datatypes.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected int | comparison The comparison.
static int | EQ
static int | GE
static int | GT
static int | LE
static int | LT
static int | NE
Constructor Summary
ComparisonTerm()
Method Summary
boolean | equals(Object obj) Equality comparison.
int | hashCode() Compute a hashCode for this object.
Methods inherited from class javax.mail.search.SearchTerm
match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

LE

public static final int LE
See Also:
Constant Field Values

LT

public static final int LT
See Also:
Constant Field Values

EQ

public static final int EQ
See Also:
Constant Field Values

NE

public static final int NE
See Also:
Constant Field Values

GT

public static final int GT
See Also:
Constant Field Values

GE

public static final int GE
See Also:
Constant Field Values

comparison

protected int comparison
The comparison.

Constructor Detail

ComparisonTerm

public ComparisonTerm()
Method Detail

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class Object

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DateTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class DateTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.ComparisonTerm
            extended by  javax.mail.search.DateTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ReceivedDateTerm, SentDateTerm
public abstract class DateTerm
extends ComparisonTerm

This class implements comparisons for Dates

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  Date date
The date.
Fields inherited from class javax.mail.search.ComparisonTerm
comparison, EQ, GE, GT, LE, LT, NE
Constructor Summary
protected DateTerm(int comparison, Date date)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
int | getComparison() Return the type of comparison.
Date | getDate() Return the Date to compare with.
int | hashCode() Compute a hashCode for this object.
protected boolean | match(Date d) The date comparison method.
Methods inherited from class javax.mail.search.SearchTerm
match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

date

protected Date date
The date.

Constructor Detail

DateTerm

protected DateTerm(int comparison,
                   Date date)
Constructor.

Parameters:
comparison - the comparison type
date - The Date to be compared against
Method Detail

getDate

public Date getDate()
Return the Date to compare with.

getComparison

public int getComparison()
Return the type of comparison.

match

protected boolean match(Date d)
The date comparison method.

Parameters:
d - the date in the constructor is compared with this date
Returns:
true if the dates match, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class ComparisonTerm

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class ComparisonTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FlagTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class FlagTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.FlagTerm
All Implemented Interfaces:
Serializable
public final class FlagTerm
extends SearchTerm

This class implements comparisons for Message Flags.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected Flags | flags Flags object containing the flags to test.
protected boolean | set Indicates whether to test for the presence or absence of the specified Flag.
Constructor Summary
FlagTerm(Flags flags, boolean set)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
Flags | getFlags() Return the Flags to test.
boolean | getTestSet() Return true if testing whether the flags are set.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) The comparison method.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

set

protected boolean set
Indicates whether to test for the presence or absence of the specified Flag. If true, then test whether all the specified flags are present, else test whether all the specified flags are absent.

flags

protected Flags flags
Flags object containing the flags to test.

Constructor Detail

FlagTerm

public FlagTerm(Flags flags,
                boolean set)
Constructor.

Parameters:
flags - Flags object containing the flags to check for
set - the flag setting to check for
Method Detail

getFlags

public Flags getFlags()
Return the Flags to test.

getTestSet

public boolean getTestSet()
Return true if testing whether the flags are set.

match

public boolean match(Message msg)
The comparison method.

Specified by:
match in class SearchTerm
Parameters:
msg - The flag comparison is applied to this Message
Returns:
true if the comparson succeeds, otherwise false.

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class Object

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FromStringTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class FromStringTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.StringTerm
            extended by  javax.mail.search.AddressStringTerm
                extended by  javax.mail.search.FromStringTerm
All Implemented Interfaces:
Serializable
public final class FromStringTerm
extends AddressStringTerm

This class implements string comparisons for the From Address header.

Note that this class differs from the FromTerm class in that this class does comparisons on address strings rather than Address objects. The string comparisons are case-insensitive.

Since:
JavaMail 1.1
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
FromStringTerm(String pattern)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) Check whether the address string specified in the constructor is a substring of the From address of this Message.
Methods inherited from class javax.mail.search.AddressStringTerm
match
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FromStringTerm

public FromStringTerm(String pattern)
Constructor.

Parameters:
pattern - the address pattern to be compared.
Method Detail

match

public boolean match(Message msg)
Check whether the address string specified in the constructor is a substring of the From address of this Message.

Specified by:
match in class SearchTerm
Parameters:
msg - The comparison is applied to this Message's From address.
Returns:
true if the match succeeds, otherwise false.

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class AddressStringTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FromTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class FromTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.AddressTerm
            extended by  javax.mail.search.FromTerm
All Implemented Interfaces:
Serializable
public final class FromTerm
extends AddressTerm

This class implements comparisons for the From Address header.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.AddressTerm
address
Constructor Summary
FromTerm(Address address)
Constructor
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The address comparator.
Methods inherited from class javax.mail.search.AddressTerm
getAddress, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FromTerm

public FromTerm(Address address)
Constructor

Parameters:
address - The Address to be compared
Method Detail

match

public boolean match(Message msg)
The address comparator.

Specified by:
match in class SearchTerm
Parameters:
msg - The address comparison is applied to this Message
Returns:
true if the comparison succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class AddressTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HeaderTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class HeaderTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.StringTerm
            extended by  javax.mail.search.HeaderTerm
All Implemented Interfaces:
Serializable
public final class HeaderTerm
extends StringTerm

This class implements comparisons for Message headers. The comparison is case-insensitive.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  String headerName
The name of the header.
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
HeaderTerm(String headerName, String pattern)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
String | getHeaderName() Return the name of the header to compare with.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) The header match method.
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

headerName

protected String headerName
The name of the header.

Constructor Detail

HeaderTerm

public HeaderTerm(String headerName,
                  String pattern)
Constructor.

Parameters:
headerName - The name of the header
pattern - The pattern to search for
Method Detail

getHeaderName

public String getHeaderName()
Return the name of the header to compare with.

match

public boolean match(Message msg)
The header match method.

Specified by:
match in class SearchTerm
Parameters:
msg - The match is applied to this Message's header
Returns:
true if the match succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class StringTerm

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class StringTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


IntegerComparisonTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class IntegerComparisonTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.ComparisonTerm
            extended by  javax.mail.search.IntegerComparisonTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
MessageNumberTerm, SizeTerm
public abstract class IntegerComparisonTerm
extends ComparisonTerm

This class implements comparisons for integers.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  int number
The number.
Fields inherited from class javax.mail.search.ComparisonTerm
comparison, EQ, GE, GT, LE, LT, NE
Constructor Summary
protected IntegerComparisonTerm(int comparison, int number)
Method Summary
boolean | equals(Object obj) Equality comparison.
int | getComparison() Return the type of comparison.
int | getNumber() Return the number to compare with.
int | hashCode() Compute a hashCode for this object.
protected boolean | match(int i)
Methods inherited from class javax.mail.search.SearchTerm
match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

number

protected int number
The number.

Constructor Detail

IntegerComparisonTerm

protected IntegerComparisonTerm(int comparison,
                                int number)
Method Detail

getNumber

public int getNumber()
Return the number to compare with.

getComparison

public int getComparison()
Return the type of comparison.

match

protected boolean match(int i)

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class ComparisonTerm

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class ComparisonTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageIDTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class MessageIDTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.StringTerm
            extended by  javax.mail.search.MessageIDTerm
All Implemented Interfaces:
Serializable
public final class MessageIDTerm
extends StringTerm

This term models the RFC822 "MessageId" - a message-id for Internet messages that is supposed to be unique per message. Clients can use this term to search a folder for a message given its MessageId.

The MessageId is represented as a String.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
MessageIDTerm(String msgid)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MessageIDTerm

public MessageIDTerm(String msgid)
Constructor.

Parameters:
msgid - the msgid to search for
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - the match is applied to this Message's Message-ID header
Returns:
true if the match succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class StringTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageNumberTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class MessageNumberTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.ComparisonTerm
            extended by  javax.mail.search.IntegerComparisonTerm
                extended by  javax.mail.search.MessageNumberTerm
All Implemented Interfaces:
Serializable
public final class MessageNumberTerm
extends IntegerComparisonTerm

This class implements comparisons for Message numbers.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.IntegerComparisonTerm
number
Fields inherited from class javax.mail.search.ComparisonTerm
comparison, EQ, GE, GT, LE, LT, NE
Constructor Summary
MessageNumberTerm(int number)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.IntegerComparisonTerm
getComparison, getNumber, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MessageNumberTerm

public MessageNumberTerm(int number)
Constructor.

Parameters:
number - the Message number
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - the Message number is matched with this Message
Returns:
true if the match succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class IntegerComparisonTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NotTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class NotTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.NotTerm
All Implemented Interfaces:
Serializable
public final class NotTerm
extends SearchTerm

This class implements the logical NEGATION operator.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  SearchTerm term
The search term to negate.
Constructor Summary
NotTerm(SearchTerm t)
Method Summary
boolean | equals(Object obj) Equality comparison.
SearchTerm | getTerm() Return the term to negate.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) This method applies a specific match criterion to the given message and returns the result.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

term

protected SearchTerm term
The search term to negate.

Constructor Detail

NotTerm

public NotTerm(SearchTerm t)
Method Detail

getTerm

public SearchTerm getTerm()
Return the term to negate.

match

public boolean match(Message msg)
Description copied from class: SearchTerm
This method applies a specific match criterion to the given message and returns the result.

Specified by:
match in class SearchTerm
Parameters:
msg - The match criterion is applied on this message
Returns:
true, it the match succeeds, false if the match fails

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class Object

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


OrTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class OrTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.OrTerm
All Implemented Interfaces:
Serializable
public final class OrTerm
extends SearchTerm

This class implements the logical OR operator on individual SearchTerms.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  SearchTerm[] terms
The array of terms on which the OR operator should be applied.
Constructor Summary
OrTerm(SearchTerm[] t)
Constructor that takes an array of SearchTerms.
OrTerm(SearchTerm t1, SearchTerm t2)
Constructor that takes two operands.
Method Summary
boolean | equals(Object obj) Equality comparison.
SearchTerm[] | getTerms() Return the search terms.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) The OR operation.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

terms

protected SearchTerm[] terms
The array of terms on which the OR operator should be applied.

Constructor Detail

OrTerm

public OrTerm(SearchTerm t1,
              SearchTerm t2)
Constructor that takes two operands.

Parameters:
t1 - first term
t2 - second term

OrTerm

public OrTerm(SearchTerm[] t)
Constructor that takes an array of SearchTerms.

Parameters:
t - array of search terms
Method Detail

getTerms

public SearchTerm[] getTerms()
Return the search terms.

match

public boolean match(Message msg)
The OR operation.

The terms specified in the constructor are applied to the given object and the OR operator is applied to their results.

Specified by:
match in class SearchTerm
Parameters:
msg - The specified SearchTerms are applied to this Message and the OR operator is applied to their results.
Returns:
true if the OR succeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class Object

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ReceivedDateTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class ReceivedDateTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.ComparisonTerm
            extended by  javax.mail.search.DateTerm
                extended by  javax.mail.search.ReceivedDateTerm
All Implemented Interfaces:
Serializable
public final class ReceivedDateTerm
extends DateTerm

This class implements comparisons for the Message Received date

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.DateTerm
date
Fields inherited from class javax.mail.search.ComparisonTerm
comparison, EQ, GE, GT, LE, LT, NE
Constructor Summary
ReceivedDateTerm(int comparison, Date date)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.DateTerm
getComparison, getDate, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReceivedDateTerm

public ReceivedDateTerm(int comparison,
                        Date date)
Constructor.

Parameters:
comparison - the Comparison type
date - the date to be compared
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - the date comparator is applied to this Message's sent date
Returns:
true if the comparison succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class DateTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RecipientStringTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class RecipientStringTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.StringTerm
            extended by  javax.mail.search.AddressStringTerm
                extended by  javax.mail.search.RecipientStringTerm
All Implemented Interfaces:
Serializable
public final class RecipientStringTerm
extends AddressStringTerm

This class implements string comparisons for the Recipient Address headers.

Note that this class differs from the RecipientTerm class in that this class does comparisons on address strings rather than Address objects. The string comparisons are case-insensitive.

Since:
JavaMail 1.1
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
RecipientStringTerm(Message.RecipientType type, String pattern)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
Message.RecipientType | getRecipientType() Return the type of recipient to match with.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) Check whether the address specified in the constructor is a substring of the recipient address of this Message.
Methods inherited from class javax.mail.search.AddressStringTerm
match
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecipientStringTerm

public RecipientStringTerm(Message.RecipientType type,
                           String pattern)
Constructor.

Parameters:
type - the recipient type
pattern - the address pattern to be compared.
Method Detail

getRecipientType

public Message.RecipientType getRecipientType()
Return the type of recipient to match with.

match

public boolean match(Message msg)
Check whether the address specified in the constructor is a substring of the recipient address of this Message.

Specified by:
match in class SearchTerm
Parameters:
msg - The comparison is applied to this Message's recepient address.
Returns:
true if the match succeeds, otherwise false.

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class AddressStringTerm

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class StringTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RecipientTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class RecipientTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.AddressTerm
            extended by  javax.mail.search.RecipientTerm
All Implemented Interfaces:
Serializable
public final class RecipientTerm
extends AddressTerm

This class implements comparisons for the Recipient Address headers.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected  Message.RecipientType type
The recipient type.
Fields inherited from class javax.mail.search.AddressTerm
address
Constructor Summary
RecipientTerm(Message.RecipientType type, Address address)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
Message.RecipientType | getRecipientType() Return the type of recipient to match with.
int | hashCode() Compute a hashCode for this object.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.AddressTerm
getAddress, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

type

protected Message.RecipientType type
The recipient type.

Constructor Detail

RecipientTerm

public RecipientTerm(Message.RecipientType type,
                     Address address)
Constructor.

Parameters:
type - the recipient type
address - the address to match for
Method Detail

getRecipientType

public Message.RecipientType getRecipientType()
Return the type of recipient to match with.

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - The address match is applied to this Message's recepient address
Returns:
true if the match succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class AddressTerm

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class AddressTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SearchException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class SearchException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
                extended by  javax.mail.search.SearchException
All Implemented Interfaces:
Serializable
public class SearchException
extends MessagingException

The exception thrown when a Search expression could not be handled.

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
SearchException()
Constructs a SearchException with no detail message.
SearchException(String s)
Constructs a SearchException with the specified detail message.
Method Summary
Methods inherited from class javax.mail.MessagingException
getCause, getNextException, setNextException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SearchException

public SearchException()
Constructs a SearchException with no detail message.

SearchException

public SearchException(String s)
Constructs a SearchException with the specified detail message.

Parameters:
s - the detail message
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SearchTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class SearchTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AddressTerm, AndTerm, ComparisonTerm, FlagTerm, NotTerm, OrTerm, StringTerm
public abstract class SearchTerm
extends Object
implements Serializable

Search criteria are expressed as a tree of search-terms, forming a parse-tree for the search expression.

Search-terms are represented by this class. This is an abstract class; subclasses implement specific match methods.

Search terms are serializable, which allows storing a search term between sessions. Warning: Serialized objects of this class may not be compatible with future JavaMail API releases. The current serialization support is appropriate for short term storage.

Warning: Search terms that include references to objects of type Message.RecipientType will not be deserialized correctly on JDK 1.1 systems. While these objects will be deserialized without throwing any exceptions, the resulting objects violate the type-safe enum contract of the Message.RecipientType class. Proper deserialization of these objects depends on support for the readReplace method, added in JDK 1.2.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Constructor Summary
SearchTerm()
Method Summary
abstract  boolean match(Message msg)
This method applies a specific match criterion to the given message and returns the result.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SearchTerm

public SearchTerm()
Method Detail

match

public abstract boolean match(Message msg)
This method applies a specific match criterion to the given message and returns the result.

Parameters:
msg - The match criterion is applied on this message
Returns:
true, it the match succeeds, false if the match fails
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SentDateTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class SentDateTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.ComparisonTerm
            extended by  javax.mail.search.DateTerm
                extended by  javax.mail.search.SentDateTerm
All Implemented Interfaces:
Serializable
public final class SentDateTerm
extends DateTerm

This class implements comparisons for the Message SentDate.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.DateTerm
date
Fields inherited from class javax.mail.search.ComparisonTerm
comparison, EQ, GE, GT, LE, LT, NE
Constructor Summary
SentDateTerm(int comparison, Date date)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.DateTerm
getComparison, getDate, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SentDateTerm

public SentDateTerm(int comparison,
                    Date date)
Constructor.

Parameters:
comparison - the Comparison type
date - the date to be compared
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - the date comparator is applied to this Message's sent date
Returns:
true if the comparison succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class DateTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SizeTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class SizeTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.ComparisonTerm
            extended by  javax.mail.search.IntegerComparisonTerm
                extended by  javax.mail.search.SizeTerm
All Implemented Interfaces:
Serializable
public final class SizeTerm
extends IntegerComparisonTerm

This class implements comparisons for Message sizes.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.IntegerComparisonTerm
number
Fields inherited from class javax.mail.search.ComparisonTerm
comparison, EQ, GE, GT, LE, LT, NE
Constructor Summary
SizeTerm(int comparison, int size)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.IntegerComparisonTerm
getComparison, getNumber, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SizeTerm

public SizeTerm(int comparison,
                int size)
Constructor.

Parameters:
comparison - the Comparison type
size - the size
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - the size comparator is applied to this Message's size
Returns:
true if the size is equal, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class IntegerComparisonTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StringTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class StringTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.StringTerm
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AddressStringTerm, BodyTerm, HeaderTerm, MessageIDTerm, SubjectTerm
public abstract class StringTerm
extends SearchTerm

This class implements the match method for Strings. The current implementation provides only for substring matching. We could add comparisons (like strcmp ...).

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
protected boolean | ignoreCase Ignore case when comparing?
protected String | pattern The pattern.
Constructor Summary
protected | StringTerm(String pattern)
protected | StringTerm(String pattern, boolean ignoreCase)
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | getIgnoreCase() Return true if we should ignore case when matching.
String | getPattern() Return the string to match with.
int | hashCode() Compute a hashCode for this object.
protected boolean | match(String s)
Methods inherited from class javax.mail.search.SearchTerm
match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

pattern

protected String pattern
The pattern.

ignoreCase

protected boolean ignoreCase
Ignore case when comparing?

Constructor Detail

StringTerm

protected StringTerm(String pattern)

StringTerm

protected StringTerm(String pattern,
                     boolean ignoreCase)
Method Detail

getPattern

public String getPattern()
Return the string to match with.

getIgnoreCase

public boolean getIgnoreCase()
Return true if we should ignore case when matching.

match

protected boolean match(String s)

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class Object

hashCode

public int hashCode()
Compute a hashCode for this object.

Overrides:
hashCode in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SubjectTerm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.search
Class SubjectTerm

java.lang.Object
    extended by  javax.mail.search.SearchTerm
        extended by  javax.mail.search.StringTerm
            extended by  javax.mail.search.SubjectTerm
All Implemented Interfaces:
Serializable
public final class SubjectTerm
extends StringTerm

This class implements comparisons for the Message Subject header. The comparison is case-insensitive.

Author:
Bill Shannon, John Mani
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.mail.search.StringTerm
ignoreCase, pattern
Constructor Summary
SubjectTerm(String pattern)
Constructor.
Method Summary
boolean | equals(Object obj) Equality comparison.
boolean | match(Message msg) The match method.
Methods inherited from class javax.mail.search.StringTerm
getIgnoreCase, getPattern, hashCode, match
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SubjectTerm

public SubjectTerm(String pattern)
Constructor.

Parameters:
pattern - the pattern to search for
Method Detail

match

public boolean match(Message msg)
The match method.

Specified by:
match in class SearchTerm
Parameters:
msg - the pattern match is applied to this Message's subject header
Returns:
true if the pattern match succeeds, otherwise false

equals

public boolean equals(Object obj)
Equality comparison.

Overrides:
equals in class StringTerm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SendFailedException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class SendFailedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
                extended by  javax.mail.SendFailedException
All Implemented Interfaces:
Serializable
public class SendFailedException
extends MessagingException

This exception is thrown when the message cannot be sent.

The exception includes those addresses to which the message could not be sent as well as the valid addresses to which the message was sent and valid addresses to which the message was not sent.

Author:
John Mani, Max Spivak
See Also:
Transport.send(javax.mail.Message), Transport.sendMessage(javax.mail.Message, javax.mail.Address[]), TransportEvent, Serialized Form

Field Summary
protected Address[] | invalid
protected Address[] | validSent
protected Address[] | validUnsent
Constructor Summary
SendFailedException()
Constructs a SendFailedException with no detail message.
SendFailedException(String s)
Constructs a SendFailedException with the specified detail message.
SendFailedException(String s, Exception e)
Constructs a SendFailedException with the specified Exception and detail message.
SendFailedException(String msg, Exception ex, Address[] validSent, Address[] validUnsent, Address[] invalid)
Constructs a SendFailedException with the specified string and the specified address objects.
Method Summary
Address[] | getInvalidAddresses() Return the addresses to which this message could not be sent.
Address[] | getValidSentAddresses() Return the addresses to which this message was sent succesfully.
Address[] | getValidUnsentAddresses() Return the addresses that are valid but to which this message was not sent.
Methods inherited from class javax.mail.MessagingException
getCause, getNextException, setNextException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

invalid

protected transient Address[] invalid

validSent

protected transient Address[] validSent

validUnsent

protected transient Address[] validUnsent
Constructor Detail

SendFailedException

public SendFailedException()
Constructs a SendFailedException with no detail message.

SendFailedException

public SendFailedException(String s)
Constructs a SendFailedException with the specified detail message.

Parameters:
s - the detail message

SendFailedException

public SendFailedException(String s,
                           Exception e)
Constructs a SendFailedException with the specified Exception and detail message. The specified exception is chained to this exception.

Parameters:
s - the detail message
e - the embedded exception
See Also:
MessagingException.getNextException(), MessagingException.setNextException(java.lang.Exception)

SendFailedException

public SendFailedException(String msg,
                           Exception ex,
                           Address[] validSent,
                           Address[] validUnsent,
                           Address[] invalid)
Constructs a SendFailedException with the specified string and the specified address objects.

Parameters:
msg - the detail message
ex - the embedded exception
validSent - valid addresses to which message was sent
validUnsent - valid addresses to which message was not sent
invalid - the invalid addresses
See Also:
MessagingException.getNextException(), MessagingException.setNextException(java.lang.Exception)
Method Detail

getValidSentAddresses

public Address[] getValidSentAddresses()
Return the addresses to which this message was sent succesfully.

Returns:
Addresses to which the message was sent successfully or null

getValidUnsentAddresses

public Address[] getValidUnsentAddresses()
Return the addresses that are valid but to which this message was not sent.

Returns:
Addresses that are valid but to which the message was not sent successfully or null

getInvalidAddresses

public Address[] getInvalidAddresses()
Return the addresses to which this message could not be sent.

Returns:
Addresses to which the message sending failed or null;
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Service

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Service

java.lang.Object
    extended by  javax.mail.Service
Direct Known Subclasses:
Store, Transport
public abstract class Service
extends Object

An abstract class that contains the functionality common to messaging services, such as stores and transports.

A messaging service is created from a Session and is named using a URLName. A service must be connected before it can be used. Connection events are sent to reflect its connection status.

Version:
1.30, 05/08/29
Author:
Christopher Cotton, Bill Shannon, Kanwar Oberoi

Field Summary
protected boolean | debug Debug flag for this service.
protected Session | session The session from which this service was created.
protected URLName | url The URLName of this service.
Constructor Summary
protected Service(Session session, URLName urlname)
Constructor.
Method Summary
 void addConnectionListener(ConnectionListener l)
Add a listener for Connection events on this service.
 void close()
Close this service and terminate its connection.
 void connect()
A generic connect method that takes no parameters.
 void connect(String host, int port, String user, String password)
Similar to connect(host, user, password) except a specific port can be specified.
 void connect(String user, String password)
Connect to the current host using the specified username and password.
 void connect(String host, String user, String password)
Connect to the specified address.
protected  void finalize()
Stop the event dispatcher thread so the queue can be garbage collected.
 URLName getURLName()
Return a URLName representing this service.
 boolean isConnected()
Is this service currently connected?
protected  void notifyConnectionListeners(int type)
Notify all ConnectionListeners.
protected  boolean protocolConnect(String host, int port, String user, String password)
The service implementation should override this method to perform the actual protocol-specific connection attempt.
protected  void queueEvent(MailEvent event, Vector vector)
Add the event and vector of listeners to the queue to be delivered.
 void removeConnectionListener(ConnectionListener l)
Remove a Connection event listener.
protected  void setConnected(boolean connected)
Set the connection state of this service.
protected  void setURLName(URLName url)
Set the URLName representing this service.
 String toString()
Return getURLName.toString() if this service has a URLName, otherwise it will return the default toString.
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

session

protected Session session
The session from which this service was created.

url

protected URLName url
The URLName of this service.

debug

protected boolean debug
Debug flag for this service. Set from the session's debug flag when this service is created.

Constructor Detail

Service

protected Service(Session session,
                  URLName urlname)
Constructor.

Parameters:
session - Session object for this service
urlname - URLName object to be used for this service
Method Detail

connect

public void connect()
             throws MessagingException
A generic connect method that takes no parameters. Subclasses can implement the appropriate authentication schemes. Subclasses that need additional information might want to use some properties or might get it interactively using a popup window.

If the connection is successful, an "open" ConnectionEvent is delivered to any ConnectionListeners on this service.

Most clients should just call this method to connect to the service.

It is an error to connect to an already connected service.

The implementation provided here simply calls the following connect(String, String, String) method with nulls.

Throws:
AuthenticationFailedException - for authentication failures
MessagingException - for other failures
IllegalStateException - if the service is already connected
See Also:
ConnectionEvent

connect

public void connect(String host,
                    String user,
                    String password)
             throws MessagingException
Connect to the specified address. This method provides a simple authentication scheme that requires a username and password.

If the connection is successful, an "open" ConnectionEvent is delivered to any ConnectionListeners on this service.

It is an error to connect to an already connected service.

The implementation in the Service class will collect defaults for the host, user, and password from the session, from the URLName for this service, and from the supplied parameters and then call the protocolConnect method. If the protocolConnect method returns false, the user will be prompted for any missing information and the protocolConnect method will be called again. The subclass should override the protocolConnect method. The subclass should also implement the getURLName method, or use the implementation in this class.

On a successful connection, the setURLName method is called with a URLName that includes the information used to make the connection, including the password.

If the username passed in is null, a default value will be chosen as described above. If the password passed in is null and this is the first successful connection to this service, the user name and the password collected from the user will be saved as defaults for subsequent connection attempts to this same service when using other Service object instances (the connection information is typically always saved within a particular Service object instance). The password is saved using the Session method setPasswordAuthentication. If the password passed in is not null, it is not saved, on the assumption that the application is managing passwords explicitly.

Parameters:
host - the host to connect to
user - the user name
password - this user's password
Throws:
AuthenticationFailedException - for authentication failures
MessagingException - for other failures
IllegalStateException - if the service is already connected
See Also:
ConnectionEvent, Session.setPasswordAuthentication(javax.mail.URLName, javax.mail.PasswordAuthentication)

connect

public void connect(String user,
                    String password)
             throws MessagingException
Connect to the current host using the specified username and password. This method is equivalent to calling the connect(host, user, password) method with null for the host name.

Parameters:
user - the user name
password - this user's password
Throws:
AuthenticationFailedException - for authentication failures
MessagingException - for other failures
IllegalStateException - if the service is already connected
Since:
JavaMail 1.4
See Also:
ConnectionEvent, Session.setPasswordAuthentication(javax.mail.URLName, javax.mail.PasswordAuthentication), connect(java.lang.String, java.lang.String, java.lang.String)

connect

public void connect(String host,
                    int port,
                    String user,
                    String password)
             throws MessagingException
Similar to connect(host, user, password) except a specific port can be specified.

Parameters:
host - the host to connect to
port - the port to connect to (-1 means the default port)
user - the user name
password - this user's password
Throws:
AuthenticationFailedException - for authentication failures
MessagingException - for other failures
IllegalStateException - if the service is already connected
See Also:
connect(java.lang.String, java.lang.String, java.lang.String), ConnectionEvent

protocolConnect

protected boolean protocolConnect(String host,
                                  int port,
                                  String user,
                                  String password)
                           throws MessagingException
The service implementation should override this method to perform the actual protocol-specific connection attempt. The default implementation of the connect method calls this method as needed.

The protocolConnect method should return false if a user name or password is required for authentication but the corresponding parameter is null; the connect method will prompt the user when needed to supply missing information. This method may also return false if authentication fails for the supplied user name or password. Alternatively, this method may throw an AuthenticationFailedException when authentication fails. This exception may include a String message with more detail about the failure.

The protocolConnect method should throw an exception to report failures not related to authentication, such as an invalid host name or port number, loss of a connection during the authentication process, unavailability of the server, etc.

Parameters:
host - the name of the host to connect to
port - the port to use (-1 means use default port)
user - the name of the user to login as
password - the user's password
Returns:
true if connection successful, false if authentication failed
Throws:
AuthenticationFailedException - for authentication failures
MessagingException - for non-authentication failures

isConnected

public boolean isConnected()
Is this service currently connected?

This implementation uses a private boolean field to store the connection state. This method returns the value of that field.

Subclasses may want to override this method to verify that any connection to the message store is still alive.

Returns:
true if the service is connected, false if it is not connected

setConnected

protected void setConnected(boolean connected)
Set the connection state of this service. The connection state will automatically be set by the service implementation during the connect and close methods. Subclasses will need to call this method to set the state if the service was automatically disconnected.

The implementation in this class merely sets the private field returned by the isConnected method.

Parameters:
connected - true if the service is connected, false if it is not connected

close

public void close()
           throws MessagingException
Close this service and terminate its connection. A close ConnectionEvent is delivered to any ConnectionListeners. Any Messaging components (Folders, Messages, etc.) belonging to this service are invalid after this service is closed. Note that the service is closed even if this method terminates abnormally by throwing a MessagingException.

This implementation uses setConnected(false) to set this service's connected state to false. It will then send a close ConnectionEvent to any registered ConnectionListeners. Subclasses overriding this method to do implementation specific cleanup should call this method as a last step to insure event notification, probably by including a call to super.close() in a finally clause.

Throws:
MessagingException - for errors while closing
See Also:
ConnectionEvent

getURLName

public URLName getURLName()
Return a URLName representing this service. The returned URLName does not include the password field.

Subclasses should only override this method if their URLName does not follow the standard format.

The implementation in the Service class returns (usually a copy of) the url field with the password and file information stripped out.

Returns:
the URLName representing this service
See Also:
URLName

setURLName

protected void setURLName(URLName url)
Set the URLName representing this service. Normally used to update the url field after a service has successfully connected.

Subclasses should only override this method if their URL does not follow the standard format. In particular, subclasses should override this method if their URL does not require all the possible fields supported by URLName; a new URLName should be constructed with any unneeded fields removed.

The implementation in the Service class simply sets the url field.

See Also:
URLName

addConnectionListener

public void addConnectionListener(ConnectionListener l)
Add a listener for Connection events on this service.

The default implementation provided here adds this listener to an internal list of ConnectionListeners.

Parameters:
l - the Listener for Connection events
See Also:
ConnectionEvent

removeConnectionListener

public void removeConnectionListener(ConnectionListener l)
Remove a Connection event listener.

The default implementation provided here removes this listener from the internal list of ConnectionListeners.

Parameters:
l - the listener
See Also:
addConnectionListener(javax.mail.event.ConnectionListener)

notifyConnectionListeners

protected void notifyConnectionListeners(int type)
Notify all ConnectionListeners. Service implementations are expected to use this method to broadcast connection events.

The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered ConnectionListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

toString

public String toString()
Return getURLName.toString() if this service has a URLName, otherwise it will return the default toString.

Overrides:
toString in class Object

queueEvent

protected void queueEvent(MailEvent event,
                          Vector vector)
Add the event and vector of listeners to the queue to be delivered.

finalize

protected void finalize()
                 throws Throwable
Stop the event dispatcher thread so the queue can be garbage collected.

Overrides:
finalize in class Object
Throws:
Throwable
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Session

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Session

java.lang.Object
    extended by  javax.mail.Session

public final class Session
extends Object

The Session class represents a mail session and is not subclassed. It collects together properties and defaults used by the mail API's. A single default session can be shared by multiple applications on the desktop. Unshared sessions can also be created.

The Session class provides access to the protocol providers that implement the Store, Transport, and related classes. The protocol providers are configured using the following files:

  • javamail.providers and javamail.default.providers
  • javamail.address.map and javamail.default.address.map

Each javamail.X resource file is searched for using three methods in the following order:

  1. java.home/lib/javamail.X
  2. META-INF/javamail.X
  3. META-INF/javamail.default.X

The first method allows the user to include their own version of the resource file by placing it in the lib directory where the java.home property points. The second method allows an application that uses the JavaMail APIs to include their own resource files in their application's or jar file's META-INF directory. The javamail.default.X default files are part of the JavaMail mail.jar file.

File location depends upon how the ClassLoader method getResource is implemented. Usually, the getResource method searches through CLASSPATH until it finds the requested file and then stops. JDK 1.1 has a limitation that the number of files of each name that will be found in the CLASSPATH is limited to one. However, this only affects method two, above; method one is loaded from a specific location (if allowed by the SecurityManager) and method three uses a different name to ensure that the default resource file is always loaded successfully. J2SE 1.2 and later are not limited to one file of a given name.

The ordering of entries in the resource files matters. If multiple entries exist, the first entries take precedence over the later entries. For example, the first IMAP provider found will be set as the default IMAP implementation until explicitly changed by the application. The user- or system-supplied resource files augment, they do not override, the default files included with the JavaMail APIs. This means that all entries in all files loaded will be available.

javamail.providers and javamail.default.providers

These resource files specify the stores and transports that are available on the system, allowing an application to "discover" what store and transport implementations are available. The protocol implementations are listed one per line. The file format defines four attributes that describe a protocol implementation. Each attribute is an "="-separated name-value pair with the name in lowercase. Each name-value pair is semi-colon (";") separated. The following names are defined.

Attribute Names in Providers Files
Name | Description
protocol | Name assigned to protocol. For example, smtp for Transport.
type | Valid entries are store and transport.
class | Class name that implements this protocol.
vendor | Optional string identifying the vendor.
version | Optional string identifying the version.

Here's an example of META-INF/javamail.default.providers file contents:

 protocol=imap; type=store; class=com.sun.mail.imap.IMAPStore; vendor=Sun Microsystems, Inc.;
 protocol=smtp; type=transport; class=com.sun.mail.smtp.SMTPTransport; vendor=Sun Microsystems, Inc.;

javamail.address.map and javamail.default.address.map

These resource files map transport address types to the transport protocol. The getType method of javax.mail.Address returns the address type. The javamail.address.map file maps the transport type to the protocol. The file format is a series of name-value pairs. Each key name should correspond to an address type that is currently installed on the system; there should also be an entry for each javax.mail.Address implementation that is present if it is to be used. For example, the javax.mail.internet.InternetAddress method getType returns "rfc822". Each referenced protocol should be installed on the system. For the case of news, below, the client should install a Transport provider supporting the nntp protocol.

Here are the typical contents of a javamail.address.map file:

 rfc822=smtp
 news=nntp

Version:
1.71, 05/12/12
Author:
John Mani, Bill Shannon, Max Spivak

Method Summary
void | addProvider(Provider provider) Add a provider to the session.
boolean | getDebug() Get the debug setting for this Session.
PrintStream | getDebugOut() Returns the stream to be used for debugging output.
static Session | getDefaultInstance(Properties props) Get the default Session object.
static Session | getDefaultInstance(Properties props, Authenticator authenticator) Get the default Session object.
Folder | getFolder(URLName url) Get a closed Folder object for the given URLName.
static Session | getInstance(Properties props) Get a new Session object.
static Session | getInstance(Properties props, Authenticator authenticator) Get a new Session object.
PasswordAuthentication | getPasswordAuthentication(URLName url) Return any saved PasswordAuthentication for this (store or transport) URLName.
Properties | getProperties() Returns the Properties object associated with this Session
String | getProperty(String name) Returns the value of the specified property.
Provider | getProvider(String protocol) Returns the default Provider for the protocol specified.
Provider[] | getProviders() This method returns an array of all the implementations installed via the javamail.
Store | getStore() Get a Store object that implements this user's desired Store protocol.
Store | getStore(Provider provider) Get an instance of the store specified by Provider.
Store | getStore(String protocol) Get a Store object that implements the specified protocol.
Store | getStore(URLName url) Get a Store object for the given URLName.
Transport | getTransport() Get a Transport object that implements this user's desired Transport protcol.
Transport | getTransport(Address address) Get a Transport object that can transport a Message to the specified address type.
Transport | getTransport(Provider provider) Get an instance of the transport specified in the Provider.
Transport | getTransport(String protocol) Get a Transport object that implements the specified protocol.
Transport | getTransport(URLName url) Get a Transport object for the given URLName.
PasswordAuthentication | requestPasswordAuthentication(InetAddress addr, int port, String protocol, String prompt, String defaultUserName) Call back to the application to get the needed user name and password.
void | setDebug(boolean debug) Set the debug setting for this Session.
void | setDebugOut(PrintStream out) Set the stream to be used for debugging output for this session.
void | setPasswordAuthentication(URLName url, PasswordAuthentication pw) Save a PasswordAuthentication for this (store or transport) URLName.
void | setProtocolForAddress(String addresstype, String protocol) Set the default transport protocol to use for addresses of the specified type.
void | setProvider(Provider provider) Set the passed Provider to be the default implementation for the protocol in Provider.protocol overriding any previous values.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getInstance

public static Session getInstance(Properties props,
                                  Authenticator authenticator)
Get a new Session object.

Parameters:
props - Properties object that hold relevant properties.
It is expected that the client supplies values for the properties listed in Appendix A of the JavaMail spec (particularly mail.store.protocol, mail.transport.protocol, mail.host, mail.user, and mail.from) as the defaults are unlikely to work in all cases.
authenticator - Authenticator object used to call back to the application when a user name and password is needed.
Returns:
a new Session object
See Also:
Authenticator

getInstance

public static Session getInstance(Properties props)
Get a new Session object.

Parameters:
props - Properties object that hold relevant properties.
It is expected that the client supplies values for the properties listed in Appendix A of the JavaMail spec (particularly mail.store.protocol, mail.transport.protocol, mail.host, mail.user, and mail.from) as the defaults are unlikely to work in all cases.
Returns:
a new Session object
Since:
JavaMail 1.2

getDefaultInstance

public static Session getDefaultInstance(Properties props,
                                         Authenticator authenticator)
Get the default Session object. If a default has not yet been setup, a new Session object is created and installed as the default.

Since the default session is potentially available to all code executing in the same Java virtual machine, and the session can contain security sensitive information such as user names and passwords, access to the default session is restricted. The Authenticator object, which must be created by the caller, is used indirectly to check access permission. The Authenticator object passed in when the session is created is compared with the Authenticator object passed in to subsequent requests to get the default session. If both objects are the same, or are from the same ClassLoader, the request is allowed. Otherwise, it is denied.

Note that if the Authenticator object used to create the session is null, anyone can get the default session by passing in null.

Note also that the Properties object is used only the first time this method is called, when a new Session object is created. Subsequent calls return the Session object that was created by the first call, and ignore the passed Properties object. Use the getInstance method to get a new Session object every time the method is called.

In JDK 1.2, additional security Permission objects may be used to control access to the default session.

Parameters:
props - Properties object. Used only if a new Session object is created.
It is expected that the client supplies values for the properties listed in Appendix A of the JavaMail spec (particularly mail.store.protocol, mail.transport.protocol, mail.host, mail.user, and mail.from) as the defaults are unlikely to work in all cases.
authenticator - Authenticator object. Used only if a new Session object is created. Otherwise, it must match the Authenticator used to create the Session.
Returns:
the default Session object

getDefaultInstance

public static Session getDefaultInstance(Properties props)
Get the default Session object. If a default has not yet been setup, a new Session object is created and installed as the default.

Note that a default session created with no Authenticator is available to all code executing in the same Java virtual machine, and the session can contain security sensitive information such as user names and passwords.

Parameters:
props - Properties object. Used only if a new Session object is created.
It is expected that the client supplies values for the properties listed in Appendix A of the JavaMail spec (particularly mail.store.protocol, mail.transport.protocol, mail.host, mail.user, and mail.from) as the defaults are unlikely to work in all cases.
Returns:
the default Session object
Since:
JavaMail 1.2

setDebug

public void setDebug(boolean debug)
Set the debug setting for this Session.

Since the debug setting can be turned on only after the Session has been created, to turn on debugging in the Session constructor, set the property mail.debug in the Properties object passed in to the constructor to true. The value of the mail.debug property is used to initialize the per-Session debugging flag. Subsequent calls to the setDebug method manipulate the per-Session debugging flag and have no affect on the mail.debug property.

Parameters:
debug - Debug setting

getDebug

public boolean getDebug()
Get the debug setting for this Session.

Returns:
current debug setting

setDebugOut

public void setDebugOut(PrintStream out)
Set the stream to be used for debugging output for this session. If out is null, System.out will be used. Note that debugging output that occurs before any session is created, as a result of setting the mail.debug system property, will always be sent to System.out.

Parameters:
out - the PrintStream to use for debugging output
Since:
JavaMail 1.3

getDebugOut

public PrintStream getDebugOut()
Returns the stream to be used for debugging output. If no stream has been set, System.out is returned.

Returns:
the PrintStream to use for debugging output
Since:
JavaMail 1.3

getProviders

public Provider[] getProviders()
This method returns an array of all the implementations installed via the javamail.[default.]providers files that can be loaded using the ClassLoader available to this application.

Returns:
Array of configured providers

getProvider

public Provider getProvider(String protocol)
                     throws NoSuchProviderException
Returns the default Provider for the protocol specified. Checks mail.<protocol>.class property first and if it exists, returns the Provider associated with this implementation. If it doesn't exist, returns the Provider that appeared first in the configuration files. If an implementation for the protocol isn't found, throws NoSuchProviderException

Parameters:
protocol - Configured protocol (i.e. smtp, imap, etc)
Returns:
Currently configured Provider for the specified protocol
Throws:
NoSuchProviderException - If a provider for the given protocol is not found.

setProvider

public void setProvider(Provider provider)
                 throws NoSuchProviderException
Set the passed Provider to be the default implementation for the protocol in Provider.protocol overriding any previous values.

Parameters:
provider - Currently configured Provider which will be set as the default for the protocol
Throws:
NoSuchProviderException - If the provider passed in is invalid.

getStore

public Store getStore()
               throws NoSuchProviderException
Get a Store object that implements this user's desired Store protocol. The mail.store.protocol property specifies the desired protocol. If an appropriate Store object is not obtained, NoSuchProviderException is thrown

Returns:
a Store object
Throws:
NoSuchProviderException - If a provider for the given protocol is not found.

getStore

public Store getStore(String protocol)
               throws NoSuchProviderException
Get a Store object that implements the specified protocol. If an appropriate Store object cannot be obtained, NoSuchProviderException is thrown.

Parameters:
protocol -
Returns:
a Store object
Throws:
NoSuchProviderException - If a provider for the given protocol is not found.

getStore

public Store getStore(URLName url)
               throws NoSuchProviderException
Get a Store object for the given URLName. If the requested Store object cannot be obtained, NoSuchProviderException is thrown. The "scheme" part of the URL string (Refer RFC 1738) is used to locate the Store protocol.

Parameters:
url - URLName that represents the desired Store
Returns:
a closed Store object
Throws:
NoSuchProviderException - If a provider for the given URLName is not found.
See Also:
getFolder(URLName), URLName

getStore

public Store getStore(Provider provider)
               throws NoSuchProviderException
Get an instance of the store specified by Provider. Instantiates the store and returns it.

Parameters:
provider - Store Provider that will be instantiated
Returns:
Instantiated Store
Throws:
NoSuchProviderException - If a provider for the given Provider is not found.

getFolder

public Folder getFolder(URLName url)
                 throws MessagingException
Get a closed Folder object for the given URLName. If the requested Folder object cannot be obtained, null is returned.

The "scheme" part of the URL string (Refer RFC 1738) is used to locate the Store protocol. The rest of the URL string (that is, the "schemepart", as per RFC 1738) is used by that Store in a protocol dependent manner to locate and instantiate the appropriate Folder object.

Note that RFC 1738 also specifies the syntax for the "schemepart" for IP-based protocols (IMAP4, POP3, etc.). Providers of IP-based mail Stores should implement that syntax for referring to Folders.

Parameters:
url - URLName that represents the desired folder
Returns:
Folder
Throws:
NoSuchProviderException - If a provider for the given URLName is not found.
MessagingException - if the Folder could not be located or created.
See Also:
getStore(URLName), URLName

getTransport

public Transport getTransport()
                       throws NoSuchProviderException
Get a Transport object that implements this user's desired Transport protcol. The mail.transport.protocol property specifies the desired protocol. If an appropriate Transport object cannot be obtained, MessagingException is thrown.

Returns:
a Transport object
Throws:
NoSuchProviderException - If the provider is not found.

getTransport

public Transport getTransport(String protocol)
                       throws NoSuchProviderException
Get a Transport object that implements the specified protocol. If an appropriate Transport object cannot be obtained, null is returned.

Returns:
a Transport object
Throws:
NoSuchProviderException - If provider for the given protocol is not found.

getTransport

public Transport getTransport(URLName url)
                       throws NoSuchProviderException
Get a Transport object for the given URLName. If the requested Transport object cannot be obtained, NoSuchProviderException is thrown. The "scheme" part of the URL string (Refer RFC 1738) is used to locate the Transport protocol.

Parameters:
url - URLName that represents the desired Transport
Returns:
a closed Transport object
Throws:
NoSuchProviderException - If a provider for the given URLName is not found.
See Also:
URLName

getTransport

public Transport getTransport(Provider provider)
                       throws NoSuchProviderException
Get an instance of the transport specified in the Provider. Instantiates the transport and returns it.

Parameters:
provider - Transport Provider that will be instantiated
Returns:
Instantiated Transport
Throws:
NoSuchProviderException - If provider for the given provider is not found.

getTransport

public Transport getTransport(Address address)
                       throws NoSuchProviderException
Get a Transport object that can transport a Message to the specified address type.

Parameters:
address -
Returns:
A Transport object
Throws:
NoSuchProviderException - If provider for the Address type is not found
See Also:
Address

setPasswordAuthentication

public void setPasswordAuthentication(URLName url,
                                      PasswordAuthentication pw)
Save a PasswordAuthentication for this (store or transport) URLName. If pw is null the entry corresponding to the URLName is removed.

This is normally used only by the store or transport implementations to allow authentication information to be shared among multiple uses of a session.

getPasswordAuthentication

public PasswordAuthentication getPasswordAuthentication(URLName url)
Return any saved PasswordAuthentication for this (store or transport) URLName. Normally used only by store or transport implementations.

Returns:
the PasswordAuthentication corresponding to the URLName

requestPasswordAuthentication

public PasswordAuthentication requestPasswordAuthentication(InetAddress addr,
                                                            int port,
                                                            String protocol,
                                                            String prompt,
                                                            String defaultUserName)
Call back to the application to get the needed user name and password. The application should put up a dialog something like:

 Connecting to <protocol> mail service on host <addr>, port <port>.
 <prompt>

 User Name: <defaultUserName>
 Password:

Parameters:
addr - InetAddress of the host. may be null.
protocol - protocol scheme (e.g. imap, pop3, etc.)
prompt - any additional String to show as part of the prompt; may be null.
defaultUserName - the default username. may be null.
Returns:
the authentication which was collected by the authenticator; may be null.

getProperties

public Properties getProperties()
Returns the Properties object associated with this Session

Returns:
Properties object

getProperty

public String getProperty(String name)
Returns the value of the specified property. Returns null if this property does not exist.

Returns:
String that is the property value

addProvider

public void addProvider(Provider provider)
Add a provider to the session.

Parameters:
provider - the provider to add
Since:
JavaMail 1.4

setProtocolForAddress

public void setProtocolForAddress(String addresstype,
                                  String protocol)
Set the default transport protocol to use for addresses of the specified type. Normally the default is set by the javamail.default.address.map or javamail.address.map files or resources.

Parameters:
addresstype - type of address
protocol - name of protocol
Since:
JavaMail 1.4
See Also:
getTransport(Address)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Store

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Store

java.lang.Object
    extended by  javax.mail.Service
        extended by  javax.mail.Store

public abstract class Store
extends Service

An abstract class that models a message store and its access protocol, for storing and retrieving messages. Subclasses provide actual implementations.

Note that Store extends the Service class, which provides many common methods for naming stores, connecting to stores, and listening to connection events.

Version:
1.27, 05/08/29
Author:
John Mani, Bill Shannon
See Also:
Service, ConnectionEvent, StoreEvent

Field Summary
Fields inherited from class javax.mail.Service
debug, session, url
Constructor Summary
protected Store(Session session, URLName urlname)
Constructor.
Method Summary
void | addFolderListener(FolderListener l) Add a listener for Folder events on any Folder object obtained from this Store.
void | addStoreListener(StoreListener l) Add a listener for StoreEvents on this Store.
abstract Folder | getDefaultFolder() Returns a Folder object that represents the 'root' of the default namespace presented to the user by the Store.
abstract Folder | getFolder(String name) Return the Folder object corresponding to the given name.
abstract Folder | getFolder(URLName url) Return a closed Folder object, corresponding to the given URLName.
Folder[] | getPersonalNamespaces() Return a set of folders representing the personal namespaces for the current user.
Folder[] | getSharedNamespaces() Return a set of folders representing the shared namespaces.
Folder[] | getUserNamespaces(String user) Return a set of folders representing the namespaces for user.
protected void | notifyFolderListeners(int type, Folder folder) Notify all FolderListeners.
protected void | notifyFolderRenamedListeners(Folder oldF, Folder newF) Notify all FolderListeners about the renaming of a folder.
protected void | notifyStoreListeners(int type, String message) Notify all StoreListeners.
void | removeFolderListener(FolderListener l) Remove a listener for Folder events.
void | removeStoreListener(StoreListener l) Remove a listener for Store events.
Methods inherited from class javax.mail.Service
addConnectionListener, close, connect, connect, connect, connect, finalize, getURLName, isConnected, notifyConnectionListeners, protocolConnect, queueEvent, removeConnectionListener, setConnected, setURLName, toString
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Store

protected Store(Session session,
                URLName urlname)
Constructor.

Parameters:
session - Session object for this Store.
urlname - URLName object to be used for this Store
Method Detail

getDefaultFolder

public abstract Folder getDefaultFolder()
                                 throws MessagingException
Returns a Folder object that represents the 'root' of the default namespace presented to the user by the Store.

Returns:
the root Folder
Throws:
IllegalStateException - if this Store is not connected.
MessagingException

getFolder

public abstract Folder getFolder(String name)
                          throws MessagingException
Return the Folder object corresponding to the given name. Note that a Folder object is returned even if the named folder does not physically exist on the Store. The exists() method on the folder object indicates whether this folder really exists.

Folder objects are not cached by the Store, so invoking this method on the same name multiple times will return that many distinct Folder objects.

Parameters:
name - The name of the Folder. In some Stores, name can be an absolute path if it starts with the hierarchy delimiter. Else it is interpreted relative to the 'root' of this namespace.
Returns:
Folder object
Throws:
IllegalStateException - if this Store is not connected.
MessagingException
See Also:
Folder.exists(), Folder.create(int)

getFolder

public abstract Folder getFolder(URLName url)
                          throws MessagingException
Return a closed Folder object, corresponding to the given URLName. The store specified in the given URLName should refer to this Store object.

Implementations of this method may obtain the name of the actual folder using the getFile() method on URLName, and use that name to create the folder.

Parameters:
url - URLName that denotes a folder
Returns:
Folder object
Throws:
IllegalStateException - if this Store is not connected.
MessagingException
See Also:
URLName

getPersonalNamespaces

public Folder[] getPersonalNamespaces()
                               throws MessagingException
Return a set of folders representing the personal namespaces for the current user. A personal namespace is a set of names that is considered within the personal scope of the authenticated user. Typically, only the authenticated user has access to mail folders in their personal namespace. If an INBOX exists for a user, it must appear within the user's personal namespace. In the typical case, there should be only one personal namespace for each user in each Store.

This implementation returns an array with a single entry containing the return value of the getDefaultFolder method. Subclasses should override this method to return appropriate information.

Returns:
array of Folder objects
Throws:
IllegalStateException - if this Store is not connected.
MessagingException
Since:
JavaMail 1.2

getUserNamespaces

public Folder[] getUserNamespaces(String user)
                           throws MessagingException
Return a set of folders representing the namespaces for user. The namespaces returned represent the personal namespaces for the user. To access mail folders in the other user's namespace, the currently authenticated user must be explicitly granted access rights. For example, it is common for a manager to grant to their secretary access rights to their mail folders.

This implementation returns an empty array. Subclasses should override this method to return appropriate information.

Returns:
array of Folder objects
Throws:
IllegalStateException - if this Store is not connected.
MessagingException
Since:
JavaMail 1.2

getSharedNamespaces

public Folder[] getSharedNamespaces()
                             throws MessagingException
Return a set of folders representing the shared namespaces. A shared namespace is a namespace that consists of mail folders that are intended to be shared amongst users and do not exist within a user's personal namespace.

This implementation returns an empty array. Subclasses should override this method to return appropriate information.

Returns:
array of Folder objects
Throws:
IllegalStateException - if this Store is not connected.
MessagingException
Since:
JavaMail 1.2

addStoreListener

public void addStoreListener(StoreListener l)
Add a listener for StoreEvents on this Store.

The default implementation provided here adds this listener to an internal list of StoreListeners.

Parameters:
l - the Listener for Store events
See Also:
StoreEvent

removeStoreListener

public void removeStoreListener(StoreListener l)
Remove a listener for Store events.

The default implementation provided here removes this listener from the internal list of StoreListeners.

Parameters:
l - the listener
See Also:
addStoreListener(javax.mail.event.StoreListener)

notifyStoreListeners

protected void notifyStoreListeners(int type,
                                    String message)
Notify all StoreListeners. Store implementations are expected to use this method to broadcast StoreEvents.

The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered StoreListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

addFolderListener

public void addFolderListener(FolderListener l)
Add a listener for Folder events on any Folder object obtained from this Store. FolderEvents are delivered to FolderListeners on the affected Folder as well as to FolderListeners on the containing Store.

The default implementation provided here adds this listener to an internal list of FolderListeners.

Parameters:
l - the Listener for Folder events
See Also:
FolderEvent

removeFolderListener

public void removeFolderListener(FolderListener l)
Remove a listener for Folder events.

The default implementation provided here removes this listener from the internal list of FolderListeners.

Parameters:
l - the listener
See Also:
addFolderListener(javax.mail.event.FolderListener)

notifyFolderListeners

protected void notifyFolderListeners(int type,
                                     Folder folder)
Notify all FolderListeners. Store implementations are expected to use this method to broadcast Folder events.

The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered FolderListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

Parameters:
type - type of FolderEvent
folder - affected Folder
See Also:
notifyFolderRenamedListeners(javax.mail.Folder, javax.mail.Folder)

notifyFolderRenamedListeners

protected void notifyFolderRenamedListeners(Folder oldF,
                                            Folder newF)
Notify all FolderListeners about the renaming of a folder. Store implementations are expected to use this method to broadcast Folder events indicating the renaming of folders.

The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered FolderListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

Parameters:
oldF - the folder being renamed
newF - the folder representing the new name.
Since:
JavaMail 1.1
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StoreClosedException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class StoreClosedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.mail.MessagingException
                extended by  javax.mail.StoreClosedException
All Implemented Interfaces:
Serializable
public class StoreClosedException
extends MessagingException

This exception is thrown when a method is invoked on a Messaging object and the Store that owns that object has died due to some reason. This exception should be treated as a fatal error; in particular any messaging object belonging to that Store must be considered invalid.

The connect method may be invoked on the dead Store object to revive it.

The getMessage() method returns more detailed information about the error that caused this exception.

Author:
John Mani
See Also:
Serialized Form

Constructor Summary
StoreClosedException(Store store)
Constructor
StoreClosedException(Store store, String message)
Constructor
Method Summary
 Store getStore()
Returns the dead Store object
Methods inherited from class javax.mail.MessagingException
getCause, getNextException, setNextException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

StoreClosedException

public StoreClosedException(Store store)
Constructor

Parameters:
store - The dead Store object

StoreClosedException

public StoreClosedException(Store store,
                            String message)
Constructor

Parameters:
store - The dead Store object
message - The detailed error message
Method Detail

getStore

public Store getStore()
Returns the dead Store object

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Transport

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class Transport

java.lang.Object
    extended by  javax.mail.Service
        extended by  javax.mail.Transport

public abstract class Transport
extends Service

An abstract class that models a message transport. Subclasses provide actual implementations.

Note that Transport extends the Service class, which provides many common methods for naming transports, connecting to transports, and listening to connection events.

Version:
1.38, 05/08/29
Author:
John Mani, Max Spivak, Bill Shannon
See Also:
Service, ConnectionEvent, TransportEvent

Field Summary
Fields inherited from class javax.mail.Service
debug, session, url
Constructor Summary
Transport(Session session, URLName urlname)
Constructor.
Method Summary
void | addTransportListener(TransportListener l) Add a listener for Transport events.
protected void | notifyTransportListeners(int type, Address[] validSent, Address[] validUnsent, Address[] invalid, Message msg) Notify all TransportListeners.
void | removeTransportListener(TransportListener l) Remove a listener for Transport events.
static void | send(Message msg) Send a message.
static void | send(Message msg, Address[] addresses) Send the message to the specified addresses, ignoring any recipients specified in the message itself.
abstract void | sendMessage(Message msg, Address[] addresses) Send the Message to the specified list of addresses.
Methods inherited from class javax.mail.Service
addConnectionListener, close, connect, connect, connect, connect, finalize, getURLName, isConnected, notifyConnectionListeners, protocolConnect, queueEvent, removeConnectionListener, setConnected, setURLName, toString
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Transport

public Transport(Session session,
                 URLName urlname)
Constructor.

Parameters:
session - Session object for this Transport.
urlname - URLName object to be used for this Transport
Method Detail

send

public static void send(Message msg)
                 throws MessagingException
Send a message. The message will be sent to all recipient addresses specified in the message (as returned from the Message method getAllRecipients), using message transports appropriate to each address. The send method calls the saveChanges method on the message before sending it.

If any of the recipient addresses is detected to be invalid by the Transport during message submission, a SendFailedException is thrown. Clients can get more detail about the failure by examining the exception. Whether or not the message is still sent succesfully to any valid addresses depends on the Transport implementation. See SendFailedException for more details. Note also that success does not imply that the message was delivered to the ultimate recipient, as failures may occur in later stages of delivery. Once a Transport accepts a message for delivery to a recipient, failures that occur later should be reported to the user via another mechanism, such as returning the undeliverable message.

Parameters:
msg - the message to send
Throws:
SendFailedException - if the message could not be sent to some or any of the recipients.
MessagingException
See Also:
Message.saveChanges(),
Message.getAllRecipients(),
send(Message, Address[]),
SendFailedException

send

public static void send(Message msg,
                        Address[] addresses)
                 throws MessagingException
Send the message to the specified addresses, ignoring any recipients specified in the message itself. The send method calls the saveChanges method on the message before sending it.

Parameters:
msg - the message to send
addresses - the addresses to which to send the message
Throws:
SendFailedException - if the message could not be sent to some or any of the recipients.
MessagingException
See Also:
Message.saveChanges(), send(Message), SendFailedException

sendMessage

public abstract void sendMessage(Message msg,
                                 Address[] addresses)
                          throws MessagingException
Send the Message to the specified list of addresses. An appropriate TransportEvent indicating the delivery status is delivered to any TransportListener registered on this Transport. Also, if any of the addresses is invalid, a SendFailedException is thrown. Whether or not the message is still sent succesfully to any valid addresses depends on the Transport implementation.

Unlike the static send method, the sendMessage method does not call the saveChanges method on the message; the caller should do so.

Parameters:
msg - The Message to be sent
addresses - array of addresses to send this message to
Throws:
SendFailedException - if the send failed because of invalid addresses.
MessagingException - if the connection is dead or not in the connected state
See Also:
TransportEvent

addTransportListener

public void addTransportListener(TransportListener l)
Add a listener for Transport events.

The default implementation provided here adds this listener to an internal list of TransportListeners.

Parameters:
l - the Listener for Transport events
See Also:
TransportEvent

removeTransportListener

public void removeTransportListener(TransportListener l)
Remove a listener for Transport events.

The default implementation provided here removes this listener from the internal list of TransportListeners.

Parameters:
l - the listener
See Also:
addTransportListener(javax.mail.event.TransportListener)

notifyTransportListeners

protected void notifyTransportListeners(int type,
                                        Address[] validSent,
                                        Address[] validUnsent,
                                        Address[] invalid,
                                        Message msg)
Notify all TransportListeners. Transport implementations are expected to use this method to broadcast TransportEvents.

The provided default implementation queues the event into an internal event queue. An event dispatcher thread dequeues events from the queue and dispatches them to the registered TransportListeners. Note that the event dispatching occurs in a separate thread, thus avoiding potential deadlock problems.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIDFolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Interface UIDFolder

public interface UIDFolder

The UIDFolder interface is implemented by Folders that can support the "disconnected" mode of operation, by providing unique-ids for messages in the folder. This interface is based on the IMAP model for supporting disconnected operation.

A Unique identifier (UID) is a positive long value, assigned to each message in a specific folder. Unique identifiers are assigned in a strictly ascending fashion in the mailbox. That is, as each message is added to the mailbox it is assigned a higher UID than the message(s) which were added previously. Unique identifiers persist across sessions. This permits a client to resynchronize its state from a previous session with the server.

Associated with every mailbox is a unique identifier validity value. If unique identifiers from an earlier session fail to persist to this session, the unique identifier validity value must be greater than the one used in the earlier session.

Refer to RFC 2060 http://www.ietf.org/rfc/rfc2060.txt for more information.

Author:
John Mani

Nested Class Summary
static class UIDFolder.FetchProfileItem
A fetch profile item for fetching UIDs.
Field Summary
static long LASTUID
This is a special value that can be used as the end parameter in getMessages(start, end), to denote the last UID in this folder.
Method Summary
Message | getMessageByUID(long uid) Get the Message corresponding to the given UID.
Message[] | getMessagesByUID(long[] uids) Get the Messages specified by the given array of UIDs.
Message[] | getMessagesByUID(long start, long end) Get the Messages specified by the given range.
long | getUID(Message message) Get the UID for the specified message.
long | getUIDValidity() Returns the UIDValidity value associated with this folder.

Field Detail

LASTUID

static final long LASTUID
This is a special value that can be used as the end parameter in getMessages(start, end), to denote the last UID in this folder.

See Also:
getMessagesByUID(long, long), Constant Field Values
Method Detail

getUIDValidity

long getUIDValidity()
                    throws MessagingException
Returns the UIDValidity value associated with this folder.

Clients typically compare this value against a UIDValidity value saved from a previous session to insure that any cached UIDs are not stale.

Returns:
UIDValidity
Throws:
MessagingException

getMessageByUID

Message getMessageByUID(long uid)
                        throws MessagingException
Get the Message corresponding to the given UID. If no such message exists, null is returned.

Parameters:
uid - UID for the desired message
Returns:
the Message object. null is returned if no message corresponding to this UID is obtained.
Throws:
MessagingException

getMessagesByUID

Message[] getMessagesByUID(long start,
                           long end)
                           throws MessagingException
Get the Messages specified by the given range. The special value LASTUID can be used for the end parameter to indicate the last available UID.

Parameters:
start - start UID
end - end UID
Returns:
array of Message objects
Throws:
MessagingException
See Also:
LASTUID

getMessagesByUID

Message[] getMessagesByUID(long[] uids)
                           throws MessagingException
Get the Messages specified by the given array of UIDs. If any UID is invalid, null is returned for that entry.

Note that the returned array will be of the same size as the specified array of UIDs, and null entries may be present in the array to indicate invalid UIDs.

Parameters:
uids - array of UIDs
Returns:
array of Message objects
Throws:
MessagingException

getUID

long getUID(Message message)
            throws MessagingException
Get the UID for the specified message. Note that the message must belong to this folder. Otherwise java.util.NoSuchElementException is thrown.

Parameters:
message - Message from this folder
Returns:
UID for this message
Throws:
NoSuchElementException - if the given Message is not in this Folder.
MessagingException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UIDFolder.FetchProfileItem

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class UIDFolder.FetchProfileItem

java.lang.Object
    extended by  javax.mail.FetchProfile.Item
        extended by  javax.mail.UIDFolder.FetchProfileItem
Enclosing interface:
UIDFolder
public static class UIDFolder.FetchProfileItem
extends FetchProfile.Item

A fetch profile item for fetching UIDs. This inner class extends the FetchProfile.Item class to add new FetchProfile item types, specific to UIDFolders. The only item currently defined here is the UID item.

See Also:
FetchProfile

Field Summary
static UIDFolder.FetchProfileItem UID
UID is a fetch profile item that can be included in a FetchProfile during a fetch request to a Folder.
Fields inherited from class javax.mail.FetchProfile.Item
CONTENT_INFO, ENVELOPE, FLAGS
Constructor Summary
protected UIDFolder.FetchProfileItem(String name)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UID

public static final UIDFolder.FetchProfileItem UID
UID is a fetch profile item that can be included in a FetchProfile during a fetch request to a Folder. This item indicates that the UIDs for messages in the specified range are desired to be prefetched.

An example of how a client uses this is below:

        FetchProfile fp = new FetchProfile();
        fp.add(UIDFolder.FetchProfileItem.UID);
        folder.fetch(msgs, fp);

Constructor Detail

UIDFolder.FetchProfileItem

protected UIDFolder.FetchProfileItem(String name)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


URLName

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail
Class URLName

java.lang.Object
    extended by  javax.mail.URLName

public class URLName
extends Object

The name of a URL. This class represents a URL name and also provides the basic parsing functionality to parse most internet standard URL schemes.

Note that this class differs from java.net.URL in that this class just represents the name of a URL, it does not model the connection to a URL.

Version:
1.17, 05/08/29
Author:
Christopher Cotton, Bill Shannon

Field Summary
protected  String fullURL
The full version of the URL
Constructor Summary
URLName(String url)
Construct a URLName from the string.
URLName(String protocol, String host, int port, String file, String username, String password)
Creates a URLName object from the specified protocol, host, port number, file, username, and password.
URLName(URL url)
Construct a URLName from a java.net.URL object.
Method Summary
boolean | equals(Object obj) Compares two URLNames.
String | getFile() Returns the file name of this URLName.
String | getHost() Returns the host of this URLName.
String | getPassword() Returns the password of this URLName.
int | getPort() Returns the port number of this URLName.
String | getProtocol() Returns the protocol of this URLName.
String | getRef() Returns the reference of this URLName.
URL | getURL() Constructs a URL from the URLName.
String | getUsername() Returns the user name of this URLName.
int | hashCode() Compute the hash code for this URLName.
protected void | parseString(String url) Method which does all of the work of parsing the string.
String | toString() Constructs a string representation of this URLName.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

fullURL

protected String fullURL
The full version of the URL

Constructor Detail

URLName

public URLName(String protocol,
               String host,
               int port,
               String file,
               String username,
               String password)
Creates a URLName object from the specified protocol, host, port number, file, username, and password. Specifying a port number of -1 indicates that the URL should use the default port for the protocol.

URLName

public URLName(URL url)
Construct a URLName from a java.net.URL object.

URLName

public URLName(String url)
Construct a URLName from the string. Parses out all the possible information (protocol, host, port, file, username, password).

Method Detail

toString

public String toString()
Constructs a string representation of this URLName.

Overrides:
toString in class Object

parseString

protected void parseString(String url)
Method which does all of the work of parsing the string.

getPort

public int getPort()
Returns the port number of this URLName. Returns -1 if the port is not set.

getProtocol

public String getProtocol()
Returns the protocol of this URLName. Returns null if this URLName has no protocol.

getFile

public String getFile()
Returns the file name of this URLName. Returns null if this URLName has no file name.

getRef

public String getRef()
Returns the reference of this URLName. Returns null if this URLName has no reference.

getHost

public String getHost()
Returns the host of this URLName. Returns null if this URLName has no host.

getUsername

public String getUsername()
Returns the user name of this URLName. Returns null if this URLName has no user name.

getPassword

public String getPassword()
Returns the password of this URLName. Returns null if this URLName has no password.

getURL

public URL getURL()
           throws MalformedURLException
Constructs a URL from the URLName.

Throws:
MalformedURLException

equals

public boolean equals(Object obj)
Compares two URLNames. The result is true if and only if the argument is not null and is a URLName object that represents the same URLName as this object. Two URLName objects are equal if they have the same protocol and the same host, the same port number on the host, the same username, and the same file on the host. The fields (host, username, file) are also considered the same if they are both null.

Hosts are considered equal if the names are equal (case independent) or if host name lookups for them both succeed and they both reference the same IP address.

Note that URLName has no knowledge of default port numbers for particular protocols, so "imap://host" and "imap://host:143" would not compare as equal.

Note also that the password field is not included in the comparison, nor is any reference field appended to the filename.

Overrides:
equals in class Object

hashCode

public int hashCode()
Compute the hash code for this URLName.

Overrides:
hashCode in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


util

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.mail.util

Utility classes.

See:
Description

Class Summary
ByteArrayDataSource | A DataSource backed by a byte array.
SharedByteArrayInputStream | A ByteArrayInputStream that implements the SharedInputStream interface, allowing the underlying byte array to be shared between multiple readers.
SharedFileInputStream | A SharedFileInputStream is a BufferedInputStream that buffers data from the file and supports the mark and reset methods.

Package javax.mail.util Description

Utility classes. This package specifies utility classes that are useful with other JavaMail APIs.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.mail.util Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.mail.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.mail.util.ByteArrayDataSource (implements javax.activation.DataSource)
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.ByteArrayInputStream
        • javax.mail.util.SharedByteArrayInputStream (implements javax.mail.internet.SharedInputStream)
      • java.io.FilterInputStream
        • java.io.BufferedInputStream
          • javax.mail.util.SharedFileInputStream (implements javax.mail.internet.SharedInputStream)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ByteArrayDataSource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.util
Class ByteArrayDataSource

java.lang.Object
    extended by  javax.mail.util.ByteArrayDataSource
All Implemented Interfaces:
DataSource
public class ByteArrayDataSource
extends Object
implements DataSource

A DataSource backed by a byte array. The byte array may be passed in directly, or may be initialized from an InputStream or a String.

Since:
JavaMail 1.4
Author:
John Mani, Bill Shannon, Max Spivak

Constructor Summary
ByteArrayDataSource(byte[] data, String type)
Create a ByteArrayDataSource with data from the specified byte array and with the specified MIME type.
ByteArrayDataSource(InputStream is, String type)
Create a ByteArrayDataSource with data from the specified InputStream and with the specified MIME type.
ByteArrayDataSource(String data, String type)
Create a ByteArrayDataSource with data from the specified String and with the specified MIME type.
Method Summary
String | getContentType() Get the MIME content type of the data.
InputStream | getInputStream() Return an InputStream for the data.
String | getName() Get the name of the data.
OutputStream | getOutputStream() Return an OutputStream for the data.
void | setName(String name) Set the name of the data.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ByteArrayDataSource

public ByteArrayDataSource(InputStream is,
                           String type)
                    throws IOException
Create a ByteArrayDataSource with data from the specified InputStream and with the specified MIME type. The InputStream is read completely and the data is stored in a byte array.

Parameters:
is - the InputStream
type - the MIME type
Throws:
IOException - errors reading the stream

ByteArrayDataSource

public ByteArrayDataSource(byte[] data,
                           String type)
Create a ByteArrayDataSource with data from the specified byte array and with the specified MIME type.

Parameters:
data - the data
type - the MIME type

ByteArrayDataSource

public ByteArrayDataSource(String data,
                           String type)
                    throws IOException
Create a ByteArrayDataSource with data from the specified String and with the specified MIME type. The MIME type should include a charset parameter specifying the charset to be used for the string. If the parameter is not included, the default charset is used.

Parameters:
data - the String
type - the MIME type
Throws:
IOException - errors reading the String
Method Detail

getInputStream

public InputStream getInputStream()
                           throws IOException
Return an InputStream for the data. Note that a new stream is returned each time this method is called.

Specified by:
getInputStream in interface DataSource
Returns:
the InputStream
Throws:
IOException - if no data has been set

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
Return an OutputStream for the data. Writing the data is not supported; an IOException is always thrown.

Specified by:
getOutputStream in interface DataSource
Returns:
an OutputStream
Throws:
IOException - always

getContentType

public String getContentType()
Get the MIME content type of the data.

Specified by:
getContentType in interface DataSource
Returns:
the MIME type

getName

public String getName()
Get the name of the data. By default, an empty string ("") is returned.

Specified by:
getName in interface DataSource
Returns:
the name of this data

setName

public void setName(String name)
Set the name of the data.

Parameters:
name - the name of this data
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SharedByteArrayInputStream

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.mail.util
Class SharedByteArrayInputStream

java.lang.Object
    extended by  java.io.InputStream
        extended by  java.io.ByteArrayInputStream
            extended by  javax.mail.util.SharedByteArrayInputStream
All Implemented Interfaces:
Closeable, SharedInputStream
public class SharedByteArrayInputStream
extends ByteArrayInputStream
implements SharedInputStream

A ByteArrayInputStream that implements the SharedInputStream interface, allowing the underlying byte array to be shared between multiple readers.

Since:
JavaMail 1.4
Version:
1.4, 05/08/29
Author:
Bill Shannon

Field Summary
protected  int start
Position within shared buffer that this stream starts at.
Fields inherited from class java.io.ByteArrayInputStream
buf, count, mark, pos
Constructor Summary
SharedByteArrayInputStream(byte[] buf)
Create a SharedByteArrayInputStream representing the entire byte array.
SharedByteArrayInputStream(byte[] buf, int offset, int length)
Create a SharedByteArrayInputStream representing the part of the byte array from offset for length bytes.
Method Summary
long | getPosition() Return the current position in the InputStream, as an offset from the beginning of the InputStream.
InputStream | newStream(long start, long end) Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive).
Methods inherited from class java.io.ByteArrayInputStream
available, close, mark, markSupported, read, read, reset, skip
Methods inherited from class java.io.InputStream
read
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

start

protected int start
Position within shared buffer that this stream starts at.

Constructor Detail

SharedByteArrayInputStream

public SharedByteArrayInputStream(byte[] buf)
Create a SharedByteArrayInputStream representing the entire byte array.

Parameters:
buf - the byte array

SharedByteArrayInputStream

public SharedByteArrayInputStream(byte[] buf,
                                  int offset,
                                  int length)
Create a SharedByteArrayInputStream representing the part of the byte array from offset for length bytes.

Parameters:
buf - the byte array
offset - offset in byte array to first byte to include
length - number of bytes to include
Method Detail

getPosition

public long getPosition()
Return the current position in the InputStream, as an offset from the beginning of the InputStream.

Specified by:
getPosition in interface SharedInputStream
Returns:
the current position

newStream

public InputStream newStream(long start,
                             long end)
Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive). start must be non-negative. If end is -1, the new stream ends at the same place as this stream. The returned InputStream will also implement the SharedInputStream interface.

Specified by:
newStream in interface SharedInputStream
Parameters:
start - the starting position
end - the ending position + 1
Returns:
the new stream
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SharedFileInputStream

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.mail.util
Class SharedFileInputStream

java.lang.Object
    extended by  java.io.InputStream
        extended by  java.io.FilterInputStream
            extended by  java.io.BufferedInputStream
                extended by  javax.mail.util.SharedFileInputStream
All Implemented Interfaces:
Closeable, SharedInputStream
public class SharedFileInputStream
extends BufferedInputStream
implements SharedInputStream

A SharedFileInputStream is a BufferedInputStream that buffers data from the file and supports the mark and reset methods. It also supports the newStream method that allows you to create other streams that represent subsets of the file. A RandomAccessFile object is used to access the file data.

Since:
JavaMail 1.4
Author:
Bill Shannon

Field Summary
protected long | bufpos The file offset that corresponds to the first byte in the read buffer.
protected int | bufsize The normal size of the read buffer.
protected long | datalen The amount of data in this subset of the file.
protected RandomAccessFile | in The file containing the data.
protected long | start The file offset of the start of data in this subset of the file.
Fields inherited from class java.io.BufferedInputStream
buf, count, marklimit, markpos, pos
Constructor Summary
SharedFileInputStream(File file)
Creates a SharedFileInputStream for the file.
SharedFileInputStream(File file, int size)
Creates a SharedFileInputStream with the specified buffer size.
SharedFileInputStream(String file)
Creates a SharedFileInputStream for the named file
SharedFileInputStream(String file, int size)
Creates a SharedFileInputStream with the specified buffer size.
Method Summary
int | available() Returns the number of bytes that can be read from this input stream without blocking.
void | close() Closes this input stream and releases any system resources associated with the stream.
protected void | finalize() Force this stream to close.
long | getPosition() Return the current position in the InputStream, as an offset from the beginning of the InputStream.
void | mark(int readlimit) See the general contract of the mark method of InputStream.
boolean | markSupported() Tests if this input stream supports the mark and reset methods.
InputStream | newStream(long start, long end) Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive).
int | read() See the general contract of the read method of InputStream.
int | read(byte[] b, int off, int len) Reads bytes from this stream into the specified byte array, starting at the given offset.
void | reset() See the general contract of the reset method of InputStream.
long | skip(long n) See the general contract of the skip method of InputStream.
Methods inherited from class java.io.FilterInputStream
read
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

in

protected RandomAccessFile in
The file containing the data. Shared by all related SharedFileInputStreams.

bufsize

protected int bufsize
The normal size of the read buffer.

bufpos

protected long bufpos
The file offset that corresponds to the first byte in the read buffer.

start

protected long start
The file offset of the start of data in this subset of the file.

datalen

protected long datalen
The amount of data in this subset of the file.

Constructor Detail

SharedFileInputStream

public SharedFileInputStream(File file)
                      throws IOException
Creates a SharedFileInputStream for the file.

Parameters:
file - the file
Throws:
IOException

SharedFileInputStream

public SharedFileInputStream(String file)
                      throws IOException
Creates a SharedFileInputStream for the named file

Parameters:
file - the file
Throws:
IOException

SharedFileInputStream

public SharedFileInputStream(File file,
                             int size)
                      throws IOException
Creates a SharedFileInputStream with the specified buffer size.

Parameters:
file - the file
size - the buffer size.
Throws:
IllegalArgumentException - if size <= 0.="0." IOException

SharedFileInputStream

public SharedFileInputStream(String file,
                             int size)
                      throws IOException
Creates a SharedFileInputStream with the specified buffer size.

Parameters:
file - the file
size - the buffer size.
Throws:
IllegalArgumentException - if size <= 0.="0." IOException
Method Detail

read

public int read()
         throws IOException
See the general contract of the read method of InputStream.

Overrides:
read in class BufferedInputStream
Returns:
the next byte of data, or -1 if the end of the stream is reached.
Throws:
IOException - if an I/O error occurs.

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
Reads bytes from this stream into the specified byte array, starting at the given offset.

This method implements the general contract of the corresponding read method of the InputStream class.

Overrides:
read in class BufferedInputStream
Parameters:
b - destination buffer.
off - offset at which to start storing bytes.
len - maximum number of bytes to read.
Returns:
the number of bytes read, or -1 if the end of the stream has been reached.
Throws:
IOException - if an I/O error occurs.

skip

public long skip(long n)
          throws IOException
See the general contract of the skip method of InputStream.

Overrides:
skip in class BufferedInputStream
Parameters:
n - the number of bytes to be skipped.
Returns:
the actual number of bytes skipped.
Throws:
IOException - if an I/O error occurs.

available

public int available()
              throws IOException
Returns the number of bytes that can be read from this input stream without blocking.

Overrides:
available in class BufferedInputStream
Returns:
the number of bytes that can be read from this input stream without blocking.
Throws:
IOException - if an I/O error occurs.

mark

public void mark(int readlimit)
See the general contract of the mark method of InputStream.

Overrides:
mark in class BufferedInputStream
Parameters:
readlimit - the maximum limit of bytes that can be read before the mark position becomes invalid.
See Also:
reset()

reset

public void reset()
           throws IOException
See the general contract of the reset method of InputStream.

If markpos is -1 (no mark has been set or the mark has been invalidated), an IOException is thrown. Otherwise, pos is set equal to markpos.

Overrides:
reset in class BufferedInputStream
Throws:
IOException - if this stream has not been marked or if the mark has been invalidated.
See Also:
mark(int)

markSupported

public boolean markSupported()
Tests if this input stream supports the mark and reset methods. The markSupported method of SharedFileInputStream returns true.

Overrides:
markSupported in class BufferedInputStream
Returns:
a boolean indicating if this stream type supports the mark and reset methods.
See Also:
InputStream.mark(int), InputStream.reset()

close

public void close()
           throws IOException
Closes this input stream and releases any system resources associated with the stream.

Specified by:
close in interface Closeable
Overrides:
close in class BufferedInputStream
Throws:
IOException - if an I/O error occurs.

getPosition

public long getPosition()
Return the current position in the InputStream, as an offset from the beginning of the InputStream.

Specified by:
getPosition in interface SharedInputStream
Returns:
the current position

newStream

public InputStream newStream(long start,
                             long end)
Return a new InputStream representing a subset of the data from this InputStream, starting at start (inclusive) up to end (exclusive). start must be non-negative. If end is -1, the new stream ends at the same place as this stream. The returned InputStream will also implement the SharedInputStream interface.

Specified by:
newStream in interface SharedInputStream
Parameters:
start - the starting position
end - the ending position + 1
Returns:
the new stream

finalize

protected void finalize()
                 throws Throwable
Force this stream to close.

Overrides:
finalize in class Object
Throws:
Throwable
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


j2ee

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.management.j2ee

Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.

See:
Description

Interface Summary
ListenerRegistration | ListenerRegistration defines the methods which clients of the MEJB use to add and remove event listeners.
Management | The Management interface provides the APIs to navigate and manipulate managed objects.
ManagementHome | The required home interface for the J2EE Management EJB component (MEJB).

Package javax.management.j2ee Description

Provides the J2EE Management Enterprise Bean component (MEJB) interfaces.

Package Specification

  • JSR 77, J2EE Management

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • J2EE Tools

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.management.j2ee Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.management.j2ee

Package Hierarchies:
All Packages

Interface Hierarchy

  • java.rmi.Remote
    • javax.ejb.EJBHome
      • javax.management.j2ee.ManagementHome
    • javax.ejb.EJBObject
      • javax.management.j2ee.Management
  • java.io.Serializable
    • javax.management.j2ee.ListenerRegistration
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ListenerRegistration

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee
Interface ListenerRegistration

All Superinterfaces:
Serializable
public interface ListenerRegistration
extends Serializable

ListenerRegistration defines the methods which clients of the MEJB use to add and remove event listeners.

Author:
Hans Hrasna

Method Summary
void | addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) Add a listener to a registered managed object.
void | removeNotificationListener(ObjectName name, NotificationListener listener) Remove a listener from a registered managed object.

Method Detail

addNotificationListener

void addNotificationListener(ObjectName name,
                             NotificationListener listener,
                             NotificationFilter filter,
                             Object handback)
                             throws InstanceNotFoundException,
                                    RemoteException
Add a listener to a registered managed object.

Parameters:
name - The name of the managed object on which the listener should be added.
listener - The listener object which will handle the notifications emitted by the registered managed object.
filter - The filter object. If filter is null, no filtering will be performed before handling notifications.
handback - The context to be sent to the listener when a notification is emitted.
Throws:
InstanceNotFoundException - The managed object name provided does not match any of the registered managed objects.
RemoteException - A communication exception occurred during the execution of a remote method call

removeNotificationListener

void removeNotificationListener(ObjectName name,
                                NotificationListener listener)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       RemoteException
Remove a listener from a registered managed object.

Parameters:
name - The name of the managed object on which the listener should be removed.
listener - The listener object which will handle the notifications emitted by the registered managed object. This method will remove all the information related to this listener.
Throws:
InstanceNotFoundException - The managed object name provided does not match any of the registered managed objects.
ListenerNotFoundException - The listener is not registered in the managed object.
RemoteException - A communication exception occurred during the execution of a remote method call
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Management

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee
Interface Management

All Superinterfaces:
EJBObject, Remote
public interface Management
extends EJBObject

The Management interface provides the APIs to navigate and manipulate managed objects. The J2EE Management EJB component (MEJB) must implement this as its remote interface.

Author:
Hans Hrasna

Method Summary
Object | getAttribute(ObjectName name, String attribute) Gets the value of a specific attribute of a named managed object.
AttributeList | getAttributes(ObjectName name, String[] attributes) Enables the values of several attributes of a named managed object.
String | getDefaultDomain() Returns the default domain name of this MEJB.
ListenerRegistration | getListenerRegistry() Returns the listener registry implementation for this MEJB.
Integer | getMBeanCount() Returns the number of managed objects registered in the MEJB.
MBeanInfo | getMBeanInfo(ObjectName name) This method discovers the attributes and operations that a managed object exposes for management.
Object | invoke(ObjectName name, String operationName, Object[] params, String[] signature) Invokes an operation on a managed object.
boolean | isRegistered(ObjectName name) Checks whether a managed object, identified by its object name, is already registered with the MEJB.
Set | queryNames(ObjectName name, QueryExp query) Gets the names of managed objects controlled by the MEJB.
void | setAttribute(ObjectName name, Attribute attribute) Sets the value of a specific attribute of a named managed object.
AttributeList | setAttributes(ObjectName name, AttributeList attributes) Sets the values of several attributes of a named managed object.
Methods inherited from interface javax.ejb.EJBObject
getEJBHome, getHandle, getPrimaryKey, isIdentical, remove

Method Detail

queryNames

Set queryNames(ObjectName name,
               QueryExp query)
               throws RemoteException
Gets the names of managed objects controlled by the MEJB. This method enables any of the following to be obtained: The names of all managed objects, the names of a set of managed objects specified by pattern matching on the ObjectName, a specific managed object name (equivalent to testing whether a managed object is registered). When the object name is null or no domain and key properties are specified, all objects are selected. It returns the set of J2EEObjectNames for the managed objects selected.

Parameters:
name - The object name pattern identifying the managed objects to be retrieved. If null or no domain and key properties are specified, all the managed objects registered will be retrieved.
Returns:
A set containing the ObjectNames for the managed objects selected. If no managed object satisfies the query, an empty set is returned.
Throws:
RemoteException - A communication exception occurred during the execution of a remote method call

isRegistered

boolean isRegistered(ObjectName name)
                     throws RemoteException
Checks whether a managed object, identified by its object name, is already registered with the MEJB.

Parameters:
name - The object name of the managed object to be checked.
Returns:
True if the managed object is already registered in the MEJB, false otherwise.
Throws:
RemoteException - A communication exception occurred during the execution of a remote method call

getMBeanCount

Integer getMBeanCount()
                      throws RemoteException
Returns the number of managed objects registered in the MEJB.

Throws:
RemoteException - A communication exception occurred during the execution of a remote method call

getMBeanInfo

MBeanInfo getMBeanInfo(ObjectName name)
                       throws IntrospectionException,
                              InstanceNotFoundException,
                              ReflectionException,
                              RemoteException
This method discovers the attributes and operations that a managed object exposes for management.

Parameters:
name - The name of the managed object to analyze
Returns:
An instance of MBeanInfo allowing the retrieval of all attributes and operations of this managed object.
Throws:
IntrospectionException - An exception occurs during introspection.
InstanceNotFoundException - The managed object specified is not found.
ReflectionException - An exception occurred when trying to perform reflection on a managed object
RemoteException - A communication exception occurred during the execution of a remote method call

getAttribute

Object getAttribute(ObjectName name,
                    String attribute)
                    throws MBeanException,
                           AttributeNotFoundException,
                           InstanceNotFoundException,
                           ReflectionException,
                           RemoteException
Gets the value of a specific attribute of a named managed object. The managed object is identified by its object name.

Parameters:
name - The object name of the managed object from which the attribute is to be retrieved.
attribute - A String specifying the name of the attribute to be retrieved.
Returns:
The value of the retrieved attribute.
Throws:
AttributeNotFoundException - The attribute specified is not accessible in the managed object.
MBeanException - Wraps an exception thrown by the managed object's getter.
InstanceNotFoundException - The managed object specified is not registered in the MEJB.
ReflectionException - An exception occurred when trying to invoke the getAttribute method of a Dynamic MBean
RemoteException - A communication exception occurred during the execution of a remote method call

getAttributes

AttributeList getAttributes(ObjectName name,
                            String[] attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   RemoteException
Enables the values of several attributes of a named managed object. The managed object is identified by its object name.

Parameters:
name - The object name of the managed object from which the attributes are retrieved.
attributes - A list of the attributes to be retrieved.
Returns:
The list of the retrieved attributes.
Throws:
InstanceNotFoundException - The managed object specified is not registered in the MEJB.
ReflectionException - An exception occurred when trying to invoke the getAttributes method of a Dynamic MBean.
RemoteException - A communication exception occurred during the execution of a remote method call

setAttribute

void setAttribute(ObjectName name,
                  Attribute attribute)
                  throws InstanceNotFoundException,
                         AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException,
                         RemoteException
Sets the value of a specific attribute of a named managed object. The managed object is identified by its object name.

Parameters:
name - The name of the managed object within which the attribute is to be set.
attribute - The identification of the attribute to be set and the value it is to be set to.
Throws:
InstanceNotFoundException - The managed object specified is not registered in the MEJB.
AttributeNotFoundException - The attribute specified is not accessible in the managed object.
InvalidAttributeValueException - The value specified for the attribute is not valid.
MBeanException - Wraps an exception thrown by the managed object's setter.
ReflectionException - An exception occurred when trying to invoke the setAttribute method of a Dynamic MBean.
RemoteException - A communication exception occurred during the execution of a remote method call

setAttributes

AttributeList setAttributes(ObjectName name,
                            AttributeList attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   RemoteException
Sets the values of several attributes of a named managed object. The managed object is identified by its object name.

Parameters:
name - The object name of the managed object within which the attributes are to be set.
attributes - A list of attributes: The identification of the attributes to be set and the values they are to be set to.
Returns:
The list of attributes that were set, with their new values.
Throws:
InstanceNotFoundException - The managed object specified is not registered in the MEJB.
ReflectionException - An exception occurred when trying to invoke the setAttributes method of a Dynamic MBean.
RemoteException - A communication exception occurred during the execution of a remote method call

invoke

Object invoke(ObjectName name,
              String operationName,
              Object[] params,
              String[] signature)
              throws InstanceNotFoundException,
                     MBeanException,
                     ReflectionException,
                     RemoteException
Invokes an operation on a managed object.

Parameters:
name - The object name of the managed object on which the method is to be invoked.
operationName - The name of the operation to be invoked.
params - An array containing the parameters to be set when the operation is invoked
signature - An array containing the signature of the operation. The class objects will be loaded using the same class loader as the one used for loading the managed object on which the operation was invoked.
Returns:
The object returned by the operation, which represents the result of invoking the operation on the managed object specified.
Throws:
InstanceNotFoundException - The managed object specified is not registered in the MEJB.
MBeanException - Wraps an exception thrown by the managed object's invoked method.
ReflectionException - Wraps a java.lang.Exception thrown while trying to invoke the method.
RemoteException - A communication exception occurred during the execution of a remote method call

getDefaultDomain

String getDefaultDomain()
                        throws RemoteException
Returns the default domain name of this MEJB.

Throws:
RemoteException - A communication exception occurred during the execution of a remote method call

getListenerRegistry

ListenerRegistration getListenerRegistry()
                                         throws RemoteException
Returns the listener registry implementation for this MEJB. The listener registry implements the methods that enable clints to add and remove event notification listeners managed objects

Returns:
An implementation of javax.management.j2ee.ListenerRegistration
Throws:
RemoteException - A communication exception occurred during the execution of a remote method call
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ManagementHome

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee
Interface ManagementHome

All Superinterfaces:
EJBHome, Remote
public interface ManagementHome
extends EJBHome

The required home interface for the J2EE Management EJB component (MEJB). A J2EE client must be able to create a compliant session object using the specified create() method.

Author:
Hans Hrasna

Method Summary
 Management create()
Creates an MEJB session object which provides access to the J2EE Management Model
Methods inherited from interface javax.ejb.EJBHome
getEJBMetaData, getHomeHandle, remove, remove

Method Detail

create

Management create()
                  throws CreateException,
                         RemoteException
Creates an MEJB session object which provides access to the J2EE Management Model

Returns:
An MEJB session object which implements javax.management.j2ee.Management
Throws:
CreateExceotion - Indicates a failure to create the EJB object
RemoteException - A communication exception occurred during the execution of a remote method call
CreateException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


statistics

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.management.j2ee.statistics

Provides the standard interfaces for accessing performance data from J2EE managed objects Package Specification JSR 77, J2EE Management Related Documentation For overviews, tutorials, examples, guides, and tool documentation, please see: J2EE Tools


BoundedRangeStatistic

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface BoundedRangeStatistic

All Superinterfaces:
BoundaryStatistic, RangeStatistic, Statistic
public interface BoundedRangeStatistic
extends BoundaryStatistic, RangeStatistic

The BoundedRangeStatistic model aggregates the attributes of RangeStatistic and BoundaryStatistic and provides standard measurements of a range that has fixed limits.

Method Summary
Methods inherited from interface javax.management.j2ee.statistics.BoundaryStatistic
getLowerBound, getUpperBound
Methods inherited from interface javax.management.j2ee.statistics.Statistic
getDescription, getLastSampleTime, getName, getStartTime, getUnit
Methods inherited from interface javax.management.j2ee.statistics.RangeStatistic
getCurrent, getHighWaterMark, getLowWaterMark
Methods inherited from interface javax.management.j2ee.statistics.Statistic
getDescription, getLastSampleTime, getName, getStartTime, getUnit

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.management.j2ee.statistics Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.management.j2ee.statistics

Package Hierarchies:
All Packages

Interface Hierarchy

  • javax.management.j2ee.statistics.JavaMailStats
  • javax.management.j2ee.statistics.Statistic
    • javax.management.j2ee.statistics.BoundaryStatistic
      • javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.RangeStatistic)
    • javax.management.j2ee.statistics.CountStatistic
    • javax.management.j2ee.statistics.RangeStatistic
      • javax.management.j2ee.statistics.BoundedRangeStatistic (also extends javax.management.j2ee.statistics.BoundaryStatistic)
    • javax.management.j2ee.statistics.TimeStatistic
  • javax.management.j2ee.statistics.Stats
    • javax.management.j2ee.statistics.EJBStats
      • javax.management.j2ee.statistics.EntityBeanStats
      • javax.management.j2ee.statistics.MessageDrivenBeanStats
      • javax.management.j2ee.statistics.SessionBeanStats
        • javax.management.j2ee.statistics.StatefulSessionBeanStats
        • javax.management.j2ee.statistics.StatelessSessionBeanStats
    • javax.management.j2ee.statistics.JCAConnectionStats
      • javax.management.j2ee.statistics.JCAConnectionPoolStats
    • javax.management.j2ee.statistics.JCAStats
    • javax.management.j2ee.statistics.JDBCConnectionStats
      • javax.management.j2ee.statistics.JDBCConnectionPoolStats
    • javax.management.j2ee.statistics.JDBCStats
    • javax.management.j2ee.statistics.JMSConnectionStats
    • javax.management.j2ee.statistics.JMSEndpointStats
      • javax.management.j2ee.statistics.JMSConsumerStats
      • javax.management.j2ee.statistics.JMSProducerStats
    • javax.management.j2ee.statistics.JMSSessionStats
    • javax.management.j2ee.statistics.JMSStats
    • javax.management.j2ee.statistics.JTAStats
    • javax.management.j2ee.statistics.JVMStats
    • javax.management.j2ee.statistics.ServletStats
    • javax.management.j2ee.statistics.URLStats
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StatelessSessionBeanStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface StatelessSessionBeanStats

All Superinterfaces:
EJBStats, SessionBeanStats, Stats
public interface StatelessSessionBeanStats
extends SessionBeanStats

Specifies the statistics provided by a stateless session bean.

Method Summary
Methods inherited from interface javax.management.j2ee.statistics.SessionBeanStats
getMethodReadyCount
Methods inherited from interface javax.management.j2ee.statistics.EJBStats
getCreateCount, getRemoveCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


URLStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface URLStats

All Superinterfaces:
Stats
public interface URLStats
extends Stats

Specifies the statistics provided by a URL resource.

Method Summary
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BoundaryStatistic

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface BoundaryStatistic

All Superinterfaces:
Statistic
All Known Subinterfaces:
BoundedRangeStatistic
public interface BoundaryStatistic
extends Statistic

Specifies standard measurements of the upper and lower limits of the value of an attribute.

Method Summary
long | getLowerBound() The lower limit of the value of this attribute.The upper limit of the value of this attribute.
long | getUpperBound() The upper limit of the value of this attribute.
Methods inherited from interface javax.management.j2ee.statistics.Statistic
getDescription, getLastSampleTime, getName, getStartTime, getUnit

Method Detail

getUpperBound

long getUpperBound()
The upper limit of the value of this attribute.

getLowerBound

long getLowerBound()
The lower limit of the value of this attribute.The upper limit of the value of this attribute.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


CountStatistic

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface CountStatistic

All Superinterfaces:
Statistic
public interface CountStatistic
extends Statistic

Specifies standard count measurements.

Method Summary
 long getCount()
The count since the last reset.
Methods inherited from interface javax.management.j2ee.statistics.Statistic
getDescription, getLastSampleTime, getName, getStartTime, getUnit

Method Detail

getCount

long getCount()
The count since the last reset.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface EJBStats

All Superinterfaces:
Stats
All Known Subinterfaces:
EntityBeanStats, MessageDrivenBeanStats, SessionBeanStats, StatefulSessionBeanStats, StatelessSessionBeanStats
public interface EJBStats
extends Stats

Specifies statistics provided by all EJB component types.

Method Summary
CountStatistic | getCreateCount() Number of times create was called.
CountStatistic | getRemoveCount() Number of times remove was called.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getCreateCount

CountStatistic getCreateCount()
Number of times create was called.

getRemoveCount

CountStatistic getRemoveCount()
Number of times remove was called.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EntityBeanStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface EntityBeanStats

All Superinterfaces:
EJBStats, Stats
public interface EntityBeanStats
extends EJBStats

Specifies statistics provided by entity beans.

Method Summary
RangeStatistic | getPooledCount() Number of beans in the pooled state.
RangeStatistic | getReadyCount() Number of beans in the ready state.
Methods inherited from interface javax.management.j2ee.statistics.EJBStats
getCreateCount, getRemoveCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getReadyCount

RangeStatistic getReadyCount()
Number of beans in the ready state.

getPooledCount

RangeStatistic getPooledCount()
Number of beans in the pooled state.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JavaMailStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JavaMailStats

public interface JavaMailStats

Specifies the statistics provided by a JavaMail resource.

Method Summary
 CountStatistic getSentMailCount()
The number of mail messages sent.

Method Detail

getSentMailCount

CountStatistic getSentMailCount()
The number of mail messages sent.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JCAConnectionPoolStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JCAConnectionPoolStats

All Superinterfaces:
JCAConnectionStats, Stats
public interface JCAConnectionPoolStats
extends JCAConnectionStats

Specifies the statistics provided by a JCA Connection Pool

Method Summary
CountStatistic | getCloseCount() The number of connections closed
CountStatistic | getCreateCount() The number of connections created
BoundedRangeStatistic | getFreePoolSize() The number of free connections in the pool
BoundedRangeStatistic | getPoolSize() The size of the connection pool
RangeStatistic | getWaitingThreadCount() The number of threads waiting for a connection
Methods inherited from interface javax.management.j2ee.statistics.JCAConnectionStats
getConnectionFactory, getManagedConnectionFactory, getUseTime, getWaitTime
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getCloseCount

CountStatistic getCloseCount()
The number of connections closed

Returns:
CountStatistic

getCreateCount

CountStatistic getCreateCount()
The number of connections created

Returns:
CountStatistic

getFreePoolSize

BoundedRangeStatistic getFreePoolSize()
The number of free connections in the pool

Returns:
BoundedRangeStatistic

getPoolSize

BoundedRangeStatistic getPoolSize()
The size of the connection pool

Returns:
BoundedRangeStatistic

getWaitingThreadCount

RangeStatistic getWaitingThreadCount()
The number of threads waiting for a connection

Returns:
BoundedRangeStatistic
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JCAConnectionStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JCAConnectionStats

All Superinterfaces:
Stats
All Known Subinterfaces:
JCAConnectionPoolStats
public interface JCAConnectionStats
extends Stats

Specifies the statistics provided by a JCA connection

Method Summary
String | getConnectionFactory() Returns the associated JCAConnectionFactory OBJECT_NAME
String | getManagedConnectionFactory() Returns the associated JCAManagedConnectionFactory OBJECT_NAME
TimeStatistic | getUseTime() Returns the time spent using a connection
TimeStatistic | getWaitTime() Returns the time spent waiting for a connection to be available
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getConnectionFactory

String getConnectionFactory()
Returns the associated JCAConnectionFactory OBJECT_NAME

Returns:
String the OBJECT_NAME of the managed object that identifies the connection factory for this connection

getManagedConnectionFactory

String getManagedConnectionFactory()
Returns the associated JCAManagedConnectionFactory OBJECT_NAME

Returns:
String the OBJECT_NAME of the managed object that identifies the managed connection factory for this connection

getWaitTime

TimeStatistic getWaitTime()
Returns the time spent waiting for a connection to be available

Returns:
TimeStatistic

getUseTime

TimeStatistic getUseTime()
Returns the time spent using a connection

Returns:
TimeStatistic
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JCAStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JCAStats

All Superinterfaces:
Stats
public interface JCAStats
extends Stats

Specifies statistics provided by a JCA resource

Method Summary
JCAConnectionPoolStats[] | getConnectionPools() Returns an array of JCAConnectionPool Stats that provide statistics about the connection pools associated with the referencing JCA resource statistics
JCAConnectionStats[] | getConnections() Returns an array of JCAConnectionStats that provide statistics about the non-pooled connections associated with the referencing JCA resource statistics
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getConnections

JCAConnectionStats[] getConnections()
Returns an array of JCAConnectionStats that provide statistics about the non-pooled connections associated with the referencing JCA resource statistics

Returns:
JCAConnectionStats []

getConnectionPools

JCAConnectionPoolStats[] getConnectionPools()
Returns an array of JCAConnectionPool Stats that provide statistics about the connection pools associated with the referencing JCA resource statistics

Returns:
JCAConnectionPoolStats []
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JDBCConnectionPoolStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JDBCConnectionPoolStats

All Superinterfaces:
JDBCConnectionStats, Stats
public interface JDBCConnectionPoolStats
extends JDBCConnectionStats

Specifies the statistics provided by a JDBC connection pool.

Method Summary
CountStatistic | getCloseCount() Number of connections closed.
CountStatistic | getCreateCount() Number of connections created.
BoundedRangeStatistic | getFreePoolSize() Number of free connections in the pool.
BoundedRangeStatistic | getPoolSize() Size of the connection pool.
RangeStatistic | getWaitingThreadCount() Number of threads waiting for a connection.
Methods inherited from interface javax.management.j2ee.statistics.JDBCConnectionStats
getJdbcDataSource, getUseTime, getWaitTime
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getCreateCount

CountStatistic getCreateCount()
Number of connections created.

getCloseCount

CountStatistic getCloseCount()
Number of connections closed.

getPoolSize

BoundedRangeStatistic getPoolSize()
Size of the connection pool.

getFreePoolSize

BoundedRangeStatistic getFreePoolSize()
Number of free connections in the pool.

getWaitingThreadCount

RangeStatistic getWaitingThreadCount()
Number of threads waiting for a connection.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JDBCConnectionStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JDBCConnectionStats

All Superinterfaces:
Stats
All Known Subinterfaces:
JDBCConnectionPoolStats
public interface JDBCConnectionStats
extends Stats

Specifies the statistics provided by all (pooled and non-pooled) JDBC connections.

Method Summary
String | getJdbcDataSource() Identifies the JDBC driver for the corresponding JDBCConnection.
TimeStatistic | getUseTime() Time spent using a connection.
TimeStatistic | getWaitTime() Time spent waiting for a connection to be available.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getJdbcDataSource

String getJdbcDataSource()
Identifies the JDBC driver for the corresponding JDBCConnection.

getWaitTime

TimeStatistic getWaitTime()
Time spent waiting for a connection to be available.

getUseTime

TimeStatistic getUseTime()
Time spent using a connection.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JDBCStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JDBCStats

All Superinterfaces:
Stats
public interface JDBCStats
extends Stats

Statistics provided by a JDBC resource

Author:
Hans Hrasna

Method Summary
JDBCConnectionPoolStats[] | getConnectionPools()
JDBCConnectionStats[] | getConnections()
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getConnections

JDBCConnectionStats[] getConnections()

getConnectionPools

JDBCConnectionPoolStats[] getConnectionPools()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JMSConnectionStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JMSConnectionStats

All Superinterfaces:
Stats
public interface JMSConnectionStats
extends Stats

Specifies the statistics provided by a JMS connection

Author:
Hans Hrasna

Method Summary
JMSSessionStats[] | getSessions() Returns an array of JMSSessionStats that provide statistics about the sessions associated with the referencing JMSConnectionStats.
boolean | isTransactional() Returns the transactional state of this JMS connection.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getSessions

JMSSessionStats[] getSessions()
Returns an array of JMSSessionStats that provide statistics about the sessions associated with the referencing JMSConnectionStats.

isTransactional

boolean isTransactional()
Returns the transactional state of this JMS connection. If true, indicates that this JMS connection is transactional.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JMSConsumerStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JMSConsumerStats

All Superinterfaces:
JMSEndpointStats, Stats
public interface JMSConsumerStats
extends JMSEndpointStats

Specifies the statistics provided by a JMS message consumer

Author:
Hans Hrasna

Method Summary
 String getOrigin()
Returns a string that encapsulates the identity of a message origin
Methods inherited from interface javax.management.j2ee.statistics.JMSEndpointStats
getExpiredMessageCount, getMessageCount, getMessageWaitTime, getPendingMessageCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getOrigin

String getOrigin()
Returns a string that encapsulates the identity of a message origin

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JMSEndpointStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JMSEndpointStats

All Superinterfaces:
Stats
All Known Subinterfaces:
JMSConsumerStats, JMSProducerStats
public interface JMSEndpointStats
extends Stats

Specifies the statistics provided by a JMS message producer or a JMS message consumer.

Method Summary
CountStatistic | getExpiredMessageCount() Number of messages that expired before delivery.
CountStatistic | getMessageCount() Number of messages sent or received.
TimeStatistic | getMessageWaitTime() Time spent by a message before being delivered.
CountStatistic | getPendingMessageCount() Number of pending messages.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getMessageCount

CountStatistic getMessageCount()
Number of messages sent or received.

getPendingMessageCount

CountStatistic getPendingMessageCount()
Number of pending messages.

getExpiredMessageCount

CountStatistic getExpiredMessageCount()
Number of messages that expired before delivery.

getMessageWaitTime

TimeStatistic getMessageWaitTime()
Time spent by a message before being delivered.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JMSProducerStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JMSProducerStats

All Superinterfaces:
JMSEndpointStats, Stats
public interface JMSProducerStats
extends JMSEndpointStats

Specifies the statistics provided by a JMS message producer

Author:
Hans Hrasna

Method Summary
 String getDestination()
Returns a string that encapsulates the identity of the message destination
Methods inherited from interface javax.management.j2ee.statistics.JMSEndpointStats
getExpiredMessageCount, getMessageCount, getMessageWaitTime, getPendingMessageCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getDestination

String getDestination()
Returns a string that encapsulates the identity of the message destination

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JMSSessionStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JMSSessionStats

All Superinterfaces:
Stats
public interface JMSSessionStats
extends Stats

Specifies the statistics provided by a JMS session.

Author:
Hans Hrasna

Method Summary
JMSConsumerStats[] | getConsumers() Returns an array of JMSConsumerStats that provide statistics about the message consumers associated with the referencing JMS session statistics.
CountStatistic | getDurableSubscriptionCount() Number of durable subscriptions.
CountStatistic | getExpiredMessageCount() Number of expired messages.
CountStatistic | getMessageCount() Number of messages exchanged.
TimeStatistic | getMessageWaitTime() Time spent by a message before being delivered.
CountStatistic | getPendingMessageCount() Number of pending messages.
JMSProducerStats[] | getProducers() Returns an array of JMSProducerStats that provide statistics about the message producers associated with the referencing JMS session statistics.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getProducers

JMSProducerStats[] getProducers()
Returns an array of JMSProducerStats that provide statistics about the message producers associated with the referencing JMS session statistics.

getConsumers

JMSConsumerStats[] getConsumers()
Returns an array of JMSConsumerStats that provide statistics about the message consumers associated with the referencing JMS session statistics.

getMessageCount

CountStatistic getMessageCount()
Number of messages exchanged.

getPendingMessageCount

CountStatistic getPendingMessageCount()
Number of pending messages.

getExpiredMessageCount

CountStatistic getExpiredMessageCount()
Number of expired messages.

getMessageWaitTime

TimeStatistic getMessageWaitTime()
Time spent by a message before being delivered.

getDurableSubscriptionCount

CountStatistic getDurableSubscriptionCount()
Number of durable subscriptions.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JMSStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JMSStats

All Superinterfaces:
Stats
public interface JMSStats
extends Stats

Specifies the statistics provided by a JMS Resource

Author:
Hans Hrasna

Method Summary
 JMSConnectionStats[] getConnections()
Returns an array of JMSConnectionStats that provide statistics about the connections associated with the referencing JMS resource.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getConnections

JMSConnectionStats[] getConnections()
Returns an array of JMSConnectionStats that provide statistics about the connections associated with the referencing JMS resource.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JTAStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JTAStats

All Superinterfaces:
Stats
public interface JTAStats
extends Stats

Specifies the statistics provided by a JTA resource.

Method Summary
CountStatistic | getActiveCount() Number of active transactions.
CountStatistic | getCommittedCount() Number of committed transactions.
CountStatistic | getRolledbackCount() Number of rolled-back transactions.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getActiveCount

CountStatistic getActiveCount()
Number of active transactions.

getCommittedCount

CountStatistic getCommittedCount()
Number of committed transactions.

getRolledbackCount

CountStatistic getRolledbackCount()
Number of rolled-back transactions.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JVMStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface JVMStats

All Superinterfaces:
Stats
public interface JVMStats
extends Stats

Specifies the statistics provided by a Java VM.

Method Summary
BoundedRangeStatistic | getHeapSize() Size of the JVM's heap.
CountStatistic | getUpTime() Amount of time the JVM has been running.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getUpTime

CountStatistic getUpTime()
Amount of time the JVM has been running.

getHeapSize

BoundedRangeStatistic getHeapSize()
Size of the JVM's heap.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageDrivenBeanStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface MessageDrivenBeanStats

All Superinterfaces:
EJBStats, Stats
public interface MessageDrivenBeanStats
extends EJBStats

Specifies the statistics provided by a message driven bean.

Method Summary
 CountStatistic getMessageCount()
Number of messages received.
Methods inherited from interface javax.management.j2ee.statistics.EJBStats
getCreateCount, getRemoveCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getMessageCount

CountStatistic getMessageCount()
Number of messages received.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RangeStatistic

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface RangeStatistic

All Superinterfaces:
Statistic
All Known Subinterfaces:
BoundedRangeStatistic
public interface RangeStatistic
extends Statistic

Specifies standard measurements of the lowest and highest values an attribute has held as well as its current value.

Method Summary
long | getCurrent() The current value of this attribute.
long | getHighWaterMark() The highest value this attribute has held since the beginning of the measurement.
long | getLowWaterMark() The lowest value this attribute has held since the beginning of the measurement.
Methods inherited from interface javax.management.j2ee.statistics.Statistic
getDescription, getLastSampleTime, getName, getStartTime, getUnit

Method Detail

getHighWaterMark

long getHighWaterMark()
The highest value this attribute has held since the beginning of the measurement.

getLowWaterMark

long getLowWaterMark()
The lowest value this attribute has held since the beginning of the measurement.

getCurrent

long getCurrent()
The current value of this attribute.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface ServletStats

All Superinterfaces:
Stats
public interface ServletStats
extends Stats

Specifies the statistics provided by a Servlet.

Method Summary
 TimeStatistic getServiceTime()
Execution times for the methods.
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getServiceTime

TimeStatistic getServiceTime()
Execution times for the methods.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SessionBeanStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface SessionBeanStats

All Superinterfaces:
EJBStats, Stats
All Known Subinterfaces:
StatefulSessionBeanStats, StatelessSessionBeanStats
public interface SessionBeanStats
extends EJBStats

Specifies the statistics provided by session beans of both stateful and stateless types.

Method Summary
 RangeStatistic getMethodReadyCount()
Number of beans in the method-ready state.
Methods inherited from interface javax.management.j2ee.statistics.EJBStats
getCreateCount, getRemoveCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getMethodReadyCount

RangeStatistic getMethodReadyCount()
Number of beans in the method-ready state.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StatefulSessionBeanStats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface StatefulSessionBeanStats

All Superinterfaces:
EJBStats, SessionBeanStats, Stats
public interface StatefulSessionBeanStats
extends SessionBeanStats

Specifies the statistics provided by a stateful session bean.

Method Summary
 RangeStatistic getPassiveCount()
Number of beans that are in the passive state.
Methods inherited from interface javax.management.j2ee.statistics.SessionBeanStats
getMethodReadyCount
Methods inherited from interface javax.management.j2ee.statistics.EJBStats
getCreateCount, getRemoveCount
Methods inherited from interface javax.management.j2ee.statistics.Stats
getStatistic, getStatisticNames, getStatistics

Method Detail

getPassiveCount

RangeStatistic getPassiveCount()
Number of beans that are in the passive state.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Statistic

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface Statistic

All Known Subinterfaces:
BoundaryStatistic, BoundedRangeStatistic, CountStatistic, RangeStatistic, TimeStatistic
public interface Statistic

The Statistic model and its sub-models specify the data models which are requried to be used to provide the performance data described by the specific attributes in the Stats models.

Method Summary
String | getDescription() A human-readable description of the Statistic.
long | getLastSampleTime() The time of the last measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.
String | getName() The name of this Statistic.
long | getStartTime() The time of the first measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.
String | getUnit() The unit of measurement for this Statistic.

Method Detail

getName

String getName()
The name of this Statistic.

getUnit

String getUnit()
The unit of measurement for this Statistic. Valid values for TimeStatistic measurements are "HOUR", "MINUTE", "SECOND", "MILLISECOND", "MICROSECOND" and "NANOSECOND".

getDescription

String getDescription()
A human-readable description of the Statistic.

getStartTime

long getStartTime()
The time of the first measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.

getLastSampleTime

long getLastSampleTime()
The time of the last measurement represented as a long, whose value is the number of milliseconds since January 1, 1970, 00:00:00.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Stats

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface Stats

All Known Subinterfaces:
EJBStats, EntityBeanStats, JCAConnectionPoolStats, JCAConnectionStats, JCAStats, JDBCConnectionPoolStats, JDBCConnectionStats, JDBCStats, JMSConnectionStats, JMSConsumerStats, JMSEndpointStats, JMSProducerStats, JMSSessionStats, JMSStats, JTAStats, JVMStats, MessageDrivenBeanStats, ServletStats, SessionBeanStats, StatefulSessionBeanStats, StatelessSessionBeanStats, URLStats
public interface Stats

The Stats model and its submodels specify performance data attributes for each of the specific managed object types.

Method Summary
Statistic | getStatistic(String statisticName) Get a Statistic by name.
String[] | getStatisticNames() Returns an array of Strings which are the names of the attributes from the specific Stats submodel that this object supports.
Statistic[] | getStatistics() Returns an array containing all of the Statistic objects supported by this Stats object.

Method Detail

getStatistic

Statistic getStatistic(String statisticName)
Get a Statistic by name.

getStatisticNames

String[] getStatisticNames()
Returns an array of Strings which are the names of the attributes from the specific Stats submodel that this object supports. Attributes named in the list must correspond to attributes that will return a Statistic object of the appropriate type which contains valid performance data. The return value of attributes in the Stats submodel that are not included in the statisticNames list must be null. For each name in the statisticNames list there must be one Statistic with the same name in the statistics list.

getStatistics

Statistic[] getStatistics()
Returns an array containing all of the Statistic objects supported by this Stats object.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TimeStatistic

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.management.j2ee.statistics
Interface TimeStatistic

All Superinterfaces:
Statistic
public interface TimeStatistic
extends Statistic

Specifies standard timing measurements.

Method Summary
long | getCount() Number of times the operation was invoked since the beginning of this measurement.
long | getMaxTime() The maximum amount of time taken to complete one invocation of this operation since the beginning of this measurement.
long | getMinTime() The minimum amount of time taken to complete one invocation of this operation since the beginning of this measurement.
long | getTotalTime() This is the sum total of time taken to complete every invocation of this operation since the beginning of this measurement.
Methods inherited from interface javax.management.j2ee.statistics.Statistic
getDescription, getLastSampleTime, getName, getStartTime, getUnit

Method Detail

getCount

long getCount()
Number of times the operation was invoked since the beginning of this measurement.

getMaxTime

long getMaxTime()
The maximum amount of time taken to complete one invocation of this operation since the beginning of this measurement.

getMinTime

long getMinTime()
The minimum amount of time taken to complete one invocation of this operation since the beginning of this measurement.

getTotalTime

long getTotalTime()
This is the sum total of time taken to complete every invocation of this operation since the beginning of this measurement. Dividing totalTime by count will give you the average execution time for this operation.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


persistence

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.persistence

The javax.persistence package contains the classes and interfaces that define the contracts between a persistence provider and the managed classes and the clients of the Java Persistence API.

See:
Description

Interface Summary
EntityManager | Interface used to interact with the persistence context.
EntityManagerFactory | The EntityManagerFactory interface is used by the application to obtain an application-managed entity manager.
EntityTransaction | The EntityTransaction interface is used to control resource transactions on resource-local entity managers.
Query | Interface used to control query execution.

Class Summary
Persistence Bootstrap class that is used to obtain an EntityManagerFactory.

Enum Summary
CascadeType | Defines the set of cascadable operations that are propagated to the associated entity.
DiscriminatorType | Defines supported types of the discriminator column.
EnumType | Defines mapping for the enumerated types.
FetchType | Defines strategies for fetching data from the database.
FlushModeType | Flush mode setting.
GenerationType | Defines the types of primary key generation.
InheritanceType | Defines inheritance strategy options.
LockModeType | Lock modes that can be specified by means of the EntityManager.lock() method.
PersistenceContextType | Specifies whether a transaction-scoped or extended persistence context is to be used in PersistenceContext.
TemporalType | Type used to indicate a specific mapping of Date or Calendar.

Exception Summary
EntityExistsException | Thrown by the persistence provider when EntityManager.persist(Object) is called and the entity already exists.
EntityNotFoundException | Thrown by the persistence provider when an entity reference obtained by EntityManager.getReference(Class,Object) is accessed but the entity does not exist.
NonUniqueResultException | Thrown by the persistence provider when getSingleResult() is executed on a query and there is more than one result from the query.
NoResultException | Thrown by the persistence provider when getSingleResult() is executed on a query and there is no result to return.
OptimisticLockException | Thrown by the persistence provider when an optimistic locking conflict occurs.
PersistenceException | Thrown by the persistence provider when a problem occurs.
RollbackException | Thrown by the persistence provider when the EntityTransaction.commit() fails.
TransactionRequiredException | Thrown by the persistence provider when a transaction is required but is not active.

Annotation Types Summary
AssociationOverride | This annotation is used to override a many-to-one or one-to-one mapping of property or field for an entity relationship.
AssociationOverrides | This annotation is used to override mappings of multiple many-to-one or one-to-one relationship properties or fields.
AttributeOverride | The AttributeOverride annotation is used to override the mapping of a Basic (whether explicit or default) property or field or Id property or field.
AttributeOverrides | Is used to override mappings of multiple properties or fields.
Basic | The Basic annotation is the simplest type of mapping to a database column.
Column | Is used to specify a mapped column for a persistent property or field.
ColumnResult | References name of a column in the SELECT clause of a SQL query - i.e., column alias, if applicable.
DiscriminatorColumn | Is used to define the discriminator column for the SINGLE_TABLE and JOINED inheritance mapping strategies.
DiscriminatorValue | Is used to specify the value of the discriminator column for entities of the given type.
Embeddable | Defines a class whose instances are stored as an intrinsic part of an owning entity and share the identity of the entity.
Embedded | Defines a persistent field or property of an entity whose value is an instance of an embeddable class.
EmbeddedId | Is applied to a persistent field or property of an entity class or mapped superclass to denote a composite primary key that is an embeddable class.
Entity | Specifies that the class is an entity.
EntityListeners | Specifies the callback listener classes to be used for an entity or mapped superclass.
EntityResult | References an entity in the SELECT clause of a SQL query.
Enumerated | Specifies that a persistent property or field should be persisted as a enumerated type.
ExcludeDefaultListeners | Specifies that the invocation of default listeners is to be excluded for the entity class (or mapped superclass) and its subclasses.
ExcludeSuperclassListeners | Specifies that the invocation of superclass listeners is to be excluded for the entity class (or mapped superclass) and its subclasses.
FieldResult | Is used to map the columns specified in the SELECT list of the query to the properties or fields of the entity class.
GeneratedValue | Provides for the specification of generation strategies for the values of primary keys.
Id | Specifies the primary key property or field of an entity.
IdClass | Specifies a composite primary key class that is mapped to multiple fields or properties of the entity.
Inheritance | Defines the inheritance strategy to be used for an entity class hierarchy.
JoinColumn | Is used to specify a mapped column for joining an entity association.
JoinColumns | Defines mapping for the composite foreign keys.
JoinTable | This annotation is used in the mapping of associations.
Lob | Specifies that a persistent property or field should be persisted as a large object to a database-supported large object type.
ManyToMany | Defines a many-valued association with many-to-many multiplicity.
ManyToOne | This annotation defines a single-valued association to another entity class that has many-to-one multiplicity.
MapKey | Is used to specify the map key for associations of type Map.
MappedSuperclass | Designates a class whose mapping information is applied to the entities that inherit from it.
NamedNativeQueries | Is used to specify an array of native SQL named queries.
NamedNativeQuery | Is used to specify a native SQL named query.
NamedQueries | Specifies an array of named Java Persistence query language queries.
NamedQuery | Is used to specify a named query in the Java Persistence query language, which is a static query expressed in metadata.
OneToMany | Defines a many-valued association with one-to-many multiplicity.
OneToOne | This annotation defines a single-valued association to another entity that has one-to-one multiplicity.
OrderBy | This annotation specifies the ordering of the elements of a collection valued association at the point when the association is retrieved.
PersistenceContext | Expresses a dependency on an EntityManager persistence context.
PersistenceContexts | Declares one or more PersistenceContext annotations.
PersistenceProperty | Describes a single container or persistence provider property.
PersistenceUnit | Expresses a dependency on an EntityManagerFactory.
PersistenceUnits | Declares one or more PersistenceUnit annotations.
PostLoad | Is used to specify callback methods for the corresponding lifecycle event.
PostPersist | Is used to specify callback methods for the corresponding lifecycle event.
PostRemove | Is used to specify callback methods for the corresponding lifecycle event.
PostUpdate | Is used to specify callback methods for the corresponding lifecycle event.
PrePersist | Is used to specify callback methods for the corresponding lifecycle event.
PreRemove | Is used to specify callback methods for the corresponding lifecycle event.
PreUpdate | Is used to specify callback methods for the corresponding lifecycle event.
PrimaryKeyJoinColumn | This annotation specifies a primary key column that is used as a foreign key to join to another table.
PrimaryKeyJoinColumns | This annotation groups PrimaryKeyJoinColumn annotations.
QueryHint | An implementation-specific Query hint.
SecondaryTable | This annotation is used to specify a secondary table for the annotated entity class.
SecondaryTables | This annotation is used to specify multiple secondary tables for an entity.
SequenceGenerator | This annotation defines a primary key generator that may be referenced by name when a generator element is specified for the GeneratedValue annotation.
SqlResultSetMapping | This annotation is used to specify the mapping of the result of a native SQL query.
SqlResultSetMappings | This annotation is used to define one or more SqlResultSetMapping.
Table | This annotation specifies the primary table for the annotated entity.
TableGenerator | This annotation defines a primary key generator that may be referenced by name when a generator element is specified for the GeneratedValue annotation.
Temporal | This annotation must be specified for persistent fields or properties of type Date and Calendar.
Transient | This annotation specifies that the property or field is not persistent.
UniqueConstraint | This annotation is used to specify that a unique constraint is to be included in the generated DDL for a primary or secondary table.
Version | This annotation specifies the version field or property of an entity class that serves as its optimistic lock value.

Package javax.persistence Description

The javax.persistence package contains the classes and interfaces that define the contracts between a persistence provider and the managed classes and the clients of the Java Persistence API.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Embeddable

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type Embeddable

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Embeddable

Defines a class whose instances are stored as an intrinsic part of an owning entity and share the identity of the entity. Each of the persistent properties or fields of the embedded object is mapped to the database table for the entity. Only Basic, Column, Lob, Temporal, and Enumerated mapping annotations may portably be used to map the persistent fields or properties of classes annotated as Embeddable.

Note that the Transient annotation may be used to designate the non-persistent state of an embeddable class.

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Embedded

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type Embedded

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Embedded

Defines a persistent field or property of an entity whose value is an instance of an embeddable class. The embeddable class must be annotated as Embeddable.

   Example:

   @Embedded
   @AttributeOverrides({
       @AttributeOverride(name="startDate",
           column=@Column("EMP_START")),
       @AttributeOverride(name="endDate", column=@Column("EMP_END"))
   })
   public EmploymentPeriod getEmploymentPeriod() { ... }

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EmbeddedId

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type EmbeddedId

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface EmbeddedId

Is applied to a persistent field or property of an entity class or mapped superclass to denote a composite primary key that is an embeddable class. The embeddable class must be annotated as Embeddable.

    Example:

    @EmbeddedId
    protected EmployeePK empPK;

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ExcludeDefaultListeners

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type ExcludeDefaultListeners

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface ExcludeDefaultListeners

Specifies that the invocation of default listeners is to be excluded for the entity class (or mapped superclass) and its subclasses.

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ExcludeSuperclassListeners

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type ExcludeSuperclassListeners

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface ExcludeSuperclassListeners

Specifies that the invocation of superclass listeners is to be excluded for the entity class (or mapped superclass) and its subclasses.

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Id

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type Id

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Id

Specifies the primary key property or field of an entity.

   Example:

   @Id
   public Long getId() { return id; }

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.persistence Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.persistence

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.persistence.Persistence
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.persistence.PersistenceException
            • javax.persistence.EntityExistsException
            • javax.persistence.EntityNotFoundException
            • javax.persistence.NonUniqueResultException
            • javax.persistence.NoResultException
            • javax.persistence.OptimisticLockException
            • javax.persistence.RollbackException
            • javax.persistence.TransactionRequiredException

Interface Hierarchy

  • javax.persistence.EntityManager
  • javax.persistence.EntityManagerFactory
  • javax.persistence.EntityTransaction
  • javax.persistence.Query

Annotation Type Hierarchy

  • javax.persistence.AssociationOverride (implements java.lang.annotation.Annotation)
  • javax.persistence.AssociationOverrides (implements java.lang.annotation.Annotation)
  • javax.persistence.AttributeOverride (implements java.lang.annotation.Annotation)
  • javax.persistence.AttributeOverrides (implements java.lang.annotation.Annotation)
  • javax.persistence.Basic (implements java.lang.annotation.Annotation)
  • javax.persistence.Column (implements java.lang.annotation.Annotation)
  • javax.persistence.ColumnResult (implements java.lang.annotation.Annotation)
  • javax.persistence.DiscriminatorColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.DiscriminatorValue (implements java.lang.annotation.Annotation)
  • javax.persistence.Embeddable (implements java.lang.annotation.Annotation)
  • javax.persistence.Embedded (implements java.lang.annotation.Annotation)
  • javax.persistence.EmbeddedId (implements java.lang.annotation.Annotation)
  • javax.persistence.Entity (implements java.lang.annotation.Annotation)
  • javax.persistence.EntityListeners (implements java.lang.annotation.Annotation)
  • javax.persistence.EntityResult (implements java.lang.annotation.Annotation)
  • javax.persistence.Enumerated (implements java.lang.annotation.Annotation)
  • javax.persistence.ExcludeDefaultListeners (implements java.lang.annotation.Annotation)
  • javax.persistence.ExcludeSuperclassListeners (implements java.lang.annotation.Annotation)
  • javax.persistence.FieldResult (implements java.lang.annotation.Annotation)
  • javax.persistence.GeneratedValue (implements java.lang.annotation.Annotation)
  • javax.persistence.Id (implements java.lang.annotation.Annotation)
  • javax.persistence.IdClass (implements java.lang.annotation.Annotation)
  • javax.persistence.Inheritance (implements java.lang.annotation.Annotation)
  • javax.persistence.JoinColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.JoinColumns (implements java.lang.annotation.Annotation)
  • javax.persistence.JoinTable (implements java.lang.annotation.Annotation)
  • javax.persistence.Lob (implements java.lang.annotation.Annotation)
  • javax.persistence.ManyToMany (implements java.lang.annotation.Annotation)
  • javax.persistence.ManyToOne (implements java.lang.annotation.Annotation)
  • javax.persistence.MapKey (implements java.lang.annotation.Annotation)
  • javax.persistence.MappedSuperclass (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedNativeQueries (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedNativeQuery (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedQueries (implements java.lang.annotation.Annotation)
  • javax.persistence.NamedQuery (implements java.lang.annotation.Annotation)
  • javax.persistence.OneToMany (implements java.lang.annotation.Annotation)
  • javax.persistence.OneToOne (implements java.lang.annotation.Annotation)
  • javax.persistence.OrderBy (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceContext (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceContexts (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceProperty (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceUnit (implements java.lang.annotation.Annotation)
  • javax.persistence.PersistenceUnits (implements java.lang.annotation.Annotation)
  • javax.persistence.PostLoad (implements java.lang.annotation.Annotation)
  • javax.persistence.PostPersist (implements java.lang.annotation.Annotation)
  • javax.persistence.PostRemove (implements java.lang.annotation.Annotation)
  • javax.persistence.PostUpdate (implements java.lang.annotation.Annotation)
  • javax.persistence.PrePersist (implements java.lang.annotation.Annotation)
  • javax.persistence.PreRemove (implements java.lang.annotation.Annotation)
  • javax.persistence.PreUpdate (implements java.lang.annotation.Annotation)
  • javax.persistence.PrimaryKeyJoinColumn (implements java.lang.annotation.Annotation)
  • javax.persistence.PrimaryKeyJoinColumns (implements java.lang.annotation.Annotation)
  • javax.persistence.QueryHint (implements java.lang.annotation.Annotation)
  • javax.persistence.SecondaryTable (implements java.lang.annotation.Annotation)
  • javax.persistence.SecondaryTables (implements java.lang.annotation.Annotation)
  • javax.persistence.SequenceGenerator (implements java.lang.annotation.Annotation)
  • javax.persistence.SqlResultSetMapping (implements java.lang.annotation.Annotation)
  • javax.persistence.SqlResultSetMappings (implements java.lang.annotation.Annotation)
  • javax.persistence.Table (implements java.lang.annotation.Annotation)
  • javax.persistence.TableGenerator (implements java.lang.annotation.Annotation)
  • javax.persistence.Temporal (implements java.lang.annotation.Annotation)
  • javax.persistence.Transient (implements java.lang.annotation.Annotation)
  • javax.persistence.UniqueConstraint (implements java.lang.annotation.Annotation)
  • javax.persistence.Version (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.persistence.CascadeType
      • javax.persistence.DiscriminatorType
      • javax.persistence.EnumType
      • javax.persistence.FetchType
      • javax.persistence.FlushModeType
      • javax.persistence.GenerationType
      • javax.persistence.InheritanceType
      • javax.persistence.LockModeType
      • javax.persistence.PersistenceContextType
      • javax.persistence.TemporalType
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Lob

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type Lob

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Lob

Specifies that a persistent property or field should be persisted as a large object to a database-supported large object type. The Lob annotation may be used in conjunction with the Basic annotation. A Lob may be either a binary or character type.

The Lob type is inferred from the type of the persistent field or property, and except for string and character-based types defaults to Blob.

   Example:

   @Lob @Basic(fetch=LAZY)
   @Column(name="REPORT")
   protected String report;

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MappedSuperclass

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type MappedSuperclass

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface MappedSuperclass

Designates a class whose mapping information is applied to the entities that inherit from it. A mapped superclass has no separate table defined for it.

A class designated with the MappedSuperclass annotation can be mapped in the same way as an entity except that the mappings will apply only to its subclasses since no table exists for the mapped superclass itself. When applied to the subclasses the inherited mappings will apply in the context of the subclass tables. Mapping information may be overridden in such subclasses by using the AttributeOverride and AssociationOverride annotations or corresponding XML elements.

    Example: Concrete class as a mapped superclass

    @MappedSuperclass
    public class Employee {

        @Id protected Integer empId;
        @Version protected Integer version;
        @ManyToOne @JoinColumn(name="ADDR")
        protected Address address;

        public Integer getEmpId() { ... }
        public void setEmpId(Integer id) { ... }
        public Address getAddress() { ... }
        public void setAddress(Address addr) { ... }
    }

    // Default table is FTEMPLOYEE table
    @Entity
    public class FTEmployee extends Employee {

        // Inherited empId field mapped to FTEMPLOYEE.EMPID
        // Inherited version field mapped to FTEMPLOYEE.VERSION
        // Inherited address field mapped to FTEMPLOYEE.ADDR fk

    // Defaults to FTEMPLOYEE.SALARY

    protected Integer salary;

    public FTEmployee() {}

    public Integer getSalary() { ... }

    public void setSalary(Integer salary) { ... }
    }

    @Entity @Table(name="PT_EMP")
    @AssociationOverride(name="address",

    joincolumns=@JoinColumn(name="ADDR_ID"))
    public class PartTimeEmployee extends Employee {

        // Inherited empId field mapped to PT_EMP.EMPID
        // Inherited version field mapped to PT_EMP.VERSION
        // address field mapping overridden to PT_EMP.ADDR_ID fk
        @Column(name="WAGE")
        protected Float hourlyWage;

        public PartTimeEmployee() {}

        public Float getHourlyWage() { ... }
        public void setHourlyWage(Float wage) { ... }
    }

    Example: Non-entity superclass

    public class Cart {

        // This state is transient
        Integer operationCount;

        public Cart() { operationCount = 0; }
        public Integer getOperationCount() { return operationCount; }
        public void incrementOperationCount() { operationCount++; }
    }

    @Entity
    public class ShoppingCart extends Cart {

        Collection items = new Vector();

        public ShoppingCart() { super(); }

    ...

        @OneToMany
        public Collection getItems() { return items; }
        public void addItem(Item item) {
            items.add(item);
            incrementOperationCount();
        }
    }

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PostLoad

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PostLoad

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PostLoad

Is used to specify callback methods for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PostPersist

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PostPersist

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PostPersist

Is used to specify callback methods for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PostRemove

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PostRemove

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PostRemove

Is used to specify callback methods for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PostUpdate

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PostUpdate

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PostUpdate

Is used to specify callback methods for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PrePersist

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PrePersist

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PrePersist

Is used to specify callback methods for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PreRemove

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PreRemove

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PreRemove

Is used to specify callback methods for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PreUpdate

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PreUpdate

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface PreUpdate

Is used to specify callback methods for the corresponding lifecycle event. This annotation may be applied to methods of an entity class, a mapped superclass, or a callback listener class.

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Transient

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type Transient

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Transient

This annotation specifies that the property or field is not persistent. It is used to annotate a property or field of an entity class, mapped superclass, or embeddable class.

    Example:
    @Entity
    public class Employee {
        @Id int id;
        @Transient User currentUser;
        ...
    }

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Version

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.persistence
Annotation Type Version

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Version

This annotation specifies the version field or property of an entity class that serves as its optimistic lock value. The version is used to ensure integrity when performing the merge operation and for optimistic concurrency control.

Only a single Version property or field should be used per class; applications that use more than one Version property or field will not be portable.

The Version property should be mapped to the primary table for the entity class; applications that map the Version property to a table other than the primary table will not be portable.

The following types are supported for version properties: int, Integer, short, Short, long, Long, Timestamp.

    Example:

    @Version
    @Column(name="OPTLOCK")
    protected int getVersionNum() { return versionNum; }

Since:
Java Persistence 1.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AssociationOverride

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.persistence
Annotation Type AssociationOverride

@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface AssociationOverride

This annotation is used to override a many-to-one or one-to-one mapping of property or field for an entity relationship.

The AssociationOverride annotation may be applied to an entity that extends a mapped superclass to override a many-to-one or one-to-one mapping defined by the mapped superclass. If the AssociationOverride annotation is not specified, the join column is mapped the same as in the original mapping.

    Example:
    @MappedSuperclass
    public class Employee {
        ...
        @ManyToOne
        protected Address address;
        ...
    }

    @Entity
    @AssociationOverride(name="address",
        joinColumns=@JoinColumn(name="ADDR_ID"))
    // address field mapping overridden to ADDR_ID fk
    public class PartTimeEmployee extends Employee {
        ...
    }

Since:
Java Persistence 1.0
See Also:
OneToOne, ManyToOne, MappedSuperclass

Required Element Summary
JoinColumn[] | joinColumns The join column that is being mapped to the persistent attribute.
String | name The name of the relationship property whose mapping is being overridden if property-based access is being used, or the name of the relationship field if field-based access is used.

Element Detail

name

public abstract String name
The name of the relationship property whose mapping is being overridden if property-based access is being used, or the name of the relationship field if field-based access is used.

joinColumns

public abstract JoinColumn[] joinColumns
The join column that is being mapped to the persistent attribute. The mapping type will remain the same as is defined in the mapped superclass.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AssociationOverrides

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type AssociationOverrides

@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface AssociationOverrides

This annotation is used to override mappings of multiple many-to-one or one-to-one relationship properties or fields.

    Example:
    @MappedSuperclass
    public class Employee {

        @Id protected Integer id;
        @Version protected Integer version;
        @ManyToOne protected Address address;
        @OneToOne protected Locker locker;

        public Integer getId() { ... }
        public void setId(Integer id) { ... }
        public Address getAddress() { ... }
        public void setAddress(Address address) { ... }
        public Locker getLocker() { ... }
        public void setLocker(Locker locker) { ... }

    }

    @Entity
    @AssociationOverrides({

    @AssociationOverride(name="address",
            joinColumns=@JoinColumn("ADDR_ID")),
        @AttributeOverride(name="locker",
            joinColumns=@JoinColumn("LCKR_ID"))})
    public PartTimeEmployee { ... }

Since:
Java Persistence 1.0

Required Element Summary
 AssociationOverride[] value
Mapping overrides of relationship properties or fields

Element Detail

value

public abstract AssociationOverride[] value
Mapping overrides of relationship properties or fields

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AttributeOverride

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type AttributeOverride

@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface AttributeOverride

The AttributeOverride annotation is used to override the mapping of a Basic (whether explicit or default) property or field or Id property or field.

The AttributeOverride annotation may be applied to an entity that extends a mapped superclass or to an embedded field or property to override a basic mapping defined by the mapped superclass or embeddable class. If the AttributeOverride annotation is not specified, the column is mapped the same as in the original mapping.

 Example:

   @MappedSuperclass
   public class Employee {
       @Id protected Integer id;
       @Version protected Integer version;
       protected String address;
       public Integer getId() { ... }
       public void setId(Integer id) { ... }
       public String getAddress() { ... }
       public void setAddress(String address) { ... }
   }

   @Entity
   @AttributeOverride(name="address", column=@Column(name="ADDR"))
   public class PartTimeEmployee extends Employee {
       // address field mapping overridden to ADDR
       protected Float wage();
       public Float getHourlyWage() { ... }
       public void setHourlyWage(Float wage) { ... }
   }

Since:
Java Persistence 1.0
See Also:
Embedded, Embeddable, MappedSuperclass

Required Element Summary
Column | column (Required) The column that is being mapped to the persistent attribute.
String | name (Required) The name of the property whose mapping is being overridden if property-based access is being used, or the name of the field if field-based access is used.

Element Detail

name

public abstract String name
(Required) The name of the property whose mapping is being overridden if property-based access is being used, or the name of the field if field-based access is used.

column

public abstract Column column
(Required) The column that is being mapped to the persistent attribute. The mapping type will remain the same as is defined in the embeddable class or mapped superclass.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AttributeOverrides

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type AttributeOverrides

@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface AttributeOverrides

Is used to override mappings of multiple properties or fields.

    Example:

    @Embedded
    @AttributeOverrides({
            @AttributeOverride(name="startDate", column=@Column("
                    EMP_START")),
            @AttributeOverride(name="endDate", column=@Column("EMP_END"))
    })
    public EmploymentPeriod getEmploymentPeriod() { ... }

Since:
Java Persistence 1.0

Required Element Summary
 AttributeOverride[] value
One or more mapping override

Element Detail

value

public abstract AttributeOverride[] value
One or more mapping override

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Basic

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type Basic

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Basic

The Basic annotation is the simplest type of mapping to a database column. The Basic annotation can be applied to a persistent property or instance variable of any of the following types: Java primitive types, wrappers of the primitive types, String, java.math.BigInteger, java.math.BigDecimal, java.util.Date, java.util.Calendar, java.sql.Date, java.sql.Time, java.sql.Timestamp, byte[], Byte[], char[], Character[], enums, and any other type that implements Serializable.

The use of the Basic annotation is optional for persistent fields and properties of these types.

Since:
Java Persistence 1.0

Optional Element Summary
FetchType | fetch (Optional) Defines whether the value of the field or property should be lazily loaded or must be eagerly fetched.
boolean | optional (Optional) Defines whether the value of the field or property may be null.

fetch

public abstract FetchType fetch
(Optional) Defines whether the value of the field or property should be lazily loaded or must be eagerly fetched. The EAGER strategy is a requirement on the persistence provider runtime that the value must be eagerly fetched. The LAZY strategy is a hint to the persistence provider runtime. If not specified, defaults to EAGER.

Default:
EAGER

optional

public abstract boolean optional
(Optional) Defines whether the value of the field or property may be null. This is a hint and is disregarded for primitive types; it may be used in schema generation. If not specified, defaults to true.

Default:
true
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


CascadeType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.persistence
Enum CascadeType

java.lang.Object
    extended by  java.lang.Enum<CascadeType>
        extended by  javax.persistence.CascadeType
All Implemented Interfaces:
Serializable, Comparable<CascadeType>
public enum CascadeType
extends Enum<CascadeType>

Defines the set of cascadable operations that are propagated to the associated entity. The value cascade=ALL is equivalent to cascade={PERSIST, MERGE, REMOVE, REFRESH}.

Since:
Java Persistence 1.0

Enum Constant Summary
ALL
          Cascade all operations
MERGE
          Cascade merge operation
PERSIST
          Cascade persist operation
REFRESH
          Cascade refresh operation
REMOVE
          Cascade remove operation

Method Summary
static CascadeType | valueOf(String name) Returns the enum constant of this type with the specified name.
static CascadeType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.

Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf

Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

ALL

public static final CascadeType ALL
Cascade all operations

PERSIST

public static final CascadeType PERSIST
Cascade persist operation

MERGE

public static final CascadeType MERGE
Cascade merge operation

REMOVE

public static final CascadeType REMOVE
Cascade remove operation

REFRESH

public static final CascadeType REFRESH
Cascade refresh operation

Method Detail

values

public static final CascadeType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(CascadeType c : CascadeType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static CascadeType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview  Package   Class  Tree  Deprecated  Index  Help
Java EE 5 SDK
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Column

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type Column

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Column

Is used to specify a mapped column for a persistent property or field. If no Column annotation is specified, the default values are applied.

Examples:

 Example 1:
 @Column(name="DESC", nullable=false, length=512)
 public String getDescription() { return description; }

 Example 2:
 @Column(name="DESC",
         columnDefinition="CLOB NOT NULL",
         table="EMP_DETAIL")
 @Lob
 public String getDescription() { return description; }

 Example 3:
 @Column(name="ORDER_COST", updatable=false, precision=12, scale=2)
 public BigDecimal getCost() { return cost; }

Since:
Java Persistence 1.0

Optional Element Summary
String | columnDefinition (Optional) The SQL fragment that is used when generating the DDL for the column.
boolean | insertable (Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.
int | length (Optional) The column length.
String | name (Optional) The name of the column.
boolean | nullable (Optional) Whether the database column is nullable.
int | precision (Optional) The precision for a decimal (exact numeric) column.
int | scale (Optional) The scale for a decimal (exact numeric) column.
String | table (Optional) The name of the table that contains the column.
boolean | unique (Optional) Whether the property is a unique key.
boolean | updatable (Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.

name

public abstract String name
(Optional) The name of the column. Defaults to the property or field name.

Default:
""

unique

public abstract boolean unique
(Optional) Whether the property is a unique key. This is a shortcut for the UniqueConstraint annotation at the table level and is useful for when the unique key constraint is only a single field. This constraint applies in addition to any constraint entailed by primary key mapping and to constraints specified at the table level.

Default:
false

nullable

public abstract boolean nullable
(Optional) Whether the database column is nullable.

Default:
true

insertable

public abstract boolean insertable
(Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.

Default:
true

updatable

public abstract boolean updatable
(Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.

Default:
true

columnDefinition

public abstract String columnDefinition
(Optional) The SQL fragment that is used when generating the DDL for the column.

Defaults to the generated SQL to create a column of the inferred type.

Default:
""

table

public abstract String table
(Optional) The name of the table that contains the column. If absent the column is assumed to be in the primary table.

Default:
""

length

public abstract int length
(Optional) The column length. (Applies only if a string-valued column is used.)

Default:
255

precision

public abstract int precision
(Optional) The precision for a decimal (exact numeric) column. (Applies only if a decimal column is used.) Value must be set by developer if used when generating the DDL for the column.

Default:
0

scale

public abstract int scale
(Optional) The scale for a decimal (exact numeric) column. (Applies only if a decimal column is used.)

Default:
0
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ColumnResult

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type ColumnResult

@Target(value={})
@Retention(value=RUNTIME)
public @interface ColumnResult

References name of a column in the SELECT clause of a SQL query - i.e., column alias, if applicable. Scalar result types can be included in the query result by specifying this annotation in the metadata.

 Example:
   Query q = em.createNativeQuery(
       "SELECT o.id AS order_id, " +
           "o.quantity AS order_quantity, " +
           "o.item AS order_item, " +
           "i.name AS item_name, " +
         "FROM Order o, Item i " +
         "WHERE (order_quantity > 25) AND (order_item = i.id)",
       "OrderResults");

   @SqlResultSetMapping(name="OrderResults",
       entities={
           @EntityResult(entityClass=com.acme.Order.class, fields={
               @FieldResult(name="id", column="order_id"),
               @FieldResult(name="quantity", column="order_quantity"),
               @FieldResult(name="item", column="order_item")})},
       columns={
           @ColumnResult(name="item_name")}
       )

Since:
Java Persistence 1.0

Required Element Summary
 String name
The name of a column in the SELECT clause of a SQL query

Element Detail

name

public abstract String name
The name of a column in the SELECT clause of a SQL query

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DiscriminatorColumn

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type DiscriminatorColumn

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface DiscriminatorColumn

Is used to define the discriminator column for the SINGLE_TABLE and JOINED inheritance mapping strategies.

The strategy and the discriminator column are only specified in the root of an entity class hierarchy or subhierarchy in which a different inheritance strategy is applied

If the DiscriminatorColumn annotation is missing, and a discriminator column is required, the name of the discriminator column defaults to "DTYPE" and the discriminator type to DiscriminatorType.STRING.

     Example:
     @Entity
     @Table(name="CUST")
     @Inheritance(strategy=SINGLE_TABLE)
     @DiscriminatorColumn(name="DISC", discriminatorType=STRING,length=20)
     public class Customer { ... }

     @Entity
     public class ValuedCustomer extends Customer { ... }

Since:
Java Persistence 1.0

Optional Element Summary
String | columnDefinition (Optional) The SQL fragment that is used when generating the DDL for the discriminator column.
DiscriminatorType | discriminatorType (Optional) The type of object/column to use as a class discriminator.
int | length (Optional) The column length for String-based discriminator types.
String | name (Optional) The name of column to be used for the discriminator.

name

public abstract String name
(Optional) The name of column to be used for the discriminator.

Default:
"DTYPE"

discriminatorType

public abstract DiscriminatorType discriminatorType
(Optional) The type of object/column to use as a class discriminator. Defaults to DiscriminatorType.STRING.

Default:
STRING

columnDefinition

public abstract String columnDefinition
(Optional) The SQL fragment that is used when generating the DDL for the discriminator column.

Defaults to the provider-generated SQL to create a column of the specified discriminator type.

Default:
""

length

public abstract int length
(Optional) The column length for String-based discriminator types. Ignored for other discriminator types.

Default:
31
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DiscriminatorType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.persistence
Enum DiscriminatorType

java.lang.Object
    extended by  java.lang.Enum<DiscriminatorType>
        extended by  javax.persistence.DiscriminatorType
All Implemented Interfaces:
Serializable, Comparable<DiscriminatorType>
public enum DiscriminatorType
extends Enum<DiscriminatorType>

Defines supported types of the discriminator column.

Since:
Java Persistence 1.0

Enum Constant Summary
CHAR
Single character as the discriminator type
INTEGER
Integer as the discriminator type
STRING
String as the discriminator type
Method Summary
static DiscriminatorType | valueOf(String name) Returns the enum constant of this type with the specified name.
static DiscriminatorType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

STRING

public static final DiscriminatorType STRING
String as the discriminator type

CHAR

public static final DiscriminatorType CHAR
Single character as the discriminator type

INTEGER

public static final DiscriminatorType INTEGER
Integer as the discriminator type

Method Detail

values

public static final DiscriminatorType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(DiscriminatorType c : DiscriminatorType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static DiscriminatorType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DiscriminatorValue

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type DiscriminatorValue

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface DiscriminatorValue

Is used to specify the value of the discriminator column for entities of the given type. The DiscriminatorValue annotation can only be specified on a concrete entity class. If the DiscriminatorValue annotation is not specified and a discriminator column is used, a provider-specific function will be used to generate a value representing the entity type. If the DiscriminatorType is STRING, the discriminator value default is the entity name.

The inheritance strategy and the discriminator column are only specified in the root of an entity class hierarchy or subhierarchy in which a different inheritance strategy is applied. The discriminator value, if not defaulted, should be specified for each entity class in the hierarchy.

    Example:

    @Entity
    @Table(name="CUST")
    @Inheritance(strategy=SINGLE_TABLE)
    @DiscriminatorColumn(name="DISC", discriminatorType=STRING,length=20)
    @DiscriminatorValue("CUSTOMER")
    public class Customer { ... }

    @Entity
    @DiscriminatorValue("VCUSTOMER")
    public class ValuedCustomer extends Customer { ... }

Since:
Java Persistence 1.0

Required Element Summary
 String value
(Optional) The value that indicates that the row is an entity of the annotated entity type.

Element Detail

value

public abstract String value
(Optional) The value that indicates that the row is an entity of the annotated entity type.

If the DiscriminatorValue annotation is not specified and a discriminator column is used, a provider-specific function will be used to generate a value representing the entity type. If the DiscriminatorType is STRING, the discriminator value default is the entity name.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Entity

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type Entity

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Entity

Specifies that the class is an entity. This annotation is applied to the entity class.

Since:
Java Persistence 1.0

Optional Element Summary
 String name
The name of an entity.

name

public abstract String name
The name of an entity. Defaults to the unqualified name of the entity class. This name is used to refer to the entity in queries. The name must not be a reserved literal in the Java Persistence query language.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EntityExistsException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence
Class EntityExistsException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.persistence.PersistenceException
                    extended by  javax.persistence.EntityExistsException
All Implemented Interfaces:
Serializable
public class EntityExistsException
extends PersistenceException

Thrown by the persistence provider when EntityManager.persist(Object) is called and the entity already exists. The current transaction, if one is active, will be marked for rollback.

Since:
Java Persistence 1.0
See Also:
EntityManager.persist(Object), Serialized Form

Constructor Summary
EntityExistsException()
Constructs a new EntityExistsException exception with null as its detail message.
EntityExistsException(String message)
Constructs a new EntityExistsException exception with the specified detail message.
EntityExistsException(String message, Throwable cause)
Constructs a new EntityExistsException exception with the specified detail message and cause.
EntityExistsException(Throwable cause)
Constructs a new EntityExistsException exception with the specified cause.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EntityExistsException

public EntityExistsException()
Constructs a new EntityExistsException exception with null as its detail message.

EntityExistsException

public EntityExistsException(String message)
Constructs a new EntityExistsException exception with the specified detail message.

Parameters:
message - the detail message.

EntityExistsException

public EntityExistsException(String message,
                             Throwable cause)
Constructs a new EntityExistsException exception with the specified detail message and cause.

Parameters:
message - the detail message.
cause - the cause.

EntityExistsException

public EntityExistsException(Throwable cause)
Constructs a new EntityExistsException exception with the specified cause.

Parameters:
cause - the cause.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EntityListeners

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type EntityListeners

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface EntityListeners

Specifies the callback listener classes to be used for an entity or mapped superclass. This annotation may be applied to an entity class or mapped superclass.

Since:
Java Persistence 1.0

Required Element Summary
 Class[] value
The callback listener classes

Element Detail

value

public abstract Class[] value
The callback listener classes

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EntityManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence
Interface EntityManager

public interface EntityManager

Interface used to interact with the persistence context.

An EntityManager instance is associated with a persistence context. A persistence context is a set of entity instances in which for any persistent entity identity there is a unique entity instance. Within the persistence context, the entity instances and their lifecycle are managed. This interface defines the methods that are used to interact with the persistence context. The EntityManager API is used to create and remove persistent entity instances, to find entities by their primary key, and to query over entities.

The set of entities that can be managed by a given EntityManager instance is defined by a persistence unit. A persistence unit defines the set of all classes that are related or grouped by the application, and which must be colocated in their mapping to a single database.

Since:
Java Persistence 1.0

Method Summary
 void clear()
Clear the persistence context, causing all managed entities to become detached.
 void close()
Close an application-managed EntityManager.
 boolean contains(Object entity)
Check if the instance belongs to the current persistence context.
 Query createNamedQuery(String name)
Create an instance of Query for executing a named query (in the Java Persistence query language or in native SQL).
 Query createNativeQuery(String sqlString)
Create an instance of Query for executing a native SQL statement, e.g., for update or delete.
 Query createNativeQuery(String sqlString, Class resultClass)
Create an instance of Query for executing a native SQL query.
 Query createNativeQuery(String sqlString, String resultSetMapping)
Create an instance of Query for executing a native SQL query.
 Query createQuery(String qlString)
Create an instance of Query for executing a Java Persistence query language statement.
<T> T
find(Class<T> entityClass, Object primaryKey)
Find by primary key.
 void flush()
Synchronize the persistence context to the underlying database.
 Object getDelegate()
Return the underlying provider object for the EntityManager, if available.
 FlushModeType getFlushMode()
Get the flush mode that applies to all objects contained in the persistence context.
<T> T
getReference(Class<T> entityClass, Object primaryKey)
Get an instance, whose state may be lazily fetched.
 EntityTransaction getTransaction()
Returns the resource-level transaction object.
 boolean isOpen()
Determine whether the EntityManager is open.
 void joinTransaction()
Indicate to the EntityManager that a JTA transaction is active.
 void lock(Object entity, LockModeType lockMode)
Set the lock mode for an entity object contained in the persistence context.
<T> T
merge(T entity)
Merge the state of the given entity into the current persistence context.
 void persist(Object entity)
Make an entity instance managed and persistent.
 void refresh(Object entity)
Refresh the state of the instance from the database, overwriting changes made to the entity, if any.
 void remove(Object entity)
Remove the entity instance.
 void setFlushMode(FlushModeType flushMode)
Set the flush mode that applies to all objects contained in the persistence context.

Method Detail

persist

void persist(Object entity)
Make an entity instance managed and persistent.

Parameters:
entity -
Throws:
EntityExistsException - if the entity already exists. (The EntityExistsException may be thrown when the persist operation is invoked, or the EntityExistsException or another PersistenceException may be thrown at flush or commit time.)
IllegalStateException - if this EntityManager has been closed.
IllegalArgumentException - if not an entity
TransactionRequiredException - if invoked on a container-managed entity manager of type PersistenceContextType.TRANSACTION and there is no transaction.

merge

<T> T merge(T entity)
Merge the state of the given entity into the current persistence context.

Parameters:
entity -
Returns:
the instance that the state was merged to
Throws:
IllegalStateException - if this EntityManager has been closed.
IllegalArgumentException - if instance is not an entity or is a removed entity
TransactionRequiredException - if invoked on a container-managed entity manager of type PersistenceContextType.TRANSACTION and there is no transaction.

remove

void remove(Object entity)
Remove the entity instance.

Parameters:
entity -
Throws:
IllegalStateException - if this EntityManager has been closed.
IllegalArgumentException - if not an entity or if a detached entity
TransactionRequiredException - if invoked on a container-managed entity manager of type PersistenceContextType.TRANSACTION and there is no transaction.

find

<T> T find(Class<T> entityClass,
           Object primaryKey)
Find by primary key.

Parameters:
entityClass -
primaryKey -
Returns:
the found entity instance or null if the entity does not exist
Throws:
IllegalStateException - if this EntityManager has been closed.
IllegalArgumentException - if the first argument does not denote an entity type or the second argument is not a valid type for that entity's primary key

getReference

<T> T getReference(Class<T> entityClass,
                   Object primaryKey)
Get an instance, whose state may be lazily fetched. If the requested instance does not exist in the database, throws EntityNotFoundException when the instance state is first accessed. (The persistence provider runtime is permitted to throw EntityNotFoundException when getReference(java.lang.Class, java.lang.Object) is called.) The application should not expect that the instance state will be available upon detachment, unless it was accessed by the application while the entity manager was open.

Parameters:
entityClass -
primaryKey -
Returns:
the found entity instance
Throws:
IllegalStateException - if this EntityManager has been closed.
IllegalArgumentException - if the first argument does not denote an entity type or the second argument is not a valid type for that entity's primary key
EntityNotFoundException - if the entity state cannot be accessed

flush

void flush()
Synchronize the persistence context to the underlying database.

Throws:
IllegalStateException - if this EntityManager has been closed.
TransactionRequiredException - if there is no transaction
PersistenceException - if the flush fails

setFlushMode

void setFlushMode(FlushModeType flushMode)
Set the flush mode that applies to all objects contained in the persistence context.

Parameters:
flushMode -
Throws:
IllegalStateException - if this EntityManager has been closed.

getFlushMode

FlushModeType getFlushMode()
Get the flush mode that applies to all objects contained in the persistence context.

Returns:
flush mode
Throws:
IllegalStateException - if this EntityManager has been closed.

lock

void lock(Object entity,
          LockModeType lockMode)
Set the lock mode for an entity object contained in the persistence context.

Parameters:
entity -
lockMode -
Throws:
IllegalStateException - if this EntityManager has been closed.
PersistenceException - if an unsupported lock call is made
IllegalArgumentException - if the instance is not an entity or is a detached entity
TransactionRequiredException - if there is no transaction

refresh

void refresh(Object entity)
Refresh the state of the instance from the database, overwriting changes made to the entity, if any.

Parameters:
entity -
Throws:
IllegalStateException - if this EntityManager has been closed.
IllegalArgumentException - if not an entity or entity is not managed
TransactionRequiredException - if invoked on a container-managed entity manager of type PersistenceContextType.TRANSACTION and there is no transaction.
EntityNotFoundException - if the entity no longer exists in the database.

clear

void clear()
Clear the persistence context, causing all managed entities to become detached. Changes made to entities that have not been flushed to the database will not be persisted.

Throws:
IllegalStateException - if this EntityManager has been closed.

contains

boolean contains(Object entity)
Check if the instance belongs to the current persistence context.

Parameters:
entity -
Returns:
true if the instance belongs to the current persistence context.
Throws:
IllegalStateException - if this EntityManager has been closed.
IllegalArgumentException - if not an entity

createQuery

Query createQuery(String qlString)
Create an instance of Query for executing a Java Persistence query language statement.

Parameters:
qlString - a Java Persistence query language query string
Returns:
the new query instance
Throws:
IllegalStateException - if this EntityManager has been closed.
IllegalArgumentException - if query string is not valid

createNamedQuery

Query createNamedQuery(String name)
Create an instance of Query for executing a named query (in the Java Persistence query language or in native SQL).

Parameters:
name - the name of a query defined in metadata
Returns:
the new query instance
Throws:
IllegalStateException - if this EntityManager has been closed.
IllegalArgumentException - if a query has not been defined with the given name

createNativeQuery

Query createNativeQuery(String sqlString)
Create an instance of Query for executing a native SQL statement, e.g., for update or delete.

Parameters:
sqlString - a native SQL query string
Returns:
the new query instance
Throws:
IllegalStateException - if this EntityManager has been closed.

createNativeQuery

Query createNativeQuery(String sqlString,
                        Class resultClass)
Create an instance of Query for executing a native SQL query.

Parameters:
sqlString - a native SQL query string
resultClass - the class of the resulting instance(s)
Returns:
the new query instance
Throws:
IllegalStateException - if this EntityManager has been closed.

createNativeQuery

Query createNativeQuery(String sqlString,
                        String resultSetMapping)
Create an instance of Query for executing a native SQL query.

Parameters:
sqlString - a native SQL query string
resultSetMapping - the name of the result set mapping
Returns:
the new query instance
Throws:
IllegalStateException - if this EntityManager has been closed.

joinTransaction

void joinTransaction()
Indicate to the EntityManager that a JTA transaction is active. This method should be called on a JTA application managed EntityManager that was created outside the scope of the active transaction to associate it with the current JTA transaction.

Throws:
IllegalStateException - if this EntityManager has been closed.
TransactionRequiredException - if there is no transaction.

getDelegate

Object getDelegate()
Return the underlying provider object for the EntityManager, if available. The result of this method is implementation specific.

Throws:
IllegalStateException - if this EntityManager has been closed.

close

void close()
Close an application-managed EntityManager. After the close method has been invoked, all methods on the EntityManager instance and any Query objects obtained from it will throw the IllegalStateException except for getTransaction and isOpen (which will return false). If this method is called when the EntityManager is associated with an active transaction, the persistence context remains managed until the transaction completes.

Throws:
IllegalStateException - if the EntityManager is container-managed or has been already closed..

isOpen

boolean isOpen()
Determine whether the EntityManager is open.

Returns:
true until the EntityManager has been closed.

getTransaction

EntityTransaction getTransaction()
Returns the resource-level transaction object. The EntityTransaction instance may be used serially to begin and commit multiple transactions.

Returns:
EntityTransaction instance
Throws:
IllegalStateException - if invoked on a JTA EntityManager.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EntityManagerFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence
Interface EntityManagerFactory

public interface EntityManagerFactory

The EntityManagerFactory interface is used by the application to obtain an application-managed entity manager. When the application has finished using the entity manager factory, and/or at application shutdown, the application should close the entity manager factory. Once an EntityManagerFactory has been closed, all its entity managers are considered to be in the closed state.

Since:
Java Persistence 1.0

Method Summary
void | close() Close the factory, releasing any resources that it holds.
EntityManager | createEntityManager() Create a new EntityManager.
EntityManager | createEntityManager(Map map) Create a new EntityManager with the specified Map of properties.
boolean | isOpen() Indicates whether or not this factory is open.

Method Detail

createEntityManager

EntityManager createEntityManager()
Create a new EntityManager. This method returns a new EntityManager instance each time it is invoked. The isOpen method will return true on the returned instance.

createEntityManager

EntityManager createEntityManager(Map map)
Create a new EntityManager with the specified Map of properties. This method returns a new EntityManager instance each time it is invoked. The isOpen method will return true on the returned instance.

close

void close()
Close the factory, releasing any resources that it holds. After a factory instance is closed, all methods invoked on it will throw an IllegalStateException, except for isOpen, which will return false. Once an EntityManagerFactory has been closed, all its entity managers are considered to be in the closed state.

isOpen

boolean isOpen()
Indicates whether or not this factory is open. Returns true until a call to close has been made.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EntityNotFoundException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence
Class EntityNotFoundException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.persistence.PersistenceException
                    extended by  javax.persistence.EntityNotFoundException
All Implemented Interfaces:
Serializable
public class EntityNotFoundException
extends PersistenceException

Thrown by the persistence provider when an entity reference obtained by EntityManager.getReference(Class,Object) is accessed but the entity does not exist. Also thrown when EntityManager.refresh(Object) is called and the object no longer exists in the database. The current transaction, if one is active, will be marked for rollback.

Since:
Java Persistence 1.0
See Also:
EntityManager.getReference(Class,Object), EntityManager.refresh(Object), Serialized Form

Constructor Summary
EntityNotFoundException()
Constructs a new EntityNotFoundException exception with null as its detail message.
EntityNotFoundException(String message)
Constructs a new EntityNotFoundException exception with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EntityNotFoundException

public EntityNotFoundException()
Constructs a new EntityNotFoundException exception with null as its detail message.

EntityNotFoundException

public EntityNotFoundException(String message)
Constructs a new EntityNotFoundException exception with the specified detail message.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EntityResult

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type EntityResult

@Target(value={})
@Retention(value=RUNTIME)
public @interface EntityResult

References an entity in the SELECT clause of a SQL query. If this annotation is used, the SQL statement should select all of the columns that are mapped to the entity object. This should include foreign key columns to related entities. The results obtained when insufficient data is available are undefined.

   Example
   Query q = em.createNativeQuery(
       "SELECT o.id, o.quantity, o.item, i.id, i.name, i.description "+
           "FROM Order o, Item i " +
           "WHERE (o.quantity > 25) AND (o.item = i.id)",
       "OrderItemResults");
   @SqlResultSetMapping(name="OrderItemResults",
       entities={
           @EntityResult(entityClass=com.acme.Order.class),
           @EntityResult(entityClass=com.acme.Item.class)
   })

Since:
Java Persistence 1.0

Required Element Summary
 Class entityClass
The class of the result
Optional Element Summary
String | discriminatorColumn Specifies the column name (or alias) of the column in the SELECT list that is used to determine the type of the entity instance.
FieldResult[] | fields Maps the columns specified in the SELECT list of the query to the properties or fields of the entity class.

Element Detail

entityClass

public abstract Class entityClass
The class of the result

fields

public abstract FieldResult[] fields
Maps the columns specified in the SELECT list of the query to the properties or fields of the entity class.

Default:
{}

discriminatorColumn

public abstract String discriminatorColumn
Specifies the column name (or alias) of the column in the SELECT list that is used to determine the type of the entity instance.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EntityTransaction

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence
Interface EntityTransaction

public interface EntityTransaction

The EntityTransaction interface is used to control resource transactions on resource-local entity managers. The EntityManager.getTransaction() method returns the EntityTransaction interface.

Since:
Java Persistence 1.0

Method Summary
void | begin() Start the resource transaction.
void | commit() Commit the current transaction, writing any unflushed changes to the database.
boolean | getRollbackOnly() Determine whether the current transaction has been marked for rollback.
boolean | isActive() Indicate whether a transaction is in progress.
void | rollback() Roll back the current transaction
void | setRollbackOnly() Mark the current transaction so that the only possible outcome of the transaction is for the transaction to be rolled back.

Method Detail

begin

void begin()
Start the resource transaction.

Throws:
IllegalStateException - if isActive() is true.

commit

void commit()
Commit the current transaction, writing any unflushed changes to the database.

Throws:
IllegalStateException - if isActive() is false.
RollbackException - if the commit fails.

rollback

void rollback()
Roll back the current transaction

Throws:
IllegalStateException - if isActive() is false.
PersistenceException - if an unexpected error condition is encountered.

setRollbackOnly

void setRollbackOnly()
Mark the current transaction so that the only possible outcome of the transaction is for the transaction to be rolled back.

Throws:
IllegalStateException - if isActive() is false.

getRollbackOnly

boolean getRollbackOnly()
Determine whether the current transaction has been marked for rollback.

Throws:
IllegalStateException - if isActive() is false.

isActive

boolean isActive()
Indicate whether a transaction is in progress.

Throws:
PersistenceException - if an unexpected error condition is encountered.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Enumerated

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type Enumerated

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Enumerated

Specifies that a persistent property or field should be persisted as a enumerated type. It may be used in conjunction with the Basic annotation.

   Example:

   public enum EmployeeStatus {FULL_TIME, PART_TIME, CONTRACT}

   public enum SalaryRate {JUNIOR, SENIOR, MANAGER, EXECUTIVE}

   @Entity public class Employee {
       public EmployeeStatus getStatus() {...}
       @Enumerated(STRING)
       public SalaryRate getPayScale() {...}
       ...
   }

Since:
Java Persistence 1.0

Optional Element Summary
 EnumType value
(Optional) The type used in mapping an enum type.

value

public abstract EnumType value
(Optional) The type used in mapping an enum type.

Default:
ORDINAL
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EnumType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.persistence
Enum EnumType

java.lang.Object
    extended by  java.lang.Enum<EnumType>
        extended by  javax.persistence.EnumType
All Implemented Interfaces:
Serializable, Comparable<EnumType>
public enum EnumType
extends Enum<EnumType>

Defines mapping for the enumerated types. The constants of this enumerated type specify how persistent property or field should be persisted as a enumerated type.

Since:
Java Persistence 1.0

Enum Constant Summary
ORDINAL
Persist enumerated type property or field as an integer
STRING
Persist enumerated type property or field as a string
Method Summary
static EnumType | valueOf(String name) Returns the enum constant of this type with the specified name.
static EnumType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

ORDINAL

public static final EnumType ORDINAL
Persist enumerated type property or field as an integer

STRING

public static final EnumType STRING
Persist enumerated type property or field as a string

Method Detail

values

public static final EnumType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(EnumType c : EnumType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static EnumType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FetchType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.persistence
Enum FetchType

java.lang.Object
    extended by  java.lang.Enum<FetchType>
        extended by  javax.persistence.FetchType
All Implemented Interfaces:
Serializable, Comparable<FetchType>
public enum FetchType
extends Enum<FetchType>

Defines strategies for fetching data from the database. The EAGER strategy is a requirement on the persistence provider runtime that data must be eagerly fetched. The LAZY strategy is a hint to the persistence provider runtime that data should be fetched lazily when it is first accessed. The implementation is permitted to eagerly fetch data for which the LAZY strategy hint has been specified. In particular, lazy fetching might only be available for Basic mappings for which property-based access is used.

   Example:
   @Basic(fetch=LAZY)
   protected String getName() { return name; }

Since:
Java Persistence 1.0

Enum Constant Summary
EAGER
Defines that data must be eagerly fetched
LAZY
Defines that data can be lazily fetched
Method Summary
static FetchType | valueOf(String name) Returns the enum constant of this type with the specified name.
static FetchType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

LAZY

public static final FetchType LAZY
Defines that data can be lazily fetched

EAGER

public static final FetchType EAGER
Defines that data must be eagerly fetched

Method Detail

values

public static final FetchType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(FetchType c : FetchType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static FetchType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FieldResult

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type FieldResult

@Target(value={})
@Retention(value=RUNTIME)
public @interface FieldResult

Is used to map the columns specified in the SELECT list of the query to the properties or fields of the entity class.

 Example:
   Query q = em.createNativeQuery(
       "SELECT o.id AS order_id, " +
           "o.quantity AS order_quantity, " +
           "o.item AS order_item, " +
         "FROM Order o, Item i " +
         "WHERE (order_quantity > 25) AND (order_item = i.id)",
       "OrderResults");

   @SqlResultSetMapping(name="OrderResults",
       entities={
           @EntityResult(entityClass=com.acme.Order.class, fields={
               @FieldResult(name="id", column="order_id"),
               @FieldResult(name="quantity", column="order_quantity"),
               @FieldResult(name="item", column="order_item")})
       })

Since:
Java Persistence 1.0

Required Element Summary
String | column Name of the column in the SELECT clause - i.e., column aliases, if applicable.
String | name Name of the persistent field or property of the class.

Element Detail

name

public abstract String name
Name of the persistent field or property of the class.

column

public abstract String column
Name of the column in the SELECT clause - i.e., column aliases, if applicable.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FlushModeType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.persistence
Enum FlushModeType

java.lang.Object
    extended by  java.lang.Enum<FlushModeType>
        extended by  javax.persistence.FlushModeType
All Implemented Interfaces:
Serializable, Comparable<FlushModeType>
public enum FlushModeType
extends Enum<FlushModeType>

Flush mode setting.

When queries are executed within a transaction, if FlushModeType.AUTO is set on the Query object, or if the flush mode setting for the persistence context is AUTO (the default) and a flush mode setting has not been specified for the Query object, the persistence provider is responsible for ensuring that all updates to the state of all entities in the persistence context which could potentially affect the result of the query are visible to the processing of the query. The persistence provider implementation may achieve this by flushing those entities to the database or by some other means. If FlushModeType.COMMIT is set, the effect of updates made to entities in the persistence context upon queries is unspecified.

If there is no transaction active, the persistence provider must not flush to the database.

Since:
Java Persistence 1.0

Enum Constant Summary
AUTO
(Default) Flushing to occur at query execution
COMMIT
Flushing must occur only at transaction commit
Method Summary
static FlushModeType | valueOf(String name) Returns the enum constant of this type with the specified name.
static FlushModeType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

COMMIT

public static final FlushModeType COMMIT
Flushing must occur only at transaction commit

AUTO

public static final FlushModeType AUTO
(Default) Flushing to occur at query execution

Method Detail

values

public static final FlushModeType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(FlushModeType c : FlushModeType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static FlushModeType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


GeneratedValue

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type GeneratedValue

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface GeneratedValue

Provides for the specification of generation strategies for the values of primary keys. The GeneratedValue annotation may be applied to a primary key property or field of an entity or mapped superclass in conjunction with the Id annotation.

 Example 1:

     @Id
     @GeneratedValue(strategy=SEQUENCE, generator="CUST_SEQ")
     @Column(name="CUST_ID")
     public Long getId() { return id; }

     Example 2:

     @Id
     @GeneratedValue(strategy=TABLE, generator="CUST_GEN")
     @Column(name="CUST_ID")
     Long id;

Since:
Java Persistence 1.0

Optional Element Summary
String | generator (Optional) The name of the primary key generator to use as specified in the SequenceGenerator or TableGenerator annotation.
GenerationType | strategy (Optional) The primary key generation strategy that the persistence provider must use to generate the annotated entity primary key.

strategy

public abstract GenerationType strategy
(Optional) The primary key generation strategy that the persistence provider must use to generate the annotated entity primary key.

Default:
AUTO

generator

public abstract String generator
(Optional) The name of the primary key generator to use as specified in the SequenceGenerator or TableGenerator annotation.

Defaults to the id generator supplied by persistence provider.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


GenerationType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.persistence
Enum GenerationType

java.lang.Object
    extended by  java.lang.Enum<GenerationType>
        extended by  javax.persistence.GenerationType
All Implemented Interfaces:
Serializable, Comparable<GenerationType>
public enum GenerationType
extends Enum<GenerationType>

Defines the types of primary key generation.

Since:
Java Persistence 1.0

Enum Constant Summary
AUTO
Indicates that the persistence provider should pick an appropriate strategy for the particular database.
IDENTITY
Indicates that the persistence provider must assign primary keys for the entity using database identity column.
SEQUENCE
Indicates that the persistence provider must assign primary keys for the entity using database sequence column.
TABLE
Indicates that the persistence provider must assign primary keys for the entity using an underlying database table to ensure uniqueness.
Method Summary
static GenerationType | valueOf(String name) Returns the enum constant of this type with the specified name.
static GenerationType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

TABLE

public static final GenerationType TABLE
Indicates that the persistence provider must assign primary keys for the entity using an underlying database table to ensure uniqueness.

SEQUENCE

public static final GenerationType SEQUENCE
Indicates that the persistence provider must assign primary keys for the entity using database sequence column.

IDENTITY

public static final GenerationType IDENTITY
Indicates that the persistence provider must assign primary keys for the entity using database identity column.

AUTO

public static final GenerationType AUTO
Indicates that the persistence provider should pick an appropriate strategy for the particular database. The AUTO generation strategy may expect a database resource to exist, or it may attempt to create one. A vendor may provide documentation on how to create such resources in the event that it does not support schema generation or cannot create the schema resource at runtime.

Method Detail

values

public static final GenerationType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(GenerationType c : GenerationType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static GenerationType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


IdClass

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type IdClass

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface IdClass

Specifies a composite primary key class that is mapped to multiple fields or properties of the entity.

The names of the fields or properties in the primary key class and the primary key fields or properties of the entity must correspond and their types must be the same.

   Example:

   @IdClass(com.acme.EmployeePK.class)
   @Entity
   public class Employee {
     @Id String empName;
     @Id Date birthDay;
     ...
   }

Since:
Java Persistence 1.0

Required Element Summary
 Class value
Primary key class

Element Detail

value

public abstract Class value
Primary key class

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Inheritance

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type Inheritance

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Inheritance

Defines the inheritance strategy to be used for an entity class hierarchy. It is specified on the entity class that is the root of the entity class hierarchy.

   Example:

   @Entity
   @Inheritance(strategy=JOINED)
   public class Customer { ... }

   @Entity
   public class ValuedCustomer extends Customer { ... }

Since:
Java Persistence 1.0

Optional Element Summary
 InheritanceType strategy
The strategy to be used

strategy

public abstract InheritanceType strategy
The strategy to be used

Default:
SINGLE_TABLE
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InheritanceType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.persistence
Enum InheritanceType

java.lang.Object
    extended by  java.lang.Enum<InheritanceType>
        extended by  javax.persistence.InheritanceType
All Implemented Interfaces:
Serializable, Comparable<InheritanceType>
public enum InheritanceType
extends Enum<InheritanceType>

Defines inheritance strategy options.

Since:
Java Persistence 1.0

Enum Constant Summary
JOINED
A strategy in which fields that are specific to a subclass are mapped to a separate table than the fields that are common to the parent class, and a join is performed to instantiate the subclass.
SINGLE_TABLE
A single table per class hierarchy
TABLE_PER_CLASS
A table per concrete entity class
Method Summary
static InheritanceType | valueOf(String name) Returns the enum constant of this type with the specified name.
static InheritanceType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

SINGLE_TABLE

public static final InheritanceType SINGLE_TABLE
A single table per class hierarchy

TABLE_PER_CLASS

public static final InheritanceType TABLE_PER_CLASS
A table per concrete entity class

JOINED

public static final InheritanceType JOINED
A strategy in which fields that are specific to a subclass are mapped to a separate table than the fields that are common to the parent class, and a join is performed to instantiate the subclass.

Method Detail

values

public static final InheritanceType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(InheritanceType c : InheritanceType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static InheritanceType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JoinColumn

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type JoinColumn

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface JoinColumn

Is used to specify a mapped column for joining an entity association.

   Example:

   @ManyToOne
   @JoinColumn(name="ADDR_ID")
   public Address getAddress() { return address; }

Since:
Java Persistence 1.0

Optional Element Summary
String | columnDefinition (Optional) The SQL fragment that is used when generating the DDL for the column.
boolean | insertable (Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.
String | name (Optional) The name of the foreign key column.
boolean | nullable (Optional) Whether the foreign key column is nullable.
String | referencedColumnName (Optional) The name of the column referenced by this foreign key column.
String | table (Optional) The name of the table that contains the column.
boolean | unique (Optional) Whether the property is a unique key.
boolean | updatable (Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.

name

public abstract String name
(Optional) The name of the foreign key column. The table in which it is found depends upon the context. If the join is for a OneToOne or Many- ToOne mapping, the foreign key column is in the table of the source entity. If the join is for a ManyToMany, the foreign key is in a join table. Default (only applies if a single join column is used): The concatenation of the following: the name of the referencing relationship property or field of the referencing entity; "_"; the name of the referenced primary key column. If there is no such referencing relationship property or field in the entity, the join column name is formed as the concatenation of the following: the name of the entity; "_"; the name of the referenced primary key column.

Default:
""

referencedColumnName

public abstract String referencedColumnName
(Optional) The name of the column referenced by this foreign key column. When used with relationship mappings, the referenced column is in the table of the target entity. When used inside a JoinTable annotation, the referenced key column is in the entity table of the owning entity, or inverse entity if the join is part of the inverse join definition. Default (only applies if single join column is being used): The same name as the primary key column of the referenced table.

Default:
""

unique

public abstract boolean unique
(Optional) Whether the property is a unique key. This is a shortcut for the UniqueConstraint annotation at the table level and is useful for when the unique key constraint is only a single field. It is not necessary to explicitly specify this for a join column that corresponds to a primary key that is part of a foreign key.

Default:
false

nullable

public abstract boolean nullable
(Optional) Whether the foreign key column is nullable.

Default:
true

insertable

public abstract boolean insertable
(Optional) Whether the column is included in SQL INSERT statements generated by the persistence provider.

Default:
true

updatable

public abstract boolean updatable
(Optional) Whether the column is included in SQL UPDATE statements generated by the persistence provider.

Default:
true

columnDefinition

public abstract String columnDefinition
(Optional) The SQL fragment that is used when generating the DDL for the column.

Defaults to the generated SQL for the column.

Default:
""

table

public abstract String table
(Optional) The name of the table that contains the column. If a table is not specified, the column is assumed to be in the primary table of the applicable entity.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JoinColumns

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type JoinColumns

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface JoinColumns

Defines mapping for the composite foreign keys. This annotation groups JoinColumn annotations for the same relationship.

When the JoinColumns annotation is used, both the name and the referencedColumnName elements must be specified in each such JoinColumn annotation.

    Example:
    @ManyToOne
    @JoinColumns({
        @JoinColumn(name="ADDR_ID", referencedColumnName="ID"),
        @JoinColumn(name="ADDR_ZIP", referencedColumnName="ZIP")
    })
    public Address getAddress() { return address; }

Since:
Java Persistence 1.0

Required Element Summary
 JoinColumn[] value

Element Detail

value

public abstract JoinColumn[] value
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JoinTable

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type JoinTable

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface JoinTable

This annotation is used in the mapping of associations. It is specified on the owning side of a many-to-many association, or in a unidirectional one-to-many association.

If the JoinTable annotation is missing, the default values of the annotation elements apply. The name of the join table is assumed to be the table names of the associated primary tables concatenated together (owning side first) using an underscore.

    Example:
    @JoinTable(
    name="CUST_PHONE",
    joinColumns=
        @JoinColumn(name="CUST_ID", referencedColumnName="ID"),
    inverseJoinColumns=
        @JoinColumn(name="PHONE_ID", referencedColumnName="ID")
    )

Since:
Java Persistence 1.0

Optional Element Summary
String | catalog (Optional) The catalog of the table.
JoinColumn[] | inverseJoinColumns (Optional) The foreign key columns of the join table which reference the primary table of the entity that does not own the association (i.e. the inverse side of the association).
JoinColumn[] | joinColumns (Optional) The foreign key columns of the join table which reference the primary table of the entity owning the association (i.e. the owning side of the association).
String | name (Optional) The name of the join table.
String | schema (Optional) The schema of the table.
UniqueConstraint[] | uniqueConstraints (Optional) Unique constraints that are to be placed on the table.

name

public abstract String name
(Optional) The name of the join table.

Defaults to the concatenated names of the two associated primary entity tables, separated by an underscore.

Default:
""

catalog

public abstract String catalog
(Optional) The catalog of the table.

Defaults to the default catalog.

Default:
""

schema

public abstract String schema
(Optional) The schema of the table.

Defaults to the default schema for user.

Default:
""

joinColumns

public abstract JoinColumn[] joinColumns
(Optional) The foreign key columns of the join table which reference the primary table of the entity owning the association (i.e. the owning side of the association).

Uses the same defaults as for JoinColumn.

Default:
{}

inverseJoinColumns

public abstract JoinColumn[] inverseJoinColumns
(Optional) The foreign key columns of the join table which reference the primary table of the entity that does not own the association (i.e. the inverse side of the association).

Uses the same defaults as for JoinColumn.

Default:
{}

uniqueConstraints

public abstract UniqueConstraint[] uniqueConstraints
(Optional) Unique constraints that are to be placed on the table. These are only used if table generation is in effect.

Defaults to no additional constraints.

Default:
{}
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LockModeType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.persistence
Enum LockModeType

java.lang.Object
    extended by  java.lang.Enum<LockModeType>
        extended by  javax.persistence.LockModeType
All Implemented Interfaces:
Serializable, Comparable<LockModeType>
public enum LockModeType
extends Enum<LockModeType>

Lock modes that can be specified by means of the EntityManager.lock() method.

The semantics of requesting locks of type LockModeType.READ and LockModeType.WRITE are the following.

If transaction T1 calls lock(entity, LockModeType.READ) on a versioned object, the entity manager must ensure that neither of the following phenomena can occur:

  • P1 (Dirty read): Transaction T1 modifies a row. Another transaction T2 then reads that row and obtains the modified value, before T1 has committed or rolled back. Transaction T2 eventually commits successfully; it does not matter whether T1 commits or rolls back and whether it does so before or after T2 commits.
    • P2 (Non-repeatable read): Transaction T1 reads a row. Another transaction T2 then modifies or deletes that row, before T1 has committed. Both transactions eventually commit successfully.

Lock modes must always prevent the phenomena P1 and P2.

In addition, calling lock(entity, LockModeType.WRITE) on a versioned object, will also force an update (increment) to the entity's version column.

The persistence implementation is not required to support calling EntityManager.lock() on a non-versioned object. When it cannot support a such lock call, it must throw the PersistenceException.

Since:
Java Persistence 1.0

Enum Constant Summary
READ
Read lock
WRITE
Write lock
Method Summary
static LockModeType | valueOf(String name) Returns the enum constant of this type with the specified name.
static LockModeType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

READ

public static final LockModeType READ
Read lock

WRITE

public static final LockModeType WRITE
Write lock

Method Detail

values

public static final LockModeType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(LockModeType c : LockModeType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static LockModeType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ManyToMany

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type ManyToMany

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface ManyToMany

Defines a many-valued association with many-to-many multiplicity. If the Collection is defined using generics to specify the element type, the associated target entity class does not need to be specified; otherwise it must be specified.

Every many-to-many association has two sides, the owning side and the non-owning, or inverse, side. The join table is specified on the owning side. If the association is bidirectional, either side may be designated as the owning side.

The same annotation elements for the OneToMany annotation apply to the ManyToMany annotation.

    Example 1:

    In Customer class:

    @ManyToMany
    @JoinTable(name="CUST_PHONES")
    public Set getPhones() { return phones; }

    In PhoneNumber class:

    @ManyToMany(mappedBy="phones")
    public Set getCustomers() { return customers; }

    Example 2:

    In Customer class:

    @ManyToMany(targetEntity=com.acme.PhoneNumber.class)
    public Set getPhones() { return phones; }

    In PhoneNumber class:

    @ManyToMany(targetEntity=com.acme.Customer.class, mappedBy="phones")
    public Set getCustomers() { return customers; }

    Example 3:

    In Customer class:

    @ManyToMany
    @JoinTable(name="CUST_PHONE",
        joinColumns=
            @JoinColumn(name="CUST_ID", referencedColumnName="ID"),
        inverseJoinColumns=
            @JoinColumn(name="PHONE_ID", referencedColumnName="ID")
        )
    public Set getPhones() { return phones; }

    In PhoneNumberClass:

    @ManyToMany(mappedBy="phones")
    public Set getCustomers() { return customers; }

Since:
Java Persistence 1.0

Optional Element Summary
CascadeType[] | cascade (Optional) The operations that must be cascaded to the target of the association.
FetchType | fetch (Optional) Whether the association should be lazily loaded or must be eagerly fetched.
String | mappedBy The field that owns the relationship.
Class | targetEntity (Optional) The entity class that is the target of the association.

targetEntity

public abstract Class targetEntity
(Optional) The entity class that is the target of the association. Optional only if the collection property is defined using Java generics. Must be specified otherwise.

Defaults to the parameterized type of the collection when defined using generics.

Default:
void.class

cascade

public abstract CascadeType[] cascade
(Optional) The operations that must be cascaded to the target of the association.

Defaults to no operations being cascaded.

Default:
{}

fetch

public abstract FetchType fetch
(Optional) Whether the association should be lazily loaded or must be eagerly fetched. The EAGER strategy is a requirement on the persistenceprovider runtime that the associatedentities must be eagerly fetched. The LAZY strategy is a hint to the persistence provider runtime.

Default:
LAZY

mappedBy

public abstract String mappedBy
The field that owns the relationship. Required unless the relationship is unidirectional.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ManyToOne

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type ManyToOne

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface ManyToOne

This annotation defines a single-valued association to another entity class that has many-to-one multiplicity. It is not normally necessary to specify the target entity explicitly since it can usually be inferred from the type of the object being referenced.

     Example:

     @ManyToOne(optional=false)
     @JoinColumn(name="CUST_ID", nullable=false, updatable=false)
     public Customer getCustomer() { return customer; }

Since:
Java Persistence 1.0

Optional Element Summary
CascadeType[] | cascade (Optional) The operations that must be cascaded to the target of the association.
FetchType | fetch (Optional) Whether the association should be lazily loaded or must be eagerly fetched.
boolean | optional (Optional) Whether the association is optional.
Class | targetEntity (Optional) The entity class that is the target of the association.

targetEntity

public abstract Class targetEntity
(Optional) The entity class that is the target of the association.

Defaults to the type of the field or property that stores the association.

Default:
void.class

cascade

public abstract CascadeType[] cascade
(Optional) The operations that must be cascaded to the target of the association.

By default no operations are cascaded.

Default:
{}

fetch

public abstract FetchType fetch
(Optional) Whether the association should be lazily loaded or must be eagerly fetched. The EAGER strategy is a requirement on the persistence provider runtime that the associated entity must be eagerly fetched. The LAZY strategy is a hint to the persistence provider runtime.

Default:
EAGER

optional

public abstract boolean optional
(Optional) Whether the association is optional. If set to false then a non-null relationship must always exist.

Default:
true
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MapKey

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type MapKey

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface MapKey

Is used to specify the map key for associations of type Map.

If a persistent field or property other than the primary key is used as a map key then it is expected to have a uniqueness constraint associated with it.

    Example 1:

    @Entity
    public class Department {
        ...
        @OneToMany(mappedBy="department")
        @MapKey(name="empId")
        public Map getEmployees() {... }
        ...
    }

    @Entity
    public class Employee {
        ...
        @Id Integer getEmpid() { ... }
        @ManyToOne
        @JoinColumn(name="dept_id")
        public Department getDepartment() { ... }
        ...
    }

    Example 2:

    @Entity
        public class Department {
        ...
        @OneToMany(mappedBy="department")
        @MapKey(name="empPK")
        public Map getEmployees() {... }
        ...
    }

    @Entity
        public class Employee {
        @EmbeddedId public EmployeePK getEmpPK() { ... }
        ...
        @ManyToOne
        @JoinColumn(name="dept_id")
        public Department getDepartment() { ... }
        ...
    }

    @Embeddable
    public class EmployeePK {
        String name;
        Date bday;
    }

Since:
Java Persistence 1.0

Optional Element Summary
 String name
The name of the persistent field or property of the associated entity that is used as the map key.

name

public abstract String name
The name of the persistent field or property of the associated entity that is used as the map key. If the name element is not specified, the primary key of the associated entity is used as the map key. If the primary key is a composite primary key and is mapped as IdClass, an instance of the primary key class is used as the key.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NamedNativeQueries

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type NamedNativeQueries

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface NamedNativeQueries

Is used to specify an array of native SQL named queries. Query names are scoped to the persistence unit.

Since:
Java Persistence 1.0

Required Element Summary
 NamedNativeQuery[] value
Array of native SQL named queries

Element Detail

value

public abstract NamedNativeQuery[] value
Array of native SQL named queries

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NamedNativeQuery

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type NamedNativeQuery

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface NamedNativeQuery

Is used to specify a native SQL named query. Query names are scoped to the persistence unit.

Since:
Java Persistence 1.0

Required Element Summary
String | name Is used to refer to the query when using the EntityManager methods that create query objects.
String | query The SQL query string
Optional Element Summary
QueryHint[] | hints Vendor-specific query hints
Class | resultClass The class of the result
String | resultSetMapping The name of a SqlResultSetMapping, as defined in metadata

Element Detail

name

public abstract String name
Is used to refer to the query when using the EntityManager methods that create query objects.

query

public abstract String query
The SQL query string

hints

public abstract QueryHint[] hints
Vendor-specific query hints

Default:
{}

resultClass

public abstract Class resultClass
The class of the result

Default:
void.class

resultSetMapping

public abstract String resultSetMapping
The name of a SqlResultSetMapping, as defined in metadata

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NamedQueries

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type NamedQueries

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface NamedQueries

Specifies an array of named Java Persistence query language queries. Query names are scoped to the persistence unit.

Since:
Java Persistence 1.0

Required Element Summary
 NamedQuery[] value
An array of named Java Persistence query language queries.

Element Detail

value

public abstract NamedQuery[] value
An array of named Java Persistence query language queries.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NamedQuery

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type NamedQuery

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface NamedQuery

Is used to specify a named query in the Java Persistence query language, which is a static query expressed in metadata. Query names are scoped to the persistence unit.

The following is an example of the definition of a named query in the Java Persistence query language:

    @NamedQuery(
            name="findAllCustomersWithName",
            query="SELECT c FROM Customer c WHERE c.name LIKE :custName"
    )

The following is an example of the use of a named query:

    @PersistenceContext
    public EntityManager em;
    ...
    customers = em.createNamedQuery("findAllCustomersWithName")
            .setParameter("custName", "Smith")
            .getResultList();

Since:
Java Persistence 1.0

Required Element Summary
String | name Refers to the query when using the EntityManager methods that create query objects.
String | query The query string in the Java Persistence query language
Optional Element Summary
 QueryHint[] hints
Vendor-specific query hints

Element Detail

name

public abstract String name
Refers to the query when using the EntityManager methods that create query objects.

query

public abstract String query
The query string in the Java Persistence query language

hints

public abstract QueryHint[] hints
Vendor-specific query hints

Default:
{}
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NonUniqueResultException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence
Class NonUniqueResultException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.persistence.PersistenceException
                    extended by  javax.persistence.NonUniqueResultException
All Implemented Interfaces:
Serializable
public class NonUniqueResultException
extends PersistenceException

Thrown by the persistence provider when getSingleResult() is executed on a query and there is more than one result from the query. This exception will not cause the current transaction, if one is active, to be marked for roll back.

Since:
Java Persistence 1.0
See Also:
Query.getSingleResult(), Serialized Form

Constructor Summary
NonUniqueResultException()
Constructs a new NonUniqueResultException exception with null as its detail message.
NonUniqueResultException(String message)
Constructs a new NonUniqueResultException exception with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NonUniqueResultException

public NonUniqueResultException()
Constructs a new NonUniqueResultException exception with null as its detail message.

NonUniqueResultException

public NonUniqueResultException(String message)
Constructs a new NonUniqueResultException exception with the specified detail message.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NoResultException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence
Class NoResultException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.persistence.PersistenceException
                    extended by  javax.persistence.NoResultException
All Implemented Interfaces:
Serializable
public class NoResultException
extends PersistenceException

Thrown by the persistence provider when getSingleResult() is executed on a query and there is no result to return. This exception will not cause the current transaction, if one is active, to be marked for roll back.

Since:
Java Persistence 1.0
See Also:
Query.getSingleResult(), Serialized Form

Constructor Summary
NoResultException()
Constructs a new NoResultException exception with null as its detail message.
NoResultException(String message)
Constructs a new NoResultException exception with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoResultException

public NoResultException()
Constructs a new NoResultException exception with null as its detail message.

NoResultException

public NoResultException(String message)
Constructs a new NoResultException exception with the specified detail message.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


OneToMany

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type OneToMany

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface OneToMany

Defines a many-valued association with one-to-many multiplicity.

If the collection is defined using generics to specify the element type, the associated target entity type need not be specified; otherwise the target entity class must be specified.

    Example 1: One-to-Many association using generics

    In Customer class:

    @OneToMany(cascade=ALL, mappedBy="customer")
    public Set getOrders() { return orders; }

    In Order class:

    @ManyToOne
    @JoinColumn(name="CUST_ID", nullable=false)
    public Customer getCustomer() { return customer; }

    Example 2: One-to-Many association without using generics

    In Customer class:

    @OneToMany(targetEntity=com.acme.Order.class, cascade=ALL,
            mappedBy="customer")
    public Set getOrders() { return orders; }

    In Order class:

    @ManyToOne
    @JoinColumn(name="CUST_ID", nullable=false)
    public Customer getCustomer() { return customer; }

Since:
Java Persistence 1.0

Optional Element Summary
CascadeType[] | cascade (Optional) The operations that must be cascaded to the target of the association.
FetchType | fetch (Optional) Whether the association should be lazily loaded or must be eagerly fetched.
String | mappedBy The field that owns the relationship.
Class | targetEntity (Optional) The entity class that is the target of the association.

targetEntity

public abstract Class targetEntity
(Optional) The entity class that is the target of the association. Optional only if the collection property is defined using Java generics. Must be specified otherwise.

Defaults to the parameterized type of the collection when defined using generics.

Default:
void.class

cascade

public abstract CascadeType[] cascade
(Optional) The operations that must be cascaded to the target of the association.

Defaults to no operations being cascaded.

Default:
{}

fetch

public abstract FetchType fetch
(Optional) Whether the association should be lazily loaded or must be eagerly fetched. The EAGER strategy is a requirement on the persistenceprovider runtime that the associatedentities must be eagerly fetched. The LAZY strategy is a hint to the persistence provider runtime.

Default:
LAZY

mappedBy

public abstract String mappedBy
The field that owns the relationship. Required unless the relationship is unidirectional.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


OneToOne

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type OneToOne

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface OneToOne

This annotation defines a single-valued association to another entity that has one-to-one multiplicity. It is not normally necessary to specify the associated target entity explicitly since it can usually be inferred from the type of the object being referenced.

    Example 1: One-to-one association that maps a foreign key column

    On Customer class:

    @OneToOne(optional=false)
    @JoinColumn(
        name="CUSTREC_ID", unique=true, nullable=false, updatable=false)
    public CustomerRecord getCustomerRecord() { return customerRecord; }

    On CustomerRecord class:

    @OneToOne(optional=false, mappedBy="customerRecord")
    public Customer getCustomer() { return customer; }

    Example 2: One-to-one association that assumes both the source and target share the same primary key values.

    On Employee class:

    @Entity
    public class Employee {
        @Id Integer id;

        @OneToOne @PrimaryKeyJoinColumn
        EmployeeInfo info;
        ...
    }

    On EmployeeInfo class:

    @Entity
    public class EmployeeInfo {
        @Id Integer id;
        ...
    }

Since:
Java Persistence 1.0

Optional Element Summary
CascadeType[] | cascade (Optional) The operations that must be cascaded to the target of the association.
FetchType | fetch (Optional) Whether the association should be lazily loaded or must be eagerly fetched.
String | mappedBy (Optional) The field that owns the relationship.
boolean | optional (Optional) Whether the association is optional.
Class | targetEntity (Optional) The entity class that is the target of the association.

targetEntity

public abstract Class targetEntity
(Optional) The entity class that is the target of the association.

Defaults to the type of the field or property that stores the association.

Default:
void.class

cascade

public abstract CascadeType[] cascade
(Optional) The operations that must be cascaded to the target of the association.

By default no operations are cascaded.

Default:
{}

fetch

public abstract FetchType fetch
(Optional) Whether the association should be lazily loaded or must be eagerly fetched. The EAGER strategy is a requirement on the persistence provider runtime that the associated entity must be eagerly fetched. The LAZY strategy is a hint to the persistence provider runtime.

Default:
EAGER

optional

public abstract boolean optional
(Optional) Whether the association is optional. If set to false then a non-null relationship must always exist.

Default:
true

mappedBy

public abstract String mappedBy
(Optional) The field that owns the relationship. This element is only specified on the inverse (non-owning) side of the association.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


OptimisticLockException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence
Class OptimisticLockException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.persistence.PersistenceException
                    extended by  javax.persistence.OptimisticLockException
All Implemented Interfaces:
Serializable
public class OptimisticLockException
extends PersistenceException

Thrown by the persistence provider when an optimistic locking conflict occurs. This exception may be thrown as part of an API call, a flush or at commit time. The current transaction, if one is active, will be marked for rollback.

Since:
Java Persistence 1.0
See Also:
Serialized Form

Constructor Summary
OptimisticLockException()
Constructs a new OptimisticLockException exception with null as its detail message.
OptimisticLockException(Object entity)
Constructs a new OptimisticLockException exception with the specified entity.
OptimisticLockException(String message)
Constructs a new OptimisticLockException exception with the specified detail message.
OptimisticLockException(String message, Throwable cause)
Constructs a new OptimisticLockException exception with the specified detail message and cause.
OptimisticLockException(String message, Throwable cause, Object entity)
Constructs a new OptimisticLockException exception with the specified detail message, cause, and entity.
OptimisticLockException(Throwable cause)
Constructs a new OptimisticLockException exception with the specified cause.
Method Summary
 Object getEntity()
Returns the entity that caused this exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OptimisticLockException

public OptimisticLockException()
Constructs a new OptimisticLockException exception with null as its detail message.

OptimisticLockException

public OptimisticLockException(String message)
Constructs a new OptimisticLockException exception with the specified detail message.

Parameters:
message - the detail message.

OptimisticLockException

public OptimisticLockException(String message,
                               Throwable cause)
Constructs a new OptimisticLockException exception with the specified detail message and cause.

Parameters:
message - the detail message.
cause - the cause.

OptimisticLockException

public OptimisticLockException(Throwable cause)
Constructs a new OptimisticLockException exception with the specified cause.

Parameters:
cause - the cause.

OptimisticLockException

public OptimisticLockException(Object entity)
Constructs a new OptimisticLockException exception with the specified entity.

Parameters:
entity - the entity.

OptimisticLockException

public OptimisticLockException(String message,
                               Throwable cause,
                               Object entity)
Constructs a new OptimisticLockException exception with the specified detail message, cause, and entity.

Parameters:
message - the detail message.
cause - the cause.
entity - the entity.
Method Detail

getEntity

public Object getEntity()
Returns the entity that caused this exception.

Returns:
the entity.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


OrderBy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type OrderBy

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface OrderBy

This annotation specifies the ordering of the elements of a collection valued association at the point when the association is retrieved.

The syntax of the value ordering element is an orderby_list, as follows:

    orderby_list::= orderby_item [,orderby_item]*
    orderby_item::= property_or_field_name [ASC | DESC]

If ASC or DESC is not specified, ASC (ascending order) is assumed.

If the ordering element is not specified, ordering by the primary key of the associated entity is assumed.

The property or field name must correspond to that of a persistent property or field of the associated class. The properties or fields used in the ordering must correspond to columns for which comparison operators are supported.

    Example:

    @Entity public class Course {
     ...
     @ManyToMany
     @OrderBy("lastname ASC")
     public List getStudents() {...};
     ...
    }

    @Entity public class Student {
      ...
      @ManyToMany(mappedBy="students")
      @OrderBy // PK is assumed
      public List getCourses() {...};
      ...
    }

Since:
Java Persistence 1.0

Optional Element Summary
 String value
An orderby_list, specified as follows: orderby_list::= orderby_item [,orderby_item]* orderby_item::= property_or_field_name [ASC | DESC] If ASC or DESC is not specified, ASC (ascending order) is assumed.

value

public abstract String value
An orderby_list, specified as follows:
    orderby_list::= orderby_item [,orderby_item]*
    orderby_item::= property_or_field_name [ASC | DESC]

If ASC or DESC is not specified, ASC (ascending order) is assumed.

If the ordering element is not specified, ordering by the primary key of the associated entity is assumed.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Persistence

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence
Class Persistence

java.lang.Object
    extended by  javax.persistence.Persistence

public class Persistence
extends Object

Bootstrap class that is used to obtain an EntityManagerFactory.

Since:
Java Persistence 1.0

Field Summary
static String | PERSISTENCE_PROVIDER
protected static Set<PersistenceProvider> | providers
Constructor Summary
Persistence()
Method Summary
static EntityManagerFactory | createEntityManagerFactory(String persistenceUnitName) Create and return an EntityManagerFactory for the named persistence unit.
static EntityManagerFactory | createEntityManagerFactory(String persistenceUnitName, Map properties) Create and return an EntityManagerFactory for the named persistence unit using the given properties.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PERSISTENCE_PROVIDER

public static String PERSISTENCE_PROVIDER

providers

protected static final Set<PersistenceProvider> providers
Constructor Detail

Persistence

public Persistence()
Method Detail

createEntityManagerFactory

public static EntityManagerFactory createEntityManagerFactory(String persistenceUnitName)
Create and return an EntityManagerFactory for the named persistence unit.

Parameters:
persistenceUnitName - The name of the persistence unit
Returns:
The factory that creates EntityManagers configured according to the specified persistence unit

createEntityManagerFactory

public static EntityManagerFactory createEntityManagerFactory(String persistenceUnitName,
                                                              Map properties)
Create and return an EntityManagerFactory for the named persistence unit using the given properties.

Parameters:
persistenceUnitName - The name of the persistence unit
properties - Additional properties to use when creating the factory. The values of these properties override any values that may have been configured elsewhere.
Returns:
The factory that creates EntityManagers configured according to the specified persistence unit.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PersistenceContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PersistenceContext

@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface PersistenceContext

Expresses a dependency on an EntityManager persistence context.

Since:
Java Persistence 1.0

Optional Element Summary
String | name The name by which the entity manager is to be accessed in the environment referencing context, and is not needed when dependency injection is used.
PersistenceProperty[] | properties Used to specify properties for the container or persistence provider.
PersistenceContextType | type Specifies whether this is a transaction-scoped persistence context or an extended persistence context.
String | unitName The name of the persistence unit.

name

public abstract String name
The name by which the entity manager is to be accessed in the environment referencing context, and is not needed when dependency injection is used.

Default:
""

unitName

public abstract String unitName
The name of the persistence unit. If the unitName element is specified, the persistence unit for the entity manager that is accessible in JNDI must have the same name.

Default:
""

type

public abstract PersistenceContextType type
Specifies whether this is a transaction-scoped persistence context or an extended persistence context.

Default:
TRANSACTION

properties

public abstract PersistenceProperty[] properties
Used to specify properties for the container or persistence provider. Vendor specific properties may be included in this set of properties. Properties that are not recognized by a vendor are ignored.

Default:
{}
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PersistenceContexts

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PersistenceContexts

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface PersistenceContexts

Declares one or more PersistenceContext annotations. It is used to express a dependency on container-managed entity manager persistence contexts.

Since:
Java Persistence 1.0

Required Element Summary
 PersistenceContext[] value
One or more persistence context

Element Detail

value

public abstract PersistenceContext[] value
One or more persistence context

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PersistenceContextType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.persistence
Enum PersistenceContextType

java.lang.Object
    extended by  java.lang.Enum<PersistenceContextType>
        extended by  javax.persistence.PersistenceContextType
All Implemented Interfaces:
Serializable, Comparable<PersistenceContextType>
public enum PersistenceContextType
extends Enum<PersistenceContextType>

Specifies whether a transaction-scoped or extended persistence context is to be used in PersistenceContext. If the type element is not specified, a transaction-scoped persistence context is used.

Since:
Java Persistence 1.0

Enum Constant Summary
EXTENDED
Extended persistence context
TRANSACTION
Transaction-scoped persistence context
Method Summary
static PersistenceContextType | valueOf(String name) Returns the enum constant of this type with the specified name.
static PersistenceContextType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

TRANSACTION

public static final PersistenceContextType TRANSACTION
Transaction-scoped persistence context

EXTENDED

public static final PersistenceContextType EXTENDED
Extended persistence context

Method Detail

values

public static final PersistenceContextType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(PersistenceContextType c : PersistenceContextType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static PersistenceContextType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PersistenceException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence
Class PersistenceException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.persistence.PersistenceException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
EntityExistsException, EntityNotFoundException, NonUniqueResultException, NoResultException, OptimisticLockException, RollbackException, TransactionRequiredException
public class PersistenceException
extends RuntimeException

Thrown by the persistence provider when a problem occurs. All instances of PersistenceException except for instances of NoResultException and NonUniqueResultException will cause the current transaction, if one is active, to be marked for rollback.

Since:
Java Persistence 1.0
See Also:
Serialized Form

Constructor Summary
PersistenceException()
Constructs a new PersistenceException exception with null as its detail message.
PersistenceException(String message)
Constructs a new PersistenceException exception with the specified detail message.
PersistenceException(String message, Throwable cause)
Constructs a new PersistenceException exception with the specified detail message and cause.
PersistenceException(Throwable cause)
Constructs a new PersistenceException exception with the specified cause.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PersistenceException

public PersistenceException()
Constructs a new PersistenceException exception with null as its detail message.

PersistenceException

public PersistenceException(String message)
Constructs a new PersistenceException exception with the specified detail message.

Parameters:
message - the detail message.

PersistenceException

public PersistenceException(String message,
                            Throwable cause)
Constructs a new PersistenceException exception with the specified detail message and cause.

Parameters:
message - the detail message.
cause - the cause.

PersistenceException

public PersistenceException(Throwable cause)
Constructs a new PersistenceException exception with the specified cause.

Parameters:
cause - the cause.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PersistenceProperty

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PersistenceProperty

@Target(value={})
@Retention(value=RUNTIME)
public @interface PersistenceProperty

Describes a single container or persistence provider property.

Vendor specific properties may be included in the set of properties, and are passed to the persistence provider by the container when the entity manager is created. Properties that are not recognized by a vendor will be ignored.

Since:
Java Persistence 1.0

Required Element Summary
String | name The name of the property
String | value The value of the property

Element Detail

name

public abstract String name
The name of the property

value

public abstract String value
The value of the property

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PersistenceUnit

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PersistenceUnit

@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface PersistenceUnit

Expresses a dependency on an EntityManagerFactory.

Since:
Java Persistence 1.0

Optional Element Summary
String | name The name by which the entity manager factory is to be accessed in the environment referencing context, and is not needed when dependency injection is used.
String | unitName The name of the persistence unit as defined in the persistence.xml file.

name

public abstract String name
The name by which the entity manager factory is to be accessed in the environment referencing context, and is not needed when dependency injection is used.

Default:
""

unitName

public abstract String unitName
The name of the persistence unit as defined in the persistence.xml file. If specified, the persistence unit for the entity manager factory that is accessible in JNDI must have the same name.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PersistenceUnits

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PersistenceUnits

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface PersistenceUnits

Declares one or more PersistenceUnit annotations.

Since:
Java Persistence 1.0

Required Element Summary
 PersistenceUnit[] value
One or more PersistenceUnit annotations.

Element Detail

value

public abstract PersistenceUnit[] value
One or more PersistenceUnit annotations.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PrimaryKeyJoinColumn

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PrimaryKeyJoinColumn

@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface PrimaryKeyJoinColumn

This annotation specifies a primary key column that is used as a foreign key to join to another table.

It is used to join the primary table of an entity subclass in the JOINED mapping strategy to the primary table of its superclass; it is used within a SecondaryTable annotation to join a secondary table to a primary table; and it may be used in a OneToOne mapping in which the primary key of the referencing entity is used as a foreign key to the referenced entity.

If no PrimaryKeyJoinColumn annotation is specified for a subclass in the JOINED mapping strategy, the foreign key columns are assumed to have the same names as the primary key columns of the primary table of the superclass

    Example: Customer and ValuedCustomer subclass

    @Entity
    @Table(name="CUST")
    @Inheritance(strategy=JOINED)
    @DiscriminatorValue("CUST")
    public class Customer { ... }

    @Entity
    @Table(name="VCUST")
    @DiscriminatorValue("VCUST")
    @PrimaryKeyJoinColumn(name="CUST_ID")
    public class ValuedCustomer extends Customer { ... }

Since:
Java Persistence 1.0

Optional Element Summary
String | columnDefinition (Optional) The SQL fragment that is used when generating the DDL for the column.
String | name The name of the primary key column of the current table.
String | referencedColumnName (Optional) The name of the primary key column of the table being joined to.

name

public abstract String name
The name of the primary key column of the current table.

Defaults to the same name as the primary key column of the primary table of the superclass (JOINED mapping strategy); the same name as the primary key column of the primary table (SecondaryTable mapping); or the same name as the primary key column for the table for the referencing entity (OneToOne mapping)

Default:
""

referencedColumnName

public abstract String referencedColumnName
(Optional) The name of the primary key column of the table being joined to.

Defaults to the same name as the primary key column of the primary table of the superclass (JOINED mapping strategy); the same name as the primary key column of the primary table (SecondaryTable mapping); or the same name as the primary key column for the table for the referencing entity (OneToOne mapping)

Default:
""

columnDefinition

public abstract String columnDefinition
(Optional) The SQL fragment that is used when generating the DDL for the column. This should not be specified for a OneToOne primary key association.

Defaults to the generated SQL to create a column of the inferred type.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PrimaryKeyJoinColumns

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type PrimaryKeyJoinColumns

@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface PrimaryKeyJoinColumns

This annotation groups PrimaryKeyJoinColumn annotations. It is used to map composite foreign keys.

    Example 1: ValuedCustomer subclass

    @Entity
    @Table(name="VCUST")
    @DiscriminatorValue("VCUST")
    @PrimaryKeyJoinColumns({
        @PrimaryKeyJoinColumn(name="CUST_ID",
            referencedColumnName="ID"),
        @PrimaryKeyJoinColumn(name="CUST_TYPE",
            referencedColumnName="TYPE")
    })
    public class ValuedCustomer extends Customer { ... }

Since:
Java Persistence 1.0

Required Element Summary
 PrimaryKeyJoinColumn[] value
One or more PrimaryKeyJoinColumn annotations.

Element Detail

value

public abstract PrimaryKeyJoinColumn[] value
One or more PrimaryKeyJoinColumn annotations.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Query

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence
Interface Query

public interface Query

Interface used to control query execution.

Since:
Java Persistence 1.0

Method Summary
int | executeUpdate() Execute an update or delete statement.
List | getResultList() Execute a SELECT query and return the query results as a List.
Object | getSingleResult() Execute a SELECT query that returns a single result.
Query | setFirstResult(int startPosition) Set the position of the first result to retrieve.
Query | setFlushMode(FlushModeType flushMode) Set the flush mode type to be used for the query execution.
Query | setHint(String hintName, Object value) Set an implementation-specific hint.
Query | setMaxResults(int maxResult) Set the maximum number of results to retrieve.
Query | setParameter(int position, Calendar value, TemporalType temporalType) Bind an instance of java.util.Calendar to a positional parameter.
Query | setParameter(int position, Date value, TemporalType temporalType) Bind an instance of java.util.Date to a positional parameter.
Query | setParameter(int position, Object value) Bind an argument to a positional parameter.
Query | setParameter(String name, Calendar value, TemporalType temporalType) Bind an instance of java.util.Calendar to a named parameter.
Query | setParameter(String name, Date value, TemporalType temporalType) Bind an instance of java.util.Date to a named parameter.
Query | setParameter(String name, Object value) Bind an argument to a named parameter.

Method Detail

getResultList

List getResultList()
Execute a SELECT query and return the query results as a List.

Returns:
a list of the results
Throws:
IllegalStateException - if called for a Java Persistence query language UPDATE or DELETE statement

getSingleResult

Object getSingleResult()
Execute a SELECT query that returns a single result.

Returns:
the result
Throws:
NoResultException - if there is no result
NonUniqueResultException - if more than one result
IllegalStateException - if called for a Java Persistence query language UPDATE or DELETE statement

executeUpdate

int executeUpdate()
Execute an update or delete statement.

Returns:
the number of entities updated or deleted
Throws:
IllegalStateException - if called for a Java Persistence query language SELECT statement
TransactionRequiredException - if there is no transaction

setMaxResults

Query setMaxResults(int maxResult)
Set the maximum number of results to retrieve.

Parameters:
maxResult -
Returns:
the same query instance
Throws:
IllegalArgumentException - if argument is negative

setFirstResult

Query setFirstResult(int startPosition)
Set the position of the first result to retrieve.

Parameters:
startPosition - the start position of the first result, numbered from 0
Returns:
the same query instance
Throws:
IllegalArgumentException - if argument is negative

setHint

Query setHint(String hintName,
              Object value)
Set an implementation-specific hint. If the hint name is not recognized, it is silently ignored.

Parameters:
hintName -
value -
Returns:
the same query instance
Throws:
IllegalArgumentException - if the second argument is not valid for the implementation

setParameter

Query setParameter(String name,
                   Object value)
Bind an argument to a named parameter.

Parameters:
name - the parameter name
value -
Returns:
the same query instance
Throws:
IllegalArgumentException - if parameter name does not correspond to parameter in query string or argument is of incorrect type

setParameter

Query setParameter(String name,
                   Date value,
                   TemporalType temporalType)
Bind an instance of java.util.Date to a named parameter.

Parameters:
name -
value -
temporalType -
Returns:
the same query instance
Throws:
IllegalArgumentException - if parameter name does not correspond to parameter in query string

setParameter

Query setParameter(String name,
                   Calendar value,
                   TemporalType temporalType)
Bind an instance of java.util.Calendar to a named parameter.

Parameters:
name -
value -
temporalType -
Returns:
the same query instance
Throws:
IllegalArgumentException - if parameter name does not correspond to parameter in query string

setParameter

Query setParameter(int position,
                   Object value)
Bind an argument to a positional parameter.

Parameters:
position -
value -
Returns:
the same query instance
Throws:
IllegalArgumentException - if position does not correspond to positional parameter of query or argument is of incorrect type

setParameter

Query setParameter(int position,
                   Date value,
                   TemporalType temporalType)
Bind an instance of java.util.Date to a positional parameter.

Parameters:
position -
value -
temporalType -
Returns:
the same query instance
Throws:
IllegalArgumentException - if position does not correspond to positional parameter of query

setParameter

Query setParameter(int position,
                   Calendar value,
                   TemporalType temporalType)
Bind an instance of java.util.Calendar to a positional parameter.

Parameters:
position -
value -
temporalType -
Returns:
the same query instance
Throws:
IllegalArgumentException - if position does not correspond to positional parameter of query

setFlushMode

Query setFlushMode(FlushModeType flushMode)
Set the flush mode type to be used for the query execution. The flush mode type applies to the query regardless of the flush mode type in use for the entity manager.

Parameters:
flushMode -
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


QueryHint

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type QueryHint

@Target(value={})
@Retention(value=RUNTIME)
public @interface QueryHint

An implementation-specific Query hint.

Since:
Java Persistence 1.0

Required Element Summary
String | name Name of the hint
String | value Value of the hint

Element Detail

name

public abstract String name
Name of the hint

value

public abstract String value
Value of the hint

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RollbackException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence
Class RollbackException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.persistence.PersistenceException
                    extended by  javax.persistence.RollbackException
All Implemented Interfaces:
Serializable
public class RollbackException
extends PersistenceException

Thrown by the persistence provider when the EntityTransaction.commit() fails.

Since:
Java Persistence 1.0
See Also:
EntityTransaction.commit(), Serialized Form

Constructor Summary
RollbackException()
Constructs a new RollbackException exception with null as its detail message.
RollbackException(String message)
Constructs a new RollbackException exception with the specified detail message.
RollbackException(String message, Throwable cause)
Constructs a new RollbackException exception with the specified detail message and cause.
RollbackException(Throwable cause)
Constructs a new RollbackException exception with the specified cause.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RollbackException

public RollbackException()
Constructs a new RollbackException exception with null as its detail message.

RollbackException

public RollbackException(String message)
Constructs a new RollbackException exception with the specified detail message.

Parameters:
message - the detail message.

RollbackException

public RollbackException(String message,
                         Throwable cause)
Constructs a new RollbackException exception with the specified detail message and cause.

Parameters:
message - the detail message.
cause - the cause.

RollbackException

public RollbackException(Throwable cause)
Constructs a new RollbackException exception with the specified cause.

Parameters:
cause - the cause.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SecondaryTable

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type SecondaryTable

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface SecondaryTable

This annotation is used to specify a secondary table for the annotated entity class. Specifying one or more secondary tables indicates that the data for the entity class is stored across multiple tables.

If no SecondaryTable annotation is specified, it is assumed that all persistent fields or properties of the entity are mapped to the primary table. If no primary key join columns are specified, the join columns are assumed to reference the primary key columns of the primary table, and have the same names and types as the referenced primary key columns of the primary table.

 Example 1: Single secondary table with a single primary key column.

    @Entity
    @Table(name="CUSTOMER")
    @SecondaryTable(name="CUST_DETAIL",
        pkJoinColumns=@PrimaryKeyJoinColumn(name="CUST_ID"))
    public class Customer { ... }

    Example 2: Single secondary table with multiple primary key columns.

    @Entity
    @Table(name="CUSTOMER")
    @SecondaryTable(name="CUST_DETAIL",
        pkJoinColumns={
            @PrimaryKeyJoinColumn(name="CUST_ID"),
            @PrimaryKeyJoinColumn(name="CUST_TYPE")})
    public class Customer { ... }

Since:
Java Persistence 1.0

Required Element Summary
 String name
(Required) The name of the table.
Optional Element Summary
String | catalog (Optional) The catalog of the table.
PrimaryKeyJoinColumn[] | pkJoinColumns (Optional) The columns that are used to join with the primary table.
String | schema (Optional) The schema of the table.
UniqueConstraint[] | uniqueConstraints (Optional) Unique constraints that are to be placed on the table.

Element Detail

name

public abstract String name
(Required) The name of the table.

catalog

public abstract String catalog
(Optional) The catalog of the table.

Defaults to the default catalog.

Default:
""

schema

public abstract String schema
(Optional) The schema of the table.

Defaults to the default schema for user.

Default:
""

pkJoinColumns

public abstract PrimaryKeyJoinColumn[] pkJoinColumns
(Optional) The columns that are used to join with the primary table.

Defaults to the column(s) of the same name(s) as the primary key column(s) in the primary table

Default:
{}

uniqueConstraints

public abstract UniqueConstraint[] uniqueConstraints
(Optional) Unique constraints that are to be placed on the table. These are typically only used if table generation is in effect. These constraints apply in addition to any constraints specified by the Column and JoinColumn annotations and constraints entailed by primary key mappings.

Defaults to no additional constraints.

Default:
{}
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SecondaryTables

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type SecondaryTables

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface SecondaryTables

This annotation is used to specify multiple secondary tables for an entity.

    Example 1: Multiple secondary tables assuming primary key columns are named the same in all tables.

    @Entity
    @Table(name="EMPLOYEE")
    @SecondaryTables({
        @SecondaryTable(name="EMP_DETAIL"),
        @SecondaryTable(name="EMP_HIST")
    })
    public class Employee { ... }

    Example 2: Multiple secondary tables with differently named primary key columns.

    @Entity
    @Table(name="EMPLOYEE")
    @SecondaryTables({
        @SecondaryTable(name="EMP_DETAIL",
            pkJoinColumns=@PrimaryKeyJoinColumn(name="EMPL_ID")),
        @SecondaryTable(name="EMP_HIST",
            pkJoinColumns=@PrimaryKeyJoinColumn(name="EMPLOYEE_ID"))
    })
    public class Employee { ... }

Since:
Java Persistence 1.0

Required Element Summary
 SecondaryTable[] value
The secondary tables for an entity.

Element Detail

value

public abstract SecondaryTable[] value
The secondary tables for an entity.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SequenceGenerator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type SequenceGenerator

@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface SequenceGenerator

This annotation defines a primary key generator that may be referenced by name when a generator element is specified for the GeneratedValue annotation. A sequence generator may be specified on the entity class or on the primary key field or property. The scope of the generator name is global to the persistence unit (across all generator types).

   Example:

   @SequenceGenerator(name="EMP_SEQ", allocationSize=25)

Since:
Java Persistence 1.0

Required Element Summary
 String name
(Required) A unique generator name that can be referenced by one or more classes to be the generator for primary key values.
Optional Element Summary
int | allocationSize (Optional) The amount to increment by when allocating sequence numbers from the sequence.
int | initialValue (Optional) The value from which the sequence object is to start generating.
String | sequenceName (Optional) The name of the database sequence object from which to obtain primary key values.

Element Detail

name

public abstract String name
(Required) A unique generator name that can be referenced by one or more classes to be the generator for primary key values.

sequenceName

public abstract String sequenceName
(Optional) The name of the database sequence object from which to obtain primary key values.

Defaults to a provider-chosen value.

Default:
""

initialValue

public abstract int initialValue
(Optional) The value from which the sequence object is to start generating.

Default:
1

allocationSize

public abstract int allocationSize
(Optional) The amount to increment by when allocating sequence numbers from the sequence.

Default:
50
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


spi

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.persistence.spi

The javax.persistence.spi package defines the classes and interfaces that are implemented by the persistence provider and the Java EE container for use by the container, provider, and/or Persistence bootstrap class in deployment and bootstrapping.

See:
Description

Interface Summary
ClassTransformer | A persistence provider supplies an instance of this interface to the PersistenceUnitInfo.addTransformer method.
PersistenceProvider | Interface implemented by a persistence provider.
PersistenceUnitInfo | Interface implemented by the container and used by the persistence provider when creating an EntityManagerFactory.

Enum Summary
PersistenceUnitTransactionType This enum class defines whether the entity managers created by the EntityManagerFactory will be JTA or resource-local entity managers.

Package javax.persistence.spi Description

The javax.persistence.spi package defines the classes and interfaces that are implemented by the persistence provider and the Java EE container for use by the container, provider, and/or Persistence bootstrap class in deployment and bootstrapping.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.persistence.spi Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.persistence.spi

Package Hierarchies:
All Packages

Interface Hierarchy

  • javax.persistence.spi.ClassTransformer
  • javax.persistence.spi.PersistenceProvider
  • javax.persistence.spi.PersistenceUnitInfo

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.persistence.spi.PersistenceUnitTransactionType
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ClassTransformer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.persistence.spi
Interface ClassTransformer

public interface ClassTransformer

A persistence provider supplies an instance of this interface to the PersistenceUnitInfo.addTransformer method. The supplied transformer instance will get called to transform entity class files when they are loaded or redefined. The transformation occurs before the class is defined by the JVM.

Since:
Java Persistence 1.0

Method Summary
 byte[] transform(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
Invoked when a class is being loaded or redefined.

Method Detail

transform

byte[] transform(ClassLoader loader,
                 String className,
                 Class<?> classBeingRedefined,
                 ProtectionDomain protectionDomain,
                 byte[] classfileBuffer)
                 throws IllegalClassFormatException
Invoked when a class is being loaded or redefined. The implementation of this method may transform the supplied class file and return a new replacement class file.

Parameters:
loader - The defining loader of the class to be transformed, may be null if the bootstrap loader
className - The name of the class in the internal form of fully qualified class and interface names
classBeingRedefined - If this is a redefine, the class being redefined, otherwise null
protectionDomain - The protection domain of the class being defined or redefined
classfileBuffer - The input byte buffer in class file format - must not be modified
Returns:
A well-formed class file buffer (the result of the transform), or null if no transform is performed
Throws:
IllegalClassFormatException - If the input does not represent a well-formed class file
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PersistenceProvider

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence.spi
Interface PersistenceProvider

public interface PersistenceProvider

Interface implemented by a persistence provider. The implementation of this interface that is to be used for a given EntityManager is specified in persistence.xml file in the persistence archive. This interface is invoked by the Container when it needs to create an EntityManagerFactory, or by the Persistence class when running outside the Container.

Since:
Java Persistence 1.0

Method Summary
EntityManagerFactory | createContainerEntityManagerFactory(PersistenceUnitInfo info, Map map) Called by the container when an EntityManagerFactory is to be created.
EntityManagerFactory | createEntityManagerFactory(String emName, Map map) Called by Persistence class when an EntityManagerFactory is to be created.

Method Detail

createEntityManagerFactory

EntityManagerFactory createEntityManagerFactory(String emName,
                                                Map map)
Called by Persistence class when an EntityManagerFactory is to be created.

Parameters:
emName - The name of the persistence unit
map - A Map of properties for use by the persistence provider. These properties may be used to override the values of the corresponding elements in the persistence.xml file or specify values for properties not specified in the persistence.xml.
Returns:
EntityManagerFactory for the persistence unit, or null if the provider is not the right provider

createContainerEntityManagerFactory

EntityManagerFactory createContainerEntityManagerFactory(PersistenceUnitInfo info,
                                                         Map map)
Called by the container when an EntityManagerFactory is to be created.

Parameters:
info - Metadata for use by the persistence provider
map - A Map of integration-level properties for use by the persistence provider. Can be null if there is no integration-level property.
Returns:
EntityManagerFactory for the persistence unit specified by the metadata
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PersistenceUnitInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence.spi
Interface PersistenceUnitInfo

public interface PersistenceUnitInfo

Interface implemented by the container and used by the persistence provider when creating an EntityManagerFactory.

Since:
Java Persistence 1.0

Method Summary
void | addTransformer(ClassTransformer transformer) Add a transformer supplied by the provider that will be called for every new class definition or class redefinition that gets loaded by the loader returned by the getClassLoader() method.
boolean | excludeUnlistedClasses() Returns whether classes in the root of the persistence unit that have not been explicitly listed are to be included in the set of managed classes.
ClassLoader | getClassLoader() Returns ClassLoader that the provider may use to load any classes, resources, or open URLs.
List<URL> | getJarFileUrls() Returns a list of URLs for the jar files or exploded jar file directories that the persistence provider must examine for managed classes of the persistence unit.
DataSource | getJtaDataSource() Returns the JTA-enabled data source to be used by the persistence provider.
List<String> | getManagedClassNames() Returns the list of the names of the classes that the persistence provider must add it to its set of managed classes.
List<String> | getMappingFileNames() Returns the list of mapping file names that the persistence provider must load to determine the mappings for the entity classes.
ClassLoader | getNewTempClassLoader() Return a new instance of a ClassLoader that the provider may use to temporarily load any classes, resources, or open URLs.
DataSource | getNonJtaDataSource() Returns the non-JTA-enabled data source to be used by the persistence provider for accessing data outside a JTA transaction.
String | getPersistenceProviderClassName() Returns the fully qualified name of the persistence provider implementation class.
String | getPersistenceUnitName() Returns the name of the persistence unit.
URL | getPersistenceUnitRootUrl() Returns the URL for the jar file or directory that is the root of the persistence unit.
Properties | getProperties() Returns properties object.
PersistenceUnitTransactionType | getTransactionType() Returns the transaction type of the entity managers created by the EntityManagerFactory.

Method Detail

getPersistenceUnitName

String getPersistenceUnitName()
Returns the name of the persistence unit. Corresponds to the name attribute in the persistence.xml file.

Returns:
The name of the persistence unit. Corresponds to the name attribute in the persistence.xml file.

getPersistenceProviderClassName

String getPersistenceProviderClassName()
Returns the fully qualified name of the persistence provider implementation class. Corresponds to the <provider> element in the persistence.xml file.

Returns:
The fully qualified name of the persistence provider implementation class. Corresponds to the <provider> element in the persistence.xml file.

getTransactionType

PersistenceUnitTransactionType getTransactionType()
Returns the transaction type of the entity managers created by the EntityManagerFactory. The transaction type corresponds to the transaction-type attribute in the persistence.xml file.

Returns:
The transaction type of the entity managers created by the EntityManagerFactory. The transaction type corresponds to the transaction-type attribute in the persistence.xml file.

getJtaDataSource

DataSource getJtaDataSource()
Returns the JTA-enabled data source to be used by the persistence provider. The data source corresponds to the <jta-data-source> element in the persistence.xml file or is provided at deployment or by the container.

Returns:
the JTA-enabled data source to be used by the persistence provider. The data source corresponds to the <jta-data-source> element in the persistence.xml file or is provided at deployment or by the container.

getNonJtaDataSource

DataSource getNonJtaDataSource()
Returns the non-JTA-enabled data source to be used by the persistence provider for accessing data outside a JTA transaction. The data source corresponds to the named <non-jta-data-source> element in the persistence.xml file or provided at deployment or by the container.

Returns:
The non-JTA-enabled data source to be used by the persistence provider for accessing data outside a JTA transaction. The data source corresponds to the named <non-jta-data-source> element in the persistence.xml file or provided at deployment or by the container.

getMappingFileNames

List<String> getMappingFileNames()
Returns the list of mapping file names that the persistence provider must load to determine the mappings for the entity classes. The mapping files must be in the standard XML mapping format, be uniquely named and be resource-loadable from the application classpath. This list will not include the orm.xml file if one was specified. Each mapping file name corresponds to a <mapping-file> element in the persistence.xml file.

Returns:
The list of mapping file names that the persistence provider must load to determine the mappings for the entity classes. The mapping files must be in the standard XML mapping format, be uniquely named and be resource-loadable from the application classpath. This list will not include the orm.xml file if one was specified. Each mapping file name corresponds to a <mapping-file> element in the persistence.xml file.

getJarFileUrls

List<URL> getJarFileUrls()
Returns a list of URLs for the jar files or exploded jar file directories that the persistence provider must examine for managed classes of the persistence unit. Each URL corresponds to a named element in the persistence.xml file. A URL will either be a file: URL referring to a jar file or referring to a directory that contains an exploded jar file, or some other URL from which an InputStream in jar format can be obtained.

Returns:
a list of URL objects referring to jar files or directories.

getPersistenceUnitRootUrl

URL getPersistenceUnitRootUrl()
Returns the URL for the jar file or directory that is the root of the persistence unit. (If the persistence unit is rooted in the WEB-INF/classes directory, this will be the URL of that directory.) The URL will either be a file: URL referring to a jar file or referring to a directory that contains an exploded jar file, or some other URL from which an InputStream in jar format can be obtained.

Returns:
a URL referring to a jar file or directory.

getManagedClassNames

List<String> getManagedClassNames()
Returns the list of the names of the classes that the persistence provider must add it to its set of managed classes. Each name corresponds to a named <class> element in the persistence.xml file.

Returns:
The list of the names of the classes that the persistence provider must add it to its set of managed classes. Each name corresponds to a named <class> element in the persistence.xml file.

excludeUnlistedClasses

boolean excludeUnlistedClasses()
Returns whether classes in the root of the persistence unit that have not been explicitly listed are to be included in the set of managed classes. This value corresponds to the <exclude-unlisted-classes> element in the persistence.xml file.

Returns:
Whether classes in the root of the persistence unit that have not been explicitly listed are to be included in the set of managed classes. This value corresponds to the <exclude-unlisted-classes> element in the persistence.xml file.

getProperties

Properties getProperties()
Returns properties object. Each property corresponds to a <property> element in the persistence.xml file

Returns:
Properties object. Each property corresponds to a <property> element in the persistence.xml file

getClassLoader

ClassLoader getClassLoader()
Returns ClassLoader that the provider may use to load any classes, resources, or open URLs.

Returns:
ClassLoader that the provider may use to load any classes, resources, or open URLs.

addTransformer

void addTransformer(ClassTransformer transformer)
Add a transformer supplied by the provider that will be called for every new class definition or class redefinition that gets loaded by the loader returned by the getClassLoader() method. The transformer has no effect on the result returned by the getNewTempClassLoader() method. Classes are only transformed once within the same classloading scope, regardless of how many persistence units they may be a part of.

Parameters:
transformer - A provider-supplied transformer that the Container invokes at class-(re)definition time

getNewTempClassLoader

ClassLoader getNewTempClassLoader()
Return a new instance of a ClassLoader that the provider may use to temporarily load any classes, resources, or open URLs. The scope and classpath of this loader is exactly the same as that of the loader returned by getClassLoader(). None of the classes loaded by this class loader will be visible to application components. The provider may only use this ClassLoader within the scope of the PersistenceProvider.createContainerEntityManagerFactory(javax.persistence.spi.PersistenceUnitInfo, java.util.Map) call.

Returns:
Temporary ClassLoader with same visibility as current loader
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PersistenceUnitTransactionType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.persistence.spi
Enum PersistenceUnitTransactionType

java.lang.Object
    extended by  java.lang.Enum<PersistenceUnitTransactionType>
        extended by  javax.persistence.spi.PersistenceUnitTransactionType
All Implemented Interfaces:
Serializable, Comparable<PersistenceUnitTransactionType>
public enum PersistenceUnitTransactionType
extends Enum<PersistenceUnitTransactionType>

This enum class defines whether the entity managers created by the EntityManagerFactory will be JTA or resource-local entity managers.

Since:
Java Persistence 1.0

Enum Constant Summary
JTA
JTA entity manager
RESOURCE_LOCAL
resource-local entity manager
Method Summary
static PersistenceUnitTransactionType | valueOf(String name) Returns the enum constant of this type with the specified name.
static PersistenceUnitTransactionType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

JTA

public static final PersistenceUnitTransactionType JTA
JTA entity manager

RESOURCE_LOCAL

public static final PersistenceUnitTransactionType RESOURCE_LOCAL
resource-local entity manager

Method Detail

values

public static final PersistenceUnitTransactionType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(PersistenceUnitTransactionType c : PersistenceUnitTransactionType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static PersistenceUnitTransactionType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SqlResultSetMapping

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type SqlResultSetMapping

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface SqlResultSetMapping

This annotation is used to specify the mapping of the result of a native SQL query.

    Example:

    Query q = em.createNativeQuery(
        "SELECT o.id AS order_id, " +
            "o.quantity AS order_quantity, " +
            "o.item AS order_item, " +
            "i.name AS item_name, " +
        "FROM Order o, Item i " +
        "WHERE (order_quantity > 25) AND (order_item = i.id)",
    "OrderResults");

    @SqlResultSetMapping(name="OrderResults",
        entities={
            @EntityResult(entityClass=com.acme.Order.class, fields={
                @FieldResult(name="id", column="order_id"),
                @FieldResult(name="quantity", column="order_quantity"),
                @FieldResult(name="item", column="order_item")})},
        columns={
            @ColumnResult(name="item_name")}
    )

Since:
Java Persistence 1.0

Required Element Summary
 String name
The name given to the result set mapping, and used to refer to it in the methods of the Query API.
Optional Element Summary
ColumnResult[] | columns Specifies the result set mapping to scalar values.
EntityResult[] | entities Specifies the result set mapping to entities.

Element Detail

name

public abstract String name
The name given to the result set mapping, and used to refer to it in the methods of the Query API.

entities

public abstract EntityResult[] entities
Specifies the result set mapping to entities.

Default:
{}

columns

public abstract ColumnResult[] columns
Specifies the result set mapping to scalar values.

Default:
{}
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SqlResultSetMappings

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type SqlResultSetMappings

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface SqlResultSetMappings

This annotation is used to define one or more SqlResultSetMapping.

Since:
Java Persistence 1.0

Required Element Summary
 SqlResultSetMapping[] value
One or more SqlResultSetMapping.

Element Detail

value

public abstract SqlResultSetMapping[] value
One or more SqlResultSetMapping.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Table

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type Table

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Table

This annotation specifies the primary table for the annotated entity. Additional tables may be specified using SecondaryTable or SecondaryTables annotation.

If no Table annotation is specified for an entity class, the default values apply.

    Example:

    @Entity
    @Table(name="CUST", schema="RECORDS")
    public class Customer { ... }

Since:
Java Persistence 1.0

Optional Element Summary
String | catalog (Optional) The catalog of the table.
String | name (Optional) The name of the table.
String | schema (Optional) The schema of the table.
UniqueConstraint[] | uniqueConstraints (Optional) Unique constraints that are to be placed on the table.

name

public abstract String name
(Optional) The name of the table.

Defaults to the entity name.

Default:
""

catalog

public abstract String catalog
(Optional) The catalog of the table.

Defaults to the default catalog.

Default:
""

schema

public abstract String schema
(Optional) The schema of the table.

Defaults to the default schema for user.

Default:
""

uniqueConstraints

public abstract UniqueConstraint[] uniqueConstraints
(Optional) Unique constraints that are to be placed on the table. These are only used if table generation is in effect. These constraints apply in addition to any constraints specified by the Column and JoinColumn annotations and constraints entailed by primary key mappings.

Defaults to no additional constraints.

Default:
{}
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TableGenerator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type TableGenerator

@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface TableGenerator

This annotation defines a primary key generator that may be referenced by name when a generator element is specified for the GeneratedValue annotation. A table generator may be specified on the entity class or on the primary key field or property. The scope of the generator name is global to the persistence unit (across all generator types).

    Example 1:

    @Entity public class Employee {
        ...
        @TableGenerator(
            name="empGen",
            table="ID_GEN",
            pkColumnName="GEN_KEY",
            valueColumnName="GEN_VALUE",
            pkColumnValue="EMP_ID",
            allocationSize=1)
        @Id
        @GeneratedValue(strategy=TABLE, generator="empGen")
        public int id;
        ...
    }

    Example 2:

    @Entity public class Address {
        ...
        @TableGenerator(
            name="addressGen",
            table="ID_GEN",
            pkColumnName="GEN_KEY",
            valueColumnName="GEN_VALUE",
            pkColumnValue="ADDR_ID")
        @Id
        @GeneratedValue(strategy=TABLE, generator="addressGen")
        public int id;
        ...
    }

Since:
Java Persistence 1.0

Required Element Summary
 String name
(Required) A unique generator name that can be referenced by one or more classes to be the generator for id values.
Optional Element Summary
int | allocationSize (Optional) The amount to increment by when allocating id numbers from the generator.
String | catalog (Optional) The catalog of the table.
int | initialValue (Optional) The initial value to be used when allocating id numbers from the generator.
String | pkColumnName (Optional) Name of the primary key column in the table.
String | pkColumnValue (Optional) The primary key value in the generator table that distinguishes this set of generated values from others that may be stored in the table.
String | schema (Optional) The schema of the table.
String | table (Optional) Name of table that stores the generated id values.
UniqueConstraint[] | uniqueConstraints (Optional) Unique constraints that are to be placed on the table.
String | valueColumnName (Optional) Name of the column that stores the last value generated.

Element Detail

name

public abstract String name
(Required) A unique generator name that can be referenced by one or more classes to be the generator for id values.

table

public abstract String table
(Optional) Name of table that stores the generated id values.

Defaults to a name chosen by persistence provider.

Default:
""

catalog

public abstract String catalog
(Optional) The catalog of the table.

Defaults to the default catalog.

Default:
""

schema

public abstract String schema
(Optional) The schema of the table.

Defaults to the default schema for user.

Default:
""

pkColumnName

public abstract String pkColumnName
(Optional) Name of the primary key column in the table.

Defaults to a provider-chosen name.

Default:
""

valueColumnName

public abstract String valueColumnName
(Optional) Name of the column that stores the last value generated.

Defaults to a provider-chosen name.

Default:
""

pkColumnValue

public abstract String pkColumnValue
(Optional) The primary key value in the generator table that distinguishes this set of generated values from others that may be stored in the table.

Defaults to a provider-chosen value to store in the primary key column of the generator table

Default:
""

initialValue

public abstract int initialValue
(Optional) The initial value to be used when allocating id numbers from the generator.

Default:
0

allocationSize

public abstract int allocationSize
(Optional) The amount to increment by when allocating id numbers from the generator.

Default:
50

uniqueConstraints

public abstract UniqueConstraint[] uniqueConstraints
(Optional) Unique constraints that are to be placed on the table. These are only used if table generation is in effect. These constraints apply in addition to primary key constraints.

Defaults to no additional constraints.

Default:
{}
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Temporal

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type Temporal

@Target(value={METHOD,FIELD})
@Retention(value=RUNTIME)
public @interface Temporal

This annotation must be specified for persistent fields or properties of type Date and Calendar. It may only be specified for fields or properties of these types.

The Temporal annotation may be used in conjunction with the Basic annotation.

     Example:

     @Temporal(DATE)
     protected java.util.Date endDate;

Since:
Java Persistence 1.0

Required Element Summary
 TemporalType value
The type used in mapping java.util.Date or java.util.Calendar.

Element Detail

value

public abstract TemporalType value
The type used in mapping java.util.Date or java.util.Calendar.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TemporalType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.persistence
Enum TemporalType

java.lang.Object
    extended by  java.lang.Enum<TemporalType>
        extended by  javax.persistence.TemporalType
All Implemented Interfaces:
Serializable, Comparable<TemporalType>
public enum TemporalType
extends Enum<TemporalType>

Type used to indicate a specific mapping of Date or Calendar.

Since:
Java Persistence 1.0

Enum Constant Summary
DATE
Map as java.sql.Date
TIME
Map as java.sql.Time
TIMESTAMP
Map as java.sql.Timestamp
Method Summary
static TemporalType | valueOf(String name) Returns the enum constant of this type with the specified name.
static TemporalType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

DATE

public static final TemporalType DATE
Map as java.sql.Date

TIME

public static final TemporalType TIME
Map as java.sql.Time

TIMESTAMP

public static final TemporalType TIMESTAMP
Map as java.sql.Timestamp

Method Detail

values

public static final TemporalType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(TemporalType c : TemporalType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static TemporalType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransactionRequiredException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.persistence
Class TransactionRequiredException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.persistence.PersistenceException
                    extended by  javax.persistence.TransactionRequiredException
All Implemented Interfaces:
Serializable
public class TransactionRequiredException
extends PersistenceException

Thrown by the persistence provider when a transaction is required but is not active.

Since:
Java Persistence 1.0
See Also:
Serialized Form

Constructor Summary
TransactionRequiredException()
Constructs a new TransactionRequiredException exception with null as its detail message.
TransactionRequiredException(String message)
Constructs a new TransactionRequiredException exception with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionRequiredException

public TransactionRequiredException()
Constructs a new TransactionRequiredException exception with null as its detail message.

TransactionRequiredException

public TransactionRequiredException(String message)
Constructs a new TransactionRequiredException exception with the specified detail message.

Parameters:
message - the detail message.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UniqueConstraint

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.persistence
Annotation Type UniqueConstraint

@Target(value={})
@Retention(value=RUNTIME)
public @interface UniqueConstraint

This annotation is used to specify that a unique constraint is to be included in the generated DDL for a primary or secondary table.

    Example:
    @Entity
    @Table(
        name="EMPLOYEE",
        uniqueConstraints=
            @UniqueConstraint(columnNames={"EMP_ID", "EMP_NAME"})
    )
    public class Employee { ... }

Since:
Java Persistence 1.0

Required Element Summary
 String[] columnNames
(Required) An array of the column names that make up the constraint.

Element Detail

columnNames

public abstract String[] columnNames
(Required) An array of the column names that make up the constraint.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


resource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.resource

The javax.resource package is the top-level package for the J2EE Connector API specification.

See:
Description

Interface Summary
Referenceable The Referenceable interface extends the javax.naming.Referenceable interface.

Exception Summary
NotSupportedException | A NotSupportedException is thrown to indicate that callee (resource adapter or application server for system contracts) cannot execute an operation because the operation is not a supported feature.
ResourceException | This is the root interface of the exception hierarchy defined for the Connector architecture.

Package javax.resource Description

The javax.resource package is the top-level package for the J2EE Connector API specification.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.resource Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.resource

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.NotSupportedException

Interface Hierarchy

  • javax.naming.Referenceable
    • javax.resource.Referenceable
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


cci

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.resource.cci

The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

See:
Description

Interface Summary
Connection | A Connection represents an application-level handle that is used by a client to access the underlying physical connection.
ConnectionFactory | ConnectionFactory provides an interface for getting connection to an EIS instance.
ConnectionMetaData | The interface ConnectionMetaData provides information about an EIS instance connected through a Connection instance.
ConnectionSpec | ConnectionSpec is used by an application component to pass connection request-specific properties to the ConnectionFactory.
IndexedRecord | IndexedRecord represents an ordered collection of record elements based on the java.util.List interface.
Interaction | The javax.resource.cci.Interaction enables a component to execute EIS functions.
InteractionSpec | An InteractionSpec holds properties for driving an Interaction with an EIS instance.
LocalTransaction | The LocalTransaction defines a transaction demarcation interface for resource manager local transactions.
MappedRecord | The interface javax.resource.cci.MappedRecord is used for key-value map based representation of record elements.
MessageListener | This serves as a request-response message listener type that message endpoints (message-driven beans) may implement.
Record | The javax.resource.cci.Record interface is the base interface for the representation of an input or output to the execute methods defined on an Interaction.
RecordFactory | The RecordFactory interface is used for creating MappedRecord and IndexedRecord instances.
ResourceAdapterMetaData | The interface javax.resource.cci.ResourceAdapterMetaData provides information about capabilities of a resource adapter implementation.
ResultSet | A ResultSet represents tabular data that is retrieved from an EIS instance by the execution of an Interaction..
ResultSetInfo | The interface javax.resource.cci.ResultSetInfo provides information on the support provided for ResultSet by a connected EIS instance.
Streamable | Streamable interface enables a resource adapter to extract data from an input Record or set data into an output Record as a stream of bytes.

Exception Summary
ResourceWarning A ResourceWarning provides information on warnings related to execution of an interaction with an EIS.

Package javax.resource.cci Description

The javax.resource.cci package contains API specification for the Common Client Interface (CCI).

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionSpec

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface ConnectionSpec

public interface ConnectionSpec

ConnectionSpec is used by an application component to pass connection request-specific properties to the ConnectionFactory. getConnection method.

It is recommended that the ConnectionSpec interface be implemented as a JavaBean to support tools. The properties on the ConnectionSpec implementation class must be defined through the getter and setter methods pattern.

The CCI specification defines a set of standard properties for an ConnectionSpec. The properties are defined either on a derived interface or an implementation class of an empty ConnectionSpec interface. In addition, a resource adapter may define additional properties specific to its underlying EIS.

Version:
1.0 Public Draft 1
Author:
Rahul Sharma
See Also:
ConnectionFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


IndexedRecord

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface IndexedRecord

All Superinterfaces:
Cloneable, Collection, Iterable, List, Record, Serializable
public interface IndexedRecord
extends Record, List, Serializable

IndexedRecord represents an ordered collection of record elements based on the java.util.List interface. This interface allows a client to access elements by their integer index (position in the list) and search for elements in the List.

Since:
0.8
Author:
Rahul Sharma

Method Summary
Methods inherited from interface javax.resource.cci.Record
clone, equals, getRecordName, getRecordShortDescription, hashCode, setRecordName, setRecordShortDescription
Methods inherited from interface java.util.List
add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, remove, remove, removeAll, retainAll, set, size, subList, toArray, toArray

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.resource.cci Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.resource.cci

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.cci.ResourceWarning

Interface Hierarchy

  • java.lang.Cloneable
    • javax.resource.cci.Record (also extends java.io.Serializable)
      • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, java.io.Serializable)
      • javax.resource.cci.MappedRecord (also extends java.util.Map<K,V>, java.io.Serializable)
      • javax.resource.cci.ResultSet (also extends java.sql.ResultSet)
  • javax.resource.cci.Connection
  • javax.resource.cci.ConnectionMetaData
  • javax.resource.cci.ConnectionSpec
  • javax.resource.cci.Interaction
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.util.List<E>
        • javax.resource.cci.IndexedRecord (also extends javax.resource.cci.Record, java.io.Serializable)
  • javax.resource.cci.LocalTransaction
  • java.util.Map<K,V>
    • javax.resource.cci.MappedRecord (also extends javax.resource.cci.Record, java.io.Serializable)
  • javax.resource.cci.MessageListener
  • javax.resource.cci.RecordFactory
  • javax.naming.Referenceable
    • javax.resource.Referenceable
      • javax.resource.cci.ConnectionFactory (also extends java.io.Serializable)
  • javax.resource.cci.ResourceAdapterMetaData
  • java.sql.ResultSet
    • javax.resource.cci.ResultSet (also extends javax.resource.cci.Record)
  • javax.resource.cci.ResultSetInfo
  • java.io.Serializable
    • javax.resource.cci.ConnectionFactory (also extends javax.resource.Referenceable)
    • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, javax.resource.cci.Record)
    • javax.resource.cci.InteractionSpec
    • javax.resource.cci.MappedRecord (also extends java.util.Map<K,V>, javax.resource.cci.Record)
    • javax.resource.cci.Record (also extends java.lang.Cloneable)
      • javax.resource.cci.IndexedRecord (also extends java.util.List<E>, java.io.Serializable)
      • javax.resource.cci.MappedRecord (also extends java.util.Map<K,V>, java.io.Serializable)
      • javax.resource.cci.ResultSet (also extends java.sql.ResultSet)
  • javax.resource.cci.Streamable
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResultSet

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface ResultSet

All Superinterfaces:
Cloneable, Record, ResultSet, Serializable
public interface ResultSet
extends Record, ResultSet

A ResultSet represents tabular data that is retrieved from an EIS instance by the execution of an Interaction.. The CCI ResultSet is based on the JDBC ResultSet.

Refer the CCI specification in Connectors 1.0 for detailed requirements on the implementation of a CCI ResultSet.

Since:
0.8
Author:
Rahul Sharma
See Also:
ResultSet

Field Summary
Fields inherited from interface java.sql.ResultSet
CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE
Method Summary
Methods inherited from interface javax.resource.cci.Record
clone, equals, getRecordName, getRecordShortDescription, hashCode, setRecordName, setRecordShortDescription
Methods inherited from interface java.sql.ResultSet
absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getInt, getInt, getLong, getLong, getMetaData, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getShort, getShort, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, next, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateShort, updateShort, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Connection

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface Connection

public interface Connection

A Connection represents an application-level handle that is used by a client to access the underlying physical connection. The actual physical connection associated with a Connection instance is represented by a ManagedConnection instance.

A client gets a Connection instance by using the getConnection method on a ConnectionFactory instance. A connection can be associated with zero or more Interaction instances.

Version:
0.8
Author:
Rahul Sharma
See Also:
ConnectionFactory, Interaction

Method Summary
void | close() Initiates close of the connection handle at the application level.
Interaction | createInteraction() Creates an Interaction associated with this Connection.
LocalTransaction | getLocalTransaction() Returns an LocalTransaction instance that enables a component to demarcate resource manager local transactions on the Connection.
ConnectionMetaData | getMetaData() Gets the information on the underlying EIS instance represented through an active connection.
ResultSetInfo | getResultSetInfo() Gets the information on the ResultSet functionality supported by a connected EIS instance.

Method Detail

createInteraction

Interaction createInteraction()
                              throws ResourceException
Creates an Interaction associated with this Connection. An Interaction enables an application to execute EIS functions.

Returns:
Interaction instance
Throws:
ResourceException - Failed to create an Interaction

getLocalTransaction

LocalTransaction getLocalTransaction()
                                     throws ResourceException
Returns an LocalTransaction instance that enables a component to demarcate resource manager local transactions on the Connection. If a resource adapter does not allow a component to demarcate local transactions on an Connection using LocalTransaction interface, then the method getLocalTransaction should throw a NotSupportedException.

Returns:
LocalTransaction instance
Throws:
ResourceException - Failed to return a LocalTransaction instance because of a resource adapter error
NotSupportedException - Demarcation of Resource manager local transactions is not supported on this Connection
See Also:
LocalTransaction

getMetaData

ConnectionMetaData getMetaData()
                               throws ResourceException
Gets the information on the underlying EIS instance represented through an active connection.

Returns:
ConnectionMetaData instance representing information about the EIS instance
Throws:
ResourceException - Failed to get information about the connected EIS instance. Error can be resource adapter-internal, EIS-specific or communication related.

getResultSetInfo

ResultSetInfo getResultSetInfo()
                               throws ResourceException
Gets the information on the ResultSet functionality supported by a connected EIS instance.

Returns:
ResultSetInfo instance
Throws:
ResourceException - Failed to get ResultSet related information
NotSupportedException - ResultSet functionality is not supported

close

void close()
           throws ResourceException
Initiates close of the connection handle at the application level. A client should not use a closed connection to interact with an EIS.

Throws:
ResourceException - Exception thrown if close on a connection handle fails.

Any invalid connection close invocation--example, calling close on a connection handle that is already closed--should also throw this exception.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface ConnectionFactory

All Superinterfaces:
Referenceable, Serializable
public interface ConnectionFactory
extends Serializable, Referenceable

ConnectionFactory provides an interface for getting connection to an EIS instance. An implementation of ConnectionFactory interface is provided by a resource adapter.

Application code looks up a ConnectionFactory instance from JNDI namespace and uses it to get EIS connections.

An implementation class for ConnectionFactory is required to implement java.io.Serializable and javax.resource.Referenceableinterfaces to support JNDI registration.

Version:
0.8
Author:
Rahul Sharma
See Also:
Connection, Referenceable

Method Summary
Connection | getConnection() Gets a connection to an EIS instance.
Connection | getConnection(ConnectionSpec properties) Gets a connection to an EIS instance.
ResourceAdapterMetaData | getMetaData() Gets metadata for the Resource Adapter.
RecordFactory | getRecordFactory() Gets a RecordFactory instance.
Methods inherited from interface javax.resource.Referenceable
setReference
Methods inherited from interface javax.naming.Referenceable
getReference

Method Detail

getConnection

Connection getConnection()
                         throws ResourceException
Gets a connection to an EIS instance. This getConnection variant should be used when a component wants the container to manage EIS sign-on. This case is termed container-managed sign-on. The component does not pass any security information.

Returns:
Connection instance
Throws:
ResourceException - Failed to get a connection to the EIS instance. Examples of error cases are:
  • Invalid configuration of ManagedConnectionFactory-- example: invalid server name
  • Application server-internal error--example: connection pool related error
  • Communication error
  • EIS-specific error--example: EIS not active
  • Resource adapter-internal error
  • Security related error; example: invalid user
  • Failure to allocate system resources

getConnection

Connection getConnection(ConnectionSpec properties)
                         throws ResourceException
Gets a connection to an EIS instance. A component should use the getConnection variant with javax.resource.cci.ConnectionSpec parameter, if it needs to pass any resource adapter specific security information and connection parameters. In the component- managed sign-on case, an application component passes security information (example: username, password) through the ConnectionSpec instance.

It is important to note that the properties passed through the getConnection method should be client-specific (example: username, password, language) and not related to the configuration of a target EIS instance (example: port number, server name). The ManagedConnectionFactory instance is configured with complete set of properties required for the creation of a connection to an EIS instance.

Parameters:
properties - Connection parameters and security information specified as ConnectionSpec instance
Returns:
Connection instance
Throws:
ResourceException - Failed to get a connection to the EIS instance. Examples of error cases are:
  • Invalid specification of input parameters
  • Invalid configuration of ManagedConnectionFactory-- example: invalid server name
  • Application server-internal error--example: connection pool related error
  • Communication error
  • EIS-specific error--example: EIS not active
  • Resource adapter-internal error
  • Security related error; example: invalid user
  • Failure to allocate system resources
See Also:
ConnectionSpec

getRecordFactory

RecordFactory getRecordFactory()
                               throws ResourceException
Gets a RecordFactory instance. The RecordFactory is used for the creation of generic Record instances.

Returns:
RecordFactory RecordFactory instance
Throws:
ResourceException - Failed to create a RecordFactory
NotSupportedException - Operation not supported

getMetaData

ResourceAdapterMetaData getMetaData()
                                    throws ResourceException
Gets metadata for the Resource Adapter. Note that the metadata information is about the ResourceAdapter and not the EIS instance. An invocation of this method does not require that an active connection to an EIS instance should have been established.

Returns:
ResourceAdapterMetaData instance
Throws:
ResourceException - Failed to get metadata information about the resource adapter
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionMetaData

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface ConnectionMetaData

public interface ConnectionMetaData

The interface ConnectionMetaData provides information about an EIS instance connected through a Connection instance. A component calls the method Connection.getMetaData to get a ConnectionMetaData instance.

Version:
0.8
Author:
Rahul Sharma
See Also:
Connection, ResultSetInfo

Method Summary
String | getEISProductName() Returns product name of the underlying EIS instance connected through the Connection that produced this metadata.
String | getEISProductVersion() Returns product version of the underlying EIS instance.
String | getUserName() Returns the user name for an active connection as known to the underlying EIS instance.

Method Detail

getEISProductName

String getEISProductName()
                         throws ResourceException
Returns product name of the underlying EIS instance connected through the Connection that produced this metadata.

Returns:
Product name of the EIS instance
Throws:
ResourceException - Failed to get the information for the EIS instance

getEISProductVersion

String getEISProductVersion()
                            throws ResourceException
Returns product version of the underlying EIS instance.

Returns:
Product version of an EIS instance.
Throws:
ResourceException - Failed to get the information for the EIS instance

getUserName

String getUserName()
                   throws ResourceException
Returns the user name for an active connection as known to the underlying EIS instance. The name corresponds the resource principal under whose security context a connection to the EIS instance has been established.

Returns:
String representing the user name
Throws:
ResourceException - Failed to get the information for the EIS instance
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Interaction

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface Interaction

public interface Interaction

The javax.resource.cci.Interaction enables a component to execute EIS functions. An Interaction instance supports the following ways of interacting with an EIS instance:

  • execute method that takes an input Record, output Record and an InteractionSpec. This method executes the EIS function represented by the InteractionSpec and updates the output Record
  • execute method that takes an input Record and an InteractionSpec. This method implementation executes the EIS function represented by the InteractionSpec and produces the output Record as a return value.

An Interaction instance is created from a Connection and is required to maintain its association with the Connection instance. The close method releases all resources maintained by the resource adapter for the Interaction. The close of an Interaction instance should not close the associated Connection instance.

Since:
0.8
Version:
0.8
Author:
Rahul Sharma
See Also:
ResultSet

Method Summary
void | clearWarnings() Clears all the warning reported by this Interaction instance.
void | close() Closes the current Interaction and release all the resources held for this instance by the resource adapter.
Record | execute(InteractionSpec ispec, Record input) Executes an interaction represented by the InteractionSpec.
boolean | execute(InteractionSpec ispec, Record input, Record output) Executes an interaction represented by the InteractionSpec.
Connection | getConnection() Gets the Connection associated with the Interaction.
ResourceWarning | getWarnings() Gets the first ResourceWarning from the chain of warnings associated with this Interaction instance.

Method Detail

close

void close()
           throws ResourceException
Closes the current Interaction and release all the resources held for this instance by the resource adapter. The close of an Interaction instance does not close the associated Connection instance. It is recommended that Interaction instances be closed explicitly to free any held resources.

Throws:
ResourceException - Failed to close the Interaction instance. Invoking close on an already closed Interaction should also throw this exception.

getConnection

Connection getConnection()
Gets the Connection associated with the Interaction.

Returns:
Connection instance associated with the Interaction

execute

boolean execute(InteractionSpec ispec,
                Record input,
                Record output)
                throws ResourceException
Executes an interaction represented by the InteractionSpec. This form of invocation takes an input Record and updates the output Record.

Parameters:
ispec - InteractionSpec representing a target EIS data/function module
input - Input Record
output - Output Record
Returns:
true if execution of the EIS function has been successful and output Record has been updated; false otherwise
Throws:
ResourceException - Exception if execute operation fails. Examples of error cases are:
  • Resource adapter internal, EIS-specific or communication error
  • Invalid specification of an InteractionSpec, input or output record structure
  • Errors in use of input or output Record
  • Invalid connection associated with this Interaction
NotSupportedException - Operation not supported

execute

Record execute(InteractionSpec ispec,
               Record input)
               throws ResourceException
Executes an interaction represented by the InteractionSpec. This form of invocation takes an input Record and returns an output Record if the execution of the Interaction has been successfull.

Parameters:
ispec - InteractionSpec representing a target EIS data/function module
input - Input Record
Returns:
output Record if execution of the EIS function has been successful; null otherwise
Throws:
ResourceException - Exception if execute operation fails. Examples of error cases are:
  • Resource adapter internal, EIS-specific or communication error
  • Invalid specification of an InteractionSpec or input record structure
  • Errors in use of input Record or creation of an output Record
  • Invalid connection associated with this Interaction
NotSupportedException - Operation not supported

getWarnings

ResourceWarning getWarnings()
                            throws ResourceException
Gets the first ResourceWarning from the chain of warnings associated with this Interaction instance.

Returns:
ResourceWarning at top of the warning chain
Throws:
ResourceException - Failed to get ResourceWarnings associated with Interaction

clearWarnings

void clearWarnings()
                   throws ResourceException
Clears all the warning reported by this Interaction instance. After a call to this method, the method getWarnings will return null until a new warning is reported for this Interaction.

Throws:
ResourceException - Failed to clear ResourceWarnings associated with Interaction
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InteractionSpec

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface InteractionSpec

All Superinterfaces:
Serializable
public interface InteractionSpec
extends Serializable

An InteractionSpec holds properties for driving an Interaction with an EIS instance. An InteractionSpec is used by an Interaction to execute the specified function on an underlying EIS.

The CCI specification defines a set of standard properties for an InteractionSpec. An InteractionSpec implementation is not required to support a standard property if that property does not apply to its underlying EIS.

The InteractionSpec implementation class must provide getter and setter methods for each of its supported properties. The getter and setter methods convention should be based on the Java Beans design pattern.

The standard properties are as follows:

  • FunctionName: name of an EIS function
  • InteractionVerb: mode of interaction with an EIS instance: SYNC_SEND, SYNC_SEND_RECEIVE, SYNC_RECEIVE
  • ExecutionTimeout: the number of milliseconds an Interaction will wait for an EIS to execute the specified function

The following standard properties are used to give hints to an Interaction instance about the ResultSet requirements:

  • FetchSize
  • FetchDirection
  • MaxFieldSize
  • ResultSetType
  • ResultSetConcurrency

A CCI implementation can provide additional properties beyond that described in the InteractionSpec interface. Note that the format and type of the additional properties is specific to an EIS and is outside the scope of the CCI specification.

It is required that the InteractionSpec interface be implemented as a JavaBean for the toolability support. The properties on the InteractionSpec implementation class should be defined through the getter and setter methods pattern. An implementation class for InteractionSpec interface is required to implement the java.io.Serializable interface.

Since:
0.8
Version:
0.8
Author:
Rahul Sharma
See Also:
Interaction

Field Summary
static int | SYNC_RECEIVE The execution of an Interaction results in a synchronous receive of an output Record.
static int | SYNC_SEND Interaction Verb type: The execution of an Interaction does only a send to the target EIS instance.
static int | SYNC_SEND_RECEIVE Interaction Verb type: The execution of an Interaction sends a request to the EIS instance and receives response synchronously.

Field Detail

SYNC_SEND

static final int SYNC_SEND
Interaction Verb type: The execution of an Interaction does only a send to the target EIS instance. The input record is sent to the EIS instance without any synchronous response in terms of an output Record or ResultSet.

See Also:
Constant Field Values

SYNC_SEND_RECEIVE

static final int SYNC_SEND_RECEIVE
Interaction Verb type: The execution of an Interaction sends a request to the EIS instance and receives response synchronously. The input record is sent to the EIS instance with the output received either as Record or CCIResultSet.

See Also:
Constant Field Values

SYNC_RECEIVE

static final int SYNC_RECEIVE
The execution of an Interaction results in a synchronous receive of an output Record. An example is: a session bean gets a method invocation and it uses this SEND_RECEIVE form of interaction to retrieve messages that have been delivered to a message queue.

See Also:
Constant Field Values
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LocalTransaction

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface LocalTransaction

public interface LocalTransaction

The LocalTransaction defines a transaction demarcation interface for resource manager local transactions. Note that this interface is used for application level local transaction demarcation. The system contract level LocalTransaction interface (as defined in the javax.resource.spi package) is used by the container for local transaction management.

A local transaction is managed internal to a resource manager. There is no external transaction manager involved in the coordination of such transactions.

A CCI implementation can (but is not required to) implement the LocalTransaction interface. If the LocalTransaction interface is supported by a CCI implementation, then the method Connection.getLocalTransaction should return a LocalTransaction instance. A component can then use the returned LocalTransaction to demarcate a resource manager local transaction (associated with the Connection instance) on the underlying EIS instance.

Since:
0.8
Author:
Rahul Sharma
See Also:
Connection

Method Summary
void | begin() Begins a local transaction on an EIS instance.
void | commit() Commits the current local transaction and release all locks held by the underlying EIS instance.
void | rollback() Rollbacks the current resource manager local transaction.

Method Detail

begin

void begin()
           throws ResourceException
Begins a local transaction on an EIS instance.

Throws:
ResourceException - Failed to begin a local transaction. Examples of error cases are:
  • Resource adapter internal or EIS-specific error
  • Connection is already participating in a local or JTA transaction

commit

void commit()
            throws ResourceException
Commits the current local transaction and release all locks held by the underlying EIS instance.

Throws:
ResourceException - Failed to commit a local transaction. Examples of error cases are:
  • Resource adapter internal or EIS-specific error
  • Violation of integrity constraints, deadlock detection, communication failure during transaction completion, or any retry requirement
  • Connection is participating in an active JTA transaction
  • Invalid transaction context; commit operation invoked without an active transaction context

rollback

void rollback()
              throws ResourceException
Rollbacks the current resource manager local transaction.

Throws:
ResourceException - Failed to rollback a local transaction. Examples of error cases are:
  • Resource adapter internal or EIS-specific error
  • Connection is participating in an active JTA transaction
  • Invalid transaction context; rollback operation invoked without an active transaction context
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MappedRecord

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface MappedRecord

All Superinterfaces:
Cloneable, Map, Record, Serializable
public interface MappedRecord
extends Record, Map, Serializable

The interface javax.resource.cci.MappedRecord is used for key-value map based representation of record elements. The MappedRecord interface extends both Record and java.util.Mapinterfaces.

Version:
0.8
Author:
Rahul Sharma

Nested Class Summary
Nested classes/interfaces inherited from interface java.util.Map
Map.Entry<K,V>
Method Summary
Methods inherited from interface javax.resource.cci.Record
clone, equals, getRecordName, getRecordShortDescription, hashCode, setRecordName, setRecordShortDescription
Methods inherited from interface java.util.Map
clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface MessageListener

public interface MessageListener

This serves as a request-response message listener type that message endpoints (message-driven beans) may implement. This allows an EIS to communicate with an endpoint using a request-response style.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 Record onMessage(Record inputData)
This method allows an EIS to call a message endpoint using a request-response style communication.

Method Detail

onMessage

Record onMessage(Record inputData)
                 throws ResourceException
This method allows an EIS to call a message endpoint using a request-response style communication.

Parameters:
inputData - a Record instance.
Returns:
a Record instance or null.
Throws:
ResourceException - indicates an exceptional condition.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Record

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface Record

All Superinterfaces:
Cloneable, Serializable
All Known Subinterfaces:
IndexedRecord, MappedRecord, ResultSet
public interface Record
extends Cloneable, Serializable

The javax.resource.cci.Record interface is the base interface for the representation of an input or output to the execute methods defined on an Interaction.

The Record interface can be extended to form a one of the following representations:

  • MappedRecord: A key-value pair based collection represents a record. This interface is based on the java.util.Map
  • IndexedRecord:An ordered and indexed collection represents a record. This interface is based on the java.util.List.
  • JavaBean based representation of an EIS abstraction: An example is a custom record generated to represent a purchase order in an ERP system.
  • javax.resource.cci.ResultSet: This interface extends both java.sql.ResultSet and javax.resource.cci.Record. A ResultSet represents tabular data.

A MappedRecord or IndexedRecord can contain another Record. This means that MappedRecord and IndexedRecord can be used to create a hierarchical structure of any arbitrary depth. A basic Java type is used as the leaf element of a hierarchical structure represented by a MappedRecord or IndexedRecord.

Version:
0.8
Author:
Rahul Sharma
See Also:
Interaction, ResultSet

Method Summary
Object | clone() Creates and returns a copy of this object.
boolean | equals(Object other) Check if this instance is equal to another Record.
String | getRecordName() Gets the name of the Record.
String | getRecordShortDescription() Gets a short description string for the Record.
int | hashCode() Returns the hash code for the Record instance.
void | setRecordName(String name) Sets the name of the Record.
void | setRecordShortDescription(String description) Sets a short description string for the Record.

Method Detail

getRecordName

String getRecordName()
Gets the name of the Record.

Returns:
String representing name of the Record

setRecordName

void setRecordName(String name)
Sets the name of the Record.

Parameters:
name - Name of the Record

setRecordShortDescription

void setRecordShortDescription(String description)
Sets a short description string for the Record. This property is used primarily by application development tools.

Parameters:
description - Description of the Record

getRecordShortDescription

String getRecordShortDescription()
Gets a short description string for the Record. This property is used primarily by application development tools.

Returns:
String representing a short description of the Record

equals

boolean equals(Object other)
Check if this instance is equal to another Record.

Overrides:
equals in class Object
Returns:
true if two instances are equal

hashCode

int hashCode()
Returns the hash code for the Record instance.

Overrides:
hashCode in class Object
Returns:
hash code

clone

Object clone()
             throws CloneNotSupportedException
Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object.

Returns:
a clone of this instance.
Throws:
CloneNotSupportedException - If the object's class does not support the Cloneable interface Subclasses that override the clone method can also throw this exception to indicate that an instance cannot be cloned.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RecordFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface RecordFactory

public interface RecordFactory

The RecordFactory interface is used for creating MappedRecord and IndexedRecord instances. Note that the RecordFactory is only used for creation of generic record instances. A CCI implementation provides an implementation class for the RecordFactory interface.

Since:
0.8
Author:
Rahul Sharma
See Also:
IndexedRecord, MappedRecord

Method Summary
IndexedRecord | createIndexedRecord(String recordName) Creates a IndexedRecord.
MappedRecord | createMappedRecord(String recordName) Creates a MappedRecord.

Method Detail

createMappedRecord

MappedRecord createMappedRecord(String recordName)
                                throws ResourceException
Creates a MappedRecord. The method takes the name of the record that is to be created by the RecordFactory. The name of the record acts as a pointer to the meta information (stored in the metadata repository) for a specific record type.

Parameters:
recordName - Name of the Record
Returns:
MappedRecord
Throws:
ResourceException - Failed to create a MappedRecord. Example error cases are:
  • Invalid specification of record name
  • Resource adapter internal error
  • Failed to access metadata repository
NotSupportedException - Operation not supported

createIndexedRecord

IndexedRecord createIndexedRecord(String recordName)
                                  throws ResourceException
Creates a IndexedRecord. The method takes the name of the record that is to be created by the RecordFactory. The name of the record acts as a pointer to the meta information (stored in the metadata repository) for a specific record type.

Parameters:
recordName - Name of the Record
Returns:
IndexedRecord
Throws:
ResourceException - Failed to create an IndexedRecord. Example error cases are:
  • Invalid specification of record name
  • Resource adapter internal error
  • Failed to access metadata repository
NotSupportedException - Operation not supported
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResourceAdapterMetaData

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface ResourceAdapterMetaData

public interface ResourceAdapterMetaData

The interface javax.resource.cci.ResourceAdapterMetaData provides information about capabilities of a resource adapter implementation. Note that this interface does not provide information about an EIS instance that is connected through the resource adapter.

A CCI client uses a ConnectionFactory.getMetaData to get metadata information about the resource adapter. The getMetaData method does not require that an active connection to an EIS instance should have been established.

The ResourceAdapterMetaData can be extended to provide more information specific to a resource adapter implementation.

Since:
0.8
Version:
0.8
Author:
Rahul Sharma
See Also:
ConnectionFactory

Method Summary
 String getAdapterName()
Gets a tool displayable name of the resource adapter.
 String getAdapterShortDescription()
Gets a tool displayable short desription of the resource adapter.
 String getAdapterVendorName()
Gets the name of the vendor that has provided the resource adapter.
 String getAdapterVersion()
Gets the version of the resource adapter.
 String[] getInteractionSpecsSupported()
Returns an array of fully-qualified names of InteractionSpec types supported by the CCI implementation for this resource adapter.
 String getSpecVersion()
Returns a string representation of the version of the connector architecture specification that is supported by the resource adapter.
 boolean supportsExecuteWithInputAndOutputRecord()
Returns true if the implementation class for the Interaction interface implements public boolean execute(InteractionSpec ispec, Record input, Record output) method; otherwise the method returns false.
 boolean supportsExecuteWithInputRecordOnly()
Returns true if the implementation class for the Interaction interface implements public Record execute(InteractionSpec ispec, Record input) method; otherwise the method returns false.
 boolean supportsLocalTransactionDemarcation()
Returns true if the resource adapter implements the LocalTransaction interface and supports local transaction demarcation on the underlying EIS instance through the LocalTransaction interface.

Method Detail

getAdapterVersion

String getAdapterVersion()
Gets the version of the resource adapter.

Returns:
String representing version of the resource adapter

getAdapterVendorName

String getAdapterVendorName()
Gets the name of the vendor that has provided the resource adapter.

Returns:
String representing name of the vendor that has provided the resource adapter

getAdapterName

String getAdapterName()
Gets a tool displayable name of the resource adapter.

Returns:
String representing the name of the resource adapter

getAdapterShortDescription

String getAdapterShortDescription()
Gets a tool displayable short desription of the resource adapter.

Returns:
String describing the resource adapter

getSpecVersion

String getSpecVersion()
Returns a string representation of the version of the connector architecture specification that is supported by the resource adapter.

Returns:
String representing the supported version of the connector architecture

getInteractionSpecsSupported

String[] getInteractionSpecsSupported()
Returns an array of fully-qualified names of InteractionSpec types supported by the CCI implementation for this resource adapter. Note that the fully-qualified class name is for the implementation class of an InteractionSpec. This method may be used by tools vendor to find information on the supported InteractionSpec types. The method should return an array of length 0 if the CCI implementation does not define specific InteractionSpec types.

Returns:
Array of fully-qualified class names of InteractionSpec classes supported by this resource adapter's CCI implementation
See Also:
InteractionSpec

supportsExecuteWithInputAndOutputRecord

boolean supportsExecuteWithInputAndOutputRecord()
Returns true if the implementation class for the Interaction interface implements public boolean execute(InteractionSpec ispec, Record input, Record output) method; otherwise the method returns false.

Returns:
boolean depending on method support
See Also:
Interaction

supportsExecuteWithInputRecordOnly

boolean supportsExecuteWithInputRecordOnly()
Returns true if the implementation class for the Interaction interface implements public Record execute(InteractionSpec ispec, Record input) method; otherwise the method returns false.

Returns:
boolean depending on method support
See Also:
Interaction

supportsLocalTransactionDemarcation

boolean supportsLocalTransactionDemarcation()
Returns true if the resource adapter implements the LocalTransaction interface and supports local transaction demarcation on the underlying EIS instance through the LocalTransaction interface.

Returns:
true if resource adapter supports resource manager local transaction demarcation through LocalTransaction interface; false otherwise
See Also:
LocalTransaction
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResourceWarning

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Class ResourceWarning

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.cci.ResourceWarning
All Implemented Interfaces:
Serializable
public class ResourceWarning
extends ResourceException

A ResourceWarning provides information on warnings related to execution of an interaction with an EIS. Warnings are silently chained to the object whose method caused it to be reported.

See Also:
Interaction.getWarnings(), Serialized Form

Constructor Summary
ResourceWarning()
Constructs a new instance with null as its detail message.
ResourceWarning(String message)
Constructs a new instance with the specified detail message.
ResourceWarning(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
ResourceWarning(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
ResourceWarning(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
ResourceWarning | getLinkedWarning() Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
void | setLinkedWarning(ResourceWarning warning) Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResourceWarning

public ResourceWarning()
Constructs a new instance with null as its detail message.

ResourceWarning

public ResourceWarning(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

ResourceWarning

public ResourceWarning(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

ResourceWarning

public ResourceWarning(String message,
                       Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

ResourceWarning

public ResourceWarning(String message,
                       String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Method Detail

getLinkedWarning

public ResourceWarning getLinkedWarning()
Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.

Retrieves the warning chained to this ResourceWarning object.

Returns:
next ResourceWarning in the chain; null if none.

setLinkedWarning

public void setLinkedWarning(ResourceWarning warning)
Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.

Adds an ResourceWarning object to the end of the chain.

Parameters:
warning - ResourceWarning to be added to the chain.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResultSetInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface ResultSetInfo

public interface ResultSetInfo

The interface javax.resource.cci.ResultSetInfo provides information on the support provided for ResultSet by a connected EIS instance. A component calls the method Connection.getResultInfo to get the ResultSetInfo instance.

A CCI implementation is not required to support javax.resource.cci.ResultSetInfo interface. The implementation of this interface is provided only if the CCI supports the ResultSet facility.

Version:
0.9
Author:
Rahul Sharma
See Also:
Connection, ResultSet, ConnectionMetaData

Method Summary
boolean | deletesAreDetected(int type)
boolean | insertsAreDetected(int type) Indicates whether or not a visible row insert can be detected by calling ResultSet.rowInserted.
boolean | othersDeletesAreVisible(int type) Indicates whether deletes made by others are visible.
boolean | othersInsertsAreVisible(int type) Indicates whether inserts made by others are visible.
boolean | othersUpdatesAreVisible(int type) Indicates whether updates made by others are visible.
boolean | ownDeletesAreVisible(int type)
boolean | ownInsertsAreVisible(int type)
boolean | ownUpdatesAreVisible(int type)
boolean | supportsResultSetType(int type) Indicates whether or not a resource adapter supports a type of ResultSet.
boolean | supportsResultTypeConcurrency(int type, int concurrency) Indicates whether or not a resource adapter supports the concurrency type in combination with the given ResultSet type/
boolean | updatesAreDetected(int type) Indicates whether or not a visible row update can be detected by calling the method ResultSet.rowUpdated.

Method Detail

updatesAreDetected

boolean updatesAreDetected(int type)
                           throws ResourceException
Indicates whether or not a visible row update can be detected by calling the method ResultSet.rowUpdated.

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
Returns:
true if changes are detected by the result set type; false otherwise
Throws:
ResourceException - Failed to get the information
See Also:
ResultSet.rowUpdated()

insertsAreDetected

boolean insertsAreDetected(int type)
                           throws ResourceException
Indicates whether or not a visible row insert can be detected by calling ResultSet.rowInserted.

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
Returns:
true if changes are detected by the result set type; false otherwise
Throws:
ResourceException - Failed to get the information
See Also:
ResultSet.rowInserted()

deletesAreDetected

boolean deletesAreDetected(int type)
                           throws ResourceException
Throws:
ResourceException

supportsResultSetType

boolean supportsResultSetType(int type)
                              throws ResourceException
Indicates whether or not a resource adapter supports a type of ResultSet.

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
Returns:
true if ResultSet type supported; false otherwise
Throws:
ResourceException - Failed to get the information

supportsResultTypeConcurrency

boolean supportsResultTypeConcurrency(int type,
                                      int concurrency)
                                      throws ResourceException
Indicates whether or not a resource adapter supports the concurrency type in combination with the given ResultSet type/

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
concurrency - ResultSet concurrency type defined in java.sql.ResultSet
Returns:
true if the specified combination supported; false otherwise
Throws:
ResourceException - Failed to get the information

othersUpdatesAreVisible

boolean othersUpdatesAreVisible(int type)
                                throws ResourceException
Indicates whether updates made by others are visible.

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
Returns:
true if updates by others are visible for the ResultSet type; false otherwise
Throws:
ResourceException - Failed to get the information

othersDeletesAreVisible

boolean othersDeletesAreVisible(int type)
                                throws ResourceException
Indicates whether deletes made by others are visible.

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
Returns:
true if deletes by others are visible for the ResultSet type; false otherwise
Throws:
ResourceException - Failed to get the information

othersInsertsAreVisible

boolean othersInsertsAreVisible(int type)
                                throws ResourceException
Indicates whether inserts made by others are visible.

Parameters:
type - type of the ResultSet i.e. ResultSet.TYPE_XXX
Returns:
true if inserts by others are visible for the ResultSet type; false otherwise
Throws:
ResourceException - Failed to get the information

ownUpdatesAreVisible

boolean ownUpdatesAreVisible(int type)
                             throws ResourceException
Throws:
ResourceException

ownInsertsAreVisible

boolean ownInsertsAreVisible(int type)
                             throws ResourceException
Throws:
ResourceException

ownDeletesAreVisible

boolean ownDeletesAreVisible(int type)
                             throws ResourceException
Throws:
ResourceException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Streamable

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.cci
Interface Streamable

public interface Streamable

Streamable interface enables a resource adapter to extract data from an input Record or set data into an output Record as a stream of bytes.

The Streamable interface provides a resource adapter's view of the data that has been set in a Record instance by a component.

The Streamable interface is not directly used by a component. It is used by a resource adapter implementation. A component uses Record or any derived interfaces to manage records.

Since:
0.8
Author:
Rahul Sharma
See Also:
Record

Method Summary
void | read(InputStream istream) Read data from an InputStream and initialize fields of a Streamable object.
void | write(OutputStream ostream) Write fields of a Streamable object to an OutputStream

Method Detail

read

void read(InputStream istream)
          throws IOException
Read data from an InputStream and initialize fields of a Streamable object.

Parameters:
istream - InputStream that represents a resource adapter specific internal representation of fields of a Streamable object
Throws:
IOException

write

void write(OutputStream ostream)
           throws IOException
Write fields of a Streamable object to an OutputStream

Parameters:
ostream - OutputStream that holds value of a Streamable object
Throws:
IOException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NotSupportedException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource
Class NotSupportedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.NotSupportedException
All Implemented Interfaces:
Serializable
public class NotSupportedException
extends ResourceException

A NotSupportedException is thrown to indicate that callee (resource adapter or application server for system contracts) cannot execute an operation because the operation is not a supported feature. For example, if the transaction support level for a resource adapter is NO_TRANSACTION, an invocation of getXAResource method on a ManagedConnection object should throw a NotSupportedException exception.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
NotSupportedException()
Constructs a new instance with null as its detail message.
NotSupportedException(String message)
Constructs a new instance with the specified detail message.
NotSupportedException(String message, String errorCode)
Constructs a new throwable with the specified detail message and error code.
NotSupportedException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
NotSupportedException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NotSupportedException

public NotSupportedException()
Constructs a new instance with null as its detail message.

NotSupportedException

public NotSupportedException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

NotSupportedException

public NotSupportedException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

NotSupportedException

public NotSupportedException(String message,
                             Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

NotSupportedException

public NotSupportedException(String message,
                             String errorCode)
Constructs a new throwable with the specified detail message and error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Referenceable

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource
Interface Referenceable

All Superinterfaces:
Referenceable
All Known Subinterfaces:
ConnectionFactory
public interface Referenceable
extends Referenceable

The Referenceable interface extends the javax.naming.Referenceable interface. It enables support for JNDI Reference mechanism for the registration of the connection factory in the JNDI name space. Note that the implementation and structure of Reference is specific to an application server.

The implementation class for a connection factory interface is required to implement both java.io.Serializable and javax.resource.Referenceable interfaces to support JNDI registration.

Version:
0.9
Author:
Rahul Sharma

Method Summary
 void setReference(Reference reference)
Sets the Reference instance.
Methods inherited from interface javax.naming.Referenceable
getReference

Method Detail

setReference

void setReference(Reference reference)
Sets the Reference instance. This method is called by the deployment code to set the Reference that can be later returned by the getReference method (as defined in the javax.naming.Referenceable interface).

Parameters:
reference - A Reference instance
See Also:
Referenceable.getReference()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResourceException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource
Class ResourceException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ApplicationServerInternalException, CommException, EISSystemException, IllegalStateException, InvalidPropertyException, LocalTransactionException, NotSupportedException, ResourceAdapterInternalException, ResourceAllocationException, ResourceWarning, SecurityException, SharingViolationException, UnavailableException, WorkException
public class ResourceException
extends Exception

This is the root interface of the exception hierarchy defined for the Connector architecture. The ResourceException provides the following information:

  • A resource adapter vendor specific string describing the error. This string is a standard Java exception message and is available through getMessage() method.
  • resource adapter vendor specific error code.
  • reference to another exception. Often a resource exception will be result of a lower level problem. If appropriate, this lower level exception can be linked to the ResourceException. Note, this has been deprecated in favor of J2SE release 1.4 exception chaining facility.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
ResourceException()
Constructs a new instance with null as its detail message.
ResourceException(String message)
Constructs a new instance with the specified detail message.
ResourceException(String message, String errorCode)
Create a new throwable with the specified message and error code.
ResourceException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
ResourceException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
String | getErrorCode() Get the error code.
Exception | getLinkedException() Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class..
String | getMessage() Returns a detailed message string describing this exception.
void | setErrorCode(String errorCode) Set the error code.
void | setLinkedException(Exception ex) Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResourceException

public ResourceException()
Constructs a new instance with null as its detail message.

ResourceException

public ResourceException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

ResourceException

public ResourceException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

ResourceException

public ResourceException(String message,
                         Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

ResourceException

public ResourceException(String message,
                         String errorCode)
Create a new throwable with the specified message and error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Method Detail

setErrorCode

public void setErrorCode(String errorCode)
Set the error code.

Parameters:
errorCode - the error code.

getErrorCode

public String getErrorCode()
Get the error code.

Returns:
the error code.

getLinkedException

public Exception getLinkedException()
Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class..

Get the exception linked to this ResourceException

Returns:
linked Exception, null if none

setLinkedException

public void setLinkedException(Exception ex)
Deprecated. J2SE release 1.4 supports a chained exception facility that allows any throwable to know about another throwable, if any, that caused it to get thrown. Refer to getCause and initCause methods of the java.lang.Throwable class.

Add a linked Exception to this ResourceException.

Parameters:
ex - linked Exception

getMessage

public String getMessage()
Returns a detailed message string describing this exception.

Overrides:
getMessage in class Throwable
Returns:
a detailed message string.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


spi

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.resource.spi

The javax.resource.spi package contains APIs for the system contracts defined in the J2EE Connector Architecture specification.

See:
Description

Interface Summary
ActivationSpec | This interface serves as a marker.
BootstrapContext | This provides a mechanism to pass a bootstrap context to a resource adapter instance when it is bootstrapped.
ConnectionEventListener | The ConnectionEventListener interface provides an event callback mechanism to enable an application server to receive notifications from a ManagedConnection instance.
ConnectionManager | ConnectionManager interface provides a hook for the resource adapter to pass a connection request to the application server.
ConnectionRequestInfo | The ConnectionRequestInfo interface enables a resource adapter to pass its own request specific data structure across the connection request flow.
DissociatableManagedConnection | This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation.
LazyAssociatableConnectionManager | This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation.
LazyEnlistableConnectionManager | This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation.
LazyEnlistableManagedConnection | This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation.
LocalTransaction | LocalTransaction interface provides support for transactions that are managed internal to an EIS resource manager, and do not require an external transaction manager.
ManagedConnection | ManagedConnection instance represents a physical connection to the underlying EIS.
ManagedConnectionFactory | ManagedConnectionFactory instance is a factory of both ManagedConnection and EIS-specific connection factory instances.
ManagedConnectionMetaData | The ManagedConnectionMetaData interface provides information about the underlying EIS instance associated with a ManagedConnection instance.
ResourceAdapter | This represents a resource adapter instance and contains operations for lifecycle management and message endpoint setup.
ResourceAdapterAssociation | This interface specifies the methods to associate a ResourceAdapter object with other objects that implement this interface like ManagedConnectionFactory and ActivationSpec.
ValidatingManagedConnectionFactory | This interface is implemented by a ManagedConnectionFactory instance that supports the ability to validate ManagedConnection objects.
XATerminator | The XATerminator interface is used for transaction completion and crash recovery flows.

Class Summary
ConnectionEvent The ConnectionEvent class provides information about the source of a connection related event.A ConnectionEvent instance contains the following information: Type of the connection event ManagedConnection instance that generated the connection event.

Exception Summary
ApplicationServerInternalException | An ApplicationServerInternalException is thrown by an application server to indicate error conditions specific to an application server.
CommException | This indicates errors related to failed or interrupted communication with an EIS instance.
EISSystemException | An EISSystemException is used to indicate any EIS specific system-level error conditions.
IllegalStateException | An IllegalStateException is thrown from a method if the callee (resource adapter or application server for system contracts) is in an illegal or inappropriate state for the method invocation.
InvalidPropertyException | This exception is thrown to indicate invalid configuration property settings.
LocalTransactionException | A LocalTransactionException represents various error conditions related to the local transaction management contract.
ResourceAdapterInternalException | A ResourceAdapterInternalException indicates any system-level error conditions related to a resource adapter.
ResourceAllocationException | A ResourceAllocationException can be thrown by an application server or resource adapter to indicate any failure to allocate system resources (example: threads, physical connections).
SecurityException | A SecurityException indicates error conditions related to the security contract between an application server and resource adapter.
SharingViolationException | This is thrown to indicate a connection sharing violation.
UnavailableException | This is thrown to indicate that a service is unavailable.

Package javax.resource.spi Description

The javax.resource.spi package contains APIs for the system contracts defined in the J2EE Connector Architecture specification.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.resource.spi Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.resource.spi

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.resource.spi.ConnectionEvent
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.ApplicationServerInternalException
          • javax.resource.spi.CommException
          • javax.resource.spi.EISSystemException
          • javax.resource.spi.IllegalStateException
          • javax.resource.spi.InvalidPropertyException
          • javax.resource.spi.LocalTransactionException
          • javax.resource.spi.ResourceAdapterInternalException
          • javax.resource.spi.ResourceAllocationException
          • javax.resource.spi.SecurityException
          • javax.resource.spi.SharingViolationException
          • javax.resource.spi.UnavailableException

Interface Hierarchy

  • javax.resource.spi.BootstrapContext
  • javax.resource.spi.ConnectionRequestInfo
  • javax.resource.spi.DissociatableManagedConnection
  • java.util.EventListener
    • javax.resource.spi.ConnectionEventListener
  • javax.resource.spi.LazyAssociatableConnectionManager
  • javax.resource.spi.LazyEnlistableConnectionManager
  • javax.resource.spi.LazyEnlistableManagedConnection
  • javax.resource.spi.LocalTransaction
  • javax.resource.spi.ManagedConnection
  • javax.resource.spi.ManagedConnectionMetaData
  • javax.resource.spi.ResourceAdapter
  • javax.resource.spi.ResourceAdapterAssociation
    • javax.resource.spi.ActivationSpec
  • java.io.Serializable
    • javax.resource.spi.ConnectionManager
    • javax.resource.spi.ManagedConnectionFactory
  • javax.resource.spi.ValidatingManagedConnectionFactory
  • javax.resource.spi.XATerminator
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LazyEnlistableManagedConnection

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface LazyEnlistableManagedConnection

public interface LazyEnlistableManagedConnection

This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation. An implementation of this interface must support the lazy transaction enlistment optimization.

Version:
1.0
Author:
Ram Jeyaraman

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ActivationSpec

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ActivationSpec

All Superinterfaces:
ResourceAdapterAssociation
public interface ActivationSpec
extends ResourceAdapterAssociation

This interface serves as a marker. An instance of an ActivationSpec must be a JavaBean and must be serializable. This holds the activation configuration information for a message endpoint.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 void validate()
This method may be called by a deployment tool to validate the overall activation configuration information provided by the endpoint deployer.
Methods inherited from interface javax.resource.spi.ResourceAdapterAssociation
getResourceAdapter, setResourceAdapter

Method Detail

validate

void validate()
              throws InvalidPropertyException
This method may be called by a deployment tool to validate the overall activation configuration information provided by the endpoint deployer. This helps to catch activation configuration errors earlier on without having to wait until endpoint activation time for configuration validation. The implementation of this self-validation check behavior is optional.

Throws:
InvalidPropertyException - indicates invalid configuration property settings.
InvalidPropertyException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ApplicationServerInternalException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class ApplicationServerInternalException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.ApplicationServerInternalException
All Implemented Interfaces:
Serializable
public class ApplicationServerInternalException
extends ResourceException

An ApplicationServerInternalException is thrown by an application server to indicate error conditions specific to an application server. These error conditions can be related to either configuration related errors or implementation of mechanisms internal to an application server (example: connection pooling, thread management).

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
ApplicationServerInternalException()
Constructs a new instance with null as its detail message.
ApplicationServerInternalException(String message)
Constructs a new instance with the specified detail message.
ApplicationServerInternalException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
ApplicationServerInternalException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
ApplicationServerInternalException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ApplicationServerInternalException

public ApplicationServerInternalException()
Constructs a new instance with null as its detail message.

ApplicationServerInternalException

public ApplicationServerInternalException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

ApplicationServerInternalException

public ApplicationServerInternalException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

ApplicationServerInternalException

public ApplicationServerInternalException(String message,
                                          Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

ApplicationServerInternalException

public ApplicationServerInternalException(String message,
                                          String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BootstrapContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface BootstrapContext

public interface BootstrapContext

This provides a mechanism to pass a bootstrap context to a resource adapter instance when it is bootstrapped. That is, when (start(BootstrapContext)) method on the ResourceAdapter class is invoked. The bootstrap context contains references to useful facilities that could be used by the resource adapter instance.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
Timer | createTimer() Creates a new java.util.Timer instance.
WorkManager | getWorkManager() Provides a handle to a WorkManager instance.
XATerminator | getXATerminator() Provides a handle to a XATerminator instance.

Method Detail

getWorkManager

WorkManager getWorkManager()
Provides a handle to a WorkManager instance. The WorkManager instance could be used by a resource adapter to do its work by submitting Work instances for execution.

Returns:
a WorkManager instance.

getXATerminator

XATerminator getXATerminator()
Provides a handle to a XATerminator instance. The XATerminator instance could be used by a resource adapter to flow-in transaction completion and crash recovery calls from an EIS.

Returns:
a XATerminator instance.

createTimer

Timer createTimer()
                  throws UnavailableException
Creates a new java.util.Timer instance. The Timer instance could be used to perform periodic Work executions or other tasks.

Returns:
a new Timer instance.
Throws:
UnavailableException - indicates that a Timer instance is not available. The request may be retried later.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


CommException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class CommException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.CommException
All Implemented Interfaces:
Serializable
public class CommException
extends ResourceException

This indicates errors related to failed or interrupted communication with an EIS instance. Examples of common error conditions represented by this exception type are communication protocol error and invalidated connection due to server failure.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
CommException()
Constructs a new instance with null as its detail message.
CommException(String message)
Constructs a new instance with the specified detail message.
CommException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
CommException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
CommException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CommException

public CommException()
Constructs a new instance with null as its detail message.

CommException

public CommException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

CommException

public CommException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

CommException

public CommException(String message,
                     Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

CommException

public CommException(String message,
                     String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class ConnectionEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.resource.spi.ConnectionEvent
All Implemented Interfaces:
Serializable
public class ConnectionEvent
extends EventObject

The ConnectionEvent class provides information about the source of a connection related event.A ConnectionEvent instance contains the following information:

  • Type of the connection event
  • ManagedConnection instance that generated the connection event. A ManagedConnection instance is returned from the method ConnectionEvent.getSource.
  • Connection handle associated with the ManagedConnection instance; required for the CONNECTION_CLOSED event and optional for the other event types.
  • Optionally, an exception indicating the connection related error. Note that exception is used for CONNECTION_ERROR_OCCURRED.

This class defines following types of event notifications:

  • CONNECTION_CLOSED
  • LOCAL_TRANSACTION_STARTED
  • LOCAL_TRANSACTION_COMMITTED
  • LOCAL_TRANSACTION_ROLLEDBACK
  • CONNECTION_ERROR_OCCURRED

Version:
0.5
Author:
Rahul Sharma
See Also:
ConnectionEventListener, Serialized Form

Field Summary
static int | CONNECTION_CLOSED Event notification that an application component has closed the connection
static int | CONNECTION_ERROR_OCCURRED Event notification that an error occurred on the connection.
protected int | id Type of the event
static int | LOCAL_TRANSACTION_COMMITTED Event notification that a Resource Manager Local Transaction was committed on the connection
static int | LOCAL_TRANSACTION_ROLLEDBACK Event notification that a Resource Manager Local Transaction was rolled back on the connection
static int | LOCAL_TRANSACTION_STARTED Event notification that a Resource Manager Local Transaction was started on the connection
Fields inherited from class java.util.EventObject
source
Constructor Summary
ConnectionEvent(ManagedConnection source, int eid)
Construct a ConnectionEvent object.
ConnectionEvent(ManagedConnection source, int eid, Exception exception)
Construct a ConnectionEvent object.
Method Summary
Object | getConnectionHandle() Get the connection handle associated with the Managed Connection instance.
Exception | getException() Get the exception.
int | getId() Get the type of event
void | setConnectionHandle(Object connectionHandle) Set the connection handle.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

CONNECTION_CLOSED

public static final int CONNECTION_CLOSED
Event notification that an application component has closed the connection

See Also:
Constant Field Values

LOCAL_TRANSACTION_STARTED

public static final int LOCAL_TRANSACTION_STARTED
Event notification that a Resource Manager Local Transaction was started on the connection

See Also:
Constant Field Values

LOCAL_TRANSACTION_COMMITTED

public static final int LOCAL_TRANSACTION_COMMITTED
Event notification that a Resource Manager Local Transaction was committed on the connection

See Also:
Constant Field Values

LOCAL_TRANSACTION_ROLLEDBACK

public static final int LOCAL_TRANSACTION_ROLLEDBACK
Event notification that a Resource Manager Local Transaction was rolled back on the connection

See Also:
Constant Field Values

CONNECTION_ERROR_OCCURRED

public static final int CONNECTION_ERROR_OCCURRED
Event notification that an error occurred on the connection. This event indicates that the ManagedConnection instance is now invalid and unusable.

See Also:
Constant Field Values

id

protected int id
Type of the event

Constructor Detail

ConnectionEvent

public ConnectionEvent(ManagedConnection source,
                       int eid)
Construct a ConnectionEvent object. Exception defaults to null.

Parameters:
source - ManagedConnection that is the source of the event
eid - type of the Connection event

ConnectionEvent

public ConnectionEvent(ManagedConnection source,
                       int eid,
                       Exception exception)
Construct a ConnectionEvent object.

Parameters:
source - ManagedConnection that is the source of the event
exception - exception about to be thrown to the application
eid - type of the Connection event
Method Detail

getConnectionHandle

public Object getConnectionHandle()
Get the connection handle associated with the Managed Connection instance. Used for CONNECTION_CLOSED event.

Returns:
the connection handle. May be null

setConnectionHandle

public void setConnectionHandle(Object connectionHandle)
Set the connection handle. Used for CONNECTION_CLOSED event

getException

public Exception getException()
Get the exception. May be null.

Returns:
the exception about to be thrown.

getId

public int getId()
Get the type of event

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionEventListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ConnectionEventListener

All Superinterfaces:
EventListener
public interface ConnectionEventListener
extends EventListener

The ConnectionEventListener interface provides an event callback mechanism to enable an application server to receive notifications from a ManagedConnection instance.

An application server uses these event notifications to manage its connection pool, to clean up any invalid or terminated connections and to manage local transactions.

An application server implements the ConnectionEventListener interface. It registers a connection listener with a ManagedConnection instance by using ManagedConnection.addConnectionEventListener method.

Version:
0.5
Author:
Rahul Sharma
See Also:
ConnectionEvent

Method Summary
void | connectionClosed(ConnectionEvent event) Notifies that an application component has closed the connection.
void | connectionErrorOccurred(ConnectionEvent event) Notifies a connection related error.
void | localTransactionCommitted(ConnectionEvent event) Notifies that a Resource Manager Local Transaction was committed on the ManagedConnection instance.
void | localTransactionRolledback(ConnectionEvent event) Notifies that a Resource Manager Local Transaction was rolled back on the ManagedConnection instance.
void | localTransactionStarted(ConnectionEvent event) Notifies that a Resource Manager Local Transaction was started on the ManagedConnection instance.

Method Detail

connectionClosed

void connectionClosed(ConnectionEvent event)
Notifies that an application component has closed the connection.

A ManagedConnection instance notifies its registered set of listeners by calling ConnectionEventListener.connectionClosed method when an application component closes a connection handle. The application server uses this connection close event to put the ManagedConnection instance back in to the connection pool.

Parameters:
event - event object describing the source of the event

localTransactionStarted

void localTransactionStarted(ConnectionEvent event)
Notifies that a Resource Manager Local Transaction was started on the ManagedConnection instance.

Parameters:
event - event object describing the source of the event

localTransactionCommitted

void localTransactionCommitted(ConnectionEvent event)
Notifies that a Resource Manager Local Transaction was committed on the ManagedConnection instance.

Parameters:
event - event object describing the source of the event

localTransactionRolledback

void localTransactionRolledback(ConnectionEvent event)
Notifies that a Resource Manager Local Transaction was rolled back on the ManagedConnection instance.

Parameters:
event - event object describing the source of the event

connectionErrorOccurred

void connectionErrorOccurred(ConnectionEvent event)
Notifies a connection related error. The ManagedConnection instance calls the method ConnectionEventListener.connectionErrorOccurred to notify its registered listeners of the occurrence of a physical connection-related error. The event notification happens just before a resource adapter throws an exception to the application component using the connection handle. The connectionErrorOccurred method indicates that the associated ManagedConnection instance is now invalid and unusable. The application server handles the connection error event notification by initiating application server-specific cleanup (for example, removing ManagedConnection instance from the connection pool) and then calling ManagedConnection.destroy method to destroy the physical connection.

Parameters:
event - event object describing the source of the event
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ConnectionManager

All Superinterfaces:
Serializable
public interface ConnectionManager
extends Serializable

ConnectionManager interface provides a hook for the resource adapter to pass a connection request to the application server.

An application server provides implementation of the ConnectionManager interface. This implementation is not specific to any particular type of the resource adapter or connection factory interface.

The ConnectionManager implementation delegates to the application server to enable latter to provide quality of services (QoS) - security, connection pool management, transaction management and error logging/tracing.

An application server implements these services in a generic manner, independent of any resource adapter and EIS specific mechanisms. The connector architecture does not specify how an application server implements these services; the implementation is specific to an application server.

After an application server hooks-in its services, the connection request gets delegated to a ManagedConnectionFactory instance either for the creation of a new physical connection or for the matching of an already existing physical connection.

An implementation class for ConnectionManager interface is required to implement the java.io.Serializable interface.

In the non-managed application scenario, the ConnectionManager implementation class can be provided either by a resource adapter (as a default ConnectionManager implementation) or by application developers. In both cases, QOS can be provided as components by third party vendors.

Since:
0.6
Author:
Rahul Sharma
See Also:
ManagedConnectionFactory

Method Summary
 Object allocateConnection(ManagedConnectionFactory mcf, ConnectionRequestInfo cxRequestInfo)
The method allocateConnection gets called by the resource adapter's connection factory instance.

Method Detail

allocateConnection

Object allocateConnection(ManagedConnectionFactory mcf,
                          ConnectionRequestInfo cxRequestInfo)
                          throws ResourceException

The method allocateConnection gets called by the resource adapter's connection factory instance. This lets connection factory instance (provided by the resource adapter) pass a connection request to the ConnectionManager instance.

The connectionRequestInfo parameter represents information specific to the resource adapter for handling of the connection request.

Parameters:
mcf - used by application server to delegate connection matching/creation
cxRequestInfo - connection request Information
Returns:
connection handle with an EIS specific connection interface.
Throws:
ResourceException - Generic exception
ApplicationServerInternalException - Application server specific exception
SecurityException - Security related error
ResourceAllocationException - Failed to allocate system resources for connection request
ResourceAdapterInternalException - Resource adapter related error condition
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionRequestInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ConnectionRequestInfo

public interface ConnectionRequestInfo

The ConnectionRequestInfo interface enables a resource adapter to pass its own request specific data structure across the connection request flow. A resource adapter extends the empty interface to supports its own data structures for connection request.

A typical use allows a resource adapter to handle application component specified per-connection request properties (example - client ID, language). The application server passes these properties back across to match/createManagedConnection calls on the resource adapter. These properties remain opaque to the application server during the connection request flow.

Once the ConnectionRequestInfo reaches match/createManagedConnection methods on the ManagedConnectionFactory instance, resource adapter uses this additional per-request information to do connection creation and matching.

Version:
0.8
Author:
Rahul Sharma
See Also:
ManagedConnectionFactory, ManagedConnection

Method Summary
boolean | equals(Object other) Checks whether this instance is equal to another.
int | hashCode() Returns the hashCode of the ConnectionRequestInfo.

Method Detail

equals

boolean equals(Object other)
Checks whether this instance is equal to another. Since connectionRequestInfo is defined specific to a resource adapter, the resource adapter is required to implement this method. The conditions for equality are specific to the resource adapter.

Overrides:
equals in class Object
Returns:
True if the two instances are equal.

hashCode

int hashCode()
Returns the hashCode of the ConnectionRequestInfo.

Overrides:
hashCode in class Object
Returns:
hash code os this instance
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DissociatableManagedConnection

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface DissociatableManagedConnection

public interface DissociatableManagedConnection

This is a mix-in interface that may be optionally implemented by a ManagedConnection implementation. An implementation of this interface must support the lazy connection association optimization.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 void dissociateConnections()
This method is called by an application server (that is capable of lazy connection association optimization) in order to dissociate a ManagedConnection instance from all of its connection handles.

Method Detail

dissociateConnections

void dissociateConnections()
                           throws ResourceException
This method is called by an application server (that is capable of lazy connection association optimization) in order to dissociate a ManagedConnection instance from all of its connection handles.

Throws:
ResourceException - generic exception if operation fails.
ResourceAdapterInternalException - resource adapter internal error condition
IllegalStateException - Illegal state for calling connection cleanup. Example - if a localtransaction is in progress that doesn't allow connection cleanup.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EISSystemException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class EISSystemException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.EISSystemException
All Implemented Interfaces:
Serializable
public class EISSystemException
extends ResourceException

An EISSystemException is used to indicate any EIS specific system-level error conditions. The common error conditions are: failure or inactivity of an EIS instance, communication failure and EIS specific error in the creation of a new physical connection.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
EISSystemException()
Constructs a new instance with null as its detail message.
EISSystemException(String message)
Constructs a new instance with the specified detail message.
EISSystemException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
EISSystemException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
EISSystemException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EISSystemException

public EISSystemException()
Constructs a new instance with null as its detail message.

EISSystemException

public EISSystemException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

EISSystemException

public EISSystemException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

EISSystemException

public EISSystemException(String message,
                          Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

EISSystemException

public EISSystemException(String message,
                          String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


endpoint

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.resource.spi.endpoint

This package contains system contracts for service endpoint interactions.

See:
Description

Interface Summary
MessageEndpoint | This defines a contract for a message endpoint.
MessageEndpointFactory | This serves as a factory for creating message endpoints.

Package javax.resource.spi.endpoint Description

This package contains system contracts for service endpoint interactions.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.resource.spi.endpoint Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.resource.spi.endpoint

Package Hierarchies:
All Packages

Interface Hierarchy

  • javax.resource.spi.endpoint.MessageEndpoint
  • javax.resource.spi.endpoint.MessageEndpointFactory
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageEndpoint

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.endpoint
Interface MessageEndpoint

public interface MessageEndpoint

This defines a contract for a message endpoint. This is implemented by an application server.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
void | afterDelivery() This is called by a resource adapter after a message is delivered.
void | beforeDelivery(Method method) This is called by a resource adapter before a message is delivered.
void | release() This method may be called by the resource adapter to indicate that it no longer needs a proxy endpoint instance.

Method Detail

beforeDelivery

void beforeDelivery(Method method)
                    throws NoSuchMethodException,
                           ResourceException
This is called by a resource adapter before a message is delivered.

Parameters:
method - description of a target method. This information about the intended target method allows an application server to decide whether to start a transaction during this method call, depending on the transaction preferences of the target method. The processing (by the application server) of the actual message delivery method call on the endpoint must be independent of the class loader associated with this descriptive method object.
Throws:
NoSuchMethodException - indicates that the specified method does not exist on the target endpoint.
ResourceException - generic exception.
ApplicationServerInternalException - indicates an error condition in the application server.
IllegalStateException - indicates that the endpoint is in an illegal state for the method invocation. For example, this occurs when beforeDelivery and afterDelivery method calls are not paired.
UnavailableException - indicates that the endpoint is not available.

afterDelivery

void afterDelivery()
                   throws ResourceException
This is called by a resource adapter after a message is delivered.

Throws:
ResourceException - generic exception.
ApplicationServerInternalException - indicates an error condition in the application server.
IllegalStateException - indicates that the endpoint is in an illegal state for the method invocation. For example, this occurs when beforeDelivery and afterDelivery method calls are not paired.
UnavailableException - indicates that the endpoint is not available.

release

void release()
This method may be called by the resource adapter to indicate that it no longer needs a proxy endpoint instance. This hint may be used by the application server for endpoint pooling decisions.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageEndpointFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.endpoint
Interface MessageEndpointFactory

public interface MessageEndpointFactory

This serves as a factory for creating message endpoints.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
MessageEndpoint | createEndpoint(XAResource xaResource) This is used to create a message endpoint.
boolean | isDeliveryTransacted(Method method) This is used to find out whether message deliveries to a target method on a message listener interface that is implemented by a message endpoint will be transacted or not.

Method Detail

createEndpoint

MessageEndpoint createEndpoint(XAResource xaResource)
                               throws UnavailableException
This is used to create a message endpoint. The message endpoint is expected to implement the correct message listener type.

Parameters:
xaResource - an optional XAResource instance used to get transaction notifications when the message delivery is transacted.
Returns:
a message endpoint instance.
Throws:
UnavailableException - indicates a transient failure in creating a message endpoint. Subsequent attempts to create a message endpoint might succeed.

isDeliveryTransacted

boolean isDeliveryTransacted(Method method)
                             throws NoSuchMethodException
This is used to find out whether message deliveries to a target method on a message listener interface that is implemented by a message endpoint will be transacted or not. The message endpoint may indicate its transacted delivery preferences (at a per method level) through its deployment descriptor. The message delivery preferences must not change during the lifetime of a message endpoint.

Parameters:
method - description of a target method. This information about the intended target method allows an application server to find out whether the target method call will be transacted or not.
Returns:
true, if message endpoint requires transacted message delivery.
Throws:
NoSuchMethodException - indicates that the specified method does not exist on the target endpoint.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


IllegalStateException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class IllegalStateException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.IllegalStateException
All Implemented Interfaces:
Serializable
public class IllegalStateException
extends ResourceException

An IllegalStateException is thrown from a method if the callee (resource adapter or application server for system contracts) is in an illegal or inappropriate state for the method invocation.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
IllegalStateException()
Constructs a new instance with null as its detail message.
IllegalStateException(String message)
Constructs a new instance with the specified detail message.
IllegalStateException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
IllegalStateException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
IllegalStateException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IllegalStateException

public IllegalStateException()
Constructs a new instance with null as its detail message.

IllegalStateException

public IllegalStateException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

IllegalStateException

public IllegalStateException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

IllegalStateException

public IllegalStateException(String message,
                             Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

IllegalStateException

public IllegalStateException(String message,
                             String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InvalidPropertyException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class InvalidPropertyException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.InvalidPropertyException
All Implemented Interfaces:
Serializable
public class InvalidPropertyException
extends ResourceException

This exception is thrown to indicate invalid configuration property settings.

Version:
0.2
Author:
Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
InvalidPropertyException()
Create a InvalidPropertyException.
InvalidPropertyException(String message)
Create a InvalidPropertyException.
InvalidPropertyException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
InvalidPropertyException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
InvalidPropertyException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
PropertyDescriptor[] | getInvalidPropertyDescriptors() Get the list of invalid properties.
void | setInvalidPropertyDescriptors(PropertyDescriptor[] invalidProperties) Set a list of invalid properties.
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidPropertyException

public InvalidPropertyException()
Create a InvalidPropertyException.

InvalidPropertyException

public InvalidPropertyException(String message)
Create a InvalidPropertyException.

Parameters:
message - a description of the exception

InvalidPropertyException

public InvalidPropertyException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

InvalidPropertyException

public InvalidPropertyException(String message,
                                Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

InvalidPropertyException

public InvalidPropertyException(String message,
                                String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Method Detail

setInvalidPropertyDescriptors

public void setInvalidPropertyDescriptors(PropertyDescriptor[] invalidProperties)
Set a list of invalid properties.

getInvalidPropertyDescriptors

public PropertyDescriptor[] getInvalidPropertyDescriptors()
Get the list of invalid properties.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LazyAssociatableConnectionManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface LazyAssociatableConnectionManager

public interface LazyAssociatableConnectionManager

This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation. An implementation of this interface must support the lazy connection association optimization.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 void associateConnection(Object connection, ManagedConnectionFactory mcf, ConnectionRequestInfo cxReqInfo)
This method is called by a resource adapter (that is capable of lazy connection association optimization) in order to lazily associate a connection object with a ManagedConnection instance.

Method Detail

associateConnection

void associateConnection(Object connection,
                         ManagedConnectionFactory mcf,
                         ConnectionRequestInfo cxReqInfo)
                         throws ResourceException
This method is called by a resource adapter (that is capable of lazy connection association optimization) in order to lazily associate a connection object with a ManagedConnection instance.

Parameters:
connection - the connection object that is to be associated.
mcf - The ManagedConnectionFactory instance that was originally used to create the connection object.
cxReqInfo - connection request information. This information must be the same as that used to originally create the connection object.
Throws:
ResourceException - Generic exception.
ApplicationServerInternalException - Application server specific exception.
SecurityException - Security related error.
ResourceAllocationException - Failed to allocate system resources for connection request.
ResourceAdapterInternalException - Resource adapter related error condition.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LazyEnlistableConnectionManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface LazyEnlistableConnectionManager

public interface LazyEnlistableConnectionManager

This is a mix-in interface that may be optionally implemented by a ConnectionManager implementation. An implementation of this interface must support the lazy transaction enlistment optimization.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 void lazyEnlist(ManagedConnection mc)
This method is called by a resource adapter (that is capable of lazy transaction enlistment optimization) in order to lazily enlist a connection object with a XA transaction.

Method Detail

lazyEnlist

void lazyEnlist(ManagedConnection mc)
                throws ResourceException
This method is called by a resource adapter (that is capable of lazy transaction enlistment optimization) in order to lazily enlist a connection object with a XA transaction.

Parameters:
mc - The ManagedConnection instance that needs to be lazily associated.
Throws:
ResourceException - Generic exception.
ApplicationServerInternalException - Application server specific exception.
ResourceAllocationException - Failed to allocate system resources for connection request.
ResourceAdapterInternalException - Resource adapter related error condition.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LocalTransaction

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface LocalTransaction

public interface LocalTransaction

LocalTransaction interface provides support for transactions that are managed internal to an EIS resource manager, and do not require an external transaction manager.

A resource adapter implements the javax.resource.spi.LocalTransaction interface to provide support for local transactions that are performed on the underlying resource manager.

If a resource adapter supports the LocalTransaction interface, then the application server can choose to perform local transaction optimization (uses local transaction instead of a JTA transaction for a single resource manager case).

Version:
0.5
Author:
Rahul Sharma
See Also:
ManagedConnection

Method Summary
void | begin() Begin a local transaction
void | commit() Commit a local transaction
void | rollback() Rollback a local transaction

Method Detail

begin

void begin()
           throws ResourceException
Begin a local transaction

Throws:
ResourceException - generic exception if operation fails
LocalTransactionException - error condition related to local transaction management
ResourceAdapterInternalException - error condition internal to resource adapter
EISSystemException - EIS instance specific error condition

commit

void commit()
            throws ResourceException
Commit a local transaction

Throws:
ResourceException - generic exception if operation fails
LocalTransactionException - error condition related to local transaction management
ResourceAdapterInternalException - error condition internal to resource adapter
EISSystemException - EIS instance specific error condition

rollback

void rollback()
              throws ResourceException
Rollback a local transaction

Throws:
ResourceException - generic exception if operation fails
LocalTransactionException - error condition related to local transaction management
ResourceAdapterInternalException - error condition internal to resource adapter
EISSystemException - EIS instance specific error condition
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LocalTransactionException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class LocalTransactionException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.LocalTransactionException
All Implemented Interfaces:
Serializable
public class LocalTransactionException
extends ResourceException

A LocalTransactionException represents various error conditions related to the local transaction management contract. The Java Transaction API specification specifies the javax.transaction.xa.XAException class for exceptions related to XAResource based transaction management contract.

The LocalTransactionException is used for the local transaction management contract to indicate the following common error conditions:

  • Invalid transaction context when a transaction operation is executed. For example, calling commit method on LocalTransaction object without an active local transaction is an error condition.
  • Transaction is rolled back instead of getting committed during a commit method call on the LocalTransaction object.
  • An attempt to start a local transaction from the same thread on a ManagedConnection that is already associated with an active local transaction.
  • Any resource adapter or resource manager specific error conditions related to local transaction management. Examples are violation of integrity of resources, deadlock detection, communication failure during transaction completion, retry required or any internal error in a resource manager.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
LocalTransactionException()
Constructs a new instance with null as its detail message.
LocalTransactionException(String message)
Constructs a new instance with the specified detail message.
LocalTransactionException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
LocalTransactionException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
LocalTransactionException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LocalTransactionException

public LocalTransactionException()
Constructs a new instance with null as its detail message.

LocalTransactionException

public LocalTransactionException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

LocalTransactionException

public LocalTransactionException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

LocalTransactionException

public LocalTransactionException(String message,
                                 Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

LocalTransactionException

public LocalTransactionException(String message,
                                 String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ManagedConnection

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ManagedConnection

public interface ManagedConnection

ManagedConnection instance represents a physical connection to the underlying EIS.

A ManagedConnection instance provides access to a pair of interfaces: javax.transaction.xa.XAResource and javax.resource.spi.LocalTransaction.

XAResource interface is used by the transaction manager to associate and dissociate a transaction with the underlying EIS resource manager instance and to perform two-phase commit protocol. The ManagedConnection interface is not directly used by the transaction manager. More details on the XAResource interface are described in the JTA specification.

The LocalTransaction interface is used by the application server to manage local transactions.

Version:
0.5
Author:
Rahul Sharma
See Also:
ManagedConnectionFactory, XAResource, LocalTransaction

Method Summary
void | addConnectionEventListener(ConnectionEventListener listener) Adds a connection event listener to the ManagedConnection instance.
void | associateConnection(Object connection) Used by the container to change the association of an application-level connection handle with a ManagedConneciton instance.
void | cleanup() Application server calls this method to force any cleanup on the ManagedConnection instance.
void | destroy() Destroys the physical connection to the underlying resource manager.
Object | getConnection(Subject subject, ConnectionRequestInfo cxRequestInfo) Creates a new connection handle for the underlying physical connection represented by the ManagedConnection instance.
LocalTransaction | getLocalTransaction() Returns an javax.resource.spi.LocalTransaction instance.
PrintWriter | getLogWriter() Gets the log writer for this ManagedConnection instance.
ManagedConnectionMetaData | getMetaData() Gets the metadata information for this connection's underlying EIS resource manager instance.
XAResource | getXAResource() Returns an javax.transaction.xa.XAresource instance.
void | removeConnectionEventListener(ConnectionEventListener listener) Removes an already registered connection event listener from the ManagedConnection instance.
void | setLogWriter(PrintWriter out) Sets the log writer for this ManagedConnection instance.

Method Detail

getConnection

Object getConnection(Subject subject,
                     ConnectionRequestInfo cxRequestInfo)
                     throws ResourceException
Creates a new connection handle for the underlying physical connection represented by the ManagedConnection instance. This connection handle is used by the application code to refer to the underlying physical connection. This connection handle is associated with its ManagedConnection instance in a resource adapter implementation specific way.

The ManagedConnection uses the Subject and additional ConnectionRequest Info (which is specific to resource adapter and opaque to application server) to set the state of the physical connection.

Parameters:
subject - security context as JAAS subject
cxRequestInfo - ConnectionRequestInfo instance
Returns:
generic Object instance representing the connection handle. For CCI, the connection handle created by a ManagedConnection instance is of the type javax.resource.cci.Connection.
Throws:
ResourceException - generic exception if operation fails
ResourceAdapterInternalException - resource adapter internal error condition
SecurityException - security related error condition
CommException - failed communication with EIS instance
EISSystemException - internal error condition in EIS instance - used if EIS instance is involved in setting state of ManagedConnection

destroy

void destroy()
             throws ResourceException
Destroys the physical connection to the underlying resource manager.

To manage the size of the connection pool, an application server can explictly call ManagedConnection.destroy to destroy a physical connection. A resource adapter should destroy all allocated system resources for this ManagedConnection instance when the method destroy is called.

Throws:
ResourceException - generic exception if operation failed
IllegalStateException - illegal state for destroying connection

cleanup

void cleanup()
             throws ResourceException
Application server calls this method to force any cleanup on the ManagedConnection instance.

The method ManagedConnection.cleanup initiates a cleanup of the any client-specific state as maintained by a ManagedConnection instance. The cleanup should invalidate all connection handles that had been created using this ManagedConnection instance. Any attempt by an application component to use the connection handle after cleanup of the underlying ManagedConnection should result in an exception.

The cleanup of ManagedConnection is always driven by an application server. An application server should not invoke ManagedConnection.cleanup when there is an uncompleted transaction (associated with a ManagedConnection instance) in progress.

The invocation of ManagedConnection.cleanup method on an already cleaned-up connection should not throw an exception.

The cleanup of ManagedConnection instance resets its client specific state and prepares the connection to be put back in to a connection pool. The cleanup method should not cause resource adapter to close the physical pipe and reclaim system resources associated with the physical connection.

Throws:
ResourceException - generic exception if operation fails
ResourceAdapterInternalException - resource adapter internal error condition
IllegalStateException - Illegal state for calling connection cleanup. Example - if a localtransaction is in progress that doesn't allow connection cleanup

associateConnection

void associateConnection(Object connection)
                         throws ResourceException
Used by the container to change the association of an application-level connection handle with a ManagedConneciton instance. The container should find the right ManagedConnection instance and call the associateConnection method.

The resource adapter is required to implement the associateConnection method. The method implementation for a ManagedConnection should dissociate the connection handle (passed as a parameter) from its currently associated ManagedConnection and associate the new connection handle with itself.

Parameters:
connection - Application-level connection handle
Throws:
ResourceException - Failed to associate the connection handle with this ManagedConnection instance
IllegalStateException - Illegal state for invoking this method
ResourceAdapterInternalException - Resource adapter internal error condition

addConnectionEventListener

void addConnectionEventListener(ConnectionEventListener listener)
Adds a connection event listener to the ManagedConnection instance.

The registered ConnectionEventListener instances are notified of connection close and error events, also of local transaction related events on the Managed Connection.

Parameters:
listener - a new ConnectionEventListener to be registered

removeConnectionEventListener

void removeConnectionEventListener(ConnectionEventListener listener)
Removes an already registered connection event listener from the ManagedConnection instance.

Parameters:
listener - already registered connection event listener to be removed

getXAResource

XAResource getXAResource()
                         throws ResourceException
Returns an javax.transaction.xa.XAresource instance. An application server enlists this XAResource instance with the Transaction Manager if the ManagedConnection instance is being used in a JTA transaction that is being coordinated by the Transaction Manager.

Returns:
XAResource instance
Throws:
ResourceException - generic exception if operation fails
NotSupportedException - if the operation is not supported
ResourceAdapterInternalException - resource adapter internal error condition

getLocalTransaction

LocalTransaction getLocalTransaction()
                                     throws ResourceException
Returns an javax.resource.spi.LocalTransaction instance. The LocalTransaction interface is used by the container to manage local transactions for a RM instance.

Returns:
LocalTransaction instance
Throws:
ResourceException - generic exception if operation fails
NotSupportedException - if the operation is not supported
ResourceAdapterInternalException - resource adapter internal error condition

getMetaData

ManagedConnectionMetaData getMetaData()
                                      throws ResourceException

Gets the metadata information for this connection's underlying EIS resource manager instance. The ManagedConnectionMetaData interface provides information about the underlying EIS instance associated with the ManagedConenction instance.

Returns:
ManagedConnectionMetaData instance
Throws:
ResourceException - generic exception if operation fails
NotSupportedException - if the operation is not supported

setLogWriter

void setLogWriter(PrintWriter out)
                  throws ResourceException
Sets the log writer for this ManagedConnection instance.

The log writer is a character output stream to which all logging and tracing messages for this ManagedConnection instance will be printed. Application Server manages the association of output stream with the ManagedConnection instance based on the connection pooling requirements.

When a ManagedConnection object is initially created, the default log writer associated with this instance is obtained from the ManagedConnectionFactory. An application server can set a log writer specific to this ManagedConnection to log/trace this instance using setLogWriter method.

Parameters:
out - Character Output stream to be associated
Throws:
ResourceException - generic exception if operation fails
ResourceAdapterInternalException - resource adapter related error condition

getLogWriter

PrintWriter getLogWriter()
                         throws ResourceException
Gets the log writer for this ManagedConnection instance.

The log writer is a character output stream to which all logging and tracing messages for this ManagedConnection instance will be printed. ConnectionManager manages the association of output stream with the ManagedConnection instance based on the connection pooling requirements.

The Log writer associated with a ManagedConnection instance can be one set as default from the ManagedConnectionFactory (that created this connection) or one set specifically for this instance by the application server.

Returns:
Character ourput stream associated with this Managed- Connection instance
Throws:
ResourceException - generic exception if operation fails
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ManagedConnectionFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ManagedConnectionFactory

All Superinterfaces:
Serializable
public interface ManagedConnectionFactory
extends Serializable

ManagedConnectionFactory instance is a factory of both ManagedConnection and EIS-specific connection factory instances. This interface supports connection pooling by providing methods for matching and creation of ManagedConnection instance. A ManagedConnectionFactory instance is required to be a JavaBean.

Version:
0.6
Author:
Rahul Sharma
See Also:
ManagedConnection

Method Summary
Object | createConnectionFactory() Creates a Connection Factory instance.
Object | createConnectionFactory(ConnectionManager cxManager) Creates a Connection Factory instance.
ManagedConnection | createManagedConnection(Subject subject, ConnectionRequestInfo cxRequestInfo) Creates a new physical connection to the underlying EIS resource manager.
boolean | equals(Object other) Check if this ManagedConnectionFactory is equal to another ManagedConnectionFactory.
PrintWriter | getLogWriter() Get the log writer for this ManagedConnectionFactory instance.
int | hashCode() Returns the hash code for the ManagedConnectionFactory
ManagedConnection | matchManagedConnections(Set connectionSet, Subject subject, ConnectionRequestInfo cxRequestInfo) Returns a matched connection from the candidate set of connections.
void | setLogWriter(PrintWriter out) Set the log writer for this ManagedConnectionFactory instance.

Method Detail

createConnectionFactory

Object createConnectionFactory(ConnectionManager cxManager)
                               throws ResourceException
Creates a Connection Factory instance. The Connection Factory instance gets initialized with the passed ConnectionManager. In the managed scenario, ConnectionManager is provided by the application server.

Parameters:
cxManager - ConnectionManager to be associated with created EIS connection factory instance
Returns:
EIS-specific Connection Factory instance or javax.resource.cci.ConnectionFactory instance
Throws:
ResourceException - Generic exception
ResourceAdapterInternalException - Resource adapter related error condition

createConnectionFactory

Object createConnectionFactory()
                               throws ResourceException
Creates a Connection Factory instance. The Connection Factory instance gets initialized with a default ConnectionManager provided by the resource adapter.

Returns:
EIS-specific Connection Factory instance or javax.resource.cci.ConnectionFactory instance
Throws:
ResourceException - Generic exception
ResourceAdapterInternalException - Resource adapter related error condition

createManagedConnection

ManagedConnection createManagedConnection(Subject subject,
                                          ConnectionRequestInfo cxRequestInfo)
                                          throws ResourceException
Creates a new physical connection to the underlying EIS resource manager.

ManagedConnectionFactory uses the security information (passed as Subject) and additional ConnectionRequestInfo (which is specific to ResourceAdapter and opaque to application server) to create this new connection.

Parameters:
subject - Caller's security information
cxRequestInfo - Additional resource adapter specific connection request information
Returns:
ManagedConnection instance
Throws:
ResourceException - generic exception
SecurityException - security related error
ResourceAllocationException - failed to allocate system resources for connection request
ResourceAdapterInternalException - resource adapter related error condition
EISSystemException - internal error condition in EIS instance

matchManagedConnections

ManagedConnection matchManagedConnections(Set connectionSet,
                                          Subject subject,
                                          ConnectionRequestInfo cxRequestInfo)
                                          throws ResourceException
Returns a matched connection from the candidate set of connections.

ManagedConnectionFactory uses the security info (as in Subject) and information provided through ConnectionRequestInfo and additional Resource Adapter specific criteria to do matching. Note that criteria used for matching is specific to a resource adapter and is not prescribed by the Connector specification.

This method returns a ManagedConnection instance that is the best match for handling the connection allocation request.

Parameters:
connectionSet - candidate connection set
subject - caller's security information
cxRequestInfo - additional resource adapter specific connection request information
Returns:
ManagedConnection if resource adapter finds an acceptable match otherwise null
Throws:
ResourceException - generic exception
SecurityException - security related error
ResourceAdapterInternalException - resource adapter related error condition
NotSupportedException - if operation is not supported

setLogWriter

void setLogWriter(PrintWriter out)
                  throws ResourceException
Set the log writer for this ManagedConnectionFactory instance.

The log writer is a character output stream to which all logging and tracing messages for this ManagedConnectionfactory instance will be printed.

ApplicationServer manages the association of output stream with the ManagedConnectionFactory. When a ManagedConnectionFactory object is created the log writer is initially null, in other words, logging is disabled. Once a log writer is associated with a ManagedConnectionFactory, logging and tracing for ManagedConnectionFactory instance is enabled.

The ManagedConnection instances created by ManagedConnectionFactory "inherits" the log writer, which can be overridden by ApplicationServer using ManagedConnection.setLogWriter to set ManagedConnection specific logging and tracing.

Parameters:
out - PrintWriter - an out stream for error logging and tracing
Throws:
ResourceException - generic exception
ResourceAdapterInternalException - resource adapter related error condition

getLogWriter

PrintWriter getLogWriter()
                         throws ResourceException
Get the log writer for this ManagedConnectionFactory instance.

The log writer is a character output stream to which all logging and tracing messages for this ManagedConnectionFactory instance will be printed

ApplicationServer manages the association of output stream with the ManagedConnectionFactory. When a ManagedConnectionFactory object is created the log writer is initially null, in other words, logging is disabled.

Returns:
PrintWriter
Throws:
ResourceException - generic exception

hashCode

int hashCode()
Returns the hash code for the ManagedConnectionFactory

Overrides:
hashCode in class Object
Returns:
hash code for the ManagedConnectionFactory

equals

boolean equals(Object other)
Check if this ManagedConnectionFactory is equal to another ManagedConnectionFactory.

Overrides:
equals in class Object
Returns:
true if two instances are equal
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ManagedConnectionMetaData

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ManagedConnectionMetaData

public interface ManagedConnectionMetaData

The ManagedConnectionMetaData interface provides information about the underlying EIS instance associated with a ManagedConnection instance. An application server uses this information to get runtime information about a connected EIS instance.

The method ManagedConnection.getMetaData returns a ManagedConnectionMetaData instance.

Version:
0.8
Author:
Rahul Sharma
See Also:
ManagedConnection

Method Summary
String | getEISProductName() Returns Product name of the underlying EIS instance connected through the ManagedConnection.
String | getEISProductVersion() Returns product version of the underlying EIS instance connected through the ManagedConnection.
int | getMaxConnections() Returns maximum limit on number of active concurrent connections that an EIS instance can support across client processes.
String | getUserName() Returns name of the user associated with the ManagedConnection instance.

Method Detail

getEISProductName

String getEISProductName()
                         throws ResourceException
Returns Product name of the underlying EIS instance connected through the ManagedConnection.

Returns:
Product name of the EIS instance.
Throws:
ResourceException

getEISProductVersion

String getEISProductVersion()
                            throws ResourceException
Returns product version of the underlying EIS instance connected through the ManagedConnection.

Returns:
Product version of the EIS instance
Throws:
ResourceException

getMaxConnections

int getMaxConnections()
                      throws ResourceException
Returns maximum limit on number of active concurrent connections that an EIS instance can support across client processes. If an EIS instance does not know about (or does not have) any such limit, it returns a 0.

Returns:
Maximum limit for number of active concurrent connections
Throws:
ResourceException

getUserName

String getUserName()
                   throws ResourceException
Returns name of the user associated with the ManagedConnection instance. The name corresponds to the resource principal under whose whose security context, a connection to the EIS instance has been established.

Returns:
name of the user
Throws:
ResourceException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResourceAdapter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ResourceAdapter

public interface ResourceAdapter

This represents a resource adapter instance and contains operations for lifecycle management and message endpoint setup. A concrete implementation of this interface is required to be a JavaBean.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
void | endpointActivation(MessageEndpointFactory endpointFactory, ActivationSpec spec) This is called during the activation of a message endpoint.
void | endpointDeactivation(MessageEndpointFactory endpointFactory, ActivationSpec spec) This is called when a message endpoint is deactivated.
XAResource[] | getXAResources(ActivationSpec[] specs) This method is called by the application server during crash recovery.
void | start(BootstrapContext ctx) This is called when a resource adapter instance is bootstrapped.
void | stop() This is called when a resource adapter instance is undeployed or during application server shutdown.

Method Detail

start

void start(BootstrapContext ctx)
           throws ResourceAdapterInternalException
This is called when a resource adapter instance is bootstrapped. This may be during resource adapter deployment or application server startup. This is a startup notification from the application server, and this method is called by an application server thread. The application server thread executes in an unspecified context.

During this method call a ResourceAdapter JavaBean is responsible for initializing the resource adapter instance. Any exception thrown during this method call causes the application server to abort the bootstrap procedure for this specific resource adapter instance.

Parameters:
ctx - a bootstrap context containing references to useful facilities that could be used by a resource adapter instance.
Throws:
ResourceAdapterInternalException - indicates bootstrap failure. The resource adapter instance is unusable and must be discarded.

stop

void stop()
This is called when a resource adapter instance is undeployed or during application server shutdown. This is a shutdown notification from the application server, and this method is called by an application server thread. The application server thread executes in an unspecified context.

During this method call, a ResourceAdapter JavaBean is responsible for performing an orderly shutdown of the resource adapter instance. Any exception thrown by this method call does not alter the processing of the application server shutdown or resource adapter undeployment that caused this method call. The application server may log the exception information for error reporting purposes.

endpointActivation

void endpointActivation(MessageEndpointFactory endpointFactory,
                        ActivationSpec spec)
                        throws ResourceException
This is called during the activation of a message endpoint. This causes the resource adapter instance to do the necessary setup (ie., setup message delivery for the message endpoint with a message provider). Note that message delivery to the message endpoint might start even before this method returns.

Endpoint activation is deemed successful only when this method completes successfully without throwing any exceptions.

Parameters:
endpointFactory - a message endpoint factory instance.
spec - an activation spec JavaBean instance.
Throws:
NotSupportedException - indicates message endpoint activation rejection due to incorrect activation setup information.
ResourceException

endpointDeactivation

void endpointDeactivation(MessageEndpointFactory endpointFactory,
                          ActivationSpec spec)
This is called when a message endpoint is deactivated. The instances passed as arguments to this method call should be identical to those passed in for the corresponding endpointActivation call. This causes the resource adapter to stop delivering messages to the message endpoint.

Any exception thrown by this method is ignored. After this method call, the endpoint is deemed inactive.

Parameters:
endpointFactory - a message endpoint factory instance.
spec - an activation spec JavaBean instance.

getXAResources

XAResource[] getXAResources(ActivationSpec[] specs)
                            throws ResourceException
This method is called by the application server during crash recovery. This method takes in an array of ActivationSpec JavaBeans and returns an array of XAResource objects each of which represents a unique resource manager. The resource adapter may return null if it does not implement the XAResource interface. Otherwise, it must return an array of XAResource objects, each of which represents a unique resource manager that was used by the endpoint applications. The application server uses the XAResource objects to query each resource manager for a list of in-doubt transactions. It then completes each pending transaction by sending the commit decision to the participating resource managers.

Parameters:
specs - an array of ActivationSpec JavaBeans each of which corresponds to an deployed endpoint application that was active prior to the system crash.
Returns:
an array of XAResource objects each of which represents a unique resource manager.
Throws:
ResourceException - generic exception if operation fails due to an error condition.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResourceAdapterAssociation

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ResourceAdapterAssociation

All Known Subinterfaces:
ActivationSpec
public interface ResourceAdapterAssociation

This interface specifies the methods to associate a ResourceAdapter object with other objects that implement this interface like ManagedConnectionFactory and ActivationSpec.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
ResourceAdapter | getResourceAdapter() Get the associated ResourceAdapter object.
void | setResourceAdapter(ResourceAdapter ra) Associate this object with a ResourceAdapter object.

Method Detail

getResourceAdapter

ResourceAdapter getResourceAdapter()
Get the associated ResourceAdapter object.

Returns:
the associated ResourceAdapter object.

setResourceAdapter

void setResourceAdapter(ResourceAdapter ra)
                        throws ResourceException
Associate this object with a ResourceAdapter object. Note, this method must be called exactly once. That is, the association must not change during the lifetime of this object.

Parameters:
ra - ResourceAdapter object to be associated with.
Throws:
ResourceException - generic exception.
ResourceAdapterInternalException - resource adapter related error condition.
IllegalStateException - indicates that this object is in an illegal state for the method invocation. For example, this occurs when this method is called more than once on the same object.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResourceAdapterInternalException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class ResourceAdapterInternalException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.ResourceAdapterInternalException
All Implemented Interfaces:
Serializable
public class ResourceAdapterInternalException
extends ResourceException

A ResourceAdapterInternalException indicates any system-level error conditions related to a resource adapter. The common conditions indicated by this exception type are:

  • Invalid configuration for creation of a new physical connection. An example is invalid server name for a target EIS instance.
  • Failure to create a physical connection to a EIS instance due to communication protocol error or any resource adapter implementation specific error.
  • Error conditions internal to resource adapter implementation.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
ResourceAdapterInternalException()
Constructs a new instance with null as its detail message.
ResourceAdapterInternalException(String message)
Constructs a new instance with the specified detail message.
ResourceAdapterInternalException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
ResourceAdapterInternalException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
ResourceAdapterInternalException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResourceAdapterInternalException

public ResourceAdapterInternalException()
Constructs a new instance with null as its detail message.

ResourceAdapterInternalException

public ResourceAdapterInternalException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

ResourceAdapterInternalException

public ResourceAdapterInternalException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

ResourceAdapterInternalException

public ResourceAdapterInternalException(String message,
                                        Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

ResourceAdapterInternalException

public ResourceAdapterInternalException(String message,
                                        String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResourceAllocationException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class ResourceAllocationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.ResourceAllocationException
All Implemented Interfaces:
Serializable
public class ResourceAllocationException
extends ResourceException

A ResourceAllocationException can be thrown by an application server or resource adapter to indicate any failure to allocate system resources (example: threads, physical connections). An example is error condition when an upper bound is reached on the maximum number of physical connections that can be managed by an application server specific connection pool.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
ResourceAllocationException()
Constructs a new instance with null as its detail message.
ResourceAllocationException(String message)
Constructs a new instance with the specified detail message.
ResourceAllocationException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
ResourceAllocationException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
ResourceAllocationException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResourceAllocationException

public ResourceAllocationException()
Constructs a new instance with null as its detail message.

ResourceAllocationException

public ResourceAllocationException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

ResourceAllocationException

public ResourceAllocationException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

ResourceAllocationException

public ResourceAllocationException(String message,
                                   Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

ResourceAllocationException

public ResourceAllocationException(String message,
                                   String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


security

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.resource.spi.security

The javax.resource.spi.security package contains APIs for the security management contract.

See:
Description

Interface Summary
GenericCredential Deprecated. The preferred way to represent generic credential information is via the org.ietf.jgss.GSSCredential interface in J2SE Version 1.4, which provides similar functionality.

Class Summary
PasswordCredential The class PasswordCredential acts as a holder for username and password.

Package javax.resource.spi.security Description

The javax.resource.spi.security package contains APIs for the security management contract.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.resource.spi.security Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.resource.spi.security

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.resource.spi.security.PasswordCredential (implements java.io.Serializable)

Interface Hierarchy

  • javax.resource.spi.security.GenericCredential
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


GenericCredential

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.security
Interface GenericCredential

Deprecated. The preferred way to represent generic credential information is via the org.ietf.jgss.GSSCredential interface in J2SE Version 1.4, which provides similar functionality.

public interface GenericCredential

The interface javax.resource.spi.security.GenericCredential defines a security mechanism independent interface for accessing security credential of a resource principal.

The GenericCredential interface provides a Java wrapper over an underlying mechanism specific representation of a security credential. For example, the GenericCredential interface can be used to wrap Kerberos credentials.

The connector architecture does not define any standard format and requirements for security mechanism specific credentials. For example, a security credential wrapped by a GenericCredential interface can have a native representation specific to an operating system.

The GenericCredential interface enables a resource adapter to extract information about a security credential. The resource adapter can then manage EIS sign-on for a resource principal by either:

  • using the credentials in an EIS specific manner if the underlying EIS supports the security mechanism type represented by the GenericCredential instance, or,
  • using GSS-API if the resource adapter and underlying EIS instance support GSS-API.

Since:
0.7
Version:
0.7
Author:
Rahul Sharma
See Also:
Subject, Principal

Method Summary
boolean | equals(Object another) Deprecated. Tests if this GenericCredential instance refers to the same entity as the supplied object.
byte[] | getCredentialData() Deprecated. Gets security data for a specific security mechanism represented by the GenericCredential.
String | getMechType() Deprecated. Returns the mechanism type for the GenericCredential instance.
String | getName() Deprecated. Returns the name of the resource principal associated with a GenericCredential instance.
int | hashCode() Deprecated. Returns the hash code for this GenericCredential

Method Detail

getName

String getName()
Deprecated.
Returns the name of the resource principal associated with a GenericCredential instance.

Returns:
Name of the principal

getMechType

String getMechType()
Deprecated.
Returns the mechanism type for the GenericCredential instance. The mechanism type definition for GenericCredential should be consistent with the Object Identifier (OID) based representation specified in the GSS specification. In the GenericCredential interface, the mechanism type is returned as a stringified representation of the OID specification.

Returns:
mechanism type

getCredentialData

byte[] getCredentialData()
                         throws SecurityException
Deprecated.
Gets security data for a specific security mechanism represented by the GenericCredential. An example is authentication data required for establishing a secure association with an EIS instance on behalf of the associated resource principal.

The getCredentialData method returns the credential representation as an array of bytes. Note that the connector architecture does not define any standard format for the returned credential data.

Returns:
credential representation as an array of bytes.
Throws:
SecurityException - Failed operation due to security related error condition

equals

boolean equals(Object another)
Deprecated.
Tests if this GenericCredential instance refers to the same entity as the supplied object. The two credentials must be acquired over the same mechanisms and must refer to the same principal. Returns true if the two GenericCredentials refer to the same entity; false otherwise.

Overrides:
equals in class Object

hashCode

int hashCode()
Deprecated.
Returns the hash code for this GenericCredential

Overrides:
hashCode in class Object
Returns:
hash code for this GenericCredential
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PasswordCredential

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.security
Class PasswordCredential

java.lang.Object
    extended by  javax.resource.spi.security.PasswordCredential
All Implemented Interfaces:
Serializable
public final class PasswordCredential
extends Object
implements Serializable

The class PasswordCredential acts as a holder for username and password.

Since:
0.6
Version:
0.6
Author:
Rahul Sharma
See Also:
ManagedConnectionFactory, Serialized Form

Constructor Summary
PasswordCredential(String userName, char[] password)
Creates a new PasswordCredential object from the given user name and password.
Method Summary
boolean | equals(Object other) Compares this PasswordCredential with the specified object for equality.
ManagedConnectionFactory | getManagedConnectionFactory() Gets the target ManagedConnectionFactory for which the user name and password has been set by the application server.
char[] | getPassword() Returns the user password.
String | getUserName() Returns the user name.
int | hashCode() Returns the hash code for this PasswordCredential
void | setManagedConnectionFactory(ManagedConnectionFactory mcf) Sets the target ManagedConenctionFactory instance for which the user name and password has been set by the application server.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PasswordCredential

public PasswordCredential(String userName,
                          char[] password)
Creates a new PasswordCredential object from the given user name and password.

Note that the given user password is cloned before it is stored in the new PasswordCredential object.

Parameters:
userName - the user name
password - the user's password
Method Detail

getUserName

public String getUserName()
Returns the user name.

Returns:
the user name

getPassword

public char[] getPassword()
Returns the user password.

Note that this method returns a reference to the password. It is the caller's responsibility to zero out the password information after it is no longer needed.

Returns:
the password

getManagedConnectionFactory

public ManagedConnectionFactory getManagedConnectionFactory()
Gets the target ManagedConnectionFactory for which the user name and password has been set by the application server. A ManagedConnection- Factory uses this field to find out whether PasswordCredential should be used by it for sign-on to the target EIS instance.

Returns:
ManagedConnectionFactory instance for which user name and password have been specified

setManagedConnectionFactory

public void setManagedConnectionFactory(ManagedConnectionFactory mcf)
Sets the target ManagedConenctionFactory instance for which the user name and password has been set by the application server.

Parameters:
mcf - ManagedConnectionFactory instance for which user name and password have been specified

equals

public boolean equals(Object other)
Compares this PasswordCredential with the specified object for equality. The two PasswordCredential instances are the same if they are equal in username and password.

Overrides:
equals in class Object
Parameters:
other - Object to which PasswordCredential is to be compared
Returns:
true if and if the specified object is a PasswordCredential whose username and password are equal to this instance.

hashCode

public int hashCode()
Returns the hash code for this PasswordCredential

Overrides:
hashCode in class Object
Returns:
hash code for this PasswordCredential
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SecurityException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class SecurityException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.SecurityException
All Implemented Interfaces:
Serializable
public class SecurityException
extends ResourceException

A SecurityException indicates error conditions related to the security contract between an application server and resource adapter. The common error conditions represented by this exception are:

  • Invalid security information (represented as a Subject instance) passed across the security contract - for example, credentials have expired or have invalid format.
  • Lack of support for a specific security mechanism in an EIS or resource adapter.
  • Failure to create a connection to an EIS because of failed authentication or authorization.
  • Failure to authenticate a resource principal to an EIS instance or failure to establish a secure association with an underlying EIS instance.
  • Access control exception to indicate that a requested access to an EIS resource or a request to create a new connection is denied.

Version:
1.0
Author:
Rahul Sharma, Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
SecurityException()
Constructs a new instance with null as its detail message.
SecurityException(String message)
Constructs a new instance with the specified detail message.
SecurityException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
SecurityException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
SecurityException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SecurityException

public SecurityException()
Constructs a new instance with null as its detail message.

SecurityException

public SecurityException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

SecurityException

public SecurityException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

SecurityException

public SecurityException(String message,
                         Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

SecurityException

public SecurityException(String message,
                         String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SharingViolationException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class SharingViolationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.SharingViolationException
All Implemented Interfaces:
Serializable
public class SharingViolationException
extends ResourceException

This is thrown to indicate a connection sharing violation.

This may be thrown by a resource adapter when an application uses a shareable connection in an unshareable manner.

Version:
1.0
Author:
Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
SharingViolationException()
Constructs a new instance with null as its detail message.
SharingViolationException(String message)
Constructs a new instance with the specified detail message.
SharingViolationException(String message, String errorCode)
Constructs a new throwable with the specified detail message and error code.
SharingViolationException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
SharingViolationException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SharingViolationException

public SharingViolationException()
Constructs a new instance with null as its detail message.

SharingViolationException

public SharingViolationException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

SharingViolationException

public SharingViolationException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

SharingViolationException

public SharingViolationException(String message,
                                 Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

SharingViolationException

public SharingViolationException(String message,
                                 String errorCode)
Constructs a new throwable with the specified detail message and error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UnavailableException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Class UnavailableException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.UnavailableException
All Implemented Interfaces:
Serializable
public class UnavailableException
extends ResourceException

This is thrown to indicate that a service is unavailable.

Version:
1.0
Author:
Ram Jeyaraman
See Also:
Serialized Form

Constructor Summary
UnavailableException()
Constructs a new instance with null as its detail message.
UnavailableException(String message)
Constructs a new instance with the specified detail message.
UnavailableException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
UnavailableException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
UnavailableException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnavailableException

public UnavailableException()
Constructs a new instance with null as its detail message.

UnavailableException

public UnavailableException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

UnavailableException

public UnavailableException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

UnavailableException

public UnavailableException(String message,
                            Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

UnavailableException

public UnavailableException(String message,
                            String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValidatingManagedConnectionFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface ValidatingManagedConnectionFactory

public interface ValidatingManagedConnectionFactory

This interface is implemented by a ManagedConnectionFactory instance that supports the ability to validate ManagedConnection objects.

This may be used by the application server to prune invalid ManagedConnection objects from its connection pool.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 Set getInvalidConnections(Set connectionSet)
This method returns a set of invalid ManagedConnection objects chosen from a specified set of ManagedConnection objects.

Method Detail

getInvalidConnections

Set getInvalidConnections(Set connectionSet)
                          throws ResourceException
This method returns a set of invalid ManagedConnection objects chosen from a specified set of ManagedConnection objects.

Parameters:
connectionSet - a set of ManagedConnection objects that need to be validated.
Returns:
a set of invalid ManagedConnection objects.
Throws:
ResourceException - generic exception.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


work

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.resource.spi.work

This package contains APIs for the work management contract.

See:
Description

Interface Summary
Work | This models a Work instance that would be executed by a WorkManager upon submission.
WorkListener | This models a WorkListener instance which would be notified by the WorkManager when the various Work processing events (work accepted, work rejected, work started, work completed) occur.
WorkManager | This interface models a WorkManager which provides a facility to submit Work instances for execution.

Class Summary
ExecutionContext | This class models an execution context (transaction, security, etc) with which the Work instance must be executed.
WorkAdapter | This class is provided as a convenience for easily creating WorkListener instances by extending this class and overriding only those methods of interest.
WorkEvent | This class models the various events that occur during the processing of a Work instance.

Exception Summary
WorkCompletedException | This exception is thrown by a WorkManager to indicate that a submitted Work instance has completed with an exception.
WorkException | A common base class for all Work processing related exceptions.
WorkRejectedException | This exception is thrown by a WorkManager to indicate that a submitted Work instance has been rejected.

Package javax.resource.spi.work Description

This package contains APIs for the work management contract.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.resource.spi.work Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.resource.spi.work

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.resource.spi.work.WorkEvent
    • javax.resource.spi.work.ExecutionContext
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.resource.ResourceException
          • javax.resource.spi.work.WorkException
            • javax.resource.spi.work.WorkCompletedException
            • javax.resource.spi.work.WorkRejectedException
    • javax.resource.spi.work.WorkAdapter (implements javax.resource.spi.work.WorkListener)

Interface Hierarchy

  • java.util.EventListener
    • javax.resource.spi.work.WorkListener
  • java.lang.Runnable
    • javax.resource.spi.work.Work
  • javax.resource.spi.work.WorkManager
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ExecutionContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Class ExecutionContext

java.lang.Object
    extended by  javax.resource.spi.work.ExecutionContext

public class ExecutionContext
extends Object

This class models an execution context (transaction, security, etc) with which the Work instance must be executed. This class is provided as a convenience for easily creating ExecutionContext instances by extending this class and overriding only those methods of interest.

Some reasons why it is better for ExecutionContext to be a class rather than an interface:

  • There is no need for a resource adapter to implement this class. It only needs to implement the context information like transaction, etc.
  • The resource adapter code does not have to change when the ExecutionContext class evolves. For example, more context types could be added to the ExecutionContext class (in the future) without forcing resource adapter implementations to change.

Version:
1.0
Author:
Ram Jeyaraman

Constructor Summary
ExecutionContext()
Method Summary
long | getTransactionTimeout() Get the transaction timeout value for a imported transaction.
Xid | getXid()
void | setTransactionTimeout(long timeout) Set the transaction timeout value for a imported transaction.
void | setXid(Xid xid) set a transaction context.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExecutionContext

public ExecutionContext()
Method Detail

setXid

public void setXid(Xid xid)
set a transaction context.

Parameters:
xid - transaction context.

getXid

public Xid getXid()

setTransactionTimeout

public void setTransactionTimeout(long timeout)
                           throws NotSupportedException
Set the transaction timeout value for a imported transaction.

Parameters:
timeout - transaction timeout value in seconds. Only positive non-zero values are accepted. Other values are illegal and are rejected with a NotSupportedException.
Throws:
NotSupportedException - thrown to indicate an illegal timeout value.

getTransactionTimeout

public long getTransactionTimeout()
Get the transaction timeout value for a imported transaction.

Returns:
the specified transaction timeout value in seconds. When no timeout value or an illegal timeout value had been specified, a value of -1 (WorkManager.UNKNOWN) is returned; such a transaction is excluded from regular timeout processing.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Work

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Interface Work

All Superinterfaces:
Runnable
public interface Work
extends Runnable

This models a Work instance that would be executed by a WorkManager upon submission.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
 void release()
The WorkManager might call this method to hint the active Work instance to complete execution as soon as possible.
Methods inherited from interface java.lang.Runnable
run

Method Detail

release

void release()
The WorkManager might call this method to hint the active Work instance to complete execution as soon as possible. This would be called on a seperate thread other than the one currently executing the Work instance.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WorkAdapter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Class WorkAdapter

java.lang.Object
    extended by  javax.resource.spi.work.WorkAdapter
All Implemented Interfaces:
EventListener, WorkListener
public class WorkAdapter
extends Object
implements WorkListener

This class is provided as a convenience for easily creating WorkListener instances by extending this class and overriding only those methods of interest.

Version:
1.0
Author:
Ram Jeyaraman

Constructor Summary
WorkAdapter()
Method Summary
void | workAccepted(WorkEvent e) Invoked when a Work instance has been accepted.
void | workCompleted(WorkEvent e) Invoked when a Work instance has completed execution.
void | workRejected(WorkEvent e) Invoked when a Work instance has been rejected.
void | workStarted(WorkEvent e) Invoked when a Work instance has started execution.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WorkAdapter

public WorkAdapter()
Method Detail

workAccepted

public void workAccepted(WorkEvent e)
Invoked when a Work instance has been accepted.

Specified by:
workAccepted in interface WorkListener

workRejected

public void workRejected(WorkEvent e)
Invoked when a Work instance has been rejected.

Specified by:
workRejected in interface WorkListener

workStarted

public void workStarted(WorkEvent e)
Invoked when a Work instance has started execution. This only means that a thread has been allocated.

Specified by:
workStarted in interface WorkListener

workCompleted

public void workCompleted(WorkEvent e)
Invoked when a Work instance has completed execution.

Specified by:
workCompleted in interface WorkListener
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WorkCompletedException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Class WorkCompletedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.work.WorkException
                    extended by  javax.resource.spi.work.WorkCompletedException
All Implemented Interfaces:
Serializable
public class WorkCompletedException
extends WorkException

This exception is thrown by a WorkManager to indicate that a submitted Work instance has completed with an exception.

This could be thrown only after the execution of a Work instance has started (that is, after a thread has been allocated for Work execution). The allocated thread sets up an execution context (if it has been specified), and then calls Work.run().

Any exception thrown during execution context setup or during Work execution (that is, during Work.run()) is chained within this exception.

An associated error code indicates the nature of the error condition. Possible error codes are WorkException.TX_RECREATE_FAILED, WorkException.TX_CONCURRENT_WORK_DISALLOWED or WorkException.UNDEFINED.

Version:
1.0
Author:
Ram Jeyaraman
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.resource.spi.work.WorkException
INTERNAL, START_TIMED_OUT, TX_CONCURRENT_WORK_DISALLOWED, TX_RECREATE_FAILED, UNDEFINED
Constructor Summary
WorkCompletedException()
Constructs a new instance with null as its detail message.
WorkCompletedException(String message)
Constructs a new instance with the specified detail message.
WorkCompletedException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
WorkCompletedException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
WorkCompletedException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkCompletedException

public WorkCompletedException()
Constructs a new instance with null as its detail message.

WorkCompletedException

public WorkCompletedException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

WorkCompletedException

public WorkCompletedException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

WorkCompletedException

public WorkCompletedException(String message,
                              Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

WorkCompletedException

public WorkCompletedException(String message,
                              String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WorkEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Class WorkEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.resource.spi.work.WorkEvent
All Implemented Interfaces:
Serializable
public class WorkEvent
extends EventObject

This class models the various events that occur during the processing of a Work instance.

Version:
1.0
Author:
Ram Jeyaraman
See Also:
Serialized Form

Field Summary
static int | WORK_ACCEPTED Indicates Work instance has been accepted.
static int | WORK_COMPLETED Indicates Work instance has completed execution.
static int | WORK_REJECTED Indicates Work instance has been rejected.
static int | WORK_STARTED Indicates Work instance has started execution.
Fields inherited from class java.util.EventObject
source
Constructor Summary
WorkEvent(Object source, int type, Work work, WorkException exc)
Constructor.
WorkEvent(Object source, int type, Work work, WorkException exc, long startDuration)
Constructor.
Method Summary
WorkException | getException() Return the WorkException.
long | getStartDuration() Return the start interval duration.
int | getType() Return the type of this event.
Work | getWork() Return the Work instance which is the cause of the event.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

WORK_ACCEPTED

public static final int WORK_ACCEPTED
Indicates Work instance has been accepted.

See Also:
Constant Field Values

WORK_REJECTED

public static final int WORK_REJECTED
Indicates Work instance has been rejected.

See Also:
Constant Field Values

WORK_STARTED

public static final int WORK_STARTED
Indicates Work instance has started execution.

See Also:
Constant Field Values

WORK_COMPLETED

public static final int WORK_COMPLETED
Indicates Work instance has completed execution.

See Also:
Constant Field Values
Constructor Detail

WorkEvent

public WorkEvent(Object source,
                 int type,
                 Work work,
                 WorkException exc)
Constructor.

Parameters:
source - The object on which the event initially occurred.
type - The event type.
work - The Work object on which the event occured.
exc - The exception that occured during Work processing.

WorkEvent

public WorkEvent(Object source,
                 int type,
                 Work work,
                 WorkException exc,
                 long startDuration)
Constructor.

Parameters:
source - The object on which the event initially occurred.
type - The event type.
work - The Work object on which the event occured.
exc - The exception that occured during Work processing.
startDuration - The start delay duration (in milliseconds).
Method Detail

getType

public int getType()
Return the type of this event.

Returns:
the event type.

getWork

public Work getWork()
Return the Work instance which is the cause of the event.

Returns:
the Work instance.

getStartDuration

public long getStartDuration()
Return the start interval duration.

Returns:
the time elapsed (in milliseconds) since the Work was accepted, until the Work execution started. Note, this does not offer real-time guarantees. It is valid to return -1, if the actual start interval duration is unknown.

getException

public WorkException getException()
Return the WorkException. The actual WorkException subtype returned depends on the type of the event.

Returns:
a WorkRejectedException or a WorkCompletedException, if any.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WorkException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Class WorkException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.work.WorkException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
WorkCompletedException, WorkRejectedException
public class WorkException
extends ResourceException

A common base class for all Work processing related exceptions.

Version:
1.0
Author:
Ram Jeyaraman
See Also:
Serialized Form

Field Summary
static String | INTERNAL Indicates an internal error condition.
static String | START_TIMED_OUT Indicates start timeout expiration.
static String | TX_CONCURRENT_WORK_DISALLOWED Indicates that concurrent work within a transaction is disallowed.
static String | TX_RECREATE_FAILED Indicates a failure in recreating the specified transaction context.
static String | UNDEFINED Undefined error code.
Constructor Summary
WorkException()
Constructs a new instance with null as its detail message.
WorkException(String message)
Constructs a new instance with the specified detail message.
WorkException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
WorkException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
WorkException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

INTERNAL

public static final String INTERNAL
Indicates an internal error condition.

See Also:
Constant Field Values

UNDEFINED

public static final String UNDEFINED
Undefined error code.

See Also:
Constant Field Values

START_TIMED_OUT

public static final String START_TIMED_OUT
Indicates start timeout expiration.

See Also:
Constant Field Values

TX_CONCURRENT_WORK_DISALLOWED

public static final String TX_CONCURRENT_WORK_DISALLOWED
Indicates that concurrent work within a transaction is disallowed. That is, there is already another Work instance associated with the specified transaction context.

See Also:
Constant Field Values

TX_RECREATE_FAILED

public static final String TX_RECREATE_FAILED
Indicates a failure in recreating the specified transaction context.

See Also:
Constant Field Values
Constructor Detail

WorkException

public WorkException()
Constructs a new instance with null as its detail message.

WorkException

public WorkException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

WorkException

public WorkException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

WorkException

public WorkException(String message,
                     Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

WorkException

public WorkException(String message,
                     String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WorkListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Interface WorkListener

All Superinterfaces:
EventListener
All Known Implementing Classes:
WorkAdapter
public interface WorkListener
extends EventListener

This models a WorkListener instance which would be notified by the WorkManager when the various Work processing events (work accepted, work rejected, work started, work completed) occur. The WorkListener instance must not make any thread assumptions and must be thread-safe ie., a notification could occur from any arbitrary thread. Further, it must not make any assumptions on the ordering of notifications.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
void | workAccepted(WorkEvent e) Invoked when a Work instance has been accepted.
void | workCompleted(WorkEvent e) Invoked when a Work instance has completed execution.
void | workRejected(WorkEvent e) Invoked when a Work instance has been rejected.
void | workStarted(WorkEvent e) Invoked when a Work instance has started execution.

Method Detail

workAccepted

void workAccepted(WorkEvent e)
Invoked when a Work instance has been accepted.

workRejected

void workRejected(WorkEvent e)
Invoked when a Work instance has been rejected.

workStarted

void workStarted(WorkEvent e)
Invoked when a Work instance has started execution. This only means that a thread has been allocated.

workCompleted

void workCompleted(WorkEvent e)
Invoked when a Work instance has completed execution.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WorkManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Interface WorkManager

public interface WorkManager

This interface models a WorkManager which provides a facility to submit Work instances for execution. This frees the user from having to create Java threads directly to do work. Further, this allows efficient pooling of thread resources and more control over thread usage. The various stages in Work processing are:

  • work submit: A Work instance is being submitted for execution. The Work instance could either be accepted or rejected with a WorkRejectedException set to an appropriate error code.
  • work accepted: The submitted Work instance has been accepted. The accepted Work instance could either start execution or could be rejected again with a WorkRejectedException set to an appropriate error code. There is no guarantee on when the execution would start unless a start timeout duration is specified. When a start timeout is specified, the Work execution must be started within the specified duration (not a real-time guarantee), failing which a WorkRejectedException set to an error code (WorkRejected.TIMED_OUT) is thrown.
  • work rejected: The Work instance has been rejected. The Work instance could be rejected during Work submittal or after the Work instance has been accepted (but before Work instance starts execution). The rejection could be due to internal factors or start timeout expiration. A WorkRejectedException with an appropriate error code (indicates the reason) is thrown in both cases.
  • work started: The execution of the Work instance has started. This means that a thread has been allocated for its execution. But this does not guarantee that the allocated thread has been scheduled to run on a CPU resource. Once execution is started, the allocated thread sets up an appropriate execution context (transaction , security, etc) and calls Work.run(). Note, any exception thrown during execution context setup or Work.run() leads to completion of processing.
  • work completed: The execution of the Work has been completed. The execution could complete with or without an exception. The WorkManager catches any exception thrown during Work processing (which includes execution context setup), and wraps it with a WorkCompletedException.

Version:
1.0
Author:
Ram Jeyaraman

Field Summary
static long | IMMEDIATE A constant to indicate timeout duration.
static long | INDEFINITE A constant to indicate timeout duration.
static long | UNKNOWN A constant to indicate an unknown start delay duration or other unknown values.
Method Summary
void | doWork(Work work) Accepts a Work instance for processing.
void | doWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener) Accepts a Work instance for processing.
void | scheduleWork(Work work) Accepts a Work instance for processing.
void | scheduleWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener) Accepts a Work instance for processing.
long | startWork(Work work) Accepts a Work instance for processing.
long | startWork(Work work, long startTimeout, ExecutionContext execContext, WorkListener workListener) Accepts a Work instance for processing.

Field Detail

IMMEDIATE

static final long IMMEDIATE
A constant to indicate timeout duration. A zero timeout value indicates an action be performed immediately.

See Also:
Constant Field Values

INDEFINITE

static final long INDEFINITE
A constant to indicate timeout duration. A maximum timeout value indicates that an action be performed arbitrarily without any time constraint.

See Also:
Constant Field Values

UNKNOWN

static final long UNKNOWN
A constant to indicate an unknown start delay duration or other unknown values.

See Also:
Constant Field Values
Method Detail

doWork

void doWork(Work work)
            throws WorkException
Accepts a Work instance for processing. This call blocks until the Work instance completes execution. There is no guarantee on when the accepted Work instance would start execution ie., there is no time constraint to start execution.

Parameters:
work - The unit of work to be done. Could be long or short-lived.
Throws:
WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors.
WorkCompletedException - indicates that a Work instance has completed execution with an exception.
WorkException

doWork

void doWork(Work work,
            long startTimeout,
            ExecutionContext execContext,
            WorkListener workListener)
            throws WorkException
Accepts a Work instance for processing. This call blocks until the Work instance completes execution.

Parameters:
work - The unit of work to be done. Could be long or short-lived.
startTimeout - a time duration (in milliseconds) within which the execution of the Work instance must start. Otherwise, the Work instance is rejected with a WorkRejectedException set to an appropriate error code (WorkRejectedException.TIMED_OUT). Note, this does not offer real-time guarantees.
execContext - an object containing the execution context with which the submitted Work instance must be executed.
workListener - an object which would be notified when the various Work processing events (work accepted, work rejected, work started, work completed) occur.
Throws:
WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors or start timeout expiration.
WorkCompletedException - indicates that a Work instance has completed execution with an exception.
WorkException

startWork

long startWork(Work work)
               throws WorkException
Accepts a Work instance for processing. This call blocks until the Work instance starts execution but not until its completion. There is no guarantee on when the accepted Work instance would start execution ie., there is no time constraint to start execution.

Parameters:
work - The unit of work to be done. Could be long or short-lived.
Returns:
the time elapsed (in milliseconds) from Work acceptance until start of execution. Note, this does not offer real-time guarantees. It is valid to return -1, if the actual start delay duration is unknown.
Throws:
WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors.
WorkException

startWork

long startWork(Work work,
               long startTimeout,
               ExecutionContext execContext,
               WorkListener workListener)
               throws WorkException
Accepts a Work instance for processing. This call blocks until the Work instance starts execution but not until its completion. There is no guarantee on when the accepted Work instance would start execution ie., there is no time constraint to start execution.

Parameters:
work - The unit of work to be done. Could be long or short-lived.
startTimeout - a time duration (in milliseconds) within which the execution of the Work instance must start. Otherwise, the Work instance is rejected with a WorkRejectedException set to an appropriate error code (WorkRejectedException.TIMED_OUT). Note, this does not offer real-time guarantees.
execContext - an object containing the execution context with which the submitted Work instance must be executed.
workListener - an object which would be notified when the various Work processing events (work accepted, work rejected, work started, work completed) occur.
Returns:
the time elapsed (in milliseconds) from Work acceptance until start of execution. Note, this does not offer real-time guarantees. It is valid to return -1, if the actual start delay duration is unknown.
Throws:
WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors or start timeout expiration.
WorkException

scheduleWork

void scheduleWork(Work work)
                  throws WorkException
Accepts a Work instance for processing. This call does not block and returns immediately once a Work instance has been accepted for processing. There is no guarantee on when the submitted Work instance would start execution ie., there is no time constraint to start execution.

Parameters:
work - The unit of work to be done. Could be long or short-lived.
Throws:
WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors.
WorkException

scheduleWork

void scheduleWork(Work work,
                  long startTimeout,
                  ExecutionContext execContext,
                  WorkListener workListener)
                  throws WorkException
Accepts a Work instance for processing. This call does not block and returns immediately once a Work instance has been accepted for processing.

Parameters:
work - The unit of work to be done. Could be long or short-lived.
startTimeout - a time duration (in milliseconds) within which the execution of the Work instance must start. Otherwise, the Work instance is rejected with a WorkRejectedException set to an appropriate error code (WorkRejectedException.TIMED_OUT). Note, this does not offer real-time guarantees.
execContext - an object containing the execution context with which the submitted Work instance must be executed.
workListener - an object which would be notified when the various Work processing events (work accepted, work rejected, work started, work completed) occur.
Throws:
WorkRejectedException - indicates that a Work instance has been rejected from further processing. This can occur due to internal factors.
WorkException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WorkRejectedException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi.work
Class WorkRejectedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.resource.ResourceException
                extended by  javax.resource.spi.work.WorkException
                    extended by  javax.resource.spi.work.WorkRejectedException
All Implemented Interfaces:
Serializable
public class WorkRejectedException
extends WorkException

This exception is thrown by a WorkManager to indicate that a submitted Work instance has been rejected. The rejection could be due to internal factors or start timeout expiration.

This could be thrown only before the execution of a Work instance starts (that is, before a thread has been allocated for Work execution).

An associated error code indicates the nature of the error condition. Possible error codes are WorkException.START_TIMED_OUT, WorkException.INTERNAL or WorkException.UNDEFINED.

Version:
1.0
Author:
Ram Jeyaraman
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.resource.spi.work.WorkException
INTERNAL, START_TIMED_OUT, TX_CONCURRENT_WORK_DISALLOWED, TX_RECREATE_FAILED, UNDEFINED
Constructor Summary
WorkRejectedException()
Constructs a new instance with null as its detail message.
WorkRejectedException(String message)
Constructs a new instance with the specified detail message.
WorkRejectedException(String message, String errorCode)
Constructs a new throwable with the specified detail message and an error code.
WorkRejectedException(String message, Throwable cause)
Constructs a new throwable with the specified detail message and cause.
WorkRejectedException(Throwable cause)
Constructs a new throwable with the specified cause.
Method Summary
Methods inherited from class javax.resource.ResourceException
getErrorCode, getLinkedException, getMessage, setErrorCode, setLinkedException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

WorkRejectedException

public WorkRejectedException()
Constructs a new instance with null as its detail message.

WorkRejectedException

public WorkRejectedException(String message)
Constructs a new instance with the specified detail message.

Parameters:
message - the detail message.

WorkRejectedException

public WorkRejectedException(Throwable cause)
Constructs a new throwable with the specified cause.

Parameters:
cause - a chained exception of type Throwable.

WorkRejectedException

public WorkRejectedException(String message,
                             Throwable cause)
Constructs a new throwable with the specified detail message and cause.

Parameters:
message - the detail message.
cause - a chained exception of type Throwable.

WorkRejectedException

public WorkRejectedException(String message,
                             String errorCode)
Constructs a new throwable with the specified detail message and an error code.

Parameters:
message - a description of the exception.
errorCode - a string specifying the vendor specific error code.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XATerminator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.resource.spi
Interface XATerminator

public interface XATerminator

The XATerminator interface is used for transaction completion and crash recovery flows.

Version:
1.0
Author:
Ram Jeyaraman

Method Summary
void | commit(Xid xid, boolean onePhase) Commits the global transaction specified by xid.
void | forget(Xid xid) Tells the resource manager to forget about a heuristically completed transaction branch.
int | prepare(Xid xid) Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
Xid[] | recover(int flag) Obtains a list of prepared transaction branches from a resource manager.
void | rollback(Xid xid) Informs the resource manager to roll back work done on behalf of a transaction branch.

Method Detail

commit

void commit(Xid xid,
            boolean onePhase)
            throws XAException
Commits the global transaction specified by xid.

Parameters:
xid - A global transaction identifier
onePhase - If true, the resource manager should use a one-phase commit protocol to commit the work done on behalf of xid.
Throws:
XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

If the resource manager did not commit the transaction and the parameter onePhase is set to true, the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

forget

void forget(Xid xid)
            throws XAException
Tells the resource manager to forget about a heuristically completed transaction branch.

Parameters:
xid - A global transaction identifier.
Throws:
XAException - An error has occurred. Possible exception values are XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

prepare

int prepare(Xid xid)
            throws XAException
Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.

Parameters:
xid - A global transaction identifier.
Returns:
A value indicating the resource manager's vote on the outcome of the transaction. The possible values are: XA_RDONLY or XA_OK. These constants are defined in javax.transaction.xa.XAResource interface. If the resource manager wants to roll back the transaction, it should do so by raising an appropriate XAException in the prepare method.
Throws:
XAException - An error has occurred. Possible exception values are: XA_RB*, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

recover

Xid[] recover(int flag)
              throws XAException
Obtains a list of prepared transaction branches from a resource manager. The transaction manager calls this method during recovery to obtain the list of transaction branches that are currently in prepared or heuristically completed states.

Parameters:
flag - One of TMSTARTRSCAN, TMENDRSCAN, TMNOFLAGS. TMNOFLAGS must be used when no other flags are set in the parameter. These constants are defined in javax.transaction.xa.XAResource interface.
Returns:
The resource manager returns zero or more XIDs of the transaction branches that are currently in a prepared or heuristically completed state. If an error occurs during the operation, the resource manager should throw the appropriate XAException.
Throws:
XAException - An error has occurred. Possible values are XAER_RMERR, XAER_RMFAIL, XAER_INVAL, and XAER_PROTO.

rollback

void rollback(Xid xid)
              throws XAException
Informs the resource manager to roll back work done on behalf of a transaction branch.

Parameters:
xid - A global transaction identifier.
Throws:
XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

If the transaction branch is already marked rollback-only the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


jacc

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.security.jacc

This package contains the Java Authorization Contract for Containers API

See:
Description

Interface Summary
PolicyConfiguration | The methods of this interface are used by containers to create policy statements in a Policy provider.
PolicyContextHandler | This interface defines the methods that must be implemented by handlers that are to be registered and activated by the PolicyContext class.

Class Summary
EJBMethodPermission | Class for EJB method permissions.
EJBRoleRefPermission | Class for EJB isCallerInRole (String reference) permissions.
PolicyConfigurationFactory | Abstract factory and finder class for obtaining the instance of the class that implements the PolicyConfigurationFactory of a provider.
PolicyContext | This utility class is used by containers to communicate policy context identifiers and other policy relevant context to Policy providers.
WebResourcePermission | Class for Servlet web resource permissions.
WebRoleRefPermission | Class for Servlet isUserInRole (String reference) permissions.
WebUserDataPermission | Class for Servlet Web user data permissions.

Exception Summary
PolicyContextException This checked exception is thrown by implementations of the javax.security.jacc.PolicyConfiguration Interface, the javax.security.jacc.PolicyConfigurationFactory abstract class, the javax.security.jacc.PolicyContext utility class, and implementations of the javax.security.jacc.PolicyContextException Interface.

Package javax.security.jacc Description

This package contains the Java Authorization Contract for Containers API

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.security.jacc Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.security.jacc

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • javax.security.jacc.EJBMethodPermission (implements java.io.Serializable)
      • javax.security.jacc.EJBRoleRefPermission (implements java.io.Serializable)
      • javax.security.jacc.WebResourcePermission (implements java.io.Serializable)
      • javax.security.jacc.WebRoleRefPermission (implements java.io.Serializable)
      • javax.security.jacc.WebUserDataPermission (implements java.io.Serializable)
    • javax.security.jacc.PolicyConfigurationFactory
    • javax.security.jacc.PolicyContext
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.security.jacc.PolicyContextException

Interface Hierarchy

  • javax.security.jacc.PolicyConfiguration
  • javax.security.jacc.PolicyContextHandler
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBMethodPermission

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class EJBMethodPermission

java.lang.Object
    extended by  java.security.Permission
        extended by  javax.security.jacc.EJBMethodPermission
All Implemented Interfaces:
Serializable, Guard
public final class EJBMethodPermission
extends Permission
implements Serializable

Class for EJB method permissions.

The name of an EJBMethodPermission contains the value of the ejb-name element in the application's deployment descriptor that identifies the target EJB.

The actions of an EJBMethodPermission identifies the methods of the EJB to which the permission applies.

Implementations of this class MAY implement newPermissionCollection or inherit its implementation from the super class.

Author:
Ron Monzillo, Gary Ellison
See Also:
Permission, Serialized Form

Constructor Summary
EJBMethodPermission(String name, String actions)
Creates a new EJBMethodPermission with the specified name and actions.
EJBMethodPermission(String EJBName, String methodInterface, Method method)
Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodInterface, and the Method object.
EJBMethodPermission(String EJBName, String methodName, String methodInterface, String[] methodParams)
Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodName, methodInterface, and methodParams.
Method Summary
boolean | equals(Object o) Checks two EJBMethodPermission objects for equality.
String | getActions() Returns a String containing a canonical representation of the actions of this EJBMethodPermission.
int | hashCode() Returns the hash code value for this EJBMethodPermission.
boolean | implies(Permission permission) Determines if the argument Permission is "implied by" this EJBMethodPermission.
Methods inherited from class java.security.Permission
checkGuard, getName, newPermissionCollection, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EJBMethodPermission

public EJBMethodPermission(String name,
                           String actions)
Creates a new EJBMethodPermission with the specified name and actions.

The name contains the value of the ejb-name element corresponding to an EJB in the application's deployment descriptor.

The actions contains a methodSpec. The syntax of the actions parameter is defined as follows:

      methodNameSpec ::= methodName | emptyString

      methodInterfaceName ::= String

      methodInterfaceSpec ::= methodInterfaceName | emptyString

      typeName ::= typeName | typeName []

      methodParams ::= typeName | methodParams comma typeName

      methodParamsSpec ::= emptyString | methodParams

      methodSpec ::= null |
           methodNameSpec |
           methodNameSpec comma methodInterfaceName |
           methodNameSpec comma methodInterfaceSpec comma methodParamsSpec

A MethodInterfaceName is a non-empty String and should contain a method-intf value as defined for use in EJB deployment descriptors. An implementation must be flexible such that it supports additional interface names especially if they are standardized by the EJB Specification. The EJB Specification currently defines the following method-intf values:

       { "Home", "LocalHome", "Remote", "Local", "ServiceEndpoint" }

A null or empty string methodSpec indicates that the permission applies to all methods of the EJB. A methodSpec with a methodNameSpec of the empty string matches all methods of the EJB that match the methodInterface and methodParams elements of the methodSpec.

A methodSpec with a methodInterfaceSpec of the empty string matches all methods of the EJB that match the methodNameSpec and methodParamsSpec elements of the methodSpec.

A methodSpec without a methodParamsSpec matches all methods of the EJB that match the methodNameSpec and methodInterface elements of the methodSpec.

The order of the typeNames in methodParams array must match the order of occurence of the corresponding parameters in the method signature of the target method(s). Each typeName in the methodParams must contain the canonical form of the corresponding parameter's typeName as defined by the getActions method. A methodSpec with an empty methodParamsSpec matches all 0 argument methods of the EJB that match the methodNameSpec and methodInterfaceSpec elements of the methodSpec.

Parameters:
name - of the EJB to which the permission pertains.

actions - identifies the methods of the EJB to which the permission pertains.

EJBMethodPermission

public EJBMethodPermission(String EJBName,
                           String methodName,
                           String methodInterface,
                           String[] methodParams)
Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodName, methodInterface, and methodParams.

Parameters:
EJBName - The string representation of the name of the EJB as it appears in the corresponding ejb-name element in the deployment descriptor.

methodName - A string that may be used to indicate the method of the EJB to which the permission pertains. A value of null or "" indicates that the permission pertains to all methods that match the other parameters of the permission specification without consideration of method name.

methodInterface - A string that may be used to specify the EJB interface to which the permission pertains. A value of null or "", indicates that the permission pertains to all methods that match the other parameters of the permission specification without consideration of the interface they occur on.

methodParams - An array of strings that may be used to specify (by typeNames) the parameter signature of the target methods. The order of the typeNames in methodParams array must match the order of occurence of the corresponding parameters in the method signature of the target method(s). Each typeName in the methodParams array must contain the canonical form of the corresponding parameter's typeName as defined by the getActions method. An empty methodParams array is used to represent a method signature with no arguments. A value of null indicates that the permission pertains to all methods that match the other parameters of the permission specification without consideration of method signature.

EJBMethodPermission

public EJBMethodPermission(String EJBName,
                           String methodInterface,
                           Method method)
Creates a new EJBMethodPermission with name corresponding to the EJBName and actions composed from methodInterface, and the Method object.

A container uses this constructor prior to checking if a caller has permission to call the method of an EJB.

Parameters:
EJBName - The string representation of the name of the EJB as it appears in the corresponding ejb-name element in the deployment descriptor.

methodInterface - A string that may be used to specify the EJB interface to which the permission pertains. A value of null or "", indicates that the permission pertains to all methods that match the other parameters of the permission specification without consideration of the interface they occur on.

method - an instance of the Java.lang.reflect.Method class corresponding to the method that the container is trying to determine whether the caller has permission to access. This value must not be null.
Method Detail

equals

public boolean equals(Object o)
Checks two EJBMethodPermission objects for equality. EJBMethodPermission objects are equivalent if they have case sensitive equivalent name and actions values.

Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

Specified by:
equals in class Permission
Parameters:
o - the EJBMethodPermission object being tested for equality with this EJBMethodPermission

Returns:
true if the argument EJBMethodPermission object is equivalent to this EJBMethodPermission.

getActions

public String getActions()
Returns a String containing a canonical representation of the actions of this EJBMethodPermission. The Canonical form of the actions of an EJBMethodPermission is described by the following syntax description.

      methodNameSpec ::= methodName | emptyString

      methodInterfaceName ::= String

      methodInterfaceSpec ::= methodInterfaceName | emptyString

      typeName ::= typeName | typeName []

      methodParams ::= typeName | methodParams comma typeName

      methodParamsSpec ::= emptyString | methodParams

      methodSpec ::= null |
           methodName |
           methodNameSpec comma methodInterfaceName |
           methodNameSpec comma methodInterfaceSpec comma methodParamsSpec

The canonical form of each typeName must begin with the fully qualified Java name of the corresponding parameter's type. The canonical form of a typeName for an array parameter is the fully qualified Java name of the array's component type followed by as many instances of the string "[]" as there are dimensions to the array. No additional characters (e.g. blanks) may occur in the canonical form.

A MethodInterfaceName is a non-empty String and should contain a method-intf value as defined for use in EJB deployment descriptors. An implementation must be flexible such that it supports additional interface names especially if they are standardized by the EJB Specification. The EJB Specification currently defines the following method-intf values:

       { "Home", "LocalHome", "Remote", "Local", "ServiceEndpoint" }

Specified by:
getActions in class Permission
Returns:
a String containing the canonicalized actions of this EJBMethodPermission.

hashCode

public int hashCode()
Returns the hash code value for this EJBMethodPermission. The properties of the returned hash code must be as follows:

  • During the lifetime of a Java application, the hashCode method must return the same integer value every time it is called on a EJBMethodPermission object. The value returned by hashCode for a particular EJBMethodPermission need not remain consistent from one execution of an application to another.
  • If two EJBMethodPermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

Specified by:
hashCode in class Permission
Returns:
the integer hash code value for this object.

implies

public boolean implies(Permission permission)
Determines if the argument Permission is "implied by" this EJBMethodPermission. For this to be the case,

  • The argument must be an instanceof EJBMethodPermission
  • with name equivalent to that of this EJBMethodPermission, and
  • the methods to which the argument permission applies (as defined in its actions) must be a subset of the methods to which this EJBMethodPermission applies (as defined in its actions).

The argument permission applies to a subset of the methods to which this permission applies if all of the following conditions are met.

  • the method name component of the methodNameSpec of this permission is null, the empty string, or equivalent to the method name of the argument permission, and
  • the method interface component of the methodNameSpec of this permission is null, the empty string, or equivalent to the method interface of the argument permission, and
  • the method parameter list component of the methodNameSpec of this permission is null, the empty string, or equivalent to the method parameter list of the argument permission.

The name and actions comparisons described above are case sensitive.

Specified by:
implies in class Permission
Parameters:
permission - "this" EJBMethodPermission is checked to see if it implies the argument permission.

Returns:
true if the specified permission is implied by this object, false if not.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EJBRoleRefPermission

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class EJBRoleRefPermission

java.lang.Object
    extended by  java.security.Permission
        extended by  javax.security.jacc.EJBRoleRefPermission
All Implemented Interfaces:
Serializable, Guard
public final class EJBRoleRefPermission
extends Permission
implements Serializable

Class for EJB isCallerInRole (String reference) permissions. An EJBRoleRefPermission is a named permission and has actions.

The name of an EJBRoleRefPermission contains the value of the ejb-name element in the application's deployment descriptor that identifies the EJB in whose context the permission is being evalutated.

the actions of an EJBRoleRefPermission identifies the role reference to which the permission applies. An EJBRoleRefPermission is checked to determine if the subject is a member of the role identified by the reference.

Implementations of this class MAY implement newPermissionCollection or inherit its implementation from the super class.

Author:
Ron Monzillo, Gary Ellison
See Also:
Permission, Serialized Form

Constructor Summary
EJBRoleRefPermission(String name, String actions)
Creates a new EJBRoleRefPermission with the specified name and actions.
Method Summary
boolean | equals(Object o) Checks two EJBRoleRefPermission objects for equality.
String | getActions() Returns a canonical String representation of the actions of this EJBRoleRefPermission.
int | hashCode() Returns the hash code value for this EJBRoleRefPermission.
boolean | implies(Permission permission) Determines if the argument Permission is "implied by" this EJBRoleRefPermission.
Methods inherited from class java.security.Permission
checkGuard, getName, newPermissionCollection, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EJBRoleRefPermission

public EJBRoleRefPermission(String name,
                            String actions)
Creates a new EJBRoleRefPermission with the specified name and actions.

Parameters:
name - the ejb-name that identifies the EJB in whose context the role references are to be evaluated.

actions - identifies the role reference to which the permission pertains. The role reference is scoped to the EJB identified in the name parameter. The value of the role reference must not be null or the empty string.
Method Detail

equals

public boolean equals(Object o)
Checks two EJBRoleRefPermission objects for equality. EJBRoleRefPermission objects are equivalent if they have case equivalent name and actions values.

Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

Specified by:
equals in class Permission
Parameters:
o - the EJBRoleRefPermission object being tested for equality with this EJBRoleRefPermission.

Returns:
true if the argument EJBRoleRefPermission object is equivalent to this EJBRoleRefPermission.

getActions

public String getActions()
Returns a canonical String representation of the actions of this EJBRoleRefPermission.

Specified by:
getActions in class Permission
Returns:
a String containing the canonicalized actions of this EJBRoleRefPermission.

hashCode

public int hashCode()
Returns the hash code value for this EJBRoleRefPermission. The properties of the returned hash code must be as follows:

  • During the lifetime of a Java application, the hashCode method must return the same integer value, every time it is called on a EJBRoleRefPermission object. The value returned by hashCode for a particular EJBRoleRefPermission need not remain consistent from one execution of an application to another.
  • If two EJBRoleRefPermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

Specified by:
hashCode in class Permission
Returns:
the integer hash code value for this object.

implies

public boolean implies(Permission permission)
Determines if the argument Permission is "implied by" this EJBRoleRefPermission. For this to be the case,

  • The argument must be an instanceof EJBRoleRefPermission
  • with name equivalent to that of this EJBRoleRefPermission, and
  • with the role reference equivalent to that of this EJBRoleRefPermission applies.

    The name and actions comparisons described above are case sensitive.

    Specified by:
    implies in class Permission
    Parameters:
    permission - "this" EJBRoleRefPermission is checked to see if it implies the argument permission.

    Returns:
    true if the specified permission is implied by this object, false if not.
    • Overview Package Class Tree Deprecated Index Help
            Java EE 5 SDK
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
    Submit a bug or feature

    Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PolicyConfiguration

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Interface PolicyConfiguration

public interface PolicyConfiguration

The methods of this interface are used by containers to create policy statements in a Policy provider. An object that implements the PolicyConfiguration interface provides the policy statement configuration interface for a corresponding policy context within the corresponding Policy provider.

The life cycle of a policy context is defined by three states; "open", "inService", and "deleted". A policy context is in one of these three states.

A policy context in the "open" state is in the process of being configured, and may be operated on by any of the methods of the PolicyConfiguration interface. A policy context in the "open" state must not be assimilated at Policy.refresh into the policy statements used by the Policy provider in performing its access decisions. In order for the policy statements of a policy context to be assimilated by the associated provider, the policy context must be in the "inService" state. A policy context in the "open" state is transitioned to the "inService" state by calling the commit method.

A policy context in the "inService" state is available for assimilation into the policy statements being used to perform access decisions by the associated Policy provider. Providers assimilate policy contexts containing policy statements when the refresh method of the provider is called. When a provider's refresh method is called, it must assimilate only those policy contexts whose state is "inService" and it must ensure that the policy statements put into service for each policy context are only those defined in the context at the time of the call to refresh. A policy context in the "inService" state is not available for additional configuration and may be returned to the "open" state by calling the getPolicyConfiguration method of the PolicyConfigurationFactory.

A policy context in the "deleted" state is neither available for configuration, nor is it available for assimilation into the Provider. A policy context whose state is "deleted" may be reclaimed for subsequent processing by calling the getPolicyConfiguration method of the associated PolicyConfigurationFactory. A "deleted" policy context is transitioned to the "open" state when it it returned as a result of a call to getPolicyConfiguration.

The following table captures the correspondence between the policy context life cycle and the methods of the PolicyConfiguration interface. The rightmost 3 columns of the table correspond to the PolicyConfiguration state identified at the head of the column. The values in the cells of these columns indicate the next state resulting from a call to the method identifed in the leftmost column of the corresponding row, or that calling the method is unsupported in the state represented by the column (in which case the state will remain unchanged).

PolicyConfiguration State Table
Method | Current State to Next State
 | deleted | open | inService
addToExcludedPolicy | Unsupported Operation | open | Unsupported Operation
addToRole | Unsupported Operation | open | Unsupported Operation
addToUncheckedPolicy | Unsupported Operation | open | Unsupported Operation
commit | Unsupported Operation | inService | inService
delete | deleted | deleted | deleted
getContextID | deleted | open | inService
inService | deleted | open | inService
linkConfiguration | Unsupported Operation | open | Unsupported Operation
removeExcludedPolicy | Unsupported Operation | open | Unsupported Operation
removeRole | Unsupported Operation | open | Unsupported Operation
removeUncheckedPolicy | Unsupported Operation | open | Unsupported Operation

For a provider implementation to be compatible with multi-threaded environments, it may be necessary to synchronize the refresh method of the provider with the methods of its PolicyConfiguration interface and with the getPolicyConfiguration and inService methods of its PolicyConfigurationFactory.

Author:
Ron Monzillo, Gary Ellison
See Also:
Permission, PermissionCollection, PolicyContextException, PolicyConfigurationFactory

Method Summary
void | addToExcludedPolicy(Permission permission) Used to add a single excluded policy statement to this PolicyConfiguration.
void | addToExcludedPolicy(PermissionCollection permissions) Used to add excluded policy statements to this PolicyConfiguration.
void | addToRole(String roleName, Permission permission) Used to add a single permission to a named role in this PolicyConfiguration.
void | addToRole(String roleName, PermissionCollection permissions) Used to add permissions to a named role in this PolicyConfiguration.
void | addToUncheckedPolicy(Permission permission) Used to add a single unchecked policy statement to this PolicyConfiguration.
void | addToUncheckedPolicy(PermissionCollection permissions) Used to add unchecked policy statements to this PolicyConfiguration.
void | commit() This method is used to set to "inService" the state of the policy context whose interface is this PolicyConfiguration Object.
void | delete() Causes all policy statements to be deleted from this PolicyConfiguration and sets its internal state such that calling any method, other than delete, getContextID, or inService on the PolicyConfiguration will be rejected and cause an UnsupportedOperationException to be thrown.
String | getContextID() This method returns this object's policy context identifier.
boolean | inService() This method is used to determine if the policy context whose interface is this PolicyConfiguration Object is in the "inService" state.
void | linkConfiguration(PolicyConfiguration link) Creates a relationship between this configuration and another such that they share the same principal-to-role mappings.
void | removeExcludedPolicy() Used to remove any excluded policy statements from this PolicyConfiguration.
void | removeRole(String roleName) Used to remove a role and all its permissions from this PolicyConfiguration.
void | removeUncheckedPolicy() Used to remove any unchecked policy statements from this PolicyConfiguration.

Method Detail

getContextID

String getContextID()
                    throws PolicyContextException
This method returns this object's policy context identifier.

Returns:
this object's policy context identifier.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the getContextID method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

addToRole

void addToRole(String roleName,
               PermissionCollection permissions)
               throws PolicyContextException
Used to add permissions to a named role in this PolicyConfiguration. If the named Role does not exist in the PolicyConfiguration, it is created as a result of the call to this function.

It is the job of the Policy provider to ensure that all the permissions added to a role are granted to principals "mapped to the role".

Parameters:
roleName - the name of the Role to which the permissions are to be added.

permissions - the collection of permissions to be added to the role. The collection may be either a homogenous or heterogenous collection.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToRole method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

addToRole

void addToRole(String roleName,
               Permission permission)
               throws PolicyContextException
Used to add a single permission to a named role in this PolicyConfiguration. If the named Role does not exist in the PolicyConfiguration, it is created as a result of the call to this function.

It is the job of the Policy provider to ensure that all the permissions added to a role are granted to principals "mapped to the role".

Parameters:
roleName - the name of the Role to which the permission is to be added.

permission - the permission to be added to the role.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToRole method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

addToUncheckedPolicy

void addToUncheckedPolicy(PermissionCollection permissions)
                          throws PolicyContextException
Used to add unchecked policy statements to this PolicyConfiguration.

Parameters:
permissions - the collection of permissions to be added as unchecked policy statements. The collection may be either a homogenous or heterogenous collection.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToUncheckedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

addToUncheckedPolicy

void addToUncheckedPolicy(Permission permission)
                          throws PolicyContextException
Used to add a single unchecked policy statement to this PolicyConfiguration.

Parameters:
permission - the permission to be added to the unchecked policy statements.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToUncheckedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

addToExcludedPolicy

void addToExcludedPolicy(PermissionCollection permissions)
                         throws PolicyContextException
Used to add excluded policy statements to this PolicyConfiguration.

Parameters:
permissions - the collection of permissions to be added to the excluded policy statements. The collection may be either a homogenous or heterogenous collection.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToExcludedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

addToExcludedPolicy

void addToExcludedPolicy(Permission permission)
                         throws PolicyContextException
Used to add a single excluded policy statement to this PolicyConfiguration.

Parameters:
permission - the permission to be added to the excluded policy statements.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the addToExcludedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

removeRole

void removeRole(String roleName)
                throws PolicyContextException
Used to remove a role and all its permissions from this PolicyConfiguration.

Parameters:
roleName - the name of the Role to remove from this PolicyConfiguration.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the removeRole method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

removeUncheckedPolicy

void removeUncheckedPolicy()
                           throws PolicyContextException
Used to remove any unchecked policy statements from this PolicyConfiguration.

Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the removeUncheckedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

removeExcludedPolicy

void removeExcludedPolicy()
                          throws PolicyContextException
Used to remove any excluded policy statements from this PolicyConfiguration.

Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the removeExcludedPolicy method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

linkConfiguration

void linkConfiguration(PolicyConfiguration link)
                       throws PolicyContextException
Creates a relationship between this configuration and another such that they share the same principal-to-role mappings. PolicyConfigurations are linked to apply a common principal-to-role mapping to multiple seperately manageable PolicyConfigurations, as is required when an application is composed of multiple modules.

Note that the policy statements which comprise a role, or comprise the excluded or unchecked policy collections in a PolicyConfiguration are unaffected by the configuration being linked to another.

Parameters:
link - a reference to a different PolicyConfiguration than this PolicyConfiguration.

The relationship formed by this method is symetric, transitive and idempotent. If the argument PolicyConfiguration does not have a different Policy context identifier than this PolicyConfiguration no relationship is formed, and an exception, as described below, is thrown.

Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" or "inService" when this method is called.
IllegalArgumentException - if called with an argument PolicyConfiguration whose Policy context is equivalent to that of this PolicyConfiguration.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the linkConfiguration method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

delete

void delete()
            throws PolicyContextException
Causes all policy statements to be deleted from this PolicyConfiguration and sets its internal state such that calling any method, other than delete, getContextID, or inService on the PolicyConfiguration will be rejected and cause an UnsupportedOperationException to be thrown.

This operation has no affect on any linked PolicyConfigurations other than removing any links involving the deleted PolicyConfiguration.

Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the delete method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

commit

void commit()
            throws PolicyContextException
This method is used to set to "inService" the state of the policy context whose interface is this PolicyConfiguration Object. Only those policy contexts whose state is "inService" will be included in the policy contexts processed by the Policy.refresh method. A policy context whose state is "inService" may be returned to the "open" state by calling the getPolicyConfiguration method of the PolicyConfiguration factory with the policy context identifier of the policy context.

When the state of a policy context is "inService", calling any method other than commit, delete, getContextID, or inService on its PolicyConfiguration Object will cause an UnsupportedOperationException to be thrown.

Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
UnsupportedOperationException - if the state of the policy context whose interface is this PolicyConfiguration Object is "deleted" when this method is called.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the commit method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

inService

boolean inService()
                  throws PolicyContextException
This method is used to determine if the policy context whose interface is this PolicyConfiguration Object is in the "inService" state.

Returns:
true if the state of the associated policy context is "inService"; false otherwise.
Throws:
SecurityException - if called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the inService method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PolicyConfigurationFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class PolicyConfigurationFactory

java.lang.Object
    extended by  javax.security.jacc.PolicyConfigurationFactory

public abstract class PolicyConfigurationFactory
extends Object

Abstract factory and finder class for obtaining the instance of the class that implements the PolicyConfigurationFactory of a provider. The factory will be used to instantiate PolicyConfiguration objects that will be used by the deployment tools of the container to create and manage policy contexts within the Policy Provider.

Implementation classes must have a public no argument constructor that may be used to create an operational instance of the factory implementation class.

Author:
Ron Monzillo, Gary Ellison, Harpreet Singh
See Also:
Permission, PolicyConfiguration, PolicyContextException

Constructor Summary
PolicyConfigurationFactory()
Method Summary
abstract PolicyConfiguration | getPolicyConfiguration(String contextID, boolean remove) This method is used to obtain an instance of the provider specific class that implements the PolicyConfiguration interface that corresponds to the identified policy context within the provider.
static PolicyConfigurationFactory | getPolicyConfigurationFactory() This static method uses a system property to find and instantiate (via a public constructor) a provider specific factory implementation class.
abstract boolean | inService(String contextID) This method determines if the identified policy context exists with state "inService" in the Policy provider associated with the factory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PolicyConfigurationFactory

public PolicyConfigurationFactory()
Method Detail

getPolicyConfigurationFactory

public static PolicyConfigurationFactory getPolicyConfigurationFactory()
                                                                throws ClassNotFoundException,
                                                                       PolicyContextException
This static method uses a system property to find and instantiate (via a public constructor) a provider specific factory implementation class. The name of the provider specific factory implementation class is obtained from the value of the system property,

     javax.security.jacc.PolicyConfigurationFactory.provider.

Returns:
the singleton instance of the provider specific PolicyConfigurationFactory implementation class.
Throws:
SecurityException - when called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
ClassNotFoundException - when the class named by the system property could not be found including because the value of the system property has not be set.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the getPolicyConfigurationFactory method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException

getPolicyConfiguration

public abstract PolicyConfiguration getPolicyConfiguration(String contextID,
                                                           boolean remove)
                                                    throws PolicyContextException
This method is used to obtain an instance of the provider specific class that implements the PolicyConfiguration interface that corresponds to the identified policy context within the provider. The methods of the PolicyConfiguration interface are used to define the policy statements of the identified policy context.

If at the time of the call, the identified policy context does not exist in the provider, then the policy context will be created in the provider and the Object that implements the context's PolicyConfiguration Interface will be returned. If the state of the identified context is "deleted" or "inService" it will be transitioned to the "open" state as a result of the call. The states in the lifecycle of a policy context are defined by the PolicyConfiguration interface.

For a given value of policy context identifier, this method must always return the same instance of PolicyConfiguration and there must be at most one actual instance of a PolicyConfiguration with a given policy context identifier (during a process context).

To preserve the invariant that there be at most one PolicyConfiguration object for a given policy context, it may be necessary for this method to be thread safe.

Parameters:
contextID - A String identifying the policy context whose PolicyConfiguration interface is to be returned. The value passed to this parameter must not be null.

remove - A boolean value that establishes whether or not the policy statements of an existing policy context are to be removed before its PolicyConfiguration object is returned. If the value passed to this parameter is true, the policy statements of an existing policy context will be removed. If the value is false, they will not be removed.
Returns:
an Object that implements the PolicyConfiguration Interface matched to the Policy provider and corresponding to the identified policy context.
Throws:
SecurityException - when called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the getPolicyConfiguration method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.

inService

public abstract boolean inService(String contextID)
                           throws PolicyContextException
This method determines if the identified policy context exists with state "inService" in the Policy provider associated with the factory.

Parameters:
contextID - A string identifying a policy context
Returns:
true if the identified policy context exists within the provider and its state is "inService", false otherwise.
Throws:
SecurityException - when called by an AccessControlContext that has not been granted the "setPolicy" SecurityPermission.
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the inService method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PolicyContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class PolicyContext

java.lang.Object
    extended by  javax.security.jacc.PolicyContext

public final class PolicyContext
extends Object

This utility class is used by containers to communicate policy context identifiers and other policy relevant context to Policy providers. Policy providers use the policy context identifier to select the subset of policy to apply in access decisions.

The value of a policy context identifier is a String and each thread has an independently established policy context identifier. A container will establish the thread-scoped value of a policy context identifier by calling the static setContextID method. The value of a thread-scoped policy context identifier is available (to Policy) by calling the static getContextID method.

This class is also used by Policy providers to request additional thread-scoped policy relevant context objects from the calling container. Containers register container-specific PolicyContext handlers using the static registerHandler method. Handler registration is scoped to the class, such that the same handler registrations are active in all thread contexts. Containers may use the static method setHandlerData to establish a thread-scoped parameter that will be passed to handlers when they are activated by Policy providers. The static getContext method is used to activate a handler and obtain the corresponding context object.

The static accessor functions provided by this class allow per-thread policy context values to be established and communicated independent of a common reference to a particular PolicyContext instance.

The PolicyContext class may encapsulate static ThreadLocal instance variables to represent the policy context identifier and handler data values.

The Application server must bundle or install the PolicyContext class, and the containers of the application server must prevent the methods of the PolicyContext class from being called from calling contexts that are not authorized to call these methods. With the exception of the getContextID and GetHandlerKeys methods, containers must restrict and afford access to the methods of the PolicyContext class to calling contexts trusted by the container to perform container access decisions. The PolicyContext class may satisfy this requirement (on behalf of its container) by rejecting calls made from an AccessControlContext that has not been granted the "setPolicy" SecurityPermission, and by ensuring that Policy providers used to perform container access decisions are granted the "setPolicy" permission.

Author:
Ron Monzillo, Gary Ellison
See Also:
PolicyContextHandler

Method Summary
static Object | getContext(String key) This method may be used by a Policy provider to activate the PolicyContextHandler registered to the context object key and cause it to return the corresponding policy context object from the container.
static String | getContextID() This static method returns the value of the policy context identifier associated with the thread on which the accessor is called.
static Set | getHandlerKeys() This method may be used to obtain the keys that identify the container specific context handlers registered by the container.
static void | registerHandler(String key, PolicyContextHandler handler, boolean replace) Authorization protected method used to register a container specific PolicyContext handler.
static void | setContextID(String contextID) Authorization protected method used to modify the value of the policy context identifier associated with the thread on which this method is called.
static void | setHandlerData(Object data) Authorization protected method that may be used to associate a thread-scoped handler data object with the PolicyContext.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

setContextID

public static void setContextID(String contextID)
Authorization protected method used to modify the value of the policy context identifier associated with the thread on which this method is called.

Parameters:
contextID - a String that represents the value of the policy context identifier to be assigned to the PolicyContext for the calling thread. The value null is a legitimate value for this parameter.
Throws:
SecurityException - if the calling AccessControlContext is not authorized by the container to call this method.

getContextID

public static String getContextID()
This static method returns the value of the policy context identifier associated with the thread on which the accessor is called.

Returns:
The String (or null) policy context identifier established for the thread. This method must return the default policy context identifier, null, if the policy context identifier of the thread has not been set via setContext to another value.
Throws:
SecurityException - if the calling AccessControlContext is not authorized by the container to call this method. Containers may choose to authorize calls to this method by any AccessControlContext.

setHandlerData

public static void setHandlerData(Object data)
Authorization protected method that may be used to associate a thread-scoped handler data object with the PolicyContext. The handler data object will be made available to handlers, where it can serve to supply or bind the handler to invocation scoped state within the container.

Parameters:
data - a container-specific object that will be associated with the calling thread and passed to any handler activated by a Policy provider (on the thread). The value null is a legitimate value for this parameter, and is the value that will be used in the activation of handlers if the setHandlerData has not been called on the thread.
Throws:
SecurityException - if the calling AccessControlContext is not authorized by the container to call this method.

registerHandler

public static void registerHandler(String key,
                                   PolicyContextHandler handler,
                                   boolean replace)
                            throws PolicyContextException
Authorization protected method used to register a container specific PolicyContext handler. A handler may be registered to handle multiple keys, but at any time, at most one handler may be registered for a key.

Parameters:
key - a (case-sensitive) String that identifies the context object handled by the handler. The value of this parameter must not be null.
handler - an object that implements the PolicyContextHandler interface. The value of this parameter must not be null.
replace - this boolean value defines the behavior of this method if, when it is called, a PolicyContextHandler has already been registered to handle the same key. In that case, and if the value of this argument is true, the existing handler is replaced with the argument handler. If the value of this parameter is false the existing registration is preserved and an exception is thrown.
Throws:
IllegalArgumentException - if the value of either of the handler or key arguments is null, or the value of the replace argument is false and a handler with the same key as the argument handler is already registered.
SecurityException - if the calling AccessControlContext is not authorized by the container to call this method.
PolicyContextException - if an operation by this method on the argument PolicyContextHandler causes it to throw a checked exception that is not accounted for in the signature of this method.

getHandlerKeys

public static Set getHandlerKeys()
This method may be used to obtain the keys that identify the container specific context handlers registered by the container.

Returns:
A Set, the elements of which, are the String key values that identify the handlers that have been registered and therefore may be activated on the PolicyContext.
Throws:
SecurityException - if the calling AccessControlContext is not authorized by the container to call this method. Containers may choose to authorize calls to this method by any AccessControlContext.

getContext

public static Object getContext(String key)
                         throws PolicyContextException
This method may be used by a Policy provider to activate the PolicyContextHandler registered to the context object key and cause it to return the corresponding policy context object from the container. When this method activates a handler, it passes to the handler the context object key and the handler data associated with the calling thread.

Parameters:
key - a String that identifies the PolicyContextHandler to activate and the context object to be acquired from the handler. The value of this parameter must not be null.
Returns:
the container and handler specific object containing the desired context. A null value is returned if the corresponding handler has been registered, and the value of the corresponding context is null.
Throws:
IllegalArgumentException - if a PolicyContextHandler has not been registered for the key or the registered handler no longer supports the key.
SecurityException - if the calling AccessControlContext is not authorized by the container to call this method.
PolicyContextException - if an operation by this method on the identified PolicyContextHandler causes it to throw a checked exception that is not accounted for in the signature of this method.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PolicyContextException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class PolicyContextException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.security.jacc.PolicyContextException
All Implemented Interfaces:
Serializable
public class PolicyContextException
extends Exception

This checked exception is thrown by implementations of the javax.security.jacc.PolicyConfiguration Interface, the javax.security.jacc.PolicyConfigurationFactory abstract class, the javax.security.jacc.PolicyContext utility class, and implementations of the javax.security.jacc.PolicyContextException Interface.

This exception is used by javax.security.jacc implementation classes to rethrow checked exceptions ocurring within an implementation that are not declared by the interface or class being implemented.

Author:
Ron Monzillo, Gary Ellison
See Also:
Exception, PolicyConfiguration, PolicyConfigurationFactory, PolicyContext, PolicyContextHandler, Serialized Form

Constructor Summary
PolicyContextException()
Constructs a new PolicyContextException with null as its detail message.
PolicyContextException(String msg)
Constructs a new PolicyContextException with the specified detail message
PolicyContextException(String msg, Throwable cause)
Constructs a new PolicyContextException with the specified detail message and cause.
PolicyContextException(Throwable cause)
Constructs a new PolicyContextException with the specified cause.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PolicyContextException

public PolicyContextException()
Constructs a new PolicyContextException with null as its detail message. describing the cause of the exception.

PolicyContextException

public PolicyContextException(String msg)
Constructs a new PolicyContextException with the specified detail message

Parameters:
msg - - a String containing a detail message describing the cause of the exception.

PolicyContextException

public PolicyContextException(String msg,
                              Throwable cause)
Constructs a new PolicyContextException with the specified detail message and cause. The cause will be encapsulated in the constructed exception.

Parameters:
msg - - a String containing a detail message describing the cause of the exception.
cause - - the Throwable that is "causing" this exception to be constructed. A null value is permitted, and the value passed through this parameter may subsequently be retrieved by calling getCause() on the constructed exception.

PolicyContextException

public PolicyContextException(Throwable cause)
Constructs a new PolicyContextException with the specified cause. The cause will be encapsulated in the constructed exception.

Parameters:
cause - - the Throwable that is "causing" this exception to be constructed. A null value is permitted, and the value passed through this parameter may subsequently be retrieved by calling getCause() on the constructed exception.
Overview  Package   Class  Tree  Deprecated  Index  Help
Java EE 5 SDK
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PolicyContextHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Interface PolicyContextHandler

public interface PolicyContextHandler

This interface defines the methods that must be implemented by handlers that are to be registered and activated by the PolicyContext class. The PolicyContext class provides methods for containers to register and activate container-specific PolicyContext handlers. Policy providers use the PolicyContext class to activate handlers to obtain (from the container) additional policy relevant context to apply in their access decisions. All handlers registered and activated via the PolicyContext class must implement the PolicyContextHandler interface.

Author:
Ron Monzillo, Gary Ellison
See Also:
PolicyContext, PolicyContextException

Method Summary
Object | getContext(String key, Object data) This public method is used by the PolicyContext class to activate the handler and obtain from it the context object identified by the (case-sensitive) key.
String[] | getKeys() This public method returns the keys identifying the context objects supported by the handler.
boolean | supports(String key) This public method returns a boolean result indicating whether or not the handler supports the context object identified by the (case-sensitive) key value.

Method Detail

supports

boolean supports(String key)
                 throws PolicyContextException
This public method returns a boolean result indicating whether or not the handler supports the context object identified by the (case-sensitive) key value.

Parameters:
key - a String value identifying a context object that could be supported by the handler. The value of this parameter must not be null.
Returns:
a boolean indicating whether or not the context object corresponding to the argument key is handled by the handler.
Throws:
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException

getKeys

String[] getKeys()
                 throws PolicyContextException
This public method returns the keys identifying the context objects supported by the handler. The value of each key supported by a handler must be a non-null String value.

Returns:
an array containing String values identifing the context objects supported by the handler. The array must not contain duplicate key values. In the unlikely case that the Handler supports no keys, the handler must return a zero length array. The value null must never be returned by this method.
Throws:
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException

getContext

Object getContext(String key,
                  Object data)
                  throws PolicyContextException
This public method is used by the PolicyContext class to activate the handler and obtain from it the context object identified by the (case-sensitive) key. In addition to the key, the handler will be activated with the handler data value associated within the PolicyContext class with the thread on which the call to this method is made.

Note that the policy context identifier associated with a thread is available to the handler by calling PolicyContext.getContextID().

Parameters:
key - a String that identifies the context object to be returned by the handler. The value of this paramter must not be null.
data - the handler data Object associated with the thread on which the call to this method has been made. Note that the value passed through this parameter may be null.
Returns:
The container and handler specific Object containing the desired context. A null value may be returned if the value of the corresponding context is null.
Throws:
PolicyContextException - if the implementation throws a checked exception that has not been accounted for by the method signature. The exception thrown by the implementation class will be encapsulated (during construction) in the thrown PolicyContextException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebResourcePermission

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class WebResourcePermission

java.lang.Object
    extended by  java.security.Permission
        extended by  javax.security.jacc.WebResourcePermission
All Implemented Interfaces:
Serializable, Guard
public final class WebResourcePermission
extends Permission
implements Serializable

Class for Servlet web resource permissions. A WebResourcePermission is a named permission and has actions.

The name of a WebResourcePermission (also referred to as the target name) identifies the Web resources to which the permission pertains.

Implementations of this class MAY implement newPermissionCollection or inherit its implementation from the super class.

Version:
%I% %E%
Author:
Ron Monzillo, Gary Ellison
See Also:
Permission, Serialized Form

Constructor Summary
WebResourcePermission(HttpServletRequest request)
Creates a new WebResourcePermission from the HttpServletRequest object.
WebResourcePermission(String name, String actions)
Creates a new WebResourcePermission with the specified name and actions.
WebResourcePermission(String urlPatternSpec, String[] HTTPMethods)
Creates a new WebResourcePermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods.
Method Summary
boolean | equals(Object o) Checks two WebResourcePermission objects for equality.
String | getActions() Returns a canonical String representation of the actions of this WebResourcePermission.
int | hashCode() Returns the hash code value for this WebResourcePermission.
boolean | implies(Permission permission) Determines if the argument Permission is "implied by" this WebResourcePermission.
Methods inherited from class java.security.Permission
checkGuard, getName, newPermissionCollection, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WebResourcePermission

public WebResourcePermission(String name,
                             String actions)
Creates a new WebResourcePermission with the specified name and actions.

The name contains a URLPatternSpec that identifies the web resources to which the permissions applies. The syntax of a URLPatternSpec is as follows:

          URLPatternList ::= URLPattern | URLPatternList colon URLPattern

          URLPatternSpec ::= null | URLPattern | URLPattern colon URLPatternList

A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor. The empty string is an exact URLPattern, and may occur anywhere in a URLPatternSpec that an exact URLPattern may occur. The first URLPattern in a URLPatternSpec may be any of the pattern types, exact, path-prefix, extension, or default as defined in the Java Servlet Specification). When a URLPatternSpec includes a URLPatternList, the patterns of the URLPatternList identify the resources to which the permission does NOT apply and depend on the pattern type and value of the first pattern as follows:

  • No pattern may exist in the URLPatternList that matches the first pattern.
  • If the first pattern is a path-prefix pattern, only exact patterns matched by the first pattern and path-prefix patterns matched by, but different from, the first pattern may occur in the URLPatternList.
  • If the first pattern is an extension pattern, only exact patterns that are matched by the first pattern and path-prefix patterns may occur in the URLPatternList.
  • If the first pattern is the default pattern, "/", any pattern except the default pattern may occur in the URLPatternList.
  • If the first pattern is an exact pattern a URLPatternList must not be present in the URLPatternSpec.

The actions parameter contains a comma seperated list of HTTP methods. The syntax of the actions parameter is defined as follows:

          ExtensionMethod ::= any token as defined by RFC 2616
                    (that is, 1*[any CHAR except CTLs or separators])

          HTTPMethod ::= "GET" | "POST" | "PUT" | "DELETE" | "HEAD" |
                   "OPTIONS" | "TRACE" | ExtensionMethod

          HTTPMethodList ::= HTTPMethod | HTTPMethodList comma HTTPMethod

          HTTPMethodExceptionList ::= exclaimationPoint HTTPMethodList

          HTTPMethodSpec ::= null | HTTPMethodExceptionList |
                   HTTPMethodList

If duplicates occur in the HTTPMethodSpec they must be eliminated by the permission constructor.

A null or empty string HTTPMethodSpec indicates that the permission applies to all HTTP methods at the resources identified by the URL pattern.

If the HTTPMethodSpec contains an HTTPMethodExceptionList (i.e., it begins with an exclaimationPoint), the permission pertains to all methods except those occuring in the exception list.

Parameters:
name - the URLPatternSpec that identifies the application specific web resources to which the permission pertains. All URLPatterns in the URLPatternSpec are relative to the context path of the deployed web application module, and the same URLPattern must not occur more than once in a URLPatternSpec. A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor.

actions - identifies the HTTP methods to which the permission pertains. If the value passed through this parameter is null or the empty string, then the permission pertains to all the possible HTTP methods.

WebResourcePermission

public WebResourcePermission(String urlPatternSpec,
                             String[] HTTPMethods)
Creates a new WebResourcePermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods.

Parameters:
urlPatternSpec - the URLPatternSpec that identifies the application specific web resources to which the permission pertains. All URLPatterns in the URLPatternSpec are relative to the context path of the deployed web application module, and the same URLPattern must not occur more than once in a URLPatternSpec. A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor.

HTTPMethods - an array of strings each element of which contains the value of an HTTP method. If the value passed through this parameter is null or is an array with no elements, then the permission pertains to all the possible HTTP methods.

WebResourcePermission

public WebResourcePermission(HttpServletRequest request)
Creates a new WebResourcePermission from the HttpServletRequest object.

Parameters:
request - the HttpServletRequest object corresponding to the Servlet operation to which the permission pertains. The permission name is the substring of the requestURI (HttpServletRequest.getRequestURI()) that begins after the contextPath (HttpServletRequest.getContextPath()). When the substring operation yields the string "/", the permission is constructed with the empty string as its name. The permission's actions field is obtained from HttpServletRequest.getMethod().
Method Detail

equals

public boolean equals(Object o)
Checks two WebResourcePermission objects for equality. WebResourcePermission objects are equivalent if their URLPatternSpec and (canonicalized) actions values are equivalent. The URLPatternSpec of a reference permission is equivalent to that of an argument permission if their first patterns are equivalent, and the patterns of the URLPatternList of the reference permission collectively match exactly the same set of patterns as are matched by the patterns of the URLPatternList of the argument permission.

Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

Specified by:
equals in class Permission
Parameters:
o - the WebResourcePermission object being tested for equality with this WebResourcePermission.

Returns:
true if the argument WebResourcePermission object is equivalent to this WebResourcePermission.

getActions

public String getActions()
Returns a canonical String representation of the actions of this WebResourcePermission. In the canonical form, predefined methods preceed extension methods, and within each method classification the corresponding methods occur in ascending lexical order. There may be no duplicate HTTP methods in the canonical form, and the canonical form of the set of all HTTP methods is the value null.

Specified by:
getActions in class Permission
Returns:
a String containing the canonicalized actions of this WebResourcePermission (or the null value).

hashCode

public int hashCode()
Returns the hash code value for this WebResourcePermission. The properties of the returned hash code must be as follows:

  • During the lifetime of a Java application, the hashCode method must return the same integer value, every time it is called on a WebResourcePermission object. The value returned by hashCode for a particular WebResourcePermission need not remain consistent from one execution of an application to another.
  • If two WebResourcePermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

Specified by:
hashCode in class Permission
Returns:
the integer hash code value for this object.

implies

public boolean implies(Permission permission)
Determines if the argument Permission is "implied by" this WebResourcePermission. For this to be the case, all of the following must be true:

  • The argument is an instanceof WebResourcePermission
  • The first URLPattern in the name of the argument permission is matched by the first URLPattern in the name of this permission.
  • The first URLPattern in the name of the argument permission is NOT matched by any URLPattern in the URLPatternList of the URLPatternSpec of this permission.
  • If the first URLPattern in the name of the argument permission matches the first URLPattern in the URLPatternSpec of this permission, then every URLPattern in the URLPatternList of the URLPatternSpec of this permission is matched by a URLPattern in the URLPatternList of the argument permission.
  • The HTTP methods represented by the actions of the argument permission are a subset of the HTTP methods represented by the actions of this permission.

URLPattern matching is performed using the Servlet matching rules where two URL patterns match if they are related as follows:

  • their pattern values are String equivalent, or
  • this pattern is the path-prefix pattern "/*", or
  • this pattern is a path-prefix pattern (that is, it starts with "/" and ends with "/*") and the argument pattern starts with the substring of this pattern, minus its last 2 characters, and the next character of the argument pattern, if there is one, is "/", or
  • this pattern is an extension pattern (that is, it starts with "*.") and the argument pattern ends with this pattern, or
  • the reference pattern is the special default pattern, "/", which matches all argument patterns.

All of the comparisons described above are case sensitive.

Specified by:
implies in class Permission
Parameters:
permission - "this" WebResourcePermission is checked to see if it implies the argument permission.

Returns:
true if the specified permission is implied by this object, false if not.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebRoleRefPermission

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class WebRoleRefPermission

java.lang.Object
    extended by  java.security.Permission
        extended by  javax.security.jacc.WebRoleRefPermission
All Implemented Interfaces:
Serializable, Guard
public final class WebRoleRefPermission
extends Permission
implements Serializable

Class for Servlet isUserInRole (String reference) permissions. A WebRoleRefPermission is a named permission and has actions.

The name of an WebRoleRefPermission (also referred to as the target name) identifies a Web resource by the servlet name (in the deployment descriptor corresponding to the component from which the call to isUserInRole (String reference) is being made.

The actions of an WebRoleRefPermission identifies the role reference to which the permission applies. A WebRoleRefPermission is checked to determine if the subject is a member of the role identified by the reference.

Implementations of this class MAY implement newPermissionCollection or inherit its implementation from the super class.

Author:
Ron Monzillo, Gary Ellison
See Also:
Permission, Serialized Form

Constructor Summary
WebRoleRefPermission(String name, String actions)
Creates a new WebRoleRefPermission with the specified name and actions.
Method Summary
boolean | equals(Object o) Checks two WebRoleRefPermission objects for equality.
String | getActions() Returns a canonical String representation of the actions of this WebRoleRefPermission.
int | hashCode() Returns the hash code value for this WebRoleRefPermission.
boolean | implies(Permission permission) Determines if the argument Permission is "implied by" this WebRoleRefPermission.
Methods inherited from class java.security.Permission
checkGuard, getName, newPermissionCollection, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WebRoleRefPermission

public WebRoleRefPermission(String name,
                            String actions)
Creates a new WebRoleRefPermission with the specified name and actions.

Parameters:
name - the servlet-name that identifies the application specific web resource in whose context the role references are to be evaluated.

actions - identifies the role reference to which the permission pertains. The role reference is scoped to the Web resource identified in the name parameter. The value of the role reference must not be null or the empty string.
Method Detail

equals

public boolean equals(Object o)
Checks two WebRoleRefPermission objects for equality. WebRoleRefPermission objects are equivalent if they have case equivalent name and actions values.

Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

The name and actions comparisons described above are case sensitive.

Specified by:
equals in class Permission
Parameters:
o - the WebRoleRefPermission object being tested for equality with this WebRoleRefPermission.
Returns:
true if the argument WebRoleRefPermission object is equivalent to this WebRoleRefPermission.

getActions

public String getActions()
Returns a canonical String representation of the actions of this WebRoleRefPermission.

Specified by:
getActions in class Permission
Returns:
a String containing the canonicalized actions of this WebRoleRefPermission.

hashCode

public int hashCode()
Returns the hash code value for this WebRoleRefPermission. The properties of the returned hash code must be as follows:

  • During the lifetime of a Java application, the hashCode method must return the same integer value, every time it is called on a WebRoleRefPermission object. The value returned by hashCode for a particular WebRoleRefPermission need not remain consistent from one execution of an application to another.
  • If two WebRoleRefPermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

Specified by:
hashCode in class Permission
Returns:
the integer hash code value for this object.

implies

public boolean implies(Permission permission)
Determines if the argument Permission is "implied by" this WebRoleRefPermission. For this to be the case,

  • The argument must be an instanceof WebRoleRefPermission
  • with name equivalent to this WebRoleRefPermission, and
  • with role reference equivalent to this WebRoleRefPermission (as defined in their actions).

The comparisons described above are case sensitive.

Specified by:
implies in class Permission
Parameters:
permission - "this" WebRoleRefPermission is checked to see if it implies the argument permission.

Returns:
true if the specified permission is implied by this object, false if not.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebUserDataPermission

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.security.jacc
Class WebUserDataPermission

java.lang.Object
    extended by  java.security.Permission
        extended by  javax.security.jacc.WebUserDataPermission
All Implemented Interfaces:
Serializable, Guard
public final class WebUserDataPermission
extends Permission
implements Serializable

Class for Servlet Web user data permissions. A WebUserDataPermission is a named permission and has actions.

The name of a WebUserDataPermission (also referred to as the target name) identifies a Web resource by its context path relative URL pattern.

Author:
Ron Monzillo, Gary Ellison
See Also:
Permission, Serialized Form

Constructor Summary
WebUserDataPermission(HttpServletRequest request)
Creates a new WebUserDataPermission from the HttpServletRequest object.
WebUserDataPermission(String name, String actions)
Creates a new WebUserDataPermission with the specified name and actions.
WebUserDataPermission(String urlPatternSpec, String[] HTTPMethods, String transportType)
Creates a new WebUserDataPermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods and the transport type.
Method Summary
boolean | equals(Object o) Checks two WebUserDataPermission objects for equality.
String | getActions() Returns a canonical String representation of the actions of this WebUserDataPermission.
int | hashCode() Returns the hash code value for this WebUserDataPermission.
boolean | implies(Permission permission) Determines if the argument Permission is "implied by" this WebUserDataPermission.
Methods inherited from class java.security.Permission
checkGuard, getName, newPermissionCollection, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WebUserDataPermission

public WebUserDataPermission(String name,
                             String actions)
Creates a new WebUserDataPermission with the specified name and actions.

The name contains a URLPatternSpec that identifies the web resources to which the permissions applies. The syntax of a URLPatternSpec is as follows:

          URLPatternList ::= URLPattern | URLPatternList colon URLPattern

          URLPatternSpec ::= null | URLPattern | URLPattern colon URLPatternList

A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor. The empty string is an exact URLPattern, and may occur anywhere in a URLPatternSpec that an exact URLPattern may occur. The first URLPattern in a URLPatternSpec may be any of the pattern types, exact, path-prefix, extension, or default as defined in the Java Servlet Specification). When a URLPatternSpec includes a URLPatternList, the patterns of the URLPatternList identify the resources to which the permission does NOT apply and depend on the pattern type and value of the first pattern as follows:

  • No pattern may exist in the URLPatternList that matches the first pattern.
  • If the first pattern is a path-prefix pattern, only exact patterns matched by the first pattern and path-prefix patterns matched by, but different from, the first pattern may occur in the URLPatternList.
  • If the first pattern is an extension pattern, only exact patterns that are matched by the first pattern and path-prefix patterns may occur in the URLPatternList.
  • If the first pattern is the default pattern, "/", any pattern except the default pattern may occur in the URLPatternList.
  • If the first pattern is an exact pattern a URLPatternList must not be present in the URLPatternSpec.

The actions parameter contains a comma separated list of HTTP methods that may be followed by a transportType separated from the HTTP method by a colon.

          ExtensionMethod ::= any token as defined by RFC 2616
                  (that is, 1*[any CHAR except CTLs or separators])

          HTTPMethod ::= "Get" | "POST" | "PUT" | "DELETE" | "HEAD" |
                  "OPTIONS" | "TRACE" | ExtensionMethod

          HTTPMethodList ::= HTTPMethod | HTTPMethodList comma HTTPMethod

          HTTPMethodExceptionList ::= exclaimationPoint HTTPMethodList

          HTTPMethodSpec ::= emptyString | HTTPMethodExceptionList |
                  HTTPMethodList

          transportType ::= "INTEGRAL" | "CONFIDENTIAL" | "NONE"

          actions ::= null | HTTPMethodSpec |
                  HTTPMethodSpec colon transportType

If duplicates occur in the HTTPMethodSpec they must be eliminated by the permission constructor.

An empty string HTTPMethodSpec is a shorthand for a List containing all the possible HTTP methods.

If the HTTPMethodSpec contains an HTTPMethodExceptionList (i.e., it begins with an exclaimationPoint), the permission pertains to all methods except those occuring in the exception list.

An actions string without a transportType is a shorthand for a actions string with the value "NONE" as its TransportType.

A granted permission representing a transportType of "NONE", indicates that the associated resources may be accessed using any conection type.

Parameters:
name - the URLPatternSpec that identifies the application specific web resources to which the permission pertains. All URLPatterns in the URLPatternSpec are relative to the context path of the deployed web application module, and the same URLPattern must not occur more than once in a URLPatternSpec. A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor.

actions - identifies the HTTP methods and transport type to which the permission pertains. If the value passed through this parameter is null or the empty string, then the permission is constructed with actions corresponding to all the possible HTTP methods and transportType "NONE".

WebUserDataPermission

public WebUserDataPermission(String urlPatternSpec,
                             String[] HTTPMethods,
                             String transportType)
Creates a new WebUserDataPermission with name corresponding to the URLPatternSpec, and actions composed from the array of HTTP methods and the transport type.

Parameters:
urlPatternSpec - the URLPatternSpec that identifies the application specific web resources to which the permission pertains. All URLPatterns in the URLPatternSpec are relative to the context path of the deployed web application module, and the same URLPattern must not occur more than once in a URLPatternSpec. A null URLPatternSpec is translated to the default URLPattern, "/", by the permission constructor.

HTTPMethods - an array of strings each element of which contains the value of an HTTP method. If the value passed through this parameter is null or is an array with no elements, then the permission is constructed with actions corresponding to all the possible HTTP methods.

transportType - a String whose value is a transportType. If the value passed through this parameter is null, then the permission is constructed with actions corresponding to transportType "NONE".

WebUserDataPermission

public WebUserDataPermission(HttpServletRequest request)
Creates a new WebUserDataPermission from the HttpServletRequest object.

Parameters:
request - the HttpServletRequest object corresponding to the Servlet operation to which the permission pertains. The permission name is the substring of the requestURI (HttpServletRequest.getRequestURI()) that begins after the contextPath (HttpServletRequest.getContextPath()). When the substring operation yields the string "/", the permission is constructed with the empty string as its name. The HTTP method component of the permission's actions is as obtained from HttpServletRequest.getMethod(). The TransportType component of the permission's actions is determined by calling HttpServletRequest.isSecure().
Method Detail

equals

public boolean equals(Object o)
Checks two WebUserDataPermission objects for equality. WebUserDataPermission objects are equivalent if their URLPatternSpec and (canonicalized) actions values are equivalent. The URLPatternSpec of a reference permission is equivalent to that of an argument permission if their first patterns are equivalent, and the patterns of the URLPatternList of the reference permission collectively match exactly the same set of patterns as are matched by the patterns of the URLPatternList of the argument permission.

Two Permission objects, P1 and P2, are equivalent if and only if P1.implies(P2) && P2.implies(P1).

Specified by:
equals in class Permission
Parameters:
o - the WebUserDataPermission object being tested for equality with this WebUserDataPermission.

Returns:
true if the argument WebUserDataPermission object is equivalent to this WebUserDataPermission.

getActions

public String getActions()
Returns a canonical String representation of the actions of this WebUserDataPermission. The canonical form of the actions of a WebUserDataPermission is described by the following syntax description.

          ExtensionMethod ::= any token as defined by RFC 2616
                   (that is, 1*[any CHAR except CTLs or separators])

          HTTPMethod ::= "GET" | "POST" | "PUT" | "DELETE" | "HEAD" |
                   "OPTIONS" | "TRACE" | ExtensionMethod

          HTTPMethodList ::= HTTPMethod | HTTPMethodList comma HTTPMethod

          HTTPMethodExceptionList ::= exclaimationPoint HTTPMethodList

          HTTPMethodSpec ::= emptyString | HTTPMethodExceptionList |
                  HTTPMethodList

          transportType ::= "INTEGRAL" | "CONFIDENTIAL" | "NONE"

          actions ::= null | HTTPMethodList |
                  HTTPMethodSpec colon transportType

If the permission's HTTP methods correspond to the entire HTTP method set and the permission's transport type is "INTEGRAL" or "CONFIDENTIAL", the HTTP methods shall be represented in the canonical form by an emptyString HTTPMethodSpec. If the permission's HTTP methods correspond to the entire HTTP method set, and the permission's transport type is not "INTEGRAL"or "CONFIDENTIAL", the canonical actions value shall be the null value.

If the permission's methods do not correspond to the entire HTTP method set, duplicates must be eliminated and the remaining elements must be ordered such that the predefined methods preceed the extension methods, and such that within each method classification the corresponding methods occur in ascending lexical order. The resulting (non-emptyString) HTTPMethodSpec must be included in the canonical form, and if the permission's transport type is not "INTEGRAL" or "CONFIDENTIAL", the canonical actions value must be exactly the resulting HTTPMethodSpec.

Specified by:
getActions in class Permission
Returns:
a String containing the canonicalized actions of this WebUserDataPermission (or the null value).

hashCode

public int hashCode()
Returns the hash code value for this WebUserDataPermission. The properties of the returned hash code must be as follows:

  • During the lifetime of a Java application, the hashCode method shall return the same integer value every time it is called on a WebUserDataPermission object. The value returned by hashCode for a particular EJBMethod permission need not remain consistent from one execution of an application to another.
  • If two WebUserDataPermission objects are equal according to the equals method, then calling the hashCode method on each of the two Permission objects must produce the same integer result (within an application).

Specified by:
hashCode in class Permission
Returns:
the integer hash code value for this object.

implies

public boolean implies(Permission permission)
Determines if the argument Permission is "implied by" this WebUserDataPermission. For this to be the case all of the following must be true:

  • The argument is an instanceof WebUserDataPermission.
  • The first URLPattern in the name of the argument permission is matched by the first URLPattern in the name of this permission.
  • The first URLPattern in the name of the argument permission is NOT matched by any URLPattern in the URLPatternList of the URLPatternSpec of this permission.
  • If the first URLPattern in the name of the argument permission matches the first URLPattern in the URLPatternSpec of this permission, then every URLPattern in the URLPatternList of the URLPatternSpec of this permission is matched by a URLPattern in the URLPatternList of the argument permission.
  • The HTTP methods represented by the actions of the argument permission are a subset of the HTTP methods represented by the actions of this permission.
  • The transportType in the actions of this permission either corresponds to the value "NONE", or equals the transportType in the actions of the argument permission.

URLPattern matching is performed using the Servlet matching rules where two URL patterns match if they are related as follows:

  • their pattern values are String equivalent, or
  • this pattern is the path-prefix pattern "/*", or
  • this pattern is a path-prefix pattern (that is, it starts with "/" and ends with "/*") and the argument pattern starts with the substring of this pattern, minus its last 2 characters, and the next character of the argument pattern, if there is one, is "/", or
  • this pattern is an extension pattern (that is, it starts with "*.") and the argument pattern ends with this pattern, or
  • the reference pattern is the special default pattern, "/", which matches all argument patterns.

All of the comparisons described above are case sensitive.

Specified by:
implies in class Permission
Parameters:
permission - "this" WebUserDataPermission is checked to see if it implies the argument permission.

Returns:
true if the specified permission is implied by this object, false if not.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


servlet

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.servlet

The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

See:
Description

Interface Summary
Filter | A filter is an object that performs filtering tasks on either the request to a resource (a servlet or static content), or on the response from a resource, or both.
FilterChain | A FilterChain is an object provided by the servlet container to the developer giving a view into the invocation chain of a filtered request for a resource.
FilterConfig | A filter configuration object used by a servlet container to pass information to a filter during initialization.
RequestDispatcher | Defines an object that receives requests from the client and sends them to any resource (such as a servlet, HTML file, or JSP file) on the server.
Servlet | Defines methods that all servlets must implement.
ServletConfig | A servlet configuration object used by a servlet container to pass information to a servlet during initialization.
ServletContext | Defines a set of methods that a servlet uses to communicate with its servlet container, for example, to get the MIME type of a file, dispatch requests, or write to a log file.
ServletContextAttributeListener | Implementations of this interface receive notifications of changes to the attribute list on the servlet context of a web application.
ServletContextListener | Implementations of this interface receive notifications about changes to the servlet context of the web application they are part of.
ServletRequest | Defines an object to provide client request information to a servlet.
ServletRequestAttributeListener | A ServletRequestAttributeListener can be implemented by the developer interested in being notified of request attribute changes.
ServletRequestListener | A ServletRequestListener can be implemented by the developer interested in being notified of requests coming in and out of scope in a web component.
ServletResponse | Defines an object to assist a servlet in sending a response to the client.
SingleThreadModel | Deprecated. As of Java Servlet API 2.4, with no direct replacement.

Class Summary
GenericServlet | Defines a generic, protocol-independent servlet.
ServletContextAttributeEvent | This is the event class for notifications about changes to the attributes of the servlet context of a web application.
ServletContextEvent | This is the event class for notifications about changes to the servlet context of a web application.
ServletInputStream | Provides an input stream for reading binary data from a client request, including an efficient readLine method for reading data one line at a time.
ServletOutputStream | Provides an output stream for sending binary data to the client.
ServletRequestAttributeEvent | This is the event class for notifications of changes to the attributes of the servlet request in an application.
ServletRequestEvent | Events of this kind indicate lifecycle events for a ServletRequest.
ServletRequestWrapper | Provides a convenient implementation of the ServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.
ServletResponseWrapper | Provides a convenient implementation of the ServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.

Exception Summary
ServletException | Defines a general exception a servlet can throw when it encounters difficulty.
UnavailableException | Defines an exception that a servlet or filter throws to indicate that it is permanently or temporarily unavailable.

Package javax.servlet Description

The javax.servlet package contains a number of classes and interfaces that describe and define the contracts between a servlet class and the runtime environment provided for an instance of such a class by a conforming servlet container.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.servlet Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.servlet

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.servlet.ServletContextEvent
        • javax.servlet.ServletContextAttributeEvent
      • javax.servlet.ServletRequestEvent
        • javax.servlet.ServletRequestAttributeEvent
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
    • java.io.InputStream (implements java.io.Closeable)
      • javax.servlet.ServletInputStream
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • javax.servlet.ServletOutputStream
    • javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
    • javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.servlet.ServletException
          • javax.servlet.UnavailableException

Interface Hierarchy

  • java.util.EventListener
    • javax.servlet.ServletContextAttributeListener
    • javax.servlet.ServletContextListener
    • javax.servlet.ServletRequestAttributeListener
    • javax.servlet.ServletRequestListener
  • javax.servlet.Filter
  • javax.servlet.FilterChain
  • javax.servlet.FilterConfig
  • javax.servlet.RequestDispatcher
  • javax.servlet.Servlet
  • javax.servlet.ServletConfig
  • javax.servlet.ServletContext
  • javax.servlet.ServletRequest
  • javax.servlet.ServletResponse
  • javax.servlet.SingleThreadModel
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SingleThreadModel

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface SingleThreadModel

Deprecated. As of Java Servlet API 2.4, with no direct replacement.

public interface SingleThreadModel

Ensures that servlets handle only one request at a time. This interface has no methods.

If a servlet implements this interface, you are guaranteed that no two threads will execute concurrently in the servlet's service method. The servlet container can make this guarantee by synchronizing access to a single instance of the servlet, or by maintaining a pool of servlet instances and dispatching each new request to a free servlet.

Note that SingleThreadModel does not solve all thread safety issues. For example, session attributes and static variables can still be accessed by multiple requests on multiple threads at the same time, even when SingleThreadModel servlets are used. It is recommended that a developer take other means to resolve those issues instead of implementing this interface, such as avoiding the usage of an instance variable or synchronizing the block of the code accessing those resources. This interface is deprecated in Servlet API version 2.4.

Author:
Various

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Filter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface Filter

public interface Filter

A filter is an object that performs filtering tasks on either the request to a resource (a servlet or static content), or on the response from a resource, or both.

Filters perform filtering in the doFilter method. Every Filter has access to a FilterConfig object from which it can obtain its initialization parameters, a reference to the ServletContext which it can use, for example, to load resources needed for filtering tasks.

Filters are configured in the deployment descriptor of a web application

Examples that have been identified for this design are
1) Authentication Filters
2) Logging and Auditing Filters
3) Image conversion Filters
4) Data compression Filters
5) Encryption Filters
6) Tokenizing Filters
7) Filters that trigger resource access events
8) XSL/T filters
9) Mime-type chain Filter

Since:
Servlet 2.3

Method Summary
void | destroy() Called by the web container to indicate to a filter that it is being taken out of service.
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) The doFilter method of the Filter is called by the container each time a request/response pair is passed through the chain due to a client request for a resource at the end of the chain.
void | init(FilterConfig filterConfig) Called by the web container to indicate to a filter that it is being placed into service.

Method Detail

init

void init(FilterConfig filterConfig)
          throws ServletException
Called by the web container to indicate to a filter that it is being placed into service. The servlet container calls the init method exactly once after instantiating the filter. The init method must complete successfully before the filter is asked to do any filtering work.

The web container cannot place the filter into service if the init method either
1.Throws a ServletException
2.Does not return within a time period defined by the web container

Throws:
ServletException

doFilter

void doFilter(ServletRequest request,
              ServletResponse response,
              FilterChain chain)
              throws IOException,
                     ServletException
The doFilter method of the Filter is called by the container each time a request/response pair is passed through the chain due to a client request for a resource at the end of the chain. The FilterChain passed in to this method allows the Filter to pass on the request and response to the next entity in the chain.

A typical implementation of this method would follow the following pattern:-
1. Examine the request
2. Optionally wrap the request object with a custom implementation to filter content or headers for input filtering
3. Optionally wrap the response object with a custom implementation to filter content or headers for output filtering
4. a) Either invoke the next entity in the chain using the FilterChain object (chain.doFilter()),
4. b) or not pass on the request/response pair to the next entity in the filter chain to block the request processing
5. Directly set headers on the response after invocation of the next entity in the filter chain.

Throws:
IOException
ServletException

destroy

void destroy()
Called by the web container to indicate to a filter that it is being taken out of service. This method is only called once all threads within the filter's doFilter method have exited or after a timeout period has passed. After the web container calls this method, it will not call the doFilter method again on this instance of the filter.

This method gives the filter an opportunity to clean up any resources that are being held (for example, memory, file handles, threads) and make sure that any persistent state is synchronized with the filter's current state in memory.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FilterChain

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface FilterChain

public interface FilterChain

A FilterChain is an object provided by the servlet container to the developer giving a view into the invocation chain of a filtered request for a resource. Filters use the FilterChain to invoke the next filter in the chain, or if the calling filter is the last filter in the chain, to invoke the resource at the end of the chain.

Since:
Servlet 2.3
See Also:
Filter

Method Summary
 void doFilter(ServletRequest request, ServletResponse response)
Causes the next filter in the chain to be invoked, or if the calling filter is the last filter in the chain, causes the resource at the end of the chain to be invoked.

Method Detail

doFilter

void doFilter(ServletRequest request,
              ServletResponse response)
              throws IOException,
                     ServletException
Causes the next filter in the chain to be invoked, or if the calling filter is the last filter in the chain, causes the resource at the end of the chain to be invoked.

Parameters:
request - the request to pass along the chain.
response - the response to pass along the chain.
Throws:
IOException
ServletException
Since:
2.3
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FilterConfig

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface FilterConfig

public interface FilterConfig

A filter configuration object used by a servlet container to pass information to a filter during initialization.

Since:
Servlet 2.3
See Also:
Filter

Method Summary
String | getFilterName() Returns the filter-name of this filter as defined in the deployment descriptor.
String | getInitParameter(String name) Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.
Enumeration | getInitParameterNames() Returns the names of the filter's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the filter has no initialization parameters.
ServletContext | getServletContext() Returns a reference to the ServletContext in which the caller is executing.

Method Detail

getFilterName

String getFilterName()
Returns the filter-name of this filter as defined in the deployment descriptor.

getServletContext

ServletContext getServletContext()
Returns a reference to the ServletContext in which the caller is executing.

Returns:
a ServletContext object, used by the caller to interact with its servlet container
See Also:
ServletContext

getInitParameter

String getInitParameter(String name)
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.

Parameters:
name - a String specifying the name of the initialization parameter
Returns:
a String containing the value of the initialization parameter

getInitParameterNames

Enumeration getInitParameterNames()
Returns the names of the filter's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the filter has no initialization parameters.

Returns:
an Enumeration of String objects containing the names of the filter's initialization parameters
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


GenericServlet

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class GenericServlet

java.lang.Object
    extended by  javax.servlet.GenericServlet
All Implemented Interfaces:
Serializable, Servlet, ServletConfig
Direct Known Subclasses:
HttpServlet
public abstract class GenericServlet
extends Object
implements Servlet, ServletConfig, Serializable

Defines a generic, protocol-independent servlet. To write an HTTP servlet for use on the Web, extend HttpServlet instead.

GenericServlet implements the Servlet and ServletConfig interfaces. GenericServlet may be directly extended by a servlet, although it's more common to extend a protocol-specific subclass such as HttpServlet.

GenericServlet makes writing servlets easier. It provides simple versions of the lifecycle methods init and destroy and of the methods in the ServletConfig interface. GenericServlet also implements the log method, declared in the ServletContext interface.

To write a generic servlet, you need only override the abstract service method.

Author:
Various
See Also:
Serialized Form

Constructor Summary
GenericServlet()
Does nothing.
Method Summary
 void destroy()
Called by the servlet container to indicate to a servlet that the servlet is being taken out of service.
 String getInitParameter(String name)
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.
 Enumeration getInitParameterNames()
Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.
 ServletConfig getServletConfig()
Returns this servlet's ServletConfig object.
 ServletContext getServletContext()
Returns a reference to the ServletContext in which this servlet is running.
 String getServletInfo()
Returns information about the servlet, such as author, version, and copyright.
 String getServletName()
Returns the name of this servlet instance.
 void init()
A convenience method which can be overridden so that there's no need to call super.init(config).
 void init(ServletConfig config)
Called by the servlet container to indicate to a servlet that the servlet is being placed into service.
 void log(String msg)
Writes the specified message to a servlet log file, prepended by the servlet's name.
 void log(String message, Throwable t)
Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file, prepended by the servlet's name.
abstract  void service(ServletRequest req, ServletResponse res)
Called by the servlet container to allow the servlet to respond to a request.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GenericServlet

public GenericServlet()
Does nothing. All of the servlet initialization is done by one of the init methods.

Method Detail

destroy

public void destroy()
Called by the servlet container to indicate to a servlet that the servlet is being taken out of service. See Servlet.destroy().

Specified by:
destroy in interface Servlet

getInitParameter

public String getInitParameter(String name)
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist. See ServletConfig.getInitParameter(java.lang.String).

This method is supplied for convenience. It gets the value of the named parameter from the servlet's ServletConfig object.

Specified by:
getInitParameter in interface ServletConfig
Parameters:
name - a String specifying the name of the initialization parameter
Returns:
String a String containing the value of the initialization parameter

getInitParameterNames

public Enumeration getInitParameterNames()
Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters. See ServletConfig.getInitParameterNames().

This method is supplied for convenience. It gets the parameter names from the servlet's ServletConfig object.

Specified by:
getInitParameterNames in interface ServletConfig
Returns:
Enumeration an enumeration of String objects containing the names of the servlet's initialization parameters

getServletConfig

public ServletConfig getServletConfig()
Returns this servlet's ServletConfig object.

Specified by:
getServletConfig in interface Servlet
Returns:
ServletConfig the ServletConfig object that initialized this servlet
See Also:
Servlet.init(javax.servlet.ServletConfig)

getServletContext

public ServletContext getServletContext()
Returns a reference to the ServletContext in which this servlet is running. See ServletConfig.getServletContext().

This method is supplied for convenience. It gets the context from the servlet's ServletConfig object.

Specified by:
getServletContext in interface ServletConfig
Returns:
ServletContext the ServletContext object passed to this servlet by the init method
See Also:
ServletContext

getServletInfo

public String getServletInfo()
Returns information about the servlet, such as author, version, and copyright. By default, this method returns an empty string. Override this method to have it return a meaningful value. See Servlet.getServletInfo().

Specified by:
getServletInfo in interface Servlet
Returns:
String information about this servlet, by default an empty string

init

public void init(ServletConfig config)
          throws ServletException
Called by the servlet container to indicate to a servlet that the servlet is being placed into service. See Servlet.init(javax.servlet.ServletConfig).

This implementation stores the ServletConfig object it receives from the servlet container for later use. When overriding this form of the method, call super.init(config).

Specified by:
init in interface Servlet
Parameters:
config - the ServletConfig object that contains configutation information for this servlet
Throws:
ServletException - if an exception occurs that interrupts the servlet's normal operation
See Also:
UnavailableException

init

public void init()
          throws ServletException
A convenience method which can be overridden so that there's no need to call super.init(config).

Instead of overriding init(ServletConfig), simply override this method and it will be called by GenericServlet.init(ServletConfig config). The ServletConfig object can still be retrieved via getServletConfig().

Throws:
ServletException - if an exception occurs that interrupts the servlet's normal operation

log

public void log(String msg)
Writes the specified message to a servlet log file, prepended by the servlet's name. See ServletContext.log(String).

Parameters:
msg - a String specifying the message to be written to the log file

log

public void log(String message,
                Throwable t)
Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file, prepended by the servlet's name. See ServletContext.log(String, Throwable).

Parameters:
message - a String that describes the error or exception
t - the java.lang.Throwable error or exception

service

public abstract void service(ServletRequest req,
                             ServletResponse res)
                      throws ServletException,
                             IOException
Called by the servlet container to allow the servlet to respond to a request. See Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse).

This method is declared abstract so subclasses, such as HttpServlet, must override it.

Specified by:
service in interface Servlet
Parameters:
req - the ServletRequest object that contains the client's request
res - the ServletResponse object that will contain the servlet's response
Throws:
ServletException - if an exception occurs that interferes with the servlet's normal operation occurred
IOException - if an input or output exception occurs

getServletName

public String getServletName()
Returns the name of this servlet instance. See ServletConfig.getServletName().

Specified by:
getServletName in interface ServletConfig
Returns:
the name of this servlet instance
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


http

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.servlet.http

The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

See:
Description

Interface Summary
HttpServletRequest | Extends the ServletRequest interface to provide request information for HTTP servlets.
HttpServletResponse | Extends the ServletResponse interface to provide HTTP-specific functionality in sending a response.
HttpSession | Provides a way to identify a user across more than one page request or visit to a Web site and to store information about that user.
HttpSessionActivationListener | Objects that are bound to a session may listen to container events notifying them that sessions will be passivated and that session will be activated.
HttpSessionAttributeListener | This listener interface can be implemented in order to get notifications of changes to the attribute lists of sessions within this web application.
HttpSessionBindingListener | Causes an object to be notified when it is bound to or unbound from a session.
HttpSessionContext | Deprecated. As of Java(tm) Servlet API 2.1 for security reasons, with no replacement.
HttpSessionListener | Implementations of this interface are notified of changes to the list of active sessions in a web application.

Class Summary
Cookie | Creates a cookie, a small amount of information sent by a servlet to a Web browser, saved by the browser, and later sent back to the server.
HttpServlet | Provides an abstract class to be subclassed to create an HTTP servlet suitable for a Web site.
HttpServletRequestWrapper | Provides a convenient implementation of the HttpServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet.
HttpServletResponseWrapper | Provides a convenient implementation of the HttpServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet.
HttpSessionBindingEvent | Events of this type are either sent to an object that implements HttpSessionBindingListener when it is bound or unbound from a session, or to a HttpSessionAttributeListener that has been configured in the deployment descriptor when any attribute is bound, unbound or replaced in a session.
HttpSessionEvent | This is the class representing event notifications for changes to sessions within a web application.
HttpUtils | Deprecated. As of Java(tm) Servlet API 2.3.

Package javax.servlet.http Description

The javax.servlet.http package contains a number of classes and interfaces that describe and define the contracts between a servlet class running under the HTTP protocol and the runtime environment provided for an instance of such a class by a conforming servlet container.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.servlet.http Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.servlet.http

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.http.Cookie (implements java.lang.Cloneable)
    • java.util.EventObject (implements java.io.Serializable)
      • javax.servlet.http.HttpSessionEvent
        • javax.servlet.http.HttpSessionBindingEvent
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • javax.servlet.http.HttpServlet (implements java.io.Serializable)
    • javax.servlet.http.HttpUtils
    • javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
      • javax.servlet.http.HttpServletRequestWrapper (implements javax.servlet.http.HttpServletRequest)
    • javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)

Interface Hierarchy

  • java.util.EventListener
    • javax.servlet.http.HttpSessionActivationListener
    • javax.servlet.http.HttpSessionAttributeListener
    • javax.servlet.http.HttpSessionBindingListener
    • javax.servlet.http.HttpSessionListener
  • javax.servlet.http.HttpSession
  • javax.servlet.http.HttpSessionContext
  • javax.servlet.ServletRequest
    • javax.servlet.http.HttpServletRequest
  • javax.servlet.ServletResponse
    • javax.servlet.http.HttpServletResponse
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Cookie

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class Cookie

java.lang.Object
    extended by  javax.servlet.http.Cookie
All Implemented Interfaces:
Cloneable
public class Cookie
extends Object
implements Cloneable

Creates a cookie, a small amount of information sent by a servlet to a Web browser, saved by the browser, and later sent back to the server. A cookie's value can uniquely identify a client, so cookies are commonly used for session management.

A cookie has a name, a single value, and optional attributes such as a comment, path and domain qualifiers, a maximum age, and a version number. Some Web browsers have bugs in how they handle the optional attributes, so use them sparingly to improve the interoperability of your servlets.

The servlet sends cookies to the browser by using the HttpServletResponse.addCookie(javax.servlet.http.Cookie) method, which adds fields to HTTP response headers to send cookies to the browser, one at a time. The browser is expected to support 20 cookies for each Web server, 300 cookies total, and may limit cookie size to 4 KB each.

The browser returns cookies to the servlet by adding fields to HTTP request headers. Cookies can be retrieved from a request by using the HttpServletRequest.getCookies() method. Several cookies might have the same name but different path attributes.

Cookies affect the caching of the Web pages that use them. HTTP 1.0 does not cache pages that use cookies created with this class. This class does not support the cache control defined with HTTP 1.1.

This class supports both the Version 0 (by Netscape) and Version 1 (by RFC 2109) cookie specifications. By default, cookies are created using Version 0 to ensure the best interoperability.

Author:
Various

Constructor Summary
Cookie(String name, String value)
Constructs a cookie with a specified name and value.
Method Summary
Object | clone() Overrides the standard java.lang.Object.clone method to return a copy of this cookie.
String | getComment() Returns the comment describing the purpose of this cookie, or null if the cookie has no comment.
String | getDomain() Returns the domain name set for this cookie.
int | getMaxAge() Returns the maximum age of the cookie, specified in seconds, By default, -1 indicating the cookie will persist until browser shutdown.
String | getName() Returns the name of the cookie.
String | getPath() Returns the path on the server to which the browser returns this cookie.
boolean | getSecure() Returns true if the browser is sending cookies only over a secure protocol, or false if the browser can send cookies using any protocol.
String | getValue() Returns the value of the cookie.
int | getVersion() Returns the version of the protocol this cookie complies with.
void | setComment(String purpose) Specifies a comment that describes a cookie's purpose.
void | setDomain(String pattern) Specifies the domain within which this cookie should be presented.
void | setMaxAge(int expiry) Sets the maximum age of the cookie in seconds.
void | setPath(String uri) Specifies a path for the cookie to which the client should return the cookie.
void | setSecure(boolean flag) Indicates to the browser whether the cookie should only be sent using a secure protocol, such as HTTPS or SSL.
void | setValue(String newValue) Assigns a new value to a cookie after the cookie is created.
void | setVersion(int v) Sets the version of the cookie protocol this cookie complies with.
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Cookie

public Cookie(String name,
              String value)
Constructs a cookie with a specified name and value.

The name must conform to RFC 2109. That means it can contain only ASCII alphanumeric characters and cannot contain commas, semicolons, or white space or begin with a $ character. The cookie's name cannot be changed after creation.

The value can be anything the server chooses to send. Its value is probably of interest only to the server. The cookie's value can be changed after creation with the setValue method.

By default, cookies are created according to the Netscape cookie specification. The version can be changed with the setVersion method.

Parameters:
name - a String specifying the name of the cookie
value - a String specifying the value of the cookie
Throws:
IllegalArgumentException - if the cookie name contains illegal characters (for example, a comma, space, or semicolon) or it is one of the tokens reserved for use by the cookie protocol
See Also:
setValue(java.lang.String), setVersion(int)
Method Detail

setComment

public void setComment(String purpose)
Specifies a comment that describes a cookie's purpose. The comment is useful if the browser presents the cookie to the user. Comments are not supported by Netscape Version 0 cookies.

Parameters:
purpose - a String specifying the comment to display to the user
See Also:
getComment()

getComment

public String getComment()
Returns the comment describing the purpose of this cookie, or null if the cookie has no comment.

Returns:
a String containing the comment, or null if none
See Also:
setComment(java.lang.String)

setDomain

public void setDomain(String pattern)
Specifies the domain within which this cookie should be presented.

The form of the domain name is specified by RFC 2109. A domain name begins with a dot (.foo.com) and means that the cookie is visible to servers in a specified Domain Name System (DNS) zone (for example, www.foo.com, but not a.b.foo.com). By default, cookies are only returned to the server that sent them.

Parameters:
pattern - a String containing the domain name within which this cookie is visible; form is according to RFC 2109
See Also:
getDomain()

getDomain

public String getDomain()
Returns the domain name set for this cookie. The form of the domain name is set by RFC 2109.

Returns:
a String containing the domain name
See Also:
setDomain(java.lang.String)

setMaxAge

public void setMaxAge(int expiry)
Sets the maximum age of the cookie in seconds.

A positive value indicates that the cookie will expire after that many seconds have passed. Note that the value is the maximum age when the cookie will expire, not the cookie's current age.

A negative value means that the cookie is not stored persistently and will be deleted when the Web browser exits. A zero value causes the cookie to be deleted.

Parameters:
expiry - an integer specifying the maximum age of the cookie in seconds; if negative, means the cookie is not stored; if zero, deletes the cookie
See Also:
getMaxAge()

getMaxAge

public int getMaxAge()
Returns the maximum age of the cookie, specified in seconds, By default, -1 indicating the cookie will persist until browser shutdown.

Returns:
an integer specifying the maximum age of the cookie in seconds; if negative, means the cookie persists until browser shutdown
See Also:
setMaxAge(int)

setPath

public void setPath(String uri)
Specifies a path for the cookie to which the client should return the cookie.

The cookie is visible to all the pages in the directory you specify, and all the pages in that directory's subdirectories. A cookie's path must include the servlet that set the cookie, for example, /catalog, which makes the cookie visible to all directories on the server under /catalog.

Consult RFC 2109 (available on the Internet) for more information on setting path names for cookies.

Parameters:
uri - a String specifying a path
See Also:
getPath()

getPath

public String getPath()
Returns the path on the server to which the browser returns this cookie. The cookie is visible to all subpaths on the server.

Returns:
a String specifying a path that contains a servlet name, for example, /catalog
See Also:
setPath(java.lang.String)

setSecure

public void setSecure(boolean flag)
Indicates to the browser whether the cookie should only be sent using a secure protocol, such as HTTPS or SSL.

The default value is false.

Parameters:
flag - if true, sends the cookie from the browser to the server only when using a secure protocol; if false, sent on any protocol
See Also:
getSecure()

getSecure

public boolean getSecure()
Returns true if the browser is sending cookies only over a secure protocol, or false if the browser can send cookies using any protocol.

Returns:
true if the browser uses a secure protocol; otherwise, true
See Also:
setSecure(boolean)

getName

public String getName()
Returns the name of the cookie. The name cannot be changed after creation.

Returns:
a String specifying the cookie's name

setValue

public void setValue(String newValue)
Assigns a new value to a cookie after the cookie is created. If you use a binary value, you may want to use BASE64 encoding.

With Version 0 cookies, values should not contain white space, brackets, parentheses, equals signs, commas, double quotes, slashes, question marks, at signs, colons, and semicolons. Empty values may not behave the same way on all browsers.

Parameters:
newValue - a String specifying the new value
See Also:
getValue(), Cookie

getValue

public String getValue()
Returns the value of the cookie.

Returns:
a String containing the cookie's present value
See Also:
setValue(java.lang.String), Cookie

getVersion

public int getVersion()
Returns the version of the protocol this cookie complies with. Version 1 complies with RFC 2109, and version 0 complies with the original cookie specification drafted by Netscape. Cookies provided by a browser use and identify the browser's cookie version.

Returns:
0 if the cookie complies with the original Netscape specification; 1 if the cookie complies with RFC 2109
See Also:
setVersion(int)

setVersion

public void setVersion(int v)
Sets the version of the cookie protocol this cookie complies with. Version 0 complies with the original Netscape cookie specification. Version 1 complies with RFC 2109.

Since RFC 2109 is still somewhat new, consider version 1 as experimental; do not use it yet on production sites.

Parameters:
v - 0 if the cookie should comply with the original Netscape specification; 1 if the cookie should comply with RFC 2109
See Also:
getVersion()

clone

public Object clone()
Overrides the standard java.lang.Object.clone method to return a copy of this cookie.

Overrides:
clone in class Object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpServlet

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class HttpServlet

java.lang.Object
    extended by  javax.servlet.GenericServlet
        extended by  javax.servlet.http.HttpServlet
All Implemented Interfaces:
Serializable, Servlet, ServletConfig
public abstract class HttpServlet
extends GenericServlet
implements Serializable

Provides an abstract class to be subclassed to create an HTTP servlet suitable for a Web site. A subclass of HttpServlet must override at least one method, usually one of these:

  • doGet, if the servlet supports HTTP GET requests
  • doPost, for HTTP POST requests
  • doPut, for HTTP PUT requests
  • doDelete, for HTTP DELETE requests
  • init and destroy, to manage resources that are held for the life of the servlet
  • getServletInfo, which the servlet uses to provide information about itself

There's almost no reason to override the service method. service handles standard HTTP requests by dispatching them to the handler methods for each HTTP request type (the do XXX methods listed above).

Likewise, there's almost no reason to override the doOptions and doTrace methods.

Servlets typically run on multithreaded servers, so be aware that a servlet must handle concurrent requests and be careful to synchronize access to shared resources. Shared resources include in-memory data such as instance or class variables and external objects such as files, database connections, and network connections. See the Java Tutorial on Multithreaded Programming for more information on handling multiple threads in a Java program.

Author:
Various
See Also:
Serialized Form

Constructor Summary
HttpServlet()
Does nothing, because this is an abstract class.
Method Summary
protected void | doDelete(HttpServletRequest req, HttpServletResponse resp) Called by the server (via the service method) to allow a servlet to handle a DELETE request.
protected void | doGet(HttpServletRequest req, HttpServletResponse resp) Called by the server (via the service method) to allow a servlet to handle a GET request.
protected void | doHead(HttpServletRequest req, HttpServletResponse resp) Receives an HTTP HEAD request from the protected service method and handles the request.
protected void | doOptions(HttpServletRequest req, HttpServletResponse resp) Called by the server (via the service method) to allow a servlet to handle a OPTIONS request.
protected void | doPost(HttpServletRequest req, HttpServletResponse resp) Called by the server (via the service method) to allow a servlet to handle a POST request.
protected void | doPut(HttpServletRequest req, HttpServletResponse resp) Called by the server (via the service method) to allow a servlet to handle a PUT request.
protected void | doTrace(HttpServletRequest req, HttpServletResponse resp) Called by the server (via the service method) to allow a servlet to handle a TRACE request.
protected long | getLastModified(HttpServletRequest req) Returns the time the HttpServletRequest object was last modified, in milliseconds since midnight January 1, 1970 GMT.
protected void | service(HttpServletRequest req, HttpServletResponse resp) Receives standard HTTP requests from the public service method and dispatches them to the do XXX methods defined in this class.
void | service(ServletRequest req, ServletResponse res) Dispatches client requests to the protected service method.
Methods inherited from class javax.servlet.GenericServlet
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, init, log, log
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HttpServlet

public HttpServlet()
Does nothing, because this is an abstract class.

Method Detail

doGet

protected void doGet(HttpServletRequest req,
                     HttpServletResponse resp)
              throws ServletException,
                     IOException
Called by the server (via the service method) to allow a servlet to handle a GET request.

Overriding this method to support a GET request also automatically supports an HTTP HEAD request. A HEAD request is a GET request that returns no body in the response, only the request header fields.

When overriding this method, read the request data, write the response headers, get the response's writer or output stream object, and finally, write the response data. It's best to include content type and encoding. When using a PrintWriter object to return the response, set the content type before accessing the PrintWriter object.

The servlet container must write the headers before committing the response, because in HTTP the headers must be sent before the response body.

Where possible, set the Content-Length header (with the ServletResponse.setContentLength(int) method), to allow the servlet container to use a persistent connection to return its response to the client, improving performance. The content length is automatically set if the entire response fits inside the response buffer.

When using HTTP 1.1 chunked encoding (which means that the response has a Transfer-Encoding header), do not set the Content-Length header.

The GET method should be safe, that is, without any side effects for which users are held responsible. For example, most form queries have no side effects. If a client request is intended to change stored data, the request should use some other HTTP method.

The GET method should also be idempotent, meaning that it can be safely repeated. Sometimes making a method safe also makes it idempotent. For example, repeating queries is both safe and idempotent, but buying a product online or modifying data is neither safe nor idempotent.

If the request is incorrectly formatted, doGet returns an HTTP "Bad Request" message.

Parameters:
req - an HttpServletRequest object that contains the request the client has made of the servlet
resp - an HttpServletResponse object that contains the response the servlet sends to the client
Throws:
IOException - if an input or output error is detected when the servlet handles the GET request
ServletException - if the request for the GET could not be handled
See Also:
ServletResponse.setContentType(java.lang.String)

getLastModified

protected long getLastModified(HttpServletRequest req)
Returns the time the HttpServletRequest object was last modified, in milliseconds since midnight January 1, 1970 GMT. If the time is unknown, this method returns a negative number (the default).

Servlets that support HTTP GET requests and can quickly determine their last modification time should override this method. This makes browser and proxy caches work more effectively, reducing the load on server and network resources.

Parameters:
req - the HttpServletRequest object that is sent to the servlet
Returns:
a long integer specifying the time the HttpServletRequest object was last modified, in milliseconds since midnight, January 1, 1970 GMT, or -1 if the time is not known

doHead

protected void doHead(HttpServletRequest req,
                      HttpServletResponse resp)
               throws ServletException,
                      IOException

Receives an HTTP HEAD request from the protected service method and handles the request. The client sends a HEAD request when it wants to see only the headers of a response, such as Content-Type or Content-Length. The HTTP HEAD method counts the output bytes in the response to set the Content-Length header accurately.

If you override this method, you can avoid computing the response body and just set the response headers directly to improve performance. Make sure that the doHead method you write is both safe and idempotent (that is, protects itself from being called multiple times for one HTTP HEAD request).

If the HTTP HEAD request is incorrectly formatted, doHead returns an HTTP "Bad Request" message.

Parameters:
req - the request object that is passed to the servlet
resp - the response object that the servlet uses to return the headers to the clien
Throws:
IOException - if an input or output error occurs
ServletException - if the request for the HEAD could not be handled

doPost

protected void doPost(HttpServletRequest req,
                      HttpServletResponse resp)
               throws ServletException,
                      IOException
Called by the server (via the service method) to allow a servlet to handle a POST request. The HTTP POST method allows the client to send data of unlimited length to the Web server a single time and is useful when posting information such as credit card numbers.

When overriding this method, read the request data, write the response headers, get the response's writer or output stream object, and finally, write the response data. It's best to include content type and encoding. When using a PrintWriter object to return the response, set the content type before accessing the PrintWriter object.

The servlet container must write the headers before committing the response, because in HTTP the headers must be sent before the response body.

Where possible, set the Content-Length header (with the ServletResponse.setContentLength(int) method), to allow the servlet container to use a persistent connection to return its response to the client, improving performance. The content length is automatically set if the entire response fits inside the response buffer.

When using HTTP 1.1 chunked encoding (which means that the response has a Transfer-Encoding header), do not set the Content-Length header.

This method does not need to be either safe or idempotent. Operations requested through POST can have side effects for which the user can be held accountable, for example, updating stored data or buying items online.

If the HTTP POST request is incorrectly formatted, doPost returns an HTTP "Bad Request" message.

Parameters:
req - an HttpServletRequest object that contains the request the client has made of the servlet
resp - an HttpServletResponse object that contains the response the servlet sends to the client
Throws:
IOException - if an input or output error is detected when the servlet handles the request
ServletException - if the request for the POST could not be handled
See Also:
ServletOutputStream, ServletResponse.setContentType(java.lang.String)

doPut

protected void doPut(HttpServletRequest req,
                     HttpServletResponse resp)
              throws ServletException,
                     IOException
Called by the server (via the service method) to allow a servlet to handle a PUT request. The PUT operation allows a client to place a file on the server and is similar to sending a file by FTP.

When overriding this method, leave intact any content headers sent with the request (including Content-Length, Content-Type, Content-Transfer-Encoding, Content-Encoding, Content-Base, Content-Language, Content-Location, Content-MD5, and Content-Range). If your method cannot handle a content header, it must issue an error message (HTTP 501 - Not Implemented) and discard the request. For more information on HTTP 1.1, see RFC 2616 .

This method does not need to be either safe or idempotent. Operations that doPut performs can have side effects for which the user can be held accountable. When using this method, it may be useful to save a copy of the affected URL in temporary storage.

If the HTTP PUT request is incorrectly formatted, doPut returns an HTTP "Bad Request" message.

Parameters:
req - the HttpServletRequest object that contains the request the client made of the servlet
resp - the HttpServletResponse object that contains the response the servlet returns to the client
Throws:
IOException - if an input or output error occurs while the servlet is handling the PUT request
ServletException - if the request for the PUT cannot be handled

doDelete

protected void doDelete(HttpServletRequest req,
                        HttpServletResponse resp)
                 throws ServletException,
                        IOException
Called by the server (via the service method) to allow a servlet to handle a DELETE request. The DELETE operation allows a client to remove a document or Web page from the server.

This method does not need to be either safe or idempotent. Operations requested through DELETE can have side effects for which users can be held accountable. When using this method, it may be useful to save a copy of the affected URL in temporary storage.

If the HTTP DELETE request is incorrectly formatted, doDelete returns an HTTP "Bad Request" message.

Parameters:
req - the HttpServletRequest object that contains the request the client made of the servlet
resp - the HttpServletResponse object that contains the response the servlet returns to the client
Throws:
IOException - if an input or output error occurs while the servlet is handling the DELETE request
ServletException - if the request for the DELETE cannot be handled

doOptions

protected void doOptions(HttpServletRequest req,
                         HttpServletResponse resp)
                  throws ServletException,
                         IOException
Called by the server (via the service method) to allow a servlet to handle a OPTIONS request. The OPTIONS request determines which HTTP methods the server supports and returns an appropriate header. For example, if a servlet overrides doGet, this method returns the following header:

Allow: GET, HEAD, TRACE, OPTIONS

There's no need to override this method unless the servlet implements new HTTP methods, beyond those implemented by HTTP 1.1.

Parameters:
req - the HttpServletRequest object that contains the request the client made of the servlet
resp - the HttpServletResponse object that contains the response the servlet returns to the client
Throws:
IOException - if an input or output error occurs while the servlet is handling the OPTIONS request
ServletException - if the request for the OPTIONS cannot be handled

doTrace

protected void doTrace(HttpServletRequest req,
                       HttpServletResponse resp)
                throws ServletException,
                       IOException
Called by the server (via the service method) to allow a servlet to handle a TRACE request. A TRACE returns the headers sent with the TRACE request to the client, so that they can be used in debugging. There's no need to override this method.

Parameters:
req - the HttpServletRequest object that contains the request the client made of the servlet
resp - the HttpServletResponse object that contains the response the servlet returns to the client
Throws:
IOException - if an input or output error occurs while the servlet is handling the TRACE request
ServletException - if the request for the TRACE cannot be handled

service

protected void service(HttpServletRequest req,
                       HttpServletResponse resp)
                throws ServletException,
                       IOException
Receives standard HTTP requests from the public service method and dispatches them to the do XXX methods defined in this class. This method is an HTTP-specific version of the Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse) method. There's no need to override this method.

Parameters:
req - the HttpServletRequest object that contains the request the client made of the servlet
resp - the HttpServletResponse object that contains the response the servlet returns to the client
Throws:
IOException - if an input or output error occurs while the servlet is handling the HTTP request
ServletException - if the HTTP request cannot be handled
See Also:
Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse)

service

public void service(ServletRequest req,
                    ServletResponse res)
             throws ServletException,
                    IOException
Dispatches client requests to the protected service method. There's no need to override this method.

Specified by:
service in interface Servlet
Specified by:
service in class GenericServlet
Parameters:
req - the HttpServletRequest object that contains the request the client made of the servlet
res - the HttpServletResponse object that contains the response the servlet returns to the client
Throws:
IOException - if an input or output error occurs while the servlet is handling the HTTP request
ServletException - if the HTTP request cannot be handled
See Also:
Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpServletRequest

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpServletRequest

All Superinterfaces:
ServletRequest
All Known Implementing Classes:
HttpServletRequestWrapper
public interface HttpServletRequest
extends ServletRequest

Extends the ServletRequest interface to provide request information for HTTP servlets.

The servlet container creates an HttpServletRequest object and passes it as an argument to the servlet's service methods (doGet, doPost, etc).

Author:
Various

Field Summary
static String | BASIC_AUTH String identifier for Basic authentication.
static String | CLIENT_CERT_AUTH String identifier for Client Certificate authentication.
static String | DIGEST_AUTH String identifier for Digest authentication.
static String | FORM_AUTH String identifier for Form authentication.
Method Summary
 String getAuthType()
Returns the name of the authentication scheme used to protect the servlet.
 String getContextPath()
Returns the portion of the request URI that indicates the context of the request.
 Cookie[] getCookies()
Returns an array containing all of the Cookie objects the client sent with this request.
 long getDateHeader(String name)
Returns the value of the specified request header as a long value that represents a Date object.
 String getHeader(String name)
Returns the value of the specified request header as a String.
 Enumeration getHeaderNames()
Returns an enumeration of all the header names this request contains.
 Enumeration getHeaders(String name)
Returns all the values of the specified request header as an Enumeration of String objects.
 int getIntHeader(String name)
Returns the value of the specified request header as an int.
 String getMethod()
Returns the name of the HTTP method with which this request was made, for example, GET, POST, or PUT.
 String getPathInfo()
Returns any extra path information associated with the URL the client sent when it made this request.
 String getPathTranslated()
Returns any extra path information after the servlet name but before the query string, and translates it to a real path.
 String getQueryString()
Returns the query string that is contained in the request URL after the path.
 String getRemoteUser()
Returns the login of the user making this request, if the user has been authenticated, or null if the user has not been authenticated.
 String getRequestedSessionId()
Returns the session ID specified by the client.
 String getRequestURI()
Returns the part of this request's URL from the protocol name up to the query string in the first line of the HTTP request.
 StringBuffer getRequestURL()
Reconstructs the URL the client used to make the request.
 String getServletPath()
Returns the part of this request's URL that calls the servlet.
 HttpSession getSession()
Returns the current session associated with this request, or if the request does not have a session, creates one.
 HttpSession getSession(boolean create)
Returns the current HttpSession associated with this request or, if there is no current session and create is true, returns a new session.
 Principal getUserPrincipal()
Returns a java.security.Principal object containing the name of the current authenticated user.
 boolean isRequestedSessionIdFromCookie()
Checks whether the requested session ID came in as a cookie.
 boolean isRequestedSessionIdFromUrl()
Deprecated. As of Version 2.1 of the Java Servlet API, use isRequestedSessionIdFromURL() instead.
 boolean isRequestedSessionIdFromURL()
Checks whether the requested session ID came in as part of the request URL.
 boolean isRequestedSessionIdValid()
Checks whether the requested session ID is still valid.
 boolean isUserInRole(String role)
Returns a boolean indicating whether the authenticated user is included in the specified logical "role".
Methods inherited from interface javax.servlet.ServletRequest
getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocalAddr, getLocale, getLocales, getLocalName, getLocalPort, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRemotePort, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding

Field Detail

BASIC_AUTH

static final String BASIC_AUTH
String identifier for Basic authentication. Value "BASIC"

See Also:
Constant Field Values

FORM_AUTH

static final String FORM_AUTH
String identifier for Form authentication. Value "FORM"

See Also:
Constant Field Values

CLIENT_CERT_AUTH

static final String CLIENT_CERT_AUTH
String identifier for Client Certificate authentication. Value "CLIENT_CERT"

See Also:
Constant Field Values

DIGEST_AUTH

static final String DIGEST_AUTH
String identifier for Digest authentication. Value "DIGEST"

See Also:
Constant Field Values
Method Detail

getAuthType

String getAuthType()
Returns the name of the authentication scheme used to protect the servlet. All servlet containers support basic, form and client certificate authentication, and may additionally support digest authentication. If the servlet is not authenticated null is returned.

Same as the value of the CGI variable AUTH_TYPE.

Returns:
one of the static members BASIC_AUTH, FORM_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH (suitable for == comparison) or the container-specific string indicating the authentication scheme, or null if the request was not authenticated.

getCookies

Cookie[] getCookies()
Returns an array containing all of the Cookie objects the client sent with this request. This method returns null if no cookies were sent.

Returns:
an array of all the Cookies included with this request, or null if the request has no cookies

getDateHeader

long getDateHeader(String name)
Returns the value of the specified request header as a long value that represents a Date object. Use this method with headers that contain dates, such as If-Modified-Since.

The date is returned as the number of milliseconds since January 1, 1970 GMT. The header name is case insensitive.

If the request did not have a header of the specified name, this method returns -1. If the header can't be converted to a date, the method throws an IllegalArgumentException.

Parameters:
name - a String specifying the name of the header
Returns:
a long value representing the date specified in the header expressed as the number of milliseconds since January 1, 1970 GMT, or -1 if the named header was not included with the request
Throws:
IllegalArgumentException - If the header value can't be converted to a date

getHeader

String getHeader(String name)
Returns the value of the specified request header as a String. If the request did not include a header of the specified name, this method returns null. If there are multiple headers with the same name, this method returns the first head in the request. The header name is case insensitive. You can use this method with any request header.

Parameters:
name - a String specifying the header name
Returns:
a String containing the value of the requested header, or null if the request does not have a header of that name

getHeaders

Enumeration getHeaders(String name)
Returns all the values of the specified request header as an Enumeration of String objects.

Some headers, such as Accept-Language can be sent by clients as several headers each with a different value rather than sending the header as a comma separated list.

If the request did not include any headers of the specified name, this method returns an empty Enumeration. The header name is case insensitive. You can use this method with any request header.

Parameters:
name - a String specifying the header name
Returns:
an Enumeration containing the values of the requested header. If the request does not have any headers of that name return an empty enumeration. If the container does not allow access to header information, return null

getHeaderNames

Enumeration getHeaderNames()
Returns an enumeration of all the header names this request contains. If the request has no headers, this method returns an empty enumeration.

Some servlet containers do not allow servlets to access headers using this method, in which case this method returns null

Returns:
an enumeration of all the header names sent with this request; if the request has no headers, an empty enumeration; if the servlet container does not allow servlets to use this method, null

getIntHeader

int getIntHeader(String name)
Returns the value of the specified request header as an int. If the request does not have a header of the specified name, this method returns -1. If the header cannot be converted to an integer, this method throws a NumberFormatException.

The header name is case insensitive.

Parameters:
name - a String specifying the name of a request header
Returns:
an integer expressing the value of the request header or -1 if the request doesn't have a header of this name
Throws:
NumberFormatException - If the header value can't be converted to an int

getMethod

String getMethod()
Returns the name of the HTTP method with which this request was made, for example, GET, POST, or PUT. Same as the value of the CGI variable REQUEST_METHOD.

Returns:
a String specifying the name of the method with which this request was made

getPathInfo

String getPathInfo()
Returns any extra path information associated with the URL the client sent when it made this request. The extra path information follows the servlet path but precedes the query string and will start with a "/" character.

This method returns null if there was no extra path information.

Same as the value of the CGI variable PATH_INFO.

Returns:
a String, decoded by the web container, specifying extra path information that comes after the servlet path but before the query string in the request URL; or null if the URL does not have any extra path information

getPathTranslated

String getPathTranslated()
Returns any extra path information after the servlet name but before the query string, and translates it to a real path. Same as the value of the CGI variable PATH_TRANSLATED.

If the URL does not have any extra path information, this method returns null or the servlet container cannot translate the virtual path to a real path for any reason (such as when the web application is executed from an archive). The web container does not decode this string.

Returns:
a String specifying the real path, or null if the URL does not have any extra path information

getContextPath

String getContextPath()
Returns the portion of the request URI that indicates the context of the request. The context path always comes first in a request URI. The path starts with a "/" character but does not end with a "/" character. For servlets in the default (root) context, this method returns "". The container does not decode this string.

It is possible that a servlet container may match a context by more than one context path. In such cases this method will return the actual context path used by the request and it may differ from the path returned by the ServletContext.getContextPath() method. The context path returned by ServletContext.getContextPath() should be considered as the prime or preferred context path of the application.

Returns:
a String specifying the portion of the request URI that indicates the context of the request
See Also:
ServletContext.getContextPath()

getQueryString

String getQueryString()
Returns the query string that is contained in the request URL after the path. This method returns null if the URL does not have a query string. Same as the value of the CGI variable QUERY_STRING.

Returns:
a String containing the query string or null if the URL contains no query string. The value is not decoded by the container.

getRemoteUser

String getRemoteUser()
Returns the login of the user making this request, if the user has been authenticated, or null if the user has not been authenticated. Whether the user name is sent with each subsequent request depends on the browser and type of authentication. Same as the value of the CGI variable REMOTE_USER.

Returns:
a String specifying the login of the user making this request, or null if the user login is not known

isUserInRole

boolean isUserInRole(String role)
Returns a boolean indicating whether the authenticated user is included in the specified logical "role". Roles and role membership can be defined using deployment descriptors. If the user has not been authenticated, the method returns false.

Parameters:
role - a String specifying the name of the role
Returns:
a boolean indicating whether the user making this request belongs to a given role; false if the user has not been authenticated

getUserPrincipal

Principal getUserPrincipal()
Returns a java.security.Principal object containing the name of the current authenticated user. If the user has not been authenticated, the method returns null.

Returns:
a java.security.Principal containing the name of the user making this request; null if the user has not been authenticated

getRequestedSessionId

String getRequestedSessionId()
Returns the session ID specified by the client. This may not be the same as the ID of the current valid session for this request. If the client did not specify a session ID, this method returns null.

Returns:
a String specifying the session ID, or null if the request did not specify a session ID
See Also:
isRequestedSessionIdValid()

getRequestURI

String getRequestURI()
Returns the part of this request's URL from the protocol name up to the query string in the first line of the HTTP request. The web container does not decode this String. For example:
First line of HTTP request | Returned Value
POST /some/path.html HTTP/1.1 | /some/path.html
GET http://foo.bar/a.html HTTP/1.0 | /a.html
HEAD /xyz?a=b HTTP/1.1 | /xyz

To reconstruct an URL with a scheme and host, use HttpUtils.getRequestURL(javax.servlet.http.HttpServletRequest).

Returns:
a String containing the part of the URL from the protocol name up to the query string
See Also:
HttpUtils.getRequestURL(javax.servlet.http.HttpServletRequest)

getRequestURL

StringBuffer getRequestURL()
Reconstructs the URL the client used to make the request. The returned URL contains a protocol, server name, port number, and server path, but it does not include query string parameters.

If this request has been forwarded using RequestDispatcher.forward(javax.servlet.ServletRequest, javax.servlet.ServletResponse), the server path in the reconstructed URL must reflect the path used to obtain the RequestDispatcher, and not the server path specified by the client.

Because this method returns a StringBuffer, not a string, you can modify the URL easily, for example, to append query parameters.

This method is useful for creating redirect messages and for reporting errors.

Returns:
a StringBuffer object containing the reconstructed URL

getServletPath

String getServletPath()
Returns the part of this request's URL that calls the servlet. This path starts with a "/" character and includes either the servlet name or a path to the servlet, but does not include any extra path information or a query string. Same as the value of the CGI variable SCRIPT_NAME.

This method will return an empty string ("") if the servlet used to process this request was matched using the "/*" pattern.

Returns:
a String containing the name or path of the servlet being called, as specified in the request URL, decoded, or an empty string if the servlet used to process the request is matched using the "/*" pattern.

getSession

HttpSession getSession(boolean create)
Returns the current HttpSession associated with this request or, if there is no current session and create is true, returns a new session.

If create is false and the request has no valid HttpSession, this method returns null.

To make sure the session is properly maintained, you must call this method before the response is committed. If the container is using cookies to maintain session integrity and is asked to create a new session when the response is committed, an IllegalStateException is thrown.

Parameters:
create - true to create a new session for this request if necessary; false to return null if there's no current session
Returns:
the HttpSession associated with this request or null if create is false and the request has no valid session
See Also:
getSession()

getSession

HttpSession getSession()
Returns the current session associated with this request, or if the request does not have a session, creates one.

Returns:
the HttpSession associated with this request
See Also:
getSession(boolean)

isRequestedSessionIdValid

boolean isRequestedSessionIdValid()
Checks whether the requested session ID is still valid.

If the client did not specify any session ID, this method returns false.

Returns:
true if this request has an id for a valid session in the current session context; false otherwise
See Also:
getRequestedSessionId(), getSession(boolean), HttpSessionContext

isRequestedSessionIdFromCookie

boolean isRequestedSessionIdFromCookie()
Checks whether the requested session ID came in as a cookie.

Returns:
true if the session ID came in as a cookie; otherwise, false
See Also:
getSession(boolean)

isRequestedSessionIdFromURL

boolean isRequestedSessionIdFromURL()
Checks whether the requested session ID came in as part of the request URL.

Returns:
true if the session ID came in as part of a URL; otherwise, false
See Also:
getSession(boolean)

isRequestedSessionIdFromUrl

boolean isRequestedSessionIdFromUrl()
Deprecated. As of Version 2.1 of the Java Servlet API, use isRequestedSessionIdFromURL() instead.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpServletRequestWrapper

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class HttpServletRequestWrapper

java.lang.Object
    extended by  javax.servlet.ServletRequestWrapper
        extended by  javax.servlet.http.HttpServletRequestWrapper
All Implemented Interfaces:
HttpServletRequest, ServletRequest
public class HttpServletRequestWrapper
extends ServletRequestWrapper
implements HttpServletRequest

Provides a convenient implementation of the HttpServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet. This class implements the Wrapper or Decorator pattern. Methods default to calling through to the wrapped request object.

Since:
v 2.3
See Also:
HttpServletRequest

Field Summary
Fields inherited from interface javax.servlet.http.HttpServletRequest
BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, FORM_AUTH
Constructor Summary
HttpServletRequestWrapper(HttpServletRequest request)
Constructs a request object wrapping the given request.
Method Summary
 String getAuthType()
The default behavior of this method is to return getAuthType() on the wrapped request object.
 String getContextPath()
The default behavior of this method is to return getContextPath() on the wrapped request object.
 Cookie[] getCookies()
The default behavior of this method is to return getCookies() on the wrapped request object.
 long getDateHeader(String name)
The default behavior of this method is to return getDateHeader(String name) on the wrapped request object.
 String getHeader(String name)
The default behavior of this method is to return getHeader(String name) on the wrapped request object.
 Enumeration getHeaderNames()
The default behavior of this method is to return getHeaderNames() on the wrapped request object.
 Enumeration getHeaders(String name)
The default behavior of this method is to return getHeaders(String name) on the wrapped request object.
 int getIntHeader(String name)
The default behavior of this method is to return getIntHeader(String name) on the wrapped request object.
 String getMethod()
The default behavior of this method is to return getMethod() on the wrapped request object.
 String getPathInfo()
The default behavior of this method is to return getPathInfo() on the wrapped request object.
 String getPathTranslated()
The default behavior of this method is to return getPathTranslated() on the wrapped request object.
 String getQueryString()
The default behavior of this method is to return getQueryString() on the wrapped request object.
 String getRemoteUser()
The default behavior of this method is to return getRemoteUser() on the wrapped request object.
 String getRequestedSessionId()
The default behavior of this method is to return getRequestedSessionId() on the wrapped request object.
 String getRequestURI()
The default behavior of this method is to return getRequestURI() on the wrapped request object.
 StringBuffer getRequestURL()
The default behavior of this method is to return getRequestURL() on the wrapped request object.
 String getServletPath()
The default behavior of this method is to return getServletPath() on the wrapped request object.
 HttpSession getSession()
The default behavior of this method is to return getSession() on the wrapped request object.
 HttpSession getSession(boolean create)
The default behavior of this method is to return getSession(boolean create) on the wrapped request object.
 Principal getUserPrincipal()
The default behavior of this method is to return getUserPrincipal() on the wrapped request object.
 boolean isRequestedSessionIdFromCookie()
The default behavior of this method is to return isRequestedSessionIdFromCookie() on the wrapped request object.
 boolean isRequestedSessionIdFromUrl()
The default behavior of this method is to return isRequestedSessionIdFromUrl() on the wrapped request object.
 boolean isRequestedSessionIdFromURL()
The default behavior of this method is to return isRequestedSessionIdFromURL() on the wrapped request object.
 boolean isRequestedSessionIdValid()
The default behavior of this method is to return isRequestedSessionIdValid() on the wrapped request object.
 boolean isUserInRole(String role)
The default behavior of this method is to return isUserInRole(String role) on the wrapped request object.
Methods inherited from class javax.servlet.ServletRequestWrapper
getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocalAddr, getLocale, getLocales, getLocalName, getLocalPort, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRemotePort, getRequest, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding, setRequest
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.ServletRequest
getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocalAddr, getLocale, getLocales, getLocalName, getLocalPort, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRemotePort, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding

Constructor Detail

HttpServletRequestWrapper

public HttpServletRequestWrapper(HttpServletRequest request)
Constructs a request object wrapping the given request.

Throws:
IllegalArgumentException - if the request is null
Method Detail

getAuthType

public String getAuthType()
The default behavior of this method is to return getAuthType() on the wrapped request object.

Specified by:
getAuthType in interface HttpServletRequest
Returns:
one of the static members BASIC_AUTH, FORM_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH (suitable for == comparison) or the container-specific string indicating the authentication scheme, or null if the request was not authenticated.

getCookies

public Cookie[] getCookies()
The default behavior of this method is to return getCookies() on the wrapped request object.

Specified by:
getCookies in interface HttpServletRequest
Returns:
an array of all the Cookies included with this request, or null if the request has no cookies

getDateHeader

public long getDateHeader(String name)
The default behavior of this method is to return getDateHeader(String name) on the wrapped request object.

Specified by:
getDateHeader in interface HttpServletRequest
Parameters:
name - a String specifying the name of the header
Returns:
a long value representing the date specified in the header expressed as the number of milliseconds since January 1, 1970 GMT, or -1 if the named header was not included with the request

getHeader

public String getHeader(String name)
The default behavior of this method is to return getHeader(String name) on the wrapped request object.

Specified by:
getHeader in interface HttpServletRequest
Parameters:
name - a String specifying the header name
Returns:
a String containing the value of the requested header, or null if the request does not have a header of that name

getHeaders

public Enumeration getHeaders(String name)
The default behavior of this method is to return getHeaders(String name) on the wrapped request object.

Specified by:
getHeaders in interface HttpServletRequest
Parameters:
name - a String specifying the header name
Returns:
an Enumeration containing the values of the requested header. If the request does not have any headers of that name return an empty enumeration. If the container does not allow access to header information, return null

getHeaderNames

public Enumeration getHeaderNames()
The default behavior of this method is to return getHeaderNames() on the wrapped request object.

Specified by:
getHeaderNames in interface HttpServletRequest
Returns:
an enumeration of all the header names sent with this request; if the request has no headers, an empty enumeration; if the servlet container does not allow servlets to use this method, null

getIntHeader

public int getIntHeader(String name)
The default behavior of this method is to return getIntHeader(String name) on the wrapped request object.

Specified by:
getIntHeader in interface HttpServletRequest
Parameters:
name - a String specifying the name of a request header
Returns:
an integer expressing the value of the request header or -1 if the request doesn't have a header of this name

getMethod

public String getMethod()
The default behavior of this method is to return getMethod() on the wrapped request object.

Specified by:
getMethod in interface HttpServletRequest
Returns:
a String specifying the name of the method with which this request was made

getPathInfo

public String getPathInfo()
The default behavior of this method is to return getPathInfo() on the wrapped request object.

Specified by:
getPathInfo in interface HttpServletRequest
Returns:
a String, decoded by the web container, specifying extra path information that comes after the servlet path but before the query string in the request URL; or null if the URL does not have any extra path information

getPathTranslated

public String getPathTranslated()
The default behavior of this method is to return getPathTranslated() on the wrapped request object.

Specified by:
getPathTranslated in interface HttpServletRequest
Returns:
a String specifying the real path, or null if the URL does not have any extra path information

getContextPath

public String getContextPath()
The default behavior of this method is to return getContextPath() on the wrapped request object.

Specified by:
getContextPath in interface HttpServletRequest
Returns:
a String specifying the portion of the request URI that indicates the context of the request
See Also:
ServletContext.getContextPath()

getQueryString

public String getQueryString()
The default behavior of this method is to return getQueryString() on the wrapped request object.

Specified by:
getQueryString in interface HttpServletRequest
Returns:
a String containing the query string or null if the URL contains no query string. The value is not decoded by the container.

getRemoteUser

public String getRemoteUser()
The default behavior of this method is to return getRemoteUser() on the wrapped request object.

Specified by:
getRemoteUser in interface HttpServletRequest
Returns:
a String specifying the login of the user making this request, or null if the user login is not known

isUserInRole

public boolean isUserInRole(String role)
The default behavior of this method is to return isUserInRole(String role) on the wrapped request object.

Specified by:
isUserInRole in interface HttpServletRequest
Parameters:
role - a String specifying the name of the role
Returns:
a boolean indicating whether the user making this request belongs to a given role; false if the user has not been authenticated

getUserPrincipal

public Principal getUserPrincipal()
The default behavior of this method is to return getUserPrincipal() on the wrapped request object.

Specified by:
getUserPrincipal in interface HttpServletRequest
Returns:
a java.security.Principal containing the name of the user making this request; null if the user has not been authenticated

getRequestedSessionId

public String getRequestedSessionId()
The default behavior of this method is to return getRequestedSessionId() on the wrapped request object.

Specified by:
getRequestedSessionId in interface HttpServletRequest
Returns:
a String specifying the session ID, or null if the request did not specify a session ID
See Also:
HttpServletRequest.isRequestedSessionIdValid()

getRequestURI

public String getRequestURI()
The default behavior of this method is to return getRequestURI() on the wrapped request object.

Specified by:
getRequestURI in interface HttpServletRequest
Returns:
a String containing the part of the URL from the protocol name up to the query string
See Also:
HttpUtils.getRequestURL(javax.servlet.http.HttpServletRequest)

getRequestURL

public StringBuffer getRequestURL()
The default behavior of this method is to return getRequestURL() on the wrapped request object.

Specified by:
getRequestURL in interface HttpServletRequest
Returns:
a StringBuffer object containing the reconstructed URL

getServletPath

public String getServletPath()
The default behavior of this method is to return getServletPath() on the wrapped request object.

Specified by:
getServletPath in interface HttpServletRequest
Returns:
a String containing the name or path of the servlet being called, as specified in the request URL, decoded, or an empty string if the servlet used to process the request is matched using the "/*" pattern.

getSession

public HttpSession getSession(boolean create)
The default behavior of this method is to return getSession(boolean create) on the wrapped request object.

Specified by:
getSession in interface HttpServletRequest
Parameters:
create - true to create a new session for this request if necessary; false to return null if there's no current session
Returns:
the HttpSession associated with this request or null if create is false and the request has no valid session
See Also:
HttpServletRequest.getSession()

getSession

public HttpSession getSession()
The default behavior of this method is to return getSession() on the wrapped request object.

Specified by:
getSession in interface HttpServletRequest
Returns:
the HttpSession associated with this request
See Also:
HttpServletRequest.getSession(boolean)

isRequestedSessionIdValid

public boolean isRequestedSessionIdValid()
The default behavior of this method is to return isRequestedSessionIdValid() on the wrapped request object.

Specified by:
isRequestedSessionIdValid in interface HttpServletRequest
Returns:
true if this request has an id for a valid session in the current session context; false otherwise
See Also:
HttpServletRequest.getRequestedSessionId(), HttpServletRequest.getSession(boolean), HttpSessionContext

isRequestedSessionIdFromCookie

public boolean isRequestedSessionIdFromCookie()
The default behavior of this method is to return isRequestedSessionIdFromCookie() on the wrapped request object.

Specified by:
isRequestedSessionIdFromCookie in interface HttpServletRequest
Returns:
true if the session ID came in as a cookie; otherwise, false
See Also:
HttpServletRequest.getSession(boolean)

isRequestedSessionIdFromURL

public boolean isRequestedSessionIdFromURL()
The default behavior of this method is to return isRequestedSessionIdFromURL() on the wrapped request object.

Specified by:
isRequestedSessionIdFromURL in interface HttpServletRequest
Returns:
true if the session ID came in as part of a URL; otherwise, false
See Also:
HttpServletRequest.getSession(boolean)

isRequestedSessionIdFromUrl

public boolean isRequestedSessionIdFromUrl()
The default behavior of this method is to return isRequestedSessionIdFromUrl() on the wrapped request object.

Specified by:
isRequestedSessionIdFromUrl in interface HttpServletRequest
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpServletResponse

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpServletResponse

All Superinterfaces:
ServletResponse
All Known Implementing Classes:
HttpServletResponseWrapper
public interface HttpServletResponse
extends ServletResponse

Extends the ServletResponse interface to provide HTTP-specific functionality in sending a response. For example, it has methods to access HTTP headers and cookies.

The servlet container creates an HttpServletResponse object and passes it as an argument to the servlet's service methods (doGet, doPost, etc).

Author:
Various
See Also:
ServletResponse

Field Summary
static int | SC_ACCEPTED Status code (202) indicating that a request was accepted for processing, but was not completed.
static int | SC_BAD_GATEWAY Status code (502) indicating that the HTTP server received an invalid response from a server it consulted when acting as a proxy or gateway.
static int | SC_BAD_REQUEST Status code (400) indicating the request sent by the client was syntactically incorrect.
static int | SC_CONFLICT Status code (409) indicating that the request could not be completed due to a conflict with the current state of the resource.
static int | SC_CONTINUE Status code (100) indicating the client can continue.
static int | SC_CREATED Status code (201) indicating the request succeeded and created a new resource on the server.
static int | SC_EXPECTATION_FAILED Status code (417) indicating that the server could not meet the expectation given in the Expect request header.
static int | SC_FORBIDDEN Status code (403) indicating the server understood the request but refused to fulfill it.
static int | SC_FOUND Status code (302) indicating that the resource reside temporarily under a different URI.
static int | SC_GATEWAY_TIMEOUT Status code (504) indicating that the server did not receive a timely response from the upstream server while acting as a gateway or proxy.
static int | SC_GONE Status code (410) indicating that the resource is no longer available at the server and no forwarding address is known.
static int | SC_HTTP_VERSION_NOT_SUPPORTED Status code (505) indicating that the server does not support or refuses to support the HTTP protocol version that was used in the request message.
static int | SC_INTERNAL_SERVER_ERROR Status code (500) indicating an error inside the HTTP server which prevented it from fulfilling the request.
static int | SC_LENGTH_REQUIRED Status code (411) indicating that the request cannot be handled without a defined Content-Length.
static int | SC_METHOD_NOT_ALLOWED Status code (405) indicating that the method specified in the Request-Line is not allowed for the resource identified by the Request-URI.
static int | SC_MOVED_PERMANENTLY Status code (301) indicating that the resource has permanently moved to a new location, and that future references should use a new URI with their requests.
static int | SC_MOVED_TEMPORARILY Status code (302) indicating that the resource has temporarily moved to another location, but that future references should still use the original URI to access the resource.
static int | SC_MULTIPLE_CHOICES Status code (300) indicating that the requested resource corresponds to any one of a set of representations, each with its own specific location.
static int | SC_NO_CONTENT Status code (204) indicating that the request succeeded but that there was no new information to return.
static int | SC_NON_AUTHORITATIVE_INFORMATION Status code (203) indicating that the meta information presented by the client did not originate from the server.
static int | SC_NOT_ACCEPTABLE Status code (406) indicating that the resource identified by the request is only capable of generating response entities which have content characteristics not acceptable according to the accept headers sent in the request.
static int | SC_NOT_FOUND Status code (404) indicating that the requested resource is not available.
static int | SC_NOT_IMPLEMENTED Status code (501) indicating the HTTP server does not support the functionality needed to fulfill the request.
static int | SC_NOT_MODIFIED Status code (304) indicating that a conditional GET operation found that the resource was available and not modified.
static int | SC_OK Status code (200) indicating the request succeeded normally.
static int | SC_PARTIAL_CONTENT Status code (206) indicating that the server has fulfilled the partial GET request for the resource.
static int | SC_PAYMENT_REQUIRED Status code (402) reserved for future use.
static int | SC_PRECONDITION_FAILED Status code (412) indicating that the precondition given in one or more of the request-header fields evaluated to false when it was tested on the server.
static int | SC_PROXY_AUTHENTICATION_REQUIRED Status code (407) indicating that the client MUST first authenticate itself with the proxy.
static int | SC_REQUEST_ENTITY_TOO_LARGE Status code (413) indicating that the server is refusing to process the request because the request entity is larger than the server is willing or able to process.
static int | SC_REQUEST_TIMEOUT Status code (408) indicating that the client did not produce a request within the time that the server was prepared to wait.
static int | SC_REQUEST_URI_TOO_LONG Status code (414) indicating that the server is refusing to service the request because the Request-URI is longer than the server is willing to interpret.
static int | SC_REQUESTED_RANGE_NOT_SATISFIABLE Status code (416) indicating that the server cannot serve the requested byte range.
static int | SC_RESET_CONTENT Status code (205) indicating that the agent SHOULD reset the document view which caused the request to be sent.
static int | SC_SEE_OTHER Status code (303) indicating that the response to the request can be found under a different URI.
static int | SC_SERVICE_UNAVAILABLE Status code (503) indicating that the HTTP server is temporarily overloaded, and unable to handle the request.
static int | SC_SWITCHING_PROTOCOLS Status code (101) indicating the server is switching protocols according to Upgrade header.
static int | SC_TEMPORARY_REDIRECT Status code (307) indicating that the requested resource resides temporarily under a different URI.
static int | SC_UNAUTHORIZED Status code (401) indicating that the request requires HTTP authentication.
static int | SC_UNSUPPORTED_MEDIA_TYPE Status code (415) indicating that the server is refusing to service the request because the entity of the request is in a format not supported by the requested resource for the requested method.
static int | SC_USE_PROXY Status code (305) indicating that the requested resource MUST be accessed through the proxy given by the Location field.
Method Summary
 void addCookie(Cookie cookie)
Adds the specified cookie to the response.
 void addDateHeader(String name, long date)
Adds a response header with the given name and date-value.
 void addHeader(String name, String value)
Adds a response header with the given name and value.
 void addIntHeader(String name, int value)
Adds a response header with the given name and integer value.
 boolean containsHeader(String name)
Returns a boolean indicating whether the named response header has already been set.
 String encodeRedirectUrl(String url)
Deprecated. As of version 2.1, use encodeRedirectURL(String url) instead
 String encodeRedirectURL(String url)
Encodes the specified URL for use in the sendRedirect method or, if encoding is not needed, returns the URL unchanged.
 String encodeUrl(String url)
Deprecated. As of version 2.1, use encodeURL(String url) instead
 String encodeURL(String url)
Encodes the specified URL by including the session ID in it, or, if encoding is not needed, returns the URL unchanged.
 void sendError(int sc)
Sends an error response to the client using the specified status code and clearing the buffer.
 void sendError(int sc, String msg)
Sends an error response to the client using the specified status.
 void sendRedirect(String location)
Sends a temporary redirect response to the client using the specified redirect location URL.
 void setDateHeader(String name, long date)
Sets a response header with the given name and date-value.
 void setHeader(String name, String value)
Sets a response header with the given name and value.
 void setIntHeader(String name, int value)
Sets a response header with the given name and integer value.
 void setStatus(int sc)
Sets the status code for this response.
 void setStatus(int sc, String sm)
Deprecated. As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use setStatus(int), to send an error with a description use sendError(int, String). Sets the status code and message for this response.
Methods inherited from interface javax.servlet.ServletResponse
flushBuffer, getBufferSize, getCharacterEncoding, getContentType, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setCharacterEncoding, setContentLength, setContentType, setLocale

Field Detail

SC_CONTINUE

static final int SC_CONTINUE
Status code (100) indicating the client can continue.

See Also:
Constant Field Values

SC_SWITCHING_PROTOCOLS

static final int SC_SWITCHING_PROTOCOLS
Status code (101) indicating the server is switching protocols according to Upgrade header.

See Also:
Constant Field Values

SC_OK

static final int SC_OK
Status code (200) indicating the request succeeded normally.

See Also:
Constant Field Values

SC_CREATED

static final int SC_CREATED
Status code (201) indicating the request succeeded and created a new resource on the server.

See Also:
Constant Field Values

SC_ACCEPTED

static final int SC_ACCEPTED
Status code (202) indicating that a request was accepted for processing, but was not completed.

See Also:
Constant Field Values

SC_NON_AUTHORITATIVE_INFORMATION

static final int SC_NON_AUTHORITATIVE_INFORMATION
Status code (203) indicating that the meta information presented by the client did not originate from the server.

See Also:
Constant Field Values

SC_NO_CONTENT

static final int SC_NO_CONTENT
Status code (204) indicating that the request succeeded but that there was no new information to return.

See Also:
Constant Field Values

SC_RESET_CONTENT

static final int SC_RESET_CONTENT
Status code (205) indicating that the agent SHOULD reset the document view which caused the request to be sent.

See Also:
Constant Field Values

SC_PARTIAL_CONTENT

static final int SC_PARTIAL_CONTENT
Status code (206) indicating that the server has fulfilled the partial GET request for the resource.

See Also:
Constant Field Values

SC_MULTIPLE_CHOICES

static final int SC_MULTIPLE_CHOICES
Status code (300) indicating that the requested resource corresponds to any one of a set of representations, each with its own specific location.

See Also:
Constant Field Values

SC_MOVED_PERMANENTLY

static final int SC_MOVED_PERMANENTLY
Status code (301) indicating that the resource has permanently moved to a new location, and that future references should use a new URI with their requests.

See Also:
Constant Field Values

SC_MOVED_TEMPORARILY

static final int SC_MOVED_TEMPORARILY
Status code (302) indicating that the resource has temporarily moved to another location, but that future references should still use the original URI to access the resource. This definition is being retained for backwards compatibility. SC_FOUND is now the preferred definition.

See Also:
Constant Field Values

SC_FOUND

static final int SC_FOUND
Status code (302) indicating that the resource reside temporarily under a different URI. Since the redirection might be altered on occasion, the client should continue to use the Request-URI for future requests.(HTTP/1.1) To represent the status code (302), it is recommended to use this variable.

See Also:
Constant Field Values

SC_SEE_OTHER

static final int SC_SEE_OTHER
Status code (303) indicating that the response to the request can be found under a different URI.

See Also:
Constant Field Values

SC_NOT_MODIFIED

static final int SC_NOT_MODIFIED
Status code (304) indicating that a conditional GET operation found that the resource was available and not modified.

See Also:
Constant Field Values

SC_USE_PROXY

static final int SC_USE_PROXY
Status code (305) indicating that the requested resource MUST be accessed through the proxy given by the Location field.

See Also:
Constant Field Values

SC_TEMPORARY_REDIRECT

static final int SC_TEMPORARY_REDIRECT
Status code (307) indicating that the requested resource resides temporarily under a different URI. The temporary URI SHOULD be given by the Location field in the response.

See Also:
Constant Field Values

SC_BAD_REQUEST

static final int SC_BAD_REQUEST
Status code (400) indicating the request sent by the client was syntactically incorrect.

See Also:
Constant Field Values

SC_UNAUTHORIZED

static final int SC_UNAUTHORIZED
Status code (401) indicating that the request requires HTTP authentication.

See Also:
Constant Field Values

SC_PAYMENT_REQUIRED

static final int SC_PAYMENT_REQUIRED
Status code (402) reserved for future use.

See Also:
Constant Field Values

SC_FORBIDDEN

static final int SC_FORBIDDEN
Status code (403) indicating the server understood the request but refused to fulfill it.

See Also:
Constant Field Values

SC_NOT_FOUND

static final int SC_NOT_FOUND
Status code (404) indicating that the requested resource is not available.

See Also:
Constant Field Values

SC_METHOD_NOT_ALLOWED

static final int SC_METHOD_NOT_ALLOWED
Status code (405) indicating that the method specified in the Request-Line is not allowed for the resource identified by the Request-URI.

See Also:
Constant Field Values

SC_NOT_ACCEPTABLE

static final int SC_NOT_ACCEPTABLE
Status code (406) indicating that the resource identified by the request is only capable of generating response entities which have content characteristics not acceptable according to the accept headers sent in the request.

See Also:
Constant Field Values

SC_PROXY_AUTHENTICATION_REQUIRED

static final int SC_PROXY_AUTHENTICATION_REQUIRED
Status code (407) indicating that the client MUST first authenticate itself with the proxy.

See Also:
Constant Field Values

SC_REQUEST_TIMEOUT

static final int SC_REQUEST_TIMEOUT
Status code (408) indicating that the client did not produce a request within the time that the server was prepared to wait.

See Also:
Constant Field Values

SC_CONFLICT

static final int SC_CONFLICT
Status code (409) indicating that the request could not be completed due to a conflict with the current state of the resource.

See Also:
Constant Field Values

SC_GONE

static final int SC_GONE
Status code (410) indicating that the resource is no longer available at the server and no forwarding address is known. This condition SHOULD be considered permanent.

See Also:
Constant Field Values

SC_LENGTH_REQUIRED

static final int SC_LENGTH_REQUIRED
Status code (411) indicating that the request cannot be handled without a defined Content-Length.

See Also:
Constant Field Values

SC_PRECONDITION_FAILED

static final int SC_PRECONDITION_FAILED
Status code (412) indicating that the precondition given in one or more of the request-header fields evaluated to false when it was tested on the server.

See Also:
Constant Field Values

SC_REQUEST_ENTITY_TOO_LARGE

static final int SC_REQUEST_ENTITY_TOO_LARGE
Status code (413) indicating that the server is refusing to process the request because the request entity is larger than the server is willing or able to process.

See Also:
Constant Field Values

SC_REQUEST_URI_TOO_LONG

static final int SC_REQUEST_URI_TOO_LONG
Status code (414) indicating that the server is refusing to service the request because the Request-URI is longer than the server is willing to interpret.

See Also:
Constant Field Values

SC_UNSUPPORTED_MEDIA_TYPE

static final int SC_UNSUPPORTED_MEDIA_TYPE
Status code (415) indicating that the server is refusing to service the request because the entity of the request is in a format not supported by the requested resource for the requested method.

See Also:
Constant Field Values

SC_REQUESTED_RANGE_NOT_SATISFIABLE

static final int SC_REQUESTED_RANGE_NOT_SATISFIABLE
Status code (416) indicating that the server cannot serve the requested byte range.

See Also:
Constant Field Values

SC_EXPECTATION_FAILED

static final int SC_EXPECTATION_FAILED
Status code (417) indicating that the server could not meet the expectation given in the Expect request header.

See Also:
Constant Field Values

SC_INTERNAL_SERVER_ERROR

static final int SC_INTERNAL_SERVER_ERROR
Status code (500) indicating an error inside the HTTP server which prevented it from fulfilling the request.

See Also:
Constant Field Values

SC_NOT_IMPLEMENTED

static final int SC_NOT_IMPLEMENTED
Status code (501) indicating the HTTP server does not support the functionality needed to fulfill the request.

See Also:
Constant Field Values

SC_BAD_GATEWAY

static final int SC_BAD_GATEWAY
Status code (502) indicating that the HTTP server received an invalid response from a server it consulted when acting as a proxy or gateway.

See Also:
Constant Field Values

SC_SERVICE_UNAVAILABLE

static final int SC_SERVICE_UNAVAILABLE
Status code (503) indicating that the HTTP server is temporarily overloaded, and unable to handle the request.

See Also:
Constant Field Values

SC_GATEWAY_TIMEOUT

static final int SC_GATEWAY_TIMEOUT
Status code (504) indicating that the server did not receive a timely response from the upstream server while acting as a gateway or proxy.

See Also:
Constant Field Values

SC_HTTP_VERSION_NOT_SUPPORTED

static final int SC_HTTP_VERSION_NOT_SUPPORTED
Status code (505) indicating that the server does not support or refuses to support the HTTP protocol version that was used in the request message.

See Also:
Constant Field Values
Method Detail

addCookie

void addCookie(Cookie cookie)
Adds the specified cookie to the response. This method can be called multiple times to set more than one cookie.

Parameters:
cookie - the Cookie to return to the client

containsHeader

boolean containsHeader(String name)
Returns a boolean indicating whether the named response header has already been set.

Parameters:
name - the header name
Returns:
true if the named response header has already been set; false otherwise

encodeURL

String encodeURL(String url)
Encodes the specified URL by including the session ID in it, or, if encoding is not needed, returns the URL unchanged. The implementation of this method includes the logic to determine whether the session ID needs to be encoded in the URL. For example, if the browser supports cookies, or session tracking is turned off, URL encoding is unnecessary.

For robust session tracking, all URLs emitted by a servlet should be run through this method. Otherwise, URL rewriting cannot be used with browsers which do not support cookies.

Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.

encodeRedirectURL

String encodeRedirectURL(String url)
Encodes the specified URL for use in the sendRedirect method or, if encoding is not needed, returns the URL unchanged. The implementation of this method includes the logic to determine whether the session ID needs to be encoded in the URL. Because the rules for making this determination can differ from those used to decide whether to encode a normal link, this method is separated from the encodeURL method.

All URLs sent to the HttpServletResponse.sendRedirect method should be run through this method. Otherwise, URL rewriting cannot be used with browsers which do not support cookies.

Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.
See Also:
sendRedirect(java.lang.String), encodeUrl(java.lang.String)

encodeUrl

String encodeUrl(String url)
Deprecated. As of version 2.1, use encodeURL(String url) instead

Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.

encodeRedirectUrl

String encodeRedirectUrl(String url)
Deprecated. As of version 2.1, use encodeRedirectURL(String url) instead

Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.

sendError

void sendError(int sc,
               String msg)
               throws IOException
Sends an error response to the client using the specified status. The server defaults to creating the response to look like an HTML-formatted server error page containing the specified message, setting the content type to "text/html", leaving cookies and other headers unmodified. If an error-page declaration has been made for the web application corresponding to the status code passed in, it will be served back in preference to the suggested msg parameter.

If the response has already been committed, this method throws an IllegalStateException. After using this method, the response should be considered to be committed and should not be written to.

Parameters:
sc - the error status code
msg - the descriptive message
Throws:
IOException - If an input or output exception occurs
IllegalStateException - If the response was committed

sendError

void sendError(int sc)
               throws IOException
Sends an error response to the client using the specified status code and clearing the buffer.

If the response has already been committed, this method throws an IllegalStateException. After using this method, the response should be considered to be committed and should not be written to.

Parameters:
sc - the error status code
Throws:
IOException - If an input or output exception occurs
IllegalStateException - If the response was committed before this method call

sendRedirect

void sendRedirect(String location)
                  throws IOException
Sends a temporary redirect response to the client using the specified redirect location URL. This method can accept relative URLs; the servlet container must convert the relative URL to an absolute URL before sending the response to the client. If the location is relative without a leading '/' the container interprets it as relative to the current request URI. If the location is relative with a leading '/' the container interprets it as relative to the servlet container root.

If the response has already been committed, this method throws an IllegalStateException. After using this method, the response should be considered to be committed and should not be written to.

Parameters:
location - the redirect location URL
Throws:
IOException - If an input or output exception occurs
IllegalStateException - If the response was committed or if a partial URL is given and cannot be converted into a valid URL

setDateHeader

void setDateHeader(String name,
                   long date)
Sets a response header with the given name and date-value. The date is specified in terms of milliseconds since the epoch. If the header had already been set, the new value overwrites the previous one. The containsHeader method can be used to test for the presence of a header before setting its value.

Parameters:
name - the name of the header to set
date - the assigned date value
See Also:
containsHeader(java.lang.String), addDateHeader(java.lang.String, long)

addDateHeader

void addDateHeader(String name,
                   long date)
Adds a response header with the given name and date-value. The date is specified in terms of milliseconds since the epoch. This method allows response headers to have multiple values.

Parameters:
name - the name of the header to set
date - the additional date value
See Also:
setDateHeader(java.lang.String, long)

setHeader

void setHeader(String name,
               String value)
Sets a response header with the given name and value. If the header had already been set, the new value overwrites the previous one. The containsHeader method can be used to test for the presence of a header before setting its value.

Parameters:
name - the name of the header
value - the header value If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
See Also:
containsHeader(java.lang.String), addHeader(java.lang.String, java.lang.String)

addHeader

void addHeader(String name,
               String value)
Adds a response header with the given name and value. This method allows response headers to have multiple values.

Parameters:
name - the name of the header
value - the additional header value If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
See Also:
setHeader(java.lang.String, java.lang.String)

setIntHeader

void setIntHeader(String name,
                  int value)
Sets a response header with the given name and integer value. If the header had already been set, the new value overwrites the previous one. The containsHeader method can be used to test for the presence of a header before setting its value.

Parameters:
name - the name of the header
value - the assigned integer value
See Also:
containsHeader(java.lang.String), addIntHeader(java.lang.String, int)

addIntHeader

void addIntHeader(String name,
                  int value)
Adds a response header with the given name and integer value. This method allows response headers to have multiple values.

Parameters:
name - the name of the header
value - the assigned integer value
See Also:
setIntHeader(java.lang.String, int)

setStatus

void setStatus(int sc)
Sets the status code for this response. This method is used to set the return status code when there is no error (for example, for the status codes SC_OK or SC_MOVED_TEMPORARILY). If there is an error, and the caller wishes to invoke an error-page defined in the web application, the sendError method should be used instead.

The container clears the buffer and sets the Location header, preserving cookies and other headers.

Parameters:
sc - the status code
See Also:
sendError(int, java.lang.String)

setStatus

void setStatus(int sc,
               String sm)
Deprecated. As of version 2.1, due to ambiguous meaning of the message parameter. To set a status code use setStatus(int), to send an error with a description use sendError(int, String). Sets the status code and message for this response.

Parameters:
sc - the status code
sm - the status message
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpServletResponseWrapper

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class HttpServletResponseWrapper

java.lang.Object
    extended by  javax.servlet.ServletResponseWrapper
        extended by  javax.servlet.http.HttpServletResponseWrapper
All Implemented Interfaces:
HttpServletResponse, ServletResponse
public class HttpServletResponseWrapper
extends ServletResponseWrapper
implements HttpServletResponse

Provides a convenient implementation of the HttpServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet. This class implements the Wrapper or Decorator pattern. Methods default to calling through to the wrapped response object.

Since:
v 2.3
Author:
Various
See Also:
HttpServletResponse

Field Summary
Fields inherited from interface javax.servlet.http.HttpServletResponse
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_FOUND, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
Constructor Summary
HttpServletResponseWrapper(HttpServletResponse response)
Constructs a response adaptor wrapping the given response.
Method Summary
 void addCookie(Cookie cookie)
The default behavior of this method is to call addCookie(Cookie cookie) on the wrapped response object.
 void addDateHeader(String name, long date)
The default behavior of this method is to call addDateHeader(String name, long date) on the wrapped response object.
 void addHeader(String name, String value)
The default behavior of this method is to return addHeader(String name, String value) on the wrapped response object.
 void addIntHeader(String name, int value)
The default behavior of this method is to call addIntHeader(String name, int value) on the wrapped response object.
 boolean containsHeader(String name)
The default behavior of this method is to call containsHeader(String name) on the wrapped response object.
 String encodeRedirectUrl(String url)
The default behavior of this method is to return encodeRedirectUrl(String url) on the wrapped response object.
 String encodeRedirectURL(String url)
The default behavior of this method is to return encodeRedirectURL(String url) on the wrapped response object.
 String encodeUrl(String url)
The default behavior of this method is to call encodeUrl(String url) on the wrapped response object.
 String encodeURL(String url)
The default behavior of this method is to call encodeURL(String url) on the wrapped response object.
 void sendError(int sc)
The default behavior of this method is to call sendError(int sc) on the wrapped response object.
 void sendError(int sc, String msg)
The default behavior of this method is to call sendError(int sc, String msg) on the wrapped response object.
 void sendRedirect(String location)
The default behavior of this method is to return sendRedirect(String location) on the wrapped response object.
 void setDateHeader(String name, long date)
The default behavior of this method is to call setDateHeader(String name, long date) on the wrapped response object.
 void setHeader(String name, String value)
The default behavior of this method is to return setHeader(String name, String value) on the wrapped response object.
 void setIntHeader(String name, int value)
The default behavior of this method is to call setIntHeader(String name, int value) on the wrapped response object.
 void setStatus(int sc)
The default behavior of this method is to call setStatus(int sc) on the wrapped response object.
 void setStatus(int sc, String sm)
The default behavior of this method is to call setStatus(int sc, String sm) on the wrapped response object.
Methods inherited from class javax.servlet.ServletResponseWrapper
flushBuffer, getBufferSize, getCharacterEncoding, getContentType, getLocale, getOutputStream, getResponse, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setCharacterEncoding, setContentLength, setContentType, setLocale, setResponse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.ServletResponse
flushBuffer, getBufferSize, getCharacterEncoding, getContentType, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setCharacterEncoding, setContentLength, setContentType, setLocale

Constructor Detail

HttpServletResponseWrapper

public HttpServletResponseWrapper(HttpServletResponse response)
Constructs a response adaptor wrapping the given response.

Throws:
IllegalArgumentException - if the response is null
Method Detail

addCookie

public void addCookie(Cookie cookie)
The default behavior of this method is to call addCookie(Cookie cookie) on the wrapped response object.

Specified by:
addCookie in interface HttpServletResponse
Parameters:
cookie - the Cookie to return to the client

containsHeader

public boolean containsHeader(String name)
The default behavior of this method is to call containsHeader(String name) on the wrapped response object.

Specified by:
containsHeader in interface HttpServletResponse
Parameters:
name - the header name
Returns:
true if the named response header has already been set; false otherwise

encodeURL

public String encodeURL(String url)
The default behavior of this method is to call encodeURL(String url) on the wrapped response object.

Specified by:
encodeURL in interface HttpServletResponse
Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.

encodeRedirectURL

public String encodeRedirectURL(String url)
The default behavior of this method is to return encodeRedirectURL(String url) on the wrapped response object.

Specified by:
encodeRedirectURL in interface HttpServletResponse
Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.
See Also:
HttpServletResponse.sendRedirect(java.lang.String), HttpServletResponse.encodeUrl(java.lang.String)

encodeUrl

public String encodeUrl(String url)
The default behavior of this method is to call encodeUrl(String url) on the wrapped response object.

Specified by:
encodeUrl in interface HttpServletResponse
Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.

encodeRedirectUrl

public String encodeRedirectUrl(String url)
The default behavior of this method is to return encodeRedirectUrl(String url) on the wrapped response object.

Specified by:
encodeRedirectUrl in interface HttpServletResponse
Parameters:
url - the url to be encoded.
Returns:
the encoded URL if encoding is needed; the unchanged URL otherwise.

sendError

public void sendError(int sc,
                      String msg)
               throws IOException
The default behavior of this method is to call sendError(int sc, String msg) on the wrapped response object.

Specified by:
sendError in interface HttpServletResponse
Parameters:
sc - the error status code
msg - the descriptive message
Throws:
IOException - If an input or output exception occurs

sendError

public void sendError(int sc)
               throws IOException
The default behavior of this method is to call sendError(int sc) on the wrapped response object.

Specified by:
sendError in interface HttpServletResponse
Parameters:
sc - the error status code
Throws:
IOException - If an input or output exception occurs

sendRedirect

public void sendRedirect(String location)
                  throws IOException
The default behavior of this method is to return sendRedirect(String location) on the wrapped response object.

Specified by:
sendRedirect in interface HttpServletResponse
Parameters:
location - the redirect location URL
Throws:
IOException - If an input or output exception occurs

setDateHeader

public void setDateHeader(String name,
                          long date)
The default behavior of this method is to call setDateHeader(String name, long date) on the wrapped response object.

Specified by:
setDateHeader in interface HttpServletResponse
Parameters:
name - the name of the header to set
date - the assigned date value
See Also:
HttpServletResponse.containsHeader(java.lang.String), HttpServletResponse.addDateHeader(java.lang.String, long)

addDateHeader

public void addDateHeader(String name,
                          long date)
The default behavior of this method is to call addDateHeader(String name, long date) on the wrapped response object.

Specified by:
addDateHeader in interface HttpServletResponse
Parameters:
name - the name of the header to set
date - the additional date value
See Also:
HttpServletResponse.setDateHeader(java.lang.String, long)

setHeader

public void setHeader(String name,
                      String value)
The default behavior of this method is to return setHeader(String name, String value) on the wrapped response object.

Specified by:
setHeader in interface HttpServletResponse
Parameters:
name - the name of the header
value - the header value If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
See Also:
HttpServletResponse.containsHeader(java.lang.String), HttpServletResponse.addHeader(java.lang.String, java.lang.String)

addHeader

public void addHeader(String name,
                      String value)
The default behavior of this method is to return addHeader(String name, String value) on the wrapped response object.

Specified by:
addHeader in interface HttpServletResponse
Parameters:
name - the name of the header
value - the additional header value If it contains octet string, it should be encoded according to RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt)
See Also:
HttpServletResponse.setHeader(java.lang.String, java.lang.String)

setIntHeader

public void setIntHeader(String name,
                         int value)
The default behavior of this method is to call setIntHeader(String name, int value) on the wrapped response object.

Specified by:
setIntHeader in interface HttpServletResponse
Parameters:
name - the name of the header
value - the assigned integer value
See Also:
HttpServletResponse.containsHeader(java.lang.String), HttpServletResponse.addIntHeader(java.lang.String, int)

addIntHeader

public void addIntHeader(String name,
                         int value)
The default behavior of this method is to call addIntHeader(String name, int value) on the wrapped response object.

Specified by:
addIntHeader in interface HttpServletResponse
Parameters:
name - the name of the header
value - the assigned integer value
See Also:
HttpServletResponse.setIntHeader(java.lang.String, int)

setStatus

public void setStatus(int sc)
The default behavior of this method is to call setStatus(int sc) on the wrapped response object.

Specified by:
setStatus in interface HttpServletResponse
Parameters:
sc - the status code
See Also:
HttpServletResponse.sendError(int, java.lang.String)

setStatus

public void setStatus(int sc,
                      String sm)
The default behavior of this method is to call setStatus(int sc, String sm) on the wrapped response object.

Specified by:
setStatus in interface HttpServletResponse
Parameters:
sc - the status code
sm - the status message
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpSession

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpSession

public interface HttpSession

Provides a way to identify a user across more than one page request or visit to a Web site and to store information about that user.

The servlet container uses this interface to create a session between an HTTP client and an HTTP server. The session persists for a specified time period, across more than one connection or page request from the user. A session usually corresponds to one user, who may visit a site many times. The server can maintain a session in many ways such as using cookies or rewriting URLs.

This interface allows servlets to

  • View and manipulate information about a session, such as the session identifier, creation time, and last accessed time
  • Bind objects to sessions, allowing user information to persist across multiple user connections

When an application stores an object in or removes an object from a session, the session checks whether the object implements HttpSessionBindingListener. If it does, the servlet notifies the object that it has been bound to or unbound from the session. Notifications are sent after the binding methods complete. For session that are invalidated or expire, notifications are sent after the session has been invalidated or expired.

When container migrates a session between VMs in a distributed container setting, all session attributes implementing the HttpSessionActivationListener interface are notified.

A servlet should be able to handle cases in which the client does not choose to join a session, such as when cookies are intentionally turned off. Until the client joins the session, isNew returns true. If the client chooses not to join the session, getSession will return a different session on each request, and isNew will always return true.

Session information is scoped only to the current web application (ServletContext), so information stored in one context will not be directly visible in another.

Author:
Various
See Also:
HttpSessionBindingListener, HttpSessionContext

Method Summary
 Object getAttribute(String name)
Returns the object bound with the specified name in this session, or null if no object is bound under the name.
 Enumeration getAttributeNames()
Returns an Enumeration of String objects containing the names of all the objects bound to this session.
 long getCreationTime()
Returns the time when this session was created, measured in milliseconds since midnight January 1, 1970 GMT.
 String getId()
Returns a string containing the unique identifier assigned to this session.
 long getLastAccessedTime()
Returns the last time the client sent a request associated with this session, as the number of milliseconds since midnight January 1, 1970 GMT, and marked by the time the container received the request.
 int getMaxInactiveInterval()
Returns the maximum time interval, in seconds, that the servlet container will keep this session open between client accesses.
 ServletContext getServletContext()
Returns the ServletContext to which this session belongs.
 HttpSessionContext getSessionContext()
Deprecated. As of Version 2.1, this method is deprecated and has no replacement. It will be removed in a future version of the Java Servlet API.
 Object getValue(String name)
Deprecated. As of Version 2.2, this method is replaced by getAttribute(java.lang.String).
 String[] getValueNames()
Deprecated. As of Version 2.2, this method is replaced by getAttributeNames()
 void invalidate()
Invalidates this session then unbinds any objects bound to it.
 boolean isNew()
Returns true if the client does not yet know about the session or if the client chooses not to join the session.
 void putValue(String name, Object value)
Deprecated. As of Version 2.2, this method is replaced by setAttribute(java.lang.String, java.lang.Object)
 void removeAttribute(String name)
Removes the object bound with the specified name from this session.
 void removeValue(String name)
Deprecated. As of Version 2.2, this method is replaced by removeAttribute(java.lang.String)
 void setAttribute(String name, Object value)
Binds an object to this session, using the name specified.
 void setMaxInactiveInterval(int interval)
Specifies the time, in seconds, between client requests before the servlet container will invalidate this session.

Method Detail

getCreationTime

long getCreationTime()
Returns the time when this session was created, measured in milliseconds since midnight January 1, 1970 GMT.

Returns:
a long specifying when this session was created, expressed in milliseconds since 1/1/1970 GMT
Throws:
IllegalStateException - if this method is called on an invalidated session

getId

String getId()
Returns a string containing the unique identifier assigned to this session. The identifier is assigned by the servlet container and is implementation dependent.

Returns:
a string specifying the identifier assigned to this session

getLastAccessedTime

long getLastAccessedTime()
Returns the last time the client sent a request associated with this session, as the number of milliseconds since midnight January 1, 1970 GMT, and marked by the time the container received the request.

Actions that your application takes, such as getting or setting a value associated with the session, do not affect the access time.

Returns:
a long representing the last time the client sent a request associated with this session, expressed in milliseconds since 1/1/1970 GMT
Throws:
IllegalStateException - if this method is called on an invalidated session

getServletContext

ServletContext getServletContext()
Returns the ServletContext to which this session belongs.

Returns:
The ServletContext object for the web application
Since:
2.3

setMaxInactiveInterval

void setMaxInactiveInterval(int interval)
Specifies the time, in seconds, between client requests before the servlet container will invalidate this session. A negative time indicates the session should never timeout.

Parameters:
interval - An integer specifying the number of seconds

getMaxInactiveInterval

int getMaxInactiveInterval()
Returns the maximum time interval, in seconds, that the servlet container will keep this session open between client accesses. After this interval, the servlet container will invalidate the session. The maximum time interval can be set with the setMaxInactiveInterval method. A negative time indicates the session should never timeout.

Returns:
an integer specifying the number of seconds this session remains open between client requests
See Also:
setMaxInactiveInterval(int)

getSessionContext

HttpSessionContext getSessionContext()
Deprecated. As of Version 2.1, this method is deprecated and has no replacement. It will be removed in a future version of the Java Servlet API.

getAttribute

Object getAttribute(String name)
Returns the object bound with the specified name in this session, or null if no object is bound under the name.

Parameters:
name - a string specifying the name of the object
Returns:
the object with the specified name
Throws:
IllegalStateException - if this method is called on an invalidated session

getValue

Object getValue(String name)
Deprecated. As of Version 2.2, this method is replaced by getAttribute(java.lang.String).

Parameters:
name - a string specifying the name of the object
Returns:
the object with the specified name
Throws:
IllegalStateException - if this method is called on an invalidated session

getAttributeNames

Enumeration getAttributeNames()
Returns an Enumeration of String objects containing the names of all the objects bound to this session.

Returns:
an Enumeration of String objects specifying the names of all the objects bound to this session
Throws:
IllegalStateException - if this method is called on an invalidated session

getValueNames

String[] getValueNames()
Deprecated. As of Version 2.2, this method is replaced by getAttributeNames()

Returns:
an array of String objects specifying the names of all the objects bound to this session
Throws:
IllegalStateException - if this method is called on an invalidated session

setAttribute

void setAttribute(String name,
                  Object value)
Binds an object to this session, using the name specified. If an object of the same name is already bound to the session, the object is replaced.

After this method executes, and if the new object implements HttpSessionBindingListener, the container calls HttpSessionBindingListener.valueBound. The container then notifies any HttpSessionAttributeListeners in the web application.

If an object was already bound to this session of this name that implements HttpSessionBindingListener, its HttpSessionBindingListener.valueUnbound method is called.

If the value passed in is null, this has the same effect as calling removeAttribute().

Parameters:
name - the name to which the object is bound; cannot be null
value - the object to be bound
Throws:
IllegalStateException - if this method is called on an invalidated session

putValue

void putValue(String name,
              Object value)
Deprecated. As of Version 2.2, this method is replaced by setAttribute(java.lang.String, java.lang.Object)

Parameters:
name - the name to which the object is bound; cannot be null
value - the object to be bound; cannot be null
Throws:
IllegalStateException - if this method is called on an invalidated session

removeAttribute

void removeAttribute(String name)
Removes the object bound with the specified name from this session. If the session does not have an object bound with the specified name, this method does nothing.

After this method executes, and if the object implements HttpSessionBindingListener, the container calls HttpSessionBindingListener.valueUnbound. The container then notifies any HttpSessionAttributeListeners in the web application.

Parameters:
name - the name of the object to remove from this session
Throws:
IllegalStateException - if this method is called on an invalidated session

removeValue

void removeValue(String name)
Deprecated. As of Version 2.2, this method is replaced by removeAttribute(java.lang.String)

Parameters:
name - the name of the object to remove from this session
Throws:
IllegalStateException - if this method is called on an invalidated session

invalidate

void invalidate()
Invalidates this session then unbinds any objects bound to it.

Throws:
IllegalStateException - if this method is called on an already invalidated session

isNew

boolean isNew()
Returns true if the client does not yet know about the session or if the client chooses not to join the session. For example, if the server used only cookie-based sessions, and the client had disabled the use of cookies, then a session would be new on each request.

Returns:
true if the server has created a session, but the client has not yet joined
Throws:
IllegalStateException - if this method is called on an already invalidated session
Overview  Package   Class  Tree  Deprecated  Index  Help
Java EE 5 SDK
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpSessionActivationListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpSessionActivationListener

All Superinterfaces:
EventListener
public interface HttpSessionActivationListener
extends EventListener

Objects that are bound to a session may listen to container events notifying them that sessions will be passivated and that session will be activated. A container that migrates session between VMs or persists sessions is required to notify all attributes bound to sessions implementing HttpSessionActivationListener.

Since:
2.3

Method Summary
void | sessionDidActivate(HttpSessionEvent se) Notification that the session has just been activated.
void | sessionWillPassivate(HttpSessionEvent se) Notification that the session is about to be passivated.

Method Detail

sessionWillPassivate

void sessionWillPassivate(HttpSessionEvent se)
Notification that the session is about to be passivated.

sessionDidActivate

void sessionDidActivate(HttpSessionEvent se)
Notification that the session has just been activated.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpSessionAttributeListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpSessionAttributeListener

All Superinterfaces:
EventListener
public interface HttpSessionAttributeListener
extends EventListener

This listener interface can be implemented in order to get notifications of changes to the attribute lists of sessions within this web application.

Since:
v 2.3

Method Summary
void | attributeAdded(HttpSessionBindingEvent se) Notification that an attribute has been added to a session.
void | attributeRemoved(HttpSessionBindingEvent se) Notification that an attribute has been removed from a session.
void | attributeReplaced(HttpSessionBindingEvent se) Notification that an attribute has been replaced in a session.

Method Detail

attributeAdded

void attributeAdded(HttpSessionBindingEvent se)
Notification that an attribute has been added to a session. Called after the attribute is added.

attributeRemoved

void attributeRemoved(HttpSessionBindingEvent se)
Notification that an attribute has been removed from a session. Called after the attribute is removed.

attributeReplaced

void attributeReplaced(HttpSessionBindingEvent se)
Notification that an attribute has been replaced in a session. Called after the attribute is replaced.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpSessionBindingEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class HttpSessionBindingEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.servlet.http.HttpSessionEvent
            extended by  javax.servlet.http.HttpSessionBindingEvent
All Implemented Interfaces:
Serializable
public class HttpSessionBindingEvent
extends HttpSessionEvent

Events of this type are either sent to an object that implements HttpSessionBindingListener when it is bound or unbound from a session, or to a HttpSessionAttributeListener that has been configured in the deployment descriptor when any attribute is bound, unbound or replaced in a session.

The session binds the object by a call to HttpSession.setAttribute and unbinds the object by a call to HttpSession.removeAttribute.

Author:
Various
See Also:
HttpSession, HttpSessionBindingListener, HttpSessionAttributeListener, Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
HttpSessionBindingEvent(HttpSession session, String name)
Constructs an event that notifies an object that it has been bound to or unbound from a session.
HttpSessionBindingEvent(HttpSession session, String name, Object value)
Constructs an event that notifies an object that it has been bound to or unbound from a session.
Method Summary
String | getName() Returns the name with which the attribute is bound to or unbound from the session.
HttpSession | getSession() Return the session that changed.
Object | getValue() Returns the value of the attribute that has been added, removed or replaced.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HttpSessionBindingEvent

public HttpSessionBindingEvent(HttpSession session,
                               String name)
Constructs an event that notifies an object that it has been bound to or unbound from a session. To receive the event, the object must implement HttpSessionBindingListener.

Parameters:
session - the session to which the object is bound or unbound
name - the name with which the object is bound or unbound
See Also:
getName(), getSession()

HttpSessionBindingEvent

public HttpSessionBindingEvent(HttpSession session,
                               String name,
                               Object value)
Constructs an event that notifies an object that it has been bound to or unbound from a session. To receive the event, the object must implement HttpSessionBindingListener.

Parameters:
session - the session to which the object is bound or unbound
name - the name with which the object is bound or unbound
See Also:
getName(), getSession()
Method Detail

getSession

public HttpSession getSession()
Return the session that changed.

Overrides:
getSession in class HttpSessionEvent

getName

public String getName()
Returns the name with which the attribute is bound to or unbound from the session.

Returns:
a string specifying the name with which the object is bound to or unbound from the session

getValue

public Object getValue()
Returns the value of the attribute that has been added, removed or replaced. If the attribute was added (or bound), this is the value of the attribute. If the attribute was removed (or unbound), this is the value of the removed attribute. If the attribute was replaced, this is the old value of the attribute.

Since:
2.3
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpSessionBindingListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpSessionBindingListener

All Superinterfaces:
EventListener
public interface HttpSessionBindingListener
extends EventListener

Causes an object to be notified when it is bound to or unbound from a session. The object is notified by an HttpSessionBindingEvent object. This may be as a result of a servlet programmer explicitly unbinding an attribute from a session, due to a session being invalidated, or due to a session timing out.

Author:
Various
See Also:
HttpSession, HttpSessionBindingEvent

Method Summary
void | valueBound(HttpSessionBindingEvent event) Notifies the object that it is being bound to a session and identifies the session.
void | valueUnbound(HttpSessionBindingEvent event) Notifies the object that it is being unbound from a session and identifies the session.

Method Detail

valueBound

void valueBound(HttpSessionBindingEvent event)
Notifies the object that it is being bound to a session and identifies the session.

Parameters:
event - the event that identifies the session
See Also:
valueUnbound(javax.servlet.http.HttpSessionBindingEvent)

valueUnbound

void valueUnbound(HttpSessionBindingEvent event)
Notifies the object that it is being unbound from a session and identifies the session.

Parameters:
event - the event that identifies the session
See Also:
valueBound(javax.servlet.http.HttpSessionBindingEvent)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpSessionContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpSessionContext

Deprecated. As of Java(tm) Servlet API 2.1 for security reasons, with no replacement. This interface will be removed in a future version of this API.

public interface HttpSessionContext

Author:
Various
See Also:
HttpSession, HttpSessionBindingEvent, HttpSessionBindingListener

Method Summary
Enumeration | getIds() Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return an empty Enumeration and will be removed in a future version of this API.
HttpSession | getSession(String sessionId) Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return null and will be removed in a future version of this API.

Method Detail

getSession

HttpSession getSession(String sessionId)
Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return null and will be removed in a future version of this API.

getIds

Enumeration getIds()
Deprecated. As of Java Servlet API 2.1 with no replacement. This method must return an empty Enumeration and will be removed in a future version of this API.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpSessionEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class HttpSessionEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.servlet.http.HttpSessionEvent
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
HttpSessionBindingEvent
public class HttpSessionEvent
extends EventObject

This is the class representing event notifications for changes to sessions within a web application.

Since:
v 2.3
See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
HttpSessionEvent(HttpSession source)
Construct a session event from the given source.
Method Summary
 HttpSession getSession()
Return the session that changed.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HttpSessionEvent

public HttpSessionEvent(HttpSession source)
Construct a session event from the given source.

Method Detail

getSession

public HttpSession getSession()
Return the session that changed.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpSessionListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Interface HttpSessionListener

All Superinterfaces:
EventListener
public interface HttpSessionListener
extends EventListener

Implementations of this interface are notified of changes to the list of active sessions in a web application. To receive notification events, the implementation class must be configured in the deployment descriptor for the web application.

Since:
v 2.3
See Also:
HttpSessionEvent

Method Summary
void | sessionCreated(HttpSessionEvent se) Notification that a session was created.
void | sessionDestroyed(HttpSessionEvent se) Notification that a session is about to be invalidated.

Method Detail

sessionCreated

void sessionCreated(HttpSessionEvent se)
Notification that a session was created.

Parameters:
se - the notification event

sessionDestroyed

void sessionDestroyed(HttpSessionEvent se)
Notification that a session is about to be invalidated.

Parameters:
se - the notification event
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpUtils

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.http
Class HttpUtils

java.lang.Object
    extended by  javax.servlet.http.HttpUtils
Deprecated. As of Java(tm) Servlet API 2.3. These methods were only useful with the default encoding and have been moved to the request interfaces.

public class HttpUtils
extends Object

Constructor Summary
HttpUtils()
Deprecated. Constructs an empty HttpUtils object.
Method Summary
static StringBuffer | getRequestURL(HttpServletRequest req) Deprecated. Reconstructs the URL the client used to make the request, using information in the HttpServletRequest object.
static Hashtable | parsePostData(int len, ServletInputStream in) Deprecated. Parses data from an HTML form that the client sends to the server using the HTTP POST method and the application/x-www-form-urlencoded MIME type.
static Hashtable | parseQueryString(String s) Deprecated. Parses a query string passed from the client to the server and builds a HashTable object with key-value pairs.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HttpUtils

public HttpUtils()
Deprecated.
Constructs an empty HttpUtils object.

Method Detail

parseQueryString

public static Hashtable parseQueryString(String s)
Deprecated.
Parses a query string passed from the client to the server and builds a HashTable object with key-value pairs. The query string should be in the form of a string packaged by the GET or POST method, that is, it should have key-value pairs in the form key=value, with each pair separated from the next by a & character.

A key can appear more than once in the query string with different values. However, the key appears only once in the hashtable, with its value being an array of strings containing the multiple values sent by the query string.

The keys and values in the hashtable are stored in their decoded form, so any + characters are converted to spaces, and characters sent in hexadecimal notation (like %xx) are converted to ASCII characters.

Parameters:
s - a string containing the query to be parsed
Returns:
a HashTable object built from the parsed key-value pairs
Throws:
IllegalArgumentException - if the query string is invalid

parsePostData

public static Hashtable parsePostData(int len,
                                      ServletInputStream in)
Deprecated.
Parses data from an HTML form that the client sends to the server using the HTTP POST method and the application/x-www-form-urlencoded MIME type.

The data sent by the POST method contains key-value pairs. A key can appear more than once in the POST data with different values. However, the key appears only once in the hashtable, with its value being an array of strings containing the multiple values sent by the POST method.

The keys and values in the hashtable are stored in their decoded form, so any + characters are converted to spaces, and characters sent in hexadecimal notation (like %xx) are converted to ASCII characters.

Parameters:
len - an integer specifying the length, in characters, of the ServletInputStream object that is also passed to this method
in - the ServletInputStream object that contains the data sent from the client
Returns:
a HashTable object built from the parsed key-value pairs
Throws:
IllegalArgumentException - if the data sent by the POST method is invalid

getRequestURL

public static StringBuffer getRequestURL(HttpServletRequest req)
Deprecated.
Reconstructs the URL the client used to make the request, using information in the HttpServletRequest object. The returned URL contains a protocol, server name, port number, and server path, but it does not include query string parameters.

Because this method returns a StringBuffer, not a string, you can modify the URL easily, for example, to append query parameters.

This method is useful for creating redirect messages and for reporting errors.

Parameters:
req - a HttpServletRequest object containing the client's request
Returns:
a StringBuffer object containing the reconstructed URL
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


jsp

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.servlet.jsp

Classes and interfaces for the Core JSP 2.1 API.

See:
Description

Interface Summary
HttpJspPage | The HttpJspPage interface describes the interaction that a JSP Page Implementation Class must satisfy when using the HTTP protocol.
JspApplicationContext | Stores application-scoped information relevant to JSP containers.
JspPage | The JspPage interface describes the generic interaction that a JSP Page Implementation class must satisfy; pages that use the HTTP protocol are described by the HttpJspPage interface.

Class Summary
ErrorData | Contains information about an error, for error pages.
JspContext | JspContext serves as the base class for the PageContext class and abstracts all information that is not specific to servlets.
JspEngineInfo | The JspEngineInfo is an abstract class that provides information on the current JSP engine.
JspFactory | The JspFactory is an abstract class that defines a number of factory methods available to a JSP page at runtime for the purposes of creating instances of various interfaces and classes used to support the JSP implementation.
JspWriter | The actions and template data in a JSP page is written using the JspWriter object that is referenced by the implicit variable out which is initialized automatically using methods in the PageContext object.
PageContext | PageContext extends JspContext to provide useful context information for when JSP technology is used in a Servlet environment.

Exception Summary
JspException | A generic exception known to the JSP engine; uncaught JspExceptions will result in an invocation of the errorpage machinery.
JspTagException | Exception to be used by a Tag Handler to indicate some unrecoverable error.
SkipPageException | Exception to indicate the calling page must cease evaluation.

Package javax.servlet.jsp Description

Classes and interfaces for the Core JSP 2.1 API.

The javax.servlet.jsp package contains a number of classes and interfaces that describe and define the contracts between a JSP page implementation class and the runtime environment provided for an instance of such a class by a conforming JSP container.

JSP Page Implementation Object Contract

This section describes the basic contract between a JSP Page implementation object and its container.

The main contract is defined by the classes JspPage and HttpJspPage. The JspFactory class describes the mechanism to portably instantiate all needed runtime objects, and JspEngineInfo provides basic information on the current JSP container. Class JspApplicationContext stores application-scoped information relevant to JSP containers. It was added in JSP 2.1 to support the integration of the unified Expression Language.

None of these classes are intended to be used by JSP page authors; an example of how these classes may be used is included below.

Implicit Objects

The PageContext object and the JspWriter are available by default as implicit objects.

Exceptions

The JspException class is the base class for all JSP exceptions. The JspTagException and SkipPageException exceptions are used by the tag extension mechanism.

For JSP error pages, the ErrorData class encapsulates information about the error.

An Implementation Example

An instance of an implementation dependent subclass of the PageContext abstract base class can be created by a JSP implementation class at the beginning of it's _jspService() method via an implementation default JspFactory.

Here is one example of how to use these classes

 public class foo implements Servlet {

 // ...

public void _jspService(HttpServletRequest request,
                        HttpServletResponse response)
       throws IOException, ServletException {

    JspFactory  factory     = JspFactory.getDefaultFactory();
    PageContext pageContext = factory.getPageContext(
                                        this,
                                        request,
                                        response,
                                        null,  // errorPageURL
                                        false, // needsSession
                                        JspWriter.DEFAULT_BUFFER,
                                        true   // autoFlush
                                );

    // initialize implicit variables for scripting env ...

    HttpSession session = pageContext.getSession();
    JspWriter   out     = pageContext.getOut();
    Object      page    = this;

    try {
        // body of translated JSP here ...
    } catch (Exception e) {
        out.clear();
        pageContext.handlePageException(e);
    } finally {
        out.close();
          factory.releasePageContext(pageContext);
    }
}

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HttpJspPage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Interface HttpJspPage

All Superinterfaces:
JspPage, Servlet
public interface HttpJspPage
extends JspPage

The HttpJspPage interface describes the interaction that a JSP Page Implementation Class must satisfy when using the HTTP protocol.

The behaviour is identical to that of the JspPage, except for the signature of the _jspService method, which is now expressible in the Java type system and included explicitly in the interface.

See Also:
JspPage

Method Summary
 void _jspService(HttpServletRequest request, HttpServletResponse response)
The _jspService()method corresponds to the body of the JSP page.
Methods inherited from interface javax.servlet.jsp.JspPage
jspDestroy, jspInit
Methods inherited from interface javax.servlet.Servlet
destroy, getServletConfig, getServletInfo, init, service

Method Detail

_jspService

void _jspService(HttpServletRequest request,
                 HttpServletResponse response)
                 throws ServletException,
                        IOException
The _jspService()method corresponds to the body of the JSP page. This method is defined automatically by the JSP container and should never be defined by the JSP page author.

If a superclass is specified using the extends attribute, that superclass may choose to perform some actions in its service() method before or after calling the _jspService() method. See using the extends attribute in the JSP_Engine chapter of the JSP specification.

Parameters:
request - Provides client request information to the JSP.
response - Assists the JSP in sending a response to the client.
Throws:
ServletException - Thrown if an error occurred during the processing of the JSP and that the container should take appropriate action to clean up the request.
IOException - Thrown if an error occurred while writing the response for this page.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.servlet.jsp Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.servlet.jsp

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.jsp.ErrorData
    • javax.servlet.jsp.JspContext
      • javax.servlet.jsp.PageContext
    • javax.servlet.jsp.JspEngineInfo
    • javax.servlet.jsp.JspFactory
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.servlet.jsp.JspException
          • javax.servlet.jsp.JspTagException
          • javax.servlet.jsp.SkipPageException
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • javax.servlet.jsp.JspWriter

Interface Hierarchy

  • javax.servlet.jsp.JspApplicationContext
  • javax.servlet.Servlet
    • javax.servlet.jsp.JspPage
      • javax.servlet.jsp.HttpJspPage
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


el

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.servlet.jsp.el

Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.

See:
Description

Interface Summary
FunctionMapper | Deprecated. As of JSP 2.1, replaced by FunctionMapper
VariableResolver | Deprecated. As of JSP 2.1, replaced by ELResolver

Class Summary
Expression | Deprecated. As of JSP 2.1, replaced by ValueExpression
ExpressionEvaluator | Deprecated. As of JSP 2.1, replaced by ExpressionFactory
ImplicitObjectELResolver | Defines variable resolution behavior for the EL implicit objects defined in the JSP specification.
ScopedAttributeELResolver | Defines variable resolution behavior for scoped attributes.

Exception Summary
ELException | Deprecated. As of JSP 2.1, replaced by ELException
ELParseException | Deprecated. As of JSP 2.1, replaced by ELException

Package javax.servlet.jsp.el Description

Provides the ELResolver classes that define the object resolution rules that must be supported by a JSP container with the new unified Expression Language.

The package also defines programmatic access to the old Expression Language evaluator (pre JSP 2.1).

Please note that as of JSP 2.1, all classes and interfaces that were in package javax.servlet.jsp.el have been deprecated in favor of the new unified Expression Language APIs (javax.el). See the Expression Language specification document for more details.

While a JSP container must still support the deprecated APIs defined in javax.servlet.jsp.el, developers should only rely on the new javax.el APIs for new development work.

Two ELResolver classes have been added in JSP 2.1 to implement object resolution rules that must be supported by a JSP container with the new unified Expression Language: ImplicitObjectELResolver and ScopedAttributeELResolver.

Documentation on the old and deprecated API

The JavaServer Pages(tm) (JSP) 2.0 specification provides a portable API for evaluating "EL Expressions". As of JSP 2.0, EL expressions can be placed directly in the template text of JSP pages and tag files.

This package contains a number of classes and interfaces that describe and define programmatic access to the Expression Language evaluator. This API can also be used by an implementation of JSP to evaluate the expressions, but other implementations, like open-coding into Java bytecodes, are allowed. This package is intended to have no dependencies on other portions of the JSP 2.0 specification.

Expression Evaluator

Programmatic access to the EL Expression Evaluator is provided through the following types:
  • ExpressionEvaluator
  • Expression
  • FunctionMapper
  • VariableResolver

An ExpressionEvaluator object can be obtained from a JspContext object through the getExpressionEvaluator method. An ExpressionEvaluator encapsulates the EL processor. An EL expression provided as a String can then be evaluated directly, or it can be parsed first into an Expression object. The parse step, can be used to factor out the cost of parsing the expression, or even the cost of optimizing the implementation.

The parsing of an expression string is done against a target type, a default prefix (that applies when a function has no prefix), and a FunctionMapper. The FunctionMapper object maps a prefix and a local name part into a java.lang.reflect.Method object.

The interpretation or evaluation of a parsed expression is done using a VariableResolver object. This object resolves top level object names into Objects. A VariableResolver can be obtained from a JspContext object through the getVariableResolver method.

Exceptions

The ELException exception is used by the expression language to denote any exception that may arise during the parsing or evaluation of an expression. The ELParseException exception is a subclass of ELException that corresponds to parsing errors

Parsing errors are conveyed as exceptions to simplify the API. It is expected that many JSP containers will use additional mechanisms to parse EL expressions and report their errors - a run-time API cannot provide accurate line-error numbers without additional machinery.

Code Fragment

Below is a non-normative code fragment outlining how the APIs can be used.

// Get an instance of an ExpressionEvaluator

ExpressionEvaluator ee = myJspContext.getExpressionEvaluator();
VariableResolver vr = myJspContext.getVariableResolver();

FunctionMapper fm; // we don't have a portable implementation yet

// Example of compiling an expression.  See [ISSUE-2]
// Errors detected this way may have higher quality than those
// found with a simple validate() invocation.

ExpressionCompilation ce;

try {
  ce = ee.prepareExpression(expr,
                            targetClass,
                            fm,
                            null // no prefixes
                            );
} catch (ELParseException e) {
        log (e.getMessage());
}

try {
  ce.evaluate(vr);
} catch (ElException e) {
        log (e);
}

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.servlet.jsp.el Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.servlet.jsp.el

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.el.ELResolver
      • javax.servlet.jsp.el.ImplicitObjectELResolver
      • javax.servlet.jsp.el.ScopedAttributeELResolver
    • javax.servlet.jsp.el.Expression
    • javax.servlet.jsp.el.ExpressionEvaluator
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.servlet.jsp.el.ELException
          • javax.servlet.jsp.el.ELParseException

Interface Hierarchy

  • javax.servlet.jsp.el.FunctionMapper
  • javax.servlet.jsp.el.VariableResolver
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ELException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Class ELException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.servlet.jsp.el.ELException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ELParseException
Deprecated. As of JSP 2.1, replaced by ELException

public class ELException
extends Exception

Represents any of the exception conditions that arise during the operation evaluation of the evaluator.

Since:
JSP 2.0
See Also:
Serialized Form

Constructor Summary
ELException()
Deprecated. Creates an ELException with no detail message.
ELException(String pMessage)
Deprecated. Creates an ELException with the provided detail message.
ELException(String pMessage, Throwable pRootCause)
Deprecated. Creates an ELException with the given detail message and root cause.
ELException(Throwable pRootCause)
Deprecated. Creates an ELException with the given root cause.
Method Summary
 Throwable getRootCause()
Deprecated. Returns the root cause.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ELException

public ELException()
Deprecated.
Creates an ELException with no detail message.

ELException

public ELException(String pMessage)
Deprecated.
Creates an ELException with the provided detail message.

Parameters:
pMessage - the detail message

ELException

public ELException(Throwable pRootCause)
Deprecated.
Creates an ELException with the given root cause.

Parameters:
pRootCause - the originating cause of this exception

ELException

public ELException(String pMessage,
                   Throwable pRootCause)
Deprecated.
Creates an ELException with the given detail message and root cause.

Parameters:
pMessage - the detail message
pRootCause - the originating cause of this exception
Method Detail

getRootCause

public Throwable getRootCause()
Deprecated.
Returns the root cause.

Returns:
the root cause of this exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ELParseException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Class ELParseException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.servlet.jsp.el.ELException
                extended by  javax.servlet.jsp.el.ELParseException
All Implemented Interfaces:
Serializable
Deprecated. As of JSP 2.1, replaced by ELException

public class ELParseException
extends ELException

Represents a parsing error encountered while parsing an EL expression.

Since:
JSP 2.0
See Also:
Serialized Form

Constructor Summary
ELParseException()
Deprecated. Creates an ELParseException with no detail message.
ELParseException(String pMessage)
Deprecated. Creates an ELParseException with the provided detail message.
Method Summary
Methods inherited from class javax.servlet.jsp.el.ELException
getRootCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ELParseException

public ELParseException()
Deprecated.
Creates an ELParseException with no detail message.

ELParseException

public ELParseException(String pMessage)
Deprecated.
Creates an ELParseException with the provided detail message.

Parameters:
pMessage - the detail message
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Expression

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Class Expression

java.lang.Object
    extended by  javax.servlet.jsp.el.Expression
Deprecated. As of JSP 2.1, replaced by ValueExpression

public abstract class Expression
extends Object

The abstract class for a prepared expression.

An instance of an Expression can be obtained via from an ExpressionEvaluator instance.

An Expression may or not have done a syntactic parse of the expression. A client invoking the evaluate() method should be ready for the case where ELParseException exceptions are raised.

Since:
JSP 2.0

Constructor Summary
Expression()
Deprecated.
Method Summary
abstract  Object evaluate(VariableResolver vResolver)
Deprecated. Evaluates an expression that was previously prepared.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Expression

public Expression()
Deprecated.
Method Detail

evaluate

public abstract Object evaluate(VariableResolver vResolver)
                         throws ELException
Deprecated.
Evaluates an expression that was previously prepared. In some implementations preparing an expression involves full syntactic validation, but others may not do so. Evaluating the expression may raise an ELParseException as well as other ELExceptions due to run-time evaluation.

Parameters:
vResolver - A VariableResolver instance that can be used at runtime to resolve the name of implicit objects into Objects.
Returns:
The result of the expression evaluation.
Throws:
ELException - Thrown if the expression evaluation failed.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ExpressionEvaluator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Class ExpressionEvaluator

java.lang.Object
    extended by  javax.servlet.jsp.el.ExpressionEvaluator
Deprecated. As of JSP 2.1, replaced by ExpressionFactory

public abstract class ExpressionEvaluator
extends Object

The abstract base class for an expression-language evaluator. Classes that implement an expression language expose their functionality via this abstract class.

An instance of the ExpressionEvaluator can be obtained via the JspContext / PageContext

The parseExpression() and evaluate() methods must be thread-safe. That is, multiple threads may call these methods on the same ExpressionEvaluator object simultaneously. Implementations should synchronize access if they depend on transient state. Implementations should not, however, assume that only one object of each ExpressionEvaluator type will be instantiated; global caching should therefore be static.

Only a single EL expression, starting with '${' and ending with '}', can be parsed or evaluated at a time. EL expressions cannot be mixed with static text. For example, attempting to parse or evaluate "abc${1+1}def${1+1}ghi" or even "${1+1}${1+1}" will cause an ELException to be thrown.

The following are examples of syntactically legal EL expressions:

  • ${person.lastName}
  • ${8 * 8}
  • ${my:reverse('hello')}

Since:
JSP 2.0

Constructor Summary
ExpressionEvaluator()
Deprecated.
Method Summary
abstract Object | evaluate(String expression, Class expectedType, VariableResolver vResolver, FunctionMapper fMapper) Deprecated. Evaluates an expression.
abstract Expression | parseExpression(String expression, Class expectedType, FunctionMapper fMapper) Deprecated. Prepare an expression for later evaluation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExpressionEvaluator

public ExpressionEvaluator()
Deprecated.
Method Detail

parseExpression

public abstract Expression parseExpression(String expression,
                                           Class expectedType,
                                           FunctionMapper fMapper)
                                    throws ELException
Deprecated.
Prepare an expression for later evaluation. This method should perform syntactic validation of the expression; if in doing so it detects errors, it should raise an ELParseException.

Parameters:
expression - The expression to be evaluated.
expectedType - The expected type of the result of the evaluation
fMapper - A FunctionMapper to resolve functions found in the expression. It can be null, in which case no functions are supported for this invocation. The ExpressionEvaluator must not hold on to the FunctionMapper reference after returning from parseExpression(). The Expression object returned must invoke the same functions regardless of whether the mappings in the provided FunctionMapper instance change between calling ExpressionEvaluator.parseExpression() and Expression.evaluate().
Returns:
The Expression object encapsulating the arguments.
Throws:
ELException - Thrown if parsing errors were found.

evaluate

public abstract Object evaluate(String expression,
                                Class expectedType,
                                VariableResolver vResolver,
                                FunctionMapper fMapper)
                         throws ELException
Deprecated.
Evaluates an expression. This method may perform some syntactic validation and, if so, it should raise an ELParseException error if it encounters syntactic errors. EL evaluation errors should cause an ELException to be raised.

Parameters:
expression - The expression to be evaluated.
expectedType - The expected type of the result of the evaluation
vResolver - A VariableResolver instance that can be used at runtime to resolve the name of implicit objects into Objects.
fMapper - A FunctionMapper to resolve functions found in the expression. It can be null, in which case no functions are supported for this invocation.
Returns:
The result of the expression evaluation.
Throws:
ELException - Thrown if the expression evaluation failed.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FunctionMapper

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Interface FunctionMapper

Deprecated. As of JSP 2.1, replaced by FunctionMapper

public interface FunctionMapper

The interface to a map between EL function names and methods.

Classes implementing this interface may, for instance, consult tag library information to resolve the map.

Since:
JSP 2.0

Method Summary
 Method resolveFunction(String prefix, String localName)
Deprecated. Resolves the specified local name and prefix into a Java.lang.Method.

Method Detail

resolveFunction

Method resolveFunction(String prefix,
                       String localName)
Deprecated.
Resolves the specified local name and prefix into a Java.lang.Method. Returns null if the prefix and local name are not found.

Parameters:
prefix - the prefix of the function, or "" if no prefix.
localName - the short name of the function
Returns:
the result of the method mapping. Null means no entry found.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ImplicitObjectELResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Class ImplicitObjectELResolver

java.lang.Object
    extended by  javax.el.ELResolver
        extended by  javax.servlet.jsp.el.ImplicitObjectELResolver

public class ImplicitObjectELResolver
extends ELResolver

Defines variable resolution behavior for the EL implicit objects defined in the JSP specification.

The following variables are resolved by this ELResolver, as per the JSP specification:

  • pageContext - the PageContext object.
  • pageScope - a Map that maps page-scoped attribute names to their values.
  • requestScope - a Map that maps request-scoped attribute names to their values.
  • sessionScope - a Map that maps session-scoped attribute names to their values.
  • applicationScope - a Map that maps application-scoped attribute names to their values.
  • param - a Map that maps parameter names to a single String parameter value (obtained by calling ServletRequest.getParameter(String name)).
  • paramValues - a Map that maps parameter names to a String[] of all values for that parameter (obtained by calling ServletRequest.getParameterValues(String name)).
  • header - a Map that maps header names to a single String header value (obtained by calling HttpServletRequest.getHeader(String name)).
  • headerValues - a Map that maps header names to a String[] of all values for that header (obtained by calling HttpServletRequest.getHeaders(String)).
  • cookie - a Map that maps cookie names to a single Cookie object. Cookies are retrieved according to the semantics of HttpServletRequest.getCookies(). If the same name is shared by multiple cookies, an implementation must use the first one encountered in the array of Cookie objects returned by the getCookies() method. However, users of the cookie implicit object must be aware that the ordering of cookies is currently unspecified in the servlet specification.
  • initParam - a Map that maps context initialization parameter names to their String parameter value (obtained by calling ServletContext.getInitParameter(String name)).

Since:
JSP 2.1
See Also:
ELResolver

Field Summary

Fields inherited from class javax.el.ELResolver
RESOLVABLE_AT_DESIGN_TIME, TYPE

Constructor Summary
ImplicitObjectELResolver()

Method Summary
 Class<String> getCommonPropertyType(ELContext context, Object base)
          If the base object is null, returns String.class.
 Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context, Object base)
          If the base object is null, and the property matches the name of a JSP implicit object, returns an Iterator containing FeatureDescriptor objects with information about each JSP implicit object resolved by this resolver.
 Class getType(ELContext context, Object base, Object property)
          If the base object is null, and the property matches the name of a JSP implicit object, returns null to indicate that no types are ever accepted to setValue().
 Object getValue(ELContext context, Object base, Object property)
          If the base object is null, and the property matches the name of a JSP implicit object, returns the implicit object.
 boolean isReadOnly(ELContext context, Object base, Object property)
          If the base object is null, and the property matches the name of a JSP implicit object, returns true to indicate that implicit objects cannot be overwritten.
 void setValue(ELContext context, Object base, Object property, Object val)
          If the base object is null, and the property matches the name of a JSP implicit object, throws PropertyNotWritableException to indicate that implicit objects cannot be overwritten.

Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ImplicitObjectELResolver

public ImplicitObjectELResolver()
Method Detail

getValue

public Object getValue(ELContext context,
                       Object base,
                       Object property)
If the base object is null, and the property matches the name of a JSP implicit object, returns the implicit object.

The propertyResolved property of the ELContext object must be set to true by this resolver before returning if an implicit object is matched. If this property is not true after this method is called, the caller should ignore the return value.

Specified by:
getValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - Only null is handled by this resolver. Other values will result in an immediate return.
property - The name of the implicit object to resolve.
Returns:
If the propertyResolved property of ELContext was set to true, then the implicit object; otherwise undefined.
Throws:
NullPointerException - if context is null
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getType

public Class getType(ELContext context,
                     Object base,
                     Object property)
If the base object is null, and the property matches the name of a JSP implicit object, returns null to indicate that no types are ever accepted to setValue().

The propertyResolved property of the ELContext object must be set to true by this resolver before returning if an implicit object is matched. If this property is not true after this method is called, the caller should ignore the return value.

Specified by:
getType in class ELResolver
Parameters:
context - The context of this evaluation.
base - Only null is handled by this resolver. Other values will result in an immediate return.
property - The name of the implicit object to resolve.
Returns:
If the propertyResolved property of ELContext was set to true, then null; otherwise undefined.
Throws:
NullPointerException - if context is null
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

setValue

public void setValue(ELContext context,
                     Object base,
                     Object property,
                     Object val)
If the base object is null, and the property matches the name of a JSP implicit object, throws PropertyNotWritableException to indicate that implicit objects cannot be overwritten.

The propertyResolved property of the ELContext object must be set to true by this resolver before returning if an implicit object is matched. If this property is not true after this method is called, the caller should ignore the return value.

Specified by:
setValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - Only null is handled by this resolver. Other values will result in an immediate return.
property - The name of the implicit object.
val - The value to be associated with the implicit object.
Throws:
NullPointerException - if context is null.
PropertyNotWritableException - always thrown, if the implicit object name is recognized by this resolver.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

isReadOnly

public boolean isReadOnly(ELContext context,
                          Object base,
                          Object property)
If the base object is null, and the property matches the name of a JSP implicit object, returns true to indicate that implicit objects cannot be overwritten.

The propertyResolved property of the ELContext object must be set to true by this resolver before returning if an implicit object is matched. If this property is not true after this method is called, the caller should ignore the return value.

Specified by:
isReadOnly in class ELResolver
Parameters:
context - The context of this evaluation.
base - Only null is handled by this resolver. Other values will result in an immediate return.
property - The name of the implicit object.
Returns:
If the propertyResolved property of ELContext was set to true, then true; otherwise undefined.
Throws:
NullPointerException - if context is null.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getFeatureDescriptors

public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                         Object base)
If the base object is null, and the property matches the name of a JSP implicit object, returns an Iterator containing FeatureDescriptor objects with information about each JSP implicit object resolved by this resolver. Otherwise, returns null.

The Iterator returned must contain one instance of FeatureDescriptor for each of the EL implicit objects defined by the JSP spec. Each info object contains information about a single implicit object, and is initialized as follows:

  • displayName - The name of the implicit object.
  • name - Same as displayName property.
  • shortDescription - A suitable description for the implicit object. Will vary by implementation.
  • expert - false
  • hidden - false
  • preferred - true
    • In addition, the following named attributes must be set in the returned FeatureDescriptors:
  • ELResolver.TYPE - The runtime type of the implicit object.
  • ELResolver.RESOLVABLE_AT_DESIGN_TIME - true.

    • Specified by:
    getFeatureDescriptors in class ELResolver
    Parameters:
    context - The context of this evaluation.
    base - Only null is handled by this resolver. Other values will result in a null return value.
    Returns:
    An Iterator containing one FeatureDescriptor object for each implicit object, or null if base is not null.
    See Also:
    FeatureDescriptor

    getCommonPropertyType

    public Class<String> getCommonPropertyType(ELContext context,
                                           Object base)
    If the base object is null, returns String.class. Otherwise, returns null.

    Specified by:
    getCommonPropertyType in class ELResolver
    Parameters:
    context - The context of this evaluation.
    base - Only null is handled by this resolver. Other values will result in a null return value.
    Returns:
    null if base is not null; otherwise String.class.
    Overview  Package   Class  Tree  Deprecated  Index  Help
            Java EE 5 SDK
     PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
    Submit a bug or feature

    Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ScopedAttributeELResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Class ScopedAttributeELResolver

java.lang.Object
    extended by  javax.el.ELResolver
        extended by  javax.servlet.jsp.el.ScopedAttributeELResolver

public class ScopedAttributeELResolver
extends ELResolver

Defines variable resolution behavior for scoped attributes.

This resolver handles all variable resolutions (where base is null. It searches PageContext.findAttribute() for a matching attribute. If not found, it will return null, or in the case of setValue it will create a new attribute in the page scope with the given name.

Since:
JSP 2.1
See Also:
ELResolver

Field Summary
Fields inherited from class javax.el.ELResolver
RESOLVABLE_AT_DESIGN_TIME, TYPE
Constructor Summary
ScopedAttributeELResolver()
Method Summary
Class<String> | getCommonPropertyType(ELContext context, Object base) If the base object is null, returns String.class.
Iterator<FeatureDescriptor> | getFeatureDescriptors(ELContext context, Object base) If the base object is null, returns an Iterator containing FeatureDescriptor objects with information about each scoped attribute resolved by this resolver.
Class<Object> | getType(ELContext context, Object base, Object property) If the base object is null, returns Object.class to indicate that any type is valid to set for a scoped attribute.
Object | getValue(ELContext context, Object base, Object property) If the base object is null, searches the page, request, session and application scopes for an attribute with the given name and returns it, or null if no attribute exists with the current name.
boolean | isReadOnly(ELContext context, Object base, Object property) If the base object is null, returns false to indicate that scoped attributes are never read-only.
void | setValue(ELContext context, Object base, Object property, Object val) If the base object is null, sets an existing scoped attribute to the new value, or creates a new scoped attribute if one does not exist by this name.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ScopedAttributeELResolver

public ScopedAttributeELResolver()
Method Detail

getValue

public Object getValue(ELContext context,
                       Object base,
                       Object property)
If the base object is null, searches the page, request, session and application scopes for an attribute with the given name and returns it, or null if no attribute exists with the current name.

The propertyResolved property of the ELContext object must be set to true by this resolver before returning if base is null. If this property is not true after this method is called, the caller should ignore the return value.

Specified by:
getValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - Only null is handled by this resolver. Other values will result in an immediate return.
property - The name of the scoped attribute to resolve.
Returns:
If the propertyResolved property of ELContext was set to true, then the scoped attribute; otherwise undefined.
Throws:
NullPointerException - if context is null
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getType

public Class<Object> getType(ELContext context,
                             Object base,
                             Object property)
If the base object is null, returns Object.class to indicate that any type is valid to set for a scoped attribute.

The propertyResolved property of the ELContext object must be set to true by this resolver before returning if base is null. If this property is not true after this method is called, the caller should ignore the return value.

Specified by:
getType in class ELResolver
Parameters:
context - The context of this evaluation.
base - Only null is handled by this resolver. Other values will result in an immediate return.
property - The name of the scoped attribute to resolve.
Returns:
If the propertyResolved property of ELContext was set to true, then Object.class; otherwise undefined.
Throws:
NullPointerException - if context is null
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

setValue

public void setValue(ELContext context,
                     Object base,
                     Object property,
                     Object val)
If the base object is null, sets an existing scoped attribute to the new value, or creates a new scoped attribute if one does not exist by this name.

If the provided attribute name matches the key of an attribute in page scope, request scope, session scope, or application scope, the corresponding attribute value will be replaced by the provided value. Otherwise, a new page scope attribute will be created with the given name and value.

The propertyResolved property of the ELContext object must be set to true by this resolver before returning if base is null. If this property is not true after this method is called, the caller should ignore the return value.

Specified by:
setValue in class ELResolver
Parameters:
context - The context of this evaluation.
base - Only null is handled by this resolver. Other values will result in an immediate return.
property - The name of the scoped attribute to set.
val - The value for the scoped attribute.
Throws:
NullPointerException - if context is null.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

isReadOnly

public boolean isReadOnly(ELContext context,
                          Object base,
                          Object property)
If the base object is null, returns false to indicate that scoped attributes are never read-only.

The propertyResolved property of the ELContext object must be set to true by this resolver before returning if base is null. If this property is not true after this method is called, the caller should ignore the return value.

Specified by:
isReadOnly in class ELResolver
Parameters:
context - The context of this evaluation.
base - Only null is handled by this resolver. Other values will result in an immediate return.
property - The name of the scoped attribute.
Returns:
If the propertyResolved property of ELContext was set to true, then false; otherwise undefined.
Throws:
NullPointerException - if context is null.
ELException - if an exception was thrown while performing the property or variable resolution. The thrown exception must be included as the cause property of this exception, if available.

getFeatureDescriptors

public Iterator<FeatureDescriptor> getFeatureDescriptors(ELContext context,
                                                         Object base)
If the base object is null, returns an Iterator containing FeatureDescriptor objects with information about each scoped attribute resolved by this resolver. Otherwise, returns null.

The Iterator returned must contain one instance of FeatureDescriptor for each scoped attribute found in any scope. Each info object contains information about a single scoped attribute, and is initialized as follows:

  • displayName - The name of the scoped attribute.
  • name - Same as displayName property.
  • shortDescription - A suitable description for the scoped attribute. Should include the attribute's current scope (page, request, session, application). Will vary by implementation.
  • expert - false
  • hidden - false
  • preferred - true
    • In addition, the following named attributes must be set in the returned FeatureDescriptors:
  • ELResolver.TYPE - The current runtime type of the scoped attribute.
  • ELResolver.RESOLVABLE_AT_DESIGN_TIME - true.

    • Specified by:
    getFeatureDescriptors in class ELResolver
    Parameters:
    context - The context of this evaluation.
    base - Only null is handled by this resolver. Other values will result in a null return value.
    Returns:
    An Iterator containing one FeatureDescriptor object for each scoped attribute, or null if base is not null.
    See Also:
    FeatureDescriptor

    getCommonPropertyType

    public Class<String> getCommonPropertyType(ELContext context,
                                           Object base)
    If the base object is null, returns String.class. Otherwise, returns null.

    Specified by:
    getCommonPropertyType in class ELResolver
    Parameters:
    context - The context of this evaluation.
    base - Only null is handled by this resolver. Other values will result in a null return value.
    Returns:
    null if base is not null; otherwise String.class.
    Overview Package Class Tree Deprecated Index Help
            Java EE 5 SDK
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
    Submit a bug or feature

    Copyright 2006 Sun Microsystems, Inc. All rights reserved.


VariableResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.el
Interface VariableResolver

Deprecated. As of JSP 2.1, replaced by ELResolver

public interface VariableResolver

This class is used to customize the way an ExpressionEvaluator resolves variable references at evaluation time. For example, instances of this class can implement their own variable lookup mechanisms, or introduce the notion of "implicit variables" which override any other variables. An instance of this class should be passed when evaluating an expression.

An instance of this class includes the context against which resolution will happen

Since:
JSP 2.0

Method Summary
 Object resolveVariable(String pName)
Deprecated. Resolves the specified variable.

Method Detail

resolveVariable

Object resolveVariable(String pName)
                       throws ELException
Deprecated.
Resolves the specified variable. Returns null if the variable is not found.

Parameters:
pName - the name of the variable to resolve
Returns:
the result of the variable resolution
Throws:
ELException - if a failure occurred while trying to resolve the given variable
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ErrorData

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class ErrorData

java.lang.Object
    extended by  javax.servlet.jsp.ErrorData

public final class ErrorData
extends Object

Contains information about an error, for error pages. The information contained in this instance is meaningless if not used in the context of an error page. To indicate a JSP is an error page, the page author must set the isErrorPage attribute of the page directive to "true".

Since:
JSP 2.0
See Also:
PageContext.getErrorData()

Constructor Summary
ErrorData(Throwable throwable, int statusCode, String uri, String servletName)
Creates a new ErrorData object.
Method Summary
String | getRequestURI() Returns the request URI.
String | getServletName() Returns the name of the servlet invoked.
int | getStatusCode() Returns the status code of the error.
Throwable | getThrowable() Returns the Throwable that caused the error.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ErrorData

public ErrorData(Throwable throwable,
                 int statusCode,
                 String uri,
                 String servletName)
Creates a new ErrorData object.

Parameters:
throwable - The Throwable that is the cause of the error
statusCode - The status code of the error
uri - The request URI
servletName - The name of the servlet invoked
Method Detail

getThrowable

public Throwable getThrowable()
Returns the Throwable that caused the error.

Returns:
The Throwable that caused the error

getStatusCode

public int getStatusCode()
Returns the status code of the error.

Returns:
The status code of the error

getRequestURI

public String getRequestURI()
Returns the request URI.

Returns:
The request URI

getServletName

public String getServletName()
Returns the name of the servlet invoked.

Returns:
The name of the servlet invoked
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JspApplicationContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Interface JspApplicationContext

public interface JspApplicationContext

Stores application-scoped information relevant to JSP containers.

The JSP container must create a single instance of JspApplicationContext for each ServletContext instance.

An instance of JspApplicationContext is obtained by invoking the static JspFactory.getJspApplicationContext(javax.servlet.ServletContext) method, passing the ServletContext of the corresponding web application.

The JspApplicationContext provides the following services to JSP applications:

  • Allows registration of ELResolvers, which are used to resolve variables in EL expressions contained in JSP pages and tag files.
  • Provides an instance of ExpressionFactory for those applications or frameworks that need to perform programmatic evaluation of EL expressions instead of allowing the JSP container to do it for them.
  • Allows the attachment of ELContextListener instances for notification whenever a new ELContext is created. This is necessary when an application wishes to make custom context objects available to their pluggable ELResolvers.

Since:
JSP 2.1
See Also:
ServletContext, JspFactory, ELResolver, ExpressionFactory, ELContextListener

Method Summary
void | addELContextListener(ELContextListener listener) Registers a ELContextListeners so that context objects can be added whenever a new ELContext is created.
void | addELResolver(ELResolver resolver) Adds an ELResolver to affect the way EL variables and properties are resolved for EL expressions appearing in JSP pages and tag files.
ExpressionFactory | getExpressionFactory() Returns a factory used to create ValueExpressions and MethodExpressions so that EL expressions can be parsed and evaluated.

Method Detail

addELResolver

void addELResolver(ELResolver resolver)
Adds an ELResolver to affect the way EL variables and properties are resolved for EL expressions appearing in JSP pages and tag files.

For example, in the EL expression ${employee.lastName}, an ELResolver determines what object "employee" references and how to find its "lastName" property.

When evaluating an expression, the JSP container will consult a set of standard resolvers as well as any resolvers registered via this method. The set of resolvers are consulted in the following order:

  • ImplicitObjectELResolver
  • ELResolvers registered via this method, in the order in which they are registered.
  • MapELResolver
  • ListELResolver
  • ArrayELResolver
  • BeanELResolver
  • ScopedAttributeELResolver

It is illegal to register an ELResolver after the application has received any request from the client. If an attempt is made to register an ELResolver after that time, an IllegalStateException is thrown.

This restriction is in place to allow the JSP container to optimize for the common case where no additional ELResolvers are in the chain, aside from the standard ones. It is permissible to add ELResolvers before or after initialization to a CompositeELResolver that is already in the chain.

It is not possible to remove an ELResolver registered with this method, once it has been registered.

Parameters:
resolver - The new ELResolver
Throws:
IllegalStateException - if an attempt is made to call this method after all ServletContextListeners have had their contextInitialized methods invoked.

getExpressionFactory

ExpressionFactory getExpressionFactory()
Returns a factory used to create ValueExpressions and MethodExpressions so that EL expressions can be parsed and evaluated.

Returns:
A concrete implementation of the an ExpressionFactory.

addELContextListener

void addELContextListener(ELContextListener listener)
Registers a ELContextListeners so that context objects can be added whenever a new ELContext is created.

At a minimum, the ELContext objects created will contain a reference to the JspContext for this request, which is added by the JSP container. This is sufficient for all the default ELResolvers listed in addELResolver(javax.el.ELResolver). Note that JspContext.class is used as the key to ELContext.putContext() for the JspContext object reference.

This method is generally used by frameworks and applications that register their own ELResolver that needs context other than JspContext. The listener will typically add the necessary context to the ELContext provided in the event object. Registering a listener that adds context allows the ELResolvers in the stack to access the context they need when they do a resolution.

Parameters:
listener - The listener to be notified when a new ELContext is created.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JspContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class JspContext

java.lang.Object
    extended by  javax.servlet.jsp.JspContext
Direct Known Subclasses:
PageContext
public abstract class JspContext
extends Object

JspContext serves as the base class for the PageContext class and abstracts all information that is not specific to servlets. This allows for Simple Tag Extensions to be used outside of the context of a request/response Servlet.

The JspContext provides a number of facilities to the page/component author and page implementor, including:

  • a single API to manage the various scoped namespaces
  • a mechanism to obtain the JspWriter for output
  • a mechanism to expose page directive attributes to the scripting environment

Methods Intended for Container Generated Code

The following methods enable the management of nested JspWriter streams to implement Tag Extensions: pushBody() and popBody()

Methods Intended for JSP authors

Some methods provide uniform access to the diverse objects representing scopes. The implementation must use the underlying machinery corresponding to that scope, so information can be passed back and forth between the underlying environment (e.g. Servlets) and JSP pages. The methods are: setAttribute(), getAttribute(), findAttribute(), removeAttribute(), getAttributesScope() and getAttributeNamesInScope().

The following methods provide convenient access to implicit objects: getOut()

The following methods provide programmatic access to the Expression Language evaluator: getExpressionEvaluator(), getVariableResolver()

Since:
JSP 2.0

Constructor Summary
JspContext()
Sole constructor.
Method Summary
abstract  Object findAttribute(String name)
Searches for the named attribute in page, request, session (if valid), and application scope(s) in order and returns the value associated or null.
abstract  Object getAttribute(String name)
Returns the object associated with the name in the page scope or null if not found.
abstract  Object getAttribute(String name, int scope)
Return the object associated with the name in the specified scope or null if not found.
abstract  Enumeration<String> getAttributeNamesInScope(int scope)
Enumerate all the attributes in a given scope.
abstract  int getAttributesScope(String name)
Get the scope where a given attribute is defined.
abstract  ELContext getELContext()
Returns the ELContext associated with this JspContext.
abstract  ExpressionEvaluator getExpressionEvaluator()
Deprecated. As of JSP 2.1, replaced by JspApplicationContext.getExpressionFactory()
abstract  JspWriter getOut()
The current value of the out object (a JspWriter).
abstract  VariableResolver getVariableResolver()
Deprecated. As of JSP 2.1, replaced by ELContext.getELResolver(), which can be obtained by jspContext.getELContext().getELResolver().
 JspWriter popBody()
Return the previous JspWriter "out" saved by the matching pushBody(), and update the value of the "out" attribute in the page scope attribute namespace of the JspContext.
 JspWriter pushBody(Writer writer)
Return a new JspWriter object that sends output to the provided Writer.
abstract  void removeAttribute(String name)
Remove the object reference associated with the given name from all scopes.
abstract  void removeAttribute(String name, int scope)
Remove the object reference associated with the specified name in the given scope.
abstract  void setAttribute(String name, Object value)
Register the name and value specified with page scope semantics.
abstract  void setAttribute(String name, Object value, int scope)
Register the name and value specified with appropriate scope semantics.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JspContext

public JspContext()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

setAttribute

public abstract void setAttribute(String name,
                                  Object value)
Register the name and value specified with page scope semantics. If the value passed in is null, this has the same effect as calling removeAttribute( name, PageContext.PAGE_SCOPE ).

Parameters:
name - the name of the attribute to set
value - the value to associate with the name, or null if the attribute is to be removed from the page scope.
Throws:
NullPointerException - if the name is null

setAttribute

public abstract void setAttribute(String name,
                                  Object value,
                                  int scope)
Register the name and value specified with appropriate scope semantics. If the value passed in is null, this has the same effect as calling removeAttribute( name, scope ).

Parameters:
name - the name of the attribute to set
value - the object to associate with the name, or null if the attribute is to be removed from the specified scope.
scope - the scope with which to associate the name/object
Throws:
NullPointerException - if the name is null
IllegalArgumentException - if the scope is invalid
IllegalStateException - if the scope is PageContext.SESSION_SCOPE but the page that was requested does not participate in a session or the session has been invalidated.

getAttribute

public abstract Object getAttribute(String name)
Returns the object associated with the name in the page scope or null if not found.

Parameters:
name - the name of the attribute to get
Returns:
the object associated with the name in the page scope or null if not found.
Throws:
NullPointerException - if the name is null

getAttribute

public abstract Object getAttribute(String name,
                                    int scope)
Return the object associated with the name in the specified scope or null if not found.

Parameters:
name - the name of the attribute to set
scope - the scope with which to associate the name/object
Returns:
the object associated with the name in the specified scope or null if not found.
Throws:
NullPointerException - if the name is null
IllegalArgumentException - if the scope is invalid
IllegalStateException - if the scope is PageContext.SESSION_SCOPE but the page that was requested does not participate in a session or the session has been invalidated.

findAttribute

public abstract Object findAttribute(String name)
Searches for the named attribute in page, request, session (if valid), and application scope(s) in order and returns the value associated or null.

Parameters:
name - the name of the attribute to search for
Returns:
the value associated or null
Throws:
NullPointerException - if the name is null

removeAttribute

public abstract void removeAttribute(String name)
Remove the object reference associated with the given name from all scopes. Does nothing if there is no such object.

Parameters:
name - The name of the object to remove.
Throws:
NullPointerException - if the name is null

removeAttribute

public abstract void removeAttribute(String name,
                                     int scope)
Remove the object reference associated with the specified name in the given scope. Does nothing if there is no such object.

Parameters:
name - The name of the object to remove.
scope - The scope where to look.
Throws:
IllegalArgumentException - if the scope is invalid
IllegalStateException - if the scope is PageContext.SESSION_SCOPE but the page that was requested does not participate in a session or the session has been invalidated.
NullPointerException - if the name is null

getAttributesScope

public abstract int getAttributesScope(String name)
Get the scope where a given attribute is defined.

Parameters:
name - the name of the attribute to return the scope for
Returns:
the scope of the object associated with the name specified or 0
Throws:
NullPointerException - if the name is null

getAttributeNamesInScope

public abstract Enumeration<String> getAttributeNamesInScope(int scope)
Enumerate all the attributes in a given scope.

Parameters:
scope - the scope to enumerate all the attributes for
Returns:
an enumeration of names (java.lang.String) of all the attributes the specified scope
Throws:
IllegalArgumentException - if the scope is invalid
IllegalStateException - if the scope is PageContext.SESSION_SCOPE but the page that was requested does not participate in a session or the session has been invalidated.

getOut

public abstract JspWriter getOut()
The current value of the out object (a JspWriter).

Returns:
the current JspWriter stream being used for client response

getExpressionEvaluator

public abstract ExpressionEvaluator getExpressionEvaluator()
Deprecated. As of JSP 2.1, replaced by JspApplicationContext.getExpressionFactory()

Provides programmatic access to the ExpressionEvaluator. The JSP Container must return a valid instance of an ExpressionEvaluator that can parse EL expressions.

Returns:
A valid instance of an ExpressionEvaluator.
Since:
JSP 2.0

getVariableResolver

public abstract VariableResolver getVariableResolver()
Deprecated. As of JSP 2.1, replaced by ELContext.getELResolver(), which can be obtained by jspContext.getELContext().getELResolver().

Returns an instance of a VariableResolver that provides access to the implicit objects specified in the JSP specification using this JspContext as the context object.

Returns:
A valid instance of a VariableResolver.
Since:
JSP 2.0

getELContext

public abstract ELContext getELContext()
Returns the ELContext associated with this JspContext.

The ELContext is created lazily and is reused if it already exists. There is a new ELContext for each JspContext.

The ELContext must contain the ELResolver described in the JSP specification (and in the javadocs for JspApplicationContext.addELResolver(javax.el.ELResolver)).

Returns:
The ELContext associated with this JspContext.
Since:
JSP 2.1

pushBody

public JspWriter pushBody(Writer writer)
Return a new JspWriter object that sends output to the provided Writer. Saves the current "out" JspWriter, and updates the value of the "out" attribute in the page scope attribute namespace of the JspContext.

The returned JspWriter must implement all methods and behave as though it were unbuffered. More specifically:

  • clear() must throw an IOException
  • clearBuffer() does nothing
  • getBufferSize() always returns 0
  • getRemaining() always returns 0

Parameters:
writer - The Writer for the returned JspWriter to send output to.
Returns:
a new JspWriter that writes to the given Writer.
Since:
JSP 2.0

popBody

public JspWriter popBody()
Return the previous JspWriter "out" saved by the matching pushBody(), and update the value of the "out" attribute in the page scope attribute namespace of the JspContext.

Returns:
the saved JspWriter.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JspEngineInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class JspEngineInfo

java.lang.Object
    extended by  javax.servlet.jsp.JspEngineInfo

public abstract class JspEngineInfo
extends Object

The JspEngineInfo is an abstract class that provides information on the current JSP engine.

Constructor Summary
JspEngineInfo()
Sole constructor.
Method Summary
abstract  String getSpecificationVersion()
Return the version number of the JSP specification that is supported by this JSP engine.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JspEngineInfo

public JspEngineInfo()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

getSpecificationVersion

public abstract String getSpecificationVersion()
Return the version number of the JSP specification that is supported by this JSP engine.

Specification version numbers that consists of positive decimal integers separated by periods ".", for example, "2.0" or "1.2.3.4.5.6.7". This allows an extensible number to be used to represent major, minor, micro, etc versions. The version number must begin with a number.

Returns:
the specification version, null is returned if it is not known
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JspException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class JspException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.servlet.jsp.JspException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
JspTagException, SkipPageException
public class JspException
extends Exception

A generic exception known to the JSP engine; uncaught JspExceptions will result in an invocation of the errorpage machinery.

See Also:
Serialized Form

Constructor Summary
JspException()
Construct a JspException.
JspException(String msg)
Constructs a new JSP exception with the specified message.
JspException(String message, Throwable cause)
Constructs a new JspException with the specified detail message and cause.
JspException(Throwable cause)
Constructs a new JspException with the specified cause.
Method Summary
 Throwable getRootCause()
Deprecated. As of JSP 2.1, replaced by Throwable.getCause()
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JspException

public JspException()
Construct a JspException.

JspException

public JspException(String msg)
Constructs a new JSP exception with the specified message. The message can be written to the server log and/or displayed for the user.

Parameters:
msg - a String specifying the text of the exception message

JspException

public JspException(String message,
                    Throwable cause)
Constructs a new JspException with the specified detail message and cause. The cause is saved for later retrieval by the Throwable.getCause() and getRootCause() methods.

See Also:
Exception.Exception(String, Throwable)

JspException

public JspException(Throwable cause)
Constructs a new JspException with the specified cause. The cause is saved for later retrieval by the Throwable.getCause() and getRootCause() methods.

See Also:
Exception.Exception(Throwable)
Method Detail

getRootCause

public Throwable getRootCause()
Deprecated. As of JSP 2.1, replaced by Throwable.getCause()

Returns the exception that caused this JSP exception.

Returns:
the Throwable that caused this JSP exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JspFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class JspFactory

java.lang.Object
    extended by  javax.servlet.jsp.JspFactory

public abstract class JspFactory
extends Object

The JspFactory is an abstract class that defines a number of factory methods available to a JSP page at runtime for the purposes of creating instances of various interfaces and classes used to support the JSP implementation.

A conformant JSP Engine implementation will, during it's initialization instantiate an implementation dependent subclass of this class, and make it globally available for use by JSP implementation classes by registering the instance created with this class via the static setDefaultFactory() method.

The only implementation-dependent classes that can be created from the factory are: PageContext, JspEngineInfo, and JspApplicationContext.

With the exception of JspApplicationContext, JspFactory objects should not be used by JSP application developers.

Constructor Summary
JspFactory()
Sole constructor.
Method Summary
static JspFactory | getDefaultFactory() Returns the default factory for this implementation.
abstract JspEngineInfo | getEngineInfo() called to get implementation-specific information on the current JSP engine.
abstract JspApplicationContext | getJspApplicationContext(ServletContext context) Obtains the JspApplicationContext instance associated with the web application for the given ServletContext.
abstract PageContext | getPageContext(Servlet servlet, ServletRequest request, ServletResponse response, String errorPageURL, boolean needsSession, int buffer, boolean autoflush) obtains an instance of an implementation dependent javax.servlet.jsp.PageContext abstract class for the calling Servlet and currently pending request and response.
abstract void | releasePageContext(PageContext pc) called to release a previously allocated PageContext object.
static void | setDefaultFactory(JspFactory deflt) set the default factory for this implementation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JspFactory

public JspFactory()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

setDefaultFactory

public static void setDefaultFactory(JspFactory deflt)

set the default factory for this implementation. It is illegal for any principal other than the JSP Engine runtime to call this method.

Parameters:
deflt - The default factory implementation

getDefaultFactory

public static JspFactory getDefaultFactory()
Returns the default factory for this implementation.

Returns:
the default factory for this implementation

getPageContext

public abstract PageContext getPageContext(Servlet servlet,
                                           ServletRequest request,
                                           ServletResponse response,
                                           String errorPageURL,
                                           boolean needsSession,
                                           int buffer,
                                           boolean autoflush)

obtains an instance of an implementation dependent javax.servlet.jsp.PageContext abstract class for the calling Servlet and currently pending request and response.

This method is typically called early in the processing of the _jspService() method of a JSP implementation class in order to obtain a PageContext object for the request being processed.

Invoking this method shall result in the PageContext.initialize() method being invoked. The PageContext returned is properly initialized.

All PageContext objects obtained via this method shall be released by invoking releasePageContext().

Parameters:
servlet - the requesting servlet
request - the current request pending on the servlet
response - the current response pending on the servlet
errorPageURL - the URL of the error page for the requesting JSP, or null
needsSession - true if the JSP participates in a session
buffer - size of buffer in bytes, PageContext.NO_BUFFER if no buffer, PageContext.DEFAULT_BUFFER if implementation default.
autoflush - should the buffer autoflush to the output stream on buffer overflow, or throw an IOException?
Returns:
the page context
See Also:
PageContext

releasePageContext

public abstract void releasePageContext(PageContext pc)

called to release a previously allocated PageContext object. Results in PageContext.release() being invoked. This method should be invoked prior to returning from the _jspService() method of a JSP implementation class.

Parameters:
pc - A PageContext previously obtained by getPageContext()

getEngineInfo

public abstract JspEngineInfo getEngineInfo()

called to get implementation-specific information on the current JSP engine.

Returns:
a JspEngineInfo object describing the current JSP engine

getJspApplicationContext

public abstract JspApplicationContext getJspApplicationContext(ServletContext context)
Obtains the JspApplicationContext instance associated with the web application for the given ServletContext.

Parameters:
context - The ServletContext for the web application the desired JspApplicationContext is associated with.
Returns:
The JspApplicationContext associated with the web application.
Since:
2.1
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JspPage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Interface JspPage

All Superinterfaces:
Servlet
All Known Subinterfaces:
HttpJspPage
public interface JspPage
extends Servlet

The JspPage interface describes the generic interaction that a JSP Page Implementation class must satisfy; pages that use the HTTP protocol are described by the HttpJspPage interface.

Two plus One Methods

The interface defines a protocol with 3 methods; only two of them: jspInit() and jspDestroy() are part of this interface as the signature of the third method: _jspService() depends on the specific protocol used and cannot be expressed in a generic way in Java.

A class implementing this interface is responsible for invoking the above methods at the appropriate time based on the corresponding Servlet-based method invocations.

The jspInit() and jspDestroy() methods can be defined by a JSP author, but the _jspService() method is defined automatically by the JSP processor based on the contents of the JSP page.

_jspService()

The _jspService()method corresponds to the body of the JSP page. This method is defined automatically by the JSP container and should never be defined by the JSP page author.

If a superclass is specified using the extends attribute, that superclass may choose to perform some actions in its service() method before or after calling the _jspService() method. See using the extends attribute in the JSP_Engine chapter of the JSP specification.

The specific signature depends on the protocol supported by the JSP page.

 public void _jspService(ServletRequestSubtype request,
                             ServletResponseSubtype response)
        throws ServletException, IOException;

Method Summary
 void jspDestroy()
The jspDestroy() method is invoked when the JSP page is about to be destroyed.
 void jspInit()
The jspInit() method is invoked when the JSP page is initialized.
Methods inherited from interface javax.servlet.Servlet
destroy, getServletConfig, getServletInfo, init, service

Method Detail

jspInit

void jspInit()
The jspInit() method is invoked when the JSP page is initialized. It is the responsibility of the JSP implementation (and of the class mentioned by the extends attribute, if present) that at this point invocations to the getServletConfig() method will return the desired value. A JSP page can override this method by including a definition for it in a declaration element. A JSP page should redefine the init() method from Servlet.

jspDestroy

void jspDestroy()
The jspDestroy() method is invoked when the JSP page is about to be destroyed. A JSP page can override this method by including a definition for it in a declaration element. A JSP page should redefine the destroy() method from Servlet.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JspTagException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class JspTagException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.servlet.jsp.JspException
                extended by  javax.servlet.jsp.JspTagException
All Implemented Interfaces:
Serializable
public class JspTagException
extends JspException

Exception to be used by a Tag Handler to indicate some unrecoverable error. This error is to be caught by the top level of the JSP page and will result in an error page.

See Also:
Serialized Form

Constructor Summary
JspTagException()
Constructs a new JspTagException with no message.
JspTagException(String msg)
Constructs a new JspTagException with the specified message.
JspTagException(String message, Throwable rootCause)
Constructs a new JspTagException when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.
JspTagException(Throwable rootCause)
Constructs a new JSP Tag exception when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation.
Method Summary
Methods inherited from class javax.servlet.jsp.JspException
getRootCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JspTagException

public JspTagException(String msg)
Constructs a new JspTagException with the specified message. The message can be written to the server log and/or displayed for the user.

Parameters:
msg - a String specifying the text of the exception message

JspTagException

public JspTagException()
Constructs a new JspTagException with no message.

JspTagException

public JspTagException(String message,
                       Throwable rootCause)
Constructs a new JspTagException when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.

Parameters:
message - a String containing the text of the exception message
rootCause - the Throwable exception that interfered with the JSP Tag's normal operation, making this JSP Tag exception necessary
Since:
JSP 2.0

JspTagException

public JspTagException(Throwable rootCause)
Constructs a new JSP Tag exception when the JSP Tag needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation. The exception's message is based on the localized message of the underlying exception.

This method calls the getLocalizedMessage method on the Throwable exception to get a localized exception message. When subclassing JspTagException, this method can be overridden to create an exception message designed for a specific locale.

Parameters:
rootCause - the Throwable exception that interfered with the JSP Tag's normal operation, making the JSP Tag exception necessary
Since:
JSP 2.0
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JspWriter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class JspWriter

java.lang.Object
    extended by  java.io.Writer
        extended by  javax.servlet.jsp.JspWriter
All Implemented Interfaces:
Closeable, Flushable, Appendable
Direct Known Subclasses:
BodyContent
public abstract class JspWriter
extends Writer

The actions and template data in a JSP page is written using the JspWriter object that is referenced by the implicit variable out which is initialized automatically using methods in the PageContext object.

This abstract class emulates some of the functionality found in the java.io.BufferedWriter and java.io.PrintWriter classes, however it differs in that it throws java.io.IOException from the print methods while PrintWriter does not.

Buffering

The initial JspWriter object is associated with the PrintWriter object of the ServletResponse in a way that depends on whether the page is or is not buffered. If the page is not buffered, output written to this JspWriter object will be written through to the PrintWriter directly, which will be created if necessary by invoking the getWriter() method on the response object. But if the page is buffered, the PrintWriter object will not be created until the buffer is flushed and operations like setContentType() are legal. Since this flexibility simplifies programming substantially, buffering is the default for JSP pages.

Buffering raises the issue of what to do when the buffer is exceeded. Two approaches can be taken:

  • Exceeding the buffer is not a fatal error; when the buffer is exceeded, just flush the output.
  • Exceeding the buffer is a fatal error; when the buffer is exceeded, raise an exception.

Both approaches are valid, and thus both are supported in the JSP technology. The behavior of a page is controlled by the autoFlush attribute, which defaults to true. In general, JSP pages that need to be sure that correct and complete data has been sent to their client may want to set autoFlush to false, with a typical case being that where the client is an application itself. On the other hand, JSP pages that send data that is meaningful even when partially constructed may want to set autoFlush to true; such as when the data is sent for immediate display through a browser. Each application will need to consider their specific needs.

An alternative considered was to make the buffer size unbounded; but, this had the disadvantage that runaway computations would consume an unbounded amount of resources.

The "out" implicit variable of a JSP implementation class is of this type. If the page directive selects autoflush="true" then all the I/O operations on this class shall automatically flush the contents of the buffer if an overflow condition would result if the current operation were performed without a flush. If autoflush="false" then all the I/O operations on this class shall throw an IOException if performing the current operation would result in a buffer overflow condition.

See Also:
Writer, BufferedWriter, PrintWriter

Field Summary
protected boolean | autoFlush Whether the JspWriter is autoflushing.
protected int | bufferSize The size of the buffer used by the JspWriter.
static int | DEFAULT_BUFFER Constant indicating that the Writer is buffered and is using the implementation default buffer size.
static int | NO_BUFFER Constant indicating that the Writer is not buffering output.
static int | UNBOUNDED_BUFFER Constant indicating that the Writer is buffered and is unbounded; this is used in BodyContent.
Fields inherited from class java.io.Writer
lock
Constructor Summary
protected JspWriter(int bufferSize, boolean autoFlush)
Protected constructor.
Method Summary
abstract void | clear() Clear the contents of the buffer.
abstract void | clearBuffer() Clears the current contents of the buffer.
abstract void | close() Close the stream, flushing it first.
abstract void | flush() Flush the stream.
int | getBufferSize() This method returns the size of the buffer used by the JspWriter.
abstract int | getRemaining() This method returns the number of unused bytes in the buffer.
boolean | isAutoFlush() This method indicates whether the JspWriter is autoFlushing.
abstract void | newLine() Write a line separator.
abstract void | print(boolean b) Print a boolean value.
abstract void | print(char c) Print a character.
abstract void | print(char[] s) Print an array of characters.
abstract void | print(double d) Print a double-precision floating-point number.
abstract void | print(float f) Print a floating-point number.
abstract void | print(int i) Print an integer.
abstract void | print(long l) Print a long integer.
abstract void | print(Object obj) Print an object.
abstract void | print(String s) Print a string.
abstract void | println() Terminate the current line by writing the line separator string.
abstract void | println(boolean x) Print a boolean value and then terminate the line.
abstract void | println(char x) Print a character and then terminate the line.
abstract void | println(char[] x) Print an array of characters and then terminate the line.
abstract void | println(double x) Print a double-precision floating-point number and then terminate the line.
abstract void | println(float x) Print a floating-point number and then terminate the line.
abstract void | println(int x) Print an integer and then terminate the line.
abstract void | println(long x) Print a long integer and then terminate the line.
abstract void | println(Object x) Print an Object and then terminate the line.
abstract void | println(String x) Print a String and then terminate the line.
Methods inherited from class java.io.Writer
append, append, append, write, write, write, write, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NO_BUFFER

public static final int NO_BUFFER
Constant indicating that the Writer is not buffering output.

See Also:
Constant Field Values

DEFAULT_BUFFER

public static final int DEFAULT_BUFFER
Constant indicating that the Writer is buffered and is using the implementation default buffer size.

See Also:
Constant Field Values

UNBOUNDED_BUFFER

public static final int UNBOUNDED_BUFFER
Constant indicating that the Writer is buffered and is unbounded; this is used in BodyContent.

See Also:
Constant Field Values

bufferSize

protected int bufferSize
The size of the buffer used by the JspWriter.

autoFlush

protected boolean autoFlush
Whether the JspWriter is autoflushing.

Constructor Detail

JspWriter

protected JspWriter(int bufferSize,
                    boolean autoFlush)
Protected constructor.

Parameters:
bufferSize - the size of the buffer to be used by the JspWriter
autoFlush - whether the JspWriter should be autoflushing
Method Detail

newLine

public abstract void newLine()
                      throws IOException
Write a line separator. The line separator string is defined by the system property line.separator, and is not necessarily a single newline ('\n') character.

Throws:
IOException - If an I/O error occurs

print

public abstract void print(boolean b)
                    throws IOException
Print a boolean value. The string produced by String.valueOf(boolean) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
b - The boolean to be printed
Throws:
IOException - If an error occured while writing

print

public abstract void print(char c)
                    throws IOException
Print a character. The character is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
c - The char to be printed
Throws:
IOException - If an error occured while writing

print

public abstract void print(int i)
                    throws IOException
Print an integer. The string produced by String.valueOf(int) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
i - The int to be printed
Throws:
IOException - If an error occured while writing
See Also:
Integer.toString(int)

print

public abstract void print(long l)
                    throws IOException
Print a long integer. The string produced by String.valueOf(long) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
l - The long to be printed
Throws:
IOException - If an error occured while writing
See Also:
Long.toString(long)

print

public abstract void print(float f)
                    throws IOException
Print a floating-point number. The string produced by String.valueOf(float) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
f - The float to be printed
Throws:
IOException - If an error occured while writing
See Also:
Float.toString(float)

print

public abstract void print(double d)
                    throws IOException
Print a double-precision floating-point number. The string produced by String.valueOf(double) is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
d - The double to be printed
Throws:
IOException - If an error occured while writing
See Also:
Double.toString(double)

print

public abstract void print(char[] s)
                    throws IOException
Print an array of characters. The characters are written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
s - The array of chars to be printed
Throws:
NullPointerException - If s is null
IOException - If an error occured while writing

print

public abstract void print(String s)
                    throws IOException
Print a string. If the argument is null then the string "null" is printed. Otherwise, the string's characters are written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
s - The String to be printed
Throws:
IOException - If an error occured while writing

print

public abstract void print(Object obj)
                    throws IOException
Print an object. The string produced by the String.valueOf(Object) method is written to the JspWriter's buffer or, if no buffer is used, directly to the underlying writer.

Parameters:
obj - The Object to be printed
Throws:
IOException - If an error occured while writing
See Also:
Object.toString()

println

public abstract void println()
                      throws IOException
Terminate the current line by writing the line separator string. The line separator string is defined by the system property line.separator, and is not necessarily a single newline character ('\n').

Throws:
IOException - If an error occured while writing

println

public abstract void println(boolean x)
                      throws IOException
Print a boolean value and then terminate the line. This method behaves as though it invokes print(boolean) and then println().

Parameters:
x - the boolean to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(char x)
                      throws IOException
Print a character and then terminate the line. This method behaves as though it invokes print(char) and then println().

Parameters:
x - the char to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(int x)
                      throws IOException
Print an integer and then terminate the line. This method behaves as though it invokes print(int) and then println().

Parameters:
x - the int to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(long x)
                      throws IOException
Print a long integer and then terminate the line. This method behaves as though it invokes print(long) and then println().

Parameters:
x - the long to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(float x)
                      throws IOException
Print a floating-point number and then terminate the line. This method behaves as though it invokes print(float) and then println().

Parameters:
x - the float to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(double x)
                      throws IOException
Print a double-precision floating-point number and then terminate the line. This method behaves as though it invokes print(double) and then println().

Parameters:
x - the double to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(char[] x)
                      throws IOException
Print an array of characters and then terminate the line. This method behaves as though it invokes print(char[]) and then println().

Parameters:
x - the char[] to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(String x)
                      throws IOException
Print a String and then terminate the line. This method behaves as though it invokes print(String) and then println().

Parameters:
x - the String to write
Throws:
IOException - If an error occured while writing

println

public abstract void println(Object x)
                      throws IOException
Print an Object and then terminate the line. This method behaves as though it invokes print(Object) and then println().

Parameters:
x - the Object to write
Throws:
IOException - If an error occured while writing

clear

public abstract void clear()
                    throws IOException
Clear the contents of the buffer. If the buffer has been already been flushed then the clear operation shall throw an IOException to signal the fact that some data has already been irrevocably written to the client response stream.

Throws:
IOException - If an I/O error occurs

clearBuffer

public abstract void clearBuffer()
                          throws IOException
Clears the current contents of the buffer. Unlike clear(), this method will not throw an IOException if the buffer has already been flushed. It merely clears the current content of the buffer and returns.

Throws:
IOException - If an I/O error occurs

flush

public abstract void flush()
                    throws IOException
Flush the stream. If the stream has saved any characters from the various write() methods in a buffer, write them immediately to their intended destination. Then, if that destination is another character or byte stream, flush it. Thus one flush() invocation will flush all the buffers in a chain of Writers and OutputStreams.

The method may be invoked indirectly if the buffer size is exceeded.

Once a stream has been closed, further write() or flush() invocations will cause an IOException to be thrown.

Specified by:
flush in interface Flushable
Specified by:
flush in class Writer
Throws:
IOException - If an I/O error occurs

close

public abstract void close()
                    throws IOException
Close the stream, flushing it first.

This method needs not be invoked explicitly for the initial JspWriter as the code generated by the JSP container will automatically include a call to close().

Closing a previously-closed stream, unlike flush(), has no effect.

Specified by:
close in interface Closeable
Specified by:
close in class Writer
Throws:
IOException - If an I/O error occurs

getBufferSize

public int getBufferSize()
This method returns the size of the buffer used by the JspWriter.

Returns:
the size of the buffer in bytes, or 0 is unbuffered.

getRemaining

public abstract int getRemaining()
This method returns the number of unused bytes in the buffer.

Returns:
the number of bytes unused in the buffer

isAutoFlush

public boolean isAutoFlush()
This method indicates whether the JspWriter is autoFlushing.

Returns:
if this JspWriter is auto flushing or throwing IOExceptions on buffer overflow conditions
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PageContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class PageContext

java.lang.Object
    extended by  javax.servlet.jsp.JspContext
        extended by  javax.servlet.jsp.PageContext

public abstract class PageContext
extends JspContext

PageContext extends JspContext to provide useful context information for when JSP technology is used in a Servlet environment.

A PageContext instance provides access to all the namespaces associated with a JSP page, provides access to several page attributes, as well as a layer above the implementation details. Implicit objects are added to the pageContext automatically.

The PageContext class is an abstract class, designed to be extended to provide implementation dependent implementations thereof, by conformant JSP engine runtime environments. A PageContext instance is obtained by a JSP implementation class by calling the JspFactory.getPageContext() method, and is released by calling JspFactory.releasePageContext().

An example of how PageContext, JspFactory, and other classes can be used within a JSP Page Implementation object is given elsewhere.

The PageContext provides a number of facilities to the page/component author and page implementor, including:

  • a single API to manage the various scoped namespaces
  • a number of convenience API's to access various public objects
  • a mechanism to obtain the JspWriter for output
  • a mechanism to manage session usage by the page
  • a mechanism to expose page directive attributes to the scripting environment
  • mechanisms to forward or include the current request to other active components in the application
  • a mechanism to handle errorpage exception processing

Methods Intended for Container Generated Code

Some methods are intended to be used by the code generated by the container, not by code written by JSP page authors, or JSP tag library authors.

The methods supporting lifecycle are initialize() and release()

The following methods enable the management of nested JspWriter streams to implement Tag Extensions: pushBody()

Methods Intended for JSP authors

The following methods provide convenient access to implicit objects:
getException(),  getPage()
getRequest(),  getResponse(),
getSession(),  getServletConfig()
and getServletContext().

The following methods provide support for forwarding, inclusion and error handling: forward(), include(), and handlePageException().

Field Summary
static String | APPLICATION Name used to store ServletContext in PageContext name table.
static int | APPLICATION_SCOPE Application scope: named reference remains available in the ServletContext until it is reclaimed.
static String | CONFIG Name used to store ServletConfig in PageContext name table.
static String | EXCEPTION Name used to store uncaught exception in ServletRequest attribute list and PageContext name table.
static String | OUT Name used to store current JspWriter in PageContext name table.
static String | PAGE Name used to store the Servlet in this PageContext's nametables.
static int | PAGE_SCOPE Page scope: (this is the default) the named reference remains available in this PageContext until the return from the current Servlet.service() invocation.
static String | PAGECONTEXT Name used to store this PageContext in it's own name table.
static String | REQUEST Name used to store ServletRequest in PageContext name table.
static int | REQUEST_SCOPE Request scope: the named reference remains available from the ServletRequest associated with the Servlet until the current request is completed.
static String | RESPONSE Name used to store ServletResponse in PageContext name table.
static String | SESSION Name used to store HttpSession in PageContext name table.
static int | SESSION_SCOPE Session scope (only valid if this page participates in a session): the named reference remains available from the HttpSession (if any) associated with the Servlet until the HttpSession is invalidated.
Constructor Summary
PageContext()
Sole constructor.
Method Summary
abstract  void forward(String relativeUrlPath)
This method is used to re-direct, or "forward" the current ServletRequest and ServletResponse to another active component in the application.
 ErrorData getErrorData()
Provides convenient access to error information.
abstract  Exception getException()
The current value of the exception object (an Exception).
abstract  Object getPage()
The current value of the page object (In a Servlet environment, this is an instance of javax.servlet.Servlet).
abstract  ServletRequest getRequest()
The current value of the request object (a ServletRequest).
abstract  ServletResponse getResponse()
The current value of the response object (a ServletResponse).
abstract  ServletConfig getServletConfig()
The ServletConfig instance.
abstract  ServletContext getServletContext()
The ServletContext instance.
abstract  HttpSession getSession()
The current value of the session object (an HttpSession).
abstract  void handlePageException(Exception e)
This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.
abstract  void handlePageException(Throwable t)
This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP.
abstract  void include(String relativeUrlPath)
Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.
abstract  void include(String relativeUrlPath, boolean flush)
Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread.
abstract  void initialize(Servlet servlet, ServletRequest request, ServletResponse response, String errorPageURL, boolean needsSession, int bufferSize, boolean autoFlush)
The initialize method is called to initialize an uninitialized PageContext so that it may be used by a JSP Implementation class to service an incoming request and response within it's _jspService() method.
 BodyContent pushBody()
Return a new BodyContent object, save the current "out" JspWriter, and update the value of the "out" attribute in the page scope attribute namespace of the PageContext.
abstract  void release()
This method shall "reset" the internal state of a PageContext, releasing all internal references, and preparing the PageContext for potential reuse by a later invocation of initialize().
Methods inherited from class javax.servlet.jsp.JspContext
findAttribute, getAttribute, getAttribute, getAttributeNamesInScope, getAttributesScope, getELContext, getExpressionEvaluator, getOut, getVariableResolver, popBody, pushBody, removeAttribute, removeAttribute, setAttribute, setAttribute
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PAGE_SCOPE

public static final int PAGE_SCOPE
Page scope: (this is the default) the named reference remains available in this PageContext until the return from the current Servlet.service() invocation.

See Also:
Constant Field Values

REQUEST_SCOPE

public static final int REQUEST_SCOPE
Request scope: the named reference remains available from the ServletRequest associated with the Servlet until the current request is completed.

See Also:
Constant Field Values

SESSION_SCOPE

public static final int SESSION_SCOPE
Session scope (only valid if this page participates in a session): the named reference remains available from the HttpSession (if any) associated with the Servlet until the HttpSession is invalidated.

See Also:
Constant Field Values

APPLICATION_SCOPE

public static final int APPLICATION_SCOPE
Application scope: named reference remains available in the ServletContext until it is reclaimed.

See Also:
Constant Field Values

PAGE

public static final String PAGE
Name used to store the Servlet in this PageContext's nametables.

See Also:
Constant Field Values

PAGECONTEXT

public static final String PAGECONTEXT
Name used to store this PageContext in it's own name table.

See Also:
Constant Field Values

REQUEST

public static final String REQUEST
Name used to store ServletRequest in PageContext name table.

See Also:
Constant Field Values

RESPONSE

public static final String RESPONSE
Name used to store ServletResponse in PageContext name table.

See Also:
Constant Field Values

CONFIG

public static final String CONFIG
Name used to store ServletConfig in PageContext name table.

See Also:
Constant Field Values

SESSION

public static final String SESSION
Name used to store HttpSession in PageContext name table.

See Also:
Constant Field Values

OUT

public static final String OUT
Name used to store current JspWriter in PageContext name table.

See Also:
Constant Field Values

APPLICATION

public static final String APPLICATION
Name used to store ServletContext in PageContext name table.

See Also:
Constant Field Values

EXCEPTION

public static final String EXCEPTION
Name used to store uncaught exception in ServletRequest attribute list and PageContext name table.

See Also:
Constant Field Values
Constructor Detail

PageContext

public PageContext()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

initialize

public abstract void initialize(Servlet servlet,
                                ServletRequest request,
                                ServletResponse response,
                                String errorPageURL,
                                boolean needsSession,
                                int bufferSize,
                                boolean autoFlush)
                         throws IOException,
                                IllegalStateException,
                                IllegalArgumentException

The initialize method is called to initialize an uninitialized PageContext so that it may be used by a JSP Implementation class to service an incoming request and response within it's _jspService() method.

This method is typically called from JspFactory.getPageContext() in order to initialize state.

This method is required to create an initial JspWriter, and associate the "out" name in page scope with this newly created object.

This method should not be used by page or tag library authors.

Parameters:
servlet - The Servlet that is associated with this PageContext
request - The currently pending request for this Servlet
response - The currently pending response for this Servlet
errorPageURL - The value of the errorpage attribute from the page directive or null
needsSession - The value of the session attribute from the page directive
bufferSize - The value of the buffer attribute from the page directive
autoFlush - The value of the autoflush attribute from the page directive
Throws:
IOException - during creation of JspWriter
IllegalStateException - if out not correctly initialized
IllegalArgumentException - If one of the given parameters is invalid

release

public abstract void release()

This method shall "reset" the internal state of a PageContext, releasing all internal references, and preparing the PageContext for potential reuse by a later invocation of initialize(). This method is typically called from JspFactory.releasePageContext().

Subclasses shall envelope this method.

This method should not be used by page or tag library authors.

getSession

public abstract HttpSession getSession()
The current value of the session object (an HttpSession).

Returns:
the HttpSession for this PageContext or null

getPage

public abstract Object getPage()
The current value of the page object (In a Servlet environment, this is an instance of javax.servlet.Servlet).

Returns:
the Page implementation class instance associated with this PageContext

getRequest

public abstract ServletRequest getRequest()
The current value of the request object (a ServletRequest).

Returns:
The ServletRequest for this PageContext

getResponse

public abstract ServletResponse getResponse()
The current value of the response object (a ServletResponse).

Returns:
the ServletResponse for this PageContext

getException

public abstract Exception getException()
The current value of the exception object (an Exception).

Returns:
any exception passed to this as an errorpage

getServletConfig

public abstract ServletConfig getServletConfig()
The ServletConfig instance.

Returns:
the ServletConfig for this PageContext

getServletContext

public abstract ServletContext getServletContext()
The ServletContext instance.

Returns:
the ServletContext for this PageContext

forward

public abstract void forward(String relativeUrlPath)
                      throws ServletException,
                             IOException

This method is used to re-direct, or "forward" the current ServletRequest and ServletResponse to another active component in the application.

If the relativeUrlPath begins with a "/" then the URL specified is calculated relative to the DOCROOT of the ServletContext for this JSP. If the path does not begin with a "/" then the URL specified is calculated relative to the URL of the request that was mapped to the calling JSP.

It is only valid to call this method from a Thread executing within a _jspService(...) method of a JSP.

Once this method has been called successfully, it is illegal for the calling Thread to attempt to modify the ServletResponse object. Any such attempt to do so, shall result in undefined behavior. Typically, callers immediately return from _jspService(...) after calling this method.

Parameters:
relativeUrlPath - specifies the relative URL path to the target resource as described above
Throws:
IllegalStateException - if ServletResponse is not in a state where a forward can be performed
ServletException - if the page that was forwarded to throws a ServletException
IOException - if an I/O error occurred while forwarding

include

public abstract void include(String relativeUrlPath)
                      throws ServletException,
                             IOException

Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread. The output of the target resources processing of the request is written directly to the ServletResponse output stream.

The current JspWriter "out" for this JSP is flushed as a side-effect of this call, prior to processing the include.

If the relativeUrlPath begins with a "/" then the URL specified is calculated relative to the DOCROOT of the ServletContext for this JSP. If the path does not begin with a "/" then the URL specified is calculated relative to the URL of the request that was mapped to the calling JSP.

It is only valid to call this method from a Thread executing within a _jspService(...) method of a JSP.

Parameters:
relativeUrlPath - specifies the relative URL path to the target resource to be included
Throws:
ServletException - if the page that was forwarded to throws a ServletException
IOException - if an I/O error occurred while forwarding

include

public abstract void include(String relativeUrlPath,
                             boolean flush)
                      throws ServletException,
                             IOException

Causes the resource specified to be processed as part of the current ServletRequest and ServletResponse being processed by the calling Thread. The output of the target resources processing of the request is written directly to the current JspWriter returned by a call to getOut().

If flush is true, The current JspWriter "out" for this JSP is flushed as a side-effect of this call, prior to processing the include. Otherwise, the JspWriter "out" is not flushed.

If the relativeUrlPath begins with a "/" then the URL specified is calculated relative to the DOCROOT of the ServletContext for this JSP. If the path does not begin with a "/" then the URL specified is calculated relative to the URL of the request that was mapped to the calling JSP.

It is only valid to call this method from a Thread executing within a _jspService(...) method of a JSP.

Parameters:
relativeUrlPath - specifies the relative URL path to the target resource to be included
flush - True if the JspWriter is to be flushed before the include, or false if not.
Throws:
ServletException - if the page that was forwarded to throws a ServletException
IOException - if an I/O error occurred while forwarding
Since:
JSP 2.0

handlePageException

public abstract void handlePageException(Exception e)
                                  throws ServletException,
                                         IOException

This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP. If forwarding is not possible (for example because the response has already been committed), an implementation dependent mechanism should be used to invoke the error page (e.g. "including" the error page instead).

If no error page is defined in the page, the exception should be rethrown so that the standard servlet error handling takes over.

A JSP implementation class shall typically clean up any local state prior to invoking this and will return immediately thereafter. It is illegal to generate any output to the client, or to modify any ServletResponse state after invoking this call.

This method is kept for backwards compatiblity reasons. Newly generated code should use PageContext.handlePageException(Throwable).

Parameters:
e - the exception to be handled
Throws:
ServletException - if an error occurs while invoking the error page
IOException - if an I/O error occurred while invoking the error page
NullPointerException - if the exception is null
See Also:
handlePageException(Throwable)

handlePageException

public abstract void handlePageException(Throwable t)
                                  throws ServletException,
                                         IOException

This method is intended to process an unhandled 'page' level exception by forwarding the exception to the specified error page for this JSP. If forwarding is not possible (for example because the response has already been committed), an implementation dependent mechanism should be used to invoke the error page (e.g. "including" the error page instead).

If no error page is defined in the page, the exception should be rethrown so that the standard servlet error handling takes over.

This method is intended to process an unhandled "page" level exception by redirecting the exception to either the specified error page for this JSP, or if none was specified, to perform some implementation dependent action.

A JSP implementation class shall typically clean up any local state prior to invoking this and will return immediately thereafter. It is illegal to generate any output to the client, or to modify any ServletResponse state after invoking this call.

Parameters:
t - the throwable to be handled
Throws:
ServletException - if an error occurs while invoking the error page
IOException - if an I/O error occurred while invoking the error page
NullPointerException - if the exception is null
See Also:
handlePageException(Exception)

pushBody

public BodyContent pushBody()
Return a new BodyContent object, save the current "out" JspWriter, and update the value of the "out" attribute in the page scope attribute namespace of the PageContext.

Returns:
the new BodyContent

getErrorData

public ErrorData getErrorData()
Provides convenient access to error information.

Returns:
an ErrorData instance containing information about the error, as obtained from the request attributes, as per the Servlet specification. If this is not an error page (that is, if the isErrorPage attribute of the page directive is not set to "true"), the information is meaningless.
Since:
JSP 2.0
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SkipPageException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp
Class SkipPageException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.servlet.jsp.JspException
                extended by  javax.servlet.jsp.SkipPageException
All Implemented Interfaces:
Serializable
public class SkipPageException
extends JspException

Exception to indicate the calling page must cease evaluation. Thrown by a simple tag handler to indicate that the remainder of the page must not be evaluated. The result is propagated back to the pagein the case where one tag invokes another (as can be the case with tag files). The effect is similar to that of a Classic Tag Handler returning Tag.SKIP_PAGE from doEndTag(). Jsp Fragments may also throw this exception. This exception should not be thrown manually in a JSP page or tag file - the behavior is undefined. The exception is intended to be thrown inside SimpleTag handlers and in JSP fragments.

Since:
JSP 2.0
See Also:
SimpleTag.doTag(),
JspFragment.invoke(java.io.Writer),
Tag.doEndTag(),
Serialized Form

Constructor Summary
SkipPageException()
Creates a SkipPageException with no message.
SkipPageException(String message)
Creates a SkipPageException with the provided message.
SkipPageException(String message, Throwable rootCause)
Creates a SkipPageException with the provided message and root cause.
SkipPageException(Throwable rootCause)
Creates a SkipPageException with the provided root cause.
Method Summary
Methods inherited from class javax.servlet.jsp.JspException
getRootCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SkipPageException

public SkipPageException()
Creates a SkipPageException with no message.

SkipPageException

public SkipPageException(String message)
Creates a SkipPageException with the provided message.

Parameters:
message - the detail message

SkipPageException

public SkipPageException(String message,
                         Throwable rootCause)
Creates a SkipPageException with the provided message and root cause.

Parameters:
message - the detail message
rootCause - the originating cause of this exception

SkipPageException

public SkipPageException(Throwable rootCause)
Creates a SkipPageException with the provided root cause.

Parameters:
rootCause - the originating cause of this exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


tagext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.servlet.jsp.tagext

Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

See:
Description

Interface Summary
BodyTag | The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.
DynamicAttributes | For a tag to declare that it accepts dynamic attributes, it must implement this interface.
IterationTag | The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.
JspIdConsumer | This interface indicates to the container that a tag handler wishes to be provided with a compiler generated ID.
JspTag | Serves as a base class for Tag and SimpleTag.
SimpleTag | Interface for defining Simple Tag Handlers.
Tag | The interface of a classic tag handler that does not want to manipulate its body.
TryCatchFinally | The auxiliary interface of a Tag, IterationTag or BodyTag tag handler that wants additional hooks for managing resources.

Class Summary
BodyContent | An encapsulation of the evaluation of the body of an action so it is available to a tag handler.
BodyTagSupport | A base class for defining tag handlers implementing BodyTag.
FunctionInfo | Information for a function in a Tag Library.
JspFragment | Encapsulates a portion of JSP code in an object that can be invoked as many times as needed.
PageData | Translation-time information on a JSP page.
SimpleTagSupport | A base class for defining tag handlers implementing SimpleTag.
TagAdapter | Wraps any SimpleTag and exposes it using a Tag interface.
TagAttributeInfo | Information on the attributes of a Tag, available at translation time.
TagData | The (translation-time only) attribute/value information for a tag instance.
TagExtraInfo | Optional class provided by the tag library author to describe additional translation-time information not described in the TLD.
TagFileInfo | Tag information for a tag file in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
TagInfo | Tag information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
TagLibraryInfo | Translation-time information associated with a taglib directive, and its underlying TLD file.
TagLibraryValidator | Translation-time validator class for a JSP page.
TagSupport | A base class for defining new tag handlers implementing Tag.
TagVariableInfo | Variable information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.
ValidationMessage | A validation message from either TagLibraryValidator or TagExtraInfo.
VariableInfo | Information on the scripting variables that are created/modified by a tag (at run-time).

Package javax.servlet.jsp.tagext Description

Classes and interfaces for the definition of JavaServer Pages Tag Libraries.

Custom actions can be used by JSP authors and authoring tools to simplify writing JSP pages. A custom action can be either an empty or a non-empty action.

An empty tag has no body. There are two equivalent syntaxes, one with separate start and end tags, and one where the start and end tags are combined. The two following examples are identical:

<x:foo att="myObject"></foo>
<x:foo att="myObject"/>

A non-empty tag has a start tag, a body, and an end tag. A prototypical example is of the form:

<x:foo att="myObject" >
  BODY
</x:foo/>

The JavaServer Pages(tm) (JSP) specification provides a portable mechanism for the description of tag libraries.

A JSP tag library contains

  • A Tag Library Descriptor
  • A number of Tag Files or Tag handler classes defining request-time behavior
  • Additional classes and resources used at runtime
  • Possibly some additional classes to provide extra translation information

This API is described in the following sections:

  1. Classic Tag Handlers
  2. Tag Handlers that want to access their Body Content
  3. Dynamic Attributes
  4. Annotated Tag Handler Management Example
  5. Cooperating Actions
  6. Simple Tag Handlers
  7. JSP Fragments
  8. Example Simple Tag Handler Scenario
  9. Translation-time Classes

1. Classic Tag Handlers

 This section introduces the notion of a tag handler and describes the classic types of tag handler.

JSP 2.0 introduces a new type of Tag Handler called a Simple Tag Handler, which is described in a later section. The protocol for Simple Tag handlers is much more straightforward.

Tag Handler

A tag handler is a run-time, container-managed object that evaluates custom actions during the execution of a JSP page. A tag handler supports a protocol that allows the JSP container to provide good integration of the server-side actions within a JSP page.

A tag handler is created initially using a zero argument constructor on its corresponding class; the method java.beans.Beans.instantiate() is not used.

A tag handler has some properties that are exposed to the page as attributes on an action; these properties are managed by the JSP container (via generated code). The setter methods used to set the properties are discovered using the JavaBeans introspector machinery.

The protocol supported by a tag handler provides for passing of parameters, the evaluation and reevaluation of the body of the action, and for getting access to objects and other tag handlers in the JSP page.

A tag handler instance is responsible for processing one request at a time. It is the responsability of the JSP container to enforce this.

Additional translation time information associated with the action indicates the name of any scripting variables it may introduce, their types and their scope. At specific moments, the JSP container will automatically synchronize the PageContext information with variables in the scripting language so they can be made available directly through the scripting elements.

Properties

A tag handler has some properties. All tag handlers have a pageContext property for the JSP page where the tag is located, and a parent property for the tag handler to the closest enclosing action. Specific tag handler classes may have additional properties.

All attributes of a custom action must be JavaBeans component properties, although some properties may not be exposed as attributes. The attributes that are visible to the JSP translator are exactly those listed in the Tag Library Descriptor (TLD).

All properties of a tag handler instance exposed as attributes will be initialized by the container using the appropriate setter methods before the instance can be used to perform the action methods. It is the responsibility of the JSP container to invoke the appropriate setter methods to initialize these properties. It is the responsability of user code, be it scriptlets, JavaBeans code, or code inside custom tags, to not invoke these setter methods, as doing otherwise would interfere with the container knowledge.

The setter methods that should be used when assigning a value to an attribute of a custom action are determined by using the JavaBeans introspector on the tag handler class, then use the setter method associated with the property that has the same name as the attribute in question. An implication (unclear in the JavaBeans specification) is that there is only one setter per property.

Unspecified attributes/properties should not be set (using a setter method).

Once properly set, all properties are expected to be persistent, so that if the JSP container ascertains that a property has already been set on a given tag handler instance, it must not set it again.

The JSP container may reuse classic tag handler instances for multiple occurrences of the corresponding custom action, in the same page or in different pages, but only if the same set of attributes are used for all occurrences. If a tag handler is used for more than one occurence, the container must reset all attributes where the values differ between the custom action occurrences. Attributes with the same value in all occurrences must not be reset. If an attribute value is set as a request-time attribute value (using a scripting or an EL expression), the container must reset the attribute between all reuses of the tag handler instance.

User code can access property information and access and modify tag handler internal state starting with the first action method (doStartTag) up until the last action method (doEndTag or doFinally for tag handlers implementing TryCatchFinally).

Tag Handler as a Container-Managed Object

Since a tag handler is a container managed object, the container needs to maintain its references; specifically, user code should not keep references to a tag handler except between the start of the first action method (doStartTag()) and the end of the last action method (doEndTag() or doFinally() for those tags that implement TryCatchFinally).

The restrictions on references to tag handler objects and on modifying attribute properties gives the JSP container substantial freedom in effectively managing tag handler objects to achieve different goals. For example, a container may implementing different pooling strategies to minimize creation cost, or may hoist setting of properties to reduce cost when a tag handler is inside another iterative tag.

Conversions

A tag handler implements an action; the JSP container must follow the type conversions described in Section 2.13.2 when assigning values to the attributes of an action.

Empty and Non-Empty Actions

An empty action has no body; it may use one of two syntaxes: either <foo/> or <foo></foo>. Since empty actions have no body the methods related to body manipulation are not invoked. There is a mechanism in the Tag Library Descriptor to indicate that a tag can only be used to write empty actions; when used, non-empty actions using that tag will produce a translation error.

A non-empty action has a body.

The Tag Interface

A Tag handler that does not want to process its body can implement just the Tag interface. A tag handler may not want to process its body because it is an empty tag or because the body is just to be "passed through".

The Tag interface includes methods to provide page context information to the Tag Handler instance, methods to handle the life-cycle of tag handlers, and two main methods for performing actions on a tag: doStartTag() and doEndTag(). The method doStartTag() is invoked when encountering the start tag and its return value indicates whether the body (if there is any) should be skipped, or evaluated and passed through to the current response stream. The method doEndTag() is invoked when encountering the end tag; its return value indicates whether the rest of the page should continue to be evaluated or not.

If an exception is encountered during the evaluation of the body of a tag, its doEndTag method will not be evaluated. See the TryCatchFinally tag for methods that are guaranteed to be evaluated.

The IterationTag Interface

The IterationTag interface is used to repeatedly reevaluate the body of a custom action. The interface has one method: doAfterBody() which is invoked after each evaluation of the body to determine whether to reevaluate or not.

Reevaluation is requested with the value 2, which in JSP 1.1 is defined to be BodyTag.EVAL_BODY_TAG. That constant value is still kept in JSP 1.2 (for full backwards compatibility) but, to improve clarity, a new name is also available: IterationTag.EVAL_BODY_AGAIN. To stop iterating, the returned value should be 0, which is Tag.SKIP_BODY.

The JspIdConsumer Interface

This interface indicates to the container that a tag handler wishes to be provided with a compiler generated ID that is unique within the page.

The TagSupport Base Class

The TagSupport class is a base class that can be used when implementing the Tag or IterationTag interfaces.

2. Tag Handlers that want Access to their Body Content

The evaluation of a body is delivered into a BodyContent object. This is then made available to tag handlers that implement the BodyTag interface. The BodyTagSupport class provides a useful base class to simplify writing these handlers.

If a Tag handler wants to have access to the content of its body then it must implement the BodyTag interface. This interface extends IterationTag, provides two additional methods setBodyContent(BodyContent) and doInitBody() and refers to an object of type BodyContent.

A BodyContent is a subclass of JspWriter that has a few additional methods to convert its contents into a String, insert the contents into another JspWriter, to get a Reader into its contents, and to clear the contents. Its semantics also assure that buffer size will never be exceeded.

The JSP page implementation will create a BodyContent if the doStartTag() method returns a EVAL_BODY_BUFFERED. This object will be passed to doInitBody(); then the body of the tag will be evaluated, and during that evaluation out will be bound to the BodyContent just passed to the BodyTag handler. Then doAfterBody() will be evaluated. If that method returns SKIP_BODY, no more evaluations of the body will be done; if the method returns EVAL_BODY_AGAIN, then the body will be evaluated, and doAfterBody() will be invoked again.

The content of a BodyContent instance remains available until after the invocation of its associated doEndTag() method.

A common use of the BodyContent is to extract its contents into a String and then use the String as a value for some operation. Another common use is to take its contents and push it into the out Stream that was valid when the start tag was encountered (that is available from the PageContext object passed to the handler in setPageContext).

3. Dynamic Attributes

Any tag handler can optionally extend the DynamicAttributes interface to indicate that it supports dynamic attributes. In addition to implementing the DynamicAttributes interface, tag handlers that support dynamic attributes must declare that they do so in the Tag Library Descriptor.

The TLD is what ultimately determines whether a tag handler accepts dynamic attributes or not. If a tag handler declares that it supports dynamic attributes in the TLD but it does not implement the DynamicAttributes interface, the tag handler must be considered invalid by the container.

If the dynamic-attributes element for a tag being invoked contains the value "true", the following requirements apply:

  • For each attribute specified in the tag invocation that does not have a corresponding attribute element in the TLD for this tag, a call must be made to setDynamicAttribute(), passing in the namespace of the attribute (or null if the attribute does not have a namespace or prefix), the name of the attribute without the namespace prefix, and the final value of the attribute.
  • Dynamic attributes must be considered to accept request-time expression values as well as deferred expressions.
  • Dynamic attributes must be treated as though they were of type java.lang.Object. If a ValueExpression is passed as a dynamic attribute, the default value for the expected return type is assumed to be java.lang.Object. If a MethodExpression is passed as a dynamic attribute, the default method signature is assumed to be void method().
  • Note that passing a String literal as a dynamic attribute will never be considered as a deferred expression.
  • The JSP container must recognize dynamic attributes that are passed to the tag handler using the <jsp:attribute> standard action.
  • If the setDynamicAttribute() method throws JspException, the doStartTag() or doTag() method is not invoked for this tag, and the exception must be treated in the same manner as if it came from a regular attribute setter method.
  • For a JSP document in either standard or XML syntax, If a dynamic attribute has a prefix that doesn't map to a namespace, a translation error must occur. In standard syntax, only namespaces defined using taglib directives are recognized.

In the following example, assume attributes a and b are declared using the attribute element in the TLD, attributes d1 and d2 are not declared, and the dynamic-attributes element is set to "true". The attributes are set using the calls:

  • setA( "1" ),
  • setDynamicAttribute( null, "d1", "2" ),
  • setDynamicAttribute( "http://www.foo.com/jsp/taglib/mytag.tld", "d2", "3" ),
  • setB( "4" ),
  • setDynamicAttribute( null, "d3", "5" ), and
  • setDynamicAttribute( "http://www.foo.com/jsp/taglib/mytag.tld", "d4", "6" ).
<jsp:root xmlns:mytag="http://www.foo.com/jsp/taglib/mytag.tld" version="2.0">
  <mytag:invokeDynamic a="1" d1="2" mytag:d2="3">
    <jsp:attribute name="b">4</jsp:attribute>
    <jsp:attribute name="d3">5</jsp:attribute>
    <jsp:attribute name="mytag:d4">6</jsp:attribute>
  </mytag:invokeDynamic>
</jsp:root>

4. Annotated Tag Handler Management Example

 Below is a somewhat complete example of the way one JSP container could choose to do some tag handler management. There are many other strategies that could be followed, with different pay offs.

In this example, we are assuming that x:iterate is an iterative tag, while x:doit and x:foobar are simple tag. We will also assume that x:iterate and x:foobar implement the TryCatchFinally interface, while x:doit does not.

<x:iterate src="foo">
  <x:doit att1="one" att2="<%= 1 + 1 %>" />
  <x:foobar />
  <x:doit att1="one" att2="<%= 2 + 2 %>" />
</x:iterate>
<x:doit att1="one" att2="<%= 3 + 3 %>" />

The particular code shown below assumes there is some pool of tag handlers that are managed (details not described, although pool managing is simpler when there are no optional attributes), and attemps to reuse tag handlers if possible. The code also "hoists" setting of properties to reduce the cost when appropriate, e.g. inside an iteration.

boolean b1, b2;
IterationTag i; // for x:iterate
Tag d; // for x:doit
Tag d; // for x:foobar

page: // label to end of page...

// initialize iteration tag
i = get tag from pool or new();

i.setPageContext(pc);
i.setParent(null);
i.setSrc("foo");

// x:iterate implements TryCatchFinally
try {
    if ((b1 = i.doStartTag()) == EVAL_BODY_INCLUDE) {

        // initialize doit tag
        // code has been moved out of the loop for show
        d = get tag from pool or new();

        d.setPageContext(pc);
        d.setParent(i);
        d.setAtt1("one");

    loop:
        while (1) do {
            // I'm ignoring newlines...

            // two invocations, fused together

            // first invocation of x:doit
            d.setAtt2(1+1);
            if ((b2 = d.doStartTag()) == EVAL_BODY_INCLUDE) {
                // nothing
            } else if (b2 != SKIP_BODY) {
                // Q? protocol error ...
            }
            if ((b2 = d.doEndTag()) == SKIP_PAGE) {
                break page;  // be done with it.
            } else if (b2 != EVAL_PAGE) {
                // Q? protocol error
            }

            // x:foobar invocation
            f = get tag from pool or new();
            f.setPageContext(pc);
            f.setParent(i);

            // x:foobar implements TryCatchFinally
            try {

                if ((b2 = f.doStartTag()) == EVAL_BODY_INCLUDE) {
                    // nothing
                } else if (b2 != SKIP_BODY) {
                    // Q? protocol error
                }
                if ((b2 = f.doEndTag()) == SKIP_PAGE) {
                    break page;  // be done with it.
                } else if (b2 != EVAL_PAGE) {
                    // Q? protocol error
                }
            } catch (Throwable t) {
                f.doCatch(t); // caught, may been rethrown!
            } finally {
                f.doFinally();
            }

            // put f back to pool

            // second invocation of x:doit
            d.setAtt2(2+2);
            if ((b2 = d.doStartTag()) == EVAL_BODY_INCLUDE) {
                // nothing
            } else if (b2 != SKIP_BODY) {
                // Q? protocol error
            }
            if ((b2 = d.doEndTag()) == SKIP_PAGE) {
                break page;  // be done with it.
            } else if (b2 != EVAL_PAGE) {
                // Q? protocol error
            }

            if ((b2 = i.doAfterBody()) == EVAL_BODY_AGAIN) {
                break loop;
            } else if (b2 != SKIP_BODY) {
                // Q? protocol error
            }
        // loop
        }

    } else if (b1 != SKIP_BODY) {
        // Q? protocol error
    }

    // tail end of the IteratorTag ...

    if ((b1 = i.doEndTag()) == SKIP_PAGE) {
        break page;   // be done with it.
    } else if (b1 != EVAL_PAGE) {
        // Q? protocol error
    }

    // third invocation
    // this tag handler could be reused from the previous ones.
    d = get tag from pool or new();

    d.setPageContext(pc);
    d.setParent(null);
    d.setAtt1("one");
    d.setAtt2(3+3);

    if ((b1 = d.doStartTag()) == EVAL_BODY_INCLUDE) {
        // nothing
    } else if (b1 != SKIP_BODY) {
        // Q? protocol error
    }
    if ((b1 = d.doEndTag()) == SKIP_PAGE) {
        break page;  // be done with it.
    } else if (b1 != EVAL_PAGE) {
        // Q? protocol error
    }

} catch (Throwable t) {
    i.doCatch(t); // caught, may been rethrown!
} finally {
    i.doFinally();
}

5. Cooperating Actions

 Actions can cooperate with other actions and with scripting code in a number of ways.

PageContext

Often two actions in a JSP page will want to cooperate, perhaps by one action creating some server-side object that needs to be accessed by another. One mechanism for doing this is by giving the object a name within the JSP page; the first action will create the object and associate the name to it while the second action will use the name to retrieve the object.

For example, in the following JSP segment the foo action might create a server-side object and give it the name "myObject". Then the bar action might access that server-side object and take some action.

<x:foo id="myObject" />
<x:bar ref="myObjet" />

In a JSP implementation, the mapping "name"->value is kept by the implicit object pageContext. This object is passed around through the Tag handler instances so it can be used to communicate information: all it is needed is to know the name under which the information is stored into the pageContext.

The Runtime Stack

An alternative to explicit communication of information through a named object is implicit coordination based on syntactic scoping.

For example, in the following JSP segment the foo action might create a server-side object; later the nested bar action might access that server-side object. The object is not named within the pageContext: it is found because the specific foo element is the closest enclosing instance of a known element type.

<foo>
   <bar/>
</foo>

This functionality is supported through the TagSupport.findAncestorWithClass(Tag, Class), which uses a reference to parent tag kept by each Tag instance, which effectively provides a run-time execution stack.

6. Simple Tag Handlers

This section presents the API to implement Simple Tag Handlers. Simple Tag Handlers present a much simpler invocation protocol than do Classic Tag Handlers.

The Tag Library Descriptor maps tag library declarations to their physical underlying implementations. A Simple Tag Handler is represented in Java by a class which implements the SimpleTag interface.

Unlike classic tag handlers, the SimpleTag interface does not extend Tag. Instead of supporting doStartTag() and doEndTag(), the SimpleTag interface provides a simple doTag() method, which is called once and only once for any given tag invocation. All tag logic, iteration, body evaluations, etc. are to be performed in this single method. Thus, simple tag handlers have the equivalent power of BodyTag, but with a much simpler lifecycle and interface.

To support body content, the setJspBody() method is provided. The container invokes the setJspBody() method with a JspFragment object encapsulating the body of the tag. The tag handler implementation can call invoke() on that fragment to evaluate the body. The SimpleTagSupport convenience class provides getJspBody() and other useful methods to make this even easier.

Lifecycle of Simple Tag Handlers

This section describes the lifecycle of simple tag handlers, from creation to invocation. For all semantics left unspecified by this section, the semantics default to that of a classic tag handler.

When a simple tag handler is invoked, the following steps occur (in order):

  1. Simple tag handlers are created initially using a zero argument constructor on the corresponding implementation class. Unlike classic tag handlers, this instance must never be pooled by the container. A new instance must be created for each tag invocation.
  2. The setJspContext() and setParent() methods are invoked on the tag handler. The setParent() method need not be called if the value being passed in is null. In the case of tag files, a JspContext wrapper is created so that the tag file can appear to have its own page scope. Calling getJspContext() must return the wrapped JspContext.
  3. The attributes specified as XML element attributes (if any) are evaluated next, in the order in which they are declared, according to the following rules (referred to as "evaluating an XML element attribute" below). The appropriate bean property setter is invoked for each. If no setter is defined for the specified attribute but the tag accepts dynamic attributes, the setDynamicAttribute() method is invoked as the setter.
    • If the attribute is a scripting expression (e.g. "<%= 1+1 %>" in JSP syntax, or "%= 1+1 %" in XML syntax), the expression is evaluated, and the result is converted as per the rules in "Type Conversions", and passed to the setter.
    • Otherwise, if the attribute contains any Expression Language expressions (e.g. "Hello ${name}"), the expression is evaluated, and the result is converted and passed to the setter.
    • Otherwise, the attribute value is taken verbatim, converted, and passed to the setter.
  4. The value for each <jsp:attribute> element is evaluated, and the corresponding bean property setter methods are invoked for each, in the order in which they appear in the body of the tag. If no setter is defined for the specified attribute but the tag accepts dynamic attributes, the setDynamicAttribute() method is invoked as the setter.
    • Otherwise, if the attribute is not of type JspFragment, the container evaluates the body of the <jsp:attribute> element. This evaluation can be done in a container-specific manner. Container implementors should note that in the process of evaluating this body, other custom actions may be invoked.
    • Otherwise, if the attribute is of type JspFragment, an instance of a JspFragment object is created and passed in.
  5. The value for the body of the tag is determined, and if a body exists the setJspBody() method is called on the tag handler.
    • If the tag is declared to have a body-content of "empty" or no body or an empty body is passed for this invocation, then setJspBody() is not called.
    • Otherwise, the body of the tag is either the body of the <jsp:body> element, or the body of the custom action invocation if no <jsp:body> or <jsp:attribute> elements are present. In this case, an instance of a JspFragment object is created as per the lifecycle described in the JSP Fragments section and it is passed to the setter. If the tag is declared to have a body-content of "tagdependent" the JspFragment must echo the body's contents verbatim. Otherwise, if the tag is declared to have a body-content of type "scriptless", the JspFragment must evaluate the body's contents as a JSP scriptless body.
  6. The doTag() method is invoked.
  7. The implementation of doTag() performs its function, potentially calling other tag handlers (if the tag handler is implemented as a tag file) and invoking fragments.
  8. The doTag() method returns, and the tag handler instance is discarded. If SkipPageException is thrown, the rest of the page is not evaluated and the request is completed. If this request was forwarded or included from another page (or Servlet), only the current page evaluation stops.
  9. For each tag scripting variable declared with scopes AT_BEGIN or AT_END, the appropriate scripting variables and scoped attributes are declared, as with classic tag handlers.

7. JSP Fragments

JSP Fragments are represented in Java by an instance of the javax.servlet.jsp.tagext.JspFragment abstract class. Pieces of JSP code are translated into JSP fragments in the context of a tag invocation. JSP Fragments are created when providing the body of a <jsp:attribute> standard action for an attribute that is defined as a fragment or of type JspFragment, or when providing the body of a tag invocation handled by a Simple Tag Handler.

Before being passed to a tag handler, the JspFragment instance is associated with the JspContext of the surrounding page in an implementation-dependent manner. In addition, it is associated with the parent Tag or SimpleTag instance for collaboration purposes, so that when a custom action is invoked from within the fragment, setParent() can be called with the appropriate value. The fragment implementation must keep these associations for the duration of the tag invocation in which it is used.

The invoke() method executes the body and directs all output to either the passed in java.io.Writer or the JspWriter returned by the getOut() method of the JspContext associated with the fragment.

The implementation of each method can optionally throw a JspException, which must be handled by the invoker. Note that tag library developers and page authors should not generate JspFragment implementations manually.

The following sections specify the creation and invocation lifecycles of a JSP Fragment in detail, from the JSP Container's perspective.

Creation of a JSP Fragment

When a JSP fragment is created, the following steps occur (in order):

  1. An instance of a class implementing the JspFragment abstract class is obtained (may either be created or can optionally be cached) each time the tag is invoked. This instance must be configured to produce the contents of the body of the fragment when invoked. If the fragment is defining the body of a <jsp:attribute>, the fragment must evaluate the body each time it is invoked. Otherwise, if the fragment is defining the body of a simple tag, the behavior of the fragment when invoked varies depending on the body-content declared for the tag:
    • If the body-content is "tagdependent", then the fragment must echo the contents of the body verbatim when invoked.
    • If the body-content is "scriptless", then the fragment must evaluate the body each time it is invoked.
  2. The JspFragment instance is passed a reference to the current JspContext. Whenever the fragment invokes a tag handler, it must use this value when calling setJspContext().
  3. The JspFragment instance is associated with an instance of the tag handler of the nearest enclosing tag invocation, or with null if there is no enclosing tag. Whenever the fragment invokes a tag handler, the fragment must use this value when calling setParent().

Invocation of a JSP Fragment

After a JSP fragment is created, it is passed to a tag handler for later invocation. JSP fragments can be invoked either programmatically from a tag handler written in Java, or from a tag file using the <jsp:invoke> or <jsp:doBody> standard action.

JSP fragments are passed to tag handlers using a bean property of type JspFragment. These fragments can be invoked by calling the invoke() method in the JspFragment abstract class. Note that it is legal (and possible) for a fragment to recursively invoke itself, indirectly.

The following steps are followed when invoking a JSP fragment:

  1. The tag handler invoking the fragment is responsible for setting the values of all declared AT_BEGIN and NESTED variables in the JspContext of the calling page/tag, before invoking the fragment. Note that this is not always the same as the JspContext of the fragment being invoked, as fragments can be passed from one tag to another. In the case of tag files, for each variable declared in scope AT_BEGIN or NESTED, if a page scoped attribute exists with the provided name in the tag file, the JSP container must generate code to create/update the page scoped attribute of the provided name in the calling page/tag. If a page scoped attribute with the provided name does not exist in the calling page, and a page scoped attribute of the provided name is present in the tag file, the scoped attribute is removed from the tag file's page scope. See the chapter on Tag Files for details.
  2. If <jsp:invoke> or <jsp:doBody> is being used to invoke a fragment, if the var attribute is specified, a custom java.io.Writer is created that can expose the result of the invocation as a java.lang.String object. If the varReader attribute is specified, a custom java.io.Writer object is created that can expose the resulting invocation as a java.io.Reader object.
  3. The invoke() method of the fragment is invoked, passing in an optional Writer.
  4. Before executing the body of the fragment, if a non-null value is provided for the writer parameter, then the value of JspContext.getOut() and the implicit "out" object must be updated to send output to that writer. To accomplish this, the container must call pushBody( writer ) on the current JspContext, where writer is the instance of java.io.Writer passed to the fragment upon invocation.
  5. The body of the fragment is then evaluated by executing the generated code. The body of the fragment may execute other standard or custom actions. If a classic Custom Tag Handler is invoked and returns SKIP_PAGE, or if a Simple Tag Handler is invoked and throws SkipPageException, the JspFragment must throw SkipPageException to signal that the calling page is to be skipped.
  6. Once the fragment has completed its evaluation, even if an exception is thrown, the value of JspContext.getOut() must be restored via a call to popBody() on the current JspContext.
  7. The fragment returns from invoke()
  8. If <jsp:invoke> or <jsp:doBody> is being used to invoke a fragment, if the var or varReader attribute is specified, a scoped variable with a name equal to the value of the var or varReader attribute is created (or modified) in the page scope, and the value is set to a java.lang.String or java.io.Reader respectively that can produce the results of the fragment invocation.
  9. The invoke() method can be called again, zero or more times. When the tag invocation defining the fragment is complete, the tag must discard the fragment instance since it might be reused by the container.

8. Example Simple Tag Handler Scenario

The following non-normative example is intended to help solidify some of the concepts relating to Tag Files, JSP Fragments and Simple Tag Handlers. In the first section, two sample input files are presented, a JSP (my.jsp), and a simple tag handler implemented using a tag file (simpletag.tag). One possible output of the translation process is presented in the second section.

Although short, the example shows all concepts, including the variable directive. In practice most uses of tags will be much simpler, but probably longer.

The sample generated code is annotated with comments that point to lifecycle steps presented in various sections. The notation is as follows:

  • "Step T.x" = Annotated step x from "Lifecycle of Simple Tag Handlers" earlier in this Chapter.
  • "Step C.x" = Annotated step x from "Creation of a JSP Fragment" earlier in this Chapter.
  • "Step F.x" = Annotated step x from "Invocation of a JSP Fragment" earlier in this Chapter.

Sample Source Files

This section presents the sample source files in this scenario, from which the output files are generated.

Original JSP (my.jsp)

<%@ taglib prefix="my" tagdir="/WEB-INF/tags" %>

<my:simpleTag x="10">
    <jsp:attribute name="y">20</jsp:attribute>
    <jsp:attribute name="nonfragment">
        Nonfragment Template Text
    </jsp:attribute>
    <jsp:attribute name="frag">
        Fragment Template Text ${var1}
    </jsp:attribute>
    <jsp:body>
        Body of tag that defines an AT_BEGIN
        scripting variable ${var1}.
    </jsp:body>
</my:simpleTag>

Original Tag File (/WEB-INF/tags/simpletag.tag)

<%-- /WEB-INF/tags/simpletag.tag --%>
<%@ attribute name="x" %>
<%@ attribute name="y" %>
<%@ attribute name="nonfragment" %>
<%@ attribute name="frag" fragment="true" %>
<%@ variable name-given="var1" scope="AT_BEGIN" %>
<%@ taglib prefix="c" uri="http://java.sun.com/jsp/jstl/core" %>

Some template text.
<c:set var="var1" value="${x+y}"/>
<jsp:invoke fragment="frag" varReader="var1"/>

Invoke the body:
<jsp:doBody/>

Sample Generated Files

This section presents sample output files that might be generated by a JSP compiler, from the source files presented in the previous section.

Helper class for JspFragment (JspFragmentBase.java)

public abstract class JspFragmentBase
    implements javax.servlet.jsp.tagext.JspFragment
{
    protected javax.servlet.jsp.JspContext jspContext;
    protected javax.servlet.jsp.tagext.JspTag parentTag;
    public void JspFragmentBase(
        javax.servlet.jsp.JspContext jspContext,
        javax.servlet.jsp.tagext.JspTag parentTag )
    {
        this.jspContext = jspContext;
        this.parentTag = parentTag;
    }
}

Relevant Portion of JSP Service Method

// Step T.1 - Initial creation
MySimpleTag _jsp_mySimpleTag = new MySimpleTag();
// Step T.2 - Set page context and parent (since parent is null,
// no need to call setParent() in this case)
_jsp_mySimpleTag.setJspContext( jspContext );
// Step T.3 - XML element attributes evaluated and set
_jsp.mySimpleTag.setX( "10" );
// Step T.4 - <jsp:attribute> elements evaluated and set
//   - parameter y
// (using PageContext.pushBody() is one possible implementation -
// one limitation is that this code will only work for Servlet-based code).
out = ((PageContext)jspContext).pushBody();
out.write( "20" );
_jsp_mySimpleTag.setY(
    ((javax.servlet.jsp.tagext.BodyContent)out).getString() );
out = jspContext.popBody();
//   - parameter nonfragment
// (using PageContext.pushBody() is one possible implementation -
// one limitation is that this code will only work for Servlet-based code).
// Note that trim is enabled by default, else we would have "\n    Non..."
out = ((PageContext)jspContext).pushBody();
out.write( "Nonfragment Template Text" );
_jsp_mySimpleTag.setNonfragment(
    ((javax.servlet.jsp.tagext.BodyContent)out).getString() );
out = jspContext.popBody();
//   - parameter frag
_jsp_mySimpleTag.setFrag(
    // Step C.1 - New instance of fragment created
    // Step C.2 - Store jspContext
    // Step C.3 - Association with nearest enclosing Tag instance
    new JspFragmentBase( jspContext, _jsp_mySimpleTag ) {
        public void invoke( java.io.Writer writer ) {
            javax.servlet.jsp.JspWriter out;
            // Step F.1-F.3 done in tag file (see following example)
            // Step F.4 - If writer provided, push body:
            if( out == null ) {
                out = this.jspContext.getOut();
            }
            else {
                out = this.jspContext.pushBody( writer );
            }
            // Step F.5 - Evaluate body of fragment:
            try {
                out.write( "Fragment Template Text " );
                out.write( jspContext.getExpressionEvaluator().evaluate(
                    "${var1}",
                    java.lang.String.class,
                    vResolver, fMapper, "my" ) );
            }
            finally {
                // Step F.6 - Restore value of JspContext.getOut()
                if( writer != null ) {
                    this.jspContext.popBody();
                }
            }

            // Step F.7-F.9 done in tag file (see following example)
        }
    } );
// Step T.5 - Determine and set body of the tag
// - body of tag
_jsp_mySimpleTag.setJspBody(
    // Step C.1 - New instance of fragment created
    // Step C.2 - Store jspContext
    // Step C.3 - Association with nearest enclosing Tag instance
    new JspFragmentBase( jspContext, _jsp_mySimpleTag ) {
        public void invoke( java.io.Writer writer ) {
            javax.servlet.jsp.JspWriter out;
            // Step F.1-F.3 done in tag file (see following example)
            // Step F.4 - If writer provided, push body:
            if( writer == null ) {
                out = this.jspContext.getOut();
            }
            else {
                out = this.jspContext.pushBody( writer );
            }
            // Step F.5 - Evaluate body of fragment:
            try {
                out.write(
                    "Body of tag that defines an AT_BEGIN\n" +
                    " scripting variable " );
                out.write( jspContext.getExpressionEvaluator().evaluate(
                    "${var1}",
                    java.lang.String.class,
                    vResolver, fMapper, "my" ) );
                out.write( ".\n" );
            }
            finally {
                // Step F.6 - Restore value of JspContext.getOut()
                if( writer != null ) {
                    this.jspContext.popBody();
                }
            }

            // Step F.7-F.9 done in tag file (see following example)
        }
    } );
// Step T.6 - Inovke doTag
// Step T.7 occurs in the tag file (see following example)
// Step T.8 - doTag returns - page will catch SkipPageException.
_jsp_mySimpleTag.doTag();
// Step T.9 - Declare AT_BEGIN and AT_END scripting variables
String var1 = (String)jspContext.findAttribute( "var1" );

Generated Simple Tag Handler (MySimpleTag.java)

public class MySimpleTag
    extends javax.servlet.jsp.tagext.SimpleTagSupport
{
    // Attributes:
    private String x;
    private String y;
    private String nonfragment;
    private javax.servlet.jsp.tagext.JspFragment frag;
    // Setters and getters for attributes:
    public void setX( Stirng x ) {
        this.x = x;
    }
    public String getX() {
        return this.x;
    }
    public void setY( String y ) {
        this.y = y;
    }
    public String getY() {
        return this.y;
    }
    public void setNonfragment( String nonfragment ) {
        this.nonfragment = nonfragment;
    }
    public String getNonfragment() {
        return this.nonfragment;
    }
    public void setFrag( javax.servlet.jsp.tagext.JspFragment frag ) {
        this.frag = frag;
    }
    public javax.servlet.jsp.tagext.JspFragment getFrag() {
        return this.frag;
    }

    protected JspContext jspContext;
    public void setJspContext( JspContext ctx ) {
        super.setJspContext( ctx );
        // Step T.2 - A JspContext wrapper is created.
        // (Implementation of wrapper not shown).
        this.jspContext = new utils.JspContextWrapper( ctx );
    }
    public JspContext getJspContext() {
        // Step T.2 - Calling getJspContext() must return the
        // wrapped JspContext.
        return this.jspContext;
    }

    public void doTag() throws JspException {
        java.lang.Object jspValue;
        JspContext jspContext = getJspContext();
        JspContext _jsp_parentContext =
            SimpleTagSupport.this.getJspContext();
        try {
            javax.servlet.jsp.JspWriter out = jspContext.getOut();

            // Create page-scope attributes for each tag attribute:
            this.jspContext.setAttribute( "x", getX() );
            this.jspContext.setAttribute( "y", getY() );
            this.jspContext.setAttribute( "nonfragment", getNonfragment() );
            this.jspContext.setAttribute( "frag", getFrag() );

            // Synchronize AT_BEGIN variables from calling page
            if( (jspValue = _jsp_parentContext.getAttribute(
                    "var1" )) != null )
            {
                jspContext.setAttribute( "var1", value );
            }
            else {
                jspContext.removeAttribute( "var1",
                    JspContext.PAGE_SCOPE );
            }

            // Tag template text:
            out.write( "\n\n\n\n\n\n\n\nSome template text.\n" );

            // Invoke c:set - recognized tag handler from JSTL:
            jspContext.setAttribute( "var1",
                jspContext.getExpressionEvaluator().evaluate(
                    "${x+y}",
                    java.lang.String.class,
                    jspContext,
                    prefixMap, functionMap, "my" ) );

            // Invoke the "frag" fragment:
            // Step F.1 - Set values of AT_BEGIN and NESTED variables
            //     in calling page context.
            if( (jspValue = jspContext.getAttribute( "var1" )) != null ) {
                _jsp_parentContext.setAttribute( "var1", value );
            }
            else {
                _jsp_parentContext.removeAttribute( "var1",
                    JspContext.PAGE_SCOPE );
            }

            // Step F.2 - varReader is specified, generate a writer.
            java.io.Writer _jsp_sout = new java.io.StringWriter();

            // Step F.3 - Invoke fragment with writer
            getFrag().invoke( _jsp_sout );

            // Step F.4 - F.6 occur in the fragment (see above)
            // Step F.7 - fragment returns

            // Step F.8 - varReader specified, so save to var
            jspContext.setAttribute(
                "var1", new StringReader( _jsp_sout.toString() ) );

            // Step F.9 - Done!

            out.write( "\n\nInvoke the body:\n" );

            // Invoke the body of the tag:
            // Step F.1 - Set values of AT_BEGIN and NESTED variables
            //     in calling page context.
            if( (jspValue = jspContext.getAttribute( "var1" )) != null ) {
                _jsp_parentContext.setAttribute( "var1", value );
            }
            else {
                _jsp_parentContext.removeAttribute( "var1",
                    JspContext.PAGE_SCOPE);
            }

            // Step F.2 - varReader is not specified - does not apply.

            try {
                // Step F.3 - Invoke body, passing optional writer
                getJspBody().invoke( null );
            }
            finally {
                // Steps F.4 - F.6 occur in the fragment (see above)
                // Step F.7 - fragment returns
            }

            // Step F.8 does not apply.
            // Step F.9 - Done!
        }
        finally {
            // Tag handlers generate code to synchronize AT_BEGIN with
            // calling page, regardless of whether an error occurs.
            if( (jspValue = jspContext.getAttribute( "var1" )) != null ) {
                _jsp_parentContext.setAttribute( "var1", value );
            }
            else {
                _jsp_parentContext.removeAttribute( "var1",
                    JspContext.PAGE_SCOPE );
            }
        }
    }
}

9. Translation-time Classes

 The following classes are used at translation time.

Tag mapping, Tag name

A taglib directive introduces a tag library and associates a prefix to it. The TLD associated with the library associates Tag handler classes (plus other information) with tag names. This information is used to associate a Tag class, a prefix, and a name with each custom action element appearing in a JSP page.

At execution time the implementation of a JSP page will use an available Tag instance with the appropriate property settings and then follow the protocol described by the interfaces Tag, IterationTag, BodyTag, SimpleTag, and TryCatchFinally. The implementation guarantees that all tag handler instances are initialized and all are released, but the implementation can assume that previous settings are preserved by a tag handler, to reduce run-time costs.

Scripting Variables

JSP supports scripting variables that can be declared within a scriptlet and can be used in another. JSP actions also can be used to define scripting variables so they can used in scripting elements, or in other actions. This is very useful in some cases; for example, the jsp:useBean standard action may define an object which can later be used through a scripting variable.

In some cases the information on scripting variables can be described directly into the TLD using elements. A special case is typical interpretation of the "id" attribute. In other cases the logic that decides whether an action instance will define a scripting variable may be quite complex and the name of a TagExtraInfo class is instead given in the TLD. The getVariableInfo method of this class is used at translation time to obtain information on each variable that will be created at request time when this action is executed. The method is passed a TagData instance that contains the translation-time attribute values.

Validation

The TLD file contains several pieces of information that is used to do syntactic validation at translation-time. It also contains two extensible validation mechanisms: a TagLibraryValidator class can be used to validate a complete JSP page, and a TagExtraInfo class can be used to validate a specific action. In some cases, additional request-time validation will be done dynamically within the methods in the Tag instance. If an error is discovered, an instance of JspTagException can be thrown. If uncaught, this object will invoke the errorpage mechanism of JSP.

The TagLibraryValidator is an addition to the JSP 1.2 specification and is very open ended, being strictly more powerful than the TagExtraInfo mechanism. A JSP page is presented via the PageData object, which abstracts the XML view of the JSP page.

A PageData instance will provides an InputStream (read-only) on the page. Later specifications may add other views on the page (DOM, SAX, JDOM are all candidates), for now these views can be generated from the InputStream and perhaps can be cached for improved performance (recall the view of the page is just read-only).

As of JSP 2.0, the JSP container must support a jsp:id attribute to provide higher quality validation errors. The container will track the JSP pages as passed to the container, and will assign to each element a unique "id", which is passed as the value of the jsp:id attribute. Each XML element in the XML view will be extended with this attribute. The TagLibraryValidator can use the attribute in one or more ValidationMessage objects. The container then, in turn, can use these values to provide more precise information on the location of an error.

The prefix for the id attribute need not be "jsp" but it must map to the namespace http://java.sun.com/JSP/Page. In the case where the user has redefined the jsp prefix, an alternative prefix must be used by the container.

Validation Details

In detail, validation is done as follows:

First, the JSP page is parsed using the information in the TLD. At this stage valid mandatory and optional attributes are checked.

Second, for each unique tag library in the page as determined by the tag library URI, and in the lexical order in which they appear, their associated validator class (if any) is invoked. This involves several substeps.

The first substep is to obtain an initialized validator instance by either:

  • construct a new instance and invoke setInitParameters() on it, or
  • obtain an existing instance that is not being used, invoke release() on it, and then invoke setInitParameters() on it, or
  • locate an existing instance that is not being used on which the desired setInitParameters() has already been invoked

The class name is as indicated in the <validator-class> element, and the Map passed through setInitParameters() is as described in the <init-params> element. All TagLibraryValidator classes are supposed to keep their initParameters until new ones are set, or until release() is invoked on them.

The second substep is to perform the actual validation. This is done by invoking the validate() method with a prefix, uri, and PageData that correspond to the taglib directive instance being validated and the PageData representing the page. In the case where a single URI is mapped to more than one prefix, the prefix of the first URI must be used.

The last substep is to invoke the release() method on the validator tag when it is no longer needed. This method releases all resources.

Finally, after checking all the tag library validator classes, the TagExtraInfo classes for all tags will be consulted by invoking their validate method. The order of invocation of this methods is undefined.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.servlet.jsp.tagext Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.servlet.jsp.tagext

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.jsp.tagext.FunctionInfo
    • javax.servlet.jsp.tagext.JspFragment
    • javax.servlet.jsp.tagext.PageData
    • javax.servlet.jsp.tagext.SimpleTagSupport (implements javax.servlet.jsp.tagext.SimpleTag)
    • javax.servlet.jsp.tagext.TagAdapter (implements javax.servlet.jsp.tagext.Tag)
    • javax.servlet.jsp.tagext.TagAttributeInfo
    • javax.servlet.jsp.tagext.TagData (implements java.lang.Cloneable)
    • javax.servlet.jsp.tagext.TagExtraInfo
    • javax.servlet.jsp.tagext.TagFileInfo
    • javax.servlet.jsp.tagext.TagInfo
    • javax.servlet.jsp.tagext.TagLibraryInfo
    • javax.servlet.jsp.tagext.TagLibraryValidator
    • javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
    • javax.servlet.jsp.tagext.TagVariableInfo
    • javax.servlet.jsp.tagext.ValidationMessage
    • javax.servlet.jsp.tagext.VariableInfo
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • javax.servlet.jsp.JspWriter
        • javax.servlet.jsp.tagext.BodyContent

Interface Hierarchy

  • javax.servlet.jsp.tagext.DynamicAttributes
  • javax.servlet.jsp.tagext.JspIdConsumer
  • javax.servlet.jsp.tagext.JspTag
    • javax.servlet.jsp.tagext.SimpleTag
    • javax.servlet.jsp.tagext.Tag
      • javax.servlet.jsp.tagext.IterationTag
        • javax.servlet.jsp.tagext.BodyTag
  • javax.servlet.jsp.tagext.TryCatchFinally
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JspTag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface JspTag

All Known Subinterfaces:
BodyTag, IterationTag, SimpleTag, Tag
All Known Implementing Classes:
AttributeTag, BodyTagSupport, ConverterELTag, ConverterTag, FacetTag, SimpleTagSupport, TagAdapter, TagSupport, UIComponentBodyTag, UIComponentClassicTagBase, UIComponentELTag, UIComponentTag, UIComponentTagBase, ValidatorELTag, ValidatorTag
public interface JspTag

Serves as a base class for Tag and SimpleTag. This is mostly for organizational and type-safety purposes.

Since:
JSP 2.0

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BodyContent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class BodyContent

java.lang.Object
    extended by  java.io.Writer
        extended by  javax.servlet.jsp.JspWriter
            extended by  javax.servlet.jsp.tagext.BodyContent
All Implemented Interfaces:
Closeable, Flushable, Appendable
public abstract class BodyContent
extends JspWriter

An encapsulation of the evaluation of the body of an action so it is available to a tag handler. BodyContent is a subclass of JspWriter.

Note that the content of BodyContent is the result of evaluation, so it will not contain actions and the like, but the result of their invocation.

BodyContent has methods to convert its contents into a String, to read its contents, and to clear the contents.

The buffer size of a BodyContent object is unbounded. A BodyContent object cannot be in autoFlush mode. It is not possible to invoke flush on a BodyContent object, as there is no backing stream.

Instances of BodyContent are created by invoking the pushBody and popBody methods of the PageContext class. A BodyContent is enclosed within another JspWriter (maybe another BodyContent object) following the structure of their associated actions.

A BodyContent is made available to a BodyTag through a setBodyContent() call. The tag handler can use the object until after the call to doEndTag().

Field Summary
Fields inherited from class javax.servlet.jsp.JspWriter
autoFlush, bufferSize, DEFAULT_BUFFER, NO_BUFFER, UNBOUNDED_BUFFER
Fields inherited from class java.io.Writer
lock
Constructor Summary
protected BodyContent(JspWriter e)
Protected constructor.
Method Summary
 void clearBody()
Clear the body without throwing any exceptions.
 void flush()
Redefined flush() so it is not legal.
 JspWriter getEnclosingWriter()
Get the enclosing JspWriter.
abstract  Reader getReader()
Return the value of this BodyContent as a Reader.
abstract  String getString()
Return the value of the BodyContent as a String.
abstract  void writeOut(Writer out)
Write the contents of this BodyContent into a Writer.
Methods inherited from class javax.servlet.jsp.JspWriter
clear, clearBuffer, close, getBufferSize, getRemaining, isAutoFlush, newLine, print, print, print, print, print, print, print, print, print, println, println, println, println, println, println, println, println, println, println
Methods inherited from class java.io.Writer
append, append, append, write, write, write, write, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BodyContent

protected BodyContent(JspWriter e)
Protected constructor. Unbounded buffer, no autoflushing.

Parameters:
e - the enclosing JspWriter
Method Detail

flush

public void flush()
           throws IOException
Redefined flush() so it is not legal.

It is not valid to flush a BodyContent because there is no backing stream behind it.

Specified by:
flush in interface Flushable
Specified by:
flush in class JspWriter
Throws:
IOException - always thrown

clearBody

public void clearBody()
Clear the body without throwing any exceptions.

getReader

public abstract Reader getReader()
Return the value of this BodyContent as a Reader.

Returns:
the value of this BodyContent as a Reader

getString

public abstract String getString()
Return the value of the BodyContent as a String.

Returns:
the value of the BodyContent as a String

writeOut

public abstract void writeOut(Writer out)
                       throws IOException
Write the contents of this BodyContent into a Writer. Subclasses may optimize common invocation patterns.

Parameters:
out - The writer into which to place the contents of this body evaluation
Throws:
IOException - if an I/O error occurred while writing the contents of this BodyContent to the given Writer

getEnclosingWriter

public JspWriter getEnclosingWriter()
Get the enclosing JspWriter.

Returns:
the enclosing JspWriter passed at construction time
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BodyTag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface BodyTag

All Superinterfaces:
IterationTag, JspTag, Tag
All Known Implementing Classes:
BodyTagSupport, UIComponentBodyTag, UIComponentClassicTagBase, UIComponentELTag, UIComponentTag
public interface BodyTag
extends IterationTag

The BodyTag interface extends IterationTag by defining additional methods that let a tag handler manipulate the content of evaluating its body.

It is the responsibility of the tag handler to manipulate the body content. For example the tag handler may take the body content, convert it into a String using the bodyContent.getString method and then use it. Or the tag handler may take the body content and write it out into its enclosing JspWriter using the bodyContent.writeOut method.

A tag handler that implements BodyTag is treated as one that implements IterationTag, except that the doStartTag method can return SKIP_BODY, EVAL_BODY_INCLUDE or EVAL_BODY_BUFFERED.

If EVAL_BODY_INCLUDE is returned, then evaluation happens as in IterationTag.

If EVAL_BODY_BUFFERED is returned, then a BodyContent object will be created (by code generated by the JSP compiler) to capture the body evaluation. The code generated by the JSP compiler obtains the BodyContent object by calling the pushBody method of the current pageContext, which additionally has the effect of saving the previous out value. The page compiler returns this object by calling the popBody method of the PageContext class; the call also restores the value of out.

The interface provides one new property with a setter method and one new action method.

Properties

There is a new property: bodyContent, to contain the BodyContent object, where the JSP Page implementation object will place the evaluation (and reevaluation, if appropriate) of the body. The setter method (setBodyContent) will only be invoked if doStartTag() returns EVAL_BODY_BUFFERED and the corresponding action element does not have an empty body.

Methods

In addition to the setter method for the bodyContent property, there is a new action method: doInitBody(), which is invoked right after setBodyContent() and before the body evaluation. This method is only invoked if doStartTag() returns EVAL_BODY_BUFFERED.

Lifecycle

Lifecycle details are described by the transition diagram below. Exceptions that are thrown during the computation of doStartTag(), setBodyContent(), doInitBody(), BODY, doAfterBody() interrupt the execution sequence and are propagated up the stack, unless the tag handler implements the TryCatchFinally interface; see that interface for details.

Lifecycle Details Transition Diagram for BodyTag

Empty and Non-Empty Action

If the TagLibraryDescriptor file indicates that the action must always have an empty element body, by an <body-content> entry of "empty", then the doStartTag() method must return SKIP_BODY. Otherwise, the doStartTag() method may return SKIP_BODY, EVAL_BODY_INCLUDE, or EVAL_BODY_BUFFERED.

Note that which methods are invoked after the doStartTag() depends on both the return value and on if the custom action element is empty or not in the JSP page, not how it's declared in the TLD.

If SKIP_BODY is returned the body is not evaluated, and doEndTag() is invoked.

If EVAL_BODY_INCLUDE is returned, and the custom action element is not empty, setBodyContent() is not invoked, doInitBody() is not invoked, the body is evaluated and "passed through" to the current out, doAfterBody() is invoked and then, after zero or more iterations, doEndTag() is invoked. If the custom action element is empty, only doStart() and doEndTag() are invoked.

If EVAL_BODY_BUFFERED is returned, and the custom action element is not empty, setBodyContent() is invoked, doInitBody() is invoked, the body is evaluated, doAfterBody() is invoked, and then, after zero or more iterations, doEndTag() is invoked. If the custom action element is empty, only doStart() and doEndTag() are invoked.

Field Summary
static int | EVAL_BODY_BUFFERED Request the creation of new buffer, a BodyContent on which to evaluate the body of this tag.
static int | EVAL_BODY_TAG Deprecated. As of Java JSP API 1.2, use BodyTag.EVAL_BODY_BUFFERED or IterationTag.EVAL_BODY_AGAIN.
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Method Summary
void | doInitBody() Prepare for evaluation of the body.
void | setBodyContent(BodyContent b) Set the bodyContent property.
Methods inherited from interface javax.servlet.jsp.tagext.IterationTag
doAfterBody
Methods inherited from interface javax.servlet.jsp.tagext.Tag
doEndTag, doStartTag, getParent, release, setPageContext, setParent

Field Detail

EVAL_BODY_TAG

static final int EVAL_BODY_TAG
Deprecated. As of Java JSP API 1.2, use BodyTag.EVAL_BODY_BUFFERED or IterationTag.EVAL_BODY_AGAIN.
Deprecated constant that has the same value as EVAL_BODY_BUFFERED and EVAL_BODY_AGAIN. This name has been marked as deprecated to encourage the use of the two different terms, which are much more descriptive.

See Also:
Constant Field Values

EVAL_BODY_BUFFERED

static final int EVAL_BODY_BUFFERED
Request the creation of new buffer, a BodyContent on which to evaluate the body of this tag. Returned from doStartTag when it implements BodyTag. This is an illegal return value for doStartTag when the class does not implement BodyTag.

See Also:
Constant Field Values
Method Detail

setBodyContent

void setBodyContent(BodyContent b)
Set the bodyContent property. This method is invoked by the JSP page implementation object at most once per action invocation. This method will be invoked before doInitBody. This method will not be invoked for empty tags or for non-empty tags whose doStartTag() method returns SKIP_BODY or EVAL_BODY_INCLUDE.

When setBodyContent is invoked, the value of the implicit object out has already been changed in the pageContext object. The BodyContent object passed will have not data on it but may have been reused (and cleared) from some previous invocation.

The BodyContent object is available and with the appropriate content until after the invocation of the doEndTag method, at which case it may be reused.

Parameters:
b - the BodyContent
See Also:
doInitBody(), IterationTag.doAfterBody()

doInitBody

void doInitBody()
                throws JspException
Prepare for evaluation of the body. This method is invoked by the JSP page implementation object after setBodyContent and before the first time the body is to be evaluated. This method will not be invoked for empty tags or for non-empty tags whose doStartTag() method returns SKIP_BODY or EVAL_BODY_INCLUDE.

The JSP container will resynchronize the values of any AT_BEGIN and NESTED variables (defined by the associated TagExtraInfo or TLD) after the invocation of doInitBody().

Throws:
JspException - if an error occurred while processing this tag
See Also:
IterationTag.doAfterBody()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BodyTagSupport

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class BodyTagSupport

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class BodyTagSupport
extends TagSupport
implements BodyTag

A base class for defining tag handlers implementing BodyTag.

The BodyTagSupport class implements the BodyTag interface and adds additional convenience methods including getter methods for the bodyContent property and methods to get at the previous out JspWriter.

Many tag handlers will extend BodyTagSupport and only redefine a few methods.

See Also:
Serialized Form

Field Summary
protected  BodyContent bodyContent
The current BodyContent for this BodyTag.
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
BodyTagSupport()
Default constructor, all subclasses are required to only define a public constructor with the same signature, and to call the superclass constructor.
Method Summary
int | doAfterBody() After the body evaluation: do not reevaluate and continue with the page.
int | doEndTag() Default processing of the end tag returning EVAL_PAGE.
void | doInitBody() Prepare for evaluation of the body just before the first body evaluation: no action.
int | doStartTag() Default processing of the start tag returning EVAL_BODY_BUFFERED.
BodyContent | getBodyContent() Get current bodyContent.
JspWriter | getPreviousOut() Get surrounding out JspWriter.
void | release() Release state.
void | setBodyContent(BodyContent b) Prepare for evaluation of the body: stash the bodyContent away.
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

bodyContent

protected BodyContent bodyContent
The current BodyContent for this BodyTag.

Constructor Detail

BodyTagSupport

public BodyTagSupport()
Default constructor, all subclasses are required to only define a public constructor with the same signature, and to call the superclass constructor. This constructor is called by the code generated by the JSP translator.

Method Detail

doStartTag

public int doStartTag()
               throws JspException
Default processing of the start tag returning EVAL_BODY_BUFFERED.

Specified by:
doStartTag in interface Tag
Overrides:
doStartTag in class TagSupport
Returns:
EVAL_BODY_BUFFERED
Throws:
JspException - if an error occurred while processing this tag
See Also:
Tag.doStartTag()

doEndTag

public int doEndTag()
             throws JspException
Default processing of the end tag returning EVAL_PAGE.

Specified by:
doEndTag in interface Tag
Overrides:
doEndTag in class TagSupport
Returns:
EVAL_PAGE
Throws:
JspException - if an error occurred while processing this tag
See Also:
Tag.doEndTag()

setBodyContent

public void setBodyContent(BodyContent b)
Prepare for evaluation of the body: stash the bodyContent away.

Specified by:
setBodyContent in interface BodyTag
Parameters:
b - the BodyContent
See Also:
doAfterBody(),
doInitBody(),
BodyTag.setBodyContent(javax.servlet.jsp.tagext.BodyContent)

doInitBody

public void doInitBody()
                throws JspException
Prepare for evaluation of the body just before the first body evaluation: no action.

Specified by:
doInitBody in interface BodyTag
Throws:
JspException - if an error occurred while processing this tag
See Also:
setBodyContent(javax.servlet.jsp.tagext.BodyContent),
doAfterBody(),
BodyTag.doInitBody()

doAfterBody

public int doAfterBody()
                throws JspException
After the body evaluation: do not reevaluate and continue with the page. By default nothing is done with the bodyContent data (if any).

Specified by:
doAfterBody in interface IterationTag
Overrides:
doAfterBody in class TagSupport
Returns:
SKIP_BODY
Throws:
JspException - if an error occurred while processing this tag
See Also:
doInitBody(), IterationTag.doAfterBody()

release

public void release()
Release state.

Specified by:
release in interface Tag
Overrides:
release in class TagSupport
See Also:
Tag.release()

getBodyContent

public BodyContent getBodyContent()
Get current bodyContent.

Returns:
the body content.

getPreviousOut

public JspWriter getPreviousOut()
Get surrounding out JspWriter.

Returns:
the enclosing JspWriter, from the bodyContent.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DynamicAttributes

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface DynamicAttributes

public interface DynamicAttributes

For a tag to declare that it accepts dynamic attributes, it must implement this interface. The entry for the tag in the Tag Library Descriptor must also be configured to indicate dynamic attributes are accepted.
For any attribute that is not declared in the Tag Library Descriptor for this tag, instead of getting an error at translation time, the setDynamicAttribute() method is called, with the name and value of the attribute. It is the responsibility of the tag to remember the names and values of the dynamic attributes.

Since:
JSP 2.0

Method Summary
 void setDynamicAttribute(String uri, String localName, Object value)
Called when a tag declared to accept dynamic attributes is passed an attribute that is not declared in the Tag Library Descriptor.

Method Detail

setDynamicAttribute

void setDynamicAttribute(String uri,
                         String localName,
                         Object value)
                         throws JspException
Called when a tag declared to accept dynamic attributes is passed an attribute that is not declared in the Tag Library Descriptor.

Parameters:
uri - the namespace of the attribute, or null if in the default namespace.
localName - the name of the attribute being set.
value - the value of the attribute
Throws:
JspException - if the tag handler wishes to signal that it does not accept the given attribute. The container must not call doStartTag() or doTag() for this tag.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FunctionInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class FunctionInfo

java.lang.Object
    extended by  javax.servlet.jsp.tagext.FunctionInfo

public class FunctionInfo
extends Object

Information for a function in a Tag Library. This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.

Since:
JSP 2.0

Constructor Summary
FunctionInfo(String name, String klass, String signature)
Constructor for FunctionInfo.
Method Summary
String | getFunctionClass() The class of the function.
String | getFunctionSignature() The signature of the function.
String | getName() The name of the function.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FunctionInfo

public FunctionInfo(String name,
                    String klass,
                    String signature)
Constructor for FunctionInfo.

Parameters:
name - The name of the function
klass - The class of the function
signature - The signature of the function
Method Detail

getName

public String getName()
The name of the function.

Returns:
The name of the function

getFunctionClass

public String getFunctionClass()
The class of the function.

Returns:
The class of the function

getFunctionSignature

public String getFunctionSignature()
The signature of the function.

Returns:
The signature of the function
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


IterationTag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface IterationTag

All Superinterfaces:
JspTag, Tag
All Known Subinterfaces:
BodyTag
All Known Implementing Classes:
AttributeTag, BodyTagSupport, ConverterELTag, ConverterTag, FacetTag, TagSupport, UIComponentBodyTag, UIComponentClassicTagBase, UIComponentELTag, UIComponentTag, ValidatorELTag, ValidatorTag
public interface IterationTag
extends Tag

The IterationTag interface extends Tag by defining one additional method that controls the reevaluation of its body.

A tag handler that implements IterationTag is treated as one that implements Tag regarding the doStartTag() and doEndTag() methods. IterationTag provides a new method: doAfterBody().

The doAfterBody() method is invoked after every body evaluation to control whether the body will be reevaluated or not. If doAfterBody() returns IterationTag.EVAL_BODY_AGAIN, then the body will be reevaluated. If doAfterBody() returns Tag.SKIP_BODY, then the body will be skipped and doEndTag() will be evaluated instead.

Properties There are no new properties in addition to those in Tag.

Methods There is one new methods: doAfterBody().

Lifecycle

Lifecycle details are described by the transition diagram below. Exceptions that are thrown during the computation of doStartTag(), BODY and doAfterBody() interrupt the execution sequence and are propagated up the stack, unless the tag handler implements the TryCatchFinally interface; see that interface for details.

Lifecycle Details Transition Diagram for IterationTag

Empty and Non-Empty Action

If the TagLibraryDescriptor file indicates that the action must always have an empty element body, by a <body-content> entry of "empty", then the doStartTag() method must return SKIP_BODY.

Note that which methods are invoked after the doStartTag() depends on both the return value and on if the custom action element is empty or not in the JSP page, not on how it's declared in the TLD.

If SKIP_BODY is returned the body is not evaluated, and then doEndTag() is invoked.

If EVAL_BODY_INCLUDE is returned, and the custom action element is not empty, the body is evaluated and "passed through" to the current out, then doAfterBody() is invoked and, after zero or more iterations, doEndTag() is invoked.

Field Summary
static int EVAL_BODY_AGAIN
Request the reevaluation of some body.
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Method Summary
 int doAfterBody()
Process body (re)evaluation.
Methods inherited from interface javax.servlet.jsp.tagext.Tag
doEndTag, doStartTag, getParent, release, setPageContext, setParent

Field Detail

EVAL_BODY_AGAIN

static final int EVAL_BODY_AGAIN
Request the reevaluation of some body. Returned from doAfterBody. For compatibility with JSP 1.1, the value is carefully selected to be the same as the, now deprecated, BodyTag.EVAL_BODY_TAG,

See Also:
Constant Field Values
Method Detail

doAfterBody

int doAfterBody()
                throws JspException
Process body (re)evaluation. This method is invoked by the JSP Page implementation object after every evaluation of the body into the BodyEvaluation object. The method is not invoked if there is no body evaluation.

If doAfterBody returns EVAL_BODY_AGAIN, a new evaluation of the body will happen (followed by another invocation of doAfterBody). If doAfterBody returns SKIP_BODY, no more body evaluations will occur, and the doEndTag method will be invoked.

If this tag handler implements BodyTag and doAfterBody returns SKIP_BODY, the value of out will be restored using the popBody method in pageContext prior to invoking doEndTag.

The method re-invocations may be lead to different actions because there might have been some changes to shared state, or because of external computation.

The JSP container will resynchronize the values of any AT_BEGIN and NESTED variables (defined by the associated TagExtraInfo or TLD) after the invocation of doAfterBody().

Returns:
whether additional evaluations of the body are desired
Throws:
JspException - if an error occurred while processing this tag
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JspFragment

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class JspFragment

java.lang.Object
    extended by  javax.servlet.jsp.tagext.JspFragment

public abstract class JspFragment
extends Object

Encapsulates a portion of JSP code in an object that can be invoked as many times as needed. JSP Fragments are defined using JSP syntax as the body of a tag for an invocation to a SimpleTag handler, or as the body of a <jsp:attribute> standard action specifying the value of an attribute that is declared as a fragment, or to be of type JspFragment in the TLD.

The definition of the JSP fragment must only contain template text and JSP action elements. In other words, it must not contain scriptlets or scriptlet expressions. At translation time, the container generates an implementation of the JspFragment abstract class capable of executing the defined fragment.

A tag handler can invoke the fragment zero or more times, or pass it along to other tags, before returning. To communicate values to/from a JSP fragment, tag handlers store/retrieve values in the JspContext associated with the fragment.

Note that tag library developers and page authors should not generate JspFragment implementations manually.

Implementation Note: It is not necessary to generate a separate class for each fragment. One possible implementation is to generate a single helper class for each page that implements JspFragment. Upon construction, a discriminator can be passed to select which fragment that instance will execute.

Since:
JSP 2.0

Constructor Summary
JspFragment()
Method Summary
abstract JspContext | getJspContext() Returns the JspContext that is bound to this JspFragment.
abstract void | invoke(Writer out) Executes the fragment and directs all output to the given Writer, or the JspWriter returned by the getOut() method of the JspContext associated with the fragment if out is null.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JspFragment

public JspFragment()
Method Detail

invoke

public abstract void invoke(Writer out)
                     throws JspException,
                            IOException
Executes the fragment and directs all output to the given Writer, or the JspWriter returned by the getOut() method of the JspContext associated with the fragment if out is null.

Parameters:
out - The Writer to output the fragment to, or null if output should be sent to JspContext.getOut().
Throws:
JspException - Thrown if an error occured while invoking this fragment.
SkipPageException - Thrown if the page that (either directly or indirectly) invoked the tag handler that invoked this fragment is to cease evaluation. The container must throw this exception if a Classic Tag Handler returned Tag.SKIP_PAGE or if a Simple Tag Handler threw SkipPageException.
IOException - If there was an error writing to the stream.

getJspContext

public abstract JspContext getJspContext()
Returns the JspContext that is bound to this JspFragment.

Returns:
The JspContext used by this fragment at invocation time.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JspIdConsumer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface JspIdConsumer

All Known Implementing Classes:
UIComponentBodyTag, UIComponentClassicTagBase, UIComponentELTag, UIComponentTag
public interface JspIdConsumer

This interface indicates to the container that a tag handler wishes to be provided with a compiler generated ID.

The container sets the jspId attribute of the tag handler with an identification string, as part of tag property initialization. Each tag in a JSP page has a unique jspId, and a given tag in a JSP page always has the same jspId, even for multiple requests to the page.

Tag handler instances that implement JspIdConsumer cannot be reused.

Even though the jspId attribute is similar in concept to the jsp:id attribute of an XML view (see Section JSP.10.1.13 of the spec), they are not related. The jsp:id attribute is available only at translation time, and the jspId attribute is avalable only at request time.

The JSP container must provide a value for jspId that conforms to the following rules:

  • It must start with a letter (as defined by the Character.isLetter() method) or underscore ('_').
  • Subsequent characters may be letters (as defined by the Character.isLetter() method), digits (as defined by the Character.isDigit() method), dashes ('-'), or underscores ('_')

Note that the rules exclude colons ':' in a jspId, and that they are the same rules used for a component ID in JavaServer Faces.

Since:
JSP 2.1

Method Summary
 void setJspId(String id)
Called by the container generated code to set a value for the jspId attribute.

Method Detail

setJspId

void setJspId(String id)
Called by the container generated code to set a value for the jspId attribute. An unique identification string, relative to this page, is generated at translation time.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PageData

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class PageData

java.lang.Object
    extended by  javax.servlet.jsp.tagext.PageData

public abstract class PageData
extends Object

Translation-time information on a JSP page. The information corresponds to the XML view of the JSP page.

Objects of this type are generated by the JSP translator, e.g. when being pased to a TagLibraryValidator instance.

Constructor Summary
PageData()
Sole constructor.
Method Summary
abstract  InputStream getInputStream()
Returns an input stream on the XML view of a JSP page.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PageData

public PageData()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

getInputStream

public abstract InputStream getInputStream()
Returns an input stream on the XML view of a JSP page. The stream is encoded in UTF-8. Recall tht the XML view of a JSP page has the include directives expanded.

Returns:
An input stream on the document.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SimpleTag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface SimpleTag

All Superinterfaces:
JspTag
All Known Implementing Classes:
SimpleTagSupport
public interface SimpleTag
extends JspTag

Interface for defining Simple Tag Handlers.

Simple Tag Handlers differ from Classic Tag Handlers in that instead of supporting doStartTag() and doEndTag(), the SimpleTag interface provides a simple doTag() method, which is called once and only once for any given tag invocation. All tag logic, iteration, body evaluations, etc. are to be performed in this single method. Thus, simple tag handlers have the equivalent power of BodyTag, but with a much simpler lifecycle and interface.

To support body content, the setJspBody() method is provided. The container invokes the setJspBody() method with a JspFragment object encapsulating the body of the tag. The tag handler implementation can call invoke() on that fragment to evaluate the body as many times as it needs.

A SimpleTag handler must have a public no-args constructor. Most SimpleTag handlers should extend SimpleTagSupport.

Lifecycle

The following is a non-normative, brief overview of the SimpleTag lifecycle. Refer to the JSP Specification for details.

  1. A new tag handler instance is created each time by the container by calling the provided zero-args constructor. Unlike classic tag handlers, simple tag handlers are never cached and reused by the JSP container.
  2. The setJspContext() and setParent() methods are called by the container. The setParent() method is only called if the element is nested within another tag invocation.
  3. The setters for each attribute defined for this tag are called by the container.
  4. If a body exists, the setJspBody() method is called by the container to set the body of this tag, as a JspFragment. If the action element is empty in the page, this method is not called at all.
  5. The doTag() method is called by the container. All tag logic, iteration, body evaluations, etc. occur in this method.
  6. The doTag() method returns and all variables are synchronized.

Since:
JSP 2.0
See Also:
SimpleTagSupport

Method Summary
void | doTag() Called by the container to invoke this tag.
JspTag | getParent() Returns the parent of this tag, for collaboration purposes.
void | setJspBody(JspFragment jspBody) Provides the body of this tag as a JspFragment object, able to be invoked zero or more times by the tag handler.
void | setJspContext(JspContext pc) Called by the container to provide this tag handler with the JspContext for this invocation.
void | setParent(JspTag parent) Sets the parent of this tag, for collaboration purposes.

Method Detail

doTag

void doTag()
           throws JspException,
                  IOException
Called by the container to invoke this tag. The implementation of this method is provided by the tag library developer, and handles all tag processing, body iteration, etc.

The JSP container will resynchronize any AT_BEGIN and AT_END variables (defined by the associated tag file, TagExtraInfo, or TLD) after the invocation of doTag().

Throws:
JspException - If an error occurred while processing this tag.
SkipPageException - If the page that (either directly or indirectly) invoked this tag is to cease evaluation. A Simple Tag Handler generated from a tag file must throw this exception if an invoked Classic Tag Handler returned SKIP_PAGE or if an invoked Simple Tag Handler threw SkipPageException or if an invoked Jsp Fragment threw a SkipPageException.
IOException - If there was an error writing to the output stream.

setParent

void setParent(JspTag parent)
Sets the parent of this tag, for collaboration purposes.

The container invokes this method only if this tag invocation is nested within another tag invocation.

Parameters:
parent - the tag that encloses this tag

getParent

JspTag getParent()
Returns the parent of this tag, for collaboration purposes.

Returns:
the parent of this tag

setJspContext

void setJspContext(JspContext pc)
Called by the container to provide this tag handler with the JspContext for this invocation. An implementation should save this value.

Parameters:
pc - the page context for this invocation
See Also:
Tag.setPageContext(javax.servlet.jsp.PageContext)

setJspBody

void setJspBody(JspFragment jspBody)
Provides the body of this tag as a JspFragment object, able to be invoked zero or more times by the tag handler.

This method is invoked by the JSP page implementation object prior to doTag(). If the action element is empty in the page, this method is not called at all.

Parameters:
jspBody - The fragment encapsulating the body of this tag.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SimpleTagSupport

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class SimpleTagSupport

java.lang.Object
    extended by  javax.servlet.jsp.tagext.SimpleTagSupport
All Implemented Interfaces:
JspTag, SimpleTag
public class SimpleTagSupport
extends Object
implements SimpleTag

A base class for defining tag handlers implementing SimpleTag.

The SimpleTagSupport class is a utility class intended to be used as the base class for new simple tag handlers. The SimpleTagSupport class implements the SimpleTag interface and adds additional convenience methods including getter methods for the properties in SimpleTag.

Since:
JSP 2.0

Constructor Summary
SimpleTagSupport()
Sole constructor.
Method Summary
void | doTag() Default processing of the tag does nothing.
static JspTag | findAncestorWithClass(JspTag from, Class<?> klass) Find the instance of a given class type that is closest to a given instance.
protected JspFragment | getJspBody() Returns the body passed in by the container via setJspBody.
protected JspContext | getJspContext() Returns the page context passed in by the container via setJspContext.
JspTag | getParent() Returns the parent of this tag, for collaboration purposes.
void | setJspBody(JspFragment jspBody) Stores the provided JspFragment.
void | setJspContext(JspContext pc) Stores the provided JSP context in the private jspContext field.
void | setParent(JspTag parent) Sets the parent of this tag, for collaboration purposes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SimpleTagSupport

public SimpleTagSupport()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

doTag

public void doTag()
           throws JspException,
                  IOException
Default processing of the tag does nothing.

Specified by:
doTag in interface SimpleTag
Throws:
JspException - Subclasses can throw JspException to indicate an error occurred while processing this tag.
SkipPageException - If the page that (either directly or indirectly) invoked this tag is to cease evaluation. A Simple Tag Handler generated from a tag file must throw this exception if an invoked Classic Tag Handler returned SKIP_PAGE or if an invoked Simple Tag Handler threw SkipPageException or if an invoked Jsp Fragment threw a SkipPageException.
IOException - Subclasses can throw IOException if there was an error writing to the output stream
See Also:
SimpleTag.doTag()

setParent

public void setParent(JspTag parent)
Sets the parent of this tag, for collaboration purposes.

The container invokes this method only if this tag invocation is nested within another tag invocation.

Specified by:
setParent in interface SimpleTag
Parameters:
parent - the tag that encloses this tag

getParent

public JspTag getParent()
Returns the parent of this tag, for collaboration purposes.

Specified by:
getParent in interface SimpleTag
Returns:
the parent of this tag

setJspContext

public void setJspContext(JspContext pc)
Stores the provided JSP context in the private jspContext field. Subclasses can access the JspContext via getJspContext().

Specified by:
setJspContext in interface SimpleTag
Parameters:
pc - the page context for this invocation
See Also:
SimpleTag.setJspContext(javax.servlet.jsp.JspContext)

getJspContext

protected JspContext getJspContext()
Returns the page context passed in by the container via setJspContext.

Returns:
the page context for this invocation

setJspBody

public void setJspBody(JspFragment jspBody)
Stores the provided JspFragment.

Specified by:
setJspBody in interface SimpleTag
Parameters:
jspBody - The fragment encapsulating the body of this tag. If the action element is empty in the page, this method is not called at all.
See Also:
SimpleTag.setJspBody(javax.servlet.jsp.tagext.JspFragment)

getJspBody

protected JspFragment getJspBody()
Returns the body passed in by the container via setJspBody.

Returns:
the fragment encapsulating the body of this tag, or null if the action element is empty in the page.

findAncestorWithClass

public static final JspTag findAncestorWithClass(JspTag from,
                                                 Class<?> klass)
Find the instance of a given class type that is closest to a given instance. This method uses the getParent method from the Tag and/or SimpleTag interfaces. This method is used for coordination among cooperating tags.

For every instance of TagAdapter encountered while traversing the ancestors, the tag handler returned by TagAdapter.getAdaptee() - instead of the TagAdpater itself - is compared to klass. If the tag handler matches, it - and not its TagAdapter - is returned.

The current version of the specification only provides one formal way of indicating the observable type of a tag handler: its tag handler implementation class, described in the tag-class subelement of the tag element. This is extended in an informal manner by allowing the tag library author to indicate in the description subelement an observable type. The type should be a subtype of the tag handler implementation class or void. This addititional constraint can be exploited by a specialized container that knows about that specific tag library, as in the case of the JSP standard tag library.

When a tag library author provides information on the observable type of a tag handler, client programmatic code should adhere to that constraint. Specifically, the Class passed to findAncestorWithClass should be a subtype of the observable type.

Parameters:
from - The instance from where to start looking.
klass - The subclass of JspTag or interface to be matched
Returns:
the nearest ancestor that implements the interface or is an instance of the class specified
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Tag

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface Tag

All Superinterfaces:
JspTag
All Known Subinterfaces:
BodyTag, IterationTag
All Known Implementing Classes:
AttributeTag, BodyTagSupport, ConverterELTag, ConverterTag, FacetTag, TagAdapter, TagSupport, UIComponentBodyTag, UIComponentClassicTagBase, UIComponentELTag, UIComponentTag, ValidatorELTag, ValidatorTag
public interface Tag
extends JspTag

The interface of a classic tag handler that does not want to manipulate its body. The Tag interface defines the basic protocol between a Tag handler and JSP page implementation class. It defines the life cycle and the methods to be invoked at start and end tag.

Properties

The Tag interface specifies the setter and getter methods for the core pageContext and parent properties.

The JSP page implementation object invokes setPageContext and setParent, in that order, before invoking doStartTag() or doEndTag().

Methods

There are two main actions: doStartTag and doEndTag. Once all appropriate properties have been initialized, the doStartTag and doEndTag methods can be invoked on the tag handler. Between these invocations, the tag handler is assumed to hold a state that must be preserved. After the doEndTag invocation, the tag handler is available for further invocations (and it is expected to have retained its properties).

Lifecycle

Lifecycle details are described by the transition diagram below, with the following comments:

  • [1] This transition is intended to be for releasing long-term data. no guarantees are assumed on whether any properties have been retained or not.
  • [2] This transition happens if and only if the tag ends normally without raising an exception
  • [3] Some setters may be called again before a tag handler is reused. For instance, setParent() is called if it's reused within the same page but at a different level, setPageContext() is called if it's used in another page, and attribute setters are called if the values differ or are expressed as request-time attribute values.
  • Check the TryCatchFinally interface for additional details related to exception handling and resource management.

Lifecycle Details Transition Diagram for Tag

Once all invocations on the tag handler are completed, the release method is invoked on it. Once a release method is invoked all properties, including parent and pageContext, are assumed to have been reset to an unspecified value. The page compiler guarantees that release() will be invoked on the Tag handler before the handler is released to the GC.

Empty and Non-Empty Action

If the TagLibraryDescriptor file indicates that the action must always have an empty action, by an <body-content> entry of "empty", then the doStartTag() method must return SKIP_BODY.

Otherwise, the doStartTag() method may return SKIP_BODY or EVAL_BODY_INCLUDE.

If SKIP_BODY is returned the body, if present, is not evaluated.

If EVAL_BODY_INCLUDE is returned, the body is evaluated and "passed through" to the current out.

Field Summary
static int | EVAL_BODY_INCLUDE Evaluate body into existing out stream.
static int | EVAL_PAGE Continue evaluating the page.
static int | SKIP_BODY Skip body evaluation.
static int | SKIP_PAGE Skip the rest of the page.
Method Summary
int | doEndTag() Process the end tag for this instance.
int | doStartTag() Process the start tag for this instance.
Tag | getParent() Get the parent (closest enclosing tag handler) for this tag handler.
void | release() Called on a Tag handler to release state.
void | setPageContext(PageContext pc) Set the current page context.
void | setParent(Tag t) Set the parent (closest enclosing tag handler) of this tag handler.

Field Detail

SKIP_BODY

static final int SKIP_BODY
Skip body evaluation. Valid return value for doStartTag and doAfterBody.

See Also:
Constant Field Values

EVAL_BODY_INCLUDE

static final int EVAL_BODY_INCLUDE
Evaluate body into existing out stream. Valid return value for doStartTag.

See Also:
Constant Field Values

SKIP_PAGE

static final int SKIP_PAGE
Skip the rest of the page. Valid return value for doEndTag.

See Also:
Constant Field Values

EVAL_PAGE

static final int EVAL_PAGE
Continue evaluating the page. Valid return value for doEndTag().

See Also:
Constant Field Values
Method Detail

setPageContext

void setPageContext(PageContext pc)
Set the current page context. This method is invoked by the JSP page implementation object prior to doStartTag().

This value is *not* reset by doEndTag() and must be explicitly reset by a page implementation if it changes between calls to doStartTag().

Parameters:
pc - The page context for this tag handler.

setParent

void setParent(Tag t)
Set the parent (closest enclosing tag handler) of this tag handler. Invoked by the JSP page implementation object prior to doStartTag().

This value is *not* reset by doEndTag() and must be explicitly reset by a page implementation.

Parameters:
t - The parent tag, or null.

getParent

Tag getParent()
Get the parent (closest enclosing tag handler) for this tag handler.

The getParent() method can be used to navigate the nested tag handler structure at runtime for cooperation among custom actions; for example, the findAncestorWithClass() method in TagSupport provides a convenient way of doing this.

The current version of the specification only provides one formal way of indicating the observable type of a tag handler: its tag handler implementation class, described in the tag-class subelement of the tag element. This is extended in an informal manner by allowing the tag library author to indicate in the description subelement an observable type. The type should be a subtype of the tag handler implementation class or void. This addititional constraint can be exploited by a specialized container that knows about that specific tag library, as in the case of the JSP standard tag library.

Returns:
the current parent, or null if none.
See Also:
TagSupport.findAncestorWithClass(javax.servlet.jsp.tagext.Tag, java.lang.Class)

doStartTag

int doStartTag()
               throws JspException
Process the start tag for this instance. This method is invoked by the JSP page implementation object.

The doStartTag method assumes that the properties pageContext and parent have been set. It also assumes that any properties exposed as attributes have been set too. When this method is invoked, the body has not yet been evaluated.

This method returns Tag.EVAL_BODY_INCLUDE or BodyTag.EVAL_BODY_BUFFERED to indicate that the body of the action should be evaluated or SKIP_BODY to indicate otherwise.

When a Tag returns EVAL_BODY_INCLUDE the result of evaluating the body (if any) is included into the current "out" JspWriter as it happens and then doEndTag() is invoked.

BodyTag.EVAL_BODY_BUFFERED is only valid if the tag handler implements BodyTag.

The JSP container will resynchronize the values of any AT_BEGIN and NESTED variables (defined by the associated TagExtraInfo or TLD) after the invocation of doStartTag(), except for a tag handler implementing BodyTag whose doStartTag() method returns BodyTag.EVAL_BODY_BUFFERED.

Returns:
EVAL_BODY_INCLUDE if the tag wants to process body, SKIP_BODY if it does not want to process it.
Throws:
JspException - if an error occurred while processing this tag
See Also:
BodyTag

doEndTag

int doEndTag()
             throws JspException
Process the end tag for this instance. This method is invoked by the JSP page implementation object on all Tag handlers.

This method will be called after returning from doStartTag. The body of the action may or may not have been evaluated, depending on the return value of doStartTag.

If this method returns EVAL_PAGE, the rest of the page continues to be evaluated. If this method returns SKIP_PAGE, the rest of the page is not evaluated, the request is completed, and the doEndTag() methods of enclosing tags are not invoked. If this request was forwarded or included from another page (or Servlet), only the current page evaluation is stopped.

The JSP container will resynchronize the values of any AT_BEGIN and AT_END variables (defined by the associated TagExtraInfo or TLD) after the invocation of doEndTag().

Returns:
indication of whether to continue evaluating the JSP page.
Throws:
JspException - if an error occurred while processing this tag

release

void release()
Called on a Tag handler to release state. The page compiler guarantees that JSP page implementation objects will invoke this method on all tag handlers, but there may be multiple invocations on doStartTag and doEndTag in between.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TagAdapter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagAdapter

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagAdapter
All Implemented Interfaces:
JspTag, Tag
public class TagAdapter
extends Object
implements Tag

Wraps any SimpleTag and exposes it using a Tag interface. This is used to allow collaboration between classic Tag handlers and SimpleTag handlers.

Because SimpleTag does not extend Tag, and because Tag.setParent() only accepts a Tag instance, a classic tag handler (one that implements Tag) cannot have a SimpleTag as its parent. To remedy this, a TagAdapter is created to wrap the SimpleTag parent, and the adapter is passed to setParent() instead. A classic Tag Handler can call getAdaptee() to retrieve the encapsulated SimpleTag instance.

Since:
JSP 2.0

Field Summary
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
TagAdapter(SimpleTag adaptee)
Creates a new TagAdapter that wraps the given SimpleTag and returns the parent tag when getParent() is called.
Method Summary
 int doEndTag()
Must not be called.
 int doStartTag()
Must not be called.
 JspTag getAdaptee()
Gets the tag that is being adapted to the Tag interface.
 Tag getParent()
Returns the parent of this tag, which is always getAdaptee().getParent().
 void release()
Must not be called.
 void setPageContext(PageContext pc)
Must not be called.
 void setParent(Tag parentTag)
Must not be called.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TagAdapter

public TagAdapter(SimpleTag adaptee)
Creates a new TagAdapter that wraps the given SimpleTag and returns the parent tag when getParent() is called.

Parameters:
adaptee - The SimpleTag being adapted as a Tag.
Method Detail

setPageContext

public void setPageContext(PageContext pc)
Must not be called.

Specified by:
setPageContext in interface Tag
Parameters:
pc - ignored.
Throws:
UnsupportedOperationException - Must not be called

setParent

public void setParent(Tag parentTag)
Must not be called. The parent of this tag is always getAdaptee().getParent().

Specified by:
setParent in interface Tag
Parameters:
parentTag - ignored.
Throws:
UnsupportedOperationException - Must not be called.

getParent

public Tag getParent()
Returns the parent of this tag, which is always getAdaptee().getParent(). This will either be the enclosing Tag (if getAdaptee().getParent() implements Tag), or an adapter to the enclosing Tag (if getAdaptee().getParent() does not implement Tag).

Specified by:
getParent in interface Tag
Returns:
The parent of the tag being adapted.
See Also:
TagSupport.findAncestorWithClass(javax.servlet.jsp.tagext.Tag, java.lang.Class)

getAdaptee

public JspTag getAdaptee()
Gets the tag that is being adapted to the Tag interface. This should be an instance of SimpleTag in JSP 2.0, but room is left for other kinds of tags in future spec versions.

Returns:
the tag that is being adapted

doStartTag

public int doStartTag()
               throws JspException
Must not be called.

Specified by:
doStartTag in interface Tag
Returns:
always throws UnsupportedOperationException
Throws:
UnsupportedOperationException - Must not be called
JspException - never thrown
See Also:
BodyTag

doEndTag

public int doEndTag()
             throws JspException
Must not be called.

Specified by:
doEndTag in interface Tag
Returns:
always throws UnsupportedOperationException
Throws:
UnsupportedOperationException - Must not be called
JspException - never thrown

release

public void release()
Must not be called.

Specified by:
release in interface Tag
Throws:
UnsupportedOperationException - Must not be called
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TagAttributeInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagAttributeInfo

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagAttributeInfo

public class TagAttributeInfo
extends Object

Information on the attributes of a Tag, available at translation time. This class is instantiated from the Tag Library Descriptor file (TLD).

Only the information needed to generate code is included here. Other information like SCHEMA for validation belongs elsewhere.

Note from the Expert Group:
This should have been designed as an interface. Every time we change the TLD, we need to add a new constructor to this class (not good). This class should only be instantiated by container implementations (not by JSP developers).

Field Summary
static String ID
"id" is wired in to be ID.
Constructor Summary
TagAttributeInfo(String name, boolean required, String type, boolean reqTime)
Constructor for TagAttributeInfo.
TagAttributeInfo(String name, boolean required, String type, boolean reqTime, boolean fragment)
JSP 2.0 Constructor for TagAttributeInfo.
TagAttributeInfo(String name, boolean required, String type, boolean reqTime, boolean fragment, String description, boolean deferredValue, boolean deferredMethod, String expectedTypeName, String methodSignature)
JSP 2.1 Constructor for TagAttributeInfo.
Method Summary
boolean | canBeRequestTime() Whether this attribute has been specified in the TLD as rtexprvalue.
String | getDescription() Gets the description string of this tag attribute.
String | getExpectedTypeName() Returns the name of the expected type (as a String) of this deferred value attribute.
static TagAttributeInfo | getIdAttribute(TagAttributeInfo[] a) Convenience static method that goes through an array of TagAttributeInfo objects and looks for "id".
String | getMethodSignature() Returns the expected method signature of this deferred method attribute.
String | getName() The name of this attribute.
String | getTypeName() The type (as a String) of this attribute.
boolean | isDeferredMethod() Returns true if this attribute is to be passed a MethodExpression so that expression evaluation can be deferred.
boolean | isDeferredValue() Returns true if this attribute is to be passed a ValueExpression so that expression evaluation can be deferred.
boolean | isFragment() Whether this attribute is of type JspFragment.
boolean | isRequired() Whether this attribute is required.
String | toString() Returns a String representation of this TagAttributeInfo, suitable for debugging purposes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ID

public static final String ID
"id" is wired in to be ID. There is no real benefit in having it be something else IDREFs are not handled any differently.

See Also:
Constant Field Values
Constructor Detail

TagAttributeInfo

public TagAttributeInfo(String name,
                        boolean required,
                        String type,
                        boolean reqTime)
Constructor for TagAttributeInfo. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor).

Parameters:
name - The name of the attribute.
required - If this attribute is required in tag instances.
type - The name of the type of the attribute.
reqTime - Whether this attribute holds a request-time Attribute.

TagAttributeInfo

public TagAttributeInfo(String name,
                        boolean required,
                        String type,
                        boolean reqTime,
                        boolean fragment)
JSP 2.0 Constructor for TagAttributeInfo. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor).

Parameters:
name - The name of the attribute.
required - If this attribute is required in tag instances.
type - The name of the type of the attribute.
reqTime - Whether this attribute holds a request-time Attribute.
fragment - Whether this attribute is of type JspFragment
Since:
JSP 2.0

TagAttributeInfo

public TagAttributeInfo(String name,
                        boolean required,
                        String type,
                        boolean reqTime,
                        boolean fragment,
                        String description,
                        boolean deferredValue,
                        boolean deferredMethod,
                        String expectedTypeName,
                        String methodSignature)
JSP 2.1 Constructor for TagAttributeInfo. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor).

Parameters:
name - The name of the attribute.
required - If this attribute is required in tag instances.
type - The name of the type of the attribute.
reqTime - Whether this attribute holds a request-time Attribute.
fragment - Whether this attribute is of type JspFragment
description - The description of the attribute.
deferredValue - Whether this attribute is a deferred value.
deferredMethod - Whether this attribute is a deferred method. rtexpr or deferred value.
expectedTypeName - The name of the expected type of this deferred value (or null if this is not a deferred value).
methodSignature - The expected method signature of this deferred method (or null if this is not a deferred method).
Since:
JSP 2.1
Method Detail

getName

public String getName()
The name of this attribute.

Returns:
the name of the attribute

getTypeName

public String getTypeName()
The type (as a String) of this attribute.

This method must return "javax.el.ValueExpression" if isDeferredValue() returns true and canBeRequestTime() returns false. It must return "javax.el.MethodExpression" if isDeferredMethod() returns true. It must return "java.lang.Object" if isDeferredValue() returns true and canBeRequestTime() returns true.

Returns:
the type of the attribute

canBeRequestTime

public boolean canBeRequestTime()
Whether this attribute has been specified in the TLD as rtexprvalue. If true, this means the attribute can hold a request-time value.

Returns:
true if the attribute has been specified in the TLD as rtexprvalue

isRequired

public boolean isRequired()
Whether this attribute is required.

Returns:
if the attribute is required.

getIdAttribute

public static TagAttributeInfo getIdAttribute(TagAttributeInfo[] a)
Convenience static method that goes through an array of TagAttributeInfo objects and looks for "id".

Parameters:
a - An array of TagAttributeInfo
Returns:
The TagAttributeInfo reference with name "id"

isFragment

public boolean isFragment()
Whether this attribute is of type JspFragment.

Returns:
if the attribute is of type JspFragment
Since:
JSP 2.0

getDescription

public String getDescription()
Gets the description string of this tag attribute.

Returns:
the description string of this tag attribute

isDeferredValue

public boolean isDeferredValue()
Returns true if this attribute is to be passed a ValueExpression so that expression evaluation can be deferred.

If this method returns true, then getTypeName() must return "javax.el.ValueExpression".

The getExpectedType() method can be used to retrieve the expected type this value expression will be constructed with.

Returns:
true if this attribute accepts a deferred value; false otherwise.
Since:
JSP 2.1

isDeferredMethod

public boolean isDeferredMethod()
Returns true if this attribute is to be passed a MethodExpression so that expression evaluation can be deferred.

If this method returns true, then getTypeName() must return "javax.el.MethodExpression".

The getMethodSignature() method can be used to retrieve the expected method signature this method expression will be constructed with.

Returns:
true if this attribute accepts a deferred method; false otherwise.
Since:
JSP 2.1

getExpectedTypeName

public String getExpectedTypeName()
Returns the name of the expected type (as a String) of this deferred value attribute.

This method returns null if isDeferredValue() returns false.

Returns:
the name of the expected type
Since:
JSP 2.1

getMethodSignature

public String getMethodSignature()
Returns the expected method signature of this deferred method attribute.

This method returns null if isDeferredMethod() returns false.

Returns:
the method signature
Since:
JSP 2.1

toString

public String toString()
Returns a String representation of this TagAttributeInfo, suitable for debugging purposes.

Overrides:
toString in class Object
Returns:
a String representation of this TagAttributeInfo
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TagData

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagData

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagData
All Implemented Interfaces:
Cloneable
public class TagData
extends Object
implements Cloneable

The (translation-time only) attribute/value information for a tag instance.

TagData is only used as an argument to the isValid, validate, and getVariableInfo methods of TagExtraInfo, which are invoked at translation time.

Field Summary
static Object REQUEST_TIME_VALUE
Distinguished value for an attribute to indicate its value is a request-time expression (which is not yet available because TagData instances are used at translation-time).
Constructor Summary
TagData(Hashtable<String,Object> attrs)
Constructor for a TagData.
TagData(Object[][] atts)
Constructor for TagData.
Method Summary
Object | getAttribute(String attName) The value of the attribute.
Enumeration<String> | getAttributes() Enumerates the attributes.
String | getAttributeString(String attName) Get the value for a given attribute.
String | getId() The value of the tag's id attribute.
void | setAttribute(String attName, Object value) Set the value of an attribute.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

REQUEST_TIME_VALUE

public static final Object REQUEST_TIME_VALUE
Distinguished value for an attribute to indicate its value is a request-time expression (which is not yet available because TagData instances are used at translation-time).

Constructor Detail

TagData

public TagData(Object[][] atts)
Constructor for TagData.

A typical constructor may be

 static final Object[][] att = {{"connection", "conn0"}, {"id", "query0"}};
 static final TagData td = new TagData(att);
All values must be Strings except for those holding the distinguished object REQUEST_TIME_VALUE.

Parameters:
atts - the static attribute and values. May be null.

TagData

public TagData(Hashtable<String,Object> attrs)
Constructor for a TagData. If you already have the attributes in a hashtable, use this constructor.

Parameters:
attrs - A hashtable to get the values from.
Method Detail

getId

public String getId()
The value of the tag's id attribute.

Returns:
the value of the tag's id attribute, or null if no such attribute was specified.

getAttribute

public Object getAttribute(String attName)
The value of the attribute. If a static value is specified for an attribute that accepts a request-time attribute expression then that static value is returned, even if the value is provided in the body of a <jsp:attribute> action. The distinguished object REQUEST_TIME_VALUE is only returned if the value is specified as a request-time attribute expression or via the <jsp:attribute> action with a body that contains dynamic content (scriptlets, scripting expressions, EL expressions, standard actions, or custom actions). Returns null if the attribute is not set.

Parameters:
attName - the name of the attribute
Returns:
the attribute's value

setAttribute

public void setAttribute(String attName,
                         Object value)
Set the value of an attribute.

Parameters:
attName - the name of the attribute
value - the value.

getAttributeString

public String getAttributeString(String attName)
Get the value for a given attribute.

Parameters:
attName - the name of the attribute
Returns:
the attribute value string
Throws:
ClassCastException - if attribute value is not a String

getAttributes

public Enumeration<String> getAttributes()
Enumerates the attributes.

Returns:
An enumeration of the attributes in a TagData
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TagExtraInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagExtraInfo

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagExtraInfo

public abstract class TagExtraInfo
extends Object

Optional class provided by the tag library author to describe additional translation-time information not described in the TLD. The TagExtraInfo class is mentioned in the Tag Library Descriptor file (TLD).

This class can be used:

  • to indicate that the tag defines scripting variables
  • to perform translation-time validation of the tag attributes.

It is the responsibility of the JSP translator that the initial value to be returned by calls to getTagInfo() corresponds to a TagInfo object for the tag being translated. If an explicit call to setTagInfo() is done, then the object passed will be returned in subsequent calls to getTagInfo().

The only way to affect the value returned by getTagInfo() is through a setTagInfo() call, and thus, TagExtraInfo.setTagInfo() is to be called by the JSP translator, with a TagInfo object that corresponds to the tag being translated. The call should happen before any invocation on validate() and before any invocation on getVariableInfo().

NOTE: It is a (translation time) error for a tag definition in a TLD with one or more variable subelements to have an associated TagExtraInfo implementation that returns a VariableInfo array with one or more elements from a call to getVariableInfo().

Constructor Summary
TagExtraInfo()
Sole constructor.
Method Summary
TagInfo | getTagInfo() Get the TagInfo for this class.
VariableInfo[] | getVariableInfo(TagData data) information on scripting variables defined by the tag associated with this TagExtraInfo instance.
boolean | isValid(TagData data) Translation-time validation of the attributes.
void | setTagInfo(TagInfo tagInfo) Set the TagInfo for this class.
ValidationMessage[] | validate(TagData data) Translation-time validation of the attributes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TagExtraInfo

public TagExtraInfo()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

getVariableInfo

public VariableInfo[] getVariableInfo(TagData data)
information on scripting variables defined by the tag associated with this TagExtraInfo instance. Request-time attributes are indicated as such in the TagData parameter.

Parameters:
data - The TagData instance.
Returns:
An array of VariableInfo data, or null or a zero length array if no scripting variables are to be defined.

isValid

public boolean isValid(TagData data)
Translation-time validation of the attributes. Request-time attributes are indicated as such in the TagData parameter. Note that the preferred way to do validation is with the validate() method, since it can return more detailed information.

Parameters:
data - The TagData instance.
Returns:
Whether this tag instance is valid.
See Also:
validate(javax.servlet.jsp.tagext.TagData)

validate

public ValidationMessage[] validate(TagData data)
Translation-time validation of the attributes. Request-time attributes are indicated as such in the TagData parameter. Because of the higher quality validation messages possible, this is the preferred way to do validation (although isValid() still works).

JSP 2.0 and higher containers call validate() instead of isValid(). The default implementation of this method is to call isValid(). If isValid() returns false, a generic ValidationMessage[] is returned indicating isValid() returned false.

Parameters:
data - The TagData instance.
Returns:
A null object, or zero length array if no errors, an array of ValidationMessages otherwise.
Since:
JSP 2.0

setTagInfo

public final void setTagInfo(TagInfo tagInfo)
Set the TagInfo for this class.

Parameters:
tagInfo - The TagInfo this instance is extending

getTagInfo

public final TagInfo getTagInfo()
Get the TagInfo for this class.

Returns:
the taginfo instance this instance is extending
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TagFileInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagFileInfo

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagFileInfo

public class TagFileInfo
extends Object

Tag information for a tag file in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.

Since:
JSP 2.0

Constructor Summary
TagFileInfo(String name, String path, TagInfo tagInfo)
Constructor for TagFileInfo from data in the JSP 2.0 format for TLD.
Method Summary
String | getName() The unique action name of this tag.
String | getPath() Where to find the .tag file implementing this action.
TagInfo | getTagInfo() Returns information about this tag, parsed from the directives in the tag file.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TagFileInfo

public TagFileInfo(String name,
                   String path,
                   TagInfo tagInfo)
Constructor for TagFileInfo from data in the JSP 2.0 format for TLD. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor). Note that, since TagLibibraryInfo reflects both TLD information and taglib directive information, a TagFileInfo instance is dependent on a taglib directive. This is probably a design error, which may be fixed in the future.

Parameters:
name - The unique action name of this tag
path - Where to find the .tag file implementing this action, relative to the location of the TLD file.
tagInfo - The detailed information about this tag, as parsed from the directives in the tag file.
Method Detail

getName

public String getName()
The unique action name of this tag.

Returns:
The (short) name of the tag.

getPath

public String getPath()
Where to find the .tag file implementing this action.

Returns:
The path of the tag file, relative to the TLD, or "." if the tag file was defined in an implicit tag file.

getTagInfo

public TagInfo getTagInfo()
Returns information about this tag, parsed from the directives in the tag file.

Returns:
a TagInfo object containing information about this tag
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TagInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagInfo

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagInfo

public class TagInfo
extends Object

Tag information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time.

Field Summary
static String | BODY_CONTENT_EMPTY Static constant for getBodyContent() when it is empty.
static String | BODY_CONTENT_JSP Static constant for getBodyContent() when it is JSP.
static String | BODY_CONTENT_SCRIPTLESS Static constant for getBodyContent() when it is scriptless.
static String | BODY_CONTENT_TAG_DEPENDENT Static constant for getBodyContent() when it is Tag dependent.
Constructor Summary
TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo)
Constructor for TagInfo from data in the JSP 1.1 format for TLD.
TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi)
Constructor for TagInfo from data in the JSP 1.2 format for TLD.
TagInfo(String tagName, String tagClassName, String bodycontent, String infoString, TagLibraryInfo taglib, TagExtraInfo tagExtraInfo, TagAttributeInfo[] attributeInfo, String displayName, String smallIcon, String largeIcon, TagVariableInfo[] tvi, boolean dynamicAttributes)
Constructor for TagInfo from data in the JSP 2.0 format for TLD.
Method Summary
TagAttributeInfo[] | getAttributes() Attribute information (in the TLD) on this tag.
String | getBodyContent() The bodycontent information for this tag.
String | getDisplayName() Get the displayName.
String | getInfoString() The information string for the tag.
String | getLargeIcon() Get the path to the large icon.
String | getSmallIcon() Get the path to the small icon.
String | getTagClassName() Name of the class that provides the handler for this tag.
TagExtraInfo | getTagExtraInfo() The instance (if any) for extra tag information.
TagLibraryInfo | getTagLibrary() The instance of TabLibraryInfo we belong to.
String | getTagName() The name of the Tag.
TagVariableInfo[] | getTagVariableInfos() Get TagVariableInfo objects associated with this TagInfo.
VariableInfo[] | getVariableInfo(TagData data) Information on the scripting objects created by this tag at runtime.
boolean | hasDynamicAttributes() Get dynamicAttributes associated with this TagInfo.
boolean | isValid(TagData data) Translation-time validation of the attributes.
void | setTagExtraInfo(TagExtraInfo tei) Set the instance for extra tag information.
void | setTagLibrary(TagLibraryInfo tl) Set the TagLibraryInfo property.
ValidationMessage[] | validate(TagData data) Translation-time validation of the attributes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

BODY_CONTENT_JSP

public static final String BODY_CONTENT_JSP
Static constant for getBodyContent() when it is JSP.

See Also:
Constant Field Values

BODY_CONTENT_TAG_DEPENDENT

public static final String BODY_CONTENT_TAG_DEPENDENT
Static constant for getBodyContent() when it is Tag dependent.

See Also:
Constant Field Values

BODY_CONTENT_EMPTY

public static final String BODY_CONTENT_EMPTY
Static constant for getBodyContent() when it is empty.

See Also:
Constant Field Values

BODY_CONTENT_SCRIPTLESS

public static final String BODY_CONTENT_SCRIPTLESS
Static constant for getBodyContent() when it is scriptless.

Since:
JSP 2.0
See Also:
Constant Field Values
Constructor Detail

TagInfo

public TagInfo(String tagName,
               String tagClassName,
               String bodycontent,
               String infoString,
               TagLibraryInfo taglib,
               TagExtraInfo tagExtraInfo,
               TagAttributeInfo[] attributeInfo)
Constructor for TagInfo from data in the JSP 1.1 format for TLD. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor). Note that, since TagLibibraryInfo reflects both TLD information and taglib directive information, a TagInfo instance is dependent on a taglib directive. This is probably a design error, which may be fixed in the future.

Parameters:
tagName - The name of this tag
tagClassName - The name of the tag handler class
bodycontent - Information on the body content of these tags
infoString - The (optional) string information for this tag
taglib - The instance of the tag library that contains us.
tagExtraInfo - The instance providing extra Tag info. May be null
attributeInfo - An array of AttributeInfo data from descriptor. May be null;

TagInfo

public TagInfo(String tagName,
               String tagClassName,
               String bodycontent,
               String infoString,
               TagLibraryInfo taglib,
               TagExtraInfo tagExtraInfo,
               TagAttributeInfo[] attributeInfo,
               String displayName,
               String smallIcon,
               String largeIcon,
               TagVariableInfo[] tvi)
Constructor for TagInfo from data in the JSP 1.2 format for TLD. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor). Note that, since TagLibibraryInfo reflects both TLD information and taglib directive information, a TagInfo instance is dependent on a taglib directive. This is probably a design error, which may be fixed in the future.

Parameters:
tagName - The name of this tag
tagClassName - The name of the tag handler class
bodycontent - Information on the body content of these tags
infoString - The (optional) string information for this tag
taglib - The instance of the tag library that contains us.
tagExtraInfo - The instance providing extra Tag info. May be null
attributeInfo - An array of AttributeInfo data from descriptor. May be null;
displayName - A short name to be displayed by tools
smallIcon - Path to a small icon to be displayed by tools
largeIcon - Path to a large icon to be displayed by tools
tvi - An array of a TagVariableInfo (or null)

TagInfo

public TagInfo(String tagName,
               String tagClassName,
               String bodycontent,
               String infoString,
               TagLibraryInfo taglib,
               TagExtraInfo tagExtraInfo,
               TagAttributeInfo[] attributeInfo,
               String displayName,
               String smallIcon,
               String largeIcon,
               TagVariableInfo[] tvi,
               boolean dynamicAttributes)
Constructor for TagInfo from data in the JSP 2.0 format for TLD. This class is to be instantiated only from the TagLibrary code under request from some JSP code that is parsing a TLD (Tag Library Descriptor). Note that, since TagLibibraryInfo reflects both TLD information and taglib directive information, a TagInfo instance is dependent on a taglib directive. This is probably a design error, which may be fixed in the future.

Parameters:
tagName - The name of this tag
tagClassName - The name of the tag handler class
bodycontent - Information on the body content of these tags
infoString - The (optional) string information for this tag
taglib - The instance of the tag library that contains us.
tagExtraInfo - The instance providing extra Tag info. May be null
attributeInfo - An array of AttributeInfo data from descriptor. May be null;
displayName - A short name to be displayed by tools
smallIcon - Path to a small icon to be displayed by tools
largeIcon - Path to a large icon to be displayed by tools
tvi - An array of a TagVariableInfo (or null)
dynamicAttributes - True if supports dynamic attributes
Since:
JSP 2.0
Method Detail

getTagName

public String getTagName()
The name of the Tag.

Returns:
The (short) name of the tag.

getAttributes

public TagAttributeInfo[] getAttributes()
Attribute information (in the TLD) on this tag. The return is an array describing the attributes of this tag, as indicated in the TLD.

Returns:
The array of TagAttributeInfo for this tag, or a zero-length array if the tag has no attributes.

getVariableInfo

public VariableInfo[] getVariableInfo(TagData data)
Information on the scripting objects created by this tag at runtime. This is a convenience method on the associated TagExtraInfo class.

Parameters:
data - TagData describing this action.
Returns:
if a TagExtraInfo object is associated with this TagInfo, the result of getTagExtraInfo().getVariableInfo( data ), otherwise null.

isValid

public boolean isValid(TagData data)
Translation-time validation of the attributes. This is a convenience method on the associated TagExtraInfo class.

Parameters:
data - The translation-time TagData instance.
Returns:
Whether the data is valid.

validate

public ValidationMessage[] validate(TagData data)
Translation-time validation of the attributes. This is a convenience method on the associated TagExtraInfo class.

Parameters:
data - The translation-time TagData instance.
Returns:
A null object, or zero length array if no errors, an array of ValidationMessages otherwise.
Since:
JSP 2.0

setTagExtraInfo

public void setTagExtraInfo(TagExtraInfo tei)
Set the instance for extra tag information.

Parameters:
tei - the TagExtraInfo instance

getTagExtraInfo

public TagExtraInfo getTagExtraInfo()
The instance (if any) for extra tag information.

Returns:
The TagExtraInfo instance, if any.

getTagClassName

public String getTagClassName()
Name of the class that provides the handler for this tag.

Returns:
The name of the tag handler class.

getBodyContent

public String getBodyContent()
The bodycontent information for this tag. If the bodycontent is not defined for this tag, the default of JSP will be returned.

Returns:
the body content string.

getInfoString

public String getInfoString()
The information string for the tag.

Returns:
the info string, or null if not defined

setTagLibrary

public void setTagLibrary(TagLibraryInfo tl)
Set the TagLibraryInfo property. Note that a TagLibraryInfo element is dependent not just on the TLD information but also on the specific taglib instance used. This means that a fair amount of work needs to be done to construct and initialize TagLib objects. If used carefully, this setter can be used to avoid having to create new TagInfo elements for each taglib directive.

Parameters:
tl - the TagLibraryInfo to assign

getTagLibrary

public TagLibraryInfo getTagLibrary()
The instance of TabLibraryInfo we belong to.

Returns:
the tag library instance we belong to

getDisplayName

public String getDisplayName()
Get the displayName.

Returns:
A short name to be displayed by tools, or null if not defined

getSmallIcon

public String getSmallIcon()
Get the path to the small icon.

Returns:
Path to a small icon to be displayed by tools, or null if not defined

getLargeIcon

public String getLargeIcon()
Get the path to the large icon.

Returns:
Path to a large icon to be displayed by tools, or null if not defined

getTagVariableInfos

public TagVariableInfo[] getTagVariableInfos()
Get TagVariableInfo objects associated with this TagInfo.

Returns:
Array of TagVariableInfo objects corresponding to variables declared by this tag, or a zero length array if no variables have been declared

hasDynamicAttributes

public boolean hasDynamicAttributes()
Get dynamicAttributes associated with this TagInfo.

Returns:
True if tag handler supports dynamic attributes
Since:
JSP 2.0
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TagLibraryInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagLibraryInfo

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagLibraryInfo

public abstract class TagLibraryInfo
extends Object

Translation-time information associated with a taglib directive, and its underlying TLD file. Most of the information is directly from the TLD, except for the prefix and the uri values used in the taglib directive

Field Summary
protected FunctionInfo[] | functions An array describing the functions that are defined in this tag library.
protected String | info Information (documentation) for this TLD.
protected String | jspversion The version of the JSP specification this tag library is written to.
protected String | prefix The prefix assigned to this taglib from the taglib directive.
protected String | shortname The preferred short name (prefix) as indicated in the TLD.
protected TagFileInfo[] | tagFiles An array describing the tag files that are defined in this tag library.
protected TagInfo[] | tags An array describing the tags that are defined in this tag library.
protected String | tlibversion The version of the tag library.
protected String | uri The value of the uri attribute from the taglib directive for this library.
protected String | urn The "reliable" URN indicated in the TLD.
Constructor Summary
protected TagLibraryInfo(String prefix, String uri)
Constructor.
Method Summary
FunctionInfo | getFunction(String name) Get the FunctionInfo for a given function name, looking through all the functions in this tag library.
FunctionInfo[] | getFunctions() An array describing the functions that are defined in this tag library.
String | getInfoString() Information (documentation) for this TLD.
String | getPrefixString() The prefix assigned to this taglib from the taglib directive
String | getReliableURN() The "reliable" URN indicated in the TLD (the uri element).
String | getRequiredVersion() A string describing the required version of the JSP container.
String | getShortName() The preferred short name (prefix) as indicated in the TLD.
TagInfo | getTag(String shortname) Get the TagInfo for a given tag name, looking through all the tags in this tag library.
TagFileInfo | getTagFile(String shortname) Get the TagFileInfo for a given tag name, looking through all the tag files in this tag library.
TagFileInfo[] | getTagFiles() An array describing the tag files that are defined in this tag library.
abstract TagLibraryInfo[] | getTagLibraryInfos() Returns an array of TagLibraryInfo objects representing the entire set of tag libraries (including this TagLibraryInfo) imported by taglib directives in the translation unit that references this TagLibraryInfo.
TagInfo[] | getTags() An array describing the tags that are defined in this tag library.
String | getURI() The value of the uri attribute from the taglib directive for this library.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

prefix

protected String prefix
The prefix assigned to this taglib from the taglib directive.

uri

protected String uri
The value of the uri attribute from the taglib directive for this library.

tags

protected TagInfo[] tags
An array describing the tags that are defined in this tag library.

tagFiles

protected TagFileInfo[] tagFiles
An array describing the tag files that are defined in this tag library.

Since:
JSP 2.0

functions

protected FunctionInfo[] functions
An array describing the functions that are defined in this tag library.

Since:
JSP 2.0

tlibversion

protected String tlibversion
The version of the tag library.

jspversion

protected String jspversion
The version of the JSP specification this tag library is written to.

shortname

protected String shortname
The preferred short name (prefix) as indicated in the TLD.

urn

protected String urn
The "reliable" URN indicated in the TLD.

info

protected String info
Information (documentation) for this TLD.

Constructor Detail

TagLibraryInfo

protected TagLibraryInfo(String prefix,
                         String uri)
Constructor.

Parameters:
prefix - the prefix actually used by the taglib directive
uri - the URI actually used by the taglib directive
Method Detail

getURI

public String getURI()
The value of the uri attribute from the taglib directive for this library.

Returns:
the value of the uri attribute

getPrefixString

public String getPrefixString()
The prefix assigned to this taglib from the taglib directive

Returns:
the prefix assigned to this taglib from the taglib directive

getShortName

public String getShortName()
The preferred short name (prefix) as indicated in the TLD. This may be used by authoring tools as the preferred prefix to use when creating an taglib directive for this library.

Returns:
the preferred short name for the library

getReliableURN

public String getReliableURN()
The "reliable" URN indicated in the TLD (the uri element). This may be used by authoring tools as a global identifier to use when creating a taglib directive for this library.

Returns:
a reliable URN to a TLD like this

getInfoString

public String getInfoString()
Information (documentation) for this TLD.

Returns:
the info string for this tag lib

getRequiredVersion

public String getRequiredVersion()
A string describing the required version of the JSP container.

Returns:
the (minimal) required version of the JSP container.
See Also:
JspEngineInfo

getTags

public TagInfo[] getTags()
An array describing the tags that are defined in this tag library.

Returns:
the TagInfo objects corresponding to the tags defined by this tag library, or a zero length array if this tag library defines no tags

getTagFiles

public TagFileInfo[] getTagFiles()
An array describing the tag files that are defined in this tag library.

Returns:
the TagFileInfo objects corresponding to the tag files defined by this tag library, or a zero length array if this tag library defines no tags files
Since:
JSP 2.0

getTag

public TagInfo getTag(String shortname)
Get the TagInfo for a given tag name, looking through all the tags in this tag library.

Parameters:
shortname - The short name (no prefix) of the tag
Returns:
the TagInfo for the tag with the specified short name, or null if no such tag is found

getTagFile

public TagFileInfo getTagFile(String shortname)
Get the TagFileInfo for a given tag name, looking through all the tag files in this tag library.

Parameters:
shortname - The short name (no prefix) of the tag
Returns:
the TagFileInfo for the specified Tag file, or null if no Tag file is found
Since:
JSP 2.0

getFunctions

public FunctionInfo[] getFunctions()
An array describing the functions that are defined in this tag library.

Returns:
the functions defined in this tag library, or a zero length array if the tag library defines no functions.
Since:
JSP 2.0

getFunction

public FunctionInfo getFunction(String name)
Get the FunctionInfo for a given function name, looking through all the functions in this tag library.

Parameters:
name - The name (no prefix) of the function
Returns:
the FunctionInfo for the function with the given name, or null if no such function exists
Since:
JSP 2.0

getTagLibraryInfos

public abstract TagLibraryInfo[] getTagLibraryInfos()
Returns an array of TagLibraryInfo objects representing the entire set of tag libraries (including this TagLibraryInfo) imported by taglib directives in the translation unit that references this TagLibraryInfo. If a tag library is imported more than once and bound to different prefices, only the TagLibraryInfo bound to the first prefix must be included in the returned array.

Returns:
Array of TagLibraryInfo objects representing the entire set of tag libraries (including this TagLibraryInfo) imported by taglib directives in the translation unit that references this TagLibraryInfo.
Since:
JSP 2.1
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TagLibraryValidator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagLibraryValidator

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagLibraryValidator

public abstract class TagLibraryValidator
extends Object

Translation-time validator class for a JSP page. A validator operates on the XML view associated with the JSP page.

The TLD file associates a TagLibraryValidator class and some init arguments with a tag library.

The JSP container is reponsible for locating an appropriate instance of the appropriate subclass by

  • new a fresh instance, or reuse an available one
  • invoke the setInitParams(Map) method on the instance
once initialized, the validate(String, String, PageData) method will be invoked, where the first two arguments are the prefix and uri for this tag library in the XML View. The prefix is intended to make it easier to produce an error message. However, it is not always accurate. In the case where a single URI is mapped to more than one prefix in the XML view, the prefix of the first URI is provided. Therefore, to provide high quality error messages in cases where the tag elements themselves are checked, the prefix parameter should be ignored and the actual prefix of the element should be used instead. TagLibraryValidators should always use the uri to identify elements as beloning to the tag library, not the prefix.

A TagLibraryValidator instance may create auxiliary objects internally to perform the validation (e.g. an XSchema validator) and may reuse it for all the pages in a given translation run.

The JSP container is not guaranteed to serialize invocations of validate() method, and TagLibraryValidators should perform any synchronization they may require.

As of JSP 2.0, a JSP container must provide a jsp:id attribute to provide higher quality validation errors. The container will track the JSP pages as passed to the container, and will assign to each element a unique "id", which is passed as the value of the jsp:id attribute. Each XML element in the XML view available will be extended with this attribute. The TagLibraryValidator can then use the attribute in one or more ValidationMessage objects. The container then, in turn, can use these values to provide more precise information on the location of an error.

The actual prefix of the id attribute may or may not be jsp but it will always map to the namespace http://java.sun.com/JSP/Page. A TagLibraryValidator implementation must rely on the uri, not the prefix, of the id attribute.

Constructor Summary
TagLibraryValidator()
Sole constructor.
Method Summary
Map<String,Object> | getInitParameters() Get the init parameters data as an immutable Map.
void | release() Release any data kept by this instance for validation purposes.
void | setInitParameters(Map<String,Object> map) Set the init data in the TLD for this validator.
ValidationMessage[] | validate(String prefix, String uri, PageData page) Validate a JSP page.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TagLibraryValidator

public TagLibraryValidator()
Sole constructor. (For invocation by subclass constructors, typically implicit.)

Method Detail

setInitParameters

public void setInitParameters(Map<String,Object> map)
Set the init data in the TLD for this validator. Parameter names are keys, and parameter values are the values.

Parameters:
map - A Map describing the init parameters

getInitParameters

public Map<String,Object> getInitParameters()
Get the init parameters data as an immutable Map. Parameter names are keys, and parameter values are the values.

Returns:
The init parameters as an immutable map.

validate

public ValidationMessage[] validate(String prefix,
                                    String uri,
                                    PageData page)
Validate a JSP page. This will get invoked once per unique tag library URI in the XML view. This method will return null if the page is valid; otherwise the method should return an array of ValidationMessage objects. An array of length zero is also interpreted as no errors.

Parameters:
prefix - the first prefix with which the tag library is associated, in the XML view. Note that some tags may use a different prefix if the namespace is redefined.
uri - the tag library's unique identifier
page - the JspData page object
Returns:
A null object, or zero length array if no errors, an array of ValidationMessages otherwise.

release

public void release()
Release any data kept by this instance for validation purposes.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TagSupport

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagSupport

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
All Implemented Interfaces:
Serializable, IterationTag, JspTag, Tag
Direct Known Subclasses:
AttributeTag, BodyTagSupport, ConverterELTag, ConverterTag, FacetTag, ValidatorELTag, ValidatorTag
public class TagSupport
extends Object
implements IterationTag, Serializable

A base class for defining new tag handlers implementing Tag.

The TagSupport class is a utility class intended to be used as the base class for new tag handlers. The TagSupport class implements the Tag and IterationTag interfaces and adds additional convenience methods including getter methods for the properties in Tag. TagSupport has one static method that is included to facilitate coordination among cooperating tags.

Many tag handlers will extend TagSupport and only redefine a few methods.

See Also:
Serialized Form

Field Summary
protected String | id The value of the id attribute of this tag; or null.
protected PageContext | pageContext The PageContext.
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
TagSupport()
Default constructor, all subclasses are required to define only a public constructor with the same signature, and to call the superclass constructor.
Method Summary
int | doAfterBody() Default processing for a body.
int | doEndTag() Default processing of the end tag returning EVAL_PAGE.
int | doStartTag() Default processing of the start tag, returning SKIP_BODY.
static Tag | findAncestorWithClass(Tag from, Class klass) Find the instance of a given class type that is closest to a given instance.
String | getId() The value of the id attribute of this tag; or null.
Tag | getParent() The Tag instance most closely enclosing this tag instance.
Object | getValue(String k) Get a the value associated with a key.
Enumeration<String> | getValues() Enumerate the keys for the values kept by this tag handler.
void | release() Release state.
void | removeValue(String k) Remove a value associated with a key.
void | setId(String id) Set the id attribute for this tag.
void | setPageContext(PageContext pageContext) Set the page context.
void | setParent(Tag t) Set the nesting tag of this tag.
void | setValue(String k, Object o) Associate a value with a String key.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

id

protected String id
The value of the id attribute of this tag; or null.

pageContext

protected PageContext pageContext
The PageContext.

Constructor Detail

TagSupport

public TagSupport()
Default constructor, all subclasses are required to define only a public constructor with the same signature, and to call the superclass constructor. This constructor is called by the code generated by the JSP translator.

Method Detail

findAncestorWithClass

public static final Tag findAncestorWithClass(Tag from,
                                              Class klass)
Find the instance of a given class type that is closest to a given instance. This method uses the getParent method from the Tag interface. This method is used for coordination among cooperating tags.

The current version of the specification only provides one formal way of indicating the observable type of a tag handler: its tag handler implementation class, described in the tag-class subelement of the tag element. This is extended in an informal manner by allowing the tag library author to indicate in the description subelement an observable type. The type should be a subtype of the tag handler implementation class or void. This addititional constraint can be exploited by a specialized container that knows about that specific tag library, as in the case of the JSP standard tag library.

When a tag library author provides information on the observable type of a tag handler, client programmatic code should adhere to that constraint. Specifically, the Class passed to findAncestorWithClass should be a subtype of the observable type.

Parameters:
from - The instance from where to start looking.
klass - The subclass of Tag or interface to be matched
Returns:
the nearest ancestor that implements the interface or is an instance of the class specified

doStartTag

public int doStartTag()
               throws JspException
Default processing of the start tag, returning SKIP_BODY.

Specified by:
doStartTag in interface Tag
Returns:
SKIP_BODY
Throws:
JspException - if an error occurs while processing this tag
See Also:
Tag.doStartTag()

doEndTag

public int doEndTag()
             throws JspException
Default processing of the end tag returning EVAL_PAGE.

Specified by:
doEndTag in interface Tag
Returns:
EVAL_PAGE
Throws:
JspException - if an error occurs while processing this tag
See Also:
Tag.doEndTag()

doAfterBody

public int doAfterBody()
                throws JspException
Default processing for a body.

Specified by:
doAfterBody in interface IterationTag
Returns:
SKIP_BODY
Throws:
JspException - if an error occurs while processing this tag
See Also:
IterationTag.doAfterBody()

release

public void release()
Release state.

Specified by:
release in interface Tag
See Also:
Tag.release()

setParent

public void setParent(Tag t)
Set the nesting tag of this tag.

Specified by:
setParent in interface Tag
Parameters:
t - The parent Tag.
See Also:
Tag.setParent(Tag)

getParent

public Tag getParent()
The Tag instance most closely enclosing this tag instance.

Specified by:
getParent in interface Tag
Returns:
the parent tag instance or null
See Also:
Tag.getParent()

setId

public void setId(String id)
Set the id attribute for this tag.

Parameters:
id - The String for the id.

getId

public String getId()
The value of the id attribute of this tag; or null.

Returns:
the value of the id attribute, or null

setPageContext

public void setPageContext(PageContext pageContext)
Set the page context.

Specified by:
setPageContext in interface Tag
Parameters:
pageContext - The PageContext.
See Also:
Tag.setPageContext(javax.servlet.jsp.PageContext)

setValue

public void setValue(String k,
                     Object o)
Associate a value with a String key.

Parameters:
k - The key String.
o - The value to associate.

getValue

public Object getValue(String k)
Get a the value associated with a key.

Parameters:
k - The string key.
Returns:
The value associated with the key, or null.

removeValue

public void removeValue(String k)
Remove a value associated with a key.

Parameters:
k - The string key.

getValues

public Enumeration<String> getValues()
Enumerate the keys for the values kept by this tag handler.

Returns:
An enumeration of all the keys for the values set, or null or an empty Enumeration if no values have been set.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TagVariableInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class TagVariableInfo

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagVariableInfo

public class TagVariableInfo
extends Object

Variable information for a tag in a Tag Library; This class is instantiated from the Tag Library Descriptor file (TLD) and is available only at translation time. This object should be immutable. This information is only available in JSP 1.2 format TLDs or above.

Constructor Summary
TagVariableInfo(String nameGiven, String nameFromAttribute, String className, boolean declare, int scope)
Constructor for TagVariableInfo.
Method Summary
String | getClassName() The body of the <variable-class> element.
boolean | getDeclare() The body of the <declare> element.
String | getNameFromAttribute() The body of the <name-from-attribute> element.
String | getNameGiven() The body of the <name-given> element.
int | getScope() The body of the <scope> element.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TagVariableInfo

public TagVariableInfo(String nameGiven,
                       String nameFromAttribute,
                       String className,
                       boolean declare,
                       int scope)
Constructor for TagVariableInfo.

Parameters:
nameGiven - value of <name-given>
nameFromAttribute - value of <name-from-attribute>
className - value of <variable-class>
declare - value of <declare>
scope - value of <scope>
Method Detail

getNameGiven

public String getNameGiven()
The body of the <name-given> element.

Returns:
The variable name as a constant

getNameFromAttribute

public String getNameFromAttribute()
The body of the <name-from-attribute> element. This is the name of an attribute whose (translation-time) value will give the name of the variable. One of <name-given> or <name-from-attribute> is required.

Returns:
The attribute whose value defines the variable name

getClassName

public String getClassName()
The body of the <variable-class> element.

Returns:
The name of the class of the variable or 'java.lang.String' if not defined in the TLD.

getDeclare

public boolean getDeclare()
The body of the <declare> element.

Returns:
Whether the variable is to be declared or not. If not defined in the TLD, 'true' will be returned.

getScope

public int getScope()
The body of the <scope> element.

Returns:
The scope to give the variable. NESTED scope will be returned if not defined in the TLD.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TryCatchFinally

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Interface TryCatchFinally

public interface TryCatchFinally

The auxiliary interface of a Tag, IterationTag or BodyTag tag handler that wants additional hooks for managing resources.

This interface provides two new methods: doCatch(Throwable) and doFinally(). The prototypical invocation is as follows:

 h = get a Tag();  // get a tag handler, perhaps from pool

 h.setPageContext(pc);  // initialize as desired
 h.setParent(null);
 h.setFoo("foo");

 // tag invocation protocol; see Tag.java
 try {
   doStartTag()...
   ....
   doEndTag()...
 } catch (Throwable t) {
   // react to exceptional condition
   h.doCatch(t);
 } finally {
   // restore data invariants and release per-invocation resources
   h.doFinally();
 }

 ... other invocations perhaps with some new setters
 ...
 h.release();  // release long-term resources

Method Summary
 void doCatch(Throwable t)
Invoked if a Throwable occurs while evaluating the BODY inside a tag or in any of the following methods: Tag.doStartTag(), Tag.doEndTag(), IterationTag.doAfterBody() and BodyTag.doInitBody().
 void doFinally()
Invoked in all cases after doEndTag() for any class implementing Tag, IterationTag or BodyTag.

Method Detail

doCatch

void doCatch(Throwable t)
             throws Throwable
Invoked if a Throwable occurs while evaluating the BODY inside a tag or in any of the following methods: Tag.doStartTag(), Tag.doEndTag(), IterationTag.doAfterBody() and BodyTag.doInitBody().

This method is not invoked if the Throwable occurs during one of the setter methods.

This method may throw an exception (the same or a new one) that will be propagated further up the nest chain. If an exception is thrown, doFinally() will be invoked.

This method is intended to be used to respond to an exceptional condition.

Parameters:
t - The throwable exception navigating through this tag.
Throws:
Throwable - if the exception is to be rethrown further up the nest chain.

doFinally

void doFinally()
Invoked in all cases after doEndTag() for any class implementing Tag, IterationTag or BodyTag. This method is invoked even if an exception has occurred in the BODY of the tag, or in any of the following methods: Tag.doStartTag(), Tag.doEndTag(), IterationTag.doAfterBody() and BodyTag.doInitBody().

This method is not invoked if the Throwable occurs during one of the setter methods.

This method should not throw an Exception.

This method is intended to maintain per-invocation data integrity and resource management actions.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValidationMessage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class ValidationMessage

java.lang.Object
    extended by  javax.servlet.jsp.tagext.ValidationMessage

public class ValidationMessage
extends Object

A validation message from either TagLibraryValidator or TagExtraInfo.

As of JSP 2.0, a JSP container must support a jsp:id attribute to provide higher quality validation errors. The container will track the JSP pages as passed to the container, and will assign to each element a unique "id", which is passed as the value of the jsp:id attribute. Each XML element in the XML view available will be extended with this attribute. The TagLibraryValidator can then use the attribute in one or more ValidationMessage objects. The container then, in turn, can use these values to provide more precise information on the location of an error.

The actual prefix of the id attribute may or may not be jsp but it will always map to the namespace http://java.sun.com/JSP/Page. A TagLibraryValidator implementation must rely on the uri, not the prefix, of the id attribute.

Constructor Summary
ValidationMessage(String id, String message)
Create a ValidationMessage.
Method Summary
String | getId() Get the jsp:id.
String | getMessage() Get the localized validation message.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValidationMessage

public ValidationMessage(String id,
                         String message)
Create a ValidationMessage. The message String should be non-null. The value of id may be null, if the message is not specific to any XML element, or if no jsp:id attributes were passed on. If non-null, the value of id must be the value of a jsp:id attribute for the PageData passed into the validate() method.

Parameters:
id - Either null, or the value of a jsp:id attribute.
message - A localized validation message.
Method Detail

getId

public String getId()
Get the jsp:id. Null means that there is no information available.

Returns:
The jsp:id information.

getMessage

public String getMessage()
Get the localized validation message.

Returns:
A validation message
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


VariableInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet.jsp.tagext
Class VariableInfo

java.lang.Object
    extended by  javax.servlet.jsp.tagext.VariableInfo

public class VariableInfo
extends Object

Information on the scripting variables that are created/modified by a tag (at run-time). This information is provided by TagExtraInfo classes and it is used by the translation phase of JSP.

Scripting variables generated by a custom action have an associated scope of either AT_BEGIN, NESTED, or AT_END.

The class name (VariableInfo.getClassName) in the returned objects is used to determine the types of the scripting variables. Note that because scripting variables are assigned their values from scoped attributes which cannot be of primitive types, "boxed" types such as java.lang.Integer must be used instead of primitives.

The class name may be a Fully Qualified Class Name, or a short class name.

If a Fully Qualified Class Name is provided, it should refer to a class that should be in the CLASSPATH for the Web Application (see Servlet 2.4 specification - essentially it is WEB-INF/lib and WEB-INF/classes). Failure to be so will lead to a translation-time error.

If a short class name is given in the VariableInfo objects, then the class name must be that of a public class in the context of the import directives of the page where the custom action appears. The class must also be in the CLASSPATH for the Web Application (see Servlet 2.4 specification - essentially it is WEB-INF/lib and WEB-INF/classes). Failure to be so will lead to a translation-time error.

Usage Comments

Frequently a fully qualified class name will refer to a class that is known to the tag library and thus, delivered in the same JAR file as the tag handlers. In most other remaining cases it will refer to a class that is in the platform on which the JSP processor is built (like Java EE). Using fully qualified class names in this manner makes the usage relatively resistant to configuration errors.

A short name is usually generated by the tag library based on some attributes passed through from the custom action user (the author), and it is thus less robust: for instance a missing import directive in the referring JSP page will lead to an invalid short name class and a translation error.

Synchronization Protocol

The result of the invocation on getVariableInfo is an array of VariableInfo objects. Each such object describes a scripting variable by providing its name, its type, whether the variable is new or not, and what its scope is. Scope is best described through a picture:

NESTED, AT_BEGIN and AT_END Variable Scopes

The JSP 2.0 specification defines the interpretation of 3 values:

  • NESTED, if the scripting variable is available between the start tag and the end tag of the action that defines it.
  • AT_BEGIN, if the scripting variable is available from the start tag of the action that defines it until the end of the scope.
  • AT_END, if the scripting variable is available after the end tag of the action that defines it until the end of the scope.
The scope value for a variable implies what methods may affect its value and thus where synchronization is needed as illustrated by the table below. Note: the synchronization of the variable(s) will occur after the respective method has been called.
Variable Synchronization Points
doStartTag() doInitBody() doAfterBody() doEndTag() doTag()
Tag
         AT_BEGIN, NESTED

AT_BEGIN, AT_END
IterationTag
         AT_BEGIN, NESTED
AT_BEGIN, NESTED
 AT_BEGIN, AT_END
BodyTag
         AT_BEGIN, NESTED1
 AT_BEGIN, NESTED1
 AT_BEGIN, NESTED
 AT_BEGIN, AT_END
SimpleTag

AT_BEGIN, AT_END
1 Called after doStartTag() if EVAL_BODY_INCLUDE is returned, or after doInitBody() otherwise.

Variable Information in the TLD

Scripting variable information can also be encoded directly for most cases into the Tag Library Descriptor using the <variable> subelement of the <tag> element. See the JSP specification.

Field Summary
static int | AT_BEGIN Scope information that scripting variable is visible after start tag.
static int | AT_END Scope information that scripting variable is visible after end tag.
static int | NESTED Scope information that scripting variable is visible only within the start/end tags.
Constructor Summary
VariableInfo(String varName, String className, boolean declare, int scope)
Constructor These objects can be created (at translation time) by the TagExtraInfo instances.
Method Summary
String | getClassName() Returns the type of this variable.
boolean | getDeclare() Returns whether this is a new variable.
int | getScope() Returns the lexical scope of the variable.
String | getVarName() Returns the name of the scripting variable.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NESTED

public static final int NESTED
Scope information that scripting variable is visible only within the start/end tags.

See Also:
Constant Field Values

AT_BEGIN

public static final int AT_BEGIN
Scope information that scripting variable is visible after start tag.

See Also:
Constant Field Values

AT_END

public static final int AT_END
Scope information that scripting variable is visible after end tag.

See Also:
Constant Field Values
Constructor Detail

VariableInfo

public VariableInfo(String varName,
                    String className,
                    boolean declare,
                    int scope)
Constructor These objects can be created (at translation time) by the TagExtraInfo instances.

Parameters:
varName - The name of the scripting variable
className - The type of this variable
declare - If true, it is a new variable (in some languages this will require a declaration)
scope - Indication on the lexical scope of the variable
Method Detail

getVarName

public String getVarName()
Returns the name of the scripting variable.

Returns:
the name of the scripting variable

getClassName

public String getClassName()
Returns the type of this variable.

Returns:
the type of this variable

getDeclare

public boolean getDeclare()
Returns whether this is a new variable. If so, in some languages this will require a declaration.

Returns:
whether this is a new variable.

getScope

public int getScope()
Returns the lexical scope of the variable.

Returns:
the lexical scope of the variable, either AT_BEGIN, AT_END, or NESTED.
See Also:
AT_BEGIN, AT_END, NESTED
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RequestDispatcher

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface RequestDispatcher

public interface RequestDispatcher

Defines an object that receives requests from the client and sends them to any resource (such as a servlet, HTML file, or JSP file) on the server. The servlet container creates the RequestDispatcher object, which is used as a wrapper around a server resource located at a particular path or given by a particular name.

This interface is intended to wrap servlets, but a servlet container can create RequestDispatcher objects to wrap any type of resource.

Author:
Various
See Also:
ServletContext.getRequestDispatcher(java.lang.String),
ServletContext.getNamedDispatcher(java.lang.String),
ServletRequest.getRequestDispatcher(java.lang.String)

Method Summary
void | forward(ServletRequest request, ServletResponse response) Forwards a request from a servlet to another resource (servlet, JSP file, or HTML file) on the server.
void | include(ServletRequest request, ServletResponse response) Includes the content of a resource (servlet, JSP page, HTML file) in the response.

Method Detail

forward

void forward(ServletRequest request,
             ServletResponse response)
             throws ServletException,
                    IOException
Forwards a request from a servlet to another resource (servlet, JSP file, or HTML file) on the server. This method allows one servlet to do preliminary processing of a request and another resource to generate the response.

For a RequestDispatcher obtained via getRequestDispatcher(), the ServletRequest object has its path elements and parameters adjusted to match the path of the target resource.

forward should be called before the response has been committed to the client (before response body output has been flushed). If the response already has been committed, this method throws an IllegalStateException. Uncommitted output in the response buffer is automatically cleared before the forward.

The request and response parameters must be either the same objects as were passed to the calling servlet's service method or be subclasses of the ServletRequestWrapper or ServletResponseWrapper classes that wrap them.

Parameters:
request - a ServletRequest object that represents the request the client makes of the servlet
response - a ServletResponse object that represents the response the servlet returns to the client
Throws:
ServletException - if the target resource throws this exception
IOException - if the target resource throws this exception
IllegalStateException - if the response was already committed

include

void include(ServletRequest request,
             ServletResponse response)
             throws ServletException,
                    IOException
Includes the content of a resource (servlet, JSP page, HTML file) in the response. In essence, this method enables programmatic server-side includes.

The ServletResponse object has its path elements and parameters remain unchanged from the caller's. The included servlet cannot change the response status code or set headers; any attempt to make a change is ignored.

The request and response parameters must be either the same objects as were passed to the calling servlet's service method or be subclasses of the ServletRequestWrapper or ServletResponseWrapper classes that wrap them.

Parameters:
request - a ServletRequest object that contains the client's request
response - a ServletResponse object that contains the servlet's response
Throws:
ServletException - if the included resource throws this exception
IOException - if the included resource throws this exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Servlet

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface Servlet

All Known Subinterfaces:
HttpJspPage, JspPage
All Known Implementing Classes:
FacesServlet, GenericServlet, HttpServlet
public interface Servlet

Defines methods that all servlets must implement.

A servlet is a small Java program that runs within a Web server. Servlets receive and respond to requests from Web clients, usually across HTTP, the HyperText Transfer Protocol.

To implement this interface, you can write a generic servlet that extends javax.servlet.GenericServlet or an HTTP servlet that extends javax.servlet.http.HttpServlet.

This interface defines methods to initialize a servlet, to service requests, and to remove a servlet from the server. These are known as life-cycle methods and are called in the following sequence:

  1. The servlet is constructed, then initialized with the init method.
  2. Any calls from clients to the service method are handled.
  3. The servlet is taken out of service, then destroyed with the destroy method, then garbage collected and finalized.

In addition to the life-cycle methods, this interface provides the getServletConfig method, which the servlet can use to get any startup information, and the getServletInfo method, which allows the servlet to return basic information about itself, such as author, version, and copyright.

Author:
Various
See Also:
GenericServlet, HttpServlet

Method Summary
void | destroy() Called by the servlet container to indicate to a servlet that the servlet is being taken out of service.
ServletConfig | getServletConfig() Returns a ServletConfig object, which contains initialization and startup parameters for this servlet.
String | getServletInfo() Returns information about the servlet, such as author, version, and copyright.
void | init(ServletConfig config) Called by the servlet container to indicate to a servlet that the servlet is being placed into service.
void | service(ServletRequest req, ServletResponse res) Called by the servlet container to allow the servlet to respond to a request.

Method Detail

init

void init(ServletConfig config)
          throws ServletException
Called by the servlet container to indicate to a servlet that the servlet is being placed into service.

The servlet container calls the init method exactly once after instantiating the servlet. The init method must complete successfully before the servlet can receive any requests.

The servlet container cannot place the servlet into service if the init method

  1. Throws a ServletException
  2. Does not return within a time period defined by the Web server

Parameters:
config - a ServletConfig object containing the servlet's configuration and initialization parameters
Throws:
ServletException - if an exception has occurred that interferes with the servlet's normal operation
See Also:
UnavailableException, getServletConfig()

getServletConfig

ServletConfig getServletConfig()
Returns a ServletConfig object, which contains initialization and startup parameters for this servlet. The ServletConfig object returned is the one passed to the init method.

Implementations of this interface are responsible for storing the ServletConfig object so that this method can return it. The GenericServlet class, which implements this interface, already does this.

Returns:
the ServletConfig object that initializes this servlet
See Also:
init(javax.servlet.ServletConfig)

service

void service(ServletRequest req,
             ServletResponse res)
             throws ServletException,
                    IOException
Called by the servlet container to allow the servlet to respond to a request.

This method is only called after the servlet's init() method has completed successfully.

The status code of the response always should be set for a servlet that throws or sends an error.

Servlets typically run inside multithreaded servlet containers that can handle multiple requests concurrently. Developers must be aware to synchronize access to any shared resources such as files, network connections, and as well as the servlet's class and instance variables. More information on multithreaded programming in Java is available in the Java tutorial on multi-threaded programming.

Parameters:
req - the ServletRequest object that contains the client's request
res - the ServletResponse object that contains the servlet's response
Throws:
ServletException - if an exception occurs that interferes with the servlet's normal operation
IOException - if an input or output exception occurs

getServletInfo

String getServletInfo()
Returns information about the servlet, such as author, version, and copyright.

The string that this method returns should be plain text and not markup of any kind (such as HTML, XML, etc.).

Returns:
a String containing servlet information

destroy

void destroy()
Called by the servlet container to indicate to a servlet that the servlet is being taken out of service. This method is only called once all threads within the servlet's service method have exited or after a timeout period has passed. After the servlet container calls this method, it will not call the service method again on this servlet.

This method gives the servlet an opportunity to clean up any resources that are being held (for example, memory, file handles, threads) and make sure that any persistent state is synchronized with the servlet's current state in memory.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletConfig

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletConfig

All Known Implementing Classes:
GenericServlet, HttpServlet
public interface ServletConfig

A servlet configuration object used by a servlet container to pass information to a servlet during initialization.

Method Summary
String | getInitParameter(String name) Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.
Enumeration | getInitParameterNames() Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.
ServletContext | getServletContext() Returns a reference to the ServletContext in which the caller is executing.
String | getServletName() Returns the name of this servlet instance.

Method Detail

getServletName

String getServletName()
Returns the name of this servlet instance. The name may be provided via server administration, assigned in the web application deployment descriptor, or for an unregistered (and thus unnamed) servlet instance it will be the servlet's class name.

Returns:
the name of the servlet instance

getServletContext

ServletContext getServletContext()
Returns a reference to the ServletContext in which the caller is executing.

Returns:
a ServletContext object, used by the caller to interact with its servlet container
See Also:
ServletContext

getInitParameter

String getInitParameter(String name)
Returns a String containing the value of the named initialization parameter, or null if the parameter does not exist.

Parameters:
name - a String specifying the name of the initialization parameter
Returns:
a String containing the value of the initialization parameter

getInitParameterNames

Enumeration getInitParameterNames()
Returns the names of the servlet's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the servlet has no initialization parameters.

Returns:
an Enumeration of String objects containing the names of the servlet's initialization parameters
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletContext

public interface ServletContext

Defines a set of methods that a servlet uses to communicate with its servlet container, for example, to get the MIME type of a file, dispatch requests, or write to a log file.

There is one context per "web application" per Java Virtual Machine. (A "web application" is a collection of servlets and content installed under a specific subset of the server's URL namespace such as /catalog and possibly installed via a .war file.)

In the case of a web application marked "distributed" in its deployment descriptor, there will be one context instance for each virtual machine. In this situation, the context cannot be used as a location to share global information (because the information won't be truly global). Use an external resource like a database instead.

The ServletContext object is contained within the ServletConfig object, which the Web server provides the servlet when the servlet is initialized.

Author:
Various
See Also:
Servlet.getServletConfig(), ServletConfig.getServletContext()

Method Summary
 Object getAttribute(String name)
Returns the servlet container attribute with the given name, or null if there is no attribute by that name.
 Enumeration getAttributeNames()
Returns an Enumeration containing the attribute names available within this servlet context.
 ServletContext getContext(String uripath)
Returns a ServletContext object that corresponds to a specified URL on the server.
 String getContextPath()
Returns the context path of the web application.
 String getInitParameter(String name)
Returns a String containing the value of the named context-wide initialization parameter, or null if the parameter does not exist.
 Enumeration getInitParameterNames()
Returns the names of the context's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the context has no initialization parameters.
 int getMajorVersion()
Returns the major version of the Java Servlet API that this servlet container supports.
 String getMimeType(String file)
Returns the MIME type of the specified file, or null if the MIME type is not known.
 int getMinorVersion()
Returns the minor version of the Servlet API that this servlet container supports.
 RequestDispatcher getNamedDispatcher(String name)
Returns a RequestDispatcher object that acts as a wrapper for the named servlet.
 String getRealPath(String path)
Returns a String containing the real path for a given virtual path.
 RequestDispatcher getRequestDispatcher(String path)
Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.
 URL getResource(String path)
Returns a URL to the resource that is mapped to a specified path.
 InputStream getResourceAsStream(String path)
Returns the resource located at the named path as an InputStream object.
 Set getResourcePaths(String path)
Returns a directory-like listing of all the paths to resources within the web application whose longest sub-path matches the supplied path argument.
 String getServerInfo()
Returns the name and version of the servlet container on which the servlet is running.
 Servlet getServlet(String name)
Deprecated. As of Java Servlet API 2.1, with no direct replacement.

This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.

 String getServletContextName()
Returns the name of this web application corresponding to this ServletContext as specified in the deployment descriptor for this web application by the display-name element.
 Enumeration getServletNames()
Deprecated. As of Java Servlet API 2.1, with no replacement.

This method was originally defined to return an Enumeration of all the servlet names known to this context. In this version, this method always returns an empty Enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

 Enumeration getServlets()
Deprecated. As of Java Servlet API 2.0, with no replacement.

This method was originally defined to return an Enumeration of all the servlets known to this servlet context. In this version, this method always returns an empty enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

 void log(Exception exception, String msg)
Deprecated. As of Java Servlet API 2.1, use log(String message, Throwable throwable) instead.

This method was originally defined to write an exception's stack trace and an explanatory error message to the servlet log file.

 void log(String msg)
Writes the specified message to a servlet log file, usually an event log.
 void log(String message, Throwable throwable)
Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file.
 void removeAttribute(String name)
Removes the attribute with the given name from the servlet context.
 void setAttribute(String name, Object object)
Binds an object to a given attribute name in this servlet context.

Method Detail

getContextPath

String getContextPath()
Returns the context path of the web application.

The context path is the portion of the request URI that is used to select the context of the request. The context path always comes first in a request URI. The path starts with a "/" character but does not end with a "/" character. For servlets in the default (root) context, this method returns "".

It is possible that a servlet container may match a context by more than one context path. In such cases the HttpServletRequest.getContextPath() will return the actual context path used by the request and it may differ from the path returned by this method. The context path returned by this method should be considered as the prime or preferred context path of the application.

Returns:
The context path of the web application, or "" for the default (root) context
Since:
Servlet 2.5
See Also:
HttpServletRequest.getContextPath()

getContext

ServletContext getContext(String uripath)
Returns a ServletContext object that corresponds to a specified URL on the server.

This method allows servlets to gain access to the context for various parts of the server, and as needed obtain RequestDispatcher objects from the context. The given path must be begin with "/", is interpreted relative to the server's document root and is matched against the context roots of other web applications hosted on this container.

In a security conscious environment, the servlet container may return null for a given URL.

Parameters:
uripath - a String specifying the context path of another web application in the container.
Returns:
the ServletContext object that corresponds to the named URL, or null if either none exists or the container wishes to restrict this access.
See Also:
RequestDispatcher

getMajorVersion

int getMajorVersion()
Returns the major version of the Java Servlet API that this servlet container supports. All implementations that comply with Version 2.5 must have this method return the integer 2.

Returns:
2

getMinorVersion

int getMinorVersion()
Returns the minor version of the Servlet API that this servlet container supports. All implementations that comply with Version 2.5 must have this method return the integer 5.

Returns:
5

getMimeType

String getMimeType(String file)
Returns the MIME type of the specified file, or null if the MIME type is not known. The MIME type is determined by the configuration of the servlet container, and may be specified in a web application deployment descriptor. Common MIME types are "text/html" and "image/gif".

Parameters:
file - a String specifying the name of a file
Returns:
a String specifying the file's MIME type

getResourcePaths

Set getResourcePaths(String path)
Returns a directory-like listing of all the paths to resources within the web application whose longest sub-path matches the supplied path argument. Paths indicating subdirectory paths end with a '/'. The returned paths are all relative to the root of the web application and have a leading '/'. For example, for a web application containing

/welcome.html
/catalog/index.html
/catalog/products.html
/catalog/offers/books.html
/catalog/offers/music.html
/customer/login.jsp
/WEB-INF/web.xml
/WEB-INF/classes/com.acme.OrderServlet.class,

getResourcePaths("/") returns {"/welcome.html", "/catalog/", "/customer/", "/WEB-INF/"}
getResourcePaths("/catalog/") returns {"/catalog/index.html", "/catalog/products.html", "/catalog/offers/"}.

Parameters:
path - the partial path used to match the resources, which must start with a /
Returns:
a Set containing the directory listing, or null if there are no resources in the web application whose path begins with the supplied path.
Since:
Servlet 2.3

getResource

URL getResource(String path)
                throws MalformedURLException
Returns a URL to the resource that is mapped to a specified path. The path must begin with a "/" and is interpreted as relative to the current context root.

This method allows the servlet container to make a resource available to servlets from any source. Resources can be located on a local or remote file system, in a database, or in a .war file.

The servlet container must implement the URL handlers and URLConnection objects that are necessary to access the resource.

This method returns null if no resource is mapped to the pathname.

Some containers may allow writing to the URL returned by this method using the methods of the URL class.

The resource content is returned directly, so be aware that requesting a .jsp page returns the JSP source code. Use a RequestDispatcher instead to include results of an execution.

This method has a different purpose than java.lang.Class.getResource, which looks up resources based on a class loader. This method does not use class loaders.

Parameters:
path - a String specifying the path to the resource
Returns:
the resource located at the named path, or null if there is no resource at that path
Throws:
MalformedURLException - if the pathname is not given in the correct form

getResourceAsStream

InputStream getResourceAsStream(String path)
Returns the resource located at the named path as an InputStream object.

The data in the InputStream can be of any type or length. The path must be specified according to the rules given in getResource. This method returns null if no resource exists at the specified path.

Meta-information such as content length and content type that is available via getResource method is lost when using this method.

The servlet container must implement the URL handlers and URLConnection objects necessary to access the resource.

This method is different from java.lang.Class.getResourceAsStream, which uses a class loader. This method allows servlet containers to make a resource available to a servlet from any location, without using a class loader.

Parameters:
path - a String specifying the path to the resource
Returns:
the InputStream returned to the servlet, or null if no resource exists at the specified path

getRequestDispatcher

RequestDispatcher getRequestDispatcher(String path)
Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path. A RequestDispatcher object can be used to forward a request to the resource or to include the resource in a response. The resource can be dynamic or static.

The pathname must begin with a "/" and is interpreted as relative to the current context root. Use getContext to obtain a RequestDispatcher for resources in foreign contexts. This method returns null if the ServletContext cannot return a RequestDispatcher.

Parameters:
path - a String specifying the pathname to the resource
Returns:
a RequestDispatcher object that acts as a wrapper for the resource at the specified path, or null if the ServletContext cannot return a RequestDispatcher
See Also:
RequestDispatcher, getContext(java.lang.String)

getNamedDispatcher

RequestDispatcher getNamedDispatcher(String name)
Returns a RequestDispatcher object that acts as a wrapper for the named servlet.

Servlets (and JSP pages also) may be given names via server administration or via a web application deployment descriptor. A servlet instance can determine its name using ServletConfig.getServletName().

This method returns null if the ServletContext cannot return a RequestDispatcher for any reason.

Parameters:
name - a String specifying the name of a servlet to wrap
Returns:
a RequestDispatcher object that acts as a wrapper for the named servlet, or null if the ServletContext cannot return a RequestDispatcher
See Also:
RequestDispatcher, getContext(java.lang.String), ServletConfig.getServletName()

getServlet

Servlet getServlet(String name)
                   throws ServletException
Deprecated. As of Java Servlet API 2.1, with no direct replacement.

This method was originally defined to retrieve a servlet from a ServletContext. In this version, this method always returns null and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

In lieu of this method, servlets can share information using the ServletContext class and can perform shared business logic by invoking methods on common non-servlet classes.

Throws:
ServletException

getServlets

Enumeration getServlets()
Deprecated. As of Java Servlet API 2.0, with no replacement.

This method was originally defined to return an Enumeration of all the servlets known to this servlet context. In this version, this method always returns an empty enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

getServletNames

Enumeration getServletNames()
Deprecated. As of Java Servlet API 2.1, with no replacement.

This method was originally defined to return an Enumeration of all the servlet names known to this context. In this version, this method always returns an empty Enumeration and remains only to preserve binary compatibility. This method will be permanently removed in a future version of the Java Servlet API.

log

void log(String msg)
Writes the specified message to a servlet log file, usually an event log. The name and type of the servlet log file is specific to the servlet container.

Parameters:
msg - a String specifying the message to be written to the log file

log

void log(Exception exception,
         String msg)
Deprecated. As of Java Servlet API 2.1, use log(String message, Throwable throwable) instead.

This method was originally defined to write an exception's stack trace and an explanatory error message to the servlet log file.

log

void log(String message,
         Throwable throwable)
Writes an explanatory message and a stack trace for a given Throwable exception to the servlet log file. The name and type of the servlet log file is specific to the servlet container, usually an event log.

Parameters:
message - a String that describes the error or exception
throwable - the Throwable error or exception

getRealPath

String getRealPath(String path)
Returns a String containing the real path for a given virtual path. For example, the path "/index.html" returns the absolute file path on the server's filesystem would be served by a request for "http://host/contextPath/index.html", where contextPath is the context path of this ServletContext..

The real path returned will be in a form appropriate to the computer and operating system on which the servlet container is running, including the proper path separators. This method returns null if the servlet container cannot translate the virtual path to a real path for any reason (such as when the content is being made available from a .war archive).

Parameters:
path - a String specifying a virtual path
Returns:
a String specifying the real path, or null if the translation cannot be performed

getServerInfo

String getServerInfo()
Returns the name and version of the servlet container on which the servlet is running.

The form of the returned string is servername/versionnumber. For example, the JavaServer Web Development Kit may return the string JavaServer Web Dev Kit/1.0.

The servlet container may return other optional information after the primary string in parentheses, for example, JavaServer Web Dev Kit/1.0 (JDK 1.1.6; Windows NT 4.0 x86).

Returns:
a String containing at least the servlet container name and version number

getInitParameter

String getInitParameter(String name)
Returns a String containing the value of the named context-wide initialization parameter, or null if the parameter does not exist.

This method can make available configuration information useful to an entire "web application". For example, it can provide a webmaster's email address or the name of a system that holds critical data.

Parameters:
name - a String containing the name of the parameter whose value is requested
Returns:
a String containing at least the servlet container name and version number
See Also:
ServletConfig.getInitParameter(java.lang.String)

getInitParameterNames

Enumeration getInitParameterNames()
Returns the names of the context's initialization parameters as an Enumeration of String objects, or an empty Enumeration if the context has no initialization parameters.

Returns:
an Enumeration of String objects containing the names of the context's initialization parameters
See Also:
ServletConfig.getInitParameter(java.lang.String)

getAttribute

Object getAttribute(String name)
Returns the servlet container attribute with the given name, or null if there is no attribute by that name. An attribute allows a servlet container to give the servlet additional information not already provided by this interface. See your server documentation for information about its attributes. A list of supported attributes can be retrieved using getAttributeNames.

The attribute is returned as a java.lang.Object or some subclass. Attribute names should follow the same convention as package names. The Java Servlet API specification reserves names matching java.*, javax.*, and sun.*.

Parameters:
name - a String specifying the name of the attribute
Returns:
an Object containing the value of the attribute, or null if no attribute exists matching the given name
See Also:
getAttributeNames()

getAttributeNames

Enumeration getAttributeNames()
Returns an Enumeration containing the attribute names available within this servlet context. Use the getAttribute(java.lang.String) method with an attribute name to get the value of an attribute.

Returns:
an Enumeration of attribute names
See Also:
getAttribute(java.lang.String)

setAttribute

void setAttribute(String name,
                  Object object)
Binds an object to a given attribute name in this servlet context. If the name specified is already used for an attribute, this method will replace the attribute with the new to the new attribute.

If listeners are configured on the ServletContext the container notifies them accordingly.

If a null value is passed, the effect is the same as calling removeAttribute().

Attribute names should follow the same convention as package names. The Java Servlet API specification reserves names matching java.*, javax.*, and sun.*.

Parameters:
name - a String specifying the name of the attribute
object - an Object representing the attribute to be bound

removeAttribute

void removeAttribute(String name)
Removes the attribute with the given name from the servlet context. After removal, subsequent calls to getAttribute(java.lang.String) to retrieve the attribute's value will return null.

If listeners are configured on the ServletContext the container notifies them accordingly.

Parameters:
name - a String specifying the name of the attribute to be removed

getServletContextName

String getServletContextName()
Returns the name of this web application corresponding to this ServletContext as specified in the deployment descriptor for this web application by the display-name element.

Returns:
The name of the web application or null if no name has been declared in the deployment descriptor.
Since:
Servlet 2.3
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletContextAttributeEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletContextAttributeEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.servlet.ServletContextEvent
            extended by  javax.servlet.ServletContextAttributeEvent
All Implemented Interfaces:
Serializable
public class ServletContextAttributeEvent
extends ServletContextEvent

This is the event class for notifications about changes to the attributes of the servlet context of a web application.

Since:
v 2.3
See Also:
ServletContextAttributeListener, Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
ServletContextAttributeEvent(ServletContext source, String name, Object value)
Construct a ServletContextAttributeEvent from the given context for the given attribute name and attribute value.
Method Summary
String | getName() Return the name of the attribute that changed on the ServletContext.
Object | getValue() Returns the value of the attribute that has been added, removed, or replaced.
Methods inherited from class javax.servlet.ServletContextEvent
getServletContext
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServletContextAttributeEvent

public ServletContextAttributeEvent(ServletContext source,
                                    String name,
                                    Object value)
Construct a ServletContextAttributeEvent from the given context for the given attribute name and attribute value.

Method Detail

getName

public String getName()
Return the name of the attribute that changed on the ServletContext.

getValue

public Object getValue()
Returns the value of the attribute that has been added, removed, or replaced. If the attribute was added, this is the value of the attribute. If the attribute was removed, this is the value of the removed attribute. If the attribute was replaced, this is the old value of the attribute.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletContextAttributeListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletContextAttributeListener

All Superinterfaces:
EventListener
public interface ServletContextAttributeListener
extends EventListener

Implementations of this interface receive notifications of changes to the attribute list on the servlet context of a web application. To receive notification events, the implementation class must be configured in the deployment descriptor for the web application.

Since:
v 2.3
See Also:
ServletContextAttributeEvent

Method Summary
void | attributeAdded(ServletContextAttributeEvent scab) Notification that a new attribute was added to the servlet context.
void | attributeRemoved(ServletContextAttributeEvent scab) Notification that an existing attribute has been removed from the servlet context.
void | attributeReplaced(ServletContextAttributeEvent scab) Notification that an attribute on the servlet context has been replaced.

Method Detail

attributeAdded

void attributeAdded(ServletContextAttributeEvent scab)
Notification that a new attribute was added to the servlet context. Called after the attribute is added.

attributeRemoved

void attributeRemoved(ServletContextAttributeEvent scab)
Notification that an existing attribute has been removed from the servlet context. Called after the attribute is removed.

attributeReplaced

void attributeReplaced(ServletContextAttributeEvent scab)
Notification that an attribute on the servlet context has been replaced. Called after the attribute is replaced.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletContextEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletContextEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.servlet.ServletContextEvent
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ServletContextAttributeEvent
public class ServletContextEvent
extends EventObject

This is the event class for notifications about changes to the servlet context of a web application.

Since:
v 2.3
See Also:
ServletContextListener, Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
ServletContextEvent(ServletContext source)
Construct a ServletContextEvent from the given context.
Method Summary
 ServletContext getServletContext()
Return the ServletContext that changed.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServletContextEvent

public ServletContextEvent(ServletContext source)
Construct a ServletContextEvent from the given context.

Parameters:
source - - the ServletContext that is sending the event.
Method Detail

getServletContext

public ServletContext getServletContext()
Return the ServletContext that changed.

Returns:
the ServletContext that sent the event.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletContextListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletContextListener

All Superinterfaces:
EventListener
public interface ServletContextListener
extends EventListener

Implementations of this interface receive notifications about changes to the servlet context of the web application they are part of. To receive notification events, the implementation class must be configured in the deployment descriptor for the web application.

Since:
v 2.3
See Also:
ServletContextEvent

Method Summary
void | contextDestroyed(ServletContextEvent sce) Notification that the servlet context is about to be shut down.
void | contextInitialized(ServletContextEvent sce) Notification that the web application initialization process is starting.

Method Detail

contextInitialized

void contextInitialized(ServletContextEvent sce)
Notification that the web application initialization process is starting. All ServletContextListeners are notified of context initialization before any filter or servlet in the web application is initialized.

contextDestroyed

void contextDestroyed(ServletContextEvent sce)
Notification that the servlet context is about to be shut down. All servlets and filters have been destroy()ed before any ServletContextListeners are notified of context destruction.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.servlet.ServletException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
UnavailableException
public class ServletException
extends Exception

Defines a general exception a servlet can throw when it encounters difficulty.

Author:
Various
See Also:
Serialized Form

Constructor Summary
ServletException()
Constructs a new servlet exception.
ServletException(String message)
Constructs a new servlet exception with the specified message.
ServletException(String message, Throwable rootCause)
Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.
ServletException(Throwable rootCause)
Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation.
Method Summary
 Throwable getRootCause()
Returns the exception that caused this servlet exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServletException

public ServletException()
Constructs a new servlet exception.

ServletException

public ServletException(String message)
Constructs a new servlet exception with the specified message. The message can be written to the server log and/or displayed for the user.

Parameters:
message - a String specifying the text of the exception message

ServletException

public ServletException(String message,
                        Throwable rootCause)
Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation, including a description message.

Parameters:
message - a String containing the text of the exception message
rootCause - the Throwable exception that interfered with the servlet's normal operation, making this servlet exception necessary

ServletException

public ServletException(Throwable rootCause)
Constructs a new servlet exception when the servlet needs to throw an exception and include a message about the "root cause" exception that interfered with its normal operation. The exception's message is based on the localized message of the underlying exception.

This method calls the getLocalizedMessage method on the Throwable exception to get a localized exception message. When subclassing ServletException, this method can be overridden to create an exception message designed for a specific locale.

Parameters:
rootCause - the Throwable exception that interfered with the servlet's normal operation, making the servlet exception necessary
Method Detail

getRootCause

public Throwable getRootCause()
Returns the exception that caused this servlet exception.

Returns:
the Throwable that caused this servlet exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletInputStream

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletInputStream

java.lang.Object
    extended by  java.io.InputStream
        extended by  javax.servlet.ServletInputStream
All Implemented Interfaces:
Closeable
public abstract class ServletInputStream
extends InputStream

Provides an input stream for reading binary data from a client request, including an efficient readLine method for reading data one line at a time. With some protocols, such as HTTP POST and PUT, a ServletInputStream object can be used to read data sent from the client.

A ServletInputStream object is normally retrieved via the ServletRequest.getInputStream() method.

This is an abstract class that a servlet container implements. Subclasses of this class must implement the java.io.InputStream.read() method.

Author:
Various
See Also:
ServletRequest

Constructor Summary
protected ServletInputStream()
Does nothing, because this is an abstract class.
Method Summary
 int readLine(byte[] b, int off, int len)
Reads the input stream, one line at a time.
Methods inherited from class java.io.InputStream
available, close, mark, markSupported, read, read, read, reset, skip
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServletInputStream

protected ServletInputStream()
Does nothing, because this is an abstract class.

Method Detail

readLine

public int readLine(byte[] b,
                    int off,
                    int len)
             throws IOException
Reads the input stream, one line at a time. Starting at an offset, reads bytes into an array, until it reads a certain number of bytes or reaches a newline character, which it reads into the array as well.

This method returns -1 if it reaches the end of the input stream before reading the maximum number of bytes.

Parameters:
b - an array of bytes into which data is read
off - an integer specifying the character at which this method begins reading
len - an integer specifying the maximum number of bytes to read
Returns:
an integer specifying the actual number of bytes read, or -1 if the end of the stream is reached
Throws:
IOException - if an input or output exception has occurred
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletOutputStream

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletOutputStream

java.lang.Object
    extended by  java.io.OutputStream
        extended by  javax.servlet.ServletOutputStream
All Implemented Interfaces:
Closeable, Flushable
public abstract class ServletOutputStream
extends OutputStream

Provides an output stream for sending binary data to the client. A ServletOutputStream object is normally retrieved via the ServletResponse.getOutputStream() method.

This is an abstract class that the servlet container implements. Subclasses of this class must implement the java.io.OutputStream.write(int) method.

Author:
Various
See Also:
ServletResponse

Constructor Summary
protected ServletOutputStream()
Does nothing, because this is an abstract class.
Method Summary
void | print(boolean b) Writes a boolean value to the client, with no carriage return-line feed (CRLF) character at the end.
void | print(char c) Writes a character to the client, with no carriage return-line feed (CRLF) at the end.
void | print(double d) Writes a double value to the client, with no carriage return-line feed (CRLF) at the end.
void | print(float f) Writes a float value to the client, with no carriage return-line feed (CRLF) at the end.
void | print(int i) Writes an int to the client, with no carriage return-line feed (CRLF) at the end.
void | print(long l) Writes a long value to the client, with no carriage return-line feed (CRLF) at the end.
void | print(String s) Writes a String to the client, without a carriage return-line feed (CRLF) character at the end.
void | println() Writes a carriage return-line feed (CRLF) to the client.
void | println(boolean b) Writes a boolean value to the client, followed by a carriage return-line feed (CRLF).
void | println(char c) Writes a character to the client, followed by a carriage return-line feed (CRLF).
void | println(double d) Writes a double value to the client, followed by a carriage return-line feed (CRLF).
void | println(float f) Writes a float value to the client, followed by a carriage return-line feed (CRLF).
void | println(int i) Writes an int to the client, followed by a carriage return-line feed (CRLF) character.
void | println(long l) Writes a long value to the client, followed by a carriage return-line feed (CRLF).
void | println(String s) Writes a String to the client, followed by a carriage return-line feed (CRLF).
Methods inherited from class java.io.OutputStream
close, flush, write, write, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServletOutputStream

protected ServletOutputStream()
Does nothing, because this is an abstract class.

Method Detail

print

public void print(String s)
           throws IOException
Writes a String to the client, without a carriage return-line feed (CRLF) character at the end.

Parameters:
s - the String to send to the client
Throws:
IOException - if an input or output exception occurred

print

public void print(boolean b)
           throws IOException
Writes a boolean value to the client, with no carriage return-line feed (CRLF) character at the end.

Parameters:
b - the boolean value to send to the client
Throws:
IOException - if an input or output exception occurred

print

public void print(char c)
           throws IOException
Writes a character to the client, with no carriage return-line feed (CRLF) at the end.

Parameters:
c - the character to send to the client
Throws:
IOException - if an input or output exception occurred

print

public void print(int i)
           throws IOException
Writes an int to the client, with no carriage return-line feed (CRLF) at the end.

Parameters:
i - the int to send to the client
Throws:
IOException - if an input or output exception occurred

print

public void print(long l)
           throws IOException
Writes a long value to the client, with no carriage return-line feed (CRLF) at the end.

Parameters:
l - the long value to send to the client
Throws:
IOException - if an input or output exception occurred

print

public void print(float f)
           throws IOException
Writes a float value to the client, with no carriage return-line feed (CRLF) at the end.

Parameters:
f - the float value to send to the client
Throws:
IOException - if an input or output exception occurred

print

public void print(double d)
           throws IOException
Writes a double value to the client, with no carriage return-line feed (CRLF) at the end.

Parameters:
d - the double value to send to the client
Throws:
IOException - if an input or output exception occurred

println

public void println()
             throws IOException
Writes a carriage return-line feed (CRLF) to the client.

Throws:
IOException - if an input or output exception occurred

println

public void println(String s)
             throws IOException
Writes a String to the client, followed by a carriage return-line feed (CRLF).

Parameters:
s - the String to write to the client
Throws:
IOException - if an input or output exception occurred

println

public void println(boolean b)
             throws IOException
Writes a boolean value to the client, followed by a carriage return-line feed (CRLF).

Parameters:
b - the boolean value to write to the client
Throws:
IOException - if an input or output exception occurred

println

public void println(char c)
             throws IOException
Writes a character to the client, followed by a carriage return-line feed (CRLF).

Parameters:
c - the character to write to the client
Throws:
IOException - if an input or output exception occurred

println

public void println(int i)
             throws IOException
Writes an int to the client, followed by a carriage return-line feed (CRLF) character.

Parameters:
i - the int to write to the client
Throws:
IOException - if an input or output exception occurred

println

public void println(long l)
             throws IOException
Writes a long value to the client, followed by a carriage return-line feed (CRLF).

Parameters:
l - the long value to write to the client
Throws:
IOException - if an input or output exception occurred

println

public void println(float f)
             throws IOException
Writes a float value to the client, followed by a carriage return-line feed (CRLF).

Parameters:
f - the float value to write to the client
Throws:
IOException - if an input or output exception occurred

println

public void println(double d)
             throws IOException
Writes a double value to the client, followed by a carriage return-line feed (CRLF).

Parameters:
d - the double value to write to the client
Throws:
IOException - if an input or output exception occurred
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletRequest

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletRequest

All Known Subinterfaces:
HttpServletRequest
All Known Implementing Classes:
HttpServletRequestWrapper, ServletRequestWrapper
public interface ServletRequest

Defines an object to provide client request information to a servlet. The servlet container creates a ServletRequest object and passes it as an argument to the servlet's service method.

A ServletRequest object provides data including parameter name and values, attributes, and an input stream. Interfaces that extend ServletRequest can provide additional protocol-specific data (for example, HTTP data is provided by HttpServletRequest.

Author:
Various
See Also:
HttpServletRequest

Method Summary
Object | getAttribute(String name) Returns the value of the named attribute as an Object, or null if no attribute of the given name exists.
Enumeration | getAttributeNames() Returns an Enumeration containing the names of the attributes available to this request.
String | getCharacterEncoding() Returns the name of the character encoding used in the body of this request.
int | getContentLength() Returns the length, in bytes, of the request body and made available by the input stream, or -1 if the length is not known.
String | getContentType() Returns the MIME type of the body of the request, or null if the type is not known.
ServletInputStream | getInputStream() Retrieves the body of the request as binary data using a ServletInputStream.
String | getLocalAddr() Returns the Internet Protocol (IP) address of the interface on which the request was received.
Locale | getLocale() Returns the preferred Locale that the client will accept content in, based on the Accept-Language header.
Enumeration | getLocales() Returns an Enumeration of Locale objects indicating, in decreasing order starting with the preferred locale, the locales that are acceptable to the client based on the Accept-Language header.
String | getLocalName() Returns the host name of the Internet Protocol (IP) interface on which the request was received.
int | getLocalPort() Returns the Internet Protocol (IP) port number of the interface on which the request was received.
String | getParameter(String name) Returns the value of a request parameter as a String, or null if the parameter does not exist.
Map | getParameterMap() Returns a java.util.Map of the parameters of this request.
Enumeration | getParameterNames() Returns an Enumeration of String objects containing the names of the parameters contained in this request.
String[] | getParameterValues(String name) Returns an array of String objects containing all of the values the given request parameter has, or null if the parameter does not exist.
String | getProtocol() Returns the name and version of the protocol the request uses in the form protocol/majorVersion.minorVersion, for example, HTTP/1.1.
BufferedReader | getReader() Retrieves the body of the request as character data using a BufferedReader.
String | getRealPath(String path) Deprecated. As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead.
String | getRemoteAddr() Returns the Internet Protocol (IP) address of the client or last proxy that sent the request.
String | getRemoteHost() Returns the fully qualified name of the client or the last proxy that sent the request.
int | getRemotePort() Returns the Internet Protocol (IP) source port of the client or last proxy that sent the request.
RequestDispatcher | getRequestDispatcher(String path) Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path.
String | getScheme() Returns the name of the scheme used to make this request, for example, http, https, or ftp.
String | getServerName() Returns the host name of the server to which the request was sent.
int | getServerPort() Returns the port number to which the request was sent.
boolean | isSecure() Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.
void | removeAttribute(String name) Removes an attribute from this request.
void | setAttribute(String name, Object o) Stores an attribute in this request.
void | setCharacterEncoding(String env) Overrides the name of the character encoding used in the body of this request.

Method Detail

getAttribute

Object getAttribute(String name)
Returns the value of the named attribute as an Object, or null if no attribute of the given name exists.

Attributes can be set two ways. The servlet container may set attributes to make available custom information about a request. For example, for requests made using HTTPS, the attribute javax.servlet.request.X509Certificate can be used to retrieve information on the certificate of the client. Attributes can also be set programatically using setAttribute(java.lang.String, java.lang.Object). This allows information to be embedded into a request before a RequestDispatcher call.

Attribute names should follow the same conventions as package names. This specification reserves names matching java.*, javax.*, and sun.*.

Parameters:
name - a String specifying the name of the attribute
Returns:
an Object containing the value of the attribute, or null if the attribute does not exist

getAttributeNames

Enumeration getAttributeNames()
Returns an Enumeration containing the names of the attributes available to this request. This method returns an empty Enumeration if the request has no attributes available to it.

Returns:
an Enumeration of strings containing the names of the request's attributes

getCharacterEncoding

String getCharacterEncoding()
Returns the name of the character encoding used in the body of this request. This method returns null if the request does not specify a character encoding

Returns:
a String containing the name of the character encoding, or null if the request does not specify a character encoding

setCharacterEncoding

void setCharacterEncoding(String env)
                          throws UnsupportedEncodingException
Overrides the name of the character encoding used in the body of this request. This method must be called prior to reading request parameters or reading input using getReader(). Otherwise, it has no effect.

Parameters:
env - String containing the name of the character encoding.
Throws:
UnsupportedEncodingException - if this ServletRequest is still in a state where a character encoding may be set, but the specified encoding is invalid

getContentLength

int getContentLength()
Returns the length, in bytes, of the request body and made available by the input stream, or -1 if the length is not known. For HTTP servlets, same as the value of the CGI variable CONTENT_LENGTH.

Returns:
an integer containing the length of the request body or -1 if the length is not known

getContentType

String getContentType()
Returns the MIME type of the body of the request, or null if the type is not known. For HTTP servlets, same as the value of the CGI variable CONTENT_TYPE.

Returns:
a String containing the name of the MIME type of the request, or null if the type is not known

getInputStream

ServletInputStream getInputStream()
                                  throws IOException
Retrieves the body of the request as binary data using a ServletInputStream. Either this method or getReader() may be called to read the body, not both.

Returns:
a ServletInputStream object containing the body of the request
Throws:
IllegalStateException - if the getReader() method has already been called for this request
IOException - if an input or output exception occurred

getParameter

String getParameter(String name)
Returns the value of a request parameter as a String, or null if the parameter does not exist. Request parameters are extra information sent with the request. For HTTP servlets, parameters are contained in the query string or posted form data.

You should only use this method when you are sure the parameter has only one value. If the parameter might have more than one value, use getParameterValues(java.lang.String).

If you use this method with a multivalued parameter, the value returned is equal to the first value in the array returned by getParameterValues.

If the parameter data was sent in the request body, such as occurs with an HTTP POST request, then reading the body directly via getInputStream() or getReader() can interfere with the execution of this method.

Parameters:
name - a String specifying the name of the parameter
Returns:
a String representing the single value of the parameter
See Also:
getParameterValues(java.lang.String)

getParameterNames

Enumeration getParameterNames()
Returns an Enumeration of String objects containing the names of the parameters contained in this request. If the request has no parameters, the method returns an empty Enumeration.

Returns:
an Enumeration of String objects, each String containing the name of a request parameter; or an empty Enumeration if the request has no parameters

getParameterValues

String[] getParameterValues(String name)
Returns an array of String objects containing all of the values the given request parameter has, or null if the parameter does not exist.

If the parameter has a single value, the array has a length of 1.

Parameters:
name - a String containing the name of the parameter whose value is requested
Returns:
an array of String objects containing the parameter's values
See Also:
getParameter(java.lang.String)

getParameterMap

Map getParameterMap()
Returns a java.util.Map of the parameters of this request. Request parameters are extra information sent with the request. For HTTP servlets, parameters are contained in the query string or posted form data.

Returns:
an immutable java.util.Map containing parameter names as keys and parameter values as map values. The keys in the parameter map are of type String. The values in the parameter map are of type String array.

getProtocol

String getProtocol()
Returns the name and version of the protocol the request uses in the form protocol/majorVersion.minorVersion, for example, HTTP/1.1. For HTTP servlets, the value returned is the same as the value of the CGI variable SERVER_PROTOCOL.

Returns:
a String containing the protocol name and version number

getScheme

String getScheme()
Returns the name of the scheme used to make this request, for example, http, https, or ftp. Different schemes have different rules for constructing URLs, as noted in RFC 1738.

Returns:
a String containing the name of the scheme used to make this request

getServerName

String getServerName()
Returns the host name of the server to which the request was sent. It is the value of the part before ":" in the Host header value, if any, or the resolved server name, or the server IP address.

Returns:
a String containing the name of the server

getServerPort

int getServerPort()
Returns the port number to which the request was sent. It is the value of the part after ":" in the Host header value, if any, or the server port where the client connection was accepted on.

Returns:
an integer specifying the port number

getReader

BufferedReader getReader()
                         throws IOException
Retrieves the body of the request as character data using a BufferedReader. The reader translates the character data according to the character encoding used on the body. Either this method or getInputStream() may be called to read the body, not both.

Returns:
a BufferedReader containing the body of the request
Throws:
UnsupportedEncodingException - if the character set encoding used is not supported and the text cannot be decoded
IllegalStateException - if getInputStream() method has been called on this request
IOException - if an input or output exception occurred
See Also:
getInputStream()

getRemoteAddr

String getRemoteAddr()
Returns the Internet Protocol (IP) address of the client or last proxy that sent the request. For HTTP servlets, same as the value of the CGI variable REMOTE_ADDR.

Returns:
a String containing the IP address of the client that sent the request

getRemoteHost

String getRemoteHost()
Returns the fully qualified name of the client or the last proxy that sent the request. If the engine cannot or chooses not to resolve the hostname (to improve performance), this method returns the dotted-string form of the IP address. For HTTP servlets, same as the value of the CGI variable REMOTE_HOST.

Returns:
a String containing the fully qualified name of the client

setAttribute

void setAttribute(String name,
                  Object o)
Stores an attribute in this request. Attributes are reset between requests. This method is most often used in conjunction with RequestDispatcher.

Attribute names should follow the same conventions as package names. Names beginning with java.*, javax.*, and com.sun.*, are reserved for use by Sun Microsystems.
If the object passed in is null, the effect is the same as calling removeAttribute(java.lang.String).
It is warned that when the request is dispatched from the servlet resides in a different web application by RequestDispatcher, the object set by this method may not be correctly retrieved in the caller servlet.

Parameters:
name - a String specifying the name of the attribute
o - the Object to be stored

removeAttribute

void removeAttribute(String name)
Removes an attribute from this request. This method is not generally needed as attributes only persist as long as the request is being handled.

Attribute names should follow the same conventions as package names. Names beginning with java.*, javax.*, and com.sun.*, are reserved for use by Sun Microsystems.

Parameters:
name - a String specifying the name of the attribute to remove

getLocale

Locale getLocale()
Returns the preferred Locale that the client will accept content in, based on the Accept-Language header. If the client request doesn't provide an Accept-Language header, this method returns the default locale for the server.

Returns:
the preferred Locale for the client

getLocales

Enumeration getLocales()
Returns an Enumeration of Locale objects indicating, in decreasing order starting with the preferred locale, the locales that are acceptable to the client based on the Accept-Language header. If the client request doesn't provide an Accept-Language header, this method returns an Enumeration containing one Locale, the default locale for the server.

Returns:
an Enumeration of preferred Locale objects for the client

isSecure

boolean isSecure()
Returns a boolean indicating whether this request was made using a secure channel, such as HTTPS.

Returns:
a boolean indicating if the request was made using a secure channel

getRequestDispatcher

RequestDispatcher getRequestDispatcher(String path)
Returns a RequestDispatcher object that acts as a wrapper for the resource located at the given path. A RequestDispatcher object can be used to forward a request to the resource or to include the resource in a response. The resource can be dynamic or static.

The pathname specified may be relative, although it cannot extend outside the current servlet context. If the path begins with a "/" it is interpreted as relative to the current context root. This method returns null if the servlet container cannot return a RequestDispatcher.

The difference between this method and ServletContext.getRequestDispatcher(java.lang.String) is that this method can take a relative path.

Parameters:
path - a String specifying the pathname to the resource. If it is relative, it must be relative against the current servlet.
Returns:
a RequestDispatcher object that acts as a wrapper for the resource at the specified path, or null if the servlet container cannot return a RequestDispatcher
See Also:
RequestDispatcher, ServletContext.getRequestDispatcher(java.lang.String)

getRealPath

String getRealPath(String path)
Deprecated. As of Version 2.1 of the Java Servlet API, use ServletContext.getRealPath(java.lang.String) instead.

getRemotePort

int getRemotePort()
Returns the Internet Protocol (IP) source port of the client or last proxy that sent the request.

Returns:
an integer specifying the port number
Since:
2.4

getLocalName

String getLocalName()
Returns the host name of the Internet Protocol (IP) interface on which the request was received.

Returns:
a String containing the host name of the IP on which the request was received.
Since:
2.4

getLocalAddr

String getLocalAddr()
Returns the Internet Protocol (IP) address of the interface on which the request was received.

Returns:
a String containing the IP address on which the request was received.
Since:
2.4

getLocalPort

int getLocalPort()
Returns the Internet Protocol (IP) port number of the interface on which the request was received.

Returns:
an integer specifying the port number
Since:
2.4
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletRequestAttributeEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletRequestAttributeEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.servlet.ServletRequestEvent
            extended by  javax.servlet.ServletRequestAttributeEvent
All Implemented Interfaces:
Serializable
public class ServletRequestAttributeEvent
extends ServletRequestEvent

This is the event class for notifications of changes to the attributes of the servlet request in an application.

Since:
Servlet 2.4
See Also:
ServletRequestAttributeListener, Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
ServletRequestAttributeEvent(ServletContext sc, ServletRequest request, String name, Object value)
Construct a ServletRequestAttributeEvent giving the servlet context of this web application, the ServletRequest whose attributes are changing and the name and value of the attribute.
Method Summary
String | getName() Return the name of the attribute that changed on the ServletRequest.
Object | getValue() Returns the value of the attribute that has been added, removed or replaced.
Methods inherited from class javax.servlet.ServletRequestEvent
getServletContext, getServletRequest
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServletRequestAttributeEvent

public ServletRequestAttributeEvent(ServletContext sc,
                                    ServletRequest request,
                                    String name,
                                    Object value)
Construct a ServletRequestAttributeEvent giving the servlet context of this web application, the ServletRequest whose attributes are changing and the name and value of the attribute.

Parameters:
sc - the ServletContext that is sending the event.
request - the ServletRequest that is sending the event.
name - the name of the request attribute.
value - the value of the request attribute.
Method Detail

getName

public String getName()
Return the name of the attribute that changed on the ServletRequest.

Returns:
the name of the changed request attribute

getValue

public Object getValue()
Returns the value of the attribute that has been added, removed or replaced. If the attribute was added, this is the value of the attribute. If the attribute was removed, this is the value of the removed attribute. If the attribute was replaced, this is the old value of the attribute.

Returns:
the value of the changed request attribute
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletRequestAttributeListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletRequestAttributeListener

All Superinterfaces:
EventListener
public interface ServletRequestAttributeListener
extends EventListener

A ServletRequestAttributeListener can be implemented by the developer interested in being notified of request attribute changes. Notifications will be generated while the request is within the scope of the web application in which the listener is registered. A request is defined as coming into scope when it is about to enter the first servlet or filter in each web application, as going out of scope when it exits the last servlet or the first filter in the chain.

Since:
Servlet 2.4

Method Summary
void | attributeAdded(ServletRequestAttributeEvent srae) Notification that a new attribute was added to the servlet request.
void | attributeRemoved(ServletRequestAttributeEvent srae) Notification that an existing attribute has been removed from the servlet request.
void | attributeReplaced(ServletRequestAttributeEvent srae) Notification that an attribute was replaced on the servlet request.

Method Detail

attributeAdded

void attributeAdded(ServletRequestAttributeEvent srae)
Notification that a new attribute was added to the servlet request. Called after the attribute is added.

attributeRemoved

void attributeRemoved(ServletRequestAttributeEvent srae)
Notification that an existing attribute has been removed from the servlet request. Called after the attribute is removed.

attributeReplaced

void attributeReplaced(ServletRequestAttributeEvent srae)
Notification that an attribute was replaced on the servlet request. Called after the attribute is replaced.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletRequestEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletRequestEvent

java.lang.Object
    extended by  java.util.EventObject
        extended by  javax.servlet.ServletRequestEvent
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ServletRequestAttributeEvent
public class ServletRequestEvent
extends EventObject

Events of this kind indicate lifecycle events for a ServletRequest. The source of the event is the ServletContext of this web application.

Since:
Servlet 2.4
See Also:
ServletRequestListener, Serialized Form

Field Summary
Fields inherited from class java.util.EventObject
source
Constructor Summary
ServletRequestEvent(ServletContext sc, ServletRequest request)
Construct a ServletRequestEvent for the given ServletContext and ServletRequest.
Method Summary
ServletContext | getServletContext() Returns the ServletContext of this web application.
ServletRequest | getServletRequest() Returns the ServletRequest that is changing.
Methods inherited from class java.util.EventObject
getSource, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServletRequestEvent

public ServletRequestEvent(ServletContext sc,
                           ServletRequest request)
Construct a ServletRequestEvent for the given ServletContext and ServletRequest.

Parameters:
sc - the ServletContext of the web application.
request - the ServletRequest that is sending the event.
Method Detail

getServletRequest

public ServletRequest getServletRequest()
Returns the ServletRequest that is changing.

getServletContext

public ServletContext getServletContext()
Returns the ServletContext of this web application.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletRequestListener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletRequestListener

All Superinterfaces:
EventListener
public interface ServletRequestListener
extends EventListener

A ServletRequestListener can be implemented by the developer interested in being notified of requests coming in and out of scope in a web component. A request is defined as coming into scope when it is about to enter the first servlet or filter in each web application, as going out of scope when it exits the last servlet or the first filter in the chain.

Since:
Servlet 2.4

Method Summary
void | requestDestroyed(ServletRequestEvent sre) The request is about to go out of scope of the web application.
void | requestInitialized(ServletRequestEvent sre) The request is about to come into scope of the web application.

Method Detail

requestDestroyed

void requestDestroyed(ServletRequestEvent sre)
The request is about to go out of scope of the web application.

requestInitialized

void requestInitialized(ServletRequestEvent sre)
The request is about to come into scope of the web application.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletRequestWrapper

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletRequestWrapper

java.lang.Object
    extended by  javax.servlet.ServletRequestWrapper
All Implemented Interfaces:
ServletRequest
Direct Known Subclasses:
HttpServletRequestWrapper
public class ServletRequestWrapper
extends Object
implements ServletRequest

Provides a convenient implementation of the ServletRequest interface that can be subclassed by developers wishing to adapt the request to a Servlet. This class implements the Wrapper or Decorator pattern. Methods default to calling through to the wrapped request object.

Since:
v 2.3
See Also:
ServletRequest

Constructor Summary
ServletRequestWrapper(ServletRequest request)
Creates a ServletRequest adaptor wrapping the given request object.
Method Summary
 Object getAttribute(String name)
The default behavior of this method is to call getAttribute(String name) on the wrapped request object.
 Enumeration getAttributeNames()
The default behavior of this method is to return getAttributeNames() on the wrapped request object.
 String getCharacterEncoding()
The default behavior of this method is to return getCharacterEncoding() on the wrapped request object.
 int getContentLength()
The default behavior of this method is to return getContentLength() on the wrapped request object.
 String getContentType()
The default behavior of this method is to return getContentType() on the wrapped request object.
 ServletInputStream getInputStream()
The default behavior of this method is to return getInputStream() on the wrapped request object.
 String getLocalAddr()
The default behavior of this method is to return getLocalAddr() on the wrapped request object.
 Locale getLocale()
The default behavior of this method is to return getLocale() on the wrapped request object.
 Enumeration getLocales()
The default behavior of this method is to return getLocales() on the wrapped request object.
 String getLocalName()
The default behavior of this method is to return getLocalName() on the wrapped request object.
 int getLocalPort()
The default behavior of this method is to return getLocalPort() on the wrapped request object.
 String getParameter(String name)
The default behavior of this method is to return getParameter(String name) on the wrapped request object.
 Map getParameterMap()
The default behavior of this method is to return getParameterMap() on the wrapped request object.
 Enumeration getParameterNames()
The default behavior of this method is to return getParameterNames() on the wrapped request object.
 String[] getParameterValues(String name)
The default behavior of this method is to return getParameterValues(String name) on the wrapped request object.
 String getProtocol()
The default behavior of this method is to return getProtocol() on the wrapped request object.
 BufferedReader getReader()
The default behavior of this method is to return getReader() on the wrapped request object.
 String getRealPath(String path)
The default behavior of this method is to return getRealPath(String path) on the wrapped request object.
 String getRemoteAddr()
The default behavior of this method is to return getRemoteAddr() on the wrapped request object.
 String getRemoteHost()
The default behavior of this method is to return getRemoteHost() on the wrapped request object.
 int getRemotePort()
The default behavior of this method is to return getRemotePort() on the wrapped request object.
 ServletRequest getRequest()
Return the wrapped request object.
 RequestDispatcher getRequestDispatcher(String path)
The default behavior of this method is to return getRequestDispatcher(String path) on the wrapped request object.
 String getScheme()
The default behavior of this method is to return getScheme() on the wrapped request object.
 String getServerName()
The default behavior of this method is to return getServerName() on the wrapped request object.
 int getServerPort()
The default behavior of this method is to return getServerPort() on the wrapped request object.
 boolean isSecure()
The default behavior of this method is to return isSecure() on the wrapped request object.
 void removeAttribute(String name)
The default behavior of this method is to call removeAttribute(String name) on the wrapped request object.
 void setAttribute(String name, Object o)
The default behavior of this method is to return setAttribute(String name, Object o) on the wrapped request object.
 void setCharacterEncoding(String enc)
The default behavior of this method is to set the character encoding on the wrapped request object.
 void setRequest(ServletRequest request)
Sets the request object being wrapped.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServletRequestWrapper

public ServletRequestWrapper(ServletRequest request)
Creates a ServletRequest adaptor wrapping the given request object.

Throws:
IllegalArgumentException - if the request is null
Method Detail

getRequest

public ServletRequest getRequest()
Return the wrapped request object.

setRequest

public void setRequest(ServletRequest request)
Sets the request object being wrapped.

Throws:
IllegalArgumentException - if the request is null.

getAttribute

public Object getAttribute(String name)
The default behavior of this method is to call getAttribute(String name) on the wrapped request object.

Specified by:
getAttribute in interface ServletRequest
Parameters:
name - a String specifying the name of the attribute
Returns:
an Object containing the value of the attribute, or null if the attribute does not exist

getAttributeNames

public Enumeration getAttributeNames()
The default behavior of this method is to return getAttributeNames() on the wrapped request object.

Specified by:
getAttributeNames in interface ServletRequest
Returns:
an Enumeration of strings containing the names of the request's attributes

getCharacterEncoding

public String getCharacterEncoding()
The default behavior of this method is to return getCharacterEncoding() on the wrapped request object.

Specified by:
getCharacterEncoding in interface ServletRequest
Returns:
a String containing the name of the character encoding, or null if the request does not specify a character encoding

setCharacterEncoding

public void setCharacterEncoding(String enc)
                          throws UnsupportedEncodingException
The default behavior of this method is to set the character encoding on the wrapped request object.

Specified by:
setCharacterEncoding in interface ServletRequest
Parameters:
enc - String containing the name of the character encoding.
Throws:
UnsupportedEncodingException - if this ServletRequest is still in a state where a character encoding may be set, but the specified encoding is invalid

getContentLength

public int getContentLength()
The default behavior of this method is to return getContentLength() on the wrapped request object.

Specified by:
getContentLength in interface ServletRequest
Returns:
an integer containing the length of the request body or -1 if the length is not known

getContentType

public String getContentType()
The default behavior of this method is to return getContentType() on the wrapped request object.

Specified by:
getContentType in interface ServletRequest
Returns:
a String containing the name of the MIME type of the request, or null if the type is not known

getInputStream

public ServletInputStream getInputStream()
                                  throws IOException
The default behavior of this method is to return getInputStream() on the wrapped request object.

Specified by:
getInputStream in interface ServletRequest
Returns:
a ServletInputStream object containing the body of the request
Throws:
IOException - if an input or output exception occurred

getParameter

public String getParameter(String name)
The default behavior of this method is to return getParameter(String name) on the wrapped request object.

Specified by:
getParameter in interface ServletRequest
Parameters:
name - a String specifying the name of the parameter
Returns:
a String representing the single value of the parameter
See Also:
ServletRequest.getParameterValues(java.lang.String)

getParameterMap

public Map getParameterMap()
The default behavior of this method is to return getParameterMap() on the wrapped request object.

Specified by:
getParameterMap in interface ServletRequest
Returns:
an immutable java.util.Map containing parameter names as keys and parameter values as map values. The keys in the parameter map are of type String. The values in the parameter map are of type String array.

getParameterNames

public Enumeration getParameterNames()
The default behavior of this method is to return getParameterNames() on the wrapped request object.

Specified by:
getParameterNames in interface ServletRequest
Returns:
an Enumeration of String objects, each String containing the name of a request parameter; or an empty Enumeration if the request has no parameters

getParameterValues

public String[] getParameterValues(String name)
The default behavior of this method is to return getParameterValues(String name) on the wrapped request object.

Specified by:
getParameterValues in interface ServletRequest
Parameters:
name - a String containing the name of the parameter whose value is requested
Returns:
an array of String objects containing the parameter's values
See Also:
ServletRequest.getParameter(java.lang.String)

getProtocol

public String getProtocol()
The default behavior of this method is to return getProtocol() on the wrapped request object.

Specified by:
getProtocol in interface ServletRequest
Returns:
a String containing the protocol name and version number

getScheme

public String getScheme()
The default behavior of this method is to return getScheme() on the wrapped request object.

Specified by:
getScheme in interface ServletRequest
Returns:
a String containing the name of the scheme used to make this request

getServerName

public String getServerName()
The default behavior of this method is to return getServerName() on the wrapped request object.

Specified by:
getServerName in interface ServletRequest
Returns:
a String containing the name of the server

getServerPort

public int getServerPort()
The default behavior of this method is to return getServerPort() on the wrapped request object.

Specified by:
getServerPort in interface ServletRequest
Returns:
an integer specifying the port number

getReader

public BufferedReader getReader()
                         throws IOException
The default behavior of this method is to return getReader() on the wrapped request object.

Specified by:
getReader in interface ServletRequest
Returns:
a BufferedReader containing the body of the request
Throws:
IOException - if an input or output exception occurred
See Also:
ServletRequest.getInputStream()

getRemoteAddr

public String getRemoteAddr()
The default behavior of this method is to return getRemoteAddr() on the wrapped request object.

Specified by:
getRemoteAddr in interface ServletRequest
Returns:
a String containing the IP address of the client that sent the request

getRemoteHost

public String getRemoteHost()
The default behavior of this method is to return getRemoteHost() on the wrapped request object.

Specified by:
getRemoteHost in interface ServletRequest
Returns:
a String containing the fully qualified name of the client

setAttribute

public void setAttribute(String name,
                         Object o)
The default behavior of this method is to return setAttribute(String name, Object o) on the wrapped request object.

Specified by:
setAttribute in interface ServletRequest
Parameters:
name - a String specifying the name of the attribute
o - the Object to be stored

removeAttribute

public void removeAttribute(String name)
The default behavior of this method is to call removeAttribute(String name) on the wrapped request object.

Specified by:
removeAttribute in interface ServletRequest
Parameters:
name - a String specifying the name of the attribute to remove

getLocale

public Locale getLocale()
The default behavior of this method is to return getLocale() on the wrapped request object.

Specified by:
getLocale in interface ServletRequest
Returns:
the preferred Locale for the client

getLocales

public Enumeration getLocales()
The default behavior of this method is to return getLocales() on the wrapped request object.

Specified by:
getLocales in interface ServletRequest
Returns:
an Enumeration of preferred Locale objects for the client

isSecure

public boolean isSecure()
The default behavior of this method is to return isSecure() on the wrapped request object.

Specified by:
isSecure in interface ServletRequest
Returns:
a boolean indicating if the request was made using a secure channel

getRequestDispatcher

public RequestDispatcher getRequestDispatcher(String path)
The default behavior of this method is to return getRequestDispatcher(String path) on the wrapped request object.

Specified by:
getRequestDispatcher in interface ServletRequest
Parameters:
path - a String specifying the pathname to the resource. If it is relative, it must be relative against the current servlet.
Returns:
a RequestDispatcher object that acts as a wrapper for the resource at the specified path, or null if the servlet container cannot return a RequestDispatcher
See Also:
RequestDispatcher, ServletContext.getRequestDispatcher(java.lang.String)

getRealPath

public String getRealPath(String path)
The default behavior of this method is to return getRealPath(String path) on the wrapped request object.

Specified by:
getRealPath in interface ServletRequest

getRemotePort

public int getRemotePort()
The default behavior of this method is to return getRemotePort() on the wrapped request object.

Specified by:
getRemotePort in interface ServletRequest
Returns:
an integer specifying the port number
Since:
2.4

getLocalName

public String getLocalName()
The default behavior of this method is to return getLocalName() on the wrapped request object.

Specified by:
getLocalName in interface ServletRequest
Returns:
a String containing the host name of the IP on which the request was received.
Since:
2.4

getLocalAddr

public String getLocalAddr()
The default behavior of this method is to return getLocalAddr() on the wrapped request object.

Specified by:
getLocalAddr in interface ServletRequest
Returns:
a String containing the IP address on which the request was received.
Since:
2.4

getLocalPort

public int getLocalPort()
The default behavior of this method is to return getLocalPort() on the wrapped request object.

Specified by:
getLocalPort in interface ServletRequest
Returns:
an integer specifying the port number
Since:
2.4
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletResponse

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Interface ServletResponse

All Known Subinterfaces:
HttpServletResponse
All Known Implementing Classes:
HttpServletResponseWrapper, ServletResponseWrapper
public interface ServletResponse

Defines an object to assist a servlet in sending a response to the client. The servlet container creates a ServletResponse object and passes it as an argument to the servlet's service method.

To send binary data in a MIME body response, use the ServletOutputStream returned by getOutputStream(). To send character data, use the PrintWriter object returned by getWriter(). To mix binary and text data, for example, to create a multipart response, use a ServletOutputStream and manage the character sections manually.

The charset for the MIME body response can be specified explicitly using the setCharacterEncoding(java.lang.String) and setContentType(java.lang.String) methods, or implicitly using the setLocale(java.util.Locale) method. Explicit specifications take precedence over implicit specifications. If no charset is specified, ISO-8859-1 will be used. The setCharacterEncoding, setContentType, or setLocale method must be called before getWriter and before committing the response for the character encoding to be used.

See the Internet RFCs such as RFC 2045 for more information on MIME. Protocols such as SMTP and HTTP define profiles of MIME, and those standards are still evolving.

Author:
Various
See Also:
ServletOutputStream

Method Summary
 void flushBuffer()
Forces any content in the buffer to be written to the client.
 int getBufferSize()
Returns the actual buffer size used for the response.
 String getCharacterEncoding()
Returns the name of the character encoding (MIME charset) used for the body sent in this response.
 String getContentType()
Returns the content type used for the MIME body sent in this response.
 Locale getLocale()
Returns the locale specified for this response using the setLocale(java.util.Locale) method.
 ServletOutputStream getOutputStream()
Returns a ServletOutputStream suitable for writing binary data in the response.
 PrintWriter getWriter()
Returns a PrintWriter object that can send character text to the client.
 boolean isCommitted()
Returns a boolean indicating if the response has been committed.
 void reset()
Clears any data that exists in the buffer as well as the status code and headers.
 void resetBuffer()
Clears the content of the underlying buffer in the response without clearing headers or status code.
 void setBufferSize(int size)
Sets the preferred buffer size for the body of the response.
 void setCharacterEncoding(String charset)
Sets the character encoding (MIME charset) of the response being sent to the client, for example, to UTF-8.
 void setContentLength(int len)
Sets the length of the content body in the response In HTTP servlets, this method sets the HTTP Content-Length header.
 void setContentType(String type)
Sets the content type of the response being sent to the client, if the response has not been committed yet.
 void setLocale(Locale loc)
Sets the locale of the response, if the response has not been committed yet.

Method Detail

getCharacterEncoding

String getCharacterEncoding()
Returns the name of the character encoding (MIME charset) used for the body sent in this response. The character encoding may have been specified explicitly using the setCharacterEncoding(java.lang.String) or setContentType(java.lang.String) methods, or implicitly using the setLocale(java.util.Locale) method. Explicit specifications take precedence over implicit specifications. Calls made to these methods after getWriter has been called or after the response has been committed have no effect on the character encoding. If no character encoding has been specified, ISO-8859-1 is returned.

See RFC 2047 (http://www.ietf.org/rfc/rfc2047.txt) for more information about character encoding and MIME.

Returns:
a String specifying the name of the character encoding, for example, UTF-8

getContentType

String getContentType()
Returns the content type used for the MIME body sent in this response. The content type proper must have been specified using setContentType(java.lang.String) before the response is committed. If no content type has been specified, this method returns null. If a content type has been specified, and a character encoding has been explicitly or implicitly specified as described in getCharacterEncoding() or getWriter() has been called, the charset parameter is included in the string returned. If no character encoding has been specified, the charset parameter is omitted.

Returns:
a String specifying the content type, for example, text/html; charset=UTF-8, or null
Since:
2.4

getOutputStream

ServletOutputStream getOutputStream()
                                    throws IOException
Returns a ServletOutputStream suitable for writing binary data in the response. The servlet container does not encode the binary data.

Calling flush() on the ServletOutputStream commits the response. Either this method or getWriter() may be called to write the body, not both.

Returns:
a ServletOutputStream for writing binary data
Throws:
IllegalStateException - if the getWriter method has been called on this response
IOException - if an input or output exception occurred
See Also:
getWriter()

getWriter

PrintWriter getWriter()
                      throws IOException
Returns a PrintWriter object that can send character text to the client. The PrintWriter uses the character encoding returned by getCharacterEncoding(). If the response's character encoding has not been specified as described in getCharacterEncoding (i.e., the method just returns the default value ISO-8859-1), getWriter updates it to ISO-8859-1.

Calling flush() on the PrintWriter commits the response.

Either this method or getOutputStream() may be called to write the body, not both.

Returns:
a PrintWriter object that can return character data to the client
Throws:
UnsupportedEncodingException - if the character encoding returned by getCharacterEncoding cannot be used
IllegalStateException - if the getOutputStream method has already been called for this response object
IOException - if an input or output exception occurred
See Also:
getOutputStream(), setCharacterEncoding(java.lang.String)

setCharacterEncoding

void setCharacterEncoding(String charset)
Sets the character encoding (MIME charset) of the response being sent to the client, for example, to UTF-8. If the character encoding has already been set by setContentType(java.lang.String) or setLocale(java.util.Locale), this method overrides it. Calling setContentType(java.lang.String) with the String of text/html and calling this method with the String of UTF-8 is equivalent with calling setContentType with the String of text/html; charset=UTF-8.

This method can be called repeatedly to change the character encoding. This method has no effect if it is called after getWriter has been called or after the response has been committed.

Containers must communicate the character encoding used for the servlet response's writer to the client if the protocol provides a way for doing so. In the case of HTTP, the character encoding is communicated as part of the Content-Type header for text media types. Note that the character encoding cannot be communicated via HTTP headers if the servlet does not specify a content type; however, it is still used to encode text written via the servlet response's writer.

Parameters:
charset - a String specifying only the character set defined by IANA Character Sets (http://www.iana.org/assignments/character-sets)
Since:
2.4
See Also:
#setLocale

setContentLength

void setContentLength(int len)
Sets the length of the content body in the response In HTTP servlets, this method sets the HTTP Content-Length header.

Parameters:
len - an integer specifying the length of the content being returned to the client; sets the Content-Length header

setContentType

void setContentType(String type)
Sets the content type of the response being sent to the client, if the response has not been committed yet. The given content type may include a character encoding specification, for example, text/html;charset=UTF-8. The response's character encoding is only set from the given content type if this method is called before getWriter is called.

This method may be called repeatedly to change content type and character encoding. This method has no effect if called after the response has been committed. It does not set the response's character encoding if it is called after getWriter has been called or after the response has been committed.

Containers must communicate the content type and the character encoding used for the servlet response's writer to the client if the protocol provides a way for doing so. In the case of HTTP, the Content-Type header is used.

Parameters:
type - a String specifying the MIME type of the content
See Also:
setLocale(java.util.Locale),
setCharacterEncoding(java.lang.String),
getOutputStream(),
getWriter()

setBufferSize

void setBufferSize(int size)
Sets the preferred buffer size for the body of the response. The servlet container will use a buffer at least as large as the size requested. The actual buffer size used can be found using getBufferSize.

A larger buffer allows more content to be written before anything is actually sent, thus providing the servlet with more time to set appropriate status codes and headers. A smaller buffer decreases server memory load and allows the client to start receiving data more quickly.

This method must be called before any response body content is written; if content has been written or the response object has been committed, this method throws an IllegalStateException.

Parameters:
size - the preferred buffer size
Throws:
IllegalStateException - if this method is called after content has been written
See Also:
getBufferSize(),
flushBuffer(),
isCommitted(),
reset()

getBufferSize

int getBufferSize()
Returns the actual buffer size used for the response. If no buffering is used, this method returns 0.

Returns:
the actual buffer size used
See Also:
setBufferSize(int),
flushBuffer(),
isCommitted(),
reset()

flushBuffer

void flushBuffer()
                 throws IOException
Forces any content in the buffer to be written to the client. A call to this method automatically commits the response, meaning the status code and headers will be written.

Throws:
IOException
See Also:
setBufferSize(int),
getBufferSize(),
isCommitted(),
reset()

resetBuffer

void resetBuffer()
Clears the content of the underlying buffer in the response without clearing headers or status code. If the response has been committed, this method throws an IllegalStateException.

Since:
2.3
See Also:
setBufferSize(int),
getBufferSize(),
isCommitted(),
reset()

isCommitted

boolean isCommitted()
Returns a boolean indicating if the response has been committed. A committed response has already had its status code and headers written.

Returns:
a boolean indicating if the response has been committed
See Also:
setBufferSize(int),
getBufferSize(),
flushBuffer(),
reset()

reset

void reset()
Clears any data that exists in the buffer as well as the status code and headers. If the response has been committed, this method throws an IllegalStateException.

Throws:
IllegalStateException - if the response has already been committed
See Also:
setBufferSize(int),
getBufferSize(),
flushBuffer(),
isCommitted()

setLocale

void setLocale(Locale loc)
Sets the locale of the response, if the response has not been committed yet. It also sets the response's character encoding appropriately for the locale, if the character encoding has not been explicitly set using setContentType(java.lang.String) or setCharacterEncoding(java.lang.String), getWriter hasn't been called yet, and the response hasn't been committed yet. If the deployment descriptor contains a locale-encoding-mapping-list element, and that element provides a mapping for the given locale, that mapping is used. Otherwise, the mapping from locale to character encoding is container dependent.

This method may be called repeatedly to change locale and character encoding. The method has no effect if called after the response has been committed. It does not set the response's character encoding if it is called after setContentType(java.lang.String) has been called with a charset specification, after setCharacterEncoding(java.lang.String) has been called, after getWriter has been called, or after the response has been committed.

Containers must communicate the locale and the character encoding used for the servlet response's writer to the client if the protocol provides a way for doing so. In the case of HTTP, the locale is communicated via the Content-Language header, the character encoding as part of the Content-Type header for text media types. Note that the character encoding cannot be communicated via HTTP headers if the servlet does not specify a content type; however, it is still used to encode text written via the servlet response's writer.

Parameters:
loc - the locale of the response
See Also:
getLocale(),
setContentType(java.lang.String),
setCharacterEncoding(java.lang.String)

getLocale

Locale getLocale()
Returns the locale specified for this response using the setLocale(java.util.Locale) method. Calls made to setLocale after the response is committed have no effect. If no locale has been specified, the container's default locale is returned.

See Also:
setLocale(java.util.Locale)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletResponseWrapper

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class ServletResponseWrapper

java.lang.Object
    extended by  javax.servlet.ServletResponseWrapper
All Implemented Interfaces:
ServletResponse
Direct Known Subclasses:
HttpServletResponseWrapper
public class ServletResponseWrapper
extends Object
implements ServletResponse

Provides a convenient implementation of the ServletResponse interface that can be subclassed by developers wishing to adapt the response from a Servlet. This class implements the Wrapper or Decorator pattern. Methods default to calling through to the wrapped response object.

Since:
v 2.3
Author:
Various
See Also:
ServletResponse

Constructor Summary
ServletResponseWrapper(ServletResponse response)
Creates a ServletResponse adaptor wrapping the given response object.
Method Summary
 void flushBuffer()
The default behavior of this method is to call flushBuffer() on the wrapped response object.
 int getBufferSize()
The default behavior of this method is to return getBufferSize() on the wrapped response object.
 String getCharacterEncoding()
The default behavior of this method is to return getCharacterEncoding() on the wrapped response object.
 String getContentType()
The default behavior of this method is to return getContentType() on the wrapped response object.
 Locale getLocale()
The default behavior of this method is to return getLocale() on the wrapped response object.
 ServletOutputStream getOutputStream()
The default behavior of this method is to return getOutputStream() on the wrapped response object.
 ServletResponse getResponse()
Return the wrapped ServletResponse object.
 PrintWriter getWriter()
The default behavior of this method is to return getWriter() on the wrapped response object.
 boolean isCommitted()
The default behavior of this method is to return isCommitted() on the wrapped response object.
 void reset()
The default behavior of this method is to call reset() on the wrapped response object.
 void resetBuffer()
The default behavior of this method is to call resetBuffer() on the wrapped response object.
 void setBufferSize(int size)
The default behavior of this method is to call setBufferSize(int size) on the wrapped response object.
 void setCharacterEncoding(String charset)
The default behavior of this method is to call setCharacterEncoding(String charset) on the wrapped response object.
 void setContentLength(int len)
The default behavior of this method is to call setContentLength(int len) on the wrapped response object.
 void setContentType(String type)
The default behavior of this method is to call setContentType(String type) on the wrapped response object.
 void setLocale(Locale loc)
The default behavior of this method is to call setLocale(Locale loc) on the wrapped response object.
 void setResponse(ServletResponse response)
Sets the response being wrapped.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServletResponseWrapper

public ServletResponseWrapper(ServletResponse response)
Creates a ServletResponse adaptor wrapping the given response object.

Throws:
IllegalArgumentException - if the response is null.
Method Detail

getResponse

public ServletResponse getResponse()
Return the wrapped ServletResponse object.

setResponse

public void setResponse(ServletResponse response)
Sets the response being wrapped.

Throws:
IllegalArgumentException - if the response is null.

setCharacterEncoding

public void setCharacterEncoding(String charset)
The default behavior of this method is to call setCharacterEncoding(String charset) on the wrapped response object.

Specified by:
setCharacterEncoding in interface ServletResponse
Parameters:
charset - a String specifying only the character set defined by IANA Character Sets (http://www.iana.org/assignments/character-sets)
Since:
2.4
See Also:
#setLocale

getCharacterEncoding

public String getCharacterEncoding()
The default behavior of this method is to return getCharacterEncoding() on the wrapped response object.

Specified by:
getCharacterEncoding in interface ServletResponse
Returns:
a String specifying the name of the character encoding, for example, UTF-8

getOutputStream

public ServletOutputStream getOutputStream()
                                    throws IOException
The default behavior of this method is to return getOutputStream() on the wrapped response object.

Specified by:
getOutputStream in interface ServletResponse
Returns:
a ServletOutputStream for writing binary data
Throws:
IOException - if an input or output exception occurred
See Also:
ServletResponse.getWriter()

getWriter

public PrintWriter getWriter()
                      throws IOException
The default behavior of this method is to return getWriter() on the wrapped response object.

Specified by:
getWriter in interface ServletResponse
Returns:
a PrintWriter object that can return character data to the client
Throws:
IOException - if an input or output exception occurred
See Also:
ServletResponse.getOutputStream(), ServletResponse.setCharacterEncoding(java.lang.String)

setContentLength

public void setContentLength(int len)
The default behavior of this method is to call setContentLength(int len) on the wrapped response object.

Specified by:
setContentLength in interface ServletResponse
Parameters:
len - an integer specifying the length of the content being returned to the client; sets the Content-Length header

setContentType

public void setContentType(String type)
The default behavior of this method is to call setContentType(String type) on the wrapped response object.

Specified by:
setContentType in interface ServletResponse
Parameters:
type - a String specifying the MIME type of the content
See Also:
ServletResponse.setLocale(java.util.Locale),
ServletResponse.setCharacterEncoding(java.lang.String),
ServletResponse.getOutputStream(),
ServletResponse.getWriter()

getContentType

public String getContentType()
The default behavior of this method is to return getContentType() on the wrapped response object.

Specified by:
getContentType in interface ServletResponse
Returns:
a String specifying the content type, for example, text/html; charset=UTF-8, or null
Since:
2.4

setBufferSize

public void setBufferSize(int size)
The default behavior of this method is to call setBufferSize(int size) on the wrapped response object.

Specified by:
setBufferSize in interface ServletResponse
Parameters:
size - the preferred buffer size
See Also:
ServletResponse.getBufferSize(),
ServletResponse.flushBuffer(),
ServletResponse.isCommitted(),
ServletResponse.reset()

getBufferSize

public int getBufferSize()
The default behavior of this method is to return getBufferSize() on the wrapped response object.

Specified by:
getBufferSize in interface ServletResponse
Returns:
the actual buffer size used
See Also:
ServletResponse.setBufferSize(int),
ServletResponse.flushBuffer(),
ServletResponse.isCommitted(),
ServletResponse.reset()

flushBuffer

public void flushBuffer()
                 throws IOException
The default behavior of this method is to call flushBuffer() on the wrapped response object.

Specified by:
flushBuffer in interface ServletResponse
Throws:
IOException
See Also:
ServletResponse.setBufferSize(int),
ServletResponse.getBufferSize(),
ServletResponse.isCommitted(),
ServletResponse.reset()

isCommitted

public boolean isCommitted()
The default behavior of this method is to return isCommitted() on the wrapped response object.

Specified by:
isCommitted in interface ServletResponse
Returns:
a boolean indicating if the response has been committed
See Also:
ServletResponse.setBufferSize(int),
ServletResponse.getBufferSize(),
ServletResponse.flushBuffer(),
ServletResponse.reset()

reset

public void reset()
The default behavior of this method is to call reset() on the wrapped response object.

Specified by:
reset in interface ServletResponse
See Also:
ServletResponse.setBufferSize(int),
ServletResponse.getBufferSize(),
ServletResponse.flushBuffer(),
ServletResponse.isCommitted()

resetBuffer

public void resetBuffer()
The default behavior of this method is to call resetBuffer() on the wrapped response object.

Specified by:
resetBuffer in interface ServletResponse
See Also:
ServletResponse.setBufferSize(int),
ServletResponse.getBufferSize(),
ServletResponse.isCommitted(),
ServletResponse.reset()

setLocale

public void setLocale(Locale loc)
The default behavior of this method is to call setLocale(Locale loc) on the wrapped response object.

Specified by:
setLocale in interface ServletResponse
Parameters:
loc - the locale of the response
See Also:
ServletResponse.getLocale(),
ServletResponse.setContentType(java.lang.String),
ServletResponse.setCharacterEncoding(java.lang.String)

getLocale

public Locale getLocale()
The default behavior of this method is to return getLocale() on the wrapped response object.

Specified by:
getLocale in interface ServletResponse
See Also:
ServletResponse.setLocale(java.util.Locale)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UnavailableException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.servlet
Class UnavailableException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.servlet.ServletException
                extended by  javax.servlet.UnavailableException
All Implemented Interfaces:
Serializable
public class UnavailableException
extends ServletException

Defines an exception that a servlet or filter throws to indicate that it is permanently or temporarily unavailable.

When a servlet or filter is permanently unavailable, something is wrong with it, and it cannot handle requests until some action is taken. For example, a servlet might be configured incorrectly, or a filter's state may be corrupted. The component should log both the error and the corrective action that is needed.

A servlet or filter is temporarily unavailable if it cannot handle requests momentarily due to some system-wide problem. For example, a third-tier server might not be accessible, or there may be insufficient memory or disk storage to handle requests. A system administrator may need to take corrective action.

Servlet containers can safely treat both types of unavailable exceptions in the same way. However, treating temporary unavailability effectively makes the servlet container more robust. Specifically, the servlet container might block requests to the servlet or filter for a period of time suggested by the exception, rather than rejecting them until the servlet container restarts.

Author:
Various
See Also:
Serialized Form

Constructor Summary
UnavailableException(int seconds, Servlet servlet, String msg)
Deprecated. As of Java Servlet API 2.2, use UnavailableException(String, int) instead.
UnavailableException(Servlet servlet, String msg)
Deprecated. As of Java Servlet API 2.2, use UnavailableException(String) instead.
UnavailableException(String msg)
Constructs a new exception with a descriptive message indicating that the servlet is permanently unavailable.
UnavailableException(String msg, int seconds)
Constructs a new exception with a descriptive message indicating that the servlet is temporarily unavailable and giving an estimate of how long it will be unavailable.
Method Summary
Servlet | getServlet() Deprecated. As of Java Servlet API 2.2, with no replacement. Returns the servlet that is reporting its unavailability.
int | getUnavailableSeconds() Returns the number of seconds the servlet expects to be temporarily unavailable.
boolean | isPermanent() Returns a boolean indicating whether the servlet is permanently unavailable.
Methods inherited from class javax.servlet.ServletException
getRootCause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnavailableException

public UnavailableException(Servlet servlet,
                            String msg)
Deprecated. As of Java Servlet API 2.2, use UnavailableException(String) instead.

Parameters:
servlet - the Servlet instance that is unavailable
msg - a String specifying the descriptive message

UnavailableException

public UnavailableException(int seconds,
                            Servlet servlet,
                            String msg)
Deprecated. As of Java Servlet API 2.2, use UnavailableException(String, int) instead.

Parameters:
seconds - an integer specifying the number of seconds the servlet expects to be unavailable; if zero or negative, indicates that the servlet can't make an estimate
servlet - the Servlet that is unavailable
msg - a String specifying the descriptive message, which can be written to a log file or displayed for the user.

UnavailableException

public UnavailableException(String msg)
Constructs a new exception with a descriptive message indicating that the servlet is permanently unavailable.

Parameters:
msg - a String specifying the descriptive message

UnavailableException

public UnavailableException(String msg,
                            int seconds)
Constructs a new exception with a descriptive message indicating that the servlet is temporarily unavailable and giving an estimate of how long it will be unavailable.

In some cases, the servlet cannot make an estimate. For example, the servlet might know that a server it needs is not running, but not be able to report how long it will take to be restored to functionality. This can be indicated with a negative or zero value for the seconds argument.

Parameters:
msg - a String specifying the descriptive message, which can be written to a log file or displayed for the user.
seconds - an integer specifying the number of seconds the servlet expects to be unavailable; if zero or negative, indicates that the servlet can't make an estimate
Method Detail

isPermanent

public boolean isPermanent()
Returns a boolean indicating whether the servlet is permanently unavailable. If so, something is wrong with the servlet, and the system administrator must take some corrective action.

Returns:
true if the servlet is permanently unavailable; false if the servlet is available or temporarily unavailable

getServlet

public Servlet getServlet()
Deprecated. As of Java Servlet API 2.2, with no replacement. Returns the servlet that is reporting its unavailability.

Returns:
the Servlet object that is throwing the UnavailableException

getUnavailableSeconds

public int getUnavailableSeconds()
Returns the number of seconds the servlet expects to be temporarily unavailable.

If this method returns a negative number, the servlet is permanently unavailable or cannot provide an estimate of how long it will be unavailable. No effort is made to correct for the time elapsed since the exception was first reported.

Returns:
an integer specifying the number of seconds the servlet will be temporarily unavailable, or a negative number if the servlet is permanently unavailable or cannot make an estimate
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


transaction

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.transaction

Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server.

See:
Description

Interface Summary
Status | The Status interface defines static variables used for transaction status codes.
Synchronization | The transaction manager supports a synchronization mechanism that allows the interested party to be notified before and after the transaction completes.
Transaction | The Transaction interface allows operations to be performed against the transaction in the target Transaction object.
TransactionManager | The TransactionManager interface defines the methods that allow an application server to manage transaction boundaries.
TransactionSynchronizationRegistry | This interface is intended for use by system level application server components such as persistence managers, resource adapters, as well as EJB and Web application components.
UserTransaction | The UserTransaction interface defines the methods that allow an application to explicitly manage transaction boundaries.

Exception Summary
HeuristicCommitException | This exception is thrown by the rollback operation on a resource to report that a heuristic decision was made and that all relevant updates have been committed.
HeuristicMixedException | This exception is thrown to report that a heuristic decision was made and that some relevant updates have been committed and others have been rolled back.
HeuristicRollbackException | This exception is thrown by the commit operation to report that a heuristic decision was made and that all relevant updates have been rolled back.
InvalidTransactionException | This exception indicates that the request carried an invalid transaction context.
NotSupportedException | NotSupportedException exception indicates that the request cannot be executed because the operation is not a supported feature.
RollbackException | RollbackException exception is thrown when the transaction has been marked for rollback only or the transaction has been rolled back instead of committed.
SystemException | The SystemException is thrown by the transaction manager to indicate that it has encountered an unexpected error condition that prevents future transaction services from proceeding.
TransactionRequiredException | This exception indicates that a request carried a null transaction context, but the target object requires an activate transaction.
TransactionRolledbackException | This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back.

Package javax.transaction Description

Provides the API that defines the contract between the transaction manager and the various parties involved in a distributed transaction namely : resource manager, application, and application server. The implementation of this API is provided by the application server vendor and the resource manager driver vendor.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.transaction Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.transaction

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.transaction.HeuristicCommitException
        • javax.transaction.HeuristicMixedException
        • javax.transaction.HeuristicRollbackException
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.transaction.InvalidTransactionException
            • javax.transaction.TransactionRequiredException
            • javax.transaction.TransactionRolledbackException
        • javax.transaction.NotSupportedException
        • javax.transaction.RollbackException
        • javax.transaction.SystemException

Interface Hierarchy

  • javax.transaction.Status
  • javax.transaction.Synchronization
  • javax.transaction.Transaction
  • javax.transaction.TransactionManager
  • javax.transaction.TransactionSynchronizationRegistry
  • javax.transaction.UserTransaction
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HeuristicCommitException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class HeuristicCommitException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.transaction.HeuristicCommitException
All Implemented Interfaces:
Serializable
public class HeuristicCommitException
extends Exception

This exception is thrown by the rollback operation on a resource to report that a heuristic decision was made and that all relevant updates have been committed.

See Also:
Serialized Form

Constructor Summary
HeuristicCommitException()
HeuristicCommitException(String msg)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HeuristicCommitException

public HeuristicCommitException()

HeuristicCommitException

public HeuristicCommitException(String msg)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HeuristicMixedException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class HeuristicMixedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.transaction.HeuristicMixedException
All Implemented Interfaces:
Serializable
public class HeuristicMixedException
extends Exception

This exception is thrown to report that a heuristic decision was made and that some relevant updates have been committed and others have been rolled back.

See Also:
Serialized Form

Constructor Summary
HeuristicMixedException()
HeuristicMixedException(String msg)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HeuristicMixedException

public HeuristicMixedException()

HeuristicMixedException

public HeuristicMixedException(String msg)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HeuristicRollbackException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class HeuristicRollbackException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.transaction.HeuristicRollbackException
All Implemented Interfaces:
Serializable
public class HeuristicRollbackException
extends Exception

This exception is thrown by the commit operation to report that a heuristic decision was made and that all relevant updates have been rolled back.

See Also:
Serialized Form

Constructor Summary
HeuristicRollbackException()
HeuristicRollbackException(String msg)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HeuristicRollbackException

public HeuristicRollbackException()

HeuristicRollbackException

public HeuristicRollbackException(String msg)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InvalidTransactionException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class InvalidTransactionException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.io.IOException
                extended by  java.rmi.RemoteException
                    extended by  javax.transaction.InvalidTransactionException
All Implemented Interfaces:
Serializable
public class InvalidTransactionException
extends RemoteException

This exception indicates that the request carried an invalid transaction context. For example, this exception could be raised if an error occured when trying to register a resource.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.rmi.RemoteException
detail
Constructor Summary
InvalidTransactionException()
InvalidTransactionException(String msg)
Method Summary
Methods inherited from class java.rmi.RemoteException
getCause, getMessage
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidTransactionException

public InvalidTransactionException()

InvalidTransactionException

public InvalidTransactionException(String msg)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NotSupportedException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class NotSupportedException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.transaction.NotSupportedException
All Implemented Interfaces:
Serializable
public class NotSupportedException
extends Exception

NotSupportedException exception indicates that the request cannot be executed because the operation is not a supported feature. For example, because nested transactions are not supported, the Transaction Manager throws this exception when a calling thread that is already associated with a transaction attempts to start a new transaction. (A nested transaction occurs when a thread is already associated with one transaction and attempts to start a second transaction.)

See Also:
Serialized Form

Constructor Summary
NotSupportedException()
NotSupportedException(String msg)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NotSupportedException

public NotSupportedException()

NotSupportedException

public NotSupportedException(String msg)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RollbackException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class RollbackException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.transaction.RollbackException
All Implemented Interfaces:
Serializable
public class RollbackException
extends Exception

RollbackException exception is thrown when the transaction has been marked for rollback only or the transaction has been rolled back instead of committed. This is a local exception thrown by methods in the UserTransaction, Transaction, and TransactionManager interfaces.

See Also:
Serialized Form

Constructor Summary
RollbackException()
RollbackException(String msg)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RollbackException

public RollbackException()

RollbackException

public RollbackException(String msg)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Status

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Interface Status

public interface Status

The Status interface defines static variables used for transaction status codes.

Field Summary
static int | STATUS_ACTIVE A transaction is associated with the target object and it is in the active state.
static int | STATUS_COMMITTED A transaction is associated with the target object and it has been committed.
static int | STATUS_COMMITTING A transaction is associated with the target object and it is in the process of committing.
static int | STATUS_MARKED_ROLLBACK A transaction is associated with the target object and it has been marked for rollback, perhaps as a result of a setRollbackOnly operation.
static int | STATUS_NO_TRANSACTION No transaction is currently associated with the target object.
static int | STATUS_PREPARED A transaction is associated with the target object and it has been prepared.
static int | STATUS_PREPARING A transaction is associated with the target object and it is in the process of preparing.
static int | STATUS_ROLLEDBACK A transaction is associated with the target object and the outcome has been determined to be rollback.
static int | STATUS_ROLLING_BACK A transaction is associated with the target object and it is in the process of rolling back.
static int | STATUS_UNKNOWN A transaction is associated with the target object but its current status cannot be determined.

Field Detail

STATUS_ACTIVE

static final int STATUS_ACTIVE
A transaction is associated with the target object and it is in the active state. An implementation returns this status after a transaction has been started and prior to a Coordinator issuing any prepares, unless the transaction has been marked for rollback.

See Also:
Constant Field Values

STATUS_MARKED_ROLLBACK

static final int STATUS_MARKED_ROLLBACK
A transaction is associated with the target object and it has been marked for rollback, perhaps as a result of a setRollbackOnly operation.

See Also:
Constant Field Values

STATUS_PREPARED

static final int STATUS_PREPARED
A transaction is associated with the target object and it has been prepared. That is, all subordinates have agreed to commit. The target object may be waiting for instructions from a superior as to how to proceed.

See Also:
Constant Field Values

STATUS_COMMITTED

static final int STATUS_COMMITTED
A transaction is associated with the target object and it has been committed. It is likely that heuristics exist; otherwise, the transaction would have been destroyed and NoTransaction returned.

See Also:
Constant Field Values

STATUS_ROLLEDBACK

static final int STATUS_ROLLEDBACK
A transaction is associated with the target object and the outcome has been determined to be rollback. It is likely that heuristics exist; otherwise, the transaction would have been destroyed and NoTransaction returned.

See Also:
Constant Field Values

STATUS_UNKNOWN

static final int STATUS_UNKNOWN
A transaction is associated with the target object but its current status cannot be determined. This is a transient condition and a subsequent invocation will ultimately return a different status.

See Also:
Constant Field Values

STATUS_NO_TRANSACTION

static final int STATUS_NO_TRANSACTION
No transaction is currently associated with the target object. This will occur after a transaction has completed.

See Also:
Constant Field Values

STATUS_PREPARING

static final int STATUS_PREPARING
A transaction is associated with the target object and it is in the process of preparing. An implementation returns this status if it has started preparing, but has not yet completed the process. The likely reason for this is that the implementation is probably waiting for responses to prepare from one or more Resources.

See Also:
Constant Field Values

STATUS_COMMITTING

static final int STATUS_COMMITTING
A transaction is associated with the target object and it is in the process of committing. An implementation returns this status if it has decided to commit but has not yet completed the committing process. This occurs because the implementation is probably waiting for responses from one or more Resources.

See Also:
Constant Field Values

STATUS_ROLLING_BACK

static final int STATUS_ROLLING_BACK
A transaction is associated with the target object and it is in the process of rolling back. An implementation returns this status if it has decided to rollback but has not yet completed the process. The implementation is probably waiting for responses from one or more Resources.

See Also:
Constant Field Values
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Synchronization

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Interface Synchronization

public interface Synchronization

The transaction manager supports a synchronization mechanism that allows the interested party to be notified before and after the transaction completes. Using the registerSynchronization method, the application server registers a Synchronization object for the transaction currently associated with the target Transaction object.

Method Summary
void | afterCompletion(int status) This method is called by the transaction manager after the transaction is committed or rolled back.
void | beforeCompletion() The beforeCompletion method is called by the transaction manager prior to the start of the two-phase transaction commit process.

Method Detail

beforeCompletion

void beforeCompletion()
The beforeCompletion method is called by the transaction manager prior to the start of the two-phase transaction commit process. This call is executed with the transaction context of the transaction that is being committed.

afterCompletion

void afterCompletion(int status)
This method is called by the transaction manager after the transaction is committed or rolled back.

Parameters:
status - The status of the transaction completion.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SystemException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class SystemException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.transaction.SystemException
All Implemented Interfaces:
Serializable
public class SystemException
extends Exception

The SystemException is thrown by the transaction manager to indicate that it has encountered an unexpected error condition that prevents future transaction services from proceeding.

See Also:
Serialized Form

Field Summary
 int errorCode
The error code with which to create the SystemException.
Constructor Summary
SystemException()
SystemException(int errcode)
Create a SystemException with a given error code.
SystemException(String s)
Create a SystemException with a given string.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

errorCode

public int errorCode
The error code with which to create the SystemException.

Constructor Detail

SystemException

public SystemException()

SystemException

public SystemException(String s)
Create a SystemException with a given string.

Parameters:
s - The string message for the exception

SystemException

public SystemException(int errcode)
Create a SystemException with a given error code.

Parameters:
errcode - The error code for the exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Transaction

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Interface Transaction

public interface Transaction

The Transaction interface allows operations to be performed against the transaction in the target Transaction object. A Transaction object is created corresponding to each global transaction creation. The Transaction object can be used for resource enlistment, synchronization registration, transaction completion, and status query operations.

Method Summary
void | commit() Complete the transaction represented by this Transaction object.
boolean | delistResource(XAResource xaRes, int flag) Disassociate the resource specified from the transaction associated with the target Transaction object.
boolean | enlistResource(XAResource xaRes) Enlist the resource specified with the transaction associated with the target Transaction object.
int | getStatus() Obtain the status of the transaction associated with the target Transaction object.
void | registerSynchronization(Synchronization sync) Register a synchronization object for the transaction currently associated with the target object.
void | rollback() Rollback the transaction represented by this Transaction object.
void | setRollbackOnly() Modify the transaction associated with the target object such that the only possible outcome of the transaction is to roll back the transaction.

Method Detail

commit

void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
Complete the transaction represented by this Transaction object.

Throws:
RollbackException - Thrown to indicate that the transaction has been rolled back rather than committed.
HeuristicMixedException - Thrown to indicate that a heuristic decision was made and that some relevant updates have been committed while others have been rolled back.
HeuristicRollbackException - Thrown to indicate that a heuristic decision was made and that all relevant updates have been rolled back.
SecurityException - Thrown to indicate that the thread is not allowed to commit the transaction.
IllegalStateException - Thrown if the transaction in the target object is inactive.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

delistResource

boolean delistResource(XAResource xaRes,
                       int flag)
                       throws IllegalStateException,
                              SystemException
Disassociate the resource specified from the transaction associated with the target Transaction object.

Parameters:
xaRes - The XAResource object associated with the resource (connection).
flag - One of the values of TMSUCCESS, TMSUSPEND, or TMFAIL.
Returns:
true if the resource was delisted successfully; otherwise false.
Throws:
IllegalStateException - Thrown if the transaction in the target object is inactive.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

enlistResource

boolean enlistResource(XAResource xaRes)
                       throws RollbackException,
                              IllegalStateException,
                              SystemException
Enlist the resource specified with the transaction associated with the target Transaction object.

Parameters:
xaRes - The XAResource object associated with the resource (connection).
Returns:
true if the resource was enlisted successfully; otherwise false.
Throws:
RollbackException - Thrown to indicate that the transaction has been marked for rollback only.
IllegalStateException - Thrown if the transaction in the target object is in the prepared state or the transaction is inactive.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

getStatus

int getStatus()
              throws SystemException
Obtain the status of the transaction associated with the target Transaction object.

Returns:
The transaction status. If no transaction is associated with the target object, this method returns the Status.NoTransaction value.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

registerSynchronization

void registerSynchronization(Synchronization sync)
                             throws RollbackException,
                                    IllegalStateException,
                                    SystemException
Register a synchronization object for the transaction currently associated with the target object. The transction manager invokes the beforeCompletion method prior to starting the two-phase transaction commit process. After the transaction is completed, the transaction manager invokes the afterCompletion method.

Parameters:
sync - The Synchronization object for the transaction associated with the target object.
Throws:
RollbackException - Thrown to indicate that the transaction has been marked for rollback only.
IllegalStateException - Thrown if the transaction in the target object is in the prepared state or the transaction is inactive.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

rollback

void rollback()
              throws IllegalStateException,
                     SystemException
Rollback the transaction represented by this Transaction object.

Throws:
IllegalStateException - Thrown if the transaction in the target object is in the prepared state or the transaction is inactive.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

setRollbackOnly

void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
Modify the transaction associated with the target object such that the only possible outcome of the transaction is to roll back the transaction.

Throws:
IllegalStateException - Thrown if the target object is not associated with any transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransactionManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Interface TransactionManager

public interface TransactionManager

The TransactionManager interface defines the methods that allow an application server to manage transaction boundaries.

Method Summary
void | begin() Create a new transaction and associate it with the current thread.
void | commit() Complete the transaction associated with the current thread.
int | getStatus() Obtain the status of the transaction associated with the current thread.
Transaction | getTransaction() Get the transaction object that represents the transaction context of the calling thread.
void | resume(Transaction tobj) Resume the transaction context association of the calling thread with the transaction represented by the supplied Transaction object.
void | rollback() Roll back the transaction associated with the current thread.
void | setRollbackOnly() Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.
void | setTransactionTimeout(int seconds) Modify the timeout value that is associated with transactions started by the current thread with the begin method.
Transaction | suspend() Suspend the transaction currently associated with the calling thread and return a Transaction object that represents the transaction context being suspended.

Method Detail

begin

void begin()
           throws NotSupportedException,
                  SystemException
Create a new transaction and associate it with the current thread.

Throws:
NotSupportedException - Thrown if the thread is already associated with a transaction and the Transaction Manager implementation does not support nested transactions.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

commit

void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
Complete the transaction associated with the current thread. When this method completes, the thread is no longer associated with a transaction.

Throws:
RollbackException - Thrown to indicate that the transaction has been rolled back rather than committed.
HeuristicMixedException - Thrown to indicate that a heuristic decision was made and that some relevant updates have been committed while others have been rolled back.
HeuristicRollbackException - Thrown to indicate that a heuristic decision was made and that all relevant updates have been rolled back.
SecurityException - Thrown to indicate that the thread is not allowed to commit the transaction.
IllegalStateException - Thrown if the current thread is not associated with a transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

getStatus

int getStatus()
              throws SystemException
Obtain the status of the transaction associated with the current thread.

Returns:
The transaction status. If no transaction is associated with the current thread, this method returns the Status.NoTransaction value.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

getTransaction

Transaction getTransaction()
                           throws SystemException
Get the transaction object that represents the transaction context of the calling thread.

Returns:
the Transaction object representing the transaction associated with the calling thread.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

resume

void resume(Transaction tobj)
            throws InvalidTransactionException,
                   IllegalStateException,
                   SystemException
Resume the transaction context association of the calling thread with the transaction represented by the supplied Transaction object. When this method returns, the calling thread is associated with the transaction context specified.

Parameters:
tobj - The Transaction object that represents the transaction to be resumed.
Throws:
InvalidTransactionException - Thrown if the parameter transaction object contains an invalid transaction.
IllegalStateException - Thrown if the thread is already associated with another transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

rollback

void rollback()
              throws IllegalStateException,
                     SecurityException,
                     SystemException
Roll back the transaction associated with the current thread. When this method completes, the thread is no longer associated with a transaction.

Throws:
SecurityException - Thrown to indicate that the thread is not allowed to roll back the transaction.
IllegalStateException - Thrown if the current thread is not associated with a transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

setRollbackOnly

void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.

Throws:
IllegalStateException - Thrown if the current thread is not associated with a transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

setTransactionTimeout

void setTransactionTimeout(int seconds)
                           throws SystemException
Modify the timeout value that is associated with transactions started by the current thread with the begin method.

If an application has not called this method, the transaction service uses some default value for the transaction timeout.

Parameters:
seconds - The value of the timeout in seconds. If the value is zero, the transaction service restores the default value. If the value is negative a SystemException is thrown.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

suspend

Transaction suspend()
                    throws SystemException
Suspend the transaction currently associated with the calling thread and return a Transaction object that represents the transaction context being suspended. If the calling thread is not associated with a transaction, the method returns a null object reference. When this method returns, the calling thread is not associated with a transaction.

Returns:
Transaction object representing the suspended transaction.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransactionRequiredException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class TransactionRequiredException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.io.IOException
                extended by  java.rmi.RemoteException
                    extended by  javax.transaction.TransactionRequiredException
All Implemented Interfaces:
Serializable
public class TransactionRequiredException
extends RemoteException

This exception indicates that a request carried a null transaction context, but the target object requires an activate transaction.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.rmi.RemoteException
detail
Constructor Summary
TransactionRequiredException()
TransactionRequiredException(String msg)
Method Summary
Methods inherited from class java.rmi.RemoteException
getCause, getMessage
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionRequiredException

public TransactionRequiredException()

TransactionRequiredException

public TransactionRequiredException(String msg)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransactionRolledbackException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Class TransactionRolledbackException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.io.IOException
                extended by  java.rmi.RemoteException
                    extended by  javax.transaction.TransactionRolledbackException
All Implemented Interfaces:
Serializable
public class TransactionRolledbackException
extends RemoteException

This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back. Thus the requested operation either could not be performed or was not performed because further computation on behalf of the transaction would be fruitless

See Also:
Serialized Form

Field Summary
Fields inherited from class java.rmi.RemoteException
detail
Constructor Summary
TransactionRolledbackException()
TransactionRolledbackException(String msg)
Method Summary
Methods inherited from class java.rmi.RemoteException
getCause, getMessage
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionRolledbackException

public TransactionRolledbackException()

TransactionRolledbackException

public TransactionRolledbackException(String msg)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TransactionSynchronizationRegistry

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Interface TransactionSynchronizationRegistry

public interface TransactionSynchronizationRegistry

This interface is intended for use by system level application server components such as persistence managers, resource adapters, as well as EJB and Web application components. This provides the ability to register synchronization objects with special ordering semantics, associate resource objects with the current transaction, get the transaction context of the current transaction, get current transaction status, and mark the current transaction for rollback. This interface is implemented by the application server by a stateless service object. The same object can be used by any number of components with thread safety.

In standard application server environments, an instance implementing this interface can be looked up by a standard name via JNDI. The standard name is java:comp/TransactionSynchronizationRegistry.

Since:
JTA 1.1

Method Summary
Object | getResource(Object key) Get an object from the Map of resources being managed for the transaction bound to the current thread at the time this method is called.
boolean | getRollbackOnly() Get the rollbackOnly status of the transaction bound to the current thread at the time this method is called.
Object | getTransactionKey() Return an opaque object to represent the transaction bound to the current thread at the time this method is called.
int | getTransactionStatus() Return the status of the transaction bound to the current thread at the time this method is called.
void | putResource(Object key, Object value) Add or replace an object in the Map of resources being managed for the transaction bound to the current thread at the time this method is called.
void | registerInterposedSynchronization(Synchronization sync) Register a Synchronization instance with special ordering semantics.
void | setRollbackOnly() Set the rollbackOnly status of the transaction bound to the current thread at the time this method is called.

Method Detail

getTransactionKey

Object getTransactionKey()
Return an opaque object to represent the transaction bound to the current thread at the time this method is called. This object overrides hashCode and equals to allow its use as the key in a hashMap for use by the caller. If there is no transaction currently active, return null.

This object will return the same hashCode and compare equal to all other objects returned by calling this method from any component executing in the same transaction context in the same application server.

The toString method returns a String that might be usable by a human reader to usefully understand the transaction context. The toString result is otherwise not defined. Specifically, there is no forward or backward compatibility guarantee of the results of toString.

The object is not necessarily serializable, and has no defined behavior outside the virtual machine whence it was obtained.

Returns:
an opaque object representing the transaction bound to the current thread at the time this method is called.
Since:
JTA 1.1

putResource

void putResource(Object key,
                 Object value)
Add or replace an object in the Map of resources being managed for the transaction bound to the current thread at the time this method is called. The supplied key should be of an caller- defined class so as not to conflict with other users. The class of the key must guarantee that the hashCode and equals methods are suitable for use as keys in a map. The key and value are not examined or used by the implementation. The general contract of this method is that of Map.put(Object, Object) for a Map that supports non-null keys and null values. For example, if there is already an value associated with the key, it is replaced by the value parameter.

Parameters:
key - the key for the Map entry.
value - the value for the Map entry.
Throws:
IllegalStateException - if no transaction is active.
NullPointerException - if the parameter key is null.
Since:
JTA 1.1

getResource

Object getResource(Object key)
Get an object from the Map of resources being managed for the transaction bound to the current thread at the time this method is called. The key should have been supplied earlier by a call to putResouce in the same transaction. If the key cannot be found in the current resource Map, null is returned. The general contract of this method is that of Map.get(Object) for a Map that supports non-null keys and null values. For example, the returned value is null if there is no entry for the parameter key or if the value associated with the key is actually null.

Parameters:
key - the key for the Map entry.
Returns:
the value associated with the key.
Throws:
IllegalStateException - if no transaction is active.
NullPointerException - if the parameter key is null.
Since:
JTA 1.1

registerInterposedSynchronization

void registerInterposedSynchronization(Synchronization sync)
Register a Synchronization instance with special ordering semantics. Its beforeCompletion will be called after all SessionSynchronization beforeCompletion callbacks and callbacks registered directly with the Transaction, but before the 2-phase commit process starts. Similarly, the afterCompletion callback will be called after 2-phase commit completes but before any SessionSynchronization and Transaction afterCompletion callbacks.

The beforeCompletion callback will be invoked in the transaction context of the transaction bound to the current thread at the time this method is called. Allowable methods include access to resources, e.g. Connectors. No access is allowed to "user components" (e.g. timer services or bean methods), as these might change the state of data being managed by the caller, and might change the state of data that has already been flushed by another caller of registerInterposedSynchronization. The general context is the component context of the caller of registerInterposedSynchronization.

The afterCompletion callback will be invoked in an undefined context. No access is permitted to "user components" as defined above. Resources can be closed but no transactional work can be performed with them.

If this method is invoked without an active transaction context, an IllegalStateException is thrown.

Other than the transaction context, no component J2EE context is active during either of the callbacks.

Parameters:
sync - the Synchronization instance.
Throws:
IllegalStateException - if no transaction is active.
Since:
JTA 1.1

getTransactionStatus

int getTransactionStatus()
Return the status of the transaction bound to the current thread at the time this method is called. This is the result of executing TransactionManager.getStatus() in the context of the transaction bound to the current thread at the time this method is called.

Returns:
the status of the transaction bound to the current thread at the time this method is called.
Since:
JTA 1.1

setRollbackOnly

void setRollbackOnly()
Set the rollbackOnly status of the transaction bound to the current thread at the time this method is called.

Throws:
IllegalStateException - if no transaction is active.
Since:
JTA 1.1

getRollbackOnly

boolean getRollbackOnly()
Get the rollbackOnly status of the transaction bound to the current thread at the time this method is called.

Returns:
the rollbackOnly status.
Throws:
IllegalStateException - if no transaction is active.
Since:
JTA 1.1
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UserTransaction

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.transaction
Interface UserTransaction

public interface UserTransaction

The UserTransaction interface defines the methods that allow an application to explicitly manage transaction boundaries.

Method Summary
void | begin() Create a new transaction and associate it with the current thread.
void | commit() Complete the transaction associated with the current thread.
int | getStatus() Obtain the status of the transaction associated with the current thread.
void | rollback() Roll back the transaction associated with the current thread.
void | setRollbackOnly() Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.
void | setTransactionTimeout(int seconds) Modify the timeout value that is associated with transactions started by the current thread with the begin method.

Method Detail

begin

void begin()
           throws NotSupportedException,
                  SystemException
Create a new transaction and associate it with the current thread.

Throws:
NotSupportedException - Thrown if the thread is already associated with a transaction and the Transaction Manager implementation does not support nested transactions.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

commit

void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
Complete the transaction associated with the current thread. When this method completes, the thread is no longer associated with a transaction.

Throws:
RollbackException - Thrown to indicate that the transaction has been rolled back rather than committed.
HeuristicMixedException - Thrown to indicate that a heuristic decision was made and that some relevant updates have been committed while others have been rolled back.
HeuristicRollbackException - Thrown to indicate that a heuristic decision was made and that all relevant updates have been rolled back.
SecurityException - Thrown to indicate that the thread is not allowed to commit the transaction.
IllegalStateException - Thrown if the current thread is not associated with a transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

rollback

void rollback()
              throws IllegalStateException,
                     SecurityException,
                     SystemException
Roll back the transaction associated with the current thread. When this method completes, the thread is no longer associated with a transaction.

Throws:
SecurityException - Thrown to indicate that the thread is not allowed to roll back the transaction.
IllegalStateException - Thrown if the current thread is not associated with a transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

setRollbackOnly

void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
Modify the transaction associated with the current thread such that the only possible outcome of the transaction is to roll back the transaction.

Throws:
IllegalStateException - Thrown if the current thread is not associated with a transaction.
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

getStatus

int getStatus()
              throws SystemException
Obtain the status of the transaction associated with the current thread.

Returns:
The transaction status. If no transaction is associated with the current thread, this method returns the Status.NoTransaction value.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.

setTransactionTimeout

void setTransactionTimeout(int seconds)
                           throws SystemException
Modify the timeout value that is associated with transactions started by the current thread with the begin method.

If an application has not called this method, the transaction service uses some default value for the transaction timeout.

Parameters:
seconds - The value of the timeout in seconds. If the value is zero, the transaction service restores the default value. If the value is negative a SystemException is thrown.
Throws:
SystemException - Thrown if the transaction manager encounters an unexpected error condition.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


xa

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.transaction.xa

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.

See:
Description

Interface Summary
XAResource | The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
Xid | The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.

Exception Summary
XAException The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.

Package javax.transaction.xa Description

Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions. The driver vendor for a specific resource manager provides the implementation of this API.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.transaction.xa Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.transaction.xa

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.transaction.xa.XAException

Interface Hierarchy

  • javax.transaction.xa.XAResource
  • javax.transaction.xa.Xid
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XAException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.transaction.xa
Class XAException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.transaction.xa.XAException
All Implemented Interfaces:
Serializable
public class XAException
extends Exception

The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.

See Also:
Serialized Form

Field Summary
int | errorCode The error code with which to create the SystemException.
static int | XA_HEURCOM The transaction branch has been heuristically committed.
static int | XA_HEURHAZ The transaction branch may have been heuristically completed.
static int | XA_HEURMIX The transaction branch has been heuristically committed and rolled back.
static int | XA_HEURRB The transaction branch has been heuristically rolled back.
static int | XA_NOMIGRATE Resumption must occur where the suspension occurred.
static int | XA_RBBASE The inclusive lower bound of the rollback codes.
static int | XA_RBCOMMFAIL Indicates that the rollback was caused by a communication failure.
static int | XA_RBDEADLOCK A deadlock was detected.
static int | XA_RBEND The inclusive upper bound of the rollback error code.
static int | XA_RBINTEGRITY A condition that violates the integrity of the resource was detected.
static int | XA_RBOTHER The resource manager rolled back the transaction branch for a reason not on this list.
static int | XA_RBPROTO A protocol error occurred in the resource manager.
static int | XA_RBROLLBACK Indicates that the rollback was caused by an unspecified reason.
static int | XA_RBTIMEOUT A transaction branch took too long.
static int | XA_RBTRANSIENT May retry the transaction branch.
static int | XA_RDONLY The transaction branch was read-only and has been committed.
static int | XA_RETRY Routine returned with no effect and may be reissued.
static int | XAER_ASYNC There is an asynchronous operation already outstanding.
static int | XAER_DUPID The XID already exists.
static int | XAER_INVAL Invalid arguments were given.
static int | XAER_NOTA The XID is not valid.
static int | XAER_OUTSIDE The resource manager is doing work outside a global transaction.
static int | XAER_PROTO Routine was invoked in an improper context.
static int | XAER_RMERR A resource manager error has occurred in the transaction branch.
static int | XAER_RMFAIL Resource manager is unavailable.
Constructor Summary
XAException()
Create an XAException.
XAException(int errcode)
Create an XAException with a given error code.
XAException(String s)
Create an XAException with a given string.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

errorCode

public int errorCode
The error code with which to create the SystemException.

XA_RBBASE

public static final int XA_RBBASE
The inclusive lower bound of the rollback codes.

See Also:
Constant Field Values

XA_RBROLLBACK

public static final int XA_RBROLLBACK
Indicates that the rollback was caused by an unspecified reason.

See Also:
Constant Field Values

XA_RBCOMMFAIL

public static final int XA_RBCOMMFAIL
Indicates that the rollback was caused by a communication failure.

See Also:
Constant Field Values

XA_RBDEADLOCK

public static final int XA_RBDEADLOCK
A deadlock was detected.

See Also:
Constant Field Values

XA_RBINTEGRITY

public static final int XA_RBINTEGRITY
A condition that violates the integrity of the resource was detected.

See Also:
Constant Field Values

XA_RBOTHER

public static final int XA_RBOTHER
The resource manager rolled back the transaction branch for a reason not on this list.

See Also:
Constant Field Values

XA_RBPROTO

public static final int XA_RBPROTO
A protocol error occurred in the resource manager.

See Also:
Constant Field Values

XA_RBTIMEOUT

public static final int XA_RBTIMEOUT
A transaction branch took too long.

See Also:
Constant Field Values

XA_RBTRANSIENT

public static final int XA_RBTRANSIENT
May retry the transaction branch.

See Also:
Constant Field Values

XA_RBEND

public static final int XA_RBEND
The inclusive upper bound of the rollback error code.

See Also:
Constant Field Values

XA_NOMIGRATE

public static final int XA_NOMIGRATE
Resumption must occur where the suspension occurred.

See Also:
Constant Field Values

XA_HEURHAZ

public static final int XA_HEURHAZ
The transaction branch may have been heuristically completed.

See Also:
Constant Field Values

XA_HEURCOM

public static final int XA_HEURCOM
The transaction branch has been heuristically committed.

See Also:
Constant Field Values

XA_HEURRB

public static final int XA_HEURRB
The transaction branch has been heuristically rolled back.

See Also:
Constant Field Values

XA_HEURMIX

public static final int XA_HEURMIX
The transaction branch has been heuristically committed and rolled back.

See Also:
Constant Field Values

XA_RETRY

public static final int XA_RETRY
Routine returned with no effect and may be reissued.

See Also:
Constant Field Values

XA_RDONLY

public static final int XA_RDONLY
The transaction branch was read-only and has been committed.

See Also:
Constant Field Values

XAER_ASYNC

public static final int XAER_ASYNC
There is an asynchronous operation already outstanding.

See Also:
Constant Field Values

XAER_RMERR

public static final int XAER_RMERR
A resource manager error has occurred in the transaction branch.

See Also:
Constant Field Values

XAER_NOTA

public static final int XAER_NOTA
The XID is not valid.

See Also:
Constant Field Values

XAER_INVAL

public static final int XAER_INVAL
Invalid arguments were given.

See Also:
Constant Field Values

XAER_PROTO

public static final int XAER_PROTO
Routine was invoked in an improper context.

See Also:
Constant Field Values

XAER_RMFAIL

public static final int XAER_RMFAIL
Resource manager is unavailable.

See Also:
Constant Field Values

XAER_DUPID

public static final int XAER_DUPID
The XID already exists.

See Also:
Constant Field Values

XAER_OUTSIDE

public static final int XAER_OUTSIDE
The resource manager is doing work outside a global transaction.

See Also:
Constant Field Values
Constructor Detail

XAException

public XAException()
Create an XAException.

XAException

public XAException(String s)
Create an XAException with a given string.

Parameters:
s - The String object containing the exception message.

XAException

public XAException(int errcode)
Create an XAException with a given error code.

Parameters:
errcode - The error code identifying the exception.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XAResource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.transaction.xa
Interface XAResource

public interface XAResource

The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).

The XA interface defines the contract between a Resource Manager and a Transaction Manager in a distributed transaction processing (DTP) environment. A JDBC driver or a JMS provider implements this interface to support the association between a global transaction and a database or message service connection.

The XAResource interface can be supported by any transactional resource that is intended to be used by application programs in an environment where transactions are controlled by an external transaction manager. An example of such a resource is a database management system. An application may access data through multiple database connections. Each database connection is enlisted with the transaction manager as a transactional resource. The transaction manager obtains an XAResource for each connection participating in a global transaction. The transaction manager uses the start method to associate the global transaction with the resource, and it uses the end method to disassociate the transaction from the resource. The resource manager is responsible for associating the global transaction to all work performed on its data between the start and end method invocations.

At transaction commit time, the resource managers are informed by the transaction manager to prepare, commit, or rollback a transaction according to the two-phase commit protocol.

Field Summary
static int | TMENDRSCAN Ends a recovery scan.
static int | TMFAIL Disassociates the caller and marks the transaction branch rollback-only.
static int | TMJOIN Caller is joining existing transaction branch.
static int | TMNOFLAGS Use TMNOFLAGS to indicate no flags value is selected.
static int | TMONEPHASE Caller is using one-phase optimization.
static int | TMRESUME Caller is resuming association with a suspended transaction branch.
static int | TMSTARTRSCAN Starts a recovery scan.
static int | TMSUCCESS Disassociates caller from a transaction branch.
static int | TMSUSPEND Caller is suspending (not ending) its association with a transaction branch.
static int | XA_OK The transaction work has been prepared normally.
static int | XA_RDONLY The transaction branch has been read-only and has been committed.
Method Summary
void | commit(Xid xid, boolean onePhase) Commits the global transaction specified by xid.
void | end(Xid xid, int flags) Ends the work performed on behalf of a transaction branch.
void | forget(Xid xid) Tells the resource manager to forget about a heuristically completed transaction branch.
int | getTransactionTimeout() Obtains the current transaction timeout value set for this XAResource instance.
boolean | isSameRM(XAResource xares) This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
int | prepare(Xid xid) Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
Xid[] | recover(int flag) Obtains a list of prepared transaction branches from a resource manager.
void | rollback(Xid xid) Informs the resource manager to roll back work done on behalf of a transaction branch.
boolean | setTransactionTimeout(int seconds) Sets the current transaction timeout value for this XAResource instance.
void | start(Xid xid, int flags) Starts work on behalf of a transaction branch specified in xid.

Field Detail

TMENDRSCAN

static final int TMENDRSCAN
Ends a recovery scan.

See Also:
Constant Field Values

TMFAIL

static final int TMFAIL
Disassociates the caller and marks the transaction branch rollback-only.

See Also:
Constant Field Values

TMJOIN

static final int TMJOIN
Caller is joining existing transaction branch.

See Also:
Constant Field Values

TMNOFLAGS

static final int TMNOFLAGS
Use TMNOFLAGS to indicate no flags value is selected.

See Also:
Constant Field Values

TMONEPHASE

static final int TMONEPHASE
Caller is using one-phase optimization.

See Also:
Constant Field Values

TMRESUME

static final int TMRESUME
Caller is resuming association with a suspended transaction branch.

See Also:
Constant Field Values

TMSTARTRSCAN

static final int TMSTARTRSCAN
Starts a recovery scan.

See Also:
Constant Field Values

TMSUCCESS

static final int TMSUCCESS
Disassociates caller from a transaction branch.

See Also:
Constant Field Values

TMSUSPEND

static final int TMSUSPEND
Caller is suspending (not ending) its association with a transaction branch.

See Also:
Constant Field Values

XA_RDONLY

static final int XA_RDONLY
The transaction branch has been read-only and has been committed.

See Also:
Constant Field Values

XA_OK

static final int XA_OK
The transaction work has been prepared normally.

See Also:
Constant Field Values
Method Detail

commit

void commit(Xid xid,
            boolean onePhase)
            throws XAException
Commits the global transaction specified by xid.

Parameters:
xid - A global transaction identifier
onePhase - If true, the resource manager should use a one-phase commit protocol to commit the work done on behalf of xid.
Throws:
XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

If the resource manager did not commit the transaction and the parameter onePhase is set to true, the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

end

void end(Xid xid,
         int flags)
         throws XAException
Ends the work performed on behalf of a transaction branch. The resource manager disassociates the XA resource from the transaction branch specified and lets the transaction complete.

If TMSUSPEND is specified in the flags, the transaction branch is temporarily suspended in an incomplete state. The transaction context is in a suspended state and must be resumed via the start method with TMRESUME specified.

If TMFAIL is specified, the portion of work has failed. The resource manager may mark the transaction as rollback-only

If TMSUCCESS is specified, the portion of work has completed successfully.

Parameters:
xid - A global transaction identifier that is the same as the identifier used previously in the start method.
flags - One of TMSUCCESS, TMFAIL, or TMSUSPEND.
Throws:
XAException - An error has occurred. Possible XAException values are XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, XAER_PROTO, or XA_RB*.

forget

void forget(Xid xid)
            throws XAException
Tells the resource manager to forget about a heuristically completed transaction branch.

Parameters:
xid - A global transaction identifier.
Throws:
XAException - An error has occurred. Possible exception values are XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

getTransactionTimeout

int getTransactionTimeout()
                          throws XAException
Obtains the current transaction timeout value set for this XAResource instance. If XAResource.setTransactionTimeout was not used prior to invoking this method, the return value is the default timeout set for the resource manager; otherwise, the value used in the previous setTransactionTimeout call is returned.

Returns:
the transaction timeout value in seconds.
Throws:
XAException - An error has occurred. Possible exception values are XAER_RMERR and XAER_RMFAIL.

isSameRM

boolean isSameRM(XAResource xares)
                 throws XAException
This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.

Parameters:
xares - An XAResource object whose resource manager instance is to be compared with the resource manager instance of the target object.
Returns:
true if it's the same RM instance; otherwise false.
Throws:
XAException - An error has occurred. Possible exception values are XAER_RMERR and XAER_RMFAIL.

prepare

int prepare(Xid xid)
            throws XAException
Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.

Parameters:
xid - A global transaction identifier.
Returns:
A value indicating the resource manager's vote on the outcome of the transaction. The possible values are: XA_RDONLY or XA_OK. If the resource manager wants to roll back the transaction, it should do so by raising an appropriate XAException in the prepare method.
Throws:
XAException - An error has occurred. Possible exception values are: XA_RB*, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

recover

Xid[] recover(int flag)
              throws XAException
Obtains a list of prepared transaction branches from a resource manager. The transaction manager calls this method during recovery to obtain the list of transaction branches that are currently in prepared or heuristically completed states.

Parameters:
flag - One of TMSTARTRSCAN, TMENDRSCAN, TMNOFLAGS. TMNOFLAGS must be used when no other flags are set in the parameter.
Returns:
The resource manager returns zero or more XIDs of the transaction branches that are currently in a prepared or heuristically completed state. If an error occurs during the operation, the resource manager should throw the appropriate XAException.
Throws:
XAException - An error has occurred. Possible values are XAER_RMERR, XAER_RMFAIL, XAER_INVAL, and XAER_PROTO.

rollback

void rollback(Xid xid)
              throws XAException
Informs the resource manager to roll back work done on behalf of a transaction branch.

Parameters:
xid - A global transaction identifier.
Throws:
XAException - An error has occurred. Possible XAExceptions are XA_HEURHAZ, XA_HEURCOM, XA_HEURRB, XA_HEURMIX, XAER_RMERR, XAER_RMFAIL, XAER_NOTA, XAER_INVAL, or XAER_PROTO.

If the transaction branch is already marked rollback-only the resource manager may throw one of the XA_RB* exceptions. Upon return, the resource manager has rolled back the branch's work and has released all held resources.

setTransactionTimeout

boolean setTransactionTimeout(int seconds)
                              throws XAException

Sets the current transaction timeout value for this XAResource instance. Once set, this timeout value is effective until setTransactionTimeout is invoked again with a different value. To reset the timeout value to the default value used by the resource manager, set the value to zero. If the timeout operation is performed successfully, the method returns true; otherwise false. If a resource manager does not support explicitly setting the transaction timeout value, this method returns false.

Parameters:
seconds - The transaction timeout value in seconds.
Returns:
true if the transaction timeout value is set successfully; otherwise false.
Throws:
XAException - An error has occurred. Possible exception values are XAER_RMERR, XAER_RMFAIL, or XAER_INVAL.

start

void start(Xid xid,
           int flags)
           throws XAException
Starts work on behalf of a transaction branch specified in xid. If TMJOIN is specified, the start applies to joining a transaction previously seen by the resource manager. If TMRESUME is specified, the start applies to resuming a suspended transaction specified in the parameter xid. If neither TMJOIN nor TMRESUME is specified and the transaction specified by xid has previously been seen by the resource manager, the resource manager throws the XAException exception with XAER_DUPID error code.

Parameters:
xid - A global transaction identifier to be associated with the resource.
flags - One of TMNOFLAGS, TMJOIN, or TMRESUME.
Throws:
XAException - An error has occurred. Possible exceptions are XA_RB*, XAER_RMERR, XAER_RMFAIL, XAER_DUPID, XAER_OUTSIDE, XAER_NOTA, XAER_INVAL, or XAER_PROTO.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Xid

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.transaction.xa
Interface Xid

public interface Xid

The Xid interface is a Java mapping of the X/Open transaction identifier XID structure. This interface specifies three accessor methods to retrieve a global transaction's format ID, global transaction ID, and branch qualifier. The Xid interface is used by the transaction manager and the resource managers. This interface is not visible to the application programs.

Field Summary
static int | MAXBQUALSIZE Maximum number of bytes returned by getBqual.
static int | MAXGTRIDSIZE Maximum number of bytes returned by getGtrid.
Method Summary
byte[] | getBranchQualifier() Obtain the transaction branch identifier part of XID as an array of bytes.
int | getFormatId() Obtain the format identifier part of the XID.
byte[] | getGlobalTransactionId() Obtain the global transaction identifier part of XID as an array of bytes.

Field Detail

MAXGTRIDSIZE

static final int MAXGTRIDSIZE
Maximum number of bytes returned by getGtrid.

See Also:
Constant Field Values

MAXBQUALSIZE

static final int MAXBQUALSIZE
Maximum number of bytes returned by getBqual.

See Also:
Constant Field Values
Method Detail

getFormatId

int getFormatId()
Obtain the format identifier part of the XID.

Returns:
Format identifier. O means the OSI CCR format.

getGlobalTransactionId

byte[] getGlobalTransactionId()
Obtain the global transaction identifier part of XID as an array of bytes.

Returns:
Global transaction identifier.

getBranchQualifier

byte[] getBranchQualifier()
Obtain the transaction branch identifier part of XID as an array of bytes.

Returns:
Global transaction identifier.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


bind

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.bind

Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

See:
Description

Interface Summary
DatatypeConverterInterface | The DatatypeConverterInterface is for JAXB provider use only.
Element | This is an element marker interface.
Marshaller | The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
NotIdentifiableEvent | This event indicates that a problem was encountered resolving an ID/IDREF.
ParseConversionEvent | This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
PrintConversionEvent | This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
Unmarshaller | The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
UnmarshallerHandler | Unmarshaller implemented as SAX ContentHandler.
ValidationEvent | This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
ValidationEventHandler | A basic event handler interface for validation errors.
ValidationEventLocator | Encapsulate the location of a ValidationEvent.
Validator | Deprecated. since JAXB 2.0

Class Summary
Binder<XmlNode> | Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.
DatatypeConverter | The javaType binding declaration can be used to customize the binding of an XML schema datatype to a Java datatype.
JAXBContext | The JAXBContext class provides the client's entry point to the JAXB API.
JAXBElement<T> | JAXB representation of an Xml Element.
JAXBElement.GlobalScope | Designates global scope for an xml element.
JAXBIntrospector | Provide access to JAXB xml binding data for a JAXB object.
Marshaller.Listener | Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.
SchemaOutputResolver | Controls where a JAXB implementation puts the generates schema files.
Unmarshaller.Listener | Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.

Exception Summary
JAXBException | This is the root exception class for all JAXB exceptions.
MarshalException | This exception indicates that an error has occurred while performing a marshal operation that the provider is unable to recover from.
PropertyException | This exception indicates that an error was encountered while getting or setting a property.
TypeConstraintException | This exception indicates that a violation of a dynamically checked type constraint was detected.
UnmarshalException | This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.
ValidationException | This exception indicates that an error has occurred while performing a validate operation.

Package javax.xml.bind Description

Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.

JAXBContext is the client-entry point to the runtime binding framework.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Element

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Interface Element

public interface Element

This is an element marker interface. Under certain circumstances, it is necessary for the binding compiler to generate derived java content classes that implement this interface. In those cases, client applications must supply element instances rather than types of elements. For more detail, see section 5.7 "Element Declaration" and 5.7.1 "Bind to Java Element Interface" of the specification.

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.bind Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.bind

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.Binder<XmlNode>
    • javax.xml.bind.DatatypeConverter
    • javax.xml.bind.JAXBContext
    • javax.xml.bind.JAXBElement<T> (implements java.io.Serializable)
    • javax.xml.bind.JAXBElement.GlobalScope
    • javax.xml.bind.JAXBIntrospector
    • javax.xml.bind.Marshaller.Listener
    • javax.xml.bind.SchemaOutputResolver
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.bind.JAXBException
          • javax.xml.bind.MarshalException
          • javax.xml.bind.PropertyException
          • javax.xml.bind.UnmarshalException
          • javax.xml.bind.ValidationException
        • java.lang.RuntimeException
          • javax.xml.bind.TypeConstraintException
    • javax.xml.bind.Unmarshaller.Listener

Interface Hierarchy

  • org.xml.sax.ContentHandler
    • javax.xml.bind.UnmarshallerHandler
  • javax.xml.bind.DatatypeConverterInterface
  • javax.xml.bind.Element
  • javax.xml.bind.Marshaller
  • javax.xml.bind.Unmarshaller
  • javax.xml.bind.ValidationEvent
    • javax.xml.bind.NotIdentifiableEvent
    • javax.xml.bind.ParseConversionEvent
    • javax.xml.bind.PrintConversionEvent
  • javax.xml.bind.ValidationEventHandler
  • javax.xml.bind.ValidationEventLocator
  • javax.xml.bind.Validator
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NotIdentifiableEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Interface NotIdentifiableEvent

All Superinterfaces:
ValidationEvent
All Known Implementing Classes:
NotIdentifiableEventImpl
public interface NotIdentifiableEvent
extends ValidationEvent

This event indicates that a problem was encountered resolving an ID/IDREF.

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.
See Also:
Validator, ValidationEventHandler

Field Summary
Fields inherited from interface javax.xml.bind.ValidationEvent
ERROR, FATAL_ERROR, WARNING
Method Summary
Methods inherited from interface javax.xml.bind.ValidationEvent
getLinkedException, getLocator, getMessage, getSeverity

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ParseConversionEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Interface ParseConversionEvent

All Superinterfaces:
ValidationEvent
All Known Implementing Classes:
ParseConversionEventImpl
public interface ParseConversionEvent
extends ValidationEvent

This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.
See Also:
ValidationEvent, ValidationEventHandler, Unmarshaller

Field Summary
Fields inherited from interface javax.xml.bind.ValidationEvent
ERROR, FATAL_ERROR, WARNING
Method Summary
Methods inherited from interface javax.xml.bind.ValidationEvent
getLinkedException, getLocator, getMessage, getSeverity

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PrintConversionEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Interface PrintConversionEvent

All Superinterfaces:
ValidationEvent
All Known Implementing Classes:
PrintConversionEventImpl
public interface PrintConversionEvent
extends ValidationEvent

This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.
See Also:
ValidationEvent, ValidationEventHandler, Marshaller

Field Summary
Fields inherited from interface javax.xml.bind.ValidationEvent
ERROR, FATAL_ERROR, WARNING
Method Summary
Methods inherited from interface javax.xml.bind.ValidationEvent
getLinkedException, getLocator, getMessage, getSeverity

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


annotation

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.bind.annotation

Defines annotations for customizing Java program elements to XML Schema mapping.

See:
Description

Interface Summary
DomHandler<ElementT,ResultT extends Result> Converts an element (and its descendants) from/to DOM (or similar) representation.

Class Summary
W3CDomHandler | DomHandler implementation for W3C DOM (org.w3c.dom package.)
XmlElement.DEFAULT | Used in XmlElement.type() to signal that the type be inferred from the signature of the property.
XmlElementDecl.GLOBAL | Used in XmlElementDecl.scope() to signal that the declaration is in the global scope.
XmlElementRef.DEFAULT | Used in XmlElementRef.type() to signal that the type be inferred from the signature of the property.
XmlSchemaType.DEFAULT | Used in XmlSchemaType.type() to signal that the type be inferred from the signature of the property.
XmlType.DEFAULT | Used in XmlType.factoryClass() to signal that either factory mehod is not used or that it's in the class with this XmlType itself.

Enum Summary
XmlAccessOrder | Used by XmlAccessorOrder to control the ordering of properties and fields in a JAXB bound class.
XmlAccessType | Used by XmlAccessorType to control serialization of fields or properties.
XmlNsForm | Enumeration of XML Schema namespace qualifications.

Annotation Types Summary
XmlAccessorOrder | Controls the ordering of fields and properties in a class.
XmlAccessorType | Controls whether fields or Javabean properties are serialized by default.
XmlAnyAttribute | Maps a JavaBean property to a map of wildcard attributes.
XmlAnyElement | Maps a JavaBean property to XML infoset representation and/or JAXB element.
XmlAttachmentRef | Marks a field/property that its XML form is a uri reference to mime content.
XmlAttribute | Maps a JavaBean property to a XML attribute.
XmlElement | Maps a JavaBean property to a XML element derived from property name.
XmlElementDecl | Maps a factory method to a XML element.
XmlElementRef | Maps a JavaBean property to a XML element derived from property's type.
XmlElementRefs | Marks a property that refers to classes with XmlElement or JAXBElement.
XmlElements | A container for multiple @XmlElement annotations.
XmlElementWrapper | Generates a wrapper element around XML representation.
XmlEnum | Maps an enum type Enum to XML representation.
XmlEnumValue | Maps an enum constant in Enum type to XML representation.
XmlID | Maps a JavaBean property to XML ID.
XmlIDREF | Maps a JavaBean property to XML IDREF.
XmlInlineBinaryData | Disable consideration of XOP encoding for datatypes that are bound to base64-encoded binary data in XML.
XmlList | Used to map a property to a list simple type.
XmlMimeType | Associates the MIME type that controls the XML representation of the property.
XmlMixed | Annotate a JavaBean multi-valued property to support mixed content.
XmlNs | Associates a namespace prefix with a XML namespace URI.
XmlRegistry | Marks a class that has XmlElementDecls.
XmlRootElement | Maps a class or an enum type to an XML element.
XmlSchema | Maps a package name to a XML namespace.
XmlSchemaType | Maps a Java type to a simple schema built-in type.
XmlSchemaTypes | A container for multiple @XmlSchemaType annotations.
XmlTransient | Prevents the mapping of a JavaBean property to XML representation.
XmlType | Maps a class or an enum type to a XML Schema type.
XmlValue | Enables mapping a class to a XML Schema complex type with a simpleContent or a XML Schema simple type.

Package javax.xml.bind.annotation Description

Defines annotations for customizing Java program elements to XML Schema mapping.

Package Specification

The following table shows the JAXB mapping annotations that can be associated with each program element.

Program Element JAXB annotation
Package
XmlAccessorOrder
XmlAccessorType
XmlSchema
XmlSchemaType
XmlSchemaTypes
XmlJavaTypeAdapter
XmlJavaTypeAdapters
Class
XmlAccessorOrder
XmlAccessorType
XmlInlineBinaryData
XmlRootElement
XmlType
XmlJavaTypeAdapter
Enum type
XmlEnum
XmlEnumValue (enum constant only)
XmlRootElement
XmlType
XmlJavaTypeAdapter
JavaBean Property/field
XmlElement
XmlElements
XmlElementRef
XmlElementRefs
XmlElementWrapper
XmlAnyElement
XmlAttribute
XmlAnyAttribute
XmlTransient
XmlValue
XmlID
XmlIDREF
XmlList
XmlMixed
XmlMimeType
XmlAttachmentRef
XmlInlineBinaryData
XmlElementDecl (only on method)
XmlJavaTypeAdapter
Parameter
XmlList
XmlAttachmentRef
XmlMimeType
XmlJavaTypeAdapter

Terminology

JavaBean property and field: For the purposes of mapping, there is no semantic difference between a field and a JavaBean property. Thus, an annotation that can be applied to a JavaBean property can always be applied to a field. Hence in the Javadoc documentation, for brevity, the term JavaBean property or property is used to mean either JavaBean property or a field. Where required, both are explicitly mentioned.

top level class: For the purpose of mapping, there is no semantic difference between a top level class and a static nested class. Thus, an annotation that can be applied to a top level class, can always be applied to a nested static class. Hence in the Javadoc documentation, for brevity, the term "top level class" or just class is used to mean either a top level class or a nested static class.

mapping annotation:A JAXB 2.0 defined program annotation based on the JSR 175 programming annotation facility.

Common Usage Constraints

The following usage constraints are defined here since they apply to more than annotation:

  • For a property, a given annotation can be applied to either read or write property but not both.
  • A property name must be different from any other property name in any of the super classes of the class being mapped.
  • A mapped field name or the decapitalized name of a mapped property must be unique within a class.

Notations

Namespace prefixes

The following namespace prefixes are used in the XML Schema fragments in this package.

Prefix | Namespace | Notes
xs | http://www.w3.org/2001/XMLSchema | Namespace of XML Schema namespace
ref | http://ws-i.org/profiles/basic/1.1/xsd | Namespace for swaref schema component
xsi | http://www.w3.org/2001/XMLSchema-instance | XML Schema namespace for instances

Since:
JAXB 2.0
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.bind.annotation Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.bind.annotation

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.annotation.W3CDomHandler (implements javax.xml.bind.annotation.DomHandler<ElementT,ResultT>)
    • javax.xml.bind.annotation.XmlElement.DEFAULT
    • javax.xml.bind.annotation.XmlElementDecl.GLOBAL
    • javax.xml.bind.annotation.XmlElementRef.DEFAULT
    • javax.xml.bind.annotation.XmlSchemaType.DEFAULT
    • javax.xml.bind.annotation.XmlType.DEFAULT

Interface Hierarchy

  • javax.xml.bind.annotation.DomHandler<ElementT,ResultT>

Annotation Type Hierarchy

  • javax.xml.bind.annotation.XmlAccessorOrder (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttachmentRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementDecl (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRefs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElements (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnum (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnumValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlID (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlIDREF (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlInlineBinaryData (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlList (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMimeType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMixed (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlNs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRegistry (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRootElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchema (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaTypes (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlTransient (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlValue (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.bind.annotation.XmlAccessOrder
      • javax.xml.bind.annotation.XmlAccessType
      • javax.xml.bind.annotation.XmlNsForm
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlAnyAttribute

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlAnyAttribute

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlAnyAttribute

Maps a JavaBean property to a map of wildcard attributes.

Usage

The @XmlAnyAttribute annotation can be used with the following program elements:

  • JavaBean property
  • non static, non transient field

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

The usage is subject to the following constraints:
  • At most one field or property in a class can be annotated with @XmlAnyAttribute.
  • The type of the property or the field must java.util.Map

While processing attributes to be unmarshalled into a value class, each attribute that is not statically associated with another JavaBean property, via XmlAttribute, is entered into the wildcard attribute map represented by Map<QName,Object>. The attribute QName is the map's key. The key's value is the String value of the attribute.

Since:
JAXB2.0
Author:
Kohsuke Kawaguchi, Sun Microsystems, Inc.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlAttachmentRef

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlAttachmentRef

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlAttachmentRef

Marks a field/property that its XML form is a uri reference to mime content. The mime content is optimally stored out-of-line as an attachment. A field/property must always map to the DataHandler class.

Usage

 @XmlRootElement
 class Foo {
   @XmlAttachmentRef
   @XmlAttribute
   DataHandler data;

   @XmlAttachmentRef
   @XmlElement
   DataHandler body;
 }
The above code maps to the following XML:

 <xs:element name="foo" xmlns:ref="http://ws-i.org/profiles/basic/1.1/xsd">
   <xs:complexType>
     <xs:sequence>
       <xs:element name="body" type="ref:swaRef" minOccurs="0" />
     </xs:sequence>
     <xs:attribute name="data" type="ref:swaRef" use="optional" />
   </xs:complexType>
 </xs:element>

The above binding supports WS-I AP 1.0 WS-I Attachments Profile Version 1.0.

Since:
JAXB2.0
Author:
Kohsuke Kawaguchi

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlID

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlID

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlID

Maps a JavaBean property to XML ID.

To preserve referential integrity of an object graph across XML serialization followed by a XML deserialization, requires an object reference to be marshalled by reference or containment appropriately. Annotations @XmlID and @XmlIDREF together allow a customized mapping of a JavaBean property's type by containment or reference.

Usage

The @XmlID annotation can be used with the following program elements:
  • a JavaBean property
  • non static, non transient field

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

The usage is subject to the following constraints:
  • At most one field or property in a class can be annotated with @XmlID.
  • The JavaBean property's type must be java.lang.String.
  • The only other mapping annotations that can be used with @XmlID are:@XmlElement and @XmlAttribute.

Example: Map a JavaBean property's type to xs:ID

    // Example: code fragment
    public class Customer {
        @XmlAttribute
        @XmlID
        public String getCustomerID();
        public void setCustomerID(String id);
        .... other properties not shown
    }

    <!-- Example: XML Schema fragment -->
    <xs:complexType name="Customer">
      <xs:complexContent>
        <xs:sequence>
          ....
        </xs:sequence>
        <xs:attribute name="customerID" type="xs:ID"/>
      </xs:complexContent>
    </xs:complexType>

Since:
JAXB2.0
Version:
$Revision: 1.5 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlIDREF

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlIDREF

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlIDREF

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlIDREF

Maps a JavaBean property to XML IDREF.

To preserve referential integrity of an object graph across XML serialization followed by a XML deserialization, requires an object reference to be marshalled by reference or containment appropriately. Annotations @XmlID and @XmlIDREF together allow a customized mapping of a JavaBean property's type by containment or reference.

Usage

The @XmlIDREF annotation can be used with the following program elements:
  • a JavaBean property
  • non static, non transient field

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

The usage is subject to the following constraints:

  • If the type of the field or property is a collection type, then the collection item type must contain a property or field annotated with @XmlID.
  • If the field or property is single valued, then the type of the property or field must contain a property or field annotated with @XmlID.

    Note: If the collection item type or the type of the property (for non collection type) is java.lang.Object, then the instance must contain a property/field annotated with @XmlID attribute.

  • This annotation can be used with the following annotations: XmlElement, XmlAttribute, XmlList, and XmlElements.

Example: Map a JavaBean property to xs:IDREF (i.e. by reference rather than by containment)

   //EXAMPLE: Code fragment
   public class Shipping {
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);
       ....
    }

   <!-- Example: XML Schema fragment -->
   <xs:complexType name="Shipping">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

Example 2: The following is a complete example of containment versus reference.

    // By default, Customer maps to complex type xs:Customer
    public class Customer {

        // map JavaBean property type to xs:ID
        @XmlID public String getCustomerID();
        public void setCustomerID(String id);

        // .... other properties not shown
    }

   // By default, Invoice maps to a complex type xs:Invoice
   public class Invoice {

       // map by reference
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);

      // .... other properties not shown here
   }

   // By default, Shipping maps to complex type xs:Shipping
   public class Shipping {

       // map by reference
       @XmlIDREF public Customer getCustomer();
       public void setCustomer(Customer customer);
   }

   // at least one class must reference Customer by containment;
   // Customer instances won't be marshalled.
   @XmlElement(name="CustomerData")
   public class CustomerData {
       // map reference to Customer by containment by default.
       public Customer getCustomer();

       // maps reference to Shipping by containment by default.
       public Shipping getShipping();

       // maps reference to Invoice by containment by default.
       public Invoice getInvoice();
   }

   <!-- XML Schema mapping for above code frament -->

   <xs:complexType name="Invoice">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="Shipping">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:IDREF"/>
         ....
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="Customer">
     <xs:complexContent>
       <xs:sequence>
         ....
       </xs:sequence>
       <xs:attribute name="CustomerID" type="xs:ID"/>
     </xs:complexContent>
   </xs:complexType>

   <xs:complexType name="CustomerData">
     <xs:complexContent>
       <xs:sequence>
         <xs:element name="customer" type="xs:Customer"/>
         <xs:element name="shipping" type="xs:Shipping"/>
         <xs:element name="invoice"  type="xs:Invoice"/>
       </xs:sequence>
     </xs:complexContent>
   </xs:complexType>

   <xs:element name"customerData" type="xs:CustomerData"/>

   <!-- Instance document conforming to the above XML Schema -->
    <customerData>
       <customer customerID="Alice">
           ....
       </customer>

       <shipping customer="Alice">
           ....
       </shipping>

       <invoice customer="Alice">
           ....
       </invoice>
   </customerData>

Example 3: Mapping List to repeating element of type IDREF

     // Code fragment
     public class Shipping {
         @XmlIDREF
         @XmlElement(name="Alice")
             public List customers;
     }

     <!-- XML schema fragment -->
     <xs:complexType name="Shipping">
       <xs:sequence>
         <xs:choice minOccurs="0" maxOccurs="unbounded">
           <xs:element name="Alice" type="xs:IDREF"/>
         </xs:choice>
       </xs:sequence>
     </xs:complexType>

Example 4: Mapping a List to a list of elements of type IDREF.

     //Code fragment
     public class Shipping {
         @XmlIDREF
         @XmlElements(
             @XmlElement(name="Alice", type="Customer.class")
              @XmlElement(name="John", type="InternationalCustomer.class")
         public List customers;
     }

     <!-- XML Schema fragment -->
     <xs:complexType name="Shipping">
       <xs:sequence>
         <xs:choice minOccurs="0" maxOccurs="unbounded">
           <xs:element name="Alice" type="xs:IDREF"/>
           <xs:element name="John" type="xs:IDREF"/>
         </xs:choice>
       </xs:sequence>
     </xs:complexType>

Since:
JAXB2.0
Version:
$Revision: 1.12 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlID

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlInlineBinaryData

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlInlineBinaryData

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,TYPE})
public @interface XmlInlineBinaryData

Disable consideration of XOP encoding for datatypes that are bound to base64-encoded binary data in XML.

When XOP encoding is enabled as described in AttachmentMarshaller.isXOPPackage(), this annotation disables datatypes such as Image or Source or byte[] that are bound to base64-encoded binary from being considered for XOP encoding. If a JAXB property is annotated with this annotation or if the JAXB property's base type is annotated with this annotation, neither AttachmentMarshaller.addMtomAttachment(DataHandler, String, String) nor AttachmentMarshaller.addMtomAttachment(byte[], int, int, String, String, String) is ever called for the property. The binary data will always be inlined.

Since:
JAXB2.0
Author:
Joseph Fialli

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlList

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlList

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlList

Used to map a property to a list simple type.

Usage

The @XmlList annotation can be used with the following program elements:

  • JavaBean property
  • field

When a collection property is annotated just with @XmlElement, each item in the collection will be wrapped by an element. For example,

 @XmlRootElement
 class Foo {
     @XmlElement
     List<String> data;
 }
would produce XML like this:

 <foo>
   <data>abc</data>
   <data>def</data>
 </foo>
@XmlList annotation, on the other hand, allows multiple values to be represented as whitespace-separated tokens in a single element. For example,
 @XmlRootElement
 class Foo {
     @XmlElement
     @XmlList
     List<String> data;
 }
the above code will produce XML like this:

 <foo>
   <data>abc def</data>
 </foo>

This annotation can be used with the following annotations: XmlElement, XmlAttribute, XmlValue, XmlIDREF.

  • The use of @XmlList with XmlValue while allowed, is redundant since XmlList maps a collection type to a simple schema type that derives by list just as XmlValue would.
  • The use of @XmlList with XmlAttribute while allowed, is redundant since XmlList maps a collection type to a simple schema type that derives by list just as XmlAttribute would.

Since:
JAXB2.0
Author:
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Sekhar Vajjhala, Sun Microsystems, Inc.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlMixed

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlMixed

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlMixed

Annotate a JavaBean multi-valued property to support mixed content.

The usage is subject to the following constraints:

  • can be used with @XmlElementRef, @XmlElementRefs or @XmlAnyElement

The following can be inserted into @XmlMixed annotated multi-valued property

  • XML text information items are added as values of java.lang.String.
  • Children element information items are added as instances of JAXBElement or instances with a class that is annotated with @XmlRootElement.
  • Unknown content that is not be bound to a JAXB mapped class is inserted as Element. (Assumes property annotated with @XmlAnyElement)
Below is an example of binding and creation of mixed content.

  <!-- schema fragment having  mixed content -->
  <xs:complexType name="letterBody" mixed="true">
    <xs:sequence>
        <xs:element name="name" type="xs:string" />
        <xs:element name="quantity" type="xs:positiveInteger" />
        <xs:element name="productName" type="xs:string" />
        <!-- etc. -->
    </xs:sequence>
  </xs:complexType>
  <xs:element name="letterBody" type="letterBody" />

 // Schema-derived Java code:
 // (Only annotations relevant to mixed content are shown below,
 //  others are ommitted.)
 import java.math.BigInteger;
 public class ObjectFactory {
        // element instance factories
        JAXBElement<LetterBody> createLetterBody(LetterBody value);
        JAXBElement<String>     createLetterBodyName(String value);
        JAXBElement<BigInteger> createLetterBodyQuantity(BigInteger value);
        JAXBElement<String>     createLetterBodyProductName(String value);
      // type instance factory
        LetterBody&gt; createLetterBody();
 }

 public class LetterBody {
        // Mixed content can contain instances of Element classes
        // Name, Quantity and ProductName. Text data is represented as
        // java.util.String for text.
        @XmlMixed
        @XmlElementRefs({
                @XmlElementRef(name="productName", type=JAXBElement.class),
                @XmlElementRef(name="quantity", type=JAXBElement.class),
                @XmlElementRef(name="name", type=JAXBElement.class)})
        List getContent(){...}
 }
The following is an XML instance document with mixed content

 <letterBody>
 Dear Mr.<name>Robert Smith</name>
 Your order of <quantity>1</quantity> <productName>Baby
 Monitor</productName> shipped from our warehouse. ....
 </letterBody>
that can be constructed using following JAXB API calls.

 LetterBody lb = ObjectFactory.createLetterBody();
 JAXBElement<LetterBody> lbe = ObjectFactory.createLetterBody(lb);
 List gcl = lb.getContent();  //add mixed content to general content property.
 gcl.add("Dear Mr.");  // add text information item as a String.

 // add child element information item
 gcl.add(ObjectFactory.createLetterBodyName("Robert Smith"));
 gcl.add("Your order of "); // add text information item as a String

 // add children element information items
 gcl.add(ObjectFactory.
                        createLetterBodyQuantity(new BigInteger("1")));
 gcl.add(ObjectFactory.createLetterBodyProductName("Baby Monitor"));
 gcl.add("shipped from our warehouse");  // add text information item

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

Since:
JAXB2.0
Author:
Kohsuke Kawaguchi

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlRegistry

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlRegistry

@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlRegistry

Marks a class that has XmlElementDecls.

Since:
JAXB 2.0
Author:
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlElementDecl

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlTransient

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlTransient

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlTransient

Prevents the mapping of a JavaBean property to XML representation.

The @XmlTransient annotation is useful for resolving name collisions between a JavaBean property name and a field name or preventing the mapping of a field/property. A name collision can occur when the decapitalized JavaBean property name and a field name are the same. If the JavaBean property refers to the field, then the name collision can be resolved by preventing the mapping of either the field or the JavaBean property using the @XmlTransient annotation.

Usage

The @XmlTransient annotation can be used with the following program elements:

  • a JavaBean property
  • field

@XmlTransientis mutually exclusive with all other JAXB defined annotations.

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

Example: Resolve name collision between JavaBean property and field name

   // Example: Code fragment
   public class USAddress {

       // The field name "name" collides with the property name
       // obtained by bean decapitalization of getName() below
       @XmlTransient public String name;

       String getName() {..};
       String setName() {..};
   }

   <!-- Example: XML Schema fragment -->
   <xs:complexType name="USAddress">
     <xs:sequence>
       <xs:element name="name" type="xs:string"/>
     </xs:sequence>
   </xs:complexType>

Since:
JAXB2.0
Version:
$Revision: 1.8 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlValue

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlValue

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlValue

Enables mapping a class to a XML Schema complex type with a simpleContent or a XML Schema simple type.

Usage:

The @XmlValue annotation can be used with the following program elements:

  • a JavaBean property.
  • non static, non transient field.

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

The usage is subject to the following usage constraints:
  • At most one field or property can be annotated with the @XmlValue annotation.
  • @XmlValue can be used with the following annotations: XmlList. However this is redundant since XmlList maps a type to a simple schema type that derives by list just as XmlValue would.
  • If the type of the field or property is a collection type, then the collection item type must map to a simple schema type.
  • If the type of the field or property is not a collection type, then the type must map to a XML Schema simple type.

If the annotated JavaBean property is the sole class member being mapped to XML Schema construct, then the class is mapped to a simple type. If there are additional JavaBean properties (other than the JavaBean property annotated with @XmlValue annotation) that are mapped to XML attributes, then the class is mapped to a complex type with simpleContent.

Example 1: Map a class to XML Schema simpleType

     // Example 1: Code fragment
     public class USPrice {
         @XmlValue
         public java.math.BigDecimal price;
     }

     <!-- Example 1: XML Schema fragment -->
     <xs:simpleType name="USPrice">
       <xs:restriction base="xs:decimal"/>
     </xs:simpleType>

Example 2: Map a class to XML Schema complexType with with simpleContent.

   // Example 2: Code fragment
   public class InternationalPrice {
       @XmlValue
       public java.math.BigDecimal price;

       @XmlAttribute
       public String currency;
   }

   <!-- Example 2: XML Schema fragment -->
   <xs:complexType name="InternationalPrice">
     <xs:simpleContent>
       <xs:extension base="xs:decimal">
         <xs:attribute name="currency" type="xs:string"/>
       </xs:extension>
     </xs:simpleContent>
   </xs:complexType>

Since:
JAXB2.0
Version:
$Revision: 1.6 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


adapters

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.bind.annotation.adapters

XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.

See:
Description

Class Summary
CollapsedStringAdapter | Built-in XmlAdapter to handle xs:token and its derived types.
HexBinaryAdapter | XmlAdapter for xs:hexBinary.
NormalizedStringAdapter | XmlAdapter to handle xs:normalizedString.
XmlAdapter<ValueType,BoundType> | Adapts a Java type for custom marshaling.
XmlJavaTypeAdapter.DEFAULT | Used in XmlJavaTypeAdapter.type() to signal that the type be inferred from the signature of the field, property, parameter or the class.

Annotation Types Summary
XmlJavaTypeAdapter | Use an adapter that implements XmlAdapter for custom marshaling.
XmlJavaTypeAdapters | A container for multiple @XmlJavaTypeAdapter annotations.

Package javax.xml.bind.annotation.adapters Description

XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.bind.annotation.adapters Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.bind.annotation.adapters

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
      • javax.xml.bind.annotation.adapters.CollapsedStringAdapter
      • javax.xml.bind.annotation.adapters.HexBinaryAdapter
      • javax.xml.bind.annotation.adapters.NormalizedStringAdapter
    • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT

Annotation Type Hierarchy

  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters (implements java.lang.annotation.Annotation)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


CollapsedStringAdapter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.annotation.adapters
Class CollapsedStringAdapter

java.lang.Object
    extended by  javax.xml.bind.annotation.adapters.XmlAdapter<String,String>
        extended by  javax.xml.bind.annotation.adapters.CollapsedStringAdapter

public class CollapsedStringAdapter
extends XmlAdapter<String,String>

Built-in XmlAdapter to handle xs:token and its derived types.

This adapter removes leading and trailing whitespaces, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.

Since:
JAXB 2.0
Author:
Kohsuke Kawaguchi

Constructor Summary
CollapsedStringAdapter()
Method Summary
protected static boolean | isWhiteSpace(char ch) returns true if the specified char is a white space character.
String | marshal(String s) No-op.
String | unmarshal(String text) Removes leading and trailing whitespaces of the string given as the parameter, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CollapsedStringAdapter

public CollapsedStringAdapter()
Method Detail

unmarshal

public String unmarshal(String text)
Removes leading and trailing whitespaces of the string given as the parameter, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.

Specified by:
unmarshal in class XmlAdapter<String,String>
Parameters:
text - The value to be converted. Can be null.

marshal

public String marshal(String s)
No-op. Just return the same string given as the parameter.

Specified by:
marshal in class XmlAdapter<String,String>
Parameters:
s - The value to be convereted. Can be null.

isWhiteSpace

protected static boolean isWhiteSpace(char ch)
returns true if the specified char is a white space character.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HexBinaryAdapter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.annotation.adapters
Class HexBinaryAdapter

java.lang.Object
    extended by  javax.xml.bind.annotation.adapters.XmlAdapter<String,byte[]>
        extended by  javax.xml.bind.annotation.adapters.HexBinaryAdapter

public final class HexBinaryAdapter
extends XmlAdapter<String,byte[]>

XmlAdapter for xs:hexBinary.

This XmlAdapter binds byte[] to the hexBinary representation in XML.

Since:
JAXB 2.0
Author:
Kohsuke Kawaguchi

Constructor Summary
HexBinaryAdapter()
Method Summary
String | marshal(byte[] bytes) Convert a bound type to a value type.
byte[] | unmarshal(String s) Convert a value type to a bound type.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HexBinaryAdapter

public HexBinaryAdapter()
Method Detail

unmarshal

public byte[] unmarshal(String s)
Description copied from class: XmlAdapter
Convert a value type to a bound type.

Specified by:
unmarshal in class XmlAdapter<String,byte[]>
Parameters:
s - The value to be converted. Can be null.

marshal

public String marshal(byte[] bytes)
Description copied from class: XmlAdapter
Convert a bound type to a value type.

Specified by:
marshal in class XmlAdapter<String,byte[]>
Parameters:
bytes - The value to be convereted. Can be null.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NormalizedStringAdapter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.annotation.adapters
Class NormalizedStringAdapter

java.lang.Object
    extended by  javax.xml.bind.annotation.adapters.XmlAdapter<String,String>
        extended by  javax.xml.bind.annotation.adapters.NormalizedStringAdapter

public final class NormalizedStringAdapter
extends XmlAdapter<String,String>

XmlAdapter to handle xs:normalizedString.

This adapter removes leading and trailing whitespaces, then replace any tab, CR, and LF by a whitespace character ' '.

Since:
JAXB 2.0
Author:
Kohsuke Kawaguchi

Constructor Summary
NormalizedStringAdapter()
Method Summary
protected static boolean | isWhiteSpaceExceptSpace(char ch) Returns true if the specified char is a white space character but not 0x20.
String | marshal(String s) No-op.
String | unmarshal(String text) Removes leading and trailing whitespaces of the string given as the parameter, then replace any tab, CR, and LF by a whitespace character ' '.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NormalizedStringAdapter

public NormalizedStringAdapter()
Method Detail

unmarshal

public String unmarshal(String text)
Removes leading and trailing whitespaces of the string given as the parameter, then replace any tab, CR, and LF by a whitespace character ' '.

Specified by:
unmarshal in class XmlAdapter<String,String>
Parameters:
text - The value to be converted. Can be null.

marshal

public String marshal(String s)
No-op. Just return the same string given as the parameter.

Specified by:
marshal in class XmlAdapter<String,String>
Parameters:
s - The value to be convereted. Can be null.

isWhiteSpaceExceptSpace

protected static boolean isWhiteSpaceExceptSpace(char ch)
Returns true if the specified char is a white space character but not 0x20.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlAdapter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.annotation.adapters
Class XmlAdapter<ValueType,BoundType>

java.lang.Object
    extended by  javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
Type Parameters:
BoundType - The type that JAXB doesn't know how to handle. An adapter is written to allow this type to be used as an in-memory representation through the ValueType.
ValueType - The type that JAXB knows how to handle out of the box.
Direct Known Subclasses:
CollapsedStringAdapter, HexBinaryAdapter, NormalizedStringAdapter
public abstract class XmlAdapter<ValueType,BoundType>
extends Object

Adapts a Java type for custom marshaling.

Usage:

Some Java types do not map naturally to a XML representation, for example HashMap or other non JavaBean classes. Conversely, a XML repsentation may map to a Java type but an application may choose to accesss the XML representation using another Java type. For example, the schema to Java binding rules bind xs:DateTime by default to XmlGregorianCalendar. But an application may desire to bind xs:DateTime to a custom type, MyXmlGregorianCalendar, for example. In both cases, there is a mismatch between bound type , used by an application to access XML content and the value type, that is mapped to an XML representation.

This abstract class defines methods for adapting a bound type to a value type or vice versa. The methods are invoked by the JAXB binding framework during marshaling and unmarshalling:

  • XmlAdapter.marshal(...): During marshalling, JAXB binding framework invokes XmlAdapter.marshal(..) to adapt a bound type to value type, which is then marshaled to XML representation.
  • XmlAdapter.unmarshal(...): During unmarshalling, JAXB binding framework first unmarshals XML representation to a value type and then invokes XmlAdapter.unmarshal(..) to adapt the value type to a bound type.
Writing an adapter therefore involves the following steps:
  • Write an adapter that implements this abstract class.
  • Install the adapter using the annotation XmlJavaTypeAdapter

Example: Customized mapping of HashMap

The following example illustrates the use of @XmlAdapter and @XmlJavaTypeAdapter to customize the mapping of a HashMap.

Step 1: Determine the desired XML representation for HashMap.

     <hashmap>
         <entry key="id123">this is a value</entry>
         <entry key="id312">this is another value</entry>
         ...
       </hashmap>

Step 2: Determine the schema definition that the desired XML representation shown above should follow.

     <xs:complexType name="myHashMapType">
       <xs:sequence>
         <xs:element name="entry" type="myHashMapEntryType"
                        minOccurs = "0" maxOccurs="unbounded"/>
       </xs:sequence>
     </xs:complexType>

     <xs:complexType name="myHashMapEntryType">
       <xs:simpleContent>
         <xs:extension base="xs:string">
           <xs:attribute name="key" type="xs:int"/>
         </xs:extension>
       </xs:simpleContent>
     </xs:complexType>

Step 3: Write value types that can generate the above schema definition.

     public class MyHashMapType {
         List<MyHashMapEntryType> entry;
     }

     public class MyHashMapEntryType {
         @XmlAttribute
         public Integer key;

         @XmlValue
         public String value;
     }

Step 4: Write the adapter that adapts the value type, MyHashMapType to a bound type, HashMap, used by the application.

     public final class MyHashMapAdapter extends
                        XmlAdapter<HashMap, MyHashMapType> { ... }

Step 5: Use the adapter.

     public class Foo {
         @XmlJavaTypeAdapter(MyHashMapAdapter.class)
         HashMap hashmap;
         ...
     }
The above code fragment will map to the following schema:
     <xs:complexType name="Foo">
       <xs:sequence>
         <xs:element name="hashmap" type="myHashMapType"
       </xs:sequence>
     </xs:complexType>

Since:
JAXB 2.0
Author:
  • Sekhar Vajjhala, Sun Microsystems Inc.
  • Kohsuke Kawaguchi, Sun Microsystems Inc.
See Also:
XmlJavaTypeAdapter

Constructor Summary
protected XmlAdapter()
Do-nothing constructor for the derived classes.
Method Summary
abstract ValueType | marshal(BoundType v) Convert a bound type to a value type.
abstract BoundType | unmarshal(ValueType v) Convert a value type to a bound type.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XmlAdapter

protected XmlAdapter()
Do-nothing constructor for the derived classes.

Method Detail

unmarshal

public abstract BoundType unmarshal(ValueType v)
                             throws Exception
Convert a value type to a bound type.

Parameters:
v - The value to be converted. Can be null.
Throws:
Exception - if there's an error during the conversion. The caller is responsible for reporting the error to the user through ValidationEventHandler.

marshal

public abstract ValueType marshal(BoundType v)
                           throws Exception
Convert a bound type to a value type.

Parameters:
v - The value to be convereted. Can be null.
Throws:
Exception - if there's an error during the conversion. The caller is responsible for reporting the error to the user through ValidationEventHandler.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlJavaTypeAdapter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation.adapters
Annotation Type XmlJavaTypeAdapter

@Retention(value=RUNTIME)
@Target(value={PACKAGE,FIELD,METHOD,TYPE,PARAMETER})
public @interface XmlJavaTypeAdapter

Use an adapter that implements XmlAdapter for custom marshaling.

Usage:

The @XmlJavaTypeAdapter annotation can be used with the following program elements:

  • a JavaBean property
  • field
  • parameter
  • package
  • from within XmlJavaTypeAdapters

When @XmlJavaTypeAdapter annotation is defined on a class, it applies to all references to the class.

When @XmlJavaTypeAdapter annotation is defined at the package level it applies to all references from within the package to @XmlJavaTypeAdapter.type().

When @XmlJavaTypeAdapter annotation is defined on the field, property or parameter, then the annotation applies to the field, property or the parameter only.

A @XmlJavaTypeAdapter annotation on a field, property or parameter overrides the @XmlJavaTypeAdapter annotation associated with the class being referenced by the field, property or parameter.

A @XmlJavaTypeAdapter annotation on a class overrides the @XmlJavaTypeAdapter annotation specified at the package level for that class.

This annotation can be used with the following other annotations: XmlElement, XmlAttribute, XmlElementRef, XmlElementRefs, XmlAnyElement. This can also be used at the package level with the following annotations: XmlAccessorType, XmlSchema, XmlSchemaType, XmlSchemaTypes.

Example: See example in XmlAdapter

Since:
JAXB2.0
Version:
$Revision: 1.10 $
Author:
  • Sekhar Vajjhala, Sun Microsystems Inc.
  • Kohsuke Kawaguchi, Sun Microsystems Inc.
See Also:
XmlAdapter

Required Element Summary
 Class<? extends XmlAdapter> value
Points to the clsss that converts a value type to a bound type or vice versa.
Optional Element Summary
 Class type
If this annotation is used at the package level, then value of the type() must be specified.

Element Detail

value

public abstract Class<? extends XmlAdapter> value
Points to the clsss that converts a value type to a bound type or vice versa. See XmlAdapter for more details.

type

public abstract Class type
If this annotation is used at the package level, then value of the type() must be specified.

Default:
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT.class
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlJavaTypeAdapter.DEFAULT

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.annotation.adapters
Class XmlJavaTypeAdapter.DEFAULT

java.lang.Object
    extended by  javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
Enclosing class:
XmlJavaTypeAdapter
public static final class XmlJavaTypeAdapter.DEFAULT
extends Object

Used in XmlJavaTypeAdapter.type() to signal that the type be inferred from the signature of the field, property, parameter or the class.

Constructor Summary
XmlJavaTypeAdapter.DEFAULT()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XmlJavaTypeAdapter.DEFAULT

public XmlJavaTypeAdapter.DEFAULT()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlJavaTypeAdapters

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.xml.bind.annotation.adapters
Annotation Type XmlJavaTypeAdapters

@Retention(value=RUNTIME)
@Target(value=PACKAGE)
public @interface XmlJavaTypeAdapters

A container for multiple @XmlJavaTypeAdapter annotations.

Multiple annotations of the same type are not allowed on a program element. This annotation therefore serves as a container annotation for multiple @XmlJavaTypeAdapter as follows:

 @XmlJavaTypeAdapters ({ @XmlJavaTypeAdapter(...),@XmlJavaTypeAdapter(...) })

The @XmlJavaTypeAdapters annnotation is useful for defining XmlJavaTypeAdapter annotations for different types at the package level.

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

Since:
JAXB2.0
Author:
  • Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlJavaTypeAdapter

Required Element Summary
 XmlJavaTypeAdapter[] value
Collection of @XmlJavaTypeAdapter annotations

Element Detail

value

public abstract XmlJavaTypeAdapter[] value
Collection of @XmlJavaTypeAdapter annotations

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DomHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.annotation
Interface DomHandler<ElementT,ResultT extends Result>

All Known Implementing Classes:
W3CDomHandler
public interface DomHandler<ElementT,ResultT extends Result>

Converts an element (and its descendants) from/to DOM (or similar) representation.

Implementations of this interface will be used in conjunction with XmlAnyElement annotation to map an element of XML into a representation of infoset such as W3C DOM.

Implementations hide how a portion of XML is converted into/from such DOM-like representation, allowing JAXB providers to work with arbitrary such library.

This interface is intended to be implemented by library writers and consumed by JAXB providers. None of those methods are intended to be called from applications.

Since:
JAXB2.0
Author:
Kohsuke Kawaguchi

Method Summary
ResultT | createUnmarshaller(ValidationEventHandler errorHandler) When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
ElementT | getElement(ResultT rt) Once the portion is sent to the Result.
Source | marshal(ElementT n, ValidationEventHandler errorHandler) This method is called when a JAXB provider needs to marshal an element to XML.

Method Detail

createUnmarshaller

ResultT createUnmarshaller(ValidationEventHandler errorHandler)
When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.

A JAXB provider will then send a portion of the XML into the given result. Such a portion always form a subtree of the whole XML document rooted at an element.

Parameters:
errorHandler - if any error happens between the invocation of this method and the invocation of getElement(Result), they must be reported to this handler. The caller must provide a non-null error handler. The Result object created from this method may hold a reference to this error handler.
Returns:
null if the operation fails. The error must have been reported to the error handler.

getElement

ElementT getElement(ResultT rt)
Once the portion is sent to the Result. This method is called by a JAXB provider to obtain the unmarshalled element representation.

Multiple invocations of this method may return different objects. This method can be invoked only when the whole sub-tree are fed to the Result object.

Parameters:
rt - The Result object created by createUnmarshaller(ValidationEventHandler).
Returns:
null if the operation fails. The error must have been reported to the error handler.

marshal

Source marshal(ElementT n,
               ValidationEventHandler errorHandler)
This method is called when a JAXB provider needs to marshal an element to XML.

If non-null, the returned Source must contain a whole document rooted at one element, which will then be weaved into a bigger document that the JAXB provider is marshalling.

Parameters:
errorHandler - Receives any errors happened during the process of converting an element into a Source. The caller must provide a non-null error handler.
Returns:
null if there was an error. The error should have been reported to the handler.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


W3CDomHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.annotation
Class W3CDomHandler

java.lang.Object
    extended by  javax.xml.bind.annotation.W3CDomHandler
All Implemented Interfaces:
DomHandler<Element,DOMResult>
public class W3CDomHandler
extends Object
implements DomHandler<Element,DOMResult>

DomHandler implementation for W3C DOM (org.w3c.dom package.)

Since:
JAXB2.0
Author:
Kohsuke Kawaguchi

Constructor Summary
W3CDomHandler()
Default constructor.
W3CDomHandler(DocumentBuilder builder)
Constructor that allows applications to specify which DOM implementation to be used.
Method Summary
DOMResult | createUnmarshaller(ValidationEventHandler errorHandler) When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
DocumentBuilder | getBuilder()
Element | getElement(DOMResult r) Once the portion is sent to the Result.
Source | marshal(Element element, ValidationEventHandler errorHandler) This method is called when a JAXB provider needs to marshal an element to XML.
void | setBuilder(DocumentBuilder builder)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

W3CDomHandler

public W3CDomHandler()
Default constructor. It is up to a JAXB provider to decide which DOM implementation to use or how that is configured.

W3CDomHandler

public W3CDomHandler(DocumentBuilder builder)
Constructor that allows applications to specify which DOM implementation to be used.

Parameters:
builder - must not be null. JAXB uses this DocumentBuilder to create a new element.
Method Detail

getBuilder

public DocumentBuilder getBuilder()

setBuilder

public void setBuilder(DocumentBuilder builder)

createUnmarshaller

public DOMResult createUnmarshaller(ValidationEventHandler errorHandler)
Description copied from interface: DomHandler
When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.

A JAXB provider will then send a portion of the XML into the given result. Such a portion always form a subtree of the whole XML document rooted at an element.

Specified by:
createUnmarshaller in interface DomHandler<Element,DOMResult>
Parameters:
errorHandler - if any error happens between the invocation of this method and the invocation of DomHandler.getElement(Result), they must be reported to this handler. The caller must provide a non-null error handler. The Result object created from this method may hold a reference to this error handler.
Returns:
null if the operation fails. The error must have been reported to the error handler.

getElement

public Element getElement(DOMResult r)
Description copied from interface: DomHandler
Once the portion is sent to the Result. This method is called by a JAXB provider to obtain the unmarshalled element representation.

Multiple invocations of this method may return different objects. This method can be invoked only when the whole sub-tree are fed to the Result object.

Specified by:
getElement in interface DomHandler<Element,DOMResult>
Parameters:
r - The Result object created by DomHandler.createUnmarshaller(ValidationEventHandler).
Returns:
null if the operation fails. The error must have been reported to the error handler.

marshal

public Source marshal(Element element,
                      ValidationEventHandler errorHandler)
Description copied from interface: DomHandler
This method is called when a JAXB provider needs to marshal an element to XML.

If non-null, the returned Source must contain a whole document rooted at one element, which will then be weaved into a bigger document that the JAXB provider is marshalling.

Specified by:
marshal in interface DomHandler<Element,DOMResult>
errorHandler - Receives any errors happened during the process of converting an element into a Source. The caller must provide a non-null error handler.
Returns:
null if there was an error. The error should have been reported to the handler.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlAccessOrder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.xml.bind.annotation
Enum XmlAccessOrder

java.lang.Object
    extended by  java.lang.Enum<XmlAccessOrder>
        extended by  javax.xml.bind.annotation.XmlAccessOrder
All Implemented Interfaces:
Serializable, Comparable<XmlAccessOrder>
public enum XmlAccessOrder
extends Enum<XmlAccessOrder>

Used by XmlAccessorOrder to control the ordering of properties and fields in a JAXB bound class.

Since:
JAXB2.0
Version:
$Revision: 1.1 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlAccessorOrder

Enum Constant Summary
ALPHABETICAL
The ordering of fields and properties in a class is in alphabetical order as determined by the method java.lang.String.compareTo(String anotherString).
UNDEFINED
The ordering of fields and properties in a class is undefined.
Method Summary
static XmlAccessOrder | valueOf(String name) Returns the enum constant of this type with the specified name.
static XmlAccessOrder[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

UNDEFINED

public static final XmlAccessOrder UNDEFINED
The ordering of fields and properties in a class is undefined.

ALPHABETICAL

public static final XmlAccessOrder ALPHABETICAL
The ordering of fields and properties in a class is in alphabetical order as determined by the method java.lang.String.compareTo(String anotherString).

Method Detail

values

public static final XmlAccessOrder[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(XmlAccessOrder c : XmlAccessOrder.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static XmlAccessOrder valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlAccessorOrder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlAccessorOrder

@Inherited
@Retention(value=RUNTIME)
@Target(value={PACKAGE,TYPE})
public @interface XmlAccessorOrder

Controls the ordering of fields and properties in a class.

Usage

@XmlAccessorOrder annotation can be used with the following program elements:

  • package
  • a top level class

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

The annotation @XmlAccessorOrder on a package applies to all classes in a package. The following inheritance semantics apply:

  • If there is a @XmlAccessorOrder on a class, then it is used.
  • Otherwise, if a @XmlAccessorOrder exists on one of its super classes, then it is inherited.
  • Otherwise, the @XmlAccessorOrder on a package is inherited.

Defaulting Rules:

By default, if @XmlAccessorOrder on a package is absent, then the following package level annotation is assumed.

    @XmlAccessorType(XmlAccessOrder.UNDEFINED)

By default, if @XmlAccessorOrder on a class is absent and none of super classes is annotated with XmlAccessorOrder , then the following default on the class is assumed:

    @XmlAccessorType(XmlAccessOrder.UNDEFINED)

This annotation can be used with the following annotations: XmlType, XmlRootElement, XmlAccessorType, XmlSchema, XmlSchemaType, XmlSchemaTypes, , XmlJavaTypeAdapter. It can also be used with the following annotations at the package level: XmlJavaTypeAdapter.

Since:
JAXB2.0
Version:
$Revision: 1.11 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlAccessOrder

Optional Element Summary
 XmlAccessOrder value

value

public abstract XmlAccessOrder value
Default:
UNDEFINED
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlAccessorType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlAccessorType

@Inherited
@Retention(value=RUNTIME)
@Target(value={PACKAGE,TYPE})
public @interface XmlAccessorType

Controls whether fields or Javabean properties are serialized by default.

Usage

@XmlAccessorType annotation can be used with the following program elements:

  • package
  • a top level class

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

This annotation provides control over the default serialization of properties and fields in a class.

The annotation @XmlAccessorType on a package applies to all classes in the package. The following inheritance semantics apply:

  • If there is a @XmlAccessorType on a class, then it is used.
  • Otherwise, if a @XmlAccessorType exists on one of its super classes, then it is inherited.
  • Otherwise, the @XmlAccessorType on a package is inherited.

Defaulting Rules:

By default, if @XmlAccessorType on a package is absent, then the following package level annotation is assumed.

   @XmlAccessorType(XmlAccessType.PUBLIC_MEMBER)

By default, if @XmlAccessorType on a class is absent, and none of its super classes is annotated with @XmlAccessorType, then the following default on the class is assumed:

   @XmlAccessorType(XmlAccessType.PUBLIC_MEMBER)

This annotation can be used with the following annotations: XmlType, XmlRootElement, XmlAccessorOrder, XmlSchema, XmlSchemaType, XmlSchemaTypes, , XmlJavaTypeAdapter. It can also be used with the following annotations at the package level: XmlJavaTypeAdapter.

Since:
JAXB2.0
Version:
$Revision: 1.9 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlAccessType

Optional Element Summary
 XmlAccessType value
Specifies whether fields or properties are serialized.

value

public abstract XmlAccessType value
Specifies whether fields or properties are serialized.

See Also:
XmlAccessType
Default:
PUBLIC_MEMBER
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlAccessType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.xml.bind.annotation
Enum XmlAccessType

java.lang.Object
    extended by  java.lang.Enum<XmlAccessType>
        extended by  javax.xml.bind.annotation.XmlAccessType
All Implemented Interfaces:
Serializable, Comparable<XmlAccessType>
public enum XmlAccessType
extends Enum<XmlAccessType>

Used by XmlAccessorType to control serialization of fields or properties.

Since:
JAXB2.0
Version:
$Revision: 1.1 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlAccessorType

Enum Constant Summary
FIELD
Every non static, non transient field in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient.
NONE
None of the fields or properties is bound to XML unless they are specifically annotated with some of the JAXB annotations.
PROPERTY
Every getter/setter pair in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient.
PUBLIC_MEMBER
Every public getter/setter pair and every public field will be automatically bound to XML, unless annotated by XmlTransient.
Method Summary
static XmlAccessType | valueOf(String name) Returns the enum constant of this type with the specified name.
static XmlAccessType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

PROPERTY

public static final XmlAccessType PROPERTY
Every getter/setter pair in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient. Fields are bound to XML only when they are explicitly annotated by some of the JAXB annotations.

FIELD

public static final XmlAccessType FIELD
Every non static, non transient field in a JAXB-bound class will be automatically bound to XML, unless annotated by XmlTransient. Getter/setter pairs are bound to XML only when they are explicitly annotated by some of the JAXB annotations.

PUBLIC_MEMBER

public static final XmlAccessType PUBLIC_MEMBER
Every public getter/setter pair and every public field will be automatically bound to XML, unless annotated by XmlTransient. Fields or getter/setter pairs that are private, protected, or defaulted to package-only access are bound to XML only when they are explicitly annotated by the appropriate JAXB annotations.

NONE

public static final XmlAccessType NONE
None of the fields or properties is bound to XML unless they are specifically annotated with some of the JAXB annotations.

Method Detail

values

public static final XmlAccessType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(XmlAccessType c : XmlAccessType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static XmlAccessType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlAnyElement

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlAnyElement

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlAnyElement

Maps a JavaBean property to XML infoset representation and/or JAXB element.

This annotation serves as a "catch-all" property while unmarshalling xml content into a instance of a JAXB annotated class. It typically annotates a multi-valued JavaBean property, but it can occur on single value JavaBean property. During unmarshalling, each xml element that does not match a static @XmlElement or @XmlElementRef annotation for the other JavaBean properties on the class, is added to this "catch-all" property.

Usages:

 @XmlAnyElement
 public Element[] others;

 // Collection of Element or JAXB elements.
 @XmlAnyElement(lax="true")
 public Object[] others;

 @XmlAnyElement
 private List<Element> nodes;

 @XmlAnyElement
 private Element node;

Restriction usage constraints

This annotation is mutually exclusive with XmlElement, XmlAttribute, XmlValue, XmlElements, XmlID, and XmlIDREF.

There can be only one XmlAnyElement annotated JavaBean property in a class and its super classes.

Relationship to other annotations

This annotation can be used with XmlJavaTypeAdapter, so that users can map their own data structure to DOM, which in turn can be composed into XML.

This annotation can be used with XmlMixed like this:

 // List of java.lang.String or DOM nodes.
 @XmlAnyElement @XmlMixed
 List<Object> others;

Schema To Java example

The following schema would produce the following Java class:

 <xs:complexType name="foo">
   <xs:sequence>
     <xs:element name="a" type="xs:int" />
     <xs:element name="b" type="xs:int" />
     <xs:any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded" />
   </xs:sequence>
 </xs:complexType>

 class Foo {
   int a;
   int b;
   @XmlAnyElement
   List<Element> any;
 }
It can unmarshal instances like

 <foo xmlns:e="extra">
   <a>1</a>
   <e:other />  // this will be bound to DOM, because unmarshalling is orderless
   <b>3</b>
   <e:other />
   <c>5</c>     // this will be bound to DOM, because the annotation doesn't remember namespaces.
 </foo>
The following schema would produce the following Java class:

 <xs:complexType name="bar">
   <xs:complexContent>
   <xs:extension base="foo">
     <xs:sequence>
       <xs:element name="c" type="xs:int" />
       <xs:any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded" />
     </xs:sequence>
   </xs:extension>
 </xs:complexType>

 class Bar extends Foo {
   int c;
   // Foo.getAny() also represents wildcard content for type definition bar.
 }
It can unmarshal instances like

 <bar xmlns:e="extra">
   <a>1</a>
   <e:other />  // this will be bound to DOM, because unmarshalling is orderless
   <b>3</b>
   <e:other />
   <c>5</c>     // this now goes to Bar.c
   <e:other />  // this will go to Foo.any
 </bar>

Using XmlAnyElement with XmlElementRef

The XmlAnyElement annotation can be used with XmlElementRefs to designate additional elements that can participate in the content tree.

The following schema would produce the following Java class:

 <xs:complexType name="foo">
   <xs:choice maxOccurs="unbounded" minOccurs="0">
     <xs:element name="a" type="xs:int" />
     <xs:element name="b" type="xs:int" />
     <xs:any namespace="##other" processContents="lax" />
   </xs:choice>
 </xs:complexType>

 class Foo {
   @XmlAnyElement(lax="true")
   @XmlElementRefs({
     @XmlElementRef(name="a", type="JAXBElement.class")
     @XmlElementRef(name="b", type="JAXBElement.class")
   })
   List<Object> others;
 }

 @XmlRegistry
 class ObjectFactory {
   ...
   @XmlElementDecl(name = "a", namespace = "", scope = Foo.class)
   JAXBElement<Integer> createFooA( Integer i ) { ... }

   @XmlElementDecl(name = "b", namespace = "", scope = Foo.class)
   JAXBElement<Integer> createFooB( Integer i ) { ... }
It can unmarshal instances like

 <foo xmlns:e="extra">
   <a>1</a>     // this will unmarshal to a <A title="class in javax.xml.bind" href="/j2ee5/api/javax/xml/bind/JAXBElement.html"><CODE>JAXBElement</CODE></A> instance whose value is 1.
   <e:other />  // this will unmarshal to a DOM <A title="class or interface in org.w3c.dom" href="http://java.sun.com/j2se/1.5/docs/api/org/w3c/dom/Element.html"><CODE>Element</CODE></A>.
   <b>3</b>     // this will unmarshal to a <A title="class in javax.xml.bind" href="/j2ee5/api/javax/xml/bind/JAXBElement.html"><CODE>JAXBElement</CODE></A> instance whose value is 1.
 </foo>

W3C XML Schema "lax" wildcard emulation

The lax element of the annotation enables the emulation of the "lax" wildcard semantics. For example, when the Java source code is annotated like this:
 @XmlRootElement
 class Foo {
   @XmlAnyElement(lax=true)
   public Object[] others;
 }
then the following document will unmarshal like this:

 <foo>
   <unknown />
   <foo />
 </foo>

 Foo foo = unmarshal();
 // 1 for 'unknown', another for 'foo'
 assert foo.others.length==2;
 // 'unknown' unmarshals to a DOM element
 assert foo.others[0] instanceof Element;
 // because of lax=true, the 'foo' element eagerly
 // unmarshals to a Foo object.
 assert foo.others[1] instanceof Foo;

Since:
JAXB2.0
Author:
Kohsuke Kawaguchi

Optional Element Summary
boolean | lax Controls the unmarshaller behavior when it sees elements known to the current JAXBContext.
Class<? extends DomHandler> | value Specifies the DomHandler which is responsible for actually converting XML from/to a DOM-like data structure.

lax

public abstract boolean lax
Controls the unmarshaller behavior when it sees elements known to the current JAXBContext.

When false

If false, all the elements that match the property will be unmarshalled to DOM, and the property will only contain DOM elements.

When true

If true, when an element matches a property marked with XmlAnyElement is known to JAXBContext (for example, there's a class with XmlRootElement that has the same tag name, or there's XmlElementDecl that has the same tag name), the unmarshaller will eagerly unmarshal this element to the JAXB object, instead of unmarshalling it to DOM. Additionally, if the element is unknown but it has a known xsi:type, the unmarshaller eagerly unmarshals the element to a JAXBElement, with the unknown element name and the JAXBElement value is set to an instance of the JAXB mapping of the known xsi:type.

As a result, after the unmarshalling, the property can become heterogeneous; it can have both DOM nodes and some JAXB objects at the same time.

This can be used to emulate the "lax" wildcard semantics of the W3C XML Schema.

Default:
false

value

public abstract Class<? extends DomHandler> value
Specifies the DomHandler which is responsible for actually converting XML from/to a DOM-like data structure.

Default:
javax.xml.bind.annotation.W3CDomHandler.class
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlAttribute

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlAttribute

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlAttribute

Maps a JavaBean property to a XML attribute.

Usage

The @XmlAttribute annotation can be used with the following program elements:

  • JavaBean property
  • field

A static final field is mapped to a XML fixed attribute.

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

The usage is subject to the following constraints:
  • If type of the field or the property is a collection type, then the collection item type must be mapped to schema simple type.
         // Examples
     @XmlAttribute List<Integer> items; //legal
     @XmlAttribute List<Bar> foo; // illegal if Bar does not map to a schema simple type
  • If the type of the field or the property is a non collection type, then the type of the property or field must map to a simple schema type.
         // Examples
     @XmlAttribute int foo; // legal
     @XmlAttribute Foo foo; // illegal if Foo does not map to a schema simple type
  • This annotation can be used with the following annotations: XmlID, XmlIDREF, XmlList, XmlSchemaType, XmlValue, XmlAttachmentRef, XmlMimeType, XmlInlineBinaryData, XmlJavaTypeAdapter
    • .

Example 1: Map a JavaBean property to an XML attribute.

     //Example: Code fragment
     public class USPrice {
         @XmlAttribute
         public java.math.BigDecimal getPrice() {...} ;
         public void setPrice(java.math.BigDecimal ) {...};
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="USPrice">
       <xs:sequence>
       </xs:sequence>
       <xs:attribute name="price" type="xs:decimal"/>
     </xs:complexType>

Example 2: Map a JavaBean property to an XML attribute with anonymous type.

See Example 7 in @XmlType.

Example 3: Map a JavaBean collection property to an XML attribute.

     // Example: Code fragment
     class Foo {
         ...
         @XmlAttribute List<Integer> items;
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="foo">
         ...
       <xs:attribute name="items">
         <xs:simpleType>
           <xs:list itemType="xs:int"/>
         </xs:simpleType>
     </xs:complexType>

Since:
JAXB2.0
Version:
$Revision: 1.14 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlType

Optional Element Summary
String | name Name of the XML Schema attribute.
String | namespace Specifies the XML target namespace of the XML Schema attribute.
boolean | required Specifies if the XML Schema attribute is optional or required.

name

public abstract String name
Name of the XML Schema attribute. By default, the XML Schema attribute name is derived from the JavaBean property name.

Default:
"##default"

required

public abstract boolean required
Specifies if the XML Schema attribute is optional or required. If true, then the JavaBean property is mapped to a XML Schema attribute that is required. Otherwise it is mapped to a XML Schema attribute that is optional.

Default:
false

namespace

public abstract String namespace
Specifies the XML target namespace of the XML Schema attribute.

Default:
"##default"
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlElement

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlElement

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElement

Maps a JavaBean property to a XML element derived from property name.

Usage

@XmlElement annotation can be used with the following program elements:

  • a JavaBean property
  • non static, non transient field
  • within XmlElements

The usage is subject to the following constraints:
  • This annotation can be used with following annotations: XmlID, XmlIDREF, XmlList, XmlSchemaType, XmlValue, XmlAttachmentRef, XmlMimeType, XmlInlineBinaryData, XmlElementWrapper, XmlJavaTypeAdapter
  • if the type of JavaBean property is a collection type of array, an indexed property, or a parameterized list, and this annotation is used with XmlElements then, @XmlElement.type() must be DEFAULT.class since the collection item type is already known.

A JavaBean property, when annotated with @XmlElement annotation is mapped to a local element in the XML Schema complex type to which the containing class is mapped.

Example 1: Map a public non static non final field to local element

     //Example: Code fragment
     public class USPrice {
         @XmlElement(name="itemprice")
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice"/>
       <xs:sequence>
         <xs:element name="itemprice" type="xs:decimal" minOccurs="0"/>
       </sequence>
     </xs:complexType>

Example 2: Map a field to a nillable element.

     //Example: Code fragment
     public class USPrice {
         @XmlElement(nillable=true)
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal" nillable="true" minOccurs="0"/>
       </sequence>
     </xs:complexType>

Example 3: Map a field to a nillable, required element.

     //Example: Code fragment
     public class USPrice {
         @XmlElement(nillable=true, required=true)
         public java.math.BigDecimal price;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal" nillable="true" minOccurs="1"/>
       </sequence>
     </xs:complexType>

Example 4: Map a JavaBean property to an XML element with anonymous type.

See Example 6 in @XmlType.

Since:
JAXB2.0
Version:
$Revision: 1.19 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.

Optional Element Summary
String | defaultValue Default value of this element.
String | name Name of the XML Schema element.
String | namespace XML target namespace of the XML Schema element.
boolean | nillable Customize the element declaration to be nillable.
boolean | required Customize the element declaration to be required.
Class | type The Java class being referenced.

name

public abstract String name
Name of the XML Schema element.

If the value is "##default", then element name is derived from the JavaBean property name.

Default:
"##default"

nillable

public abstract boolean nillable
Customize the element declaration to be nillable.

If nillable() is true, then the JavaBean property is mapped to a XML Schema nillable element declaration.

Default:
false

required

public abstract boolean required
Customize the element declaration to be required.

If required() is true, then Javabean property is mapped to an XML schema element declaration with minOccurs="1". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

If required() is false, then the Javabean property is mapped to XML Schema element declaration with minOccurs="0". maxOccurs is "1" for a single valued property and "unbounded" for a multivalued property.

Default:
false

namespace

public abstract String namespace
XML target namespace of the XML Schema element.

If the value is "##default", then the namespace is determined as follows:

  1. If the enclosing package has XmlSchema annotation, and its elementFormDefault is QUALIFIED, then the namespace of the enclosing class.
  2. Otherwise "" (which produces unqualified element in the default namespace.

Default:
"##default"

defaultValue

public abstract String defaultValue
Default value of this element.

The '' value specified as a default of this annotation element is used as a poor-man's substitute for null to allow implementations to recognize the 'no default value' state.

Default:
"\u0000"

type

public abstract Class type
The Java class being referenced.

Default:
javax.xml.bind.annotation.XmlElement.DEFAULT.class
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlElement.DEFAULT

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.annotation
Class XmlElement.DEFAULT

java.lang.Object
    extended by  javax.xml.bind.annotation.XmlElement.DEFAULT
Enclosing class:
XmlElement
public static final class XmlElement.DEFAULT
extends Object

Used in XmlElement.type() to signal that the type be inferred from the signature of the property.

Constructor Summary
XmlElement.DEFAULT()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XmlElement.DEFAULT

public XmlElement.DEFAULT()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlElementDecl

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlElementDecl

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface XmlElementDecl

Maps a factory method to a XML element.

Usage

The annotation creates a mapping between an XML schema element declaration and a element factory method that returns a JAXBElement instance representing the element declaration. Typically, the element factory method is generated (and annotated) from a schema into the ObjectFactory class in a Java package that represents the binding of the element declaration's target namespace. Thus, while the annotation syntax allows @XmlElementDecl to be used on any method, semantically its use is restricted to annotation of element factory method. The usage is subject to the following constraints:
  • The class containing the element factory method annotated with @XmlElementDecl must be marked with XmlRegistry.
  • The element factory method must take one parameter assignable to Object.

Example 1: Annotation on a factory method

     // Example: code fragment
     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(name="foo")
         JAXBElement<String> createFoo(String s) { ... }
     }

     <!-- XML input -->
       <foo>string</foo>

     // Example: code fragment corresponding to XML input
     JAXBElement<String> o =
     (JAXBElement<String>)unmarshaller.unmarshal(aboveDocument);
     // print JAXBElement instance to show values
     System.out.println(o.getName());   // prints  "{}foo"
     System.out.println(o.getValue());  // prints  "string"
     System.out.println(o.getValue().getClass()); // prints "java.lang.String"

     <!-- Example: XML schema definition -->
     <xs:element name="foo" type="xs:string" />

Example 2: Element declaration with non local scope

The following example illustrates the use of scope annotation parameter in binding of element declaration in schema derived code.

The following example may be replaced in a future revision of this javadoc.

     <!-- Example: XML schema definition -->
     <xs:schema>
       <xs:complexType name="pea">
         <xs:choice maxOccurs="unbounded">
           <xs:element name="foo" type="xs:string" />
           <xs:element name="bar" type="xs:string" />
         </xs:choice>
       </xs:complexType>
       <xs:element name="foo" type="xs:int" />
     </xs:schema>

     // Example: expected default binding
     class Pea {
         @XmlElementRefs({
             @XmlElementRef(name="foo",type=JAXBElement.class)
             @XmlElementRef(name="bar",type=JAXBElement.class)
         })
         List<JAXBElement<String>> fooOrBar;
     }

     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(scope=Pea.class,name="foo")
         JAXBElement createPeaFoo(String s);

         @XmlElementDecl(scope=Pea.class,name="bar")
         JAXBElement createPeaBar(String s);

         @XmlElementDecl(name="foo")
         JAXBElement createFoo(Integer i);
     }
Without scope createFoo and createPeaFoo would become ambiguous since both of them map to a XML schema element with the same local name "foo".

Since:
JAXB 2.0
See Also:
XmlRegistry

Required Element Summary
 String name
local name of the XML element.
Optional Element Summary
String | defaultValue Default value of this element.
String | namespace namespace name of the XML element.
Class | scope scope of the mapping.
String | substitutionHeadName XML local name of a substitution group's head element.
String | substitutionHeadNamespace namespace name of a substitution group's head XML element.

Element Detail

name

public abstract String name
local name of the XML element.

Note to reviewers: There is no default name; since the annotation is on a factory method, it is not clear that the method name can be derived from the factory method name.

See Also:
namespace()

scope

public abstract Class scope
scope of the mapping.

If this is not XmlElementDecl.GLOBAL, then this element declaration mapping is only active within the specified class.

Default:
javax.xml.bind.annotation.XmlElementDecl.GLOBAL.class

namespace

public abstract String namespace
namespace name of the XML element.

If the value is "##default", then the value is the namespace name for the package of the class containing this factory method.

See Also:
name()
Default:
"##default"

substitutionHeadNamespace

public abstract String substitutionHeadNamespace
namespace name of a substitution group's head XML element.

This specifies the namespace name of the XML element whose local name is specified by substitutionHeadName().

If susbtitutionHeadName() is "", then this value can only be "##default". But the value is ignored since since this element is not part of susbtitution group when the value of susbstitutionHeadName() is "".

If susbtitutionHeadName() is not "" and the value is "##default", then the namespace name is the namespace name to which the package of the containing class, marked with XmlRegistry, is mapped.

If susbtitutionHeadName() is not "" and the value is not "##default", then the value is the namespace name.

See Also:
substitutionHeadName()
Default:
"##default"

substitutionHeadName

public abstract String substitutionHeadName
XML local name of a substitution group's head element.

If the value is "", then this element is not part of any substitution group.

See Also:
substitutionHeadNamespace()
Default:
""

defaultValue

public abstract String defaultValue
Default value of this element.

The '' value specified as a default of this annotation element is used as a poor-man's substitute for null to allow implementations to recognize the 'no default value' state.

Default:
"\u0000"
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlElementDecl.GLOBAL

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.annotation
Class XmlElementDecl.GLOBAL

java.lang.Object
    extended by  javax.xml.bind.annotation.XmlElementDecl.GLOBAL
Enclosing class:
XmlElementDecl
public static final class XmlElementDecl.GLOBAL
extends Object

Used in XmlElementDecl.scope() to signal that the declaration is in the global scope.

Constructor Summary
XmlElementDecl.GLOBAL()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XmlElementDecl.GLOBAL

public XmlElementDecl.GLOBAL()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlElementRef

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlElementRef

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElementRef

Maps a JavaBean property to a XML element derived from property's type.

Usage

@XmlElementRef annotation can be used with a JavaBean property or from within XmlElementRefs

This annotation dynamically associates an XML element name with the JavaBean property. When a JavaBean property is annotated with XmlElement, the XML element name is statically derived from the JavaBean property name. However, when this annotation is used, the XML element name is derived from the instance of the type of the JavaBean property at runtime.

XML Schema substitution group support

XML Schema allows a XML document author to use XML element names that were not statically specified in the content model of a schema using substitution groups. Schema derived code provides support for substitution groups using an element property, (section 5.5.5, "Element Property" of JAXB 2.0 specification). An element property method signature is of the form:

     public void setTerm(JAXBElement<? extends="extends" Operator="Operator">);
     public JAXBElement<? extends="extends" Operator="Operator"> getTerm();

An element factory method annotated with XmlElementDecl is used to create a JAXBElement instance, containing an XML element name. The presence of @XmlElementRef annotation on an element property indicates that the element name from JAXBElement instance be used instead of deriving an XML element name from the JavaBean property name.

The usage is subject to the following constraints:

  • If the collection item type (for collection property) or property type (for single valued property) is JAXBElement, then @XmlElementRef}.name() and @XmlElementRef.namespace() must point an element factory method with an @XmlElementDecl annotation in a class annotated with @XmlRegistry (usually ObjectFactory class generated by the schema compiler) :
    • @XmlElementDecl.name() must equal @XmlElementRef.name()
    • @XmlElementDecl.namespace() must equal @XmlElementRef.namespace().
  • If the collection item type (for collection property) or property type (for single valued property) is not JAXBElement, then the type referenced by the property or field must be annotated with XmlRootElement.
  • This annotation can be used with the following annotations: XmlElementWrapper, XmlJavaTypeAdapter.

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

Example 1: Ant Task Example

The following Java class hierarchy models an Ant build script. An Ant task corresponds to a class in the class hierarchy. The XML element name of an Ant task is indicated by the @XmlRootElement annotation on its corresponding class.
     @XmlRootElement(name="target")
     class Target {
         // The presence of @XmlElementRef indicates that the XML
         // element name will be derived from the @XmlRootElement
         // annotation on the type (for e.g. "jar" for JarTask).
         @XmlElementRef
         List<Task> tasks;
     }

     abstract class Task {
     }

     @XmlRootElement(name="jar")
     class JarTask extends Task {
         ...
     }

     @XmlRootElement(name="javac")
     class JavacTask extends Task {
         ...
     }

     <!-- XML Schema fragment -->
     <xs:element name="target" type="Target">
     <xs:complexType name="Target">
       <xs:sequence>
         <xs:choice maxOccurs="unbounded">
           <xs:element ref="jar">
           <xs:element ref="javac">
         </xs:choice>
       </xs:sequence>
     </xs:complexType>

Thus the following code fragment:

     Target target = new Target();
     target.tasks.add(new JarTask());
     target.tasks.add(new JavacTask());
     marshal(target);
will produce the following XML output:

     <target>
       <jar>
         ....
       </jar>
       <javac>
         ....
       </javac>
     </target>

It is not an error to have a class that extends Task that doesn't have XmlRootElement. But they can't show up in an XML instance (because they don't have XML element names).

Example 2: XML Schema Susbstitution group support

The following example shows the annotations for XML Schema substitution groups. The annotations and the ObjectFactory are derived from the schema.

     @XmlElement
     class Math {
         //  The value of type()is
         //  JAXBElement.class , which indicates the XML
         //  element name ObjectFactory - in general a class marked
         //  with @XmlRegistry. (See ObjectFactory below)
         //
         //  The name() is "operator", a pointer to a
         // factory method annotated with a
         //  XmlElementDecl with the name "operator". Since
         //  "operator" is the head of a substitution group that
         //  contains elements "add" and "sub" elements, "operator"
         //  element can be substituted in an instance document by
         //  elements "add" or "sub". At runtime, JAXBElement
         //  instance contains the element name that has been
         //  substituted in the XML document.
         //
         @XmlElementRef(type=JAXBElement.class,name="operator")
         JAXBElement<? extends Operator> term;
     }

     @XmlRegistry
     class ObjectFactory {
         @XmlElementDecl(name="operator")
         JAXBElement<Operator> createOperator(Operator o) {...}
         @XmlElementDecl(name="add",substitutionHeadName="operator")
         JAXBElement<Operator> createAdd(Operator o) {...}
         @XmlElementDecl(name="sub",substitutionHeadName="operator")
         JAXBElement<Operator> createSub(Operator o) {...}
     }

     class Operator {
         ...
     }

Thus, the following code fragment

     Math m = new Math();
     m.term = new ObjectFactory().createAdd(new Operator());
     marshal(m);
will produce the following XML output:
     <math>
       <add>...</add>
     </math>

Since:
JAXB2.0
Author:
  • Kohsuke Kawaguchi, Sun Microsystems,Inc.
  • Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlElementRefs

Optional Element Summary
String | name
String | namespace This parameter and name() are used to determine the XML element for the JavaBean property.
Class | type The Java type being referenced.

type

public abstract Class type
The Java type being referenced.

If the value is DEFAULT.class, the type is inferred from the the type of the JavaBean property.

Default:
javax.xml.bind.annotation.XmlElementRef.DEFAULT.class

namespace

public abstract String namespace
This parameter and name() are used to determine the XML element for the JavaBean property.

If type() is JAXBElement.class , then namespace() and name() point to a factory method with XmlElementDecl. The XML element name is the element name from the factory method's XmlElementDecl annotation or if an element from its substitution group (of which it is a head element) has been substituted in the XML document, then the element name is from the XmlElementDecl on the substituted element.

If type() is not JAXBElement.class, then the XML element name is the XML element name statically associated with the type using the annotation XmlRootElement on the type. If the type is not annotated with an XmlElementDecl, then it is an error.

If type() is not JAXBElement.class, then this value must be "".

Default:
""

name

public abstract String name
See Also:
namespace()
Default:
"##default"
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlElementRef.DEFAULT

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.annotation
Class XmlElementRef.DEFAULT

java.lang.Object
    extended by  javax.xml.bind.annotation.XmlElementRef.DEFAULT
Enclosing class:
XmlElementRef
public static final class XmlElementRef.DEFAULT
extends Object

Used in XmlElementRef.type() to signal that the type be inferred from the signature of the property.

Constructor Summary
XmlElementRef.DEFAULT()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XmlElementRef.DEFAULT

public XmlElementRef.DEFAULT()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlElementRefs

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlElementRefs

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElementRefs

Marks a property that refers to classes with XmlElement or JAXBElement.

Compared to an element property (property with XmlElement annotation), a reference property has a different substitution semantics. When a sub-class is assigned to a property, an element property produces the same tag name with @xsi:type, whereas a reference property produces a different tag name (the tag name that's on the the sub-class.)

This annotation can be used with the following annotations: XmlJavaTypeAdapter, XmlElementWrapper.

Since:
JAXB2.0
Author:
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlElementWrapper, XmlElementRef

Required Element Summary
 XmlElementRef[] value

Element Detail

value

public abstract XmlElementRef[] value
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlElements

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlElements

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElements

A container for multiple @XmlElement annotations. Multiple annotations of the same type are not allowed on a program element. This annotation therefore serves as a container annotation for multiple @XmlElements as follows:

 @XmlElements({ @XmlElement(...),@XmlElement(...) })

The @XmlElements annnotation can be used with the following program elements:

  • a JavaBean property
  • non static, non transient field
This annotation is intended for annotation a JavaBean collection property (e.g. List).

Usage

The usage is subject to the following constraints:

  • This annotation can be used with the following annotations: @XmlIDREF, @XmlElementWrapper.
  • If @XmlIDREF is also specified on the JavaBean property, then each @XmlElement.type() must contain a JavaBean property annotated with @XmlID.

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

Example 1: Map to a list of elements

    // Mapped code fragment
    public class Foo {
        @XmlElements(
            @XmlElement(name="A", type=Integer.class),
            @XmlElement(name="B", type=Float.class)
         }
         public List items;
    }

    <!-- XML Representation for a List of {1,2.5}
            XML output is not wrapped using another element -->
    ...
     1
     2.5
    ...

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:choice minOccurs="0" maxOccurs="unbounded">
          <xs:element name="A" type="xs:int"/>
          <xs:element name="B" type="xs:float"/>
        <xs:choice>
      </xs:sequence>
    </xs:complexType>

Example 2: Map to a list of elements wrapped with another element

    // Mapped code fragment
    public class Foo {
        @XmlElementWrapper(name="bar")
        @XmlElements(
            @XmlElement(name="A", type=Integer.class),
            @XmlElement(name="B", type=Float.class)
        }
        public List items;
    }

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:element name="bar">
          <xs:complexType>
            <xs:choice minOccurs="0" maxOccurs="unbounded">
              <xs:element name="A" type="xs:int"/>
              <xs:element name="B" type="xs:float"/>
            </xs:choice>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:complexType>

Example 3: Change element name based on type using an adapter.

    class Foo {
       @XmlJavaTypeAdapter(QtoPAdapter.class)
       @XmlElements({
           @XmlElement(name="A",type=PX.class),
           @XmlElement(name="B",type=PY.class)
       })
       Q bar;
    }

    @XmlType abstract class P {...}
    @XmlType(name="PX") class PX extends P {...}
    @XmlType(name="PY") class PY extends P {...}

    <!-- XML Schema fragment -->
    <xs:complexType name="Foo">
      <xs:sequence>
        <xs:element name="bar">
          <xs:complexType>
            <xs:choice minOccurs="0" maxOccurs="unbounded">
              <xs:element name="A" type="PX"/>
              <xs:element name="B" type="PY"/>
            </xs:choice>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:complexType>

Since:
JAXB2.0
Author:
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlElement, XmlElementRef, XmlElementRefs, XmlJavaTypeAdapter

Required Element Summary
 XmlElement[] value
Collection of @XmlElement annotations

Element Detail

value

public abstract XmlElement[] value
Collection of @XmlElement annotations

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlElementWrapper

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlElementWrapper

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface XmlElementWrapper

Generates a wrapper element around XML representation. This is primarily intended to be used to produce a wrapper XML element around collections. The annotation therefore supports two forms of serialization shown below.

    //Example: code fragment
      int[] names;

    // XML Serialization Form 1 (Unwrapped collection)
    <names> ... </names>
    <names> ... </names>

    // XML Serialization Form 2 ( Wrapped collection )
    <wrapperElement>
       <names> value-of-item </names>
       <names> value-of-item </names>
       ....
    </wrapperElement>

The two serialized XML forms allow a null collection to be represented either by absence or presence of an element with a nillable attribute.

Usage

The @XmlElementWrapper annotation can be used with the following program elements:

  • JavaBean property
  • non static, non transient field

The usage is subject to the following constraints:

  • The property must be a collection property
  • This annotation can be used with the following annotations: XmlElement, XmlElements, XmlElementRef, XmlElementRefs, XmlJavaTypeAdapter
    • .

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

Since:
JAXB2.0
Author:
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlElement, XmlElements, XmlElementRef, XmlElementRefs

Optional Element Summary
String | name Name of the XML wrapper element.
String | namespace XML target namespace of the XML wrapper element.
boolean | nillable If true, the absence of the collection is represented by using xsi:nil='true'.

name

public abstract String name
Name of the XML wrapper element. By default, the XML wrapper element name is derived from the JavaBean property name.

Default:
"##default"

namespace

public abstract String namespace
XML target namespace of the XML wrapper element.

If the value is "##default", then the namespace is determined as follows:

  1. If the enclosing package has XmlSchema annotation, and its elementFormDefault is QUALIFIED, then the namespace of the enclosing class.
  2. Otherwise "" (which produces unqualified element in the default namespace.

Default:
"##default"

nillable

public abstract boolean nillable
If true, the absence of the collection is represented by using xsi:nil='true'. Otherwise, it is represented by the absence of the element.

Default:
false
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlEnum

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlEnum

@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlEnum

Maps an enum type Enum to XML representation.

This annotation, together with XmlEnumValue provides a mapping of enum type to XML representation.

Usage

The @XmlEnum annotation can be used with the following program elements:

  • enum type

The usage is subject to the following constraints:

  • This annotation can be used the following other annotations: XmlType, XmlRootElement

See "Package Specification" in javax.xml.bind.package javadoc for additional common information

An enum type is mapped to a schema simple type with enumeration facets. The schema type is derived from the Java type to which @XmlEnum.value(). Each enum constant @XmlEnumValue must have a valid lexical representation for the type @XmlEnum.value() .

Examples: See examples in XmlEnumValue

Since:
JAXB2.0

Optional Element Summary
 Class<?> value
Java type that is mapped to a XML simple type.

value

public abstract Class<?> value
Java type that is mapped to a XML simple type.

Default:
java.lang.String.class
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlEnumValue

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlEnumValue

@Retention(value=RUNTIME)
@Target(value=FIELD)
public @interface XmlEnumValue

Maps an enum constant in Enum type to XML representation.

Usage

The @XmlEnumValue annotation can be used with the following program elements:

  • enum constant

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

This annotation, together with XmlEnum provides a mapping of enum type to XML representation.

An enum type is mapped to a schema simple type with enumeration facets. The schema type is derived from the Java type specified in @XmlEnum.value(). Each enum constant @XmlEnumValue must have a valid lexical representation for the type @XmlEnum.value()

In the absence of this annotation, Enum.name() is used as the XML representation.

Example 1: Map enum constant name -> enumeration facet

     //Example: Code fragment
     @XmlEnum(String.class)
     public enum Card { CLUBS, DIAMONDS, HEARTS, SPADES }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Card">
       <xs:restriction base="xs:string"/>
         <xs:enumeration value="CLUBS"/>
         <xs:enumeration value="DIAMONDS"/>
         <xs:enumeration value="HEARTS"/>
         <xs:enumeration value="SPADES"/>
     </xs:simpleType>

Example 2: Map enum constant name(value) -> enumeration facet

     //Example: code fragment
     @XmlType
     @XmlEnum(Integer.class)
     public enum Coin {
         @XmlEnumValue("1") PENNY(1),
         @XmlEnumValue("5") NICKEL(5),
         @XmlEnumValue("10") DIME(10),
         @XmlEnumValue("25") QUARTER(25) }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Coin">
       <xs:restriction base="xs:int">
         <xs:enumeration value="1"/>
         <xs:enumeration value="5"/>
         <xs:enumeration value="10"/>
         <xs:enumeration value="25"/>
       </xs:restriction>
     </xs:simpleType>

Example 3: Map enum constant name -> enumeration facet

     //Code fragment
     @XmlType
     @XmlEnum(Integer.class)
     public enum Code {
         @XmlEnumValue("1") ONE,
         @XmlEnumValue("2") TWO;
     }

     <!-- Example: XML Schema fragment -->
     <xs:simpleType name="Code">
       <xs:restriction base="xs:int">
         <xs:enumeration value="1"/>
         <xs:enumeration value="2"/>
       </xs:restriction>
     </xs:simpleType>

Since:
JAXB 2.0

Required Element Summary
 String value

Element Detail

value

public abstract String value
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlMimeType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlMimeType

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,PARAMETER})
public @interface XmlMimeType

Associates the MIME type that controls the XML representation of the property.

This annotation is used in conjunction with datatypes such as Image or Source that are bound to base64-encoded binary in XML.

If a property that has this annotation has a sibling property bound to the xmime:contentType attribute, and if in the instance the property has a value, the value of the attribute takes precedence and that will control the marshalling.

Since:
JAXB2.0
Author:
Kohsuke Kawaguchi

Required Element Summary
 String value
The textual representation of the MIME type, such as "image/jpeg" "image/*", "text/xml; charset=iso-8859-1" and so on.

Element Detail

value

public abstract String value
The textual representation of the MIME type, such as "image/jpeg" "image/*", "text/xml; charset=iso-8859-1" and so on.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlNs

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlNs

@Retention(value=RUNTIME)
@Target(value={})
public @interface XmlNs

Associates a namespace prefix with a XML namespace URI.

Usage

@XmlNs annotation is intended for use from other program annotations.

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

Example:See XmlSchema annotation type for an example.

Since:
JAXB2.0
Version:
$Revision: 1.3 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.

Required Element Summary
String | namespaceURI Namespace URI
String | prefix Namespace prefix

Element Detail

prefix

public abstract String prefix
Namespace prefix

namespaceURI

public abstract String namespaceURI
Namespace URI

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlNsForm

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.xml.bind.annotation
Enum XmlNsForm

java.lang.Object
    extended by  java.lang.Enum<XmlNsForm>
        extended by  javax.xml.bind.annotation.XmlNsForm
All Implemented Interfaces:
Serializable, Comparable<XmlNsForm>
public enum XmlNsForm
extends Enum<XmlNsForm>

Enumeration of XML Schema namespace qualifications.

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

Usage

The namespace qualification values are used in the annotations defined in this packge. The enumeration values are mapped as follows:

Enum Value | XML Schema Value
UNQUALIFIED | unqualified
QUALIFIED | qualified
UNSET | namespace qualification attribute is absent from the XML Schema fragment

Since:
JAXB2.0
Version:
$Revision: 1.2 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.

Enum Constant Summary
QUALIFIED
UNQUALIFIED
UNSET
Method Summary
static XmlNsForm | valueOf(String name) Returns the enum constant of this type with the specified name.
static XmlNsForm[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

UNQUALIFIED

public static final XmlNsForm UNQUALIFIED

QUALIFIED

public static final XmlNsForm QUALIFIED

UNSET

public static final XmlNsForm UNSET
Method Detail

values

public static final XmlNsForm[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(XmlNsForm c : XmlNsForm.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static XmlNsForm valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlRootElement

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlRootElement

@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlRootElement

Maps a class or an enum type to an XML element.

Usage

The @XmlRootElement annotation can be used with the following program elements:

  • a top level class
  • an enum type

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

When a top level class or an enum type is annotated with the @XmlRootElement annotation, then its value is represented as XML element in an XML document.

This annotation can be used with the following annotations: XmlType, XmlEnum, XmlAccessorType, XmlAccessorOrder.

Example 1: Associate an element with XML Schema type

     // Example: Code fragment
     @XmlRootElement
     class Point {
        int x;
        int y;
        Point(int _x,int _y) {x=_x;y=_y;}
     }

     //Example: Code fragment corresponding to XML output
     marshal( new Point(3,5), System.out);

     <!-- Example: XML output -->
     <point>
       <x> 3 </x>
       <y> 5 </y>
     </point>
The annotation causes an global element declaration to be produced in the schema. The global element declaration is associated with the XML schema type to which the class is mapped.

     <!-- Example: XML schema definition -->
     <xs:element name="point" type="point" />
     <xs:complexType name="point">
       <xs:sequence>
         <xs:element name="x" type="xs:int" />
         <xs:element name="y" type="xs:int" />
       </xs:sequence>
     </xs:complexType>

Example 2: Orthogonality to type inheritance

An element declaration annotated on a type is not inherited by its derived types. The following example shows this.

     // Example: Code fragment
     @XmlRootElement
     class Point3D extends Point {
         int z;
         Point3D(int _x,int _y,int _z) {super(_x,_y);z=_z;}
     }

     //Example: Code fragment corresponding to XML output *
     marshal( new Point3D(3,5,0), System.out );

     <!-- Example: XML output -->
     <!-- The element name is point3D not point -->
     <point3D>
       <x>3</x>
       <y>5</y>
       <z>0</z>
     </point3D>

     <!-- Example: XML schema definition -->
     <xs:element name="point3D" type="point3D"/>
     <xs:complexType name="point3D">
       <xs:complexContent>
         <xs:extension base="point">
           <xs:sequence>
             <xs:element name="z" type="xs:int"/>
           </xs:sequence>
         </xs:extension>
       </xs:complexContent>
     </xs:complexType>
Example 3: Associate a global element with XML Schema type to which the class is mapped.
     //Example: Code fragment
     @XmlRootElement(name="PriceElement")
     public class USPrice {
         @XmlElement
         public java.math.BigDecimal price;
     }

     <!-- Example: XML schema definition -->
     <xs:element name="PriceElement" type="USPrice"/>
     <xs:complexType name="USPrice">
       <xs:sequence>
         <xs:element name="price" type="xs:decimal"/>
       </sequence>
     </xs:complexType>

Since:
JAXB2.0
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.

Optional Element Summary
String | name local name of the XML element.
String | namespace namespace name of the XML element.

namespace

public abstract String namespace
namespace name of the XML element.

If the value is "##default", then the XML namespace name is derived from the package of the class ( XmlSchema ). If the package is unnamed, then the XML namespace is the default empty namespace.

Default:
"##default"

name

public abstract String name
local name of the XML element.

If the value is "##default", then the name is derived from the class name.

Default:
"##default"
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlSchema

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlSchema

@Retention(value=RUNTIME)
@Target(value=PACKAGE)
public @interface XmlSchema

Maps a package name to a XML namespace.

Usage

The XmlSchema annotation can be used with the following program elements:

  • package
This is a package level annotation and follows the recommendations and restrictions contained in JSR 175, section III, "Annotations". Thus the usage is subject to the following constraints and recommendations.
  • There can only be one package declaration as noted in JSR 175, section III, "Annotations".
  • JSR 175 recommends package-info.java for package level annotations. JAXB Providers that follow this recommendation will allow the package level annotations to be defined in package-info.java.

Example 1: Customize name of XML namespace to which package is mapped.

    @javax.xml.bind.annotation.XmlSchema (
      namespace = "http://www.example.com/MYPO1"
    )

    <!-- XML Schema fragment -->
    <schema
      xmlns=...
      xmlns:po=....
      targetNamespace="http://www.example.com/MYPO1"
    >
    <!-- prefixes generated by default are implementation
            depedenent -->

Example 2: Customize namespace prefix, namespace URI mapping

    // Package level annotation
    @javax.xml.bind.annotation.XmlSchema (
      xmlns = {
        @javax.xml.bind.annotation.XmlNs(prefix = "po",
                   namespaceURI="http://www.example.com/myPO1"),

        @javax.xml.bind.annotation.XmlNs(prefix="xs",
                   namespaceURI="http://www.w3.org/2001/XMLSchema")
      )
    )

    <!-- XML Schema fragment -->
    <schema
        xmlns:xs="http://www.w3.org/2001/XMLSchema"
        xmlns:po="http://www.example.com/PO1"
        targetNamespace="http://www.example.com/PO1">

Example 3: Customize elementFormDefault

    @javax.xml.bind.annotation.XmlSchema (
      elementFormDefault=XmlNsForm.UNQUALIFIED
      ...
    )

    <!-- XML Schema fragment -->
    <schema
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:po="http://www.example.com/PO1"
        elementFormDefault="unqualified">

Since:
JAXB2.0
Version:
$Revision: 1.9 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.

Optional Element Summary
XmlNsForm | attributeFormDefault Namespace qualification for attributes.
XmlNsForm | elementFormDefault Namespace qualification for elements.
String | namespace Name of the XML namespace.
XmlNs[] | xmlns Customize the namespace URI, prefix associations.

xmlns

public abstract XmlNs[] xmlns
Customize the namespace URI, prefix associations. By default, the namespace prefixes for a XML namespace are generated by a JAXB Provider in an implementation dependent way.

Default:
{}

namespace

public abstract String namespace
Name of the XML namespace.

Default:
""

elementFormDefault

public abstract XmlNsForm elementFormDefault
Namespace qualification for elements. By default, element default attribute will be absent from the XML Schema fragment.

Default:
UNSET

attributeFormDefault

public abstract XmlNsForm attributeFormDefault
Namespace qualification for attributes. By default, attributesFormDefault will be absent from the XML Schema fragment.

Default:
UNSET
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlSchemaType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlSchemaType

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD,PACKAGE})
public @interface XmlSchemaType

Maps a Java type to a simple schema built-in type.

Usage

@XmlSchemaType annotation can be used with the following program elements:

  • a JavaBean property
  • field
  • package

@XmlSchemaType annotation defined for Java type applies to all references to the Java type from a property/field. A @XmlSchemaType annotation specified on the property/field overrides the @XmlSchemaType annotation specified at the package level.

This annotation can be used with the following annotations: XmlElement, XmlAttribute.

Example 1: Customize mapping of XMLGregorianCalendar on the field.

     //Example: Code fragment
     public class USPrice {
         @XmlElement
         @XmlSchemaType(name="date")
         public XMLGregorianCalendar date;
     }

     <!-- Example: Local XML Schema element -->
     <xs:complexType name="USPrice"/>
       <xs:sequence>
         <xs:element name="date" type="xs:date"/>
       </sequence>
     </xs:complexType>

Example 2: Customize mapping of XMLGregorianCalendar at package level

     package foo;
     @javax.xml.bind.annotation.XmlSchemaType(
          name="date", type=javax.xml.datatype.XMLGregorianCalendar.class)
     }

Since:
JAXB2.0

Required Element Summary
 String name
Optional Element Summary
String | namespace
Class | type If this annotation is used at the package level, then value of the type() must be specified.

Element Detail

name

public abstract String name

namespace

public abstract String namespace
Default:
"http://www.w3.org/2001/XMLSchema"

type

public abstract Class type
If this annotation is used at the package level, then value of the type() must be specified.

Default:
javax.xml.bind.annotation.XmlSchemaType.DEFAULT.class
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlSchemaType.DEFAULT

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.annotation
Class XmlSchemaType.DEFAULT

java.lang.Object
    extended by  javax.xml.bind.annotation.XmlSchemaType.DEFAULT
Enclosing class:
XmlSchemaType
public static final class XmlSchemaType.DEFAULT
extends Object

Used in XmlSchemaType.type() to signal that the type be inferred from the signature of the property.

Constructor Summary
XmlSchemaType.DEFAULT()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XmlSchemaType.DEFAULT

public XmlSchemaType.DEFAULT()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlSchemaTypes

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlSchemaTypes

@Retention(value=RUNTIME)
@Target(value=PACKAGE)
public @interface XmlSchemaTypes

A container for multiple @XmlSchemaType annotations.

Multiple annotations of the same type are not allowed on a program element. This annotation therefore serves as a container annotation for multiple @XmlSchemaType annotations as follows:

 @XmlSchemaTypes({ @XmlSchemaType(...), @XmlSchemaType(...) })

The @XmlSchemaTypes annnotation can be used to define XmlSchemaType for different types at the package level.

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

Since:
JAXB2.0
Author:
  • Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlSchemaType

Required Element Summary
 XmlSchemaType[] value
Collection of @XmlSchemaType annotations

Element Detail

value

public abstract XmlSchemaType[] value
Collection of @XmlSchemaType annotations

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.bind.annotation
Annotation Type XmlType

@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface XmlType

Maps a class or an enum type to a XML Schema type.

Usage

The @XmlType annnotation can be used with the following program elements:

  • a top level class
  • an enum type

See "Package Specification" in javax.xml.bind.package javadoc for additional common information.

Mapping a Class

A class maps to a XML Schema type. A class is a data container for values represented by properties and fields. A schema type is a data container for values represented by schema components within a schema type's content model (e.g. model groups, attributes etc).

To be mapped, a class must either have a public no-arg constructor or a static no-arg factory method. The static factory method can be specified in factoryMethod() and factoryClass() annotation elements. The static factory method or the no-arg constructor is used during unmarshalling to create an instance of this class. If both are present, the static factory method overrides the no-arg constructor.

A class maps to either a XML Schema complex type or a XML Schema simple type. The XML Schema type is derived based on the mapping of JavaBean properties and fields contained within the class. The schema type to which the class is mapped can either be named or anonymous. A class can be mapped to an anonymous schema type by annotating the class with @XmlType(name="").

Either a global element, local element or a local attribute can be associated with an anonymous type as follows:

  • global element: A global element of an anonymous type can be derived by annotating the class with @XmlRootElement. See Example 3 below.
  • local element: A JavaBean property that references a class annotated with @XmlType(name="") and is mapped to the element associated with the anonymous type. See Example 4 below.
  • attribute: A JavaBean property that references a class annotated with @XmlType(name="") and is mapped to the attribute associated with the anonymous type. See Example 5 below.
Mapping to XML Schema Complex Type
  • If class is annotated with @XmlType(name="") , it is mapped to an anonymous type otherwise, the class name maps to a complex type name. The XmlName() annotation element can be used to customize the name.
  • Properties and fields that are mapped to elements are mapped to a content model within a complex type. The annotation element propOrder() can be used to customize the content model to be xs:all or xs:sequence. It is used for specifying the order of XML elements in xs:sequence.
  • Properties and fields can be mapped to attributes within the complex type.
  • The targetnamespace of the XML Schema type can be customized using the annotation element namespace().

Mapping class to XML Schema simple type

A class can be mapped to a XML Schema simple type using the @XmlValue annotation. For additional details and examples, see @XmlValue annotation type.

The following table shows the mapping of the class to a XML Schema complex type or simple type. The notational symbols used in the table are:

  • -> : represents a mapping
  • [x]+ : one or more occurances of x
  • [ @XmlValue property ]: JavaBean property annotated with @XmlValue
  • X : don't care
Target propOrder ClassBody ComplexType SimpleType
Class {} [property]+ -> elements complexcontent
xs:all
Class non empty [property]+ -> elements complexcontent
xs:sequence
Class X no property -> element complexcontent
empty sequence
Class X 1 [ @XmlValue property] &&
[property]+ ->attributes 		simplecontent
Class X 1 [ @XmlValue property ]&&
no properties -> attribute 		simpletype

Mapping an enum type

An enum type maps to a XML schema simple type with enumeration facets. The following annotation elements are ignored since they are not meaningful: propOrder() , factoryMethod() , factoryClass() .

Usage with other annotations

This annotation can be used with the following annotations: XmlRootElement, XmlAccessorOrder, XmlAccessorType, XmlEnum. However, XmlAccessorOrder and XmlAccessorType are ignored when this annotation is used on an enum type.

Example 1: Map a class to a complex type with xs:sequence with a customized ordering of JavaBean properties.

   @XmlType(propOrder={"street", "city" , "state", "zip", "name" })
   public class USAddress {
     String getName() {..};
     void setName(String) {..};

     String getStreet() {..};
     void setStreet(String) {..};

     String getCity() {..};
     void setCity(String) {..};

     String getState() {..};
     void setState(String) {..};

     java.math.BigDecimal getZip() {..};
     void setZip(java.math.BigDecimal) {..};
   }

   <!-- XML Schema mapping for USAddress -->
   <xs:complexType name="USAddress">
     <xs:sequence>
       <xs:element name="street" type="xs:string"/>
       <xs:element name="city" type="xs:string"/>
       <xs:element name="state" type="xs:string"/>
       <xs:element name="zip" type="xs:decimal"/>
       <xs:element name="name" type="xs:string"/>
     </xs:all>
   </xs:complexType>

Example 2: Map a class to a complex type with xs:all

 @XmlType(propOrder={})
 public class USAddress { ...}

 <!-- XML Schema mapping for USAddress -->
 <xs:complexType name="USAddress">
   <xs:all>
     <xs:element name="name" type="xs:string"/>
     <xs:element name="street" type="xs:string"/>
     <xs:element name="city" type="xs:string"/>
     <xs:element name="state" type="xs:string"/>
     <xs:element name="zip" type="xs:decimal"/>
   </xs:sequence>
 </xs:complexType>

Example 3: Map a class to a global element with an anonymous type.

   @XmlRootElement
   @XmlType(name="")
   public class USAddress { ...}

   <!-- XML Schema mapping for USAddress -->
   <xs:element name="USAddress">
     <xs:complexType>
       <xs:sequence>
         <xs:element name="name" type="xs:string"/>
         <xs:element name="street" type="xs:string"/>
         <xs:element name="city" type="xs:string"/>
         <xs:element name="state" type="xs:string"/>
         <xs:element name="zip" type="xs:decimal"/>
       </xs:sequence>
     </xs:complexType>
   </xs:element>

Example 4: Map a property to a local element with anonmyous type.

   //Example: Code fragment
   public class Invoice {
       USAddress addr;
           ...
       }

   @XmlType(name="")
   public class USAddress { ... }
   }

   <!-- XML Schema mapping for USAddress -->
   <xs:complexType name="Invoice">
     <xs:sequence>
       <xs:element name="addr">
         <xs:complexType>
           <xs:element name="name", type="xs:string"/>
           <xs:element name="city", type="xs:string"/>
           <xs:element name="city" type="xs:string"/>
           <xs:element name="state" type="xs:string"/>
           <xs:element name="zip" type="xs:decimal"/>
         </xs:complexType>
       ...
     </xs:sequence>
   </xs:complexType>

Example 5: Map a property to an attribute with anonymous type.

     //Example: Code fragment
     public class Item {
         public String name;
         @XmlAttribute
         public USPrice price;
     }

     // map class to anonymous simple type.
     @XmlType(name="")
     public class USPrice {
         @XmlValue
         public java.math.BigDecimal price;
     }

     <!-- Example: XML Schema fragment -->
     <xs:complexType name="Item">
       <xs:sequence>
         <xs:element name="name" type="xs:string"/>
         <xs:attribute name="price">
           <xs:simpleType>
             <xs:restriction base="xs:decimal"/>
           </xs:simpleType>
         </xs:attribute>
       </xs:sequence>
     </xs:complexType>

Example 6: Define a factoryClass and factoryMethod

      @XmlType(name="USAddressType", factoryClass=USAddressFactory.class,
      factoryMethod="getUSAddress")
      public class USAddress {

          private String city;
          private String name;
          private String state;
          private String street;
          private int    zip;

      public USAddress(String name, String street, String city,
          String state, int zip) {
          this.name = name;
          this.street = street;
          this.city = city;
          this.state = state;
          this.zip = zip;
      }
  }

  public class USAddressFactory {
      public static USAddress getUSAddress(){
       return new USAddress("Mark Baker", "23 Elm St",
          "Dayton", "OH", 90952);
  }

Example 7: Define factoryMethod and use the default factoryClass

      @XmlType(name="USAddressType", factoryMethod="getNewInstance")
      public class USAddress {

          private String city;
          private String name;
          private String state;
          private String street;
          private int    zip;

          private USAddress() {}

          public static USAddress getNewInstance(){
              return new USAddress();
          }
      }

Since:
JAXB2.0
Version:
$Revision: 1.20 $
Author:
Sekhar Vajjhala, Sun Microsystems, Inc.
See Also:
XmlElement, XmlAttribute, XmlValue, XmlSchema

Optional Element Summary
Class | factoryClass Class containing a no-arg factory method for creating an instance of this class.
String | factoryMethod Name of a no-arg factory method in the class specified in factoryClass factoryClass().
String | name Name of the XML Schema type which the class is mapped.
String | namespace Name of the target namespace of the XML Schema type.
String[] | propOrder Specifies the order for XML Schema elements when class is mapped to a XML Schema complex type.

name

public abstract String name
Name of the XML Schema type which the class is mapped.

Default:
"##default"

propOrder

public abstract String[] propOrder
Specifies the order for XML Schema elements when class is mapped to a XML Schema complex type.

Refer to the table for how the propOrder affects the mapping of class

The propOrder is a list of names of JavaBean properties in the class. Each name in the list is the name of a Java identifier of the JavaBean property. The order in which JavaBean properties are listed is the order of XML Schema elements to which the JavaBean properties are mapped.

All of the JavaBean properties being mapped to XML Schema elements must be listed.

A JavaBean property or field listed in propOrder must not be transient or annotated with @XmlTransient.

The default ordering of JavaBean properties is determined by @XmlAccessorOrder.

Default:
""

namespace

public abstract String namespace
Name of the target namespace of the XML Schema type. By default, this is the target namespace to which the package containing the class is mapped.

Default:
"##default"

factoryClass

public abstract Class factoryClass
Class containing a no-arg factory method for creating an instance of this class. The default is this class.

If factoryClass is DEFAULT.class and factoryMethod is "", then there is no static factory method.

If factoryClass is DEFAULT.class and factoryMethod is not "", then factoryMethod is the name of a static factory method in this class.

If factoryClass is not DEFAULT.class, then factoryMethod must not be "" and must be the name of a static factory method specified in factoryClass.

Default:
javax.xml.bind.annotation.XmlType.DEFAULT.class

factoryMethod

public abstract String factoryMethod
Name of a no-arg factory method in the class specified in factoryClass factoryClass().

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XmlType.DEFAULT

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.annotation
Class XmlType.DEFAULT

java.lang.Object
    extended by  javax.xml.bind.annotation.XmlType.DEFAULT
Enclosing class:
XmlType
public static final class XmlType.DEFAULT
extends Object

Used in XmlType.factoryClass() to signal that either factory mehod is not used or that it's in the class with this XmlType itself.

Constructor Summary
XmlType.DEFAULT()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XmlType.DEFAULT

public XmlType.DEFAULT()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


attachment

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.bind.attachment

This package is implemented by a MIME-based package processor that enables the interpretation and creation of optimized binary data within an MIME-based package format.

See:
Description

Class Summary
AttachmentMarshaller | Enable JAXB marshalling to optimize storage of binary data.
AttachmentUnmarshaller | Enables JAXB unmarshalling of a root document containing optimized binary data formats.

Package javax.xml.bind.attachment Description

This package is implemented by a MIME-based package processor that enables the interpretation and creation of optimized binary data within an MIME-based package format.

Soap MTOM[1], XOP([2][3]) and WS-I AP[4] standardize approaches to optimized transmission of binary datatypes as an attachment. To optimally support these standards within a message passing environment, this package enables an integrated solution between a MIME-based package processor and JAXB unmarshall/marshal processes.

Package Specification

  • JAXB Specification

Related Standards

  • [1]SOAP Message Transmission Optimization Mechanism
  • [2]XML-binary Optimized Packaging
  • [3]WS-I Attachments Profile Version 1.0.
  • [4]Describing Media Content of Binary Data in XML

Since:
JAXB 2.0
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.bind.attachment Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.bind.attachment

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.attachment.AttachmentMarshaller
    • javax.xml.bind.attachment.AttachmentUnmarshaller
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AttachmentMarshaller

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.attachment
Class AttachmentMarshaller

java.lang.Object
    extended by  javax.xml.bind.attachment.AttachmentMarshaller

public abstract class AttachmentMarshaller
extends Object

Enable JAXB marshalling to optimize storage of binary data.

This API enables an efficient cooperative creation of optimized binary data formats between a JAXB marshalling process and a MIME-based package processor. A JAXB implementation marshals the root body of a MIME-based package, delegating the creation of referenceable MIME parts to the MIME-based package processor that implements this abstraction.

XOP processing is enabled when isXOPPackage() is true. See addMtomAttachment(DataHandler, String, String) for details.

WS-I Attachment Profile 1.0 is supported by addSwaRefAttachment(DataHandler) being called by the marshaller for each JAXB property related to {http://ws-i.org/profiles/basic/1.1/xsd}swaRef.

Since:
JAXB 2.0
Author:
Marc Hadley, Kohsuke Kawaguchi, Joseph Fialli
See Also:
Marshaller.setAttachmentMarshaller(AttachmentMarshaller), XML-binary Optimized Packaging, WS-I Attachments Profile Version 1.0.

Constructor Summary
AttachmentMarshaller()
Method Summary
abstract String | addMtomAttachment(byte[] data, int offset, int length, String mimeType, String elementNamespace, String elementLocalName) Consider binary data for optimized binary storage as an attachment.
abstract String | addMtomAttachment(DataHandler data, String elementNamespace, String elementLocalName) Consider MIME content data for optimized binary storage as an attachment.
abstract String | addSwaRefAttachment(DataHandler data) Add MIME data as an attachment and return attachment's content-id, cid.
boolean | isXOPPackage() Read-only property that returns true if JAXB marshaller should enable XOP creation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AttachmentMarshaller

public AttachmentMarshaller()
Method Detail

addMtomAttachment

public abstract String addMtomAttachment(DataHandler data,
                                         String elementNamespace,
                                         String elementLocalName)

Consider MIME content data for optimized binary storage as an attachment.

This method is called by JAXB marshal process when isXOPPackage() is true, for each element whose datatype is "base64Binary", as described in Step 3 in Creating XOP Packages.

The method implementor determines whether data shall be attached separately or inlined as base64Binary data. If the implementation chooses to optimize the storage of the binary data as a MIME part, it is responsible for attaching data to the MIME-based package, and then assigning an unique content-id, cid, that identifies the MIME part within the MIME message. This method returns the cid, which enables the JAXB marshaller to marshal a XOP element that refers to that cid in place of marshalling the binary data. When the method returns null, the JAXB marshaller inlines data as base64binary data.

The caller of this method is required to meet the following constraint. If the element infoset item containing data has the attribute xmime:contentType or if the JAXB property/field representing datais annotated with a known MIME type, data.getContentType() should be set to that MIME type.

The elementNamespace and elementLocalName parameters provide the context that contains the binary data. This information could be used by the MIME-based package processor to determine if the binary data should be inlined or optimized as an attachment.

Parameters:
data - represents the data to be attached. Must be non-null.
elementNamespace - the namespace URI of the element that encloses the base64Binary data. Can be empty but never null.
elementLocalName - The local name of the element. Always a non-null valid string.
Returns:
a valid content-id URI (see RFC 2387) that identifies the attachment containing data. Otherwise, null if the attachment was not added and should instead be inlined in the message.
See Also:
XML-binary Optimized Packaging, Describing Media Content of Binary Data in XML

addMtomAttachment

public abstract String addMtomAttachment(byte[] data,
                                         int offset,
                                         int length,
                                         String mimeType,
                                         String elementNamespace,
                                         String elementLocalName)

Consider binary data for optimized binary storage as an attachment.

Since content type is not known, the attachment's MIME content type must be set to "application/octet-stream".

The elementNamespace and elementLocalName parameters provide the context that contains the binary data. This information could be used by the MIME-based package processor to determine if the binary data should be inlined or optimized as an attachment.

Parameters:
data - represents the data to be attached. Must be non-null. The actual data region is specified by (data,offset,length) tuple.
offset - The offset within the array of the first byte to be read; must be non-negative and no larger than array.length
length - The number of bytes to be read from the given array; must be non-negative and no larger than array.length
mimeType - If the data has an associated MIME type known to JAXB, that is passed as this parameter. If none is known, "application/octet-stream". This parameter may never be null.
elementNamespace - the namespace URI of the element that encloses the base64Binary data. Can be empty but never null.
elementLocalName - The local name of the element. Always a non-null valid string.
Returns:
content-id URI, cid, to the attachment containing data or null if data should be inlined.
See Also:
addMtomAttachment(DataHandler, String, String)

isXOPPackage

public boolean isXOPPackage()

Read-only property that returns true if JAXB marshaller should enable XOP creation.

This value must not change during the marshalling process. When this value is true, the addMtomAttachment(...) method is invoked when the appropriate binary datatypes are encountered by the marshal process.

Marshaller.marshal() must throw IllegalStateException if this value is true and the XML content to be marshalled violates Step 1 in Creating XOP Pacakges http://www.w3.org/TR/2005/REC-xop10-20050125/#creating_xop_packages. "Ensure the Original XML Infoset contains no element information item with a [namespace name] of "http://www.w3.org/2004/08/xop/include" and a [local name] of Include"

When this method returns true and during the marshal process at least one call to addMtomAttachment(...) returns a content-id, the MIME-based package processor must label the root part with the application/xop+xml media type as described in Step 5 of Creating XOP Pacakges.

Returns:
true when MIME context is a XOP Package.

addSwaRefAttachment

public abstract String addSwaRefAttachment(DataHandler data)

Add MIME data as an attachment and return attachment's content-id, cid.

This method is called by JAXB marshal process for each element/attribute typed as {http://ws-i.org/profiles/basic/1.1/xsd}swaRef. The MIME-based package processor implementing this method is responsible for attaching the specified data to a MIME attachment, and generating a content-id, cid, that uniquely identifies the attachment within the MIME-based package.

Caller inserts the returned content-id, cid, into the XML content being marshalled.

Parameters:
data - represents the data to be attached. Must be non-null.
Returns:
must be a valid URI used as cid. Must satisfy Conformance Requirement R2928 from WS-I Attachments Profile Version 1.0.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AttachmentUnmarshaller

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.attachment
Class AttachmentUnmarshaller

java.lang.Object
    extended by  javax.xml.bind.attachment.AttachmentUnmarshaller

public abstract class AttachmentUnmarshaller
extends Object

Enables JAXB unmarshalling of a root document containing optimized binary data formats.

This API enables an efficient cooperative processing of optimized binary data formats between a JAXB 2.0 implementation and MIME-based package processor (MTOM/XOP and WS-I AP 1.0). JAXB unmarshals the body of a package, delegating the understanding of the packaging format being used to a MIME-based package processor that implements this abstract class.

This abstract class identifies if a package requires XOP processing, isXOPPackage() and provides retrieval of binary content stored as attachments by content-id.

Identifying the content-id, cid, to pass to getAttachment*(String cid)

  • For XOP processing, the infoset representation of the cid is described in step 2a in Section 3.2 Interpreting XOP Packages
  • For WS-I AP 1.0, the cid is identified as an element or attribute of type ref:swaRef specified in Section 4.4 Referencing Attachments from the SOAP Envelope

Since:
JAXB 2.0
Author:
Marc Hadley, Kohsuke Kawaguchi, Joseph Fialli
See Also:
Unmarshaller.setAttachmentUnmarshaller(AttachmentUnmarshaller), XML-binary Optimized Packaging, WS-I Attachments Profile Version 1.0., Describing Media Content of Binary Data in XML

Constructor Summary
AttachmentUnmarshaller()
Method Summary
abstract byte[] | getAttachmentAsByteArray(String cid) Retrieve the attachment identified by content-id, cid, as a byte[].
abstract DataHandler | getAttachmentAsDataHandler(String cid) Lookup MIME content by content-id, cid, and return as a DataHandler.
boolean | isXOPPackage() Read-only property that returns true if JAXB unmarshaller needs to perform XOP processing.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AttachmentUnmarshaller

public AttachmentUnmarshaller()
Method Detail

getAttachmentAsDataHandler

public abstract DataHandler getAttachmentAsDataHandler(String cid)

Lookup MIME content by content-id, cid, and return as a DataHandler.

The returned DataHandler instance must be configured to meet the following required mapping constaint.
Required Mappings between MIME and Java Types
MIME Type | Java Type
DataHandler.getContentType() | instanceof DataHandler.getContent()
image/gif | java.awt.Image
image/jpeg | java.awt.Image
text/xml or application/xml | javax.xml.transform.Source
Note that it is allowable to support additional mappings.

Parameters:
cid - It is expected to be a valid lexical form of the XML Schema xs:anyURI datatype. If isXOPPackage() ==true, it must be a valid URI per the cid: URI scheme (see RFC 2387)
Returns:
a DataHandler that represents the MIME attachment.
Throws:
IllegalArgumentException - if the attachment for the given cid is not found.

getAttachmentAsByteArray

public abstract byte[] getAttachmentAsByteArray(String cid)

Retrieve the attachment identified by content-id, cid, as a byte[]

.

Parameters:
cid - It is expected to be a valid lexical form of the XML Schema xs:anyURI datatype. If isXOPPackage() ==true, it must be a valid URI per the cid: URI scheme (see RFC 2387)
Returns:
byte[] representation of attachment identified by cid.
Throws:
IllegalArgumentException - if the attachment for the given cid is not found.

isXOPPackage

public boolean isXOPPackage()

Read-only property that returns true if JAXB unmarshaller needs to perform XOP processing.

This method returns true when the constraints specified in Identifying XOP Documents are met. This value must not change during the unmarshalling process.

Returns:
true when MIME context is a XOP Document.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Binder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class Binder<XmlNode>

java.lang.Object
    extended by  javax.xml.bind.Binder<XmlNode>

public abstract class Binder<XmlNode>
extends Object

Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.

An instance of this class maintains the association between XML nodes of an infoset preserving view and a JAXB representation of an XML document. Navigation between the two views is provided by the methods getXMLNode(Object) and getJAXBNode(Object).

Modifications can be made to either the infoset preserving view or the JAXB representation of the document while the other view remains unmodified. The binder is able to synchronize the changes made in the modified view back into the other view using the appropriate Binder update methods, updateXML(Object, Object) or updateJAXB(Object).

A typical usage scenario is the following:

  • load XML document into an XML infoset representation
  • unmarshal(Object) XML infoset view to JAXB view. (Note to conserve resources, it is possible to only unmarshal a subtree of the XML infoset view to the JAXB view.)
  • application access/updates JAXB view of XML document.
  • updateXML(Object) synchronizes modifications to JAXB view back into the XML infoset view. Update operation preserves as much of original XML infoset as possible (i.e. comments, PI, ...)

A Binder instance is created using the factory method JAXBContext.createBinder() or JAXBContext.createBinder(Class).

The template parameter, XmlNode, is the root interface/class for the XML infoset preserving representation. A Binder implementation is required to minimally support an XmlNode value of org.w3c.dom.Node.class. A Binder implementation can support alternative XML infoset preserving representations.

Since:
JAXB 2.0
Author:
Kohsuke Kawaguchi (kohsuke.kawaguchi@sun.com) Joseph Fialli

Constructor Summary
Binder()
Method Summary
abstract  ValidationEventHandler getEventHandler()
Return the current event handler or the default event handler if one hasn't been set.
abstract  Object getJAXBNode(XmlNode xmlNode)
Gets the JAXB object associated with the given XML element.
abstract  Object getProperty(String name)
Get the particular property in the underlying implementation of Binder.
abstract  Schema getSchema()
Gets the last Schema object (including null) set by the setSchema(Schema) method.
abstract  XmlNode getXMLNode(Object jaxbObject)
Gets the XML element associated with the given JAXB object.
abstract  void marshal(Object jaxbObject, XmlNode xmlNode)
Marshal a JAXB object tree to a new XML document.
abstract  void setEventHandler(ValidationEventHandler handler)
Allow an application to register a ValidationEventHandler.
abstract  void setProperty(String name, Object value)
Set the particular property in the underlying implementation of Binder.
abstract  void setSchema(Schema schema)
Specifies whether marshal, unmarshal and update methods performs validation on their XML content.
abstract  Object unmarshal(XmlNode xmlNode)
Unmarshal XML infoset view to a JAXB object tree.
abstract
<T> JAXBElement<T>
unmarshal(XmlNode xmlNode, Class<T> declaredType)
Unmarshal XML root element by provided declaredType to a JAXB object tree.
abstract  Object updateJAXB(XmlNode xmlNode)
Takes an XML node and updates its associated JAXB object and its descendants.
abstract  XmlNode updateXML(Object jaxbObject)
Takes an JAXB object and updates its associated XML node and its descendants.
abstract  XmlNode updateXML(Object jaxbObject, XmlNode xmlNode)
Changes in JAXB object tree are updated in its associated XML parse tree.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Binder

public Binder()
Method Detail

unmarshal

public abstract Object unmarshal(XmlNode xmlNode)
                          throws JAXBException
Unmarshal XML infoset view to a JAXB object tree.

This method is similar to Unmarshaller.unmarshal(Node) with the addition of maintaining the association between XML nodes and the produced JAXB objects, enabling future update operations, updateXML(Object, Object) or updateJAXB(Object).

When getSchema() is non-null, xmlNode and its descendants is validated during this operation.

This method throws UnmarshalException when the Binder's JAXBContext does not have a mapping for the XML element name or the type, specifiable via @xsi:type, of xmlNode to a JAXB mapped class. The method unmarshal(Object, Class) enables an application to specify the JAXB mapped class that the xmlNode should be mapped to.

Parameters:
xmlNode - the document/element to unmarshal XML data from.
Returns:
the newly created root object of the JAXB object tree.
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Binder is unable to perform the XML to Java binding.
IllegalArgumentException - If the node parameter is null

unmarshal

public abstract <T> JAXBElement<T> unmarshal(XmlNode xmlNode,
                                             Class<T> declaredType)
                                  throws JAXBException
Unmarshal XML root element by provided declaredType to a JAXB object tree.

Implements Unmarshal by Declared Type

This method is similar to Unmarshaller.unmarshal(Node, Class) with the addition of maintaining the association between XML nodes and the produced JAXB objects, enabling future update operations, updateXML(Object, Object) or updateJAXB(Object).

When getSchema() is non-null, xmlNode and its descendants is validated during this operation.

Parameters:
xmlNode - the document/element to unmarshal XML data from.
declaredType - appropriate JAXB mapped class to hold node's XML data.
Returns:
JAXB Element representation of node
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Binder is unable to perform the XML to Java binding.
IllegalArgumentException - If any of the input parameters are null
Since:
JAXB2.0

marshal

public abstract void marshal(Object jaxbObject,
                             XmlNode xmlNode)
                      throws JAXBException
Marshal a JAXB object tree to a new XML document.

This method is similar to Marshaller.marshal(Object, Node) with the addition of maintaining the association between JAXB objects and the produced XML nodes, enabling future update operations such as updateXML(Object, Object) or updateJAXB(Object).

When getSchema() is non-null, the marshalled xml content is validated during this operation.

Parameters:
jaxbObject - The content tree to be marshalled.
xmlNode - The parameter must be a Node that accepts children.
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Binder is unable to marshal jaxbObject (or any object reachable from jaxbObject).
IllegalArgumentException - If any of the method parameters are null

getXMLNode

public abstract XmlNode getXMLNode(Object jaxbObject)
Gets the XML element associated with the given JAXB object.

Once a JAXB object tree is associated with an XML fragment, this method enables navigation between the two trees.

An association between an XML element and a JAXB object is established by the bind methods and the update methods. Note that this association is partial; not all XML elements have associated JAXB objects, and not all JAXB objects have associated XML elements.

Parameters:
jaxbObject - An instance that is reachable from a prior call to a bind or update method that returned a JAXB object tree.
Returns:
null if the specified JAXB object is not known to this Binder, or if it is not associated with an XML element.
Throws:
IllegalArgumentException - If the jaxbObject parameter is null

getJAXBNode

public abstract Object getJAXBNode(XmlNode xmlNode)
Gets the JAXB object associated with the given XML element.

Once a JAXB object tree is associated with an XML fragment, this method enables navigation between the two trees.

An association between an XML element and a JAXB object is established by the unmarshal, marshal and update methods. Note that this association is partial; not all XML elements have associated JAXB objects, and not all JAXB objects have associated XML elements.

Returns:
null if the specified XML node is not known to this Binder, or if it is not associated with a JAXB object.
Throws:
IllegalArgumentException - If the node parameter is null

updateXML

public abstract XmlNode updateXML(Object jaxbObject)
                           throws JAXBException
Takes an JAXB object and updates its associated XML node and its descendants.

This is a convenience method of:

 updateXML( jaxbObject, getXMLNode(jaxbObject));

Throws:
JAXBException - If any unexpected problem occurs updating corresponding XML content.
IllegalArgumentException - If the jaxbObject parameter is null

updateXML

public abstract XmlNode updateXML(Object jaxbObject,
                                  XmlNode xmlNode)
                           throws JAXBException
Changes in JAXB object tree are updated in its associated XML parse tree.

This operation can be thought of as an "in-place" marshalling. The difference is that instead of creating a whole new XML tree, this operation updates an existing tree while trying to preserve the XML as much as possible.

For example, unknown elements/attributes in XML that were not bound to JAXB will be left untouched (whereas a marshalling operation would create a new tree that doesn't contain any of those.)

As a side-effect, this operation updates the association between XML nodes and JAXB objects.

Parameters:
jaxbObject - root of potentially modified JAXB object tree
xmlNode - root of update target XML parse tree
Returns:
Returns the updated XML node. Typically, this is the same node you passed in as xmlNode, but it maybe a different object, for example when the tag name of the object has changed.
Throws:
JAXBException - If any unexpected problem occurs updating corresponding XML content.
IllegalArgumentException - If any of the input parameters are null

updateJAXB

public abstract Object updateJAXB(XmlNode xmlNode)
                           throws JAXBException
Takes an XML node and updates its associated JAXB object and its descendants.

This operation can be thought of as an "in-place" unmarshalling. The difference is that instead of creating a whole new JAXB tree, this operation updates an existing tree, reusing as much JAXB objects as possible.

As a side-effect, this operation updates the association between XML nodes and JAXB objects.

Returns:
Returns the updated JAXB object. Typically, this is the same object that was returned from earlier marshal(Object,Object) or updateJAXB(Object) method invocation, but it maybe a different object, for example when the name of the XML element has changed.
Throws:
JAXBException - If any unexpected problem occurs updating corresponding JAXB mapped content.
IllegalArgumentException - If node parameter is null

setSchema

public abstract void setSchema(Schema schema)
Specifies whether marshal, unmarshal and update methods performs validation on their XML content.

Parameters:
schema - set to null to disable validation.
See Also:
Unmarshaller.setSchema(Schema)

getSchema

public abstract Schema getSchema()
Gets the last Schema object (including null) set by the setSchema(Schema) method.

Returns:
the Schema object for validation or null if not present

setEventHandler

public abstract void setEventHandler(ValidationEventHandler handler)
                              throws JAXBException
Allow an application to register a ValidationEventHandler.

The ValidationEventHandler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the Binder unmarshal, marshal and update methods.

Calling this method with a null parameter will cause the Binder to revert back to the default default event handler.

Parameters:
handler - the validation event handler
Throws:
JAXBException - if an error was encountered while setting the event handler

getEventHandler

public abstract ValidationEventHandler getEventHandler()
                                                throws JAXBException
Return the current event handler or the default event handler if one hasn't been set.

Returns:
the current ValidationEventHandler or the default event handler if it hasn't been set
Throws:
JAXBException - if an error was encountered while getting the current event handler

setProperty

public abstract void setProperty(String name,
                                 Object value)
                          throws PropertyException
Set the particular property in the underlying implementation of Binder. This method can only be used to set one of the standard JAXB defined unmarshal/marshal properties or a provider specific property for binder, unmarshal or marshal. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Unmarshal Properties and Supported Marshal Properties.

Parameters:
name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
value - the value of the property to be set
Throws:
PropertyException - when there is an error processing the given property or value
IllegalArgumentException - If the name parameter is null

getProperty

public abstract Object getProperty(String name)
                            throws PropertyException
Get the particular property in the underlying implementation of Binder. This method can only be used to get one of the standard JAXB defined unmarshal/marshal properties or a provider specific property for binder, unmarshal or marshal. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Unmarshal Properties and Supported Marshal Properties.

Parameters:
name - the name of the property to retrieve
Returns:
the value of the requested property
Throws:
PropertyException - when there is an error retrieving the given property or value property name
IllegalArgumentException - If the name parameter is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DatatypeConverter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class DatatypeConverter

java.lang.Object
    extended by  javax.xml.bind.DatatypeConverter

public final class DatatypeConverter
extends Object

The javaType binding declaration can be used to customize the binding of an XML schema datatype to a Java datatype. Customizations can involve writing a parse and print method for parsing and printing lexical representations of a XML schema datatype respectively. However, writing parse and print methods requires knowledge of the lexical representations ( XML Schema Part2: Datatypes specification ) and hence may be difficult to write.

This class makes it easier to write parse and print methods. It defines static parse and print methods that provide access to a JAXB provider's implementation of parse and print methods. These methods are invoked by custom parse and print methods. For example, the binding of xsd:dateTime to a long can be customized using parse and print methods as follows:

    // Customized parse method
    public long myParseCal( String dateTimeString ) {
        java.util.Calendar cal = DatatypeConverter.parseDateTime(dateTimeString);
        long longval = convert_calendar_to_long(cal); //application specific
        return longval;
    }

    // Customized print method
    public String myPrintCal( Long longval ) {
        java.util.Calendar cal = convert_long_to_calendar(longval) ; //application specific
        String dateTimeString = DatatypeConverter.printDateTime(cal);
        return dateTimeString;
    }

There is a static parse and print method corresponding to each parse and print method respectively in the DatatypeConverterInterface.

The static methods defined in the class can also be used to specify a parse or a print method in a javaType binding declaration.

JAXB Providers are required to call the setDatatypeConverter api at some point before the first marshal or unmarshal operation (perhaps during the call to JAXBContext.newInstance). This step is necessary to configure the converter that should be used to perform the print and parse functionality.

A print method for a XML schema datatype can output any lexical representation that is valid with respect to the XML schema datatype. If an error is encountered during conversion, then an IllegalArgumentException, or a subclass of IllegalArgumentException must be thrown by the method.

Since:
JAXB1.0
Version:
$Revision: 1.3 $
Author:
  • Sekhar Vajjhala, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems Inc.
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Ryan Shoemaker,Sun Microsystems Inc.
See Also:
DatatypeConverterInterface, ParseConversionEvent, PrintConversionEvent

Method Summary
static String | parseAnySimpleType(String lexicalXSDAnySimpleType) Return a string containing the lexical representation of the simple type.
static byte[] | parseBase64Binary(String lexicalXSDBase64Binary) Converts the string argument into an array of bytes.
static boolean | parseBoolean(String lexicalXSDBoolean) Converts the string argument into a boolean value.
static byte | parseByte(String lexicalXSDByte) Converts the string argument into a byte value.
static Calendar | parseDate(String lexicalXSDDate) Converts the string argument into a Calendar value.
static Calendar | parseDateTime(String lexicalXSDDateTime) Converts the string argument into a Calendar value.
static BigDecimal | parseDecimal(String lexicalXSDDecimal) Converts the string argument into a BigDecimal value.
static double | parseDouble(String lexicalXSDDouble) Converts the string argument into a double value.
static float | parseFloat(String lexicalXSDFloat) Converts the string argument into a float value.
static byte[] | parseHexBinary(String lexicalXSDHexBinary) Converts the string argument into an array of bytes.
static int | parseInt(String lexicalXSDInt) Convert the string argument into an int value.
static BigInteger | parseInteger(String lexicalXSDInteger) Convert the string argument into a BigInteger value.
static long | parseLong(String lexicalXSDLong) Converts the string argument into a long value.
static QName | parseQName(String lexicalXSDQName, NamespaceContext nsc) Converts the string argument into a byte value.
static short | parseShort(String lexicalXSDShort) Converts the string argument into a short value.
static String | parseString(String lexicalXSDString) Convert the lexical XSD string argument into a String value.
static Calendar | parseTime(String lexicalXSDTime) Converts the string argument into a Calendar value.
static long | parseUnsignedInt(String lexicalXSDUnsignedInt) Converts the string argument into a long value.
static int | parseUnsignedShort(String lexicalXSDUnsignedShort) Converts the string argument into an int value.
static String | printAnySimpleType(String val) Converts a string value into a string.
static String | printBase64Binary(byte[] val) Converts an array of bytes into a string.
static String | printBoolean(boolean val) Converts a boolean value into a string.
static String | printByte(byte val) Converts a byte value into a string.
static String | printDate(Calendar val) Converts a Calendar value into a string.
static String | printDateTime(Calendar val) Converts a Calendar value into a string.
static String | printDecimal(BigDecimal val) Converts a BigDecimal value into a string.
static String | printDouble(double val) Converts a double value into a string.
static String | printFloat(float val) Converts a float value into a string.
static String | printHexBinary(byte[] val) Converts an array of bytes into a string.
static String | printInt(int val) Converts an int value into a string.
static String | printInteger(BigInteger val) Converts a BigInteger value into a string.
static String | printLong(long val) Converts A long value into a string.
static String | printQName(QName val, NamespaceContext nsc) Converts a QName instance into a string.
static String | printShort(short val) Converts a short value into a string.
static String | printString(String val) Converts the string argument into a string.
static String | printTime(Calendar val) Converts a Calendar value into a string.
static String | printUnsignedInt(long val) Converts a long value into a string.
static String | printUnsignedShort(int val) Converts an int value into a string.
static void | setDatatypeConverter(DatatypeConverterInterface converter) This method is for JAXB provider use only.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

setDatatypeConverter

public static void setDatatypeConverter(DatatypeConverterInterface converter)
This method is for JAXB provider use only.

JAXB Providers are required to call this method at some point before allowing any of the JAXB client marshal or unmarshal operations to occur. This is necessary to configure the datatype converter that should be used to perform the print and parse conversions.

Calling this api repeatedly will have no effect - the DatatypeConverterInterface instance passed into the first invocation is the one that will be used from then on.

Parameters:
converter - an instance of a class that implements the DatatypeConverterInterface class - this parameter must not be null.
Throws:
IllegalArgumentException - if the parameter is null

parseString

public static String parseString(String lexicalXSDString)

Convert the lexical XSD string argument into a String value.

Parameters:
lexicalXSDString - A string containing a lexical representation of xsd:string.
Returns:
A String value represented by the string argument.

parseInteger

public static BigInteger parseInteger(String lexicalXSDInteger)

Convert the string argument into a BigInteger value.

Parameters:
lexicalXSDInteger - A string containing a lexical representation of xsd:integer.
Returns:
A BigInteger value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDInteger is not a valid string representation of a BigInteger value.

parseInt

public static int parseInt(String lexicalXSDInt)

Convert the string argument into an int value.

Parameters:
lexicalXSDInt - A string containing a lexical representation of xsd:int.
Returns:
A int value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDInt is not a valid string representation of an int value.

parseLong

public static long parseLong(String lexicalXSDLong)

Converts the string argument into a long value.

Parameters:
lexicalXSDLong - A string containing lexical representation of xsd:long.
Returns:
A long value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDLong is not a valid string representation of a long value.

parseShort

public static short parseShort(String lexicalXSDShort)

Converts the string argument into a short value.

Parameters:
lexicalXSDShort - A string containing lexical representation of xsd:short.
Returns:
A short value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDShort is not a valid string representation of a short value.

parseDecimal

public static BigDecimal parseDecimal(String lexicalXSDDecimal)

Converts the string argument into a BigDecimal value.

Parameters:
lexicalXSDDecimal - A string containing lexical representation of xsd:decimal.
Returns:
A BigDecimal value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDDecimal is not a valid string representation of BigDecimal.

parseFloat

public static float parseFloat(String lexicalXSDFloat)

Converts the string argument into a float value.

Parameters:
lexicalXSDFloat - A string containing lexical representation of xsd:float.
Returns:
A float value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDFloat is not a valid string representation of a float value.

parseDouble

public static double parseDouble(String lexicalXSDDouble)

Converts the string argument into a double value.

Parameters:
lexicalXSDDouble - A string containing lexical representation of xsd:double.
Returns:
A double value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDDouble is not a valid string representation of a double value.

parseBoolean

public static boolean parseBoolean(String lexicalXSDBoolean)

Converts the string argument into a boolean value.

Parameters:
lexicalXSDBoolean - A string containing lexical representation of xsd:boolean.
Returns:
A boolean value represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:boolean.

parseByte

public static byte parseByte(String lexicalXSDByte)

Converts the string argument into a byte value.

Parameters:
lexicalXSDByte - A string containing lexical representation of xsd:byte.
Returns:
A byte value represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:byte.

parseQName

public static QName parseQName(String lexicalXSDQName,
                               NamespaceContext nsc)

Converts the string argument into a byte value.

String parameter lexicalXSDQname must conform to lexical value space specifed at XML Schema Part 2:Datatypes specification:QNames

Parameters:
lexicalXSDQName - A string containing lexical representation of xsd:QName.
nsc - A namespace context for interpreting a prefix within a QName.
Returns:
A QName value represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to XML Schema Part 2 specification or if namespace prefix of lexicalXSDQname is not bound to a URI in NamespaceContext nsc.

parseDateTime

public static Calendar parseDateTime(String lexicalXSDDateTime)

Converts the string argument into a Calendar value.

Parameters:
lexicalXSDDateTime - A string containing lexical representation of xsd:datetime.
Returns:
A Calendar object represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:dateTime.

parseBase64Binary

public static byte[] parseBase64Binary(String lexicalXSDBase64Binary)

Converts the string argument into an array of bytes.

Parameters:
lexicalXSDBase64Binary - A string containing lexical representation of xsd:base64Binary.
Returns:
An array of bytes represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:base64Binary

parseHexBinary

public static byte[] parseHexBinary(String lexicalXSDHexBinary)

Converts the string argument into an array of bytes.

Parameters:
lexicalXSDHexBinary - A string containing lexical representation of xsd:hexBinary.
Returns:
An array of bytes represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:hexBinary.

parseUnsignedInt

public static long parseUnsignedInt(String lexicalXSDUnsignedInt)

Converts the string argument into a long value.

Parameters:
lexicalXSDUnsignedInt - A string containing lexical representation of xsd:unsignedInt.
Returns:
A long value represented by the string argument.
Throws:
NumberFormatException - if string parameter can not be parsed into a long value.

parseUnsignedShort

public static int parseUnsignedShort(String lexicalXSDUnsignedShort)

Converts the string argument into an int value.

Parameters:
lexicalXSDUnsignedShort - A string containing lexical representation of xsd:unsignedShort.
Returns:
An int value represented by the string argument.
Throws:
NumberFormatException - if string parameter can not be parsed into an int value.

parseTime

public static Calendar parseTime(String lexicalXSDTime)

Converts the string argument into a Calendar value.

Parameters:
lexicalXSDTime - A string containing lexical representation of xsd:time.
Returns:
A Calendar value represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Time.

parseDate

public static Calendar parseDate(String lexicalXSDDate)

Converts the string argument into a Calendar value.

Parameters:
lexicalXSDDate - A string containing lexical representation of xsd:Date.
Returns:
A Calendar value represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Date.

parseAnySimpleType

public static String parseAnySimpleType(String lexicalXSDAnySimpleType)

Return a string containing the lexical representation of the simple type.

Parameters:
lexicalXSDAnySimpleType - A string containing lexical representation of the simple type.
Returns:
A string containing the lexical representation of the simple type.

printString

public static String printString(String val)

Converts the string argument into a string.

Parameters:
val - A string value.
Returns:
A string containing a lexical representation of xsd:string.

printInteger

public static String printInteger(BigInteger val)

Converts a BigInteger value into a string.

Parameters:
val - A BigInteger value
Returns:
A string containing a lexical representation of xsd:integer
Throws:
IllegalArgumentException - val is null.

printInt

public static String printInt(int val)

Converts an int value into a string.

Parameters:
val - An int value
Returns:
A string containing a lexical representation of xsd:int

printLong

public static String printLong(long val)

Converts A long value into a string.

Parameters:
val - A long value
Returns:
A string containing a lexical representation of xsd:long

printShort

public static String printShort(short val)

Converts a short value into a string.

Parameters:
val - A short value
Returns:
A string containing a lexical representation of xsd:short

printDecimal

public static String printDecimal(BigDecimal val)

Converts a BigDecimal value into a string.

Parameters:
val - A BigDecimal value
Returns:
A string containing a lexical representation of xsd:decimal
Throws:
IllegalArgumentException - val is null.

printFloat

public static String printFloat(float val)

Converts a float value into a string.

Parameters:
val - A float value
Returns:
A string containing a lexical representation of xsd:float

printDouble

public static String printDouble(double val)

Converts a double value into a string.

Parameters:
val - A double value
Returns:
A string containing a lexical representation of xsd:double

printBoolean

public static String printBoolean(boolean val)

Converts a boolean value into a string.

Parameters:
val - A boolean value
Returns:
A string containing a lexical representation of xsd:boolean

printByte

public static String printByte(byte val)

Converts a byte value into a string.

Parameters:
val - A byte value
Returns:
A string containing a lexical representation of xsd:byte

printQName

public static String printQName(QName val,
                                NamespaceContext nsc)

Converts a QName instance into a string.

Parameters:
val - A QName value
nsc - A namespace context for interpreting a prefix within a QName.
Returns:
A string containing a lexical representation of QName
Throws:
IllegalArgumentException - if val is null or if nsc is non-null or nsc.getPrefix(nsprefixFromVal) is null.

printDateTime

public static String printDateTime(Calendar val)

Converts a Calendar value into a string.

Parameters:
val - A Calendar value
Returns:
A string containing a lexical representation of xsd:dateTime
Throws:
IllegalArgumentException - if val is null.

printBase64Binary

public static String printBase64Binary(byte[] val)

Converts an array of bytes into a string.

Parameters:
val - An array of bytes
Returns:
A string containing a lexical representation of xsd:base64Binary
Throws:
IllegalArgumentException - if val is null.

printHexBinary

public static String printHexBinary(byte[] val)

Converts an array of bytes into a string.

Parameters:
val - An array of bytes
Returns:
A string containing a lexical representation of xsd:hexBinary
Throws:
IllegalArgumentException - if val is null.

printUnsignedInt

public static String printUnsignedInt(long val)

Converts a long value into a string.

Parameters:
val - A long value
Returns:
A string containing a lexical representation of xsd:unsignedInt

printUnsignedShort

public static String printUnsignedShort(int val)

Converts an int value into a string.

Parameters:
val - An int value
Returns:
A string containing a lexical representation of xsd:unsignedShort

printTime

public static String printTime(Calendar val)

Converts a Calendar value into a string.

Parameters:
val - A Calendar value
Returns:
A string containing a lexical representation of xsd:time
Throws:
IllegalArgumentException - if val is null.

printDate

public static String printDate(Calendar val)

Converts a Calendar value into a string.

Parameters:
val - A Calendar value
Returns:
A string containing a lexical representation of xsd:date
Throws:
IllegalArgumentException - if val is null.

printAnySimpleType

public static String printAnySimpleType(String val)

Converts a string value into a string.

Parameters:
val - A string value
Returns:
A string containing a lexical representation of xsd:AnySimpleType
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DatatypeConverterInterface

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Interface DatatypeConverterInterface

public interface DatatypeConverterInterface

The DatatypeConverterInterface is for JAXB provider use only. A JAXB provider must supply a class that implements this interface. JAXB Providers are required to call the DatatypeConverter.setDatatypeConverter api at some point before the first marshal or unmarshal operation (perhaps during the call to JAXBContext.newInstance). This step is necessary to configure the converter that should be used to perform the print and parse functionality. Calling this api repeatedly will have no effect - the DatatypeConverter instance passed into the first invocation is the one that will be used from then on.

This interface defines the parse and print methods. There is one parse and print method for each XML schema datatype specified in the the default binding Table 5-1 in the JAXB specification.

The parse and print methods defined here are invoked by the static parse and print methods defined in the DatatypeConverter class.

A parse method for a XML schema datatype must be capable of converting any lexical representation of the XML schema datatype ( specified by the XML Schema Part2: Datatypes specification into a value in the value space of the XML schema datatype. If an error is encountered during conversion, then an IllegalArgumentException or a subclass of IllegalArgumentException must be thrown by the method.

A print method for a XML schema datatype can output any lexical representation that is valid with respect to the XML schema datatype. If an error is encountered during conversion, then an IllegalArgumentException, or a subclass of IllegalArgumentException must be thrown by the method.

The prefix xsd: is used to refer to XML schema datatypes XML Schema Part2: Datatypes specification.

Since:
JAXB1.0
Version:
$Revision: 1.5 $
Author:
  • Sekhar Vajjhala, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems Inc.
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Ryan Shoemaker,Sun Microsystems Inc.
See Also:
DatatypeConverter, ParseConversionEvent, PrintConversionEvent

Method Summary
String | parseAnySimpleType(String lexicalXSDAnySimpleType) Return a string containing the lexical representation of the simple type.
byte[] | parseBase64Binary(String lexicalXSDBase64Binary) Converts the string argument into an array of bytes.
boolean | parseBoolean(String lexicalXSDBoolean) Converts the string argument into a boolean value.
byte | parseByte(String lexicalXSDByte) Converts the string argument into a byte value.
Calendar | parseDate(String lexicalXSDDate) Converts the string argument into a Calendar value.
Calendar | parseDateTime(String lexicalXSDDateTime) Converts the string argument into a Calendar value.
BigDecimal | parseDecimal(String lexicalXSDDecimal) Converts the string argument into a BigDecimal value.
double | parseDouble(String lexicalXSDDouble) Converts the string argument into a double value.
float | parseFloat(String lexicalXSDFloat) Converts the string argument into a float value.
byte[] | parseHexBinary(String lexicalXSDHexBinary) Converts the string argument into an array of bytes.
int | parseInt(String lexicalXSDInt) Convert the string argument into an int value.
BigInteger | parseInteger(String lexicalXSDInteger) Convert the string argument into a BigInteger value.
long | parseLong(String lexicalXSDLong) Converts the string argument into a long value.
QName | parseQName(String lexicalXSDQName, NamespaceContext nsc) Converts the string argument into a QName value.
short | parseShort(String lexicalXSDShort) Converts the string argument into a short value.
String | parseString(String lexicalXSDString) Convert the string argument into a string.
Calendar | parseTime(String lexicalXSDTime) Converts the string argument into a Calendar value.
long | parseUnsignedInt(String lexicalXSDUnsignedInt) Converts the string argument into a long value.
int | parseUnsignedShort(String lexicalXSDUnsignedShort) Converts the string argument into an int value.
String | printAnySimpleType(String val) Converts a string value into a string.
String | printBase64Binary(byte[] val) Converts an array of bytes into a string.
String | printBoolean(boolean val) Converts a boolean value into a string.
String | printByte(byte val) Converts a byte value into a string.
String | printDate(Calendar val) Converts a Calendar value into a string.
String | printDateTime(Calendar val) Converts a Calendar value into a string.
String | printDecimal(BigDecimal val) Converts a BigDecimal value into a string.
String | printDouble(double val) Converts a double value into a string.
String | printFloat(float val) Converts a float value into a string.
String | printHexBinary(byte[] val) Converts an array of bytes into a string.
String | printInt(int val) Converts an int value into a string.
String | printInteger(BigInteger val) Converts a BigInteger value into a string.
String | printLong(long val) Converts a long value into a string.
String | printQName(QName val, NamespaceContext nsc) Converts a QName instance into a string.
String | printShort(short val) Converts a short value into a string.
String | printString(String val) Converts the string argument into a string.
String | printTime(Calendar val) Converts a Calendar value into a string.
String | printUnsignedInt(long val) Converts a long value into a string.
String | printUnsignedShort(int val) Converts an int value into a string.

Method Detail

parseString

String parseString(String lexicalXSDString)

Convert the string argument into a string.

Parameters:
lexicalXSDString - A lexical representation of the XML Schema datatype xsd:string
Returns:
A string that is the same as the input string.

parseInteger

BigInteger parseInteger(String lexicalXSDInteger)

Convert the string argument into a BigInteger value.

Parameters:
lexicalXSDInteger - A string containing a lexical representation of xsd:integer.
Returns:
A BigInteger value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDInteger is not a valid string representation of a BigInteger value.

parseInt

int parseInt(String lexicalXSDInt)

Convert the string argument into an int value.

Parameters:
lexicalXSDInt - A string containing a lexical representation of xsd:int.
Returns:
An int value represented byte the string argument.
Throws:
NumberFormatException - lexicalXSDInt is not a valid string representation of an int value.

parseLong

long parseLong(String lexicalXSDLong)

Converts the string argument into a long value.

Parameters:
lexicalXSDLong - A string containing lexical representation of xsd:long.
Returns:
A long value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDLong is not a valid string representation of a long value.

parseShort

short parseShort(String lexicalXSDShort)

Converts the string argument into a short value.

Parameters:
lexicalXSDShort - A string containing lexical representation of xsd:short.
Returns:
A short value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDShort is not a valid string representation of a short value.

parseDecimal

BigDecimal parseDecimal(String lexicalXSDDecimal)

Converts the string argument into a BigDecimal value.

Parameters:
lexicalXSDDecimal - A string containing lexical representation of xsd:decimal.
Returns:
A BigDecimal value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDDecimal is not a valid string representation of BigDecimal.

parseFloat

float parseFloat(String lexicalXSDFloat)

Converts the string argument into a float value.

Parameters:
lexicalXSDFloat - A string containing lexical representation of xsd:float.
Returns:
A float value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDFloat is not a valid string representation of a float value.

parseDouble

double parseDouble(String lexicalXSDDouble)

Converts the string argument into a double value.

Parameters:
lexicalXSDDouble - A string containing lexical representation of xsd:double.
Returns:
A double value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDDouble is not a valid string representation of a double value.

parseBoolean

boolean parseBoolean(String lexicalXSDBoolean)

Converts the string argument into a boolean value.

Parameters:
lexicalXSDBoolean - A string containing lexical representation of xsd:boolean.
Returns:
A boolean value represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:boolean.

parseByte

byte parseByte(String lexicalXSDByte)

Converts the string argument into a byte value.

Parameters:
lexicalXSDByte - A string containing lexical representation of xsd:byte.
Returns:
A byte value represented by the string argument.
Throws:
NumberFormatException - lexicalXSDByte does not contain a parseable byte.
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:byte.

parseQName

QName parseQName(String lexicalXSDQName,
                 NamespaceContext nsc)

Converts the string argument into a QName value.

String parameter lexicalXSDQname must conform to lexical value space specifed at XML Schema Part 2:Datatypes specification:QNames

Parameters:
lexicalXSDQName - A string containing lexical representation of xsd:QName.
nsc - A namespace context for interpreting a prefix within a QName.
Returns:
A QName value represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to XML Schema Part 2 specification or if namespace prefix of lexicalXSDQname is not bound to a URI in NamespaceContext nsc.

parseDateTime

Calendar parseDateTime(String lexicalXSDDateTime)

Converts the string argument into a Calendar value.

Parameters:
lexicalXSDDateTime - A string containing lexical representation of xsd:datetime.
Returns:
A Calendar object represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:dateTime.

parseBase64Binary

byte[] parseBase64Binary(String lexicalXSDBase64Binary)

Converts the string argument into an array of bytes.

Parameters:
lexicalXSDBase64Binary - A string containing lexical representation of xsd:base64Binary.
Returns:
An array of bytes represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:base64Binary

parseHexBinary

byte[] parseHexBinary(String lexicalXSDHexBinary)

Converts the string argument into an array of bytes.

Parameters:
lexicalXSDHexBinary - A string containing lexical representation of xsd:hexBinary.
Returns:
An array of bytes represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:hexBinary.

parseUnsignedInt

long parseUnsignedInt(String lexicalXSDUnsignedInt)

Converts the string argument into a long value.

Parameters:
lexicalXSDUnsignedInt - A string containing lexical representation of xsd:unsignedInt.
Returns:
A long value represented by the string argument.
Throws:
NumberFormatException - if string parameter can not be parsed into a long value.

parseUnsignedShort

int parseUnsignedShort(String lexicalXSDUnsignedShort)

Converts the string argument into an int value.

Parameters:
lexicalXSDUnsignedShort - A string containing lexical representation of xsd:unsignedShort.
Returns:
An int value represented by the string argument.
Throws:
NumberFormatException - if string parameter can not be parsed into an int value.

parseTime

Calendar parseTime(String lexicalXSDTime)

Converts the string argument into a Calendar value.

Parameters:
lexicalXSDTime - A string containing lexical representation of xsd:Time.
Returns:
A Calendar value represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Time.

parseDate

Calendar parseDate(String lexicalXSDDate)

Converts the string argument into a Calendar value.

Parameters:
lexicalXSDDate - A string containing lexical representation of xsd:Date.
Returns:
A Calendar value represented by the string argument.
Throws:
IllegalArgumentException - if string parameter does not conform to lexical value space defined in XML Schema Part 2: Datatypes for xsd:Date.

parseAnySimpleType

String parseAnySimpleType(String lexicalXSDAnySimpleType)

Return a string containing the lexical representation of the simple type.

Parameters:
lexicalXSDAnySimpleType - A string containing lexical representation of the simple type.
Returns:
A string containing the lexical representation of the simple type.

printString

String printString(String val)

Converts the string argument into a string.

Parameters:
val - A string value.
Returns:
A string containing a lexical representation of xsd:string

printInteger

String printInteger(BigInteger val)

Converts a BigInteger value into a string.

Parameters:
val - A BigInteger value
Returns:
A string containing a lexical representation of xsd:integer
Throws:
IllegalArgumentException - val is null.

printInt

String printInt(int val)

Converts an int value into a string.

Parameters:
val - An int value
Returns:
A string containing a lexical representation of xsd:int

printLong

String printLong(long val)

Converts a long value into a string.

Parameters:
val - A long value
Returns:
A string containing a lexical representation of xsd:long

printShort

String printShort(short val)

Converts a short value into a string.

Parameters:
val - A short value
Returns:
A string containing a lexical representation of xsd:short

printDecimal

String printDecimal(BigDecimal val)

Converts a BigDecimal value into a string.

Parameters:
val - A BigDecimal value
Returns:
A string containing a lexical representation of xsd:decimal
Throws:
IllegalArgumentException - val is null.

printFloat

String printFloat(float val)

Converts a float value into a string.

Parameters:
val - A float value
Returns:
A string containing a lexical representation of xsd:float

printDouble

String printDouble(double val)

Converts a double value into a string.

Parameters:
val - A double value
Returns:
A string containing a lexical representation of xsd:double

printBoolean

String printBoolean(boolean val)

Converts a boolean value into a string.

Parameters:
val - A boolean value
Returns:
A string containing a lexical representation of xsd:boolean

printByte

String printByte(byte val)

Converts a byte value into a string.

Parameters:
val - A byte value
Returns:
A string containing a lexical representation of xsd:byte

printQName

String printQName(QName val,
                  NamespaceContext nsc)

Converts a QName instance into a string.

Parameters:
val - A QName value
nsc - A namespace context for interpreting a prefix within a QName.
Returns:
A string containing a lexical representation of QName
Throws:
IllegalArgumentException - if val is null or if nsc is non-null or nsc.getPrefix(nsprefixFromVal) is null.

printDateTime

String printDateTime(Calendar val)

Converts a Calendar value into a string.

Parameters:
val - A Calendar value
Returns:
A string containing a lexical representation of xsd:dateTime
Throws:
IllegalArgumentException - if val is null.

printBase64Binary

String printBase64Binary(byte[] val)

Converts an array of bytes into a string.

Parameters:
val - an array of bytes
Returns:
A string containing a lexical representation of xsd:base64Binary
Throws:
IllegalArgumentException - if val is null.

printHexBinary

String printHexBinary(byte[] val)

Converts an array of bytes into a string.

Parameters:
val - an array of bytes
Returns:
A string containing a lexical representation of xsd:hexBinary
Throws:
IllegalArgumentException - if val is null.

printUnsignedInt

String printUnsignedInt(long val)

Converts a long value into a string.

Parameters:
val - A long value
Returns:
A string containing a lexical representation of xsd:unsignedInt

printUnsignedShort

String printUnsignedShort(int val)

Converts an int value into a string.

Parameters:
val - An int value
Returns:
A string containing a lexical representation of xsd:unsignedShort

printTime

String printTime(Calendar val)

Converts a Calendar value into a string.

Parameters:
val - A Calendar value
Returns:
A string containing a lexical representation of xsd:time
Throws:
IllegalArgumentException - if val is null.

printDate

String printDate(Calendar val)

Converts a Calendar value into a string.

Parameters:
val - A Calendar value
Returns:
A string containing a lexical representation of xsd:date
Throws:
IllegalArgumentException - if val is null.

printAnySimpleType

String printAnySimpleType(String val)

Converts a string value into a string.

Parameters:
val - A string value
Returns:
A string containing a lexical representation of xsd:AnySimpleType
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


helpers

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.bind.helpers

JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

See:
Description

Class Summary
AbstractMarshallerImpl | Partial default Marshaller implementation.
AbstractUnmarshallerImpl | Partial default Unmarshaller implementation.
DefaultValidationEventHandler | JAXB 1.0 only default validation event handler.
NotIdentifiableEventImpl | Default implementation of the NotIdentifiableEvent interface.
ParseConversionEventImpl | Default implementation of the ParseConversionEvent interface.
PrintConversionEventImpl | Default implementation of the PrintConversionEvent interface.
ValidationEventImpl | Default implementation of the ValidationEvent interface.
ValidationEventLocatorImpl | Default implementation of the ValidationEventLocator interface.

Package javax.xml.bind.helpers Description

JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.

JAXB Providers can extend these classes and implement the abstract methods.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.bind.helpers Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.bind.helpers

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.bind.helpers.AbstractMarshallerImpl (implements javax.xml.bind.Marshaller)
    • javax.xml.bind.helpers.AbstractUnmarshallerImpl (implements javax.xml.bind.Unmarshaller)
    • javax.xml.bind.helpers.DefaultValidationEventHandler (implements javax.xml.bind.ValidationEventHandler)
    • javax.xml.bind.helpers.ValidationEventImpl (implements javax.xml.bind.ValidationEvent)
      • javax.xml.bind.helpers.NotIdentifiableEventImpl (implements javax.xml.bind.NotIdentifiableEvent)
      • javax.xml.bind.helpers.ParseConversionEventImpl (implements javax.xml.bind.ParseConversionEvent)
      • javax.xml.bind.helpers.PrintConversionEventImpl (implements javax.xml.bind.PrintConversionEvent)
    • javax.xml.bind.helpers.ValidationEventLocatorImpl (implements javax.xml.bind.ValidationEventLocator)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AbstractMarshallerImpl

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.helpers
Class AbstractMarshallerImpl

java.lang.Object
    extended by  javax.xml.bind.helpers.AbstractMarshallerImpl
All Implemented Interfaces:
Marshaller
public abstract class AbstractMarshallerImpl
extends Object
implements Marshaller

Partial default Marshaller implementation.

This class provides a partial default implementation for the Marshaller interface.

The only methods that a JAXB Provider has to implement are
marshal(Object, javax.xml.transform.Result),
marshal(Object, javax.xml.stream.XMLStreamWriter), and
marshal(Object, javax.xml.stream.XMLEventWriter).

Since:
JAXB1.0
Version:
$Revision: 1.7 $ $Date: 2006/03/08 17:00:39 $
Author:
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
See Also:
Marshaller

Nested Class Summary
Nested classes/interfaces inherited from interface javax.xml.bind.Marshaller
Marshaller.Listener
Field Summary
Fields inherited from interface javax.xml.bind.Marshaller
JAXB_ENCODING, JAXB_FORMATTED_OUTPUT, JAXB_FRAGMENT, JAXB_NO_NAMESPACE_SCHEMA_LOCATION, JAXB_SCHEMA_LOCATION
Constructor Summary
AbstractMarshallerImpl()
Method Summary
<A extends XmlAdapter>
A
getAdapter(Class<A> type)
Gets the adapter associated with the specified type.
 AttachmentMarshaller getAttachmentMarshaller()
protected  String getEncoding()
Convenience method for getting the current output encoding.
 ValidationEventHandler getEventHandler()
Return the current event handler or the default event handler if one hasn't been set.
protected  String getJavaEncoding(String encoding)
Gets the corresponding Java encoding name from an IANA name.
 Marshaller.Listener getListener()
Return Marshaller.Listener registered with this Marshaller.
 Node getNode(Object obj)
By default, the getNode method is unsupported and throw an UnsupportedOperationException.
protected  String getNoNSSchemaLocation()
Convenience method for getting the current noNamespaceSchemaLocation.
 Object getProperty(String name)
Default implementation of the getProperty method handles the four defined properties in Marshaller.
 Schema getSchema()
Get the JAXP 1.3 Schema object being used to perform marshal-time validation.
protected  String getSchemaLocation()
Convenience method for getting the current schemaLocation.
protected  boolean isFormattedOutput()
Convenience method for getting the formatted output flag.
protected  boolean isFragment()
Convenience method for getting the fragment flag.
 void marshal(Object obj, ContentHandler handler)
Marshal the content tree rooted at jaxbElement into SAX2 events.
 void marshal(Object obj, Node node)
Marshal the content tree rooted at jaxbElement into a DOM tree.
 void marshal(Object obj, OutputStream os)
Marshal the content tree rooted at jaxbElement into an output stream.
 void marshal(Object obj, Writer w)
Marshal the content tree rooted at jaxbElement into a Writer.
 void marshal(Object obj, XMLEventWriter writer)
Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
 void marshal(Object obj, XMLStreamWriter writer)
Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
<A extends XmlAdapter>
void
setAdapter(Class<A> type, A adapter)
Associates a configured instance of XmlAdapter with this marshaller.
 void setAdapter(XmlAdapter adapter)
Associates a configured instance of XmlAdapter with this marshaller.
 void setAttachmentMarshaller(AttachmentMarshaller am)
Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment.
protected  void setEncoding(String encoding)
Convenience method for setting the output encoding.
 void setEventHandler(ValidationEventHandler handler)
Allow an application to register a validation event handler.
protected  void setFormattedOutput(boolean v)
Convenience method for setting the formatted output flag.
protected  void setFragment(boolean v)
Convenience method for setting the fragment flag.
 void setListener(Marshaller.Listener listener)
Register marshal event callback Marshaller.Listener with this Marshaller.
protected  void setNoNSSchemaLocation(String location)
Convenience method for setting the noNamespaceSchemaLocation.
 void setProperty(String name, Object value)
Default implementation of the setProperty method handles the four defined properties in Marshaller.
 void setSchema(Schema schema)
Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against.
protected  void setSchemaLocation(String location)
Convenience method for setting the schemaLocation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.xml.bind.Marshaller
marshal

Constructor Detail

AbstractMarshallerImpl

public AbstractMarshallerImpl()
Method Detail

marshal

public final void marshal(Object obj,
                          OutputStream os)
                   throws JAXBException
Description copied from interface: Marshaller
Marshal the content tree rooted at jaxbElement into an output stream.

Specified by:
marshal in interface Marshaller
Parameters:
obj - The root of content tree to be marshalled.
os - XML will be added to this stream.
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

marshal

public final void marshal(Object obj,
                          Writer w)
                   throws JAXBException
Description copied from interface: Marshaller
Marshal the content tree rooted at jaxbElement into a Writer.

Specified by:
marshal in interface Marshaller
Parameters:
obj - The root of content tree to be marshalled.
w - XML will be sent to this writer.
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

marshal

public final void marshal(Object obj,
                          ContentHandler handler)
                   throws JAXBException
Description copied from interface: Marshaller
Marshal the content tree rooted at jaxbElement into SAX2 events.

Specified by:
marshal in interface Marshaller
Parameters:
obj - The root of content tree to be marshalled.
handler - XML will be sent to this handler as SAX2 events.
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

marshal

public final void marshal(Object obj,
                          Node node)
                   throws JAXBException
Description copied from interface: Marshaller
Marshal the content tree rooted at jaxbElement into a DOM tree.

Specified by:
marshal in interface Marshaller
Parameters:
obj - The content tree to be marshalled.
node - DOM nodes will be added as children of this node. This parameter must be a Node that accepts children (Document, DocumentFragment, or Element)
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal jaxbElement (or any object reachable from jaxbElement). See Marshalling a JAXB element.

getNode

public Node getNode(Object obj)
             throws JAXBException
By default, the getNode method is unsupported and throw an UnsupportedOperationException. Implementations that choose to support this method must override this method.

Specified by:
getNode in interface Marshaller
Parameters:
obj - - JAXB Java representation of XML content
Returns:
the DOM tree view of the contentTree
Throws:
JAXBException - If any unexpected problem occurs

getEncoding

protected String getEncoding()
Convenience method for getting the current output encoding.

Returns:
the current encoding or "UTF-8" if it hasn't been set.

setEncoding

protected void setEncoding(String encoding)
Convenience method for setting the output encoding.

Parameters:
encoding - a valid encoding as specified in the Marshaller class documentation

getSchemaLocation

protected String getSchemaLocation()
Convenience method for getting the current schemaLocation.

Returns:
the current schemaLocation or null if it hasn't been set

setSchemaLocation

protected void setSchemaLocation(String location)
Convenience method for setting the schemaLocation.

Parameters:
location - the schemaLocation value

getNoNSSchemaLocation

protected String getNoNSSchemaLocation()
Convenience method for getting the current noNamespaceSchemaLocation.

Returns:
the current noNamespaceSchemaLocation or null if it hasn't been set

setNoNSSchemaLocation

protected void setNoNSSchemaLocation(String location)
Convenience method for setting the noNamespaceSchemaLocation.

Parameters:
location - the noNamespaceSchemaLocation value

isFormattedOutput

protected boolean isFormattedOutput()
Convenience method for getting the formatted output flag.

Returns:
the current value of the formatted output flag or false if it hasn't been set.

setFormattedOutput

protected void setFormattedOutput(boolean v)
Convenience method for setting the formatted output flag.

Parameters:
v - value of the formatted output flag.

isFragment

protected boolean isFragment()
Convenience method for getting the fragment flag.

Returns:
the current value of the fragment flag or false if it hasn't been set.

setFragment

protected void setFragment(boolean v)
Convenience method for setting the fragment flag.

Parameters:
v - value of the fragment flag.

getJavaEncoding

protected String getJavaEncoding(String encoding)
                          throws UnsupportedEncodingException
Gets the corresponding Java encoding name from an IANA name. This method is a helper method for the derived class to convert encoding names.

Throws:
UnsupportedEncodingException - If this implementation couldn't find the Java encoding name.

setProperty

public void setProperty(String name,
                        Object value)
                 throws PropertyException
Default implementation of the setProperty method handles the four defined properties in Marshaller. If a provider needs to handle additional properties, it should override this method in a derived class.

Specified by:
setProperty in interface Marshaller
Parameters:
name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
value - the value of the property to be set
Throws:
PropertyException - when there is an error processing the given property or value

getProperty

public Object getProperty(String name)
                   throws PropertyException
Default implementation of the getProperty method handles the four defined properties in Marshaller. If a provider needs to support additional provider specific properties, it should override this method in a derived class.

Specified by:
getProperty in interface Marshaller
Parameters:
name - the name of the property to retrieve
Returns:
the value of the requested property
Throws:
PropertyException - when there is an error retrieving the given property or value property name

getEventHandler

public ValidationEventHandler getEventHandler()
                                       throws JAXBException
Description copied from interface: Marshaller
Return the current event handler or the default event handler if one hasn't been set.

Specified by:
getEventHandler in interface Marshaller
Returns:
the current ValidationEventHandler or the default event handler if it hasn't been set
Throws:
JAXBException - if an error was encountered while getting the current event handler
See Also:
Marshaller.getEventHandler()

setEventHandler

public void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
Description copied from interface: Marshaller
Allow an application to register a validation event handler.

The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the marshal API's. If the client application does not register a validation event handler before invoking one of the marshal methods, then validation events will be handled by the default event handler which will terminate the marshal operation after the first error or fatal error is encountered.

Calling this method with a null parameter will cause the Marshaller to revert back to the default default event handler.

Specified by:
setEventHandler in interface Marshaller
Parameters:
handler - the validation event handler
Throws:
JAXBException - if an error was encountered while setting the event handler
See Also:
Marshaller.setEventHandler(ValidationEventHandler)

marshal

public void marshal(Object obj,
                    XMLEventWriter writer)
             throws JAXBException
Description copied from interface: Marshaller
Marshal the content tree rooted at jaxbElement into a XMLEventWriter.

Specified by:
marshal in interface Marshaller
Parameters:
obj - The content tree rooted at jaxbElement to be marshalled.
writer - XML will be sent to this writer.
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

marshal

public void marshal(Object obj,
                    XMLStreamWriter writer)
             throws JAXBException
Description copied from interface: Marshaller
Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.

Specified by:
marshal in interface Marshaller
Parameters:
obj - The content tree to be marshalled.
writer - XML will be sent to this writer.
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.

setSchema

public void setSchema(Schema schema)
Description copied from interface: Marshaller
Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against. Passing null into this method will disable validation.

This method allows the caller to validate the marshalled XML as it's marshalled.

Initially this property is set to null.

Specified by:
setSchema in interface Marshaller
Parameters:
schema - Schema object to validate marshal operations against or null to disable validation

getSchema

public Schema getSchema()
Description copied from interface: Marshaller
Get the JAXP 1.3 Schema object being used to perform marshal-time validation. If there is no Schema set on the marshaller, then this method will return null indicating that marshal-time validation will not be performed.

Specified by:
getSchema in interface Marshaller
Returns:
the Schema object being used to perform marshal-time validation or null if not present.

setAdapter

public void setAdapter(XmlAdapter adapter)
Description copied from interface: Marshaller
Associates a configured instance of XmlAdapter with this marshaller.

This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

Specified by:
setAdapter in interface Marshaller
See Also:
Marshaller.setAdapter(Class,XmlAdapter)

setAdapter

public <A extends XmlAdapter> void setAdapter(Class<A> type,
                                              A adapter)
Description copied from interface: Marshaller
Associates a configured instance of XmlAdapter with this marshaller.

Every marshaller internally maintains a Map<Class,XmlAdapter>, which it uses for marshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, a marshaller will create one by invoking its default constructor.

Specified by:
setAdapter in interface Marshaller
Parameters:
type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.

getAdapter

public <A extends XmlAdapter> A getAdapter(Class<A> type)
Description copied from interface: Marshaller
Gets the adapter associated with the specified type. This is the reverse operation of the Marshaller.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.

Specified by:
getAdapter in interface Marshaller

setAttachmentMarshaller

public void setAttachmentMarshaller(AttachmentMarshaller am)
Description copied from interface: Marshaller

Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment. The attachment is referenced from the XML document content model by content-id URIs(cid) references stored within the xml document.

Specified by:
setAttachmentMarshaller in interface Marshaller

getAttachmentMarshaller

public AttachmentMarshaller getAttachmentMarshaller()
Specified by:
getAttachmentMarshaller in interface Marshaller

setListener

public void setListener(Marshaller.Listener listener)
Description copied from interface: Marshaller

Register marshal event callback Marshaller.Listener with this Marshaller.

There is only one Listener per Marshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

Specified by:
setListener in interface Marshaller
Parameters:
listener - an instance of a class that implements Marshaller.Listener

getListener

public Marshaller.Listener getListener()
Description copied from interface: Marshaller

Return Marshaller.Listener registered with this Marshaller.

Specified by:
getListener in interface Marshaller
Returns:
registered Marshaller.Listener or null if no Listener is registered with this Marshaller.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AbstractUnmarshallerImpl

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.helpers
Class AbstractUnmarshallerImpl

java.lang.Object
    extended by  javax.xml.bind.helpers.AbstractUnmarshallerImpl
All Implemented Interfaces:
Unmarshaller
public abstract class AbstractUnmarshallerImpl
extends Object
implements Unmarshaller

Partial default Unmarshaller implementation.

This class provides a partial default implementation for the Unmarshallerinterface.

A JAXB Provider has to implement five methods (getUnmarshallerHandler, unmarshal(Node), unmarshal(XMLReader,InputSource), unmarshal(XMLStreamReader), and unmarshal(XMLEventReader).

Since:
JAXB1.0
Version:
$Revision: 1.14 $ $Date: 2006/03/08 17:01:00 $
Author:
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
See Also:
Unmarshaller

Nested Class Summary
Nested classes/interfaces inherited from interface javax.xml.bind.Unmarshaller
Unmarshaller.Listener
Field Summary
protected  boolean validating
whether or not the unmarshaller will validate
Constructor Summary
AbstractUnmarshallerImpl()
Method Summary
protected  UnmarshalException createUnmarshalException(SAXException e)
Creates an UnmarshalException from a SAXException.
<A extends XmlAdapter>
A
getAdapter(Class<A> type)
Gets the adapter associated with the specified type.
 AttachmentUnmarshaller getAttachmentUnmarshaller()
 ValidationEventHandler getEventHandler()
Return the current event handler or the default event handler if one hasn't been set.
 Unmarshaller.Listener getListener()
Return Unmarshaller.Listener registered with this Unmarshaller.
 Object getProperty(String name)
Default implementation of the getProperty method always throws PropertyException since there are no required properties.
 Schema getSchema()
Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.
protected  XMLReader getXMLReader()
Obtains a configured XMLReader.
 boolean isValidating()
Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.
<A extends XmlAdapter>
void
setAdapter(Class<A> type, A adapter)
Associates a configured instance of XmlAdapter with this unmarshaller.
 void setAdapter(XmlAdapter adapter)
Associates a configured instance of XmlAdapter with this unmarshaller.
 void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.
 void setEventHandler(ValidationEventHandler handler)
Allow an application to register a validation event handler.
 void setListener(Unmarshaller.Listener listener)
Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.
 void setProperty(String name, Object value)
Default implementation of the setProperty method always throws PropertyException since there are no required properties.
 void setSchema(Schema schema)
Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against.
 void setValidating(boolean validating)
Specifies whether or not the Unmarshaller should validate during unmarshal operations.
 Object unmarshal(File f)
Unmarshal XML data from the specified file and return the resulting content tree.
 Object unmarshal(InputSource source)
Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.
 Object unmarshal(InputStream is)
Unmarshal XML data from the specified InputStream and return the resulting content tree.
<T> JAXBElement<T>
unmarshal(Node node, Class<T> expectedType)
Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
 Object unmarshal(Reader reader)
Unmarshal XML data from the specified Reader and return the resulting content tree.
 Object unmarshal(Source source)
Unmarshal XML data from the specified XML Source and return the resulting content tree.
<T> JAXBElement<T>
unmarshal(Source source, Class<T> expectedType)
Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
 Object unmarshal(URL url)
Unmarshal XML data from the specified URL and return the resulting content tree.
 Object unmarshal(XMLEventReader reader)
Unmarshal XML data from the specified pull parser and return the resulting content tree.
<T> JAXBElement<T>
unmarshal(XMLEventReader reader, Class<T> expectedType)
Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
protected abstract  Object unmarshal(XMLReader reader, InputSource source)
Unmarshals an object by using the specified XMLReader and the InputSource.
 Object unmarshal(XMLStreamReader reader)
Unmarshal XML data from the specified pull parser and return the resulting content tree.
<T> JAXBElement<T>
unmarshal(XMLStreamReader reader, Class<T> expectedType)
Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.xml.bind.Unmarshaller
getUnmarshallerHandler, unmarshal

Field Detail

validating

protected boolean validating
whether or not the unmarshaller will validate

Constructor Detail

AbstractUnmarshallerImpl

public AbstractUnmarshallerImpl()
Method Detail

getXMLReader

protected XMLReader getXMLReader()
                          throws JAXBException
Obtains a configured XMLReader. This method is used when the client-specified SAXSource object doesn't have XMLReader. Unmarshaller is not re-entrant, so we will only use one instance of XMLReader.

Throws:
JAXBException

unmarshal

public Object unmarshal(Source source)
                 throws JAXBException
Description copied from interface: Unmarshaller
Unmarshal XML data from the specified XML Source and return the resulting content tree.

Implements Unmarshal Global Root Element.

SAX 2.0 Parser Pluggability

A client application can choose not to use the default parser mechanism supplied with their JAXB provider. Any SAX 2.0 compliant parser can be substituted for the JAXB provider's default mechanism. To do so, the client application must properly configure a SAXSource containing an XMLReader implemented by the SAX 2.0 parser provider. If the XMLReader has an org.xml.sax.ErrorHandler registered on it, it will be replaced by the JAXB Provider so that validation errors can be reported via the ValidationEventHandler mechanism of JAXB. If the SAXSource does not contain an XMLReader, then the JAXB provider's default parser mechanism will be used.

This parser replacement mechanism can also be used to replace the JAXB provider's unmarshal-time validation engine. The client application must properly configure their SAX 2.0 compliant parser to perform validation (as shown in the example above). Any SAXParserExceptions encountered by the parser during the unmarshal operation will be processed by the JAXB provider and converted into JAXB ValidationEvent objects which will be reported back to the client via the ValidationEventHandler registered with the Unmarshaller. Note: specifying a substitute validating SAX 2.0 parser for unmarshalling does not necessarily replace the validation engine used by the JAXB provider for performing on-demand validation.

The only way for a client application to specify an alternate parser mechanism to be used during unmarshal is via the unmarshal(SAXSource) API. All other forms of the unmarshal method (File, URL, Node, etc) will use the JAXB provider's default parser and validator mechanisms.

Specified by:
unmarshal in interface Unmarshaller
Parameters:
source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
Returns:
the newly created root object of the java content tree
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
See Also:
Unmarshaller.unmarshal(javax.xml.transform.Source, Class)

unmarshal

protected abstract Object unmarshal(XMLReader reader,
                                    InputSource source)
                             throws JAXBException
Unmarshals an object by using the specified XMLReader and the InputSource. The callee should call the setErrorHandler method of the XMLReader so that errors are passed to the client-specified ValidationEventHandler.

Throws:
JAXBException

unmarshal

public final Object unmarshal(InputSource source)
                       throws JAXBException
Description copied from interface: Unmarshaller
Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.

Implements Unmarshal Global Root Element.

Specified by:
unmarshal in interface Unmarshaller
Parameters:
source - the input source to unmarshal XML data from
Returns:
the newly created root object of the java content tree
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

unmarshal

public final Object unmarshal(URL url)
                       throws JAXBException
Description copied from interface: Unmarshaller
Unmarshal XML data from the specified URL and return the resulting content tree.

Implements Unmarshal Global Root Element.

Specified by:
unmarshal in interface Unmarshaller
Parameters:
url - the url to unmarshal XML data from
Returns:
the newly created root object of the java content tree
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

unmarshal

public final Object unmarshal(File f)
                       throws JAXBException
Description copied from interface: Unmarshaller
Unmarshal XML data from the specified file and return the resulting content tree.

Implements Unmarshal Global Root Element.

Specified by:
unmarshal in interface Unmarshaller
Parameters:
f - the file to unmarshal XML data from
Returns:
the newly created root object of the java content tree
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

unmarshal

public final Object unmarshal(InputStream is)
                       throws JAXBException
Description copied from interface: Unmarshaller
Unmarshal XML data from the specified InputStream and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API.

Implements Unmarshal Global Root Element.

Specified by:
unmarshal in interface Unmarshaller
Parameters:
is - the InputStream to unmarshal XML data from
Returns:
the newly created root object of the java content tree
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

unmarshal

public final Object unmarshal(Reader reader)
                       throws JAXBException
Description copied from interface: Unmarshaller
Unmarshal XML data from the specified Reader and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API, because a Reader does not provide the system ID.

Implements Unmarshal Global Root Element.

Specified by:
unmarshal in interface Unmarshaller
Parameters:
reader - the Reader to unmarshal XML data from
Returns:
the newly created root object of the java content tree
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

isValidating

public boolean isValidating()
                     throws JAXBException
Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.

Note: I named this method isValidating() to stay in-line with JAXP, as opposed to naming it getValidating().

Specified by:
isValidating in interface Unmarshaller
Returns:
true if the Unmarshaller is configured to validate during unmarshal operations, false otherwise
Throws:
JAXBException - if an error occurs while retrieving the validating flag

setEventHandler

public void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
Allow an application to register a validation event handler.

The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the unmarshal methods. If the client application does not register a validation event handler before invoking the unmarshal methods, then all validation events will be silently ignored and may result in unexpected behaviour.

Specified by:
setEventHandler in interface Unmarshaller
Parameters:
handler - the validation event handler
Throws:
JAXBException - if an error was encountered while setting the event handler

setValidating

public void setValidating(boolean validating)
                   throws JAXBException
Specifies whether or not the Unmarshaller should validate during unmarshal operations. By default, the Unmarshaller does not validate.

This method may only be invoked before or after calling one of the unmarshal methods.

Specified by:
setValidating in interface Unmarshaller
Parameters:
validating - true if the Unmarshaller should validate during unmarshal, false otherwise
Throws:
JAXBException - if an error occurred while enabling or disabling validation at unmarshal time

getEventHandler

public ValidationEventHandler getEventHandler()
                                       throws JAXBException
Return the current event handler or the default event handler if one hasn't been set.

Specified by:
getEventHandler in interface Unmarshaller
Returns:
the current ValidationEventHandler or the default event handler if it hasn't been set
Throws:
JAXBException - if an error was encountered while getting the current event handler

createUnmarshalException

protected UnmarshalException createUnmarshalException(SAXException e)
Creates an UnmarshalException from a SAXException. This is an utility method provided for the derived classes.

When a provider-implemented ContentHandler wants to throw a JAXBException, it needs to wrap the exception by a SAXException. If the unmarshaller implementation blindly wrap SAXException by JAXBException, such an exception will be a JAXBException wrapped by a SAXException wrapped by another JAXBException. This is silly.

This method checks the nested exception of SAXException and reduce those excessive wrapping.

Returns:
the resulting UnmarshalException

setProperty

public void setProperty(String name,
                        Object value)
                 throws PropertyException
Default implementation of the setProperty method always throws PropertyException since there are no required properties. If a provider needs to handle additional properties, it should override this method in a derived class.

Specified by:
setProperty in interface Unmarshaller
Parameters:
name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
value - the value of the property to be set
Throws:
PropertyException - when there is an error processing the given property or value

getProperty

public Object getProperty(String name)
                   throws PropertyException
Default implementation of the getProperty method always throws PropertyException since there are no required properties. If a provider needs to handle additional properties, it should override this method in a derived class.

Specified by:
getProperty in interface Unmarshaller
Parameters:
name - the name of the property to retrieve
Returns:
the value of the requested property
Throws:
PropertyException - when there is an error retrieving the given property or value property name

unmarshal

public Object unmarshal(XMLEventReader reader)
                 throws JAXBException
Description copied from interface: Unmarshaller
Unmarshal XML data from the specified pull parser and return the resulting content tree.

This method is an Unmarshal Global Root method.

This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

Specified by:
unmarshal in interface Unmarshaller
Parameters:
reader - The parser to be read.
Returns:
the newly created root object of the java content tree.
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
See Also:
Unmarshaller.unmarshal(javax.xml.stream.XMLEventReader, Class)

unmarshal

public Object unmarshal(XMLStreamReader reader)
                 throws JAXBException
Description copied from interface: Unmarshaller
Unmarshal XML data from the specified pull parser and return the resulting content tree.

Implements Unmarshal Global Root Element.

This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

Specified by:
unmarshal in interface Unmarshaller
Parameters:
reader - The parser to be read.
Returns:
the newly created root object of the java content tree.
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
See Also:
Unmarshaller.unmarshal(javax.xml.stream.XMLStreamReader, Class)

unmarshal

public <T> JAXBElement<T> unmarshal(Node node,
                                    Class<T> expectedType)
                         throws JAXBException
Description copied from interface: Unmarshaller
Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.

Implements Unmarshal by Declared Type

Specified by:
unmarshal in interface Unmarshaller
Parameters:
node - the document/element to unmarshal XML data from. The caller must support at least Document and Element.
expectedType - appropriate JAXB mapped class to hold node's XML data.
Returns:
JAXB Element representation of node
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

unmarshal

public <T> JAXBElement<T> unmarshal(Source source,
                                    Class<T> expectedType)
                         throws JAXBException
Description copied from interface: Unmarshaller
Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.

Implements Unmarshal by Declared Type

See SAX 2.0 Parser Pluggability

Specified by:
unmarshal in interface Unmarshaller
Parameters:
source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
expectedType - appropriate JAXB mapped class to hold source's xml root element
Returns:
Java content rooted by JAXB Element
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

unmarshal

public <T> JAXBElement<T> unmarshal(XMLStreamReader reader,
                                    Class<T> expectedType)
                         throws JAXBException
Description copied from interface: Unmarshaller
Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

This method implements unmarshal by declaredType.

This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

Specified by:
unmarshal in interface Unmarshaller
Parameters:
reader - The parser to be read.
expectedType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
Returns:
content tree rooted by JAXB Element representation
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

unmarshal

public <T> JAXBElement<T> unmarshal(XMLEventReader reader,
                                    Class<T> expectedType)
                         throws JAXBException
Description copied from interface: Unmarshaller
Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

This method implements unmarshal by declaredType.

This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

Specified by:
unmarshal in interface Unmarshaller
Parameters:
reader - The parser to be read.
expectedType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
Returns:
content tree rooted by JAXB Element representation
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data

setSchema

public void setSchema(Schema schema)
Description copied from interface: Unmarshaller
Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against. Passing null into this method will disable validation.

This method replaces the deprecated setValidating(boolean) API.

Initially this property is set to null.

Specified by:
setSchema in interface Unmarshaller
Parameters:
schema - Schema object to validate unmarshal operations against or null to disable validation

getSchema

public Schema getSchema()
Description copied from interface: Unmarshaller
Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation. If there is no Schema set on the unmarshaller, then this method will return null indicating that unmarshal-time validation will not be performed.

This method provides replacement functionality for the deprecated Unmarshaller.isValidating() API as well as access to the Schema object. To determine if the Unmarshaller has validation enabled, simply test the return type for null:

boolean isValidating = u.getSchema()!=null;

Specified by:
getSchema in interface Unmarshaller
Returns:
the Schema object being used to perform unmarshal-time validation or null if not present

setAdapter

public void setAdapter(XmlAdapter adapter)
Description copied from interface: Unmarshaller
Associates a configured instance of XmlAdapter with this unmarshaller.

This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

Specified by:
setAdapter in interface Unmarshaller
See Also:
Unmarshaller.setAdapter(Class,XmlAdapter)

setAdapter

public <A extends XmlAdapter> void setAdapter(Class<A> type,
                                              A adapter)
Description copied from interface: Unmarshaller
Associates a configured instance of XmlAdapter with this unmarshaller.

Every unmarshaller internally maintains a Map<Class,XmlAdapter>, which it uses for unmarshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, an unmarshaller will create one by invoking its default constructor.

Specified by:
setAdapter in interface Unmarshaller
Parameters:
type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.

getAdapter

public <A extends XmlAdapter> A getAdapter(Class<A> type)
Description copied from interface: Unmarshaller
Gets the adapter associated with the specified type. This is the reverse operation of the Unmarshaller.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.

Specified by:
getAdapter in interface Unmarshaller

setAttachmentUnmarshaller

public void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
Description copied from interface: Unmarshaller

Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.

Unmarshal time validation, enabled via Unmarshaller.setSchema(Schema), must be supported even when unmarshaller is performing XOP processing.

Specified by:
setAttachmentUnmarshaller in interface Unmarshaller

getAttachmentUnmarshaller

public AttachmentUnmarshaller getAttachmentUnmarshaller()
Specified by:
getAttachmentUnmarshaller in interface Unmarshaller

setListener

public void setListener(Unmarshaller.Listener listener)
Description copied from interface: Unmarshaller

Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.

There is only one Listener per Unmarshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

Specified by:
setListener in interface Unmarshaller
Parameters:
listener - provides unmarshal event callbacks for this Unmarshaller

getListener

public Unmarshaller.Listener getListener()
Description copied from interface: Unmarshaller

Return Unmarshaller.Listener registered with this Unmarshaller.

Specified by:
getListener in interface Unmarshaller
Returns:
registered Unmarshaller.Listener or null if no Listener is registered with this Unmarshaller.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DefaultValidationEventHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.helpers
Class DefaultValidationEventHandler

java.lang.Object
    extended by  javax.xml.bind.helpers.DefaultValidationEventHandler
All Implemented Interfaces:
ValidationEventHandler
public class DefaultValidationEventHandler
extends Object
implements ValidationEventHandler

JAXB 1.0 only default validation event handler. This is the default handler for all objects created from a JAXBContext that is managing schema-derived code generated by a JAXB 1.0 binding compiler.

This handler causes the unmarshal and validate operations to fail on the first error or fatal error.

This handler is not the default handler for JAXB mapped classes following JAXB 2.0 or later versions. Default validation event handling has changed and is specified in Unmarshaller and Marshaller.

Since:
JAXB1.0
Version:
$Revision: 1.5 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
See Also:
Unmarshaller, Validator, ValidationEventHandler

Constructor Summary
DefaultValidationEventHandler()
Method Summary
 boolean handleEvent(ValidationEvent event)
Receive notification of a validation warning or error.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultValidationEventHandler

public DefaultValidationEventHandler()
Method Detail

handleEvent

public boolean handleEvent(ValidationEvent event)
Description copied from interface: ValidationEventHandler
Receive notification of a validation warning or error. The ValidationEvent will have a ValidationEventLocator embedded in it that indicates where the error or warning occurred.

If an unchecked runtime exception is thrown from this method, the JAXB provider will treat it as if the method returned false and interrupt the current unmarshal, validate, or marshal operation.

Specified by:
handleEvent in interface ValidationEventHandler
Parameters:
event - the encapsulated validation event information. It is a provider error if this parameter is null.
Returns:
true if the JAXB Provider should attempt to continue the current unmarshal, validate, or marshal operation after handling this warning/error, false if the provider should terminate the current operation with the appropriate UnmarshalException, ValidationException, or MarshalException.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NotIdentifiableEventImpl

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.helpers
Class NotIdentifiableEventImpl

java.lang.Object
    extended by  javax.xml.bind.helpers.ValidationEventImpl
        extended by  javax.xml.bind.helpers.NotIdentifiableEventImpl
All Implemented Interfaces:
NotIdentifiableEvent, ValidationEvent
public class NotIdentifiableEventImpl
extends ValidationEventImpl
implements NotIdentifiableEvent

Default implementation of the NotIdentifiableEvent interface.

JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
See Also:
NotIdentifiableEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

Field Summary
Fields inherited from interface javax.xml.bind.ValidationEvent
ERROR, FATAL_ERROR, WARNING
Constructor Summary
NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator)
Create a new NotIdentifiableEventImpl.
NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
Create a new NotIdentifiableEventImpl.
Method Summary
Methods inherited from class javax.xml.bind.helpers.ValidationEventImpl
getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface javax.xml.bind.ValidationEvent
getLinkedException, getLocator, getMessage, getSeverity

Constructor Detail

NotIdentifiableEventImpl

public NotIdentifiableEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator)
Create a new NotIdentifiableEventImpl.

Parameters:
_severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
_message - The text message for this event - may be null.
_locator - The locator object for this event - may be null.
Throws:
IllegalArgumentException - if an illegal severity field is supplied

NotIdentifiableEventImpl

public NotIdentifiableEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator,
                                Throwable _linkedException)
Create a new NotIdentifiableEventImpl.

Parameters:
_severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
_message - The text message for this event - may be null.
_locator - The locator object for this event - may be null.
_linkedException - An optional linked exception that may provide additional information about the event - may be null.
Throws:
IllegalArgumentException - if an illegal severity field is supplied
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ParseConversionEventImpl

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.helpers
Class ParseConversionEventImpl

java.lang.Object
    extended by  javax.xml.bind.helpers.ValidationEventImpl
        extended by  javax.xml.bind.helpers.ParseConversionEventImpl
All Implemented Interfaces:
ParseConversionEvent, ValidationEvent
public class ParseConversionEventImpl
extends ValidationEventImpl
implements ParseConversionEvent

Default implementation of the ParseConversionEvent interface.

JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
See Also:
ParseConversionEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

Field Summary
Fields inherited from interface javax.xml.bind.ValidationEvent
ERROR, FATAL_ERROR, WARNING
Constructor Summary
ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
Create a new ParseConversionEventImpl.
ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
Create a new ParseConversionEventImpl.
Method Summary
Methods inherited from class javax.xml.bind.helpers.ValidationEventImpl
getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface javax.xml.bind.ValidationEvent
getLinkedException, getLocator, getMessage, getSeverity

Constructor Detail

ParseConversionEventImpl

public ParseConversionEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator)
Create a new ParseConversionEventImpl.

Parameters:
_severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
_message - The text message for this event - may be null.
_locator - The locator object for this event - may be null.
Throws:
IllegalArgumentException - if an illegal severity field is supplied

ParseConversionEventImpl

public ParseConversionEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator,
                                Throwable _linkedException)
Create a new ParseConversionEventImpl.

Parameters:
_severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
_message - The text message for this event - may be null.
_locator - The locator object for this event - may be null.
_linkedException - An optional linked exception that may provide additional information about the event - may be null.
Throws:
IllegalArgumentException - if an illegal severity field is supplied
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PrintConversionEventImpl

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.helpers
Class PrintConversionEventImpl

java.lang.Object
    extended by  javax.xml.bind.helpers.ValidationEventImpl
        extended by  javax.xml.bind.helpers.PrintConversionEventImpl
All Implemented Interfaces:
PrintConversionEvent, ValidationEvent
public class PrintConversionEventImpl
extends ValidationEventImpl
implements PrintConversionEvent

Default implementation of the PrintConversionEvent interface.

JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
See Also:
PrintConversionEvent, Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

Field Summary
Fields inherited from interface javax.xml.bind.ValidationEvent
ERROR, FATAL_ERROR, WARNING
Constructor Summary
PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
Create a new PrintConversionEventImpl.
PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
Create a new PrintConversionEventImpl.
Method Summary
Methods inherited from class javax.xml.bind.helpers.ValidationEventImpl
getLinkedException, getLocator, getMessage, getSeverity, setLinkedException, setLocator, setMessage, setSeverity, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface javax.xml.bind.ValidationEvent
getLinkedException, getLocator, getMessage, getSeverity

Constructor Detail

PrintConversionEventImpl

public PrintConversionEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator)
Create a new PrintConversionEventImpl.

Parameters:
_severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
_message - The text message for this event - may be null.
_locator - The locator object for this event - may be null.
Throws:
IllegalArgumentException - if an illegal severity field is supplied

PrintConversionEventImpl

public PrintConversionEventImpl(int _severity,
                                String _message,
                                ValidationEventLocator _locator,
                                Throwable _linkedException)
Create a new PrintConversionEventImpl.

Parameters:
_severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
_message - The text message for this event - may be null.
_locator - The locator object for this event - may be null.
_linkedException - An optional linked exception that may provide additional information about the event - may be null.
Throws:
IllegalArgumentException - if an illegal severity field is supplied
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValidationEventImpl

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.helpers
Class ValidationEventImpl

java.lang.Object
    extended by  javax.xml.bind.helpers.ValidationEventImpl
All Implemented Interfaces:
ValidationEvent
Direct Known Subclasses:
NotIdentifiableEventImpl, ParseConversionEventImpl, PrintConversionEventImpl
public class ValidationEventImpl
extends Object
implements ValidationEvent

Default implementation of the ValidationEvent interface.

JAXB providers are allowed to use whatever class that implements the ValidationEvent interface. This class is just provided for a convenience.

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
See Also:
Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

Field Summary
Fields inherited from interface javax.xml.bind.ValidationEvent
ERROR, FATAL_ERROR, WARNING
Constructor Summary
ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator)
Create a new ValidationEventImpl.
ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
Create a new ValidationEventImpl.
Method Summary
Throwable | getLinkedException() Retrieve the linked exception for this warning/error.
ValidationEventLocator | getLocator() Retrieve the locator for this warning/error.
String | getMessage() Retrieve the text message for this warning/error.
int | getSeverity() Retrieve the severity code for this warning/error.
void | setLinkedException(Throwable _linkedException) Set the linked exception field of this event.
void | setLocator(ValidationEventLocator _locator) Set the locator object for this event.
void | setMessage(String _message) Set the message field of this event.
void | setSeverity(int _severity) Set the severity field of this event.
String | toString() Returns a string representation of this object in a format helpful to debugging.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ValidationEventImpl

public ValidationEventImpl(int _severity,
                           String _message,
                           ValidationEventLocator _locator)
Create a new ValidationEventImpl.

Parameters:
_severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
_message - The text message for this event - may be null.
_locator - The locator object for this event - may be null.
Throws:
IllegalArgumentException - if an illegal severity field is supplied

ValidationEventImpl

public ValidationEventImpl(int _severity,
                           String _message,
                           ValidationEventLocator _locator,
                           Throwable _linkedException)
Create a new ValidationEventImpl.

Parameters:
_severity - The severity value for this event. Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR
_message - The text message for this event - may be null.
_locator - The locator object for this event - may be null.
_linkedException - An optional linked exception that may provide additional information about the event - may be null.
Throws:
IllegalArgumentException - if an illegal severity field is supplied
Method Detail

getSeverity

public int getSeverity()
Description copied from interface: ValidationEvent
Retrieve the severity code for this warning/error.

Must be one of ValidationError.WARNING, ValidationError.ERROR, or ValidationError.FATAL_ERROR.

Specified by:
getSeverity in interface ValidationEvent
Returns:
the severity code for this warning/error

setSeverity

public void setSeverity(int _severity)
Set the severity field of this event.

Parameters:
_severity - Must be one of ValidationEvent.WARNING, ValidationEvent.ERROR, or ValidationEvent.FATAL_ERROR.
Throws:
IllegalArgumentException - if an illegal severity field is supplied

getMessage

public String getMessage()
Description copied from interface: ValidationEvent
Retrieve the text message for this warning/error.

Specified by:
getMessage in interface ValidationEvent
Returns:
the text message for this warning/error or null if one wasn't set

setMessage

public void setMessage(String _message)
Set the message field of this event.

Parameters:
_message - String message - may be null.

getLinkedException

public Throwable getLinkedException()
Description copied from interface: ValidationEvent
Retrieve the linked exception for this warning/error.

Specified by:
getLinkedException in interface ValidationEvent
Returns:
the linked exception for this warning/error or null if one wasn't set

setLinkedException

public void setLinkedException(Throwable _linkedException)
Set the linked exception field of this event.

Parameters:
_linkedException - Optional linked exception - may be null.

getLocator

public ValidationEventLocator getLocator()
Description copied from interface: ValidationEvent
Retrieve the locator for this warning/error.

Specified by:
getLocator in interface ValidationEvent
Returns:
the locator that indicates where the warning/error occurred

setLocator

public void setLocator(ValidationEventLocator _locator)
Set the locator object for this event.

Parameters:
_locator - The locator - may be null.

toString

public String toString()
Returns a string representation of this object in a format helpful to debugging.

Overrides:
toString in class Object
See Also:
Object.equals(Object)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValidationEventLocatorImpl

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.helpers
Class ValidationEventLocatorImpl

java.lang.Object
    extended by  javax.xml.bind.helpers.ValidationEventLocatorImpl
All Implemented Interfaces:
ValidationEventLocator
public class ValidationEventLocatorImpl
extends Object
implements ValidationEventLocator

Default implementation of the ValidationEventLocator interface.

JAXB providers are allowed to use whatever class that implements the ValidationEventLocator interface. This class is just provided for a convenience.

Since:
JAXB1.0
Version:
$Revision: 1.2 $
Author:
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
See Also:
Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

Constructor Summary
ValidationEventLocatorImpl()
Creates an object with all fields unavailable.
ValidationEventLocatorImpl(Locator loc)
Constructs an object from an org.xml.sax.Locator.
ValidationEventLocatorImpl(Node _node)
Constructs an object that points to a DOM Node.
ValidationEventLocatorImpl(Object _object)
Constructs an object that points to a JAXB content object.
ValidationEventLocatorImpl(SAXParseException e)
Constructs an object from the location information of a SAXParseException.
Method Summary
int | getColumnNumber() Return the column number if available
int | getLineNumber() Return the line number if available
Node | getNode() Return a reference to the DOM Node if available
Object | getObject() Return a reference to the object in the Java content tree if available
int | getOffset() Return the byte offset if available
URL | getURL() Return the name of the XML source as a URL if available
void | setColumnNumber(int _columnNumber) Set the columnNumber field on this event locator.
void | setLineNumber(int _lineNumber) Set the lineNumber field on this event locator.
void | setNode(Node _node) Set the Node field on this event locator.
void | setObject(Object _object) Set the Object field on this event locator.
void | setOffset(int _offset) Set the offset field on this event locator.
void | setURL(URL _url) Set the URL field on this event locator.
String | toString() Returns a string representation of this object in a format helpful to debugging.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ValidationEventLocatorImpl

public ValidationEventLocatorImpl()
Creates an object with all fields unavailable.

ValidationEventLocatorImpl

public ValidationEventLocatorImpl(Locator loc)
Constructs an object from an org.xml.sax.Locator. The object's ColumnNumber, LineNumber, and URL become available from the values returned by the locator's getColumnNumber(), getLineNumber(), and getSystemId() methods respectively. Node, Object, and Offset are not available.

Parameters:
loc - the SAX Locator object that will be used to populate this event locator.
Throws:
IllegalArgumentException - if the Locator is null

ValidationEventLocatorImpl

public ValidationEventLocatorImpl(SAXParseException e)
Constructs an object from the location information of a SAXParseException. The object's ColumnNumber, LineNumber, and URL become available from the values returned by the locator's getColumnNumber(), getLineNumber(), and getSystemId() methods respectively. Node, Object, and Offset are not available.

Parameters:
e - the SAXParseException object that will be used to populate this event locator.
Throws:
IllegalArgumentException - if the SAXParseException is null

ValidationEventLocatorImpl

public ValidationEventLocatorImpl(Node _node)
Constructs an object that points to a DOM Node. The object's Node becomes available. ColumnNumber, LineNumber, Object, Offset, and URL are not available.

Parameters:
_node - the DOM Node object that will be used to populate this event locator.
Throws:
IllegalArgumentException - if the Node is null

ValidationEventLocatorImpl

public ValidationEventLocatorImpl(Object _object)
Constructs an object that points to a JAXB content object. The object's Object becomes available. ColumnNumber, LineNumber, Node, Offset, and URL are not available.

Parameters:
_object - the Object that will be used to populate this event locator.
Throws:
IllegalArgumentException - if the Object is null
Method Detail

getURL

public URL getURL()
Description copied from interface: ValidationEventLocator
Return the name of the XML source as a URL if available

Specified by:
getURL in interface ValidationEventLocator
Returns:
the name of the XML source as a URL or null if unavailable
See Also:
ValidationEventLocator.getURL()

setURL

public void setURL(URL _url)
Set the URL field on this event locator. Null values are allowed.

Parameters:
_url - the url

getOffset

public int getOffset()
Description copied from interface: ValidationEventLocator
Return the byte offset if available

Specified by:
getOffset in interface ValidationEventLocator
Returns:
the byte offset into the input source or -1 if unavailable
See Also:
ValidationEventLocator.getOffset()

setOffset

public void setOffset(int _offset)
Set the offset field on this event locator.

Parameters:
_offset - the offset

getLineNumber

public int getLineNumber()
Description copied from interface: ValidationEventLocator
Return the line number if available

Specified by:
getLineNumber in interface ValidationEventLocator
Returns:
the line number or -1 if unavailable
See Also:
ValidationEventLocator.getLineNumber()

setLineNumber

public void setLineNumber(int _lineNumber)
Set the lineNumber field on this event locator.

Parameters:
_lineNumber - the line number

getColumnNumber

public int getColumnNumber()
Description copied from interface: ValidationEventLocator
Return the column number if available

Specified by:
getColumnNumber in interface ValidationEventLocator
Returns:
the column number or -1 if unavailable
See Also:
ValidationEventLocator.getColumnNumber()

setColumnNumber

public void setColumnNumber(int _columnNumber)
Set the columnNumber field on this event locator.

Parameters:
_columnNumber - the column number

getObject

public Object getObject()
Description copied from interface: ValidationEventLocator
Return a reference to the object in the Java content tree if available

Specified by:
getObject in interface ValidationEventLocator
Returns:
a reference to the object in the Java content tree or null if unavailable
See Also:
ValidationEventLocator.getObject()

setObject

public void setObject(Object _object)
Set the Object field on this event locator. Null values are allowed.

Parameters:
_object - the java content object

getNode

public Node getNode()
Description copied from interface: ValidationEventLocator
Return a reference to the DOM Node if available

Specified by:
getNode in interface ValidationEventLocator
Returns:
a reference to the DOM Node or null if unavailable
See Also:
ValidationEventLocator.getNode()

setNode

public void setNode(Node _node)
Set the Node field on this event locator. Null values are allowed.

Parameters:
_node - the Node

toString

public String toString()
Returns a string representation of this object in a format helpful to debugging.

Overrides:
toString in class Object
See Also:
Object.equals(Object)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JAXBContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class JAXBContext

java.lang.Object
    extended by  javax.xml.bind.JAXBContext

public abstract class JAXBContext
extends Object

The JAXBContext class provides the client's entry point to the JAXB API. It provides an abstraction for managing the XML/Java binding information necessary to implement the JAXB binding framework operations: unmarshal, marshal and validate.

A client application normally obtains new instances of this class using one of these two styles for newInstance methods, although there are other specialized forms of the method available:

  • JAXBContext.newInstance( "com.acme.foo:com.acme.bar" )
    The JAXBContext instance is initialized from a list of colon separated Java package names. Each java package contains JAXB mapped classes, schema-derived classes and/or user annotated classes. Additionally, the java package may contain JAXB package annotations that must be processed. (see JLS 3rd Edition, Section 7.4.1. Package Annotations).
  • JAXBContext.newInstance( com.acme.foo.Foo.class )
    The JAXBContext instance is intialized with class(es) passed as parameter(s) and classes that are statically reachable from these class(es). See newInstance(Class...) for details.

SPEC REQUIREMENT: the provider must supply an implementation class containing the following method signatures:
 public static JAXBContext createContext( String contextPath, ClassLoader classLoader, Map properties ) throws JAXBException
 public static JAXBContext createContext( Class[] classes, Map properties ) throws JAXBException

The following JAXB 1.0 requirement is only required for schema to java interface/implementation binding. It does not apply to JAXB annotated classes. JAXB Providers must generate a jaxb.properties file in each package containing schema derived classes. The property file must contain a property named javax.xml.bind.context.factory whose value is the name of the class that implements the createContext APIs.

The class supplied by the provider does not have to be assignable to javax.xml.bind.JAXBContext, it simply has to provide a class that implements the createContext APIs.

In addition, the provider must call the DatatypeConverter.setDatatypeConverter api prior to any client invocations of the marshal and unmarshal methods. This is necessary to configure the datatype converter that will be used during these operations.

Unmarshalling

The Unmarshaller class provides the client application the ability to convert XML data into a tree of Java content objects. The unmarshal method allows for any global XML element declared in the schema to be unmarshalled as the root of an instance document. Additionally, the unmarshal method allows for an unrecognized root element that has an xsi:type attribute's value that references a type definition declared in the schema to be unmarshalled as the root of an instance document. The JAXBContext object allows the merging of global elements and type definitions across a set of schemas (listed in the contextPath). Since each schema in the schema set can belong to distinct namespaces, the unification of schemas to an unmarshalling context should be namespace independent. This means that a client application is able to unmarshal XML documents that are instances of any of the schemas listed in the contextPath. For example:
        JAXBContext jc = JAXBContext.newInstance( "com.acme.foo:com.acme.bar" );
        Unmarshaller u = jc.createUnmarshaller();
        FooObject fooObj = (FooObject)u.unmarshal( new File( "foo.xml" ) ); // ok
        BarObject barObj = (BarObject)u.unmarshal( new File( "bar.xml" ) ); // ok
        BazObject bazObj = (BazObject)u.unmarshal( new File( "baz.xml" ) ); // error, "com.acme.baz" not in contextPath

The client application may also generate Java content trees explicitly rather than unmarshalling existing XML data. For all JAXB-annotated value classes, an application can create content using constructors. For schema-derived interface/implementation classes and for the creation of elements that are not bound to a JAXB-annotated class, an application needs to have access and knowledge about each of the schema derived ObjectFactory classes that exist in each of java packages contained in the contextPath. For each schema derived java class, there is a static factory method that produces objects of that type. For example, assume that after compiling a schema, you have a package com.acme.foo that contains a schema derived interface named PurchaseOrder. In order to create objects of that type, the client application would use the factory method like this:

       com.acme.foo.PurchaseOrder po =
           com.acme.foo.ObjectFactory.createPurchaseOrder();

Once the client application has an instance of the the schema derived object, it can use the mutator methods to set content on it.

For more information on the generated ObjectFactory classes, see Section 4.2 Java Package of the specification.

SPEC REQUIREMENT: the provider must generate a class in each package that contains all of the necessary object factory methods for that package named ObjectFactory as well as the static newInstance( javaContentInterface ) method

Marshalling

The Marshaller class provides the client application the ability to convert a Java content tree back into XML data. There is no difference between marshalling a content tree that is created manually using the factory methods and marshalling a content tree that is the result an unmarshal operation. Clients can marshal a java content tree back to XML data to a java.io.OutputStream or a java.io.Writer. The marshalling process can alternatively produce SAX2 event streams to a registered ContentHandler or produce a DOM Node object. Client applications have control over the output encoding as well as whether or not to marshal the XML data as a complete document or as a fragment.

Here is a simple example that unmarshals an XML document and then marshals it back out:

        JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );

        // unmarshal from foo.xml
        Unmarshaller u = jc.createUnmarshaller();
        FooObject fooObj = (FooObject)u.unmarshal( new File( "foo.xml" ) );

        // marshal to System.out
        Marshaller m = jc.createMarshaller();
        m.marshal( fooObj, System.out );

Validation

Validation has been changed significantly since JAXB 1.0. The Validator class has been deprecated and made optional. This means that you are advised not to use this class and, in fact, it may not even be available depending on your JAXB provider. JAXB 1.0 client applications that rely on Validator will still work properly when deployed with the JAXB 1.0 runtime system. In JAXB 2.0, the Unmarshaller has included convenince methods that expose the JAXP 1.3 javax.xml.validation framework. Please refer to the Unmarshaller.setSchema(javax.xml.validation.Schema) API for more information.

JAXB Runtime Binding Framework Compatibility

The following JAXB 1.0 restriction only applies to binding schema to interfaces/implementation classes. Since this binding does not require a common runtime system, a JAXB client application must not attempt to mix runtime objects (JAXBContext, Marshaller, etc. ) from different providers. This does not mean that the client application isn't portable, it simply means that a client has to use a runtime system provided by the same provider that was used to compile the schema.

Since:
JAXB1.0
Version:
$Revision: 1.24 $ $Date: 2006/03/08 17:05:01 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.
See Also:
Marshaller, Unmarshaller, S 7.4.1.1 "Package Annotations" in Java Language Specification, 3rd Edition

Field Summary
static String JAXB_CONTEXT_FACTORY
The name of the property that contains the name of the class capable of creating new JAXBContext objects.
Constructor Summary
protected JAXBContext()
Method Summary
 Binder<Node> createBinder()
Creates a Binder for W3C DOM.
<T> Binder<T>
createBinder(Class<T> domType)
Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.
 JAXBIntrospector createJAXBIntrospector()
Creates a JAXBIntrospector object that can be used to introspect JAXB objects.
abstract  Marshaller createMarshaller()
Create a Marshaller object that can be used to convert a java content tree into XML data.
abstract  Unmarshaller createUnmarshaller()
Create an Unmarshaller object that can be used to convert XML data into a java content tree.
abstract  Validator createValidator()
Deprecated. since JAXB2.0
 void generateSchema(SchemaOutputResolver outputResolver)
Generates the schema documents for this context.
static JAXBContext newInstance(Class... classesToBeBound)
Obtain a new instance of a JAXBContext class.
static JAXBContext newInstance(Class[] classesToBeBound, Map<String,?> properties)
Obtain a new instance of a JAXBContext class.
static JAXBContext newInstance(String contextPath)
Obtain a new instance of a JAXBContext class.
static JAXBContext newInstance(String contextPath, ClassLoader classLoader)
Obtain a new instance of a JAXBContext class.
static JAXBContext newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
Obtain a new instance of a JAXBContext class.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

JAXB_CONTEXT_FACTORY

public static final String JAXB_CONTEXT_FACTORY
The name of the property that contains the name of the class capable of creating new JAXBContext objects.

See Also:
Constant Field Values
Constructor Detail

JAXBContext

protected JAXBContext()
Method Detail

newInstance

public static JAXBContext newInstance(String contextPath)
                               throws JAXBException

Obtain a new instance of a JAXBContext class.

This is a convenience method for the newInstance method. It uses the context class loader of the current thread. To specify the use of a different class loader, either set it via the Thread.setContextClassLoader() api or use the newInstance method.

Throws:
JAXBException - if an error was encountered while creating the JAXBContext such as
  1. failure to locate either ObjectFactory.class or jaxb.index in the packages
  2. an ambiguity among global elements contained in the contextPath
  3. failure to locate a value for the context factory provider property
  4. mixing schema derived packages from different providers on the same contextPath

newInstance

public static JAXBContext newInstance(String contextPath,
                                      ClassLoader classLoader)
                               throws JAXBException

Obtain a new instance of a JAXBContext class.

The client application must supply a context path which is a list of colon (':', \u003A) separated java package names that contain schema-derived classes and/or fully qualified JAXB-annotated classes. Schema-derived code is registered with the JAXBContext by the ObjectFactory.class generated per package. Alternatively than being listed in the context path, programmer annotated JAXB mapped classes can be listed in a jaxb.index resource file, format described below. Note that a java package can contain both schema-derived classes and user annotated JAXB classes. Additionally, the java package may contain JAXB package annotations that must be processed. (see JLS 3rd Edition, Section 7.4.1. "Package Annotations").

Every package listed on the contextPath must meet one or both of the following conditions otherwise a JAXBException will be thrown:

  1. it must contain ObjectFactory.class
  2. it must contain jaxb.index

Format for jaxb.index

The file contains a newline-separated list of class names. Space and tab characters, as well as blank lines, are ignored. The comment character is '#' (0x23); on each line all characters following the first comment character are ignored. The file must be encoded in UTF-8. Classes that are reachable, as defined in newInstance(Class...), from the listed classes are also registered with JAXBContext.

Constraints on class name occuring in a jaxb.index file are:

  • Must not end with ".class".
  • Class names are resolved relative to package containing jaxb.index file. Only classes occuring directly in package containing jaxb.index file are allowed.
  • Fully qualified class names are not allowed. A qualified class name,relative to current package, is only allowed to specify a nested or inner class.

To maintain compatibility with JAXB 1.0 schema to java interface/implementation binding, enabled by schema customization , the JAXB provider will ensure that each package on the context path has a jaxb.properties file which contains a value for the javax.xml.bind.context.factory property and that all values resolve to the same provider. This requirement does not apply to JAXB annotated classes.

If there are any global XML element name collisions across the various packages listed on the contextPath, a JAXBException will be thrown.

Mixing generated interface/impl bindings from multiple JAXB Providers in the same context path may result in a JAXBException being thrown.

Parameters:
contextPath - list of java package names that contain schema derived class and/or java to schema (JAXB-annotated) mapped classes
classLoader - This class loader will be used to locate the implementation classes.
Returns:
a new instance of a JAXBContext
Throws:
JAXBException - if an error was encountered while creating the JAXBContext such as
  1. failure to locate either ObjectFactory.class or jaxb.index in the packages
  2. an ambiguity among global elements contained in the contextPath
  3. failure to locate a value for the context factory provider property
  4. mixing schema derived packages from different providers on the same contextPath

newInstance

public static JAXBContext newInstance(String contextPath,
                                      ClassLoader classLoader,
                                      Map<String,?> properties)
                               throws JAXBException

Obtain a new instance of a JAXBContext class.

This is mostly the same as newInstance(String, ClassLoader), but this version allows you to pass in provider-specific properties to configure the instanciation of JAXBContext.

The interpretation of properties is up to implementations.

Parameters:
contextPath - list of java package names that contain schema derived classes
classLoader - This class loader will be used to locate the implementation classes.
properties - provider-specific properties
Returns:
a new instance of a JAXBContext
Throws:
JAXBException - if an error was encountered while creating the JAXBContext such as
  1. failure to locate either ObjectFactory.class or jaxb.index in the packages
  2. an ambiguity among global elements contained in the contextPath
  3. failure to locate a value for the context factory provider property
  4. mixing schema derived packages from different providers on the same contextPath
Since:
JAXB2.0

newInstance

public static JAXBContext newInstance(Class... classesToBeBound)
                               throws JAXBException

Obtain a new instance of a JAXBContext class.

The client application must supply a list of classes that the new context object needs to recognize. Not only the new context will recognize all the classes specified, but it will also recognize any classes that are directly/indirectly referenced statically from the specified classes. Subclasses of referenced classes nor @XmlTransient referenced classes are not registered with JAXBContext. For example, in the following Java code, if you do newInstance(Foo.class), the newly created JAXBContext will recognize both Foo and Bar, but not Zot or FooBar:

 class Foo {
      @XmlTransient FooBar c;
      Bar b;
 }
 class Bar { int x; }
 class Zot extends Bar { int y; }
 class FooBar { }
Therefore, a typical client application only needs to specify the top-level classes, but it needs to be careful.

Note that for each java package registered with JAXBContext, when the optional package annotations exist, they must be processed. (see JLS 3rd Edition, Section 7.4.1. "Package Annotations").

Parameters:
classesToBeBound - list of java classes to be recognized by the new JAXBContext. Can be empty, in which case a JAXBContext that only knows about spec-defined classes will be returned.
Returns:
A new instance of a JAXBContext. Always non-null valid object.
Throws:
JAXBException - if an error was encountered while creating the JAXBContext, such as (but not limited to):
  1. No JAXB implementation was discovered
  2. Classes use JAXB annotations incorrectly
  3. Classes have colliding annotations (i.e., two classes with the same type name)
  4. The JAXB implementation was unable to locate provider-specific out-of-band information (such as additional files generated at the development time.)
IllegalArgumentException - if the parameter contains null (i.e., newInstance(null);)
Since:
JAXB2.0

newInstance

public static JAXBContext newInstance(Class[] classesToBeBound,
                                      Map<String,?> properties)
                               throws JAXBException

Obtain a new instance of a JAXBContext class.

An overloading of newInstance(Class...) to configure 'properties' for this instantiation of JAXBContext.

The interpretation of properties is implementation specific.

Parameters:
classesToBeBound - list of java classes to be recognized by the new JAXBContext. Can be empty, in which case a JAXBContext that only knows about spec-defined classes will be returned.
Returns:
A new instance of a JAXBContext. Always non-null valid object.
Throws:
JAXBException - if an error was encountered while creating the JAXBContext, such as (but not limited to):
  1. No JAXB implementation was discovered
  2. Classes use JAXB annotations incorrectly
  3. Classes have colliding annotations (i.e., two classes with the same type name)
  4. The JAXB implementation was unable to locate provider-specific out-of-band information (such as additional files generated at the development time.)
IllegalArgumentException - if the parameter contains null (i.e., newInstance(null);)
Since:
JAXB2.0

createUnmarshaller

public abstract Unmarshaller createUnmarshaller()
                                         throws JAXBException
Create an Unmarshaller object that can be used to convert XML data into a java content tree.

Returns:
an Unmarshaller object
Throws:
JAXBException - if an error was encountered while creating the Unmarshaller object

createMarshaller

public abstract Marshaller createMarshaller()
                                     throws JAXBException
Create a Marshaller object that can be used to convert a java content tree into XML data.

Returns:
a Marshaller object
Throws:
JAXBException - if an error was encountered while creating the Marshaller object

createValidator

public abstract Validator createValidator()
                                   throws JAXBException
Deprecated. since JAXB2.0

Validator has been made optional and deprecated in JAXB 2.0. Please refer to the javadoc for Validator for more detail.

Create a Validator object that can be used to validate a java content tree against its source schema.

Returns:
a Validator object
Throws:
JAXBException - if an error was encountered while creating the Validator object

createBinder

public <T> Binder<T> createBinder(Class<T> domType)
Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.

Parameters:
domType - select the DOM API to use by passing in its DOM Node class.
Returns:
always a new valid Binder object.
Throws:
UnsupportedOperationException - if DOM API corresponding to domType is not supported by the implementation.
Since:
JAXB2.0

createBinder

public Binder<Node> createBinder()
Creates a Binder for W3C DOM.

Returns:
always a new valid Binder object.
Since:
JAXB2.0

createJAXBIntrospector

public JAXBIntrospector createJAXBIntrospector()
Creates a JAXBIntrospector object that can be used to introspect JAXB objects.

Returns:
always return a non-null valid JAXBIntrospector object.
Throws:
UnsupportedOperationException - Calling this method on JAXB 1.0 implementations will throw an UnsupportedOperationException.
Since:
JAXB2.0

generateSchema

public void generateSchema(SchemaOutputResolver outputResolver)
                    throws IOException
Generates the schema documents for this context.

Parameters:
outputResolver - this object controls the output to which schemas will be sent.
Throws:
IOException - if SchemaOutputResolver throws an IOException.
UnsupportedOperationException - Calling this method on JAXB 1.0 implementations will throw an UnsupportedOperationException.
Since:
JAXB 2.0
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JAXBElement

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class JAXBElement<T>

java.lang.Object
    extended by  javax.xml.bind.JAXBElement<T>
All Implemented Interfaces:
Serializable
public class JAXBElement<T>
extends Object
implements Serializable

JAXB representation of an Xml Element.

This class represents information about an Xml Element from both the element declaration within a schema and the element instance value within an xml document with the following properties

  • element's xml tag name
  • value represents the element instance's atttribute(s) and content model
  • element declaration's declaredType (xs:element @type attribute)
  • scope of element declaration
  • boolean nil property. (element instance's xsi:nil attribute)

The declaredType and scope property are the JAXB class binding for the xml type definition.

Scope is either JAXBElement.GlobalScope or the Java class representing the complex type definition containing the schema element declaration.

There is a property constraint that if value is null, then nil must be true. The converse is not true to enable representing a nil element with attribute(s). If nil is true, it is possible that value is non-null so it can hold the value of the attributes associated with a nil element.

Since:
JAXB 2.0
Author:
Kohsuke Kawaguchi, Joe Fialli
See Also:
Serialized Form

Nested Class Summary
static class JAXBElement.GlobalScope
Designates global scope for an xml element.
Field Summary
protected Class<T> | declaredType Java datatype binding for xml element declaration's type.
protected QName | name xml element tag name
protected boolean | nil true iff the xml element instance has xsi:nil="true".
protected Class | scope Scope of xml element declaration representing this xml element instance.
protected T | value xml element value.
Constructor Summary
JAXBElement(QName name, Class<T> declaredType, Class scope, T value)
Construct an xml element instance.
JAXBElement(QName name, Class<T> declaredType, T value)
Construct an xml element instance.
Method Summary
Class<T> | getDeclaredType() Returns the Java binding of the xml element declaration's type attribute.
QName | getName() Returns the xml element tag name.
Class | getScope() Returns scope of xml element declaration.
T | getValue() Return the content model and attribute values for this element.
boolean | isGlobalScope() Returns true iff this xml element declaration is global.
boolean | isNil() Returns true iff this element instance content model is nil.
boolean | isTypeSubstituted() Returns true iff this xml element instance's value has a different type than xml element declaration's declared type.
void | setNil(boolean value) Set whether this element has nil content.
void | setValue(T t) Set the content model and attributes of this xml element.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

protected final QName name
xml element tag name

declaredType

protected final Class<T> declaredType
Java datatype binding for xml element declaration's type.

scope

protected final Class scope
Scope of xml element declaration representing this xml element instance. Can be one of the following values: - JAXBElement.GlobalScope for global xml element declaration. - local element declaration has a scope set to the Java class representation of complex type defintion containing xml element declaration.

value

protected T value
xml element value. Represents content model and attributes of an xml element instance.

nil

protected boolean nil
true iff the xml element instance has xsi:nil="true".

Constructor Detail

JAXBElement

public JAXBElement(QName name,
                   Class<T> declaredType,
                   Class scope,
                   T value)

Construct an xml element instance.

Parameters:
name - Java binding of xml element tag name
declaredType - Java binding of xml element declaration's type
scope - Java binding of scope of xml element declaration. Passing null is the same as passing GlobalScope.class
value - Java instance representing xml element's value.
See Also:
getScope(), isTypeSubstituted()

JAXBElement

public JAXBElement(QName name,
                   Class<T> declaredType,
                   T value)
Construct an xml element instance. This is just a convenience method for new JAXBElement(name,declaredType,GlobalScope.class,value)

Method Detail

getDeclaredType

public Class<T> getDeclaredType()
Returns the Java binding of the xml element declaration's type attribute.

getName

public QName getName()
Returns the xml element tag name.

setValue

public void setValue(T t)

Set the content model and attributes of this xml element.

When this property is set to null, isNil() must by true. Details of constraint are described at isNil().

See Also:
isTypeSubstituted()

getValue

public T getValue()

Return the content model and attribute values for this element.

See isNil() for a description of a property constraint when this value is null

getScope

public Class getScope()
Returns scope of xml element declaration.

Returns:
GlobalScope.class if this element is of global scope.
See Also:
isGlobalScope()

isNil

public boolean isNil()

Returns true iff this element instance content model is nil.

This property always returns true when getValue() is null. Note that the converse is not true, when this property is true, getValue() can contain a non-null value for attribute(s). It is valid for a nil xml element to have attribute(s).

setNil

public void setNil(boolean value)

Set whether this element has nil content.

See Also:
isNil()

isGlobalScope

public boolean isGlobalScope()
Returns true iff this xml element declaration is global.

isTypeSubstituted

public boolean isTypeSubstituted()
Returns true iff this xml element instance's value has a different type than xml element declaration's declared type.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JAXBElement.GlobalScope

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class JAXBElement.GlobalScope

java.lang.Object
    extended by  javax.xml.bind.JAXBElement.GlobalScope
Enclosing class:
JAXBElement<T>
public static final class JAXBElement.GlobalScope
extends Object

Designates global scope for an xml element.

Constructor Summary
JAXBElement.GlobalScope()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JAXBElement.GlobalScope

public JAXBElement.GlobalScope()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JAXBException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class JAXBException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.bind.JAXBException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
MarshalException, PropertyException, UnmarshalException, ValidationException
public class JAXBException
extends Exception

This is the root exception class for all JAXB exceptions.

Since:
JAXB1.0
Version:
$Revision: 1.1 $ $Date: 2004/12/14 21:50:39 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
See Also:
JAXBContext, Marshaller, Unmarshaller, Serialized Form

Constructor Summary
JAXBException(String message)
Construct a JAXBException with the specified detail message.
JAXBException(String message, String errorCode)
Construct a JAXBException with the specified detail message and vendor specific errorCode.
JAXBException(String message, String errorCode, Throwable exception)
Construct a JAXBException with the specified detail message, vendor specific errorCode, and linkedException.
JAXBException(String message, Throwable exception)
Construct a JAXBException with the specified detail message and linkedException.
JAXBException(Throwable exception)
Construct a JAXBException with a linkedException.
Method Summary
Throwable | getCause()
String | getErrorCode() Get the vendor specific error code
Throwable | getLinkedException() Get the linked exception
void | printStackTrace() Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
void | printStackTrace(PrintStream s) Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
void | printStackTrace(PrintWriter s) Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintWriter.
void | setLinkedException(Throwable exception) Add a linked Exception.
String | toString() Returns a short description of this JAXBException.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JAXBException

public JAXBException(String message)
Construct a JAXBException with the specified detail message. The errorCode and linkedException will default to null.

Parameters:
message - a description of the exception

JAXBException

public JAXBException(String message,
                     String errorCode)
Construct a JAXBException with the specified detail message and vendor specific errorCode. The linkedException will default to null.

Parameters:
message - a description of the exception
errorCode - a string specifying the vendor specific error code

JAXBException

public JAXBException(Throwable exception)
Construct a JAXBException with a linkedException. The detail message and vendor specific errorCode will default to null.

Parameters:
exception - the linked exception

JAXBException

public JAXBException(String message,
                     Throwable exception)
Construct a JAXBException with the specified detail message and linkedException. The errorCode will default to null.

Parameters:
message - a description of the exception
exception - the linked exception

JAXBException

public JAXBException(String message,
                     String errorCode,
                     Throwable exception)
Construct a JAXBException with the specified detail message, vendor specific errorCode, and linkedException.

Parameters:
message - a description of the exception
errorCode - a string specifying the vendor specific error code
exception - the linked exception
Method Detail

getErrorCode

public String getErrorCode()
Get the vendor specific error code

Returns:
a string specifying the vendor specific error code

getLinkedException

public Throwable getLinkedException()
Get the linked exception

Returns:
the linked Exception, null if none exists

setLinkedException

public void setLinkedException(Throwable exception)
Add a linked Exception.

Parameters:
exception - the linked Exception (A null value is permitted and indicates that the linked exception does not exist or is unknown).

toString

public String toString()
Returns a short description of this JAXBException.

Overrides:
toString in class Throwable

printStackTrace

public void printStackTrace(PrintStream s)
Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.

Overrides:
printStackTrace in class Throwable
Parameters:
s - PrintStream to use for output

printStackTrace

public void printStackTrace()
Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.

Overrides:
printStackTrace in class Throwable

printStackTrace

public void printStackTrace(PrintWriter s)
Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintWriter.

Overrides:
printStackTrace in class Throwable
Parameters:
s - PrintWriter to use for output

getCause

public Throwable getCause()
Overrides:
getCause in class Throwable
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JAXBIntrospector

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class JAXBIntrospector

java.lang.Object
    extended by  javax.xml.bind.JAXBIntrospector

public abstract class JAXBIntrospector
extends Object

Provide access to JAXB xml binding data for a JAXB object.

Intially, the intent of this class is to just conceptualize how a JAXB application developer can access xml binding information, independent if binding model is java to schema or schema to java. Since accessing the XML element name related to a JAXB element is a highly requested feature, demonstrate access to this binding information. The factory method to get a JAXBIntrospector instance is JAXBContext.createJAXBIntrospector().

Since:
JAXB2.0
See Also:
JAXBContext.createJAXBIntrospector()

Constructor Summary
JAXBIntrospector()
Method Summary
abstract QName | getElementName(Object jaxbElement) Get xml element qname for jaxbElement.
static Object | getValue(Object jaxbElement) Get the element value of a JAXB element.
abstract boolean | isElement(Object object) Return true iff object represents a JAXB element.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JAXBIntrospector

public JAXBIntrospector()
Method Detail

isElement

public abstract boolean isElement(Object object)

Return true iff object represents a JAXB element.

Parameter object is a JAXB element for following cases:

  1. It is an instance of javax.xml.bind.JAXBElement.
  2. The class of object is annotated with @XmlRootElement.

See Also:
getElementName(Object)

getElementName

public abstract QName getElementName(Object jaxbElement)

Get xml element qname for jaxbElement.

Parameters:
jaxbElement - is an object that isElement(Object) returned true.
Returns:
xml element qname associated with jaxbElement; null if jaxbElement is not a JAXB Element.

getValue

public static Object getValue(Object jaxbElement)

Get the element value of a JAXB element.

Convenience method to abstract whether working with either a javax.xml.bind.JAXBElement instance or an instance of @XmlRootElement annotated Java class.

Parameters:
jaxbElement - object that #isElement(Object) returns true.
Returns:
The element value of the jaxbElement.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MarshalException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class MarshalException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.bind.JAXBException
                extended by  javax.xml.bind.MarshalException
All Implemented Interfaces:
Serializable
public class MarshalException
extends JAXBException

This exception indicates that an error has occurred while performing a marshal operation that the provider is unable to recover from.

The ValidationEventHandler can cause this exception to be thrown during the marshal operations. See ValidationEventHandler.handleEvent(ValidationEvent).

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
See Also:
JAXBException, Marshaller, Serialized Form

Constructor Summary
MarshalException(String message)
Construct a MarshalException with the specified detail message.
MarshalException(String message, String errorCode)
Construct a MarshalException with the specified detail message and vendor specific errorCode.
MarshalException(String message, String errorCode, Throwable exception)
Construct a MarshalException with the specified detail message, vendor specific errorCode, and linkedException.
MarshalException(String message, Throwable exception)
Construct a MarshalException with the specified detail message and linkedException.
MarshalException(Throwable exception)
Construct a MarshalException with a linkedException.
Method Summary
Methods inherited from class javax.xml.bind.JAXBException
getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MarshalException

public MarshalException(String message)
Construct a MarshalException with the specified detail message. The errorCode and linkedException will default to null.

Parameters:
message - a description of the exception

MarshalException

public MarshalException(String message,
                        String errorCode)
Construct a MarshalException with the specified detail message and vendor specific errorCode. The linkedException will default to null.

Parameters:
message - a description of the exception
errorCode - a string specifying the vendor specific error code

MarshalException

public MarshalException(Throwable exception)
Construct a MarshalException with a linkedException. The detail message and vendor specific errorCode will default to null.

Parameters:
exception - the linked exception

MarshalException

public MarshalException(String message,
                        Throwable exception)
Construct a MarshalException with the specified detail message and linkedException. The errorCode will default to null.

Parameters:
message - a description of the exception
exception - the linked exception

MarshalException

public MarshalException(String message,
                        String errorCode,
                        Throwable exception)
Construct a MarshalException with the specified detail message, vendor specific errorCode, and linkedException.

Parameters:
message - a description of the exception
errorCode - a string specifying the vendor specific error code
exception - the linked exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Marshaller

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Interface Marshaller

All Known Implementing Classes:
AbstractMarshallerImpl
public interface Marshaller

The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data. It provides the basic marshalling methods:

Assume the following setup code for all following code fragments:

       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       Object element = u.unmarshal( new File( "foo.xml" ) );
       Marshaller m = jc.createMarshaller();

Marshalling to a File:

       OutputStream os = new FileOutputStream( "nosferatu.xml" );
       m.marshal( element, os );

Marshalling to a SAX ContentHandler:

       // assume MyContentHandler instanceof ContentHandler
       m.marshal( element, new MyContentHandler() );

Marshalling to a DOM Node:

       DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
       dbf.setNamespaceAware(true);
       DocumentBuilder db = dbf.newDocumentBuilder();
       Document doc = db.newDocument();

       m.marshal( element, doc );

Marshalling to a java.io.OutputStream:

       m.marshal( element, System.out );

Marshalling to a java.io.Writer:

       m.marshal( element, new PrintWriter( System.out ) );

Marshalling to a javax.xml.transform.SAXResult:

       // assume MyContentHandler instanceof ContentHandler
       SAXResult result = new SAXResult( new MyContentHandler() );

       m.marshal( element, result );

Marshalling to a javax.xml.transform.DOMResult:

       DOMResult result = new DOMResult();

       m.marshal( element, result );

Marshalling to a javax.xml.transform.StreamResult:

       StreamResult result = new StreamResult( System.out );

       m.marshal( element, result );

Marshalling to a javax.xml.stream.XMLStreamWriter:

       XMLStreamWriter xmlStreamWriter =
           XMLOutputFactory.newInstance().createXMLStreamWriter( ... );

       m.marshal( element, xmlStreamWriter );

Marshalling to a javax.xml.stream.XMLEventWriter:

       XMLEventWriter xmlEventWriter =
           XMLOutputFactory.newInstance().createXMLEventWriter( ... );

       m.marshal( element, xmlEventWriter );

Marshalling content tree rooted by a JAXB element

The first parameter of the overloaded Marshaller.marshal(java.lang.Object, ...) methods must be a JAXB element as computed by JAXBIntrospector.isElement(java.lang.Object); otherwise, a Marshaller.marshal method must throw a MarshalException. There exist two mechanisms to enable marshalling an instance that is not a JAXB element. One method is to wrap the instance as a value of a JAXBElement, and pass the wrapper element as the first parameter to a Marshaller.marshal method. For java to schema binding, it is also possible to simply annotate the instance's class with @XmlRootElement.

Encoding

By default, the Marshaller will use UTF-8 encoding when generating XML data to a java.io.OutputStream, or a java.io.Writer. Use the setProperty API to change the output encoding used during these marshal operations. Client applications are expected to supply a valid character encoding name as defined in the W3C XML 1.0 Recommendation and supported by your Java Platform.

Validation and Well-Formedness

Client applications are not required to validate the Java content tree prior to calling any of the marshal API's. Furthermore, there is no requirement that the Java content tree be valid with respect to its original schema in order to marshal it back into XML data. Different JAXB Providers will support marshalling invalid Java content trees at varying levels, however all JAXB Providers must be able to marshal a valid content tree back to XML data. A JAXB Provider must throw a MarshalException when it is unable to complete the marshal operation due to invalid content. Some JAXB Providers will fully allow marshalling invalid content, others will fail on the first validation error.

Even when schema validation is not explictly enabled for the marshal operation, it is possible that certain types of validation events will be detected during the operation. Validation events will be reported to the registered event handler. If the client application has not registered an event handler prior to invoking one of the marshal API's, then events will be delivered to a default event handler which will terminate the marshal operation after encountering the first error or fatal error. Note that for JAXB 2.0 and later versions, DefaultValidationEventHandler is no longer used.

Supported Properties

All JAXB Providers are required to support the following set of properties. Some providers may support additional properties.

jaxb.encoding - value must be a java.lang.String
The output encoding to use when marshalling the XML data. The Marshaller will use "UTF-8" by default if this property is not specified.
jaxb.formatted.output - value must be a java.lang.Boolean
This property controls whether or not the Marshaller will format the resulting XML data with line breaks and indentation. A true value for this property indicates human readable indented xml data, while a false value indicates unformatted xml data. The Marshaller will default to false (unformatted) if this property is not specified.
jaxb.schemaLocation - value must be a java.lang.String
This property allows the client application to specify an xsi:schemaLocation attribute in the generated XML data. The format of the schemaLocation attribute value is discussed in an easy to understand, non-normative form in Section 5.6 of the W3C XML Schema Part 0: Primer and specified in Section 2.6 of the W3C XML Schema Part 1: Structures.
jaxb.noNamespaceSchemaLocation - value must be a java.lang.String
This property allows the client application to specify an xsi:noNamespaceSchemaLocation attribute in the generated XML data. The format of the schemaLocation attribute value is discussed in an easy to understand, non-normative form in Section 5.6 of the W3C XML Schema Part 0: Primer and specified in Section 2.6 of the W3C XML Schema Part 1: Structures.
jaxb.fragment - value must be a java.lang.Boolean
This property determines whether or not document level events will be generated by the Marshaller. If the property is not specified, the default is false. This property has different implications depending on which marshal api you are using - when this property is set to true:
  • marshal(Object,ContentHandler) - the Marshaller won't
             invoke ContentHandler.startDocument() and
             ContentHandler.endDocument().
  • marshal(Object,Node) - the property has no effect on this API.
  • marshal(Object,OutputStream) - the Marshaller won't generate an xml declaration.
  • marshal(Object,Writer) - the Marshaller won't generate an xml declaration.
  • marshal(Object,Result) - depends on the kind of Result object, see semantics for Node, ContentHandler, and Stream APIs
  • marshal(Object,XMLEventWriter) - the Marshaller will not generate XMLStreamConstants.START_DOCUMENT and XMLStreamConstants.END_DOCUMENT events.
  • marshal(Object,XMLStreamWriter) - the Marshaller will not generate XMLStreamConstants.START_DOCUMENT and XMLStreamConstants.END_DOCUMENT events.

Marshal Event Callbacks

"The Marshaller provides two styles of callback mechanisms that allow application specific processing during key points in the unmarshalling process. In 'class defined' event callbacks, application specific code placed in JAXB mapped classes is triggered during marshalling. 'External listeners' allow for centralized processing of marshal events in one callback method rather than by type event callbacks.

Class defined event callback methods allow any JAXB mapped class to specify its own specific callback methods by defining methods with the following method signatures:

   // Invoked by Marshaller after it has created an instance of this object.
   boolean beforeMarshal(Marshaller, Object parent);

   // Invoked by Marshaller after it has marshalled all properties of this object.
   void afterMmarshal(Marshaller, Object parent);
The class defined event callback methods should be used when the callback method requires access to non-public methods and/or fields of the class.

The external listener callback mechanism enables the registration of a Marshaller.Listener instance with a setListener(Listener). The external listener receives all callback events, allowing for more centralized processing than per class defined callback methods.

The 'class defined' and external listener event callback methods are independent of each other, both can be called for one event. The invocation ordering when both listener callback methods exist is defined in Marshaller.Listener.beforeMarshal(Object) and Marshaller.Listener.afterMarshal(Object).

An event callback method throwing an exception terminates the current marshal process.

Since:
JAXB1.0
Version:
$Revision: 1.19 $ $Date: 2006/03/08 16:54:42 $
Author:
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.
See Also:
JAXBContext, Validator, Unmarshaller

Nested Class Summary
static class Marshaller.Listener

Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.

Field Summary
static String | JAXB_ENCODING The name of the property used to specify the output encoding in the marshalled XML data.
static String | JAXB_FORMATTED_OUTPUT The name of the property used to specify whether or not the marshalled XML data is formatted with linefeeds and indentation.
static String | JAXB_FRAGMENT The name of the property used to specify whether or not the marshaller will generate document level events (ie calling startDocument or endDocument).
static String | JAXB_NO_NAMESPACE_SCHEMA_LOCATION The name of the property used to specify the xsi:noNamespaceSchemaLocation attribute value to place in the marshalled XML output.
static String | JAXB_SCHEMA_LOCATION The name of the property used to specify the xsi:schemaLocation attribute value to place in the marshalled XML output.
Method Summary
<A extends XmlAdapter>
A
getAdapter(Class<A> type)
Gets the adapter associated with the specified type.
 AttachmentMarshaller getAttachmentMarshaller()
 ValidationEventHandler getEventHandler()
Return the current event handler or the default event handler if one hasn't been set.
 Marshaller.Listener getListener()
Return Marshaller.Listener registered with this Marshaller.
 Node getNode(Object contentTree)
Get a DOM tree view of the content tree(Optional).
 Object getProperty(String name)
Get the particular property in the underlying implementation of Marshaller.
 Schema getSchema()
Get the JAXP 1.3 Schema object being used to perform marshal-time validation.
 void marshal(Object jaxbElement, ContentHandler handler)
Marshal the content tree rooted at jaxbElement into SAX2 events.
 void marshal(Object jaxbElement, Node node)
Marshal the content tree rooted at jaxbElement into a DOM tree.
 void marshal(Object jaxbElement, OutputStream os)
Marshal the content tree rooted at jaxbElement into an output stream.
 void marshal(Object jaxbElement, Result result)
Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.
 void marshal(Object jaxbElement, Writer writer)
Marshal the content tree rooted at jaxbElement into a Writer.
 void marshal(Object jaxbElement, XMLEventWriter writer)
Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
 void marshal(Object jaxbElement, XMLStreamWriter writer)
Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
<A extends XmlAdapter>
void
setAdapter(Class<A> type, A adapter)
Associates a configured instance of XmlAdapter with this marshaller.
 void setAdapter(XmlAdapter adapter)
Associates a configured instance of XmlAdapter with this marshaller.
 void setAttachmentMarshaller(AttachmentMarshaller am)
Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment.
 void setEventHandler(ValidationEventHandler handler)
Allow an application to register a validation event handler.
 void setListener(Marshaller.Listener listener)
Register marshal event callback Marshaller.Listener with this Marshaller.
 void setProperty(String name, Object value)
Set the particular property in the underlying implementation of Marshaller.
 void setSchema(Schema schema)
Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against.

Field Detail

JAXB_ENCODING

static final String JAXB_ENCODING
The name of the property used to specify the output encoding in the marshalled XML data.

See Also:
Constant Field Values

JAXB_FORMATTED_OUTPUT

static final String JAXB_FORMATTED_OUTPUT
The name of the property used to specify whether or not the marshalled XML data is formatted with linefeeds and indentation.

See Also:
Constant Field Values

JAXB_SCHEMA_LOCATION

static final String JAXB_SCHEMA_LOCATION
The name of the property used to specify the xsi:schemaLocation attribute value to place in the marshalled XML output.

See Also:
Constant Field Values

JAXB_NO_NAMESPACE_SCHEMA_LOCATION

static final String JAXB_NO_NAMESPACE_SCHEMA_LOCATION
The name of the property used to specify the xsi:noNamespaceSchemaLocation attribute value to place in the marshalled XML output.

See Also:
Constant Field Values

JAXB_FRAGMENT

static final String JAXB_FRAGMENT
The name of the property used to specify whether or not the marshaller will generate document level events (ie calling startDocument or endDocument).

See Also:
Constant Field Values
Method Detail

marshal

void marshal(Object jaxbElement,
             Result result)
             throws JAXBException
Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.

All JAXB Providers must at least support DOMResult, SAXResult, and StreamResult. It can support other derived classes of Result as well.

Parameters:
jaxbElement - The root of content tree to be marshalled.
result - XML will be sent to this Result
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
IllegalArgumentException - If any of the method parameters are null

marshal

void marshal(Object jaxbElement,
             OutputStream os)
             throws JAXBException
Marshal the content tree rooted at jaxbElement into an output stream.

Parameters:
jaxbElement - The root of content tree to be marshalled.
os - XML will be added to this stream.
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
IllegalArgumentException - If any of the method parameters are null

marshal

void marshal(Object jaxbElement,
             Writer writer)
             throws JAXBException
Marshal the content tree rooted at jaxbElement into a Writer.

Parameters:
jaxbElement - The root of content tree to be marshalled.
writer - XML will be sent to this writer.
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
IllegalArgumentException - If any of the method parameters are null

marshal

void marshal(Object jaxbElement,
             ContentHandler handler)
             throws JAXBException
Marshal the content tree rooted at jaxbElement into SAX2 events.

Parameters:
jaxbElement - The root of content tree to be marshalled.
handler - XML will be sent to this handler as SAX2 events.
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
IllegalArgumentException - If any of the method parameters are null

marshal

void marshal(Object jaxbElement,
             Node node)
             throws JAXBException
Marshal the content tree rooted at jaxbElement into a DOM tree.

Parameters:
jaxbElement - The content tree to be marshalled.
node - DOM nodes will be added as children of this node. This parameter must be a Node that accepts children (Document, DocumentFragment, or Element)
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal jaxbElement (or any object reachable from jaxbElement). See Marshalling a JAXB element.
IllegalArgumentException - If any of the method parameters are null

marshal

void marshal(Object jaxbElement,
             XMLStreamWriter writer)
             throws JAXBException
Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.

Parameters:
jaxbElement - The content tree to be marshalled.
writer - XML will be sent to this writer.
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
IllegalArgumentException - If any of the method parameters are null
Since:
JAXB 2.0

marshal

void marshal(Object jaxbElement,
             XMLEventWriter writer)
             throws JAXBException
Marshal the content tree rooted at jaxbElement into a XMLEventWriter.

Parameters:
jaxbElement - The content tree rooted at jaxbElement to be marshalled.
writer - XML will be sent to this writer.
Throws:
JAXBException - If any unexpected problem occurs during the marshalling.
MarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Marshaller is unable to marshal obj (or any object reachable from obj). See Marshalling a JAXB element.
IllegalArgumentException - If any of the method parameters are null
Since:
JAXB 2.0

getNode

Node getNode(Object contentTree)
             throws JAXBException
Get a DOM tree view of the content tree(Optional). If the returned DOM tree is updated, these changes are also visible in the content tree. Use marshal(Object, org.w3c.dom.Node) to force a deep copy of the content tree to a DOM representation.

Parameters:
contentTree - - JAXB Java representation of XML content
Returns:
the DOM tree view of the contentTree
Throws:
UnsupportedOperationException - If the JAXB provider implementation does not support a DOM view of the content tree
IllegalArgumentException - If any of the method parameters are null
JAXBException - If any unexpected problem occurs

setProperty

void setProperty(String name,
                 Object value)
                 throws PropertyException
Set the particular property in the underlying implementation of Marshaller. This method can only be used to set one of the standard JAXB defined properties above or a provider specific property. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Properties.

Parameters:
name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
value - the value of the property to be set
Throws:
PropertyException - when there is an error processing the given property or value
IllegalArgumentException - If the name parameter is null

getProperty

Object getProperty(String name)
                   throws PropertyException
Get the particular property in the underlying implementation of Marshaller. This method can only be used to get one of the standard JAXB defined properties above or a provider specific property. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Properties.

Parameters:
name - the name of the property to retrieve
Returns:
the value of the requested property
Throws:
PropertyException - when there is an error retrieving the given property or value property name
IllegalArgumentException - If the name parameter is null

setEventHandler

void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
Allow an application to register a validation event handler.

The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the marshal API's. If the client application does not register a validation event handler before invoking one of the marshal methods, then validation events will be handled by the default event handler which will terminate the marshal operation after the first error or fatal error is encountered.

Calling this method with a null parameter will cause the Marshaller to revert back to the default default event handler.

Parameters:
handler - the validation event handler
Throws:
JAXBException - if an error was encountered while setting the event handler

getEventHandler

ValidationEventHandler getEventHandler()
                                       throws JAXBException
Return the current event handler or the default event handler if one hasn't been set.

Returns:
the current ValidationEventHandler or the default event handler if it hasn't been set
Throws:
JAXBException - if an error was encountered while getting the current event handler

setAdapter

void setAdapter(XmlAdapter adapter)
Associates a configured instance of XmlAdapter with this marshaller.

This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

Throws:
IllegalArgumentException - if the adapter parameter is null.
UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
Since:
JAXB 2.0
See Also:
setAdapter(Class,XmlAdapter)

setAdapter

<A extends XmlAdapter> void setAdapter(Class<A> type,
                                       A adapter)
Associates a configured instance of XmlAdapter with this marshaller.

Every marshaller internally maintains a Map<Class,XmlAdapter>, which it uses for marshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, a marshaller will create one by invoking its default constructor.

Parameters:
type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.
Throws:
IllegalArgumentException - if the type parameter is null.
UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
Since:
JAXB 2.0

getAdapter

<A extends XmlAdapter> A getAdapter(Class<A> type)
Gets the adapter associated with the specified type. This is the reverse operation of the setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.

Throws:
IllegalArgumentException - if the type parameter is null.
UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
Since:
JAXB 2.0

setAttachmentMarshaller

void setAttachmentMarshaller(AttachmentMarshaller am)

Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment. The attachment is referenced from the XML document content model by content-id URIs(cid) references stored within the xml document.

Throws:
IllegalStateException - if attempt to concurrently call this method during a marshal operation.

getAttachmentMarshaller

AttachmentMarshaller getAttachmentMarshaller()

setSchema

void setSchema(Schema schema)
Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against. Passing null into this method will disable validation.

This method allows the caller to validate the marshalled XML as it's marshalled.

Initially this property is set to null.

Parameters:
schema - Schema object to validate marshal operations against or null to disable validation
Throws:
UnsupportedOperationException - could be thrown if this method is invoked on an Marshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
Since:
JAXB2.0

getSchema

Schema getSchema()
Get the JAXP 1.3 Schema object being used to perform marshal-time validation. If there is no Schema set on the marshaller, then this method will return null indicating that marshal-time validation will not be performed.

Returns:
the Schema object being used to perform marshal-time validation or null if not present.
Throws:
UnsupportedOperationException - could be thrown if this method is invoked on an Marshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
Since:
JAXB2.0

setListener

void setListener(Marshaller.Listener listener)

Register marshal event callback Marshaller.Listener with this Marshaller.

There is only one Listener per Marshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

Parameters:
listener - an instance of a class that implements Marshaller.Listener
Since:
JAXB2.0

getListener

Marshaller.Listener getListener()

Return Marshaller.Listener registered with this Marshaller.

Returns:
registered Marshaller.Listener or null if no Listener is registered with this Marshaller.
Since:
JAXB2.0
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Marshaller.Listener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class Marshaller.Listener

java.lang.Object
    extended by  javax.xml.bind.Marshaller.Listener
Enclosing interface:
Marshaller
public abstract static class Marshaller.Listener
extends Object

Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.

This class enables pre and post processing of each marshalled object. The event callbacks are called when marshalling from an instance that maps to an xml element or complex type definition. The event callbacks are not called when marshalling from an instance of a Java datatype that represents a simple type definition.

External listener is one of two different mechanisms for defining marshal event callbacks. See Marshal Event Callbacks for an overview.

Since:
JAXB2.0
See Also:
Marshaller.setListener(Listener), Marshaller.getListener()

Constructor Summary
Marshaller.Listener()
Method Summary
void | afterMarshal(Object source) Callback method invoked after marshalling source to XML.
void | beforeMarshal(Object source) Callback method invoked before marshalling from source to XML.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Marshaller.Listener

public Marshaller.Listener()
Method Detail

beforeMarshal

public void beforeMarshal(Object source)

Callback method invoked before marshalling from source to XML.

This method is invoked just before marshalling process starts to marshal source. Note that if the class of source defines its own beforeMarshal method, the class specific callback method is invoked just before this method is invoked.

Parameters:
source - instance of JAXB mapped class prior to marshalling from it.

afterMarshal

public void afterMarshal(Object source)

Callback method invoked after marshalling source to XML.

This method is invoked after source and all its descendants have been marshalled. Note that if the class of source defines its own afterMarshal method, the class specific callback method is invoked just before this method is invoked.

Parameters:
source - instance of JAXB mapped class after marshalling it.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PropertyException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class PropertyException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.bind.JAXBException
                extended by  javax.xml.bind.PropertyException
All Implemented Interfaces:
Serializable
public class PropertyException
extends JAXBException

This exception indicates that an error was encountered while getting or setting a property.

Since:
JAXB1.0
Version:
$Revision: 1.1 $ $Date: 2004/12/14 21:50:40 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.
See Also:
JAXBContext, Validator, Unmarshaller, Serialized Form

Constructor Summary
PropertyException(String message)
Construct a PropertyException with the specified detail message.
PropertyException(String name, Object value)
Construct a PropertyException whose message field is set based on the name of the property and value.toString().
PropertyException(String message, String errorCode)
Construct a PropertyException with the specified detail message and vendor specific errorCode.
PropertyException(String message, String errorCode, Throwable exception)
Construct a PropertyException with the specified detail message, vendor specific errorCode, and linkedException.
PropertyException(String message, Throwable exception)
Construct a PropertyException with the specified detail message and linkedException.
PropertyException(Throwable exception)
Construct a PropertyException with a linkedException.
Method Summary
Methods inherited from class javax.xml.bind.JAXBException
getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PropertyException

public PropertyException(String message)
Construct a PropertyException with the specified detail message. The errorCode and linkedException will default to null.

Parameters:
message - a description of the exception

PropertyException

public PropertyException(String message,
                         String errorCode)
Construct a PropertyException with the specified detail message and vendor specific errorCode. The linkedException will default to null.

Parameters:
message - a description of the exception
errorCode - a string specifying the vendor specific error code

PropertyException

public PropertyException(Throwable exception)
Construct a PropertyException with a linkedException. The detail message and vendor specific errorCode will default to null.

Parameters:
exception - the linked exception

PropertyException

public PropertyException(String message,
                         Throwable exception)
Construct a PropertyException with the specified detail message and linkedException. The errorCode will default to null.

Parameters:
message - a description of the exception
exception - the linked exception

PropertyException

public PropertyException(String message,
                         String errorCode,
                         Throwable exception)
Construct a PropertyException with the specified detail message, vendor specific errorCode, and linkedException.

Parameters:
message - a description of the exception
errorCode - a string specifying the vendor specific error code
exception - the linked exception

PropertyException

public PropertyException(String name,
                         Object value)
Construct a PropertyException whose message field is set based on the name of the property and value.toString().

Parameters:
name - the name of the property related to this exception
value - the value of the property related to this exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SchemaOutputResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class SchemaOutputResolver

java.lang.Object
    extended by  javax.xml.bind.SchemaOutputResolver

public abstract class SchemaOutputResolver
extends Object

Controls where a JAXB implementation puts the generates schema files.

An implementation of this abstract class has to be provided by the calling application to generate schemas.

This is a class, not an interface so as to allow future versions to evolve without breaking the compatibility.

Author:
Kohsuke Kawaguchi (kohsuke.kawaguchi@sun.com)

Constructor Summary
SchemaOutputResolver()
Method Summary
abstract  Result createOutput(String namespaceUri, String suggestedFileName)
Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SchemaOutputResolver

public SchemaOutputResolver()
Method Detail

createOutput

public abstract Result createOutput(String namespaceUri,
                                    String suggestedFileName)
                             throws IOException
Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.

This method is called only once for any given namespace. IOW, all the components in one namespace is always written into the same schema document.

Parameters:
namespaceUri - The namespace URI that the schema declares. Can be the empty string, but never be null.
suggestedFileName - A JAXB implementation generates an unique file name (like "schema1.xsd") for the convenience of the callee. This name can be used for the file name of the schema, or the callee can just ignore this name and come up with its own name. This is just a hint.
Returns:
a Result object that encapsulates the actual destination of the schema. If the Result object has a system ID, it must be an absolute system ID. Those system IDs are relativized by the caller and used for <xs:import> statements. If the Result object does not have a system ID, a schema for the namespace URI is generated but it won't be explicitly <xs:import>ed from other schemas. If null is returned, the schema generation for this namespace URI will be skipped.
Throws:
IOException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TypeConstraintException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class TypeConstraintException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.xml.bind.TypeConstraintException
All Implemented Interfaces:
Serializable
public class TypeConstraintException
extends RuntimeException

This exception indicates that a violation of a dynamically checked type constraint was detected.

This exception can be thrown by the generated setter methods of the schema derived Java content classes. However, since fail-fast validation is an optional feature for JAXB Providers to support, not all setter methods will throw this exception when a type constraint is violated.

If this exception is throw while invoking a fail-fast setter, the value of the property is guaranteed to remain unchanged, as if the setter were never called.

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.
See Also:
ValidationEvent, Serialized Form

Constructor Summary
TypeConstraintException(String message)
Construct a TypeConstraintException with the specified detail message.
TypeConstraintException(String message, String errorCode)
Construct a TypeConstraintException with the specified detail message and vendor specific errorCode.
TypeConstraintException(String message, String errorCode, Throwable exception)
Construct a TypeConstraintException with the specified detail message, vendor specific errorCode, and linkedException.
TypeConstraintException(String message, Throwable exception)
Construct a TypeConstraintException with the specified detail message and linkedException.
TypeConstraintException(Throwable exception)
Construct a TypeConstraintException with a linkedException.
Method Summary
String | getErrorCode() Get the vendor specific error code
Throwable | getLinkedException() Get the linked exception
void | printStackTrace() Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
void | printStackTrace(PrintStream s) Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
void | setLinkedException(Throwable exception) Add a linked Exception.
String | toString() Returns a short description of this TypeConstraintException.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TypeConstraintException

public TypeConstraintException(String message)
Construct a TypeConstraintException with the specified detail message. The errorCode and linkedException will default to null.

Parameters:
message - a description of the exception

TypeConstraintException

public TypeConstraintException(String message,
                               String errorCode)
Construct a TypeConstraintException with the specified detail message and vendor specific errorCode. The linkedException will default to null.

Parameters:
message - a description of the exception
errorCode - a string specifying the vendor specific error code

TypeConstraintException

public TypeConstraintException(Throwable exception)
Construct a TypeConstraintException with a linkedException. The detail message and vendor specific errorCode will default to null.

Parameters:
exception - the linked exception

TypeConstraintException

public TypeConstraintException(String message,
                               Throwable exception)
Construct a TypeConstraintException with the specified detail message and linkedException. The errorCode will default to null.

Parameters:
message - a description of the exception
exception - the linked exception

TypeConstraintException

public TypeConstraintException(String message,
                               String errorCode,
                               Throwable exception)
Construct a TypeConstraintException with the specified detail message, vendor specific errorCode, and linkedException.

Parameters:
message - a description of the exception
errorCode - a string specifying the vendor specific error code
exception - the linked exception
Method Detail

getErrorCode

public String getErrorCode()
Get the vendor specific error code

Returns:
a string specifying the vendor specific error code

getLinkedException

public Throwable getLinkedException()
Get the linked exception

Returns:
the linked Exception, null if none exists

setLinkedException

public void setLinkedException(Throwable exception)
Add a linked Exception.

Parameters:
exception - the linked Exception (A null value is permitted and indicates that the linked exception does not exist or is unknown).

toString

public String toString()
Returns a short description of this TypeConstraintException.

Overrides:
toString in class Throwable

printStackTrace

public void printStackTrace(PrintStream s)
Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.

Overrides:
printStackTrace in class Throwable
Parameters:
s - PrintStream to use for output

printStackTrace

public void printStackTrace()
Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.

Overrides:
printStackTrace in class Throwable
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UnmarshalException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class UnmarshalException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.bind.JAXBException
                extended by  javax.xml.bind.UnmarshalException
All Implemented Interfaces:
Serializable
public class UnmarshalException
extends JAXBException

This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.

The ValidationEventHandler can cause this exception to be thrown during the unmarshal operations. See ValidationEventHandler.handleEvent(ValidationEvent).

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
See Also:
JAXBException, Unmarshaller, ValidationEventHandler, Serialized Form

Constructor Summary
UnmarshalException(String message)
Construct an UnmarshalException with the specified detail message.
UnmarshalException(String message, String errorCode)
Construct an UnmarshalException with the specified detail message and vendor specific errorCode.
UnmarshalException(String message, String errorCode, Throwable exception)
Construct an UnmarshalException with the specified detail message, vendor specific errorCode, and linkedException.
UnmarshalException(String message, Throwable exception)
Construct an UnmarshalException with the specified detail message and linkedException.
UnmarshalException(Throwable exception)
Construct an UnmarshalException with a linkedException.
Method Summary
Methods inherited from class javax.xml.bind.JAXBException
getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnmarshalException

public UnmarshalException(String message)
Construct an UnmarshalException with the specified detail message. The errorCode and linkedException will default to null.

Parameters:
message - a description of the exception

UnmarshalException

public UnmarshalException(String message,
                          String errorCode)
Construct an UnmarshalException with the specified detail message and vendor specific errorCode. The linkedException will default to null.

Parameters:
message - a description of the exception
errorCode - a string specifying the vendor specific error code

UnmarshalException

public UnmarshalException(Throwable exception)
Construct an UnmarshalException with a linkedException. The detail message and vendor specific errorCode will default to null.

Parameters:
exception - the linked exception

UnmarshalException

public UnmarshalException(String message,
                          Throwable exception)
Construct an UnmarshalException with the specified detail message and linkedException. The errorCode will default to null.

Parameters:
message - a description of the exception
exception - the linked exception

UnmarshalException

public UnmarshalException(String message,
                          String errorCode,
                          Throwable exception)
Construct an UnmarshalException with the specified detail message, vendor specific errorCode, and linkedException.

Parameters:
message - a description of the exception
errorCode - a string specifying the vendor specific error code
exception - the linked exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Unmarshaller

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Interface Unmarshaller

All Known Implementing Classes:
AbstractUnmarshallerImpl
public interface Unmarshaller

The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled. It provides an overloading of unmarshal methods for many different input kinds.

Unmarshalling from a File:

       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       Object o = u.unmarshal( new File( "nosferatu.xml" ) );

Unmarshalling from an InputStream:

       InputStream is = new FileInputStream( "nosferatu.xml" );
       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       Object o = u.unmarshal( is );

Unmarshalling from a URL:

       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       URL url = new URL( "http://beaker.east/nosferatu.xml" );
       Object o = u.unmarshal( url );

Unmarshalling from a StringBuffer using a javax.xml.transform.stream.StreamSource:

       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       StringBuffer xmlStr = new StringBuffer( "<?xml version="1.0"?>..." );
       Object o = u.unmarshal( new StreamSource( new StringReader( xmlStr.toString() ) ) );

Unmarshalling from a org.w3c.dom.Node:

       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
       dbf.setNamespaceAware(true);
       DocumentBuilder db = dbf.newDocumentBuilder();
       Document doc = db.parse(new File( "nosferatu.xml"));

       Object o = u.unmarshal( doc );

Unmarshalling from a javax.xml.transform.sax.SAXSource using a client specified validating SAX2.0 parser:

       // configure a validating SAX2.0 parser (Xerces2)
       static final String JAXP_SCHEMA_LANGUAGE =
           "http://java.sun.com/xml/jaxp/properties/schemaLanguage";
       static final String JAXP_SCHEMA_LOCATION =
           "http://java.sun.com/xml/jaxp/properties/schemaSource";
       static final String W3C_XML_SCHEMA =
           "http://www.w3.org/2001/XMLSchema";

       System.setProperty( "javax.xml.parsers.SAXParserFactory",
                           "org.apache.xerces.jaxp.SAXParserFactoryImpl" );

       SAXParserFactory spf = SAXParserFactory.newInstance();
       spf.setNamespaceAware(true);
       spf.setValidating(true);
       SAXParser saxParser = spf.newSAXParser();

       try {
           saxParser.setProperty(JAXP_SCHEMA_LANGUAGE, W3C_XML_SCHEMA);
           saxParser.setProperty(JAXP_SCHEMA_LOCATION, "http://....");
       } catch (SAXNotRecognizedException x) {
           // exception handling omitted
       }

       XMLReader xmlReader = saxParser.getXMLReader();
       SAXSource source =
           new SAXSource( xmlReader, new InputSource( "http://..." ) );

       // Setup JAXB to unmarshal
       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();
       ValidationEventCollector vec = new ValidationEventCollector();
       u.setEventHandler( vec );

       // turn off the JAXB provider's default validation mechanism to
       // avoid duplicate validation
       u.setValidating( false )

       // unmarshal
       Object o = u.unmarshal( source );

       // check for events
       if( vec.hasEvents() ) {
          // iterate over events
       }

Unmarshalling from a StAX XMLStreamReader:

       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       javax.xml.stream.XMLStreamReader xmlStreamReader =
           javax.xml.stream.XMLInputFactory().newInstance().createXMLStreamReader( ... );

       Object o = u.unmarshal( xmlStreamReader );

Unmarshalling from a StAX XMLEventReader:

       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       javax.xml.stream.XMLEventReader xmlEventReader =
           javax.xml.stream.XMLInputFactory().newInstance().createXMLEventReader( ... );

       Object o = u.unmarshal( xmlEventReader );

Unmarshalling XML Data

Unmarshalling can deserialize XML data that represents either an entire XML document or a subtree of an XML document. Typically, it is sufficient to use the unmarshalling methods described by Unmarshal root element that is declared globally. These unmarshal methods utilize JAXBContext's mapping of global XML element declarations and type definitions to JAXB mapped classes to initiate the unmarshalling of the root element of XML data. When the JAXBContext's mappings are not sufficient to unmarshal the root element of XML data, the application can assist the unmarshalling process by using the unmarshal by declaredType methods. These methods are useful for unmarshalling XML data where the root element corresponds to a local element declaration in the schema.
An unmarshal method never returns null. If the unmarshal process is unable to unmarshal the root of XML content to a JAXB mapped object, a fatal error is reported that terminates processing by throwing JAXBException.

Unmarshal a root element that is globally declared

The unmarshal methods that do not have an declaredType parameter use JAXBContext to unmarshal the root element of an XML data. The JAXBContext instance is the one that was used to create this Unmarshaller. The JAXBContext instance maintains a mapping of globally declared XML element and type definition names to JAXB mapped classes. The unmarshal method checks if JAXBContext has a mapping from the root element's XML name and/or @xsi:type to a JAXB mapped class. If it does, it umarshalls the XML data using the appropriate JAXB mapped class. Note that when the root element name is unknown and the root element has an @xsi:type, the XML data is unmarshalled using that JAXB mapped class as the value of a JAXBElement. When the JAXBContext object does not have a mapping for the root element's name nor its @xsi:type, if it exists, then the unmarshal operation will abort immediately by throwing a UnmarshalException. This exception scenario can be worked around by using the unmarshal by declaredType methods described in the next subsection.

Unmarshal by Declared Type

The unmarshal methods with a declaredType parameter enable an application to deserialize a root element of XML data, even when there is no mapping in JAXBContext of the root element's XML name. The unmarshaller unmarshals the root element using the application provided mapping specified as the declaredType parameter. Note that even when the root element's element name is mapped by JAXBContext, the declaredType parameter overrides that mapping for deserializing the root element when using these unmarshal methods. Additionally, when the root element of XML data has an xsi:type attribute and that attribute's value references a type definition that is mapped to a JAXB mapped class by JAXBContext, that the root element's xsi:type attribute takes precedence over the unmarshal methods declaredType parameter. These methods always return a JAXBElement<declaredType> instance. The table below shows how the properties of the returned JAXBElement instance are set.

Unmarshal By Declared Type returned JAXBElement
JAXBElement Property | Value
name | xml element name
value | instanceof declaredType
declaredType | unmarshal method declaredType parameter
scope | null (actual scope is unknown)

The following is an example of unmarshal by declaredType method.

Unmarshal by declaredType from a org.w3c.dom.Node:

       Schema fragment for example
       <xs:schema>
          <xs:complexType name="FooType">...<\xs:complexType>
          <!-- global element declaration "PurchaseOrder" -->
          <xs:element name="PurchaseOrder">
              <xs:complexType>
                 <xs:sequence>
                    <!-- local element declaration "foo" -->
                    <xs:element name="foo" type="FooType"/>
                    ...
                 </xs:sequence>
              </xs:complexType>
          </xs:element>
       </xs:schema>

       JAXBContext jc = JAXBContext.newInstance( "com.acme.foo" );
       Unmarshaller u = jc.createUnmarshaller();

       DocumentBuilderFactory dbf = DocumentBuilderFactory.newInstance();
       dbf.setNamespaceAware(true);
       DocumentBuilder db = dbf.newDocumentBuilder();
       Document doc = db.parse(new File( "nosferatu.xml"));
       Element  fooSubtree = ...; // traverse DOM till reach xml element foo, constrained by a
                                  // local element declaration in schema.

       // FooType is the JAXB mapping of the type of local element declaration foo.
       JAXBElement<FooType> foo = u.unmarshal( fooSubtree, FooType.class);

Support for SAX2.0 Compliant Parsers

A client application has the ability to select the SAX2.0 compliant parser of their choice. If a SAX parser is not selected, then the JAXB Provider's default parser will be used. Even though the JAXB Provider's default parser is not required to be SAX2.0 compliant, all providers are required to allow a client application to specify their own SAX2.0 parser. Some providers may require the client application to specify the SAX2.0 parser at schema compile time. See unmarshal(Source) for more detail.

Validation and Well-Formedness

A client application can enable or disable JAXP 1.3 validation mechanism via the setSchema(javax.xml.validation.Schema) API. Sophisticated clients can specify their own validating SAX 2.0 compliant parser and bypass the JAXP 1.3 validation mechanism using the unmarshal(Source) API.

Since unmarshalling invalid XML content is defined in JAXB 2.0, the Unmarshaller default validation event handler was made more lenient than in JAXB 1.0. When schema-derived code generated by JAXB 1.0 binding compiler is registered with JAXBContext, the default unmarshal validation handler is DefaultValidationEventHandler and it terminates the marshal operation after encountering either a fatal error or an error. For a JAXB 2.0 client application, there is no explicitly defined default validation handler and the default event handling only terminates the marshal operation after encountering a fatal error.

Supported Properties

There currently are not any properties required to be supported by all JAXB Providers on Unmarshaller. However, some providers may support their own set of provider specific properties.

Unmarshal Event Callbacks

The Unmarshaller provides two styles of callback mechanisms that allow application specific processing during key points in the unmarshalling process. In 'class defined' event callbacks, application specific code placed in JAXB mapped classes is triggered during unmarshalling. 'External listeners' allow for centralized processing of unmarshal events in one callback method rather than by type event callbacks.

'Class defined' event callback methods allow any JAXB mapped class to specify its own specific callback methods by defining methods with the following method signature:

   // This method is called immediately after the object is created and before the unmarshalling of this
   // object begins. The callback provides an opportunity to initialize JavaBean properties prior to unmarshalling.
   void beforeUnmarshal(Unmarshaller, Object parent);

   //This method is called after all the properties (except IDREF) are unmarshalled for this object,
   //but before this object is set to the parent object.
   void afterUnmarshal(Unmarshaller, Object parent);
The class defined callback methods should be used when the callback method requires access to non-public methods and/or fields of the class.

The external listener callback mechanism enables the registration of a Unmarshaller.Listener instance with an setListener(Listener). The external listener receives all callback events, allowing for more centralized processing than per class defined callback methods. The external listener receives events when unmarshalling proces is marshalling to a JAXB element or to JAXB mapped class.

The 'class defined' and external listener event callback methods are independent of each other, both can be called for one event. The invocation ordering when both listener callback methods exist is defined in Unmarshaller.Listener.beforeUnmarshal(Object, Object) and Unmarshaller.Listener.afterUnmarshal(Object, Object).

An event callback method throwing an exception terminates the current unmarshal process.

Since:
JAXB1.0
Version:
$Revision: 1.32 $ $Date: 2005/08/18 15:18:26 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.
See Also:
JAXBContext, Marshaller, Validator

Nested Class Summary
static class Unmarshaller.Listener

Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.

Method Summary
<A extends XmlAdapter>
A
getAdapter(Class<A> type)
Gets the adapter associated with the specified type.
 AttachmentUnmarshaller getAttachmentUnmarshaller()
 ValidationEventHandler getEventHandler()
Return the current event handler or the default event handler if one hasn't been set.
 Unmarshaller.Listener getListener()
Return Unmarshaller.Listener registered with this Unmarshaller.
 Object getProperty(String name)
Get the particular property in the underlying implementation of Unmarshaller.
 Schema getSchema()
Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.
 UnmarshallerHandler getUnmarshallerHandler()
Get an unmarshaller handler object that can be used as a component in an XML pipeline.
 boolean isValidating()
Deprecated. since JAXB2.0, please see getSchema()
<A extends XmlAdapter>
void
setAdapter(Class<A> type, A adapter)
Associates a configured instance of XmlAdapter with this unmarshaller.
 void setAdapter(XmlAdapter adapter)
Associates a configured instance of XmlAdapter with this unmarshaller.
 void setAttachmentUnmarshaller(AttachmentUnmarshaller au)
Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.
 void setEventHandler(ValidationEventHandler handler)
Allow an application to register a ValidationEventHandler.
 void setListener(Unmarshaller.Listener listener)
Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.
 void setProperty(String name, Object value)
Set the particular property in the underlying implementation of Unmarshaller.
 void setSchema(Schema schema)
Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against.
 void setValidating(boolean validating)
Deprecated. since JAXB2.0, please see setSchema(javax.xml.validation.Schema)
 Object unmarshal(File f)
Unmarshal XML data from the specified file and return the resulting content tree.
 Object unmarshal(InputSource source)
Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.
 Object unmarshal(InputStream is)
Unmarshal XML data from the specified InputStream and return the resulting content tree.
 Object unmarshal(Node node)
Unmarshal global XML data from the specified DOM tree and return the resulting content tree.
<T> JAXBElement<T>
unmarshal(Node node, Class<T> declaredType)
Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
 Object unmarshal(Reader reader)
Unmarshal XML data from the specified Reader and return the resulting content tree.
 Object unmarshal(Source source)
Unmarshal XML data from the specified XML Source and return the resulting content tree.
<T> JAXBElement<T>
unmarshal(Source source, Class<T> declaredType)
Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
 Object unmarshal(URL url)
Unmarshal XML data from the specified URL and return the resulting content tree.
 Object unmarshal(XMLEventReader reader)
Unmarshal XML data from the specified pull parser and return the resulting content tree.
<T> JAXBElement<T>
unmarshal(XMLEventReader reader, Class<T> declaredType)
Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
 Object unmarshal(XMLStreamReader reader)
Unmarshal XML data from the specified pull parser and return the resulting content tree.
<T> JAXBElement<T>
unmarshal(XMLStreamReader reader, Class<T> declaredType)
Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

Method Detail

unmarshal

Object unmarshal(File f)
                 throws JAXBException
Unmarshal XML data from the specified file and return the resulting content tree.

Implements Unmarshal Global Root Element.

Parameters:
f - the file to unmarshal XML data from
Returns:
the newly created root object of the java content tree
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
IllegalArgumentException - If the file parameter is null

unmarshal

Object unmarshal(InputStream is)
                 throws JAXBException
Unmarshal XML data from the specified InputStream and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API.

Implements Unmarshal Global Root Element.

Parameters:
is - the InputStream to unmarshal XML data from
Returns:
the newly created root object of the java content tree
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
IllegalArgumentException - If the InputStream parameter is null

unmarshal

Object unmarshal(Reader reader)
                 throws JAXBException
Unmarshal XML data from the specified Reader and return the resulting content tree. Validation event location information may be incomplete when using this form of the unmarshal API, because a Reader does not provide the system ID.

Implements Unmarshal Global Root Element.

Parameters:
reader - the Reader to unmarshal XML data from
Returns:
the newly created root object of the java content tree
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
IllegalArgumentException - If the InputStream parameter is null
Since:
JAXB2.0

unmarshal

Object unmarshal(URL url)
                 throws JAXBException
Unmarshal XML data from the specified URL and return the resulting content tree.

Implements Unmarshal Global Root Element.

Parameters:
url - the url to unmarshal XML data from
Returns:
the newly created root object of the java content tree
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
IllegalArgumentException - If the URL parameter is null

unmarshal

Object unmarshal(InputSource source)
                 throws JAXBException
Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.

Implements Unmarshal Global Root Element.

Parameters:
source - the input source to unmarshal XML data from
Returns:
the newly created root object of the java content tree
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
IllegalArgumentException - If the InputSource parameter is null

unmarshal

Object unmarshal(Node node)
                 throws JAXBException
Unmarshal global XML data from the specified DOM tree and return the resulting content tree.

Implements Unmarshal Global Root Element.

Parameters:
node - the document/element to unmarshal XML data from. The caller must support at least Document and Element.
Returns:
the newly created root object of the java content tree
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
IllegalArgumentException - If the Node parameter is null
See Also:
unmarshal(org.w3c.dom.Node, Class)

unmarshal

<T> JAXBElement<T> unmarshal(Node node,
                             Class<T> declaredType)
                         throws JAXBException
Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.

Implements Unmarshal by Declared Type

Parameters:
node - the document/element to unmarshal XML data from. The caller must support at least Document and Element.
declaredType - appropriate JAXB mapped class to hold node's XML data.
Returns:
JAXB Element representation of node
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
IllegalArgumentException - If any parameter is null
Since:
JAXB2.0

unmarshal

Object unmarshal(Source source)
                 throws JAXBException
Unmarshal XML data from the specified XML Source and return the resulting content tree.

Implements Unmarshal Global Root Element.

SAX 2.0 Parser Pluggability

A client application can choose not to use the default parser mechanism supplied with their JAXB provider. Any SAX 2.0 compliant parser can be substituted for the JAXB provider's default mechanism. To do so, the client application must properly configure a SAXSource containing an XMLReader implemented by the SAX 2.0 parser provider. If the XMLReader has an org.xml.sax.ErrorHandler registered on it, it will be replaced by the JAXB Provider so that validation errors can be reported via the ValidationEventHandler mechanism of JAXB. If the SAXSource does not contain an XMLReader, then the JAXB provider's default parser mechanism will be used.

This parser replacement mechanism can also be used to replace the JAXB provider's unmarshal-time validation engine. The client application must properly configure their SAX 2.0 compliant parser to perform validation (as shown in the example above). Any SAXParserExceptions encountered by the parser during the unmarshal operation will be processed by the JAXB provider and converted into JAXB ValidationEvent objects which will be reported back to the client via the ValidationEventHandler registered with the Unmarshaller. Note: specifying a substitute validating SAX 2.0 parser for unmarshalling does not necessarily replace the validation engine used by the JAXB provider for performing on-demand validation.

The only way for a client application to specify an alternate parser mechanism to be used during unmarshal is via the unmarshal(SAXSource) API. All other forms of the unmarshal method (File, URL, Node, etc) will use the JAXB provider's default parser and validator mechanisms.

Parameters:
source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
Returns:
the newly created root object of the java content tree
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
IllegalArgumentException - If the Source parameter is null
See Also:
unmarshal(javax.xml.transform.Source, Class)

unmarshal

<T> JAXBElement<T> unmarshal(Source source,
                             Class<T> declaredType)
                         throws JAXBException
Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.

Implements Unmarshal by Declared Type

See SAX 2.0 Parser Pluggability

Parameters:
source - the XML Source to unmarshal XML data from (providers are only required to support SAXSource, DOMSource, and StreamSource)
declaredType - appropriate JAXB mapped class to hold source's xml root element
Returns:
Java content rooted by JAXB Element
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
IllegalArgumentException - If any parameter is null
Since:
JAXB2.0

unmarshal

Object unmarshal(XMLStreamReader reader)
                 throws JAXBException
Unmarshal XML data from the specified pull parser and return the resulting content tree.

Implements Unmarshal Global Root Element.

This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

Parameters:
reader - The parser to be read.
Returns:
the newly created root object of the java content tree.
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
IllegalArgumentException - If the reader parameter is null
IllegalStateException - If reader is not pointing to a START_DOCUMENT or START_ELEMENT event.
Since:
JAXB2.0
See Also:
unmarshal(javax.xml.stream.XMLStreamReader, Class)

unmarshal

<T> JAXBElement<T> unmarshal(XMLStreamReader reader,
                             Class<T> declaredType)
                         throws JAXBException
Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

This method implements unmarshal by declaredType.

This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

Parameters:
reader - The parser to be read.
declaredType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
Returns:
content tree rooted by JAXB Element representation
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
IllegalArgumentException - If any parameter is null
Since:
JAXB2.0

unmarshal

Object unmarshal(XMLEventReader reader)
                 throws JAXBException
Unmarshal XML data from the specified pull parser and return the resulting content tree.

This method is an Unmarshal Global Root method.

This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

Parameters:
reader - The parser to be read.
Returns:
the newly created root object of the java content tree.
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
IllegalArgumentException - If the reader parameter is null
IllegalStateException - If reader is not pointing to a START_DOCUMENT or START_ELEMENT event.
Since:
JAXB2.0
See Also:
unmarshal(javax.xml.stream.XMLEventReader, Class)

unmarshal

<T> JAXBElement<T> unmarshal(XMLEventReader reader,
                             Class<T> declaredType)
                         throws JAXBException
Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.

This method implements unmarshal by declaredType.

This method assumes that the parser is on a START_DOCUMENT or START_ELEMENT event. Unmarshalling will be done from this start event to the corresponding end event. If this method returns successfully, the reader will be pointing at the token right after the end event.

Parameters:
reader - The parser to be read.
declaredType - appropriate JAXB mapped class to hold reader's START_ELEMENT XML data.
Returns:
content tree rooted by JAXB Element representation
Throws:
JAXBException - If any unexpected errors occur while unmarshalling
UnmarshalException - If the ValidationEventHandler returns false from its handleEvent method or the Unmarshaller is unable to perform the XML to Java binding. See Unmarshalling XML Data
IllegalArgumentException - If any parameter is null
Since:
JAXB2.0

getUnmarshallerHandler

UnmarshallerHandler getUnmarshallerHandler()
Get an unmarshaller handler object that can be used as a component in an XML pipeline.

The JAXB Provider can return the same handler object for multiple invocations of this method. In other words, this method does not necessarily create a new instance of UnmarshallerHandler. If the application needs to use more than one UnmarshallerHandler, it should create more than one Unmarshaller.

Returns:
the unmarshaller handler object
See Also:
UnmarshallerHandler

setValidating

void setValidating(boolean validating)
                   throws JAXBException
Deprecated. since JAXB2.0, please see setSchema(javax.xml.validation.Schema)

Specifies whether or not the default validation mechanism of the Unmarshaller should validate during unmarshal operations. By default, the Unmarshaller does not validate.

This method may only be invoked before or after calling one of the unmarshal methods.

This method only controls the JAXB Provider's default unmarshal-time validation mechanism - it has no impact on clients that specify their own validating SAX 2.0 compliant parser. Clients that specify their own unmarshal-time validation mechanism may wish to turn off the JAXB Provider's default validation mechanism via this API to avoid "double validation".

This method is deprecated as of JAXB 2.0 - please use the new setSchema(javax.xml.validation.Schema) API.

Parameters:
validating - true if the Unmarshaller should validate during unmarshal, false otherwise
Throws:
JAXBException - if an error occurred while enabling or disabling validation at unmarshal time
UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 2.0 mapped classes

isValidating

boolean isValidating()
                     throws JAXBException
Deprecated. since JAXB2.0, please see getSchema()

Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.

This API returns the state of the JAXB Provider's default unmarshal-time validation mechanism.

This method is deprecated as of JAXB 2.0 - please use the new getSchema() API.

Returns:
true if the Unmarshaller is configured to validate during unmarshal operations, false otherwise
Throws:
JAXBException - if an error occurs while retrieving the validating flag
UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 2.0 mapped classes

setEventHandler

void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
Allow an application to register a ValidationEventHandler.

The ValidationEventHandler will be called by the JAXB Provider if any validation errors are encountered during calls to any of the unmarshal methods. If the client application does not register a ValidationEventHandler before invoking the unmarshal methods, then ValidationEvents will be handled by the default event handler which will terminate the unmarshal operation after the first error or fatal error is encountered.

Calling this method with a null parameter will cause the Unmarshaller to revert back to the default event handler.

Parameters:
handler - the validation event handler
Throws:
JAXBException - if an error was encountered while setting the event handler

getEventHandler

ValidationEventHandler getEventHandler()
                                       throws JAXBException
Return the current event handler or the default event handler if one hasn't been set.

Returns:
the current ValidationEventHandler or the default event handler if it hasn't been set
Throws:
JAXBException - if an error was encountered while getting the current event handler

setProperty

void setProperty(String name,
                 Object value)
                 throws PropertyException
Set the particular property in the underlying implementation of Unmarshaller. This method can only be used to set one of the standard JAXB defined properties above or a provider specific property. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Properties.

Parameters:
name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
value - the value of the property to be set
Throws:
PropertyException - when there is an error processing the given property or value
IllegalArgumentException - If the name parameter is null

getProperty

Object getProperty(String name)
                   throws PropertyException
Get the particular property in the underlying implementation of Unmarshaller. This method can only be used to get one of the standard JAXB defined properties above or a provider specific property. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Properties.

Parameters:
name - the name of the property to retrieve
Returns:
the value of the requested property
Throws:
PropertyException - when there is an error retrieving the given property or value property name
IllegalArgumentException - If the name parameter is null

setSchema

void setSchema(Schema schema)
Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against. Passing null into this method will disable validation.

This method replaces the deprecated setValidating(boolean) API.

Initially this property is set to null.

Parameters:
schema - Schema object to validate unmarshal operations against or null to disable validation
Throws:
UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
Since:
JAXB2.0

getSchema

Schema getSchema()
Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation. If there is no Schema set on the unmarshaller, then this method will return null indicating that unmarshal-time validation will not be performed.

This method provides replacement functionality for the deprecated isValidating() API as well as access to the Schema object. To determine if the Unmarshaller has validation enabled, simply test the return type for null:

boolean isValidating = u.getSchema()!=null;

Returns:
the Schema object being used to perform unmarshal-time validation or null if not present
Throws:
UnsupportedOperationException - could be thrown if this method is invoked on an Unmarshaller created from a JAXBContext referencing JAXB 1.0 mapped classes
Since:
JAXB2.0

setAdapter

void setAdapter(XmlAdapter adapter)
Associates a configured instance of XmlAdapter with this unmarshaller.

This is a convenience method that invokes setAdapter(adapter.getClass(),adapter);.

Throws:
IllegalArgumentException - if the adapter parameter is null.
UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
Since:
JAXB2.0
See Also:
setAdapter(Class,XmlAdapter)

setAdapter

<A extends XmlAdapter> void setAdapter(Class<A> type,
                                       A adapter)
Associates a configured instance of XmlAdapter with this unmarshaller.

Every unmarshaller internally maintains a Map<Class,XmlAdapter>, which it uses for unmarshalling classes whose fields/methods are annotated with XmlJavaTypeAdapter.

This method allows applications to use a configured instance of XmlAdapter. When an instance of an adapter is not given, an unmarshaller will create one by invoking its default constructor.

Parameters:
type - The type of the adapter. The specified instance will be used when XmlJavaTypeAdapter.value() refers to this type.
adapter - The instance of the adapter to be used. If null, it will un-register the current adapter set for this type.
Throws:
IllegalArgumentException - if the type parameter is null.
UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
Since:
JAXB2.0

getAdapter

<A extends XmlAdapter> A getAdapter(Class<A> type)
Gets the adapter associated with the specified type. This is the reverse operation of the setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter) method.

Throws:
IllegalArgumentException - if the type parameter is null.
UnsupportedOperationException - if invoked agains a JAXB 1.0 implementation.
Since:
JAXB2.0

setAttachmentUnmarshaller

void setAttachmentUnmarshaller(AttachmentUnmarshaller au)

Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.

Unmarshal time validation, enabled via setSchema(Schema), must be supported even when unmarshaller is performing XOP processing.

Throws:
IllegalStateException - if attempt to concurrently call this method during a unmarshal operation.

getAttachmentUnmarshaller

AttachmentUnmarshaller getAttachmentUnmarshaller()

setListener

void setListener(Unmarshaller.Listener listener)

Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.

There is only one Listener per Unmarshaller. Setting a Listener replaces the previous set Listener. One can unregister current Listener by setting listener to null.

Parameters:
listener - provides unmarshal event callbacks for this Unmarshaller
Since:
JAXB2.0

getListener

Unmarshaller.Listener getListener()

Return Unmarshaller.Listener registered with this Unmarshaller.

Returns:
registered Unmarshaller.Listener or null if no Listener is registered with this Unmarshaller.
Since:
JAXB2.0
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Unmarshaller.Listener

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class Unmarshaller.Listener

java.lang.Object
    extended by  javax.xml.bind.Unmarshaller.Listener
Enclosing interface:
Unmarshaller
public abstract static class Unmarshaller.Listener
extends Object

Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.

This class enables pre and post processing of an instance of a JAXB mapped class as XML data is unmarshalled into it. The event callbacks are called when unmarshalling XML content into a JAXBElement instance or a JAXB mapped class that represents a complex type definition. The event callbacks are not called when unmarshalling to an instance of a Java datatype that represents a simple type definition.

External listener is one of two different mechanisms for defining unmarshal event callbacks. See Unmarshal Event Callbacks for an overview.

(@link #setListener(Listener)} (@link #getListener()}

Since:
JAXB2.0

Constructor Summary
Unmarshaller.Listener()
Method Summary
void | afterUnmarshal(Object target, Object parent) Callback method invoked after unmarshalling XML data into target.
void | beforeUnmarshal(Object target, Object parent) Callback method invoked before unmarshalling into target.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Unmarshaller.Listener

public Unmarshaller.Listener()
Method Detail

beforeUnmarshal

public void beforeUnmarshal(Object target,
                            Object parent)

Callback method invoked before unmarshalling into target.

This method is invoked immediately after target was created and before the unmarshalling of this object begins. Note that if the class of target defines its own beforeUnmarshal method, the class specific callback method is invoked before this method is invoked.

Parameters:
target - non-null instance of JAXB mapped class prior to unmarshalling into it.
parent - instance of JAXB mapped class that will eventually reference target. null when target is root element.

afterUnmarshal

public void afterUnmarshal(Object target,
                           Object parent)

Callback method invoked after unmarshalling XML data into target.

This method is invoked after all the properties (except IDREF) are unmarshalled into target, but before target is set into its parent object. Note that if the class of target defines its own afterUnmarshal method, the class specific callback method is invoked before this method is invoked.

Parameters:
target - non-null instance of JAXB mapped class prior to unmarshalling into it.
parent - instance of JAXB mapped class that will reference target. null when target is root element.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UnmarshallerHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Interface UnmarshallerHandler

All Superinterfaces:
ContentHandler
public interface UnmarshallerHandler
extends ContentHandler

Unmarshaller implemented as SAX ContentHandler.

Applications can use this interface to use their JAXB provider as a component in an XML pipeline. For example:

       JAXBContext context = JAXBContext.newInstance( "org.acme.foo" );

       Unmarshaller unmarshaller = context.createUnmarshaller();

       UnmarshallerHandler unmarshallerHandler = unmarshaller.getUnmarshallerHandler();

       SAXParserFactory spf = SAXParserFactory.newInstance();
       spf.setNamespaceAware( true );

       XMLReader xmlReader = spf.newSAXParser().getXMLReader();
       xmlReader.setContentHandler( unmarshallerHandler );
       xmlReader.parse(new InputSource( new FileInputStream( XML_FILE ) ) );

       MyObject myObject= (MyObject)unmarshallerHandler.getResult();

This interface is reusable: even if the user fails to unmarshal an object, s/he can still start a new round of unmarshalling.

Since:
JAXB1.0
Version:
$Revision: 1.2 $ $Date: 2006/03/08 16:55:17 $
Author:
  • Kohsuke KAWAGUCHI, Sun Microsystems, Inc.
See Also:
Unmarshaller.getUnmarshallerHandler()

Method Summary
 Object getResult()
Obtains the unmarshalled result.
Methods inherited from interface org.xml.sax.ContentHandler
characters, endDocument, endElement, endPrefixMapping, ignorableWhitespace, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping

Method Detail

getResult

Object getResult()
                 throws JAXBException,
                        IllegalStateException
Obtains the unmarshalled result. This method can be called only after this handler receives the endDocument SAX event.

Returns:
always return a non-null valid object which was unmarshalled.
Throws:
IllegalStateException - if this method is called before this handler receives the endDocument event.
JAXBException - if there is any unmarshalling error. Note that the implementation is allowed to throw SAXException during the parsing when it finds an error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


util

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.bind.util

Useful client utility classes.

See:
Description

Class Summary
JAXBResult | JAXP Result implementation that unmarshals a JAXB object.
JAXBSource | JAXP Source implementation that marshals a JAXB-generated object.
ValidationEventCollector | ValidationEventHandler implementation that collects all events.

Package javax.xml.bind.util Description

Useful client utility classes.

Package Specification

  • JAXB Specification

Related Documentation

For overviews, tutorials, examples, guides, and tool documentation, please see:
  • The JAXB Website

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.bind.util Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.bind.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
      • javax.xml.bind.util.JAXBResult
    • javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
      • javax.xml.bind.util.JAXBSource
    • javax.xml.bind.util.ValidationEventCollector (implements javax.xml.bind.ValidationEventHandler)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JAXBResult

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.util
Class JAXBResult

java.lang.Object
    extended by  javax.xml.transform.sax.SAXResult
        extended by  javax.xml.bind.util.JAXBResult
All Implemented Interfaces:
Result
public class JAXBResult
extends SAXResult

JAXP Result implementation that unmarshals a JAXB object.

This utility class is useful to combine JAXB with other Java/XML technologies.

The following example shows how to use JAXB to unmarshal a document resulting from an XSLT transformation.

       JAXBResult result = new JAXBResult(
         JAXBContext.newInstance("org.acme.foo") );

       // set up XSLT transformation
       TransformerFactory tf = TransformerFactory.newInstance();
       Transformer t = tf.newTransformer(new StreamSource("test.xsl"));

       // run transformation
       t.transform(new StreamSource("document.xml"),result);

       // obtain the unmarshalled content tree
       Object o = result.getResult();

The fact that JAXBResult derives from SAXResult is an implementation detail. Thus in general applications are strongly discouraged from accessing methods defined on SAXResult.

In particular it shall never attempt to call the setHandler, setLexicalHandler, and setSystemId methods.

Author:
Kohsuke Kawaguchi (kohsuke.kawaguchi@sun.com)

Field Summary
Fields inherited from class javax.xml.transform.sax.SAXResult
FEATURE
Fields inherited from interface javax.xml.transform.Result
PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING
Constructor Summary
JAXBResult(JAXBContext context)
Creates a new instance that uses the specified JAXBContext to unmarshal.
JAXBResult(Unmarshaller _unmarshaller)
Creates a new instance that uses the specified Unmarshaller to unmarshal an object.
Method Summary
 Object getResult()
Gets the unmarshalled object created by the transformation.
Methods inherited from class javax.xml.transform.sax.SAXResult
getHandler, getLexicalHandler, getSystemId, setHandler, setLexicalHandler, setSystemId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JAXBResult

public JAXBResult(JAXBContext context)
           throws JAXBException
Creates a new instance that uses the specified JAXBContext to unmarshal.

Parameters:
context - The JAXBContext that will be used to create the necessary Unmarshaller. This parameter must not be null.
Throws:
JAXBException - if an error is encountered while creating the JAXBResult or if the context parameter is null.

JAXBResult

public JAXBResult(Unmarshaller _unmarshaller)
           throws JAXBException
Creates a new instance that uses the specified Unmarshaller to unmarshal an object.

This JAXBResult object will use the specified Unmarshaller instance. It is the caller's responsibility not to use the same Unmarshaller for other purposes while it is being used by this object.

The primary purpose of this method is to allow the client to configure Unmarshaller. Unless you know what you are doing, it's easier and safer to pass a JAXBContext.

Parameters:
_unmarshaller - the unmarshaller. This parameter must not be null.
Throws:
JAXBException - if an error is encountered while creating the JAXBResult or the Unmarshaller parameter is null.
Method Detail

getResult

public Object getResult()
                 throws JAXBException
Gets the unmarshalled object created by the transformation.

Returns:
Always return a non-null object.
Throws:
IllegalStateException - if this method is called before an object is unmarshalled.
JAXBException - if there is any unmarshalling error. Note that the implementation is allowed to throw SAXException during the parsing when it finds an error.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JAXBSource

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.util
Class JAXBSource

java.lang.Object
    extended by  javax.xml.transform.sax.SAXSource
        extended by  javax.xml.bind.util.JAXBSource
All Implemented Interfaces:
Source
public class JAXBSource
extends SAXSource

JAXP Source implementation that marshals a JAXB-generated object.

This utility class is useful to combine JAXB with other Java/XML technologies.

The following example shows how to use JAXB to marshal a document for transformation by XSLT.

       MyObject o = // get JAXB content tree

       // jaxbContext is a JAXBContext object from which 'o' is created.
       JAXBSource source = new JAXBSource( jaxbContext, o );

       // set up XSLT transformation
       TransformerFactory tf = TransformerFactory.newInstance();
       Transformer t = tf.newTransformer(new StreamSource("test.xsl"));

       // run transformation
       t.transform(source,new StreamResult(System.out));

The fact that JAXBSource derives from SAXSource is an implementation detail. Thus in general applications are strongly discouraged from accessing methods defined on SAXSource. In particular, the setXMLReader and setInputSource methods shall never be called. The XMLReader object obtained by the getXMLReader method shall be used only for parsing the InputSource object returned by the getInputSource method.

Similarly the InputSource object obtained by the getInputSource method shall be used only for being parsed by the XMLReader object returned by the getXMLReader.

Author:
Kohsuke Kawaguchi (kohsuke.kawaguchi@sun.com)

Field Summary
Fields inherited from class javax.xml.transform.sax.SAXSource
FEATURE
Constructor Summary
JAXBSource(JAXBContext context, Object contentObject)
Creates a new Source for the given content object.
JAXBSource(Marshaller marshaller, Object contentObject)
Creates a new Source for the given content object.
Method Summary
Methods inherited from class javax.xml.transform.sax.SAXSource
getInputSource, getSystemId, getXMLReader, setInputSource, setSystemId, setXMLReader, sourceToInputSource
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JAXBSource

public JAXBSource(JAXBContext context,
                  Object contentObject)
           throws JAXBException
Creates a new Source for the given content object.

Parameters:
context - JAXBContext that was used to create contentObject. This context is used to create a new instance of marshaller and must not be null.
contentObject - An instance of a JAXB-generated class, which will be used as a Source (by marshalling it into XML). It must not be null.
Throws:
JAXBException - if an error is encountered while creating the JAXBSource or if either of the parameters are null.

JAXBSource

public JAXBSource(Marshaller marshaller,
                  Object contentObject)
           throws JAXBException
Creates a new Source for the given content object.

Parameters:
marshaller - A marshaller instance that will be used to marshal contentObject into XML. This must be created from a JAXBContext that was used to build contentObject and must not be null.
contentObject - An instance of a JAXB-generated class, which will be used as a Source (by marshalling it into XML). It must not be null.
Throws:
JAXBException - if an error is encountered while creating the JAXBSource or if either of the parameters are null.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValidationEventCollector

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind.util
Class ValidationEventCollector

java.lang.Object
    extended by  javax.xml.bind.util.ValidationEventCollector
All Implemented Interfaces:
ValidationEventHandler
public class ValidationEventCollector
extends Object
implements ValidationEventHandler

ValidationEventHandler implementation that collects all events.

To use this class, create a new instance and pass it to the setEventHandler method of the Validator, Unmarshaller, Marshaller class. After the call to validate or unmarshal completes, call the getEvents method to retrieve all the reported errors and warnings.

Since:
JAXB1.0
Version:
$Revision: 1.2 $
Author:
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.
See Also:
Validator, ValidationEventHandler, ValidationEvent, ValidationEventLocator

Constructor Summary
ValidationEventCollector()
Method Summary
ValidationEvent[] | getEvents() Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.
boolean | handleEvent(ValidationEvent event) Receive notification of a validation warning or error.
boolean | hasEvents() Returns true if this event collector contains at least one ValidationEvent.
void | reset() Clear all collected errors and warnings.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValidationEventCollector

public ValidationEventCollector()
Method Detail

getEvents

public ValidationEvent[] getEvents()
Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.

Returns:
a copy of all the collected errors and warnings or an empty array if there weren't any

reset

public void reset()
Clear all collected errors and warnings.

hasEvents

public boolean hasEvents()
Returns true if this event collector contains at least one ValidationEvent.

Returns:
true if this event collector contains at least one ValidationEvent, false otherwise

handleEvent

public boolean handleEvent(ValidationEvent event)
Description copied from interface: ValidationEventHandler
Receive notification of a validation warning or error. The ValidationEvent will have a ValidationEventLocator embedded in it that indicates where the error or warning occurred.

If an unchecked runtime exception is thrown from this method, the JAXB provider will treat it as if the method returned false and interrupt the current unmarshal, validate, or marshal operation.

Specified by:
handleEvent in interface ValidationEventHandler
Parameters:
event - the encapsulated validation event information. It is a provider error if this parameter is null.
Returns:
true if the JAXB Provider should attempt to continue the current unmarshal, validate, or marshal operation after handling this warning/error, false if the provider should terminate the current operation with the appropriate UnmarshalException, ValidationException, or MarshalException.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValidationEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Interface ValidationEvent

All Known Subinterfaces:
NotIdentifiableEvent, ParseConversionEvent, PrintConversionEvent
All Known Implementing Classes:
NotIdentifiableEventImpl, ParseConversionEventImpl, PrintConversionEventImpl, ValidationEventImpl
public interface ValidationEvent

This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.
See Also:
Validator, ValidationEventHandler

Field Summary
static int | ERROR Conditions that correspond to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation
static int | FATAL_ERROR Conditions that correspond to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation
static int | WARNING Conditions that are not errors or fatal errors as defined by the XML 1.0 recommendation
Method Summary
Throwable | getLinkedException() Retrieve the linked exception for this warning/error.
ValidationEventLocator | getLocator() Retrieve the locator for this warning/error.
String | getMessage() Retrieve the text message for this warning/error.
int | getSeverity() Retrieve the severity code for this warning/error.

Field Detail

WARNING

static final int WARNING
Conditions that are not errors or fatal errors as defined by the XML 1.0 recommendation

See Also:
Constant Field Values

ERROR

static final int ERROR
Conditions that correspond to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation

See Also:
Constant Field Values

FATAL_ERROR

static final int FATAL_ERROR
Conditions that correspond to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation

See Also:
Constant Field Values
Method Detail

getSeverity

int getSeverity()
Retrieve the severity code for this warning/error.

Must be one of ValidationError.WARNING, ValidationError.ERROR, or ValidationError.FATAL_ERROR.

Returns:
the severity code for this warning/error

getMessage

String getMessage()
Retrieve the text message for this warning/error.

Returns:
the text message for this warning/error or null if one wasn't set

getLinkedException

Throwable getLinkedException()
Retrieve the linked exception for this warning/error.

Returns:
the linked exception for this warning/error or null if one wasn't set

getLocator

ValidationEventLocator getLocator()
Retrieve the locator for this warning/error.

Returns:
the locator that indicates where the warning/error occurred
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValidationEventHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Interface ValidationEventHandler

All Known Implementing Classes:
DefaultValidationEventHandler, ValidationEventCollector
public interface ValidationEventHandler

A basic event handler interface for validation errors.

If an application needs to implement customized event handling, it must implement this interface and then register it with either the Unmarshaller, the Validator, or the Marshaller. The JAXB Provider will then report validation errors and warnings encountered during the unmarshal, marshal, and validate operations to these event handlers.

If the handleEvent method throws an unchecked runtime exception, the JAXB Provider must treat that as if the method returned false, effectively terminating whatever operation was in progress at the time (unmarshal, validate, or marshal).

Modifying the Java content tree within your event handler is undefined by the specification and may result in unexpected behaviour.

Failing to return false from the handleEvent method after encountering a fatal error is undefined by the specification and may result in unexpected behavior.

Default Event Handler

See: Validator javadocs

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.
See Also:
Unmarshaller, Validator, Marshaller, ValidationEvent, ValidationEventCollector

Method Summary
 boolean handleEvent(ValidationEvent event)
Receive notification of a validation warning or error.

Method Detail

handleEvent

boolean handleEvent(ValidationEvent event)
Receive notification of a validation warning or error. The ValidationEvent will have a ValidationEventLocator embedded in it that indicates where the error or warning occurred.

If an unchecked runtime exception is thrown from this method, the JAXB provider will treat it as if the method returned false and interrupt the current unmarshal, validate, or marshal operation.

Parameters:
event - the encapsulated validation event information. It is a provider error if this parameter is null.
Returns:
true if the JAXB Provider should attempt to continue the current unmarshal, validate, or marshal operation after handling this warning/error, false if the provider should terminate the current operation with the appropriate UnmarshalException, ValidationException, or MarshalException.
Throws:
IllegalArgumentException - if the event object is null.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValidationEventLocator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Interface ValidationEventLocator

All Known Implementing Classes:
ValidationEventLocatorImpl
public interface ValidationEventLocator

Encapsulate the location of a ValidationEvent.

The ValidationEventLocator indicates where the ValidationEvent occurred. Different fields will be set depending on the type of validation that was being performed when the error or warning was detected. For example, on-demand validation would produce locators that contained references to objects in the Java content tree while unmarshal-time validation would produce locators containing information appropriate to the source of the XML data (file, url, Node, etc).

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.
See Also:
Validator, ValidationEvent

Method Summary
int | getColumnNumber() Return the column number if available
int | getLineNumber() Return the line number if available
Node | getNode() Return a reference to the DOM Node if available
Object | getObject() Return a reference to the object in the Java content tree if available
int | getOffset() Return the byte offset if available
URL | getURL() Return the name of the XML source as a URL if available

Method Detail

getURL

URL getURL()
Return the name of the XML source as a URL if available

Returns:
the name of the XML source as a URL or null if unavailable

getOffset

int getOffset()
Return the byte offset if available

Returns:
the byte offset into the input source or -1 if unavailable

getLineNumber

int getLineNumber()
Return the line number if available

Returns:
the line number or -1 if unavailable

getColumnNumber

int getColumnNumber()
Return the column number if available

Returns:
the column number or -1 if unavailable

getObject

Object getObject()
Return a reference to the object in the Java content tree if available

Returns:
a reference to the object in the Java content tree or null if unavailable

getNode

Node getNode()
Return a reference to the DOM Node if available

Returns:
a reference to the DOM Node or null if unavailable
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ValidationException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Class ValidationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.bind.JAXBException
                extended by  javax.xml.bind.ValidationException
All Implemented Interfaces:
Serializable
public class ValidationException
extends JAXBException

This exception indicates that an error has occurred while performing a validate operation.

The ValidationEventHandler can cause this exception to be thrown during the validate operations. See ValidationEventHandler.handleEvent(ValidationEvent).

Since:
JAXB1.0
Version:
$Revision: 1.1 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
See Also:
JAXBException, Validator, Serialized Form

Constructor Summary
ValidationException(String message)
Construct an ValidationException with the specified detail message.
ValidationException(String message, String errorCode)
Construct an ValidationException with the specified detail message and vendor specific errorCode.
ValidationException(String message, String errorCode, Throwable exception)
Construct an ValidationException with the specified detail message, vendor specific errorCode, and linkedException.
ValidationException(String message, Throwable exception)
Construct an ValidationException with the specified detail message and linkedException.
ValidationException(Throwable exception)
Construct an ValidationException with a linkedException.
Method Summary
Methods inherited from class javax.xml.bind.JAXBException
getCause, getErrorCode, getLinkedException, printStackTrace, printStackTrace, printStackTrace, setLinkedException, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ValidationException

public ValidationException(String message)
Construct an ValidationException with the specified detail message. The errorCode and linkedException will default to null.

Parameters:
message - a description of the exception

ValidationException

public ValidationException(String message,
                           String errorCode)
Construct an ValidationException with the specified detail message and vendor specific errorCode. The linkedException will default to null.

Parameters:
message - a description of the exception
errorCode - a string specifying the vendor specific error code

ValidationException

public ValidationException(Throwable exception)
Construct an ValidationException with a linkedException. The detail message and vendor specific errorCode will default to null.

Parameters:
exception - the linked exception

ValidationException

public ValidationException(String message,
                           Throwable exception)
Construct an ValidationException with the specified detail message and linkedException. The errorCode will default to null.

Parameters:
message - a description of the exception
exception - the linked exception

ValidationException

public ValidationException(String message,
                           String errorCode,
                           Throwable exception)
Construct an ValidationException with the specified detail message, vendor specific errorCode, and linkedException.

Parameters:
message - a description of the exception
errorCode - a string specifying the vendor specific error code
exception - the linked exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Validator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.bind
Interface Validator

Deprecated. since JAXB 2.0

public interface Validator

As of JAXB 2.0, this class is deprecated and optional.

The Validator class is responsible for controlling the validation of content trees during runtime.

Three Forms of Validation

Unmarshal-Time Validation
This form of validation enables a client application to receive information about validation errors and warnings detected while unmarshalling XML data into a Java content tree and is completely orthogonal to the other types of validation. To enable or disable it, see the javadoc for Unmarshaller.setValidating. All JAXB 1.0 Providers are required to support this operation.
On-Demand Validation
This form of validation enables a client application to receive information about validation errors and warnings detected in the Java content tree. At any point, client applications can call the Validator.validate method on the Java content tree (or any sub-tree of it). All JAXB 1.0 Providers are required to support this operation.
Fail-Fast Validation
This form of validation enables a client application to receive immediate feedback about modifications to the Java content tree that violate type constraints on Java Properties as defined in the specification. JAXB Providers are not required support this type of validation. Of the JAXB Providers that do support this type of validation, some may require you to decide at schema compile time whether or not a client application will be allowed to request fail-fast validation at runtime.

The Validator class is responsible for managing On-Demand Validation. The Unmarshaller class is responsible for managing Unmarshal-Time Validation during the unmarshal operations. Although there is no formal method of enabling validation during the marshal operations, the Marshaller may detect errors, which will be reported to the ValidationEventHandler registered on it.

Using the Default EventHandler

If the client application does not set an event handler on their Validator, Unmarshaller, or Marshaller prior to calling the validate, unmarshal, or marshal methods, then a default event handler will receive notification of any errors or warnings encountered. The default event handler will cause the current operation to halt after encountering the first error or fatal error (but will attempt to continue after receiving warnings).

Handling Validation Events

There are three ways to handle events encountered during the unmarshal, validate, and marshal operations:
Use the default event handler
The default event handler will be used if you do not specify one via the setEventHandler API's on Validator, Unmarshaller, or Marshaller.
Implement and register a custom event handler
Client applications that require sophisticated event processing can implement the ValidationEventHandler interface and register it with the Unmarshaller and/or Validator.
Use the ValidationEventCollector utility
For convenience, a specialized event handler is provided that simply collects any ValidationEvent objects created during the unmarshal, validate, and marshal operations and returns them to the client application as a java.util.Collection.

Validation and Well-Formedness

Validation events are handled differently depending on how the client application is configured to process them as described in the previous section. However, there are certain cases where a JAXB Provider indicates that it is no longer able to reliably detect and report errors. In these cases, the JAXB Provider will set the severity of the ValidationEvent to FATAL_ERROR to indicate that the unmarshal, validate, or marshal operations should be terminated. The default event handler and ValidationEventCollector utility class must terminate processing after being notified of a fatal error. Client applications that supply their own ValidationEventHandler should also terminate processing after being notified of a fatal error. If not, unexpected behaviour may occur.

Supported Properties

There currently are not any properties required to be supported by all JAXB Providers on Validator. However, some providers may support their own set of provider specific properties.

Since:
JAXB1.0
Version:
$Revision: 1.4 $ $Date: 2005/07/29 20:56:02 $
Author:
  • Ryan Shoemaker, Sun Microsystems, Inc.
  • Kohsuke Kawaguchi, Sun Microsystems, Inc.
  • Joe Fialli, Sun Microsystems, Inc.
See Also:
JAXBContext, Unmarshaller, ValidationEventHandler, ValidationEvent, ValidationEventCollector

Method Summary
ValidationEventHandler | getEventHandler() Deprecated. since JAXB2.0
Object | getProperty(String name) Deprecated. since JAXB2.0
void | setEventHandler(ValidationEventHandler handler) Deprecated. since JAXB2.0
void | setProperty(String name, Object value) Deprecated. since JAXB2.0
boolean | validate(Object subrootObj) Deprecated. since JAXB2.0
boolean | validateRoot(Object rootObj) Deprecated. since JAXB2.0

Method Detail

setEventHandler

void setEventHandler(ValidationEventHandler handler)
                     throws JAXBException
Deprecated. since JAXB2.0

Allow an application to register a validation event handler.

The validation event handler will be called by the JAXB Provider if any validation errors are encountered during calls to validate. If the client application does not register a validation event handler before invoking the validate method, then validation events will be handled by the default event handler which will terminate the validate operation after the first error or fatal error is encountered.

Calling this method with a null parameter will cause the Validator to revert back to the default default event handler.

Parameters:
handler - the validation event handler
Throws:
JAXBException - if an error was encountered while setting the event handler

getEventHandler

ValidationEventHandler getEventHandler()
                                       throws JAXBException
Deprecated. since JAXB2.0

Return the current event handler or the default event handler if one hasn't been set.

Returns:
the current ValidationEventHandler or the default event handler if it hasn't been set
Throws:
JAXBException - if an error was encountered while getting the current event handler

validate

boolean validate(Object subrootObj)
                 throws JAXBException
Deprecated. since JAXB2.0

Validate the Java content tree starting at subrootObj.

Client applications can use this method to validate Java content trees on-demand at runtime. This method can be used to validate any arbitrary subtree of the Java content tree. Global constraint checking will not be performed as part of this operation (i.e. ID/IDREF constraints).

Parameters:
subrootObj - the obj to begin validation at
Returns:
true if the subtree rooted at subrootObj is valid, false otherwise
Throws:
JAXBException - if any unexpected problem occurs during validation
ValidationException - If the ValidationEventHandler returns false from its handleEvent method or the Validator is unable to validate the content tree rooted at subrootObj
IllegalArgumentException - If the subrootObj parameter is null

validateRoot

boolean validateRoot(Object rootObj)
                     throws JAXBException
Deprecated. since JAXB2.0

Validate the Java content tree rooted at rootObj.

Client applications can use this method to validate Java content trees on-demand at runtime. This method is used to validate an entire Java content tree. Global constraint checking will be performed as part of this operation (i.e. ID/IDREF constraints).

Parameters:
rootObj - the root obj to begin validation at
Returns:
true if the tree rooted at rootObj is valid, false otherwise
Throws:
JAXBException - if any unexpected problem occurs during validation
ValidationException - If the ValidationEventHandler returns false from its handleEvent method or the Validator is unable to validate the content tree rooted at rootObj
IllegalArgumentException - If the rootObj parameter is null

setProperty

void setProperty(String name,
                 Object value)
                 throws PropertyException
Deprecated. since JAXB2.0

Set the particular property in the underlying implementation of Validator. This method can only be used to set one of the standard JAXB defined properties above or a provider specific property. Attempting to set an undefined property will result in a PropertyException being thrown. See Supported Properties.

Parameters:
name - the name of the property to be set. This value can either be specified using one of the constant fields or a user supplied string.
value - the value of the property to be set
Throws:
PropertyException - when there is an error processing the given property or value
IllegalArgumentException - If the name parameter is null

getProperty

Object getProperty(String name)
                   throws PropertyException
Deprecated. since JAXB2.0

Get the particular property in the underlying implementation of Validator. This method can only be used to get one of the standard JAXB defined properties above or a provider specific property. Attempting to get an undefined property will result in a PropertyException being thrown. See Supported Properties.

Parameters:
name - the name of the property to retrieve
Returns:
the value of the requested property
Throws:
PropertyException - when there is an error retrieving the given property or value property name
IllegalArgumentException - If the name parameter is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


registry

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.registry

This package and its sub-packages describe the API classes and interfaces for the JAXR API.

See:
Description

Interface Summary
BulkResponse | Contains the response of a method in the API that performs a bulk operation and returns a bulk response.
BusinessLifeCycleManager | The BusinessLifeCycleManager interface, which is exposed by the Registry Service, implements the life cycle management functionality of the Registry as part of a business level API.
BusinessQueryManager | The BusinessQueryManager interface, which is exposed by the Registry Service, implements the business style query interface.
CapabilityProfile | Provides information about the capabilities of a JAXR provider.
Connection | This class represents a connection between a JAXR client and a JAXR provider.
DeclarativeQueryManager | This interface provides the ability to execute declarative queries (e.g.
FederatedConnection | Represents a single logical connection to a federation or group of registry providers.
FindQualifier | FindQualifier provides various constants that identify options that effect find method behavior.
JAXRResponse | A JAXR requests' response.
LifeCycleManager | The LifeCycleManager interface is the main interface in the API for managing life cycle operations on objects defined by the information model.
Query | The Query interface encapsulates a query in a declarative query language.
QueryManager | This is the common base interface for all QueryManagers in the API.
RegistryService | This is the principal interface implemented by a JAXR provider.

Class Summary
ConnectionFactory This is the abstract base class for factory classes for creating a JAXR connection.

Exception Summary
DeleteException | A RegistryException that occurs during a delete action.
FindException | A RegistryException that occurs during a find action.
InvalidRequestException | This exception is thrown when a JAXR client attempts to invoke an API method that is not valid for some reason.
JAXRException | Signals that a JAXR exception has occurred.
RegistryException | This is the common base class for all Exceptions that are detected on the registry provider side rather than the JAXR client side.
SaveException | A RegistryException that occurs during a save action.
UnexpectedObjectException | This exception is thrown when the JAXR provider finds a Object that is out-of-place or of the wrong type within the context of a user request.
UnsupportedCapabilityException | This exception must be thrown when a JAXR client attempts to invoke an API method that is not supported by the capability profile that is supported by the JAXR provider.

Package javax.xml.registry Description

This package and its sub-packages describe the API classes and interfaces for the JAXR API. In this package are the high-level interfaces and classes that a client uses to interact with a registry via a JAXR provider.

Figure 1 shows the primary interfaces in the JAXR API.

Figure 1. Primary Interfaces in the JAXR API

Figure 2 shows the response and exception classes in the JAXR API.

Figure 2. Response and Exception Classes in the JAXR API

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FederatedConnection

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface FederatedConnection

All Superinterfaces:
Connection
public interface FederatedConnection
extends Connection

Represents a single logical connection to a federation or group of registry providers. This interface is used in support of the distributed query feature of the JAXR API.

Author:
Farrukh S. Najmi

Method Summary
Methods inherited from interface javax.xml.registry.Connection
close, getCredentials, getRegistryService, isClosed, isSynchronous, setCredentials, setSynchronous

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.registry Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.registry

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.registry.ConnectionFactory
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.registry.JAXRException (implements javax.xml.registry.JAXRResponse)
          • javax.xml.registry.InvalidRequestException
          • javax.xml.registry.RegistryException
            • javax.xml.registry.DeleteException
            • javax.xml.registry.FindException
            • javax.xml.registry.SaveException
          • javax.xml.registry.UnexpectedObjectException
          • javax.xml.registry.UnsupportedCapabilityException

Interface Hierarchy

  • javax.xml.registry.CapabilityProfile
  • javax.xml.registry.Connection
    • javax.xml.registry.FederatedConnection
  • javax.xml.registry.FindQualifier
  • javax.xml.registry.JAXRResponse
    • javax.xml.registry.BulkResponse
  • javax.xml.registry.LifeCycleManager
    • javax.xml.registry.BusinessLifeCycleManager
  • javax.xml.registry.Query
  • javax.xml.registry.QueryManager
    • javax.xml.registry.BusinessQueryManager
    • javax.xml.registry.DeclarativeQueryManager
  • javax.xml.registry.RegistryService
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BulkResponse

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface BulkResponse

All Superinterfaces:
JAXRResponse
public interface BulkResponse
extends JAXRResponse

Contains the response of a method in the API that performs a bulk operation and returns a bulk response. Partial commits are allowed on a bulk operation.

In the event of a partial success where only a subset of objects were processed successfully, the getStatus method of the BulkResponse must return JAXRResponse.STATUS_WARNING. In this case, a Collection of JAXRException instances is included in the BulkResponse instance. The JAXRExceptions provide information on each error that prevented some objects in the request to not be processed successfully.

Author:
Farrukh S. Najmi
See Also:
QueryManager, LifeCycleManager

Field Summary
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Method Summary
Collection | getCollection() Get the Collection of objects returned as a response of a bulk operation.
Collection | getExceptions() Get the Collection of RegistryException instances in case of partial commit.
boolean | isPartialResponse() Determines whether the response is a partial response due to large result set.
Methods inherited from interface javax.xml.registry.JAXRResponse
getRequestId, getStatus, isAvailable

Method Detail

getCollection

Collection getCollection()
                         throws JAXRException
Get the Collection of objects returned as a response of a bulk operation. Caller thread will block here if result is not yet available.

Capability Level: 0

Returns:
Collection of RegistryObject instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryObject

getExceptions

Collection getExceptions()
                         throws JAXRException
Get the Collection of RegistryException instances in case of partial commit. Caller thread will block here if result is not yet available.

Capability Level: 0

Returns:
Collection of RegistryException instances. Return null if result is available and there is no RegistryException.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryException

isPartialResponse

boolean isPartialResponse()
                          throws JAXRException
Determines whether the response is a partial response due to large result set.

Capability Level: 0

Returns:
true if the response is partial; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BusinessLifeCycleManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface BusinessLifeCycleManager

All Superinterfaces:
LifeCycleManager
public interface BusinessLifeCycleManager
extends LifeCycleManager

The BusinessLifeCycleManager interface, which is exposed by the Registry Service, implements the life cycle management functionality of the Registry as part of a business level API. Note that there is no authentication information provided, because the Connection interface keeps that state and context on behalf of the client.

Author:
Farrukh S. Najmi
See Also:
LifeCycleManager

Field Summary
Fields inherited from interface javax.xml.registry.LifeCycleManager
ASSOCIATION, AUDITABLE_EVENT, CLASSIFICATION, CLASSIFICATION_SCHEME, CONCEPT, EMAIL_ADDRESS, EXTERNAL_IDENTIFIER, EXTERNAL_LINK, EXTRINSIC_OBJECT, INTERNATIONAL_STRING, KEY, LOCALIZED_STRING, ORGANIZATION, PERSON_NAME, POSTAL_ADDRESS, REGISTRY_ENTRY, REGISTRY_PACKAGE, SERVICE, SERVICE_BINDING, SLOT, SPECIFICATION_LINK, TELEPHONE_NUMBER, USER, VERSIONABLE
Method Summary
void | confirmAssociation(Association assoc) Confirms this Association by the User associated with the caller.
BulkResponse | deleteAssociations(Collection associationKeys) Deletes the Associations corresponding to the specified Keys.
BulkResponse | deleteClassificationSchemes(Collection schemeKeys) Deletes the ClassificationSchemes corresponding to the specified Keys.
BulkResponse | deleteConcepts(Collection conceptKeys) Deletes the Concepts corresponding to the specified Keys.
BulkResponse | deleteOrganizations(Collection organizationKeys) Deletes the organizations corresponding to the specified Keys.
BulkResponse | deleteServiceBindings(Collection bindingKeys) Deletes the ServiceBindings corresponding to the specified Keys.
BulkResponse | deleteServices(Collection serviceKeys) Deletes the services corresponding to the specified Keys.
BulkResponse | saveAssociations(Collection associations, boolean replace) Saves the specified Association instances.
BulkResponse | saveClassificationSchemes(Collection schemes) Saves the specified ClassificationScheme instances.
BulkResponse | saveConcepts(Collection concepts) Saves the specified Concepts.
BulkResponse | saveOrganizations(Collection organizations) Saves the specified Organizations.
BulkResponse | saveServiceBindings(Collection bindings) Saves the specified ServiceBindings.
BulkResponse | saveServices(Collection services) Saves the specified Services.
void | unConfirmAssociation(Association assoc) Undoes a previous confirmation of this Association by the User associated with the caller.
Methods inherited from interface javax.xml.registry.LifeCycleManager
createAssociation, createClassification, createClassification, createClassification, createClassificationScheme, createClassificationScheme, createClassificationScheme, createConcept, createConcept, createEmailAddress, createEmailAddress, createExternalIdentifier, createExternalIdentifier, createExternalLink, createExternalLink, createExtrinsicObject, createInternationalString, createInternationalString, createInternationalString, createKey, createLocalizedString, createLocalizedString, createObject, createOrganization, createOrganization, createPersonName, createPersonName, createPostalAddress, createRegistryPackage, createRegistryPackage, createService, createService, createServiceBinding, createSlot, createSlot, createSpecificationLink, createTelephoneNumber, createUser, deleteObjects, deleteObjects, deprecateObjects, getRegistryService, saveObjects, unDeprecateObjects

Method Detail

saveOrganizations

BulkResponse saveOrganizations(Collection organizations)
                               throws JAXRException
Saves the specified Organizations.

If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

Partial commits are allowed. Processing stops on first SaveException encountered.

Capability Level: 0

Parameters:
organizations - the Collection of Organization objects to be saved
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

saveServices

BulkResponse saveServices(Collection services)
                          throws JAXRException
Saves the specified Services.

If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

Partial commits are allowed. Processing stops on first SaveException encountered.

Capability Level: 0

Parameters:
services - the Collection of Service objects to be saved
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

saveServiceBindings

BulkResponse saveServiceBindings(Collection bindings)
                                 throws JAXRException
Saves the specified ServiceBindings.

If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

Partial commits are allowed. Processing stops on first SaveException encountered.

Capability Level: 0

Parameters:
bindings - the Collection of ServiceBinding objects to be saved
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

saveConcepts

BulkResponse saveConcepts(Collection concepts)
                          throws JAXRException
Saves the specified Concepts.

If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

Partial commits are allowed. Processing stops on first SaveException encountered.

Capability Level: 0

Parameters:
concepts - the Collection of Concept objects to be saved
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

saveClassificationSchemes

BulkResponse saveClassificationSchemes(Collection schemes)
                                       throws JAXRException
Saves the specified ClassificationScheme instances.

If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

Partial commits are allowed. Processing stops on first SaveException encountered.

Capability Level: 0

Parameters:
schemes - the Collection of ClassificationScheme objects to be saved
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

saveAssociations

BulkResponse saveAssociations(Collection associations,
                              boolean replace)
                              throws JAXRException
Saves the specified Association instances.

If the object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, its state is updated (replaced) in the registry.

Partial commits are allowed. Processing stops on first SaveException encountered.

Capability Level: 0

Parameters:
associations - the Collection of Association objects to be saved
replace - If set to true, the specified associations replace any existing associations owned by the caller. If set to false, the specified associations are saved, while any existing associations not being updated by this call are preserved.
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteOrganizations

BulkResponse deleteOrganizations(Collection organizationKeys)
                                 throws JAXRException
Deletes the organizations corresponding to the specified Keys.

Partial commits are allowed. Processing stops on first DeleteException encountered.

Capability Level: 0

Parameters:
organizationKeys - the Collection of keys for the Organization objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteServices

BulkResponse deleteServices(Collection serviceKeys)
                            throws JAXRException
Deletes the services corresponding to the specified Keys.

Partial commits are allowed. Processing stops on first DeleteException encountered.

Capability Level: 0

Parameters:
serviceKeys - the Collection of keys for the Service objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteServiceBindings

BulkResponse deleteServiceBindings(Collection bindingKeys)
                                   throws JAXRException
Deletes the ServiceBindings corresponding to the specified Keys.

Partial commits are allowed. Processing stops on first DeleteException encountered.

Capability Level: 0

Parameters:
bindingKeys - the Collection of keys for the ServiceBinding objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteConcepts

BulkResponse deleteConcepts(Collection conceptKeys)
                            throws JAXRException
Deletes the Concepts corresponding to the specified Keys.

Partial commits are allowed. Processing stops on first DeleteException encountered.

Capability Level: 0

Parameters:
conceptKeys - the Collection of keys for the Concept objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteClassificationSchemes

BulkResponse deleteClassificationSchemes(Collection schemeKeys)
                                         throws JAXRException
Deletes the ClassificationSchemes corresponding to the specified Keys.

Partial commits are allowed. Processing stops on first DeleteException encountered.

Capability Level: 0

Parameters:
schemeKeys - the Collection of keys for the ClassificationScheme objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteAssociations

BulkResponse deleteAssociations(Collection associationKeys)
                                throws JAXRException
Deletes the Associations corresponding to the specified Keys.

Partial commits are allowed. Processing stops on first DeleteException encountered.

Capability Level: 0

Parameters:
associationKeys - the Collection of keys for the Association objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

confirmAssociation

void confirmAssociation(Association assoc)
                        throws JAXRException,
                               InvalidRequestException
Confirms this Association by the User associated with the caller. The User must be the owner of the sourceObject or the targetObject in this association.

  • If the Association is intramural, this method does nothing and returns.
  • If the Association is extramural and already confirmed (isConfirmed returns true), this method does nothing and returns.
  • If the Association is extramural and not already confirmed, this method confirms the association for the User associated with the caller.

The details of confirming an extramural Association are registry-specific. For UDDI and ebXML registries, the registry-specific details are described in the JAXR specification.

Capability Level: 0

Parameters:
assoc - the Association object to be confirmed
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException - if the User is not the owner of the sourceObject or the targetObject

unConfirmAssociation

void unConfirmAssociation(Association assoc)
                          throws JAXRException,
                                 InvalidRequestException
Undoes a previous confirmation of this Association by the User associated with the caller. The User must be the owner of the sourceObject or the targetObject in this association.

  • If the Association is intramural, this method does nothing and returns.
  • If the Association is extramural and already confirmed (isConfirmed returns true), this method unconfirms it for the requestor.
  • If the Association is extramural and not already confirmed, this method does nothing and returns.

The details of unconfirming an extramural Association are registry-specific. For UDDI and ebXML registries, the registry-specific details are described in the JAXR specification.

Capability Level: 0

Parameters:
assoc - the Association object to be unconfirmed
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException - if the User is not the owner of the sourceObject or the targetObject
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BusinessQueryManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface BusinessQueryManager

All Superinterfaces:
QueryManager
public interface BusinessQueryManager
extends QueryManager

The BusinessQueryManager interface, which is exposed by the Registry Service, implements the business style query interface. It is also referred to as the focused query interface.

Author:
Farrukh S. Najmi
See Also:
DeclarativeQueryManager, FindQualifier, BulkResponse

Method Summary
BulkResponse | findAssociations(Collection findQualifiers, String sourceObjectId, String targetObjectId, Collection associationTypes) Finds all Association objects that match all of the criteria specified by the parameters of this call.
BulkResponse | findCallerAssociations(Collection findQualifiers, Boolean confirmedByCaller, Boolean confirmedByOtherParty, Collection associationTypes) Finds all Association objects owned by the caller that match all of the criteria specified by the parameters of this call.
ClassificationScheme | findClassificationSchemeByName(Collection findQualifiers, String namePattern) Finds a ClassificationScheme by name based on the specified find qualifiers and name pattern.
BulkResponse | findClassificationSchemes(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalLinks) Finds all ClassificationScheme objects that match all of the criteria specified by the parameters of this call.
Concept | findConceptByPath(String path) Finds a Concept based on the path specified.
BulkResponse | findConcepts(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalIdentifiers, Collection externalLinks) Finds all Concept objects that match all of the criteria specified by the parameters of this call.
BulkResponse | findOrganizations(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection specifications, Collection externalIdentifiers, Collection externalLinks) Finds all Organization objects that match all of the criteria specified by the parameters of this call.
BulkResponse | findRegistryPackages(Collection findQualifiers, Collection namePatterns, Collection classifications, Collection externalLinks) Finds all RegistryPackage objects that match all of the criteria specified by the parameters of this call.
BulkResponse | findServiceBindings(Key serviceKey, Collection findQualifiers, Collection classifications, Collection specifications) Finds all ServiceBinding objects that match all of the criteria specified by the parameters of this call.
BulkResponse | findServices(Key orgKey, Collection findQualifiers, Collection namePatterns, Collection classifications, Collection specifications) Finds all Service objects that match all of the criteria specified by the parameters of this call.
Methods inherited from interface javax.xml.registry.QueryManager
getRegistryObject, getRegistryObject, getRegistryObjects, getRegistryObjects, getRegistryObjects, getRegistryObjects, getRegistryService

Method Detail

findAssociations

BulkResponse findAssociations(Collection findQualifiers,
                              String sourceObjectId,
                              String targetObjectId,
                              Collection associationTypes)
                              throws JAXRException
Finds all Association objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters. If no parameters are specified, no Associations are returned.

Capability Level: 0

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
sourceObjectId - a String that represents the id for a RegistryObject that must be the sourceObject of the Associations that match. This parameter is ignored if specified as null.
targetObjectId - a String that represents the id for a RegistryObject that must be the targetObject of the Associations that match. This parameter is ignored if specified as null.
associationTypes - a Collection of associationTypes. This is a logical OR operation across the collection. This parameter is ignored if specified as null.
Returns:
a BulkResponse containing a Collection of Associations
Throws:
JAXRException - if the JAXR provider encounters an internal error

findCallerAssociations

BulkResponse findCallerAssociations(Collection findQualifiers,
                                    Boolean confirmedByCaller,
                                    Boolean confirmedByOtherParty,
                                    Collection associationTypes)
                                    throws JAXRException
Finds all Association objects owned by the caller that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters. If no parameters are specified, no Associations are returned.

This call is sensitive to the identity of the caller and is a privileged operation that requires the caller to have provided its identity credentials to the Connection associated with this object.

Capability Level: 0

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
confirmedByCaller - If true, provider must include Associations involving the caller that have been confirmed by the caller. If false, provider must include Associations involving the caller that have not been confirmed by the caller. This parameter is ignored if specified as null.
confirmedByOtherParty - If true, provider must include Associations involving the caller that have been confirmed by the other party. If false, provider must include Associations involving the caller that have not been confirmed by the other party. This parameter is ignored if specified as null.
associationTypes - a Collection of associationTypes. This is a logical OR operation across the collection. This parameter is ignored if specified as null.
Returns:
a BulkResponse containing a Collection of Associations
Throws:
JAXRException - if the JAXR provider encounters an internal error

findOrganizations

BulkResponse findOrganizations(Collection findQualifiers,
                               Collection namePatterns,
                               Collection classifications,
                               Collection specifications,
                               Collection externalIdentifiers,
                               Collection externalLinks)
                               throws JAXRException
Finds all Organization objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

Capability Level: 0

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
specifications - a Collection of RegistryObjects that represent (proxy) a technical specification. It is analogous to a tModelBag in the UDDI specification. In the case of a UDDI provider, the RegistryObject is a specification Concept. In the case of an ebXML provider, the RegistryObject is likely to be an ExtrinsicObject. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Specifications qualifies as a match for this criterion.
externalIdentifiers - a Collection of ExternalIdentifier objects that provide an external identifier for the object using an identification scheme such as DUNS. It is analogous to an identifierBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalIdentifiers qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createExternalIdentifier method to create a transient ExternalIdentifier for use in this Collection.
externalLinks - a Collection of ExternalLink objects that link the object to content outside the registry. It is analogous to an overviewDoc in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalLinks qualifies as a match for this criterion.
Returns:
a BulkResponse containing a Collection of Organizations
Throws:
JAXRException - if the JAXR provider encounters an internal error

findServices

BulkResponse findServices(Key orgKey,
                          Collection findQualifiers,
                          Collection namePatterns,
                          Collection classifications,
                          Collection specifications)
                          throws JAXRException
Finds all Service objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

Capability Level: 0

Parameters:
orgKey - Key identifying an Organization. Required for UDDI providers.
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
specifications - a Collection of RegistryObjects that represent (proxy) a technical specification. It is analogous to a tModelBag in the UDDI specification. In the case of a UDDI provider, the RegistryObject is a specification Concept. In the case of an ebXML provider, the RegistryObject is likely to be an ExtrinsicObject. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Specifications qualifies as a match for this criterion.
Returns:
a BulkResponse containing a Collection of Services
Throws:
JAXRException - if the JAXR provider encounters an internal error

findServiceBindings

BulkResponse findServiceBindings(Key serviceKey,
                                 Collection findQualifiers,
                                 Collection classifications,
                                 Collection specifications)
                                 throws JAXRException
Finds all ServiceBinding objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

Capability Level: 0

Parameters:
serviceKey - Key identifying a Service. Required for UDDI providers.
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
specifications - a Collection of RegistryObjects that represent (proxy) a technical specification. It is analogous to a tModelBag in the UDDI specification. In the case of a UDDI provider, the RegistryObject is a specification Concept. In the case of an ebXML provider, the RegistryObject is likely to be an ExtrinsicObject. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Specifications qualifies as a match for this criterion.
Returns:
a BulkResponse containing a Collection of ServiceBindings
Throws:
JAXRException - if the JAXR provider encounters an internal error

findClassificationSchemes

BulkResponse findClassificationSchemes(Collection findQualifiers,
                                       Collection namePatterns,
                                       Collection classifications,
                                       Collection externalLinks)
                                       throws JAXRException
Finds all ClassificationScheme objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

Capability Level: 0

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
externalLinks - a Collection of ExternalLink objects that link the object to content outside the registry. It is analogous to an overviewDoc in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalLinks qualifies as a match for this criterion.
Returns:
a BulkResponse containing a Collection of ClassificationSchemes
Throws:
JAXRException - if the JAXR provider encounters an internal error

findClassificationSchemeByName

ClassificationScheme findClassificationSchemeByName(Collection findQualifiers,
                                                    String namePattern)
                                                    throws JAXRException
Finds a ClassificationScheme by name based on the specified find qualifiers and name pattern.

Capability Level: 0

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
namePattern - a String that is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification
Returns:
the ClassificationScheme matching the namePattern, or null if no match is found.
Throws:
JAXRException - if the JAXR provider encounters an internal error. Throws an InvalidRequestException if multiple matches are found.

findConcepts

BulkResponse findConcepts(Collection findQualifiers,
                          Collection namePatterns,
                          Collection classifications,
                          Collection externalIdentifiers,
                          Collection externalLinks)
                          throws JAXRException
Finds all Concept objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

Capability Level: 0

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
externalIdentifiers - a Collection of ExternalIdentifier objects that provide an external identifier for the object using an identification scheme such as DUNS. It is analogous to an identifierBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalIdentifiers qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createExternalIdentifier method to create a transient ExternalIdentifier for use in this Collection.
externalLinks - a Collection of ExternalLink objects that link the object to content outside the registry. It is analogous to an overviewDoc in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalLinks qualifies as a match for this criterion.
Returns:
a BulkResponse containing a Collection of Concepts
Throws:
JAXRException - if the JAXR provider encounters an internal error

findConceptByPath

Concept findConceptByPath(String path)
                          throws JAXRException
Finds a Concept based on the path specified. If the specified path matches more than one Concept, the one that is most general (higher in the concept hierarchy) is returned.

Capability Level: 0

Parameters:
path - a canonical path expression, as defined in the JAXR specification, that identifies the Concept.
Returns:
the Concept found, or null if no match is found
Throws:
JAXRException - if the JAXR provider encounters an internal error

findRegistryPackages

BulkResponse findRegistryPackages(Collection findQualifiers,
                                  Collection namePatterns,
                                  Collection classifications,
                                  Collection externalLinks)
                                  throws JAXRException
Finds all RegistryPackage objects that match all of the criteria specified by the parameters of this call. This is a logical AND operation between all non-null parameters.

Capability Level: 1

Parameters:
findQualifiers - a Collection of find qualifiers as defined by the FindQualifier interface, which specifies qualifiers that affect string matching, sorting, boolean predicate logic, and the like.
namePatterns - a Collection that may consist of either String or LocalizedString objects. Each String or value within a LocalizedString is a partial or full name pattern with wildcard searching as specified by the SQL-92 LIKE specification. Unless otherwise specified in findQualifiers, this is a logical OR, and a match on any name qualifies as a match for this criterion.
classifications - a Collection of Classification objects that classify the object. It is analogous to a catgegoryBag in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified Classifications qualifies as a match for this criterion. The programmer may use the LifeCycleManager.createClassification method to create a transient Classification for use in this Collection.
externalLinks - a Collection of ExternalLink objects that link the object to content outside the registry. It is analogous to an overviewDoc in the UDDI specification. Unless otherwise specified in findQualifiers, this is a logical AND, and a match on all specified ExternalLinks qualifies as a match for this criterion.
Returns:
a BulkResponse containing a Collection of RegistryPackages
Throws:
JAXRException - if the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


CapabilityProfile

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface CapabilityProfile

public interface CapabilityProfile

Provides information about the capabilities of a JAXR provider.

Author:
Farrukh S. Najmi

Method Summary
int | getCapabilityLevel() Gets the capability level supported by the JAXR provider.
String | getVersion() Gets the JAXR specification version supported by the JAXR provider.

Method Detail

getVersion

String getVersion()
                  throws JAXRException
Gets the JAXR specification version supported by the JAXR provider.

Capability Level: 0

Returns:
the specification version
Throws:
JAXRException - If the JAXR provider encounters an internal error

getCapabilityLevel

int getCapabilityLevel()
                       throws JAXRException
Gets the capability level supported by the JAXR provider.

Capability Level: 0

Returns:
the capability level
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Connection

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface Connection

All Known Subinterfaces:
FederatedConnection
public interface Connection

This class represents a connection between a JAXR client and a JAXR provider.

Author:
Farrukh S. Najmi
See Also:
ConnectionFactory

Method Summary
void | close() Closes a Connection when it is no longer needed.
Set | getCredentials() Gets the credentials associated with this client.
RegistryService | getRegistryService() Gets the RegistryService interface associated with the Connection.
boolean | isClosed() Indicated whether this Connection has been closed or not.
boolean | isSynchronous() Indicates whether a client uses synchronous communication with JAXR provider or not.
void | setCredentials(Set credentials) Sets the Credentials associated with this client.
void | setSynchronous(boolean sync) Sets whether the client uses synchronous communication or not.

Method Detail

getRegistryService

RegistryService getRegistryService()
                                   throws JAXRException
Gets the RegistryService interface associated with the Connection. If a Connection property (e.g. credentials) is set after the client calls getRegistryService then the newly set Connection property is visible to the RegistryService previously returned by this call.

Capability Level: 0

Returns:
the RegistryService associated with this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryService

close

void close()
           throws JAXRException
Closes a Connection when it is no longer needed. Since a provider typically allocates significant resources outside the JVM on behalf of a Connection, clients should close them when they are not needed.

Capability Level: 0

Throws:
JAXRException - If the JAXR provider encounters an internal error

isClosed

boolean isClosed()
                 throws JAXRException
Indicated whether this Connection has been closed or not.

Capability Level: 0

Returns:
true if Connection is closed; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

isSynchronous

boolean isSynchronous()
                      throws JAXRException
Indicates whether a client uses synchronous communication with JAXR provider or not. A JAXR provider must support both modes of communication. A JAXR client can choose which mode it wants to use.

Capability Level: 0

Returns:
true if Connection is synchronous (default); false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

setSynchronous

void setSynchronous(boolean sync)
                    throws JAXRException
Sets whether the client uses synchronous communication or not. A JAXR client may dynamically change its communication style preference.

Capability Level: 0

Parameters:
sync - true if Connection is desired to be synchronous; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

setCredentials

void setCredentials(Set credentials)
                    throws JAXRException
Sets the Credentials associated with this client. The credentials is used to authenticate the client with the JAXR provider. A JAXR client may dynamically change its identity by changing the credentials associated with it.

Capability Level: 0

Parameters:
credentials - a Collection oj java.lang.Objects which provide identity related information for the caller.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getCredentials

Set getCredentials()
                   throws JAXRException
Gets the credentials associated with this client.

Capability Level: 0

Returns:
Set of java.lang.Object instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ConnectionFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class ConnectionFactory

java.lang.Object
    extended by  javax.xml.registry.ConnectionFactory

public abstract class ConnectionFactory
extends Object

This is the abstract base class for factory classes for creating a JAXR connection. A JAXR ConnectionFactory object is configured in a provider-specific way to create connections with registry providers.

Looking Up a ConnectionFactory Using the JNDI API

The preferred way for a client to look up a JAXR ConnectionFactory is within the Java Naming and Directory InterfaceTM (JNDI) API. A ConnectionFactory object is registered with a naming service in a provider specific way, such as one based on the JNDI API. This registration associates the ConnectionFactory object with a logical name. When an application wants to establish a connection with the provider associated with that ConnectionFactory object, it does a lookup, providing the logical name. The application can then use the ConnectionFactory object that is returned to create a connection to the messaging provider.

Looking Up a ConnectionFactory Without Using the JNDI API

The JAXR API provides an alternative way to look up a JAXR ConnectionFactory that does not require the use of the JNDI API. This is done using the newInstance static method on the abstract class ConnectionFactory provided in the JAXR API. The newInstance method returns a JAXR ConnectionFactory. The client may indicate which factory class should be instantiated by the newInstance method by defining the system property javax.xml.registry.ConnectionFactoryClass. If this property is not set, the JAXR provider must return a default ConnectionFactory instance.

Author:
Farrukh S. Najmi
See Also:
Connection

Constructor Summary
ConnectionFactory()
Method Summary
abstract Connection | createConnection() Create a named connection.
abstract FederatedConnection | createFederatedConnection(Collection connections) Create a FederatedConnection.
abstract Properties | getProperties() Gets the Properties used during createConnection and createFederatedConnection calls.
static ConnectionFactory | newInstance() Creates a default ConnectionFactory object.
abstract void | setProperties(Properties properties) Sets the Properties used during createConnection and createFederatedConnection calls.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConnectionFactory

public ConnectionFactory()
Method Detail

setProperties

public abstract void setProperties(Properties properties)
                            throws JAXRException
Sets the Properties used during createConnection and createFederatedConnection calls.

Standard Connection Properties:
javax.xml.registry.queryManagerURL - URL String for the query manager service within the target registry provider
javax.xml.registry.lifeCycleManagerURL - URL String for the life cycle manager service within the target registry provider. If unspecified, must default to value of the queryManagerURL described above
javax.xml.registry.semanticEquivalences - String that allows specification of semantic equivalences
javax.xml.registry.security.authenticationMethod - string that provides a hint to the JAXR provider on the authentication method to be used when authenticating with the registry provider. Possible value include but are not limited to "UDDI_GET_AUTHTOKEN", "HTTP_BASIC", "CLIENT_CERTIFICATE", "MS_PASSPORT"
javax.xml.registry.uddi.maxRows - integer that specifies the maximum number of rows to be returned for find operations. This property is specific for UDDI providers
javax.xml.registry.postalAddressScheme - String that specifies the id of a ClassificationScheme that is used as the default postal address scheme for this connection

Capability Level: 0

Parameters:
properties - configuration properties that are either specified by JAXR specification or are provider specific.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getProperties

public abstract Properties getProperties()
                                  throws JAXRException
Gets the Properties used during createConnection and createFederatedConnection calls.

Capability Level: 0

Returns:
the Properties defined for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

createConnection

public abstract Connection createConnection()
                                     throws JAXRException
Create a named connection. Such a connection can be used to communicate with a JAXR provider.

Capability Level: 0

Returns:
the Connection created by this call
Throws:
JAXRException - If the JAXR provider encounters an internal error

createFederatedConnection

public abstract FederatedConnection createFederatedConnection(Collection connections)
                                                       throws JAXRException
Create a FederatedConnection.

Capability Level: 0 (optional)

Parameters:
connections - Is a Collection of Connection objects. Note that Connection objects may also be FederatedConnection objects.
Returns:
the FederatedConnection created by this call
Throws:
JAXRException - If the JAXR provider encounters an internal error

newInstance

public static ConnectionFactory newInstance()
                                     throws JAXRException
Creates a default ConnectionFactory object.

Returns:
a new instance of a ConnectionFactory
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DeclarativeQueryManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface DeclarativeQueryManager

All Superinterfaces:
QueryManager
public interface DeclarativeQueryManager
extends QueryManager

This interface provides the ability to execute declarative queries (e.g. SQL)

Author:
Farrukh S. Najmi

Method Summary
Query | createQuery(int queryType, String queryString) Creates a Query object given a queryType (for example, QUERY_TYPE_SQL) and a String that represents a query in the syntax appropriate for queryType.
BulkResponse | executeQuery(Query query) Executes a query as specified by query parameter.
Methods inherited from interface javax.xml.registry.QueryManager
getRegistryObject, getRegistryObject, getRegistryObjects, getRegistryObjects, getRegistryObjects, getRegistryObjects, getRegistryService

Method Detail

createQuery

Query createQuery(int queryType,
                  String queryString)
                  throws InvalidRequestException,
                         JAXRException
Creates a Query object given a queryType (for example, QUERY_TYPE_SQL) and a String that represents a query in the syntax appropriate for queryType.

Capability Level: 1

Parameters:
queryType - the type of query
queryString - the query in its string representation
Throws:
JAXRException - If the JAXR provider encounters an internal error
InvalidRequestException - If the JAXR provider validates query syntax (optional) and the sqlQuery is not valid
See Also:
Query.QUERY_TYPE_SQL, Query.QUERY_TYPE_XQUERY, Query.QUERY_TYPE_EBXML_FILTER_QUERY

executeQuery

BulkResponse executeQuery(Query query)
                          throws JAXRException
Executes a query as specified by query parameter.

Capability Level: 1

Parameters:
query - the query to be executed
Returns:
the BulkResponse that is the result of the query
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DeleteException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class DeleteException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.registry.JAXRException
                extended by  javax.xml.registry.RegistryException
                    extended by  javax.xml.registry.DeleteException
All Implemented Interfaces:
Serializable, JAXRResponse
public class DeleteException
extends RegistryException

A RegistryException that occurs during a delete action.

Author:
Farrukh S. Najmi
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
DeleteException()
Constructs a JAXRException object with no reason or embedded Throwable.
DeleteException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
DeleteException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
DeleteException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Method Summary
Methods inherited from class javax.xml.registry.RegistryException
getErrorObjectKey, setErrorObjectKey
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DeleteException

public DeleteException()
Constructs a JAXRException object with no reason or embedded Throwable.

DeleteException

public DeleteException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

DeleteException

public DeleteException(String reason,
                       Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

DeleteException

public DeleteException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FindException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class FindException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.registry.JAXRException
                extended by  javax.xml.registry.RegistryException
                    extended by  javax.xml.registry.FindException
All Implemented Interfaces:
Serializable, JAXRResponse
public class FindException
extends RegistryException

A RegistryException that occurs during a find action.

Author:
Farrukh S. Najmi
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
FindException()
Constructs a JAXRException object with no reason or embedded Throwable.
FindException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
FindException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
FindException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Method Summary
Methods inherited from class javax.xml.registry.RegistryException
getErrorObjectKey, setErrorObjectKey
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FindException

public FindException()
Constructs a JAXRException object with no reason or embedded Throwable.

FindException

public FindException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

FindException

public FindException(String reason,
                     Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

FindException

public FindException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FindQualifier

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface FindQualifier

public interface FindQualifier

FindQualifier provides various constants that identify options that effect find method behavior. A JAXR provider may silently ignore any qualifiers marked as optional. A JAXR provider must support qualifiers not marked optional.

See Also:
BusinessQueryManager

Field Summary
static String | AND_ALL_KEYS
static String | CASE_SENSITIVE_MATCH
static String | COMBINE_CLASSIFICATIONS Maps to UDDI combineCategoryBags.
static String | EXACT_NAME_MATCH
static String | OR_ALL_KEYS
static String | OR_LIKE_KEYS
static String | SERVICE_SUBSET Maps to UDDI serviceSubset.
static String | SORT_BY_DATE_ASC
static String | SORT_BY_DATE_DESC
static String | SORT_BY_NAME_ASC
static String | SORT_BY_NAME_DESC
static String | SOUNDEX Optional qualifier that allows matching strings by their sounds.

Field Detail

EXACT_NAME_MATCH

static final String EXACT_NAME_MATCH
See Also:
Constant Field Values

CASE_SENSITIVE_MATCH

static final String CASE_SENSITIVE_MATCH
See Also:
Constant Field Values

SORT_BY_NAME_ASC

static final String SORT_BY_NAME_ASC
See Also:
Constant Field Values

SORT_BY_NAME_DESC

static final String SORT_BY_NAME_DESC
See Also:
Constant Field Values

SORT_BY_DATE_ASC

static final String SORT_BY_DATE_ASC
See Also:
Constant Field Values

SORT_BY_DATE_DESC

static final String SORT_BY_DATE_DESC
See Also:
Constant Field Values

OR_LIKE_KEYS

static final String OR_LIKE_KEYS
See Also:
Constant Field Values

OR_ALL_KEYS

static final String OR_ALL_KEYS
See Also:
Constant Field Values

COMBINE_CLASSIFICATIONS

static final String COMBINE_CLASSIFICATIONS
Maps to UDDI combineCategoryBags. Required for JAXR UDDI providers, optional for all others.

See Also:
Constant Field Values

SERVICE_SUBSET

static final String SERVICE_SUBSET
Maps to UDDI serviceSubset. Required for JAXR UDDI providers, optional for all others.

See Also:
Constant Field Values

AND_ALL_KEYS

static final String AND_ALL_KEYS
See Also:
Constant Field Values

SOUNDEX

static final String SOUNDEX
Optional qualifier that allows matching strings by their sounds.

See Also:
Constant Field Values
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


infomodel

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.registry.infomodel

This package describes the information model for the JAXR API.

See:
Description

Interface Summary
Association | A RegistryObject instance may be associated with zero or more RegistryObject instances.
AuditableEvent | AuditableEvent instances provide a long term record of events that effect a change of state in a RegistryObject.
Classification | The Classification interface is used to classify RegistryObject instances.
ClassificationScheme | A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances.
Concept | The Concept interface is used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy.
EmailAddress | Represents an email address.
ExtensibleObject | An ExtensibleObject is one that allows itself to be extended by utilizing dynamically added Slots that add arbitrary attributes to the object on a per instance basis.
ExternalIdentifier | ExternalIdentifier instances provide the additional identifier information to RegistryObjects such as DUNS number, Social Security Number, or an alias name of the organization.
ExternalLink | ExternalLink instances model a named URI to content that may reside outside the registry.
ExtrinsicObject | ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).
InternationalString | This interface represents a String that has been internationalized into several Locales.
Key | Represents a unique key that identifies a RegistryObject.
LocalizedString | This interface is used as a simple wrapper interface that associates a String with its Locale.
Organization | Organization instances provide information on organizations such as a Submitting Organization.
PersonName | Represents a person's name.
PostalAddress | PostalAddress is a simple re-usable entity class that defines attributes of a postal Address.
RegistryEntry | The RegistryEntry interface is a base interface for interfaces in the model that require additional metadata beyond what is provided by the RegistryObject interface.
RegistryObject | The RegistryObject class is an abstract base class used by most classes in the model.
RegistryPackage | RegistryPackage instances are RegistryEntries that group logically related RegistryEntries together.
Service | Service instances are RegistryObjects that provide information on services (for example, web services) offered by an Organization.
ServiceBinding | ServiceBinding instances are RegistryObjects that represent technical information on a specific way to access a specific interface offered by a Service instance.
Slot | Slot instances provide a dynamic way to add arbitrary attributes to RegistryObject instances.
SpecificationLink | A SpecificationLink provides the linkage between a ServiceBinding and one of its technical specifications that describes how to use the service using the ServiceBinding.
TelephoneNumber | A simple re-usable entity class that defines attributes of a telephone number.
URIValidator | Defines common behavior expected of any class that validates URIs.
User | User instances are RegistryObjects that are used to provide information about registered users within the registry.
Versionable | The Versionable interface defines the behavior common to classes that are capable of creating versions of their instances.

Package javax.xml.registry.infomodel Description

This package describes the information model for the JAXR API. It is based largely on the ebXML Registry Information Model with enhancements to support other registry specifications such as UDDI.

The class diagram in Figure 1 shows the public view of the information model.

Figure 1. Information Model Public View

The class diagram in Figure 2 shows the inheritance view of the information model.

Figure 2. Information Model Detailed View

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.registry.infomodel Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.registry.infomodel

Package Hierarchies:
All Packages

Interface Hierarchy

  • javax.xml.registry.infomodel.EmailAddress
  • javax.xml.registry.infomodel.ExtensibleObject
    • javax.xml.registry.infomodel.PostalAddress
    • javax.xml.registry.infomodel.RegistryObject
      • javax.xml.registry.infomodel.Association
      • javax.xml.registry.infomodel.AuditableEvent
      • javax.xml.registry.infomodel.Classification
      • javax.xml.registry.infomodel.Concept
      • javax.xml.registry.infomodel.ExternalIdentifier
      • javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.URIValidator)
      • javax.xml.registry.infomodel.Organization
      • javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.Versionable)
        • javax.xml.registry.infomodel.ClassificationScheme
        • javax.xml.registry.infomodel.ExtrinsicObject
        • javax.xml.registry.infomodel.RegistryPackage
        • javax.xml.registry.infomodel.Service
      • javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.URIValidator)
      • javax.xml.registry.infomodel.SpecificationLink
      • javax.xml.registry.infomodel.User
  • javax.xml.registry.infomodel.InternationalString
  • javax.xml.registry.infomodel.Key
  • javax.xml.registry.infomodel.LocalizedString
  • javax.xml.registry.infomodel.PersonName
  • javax.xml.registry.infomodel.Slot
  • javax.xml.registry.infomodel.TelephoneNumber
  • javax.xml.registry.infomodel.URIValidator
    • javax.xml.registry.infomodel.ExternalLink (also extends javax.xml.registry.infomodel.RegistryObject)
    • javax.xml.registry.infomodel.ServiceBinding (also extends javax.xml.registry.infomodel.RegistryObject)
  • javax.xml.registry.infomodel.Versionable
    • javax.xml.registry.infomodel.RegistryEntry (also extends javax.xml.registry.infomodel.RegistryObject)
      • javax.xml.registry.infomodel.ClassificationScheme
      • javax.xml.registry.infomodel.ExtrinsicObject
      • javax.xml.registry.infomodel.RegistryPackage
      • javax.xml.registry.infomodel.Service
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Association

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Association

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface Association
extends RegistryObject

A RegistryObject instance may be associated with zero or more RegistryObject instances. The information model defines an Association interface, an instance of which may be used to associate any two RegistryObject instances.

Example of an Association

One example of such an association is between two ClassificationScheme instances, where one ClassificationScheme supersedes the other ClassificationScheme as shown in Figure 1. This may be the case when a new version of a ClassificationScheme is submitted. In Figure 1, we see how an Association is defined between a new version of the NAICS ClassificationScheme and an older version of the NAICS ClassificationScheme.

Figure 1. Example of RegistryObject Association

Source and Target Objects

An Association instance represents an association between a source RegistryObject and a target RegistryObject. These are referred to as sourceObject and targetObject for the Association instance. It is important which object is the sourceObject and which is the targetObject as it determines the directional semantics of an Association. In the example in Figure 1, it is important to make the newer version of NAICS ClassificationScheme be the sourceObject and the older version of NAICS be the targetObject because the associationType implies that the sourceObject supersedes the targetObject (and not the other way around).

Association Types

Each Association must have an associationType attribute that identifies the type of that association. The associationType attribute is a reference to an enumeration Concept as defined by the predefined associationType ClassificationScheme in the JAXR specification. Our example uses the pre-defined associationType Concept named Supersedes.

Intramural Associations

A common use case for the Association interface is when a User "u" creates an Association "a" between two RegistryObjects "o1" and "o2" where association "a" and RegistryObjects "o1" and "o2" are objects that were created by the same User "u". This is the simplest use case where the association is between two objects that are owned by same User that is defining the Association. Such associations are referred to as intramural associations. Figure 2 extends the previous example in Figure 1 for the intramural association case.

Figure 2. Example of Intramural Association

Extramural Association

The information model also allows a more sophisticated use case where a User "u1" creates an Association "a" between two RegistryObjects "o1" and "o2" where association "a" is owned by User "u1", but RegistryObjects "o1" and "o2" are owned by User "u2" and User "u3" respectively. In this use case the Association is being defined where either or both objects that are being associated are owned by a User different from the User defining the Association. Such associations are referred to as extramural associations. The Association interface provides a convenience method called isExtramural that returns true if the Association instance is an extramural Association. Figure 3 extends the previous example in Figure 1 for the extramural association case. Note that it is possible for an extramural association to have two distinct Users rather than three distinct Users as shown in Figure 3. In such case, one of the two users owns two of the three objects involved (Association, sourceObject and targetObject).

Figure 3. Example of Extramural Association

Confirmation of an Association

An association may need to be confirmed by the parties whose objects are involved in that Association. This section describes the semantics of confirmation of an association by the parties involved.

Confirmation of Intramural Associations

Intramural associations may be viewed as declarations of truth and do not require any explicit steps to confirm that Association as being true. In other words, intramural associations are implicitly considered be confirmed.

Confirmation of Extramural Associations

Extramural associations may be viewed as a unilateral assertion that may not be viewed as truth until it has been confirmed by the other (extramural) parties (Users "u2" and "u3" in example). The confirmAssociation method on the BusinessLifeCycleManager interface may be called by the extramural parties that own the sourceObject or targetObject.

Visibility of Unconfirmed Associations

Extramural associations require each extramural party to confirm the assertion being made by the extramural Association before the Association is visible to 3rd parties that are not involved in the Association. This ensures that unconfirmed Associations are not visible to 3rd party registry clients.

Possible Confirmation States

Assume the most general case where there are three distinct User instances as shown in Figure 23 for an extramural Association. The extramural Association needs to be confirmed by both the other (extramural) parties (Users "u2" and "u3" in example) in order to be fully confirmed. The methods isConfirmedBySourceOwner and isConfiremedByTargetOwner in the Association interface provide access to confirmation state for both the sourceObject and targetObject. A third convenience method called isConfirmed provides a way to determine whether the Association is fully confirmed or not. So there are the following four possibilities related to confirmation state of an extramural Association:
  • The Association is confirmed neither by the owner of the sourceObject nor is it confirmed by owner of targetObject.
  • The Association is confirmed by the owner of the sourceObject but it is not confirmed by owner of targetObject.
  • The Association is not confirmed by the owner of the sourceObject but it is confirmed by owner of targetObject.
  • The Association is confirmed by the owner of the sourceObject and it is confirmed by owner of targetObject. This is the only state where the Association is fully confirmed.

Author:
Farrukh S. Najmi
See Also:
RegistryObject

Method Summary
Concept | getAssociationType() Gets the association type for this Association.
RegistryObject | getSourceObject() Gets the Object that is the source of this Association.
RegistryObject | getTargetObject() Gets the Object that is the target of this Association.
boolean | isConfirmed() Determines whether an Association has been confirmed completely.
boolean | isConfirmedBySourceOwner() Determines whether an Association has been confirmed by the owner of the source object.
boolean | isConfirmedByTargetOwner() Determines whether an Association has been confirmed by the owner of the target object.
boolean | isExtramural() Determines whether an Association is extramural or not.
void | setAssociationType(Concept associationType) Sets the association type for this Association.
void | setSourceObject(RegistryObject srcObject) Sets the Object that is the source of this Association.
void | setTargetObject(RegistryObject targetObject) Sets the Object that is the target of this Association.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getSourceObject

RegistryObject getSourceObject()
                               throws JAXRException
Gets the Object that is the source of this Association.

Capability Level: 0

Returns:
The RegistryObject that is the source object of this Association
Throws:
JAXRException - If the JAXR provider encounters an internal error

setSourceObject

void setSourceObject(RegistryObject srcObject)
                     throws JAXRException
Sets the Object that is the source of this Association.

Capability Level: 0

Parameters:
srcObject - the RegistryObject that is the source object of this Association
Throws:
JAXRException - If the JAXR provider encounters an internal error

getTargetObject

RegistryObject getTargetObject()
                               throws JAXRException
Gets the Object that is the target of this Association.

Capability Level: 0

Returns:
The RegistryObject that is the target object of this Association
Throws:
JAXRException - If the JAXR provider encounters an internal error

setTargetObject

void setTargetObject(RegistryObject targetObject)
                     throws JAXRException
Sets the Object that is the target of this Association.

Capability Level: 0

Parameters:
targetObject - the RegistryObject that is the target object of this Association
Throws:
JAXRException - If the JAXR provider encounters an internal error

getAssociationType

Concept getAssociationType()
                           throws JAXRException
Gets the association type for this Association.

Capability Level: 0

Returns:
The association type for this Association which is a Concept in the AssociationType ClassificationScheme
Throws:
JAXRException - If the JAXR provider encounters an internal error

setAssociationType

void setAssociationType(Concept associationType)
                        throws JAXRException
Sets the association type for this Association.

Capability Level: 0

Parameters:
associationType - the association type for this Association which is a Concept in the AssociationType ClassificationScheme
Throws:
JAXRException - If the JAXR provider encounters an internal error

isExtramural

boolean isExtramural()
                     throws JAXRException
Determines whether an Association is extramural or not.

An Extramural Association must be confirmed by the User(s) that own the source and/or targert object, if they are different from the User who creates this extramural association. Both the sourceObject and targetObject owners must confirm an extramural Association, in order for it to be visible to third parties.

Capability Level: 0

Returns:
true if the sourceObject and/or the targetObject are owned by a User that is different from the User that created the Association; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

isConfirmedBySourceOwner

boolean isConfirmedBySourceOwner()
                                 throws JAXRException
Determines whether an Association has been confirmed by the owner of the source object.

Capability Level: 0

Returns:
true if the association has been confirmed by the owner of the sourceObject; false otherwise. For intramural Associations always return true
Throws:
JAXRException - If the JAXR provider encounters an internal error

isConfirmedByTargetOwner

boolean isConfirmedByTargetOwner()
                                 throws JAXRException
Determines whether an Association has been confirmed by the owner of the target object.

Capability Level: 0

Returns:
true if the association has been confirmed by the owner of the targetObject; false otherwise. For intramural Associations always return true
Throws:
JAXRException - If the JAXR provider encounters an internal error

isConfirmed

boolean isConfirmed()
                    throws JAXRException
Determines whether an Association has been confirmed completely.

An association should only be visible to third parties (not involved with the Association) if isConfirmed returns true.

Capability Level: 0

Returns:
true if the isConfirmedBySourceOwner and isConfirmedByTargetOwner methods both return true; false otherwise. For intramural Associations always return true
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
isConfirmedBySourceOwner(), isConfirmedByTargetOwner()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AuditableEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface AuditableEvent

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface AuditableEvent
extends RegistryObject

AuditableEvent instances provide a long term record of events that effect a change of state in a RegistryObject. Such events are usually a result of a client initiated request. AuditableEvent instances are generated by the registry service to log such events.

Often such events effect a change in the life cycle of a RegistryObject. For example a client request could Create, Update, Deprecate or Delete a RegistryObject. No AuditableEvent is created for requests that do not alter the state of a RegistryObject. Specifically, read-only requests do not generate an AuditableEvent. No AuditableEvent is generated for a RegistryObject when it is classified, assigned to a Package or associated with another Object.

A RegistryObject is associated with an ordered Collection of AuditableEvent instances that provide a complete audit trail for that Object.

Author:
Farrukh S. Najmi
See Also:
RegistryObject

Field Summary
static int | EVENT_TYPE_CREATED An event where a RegistryObject is created.
static int | EVENT_TYPE_DELETED An event where a RegistryObject is deleted.
static int | EVENT_TYPE_DEPRECATED An event where a RegistryObject is deprecated.
static int | EVENT_TYPE_UNDEPRECATED An event where a RegistryObject is undeprecated.
static int | EVENT_TYPE_UPDATED An event where a RegistryObject is updated.
static int | EVENT_TYPE_VERSIONED An event where a RegistryObject is versioned.
Method Summary
int | getEventType() Gets the type of this event.
RegistryObject | getRegistryObject() Gets the RegistryObject associated with this AuditableEvent.
Timestamp | getTimestamp() Gets the Timestamp for when this event occurred.
User | getUser() Gets the User associated with this object.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Field Detail

EVENT_TYPE_CREATED

static final int EVENT_TYPE_CREATED
An event where a RegistryObject is created.

See Also:
Constant Field Values

EVENT_TYPE_DELETED

static final int EVENT_TYPE_DELETED
An event where a RegistryObject is deleted.

See Also:
Constant Field Values

EVENT_TYPE_DEPRECATED

static final int EVENT_TYPE_DEPRECATED
An event where a RegistryObject is deprecated.

See Also:
Constant Field Values

EVENT_TYPE_UPDATED

static final int EVENT_TYPE_UPDATED
An event where a RegistryObject is updated.

See Also:
Constant Field Values

EVENT_TYPE_VERSIONED

static final int EVENT_TYPE_VERSIONED
An event where a RegistryObject is versioned.

See Also:
Constant Field Values

EVENT_TYPE_UNDEPRECATED

static final int EVENT_TYPE_UNDEPRECATED
An event where a RegistryObject is undeprecated.

See Also:
Constant Field Values
Method Detail

getUser

User getUser()
             throws JAXRException
Gets the User associated with this object.

Capability Level: 1

Returns:
the User that sent the request that generated this this AuditableEvent. Must not be null
Throws:
JAXRException - If the JAXR provider encounters an internal error

getTimestamp

Timestamp getTimestamp()
                       throws JAXRException
Gets the Timestamp for when this event occurred.

Capability Level: 1

Returns:
the timestamp that records the time the event occured
Throws:
JAXRException - If the JAXR provider encounters an internal error

getEventType

int getEventType()
                 throws JAXRException
Gets the type of this event.

Capability Level: 1

Returns:
the type of this event
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
EVENT_TYPE_CREATED

getRegistryObject

RegistryObject getRegistryObject()
                                 throws JAXRException
Gets the RegistryObject associated with this AuditableEvent.

Capability Level: 1

Returns:
the RegistryObject that was the focus of this event
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Classification

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Classification

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface Classification
extends RegistryObject

The Classification interface is used to classify RegistryObject instances. A RegistryObject may be classified along multiple dimensions by adding zero or more Classification instances to the RegistryObject. For example, an Organization may be classified by its industry, by the products it sells and by its geographical location. In this example the RegistryObject would have at least three Classification instances added to it. The RegistryObject interface provides several addClassification methods to allow a client to add Classification instances to a Registry Object.

Figure 1 shows how a Classification classifies a RegistryObject using a ClassificationScheme.

Figure 1. Using a ClassificationScheme to Classify an Object

Internal vs. External Taxonomies

A taxonomy may be represented within a JAXR provider in one of the following ways:
  1. The taxonomy elements and their structural relationship with each other are available within the JAXR provider. This case is referred to as Internal Taxonomy since the structure of the taxonomy is available internal to the JAXR provider.
  2. The taxonomy elements and their structural relationship with each other is represented somewhere external to the JAXR provider. This case is referred to as External Taxonomy since the structure of the taxonomy is not available to the JAXR provider.

Internal vs. External Classifications

The Classification interface allows the classification of RegistryObjects using a ClassificationScheme whether the ClassificationScheme represents an internal taxonomy or an external taxonomy. When a Classification instance uses a ClassificationScheme representing an internal taxonomy then it is referred to as an internal Classification. When a Classification instance uses a ClassificationScheme representing an external taxonomy then it is referred to as an external Classification.

Internal Classification

When a Classification instance is used to classify a RegistryObject using an internal taxonomy it is referred to as an internal Classification. A client must call the setConcept method on a Classification and define a reference to a Concept instance from the Classification instance in order for that Classification to use an internal taxonomy. It is not necessary for the client to call setClassificationScheme for internal Classifications since the classifying Concept already knows it root ClassificationScheme.

Example of Internal Classification

Figure 2 shows an example of internal classification using a Concept to represent a taxonomy element. The example classifies an Organization instance as a Book Publisher using the NAICS standard taxonomy available as an internal taxonomy. Note that the figure does not show all the Concepts between the “Book Publishers” node and the NAICS ClassificationScheme to save space. Had they been there they would have been linked together by the parent attribute of each Concept.

Figure 2. Example of Internal Classification

External Classification

When a Classification instance is used to classify a RegistryObject using an external taxonomy it is referred to as an external Classification. A client must call the setValue method on a Classification and define a unique value that logically represents a taxonomy element within the taxonomy whose structure is defined externally. It is necessary for the client call setClassificationScheme for external Classifications since there is no other way to infer the ClassificationScheme that represents the external taxonomy.

Example of External Classification

Figure 3 shows an example of external classification. The example uses the same scenario where a Classification classifies an Organization instance as a Book Publisher using the NAICS standard taxonomy. However, this time the structure of the NAICS taxonomy is not available internally to the JAXR provider and consequently there is no Concept instance. Instead, the name and value attributes of the Classification are used to pinpoint the Book Publisher's taxonomy element. Note that name is optional but value is required.

Figure 3. Example of External Classification

An Example of Multiple Classifications

The next example shows how a RegistryObject may be classified by multiple classification schemes. In this example, two internal ClassificationSchemes named Industry and Geography are used to classify several Organization RegistryObjects by their industry and Geography. In Figure 4, in order to save space and improve readability, the Classification instances are not explicitly shown but are implied as associations between the RegistryObjects (shaded leaf node) and the associated Concepts.

Figure 4. Example of Multiple Classifications

Author:
Farrukh S. Najmi
See Also:
RegistryObject, Concept

Method Summary
ClassificationScheme | getClassificationScheme() Gets the ClassificationScheme that is used in classifying the object.
RegistryObject | getClassifiedObject() Gets the Object that is being classified.
Concept | getConcept() Gets the Concept that is classifying the object.
String | getValue() Gets the taxonomy value for this Classification.
boolean | isExternal() Returns true if this is an external classification.
void | setClassificationScheme(ClassificationScheme classificationScheme) Sets the ClassificationScheme for this external classification.
void | setClassifiedObject(RegistryObject classifiedObject) Sets the object that is being classified.
void | setConcept(Concept concept) Sets the concept for this internal classification.
void | setValue(String value) Sets the taxonomy value for this external Classification.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getConcept

Concept getConcept()
                   throws JAXRException
Gets the Concept that is classifying the object.

Capability Level: 0

Returns:
the Concept that is classifying the classified object. null if this is a external Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error

setConcept

void setConcept(Concept concept)
                throws JAXRException
Sets the concept for this internal classification.

This method should be used mutually exclusively with the setClassificationScheme method.

Capability Level: 0

Parameters:
concept - the Concept that is classifying the classified object.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getClassificationScheme

ClassificationScheme getClassificationScheme()
                                             throws JAXRException
Gets the ClassificationScheme that is used in classifying the object. If the Classification is an internal Classification then this method should return the value returned by calling the getClassificationScheme method on the Concept representing the taxonomy element.

Capability Level: 0

Returns:
the ClassificationScheme used by this Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
ClassificationScheme

setClassificationScheme

void setClassificationScheme(ClassificationScheme classificationScheme)
                             throws JAXRException
Sets the ClassificationScheme for this external classification.

If this method is called then you must also call setValue method. This method should be used mutually exclusively with the setConcept method.

Capability Level: 0

Parameters:
classificationScheme - the ClassificationScheme used by this Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error

getValue

String getValue()
                throws JAXRException
Gets the taxonomy value for this Classification.

Capability Level: 0

Returns:
the value of the taxonomy element if external Classification; the value of the Concept representing the taxonomy element if internal Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error

setValue

void setValue(String value)
              throws JAXRException
Sets the taxonomy value for this external Classification.

Capability Level: 0

Parameters:
value - the taxonomy value used by this external Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error

getClassifiedObject

RegistryObject getClassifiedObject()
                                   throws JAXRException
Gets the Object that is being classified.

Capability Level: 0

Returns:
the RegistryObject that is classified by this Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error

setClassifiedObject

void setClassifiedObject(RegistryObject classifiedObject)
                         throws JAXRException
Sets the object that is being classified.

Capability Level: 0

Parameters:
classifiedObject - the RegistryObject that is classified by this Classification
Throws:
JAXRException - If the JAXR provider encounters an internal error

isExternal

boolean isExternal()
                   throws JAXRException
Returns true if this is an external classification.

Capability Level: 0

Returns:
true if this is an external Classification; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ClassificationScheme

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface ClassificationScheme

All Superinterfaces:
ExtensibleObject, RegistryEntry, RegistryObject, Versionable
public interface ClassificationScheme
extends RegistryEntry

A ClassificationScheme instance represents a taxonomy that may be used to classify or categorize RegistryObject instances. A very common example of a classification scheme in science is the Classification of living things where living things are categorized in under a tree like structure. Another example is the Dewey Decimal system used in libraries to categorize books and other publications. A common example in eBusiness is that of North American Industry Classification System (NAICS), which is a classification scheme used to classify businesses and services by the industry to which they belong.

Figure 1 shows how a ClassificationScheme is used by a Classification to classify a RegistryObject.

Figure 1. Using a ClassificationScheme to Classify an Object

Field Summary
static int | VALUE_TYPE_EMBEDDED_PATH Each taxonomy value in ClassificationScheme embeds the full path from scheme to that Concept.
static int | VALUE_TYPE_NON_UNIQUE Taxonomy values in ClassificationScheme may be repeated within the same scheme.
static int | VALUE_TYPE_UNIQUE Each taxonomy value in ClassificationScheme is unique.
Fields inherited from interface javax.xml.registry.infomodel.RegistryEntry
STABILITY_DYNAMIC, STABILITY_DYNAMIC_COMPATIBLE, STABILITY_STATIC, STATUS_APPROVED, STATUS_DEPRECATED, STATUS_SUBMITTED, STATUS_WITHDRAWN
Method Summary
void | addChildConcept(Concept concept) Adds a child Concept.
void | addChildConcepts(Collection concepts) Adds a Collection of Concept children.
int | getChildConceptCount() Gets number of children.
Collection | getChildrenConcepts() Gets all immediate children Concepts.
Collection | getDescendantConcepts() Gets all descendant Concepts.
int | getValueType() Gets the value type for this object.
boolean | isExternal() Determines whether this ClassificationScheme is an external ClassificationScheme or an internal ClassificationScheme.
void | removeChildConcept(Concept concept) Removes a child Concept.
void | removeChildConcepts(Collection concepts) Removes a Collection of children Concepts.
void | setValueType(int valueType) Sets the value type for this object.
Methods inherited from interface javax.xml.registry.infomodel.RegistryEntry
getExpiration, getStability, getStatus, setExpiration, setStability
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.Versionable
getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

Field Detail

VALUE_TYPE_UNIQUE

static final int VALUE_TYPE_UNIQUE
Each taxonomy value in ClassificationScheme is unique.

See Also:
Constant Field Values

VALUE_TYPE_EMBEDDED_PATH

static final int VALUE_TYPE_EMBEDDED_PATH
Each taxonomy value in ClassificationScheme embeds the full path from scheme to that Concept. This also implies that each taxonomy value is unique.

See Also:
Constant Field Values

VALUE_TYPE_NON_UNIQUE

static final int VALUE_TYPE_NON_UNIQUE
Taxonomy values in ClassificationScheme may be repeated within the same scheme. However, two Concepts that have the same parent cannot have the same value.

See Also:
Constant Field Values
Method Detail

addChildConcept

void addChildConcept(Concept concept)
                     throws JAXRException
Adds a child Concept.

Capability Level: 0

Parameters:
concept - the concept being added as a child of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addChildConcepts

void addChildConcepts(Collection concepts)
                      throws JAXRException
Adds a Collection of Concept children.

Capability Level: 0

Parameters:
concepts - the Collection of Concepts being added as a children of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeChildConcept

void removeChildConcept(Concept concept)
                        throws JAXRException
Removes a child Concept.

Capability Level: 0

Parameters:
concept - the concept being removed as a child Concept of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeChildConcepts

void removeChildConcepts(Collection concepts)
                         throws JAXRException
Removes a Collection of children Concepts.

Capability Level: 0

Parameters:
concepts - the Collection of Concepts being removed as children Concepts of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getChildConceptCount

int getChildConceptCount()
                         throws JAXRException
Gets number of children.

Capability Level: 0

Returns:
the number of children Concepts
Throws:
JAXRException - If the JAXR provider encounters an internal error

getChildrenConcepts

Collection getChildrenConcepts()
                               throws JAXRException
Gets all immediate children Concepts.

Capability Level: 0

Returns:
Collection of Concept instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Concept

getDescendantConcepts

Collection getDescendantConcepts()
                                 throws JAXRException
Gets all descendant Concepts.

Capability Level: 0

Returns:
Collection of Concept instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Concept

isExternal

boolean isExternal()
                   throws JAXRException
Determines whether this ClassificationScheme is an external ClassificationScheme or an internal ClassificationScheme.

Capability Level: 0

Returns:
trueif this is an external ClassificationScheme; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

getValueType

int getValueType()
                 throws JAXRException
Gets the value type for this object. The value type describes how taxonomy values are defined within the scheme.

Capability Level: 1

Returns:
an integer constant that describes the type of values supported by this ClassificationScheme
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
VALUE_TYPE_UNIQUE, VALUE_TYPE_EMBEDDED_PATH, VALUE_TYPE_NON_UNIQUE

setValueType

void setValueType(int valueType)
                  throws JAXRException
Sets the value type for this object.

Capability Level: 1

Parameters:
valueType - an integer constant that describes the type of values supported by this ClassificationScheme
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
VALUE_TYPE_UNIQUE, VALUE_TYPE_EMBEDDED_PATH, VALUE_TYPE_NON_UNIQUE
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Concept

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Concept

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface Concept
extends RegistryObject

The Concept interface is used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy. Concept instances are used to define tree structures where the root of the tree is a ClassificationScheme instance and each node in the tree is a Concept instance. Two Concepts may be defined as being equivalent.

Figure 1 shows how Concept instances are used to represent taxonomy elements and their structural relationship with each other in order to describe an internal taxonomy.

Figure 1. Using Concepts to Represent Taxonomy Elements

Author:
Farrukh S. Najmi
See Also:
RegistryObject, Classification, ClassificationScheme

Method Summary
void | addChildConcept(Concept concept) Adds a child Concept.
void | addChildConcepts(Collection concepts) Adds a Collection of Concept children.
int | getChildConceptCount() Gets number of children.
Collection | getChildrenConcepts() Gets all immediate children Concepts.
ClassificationScheme | getClassificationScheme() Gets the ClassificationScheme that this Concept is a descendent of.
Collection | getDescendantConcepts() Gets all descendant Concepts.
RegistryObject | getParent() Gets the parent Concept or ClassificationScheme for this object.
Concept | getParentConcept() Gets the parent Concept or null if parent is a ClassificationScheme.
String | getPath() Gets the canonical path representation for this Concept.
String | getValue() Gets the value (usually a code in a taxonomy) associated with this Concept.
void | removeChildConcept(Concept concept) Removes a child Concept.
void | removeChildConcepts(Collection concepts) Removes a Collection of children Concepts.
void | setValue(String value) Sets the value (usually a taxonomy value) associated with this Concept.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getValue

String getValue()
                throws JAXRException
Gets the value (usually a code in a taxonomy) associated with this Concept.

Capability Level: 0

Returns:
the value (usually a taxonomy value) associated with this Concept
Throws:
JAXRException - If the JAXR provider encounters an internal error

setValue

void setValue(String value)
              throws JAXRException
Sets the value (usually a taxonomy value) associated with this Concept.

Capability Level: 0

Parameters:
value - the value (usually a taxonomy value) associated with this Concept
Throws:
JAXRException - If the JAXR provider encounters an internal error

addChildConcept

void addChildConcept(Concept concept)
                     throws JAXRException
Adds a child Concept.

Capability Level: 0

Parameters:
concept - the concept being added as a child of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addChildConcepts

void addChildConcepts(Collection concepts)
                      throws JAXRException
Adds a Collection of Concept children.

Capability Level: 0

Parameters:
concepts - the Collection of Concepts being added as a children of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeChildConcept

void removeChildConcept(Concept concept)
                        throws JAXRException
Removes a child Concept.

Capability Level: 0

Parameters:
concept - the concept being removed as a child Concept of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeChildConcepts

void removeChildConcepts(Collection concepts)
                         throws JAXRException
Removes a Collection of children Concepts.

Capability Level: 0

Parameters:
concepts - the Collection of Concepts being removed as children Concepts of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getChildConceptCount

int getChildConceptCount()
                         throws JAXRException
Gets number of children.

Capability Level: 0

Returns:
the number of children Concepts
Throws:
JAXRException - If the JAXR provider encounters an internal error

getChildrenConcepts

Collection getChildrenConcepts()
                               throws JAXRException
Gets all immediate children Concepts.

Capability Level: 0

Returns:
Collection of Concept instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Concept

getDescendantConcepts

Collection getDescendantConcepts()
                                 throws JAXRException
Gets all descendant Concepts.

Capability Level: 0

Returns:
Collection of Concept instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Concept

getParentConcept

Concept getParentConcept()
                         throws JAXRException
Gets the parent Concept or null if parent is a ClassificationScheme.

Capability Level: 0

Returns:
the Concept that is the parent of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getClassificationScheme

ClassificationScheme getClassificationScheme()
                                             throws JAXRException
Gets the ClassificationScheme that this Concept is a descendent of.

Capability Level: 0

Returns:
the ClassificationScheme that is the ancestor of this object. May return null
Throws:
JAXRException - If the JAXR provider encounters an internal error

getPath

String getPath()
               throws JAXRException
Gets the canonical path representation for this Concept.

Capability Level: 0

Returns:
the canonical path String representing this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getParent

RegistryObject getParent()
                         throws JAXRException
Gets the parent Concept or ClassificationScheme for this object.

Capability Level: 0

Returns:
the parent Concept or ClassificationScheme for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EmailAddress

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface EmailAddress

public interface EmailAddress

Represents an email address.

Author:
Farrukh S. Najmi
See Also:
User

Method Summary
String | getAddress() Returns the email address for this object.
String | getType() Gets the type for this object.
void | setAddress(String address) Sets the email address for this object.
void | setType(String type) Sets the type for this object.

Method Detail

getAddress

String getAddress()
                  throws JAXRException
Returns the email address for this object. Default is a NULL String.

Capability Level: 0

Returns:
the actual email address (e.g. john.doe@acme.com)
Throws:
JAXRException - If the JAXR provider encounters an internal error

setAddress

void setAddress(String address)
                throws JAXRException
Sets the email address for this object.

Capability Level: 0

Parameters:
address - the actual email address (e.g. john.doe@acme.com)
Throws:
JAXRException - If the JAXR provider encounters an internal error

getType

String getType()
               throws JAXRException
Gets the type for this object. Default is a NULL String.

Capability Level: 0

Returns:
the usage type for this object which is an arbitrary value (e.g. "Home" or "Office")
Throws:
JAXRException - If the JAXR provider encounters an internal error

setType

void setType(String type)
             throws JAXRException
Sets the type for this object.

Capability Level: 0

Parameters:
type - the usage type for this object which is an arbitrary value (e.g. "Home" or "Office")
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ExtensibleObject

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface ExtensibleObject

All Known Subinterfaces:
Association, AuditableEvent, Classification, ClassificationScheme, Concept, ExternalIdentifier, ExternalLink, ExtrinsicObject, Organization, PostalAddress, RegistryEntry, RegistryObject, RegistryPackage, Service, ServiceBinding, SpecificationLink, User
public interface ExtensibleObject

An ExtensibleObject is one that allows itself to be extended by utilizing dynamically added Slots that add arbitrary attributes to the object on a per instance basis.

Author:
Farrukh S. Najmi
See Also:
Slot

Method Summary
void | addSlot(Slot slot) Adds a Slot to this object.
void | addSlots(Collection slots) Adds more Slots to this object.
Slot | getSlot(String slotName) Gets the slot specified by slotName.
Collection | getSlots() Returns the Slots associated with this object.
void | removeSlot(String slotName) Removes a Slot from this object.
void | removeSlots(Collection slotNames) Removes specified Slots from this object.

Method Detail

addSlot

void addSlot(Slot slot)
             throws JAXRException
Adds a Slot to this object.

Capability Level: 0

Parameters:
slot - the Slot object being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addSlots

void addSlots(Collection slots)
              throws JAXRException
Adds more Slots to this object.

Capability Level: 0

Parameters:
slots - the Collection of Slot objects being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeSlot

void removeSlot(String slotName)
                throws JAXRException
Removes a Slot from this object. The Slot is identified by its name.

Capability Level: 0

Parameters:
slotName - the name for the Slot object being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeSlots

void removeSlots(Collection slotNames)
                 throws JAXRException
Removes specified Slots from this object. The Slots are identified by its name.

Capability Level: 0

Parameters:
slotNames - the Collection of names for Slot objects being removed from this object. Must be a Collection of Strings
Throws:
JAXRException - If the JAXR provider encounters an internal error

getSlot

Slot getSlot(String slotName)
             throws JAXRException
Gets the slot specified by slotName.

Capability Level: 0

Parameters:
slotName - the name of the desired Slot object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getSlots

Collection getSlots()
                    throws JAXRException
Returns the Slots associated with this object.

Capability Level: 0

Returns:
Collection of Slot instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ExternalIdentifier

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface ExternalIdentifier

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface ExternalIdentifier
extends RegistryObject

ExternalIdentifier instances provide the additional identifier information to RegistryObjects such as DUNS number, Social Security Number, or an alias name of the organization. The attribute name inherited from RegistryObject is used to contain the identification scheme ("DUNS" "Social Security Number", etc.), and the attribute value contains the actual information (e.g. the actual DUNS number). Each RegistryObject may have 0 or more ExternalIdentifiers.

Author:
Farrukh S. Najmi
See Also:
RegistryObject

Method Summary
ClassificationScheme | getIdentificationScheme() Gets the ClassificationScheme that is used as the identification scheme for identifying this object.
RegistryObject | getRegistryObject() Gets the parent RegistryObject for this ExternalIdentifier.
String | getValue() Gets the value of an ExternalIdentifier.
void | setIdentificationScheme(ClassificationScheme identificationScheme) Sets the ClassificationScheme that is used as the identification scheme for identifying this object.
void | setValue(String value) Sets the value of an ExternalIdentifier.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getRegistryObject

RegistryObject getRegistryObject()
                                 throws JAXRException
Gets the parent RegistryObject for this ExternalIdentifier. To set the registryObject call addExternalIdentifier on a RegistryObject.

Capability Level: 0

Returns:
the RegistryObject that this object identifies
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryObject.addExternalIdentifier(ExternalIdentifier ei)

getValue

String getValue()
                throws JAXRException
Gets the value of an ExternalIdentifier.

Capability Level: 0

Returns:
the identification value defined by this object (e.g. a company's DUNS number)
Throws:
JAXRException - If the JAXR provider encounters an internal error

setValue

void setValue(String value)
              throws JAXRException
Sets the value of an ExternalIdentifier.

Capability Level: 0

Parameters:
value - the identification value defined by this object (e.g. a company's DUNS number)
Throws:
JAXRException - If the JAXR provider encounters an internal error

getIdentificationScheme

ClassificationScheme getIdentificationScheme()
                                             throws JAXRException
Gets the ClassificationScheme that is used as the identification scheme for identifying this object.

Capability Level: 0

Returns:
the ClassificationScheme that is used as the identification scheme (e.g. "DUNS")
Throws:
JAXRException - If the JAXR provider encounters an internal error

setIdentificationScheme

void setIdentificationScheme(ClassificationScheme identificationScheme)
                             throws JAXRException
Sets the ClassificationScheme that is used as the identification scheme for identifying this object.

Capability Level: 0

Parameters:
identificationScheme - the ClassificationScheme that is used as the identification scheme (e.g. "DUNS")
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ExternalLink

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface ExternalLink

All Superinterfaces:
ExtensibleObject, RegistryObject, URIValidator
public interface ExternalLink
extends RegistryObject, URIValidator

ExternalLink instances model a named URI to content that may reside outside the registry. RegistryObject may be associated with any number of ExternalLinks to annotate a RegistryObject with external links to external content.

Consider the case where a Submitting Organization submits a repository item (e.g. a DTD) and wants to associate some external content to that object (e.g. the Submitting Organization's home page). The ExternalLink enables this capability.

Author:
Farrukh S. Najmi
See Also:
RegistryObject

Method Summary
String | getExternalURI() Gets URI to the an external resource.
Collection | getLinkedObjects() Gets the collection of RegistryObjects that are annotated by this ExternalLink.
void | setExternalURI(String uri) Sets URI for an external resource.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.URIValidator
getValidateURI, setValidateURI

Method Detail

getLinkedObjects

Collection getLinkedObjects()
                            throws JAXRException
Gets the collection of RegistryObjects that are annotated by this ExternalLink.

Capability Level: 0

Returns:
Collection of RegistryObjects. Return an empty Collection if no RegistryObjects are annotated by this object.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getExternalURI

String getExternalURI()
                      throws JAXRException
Gets URI to the an external resource. Default is a NULL String.

Capability Level: 0

Returns:
the URI String for this object (e.g. "http://java.sun.com")
Throws:
JAXRException - If the JAXR provider encounters an internal error

setExternalURI

void setExternalURI(String uri)
                    throws JAXRException
Sets URI for an external resource.

Capability Level: 0

Parameters:
uri - the URI String for this object (e.g. "http://java.sun.com")
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ExtrinsicObject

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface ExtrinsicObject

All Superinterfaces:
ExtensibleObject, RegistryEntry, RegistryObject, Versionable
public interface ExtrinsicObject
extends RegistryEntry

ExtrinsicObjects provide metadata that describes submitted content whose type is not intrinsically known to the registry and therefore must be described by means of additional attributes (e.g., mime type).

Examples of content described by ExtrinsicObject include Collaboration Protocol Profiles (CPP), business process descriptions, and schemas.

Author:
Farrukh S. Najmi

Field Summary
Fields inherited from interface javax.xml.registry.infomodel.RegistryEntry
STABILITY_DYNAMIC, STABILITY_DYNAMIC_COMPATIBLE, STABILITY_STATIC, STATUS_APPROVED, STATUS_DEPRECATED, STATUS_SUBMITTED, STATUS_WITHDRAWN
Method Summary
String | getMimeType() Gets the mime type associated with this object.
DataHandler | getRepositoryItem() Gets the repository item for this object.
boolean | isOpaque() Determines whether the ExtrinsicObject is opaque (not readable) by the registry operator.
void | setMimeType(String mimeType) Sets the mime type associated with this object.
void | setOpaque(boolean isOpaque) Sets whether the ExtrinsicObject is opaque (not readable) by the registry.
void | setRepositoryItem(DataHandler repositoryItem) Sets the repository item for this object.
Methods inherited from interface javax.xml.registry.infomodel.RegistryEntry
getExpiration, getStability, getStatus, setExpiration, setStability
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.Versionable
getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

Method Detail

getMimeType

String getMimeType()
                   throws JAXRException
Gets the mime type associated with this object. Default is a NULL String.

Capability Level: 1

Returns:
the mime type associated with this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setMimeType

void setMimeType(String mimeType)
                 throws JAXRException
Sets the mime type associated with this object.

Capability Level: 1

Parameters:
mimeType - the mime type associated with this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

isOpaque

boolean isOpaque()
                 throws JAXRException
Determines whether the ExtrinsicObject is opaque (not readable) by the registry operator.

In some situations, a Submitting Organization may submit content that is encrypted and not even readable by the registry. This attribute allows the registry to know whether this is the case.

Capability Level: 1

Returns:
true if the ExtrinsicObject is readable by the registry operator; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

setOpaque

void setOpaque(boolean isOpaque)
               throws JAXRException
Sets whether the ExtrinsicObject is opaque (not readable) by the registry.

Capability Level: 1

Parameters:
isOpaque - boolean value set to true if the ExtrinsicObject is readable by the registry operator; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRepositoryItem

DataHandler getRepositoryItem()
                              throws JAXRException
Gets the repository item for this object. Must not return null.

Capability Level: 1

Returns:
the DataHandler for the repository item
Throws:
JAXRException - If the JAXR provider encounters an internal error

setRepositoryItem

void setRepositoryItem(DataHandler repositoryItem)
                       throws JAXRException
Sets the repository item for this object.

Capability Level: 1

Parameters:
repositoryItem - the DataHandler for the repository item. Must not be null
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InternationalString

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface InternationalString

public interface InternationalString

This interface represents a String that has been internationalized into several Locales. This interface is used as a replacement for the String type whenever a String attribute needs to be I18N capable. An instance of the InternationalString interface composes within it a Collection of LocalizedString instances, where each String is specific to a particular Locale. The InternationalString interface provides set/get methods for adding or getting locale specific String values for the InternationalString instance.

Author:
Farrukh S. Najmi
See Also:
LocalizedString

Method Summary
 void addLocalizedString(LocalizedString localizedString)
Adds a LocalizedString to this object.
 void addLocalizedStrings(Collection localizedStrings)
Adds many LocalizedStrings to this object.
 LocalizedString getLocalizedString(Locale locale, String charsetName)
Gets the LocalizedString for the specified Locale and charsetName.
 Collection getLocalizedStrings()
Returns the LocalizedStrings associated with this object.
 String getValue()
Gets the String value for the Locale returned by Locale.getDefault().
 String getValue(Locale locale)
Gets the String value for the specified Locale.
 void removeLocalizedString(LocalizedString localizedString)
Removes a LocalizedString from this object.
 void removeLocalizedStrings(Collection localizedStrings)
Removes specified LocalizedStrings to this object.
 void setValue(Locale locale, String value)
Sets the String value for the specified Locale.
 void setValue(String value)
Sets the String value for the Locale returned by Locale.getDefault().

Method Detail

getValue

String getValue()
                throws JAXRException
Gets the String value for the Locale returned by Locale.getDefault().

Capability Level: 0

Returns:
the String value for the Locale returned by Locale.getDefault()
Throws:
JAXRException - If the JAXR provider encounters an internal error

getValue

String getValue(Locale locale)
                throws JAXRException
Gets the String value for the specified Locale. Return null if no locale specific value is found for the specified locale.

Capability Level: 0

Parameters:
locale - The Locale for the desired value
Returns:
the String value for the specified Locale
Throws:
JAXRException - If the JAXR provider encounters an internal error

setValue

void setValue(String value)
              throws JAXRException
Sets the String value for the Locale returned by Locale.getDefault().

Capability Level: 0

Parameters:
value - the String value for the Locale returned by Locale.getDefault()
Throws:
JAXRException - If the JAXR provider encounters an internal error

setValue

void setValue(Locale locale,
              String value)
              throws JAXRException
Sets the String value for the specified Locale.

Capability Level: 0

Parameters:
locale - The locale for this value being set
value - The value being set
Throws:
JAXRException - If the JAXR provider encounters an internal error

addLocalizedString

void addLocalizedString(LocalizedString localizedString)
                        throws JAXRException
Adds a LocalizedString to this object.

Capability Level: 0

Parameters:
localizedString - the LocalizedString being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addLocalizedStrings

void addLocalizedStrings(Collection localizedStrings)
                         throws JAXRException
Adds many LocalizedStrings to this object.

Capability Level: 0

Parameters:
localizedStrings - the Collection of LocalizedStrings being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeLocalizedString

void removeLocalizedString(LocalizedString localizedString)
                           throws JAXRException
Removes a LocalizedString from this object.

Capability Level: 0

Parameters:
localizedString - the LocalizedString being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeLocalizedStrings

void removeLocalizedStrings(Collection localizedStrings)
                            throws JAXRException
Removes specified LocalizedStrings to this object.

Capability Level: 0

Parameters:
localizedStrings - the Collection of LocalizedStrings being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getLocalizedString

LocalizedString getLocalizedString(Locale locale,
                                   String charsetName)
                                   throws JAXRException
Gets the LocalizedString for the specified Locale and charsetName.

Capability Level: 0

Parameters:
locale - The loacle for the desired LocalizedStrings
charsetName - The character set name for the desired LocalizedStrings
Returns:
the LocalizedString that matches specified locale and character set
Throws:
JAXRException - If the JAXR provider encounters an internal error

getLocalizedStrings

Collection getLocalizedStrings()
                               throws JAXRException
Returns the LocalizedStrings associated with this object.

Capability Level: 0

Returns:
Collection of LocalizedString instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
LocalizedString
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Key

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Key

public interface Key

Represents a unique key that identifies a RegistryObject. Must be a DCE 128 UUID.

Author:
Farrukh S. Najmi
See Also:
RegistryObject

Method Summary
String | getId() Returns the unique Id of this key.
void | setId(String id) Sets the unique id associated with this key.

Method Detail

getId

String getId()
             throws JAXRException
Returns the unique Id of this key. Default is a NULL String.

Capability Level: 0

Returns:
the id for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setId

void setId(String id)
           throws JAXRException
Sets the unique id associated with this key.

Capability Level: 0

Parameters:
id - the id being defined for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LocalizedString

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface LocalizedString

public interface LocalizedString

This interface is used as a simple wrapper interface that associates a String with its Locale. The interface is needed in the InternationalString interface where a Collection of LocalizedString instances are kept. Each LocalizedString instance has a Locale and a String instance.

Author:
Farrukh S. Najmi
See Also:
InternationalString

Field Summary
static String DEFAULT_CHARSET_NAME
The default name returned by getCharsetName if no other name has explicitly been set.
Method Summary
String | getCharsetName() Gets the canonical name for the charset for this object.
Locale | getLocale() Get the Locale for this object.
String | getValue() Get the String value for this object.
void | setCharsetName(String charsetName) Set the canonical name for the charset for this object.
void | setLocale(Locale locale) Set the Locale for this object.
void | setValue(String value) Set the String value for the specified object.

Field Detail

DEFAULT_CHARSET_NAME

static final String DEFAULT_CHARSET_NAME
The default name returned by getCharsetName if no other name has explicitly been set.

See Also:
Constant Field Values
Method Detail

getCharsetName

String getCharsetName()
                      throws JAXRException
Gets the canonical name for the charset for this object. Must return the default charset when there is no charset name defined.

Capability Level: 0

Returns:
the character set name for the character set used by this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
DEFAULT_CHARSET_NAME

getLocale

Locale getLocale()
                 throws JAXRException
Get the Locale for this object. Must return the default Locale when no Locale has been defined.

Capability Level: 0

Returns:
the Locale used by this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Locale.getDefault()

getValue

String getValue()
                throws JAXRException
Get the String value for this object.

Capability Level: 0

Returns:
the value defined by this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setCharsetName

void setCharsetName(String charsetName)
                    throws JAXRException
Set the canonical name for the charset for this object.

Capability Level: 0

Parameters:
charsetName - the character set name for the character set used by this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setLocale

void setLocale(Locale locale)
               throws JAXRException
Set the Locale for this object.

Capability Level: 0

Parameters:
locale - the Locale used by this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setValue

void setValue(String value)
              throws JAXRException
Set the String value for the specified object.

Capability Level: 0

Parameters:
value - the value defined by this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Organization

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Organization

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface Organization
extends RegistryObject

Organization instances provide information on organizations such as a Submitting Organization. Each Organization instance may have a reference to a parent Organization. In addition it may have a contact attribute defining the primary contact within the organization. An Organization also has an address attribute.

Author:
Farrukh S. Najmi
See Also:
Service

Method Summary
void | addChildOrganization(Organization organization) Adds a child Organization.
void | addChildOrganizations(Collection organizations) Adds a Collection of Organization children.
void | addService(Service service) Adds a child Service.
void | addServices(Collection services) Adds a Collection of Service children.
void | addUser(User user) Adds a User.
void | addUsers(Collection users) Adds a Collection of Users.
int | getChildOrganizationCount() Gets number of children.
Collection | getChildOrganizations() Gets all immediate children Organizations.
Collection | getDescendantOrganizations() Gets all descendant Organizations.
Organization | getParentOrganization() Gets the parent (container) organization.
PostalAddress | getPostalAddress() Gets the Address for this Organization.
User | getPrimaryContact() Gets the primary Contact for this Organization.
Organization | getRootOrganization() Gets the root organization.
Collection | getServices() Gets all children Services.
Collection | getTelephoneNumbers(String phoneType) Gets the telephone numbers for this User that match the specified telephone number type.
Collection | getUsers() Gets the Collection of Users affiliated with this Organization.
void | removeChildOrganization(Organization organization) Removes a child Organization.
void | removeChildOrganizations(Collection organizations) Removes a Collection of children Organizations.
void | removeService(Service service) Removes a Service from this object.
void | removeServices(Collection services) Removes a Collection of children Services from this object.
void | removeUser(User user) Removes a User.
void | removeUsers(Collection users) Removes a Collection of Users.
void | setPostalAddress(PostalAddress address) Sets the address for this Organization.
void | setPrimaryContact(User primaryContact) Sets the primary contact for this Organization.
void | setTelephoneNumbers(Collection phoneNumbers) Sets the various telephone numbers for this user.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getPostalAddress

PostalAddress getPostalAddress()
                               throws JAXRException
Gets the Address for this Organization.

Capability Level: 1

Returns:
the PostalAddress for this Organization
Throws:
JAXRException - If the JAXR provider encounters an internal error

setPostalAddress

void setPostalAddress(PostalAddress address)
                      throws JAXRException
Sets the address for this Organization.

Capability Level: 1

Parameters:
address - the PostalAddress for this Organization
Throws:
JAXRException - If the JAXR provider encounters an internal error

getPrimaryContact

User getPrimaryContact()
                       throws JAXRException
Gets the primary Contact for this Organization. The primary contact is one of the Users of the Organization, as returned by the getUsers call on an Organization instance.

Capability Level: 0

Returns:
the User that is the primary Contact for this Organization. Must not be null
Throws:
JAXRException - If the JAXR provider encounters an internal error

setPrimaryContact

void setPrimaryContact(User primaryContact)
                       throws JAXRException
Sets the primary contact for this Organization. If the primary contact is not in the existing Collection of User instances for this object then it must be added to that Collection. If the primary contact is already in the existing Collection of User instances for this object, then it should not be added to the Users collection as a duplicate entry. In either case, the primary contact is a distinguished User instance within the Collection of User instances for this Object.

Capability Level: 0

Parameters:
primaryContact - the User that is the primary Contact for this Organization
Throws:
JAXRException - If the JAXR provider encounters an internal error

addUser

void addUser(User user)
             throws JAXRException
Adds a User.

Capability Level: 0

Parameters:
user - the User being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addUsers

void addUsers(Collection users)
              throws JAXRException
Adds a Collection of Users.

Capability Level: 0

Parameters:
users - the Collection of Users being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeUser

void removeUser(User user)
                throws JAXRException
Removes a User.

Capability Level: 0

Parameters:
user - the User being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeUsers

void removeUsers(Collection users)
                 throws JAXRException
Removes a Collection of Users.

Capability Level: 0

Parameters:
users - the Collection of Users being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getUsers

Collection getUsers()
                    throws JAXRException
Gets the Collection of Users affiliated with this Organization. One of these users is designated as the primary contact.

Capability Level: 0

Returns:
Collection of User instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
User

getTelephoneNumbers

Collection getTelephoneNumbers(String phoneType)
                               throws JAXRException
Gets the telephone numbers for this User that match the specified telephone number type. If phoneType is null return all telephoneNumbers.

Capability Level: 0

Parameters:
phoneType - a String that specifies the type of phone numbers desired
Returns:
Collection of TelephoneNumber instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
TelephoneNumber

setTelephoneNumbers

void setTelephoneNumbers(Collection phoneNumbers)
                         throws JAXRException
Sets the various telephone numbers for this user.

Capability Level: 0

Parameters:
phoneNumbers - the TelephoneNumbers being set for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addService

void addService(Service service)
                throws JAXRException
Adds a child Service.

Capability Level: 0

Parameters:
service - the Service being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addServices

void addServices(Collection services)
                 throws JAXRException
Adds a Collection of Service children.

Capability Level: 0

Parameters:
services - the Collection of Services being added to this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeService

void removeService(Service service)
                   throws JAXRException
Removes a Service from this object.

Capability Level: 0

Parameters:
service - the Service being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeServices

void removeServices(Collection services)
                    throws JAXRException
Removes a Collection of children Services from this object.

Capability Level: 0

Parameters:
services - the Collection of Services being removed from this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getServices

Collection getServices()
                       throws JAXRException
Gets all children Services.

Capability Level: 0

Returns:
Collection of Service instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Service

addChildOrganization

void addChildOrganization(Organization organization)
                          throws JAXRException
Adds a child Organization.

Capability Level: 1

Parameters:
organization - the child Organization being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addChildOrganizations

void addChildOrganizations(Collection organizations)
                           throws JAXRException
Adds a Collection of Organization children.

Capability Level: 1

Parameters:
organizations - the Collection of child Organizations being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeChildOrganization

void removeChildOrganization(Organization organization)
                             throws JAXRException
Removes a child Organization.

Capability Level: 1

Parameters:
organization - the child Organization being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeChildOrganizations

void removeChildOrganizations(Collection organizations)
                              throws JAXRException
Removes a Collection of children Organizations.

Capability Level: 1

Parameters:
organizations - the Collection of child Organizations being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

getChildOrganizationCount

int getChildOrganizationCount()
                              throws JAXRException
Gets number of children.

Capability Level: 1

Returns:
the number of children Organizations
Throws:
JAXRException - If the JAXR provider encounters an internal error

getChildOrganizations

Collection getChildOrganizations()
                                 throws JAXRException
Gets all immediate children Organizations.

Capability Level: 1

Returns:
Collection of Organization instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Organization

getDescendantOrganizations

Collection getDescendantOrganizations()
                                      throws JAXRException
Gets all descendant Organizations.

Capability Level: 1

Returns:
Collection of Organization instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Organization

getParentOrganization

Organization getParentOrganization()
                                   throws JAXRException
Gets the parent (container) organization.

Capability Level: 1

Returns:
the parent Organization or null if object has no parent Organization
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRootOrganization

Organization getRootOrganization()
                                 throws JAXRException
Gets the root organization.

Capability Level: 1

Returns:
the root Organization or null if object has no parent Organization
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PersonName

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface PersonName

public interface PersonName

Represents a person's name.

Author:
Farrukh S. Najmi

Method Summary
String | getFirstName() Gets the first name for this Person.
String | getFullName() Gets the fully formatted name for this person.
String | getLastName() Gets the last name (surname) for this Person.
String | getMiddleName() Gets the middle name for this Person.
void | setFirstName(String firstName) Sets the first name for this Person.
void | setFullName(String fullName) Sets the fully formatted name for this person.
void | setLastName(String lastName) Sets the last name (surname) for this Person.
void | setMiddleName(String middleName) Sets the middle name for this Person.

Method Detail

getLastName

String getLastName()
                   throws JAXRException
Gets the last name (surname) for this Person. Default is a NULL String.

Capability Level: 1

Returns:
the person's last name
Throws:
JAXRException - If the JAXR provider encounters an internal error

setLastName

void setLastName(String lastName)
                 throws JAXRException
Sets the last name (surname) for this Person.

Capability Level: 1

Parameters:
lastName - the person's last name
Throws:
JAXRException - If the JAXR provider encounters an internal error

getFirstName

String getFirstName()
                    throws JAXRException
Gets the first name for this Person. Default is an empty String.

Capability Level: 1

Returns:
the person's first name
Throws:
JAXRException - If the JAXR provider encounters an internal error

setFirstName

void setFirstName(String firstName)
                  throws JAXRException
Sets the first name for this Person.

Capability Level: 1

Parameters:
firstName - the person's first name
Throws:
JAXRException - If the JAXR provider encounters an internal error

getMiddleName

String getMiddleName()
                     throws JAXRException
Gets the middle name for this Person. Default is an empty String.

Capability Level: 1

Returns:
the person's middle name
Throws:
JAXRException - If the JAXR provider encounters an internal error

setMiddleName

void setMiddleName(String middleName)
                   throws JAXRException
Sets the middle name for this Person.

Capability Level: 1

Parameters:
middleName - the person's middle name
Throws:
JAXRException - If the JAXR provider encounters an internal error

getFullName

String getFullName()
                   throws JAXRException
Gets the fully formatted name for this person. Default is an empty String.

Capability Level: 0

Returns:
the person's full name
Throws:
JAXRException - If the JAXR provider encounters an internal error

setFullName

void setFullName(String fullName)
                 throws JAXRException
Sets the fully formatted name for this person.

Capability Level: 0

Parameters:
fullName - the person's full name
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PostalAddress

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface PostalAddress

All Superinterfaces:
ExtensibleObject
public interface PostalAddress
extends ExtensibleObject

PostalAddress is a simple re-usable entity class that defines attributes of a postal Address.

Author:
Farrukh S. Najmi

Method Summary
String | getCity() Returns the city.
String | getCountry() Returns the country.
String | getPostalCode() Returns the postal or zip code.
ClassificationScheme | getPostalScheme() Returns a user-defined postal scheme for codifying the attributes of PostalAddress.
String | getStateOrProvince() Returns the state or province.
String | getStreet() Returns the street name.
String | getStreetNumber() Returns the street number.
String | getType() Returns the type of address (for example, "headquarters") as a String.
void | setCity(String city) Sets the city.
void | setCountry(String country) Sets the country.
void | setPostalCode(String postalCode) Sets the postal or zip code.
void | setPostalScheme(ClassificationScheme scheme) Sets a user-defined postal scheme for codifying the attributes of PostalAddress.
void | setStateOrProvince(String stateOrProvince) Sets the state or province.
void | setStreet(String street) Sets the street name.
void | setStreetNumber(String streetNumber) Sets the street number.
void | setType(String type) Sets the type of address (for example, "headquarters") as a String.
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getStreet

String getStreet()
                 throws JAXRException
Returns the street name. Default is an empty String.

Capability Level: 0

Returns:
the street name
Throws:
JAXRException - If the JAXR provider encounters an internal error

setStreet

void setStreet(String street)
               throws JAXRException
Sets the street name.

Capability Level: 0

Parameters:
street - the street name
Throws:
JAXRException - If the JAXR provider encounters an internal error

getStreetNumber

String getStreetNumber()
                       throws JAXRException
Returns the street number. Default is an empty String.

Capability Level: 0

Returns:
the street number
Throws:
JAXRException - If the JAXR provider encounters an internal error

setStreetNumber

void setStreetNumber(String streetNumber)
                     throws JAXRException
Sets the street number.

Capability Level: 0

Parameters:
streetNumber - the street number
Throws:
JAXRException - If the JAXR provider encounters an internal error

getCity

String getCity()
               throws JAXRException
Returns the city. Default is an empty String.

Capability Level: 0

Returns:
the city
Throws:
JAXRException - If the JAXR provider encounters an internal error

setCity

void setCity(String city)
             throws JAXRException
Sets the city.

Capability Level: 0

Parameters:
city - the city
Throws:
JAXRException - If the JAXR provider encounters an internal error

getStateOrProvince

String getStateOrProvince()
                          throws JAXRException
Returns the state or province. Default is an empty String.

Capability Level: 0

Returns:
the state or province
Throws:
JAXRException - If the JAXR provider encounters an internal error

setStateOrProvince

void setStateOrProvince(String stateOrProvince)
                        throws JAXRException
Sets the state or province.

Capability Level: 0

Parameters:
stateOrProvince - the state or province
Throws:
JAXRException - If the JAXR provider encounters an internal error

getPostalCode

String getPostalCode()
                     throws JAXRException
Returns the postal or zip code. Default is an empty String.

Capability Level: 0

Returns:
the postal code (e.g. US zip code)
Throws:
JAXRException - If the JAXR provider encounters an internal error

setPostalCode

void setPostalCode(String postalCode)
                   throws JAXRException
Sets the postal or zip code.

Capability Level: 0

Parameters:
postalCode - the postal code (e.g. US zip code)
Throws:
JAXRException - If the JAXR provider encounters an internal error

getCountry

String getCountry()
                  throws JAXRException
Returns the country. Default is an empty String.

Capability Level: 0

Returns:
the country
Throws:
JAXRException - If the JAXR provider encounters an internal error

setCountry

void setCountry(String country)
                throws JAXRException
Sets the country.

Capability Level: 0

Parameters:
country - the country
Throws:
JAXRException - If the JAXR provider encounters an internal error

getType

String getType()
               throws JAXRException
Returns the type of address (for example, "headquarters") as a String.

Capability Level: 0

Returns:
the type for this PostalAddress. This is an arbitrary String (e.g. "Home", "Office")
Throws:
JAXRException - If the JAXR provider encounters an internal error

setType

void setType(String type)
             throws JAXRException
Sets the type of address (for example, "headquarters") as a String.

Capability Level: 0

Parameters:
type - the type for this PostalAddress. This is an arbitrary String (e.g. "Home", "Office")
Throws:
JAXRException - If the JAXR provider encounters an internal error

setPostalScheme

void setPostalScheme(ClassificationScheme scheme)
                     throws JAXRException
Sets a user-defined postal scheme for codifying the attributes of PostalAddress.

Capability Level: 0

Parameters:
scheme - the user defined postal scheme.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getPostalScheme

ClassificationScheme getPostalScheme()
                                     throws JAXRException
Returns a user-defined postal scheme for codifying the attributes of PostalAddress. If none is defined for this object, then must return the default value returned by RegistryService#getDefaultPostalScheme()

Capability Level: 0

Returns:
the user defined postal scheme.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryService.getDefaultPostalScheme()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RegistryEntry

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface RegistryEntry

All Superinterfaces:
ExtensibleObject, RegistryObject, Versionable
All Known Subinterfaces:
ClassificationScheme, ExtrinsicObject, RegistryPackage, Service
public interface RegistryEntry
extends RegistryObject, Versionable

The RegistryEntry interface is a base interface for interfaces in the model that require additional metadata beyond what is provided by the RegistryObject interface. A few interfaces in the model represent high level (coarse grain) objects in the registry that require additional metadata such as version information and indication of the stability or volatility of the information.

Author:
Farrukh S. Najmi

Field Summary
static int | STABILITY_DYNAMIC RegistryEntry may change at any time.
static int | STABILITY_DYNAMIC_COMPATIBLE RegistryEntry may change at any time, however the changes will be backward compatible.
static int | STABILITY_STATIC RegistryEntry will not change.
static int | STATUS_APPROVED RegistryEntry has been submitted and approved.
static int | STATUS_DEPRECATED RegistryEntry has been deprecated.
static int | STATUS_SUBMITTED RegistryEntry has been submitted.
static int | STATUS_WITHDRAWN RegistryEntry has been withdrawn by the submitter.
Method Summary
Date | getExpiration() Gets expirationDate attribute of the RegistryEntry within the Registry.
int | getStability() Gets the stability indicator for the RegistryEntry within the Registry.
int | getStatus() Gets the life cycle status of the RegistryEntry within the registry.
void | setExpiration(Date expiration) Sets the expirationDate.
void | setStability(int stability) Sets the stability indicator for the RegistryEntry.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.Versionable
getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

Field Detail

STATUS_SUBMITTED

static final int STATUS_SUBMITTED
RegistryEntry has been submitted.

See Also:
Constant Field Values

STATUS_APPROVED

static final int STATUS_APPROVED
RegistryEntry has been submitted and approved.

See Also:
Constant Field Values

STATUS_DEPRECATED

static final int STATUS_DEPRECATED
RegistryEntry has been deprecated.

See Also:
Constant Field Values

STATUS_WITHDRAWN

static final int STATUS_WITHDRAWN
RegistryEntry has been withdrawn by the submitter.

See Also:
Constant Field Values

STABILITY_DYNAMIC

static final int STABILITY_DYNAMIC
RegistryEntry may change at any time.

See Also:
Constant Field Values

STABILITY_DYNAMIC_COMPATIBLE

static final int STABILITY_DYNAMIC_COMPATIBLE
RegistryEntry may change at any time, however the changes will be backward compatible.

See Also:
Constant Field Values

STABILITY_STATIC

static final int STABILITY_STATIC
RegistryEntry will not change.

See Also:
Constant Field Values
Method Detail

getStatus

int getStatus()
              throws JAXRException
Gets the life cycle status of the RegistryEntry within the registry.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
the life cycle status as an integer enumeration
Throws:
JAXRException - If the JAXR provider encounters an internal error

getStability

int getStability()
                 throws JAXRException
Gets the stability indicator for the RegistryEntry within the Registry. The stability indicator is provided by the submitter as an indication of the level of stability for the content.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
the stability indicator as an integer enumeration
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
STABILITY_DYNAMIC

setStability

void setStability(int stability)
                  throws JAXRException
Sets the stability indicator for the RegistryEntry.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Parameters:
stability - the stability indicator
Throws:
JAXRException - If the JAXR provider encounters an internal error

getExpiration

Date getExpiration()
                   throws JAXRException
Gets expirationDate attribute of the RegistryEntry within the Registry. This attribute defines a time limit upon the stability indication provided by the stability attribute. Once the expirationDate has been reached the stability attribute in effect becomes STABILITY_DYNAMIC implying that content can change at any time and in any manner. A null value implies that there is no expiration on stability attribute.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
the expiration Date for the stability indicator
Throws:
JAXRException - If the JAXR provider encounters an internal error

setExpiration

void setExpiration(Date expiration)
                   throws JAXRException
Sets the expirationDate.

Capability Level: 1

Parameters:
expiration - the expiration Date for the stability indicator
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RegistryObject

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface RegistryObject

All Superinterfaces:
ExtensibleObject
All Known Subinterfaces:
Association, AuditableEvent, Classification, ClassificationScheme, Concept, ExternalIdentifier, ExternalLink, ExtrinsicObject, Organization, RegistryEntry, RegistryPackage, Service, ServiceBinding, SpecificationLink, User
public interface RegistryObject
extends ExtensibleObject

The RegistryObject class is an abstract base class used by most classes in the model. It provides minimal metadata for registry objects. It also provides methods for accessing related objects that provide additional dynamic metadata for the registry object.

Author:
Farrukh S. Najmi
See Also:
RegistryEntry

Method Summary
void | addAssociation(Association association) Adds specified Association to use this object as source.
void | addAssociations(Collection associations) Adds specified Associations to use this object as source.
void | addClassification(Classification classification) Adds specified Classification to this object.
void | addClassifications(Collection classifications) Adds specified Classifications to this object.
void | addExternalIdentifier(ExternalIdentifier externalIdentifier) Adds specified ExternalIdentifier as an external identifier to this object.
void | addExternalIdentifiers(Collection externalIdentifiers) Adds specified ExternalIdentifiers as an external identifiers to this object.
void | addExternalLink(ExternalLink externalLink) Adds specified ExternalLink to this object.
void | addExternalLinks(Collection externalLinks) Adds specified ExternalLinks to this object.
Collection | getAssociatedObjects() Returns the collection of RegistryObject instances associated with this object.
Collection | getAssociations() Gets all Associations where this object is source.
Collection | getAuditTrail() Returns the complete audit trail of all requests that effected a state change in this object as an ordered Collection of AuditableEvent objects.
Collection | getClassifications() Gets the Classification instances that classify this object.
InternationalString | getDescription() Gets the textual description for this object.
Collection | getExternalIdentifiers() Returns the ExternalIdentifiers associated with this object that are external identifiers for this object.
Collection | getExternalLinks() Returns the ExternalLinks associated with this object.
Key | getKey() Gets the key representing the universally unique ID (UUID) for this object.
LifeCycleManager | getLifeCycleManager() Returns the LifeCycleManager that created this object.
InternationalString | getName() Gets the user-friendly name of this object.
Concept | getObjectType() Gets the object type that best describes the RegistryObject.
Collection | getRegistryPackages() Returns the Package associated with this object.
Organization | getSubmittingOrganization() Gets the Organization that submitted this RegistryObject.
void | removeAssociation(Association association) Removes specified Association from this object.
void | removeAssociations(Collection associations) Removes specified Associations from this object.
void | removeClassification(Classification classification) Removes specified Classification from this object.
void | removeClassifications(Collection classifications) Removes specified Classifications from this object.
void | removeExternalIdentifier(ExternalIdentifier externalIdentifier) Removes specified ExternalIdentifier as an external identifier from this object.
void | removeExternalIdentifiers(Collection externalIdentifiers) Removes specified ExternalIdentifiers as an external identifiers from this object.
void | removeExternalLink(ExternalLink externalLink) Removes specified ExternalLink from this object.
void | removeExternalLinks(Collection externalLinks) Removes specified ExternalLinks from this object.
void | setAssociations(Collection associations) Replaces all previous Associations from this object with specified Associations.
void | setClassifications(Collection classifications) Replaces all previous Classifications with specified Classifications.
void | setDescription(InternationalString description) Sets the context independent textual description for this object.
void | setExternalIdentifiers(Collection externalIdentifiers) Replaces all previous external identifiers with specified Collection of ExternalIdentifiers as an external identifier.
void | setExternalLinks(Collection externalLinks) Replaces all previous ExternalLinks with specified ExternalLinks.
void | setKey(Key key) Sets the key representing the universally unique ID (UUID) for this object.
void | setName(InternationalString name) Sets user-friendly name of object in repository.
String | toXML() Returns a registry provider specific XML representation of this Object.
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getKey

Key getKey()
           throws JAXRException
Gets the key representing the universally unique ID (UUID) for this object.

Capability Level: 0

Returns:
the Key for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getDescription

InternationalString getDescription()
                                   throws JAXRException
Gets the textual description for this object.

Capability Level: 0

Returns:
the description for this object which must not be null
Throws:
JAXRException - If the JAXR provider encounters an internal error

setDescription

void setDescription(InternationalString description)
                    throws JAXRException
Sets the context independent textual description for this object.

Capability Level: 0

Parameters:
description - the description for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getName

InternationalString getName()
                            throws JAXRException
Gets the user-friendly name of this object.

Capability Level: 0

Returns:
the name for this object which must not be null.
Throws:
JAXRException - If the JAXR provider encounters an internal error

setName

void setName(InternationalString name)
             throws JAXRException
Sets user-friendly name of object in repository.

Capability Level: 0

Parameters:
name - the name for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setKey

void setKey(Key key)
            throws JAXRException
Sets the key representing the universally unique ID (UUID) for this object.

Capability Level: 0

Parameters:
key - the key for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

toXML

String toXML()
             throws JAXRException
Returns a registry provider specific XML representation of this Object. This may be used as a last resort back door way to get to a provider specific information element that is not accessible via the API. Implementation may choose to throw a UnsupportedCapabilityException.

Capability Level: 0

Returns:
the String containing the XML representation for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addClassification

void addClassification(Classification classification)
                       throws JAXRException
Adds specified Classification to this object. Silently replaces the classifiedObject in Classification with reference to this object.

Capability Level: 0

Parameters:
classification - the Classification being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addClassifications

void addClassifications(Collection classifications)
                        throws JAXRException
Adds specified Classifications to this object. Silently replaces the classifiedObject in Classifications with reference to this object.

Capability Level: 0

Parameters:
classifications - the Collection of Classifications being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeClassification

void removeClassification(Classification classification)
                          throws JAXRException
Removes specified Classification from this object.

Capability Level: 0

Parameters:
classification - the Classification being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeClassifications

void removeClassifications(Collection classifications)
                           throws JAXRException
Removes specified Classifications from this object.

Capability Level: 0

Parameters:
classifications - the Collection of Classifications being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

setClassifications

void setClassifications(Collection classifications)
                        throws JAXRException
Replaces all previous Classifications with specified Classifications.

Capability Level: 0

Parameters:
classifications - the Collection of Classifications being set
Throws:
JAXRException - If the JAXR provider encounters an internal error

getClassifications

Collection getClassifications()
                              throws JAXRException
Gets the Classification instances that classify this object.

Capability Level: 0

Returns:
Collection of Classification instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Classification

getAuditTrail

Collection getAuditTrail()
                         throws JAXRException
Returns the complete audit trail of all requests that effected a state change in this object as an ordered Collection of AuditableEvent objects.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
Collection of AuditableEvent instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
AuditableEvent

addAssociation

void addAssociation(Association association)
                    throws JAXRException
Adds specified Association to use this object as source. Silently replaces the sourceObject in Association with reference to this object.

Capability Level: 0

Parameters:
association - the Association being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addAssociations

void addAssociations(Collection associations)
                     throws JAXRException
Adds specified Associations to use this object as source. Silently replaces the sourceObject in Associations with reference to this object.

Capability Level: 0

Parameters:
associations - the Collection of Associations being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeAssociation

void removeAssociation(Association association)
                       throws JAXRException
Removes specified Association from this object.

Capability Level: 0

Parameters:
association - the Association being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeAssociations

void removeAssociations(Collection associations)
                        throws JAXRException
Removes specified Associations from this object.

Capability Level: 0

Parameters:
associations - the Collection of Associations being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

setAssociations

void setAssociations(Collection associations)
                     throws JAXRException
Replaces all previous Associations from this object with specified Associations.

Capability Level: 0

Parameters:
associations - the Collection of Associations being set
Throws:
JAXRException - If the JAXR provider encounters an internal error

getAssociations

Collection getAssociations()
                           throws JAXRException
Gets all Associations where this object is source.

Capability Level: 0

Returns:
Collection of Association instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
Association

getAssociatedObjects

Collection getAssociatedObjects()
                                throws JAXRException
Returns the collection of RegistryObject instances associated with this object.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
Collection of RegistryObject instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryObject

addExternalIdentifier

void addExternalIdentifier(ExternalIdentifier externalIdentifier)
                           throws JAXRException
Adds specified ExternalIdentifier as an external identifier to this object. Silently replaces the registryObject in ExternalIdentifier with reference to this object.

Capability Level: 0

Parameters:
externalIdentifier - the ExternalIdentifier being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addExternalIdentifiers

void addExternalIdentifiers(Collection externalIdentifiers)
                            throws JAXRException
Adds specified ExternalIdentifiers as an external identifiers to this object. Silently replaces the registryObject in ExternalIdentifiers with reference to this object.

Capability Level: 0

Parameters:
externalIdentifiers - the Collection of ExternalIdentifiers being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeExternalIdentifier

void removeExternalIdentifier(ExternalIdentifier externalIdentifier)
                              throws JAXRException
Removes specified ExternalIdentifier as an external identifier from this object.

Capability Level: 0

Parameters:
externalIdentifier - the ExternalIdentifier being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeExternalIdentifiers

void removeExternalIdentifiers(Collection externalIdentifiers)
                               throws JAXRException
Removes specified ExternalIdentifiers as an external identifiers from this object.

Capability Level: 0

Parameters:
externalIdentifiers - the Collection of ExternalIdentifiers being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

setExternalIdentifiers

void setExternalIdentifiers(Collection externalIdentifiers)
                            throws JAXRException
Replaces all previous external identifiers with specified Collection of ExternalIdentifiers as an external identifier.

Capability Level: 0

Parameters:
externalIdentifiers - the Collection of ExternalIdentifiers being set
Throws:
JAXRException - If the JAXR provider encounters an internal error

getExternalIdentifiers

Collection getExternalIdentifiers()
                                  throws JAXRException
Returns the ExternalIdentifiers associated with this object that are external identifiers for this object.

Capability Level: 0

Returns:
Collection of ExternalIdentifier instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
ExternalIdentifier

addExternalLink

void addExternalLink(ExternalLink externalLink)
                     throws JAXRException
Adds specified ExternalLink to this object.

Capability Level: 0

Parameters:
externalLinks - the ExternalLink being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addExternalLinks

void addExternalLinks(Collection externalLinks)
                      throws JAXRException
Adds specified ExternalLinks to this object.

Capability Level: 0

Parameters:
externalLinks - the Collection of ExternalLinks being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeExternalLink

void removeExternalLink(ExternalLink externalLink)
                        throws JAXRException
Removes specified ExternalLink from this object.

Capability Level: 0

Parameters:
externalLink - the ExternalLink being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeExternalLinks

void removeExternalLinks(Collection externalLinks)
                         throws JAXRException
Removes specified ExternalLinks from this object.

Capability Level: 0

Parameters:
externalLinks - the Collection of ExternalLinks being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

setExternalLinks

void setExternalLinks(Collection externalLinks)
                      throws JAXRException
Replaces all previous ExternalLinks with specified ExternalLinks.

Capability Level: 0

Parameters:
externalLink - the Collection of ExternalLinks being set
Throws:
JAXRException - If the JAXR provider encounters an internal error

getExternalLinks

Collection getExternalLinks()
                            throws JAXRException
Returns the ExternalLinks associated with this object.

Capability Level: 0

Returns:
Collection of ExternalLink instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
ExternalLink

getObjectType

Concept getObjectType()
                      throws JAXRException
Gets the object type that best describes the RegistryObject.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
the object type as a Concept within the pre-defined ClassificationScheme named ObjectType
Throws:
JAXRException - If the JAXR provider encounters an internal error

getSubmittingOrganization

Organization getSubmittingOrganization()
                                       throws JAXRException
Gets the Organization that submitted this RegistryObject.

Returns:
the Organization that submitted this object to the registry
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryPackages

Collection getRegistryPackages()
                               throws JAXRException
Returns the Package associated with this object.

Capability Level: 1
This method must throw UnsupportedCapabilityException in lower capability levels.

Returns:
Collection of RegistryPackage instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryPackage

getLifeCycleManager

LifeCycleManager getLifeCycleManager()
                                     throws JAXRException
Returns the LifeCycleManager that created this object.

Capability Level: 0

Returns:
the LifeCycleManager objet that created this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RegistryPackage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface RegistryPackage

All Superinterfaces:
ExtensibleObject, RegistryEntry, RegistryObject, Versionable
public interface RegistryPackage
extends RegistryEntry

RegistryPackage instances are RegistryEntries that group logically related RegistryEntries together. A package may contain any number of RegistryObjects. A RegistryObject may be a member of any number of Packages.

Author:
Farrukh S. Najmi
See Also:
RegistryObject

Field Summary
Fields inherited from interface javax.xml.registry.infomodel.RegistryEntry
STABILITY_DYNAMIC, STABILITY_DYNAMIC_COMPATIBLE, STABILITY_STATIC, STATUS_APPROVED, STATUS_DEPRECATED, STATUS_SUBMITTED, STATUS_WITHDRAWN
Method Summary
void | addRegistryObject(RegistryObject registryObject) Adds a child RegistryObject as member.
void | addRegistryObjects(Collection registryObjects) Adds a Collection of RegistryObject children as members.
Set | getRegistryObjects() Gets the collection of member RegistryObjects of this RegistryPackage.
void | removeRegistryObject(RegistryObject registryObject) Removes a child RegistryObject from membership.
void | removeRegistryObjects(Collection registryObjects) Removes a Collection of children RegistryObjects from membership.
Methods inherited from interface javax.xml.registry.infomodel.RegistryEntry
getExpiration, getStability, getStatus, setExpiration, setStability
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.Versionable
getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

Method Detail

addRegistryObject

void addRegistryObject(RegistryObject registryObject)
                       throws JAXRException
Adds a child RegistryObject as member.

Capability Level: 1

Parameters:
registryObject - the RegistryObject being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addRegistryObjects

void addRegistryObjects(Collection registryObjects)
                        throws JAXRException
Adds a Collection of RegistryObject children as members.

Capability Level: 1

Parameters:
registryObjects - the Collection of RegistryObjects being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeRegistryObject

void removeRegistryObject(RegistryObject registryObject)
                          throws JAXRException
Removes a child RegistryObject from membership.

Capability Level: 1

Parameters:
registryObject - the RegistryObject being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeRegistryObjects

void removeRegistryObjects(Collection registryObjects)
                           throws JAXRException
Removes a Collection of children RegistryObjects from membership.

Capability Level: 1

Parameters:
registryObjects - the Collection of RegistryObject being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryObjects

Set getRegistryObjects()
                       throws JAXRException
Gets the collection of member RegistryObjects of this RegistryPackage.

Capability Level: 1

Returns:
the Set of RegistryObjects that are members of this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Service

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Service

All Superinterfaces:
ExtensibleObject, RegistryEntry, RegistryObject, Versionable
public interface Service
extends RegistryEntry

Service instances are RegistryObjects that provide information on services (for example, web services) offered by an Organization. A Service may have a set of ServiceBinding instances. Maps to a BusinessService in UDDI.

Author:
Farrukh S. Najmi
See Also:
ServiceBinding

Field Summary
Fields inherited from interface javax.xml.registry.infomodel.RegistryEntry
STABILITY_DYNAMIC, STABILITY_DYNAMIC_COMPATIBLE, STABILITY_STATIC, STATUS_APPROVED, STATUS_DEPRECATED, STATUS_SUBMITTED, STATUS_WITHDRAWN
Method Summary
void | addServiceBinding(ServiceBinding serviceBinding) Adds a child ServiceBinding.
void | addServiceBindings(Collection serviceBindings) Adds a Collection of ServiceBinding children.
Organization | getProvidingOrganization() Gets the Organization that provides this service.
Collection | getServiceBindings() Gets all children ServiceBindings.
void | removeServiceBinding(ServiceBinding serviceBinding) Removes a child ServiceBinding.
void | removeServiceBindings(Collection serviceBindings) Removes a Collection of children ServiceBindings.
void | setProvidingOrganization(Organization providingOrganization) Sets the Organization that provides this service.
Methods inherited from interface javax.xml.registry.infomodel.RegistryEntry
getExpiration, getStability, getStatus, setExpiration, setStability
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.Versionable
getMajorVersion, getMinorVersion, getUserVersion, setMajorVersion, setMinorVersion, setUserVersion

Method Detail

getProvidingOrganization

Organization getProvidingOrganization()
                                      throws JAXRException
Gets the Organization that provides this service. Providing Organization may be null. The providing Organization may be different from the Submitting Organization as defined by RegistryObject#getSubmittingOrganization.

Capability Level: 0

Returns:
the Organization that provides this service
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
RegistryObject.getSubmittingOrganization()

setProvidingOrganization

void setProvidingOrganization(Organization providingOrganization)
                              throws JAXRException
Sets the Organization that provides this service.

Capability Level: 0

Parameters:
providingOrganization - the Organization that provides this service
Throws:
JAXRException - If the JAXR provider encounters an internal error

addServiceBinding

void addServiceBinding(ServiceBinding serviceBinding)
                       throws JAXRException
Adds a child ServiceBinding.

Capability Level: 0

Parameters:
serviceBinding - the ServiceBinding being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addServiceBindings

void addServiceBindings(Collection serviceBindings)
                        throws JAXRException
Adds a Collection of ServiceBinding children.

Capability Level: 0

Parameters:
serviceBindings - the Collection of ServiceBindings being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeServiceBinding

void removeServiceBinding(ServiceBinding serviceBinding)
                          throws JAXRException
Removes a child ServiceBinding.

Capability Level: 0

Parameters:
serviceBinding - the ServiceBinding being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeServiceBindings

void removeServiceBindings(Collection serviceBindings)
                           throws JAXRException
Removes a Collection of children ServiceBindings.

Capability Level: 0

Parameters:
serviceBindings - the Collection of ServiceBindings being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

getServiceBindings

Collection getServiceBindings()
                              throws JAXRException
Gets all children ServiceBindings.

Capability Level: 0

Returns:
Collection of ServiceBinding instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
ServiceBinding
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServiceBinding

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface ServiceBinding

All Superinterfaces:
ExtensibleObject, RegistryObject, URIValidator
public interface ServiceBinding
extends RegistryObject, URIValidator

ServiceBinding instances are RegistryObjects that represent technical information on a specific way to access a specific interface offered by a Service instance. A ServiceBinding may have a set of SpecificationLink instances. Maps to a BindingTemplate in UDDI.

Author:
Farrukh S. Najmi
See Also:
Concept

Method Summary
void | addSpecificationLink(SpecificationLink specificationLink) Adds a child SpecificationLink.
void | addSpecificationLinks(Collection specificationLinks) Adds a Collection of SpecificationLink children.
String | getAccessURI() Gets the URI that gives access to the service via this binding.
Service | getService() Gets the parent service for which this is a binding.
Collection | getSpecificationLinks() Gets all children SpecificationLinks.
ServiceBinding | getTargetBinding() Gets the next ServiceBinding in case there is a redirection from one service provider to another service provider.
void | removeSpecificationLink(SpecificationLink specificationLink) Removes a child SpecificationLink.
void | removeSpecificationLinks(Collection specificationLinks) Removes a Collection of children SpecificationLinks.
void | setAccessURI(String uri) Sets the URI that gives access to the service via this binding.
void | setTargetBinding(ServiceBinding binding) Sets the next ServiceBinding in case there is a redirection.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots
Methods inherited from interface javax.xml.registry.infomodel.URIValidator
getValidateURI, setValidateURI

Method Detail

getAccessURI

String getAccessURI()
                    throws JAXRException
Gets the URI that gives access to the service via this binding. Default is a NULL String.

Capability Level: 0

Returns:
the URI that gives access to the service via this binding
Throws:
JAXRException - If the JAXR provider encounters an internal error

setAccessURI

void setAccessURI(String uri)
                  throws JAXRException
Sets the URI that gives access to the service via this binding. The accessURI is mutually exclusive from targetBinding. JAXR Provider must throw an InvalidRequestException if an accessURI is set when there is already a non-null targetBinding defined.

Capability Level: 0

Parameters:
uri - the URI that gives access to the service via this binding
Throws:
JAXRException - If the JAXR provider encounters an internal error

getTargetBinding

ServiceBinding getTargetBinding()
                                throws JAXRException
Gets the next ServiceBinding in case there is a redirection from one service provider to another service provider.

Capability Level: 0

Returns:
the next ServiceBinding in case there is a service redirection
Throws:
JAXRException - If the JAXR provider encounters an internal error

setTargetBinding

void setTargetBinding(ServiceBinding binding)
                      throws JAXRException
Sets the next ServiceBinding in case there is a redirection. The targetBinding is mutually exclusive from the accessURI. JAXR Provider must throw an InvalidRequestExcpetion if a targetBinding is set when there is already a non-null accessURI defined.

Capability Level: 0

Parameters:
binding - the target ServiceBinding to which this object is redirected to
Throws:
JAXRException - If the JAXR provider encounters an internal error

getService

Service getService()
                   throws JAXRException
Gets the parent service for which this is a binding.

Capability Level: 0

Returns:
the parent Service object
Throws:
JAXRException - If the JAXR provider encounters an internal error

addSpecificationLink

void addSpecificationLink(SpecificationLink specificationLink)
                          throws JAXRException
Adds a child SpecificationLink.

Capability Level: 0

Parameters:
specificationLink - the SpecificationLink being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

addSpecificationLinks

void addSpecificationLinks(Collection specificationLinks)
                           throws JAXRException
Adds a Collection of SpecificationLink children.

Capability Level: 0

Parameters:
specificationLinks - the Collection of SpecificationLinks being added
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeSpecificationLink

void removeSpecificationLink(SpecificationLink specificationLink)
                             throws JAXRException
Removes a child SpecificationLink.

Capability Level: 0

Parameters:
specificationLink - the SpecificationLink being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

removeSpecificationLinks

void removeSpecificationLinks(Collection specificationLinks)
                              throws JAXRException
Removes a Collection of children SpecificationLinks.

Capability Level: 0

Parameters:
specificationLinks - the Collection of SpecificationLinks being removed
Throws:
JAXRException - If the JAXR provider encounters an internal error

getSpecificationLinks

Collection getSpecificationLinks()
                                 throws JAXRException
Gets all children SpecificationLinks.

Capability Level: 0

Returns:
Collection of SpecificationLink instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
SpecificationLink
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Slot

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Slot

public interface Slot

Slot instances provide a dynamic way to add arbitrary attributes to RegistryObject instances. This ability to add attributes dynamically to RegistryObject instances enables extensibility within the Registry Information Model.

A RegistryObject may have 0 or more Slots. A slot is composed of a name, a slotType and a collection of values. The name of a slot is locally unique within the RegistryObject instance. Similarly, the value of a Slot is locally unique within a slot instance. Since a Slot represents an extensible attribute whose value may be a collection, a Slot is allowed to have a collection of values rather than a single value. The slotType attribute may optionally specify a type or category for the slot.

Author:
Farrukh S. Najmi
See Also:
ExtensibleObject

Field Summary
static String | ADDRESS_LINES_SLOT Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.
static String | AUTHORIZED_NAME_SLOT Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.
static String | OPERATOR_SLOT Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.
static String | SORT_CODE_SLOT Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.
Method Summary
String | getName() Gets the name for this Slot.
String | getSlotType() Gets the slotType for this Slot.
Collection | getValues() Gets the values for this Slot.
void | setName(String name) Sets the name for this Slot.
void | setSlotType(String slotType) Sets the slotType for this Slot.
void | setValues(Collection values) Sets the values for this Slot.

Field Detail

SORT_CODE_SLOT

static final String SORT_CODE_SLOT
Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.

See Also:
Constant Field Values

ADDRESS_LINES_SLOT

static final String ADDRESS_LINES_SLOT
Name for pre-defined Slot used in PostalAddress by JAXR UDDI provider.

See Also:
Constant Field Values

AUTHORIZED_NAME_SLOT

static final String AUTHORIZED_NAME_SLOT
Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.

See Also:
Constant Field Values

OPERATOR_SLOT

static final String OPERATOR_SLOT
Name for pre-defined Slot used in Organization and ClassificationScheme by JAXR UDDI provider.

See Also:
Constant Field Values
Method Detail

getName

String getName()
               throws JAXRException
Gets the name for this Slot. Default is a NULL String.

Capability Level: 0

Returns:
the name
Throws:
JAXRException - If the JAXR provider encounters an internal error

setName

void setName(String name)
             throws JAXRException
Sets the name for this Slot. Default is a NULL String.

Capability Level: 0

Parameters:
name - the name
Throws:
JAXRException - If the JAXR provider encounters an internal error

getSlotType

String getSlotType()
                   throws JAXRException
Gets the slotType for this Slot. Default is a NULL String.

Capability Level: 0

Returns:
the slot type which is an arbitrary String
Throws:
JAXRException - If the JAXR provider encounters an internal error

setSlotType

void setSlotType(String slotType)
                 throws JAXRException
Sets the slotType for this Slot.

Capability Level: 0

Parameters:
slotType - the slot type which is an arbitrary String
Throws:
JAXRException - If the JAXR provider encounters an internal error

getValues

Collection getValues()
                     throws JAXRException
Gets the values for this Slot.

Capability Level: 0

Returns:
Collection of String instances representing the values for this Slot. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
String

setValues

void setValues(Collection values)
               throws JAXRException
Sets the values for this Slot.

Capability Level: 0

Parameters:
values - the values for this Slot
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SpecificationLink

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface SpecificationLink

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface SpecificationLink
extends RegistryObject

A SpecificationLink provides the linkage between a ServiceBinding and one of its technical specifications that describes how to use the service using the ServiceBinding. For example, a ServiceBinding may have a SpecificationLink instance that describes how to access the service using a technical specification in the form of a WSDL document or a CORBA IDL document. It serves the same purpose as the union of the tModelInstanceInfo and instanceDetails structures in UDDI.

Author:
Farrukh S. Najmi
See Also:
Concept

Method Summary
ServiceBinding | getServiceBinding() Gets the parent ServiceBinding for this SpecificationLink.
RegistryObject | getSpecificationObject() Gets the specification object for this object.
InternationalString | getUsageDescription() Gets the description of usage parameters.
Collection | getUsageParameters() Gets any usage parameters.
void | setSpecificationObject(RegistryObject obj) Sets the specification object for this object.
void | setUsageDescription(InternationalString usageDescription) Sets the description of usage parameters.
void | setUsageParameters(Collection usageParameters) Sets any usage parameters.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getSpecificationObject

RegistryObject getSpecificationObject()
                                      throws JAXRException
Gets the specification object for this object.

Capability Level: 0

Returns:
the RegistryObject that is the specification object. For a UDDI provider the specification object must be a Concept with no parent. For an ebXML provider it is likely to be an ExtrinsicObject.
Throws:
JAXRException - If the JAXR provider encounters an internal error

setSpecificationObject

void setSpecificationObject(RegistryObject obj)
                            throws JAXRException
Sets the specification object for this object.

Capability Level: 0

Parameters:
obj - the RegistryObject that is the specification object. For a UDDI provider the specification object must be a Concept with no parent. For an ebXML provider it is likely to be an ExtrinsicObject.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getUsageDescription

InternationalString getUsageDescription()
                                        throws JAXRException
Gets the description of usage parameters. Default is an empty String.

Capability Level: 0

Returns:
the usage description for this object, which must not be null
Throws:
JAXRException - If the JAXR provider encounters an internal error

setUsageDescription

void setUsageDescription(InternationalString usageDescription)
                         throws JAXRException
Sets the description of usage parameters.

Capability Level: 0

Parameters:
usageDescription - the description of usage parameters for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

getUsageParameters

Collection getUsageParameters()
                              throws JAXRException
Gets any usage parameters. A usage parameter is an arbitrary String that describes how to use the technical specification accessed via this SpecificationLink. Each parameter is a String.

Capability Level: 0

Returns:
the Collection of String instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error

setUsageParameters

void setUsageParameters(Collection usageParameters)
                        throws JAXRException
Sets any usage parameters. Each parameter is a String

Capability Level: 0

Parameters:
usageParameters - the Collection of usage parameter Strings
Throws:
JAXRException - If the JAXR provider encounters an internal error

getServiceBinding

ServiceBinding getServiceBinding()
                                 throws JAXRException
Gets the parent ServiceBinding for this SpecificationLink.

Capability Level: 0

Returns:
the parent ServiceBinding within which this object is composed
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TelephoneNumber

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface TelephoneNumber

public interface TelephoneNumber

A simple re-usable entity class that defines attributes of a telephone number.

Author:
Farrukh S. Najmi

Method Summary
String | getAreaCode() Gets the area code.
String | getCountryCode() Gets the country code.
String | getExtension() Gets the internal extension.
String | getNumber() Gets the telephone number suffix, not including the country or area code.
String | getType() The type of telephone number (for example, "fax").
String | getUrl() Gets the URL that can dial this number electronically.
void | setAreaCode(String areaCode) Sets the area code.
void | setCountryCode(String countryCode) Sets country code.
void | setExtension(String extension) Sets the internal extension.
void | setNumber(String number) Sets the telephone number suffix, not including the country or area code.
void | setType(String type) Sets the type of telephone number (for example, "fax").
void | setUrl(String url) Sets the URL that can dial this number electronically.

Method Detail

getCountryCode

String getCountryCode()
                      throws JAXRException
Gets the country code. Default is an empty String.

Capability Level: 1

Returns:
the country code
Throws:
JAXRException - If the JAXR provider encounters an internal error

getAreaCode

String getAreaCode()
                   throws JAXRException
Gets the area code. Default is an empty String.

Capability Level: 1

Returns:
the area code
Throws:
JAXRException - If the JAXR provider encounters an internal error

getNumber

String getNumber()
                 throws JAXRException
Gets the telephone number suffix, not including the country or area code. Default is an empty String.

Capability Level: 0

Returns:
the telephone number
Throws:
JAXRException - If the JAXR provider encounters an internal error

getExtension

String getExtension()
                    throws JAXRException
Gets the internal extension. Default is an empty String.

Capability Level: 1

Returns:
the internal extension number
Throws:
JAXRException - If the JAXR provider encounters an internal error

getUrl

String getUrl()
              throws JAXRException
Gets the URL that can dial this number electronically. Default is a NULL String.

Capability Level: 1

Returns:
the url
Throws:
JAXRException - If the JAXR provider encounters an internal error

getType

String getType()
               throws JAXRException
The type of telephone number (for example, "fax"). Any String would do.

Capability Level: 0

Returns:
the type for this TelephoneNumber, which is an arbitrary String
Throws:
JAXRException - If the JAXR provider encounters an internal error

setCountryCode

void setCountryCode(String countryCode)
                    throws JAXRException
Sets country code.

Capability Level: 1

Parameters:
countryCode - the country code
Throws:
JAXRException - If the JAXR provider encounters an internal error

setAreaCode

void setAreaCode(String areaCode)
                 throws JAXRException
Sets the area code.

Capability Level: 1

Parameters:
areaCode - the area code
Throws:
JAXRException - If the JAXR provider encounters an internal error

setNumber

void setNumber(String number)
               throws JAXRException
Sets the telephone number suffix, not including the country or area code.

Capability Level: 0

Parameters:
number - the telephone number
Throws:
JAXRException - If the JAXR provider encounters an internal error

setExtension

void setExtension(String extension)
                  throws JAXRException
Sets the internal extension.

Capability Level: 1

Parameters:
extension - the internal extension number
Throws:
JAXRException - If the JAXR provider encounters an internal error

setUrl

void setUrl(String url)
            throws JAXRException
Sets the URL that can dial this number electronically.

Capability Level: 1

Parameters:
url - the URL string
Throws:
JAXRException - If the JAXR provider encounters an internal error

setType

void setType(String type)
             throws JAXRException
Sets the type of telephone number (for example, "fax"). Any String will do.

Capability Level: 0

Parameters:
type - the type for this TelephoneNumber, which is an arbitrary String
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


URIValidator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface URIValidator

All Known Subinterfaces:
ExternalLink, ServiceBinding
public interface URIValidator

Defines common behavior expected of any class that validates URIs.

Author:
Farrukh S. Najmi

Method Summary
boolean | getValidateURI() Gets whether to do URI validation for this object.
void | setValidateURI(boolean validate) Sets whether to do URI validation for this object.

Method Detail

setValidateURI

void setValidateURI(boolean validate)
                    throws JAXRException
Sets whether to do URI validation for this object. Default is true.

Capability Level: 0

Parameters:
validate - true implies JAXR provider must perform validation of URIs when they are set; false implies validation is turned off
Throws:
JAXRException - If the JAXR provider encounters an internal error

getValidateURI

boolean getValidateURI()
                       throws JAXRException
Gets whether to do URI validation for this object.

Capability Level: 0

Returns:
true implies JAXR provider must perform validation of URIs when they are set; false implies validation is turned off
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


User

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface User

All Superinterfaces:
ExtensibleObject, RegistryObject
public interface User
extends RegistryObject

User instances are RegistryObjects that are used to provide information about registered users within the registry. Users are affiliated with Organizations. User objects are used in the audit trail for a RegistryObject.

Author:
Farrukh S. Najmi
See Also:
Organization, AuditableEvent

Method Summary
Collection | getEmailAddresses() Gets the email addresses for this User.
Organization | getOrganization() Gets the Organization that this User is affiliated with.
PersonName | getPersonName() Returns the name of this User.
Collection | getPostalAddresses() Gets the postal address for this User.
Collection | getTelephoneNumbers(String phoneType) Gets the telephone numbers for this User that match the specified telephone number type.
String | getType() Gets the type for this User.
URL | getUrl() Gets the URL to the web page for this User.
void | setEmailAddresses(Collection emailAddresses) Sets the Collection of EmailAddress instances for this User.
void | setPersonName(PersonName personName) Sets the name of this User.
void | setPostalAddresses(Collection addresses) Sets the addresses for this User.
void | setTelephoneNumbers(Collection phoneNumbers) Sets the various telephone numbers for this user.
void | setType(String type) Sets the type for this User.
void | setUrl(URL url) Sets the URL to the web page for this User.
Methods inherited from interface javax.xml.registry.infomodel.RegistryObject
addAssociation, addAssociations, addClassification, addClassifications, addExternalIdentifier, addExternalIdentifiers, addExternalLink, addExternalLinks, getAssociatedObjects, getAssociations, getAuditTrail, getClassifications, getDescription, getExternalIdentifiers, getExternalLinks, getKey, getLifeCycleManager, getName, getObjectType, getRegistryPackages, getSubmittingOrganization, removeAssociation, removeAssociations, removeClassification, removeClassifications, removeExternalIdentifier, removeExternalIdentifiers, removeExternalLink, removeExternalLinks, setAssociations, setClassifications, setDescription, setExternalIdentifiers, setExternalLinks, setKey, setName, toXML
Methods inherited from interface javax.xml.registry.infomodel.ExtensibleObject
addSlot, addSlots, getSlot, getSlots, removeSlot, removeSlots

Method Detail

getOrganization

Organization getOrganization()
                             throws JAXRException
Gets the Organization that this User is affiliated with.

Capability Level: 0

Returns:
the Organization that this User is affiliated with
Throws:
JAXRException - If the JAXR provider encounters an internal error

getPersonName

PersonName getPersonName()
                         throws JAXRException
Returns the name of this User.

Capability Level: 0

Returns:
the name of this User
Throws:
JAXRException - If the JAXR provider encounters an internal error

setPersonName

void setPersonName(PersonName personName)
                   throws JAXRException
Sets the name of this User.

Capability Level: 0

Parameters:
personName - the name of this User
Throws:
JAXRException - If the JAXR provider encounters an internal error

getPostalAddresses

Collection getPostalAddresses()
                              throws JAXRException
Gets the postal address for this User.

Capability Level: 0

Returns:
Collection of PostalAddress instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
PostalAddress

setPostalAddresses

void setPostalAddresses(Collection addresses)
                        throws JAXRException
Sets the addresses for this User.

Capability Level: 0

Parameters:
addresses - Is a Collection of PostAddress instances.
Throws:
JAXRException - If the JAXR provider encounters an internal error

getUrl

URL getUrl()
           throws JAXRException
Gets the URL to the web page for this User.

Capability Level: 1

Returns:
the URL for this User's home page
Throws:
JAXRException - If the JAXR provider encounters an internal error

setUrl

void setUrl(URL url)
            throws JAXRException
Sets the URL to the web page for this User.

Capability Level: 1

Parameters:
url - the URL for this User's home page
Throws:
JAXRException - If the JAXR provider encounters an internal error

getTelephoneNumbers

Collection getTelephoneNumbers(String phoneType)
                               throws JAXRException
Gets the telephone numbers for this User that match the specified telephone number type.

Capability Level: 0

Parameters:
phoneType - specifies the type of phone numbers to be returned. If phoneType is null, return all telephoneNumbers
Returns:
Collection of TelephoneNumber instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
TelephoneNumber

setTelephoneNumbers

void setTelephoneNumbers(Collection phoneNumbers)
                         throws JAXRException
Sets the various telephone numbers for this user.

Capability Level: 0

Parameters:
phoneNumbers - the Collection of TelephoneNumbers to be set
Throws:
JAXRException - If the JAXR provider encounters an internal error

getEmailAddresses

Collection getEmailAddresses()
                             throws JAXRException
Gets the email addresses for this User.

Capability Level: 0

Returns:
Collection of EmailAddress instances. The Collection may be empty but not null.
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
EmailAddress

setEmailAddresses

void setEmailAddresses(Collection emailAddresses)
                       throws JAXRException
Sets the Collection of EmailAddress instances for this User.

Capability Level: 0

Parameters:
emailAddresses - the Collection of EmailAddresses to be set
Throws:
JAXRException - If the JAXR provider encounters an internal error

getType

String getType()
               throws JAXRException
Gets the type for this User. Default is a NULL String.

Capability Level: 0

Returns:
the type for this User, which is an arbitrary String
Throws:
JAXRException - If the JAXR provider encounters an internal error

setType

void setType(String type)
             throws JAXRException
Sets the type for this User.

Capability Level: 0

Parameters:
type - the type for this User, which is an arbitrary String
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Versionable

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry.infomodel
Interface Versionable

All Known Subinterfaces:
ClassificationScheme, ExtrinsicObject, RegistryEntry, RegistryPackage, Service
public interface Versionable

The Versionable interface defines the behavior common to classes that are capable of creating versions of their instances. At present all RegistryEntry classes are required to implement the Versionable interface.

Author:
Farrukh S. Najmi
See Also:
RegistryEntry

Method Summary
int | getMajorVersion() Gets the major revision number for this version of the Versionable object.
int | getMinorVersion() Gets the minor revision number for this version of the Versionable object.
String | getUserVersion() Gets the user-specified revision number for this version of the Versionable object.
void | setMajorVersion(int majorVersion) Sets the major revision number for this version of the Versionable object.
void | setMinorVersion(int minorVersion) Sets the minor revision number for this version of the Versionable object.
void | setUserVersion(String userVersion) Sets the user specified revision number for this version of the Versionable object.

Method Detail

getMajorVersion

int getMajorVersion()
                    throws JAXRException
Gets the major revision number for this version of the Versionable object.

Capability Level: 1

Returns:
the major version for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setMajorVersion

void setMajorVersion(int majorVersion)
                     throws JAXRException
Sets the major revision number for this version of the Versionable object.

Capability Level: 1

Parameters:
majorVersion - the major version number
Throws:
JAXRException - If the JAXR provider encounters an internal error

getMinorVersion

int getMinorVersion()
                    throws JAXRException
Gets the minor revision number for this version of the Versionable object.

Capability Level: 1

Returns:
the minor version for this object
Throws:
JAXRException - If the JAXR provider encounters an internal error

setMinorVersion

void setMinorVersion(int minorVersion)
                     throws JAXRException
Sets the minor revision number for this version of the Versionable object.

Capability Level: 1

Parameters:
minorVersion - the minor version number
Throws:
JAXRException - If the JAXR provider encounters an internal error

getUserVersion

String getUserVersion()
                      throws JAXRException
Gets the user-specified revision number for this version of the Versionable object.

Capability Level: 1

Returns:
the user-defined version number
Throws:
JAXRException - If the JAXR provider encounters an internal error

setUserVersion

void setUserVersion(String userVersion)
                    throws JAXRException
Sets the user specified revision number for this version of the Versionable object.

Capability Level: 1

Parameters:
userVersion - the user-defined version number
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


InvalidRequestException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class InvalidRequestException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.registry.JAXRException
                extended by  javax.xml.registry.InvalidRequestException
All Implemented Interfaces:
Serializable, JAXRResponse
public class InvalidRequestException
extends JAXRException

This exception is thrown when a JAXR client attempts to invoke an API method that is not valid for some reason.

Author:
Farrukh S. Najmi
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
InvalidRequestException()
Constructs a JAXRException object with no reason or embedded Throwable.
InvalidRequestException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
InvalidRequestException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
InvalidRequestException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Method Summary
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidRequestException

public InvalidRequestException()
Constructs a JAXRException object with no reason or embedded Throwable.

InvalidRequestException

public InvalidRequestException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

InvalidRequestException

public InvalidRequestException(String reason,
                               Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

InvalidRequestException

public InvalidRequestException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JAXRException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class JAXRException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.registry.JAXRException
All Implemented Interfaces:
Serializable, JAXRResponse
Direct Known Subclasses:
InvalidRequestException, RegistryException, UnexpectedObjectException, UnsupportedCapabilityException
public class JAXRException
extends Exception
implements JAXRResponse

Signals that a JAXR exception has occurred. It contains no members other than the standard reason String.

Author:
Nicholas Kassem, Mark Hapner, Rajiv Mordani, Farrukh Najmi
See Also:
JAXRResponse, Serialized Form

Field Summary
protected  Throwable cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
JAXRException()
Constructs a JAXRException object with no reason or embedded Throwable.
JAXRException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
JAXRException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
JAXRException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Method Summary
Throwable | getCause() Returns the Throwable embedded in this JAXRException if there is one.
String | getMessage() Returns the detail message for this JAXRException object.
String | getRequestId() Returns the unique id for the request that generated this response.
int | getStatus() Returns the status for this response.
Throwable | initCause(Throwable cause) Initializes the cause of this throwable to the specified value.
boolean | isAvailable() Returns true if a response is available, false otherwise.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

cause

protected Throwable cause
Constructor Detail

JAXRException

public JAXRException()
Constructs a JAXRException object with no reason or embedded Throwable.

JAXRException

public JAXRException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

JAXRException

public JAXRException(String reason,
                     Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

JAXRException

public JAXRException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Method Detail

getMessage

public String getMessage()
Returns the detail message for this JAXRException object.

If there is an embedded Throwable, and if the JAXRException object has no detail message of its own, this method will return the detail message from the embedded Throwable.

Overrides:
getMessage in class Throwable
Returns:
the error or warning message for this JAXRException or, if it has none, the message of the embedded Throwable, if there is one

getCause

public Throwable getCause()
Returns the Throwable embedded in this JAXRException if there is one. Otherwise, this method returns null.

Overrides:
getCause in class Throwable
Returns:
the embedded Throwable or null if there is none

initCause

public Throwable initCause(Throwable cause)
Initializes the cause of this throwable to the specified value. (The cause is the throwable that caused this throwable to get thrown.)

This method can be called at most once. It is generally called from within the constructor, or immediately after creating the throwable. If this throwable was created with JAXRException(Throwable) or JAXRException(String,Throwable), this method cannot be called even once.

Overrides:
initCause in class Throwable
Parameters:
cause - the cause (which is saved for later retrieval by the getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
Returns:
a reference to this Throwable instance.
Throws:
IllegalArgumentException - if cause is this throwable. (A throwable cannot be its own cause.)
IllegalStateException - if this throwable was created with JAXRException(Throwable) or JAXRException(String,Throwable), or this method has already been called on this throwable.

getRequestId

public String getRequestId()
Description copied from interface: JAXRResponse
Returns the unique id for the request that generated this response.

Capability Level: 0

Specified by:
getRequestId in interface JAXRResponse
Returns:
the request id

getStatus

public int getStatus()
Description copied from interface: JAXRResponse
Returns the status for this response.

Capability Level: 0

Specified by:
getStatus in interface JAXRResponse
Returns:
the status which is an integer enumerated value
See Also:
JAXRResponse.STATUS_SUCCESS

isAvailable

public boolean isAvailable()
                    throws JAXRException
Returns true if a response is available, false otherwise. This is a polling method and must not block.

Specified by:
isAvailable in interface JAXRResponse
Returns:
true if the response is available; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JAXRResponse

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface JAXRResponse

All Known Subinterfaces:
BulkResponse
All Known Implementing Classes:
DeleteException, FindException, InvalidRequestException, JAXRException, RegistryException, SaveException, UnexpectedObjectException, UnsupportedCapabilityException
public interface JAXRResponse

A JAXR requests' response.

Author:
Farrukh S. Najmi
See Also:
JAXRException

Field Summary
static int | STATUS_FAILURE Status indicating a failure response.
static int | STATUS_SUCCESS Status indicating a successful response.
static int | STATUS_UNAVAILABLE Status indicating that the results are currently unavailable.
static int | STATUS_WARNING Status indicating a successful response that included at least one warning.
Method Summary
String | getRequestId() Returns the unique id for the request that generated this response.
int | getStatus() Returns the status for this response.
boolean | isAvailable() Returns true if a response is available, false otherwise.

Field Detail

STATUS_SUCCESS

static final int STATUS_SUCCESS
Status indicating a successful response.

See Also:
Constant Field Values

STATUS_WARNING

static final int STATUS_WARNING
Status indicating a successful response that included at least one warning.

See Also:
Constant Field Values

STATUS_FAILURE

static final int STATUS_FAILURE
Status indicating a failure response.

See Also:
Constant Field Values

STATUS_UNAVAILABLE

static final int STATUS_UNAVAILABLE
Status indicating that the results are currently unavailable.

See Also:
Constant Field Values
Method Detail

getRequestId

String getRequestId()
                    throws JAXRException
Returns the unique id for the request that generated this response.

Capability Level: 0

Returns:
the request id
Throws:
JAXRException - If the JAXR provider encounters an internal error

getStatus

int getStatus()
              throws JAXRException
Returns the status for this response.

Capability Level: 0

Returns:
the status which is an integer enumerated value
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
STATUS_SUCCESS

isAvailable

boolean isAvailable()
                    throws JAXRException
Returns true if a response is available, false otherwise. This is a polling method and must not block.

Capability Level: 0

Returns:
true if the response is available; false otherwise
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LifeCycleManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface LifeCycleManager

All Known Subinterfaces:
BusinessLifeCycleManager
public interface LifeCycleManager

The LifeCycleManager interface is the main interface in the API for managing life cycle operations on objects defined by the information model.

The factory methods of this interface must throw an UnsupportedCapabilityException if the client attempts to create an instance of an infomodel interface that is not supported by the capability level of the JAXR provider.

Author:
Farrukh S. Najmi

Field Summary
static String | ASSOCIATION
static String | AUDITABLE_EVENT
static String | CLASSIFICATION
static String | CLASSIFICATION_SCHEME
static String | CONCEPT
static String | EMAIL_ADDRESS
static String | EXTERNAL_IDENTIFIER
static String | EXTERNAL_LINK
static String | EXTRINSIC_OBJECT
static String | INTERNATIONAL_STRING
static String | KEY
static String | LOCALIZED_STRING
static String | ORGANIZATION
static String | PERSON_NAME
static String | POSTAL_ADDRESS
static String | REGISTRY_ENTRY
static String | REGISTRY_PACKAGE
static String | SERVICE
static String | SERVICE_BINDING
static String | SLOT
static String | SPECIFICATION_LINK
static String | TELEPHONE_NUMBER
static String | USER
static String | VERSIONABLE
Method Summary
Association | createAssociation(RegistryObject targetObject, Concept associationType) Creates an Association instance using the specified parameters.
Classification | createClassification(ClassificationScheme scheme, InternationalString name, String value) Creates a Classification instance for an external Classification using the specified InternationalString name and String value that identify a taxonomy element within the specified ClassificationScheme.
Classification | createClassification(ClassificationScheme scheme, String name, String value) Creates a Classification instance for an external Classification using the specified String name and String value that identify a taxonomy element within the specified ClassificationScheme.
Classification | createClassification(Concept concept) Creates a Classification instance for an internal Classification using the specified Concept that identifies a taxonomy element within an internal ClassificationScheme.
ClassificationScheme | createClassificationScheme(Concept concept) Creates a ClassificationScheme from a Concept that has no ClassificationScheme or parent Concept.
ClassificationScheme | createClassificationScheme(InternationalString name, InternationalString description) Creates a ClassificationScheme given the specified InternationalString parameters.
ClassificationScheme | createClassificationScheme(String name, String description) Creates a ClassificationScheme given the specified String parameters.
Concept | createConcept(RegistryObject parent, InternationalString name, String value) Creates a Concept instance using the specified parameters, where the name is an InternationalString.
Concept | createConcept(RegistryObject parent, String name, String value) Creates a Concept instance using the specified parameters, where the name is a String.
EmailAddress | createEmailAddress(String address) Creates an EmailAddress instance using an address as the parameter.
EmailAddress | createEmailAddress(String address, String type) Creates an EmailAddress instance using both an address and a type as parameters.
ExternalIdentifier | createExternalIdentifier(ClassificationScheme identificationScheme, InternationalString name, String value) Creates an ExternalIdentifier instance using the specified parameters, where the name is an InternationalString.
ExternalIdentifier | createExternalIdentifier(ClassificationScheme identificationScheme, String name, String value) Creates an ExternalIdentifier instance using the specified parameters, where the name is a String.
ExternalLink | createExternalLink(String externalURI, InternationalString description) Creates an ExternalLink instance using the specified parameters, where the description is an InternationalString.
ExternalLink | createExternalLink(String externalURI, String description) Creates an ExternalLink instance using the specified parameters, where the description is a String.
ExtrinsicObject | createExtrinsicObject(DataHandler repositoryItem) Creates an ExtrinsicObject instance using the specified parameters.
InternationalString | createInternationalString() Creates an empty InternationalString instance.
InternationalString | createInternationalString(Locale l, String s) Creates an InternationalString instance using the specified Locale and String parameters.
InternationalString | createInternationalString(String s) Creates an InternationalString instance using a String parameter and the default Locale.
Key | createKey(String id) Creates a Key instance from an ID.
LocalizedString | createLocalizedString(Locale l, String s) Creates a LocalizedString instance using the specified Locale and String parameters.
LocalizedString | createLocalizedString(Locale l, String s, String charSetName) Creates a LocalizedString instance using the specified Locale, String, and character set parameters.
Object | createObject(String interfaceName) Creates instances of information model interfaces (factory method).
Organization | createOrganization(InternationalString name) Creates an Organization instance using the specified name, where the name is an InternationalString.
Organization | createOrganization(String name) Creates an Organization instance using the specified name, where the name is a String.
PersonName | createPersonName(String fullName) Creates a PersonName instance using the specified full name.
PersonName | createPersonName(String firstName, String middleName, String lastName) Creates a PersonName instance using the specified first, middle, and last names.
PostalAddress | createPostalAddress(String streetNumber, String street, String city, String stateOrProvince, String country, String postalCode, String type) Creates a PostalAddress instance using the specified parameters.
RegistryPackage | createRegistryPackage(InternationalString name) Creates a RegistryPackage instance using the specified name, where the name is an InternationalString.
RegistryPackage | createRegistryPackage(String name) Creates a RegistryPackage instance using the specified name, where the name is a String.
Service | createService(InternationalString name) Creates a Service instance using the specified name, where the name is an InternationalString.
Service | createService(String name) Creates a Service instance using the specified name, where the name is a String.
ServiceBinding | createServiceBinding() Creates an empty ServiceBinding instance.
Slot | createSlot(String name, Collection values, String slotType) Creates a Slot instance using the specified parameters, where the value is a Collection of Strings.
Slot | createSlot(String name, String value, String slotType) Creates a Slot instance using the specified parameters, where the value is a String.
SpecificationLink | createSpecificationLink() Creates an empty SpecificationLink instance.
TelephoneNumber | createTelephoneNumber() Creates an empty TelephoneNumber instance.
User | createUser() Creates an empty User instance.
BulkResponse | deleteObjects(Collection keys) Deletes one or more previously submitted objects from the registry using the object keys.
BulkResponse | deleteObjects(Collection keys, String objectType) Deletes one or more previously submitted objects from the registry using the object keys and a specified objectType attribute.
BulkResponse | deprecateObjects(Collection keys) Deprecates one or more previously submitted objects.
RegistryService | getRegistryService() Returns the parent RegistryService that created this object.
BulkResponse | saveObjects(Collection objects) Saves one or more Objects to the registry.
BulkResponse | unDeprecateObjects(Collection keys) Undeprecates one or more previously deprecated objects.

Field Detail

ASSOCIATION

static final String ASSOCIATION
See Also:
Constant Field Values

AUDITABLE_EVENT

static final String AUDITABLE_EVENT
See Also:
Constant Field Values

CLASSIFICATION

static final String CLASSIFICATION
See Also:
Constant Field Values

CLASSIFICATION_SCHEME

static final String CLASSIFICATION_SCHEME
See Also:
Constant Field Values

CONCEPT

static final String CONCEPT
See Also:
Constant Field Values

EMAIL_ADDRESS

static final String EMAIL_ADDRESS
See Also:
Constant Field Values

EXTERNAL_IDENTIFIER

static final String EXTERNAL_IDENTIFIER
See Also:
Constant Field Values

EXTERNAL_LINK

static final String EXTERNAL_LINK
See Also:
Constant Field Values

EXTRINSIC_OBJECT

static final String EXTRINSIC_OBJECT
See Also:
Constant Field Values

INTERNATIONAL_STRING

static final String INTERNATIONAL_STRING
See Also:
Constant Field Values

KEY

static final String KEY
See Also:
Constant Field Values

LOCALIZED_STRING

static final String LOCALIZED_STRING
See Also:
Constant Field Values

ORGANIZATION

static final String ORGANIZATION
See Also:
Constant Field Values

PERSON_NAME

static final String PERSON_NAME
See Also:
Constant Field Values

POSTAL_ADDRESS

static final String POSTAL_ADDRESS
See Also:
Constant Field Values

REGISTRY_ENTRY

static final String REGISTRY_ENTRY
See Also:
Constant Field Values

REGISTRY_PACKAGE

static final String REGISTRY_PACKAGE
See Also:
Constant Field Values

SERVICE

static final String SERVICE
See Also:
Constant Field Values

SERVICE_BINDING

static final String SERVICE_BINDING
See Also:
Constant Field Values

SLOT

static final String SLOT
See Also:
Constant Field Values

SPECIFICATION_LINK

static final String SPECIFICATION_LINK
See Also:
Constant Field Values

TELEPHONE_NUMBER

static final String TELEPHONE_NUMBER
See Also:
Constant Field Values

USER

static final String USER
See Also:
Constant Field Values

VERSIONABLE

static final String VERSIONABLE
See Also:
Constant Field Values
Method Detail

createObject

Object createObject(String interfaceName)
                    throws JAXRException,
                           InvalidRequestException,
                           UnsupportedCapabilityException
Creates instances of information model interfaces (factory method). To create an Organization, use this method as follows:
 Organization org = (Organization)
    lifeCycleMgr.createObject(LifeCycleManager.ORGANIZATION);

Capability Level: 0

Parameters:
interfaceName - the unqualified name of an interface in the javax.xml.registry.infomodel package
Returns:
an Object that can then be cast to an instance of the interface
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException - if the interface is not an interface in the javax.xml.registry.infomodel package
UnsupportedCapabilityException - if the client attempts to create an instance of an infomodel interface that is not supported by the capability level of the JAXR provider

createAssociation

Association createAssociation(RegistryObject targetObject,
                              Concept associationType)
                              throws JAXRException
Creates an Association instance using the specified parameters. The sourceObject is left null and will be set when the Association is added to a RegistryObject.

Note that for a UDDI provider an Association may only be created between Organizations.

Capability Level: 0

Parameters:
targetObject - the target RegistryObject for the association
associationType - the association type for the Association
Returns:
the Association instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createClassification

Classification createClassification(ClassificationScheme scheme,
                                    String name,
                                    String value)
                                    throws JAXRException
Creates a Classification instance for an external Classification using the specified String name and String value that identify a taxonomy element within the specified ClassificationScheme.

Capability Level: 0

Parameters:
scheme - the ClassificationScheme to be used
name - the name of the taxonomy element (a String)
value - the value of the taxonomy element
Returns:
the Classification instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createClassification

Classification createClassification(ClassificationScheme scheme,
                                    InternationalString name,
                                    String value)
                                    throws JAXRException
Creates a Classification instance for an external Classification using the specified InternationalString name and String value that identify a taxonomy element within the specified ClassificationScheme.

Capability Level: 0

Parameters:
scheme - the ClassificationScheme to be used
name - the name of the taxonomy element (an InternationalString)
value - the value of the taxonomy element
Returns:
the Classification instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createClassification

Classification createClassification(Concept concept)
                                    throws JAXRException,
                                           InvalidRequestException
Creates a Classification instance for an internal Classification using the specified Concept that identifies a taxonomy element within an internal ClassificationScheme.

Capability Level: 0

Parameters:
concept - the Concept that identifies the taxonomy element
Returns:
the Classification instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException - if the Concept is not under a ClassificationScheme

createClassificationScheme

ClassificationScheme createClassificationScheme(String name,
                                                String description)
                                                throws JAXRException,
                                                       InvalidRequestException
Creates a ClassificationScheme given the specified String parameters.

Capability Level: 0

Parameters:
name - the name of the ClassificationScheme (a String)
description - a description of the ClassificationScheme (a String)
Returns:
the ClassificationScheme instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException

createClassificationScheme

ClassificationScheme createClassificationScheme(InternationalString name,
                                                InternationalString description)
                                                throws JAXRException,
                                                       InvalidRequestException
Creates a ClassificationScheme given the specified InternationalString parameters.

Capability Level: 0

Parameters:
name - the name of the ClassificationScheme (an InternationalString)
description - a description of the ClassificationScheme (an InternationalString)
Returns:
the ClassificationScheme instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException

createClassificationScheme

ClassificationScheme createClassificationScheme(Concept concept)
                                                throws JAXRException,
                                                       InvalidRequestException
Creates a ClassificationScheme from a Concept that has no ClassificationScheme or parent Concept.

This method is a special-case method to do a type-safe conversion from Concept to ClassificationScheme.

This method is provided to allow for Concepts returned by the BusinessQueryManager findConcepts call to be safely cast to ClassificationScheme. It is up to the programmer to make sure that the Concept is indeed semantically a ClassificationScheme.

This method is necessary because in the UDDI specification a tModel may serve multiple purposes, and there is no way to know when a tModel maps to a Concept and when it maps to a ClassificationScheme. The UDDI specification leaves the determination to the programmer, and consequently so does this method.

Capability Level: 0

Parameters:
concept - the Concept to be used
Returns:
the ClassificationScheme instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error
InvalidRequestException - if the Concept has a parent Concept or is under a ClassificationScheme

createConcept

Concept createConcept(RegistryObject parent,
                      String name,
                      String value)
                      throws JAXRException
Creates a Concept instance using the specified parameters, where the name is a String.

Capability Level: 0

Parameters:
parent - a reference either to a parent ClassificationScheme or to a Concept
name - the name of the concept (a String)
value - the value of the concept
Returns:
the Concept instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createConcept

Concept createConcept(RegistryObject parent,
                      InternationalString name,
                      String value)
                      throws JAXRException
Creates a Concept instance using the specified parameters, where the name is an InternationalString.

Capability Level: 0

Parameters:
parent - a reference either to a parent ClassificationScheme or to a Concept
name - the name of the concept (an InternationalString)
value - the value of the concept
Returns:
the Concept instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createEmailAddress

EmailAddress createEmailAddress(String address)
                                throws JAXRException
Creates an EmailAddress instance using an address as the parameter.

Capability Level: 0

Parameters:
address - the email address
Returns:
the EmailAddress instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createEmailAddress

EmailAddress createEmailAddress(String address,
                                String type)
                                throws JAXRException
Creates an EmailAddress instance using both an address and a type as parameters.

Capability Level: 0

Parameters:
address - the email address
type - the type of the address
Returns:
the EmailAddress instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createExternalIdentifier

ExternalIdentifier createExternalIdentifier(ClassificationScheme identificationScheme,
                                            String name,
                                            String value)
                                            throws JAXRException
Creates an ExternalIdentifier instance using the specified parameters, where the name is a String.

Capability Level: 0

Parameters:
identificationScheme - the ClassificationScheme used
name - the name of the external identifier (a String)
value - the value of the external identifier
Returns:
the ExternalIdentifier instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createExternalIdentifier

ExternalIdentifier createExternalIdentifier(ClassificationScheme identificationScheme,
                                            InternationalString name,
                                            String value)
                                            throws JAXRException
Creates an ExternalIdentifier instance using the specified parameters, where the name is an InternationalString.

Capability Level: 0

Parameters:
identificationScheme - the ClassificationScheme used
name - the name of the external identifier (an InternationalString)
value - the value of the external identifier
Returns:
the ExternalIdentifier instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createExternalLink

ExternalLink createExternalLink(String externalURI,
                                String description)
                                throws JAXRException
Creates an ExternalLink instance using the specified parameters, where the description is a String.

Capability Level: 0

Parameters:
externalURI - the external URI
description - a description of the link (a String)
Returns:
the ExternalLink instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createExternalLink

ExternalLink createExternalLink(String externalURI,
                                InternationalString description)
                                throws JAXRException
Creates an ExternalLink instance using the specified parameters, where the description is an InternationalString.

Capability Level: 0

Parameters:
externalURI - the external URI
description - a description of the link (an InternationalString)
Returns:
the ExternalLink instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createExtrinsicObject

ExtrinsicObject createExtrinsicObject(DataHandler repositoryItem)
                                      throws JAXRException
Creates an ExtrinsicObject instance using the specified parameters.

Capability Level: 1

Parameters:
repositoryItem - the DataHandler for the repository item. Must not be null.
Returns:
the ExtrinsicObject instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createInternationalString

InternationalString createInternationalString()
                                              throws JAXRException
Creates an empty InternationalString instance.

Capability Level: 0

Returns:
the InternationalString instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createInternationalString

InternationalString createInternationalString(String s)
                                              throws JAXRException
Creates an InternationalString instance using a String parameter and the default Locale.

Capability Level: 0

Parameters:
s - the String from which to create the InternationalString
Returns:
the InternationalString instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createInternationalString

InternationalString createInternationalString(Locale l,
                                              String s)
                                              throws JAXRException
Creates an InternationalString instance using the specified Locale and String parameters.

Capability Level: 0

Parameters:
l - the Locale in which to create the InternationalString
s - the String from which to create the InternationalString
Returns:
the InternationalString instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createKey

Key createKey(String id)
              throws JAXRException
Creates a Key instance from an ID.

Capability Level: 0

Parameters:
id - the ID string from which to create the Key
Returns:
the Key instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createLocalizedString

LocalizedString createLocalizedString(Locale l,
                                      String s)
                                      throws JAXRException
Creates a LocalizedString instance using the specified Locale and String parameters.

Capability Level: 0

Parameters:
l - the Locale in which to create the LocalizedString
s - the String from which to create the LocalizedString
Returns:
the LocalizedString instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createLocalizedString

LocalizedString createLocalizedString(Locale l,
                                      String s,
                                      String charSetName)
                                      throws JAXRException
Creates a LocalizedString instance using the specified Locale, String, and character set parameters.

Capability Level: 0

Parameters:
l - the Locale in which to create the LocalizedString
s - the String from which to create the LocalizedString
charSetName - the name of the character set to use
Returns:
the LocalizedString instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createOrganization

Organization createOrganization(String name)
                                throws JAXRException
Creates an Organization instance using the specified name, where the name is a String.

Capability Level: 0

Parameters:
name - the name of the Organization
Returns:
the Organization instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createOrganization

Organization createOrganization(InternationalString name)
                                throws JAXRException
Creates an Organization instance using the specified name, where the name is an InternationalString.

Capability Level: 0

Parameters:
name - the name of the Organization
Returns:
the Organization instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createPersonName

PersonName createPersonName(String firstName,
                            String middleName,
                            String lastName)
                            throws JAXRException
Creates a PersonName instance using the specified first, middle, and last names.

Capability Level: 1

Parameters:
firstName - the person's first name
middleName - the person's middle name
lastName - the person's last name
Returns:
the PersonName instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createPersonName

PersonName createPersonName(String fullName)
                            throws JAXRException
Creates a PersonName instance using the specified full name.

Capability Level: 0

Parameters:
fullName - the person's full name
Returns:
the PersonName instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createPostalAddress

PostalAddress createPostalAddress(String streetNumber,
                                  String street,
                                  String city,
                                  String stateOrProvince,
                                  String country,
                                  String postalCode,
                                  String type)
                                  throws JAXRException
Creates a PostalAddress instance using the specified parameters.

Capability Level: 0

Parameters:
streetNumber - the street number
street - the street name
city - the city name
stateOrProvince - the state or province name
country - the country name
postalCode - the postal code (such as a US ZIP code)
type - the type of the address
Returns:
the PostalAddress instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createRegistryPackage

RegistryPackage createRegistryPackage(String name)
                                      throws JAXRException
Creates a RegistryPackage instance using the specified name, where the name is a String.

Capability Level: 1

Parameters:
name - the name of the registry package (a String)
Returns:
the RegistryPackage instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createRegistryPackage

RegistryPackage createRegistryPackage(InternationalString name)
                                      throws JAXRException
Creates a RegistryPackage instance using the specified name, where the name is an InternationalString.

Capability Level: 1

Parameters:
name - the name of the registry package (an InternationalString)
Returns:
the RegistryPackage instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createService

Service createService(String name)
                      throws JAXRException
Creates a Service instance using the specified name, where the name is a String.

Capability Level: 0

Parameters:
name - the name of the Service (a String)
Returns:
the Service instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createService

Service createService(InternationalString name)
                      throws JAXRException
Creates a Service instance using the specified name, where the name is an InternationalString.

Capability Level: 0

Parameters:
name - the name of the Service (an InternationalString)
Returns:
the Service instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createServiceBinding

ServiceBinding createServiceBinding()
                                    throws JAXRException
Creates an empty ServiceBinding instance.

Capability Level: 0

Returns:
the ServiceBinding instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createSlot

Slot createSlot(String name,
                String value,
                String slotType)
                throws JAXRException
Creates a Slot instance using the specified parameters, where the value is a String.

Capability Level: 0

Parameters:
name - the name of the Slot
value - the value (a String)
slotType - the slot type
Returns:
the Slot instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createSlot

Slot createSlot(String name,
                Collection values,
                String slotType)
                throws JAXRException
Creates a Slot instance using the specified parameters, where the value is a Collection of Strings.

Capability Level: 0

Parameters:
name - the name of the Slot
value - the value (a Collection of Strings)
slotType - the slot type
Returns:
the Slot instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createSpecificationLink

SpecificationLink createSpecificationLink()
                                          throws JAXRException
Creates an empty SpecificationLink instance.

Capability Level: 0

Returns:
the SpecificationLink instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createTelephoneNumber

TelephoneNumber createTelephoneNumber()
                                      throws JAXRException
Creates an empty TelephoneNumber instance.

Capability Level: 0

Returns:
the TelephoneNumber instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

createUser

User createUser()
                throws JAXRException
Creates an empty User instance.

Capability Level: 0

Returns:
the User instance created
Throws:
JAXRException - if the JAXR provider encounters an internal error

saveObjects

BulkResponse saveObjects(Collection objects)
                         throws JAXRException
Saves one or more Objects to the registry. An object may be a RegistryObject subclass instance.

If an object is not in the registry, it is created in the registry. If it already exists in the registry and has been modified, then its state is updated (replaced) in the registry.

Capability Level: 0

Parameters:
objects - a potentially heterogeneous Collection of RegistryObject instances
Returns:
a BulkResponse containing the Collection of keys for those objects that were saved successfully and any SaveException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deprecateObjects

BulkResponse deprecateObjects(Collection keys)
                              throws JAXRException
Deprecates one or more previously submitted objects. Deprecation marks an object as "soon to be deleted". Once an object is deprecated, the JAXR provider must not allow any new references (e.g. new Associations, Classifications and ExternalLinks) to that object to be submitted. If a client makes an API call that results in a new reference to a deprecated object, the JAXR provider must throw a java.lang.IllegalStateException within a JAXRException. However, existing references to a deprecated object continue to function normally.

Capability Level: 1

Parameters:
keys - a Collection of keys for the objects to be deprecated
Returns:
a BulkResponse containing the Collection of keys for those objects that were deprecated successfully and any JAXRException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

unDeprecateObjects

BulkResponse unDeprecateObjects(Collection keys)
                                throws JAXRException
Undeprecates one or more previously deprecated objects. If an object was not previously deprecated, it is not an error, and no exception is thrown. Once an object is undeprecated, the JAXR provider must again allow new references (e.g. new Associations, Classifications and ExternalLinks) to that object to be submitted.

Capability Level: 1

Parameters:
keys - a Collection of keys for the objects to be undeprecated
Returns:
a BulkResponse containing the Collection of keys for those objects that were deprecated successfully and any JAXRException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteObjects

BulkResponse deleteObjects(Collection keys)
                           throws JAXRException
Deletes one or more previously submitted objects from the registry using the object keys.

Capability Level: 1

Parameters:
keys - a Collection of keys for the objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

deleteObjects

BulkResponse deleteObjects(Collection keys,
                           String objectType)
                           throws JAXRException
Deletes one or more previously submitted objects from the registry using the object keys and a specified objectType attribute.

Capability Level: 0

Parameters:
keys - a Collection of keys for the objects to be deleted
objectType - the objectType attribute for the objects to be deleted
Returns:
a BulkResponse containing the Collection of keys for those objects that were deleted successfully and any DeleteException that was encountered in case of partial commit
Throws:
JAXRException - if the JAXR provider encounters an internal error

getRegistryService

RegistryService getRegistryService()
                                   throws JAXRException
Returns the parent RegistryService that created this object.

Capability Level: 0

Returns:
the parent RegistryService
Throws:
JAXRException - if the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Query

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface Query

public interface Query

The Query interface encapsulates a query in a declarative query language. Currently a Query can be an SQL query or an ebXML Filter Query only. In future support for other query languages such as XQL query may be added. The query must conform to a fixed schema as defined by the JAXR specification.

Author:
Farrukh S. Najmi

Field Summary
static int | QUERY_TYPE_EBXML_FILTER_QUERY An OASIS ebXML Registry XML Filter Query type.
static int | QUERY_TYPE_SQL An SQL query type.
static int | QUERY_TYPE_XQUERY A W3C XQuery type.
Method Summary
int | getType() Gets the type of Query (for example, QUERY_TYPE_SQL).
String | toString() Returns the String representing the query.

Field Detail

QUERY_TYPE_SQL

static final int QUERY_TYPE_SQL
An SQL query type.

See Also:
Constant Field Values

QUERY_TYPE_XQUERY

static final int QUERY_TYPE_XQUERY
A W3C XQuery type.

See Also:
Constant Field Values

QUERY_TYPE_EBXML_FILTER_QUERY

static final int QUERY_TYPE_EBXML_FILTER_QUERY
An OASIS ebXML Registry XML Filter Query type.

See Also:
Constant Field Values
Method Detail

getType

int getType()
            throws JAXRException
Gets the type of Query (for example, QUERY_TYPE_SQL).

Capability Level: 1

Returns:
the type of query
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
QUERY_TYPE_SQL, QUERY_TYPE_XQUERY, QUERY_TYPE_EBXML_FILTER_QUERY

toString

String toString()
Returns the String representing the query. For example, in the case of an SQL query, returns the SQL query as a string.

Capability Level: 1

Overrides:
toString in class Object
Returns:
the String representation for this query
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


QueryManager

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface QueryManager

All Known Subinterfaces:
BusinessQueryManager, DeclarativeQueryManager
public interface QueryManager

This is the common base interface for all QueryManagers in the API.

Author:
Farrukh S. Najmi

Method Summary
RegistryObject | getRegistryObject(String id) Gets the RegistryObject specified by the Id.
RegistryObject | getRegistryObject(String id, String objectType) Gets the RegistryObject specified by the Id and type of object.
BulkResponse | getRegistryObjects() Gets the RegistryObjects owned by the caller.
BulkResponse | getRegistryObjects(Collection objectKeys) Gets the specified RegistryObjects.
BulkResponse | getRegistryObjects(Collection objectKeys, String objectTypes) Gets the specified RegistryObjects.
BulkResponse | getRegistryObjects(String objectType) Gets the RegistryObjects owned by the caller, that are of the specified type.
RegistryService | getRegistryService() Returns the parent RegistryService that created this object.

Method Detail

getRegistryObject

RegistryObject getRegistryObject(String id,
                                 String objectType)
                                 throws JAXRException
Gets the RegistryObject specified by the Id and type of object.

Capability Level: 0

Parameters:
id - is the id of the Key for a RegistryObject.
objectType - is a constant definition from LifeCycleManager that specifies the type of object desired.
Returns:
the RegistryObject, returned as its concrete type (e.g. Organization, User etc.).
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryObject

RegistryObject getRegistryObject(String id)
                                 throws JAXRException
Gets the RegistryObject specified by the Id.

Capability Level: 1

Parameters:
id - the id for the desired object
Returns:
the RegistryObject, returned as its concrete type (e.g. Organization, User etc.).
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryObjects

BulkResponse getRegistryObjects(Collection objectKeys)
                                throws JAXRException
Gets the specified RegistryObjects. The objects are returned as their concrete type (e.g. Organization, User etc.).

Capability Level: 1

Parameters:
objectKeys - a Collection of Key objects for the desired objects
Returns:
BulkResponse containing a heterogeneous Collection of RegistryObjects (e.g. Organization, User etc.).
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryObjects

BulkResponse getRegistryObjects(Collection objectKeys,
                                String objectTypes)
                                throws JAXRException
Gets the specified RegistryObjects. The objects are returned as their concrete type (e.g. Organization, User etc.).

Capability Level: 0

Parameters:
objectKeys - a Collection of Key objects for the desired objects
objectTypes - a Collection of String objects that allow filtering desired objects by their type
Returns:
BulkResponse containing a heterogeneous Collection of RegistryObjects (e.g. Organization, User etc.).
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryObjects

BulkResponse getRegistryObjects()
                                throws JAXRException
Gets the RegistryObjects owned by the caller. The objects are returned as their concrete type (e.g. Organization, User etc.).

Capability Level: 0

Returns:
BulkResponse containing a heterogeneous Collection of RegistryObjects (e.g. Organization, User etc.).
Throws:
JAXRException - If the JAXR provider encounters an internal error

getRegistryObjects

BulkResponse getRegistryObjects(String objectType)
                                throws JAXRException
Gets the RegistryObjects owned by the caller, that are of the specified type. The objects are returned as their concrete type (e.g. Organization, User etc.).

Capability Level: 0

Parameters:
objectType - Is a constant that defines the type of object sought. See LifeCycleManager for constants for object types.
Returns:
BulkResponse containing a heterogeneous Collection of RegistryObjects (e.g. Organization, User etc.).
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
LifeCycleManager.ORGANIZATION

getRegistryService

RegistryService getRegistryService()
                                   throws JAXRException
Returns the parent RegistryService that created this object.

Capability Level: 0

Returns:
the RegistryService created this object
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RegistryException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class RegistryException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.registry.JAXRException
                extended by  javax.xml.registry.RegistryException
All Implemented Interfaces:
Serializable, JAXRResponse
Direct Known Subclasses:
DeleteException, FindException, SaveException
public class RegistryException
extends JAXRException

This is the common base class for all Exceptions that are detected on the registry provider side rather than the JAXR client side.

Author:
Farrukh S. Najmi
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
RegistryException()
Constructs a JAXRException object with no reason or embedded Throwable.
RegistryException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
RegistryException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
RegistryException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Method Summary
Key | getErrorObjectKey() Gets the Key to the first object that encountered an error in the registry.
void | setErrorObjectKey(Key key) Sets the Key to the first object that encountered an error in the registry.
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RegistryException

public RegistryException()
Constructs a JAXRException object with no reason or embedded Throwable.

RegistryException

public RegistryException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

RegistryException

public RegistryException(String reason,
                         Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

RegistryException

public RegistryException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Method Detail

getErrorObjectKey

public Key getErrorObjectKey()
                      throws JAXRException
Gets the Key to the first object that encountered an error in the registry.

Returns:
the key to the first object in error
Throws:
JAXRException

setErrorObjectKey

public void setErrorObjectKey(Key key)
                       throws JAXRException
Sets the Key to the first object that encountered an error in the registry.

Parameters:
key - the key to the first object in error
Throws:
JAXRException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RegistryService

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Interface RegistryService

public interface RegistryService

This is the principal interface implemented by a JAXR provider. A registry client can get this interface from a Connection to a registry. It provides the methods that are used by the client to discover various capability specific interfaces implemented by the JAXR provider.

Author:
Farrukh S. Najmi
See Also:
Connection

Method Summary
BulkResponse | getBulkResponse(String requestId) Returns the BulkResponse associated with specified requestId.
BusinessLifeCycleManager | getBusinessLifeCycleManager() Returns the BusinessLifeCycleManager object implemented by the JAXR provider.
BusinessQueryManager | getBusinessQueryManager() Returns the BusinessQueryManager object implemented by the JAXR provider.
CapabilityProfile | getCapabilityProfile() Returns the CapabilityProfile for the JAXR provider.
DeclarativeQueryManager | getDeclarativeQueryManager() Returns the DeclarativeQueryManager object implemented by the JAXR provider.
ClassificationScheme | getDefaultPostalScheme() Gets the default user-defined postal scheme for codifying the attributes of PostalAddress.
String | makeRegistrySpecificRequest(String request) Takes a String that is an XML request in a registry-specific format, sends the request to the registry, and returns a String that is the registry-specific XML response.

Method Detail

getCapabilityProfile

CapabilityProfile getCapabilityProfile()
                                       throws JAXRException
Returns the CapabilityProfile for the JAXR provider.

Capability Level: 0

Returns:
the CapabilityProfile for a JAXR provider
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
LifeCycleManager

getBusinessLifeCycleManager

BusinessLifeCycleManager getBusinessLifeCycleManager()
                                                     throws JAXRException
Returns the BusinessLifeCycleManager object implemented by the JAXR provider.

Capability Level: 0

Returns:
the BusinessLifeCycleManager
Throws:
JAXRException - If the JAXR provider encounters an internal error
See Also:
LifeCycleManager

getBusinessQueryManager

BusinessQueryManager getBusinessQueryManager()
                                             throws JAXRException
Returns the BusinessQueryManager object implemented by the JAXR provider.

Capability Level: 0

Returns:
the BusinessQueryManaer
Throws:
JAXRException - If the JAXR provider encounters an internal error

getDeclarativeQueryManager

DeclarativeQueryManager getDeclarativeQueryManager()
                                                   throws JAXRException,
                                                          UnsupportedCapabilityException
Returns the DeclarativeQueryManager object implemented by the JAXR provider.

Capability Level: 1

Returns:
the DeclarativeQueryManager
Throws:
JAXRException - If the JAXR provider encounters an internal error
UnsupportedCapabilityException

getBulkResponse

BulkResponse getBulkResponse(String requestId)
                             throws InvalidRequestException,
                                    JAXRException
Returns the BulkResponse associated with specified requestId. Once a client retrieves a BulkResponse for a particular requestId any subsequent calls to retrieve the Bulkresponse for the same requestId should result in an InvalidRequestException.

Capability Level: 0

Parameters:
requestId - the id for a previous asynchronous request
Returns:
the BulkResponse that contains the result for the specified request
Throws:
InvalidRequestException - if no responses exist for specified requestId
JAXRException - If the JAXR provider encounters an internal error

getDefaultPostalScheme

ClassificationScheme getDefaultPostalScheme()
                                            throws JAXRException
Gets the default user-defined postal scheme for codifying the attributes of PostalAddress.

Capability Level: 0

Returns:
the ClassificationScheme that is the default postal scheme
Throws:
JAXRException - If the JAXR provider encounters an internal error

makeRegistrySpecificRequest

String makeRegistrySpecificRequest(String request)
                                   throws JAXRException
Takes a String that is an XML request in a registry-specific format, sends the request to the registry, and returns a String that is the registry-specific XML response.

Capability Level: 0

Parameters:
request - the registry-specific request in a String representation
Returns:
the String that is the XML response in a registry-specific manner
Throws:
JAXRException - If the JAXR provider encounters an internal error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SaveException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class SaveException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.registry.JAXRException
                extended by  javax.xml.registry.RegistryException
                    extended by  javax.xml.registry.SaveException
All Implemented Interfaces:
Serializable, JAXRResponse
public class SaveException
extends RegistryException

A RegistryException that occurs during a save action.

Author:
Farrukh S. Najmi
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
SaveException()
Constructs a JAXRException object with no reason or embedded Throwable.
SaveException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
SaveException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
SaveException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Method Summary
Methods inherited from class javax.xml.registry.RegistryException
getErrorObjectKey, setErrorObjectKey
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SaveException

public SaveException()
Constructs a JAXRException object with no reason or embedded Throwable.

SaveException

public SaveException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

SaveException

public SaveException(String reason,
                     Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

SaveException

public SaveException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UnexpectedObjectException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class UnexpectedObjectException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.registry.JAXRException
                extended by  javax.xml.registry.UnexpectedObjectException
All Implemented Interfaces:
Serializable, JAXRResponse
public class UnexpectedObjectException
extends JAXRException

This exception is thrown when the JAXR provider finds a Object that is out-of-place or of the wrong type within the context of a user request. For example a saveOrganizations request in BusinessLifeCycleManager would throw this Exception if it found an Object other than Organization in the Collection of Objects provided by client to be saved by the request.

Author:
Farrukh S. Najmi
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
UnexpectedObjectException()
Constructs a JAXRException object with no reason or embedded Throwable.
UnexpectedObjectException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
UnexpectedObjectException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
UnexpectedObjectException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Method Summary
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnexpectedObjectException

public UnexpectedObjectException()
Constructs a JAXRException object with no reason or embedded Throwable.

UnexpectedObjectException

public UnexpectedObjectException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

UnexpectedObjectException

public UnexpectedObjectException(String reason,
                                 Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

UnexpectedObjectException

public UnexpectedObjectException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


UnsupportedCapabilityException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.registry
Class UnsupportedCapabilityException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.registry.JAXRException
                extended by  javax.xml.registry.UnsupportedCapabilityException
All Implemented Interfaces:
Serializable, JAXRResponse
public class UnsupportedCapabilityException
extends JAXRException

This exception must be thrown when a JAXR client attempts to invoke an API method that is not supported by the capability profile that is supported by the JAXR provider.

Author:
Farrukh S. Najmi
See Also:
RegistryService, Serialized Form

Field Summary
Fields inherited from class javax.xml.registry.JAXRException
cause
Fields inherited from interface javax.xml.registry.JAXRResponse
STATUS_FAILURE, STATUS_SUCCESS, STATUS_UNAVAILABLE, STATUS_WARNING
Constructor Summary
UnsupportedCapabilityException()
Constructs a JAXRException object with no reason or embedded Throwable.
UnsupportedCapabilityException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.
UnsupportedCapabilityException(String reason, Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.
UnsupportedCapabilityException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.
Method Summary
Methods inherited from class javax.xml.registry.JAXRException
getCause, getMessage, getRequestId, getStatus, initCause, isAvailable
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnsupportedCapabilityException

public UnsupportedCapabilityException()
Constructs a JAXRException object with no reason or embedded Throwable.

UnsupportedCapabilityException

public UnsupportedCapabilityException(String reason)
Constructs a JAXRException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

UnsupportedCapabilityException

public UnsupportedCapabilityException(String reason,
                                      Throwable cause)
Constructs a JAXRException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded Throwable.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this JAXRException object

UnsupportedCapabilityException

public UnsupportedCapabilityException(Throwable cause)
Constructs a JAXRException object initialized with the given Throwable object.

Parameters:
cause - the Throwable that caused this Exception
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


rpc

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc

This package contains the core JAX-RPC APIs for the client programming model.

See:
Description

Interface Summary
Call | The javax.xml.rpc.Call interface provides support for the dynamic invocation of a service endpoint.
Service | Service class acts as a factory of the following: Dynamic proxy for the target service endpoint.
Stub | The interface javax.xml.rpc.Stub is the common base interface for the stub classes.

Class Summary
NamespaceConstants | Constants used in JAX-RPC for namespace prefixes and URIs
ParameterMode | The javax.xml.rpc.ParameterMode is a type-safe enumeration for parameter mode.
ServiceFactory | The javax.xml.rpc.ServiceFactory is an abstract class that provides a factory for the creation of instances of the type javax.xml.rpc.Service.

Exception Summary
JAXRPCException | The javax.xml.rpc.JAXRPCException is thrown from the core JAX-RPC APIs to indicate an exception related to the JAX-RPC runtime mechanisms.
ServiceException | The javax.xml.rpc.ServiceException is thrown from the methods in the javax.xml.rpc.Service interface and ServiceFactory class.

Package javax.xml.rpc Description

This package contains the core JAX-RPC APIs for the client programming model.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.rpc.NamespaceConstants
    • javax.xml.rpc.ParameterMode
    • javax.xml.rpc.ServiceFactory
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.rpc.JAXRPCException
        • javax.xml.rpc.ServiceException

Interface Hierarchy

  • javax.xml.rpc.Call
  • javax.xml.rpc.Service
  • javax.xml.rpc.Stub
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Call

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Interface Call

public interface Call

The javax.xml.rpc.Call interface provides support for the dynamic invocation of a service endpoint. The javax.xml.rpc.Service interface acts as a factory for the creation of Call instances.

Once a Call instance is created, various setter and getter methods may be used to configure this Call instance.

Version:
1.0
Author:
Rahul Sharma

Field Summary
static String | ENCODINGSTYLE_URI_PROPERTY Standard property for encoding Style: Encoding style specified as a namespace URI.
static String | OPERATION_STYLE_PROPERTY Standard property for operation style.
static String | PASSWORD_PROPERTY Standard property: Password for authentication Type: java.lang.String
static String | SESSION_MAINTAIN_PROPERTY Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.
static String | SOAPACTION_URI_PROPERTY Standard property for SOAPAction.
static String | SOAPACTION_USE_PROPERTY Standard property for SOAPAction.
static String | USERNAME_PROPERTY Standard property: User name for authentication Type: java.lang.String
Method Summary
void | addParameter(String paramName, QName xmlType, Class javaType, ParameterMode parameterMode) Adds a parameter type and mode for a specific operation.
void | addParameter(String paramName, QName xmlType, ParameterMode parameterMode) Adds a parameter type and mode for a specific operation.
QName | getOperationName() Gets the name of the operation to be invoked using this Call instance.
Map | getOutputParams() Returns a Map of {name, value} for the output parameters of the last invoked operation.
List | getOutputValues() Returns a List values for the output parameters of the last invoked operation.
QName | getParameterTypeByName(String paramName) Gets the XML type of a parameter by name
QName | getPortTypeName() Gets the qualified name of the port type.
Object | getProperty(String name) Gets the value of a named property.
Iterator | getPropertyNames() Gets the names of configurable properties supported by this Call object.
QName | getReturnType() Gets the return type for a specific operation
String | getTargetEndpointAddress() Gets the address of a target service endpoint.
Object | invoke(Object[] inputParams) Invokes a specific operation using a synchronous request-response interaction mode.
Object | invoke(QName operationName, Object[] inputParams) Invokes a specific operation using a synchronous request-response interaction mode.
void | invokeOneWay(Object[] inputParams) Invokes a remote method using the one-way interaction mode.
boolean | isParameterAndReturnSpecRequired(QName operationName) Indicates whether addParameter and setReturnType methods are to be invoked to specify the parameter and return type specification for a specific operation.
void | removeAllParameters() Removes all specified parameters from this Call instance.
void | removeProperty(String name) Removes a named property.
void | setOperationName(QName operationName) Sets the name of the operation to be invoked using this Call instance.
void | setPortTypeName(QName portType) Sets the qualified name of the port type.
void | setProperty(String name, Object value) Sets the value for a named property.
void | setReturnType(QName xmlType) Sets the return type for a specific operation.
void | setReturnType(QName xmlType, Class javaType) Sets the return type for a specific operation.
void | setTargetEndpointAddress(String address) Sets the address of the target service endpoint.

Field Detail

USERNAME_PROPERTY

static final String USERNAME_PROPERTY
Standard property: User name for authentication

Type: java.lang.String

See Also:
Constant Field Values

PASSWORD_PROPERTY

static final String PASSWORD_PROPERTY
Standard property: Password for authentication

Type: java.lang.String

See Also:
Constant Field Values

OPERATION_STYLE_PROPERTY

static final String OPERATION_STYLE_PROPERTY
Standard property for operation style. This property is set to "rpc" if the operation style is rpc; "document" if the operation style is document.

Type: java.lang.String

See Also:
Constant Field Values

SOAPACTION_USE_PROPERTY

static final String SOAPACTION_USE_PROPERTY
Standard property for SOAPAction. This boolean property indicates whether or not SOAPAction is to be used. The default value of this property is false indicating that the SOAPAction is not used.

Type: java.lang.Boolean

See Also:
Constant Field Values

SOAPACTION_URI_PROPERTY

static final String SOAPACTION_URI_PROPERTY
Standard property for SOAPAction. Indicates the SOAPAction URI if the javax.xml.rpc.soap.http.soapaction.use property is set to true.

Type: java.lang.String

See Also:
Constant Field Values

ENCODINGSTYLE_URI_PROPERTY

static final String ENCODINGSTYLE_URI_PROPERTY
Standard property for encoding Style: Encoding style specified as a namespace URI. The default value is the SOAP 1.1 encoding http://schemas.xmlsoap.org/soap/encoding/

Type: java.lang.String

See Also:
Constant Field Values

SESSION_MAINTAIN_PROPERTY

static final String SESSION_MAINTAIN_PROPERTY
Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint. If this property is set to true, the service client indicates that it wants the session to be maintained. If set to false, the session is not maintained. The default value for this property is false.

Type: java.lang.Boolean

See Also:
Constant Field Values
Method Detail

isParameterAndReturnSpecRequired

boolean isParameterAndReturnSpecRequired(QName operationName)
Indicates whether addParameter and setReturnType methods are to be invoked to specify the parameter and return type specification for a specific operation.

Parameters:
operationName - Qualified name of the operation
Returns:
Returns true if the Call implementation class requires addParameter and setReturnType to be invoked in the client code for the specified operation. This method returns false otherwise.
Throws:
IllegalArgumentException - If invalid operation name is specified

addParameter

void addParameter(String paramName,
                  QName xmlType,
                  ParameterMode parameterMode)
Adds a parameter type and mode for a specific operation. Note that the client code may not call any addParameter and setReturnType methods before calling the invoke method. In this case, the Call implementation class determines the parameter types by using reflection on parameters, using the WSDL description and configured type mapping registry.

Parameters:
paramName - Name of the parameter
xmlType - XML type of the parameter
parameterMode - Mode of the parameter-whether ParameterMode.IN, ParameterMode.OUT, or ParameterMode.INOUT,
Throws:
javax.xml.rpc.JAXRPCException: - This exception may be thrown if the method isParameterAndReturnSpecRequired returns false for this operation.
IllegalArgumentException - If any illegal parameter name or XML type is specified
See Also:
isParameterAndReturnSpecRequired(javax.xml.namespace.QName)

addParameter

void addParameter(String paramName,
                  QName xmlType,
                  Class javaType,
                  ParameterMode parameterMode)
Adds a parameter type and mode for a specific operation. This method is used to specify the Java type for either OUT or INOUT parameters.

Parameters:
paramName - Name of the parameter
xmlType - XML type of the parameter
javaType - Java class of the parameter
parameterMode - Mode of the parameter-whether ParameterMode.IN, OUT or INOUT
Throws:
JAXRPCException -
  • This exception may be thrown if this method is invoked when the method isParameterAndReturnSpecRequired returns false.
  • If specified XML type and Java type mapping is not valid. For example, TypeMappingRegistry has no serializers for this mapping.
IllegalArgumentException - If any illegal parameter name or XML type is specified
UnsupportedOperationException - If this method is not supported
See Also:
isParameterAndReturnSpecRequired(javax.xml.namespace.QName)

getParameterTypeByName

QName getParameterTypeByName(String paramName)
Gets the XML type of a parameter by name

Parameters:
paramName - Name of the parameter
Returns:
Returns XML type for the specified parameter

setReturnType

void setReturnType(QName xmlType)
Sets the return type for a specific operation. Invoking setReturnType(null) removes the return type for this Call object.

Parameters:
xmlType - XML data type of the return value
Throws:
JAXRPCException - This exception may be thrown when the method isParameterAndReturnSpecRequired returns false.
IllegalArgumentException - If an illegal XML type is specified

setReturnType

void setReturnType(QName xmlType,
                   Class javaType)
Sets the return type for a specific operation.

Parameters:
type - XML data type of the return value
javaType - Java Class of the return value
Throws:
JAXRPCException -
  • This exception may be thrown if this method is invoked when the method isParameterAndReturnSpecRequired returns false.
  • If XML type and Java type cannot be mapped using the standard type mapping or TypeMapping registry
UnsupportedOperationException - If this method is not supported
IllegalArgumentException - If an illegal XML type is specified

getReturnType

QName getReturnType()
Gets the return type for a specific operation

Returns:
Returns the XML type for the return value

removeAllParameters

void removeAllParameters()
Removes all specified parameters from this Call instance. Note that this method removes only the parameters and not the return type. The setReturnType(null) is used to remove the return type.

Throws:
JAXRPCException - This exception may be thrown If this method is called when the method isParameterAndReturnSpecRequired returns false for this Call's operation.

getOperationName

QName getOperationName()
Gets the name of the operation to be invoked using this Call instance.

Returns:
Qualified name of the operation

setOperationName

void setOperationName(QName operationName)
Sets the name of the operation to be invoked using this Call instance.

Parameters:
operationName - QName of the operation to be invoked using the Call instance

getPortTypeName

QName getPortTypeName()
Gets the qualified name of the port type.

Returns:
Qualified name of the port type

setPortTypeName

void setPortTypeName(QName portType)
Sets the qualified name of the port type.

Parameters:
portType - Qualified name of the port type

setTargetEndpointAddress

void setTargetEndpointAddress(String address)
Sets the address of the target service endpoint. This address must correspond to the transport specified in the binding for this Call instance.

Parameters:
address - Address of the target service endpoint; specified as an URI

getTargetEndpointAddress

String getTargetEndpointAddress()
Gets the address of a target service endpoint.

Returns:
Address of the target service endpoint as an URI

setProperty

void setProperty(String name,
                 Object value)
Sets the value for a named property. JAX-RPC specification specifies a standard set of properties that may be passed to the Call.setProperty method.

Parameters:
name - Name of the property
value - Value of the property
Throws:
JAXRPCException -
  • If an optional standard property name is specified, however this Call implementation class does not support the configuration of this property.
  • If an invalid (or unsupported) property name is specified or if a value of mismatched property type is passed.
  • If there is any error in the configuration of a valid property.

getProperty

Object getProperty(String name)
Gets the value of a named property.

Parameters:
name - Name of the property
Returns:
Value of the named property
Throws:
JAXRPCException - if an invalid or unsupported property name is passed.

removeProperty

void removeProperty(String name)
Removes a named property.

Parameters:
name - Name of the property
Throws:
JAXRPCException - if an invalid or unsupported property name is passed.

getPropertyNames

Iterator getPropertyNames()
Gets the names of configurable properties supported by this Call object.

Returns:
Iterator for the property names

invoke

Object invoke(Object[] inputParams)
              throws RemoteException
Invokes a specific operation using a synchronous request-response interaction mode.

Parameters:
inputParams - Object[]--Parameters for this invocation. This includes only the input params
Returns:
Returns the return value or null
Throws:
RemoteException - if there is any error in the remote method invocation
SOAPFaultException - Indicates a SOAP fault
JAXRPCException -
  • If there is an error in the configuration of the Call object
  • If inputParams do not match the required parameter set (as specified through the addParameter invocations or in the corresponding WSDL)
  • If parameters and return type are incorrectly specified

invoke

Object invoke(QName operationName,
              Object[] inputParams)
              throws RemoteException
Invokes a specific operation using a synchronous request-response interaction mode.

Parameters:
operationName - QName of the operation
inputParams - Object[]--Parameters for this invocation. This includes only the input params.
Returns:
Return value or null
Throws:
RemoteException - if there is any error in the remote method invocation.
SOAPFaultException - Indicates a SOAP fault
JAXRPCException -
  • If there is an error in the configuration of the Call object
  • If inputParams do not match the required parameter set (as specified through the addParameter invocations or in the corresponding WSDL)
  • If parameters and return type are incorrectly specified

invokeOneWay

void invokeOneWay(Object[] inputParams)
Invokes a remote method using the one-way interaction mode. The client thread does not normally block waiting for the completion of the server processing for this remote method invocation. When the protocol in use is SOAP/HTTP, this method should block until an HTTP response code has been received or an error occurs. This method must not throw any remote exceptions. This method may throw a JAXRPCException during the processing of the one-way remote call.

Parameters:
inputParams - Object[]--Parameters for this invocation. This includes only the input params.
Throws:
JAXRPCException - if there is an error in the configuration of the Call object (example: a non-void return type has been incorrectly specified for the one-way call) or if there is any error during the invocation of the one-way remote call

getOutputParams

Map getOutputParams()
Returns a Map of {name, value} for the output parameters of the last invoked operation. The parameter names in the returned Map are of type java.lang.String.

Returns:
Map Output parameters for the last Call.invoke(). Empty Map is returned if there are no output parameters.
Throws:
JAXRPCException - If this method is invoked for a one-way operation or is invoked before any invoke method has been called.

getOutputValues

List getOutputValues()
Returns a List values for the output parameters of the last invoked operation.

Returns:
java.util.List Values for the output parameters. An empty List is returned if there are no output values.
Throws:
JAXRPCException - If this method is invoked for a one-way operation or is invoked before any invoke method has been called.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


encoding

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc.encoding

This package defines APIs for the extensible type mapping framework.

See:
Description

Interface Summary
DeserializationContext | The javax.xml.rpc.encoding.DeserializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner.
Deserializer | The javax.xml.rpc.encoding.Deserializer interface defines a base interface for deserializers.
DeserializerFactory | The javax.xml.rpc.encoding.DeserializerFactory is a factory of deserializers.
SerializationContext | The javax.xml.rpc.encoding.SerializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner.
Serializer | The javax.xml.rpc.encoding.Serializer interface defines the base interface for serializers.
SerializerFactory | The javax.xml.rpc.encoding.SerializerFactory is a factory of the serializers.
TypeMapping | The javax.xml.rpc.encoding.TypeMapping is the base interface for the representation of a type mapping.
TypeMappingRegistry | The interface javax.xml.rpc.encoding.TypeMappingRegistry defines a registry of TypeMapping instances for various encoding styles.

Class Summary
XMLType Constants for common XML Schema and SOAP 1.1 types.

Package javax.xml.rpc.encoding Description

This package defines APIs for the extensible type mapping framework.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DeserializationContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface DeserializationContext

public interface DeserializationContext

The javax.xml.rpc.encoding.DeserializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner. A deserializer uses this interface to access and maintain context information during the deserialization..

Version:
1.0
Author:
Rahul Sharma

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc.encoding Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc.encoding

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.rpc.encoding.XMLType

Interface Hierarchy

  • javax.xml.rpc.encoding.DeserializationContext
  • java.io.Serializable
    • javax.xml.rpc.encoding.Deserializer
    • javax.xml.rpc.encoding.DeserializerFactory
    • javax.xml.rpc.encoding.Serializer
    • javax.xml.rpc.encoding.SerializerFactory
    • javax.xml.rpc.encoding.TypeMappingRegistry
  • javax.xml.rpc.encoding.SerializationContext
  • javax.xml.rpc.encoding.TypeMapping
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SerializationContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface SerializationContext

public interface SerializationContext

The javax.xml.rpc.encoding.SerializationContext interface is implemented by the JAX-RPC runtime system in an XML processing mechanism specific manner. A serializer uses the SerializationContext interface during the serialization to get the context information related to the XML processing mechanism and to manage information specific to serialization.

Version:
1.0
Author:
Rahul Sharma
See Also:
Serializer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Deserializer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface Deserializer

All Superinterfaces:
Serializable
public interface Deserializer
extends Serializable

The javax.xml.rpc.encoding.Deserializer interface defines a base interface for deserializers. A Deserializer converts an XML representation to a Java object using a specific XML processing mechanism and based on the specified type mapping and encoding style.

Version:
1.0
Author:
Rahul Sharma

Method Summary
 String getMechanismType()
Gets the type of the XML processing mechanism and representation used by this Deserializer.

Method Detail

getMechanismType

String getMechanismType()
Gets the type of the XML processing mechanism and representation used by this Deserializer.

Returns:
XML processing mechanism type
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DeserializerFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface DeserializerFactory

All Superinterfaces:
Serializable
public interface DeserializerFactory
extends Serializable

The javax.xml.rpc.encoding.DeserializerFactory is a factory of deserializers. A DeserializerFactory is registered with a TypeMapping instance as part of the TypeMappingRegistry.

Version:
1.0
Author:
Rahul Sharma
See Also:
Serializer

Method Summary
Deserializer | getDeserializerAs(String mechanismType) Returns a Deserializer for the specified XML processing mechanism type.
Iterator | getSupportedMechanismTypes() Returns a list of all XML processing mechanism types supported by this DeserializerFactory.

Method Detail

getDeserializerAs

Deserializer getDeserializerAs(String mechanismType)
Returns a Deserializer for the specified XML processing mechanism type.

Parameters:
mechanismType - XML processing mechanism type [TBD: definition of valid constants]
Throws:
JAXRPCException - If DeserializerFactory does not support the specified XML processing mechanism

getSupportedMechanismTypes

Iterator getSupportedMechanismTypes()
Returns a list of all XML processing mechanism types supported by this DeserializerFactory.

Returns:
List of unique identifiers for the supported XML processing mechanism types
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Serializer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface Serializer

All Superinterfaces:
Serializable
public interface Serializer
extends Serializable

The javax.xml.rpc.encoding.Serializer interface defines the base interface for serializers. A Serializer converts a Java object to an XML representation using a specific XML processing mechanism and based on the specified type mapping and encoding style.

Version:
1.0
Author:
Rahul Sharma

Method Summary
 String getMechanismType()
Gets the type of the XML processing mechanism and representation used by this Serializer.

Method Detail

getMechanismType

String getMechanismType()
Gets the type of the XML processing mechanism and representation used by this Serializer.

Returns:
XML processing mechanism type
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SerializerFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface SerializerFactory

All Superinterfaces:
Serializable
public interface SerializerFactory
extends Serializable

The javax.xml.rpc.encoding.SerializerFactory is a factory of the serializers. A SerializerFactory is registered with a TypeMapping object as part of the TypeMappingRegistry.

Version:
1.0
Author:
Rahul Sharma
See Also:
Serializer

Method Summary
Serializer | getSerializerAs(String mechanismType) Returns a Serializer for the specified XML processing mechanism type.
Iterator | getSupportedMechanismTypes() Returns a list of all XML processing mechanism types supported by this SerializerFactory.

Method Detail

getSerializerAs

Serializer getSerializerAs(String mechanismType)
Returns a Serializer for the specified XML processing mechanism type.

Parameters:
mechanismType - XML processing mechanism type [TBD: definition of valid constants]
Throws:
JAXRPCException - If SerializerFactory does not support the specified XML processing mechanism
IllegalArgumentException - If an invalid mechanism type is specified.

getSupportedMechanismTypes

Iterator getSupportedMechanismTypes()
Returns a list of all XML processing mechanism types supported by this SerializerFactory.

Returns:
List of unique identifiers for the supported XML processing mechanism types
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TypeMapping

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface TypeMapping

public interface TypeMapping

The javax.xml.rpc.encoding.TypeMapping is the base interface for the representation of a type mapping. A TypeMapping implementation class may support one or more encoding styles.

For its supported encoding styles, a TypeMapping instance maintains a set of tuples of the type {Java type, SerializerFactory, DeserializerFactory, XML type}.

Version:
1.0
Author:
Rahul Sharma

Method Summary
DeserializerFactory | getDeserializer(Class javaType, QName xmlType) Gets the DeserializerFactory registered for the specified pair of Java type and XML data type.
SerializerFactory | getSerializer(Class javaType, QName xmlType) Gets the SerializerFactory registered for the specified pair of Java type and XML data type.
String[] | getSupportedEncodings() Returns the encodingStyle URIs (as String[]) supported by this TypeMapping instance.
boolean | isRegistered(Class javaType, QName xmlType) Checks whether or not type mapping between specified XML type and Java type is registered.
void | register(Class javaType, QName xmlType, SerializerFactory sf, DeserializerFactory dsf) Registers SerializerFactory and DeserializerFactory for a specific type mapping between an XML type and Java type.
void | removeDeserializer(Class javaType, QName xmlType) Removes the DeserializerFactory registered for the specified pair of Java type and XML data type.
void | removeSerializer(Class javaType, QName xmlType) Removes the SerializerFactory registered for the specified pair of Java type and XML data type.
void | setSupportedEncodings(String[] encodingStyleURIs) Sets the encodingStyle URIs supported by this TypeMapping instance.

Method Detail

getSupportedEncodings

String[] getSupportedEncodings()
Returns the encodingStyle URIs (as String[]) supported by this TypeMapping instance. A TypeMapping that contains only encoding style independent serializers and deserializers returns null from this method.

Returns:
Array of encodingStyle URIs for the supported encoding styles

setSupportedEncodings

void setSupportedEncodings(String[] encodingStyleURIs)
Sets the encodingStyle URIs supported by this TypeMapping instance. A TypeMapping that contains only encoding independent serializers and deserializers requires null as the parameter for this method.

Parameters:
encodingStyleURIs - Array of encodingStyle URIs for the supported encoding styles

isRegistered

boolean isRegistered(Class javaType,
                     QName xmlType)
Checks whether or not type mapping between specified XML type and Java type is registered.

Parameters:
javaType - Class of the Java type
QName - Qualified name of the XML data type
Returns:
boolean; true if type mapping between the specified XML type and Java type is registered; otherwise false

register

void register(Class javaType,
              QName xmlType,
              SerializerFactory sf,
              DeserializerFactory dsf)
Registers SerializerFactory and DeserializerFactory for a specific type mapping between an XML type and Java type. This method replaces any existing registered SerializerFactory DeserializerFactory instances.

Parameters:
javaType - Class of the Java type
QName - Qualified name of the XML data type
sf - SerializerFactory
dsf - DeserializerFactory
Throws:
JAXRPCException - If any error during the registration

getSerializer

SerializerFactory getSerializer(Class javaType,
                                QName xmlType)
Gets the SerializerFactory registered for the specified pair of Java type and XML data type.

Parameters:
javaType - Class of the Java type
QName - Qualified name of the XML data type
Returns:
Registered SerializerFactory or null if there is no registered factory

getDeserializer

DeserializerFactory getDeserializer(Class javaType,
                                    QName xmlType)
Gets the DeserializerFactory registered for the specified pair of Java type and XML data type.

Parameters:
javaType - Class of the Java type
QName - Qualified name of the XML data type
Returns:
Registered DeserializerFactory or null if there is no registered factory

removeSerializer

void removeSerializer(Class javaType,
                      QName xmlType)
Removes the SerializerFactory registered for the specified pair of Java type and XML data type.

Throws:
JAXRPCException - If there is error in removing the registered SerializerFactory

removeDeserializer

void removeDeserializer(Class javaType,
                        QName xmlType)
Removes the DeserializerFactory registered for the specified pair of Java type and XML data type.

Throws:
JAXRPCException - If there is error in removing the registered DeserializerFactory
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


TypeMappingRegistry

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Interface TypeMappingRegistry

All Superinterfaces:
Serializable
public interface TypeMappingRegistry
extends Serializable

The interface javax.xml.rpc.encoding.TypeMappingRegistry defines a registry of TypeMapping instances for various encoding styles.

Version:
1.0
Author:
Rahul Sharma

Method Summary
void | clear() Removes all registered TypeMappings and encodingStyleURIs from this TypeMappingRegistry.
TypeMapping | createTypeMapping() Creates a new empty TypeMapping object.
TypeMapping | getDefaultTypeMapping() Gets the registered default TypeMapping instance.
String[] | getRegisteredEncodingStyleURIs() Returns a list of registered encodingStyle URIs in this TypeMappingRegistry instance.
TypeMapping | getTypeMapping(String encodingStyleURI) Returns the registered TypeMapping for the specified encodingStyle URI.
TypeMapping | register(String encodingStyleURI, TypeMapping mapping) Registers a TypeMapping instance with the TypeMappingRegistry.
void | registerDefault(TypeMapping mapping) Registers the TypeMapping instance that is default for all encoding styles supported by the TypeMappingRegistry.
boolean | removeTypeMapping(TypeMapping mapping) Removes a TypeMapping from the TypeMappingRegistry.
TypeMapping | unregisterTypeMapping(String encodingStyleURI) Unregisters a TypeMapping instance, if present, from the specified encodingStyleURI.

Method Detail

register

TypeMapping register(String encodingStyleURI,
                     TypeMapping mapping)
Registers a TypeMapping instance with the TypeMappingRegistry. This method replaces any existing registered TypeMapping instance for the specified encodingStyleURI.

Parameters:
encodingStyleURI - An encoding style specified as an URI. An example is "http://schemas.xmlsoap.org/soap/encoding/"
mapping - TypeMapping instance
Returns:
Previous TypeMapping associated with the specified encodingStyleURI, or null if there was no TypeMapping associated with the specified encodingStyleURI
Throws:
JAXRPCException - If there is an error in the registration of the TypeMapping for the specified encodingStyleURI.

registerDefault

void registerDefault(TypeMapping mapping)
Registers the TypeMapping instance that is default for all encoding styles supported by the TypeMappingRegistry. A default TypeMapping should include serializers and deserializers that are independent of and usable with any encoding style. Successive invocations of the registerDefault method replace any existing default TypeMapping instance.

If the default TypeMapping is registered, any other TypeMapping instances registered through the TypeMappingRegistry.register method (for a set of encodingStyle URIs) override the default TypeMapping.

Parameters:
mapping - TypeMapping instance
Throws:
JAXRPCException - If there is an error in the registration of the default TypeMapping

getDefaultTypeMapping

TypeMapping getDefaultTypeMapping()
Gets the registered default TypeMapping instance. This method returns null if there is no registered default TypeMapping in the registry.

Returns:
The registered default TypeMapping instance or null

getRegisteredEncodingStyleURIs

String[] getRegisteredEncodingStyleURIs()
Returns a list of registered encodingStyle URIs in this TypeMappingRegistry instance.

Returns:
Array of the registered encodingStyle URIs

getTypeMapping

TypeMapping getTypeMapping(String encodingStyleURI)
Returns the registered TypeMapping for the specified encodingStyle URI. If there is no registered TypeMapping for the specified encodingStyleURI, this method returns null.

Parameters:
encodingStyleURI - Encoding style specified as an URI
Returns:
TypeMapping for the specified encodingStyleURI or null

createTypeMapping

TypeMapping createTypeMapping()
Creates a new empty TypeMapping object.

Returns:
TypeMapping instance

unregisterTypeMapping

TypeMapping unregisterTypeMapping(String encodingStyleURI)
Unregisters a TypeMapping instance, if present, from the specified encodingStyleURI.

Parameters:
encodingStyleURI - Encoding style specified as an URI
Returns:
TypeMapping instance that has been unregistered or null if there was no TypeMapping registered for the specified encodingStyleURI

removeTypeMapping

boolean removeTypeMapping(TypeMapping mapping)
Removes a TypeMapping from the TypeMappingRegistry. A TypeMapping is associated with 1 or more encodingStyleURIs. This method unregisters the specified TypeMapping instance from all associated encodingStyleURIs and then removes this TypeMapping instance from the registry.

Parameters:
mapping - TypeMapping to be removed
Returns:
true if specified TypeMapping is removed from the TypeMappingRegistry; false if the specified TypeMapping was not in the TypeMappingRegistry

clear

void clear()
Removes all registered TypeMappings and encodingStyleURIs from this TypeMappingRegistry.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.encoding
Class XMLType

java.lang.Object
    extended by  javax.xml.rpc.encoding.XMLType

public class XMLType
extends Object

Constants for common XML Schema and SOAP 1.1 types.

Version:
1.0
Author:
Rahul Sharma

Field Summary
static QName | SOAP_ARRAY The name of the SOAP-ENC:Array type.
static QName | SOAP_BASE64 The name of the SOAP-ENC:base64 type.
static QName | SOAP_BOOLEAN The name of the SOAP-ENC:boolean type.
static QName | SOAP_BYTE The name of the SOAP-ENC:byte type.
static QName | SOAP_DOUBLE The name of the SOAP-ENC:double type.
static QName | SOAP_FLOAT The name of the SOAP-ENC:float type.
static QName | SOAP_INT The name of the SOAP-ENC:int type.
static QName | SOAP_LONG The name of the SOAP-ENC:long type.
static QName | SOAP_SHORT The name of the SOAP-ENC:short type.
static QName | SOAP_STRING The name of the SOAP-ENC:string type.
static QName | XSD_BASE64 The name of the xsd:base64Binary type.
static QName | XSD_BOOLEAN The name of the xsd:boolean type.
static QName | XSD_BYTE The name of the xsd:byte type.
static QName | XSD_DATETIME The name of the xsd:dateTime type.
static QName | XSD_DECIMAL The name of the xsd:decimal type.
static QName | XSD_DOUBLE The name of the xsd:double type.
static QName | XSD_FLOAT The name of the xsd:float type.
static QName | XSD_HEXBINARY The name of the xsd:hexBinary type.
static QName | XSD_INT The name of the xsd:int type.
static QName | XSD_INTEGER The name of the xsd:integer type.
static QName | XSD_LONG The name of the xsd:long type.
static QName | XSD_QNAME The name of the xsd:QName type.
static QName | XSD_SHORT The name of the xsd:short type.
static QName | XSD_STRING The name of the xsd:string type.
Constructor Summary
XMLType()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

XSD_STRING

public static final QName XSD_STRING
The name of the xsd:string type.

XSD_FLOAT

public static final QName XSD_FLOAT
The name of the xsd:float type.

XSD_BOOLEAN

public static final QName XSD_BOOLEAN
The name of the xsd:boolean type.

XSD_DOUBLE

public static final QName XSD_DOUBLE
The name of the xsd:double type.

XSD_INTEGER

public static final QName XSD_INTEGER
The name of the xsd:integer type.

XSD_INT

public static final QName XSD_INT
The name of the xsd:int type.

XSD_LONG

public static final QName XSD_LONG
The name of the xsd:long type.

XSD_SHORT

public static final QName XSD_SHORT
The name of the xsd:short type.

XSD_DECIMAL

public static final QName XSD_DECIMAL
The name of the xsd:decimal type.

XSD_BASE64

public static final QName XSD_BASE64
The name of the xsd:base64Binary type.

XSD_HEXBINARY

public static final QName XSD_HEXBINARY
The name of the xsd:hexBinary type.

XSD_BYTE

public static final QName XSD_BYTE
The name of the xsd:byte type.

XSD_DATETIME

public static final QName XSD_DATETIME
The name of the xsd:dateTime type.

XSD_QNAME

public static final QName XSD_QNAME
The name of the xsd:QName type.

SOAP_STRING

public static final QName SOAP_STRING
The name of the SOAP-ENC:string type.

SOAP_BOOLEAN

public static final QName SOAP_BOOLEAN
The name of the SOAP-ENC:boolean type.

SOAP_DOUBLE

public static final QName SOAP_DOUBLE
The name of the SOAP-ENC:double type.

SOAP_BASE64

public static final QName SOAP_BASE64
The name of the SOAP-ENC:base64 type.

SOAP_FLOAT

public static final QName SOAP_FLOAT
The name of the SOAP-ENC:float type.

SOAP_INT

public static final QName SOAP_INT
The name of the SOAP-ENC:int type.

SOAP_LONG

public static final QName SOAP_LONG
The name of the SOAP-ENC:long type.

SOAP_SHORT

public static final QName SOAP_SHORT
The name of the SOAP-ENC:short type.

SOAP_BYTE

public static final QName SOAP_BYTE
The name of the SOAP-ENC:byte type.

SOAP_ARRAY

public static final QName SOAP_ARRAY
The name of the SOAP-ENC:Array type.

Constructor Detail

XMLType

public XMLType()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


handler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc.handler

This package defines APIs for SOAP Message Handlers

See:
Description

Interface Summary
Handler | The javax.xml.rpc.handler.Handler interface is required to be implemented by a SOAP message handler.
HandlerChain | The javax.xml.rpc.handler.HandlerChain represents a list of handlers.
HandlerRegistry | The javax.xml.rpc.handler.HandlerRegistry provides support for the programmatic configuration of handlers in a HandlerRegistry.
MessageContext | The interface MessageContext abstracts the message context that is processed by a handler in the handle method.

Class Summary
GenericHandler | The javax.xml.rpc.handler.GenericHandler class implements the Handler interface.
HandlerInfo | The javax.xml.rpc.handler.HandlerInfo represents information about a handler in the HandlerChain.

Package javax.xml.rpc.handler Description

This package defines APIs for SOAP Message Handlers

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc.handler Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc.handler

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.rpc.handler.GenericHandler (implements javax.xml.rpc.handler.Handler)
    • javax.xml.rpc.handler.HandlerInfo (implements java.io.Serializable)

Interface Hierarchy

  • javax.xml.rpc.handler.Handler
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.util.List<E>
        • javax.xml.rpc.handler.HandlerChain
  • javax.xml.rpc.handler.MessageContext
  • java.io.Serializable
    • javax.xml.rpc.handler.HandlerRegistry
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


GenericHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler
Class GenericHandler

java.lang.Object
    extended by  javax.xml.rpc.handler.GenericHandler
All Implemented Interfaces:
Handler
public abstract class GenericHandler
extends Object
implements Handler

The javax.xml.rpc.handler.GenericHandler class implements the Handler interface. SOAP Message Handler developers should typically subclass GenericHandler class unless the Handler class needs another class as a superclass.

The GenericHandler class is a convenience abstract class that makes writing Handlers easy. This class provides default implementations of the lifecycle methods init and destroy and also different handle methods. A Handler developer should only override methods that it needs to specialize as part of the derived Handler implementation class.

Version:
1.0
Author:
Rahul Sharma

Constructor Summary
protected GenericHandler()
Default constructor
Method Summary
void | destroy() The destroy method indicates the end of lifecycle for a Handler instance.
abstract QName[] | getHeaders() Gets the header blocks processed by this Handler instance.
boolean | handleFault(MessageContext context) The handleFault method processes the SOAP faults based on the SOAP message processing model.
boolean | handleRequest(MessageContext context) The handleRequest method processes the request SOAP message.
boolean | handleResponse(MessageContext context) The handleResponse method processes the response message.
void | init(HandlerInfo config) The init method to enable the Handler instance to initialize itself.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GenericHandler

protected GenericHandler()
Default constructor

Method Detail

handleRequest

public boolean handleRequest(MessageContext context)
The handleRequest method processes the request SOAP message. The default implementation of this method returns true. This indicates that the handler chain should continue processing of the request SOAP message. This method should be overridden if the derived Handler class needs to specialize implementation of this method.

Specified by:
handleRequest in interface Handler
Parameters:
context - MessageContext parameter provides access to the request message.
Returns:
boolean Indicates the processing mode
  • Return true to indicate continued processing of the request handler chain. The HandlerChain takes the responsibility of invoking the next entity. The next entity may be the next handler in the HandlerChain or if this handler is the last handler in the chain, the next entity is the service endpoint object.
  • Return false to indicate blocking of the request handler chain. In this case, further processing of the request handler chain is blocked and the target service endpoint is not dispatched. The JAX-RPC runtime system takes the responsibility of invoking the response handler chain next with the SOAPMessageContext. The Handler implementation class has the the responsibility of setting the appropriate response SOAP message in either handleRequest and/or handleResponse method. In the default processing model, the response handler chain starts processing from the same Handler instance (that returned false) and goes backward in the execution sequence.
See Also:
Handler.handleRequest(javax.xml.rpc.handler.MessageContext)

handleResponse

public boolean handleResponse(MessageContext context)
The handleResponse method processes the response message. The default implementation of this method returns true. This indicates that the handler chain should continue processing of the response SOAP message. This method should be overridden if the derived Handler class needs to specialize implementation of this method.

Specified by:
handleResponse in interface Handler
Parameters:
context - MessageContext parameter provides access to the response SOAP message
Returns:
boolean Indicates the processing mode
  • Return true to indicate continued processing ofthe response handler chain. The HandlerChain invokes the handleResponse method on the next Handler in the handler chain.
  • Return false to indicate blocking of the response handler chain. In this case, no other response handlers in the handler chain are invoked.
See Also:
Handler.handleResponse(javax.xml.rpc.handler.MessageContext)

handleFault

public boolean handleFault(MessageContext context)
The handleFault method processes the SOAP faults based on the SOAP message processing model. The default implementation of this method returns true. This indicates that the handler chain should continue processing of the SOAP fault. This method should be overridden if the derived Handler class needs to specialize implementation of this method.

Specified by:
handleFault in interface Handler
Parameters:
context - MessageContext parameter provides access to the SOAP message
Returns:
boolean Indicates the processing mode
  • Return true to indicate continued processing of SOAP Fault. The HandlerChain invokes the handleFault method on the next Handler in the handler chain.
  • Return false to indicate end of the SOAP fault processing. In this case, no other handlers in the handler chain are invoked.
See Also:
Handler.handleFault(javax.xml.rpc.handler.MessageContext)

init

public void init(HandlerInfo config)
The init method to enable the Handler instance to initialize itself. This method should be overridden if the derived Handler class needs to specialize implementation of this method.

Specified by:
init in interface Handler
See Also:
Handler.init(javax.xml.rpc.handler.HandlerInfo)

destroy

public void destroy()
The destroy method indicates the end of lifecycle for a Handler instance. This method should be overridden if the derived Handler class needs to specialize implementation of this method.

Specified by:
destroy in interface Handler
See Also:
Handler.destroy()

getHeaders

public abstract QName[] getHeaders()
Gets the header blocks processed by this Handler instance.

Specified by:
getHeaders in interface Handler
Returns:
Array of QNames of header blocks processed by this handler instance. QName is the qualified name of the outermost element of the Header block.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Handler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler
Interface Handler

All Known Implementing Classes:
GenericHandler
public interface Handler

The javax.xml.rpc.handler.Handler interface is required to be implemented by a SOAP message handler. The handleRequest, handleResponse and handleFault methods for a SOAP message handler get access to the SOAPMessage from the SOAPMessageContext. The implementation of these methods can modify the SOAPMessage including the headers and body elements.

Version:
1.0
Author:
Rahul Sharma

Method Summary
void | destroy() The destroy method indicates the end of lifecycle for a Handler instance.
QName[] | getHeaders() Gets the header blocks that can be processed by this Handler instance.
boolean | handleFault(MessageContext context) The handleFault method processes the SOAP faults based on the SOAP message processing model.
boolean | handleRequest(MessageContext context) The handleRequest method processes the request message.
boolean | handleResponse(MessageContext context) The handleResponse method processes the response SOAP message.
void | init(HandlerInfo config) The init method enables the Handler instance to initialize itself.

Method Detail

handleRequest

boolean handleRequest(MessageContext context)
The handleRequest method processes the request message.

Parameters:
context - MessageContext parameter provides access to the request message.
Returns:
boolean Indicates the processing mode
  • Return true to indicate continued processing of the request handler chain. The HandlerChain takes the responsibility of invoking the next entity. The next entity may be the next handler in the HandlerChain or if this handler is the last handler in the chain, the next entity is the service endpoint object.
  • Return false to indicate blocking of the request handler chain. In this case, further processing of the request handler chain is blocked and the target service endpoint is not dispatched. The JAX-RPC runtime system takes the responsibility of invoking the response handler chain next with the SOAPMessageContext. The Handler implementation class has the the responsibility of setting the appropriate response SOAP message in either handleRequest and/or handleResponse method. In the default processing model, the response handler chain starts processing from the same Handler instance (that returned false) and goes backward in the execution sequence.
Throws:
JAXRPCException - This exception indicates handler specific runtime error. If JAXRPCException is thrown by a handleRequest method, the HandlerChain terminates the further processing of this handler chain. On the server side, the HandlerChain generates a SOAP fault that indicates that the message could not be processed for reasons not directly attributable to the contents of the message itself but rather to a runtime error during the processing of the message. On the client side, the exception is propagated to the client code
SOAPFaultException - This indicates a SOAP fault. The Handler implementation class has the the responsibility of setting the SOAP fault in the SOAP message in either handleRequest and/or handleFault method. If SOAPFaultException is thrown by a server-side request handler's handleRequest method, the HandlerChain terminates the further processing of the request handlers in this handler chain and invokes the handleFault method on the HandlerChain with the SOAP message context. Next, the HandlerChain invokes the handleFault method on handlers registered in the handler chain, beginning with the Handler instance that threw the exception and going backward in execution. The client-side request handler's handleRequest method should not throw the SOAPFaultException.

handleResponse

boolean handleResponse(MessageContext context)
The handleResponse method processes the response SOAP message.

Parameters:
context - MessageContext parameter provides access to the response SOAP message
Returns:
boolean Indicates the processing mode
  • Return true to indicate continued processing ofthe response handler chain. The HandlerChain invokes the handleResponse method on the next Handler in the handler chain.
  • Return false to indicate blocking of the response handler chain. In this case, no other response handlers in the handler chain are invoked.
Throws:
JAXRPCException - Indicates handler specific runtime error. If JAXRPCException is thrown by a handleResponse method, the HandlerChain terminates the further processing of this handler chain. On the server side, the HandlerChain generates a SOAP fault that indicates that the message could not be processed for reasons not directly attributable to the contents of the message itself but rather to a runtime error during the processing of the message. On the client side, the runtime exception is propagated to the client code.

handleFault

boolean handleFault(MessageContext context)
The handleFault method processes the SOAP faults based on the SOAP message processing model.

Parameters:
context - MessageContext parameter provides access to the SOAP message
Returns:
boolean Indicates the processing mode
  • Return true to indicate continued processing of SOAP Fault. The HandlerChain invokes the handleFault method on the next Handler in the handler chain.
  • Return false to indicate end of the SOAP fault processing. In this case, no other handlers in the handler chain are invoked.
Throws:
JAXRPCException - Indicates handler specific runtime error. If JAXRPCException is thrown by a handleFault method, the HandlerChain terminates the further processing of this handler chain. On the server side, the HandlerChain generates a SOAP fault that indicates that the message could not be processed for reasons not directly attributable to the contents of the message itself but rather to a runtime error during the processing of the message. On the client side, the JAXRPCException is propagated to the client code.

init

void init(HandlerInfo config)
The init method enables the Handler instance to initialize itself. The init method passes the handler configuration as a HandlerInfo instance. The HandlerInfo is used to configure the Handler (for example: setup access to an external resource or service) during the initialization.

In the init method, the Handler class may get access to any resources (for example; access to a logging service or database) and maintain these as part of its instance variables. Note that these instance variables must not have any state specific to the SOAP message processing performed in the various handle method.

Parameters:
HandlerInfo - Configuration for the initialization of this handler
Throws:
JAXRPCException - If initialization of the handler fails

destroy

void destroy()
The destroy method indicates the end of lifecycle for a Handler instance. The Handler implementation class should release its resources and perform cleanup in the implementation of the destroy method.

Throws:
JAXRPCException - If any error during destroy

getHeaders

QName[] getHeaders()
Gets the header blocks that can be processed by this Handler instance.

Returns:
Array of QNames of header blocks processed by this handler instance. QName is the qualified name of the outermost element of the Header block.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HandlerChain

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler
Interface HandlerChain

All Superinterfaces:
Collection, Iterable, List
public interface HandlerChain
extends List

The javax.xml.rpc.handler.HandlerChain represents a list of handlers. All elements in the HandlerChain are of the type javax.xml.rpc.handler.Handler.

An implementation class for the HandlerChain interface abstracts the policy and mechanism for the invocation of the registered handlers.

Version:
1.0
Author:
Rahul Sharma
See Also:
HandlerChain

Method Summary
void | destroy() Indicates the end of lifecycle for a HandlerChain.
String[] | getRoles() Gets SOAP actor roles registered for this HandlerChain at this SOAP node.
boolean | handleFault(MessageContext context) The handleFault method initiates the SOAP fault processing for this handler chain.
boolean | handleRequest(MessageContext context) The handleRequest method initiates the request processing for this handler chain.
boolean | handleResponse(MessageContext context) The handleResponse method initiates the response processing for this handler chain.
void | init(Map config) Initializes the configuration for a HandlerChain.
void | setRoles(String[] soapActorNames) Sets SOAP Actor roles for this HandlerChain.
Methods inherited from interface java.util.List
add, add, addAll, addAll, clear, contains, containsAll, equals, get, hashCode, indexOf, isEmpty, iterator, lastIndexOf, listIterator, listIterator, remove, remove, removeAll, retainAll, set, size, subList, toArray, toArray

Method Detail

handleRequest

boolean handleRequest(MessageContext context)
The handleRequest method initiates the request processing for this handler chain.

Parameters:
context - MessageContext parameter provides access to the request SOAP message.
Returns:
boolean Returns true if all handlers in chain have been processed. Returns false if a handler in the chain returned false from its handleRequest method.
Throws:
JAXRPCException - if any processing error happens
See Also:
Handler.handleRequest(javax.xml.rpc.handler.MessageContext)

handleResponse

boolean handleResponse(MessageContext context)
The handleResponse method initiates the response processing for this handler chain.

Parameters:
context - MessageContext parameter provides access to the response SOAP message.
Returns:
boolean Returns true if all handlers in chain have been processed. Returns false if a handler in the chain returned false from its handleResponse method.
Throws:
JAXRPCException - if any processing error happens
See Also:
Handler.handleResponse(javax.xml.rpc.handler.MessageContext)

handleFault

boolean handleFault(MessageContext context)
The handleFault method initiates the SOAP fault processing for this handler chain.

Parameters:
context - MessageContext parameter provides access to the SOAP message.
Returns:
boolean Returns true if all handlers in chain have been processed. Returns false if a handler in the chain returned false from its handleFault method.
Throws:
JAXRPCException - if any processing error happens
See Also:
Handler.handleFault(javax.xml.rpc.handler.MessageContext)

init

void init(Map config)
Initializes the configuration for a HandlerChain.

Parameters:
config - Configuration for the initialization of this handler chain
Throws:
JAXRPCException - If any error during initialization

destroy

void destroy()
Indicates the end of lifecycle for a HandlerChain.

Throws:
JAXRPCException - If any error during destroy

setRoles

void setRoles(String[] soapActorNames)
Sets SOAP Actor roles for this HandlerChain. This specifies the set of roles in which this HandlerChain is to act for the SOAP message processing at this SOAP node. These roles assumed by a HandlerChain must be invariant during the processing of an individual SOAP message through the HandlerChain.

A HandlerChain always acts in the role of the special SOAP actor next. Refer to the SOAP specification for the URI name for this special SOAP actor. There is no need to set this special role using this method.

Parameters:
soapActorNames - URIs for SOAP actor name
See Also:
NamespaceConstants

getRoles

String[] getRoles()
Gets SOAP actor roles registered for this HandlerChain at this SOAP node. The returned array includes the special SOAP actor next.

Returns:
String[] SOAP Actor roles as URIs
See Also:
NamespaceConstants
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HandlerInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler
Class HandlerInfo

java.lang.Object
    extended by  javax.xml.rpc.handler.HandlerInfo
All Implemented Interfaces:
Serializable
public class HandlerInfo
extends Object
implements Serializable

The javax.xml.rpc.handler.HandlerInfo represents information about a handler in the HandlerChain. A HandlerInfo instance is passed in the Handler.init method to initialize a Handler instance.

Version:
1.0
Author:
Rahul Sharma
See Also:
HandlerChain, Serialized Form

Constructor Summary
HandlerInfo()
Default constructor
HandlerInfo(Class handlerClass, Map config, QName[] headers)
Constructor for HandlerInfo
Method Summary
Class | getHandlerClass() Gets the Handler class
Map | getHandlerConfig() Gets the Handler configuration
QName[] | getHeaders() Gets the header blocks processed by this Handler.
void | setHandlerClass(Class handlerClass) Sets the Handler class
void | setHandlerConfig(Map config) Sets the Handler configuration as java.util.Map
void | setHeaders(QName[] headers) Sets the header blocks processed by this Handler.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HandlerInfo

public HandlerInfo()
Default constructor

HandlerInfo

public HandlerInfo(Class handlerClass,
                   Map config,
                   QName[] headers)
Constructor for HandlerInfo

Parameters:
handlerClass - Java Class for the Handler
config - Handler Configuration as a java.util.Map
headers - QNames for the header blocks processed by this Handler. QName is the qualified name of the outermost element of a header block
Method Detail

setHandlerClass

public void setHandlerClass(Class handlerClass)
Sets the Handler class

Parameters:
handlerClass - Class for the Handler

getHandlerClass

public Class getHandlerClass()
Gets the Handler class

Returns:
Returns null if no Handler class has been set; otherwise the set handler class

setHandlerConfig

public void setHandlerConfig(Map config)
Sets the Handler configuration as java.util.Map

Parameters:
config - Configuration map

getHandlerConfig

public Map getHandlerConfig()
Gets the Handler configuration

Returns:
Returns empty Map if no configuration map has been set; otherwise returns the set configuration map

setHeaders

public void setHeaders(QName[] headers)
Sets the header blocks processed by this Handler.

Parameters:
headers - QNames of the header blocks. QName is the qualified name of the outermost element of the SOAP header block

getHeaders

public QName[] getHeaders()
Gets the header blocks processed by this Handler.

Returns:
Array of QNames for the header blocks. Returns null if no header blocks have been set using the setHeaders method.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HandlerRegistry

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler
Interface HandlerRegistry

All Superinterfaces:
Serializable
public interface HandlerRegistry
extends Serializable

The javax.xml.rpc.handler.HandlerRegistry provides support for the programmatic configuration of handlers in a HandlerRegistry.

A handler chain is registered per service endpoint, as indicated by the qualified name of a port. The getHandlerChain returns the handler chain (as a java.util.List) for the specified service endpoint. The returned handler chain is configured using the java.util.List interface. Each element in this list is required to be of the Java type javax.xml.rpc.handler.HandlerInfo.

Version:
1.0
Author:
Rahul Sharma
See Also:
Service

Method Summary
List | getHandlerChain(QName portName) Gets the handler chain for the specified service endpoint.
void | setHandlerChain(QName portName, List chain) Sets the handler chain for the specified service endpoint as a java.util.List.

Method Detail

getHandlerChain

List getHandlerChain(QName portName)
Gets the handler chain for the specified service endpoint. The returned List is used to configure this specific handler chain in this HandlerRegistry. Each element in this list is required to be of the Java type javax.xml.rpc.handler.HandlerInfo.

Parameters:
portName - Qualified name of the target service endpoint
Returns:
java.util.List Handler chain
Throws:
IllegalArgumentException - If an invalid portName is specified

setHandlerChain

void setHandlerChain(QName portName,
                     List chain)
Sets the handler chain for the specified service endpoint as a java.util.List. Each element in this list is required to be of the Java type javax.xml.rpc.handler.HandlerInfo.

Parameters:
portName - Qualified name of the target service endpoint
chain - A List representing configuration for the handler chain
Throws:
JAXRPCException - If any error in the configuration of the handler chain
UnsupportedOperationException - If this set operation is not supported. This is done to avoid any overriding of a pre-configured handler chain.
IllegalArgumentException - If an invalid portName is specified
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler
Interface MessageContext

All Known Subinterfaces:
SOAPMessageContext
public interface MessageContext

The interface MessageContext abstracts the message context that is processed by a handler in the handle method.

The MessageContext interface provides methods to manage a property set. MessageContext properties enable handlers in a handler chain to share processing related state.

Version:
1.1
Author:
Rahul Sharma, Roberto Chinnici
See Also:
Handler

Method Summary
boolean | containsProperty(String name) Returns true if the MessageContext contains a property with the specified name.
Object | getProperty(String name) Gets the value of a specific property from the MessageContext
Iterator | getPropertyNames() Returns an Iterator view of the names of the properties in this MessageContext
void | removeProperty(String name) Removes a property (name-value pair) from the MessageContext
void | setProperty(String name, Object value) Sets the name and value of a property associated with the MessageContext.

Method Detail

setProperty

void setProperty(String name,
                 Object value)
Sets the name and value of a property associated with the MessageContext. If the MessageContext contains a value of the same property, the old value is replaced.

Parameters:
name - Name of the property associated with the MessageContext
value - Value of the property
Throws:
IllegalArgumentException - If some aspect of the property is prevents it from being stored in the context
UnsupportedOperationException - If this method is not supported.

getProperty

Object getProperty(String name)
Gets the value of a specific property from the MessageContext

Parameters:
name - Name of the property whose value is to be retrieved
Returns:
Value of the property
Throws:
IllegalArgumentException - if an illegal property name is specified

removeProperty

void removeProperty(String name)
Removes a property (name-value pair) from the MessageContext

Parameters:
name - Name of the property to be removed
Throws:
IllegalArgumentException - if an illegal property name is specified

containsProperty

boolean containsProperty(String name)
Returns true if the MessageContext contains a property with the specified name.

Parameters:
name - Name of the property whose presense is to be tested
Returns:
Returns true if the MessageContext contains the property; otherwise false

getPropertyNames

Iterator getPropertyNames()
Returns an Iterator view of the names of the properties in this MessageContext

Returns:
Iterator for the property names
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


soap

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc.handler.soap

This package defines APIs for SOAP Message Handlers

See:
Description

Interface Summary
SOAPMessageContext The interface javax.xml.rpc.soap.SOAPMessageContext provides access to the SOAP message for either RPC request or response.

Package javax.xml.rpc.handler.soap Description

This package defines APIs for SOAP Message Handlers

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc.handler.soap Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc.handler.soap

Package Hierarchies:
All Packages

Interface Hierarchy

  • javax.xml.rpc.handler.MessageContext
    • javax.xml.rpc.handler.soap.SOAPMessageContext
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPMessageContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.handler.soap
Interface SOAPMessageContext

All Superinterfaces:
MessageContext
public interface SOAPMessageContext
extends MessageContext

The interface javax.xml.rpc.soap.SOAPMessageContext provides access to the SOAP message for either RPC request or response. The javax.xml.soap.SOAPMessage specifies the standard Java API for the representation of a SOAP 1.1 message with attachments.

Version:
1.0
Author:
Rahul Sharma
See Also:
SOAPMessage

Method Summary
SOAPMessage | getMessage() Gets the SOAPMessage from this message context
String[] | getRoles() Gets the SOAP actor roles associated with an execution of the HandlerChain and its contained Handler instances.
void | setMessage(SOAPMessage message) Sets the SOAPMessage in this message context
Methods inherited from interface javax.xml.rpc.handler.MessageContext
containsProperty, getProperty, getPropertyNames, removeProperty, setProperty

Method Detail

getMessage

SOAPMessage getMessage()
Gets the SOAPMessage from this message context

Returns:
Returns the SOAPMessage; returns null if no SOAPMessage is present in this message context

setMessage

void setMessage(SOAPMessage message)
Sets the SOAPMessage in this message context

Parameters:
message - SOAP message
Throws:
JAXRPCException - If any error during the setting of the SOAPMessage in this message context
UnsupportedOperationException - If this operation is not supported

getRoles

String[] getRoles()
Gets the SOAP actor roles associated with an execution of the HandlerChain and its contained Handler instances. Note that SOAP actor roles apply to the SOAP node and are managed using HandlerChain.setRoles and HandlerChain.getRoles. Handler instances in the HandlerChain use this information about the SOAP actor roles to process the SOAP header blocks. Note that the SOAP actor roles are invariant during the processing of SOAP message through the HandlerChain.

Returns:
Array of URIs for SOAP actor roles
See Also:
HandlerChain.setRoles(java.lang.String[]), HandlerChain.getRoles()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


holders

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc.holders

This package contains the standard Java Holder classes.

See:
Description

Interface Summary
Holder The java.xml.rpc.holders.Holder interface represents the base interface for both standard and generated Holder classes.

Class Summary
BigDecimalHolder
BigIntegerHolder
BooleanHolder
BooleanWrapperHolder
ByteArrayHolder
ByteHolder
ByteWrapperHolder
CalendarHolder
DoubleHolder
DoubleWrapperHolder
FloatHolder
FloatWrapperHolder
IntegerWrapperHolder
IntHolder
LongHolder
LongWrapperHolder
ObjectHolder
QNameHolder
ShortHolder
ShortWrapperHolder
StringHolder

Package javax.xml.rpc.holders Description

This package contains the standard Java Holder classes.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Holder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Interface Holder

All Known Implementing Classes:
BigDecimalHolder, BigIntegerHolder, BooleanHolder, BooleanWrapperHolder, ByteArrayHolder, ByteHolder, ByteWrapperHolder, CalendarHolder, DoubleHolder, DoubleWrapperHolder, FloatHolder, FloatWrapperHolder, IntegerWrapperHolder, IntHolder, LongHolder, LongWrapperHolder, ObjectHolder, QNameHolder, ShortHolder, ShortWrapperHolder, StringHolder
public interface Holder

The java.xml.rpc.holders.Holder interface represents the base interface for both standard and generated Holder classes. A generated Holder class is required to implement this Holder interface.

Version:
1.0
Author:
Rahul Sharma

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc.holders Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc.holders

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.rpc.holders.BigDecimalHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.BigIntegerHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.BooleanHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.BooleanWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ByteArrayHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ByteHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ByteWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.CalendarHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.DoubleHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.DoubleWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.FloatHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.FloatWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.IntegerWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.IntHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.LongHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.LongWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ObjectHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.QNameHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ShortHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.ShortWrapperHolder (implements javax.xml.rpc.holders.Holder)
    • javax.xml.rpc.holders.StringHolder (implements javax.xml.rpc.holders.Holder)

Interface Hierarchy

  • javax.xml.rpc.holders.Holder
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BigDecimalHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class BigDecimalHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.BigDecimalHolder
All Implemented Interfaces:
Holder
public final class BigDecimalHolder
extends Object
implements Holder

Field Summary
 BigDecimal value
Constructor Summary
BigDecimalHolder()
BigDecimalHolder(BigDecimal myBigDecimal)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public BigDecimal value
Constructor Detail

BigDecimalHolder

public BigDecimalHolder()

BigDecimalHolder

public BigDecimalHolder(BigDecimal myBigDecimal)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BigIntegerHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class BigIntegerHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.BigIntegerHolder
All Implemented Interfaces:
Holder
public final class BigIntegerHolder
extends Object
implements Holder

Field Summary
 BigInteger value
Constructor Summary
BigIntegerHolder()
BigIntegerHolder(BigInteger myBigInteger)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public BigInteger value
Constructor Detail

BigIntegerHolder

public BigIntegerHolder()

BigIntegerHolder

public BigIntegerHolder(BigInteger myBigInteger)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BooleanHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class BooleanHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.BooleanHolder
All Implemented Interfaces:
Holder
public final class BooleanHolder
extends Object
implements Holder

Field Summary
 boolean value
Constructor Summary
BooleanHolder()
BooleanHolder(boolean myboolean)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public boolean value
Constructor Detail

BooleanHolder

public BooleanHolder()

BooleanHolder

public BooleanHolder(boolean myboolean)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BooleanWrapperHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class BooleanWrapperHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.BooleanWrapperHolder
All Implemented Interfaces:
Holder
public final class BooleanWrapperHolder
extends Object
implements Holder

Field Summary
 Boolean value
Constructor Summary
BooleanWrapperHolder()
BooleanWrapperHolder(Boolean myboolean)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Boolean value
Constructor Detail

BooleanWrapperHolder

public BooleanWrapperHolder()

BooleanWrapperHolder

public BooleanWrapperHolder(Boolean myboolean)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ByteArrayHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class ByteArrayHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.ByteArrayHolder
All Implemented Interfaces:
Holder
public final class ByteArrayHolder
extends Object
implements Holder

Field Summary
 byte[] value
Constructor Summary
ByteArrayHolder()
ByteArrayHolder(byte[] mybyteArray)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public byte[] value
Constructor Detail

ByteArrayHolder

public ByteArrayHolder()

ByteArrayHolder

public ByteArrayHolder(byte[] mybyteArray)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ByteHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class ByteHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.ByteHolder
All Implemented Interfaces:
Holder
public final class ByteHolder
extends Object
implements Holder

Field Summary
 byte value
Constructor Summary
ByteHolder()
ByteHolder(byte mybyte)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public byte value
Constructor Detail

ByteHolder

public ByteHolder()

ByteHolder

public ByteHolder(byte mybyte)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ByteWrapperHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class ByteWrapperHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.ByteWrapperHolder
All Implemented Interfaces:
Holder
public final class ByteWrapperHolder
extends Object
implements Holder

Field Summary
 Byte value
Constructor Summary
ByteWrapperHolder()
ByteWrapperHolder(Byte mybyte)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Byte value
Constructor Detail

ByteWrapperHolder

public ByteWrapperHolder()

ByteWrapperHolder

public ByteWrapperHolder(Byte mybyte)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


CalendarHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class CalendarHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.CalendarHolder
All Implemented Interfaces:
Holder
public final class CalendarHolder
extends Object
implements Holder

Field Summary
 Calendar value
Constructor Summary
CalendarHolder()
CalendarHolder(Calendar myCalendar)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Calendar value
Constructor Detail

CalendarHolder

public CalendarHolder()

CalendarHolder

public CalendarHolder(Calendar myCalendar)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DoubleHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class DoubleHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.DoubleHolder
All Implemented Interfaces:
Holder
public final class DoubleHolder
extends Object
implements Holder

Field Summary
 double value
Constructor Summary
DoubleHolder()
DoubleHolder(double mydouble)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public double value
Constructor Detail

DoubleHolder

public DoubleHolder()

DoubleHolder

public DoubleHolder(double mydouble)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DoubleWrapperHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class DoubleWrapperHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.DoubleWrapperHolder
All Implemented Interfaces:
Holder
public final class DoubleWrapperHolder
extends Object
implements Holder

Field Summary
 Double value
Constructor Summary
DoubleWrapperHolder()
DoubleWrapperHolder(Double mydouble)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Double value
Constructor Detail

DoubleWrapperHolder

public DoubleWrapperHolder()

DoubleWrapperHolder

public DoubleWrapperHolder(Double mydouble)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FloatHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class FloatHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.FloatHolder
All Implemented Interfaces:
Holder
public final class FloatHolder
extends Object
implements Holder

Field Summary
 float value
Constructor Summary
FloatHolder()
FloatHolder(float myfloat)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public float value
Constructor Detail

FloatHolder

public FloatHolder()

FloatHolder

public FloatHolder(float myfloat)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FloatWrapperHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class FloatWrapperHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.FloatWrapperHolder
All Implemented Interfaces:
Holder
public final class FloatWrapperHolder
extends Object
implements Holder

Field Summary
 Float value
Constructor Summary
FloatWrapperHolder()
FloatWrapperHolder(Float myfloat)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Float value
Constructor Detail

FloatWrapperHolder

public FloatWrapperHolder()

FloatWrapperHolder

public FloatWrapperHolder(Float myfloat)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


IntegerWrapperHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class IntegerWrapperHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.IntegerWrapperHolder
All Implemented Interfaces:
Holder
public final class IntegerWrapperHolder
extends Object
implements Holder

Field Summary
 Integer value
Constructor Summary
IntegerWrapperHolder()
IntegerWrapperHolder(Integer myint)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Integer value
Constructor Detail

IntegerWrapperHolder

public IntegerWrapperHolder()

IntegerWrapperHolder

public IntegerWrapperHolder(Integer myint)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


IntHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class IntHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.IntHolder
All Implemented Interfaces:
Holder
public final class IntHolder
extends Object
implements Holder

Field Summary
 int value
Constructor Summary
IntHolder()
IntHolder(int myint)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public int value
Constructor Detail

IntHolder

public IntHolder()

IntHolder

public IntHolder(int myint)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LongHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class LongHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.LongHolder
All Implemented Interfaces:
Holder
public final class LongHolder
extends Object
implements Holder

Field Summary
 long value
Constructor Summary
LongHolder()
LongHolder(long mylong)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public long value
Constructor Detail

LongHolder

public LongHolder()

LongHolder

public LongHolder(long mylong)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LongWrapperHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class LongWrapperHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.LongWrapperHolder
All Implemented Interfaces:
Holder
public final class LongWrapperHolder
extends Object
implements Holder

Field Summary
 Long value
Constructor Summary
LongWrapperHolder()
LongWrapperHolder(Long mylong)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Long value
Constructor Detail

LongWrapperHolder

public LongWrapperHolder()

LongWrapperHolder

public LongWrapperHolder(Long mylong)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ObjectHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class ObjectHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.ObjectHolder
All Implemented Interfaces:
Holder
public final class ObjectHolder
extends Object
implements Holder

Field Summary
 Object value
Constructor Summary
ObjectHolder()
ObjectHolder(Object value)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Object value
Constructor Detail

ObjectHolder

public ObjectHolder()

ObjectHolder

public ObjectHolder(Object value)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


QNameHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class QNameHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.QNameHolder
All Implemented Interfaces:
Holder
public final class QNameHolder
extends Object
implements Holder

Field Summary
 QName value
Constructor Summary
QNameHolder()
QNameHolder(QName myQName)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public QName value
Constructor Detail

QNameHolder

public QNameHolder()

QNameHolder

public QNameHolder(QName myQName)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ShortHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class ShortHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.ShortHolder
All Implemented Interfaces:
Holder
public final class ShortHolder
extends Object
implements Holder

Field Summary
 short value
Constructor Summary
ShortHolder()
ShortHolder(short myshort)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public short value
Constructor Detail

ShortHolder

public ShortHolder()

ShortHolder

public ShortHolder(short myshort)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ShortWrapperHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class ShortWrapperHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.ShortWrapperHolder
All Implemented Interfaces:
Holder
public final class ShortWrapperHolder
extends Object
implements Holder

Field Summary
 Short value
Constructor Summary
ShortWrapperHolder()
ShortWrapperHolder(Short myshort)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public Short value
Constructor Detail

ShortWrapperHolder

public ShortWrapperHolder()

ShortWrapperHolder

public ShortWrapperHolder(Short myshort)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StringHolder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.holders
Class StringHolder

java.lang.Object
    extended by  javax.xml.rpc.holders.StringHolder
All Implemented Interfaces:
Holder
public final class StringHolder
extends Object
implements Holder

Field Summary
 String value
Constructor Summary
StringHolder()
StringHolder(String myString)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public String value
Constructor Detail

StringHolder

public StringHolder()

StringHolder

public StringHolder(String myString)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


JAXRPCException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Class JAXRPCException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.xml.rpc.JAXRPCException
All Implemented Interfaces:
Serializable
public class JAXRPCException
extends RuntimeException

The javax.xml.rpc.JAXRPCException is thrown from the core JAX-RPC APIs to indicate an exception related to the JAX-RPC runtime mechanisms.

Version:
1.0
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
JAXRPCException()
Constructs a new exception with null as its detail message.
JAXRPCException(String message)
Constructs a new exception with the specified detail message.
JAXRPCException(String message, Throwable cause)
Constructs a new exception with the specified detail message and cause.
JAXRPCException(Throwable cause)
Constructs a new JAXRPCException with the specified cause and a detail message of (cause==null ?
Method Summary
 Throwable getLinkedCause()
Gets the Linked cause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JAXRPCException

public JAXRPCException()
Constructs a new exception with null as its detail message. The cause is not initialized.

JAXRPCException

public JAXRPCException(String message)
Constructs a new exception with the specified detail message. The cause is not initialized.

Parameters:
message - The detail message which is later retrieved using the getMessage method

JAXRPCException

public JAXRPCException(String message,
                       Throwable cause)
Constructs a new exception with the specified detail message and cause.

Parameters:
message - The detail message which is later retrieved using the getMessage method
cause - The cause which is saved for the later retrieval throw by the getCause method

JAXRPCException

public JAXRPCException(Throwable cause)
Constructs a new JAXRPCException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

Parameters:
cause - The cause which is saved for the later retrieval throw by the getCause method. (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
Method Detail

getLinkedCause

public Throwable getLinkedCause()
Gets the Linked cause

Returns:
The cause of this Exception or null if the cause is noexistent or unknown
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NamespaceConstants

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Class NamespaceConstants

java.lang.Object
    extended by  javax.xml.rpc.NamespaceConstants

public class NamespaceConstants
extends Object

Constants used in JAX-RPC for namespace prefixes and URIs

Version:
1.0
Author:
Rahul Sharma

Field Summary
static String | NSPREFIX_SCHEMA_XSD Namespace prefix for XML schema XSD
static String | NSPREFIX_SCHEMA_XSI Namespace prefix for XML Schema XSI
static String | NSPREFIX_SOAP_ENCODING Namespace prefix for SOAP Encoding
static String | NSPREFIX_SOAP_ENVELOPE Namespace prefix for SOAP Envelope
static String | NSURI_SCHEMA_XSD Namespace URI for XML Schema XSD
static String | NSURI_SCHEMA_XSI Namespace URI for XML Schema XSI
static String | NSURI_SOAP_ENCODING Nameapace URI for SOAP 1.1 Encoding
static String | NSURI_SOAP_ENVELOPE Nameapace URI for SOAP 1.1 Envelope
static String | NSURI_SOAP_NEXT_ACTOR Nameapace URI for SOAP 1.1 next actor role
Constructor Summary
NamespaceConstants()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NSPREFIX_SOAP_ENVELOPE

public static final String NSPREFIX_SOAP_ENVELOPE
Namespace prefix for SOAP Envelope

See Also:
Constant Field Values

NSPREFIX_SOAP_ENCODING

public static final String NSPREFIX_SOAP_ENCODING
Namespace prefix for SOAP Encoding

See Also:
Constant Field Values

NSPREFIX_SCHEMA_XSD

public static final String NSPREFIX_SCHEMA_XSD
Namespace prefix for XML schema XSD

See Also:
Constant Field Values

NSPREFIX_SCHEMA_XSI

public static final String NSPREFIX_SCHEMA_XSI
Namespace prefix for XML Schema XSI

See Also:
Constant Field Values

NSURI_SOAP_ENVELOPE

public static final String NSURI_SOAP_ENVELOPE
Nameapace URI for SOAP 1.1 Envelope

See Also:
Constant Field Values

NSURI_SOAP_ENCODING

public static final String NSURI_SOAP_ENCODING
Nameapace URI for SOAP 1.1 Encoding

See Also:
Constant Field Values

NSURI_SOAP_NEXT_ACTOR

public static final String NSURI_SOAP_NEXT_ACTOR
Nameapace URI for SOAP 1.1 next actor role

See Also:
Constant Field Values

NSURI_SCHEMA_XSD

public static final String NSURI_SCHEMA_XSD
Namespace URI for XML Schema XSD

See Also:
Constant Field Values

NSURI_SCHEMA_XSI

public static final String NSURI_SCHEMA_XSI
Namespace URI for XML Schema XSI

See Also:
Constant Field Values
Constructor Detail

NamespaceConstants

public NamespaceConstants()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ParameterMode

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Class ParameterMode

java.lang.Object
    extended by  javax.xml.rpc.ParameterMode

public class ParameterMode
extends Object

The javax.xml.rpc.ParameterMode is a type-safe enumeration for parameter mode. This class is used in the CallAPI to specify parameter passing modes.

Version:
1.0
Author:
Rahul Sharma
See Also:
Call

Field Summary
static ParameterMode | IN IN mode for parameter passing
static ParameterMode | INOUT INOUT mode for parameter passing
static ParameterMode | OUT OUT mode for parameter passing
Method Summary
 String toString()
Returns a String describing this ParameterMode object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

IN

public static final ParameterMode IN
IN mode for parameter passing

OUT

public static final ParameterMode OUT
OUT mode for parameter passing

INOUT

public static final ParameterMode INOUT
INOUT mode for parameter passing

Method Detail

toString

public String toString()
Returns a String describing this ParameterMode object.

Overrides:
toString in class Object
Returns:
A string representation of the object.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


server

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc.server

This package defines APIs for the servlet based JAX-RPC endpoint model.

See:
Description

Interface Summary
ServiceLifecycle | The javax.xml.rpc.server.ServiceLifecycle defines a lifecycle interface for a JAX-RPC service endpoint.
ServletEndpointContext | The ServletEndpointContext provides an endpoint context maintained by the underlying servlet container based JAX-RPC runtime system.

Package javax.xml.rpc.server Description

This package defines APIs for the servlet based JAX-RPC endpoint model.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc.server Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc.server

Package Hierarchies:
All Packages

Interface Hierarchy

  • javax.xml.rpc.server.ServiceLifecycle
  • javax.xml.rpc.server.ServletEndpointContext
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServiceLifecycle

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.server
Interface ServiceLifecycle

public interface ServiceLifecycle

The javax.xml.rpc.server.ServiceLifecycle defines a lifecycle interface for a JAX-RPC service endpoint. If the service endpoint class implements the ServiceLifeycle interface, the servlet container based JAX-RPC runtime system is required to manage the lifecycle of the corresponding service endpoint objects.

Version:
1.0
Author:
Rahul Sharma

Method Summary
void | destroy() JAX-RPC runtime system ends the lifecycle of a service endpoint instance by invoking the destroy method.
void | init(Object context) Used for initialization of a service endpoint.

Method Detail

init

void init(Object context)
          throws ServiceException
Used for initialization of a service endpoint. After a service endpoint instance (an instance of a service endpoint class) is instantiated, the JAX-RPC runtime system invokes the init method. The service endpoint class uses the init method to initialize its configuration and setup access to any external resources. The context parameter in the init method enables the endpoint instance to access the endpoint context provided by the underlying JAX-RPC runtime system.

The init method implementation should typecast the context parameter to an appropriate Java type. For service endpoints deployed on a servlet container based JAX-RPC runtime system, the context parameter is of the Java type javax.xml.rpc.server.ServletEndpointContext. The ServletEndpointContext provides an endpoint context maintained by the underlying servlet container based JAX-RPC runtime system

Parameters:
context - Endpoint context for a JAX-RPC service endpoint
Throws:
ServiceException - If any error in initialization of the service endpoint; or if any illegal context has been provided in the init method

destroy

void destroy()
JAX-RPC runtime system ends the lifecycle of a service endpoint instance by invoking the destroy method. The service endpoint releases its resourcesin the implementation of the destroy method.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServletEndpointContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.server
Interface ServletEndpointContext

public interface ServletEndpointContext

The ServletEndpointContext provides an endpoint context maintained by the underlying servlet container based JAX-RPC runtime system. For service endpoints deployed on a servlet container based JAX-RPC runtime system, the context parameter in the ServiceLifecycle.init method is required to be of the Java type javax.xml.rpc.server.ServletEndpointContext.

A servlet container based JAX-RPC runtime system implements the ServletEndpointContext interface. The JAX-RPC runtime system is required to provide appropriate session, message context, servlet context and user principal information per method invocation on the endpoint class.

Version:
1.1
Author:
Rahul Sharma, Roberto Chinnici

Method Summary
HttpSession | getHttpSession() The getHttpSession method returns the current HTTP session (as a javax.servlet.http.HTTPSession).
MessageContext | getMessageContext() The method getMessageContext returns the MessageContext targeted for this endpoint instance.
ServletContext | getServletContext() The method getServletContext returns the ServletContext associated with the web application that contain this endpoint.
Principal | getUserPrincipal() Returns a java.security.Principal instance that contains the name of the authenticated user for the current method invocation on the endpoint instance.
boolean | isUserInRole(String role) Returns a boolean indicating whether the authenticated user for the current method invocation on the endpoint instance is included in the specified logical "role".

Method Detail

getMessageContext

MessageContext getMessageContext()
The method getMessageContext returns the MessageContext targeted for this endpoint instance. This enables the service endpoint instance to acccess the MessageContext propagated by request HandlerChain (and its contained Handler instances) to the target endpoint instance and to share any SOAP message processing related context. The endpoint instance can access and manipulate the MessageContext and share the SOAP message processing related context with the response HandlerChain.

Returns:
MessageContext; If there is no associated MessageContext, this method returns null.
Throws:
IllegalStateException - if this method is invoked outside a remote method implementation by a service endpoint instance.
See Also:
MessageContext, HandlerChain, Handler

getUserPrincipal

Principal getUserPrincipal()
Returns a java.security.Principal instance that contains the name of the authenticated user for the current method invocation on the endpoint instance. This method returns null if there is no associated principal yet. The underlying JAX-RPC runtime system takes the responsibility of providing the appropriate authenticated principal for a remote method invocation on the service endpoint instance.

Returns:
A java.security.Principal for the authenticated principal associated with the current invocation on the servlet endpoint instance; Returns null if there no authenticated user associated with a method invocation.
See Also:
Principal

getHttpSession

HttpSession getHttpSession()
The getHttpSession method returns the current HTTP session (as a javax.servlet.http.HTTPSession). When invoked by the service endpoint within a remote method implementation, the getHttpSession returns the HTTP session associated currently with this method invocation. This method returns null if there is no HTTP session currently active and associated with this service endpoint. An endpoint class should not rely on an active HTTP session being always there; the underlying JAX-RPC runtime system is responsible for managing whether or not there is an active HTTP session.

The getHttpSession method throws JAXRPCException if invoked by an non HTTP bound endpoint.

Returns:
The HTTP session associated with the current invocation or null if there is no active session.
Throws:
JAXRPCException - If this method invoked by any non-HTTP bound endpoint
See Also:
HttpSession

getServletContext

ServletContext getServletContext()
The method getServletContext returns the ServletContext associated with the web application that contain this endpoint. According to the Servlet specification, There is one context per web application (installed as a WAR) per JVM . A servlet based service endpoint is deployed as part of a web application.

Returns:
ServletContext
See Also:
ServletContext

isUserInRole

boolean isUserInRole(String role)
Returns a boolean indicating whether the authenticated user for the current method invocation on the endpoint instance is included in the specified logical "role".

Parameters:
role - a String specifying the name of the role
Returns:
a boolean indicating whether the authenticated user associated with the current method invocation belongs to a given role; false if the user has not been authenticated
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Service

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Interface Service

public interface Service

Service class acts as a factory of the following:

  • Dynamic proxy for the target service endpoint.
  • Instance of the type javax.xml.rpc.Call for the dynamic invocation of a remote operation on the target service endpoint.
  • Instance of a generated stub class

Version:
1.0
Author:
Rahul Sharma
See Also:
Call, Stub

Method Summary
Call | createCall() Creates a Call object not associated with specific operation or target service endpoint.
Call | createCall(QName portName) Creates a Call instance.
Call | createCall(QName portName, QName operationName) Creates a Call instance.
Call | createCall(QName portName, String operationName) Creates a Call instance.
Call[] | getCalls(QName portName) Gets an array of preconfigured Call objects for invoking operations on the specified port.
HandlerRegistry | getHandlerRegistry() Returns the configured HandlerRegistry instance for this Service instance.
Remote | getPort(Class serviceEndpointInterface) The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.
Remote | getPort(QName portName, Class serviceEndpointInterface) The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy.
Iterator | getPorts() Returns an Iterator for the list of QNames of service endpoints grouped by this service
QName | getServiceName() Gets the name of this service.
TypeMappingRegistry | getTypeMappingRegistry() Gets the TypeMappingRegistry for this Service object.
URL | getWSDLDocumentLocation() Gets the location of the WSDL document for this Service.

Method Detail

getPort

Remote getPort(QName portName,
               Class serviceEndpointInterface)
               throws ServiceException
The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy. A service client uses this dynamic proxy to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy or stub instance.

Parameters:
portName - Qualified name of the service endpoint in the WSDL service description
serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy or stub instance
Returns:
java.rmi.Remote Stub instance or dynamic proxy that supports the specified service endpoint interface
Throws:
ServiceException - This exception is thrown in the following cases:
  • If there is an error in creation of the dynamic proxy or stub instance
  • If there is any missing WSDL metadata as required by this method
  • Optionally, if an illegal serviceEndpointInterface or portName is specified
See Also:
Proxy, InvocationHandler

getPort

Remote getPort(Class serviceEndpointInterface)
               throws ServiceException
The getPort method returns either an instance of a generated stub implementation class or a dynamic proxy. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned stub or proxy. In the implementation of this method, the JAX-RPC runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the stub accordingly. The returned Stub instance should not be reconfigured by the client.

Parameters:
serviceEndpointInterface - Service endpoint interface
Returns:
Stub instance or dynamic proxy that supports the specified service endpoint interface
Throws:
ServiceException -
  • If there is an error during creation of stub instance or dynamic proxy
  • If there is any missing WSDL metadata as required by this method
  • Optionally, if an illegal serviceEndpointInterface is specified

getCalls

Call[] getCalls(QName portName)
                throws ServiceException
Gets an array of preconfigured Call objects for invoking operations on the specified port. There is one Call object per operation that can be invoked on the specified port. Each Call object is pre-configured and does not need to be configured using the setter methods on Call interface.

Each invocation of the getCalls method returns a new array of preconfigured Call objects

This method requires the Service implementation class to have access to the WSDL related metadata.

Parameters:
portName - Qualified name for the target service endpoint
Returns:
Call[] Array of pre-configured Call objects
Throws:
ServiceException - If this Service class does not have access to the required WSDL metadata or if an illegal portName is specified.

createCall

Call createCall(QName portName)
                throws ServiceException
Creates a Call instance.

Parameters:
portName - Qualified name for the target service endpoint
Returns:
Call instance
Throws:
ServiceException - If any error in the creation of the Call object

createCall

Call createCall(QName portName,
                QName operationName)
                throws ServiceException
Creates a Call instance.

Parameters:
portName - Qualified name for the target service endpoint
operationName - Qualified Name of the operation for which this Call object is to be created.
Returns:
Call instance
Throws:
ServiceException - If any error in the creation of the Call object

createCall

Call createCall(QName portName,
                String operationName)
                throws ServiceException
Creates a Call instance.

Parameters:
portName - Qualified name for the target service endpoint
operationName - Name of the operation for which this Call object is to be created.
Returns:
Call instance
Throws:
ServiceException - If any error in the creation of the Call object

createCall

Call createCall()
                throws ServiceException
Creates a Call object not associated with specific operation or target service endpoint. This Call object needs to be configured using the setter methods on the Call interface.

Returns:
Call object
Throws:
ServiceException - If any error in the creation of the Call object

getServiceName

QName getServiceName()
Gets the name of this service.

Returns:
Qualified name of this service

getPorts

Iterator getPorts()
                  throws ServiceException
Returns an Iterator for the list of QNames of service endpoints grouped by this service

Returns:
Returns java.util.Iterator with elements of type javax.xml.namespace.QName
Throws:
ServiceException - If this Service class does not have access to the required WSDL metadata

getWSDLDocumentLocation

URL getWSDLDocumentLocation()
Gets the location of the WSDL document for this Service.

Returns:
URL for the location of the WSDL document for this service

getTypeMappingRegistry

TypeMappingRegistry getTypeMappingRegistry()
Gets the TypeMappingRegistry for this Service object. The returned TypeMappingRegistry instance is pre-configured to support the standard type mapping between XML and Java types types as required by the JAX-RPC specification.

Returns:
The TypeMappingRegistry for this Service object.
Throws:
java.lang.UnsupportedOperationException - if the Service class does not support the configuration of TypeMappingRegistry.

getHandlerRegistry

HandlerRegistry getHandlerRegistry()
Returns the configured HandlerRegistry instance for this Service instance.

Returns:
HandlerRegistry
Throws:
java.lang.UnsupportedOperationException - if the Service class does not support the configuration of a HandlerRegistry
Overview  Package   Class  Tree  Deprecated  Index  Help
Java EE 5 SDK
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServiceException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Class ServiceException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.rpc.ServiceException
All Implemented Interfaces:
Serializable
public class ServiceException
extends Exception

The javax.xml.rpc.ServiceException is thrown from the methods in the javax.xml.rpc.Service interface and ServiceFactory class.

Version:
1.0
Author:
Rahul Sharma
See Also:
Serialized Form

Constructor Summary
ServiceException()
Constructs a new exception with null as its detail message.
ServiceException(String message)
Constructs a new exception with the specified detail message.
ServiceException(String message, Throwable cause)
Constructs a new exception with the specified detail message and cause.
ServiceException(Throwable cause)
Constructs a new exception with the specified cause and a detail message of (cause==null ?
Method Summary
 Throwable getLinkedCause()
Gets the Linked cause
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ServiceException

public ServiceException()
Constructs a new exception with null as its detail message. The cause is not initialized.

ServiceException

public ServiceException(String message)
Constructs a new exception with the specified detail message. The cause is not initialized.

Parameters:
message - The detail message which is later retrieved using the getMessage method

ServiceException

public ServiceException(String message,
                        Throwable cause)
Constructs a new exception with the specified detail message and cause.

Parameters:
message - The detail message which is later retrieved using the getMessage method
cause - The cause which is saved for the later retrieval throw by the getCause method

ServiceException

public ServiceException(Throwable cause)
Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

Parameters:
cause - The cause which is saved for the later retrieval throw by the getCause method. (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
Method Detail

getLinkedCause

public Throwable getLinkedCause()
Gets the Linked cause

Returns:
The cause of this Exception or null if the cause is noexistent or unknown
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServiceFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Class ServiceFactory

java.lang.Object
    extended by  javax.xml.rpc.ServiceFactory

public abstract class ServiceFactory
extends Object

The javax.xml.rpc.ServiceFactory is an abstract class that provides a factory for the creation of instances of the type javax.xml.rpc.Service. This abstract class follows the abstract static factory design pattern. This enables a J2SE based client to create a Service instance in a portable manner without using the constructor of the Service implementation class.

The ServiceFactory implementation class is set using the system property SERVICEFACTORY_PROPERTY.

Version:
1.1
Author:
Rahul Sharma, Roberto Chinnici
See Also:
Service

Field Summary
static String SERVICEFACTORY_PROPERTY
A constant representing the property used to lookup the name of a ServiceFactory implementation class.
Constructor Summary
protected ServiceFactory()
Method Summary
abstract Service | createService(QName serviceName) Create a Service instance.
abstract Service | createService(URL wsdlDocumentLocation, QName serviceName) Create a Service instance.
abstract Service | loadService(Class serviceInterface) Create an instance of the generated service implementation class for a given service interface, if available.
abstract Service | loadService(URL wsdlDocumentLocation, Class serviceInterface, Properties properties) Create an instance of the generated service implementation class for a given service interface, if available.
abstract Service | loadService(URL wsdlDocumentLocation, QName serviceName, Properties properties) Create an instance of the generated service implementation class for a given service, if available.
static ServiceFactory | newInstance() Gets an instance of the ServiceFactory Only one copy of a factory exists and is returned to the application each time this method is called.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SERVICEFACTORY_PROPERTY

public static final String SERVICEFACTORY_PROPERTY
A constant representing the property used to lookup the name of a ServiceFactory implementation class.

See Also:
Constant Field Values
Constructor Detail

ServiceFactory

protected ServiceFactory()
Method Detail

newInstance

public static ServiceFactory newInstance()
                                  throws ServiceException
Gets an instance of the ServiceFactory

Only one copy of a factory exists and is returned to the application each time this method is called.

The implementation class to be used can be overridden by setting the javax.xml.rpc.ServiceFactory system property.

Throws:
ServiceException

createService

public abstract Service createService(URL wsdlDocumentLocation,
                                      QName serviceName)
                               throws ServiceException
Create a Service instance.

Parameters:
wsdlDocumentLocation - URL for the WSDL document location for the service
serviceName - QName for the service
Throws:
ServiceException - If any error in creation of the specified service

createService

public abstract Service createService(QName serviceName)
                               throws ServiceException
Create a Service instance.

Parameters:
serviceName - QName for the service
Throws:
ServiceException - If any error in creation of the specified service

loadService

public abstract Service loadService(Class serviceInterface)
                             throws ServiceException
Create an instance of the generated service implementation class for a given service interface, if available.

Parameters:
serviceInterface - Service interface
Throws:
ServiceException - If there is any error while creating the specified service, including the case where a generated service implementation class cannot be located

loadService

public abstract Service loadService(URL wsdlDocumentLocation,
                                    Class serviceInterface,
                                    Properties properties)
                             throws ServiceException
Create an instance of the generated service implementation class for a given service interface, if available. An implementation may use the provided wsdlDocumentLocation and properties to help locate the generated implementation class. If no such class is present, a ServiceException will be thrown.

Parameters:
wsdlDocumentLocation - URL for the WSDL document location for the service or null
serviceInterface - Service interface
properties - A set of implementation-specific properties to help locate the generated service implementation class
Throws:
ServiceException - If there is any error while creating the specified service, including the case where a generated service implementation class cannot be located

loadService

public abstract Service loadService(URL wsdlDocumentLocation,
                                    QName serviceName,
                                    Properties properties)
                             throws ServiceException
Create an instance of the generated service implementation class for a given service, if available. The service is uniquely identified by the wsdlDocumentLocation and serviceName arguments. An implementation may use the provided properties to help locate the generated implementation class. If no such class is present, a ServiceException will be thrown.

Parameters:
wsdlDocumentLocation - URL for the WSDL document location for the service or null
serviceName - Qualified name for the service
properties - A set of implementation-specific properties to help locate the generated service implementation class
Throws:
ServiceException - If there is any error while creating the specified service, including the case where a generated service implementation class cannot be located
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


soap

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.rpc.soap

This package defines APIs specific to the SOAP binding.

See:
Description

Exception Summary
SOAPFaultException The SOAPFaultException exception represents a SOAP fault.

Package javax.xml.rpc.soap Description

This package defines APIs specific to the SOAP binding.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.rpc.soap Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.rpc.soap

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.rpc.soap.SOAPFaultException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPFaultException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc.soap
Class SOAPFaultException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.xml.rpc.soap.SOAPFaultException
All Implemented Interfaces:
Serializable
public class SOAPFaultException
extends RuntimeException

The SOAPFaultException exception represents a SOAP fault.

The message part in the SOAP fault maps to the contents of faultdetail element accessible through the getDetail method on the SOAPFaultException. The method createDetail on the javax.xml.soap.SOAPFactory creates an instance of the javax.xml.soap.Detail.

The faultstring provides a human-readable description of the SOAP fault. The faultcode element provides an algorithmic mapping of the SOAP fault.

Refer to SOAP 1.1 and WSDL 1.1 specifications for more details of the SOAP faults.

Version:
1.0
Author:
Rahul Sharma
See Also:
Detail, SOAPFactory.createDetail(), Serialized Form

Constructor Summary
SOAPFaultException(QName faultcode, String faultstring, String faultactor, Detail faultdetail)
Constructor for the SOAPFaultException
Method Summary
Detail | getDetail() Gets the detail element.
String | getFaultActor() Gets the faultactor element.
QName | getFaultCode() Gets the faultcode element.
String | getFaultString() Gets the faultstring element.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SOAPFaultException

public SOAPFaultException(QName faultcode,
                          String faultstring,
                          String faultactor,
                          Detail faultdetail)
Constructor for the SOAPFaultException

Parameters:
faultCode - QName for the SOAP faultcode
faultstring - faultstring element of SOAP fault
faultactor - faultactor element of SOAP fault
faultdetail - faultdetail element of SOAP fault
See Also:
SOAPFactory.createDetail()
Method Detail

getFaultCode

public QName getFaultCode()
Gets the faultcode element. The faultcode element provides an algorithmic mechanism for identifying the fault. SOAP defines a small set of SOAP fault codes covering basic SOAP faults.

Returns:
QName of the faultcode element

getFaultString

public String getFaultString()
Gets the faultstring element. The faultstring provides a human-readable description of the SOAP fault and is not intended for algorithmic processing.

Returns:
faultstring element of the SOAP fault

getFaultActor

public String getFaultActor()
Gets the faultactor element. The faultactor element provides information about which SOAP node on the SOAP message path caused the fault to happen. It indicates the source of the fault.

Returns:
faultactor element of the SOAP fault

getDetail

public Detail getDetail()
Gets the detail element. The detail element is intended for carrying application specific error information related to the SOAP Body.

Parameters:
detail - element of the SOAP fault
See Also:
Detail
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Stub

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.rpc
Interface Stub

public interface Stub

The interface javax.xml.rpc.Stub is the common base interface for the stub classes. All generated stub classes are required to implement the javax.xml.rpc.Stub interface. An instance of a stub class represents a client side proxy or stub instance for the target service endpoint.

The javax.xml.rpc.Stub interface provides an extensible property mechanism for the dynamic configuration of a stub instance.

Version:
0.1
Author:
Rahul Sharma
See Also:
Service

Field Summary
static String | ENDPOINT_ADDRESS_PROPERTY Standard property: Target service endpoint address.
static String | PASSWORD_PROPERTY Standard property: Password for authentication.
static String | SESSION_MAINTAIN_PROPERTY Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.
static String | USERNAME_PROPERTY Standard property: User name for authentication.
Method Summary
Object | _getProperty(String name) Gets the value of a specific configuration property.
Iterator | _getPropertyNames() Returns an Iterato view of the names of the properties that can be configured on this stub instance.
void | _setProperty(String name, Object value) Sets the name and value of a configuration property for this Stub instance.

Field Detail

USERNAME_PROPERTY

static final String USERNAME_PROPERTY
Standard property: User name for authentication.

Type: java.lang.String

See Also:
Constant Field Values

PASSWORD_PROPERTY

static final String PASSWORD_PROPERTY
Standard property: Password for authentication.

Type: java.lang.String

See Also:
Constant Field Values

ENDPOINT_ADDRESS_PROPERTY

static final String ENDPOINT_ADDRESS_PROPERTY
Standard property: Target service endpoint address. The URI scheme for the endpoint address specification must correspond to the protocol/transport binding for this stub class.

Type: java.lang.String

See Also:
Constant Field Values

SESSION_MAINTAIN_PROPERTY

static final String SESSION_MAINTAIN_PROPERTY
Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint. If this property is set to true, the service client indicates that it wants the session to be maintained. If set to false, the session is not maintained. The default value for this property is false.

Type: java.lang.Boolean

See Also:
Constant Field Values
Method Detail

_setProperty

void _setProperty(String name,
                  Object value)
Sets the name and value of a configuration property for this Stub instance. If the Stub instances contains a value of the same property, the old value is replaced.

Note that the _setProperty method may not perform validity check on a configured property value. An example is the standard property for the target service endpoint address that is not checked for validity in the _setProperty method. In this case, stub configuration errors are detected at the remote method invocation.

Parameters:
name - Name of the configuration property
value - Value of the property
Throws:
JAXRPCException -
  • If an optional standard property name is specified, however this Stub implementation class does not support the configuration of this property.
  • If an invalid or unsupported property name is specified or if a value of mismatched property type is passed.
  • If there is any error in the configuration of a valid property.

_getProperty

Object _getProperty(String name)
Gets the value of a specific configuration property.

Parameters:
name - Name of the property whose value is to be retrieved
Returns:
Value of the configuration property
Throws:
JAXRPCException - if an invalid or unsupported property name is passed.

_getPropertyNames

Iterator _getPropertyNames()
Returns an Iterato view of the names of the properties that can be configured on this stub instance.

Returns:
Iterator for the property names of the type java.lang.String
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


soap

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.soap

Provides the API for creating and building SOAP messages.

See:
Description

Interface Summary
Detail | A container for DetailEntry objects.
DetailEntry | The content for a Detail object, giving details for a SOAPFault object.
Name | A representation of an XML name.
Node | A representation of a node (element) in an XML document.
SOAPBody | An object that represents the contents of the SOAP body element in a SOAP message.
SOAPBodyElement | A SOAPBodyElement object represents the contents in a SOAPBody object.
SOAPConstants | The definition of constants pertaining to the SOAP protocol.
SOAPElement | An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
SOAPEnvelope | The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
SOAPFault | An element in the SOAPBody object that contains error and/or status information.
SOAPFaultElement | A representation of the contents in a SOAPFault object.
SOAPHeader | A representation of the SOAP header element.
SOAPHeaderElement | An object representing the contents in the SOAP header part of the SOAP envelope.
Text | A representation of a node whose value is text.

Class Summary
AttachmentPart | A single attachment to a SOAPMessage object.
MessageFactory | A factory for creating SOAPMessage objects.
MimeHeader | An object that stores a MIME header name and its value.
MimeHeaders | A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.
SAAJMetaFactory | The access point for the implementation classes of the factories defined in the SAAJ API.
SAAJResult | Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree.
SOAPConnection | A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).
SOAPConnectionFactory | A factory for creating SOAPConnection objects.
SOAPElementFactory | Deprecated. - Use javax.xml.soap.SOAPFactory for creating SOAPElements.
SOAPFactory | SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.
SOAPMessage | The root class for all SOAP messages.
SOAPPart | The container for the SOAP-specific portion of a SOAPMessage object.

Exception Summary
SOAPException An exception that signals that a SOAP exception has occurred.

Package javax.xml.soap Description

Provides the API for creating and building SOAP messages. This package is defined in the SOAP with Attachments API for JavaTM (SAAJ) 1.3 specification.

The API in the javax.xml.soap package allows you to do the following:

  • create a point-to-point connection to a specified endpoint
  • create a SOAP message
  • create an XML fragment
  • add content to the header of a SOAP message
  • add content to the body of a SOAP message
  • create attachment parts and add content to them
  • access/add/modify parts of a SOAP message
  • create/add/modify SOAP fault information
  • extract content from a SOAP message
  • send a SOAP request-response message

In addition the APIs in the javax.xml.soap package extend their counterparts in the org.w3c.dom package. This means that the SOAPPart of a SOAPMessage is also a DOM Level 2 Document, and can be manipulated as such by applications, tools and libraries that use DOM (see http://www.w3.org/DOM/ for more information). It is important to note that, while it is possible to use DOM APIs to add ordinary DOM nodes to a SAAJ tree, the SAAJ APIs are still required to return SAAJ types when examining or manipulating the tree. In order to accomplish this the SAAJ APIs (specifically SOAPElement.getChildElements()) are allowed to silently replace objects that are incorrectly typed relative to SAAJ requirements with equivalent objects of the required type. These replacements must never cause the logical structure of the tree to change, so from the perspective of the DOM APIs the tree will remain unchanged. However, the physical composition of the tree will have changed so that references to the nodes that were replaced will refer to nodes that are no longer a part of the tree. The SAAJ APIs are not allowed to make these replacements if they are not required so the replacement objects will never subsequently be silently replaced by future calls to the SAAJ API.

What this means in practical terms is that an application that starts to use SAAJ APIs on a tree after manipulating it using DOM APIs must assume that the tree has been translated into an all SAAJ tree and that any references to objects within the tree that were obtained using DOM APIs are no longer valid. Switching from SAAJ APIs to DOM APIs is not allowed to cause invalid references and neither is using SAAJ APIs exclusively. It is only switching from using DOM APIs on a particular SAAJ tree to using SAAJ APIs that causes the risk of invalid references.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DetailEntry

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface DetailEntry

All Superinterfaces:
Element, Node, SOAPElement
public interface DetailEntry
extends SOAPElement

The content for a Detail object, giving details for a SOAPFault object. A DetailEntry object, which carries information about errors related to the SOAPBody object that contains it, is application-specific.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.soap Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.soap

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.soap.AttachmentPart
    • javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
      • javax.xml.soap.SAAJResult
    • javax.xml.soap.MessageFactory
    • javax.xml.soap.MimeHeader
    • javax.xml.soap.MimeHeaders
    • javax.xml.soap.SAAJMetaFactory
    • javax.xml.soap.SOAPConnection
    • javax.xml.soap.SOAPConnectionFactory
    • javax.xml.soap.SOAPElementFactory
    • javax.xml.soap.SOAPFactory
    • javax.xml.soap.SOAPMessage
    • javax.xml.soap.SOAPPart (implements org.w3c.dom.Document, javax.xml.soap.Node)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.xml.soap.SOAPException

Interface Hierarchy

  • javax.xml.soap.Name
  • org.w3c.dom.Node
    • org.w3c.dom.CharacterData
      • org.w3c.dom.Text
        • javax.xml.soap.Text (also extends javax.xml.soap.Node)
    • org.w3c.dom.Element
      • javax.xml.soap.SOAPElement (also extends javax.xml.soap.Node)
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
    • javax.xml.soap.Node
      • javax.xml.soap.SOAPElement (also extends org.w3c.dom.Element)
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.Text (also extends org.w3c.dom.Text)
  • javax.xml.soap.SOAPConstants
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPBodyElement

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPBodyElement

All Superinterfaces:
Element, Node, SOAPElement
All Known Subinterfaces:
SOAPFault
public interface SOAPBodyElement
extends SOAPElement

A SOAPBodyElement object represents the contents in a SOAPBody object. The SOAPFault interface is a SOAPBodyElement object that has been defined.

A new SOAPBodyElement object can be created and added to a SOAPBody object with the SOAPBody method addBodyElement. In the following line of code, sb is a SOAPBody object, and myName is a Name object.

    SOAPBodyElement sbe = sb.addBodyElement(myName);

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPFaultElement

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPFaultElement

All Superinterfaces:
Element, Node, SOAPElement
All Known Subinterfaces:
Detail
public interface SOAPFaultElement
extends SOAPElement

A representation of the contents in a SOAPFault object. The Detail interface is a SOAPFaultElement.

Content is added to a SOAPFaultElement using the SOAPElement method addTextNode.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AttachmentPart

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class AttachmentPart

java.lang.Object
    extended by  javax.xml.soap.AttachmentPart

public abstract class AttachmentPart
extends Object

A single attachment to a SOAPMessage object. A SOAPMessage object may contain zero, one, or many AttachmentPart objects. Each AttachmentPart object consists of two parts, application-specific content and associated MIME headers. The MIME headers consists of name/value pairs that can be used to identify and describe the content.

An AttachmentPart object must conform to certain standards.

  1. It must conform to MIME [RFC2045] standards
  2. It MUST contain content
  3. The header portion MUST include the following header:
    • Content-Type
      This header identifies the type of data in the content of an AttachmentPart object and MUST conform to [RFC2045]. The following is an example of a Content-Type header:
             Content-Type:  application/xml
      The following line of code, in which ap is an AttachmentPart object, sets the header shown in the previous example.
             ap.setMimeHeader("Content-Type", "application/xml");

There are no restrictions on the content portion of an AttachmentPart object. The content may be anything from a simple plain text object to a complex XML document or image file.

An AttachmentPart object is created with the method SOAPMessage.createAttachmentPart. After setting its MIME headers, the AttachmentPart object is added to the message that created it with the method SOAPMessage.addAttachmentPart.

The following code fragment, in which m is a SOAPMessage object and contentStringl is a String, creates an instance of AttachmentPart, sets the AttachmentPart object with some content and header information, and adds the AttachmentPart object to the SOAPMessage object.

     AttachmentPart ap1 = m.createAttachmentPart();
     ap1.setContent(contentString1, "text/plain");
     m.addAttachmentPart(ap1);

The following code fragment creates and adds a second AttachmentPart instance to the same message. jpegData is a binary byte buffer representing the jpeg file.

     AttachmentPart ap2 = m.createAttachmentPart();
     byte[] jpegData =  ...;
     ap2.setContent(new ByteArrayInputStream(jpegData), "image/jpeg");
     m.addAttachmentPart(ap2);

The getContent method retrieves the contents and header from an AttachmentPart object. Depending on the DataContentHandler objects present, the returned Object can either be a typed Java object corresponding to the MIME type or an InputStream object that contains the content as bytes.

     String content1 = ap1.getContent();
     java.io.InputStream content2 = ap2.getContent();
The method clearContent removes all the content from an AttachmentPart object but does not affect its header information.
     ap1.clearContent();

Constructor Summary
AttachmentPart()
Method Summary
abstract void | addMimeHeader(String name, String value) Adds a MIME header with the specified name and value to this AttachmentPart object.
abstract void | clearContent() Clears out the content of this AttachmentPart object.
abstract Iterator | getAllMimeHeaders() Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.
abstract InputStream | getBase64Content() Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.
abstract Object | getContent() Gets the content of this AttachmentPart object as a Java object.
String | getContentId() Gets the value of the MIME header whose name is "Content-ID".
String | getContentLocation() Gets the value of the MIME header whose name is "Content-Location".
String | getContentType() Gets the value of the MIME header whose name is "Content-Type".
abstract DataHandler | getDataHandler() Gets the DataHandler object for this AttachmentPart object.
abstract Iterator | getMatchingMimeHeaders(String[] names) Retrieves all MimeHeader objects that match a name in the given array.
abstract String[] | getMimeHeader(String name) Gets all the values of the header identified by the given String.
abstract Iterator | getNonMatchingMimeHeaders(String[] names) Retrieves all MimeHeader objects whose name does not match a name in the given array.
abstract InputStream | getRawContent() Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
abstract byte[] | getRawContentBytes() Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.
abstract int | getSize() Returns the number of bytes in this AttachmentPart object.
abstract void | removeAllMimeHeaders() Removes all the MIME header entries.
abstract void | removeMimeHeader(String header) Removes all MIME headers that match the given name.
abstract void | setBase64Content(InputStream content, String contentType) Sets the content of this attachment part from the Base64 source InputStream and sets the value of the Content-Type header to the value contained in contentType, This method would first decode the base64 input and write the resulting raw bytes to the attachment.
abstract void | setContent(Object object, String contentType) Sets the content of this attachment part to that of the given Object and sets the value of the Content-Type header to the given type.
void | setContentId(String contentId) Sets the MIME header whose name is "Content-ID" with the given value.
void | setContentLocation(String contentLocation) Sets the MIME header whose name is "Content-Location" with the given value.
void | setContentType(String contentType) Sets the MIME header whose name is "Content-Type" with the given value.
abstract void | setDataHandler(DataHandler dataHandler) Sets the given DataHandler object as the data handler for this AttachmentPart object.
abstract void | setMimeHeader(String name, String value) Changes the first header entry that matches the given name to the given value, adding a new header if no existing header matches.
abstract void | setRawContent(InputStream content, String contentType) Sets the content of this attachment part to that contained by the InputStream content and sets the value of the Content-Type header to the value contained in contentType.
abstract void | setRawContentBytes(byte[] content, int offset, int len, String contentType) Sets the content of this attachment part to that contained by the byte[] array content and sets the value of the Content-Type header to the value contained in contentType.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AttachmentPart

public AttachmentPart()
Method Detail

getSize

public abstract int getSize()
                     throws SOAPException
Returns the number of bytes in this AttachmentPart object.

Returns:
the size of this AttachmentPart object in bytes or -1 if the size cannot be determined
Throws:
SOAPException - if the content of this attachment is corrupted of if there was an exception while trying to determine the size.

clearContent

public abstract void clearContent()
Clears out the content of this AttachmentPart object. The MIME header portion is left untouched.

getContent

public abstract Object getContent()
                           throws SOAPException
Gets the content of this AttachmentPart object as a Java object. The type of the returned Java object depends on (1) the DataContentHandler object that is used to interpret the bytes and (2) the Content-Type given in the header.

For the MIME content types "text/plain", "text/html" and "text/xml", the DataContentHandler object does the conversions to and from the Java types corresponding to the MIME types. For other MIME types,the DataContentHandler object can return an InputStream object that contains the content data as raw bytes.

A SAAJ-compliant implementation must, as a minimum, return a java.lang.String object corresponding to any content stream with a Content-Type value of text/plain, a javax.xml.transform.stream.StreamSource object corresponding to a content stream with a Content-Type value of text/xml, a java.awt.Image object corresponding to a content stream with a Content-Type value of image/gif or image/jpeg. For those content types that an installed DataContentHandler object does not understand, the DataContentHandler object is required to return a java.io.InputStream object with the raw bytes.

Returns:
a Java object with the content of this AttachmentPart object
Throws:
SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error

getRawContent

public abstract InputStream getRawContent()
                                   throws SOAPException
Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.

Note that reading from the returned InputStream would result in consuming the data in the stream. It is the responsibility of the caller to reset the InputStream appropriately before calling a Subsequent API. If a copy of the raw attachment content is required then the getRawContentBytes() API should be used instead.

Returns:
an InputStream from which the raw data contained by the AttachmentPart can be accessed.
Throws:
SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error.
Since:
SAAJ 1.3
See Also:
getRawContentBytes()

getRawContentBytes

public abstract byte[] getRawContentBytes()
                                   throws SOAPException
Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.

Returns:
a byte[] array containing the raw data of the AttachmentPart.
Throws:
SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error.
Since:
SAAJ 1.3

getBase64Content

public abstract InputStream getBase64Content()
                                      throws SOAPException
Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.

Returns:
an InputStream from which the Base64 encoded AttachmentPart can be read.
Throws:
SOAPException - if there is no content set into this AttachmentPart object or if there was a data transformation error.
Since:
SAAJ 1.3

setContent

public abstract void setContent(Object object,
                                String contentType)
Sets the content of this attachment part to that of the given Object and sets the value of the Content-Type header to the given type. The type of the Object should correspond to the value given for the Content-Type. This depends on the particular set of DataContentHandler objects in use.

Parameters:
object - the Java object that makes up the content for this attachment part
contentType - the MIME string that specifies the type of the content
Throws:
IllegalArgumentException - may be thrown if the contentType does not match the type of the content object, or if there was no DataContentHandler object for this content object
See Also:
getContent()

setRawContent

public abstract void setRawContent(InputStream content,
                                   String contentType)
                            throws SOAPException
Sets the content of this attachment part to that contained by the InputStream content and sets the value of the Content-Type header to the value contained in contentType.

A subsequent call to getSize() may not be an exact measure of the content size.

Parameters:
content - the raw data to add to the attachment part
contentType - the value to set into the Content-Type header
Throws:
SOAPException - if an there is an error in setting the content
NullPointerException - if content is null
Since:
SAAJ 1.3

setRawContentBytes

public abstract void setRawContentBytes(byte[] content,
                                        int offset,
                                        int len,
                                        String contentType)
                                 throws SOAPException
Sets the content of this attachment part to that contained by the byte[] array content and sets the value of the Content-Type header to the value contained in contentType.

Parameters:
content - the raw data to add to the attachment part
contentType - the value to set into the Content-Type header
offset - the offset in the byte array of the content
len - the number of bytes that form the content
Throws:
SOAPException - if an there is an error in setting the content or content is null
Since:
SAAJ 1.3

setBase64Content

public abstract void setBase64Content(InputStream content,
                                      String contentType)
                               throws SOAPException
Sets the content of this attachment part from the Base64 source InputStream and sets the value of the Content-Type header to the value contained in contentType, This method would first decode the base64 input and write the resulting raw bytes to the attachment.

A subsequent call to getSize() may not be an exact measure of the content size.

Parameters:
content - the base64 encoded data to add to the attachment part
contentType - the value to set into the Content-Type header
Throws:
SOAPException - if an there is an error in setting the content
NullPointerException - if content is null
Since:
SAAJ 1.3

getDataHandler

public abstract DataHandler getDataHandler()
                                    throws SOAPException
Gets the DataHandler object for this AttachmentPart object.

Returns:
the DataHandler object associated with this AttachmentPart object
Throws:
SOAPException - if there is no data in this AttachmentPart object

setDataHandler

public abstract void setDataHandler(DataHandler dataHandler)
Sets the given DataHandler object as the data handler for this AttachmentPart object. Typically, on an incoming message, the data handler is automatically set. When a message is being created and populated with content, the setDataHandler method can be used to get data from various data sources into the message.

Parameters:
dataHandler - the DataHandler object to be set
Throws:
IllegalArgumentException - if there was a problem with the specified DataHandler object

getContentId

public String getContentId()
Gets the value of the MIME header whose name is "Content-ID".

Returns:
a String giving the value of the "Content-ID" header or null if there is none
See Also:
setContentId(java.lang.String)

getContentLocation

public String getContentLocation()
Gets the value of the MIME header whose name is "Content-Location".

Returns:
a String giving the value of the "Content-Location" header or null if there is none

getContentType

public String getContentType()
Gets the value of the MIME header whose name is "Content-Type".

Returns:
a String giving the value of the "Content-Type" header or null if there is none

setContentId

public void setContentId(String contentId)
Sets the MIME header whose name is "Content-ID" with the given value.

Parameters:
contentId - a String giving the value of the "Content-ID" header
Throws:
IllegalArgumentException - if there was a problem with the specified contentId value
See Also:
getContentId()

setContentLocation

public void setContentLocation(String contentLocation)
Sets the MIME header whose name is "Content-Location" with the given value.

Parameters:
contentLocation - a String giving the value of the "Content-Location" header
Throws:
IllegalArgumentException - if there was a problem with the specified content location

setContentType

public void setContentType(String contentType)
Sets the MIME header whose name is "Content-Type" with the given value.

Parameters:
contentType - a String giving the value of the "Content-Type" header
Throws:
IllegalArgumentException - if there was a problem with the specified content type

removeMimeHeader

public abstract void removeMimeHeader(String header)
Removes all MIME headers that match the given name.

Parameters:
header - the string name of the MIME header/s to be removed

removeAllMimeHeaders

public abstract void removeAllMimeHeaders()
Removes all the MIME header entries.

getMimeHeader

public abstract String[] getMimeHeader(String name)
Gets all the values of the header identified by the given String.

Parameters:
name - the name of the header; example: "Content-Type"
Returns:
a String array giving the value for the specified header
See Also:
setMimeHeader(java.lang.String, java.lang.String)

setMimeHeader

public abstract void setMimeHeader(String name,
                                   String value)
Changes the first header entry that matches the given name to the given value, adding a new header if no existing header matches. This method also removes all matching headers but the first.

Note that RFC822 headers can only contain US-ASCII characters.

Parameters:
name - a String giving the name of the header for which to search
value - a String giving the value to be set for the header whose name matches the given name
Throws:
IllegalArgumentException - if there was a problem with the specified mime header name or value

addMimeHeader

public abstract void addMimeHeader(String name,
                                   String value)
Adds a MIME header with the specified name and value to this AttachmentPart object.

Note that RFC822 headers can contain only US-ASCII characters.

Parameters:
name - a String giving the name of the header to be added
value - a String giving the value of the header to be added
Throws:
IllegalArgumentException - if there was a problem with the specified mime header name or value

getAllMimeHeaders

public abstract Iterator getAllMimeHeaders()
Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.

Returns:
an Iterator object with all of the Mime headers for this AttachmentPart object

getMatchingMimeHeaders

public abstract Iterator getMatchingMimeHeaders(String[] names)
Retrieves all MimeHeader objects that match a name in the given array.

Parameters:
names - a String array with the name(s) of the MIME headers to be returned
Returns:
all of the MIME headers that match one of the names in the given array as an Iterator object

getNonMatchingMimeHeaders

public abstract Iterator getNonMatchingMimeHeaders(String[] names)
Retrieves all MimeHeader objects whose name does not match a name in the given array.

Parameters:
names - a String array with the name(s) of the MIME headers not to be returned
Returns:
all of the MIME headers in this AttachmentPart object except those that match one of the names in the given array. The nonmatching MIME headers are returned as an Iterator object.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Detail

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface Detail

All Superinterfaces:
Element, Node, SOAPElement, SOAPFaultElement
public interface Detail
extends SOAPFaultElement

A container for DetailEntry objects. DetailEntry objects give detailed error information that is application-specific and related to the SOAPBody object that contains it.

A Detail object, which is part of a SOAPFault object, can be retrieved using the method SOAPFault.getDetail. The Detail interface provides two methods. One creates a new DetailEntry object and also automatically adds it to the Detail object. The second method gets a list of the DetailEntry objects contained in a Detail object.

The following code fragment, in which sf is a SOAPFault object, gets its Detail object (d), adds a new DetailEntry object to d, and then gets a list of all the DetailEntry objects in d. The code also creates a Name object to pass to the method addDetailEntry. The variable se, used to create the Name object, is a SOAPEnvelope object.

    Detail d = sf.getDetail();
    Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");
    d.addDetailEntry(name);
    Iterator it = d.getDetailEntries();

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
DetailEntry | addDetailEntry(Name name) Creates a new DetailEntry object with the given name and adds it to this Detail object.
DetailEntry | addDetailEntry(QName qname) Creates a new DetailEntry object with the given QName and adds it to this Detail object.
Iterator | getDetailEntries() Gets an Iterator over all of the DetailEntrys in this Detail object.
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

addDetailEntry

DetailEntry addDetailEntry(Name name)
                           throws SOAPException
Creates a new DetailEntry object with the given name and adds it to this Detail object.

Parameters:
name - a Name object identifying the new DetailEntry object
Throws:
SOAPException - thrown when there is a problem in adding a DetailEntry object to this Detail object.
See Also:
addDetailEntry(QName qname)

addDetailEntry

DetailEntry addDetailEntry(QName qname)
                           throws SOAPException
Creates a new DetailEntry object with the given QName and adds it to this Detail object. This method is the preferred over the one using Name.

Parameters:
qname - a QName object identifying the new DetailEntry object
Throws:
SOAPException - thrown when there is a problem in adding a DetailEntry object to this Detail object.
Since:
SAAJ 1.3
See Also:
addDetailEntry(Name name)

getDetailEntries

Iterator getDetailEntries()
Gets an Iterator over all of the DetailEntrys in this Detail object.

Returns:
an Iterator object over the DetailEntry objects in this Detail object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class MessageFactory

java.lang.Object
    extended by  javax.xml.soap.MessageFactory

public abstract class MessageFactory
extends Object

A factory for creating SOAPMessage objects.

A SAAJ client can create a MessageFactory object using the method newInstance, as shown in the following lines of code.

       MessageFactory mf = MessageFactory.newInstance();
       MessageFactory mf12 = MessageFactory.newInstance(SOAPConstants.SOAP_1_2_PROTOCOL);

All MessageFactory objects, regardless of how they are created, will produce SOAPMessage objects that have the following elements by default:

  • A SOAPPart object
  • A SOAPEnvelope object
  • A SOAPBody object
  • A SOAPHeader object
In some cases, specialized MessageFactory objects may be obtained that produce messages prepopulated with additional entries in the SOAPHeader object and the SOAPBody object. The content of a new SOAPMessage object depends on which of the two MessageFactory methods is used to create it.
  • createMessage()
    This is the method clients would normally use to create a request message.
  • createMessage(MimeHeaders, java.io.InputStream) -- message has content from the InputStream object and headers from the MimeHeaders object
    This method can be used internally by a service implementation to create a message that is a response to a request.

Constructor Summary
MessageFactory()
Method Summary
abstract SOAPMessage | createMessage() Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
abstract SOAPMessage | createMessage(MimeHeaders headers, InputStream in) Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
static MessageFactory | newInstance() Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load: Use the javax.xml.soap.MessageFactory system property.
static MessageFactory | newInstance(String protocol) Creates a new MessageFactory object that is an instance of the specified implementation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MessageFactory

public MessageFactory()
Method Detail

newInstance

public static MessageFactory newInstance()
                                  throws SOAPException
Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load:
  • Use the javax.xml.soap.MessageFactory system property.
  • Use the properties file "lib/jaxm.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
  • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.soap.MessageFactory in jars available to the runtime.
  • Use the SAAJMetaFactory instance to locate the MessageFactory implementation class.

Returns:
a new instance of a MessageFactory
Throws:
SOAPException - if there was an error in creating the default implementation of the MessageFactory.
See Also:
SAAJMetaFactory

newInstance

public static MessageFactory newInstance(String protocol)
                                  throws SOAPException
Creates a new MessageFactory object that is an instance of the specified implementation. May be a dynamic message factory, a SOAP 1.1 message factory, or a SOAP 1.2 message factory. A dynamic message factory creates messages based on the MIME headers specified as arguments to the createMessage method. This method uses the SAAJMetaFactory to locate the implementation class and create the MessageFactory instance.

Parameters:
protocol - a string constant representing the class of the specified message factory implementation. May be either DYNAMIC_SOAP_PROTOCOL, DEFAULT_SOAP_PROTOCOL (which is the same as) SOAP_1_1_PROTOCOL, or SOAP_1_2_PROTOCOL.
Returns:
a new instance of a MessageFactory
Throws:
SOAPException - if there was an error in creating the specified implementation of MessageFactory.
Since:
SAAJ 1.3
See Also:
SAAJMetaFactory

createMessage

public abstract SOAPMessage createMessage()
                                   throws SOAPException
Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects. Profile-specific message factories can choose to prepopulate the SOAPMessage object with profile-specific headers.

Content can be added to this message's SOAPPart object, and the message can be sent "as is" when a message containing only a SOAP part is sufficient. Otherwise, the SOAPMessage object needs to create one or more AttachmentPart objects and add them to itself. Any content that is not in XML format must be in an AttachmentPart object.

Returns:
a new SOAPMessage object
Throws:
SOAPException - if a SOAP error occurs
UnsupportedOperationException - if the protocol of this MessageFactory instance is DYNAMIC_SOAP_PROTOCOL

createMessage

public abstract SOAPMessage createMessage(MimeHeaders headers,
                                          InputStream in)
                                   throws IOException,
                                          SOAPException
Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.

Parameters:
in - the InputStream object that contains the data for a message
headers - the transport-specific headers passed to the message in a transport-independent fashion for creation of the message
Returns:
a new SOAPMessage object containing the data from the given InputStream object
Throws:
IOException - if there is a problem in reading data from the input stream
SOAPException - may be thrown if the message is invalid
IllegalArgumentException - if the MessageFactory requires one or more MIME headers to be present in the headers parameter and they are missing. MessageFactory implementations for SOAP_1_1_PROTOCOL or SOAP_1_2_PROTOCOL must not throw IllegalArgumentException for this reason.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MimeHeader

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class MimeHeader

java.lang.Object
    extended by  javax.xml.soap.MimeHeader

public class MimeHeader
extends Object

An object that stores a MIME header name and its value. One or more MimeHeader objects may be contained in a MimeHeaders object.

See Also:
MimeHeaders

Constructor Summary
MimeHeader(String name, String value)
Constructs a MimeHeader object initialized with the given name and value.
Method Summary
String | getName() Returns the name of this MimeHeader object.
String | getValue() Returns the value of this MimeHeader object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MimeHeader

public MimeHeader(String name,
                  String value)
Constructs a MimeHeader object initialized with the given name and value.

Parameters:
name - a String giving the name of the header
value - a String giving the value of the header
Method Detail

getName

public String getName()
Returns the name of this MimeHeader object.

Returns:
the name of the header as a String

getValue

public String getValue()
Returns the value of this MimeHeader object.

Returns:
the value of the header as a String
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MimeHeaders

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class MimeHeaders

java.lang.Object
    extended by  javax.xml.soap.MimeHeaders

public class MimeHeaders
extends Object

A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.

This class is used primarily when an application wants to retrieve specific attachments based on certain MIME headers and values. This class will most likely be used by implementations of AttachmentPart and other MIME dependent parts of the SAAJ API.

See Also:
SOAPMessage.getAttachments(), AttachmentPart

Constructor Summary
MimeHeaders()
Constructs a default MimeHeaders object initialized with an empty Vector object.
Method Summary
void | addHeader(String name, String value) Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.
Iterator | getAllHeaders() Returns all the MimeHeaders in this MimeHeaders object.
String[] | getHeader(String name) Returns all of the values for the specified header as an array of String objects.
Iterator | getMatchingHeaders(String[] names) Returns all the MimeHeader objects whose name matches a name in the given array of names.
Iterator | getNonMatchingHeaders(String[] names) Returns all of the MimeHeader objects whose name does not match a name in the given array of names.
void | removeAllHeaders() Removes all the header entries from this MimeHeaders object.
void | removeHeader(String name) Remove all MimeHeader objects whose name matches the given name.
void | setHeader(String name, String value) Replaces the current value of the first header entry whose name matches the given name with the given value, adding a new header if no existing header name matches.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MimeHeaders

public MimeHeaders()
Constructs a default MimeHeaders object initialized with an empty Vector object.

Method Detail

getHeader

public String[] getHeader(String name)
Returns all of the values for the specified header as an array of String objects.

Parameters:
name - the name of the header for which values will be returned
Returns:
a String array with all of the values for the specified header
See Also:
setHeader(java.lang.String, java.lang.String)

setHeader

public void setHeader(String name,
                      String value)
Replaces the current value of the first header entry whose name matches the given name with the given value, adding a new header if no existing header name matches. This method also removes all matching headers after the first one.

Note that RFC822 headers can contain only US-ASCII characters.

Parameters:
name - a String with the name of the header for which to search
value - a String with the value that will replace the current value of the specified header
Throws:
IllegalArgumentException - if there was a problem in the mime header name or the value being set
See Also:
getHeader(java.lang.String)

addHeader

public void addHeader(String name,
                      String value)
Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.

Note that RFC822 headers can contain only US-ASCII characters.

Parameters:
name - a String with the name of the header to be added
value - a String with the value of the header to be added
Throws:
IllegalArgumentException - if there was a problem in the mime header name or value being added

removeHeader

public void removeHeader(String name)
Remove all MimeHeader objects whose name matches the given name.

Parameters:
name - a String with the name of the header for which to search

removeAllHeaders

public void removeAllHeaders()
Removes all the header entries from this MimeHeaders object.

getAllHeaders

public Iterator getAllHeaders()
Returns all the MimeHeaders in this MimeHeaders object.

Returns:
an Iterator object over this MimeHeaders object's list of MimeHeader objects

getMatchingHeaders

public Iterator getMatchingHeaders(String[] names)
Returns all the MimeHeader objects whose name matches a name in the given array of names.

Parameters:
names - an array of String objects with the names for which to search
Returns:
an Iterator object over the MimeHeader objects whose name matches one of the names in the given list

getNonMatchingHeaders

public Iterator getNonMatchingHeaders(String[] names)
Returns all of the MimeHeader objects whose name does not match a name in the given array of names.

Parameters:
names - an array of String objects with the names for which to search
Returns:
an Iterator object over the MimeHeader objects whose name does not match one of the names in the given list
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Name

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface Name

public interface Name

A representation of an XML name. This interface provides methods for getting the local and namespace-qualified names and also for getting the prefix associated with the namespace for the name. It is also possible to get the URI of the namespace.

The following is an example of a namespace declaration in an element.

   <wombat:GetLastTradePrice xmlns:wombat="http://www.wombat.org/trader">
("xmlns" stands for "XML namespace".) The following shows what the methods in the Name interface will return.
  • getQualifiedName will return "prefix:LocalName" = "WOMBAT:GetLastTradePrice"
  • getURI will return "http://www.wombat.org/trader"
  • getLocalName will return "GetLastTracePrice"
  • getPrefix will return "WOMBAT"

XML namespaces are used to disambiguate SOAP identifiers from application-specific identifiers.

Name objects are created using the method SOAPEnvelope.createName, which has two versions. One method creates Name objects with a local name, a namespace prefix, and a namespace URI. and the second creates Name objects with just a local name. The following line of code, in which se is a SOAPEnvelope object, creates a new Name object with all three.

     Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");
The following line of code gives an example of how a Name object can be used. The variable element is a SOAPElement object. This code creates a new SOAPElement object with the given name and adds it to element.
     element.addChildElement(name);

The Name interface may be deprecated in a future release of SAAJ in favor of javax.xml.namespace.QName

See Also:
SOAPEnvelope.createName, SOAPFactory.createName

Method Summary
String | getLocalName() Gets the local name part of the XML name that this Name object represents.
String | getPrefix() Returns the prefix that was specified when this Name object was initialized.
String | getQualifiedName() Gets the namespace-qualified name of the XML name that this Name object represents.
String | getURI() Returns the URI of the namespace for the XML name that this Name object represents.

Method Detail

getLocalName

String getLocalName()
Gets the local name part of the XML name that this Name object represents.

Returns:
a string giving the local name

getQualifiedName

String getQualifiedName()
Gets the namespace-qualified name of the XML name that this Name object represents.

Returns:
the namespace-qualified name as a string

getPrefix

String getPrefix()
Returns the prefix that was specified when this Name object was initialized. This prefix is associated with the namespace for the XML name that this Name object represents.

Returns:
the prefix as a string

getURI

String getURI()
Returns the URI of the namespace for the XML name that this Name object represents.

Returns:
the URI as a string
Overview  Package   Class  Tree  Deprecated  Index  Help
Java EE 5 SDK
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Node

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface Node

All Superinterfaces:
Node
All Known Subinterfaces:
Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement, Text
public interface Node
extends Node

A representation of a node (element) in an XML document. This interface extnends the standard DOM Node interface with methods for getting and setting the value of a node, for getting and setting the parent of a node, and for removing a node.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
void | detachNode() Removes this Node object from the tree.
SOAPElement | getParentElement() Returns the parent element of this Node object.
String | getValue() Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise.
void | recycleNode() Notifies the implementation that this Node object is no longer being used by the application and that the implementation is free to reuse this object for nodes that may be created later.
void | setParentElement(SOAPElement parent) Sets the parent of this Node object to the given SOAPElement object.
void | setValue(String value) If this is a Text node then this method will set its value, otherwise it sets the value of the immediate (Text) child of this node.
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

getValue

String getValue()
Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise. If there is an immediate child of this Node that it is a Text node then it's value will be returned. If there is more than one Text node then the value of the first Text Node will be returned. Otherwise null is returned.

Returns:
a String with the text of this node if this is a Text node or the text contained by the first immediate child of this Node object that is a Text object if such a child exists; null otherwise.

setValue

void setValue(String value)
If this is a Text node then this method will set its value, otherwise it sets the value of the immediate (Text) child of this node. The value of the immediate child of this node can be set only if, there is one child node and that node is a Text node, or if there are no children in which case a child Text node will be created.

Throws:
IllegalStateException - if the node is not a Text node and either has more than one child node or has a child node that is not a Text node.
Since:
SAAJ 1.2

setParentElement

void setParentElement(SOAPElement parent)
                      throws SOAPException
Sets the parent of this Node object to the given SOAPElement object.

Parameters:
parent - the SOAPElement object to be set as the parent of this Node object
Throws:
SOAPException - if there is a problem in setting the parent to the given element
See Also:
getParentElement()

getParentElement

SOAPElement getParentElement()
Returns the parent element of this Node object. This method can throw an UnsupportedOperationException if the tree is not kept in memory.

Returns:
the SOAPElement object that is the parent of this Node object or null if this Node object is root
Throws:
UnsupportedOperationException - if the whole tree is not kept in memory
See Also:
setParentElement(javax.xml.soap.SOAPElement)

detachNode

void detachNode()
Removes this Node object from the tree.

recycleNode

void recycleNode()
Notifies the implementation that this Node object is no longer being used by the application and that the implementation is free to reuse this object for nodes that may be created later.

Calling the method recycleNode implies that the method detachNode has been called previously.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SAAJMetaFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SAAJMetaFactory

java.lang.Object
    extended by  javax.xml.soap.SAAJMetaFactory

public abstract class SAAJMetaFactory
extends Object

The access point for the implementation classes of the factories defined in the SAAJ API. All of the newInstance methods defined on factories in SAAJ 1.3 defer to instances of this class to do the actual object creation. The implementations of newInstance() methods (in SOAPFactory and MessageFactory) that existed in SAAJ 1.2 have been updated to also delegate to the SAAJMetaFactory when the SAAJ 1.2 defined lookup fails to locate the Factory implementation class name.

SAAJMetaFactory is a service provider interface. There are no public methods on this class.

Since:
SAAJ 1.3
Author:
SAAJ RI Development Team

Constructor Summary
protected SAAJMetaFactory()
Method Summary
protected abstract MessageFactory | newMessageFactory(String protocol) Creates a MessageFactory object for the given String protocol.
protected abstract SOAPFactory | newSOAPFactory(String protocol) Creates a SOAPFactory object for the given String protocol.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SAAJMetaFactory

protected SAAJMetaFactory()
Method Detail

newMessageFactory

protected abstract MessageFactory newMessageFactory(String protocol)
                                             throws SOAPException
Creates a MessageFactory object for the given String protocol.

Parameters:
protocol - a String indicating the protocol
Throws:
SOAPException - if there is an error in creating the MessageFactory
See Also:
SOAPConstants.SOAP_1_1_PROTOCOL, SOAPConstants.SOAP_1_2_PROTOCOL, SOAPConstants.DYNAMIC_SOAP_PROTOCOL

newSOAPFactory

protected abstract SOAPFactory newSOAPFactory(String protocol)
                                       throws SOAPException
Creates a SOAPFactory object for the given String protocol.

Parameters:
protocol - a String indicating the protocol
Throws:
SOAPException - if there is an error in creating the SOAPFactory
See Also:
SOAPConstants.SOAP_1_1_PROTOCOL, SOAPConstants.SOAP_1_2_PROTOCOL, SOAPConstants.DYNAMIC_SOAP_PROTOCOL
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SAAJResult

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SAAJResult

java.lang.Object
    extended by  javax.xml.transform.dom.DOMResult
        extended by  javax.xml.soap.SAAJResult
All Implemented Interfaces:
Result
public class SAAJResult
extends DOMResult

Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree. These results should be accessed by using the getResult() method. The DOMResult.getNode() method should be avoided in almost all cases.

Since:
SAAJ 1.3
Author:
XWS-Security Development Team

Field Summary
Fields inherited from class javax.xml.transform.dom.DOMResult
FEATURE
Fields inherited from interface javax.xml.transform.Result
PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING
Constructor Summary
SAAJResult()
Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the default (SOAP 1.1) protocol.
SAAJResult(SOAPElement rootNode)
Creates a SAAJResult that will write the results as a child node of the SOAPElement specified.
SAAJResult(SOAPMessage message)
Creates a SAAJResult that will write the results into the SOAPPart of the supplied SOAPMessage.
SAAJResult(String protocol)
Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the specified protocol.
Method Summary
 Node getResult()
Methods inherited from class javax.xml.transform.dom.DOMResult
getNextSibling, getNode, getSystemId, setNextSibling, setNode, setSystemId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SAAJResult

public SAAJResult()
           throws SOAPException
Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the default (SOAP 1.1) protocol.

This kind of SAAJResult is meant for use in situations where the results will be used as a parameter to a method that takes a parameter whose type, such as SOAPElement, is drawn from the SAAJ API. When used in a transformation, the results are populated into the SOAPPart of a SOAPMessage that is created internally. The SOAPPart returned by DOMResult.getNode() is not guaranteed to be well-formed.

Throws:
SOAPException - if there is a problem creating a SOAPMessage
Since:
SAAJ 1.3

SAAJResult

public SAAJResult(String protocol)
           throws SOAPException
Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the specified protocol. The DYNAMIC_SOAP_PROTOCOL is ambiguous in this context and will cause this constructor to throw an UnsupportedOperationException.

This kind of SAAJResult is meant for use in situations where the results will be used as a parameter to a method that takes a parameter whose type, such as SOAPElement, is drawn from the SAAJ API. When used in a transformation the results are populated into the SOAPPart of a SOAPMessage that is created internally. The SOAPPart returned by DOMResult.getNode() is not guaranteed to be well-formed.

Parameters:
protocol - - the name of the SOAP protocol that the resulting SAAJ tree should support
Throws:
SOAPException - if a SOAPMessage supporting the specified protocol cannot be created
Since:
SAAJ 1.3

SAAJResult

public SAAJResult(SOAPMessage message)
Creates a SAAJResult that will write the results into the SOAPPart of the supplied SOAPMessage. In the normal case these results will be written using DOM APIs and, as a result, the finished SOAPPart will not be guaranteed to be well-formed unless the data used to create it is also well formed. When used in a transformation the validity of the SOAPMessage after the transformation can be guaranteed only by means outside SAAJ specification.

Parameters:
message - - the message whose SOAPPart will be populated as a result of some transformation or marshalling operation
Since:
SAAJ 1.3

SAAJResult

public SAAJResult(SOAPElement rootNode)
Creates a SAAJResult that will write the results as a child node of the SOAPElement specified. In the normal case these results will be written using DOM APIs and as a result may invalidate the structure of the SAAJ tree. This kind of SAAJResult should only be used when the validity of the incoming data can be guaranteed by means outside of the SAAJ specification.

Parameters:
rootNode - - the root to which the results will be appended
Since:
SAAJ 1.3
Method Detail

getResult

public Node getResult()
Returns:
the resulting Tree that was created under the specified root Node.
Since:
SAAJ 1.3
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPBody

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPBody

All Superinterfaces:
Element, Node, SOAPElement
public interface SOAPBody
extends SOAPElement

An object that represents the contents of the SOAP body element in a SOAP message. A SOAP body element consists of XML data that affects the way the application-specific content is processed.

A SOAPBody object contains SOAPBodyElement objects, which have the content for the SOAP body. A SOAPFault object, which carries status and/or error information, is an example of a SOAPBodyElement object.

See Also:
SOAPFault

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
SOAPBodyElement | addBodyElement(Name name) Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
SOAPBodyElement | addBodyElement(QName qname) Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
SOAPBodyElement | addDocument(Document document) Adds the root node of the DOM Document to this SOAPBody object.
SOAPFault | addFault() Creates a new SOAPFault object and adds it to this SOAPBody object.
SOAPFault | addFault(Name faultCode, String faultString) Creates a new SOAPFault object and adds it to this SOAPBody object.
SOAPFault | addFault(Name faultCode, String faultString, Locale locale) Creates a new SOAPFault object and adds it to this SOAPBody object.
SOAPFault | addFault(QName faultCode, String faultString) Creates a new SOAPFault object and adds it to this SOAPBody object.
SOAPFault | addFault(QName faultCode, String faultString, Locale locale) Creates a new SOAPFault object and adds it to this SOAPBody object.
Document | extractContentAsDocument() Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.
SOAPFault | getFault() Returns the SOAPFault object in this SOAPBody object.
boolean | hasFault() Indicates whether a SOAPFault object exists in this SOAPBody object.
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

addFault

SOAPFault addFault()
                   throws SOAPException
Creates a new SOAPFault object and adds it to this SOAPBody object. The new SOAPFault will have default values set for the mandatory child elements. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

A SOAPBody may contain at most one SOAPFault child element.

Returns:
the new SOAPFault object
Throws:
SOAPException - if there is a SOAP error

addFault

SOAPFault addFault(Name faultCode,
                   String faultString,
                   Locale locale)
                   throws SOAPException
Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

A SOAPBody may contain at most one SOAPFault child element.

Parameters:
faultCode - a Name object giving the fault code to be set; must be one of the fault codes defined in the Version of SOAP specification in use
faultString - a String giving an explanation of the fault
locale - a Locale object indicating the native language of the faultString
Returns:
the new SOAPFault object
Throws:
SOAPException - if there is a SOAP error
Since:
SAAJ 1.2
See Also:
SOAPFault.setFaultCode(javax.xml.soap.Name), SOAPFault.setFaultString(java.lang.String)

addFault

SOAPFault addFault(QName faultCode,
                   String faultString,
                   Locale locale)
                   throws SOAPException
Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

A SOAPBody may contain at most one SOAPFault child element.

Parameters:
faultCode - a QName object giving the fault code to be set; must be one of the fault codes defined in the version of SOAP specification in use.
faultString - a String giving an explanation of the fault
locale - a Locale object indicating the native language of the faultString
Returns:
the new SOAPFault object
Throws:
SOAPException - if there is a SOAP error
Since:
SAAJ 1.3
See Also:
SOAPFault.setFaultCode(javax.xml.soap.Name),
SOAPFault.setFaultString(java.lang.String),
addFault(Name faultCode, String faultString, Locale locale)

addFault

SOAPFault addFault(Name faultCode,
                   String faultString)
                   throws SOAPException
Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

In case of a SOAP 1.2 fault, the default value for the mandatory xml:lang attribute on the Fault/Reason/Text element will be set to java.util.Locale.getDefault()

A SOAPBody may contain at most one SOAPFault child element.

Parameters:
faultCode - a Name object giving the fault code to be set; must be one of the fault codes defined in the version of SOAP specification in use
faultString - a String giving an explanation of the fault
Returns:
the new SOAPFault object
Throws:
SOAPException - if there is a SOAP error
Since:
SAAJ 1.2
See Also:
SOAPFault.setFaultCode(javax.xml.soap.Name), SOAPFault.setFaultString(java.lang.String)

addFault

SOAPFault addFault(QName faultCode,
                   String faultString)
                   throws SOAPException
Creates a new SOAPFault object and adds it to this SOAPBody object. The type of the SOAPFault will be a SOAP 1.1 or a SOAP 1.2 SOAPFault depending on the protocol specified while creating the MessageFactory instance.

For SOAP 1.2 the faultCode parameter is the value of the Fault/Code/Value element and the faultString parameter is the value of the Fault/Reason/Text element. For SOAP 1.1 the faultCode parameter is the value of the faultcode element and the faultString parameter is the value of the faultstring element.

In case of a SOAP 1.2 fault, the default value for the mandatory xml:lang attribute on the Fault/Reason/Text element will be set to java.util.Locale.getDefault()

A SOAPBody may contain at most one SOAPFault child element

Parameters:
faultCode - a QName object giving the fault code to be set; must be one of the fault codes defined in the version of SOAP specification in use
faultString - a String giving an explanation of the fault
Returns:
the new SOAPFault object
Throws:
SOAPException - if there is a SOAP error
Since:
SAAJ 1.3
See Also:
SOAPFault.setFaultCode(javax.xml.soap.Name),
SOAPFault.setFaultString(java.lang.String),
addFault(Name faultCode, String faultString)

hasFault

boolean hasFault()
Indicates whether a SOAPFault object exists in this SOAPBody object.

Returns:
true if a SOAPFault object exists in this SOAPBody object; false otherwise

getFault

SOAPFault getFault()
Returns the SOAPFault object in this SOAPBody object.

Returns:
the SOAPFault object in this SOAPBody object if present, null otherwise.

addBodyElement

SOAPBodyElement addBodyElement(Name name)
                               throws SOAPException
Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.

Parameters:
name - a Name object with the name for the new SOAPBodyElement object
Returns:
the new SOAPBodyElement object
Throws:
SOAPException - if a SOAP error occurs
See Also:
addBodyElement(javax.xml.namespace.QName)

addBodyElement

SOAPBodyElement addBodyElement(QName qname)
                               throws SOAPException
Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.

Parameters:
qname - a QName object with the qname for the new SOAPBodyElement object
Returns:
the new SOAPBodyElement object
Throws:
SOAPException - if a SOAP error occurs
Since:
SAAJ 1.3
See Also:
addBodyElement(Name)

addDocument

SOAPBodyElement addDocument(Document document)
                            throws SOAPException
Adds the root node of the DOM Document to this SOAPBody object.

Calling this method invalidates the document parameter. The client application should discard all references to this Document and its contents upon calling addDocument. The behavior of an application that continues to use such references is undefined.

Parameters:
document - the Document object whose root node will be added to this SOAPBody.
Returns:
the SOAPBodyElement that represents the root node that was added.
Throws:
SOAPException - if the Document cannot be added
Since:
SAAJ 1.2

extractContentAsDocument

Document extractContentAsDocument()
                                  throws SOAPException
Creates a new DOM Document and sets the first child of this SOAPBody as it's document element. The child SOAPElement is removed as part of the process.

Returns:
the Document representation of the SOAPBody content.
Throws:
SOAPException - if there is not exactly one child SOAPElement of the SOAPBody.
Since:
SAAJ 1.3
Overview  Package   Class  Tree  Deprecated  Index  Help
Java EE 5 SDK
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPConnection

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPConnection

java.lang.Object
    extended by  javax.xml.soap.SOAPConnection

public abstract class SOAPConnection
extends Object

A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).

The SOAPConnection class is optional. Some implementations may not implement this interface in which case the call to SOAPConnectionFactory.newInstance() (see below) will throw an UnsupportedOperationException.

A client can obtain a SOAPConnection object using a SOAPConnectionFactory object as in the following example:

      SOAPConnectionFactory factory = SOAPConnectionFactory.newInstance();
      SOAPConnection con = factory.createConnection();
A SOAPConnection object can be used to send messages directly to a URL following the request/response paradigm. That is, messages are sent using the method call, which sends the message and then waits until it gets a reply.

Constructor Summary
SOAPConnection()
Method Summary
abstract SOAPMessage | call(SOAPMessage request, Object to) Sends the given message to the specified endpoint and blocks until it has returned the response.
abstract void | close() Closes this SOAPConnection object.
SOAPMessage | get(Object to) Gets a message from a specific endpoint and blocks until it receives,
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SOAPConnection

public SOAPConnection()
Method Detail

call

public abstract SOAPMessage call(SOAPMessage request,
                                 Object to)
                          throws SOAPException
Sends the given message to the specified endpoint and blocks until it has returned the response.

Parameters:
request - the SOAPMessage object to be sent
to - an Object that identifies where the message should be sent. It is required to support Objects of type java.lang.String, java.net.URL, and when JAXM is present javax.xml.messaging.URLEndpoint
Returns:
the SOAPMessage object that is the response to the message that was sent
Throws:
SOAPException - if there is a SOAP error

get

public SOAPMessage get(Object to)
                throws SOAPException
Gets a message from a specific endpoint and blocks until it receives,

Parameters:
to - an Object that identifies where the request should be sent. Objects of type java.lang.String and java.net.URL must be supported.
Returns:
the SOAPMessage object that is the response to the get message request
Throws:
SOAPException - if there is a SOAP error
Since:
SAAJ 1.3

close

public abstract void close()
                    throws SOAPException
Closes this SOAPConnection object.

Throws:
SOAPException - if there is a SOAP error
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPConnectionFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPConnectionFactory

java.lang.Object
    extended by  javax.xml.soap.SOAPConnectionFactory

public abstract class SOAPConnectionFactory
extends Object

A factory for creating SOAPConnection objects. Implementation of this class is optional. If SOAPConnectionFactory.newInstance() throws an UnsupportedOperationException then the implementation does not support the SAAJ communication infrastructure. Otherwise SOAPConnection objects can be created by calling createConnection() on the newly created SOAPConnectionFactory object.

Constructor Summary
SOAPConnectionFactory()
Method Summary
abstract SOAPConnection | createConnection() Create a new SOAPConnection.
static SOAPConnectionFactory | newInstance() Creates an instance of the default SOAPConnectionFactory object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SOAPConnectionFactory

public SOAPConnectionFactory()
Method Detail

newInstance

public static SOAPConnectionFactory newInstance()
                                         throws SOAPException,
                                                UnsupportedOperationException
Creates an instance of the default SOAPConnectionFactory object.

Returns:
a new instance of a default SOAPConnectionFactory object
Throws:
SOAPException - if there was an error creating the SOAPConnectionFactory
UnsupportedOperationException - if newInstance is not supported.

createConnection

public abstract SOAPConnection createConnection()
                                         throws SOAPException
Create a new SOAPConnection.

Returns:
the new SOAPConnection object.
Throws:
SOAPException - if there was an exception creating the SOAPConnection object.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPConstants

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPConstants

public interface SOAPConstants

The definition of constants pertaining to the SOAP protocol.

Field Summary
static String | DEFAULT_SOAP_PROTOCOL The default protocol: SOAP 1.1 for backwards compatibility.
static String | DYNAMIC_SOAP_PROTOCOL Used to create MessageFactory instances that create SOAPMessages whose concrete type is based on the Content-Type MIME header passed to the createMessage method.
static String | SOAP_1_1_CONTENT_TYPE The media type of the Content-Type MIME header in SOAP 1.1.
static String | SOAP_1_1_PROTOCOL Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.1 specification.
static String | SOAP_1_2_CONTENT_TYPE The media type of the Content-Type MIME header in SOAP 1.2.
static String | SOAP_1_2_PROTOCOL Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.2 specification
static QName | SOAP_DATAENCODINGUNKNOWN_FAULT SOAP 1.2 DataEncodingUnknown Fault
static String | SOAP_ENV_PREFIX The default namespace prefix for http://www.w3.org/2003/05/soap-envelope
static QName | SOAP_MUSTUNDERSTAND_FAULT SOAP 1.2 MustUnderstand Fault
static QName | SOAP_RECEIVER_FAULT SOAP 1.2 Receiver Fault
static QName | SOAP_SENDER_FAULT SOAP 1.2 Sender Fault
static QName | SOAP_VERSIONMISMATCH_FAULT SOAP 1.2 VersionMismatch Fault
static String | URI_NS_SOAP_1_1_ENVELOPE The namespace identifier for the SOAP 1.1 envelope.
static String | URI_NS_SOAP_1_2_ENCODING The namespace identifier for the SOAP 1.2 encoding.
static String | URI_NS_SOAP_1_2_ENVELOPE The namespace identifier for the SOAP 1.2 envelope.
static String | URI_NS_SOAP_ENCODING The namespace identifier for the SOAP 1.1 encoding.
static String | URI_NS_SOAP_ENVELOPE The namespace identifier for the SOAP 1.1 envelope, All SOAPElements in this namespace are defined by the SOAP 1.1 specification.
static String | URI_SOAP_1_2_ROLE_NEXT The URI identifying the next application processing a SOAP request as the intended role for a SOAP 1.2 header entry (see section 2.2 of part 1 of the SOAP 1.2 specification).
static String | URI_SOAP_1_2_ROLE_NONE The URI specifying the role None in SOAP 1.2.
static String | URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER The URI identifying the ultimate receiver of the SOAP 1.2 message.
static String | URI_SOAP_ACTOR_NEXT The URI identifying the next application processing a SOAP request as the intended actor for a SOAP 1.1 header entry (see section 4.2.2 of the SOAP 1.1 specification).

Field Detail

DYNAMIC_SOAP_PROTOCOL

static final String DYNAMIC_SOAP_PROTOCOL
Used to create MessageFactory instances that create SOAPMessages whose concrete type is based on the Content-Type MIME header passed to the createMessage method. If no Content-Type header is passed then the createMessage may throw an IllegalArgumentException or, in the case of the no argument version of createMessage, an UnsupportedOperationException.

Since:
SAAJ 1.3
See Also:
Constant Field Values

SOAP_1_1_PROTOCOL

static final String SOAP_1_1_PROTOCOL
Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.1 specification.

Since:
SAAJ 1.3
See Also:
Constant Field Values

SOAP_1_2_PROTOCOL

static final String SOAP_1_2_PROTOCOL
Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.2 specification

Since:
SAAJ 1.3
See Also:
Constant Field Values

DEFAULT_SOAP_PROTOCOL

static final String DEFAULT_SOAP_PROTOCOL
The default protocol: SOAP 1.1 for backwards compatibility.

Since:
SAAJ 1.3
See Also:
Constant Field Values

URI_NS_SOAP_1_1_ENVELOPE

static final String URI_NS_SOAP_1_1_ENVELOPE
The namespace identifier for the SOAP 1.1 envelope.

Since:
SAAJ 1.3
See Also:
Constant Field Values

URI_NS_SOAP_1_2_ENVELOPE

static final String URI_NS_SOAP_1_2_ENVELOPE
The namespace identifier for the SOAP 1.2 envelope.

Since:
SAAJ 1.3
See Also:
Constant Field Values

URI_NS_SOAP_ENVELOPE

static final String URI_NS_SOAP_ENVELOPE
The namespace identifier for the SOAP 1.1 envelope, All SOAPElements in this namespace are defined by the SOAP 1.1 specification.

See Also:
Constant Field Values

URI_NS_SOAP_ENCODING

static final String URI_NS_SOAP_ENCODING
The namespace identifier for the SOAP 1.1 encoding. An attribute named encodingStyle in the URI_NS_SOAP_ENVELOPE namespace and set to the value URI_NS_SOAP_ENCODING can be added to an element to indicate that it is encoded using the rules in section 5 of the SOAP 1.1 specification.

See Also:
Constant Field Values

URI_NS_SOAP_1_2_ENCODING

static final String URI_NS_SOAP_1_2_ENCODING
The namespace identifier for the SOAP 1.2 encoding.

Since:
SAAJ 1.3
See Also:
Constant Field Values

SOAP_1_1_CONTENT_TYPE

static final String SOAP_1_1_CONTENT_TYPE
The media type of the Content-Type MIME header in SOAP 1.1.

Since:
SAAJ 1.3
See Also:
Constant Field Values

SOAP_1_2_CONTENT_TYPE

static final String SOAP_1_2_CONTENT_TYPE
The media type of the Content-Type MIME header in SOAP 1.2.

Since:
SAAJ 1.3
See Also:
Constant Field Values

URI_SOAP_ACTOR_NEXT

static final String URI_SOAP_ACTOR_NEXT
The URI identifying the next application processing a SOAP request as the intended actor for a SOAP 1.1 header entry (see section 4.2.2 of the SOAP 1.1 specification).

This value can be passed to
SOAPHeader.examineMustUnderstandHeaderElements(String),
SOAPHeader.examineHeaderElements(String) and
SOAPHeader.extractHeaderElements(String)

See Also:
Constant Field Values

URI_SOAP_1_2_ROLE_NEXT

static final String URI_SOAP_1_2_ROLE_NEXT
The URI identifying the next application processing a SOAP request as the intended role for a SOAP 1.2 header entry (see section 2.2 of part 1 of the SOAP 1.2 specification).

Since:
SAAJ 1.3
See Also:
Constant Field Values

URI_SOAP_1_2_ROLE_NONE

static final String URI_SOAP_1_2_ROLE_NONE
The URI specifying the role None in SOAP 1.2.

Since:
SAAJ 1.3
See Also:
Constant Field Values

URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER

static final String URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER
The URI identifying the ultimate receiver of the SOAP 1.2 message.

Since:
SAAJ 1.3
See Also:
Constant Field Values

SOAP_ENV_PREFIX

static final String SOAP_ENV_PREFIX
The default namespace prefix for http://www.w3.org/2003/05/soap-envelope

Since:
SAAJ 1.3
See Also:
Constant Field Values

SOAP_VERSIONMISMATCH_FAULT

static final QName SOAP_VERSIONMISMATCH_FAULT
SOAP 1.2 VersionMismatch Fault

Since:
SAAJ 1.3

SOAP_MUSTUNDERSTAND_FAULT

static final QName SOAP_MUSTUNDERSTAND_FAULT
SOAP 1.2 MustUnderstand Fault

Since:
SAAJ 1.3

SOAP_DATAENCODINGUNKNOWN_FAULT

static final QName SOAP_DATAENCODINGUNKNOWN_FAULT
SOAP 1.2 DataEncodingUnknown Fault

Since:
SAAJ 1.3

SOAP_SENDER_FAULT

static final QName SOAP_SENDER_FAULT
SOAP 1.2 Sender Fault

Since:
SAAJ 1.3

SOAP_RECEIVER_FAULT

static final QName SOAP_RECEIVER_FAULT
SOAP 1.2 Receiver Fault

Since:
SAAJ 1.3
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPElement

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPElement

All Superinterfaces:
Element, Node
All Known Subinterfaces:
Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement
public interface SOAPElement
extends Node, Element

An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification. This interface serves as the base interface for those objects that are specifically prescribed by a SOAP specification.

Methods in this interface that are required to return SAAJ specific objects may "silently" replace nodes in the tree as required to successfully return objects of the correct type. See getChildElements() and javax.xml.soap for details.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
SOAPElement | addAttribute(Name name, String value) Adds an attribute with the specified name and value to this SOAPElement object.
SOAPElement | addAttribute(QName qname, String value) Adds an attribute with the specified name and value to this SOAPElement object.
SOAPElement | addChildElement(Name name) Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
SOAPElement | addChildElement(QName qname) Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
SOAPElement | addChildElement(SOAPElement element) Add a SOAPElement as a child of this SOAPElement instance.
SOAPElement | addChildElement(String localName) Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
SOAPElement | addChildElement(String localName, String prefix) Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
SOAPElement | addChildElement(String localName, String prefix, String uri) Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
SOAPElement | addNamespaceDeclaration(String prefix, String uri) Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
SOAPElement | addTextNode(String text) Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
QName | createQName(String localName, String prefix) Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement.
Iterator | getAllAttributes() Returns an Iterator over all of the attribute Name objects in this SOAPElement object.
Iterator | getAllAttributesAsQNames() Returns an Iterator over all of the attributes in this SOAPElement as QName objects.
String | getAttributeValue(Name name) Returns the value of the attribute with the specified name.
String | getAttributeValue(QName qname) Returns the value of the attribute with the specified qname.
Iterator | getChildElements() Returns an Iterator over all the immediate child Nodes of this element.
Iterator | getChildElements(Name name) Returns an Iterator over all the immediate child Nodes of this element with the specified name.
Iterator | getChildElements(QName qname) Returns an Iterator over all the immediate child Nodes of this element with the specified qname.
Name | getElementName() Returns the name of this SOAPElement object.
QName | getElementQName() Returns the qname of this SOAPElement object.
String | getEncodingStyle() Returns the encoding style for this SOAPElement object.
Iterator | getNamespacePrefixes() Returns an Iterator over the namespace prefix Strings declared by this element.
String | getNamespaceURI(String prefix) Returns the URI of the namespace that has the given prefix.
Iterator | getVisibleNamespacePrefixes() Returns an Iterator over the namespace prefix Strings visible to this element.
boolean | removeAttribute(Name name) Removes the attribute with the specified name.
boolean | removeAttribute(QName qname) Removes the attribute with the specified qname.
void | removeContents() Detaches all children of this SOAPElement.
boolean | removeNamespaceDeclaration(String prefix) Removes the namespace declaration corresponding to the given prefix.
SOAPElement | setElementQName(QName newName) Changes the name of this Element to newName if possible.
void | setEncodingStyle(String encodingStyle) Sets the encoding style for this SOAPElement object to one specified.
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

addChildElement

SOAPElement addChildElement(Name name)
                            throws SOAPException
Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.

This method may be deprecated in a future release of SAAJ in favor of addChildElement(javax.xml.namespace.QName)

Parameters:
name - a Name object with the XML name for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object
See Also:
addChildElement(javax.xml.namespace.QName)

addChildElement

SOAPElement addChildElement(QName qname)
                            throws SOAPException
Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object. The namespace, localname and prefix of the new SOAPElement are all taken from the qname argument.

Parameters:
qname - a QName object with the XML name for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object
Since:
SAAJ 1.3
See Also:
addChildElement(Name)

addChildElement

SOAPElement addChildElement(String localName)
                            throws SOAPException
Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object. The new SOAPElement inherits any in-scope default namespace.

Parameters:
localName - a String giving the local name for the element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object

addChildElement

SOAPElement addChildElement(String localName,
                            String prefix)
                            throws SOAPException
Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.

Parameters:
localName - a String giving the local name for the new element
prefix - a String giving the namespace prefix for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if the prefix is not valid in the context of this SOAPElement or if there is an error in creating the SOAPElement object

addChildElement

SOAPElement addChildElement(String localName,
                            String prefix,
                            String uri)
                            throws SOAPException
Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.

Parameters:
localName - a String giving the local name for the new element
prefix - a String giving the namespace prefix for the new element
uri - a String giving the URI of the namespace to which the new element belongs
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object

addChildElement

SOAPElement addChildElement(SOAPElement element)
                            throws SOAPException
Add a SOAPElement as a child of this SOAPElement instance. The SOAPElement is expected to be created by a SOAPFactory. Callers should not rely on the element instance being added as is into the XML tree. Implementations could end up copying the content of the SOAPElement passed into an instance of a different SOAPElement implementation. For instance if addChildElement() is called on a SOAPHeader, element will be copied into an instance of a SOAPHeaderElement.

The fragment rooted in element is either added as a whole or not at all, if there was an error.

The fragment rooted in element cannot contain elements named "Envelope", "Header" or "Body" and in the SOAP namespace. Any namespace prefixes present in the fragment should be fully resolved using appropriate namespace declarations within the fragment itself.

Parameters:
element - the SOAPElement to be added as a new child
Returns:
an instance representing the new SOAP element that was actually added to the tree.
Throws:
SOAPException - if there was an error in adding this element as a child

removeContents

void removeContents()
Detaches all children of this SOAPElement.

This method is useful for rolling back the construction of partially completed SOAPHeaders and SOAPBodys in preparation for sending a fault when an error condition is detected. It is also useful for recycling portions of a document within a SOAP message.

Since:
SAAJ 1.2

addTextNode

SOAPElement addTextNode(String text)
                        throws SOAPException
Creates a new Text object initialized with the given String and adds it to this SOAPElement object.

Parameters:
text - a String object with the textual content to be added
Returns:
the SOAPElement object into which the new Text object was inserted
Throws:
SOAPException - if there is an error in creating the new Text object or if it is not legal to attach it as a child to this SOAPElement

addAttribute

SOAPElement addAttribute(Name name,
                         String value)
                         throws SOAPException
Adds an attribute with the specified name and value to this SOAPElement object.

Parameters:
name - a Name object with the name of the attribute
value - a String giving the value of the attribute
Returns:
the SOAPElement object into which the attribute was inserted
Throws:
SOAPException - if there is an error in creating the Attribute, or it is invalid to set an attribute with Name name on this SOAPElement.
See Also:
addAttribute(javax.xml.namespace.QName, String)

addAttribute

SOAPElement addAttribute(QName qname,
                         String value)
                         throws SOAPException
Adds an attribute with the specified name and value to this SOAPElement object.

Parameters:
qname - a QName object with the name of the attribute
value - a String giving the value of the attribute
Returns:
the SOAPElement object into which the attribute was inserted
Throws:
SOAPException - if there is an error in creating the Attribute, or it is invalid to set an attribute with QName qname on this SOAPElement.
Since:
SAAJ 1.3
See Also:
addAttribute(Name, String)

addNamespaceDeclaration

SOAPElement addNamespaceDeclaration(String prefix,
                                    String uri)
                                    throws SOAPException
Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.

Parameters:
prefix - a String giving the prefix of the namespace
uri - a String giving the uri of the namespace
Returns:
the SOAPElement object into which this namespace declaration was inserted.
Throws:
SOAPException - if there is an error in creating the namespace

getAttributeValue

String getAttributeValue(Name name)
Returns the value of the attribute with the specified name.

Parameters:
name - a Name object with the name of the attribute
Returns:
a String giving the value of the specified attribute, Null if there is no such attribute
See Also:
getAttributeValue(javax.xml.namespace.QName)

getAttributeValue

String getAttributeValue(QName qname)
Returns the value of the attribute with the specified qname.

Parameters:
qname - a QName object with the qname of the attribute
Returns:
a String giving the value of the specified attribute, Null if there is no such attribute
Since:
SAAJ 1.3
See Also:
getAttributeValue(Name)

getAllAttributes

Iterator getAllAttributes()
Returns an Iterator over all of the attribute Name objects in this SOAPElement object. The iterator can be used to get the attribute names, which can then be passed to the method getAttributeValue to retrieve the value of each attribute.

Returns:
an iterator over the names of the attributes
See Also:
getAllAttributesAsQNames()

getAllAttributesAsQNames

Iterator getAllAttributesAsQNames()
Returns an Iterator over all of the attributes in this SOAPElement as QName objects. The iterator can be used to get the attribute QName, which can then be passed to the method getAttributeValue to retrieve the value of each attribute.

Returns:
an iterator over the QNames of the attributes
Since:
SAAJ 1.3
See Also:
getAllAttributes()

getNamespaceURI

String getNamespaceURI(String prefix)
Returns the URI of the namespace that has the given prefix.

Parameters:
prefix - a String giving the prefix of the namespace for which to search
Returns:
a String with the uri of the namespace that has the given prefix

getNamespacePrefixes

Iterator getNamespacePrefixes()
Returns an Iterator over the namespace prefix Strings declared by this element. The prefixes returned by this iterator can be passed to the method getNamespaceURI to retrieve the URI of each namespace.

Returns:
an iterator over the namespace prefixes in this SOAPElement object

getVisibleNamespacePrefixes

Iterator getVisibleNamespacePrefixes()
Returns an Iterator over the namespace prefix Strings visible to this element. The prefixes returned by this iterator can be passed to the method getNamespaceURI to retrieve the URI of each namespace.

Returns:
an iterator over the namespace prefixes are within scope of this SOAPElement object
Since:
SAAJ 1.2

createQName

QName createQName(String localName,
                  String prefix)
                  throws SOAPException
Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement. The remaining elements of the new QName are taken directly from the parameters, localName and prefix.

Parameters:
localName - a String containing the local part of the name.
prefix - a String containing the prefix for the name.
Returns:
a QName with the specified localName and prefix, and with a namespace that is associated with the prefix in the context of this SOAPElement. This namespace will be the same as the one that would be returned by getNamespaceURI(String) if it were given prefix as it's parameter.
Throws:
SOAPException - if the QName cannot be created.
Since:
SAAJ 1.3

getElementName

Name getElementName()
Returns the name of this SOAPElement object.

Returns:
a Name object with the name of this SOAPElement object

getElementQName

QName getElementQName()
Returns the qname of this SOAPElement object.

Returns:
a QName object with the qname of this SOAPElement object
Since:
SAAJ 1.3
See Also:
getElementName()

setElementQName

SOAPElement setElementQName(QName newName)
                            throws SOAPException
Changes the name of this Element to newName if possible. SOAP Defined elements such as SOAPEnvelope, SOAPHeader, SOAPBody etc. cannot have their names changed using this method. Any attempt to do so will result in a SOAPException being thrown.

Callers should not rely on the element instance being renamed as is. Implementations could end up copying the content of the SOAPElement to a renamed instance.

Parameters:
newName - the new name for the Element.
Returns:
The renamed Node
Throws:
SOAPException - if changing the name of this Element is not allowed.
Since:
SAAJ 1.3

removeAttribute

boolean removeAttribute(Name name)
Removes the attribute with the specified name.

Parameters:
name - the Name object with the name of the attribute to be removed
Returns:
true if the attribute was removed successfully; false if it was not
See Also:
removeAttribute(javax.xml.namespace.QName)

removeAttribute

boolean removeAttribute(QName qname)
Removes the attribute with the specified qname.

Parameters:
qname - the QName object with the qname of the attribute to be removed
Returns:
true if the attribute was removed successfully; false if it was not
Since:
SAAJ 1.3
See Also:
removeAttribute(Name)

removeNamespaceDeclaration

boolean removeNamespaceDeclaration(String prefix)
Removes the namespace declaration corresponding to the given prefix.

Parameters:
prefix - a String giving the prefix for which to search
Returns:
true if the namespace declaration was removed successfully; false if it was not

getChildElements

Iterator getChildElements()
Returns an Iterator over all the immediate child Nodes of this element. This includes javax.xml.soap.Text objects as well as SOAPElement objects.

Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

Returns:
an iterator with the content of this SOAPElement object

getChildElements

Iterator getChildElements(Name name)
Returns an Iterator over all the immediate child Nodes of this element with the specified name. All of these children will be SOAPElement nodes.

Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

Parameters:
name - a Name object with the name of the child elements to be returned
Returns:
an Iterator object over all the elements in this SOAPElement object with the specified name
See Also:
getChildElements(javax.xml.namespace.QName)

getChildElements

Iterator getChildElements(QName qname)
Returns an Iterator over all the immediate child Nodes of this element with the specified qname. All of these children will be SOAPElement nodes.

Calling this method may cause child Element, SOAPElement and org.w3c.dom.Text nodes to be replaced by SOAPElement, SOAPHeaderElement, SOAPBodyElement or javax.xml.soap.Text nodes as appropriate for the type of this parent node. As a result the calling application must treat any existing references to these child nodes that have been obtained through DOM APIs as invalid and either discard them or refresh them with the values returned by this Iterator. This behavior can be avoided by calling the equivalent DOM APIs. See javax.xml.soap for more details.

Parameters:
qname - a QName object with the qname of the child elements to be returned
Returns:
an Iterator object over all the elements in this SOAPElement object with the specified qname
Since:
SAAJ 1.3
See Also:
getChildElements(Name)

setEncodingStyle

void setEncodingStyle(String encodingStyle)
                      throws SOAPException
Sets the encoding style for this SOAPElement object to one specified.

Parameters:
encodingStyle - a String giving the encoding style
Throws:
IllegalArgumentException - if there was a problem in the encoding style being set.
SOAPException - if setting the encodingStyle is invalid for this SOAPElement.
See Also:
getEncodingStyle()

getEncodingStyle

String getEncodingStyle()
Returns the encoding style for this SOAPElement object.

Returns:
a String giving the encoding style
See Also:
setEncodingStyle(java.lang.String)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPElementFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPElementFactory

java.lang.Object
    extended by  javax.xml.soap.SOAPElementFactory
Deprecated. - Use javax.xml.soap.SOAPFactory for creating SOAPElements.

public class SOAPElementFactory
extends Object

SOAPElementFactory is a factory for XML fragments that will eventually end up in the SOAP part. These fragments can be inserted as children of the SOAPHeader or SOAPBody or SOAPEnvelope.

Elements created using this factory do not have the properties of an element that lives inside a SOAP header document. These elements are copied into the XML document tree when they are inserted.

See Also:
SOAPFactory

Method Summary
 SOAPElement create(Name name)
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
 SOAPElement create(String localName)
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
 SOAPElement create(String localName, String prefix, String uri)
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
static SOAPElementFactory newInstance()
Deprecated. Creates a new instance of SOAPElementFactory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

create

public SOAPElement create(Name name)
                   throws SOAPException
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead

Create a SOAPElement object initialized with the given Name object.

Parameters:
name - a Name object with the XML name for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object
See Also:
SOAPFactory.createElement(javax.xml.soap.Name), SOAPFactory.createElement(javax.xml.namespace.QName)

create

public SOAPElement create(String localName)
                   throws SOAPException
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName) instead

Create a SOAPElement object initialized with the given local name.

Parameters:
localName - a String giving the local name for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object
See Also:
SOAPFactory.createElement(java.lang.String)

create

public SOAPElement create(String localName,
                          String prefix,
                          String uri)
                   throws SOAPException
Deprecated. Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead

Create a new SOAPElement object with the given local name, prefix and uri.

Parameters:
localName - a String giving the local name for the new element
prefix - the prefix for this SOAPElement
uri - a String giving the URI of the namespace to which the new element belongs
Throws:
SOAPException - if there is an error in creating the SOAPElement object
See Also:
SOAPFactory.createElement(java.lang.String, java.lang.String, java.lang.String)

newInstance

public static SOAPElementFactory newInstance()
                                      throws SOAPException
Deprecated.
Creates a new instance of SOAPElementFactory.

Returns:
a new instance of a SOAPElementFactory
Throws:
SOAPException - if there was an error creating the default SOAPElementFactory
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPEnvelope

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPEnvelope

All Superinterfaces:
Element, Node, SOAPElement
public interface SOAPEnvelope
extends SOAPElement

The container for the SOAPHeader and SOAPBody portions of a SOAPPart object. By default, a SOAPMessage object is created with a SOAPPart object that has a SOAPEnvelope object. The SOAPEnvelope object by default has an empty SOAPBody object and an empty SOAPHeader object. The SOAPBody object is required, and the SOAPHeader object, though optional, is used in the majority of cases. If the SOAPHeader object is not needed, it can be deleted, which is shown later.

A client can access the SOAPHeader and SOAPBody objects by calling the methods SOAPEnvelope.getHeader and SOAPEnvelope.getBody. The following lines of code use these two methods after starting with the SOAPMessage object message to get the SOAPPart object sp, which is then used to get the SOAPEnvelope object se.

     SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     SOAPHeader sh = se.getHeader();
     SOAPBody sb = se.getBody();

It is possible to change the body or header of a SOAPEnvelope object by retrieving the current one, deleting it, and then adding a new body or header. The javax.xml.soap.Node method deleteNode deletes the XML element (node) on which it is called. For example, the following line of code deletes the SOAPBody object that is retrieved by the method getBody.

      se.getBody().detachNode();
To create a SOAPHeader object to replace the one that was removed, a client uses the method SOAPEnvelope.addHeader, which creates a new header and adds it to the SOAPEnvelope object. Similarly, the method addBody creates a new SOAPBody object and adds it to the SOAPEnvelope object. The following code fragment retrieves the current header, removes it, and adds a new one. Then it retrieves the current body, removes it, and adds a new one.
     SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     se.getHeader().detachNode();
     SOAPHeader sh = se.addHeader();
     se.getBody().detachNode();
     SOAPBody sb = se.addBody();
It is an error to add a SOAPBody or SOAPHeader object if one already exists.

The SOAPEnvelope interface provides three methods for creating Name objects. One method creates Name objects with a local name, a namespace prefix, and a namesapce URI. The second method creates Name objects with a local name and a namespace prefix, and the third creates Name objects with just a local name. The following line of code, in which se is a SOAPEnvelope object, creates a new Name object with all three.

     Name name = se.createName("GetLastTradePrice", "WOMBAT",
                                "http://www.wombat.org/trader");

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
SOAPBody | addBody() Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
SOAPHeader | addHeader() Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
Name | createName(String localName) Creates a new Name object initialized with the given local name.
Name | createName(String localName, String prefix, String uri) Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
SOAPBody | getBody() Returns the SOAPBody object associated with this SOAPEnvelope object.
SOAPHeader | getHeader() Returns the SOAPHeader object for this SOAPEnvelope object.
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

createName

Name createName(String localName,
                String prefix,
                String uri)
                throws SOAPException
Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.

This factory method creates Name objects for use in the SOAP/XML document.

Parameters:
localName - a String giving the local name
prefix - a String giving the prefix of the namespace
uri - a String giving the URI of the namespace
Returns:
a Name object initialized with the given local name, namespace prefix, and namespace URI
Throws:
SOAPException - if there is a SOAP error

createName

Name createName(String localName)
                throws SOAPException
Creates a new Name object initialized with the given local name.

This factory method creates Name objects for use in the SOAP/XML document.

Parameters:
localName - a String giving the local name
Returns:
a Name object initialized with the given local name
Throws:
SOAPException - if there is a SOAP error

getHeader

SOAPHeader getHeader()
                     throws SOAPException
Returns the SOAPHeader object for this SOAPEnvelope object.

A new SOAPMessage object is by default created with a SOAPEnvelope object that contains an empty SOAPHeader object. As a result, the method getHeader will always return a SOAPHeader object unless the header has been removed and a new one has not been added.

Returns:
the SOAPHeader object or null if there is none
Throws:
SOAPException - if there is a problem obtaining the SOAPHeader object

getBody

SOAPBody getBody()
                 throws SOAPException
Returns the SOAPBody object associated with this SOAPEnvelope object.

A new SOAPMessage object is by default created with a SOAPEnvelope object that contains an empty SOAPBody object. As a result, the method getBody will always return a SOAPBody object unless the body has been removed and a new one has not been added.

Returns:
the SOAPBody object for this SOAPEnvelope object or null if there is none
Throws:
SOAPException - if there is a problem obtaining the SOAPBody object

addHeader

SOAPHeader addHeader()
                     throws SOAPException
Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.

It is illegal to add a header when the envelope already contains a header. Therefore, this method should be called only after the existing header has been removed.

Returns:
the new SOAPHeader object
Throws:
SOAPException - if this SOAPEnvelope object already contains a valid SOAPHeader object

addBody

SOAPBody addBody()
                 throws SOAPException
Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.

It is illegal to add a body when the envelope already contains a body. Therefore, this method should be called only after the existing body has been removed.

Returns:
the new SOAPBody object
Throws:
SOAPException - if this SOAPEnvelope object already contains a valid SOAPBody object
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.soap.SOAPException
All Implemented Interfaces:
Serializable
public class SOAPException
extends Exception

An exception that signals that a SOAP exception has occurred. A SOAPException object may contain a String that gives the reason for the exception, an embedded Throwable object, or both. This class provides methods for retrieving reason messages and for retrieving the embedded Throwable object.

Typical reasons for throwing a SOAPException object are problems such as difficulty setting a header, not being able to send a message, and not being able to get a connection with the provider. Reasons for embedding a Throwable object include problems such as input/output errors or a parsing problem, such as an error in parsing a header.

See Also:
Serialized Form

Constructor Summary
SOAPException()
Constructs a SOAPException object with no reason or embedded Throwable object.
SOAPException(String reason)
Constructs a SOAPException object with the given String as the reason for the exception being thrown.
SOAPException(String reason, Throwable cause)
Constructs a SOAPException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded exception.
SOAPException(Throwable cause)
Constructs a SOAPException object initialized with the given Throwable object.
Method Summary
Throwable | getCause() Returns the Throwable object embedded in this SOAPException if there is one.
String | getMessage() Returns the detail message for this SOAPException object.
Throwable | initCause(Throwable cause) Initializes the cause field of this SOAPException object with the given Throwable object.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SOAPException

public SOAPException()
Constructs a SOAPException object with no reason or embedded Throwable object.

SOAPException

public SOAPException(String reason)
Constructs a SOAPException object with the given String as the reason for the exception being thrown.

Parameters:
reason - a description of what caused the exception

SOAPException

public SOAPException(String reason,
                     Throwable cause)
Constructs a SOAPException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded exception.

Parameters:
reason - a description of what caused the exception
cause - a Throwable object that is to be embedded in this SOAPException object

SOAPException

public SOAPException(Throwable cause)
Constructs a SOAPException object initialized with the given Throwable object.

Method Detail

getMessage

public String getMessage()
Returns the detail message for this SOAPException object.

If there is an embedded Throwable object, and if the SOAPException object has no detail message of its own, this method will return the detail message from the embedded Throwable object.

Overrides:
getMessage in class Throwable
Returns:
the error or warning message for this SOAPException or, if it has none, the message of the embedded Throwable object, if there is one

getCause

public Throwable getCause()
Returns the Throwable object embedded in this SOAPException if there is one. Otherwise, this method returns null.

Overrides:
getCause in class Throwable
Returns:
the embedded Throwable object or null if there is none

initCause

public Throwable initCause(Throwable cause)
Initializes the cause field of this SOAPException object with the given Throwable object.

This method can be called at most once. It is generally called from within the constructor or immediately after the constructor has returned a new SOAPException object. If this SOAPException object was created with the constructor SOAPException(Throwable) or SOAPException(String,Throwable), meaning that its cause field already has a value, this method cannot be called even once.

Overrides:
initCause in class Throwable
Parameters:
cause - the Throwable object that caused this SOAPException object to be thrown. The value of this parameter is saved for later retrieval by the getCause() method. A null value is permitted and indicates that the cause is nonexistent or unknown.
Returns:
a reference to this SOAPException instance
Throws:
IllegalArgumentException - if cause is this Throwable object. (A Throwable object cannot be its own cause.)
IllegalStateException - if the cause for this SOAPException object has already been initialized
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPFactory

java.lang.Object
    extended by  javax.xml.soap.SOAPFactory

public abstract class SOAPFactory
extends Object

SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree. SOAPFactory can be used to create XML fragments that will eventually end up in the SOAP part. These fragments can be inserted as children of the SOAPHeaderElement or SOAPBodyElement or SOAPEnvelope or other SOAPElement objects. SOAPFactory also has methods to create javax.xml.soap.Detail objects as well as java.xml.soap.Name objects.

Constructor Summary
SOAPFactory()
Method Summary
abstract Detail | createDetail() Creates a new Detail object which serves as a container for DetailEntry objects.
SOAPElement | createElement(Element domElement) Creates a SOAPElement object from an existing DOM Element.
abstract SOAPElement | createElement(Name name) Creates a SOAPElement object initialized with the given Name object.
SOAPElement | createElement(QName qname) Creates a SOAPElement object initialized with the given QName object.
abstract SOAPElement | createElement(String localName) Creates a SOAPElement object initialized with the given local name.
abstract SOAPElement | createElement(String localName, String prefix, String uri) Creates a new SOAPElement object with the given local name, prefix and uri.
abstract SOAPFault | createFault() Creates a new default SOAPFault object
abstract SOAPFault | createFault(String reasonText, QName faultCode) Creates a new SOAPFault object initialized with the given reasonText and faultCode
abstract Name | createName(String localName) Creates a new Name object initialized with the given local name.
abstract Name | createName(String localName, String prefix, String uri) Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
static SOAPFactory | newInstance() Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load: Use the javax.xml.soap.SOAPFactory system property.
static SOAPFactory | newInstance(String protocol) Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SOAPFactory

public SOAPFactory()
Method Detail

createElement

public SOAPElement createElement(Element domElement)
                          throws SOAPException
Creates a SOAPElement object from an existing DOM Element. If the DOM Element that is passed in as an argument is already a SOAPElement then this method must return it unmodified without any further work. Otherwise, a new SOAPElement is created and a deep copy is made of the domElement argument. The concrete type of the return value will depend on the name of the domElement argument. If any part of the tree rooted in domElement violates SOAP rules, a SOAPException will be thrown.

Parameters:
domElement - - the Element to be copied.
Returns:
a new SOAPElement that is a copy of domElement.
Throws:
SOAPException - if there is an error in creating the SOAPElement object
Since:
SAAJ 1.3

createElement

public abstract SOAPElement createElement(Name name)
                                   throws SOAPException
Creates a SOAPElement object initialized with the given Name object. The concrete type of the return value will depend on the name given to the new SOAPElement. For instance, a new SOAPElement with the name "{http://www.w3.org/2003/05/soap-envelope}Envelope" would cause a SOAPEnvelope that supports SOAP 1.2 behavior to be created.

Parameters:
name - a Name object with the XML name for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object
See Also:
createElement(javax.xml.namespace.QName)

createElement

public SOAPElement createElement(QName qname)
                          throws SOAPException
Creates a SOAPElement object initialized with the given QName object. The concrete type of the return value will depend on the name given to the new SOAPElement. For instance, a new SOAPElement with the name "{http://www.w3.org/2003/05/soap-envelope}Envelope" would cause a SOAPEnvelope that supports SOAP 1.2 behavior to be created.

Parameters:
qname - a QName object with the XML name for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object
Since:
SAAJ 1.3
See Also:
createElement(Name)

createElement

public abstract SOAPElement createElement(String localName)
                                   throws SOAPException
Creates a SOAPElement object initialized with the given local name.

Parameters:
localName - a String giving the local name for the new element
Returns:
the new SOAPElement object that was created
Throws:
SOAPException - if there is an error in creating the SOAPElement object

createElement

public abstract SOAPElement createElement(String localName,
                                          String prefix,
                                          String uri)
                                   throws SOAPException
Creates a new SOAPElement object with the given local name, prefix and uri. The concrete type of the return value will depend on the name given to the new SOAPElement. For instance, a new SOAPElement with the name "{http://www.w3.org/2003/05/soap-envelope}Envelope" would cause a SOAPEnvelope that supports SOAP 1.2 behavior to be created.

Parameters:
localName - a String giving the local name for the new element
prefix - the prefix for this SOAPElement
uri - a String giving the URI of the namespace to which the new element belongs
Throws:
SOAPException - if there is an error in creating the SOAPElement object

createDetail

public abstract Detail createDetail()
                             throws SOAPException
Creates a new Detail object which serves as a container for DetailEntry objects.

This factory method creates Detail objects for use in situations where it is not practical to use the SOAPFault abstraction.

Returns:
a Detail object
Throws:
SOAPException - if there is a SOAP error
UnsupportedOperationException - if the protocol specified for the SOAPFactory was DYNAMIC_SOAP_PROTOCOL

createFault

public abstract SOAPFault createFault(String reasonText,
                                      QName faultCode)
                               throws SOAPException
Creates a new SOAPFault object initialized with the given reasonText and faultCode

Parameters:
reasonText - the ReasonText/FaultString for the fault
faultCode - the FaultCode for the fault
Returns:
a SOAPFault object
Throws:
SOAPException - if there is a SOAP error
Since:
SAAJ 1.3

createFault

public abstract SOAPFault createFault()
                               throws SOAPException
Creates a new default SOAPFault object

Returns:
a SOAPFault object
Throws:
SOAPException - if there is a SOAP error
Since:
SAAJ 1.3

createName

public abstract Name createName(String localName,
                                String prefix,
                                String uri)
                         throws SOAPException
Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.

This factory method creates Name objects for use in situations where it is not practical to use the SOAPEnvelope abstraction.

Parameters:
localName - a String giving the local name
prefix - a String giving the prefix of the namespace
uri - a String giving the URI of the namespace
Returns:
a Name object initialized with the given local name, namespace prefix, and namespace URI
Throws:
SOAPException - if there is a SOAP error

createName

public abstract Name createName(String localName)
                         throws SOAPException
Creates a new Name object initialized with the given local name.

This factory method creates Name objects for use in situations where it is not practical to use the SOAPEnvelope abstraction.

Parameters:
localName - a String giving the local name
Returns:
a Name object initialized with the given local name
Throws:
SOAPException - if there is a SOAP error

newInstance

public static SOAPFactory newInstance()
                               throws SOAPException
Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load:
  • Use the javax.xml.soap.SOAPFactory system property.
  • Use the properties file "lib/jaxm.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above.
  • Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.soap.SOAPFactory in jars available to the runtime.
  • Use the SAAJMetaFactory instance to locate the SOAPFactory implementation class.

Returns:
a new instance of a SOAPFactory
Throws:
SOAPException - if there was an error creating the default SOAPFactory
See Also:
SAAJMetaFactory

newInstance

public static SOAPFactory newInstance(String protocol)
                               throws SOAPException
Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.

Parameters:
protocol - a string constant representing the protocol of the specified SOAP factory implementation. May be either DYNAMIC_SOAP_PROTOCOL, DEFAULT_SOAP_PROTOCOL (which is the same as) SOAP_1_1_PROTOCOL, or SOAP_1_2_PROTOCOL.
Returns:
a new instance of a SOAPFactory
Throws:
SOAPException - if there was an error creating the specified SOAPFactory
Since:
SAAJ 1.3
See Also:
SAAJMetaFactory
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPFault

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPFault

All Superinterfaces:
Element, Node, SOAPBodyElement, SOAPElement
public interface SOAPFault
extends SOAPBodyElement

An element in the SOAPBody object that contains error and/or status information. This information may relate to errors in the SOAPMessage object or to problems that are not related to the content in the message itself. Problems not related to the message itself are generally errors in processing, such as the inability to communicate with an upstream server.

Depending on the protocol specified while creating the MessageFactory instance, a SOAPFault has sub-elements as defined in the SOAP 1.1/SOAP 1.2 specification.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
Detail | addDetail() Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
void | addFaultReasonText(String text, Locale locale) Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale.
void | appendFaultSubcode(QName subcode) Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault.
Detail | getDetail() Returns the optional detail element for this SOAPFault object.
String | getFaultActor() Gets the fault actor for this SOAPFault object.
String | getFaultCode() Gets the fault code for this SOAPFault object.
Name | getFaultCodeAsName() Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object.
QName | getFaultCodeAsQName() Gets the fault code for this SOAPFault object as a QName object.
String | getFaultNode() Returns the optional Node element value for this SOAPFault object.
Iterator | getFaultReasonLocales() Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items.
String | getFaultReasonText(Locale locale) Returns the Reason Text associated with the given Locale.
Iterator | getFaultReasonTexts() Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.
String | getFaultRole() Returns the optional Role element value for this SOAPFault object.
String | getFaultString() Gets the fault string for this SOAPFault object.
Locale | getFaultStringLocale() Gets the locale of the fault string for this SOAPFault object.
Iterator | getFaultSubcodes() Gets the Subcodes for this SOAPFault as an iterator over QNames.
boolean | hasDetail() Returns true if this SOAPFault has a Detail subelement and false otherwise.
void | removeAllFaultSubcodes() Removes any Subcodes that may be contained by this SOAPFault.
void | setFaultActor(String faultActor) Sets this SOAPFault object with the given fault actor.
void | setFaultCode(Name faultCodeQName) Sets this SOAPFault object with the given fault code.
void | setFaultCode(QName faultCodeQName) Sets this SOAPFault object with the given fault code.
void | setFaultCode(String faultCode) Sets this SOAPFault object with the give fault code.
void | setFaultNode(String uri) Creates or replaces any existing Node element value for this SOAPFault object.
void | setFaultRole(String uri) Creates or replaces any existing Role element value for this SOAPFault object.
void | setFaultString(String faultString) Sets the fault string for this SOAPFault object to the given string.
void | setFaultString(String faultString, Locale locale) Sets the fault string for this SOAPFault object to the given string and localized to the given locale.
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

setFaultCode

void setFaultCode(Name faultCodeQName)
                  throws SOAPException
Sets this SOAPFault object with the given fault code.

Fault codes, which give information about the fault, are defined in the SOAP 1.1 specification. A fault code is mandatory and must be of type Name. This method provides a convenient way to set a fault code. For example,

 SOAPEnvelope se = ...;
 // Create a qualified name in the SOAP namespace with a localName
 // of "Client". Note that prefix parameter is optional and is null
 // here which causes the implementation to use an appropriate prefix.
 Name qname = se.createName("Client", null,
                            SOAPConstants.URI_NS_SOAP_ENVELOPE);
 SOAPFault fault = ...;
 fault.setFaultCode(qname);
It is preferable to use this method over setFaultCode(String).

Parameters:
faultCodeQName - a Name object giving the fault code to be set. It must be namespace qualified.
Throws:
SOAPException - if there was an error in adding the faultcode element to the underlying XML tree.
Since:
SAAJ 1.2
See Also:
getFaultCodeAsName()

setFaultCode

void setFaultCode(QName faultCodeQName)
                  throws SOAPException
Sets this SOAPFault object with the given fault code. It is preferable to use this method over setFaultCode(Name).

Parameters:
faultCodeQName - a QName object giving the fault code to be set. It must be namespace qualified.
Throws:
SOAPException - if there was an error in adding the faultcode element to the underlying XML tree.
Since:
SAAJ 1.3
See Also:
getFaultCodeAsQName(), setFaultCode(Name), getFaultCodeAsQName()

setFaultCode

void setFaultCode(String faultCode)
                  throws SOAPException
Sets this SOAPFault object with the give fault code.

Fault codes, which given information about the fault, are defined in the SOAP 1.1 specification. This element is mandatory in SOAP 1.1. Because the fault code is required to be a QName it is preferable to use the setFaultCode(Name) form of this method.

Parameters:
faultCode - a String giving the fault code to be set. It must be of the form "prefix:localName" where the prefix has been defined in a namespace declaration.
Throws:
SOAPException - if there was an error in adding the faultCode to the underlying XML tree.
See Also:
setFaultCode(Name), getFaultCode(), SOAPElement.addNamespaceDeclaration(java.lang.String, java.lang.String)

getFaultCodeAsName

Name getFaultCodeAsName()
Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object. The SOAP 1.1 specification requires the value of the "faultcode" element to be of type QName. This method returns the content of the element as a QName in the form of a SAAJ Name object. This method should be used instead of the getFaultCode method since it allows applications to easily access the namespace name without additional parsing.

Returns:
a Name representing the faultcode
Since:
SAAJ 1.2
See Also:
setFaultCode(Name)

getFaultCodeAsQName

QName getFaultCodeAsQName()
Gets the fault code for this SOAPFault object as a QName object.

Returns:
a QName representing the faultcode
Since:
SAAJ 1.3
See Also:
setFaultCode(QName)

getFaultSubcodes

Iterator getFaultSubcodes()
Gets the Subcodes for this SOAPFault as an iterator over QNames.

Returns:
an Iterator that accesses a sequence of QNames. This Iterator should not support the optional remove method. The order in which the Subcodes are returned reflects the hierarchy of Subcodes present in the fault from top to bottom.
Throws:
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Subcode.
Since:
SAAJ 1.3

removeAllFaultSubcodes

void removeAllFaultSubcodes()
Removes any Subcodes that may be contained by this SOAPFault. Subsequent calls to getFaultSubcodes will return an empty iterator until a call to appendFaultSubcode is made.

Throws:
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Subcode.
Since:
SAAJ 1.3

appendFaultSubcode

void appendFaultSubcode(QName subcode)
                        throws SOAPException
Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault. Subcodes, which were introduced in SOAP 1.2, are represented by a recursive sequence of subelements rooted in the mandatory Code subelement of a SOAP Fault.

Parameters:
subcode - a QName containing the Value of the Subcode.
Throws:
SOAPException - if there was an error in setting the Subcode
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Subcode.
Since:
SAAJ 1.3

getFaultCode

String getFaultCode()
Gets the fault code for this SOAPFault object.

Returns:
a String with the fault code
See Also:
getFaultCodeAsName(), setFaultCode(javax.xml.soap.Name)

setFaultActor

void setFaultActor(String faultActor)
                   throws SOAPException
Sets this SOAPFault object with the given fault actor.

The fault actor is the recipient in the message path who caused the fault to happen.

If this SOAPFault supports SOAP 1.2 then this call is equivalent to setFaultRole(String)

Parameters:
faultActor - a String identifying the actor that caused this SOAPFault object
Throws:
SOAPException - if there was an error in adding the faultActor to the underlying XML tree.
See Also:
getFaultActor()

getFaultActor

String getFaultActor()
Gets the fault actor for this SOAPFault object.

If this SOAPFault supports SOAP 1.2 then this call is equivalent to getFaultRole()

Returns:
a String giving the actor in the message path that caused this SOAPFault object
See Also:
setFaultActor(java.lang.String)

setFaultString

void setFaultString(String faultString)
                    throws SOAPException
Sets the fault string for this SOAPFault object to the given string.

If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

      addFaultReasonText(faultString, Locale.getDefault());

Parameters:
faultString - a String giving an explanation of the fault
Throws:
SOAPException - if there was an error in adding the faultString to the underlying XML tree.
See Also:
getFaultString()

setFaultString

void setFaultString(String faultString,
                    Locale locale)
                    throws SOAPException
Sets the fault string for this SOAPFault object to the given string and localized to the given locale.

If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

      addFaultReasonText(faultString, locale);

Parameters:
faultString - a String giving an explanation of the fault
locale - a Locale object indicating the native language of the faultString
Throws:
SOAPException - if there was an error in adding the faultString to the underlying XML tree.
Since:
SAAJ 1.2
See Also:
getFaultString()

getFaultString

String getFaultString()
Gets the fault string for this SOAPFault object.

If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

    String reason = null;
    try {
        reason = (String) getFaultReasonTexts().next();
    } catch (SOAPException e) {}
    return reason;

Returns:
a String giving an explanation of the fault
See Also:
setFaultString(String), setFaultString(String, Locale)

getFaultStringLocale

Locale getFaultStringLocale()
Gets the locale of the fault string for this SOAPFault object.

If this SOAPFault is part of a message that supports SOAP 1.2 then this call is equivalent to:

    Locale locale = null;
    try {
        locale = (Locale) getFaultReasonLocales().next();
    } catch (SOAPException e) {}
    return locale;

Returns:
a Locale object indicating the native language of the fault string or null if no locale was specified
Since:
SAAJ 1.2
See Also:
setFaultString(String, Locale)

hasDetail

boolean hasDetail()
Returns true if this SOAPFault has a Detail subelement and false otherwise. Equivalent to (getDetail()!=null).

Returns:
true if this SOAPFault has a Detail subelement and false otherwise.
Since:
SAAJ 1.3

getDetail

Detail getDetail()
Returns the optional detail element for this SOAPFault object.

A Detail object carries application-specific error information, the scope of the error information is restricted to faults in the SOAPBodyElement objects if this is a SOAP 1.1 Fault.

Returns:
a Detail object with application-specific error information if present, null otherwise

addDetail

Detail addDetail()
                 throws SOAPException
Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.

It is illegal to add a detail when the fault already contains a detail. Therefore, this method should be called only after the existing detail has been removed.

Returns:
the new Detail object
Throws:
SOAPException - if this SOAPFault object already contains a valid Detail object

getFaultReasonLocales

Iterator getFaultReasonLocales()
                               throws SOAPException
Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items. Any of these Locales can be used in a call to getFaultReasonText in order to obtain a localized version of the Reason Text string.

Returns:
an Iterator over a sequence of Locale objects for which there are associated Reason Text items.
Throws:
SOAPException - if there was an error in retrieving the fault Reason locales.
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
Since:
SAAJ 1.3

getFaultReasonTexts

Iterator getFaultReasonTexts()
                             throws SOAPException
Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.

Returns:
an Iterator over env:Fault/env:Reason/env:Text items.
Throws:
SOAPException - if there was an error in retrieving the fault Reason texts.
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
Since:
SAAJ 1.3

getFaultReasonText

String getFaultReasonText(Locale locale)
                          throws SOAPException
Returns the Reason Text associated with the given Locale. If more than one such Reason Text exists the first matching Text is returned

Parameters:
locale - -- the Locale for which a localized Reason Text is desired
Returns:
the Reason Text associated with locale
Throws:
SOAPException - if there was an error in retrieving the fault Reason text for the specified locale .
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
Since:
SAAJ 1.3
See Also:
getFaultString()

addFaultReasonText

void addFaultReasonText(String text,
                        Locale locale)
                        throws SOAPException
Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale. If a Reason Text item with this xml:lang already exists its text value will be replaced with text. The locale parameter should not be null

Code sample:

 SOAPFault fault = ...;
 fault.addFaultReasonText("Version Mismatch", Locale.ENGLISH);

Parameters:
text - -- reason message string
locale - -- Locale object representing the locale of the message
Throws:
SOAPException - if there was an error in adding the Reason text or the locale passed was null.
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Reason.
Since:
SAAJ 1.3

getFaultNode

String getFaultNode()
Returns the optional Node element value for this SOAPFault object. The Node element is optional in SOAP 1.2.

Returns:
Content of the env:Fault/env:Node element as a String or null if none
Throws:
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Node.
Since:
SAAJ 1.3

setFaultNode

void setFaultNode(String uri)
                  throws SOAPException
Creates or replaces any existing Node element value for this SOAPFault object. The Node element is optional in SOAP 1.2.

Throws:
SOAPException - if there was an error in setting the Node for this SOAPFault object.
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Node.
Since:
SAAJ 1.3

getFaultRole

String getFaultRole()
Returns the optional Role element value for this SOAPFault object. The Role element is optional in SOAP 1.2.

Returns:
Content of the env:Fault/env:Role element as a String or null if none
Throws:
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
Since:
SAAJ 1.3

setFaultRole

void setFaultRole(String uri)
                  throws SOAPException
Creates or replaces any existing Role element value for this SOAPFault object. The Role element is optional in SOAP 1.2.

Parameters:
uri - - the URI of the Role
Throws:
SOAPException - if there was an error in setting the Role for this SOAPFault object.
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
Since:
SAAJ 1.3
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPHeader

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPHeader

All Superinterfaces:
Element, Node, SOAPElement
public interface SOAPHeader
extends SOAPElement

A representation of the SOAP header element. A SOAP header element consists of XML data that affects the way the application-specific content is processed by the message provider. For example, transaction semantics, authentication information, and so on, can be specified as the content of a SOAPHeader object.

A SOAPEnvelope object contains an empty SOAPHeader object by default. If the SOAPHeader object, which is optional, is not needed, it can be retrieved and deleted with the following line of code. The variable se is a SOAPEnvelope object.

      se.getHeader().detachNode();
A SOAPHeader object is created with the SOAPEnvelope method addHeader. This method, which creates a new header and adds it to the envelope, may be called only after the existing header has been removed.
      se.getHeader().detachNode();
      SOAPHeader sh = se.addHeader();

A SOAPHeader object can have only SOAPHeaderElement objects as its immediate children. The method addHeaderElement creates a new HeaderElement object and adds it to the SOAPHeader object. In the following line of code, the argument to the method addHeaderElement is a Name object that is the name for the new HeaderElement object.

      SOAPHeaderElement shElement = sh.addHeaderElement(name);

See Also:
SOAPHeaderElement

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
SOAPHeaderElement | addHeaderElement(Name name) Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
SOAPHeaderElement | addHeaderElement(QName qname) Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
SOAPHeaderElement | addNotUnderstoodHeaderElement(QName name) Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
SOAPHeaderElement | addUpgradeHeaderElement(Iterator supportedSOAPURIs) Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.
SOAPHeaderElement | addUpgradeHeaderElement(String supportedSoapUri) Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.
SOAPHeaderElement | addUpgradeHeaderElement(String[] supportedSoapUris) Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.
Iterator | examineAllHeaderElements() Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.
Iterator | examineHeaderElements(String actor) Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor.
Iterator | examineMustUnderstandHeaderElements(String actor) Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.
Iterator | extractAllHeaderElements() Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.
Iterator | extractHeaderElements(String actor) Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

addHeaderElement

SOAPHeaderElement addHeaderElement(Name name)
                                   throws SOAPException
Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.

Parameters:
name - a Name object with the name of the new SOAPHeaderElement object
Returns:
the new SOAPHeaderElement object that was inserted into this SOAPHeader object
Throws:
SOAPException - if a SOAP error occurs
See Also:
addHeaderElement(javax.xml.namespace.QName)

addHeaderElement

SOAPHeaderElement addHeaderElement(QName qname)
                                   throws SOAPException
Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.

Parameters:
qname - a QName object with the qname of the new SOAPHeaderElement object
Returns:
the new SOAPHeaderElement object that was inserted into this SOAPHeader object
Throws:
SOAPException - if a SOAP error occurs
Since:
SAAJ 1.3
See Also:
addHeaderElement(Name)

examineMustUnderstandHeaderElements

Iterator examineMustUnderstandHeaderElements(String actor)
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.

In SOAP 1.2 the env:actor attribute is replaced by the env:role attribute, but with essentially the same semantics.

Parameters:
actor - a String giving the URI of the actor / role for which to search
Returns:
an Iterator object over all the SOAPHeaderElement objects that contain the specified actor / role and are marked as MustUnderstand
Since:
SAAJ 1.2
See Also:
examineHeaderElements(java.lang.String), extractHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

examineHeaderElements

Iterator examineHeaderElements(String actor)
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor. An actor is a global attribute that indicates the intermediate parties that should process a message before it reaches its ultimate receiver. An actor receives the message and processes it before sending it on to the next actor. The default actor is the ultimate intended recipient for the message, so if no actor attribute is included in a SOAPHeader object, it is sent to the ultimate receiver along with the message body.

In SOAP 1.2 the env:actor attribute is replaced by the env:role attribute, but with essentially the same semantics.

Parameters:
actor - a String giving the URI of the actor / role for which to search
Returns:
an Iterator object over all the SOAPHeaderElement objects that contain the specified actor / role
See Also:
extractHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

extractHeaderElements

Iterator extractHeaderElements(String actor)
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.

This method allows an actor to process the parts of the SOAPHeader object that apply to it and to remove them before passing the message on to the next actor.

In SOAP 1.2 the env:actor attribute is replaced by the env:role attribute, but with essentially the same semantics.

Parameters:
actor - a String giving the URI of the actor / role for which to search
Returns:
an Iterator object over all the SOAPHeaderElement objects that contain the specified actor / role
See Also:
examineHeaderElements(java.lang.String), SOAPConstants.URI_SOAP_ACTOR_NEXT

addNotUnderstoodHeaderElement

SOAPHeaderElement addNotUnderstoodHeaderElement(QName name)
                                                throws SOAPException
Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object. This operation is supported only by SOAP 1.2.

Parameters:
name - a QName object with the name of the SOAPHeaderElement object that was not understood.
Returns:
the new SOAPHeaderElement object that was inserted into this SOAPHeader object
Throws:
SOAPException - if a SOAP error occurs.
UnsupportedOperationException - if this is a SOAP 1.1 Header.
Since:
SAAJ 1.3

addUpgradeHeaderElement

SOAPHeaderElement addUpgradeHeaderElement(Iterator supportedSOAPURIs)
                                          throws SOAPException
Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object. This operation is supported on both SOAP 1.1 and SOAP 1.2 header.

Parameters:
supportedSOAPURIs - an Iterator object with the URIs of SOAP versions supported.
Returns:
the new SOAPHeaderElement object that was inserted into this SOAPHeader object
Throws:
SOAPException - if a SOAP error occurs.
Since:
SAAJ 1.3

addUpgradeHeaderElement

SOAPHeaderElement addUpgradeHeaderElement(String[] supportedSoapUris)
                                          throws SOAPException
Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object. This operation is supported on both SOAP 1.1 and SOAP 1.2 header.

Parameters:
supportedSoapUris - an array of the URIs of SOAP versions supported.
Returns:
the new SOAPHeaderElement object that was inserted into this SOAPHeader object
Throws:
SOAPException - if a SOAP error occurs.
Since:
SAAJ 1.3

addUpgradeHeaderElement

SOAPHeaderElement addUpgradeHeaderElement(String supportedSoapUri)
                                          throws SOAPException
Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object. This operation is supported on both SOAP 1.1 and SOAP 1.2 header.

Parameters:
supportedSoapUri - the URI of SOAP the version that is supported.
Returns:
the new SOAPHeaderElement object that was inserted into this SOAPHeader object
Throws:
SOAPException - if a SOAP error occurs.
Since:
SAAJ 1.3

examineAllHeaderElements

Iterator examineAllHeaderElements()
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.

Returns:
an Iterator object over all the SOAPHeaderElement objects contained by this SOAPHeader
Since:
SAAJ 1.2
See Also:
extractAllHeaderElements()

extractAllHeaderElements

Iterator extractAllHeaderElements()
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.

Returns:
an Iterator object over all the SOAPHeaderElement objects contained by this SOAPHeader
Since:
SAAJ 1.2
See Also:
examineAllHeaderElements()
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPHeaderElement

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface SOAPHeaderElement

All Superinterfaces:
Element, Node, SOAPElement
public interface SOAPHeaderElement
extends SOAPElement

An object representing the contents in the SOAP header part of the SOAP envelope. The immediate children of a SOAPHeader object can be represented only as SOAPHeaderElement objects.

A SOAPHeaderElement object can have other SOAPElement objects as its children.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
String | getActor() Returns the uri of the actor attribute of this SOAPHeaderElement.
boolean | getMustUnderstand() Returns the boolean value of the mustUnderstand attribute for this SOAPHeaderElement.
boolean | getRelay() Returns the boolean value of the relay attribute for this SOAPHeaderElement
String | getRole() Returns the value of the Role attribute of this SOAPHeaderElement.
void | setActor(String actorURI) Sets the actor associated with this SOAPHeaderElement object to the specified actor.
void | setMustUnderstand(boolean mustUnderstand) Sets the mustUnderstand attribute for this SOAPHeaderElement object to be either true or false.
void | setRelay(boolean relay) Sets the relay attribute for this SOAPHeaderElement to be either true or false.
void | setRole(String uri) Sets the Role associated with this SOAPHeaderElement object to the specified Role.
Methods inherited from interface javax.xml.soap.SOAPElement
addAttribute, addAttribute, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addChildElement, addNamespaceDeclaration, addTextNode, createQName, getAllAttributes, getAllAttributesAsQNames, getAttributeValue, getAttributeValue, getChildElements, getChildElements, getChildElements, getElementName, getElementQName, getEncodingStyle, getNamespacePrefixes, getNamespaceURI, getVisibleNamespacePrefixes, removeAttribute, removeAttribute, removeContents, removeNamespaceDeclaration, setElementQName, setEncodingStyle
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Methods inherited from interface org.w3c.dom.Element
getAttribute, getAttributeNode, getAttributeNodeNS, getAttributeNS, getElementsByTagName, getElementsByTagNameNS, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

setActor

void setActor(String actorURI)
Sets the actor associated with this SOAPHeaderElement object to the specified actor. The default value of an actor is: SOAPConstants.URI_SOAP_ACTOR_NEXT

If this SOAPHeaderElement supports SOAP 1.2 then this call is equivalent to setRole(String)

Parameters:
actorURI - a String giving the URI of the actor to set
Throws:
IllegalArgumentException - if there is a problem in setting the actor.
See Also:
getActor()

setRole

void setRole(String uri)
             throws SOAPException
Sets the Role associated with this SOAPHeaderElement object to the specified Role.

Parameters:
uri - - the URI of the Role
Throws:
SOAPException - if there is an error in setting the role
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
Since:
SAAJ 1.3

getActor

String getActor()
Returns the uri of the actor attribute of this SOAPHeaderElement.

If this SOAPHeaderElement supports SOAP 1.2 then this call is equivalent to getRole()

Returns:
a String giving the URI of the actor
See Also:
setActor(java.lang.String)

getRole

String getRole()
Returns the value of the Role attribute of this SOAPHeaderElement.

Returns:
a String giving the URI of the Role
Throws:
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Fault Role.
Since:
SAAJ 1.3

setMustUnderstand

void setMustUnderstand(boolean mustUnderstand)
Sets the mustUnderstand attribute for this SOAPHeaderElement object to be either true or false.

If the mustUnderstand attribute is on, the actor who receives the SOAPHeaderElement must process it correctly. This ensures, for example, that if the SOAPHeaderElement object modifies the message, that the message is being modified correctly.

Parameters:
mustUnderstand - true to set the mustUnderstand attribute to true; false to set it to false
Throws:
IllegalArgumentException - if there is a problem in setting the mustUnderstand attribute
See Also:
getMustUnderstand(), setRelay(boolean)

getMustUnderstand

boolean getMustUnderstand()
Returns the boolean value of the mustUnderstand attribute for this SOAPHeaderElement.

Returns:
true if the mustUnderstand attribute of this SOAPHeaderElement object is turned on; false otherwise

setRelay

void setRelay(boolean relay)
              throws SOAPException
Sets the relay attribute for this SOAPHeaderElement to be either true or false.

The SOAP relay attribute is set to true to indicate that the SOAP header block must be relayed by any node that is targeted by the header block but not actually process it. This attribute is ignored on header blocks whose mustUnderstand attribute is set to true or that are targeted at the ultimate reciever (which is the default). The default value of this attribute is false.

Parameters:
relay - the new value of the relay attribute
Throws:
SOAPException - if there is a problem in setting the relay attribute.
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Relay attribute.
Since:
SAAJ 1.3
See Also:
setMustUnderstand(boolean), getRelay()

getRelay

boolean getRelay()
Returns the boolean value of the relay attribute for this SOAPHeaderElement

Returns:
true if the relay attribute is turned on; false otherwise
Throws:
UnsupportedOperationException - if this message does not support the SOAP 1.2 concept of Relay attribute.
Since:
SAAJ 1.3
See Also:
getMustUnderstand(), setRelay(boolean)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPMessage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPMessage

java.lang.Object
    extended by  javax.xml.soap.SOAPMessage

public abstract class SOAPMessage
extends Object

The root class for all SOAP messages. As transmitted on the "wire", a SOAP message is an XML document or a MIME message whose first body part is an XML/SOAP document.

A SOAPMessage object consists of a SOAP part and optionally one or more attachment parts. The SOAP part for a SOAPMessage object is a SOAPPart object, which contains information used for message routing and identification, and which can contain application-specific content. All data in the SOAP Part of a message must be in XML format.

A new SOAPMessage object contains the following by default:

  • A SOAPPart object
  • A SOAPEnvelope object
  • A SOAPBody object
  • A SOAPHeader object
The SOAP part of a message can be retrieved by calling the method SOAPMessage.getSOAPPart(). The SOAPEnvelope object is retrieved from the SOAPPart object, and the SOAPEnvelope object is used to retrieve the SOAPBody and SOAPHeader objects.
     SOAPPart sp = message.getSOAPPart();
     SOAPEnvelope se = sp.getEnvelope();
     SOAPBody sb = se.getBody();
     SOAPHeader sh = se.getHeader();

In addition to the mandatory SOAPPart object, a SOAPMessage object may contain zero or more AttachmentPart objects, each of which contains application-specific data. The SOAPMessage interface provides methods for creating AttachmentPart objects and also for adding them to a SOAPMessage object. A party that has received a SOAPMessage object can examine its contents by retrieving individual attachment parts.

Unlike the rest of a SOAP message, an attachment is not required to be in XML format and can therefore be anything from simple text to an image file. Consequently, any message content that is not in XML format must be in an AttachmentPart object.

A MessageFactory object may create SOAPMessage objects with behavior that is specialized to a particular implementation or application of SAAJ. For instance, a MessageFactory object may produce SOAPMessage objects that conform to a particular Profile such as ebXML. In this case a MessageFactory object might produce SOAPMessage objects that are initialized with ebXML headers.

In order to ensure backward source compatibility, methods that are added to this class after version 1.1 of the SAAJ specification are all concrete instead of abstract and they all have default implementations. Unless otherwise noted in the JavaDocs for those methods the default implementations simply throw an UnsupportedOperationException and the SAAJ implementation code must override them with methods that provide the specified behavior. Legacy client code does not have this restriction, however, so long as there is no claim made that it conforms to some later version of the specification than it was originally written for. A legacy class that extends the SOAPMessage class can be compiled and/or run against succeeding versions of the SAAJ API without modification. If such a class was correctly implemented then it will continue to behave correctly relative to the version of the specification against which it was written.

See Also:
MessageFactory, AttachmentPart

Field Summary
static String | CHARACTER_SET_ENCODING Specifies the character type encoding for the SOAP Message.
static String | WRITE_XML_DECLARATION Specifies whether the SOAP Message will contain an XML declaration when it is sent.
Constructor Summary
SOAPMessage()
Method Summary
abstract void | addAttachmentPart(AttachmentPart AttachmentPart) Adds the given AttachmentPart object to this SOAPMessage object.
abstract int | countAttachments() Gets a count of the number of attachments in this message.
abstract AttachmentPart | createAttachmentPart() Creates a new empty AttachmentPart object.
AttachmentPart | createAttachmentPart(DataHandler dataHandler) Creates an AttachmentPart object and populates it using the given DataHandler object.
AttachmentPart | createAttachmentPart(Object content, String contentType) Creates an AttachmentPart object and populates it with the specified data of the specified content type.
abstract AttachmentPart | getAttachment(SOAPElement element) Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.
abstract Iterator | getAttachments() Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.
abstract Iterator | getAttachments(MimeHeaders headers) Retrieves all the AttachmentPart objects that have header entries that match the specified headers.
abstract String | getContentDescription() Retrieves a description of this SOAPMessage object's content.
abstract MimeHeaders | getMimeHeaders() Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.
Object | getProperty(String property) Retrieves value of the specified property.
SOAPBody | getSOAPBody() Gets the SOAP Body contained in this SOAPMessage object.
SOAPHeader | getSOAPHeader() Gets the SOAP Header contained in this SOAPMessage object.
abstract SOAPPart | getSOAPPart() Gets the SOAP part of this SOAPMessage object.
abstract void | removeAllAttachments() Removes all AttachmentPart objects that have been added to this SOAPMessage object.
abstract void | removeAttachments(MimeHeaders headers) Removes all the AttachmentPart objects that have header entries that match the specified headers.
abstract void | saveChanges() Updates this SOAPMessage object with all the changes that have been made to it.
abstract boolean | saveRequired() Indicates whether this SOAPMessage object needs to have the method saveChanges called on it.
abstract void | setContentDescription(String description) Sets the description of this SOAPMessage object's content with the given description.
void | setProperty(String property, Object value) Associates the specified value with the specified property.
abstract void | writeTo(OutputStream out) Writes this SOAPMessage object to the given output stream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CHARACTER_SET_ENCODING

public static final String CHARACTER_SET_ENCODING
Specifies the character type encoding for the SOAP Message. Valid values include "utf-8" and "utf-16". See vendor documentation for additional supported values. The default is "utf-8".

Since:
SAAJ 1.2
See Also:
SOAPMessage.setProperty, Constant Field Values

WRITE_XML_DECLARATION

public static final String WRITE_XML_DECLARATION
Specifies whether the SOAP Message will contain an XML declaration when it is sent. The only valid values are "true" and "false". The default is "false".

Since:
SAAJ 1.2
See Also:
SOAPMessage.setProperty, Constant Field Values
Constructor Detail

SOAPMessage

public SOAPMessage()
Method Detail

setContentDescription

public abstract void setContentDescription(String description)
Sets the description of this SOAPMessage object's content with the given description.

Parameters:
description - a String describing the content of this message
See Also:
getContentDescription()

getContentDescription

public abstract String getContentDescription()
Retrieves a description of this SOAPMessage object's content.

Returns:
a String describing the content of this message or null if no description has been set
See Also:
setContentDescription(java.lang.String)

getSOAPPart

public abstract SOAPPart getSOAPPart()
Gets the SOAP part of this SOAPMessage object.

SOAPMessage object contains one or more attachments, the SOAP Part must be the first MIME body part in the message.

Returns:
the SOAPPart object for this SOAPMessage object

getSOAPBody

public SOAPBody getSOAPBody()
                     throws SOAPException
Gets the SOAP Body contained in this SOAPMessage object.

Returns:
the SOAPBody object contained by this SOAPMessage object
Throws:
SOAPException - if the SOAP Body does not exist or cannot be retrieved
Since:
SAAJ 1.2

getSOAPHeader

public SOAPHeader getSOAPHeader()
                         throws SOAPException
Gets the SOAP Header contained in this SOAPMessage object.

Returns:
the SOAPHeader object contained by this SOAPMessage object
Throws:
SOAPException - if the SOAP Header does not exist or cannot be retrieved
Since:
SAAJ 1.2

removeAllAttachments

public abstract void removeAllAttachments()
Removes all AttachmentPart objects that have been added to this SOAPMessage object.

This method does not touch the SOAP part.

countAttachments

public abstract int countAttachments()
Gets a count of the number of attachments in this message. This count does not include the SOAP part.

Returns:
the number of AttachmentPart objects that are part of this SOAPMessage object

getAttachments

public abstract Iterator getAttachments()
Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.

Returns:
an iterator over all the attachments in this message

getAttachments

public abstract Iterator getAttachments(MimeHeaders headers)
Retrieves all the AttachmentPart objects that have header entries that match the specified headers. Note that a returned attachment could have headers in addition to those specified.

Parameters:
headers - a MimeHeaders object containing the MIME headers for which to search
Returns:
an iterator over all attachments that have a header that matches one of the given headers

removeAttachments

public abstract void removeAttachments(MimeHeaders headers)
Removes all the AttachmentPart objects that have header entries that match the specified headers. Note that the removed attachment could have headers in addition to those specified.

Parameters:
headers - a MimeHeaders object containing the MIME headers for which to search
Since:
SAAJ 1.3

getAttachment

public abstract AttachmentPart getAttachment(SOAPElement element)
                                      throws SOAPException
Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists. References can be made via an href attribute as described in SOAP Messages with Attachments, or via a single Text child node containing a URI as described in the WS-I Attachments Profile 1.0 for elements of schema type ref:swaRef(ref:swaRef). These two mechanisms must be supported. The support for references via href attribute also implies that this method should also be supported on an element that is an xop:Include element ( XOP). other reference mechanisms may be supported by individual implementations of this standard. Contact your vendor for details.

Parameters:
element - The SOAPElement containing the reference to an Attachment
Returns:
the referenced AttachmentPart or null if no such AttachmentPart exists or no reference can be found in this SOAPElement.
Throws:
SOAPException - if there is an error in the attempt to access the attachment
Since:
SAAJ 1.3

addAttachmentPart

public abstract void addAttachmentPart(AttachmentPart AttachmentPart)
Adds the given AttachmentPart object to this SOAPMessage object. An AttachmentPart object must be created before it can be added to a message.

Parameters:
AttachmentPart - an AttachmentPart object that is to become part of this SOAPMessage object
Throws:
IllegalArgumentException

createAttachmentPart

public abstract AttachmentPart createAttachmentPart()
Creates a new empty AttachmentPart object. Note that the method addAttachmentPart must be called with this new AttachmentPart object as the parameter in order for it to become an attachment to this SOAPMessage object.

Returns:
a new AttachmentPart object that can be populated and added to this SOAPMessage object

createAttachmentPart

public AttachmentPart createAttachmentPart(DataHandler dataHandler)
Creates an AttachmentPart object and populates it using the given DataHandler object.

Parameters:
dataHandler - the javax.activation.DataHandler object that will generate the content for this SOAPMessage object
Returns:
a new AttachmentPart object that contains data generated by the given DataHandler object
Throws:
IllegalArgumentException - if there was a problem with the specified DataHandler object
See Also:
DataHandler, DataContentHandler

getMimeHeaders

public abstract MimeHeaders getMimeHeaders()
Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.

Returns:
a MimeHeaders object containing the MimeHeader objects

createAttachmentPart

public AttachmentPart createAttachmentPart(Object content,
                                           String contentType)
Creates an AttachmentPart object and populates it with the specified data of the specified content type. The type of the Object should correspond to the value given for the Content-Type.

Parameters:
content - an Object containing the content for the AttachmentPart object to be created
contentType - a String object giving the type of content; examples are "text/xml", "text/plain", and "image/jpeg"
Returns:
a new AttachmentPart object that contains the given data
Throws:
IllegalArgumentException - may be thrown if the contentType does not match the type of the content object, or if there was no DataContentHandler object for the given content object
See Also:
DataHandler, DataContentHandler

saveChanges

public abstract void saveChanges()
                          throws SOAPException
Updates this SOAPMessage object with all the changes that have been made to it. This method is called automatically when writeTo(OutputStream) is called. However, if changes are made to a message that was received or to one that has already been sent, the method saveChanges needs to be called explicitly in order to save the changes. The method saveChanges also generates any changes that can be read back (for example, a MessageId in profiles that support a message id). All MIME headers in a message that is created for sending purposes are guaranteed to have valid values only after saveChanges has been called.

In addition, this method marks the point at which the data from all constituent AttachmentPart objects are pulled into the message.

Throws:
SOAPException - if there was a problem saving changes to this message.
SOAPException

saveRequired

public abstract boolean saveRequired()
Indicates whether this SOAPMessage object needs to have the method saveChanges called on it.

Returns:
true if saveChanges needs to be called; false otherwise.

writeTo

public abstract void writeTo(OutputStream out)
                      throws SOAPException,
                             IOException
Writes this SOAPMessage object to the given output stream. The externalization format is as defined by the SOAP 1.1 with Attachments specification.

If there are no attachments, just an XML stream is written out. For those messages that have attachments, writeTo writes a MIME-encoded byte stream.

Note that this method does not write the transport-specific MIME Headers of the Message

Parameters:
out - the OutputStream object to which this SOAPMessage object will be written
Throws:
IOException - if an I/O error occurs
SOAPException - if there was a problem in externalizing this SOAP message

setProperty

public void setProperty(String property,
                        Object value)
                 throws SOAPException
Associates the specified value with the specified property. If there was already a value associated with this property, the old value is replaced.

The valid property names include WRITE_XML_DECLARATION and CHARACTER_SET_ENCODING. All of these standard SAAJ properties are prefixed by "javax.xml.soap". Vendors may also add implementation specific properties. These properties must be prefixed with package names that are unique to the vendor.

Setting the property WRITE_XML_DECLARATION to "true" will cause an XML Declaration to be written out at the start of the SOAP message. The default value of "false" suppresses this declaration.

The property CHARACTER_SET_ENCODING defaults to the value "utf-8" which causes the SOAP message to be encoded using UTF-8. Setting CHARACTER_SET_ENCODING to "utf-16" causes the SOAP message to be encoded using UTF-16.

Some implementations may allow encodings in addition to UTF-8 and UTF-16. Refer to your vendor's documentation for details.

Parameters:
property - the property with which the specified value is to be associated.
value - the value to be associated with the specified property
Throws:
SOAPException - if the property name is not recognized.
Since:
SAAJ 1.2

getProperty

public Object getProperty(String property)
                   throws SOAPException
Retrieves value of the specified property.

Parameters:
property - the name of the property to retrieve
Returns:
the value associated with the named property or null if no such property exists.
Throws:
SOAPException - if the property name is not recognized.
Since:
SAAJ 1.2
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPPart

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Class SOAPPart

java.lang.Object
    extended by  javax.xml.soap.SOAPPart
All Implemented Interfaces:
Document, Node
public abstract class SOAPPart
extends Object
implements Document, Node

The container for the SOAP-specific portion of a SOAPMessage object. All messages are required to have a SOAP part, so when a SOAPMessage object is created, it will automatically have a SOAPPart object.

A SOAPPart object is a MIME part and has the MIME headers Content-Id, Content-Location, and Content-Type. Because the value of Content-Type must be "text/xml", a SOAPPart object automatically has a MIME header of Content-Type with its value set to "text/xml". The value must be "text/xml" because content in the SOAP part of a message must be in XML format. Content that is not of type "text/xml" must be in an AttachmentPart object rather than in the SOAPPart object.

When a message is sent, its SOAP part must have the MIME header Content-Type set to "text/xml". Or, from the other perspective, the SOAP part of any message that is received must have the MIME header Content-Type with a value of "text/xml".

A client can access the SOAPPart object of a SOAPMessage object by calling the method SOAPMessage.getSOAPPart. The following line of code, in which message is a SOAPMessage object, retrieves the SOAP part of a message.

   SOAPPart soapPart = message.getSOAPPart();

A SOAPPart object contains a SOAPEnvelope object, which in turn contains a SOAPBody object and a SOAPHeader object. The SOAPPart method getEnvelope can be used to retrieve the SOAPEnvelope object.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
SOAPPart()
Method Summary
abstract void | addMimeHeader(String name, String value) Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object.
abstract Iterator | getAllMimeHeaders() Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.
abstract Source | getContent() Returns the content of the SOAPEnvelope as a JAXP Source object.
String | getContentId() Retrieves the value of the MIME header whose name is "Content-Id".
String | getContentLocation() Retrieves the value of the MIME header whose name is "Content-Location".
abstract SOAPEnvelope | getEnvelope() Gets the SOAPEnvelope object associated with this SOAPPart object.
abstract Iterator | getMatchingMimeHeaders(String[] names) Retrieves all MimeHeader objects that match a name in the given array.
abstract String[] | getMimeHeader(String name) Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.
abstract Iterator | getNonMatchingMimeHeaders(String[] names) Retrieves all MimeHeader objects whose name does not match a name in the given array.
abstract void | removeAllMimeHeaders() Removes all the MimeHeader objects for this SOAPEnvelope object.
abstract void | removeMimeHeader(String header) Removes all MIME headers that match the given name.
abstract void | setContent(Source source) Sets the content of the SOAPEnvelope object with the data from the given Source object.
void | setContentId(String contentId) Sets the value of the MIME header named "Content-Id" to the given String.
void | setContentLocation(String contentLocation) Sets the value of the MIME header "Content-Location" to the given String.
abstract void | setMimeHeader(String name, String value) Changes the first header entry that matches the given header name so that its value is the given value, adding a new header with the given name and value if no existing header is a match.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.w3c.dom.Document
adoptNode, createAttribute, createAttributeNS, createCDATASection, createComment, createDocumentFragment, createElement, createElementNS, createEntityReference, createProcessingInstruction, createTextNode, getDoctype, getDocumentElement, getDocumentURI, getDomConfig, getElementById, getElementsByTagName, getElementsByTagNameNS, getImplementation, getInputEncoding, getStrictErrorChecking, getXmlEncoding, getXmlStandalone, getXmlVersion, importNode, normalizeDocument, renameNode, setDocumentURI, setStrictErrorChecking, setXmlStandalone, setXmlVersion
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Constructor Detail

SOAPPart

public SOAPPart()
Method Detail

getEnvelope

public abstract SOAPEnvelope getEnvelope()
                                  throws SOAPException
Gets the SOAPEnvelope object associated with this SOAPPart object. Once the SOAP envelope is obtained, it can be used to get its contents.

Returns:
the SOAPEnvelope object for this SOAPPart object
Throws:
SOAPException - if there is a SOAP error

getContentId

public String getContentId()
Retrieves the value of the MIME header whose name is "Content-Id".

Returns:
a String giving the value of the MIME header named "Content-Id"
See Also:
setContentId(java.lang.String)

getContentLocation

public String getContentLocation()
Retrieves the value of the MIME header whose name is "Content-Location".

Returns:
a String giving the value of the MIME header whose name is "Content-Location"
See Also:
setContentLocation(java.lang.String)

setContentId

public void setContentId(String contentId)
Sets the value of the MIME header named "Content-Id" to the given String.

Parameters:
contentId - a String giving the value of the MIME header "Content-Id"
Throws:
IllegalArgumentException - if there is a problem in setting the content id
See Also:
getContentId()

setContentLocation

public void setContentLocation(String contentLocation)
Sets the value of the MIME header "Content-Location" to the given String.

Parameters:
contentLocation - a String giving the value of the MIME header "Content-Location"
Throws:
IllegalArgumentException - if there is a problem in setting the content location.
See Also:
getContentLocation()

removeMimeHeader

public abstract void removeMimeHeader(String header)
Removes all MIME headers that match the given name.

Parameters:
header - a String giving the name of the MIME header(s) to be removed

removeAllMimeHeaders

public abstract void removeAllMimeHeaders()
Removes all the MimeHeader objects for this SOAPEnvelope object.

getMimeHeader

public abstract String[] getMimeHeader(String name)
Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.

Parameters:
name - the name of the header; example: "Content-Type"
Returns:
a String array giving all the values for the specified header
See Also:
setMimeHeader(java.lang.String, java.lang.String)

setMimeHeader

public abstract void setMimeHeader(String name,
                                   String value)
Changes the first header entry that matches the given header name so that its value is the given value, adding a new header with the given name and value if no existing header is a match. If there is a match, this method clears all existing values for the first header that matches and sets the given value instead. If more than one header has the given name, this method removes all of the matching headers after the first one.

Note that RFC822 headers can contain only US-ASCII characters.

Parameters:
name - a String giving the header name for which to search
value - a String giving the value to be set. This value will be substituted for the current value(s) of the first header that is a match if there is one. If there is no match, this value will be the value for a new MimeHeader object.
Throws:
IllegalArgumentException - if there was a problem with the specified mime header name or value
See Also:
getMimeHeader(java.lang.String)

addMimeHeader

public abstract void addMimeHeader(String name,
                                   String value)
Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object. If a MimeHeader with the specified name already exists, this method adds the specified value to the already existing value(s).

Note that RFC822 headers can contain only US-ASCII characters.

Parameters:
name - a String giving the header name
value - a String giving the value to be set or added
Throws:
IllegalArgumentException - if there was a problem with the specified mime header name or value

getAllMimeHeaders

public abstract Iterator getAllMimeHeaders()
Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.

Returns:
an Iterator object with all of the Mime headers for this SOAPPart object

getMatchingMimeHeaders

public abstract Iterator getMatchingMimeHeaders(String[] names)
Retrieves all MimeHeader objects that match a name in the given array.

Parameters:
names - a String array with the name(s) of the MIME headers to be returned
Returns:
all of the MIME headers that match one of the names in the given array, returned as an Iterator object

getNonMatchingMimeHeaders

public abstract Iterator getNonMatchingMimeHeaders(String[] names)
Retrieves all MimeHeader objects whose name does not match a name in the given array.

Parameters:
names - a String array with the name(s) of the MIME headers not to be returned
Returns:
all of the MIME headers in this SOAPPart object except those that match one of the names in the given array. The nonmatching MIME headers are returned as an Iterator object.

setContent

public abstract void setContent(Source source)
                         throws SOAPException
Sets the content of the SOAPEnvelope object with the data from the given Source object. This Source must contain a valid SOAP document.

Parameters:
source - the javax.xml.transform.Source object with the data to be set
Throws:
SOAPException - if there is a problem in setting the source
See Also:
getContent()

getContent

public abstract Source getContent()
                           throws SOAPException
Returns the content of the SOAPEnvelope as a JAXP Source object.

Returns:
the content as a javax.xml.transform.Source object
Throws:
SOAPException - if the implementation cannot convert the specified Source object
See Also:
setContent(javax.xml.transform.Source)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Text

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.soap
Interface Text

All Superinterfaces:
CharacterData, Node, Text
public interface Text
extends Node, Text

A representation of a node whose value is text. A Text object may represent text that is content or text that is a comment.

Method Summary
 boolean isComment()
Retrieves whether this Text object represents a comment.
Methods inherited from interface javax.xml.soap.Node
detachNode, getParentElement, getValue, recycleNode, setParentElement, setValue
Methods inherited from interface org.w3c.dom.Text
getWholeText, isElementContentWhitespace, replaceWholeText, splitText
Methods inherited from interface org.w3c.dom.CharacterData
appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

Method Detail

isComment

boolean isComment()
Retrieves whether this Text object represents a comment.

Returns:
true if this Text object is a comment; false otherwise
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


stream

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.stream

Interface Summary
EventFilter | This interface declares a simple filter interface that one can create to filter XMLEventReaders
Location | Provides information on the location of an event.
StreamFilter | This interface declares a simple filter interface that one can create to filter XMLStreamReaders
XMLEventReader | This is the top level interface for parsing XML Events.
XMLEventWriter | This is the top level interface for writing XML documents.
XMLReporter | This interface is used to report non-fatal errors.
XMLResolver | This interface is used to resolve resources during an XML parse.
XMLStreamConstants | This interface declares the constants used in this API.
XMLStreamReader | The XMLStreamReader interface allows forward, read-only access to XML.
XMLStreamWriter | The XMLStreamWriter interface specifies how to write XML.

Class Summary
XMLEventFactory | This interface defines a utility class for creating instances of XMLEvents
XMLInputFactory | Defines an abstract implementation of a factory for getting streams.
XMLOutputFactory | Defines an abstract implementation of a factory for getting XMLEventWriters and XMLStreamWriters.

Exception Summary
XMLStreamException The base exception for unexpected processing errors.

Error Summary
FactoryConfigurationError An error class for reporting factory configuration errors.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.stream Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.stream

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • javax.xml.stream.FactoryConfigurationError
      • java.lang.Exception
        • javax.xml.stream.XMLStreamException
    • javax.xml.stream.XMLEventFactory
    • javax.xml.stream.XMLInputFactory
    • javax.xml.stream.XMLOutputFactory

Interface Hierarchy

  • javax.xml.stream.EventFilter
  • java.util.Iterator<E>
    • javax.xml.stream.XMLEventReader
  • javax.xml.stream.Location
  • javax.xml.stream.StreamFilter
  • javax.xml.stream.util.XMLEventConsumer
    • javax.xml.stream.XMLEventWriter
  • javax.xml.stream.XMLReporter
  • javax.xml.stream.XMLResolver
  • javax.xml.stream.XMLStreamConstants
    • javax.xml.stream.XMLStreamReader
  • javax.xml.stream.XMLStreamWriter
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EventFilter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Interface EventFilter

public interface EventFilter

This interface declares a simple filter interface that one can create to filter XMLEventReaders

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Method Summary
 boolean accept(XMLEvent event)
Tests whether this event is part of this stream.

Method Detail

accept

boolean accept(XMLEvent event)
Tests whether this event is part of this stream. This method will return true if this filter accepts this event and false otherwise.

Parameters:
event - the event to test
Returns:
true if this filter accepts this event, false otherwise
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


events

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.stream.events

Interface Summary
Attribute | An interface that contains information about an attribute.
Characters | This describes the interface to Characters events.
Comment | An interface for comment events
DTD | This is the top level interface for events dealing with DTDs
EndDocument | A marker interface for the end of the document
EndElement | An interface for the end element event.
EntityDeclaration | An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
EntityReference | An interface for handling Entity events.
Namespace | An interface that contains information about a namespace.
NotationDeclaration | An interface for handling Notation Declarations Receive notification of a notation declaration event.
ProcessingInstruction | An interface that describes the data found in processing instructions
StartDocument | An interface for the start document event
StartElement | The StartElement interface provides access to information about start elements.
XMLEvent | This is the base event interface for handling markup events.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EndDocument

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface EndDocument

All Superinterfaces:
XMLEvent, XMLStreamConstants
public interface EndDocument
extends XMLEvent

A marker interface for the end of the document

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
Methods inherited from interface javax.xml.stream.events.XMLEvent
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.stream.events Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.stream.events

Package Hierarchies:
All Packages

Interface Hierarchy

  • javax.xml.stream.XMLStreamConstants
    • javax.xml.stream.events.XMLEvent
      • javax.xml.stream.events.Attribute
        • javax.xml.stream.events.Namespace
      • javax.xml.stream.events.Characters
      • javax.xml.stream.events.Comment
      • javax.xml.stream.events.DTD
      • javax.xml.stream.events.EndDocument
      • javax.xml.stream.events.EndElement
      • javax.xml.stream.events.EntityDeclaration
      • javax.xml.stream.events.EntityReference
      • javax.xml.stream.events.NotationDeclaration
      • javax.xml.stream.events.ProcessingInstruction
      • javax.xml.stream.events.StartDocument
      • javax.xml.stream.events.StartElement
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Attribute

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface Attribute

All Superinterfaces:
XMLEvent, XMLStreamConstants
All Known Subinterfaces:
Namespace
public interface Attribute
extends XMLEvent

An interface that contains information about an attribute. Attributes are reported as a set of events accessible from a StartElement. Other applications may report Attributes as first-order events, for example as the results of an XPath expression.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
StartElement

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
String | getDTDType() Gets the type of this attribute, default is the String "CDATA"
QName | getName() Returns the QName for this attribute
String | getValue() Gets the normalized value of this attribute
boolean | isSpecified() A flag indicating whether this attribute was actually specified in the start-tag of its element, or was defaulted from the schema.
Methods inherited from interface javax.xml.stream.events.XMLEvent
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

Method Detail

getName

QName getName()
Returns the QName for this attribute

getValue

String getValue()
Gets the normalized value of this attribute

getDTDType

String getDTDType()
Gets the type of this attribute, default is the String "CDATA"

Returns:
the type as a String, default is "CDATA"

isSpecified

boolean isSpecified()
A flag indicating whether this attribute was actually specified in the start-tag of its element, or was defaulted from the schema.

Returns:
returns true if this was specified in the start element
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Characters

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface Characters

All Superinterfaces:
XMLEvent, XMLStreamConstants
public interface Characters
extends XMLEvent

This describes the interface to Characters events. All text events get reported as Characters events. Content, CData and whitespace are all reported as Characters events. IgnorableWhitespace, in most cases, will be set to false unless an element declaration of element content is present for the current element.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
String | getData() Get the character data of this event
boolean | isCData() Returns true if this is a CData section.
boolean | isIgnorableWhiteSpace() Return true if this is ignorableWhiteSpace.
boolean | isWhiteSpace() Returns true if this set of Characters is all whitespace.
Methods inherited from interface javax.xml.stream.events.XMLEvent
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

Method Detail

getData

String getData()
Get the character data of this event

isWhiteSpace

boolean isWhiteSpace()
Returns true if this set of Characters is all whitespace. Whitespace inside a document is reported as CHARACTERS. This method allows checking of CHARACTERS events to see if they are composed of only whitespace characters

isCData

boolean isCData()
Returns true if this is a CData section. If this event is CData its event type will be CDATA If javax.xml.stream.isCoalescing is set to true CDATA Sections that are surrounded by non CDATA characters will be reported as a single Characters event. This method will return false in this case.

isIgnorableWhiteSpace

boolean isIgnorableWhiteSpace()
Return true if this is ignorableWhiteSpace. If this event is ignorableWhiteSpace its event type will be SPACE.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Comment

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface Comment

All Superinterfaces:
XMLEvent, XMLStreamConstants
public interface Comment
extends XMLEvent

An interface for comment events

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
 String getText()
Return the string data of the comment, returns empty string if it does not exist
Methods inherited from interface javax.xml.stream.events.XMLEvent
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

Method Detail

getText

String getText()
Return the string data of the comment, returns empty string if it does not exist

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


DTD

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface DTD

All Superinterfaces:
XMLEvent, XMLStreamConstants
public interface DTD
extends XMLEvent

This is the top level interface for events dealing with DTDs

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
String | getDocumentTypeDeclaration() Returns the entire Document Type Declaration as a string, including the internal DTD subset.
List | getEntities() Return a List containing the general entities, both external and internal, declared in the DTD.
List | getNotations() Return a List containing the notations declared in the DTD.
Object | getProcessedDTD() Returns an implementation defined representation of the DTD.
Methods inherited from interface javax.xml.stream.events.XMLEvent
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

Method Detail

getDocumentTypeDeclaration

String getDocumentTypeDeclaration()
Returns the entire Document Type Declaration as a string, including the internal DTD subset. This may be null if there is not an internal subset. If it is not null it must return the entire Document Type Declaration which matches the doctypedecl production in the XML 1.0 specification

getProcessedDTD

Object getProcessedDTD()
Returns an implementation defined representation of the DTD. This method may return null if no representation is available.

getNotations

List getNotations()
Return a List containing the notations declared in the DTD. This list must contain NotationDeclaration events.

Returns:
an unordered list of NotationDeclaration events
See Also:
NotationDeclaration

getEntities

List getEntities()
Return a List containing the general entities, both external and internal, declared in the DTD. This list must contain EntityDeclaration events.

Returns:
an unordered list of EntityDeclaration events
See Also:
EntityDeclaration
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EndElement

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface EndElement

All Superinterfaces:
XMLEvent, XMLStreamConstants
public interface EndElement
extends XMLEvent

An interface for the end element event. An EndElement is reported for each End Tag in the document.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
XMLEvent

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
QName | getName() Get the name of this event
Iterator | getNamespaces() Returns an Iterator of namespaces that have gone out of scope.
Methods inherited from interface javax.xml.stream.events.XMLEvent
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

Method Detail

getName

QName getName()
Get the name of this event

Returns:
the qualified name of this event

getNamespaces

Iterator getNamespaces()
Returns an Iterator of namespaces that have gone out of scope. Returns an empty iterator if no namespaces have gone out of scope.

Returns:
an Iterator over Namespace interfaces, or an empty iterator
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EntityDeclaration

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface EntityDeclaration

All Superinterfaces:
XMLEvent, XMLStreamConstants
public interface EntityDeclaration
extends XMLEvent

An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
String | getBaseURI() Get the base URI for this reference or null if this information is not available
String | getName() The entity's name
String | getNotationName() The name of the associated notation.
String | getPublicId() The entity's public identifier, or null if none was given
String | getReplacementText() The replacement text of the entity.
String | getSystemId() The entity's system identifier.
Methods inherited from interface javax.xml.stream.events.XMLEvent
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

Method Detail

getPublicId

String getPublicId()
The entity's public identifier, or null if none was given

Returns:
the public ID for this declaration or null

getSystemId

String getSystemId()
The entity's system identifier.

Returns:
the system ID for this declaration or null

getName

String getName()
The entity's name

Returns:
the name, may not be null

getNotationName

String getNotationName()
The name of the associated notation.

Returns:
the notation name

getReplacementText

String getReplacementText()
The replacement text of the entity. This method will only return non-null if this is an internal entity.

Returns:
null or the replacment text

getBaseURI

String getBaseURI()
Get the base URI for this reference or null if this information is not available

Returns:
the base URI or null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EntityReference

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface EntityReference

All Superinterfaces:
XMLEvent, XMLStreamConstants
public interface EntityReference
extends XMLEvent

An interface for handling Entity events. This event reports entities that have not been resolved and reports their replacement text unprocessed (if available). This event will be reported if javax.xml.stream.isReplacingEntityReferences is set to false. If javax.xml.stream.isReplacingEntityReferences is set to true entity references will be resolved transparently. Entities are handled in two possible ways: (1) If javax.xml.stream.isReplacingEntityReferences is set to true all entity references are resolved and reported as markup transparently. (2) If javax.xml.stream.isReplacingEntityReferences is set to false Entity references are reported as an EntityReference Event.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
EntityDeclaration | getDeclaration() Return the declaration of this entity.
String | getName() The name of the entity
Methods inherited from interface javax.xml.stream.events.XMLEvent
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

Method Detail

getDeclaration

EntityDeclaration getDeclaration()
Return the declaration of this entity.

getName

String getName()
The name of the entity

Returns:
the entity's name, may not be null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Namespace

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface Namespace

All Superinterfaces:
Attribute, XMLEvent, XMLStreamConstants
public interface Namespace
extends Attribute

An interface that contains information about a namespace. Namespaces are accessed from a StartElement.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
StartElement

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
String | getNamespaceURI() Gets the uri bound to the prefix of this namespace
String | getPrefix() Gets the prefix, returns "" if this is a default namespace declaration.
boolean | isDefaultNamespaceDeclaration() returns true if this attribute declares the default namespace
Methods inherited from interface javax.xml.stream.events.Attribute
getDTDType, getName, getValue, isSpecified
Methods inherited from interface javax.xml.stream.events.XMLEvent
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

Method Detail

getPrefix

String getPrefix()
Gets the prefix, returns "" if this is a default namespace declaration.

getNamespaceURI

String getNamespaceURI()
Gets the uri bound to the prefix of this namespace

isDefaultNamespaceDeclaration

boolean isDefaultNamespaceDeclaration()
returns true if this attribute declares the default namespace

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


NotationDeclaration

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface NotationDeclaration

All Superinterfaces:
XMLEvent, XMLStreamConstants
public interface NotationDeclaration
extends XMLEvent

An interface for handling Notation Declarations Receive notification of a notation declaration event. It is up to the application to record the notation for later reference, At least one of publicId and systemId must be non-null. There is no guarantee that the notation declaration will be reported before any unparsed entities that use it.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
String | getName() The notation name.
String | getPublicId() The notation's public identifier, or null if none was given.
String | getSystemId() The notation's system identifier, or null if none was given.
Methods inherited from interface javax.xml.stream.events.XMLEvent
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

Method Detail

getName

String getName()
The notation name.

getPublicId

String getPublicId()
The notation's public identifier, or null if none was given.

getSystemId

String getSystemId()
The notation's system identifier, or null if none was given.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ProcessingInstruction

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface ProcessingInstruction

All Superinterfaces:
XMLEvent, XMLStreamConstants
public interface ProcessingInstruction
extends XMLEvent

An interface that describes the data found in processing instructions

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
String | getData() The data section of the processing instruction
String | getTarget() The target section of the processing instruction
Methods inherited from interface javax.xml.stream.events.XMLEvent
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

Method Detail

getTarget

String getTarget()
The target section of the processing instruction

Returns:
the String value of the PI or null

getData

String getData()
The data section of the processing instruction

Returns:
the String value of the PI's data or null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StartDocument

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface StartDocument

All Superinterfaces:
XMLEvent, XMLStreamConstants
public interface StartDocument
extends XMLEvent

An interface for the start document event

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
boolean | encodingSet() Returns true if CharacterEncodingScheme was set in the encoding declaration of the document
String | getCharacterEncodingScheme() Returns the encoding style of the XML data
String | getSystemId() Returns the system ID of the XML data
String | getVersion() Returns the version of XML of this XML stream
boolean | isStandalone() Returns if this XML is standalone
boolean | standaloneSet() Returns true if the standalone attribute was set in the encoding declaration of the document.
Methods inherited from interface javax.xml.stream.events.XMLEvent
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

Method Detail

getSystemId

String getSystemId()
Returns the system ID of the XML data

Returns:
the system ID, defaults to ""

getCharacterEncodingScheme

String getCharacterEncodingScheme()
Returns the encoding style of the XML data

Returns:
the character encoding, defaults to "UTF-8"

encodingSet

boolean encodingSet()
Returns true if CharacterEncodingScheme was set in the encoding declaration of the document

isStandalone

boolean isStandalone()
Returns if this XML is standalone

Returns:
the standalone state of XML, defaults to "no"

standaloneSet

boolean standaloneSet()
Returns true if the standalone attribute was set in the encoding declaration of the document.

getVersion

String getVersion()
Returns the version of XML of this XML stream

Returns:
the version of XML, defaults to "1.0"
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StartElement

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface StartElement

All Superinterfaces:
XMLEvent, XMLStreamConstants
public interface StartElement
extends XMLEvent

The StartElement interface provides access to information about start elements. A StartElement is reported for each Start Tag in the document.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
Attribute | getAttributeByName(QName name) Returns the attribute referred to by this name
Iterator | getAttributes() Returns an Iterator of non-namespace declared attributes declared on this START_ELEMENT, returns an empty iterator if there are no attributes.
QName | getName() Get the name of this event
NamespaceContext | getNamespaceContext() Gets a read-only namespace context.
Iterator | getNamespaces() Returns an Iterator of namespaces declared on this element.
String | getNamespaceURI(String prefix) Gets the value that the prefix is bound to in the context of this element.
Methods inherited from interface javax.xml.stream.events.XMLEvent
asCharacters, asEndElement, asStartElement, getEventType, getLocation, getSchemaType, isAttribute, isCharacters, isEndDocument, isEndElement, isEntityReference, isNamespace, isProcessingInstruction, isStartDocument, isStartElement, writeAsEncodedUnicode

Method Detail

getName

QName getName()
Get the name of this event

Returns:
the qualified name of this event

getAttributes

Iterator getAttributes()
Returns an Iterator of non-namespace declared attributes declared on this START_ELEMENT, returns an empty iterator if there are no attributes. The iterator must contain only implementations of the javax.xml.stream.Attribute interface. Attributes are fundamentally unordered and may not be reported in any order.

Returns:
a readonly Iterator over Attribute interfaces, or an empty iterator

getNamespaces

Iterator getNamespaces()
Returns an Iterator of namespaces declared on this element. This Iterator does not contain previously declared namespaces unless they appear on the current START_ELEMENT. Therefore this list may contain redeclared namespaces and duplicate namespace declarations. Use the getNamespaceContext() method to get the current context of namespace declarations.

The iterator must contain only implementations of the javax.xml.stream.Namespace interface.

A Namespace isA Attribute. One can iterate over a list of namespaces as a list of attributes. However this method returns only the list of namespaces declared on this START_ELEMENT and does not include the attributes declared on this START_ELEMENT. Returns an empty iterator if there are no namespaces.

Returns:
a readonly Iterator over Namespace interfaces, or an empty iterator

getAttributeByName

Attribute getAttributeByName(QName name)
Returns the attribute referred to by this name

Parameters:
name - the qname of the desired name
Returns:
the attribute corresponding to the name value or null

getNamespaceContext

NamespaceContext getNamespaceContext()
Gets a read-only namespace context. If no context is available this method will return an empty namespace context. The NamespaceContext contains information about all namespaces in scope for this StartElement.

Returns:
the current namespace context

getNamespaceURI

String getNamespaceURI(String prefix)
Gets the value that the prefix is bound to in the context of this element. Returns null if the prefix is not bound in this context

Parameters:
prefix - the prefix to lookup
Returns:
the uri bound to the prefix or null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLEvent

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.events
Interface XMLEvent

All Superinterfaces:
XMLStreamConstants
All Known Subinterfaces:
Attribute, Characters, Comment, DTD, EndDocument, EndElement, EntityDeclaration, EntityReference, Namespace, NotationDeclaration, ProcessingInstruction, StartDocument, StartElement
public interface XMLEvent
extends XMLStreamConstants

This is the base event interface for handling markup events. Events are value objects that are used to communicate the XML 1.0 InfoSet to the Application. Events may be cached and referenced after the parse has completed.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
XMLEventReader, Characters, ProcessingInstruction, StartElement, EndElement, StartDocument, EndDocument, EntityReference, EntityDeclaration, NotationDeclaration

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
Characters | asCharacters() Returns this event as Characters, may result in a class cast exception if this event is not Characters.
EndElement | asEndElement() Returns this event as an end element event, may result in a class cast exception if this event is not a end element.
StartElement | asStartElement() Returns this event as a start element event, may result in a class cast exception if this event is not a start element.
int | getEventType() Returns an integer code for this event.
Location | getLocation() Return the location of this event.
QName | getSchemaType() This method is provided for implementations to provide optional type information about the associated event.
boolean | isAttribute() A utility function to check if this event is an Attribute.
boolean | isCharacters() A utility function to check if this event is Characters.
boolean | isEndDocument() A utility function to check if this event is an EndDocument.
boolean | isEndElement() A utility function to check if this event is a EndElement.
boolean | isEntityReference() A utility function to check if this event is an EntityReference.
boolean | isNamespace() A utility function to check if this event is a Namespace.
boolean | isProcessingInstruction() A utility function to check if this event is a ProcessingInstruction.
boolean | isStartDocument() A utility function to check if this event is a StartDocument.
boolean | isStartElement() A utility function to check if this event is a StartElement.
void | writeAsEncodedUnicode(Writer writer) This method will write the XMLEvent as per the XML 1.0 specification as Unicode characters.

Method Detail

getEventType

int getEventType()
Returns an integer code for this event.

See Also:
XMLStreamConstants.START_ELEMENT, XMLStreamConstants.END_ELEMENT, XMLStreamConstants.CHARACTERS, XMLStreamConstants.ATTRIBUTE, XMLStreamConstants.NAMESPACE, XMLStreamConstants.PROCESSING_INSTRUCTION, XMLStreamConstants.COMMENT, XMLStreamConstants.START_DOCUMENT, XMLStreamConstants.END_DOCUMENT, XMLStreamConstants.DTD

getLocation

Location getLocation()
Return the location of this event. The Location returned from this method is non-volatile and will retain its information.

See Also:
Location

isStartElement

boolean isStartElement()
A utility function to check if this event is a StartElement.

See Also:
StartElement

isAttribute

boolean isAttribute()
A utility function to check if this event is an Attribute.

See Also:
Attribute

isNamespace

boolean isNamespace()
A utility function to check if this event is a Namespace.

See Also:
Namespace

isEndElement

boolean isEndElement()
A utility function to check if this event is a EndElement.

See Also:
EndElement

isEntityReference

boolean isEntityReference()
A utility function to check if this event is an EntityReference.

See Also:
EntityReference

isProcessingInstruction

boolean isProcessingInstruction()
A utility function to check if this event is a ProcessingInstruction.

See Also:
ProcessingInstruction

isCharacters

boolean isCharacters()
A utility function to check if this event is Characters.

See Also:
Characters

isStartDocument

boolean isStartDocument()
A utility function to check if this event is a StartDocument.

See Also:
StartDocument

isEndDocument

boolean isEndDocument()
A utility function to check if this event is an EndDocument.

See Also:
EndDocument

asStartElement

StartElement asStartElement()
Returns this event as a start element event, may result in a class cast exception if this event is not a start element.

asEndElement

EndElement asEndElement()
Returns this event as an end element event, may result in a class cast exception if this event is not a end element.

asCharacters

Characters asCharacters()
Returns this event as Characters, may result in a class cast exception if this event is not Characters.

getSchemaType

QName getSchemaType()
This method is provided for implementations to provide optional type information about the associated event. It is optional and will return null if no information is available.

writeAsEncodedUnicode

void writeAsEncodedUnicode(Writer writer)
                           throws XMLStreamException
This method will write the XMLEvent as per the XML 1.0 specification as Unicode characters. No indentation or whitespace should be outputted. Any user defined event type SHALL have this method called when being written to on an output stream. Built in Event types MUST implement this method, but implementations MAY choose not call these methods for optimizations reasons when writing out built in Events to an output stream. The output generated MUST be equivalent in terms of the infoset expressed.

Parameters:
writer - The writer that will output the data
Throws:
XMLStreamException - if there is a fatal error writing the event
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


FactoryConfigurationError

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Class FactoryConfigurationError

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Error
            extended by  javax.xml.stream.FactoryConfigurationError
All Implemented Interfaces:
Serializable
public class FactoryConfigurationError
extends Error

An error class for reporting factory configuration errors.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
Serialized Form

Constructor Summary
FactoryConfigurationError()
Default constructor
FactoryConfigurationError(Exception e)
Construct an exception with a nested inner exception
FactoryConfigurationError(Exception e, String msg)
Construct an exception with a nested inner exception and a message
FactoryConfigurationError(String msg)
Construct an exception with associated message
FactoryConfigurationError(String msg, Exception e)
Construct an exception with a nested inner exception and a message
Method Summary
Exception | getException() Return the nested exception (if any)
String | getMessage() Report the message associated with this error
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FactoryConfigurationError

public FactoryConfigurationError()
Default constructor

FactoryConfigurationError

public FactoryConfigurationError(Exception e)
Construct an exception with a nested inner exception

Parameters:
e - the exception to nest

FactoryConfigurationError

public FactoryConfigurationError(Exception e,
                                 String msg)
Construct an exception with a nested inner exception and a message

Parameters:
e - the exception to nest
msg - the message to report

FactoryConfigurationError

public FactoryConfigurationError(String msg,
                                 Exception e)
Construct an exception with a nested inner exception and a message

Parameters:
msg - the message to report
e - the exception to nest

FactoryConfigurationError

public FactoryConfigurationError(String msg)
Construct an exception with associated message

Parameters:
e - the exception to nest
msg - the message to report
Method Detail

getException

public Exception getException()
Return the nested exception (if any)

Returns:
the nested exception or null

getMessage

public String getMessage()
Report the message associated with this error

Overrides:
getMessage in class Throwable
Returns:
the string value of the message
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Location

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Interface Location

public interface Location

Provides information on the location of an event. All the information provided by a Location is optional. For example an application may only report line numbers.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Method Summary
int | getCharacterOffset() Return the byte or character offset into the input source this location is pointing to.
int | getColumnNumber() Return the column number where the current event ends, returns -1 if none is available.
int | getLineNumber() Return the line number where the current event ends, returns -1 if none is available.
String | getPublicId() Returns the public ID of the XML
String | getSystemId() Returns the system ID of the XML

Method Detail

getLineNumber

int getLineNumber()
Return the line number where the current event ends, returns -1 if none is available.

Returns:
the current line number

getColumnNumber

int getColumnNumber()
Return the column number where the current event ends, returns -1 if none is available.

Returns:
the current column number

getCharacterOffset

int getCharacterOffset()
Return the byte or character offset into the input source this location is pointing to. If the input source is a file or a byte stream then this is the byte offset into that stream, but if the input source is a character media then the offset is the character offset. Returns -1 if there is no offset available.

Returns:
the current offset

getPublicId

String getPublicId()
Returns the public ID of the XML

Returns:
the public ID, or null if not available

getSystemId

String getSystemId()
Returns the system ID of the XML

Returns:
the system ID, or null if not available
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StreamFilter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Interface StreamFilter

public interface StreamFilter

This interface declares a simple filter interface that one can create to filter XMLStreamReaders

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Method Summary
 boolean accept(XMLStreamReader reader)
Tests whether the current state is part of this stream.

Method Detail

accept

boolean accept(XMLStreamReader reader)
Tests whether the current state is part of this stream. This method will return true if this filter accepts this event and false otherwise. The method should not change the state of the reader when accepting a state.

Parameters:
reader - the event to test
Returns:
true if this filter accepts this event, false otherwise
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


util

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.stream.util

Interface Summary
XMLEventAllocator | This interface defines a class that allows a user to register a way to allocate events given an XMLStreamReader.
XMLEventConsumer | This interface defines an event consumer interface.

Class Summary
EventReaderDelegate | This is the base class for deriving an XMLEventReader filter.
StreamReaderDelegate | This is the base class for deriving an XMLStreamReader filter This class is designed to sit between an XMLStreamReader and an application's XMLStreamReader.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.stream.util Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.stream.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.stream.util.EventReaderDelegate (implements javax.xml.stream.XMLEventReader)
    • javax.xml.stream.util.StreamReaderDelegate (implements javax.xml.stream.XMLStreamReader)

Interface Hierarchy

  • javax.xml.stream.util.XMLEventAllocator
  • javax.xml.stream.util.XMLEventConsumer
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


EventReaderDelegate

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.util
Class EventReaderDelegate

java.lang.Object
    extended by  javax.xml.stream.util.EventReaderDelegate
All Implemented Interfaces:
Iterator, XMLEventReader
public class EventReaderDelegate
extends Object
implements XMLEventReader

This is the base class for deriving an XMLEventReader filter. This class is designed to sit between an XMLEventReader and an application's XMLEventReader. By default each method does nothing but call the corresponding method on the parent interface.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
XMLEventReader, StreamReaderDelegate

Constructor Summary
EventReaderDelegate()
Construct an empty filter with no parent.
EventReaderDelegate(XMLEventReader reader)
Construct an filter with the specified parent.
Method Summary
void | close() Frees any resources associated with this Reader.
String | getElementText() Reads the content of a text-only element.
XMLEventReader | getParent() Get the parent of this instance.
Object | getProperty(String name) Get the value of a feature/property from the underlying implementation
boolean | hasNext() Check if there are more events.
Object | next()
XMLEvent | nextEvent() Get the next XMLEvent
XMLEvent | nextTag() Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached.
XMLEvent | peek() Check the next XMLEvent without reading it from the stream.
void | remove()
void | setParent(XMLEventReader reader) Set the parent of this instance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EventReaderDelegate

public EventReaderDelegate()
Construct an empty filter with no parent.

EventReaderDelegate

public EventReaderDelegate(XMLEventReader reader)
Construct an filter with the specified parent.

Parameters:
reader - the parent
Method Detail

setParent

public void setParent(XMLEventReader reader)
Set the parent of this instance.

Parameters:
reader - the new parent

getParent

public XMLEventReader getParent()
Get the parent of this instance.

Returns:
the parent or null if none is set

nextEvent

public XMLEvent nextEvent()
                   throws XMLStreamException
Description copied from interface: XMLEventReader
Get the next XMLEvent

Specified by:
nextEvent in interface XMLEventReader
Throws:
XMLStreamException - if there is an error with the underlying XML.
See Also:
XMLEvent

next

public Object next()
Specified by:
next in interface Iterator

hasNext

public boolean hasNext()
Description copied from interface: XMLEventReader
Check if there are more events. Returns true if there are more events and false otherwise.

Specified by:
hasNext in interface Iterator
Specified by:
hasNext in interface XMLEventReader
Returns:
true if the event reader has more events, false otherwise

peek

public XMLEvent peek()
              throws XMLStreamException
Description copied from interface: XMLEventReader
Check the next XMLEvent without reading it from the stream. Returns null if the stream is at EOF or has no more XMLEvents. A call to peek() will be equal to the next return of next().

Specified by:
peek in interface XMLEventReader
Throws:
XMLStreamException
See Also:
XMLEvent

close

public void close()
           throws XMLStreamException
Description copied from interface: XMLEventReader
Frees any resources associated with this Reader. This method does not close the underlying input source.

Specified by:
close in interface XMLEventReader
Throws:
XMLStreamException - if there are errors freeing associated resources

getElementText

public String getElementText()
                      throws XMLStreamException
Description copied from interface: XMLEventReader
Reads the content of a text-only element. Precondition: the current event is START_ELEMENT. Postcondition: The current event is the corresponding END_ELEMENT.

Specified by:
getElementText in interface XMLEventReader
Throws:
XMLStreamException - if the current event is not a START_ELEMENT or if a non text element is encountered

nextTag

public XMLEvent nextTag()
                 throws XMLStreamException
Description copied from interface: XMLEventReader
Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached. If anything other than space characters are encountered, an exception is thrown. This method should be used when processing element-only content because the parser is not able to recognize ignorable whitespace if the DTD is missing or not interpreted.

Specified by:
nextTag in interface XMLEventReader
Throws:
XMLStreamException - if anything other than space characters are encountered

getProperty

public Object getProperty(String name)
                   throws IllegalArgumentException
Description copied from interface: XMLEventReader
Get the value of a feature/property from the underlying implementation

Specified by:
getProperty in interface XMLEventReader
Parameters:
name - The name of the property
Returns:
The value of the property
Throws:
IllegalArgumentException - if the property is not supported

remove

public void remove()
Specified by:
remove in interface Iterator
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


StreamReaderDelegate

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.util
Class StreamReaderDelegate

java.lang.Object
    extended by  javax.xml.stream.util.StreamReaderDelegate
All Implemented Interfaces:
XMLStreamConstants, XMLStreamReader
public class StreamReaderDelegate
extends Object
implements XMLStreamReader

This is the base class for deriving an XMLStreamReader filter This class is designed to sit between an XMLStreamReader and an application's XMLStreamReader. By default each method does nothing but call the corresponding method on the parent interface.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
XMLStreamReader, EventReaderDelegate

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Constructor Summary
StreamReaderDelegate()
Construct an empty filter with no parent.
StreamReaderDelegate(XMLStreamReader reader)
Construct an filter with the specified parent.
Method Summary
 void close()
Frees any resources associated with this Reader.
 int getAttributeCount()
Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE.
 String getAttributeLocalName(int index)
Returns the localName of the attribute at the provided index
 QName getAttributeName(int index)
Returns the qname of the attribute at the provided index
 String getAttributeNamespace(int index)
Returns the namespace of the attribute at the provided index
 String getAttributePrefix(int index)
Returns the prefix of this attribute at the provided index
 String getAttributeType(int index)
Returns the XML type of the attribute at the provided index
 String getAttributeValue(int index)
Returns the value of the attribute at the index
 String getAttributeValue(String namespaceUri, String localName)
Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality
 String getCharacterEncodingScheme()
Returns the character encoding declared on the xml declaration Returns null if none was declared
 String getElementText()
Reads the content of a text-only element, an exception is thrown if this is not a text-only element.
 String getEncoding()
Return input encoding if known or null if unknown.
 int getEventType()
Returns an integer code that indicates the type of the event the cursor is pointing to.
 String getLocalName()
Returns the (local) name of the current event.
 Location getLocation()
Return the current location of the processor.
 QName getName()
Returns a QName for the current START_ELEMENT or END_ELEMENT event
 NamespaceContext getNamespaceContext()
Returns a read only namespace context for the current position.
 int getNamespaceCount()
Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE.
 String getNamespacePrefix(int index)
Returns the prefix for the namespace declared at the index.
 String getNamespaceURI()
If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace.
 String getNamespaceURI(int index)
Returns the uri for the namespace declared at the index.
 String getNamespaceURI(String prefix)
Return the uri for the given prefix.
 XMLStreamReader getParent()
Get the parent of this instance.
 String getPIData()
Get the data section of a processing instruction
 String getPITarget()
Get the target of a processing instruction
 String getPrefix()
Returns the prefix of the current event or null if the event does not have a prefix
 Object getProperty(String name)
Get the value of a feature/property from the underlying implementation
 String getText()
Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD.
 char[] getTextCharacters()
Returns an array which contains the characters from this event.
 int getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
Gets the the text associated with a CHARACTERS, SPACE or CDATA event.
 int getTextLength()
Returns the length of the sequence of characters for this Text event within the text character array.
 int getTextStart()
Returns the offset into the text character array where the first character (of this text event) is stored.
 String getVersion()
Get the xml version declared on the xml declaration Returns null if none was declared
 boolean hasName()
returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise
 boolean hasNext()
Returns true if there are more parsing events and false if there are no more events.
 boolean hasText()
Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE
 boolean isAttributeSpecified(int index)
Returns a boolean which indicates if this attribute was created by default
 boolean isCharacters()
Returns true if the cursor points to a character data event
 boolean isEndElement()
Returns true if the cursor points to an end tag (otherwise false)
 boolean isStandalone()
Get the standalone declaration from the xml declaration
 boolean isStartElement()
Returns true if the cursor points to a start tag (otherwise false)
 boolean isWhiteSpace()
Returns true if the cursor points to a character data event that consists of all whitespace
 int next()
Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks.
 int nextTag()
Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached.
 void require(int type, String namespaceURI, String localName)
Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event.
 void setParent(XMLStreamReader reader)
Set the parent of this instance.
 boolean standaloneSet()
Checks if standalone was set in the document
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StreamReaderDelegate

public StreamReaderDelegate()
Construct an empty filter with no parent.

StreamReaderDelegate

public StreamReaderDelegate(XMLStreamReader reader)
Construct an filter with the specified parent.

Parameters:
reader - the parent
Method Detail

setParent

public void setParent(XMLStreamReader reader)
Set the parent of this instance.

Parameters:
reader - the new parent

getParent

public XMLStreamReader getParent()
Get the parent of this instance.

Returns:
the parent or null if none is set

next

public int next()
         throws XMLStreamException
Description copied from interface: XMLStreamReader
Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks. If the property javax.xml.stream.isCoalescing is set to true element content must be coalesced and only one CHARACTERS event must be returned for contiguous element content or CDATA Sections. By default entity references must be expanded and reported transparently to the application. An exception will be thrown if an entity reference cannot be expanded. If element content is empty (i.e. content is "") then no CHARACTERS event will be reported.

Given the following XML:
<foo><!--description-->content text<![CDATA[<greeting>Hello</greeting>]]>other content</foo>
The behavior of calling next() when being on foo will be:
1- the comment (COMMENT)
2- then the characters section (CHARACTERS)
3- then the CDATA section (another CHARACTERS)
4- then the next characters section (another CHARACTERS)
5- then the END_ELEMENT

NOTE: empty element (such as <tag/>) will be reported with two separate events: START_ELEMENT, END_ELEMENT - This preserves parsing equivalency of empty element to <tag></tag>. This method will throw an IllegalStateException if it is called after hasNext() returns false.

Specified by:
next in interface XMLStreamReader
Returns:
the integer code corresponding to the current parse event
Throws:
XMLStreamException - if there is an error processing the underlying XML source
See Also:
XMLEvent

nextTag

public int nextTag()
            throws XMLStreamException
Description copied from interface: XMLStreamReader
Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached. If other than white space characters, COMMENT, PROCESSING_INSTRUCTION, START_ELEMENT, END_ELEMENT are encountered, an exception is thrown. This method should be used when processing element-only content seperated by white space.
Precondition: none
Postcondition: the current event is START_ELEMENT or END_ELEMENT and cursor may have moved over any whitespace event.
Essentially it does the following (implementations are free to optimized but must do equivalent processing):
 int eventType = next();
 while((eventType == XMLStreamConstants.CHARACTERS && isWhiteSpace()) // skip whitespace
 || (eventType == XMLStreamConstants.CDATA && isWhiteSpace())
 // skip whitespace
 || eventType == XMLStreamConstants.SPACE
 || eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
 || eventType == XMLStreamConstants.COMMENT
 ) {
 eventType = next();
 }
 if (eventType != XMLStreamConstants.START_ELEMENT && eventType != XMLStreamConstants.END_ELEMENT) {
 throw new String XMLStreamException("expected start or end tag", getLocation());
 }
 return eventType;

Specified by:
nextTag in interface XMLStreamReader
Returns:
the event type of the element read (START_ELEMENT or END_ELEMENT)
Throws:
XMLStreamException - if the current event is not white space, PROCESSING_INSTRUCTION, START_ELEMENT or END_ELEMENT

getElementText

public String getElementText()
                      throws XMLStreamException
Description copied from interface: XMLStreamReader
Reads the content of a text-only element, an exception is thrown if this is not a text-only element. Regardless of value of javax.xml.stream.isCoalescing this method always returns coalesced content.
Precondition: the current event is START_ELEMENT.
Postcondition: the current event is the corresponding END_ELEMENT.
The method does the following (implementations are free to optimized but must do equivalent processing):
 if(getEventType() != XMLStreamConstants.START_ELEMENT) {
 throw new XMLStreamException(
 "parser must be on START_ELEMENT to read next text", getLocation());
 }
 int eventType = next();
 StringBuffer content = new StringBuffer();
 while(eventType != XMLStreamConstants.END_ELEMENT ) {
 if(eventType == XMLStreamConstants.CHARACTERS
 || eventType == XMLStreamConstants.CDATA
 || eventType == XMLStreamConstants.SPACE
 || eventType == XMLStreamConstants.ENTITY_REFERENCE) {
 buf.append(getText());
 } else if(eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
 || eventType == XMLStreamConstants.COMMENT) {
 // skipping
 } else if(eventType == XMLStreamConstants.END_DOCUMENT) {
 throw new XMLStreamException(
 "unexpected end of document when reading element text content", this);
 } else if(eventType == XMLStreamConstants.START_ELEMENT) {
 throw new XMLStreamException(
 "element text content may not contain START_ELEMENT", getLocation());
 } else {
 throw new XMLStreamException(
 "Unexpected event type "+eventType, getLocation());
 }
 eventType = next();
 }
 return buf.toString();

Specified by:
getElementText in interface XMLStreamReader
Throws:
XMLStreamException - if the current event is not a START_ELEMENT or if a non text element is encountered

require

public void require(int type,
                    String namespaceURI,
                    String localName)
             throws XMLStreamException
Description copied from interface: XMLStreamReader
Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event. If the namespaceURI is null it is not checked for equality, if the localName is null it is not checked for equality.

Specified by:
require in interface XMLStreamReader
Parameters:
type - the event type
namespaceURI - the uri of the event, may be null
localName - the localName of the event, may be null
Throws:
XMLStreamException - if the required values are not matched.

hasNext

public boolean hasNext()
                throws XMLStreamException
Description copied from interface: XMLStreamReader
Returns true if there are more parsing events and false if there are no more events. This method will return false if the current state of the XMLStreamReader is END_DOCUMENT

Specified by:
hasNext in interface XMLStreamReader
Returns:
true if there are more events, false otherwise
Throws:
XMLStreamException - if there is a fatal error detecting the next state

close

public void close()
           throws XMLStreamException
Description copied from interface: XMLStreamReader
Frees any resources associated with this Reader. This method does not close the underlying input source.

Specified by:
close in interface XMLStreamReader
Throws:
XMLStreamException - if there are errors freeing associated resources

getNamespaceURI

public String getNamespaceURI(String prefix)
Description copied from interface: XMLStreamReader
Return the uri for the given prefix. The uri returned depends on the current state of the processor.

NOTE:The 'xml' prefix is bound as defined in Namespaces in XML specification to "http://www.w3.org/XML/1998/namespace".

NOTE: The 'xmlns' prefix must be resolved to following namespace http://www.w3.org/2000/xmlns/

Specified by:
getNamespaceURI in interface XMLStreamReader
Parameters:
prefix - The prefix to lookup, may not be null
Returns:
the uri bound to the given prefix or null if it is not bound

getNamespaceContext

public NamespaceContext getNamespaceContext()
Description copied from interface: XMLStreamReader
Returns a read only namespace context for the current position. The context is transient and only valid until a call to next() changes the state of the reader.

Specified by:
getNamespaceContext in interface XMLStreamReader
Returns:
return a namespace context

isStartElement

public boolean isStartElement()
Description copied from interface: XMLStreamReader
Returns true if the cursor points to a start tag (otherwise false)

Specified by:
isStartElement in interface XMLStreamReader
Returns:
true if the cursor points to a start tag, false otherwise

isEndElement

public boolean isEndElement()
Description copied from interface: XMLStreamReader
Returns true if the cursor points to an end tag (otherwise false)

Specified by:
isEndElement in interface XMLStreamReader
Returns:
true if the cursor points to an end tag, false otherwise

isCharacters

public boolean isCharacters()
Description copied from interface: XMLStreamReader
Returns true if the cursor points to a character data event

Specified by:
isCharacters in interface XMLStreamReader
Returns:
true if the cursor points to character data, false otherwise

isWhiteSpace

public boolean isWhiteSpace()
Description copied from interface: XMLStreamReader
Returns true if the cursor points to a character data event that consists of all whitespace

Specified by:
isWhiteSpace in interface XMLStreamReader
Returns:
true if the cursor points to all whitespace, false otherwise

getAttributeValue

public String getAttributeValue(String namespaceUri,
                                String localName)
Description copied from interface: XMLStreamReader
Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality

Specified by:
getAttributeValue in interface XMLStreamReader
Parameters:
namespaceUri - the namespace of the attribute
localName - the local name of the attribute, cannot be null
Returns:
returns the value of the attribute , returns null if not found

getAttributeCount

public int getAttributeCount()
Description copied from interface: XMLStreamReader
Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE. This count excludes namespace definitions. Attribute indices are zero-based.

Specified by:
getAttributeCount in interface XMLStreamReader
Returns:
returns the number of attributes

getAttributeName

public QName getAttributeName(int index)
Description copied from interface: XMLStreamReader
Returns the qname of the attribute at the provided index

Specified by:
getAttributeName in interface XMLStreamReader
Parameters:
index - the position of the attribute
Returns:
the QName of the attribute

getAttributePrefix

public String getAttributePrefix(int index)
Description copied from interface: XMLStreamReader
Returns the prefix of this attribute at the provided index

Specified by:
getAttributePrefix in interface XMLStreamReader
Parameters:
index - the position of the attribute
Returns:
the prefix of the attribute

getAttributeNamespace

public String getAttributeNamespace(int index)
Description copied from interface: XMLStreamReader
Returns the namespace of the attribute at the provided index

Specified by:
getAttributeNamespace in interface XMLStreamReader
Parameters:
index - the position of the attribute
Returns:
the namespace URI (can be null)

getAttributeLocalName

public String getAttributeLocalName(int index)
Description copied from interface: XMLStreamReader
Returns the localName of the attribute at the provided index

Specified by:
getAttributeLocalName in interface XMLStreamReader
Parameters:
index - the position of the attribute
Returns:
the localName of the attribute

getAttributeType

public String getAttributeType(int index)
Description copied from interface: XMLStreamReader
Returns the XML type of the attribute at the provided index

Specified by:
getAttributeType in interface XMLStreamReader
Parameters:
index - the position of the attribute
Returns:
the XML type of the attribute

getAttributeValue

public String getAttributeValue(int index)
Description copied from interface: XMLStreamReader
Returns the value of the attribute at the index

Specified by:
getAttributeValue in interface XMLStreamReader
Parameters:
index - the position of the attribute
Returns:
the attribute value

isAttributeSpecified

public boolean isAttributeSpecified(int index)
Description copied from interface: XMLStreamReader
Returns a boolean which indicates if this attribute was created by default

Specified by:
isAttributeSpecified in interface XMLStreamReader
Parameters:
index - the position of the attribute
Returns:
true if this is a default attribute

getNamespaceCount

public int getNamespaceCount()
Description copied from interface: XMLStreamReader
Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE. On an END_ELEMENT the count is of the namespaces that are about to go out of scope. This is the equivalent of the information reported by SAX callback for an end element event.

Specified by:
getNamespaceCount in interface XMLStreamReader
Returns:
returns the number of namespace declarations on this specific element

getNamespacePrefix

public String getNamespacePrefix(int index)
Description copied from interface: XMLStreamReader
Returns the prefix for the namespace declared at the index. Returns null if this is the default namespace declaration

Specified by:
getNamespacePrefix in interface XMLStreamReader
Parameters:
index - the position of the namespace declaration
Returns:
returns the namespace prefix

getNamespaceURI

public String getNamespaceURI(int index)
Description copied from interface: XMLStreamReader
Returns the uri for the namespace declared at the index.

Specified by:
getNamespaceURI in interface XMLStreamReader
Parameters:
index - the position of the namespace declaration
Returns:
returns the namespace uri

getEventType

public int getEventType()
Description copied from interface: XMLStreamReader
Returns an integer code that indicates the type of the event the cursor is pointing to.

Specified by:
getEventType in interface XMLStreamReader

getText

public String getText()
Description copied from interface: XMLStreamReader
Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD. If an ENTITY_REFERENCE has been resolved, any character data will be reported as CHARACTERS events.

Specified by:
getText in interface XMLStreamReader
Returns:
the current text or null

getTextCharacters

public int getTextCharacters(int sourceStart,
                             char[] target,
                             int targetStart,
                             int length)
                      throws XMLStreamException
Description copied from interface: XMLStreamReader
Gets the the text associated with a CHARACTERS, SPACE or CDATA event. Text starting a "sourceStart" is copied into "target" starting at "targetStart". Up to "length" characters are copied. The number of characters actually copied is returned. The "sourceStart" argument must be greater or equal to 0 and less than or equal to the number of characters associated with the event. Usually, one requests text starting at a "sourceStart" of 0. If the number of characters actually copied is less than the "length", then there is no more text. Otherwise, subsequent calls need to be made until all text has been retrieved. For example:
int length = 1024;
char[] myBuffer = new char[ length ];

for ( int sourceStart = 0 ; ; sourceStart += length )
{
   int nCopied = stream.getTextCharacters( sourceStart, myBuffer, 0, length );

  if (nCopied < length)
      break;
}
 XMLStreamException may be thrown if there are any XML errors in the underlying source. The "targetStart" argument must be greater than or equal to 0 and less than the length of "target", Length must be greater than 0 and "targetStart + length" must be less than or equal to length of "target".

Specified by:
getTextCharacters in interface XMLStreamReader
Parameters:
sourceStart - the index of the first character in the source array to copy
target - the destination array
targetStart - the start offset in the target array
length - the number of characters to copy
Returns:
the number of characters actually copied
Throws:
XMLStreamException - if the underlying XML source is not well-formed

getTextCharacters

public char[] getTextCharacters()
Description copied from interface: XMLStreamReader
Returns an array which contains the characters from this event. This array should be treated as read-only and transient. I.e. the array will contain the text characters until the XMLStreamReader moves on to the next event. Attempts to hold onto the character array beyond that time or modify the contents of the array are breaches of the contract for this interface.

Specified by:
getTextCharacters in interface XMLStreamReader
Returns:
the current text or an empty array

getTextStart

public int getTextStart()
Description copied from interface: XMLStreamReader
Returns the offset into the text character array where the first character (of this text event) is stored.

Specified by:
getTextStart in interface XMLStreamReader

getTextLength

public int getTextLength()
Description copied from interface: XMLStreamReader
Returns the length of the sequence of characters for this Text event within the text character array.

Specified by:
getTextLength in interface XMLStreamReader

getEncoding

public String getEncoding()
Description copied from interface: XMLStreamReader
Return input encoding if known or null if unknown.

Specified by:
getEncoding in interface XMLStreamReader
Returns:
the encoding of this instance or null

hasText

public boolean hasText()
Description copied from interface: XMLStreamReader
Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE

Specified by:
hasText in interface XMLStreamReader

getLocation

public Location getLocation()
Description copied from interface: XMLStreamReader
Return the current location of the processor. If the Location is unknown the processor should return an implementation of Location that returns -1 for the location and null for the publicId and systemId. The location information is only valid until next() is called.

Specified by:
getLocation in interface XMLStreamReader

getName

public QName getName()
Description copied from interface: XMLStreamReader
Returns a QName for the current START_ELEMENT or END_ELEMENT event

Specified by:
getName in interface XMLStreamReader
Returns:
the QName for the current START_ELEMENT or END_ELEMENT event

getLocalName

public String getLocalName()
Description copied from interface: XMLStreamReader
Returns the (local) name of the current event. For START_ELEMENT or END_ELEMENT returns the (local) name of the current element. For ENTITY_REFERENCE it returns entity name. The current event must be START_ELEMENT or END_ELEMENT, or ENTITY_REFERENCE

Specified by:
getLocalName in interface XMLStreamReader
Returns:
the localName

hasName

public boolean hasName()
Description copied from interface: XMLStreamReader
returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise

Specified by:
hasName in interface XMLStreamReader

getNamespaceURI

public String getNamespaceURI()
Description copied from interface: XMLStreamReader
If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace. Returns null if the event does not have a prefix.

Specified by:
getNamespaceURI in interface XMLStreamReader
Returns:
the URI bound to this elements prefix, the default namespace, or null

getPrefix

public String getPrefix()
Description copied from interface: XMLStreamReader
Returns the prefix of the current event or null if the event does not have a prefix

Specified by:
getPrefix in interface XMLStreamReader
Returns:
the prefix or null

getVersion

public String getVersion()
Description copied from interface: XMLStreamReader
Get the xml version declared on the xml declaration Returns null if none was declared

Specified by:
getVersion in interface XMLStreamReader
Returns:
the XML version or null

isStandalone

public boolean isStandalone()
Description copied from interface: XMLStreamReader
Get the standalone declaration from the xml declaration

Specified by:
isStandalone in interface XMLStreamReader
Returns:
true if this is standalone, or false otherwise

standaloneSet

public boolean standaloneSet()
Description copied from interface: XMLStreamReader
Checks if standalone was set in the document

Specified by:
standaloneSet in interface XMLStreamReader
Returns:
true if standalone was set in the document, or false otherwise

getCharacterEncodingScheme

public String getCharacterEncodingScheme()
Description copied from interface: XMLStreamReader
Returns the character encoding declared on the xml declaration Returns null if none was declared

Specified by:
getCharacterEncodingScheme in interface XMLStreamReader
Returns:
the encoding declared in the document or null

getPITarget

public String getPITarget()
Description copied from interface: XMLStreamReader
Get the target of a processing instruction

Specified by:
getPITarget in interface XMLStreamReader
Returns:
the target or null

getPIData

public String getPIData()
Description copied from interface: XMLStreamReader
Get the data section of a processing instruction

Specified by:
getPIData in interface XMLStreamReader
Returns:
the data or null

getProperty

public Object getProperty(String name)
Description copied from interface: XMLStreamReader
Get the value of a feature/property from the underlying implementation

Specified by:
getProperty in interface XMLStreamReader
Parameters:
name - The name of the property, may not be null
Returns:
The value of the property
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLEventAllocator

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.util
Interface XMLEventAllocator

public interface XMLEventAllocator

This interface defines a class that allows a user to register a way to allocate events given an XMLStreamReader. An implementation is not required to use the XMLEventFactory implementation but this is recommended. The XMLEventAllocator can be set on an XMLInputFactory using the property "javax.xml.stream.allocator"

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
XMLInputFactory, XMLEventFactory

Method Summary
XMLEvent | allocate(XMLStreamReader reader) This method allocates an event given the current state of the XMLStreamReader.
void | allocate(XMLStreamReader reader, XMLEventConsumer consumer) This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in.
XMLEventAllocator | newInstance() This method creates an instance of the XMLEventAllocator.

Method Detail

newInstance

XMLEventAllocator newInstance()
This method creates an instance of the XMLEventAllocator. This allows the XMLInputFactory to allocate a new instance per reader.

allocate

XMLEvent allocate(XMLStreamReader reader)
                  throws XMLStreamException
This method allocates an event given the current state of the XMLStreamReader. If this XMLEventAllocator does not have a one-to-one mapping between reader states and events this method will return null. This method must not modify the state of the XMLStreamReader.

Parameters:
reader - The XMLStreamReader to allocate from
Returns:
the event corresponding to the current reader state
Throws:
XMLStreamException

allocate

void allocate(XMLStreamReader reader,
              XMLEventConsumer consumer)
              throws XMLStreamException
This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in. This method can be used to expand or contract reader states into event states. This method may modify the state of the XMLStreamReader.

Parameters:
reader - The XMLStreamReader to allocate from
consumer - The XMLEventConsumer to add to.
Throws:
XMLStreamException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLEventConsumer

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream.util
Interface XMLEventConsumer

All Known Subinterfaces:
XMLEventWriter
public interface XMLEventConsumer

This interface defines an event consumer interface. The contract of the of a consumer is to accept the event. This interface can be used to mark an object as able to receive events. Add may be called several times in immediate succession so a consumer must be able to cache events it hasn't processed yet.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Method Summary
 void add(XMLEvent event)
This method adds an event to the consumer.

Method Detail

add

void add(XMLEvent event)
         throws XMLStreamException
This method adds an event to the consumer. Calling this method invalidates the event parameter. The client application should discard all references to this event upon calling add. The behavior of an application that continues to use such references is undefined.

Parameters:
event - the event to add, may not be null
Throws:
XMLStreamException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLEventFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Class XMLEventFactory

java.lang.Object
    extended by  javax.xml.stream.XMLEventFactory

public abstract class XMLEventFactory
extends Object

This interface defines a utility class for creating instances of XMLEvents

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
StartElement, EndElement, ProcessingInstruction, Comment, Characters, StartDocument, EndDocument, DTD

Constructor Summary
protected XMLEventFactory()
Method Summary
abstract Attribute | createAttribute(QName name, String value) Create a new Attribute
abstract Attribute | createAttribute(String localName, String value) Create a new Attribute
abstract Attribute | createAttribute(String prefix, String namespaceURI, String localName, String value) Create a new Attribute
abstract Characters | createCData(String content) Create a Characters event with the CData flag set to true
abstract Characters | createCharacters(String content) Create a Characters event, this method does not check if the content is all whitespace.
abstract Comment | createComment(String text) Create a comment
abstract DTD | createDTD(String dtd) Create a document type definition event This string contains the entire document type declaration that matches the doctypedecl in the XML 1.0 specification
abstract EndDocument | createEndDocument() Creates a new instance of an EndDocument event
abstract EndElement | createEndElement(QName name, Iterator namespaces) Create a new EndElement
abstract EndElement | createEndElement(String prefix, String namespaceUri, String localName) Create a new EndElement
abstract EndElement | createEndElement(String prefix, String namespaceUri, String localName, Iterator namespaces) Create a new EndElement
abstract EntityReference | createEntityReference(String name, EntityDeclaration declaration) Creates a new instance of a EntityReference event
abstract Characters | createIgnorableSpace(String content) Create an ignorable space
abstract Namespace | createNamespace(String namespaceURI) Create a new default Namespace
abstract Namespace | createNamespace(String prefix, String namespaceUri) Create a new Namespace
abstract ProcessingInstruction | createProcessingInstruction(String target, String data) Create a processing instruction
abstract Characters | createSpace(String content) Create a Characters event with the isSpace flag set to true
abstract StartDocument | createStartDocument() Creates a new instance of a StartDocument event
abstract StartDocument | createStartDocument(String encoding) Creates a new instance of a StartDocument event
abstract StartDocument | createStartDocument(String encoding, String version) Creates a new instance of a StartDocument event
abstract StartDocument | createStartDocument(String encoding, String version, boolean standalone) Creates a new instance of a StartDocument event
abstract StartElement | createStartElement(QName name, Iterator attributes, Iterator namespaces) Create a new StartElement.
abstract StartElement | createStartElement(String prefix, String namespaceUri, String localName) Create a new StartElement.
abstract StartElement | createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces) Create a new StartElement.
abstract StartElement | createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context) Create a new StartElement.
static XMLEventFactory | newInstance() Create a new instance of the factory
static XMLEventFactory | newInstance(String factoryId, ClassLoader classLoader) Create a new instance of the factory
abstract void | setLocation(Location location) This method allows setting of the Location on each event that is created by this factory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XMLEventFactory

protected XMLEventFactory()
Method Detail

newInstance

public static XMLEventFactory newInstance()
                                   throws FactoryConfigurationError
Create a new instance of the factory

Throws:
FactoryConfigurationError - if an instance of this factory cannot be loaded

newInstance

public static XMLEventFactory newInstance(String factoryId,
                                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
Create a new instance of the factory

Parameters:
factoryId - Name of the factory to find, same as a property name
classLoader - classLoader to use
Returns:
the factory implementation
Throws:
FactoryConfigurationError - if an instance of this factory cannot be loaded

setLocation

public abstract void setLocation(Location location)
This method allows setting of the Location on each event that is created by this factory. The values are copied by value into the events created by this factory. To reset the location information set the location to null.

Parameters:
location - the location to set on each event created

createAttribute

public abstract Attribute createAttribute(String prefix,
                                          String namespaceURI,
                                          String localName,
                                          String value)
Create a new Attribute

Parameters:
prefix - the prefix of this attribute, may not be null
namespaceURI - the attribute value is set to this value, may not be null
localName - the local name of the XML name of the attribute, localName cannot be null
value - the attribute value to set, may not be null
Returns:
the Attribute with specified values

createAttribute

public abstract Attribute createAttribute(String localName,
                                          String value)
Create a new Attribute

Parameters:
localName - the local name of the XML name of the attribute, localName cannot be null
value - the attribute value to set, may not be null
Returns:
the Attribute with specified values

createAttribute

public abstract Attribute createAttribute(QName name,
                                          String value)
Create a new Attribute

Parameters:
name - the qualified name of the attribute, may not be null
value - the attribute value to set, may not be null
Returns:
the Attribute with specified values

createNamespace

public abstract Namespace createNamespace(String namespaceURI)
Create a new default Namespace

Parameters:
namespaceURI - the default namespace uri
Returns:
the Namespace with the specified value

createNamespace

public abstract Namespace createNamespace(String prefix,
                                          String namespaceUri)
Create a new Namespace

Parameters:
prefix - the prefix of this namespace, may not be null
namespaceUri - the attribute value is set to this value, may not be null
Returns:
the Namespace with the specified values

createStartElement

public abstract StartElement createStartElement(QName name,
                                                Iterator attributes,
                                                Iterator namespaces)
Create a new StartElement. Namespaces can be added to this StartElement by passing in an Iterator that walks over a set of Namespace interfaces. Attributes can be added to this StartElement by passing an iterator that walks over a set of Attribute interfaces.

Parameters:
name - the qualified name of the attribute, may not be null
attributes - an optional unordered set of objects that implement Attribute to add to the new StartElement, may be null
namespaces - an optional unordered set of objects that implement Namespace to add to the new StartElement, may be null
Returns:
an instance of the requested StartElement

createStartElement

public abstract StartElement createStartElement(String prefix,
                                                String namespaceUri,
                                                String localName)
Create a new StartElement. This defaults the NamespaceContext to an empty NamespaceContext. Querying this event for its namespaces or attributes will result in an empty iterator being returned.

Parameters:
namespaceUri - the uri of the QName of the new StartElement
localName - the local name of the QName of the new StartElement
prefix - the prefix of the QName of the new StartElement
Returns:
an instance of the requested StartElement

createStartElement

public abstract StartElement createStartElement(String prefix,
                                                String namespaceUri,
                                                String localName,
                                                Iterator attributes,
                                                Iterator namespaces)
Create a new StartElement. Namespaces can be added to this StartElement by passing in an Iterator that walks over a set of Namespace interfaces. Attributes can be added to this StartElement by passing an iterator that walks over a set of Attribute interfaces.

Parameters:
namespaceUri - the uri of the QName of the new StartElement
localName - the local name of the QName of the new StartElement
prefix - the prefix of the QName of the new StartElement
attributes - an unordered set of objects that implement Attribute to add to the new StartElement
namespaces - an unordered set of objects that implement Namespace to add to the new StartElement
Returns:
an instance of the requested StartElement

createStartElement

public abstract StartElement createStartElement(String prefix,
                                                String namespaceUri,
                                                String localName,
                                                Iterator attributes,
                                                Iterator namespaces,
                                                NamespaceContext context)
Create a new StartElement. Namespaces can be added to this StartElement by passing in an Iterator that walks over a set of Namespace interfaces. Attributes can be added to this StartElement by passing an iterator that walks over a set of Attribute interfaces.

Parameters:
namespaceUri - the uri of the QName of the new StartElement
localName - the local name of the QName of the new StartElement
prefix - the prefix of the QName of the new StartElement
attributes - an unordered set of objects that implement Attribute to add to the new StartElement, may be null
namespaces - an unordered set of objects that implement Namespace to add to the new StartElement, may be null
context - the namespace context of this element
Returns:
an instance of the requested StartElement

createEndElement

public abstract EndElement createEndElement(QName name,
                                            Iterator namespaces)
Create a new EndElement

Parameters:
name - the qualified name of the EndElement
namespaces - an optional unordered set of objects that implement Namespace that have gone out of scope, may be null
Returns:
an instance of the requested EndElement

createEndElement

public abstract EndElement createEndElement(String prefix,
                                            String namespaceUri,
                                            String localName)
Create a new EndElement

Parameters:
namespaceUri - the uri of the QName of the new StartElement
localName - the local name of the QName of the new StartElement
prefix - the prefix of the QName of the new StartElement
Returns:
an instance of the requested EndElement

createEndElement

public abstract EndElement createEndElement(String prefix,
                                            String namespaceUri,
                                            String localName,
                                            Iterator namespaces)
Create a new EndElement

Parameters:
namespaceUri - the uri of the QName of the new StartElement
localName - the local name of the QName of the new StartElement
prefix - the prefix of the QName of the new StartElement
namespaces - an unordered set of objects that implement Namespace that have gone out of scope, may be null
Returns:
an instance of the requested EndElement

createCharacters

public abstract Characters createCharacters(String content)
Create a Characters event, this method does not check if the content is all whitespace. To create a space event use #createSpace(String)

Parameters:
content - the string to create
Returns:
a Characters event

createCData

public abstract Characters createCData(String content)
Create a Characters event with the CData flag set to true

Parameters:
content - the string to create
Returns:
a Characters event

createSpace

public abstract Characters createSpace(String content)
Create a Characters event with the isSpace flag set to true

Parameters:
content - the content of the space to create
Returns:
a Characters event

createIgnorableSpace

public abstract Characters createIgnorableSpace(String content)
Create an ignorable space

Parameters:
content - the space to create
Returns:
a Characters event

createStartDocument

public abstract StartDocument createStartDocument()
Creates a new instance of a StartDocument event

Returns:
a StartDocument event

createStartDocument

public abstract StartDocument createStartDocument(String encoding,
                                                  String version,
                                                  boolean standalone)
Creates a new instance of a StartDocument event

Parameters:
encoding - the encoding style
version - the XML version
standalone - the status of standalone may be set to "true" or "false"
Returns:
a StartDocument event

createStartDocument

public abstract StartDocument createStartDocument(String encoding,
                                                  String version)
Creates a new instance of a StartDocument event

Parameters:
encoding - the encoding style
version - the XML version
Returns:
a StartDocument event

createStartDocument

public abstract StartDocument createStartDocument(String encoding)
Creates a new instance of a StartDocument event

Parameters:
encoding - the encoding style
Returns:
a StartDocument event

createEndDocument

public abstract EndDocument createEndDocument()
Creates a new instance of an EndDocument event

Returns:
an EndDocument event

createEntityReference

public abstract EntityReference createEntityReference(String name,
                                                      EntityDeclaration declaration)
Creates a new instance of a EntityReference event

Parameters:
name - The name of the reference
declaration - the declaration for the event
Returns:
an EntityReference event

createComment

public abstract Comment createComment(String text)
Create a comment

Parameters:
text - The text of the comment a Comment event

createProcessingInstruction

public abstract ProcessingInstruction createProcessingInstruction(String target,
                                                                  String data)
Create a processing instruction

Parameters:
target - The target of the processing instruction
data - The text of the processing instruction
Returns:
a ProcessingInstruction event

createDTD

public abstract DTD createDTD(String dtd)
Create a document type definition event This string contains the entire document type declaration that matches the doctypedecl in the XML 1.0 specification

Parameters:
dtd - the text of the document type definition
Returns:
a DTD event
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLEventReader

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Interface XMLEventReader

All Superinterfaces:
Iterator
All Known Implementing Classes:
EventReaderDelegate
public interface XMLEventReader
extends Iterator

This is the top level interface for parsing XML Events. It provides the ability to peek at the next event and returns configuration information through the property interface.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
XMLInputFactory, XMLEventWriter

Method Summary
void | close() Frees any resources associated with this Reader.
String | getElementText() Reads the content of a text-only element.
Object | getProperty(String name) Get the value of a feature/property from the underlying implementation
boolean | hasNext() Check if there are more events.
XMLEvent | nextEvent() Get the next XMLEvent
XMLEvent | nextTag() Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached.
XMLEvent | peek() Check the next XMLEvent without reading it from the stream.
Methods inherited from interface java.util.Iterator
next, remove

Method Detail

nextEvent

XMLEvent nextEvent()
                   throws XMLStreamException
Get the next XMLEvent

Throws:
XMLStreamException - if there is an error with the underlying XML.
NoSuchElementException - iteration has no more elements.
See Also:
XMLEvent

hasNext

boolean hasNext()
Check if there are more events. Returns true if there are more events and false otherwise.

Specified by:
hasNext in interface Iterator
Returns:
true if the event reader has more events, false otherwise

peek

XMLEvent peek()
              throws XMLStreamException
Check the next XMLEvent without reading it from the stream. Returns null if the stream is at EOF or has no more XMLEvents. A call to peek() will be equal to the next return of next().

Throws:
XMLStreamException
See Also:
XMLEvent

getElementText

String getElementText()
                      throws XMLStreamException
Reads the content of a text-only element. Precondition: the current event is START_ELEMENT. Postcondition: The current event is the corresponding END_ELEMENT.

Throws:
XMLStreamException - if the current event is not a START_ELEMENT or if a non text element is encountered

nextTag

XMLEvent nextTag()
                 throws XMLStreamException
Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached. If anything other than space characters are encountered, an exception is thrown. This method should be used when processing element-only content because the parser is not able to recognize ignorable whitespace if the DTD is missing or not interpreted.

Throws:
XMLStreamException - if anything other than space characters are encountered

getProperty

Object getProperty(String name)
                   throws IllegalArgumentException
Get the value of a feature/property from the underlying implementation

Parameters:
name - The name of the property
Returns:
The value of the property
Throws:
IllegalArgumentException - if the property is not supported

close

void close()
           throws XMLStreamException
Frees any resources associated with this Reader. This method does not close the underlying input source.

Throws:
XMLStreamException - if there are errors freeing associated resources
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLEventWriter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Interface XMLEventWriter

All Superinterfaces:
XMLEventConsumer
public interface XMLEventWriter
extends XMLEventConsumer

This is the top level interface for writing XML documents. Instances of this interface are not required to validate the form of the XML.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
XMLEventReader, XMLEvent, Characters, ProcessingInstruction, StartElement, EndElement

Method Summary
void | add(XMLEvent event) Add an event to the output stream Adding a START_ELEMENT will open a new namespace scope that will be closed when the corresponding END_ELEMENT is written.
void | add(XMLEventReader reader) Adds an entire stream to an output stream, calls next() on the inputStream argument until hasNext() returns false This should be treated as a convenience method that will perform the following loop over all the events in an event reader and call add on each event.
void | close() Frees any resources associated with this stream
void | flush() Writes any cached events to the underlying output mechanism
NamespaceContext | getNamespaceContext() Returns the current namespace context.
String | getPrefix(String uri) Gets the prefix the uri is bound to
void | setDefaultNamespace(String uri) Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair.
void | setNamespaceContext(NamespaceContext context) Sets the current namespace context for prefix and uri bindings.
void | setPrefix(String prefix, String uri) Sets the prefix the uri is bound to.

Method Detail

flush

void flush()
           throws XMLStreamException
Writes any cached events to the underlying output mechanism

Throws:
XMLStreamException

close

void close()
           throws XMLStreamException
Frees any resources associated with this stream

Throws:
XMLStreamException

add

void add(XMLEvent event)
         throws XMLStreamException
Add an event to the output stream Adding a START_ELEMENT will open a new namespace scope that will be closed when the corresponding END_ELEMENT is written.
Required and optional fields for events added to the writer
Event Type | Required Fields | Optional Fields | Required Behavior
START_ELEMENT | QName name | namespaces , attributes | A START_ELEMENT will be written by writing the name, namespaces, and attributes of the event in XML 1.0 valid syntax for START_ELEMENTs. The name is written by looking up the prefix for the namespace uri. The writer can be configured to respect prefixes of QNames. If the writer is respecting prefixes it must use the prefix set on the QName. The default behavior is to lookup the value for the prefix on the EventWriter's internal namespace context. Each attribute (if any) is written using the behavior specified in the attribute section of this table. Each namespace (if any) is written using the behavior specified in the namespace section of this table.
END_ELEMENT | Qname name | None | A well formed END_ELEMENT tag is written. The name is written by looking up the prefix for the namespace uri. The writer can be configured to respect prefixes of QNames. If the writer is respecting prefixes it must use the prefix set on the QName. The default behavior is to lookup the value for the prefix on the EventWriter's internal namespace context. If the END_ELEMENT name does not match the START_ELEMENT name an XMLStreamException is thrown.
ATTRIBUTE | QName name , String value | QName type | An attribute is written using the same algorithm to find the lexical form as used in START_ELEMENT. The default is to use double quotes to wrap attribute values and to escape any double quotes found in the value. The type value is ignored.
NAMESPACE | String prefix, String namespaceURI, boolean isDefaultNamespaceDeclaration | None | A namespace declaration is written. If the namespace is a default namespace declaration (isDefault is true) then xmlns="$namespaceURI" is written and the prefix is optional. If isDefault is false, the prefix must be declared and the writer must prepend xmlns to the prefix and write out a standard prefix declaration.
PROCESSING_INSTRUCTION | None | String target, String data | The data does not need to be present and may be null. Target is required and many not be null. The writer will write data section directly after the target, enclosed in appropriate XML 1.0 syntax
COMMENT | None | String comment | If the comment is present (not null) it is written, otherwise an an empty comment is written
START_DOCUMENT | None | String encoding , boolean standalone, String version | A START_DOCUMENT event is not required to be written to the stream. If present the attributes are written inside the appropriate XML declaration syntax
END_DOCUMENT | None | None | Nothing is written to the output
DTD | String DocumentTypeDefinition | None | The DocumentTypeDefinition is written to the output

Specified by:
add in interface XMLEventConsumer
Parameters:
event - the event to be added
Throws:
XMLStreamException

add

void add(XMLEventReader reader)
         throws XMLStreamException
Adds an entire stream to an output stream, calls next() on the inputStream argument until hasNext() returns false This should be treated as a convenience method that will perform the following loop over all the events in an event reader and call add on each event.

Parameters:
reader - the event stream to add to the output
Throws:
XMLStreamException

getPrefix

String getPrefix(String uri)
                 throws XMLStreamException
Gets the prefix the uri is bound to

Parameters:
uri - the uri to look up
Throws:
XMLStreamException

setPrefix

void setPrefix(String prefix,
               String uri)
               throws XMLStreamException
Sets the prefix the uri is bound to. This prefix is bound in the scope of the current START_ELEMENT / END_ELEMENT pair. If this method is called before a START_ELEMENT has been written the prefix is bound in the root scope.

Parameters:
prefix - the prefix to bind to the uri
uri - the uri to bind to the prefix
Throws:
XMLStreamException

setDefaultNamespace

void setDefaultNamespace(String uri)
                         throws XMLStreamException
Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair. If this method is called before a START_ELEMENT has been written the uri is bound in the root scope.

Parameters:
uri - the uri to bind to the default namespace
Throws:
XMLStreamException

setNamespaceContext

void setNamespaceContext(NamespaceContext context)
                         throws XMLStreamException
Sets the current namespace context for prefix and uri bindings. This context becomes the root namespace context for writing and will replace the current root namespace context. Subsequent calls to setPrefix and setDefaultNamespace will bind namespaces using the context passed to the method as the root context for resolving namespaces.

Parameters:
context - the namespace context to use for this writer
Throws:
XMLStreamException

getNamespaceContext

NamespaceContext getNamespaceContext()
Returns the current namespace context.

Returns:
the current namespace context
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLInputFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Class XMLInputFactory

java.lang.Object
    extended by  javax.xml.stream.XMLInputFactory

public abstract class XMLInputFactory
extends Object

Defines an abstract implementation of a factory for getting streams. The following table defines the standard properties of this specification. Each property varies in the level of support required by each implementation. The level of support required is described in the 'Required' column.
Configuration parameters
Property Name | Behavior | Return type | Default Value | Required
javax.xml.stream.isValidating | Turns on/off implementation specific DTD validation | Boolean | False | No
javax.xml.stream.isNamespaceAware | Turns on/off namespace processing for XML 1.0 support | Boolean | True | True (required) / False (optional)
javax.xml.stream.isCoalescing | Requires the processor to coalesce adjacent character data | Boolean | False | Yes
javax.xml.stream.isReplacingEntityReferences | replace internal entity references with their replacement text and report them as characters | Boolean | True | Yes
javax.xml.stream.isSupportingExternalEntities | Resolve external parsed entities | Boolean | Unspecified | Yes
javax.xml.stream.supportDTD | Use this property to request processors that do not support DTDs | Boolean | True | Yes
javax.xml.stream.reporter | sets/gets the impl of the XMLReporter | javax.xml.stream.XMLReporter | Null | Yes
javax.xml.stream.resolver | sets/gets the impl of the XMLResolver interface | javax.xml.stream.XMLResolver | Null | Yes
javax.xml.stream.allocator | sets/gets the impl of the XMLEventAllocator interface | javax.xml.stream.util.XMLEventAllocator | Null | Yes

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
XMLOutputFactory, XMLEventReader, XMLStreamReader, EventFilter, XMLReporter, XMLResolver, XMLEventAllocator

Field Summary
static String | ALLOCATOR The property used to set/get the implementation of the allocator
static String | IS_COALESCING The property that requires the parser to coalesce adjacent character data sections
static String | IS_NAMESPACE_AWARE The property used to turn on/off namespace support, this is to support XML 1.0 documents, only the true setting must be supported
static String | IS_REPLACING_ENTITY_REFERENCES Requires the parser to replace internal entity references with their replacement text and report them as characters
static String | IS_SUPPORTING_EXTERNAL_ENTITIES The property that requires the parser to resolve external parsed entities
static String | IS_VALIDATING The property used to turn on/off implementation specific validation
static String | REPORTER The property used to set/get the implementation of the XMLReporter interface
static String | RESOLVER The property used to set/get the implementation of the XMLResolver
static String | SUPPORT_DTD The property that requires the parser to support DTDs
Constructor Summary
protected XMLInputFactory()
Method Summary
abstract XMLEventReader | createFilteredReader(XMLEventReader reader, EventFilter filter) Create a filtered event reader that wraps the filter around the event reader
abstract XMLStreamReader | createFilteredReader(XMLStreamReader reader, StreamFilter filter) Create a filtered reader that wraps the filter around the reader
abstract XMLEventReader | createXMLEventReader(InputStream stream) Create a new XMLEventReader from a java.io.InputStream
abstract XMLEventReader | createXMLEventReader(InputStream stream, String encoding) Create a new XMLEventReader from a java.io.InputStream
abstract XMLEventReader | createXMLEventReader(Reader reader) Create a new XMLEventReader from a reader
abstract XMLEventReader | createXMLEventReader(Source source) Create a new XMLEventReader from a JAXP source.
abstract XMLEventReader | createXMLEventReader(String systemId, InputStream stream) Create a new XMLEventReader from a java.io.InputStream
abstract XMLEventReader | createXMLEventReader(String systemId, Reader reader) Create a new XMLEventReader from a reader
abstract XMLEventReader | createXMLEventReader(XMLStreamReader reader) Create a new XMLEventReader from an XMLStreamReader.
abstract XMLStreamReader | createXMLStreamReader(InputStream stream) Create a new XMLStreamReader from a java.io.InputStream
abstract XMLStreamReader | createXMLStreamReader(InputStream stream, String encoding) Create a new XMLStreamReader from a java.io.InputStream
abstract XMLStreamReader | createXMLStreamReader(Reader reader) Create a new XMLStreamReader from a reader
abstract XMLStreamReader | createXMLStreamReader(Source source) Create a new XMLStreamReader from a JAXP source.
abstract XMLStreamReader | createXMLStreamReader(String systemId, InputStream stream) Create a new XMLStreamReader from a java.io.InputStream
abstract XMLStreamReader | createXMLStreamReader(String systemId, Reader reader) Create a new XMLStreamReader from a java.io.InputStream
abstract XMLEventAllocator | getEventAllocator() Gets the allocator used by streams created with this factory
abstract Object | getProperty(String name) Get the value of a feature/property from the underlying implementation
abstract XMLReporter | getXMLReporter() The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
abstract XMLResolver | getXMLResolver() The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
abstract boolean | isPropertySupported(String name) Query the set of properties that this factory supports.
static XMLInputFactory | newInstance() Create a new instance of the factory.
static XMLInputFactory | newInstance(String factoryId, ClassLoader classLoader) Create a new instance of the factory
abstract void | setEventAllocator(XMLEventAllocator allocator) Set a user defined event allocator for events
abstract void | setProperty(String name, Object value) Allows the user to set specific feature/property on the underlying implementation.
abstract void | setXMLReporter(XMLReporter reporter) The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
abstract void | setXMLResolver(XMLResolver resolver) The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

IS_NAMESPACE_AWARE

public static final String IS_NAMESPACE_AWARE
The property used to turn on/off namespace support, this is to support XML 1.0 documents, only the true setting must be supported

See Also:
Constant Field Values

IS_VALIDATING

public static final String IS_VALIDATING
The property used to turn on/off implementation specific validation

See Also:
Constant Field Values

IS_COALESCING

public static final String IS_COALESCING
The property that requires the parser to coalesce adjacent character data sections

See Also:
Constant Field Values

IS_REPLACING_ENTITY_REFERENCES

public static final String IS_REPLACING_ENTITY_REFERENCES
Requires the parser to replace internal entity references with their replacement text and report them as characters

See Also:
Constant Field Values

IS_SUPPORTING_EXTERNAL_ENTITIES

public static final String IS_SUPPORTING_EXTERNAL_ENTITIES
The property that requires the parser to resolve external parsed entities

See Also:
Constant Field Values

SUPPORT_DTD

public static final String SUPPORT_DTD
The property that requires the parser to support DTDs

See Also:
Constant Field Values

REPORTER

public static final String REPORTER
The property used to set/get the implementation of the XMLReporter interface

See Also:
Constant Field Values

RESOLVER

public static final String RESOLVER
The property used to set/get the implementation of the XMLResolver

See Also:
Constant Field Values

ALLOCATOR

public static final String ALLOCATOR
The property used to set/get the implementation of the allocator

See Also:
Constant Field Values
Constructor Detail

XMLInputFactory

protected XMLInputFactory()
Method Detail

newInstance

public static XMLInputFactory newInstance()
                                   throws FactoryConfigurationError
Create a new instance of the factory. This static method creates a new factory instance. This method uses the following ordered lookup procedure to determine the XMLInputFactory implementation class to load: Use the javax.xml.stream.XMLInputFactory system property. Use the properties file "lib/stax.properties" in the JRE directory. This configuration file is in standard java.util.Properties format and contains the fully qualified name of the implementation class with the key being the system property defined above. Use the Services API (as detailed in the JAR specification), if available, to determine the classname. The Services API will look for a classname in the file META-INF/services/javax.xml.stream.XMLInputFactory in jars available to the runtime. Platform default XMLInputFactory instance. Once an application has obtained a reference to a XMLInputFactory it can use the factory to configure and obtain stream instances.

Throws:
FactoryConfigurationError - if an instance of this factory cannot be loaded

newInstance

public static XMLInputFactory newInstance(String factoryId,
                                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
Create a new instance of the factory

Parameters:
factoryId - Name of the factory to find, same as a property name
classLoader - classLoader to use
Returns:
the factory implementation
Throws:
FactoryConfigurationError - if an instance of this factory cannot be loaded

createXMLStreamReader

public abstract XMLStreamReader createXMLStreamReader(Reader reader)
                                               throws XMLStreamException
Create a new XMLStreamReader from a reader

Parameters:
reader - the XML data to read from
Throws:
XMLStreamException

createXMLStreamReader

public abstract XMLStreamReader createXMLStreamReader(Source source)
                                               throws XMLStreamException
Create a new XMLStreamReader from a JAXP source. This method is optional.

Parameters:
source - the source to read from
Throws:
UnsupportedOperationException - if this method is not supported by this XMLInputFactory
XMLStreamException

createXMLStreamReader

public abstract XMLStreamReader createXMLStreamReader(InputStream stream)
                                               throws XMLStreamException
Create a new XMLStreamReader from a java.io.InputStream

Parameters:
stream - the InputStream to read from
Throws:
XMLStreamException

createXMLStreamReader

public abstract XMLStreamReader createXMLStreamReader(InputStream stream,
                                                      String encoding)
                                               throws XMLStreamException
Create a new XMLStreamReader from a java.io.InputStream

Parameters:
stream - the InputStream to read from
encoding - the character encoding of the stream
Throws:
XMLStreamException

createXMLStreamReader

public abstract XMLStreamReader createXMLStreamReader(String systemId,
                                                      InputStream stream)
                                               throws XMLStreamException
Create a new XMLStreamReader from a java.io.InputStream

Parameters:
systemId - the system ID of the stream
stream - the InputStream to read from
Throws:
XMLStreamException

createXMLStreamReader

public abstract XMLStreamReader createXMLStreamReader(String systemId,
                                                      Reader reader)
                                               throws XMLStreamException
Create a new XMLStreamReader from a java.io.InputStream

Parameters:
systemId - the system ID of the stream
reader - the InputStream to read from
Throws:
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(Reader reader)
                                             throws XMLStreamException
Create a new XMLEventReader from a reader

Parameters:
reader - the XML data to read from
Throws:
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(String systemId,
                                                    Reader reader)
                                             throws XMLStreamException
Create a new XMLEventReader from a reader

Parameters:
systemId - the system ID of the input
reader - the XML data to read from
Throws:
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(XMLStreamReader reader)
                                             throws XMLStreamException
Create a new XMLEventReader from an XMLStreamReader. After being used to construct the XMLEventReader instance returned from this method the XMLStreamReader must not be used.

Parameters:
reader - the XMLStreamReader to read from (may not be modified)
Returns:
a new XMLEventReader
Throws:
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(Source source)
                                             throws XMLStreamException
Create a new XMLEventReader from a JAXP source. Support of this method is optional.

Parameters:
source - the source to read from
Throws:
UnsupportedOperationException - if this method is not supported by this XMLInputFactory
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(InputStream stream)
                                             throws XMLStreamException
Create a new XMLEventReader from a java.io.InputStream

Parameters:
stream - the InputStream to read from
Throws:
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(InputStream stream,
                                                    String encoding)
                                             throws XMLStreamException
Create a new XMLEventReader from a java.io.InputStream

Parameters:
stream - the InputStream to read from
encoding - the character encoding of the stream
Throws:
XMLStreamException

createXMLEventReader

public abstract XMLEventReader createXMLEventReader(String systemId,
                                                    InputStream stream)
                                             throws XMLStreamException
Create a new XMLEventReader from a java.io.InputStream

Parameters:
systemId - the system ID of the stream
stream - the InputStream to read from
Throws:
XMLStreamException

createFilteredReader

public abstract XMLStreamReader createFilteredReader(XMLStreamReader reader,
                                                     StreamFilter filter)
                                              throws XMLStreamException
Create a filtered reader that wraps the filter around the reader

Parameters:
reader - the reader to filter
filter - the filter to apply to the reader
Throws:
XMLStreamException

createFilteredReader

public abstract XMLEventReader createFilteredReader(XMLEventReader reader,
                                                    EventFilter filter)
                                             throws XMLStreamException
Create a filtered event reader that wraps the filter around the event reader

Parameters:
reader - the event reader to wrap
filter - the filter to apply to the event reader
Throws:
XMLStreamException

getXMLResolver

public abstract XMLResolver getXMLResolver()
The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

setXMLResolver

public abstract void setXMLResolver(XMLResolver resolver)
The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

Parameters:
resolver - the resolver to use to resolve references

getXMLReporter

public abstract XMLReporter getXMLReporter()
The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

setXMLReporter

public abstract void setXMLReporter(XMLReporter reporter)
The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

Parameters:
reporter - the resolver to use to report non fatal errors

setProperty

public abstract void setProperty(String name,
                                 Object value)
                          throws IllegalArgumentException
Allows the user to set specific feature/property on the underlying implementation. The underlying implementation is not required to support every setting of every property in the specification and may use IllegalArgumentException to signal that an unsupported property may not be set with the specified value.

Parameters:
name - The name of the property (may not be null)
value - The value of the property
Throws:
IllegalArgumentException - if the property is not supported

getProperty

public abstract Object getProperty(String name)
                            throws IllegalArgumentException
Get the value of a feature/property from the underlying implementation

Parameters:
name - The name of the property (may not be null)
Returns:
The value of the property
Throws:
IllegalArgumentException - if the property is not supported

isPropertySupported

public abstract boolean isPropertySupported(String name)
Query the set of properties that this factory supports.

Parameters:
name - The name of the property (may not be null)
Returns:
true if the property is supported and false otherwise

setEventAllocator

public abstract void setEventAllocator(XMLEventAllocator allocator)
Set a user defined event allocator for events

Parameters:
allocator - the user defined allocator

getEventAllocator

public abstract XMLEventAllocator getEventAllocator()
Gets the allocator used by streams created with this factory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLOutputFactory

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Class XMLOutputFactory

java.lang.Object
    extended by  javax.xml.stream.XMLOutputFactory

public abstract class XMLOutputFactory
extends Object

Defines an abstract implementation of a factory for getting XMLEventWriters and XMLStreamWriters. The following table defines the standard properties of this specification. Each property varies in the level of support required by each implementation. The level of support required is described in the 'Required' column.
Configuration parameters
Property Name | Behavior | Return type | Default Value | Required
javax.xml.stream.isRepairingNamespaces | defaults prefixes on the output side | Boolean | False | Yes

The following paragraphs describe the namespace and prefix repair algorithm:

The property can be set with the following code line: setProperty("javax.xml.stream.isRepairingNamespaces",new Boolean(true|false));

This property specifies that the writer default namespace prefix declarations. The default value is false.

If a writer isRepairingNamespaces it will create a namespace declaration on the current StartElement for any attribute that does not currently have a namespace declaration in scope. If the StartElement has a uri but no prefix specified a prefix will be assigned, if the prefix has not been declared in a parent of the current StartElement it will be declared on the current StartElement. If the defaultNamespace is bound and in scope and the default namespace matches the URI of the attribute or StartElement QName no prefix will be assigned.

If an element or attribute name has a prefix, but is not bound to any namespace URI, then the prefix will be removed during serialization.

If element and/or attribute names in the same start or empty-element tag are bound to different namespace URIs and are using the same prefix then the element or the first occurring attribute retains the original prefix and the following attributes have their prefixes replaced with a new prefix that is bound to the namespace URIs of those attributes.

If an element or attribute name uses a prefix that is bound to a different URI than that inherited from the namespace context of the parent of that element and there is no namespace declaration in the context of the current element then such a namespace declaration is added.

If an element or attribute name is bound to a prefix and there is a namespace declaration that binds that prefix to a different URI then that namespace declaration is either removed if the correct mapping is inherited from the parent context of that element, or changed to the namespace URI of the element or attribute using that prefix.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
XMLInputFactory, XMLEventWriter, XMLStreamWriter

Field Summary
static String IS_REPAIRING_NAMESPACES
Property used to set prefix defaulting on the output side
Constructor Summary
protected XMLOutputFactory()
Method Summary
abstract XMLEventWriter | createXMLEventWriter(OutputStream stream) Create a new XMLEventWriter that writes to a stream
abstract XMLEventWriter | createXMLEventWriter(OutputStream stream, String encoding) Create a new XMLEventWriter that writes to a stream
abstract XMLEventWriter | createXMLEventWriter(Result result) Create a new XMLEventWriter that writes to a JAXP result.
abstract XMLEventWriter | createXMLEventWriter(Writer stream) Create a new XMLEventWriter that writes to a writer
abstract XMLStreamWriter | createXMLStreamWriter(OutputStream stream) Create a new XMLStreamWriter that writes to a stream
abstract XMLStreamWriter | createXMLStreamWriter(OutputStream stream, String encoding) Create a new XMLStreamWriter that writes to a stream
abstract XMLStreamWriter | createXMLStreamWriter(Result result) Create a new XMLStreamWriter that writes to a JAXP result.
abstract XMLStreamWriter | createXMLStreamWriter(Writer stream) Create a new XMLStreamWriter that writes to a writer
abstract Object | getProperty(String name) Get a feature/property on the underlying implementation
abstract boolean | isPropertySupported(String name) Query the set of properties that this factory supports.
static XMLOutputFactory | newInstance() Create a new instance of the factory.
static XMLInputFactory | newInstance(String factoryId, ClassLoader classLoader) Create a new instance of the factory
abstract void | setProperty(String name, Object value) Allows the user to set specific features/properties on the underlying implementation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

IS_REPAIRING_NAMESPACES

public static final String IS_REPAIRING_NAMESPACES
Property used to set prefix defaulting on the output side

See Also:
Constant Field Values
Constructor Detail

XMLOutputFactory

protected XMLOutputFactory()
Method Detail

newInstance

public static XMLOutputFactory newInstance()
                                    throws FactoryConfigurationError
Create a new instance of the factory.

Throws:
FactoryConfigurationError - if an instance of this factory cannot be loaded

newInstance

public static XMLInputFactory newInstance(String factoryId,
                                          ClassLoader classLoader)
                                   throws FactoryConfigurationError
Create a new instance of the factory

Parameters:
factoryId - Name of the factory to find, same as a property name
classLoader - classLoader to use
Returns:
the factory implementation
Throws:
FactoryConfigurationError - if an instance of this factory cannot be loaded

createXMLStreamWriter

public abstract XMLStreamWriter createXMLStreamWriter(Writer stream)
                                               throws XMLStreamException
Create a new XMLStreamWriter that writes to a writer

Parameters:
stream - the writer to write to
Throws:
XMLStreamException

createXMLStreamWriter

public abstract XMLStreamWriter createXMLStreamWriter(OutputStream stream)
                                               throws XMLStreamException
Create a new XMLStreamWriter that writes to a stream

Parameters:
stream - the stream to write to
Throws:
XMLStreamException

createXMLStreamWriter

public abstract XMLStreamWriter createXMLStreamWriter(OutputStream stream,
                                                      String encoding)
                                               throws XMLStreamException
Create a new XMLStreamWriter that writes to a stream

Parameters:
stream - the stream to write to
encoding - the encoding to use
Throws:
XMLStreamException

createXMLStreamWriter

public abstract XMLStreamWriter createXMLStreamWriter(Result result)
                                               throws XMLStreamException
Create a new XMLStreamWriter that writes to a JAXP result. This method is optional.

Parameters:
result - the result to write to
Throws:
UnsupportedOperationException - if this method is not supported by this XMLOutputFactory
XMLStreamException

createXMLEventWriter

public abstract XMLEventWriter createXMLEventWriter(Result result)
                                             throws XMLStreamException
Create a new XMLEventWriter that writes to a JAXP result. This method is optional.

Parameters:
result - the result to write to
Throws:
UnsupportedOperationException - if this method is not supported by this XMLOutputFactory
XMLStreamException

createXMLEventWriter

public abstract XMLEventWriter createXMLEventWriter(OutputStream stream)
                                             throws XMLStreamException
Create a new XMLEventWriter that writes to a stream

Parameters:
stream - the stream to write to
Throws:
XMLStreamException

createXMLEventWriter

public abstract XMLEventWriter createXMLEventWriter(OutputStream stream,
                                                    String encoding)
                                             throws XMLStreamException
Create a new XMLEventWriter that writes to a stream

Parameters:
stream - the stream to write to
encoding - the encoding to use
Throws:
XMLStreamException

createXMLEventWriter

public abstract XMLEventWriter createXMLEventWriter(Writer stream)
                                             throws XMLStreamException
Create a new XMLEventWriter that writes to a writer

Parameters:
stream - the stream to write to
Throws:
XMLStreamException

setProperty

public abstract void setProperty(String name,
                                 Object value)
                          throws IllegalArgumentException
Allows the user to set specific features/properties on the underlying implementation.

Parameters:
name - The name of the property
value - The value of the property
Throws:
IllegalArgumentException - if the property is not supported

getProperty

public abstract Object getProperty(String name)
                            throws IllegalArgumentException
Get a feature/property on the underlying implementation

Parameters:
name - The name of the property
Returns:
The value of the property
Throws:
IllegalArgumentException - if the property is not supported

isPropertySupported

public abstract boolean isPropertySupported(String name)
Query the set of properties that this factory supports.

Parameters:
name - The name of the property (may not be null)
Returns:
true if the property is supported and false otherwise
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLReporter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Interface XMLReporter

public interface XMLReporter

This interface is used to report non-fatal errors. Only warnings should be echoed through this interface.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Method Summary
 void report(String message, String errorType, Object relatedInformation, Location location)
Report the desired message in an application specific format.

Method Detail

report

void report(String message,
            String errorType,
            Object relatedInformation,
            Location location)
            throws XMLStreamException
Report the desired message in an application specific format. Only warnings and non-fatal errors should be reported through this interface. Fatal errors should be thrown as XMLStreamException.

Parameters:
message - the error message
errorType - an implementation defined error type
relatedInformation - information related to the error, if available
location - the location of the error, if available
Throws:
XMLStreamException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Interface XMLResolver

public interface XMLResolver

This interface is used to resolve resources during an XML parse. If an application wishes to perform custom entity resolution it must register an instance of this interface with the XMLInputFactory using the setXMLResolver method.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.

Method Summary
 Object resolveEntity(String publicID, String systemID, String baseURI, String namespace)
Retrieves a resource.

Method Detail

resolveEntity

Object resolveEntity(String publicID,
                     String systemID,
                     String baseURI,
                     String namespace)
                     throws XMLStreamException
Retrieves a resource. This resource can be of the following three return types: (1) java.io.InputStream (2) javax.xml.stream.XMLStreamReader (3) java.xml.stream.XMLEventReader. If this method returns null the processor will attempt to resolve the entity using its default mechanism.

Parameters:
publicID - The public identifier of the external entity being referenced, or null if none was supplied.
systemID - The system identifier of the external entity being referenced.
baseURI - Absolute base URI associated with systemId.
namespace - The namespace of the entity to resolve.
Returns:
The resource requested or null.
Throws:
XMLStreamException - if there was a failure attempting to resolve the resource.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLStreamConstants

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Interface XMLStreamConstants

All Known Subinterfaces:
Attribute, Characters, Comment, DTD, EndDocument, EndElement, EntityDeclaration, EntityReference, Namespace, NotationDeclaration, ProcessingInstruction, StartDocument, StartElement, XMLEvent, XMLStreamReader
All Known Implementing Classes:
StreamReaderDelegate
public interface XMLStreamConstants

This interface declares the constants used in this API. Numbers in the range 0 to 256 are reserved for the specification, user defined events must use event codes outside that range.

Field Summary
static int | ATTRIBUTE Indicates an event is an attribute
static int | CDATA Indicates an event is a CDATA section
static int | CHARACTERS Indicates an event is characters
static int | COMMENT Indicates an event is a comment
static int | DTD Indicates an event is a DTD
static int | END_DOCUMENT Indicates an event is an end document
static int | END_ELEMENT Indicates an event is an end element
static int | ENTITY_DECLARATION Indicates a Entity Declaration
static int | ENTITY_REFERENCE Indicates an event is an entity reference
static int | NAMESPACE Indicates the event is a namespace declaration
static int | NOTATION_DECLARATION Indicates a Notation
static int | PROCESSING_INSTRUCTION Indicates an event is a processing instruction
static int | SPACE The characters are white space (see [XML], 2.10 "White Space Handling").
static int | START_DOCUMENT Indicates an event is a start document
static int | START_ELEMENT Indicates an event is a start element

Field Detail

START_ELEMENT

static final int START_ELEMENT
Indicates an event is a start element

See Also:
StartElement, Constant Field Values

END_ELEMENT

static final int END_ELEMENT
Indicates an event is an end element

See Also:
EndElement, Constant Field Values

PROCESSING_INSTRUCTION

static final int PROCESSING_INSTRUCTION
Indicates an event is a processing instruction

See Also:
ProcessingInstruction, Constant Field Values

CHARACTERS

static final int CHARACTERS
Indicates an event is characters

See Also:
Characters, Constant Field Values

COMMENT

static final int COMMENT
Indicates an event is a comment

See Also:
Comment, Constant Field Values

SPACE

static final int SPACE
The characters are white space (see [XML], 2.10 "White Space Handling"). Events are only reported as SPACE if they are ignorable white space. Otherwise they are reported as CHARACTERS.

See Also:
Characters, Constant Field Values

START_DOCUMENT

static final int START_DOCUMENT
Indicates an event is a start document

See Also:
StartDocument, Constant Field Values

END_DOCUMENT

static final int END_DOCUMENT
Indicates an event is an end document

See Also:
EndDocument, Constant Field Values

ENTITY_REFERENCE

static final int ENTITY_REFERENCE
Indicates an event is an entity reference

See Also:
EntityReference, Constant Field Values

ATTRIBUTE

static final int ATTRIBUTE
Indicates an event is an attribute

See Also:
Attribute, Constant Field Values

DTD

static final int DTD
Indicates an event is a DTD

See Also:
DTD, Constant Field Values

CDATA

static final int CDATA
Indicates an event is a CDATA section

See Also:
Characters, Constant Field Values

NAMESPACE

static final int NAMESPACE
Indicates the event is a namespace declaration

See Also:
Namespace, Constant Field Values

NOTATION_DECLARATION

static final int NOTATION_DECLARATION
Indicates a Notation

See Also:
NotationDeclaration, Constant Field Values

ENTITY_DECLARATION

static final int ENTITY_DECLARATION
Indicates a Entity Declaration

See Also:
NotationDeclaration, Constant Field Values
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLStreamException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Class XMLStreamException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  javax.xml.stream.XMLStreamException
All Implemented Interfaces:
Serializable
public class XMLStreamException
extends Exception

The base exception for unexpected processing errors. This Exception class is used to report well-formedness errors as well as unexpected processing conditions.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
Serialized Form

Field Summary
protected Location | location
protected Throwable | nested
Constructor Summary
XMLStreamException()
Default constructor
XMLStreamException(String msg)
Construct an exception with the assocated message.
XMLStreamException(String msg, Location location)
Construct an exception with the assocated message, exception and location.
XMLStreamException(String msg, Location location, Throwable th)
Construct an exception with the assocated message, exception and location.
XMLStreamException(String msg, Throwable th)
Construct an exception with the assocated message and exception
XMLStreamException(Throwable th)
Construct an exception with the assocated exception
Method Summary
Location | getLocation() Gets the location of the exception
Throwable | getNestedException() Gets the nested exception.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

nested

protected Throwable nested

location

protected Location location
Constructor Detail

XMLStreamException

public XMLStreamException()
Default constructor

XMLStreamException

public XMLStreamException(String msg)
Construct an exception with the assocated message.

Parameters:
msg - the message to report

XMLStreamException

public XMLStreamException(Throwable th)
Construct an exception with the assocated exception

Parameters:
th - a nested exception

XMLStreamException

public XMLStreamException(String msg,
                          Throwable th)
Construct an exception with the assocated message and exception

Parameters:
th - a nested exception
msg - the message to report

XMLStreamException

public XMLStreamException(String msg,
                          Location location,
                          Throwable th)
Construct an exception with the assocated message, exception and location.

Parameters:
th - a nested exception
msg - the message to report
location - the location of the error

XMLStreamException

public XMLStreamException(String msg,
                          Location location)
Construct an exception with the assocated message, exception and location.

Parameters:
msg - the message to report
location - the location of the error
Method Detail

getNestedException

public Throwable getNestedException()
Gets the nested exception.

Returns:
Nested exception

getLocation

public Location getLocation()
Gets the location of the exception

Returns:
the location of the exception, may be null if none is available
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLStreamReader

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Interface XMLStreamReader

All Superinterfaces:
XMLStreamConstants
All Known Implementing Classes:
StreamReaderDelegate
public interface XMLStreamReader
extends XMLStreamConstants

The XMLStreamReader interface allows forward, read-only access to XML. It is designed to be the lowest level and most efficient way to read XML data.

The XMLStreamReader is designed to iterate over XML using next() and hasNext(). The data can be accessed using methods such as getEventType(), getNamespaceURI(), getLocalName() and getText();

The next() method causes the reader to read the next parse event. The next() method returns an integer which identifies the type of event just read.

The event type can be determined using getEventType().

Parsing events are defined as the XML Declaration, a DTD, start tag, character data, white space, end tag, comment, or processing instruction. An attribute or namespace event may be encountered at the root level of a document as the result of a query operation.

For XML 1.0 compliance an XML processor must pass the identifiers of declared unparsed entities, notation declarations and their associated identifiers to the application. This information is provided through the property API on this interface. The following two properties allow access to this information: javax.xml.stream.notations and javax.xml.stream.entities. When the current event is a DTD the following call will return a list of Notations List l = (List) getProperty("javax.xml.stream.notations"); The following call will return a list of entity declarations: List l = (List) getProperty("javax.xml.stream.entities"); These properties can only be accessed during a DTD event and are defined to return null if the information is not available.

The following table describes which methods are valid in what state. If a method is called in an invalid state the method will throw a java.lang.IllegalStateException.
Valid methods for each state
Event Type | Valid Methods
All States | getProperty(), hasNext(), require(), close(), getNamespaceURI(), isStartElement(), isEndElement(), isCharacters(), isWhiteSpace(), getNamespaceContext(), getEventType(),getLocation(), hasText(), hasName()
START_ELEMENT | next(), getName(), getLocalName(), hasName(), getPrefix(), getAttributeXXX(), isAttributeSpecified(), getNamespaceXXX(), getElementText(), nextTag()
ATTRIBUTE | next(), nextTag() getAttributeXXX(), isAttributeSpecified(),
NAMESPACE | next(), nextTag() getNamespaceXXX()
END_ELEMENT | next(), getName(), getLocalName(), hasName(), getPrefix(), getNamespaceXXX(), nextTag()
CHARACTERS | next(), getTextXXX(), nextTag()
CDATA | next(), getTextXXX(), nextTag()
COMMENT | next(), getTextXXX(), nextTag()
SPACE | next(), getTextXXX(), nextTag()
START_DOCUMENT | next(), getEncoding(), getVersion(), isStandalone(), standaloneSet(), getCharacterEncodingScheme(), nextTag()
END_DOCUMENT | close()
PROCESSING_INSTRUCTION | next(), getPITarget(), getPIData(), nextTag()
ENTITY_REFERENCE | next(), getLocalName(), getText(), nextTag()
DTD | next(), getText(), nextTag()

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
XMLEvent, XMLInputFactory, XMLStreamWriter

Field Summary
Fields inherited from interface javax.xml.stream.XMLStreamConstants
ATTRIBUTE, CDATA, CHARACTERS, COMMENT, DTD, END_DOCUMENT, END_ELEMENT, ENTITY_DECLARATION, ENTITY_REFERENCE, NAMESPACE, NOTATION_DECLARATION, PROCESSING_INSTRUCTION, SPACE, START_DOCUMENT, START_ELEMENT
Method Summary
 void close()
Frees any resources associated with this Reader.
 int getAttributeCount()
Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE.
 String getAttributeLocalName(int index)
Returns the localName of the attribute at the provided index
 QName getAttributeName(int index)
Returns the qname of the attribute at the provided index
 String getAttributeNamespace(int index)
Returns the namespace of the attribute at the provided index
 String getAttributePrefix(int index)
Returns the prefix of this attribute at the provided index
 String getAttributeType(int index)
Returns the XML type of the attribute at the provided index
 String getAttributeValue(int index)
Returns the value of the attribute at the index
 String getAttributeValue(String namespaceURI, String localName)
Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality
 String getCharacterEncodingScheme()
Returns the character encoding declared on the xml declaration Returns null if none was declared
 String getElementText()
Reads the content of a text-only element, an exception is thrown if this is not a text-only element.
 String getEncoding()
Return input encoding if known or null if unknown.
 int getEventType()
Returns an integer code that indicates the type of the event the cursor is pointing to.
 String getLocalName()
Returns the (local) name of the current event.
 Location getLocation()
Return the current location of the processor.
 QName getName()
Returns a QName for the current START_ELEMENT or END_ELEMENT event
 NamespaceContext getNamespaceContext()
Returns a read only namespace context for the current position.
 int getNamespaceCount()
Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE.
 String getNamespacePrefix(int index)
Returns the prefix for the namespace declared at the index.
 String getNamespaceURI()
If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace.
 String getNamespaceURI(int index)
Returns the uri for the namespace declared at the index.
 String getNamespaceURI(String prefix)
Return the uri for the given prefix.
 String getPIData()
Get the data section of a processing instruction
 String getPITarget()
Get the target of a processing instruction
 String getPrefix()
Returns the prefix of the current event or null if the event does not have a prefix
 Object getProperty(String name)
Get the value of a feature/property from the underlying implementation
 String getText()
Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD.
 char[] getTextCharacters()
Returns an array which contains the characters from this event.
 int getTextCharacters(int sourceStart, char[] target, int targetStart, int length)
Gets the the text associated with a CHARACTERS, SPACE or CDATA event.
 int getTextLength()
Returns the length of the sequence of characters for this Text event within the text character array.
 int getTextStart()
Returns the offset into the text character array where the first character (of this text event) is stored.
 String getVersion()
Get the xml version declared on the xml declaration Returns null if none was declared
 boolean hasName()
returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise
 boolean hasNext()
Returns true if there are more parsing events and false if there are no more events.
 boolean hasText()
Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE
 boolean isAttributeSpecified(int index)
Returns a boolean which indicates if this attribute was created by default
 boolean isCharacters()
Returns true if the cursor points to a character data event
 boolean isEndElement()
Returns true if the cursor points to an end tag (otherwise false)
 boolean isStandalone()
Get the standalone declaration from the xml declaration
 boolean isStartElement()
Returns true if the cursor points to a start tag (otherwise false)
 boolean isWhiteSpace()
Returns true if the cursor points to a character data event that consists of all whitespace
 int next()
Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks.
 int nextTag()
Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached.
 void require(int type, String namespaceURI, String localName)
Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event.
 boolean standaloneSet()
Checks if standalone was set in the document

Method Detail

getProperty

Object getProperty(String name)
                   throws IllegalArgumentException
Get the value of a feature/property from the underlying implementation

Parameters:
name - The name of the property, may not be null
Returns:
The value of the property
Throws:
IllegalArgumentException - if name is null

next

int next()
         throws XMLStreamException
Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks. If the property javax.xml.stream.isCoalescing is set to true element content must be coalesced and only one CHARACTERS event must be returned for contiguous element content or CDATA Sections. By default entity references must be expanded and reported transparently to the application. An exception will be thrown if an entity reference cannot be expanded. If element content is empty (i.e. content is "") then no CHARACTERS event will be reported.

Given the following XML:
<foo><!--description-->content text<![CDATA[<greeting>Hello</greeting>]]>other content</foo>
The behavior of calling next() when being on foo will be:
1- the comment (COMMENT)
2- then the characters section (CHARACTERS)
3- then the CDATA section (another CHARACTERS)
4- then the next characters section (another CHARACTERS)
5- then the END_ELEMENT

NOTE: empty element (such as <tag/>) will be reported with two separate events: START_ELEMENT, END_ELEMENT - This preserves parsing equivalency of empty element to <tag></tag>. This method will throw an IllegalStateException if it is called after hasNext() returns false.

Returns:
the integer code corresponding to the current parse event
Throws:
NoSuchElementException - if this is called when hasNext() returns false
XMLStreamException - if there is an error processing the underlying XML source
See Also:
XMLEvent

require

void require(int type,
             String namespaceURI,
             String localName)
             throws XMLStreamException
Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event. If the namespaceURI is null it is not checked for equality, if the localName is null it is not checked for equality.

Parameters:
type - the event type
namespaceURI - the uri of the event, may be null
localName - the localName of the event, may be null
Throws:
XMLStreamException - if the required values are not matched.

getElementText

String getElementText()
                      throws XMLStreamException
Reads the content of a text-only element, an exception is thrown if this is not a text-only element. Regardless of value of javax.xml.stream.isCoalescing this method always returns coalesced content.
Precondition: the current event is START_ELEMENT.
Postcondition: the current event is the corresponding END_ELEMENT.
The method does the following (implementations are free to optimized but must do equivalent processing):
 if(getEventType() != XMLStreamConstants.START_ELEMENT) {
 throw new XMLStreamException(
 "parser must be on START_ELEMENT to read next text", getLocation());
 }
 int eventType = next();
 StringBuffer content = new StringBuffer();
 while(eventType != XMLStreamConstants.END_ELEMENT ) {
 if(eventType == XMLStreamConstants.CHARACTERS
 || eventType == XMLStreamConstants.CDATA
 || eventType == XMLStreamConstants.SPACE
 || eventType == XMLStreamConstants.ENTITY_REFERENCE) {
 buf.append(getText());
 } else if(eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
 || eventType == XMLStreamConstants.COMMENT) {
 // skipping
 } else if(eventType == XMLStreamConstants.END_DOCUMENT) {
 throw new XMLStreamException(
 "unexpected end of document when reading element text content", this);
 } else if(eventType == XMLStreamConstants.START_ELEMENT) {
 throw new XMLStreamException(
 "element text content may not contain START_ELEMENT", getLocation());
 } else {
 throw new XMLStreamException(
 "Unexpected event type "+eventType, getLocation());
 }
 eventType = next();
 }
 return buf.toString();

Throws:
XMLStreamException - if the current event is not a START_ELEMENT or if a non text element is encountered

nextTag

int nextTag()
            throws XMLStreamException
Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached. If other than white space characters, COMMENT, PROCESSING_INSTRUCTION, START_ELEMENT, END_ELEMENT are encountered, an exception is thrown. This method should be used when processing element-only content seperated by white space.
Precondition: none
Postcondition: the current event is START_ELEMENT or END_ELEMENT and cursor may have moved over any whitespace event.
Essentially it does the following (implementations are free to optimized but must do equivalent processing):
 int eventType = next();
 while((eventType == XMLStreamConstants.CHARACTERS && isWhiteSpace()) // skip whitespace
 || (eventType == XMLStreamConstants.CDATA && isWhiteSpace())
 // skip whitespace
 || eventType == XMLStreamConstants.SPACE
 || eventType == XMLStreamConstants.PROCESSING_INSTRUCTION
 || eventType == XMLStreamConstants.COMMENT
 ) {
 eventType = next();
 }
 if (eventType != XMLStreamConstants.START_ELEMENT && eventType != XMLStreamConstants.END_ELEMENT) {
 throw new String XMLStreamException("expected start or end tag", getLocation());
 }
 return eventType;

Returns:
the event type of the element read (START_ELEMENT or END_ELEMENT)
Throws:
XMLStreamException - if the current event is not white space, PROCESSING_INSTRUCTION, START_ELEMENT or END_ELEMENT
NoSuchElementException - if this is called when hasNext() returns false

hasNext

boolean hasNext()
                throws XMLStreamException
Returns true if there are more parsing events and false if there are no more events. This method will return false if the current state of the XMLStreamReader is END_DOCUMENT

Returns:
true if there are more events, false otherwise
Throws:
XMLStreamException - if there is a fatal error detecting the next state

close

void close()
           throws XMLStreamException
Frees any resources associated with this Reader. This method does not close the underlying input source.

Throws:
XMLStreamException - if there are errors freeing associated resources

getNamespaceURI

String getNamespaceURI(String prefix)
Return the uri for the given prefix. The uri returned depends on the current state of the processor.

NOTE:The 'xml' prefix is bound as defined in Namespaces in XML specification to "http://www.w3.org/XML/1998/namespace".

NOTE: The 'xmlns' prefix must be resolved to following namespace http://www.w3.org/2000/xmlns/

Parameters:
prefix - The prefix to lookup, may not be null
Returns:
the uri bound to the given prefix or null if it is not bound
Throws:
IllegalArgumentException - if the prefix is null

isStartElement

boolean isStartElement()
Returns true if the cursor points to a start tag (otherwise false)

Returns:
true if the cursor points to a start tag, false otherwise

isEndElement

boolean isEndElement()
Returns true if the cursor points to an end tag (otherwise false)

Returns:
true if the cursor points to an end tag, false otherwise

isCharacters

boolean isCharacters()
Returns true if the cursor points to a character data event

Returns:
true if the cursor points to character data, false otherwise

isWhiteSpace

boolean isWhiteSpace()
Returns true if the cursor points to a character data event that consists of all whitespace

Returns:
true if the cursor points to all whitespace, false otherwise

getAttributeValue

String getAttributeValue(String namespaceURI,
                         String localName)
Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality

Parameters:
namespaceURI - the namespace of the attribute
localName - the local name of the attribute, cannot be null
Returns:
returns the value of the attribute , returns null if not found
Throws:
IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

getAttributeCount

int getAttributeCount()
Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE. This count excludes namespace definitions. Attribute indices are zero-based.

Returns:
returns the number of attributes
Throws:
IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

getAttributeName

QName getAttributeName(int index)
Returns the qname of the attribute at the provided index

Parameters:
index - the position of the attribute
Returns:
the QName of the attribute
Throws:
IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

getAttributeNamespace

String getAttributeNamespace(int index)
Returns the namespace of the attribute at the provided index

Parameters:
index - the position of the attribute
Returns:
the namespace URI (can be null)
Throws:
IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

getAttributeLocalName

String getAttributeLocalName(int index)
Returns the localName of the attribute at the provided index

Parameters:
index - the position of the attribute
Returns:
the localName of the attribute
Throws:
IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

getAttributePrefix

String getAttributePrefix(int index)
Returns the prefix of this attribute at the provided index

Parameters:
index - the position of the attribute
Returns:
the prefix of the attribute
Throws:
IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

getAttributeType

String getAttributeType(int index)
Returns the XML type of the attribute at the provided index

Parameters:
index - the position of the attribute
Returns:
the XML type of the attribute
Throws:
IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

getAttributeValue

String getAttributeValue(int index)
Returns the value of the attribute at the index

Parameters:
index - the position of the attribute
Returns:
the attribute value
Throws:
IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

isAttributeSpecified

boolean isAttributeSpecified(int index)
Returns a boolean which indicates if this attribute was created by default

Parameters:
index - the position of the attribute
Returns:
true if this is a default attribute
Throws:
IllegalStateException - if this is not a START_ELEMENT or ATTRIBUTE

getNamespaceCount

int getNamespaceCount()
Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE. On an END_ELEMENT the count is of the namespaces that are about to go out of scope. This is the equivalent of the information reported by SAX callback for an end element event.

Returns:
returns the number of namespace declarations on this specific element
Throws:
IllegalStateException - if this is not a START_ELEMENT, END_ELEMENT or NAMESPACE

getNamespacePrefix

String getNamespacePrefix(int index)
Returns the prefix for the namespace declared at the index. Returns null if this is the default namespace declaration

Parameters:
index - the position of the namespace declaration
Returns:
returns the namespace prefix
Throws:
IllegalStateException - if this is not a START_ELEMENT, END_ELEMENT or NAMESPACE

getNamespaceURI

String getNamespaceURI(int index)
Returns the uri for the namespace declared at the index.

Parameters:
index - the position of the namespace declaration
Returns:
returns the namespace uri
Throws:
IllegalStateException - if this is not a START_ELEMENT, END_ELEMENT or NAMESPACE

getNamespaceContext

NamespaceContext getNamespaceContext()
Returns a read only namespace context for the current position. The context is transient and only valid until a call to next() changes the state of the reader.

Returns:
return a namespace context

getEventType

int getEventType()
Returns an integer code that indicates the type of the event the cursor is pointing to.

getText

String getText()
Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD. If an ENTITY_REFERENCE has been resolved, any character data will be reported as CHARACTERS events.

Returns:
the current text or null
Throws:
IllegalStateException - if this state is not a valid text state.

getTextCharacters

char[] getTextCharacters()
Returns an array which contains the characters from this event. This array should be treated as read-only and transient. I.e. the array will contain the text characters until the XMLStreamReader moves on to the next event. Attempts to hold onto the character array beyond that time or modify the contents of the array are breaches of the contract for this interface.

Returns:
the current text or an empty array
Throws:
IllegalStateException - if this state is not a valid text state.

getTextCharacters

int getTextCharacters(int sourceStart,
                      char[] target,
                      int targetStart,
                      int length)
                      throws XMLStreamException
Gets the the text associated with a CHARACTERS, SPACE or CDATA event. Text starting a "sourceStart" is copied into "target" starting at "targetStart". Up to "length" characters are copied. The number of characters actually copied is returned. The "sourceStart" argument must be greater or equal to 0 and less than or equal to the number of characters associated with the event. Usually, one requests text starting at a "sourceStart" of 0. If the number of characters actually copied is less than the "length", then there is no more text. Otherwise, subsequent calls need to be made until all text has been retrieved. For example:
int length = 1024;
char[] myBuffer = new char[ length ];

for ( int sourceStart = 0 ; ; sourceStart += length )
{
   int nCopied = stream.getTextCharacters( sourceStart, myBuffer, 0, length );

  if (nCopied < length)
      break;
}
 XMLStreamException may be thrown if there are any XML errors in the underlying source. The "targetStart" argument must be greater than or equal to 0 and less than the length of "target", Length must be greater than 0 and "targetStart + length" must be less than or equal to length of "target".

Parameters:
sourceStart - the index of the first character in the source array to copy
target - the destination array
targetStart - the start offset in the target array
length - the number of characters to copy
Returns:
the number of characters actually copied
Throws:
XMLStreamException - if the underlying XML source is not well-formed
IndexOutOfBoundsException - if targetStart < 0 or > than the length of target
IndexOutOfBoundsException - if length < 0 or targetStart + length > length of target
UnsupportedOperationException - if this method is not supported
NullPointerException - is if target is null

getTextStart

int getTextStart()
Returns the offset into the text character array where the first character (of this text event) is stored.

Throws:
IllegalStateException - if this state is not a valid text state.

getTextLength

int getTextLength()
Returns the length of the sequence of characters for this Text event within the text character array.

Throws:
IllegalStateException - if this state is not a valid text state.

getEncoding

String getEncoding()
Return input encoding if known or null if unknown.

Returns:
the encoding of this instance or null

hasText

boolean hasText()
Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE

getLocation

Location getLocation()
Return the current location of the processor. If the Location is unknown the processor should return an implementation of Location that returns -1 for the location and null for the publicId and systemId. The location information is only valid until next() is called.

getName

QName getName()
Returns a QName for the current START_ELEMENT or END_ELEMENT event

Returns:
the QName for the current START_ELEMENT or END_ELEMENT event
Throws:
IllegalStateException - if this is not a START_ELEMENT or END_ELEMENT

getLocalName

String getLocalName()
Returns the (local) name of the current event. For START_ELEMENT or END_ELEMENT returns the (local) name of the current element. For ENTITY_REFERENCE it returns entity name. The current event must be START_ELEMENT or END_ELEMENT, or ENTITY_REFERENCE

Returns:
the localName
Throws:
IllegalStateException - if this not a START_ELEMENT, END_ELEMENT or ENTITY_REFERENCE

hasName

boolean hasName()
returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise

getNamespaceURI

String getNamespaceURI()
If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace. Returns null if the event does not have a prefix.

Returns:
the URI bound to this elements prefix, the default namespace, or null

getPrefix

String getPrefix()
Returns the prefix of the current event or null if the event does not have a prefix

Returns:
the prefix or null

getVersion

String getVersion()
Get the xml version declared on the xml declaration Returns null if none was declared

Returns:
the XML version or null

isStandalone

boolean isStandalone()
Get the standalone declaration from the xml declaration

Returns:
true if this is standalone, or false otherwise

standaloneSet

boolean standaloneSet()
Checks if standalone was set in the document

Returns:
true if standalone was set in the document, or false otherwise

getCharacterEncodingScheme

String getCharacterEncodingScheme()
Returns the character encoding declared on the xml declaration Returns null if none was declared

Returns:
the encoding declared in the document or null

getPITarget

String getPITarget()
Get the target of a processing instruction

Returns:
the target or null

getPIData

String getPIData()
Get the data section of a processing instruction

Returns:
the data or null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


XMLStreamWriter

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.stream
Interface XMLStreamWriter

public interface XMLStreamWriter

The XMLStreamWriter interface specifies how to write XML. The XMLStreamWriter does not perform well formedness checking on its input. However the writeCharacters method is required to escape & , < and > For attribute values the writeAttribute method will escape the above characters plus " to ensure that all character content and attribute values are well formed. Each NAMESPACE and ATTRIBUTE must be individually written. If javax.xml.stream.isPrefixDefaulting is set to false it is a fatal error if an element is written with namespace URI that has not been bound to a prefix. If javax.xml.stream.isPrefixDefaulting is set to true the XMLStreamWriter implementation must write a prefix for each unbound URI that it encounters in the current scope.

Version:
1.0
Author:
Copyright (c) 2003 by BEA Systems. All Rights Reserved.
See Also:
XMLOutputFactory, XMLStreamReader

Method Summary
void | close() Close this writer and free any resources associated with the writer.
void | flush() Write any cached data to the underlying output mechanism.
NamespaceContext | getNamespaceContext() Returns the current namespace context.
String | getPrefix(String uri) Gets the prefix the uri is bound to
Object | getProperty(String name) Get the value of a feature/property from the underlying implementation
void | setDefaultNamespace(String uri) Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair.
void | setNamespaceContext(NamespaceContext context) Sets the current namespace context for prefix and uri bindings.
void | setPrefix(String prefix, String uri) Sets the prefix the uri is bound to.
void | writeAttribute(String localName, String value) Writes an attribute to the output stream without a prefix.
void | writeAttribute(String namespaceURI, String localName, String value) Writes an attribute to the output stream
void | writeAttribute(String prefix, String namespaceURI, String localName, String value) Writes an attribute to the output stream
void | writeCData(String data) Writes a CData section
void | writeCharacters(char[] text, int start, int len) Write text to the output
void | writeCharacters(String text) Write text to the output
void | writeComment(String data) Writes an xml comment with the data enclosed
void | writeDefaultNamespace(String namespaceURI) Writes the default namespace to the stream
void | writeDTD(String dtd) Write a DTD section.
void | writeEmptyElement(String localName) Writes an empty element tag to the output
void | writeEmptyElement(String namespaceURI, String localName) Writes an empty element tag to the output
void | writeEmptyElement(String prefix, String localName, String namespaceURI) Writes an empty element tag to the output
void | writeEndDocument() Closes any start tags and writes corresponding end tags.
void | writeEndElement() Writes an end tag to the output relying on the internal state of the writer to determine the prefix and local name of the event.
void | writeEntityRef(String name) Writes an entity reference
void | writeNamespace(String prefix, String namespaceURI) Writes a namespace to the output stream If the prefix argument to this method is the empty string, "xmlns", or null this method will delegate to writeDefaultNamespace
void | writeProcessingInstruction(String target) Writes a processing instruction
void | writeProcessingInstruction(String target, String data) Writes a processing instruction
void | writeStartDocument() Write the XML Declaration.
void | writeStartDocument(String version) Write the XML Declaration.
void | writeStartDocument(String encoding, String version) Write the XML Declaration.
void | writeStartElement(String localName) Writes a start tag to the output.
void | writeStartElement(String namespaceURI, String localName) Writes a start tag to the output
void | writeStartElement(String prefix, String localName, String namespaceURI) Writes a start tag to the output

Method Detail

writeStartElement

void writeStartElement(String localName)
                       throws XMLStreamException
Writes a start tag to the output. All writeStartElement methods open a new scope in the internal namespace context. Writing the corresponding EndElement causes the scope to be closed.

Parameters:
localName - local name of the tag, may not be null
Throws:
XMLStreamException

writeStartElement

void writeStartElement(String namespaceURI,
                       String localName)
                       throws XMLStreamException
Writes a start tag to the output

Parameters:
namespaceURI - the namespaceURI of the prefix to use, may not be null
localName - local name of the tag, may not be null
Throws:
XMLStreamException - if the namespace URI has not been bound to a prefix and javax.xml.stream.isPrefixDefaulting has not been set to true

writeStartElement

void writeStartElement(String prefix,
                       String localName,
                       String namespaceURI)
                       throws XMLStreamException
Writes a start tag to the output

Parameters:
localName - local name of the tag, may not be null
prefix - the prefix of the tag, may not be null
namespaceURI - the uri to bind the prefix to, may not be null
Throws:
XMLStreamException

writeEmptyElement

void writeEmptyElement(String namespaceURI,
                       String localName)
                       throws XMLStreamException
Writes an empty element tag to the output

Parameters:
namespaceURI - the uri to bind the tag to, may not be null
localName - local name of the tag, may not be null
Throws:
XMLStreamException - if the namespace URI has not been bound to a prefix and javax.xml.stream.isPrefixDefaulting has not been set to true

writeEmptyElement

void writeEmptyElement(String prefix,
                       String localName,
                       String namespaceURI)
                       throws XMLStreamException
Writes an empty element tag to the output

Parameters:
prefix - the prefix of the tag, may not be null
localName - local name of the tag, may not be null
namespaceURI - the uri to bind the tag to, may not be null
Throws:
XMLStreamException

writeEmptyElement

void writeEmptyElement(String localName)
                       throws XMLStreamException
Writes an empty element tag to the output

Parameters:
localName - local name of the tag, may not be null
Throws:
XMLStreamException

writeEndElement

void writeEndElement()
                     throws XMLStreamException
Writes an end tag to the output relying on the internal state of the writer to determine the prefix and local name of the event.

Throws:
XMLStreamException

writeEndDocument

void writeEndDocument()
                      throws XMLStreamException
Closes any start tags and writes corresponding end tags.

Throws:
XMLStreamException

close

void close()
           throws XMLStreamException
Close this writer and free any resources associated with the writer. This must not close the underlying output stream.

Throws:
XMLStreamException

flush

void flush()
           throws XMLStreamException
Write any cached data to the underlying output mechanism.

Throws:
XMLStreamException

writeAttribute

void writeAttribute(String localName,
                    String value)
                    throws XMLStreamException
Writes an attribute to the output stream without a prefix.

Parameters:
localName - the local name of the attribute
value - the value of the attribute
Throws:
IllegalStateException - if the current state does not allow Attribute writing
XMLStreamException

writeAttribute

void writeAttribute(String prefix,
                    String namespaceURI,
                    String localName,
                    String value)
                    throws XMLStreamException
Writes an attribute to the output stream

Parameters:
prefix - the prefix for this attribute
namespaceURI - the uri of the prefix for this attribute
localName - the local name of the attribute
value - the value of the attribute
Throws:
IllegalStateException - if the current state does not allow Attribute writing
XMLStreamException - if the namespace URI has not been bound to a prefix and javax.xml.stream.isPrefixDefaulting has not been set to true

writeAttribute

void writeAttribute(String namespaceURI,
                    String localName,
                    String value)
                    throws XMLStreamException
Writes an attribute to the output stream

Parameters:
namespaceURI - the uri of the prefix for this attribute
localName - the local name of the attribute
value - the value of the attribute
Throws:
IllegalStateException - if the current state does not allow Attribute writing
XMLStreamException - if the namespace URI has not been bound to a prefix and javax.xml.stream.isPrefixDefaulting has not been set to true

writeNamespace

void writeNamespace(String prefix,
                    String namespaceURI)
                    throws XMLStreamException
Writes a namespace to the output stream If the prefix argument to this method is the empty string, "xmlns", or null this method will delegate to writeDefaultNamespace

Parameters:
prefix - the prefix to bind this namespace to
namespaceURI - the uri to bind the prefix to
Throws:
IllegalStateException - if the current state does not allow Namespace writing
XMLStreamException

writeDefaultNamespace

void writeDefaultNamespace(String namespaceURI)
                           throws XMLStreamException
Writes the default namespace to the stream

Parameters:
namespaceURI - the uri to bind the default namespace to
Throws:
IllegalStateException - if the current state does not allow Namespace writing
XMLStreamException

writeComment

void writeComment(String data)
                  throws XMLStreamException
Writes an xml comment with the data enclosed

Parameters:
data - the data contained in the comment, may be null
Throws:
XMLStreamException

writeProcessingInstruction

void writeProcessingInstruction(String target)
                                throws XMLStreamException
Writes a processing instruction

Parameters:
target - the target of the processing instruction, may not be null
Throws:
XMLStreamException

writeProcessingInstruction

void writeProcessingInstruction(String target,
                                String data)
                                throws XMLStreamException
Writes a processing instruction

Parameters:
target - the target of the processing instruction, may not be null
data - the data contained in the processing instruction, may not be null
Throws:
XMLStreamException

writeCData

void writeCData(String data)
                throws XMLStreamException
Writes a CData section

Parameters:
data - the data contained in the CData Section, may not be null
Throws:
XMLStreamException

writeDTD

void writeDTD(String dtd)
              throws XMLStreamException
Write a DTD section. This string represents the entire doctypedecl production from the XML 1.0 specification.

Parameters:
dtd - the DTD to be written
Throws:
XMLStreamException

writeEntityRef

void writeEntityRef(String name)
                    throws XMLStreamException
Writes an entity reference

Parameters:
name - the name of the entity
Throws:
XMLStreamException

writeStartDocument

void writeStartDocument()
                        throws XMLStreamException
Write the XML Declaration. Defaults the XML version to 1.0, and the encoding to utf-8

Throws:
XMLStreamException

writeStartDocument

void writeStartDocument(String version)
                        throws XMLStreamException
Write the XML Declaration. Defaults the XML version to 1.0

Parameters:
version - version of the xml document
Throws:
XMLStreamException

writeStartDocument

void writeStartDocument(String encoding,
                        String version)
                        throws XMLStreamException
Write the XML Declaration. Note that the encoding parameter does not set the actual encoding of the underlying output. That must be set when the instance of the XMLStreamWriter is created using the XMLOutputFactory

Parameters:
encoding - encoding of the xml declaration
version - version of the xml document
Throws:
XMLStreamException

writeCharacters

void writeCharacters(String text)
                     throws XMLStreamException
Write text to the output

Parameters:
text - the value to write
Throws:
XMLStreamException

writeCharacters

void writeCharacters(char[] text,
                     int start,
                     int len)
                     throws XMLStreamException
Write text to the output

Parameters:
text - the value to write
start - the starting position in the array
len - the number of characters to write
Throws:
XMLStreamException

getPrefix

String getPrefix(String uri)
                 throws XMLStreamException
Gets the prefix the uri is bound to

Returns:
the prefix or null
Throws:
XMLStreamException

setPrefix

void setPrefix(String prefix,
               String uri)
               throws XMLStreamException
Sets the prefix the uri is bound to. This prefix is bound in the scope of the current START_ELEMENT / END_ELEMENT pair. If this method is called before a START_ELEMENT has been written the prefix is bound in the root scope.

Parameters:
prefix - the prefix to bind to the uri, may not be null
uri - the uri to bind to the prefix, may be null
Throws:
XMLStreamException

setDefaultNamespace

void setDefaultNamespace(String uri)
                         throws XMLStreamException
Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair. If this method is called before a START_ELEMENT has been written the uri is bound in the root scope.

Parameters:
uri - the uri to bind to the default namespace, may be null
Throws:
XMLStreamException

setNamespaceContext

void setNamespaceContext(NamespaceContext context)
                         throws XMLStreamException
Sets the current namespace context for prefix and uri bindings. This context becomes the root namespace context for writing and will replace the current root namespace context. Subsequent calls to setPrefix and setDefaultNamespace will bind namespaces using the context passed to the method as the root context for resolving namespaces. This method may only be called once at the start of the document. It does not cause the namespaces to be declared. If a namespace URI to prefix mapping is found in the namespace context it is treated as declared and the prefix may be used by the StreamWriter.

Parameters:
context - the namespace context to use for this writer, may not be null
Throws:
XMLStreamException

getNamespaceContext

NamespaceContext getNamespaceContext()
Returns the current namespace context.

Returns:
the current NamespaceContext

getProperty

Object getProperty(String name)
                   throws IllegalArgumentException
Get the value of a feature/property from the underlying implementation

Parameters:
name - The name of the property, may not be null
Returns:
The value of the property
Throws:
IllegalArgumentException - if the property is not supported
NullPointerException - if the name is null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ws

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.ws

This package contains the core JAX-WS APIs.

See:
Description

Interface Summary
AsyncHandler<T> | The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.
Binding | The Binding interface is the base interface for JAX-WS protocol bindings.
BindingProvider | The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.
Dispatch<T> | The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
LogicalMessage | The LogicalMessage interface represents a protocol agnostic XML message and contains methods that provide access to the payload of the message.
Provider<T> | Service endpoints may implement the Provider interface as a dynamic alternative to an SEI.
Response<T> | The Response interface provides methods used to obtain the payload and context of a message sent in response to an operation invocation.
WebServiceContext | A WebServiceContext makes it possible for a web service endpoint implementation class to access message context and security information relative to a request being served.

Class Summary
Endpoint | A Web service endpoint.
Holder<T> | Holds a value of type T.
Service | Service objects provide the client view of a Web service.
WebServicePermission | This class defines web service permissions.

Enum Summary
Service.Mode The orientation of a dynamic client or service.

Exception Summary
ProtocolException | The ProtocolException class is a base class for exceptions related to a specific protocol binding.
WebServiceException | The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.

Annotation Types Summary
BindingType | The BindingType annotation is used to specify the binding to use for a web service endpoint implementation class.
RequestWrapper | Used to annotate methods in the Service Endpoint Interface with the request wrapper bean to be used at runtime.
ResponseWrapper | Used to annotate methods in the Service Endpoint Interface with the response wrapper bean to be used at runtime.
ServiceMode | Used to indicate whether a Provider implementation wishes to work with entire protocol messages or just with protocol message payloads.
WebEndpoint | Used to annotate the getPortName() methods of a generated service interface.
WebFault | Used to annotate service specific exception classes to customize to the local and namespace name of the fault element and the name of the fault bean.
WebServiceClient | Used to annotate a generated service interface.
WebServiceProvider | Used to annotate a Provider implementation class.
WebServiceRef | The WebServiceRef annotation is used to define a reference to a web service and (optionally) an injection target for it.
WebServiceRefs | The WebServiceRefs annotation allows multiple web service references to be declared at the class level.

Package javax.xml.ws Description

This package contains the core JAX-WS APIs.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.ws Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.ws

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.Endpoint
    • javax.xml.ws.Holder<T>
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.xml.ws.WebServicePermission
    • javax.xml.ws.Service
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException

Interface Hierarchy

  • javax.xml.ws.AsyncHandler<T>
  • javax.xml.ws.Binding
  • javax.xml.ws.BindingProvider
    • javax.xml.ws.Dispatch<T>
  • java.util.concurrent.Future<V>
    • javax.xml.ws.Response<T>
  • javax.xml.ws.LogicalMessage
  • javax.xml.ws.Provider<T>
  • javax.xml.ws.WebServiceContext

Annotation Type Hierarchy

  • javax.xml.ws.BindingType (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RequestWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ResponseWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ServiceMode (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebEndpoint (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebFault (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceClient (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceProvider (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRef (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRefs (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.ws.Service.Mode
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


AsyncHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Interface AsyncHandler<T>

public interface AsyncHandler<T>

The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.

Since:
JAX-WS 2.0

Method Summary
 void handleResponse(Response<T> res)
Called when the response to an asynchronous operation is available.

Method Detail

handleResponse

void handleResponse(Response<T> res)
Called when the response to an asynchronous operation is available.

Parameters:
res - The response to the operation invocation.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Binding

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Interface Binding

All Known Subinterfaces:
HTTPBinding, SOAPBinding
public interface Binding

The Binding interface is the base interface for JAX-WS protocol bindings.

Since:
JAX-WS 2.0

Method Summary
List<Handler> | getHandlerChain() Gets a copy of the handler chain for a protocol binding instance.
void | setHandlerChain(List<Handler> chain) Sets the handler chain for the protocol binding instance.

Method Detail

getHandlerChain

List<Handler> getHandlerChain()
Gets a copy of the handler chain for a protocol binding instance. If the returned chain is modified a call to setHandlerChain is required to configure the binding instance with the new chain.

Returns:
java.util.List Handler chain

setHandlerChain

void setHandlerChain(List<Handler> chain)
Sets the handler chain for the protocol binding instance.

Parameters:
chain - A List of handler configuration entries
Throws:
WebServiceException - On an error in the configuration of the handler chain
UnsupportedOperationException - If this operation is not supported. This may be done to avoid any overriding of a pre-configured handler chain.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BindingProvider

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Interface BindingProvider

All Known Subinterfaces:
Dispatch<T>
public interface BindingProvider

The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.

Since:
JAX-WS 2.0
See Also:
Binding

Field Summary
static String | ENDPOINT_ADDRESS_PROPERTY Standard property: Target service endpoint address.
static String | PASSWORD_PROPERTY Standard property: Password for authentication.
static String | SESSION_MAINTAIN_PROPERTY Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.
static String | SOAPACTION_URI_PROPERTY Standard property for SOAPAction.
static String | SOAPACTION_USE_PROPERTY Standard property for SOAPAction.
static String | USERNAME_PROPERTY Standard property: User name for authentication.
Method Summary
Binding | getBinding() Get the Binding for this binding provider.
Map<String,Object> | getRequestContext() Get the context that is used to initialize the message context for request messages.
Map<String,Object> | getResponseContext() Get the context that resulted from processing a response message.

Field Detail

USERNAME_PROPERTY

static final String USERNAME_PROPERTY
Standard property: User name for authentication.

Type: java.lang.String

See Also:
Constant Field Values

PASSWORD_PROPERTY

static final String PASSWORD_PROPERTY
Standard property: Password for authentication.

Type: java.lang.String

See Also:
Constant Field Values

ENDPOINT_ADDRESS_PROPERTY

static final String ENDPOINT_ADDRESS_PROPERTY
Standard property: Target service endpoint address. The URI scheme for the endpoint address specification must correspond to the protocol/transport binding for the binding in use.

Type: java.lang.String

See Also:
Constant Field Values

SESSION_MAINTAIN_PROPERTY

static final String SESSION_MAINTAIN_PROPERTY
Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint. If this property is set to true, the service client indicates that it wants the session to be maintained. If set to false, the session is not maintained. The default value for this property is false.

Type: java.lang.Boolean

See Also:
Constant Field Values

SOAPACTION_USE_PROPERTY

static final String SOAPACTION_USE_PROPERTY
Standard property for SOAPAction. This boolean property indicates whether or not SOAPAction is to be used. The default value of this property is false indicating that the SOAPAction is not used.

Type: java.lang.Boolean

See Also:
Constant Field Values

SOAPACTION_URI_PROPERTY

static final String SOAPACTION_URI_PROPERTY
Standard property for SOAPAction. Indicates the SOAPAction URI if the javax.xml.ws.soap.http.soapaction.use property is set to true.

Type: java.lang.String

See Also:
Constant Field Values
Method Detail

getRequestContext

Map<String,Object> getRequestContext()
Get the context that is used to initialize the message context for request messages. Modifications to the request context do not affect the message context of either synchronous or asynchronous operations that have already been started.

Returns:
The context that is used in processing request messages.

getResponseContext

Map<String,Object> getResponseContext()
Get the context that resulted from processing a response message. The returned context is for the most recently completed synchronous operation. Subsequent synchronous operation invocations overwrite the response context. Asynchronous operations return their response context via the Response interface.

Returns:
The context that resulted from processing the latest response messages.

getBinding

Binding getBinding()
Get the Binding for this binding provider.

Returns:
The Binding for this binding provider.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


BindingType

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.ws
Annotation Type BindingType

@Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface BindingType

The BindingType annotation is used to specify the binding to use for a web service endpoint implementation class.

This annotation may be overriden programmatically or via deployment descriptors, depending on the platform in use.

Since:
JAX-WS 2.0

Optional Element Summary
 String value
A binding identifier (a URI).

value

public abstract String value
A binding identifier (a URI). If not specified, the default is the SOAP 1.1 / HTTP binding.

See the SOAPBinding and HTTPBinding for the definition of the standard binding identifiers.

See Also:
Binding, SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING
Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Dispatch

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Interface Dispatch<T>

All Superinterfaces:
BindingProvider
public interface Dispatch<T>
extends BindingProvider

The Dispatch interface provides support for the dynamic invocation of a service endpoint operations. The javax.xml.ws.Service interface acts as a factory for the creation of Dispatch instances.

Since:
JAX-WS 2.0

Field Summary
Fields inherited from interface javax.xml.ws.BindingProvider
ENDPOINT_ADDRESS_PROPERTY, PASSWORD_PROPERTY, SESSION_MAINTAIN_PROPERTY, SOAPACTION_URI_PROPERTY, SOAPACTION_USE_PROPERTY, USERNAME_PROPERTY
Method Summary
T | invoke(T msg) Invoke a service operation synchronously.
Response<T> | invokeAsync(T msg) Invoke a service operation asynchronously.
Future<?> | invokeAsync(T msg, AsyncHandler<T> handler) Invoke a service operation asynchronously.
void | invokeOneWay(T msg) Invokes a service operation using the one-way interaction mode.
Methods inherited from interface javax.xml.ws.BindingProvider
getBinding, getRequestContext, getResponseContext

Method Detail

invoke

T invoke(T msg)
Invoke a service operation synchronously. The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.

Parameters:
msg - An object that will form the message or payload of the message used to invoke the operation.
Returns:
The response message or message payload to the operation invocation.
Throws:
WebServiceException - If a fault occurs during communication with the service
WebServiceException - If there is any error in the configuration of the Dispatch instance

invokeAsync

Response<T> invokeAsync(T msg)
Invoke a service operation asynchronously. The method returns without waiting for the response to the operation invocation, the results of the operation are obtained by polling the returned Response. The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.

Parameters:
msg - An object that will form the message or payload of the message used to invoke the operation.
Returns:
The response message or message payload to the operation invocation.
Throws:
WebServiceException - If there is any error in the configuration of the Dispatch instance

invokeAsync

Future<?> invokeAsync(T msg,
                      AsyncHandler<T> handler)
Invoke a service operation asynchronously. The method returns without waiting for the response to the operation invocation, the results of the operation are communicated to the client via the passed in handler. The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.

Parameters:
msg - An object that will form the message or payload of the message used to invoke the operation.
handler - The handler object that will receive the response to the operation invocation.
Returns:
A Future object that may be used to check the status of the operation invocation. This object must not be used to try to obtain the results of the operation - the object returned from Future.get() is implementation dependent and any use of it will result in non-portable behaviour.
Throws:
WebServiceException - If there is any error in the configuration of the Dispatch instance

invokeOneWay

void invokeOneWay(T msg)
Invokes a service operation using the one-way interaction mode. The operation invocation is logically non-blocking, subject to the capabilities of the underlying protocol, no results are returned. When the protocol in use is SOAP/HTTP, this method must block until an HTTP response code has been received or an error occurs. The client is responsible for ensuring that the msg object when marshalled is formed according to the requirements of the protocol binding in use.

Parameters:
msg - An object that will form the message or payload of the message used to invoke the operation.
Throws:
WebServiceException - If there is any error in the configuration of the Dispatch instance or if an error occurs during the invocation.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Endpoint

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Class Endpoint

java.lang.Object
    extended by  javax.xml.ws.Endpoint

public abstract class Endpoint
extends Object

A Web service endpoint.

Endpoints are created using the static methods defined in this class. An endpoint is always tied to one Binding and one implementor, both set at endpoint creation time.

An endpoint is either in a published or an unpublished state. The publish methods can be used to start publishing an endpoint, at which point it starts accepting incoming requests. Conversely, the stop method can be used to stop accepting incoming requests and take the endpoint down. Once stopped, an endpoint cannot be published again.

An Executor may be set on the endpoint in order to gain better control over the threads used to dispatch incoming requests. For instance, thread pooling with certain parameters can be enabled by creating a ThreadPoolExecutor and registering it with the endpoint.

Handler chains can be set using the contained Binding.

An endpoint may have a list of metadata documents, such as WSDL and XMLSchema documents, bound to it. At publishing time, the JAX-WS implementation will try to reuse as much of that metadata as possible instead of generating new one based on the annotations present on the implementor.

Since:
JAX-WS 2.0
See Also:
Binding, BindingType, SOAPBinding, Executor

Field Summary
static String | WSDL_PORT Standard property: name of WSDL port.
static String | WSDL_SERVICE Standard property: name of WSDL service.
Constructor Summary
Endpoint()
Method Summary
static Endpoint | create(Object implementor) Creates an endpoint with the specified implementor object.
static Endpoint | create(String bindingId, Object implementor) Creates an endpoint with the specified binding type and implementor object.
abstract Binding | getBinding() Returns the binding for this endpoint.
abstract Executor | getExecutor() Returns the executor for this Endpointinstance.
abstract Object | getImplementor() Returns the implementation object for this endpoint.
abstract List<Source> | getMetadata() Returns a list of metadata documents for the service.
abstract Map<String,Object> | getProperties() Returns the property bag for this Endpoint instance.
abstract boolean | isPublished() Returns true if the endpoint is in the published state.
abstract void | publish(Object serverContext) Publishes this endpoint at the provided server context.
abstract void | publish(String address) Publishes this endpoint at the given address.
static Endpoint | publish(String address, Object implementor) Creates and publishes an endpoint for the specified implementor object at the given address.
abstract void | setExecutor(Executor executor) Sets the executor for this Endpoint instance.
abstract void | setMetadata(List<Source> metadata) Sets the metadata for this endpoint.
abstract void | setProperties(Map<String,Object> properties) Sets the property bag for this Endpoint instance.
abstract void | stop() Stops publishing this endpoint.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

WSDL_SERVICE

public static final String WSDL_SERVICE
Standard property: name of WSDL service.

Type: javax.xml.namespace.QName

See Also:
Constant Field Values

WSDL_PORT

public static final String WSDL_PORT
Standard property: name of WSDL port.

Type: javax.xml.namespace.QName

See Also:
Constant Field Values
Constructor Detail

Endpoint

public Endpoint()
Method Detail

create

public static Endpoint create(Object implementor)
Creates an endpoint with the specified implementor object. If there is a binding specified via a BindingType annotation then it MUST be used else a default of SOAP 1.1 / HTTP binding MUST be used.

The newly created endpoint may be published by calling one of the javax.xml.ws.Endpoint#publish(String) and javax.xml.ws.Endpoint#publish(Object) methods.

Parameters:
implementor - The endpoint implementor.
Returns:
The newly created endpoint.

create

public static Endpoint create(String bindingId,
                              Object implementor)
Creates an endpoint with the specified binding type and implementor object.

The newly created endpoint may be published by calling one of the javax.xml.ws.Endpoint#publish(String) and javax.xml.ws.Endpoint#publish(Object) methods.

Parameters:
bindingId - A URI specifying the binding to use. If the bindingID is null and no binding is specified via a BindingType annotation then a default SOAP 1.1 / HTTP binding MUST be used.
implementor - The endpoint implementor.
Returns:
The newly created endpoint.

getBinding

public abstract Binding getBinding()
Returns the binding for this endpoint.

Returns:
The binding for this endpoint

getImplementor

public abstract Object getImplementor()
Returns the implementation object for this endpoint.

Returns:
The implementor for this endpoint

publish

public abstract void publish(String address)
Publishes this endpoint at the given address. The necessary server infrastructure will be created and configured by the JAX-WS implementation using some default configuration. In order to get more control over the server configuration, please use the javax.xml.ws.Endpoint#publish(Object) method instead.

Parameters:
address - A URI specifying the address to use. The address must be compatible with the binding specified at the time the endpoint was created.
Throws:
IllegalArgumentException - If the provided address URI is not usable in conjunction with the endpoint's binding.
IllegalStateException - If the endpoint has been published already or it has been stopped.

publish

public static Endpoint publish(String address,
                               Object implementor)
Creates and publishes an endpoint for the specified implementor object at the given address.

The necessary server infrastructure will be created and configured by the JAX-WS implementation using some default configuration. In order to get more control over the server configuration, please use the javax.xml.ws.Endpoint#create(String,Object) and javax.xml.ws.Endpoint#publish(Object) method instead.

Parameters:
address - A URI specifying the address and transport/protocol to use. A http: URI must result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
implementor - The endpoint implementor.
Returns:
The newly created endpoint.

publish

public abstract void publish(Object serverContext)
Publishes this endpoint at the provided server context. A server context encapsulates the server infrastructure and addressing information for a particular transport. For a call to this method to succeed, the server context passed as an argument to it must be compatible with the endpoint's binding.

Parameters:
serverContext - An object representing a server context to be used for publishing the endpoint.
Throws:
IllegalArgumentException - If the provided server context is not supported by the implementation or turns out to be unusable in conjunction with the endpoint's binding.
IllegalStateException - If the endpoint has been published already or it has been stopped.

stop

public abstract void stop()
Stops publishing this endpoint. If the endpoint is not in a published state, this method has not effect.

isPublished

public abstract boolean isPublished()
Returns true if the endpoint is in the published state.

Returns:
true if the endpoint is in the published state.

getMetadata

public abstract List<Source> getMetadata()
Returns a list of metadata documents for the service.

Returns:
List<javax.xml.transform.Source> A list of metadata documents for the service

setMetadata

public abstract void setMetadata(List<Source> metadata)
Sets the metadata for this endpoint.

Parameters:
metadata - A list of XML document sources containing metadata information for the endpoint (e.g. WSDL or XML Schema documents)
Throws:
IllegalStateException - If the endpoint has already been published.

getExecutor

public abstract Executor getExecutor()
Returns the executor for this Endpointinstance. The executor is used to dispatch an incoming request to the implementor object.

Returns:
The java.util.concurrent.Executor to be used to dispatch a request.
See Also:
Executor

setExecutor

public abstract void setExecutor(Executor executor)
Sets the executor for this Endpoint instance. The executor is used to dispatch an incoming request to the implementor object. If this Endpoint is published using the publish(Object) method and the specified server context defines its own threading behavior, the executor may be ignored.

Parameters:
executor - The java.util.concurrent.Executor to be used to dispatch a request.
Throws:
SecurityException - If the instance does not support setting an executor for security reasons (e.g. the necessary permissions are missing).
See Also:
Executor

getProperties

public abstract Map<String,Object> getProperties()
Returns the property bag for this Endpoint instance.

Returns:
Map<String,Object> The property bag associated with this instance.

setProperties

public abstract void setProperties(Map<String,Object> properties)
Sets the property bag for this Endpoint instance.

Parameters:
properties - The property bag associated with this instance.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


handler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.ws.handler

This package defines APIs for message handlers.

See:
Description

Interface Summary
Handler<C extends MessageContext> | The Handler interface is the base interface for JAX-WS handlers.
HandlerResolver | HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.
LogicalHandler<C extends LogicalMessageContext> | The LogicalHandler extends Handler to provide typesafety for the message context parameter.
LogicalMessageContext | The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
MessageContext | The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
PortInfo | The PortInfo interface is used by a HandlerResolver to query information about the port it is being asked to create a handler chain for.

Enum Summary
MessageContext.Scope Property scope.

Package javax.xml.ws.handler Description

This package defines APIs for message handlers.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.ws.handler Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.ws.handler

Package Hierarchies:
All Packages

Interface Hierarchy

  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.LogicalHandler<C>
  • javax.xml.ws.handler.HandlerResolver
  • java.util.Map<K,V>
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.LogicalMessageContext
  • javax.xml.ws.handler.PortInfo

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.xml.ws.handler.MessageContext.Scope
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LogicalHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.handler
Interface LogicalHandler<C extends LogicalMessageContext>

All Superinterfaces:
Handler<C>
public interface LogicalHandler<C extends LogicalMessageContext>
extends Handler<C>

The LogicalHandler extends Handler to provide typesafety for the message context parameter.

Since:
JAX-WS 2.0

Method Summary
Methods inherited from interface javax.xml.ws.handler.Handler
close, handleFault, handleMessage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Handler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.handler
Interface Handler<C extends MessageContext>

All Known Subinterfaces:
LogicalHandler<C>, SOAPHandler<T>
public interface Handler<C extends MessageContext>

The Handler interface is the base interface for JAX-WS handlers.

Since:
JAX-WS 2.0

Method Summary
void | close(MessageContext context) Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime disptaching a message, fault or exception.
boolean | handleFault(C context) The handleFault method is invoked for fault message processing.
boolean | handleMessage(C context) The handleMessage method is invoked for normal processing of inbound and outbound messages.

Method Detail

handleMessage

boolean handleMessage(C context)
The handleMessage method is invoked for normal processing of inbound and outbound messages. Refer to the description of the handler framework in the JAX-WS specification for full details.

Parameters:
context - the message context.
Returns:
An indication of whether handler processing should continue for the current message
  • Return true to continue processing.
  • Return false to block processing.
Throws:
RuntimeException - Causes the JAX-WS runtime to cease handler processing and generate a fault.
ProtocolException - Causes the JAX-WS runtime to switch to fault message processing.

handleFault

boolean handleFault(C context)
The handleFault method is invoked for fault message processing. Refer to the description of the handler framework in the JAX-WS specification for full details.

Parameters:
context - the message context
Returns:
An indication of whether handler fault processing should continue for the current message
  • Return true to continue processing.
  • Return false to block processing.
Throws:
RuntimeException - Causes the JAX-WS runtime to cease handler fault processing and dispatch the fault.
ProtocolException - Causes the JAX-WS runtime to cease handler fault processing and dispatch the fault.

close

void close(MessageContext context)
Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime disptaching a message, fault or exception. Refer to the description of the handler framework in the JAX-WS specification for full details.

Parameters:
context - the message context
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HandlerResolver

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.handler
Interface HandlerResolver

public interface HandlerResolver

HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.

A HandlerResolver may be set on a Service using the setHandlerResolver method.

When the runtime invokes a HandlerResolver, it will pass it a PortInfo object containing information about the port that the proxy/dispatch object will be accessing.

Since:
JAX-WS 2.0
See Also:
Service.setHandlerResolver(javax.xml.ws.handler.HandlerResolver)

Method Summary
 List<Handler> getHandlerChain(PortInfo portInfo)
Gets the handler chain for the specified port.

Method Detail

getHandlerChain

List<Handler> getHandlerChain(PortInfo portInfo)
Gets the handler chain for the specified port.

Parameters:
portInfo - Contains information about the port being accessed.
Returns:
java.util.List Handler chain
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LogicalMessageContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.handler
Interface LogicalMessageContext

All Superinterfaces:
Map<String,Object>, MessageContext
public interface LogicalMessageContext
extends MessageContext

The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage

Since:
JAX-WS 2.0

Nested Class Summary
Nested classes/interfaces inherited from interface javax.xml.ws.handler.MessageContext
MessageContext.Scope
Nested classes/interfaces inherited from interface java.util.Map
Map.Entry<K,V>
Field Summary
Fields inherited from interface javax.xml.ws.handler.MessageContext
HTTP_REQUEST_HEADERS, HTTP_REQUEST_METHOD, HTTP_RESPONSE_CODE, HTTP_RESPONSE_HEADERS, INBOUND_MESSAGE_ATTACHMENTS, MESSAGE_OUTBOUND_PROPERTY, OUTBOUND_MESSAGE_ATTACHMENTS, PATH_INFO, QUERY_STRING, SERVLET_CONTEXT, SERVLET_REQUEST, SERVLET_RESPONSE, WSDL_DESCRIPTION, WSDL_INTERFACE, WSDL_OPERATION, WSDL_PORT, WSDL_SERVICE
Method Summary
 LogicalMessage getMessage()
Gets the message from this message context
Methods inherited from interface javax.xml.ws.handler.MessageContext
getScope, setScope
Methods inherited from interface java.util.Map
clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

Method Detail

getMessage

LogicalMessage getMessage()
Gets the message from this message context

Returns:
The contained message; returns null if no message is present in this message context
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.handler
Interface MessageContext

All Superinterfaces:
Map<String,Object>
All Known Subinterfaces:
LogicalMessageContext, SOAPMessageContext
public interface MessageContext
extends Map<String,Object>

The interface MessageContext abstracts the message context that is processed by a handler in the handle method.

The MessageContext interface provides methods to manage a property set. MessageContext properties enable handlers in a handler chain to share processing related state.

Since:
JAX-WS 2.0

Nested Class Summary
static class MessageContext.Scope
Property scope.
Nested classes/interfaces inherited from interface java.util.Map
Map.Entry<K,V>
Field Summary
static String | HTTP_REQUEST_HEADERS Standard property: HTTP request headers.
static String | HTTP_REQUEST_METHOD Standard property: HTTP request method.
static String | HTTP_RESPONSE_CODE Standard property: HTTP response status code.
static String | HTTP_RESPONSE_HEADERS Standard property: HTTP response headers.
static String | INBOUND_MESSAGE_ATTACHMENTS Standard property: Map of attachments to a message for the inbound message, key is the MIME Content-ID, value is a DataHandler.
static String | MESSAGE_OUTBOUND_PROPERTY Standard property: message direction, true for outbound messages, false for inbound.
static String | OUTBOUND_MESSAGE_ATTACHMENTS Standard property: Map of attachments to a message for the outbound message, key is the MIME Content-ID, value is a DataHandler.
static String | PATH_INFO Standard property: Request Path Info Type: String
static String | QUERY_STRING Standard property: Query string for request.
static String | SERVLET_CONTEXT Standard property: servlet context object.
static String | SERVLET_REQUEST Standard property: servlet request object.
static String | SERVLET_RESPONSE Standard property: servlet response object.
static String | WSDL_DESCRIPTION Standard property: input source for WSDL document.
static String | WSDL_INTERFACE Standard property: name of wsdl interface (2.0) or port type (1.1).
static String | WSDL_OPERATION Standard property: name of WSDL operation.
static String | WSDL_PORT Standard property: name of WSDL port.
static String | WSDL_SERVICE Standard property: name of WSDL service.
Method Summary
MessageContext.Scope | getScope(String name) Gets the scope of a property.
void | setScope(String name, MessageContext.Scope scope) Sets the scope of a property.
Methods inherited from interface java.util.Map
clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

Field Detail

MESSAGE_OUTBOUND_PROPERTY

static final String MESSAGE_OUTBOUND_PROPERTY
Standard property: message direction, true for outbound messages, false for inbound.

Type: boolean

See Also:
Constant Field Values

INBOUND_MESSAGE_ATTACHMENTS

static final String INBOUND_MESSAGE_ATTACHMENTS
Standard property: Map of attachments to a message for the inbound message, key is the MIME Content-ID, value is a DataHandler.

Type: java.util.Map

See Also:
Constant Field Values

OUTBOUND_MESSAGE_ATTACHMENTS

static final String OUTBOUND_MESSAGE_ATTACHMENTS
Standard property: Map of attachments to a message for the outbound message, key is the MIME Content-ID, value is a DataHandler.

Type: java.util.Map

See Also:
Constant Field Values

WSDL_DESCRIPTION

static final String WSDL_DESCRIPTION
Standard property: input source for WSDL document.

Type: org.xml.sax.InputSource

See Also:
Constant Field Values

WSDL_SERVICE

static final String WSDL_SERVICE
Standard property: name of WSDL service.

Type: javax.xml.namespace.QName

See Also:
Constant Field Values

WSDL_PORT

static final String WSDL_PORT
Standard property: name of WSDL port.

Type: javax.xml.namespace.QName

See Also:
Constant Field Values

WSDL_INTERFACE

static final String WSDL_INTERFACE
Standard property: name of wsdl interface (2.0) or port type (1.1).

Type: javax.xml.namespace.QName

See Also:
Constant Field Values

WSDL_OPERATION

static final String WSDL_OPERATION
Standard property: name of WSDL operation.

Type: javax.xml.namespace.QName

See Also:
Constant Field Values

HTTP_RESPONSE_CODE

static final String HTTP_RESPONSE_CODE
Standard property: HTTP response status code.

Type: java.lang.Integer

See Also:
Constant Field Values

HTTP_REQUEST_HEADERS

static final String HTTP_REQUEST_HEADERS
Standard property: HTTP request headers.

Type: java.util.Map>

See Also:
Constant Field Values

HTTP_RESPONSE_HEADERS

static final String HTTP_RESPONSE_HEADERS
Standard property: HTTP response headers.

Type: java.util.Map>

See Also:
Constant Field Values

HTTP_REQUEST_METHOD

static final String HTTP_REQUEST_METHOD
Standard property: HTTP request method.

Type: java.lang.String

See Also:
Constant Field Values

SERVLET_REQUEST

static final String SERVLET_REQUEST
Standard property: servlet request object.

Type: javax.servlet.http.HttpServletRequest

See Also:
Constant Field Values

SERVLET_RESPONSE

static final String SERVLET_RESPONSE
Standard property: servlet response object.

Type: javax.servlet.http.HttpServletResponse

See Also:
Constant Field Values

SERVLET_CONTEXT

static final String SERVLET_CONTEXT
Standard property: servlet context object.

Type: javax.servlet.ServletContext

See Also:
Constant Field Values

QUERY_STRING

static final String QUERY_STRING
Standard property: Query string for request.

Type: String

See Also:
Constant Field Values

PATH_INFO

static final String PATH_INFO
Standard property: Request Path Info

Type: String

See Also:
Constant Field Values
Method Detail

setScope

void setScope(String name,
              MessageContext.Scope scope)
Sets the scope of a property.

Parameters:
name - Name of the property associated with the MessageContext
scope - Desired scope of the property
Throws:
IllegalArgumentException - if an illegal property name is specified

getScope

MessageContext.Scope getScope(String name)
Gets the scope of a property.

Parameters:
name - Name of the property
Returns:
Scope of the property
Throws:
IllegalArgumentException - if a non-existant property name is specified
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


MessageContext.Scope

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.xml.ws.handler
Enum MessageContext.Scope

java.lang.Object
    extended by  java.lang.Enum<MessageContext.Scope>
        extended by  javax.xml.ws.handler.MessageContext.Scope
All Implemented Interfaces:
Serializable, Comparable<MessageContext.Scope>
Enclosing interface:
MessageContext
public static enum MessageContext.Scope
extends Enum<MessageContext.Scope>

Property scope. Properties scoped as APPLICATION are visible to handlers, client applications and service endpoints; properties scoped as HANDLER are only normally visible to handlers.

Enum Constant Summary
APPLICATION
HANDLER
Method Summary
static MessageContext.Scope | valueOf(String name) Returns the enum constant of this type with the specified name.
static MessageContext.Scope[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

APPLICATION

public static final MessageContext.Scope APPLICATION

HANDLER

public static final MessageContext.Scope HANDLER
Method Detail

values

public static final MessageContext.Scope[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(MessageContext.Scope c : MessageContext.Scope.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static MessageContext.Scope valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


PortInfo

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.handler
Interface PortInfo

public interface PortInfo

The PortInfo interface is used by a HandlerResolver to query information about the port it is being asked to create a handler chain for.

This interface is never implemented by an application, only by a JAX-WS implementation.

Since:
JAX-WS 2.0

Method Summary
String | getBindingID() Gets the URI identifying the binding used by the port being accessed.
QName | getPortName() Gets the qualified name of the WSDL port being accessed.
QName | getServiceName() Gets the qualified name of the WSDL service name containing the port being accessed.

Method Detail

getServiceName

QName getServiceName()
Gets the qualified name of the WSDL service name containing the port being accessed.

Returns:
javax.xml.namespace.QName The qualified name of the WSDL service.

getPortName

QName getPortName()
Gets the qualified name of the WSDL port being accessed.

Returns:
javax.xml.namespace.QName The qualified name of the WSDL port.

getBindingID

String getBindingID()
Gets the URI identifying the binding used by the port being accessed.

Returns:
String The binding identifier for the port.
See Also:
Binding
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


soap

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.ws.handler.soap

This package defines APIs for SOAP message handlers.

See:
Description

Interface Summary
SOAPHandler<T extends SOAPMessageContext> | The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.
SOAPMessageContext | The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response.

Package javax.xml.ws.handler.soap Description

This package defines APIs for SOAP message handlers.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.ws.handler.soap Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.ws.handler.soap

Package Hierarchies:
All Packages

Interface Hierarchy

  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.soap.SOAPHandler<T>
  • java.util.Map<K,V>
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.soap.SOAPMessageContext
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPHandler

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.handler.soap
Interface SOAPHandler<T extends SOAPMessageContext>

All Superinterfaces:
Handler<T>
public interface SOAPHandler<T extends SOAPMessageContext>
extends Handler<T>

The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.

Since:
JAX-WS 2.0

Method Summary
 Set<QName> getHeaders()
Gets the header blocks that can be processed by this Handler instance.
Methods inherited from interface javax.xml.ws.handler.Handler
close, handleFault, handleMessage

Method Detail

getHeaders

Set<QName> getHeaders()
Gets the header blocks that can be processed by this Handler instance.

Returns:
Set of QNames of header blocks processed by this handler instance. QName is the qualified name of the outermost element of the Header block.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPMessageContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.handler.soap
Interface SOAPMessageContext

All Superinterfaces:
Map<String,Object>, MessageContext
public interface SOAPMessageContext
extends MessageContext

The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response. The javax.xml.soap.SOAPMessage specifies the standard Java API for the representation of a SOAP 1.1 message with attachments.

Since:
JAX-WS 2.0
See Also:
SOAPMessage

Nested Class Summary
Nested classes/interfaces inherited from interface javax.xml.ws.handler.MessageContext
MessageContext.Scope
Nested classes/interfaces inherited from interface java.util.Map
Map.Entry<K,V>
Field Summary
Fields inherited from interface javax.xml.ws.handler.MessageContext
HTTP_REQUEST_HEADERS, HTTP_REQUEST_METHOD, HTTP_RESPONSE_CODE, HTTP_RESPONSE_HEADERS, INBOUND_MESSAGE_ATTACHMENTS, MESSAGE_OUTBOUND_PROPERTY, OUTBOUND_MESSAGE_ATTACHMENTS, PATH_INFO, QUERY_STRING, SERVLET_CONTEXT, SERVLET_REQUEST, SERVLET_RESPONSE, WSDL_DESCRIPTION, WSDL_INTERFACE, WSDL_OPERATION, WSDL_PORT, WSDL_SERVICE
Method Summary
Object[] | getHeaders(QName header, JAXBContext context, boolean allRoles) Gets headers that have a particular qualified name from the message in the message context.
SOAPMessage | getMessage() Gets the SOAPMessage from this message context.
Set<String> | getRoles() Gets the SOAP actor roles associated with an execution of the handler chain.
void | setMessage(SOAPMessage message) Sets the SOAPMessage in this message context
Methods inherited from interface javax.xml.ws.handler.MessageContext
getScope, setScope
Methods inherited from interface java.util.Map
clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

Method Detail

getMessage

SOAPMessage getMessage()
Gets the SOAPMessage from this message context. Modifications to the returned SOAPMessage change the message in-place, there is no need to susequently call setMessage.

Returns:
Returns the SOAPMessage; returns null if no SOAPMessage is present in this message context

setMessage

void setMessage(SOAPMessage message)
Sets the SOAPMessage in this message context

Parameters:
message - SOAP message
Throws:
WebServiceException - If any error during the setting of the SOAPMessage in this message context
UnsupportedOperationException - If this operation is not supported

getHeaders

Object[] getHeaders(QName header,
                    JAXBContext context,
                    boolean allRoles)
Gets headers that have a particular qualified name from the message in the message context. Note that a SOAP message can contain multiple headers with the same qualified name.

Parameters:
header - The XML qualified name of the SOAP header(s).
context - The JAXBContext that should be used to unmarshall the header
allRoles - If true then returns headers for all SOAP roles, if false then only returns headers targetted at the roles currently being played by this SOAP node, see getRoles.
Returns:
An array of unmarshalled headers; returns an empty array if no message is present in this message context or no headers match the supplied qualified name.
Throws:
WebServiceException - If an error occurs when using the supplied JAXBContext to unmarshall. The cause of the WebServiceException is the original JAXBException.

getRoles

Set<String> getRoles()
Gets the SOAP actor roles associated with an execution of the handler chain. Note that SOAP actor roles apply to the SOAP node and are managed using SOAPBinding.setRoles and SOAPBinding.getRoles. Handler instances in the handler chain use this information about the SOAP actor roles to process the SOAP header blocks. Note that the SOAP actor roles are invariant during the processing of SOAP message through the handler chain.

Returns:
Array of String for SOAP actor roles
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Holder

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Class Holder<T>

java.lang.Object
    extended by  javax.xml.ws.Holder<T>

public final class Holder<T>
extends Object

Holds a value of type T.

Since:
JAX-WS 2.0

Field Summary
 T value
The value contained in the holder.
Constructor Summary
Holder()
Creates a new holder with a null value.
Holder(T value)
Create a new holder with the specified value.
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

public T value
The value contained in the holder.

Constructor Detail

Holder

public Holder()
Creates a new holder with a null value.

Holder

public Holder(T value)
Create a new holder with the specified value.

Parameters:
value - The value to be stored in the holder.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


http

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.ws.http

This package defines APIs specific to the HTTP binding.

See:
Description

Interface Summary
HTTPBinding The HTTPBinding interface is an abstraction for the XML/HTTP binding.

Exception Summary
HTTPException The HTTPException exception represents a XML/HTTP fault.

Package javax.xml.ws.http Description

This package defines APIs specific to the HTTP binding.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.ws.http Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.ws.http

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.http.HTTPException

Interface Hierarchy

  • javax.xml.ws.Binding
    • javax.xml.ws.http.HTTPBinding
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HTTPBinding

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.http
Interface HTTPBinding

All Superinterfaces:
Binding
public interface HTTPBinding
extends Binding

The HTTPBinding interface is an abstraction for the XML/HTTP binding.

Since:
JAX-WS 2.0

Field Summary
static String HTTP_BINDING
A constant representing the identity of the XML/HTTP binding.
Method Summary
Methods inherited from interface javax.xml.ws.Binding
getHandlerChain, setHandlerChain

Field Detail

HTTP_BINDING

static final String HTTP_BINDING
A constant representing the identity of the XML/HTTP binding.

See Also:
Constant Field Values
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


HTTPException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.http
Class HTTPException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.xml.ws.WebServiceException
                    extended by  javax.xml.ws.ProtocolException
                        extended by  javax.xml.ws.http.HTTPException
All Implemented Interfaces:
Serializable
public class HTTPException
extends ProtocolException

The HTTPException exception represents a XML/HTTP fault.

Since there is no standard format for faults or exceptions in XML/HTTP messaging, only the HTTP status code is captured.

Since:
JAX-WS 2.0
See Also:
Serialized Form

Constructor Summary
HTTPException(int statusCode)
Constructor for the HTTPException
Method Summary
 int getStatusCode()
Gets the HTTP status code.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HTTPException

public HTTPException(int statusCode)
Constructor for the HTTPException

Parameters:
statusCode - int for the HTTP status code
Method Detail

getStatusCode

public int getStatusCode()
Gets the HTTP status code.

Returns:
HTTP status code
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


LogicalMessage

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Interface LogicalMessage

public interface LogicalMessage

The LogicalMessage interface represents a protocol agnostic XML message and contains methods that provide access to the payload of the message.

Since:
JAX-WS 2.0

Method Summary
Source | getPayload() Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.
Object | getPayload(JAXBContext context) Gets the message payload as a JAXB object.
void | setPayload(Object payload, JAXBContext context) Sets the message payload
void | setPayload(Source payload) Sets the message payload

Method Detail

getPayload

Source getPayload()
Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.

If the returned Source is an instance of DOMSource, then modifications to the encapsulated DOM tree change the message payload in-place, there is no need to susequently call setPayload. Other types of Source provide only read access to the message payload.

Returns:
The contained message payload; returns null if no payload is present in this message.

setPayload

void setPayload(Source payload)
Sets the message payload

Parameters:
payload - message payload
Throws:
WebServiceException - If any error during the setting of the payload in this message
UnsupportedOperationException - If this operation is not supported

getPayload

Object getPayload(JAXBContext context)
Gets the message payload as a JAXB object. Note that there is no connection between the returned object and the message payload, changes to the payload require calling setPayload.

Parameters:
context - The JAXBContext that should be used to unmarshall the message payload
Returns:
The contained message payload; returns null if no payload is present in this message
Throws:
WebServiceException - If an error occurs when using a supplied JAXBContext to unmarshall the payload. The cause of the WebServiceException is the original JAXBException.

setPayload

void setPayload(Object payload,
                JAXBContext context)
Sets the message payload

Parameters:
payload - message payload
context - The JAXBContext that should be used to marshall the payload
Throws:
UnsupportedOperationException - If this operation is not supported
WebServiceException - If an error occurs when using the supplied JAXBContext to marshall the payload. The cause of the WebServiceException is the original JAXBException.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ProtocolException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Class ProtocolException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.xml.ws.WebServiceException
                    extended by  javax.xml.ws.ProtocolException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
HTTPException, SOAPFaultException
public class ProtocolException
extends WebServiceException

The ProtocolException class is a base class for exceptions related to a specific protocol binding. Subclasses are used to communicate protocol level fault information to clients and may be used on the server to control the protocol specific fault representation.

Since:
JAX-WS 2.0
See Also:
Serialized Form

Constructor Summary
ProtocolException()
Constructs a new protocol exception with null as its detail message.
ProtocolException(String message)
Constructs a new protocol exception with the specified detail message.
ProtocolException(String message, Throwable cause)
Constructs a new runtime exception with the specified detail message and cause.
ProtocolException(Throwable cause)
Constructs a new runtime exception with the specified cause and a detail message of (cause==null ?
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ProtocolException

public ProtocolException()
Constructs a new protocol exception with null as its detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).

ProtocolException

public ProtocolException(String message)
Constructs a new protocol exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to Throwable.initCause(java.lang.Throwable).

Parameters:
message - the detail message. The detail message is saved for later retrieval by the Throwable.getMessage() method.

ProtocolException

public ProtocolException(String message,
                         Throwable cause)
Constructs a new runtime exception with the specified detail message and cause. Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.

Parameters:
message - the detail message (which is saved for later retrieval by the Throwable.getMessage() method).
cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)

ProtocolException

public ProtocolException(Throwable cause)
Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause). This constructor is useful for runtime exceptions that are little more than wrappers for other throwables.

Parameters:
cause - the cause (which is saved for later retrieval by the Throwable.getCause() method). (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Provider

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Interface Provider<T>

public interface Provider<T>

Service endpoints may implement the Provider interface as a dynamic alternative to an SEI. Implementations are required to support Provider<Source> and Provider<SOAPMessage>. The ServiceMode annotation can be used to control whether the Provider instance will receive entire protocol messages or just message payloads.

Since:
JAX-WS 2.0
See Also:
Source, SOAPMessage, ServiceMode

Method Summary
 T invoke(T request)
Invokes an operation occording to the contents of the request message.

Method Detail

invoke

T invoke(T request)
Invokes an operation occording to the contents of the request message.

Parameters:
request - The request message or message payload.
Returns:
The response message or message payload. May be null if there is no response.
Throws:
WebServiceException - if there is an error processing request. The cause of the WebServiceException may be set to a subclass of ProtocolException to control the protocol level representation of the exception.
See Also:
MessageContext, ProtocolException
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


RequestWrapper

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.ws
Annotation Type RequestWrapper

@Target(value=METHOD)
@Retention(value=RUNTIME)
@Documented
public @interface RequestWrapper

Used to annotate methods in the Service Endpoint Interface with the request wrapper bean to be used at runtime. The default value of the localName is the operationName, as defined in WebMethod annotation and the targetNamespace is the target namespace of the SEI.

When starting from Java this annotation is used resolve overloading conflicts in document literal mode. Only the className is required in this case.

Since:
JAX-WS 2.0
See Also:
WebMethod

Optional Element Summary
String | className Request wrapper bean name.
String | localName Elements local name.
String | targetNamespace Elements namespace name.

localName

public abstract String localName
Elements local name.

Default:
""

targetNamespace

public abstract String targetNamespace
Elements namespace name.

Default:
""

className

public abstract String className
Request wrapper bean name.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Response

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Interface Response<T>

All Superinterfaces:
Future<T>
public interface Response<T>
extends Future<T>

The Response interface provides methods used to obtain the payload and context of a message sent in response to an operation invocation.

For asynchronous operation invocations it provides additional methods to check the status of the request. The get(...) methods may throw the standard set of exceptions and their cause may be a RemoteException or a WebServiceException that represents the error that occured during the asynchronous method invocation.

Since:
JAX-WS 2.0

Method Summary
 Map<String,Object> getContext()
Gets the contained response context.
Methods inherited from interface java.util.concurrent.Future
cancel, get, get, isCancelled, isDone

Method Detail

getContext

Map<String,Object> getContext()
Gets the contained response context.

Returns:
The contained response context. May be null if a response is not yet available.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ResponseWrapper

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.ws
Annotation Type ResponseWrapper

@Target(value=METHOD)
@Retention(value=RUNTIME)
@Documented
public @interface ResponseWrapper

Used to annotate methods in the Service Endpoint Interface with the response wrapper bean to be used at runtime. The default value of the localName is the operationName as defined in WebMethod annotation appended with Response and the targetNamespace is the target namespace of the SEI.

When starting from Java this annotation is used resolve overloading conflicts in document literal mode. Only the className is required in this case.

Since:
JAX-WS 2.0
See Also:
WebMethod

Optional Element Summary
String | className Response wrapper bean name.
String | localName Elements local name.
String | targetNamespace Elements namespace name.

localName

public abstract String localName
Elements local name.

Default:
""

targetNamespace

public abstract String targetNamespace
Elements namespace name.

Default:
""

className

public abstract String className
Response wrapper bean name.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Service

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Class Service

java.lang.Object
    extended by  javax.xml.ws.Service

public class Service
extends Object

Service objects provide the client view of a Web service.

Service acts as a factory of the following:

  • Proxies for a target service endpoint.
  • Instances of javax.xml.ws.Dispatch for dynamic message-oriented invocation of a remote operation.

    • The ports available on a service can be enumerated using the getPorts method. Alternatively, you can pass a service endpoint interface to the unary getPort method and let the runtime select a compatible port.

    Handler chains for all the objects created by a Service can be set by means of a HandlerResolver.

    An Executor may be set on the service in order to gain better control over the threads used to dispatch asynchronous callbacks. For instance, thread pooling with certain parameters can be enabled by creating a ThreadPoolExecutor and registering it with the service.

    Since:
    JAX-WS 2.0
    See Also:
    Provider, HandlerResolver, Executor

    Nested Class Summary
    static class Service.Mode
    The orientation of a dynamic client or service.
    Constructor Summary
    protected Service(URL wsdlDocumentLocation, QName serviceName)
    Method Summary
     void addPort(QName portName, String bindingId, String endpointAddress)
    Creates a new port for the service.
    static Service create(QName serviceName)
    Create a Service instance.
    static Service create(URL wsdlDocumentLocation, QName serviceName)
    Create a Service instance.
    <T> Dispatch<T>
            createDispatch(QName portName, Class<T> type, Service.Mode mode)
    Creates a Dispatch instance for use with objects of the users choosing.
     Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode)
    Creates a Dispatch instance for use with JAXB generated objects.
     Executor getExecutor()
    Returns the executor for this Serviceinstance.
     HandlerResolver getHandlerResolver()
    Returns the configured handler resolver.
    <T> T
            getPort(Class<T> serviceEndpointInterface)
    The getPort method returns a stub.
    <T> T
            getPort(QName portName, Class<T> serviceEndpointInterface)
    The getPort method returns a stub.
     Iterator<QName> getPorts()
    Returns an Iterator for the list of QNames of service endpoints grouped by this service
     QName getServiceName()
    Gets the name of this service.
     URL getWSDLDocumentLocation()
    Gets the location of the WSDL document for this Service.
     void setExecutor(Executor executor)
    Sets the executor for this Service instance.
     void setHandlerResolver(HandlerResolver handlerResolver)
    Sets the HandlerResolver for this Service instance.
    Methods inherited from class java.lang.Object
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    Constructor Detail

    Service

    protected Service(URL wsdlDocumentLocation,
                  QName serviceName)
    Method Detail

    getPort

    public <T> T getPort(QName portName,
                     Class<T> serviceEndpointInterface)
    The getPort method returns a stub. A service client uses this stub to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy or stub instance.

    Parameters:
    portName - Qualified name of the service endpoint in the WSDL service description
    serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy or stub instance
    Returns:
    Object Proxy instance that supports the specified service endpoint interface
    Throws:
    WebServiceException - This exception is thrown in the following cases:
    • If there is an error in creation of the proxy
    • If there is any missing WSDL metadata as required by this method
    • Optionally, if an illegal serviceEndpointInterface or portName is specified
    See Also:
    Proxy, InvocationHandler

    getPort

    public <T> T getPort(Class<T> serviceEndpointInterface)
    The getPort method returns a stub. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.

    Parameters:
    serviceEndpointInterface - Service endpoint interface
    Returns:
    Object instance that supports the specified service endpoint interface
    Throws:
    WebServiceException -
    • If there is an error during creation of the proxy
    • If there is any missing WSDL metadata as required by this method
    • Optionally, if an illegal serviceEndpointInterface is specified

    addPort

    public void addPort(QName portName,
                    String bindingId,
                    String endpointAddress)
    Creates a new port for the service. Ports created in this way contain no WSDL port type information and can only be used for creating Dispatchinstances.

    Parameters:
    portName - Qualified name for the target service endpoint
    bindingId - A String identifier of a binding.
    endpointAddress - Address of the target service endpoint as a URI
    Throws:
    WebServiceException - If any error in the creation of the port
    See Also:
    SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING

    createDispatch

    public <T> Dispatch<T> createDispatch(QName portName,
                                      Class<T> type,
                                      Service.Mode mode)
    Creates a Dispatch instance for use with objects of the users choosing.

    Parameters:
    portName - Qualified name for the target service endpoint
    type - The class of object used to messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
    mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body. Mode must be MESSAGE when type is SOAPMessage.
    Returns:
    Dispatch instance
    Throws:
    WebServiceException - If any error in the creation of the Dispatch object
    See Also:
    Source, SOAPMessage

    createDispatch

    public Dispatch<Object> createDispatch(QName portName,
                                       JAXBContext context,
                                       Service.Mode mode)
    Creates a Dispatch instance for use with JAXB generated objects.

    Parameters:
    portName - Qualified name for the target service endpoint
    context - The JAXB context used to marshall and unmarshall messages or message payloads.
    mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body.
    Returns:
    Dispatch instance
    Throws:
    ServiceException - If any error in the creation of the Dispatch object
    See Also:
    JAXBContext

    getServiceName

    public QName getServiceName()
    Gets the name of this service.

    Returns:
    Qualified name of this service

    getPorts

    public Iterator<QName> getPorts()
    Returns an Iterator for the list of QNames of service endpoints grouped by this service

    Returns:
    Returns java.util.Iterator with elements of type javax.xml.namespace.QName
    Throws:
    WebServiceException - If this Service class does not have access to the required WSDL metadata

    getWSDLDocumentLocation

    public URL getWSDLDocumentLocation()
    Gets the location of the WSDL document for this Service.

    Returns:
    URL for the location of the WSDL document for this service

    getHandlerResolver

    public HandlerResolver getHandlerResolver()
    Returns the configured handler resolver.

    Returns:
    HandlerResolver The HandlerResolver being used by this Service instance, or null if there isn't one.

    setHandlerResolver

    public void setHandlerResolver(HandlerResolver handlerResolver)
    Sets the HandlerResolver for this Service instance.

    The handler resolver, if present, will be called once for each proxy or dispatch instance that is created, and the handler chain returned by the resolver will be set on the instance.

    Parameters:
    handlerResolver - The HandlerResolver to use for all subsequently created proxy/dispatch objects.
    See Also:
    HandlerResolver

    getExecutor

    public Executor getExecutor()
    Returns the executor for this Serviceinstance. The executor is used for all asynchronous invocations that require callbacks.

    Returns:
    The java.util.concurrent.Executor to be used to invoke a callback.
    See Also:
    Executor

    setExecutor

    public void setExecutor(Executor executor)
    Sets the executor for this Service instance. The executor is used for all asynchronous invocations that require callbacks.

    Parameters:
    executor - The java.util.concurrent.Executor to be used to invoke a callback.
    Throws:
    SecurityException - If the instance does not support setting an executor for security reasons (e.g. the necessary permissions are missing).
    See Also:
    Executor

    create

    public static Service create(URL wsdlDocumentLocation,
                             QName serviceName)
    Create a Service instance. The specified WSDL document location and service qualified name must uniquely identify a wsdl:service element.

    Parameters:
    wsdlDocumentLocation - URL for the WSDL document location for the service
    serviceName - QName for the service
    Throws:
    WebServiceException - If any error in creation of the specified service

    create

    public static Service create(QName serviceName)
    Create a Service instance.

    Parameters:
    serviceName - QName for the service
    Throws:
    WebServiceException - If any error in creation of the specified service
    Overview Package Class Tree Deprecated Index Help
            Java EE 5 SDK
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
    Submit a bug or feature

    Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Service.Mode

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

javax.xml.ws
Enum Service.Mode

java.lang.Object
    extended by  java.lang.Enum<Service.Mode>
        extended by  javax.xml.ws.Service.Mode
All Implemented Interfaces:
Serializable, Comparable<Service.Mode>
Enclosing class:
Service
public static enum Service.Mode
extends Enum<Service.Mode>

The orientation of a dynamic client or service. MESSAGE provides access to entire protocol message, PAYLOAD to protocol message payload only.

Enum Constant Summary
MESSAGE
PAYLOAD
Method Summary
static Service.Mode | valueOf(String name) Returns the enum constant of this type with the specified name.
static Service.Mode[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

MESSAGE

public static final Service.Mode MESSAGE

PAYLOAD

public static final Service.Mode PAYLOAD
Method Detail

values

public static final Service.Mode[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(Service.Mode c : Service.Mode.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static Service.Mode valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServiceMode

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.ws
Annotation Type ServiceMode

@Target(value=TYPE)
@Retention(value=RUNTIME)
@Inherited
@Documented
public @interface ServiceMode

Used to indicate whether a Provider implementation wishes to work with entire protocol messages or just with protocol message payloads.

Since:
JAX-WS 2.0

Optional Element Summary
 Service.Mode value
Service mode.

value

public abstract Service.Mode value
Service mode. PAYLOAD indicates that the Provider implementation wishes to work with protocol message payloads only. MESSAGE indicates that the Provider implementation wishes to work with entire protocol messages.

Default:
PAYLOAD
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


soap

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.ws.soap

This package defines APIs specific to the SOAP binding.

See:
Description

Interface Summary
SOAPBinding The SOAPBinding interface is an abstraction for the SOAP binding.

Exception Summary
SOAPFaultException The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.

Package javax.xml.ws.soap Description

This package defines APIs specific to the SOAP binding.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.ws.soap Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.ws.soap

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.soap.SOAPFaultException

Interface Hierarchy

  • javax.xml.ws.Binding
    • javax.xml.ws.soap.SOAPBinding
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPBinding

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.soap
Interface SOAPBinding

All Superinterfaces:
Binding
public interface SOAPBinding
extends Binding

The SOAPBinding interface is an abstraction for the SOAP binding.

Since:
JAX-WS 2.0

Field Summary
static String | SOAP11HTTP_BINDING A constant representing the identity of the SOAP 1.1 over HTTP binding.
static String | SOAP11HTTP_MTOM_BINDING A constant representing the identity of the SOAP 1.1 over HTTP binding with MTOM enabled by default.
static String | SOAP12HTTP_BINDING A constant representing the identity of the SOAP 1.2 over HTTP binding.
static String | SOAP12HTTP_MTOM_BINDING A constant representing the identity of the SOAP 1.2 over HTTP binding with MTOM enabled by default.
Method Summary
MessageFactory | getMessageFactory() Gets the SAAJ MessageFactory instance used by this SOAP binding.
Set<String> | getRoles() Gets the roles played by the SOAP binding instance.
SOAPFactory | getSOAPFactory() Gets the SAAJ SOAPFactory instance used by this SOAP binding.
boolean | isMTOMEnabled() Returns true if the use of MTOM is enabled.
void | setMTOMEnabled(boolean flag) Enables or disables use of MTOM.
void | setRoles(Set<String> roles) Sets the roles played by the SOAP binding instance.
Methods inherited from interface javax.xml.ws.Binding
getHandlerChain, setHandlerChain

Field Detail

SOAP11HTTP_BINDING

static final String SOAP11HTTP_BINDING
A constant representing the identity of the SOAP 1.1 over HTTP binding.

See Also:
Constant Field Values

SOAP12HTTP_BINDING

static final String SOAP12HTTP_BINDING
A constant representing the identity of the SOAP 1.2 over HTTP binding.

See Also:
Constant Field Values

SOAP11HTTP_MTOM_BINDING

static final String SOAP11HTTP_MTOM_BINDING
A constant representing the identity of the SOAP 1.1 over HTTP binding with MTOM enabled by default.

See Also:
Constant Field Values

SOAP12HTTP_MTOM_BINDING

static final String SOAP12HTTP_MTOM_BINDING
A constant representing the identity of the SOAP 1.2 over HTTP binding with MTOM enabled by default.

See Also:
Constant Field Values
Method Detail

getRoles

Set<String> getRoles()
Gets the roles played by the SOAP binding instance.

Returns:
Set The set of roles played by the binding instance.

setRoles

void setRoles(Set<String> roles)
Sets the roles played by the SOAP binding instance.

Parameters:
roles - The set of roles played by the binding instance.
Throws:
WebServiceException - On an error in the configuration of the list of roles.

isMTOMEnabled

boolean isMTOMEnabled()
Returns true if the use of MTOM is enabled.

Returns:
true if and only if the use of MTOM is enabled.

setMTOMEnabled

void setMTOMEnabled(boolean flag)
Enables or disables use of MTOM.

Parameters:
flag - A boolean specifying whether the use of MTOM should be enabled or disabled.
Throws:
WebServiceException - If the specified setting is not supported by this binding instance.

getSOAPFactory

SOAPFactory getSOAPFactory()
Gets the SAAJ SOAPFactory instance used by this SOAP binding.

Returns:
SOAPFactory instance used by this SOAP binding.

getMessageFactory

MessageFactory getMessageFactory()
Gets the SAAJ MessageFactory instance used by this SOAP binding.

Returns:
MessageFactory instance used by this SOAP binding.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


SOAPFaultException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.soap
Class SOAPFaultException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.xml.ws.WebServiceException
                    extended by  javax.xml.ws.ProtocolException
                        extended by  javax.xml.ws.soap.SOAPFaultException
All Implemented Interfaces:
Serializable
public class SOAPFaultException
extends ProtocolException

The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.

A SOAPFaultException wraps a SAAJ SOAPFault that manages the SOAP-specific representation of faults. The createFault method of javax.xml.soap.SOAPFactory may be used to create an instance of javax.xml.soap.SOAPFault for use with the constructor. SOAPBinding contains an accessor for the SOAPFactory used by the binding instance.

Note that the value of getFault is the only part of the exception used when searializing a SOAP fault.

Refer to the SOAP specification for a complete description of SOAP faults.

Since:
JAX-WS 2.0
See Also:
SOAPFault, SOAPBinding.getSOAPFactory(), ProtocolException, Serialized Form

Constructor Summary
SOAPFaultException(SOAPFault fault)
Constructor for SOAPFaultException
Method Summary
 SOAPFault getFault()
Gets the embedded SOAPFault instance.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SOAPFaultException

public SOAPFaultException(SOAPFault fault)
Constructor for SOAPFaultException

Parameters:
fault - SOAPFault representing the fault
See Also:
SOAPFactory.createFault(java.lang.String, javax.xml.namespace.QName)
Method Detail

getFault

public SOAPFault getFault()
Gets the embedded SOAPFault instance.

Returns:
javax.xml.soap.SOAPFault SOAP fault element
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


spi

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package javax.xml.ws.spi

This package defines SPIs for JAX-WS 2.0.

See:
Description

Class Summary
Provider | Service provider for ServiceDelegate and Endpoint objects.
ServiceDelegate | Service delegates are used internally by Service objects to allow pluggability of JAX-WS implementations.

Package javax.xml.ws.spi Description

This package defines SPIs for JAX-WS 2.0.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


javax.xml.ws.spi Class Hierarchy

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES

Hierarchy For Package javax.xml.ws.spi

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.xml.ws.spi.Provider
    • javax.xml.ws.spi.ServiceDelegate
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV NEXT FRAMES NO FRAMES
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Provider

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.spi
Class Provider

java.lang.Object
    extended by  javax.xml.ws.spi.Provider

public abstract class Provider
extends Object

Service provider for ServiceDelegate and Endpoint objects.

Since:
JAX-WS 2.0

Field Summary
static String JAXWSPROVIDER_PROPERTY
A constant representing the property used to lookup the name of a Provider implementation class.
Constructor Summary
protected Provider()
Creates a new instance of Provider
Method Summary
abstract Endpoint | createAndPublishEndpoint(String address, Object implementor) Creates and publishes an endpoint object with the specified address and implementation object.
abstract Endpoint | createEndpoint(String bindingId, Object implementor) Creates an endpoint object with the provided binding and implementation object.
abstract ServiceDelegate | createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class serviceClass) Creates a service delegate object.
static Provider | provider() Creates a new provider object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

JAXWSPROVIDER_PROPERTY

public static final String JAXWSPROVIDER_PROPERTY
A constant representing the property used to lookup the name of a Provider implementation class.

See Also:
Constant Field Values
Constructor Detail

Provider

protected Provider()
Creates a new instance of Provider

Method Detail

provider

public static Provider provider()
Creates a new provider object.

The algorithm used to locate the provider subclass to use consists of the following steps:

  • If a resource with the name of META-INF/services/javax.xml.ws.spi.Provider exists, then its first line, if present, is used as the UTF-8 encoded name of the implementation class.
  • If the $java.home/lib/jaxws.properties file exists and it is readable by the java.util.Properties.load(InputStream) method and it contains an entry whose key is javax.xml.ws.spi.Provider, then the value of that entry is used as the name of the implementation class.
  • If a system property with the name javax.xml.ws.spi.Provider is defined, then its value is used as the name of the implementation class.
  • Finally, a default implementation class name is used.

createServiceDelegate

public abstract ServiceDelegate createServiceDelegate(URL wsdlDocumentLocation,
                                                      QName serviceName,
                                                      Class serviceClass)
Creates a service delegate object.

Parameters:
wsdlDocumentLocation - A URL pointing to the WSDL document for the service, or null if there isn't one.
serviceName - The qualified name of the service.
serviceClass - The service class, which must be either javax.xml.ws.Service or a subclass thereof.
Returns:
The newly created service delegate.

createEndpoint

public abstract Endpoint createEndpoint(String bindingId,
                                        Object implementor)
Creates an endpoint object with the provided binding and implementation object.

Parameters:
bindingId - A URI specifying the desired binding (e.g. SOAP/HTTP)
implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class must be annotated with all the necessary Web service annotations.
Returns:
The newly created endpoint.

createAndPublishEndpoint

public abstract Endpoint createAndPublishEndpoint(String address,
                                                  Object implementor)
Creates and publishes an endpoint object with the specified address and implementation object.

Parameters:
address - A URI specifying the address and transport/protocol to use. A http: URI must result in the SOAP 1.1/HTTP binding being used. Implementations may support other URI schemes.
implementor - A service implementation object to which incoming requests will be dispatched. The corresponding class must be annotated with all the necessary Web service annotations.
Returns:
The newly created endpoint.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


ServiceDelegate

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws.spi
Class ServiceDelegate

java.lang.Object
    extended by  javax.xml.ws.spi.ServiceDelegate

public abstract class ServiceDelegate
extends Object

Service delegates are used internally by Service objects to allow pluggability of JAX-WS implementations.

Every Service object has its own delegate, created using the javax.xml.ws.Provider#createServiceDelegate method. A Service object delegates all of its instance methods to its delegate.

Since:
JAX-WS 2.0
See Also:
Service, Provider

Constructor Summary
protected ServiceDelegate()
Method Summary
abstract  void addPort(QName portName, String bindingId, String endpointAddress)
Creates a new port for the service.
abstract
<T> Dispatch<T>
createDispatch(QName portName, Class<T> type, Service.Mode mode)
Creates a Dispatch instance for use with objects of the users choosing.
abstract  Dispatch<Object> createDispatch(QName portName, JAXBContext context, Service.Mode mode)
Creates a Dispatch instance for use with JAXB generated objects.
abstract  Executor getExecutor()
Returns the executor for this Serviceinstance.
abstract  HandlerResolver getHandlerResolver()
Returns the configured handler resolver.
abstract
<T> T
getPort(Class<T> serviceEndpointInterface)
The getPort method returns a stub.
abstract
<T> T
getPort(QName portName, Class<T> serviceEndpointInterface)
The getPort method returns a stub.
abstract  Iterator<QName> getPorts()
Returns an Iterator for the list of QNames of service endpoints grouped by this service
abstract  QName getServiceName()
Gets the name of this service.
abstract  URL getWSDLDocumentLocation()
Gets the location of the WSDL document for this Service.
abstract  void setExecutor(Executor executor)
Sets the executor for this Service instance.
abstract  void setHandlerResolver(HandlerResolver handlerResolver)
Sets the HandlerResolver for this Service instance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServiceDelegate

protected ServiceDelegate()
Method Detail

getPort

public abstract <T> T getPort(QName portName,
                              Class<T> serviceEndpointInterface)
The getPort method returns a stub. A service client uses this stub to invoke operations on the target service endpoint. The serviceEndpointInterface specifies the service endpoint interface that is supported by the created dynamic proxy or stub instance.

Parameters:
portName - Qualified name of the service endpoint in the WSDL service description
serviceEndpointInterface - Service endpoint interface supported by the dynamic proxy or stub instance
Returns:
Object Proxy instance that supports the specified service endpoint interface
Throws:
WebServiceException - This exception is thrown in the following cases:
  • If there is an error in creation of the proxy
  • If there is any missing WSDL metadata as required by this method
  • Optionally, if an illegal serviceEndpointInterface or portName is specified
See Also:
Proxy, InvocationHandler

getPort

public abstract <T> T getPort(Class<T> serviceEndpointInterface)
The getPort method returns a stub. The parameter serviceEndpointInterface specifies the service endpoint interface that is supported by the returned proxy. In the implementation of this method, the JAX-WS runtime system takes the responsibility of selecting a protocol binding (and a port) and configuring the proxy accordingly. The returned proxy should not be reconfigured by the client.

Parameters:
serviceEndpointInterface - Service endpoint interface
Returns:
Object instance that supports the specified service endpoint interface
Throws:
WebServiceException -
  • If there is an error during creation of the proxy
  • If there is any missing WSDL metadata as required by this method
  • Optionally, if an illegal serviceEndpointInterface is specified

addPort

public abstract void addPort(QName portName,
                             String bindingId,
                             String endpointAddress)
Creates a new port for the service. Ports created in this way contain no WSDL port type information and can only be used for creating Dispatchinstances.

Parameters:
portName - Qualified name for the target service endpoint
bindingId - A URI identifier of a binding.
endpointAddress - Address of the target service endpoint as a URI
Throws:
WebServiceException - If any error in the creation of the port
See Also:
SOAPBinding.SOAP11HTTP_BINDING, SOAPBinding.SOAP12HTTP_BINDING, HTTPBinding.HTTP_BINDING

createDispatch

public abstract <T> Dispatch<T> createDispatch(QName portName,
                                               Class<T> type,
                                               Service.Mode mode)
Creates a Dispatch instance for use with objects of the users choosing.

Parameters:
portName - Qualified name for the target service endpoint
type - The class of object used to messages or message payloads. Implementations are required to support javax.xml.transform.Source and javax.xml.soap.SOAPMessage.
mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body. Mode must be MESSAGE when type is SOAPMessage.
Returns:
Dispatch instance
Throws:
WebServiceException - If any error in the creation of the Dispatch object
See Also:
Source, SOAPMessage

createDispatch

public abstract Dispatch<Object> createDispatch(QName portName,
                                                JAXBContext context,
                                                Service.Mode mode)
Creates a Dispatch instance for use with JAXB generated objects.

Parameters:
portName - Qualified name for the target service endpoint
context - The JAXB context used to marshall and unmarshall messages or message payloads.
mode - Controls whether the created dispatch instance is message or payload oriented, i.e. whether the user will work with complete protocol messages or message payloads. E.g. when using the SOAP protocol, this parameter controls whether the user will work with SOAP messages or the contents of a SOAP body.
Returns:
Dispatch instance
Throws:
ServiceException - If any error in the creation of the Dispatch object
See Also:
JAXBContext

getServiceName

public abstract QName getServiceName()
Gets the name of this service.

Returns:
Qualified name of this service

getPorts

public abstract Iterator<QName> getPorts()
Returns an Iterator for the list of QNames of service endpoints grouped by this service

Returns:
Returns java.util.Iterator with elements of type javax.xml.namespace.QName
Throws:
WebServiceException - If this Service class does not have access to the required WSDL metadata

getWSDLDocumentLocation

public abstract URL getWSDLDocumentLocation()
Gets the location of the WSDL document for this Service.

Returns:
URL for the location of the WSDL document for this service

getHandlerResolver

public abstract HandlerResolver getHandlerResolver()
Returns the configured handler resolver.

Returns:
HandlerResolver The HandlerResolver being used by this Service instance, or null if there isn't one.

setHandlerResolver

public abstract void setHandlerResolver(HandlerResolver handlerResolver)
Sets the HandlerResolver for this Service instance.

The handler resolver, if present, will be called once for each proxy or dispatch instance that is created, and the handler chain returned by the resolver will be set on the instance.

Parameters:
handlerResolver - The HandlerResolver to use for all subsequently created proxy/dispatch objects.
See Also:
HandlerResolver

getExecutor

public abstract Executor getExecutor()
Returns the executor for this Serviceinstance. The executor is used for all asynchronous invocations that require callbacks.

Returns:
The java.util.concurrent.Executor to be used to invoke a callback.
See Also:
Executor

setExecutor

public abstract void setExecutor(Executor executor)
Sets the executor for this Service instance. The executor is used for all asynchronous invocations that require callbacks.

Parameters:
executor - The java.util.concurrent.Executor to be used to invoke a callback.
Throws:
SecurityException - If the instance does not support setting an executor for security reasons (e.g. the necessary permissions are missing).
See Also:
Executor
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebEndpoint

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.ws
Annotation Type WebEndpoint

@Target(value=METHOD)
@Retention(value=RUNTIME)
@Documented
public @interface WebEndpoint

Used to annotate the getPortName() methods of a generated service interface.

The information specified in this annotation is sufficient to uniquely identify a wsdl:port element inside a wsdl:service. The latter is determined based on the value of the WebServiceClient annotation on the generated service interface itself.

Since:
JAX-WS 2.0
See Also:
WebServiceClient

Optional Element Summary
 String name
The local name of the endpoint.

name

public abstract String name
The local name of the endpoint.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebFault

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.ws
Annotation Type WebFault

@Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebFault

Used to annotate service specific exception classes to customize to the local and namespace name of the fault element and the name of the fault bean.

Since:
JAX-WS 2.0

Optional Element Summary
String | faultBean Fault bean name.
String | name Elements local name.
String | targetNamespace Elements namespace name.

name

public abstract String name
Elements local name.

Default:
""

targetNamespace

public abstract String targetNamespace
Elements namespace name.

Default:
""

faultBean

public abstract String faultBean
Fault bean name.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebServiceClient

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.ws
Annotation Type WebServiceClient

@Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceClient

Used to annotate a generated service interface.

The information specified in this annotation is sufficient to uniquely identify a wsdl:service element inside a WSDL document. This wsdl:service element represents the Web service for which the generated service interface provides a client view.

Since:
JAX-WS 2.0

Optional Element Summary
String | name The local name of the Web service.
String | targetNamespace The namespace for the Web service.
String | wsdlLocation The location of the WSDL document for the service (a URL).

name

public abstract String name
The local name of the Web service.

Default:
""

targetNamespace

public abstract String targetNamespace
The namespace for the Web service.

Default:
""

wsdlLocation

public abstract String wsdlLocation
The location of the WSDL document for the service (a URL).

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebServiceContext

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Interface WebServiceContext

public interface WebServiceContext

A WebServiceContext makes it possible for a web service endpoint implementation class to access message context and security information relative to a request being served. Typically a WebServiceContext is injected into an endpoint implementation class using the Resource annotation.

Since:
JAX-WS 2.0
See Also:
Resource

Method Summary
MessageContext | getMessageContext() Returns the MessageContext for the request being served at the time this method is called.
Principal | getUserPrincipal() Returns the Principal that identifies the sender of the request currently being serviced.
boolean | isUserInRole(String role) Returns a boolean indicating whether the authenticated user is included in the specified logical role.

Method Detail

getMessageContext

MessageContext getMessageContext()
Returns the MessageContext for the request being served at the time this method is called. Only properties with APPLICATION scope will be visible to the application.

Returns:
MessageContext The message context.
Throws:
IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
See Also:
MessageContext, MessageContext.Scope, IllegalStateException

getUserPrincipal

Principal getUserPrincipal()
Returns the Principal that identifies the sender of the request currently being serviced. If the sender has not been authenticated, the method returns null.

Returns:
Principal The principal object.
Throws:
IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
See Also:
Principal, IllegalStateException

isUserInRole

boolean isUserInRole(String role)
Returns a boolean indicating whether the authenticated user is included in the specified logical role. If the user has not been authenticated, the method returns false.

Parameters:
role - A String specifying the name of the role
Returns:
a boolean indicating whether the sender of the request belongs to a given role
Throws:
IllegalStateException - This exception is thrown if the method is called while no request is being serviced.
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebServiceException

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Class WebServiceException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  javax.xml.ws.WebServiceException
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ProtocolException
public class WebServiceException
extends RuntimeException

The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.

Since:
JAX-WS 2.0
See Also:
Serialized Form

Constructor Summary
WebServiceException()
Constructs a new exception with null as its detail message.
WebServiceException(String message)
Constructs a new exception with the specified detail message.
WebServiceException(String message, Throwable cause)
Constructs a new exception with the specified detail message and cause.
WebServiceException(Throwable cause)
Constructs a new WebServiceException with the specified cause and a detail message of (cause==null ?
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

WebServiceException

public WebServiceException()
Constructs a new exception with null as its detail message. The cause is not initialized.

WebServiceException

public WebServiceException(String message)
Constructs a new exception with the specified detail message. The cause is not initialized.

Parameters:
message - The detail message which is later retrieved using the getMessage method

WebServiceException

public WebServiceException(String message,
                           Throwable cause)
Constructs a new exception with the specified detail message and cause.

Parameters:
message - The detail message which is later retrieved using the getMessage method
cause - The cause which is saved for the later retrieval throw by the getCause method

WebServiceException

public WebServiceException(Throwable cause)
Constructs a new WebServiceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

Parameters:
cause - The cause which is saved for the later retrieval throw by the getCause method. (A null value is permitted, and indicates that the cause is nonexistent or unknown.)
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebServicePermission

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

javax.xml.ws
Class WebServicePermission

java.lang.Object
    extended by  java.security.Permission
        extended by  java.security.BasicPermission
            extended by  javax.xml.ws.WebServicePermission
All Implemented Interfaces:
Serializable, Guard
public final class WebServicePermission
extends BasicPermission

This class defines web service permissions.

Web service Permissions are identified by name (also referred to as a "target name") alone. There are no actions associated with them.

The following permission target name is defined:

publishEndpoint

The publishEndpoint permission allows publishing a web service endpoint using the publish methods defined by the javax.xml.ws.Endpoint class.

See Also:
Endpoint, BasicPermission, Permission, Permissions, SecurityManager, Serialized Form

Constructor Summary
WebServicePermission(String name)
Creates a new permission with the specified name.
WebServicePermission(String name, String actions)
Creates a new permission with the specified name and actions.
Method Summary
Methods inherited from class java.security.BasicPermission
equals, getActions, hashCode, implies, newPermissionCollection
Methods inherited from class java.security.Permission
checkGuard, getName, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

WebServicePermission

public WebServicePermission(String name)
Creates a new permission with the specified name.

Parameters:
name - the name of the WebServicePermission

WebServicePermission

public WebServicePermission(String name,
                            String actions)
Creates a new permission with the specified name and actions. The actions parameter is currently unused and it should be null.

Parameters:
name - the name of the WebServicePermission
actions - should be null
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebServiceProvider

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.ws
Annotation Type WebServiceProvider

@Target(value=TYPE)
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceProvider

Used to annotate a Provider implementation class.

Since:
JAX-WS 2.0
See Also:
Provider

Optional Element Summary
String | portName Port name.
String | serviceName Service name.
String | targetNamespace Target namespace for the service
String | wsdlLocation Location of the WSDL description for the service.

wsdlLocation

public abstract String wsdlLocation
Location of the WSDL description for the service.

Default:
""

serviceName

public abstract String serviceName
Service name.

Default:
""

targetNamespace

public abstract String targetNamespace
Target namespace for the service

Default:
""

portName

public abstract String portName
Port name.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebServiceRef

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

javax.xml.ws
Annotation Type WebServiceRef

@Target(value={TYPE,METHOD,FIELD})
@Retention(value=RUNTIME)
@Documented
public @interface WebServiceRef

The WebServiceRef annotation is used to define a reference to a web service and (optionally) an injection target for it. Web service references are resources in the Java EE 5 sense.

Since:
JAX-WS 2.0
See Also:
Resource

Optional Element Summary
String | mappedName A product specific name that this resource should be mapped to.
String | name The JNDI name of the resource.
Class | type The Java type of the resource.
Class | value The service class, always a type extending javax.xml.ws.Service.
String | wsdlLocation A URL pointing to the WSDL document for the web service.

name

public abstract String name
The JNDI name of the resource. For field annotations, the default is the field name. For method annotations, the default is the JavaBeans property name corresponding to the method. For class annotations, there is no default and this must be specified.

Default:
""

type

public abstract Class type
The Java type of the resource. For field annotations, the default is the type of the field. For method annotations, the default is the type of the JavaBeans property. For class annotations, there is no default and this must be specified.

Default:
java.lang.Object.class

mappedName

public abstract String mappedName
A product specific name that this resource should be mapped to. The name of this resource, as defined by the name element or defaulted, is a name that is local to the application component using the resource. (It's a name in the JNDI java:comp/env namespace.) Many application servers provide a way to map these local names to names of resources known to the application server. This mapped name is often a global JNDI name, but may be a name of any form.

Application servers are not required to support any particular form or type of mapped name, nor the ability to use mapped names. The mapped name is product-dependent and often installation-dependent. No use of a mapped name is portable.

Default:
""

value

public abstract Class value
The service class, always a type extending javax.xml.ws.Service. This element must be specified whenever the type of the reference is a service endpoint interface.

Default:
java.lang.Object.class

wsdlLocation

public abstract String wsdlLocation
A URL pointing to the WSDL document for the web service. If not specified, the WSDL location specified by annotations on the resource type is used instead.

Default:
""
Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


WebServiceRefs

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

javax.xml.ws
Annotation Type WebServiceRefs

@Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface WebServiceRefs

The WebServiceRefs annotation allows multiple web service references to be declared at the class level.

Since:
2.0
See Also:
WebServiceRef

Required Element Summary
 WebServiceRef[] value
Array used for multiple web service reference declarations.

Element Detail

value

public abstract WebServiceRef[] value
Array used for multiple web service reference declarations.

Overview Package Class Tree Deprecated Index Help
Java EE 5 SDK
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT
Submit a bug or feature

Copyright 2006 Sun Microsystems, Inc. All rights reserved.


Overview

TM Platform, Enterprise Edition, v 5.0
API Specifications.">
Java EE 5 SDK
All Classes

Packages
javax.activation
javax.annotation
javax.annotation.security
javax.ejb
javax.ejb.spi
javax.el
javax.enterprise.deploy.model
javax.enterprise.deploy.model.exceptions
javax.enterprise.deploy.shared
javax.enterprise.deploy.shared.factories
javax.enterprise.deploy.spi
javax.enterprise.deploy.spi.exceptions
javax.enterprise.deploy.spi.factories
javax.enterprise.deploy.spi.status
javax.faces
javax.faces.application
javax.faces.component
javax.faces.component.html
javax.faces.context
javax.faces.convert
javax.faces.el
javax.faces.event
javax.faces.lifecycle
javax.faces.model
javax.faces.render
javax.faces.validator
javax.faces.webapp
javax.interceptor
javax.jms
javax.jws
javax.jws.soap
javax.mail
javax.mail.event
javax.mail.internet
javax.mail.search
javax.mail.util
javax.management.j2ee
javax.management.j2ee.statistics
javax.persistence
javax.persistence.spi
javax.resource
javax.resource.cci
javax.resource.spi
javax.resource.spi.endpoint
javax.resource.spi.security
javax.resource.spi.work
javax.security.jacc
javax.servlet
javax.servlet.http
javax.servlet.jsp
javax.servlet.jsp.el
javax.servlet.jsp.tagext
javax.transaction
javax.transaction.xa
javax.xml.bind
javax.xml.bind.annotation
javax.xml.bind.annotation.adapters
javax.xml.bind.attachment
javax.xml.bind.helpers
javax.xml.bind.util
javax.xml.registry
javax.xml.registry.infomodel
javax.xml.rpc
javax.xml.rpc.encoding
javax.xml.rpc.handler
javax.xml.rpc.handler.soap
javax.xml.rpc.holders
javax.xml.rpc.server
javax.xml.rpc.soap
javax.xml.soap
javax.xml.stream
javax.xml.stream.events
javax.xml.stream.util
javax.xml.ws
javax.xml.ws.handler
javax.xml.ws.handler.soap
javax.xml.ws.http
javax.xml.ws.soap
javax.xml.ws.spi


 javax.activation
Interfaces
CommandObject
DataContentHandler
DataContentHandlerFactory
DataSource
Classes
ActivationDataFlavor
CommandInfo
CommandMap
DataHandler
FileDataSource
FileTypeMap
MailcapCommandMap
MimeType
MimeTypeParameterList
MimetypesFileTypeMap
URLDataSource
Exceptions
MimeTypeParseException
UnsupportedDataTypeException


 javax.annotation
Enums
Resource.AuthenticationType
Annotation Types
Generated
PostConstruct
PreDestroy
Resource
Resources


 javax.annotation.security
Annotation Types
DeclareRoles
DenyAll
PermitAll
RolesAllowed
RunAs


 javax.ejb
Interfaces
EJBContext
EJBHome
EJBLocalHome
EJBLocalObject
EJBMetaData
EJBObject
EnterpriseBean
EntityBean
EntityContext
Handle
HomeHandle
MessageDrivenBean
MessageDrivenContext
SessionBean
SessionContext
SessionSynchronization
TimedObject
Timer
TimerHandle
TimerService
Enums
TransactionAttributeType
TransactionManagementType
Exceptions
AccessLocalException
ConcurrentAccessException
CreateException
DuplicateKeyException
EJBAccessException
EJBException
EJBTransactionRequiredException
EJBTransactionRolledbackException
FinderException
NoSuchEJBException
NoSuchEntityException
NoSuchObjectLocalException
ObjectNotFoundException
RemoveException
TransactionRequiredLocalException
TransactionRolledbackLocalException
Annotation Types
ActivationConfigProperty
ApplicationException
EJB
EJBs
Init
Local
LocalHome
MessageDriven
PostActivate
PrePassivate
Remote
RemoteHome
Remove
Stateful
Stateless
Timeout
TransactionAttribute
TransactionManagement


 javax.ejb.spi
Interfaces
HandleDelegate


 javax.el
Interfaces
ELContextListener
Classes
ArrayELResolver
BeanELResolver
BeanELResolver.BeanProperties
BeanELResolver.BeanProperty
CompositeELResolver
ELContext
ELContextEvent
ELResolver
Expression
ExpressionFactory
FunctionMapper
ListELResolver
MapELResolver
MethodExpression
MethodInfo
ResourceBundleELResolver
ValueExpression
VariableMapper
Exceptions
ELException
MethodNotFoundException
PropertyNotFoundException
PropertyNotWritableException


 javax.enterprise.deploy.model
Interfaces
DDBean
DDBeanRoot
DeployableObject
J2eeApplicationObject
XpathListener
Classes
XpathEvent


 javax.enterprise.deploy.model.exceptions
Exceptions
DDBeanCreateException


 javax.enterprise.deploy.shared
Classes
ActionType
CommandType
DConfigBeanVersionType
ModuleType
StateType


 javax.enterprise.deploy.shared.factories
Classes
DeploymentFactoryManager


 javax.enterprise.deploy.spi
Interfaces
DConfigBean
DConfigBeanRoot
DeploymentConfiguration
DeploymentManager
Target
TargetModuleID


 javax.enterprise.deploy.spi.exceptions
Exceptions
BeanNotFoundException
ClientExecuteException
ConfigurationException
DConfigBeanVersionUnsupportedException
DeploymentManagerCreationException
InvalidModuleException
OperationUnsupportedException
TargetException


 javax.enterprise.deploy.spi.factories
Interfaces
DeploymentFactory


 javax.enterprise.deploy.spi.status
Interfaces
ClientConfiguration
DeploymentStatus
ProgressListener
ProgressObject
Classes
ProgressEvent


 javax.faces
Classes
FactoryFinder
Exceptions
FacesException


 javax.faces.application
Classes
Application
ApplicationFactory
FacesMessage
FacesMessage.Severity
NavigationHandler
StateManager
StateManagerWrapper
ViewHandler
ViewHandlerWrapper
Exceptions
ViewExpiredException


 javax.faces.component
Interfaces
ActionSource
ActionSource2
ContextCallback
EditableValueHolder
NamingContainer
StateHolder
ValueHolder
Classes
UIColumn
UICommand
UIComponent
UIComponentBase
UIData
UIForm
UIGraphic
UIInput
UIMessage
UIMessages
UINamingContainer
UIOutput
UIPanel
UIParameter
UISelectBoolean
UISelectItem
UISelectItems
UISelectMany
UISelectOne
UIViewRoot


 javax.faces.component.html
Classes
HtmlColumn
HtmlCommandButton
HtmlCommandLink
HtmlDataTable
HtmlForm
HtmlGraphicImage
HtmlInputHidden
HtmlInputSecret
HtmlInputText
HtmlInputTextarea
HtmlMessage
HtmlMessages
HtmlOutputFormat
HtmlOutputLabel
HtmlOutputLink
HtmlOutputText
HtmlPanelGrid
HtmlPanelGroup
HtmlSelectBooleanCheckbox
HtmlSelectManyCheckbox
HtmlSelectManyListbox
HtmlSelectManyMenu
HtmlSelectOneListbox
HtmlSelectOneMenu
HtmlSelectOneRadio


 javax.faces.context
Classes
ExternalContext
FacesContext
FacesContextFactory
ResponseStream
ResponseWriter
ResponseWriterWrapper


 javax.faces.convert
Interfaces
Converter
Classes
BigDecimalConverter
BigIntegerConverter
BooleanConverter
ByteConverter
CharacterConverter
DateTimeConverter
DoubleConverter
EnumConverter
FloatConverter
IntegerConverter
LongConverter
NumberConverter
ShortConverter
Exceptions
ConverterException


 javax.faces.el
Classes
MethodBinding
PropertyResolver
ValueBinding
VariableResolver
Exceptions
EvaluationException
MethodNotFoundException
PropertyNotFoundException
ReferenceSyntaxException


 javax.faces.event
Interfaces
ActionListener
FacesListener
PhaseListener
ValueChangeListener
Classes
ActionEvent
FacesEvent
MethodExpressionActionListener
MethodExpressionValueChangeListener
PhaseEvent
PhaseId
ValueChangeEvent
Exceptions
AbortProcessingException


 javax.faces.lifecycle
Classes
Lifecycle
LifecycleFactory


 javax.faces.model
Interfaces
DataModelListener
Classes
ArrayDataModel
DataModel
DataModelEvent
ListDataModel
ResultDataModel
ResultSetDataModel
ScalarDataModel
SelectItem
SelectItemGroup


 javax.faces.render
Classes
Renderer
RenderKit
RenderKitFactory
ResponseStateManager


 javax.faces.validator
Interfaces
Validator
Classes
DoubleRangeValidator
LengthValidator
LongRangeValidator
MethodExpressionValidator
Exceptions
ValidatorException


 javax.faces.webapp
Classes
AttributeTag
ConverterELTag
ConverterTag
FacesServlet
FacetTag
UIComponentBodyTag
UIComponentClassicTagBase
UIComponentELTag
UIComponentTag
UIComponentTagBase
ValidatorELTag
ValidatorTag


 javax.interceptor
Interfaces
InvocationContext
Annotation Types
AroundInvoke
ExcludeClassInterceptors
ExcludeDefaultInterceptors
Interceptors


 javax.jms
Interfaces
BytesMessage
Connection
ConnectionConsumer
ConnectionFactory
ConnectionMetaData
DeliveryMode
Destination
ExceptionListener
MapMessage
Message
MessageConsumer
MessageListener
MessageProducer
ObjectMessage
Queue
QueueBrowser
QueueConnection
QueueConnectionFactory
QueueReceiver
QueueSender
QueueSession
ServerSession
ServerSessionPool
Session
StreamMessage
TemporaryQueue
TemporaryTopic
TextMessage
Topic
TopicConnection
TopicConnectionFactory
TopicPublisher
TopicSession
TopicSubscriber
XAConnection
XAConnectionFactory
XAQueueConnection
XAQueueConnectionFactory
XAQueueSession
XASession
XATopicConnection
XATopicConnectionFactory
XATopicSession
Classes
QueueRequestor
TopicRequestor
Exceptions
IllegalStateException
InvalidClientIDException
InvalidDestinationException
InvalidSelectorException
JMSException
JMSSecurityException
MessageEOFException
MessageFormatException
MessageNotReadableException
MessageNotWriteableException
ResourceAllocationException
TransactionInProgressException
TransactionRolledBackException


 javax.jws
Enums
WebParam.Mode
Annotation Types
HandlerChain
Oneway
WebMethod
WebParam
WebResult
WebService


 javax.jws.soap
Enums
SOAPBinding.ParameterStyle
SOAPBinding.Style
SOAPBinding.Use
Annotation Types
InitParam
SOAPBinding
SOAPMessageHandler
SOAPMessageHandlers


 javax.mail
Interfaces
MessageAware
MultipartDataSource
Part
QuotaAwareStore
UIDFolder
Classes
Address
Authenticator
BodyPart
FetchProfile
FetchProfile.Item
Flags
Flags.Flag
Folder
Header
Message
Message.RecipientType
MessageContext
Multipart
PasswordAuthentication
Provider
Provider.Type
Quota
Quota.Resource
Service
Session
Store
Transport
UIDFolder.FetchProfileItem
URLName
Exceptions
AuthenticationFailedException
FolderClosedException
FolderNotFoundException
IllegalWriteException
MessageRemovedException
MessagingException
MethodNotSupportedException
NoSuchProviderException
ReadOnlyFolderException
SendFailedException
StoreClosedException


 javax.mail.event
Interfaces
ConnectionListener
FolderListener
MessageChangedListener
MessageCountListener
StoreListener
TransportListener
Classes
ConnectionAdapter
ConnectionEvent
FolderAdapter
FolderEvent
MailEvent
MessageChangedEvent
MessageCountAdapter
MessageCountEvent
StoreEvent
TransportAdapter
TransportEvent


 javax.mail.internet
Interfaces
MimePart
SharedInputStream
Classes
ContentDisposition
ContentType
HeaderTokenizer
HeaderTokenizer.Token
InternetAddress
InternetHeaders
InternetHeaders.InternetHeader
MailDateFormat
MimeBodyPart
MimeMessage
MimeMessage.RecipientType
MimeMultipart
MimePartDataSource
MimeUtility
NewsAddress
ParameterList
PreencodedMimeBodyPart
Exceptions
AddressException
ParseException


 javax.mail.search
Classes
AddressStringTerm
AddressTerm
AndTerm
BodyTerm
ComparisonTerm
DateTerm
FlagTerm
FromStringTerm
FromTerm
HeaderTerm
IntegerComparisonTerm
MessageIDTerm
MessageNumberTerm
NotTerm
OrTerm
ReceivedDateTerm
RecipientStringTerm
RecipientTerm
SearchTerm
SentDateTerm
SizeTerm
StringTerm
SubjectTerm
Exceptions
SearchException


 javax.mail.util
Classes
ByteArrayDataSource
SharedByteArrayInputStream
SharedFileInputStream


 javax.management.j2ee
Interfaces
ListenerRegistration
Management
ManagementHome


 javax.management.j2ee.statistics
Interfaces
BoundaryStatistic
BoundedRangeStatistic
CountStatistic
EJBStats
EntityBeanStats
JavaMailStats
JCAConnectionPoolStats
JCAConnectionStats
JCAStats
JDBCConnectionPoolStats
JDBCConnectionStats
JDBCStats
JMSConnectionStats
JMSConsumerStats
JMSEndpointStats
JMSProducerStats
JMSSessionStats
JMSStats
JTAStats
JVMStats
MessageDrivenBeanStats
RangeStatistic
ServletStats
SessionBeanStats
StatefulSessionBeanStats
StatelessSessionBeanStats
Statistic
Stats
TimeStatistic
URLStats


 javax.persistence
Interfaces
EntityManager
EntityManagerFactory
EntityTransaction
Query
Classes
Persistence
Enums
CascadeType
DiscriminatorType
EnumType
FetchType
FlushModeType
GenerationType
InheritanceType
LockModeType
PersistenceContextType
TemporalType
Exceptions
EntityExistsException
EntityNotFoundException
NonUniqueResultException
NoResultException
OptimisticLockException
PersistenceException
RollbackException
TransactionRequiredException
Annotation Types
AssociationOverride
AssociationOverrides
AttributeOverride
AttributeOverrides
Basic
Column
ColumnResult
DiscriminatorColumn
DiscriminatorValue
Embeddable
Embedded
EmbeddedId
Entity
EntityListeners
EntityResult
Enumerated
ExcludeDefaultListeners
ExcludeSuperclassListeners
FieldResult
GeneratedValue
Id
IdClass
Inheritance
JoinColumn
JoinColumns
JoinTable
Lob
ManyToMany
ManyToOne
MapKey
MappedSuperclass
NamedNativeQueries
NamedNativeQuery
NamedQueries
NamedQuery
OneToMany
OneToOne
OrderBy
PersistenceContext
PersistenceContexts
PersistenceProperty
PersistenceUnit
PersistenceUnits
PostLoad
PostPersist
PostRemove
PostUpdate
PrePersist
PreRemove
PreUpdate
PrimaryKeyJoinColumn
PrimaryKeyJoinColumns
QueryHint
SecondaryTable
SecondaryTables
SequenceGenerator
SqlResultSetMapping
SqlResultSetMappings
Table
TableGenerator
Temporal
Transient
UniqueConstraint
Version


 javax.persistence.spi
Interfaces
ClassTransformer
PersistenceProvider
PersistenceUnitInfo
Enums
PersistenceUnitTransactionType


 javax.resource
Interfaces
Referenceable
Exceptions
NotSupportedException
ResourceException


 javax.resource.cci
Interfaces
Connection
ConnectionFactory
ConnectionMetaData
ConnectionSpec
IndexedRecord
Interaction
InteractionSpec
LocalTransaction
MappedRecord
MessageListener
Record
RecordFactory
ResourceAdapterMetaData
ResultSet
ResultSetInfo
Streamable
Exceptions
ResourceWarning


 javax.resource.spi
Interfaces
ActivationSpec
BootstrapContext
ConnectionEventListener
ConnectionManager
ConnectionRequestInfo
DissociatableManagedConnection
LazyAssociatableConnectionManager
LazyEnlistableConnectionManager
LazyEnlistableManagedConnection
LocalTransaction
ManagedConnection
ManagedConnectionFactory
ManagedConnectionMetaData
ResourceAdapter
ResourceAdapterAssociation
ValidatingManagedConnectionFactory
XATerminator
Classes
ConnectionEvent
Exceptions
ApplicationServerInternalException
CommException
EISSystemException
IllegalStateException
InvalidPropertyException
LocalTransactionException
ResourceAdapterInternalException
ResourceAllocationException
SecurityException
SharingViolationException
UnavailableException


 javax.resource.spi.endpoint
Interfaces
MessageEndpoint
MessageEndpointFactory


 javax.resource.spi.security
Interfaces
GenericCredential
Classes
PasswordCredential


 javax.resource.spi.work
Interfaces
Work
WorkListener
WorkManager
Classes
ExecutionContext
WorkAdapter
WorkEvent
Exceptions
WorkCompletedException
WorkException
WorkRejectedException


 javax.security.jacc
Interfaces
PolicyConfiguration
PolicyContextHandler
Classes
EJBMethodPermission
EJBRoleRefPermission
PolicyConfigurationFactory
PolicyContext
WebResourcePermission
WebRoleRefPermission
WebUserDataPermission
Exceptions
PolicyContextException


 javax.servlet
Interfaces
Filter
FilterChain
FilterConfig
RequestDispatcher
Servlet
ServletConfig
ServletContext
ServletContextAttributeListener
ServletContextListener
ServletRequest
ServletRequestAttributeListener
ServletRequestListener
ServletResponse
SingleThreadModel
Classes
GenericServlet
ServletContextAttributeEvent
ServletContextEvent
ServletInputStream
ServletOutputStream
ServletRequestAttributeEvent
ServletRequestEvent
ServletRequestWrapper
ServletResponseWrapper
Exceptions
ServletException
UnavailableException


 javax.servlet.http
Interfaces
HttpServletRequest
HttpServletResponse
HttpSession
HttpSessionActivationListener
HttpSessionAttributeListener
HttpSessionBindingListener
HttpSessionContext
HttpSessionListener
Classes
Cookie
HttpServlet
HttpServletRequestWrapper
HttpServletResponseWrapper
HttpSessionBindingEvent
HttpSessionEvent
HttpUtils


 javax.servlet.jsp
Interfaces
HttpJspPage
JspApplicationContext
JspPage
Classes
ErrorData
JspContext
JspEngineInfo
JspFactory
JspWriter
PageContext
Exceptions
JspException
JspTagException
SkipPageException


 javax.servlet.jsp.el
Interfaces
FunctionMapper
VariableResolver
Classes
Expression
ExpressionEvaluator
ImplicitObjectELResolver
ScopedAttributeELResolver
Exceptions
ELException
ELParseException


 javax.servlet.jsp.tagext
Interfaces
BodyTag
DynamicAttributes
IterationTag
JspIdConsumer
JspTag
SimpleTag
Tag
TryCatchFinally
Classes
BodyContent
BodyTagSupport
FunctionInfo
JspFragment
PageData
SimpleTagSupport
TagAdapter
TagAttributeInfo
TagData
TagExtraInfo
TagFileInfo
TagInfo
TagLibraryInfo
TagLibraryValidator
TagSupport
TagVariableInfo
ValidationMessage
VariableInfo


 javax.transaction
Interfaces
Status
Synchronization
Transaction
TransactionManager
TransactionSynchronizationRegistry
UserTransaction
Exceptions
HeuristicCommitException
HeuristicMixedException
HeuristicRollbackException
InvalidTransactionException
NotSupportedException
RollbackException
SystemException
TransactionRequiredException
TransactionRolledbackException


 javax.transaction.xa
Interfaces
XAResource
Xid
Exceptions
XAException


 javax.xml.bind
Interfaces
DatatypeConverterInterface
Element
Marshaller
NotIdentifiableEvent
ParseConversionEvent
PrintConversionEvent
Unmarshaller
UnmarshallerHandler
ValidationEvent
ValidationEventHandler
ValidationEventLocator
Validator
Classes
Binder
DatatypeConverter
JAXBContext
JAXBElement
JAXBElement.GlobalScope
JAXBIntrospector
Marshaller.Listener
SchemaOutputResolver
Unmarshaller.Listener
Exceptions
JAXBException
MarshalException
PropertyException
TypeConstraintException
UnmarshalException
ValidationException


 javax.xml.bind.annotation
Interfaces
DomHandler
Classes
W3CDomHandler
XmlElement.DEFAULT
XmlElementDecl.GLOBAL
XmlElementRef.DEFAULT
XmlSchemaType.DEFAULT
XmlType.DEFAULT
Enums
XmlAccessOrder
XmlAccessType
XmlNsForm
Annotation Types
XmlAccessorOrder
XmlAccessorType
XmlAnyAttribute
XmlAnyElement
XmlAttachmentRef
XmlAttribute
XmlElement
XmlElementDecl
XmlElementRef
XmlElementRefs
XmlElements
XmlElementWrapper
XmlEnum
XmlEnumValue
XmlID
XmlIDREF
XmlInlineBinaryData
XmlList
XmlMimeType
XmlMixed
XmlNs
XmlRegistry
XmlRootElement
XmlSchema
XmlSchemaType
XmlSchemaTypes
XmlTransient
XmlType
XmlValue


 javax.xml.bind.annotation.adapters
Classes
CollapsedStringAdapter
HexBinaryAdapter
NormalizedStringAdapter
XmlAdapter
XmlJavaTypeAdapter.DEFAULT
Annotation Types
XmlJavaTypeAdapter
XmlJavaTypeAdapters


 javax.xml.bind.attachment
Classes
AttachmentMarshaller
AttachmentUnmarshaller


 javax.xml.bind.helpers
Classes
AbstractMarshallerImpl
AbstractUnmarshallerImpl
DefaultValidationEventHandler
NotIdentifiableEventImpl
ParseConversionEventImpl
PrintConversionEventImpl
ValidationEventImpl
ValidationEventLocatorImpl


 javax.xml.bind.util
Classes
JAXBResult
JAXBSource
ValidationEventCollector


 javax.xml.registry
Interfaces
BulkResponse
BusinessLifeCycleManager
BusinessQueryManager
CapabilityProfile
Connection
DeclarativeQueryManager
FederatedConnection
FindQualifier
JAXRResponse
LifeCycleManager
Query
QueryManager
RegistryService
Classes
ConnectionFactory
Exceptions
DeleteException
FindException
InvalidRequestException
JAXRException
RegistryException
SaveException
UnexpectedObjectException
UnsupportedCapabilityException


 javax.xml.registry.infomodel
Interfaces
Association
AuditableEvent
Classification
ClassificationScheme
Concept
EmailAddress
ExtensibleObject
ExternalIdentifier
ExternalLink
ExtrinsicObject
InternationalString
Key
LocalizedString
Organization
PersonName
PostalAddress
RegistryEntry
RegistryObject
RegistryPackage
Service
ServiceBinding
Slot
SpecificationLink
TelephoneNumber
URIValidator
User
Versionable


 javax.xml.rpc
Interfaces
Call
Service
Stub
Classes
NamespaceConstants
ParameterMode
ServiceFactory
Exceptions
JAXRPCException
ServiceException


 javax.xml.rpc.encoding
Interfaces
DeserializationContext
Deserializer
DeserializerFactory
SerializationContext
Serializer
SerializerFactory
TypeMapping
TypeMappingRegistry
Classes
XMLType


 javax.xml.rpc.handler
Interfaces
Handler
HandlerChain
HandlerRegistry
MessageContext
Classes
GenericHandler
HandlerInfo


 javax.xml.rpc.handler.soap
Interfaces
SOAPMessageContext


 javax.xml.rpc.holders
Interfaces
Holder
Classes
BigDecimalHolder
BigIntegerHolder
BooleanHolder
BooleanWrapperHolder
ByteArrayHolder
ByteHolder
ByteWrapperHolder
CalendarHolder
DoubleHolder
DoubleWrapperHolder
FloatHolder
FloatWrapperHolder
IntegerWrapperHolder
IntHolder
LongHolder
LongWrapperHolder
ObjectHolder
QNameHolder
ShortHolder
ShortWrapperHolder
StringHolder


 javax.xml.rpc.server
Interfaces
ServiceLifecycle
ServletEndpointContext


 javax.xml.rpc.soap
Exceptions
SOAPFaultException


 javax.xml.soap
Interfaces
Detail
DetailEntry
Name
Node
SOAPBody
SOAPBodyElement
SOAPConstants
SOAPElement
SOAPEnvelope
SOAPFault
SOAPFaultElement
SOAPHeader
SOAPHeaderElement
Text
Classes
AttachmentPart
MessageFactory
MimeHeader
MimeHeaders
SAAJMetaFactory
SAAJResult
SOAPConnection
SOAPConnectionFactory
SOAPElementFactory
SOAPFactory
SOAPMessage
SOAPPart
Exceptions
SOAPException


 javax.xml.stream
Interfaces
EventFilter
Location
StreamFilter
XMLEventReader
XMLEventWriter
XMLReporter
XMLResolver
XMLStreamConstants
XMLStreamReader
XMLStreamWriter
Classes
XMLEventFactory
XMLInputFactory
XMLOutputFactory
Exceptions
XMLStreamException
Errors
FactoryConfigurationError


 javax.xml.stream.events
Interfaces
Attribute
Characters
Comment
DTD
EndDocument
EndElement
EntityDeclaration
EntityReference
Namespace
NotationDeclaration
ProcessingInstruction
StartDocument
StartElement
XMLEvent


 javax.xml.stream.util
Interfaces
XMLEventAllocator
XMLEventConsumer
Classes
EventReaderDelegate
StreamReaderDelegate


 javax.xml.ws
Interfaces
AsyncHandler
Binding
BindingProvider
Dispatch
LogicalMessage
Provider
Response
WebServiceContext
Classes
Endpoint
Holder
Service
WebServicePermission
Enums
Service.Mode
Exceptions
ProtocolException
WebServiceException
Annotation Types
BindingType
RequestWrapper
ResponseWrapper
ServiceMode
WebEndpoint
WebFault
WebServiceClient
WebServiceProvider
WebServiceRef
WebServiceRefs


 javax.xml.ws.handler
Interfaces
Handler
HandlerResolver
LogicalHandler
LogicalMessageContext
MessageContext
PortInfo
Enums
MessageContext.Scope


 javax.xml.ws.handler.soap
Interfaces
SOAPHandler
SOAPMessageContext


 javax.xml.ws.http
Interfaces
HTTPBinding
Exceptions
HTTPException


 javax.xml.ws.soap
Interfaces
SOAPBinding
Exceptions
SOAPFaultException


 javax.xml.ws.spi
Classes
Provider
ServiceDelegate


Occurences of AbortProcessingException (constructors)

AbortProcessingException (constructors) occurences:
javax.faces.event.AbortProcessingException()
javax.faces.event.AbortProcessingException(java.lang.String)
javax.faces.event.AbortProcessingException(java.lang.String, java.lang.Throwable)
javax.faces.event.AbortProcessingException(java.lang.Throwable)


Occurences of accept

accept occurences:
javax.xml.stream.EventFilter.accept(javax.xml.stream.events.XMLEvent)
javax.xml.stream.StreamFilter.accept(javax.xml.stream.XMLStreamReader)


Occurences of AccessLocalException (constructors)

AccessLocalException (constructors) occurences:
javax.ejb.AccessLocalException()
javax.ejb.AccessLocalException(java.lang.String)
javax.ejb.AccessLocalException(java.lang.String, java.lang.Exception)


Occurences of ActivationDataFlavor (constructors)

ActivationDataFlavor (constructors) occurences:
javax.activation.ActivationDataFlavor(java.lang.Class, java.lang.String)
javax.activation.ActivationDataFlavor(java.lang.Class, java.lang.String, java.lang.String)
javax.activation.ActivationDataFlavor(java.lang.String, java.lang.String)


Occurences of add

add occurences:
javax.el.CompositeELResolver.add(javax.el.ELResolver)
javax.mail.FetchProfile.add(java.lang.String)
javax.mail.FetchProfile.add(javax.mail.FetchProfile.Item)
javax.mail.Flags.add(java.lang.String)
javax.mail.Flags.add(javax.mail.Flags)
javax.mail.Flags.add(javax.mail.Flags.Flag)
javax.xml.stream.util.XMLEventConsumer.add(javax.xml.stream.events.XMLEvent)
javax.xml.stream.XMLEventWriter.add(javax.xml.stream.events.XMLEvent)
javax.xml.stream.XMLEventWriter.add(javax.xml.stream.XMLEventReader)


Occurences of addActionListener

addActionListener occurences:
javax.faces.component.ActionSource.addActionListener(javax.faces.event.ActionListener)
javax.faces.component.UICommand.addActionListener(javax.faces.event.ActionListener)


Occurences of addAttribute

addAttribute occurences:
javax.xml.soap.SOAPElement.addAttribute(javax.xml.namespace.QName, java.lang.String)
javax.xml.soap.SOAPElement.addAttribute(javax.xml.soap.Name, java.lang.String)


Occurences of addBodyElement

addBodyElement occurences:
javax.xml.soap.SOAPBody.addBodyElement(javax.xml.namespace.QName)
javax.xml.soap.SOAPBody.addBodyElement(javax.xml.soap.Name)


Occurences of addBodyPart

addBodyPart occurences:
javax.mail.Multipart.addBodyPart(javax.mail.BodyPart)
javax.mail.Multipart.addBodyPart(javax.mail.BodyPart, int)


Occurences of addChild

addChild occurences:
javax.faces.webapp.UIComponentClassicTagBase.addChild(javax.faces.component.UIComponent)
javax.faces.webapp.UIComponentTagBase.addChild(javax.faces.component.UIComponent)


Occurences of addChildConcept

addChildConcept occurences:
javax.xml.registry.infomodel.ClassificationScheme.addChildConcept(javax.xml.registry.infomodel.Concept)
javax.xml.registry.infomodel.Concept.addChildConcept(javax.xml.registry.infomodel.Concept)


Occurences of addChildConcepts

addChildConcepts occurences:
javax.xml.registry.infomodel.ClassificationScheme.addChildConcepts(java.util.Collection)
javax.xml.registry.infomodel.Concept.addChildConcepts(java.util.Collection)


Occurences of addChildElement

addChildElement occurences:
javax.xml.soap.SOAPElement.addChildElement(java.lang.String)
javax.xml.soap.SOAPElement.addChildElement(java.lang.String, java.lang.String)
javax.xml.soap.SOAPElement.addChildElement(java.lang.String, java.lang.String, java.lang.String)
javax.xml.soap.SOAPElement.addChildElement(javax.xml.namespace.QName)
javax.xml.soap.SOAPElement.addChildElement(javax.xml.soap.Name)
javax.xml.soap.SOAPElement.addChildElement(javax.xml.soap.SOAPElement)


Occurences of addConnectionListener

addConnectionListener occurences:
javax.mail.Folder.addConnectionListener(javax.mail.event.ConnectionListener)
javax.mail.Service.addConnectionListener(javax.mail.event.ConnectionListener)


Occurences of addConverter

addConverter occurences:
javax.faces.application.Application.addConverter(java.lang.Class, java.lang.String)
javax.faces.application.Application.addConverter(java.lang.String, java.lang.String)


Occurences of addCookie

addCookie occurences:
javax.servlet.http.HttpServletResponse.addCookie(javax.servlet.http.Cookie)
javax.servlet.http.HttpServletResponseWrapper.addCookie(javax.servlet.http.Cookie)


Occurences of addDateHeader

addDateHeader occurences:
javax.servlet.http.HttpServletResponse.addDateHeader(java.lang.String, long)
javax.servlet.http.HttpServletResponseWrapper.addDateHeader(java.lang.String, long)


Occurences of addDetailEntry

addDetailEntry occurences:
javax.xml.soap.Detail.addDetailEntry(javax.xml.namespace.QName)
javax.xml.soap.Detail.addDetailEntry(javax.xml.soap.Name)


Occurences of addELContextListener

addELContextListener occurences:
javax.faces.application.Application.addELContextListener(javax.el.ELContextListener)
javax.servlet.jsp.JspApplicationContext.addELContextListener(javax.el.ELContextListener)


Occurences of addELResolver

addELResolver occurences:
javax.faces.application.Application.addELResolver(javax.el.ELResolver)
javax.servlet.jsp.JspApplicationContext.addELResolver(javax.el.ELResolver)


Occurences of addFacesListener

addFacesListener occurences:
javax.faces.component.UIComponent.addFacesListener(javax.faces.event.FacesListener)
javax.faces.component.UIComponentBase.addFacesListener(javax.faces.event.FacesListener)


Occurences of addFacet

addFacet occurences:
javax.faces.webapp.UIComponentClassicTagBase.addFacet(java.lang.String)
javax.faces.webapp.UIComponentTagBase.addFacet(java.lang.String)


Occurences of addFault

addFault occurences:
javax.xml.soap.SOAPBody.addFault()
javax.xml.soap.SOAPBody.addFault(javax.xml.namespace.QName, java.lang.String)
javax.xml.soap.SOAPBody.addFault(javax.xml.namespace.QName, java.lang.String, java.util.Locale)
javax.xml.soap.SOAPBody.addFault(javax.xml.soap.Name, java.lang.String)
javax.xml.soap.SOAPBody.addFault(javax.xml.soap.Name, java.lang.String, java.util.Locale)


Occurences of addFolderListener

addFolderListener occurences:
javax.mail.Folder.addFolderListener(javax.mail.event.FolderListener)
javax.mail.Store.addFolderListener(javax.mail.event.FolderListener)


Occurences of addFrom

addFrom occurences:
javax.mail.internet.MimeMessage.addFrom(javax.mail.Address[])
javax.mail.Message.addFrom(javax.mail.Address[])


Occurences of addHeader

addHeader occurences:
javax.mail.internet.InternetHeaders.addHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimeBodyPart.addHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimeMessage.addHeader(java.lang.String, java.lang.String)
javax.mail.Part.addHeader(java.lang.String, java.lang.String)
javax.servlet.http.HttpServletResponse.addHeader(java.lang.String, java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.addHeader(java.lang.String, java.lang.String)
javax.xml.soap.MimeHeaders.addHeader(java.lang.String, java.lang.String)
javax.xml.soap.SOAPEnvelope.addHeader()


Occurences of addHeaderElement

addHeaderElement occurences:
javax.xml.soap.SOAPHeader.addHeaderElement(javax.xml.namespace.QName)
javax.xml.soap.SOAPHeader.addHeaderElement(javax.xml.soap.Name)


Occurences of addHeaderLine

addHeaderLine occurences:
javax.mail.internet.InternetHeaders.addHeaderLine(java.lang.String)
javax.mail.internet.MimeBodyPart.addHeaderLine(java.lang.String)
javax.mail.internet.MimeMessage.addHeaderLine(java.lang.String)
javax.mail.internet.MimePart.addHeaderLine(java.lang.String)


Occurences of addIntHeader

addIntHeader occurences:
javax.servlet.http.HttpServletResponse.addIntHeader(java.lang.String, int)
javax.servlet.http.HttpServletResponseWrapper.addIntHeader(java.lang.String, int)


Occurences of addMimeHeader

addMimeHeader occurences:
javax.xml.soap.AttachmentPart.addMimeHeader(java.lang.String, java.lang.String)
javax.xml.soap.SOAPPart.addMimeHeader(java.lang.String, java.lang.String)


Occurences of addMtomAttachment

addMtomAttachment occurences:
javax.xml.bind.attachment.AttachmentMarshaller.addMtomAttachment(byte[], int, int, java.lang.String, java.lang.String, java.lang.String)
javax.xml.bind.attachment.AttachmentMarshaller.addMtomAttachment(javax.activation.DataHandler, java.lang.String, java.lang.String)


Occurences of addParameter

addParameter occurences:
javax.xml.rpc.Call.addParameter(java.lang.String, javax.xml.namespace.QName, java.lang.Class, javax.xml.rpc.ParameterMode)
javax.xml.rpc.Call.addParameter(java.lang.String, javax.xml.namespace.QName, javax.xml.rpc.ParameterMode)


Occurences of addPhaseListener

addPhaseListener occurences:
javax.faces.component.UIViewRoot.addPhaseListener(javax.faces.event.PhaseListener)
javax.faces.lifecycle.Lifecycle.addPhaseListener(javax.faces.event.PhaseListener)


Occurences of addPort

addPort occurences:
javax.xml.ws.Service.addPort(javax.xml.namespace.QName, java.lang.String, java.lang.String)
javax.xml.ws.spi.ServiceDelegate.addPort(javax.xml.namespace.QName, java.lang.String, java.lang.String)


Occurences of addRecipients

addRecipients occurences:
javax.mail.internet.MimeMessage.addRecipients(javax.mail.Message.RecipientType, java.lang.String)
javax.mail.internet.MimeMessage.addRecipients(javax.mail.Message.RecipientType, javax.mail.Address[])
javax.mail.Message.addRecipients(javax.mail.Message.RecipientType, javax.mail.Address[])


Occurences of address

address occurences:
javax.mail.internet.address
javax.mail.search.address


Occurences of AddressException (constructors)

AddressException (constructors) occurences:
javax.mail.internet.AddressException()
javax.mail.internet.AddressException(java.lang.String)
javax.mail.internet.AddressException(java.lang.String, java.lang.String)
javax.mail.internet.AddressException(java.lang.String, java.lang.String, int)


Occurences of addToExcludedPolicy

addToExcludedPolicy occurences:
javax.security.jacc.PolicyConfiguration.addToExcludedPolicy(java.security.Permission)
javax.security.jacc.PolicyConfiguration.addToExcludedPolicy(java.security.PermissionCollection)


Occurences of addToRole

addToRole occurences:
javax.security.jacc.PolicyConfiguration.addToRole(java.lang.String, java.security.Permission)
javax.security.jacc.PolicyConfiguration.addToRole(java.lang.String, java.security.PermissionCollection)


Occurences of addToUncheckedPolicy

addToUncheckedPolicy occurences:
javax.security.jacc.PolicyConfiguration.addToUncheckedPolicy(java.security.Permission)
javax.security.jacc.PolicyConfiguration.addToUncheckedPolicy(java.security.PermissionCollection)


Occurences of addUpgradeHeaderElement

addUpgradeHeaderElement occurences:
javax.xml.soap.SOAPHeader.addUpgradeHeaderElement(java.lang.String)
javax.xml.soap.SOAPHeader.addUpgradeHeaderElement(java.lang.String[])
javax.xml.soap.SOAPHeader.addUpgradeHeaderElement(java.util.Iterator)


Occurences of addValidator

addValidator occurences:
javax.faces.application.Application.addValidator(java.lang.String, java.lang.String)
javax.faces.component.EditableValueHolder.addValidator(javax.faces.validator.Validator)
javax.faces.component.UIInput.addValidator(javax.faces.validator.Validator)


Occurences of addValueChangeListener

addValueChangeListener occurences:
javax.faces.component.EditableValueHolder.addValueChangeListener(javax.faces.event.ValueChangeListener)
javax.faces.component.UIInput.addValueChangeListener(javax.faces.event.ValueChangeListener)


Occurences of addXpathListener

addXpathListener occurences:
javax.enterprise.deploy.model.DDBean.addXpathListener(java.lang.String, javax.enterprise.deploy.model.XpathListener)
javax.enterprise.deploy.model.J2eeApplicationObject.addXpathListener(javax.enterprise.deploy.shared.ModuleType, java.lang.String, javax.enterprise.deploy.model.XpathListener)


Occurences of afterCompletion

afterCompletion occurences:
javax.ejb.SessionSynchronization.afterCompletion(boolean)
javax.transaction.Synchronization.afterCompletion(int)


Occurences of ALL

ALL occurences:
javax.mail.internet.ALL
javax.persistence.ALL


Occurences of All Classes

All Classes occurences:
All Classes
All Classes


Occurences of allocate

allocate occurences:
javax.xml.stream.util.XMLEventAllocator.allocate(javax.xml.stream.XMLStreamReader)
javax.xml.stream.util.XMLEventAllocator.allocate(javax.xml.stream.XMLStreamReader, javax.xml.stream.util.XMLEventConsumer)


Occurences of allocationSize

allocationSize occurences:
javax.persistence.SequenceGenerator.allocationSize()
javax.persistence.TableGenerator.allocationSize()


Occurences of AndTerm (constructors)

AndTerm (constructors) occurences:
javax.mail.search.AndTerm(javax.mail.search.SearchTerm, javax.mail.search.SearchTerm)
javax.mail.search.AndTerm(javax.mail.search.SearchTerm[])


Occurences of annotation

annotation occurences:
javax.annotation
javax.xml.bind.annotation


Occurences of annotation_type_element_detail

annotation_type_element_detail occurences:
javax.annotation.annotation_type_element_detail
javax.annotation.annotation_type_element_detail
javax.annotation.security.annotation_type_element_detail
javax.annotation.security.annotation_type_element_detail
javax.annotation.security.annotation_type_element_detail
javax.ejb.annotation_type_element_detail
javax.ejb.annotation_type_element_detail
javax.ejb.annotation_type_element_detail
javax.ejb.annotation_type_element_detail
javax.interceptor.annotation_type_element_detail
javax.jws.annotation_type_element_detail
javax.jws.soap.annotation_type_element_detail
javax.jws.soap.annotation_type_element_detail
javax.jws.soap.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.persistence.annotation_type_element_detail
javax.xml.bind.annotation.adapters.annotation_type_element_detail
javax.xml.bind.annotation.adapters.annotation_type_element_detail
javax.xml.bind.annotation.annotation_type_element_detail
javax.xml.bind.annotation.annotation_type_element_detail
javax.xml.bind.annotation.annotation_type_element_detail
javax.xml.bind.annotation.annotation_type_element_detail
javax.xml.bind.annotation.annotation_type_element_detail
javax.xml.bind.annotation.annotation_type_element_detail
javax.xml.bind.annotation.annotation_type_element_detail
javax.xml.bind.annotation.annotation_type_element_detail
javax.xml.ws.annotation_type_element_detail


Occurences of annotation_type_optional_element_summary

annotation_type_optional_element_summary occurences:
javax.annotation.annotation_type_optional_element_summary
javax.annotation.annotation_type_optional_element_summary
javax.ejb.annotation_type_optional_element_summary
javax.ejb.annotation_type_optional_element_summary
javax.ejb.annotation_type_optional_element_summary
javax.ejb.annotation_type_optional_element_summary
javax.ejb.annotation_type_optional_element_summary
javax.ejb.annotation_type_optional_element_summary
javax.ejb.annotation_type_optional_element_summary
javax.ejb.annotation_type_optional_element_summary
javax.ejb.annotation_type_optional_element_summary
javax.ejb.annotation_type_optional_element_summary
javax.ejb.annotation_type_optional_element_summary
javax.jws.annotation_type_optional_element_summary
javax.jws.annotation_type_optional_element_summary
javax.jws.annotation_type_optional_element_summary
javax.jws.annotation_type_optional_element_summary
javax.jws.annotation_type_optional_element_summary
javax.jws.soap.annotation_type_optional_element_summary
javax.jws.soap.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.persistence.annotation_type_optional_element_summary
javax.xml.bind.annotation.adapters.annotation_type_optional_element_summary
javax.xml.bind.annotation.annotation_type_optional_element_summary
javax.xml.bind.annotation.annotation_type_optional_element_summary
javax.xml.bind.annotation.annotation_type_optional_element_summary
javax.xml.bind.annotation.annotation_type_optional_element_summary
javax.xml.bind.annotation.annotation_type_optional_element_summary
javax.xml.bind.annotation.annotation_type_optional_element_summary
javax.xml.bind.annotation.annotation_type_optional_element_summary
javax.xml.bind.annotation.annotation_type_optional_element_summary
javax.xml.bind.annotation.annotation_type_optional_element_summary
javax.xml.bind.annotation.annotation_type_optional_element_summary
javax.xml.bind.annotation.annotation_type_optional_element_summary
javax.xml.bind.annotation.annotation_type_optional_element_summary
javax.xml.bind.annotation.annotation_type_optional_element_summary
javax.xml.ws.annotation_type_optional_element_summary
javax.xml.ws.annotation_type_optional_element_summary
javax.xml.ws.annotation_type_optional_element_summary
javax.xml.ws.annotation_type_optional_element_summary
javax.xml.ws.annotation_type_optional_element_summary
javax.xml.ws.annotation_type_optional_element_summary
javax.xml.ws.annotation_type_optional_element_summary
javax.xml.ws.annotation_type_optional_element_summary
javax.xml.ws.annotation_type_optional_element_summary


Occurences of annotation_type_required_element_summary

annotation_type_required_element_summary occurences:
javax.annotation.annotation_type_required_element_summary
javax.annotation.annotation_type_required_element_summary
javax.annotation.security.annotation_type_required_element_summary
javax.annotation.security.annotation_type_required_element_summary
javax.annotation.security.annotation_type_required_element_summary
javax.ejb.annotation_type_required_element_summary
javax.ejb.annotation_type_required_element_summary
javax.ejb.annotation_type_required_element_summary
javax.ejb.annotation_type_required_element_summary
javax.interceptor.annotation_type_required_element_summary
javax.jws.annotation_type_required_element_summary
javax.jws.soap.annotation_type_required_element_summary
javax.jws.soap.annotation_type_required_element_summary
javax.jws.soap.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.persistence.annotation_type_required_element_summary
javax.xml.bind.annotation.adapters.annotation_type_required_element_summary
javax.xml.bind.annotation.adapters.annotation_type_required_element_summary
javax.xml.bind.annotation.annotation_type_required_element_summary
javax.xml.bind.annotation.annotation_type_required_element_summary
javax.xml.bind.annotation.annotation_type_required_element_summary
javax.xml.bind.annotation.annotation_type_required_element_summary
javax.xml.bind.annotation.annotation_type_required_element_summary
javax.xml.bind.annotation.annotation_type_required_element_summary
javax.xml.bind.annotation.annotation_type_required_element_summary
javax.xml.bind.annotation.annotation_type_required_element_summary
javax.xml.ws.annotation_type_required_element_summary


Occurences of APPLICATION

APPLICATION occurences:
javax.annotation.APPLICATION
javax.servlet.jsp.APPLICATION
javax.xml.ws.handler.APPLICATION


Occurences of ApplicationServerInternalException (constructors)

ApplicationServerInternalException (constructors) occurences:
javax.resource.spi.ApplicationServerInternalException()
javax.resource.spi.ApplicationServerInternalException(java.lang.String)
javax.resource.spi.ApplicationServerInternalException(java.lang.String, java.lang.String)
javax.resource.spi.ApplicationServerInternalException(java.lang.String, java.lang.Throwable)
javax.resource.spi.ApplicationServerInternalException(java.lang.Throwable)


Occurences of ArrayDataModel (constructors)

ArrayDataModel (constructors) occurences:
javax.faces.model.ArrayDataModel()
javax.faces.model.ArrayDataModel(java.lang.Object[])


Occurences of ArrayELResolver (constructors)

ArrayELResolver (constructors) occurences:
javax.el.ArrayELResolver()
javax.el.ArrayELResolver(boolean)


Occurences of associateConnection

associateConnection occurences:
javax.resource.spi.LazyAssociatableConnectionManager.associateConnection(java.lang.Object, javax.resource.spi.ManagedConnectionFactory, javax.resource.spi.ConnectionRequestInfo)
javax.resource.spi.ManagedConnection.associateConnection(java.lang.Object)


Occurences of attachFile

attachFile occurences:
javax.mail.internet.MimeBodyPart.attachFile(java.io.File)
javax.mail.internet.MimeBodyPart.attachFile(java.lang.String)


Occurences of attributeAdded

attributeAdded occurences:
javax.servlet.http.HttpSessionAttributeListener.attributeAdded(javax.servlet.http.HttpSessionBindingEvent)
javax.servlet.ServletContextAttributeListener.attributeAdded(javax.servlet.ServletContextAttributeEvent)
javax.servlet.ServletRequestAttributeListener.attributeAdded(javax.servlet.ServletRequestAttributeEvent)


Occurences of attributeRemoved

attributeRemoved occurences:
javax.servlet.http.HttpSessionAttributeListener.attributeRemoved(javax.servlet.http.HttpSessionBindingEvent)
javax.servlet.ServletContextAttributeListener.attributeRemoved(javax.servlet.ServletContextAttributeEvent)
javax.servlet.ServletRequestAttributeListener.attributeRemoved(javax.servlet.ServletRequestAttributeEvent)


Occurences of attributeReplaced

attributeReplaced occurences:
javax.servlet.http.HttpSessionAttributeListener.attributeReplaced(javax.servlet.http.HttpSessionBindingEvent)
javax.servlet.ServletContextAttributeListener.attributeReplaced(javax.servlet.ServletContextAttributeEvent)
javax.servlet.ServletRequestAttributeListener.attributeReplaced(javax.servlet.ServletRequestAttributeEvent)


Occurences of AuthenticationFailedException (constructors)

AuthenticationFailedException (constructors) occurences:
javax.mail.AuthenticationFailedException()
javax.mail.AuthenticationFailedException(java.lang.String)


Occurences of AUTO

AUTO occurences:
javax.persistence.AUTO
javax.persistence.AUTO


Occurences of BASIC_AUTH

BASIC_AUTH occurences:
javax.faces.context.BASIC_AUTH
javax.servlet.http.BASIC_AUTH


Occurences of BeanELResolver (constructors)

BeanELResolver (constructors) occurences:
javax.el.BeanELResolver()
javax.el.BeanELResolver(boolean)


Occurences of beforeCompletion

beforeCompletion occurences:
javax.ejb.SessionSynchronization.beforeCompletion()
javax.transaction.Synchronization.beforeCompletion()


Occurences of begin

begin occurences:
javax.persistence.EntityTransaction.begin()
javax.resource.cci.LocalTransaction.begin()
javax.resource.spi.LocalTransaction.begin()
javax.transaction.TransactionManager.begin()
javax.transaction.UserTransaction.begin()


Occurences of BigDecimalHolder (constructors)

BigDecimalHolder (constructors) occurences:
javax.xml.rpc.holders.BigDecimalHolder()
javax.xml.rpc.holders.BigDecimalHolder(java.math.BigDecimal)


Occurences of BigIntegerHolder (constructors)

BigIntegerHolder (constructors) occurences:
javax.xml.rpc.holders.BigIntegerHolder()
javax.xml.rpc.holders.BigIntegerHolder(java.math.BigInteger)


Occurences of bodyContent

bodyContent occurences:
javax.faces.webapp.bodyContent
javax.servlet.jsp.tagext.bodyContent


Occurences of BooleanHolder (constructors)

BooleanHolder (constructors) occurences:
javax.xml.rpc.holders.BooleanHolder()
javax.xml.rpc.holders.BooleanHolder(boolean)


Occurences of BooleanWrapperHolder (constructors)

BooleanWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.BooleanWrapperHolder()
javax.xml.rpc.holders.BooleanWrapperHolder(java.lang.Boolean)


Occurences of broadcast

broadcast occurences:
javax.faces.component.UICommand.broadcast(javax.faces.event.FacesEvent)
javax.faces.component.UIComponent.broadcast(javax.faces.event.FacesEvent)
javax.faces.component.UIComponentBase.broadcast(javax.faces.event.FacesEvent)
javax.faces.component.UIData.broadcast(javax.faces.event.FacesEvent)


Occurences of ByteArrayDataSource (constructors)

ByteArrayDataSource (constructors) occurences:
javax.mail.util.ByteArrayDataSource(byte[], java.lang.String)
javax.mail.util.ByteArrayDataSource(java.io.InputStream, java.lang.String)
javax.mail.util.ByteArrayDataSource(java.lang.String, java.lang.String)


Occurences of ByteArrayHolder (constructors)

ByteArrayHolder (constructors) occurences:
javax.xml.rpc.holders.ByteArrayHolder()
javax.xml.rpc.holders.ByteArrayHolder(byte[])


Occurences of ByteHolder (constructors)

ByteHolder (constructors) occurences:
javax.xml.rpc.holders.ByteHolder()
javax.xml.rpc.holders.ByteHolder(byte)


Occurences of ByteWrapperHolder (constructors)

ByteWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.ByteWrapperHolder()
javax.xml.rpc.holders.ByteWrapperHolder(java.lang.Byte)


Occurences of calculateCharacterEncoding

calculateCharacterEncoding occurences:
javax.faces.application.ViewHandler.calculateCharacterEncoding(javax.faces.context.FacesContext)
javax.faces.application.ViewHandlerWrapper.calculateCharacterEncoding(javax.faces.context.FacesContext)


Occurences of calculateLocale

calculateLocale occurences:
javax.faces.application.ViewHandler.calculateLocale(javax.faces.context.FacesContext)
javax.faces.application.ViewHandlerWrapper.calculateLocale(javax.faces.context.FacesContext)


Occurences of calculateRenderKitId

calculateRenderKitId occurences:
javax.faces.application.ViewHandler.calculateRenderKitId(javax.faces.context.FacesContext)
javax.faces.application.ViewHandlerWrapper.calculateRenderKitId(javax.faces.context.FacesContext)


Occurences of CalendarHolder (constructors)

CalendarHolder (constructors) occurences:
javax.xml.rpc.holders.CalendarHolder()
javax.xml.rpc.holders.CalendarHolder(java.util.Calendar)


Occurences of cancel

cancel occurences:
javax.ejb.Timer.cancel()
javax.enterprise.deploy.spi.status.ProgressObject.cancel()


Occurences of cascade

cascade occurences:
javax.persistence.ManyToMany.cascade()
javax.persistence.ManyToOne.cascade()
javax.persistence.OneToMany.cascade()
javax.persistence.OneToOne.cascade()


Occurences of catalog

catalog occurences:
javax.persistence.JoinTable.catalog()
javax.persistence.SecondaryTable.catalog()
javax.persistence.Table.catalog()
javax.persistence.TableGenerator.catalog()


Occurences of className

className occurences:
javax.jws.soap.SOAPMessageHandler.className()
javax.xml.ws.RequestWrapper.className()
javax.xml.ws.ResponseWrapper.className()


Occurences of clear

clear occurences:
javax.persistence.EntityManager.clear()
javax.servlet.jsp.JspWriter.clear()
javax.xml.rpc.encoding.TypeMappingRegistry.clear()


Occurences of clearBody

clearBody occurences:
javax.jms.Message.clearBody()
javax.servlet.jsp.tagext.BodyContent.clearBody()


Occurences of ClientExecuteException (constructors)

ClientExecuteException (constructors) occurences:
javax.enterprise.deploy.spi.exceptions.ClientExecuteException()
javax.enterprise.deploy.spi.exceptions.ClientExecuteException(java.lang.String)


Occurences of CLIENT_CERT_AUTH

CLIENT_CERT_AUTH occurences:
javax.faces.context.CLIENT_CERT_AUTH
javax.servlet.http.CLIENT_CERT_AUTH


Occurences of clone

clone occurences:
javax.mail.Flags.clone()
javax.mail.internet.InternetAddress.clone()
javax.resource.cci.Record.clone()
javax.servlet.http.Cookie.clone()


Occurences of cloneWithWriter

cloneWithWriter occurences:
javax.faces.context.ResponseWriter.cloneWithWriter(java.io.Writer)
javax.faces.context.ResponseWriterWrapper.cloneWithWriter(java.io.Writer)


Occurences of close

close occurences:
javax.faces.context.ResponseWriterWrapper.close()
javax.jms.Connection.close()
javax.jms.ConnectionConsumer.close()
javax.jms.MessageConsumer.close()
javax.jms.MessageProducer.close()
javax.jms.QueueBrowser.close()
javax.jms.QueueRequestor.close()
javax.jms.Session.close()
javax.jms.TopicRequestor.close()
javax.mail.Folder.close(boolean)
javax.mail.Service.close()
javax.mail.util.SharedFileInputStream.close()
javax.persistence.EntityManager.close()
javax.persistence.EntityManagerFactory.close()
javax.resource.cci.Connection.close()
javax.resource.cci.Interaction.close()
javax.servlet.jsp.JspWriter.close()
javax.xml.registry.Connection.close()
javax.xml.soap.SOAPConnection.close()
javax.xml.stream.util.EventReaderDelegate.close()
javax.xml.stream.util.StreamReaderDelegate.close()
javax.xml.stream.XMLEventReader.close()
javax.xml.stream.XMLEventWriter.close()
javax.xml.stream.XMLStreamReader.close()
javax.xml.stream.XMLStreamWriter.close()
javax.xml.ws.handler.Handler.close(javax.xml.ws.handler.MessageContext)


Occurences of closed

closed occurences:
javax.mail.event.ConnectionAdapter.closed(javax.mail.event.ConnectionEvent)
javax.mail.event.ConnectionListener.closed(javax.mail.event.ConnectionEvent)


Occurences of column

column occurences:
javax.persistence.AttributeOverride.column()
javax.persistence.FieldResult.column()


Occurences of columnDefinition

columnDefinition occurences:
javax.persistence.Column.columnDefinition()
javax.persistence.DiscriminatorColumn.columnDefinition()
javax.persistence.JoinColumn.columnDefinition()
javax.persistence.PrimaryKeyJoinColumn.columnDefinition()


Occurences of COMMENT

COMMENT occurences:
javax.mail.internet.COMMENT
javax.xml.stream.COMMENT


Occurences of CommException (constructors)

CommException (constructors) occurences:
javax.resource.spi.CommException()
javax.resource.spi.CommException(java.lang.String)
javax.resource.spi.CommException(java.lang.String, java.lang.String)
javax.resource.spi.CommException(java.lang.String, java.lang.Throwable)
javax.resource.spi.CommException(java.lang.Throwable)


Occurences of commit

commit occurences:
javax.jms.Session.commit()
javax.jms.XASession.commit()
javax.persistence.EntityTransaction.commit()
javax.resource.cci.LocalTransaction.commit()
javax.resource.spi.LocalTransaction.commit()
javax.resource.spi.XATerminator.commit(javax.transaction.xa.Xid, boolean)
javax.security.jacc.PolicyConfiguration.commit()
javax.transaction.Transaction.commit()
javax.transaction.TransactionManager.commit()
javax.transaction.UserTransaction.commit()
javax.transaction.xa.XAResource.commit(javax.transaction.xa.Xid, boolean)


Occurences of compareTo

compareTo occurences:
javax.faces.application.FacesMessage.Severity.compareTo(java.lang.Object)
javax.faces.event.PhaseId.compareTo(java.lang.Object)


Occurences of compareValues

compareValues occurences:
javax.faces.component.UIInput.compareValues(java.lang.Object, java.lang.Object)
javax.faces.component.UISelectMany.compareValues(java.lang.Object, java.lang.Object)


Occurences of COMPONENT_FAMILY

COMPONENT_FAMILY occurences:
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY
javax.faces.component.COMPONENT_FAMILY


Occurences of COMPONENT_TYPE

COMPONENT_TYPE occurences:
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE
javax.faces.component.html.COMPONENT_TYPE


Occurences of ConcurrentAccessException (constructors)

ConcurrentAccessException (constructors) occurences:
javax.ejb.ConcurrentAccessException()
javax.ejb.ConcurrentAccessException(java.lang.String)
javax.ejb.ConcurrentAccessException(java.lang.String, java.lang.Exception)


Occurences of ConfigurationException (constructors)

ConfigurationException (constructors) occurences:
javax.enterprise.deploy.spi.exceptions.ConfigurationException()
javax.enterprise.deploy.spi.exceptions.ConfigurationException(java.lang.String)


Occurences of connect

connect occurences:
javax.mail.Service.connect()
javax.mail.Service.connect(java.lang.String, int, java.lang.String, java.lang.String)
javax.mail.Service.connect(java.lang.String, java.lang.String)
javax.mail.Service.connect(java.lang.String, java.lang.String, java.lang.String)


Occurences of Connection

Connection occurences:
javax.jms.Connection
javax.resource.cci.Connection
javax.xml.registry.Connection


Occurences of ConnectionEvent

ConnectionEvent occurences:
javax.mail.event.ConnectionEvent
javax.resource.spi.ConnectionEvent


Occurences of ConnectionEvent (constructors)

ConnectionEvent (constructors) occurences:
javax.mail.event.ConnectionEvent(java.lang.Object, int)
javax.resource.spi.ConnectionEvent(javax.resource.spi.ManagedConnection, int)
javax.resource.spi.ConnectionEvent(javax.resource.spi.ManagedConnection, int, java.lang.Exception)


Occurences of ConnectionFactory

ConnectionFactory occurences:
javax.jms.ConnectionFactory
javax.resource.cci.ConnectionFactory
javax.xml.registry.ConnectionFactory


Occurences of ConnectionMetaData

ConnectionMetaData occurences:
javax.jms.ConnectionMetaData
javax.resource.cci.ConnectionMetaData


Occurences of CONTAINER

CONTAINER occurences:
javax.annotation.CONTAINER
javax.ejb.CONTAINER


Occurences of contains

contains occurences:
javax.mail.FetchProfile.contains(java.lang.String)
javax.mail.FetchProfile.contains(javax.mail.FetchProfile.Item)
javax.mail.Flags.contains(java.lang.String)
javax.mail.Flags.contains(javax.mail.Flags)
javax.mail.Flags.contains(javax.mail.Flags.Flag)
javax.persistence.EntityManager.contains(java.lang.Object)


Occurences of containsHeader

containsHeader occurences:
javax.servlet.http.HttpServletResponse.containsHeader(java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.containsHeader(java.lang.String)


Occurences of content

content occurences:
javax.mail.internet.content
javax.mail.internet.content


Occurences of ContentDisposition (constructors)

ContentDisposition (constructors) occurences:
javax.mail.internet.ContentDisposition()
javax.mail.internet.ContentDisposition(java.lang.String)
javax.mail.internet.ContentDisposition(java.lang.String, javax.mail.internet.ParameterList)


Occurences of contentStream

contentStream occurences:
javax.mail.internet.contentStream
javax.mail.internet.contentStream


Occurences of ContentType (constructors)

ContentType (constructors) occurences:
javax.mail.internet.ContentType()
javax.mail.internet.ContentType(java.lang.String)
javax.mail.internet.ContentType(java.lang.String, java.lang.String, javax.mail.internet.ParameterList)


Occurences of ConverterException (constructors)

ConverterException (constructors) occurences:
javax.faces.convert.ConverterException()
javax.faces.convert.ConverterException(java.lang.String)
javax.faces.convert.ConverterException(java.lang.String, java.lang.Throwable)
javax.faces.convert.ConverterException(java.lang.Throwable)
javax.faces.convert.ConverterException(javax.faces.application.FacesMessage)
javax.faces.convert.ConverterException(javax.faces.application.FacesMessage, java.lang.Throwable)


Occurences of CONVERTER_ID

CONVERTER_ID occurences:
javax.faces.convert.CONVERTER_ID
javax.faces.convert.CONVERTER_ID
javax.faces.convert.CONVERTER_ID
javax.faces.convert.CONVERTER_ID
javax.faces.convert.CONVERTER_ID
javax.faces.convert.CONVERTER_ID
javax.faces.convert.CONVERTER_ID
javax.faces.convert.CONVERTER_ID
javax.faces.convert.CONVERTER_ID
javax.faces.convert.CONVERTER_ID
javax.faces.convert.CONVERTER_ID
javax.faces.convert.CONVERTER_ID
javax.faces.convert.CONVERTER_ID


Occurences of create

create occurences:
javax.mail.Folder.create(int)
javax.management.j2ee.ManagementHome.create()
javax.xml.soap.SOAPElementFactory.create(java.lang.String)
javax.xml.soap.SOAPElementFactory.create(java.lang.String, java.lang.String, java.lang.String)
javax.xml.soap.SOAPElementFactory.create(javax.xml.soap.Name)
javax.xml.ws.Endpoint.create(java.lang.Object)
javax.xml.ws.Endpoint.create(java.lang.String, java.lang.Object)
javax.xml.ws.Service.create(java.net.URL, javax.xml.namespace.QName)
javax.xml.ws.Service.create(javax.xml.namespace.QName)


Occurences of createAttachmentPart

createAttachmentPart occurences:
javax.xml.soap.SOAPMessage.createAttachmentPart()
javax.xml.soap.SOAPMessage.createAttachmentPart(java.lang.Object, java.lang.String)
javax.xml.soap.SOAPMessage.createAttachmentPart(javax.activation.DataHandler)


Occurences of createAttribute

createAttribute occurences:
javax.xml.stream.XMLEventFactory.createAttribute(java.lang.String, java.lang.String)
javax.xml.stream.XMLEventFactory.createAttribute(java.lang.String, java.lang.String, java.lang.String, java.lang.String)
javax.xml.stream.XMLEventFactory.createAttribute(javax.xml.namespace.QName, java.lang.String)


Occurences of createBinder

createBinder occurences:
javax.xml.bind.JAXBContext.createBinder()
javax.xml.bind.JAXBContext.createBinder(java.lang.Class)


Occurences of createBrowser

createBrowser occurences:
javax.jms.QueueSession.createBrowser(javax.jms.Queue)
javax.jms.QueueSession.createBrowser(javax.jms.Queue, java.lang.String)
javax.jms.Session.createBrowser(javax.jms.Queue)
javax.jms.Session.createBrowser(javax.jms.Queue, java.lang.String)


Occurences of createCall

createCall occurences:
javax.xml.rpc.Service.createCall()
javax.xml.rpc.Service.createCall(javax.xml.namespace.QName)
javax.xml.rpc.Service.createCall(javax.xml.namespace.QName, java.lang.String)
javax.xml.rpc.Service.createCall(javax.xml.namespace.QName, javax.xml.namespace.QName)


Occurences of createClassification

createClassification occurences:
javax.xml.registry.LifeCycleManager.createClassification(javax.xml.registry.infomodel.ClassificationScheme, java.lang.String, java.lang.String)
javax.xml.registry.LifeCycleManager.createClassification(javax.xml.registry.infomodel.ClassificationScheme, javax.xml.registry.infomodel.InternationalString, java.lang.String)
javax.xml.registry.LifeCycleManager.createClassification(javax.xml.registry.infomodel.Concept)


Occurences of createClassificationScheme

createClassificationScheme occurences:
javax.xml.registry.LifeCycleManager.createClassificationScheme(java.lang.String, java.lang.String)
javax.xml.registry.LifeCycleManager.createClassificationScheme(javax.xml.registry.infomodel.Concept)
javax.xml.registry.LifeCycleManager.createClassificationScheme(javax.xml.registry.infomodel.InternationalString, javax.xml.registry.infomodel.InternationalString)


Occurences of createComponent

createComponent occurences:
javax.faces.application.Application.createComponent(java.lang.String)
javax.faces.application.Application.createComponent(javax.el.ValueExpression, javax.faces.context.FacesContext, java.lang.String)
javax.faces.application.Application.createComponent(javax.faces.el.ValueBinding, javax.faces.context.FacesContext, java.lang.String)
javax.faces.webapp.UIComponentClassicTagBase.createComponent(javax.faces.context.FacesContext, java.lang.String)
javax.faces.webapp.UIComponentELTag.createComponent(javax.faces.context.FacesContext, java.lang.String)
javax.faces.webapp.UIComponentTag.createComponent(javax.faces.context.FacesContext, java.lang.String)


Occurences of createConcept

createConcept occurences:
javax.xml.registry.LifeCycleManager.createConcept(javax.xml.registry.infomodel.RegistryObject, java.lang.String, java.lang.String)
javax.xml.registry.LifeCycleManager.createConcept(javax.xml.registry.infomodel.RegistryObject, javax.xml.registry.infomodel.InternationalString, java.lang.String)


Occurences of createConnection

createConnection occurences:
javax.jms.ConnectionFactory.createConnection()
javax.jms.ConnectionFactory.createConnection(java.lang.String, java.lang.String)
javax.xml.registry.ConnectionFactory.createConnection()
javax.xml.soap.SOAPConnectionFactory.createConnection()


Occurences of createConnectionConsumer

createConnectionConsumer occurences:
javax.jms.Connection.createConnectionConsumer(javax.jms.Destination, java.lang.String, javax.jms.ServerSessionPool, int)
javax.jms.QueueConnection.createConnectionConsumer(javax.jms.Queue, java.lang.String, javax.jms.ServerSessionPool, int)
javax.jms.TopicConnection.createConnectionConsumer(javax.jms.Topic, java.lang.String, javax.jms.ServerSessionPool, int)


Occurences of createConnectionFactory

createConnectionFactory occurences:
javax.resource.spi.ManagedConnectionFactory.createConnectionFactory()
javax.resource.spi.ManagedConnectionFactory.createConnectionFactory(javax.resource.spi.ConnectionManager)


Occurences of createConsumer

createConsumer occurences:
javax.jms.Session.createConsumer(javax.jms.Destination)
javax.jms.Session.createConsumer(javax.jms.Destination, java.lang.String)
javax.jms.Session.createConsumer(javax.jms.Destination, java.lang.String, boolean)


Occurences of createConverter

createConverter occurences:
javax.faces.application.Application.createConverter(java.lang.Class)
javax.faces.application.Application.createConverter(java.lang.String)
javax.faces.webapp.ConverterELTag.createConverter()
javax.faces.webapp.ConverterTag.createConverter()


Occurences of createDataContentHandler

createDataContentHandler occurences:
javax.activation.CommandMap.createDataContentHandler(java.lang.String)
javax.activation.CommandMap.createDataContentHandler(java.lang.String, javax.activation.DataSource)
javax.activation.DataContentHandlerFactory.createDataContentHandler(java.lang.String)
javax.activation.MailcapCommandMap.createDataContentHandler(java.lang.String)


Occurences of createDispatch

createDispatch occurences:
javax.xml.ws.Service.createDispatch(javax.xml.namespace.QName, java.lang.Class, javax.xml.ws.Service.Mode)
javax.xml.ws.Service.createDispatch(javax.xml.namespace.QName, javax.xml.bind.JAXBContext, javax.xml.ws.Service.Mode)
javax.xml.ws.spi.ServiceDelegate.createDispatch(javax.xml.namespace.QName, java.lang.Class, javax.xml.ws.Service.Mode)
javax.xml.ws.spi.ServiceDelegate.createDispatch(javax.xml.namespace.QName, javax.xml.bind.JAXBContext, javax.xml.ws.Service.Mode)


Occurences of createDurableConnectionConsumer

createDurableConnectionConsumer occurences:
javax.jms.Connection.createDurableConnectionConsumer(javax.jms.Topic, java.lang.String, java.lang.String, javax.jms.ServerSessionPool, int)
javax.jms.TopicConnection.createDurableConnectionConsumer(javax.jms.Topic, java.lang.String, java.lang.String, javax.jms.ServerSessionPool, int)


Occurences of createDurableSubscriber

createDurableSubscriber occurences:
javax.jms.Session.createDurableSubscriber(javax.jms.Topic, java.lang.String)
javax.jms.Session.createDurableSubscriber(javax.jms.Topic, java.lang.String, java.lang.String, boolean)
javax.jms.TopicSession.createDurableSubscriber(javax.jms.Topic, java.lang.String)
javax.jms.TopicSession.createDurableSubscriber(javax.jms.Topic, java.lang.String, java.lang.String, boolean)


Occurences of createElement

createElement occurences:
javax.xml.soap.SOAPFactory.createElement(java.lang.String)
javax.xml.soap.SOAPFactory.createElement(java.lang.String, java.lang.String, java.lang.String)
javax.xml.soap.SOAPFactory.createElement(javax.xml.namespace.QName)
javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name)
javax.xml.soap.SOAPFactory.createElement(org.w3c.dom.Element)


Occurences of createEmailAddress

createEmailAddress occurences:
javax.xml.registry.LifeCycleManager.createEmailAddress(java.lang.String)
javax.xml.registry.LifeCycleManager.createEmailAddress(java.lang.String, java.lang.String)


Occurences of createEndElement

createEndElement occurences:
javax.xml.stream.XMLEventFactory.createEndElement(java.lang.String, java.lang.String, java.lang.String)
javax.xml.stream.XMLEventFactory.createEndElement(java.lang.String, java.lang.String, java.lang.String, java.util.Iterator)
javax.xml.stream.XMLEventFactory.createEndElement(javax.xml.namespace.QName, java.util.Iterator)


Occurences of createEndpoint

createEndpoint occurences:
javax.resource.spi.endpoint.MessageEndpointFactory.createEndpoint(javax.transaction.xa.XAResource)
javax.xml.ws.spi.Provider.createEndpoint(java.lang.String, java.lang.Object)


Occurences of createEntityManager

createEntityManager occurences:
javax.persistence.EntityManagerFactory.createEntityManager()
javax.persistence.EntityManagerFactory.createEntityManager(java.util.Map)


Occurences of createEntityManagerFactory

createEntityManagerFactory occurences:
javax.persistence.Persistence.createEntityManagerFactory(java.lang.String)
javax.persistence.Persistence.createEntityManagerFactory(java.lang.String, java.util.Map)
javax.persistence.spi.PersistenceProvider.createEntityManagerFactory(java.lang.String, java.util.Map)


Occurences of CreateException (constructors)

CreateException (constructors) occurences:
javax.ejb.CreateException()
javax.ejb.CreateException(java.lang.String)


Occurences of createExternalIdentifier

createExternalIdentifier occurences:
javax.xml.registry.LifeCycleManager.createExternalIdentifier(javax.xml.registry.infomodel.ClassificationScheme, java.lang.String, java.lang.String)
javax.xml.registry.LifeCycleManager.createExternalIdentifier(javax.xml.registry.infomodel.ClassificationScheme, javax.xml.registry.infomodel.InternationalString, java.lang.String)


Occurences of createExternalLink

createExternalLink occurences:
javax.xml.registry.LifeCycleManager.createExternalLink(java.lang.String, java.lang.String)
javax.xml.registry.LifeCycleManager.createExternalLink(java.lang.String, javax.xml.registry.infomodel.InternationalString)


Occurences of createFault

createFault occurences:
javax.xml.soap.SOAPFactory.createFault()
javax.xml.soap.SOAPFactory.createFault(java.lang.String, javax.xml.namespace.QName)


Occurences of createFilteredReader

createFilteredReader occurences:
javax.xml.stream.XMLInputFactory.createFilteredReader(javax.xml.stream.XMLEventReader, javax.xml.stream.EventFilter)
javax.xml.stream.XMLInputFactory.createFilteredReader(javax.xml.stream.XMLStreamReader, javax.xml.stream.StreamFilter)


Occurences of createInternationalString

createInternationalString occurences:
javax.xml.registry.LifeCycleManager.createInternationalString()
javax.xml.registry.LifeCycleManager.createInternationalString(java.lang.String)
javax.xml.registry.LifeCycleManager.createInternationalString(java.util.Locale, java.lang.String)


Occurences of createInternetHeaders

createInternetHeaders occurences:
javax.mail.internet.MimeMessage.createInternetHeaders(java.io.InputStream)
javax.mail.internet.MimeMultipart.createInternetHeaders(java.io.InputStream)


Occurences of createLocalizedString

createLocalizedString occurences:
javax.xml.registry.LifeCycleManager.createLocalizedString(java.util.Locale, java.lang.String)
javax.xml.registry.LifeCycleManager.createLocalizedString(java.util.Locale, java.lang.String, java.lang.String)


Occurences of createMessage

createMessage occurences:
javax.jms.Session.createMessage()
javax.xml.soap.MessageFactory.createMessage()
javax.xml.soap.MessageFactory.createMessage(javax.xml.soap.MimeHeaders, java.io.InputStream)


Occurences of createMimeBodyPart

createMimeBodyPart occurences:
javax.mail.internet.MimeMultipart.createMimeBodyPart(java.io.InputStream)
javax.mail.internet.MimeMultipart.createMimeBodyPart(javax.mail.internet.InternetHeaders, byte[])


Occurences of createName

createName occurences:
javax.xml.soap.SOAPEnvelope.createName(java.lang.String)
javax.xml.soap.SOAPEnvelope.createName(java.lang.String, java.lang.String, java.lang.String)
javax.xml.soap.SOAPFactory.createName(java.lang.String)
javax.xml.soap.SOAPFactory.createName(java.lang.String, java.lang.String, java.lang.String)


Occurences of createNamespace

createNamespace occurences:
javax.xml.stream.XMLEventFactory.createNamespace(java.lang.String)
javax.xml.stream.XMLEventFactory.createNamespace(java.lang.String, java.lang.String)


Occurences of createNativeQuery

createNativeQuery occurences:
javax.persistence.EntityManager.createNativeQuery(java.lang.String)
javax.persistence.EntityManager.createNativeQuery(java.lang.String, java.lang.Class)
javax.persistence.EntityManager.createNativeQuery(java.lang.String, java.lang.String)


Occurences of createObjectMessage

createObjectMessage occurences:
javax.jms.Session.createObjectMessage()
javax.jms.Session.createObjectMessage(java.io.Serializable)


Occurences of createOrganization

createOrganization occurences:
javax.xml.registry.LifeCycleManager.createOrganization(java.lang.String)
javax.xml.registry.LifeCycleManager.createOrganization(javax.xml.registry.infomodel.InternationalString)


Occurences of createPersonName

createPersonName occurences:
javax.xml.registry.LifeCycleManager.createPersonName(java.lang.String)
javax.xml.registry.LifeCycleManager.createPersonName(java.lang.String, java.lang.String, java.lang.String)


Occurences of createQuery

createQuery occurences:
javax.persistence.EntityManager.createQuery(java.lang.String)
javax.xml.registry.DeclarativeQueryManager.createQuery(int, java.lang.String)


Occurences of createQueue

createQueue occurences:
javax.jms.QueueSession.createQueue(java.lang.String)
javax.jms.Session.createQueue(java.lang.String)


Occurences of createQueueConnection

createQueueConnection occurences:
javax.jms.QueueConnectionFactory.createQueueConnection()
javax.jms.QueueConnectionFactory.createQueueConnection(java.lang.String, java.lang.String)


Occurences of createQueueSession

createQueueSession occurences:
javax.jms.QueueConnection.createQueueSession(boolean, int)
javax.jms.XAQueueConnection.createQueueSession(boolean, int)


Occurences of createReceiver

createReceiver occurences:
javax.jms.QueueSession.createReceiver(javax.jms.Queue)
javax.jms.QueueSession.createReceiver(javax.jms.Queue, java.lang.String)


Occurences of createRegistryPackage

createRegistryPackage occurences:
javax.xml.registry.LifeCycleManager.createRegistryPackage(java.lang.String)
javax.xml.registry.LifeCycleManager.createRegistryPackage(javax.xml.registry.infomodel.InternationalString)


Occurences of createService

createService occurences:
javax.xml.registry.LifeCycleManager.createService(java.lang.String)
javax.xml.registry.LifeCycleManager.createService(javax.xml.registry.infomodel.InternationalString)
javax.xml.rpc.ServiceFactory.createService(java.net.URL, javax.xml.namespace.QName)
javax.xml.rpc.ServiceFactory.createService(javax.xml.namespace.QName)


Occurences of createSession

createSession occurences:
javax.jms.Connection.createSession(boolean, int)
javax.jms.XAConnection.createSession(boolean, int)


Occurences of createSlot

createSlot occurences:
javax.xml.registry.LifeCycleManager.createSlot(java.lang.String, java.lang.String, java.lang.String)
javax.xml.registry.LifeCycleManager.createSlot(java.lang.String, java.util.Collection, java.lang.String)


Occurences of createStartDocument

createStartDocument occurences:
javax.xml.stream.XMLEventFactory.createStartDocument()
javax.xml.stream.XMLEventFactory.createStartDocument(java.lang.String)
javax.xml.stream.XMLEventFactory.createStartDocument(java.lang.String, java.lang.String)
javax.xml.stream.XMLEventFactory.createStartDocument(java.lang.String, java.lang.String, boolean)


Occurences of createStartElement

createStartElement occurences:
javax.xml.stream.XMLEventFactory.createStartElement(java.lang.String, java.lang.String, java.lang.String)
javax.xml.stream.XMLEventFactory.createStartElement(java.lang.String, java.lang.String, java.lang.String, java.util.Iterator, java.util.Iterator)
javax.xml.stream.XMLEventFactory.createStartElement(java.lang.String, java.lang.String, java.lang.String, java.util.Iterator, java.util.Iterator, javax.xml.namespace.NamespaceContext)
javax.xml.stream.XMLEventFactory.createStartElement(javax.xml.namespace.QName, java.util.Iterator, java.util.Iterator)


Occurences of createSubscriber

createSubscriber occurences:
javax.jms.TopicSession.createSubscriber(javax.jms.Topic)
javax.jms.TopicSession.createSubscriber(javax.jms.Topic, java.lang.String, boolean)


Occurences of createTemporaryQueue

createTemporaryQueue occurences:
javax.jms.QueueSession.createTemporaryQueue()
javax.jms.Session.createTemporaryQueue()


Occurences of createTemporaryTopic

createTemporaryTopic occurences:
javax.jms.Session.createTemporaryTopic()
javax.jms.TopicSession.createTemporaryTopic()


Occurences of createTextMessage

createTextMessage occurences:
javax.jms.Session.createTextMessage()
javax.jms.Session.createTextMessage(java.lang.String)


Occurences of createTimer

createTimer occurences:
javax.ejb.TimerService.createTimer(java.util.Date, java.io.Serializable)
javax.ejb.TimerService.createTimer(java.util.Date, long, java.io.Serializable)
javax.ejb.TimerService.createTimer(long, java.io.Serializable)
javax.ejb.TimerService.createTimer(long, long, java.io.Serializable)
javax.resource.spi.BootstrapContext.createTimer()


Occurences of createTopic

createTopic occurences:
javax.jms.Session.createTopic(java.lang.String)
javax.jms.TopicSession.createTopic(java.lang.String)


Occurences of createTopicConnection

createTopicConnection occurences:
javax.jms.TopicConnectionFactory.createTopicConnection()
javax.jms.TopicConnectionFactory.createTopicConnection(java.lang.String, java.lang.String)


Occurences of createTopicSession

createTopicSession occurences:
javax.jms.TopicConnection.createTopicSession(boolean, int)
javax.jms.XATopicConnection.createTopicSession(boolean, int)


Occurences of createUnmarshaller

createUnmarshaller occurences:
javax.xml.bind.annotation.DomHandler.createUnmarshaller(javax.xml.bind.ValidationEventHandler)
javax.xml.bind.annotation.W3CDomHandler.createUnmarshaller(javax.xml.bind.ValidationEventHandler)
javax.xml.bind.JAXBContext.createUnmarshaller()


Occurences of createValidator

createValidator occurences:
javax.faces.application.Application.createValidator(java.lang.String)
javax.faces.webapp.ValidatorELTag.createValidator()
javax.faces.webapp.ValidatorTag.createValidator()
javax.xml.bind.JAXBContext.createValidator()


Occurences of createValueExpression

createValueExpression occurences:
javax.el.ExpressionFactory.createValueExpression(java.lang.Object, java.lang.Class)
javax.el.ExpressionFactory.createValueExpression(javax.el.ELContext, java.lang.String, java.lang.Class)


Occurences of createView

createView occurences:
javax.faces.application.ViewHandler.createView(javax.faces.context.FacesContext, java.lang.String)
javax.faces.application.ViewHandlerWrapper.createView(javax.faces.context.FacesContext, java.lang.String)


Occurences of createXAConnection

createXAConnection occurences:
javax.jms.XAConnectionFactory.createXAConnection()
javax.jms.XAConnectionFactory.createXAConnection(java.lang.String, java.lang.String)


Occurences of createXAQueueConnection

createXAQueueConnection occurences:
javax.jms.XAQueueConnectionFactory.createXAQueueConnection()
javax.jms.XAQueueConnectionFactory.createXAQueueConnection(java.lang.String, java.lang.String)


Occurences of createXATopicConnection

createXATopicConnection occurences:
javax.jms.XATopicConnectionFactory.createXATopicConnection()
javax.jms.XATopicConnectionFactory.createXATopicConnection(java.lang.String, java.lang.String)


Occurences of createXMLEventReader

createXMLEventReader occurences:
javax.xml.stream.XMLInputFactory.createXMLEventReader(java.io.InputStream)
javax.xml.stream.XMLInputFactory.createXMLEventReader(java.io.InputStream, java.lang.String)
javax.xml.stream.XMLInputFactory.createXMLEventReader(java.io.Reader)
javax.xml.stream.XMLInputFactory.createXMLEventReader(java.lang.String, java.io.InputStream)
javax.xml.stream.XMLInputFactory.createXMLEventReader(java.lang.String, java.io.Reader)
javax.xml.stream.XMLInputFactory.createXMLEventReader(javax.xml.stream.XMLStreamReader)
javax.xml.stream.XMLInputFactory.createXMLEventReader(javax.xml.transform.Source)


Occurences of createXMLEventWriter

createXMLEventWriter occurences:
javax.xml.stream.XMLOutputFactory.createXMLEventWriter(java.io.OutputStream)
javax.xml.stream.XMLOutputFactory.createXMLEventWriter(java.io.OutputStream, java.lang.String)
javax.xml.stream.XMLOutputFactory.createXMLEventWriter(java.io.Writer)
javax.xml.stream.XMLOutputFactory.createXMLEventWriter(javax.xml.transform.Result)


Occurences of createXMLStreamReader

createXMLStreamReader occurences:
javax.xml.stream.XMLInputFactory.createXMLStreamReader(java.io.InputStream)
javax.xml.stream.XMLInputFactory.createXMLStreamReader(java.io.InputStream, java.lang.String)
javax.xml.stream.XMLInputFactory.createXMLStreamReader(java.io.Reader)
javax.xml.stream.XMLInputFactory.createXMLStreamReader(java.lang.String, java.io.InputStream)
javax.xml.stream.XMLInputFactory.createXMLStreamReader(java.lang.String, java.io.Reader)
javax.xml.stream.XMLInputFactory.createXMLStreamReader(javax.xml.transform.Source)


Occurences of createXMLStreamWriter

createXMLStreamWriter occurences:
javax.xml.stream.XMLOutputFactory.createXMLStreamWriter(java.io.OutputStream)
javax.xml.stream.XMLOutputFactory.createXMLStreamWriter(java.io.OutputStream, java.lang.String)
javax.xml.stream.XMLOutputFactory.createXMLStreamWriter(java.io.Writer)
javax.xml.stream.XMLOutputFactory.createXMLStreamWriter(javax.xml.transform.Result)


Occurences of DataHandler (constructors)

DataHandler (constructors) occurences:
javax.activation.DataHandler(java.lang.Object, java.lang.String)
javax.activation.DataHandler(java.net.URL)
javax.activation.DataHandler(javax.activation.DataSource)


Occurences of date

date occurences:
javax.annotation.Generated.date()
javax.mail.search.date


Occurences of DDBeanCreateException (constructors)

DDBeanCreateException (constructors) occurences:
javax.enterprise.deploy.model.exceptions.DDBeanCreateException()
javax.enterprise.deploy.model.exceptions.DDBeanCreateException(java.lang.String)


Occurences of decode

decode occurences:
javax.faces.component.UIComponent.decode(javax.faces.context.FacesContext)
javax.faces.component.UIComponentBase.decode(javax.faces.context.FacesContext)
javax.faces.component.UIInput.decode(javax.faces.context.FacesContext)
javax.faces.render.Renderer.decode(javax.faces.context.FacesContext, javax.faces.component.UIComponent)
javax.mail.internet.MimeUtility.decode(java.io.InputStream, java.lang.String)


Occurences of defaultValue

defaultValue occurences:
javax.xml.bind.annotation.XmlElement.defaultValue()
javax.xml.bind.annotation.XmlElementDecl.defaultValue()


Occurences of delete

delete occurences:
javax.jms.TemporaryQueue.delete()
javax.jms.TemporaryTopic.delete()
javax.mail.Folder.delete(boolean)
javax.security.jacc.PolicyConfiguration.delete()


Occurences of DELETED

DELETED occurences:
javax.mail.DELETED
javax.mail.event.DELETED


Occurences of DeleteException (constructors)

DeleteException (constructors) occurences:
javax.xml.registry.DeleteException()
javax.xml.registry.DeleteException(java.lang.String)
javax.xml.registry.DeleteException(java.lang.String, java.lang.Throwable)
javax.xml.registry.DeleteException(java.lang.Throwable)


Occurences of deleteObjects

deleteObjects occurences:
javax.xml.registry.LifeCycleManager.deleteObjects(java.util.Collection)
javax.xml.registry.LifeCycleManager.deleteObjects(java.util.Collection, java.lang.String)


Occurences of description

description occurences:
javax.annotation.Resource.description()
javax.ejb.EJB.description()
javax.ejb.MessageDriven.description()
javax.ejb.Stateful.description()
javax.ejb.Stateless.description()


Occurences of destroy

destroy occurences:
javax.faces.webapp.FacesServlet.destroy()
javax.resource.spi.ManagedConnection.destroy()
javax.servlet.Filter.destroy()
javax.servlet.GenericServlet.destroy()
javax.servlet.Servlet.destroy()
javax.xml.rpc.handler.GenericHandler.destroy()
javax.xml.rpc.handler.Handler.destroy()
javax.xml.rpc.handler.HandlerChain.destroy()
javax.xml.rpc.server.ServiceLifecycle.destroy()


Occurences of dh

dh occurences:
javax.mail.internet.dh
javax.mail.internet.dh


Occurences of DIGEST_AUTH

DIGEST_AUTH occurences:
javax.faces.context.DIGEST_AUTH
javax.servlet.http.DIGEST_AUTH


Occurences of disconnected

disconnected occurences:
javax.mail.event.ConnectionAdapter.disconnected(javax.mail.event.ConnectionEvent)
javax.mail.event.ConnectionListener.disconnected(javax.mail.event.ConnectionEvent)


Occurences of dispatch

dispatch occurences:
javax.faces.context.ExternalContext.dispatch(java.lang.String)
javax.mail.event.ConnectionEvent.dispatch(java.lang.Object)
javax.mail.event.FolderEvent.dispatch(java.lang.Object)
javax.mail.event.MailEvent.dispatch(java.lang.Object)
javax.mail.event.MessageChangedEvent.dispatch(java.lang.Object)
javax.mail.event.MessageCountEvent.dispatch(java.lang.Object)
javax.mail.event.StoreEvent.dispatch(java.lang.Object)
javax.mail.event.TransportEvent.dispatch(java.lang.Object)


Occurences of distribute

distribute occurences:
javax.enterprise.deploy.spi.DeploymentManager.distribute(javax.enterprise.deploy.spi.Target[], java.io.File, java.io.File)
javax.enterprise.deploy.spi.DeploymentManager.distribute(javax.enterprise.deploy.spi.Target[], java.io.InputStream, java.io.InputStream)
javax.enterprise.deploy.spi.DeploymentManager.distribute(javax.enterprise.deploy.spi.Target[], javax.enterprise.deploy.shared.ModuleType, java.io.InputStream, java.io.InputStream)


Occurences of doAfterBody

doAfterBody occurences:
javax.faces.webapp.UIComponentClassicTagBase.doAfterBody()
javax.servlet.jsp.tagext.BodyTagSupport.doAfterBody()
javax.servlet.jsp.tagext.IterationTag.doAfterBody()
javax.servlet.jsp.tagext.TagSupport.doAfterBody()


Occurences of doEndTag

doEndTag occurences:
javax.faces.webapp.AttributeTag.doEndTag()
javax.faces.webapp.UIComponentClassicTagBase.doEndTag()
javax.servlet.jsp.tagext.BodyTagSupport.doEndTag()
javax.servlet.jsp.tagext.Tag.doEndTag()
javax.servlet.jsp.tagext.TagAdapter.doEndTag()
javax.servlet.jsp.tagext.TagSupport.doEndTag()


Occurences of doFilter

doFilter occurences:
javax.servlet.Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)
javax.servlet.FilterChain.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse)


Occurences of doInitBody

doInitBody occurences:
javax.faces.webapp.UIComponentClassicTagBase.doInitBody()
javax.servlet.jsp.tagext.BodyTag.doInitBody()
javax.servlet.jsp.tagext.BodyTagSupport.doInitBody()


Occurences of doStartTag

doStartTag occurences:
javax.faces.webapp.AttributeTag.doStartTag()
javax.faces.webapp.ConverterELTag.doStartTag()
javax.faces.webapp.ConverterTag.doStartTag()
javax.faces.webapp.FacetTag.doStartTag()
javax.faces.webapp.UIComponentClassicTagBase.doStartTag()
javax.faces.webapp.ValidatorELTag.doStartTag()
javax.faces.webapp.ValidatorTag.doStartTag()
javax.servlet.jsp.tagext.BodyTagSupport.doStartTag()
javax.servlet.jsp.tagext.Tag.doStartTag()
javax.servlet.jsp.tagext.TagAdapter.doStartTag()
javax.servlet.jsp.tagext.TagSupport.doStartTag()


Occurences of doTag

doTag occurences:
javax.servlet.jsp.tagext.SimpleTag.doTag()
javax.servlet.jsp.tagext.SimpleTagSupport.doTag()


Occurences of DoubleHolder (constructors)

DoubleHolder (constructors) occurences:
javax.xml.rpc.holders.DoubleHolder()
javax.xml.rpc.holders.DoubleHolder(double)


Occurences of DoubleRangeValidator (constructors)

DoubleRangeValidator (constructors) occurences:
javax.faces.validator.DoubleRangeValidator()
javax.faces.validator.DoubleRangeValidator(double)
javax.faces.validator.DoubleRangeValidator(double, double)


Occurences of DoubleWrapperHolder (constructors)

DoubleWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.DoubleWrapperHolder()
javax.xml.rpc.holders.DoubleWrapperHolder(java.lang.Double)


Occurences of doWork

doWork occurences:
javax.resource.spi.work.WorkManager.doWork(javax.resource.spi.work.Work)
javax.resource.spi.work.WorkManager.doWork(javax.resource.spi.work.Work, long, javax.resource.spi.work.ExecutionContext, javax.resource.spi.work.WorkListener)


Occurences of DTD

DTD occurences:
javax.xml.stream.DTD
javax.xml.stream.events.DTD


Occurences of DuplicateKeyException (constructors)

DuplicateKeyException (constructors) occurences:
javax.ejb.DuplicateKeyException()
javax.ejb.DuplicateKeyException(java.lang.String)


Occurences of EISSystemException (constructors)

EISSystemException (constructors) occurences:
javax.resource.spi.EISSystemException()
javax.resource.spi.EISSystemException(java.lang.String)
javax.resource.spi.EISSystemException(java.lang.String, java.lang.String)
javax.resource.spi.EISSystemException(java.lang.String, java.lang.Throwable)
javax.resource.spi.EISSystemException(java.lang.Throwable)


Occurences of EJB

EJB occurences:
javax.ejb.EJB
javax.enterprise.deploy.shared.EJB


Occurences of EJBAccessException (constructors)

EJBAccessException (constructors) occurences:
javax.ejb.EJBAccessException()
javax.ejb.EJBAccessException(java.lang.String)


Occurences of ejbActivate

ejbActivate occurences:
javax.ejb.EntityBean.ejbActivate()
javax.ejb.SessionBean.ejbActivate()


Occurences of EJBException (constructors)

EJBException (constructors) occurences:
javax.ejb.EJBException()
javax.ejb.EJBException(java.lang.Exception)
javax.ejb.EJBException(java.lang.String)
javax.ejb.EJBException(java.lang.String, java.lang.Exception)


Occurences of EJBMethodPermission (constructors)

EJBMethodPermission (constructors) occurences:
javax.security.jacc.EJBMethodPermission(java.lang.String, java.lang.String)
javax.security.jacc.EJBMethodPermission(java.lang.String, java.lang.String, java.lang.reflect.Method)
javax.security.jacc.EJBMethodPermission(java.lang.String, java.lang.String, java.lang.String, java.lang.String[])


Occurences of ejbPassivate

ejbPassivate occurences:
javax.ejb.EntityBean.ejbPassivate()
javax.ejb.SessionBean.ejbPassivate()


Occurences of ejbRemove

ejbRemove occurences:
javax.ejb.EntityBean.ejbRemove()
javax.ejb.MessageDrivenBean.ejbRemove()
javax.ejb.SessionBean.ejbRemove()


Occurences of EJBTransactionRequiredException (constructors)

EJBTransactionRequiredException (constructors) occurences:
javax.ejb.EJBTransactionRequiredException()
javax.ejb.EJBTransactionRequiredException(java.lang.String)


Occurences of EJBTransactionRolledbackException (constructors)

EJBTransactionRolledbackException (constructors) occurences:
javax.ejb.EJBTransactionRolledbackException()
javax.ejb.EJBTransactionRolledbackException(java.lang.String)
javax.ejb.EJBTransactionRolledbackException(java.lang.String, java.lang.Exception)


Occurences of el

el occurences:
javax.el
javax.faces.el
javax.servlet.jsp.el


Occurences of ELException

ELException occurences:
javax.el.ELException
javax.servlet.jsp.el.ELException


Occurences of ELException (constructors)

ELException (constructors) occurences:
javax.el.ELException()
javax.el.ELException(java.lang.String)
javax.el.ELException(java.lang.String, java.lang.Throwable)
javax.el.ELException(java.lang.Throwable)
javax.servlet.jsp.el.ELException()
javax.servlet.jsp.el.ELException(java.lang.String)
javax.servlet.jsp.el.ELException(java.lang.String, java.lang.Throwable)
javax.servlet.jsp.el.ELException(java.lang.Throwable)


Occurences of ELParseException (constructors)

ELParseException (constructors) occurences:
javax.servlet.jsp.el.ELParseException()
javax.servlet.jsp.el.ELParseException(java.lang.String)


Occurences of encode

encode occurences:
javax.mail.internet.MimeUtility.encode(java.io.OutputStream, java.lang.String)
javax.mail.internet.MimeUtility.encode(java.io.OutputStream, java.lang.String, java.lang.String)


Occurences of encodeBegin

encodeBegin occurences:
javax.faces.component.UIComponent.encodeBegin(javax.faces.context.FacesContext)
javax.faces.component.UIComponentBase.encodeBegin(javax.faces.context.FacesContext)
javax.faces.component.UIData.encodeBegin(javax.faces.context.FacesContext)
javax.faces.component.UIViewRoot.encodeBegin(javax.faces.context.FacesContext)
javax.faces.render.Renderer.encodeBegin(javax.faces.context.FacesContext, javax.faces.component.UIComponent)
javax.faces.webapp.UIComponentClassicTagBase.encodeBegin()


Occurences of encodeChildren

encodeChildren occurences:
javax.faces.component.UIComponent.encodeChildren(javax.faces.context.FacesContext)
javax.faces.component.UIComponentBase.encodeChildren(javax.faces.context.FacesContext)
javax.faces.render.Renderer.encodeChildren(javax.faces.context.FacesContext, javax.faces.component.UIComponent)
javax.faces.webapp.UIComponentClassicTagBase.encodeChildren()


Occurences of encodeEnd

encodeEnd occurences:
javax.faces.component.UIComponent.encodeEnd(javax.faces.context.FacesContext)
javax.faces.component.UIComponentBase.encodeEnd(javax.faces.context.FacesContext)
javax.faces.component.UIViewRoot.encodeEnd(javax.faces.context.FacesContext)
javax.faces.render.Renderer.encodeEnd(javax.faces.context.FacesContext, javax.faces.component.UIComponent)
javax.faces.webapp.UIComponentClassicTagBase.encodeEnd()


Occurences of encodeRedirectUrl

encodeRedirectUrl occurences:
javax.servlet.http.HttpServletResponse.encodeRedirectUrl(java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.encodeRedirectUrl(java.lang.String)


Occurences of encodeRedirectURL

encodeRedirectURL occurences:
javax.servlet.http.HttpServletResponse.encodeRedirectURL(java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.encodeRedirectURL(java.lang.String)


Occurences of encodeText

encodeText occurences:
javax.mail.internet.MimeUtility.encodeText(java.lang.String)
javax.mail.internet.MimeUtility.encodeText(java.lang.String, java.lang.String, java.lang.String)


Occurences of encodeUrl

encodeUrl occurences:
javax.servlet.http.HttpServletResponse.encodeUrl(java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.encodeUrl(java.lang.String)


Occurences of encodeURL

encodeURL occurences:
javax.servlet.http.HttpServletResponse.encodeURL(java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.encodeURL(java.lang.String)


Occurences of encodeWord

encodeWord occurences:
javax.mail.internet.MimeUtility.encodeWord(java.lang.String)
javax.mail.internet.MimeUtility.encodeWord(java.lang.String, java.lang.String, java.lang.String)


Occurences of endDocument

endDocument occurences:
javax.faces.context.ResponseWriter.endDocument()
javax.faces.context.ResponseWriterWrapper.endDocument()


Occurences of endElement

endElement occurences:
javax.faces.context.ResponseWriter.endElement(java.lang.String)
javax.faces.context.ResponseWriterWrapper.endElement(java.lang.String)


Occurences of ENDPOINT_ADDRESS_PROPERTY

ENDPOINT_ADDRESS_PROPERTY occurences:
javax.xml.rpc.ENDPOINT_ADDRESS_PROPERTY
javax.xml.ws.ENDPOINT_ADDRESS_PROPERTY


Occurences of EntityExistsException (constructors)

EntityExistsException (constructors) occurences:
javax.persistence.EntityExistsException()
javax.persistence.EntityExistsException(java.lang.String)
javax.persistence.EntityExistsException(java.lang.String, java.lang.Throwable)
javax.persistence.EntityExistsException(java.lang.Throwable)


Occurences of EntityNotFoundException (constructors)

EntityNotFoundException (constructors) occurences:
javax.persistence.EntityNotFoundException()
javax.persistence.EntityNotFoundException(java.lang.String)


Occurences of EnumConverter (constructors)

EnumConverter (constructors) occurences:
javax.faces.convert.EnumConverter()
javax.faces.convert.EnumConverter(java.lang.Class)


Occurences of enum_constant_detail

enum_constant_detail occurences:
javax.annotation.enum_constant_detail
javax.ejb.enum_constant_detail
javax.ejb.enum_constant_detail
javax.jws.enum_constant_detail
javax.jws.soap.enum_constant_detail
javax.jws.soap.enum_constant_detail
javax.jws.soap.enum_constant_detail
javax.persistence.enum_constant_detail
javax.persistence.enum_constant_detail
javax.persistence.enum_constant_detail
javax.persistence.enum_constant_detail
javax.persistence.enum_constant_detail
javax.persistence.enum_constant_detail
javax.persistence.enum_constant_detail
javax.persistence.enum_constant_detail
javax.persistence.enum_constant_detail
javax.persistence.enum_constant_detail
javax.persistence.spi.enum_constant_detail
javax.xml.bind.annotation.enum_constant_detail
javax.xml.bind.annotation.enum_constant_detail
javax.xml.bind.annotation.enum_constant_detail
javax.xml.ws.enum_constant_detail
javax.xml.ws.handler.enum_constant_detail


Occurences of enum_constant_summary

enum_constant_summary occurences:
javax.annotation.enum_constant_summary
javax.ejb.enum_constant_summary
javax.ejb.enum_constant_summary
javax.jws.enum_constant_summary
javax.jws.soap.enum_constant_summary
javax.jws.soap.enum_constant_summary
javax.jws.soap.enum_constant_summary
javax.persistence.enum_constant_summary
javax.persistence.enum_constant_summary
javax.persistence.enum_constant_summary
javax.persistence.enum_constant_summary
javax.persistence.enum_constant_summary
javax.persistence.enum_constant_summary
javax.persistence.enum_constant_summary
javax.persistence.enum_constant_summary
javax.persistence.enum_constant_summary
javax.persistence.enum_constant_summary
javax.persistence.spi.enum_constant_summary
javax.xml.bind.annotation.enum_constant_summary
javax.xml.bind.annotation.enum_constant_summary
javax.xml.bind.annotation.enum_constant_summary
javax.xml.ws.enum_constant_summary
javax.xml.ws.handler.enum_constant_summary


Occurences of equals

equals occurences:
javax.activation.ActivationDataFlavor.equals(java.awt.datatransfer.DataFlavor)
javax.el.Expression.equals(java.lang.Object)
javax.faces.validator.DoubleRangeValidator.equals(java.lang.Object)
javax.faces.validator.LengthValidator.equals(java.lang.Object)
javax.faces.validator.LongRangeValidator.equals(java.lang.Object)
javax.mail.Address.equals(java.lang.Object)
javax.mail.Flags.equals(java.lang.Object)
javax.mail.internet.InternetAddress.equals(java.lang.Object)
javax.mail.internet.NewsAddress.equals(java.lang.Object)
javax.mail.search.AddressStringTerm.equals(java.lang.Object)
javax.mail.search.AddressTerm.equals(java.lang.Object)
javax.mail.search.AndTerm.equals(java.lang.Object)
javax.mail.search.BodyTerm.equals(java.lang.Object)
javax.mail.search.ComparisonTerm.equals(java.lang.Object)
javax.mail.search.DateTerm.equals(java.lang.Object)
javax.mail.search.FlagTerm.equals(java.lang.Object)
javax.mail.search.FromStringTerm.equals(java.lang.Object)
javax.mail.search.FromTerm.equals(java.lang.Object)
javax.mail.search.HeaderTerm.equals(java.lang.Object)
javax.mail.search.IntegerComparisonTerm.equals(java.lang.Object)
javax.mail.search.MessageIDTerm.equals(java.lang.Object)
javax.mail.search.MessageNumberTerm.equals(java.lang.Object)
javax.mail.search.NotTerm.equals(java.lang.Object)
javax.mail.search.OrTerm.equals(java.lang.Object)
javax.mail.search.ReceivedDateTerm.equals(java.lang.Object)
javax.mail.search.RecipientStringTerm.equals(java.lang.Object)
javax.mail.search.RecipientTerm.equals(java.lang.Object)
javax.mail.search.SentDateTerm.equals(java.lang.Object)
javax.mail.search.SizeTerm.equals(java.lang.Object)
javax.mail.search.StringTerm.equals(java.lang.Object)
javax.mail.search.SubjectTerm.equals(java.lang.Object)
javax.mail.URLName.equals(java.lang.Object)
javax.resource.cci.Record.equals(java.lang.Object)
javax.resource.spi.ConnectionRequestInfo.equals(java.lang.Object)
javax.resource.spi.ManagedConnectionFactory.equals(java.lang.Object)
javax.resource.spi.security.GenericCredential.equals(java.lang.Object)
javax.resource.spi.security.PasswordCredential.equals(java.lang.Object)
javax.security.jacc.EJBMethodPermission.equals(java.lang.Object)
javax.security.jacc.EJBRoleRefPermission.equals(java.lang.Object)
javax.security.jacc.WebResourcePermission.equals(java.lang.Object)
javax.security.jacc.WebRoleRefPermission.equals(java.lang.Object)
javax.security.jacc.WebUserDataPermission.equals(java.lang.Object)


Occurences of errorCode

errorCode occurences:
javax.transaction.errorCode
javax.transaction.xa.errorCode


Occurences of evaluate

evaluate occurences:
javax.servlet.jsp.el.Expression.evaluate(javax.servlet.jsp.el.VariableResolver)
javax.servlet.jsp.el.ExpressionEvaluator.evaluate(java.lang.String, java.lang.Class, javax.servlet.jsp.el.VariableResolver, javax.servlet.jsp.el.FunctionMapper)


Occurences of EvaluationException (constructors)

EvaluationException (constructors) occurences:
javax.faces.el.EvaluationException()
javax.faces.el.EvaluationException(java.lang.String)
javax.faces.el.EvaluationException(java.lang.String, java.lang.Throwable)
javax.faces.el.EvaluationException(java.lang.Throwable)


Occurences of event

event occurences:
javax.faces.event
javax.mail.event


Occurences of EventReaderDelegate (constructors)

EventReaderDelegate (constructors) occurences:
javax.xml.stream.util.EventReaderDelegate()
javax.xml.stream.util.EventReaderDelegate(javax.xml.stream.XMLEventReader)


Occurences of exceptions

exceptions occurences:
javax.enterprise.deploy.model.exceptions
javax.enterprise.deploy.spi.exceptions


Occurences of execute

execute occurences:
javax.enterprise.deploy.spi.status.ClientConfiguration.execute()
javax.faces.lifecycle.Lifecycle.execute(javax.faces.context.FacesContext)
javax.resource.cci.Interaction.execute(javax.resource.cci.InteractionSpec, javax.resource.cci.Record)
javax.resource.cci.Interaction.execute(javax.resource.cci.InteractionSpec, javax.resource.cci.Record, javax.resource.cci.Record)


Occurences of Expression

Expression occurences:
javax.el.Expression
javax.servlet.jsp.el.Expression


Occurences of Expression (constructors)

Expression (constructors) occurences:
javax.el.Expression()
javax.servlet.jsp.el.Expression()


Occurences of FacesException (constructors)

FacesException (constructors) occurences:
javax.faces.FacesException()
javax.faces.FacesException(java.lang.String)
javax.faces.FacesException(java.lang.String, java.lang.Throwable)
javax.faces.FacesException(java.lang.Throwable)


Occurences of FacesMessage (constructors)

FacesMessage (constructors) occurences:
javax.faces.application.FacesMessage()
javax.faces.application.FacesMessage(java.lang.String)
javax.faces.application.FacesMessage(java.lang.String, java.lang.String)
javax.faces.application.FacesMessage(javax.faces.application.FacesMessage.Severity, java.lang.String, java.lang.String)


Occurences of factories

factories occurences:
javax.enterprise.deploy.shared.factories
javax.enterprise.deploy.spi.factories


Occurences of FactoryConfigurationError (constructors)

FactoryConfigurationError (constructors) occurences:
javax.xml.stream.FactoryConfigurationError()
javax.xml.stream.FactoryConfigurationError(java.lang.Exception)
javax.xml.stream.FactoryConfigurationError(java.lang.Exception, java.lang.String)
javax.xml.stream.FactoryConfigurationError(java.lang.String)
javax.xml.stream.FactoryConfigurationError(java.lang.String, java.lang.Exception)


Occurences of fetch

fetch occurences:
javax.mail.Folder.fetch(javax.mail.Message[], javax.mail.FetchProfile)
javax.persistence.Basic.fetch()
javax.persistence.ManyToMany.fetch()
javax.persistence.ManyToOne.fetch()
javax.persistence.OneToMany.fetch()
javax.persistence.OneToOne.fetch()


Occurences of FileDataSource (constructors)

FileDataSource (constructors) occurences:
javax.activation.FileDataSource(java.io.File)
javax.activation.FileDataSource(java.lang.String)


Occurences of finalize

finalize occurences:
javax.mail.Folder.finalize()
javax.mail.Service.finalize()
javax.mail.util.SharedFileInputStream.finalize()


Occurences of findAncestorWithClass

findAncestorWithClass occurences:
javax.servlet.jsp.tagext.SimpleTagSupport.findAncestorWithClass(javax.servlet.jsp.tagext.JspTag, java.lang.Class)
javax.servlet.jsp.tagext.TagSupport.findAncestorWithClass(javax.servlet.jsp.tagext.Tag, java.lang.Class)


Occurences of findComponent

findComponent occurences:
javax.faces.component.UIComponent.findComponent(java.lang.String)
javax.faces.component.UIComponentBase.findComponent(java.lang.String)
javax.faces.webapp.UIComponentClassicTagBase.findComponent(javax.faces.context.FacesContext)


Occurences of FinderException (constructors)

FinderException (constructors) occurences:
javax.ejb.FinderException()
javax.ejb.FinderException(java.lang.String)


Occurences of FindException (constructors)

FindException (constructors) occurences:
javax.xml.registry.FindException()
javax.xml.registry.FindException(java.lang.String)
javax.xml.registry.FindException(java.lang.String, java.lang.Throwable)
javax.xml.registry.FindException(java.lang.Throwable)


Occurences of flags

flags occurences:
javax.mail.internet.flags
javax.mail.search.flags


Occurences of Flags (constructors)

Flags (constructors) occurences:
javax.mail.Flags()
javax.mail.Flags(java.lang.String)
javax.mail.Flags(javax.mail.Flags)
javax.mail.Flags(javax.mail.Flags.Flag)


Occurences of FloatHolder (constructors)

FloatHolder (constructors) occurences:
javax.xml.rpc.holders.FloatHolder()
javax.xml.rpc.holders.FloatHolder(float)


Occurences of FloatWrapperHolder (constructors)

FloatWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.FloatWrapperHolder()
javax.xml.rpc.holders.FloatWrapperHolder(java.lang.Float)


Occurences of flush

flush occurences:
javax.faces.context.ResponseWriter.flush()
javax.faces.context.ResponseWriterWrapper.flush()
javax.persistence.EntityManager.flush()
javax.servlet.jsp.JspWriter.flush()
javax.servlet.jsp.tagext.BodyContent.flush()
javax.xml.stream.XMLEventWriter.flush()
javax.xml.stream.XMLStreamWriter.flush()


Occurences of flushBuffer

flushBuffer occurences:
javax.servlet.ServletResponse.flushBuffer()
javax.servlet.ServletResponseWrapper.flushBuffer()


Occurences of folder

folder occurences:
javax.mail.event.folder
javax.mail.folder


Occurences of FolderClosedException (constructors)

FolderClosedException (constructors) occurences:
javax.mail.FolderClosedException(javax.mail.Folder)
javax.mail.FolderClosedException(javax.mail.Folder, java.lang.String)


Occurences of folderCreated

folderCreated occurences:
javax.mail.event.FolderAdapter.folderCreated(javax.mail.event.FolderEvent)
javax.mail.event.FolderListener.folderCreated(javax.mail.event.FolderEvent)


Occurences of folderDeleted

folderDeleted occurences:
javax.mail.event.FolderAdapter.folderDeleted(javax.mail.event.FolderEvent)
javax.mail.event.FolderListener.folderDeleted(javax.mail.event.FolderEvent)


Occurences of FolderEvent (constructors)

FolderEvent (constructors) occurences:
javax.mail.event.FolderEvent(java.lang.Object, javax.mail.Folder, int)
javax.mail.event.FolderEvent(java.lang.Object, javax.mail.Folder, javax.mail.Folder, int)


Occurences of FolderNotFoundException (constructors)

FolderNotFoundException (constructors) occurences:
javax.mail.FolderNotFoundException()
javax.mail.FolderNotFoundException(java.lang.String, javax.mail.Folder)
javax.mail.FolderNotFoundException(javax.mail.Folder)
javax.mail.FolderNotFoundException(javax.mail.Folder, java.lang.String)


Occurences of folderRenamed

folderRenamed occurences:
javax.mail.event.FolderAdapter.folderRenamed(javax.mail.event.FolderEvent)
javax.mail.event.FolderListener.folderRenamed(javax.mail.event.FolderEvent)


Occurences of forget

forget occurences:
javax.resource.spi.XATerminator.forget(javax.transaction.xa.Xid)
javax.transaction.xa.XAResource.forget(javax.transaction.xa.Xid)


Occurences of FORM_AUTH

FORM_AUTH occurences:
javax.faces.context.FORM_AUTH
javax.servlet.http.FORM_AUTH


Occurences of forward

forward occurences:
javax.servlet.jsp.PageContext.forward(java.lang.String)
javax.servlet.RequestDispatcher.forward(javax.servlet.ServletRequest, javax.servlet.ServletResponse)


Occurences of FunctionMapper

FunctionMapper occurences:
javax.el.FunctionMapper
javax.servlet.jsp.el.FunctionMapper


Occurences of get

get occurences:
javax.activation.MimeTypeParameterList.get(java.lang.String)
javax.mail.internet.ParameterList.get(java.lang.String)
javax.xml.soap.SOAPConnection.get(java.lang.Object)


Occurences of getAccesskey

getAccesskey occurences:
javax.faces.component.html.HtmlCommandButton.getAccesskey()
javax.faces.component.html.HtmlCommandLink.getAccesskey()
javax.faces.component.html.HtmlInputSecret.getAccesskey()
javax.faces.component.html.HtmlInputText.getAccesskey()
javax.faces.component.html.HtmlInputTextarea.getAccesskey()
javax.faces.component.html.HtmlOutputLabel.getAccesskey()
javax.faces.component.html.HtmlOutputLink.getAccesskey()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getAccesskey()
javax.faces.component.html.HtmlSelectManyCheckbox.getAccesskey()
javax.faces.component.html.HtmlSelectManyListbox.getAccesskey()
javax.faces.component.html.HtmlSelectManyMenu.getAccesskey()
javax.faces.component.html.HtmlSelectOneListbox.getAccesskey()
javax.faces.component.html.HtmlSelectOneMenu.getAccesskey()
javax.faces.component.html.HtmlSelectOneRadio.getAccesskey()


Occurences of getAction

getAction occurences:
javax.enterprise.deploy.spi.status.DeploymentStatus.getAction()
javax.faces.component.ActionSource.getAction()
javax.faces.component.UICommand.getAction()


Occurences of getActionExpression

getActionExpression occurences:
javax.faces.component.ActionSource2.getActionExpression()
javax.faces.component.UICommand.getActionExpression()


Occurences of getActionListener

getActionListener occurences:
javax.faces.application.Application.getActionListener()
javax.faces.component.ActionSource.getActionListener()
javax.faces.component.UICommand.getActionListener()


Occurences of getActionListeners

getActionListeners occurences:
javax.faces.component.ActionSource.getActionListeners()
javax.faces.component.UICommand.getActionListeners()


Occurences of getActions

getActions occurences:
javax.security.jacc.EJBMethodPermission.getActions()
javax.security.jacc.EJBRoleRefPermission.getActions()
javax.security.jacc.WebResourcePermission.getActions()
javax.security.jacc.WebRoleRefPermission.getActions()
javax.security.jacc.WebUserDataPermission.getActions()


Occurences of getActionURL

getActionURL occurences:
javax.faces.application.ViewHandler.getActionURL(javax.faces.context.FacesContext, java.lang.String)
javax.faces.application.ViewHandlerWrapper.getActionURL(javax.faces.context.FacesContext, java.lang.String)


Occurences of getAdapter

getAdapter occurences:
javax.xml.bind.helpers.AbstractMarshallerImpl.getAdapter(java.lang.Class)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.getAdapter(java.lang.Class)
javax.xml.bind.Marshaller.getAdapter(java.lang.Class)
javax.xml.bind.Unmarshaller.getAdapter(java.lang.Class)


Occurences of getAddress

getAddress occurences:
javax.mail.internet.InternetAddress.getAddress()
javax.mail.search.AddressTerm.getAddress()
javax.xml.registry.infomodel.EmailAddress.getAddress()


Occurences of getAllCommands

getAllCommands occurences:
javax.activation.CommandMap.getAllCommands(java.lang.String)
javax.activation.CommandMap.getAllCommands(java.lang.String, javax.activation.DataSource)
javax.activation.DataHandler.getAllCommands()
javax.activation.MailcapCommandMap.getAllCommands(java.lang.String)


Occurences of getAllHeaderLines

getAllHeaderLines occurences:
javax.mail.internet.InternetHeaders.getAllHeaderLines()
javax.mail.internet.MimeBodyPart.getAllHeaderLines()
javax.mail.internet.MimeMessage.getAllHeaderLines()
javax.mail.internet.MimePart.getAllHeaderLines()


Occurences of getAllHeaders

getAllHeaders occurences:
javax.mail.internet.InternetHeaders.getAllHeaders()
javax.mail.internet.MimeBodyPart.getAllHeaders()
javax.mail.internet.MimeMessage.getAllHeaders()
javax.mail.Part.getAllHeaders()
javax.xml.soap.MimeHeaders.getAllHeaders()


Occurences of getAllMimeHeaders

getAllMimeHeaders occurences:
javax.xml.soap.AttachmentPart.getAllMimeHeaders()
javax.xml.soap.SOAPPart.getAllMimeHeaders()


Occurences of getAllRecipients

getAllRecipients occurences:
javax.mail.internet.MimeMessage.getAllRecipients()
javax.mail.Message.getAllRecipients()


Occurences of getAlt

getAlt occurences:
javax.faces.component.html.HtmlCommandButton.getAlt()
javax.faces.component.html.HtmlGraphicImage.getAlt()
javax.faces.component.html.HtmlInputSecret.getAlt()
javax.faces.component.html.HtmlInputText.getAlt()


Occurences of getApplication

getApplication occurences:
javax.faces.application.ApplicationFactory.getApplication()
javax.faces.context.FacesContext.getApplication()


Occurences of getAsObject

getAsObject occurences:
javax.faces.convert.BigDecimalConverter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)
javax.faces.convert.BigIntegerConverter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)
javax.faces.convert.BooleanConverter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)
javax.faces.convert.ByteConverter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)
javax.faces.convert.CharacterConverter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)
javax.faces.convert.Converter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)
javax.faces.convert.DateTimeConverter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)
javax.faces.convert.DoubleConverter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)
javax.faces.convert.EnumConverter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)
javax.faces.convert.FloatConverter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)
javax.faces.convert.IntegerConverter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)
javax.faces.convert.LongConverter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)
javax.faces.convert.NumberConverter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)
javax.faces.convert.ShortConverter.getAsObject(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.String)


Occurences of getAsString

getAsString occurences:
javax.faces.convert.BigDecimalConverter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.convert.BigIntegerConverter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.convert.BooleanConverter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.convert.ByteConverter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.convert.CharacterConverter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.convert.Converter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.convert.DateTimeConverter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.convert.DoubleConverter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.convert.EnumConverter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.convert.FloatConverter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.convert.IntegerConverter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.convert.LongConverter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.convert.NumberConverter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.convert.ShortConverter.getAsString(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)


Occurences of getAttachmentMarshaller

getAttachmentMarshaller occurences:
javax.xml.bind.helpers.AbstractMarshallerImpl.getAttachmentMarshaller()
javax.xml.bind.Marshaller.getAttachmentMarshaller()


Occurences of getAttachments

getAttachments occurences:
javax.xml.soap.SOAPMessage.getAttachments()
javax.xml.soap.SOAPMessage.getAttachments(javax.xml.soap.MimeHeaders)


Occurences of getAttachmentUnmarshaller

getAttachmentUnmarshaller occurences:
javax.xml.bind.helpers.AbstractUnmarshallerImpl.getAttachmentUnmarshaller()
javax.xml.bind.Unmarshaller.getAttachmentUnmarshaller()


Occurences of getAttribute

getAttribute occurences:
javax.management.j2ee.Management.getAttribute(javax.management.ObjectName, java.lang.String)
javax.servlet.http.HttpSession.getAttribute(java.lang.String)
javax.servlet.jsp.JspContext.getAttribute(java.lang.String)
javax.servlet.jsp.JspContext.getAttribute(java.lang.String, int)
javax.servlet.jsp.tagext.TagData.getAttribute(java.lang.String)
javax.servlet.ServletContext.getAttribute(java.lang.String)
javax.servlet.ServletRequest.getAttribute(java.lang.String)
javax.servlet.ServletRequestWrapper.getAttribute(java.lang.String)


Occurences of getAttributeCount

getAttributeCount occurences:
javax.xml.stream.util.StreamReaderDelegate.getAttributeCount()
javax.xml.stream.XMLStreamReader.getAttributeCount()


Occurences of getAttributeLocalName

getAttributeLocalName occurences:
javax.xml.stream.util.StreamReaderDelegate.getAttributeLocalName(int)
javax.xml.stream.XMLStreamReader.getAttributeLocalName(int)


Occurences of getAttributeName

getAttributeName occurences:
javax.xml.stream.util.StreamReaderDelegate.getAttributeName(int)
javax.xml.stream.XMLStreamReader.getAttributeName(int)


Occurences of getAttributeNames

getAttributeNames occurences:
javax.enterprise.deploy.model.DDBean.getAttributeNames()
javax.servlet.http.HttpSession.getAttributeNames()
javax.servlet.ServletContext.getAttributeNames()
javax.servlet.ServletRequest.getAttributeNames()
javax.servlet.ServletRequestWrapper.getAttributeNames()


Occurences of getAttributeNamespace

getAttributeNamespace occurences:
javax.xml.stream.util.StreamReaderDelegate.getAttributeNamespace(int)
javax.xml.stream.XMLStreamReader.getAttributeNamespace(int)


Occurences of getAttributePrefix

getAttributePrefix occurences:
javax.xml.stream.util.StreamReaderDelegate.getAttributePrefix(int)
javax.xml.stream.XMLStreamReader.getAttributePrefix(int)


Occurences of getAttributes

getAttributes occurences:
javax.faces.component.UIComponent.getAttributes()
javax.faces.component.UIComponentBase.getAttributes()
javax.management.j2ee.Management.getAttributes(javax.management.ObjectName, java.lang.String[])
javax.servlet.jsp.tagext.TagData.getAttributes()
javax.servlet.jsp.tagext.TagInfo.getAttributes()
javax.xml.stream.events.StartElement.getAttributes()


Occurences of getAttributeType

getAttributeType occurences:
javax.xml.stream.util.StreamReaderDelegate.getAttributeType(int)
javax.xml.stream.XMLStreamReader.getAttributeType(int)


Occurences of getAttributeValue

getAttributeValue occurences:
javax.enterprise.deploy.model.DDBean.getAttributeValue(java.lang.String)
javax.xml.soap.SOAPElement.getAttributeValue(javax.xml.namespace.QName)
javax.xml.soap.SOAPElement.getAttributeValue(javax.xml.soap.Name)
javax.xml.stream.util.StreamReaderDelegate.getAttributeValue(int)
javax.xml.stream.util.StreamReaderDelegate.getAttributeValue(java.lang.String, java.lang.String)
javax.xml.stream.XMLStreamReader.getAttributeValue(int)
javax.xml.stream.XMLStreamReader.getAttributeValue(java.lang.String, java.lang.String)


Occurences of getAuthType

getAuthType occurences:
javax.faces.context.ExternalContext.getAuthType()
javax.servlet.http.HttpServletRequest.getAuthType()
javax.servlet.http.HttpServletRequestWrapper.getAuthType()


Occurences of getAutocomplete

getAutocomplete occurences:
javax.faces.component.html.HtmlInputSecret.getAutocomplete()
javax.faces.component.html.HtmlInputText.getAutocomplete()


Occurences of getBaseType

getBaseType occurences:
javax.activation.MimeType.getBaseType()
javax.mail.internet.ContentType.getBaseType()


Occurences of getBean

getBean occurences:
javax.activation.DataHandler.getBean(javax.activation.CommandInfo)
javax.enterprise.deploy.model.XpathEvent.getBean()


Occurences of getBgcolor

getBgcolor occurences:
javax.faces.component.html.HtmlDataTable.getBgcolor()
javax.faces.component.html.HtmlPanelGrid.getBgcolor()


Occurences of getBinding

getBinding occurences:
javax.xml.ws.BindingProvider.getBinding()
javax.xml.ws.Endpoint.getBinding()


Occurences of getBodyContent

getBodyContent occurences:
javax.faces.webapp.UIComponentClassicTagBase.getBodyContent()
javax.servlet.jsp.tagext.BodyTagSupport.getBodyContent()
javax.servlet.jsp.tagext.TagInfo.getBodyContent()


Occurences of getBodyPart

getBodyPart occurences:
javax.mail.internet.MimeMultipart.getBodyPart(int)
javax.mail.internet.MimeMultipart.getBodyPart(java.lang.String)
javax.mail.Multipart.getBodyPart(int)
javax.mail.MultipartDataSource.getBodyPart(int)


Occurences of getBorder

getBorder occurences:
javax.faces.component.html.HtmlDataTable.getBorder()
javax.faces.component.html.HtmlPanelGrid.getBorder()
javax.faces.component.html.HtmlSelectManyCheckbox.getBorder()
javax.faces.component.html.HtmlSelectOneRadio.getBorder()


Occurences of getBufferSize

getBufferSize occurences:
javax.servlet.jsp.JspWriter.getBufferSize()
javax.servlet.ServletResponse.getBufferSize()
javax.servlet.ServletResponseWrapper.getBufferSize()


Occurences of getCaptionClass

getCaptionClass occurences:
javax.faces.component.html.HtmlDataTable.getCaptionClass()
javax.faces.component.html.HtmlPanelGrid.getCaptionClass()


Occurences of getCaptionStyle

getCaptionStyle occurences:
javax.faces.component.html.HtmlDataTable.getCaptionStyle()
javax.faces.component.html.HtmlPanelGrid.getCaptionStyle()


Occurences of getCause

getCause occurences:
javax.faces.FacesException.getCause()
javax.mail.MessagingException.getCause()
javax.xml.bind.JAXBException.getCause()
javax.xml.registry.JAXRException.getCause()
javax.xml.soap.SOAPException.getCause()


Occurences of getCellpadding

getCellpadding occurences:
javax.faces.component.html.HtmlDataTable.getCellpadding()
javax.faces.component.html.HtmlPanelGrid.getCellpadding()


Occurences of getCellspacing

getCellspacing occurences:
javax.faces.component.html.HtmlDataTable.getCellspacing()
javax.faces.component.html.HtmlPanelGrid.getCellspacing()


Occurences of getCharacterEncoding

getCharacterEncoding occurences:
javax.faces.context.ResponseWriter.getCharacterEncoding()
javax.faces.context.ResponseWriterWrapper.getCharacterEncoding()
javax.servlet.ServletRequest.getCharacterEncoding()
javax.servlet.ServletRequestWrapper.getCharacterEncoding()
javax.servlet.ServletResponse.getCharacterEncoding()
javax.servlet.ServletResponseWrapper.getCharacterEncoding()


Occurences of getCharacterEncodingScheme

getCharacterEncodingScheme occurences:
javax.xml.stream.events.StartDocument.getCharacterEncodingScheme()
javax.xml.stream.util.StreamReaderDelegate.getCharacterEncodingScheme()
javax.xml.stream.XMLStreamReader.getCharacterEncodingScheme()


Occurences of getCharset

getCharset occurences:
javax.faces.component.html.HtmlCommandLink.getCharset()
javax.faces.component.html.HtmlOutputLink.getCharset()


Occurences of getChildBean

getChildBean occurences:
javax.enterprise.deploy.model.DDBean.getChildBean(java.lang.String)
javax.enterprise.deploy.model.DeployableObject.getChildBean(java.lang.String)
javax.enterprise.deploy.model.J2eeApplicationObject.getChildBean(javax.enterprise.deploy.shared.ModuleType, java.lang.String)


Occurences of getChildConceptCount

getChildConceptCount occurences:
javax.xml.registry.infomodel.ClassificationScheme.getChildConceptCount()
javax.xml.registry.infomodel.Concept.getChildConceptCount()


Occurences of getChildCount

getChildCount occurences:
javax.faces.component.UIComponent.getChildCount()
javax.faces.component.UIComponentBase.getChildCount()


Occurences of getChildElements

getChildElements occurences:
javax.xml.soap.SOAPElement.getChildElements()
javax.xml.soap.SOAPElement.getChildElements(javax.xml.namespace.QName)
javax.xml.soap.SOAPElement.getChildElements(javax.xml.soap.Name)


Occurences of getChildren

getChildren occurences:
javax.faces.component.UIComponent.getChildren()
javax.faces.component.UIComponentBase.getChildren()


Occurences of getChildrenConcepts

getChildrenConcepts occurences:
javax.xml.registry.infomodel.ClassificationScheme.getChildrenConcepts()
javax.xml.registry.infomodel.Concept.getChildrenConcepts()


Occurences of getClassificationScheme

getClassificationScheme occurences:
javax.xml.registry.infomodel.Classification.getClassificationScheme()
javax.xml.registry.infomodel.Concept.getClassificationScheme()


Occurences of getClassName

getClassName occurences:
javax.mail.Provider.getClassName()
javax.servlet.jsp.tagext.TagVariableInfo.getClassName()
javax.servlet.jsp.tagext.VariableInfo.getClassName()


Occurences of getClientId

getClientId occurences:
javax.faces.component.UIComponent.getClientId(javax.faces.context.FacesContext)
javax.faces.component.UIComponentBase.getClientId(javax.faces.context.FacesContext)
javax.faces.component.UIData.getClientId(javax.faces.context.FacesContext)


Occurences of getCloseCount

getCloseCount occurences:
javax.management.j2ee.statistics.JCAConnectionPoolStats.getCloseCount()
javax.management.j2ee.statistics.JDBCConnectionPoolStats.getCloseCount()


Occurences of getColumnClasses

getColumnClasses occurences:
javax.faces.component.html.HtmlDataTable.getColumnClasses()
javax.faces.component.html.HtmlPanelGrid.getColumnClasses()


Occurences of getColumnNumber

getColumnNumber occurences:
javax.xml.bind.helpers.ValidationEventLocatorImpl.getColumnNumber()
javax.xml.bind.ValidationEventLocator.getColumnNumber()
javax.xml.stream.Location.getColumnNumber()


Occurences of getCommand

getCommand occurences:
javax.activation.CommandMap.getCommand(java.lang.String, java.lang.String)
javax.activation.CommandMap.getCommand(java.lang.String, java.lang.String, javax.activation.DataSource)
javax.activation.DataHandler.getCommand(java.lang.String)
javax.activation.MailcapCommandMap.getCommand(java.lang.String, java.lang.String)
javax.enterprise.deploy.spi.status.DeploymentStatus.getCommand()


Occurences of getCommonPropertyType

getCommonPropertyType occurences:
javax.el.ArrayELResolver.getCommonPropertyType(javax.el.ELContext, java.lang.Object)
javax.el.BeanELResolver.getCommonPropertyType(javax.el.ELContext, java.lang.Object)
javax.el.CompositeELResolver.getCommonPropertyType(javax.el.ELContext, java.lang.Object)
javax.el.ELResolver.getCommonPropertyType(javax.el.ELContext, java.lang.Object)
javax.el.ListELResolver.getCommonPropertyType(javax.el.ELContext, java.lang.Object)
javax.el.MapELResolver.getCommonPropertyType(javax.el.ELContext, java.lang.Object)
javax.el.ResourceBundleELResolver.getCommonPropertyType(javax.el.ELContext, java.lang.Object)
javax.servlet.jsp.el.ImplicitObjectELResolver.getCommonPropertyType(javax.el.ELContext, java.lang.Object)
javax.servlet.jsp.el.ScopedAttributeELResolver.getCommonPropertyType(javax.el.ELContext, java.lang.Object)


Occurences of getComparison

getComparison occurences:
javax.mail.search.DateTerm.getComparison()
javax.mail.search.IntegerComparisonTerm.getComparison()


Occurences of getComponentInstance

getComponentInstance occurences:
javax.faces.webapp.UIComponentClassicTagBase.getComponentInstance()
javax.faces.webapp.UIComponentTagBase.getComponentInstance()


Occurences of getComponentStateToSave

getComponentStateToSave occurences:
javax.faces.application.StateManager.getComponentStateToSave(javax.faces.context.FacesContext)
javax.faces.application.StateManagerWrapper.getComponentStateToSave(javax.faces.context.FacesContext)


Occurences of getConnection

getConnection occurences:
javax.resource.cci.ConnectionFactory.getConnection()
javax.resource.cci.ConnectionFactory.getConnection(javax.resource.cci.ConnectionSpec)
javax.resource.cci.Interaction.getConnection()
javax.resource.spi.ManagedConnection.getConnection(javax.security.auth.Subject, javax.resource.spi.ConnectionRequestInfo)


Occurences of getConnectionPools

getConnectionPools occurences:
javax.management.j2ee.statistics.JCAStats.getConnectionPools()
javax.management.j2ee.statistics.JDBCStats.getConnectionPools()


Occurences of getConnections

getConnections occurences:
javax.management.j2ee.statistics.JCAStats.getConnections()
javax.management.j2ee.statistics.JDBCStats.getConnections()
javax.management.j2ee.statistics.JMSStats.getConnections()


Occurences of getContainerClientId

getContainerClientId occurences:
javax.faces.component.UIComponent.getContainerClientId(javax.faces.context.FacesContext)
javax.faces.component.UIForm.getContainerClientId(javax.faces.context.FacesContext)


Occurences of getContent

getContent occurences:
javax.activation.DataContentHandler.getContent(javax.activation.DataSource)
javax.activation.DataHandler.getContent()
javax.mail.internet.MimeBodyPart.getContent()
javax.mail.internet.MimeMessage.getContent()
javax.mail.Part.getContent()
javax.xml.soap.AttachmentPart.getContent()
javax.xml.soap.SOAPPart.getContent()


Occurences of getContentID

getContentID occurences:
javax.mail.internet.MimeBodyPart.getContentID()
javax.mail.internet.MimeMessage.getContentID()
javax.mail.internet.MimePart.getContentID()


Occurences of getContentId

getContentId occurences:
javax.xml.soap.AttachmentPart.getContentId()
javax.xml.soap.SOAPPart.getContentId()


Occurences of getContentLanguage

getContentLanguage occurences:
javax.mail.internet.MimeBodyPart.getContentLanguage()
javax.mail.internet.MimeMessage.getContentLanguage()
javax.mail.internet.MimePart.getContentLanguage()


Occurences of getContentLength

getContentLength occurences:
javax.servlet.ServletRequest.getContentLength()
javax.servlet.ServletRequestWrapper.getContentLength()


Occurences of getContentLocation

getContentLocation occurences:
javax.xml.soap.AttachmentPart.getContentLocation()
javax.xml.soap.SOAPPart.getContentLocation()


Occurences of getContentMD5

getContentMD5 occurences:
javax.mail.internet.MimeBodyPart.getContentMD5()
javax.mail.internet.MimeMessage.getContentMD5()
javax.mail.internet.MimePart.getContentMD5()


Occurences of getContentStream

getContentStream occurences:
javax.mail.internet.MimeBodyPart.getContentStream()
javax.mail.internet.MimeMessage.getContentStream()


Occurences of getContentType

getContentType occurences:
javax.activation.DataHandler.getContentType()
javax.activation.DataSource.getContentType()
javax.activation.FileDataSource.getContentType()
javax.activation.FileTypeMap.getContentType(java.io.File)
javax.activation.FileTypeMap.getContentType(java.lang.String)
javax.activation.MimetypesFileTypeMap.getContentType(java.io.File)
javax.activation.MimetypesFileTypeMap.getContentType(java.lang.String)
javax.activation.URLDataSource.getContentType()
javax.faces.context.ResponseWriter.getContentType()
javax.faces.context.ResponseWriterWrapper.getContentType()
javax.mail.internet.MimeBodyPart.getContentType()
javax.mail.internet.MimeMessage.getContentType()
javax.mail.internet.MimePartDataSource.getContentType()
javax.mail.Multipart.getContentType()
javax.mail.Part.getContentType()
javax.mail.util.ByteArrayDataSource.getContentType()
javax.servlet.ServletRequest.getContentType()
javax.servlet.ServletRequestWrapper.getContentType()
javax.servlet.ServletResponse.getContentType()
javax.servlet.ServletResponseWrapper.getContentType()
javax.xml.soap.AttachmentPart.getContentType()


Occurences of getContext

getContext occurences:
javax.el.ELContext.getContext(java.lang.Class)
javax.faces.context.ExternalContext.getContext()
javax.security.jacc.PolicyContext.getContext(java.lang.String)
javax.security.jacc.PolicyContextHandler.getContext(java.lang.String, java.lang.Object)
javax.servlet.ServletContext.getContext(java.lang.String)
javax.xml.ws.Response.getContext()


Occurences of getContextID

getContextID occurences:
javax.security.jacc.PolicyConfiguration.getContextID()
javax.security.jacc.PolicyContext.getContextID()


Occurences of getContextPath

getContextPath occurences:
javax.servlet.http.HttpServletRequest.getContextPath()
javax.servlet.http.HttpServletRequestWrapper.getContextPath()
javax.servlet.ServletContext.getContextPath()


Occurences of getConvertedValue

getConvertedValue occurences:
javax.faces.component.UIInput.getConvertedValue(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.render.Renderer.getConvertedValue(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)


Occurences of getConverter

getConverter occurences:
javax.faces.component.UIOutput.getConverter()
javax.faces.component.ValueHolder.getConverter()


Occurences of getCookies

getCookies occurences:
javax.servlet.http.HttpServletRequest.getCookies()
javax.servlet.http.HttpServletRequestWrapper.getCookies()


Occurences of getCoords

getCoords occurences:
javax.faces.component.html.HtmlCommandLink.getCoords()
javax.faces.component.html.HtmlOutputLink.getCoords()


Occurences of getCount

getCount occurences:
javax.mail.internet.MimeMultipart.getCount()
javax.mail.Multipart.getCount()
javax.mail.MultipartDataSource.getCount()
javax.management.j2ee.statistics.CountStatistic.getCount()
javax.management.j2ee.statistics.TimeStatistic.getCount()


Occurences of getCreateCount

getCreateCount occurences:
javax.management.j2ee.statistics.EJBStats.getCreateCount()
javax.management.j2ee.statistics.JCAConnectionPoolStats.getCreateCount()
javax.management.j2ee.statistics.JDBCConnectionPoolStats.getCreateCount()


Occurences of getCreated

getCreated occurences:
javax.faces.webapp.UIComponentClassicTagBase.getCreated()
javax.faces.webapp.UIComponentTagBase.getCreated()


Occurences of getData

getData occurences:
javax.xml.stream.events.Characters.getData()
javax.xml.stream.events.ProcessingInstruction.getData()


Occurences of getDataHandler

getDataHandler occurences:
javax.mail.internet.MimeBodyPart.getDataHandler()
javax.mail.internet.MimeMessage.getDataHandler()
javax.mail.Part.getDataHandler()
javax.xml.soap.AttachmentPart.getDataHandler()


Occurences of getDataModel

getDataModel occurences:
javax.faces.component.UIData.getDataModel()
javax.faces.model.DataModelEvent.getDataModel()


Occurences of getDateHeader

getDateHeader occurences:
javax.servlet.http.HttpServletRequest.getDateHeader(java.lang.String)
javax.servlet.http.HttpServletRequestWrapper.getDateHeader(java.lang.String)


Occurences of getDConfigBean

getDConfigBean occurences:
javax.enterprise.deploy.spi.DConfigBean.getDConfigBean(javax.enterprise.deploy.model.DDBean)
javax.enterprise.deploy.spi.DConfigBeanRoot.getDConfigBean(javax.enterprise.deploy.model.DDBeanRoot)


Occurences of getDDBeanRoot

getDDBeanRoot occurences:
javax.enterprise.deploy.model.DeployableObject.getDDBeanRoot()
javax.enterprise.deploy.model.DeployableObject.getDDBeanRoot(java.lang.String)


Occurences of getDeclare

getDeclare occurences:
javax.servlet.jsp.tagext.TagVariableInfo.getDeclare()
javax.servlet.jsp.tagext.VariableInfo.getDeclare()


Occurences of getDefaultInstance

getDefaultInstance occurences:
javax.mail.Session.getDefaultInstance(java.util.Properties)
javax.mail.Session.getDefaultInstance(java.util.Properties, javax.mail.Authenticator)


Occurences of getDefaultLocale

getDefaultLocale occurences:
javax.enterprise.deploy.spi.DeploymentManager.getDefaultLocale()
javax.faces.application.Application.getDefaultLocale()


Occurences of getDeployableObject

getDeployableObject occurences:
javax.enterprise.deploy.model.DDBeanRoot.getDeployableObject()
javax.enterprise.deploy.model.J2eeApplicationObject.getDeployableObject(java.lang.String)
javax.enterprise.deploy.spi.DeploymentConfiguration.getDeployableObject()


Occurences of getDeployableObjects

getDeployableObjects occurences:
javax.enterprise.deploy.model.J2eeApplicationObject.getDeployableObjects()
javax.enterprise.deploy.model.J2eeApplicationObject.getDeployableObjects(javax.enterprise.deploy.shared.ModuleType)


Occurences of getDeploymentManager

getDeploymentManager occurences:
javax.enterprise.deploy.shared.factories.DeploymentFactoryManager.getDeploymentManager(java.lang.String, java.lang.String, java.lang.String)
javax.enterprise.deploy.spi.factories.DeploymentFactory.getDeploymentManager(java.lang.String, java.lang.String, java.lang.String)


Occurences of getDeploymentStatus

getDeploymentStatus occurences:
javax.enterprise.deploy.spi.status.ProgressEvent.getDeploymentStatus()
javax.enterprise.deploy.spi.status.ProgressObject.getDeploymentStatus()


Occurences of getDescendantConcepts

getDescendantConcepts occurences:
javax.xml.registry.infomodel.ClassificationScheme.getDescendantConcepts()
javax.xml.registry.infomodel.Concept.getDescendantConcepts()


Occurences of getDescription

getDescription occurences:
javax.enterprise.deploy.spi.Target.getDescription()
javax.faces.model.SelectItem.getDescription()
javax.mail.internet.MimeBodyPart.getDescription()
javax.mail.internet.MimeMessage.getDescription()
javax.mail.Part.getDescription()
javax.management.j2ee.statistics.Statistic.getDescription()
javax.servlet.jsp.tagext.TagAttributeInfo.getDescription()
javax.xml.registry.infomodel.RegistryObject.getDescription()


Occurences of getDestination

getDestination occurences:
javax.jms.MessageProducer.getDestination()
javax.management.j2ee.statistics.JMSProducerStats.getDestination()


Occurences of getDetail

getDetail occurences:
javax.faces.application.FacesMessage.getDetail()
javax.xml.rpc.soap.SOAPFaultException.getDetail()
javax.xml.soap.SOAPFault.getDetail()


Occurences of getDir

getDir occurences:
javax.faces.component.html.HtmlCommandButton.getDir()
javax.faces.component.html.HtmlCommandLink.getDir()
javax.faces.component.html.HtmlDataTable.getDir()
javax.faces.component.html.HtmlForm.getDir()
javax.faces.component.html.HtmlGraphicImage.getDir()
javax.faces.component.html.HtmlInputSecret.getDir()
javax.faces.component.html.HtmlInputText.getDir()
javax.faces.component.html.HtmlInputTextarea.getDir()
javax.faces.component.html.HtmlMessage.getDir()
javax.faces.component.html.HtmlMessages.getDir()
javax.faces.component.html.HtmlOutputFormat.getDir()
javax.faces.component.html.HtmlOutputLabel.getDir()
javax.faces.component.html.HtmlOutputLink.getDir()
javax.faces.component.html.HtmlOutputText.getDir()
javax.faces.component.html.HtmlPanelGrid.getDir()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getDir()
javax.faces.component.html.HtmlSelectManyCheckbox.getDir()
javax.faces.component.html.HtmlSelectManyListbox.getDir()
javax.faces.component.html.HtmlSelectManyMenu.getDir()
javax.faces.component.html.HtmlSelectOneListbox.getDir()
javax.faces.component.html.HtmlSelectOneMenu.getDir()
javax.faces.component.html.HtmlSelectOneRadio.getDir()


Occurences of getDisabledClass

getDisabledClass occurences:
javax.faces.component.html.HtmlSelectManyCheckbox.getDisabledClass()
javax.faces.component.html.HtmlSelectManyListbox.getDisabledClass()
javax.faces.component.html.HtmlSelectManyMenu.getDisabledClass()
javax.faces.component.html.HtmlSelectOneListbox.getDisabledClass()
javax.faces.component.html.HtmlSelectOneMenu.getDisabledClass()
javax.faces.component.html.HtmlSelectOneRadio.getDisabledClass()


Occurences of getDisconnectedDeploymentManager

getDisconnectedDeploymentManager occurences:
javax.enterprise.deploy.shared.factories.DeploymentFactoryManager.getDisconnectedDeploymentManager(java.lang.String)
javax.enterprise.deploy.spi.factories.DeploymentFactory.getDisconnectedDeploymentManager(java.lang.String)


Occurences of getDisplayName

getDisplayName occurences:
javax.enterprise.deploy.spi.factories.DeploymentFactory.getDisplayName()
javax.servlet.jsp.tagext.TagInfo.getDisplayName()


Occurences of getDisposition

getDisposition occurences:
javax.mail.internet.ContentDisposition.getDisposition()
javax.mail.internet.MimeBodyPart.getDisposition()
javax.mail.internet.MimeMessage.getDisposition()
javax.mail.Part.getDisposition()


Occurences of getEISProductName

getEISProductName occurences:
javax.resource.cci.ConnectionMetaData.getEISProductName()
javax.resource.spi.ManagedConnectionMetaData.getEISProductName()


Occurences of getEISProductVersion

getEISProductVersion occurences:
javax.resource.cci.ConnectionMetaData.getEISProductVersion()
javax.resource.spi.ManagedConnectionMetaData.getEISProductVersion()


Occurences of getEJBHome

getEJBHome occurences:
javax.ejb.EJBContext.getEJBHome()
javax.ejb.EJBMetaData.getEJBHome()
javax.ejb.EJBObject.getEJBHome()
javax.ejb.HomeHandle.getEJBHome()


Occurences of getEJBLocalHome

getEJBLocalHome occurences:
javax.ejb.EJBContext.getEJBLocalHome()
javax.ejb.EJBLocalObject.getEJBLocalHome()


Occurences of getEJBLocalObject

getEJBLocalObject occurences:
javax.ejb.EntityContext.getEJBLocalObject()
javax.ejb.SessionContext.getEJBLocalObject()


Occurences of getEJBObject

getEJBObject occurences:
javax.ejb.EntityContext.getEJBObject()
javax.ejb.Handle.getEJBObject()
javax.ejb.SessionContext.getEJBObject()


Occurences of getELContext

getELContext occurences:
javax.el.ELContextEvent.getELContext()
javax.faces.context.FacesContext.getELContext()
javax.faces.webapp.UIComponentELTag.getELContext()
javax.faces.webapp.UIComponentTagBase.getELContext()
javax.servlet.jsp.JspContext.getELContext()


Occurences of getElement

getElement occurences:
javax.xml.bind.annotation.DomHandler.getElement(javax.xml.transform.Result)
javax.xml.bind.annotation.DomHandler.getElement(ResultT)
javax.xml.bind.annotation.W3CDomHandler.getElement(javax.xml.transform.dom.DOMResult)


Occurences of getElementName

getElementName occurences:
javax.xml.bind.JAXBIntrospector.getElementName(java.lang.Object)
javax.xml.soap.SOAPElement.getElementName()


Occurences of getElementText

getElementText occurences:
javax.xml.stream.util.EventReaderDelegate.getElementText()
javax.xml.stream.util.StreamReaderDelegate.getElementText()
javax.xml.stream.XMLEventReader.getElementText()
javax.xml.stream.XMLStreamReader.getElementText()


Occurences of getELResolver

getELResolver occurences:
javax.el.ELContext.getELResolver()
javax.faces.application.Application.getELResolver()


Occurences of getEnabledClass

getEnabledClass occurences:
javax.faces.component.html.HtmlSelectManyCheckbox.getEnabledClass()
javax.faces.component.html.HtmlSelectManyListbox.getEnabledClass()
javax.faces.component.html.HtmlSelectManyMenu.getEnabledClass()
javax.faces.component.html.HtmlSelectOneListbox.getEnabledClass()
javax.faces.component.html.HtmlSelectOneMenu.getEnabledClass()
javax.faces.component.html.HtmlSelectOneRadio.getEnabledClass()


Occurences of getEncoding

getEncoding occurences:
javax.mail.internet.MimeBodyPart.getEncoding()
javax.mail.internet.MimeMessage.getEncoding()
javax.mail.internet.MimePart.getEncoding()
javax.mail.internet.MimeUtility.getEncoding(javax.activation.DataHandler)
javax.mail.internet.MimeUtility.getEncoding(javax.activation.DataSource)
javax.mail.internet.PreencodedMimeBodyPart.getEncoding()
javax.xml.bind.helpers.AbstractMarshallerImpl.getEncoding()
javax.xml.stream.util.StreamReaderDelegate.getEncoding()
javax.xml.stream.XMLStreamReader.getEncoding()


Occurences of getEnumValueTable

getEnumValueTable occurences:
javax.enterprise.deploy.shared.ActionType.getEnumValueTable()
javax.enterprise.deploy.shared.CommandType.getEnumValueTable()
javax.enterprise.deploy.shared.DConfigBeanVersionType.getEnumValueTable()
javax.enterprise.deploy.shared.ModuleType.getEnumValueTable()
javax.enterprise.deploy.shared.StateType.getEnumValueTable()


Occurences of getErrorClass

getErrorClass occurences:
javax.faces.component.html.HtmlMessage.getErrorClass()
javax.faces.component.html.HtmlMessages.getErrorClass()


Occurences of getErrorCode

getErrorCode occurences:
javax.jms.JMSException.getErrorCode()
javax.resource.ResourceException.getErrorCode()
javax.xml.bind.JAXBException.getErrorCode()
javax.xml.bind.TypeConstraintException.getErrorCode()


Occurences of getErrorStyle

getErrorStyle occurences:
javax.faces.component.html.HtmlMessage.getErrorStyle()
javax.faces.component.html.HtmlMessages.getErrorStyle()


Occurences of getEventHandler

getEventHandler occurences:
javax.xml.bind.Binder.getEventHandler()
javax.xml.bind.helpers.AbstractMarshallerImpl.getEventHandler()
javax.xml.bind.helpers.AbstractUnmarshallerImpl.getEventHandler()
javax.xml.bind.Marshaller.getEventHandler()
javax.xml.bind.Unmarshaller.getEventHandler()
javax.xml.bind.Validator.getEventHandler()


Occurences of getEventType

getEventType occurences:
javax.xml.registry.infomodel.AuditableEvent.getEventType()
javax.xml.stream.events.XMLEvent.getEventType()
javax.xml.stream.util.StreamReaderDelegate.getEventType()
javax.xml.stream.XMLStreamReader.getEventType()


Occurences of getException

getException occurences:
javax.resource.spi.ConnectionEvent.getException()
javax.resource.spi.work.WorkEvent.getException()
javax.servlet.jsp.PageContext.getException()
javax.xml.stream.FactoryConfigurationError.getException()


Occurences of getExecutor

getExecutor occurences:
javax.xml.ws.Endpoint.getExecutor()
javax.xml.ws.Service.getExecutor()
javax.xml.ws.spi.ServiceDelegate.getExecutor()


Occurences of getExpiredMessageCount

getExpiredMessageCount occurences:
javax.management.j2ee.statistics.JMSEndpointStats.getExpiredMessageCount()
javax.management.j2ee.statistics.JMSSessionStats.getExpiredMessageCount()


Occurences of getExpressionFactory

getExpressionFactory occurences:
javax.faces.application.Application.getExpressionFactory()
javax.servlet.jsp.JspApplicationContext.getExpressionFactory()


Occurences of getExpressionString

getExpressionString occurences:
javax.el.Expression.getExpressionString()
javax.faces.el.MethodBinding.getExpressionString()
javax.faces.el.ValueBinding.getExpressionString()


Occurences of getFacesContext

getFacesContext occurences:
javax.faces.component.UIComponent.getFacesContext()
javax.faces.component.UIComponentBase.getFacesContext()
javax.faces.context.FacesContextFactory.getFacesContext(java.lang.Object, java.lang.Object, java.lang.Object, javax.faces.lifecycle.Lifecycle)
javax.faces.event.PhaseEvent.getFacesContext()
javax.faces.webapp.UIComponentClassicTagBase.getFacesContext()
javax.faces.webapp.UIComponentTagBase.getFacesContext()


Occurences of getFacesListeners

getFacesListeners occurences:
javax.faces.component.UIComponent.getFacesListeners(java.lang.Class)
javax.faces.component.UIComponentBase.getFacesListeners(java.lang.Class)


Occurences of getFacesMessage

getFacesMessage occurences:
javax.faces.convert.ConverterException.getFacesMessage()
javax.faces.validator.ValidatorException.getFacesMessage()


Occurences of getFacet

getFacet occurences:
javax.faces.component.UIComponent.getFacet(java.lang.String)
javax.faces.component.UIComponentBase.getFacet(java.lang.String)


Occurences of getFacetCount

getFacetCount occurences:
javax.faces.component.UIComponent.getFacetCount()
javax.faces.component.UIComponentBase.getFacetCount()


Occurences of getFacets

getFacets occurences:
javax.faces.component.UIComponent.getFacets()
javax.faces.component.UIComponentBase.getFacets()


Occurences of getFacetsAndChildren

getFacetsAndChildren occurences:
javax.faces.component.UIComponent.getFacetsAndChildren()
javax.faces.component.UIComponentBase.getFacetsAndChildren()


Occurences of getFamily

getFamily occurences:
javax.faces.component.UIColumn.getFamily()
javax.faces.component.UICommand.getFamily()
javax.faces.component.UIComponent.getFamily()
javax.faces.component.UIData.getFamily()
javax.faces.component.UIForm.getFamily()
javax.faces.component.UIGraphic.getFamily()
javax.faces.component.UIInput.getFamily()
javax.faces.component.UIMessage.getFamily()
javax.faces.component.UIMessages.getFamily()
javax.faces.component.UINamingContainer.getFamily()
javax.faces.component.UIOutput.getFamily()
javax.faces.component.UIPanel.getFamily()
javax.faces.component.UIParameter.getFamily()
javax.faces.component.UISelectBoolean.getFamily()
javax.faces.component.UISelectItem.getFamily()
javax.faces.component.UISelectItems.getFamily()
javax.faces.component.UISelectMany.getFamily()
javax.faces.component.UISelectOne.getFamily()
javax.faces.component.UIViewRoot.getFamily()


Occurences of getFatalClass

getFatalClass occurences:
javax.faces.component.html.HtmlMessage.getFatalClass()
javax.faces.component.html.HtmlMessages.getFatalClass()


Occurences of getFatalStyle

getFatalStyle occurences:
javax.faces.component.html.HtmlMessage.getFatalStyle()
javax.faces.component.html.HtmlMessages.getFatalStyle()


Occurences of getFault

getFault occurences:
javax.xml.soap.SOAPBody.getFault()
javax.xml.ws.soap.SOAPFaultException.getFault()


Occurences of getFaultActor

getFaultActor occurences:
javax.xml.rpc.soap.SOAPFaultException.getFaultActor()
javax.xml.soap.SOAPFault.getFaultActor()


Occurences of getFaultCode

getFaultCode occurences:
javax.xml.rpc.soap.SOAPFaultException.getFaultCode()
javax.xml.soap.SOAPFault.getFaultCode()


Occurences of getFaultString

getFaultString occurences:
javax.xml.rpc.soap.SOAPFaultException.getFaultString()
javax.xml.soap.SOAPFault.getFaultString()


Occurences of getFeatureDescriptors

getFeatureDescriptors occurences:
javax.el.ArrayELResolver.getFeatureDescriptors(javax.el.ELContext, java.lang.Object)
javax.el.BeanELResolver.getFeatureDescriptors(javax.el.ELContext, java.lang.Object)
javax.el.CompositeELResolver.getFeatureDescriptors(javax.el.ELContext, java.lang.Object)
javax.el.ELResolver.getFeatureDescriptors(javax.el.ELContext, java.lang.Object)
javax.el.ListELResolver.getFeatureDescriptors(javax.el.ELContext, java.lang.Object)
javax.el.MapELResolver.getFeatureDescriptors(javax.el.ELContext, java.lang.Object)
javax.el.ResourceBundleELResolver.getFeatureDescriptors(javax.el.ELContext, java.lang.Object)
javax.servlet.jsp.el.ImplicitObjectELResolver.getFeatureDescriptors(javax.el.ELContext, java.lang.Object)
javax.servlet.jsp.el.ScopedAttributeELResolver.getFeatureDescriptors(javax.el.ELContext, java.lang.Object)


Occurences of getFile

getFile occurences:
javax.activation.FileDataSource.getFile()
javax.mail.URLName.getFile()


Occurences of getFileName

getFileName occurences:
javax.mail.internet.MimeBodyPart.getFileName()
javax.mail.internet.MimeMessage.getFileName()
javax.mail.Part.getFileName()


Occurences of getFlags

getFlags occurences:
javax.mail.internet.MimeMessage.getFlags()
javax.mail.Message.getFlags()
javax.mail.search.FlagTerm.getFlags()


Occurences of getFolder

getFolder occurences:
javax.mail.event.FolderEvent.getFolder()
javax.mail.Folder.getFolder(java.lang.String)
javax.mail.FolderClosedException.getFolder()
javax.mail.FolderNotFoundException.getFolder()
javax.mail.Message.getFolder()
javax.mail.ReadOnlyFolderException.getFolder()
javax.mail.Session.getFolder(javax.mail.URLName)
javax.mail.Store.getFolder(java.lang.String)
javax.mail.Store.getFolder(javax.mail.URLName)


Occurences of getFooter

getFooter occurences:
javax.faces.component.UIColumn.getFooter()
javax.faces.component.UIData.getFooter()


Occurences of getFooterClass

getFooterClass occurences:
javax.faces.component.html.HtmlColumn.getFooterClass()
javax.faces.component.html.HtmlDataTable.getFooterClass()
javax.faces.component.html.HtmlPanelGrid.getFooterClass()


Occurences of getFor

getFor occurences:
javax.faces.component.html.HtmlOutputLabel.getFor()
javax.faces.component.UIMessage.getFor()


Occurences of getFrame

getFrame occurences:
javax.faces.component.html.HtmlDataTable.getFrame()
javax.faces.component.html.HtmlPanelGrid.getFrame()


Occurences of getFreePoolSize

getFreePoolSize occurences:
javax.management.j2ee.statistics.JCAConnectionPoolStats.getFreePoolSize()
javax.management.j2ee.statistics.JDBCConnectionPoolStats.getFreePoolSize()


Occurences of getFrom

getFrom occurences:
javax.mail.internet.MimeMessage.getFrom()
javax.mail.Message.getFrom()


Occurences of getFullName

getFullName occurences:
javax.mail.Folder.getFullName()
javax.xml.registry.infomodel.PersonName.getFullName()


Occurences of getHandle

getHandle occurences:
javax.ejb.EJBObject.getHandle()
javax.ejb.Timer.getHandle()


Occurences of getHandlerChain

getHandlerChain occurences:
javax.xml.rpc.handler.HandlerRegistry.getHandlerChain(javax.xml.namespace.QName)
javax.xml.ws.Binding.getHandlerChain()
javax.xml.ws.handler.HandlerResolver.getHandlerChain(javax.xml.ws.handler.PortInfo)


Occurences of getHandlerResolver

getHandlerResolver occurences:
javax.xml.ws.Service.getHandlerResolver()
javax.xml.ws.spi.ServiceDelegate.getHandlerResolver()


Occurences of getHeader

getHeader occurences:
javax.faces.component.UIColumn.getHeader()
javax.faces.component.UIData.getHeader()
javax.mail.internet.InternetHeaders.getHeader(java.lang.String)
javax.mail.internet.InternetHeaders.getHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimeBodyPart.getHeader(java.lang.String)
javax.mail.internet.MimeBodyPart.getHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimeMessage.getHeader(java.lang.String)
javax.mail.internet.MimeMessage.getHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimePart.getHeader(java.lang.String, java.lang.String)
javax.mail.Part.getHeader(java.lang.String)
javax.servlet.http.HttpServletRequest.getHeader(java.lang.String)
javax.servlet.http.HttpServletRequestWrapper.getHeader(java.lang.String)
javax.xml.soap.MimeHeaders.getHeader(java.lang.String)
javax.xml.soap.SOAPEnvelope.getHeader()


Occurences of getHeaderClass

getHeaderClass occurences:
javax.faces.component.html.HtmlColumn.getHeaderClass()
javax.faces.component.html.HtmlDataTable.getHeaderClass()
javax.faces.component.html.HtmlPanelGrid.getHeaderClass()


Occurences of getHeaderNames

getHeaderNames occurences:
javax.mail.FetchProfile.getHeaderNames()
javax.servlet.http.HttpServletRequest.getHeaderNames()
javax.servlet.http.HttpServletRequestWrapper.getHeaderNames()


Occurences of getHeaders

getHeaders occurences:
javax.servlet.http.HttpServletRequest.getHeaders(java.lang.String)
javax.servlet.http.HttpServletRequestWrapper.getHeaders(java.lang.String)
javax.xml.rpc.handler.GenericHandler.getHeaders()
javax.xml.rpc.handler.Handler.getHeaders()
javax.xml.rpc.handler.HandlerInfo.getHeaders()
javax.xml.ws.handler.soap.SOAPHandler.getHeaders()
javax.xml.ws.handler.soap.SOAPMessageContext.getHeaders(javax.xml.namespace.QName, javax.xml.bind.JAXBContext, boolean)


Occurences of getHost

getHost occurences:
javax.mail.internet.NewsAddress.getHost()
javax.mail.URLName.getHost()


Occurences of getHreflang

getHreflang occurences:
javax.faces.component.html.HtmlCommandLink.getHreflang()
javax.faces.component.html.HtmlOutputLink.getHreflang()


Occurences of getId

getId occurences:
javax.enterprise.deploy.model.DDBean.getId()
javax.faces.component.UIComponent.getId()
javax.faces.component.UIComponentBase.getId()
javax.faces.webapp.UIComponentClassicTagBase.getId()
javax.resource.spi.ConnectionEvent.getId()
javax.servlet.http.HttpSession.getId()
javax.servlet.jsp.tagext.TagData.getId()
javax.servlet.jsp.tagext.TagSupport.getId()
javax.servlet.jsp.tagext.ValidationMessage.getId()
javax.xml.registry.infomodel.Key.getId()


Occurences of getIndexOfNextChildTag

getIndexOfNextChildTag occurences:
javax.faces.webapp.UIComponentClassicTagBase.getIndexOfNextChildTag()
javax.faces.webapp.UIComponentTagBase.getIndexOfNextChildTag()


Occurences of getInfoClass

getInfoClass occurences:
javax.faces.component.html.HtmlMessage.getInfoClass()
javax.faces.component.html.HtmlMessages.getInfoClass()


Occurences of getInfoString

getInfoString occurences:
javax.servlet.jsp.tagext.TagInfo.getInfoString()
javax.servlet.jsp.tagext.TagLibraryInfo.getInfoString()


Occurences of getInfoStyle

getInfoStyle occurences:
javax.faces.component.html.HtmlMessage.getInfoStyle()
javax.faces.component.html.HtmlMessages.getInfoStyle()


Occurences of getInitParameter

getInitParameter occurences:
javax.faces.context.ExternalContext.getInitParameter(java.lang.String)
javax.servlet.FilterConfig.getInitParameter(java.lang.String)
javax.servlet.GenericServlet.getInitParameter(java.lang.String)
javax.servlet.ServletConfig.getInitParameter(java.lang.String)
javax.servlet.ServletContext.getInitParameter(java.lang.String)


Occurences of getInitParameterNames

getInitParameterNames occurences:
javax.servlet.FilterConfig.getInitParameterNames()
javax.servlet.GenericServlet.getInitParameterNames()
javax.servlet.ServletConfig.getInitParameterNames()
javax.servlet.ServletContext.getInitParameterNames()


Occurences of getInputStream

getInputStream occurences:
javax.activation.DataHandler.getInputStream()
javax.activation.DataSource.getInputStream()
javax.activation.FileDataSource.getInputStream()
javax.activation.URLDataSource.getInputStream()
javax.mail.internet.MimeBodyPart.getInputStream()
javax.mail.internet.MimeMessage.getInputStream()
javax.mail.internet.MimePartDataSource.getInputStream()
javax.mail.Part.getInputStream()
javax.mail.util.ByteArrayDataSource.getInputStream()
javax.servlet.jsp.tagext.PageData.getInputStream()
javax.servlet.ServletRequest.getInputStream()
javax.servlet.ServletRequestWrapper.getInputStream()


Occurences of getInstance

getInstance occurences:
javax.enterprise.deploy.shared.factories.DeploymentFactoryManager.getInstance()
javax.mail.Session.getInstance(java.util.Properties)
javax.mail.Session.getInstance(java.util.Properties, javax.mail.Authenticator)


Occurences of getIntHeader

getIntHeader occurences:
javax.servlet.http.HttpServletRequest.getIntHeader(java.lang.String)
javax.servlet.http.HttpServletRequestWrapper.getIntHeader(java.lang.String)


Occurences of getInvalidAddresses

getInvalidAddresses occurences:
javax.mail.event.TransportEvent.getInvalidAddresses()
javax.mail.SendFailedException.getInvalidAddresses()


Occurences of getJAXBNode

getJAXBNode occurences:
javax.xml.bind.Binder.getJAXBNode(java.lang.Object)
javax.xml.bind.Binder.getJAXBNode(XmlNode)


Occurences of getJspContext

getJspContext occurences:
javax.servlet.jsp.tagext.JspFragment.getJspContext()
javax.servlet.jsp.tagext.SimpleTagSupport.getJspContext()


Occurences of getLabel

getLabel occurences:
javax.faces.component.html.HtmlCommandButton.getLabel()
javax.faces.component.html.HtmlInputSecret.getLabel()
javax.faces.component.html.HtmlInputText.getLabel()
javax.faces.component.html.HtmlInputTextarea.getLabel()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getLabel()
javax.faces.component.html.HtmlSelectManyCheckbox.getLabel()
javax.faces.component.html.HtmlSelectManyListbox.getLabel()
javax.faces.component.html.HtmlSelectManyMenu.getLabel()
javax.faces.component.html.HtmlSelectOneListbox.getLabel()
javax.faces.component.html.HtmlSelectOneMenu.getLabel()
javax.faces.component.html.HtmlSelectOneRadio.getLabel()
javax.faces.model.SelectItem.getLabel()


Occurences of getLang

getLang occurences:
javax.faces.component.html.HtmlCommandButton.getLang()
javax.faces.component.html.HtmlCommandLink.getLang()
javax.faces.component.html.HtmlDataTable.getLang()
javax.faces.component.html.HtmlForm.getLang()
javax.faces.component.html.HtmlGraphicImage.getLang()
javax.faces.component.html.HtmlInputSecret.getLang()
javax.faces.component.html.HtmlInputText.getLang()
javax.faces.component.html.HtmlInputTextarea.getLang()
javax.faces.component.html.HtmlMessage.getLang()
javax.faces.component.html.HtmlMessages.getLang()
javax.faces.component.html.HtmlOutputFormat.getLang()
javax.faces.component.html.HtmlOutputLabel.getLang()
javax.faces.component.html.HtmlOutputLink.getLang()
javax.faces.component.html.HtmlOutputText.getLang()
javax.faces.component.html.HtmlPanelGrid.getLang()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getLang()
javax.faces.component.html.HtmlSelectManyCheckbox.getLang()
javax.faces.component.html.HtmlSelectManyListbox.getLang()
javax.faces.component.html.HtmlSelectManyMenu.getLang()
javax.faces.component.html.HtmlSelectOneListbox.getLang()
javax.faces.component.html.HtmlSelectOneMenu.getLang()
javax.faces.component.html.HtmlSelectOneRadio.getLang()


Occurences of getLayout

getLayout occurences:
javax.faces.component.html.HtmlMessages.getLayout()
javax.faces.component.html.HtmlPanelGroup.getLayout()
javax.faces.component.html.HtmlSelectManyCheckbox.getLayout()
javax.faces.component.html.HtmlSelectOneRadio.getLayout()


Occurences of getLineCount

getLineCount occurences:
javax.mail.internet.MimeBodyPart.getLineCount()
javax.mail.internet.MimeMessage.getLineCount()
javax.mail.Part.getLineCount()


Occurences of getLineNumber

getLineNumber occurences:
javax.xml.bind.helpers.ValidationEventLocatorImpl.getLineNumber()
javax.xml.bind.ValidationEventLocator.getLineNumber()
javax.xml.stream.Location.getLineNumber()


Occurences of getLinkedCause

getLinkedCause occurences:
javax.xml.rpc.JAXRPCException.getLinkedCause()
javax.xml.rpc.ServiceException.getLinkedCause()


Occurences of getLinkedException

getLinkedException occurences:
javax.jms.JMSException.getLinkedException()
javax.resource.ResourceException.getLinkedException()
javax.xml.bind.helpers.ValidationEventImpl.getLinkedException()
javax.xml.bind.JAXBException.getLinkedException()
javax.xml.bind.TypeConstraintException.getLinkedException()
javax.xml.bind.ValidationEvent.getLinkedException()


Occurences of getListener

getListener occurences:
javax.xml.bind.helpers.AbstractMarshallerImpl.getListener()
javax.xml.bind.helpers.AbstractUnmarshallerImpl.getListener()
javax.xml.bind.Marshaller.getListener()
javax.xml.bind.Unmarshaller.getListener()


Occurences of getLocalAddr

getLocalAddr occurences:
javax.servlet.ServletRequest.getLocalAddr()
javax.servlet.ServletRequestWrapper.getLocalAddr()


Occurences of getLocale

getLocale occurences:
javax.el.ELContext.getLocale()
javax.faces.component.UIViewRoot.getLocale()
javax.faces.convert.DateTimeConverter.getLocale()
javax.faces.convert.NumberConverter.getLocale()
javax.servlet.ServletRequest.getLocale()
javax.servlet.ServletRequestWrapper.getLocale()
javax.servlet.ServletResponse.getLocale()
javax.servlet.ServletResponseWrapper.getLocale()
javax.xml.registry.infomodel.LocalizedString.getLocale()


Occurences of getLocales

getLocales occurences:
javax.servlet.ServletRequest.getLocales()
javax.servlet.ServletRequestWrapper.getLocales()


Occurences of getLocalName

getLocalName occurences:
javax.servlet.ServletRequest.getLocalName()
javax.servlet.ServletRequestWrapper.getLocalName()
javax.xml.soap.Name.getLocalName()
javax.xml.stream.util.StreamReaderDelegate.getLocalName()
javax.xml.stream.XMLStreamReader.getLocalName()


Occurences of getLocalPort

getLocalPort occurences:
javax.servlet.ServletRequest.getLocalPort()
javax.servlet.ServletRequestWrapper.getLocalPort()


Occurences of getLocalTransaction

getLocalTransaction occurences:
javax.resource.cci.Connection.getLocalTransaction()
javax.resource.spi.ManagedConnection.getLocalTransaction()


Occurences of getLocalValue

getLocalValue occurences:
javax.faces.component.UIOutput.getLocalValue()
javax.faces.component.ValueHolder.getLocalValue()


Occurences of getLocation

getLocation occurences:
javax.xml.stream.events.XMLEvent.getLocation()
javax.xml.stream.util.StreamReaderDelegate.getLocation()
javax.xml.stream.XMLStreamException.getLocation()
javax.xml.stream.XMLStreamReader.getLocation()


Occurences of getLocator

getLocator occurences:
javax.xml.bind.helpers.ValidationEventImpl.getLocator()
javax.xml.bind.ValidationEvent.getLocator()


Occurences of getLogWriter

getLogWriter occurences:
javax.resource.spi.ManagedConnection.getLogWriter()
javax.resource.spi.ManagedConnectionFactory.getLogWriter()


Occurences of getMajorVersion

getMajorVersion occurences:
javax.servlet.ServletContext.getMajorVersion()
javax.xml.registry.infomodel.Versionable.getMajorVersion()


Occurences of getManagedConnectionFactory

getManagedConnectionFactory occurences:
javax.management.j2ee.statistics.JCAConnectionStats.getManagedConnectionFactory()
javax.resource.spi.security.PasswordCredential.getManagedConnectionFactory()


Occurences of getMatchingHeaderLines

getMatchingHeaderLines occurences:
javax.mail.internet.InternetHeaders.getMatchingHeaderLines(java.lang.String[])
javax.mail.internet.MimeBodyPart.getMatchingHeaderLines(java.lang.String[])
javax.mail.internet.MimeMessage.getMatchingHeaderLines(java.lang.String[])
javax.mail.internet.MimePart.getMatchingHeaderLines(java.lang.String[])


Occurences of getMatchingHeaders

getMatchingHeaders occurences:
javax.mail.internet.InternetHeaders.getMatchingHeaders(java.lang.String[])
javax.mail.internet.MimeBodyPart.getMatchingHeaders(java.lang.String[])
javax.mail.internet.MimeMessage.getMatchingHeaders(java.lang.String[])
javax.mail.Part.getMatchingHeaders(java.lang.String[])
javax.xml.soap.MimeHeaders.getMatchingHeaders(java.lang.String[])


Occurences of getMatchingMimeHeaders

getMatchingMimeHeaders occurences:
javax.xml.soap.AttachmentPart.getMatchingMimeHeaders(java.lang.String[])
javax.xml.soap.SOAPPart.getMatchingMimeHeaders(java.lang.String[])


Occurences of getMaximum

getMaximum occurences:
javax.faces.validator.DoubleRangeValidator.getMaximum()
javax.faces.validator.LengthValidator.getMaximum()
javax.faces.validator.LongRangeValidator.getMaximum()


Occurences of getMaxlength

getMaxlength occurences:
javax.faces.component.html.HtmlInputSecret.getMaxlength()
javax.faces.component.html.HtmlInputText.getMaxlength()


Occurences of getMechanismType

getMechanismType occurences:
javax.xml.rpc.encoding.Deserializer.getMechanismType()
javax.xml.rpc.encoding.Serializer.getMechanismType()


Occurences of getMessage

getMessage occurences:
javax.ejb.EJBException.getMessage()
javax.enterprise.deploy.spi.status.DeploymentStatus.getMessage()
javax.faces.application.ViewExpiredException.getMessage()
javax.mail.event.MessageChangedEvent.getMessage()
javax.mail.event.StoreEvent.getMessage()
javax.mail.event.TransportEvent.getMessage()
javax.mail.Folder.getMessage(int)
javax.mail.MessageContext.getMessage()
javax.resource.ResourceException.getMessage()
javax.servlet.jsp.tagext.ValidationMessage.getMessage()
javax.xml.bind.helpers.ValidationEventImpl.getMessage()
javax.xml.bind.ValidationEvent.getMessage()
javax.xml.registry.JAXRException.getMessage()
javax.xml.rpc.handler.soap.SOAPMessageContext.getMessage()
javax.xml.soap.SOAPException.getMessage()
javax.xml.stream.FactoryConfigurationError.getMessage()
javax.xml.ws.handler.LogicalMessageContext.getMessage()
javax.xml.ws.handler.soap.SOAPMessageContext.getMessage()


Occurences of getMessageContext

getMessageContext occurences:
javax.ejb.SessionContext.getMessageContext()
javax.mail.internet.MimePartDataSource.getMessageContext()
javax.mail.MessageAware.getMessageContext()
javax.xml.rpc.server.ServletEndpointContext.getMessageContext()
javax.xml.ws.WebServiceContext.getMessageContext()


Occurences of getMessageCount

getMessageCount occurences:
javax.mail.Folder.getMessageCount()
javax.management.j2ee.statistics.JMSEndpointStats.getMessageCount()
javax.management.j2ee.statistics.JMSSessionStats.getMessageCount()
javax.management.j2ee.statistics.MessageDrivenBeanStats.getMessageCount()


Occurences of getMessageListener

getMessageListener occurences:
javax.jms.MessageConsumer.getMessageListener()
javax.jms.Session.getMessageListener()


Occurences of getMessages

getMessages occurences:
javax.faces.context.FacesContext.getMessages()
javax.faces.context.FacesContext.getMessages(java.lang.String)
javax.mail.event.MessageCountEvent.getMessages()
javax.mail.Folder.getMessages()
javax.mail.Folder.getMessages(int, int)
javax.mail.Folder.getMessages(int[])


Occurences of getMessagesByUID

getMessagesByUID occurences:
javax.mail.UIDFolder.getMessagesByUID(long, long)
javax.mail.UIDFolder.getMessagesByUID(long[])


Occurences of getMessageSelector

getMessageSelector occurences:
javax.jms.MessageConsumer.getMessageSelector()
javax.jms.QueueBrowser.getMessageSelector()


Occurences of getMessageWaitTime

getMessageWaitTime occurences:
javax.management.j2ee.statistics.JMSEndpointStats.getMessageWaitTime()
javax.management.j2ee.statistics.JMSSessionStats.getMessageWaitTime()


Occurences of getMetaData

getMetaData occurences:
javax.jms.Connection.getMetaData()
javax.resource.cci.Connection.getMetaData()
javax.resource.cci.ConnectionFactory.getMetaData()
javax.resource.spi.ManagedConnection.getMetaData()


Occurences of getMethod

getMethod occurences:
javax.interceptor.InvocationContext.getMethod()
javax.servlet.http.HttpServletRequest.getMethod()
javax.servlet.http.HttpServletRequestWrapper.getMethod()


Occurences of getMimeHeader

getMimeHeader occurences:
javax.xml.soap.AttachmentPart.getMimeHeader(java.lang.String)
javax.xml.soap.SOAPPart.getMimeHeader(java.lang.String)


Occurences of getMimeType

getMimeType occurences:
javax.activation.ActivationDataFlavor.getMimeType()
javax.servlet.ServletContext.getMimeType(java.lang.String)
javax.xml.registry.infomodel.ExtrinsicObject.getMimeType()


Occurences of getMimeTypes

getMimeTypes occurences:
javax.activation.CommandMap.getMimeTypes()
javax.activation.MailcapCommandMap.getMimeTypes()


Occurences of getMinimum

getMinimum occurences:
javax.faces.validator.DoubleRangeValidator.getMinimum()
javax.faces.validator.LengthValidator.getMinimum()
javax.faces.validator.LongRangeValidator.getMinimum()


Occurences of getMinorVersion

getMinorVersion occurences:
javax.servlet.ServletContext.getMinorVersion()
javax.xml.registry.infomodel.Versionable.getMinorVersion()


Occurences of getModuleDTDVersion

getModuleDTDVersion occurences:
javax.enterprise.deploy.model.DDBeanRoot.getModuleDTDVersion()
javax.enterprise.deploy.model.DeployableObject.getModuleDTDVersion()


Occurences of getModuleUris

getModuleUris occurences:
javax.enterprise.deploy.model.J2eeApplicationObject.getModuleUris()
javax.enterprise.deploy.model.J2eeApplicationObject.getModuleUris(javax.enterprise.deploy.shared.ModuleType)


Occurences of getName

getName occurences:
javax.activation.DataHandler.getName()
javax.activation.DataSource.getName()
javax.activation.FileDataSource.getName()
javax.activation.URLDataSource.getName()
javax.el.MethodInfo.getName()
javax.enterprise.deploy.spi.Target.getName()
javax.faces.component.UIParameter.getName()
javax.faces.webapp.FacetTag.getName()
javax.mail.Folder.getName()
javax.mail.Header.getName()
javax.mail.internet.MimePartDataSource.getName()
javax.mail.util.ByteArrayDataSource.getName()
javax.management.j2ee.statistics.Statistic.getName()
javax.resource.spi.security.GenericCredential.getName()
javax.servlet.http.Cookie.getName()
javax.servlet.http.HttpSessionBindingEvent.getName()
javax.servlet.jsp.tagext.FunctionInfo.getName()
javax.servlet.jsp.tagext.TagAttributeInfo.getName()
javax.servlet.jsp.tagext.TagFileInfo.getName()
javax.servlet.ServletContextAttributeEvent.getName()
javax.servlet.ServletRequestAttributeEvent.getName()
javax.xml.bind.JAXBElement.getName()
javax.xml.registry.infomodel.RegistryObject.getName()
javax.xml.registry.infomodel.Slot.getName()
javax.xml.soap.MimeHeader.getName()
javax.xml.stream.events.Attribute.getName()
javax.xml.stream.events.EndElement.getName()
javax.xml.stream.events.EntityDeclaration.getName()
javax.xml.stream.events.EntityReference.getName()
javax.xml.stream.events.NotationDeclaration.getName()
javax.xml.stream.events.StartElement.getName()
javax.xml.stream.util.StreamReaderDelegate.getName()
javax.xml.stream.XMLStreamReader.getName()


Occurences of getNames

getNames occurences:
javax.activation.MimeTypeParameterList.getNames()
javax.mail.internet.ParameterList.getNames()


Occurences of getNamespaceContext

getNamespaceContext occurences:
javax.xml.stream.events.StartElement.getNamespaceContext()
javax.xml.stream.util.StreamReaderDelegate.getNamespaceContext()
javax.xml.stream.XMLEventWriter.getNamespaceContext()
javax.xml.stream.XMLStreamReader.getNamespaceContext()
javax.xml.stream.XMLStreamWriter.getNamespaceContext()


Occurences of getNamespaceCount

getNamespaceCount occurences:
javax.xml.stream.util.StreamReaderDelegate.getNamespaceCount()
javax.xml.stream.XMLStreamReader.getNamespaceCount()


Occurences of getNamespacePrefix

getNamespacePrefix occurences:
javax.xml.stream.util.StreamReaderDelegate.getNamespacePrefix(int)
javax.xml.stream.XMLStreamReader.getNamespacePrefix(int)


Occurences of getNamespaces

getNamespaces occurences:
javax.xml.stream.events.EndElement.getNamespaces()
javax.xml.stream.events.StartElement.getNamespaces()


Occurences of getNamespaceURI

getNamespaceURI occurences:
javax.xml.soap.SOAPElement.getNamespaceURI(java.lang.String)
javax.xml.stream.events.Namespace.getNamespaceURI()
javax.xml.stream.events.StartElement.getNamespaceURI(java.lang.String)
javax.xml.stream.util.StreamReaderDelegate.getNamespaceURI()
javax.xml.stream.util.StreamReaderDelegate.getNamespaceURI(int)
javax.xml.stream.util.StreamReaderDelegate.getNamespaceURI(java.lang.String)
javax.xml.stream.XMLStreamReader.getNamespaceURI()
javax.xml.stream.XMLStreamReader.getNamespaceURI(int)
javax.xml.stream.XMLStreamReader.getNamespaceURI(java.lang.String)


Occurences of getNode

getNode occurences:
javax.xml.bind.helpers.AbstractMarshallerImpl.getNode(java.lang.Object)
javax.xml.bind.helpers.ValidationEventLocatorImpl.getNode()
javax.xml.bind.Marshaller.getNode(java.lang.Object)
javax.xml.bind.ValidationEventLocator.getNode()


Occurences of getNonMatchingHeaderLines

getNonMatchingHeaderLines occurences:
javax.mail.internet.InternetHeaders.getNonMatchingHeaderLines(java.lang.String[])
javax.mail.internet.MimeBodyPart.getNonMatchingHeaderLines(java.lang.String[])
javax.mail.internet.MimeMessage.getNonMatchingHeaderLines(java.lang.String[])
javax.mail.internet.MimePart.getNonMatchingHeaderLines(java.lang.String[])


Occurences of getNonMatchingHeaders

getNonMatchingHeaders occurences:
javax.mail.internet.InternetHeaders.getNonMatchingHeaders(java.lang.String[])
javax.mail.internet.MimeBodyPart.getNonMatchingHeaders(java.lang.String[])
javax.mail.internet.MimeMessage.getNonMatchingHeaders(java.lang.String[])
javax.mail.Part.getNonMatchingHeaders(java.lang.String[])
javax.xml.soap.MimeHeaders.getNonMatchingHeaders(java.lang.String[])


Occurences of getNonMatchingMimeHeaders

getNonMatchingMimeHeaders occurences:
javax.xml.soap.AttachmentPart.getNonMatchingMimeHeaders(java.lang.String[])
javax.xml.soap.SOAPPart.getNonMatchingMimeHeaders(java.lang.String[])


Occurences of getNumber

getNumber occurences:
javax.mail.search.IntegerComparisonTerm.getNumber()
javax.xml.registry.infomodel.TelephoneNumber.getNumber()


Occurences of getObject

getObject occurences:
javax.jms.MapMessage.getObject(java.lang.String)
javax.jms.ObjectMessage.getObject()
javax.xml.bind.helpers.ValidationEventLocatorImpl.getObject()
javax.xml.bind.ValidationEventLocator.getObject()


Occurences of getOffset

getOffset occurences:
javax.enterprise.deploy.shared.ActionType.getOffset()
javax.enterprise.deploy.shared.CommandType.getOffset()
javax.enterprise.deploy.shared.DConfigBeanVersionType.getOffset()
javax.enterprise.deploy.shared.ModuleType.getOffset()
javax.enterprise.deploy.shared.StateType.getOffset()
javax.xml.bind.helpers.ValidationEventLocatorImpl.getOffset()
javax.xml.bind.ValidationEventLocator.getOffset()


Occurences of getOnblur

getOnblur occurences:
javax.faces.component.html.HtmlCommandButton.getOnblur()
javax.faces.component.html.HtmlCommandLink.getOnblur()
javax.faces.component.html.HtmlInputSecret.getOnblur()
javax.faces.component.html.HtmlInputText.getOnblur()
javax.faces.component.html.HtmlInputTextarea.getOnblur()
javax.faces.component.html.HtmlOutputLabel.getOnblur()
javax.faces.component.html.HtmlOutputLink.getOnblur()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOnblur()
javax.faces.component.html.HtmlSelectManyCheckbox.getOnblur()
javax.faces.component.html.HtmlSelectManyListbox.getOnblur()
javax.faces.component.html.HtmlSelectManyMenu.getOnblur()
javax.faces.component.html.HtmlSelectOneListbox.getOnblur()
javax.faces.component.html.HtmlSelectOneMenu.getOnblur()
javax.faces.component.html.HtmlSelectOneRadio.getOnblur()


Occurences of getOnchange

getOnchange occurences:
javax.faces.component.html.HtmlCommandButton.getOnchange()
javax.faces.component.html.HtmlInputSecret.getOnchange()
javax.faces.component.html.HtmlInputText.getOnchange()
javax.faces.component.html.HtmlInputTextarea.getOnchange()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOnchange()
javax.faces.component.html.HtmlSelectManyCheckbox.getOnchange()
javax.faces.component.html.HtmlSelectManyListbox.getOnchange()
javax.faces.component.html.HtmlSelectManyMenu.getOnchange()
javax.faces.component.html.HtmlSelectOneListbox.getOnchange()
javax.faces.component.html.HtmlSelectOneMenu.getOnchange()
javax.faces.component.html.HtmlSelectOneRadio.getOnchange()


Occurences of getOnclick

getOnclick occurences:
javax.faces.component.html.HtmlCommandButton.getOnclick()
javax.faces.component.html.HtmlCommandLink.getOnclick()
javax.faces.component.html.HtmlDataTable.getOnclick()
javax.faces.component.html.HtmlForm.getOnclick()
javax.faces.component.html.HtmlGraphicImage.getOnclick()
javax.faces.component.html.HtmlInputSecret.getOnclick()
javax.faces.component.html.HtmlInputText.getOnclick()
javax.faces.component.html.HtmlInputTextarea.getOnclick()
javax.faces.component.html.HtmlOutputLabel.getOnclick()
javax.faces.component.html.HtmlOutputLink.getOnclick()
javax.faces.component.html.HtmlPanelGrid.getOnclick()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOnclick()
javax.faces.component.html.HtmlSelectManyCheckbox.getOnclick()
javax.faces.component.html.HtmlSelectManyListbox.getOnclick()
javax.faces.component.html.HtmlSelectManyMenu.getOnclick()
javax.faces.component.html.HtmlSelectOneListbox.getOnclick()
javax.faces.component.html.HtmlSelectOneMenu.getOnclick()
javax.faces.component.html.HtmlSelectOneRadio.getOnclick()


Occurences of getOndblclick

getOndblclick occurences:
javax.faces.component.html.HtmlCommandButton.getOndblclick()
javax.faces.component.html.HtmlCommandLink.getOndblclick()
javax.faces.component.html.HtmlDataTable.getOndblclick()
javax.faces.component.html.HtmlForm.getOndblclick()
javax.faces.component.html.HtmlGraphicImage.getOndblclick()
javax.faces.component.html.HtmlInputSecret.getOndblclick()
javax.faces.component.html.HtmlInputText.getOndblclick()
javax.faces.component.html.HtmlInputTextarea.getOndblclick()
javax.faces.component.html.HtmlOutputLabel.getOndblclick()
javax.faces.component.html.HtmlOutputLink.getOndblclick()
javax.faces.component.html.HtmlPanelGrid.getOndblclick()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOndblclick()
javax.faces.component.html.HtmlSelectManyCheckbox.getOndblclick()
javax.faces.component.html.HtmlSelectManyListbox.getOndblclick()
javax.faces.component.html.HtmlSelectManyMenu.getOndblclick()
javax.faces.component.html.HtmlSelectOneListbox.getOndblclick()
javax.faces.component.html.HtmlSelectOneMenu.getOndblclick()
javax.faces.component.html.HtmlSelectOneRadio.getOndblclick()


Occurences of getOnfocus

getOnfocus occurences:
javax.faces.component.html.HtmlCommandButton.getOnfocus()
javax.faces.component.html.HtmlCommandLink.getOnfocus()
javax.faces.component.html.HtmlInputSecret.getOnfocus()
javax.faces.component.html.HtmlInputText.getOnfocus()
javax.faces.component.html.HtmlInputTextarea.getOnfocus()
javax.faces.component.html.HtmlOutputLabel.getOnfocus()
javax.faces.component.html.HtmlOutputLink.getOnfocus()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOnfocus()
javax.faces.component.html.HtmlSelectManyCheckbox.getOnfocus()
javax.faces.component.html.HtmlSelectManyListbox.getOnfocus()
javax.faces.component.html.HtmlSelectManyMenu.getOnfocus()
javax.faces.component.html.HtmlSelectOneListbox.getOnfocus()
javax.faces.component.html.HtmlSelectOneMenu.getOnfocus()
javax.faces.component.html.HtmlSelectOneRadio.getOnfocus()


Occurences of getOnkeydown

getOnkeydown occurences:
javax.faces.component.html.HtmlCommandButton.getOnkeydown()
javax.faces.component.html.HtmlCommandLink.getOnkeydown()
javax.faces.component.html.HtmlDataTable.getOnkeydown()
javax.faces.component.html.HtmlForm.getOnkeydown()
javax.faces.component.html.HtmlGraphicImage.getOnkeydown()
javax.faces.component.html.HtmlInputSecret.getOnkeydown()
javax.faces.component.html.HtmlInputText.getOnkeydown()
javax.faces.component.html.HtmlInputTextarea.getOnkeydown()
javax.faces.component.html.HtmlOutputLabel.getOnkeydown()
javax.faces.component.html.HtmlOutputLink.getOnkeydown()
javax.faces.component.html.HtmlPanelGrid.getOnkeydown()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOnkeydown()
javax.faces.component.html.HtmlSelectManyCheckbox.getOnkeydown()
javax.faces.component.html.HtmlSelectManyListbox.getOnkeydown()
javax.faces.component.html.HtmlSelectManyMenu.getOnkeydown()
javax.faces.component.html.HtmlSelectOneListbox.getOnkeydown()
javax.faces.component.html.HtmlSelectOneMenu.getOnkeydown()
javax.faces.component.html.HtmlSelectOneRadio.getOnkeydown()


Occurences of getOnkeypress

getOnkeypress occurences:
javax.faces.component.html.HtmlCommandButton.getOnkeypress()
javax.faces.component.html.HtmlCommandLink.getOnkeypress()
javax.faces.component.html.HtmlDataTable.getOnkeypress()
javax.faces.component.html.HtmlForm.getOnkeypress()
javax.faces.component.html.HtmlGraphicImage.getOnkeypress()
javax.faces.component.html.HtmlInputSecret.getOnkeypress()
javax.faces.component.html.HtmlInputText.getOnkeypress()
javax.faces.component.html.HtmlInputTextarea.getOnkeypress()
javax.faces.component.html.HtmlOutputLabel.getOnkeypress()
javax.faces.component.html.HtmlOutputLink.getOnkeypress()
javax.faces.component.html.HtmlPanelGrid.getOnkeypress()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOnkeypress()
javax.faces.component.html.HtmlSelectManyCheckbox.getOnkeypress()
javax.faces.component.html.HtmlSelectManyListbox.getOnkeypress()
javax.faces.component.html.HtmlSelectManyMenu.getOnkeypress()
javax.faces.component.html.HtmlSelectOneListbox.getOnkeypress()
javax.faces.component.html.HtmlSelectOneMenu.getOnkeypress()
javax.faces.component.html.HtmlSelectOneRadio.getOnkeypress()


Occurences of getOnkeyup

getOnkeyup occurences:
javax.faces.component.html.HtmlCommandButton.getOnkeyup()
javax.faces.component.html.HtmlCommandLink.getOnkeyup()
javax.faces.component.html.HtmlDataTable.getOnkeyup()
javax.faces.component.html.HtmlForm.getOnkeyup()
javax.faces.component.html.HtmlGraphicImage.getOnkeyup()
javax.faces.component.html.HtmlInputSecret.getOnkeyup()
javax.faces.component.html.HtmlInputText.getOnkeyup()
javax.faces.component.html.HtmlInputTextarea.getOnkeyup()
javax.faces.component.html.HtmlOutputLabel.getOnkeyup()
javax.faces.component.html.HtmlOutputLink.getOnkeyup()
javax.faces.component.html.HtmlPanelGrid.getOnkeyup()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOnkeyup()
javax.faces.component.html.HtmlSelectManyCheckbox.getOnkeyup()
javax.faces.component.html.HtmlSelectManyListbox.getOnkeyup()
javax.faces.component.html.HtmlSelectManyMenu.getOnkeyup()
javax.faces.component.html.HtmlSelectOneListbox.getOnkeyup()
javax.faces.component.html.HtmlSelectOneMenu.getOnkeyup()
javax.faces.component.html.HtmlSelectOneRadio.getOnkeyup()


Occurences of getOnmousedown

getOnmousedown occurences:
javax.faces.component.html.HtmlCommandButton.getOnmousedown()
javax.faces.component.html.HtmlCommandLink.getOnmousedown()
javax.faces.component.html.HtmlDataTable.getOnmousedown()
javax.faces.component.html.HtmlForm.getOnmousedown()
javax.faces.component.html.HtmlGraphicImage.getOnmousedown()
javax.faces.component.html.HtmlInputSecret.getOnmousedown()
javax.faces.component.html.HtmlInputText.getOnmousedown()
javax.faces.component.html.HtmlInputTextarea.getOnmousedown()
javax.faces.component.html.HtmlOutputLabel.getOnmousedown()
javax.faces.component.html.HtmlOutputLink.getOnmousedown()
javax.faces.component.html.HtmlPanelGrid.getOnmousedown()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOnmousedown()
javax.faces.component.html.HtmlSelectManyCheckbox.getOnmousedown()
javax.faces.component.html.HtmlSelectManyListbox.getOnmousedown()
javax.faces.component.html.HtmlSelectManyMenu.getOnmousedown()
javax.faces.component.html.HtmlSelectOneListbox.getOnmousedown()
javax.faces.component.html.HtmlSelectOneMenu.getOnmousedown()
javax.faces.component.html.HtmlSelectOneRadio.getOnmousedown()


Occurences of getOnmousemove

getOnmousemove occurences:
javax.faces.component.html.HtmlCommandButton.getOnmousemove()
javax.faces.component.html.HtmlCommandLink.getOnmousemove()
javax.faces.component.html.HtmlDataTable.getOnmousemove()
javax.faces.component.html.HtmlForm.getOnmousemove()
javax.faces.component.html.HtmlGraphicImage.getOnmousemove()
javax.faces.component.html.HtmlInputSecret.getOnmousemove()
javax.faces.component.html.HtmlInputText.getOnmousemove()
javax.faces.component.html.HtmlInputTextarea.getOnmousemove()
javax.faces.component.html.HtmlOutputLabel.getOnmousemove()
javax.faces.component.html.HtmlOutputLink.getOnmousemove()
javax.faces.component.html.HtmlPanelGrid.getOnmousemove()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOnmousemove()
javax.faces.component.html.HtmlSelectManyCheckbox.getOnmousemove()
javax.faces.component.html.HtmlSelectManyListbox.getOnmousemove()
javax.faces.component.html.HtmlSelectManyMenu.getOnmousemove()
javax.faces.component.html.HtmlSelectOneListbox.getOnmousemove()
javax.faces.component.html.HtmlSelectOneMenu.getOnmousemove()
javax.faces.component.html.HtmlSelectOneRadio.getOnmousemove()


Occurences of getOnmouseout

getOnmouseout occurences:
javax.faces.component.html.HtmlCommandButton.getOnmouseout()
javax.faces.component.html.HtmlCommandLink.getOnmouseout()
javax.faces.component.html.HtmlDataTable.getOnmouseout()
javax.faces.component.html.HtmlForm.getOnmouseout()
javax.faces.component.html.HtmlGraphicImage.getOnmouseout()
javax.faces.component.html.HtmlInputSecret.getOnmouseout()
javax.faces.component.html.HtmlInputText.getOnmouseout()
javax.faces.component.html.HtmlInputTextarea.getOnmouseout()
javax.faces.component.html.HtmlOutputLabel.getOnmouseout()
javax.faces.component.html.HtmlOutputLink.getOnmouseout()
javax.faces.component.html.HtmlPanelGrid.getOnmouseout()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOnmouseout()
javax.faces.component.html.HtmlSelectManyCheckbox.getOnmouseout()
javax.faces.component.html.HtmlSelectManyListbox.getOnmouseout()
javax.faces.component.html.HtmlSelectManyMenu.getOnmouseout()
javax.faces.component.html.HtmlSelectOneListbox.getOnmouseout()
javax.faces.component.html.HtmlSelectOneMenu.getOnmouseout()
javax.faces.component.html.HtmlSelectOneRadio.getOnmouseout()


Occurences of getOnmouseover

getOnmouseover occurences:
javax.faces.component.html.HtmlCommandButton.getOnmouseover()
javax.faces.component.html.HtmlCommandLink.getOnmouseover()
javax.faces.component.html.HtmlDataTable.getOnmouseover()
javax.faces.component.html.HtmlForm.getOnmouseover()
javax.faces.component.html.HtmlGraphicImage.getOnmouseover()
javax.faces.component.html.HtmlInputSecret.getOnmouseover()
javax.faces.component.html.HtmlInputText.getOnmouseover()
javax.faces.component.html.HtmlInputTextarea.getOnmouseover()
javax.faces.component.html.HtmlOutputLabel.getOnmouseover()
javax.faces.component.html.HtmlOutputLink.getOnmouseover()
javax.faces.component.html.HtmlPanelGrid.getOnmouseover()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOnmouseover()
javax.faces.component.html.HtmlSelectManyCheckbox.getOnmouseover()
javax.faces.component.html.HtmlSelectManyListbox.getOnmouseover()
javax.faces.component.html.HtmlSelectManyMenu.getOnmouseover()
javax.faces.component.html.HtmlSelectOneListbox.getOnmouseover()
javax.faces.component.html.HtmlSelectOneMenu.getOnmouseover()
javax.faces.component.html.HtmlSelectOneRadio.getOnmouseover()


Occurences of getOnmouseup

getOnmouseup occurences:
javax.faces.component.html.HtmlCommandButton.getOnmouseup()
javax.faces.component.html.HtmlCommandLink.getOnmouseup()
javax.faces.component.html.HtmlDataTable.getOnmouseup()
javax.faces.component.html.HtmlForm.getOnmouseup()
javax.faces.component.html.HtmlGraphicImage.getOnmouseup()
javax.faces.component.html.HtmlInputSecret.getOnmouseup()
javax.faces.component.html.HtmlInputText.getOnmouseup()
javax.faces.component.html.HtmlInputTextarea.getOnmouseup()
javax.faces.component.html.HtmlOutputLabel.getOnmouseup()
javax.faces.component.html.HtmlOutputLink.getOnmouseup()
javax.faces.component.html.HtmlPanelGrid.getOnmouseup()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOnmouseup()
javax.faces.component.html.HtmlSelectManyCheckbox.getOnmouseup()
javax.faces.component.html.HtmlSelectManyListbox.getOnmouseup()
javax.faces.component.html.HtmlSelectManyMenu.getOnmouseup()
javax.faces.component.html.HtmlSelectOneListbox.getOnmouseup()
javax.faces.component.html.HtmlSelectOneMenu.getOnmouseup()
javax.faces.component.html.HtmlSelectOneRadio.getOnmouseup()


Occurences of getOnselect

getOnselect occurences:
javax.faces.component.html.HtmlCommandButton.getOnselect()
javax.faces.component.html.HtmlInputSecret.getOnselect()
javax.faces.component.html.HtmlInputText.getOnselect()
javax.faces.component.html.HtmlInputTextarea.getOnselect()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getOnselect()
javax.faces.component.html.HtmlSelectManyCheckbox.getOnselect()
javax.faces.component.html.HtmlSelectManyListbox.getOnselect()
javax.faces.component.html.HtmlSelectManyMenu.getOnselect()
javax.faces.component.html.HtmlSelectOneListbox.getOnselect()
javax.faces.component.html.HtmlSelectOneMenu.getOnselect()
javax.faces.component.html.HtmlSelectOneRadio.getOnselect()


Occurences of getOrdinal

getOrdinal occurences:
javax.faces.application.FacesMessage.Severity.getOrdinal()
javax.faces.event.PhaseId.getOrdinal()


Occurences of getOutputStream

getOutputStream occurences:
javax.activation.DataHandler.getOutputStream()
javax.activation.DataSource.getOutputStream()
javax.activation.FileDataSource.getOutputStream()
javax.activation.URLDataSource.getOutputStream()
javax.mail.internet.MimePartDataSource.getOutputStream()
javax.mail.util.ByteArrayDataSource.getOutputStream()
javax.servlet.ServletResponse.getOutputStream()
javax.servlet.ServletResponseWrapper.getOutputStream()


Occurences of getParameter

getParameter occurences:
javax.activation.MimeType.getParameter(java.lang.String)
javax.mail.internet.ContentDisposition.getParameter(java.lang.String)
javax.mail.internet.ContentType.getParameter(java.lang.String)
javax.servlet.ServletRequest.getParameter(java.lang.String)
javax.servlet.ServletRequestWrapper.getParameter(java.lang.String)


Occurences of getParameterList

getParameterList occurences:
javax.mail.internet.ContentDisposition.getParameterList()
javax.mail.internet.ContentType.getParameterList()


Occurences of getParameterMap

getParameterMap occurences:
javax.servlet.ServletRequest.getParameterMap()
javax.servlet.ServletRequestWrapper.getParameterMap()


Occurences of getParameterNames

getParameterNames occurences:
javax.servlet.ServletRequest.getParameterNames()
javax.servlet.ServletRequestWrapper.getParameterNames()


Occurences of getParameters

getParameters occurences:
javax.activation.MimeType.getParameters()
javax.interceptor.InvocationContext.getParameters()


Occurences of getParameterValues

getParameterValues occurences:
javax.servlet.ServletRequest.getParameterValues(java.lang.String)
javax.servlet.ServletRequestWrapper.getParameterValues(java.lang.String)


Occurences of getParent

getParent occurences:
javax.faces.component.UIComponent.getParent()
javax.faces.component.UIComponentBase.getParent()
javax.faces.webapp.UIComponentClassicTagBase.getParent()
javax.mail.BodyPart.getParent()
javax.mail.Folder.getParent()
javax.mail.Multipart.getParent()
javax.servlet.jsp.tagext.SimpleTag.getParent()
javax.servlet.jsp.tagext.SimpleTagSupport.getParent()
javax.servlet.jsp.tagext.Tag.getParent()
javax.servlet.jsp.tagext.TagAdapter.getParent()
javax.servlet.jsp.tagext.TagSupport.getParent()
javax.xml.registry.infomodel.Concept.getParent()
javax.xml.stream.util.EventReaderDelegate.getParent()
javax.xml.stream.util.StreamReaderDelegate.getParent()


Occurences of getPassword

getPassword occurences:
javax.mail.PasswordAuthentication.getPassword()
javax.mail.URLName.getPassword()
javax.resource.spi.security.PasswordCredential.getPassword()


Occurences of getPasswordAuthentication

getPasswordAuthentication occurences:
javax.mail.Authenticator.getPasswordAuthentication()
javax.mail.Session.getPasswordAuthentication(javax.mail.URLName)


Occurences of getPath

getPath occurences:
javax.servlet.http.Cookie.getPath()
javax.servlet.jsp.tagext.TagFileInfo.getPath()
javax.xml.registry.infomodel.Concept.getPath()


Occurences of getPathInfo

getPathInfo occurences:
javax.servlet.http.HttpServletRequest.getPathInfo()
javax.servlet.http.HttpServletRequestWrapper.getPathInfo()


Occurences of getPathTranslated

getPathTranslated occurences:
javax.servlet.http.HttpServletRequest.getPathTranslated()
javax.servlet.http.HttpServletRequestWrapper.getPathTranslated()


Occurences of getPattern

getPattern occurences:
javax.faces.convert.DateTimeConverter.getPattern()
javax.faces.convert.NumberConverter.getPattern()
javax.mail.search.StringTerm.getPattern()


Occurences of getPayload

getPayload occurences:
javax.xml.ws.LogicalMessage.getPayload()
javax.xml.ws.LogicalMessage.getPayload(javax.xml.bind.JAXBContext)


Occurences of getPendingMessageCount

getPendingMessageCount occurences:
javax.management.j2ee.statistics.JMSEndpointStats.getPendingMessageCount()
javax.management.j2ee.statistics.JMSSessionStats.getPendingMessageCount()


Occurences of getPhaseId

getPhaseId occurences:
javax.faces.event.FacesEvent.getPhaseId()
javax.faces.event.PhaseEvent.getPhaseId()
javax.faces.event.PhaseListener.getPhaseId()


Occurences of getPIData

getPIData occurences:
javax.xml.stream.util.StreamReaderDelegate.getPIData()
javax.xml.stream.XMLStreamReader.getPIData()


Occurences of getPITarget

getPITarget occurences:
javax.xml.stream.util.StreamReaderDelegate.getPITarget()
javax.xml.stream.XMLStreamReader.getPITarget()


Occurences of getPoolSize

getPoolSize occurences:
javax.management.j2ee.statistics.JCAConnectionPoolStats.getPoolSize()
javax.management.j2ee.statistics.JDBCConnectionPoolStats.getPoolSize()


Occurences of getPort

getPort occurences:
javax.mail.URLName.getPort()
javax.xml.rpc.Service.getPort(java.lang.Class)
javax.xml.rpc.Service.getPort(javax.xml.namespace.QName, java.lang.Class)
javax.xml.ws.Service.getPort(java.lang.Class)
javax.xml.ws.Service.getPort(javax.xml.namespace.QName, java.lang.Class)
javax.xml.ws.spi.ServiceDelegate.getPort(java.lang.Class)
javax.xml.ws.spi.ServiceDelegate.getPort(javax.xml.namespace.QName, java.lang.Class)


Occurences of getPorts

getPorts occurences:
javax.xml.rpc.Service.getPorts()
javax.xml.ws.Service.getPorts()
javax.xml.ws.spi.ServiceDelegate.getPorts()


Occurences of getPosition

getPosition occurences:
javax.mail.internet.SharedInputStream.getPosition()
javax.mail.util.SharedByteArrayInputStream.getPosition()
javax.mail.util.SharedFileInputStream.getPosition()


Occurences of getPreferredCommands

getPreferredCommands occurences:
javax.activation.CommandMap.getPreferredCommands(java.lang.String)
javax.activation.CommandMap.getPreferredCommands(java.lang.String, javax.activation.DataSource)
javax.activation.DataHandler.getPreferredCommands()
javax.activation.MailcapCommandMap.getPreferredCommands(java.lang.String)


Occurences of getPrefix

getPrefix occurences:
javax.xml.soap.Name.getPrefix()
javax.xml.stream.events.Namespace.getPrefix()
javax.xml.stream.util.StreamReaderDelegate.getPrefix()
javax.xml.stream.XMLEventWriter.getPrefix(java.lang.String)
javax.xml.stream.XMLStreamReader.getPrefix()
javax.xml.stream.XMLStreamWriter.getPrefix(java.lang.String)


Occurences of getPreviousOut

getPreviousOut occurences:
javax.faces.webapp.UIComponentClassicTagBase.getPreviousOut()
javax.servlet.jsp.tagext.BodyTagSupport.getPreviousOut()


Occurences of getPrimaryKey

getPrimaryKey occurences:
javax.ejb.EJBLocalObject.getPrimaryKey()
javax.ejb.EJBObject.getPrimaryKey()
javax.ejb.EntityContext.getPrimaryKey()


Occurences of getPrimaryType

getPrimaryType occurences:
javax.activation.MimeType.getPrimaryType()
javax.mail.internet.ContentType.getPrimaryType()


Occurences of getProperties

getProperties occurences:
javax.mail.Session.getProperties()
javax.persistence.spi.PersistenceUnitInfo.getProperties()
javax.xml.registry.ConnectionFactory.getProperties()
javax.xml.ws.Endpoint.getProperties()


Occurences of getProperty

getProperty occurences:
javax.mail.Session.getProperty(java.lang.String)
javax.xml.bind.Binder.getProperty(java.lang.String)
javax.xml.bind.helpers.AbstractMarshallerImpl.getProperty(java.lang.String)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.getProperty(java.lang.String)
javax.xml.bind.Marshaller.getProperty(java.lang.String)
javax.xml.bind.Unmarshaller.getProperty(java.lang.String)
javax.xml.bind.Validator.getProperty(java.lang.String)
javax.xml.rpc.Call.getProperty(java.lang.String)
javax.xml.rpc.handler.MessageContext.getProperty(java.lang.String)
javax.xml.soap.SOAPMessage.getProperty(java.lang.String)
javax.xml.stream.util.EventReaderDelegate.getProperty(java.lang.String)
javax.xml.stream.util.StreamReaderDelegate.getProperty(java.lang.String)
javax.xml.stream.XMLEventReader.getProperty(java.lang.String)
javax.xml.stream.XMLInputFactory.getProperty(java.lang.String)
javax.xml.stream.XMLOutputFactory.getProperty(java.lang.String)
javax.xml.stream.XMLStreamReader.getProperty(java.lang.String)
javax.xml.stream.XMLStreamWriter.getProperty(java.lang.String)


Occurences of getPropertyNames

getPropertyNames occurences:
javax.jms.Message.getPropertyNames()
javax.xml.rpc.Call.getPropertyNames()
javax.xml.rpc.handler.MessageContext.getPropertyNames()


Occurences of getProtocol

getProtocol occurences:
javax.mail.Provider.getProtocol()
javax.mail.URLName.getProtocol()
javax.servlet.ServletRequest.getProtocol()
javax.servlet.ServletRequestWrapper.getProtocol()


Occurences of getPublicId

getPublicId occurences:
javax.xml.stream.events.EntityDeclaration.getPublicId()
javax.xml.stream.events.NotationDeclaration.getPublicId()
javax.xml.stream.Location.getPublicId()


Occurences of getQueryString

getQueryString occurences:
javax.servlet.http.HttpServletRequest.getQueryString()
javax.servlet.http.HttpServletRequestWrapper.getQueryString()


Occurences of getQueue

getQueue occurences:
javax.jms.QueueBrowser.getQueue()
javax.jms.QueueReceiver.getQueue()
javax.jms.QueueSender.getQueue()


Occurences of getRawInputStream

getRawInputStream occurences:
javax.mail.internet.MimeBodyPart.getRawInputStream()
javax.mail.internet.MimeMessage.getRawInputStream()


Occurences of getReader

getReader occurences:
javax.servlet.jsp.tagext.BodyContent.getReader()
javax.servlet.ServletRequest.getReader()
javax.servlet.ServletRequestWrapper.getReader()


Occurences of getRealPath

getRealPath occurences:
javax.servlet.ServletContext.getRealPath(java.lang.String)
javax.servlet.ServletRequest.getRealPath(java.lang.String)
javax.servlet.ServletRequestWrapper.getRealPath(java.lang.String)


Occurences of getReceivedDate

getReceivedDate occurences:
javax.mail.internet.MimeMessage.getReceivedDate()
javax.mail.Message.getReceivedDate()


Occurences of getRecipients

getRecipients occurences:
javax.mail.internet.MimeMessage.getRecipients(javax.mail.Message.RecipientType)
javax.mail.Message.getRecipients(javax.mail.Message.RecipientType)


Occurences of getRecipientType

getRecipientType occurences:
javax.mail.search.RecipientStringTerm.getRecipientType()
javax.mail.search.RecipientTerm.getRecipientType()


Occurences of getRef

getRef occurences:
javax.mail.internet.AddressException.getRef()
javax.mail.URLName.getRef()


Occurences of getRegistryObject

getRegistryObject occurences:
javax.xml.registry.infomodel.AuditableEvent.getRegistryObject()
javax.xml.registry.infomodel.ExternalIdentifier.getRegistryObject()
javax.xml.registry.QueryManager.getRegistryObject(java.lang.String)
javax.xml.registry.QueryManager.getRegistryObject(java.lang.String, java.lang.String)


Occurences of getRegistryObjects

getRegistryObjects occurences:
javax.xml.registry.infomodel.RegistryPackage.getRegistryObjects()
javax.xml.registry.QueryManager.getRegistryObjects()
javax.xml.registry.QueryManager.getRegistryObjects(java.lang.String)
javax.xml.registry.QueryManager.getRegistryObjects(java.util.Collection)
javax.xml.registry.QueryManager.getRegistryObjects(java.util.Collection, java.lang.String)


Occurences of getRegistryService

getRegistryService occurences:
javax.xml.registry.Connection.getRegistryService()
javax.xml.registry.LifeCycleManager.getRegistryService()
javax.xml.registry.QueryManager.getRegistryService()


Occurences of getRel

getRel occurences:
javax.faces.component.html.HtmlCommandLink.getRel()
javax.faces.component.html.HtmlOutputLink.getRel()


Occurences of getRemoteAddr

getRemoteAddr occurences:
javax.servlet.ServletRequest.getRemoteAddr()
javax.servlet.ServletRequestWrapper.getRemoteAddr()


Occurences of getRemoteHost

getRemoteHost occurences:
javax.servlet.ServletRequest.getRemoteHost()
javax.servlet.ServletRequestWrapper.getRemoteHost()


Occurences of getRemotePort

getRemotePort occurences:
javax.servlet.ServletRequest.getRemotePort()
javax.servlet.ServletRequestWrapper.getRemotePort()


Occurences of getRemoteUser

getRemoteUser occurences:
javax.faces.context.ExternalContext.getRemoteUser()
javax.servlet.http.HttpServletRequest.getRemoteUser()
javax.servlet.http.HttpServletRequestWrapper.getRemoteUser()


Occurences of getRenderer

getRenderer occurences:
javax.faces.component.UIComponent.getRenderer(javax.faces.context.FacesContext)
javax.faces.component.UIComponentBase.getRenderer(javax.faces.context.FacesContext)
javax.faces.render.RenderKit.getRenderer(java.lang.String, java.lang.String)


Occurences of getRendererType

getRendererType occurences:
javax.faces.component.UIComponent.getRendererType()
javax.faces.component.UIComponentBase.getRendererType()
javax.faces.webapp.UIComponentTagBase.getRendererType()


Occurences of getRenderKit

getRenderKit occurences:
javax.faces.context.FacesContext.getRenderKit()
javax.faces.render.RenderKitFactory.getRenderKit(javax.faces.context.FacesContext, java.lang.String)


Occurences of getRendersChildren

getRendersChildren occurences:
javax.faces.component.UIComponent.getRendersChildren()
javax.faces.component.UIComponentBase.getRendersChildren()
javax.faces.render.Renderer.getRendersChildren()


Occurences of getReplyTo

getReplyTo occurences:
javax.mail.internet.MimeMessage.getReplyTo()
javax.mail.Message.getReplyTo()


Occurences of getRequest

getRequest occurences:
javax.faces.context.ExternalContext.getRequest()
javax.servlet.jsp.PageContext.getRequest()
javax.servlet.ServletRequestWrapper.getRequest()


Occurences of getRequestDispatcher

getRequestDispatcher occurences:
javax.servlet.ServletContext.getRequestDispatcher(java.lang.String)
javax.servlet.ServletRequest.getRequestDispatcher(java.lang.String)
javax.servlet.ServletRequestWrapper.getRequestDispatcher(java.lang.String)


Occurences of getRequestedSessionId

getRequestedSessionId occurences:
javax.servlet.http.HttpServletRequest.getRequestedSessionId()
javax.servlet.http.HttpServletRequestWrapper.getRequestedSessionId()


Occurences of getRequestId

getRequestId occurences:
javax.xml.registry.JAXRException.getRequestId()
javax.xml.registry.JAXRResponse.getRequestId()


Occurences of getRequestURI

getRequestURI occurences:
javax.servlet.http.HttpServletRequest.getRequestURI()
javax.servlet.http.HttpServletRequestWrapper.getRequestURI()
javax.servlet.jsp.ErrorData.getRequestURI()


Occurences of getRequestURL

getRequestURL occurences:
javax.servlet.http.HttpServletRequest.getRequestURL()
javax.servlet.http.HttpServletRequestWrapper.getRequestURL()
javax.servlet.http.HttpUtils.getRequestURL(javax.servlet.http.HttpServletRequest)


Occurences of getResource

getResource occurences:
javax.faces.context.ExternalContext.getResource(java.lang.String)
javax.servlet.ServletContext.getResource(java.lang.String)
javax.transaction.TransactionSynchronizationRegistry.getResource(java.lang.Object)


Occurences of getResourceAsStream

getResourceAsStream occurences:
javax.faces.context.ExternalContext.getResourceAsStream(java.lang.String)
javax.servlet.ServletContext.getResourceAsStream(java.lang.String)


Occurences of getResourcePaths

getResourcePaths occurences:
javax.faces.context.ExternalContext.getResourcePaths(java.lang.String)
javax.servlet.ServletContext.getResourcePaths(java.lang.String)


Occurences of getResourceURL

getResourceURL occurences:
javax.faces.application.ViewHandler.getResourceURL(javax.faces.context.FacesContext, java.lang.String)
javax.faces.application.ViewHandlerWrapper.getResourceURL(javax.faces.context.FacesContext, java.lang.String)


Occurences of getResponse

getResponse occurences:
javax.faces.context.ExternalContext.getResponse()
javax.servlet.jsp.PageContext.getResponse()
javax.servlet.ServletResponseWrapper.getResponse()


Occurences of getResult

getResult occurences:
javax.xml.bind.UnmarshallerHandler.getResult()
javax.xml.bind.util.JAXBResult.getResult()
javax.xml.soap.SAAJResult.getResult()


Occurences of getReturnType

getReturnType occurences:
javax.el.MethodInfo.getReturnType()
javax.xml.rpc.Call.getReturnType()


Occurences of getRev

getRev occurences:
javax.faces.component.html.HtmlCommandLink.getRev()
javax.faces.component.html.HtmlOutputLink.getRev()


Occurences of getRoles

getRoles occurences:
javax.xml.rpc.handler.HandlerChain.getRoles()
javax.xml.rpc.handler.soap.SOAPMessageContext.getRoles()
javax.xml.ws.handler.soap.SOAPMessageContext.getRoles()
javax.xml.ws.soap.SOAPBinding.getRoles()


Occurences of getRollbackOnly

getRollbackOnly occurences:
javax.ejb.EJBContext.getRollbackOnly()
javax.persistence.EntityTransaction.getRollbackOnly()
javax.transaction.TransactionSynchronizationRegistry.getRollbackOnly()


Occurences of getRootCause

getRootCause occurences:
javax.servlet.jsp.el.ELException.getRootCause()
javax.servlet.jsp.JspException.getRootCause()
javax.servlet.ServletException.getRootCause()


Occurences of getRowClasses

getRowClasses occurences:
javax.faces.component.html.HtmlDataTable.getRowClasses()
javax.faces.component.html.HtmlPanelGrid.getRowClasses()


Occurences of getRowCount

getRowCount occurences:
javax.faces.component.UIData.getRowCount()
javax.faces.model.ArrayDataModel.getRowCount()
javax.faces.model.DataModel.getRowCount()
javax.faces.model.ListDataModel.getRowCount()
javax.faces.model.ResultDataModel.getRowCount()
javax.faces.model.ResultSetDataModel.getRowCount()
javax.faces.model.ScalarDataModel.getRowCount()


Occurences of getRowData

getRowData occurences:
javax.faces.component.UIData.getRowData()
javax.faces.model.ArrayDataModel.getRowData()
javax.faces.model.DataModel.getRowData()
javax.faces.model.DataModelEvent.getRowData()
javax.faces.model.ListDataModel.getRowData()
javax.faces.model.ResultDataModel.getRowData()
javax.faces.model.ResultSetDataModel.getRowData()
javax.faces.model.ScalarDataModel.getRowData()


Occurences of getRowIndex

getRowIndex occurences:
javax.faces.component.UIData.getRowIndex()
javax.faces.model.ArrayDataModel.getRowIndex()
javax.faces.model.DataModel.getRowIndex()
javax.faces.model.DataModelEvent.getRowIndex()
javax.faces.model.ListDataModel.getRowIndex()
javax.faces.model.ResultDataModel.getRowIndex()
javax.faces.model.ResultSetDataModel.getRowIndex()
javax.faces.model.ScalarDataModel.getRowIndex()


Occurences of getRows

getRows occurences:
javax.faces.component.html.HtmlInputTextarea.getRows()
javax.faces.component.UIData.getRows()


Occurences of getRules

getRules occurences:
javax.faces.component.html.HtmlDataTable.getRules()
javax.faces.component.html.HtmlPanelGrid.getRules()


Occurences of getSchema

getSchema occurences:
javax.xml.bind.Binder.getSchema()
javax.xml.bind.helpers.AbstractMarshallerImpl.getSchema()
javax.xml.bind.helpers.AbstractUnmarshallerImpl.getSchema()
javax.xml.bind.Marshaller.getSchema()
javax.xml.bind.Unmarshaller.getSchema()


Occurences of getScheme

getScheme occurences:
javax.servlet.ServletRequest.getScheme()
javax.servlet.ServletRequestWrapper.getScheme()


Occurences of getScope

getScope occurences:
javax.servlet.jsp.tagext.TagVariableInfo.getScope()
javax.servlet.jsp.tagext.VariableInfo.getScope()
javax.xml.bind.JAXBElement.getScope()
javax.xml.ws.handler.MessageContext.getScope(java.lang.String)


Occurences of getSentDate

getSentDate occurences:
javax.mail.internet.MimeMessage.getSentDate()
javax.mail.Message.getSentDate()


Occurences of getServerName

getServerName occurences:
javax.servlet.ServletRequest.getServerName()
javax.servlet.ServletRequestWrapper.getServerName()


Occurences of getServerPort

getServerPort occurences:
javax.servlet.ServletRequest.getServerPort()
javax.servlet.ServletRequestWrapper.getServerPort()


Occurences of getServiceName

getServiceName occurences:
javax.xml.rpc.Service.getServiceName()
javax.xml.ws.handler.PortInfo.getServiceName()
javax.xml.ws.Service.getServiceName()
javax.xml.ws.spi.ServiceDelegate.getServiceName()


Occurences of getServlet

getServlet occurences:
javax.servlet.ServletContext.getServlet(java.lang.String)
javax.servlet.UnavailableException.getServlet()


Occurences of getServletConfig

getServletConfig occurences:
javax.faces.webapp.FacesServlet.getServletConfig()
javax.servlet.GenericServlet.getServletConfig()
javax.servlet.jsp.PageContext.getServletConfig()
javax.servlet.Servlet.getServletConfig()


Occurences of getServletContext

getServletContext occurences:
javax.servlet.FilterConfig.getServletContext()
javax.servlet.GenericServlet.getServletContext()
javax.servlet.http.HttpSession.getServletContext()
javax.servlet.jsp.PageContext.getServletContext()
javax.servlet.ServletConfig.getServletContext()
javax.servlet.ServletContextEvent.getServletContext()
javax.servlet.ServletRequestEvent.getServletContext()
javax.xml.rpc.server.ServletEndpointContext.getServletContext()


Occurences of getServletInfo

getServletInfo occurences:
javax.faces.webapp.FacesServlet.getServletInfo()
javax.servlet.GenericServlet.getServletInfo()
javax.servlet.Servlet.getServletInfo()


Occurences of getServletName

getServletName occurences:
javax.servlet.GenericServlet.getServletName()
javax.servlet.jsp.ErrorData.getServletName()
javax.servlet.ServletConfig.getServletName()


Occurences of getServletPath

getServletPath occurences:
javax.servlet.http.HttpServletRequest.getServletPath()
javax.servlet.http.HttpServletRequestWrapper.getServletPath()


Occurences of getSession

getSession occurences:
javax.faces.context.ExternalContext.getSession(boolean)
javax.jms.ServerSession.getSession()
javax.jms.XASession.getSession()
javax.mail.MessageContext.getSession()
javax.servlet.http.HttpServletRequest.getSession()
javax.servlet.http.HttpServletRequest.getSession(boolean)
javax.servlet.http.HttpServletRequestWrapper.getSession()
javax.servlet.http.HttpServletRequestWrapper.getSession(boolean)
javax.servlet.http.HttpSessionBindingEvent.getSession()
javax.servlet.http.HttpSessionContext.getSession(java.lang.String)
javax.servlet.http.HttpSessionEvent.getSession()
javax.servlet.jsp.PageContext.getSession()


Occurences of getSeverity

getSeverity occurences:
javax.faces.application.FacesMessage.getSeverity()
javax.xml.bind.helpers.ValidationEventImpl.getSeverity()
javax.xml.bind.ValidationEvent.getSeverity()


Occurences of getShape

getShape occurences:
javax.faces.component.html.HtmlCommandLink.getShape()
javax.faces.component.html.HtmlOutputLink.getShape()


Occurences of getSize

getSize occurences:
javax.faces.component.html.HtmlInputSecret.getSize()
javax.faces.component.html.HtmlInputText.getSize()
javax.faces.component.html.HtmlSelectManyListbox.getSize()
javax.faces.component.html.HtmlSelectOneListbox.getSize()
javax.mail.internet.MimeBodyPart.getSize()
javax.mail.internet.MimeMessage.getSize()
javax.mail.Part.getSize()
javax.xml.soap.AttachmentPart.getSize()


Occurences of getState

getState occurences:
javax.enterprise.deploy.spi.status.DeploymentStatus.getState()
javax.faces.application.StateManager.SerializedView.getState()
javax.faces.render.ResponseStateManager.getState(javax.faces.context.FacesContext, java.lang.String)


Occurences of getStatus

getStatus occurences:
javax.transaction.Transaction.getStatus()
javax.transaction.TransactionManager.getStatus()
javax.transaction.UserTransaction.getStatus()
javax.xml.registry.infomodel.RegistryEntry.getStatus()
javax.xml.registry.JAXRException.getStatus()
javax.xml.registry.JAXRResponse.getStatus()


Occurences of getStatusCode

getStatusCode occurences:
javax.servlet.jsp.ErrorData.getStatusCode()
javax.xml.ws.http.HTTPException.getStatusCode()


Occurences of getStore

getStore occurences:
javax.mail.Folder.getStore()
javax.mail.Session.getStore()
javax.mail.Session.getStore(java.lang.String)
javax.mail.Session.getStore(javax.mail.Provider)
javax.mail.Session.getStore(javax.mail.URLName)
javax.mail.StoreClosedException.getStore()


Occurences of getString

getString occurences:
javax.jms.MapMessage.getString(java.lang.String)
javax.servlet.jsp.tagext.BodyContent.getString()


Occurences of getStringTable

getStringTable occurences:
javax.enterprise.deploy.shared.ActionType.getStringTable()
javax.enterprise.deploy.shared.CommandType.getStringTable()
javax.enterprise.deploy.shared.DConfigBeanVersionType.getStringTable()
javax.enterprise.deploy.shared.ModuleType.getStringTable()
javax.enterprise.deploy.shared.StateType.getStringTable()


Occurences of getStyle

getStyle occurences:
javax.faces.component.html.HtmlCommandButton.getStyle()
javax.faces.component.html.HtmlCommandLink.getStyle()
javax.faces.component.html.HtmlDataTable.getStyle()
javax.faces.component.html.HtmlForm.getStyle()
javax.faces.component.html.HtmlGraphicImage.getStyle()
javax.faces.component.html.HtmlInputSecret.getStyle()
javax.faces.component.html.HtmlInputText.getStyle()
javax.faces.component.html.HtmlInputTextarea.getStyle()
javax.faces.component.html.HtmlMessage.getStyle()
javax.faces.component.html.HtmlMessages.getStyle()
javax.faces.component.html.HtmlOutputFormat.getStyle()
javax.faces.component.html.HtmlOutputLabel.getStyle()
javax.faces.component.html.HtmlOutputLink.getStyle()
javax.faces.component.html.HtmlOutputText.getStyle()
javax.faces.component.html.HtmlPanelGrid.getStyle()
javax.faces.component.html.HtmlPanelGroup.getStyle()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getStyle()
javax.faces.component.html.HtmlSelectManyCheckbox.getStyle()
javax.faces.component.html.HtmlSelectManyListbox.getStyle()
javax.faces.component.html.HtmlSelectManyMenu.getStyle()
javax.faces.component.html.HtmlSelectOneListbox.getStyle()
javax.faces.component.html.HtmlSelectOneMenu.getStyle()
javax.faces.component.html.HtmlSelectOneRadio.getStyle()


Occurences of getStyleClass

getStyleClass occurences:
javax.faces.component.html.HtmlCommandButton.getStyleClass()
javax.faces.component.html.HtmlCommandLink.getStyleClass()
javax.faces.component.html.HtmlDataTable.getStyleClass()
javax.faces.component.html.HtmlForm.getStyleClass()
javax.faces.component.html.HtmlGraphicImage.getStyleClass()
javax.faces.component.html.HtmlInputSecret.getStyleClass()
javax.faces.component.html.HtmlInputText.getStyleClass()
javax.faces.component.html.HtmlInputTextarea.getStyleClass()
javax.faces.component.html.HtmlMessage.getStyleClass()
javax.faces.component.html.HtmlMessages.getStyleClass()
javax.faces.component.html.HtmlOutputFormat.getStyleClass()
javax.faces.component.html.HtmlOutputLabel.getStyleClass()
javax.faces.component.html.HtmlOutputLink.getStyleClass()
javax.faces.component.html.HtmlOutputText.getStyleClass()
javax.faces.component.html.HtmlPanelGrid.getStyleClass()
javax.faces.component.html.HtmlPanelGroup.getStyleClass()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getStyleClass()
javax.faces.component.html.HtmlSelectManyCheckbox.getStyleClass()
javax.faces.component.html.HtmlSelectManyListbox.getStyleClass()
javax.faces.component.html.HtmlSelectManyMenu.getStyleClass()
javax.faces.component.html.HtmlSelectOneListbox.getStyleClass()
javax.faces.component.html.HtmlSelectOneMenu.getStyleClass()
javax.faces.component.html.HtmlSelectOneRadio.getStyleClass()


Occurences of getSubject

getSubject occurences:
javax.mail.internet.MimeMessage.getSubject()
javax.mail.Message.getSubject()


Occurences of getSubmittedValue

getSubmittedValue occurences:
javax.faces.component.EditableValueHolder.getSubmittedValue()
javax.faces.component.UIInput.getSubmittedValue()


Occurences of getSubType

getSubType occurences:
javax.activation.MimeType.getSubType()
javax.mail.internet.ContentType.getSubType()


Occurences of getSummary

getSummary occurences:
javax.faces.application.FacesMessage.getSummary()
javax.faces.component.html.HtmlDataTable.getSummary()
javax.faces.component.html.HtmlPanelGrid.getSummary()


Occurences of getSupportedLocales

getSupportedLocales occurences:
javax.enterprise.deploy.spi.DeploymentManager.getSupportedLocales()
javax.faces.application.Application.getSupportedLocales()


Occurences of getSupportedMechanismTypes

getSupportedMechanismTypes occurences:
javax.xml.rpc.encoding.DeserializerFactory.getSupportedMechanismTypes()
javax.xml.rpc.encoding.SerializerFactory.getSupportedMechanismTypes()


Occurences of getSystemId

getSystemId occurences:
javax.xml.stream.events.EntityDeclaration.getSystemId()
javax.xml.stream.events.NotationDeclaration.getSystemId()
javax.xml.stream.events.StartDocument.getSystemId()
javax.xml.stream.Location.getSystemId()


Occurences of getTabindex

getTabindex occurences:
javax.faces.component.html.HtmlCommandButton.getTabindex()
javax.faces.component.html.HtmlCommandLink.getTabindex()
javax.faces.component.html.HtmlInputSecret.getTabindex()
javax.faces.component.html.HtmlInputText.getTabindex()
javax.faces.component.html.HtmlInputTextarea.getTabindex()
javax.faces.component.html.HtmlOutputLabel.getTabindex()
javax.faces.component.html.HtmlOutputLink.getTabindex()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getTabindex()
javax.faces.component.html.HtmlSelectManyCheckbox.getTabindex()
javax.faces.component.html.HtmlSelectManyListbox.getTabindex()
javax.faces.component.html.HtmlSelectManyMenu.getTabindex()
javax.faces.component.html.HtmlSelectOneListbox.getTabindex()
javax.faces.component.html.HtmlSelectOneMenu.getTabindex()
javax.faces.component.html.HtmlSelectOneRadio.getTabindex()


Occurences of getTagInfo

getTagInfo occurences:
javax.servlet.jsp.tagext.TagExtraInfo.getTagInfo()
javax.servlet.jsp.tagext.TagFileInfo.getTagInfo()


Occurences of getTarget

getTarget occurences:
javax.enterprise.deploy.spi.TargetModuleID.getTarget()
javax.faces.component.html.HtmlCommandLink.getTarget()
javax.faces.component.html.HtmlForm.getTarget()
javax.faces.component.html.HtmlOutputLink.getTarget()
javax.interceptor.InvocationContext.getTarget()
javax.xml.stream.events.ProcessingInstruction.getTarget()


Occurences of getTelephoneNumbers

getTelephoneNumbers occurences:
javax.xml.registry.infomodel.Organization.getTelephoneNumbers(java.lang.String)
javax.xml.registry.infomodel.User.getTelephoneNumbers(java.lang.String)


Occurences of getTerms

getTerms occurences:
javax.mail.search.AndTerm.getTerms()
javax.mail.search.OrTerm.getTerms()


Occurences of getText

getText occurences:
javax.enterprise.deploy.model.DDBean.getText()
javax.enterprise.deploy.model.DDBean.getText(java.lang.String)
javax.enterprise.deploy.model.DeployableObject.getText(java.lang.String)
javax.enterprise.deploy.model.J2eeApplicationObject.getText(javax.enterprise.deploy.shared.ModuleType, java.lang.String)
javax.jms.TextMessage.getText()
javax.xml.stream.events.Comment.getText()
javax.xml.stream.util.StreamReaderDelegate.getText()
javax.xml.stream.XMLStreamReader.getText()


Occurences of getTextCharacters

getTextCharacters occurences:
javax.xml.stream.util.StreamReaderDelegate.getTextCharacters()
javax.xml.stream.util.StreamReaderDelegate.getTextCharacters(int, char[], int, int)
javax.xml.stream.XMLStreamReader.getTextCharacters()
javax.xml.stream.XMLStreamReader.getTextCharacters(int, char[], int, int)


Occurences of getTextLength

getTextLength occurences:
javax.xml.stream.util.StreamReaderDelegate.getTextLength()
javax.xml.stream.XMLStreamReader.getTextLength()


Occurences of getTextStart

getTextStart occurences:
javax.xml.stream.util.StreamReaderDelegate.getTextStart()
javax.xml.stream.XMLStreamReader.getTextStart()


Occurences of getTitle

getTitle occurences:
javax.faces.component.html.HtmlCommandButton.getTitle()
javax.faces.component.html.HtmlCommandLink.getTitle()
javax.faces.component.html.HtmlDataTable.getTitle()
javax.faces.component.html.HtmlForm.getTitle()
javax.faces.component.html.HtmlGraphicImage.getTitle()
javax.faces.component.html.HtmlInputSecret.getTitle()
javax.faces.component.html.HtmlInputText.getTitle()
javax.faces.component.html.HtmlInputTextarea.getTitle()
javax.faces.component.html.HtmlMessage.getTitle()
javax.faces.component.html.HtmlMessages.getTitle()
javax.faces.component.html.HtmlOutputFormat.getTitle()
javax.faces.component.html.HtmlOutputLabel.getTitle()
javax.faces.component.html.HtmlOutputLink.getTitle()
javax.faces.component.html.HtmlOutputText.getTitle()
javax.faces.component.html.HtmlPanelGrid.getTitle()
javax.faces.component.html.HtmlSelectBooleanCheckbox.getTitle()
javax.faces.component.html.HtmlSelectManyCheckbox.getTitle()
javax.faces.component.html.HtmlSelectManyListbox.getTitle()
javax.faces.component.html.HtmlSelectManyMenu.getTitle()
javax.faces.component.html.HtmlSelectOneListbox.getTitle()
javax.faces.component.html.HtmlSelectOneMenu.getTitle()
javax.faces.component.html.HtmlSelectOneRadio.getTitle()


Occurences of getTopic

getTopic occurences:
javax.jms.TopicPublisher.getTopic()
javax.jms.TopicSubscriber.getTopic()


Occurences of getTransacted

getTransacted occurences:
javax.jms.Session.getTransacted()
javax.jms.XASession.getTransacted()


Occurences of getTransaction

getTransaction occurences:
javax.persistence.EntityManager.getTransaction()
javax.transaction.TransactionManager.getTransaction()


Occurences of getTransactionTimeout

getTransactionTimeout occurences:
javax.resource.spi.work.ExecutionContext.getTransactionTimeout()
javax.transaction.xa.XAResource.getTransactionTimeout()


Occurences of getTransferData

getTransferData occurences:
javax.activation.DataContentHandler.getTransferData(java.awt.datatransfer.DataFlavor, javax.activation.DataSource)
javax.activation.DataHandler.getTransferData(java.awt.datatransfer.DataFlavor)


Occurences of getTransferDataFlavors

getTransferDataFlavors occurences:
javax.activation.DataContentHandler.getTransferDataFlavors()
javax.activation.DataHandler.getTransferDataFlavors()


Occurences of getTransport

getTransport occurences:
javax.mail.Session.getTransport()
javax.mail.Session.getTransport(java.lang.String)
javax.mail.Session.getTransport(javax.mail.Address)
javax.mail.Session.getTransport(javax.mail.Provider)
javax.mail.Session.getTransport(javax.mail.URLName)


Occurences of getTreeStructureToSave

getTreeStructureToSave occurences:
javax.faces.application.StateManager.getTreeStructureToSave(javax.faces.context.FacesContext)
javax.faces.application.StateManagerWrapper.getTreeStructureToSave(javax.faces.context.FacesContext)


Occurences of getType

getType occurences:
javax.el.ArrayELResolver.getType(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.BeanELResolver.getType(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.CompositeELResolver.getType(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.ELResolver.getType(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.ListELResolver.getType(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.MapELResolver.getType(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.ResourceBundleELResolver.getType(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.ValueExpression.getType(javax.el.ELContext)
javax.enterprise.deploy.model.DDBeanRoot.getType()
javax.enterprise.deploy.model.DeployableObject.getType()
javax.faces.component.html.HtmlCommandButton.getType()
javax.faces.component.html.HtmlCommandLink.getType()
javax.faces.component.html.HtmlOutputLink.getType()
javax.faces.convert.DateTimeConverter.getType()
javax.faces.convert.NumberConverter.getType()
javax.faces.el.MethodBinding.getType(javax.faces.context.FacesContext)
javax.faces.el.PropertyResolver.getType(java.lang.Object, int)
javax.faces.el.PropertyResolver.getType(java.lang.Object, java.lang.Object)
javax.faces.el.ValueBinding.getType(javax.faces.context.FacesContext)
javax.mail.Address.getType()
javax.mail.event.ConnectionEvent.getType()
javax.mail.event.FolderEvent.getType()
javax.mail.event.MessageCountEvent.getType()
javax.mail.event.TransportEvent.getType()
javax.mail.Folder.getType()
javax.mail.internet.HeaderTokenizer.Token.getType()
javax.mail.internet.InternetAddress.getType()
javax.mail.internet.NewsAddress.getType()
javax.mail.Provider.getType()
javax.resource.spi.work.WorkEvent.getType()
javax.servlet.jsp.el.ImplicitObjectELResolver.getType(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.servlet.jsp.el.ScopedAttributeELResolver.getType(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.xml.registry.infomodel.EmailAddress.getType()
javax.xml.registry.infomodel.PostalAddress.getType()
javax.xml.registry.infomodel.TelephoneNumber.getType()
javax.xml.registry.infomodel.User.getType()
javax.xml.registry.Query.getType()


Occurences of getURI

getURI occurences:
javax.servlet.jsp.tagext.TagLibraryInfo.getURI()
javax.xml.soap.Name.getURI()


Occurences of getUrl

getUrl occurences:
javax.faces.component.UIGraphic.getUrl()
javax.xml.registry.infomodel.TelephoneNumber.getUrl()
javax.xml.registry.infomodel.User.getUrl()


Occurences of getURL

getURL occurences:
javax.activation.URLDataSource.getURL()
javax.mail.URLName.getURL()
javax.xml.bind.helpers.ValidationEventLocatorImpl.getURL()
javax.xml.bind.ValidationEventLocator.getURL()


Occurences of getURLName

getURLName occurences:
javax.mail.Folder.getURLName()
javax.mail.Service.getURLName()


Occurences of getUserName

getUserName occurences:
javax.mail.PasswordAuthentication.getUserName()
javax.resource.cci.ConnectionMetaData.getUserName()
javax.resource.spi.ManagedConnectionMetaData.getUserName()
javax.resource.spi.security.PasswordCredential.getUserName()


Occurences of getUserPrincipal

getUserPrincipal occurences:
javax.faces.context.ExternalContext.getUserPrincipal()
javax.servlet.http.HttpServletRequest.getUserPrincipal()
javax.servlet.http.HttpServletRequestWrapper.getUserPrincipal()
javax.xml.rpc.server.ServletEndpointContext.getUserPrincipal()
javax.xml.ws.WebServiceContext.getUserPrincipal()


Occurences of getUseTime

getUseTime occurences:
javax.management.j2ee.statistics.JCAConnectionStats.getUseTime()
javax.management.j2ee.statistics.JDBCConnectionStats.getUseTime()


Occurences of getValidator

getValidator occurences:
javax.faces.component.EditableValueHolder.getValidator()
javax.faces.component.UIInput.getValidator()


Occurences of getValidators

getValidators occurences:
javax.faces.component.EditableValueHolder.getValidators()
javax.faces.component.UIInput.getValidators()


Occurences of getValidSentAddresses

getValidSentAddresses occurences:
javax.mail.event.TransportEvent.getValidSentAddresses()
javax.mail.SendFailedException.getValidSentAddresses()


Occurences of getValidUnsentAddresses

getValidUnsentAddresses occurences:
javax.mail.event.TransportEvent.getValidUnsentAddresses()
javax.mail.SendFailedException.getValidUnsentAddresses()


Occurences of getValue

getValue occurences:
javax.el.ArrayELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.BeanELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.CompositeELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.ELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.ListELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.MapELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.ResourceBundleELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.ValueExpression.getValue(javax.el.ELContext)
javax.enterprise.deploy.shared.ActionType.getValue()
javax.enterprise.deploy.shared.CommandType.getValue()
javax.enterprise.deploy.shared.DConfigBeanVersionType.getValue()
javax.enterprise.deploy.shared.ModuleType.getValue()
javax.enterprise.deploy.shared.StateType.getValue()
javax.faces.component.UICommand.getValue()
javax.faces.component.UIData.getValue()
javax.faces.component.UIGraphic.getValue()
javax.faces.component.UIOutput.getValue()
javax.faces.component.UIParameter.getValue()
javax.faces.component.UISelectItem.getValue()
javax.faces.component.UISelectItems.getValue()
javax.faces.component.ValueHolder.getValue()
javax.faces.el.PropertyResolver.getValue(java.lang.Object, int)
javax.faces.el.PropertyResolver.getValue(java.lang.Object, java.lang.Object)
javax.faces.el.ValueBinding.getValue(javax.faces.context.FacesContext)
javax.faces.model.SelectItem.getValue()
javax.mail.Header.getValue()
javax.mail.internet.HeaderTokenizer.Token.getValue()
javax.mail.internet.InternetHeaders.InternetHeader.getValue()
javax.servlet.http.Cookie.getValue()
javax.servlet.http.HttpSession.getValue(java.lang.String)
javax.servlet.http.HttpSessionBindingEvent.getValue()
javax.servlet.jsp.el.ImplicitObjectELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.servlet.jsp.el.ScopedAttributeELResolver.getValue(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.servlet.jsp.tagext.TagSupport.getValue(java.lang.String)
javax.servlet.ServletContextAttributeEvent.getValue()
javax.servlet.ServletRequestAttributeEvent.getValue()
javax.xml.bind.JAXBElement.getValue()
javax.xml.bind.JAXBIntrospector.getValue(java.lang.Object)
javax.xml.registry.infomodel.Classification.getValue()
javax.xml.registry.infomodel.Concept.getValue()
javax.xml.registry.infomodel.ExternalIdentifier.getValue()
javax.xml.registry.infomodel.InternationalString.getValue()
javax.xml.registry.infomodel.InternationalString.getValue(java.util.Locale)
javax.xml.registry.infomodel.LocalizedString.getValue()
javax.xml.soap.MimeHeader.getValue()
javax.xml.soap.Node.getValue()
javax.xml.stream.events.Attribute.getValue()


Occurences of getValueBinding

getValueBinding occurences:
javax.faces.component.UIComponent.getValueBinding(java.lang.String)
javax.faces.component.UIComponentBase.getValueBinding(java.lang.String)
javax.faces.component.UIGraphic.getValueBinding(java.lang.String)
javax.faces.component.UISelectBoolean.getValueBinding(java.lang.String)
javax.faces.component.UISelectMany.getValueBinding(java.lang.String)


Occurences of getValueChangeListener

getValueChangeListener occurences:
javax.faces.component.EditableValueHolder.getValueChangeListener()
javax.faces.component.UIInput.getValueChangeListener()


Occurences of getValueChangeListeners

getValueChangeListeners occurences:
javax.faces.component.EditableValueHolder.getValueChangeListeners()
javax.faces.component.UIInput.getValueChangeListeners()


Occurences of getValueExpression

getValueExpression occurences:
javax.faces.component.UIComponent.getValueExpression(java.lang.String)
javax.faces.component.UIComponentBase.getValueExpression(java.lang.String)
javax.faces.component.UIGraphic.getValueExpression(java.lang.String)
javax.faces.component.UISelectBoolean.getValueExpression(java.lang.String)
javax.faces.component.UISelectMany.getValueExpression(java.lang.String)


Occurences of getValues

getValues occurences:
javax.servlet.jsp.tagext.TagSupport.getValues()
javax.xml.registry.infomodel.Slot.getValues()


Occurences of getVariableInfo

getVariableInfo occurences:
javax.servlet.jsp.tagext.TagExtraInfo.getVariableInfo(javax.servlet.jsp.tagext.TagData)
javax.servlet.jsp.tagext.TagInfo.getVariableInfo(javax.servlet.jsp.tagext.TagData)


Occurences of getVariableResolver

getVariableResolver occurences:
javax.faces.application.Application.getVariableResolver()
javax.servlet.jsp.JspContext.getVariableResolver()


Occurences of getVersion

getVersion occurences:
javax.mail.Provider.getVersion()
javax.servlet.http.Cookie.getVersion()
javax.xml.registry.CapabilityProfile.getVersion()
javax.xml.stream.events.StartDocument.getVersion()
javax.xml.stream.util.StreamReaderDelegate.getVersion()
javax.xml.stream.XMLStreamReader.getVersion()


Occurences of getViewId

getViewId occurences:
javax.faces.application.ViewExpiredException.getViewId()
javax.faces.component.UIViewRoot.getViewId()


Occurences of getWaitingThreadCount

getWaitingThreadCount occurences:
javax.management.j2ee.statistics.JCAConnectionPoolStats.getWaitingThreadCount()
javax.management.j2ee.statistics.JDBCConnectionPoolStats.getWaitingThreadCount()


Occurences of getWaitTime

getWaitTime occurences:
javax.management.j2ee.statistics.JCAConnectionStats.getWaitTime()
javax.management.j2ee.statistics.JDBCConnectionStats.getWaitTime()


Occurences of getWarnClass

getWarnClass occurences:
javax.faces.component.html.HtmlMessage.getWarnClass()
javax.faces.component.html.HtmlMessages.getWarnClass()


Occurences of getWarnStyle

getWarnStyle occurences:
javax.faces.component.html.HtmlMessage.getWarnStyle()
javax.faces.component.html.HtmlMessages.getWarnStyle()


Occurences of getWidth

getWidth occurences:
javax.faces.component.html.HtmlDataTable.getWidth()
javax.faces.component.html.HtmlGraphicImage.getWidth()
javax.faces.component.html.HtmlPanelGrid.getWidth()


Occurences of getWrapped

getWrapped occurences:
javax.faces.application.StateManagerWrapper.getWrapped()
javax.faces.application.ViewHandlerWrapper.getWrapped()
javax.faces.context.ResponseWriterWrapper.getWrapped()


Occurences of getWrappedData

getWrappedData occurences:
javax.faces.model.ArrayDataModel.getWrappedData()
javax.faces.model.DataModel.getWrappedData()
javax.faces.model.ListDataModel.getWrappedData()
javax.faces.model.ResultDataModel.getWrappedData()
javax.faces.model.ResultSetDataModel.getWrappedData()
javax.faces.model.ScalarDataModel.getWrappedData()


Occurences of getWriter

getWriter occurences:
javax.servlet.ServletResponse.getWriter()
javax.servlet.ServletResponseWrapper.getWriter()


Occurences of getWSDLDocumentLocation

getWSDLDocumentLocation occurences:
javax.xml.rpc.Service.getWSDLDocumentLocation()
javax.xml.ws.Service.getWSDLDocumentLocation()
javax.xml.ws.spi.ServiceDelegate.getWSDLDocumentLocation()


Occurences of getXAResource

getXAResource occurences:
javax.jms.XASession.getXAResource()
javax.resource.spi.ManagedConnection.getXAResource()


Occurences of getXpath

getXpath occurences:
javax.enterprise.deploy.model.DDBean.getXpath()
javax.enterprise.deploy.model.DDBeanRoot.getXpath()


Occurences of handleEvent

handleEvent occurences:
javax.xml.bind.helpers.DefaultValidationEventHandler.handleEvent(javax.xml.bind.ValidationEvent)
javax.xml.bind.util.ValidationEventCollector.handleEvent(javax.xml.bind.ValidationEvent)
javax.xml.bind.ValidationEventHandler.handleEvent(javax.xml.bind.ValidationEvent)


Occurences of handleFault

handleFault occurences:
javax.xml.rpc.handler.GenericHandler.handleFault(javax.xml.rpc.handler.MessageContext)
javax.xml.rpc.handler.Handler.handleFault(javax.xml.rpc.handler.MessageContext)
javax.xml.rpc.handler.HandlerChain.handleFault(javax.xml.rpc.handler.MessageContext)
javax.xml.ws.handler.Handler.handleFault(C)
javax.xml.ws.handler.Handler.handleFault(javax.xml.ws.handler.MessageContext)


Occurences of handleMessage

handleMessage occurences:
javax.xml.ws.handler.Handler.handleMessage(C)
javax.xml.ws.handler.Handler.handleMessage(javax.xml.ws.handler.MessageContext)


Occurences of handlePageException

handlePageException occurences:
javax.servlet.jsp.PageContext.handlePageException(java.lang.Exception)
javax.servlet.jsp.PageContext.handlePageException(java.lang.Throwable)


Occurences of handler

handler occurences:
javax.xml.rpc.handler
javax.xml.ws.handler


Occurences of Handler

Handler occurences:
javax.xml.rpc.handler.Handler
javax.xml.ws.handler.Handler


Occurences of HandlerChain

HandlerChain occurences:
javax.jws.HandlerChain
javax.xml.rpc.handler.HandlerChain


Occurences of handleRequest

handleRequest occurences:
javax.xml.rpc.handler.GenericHandler.handleRequest(javax.xml.rpc.handler.MessageContext)
javax.xml.rpc.handler.Handler.handleRequest(javax.xml.rpc.handler.MessageContext)
javax.xml.rpc.handler.HandlerChain.handleRequest(javax.xml.rpc.handler.MessageContext)


Occurences of handleResponse

handleResponse occurences:
javax.xml.rpc.handler.GenericHandler.handleResponse(javax.xml.rpc.handler.MessageContext)
javax.xml.rpc.handler.Handler.handleResponse(javax.xml.rpc.handler.MessageContext)
javax.xml.rpc.handler.HandlerChain.handleResponse(javax.xml.rpc.handler.MessageContext)
javax.xml.ws.AsyncHandler.handleResponse(javax.xml.ws.Response)


Occurences of HandlerInfo (constructors)

HandlerInfo (constructors) occurences:
javax.xml.rpc.handler.HandlerInfo()
javax.xml.rpc.handler.HandlerInfo(java.lang.Class, java.util.Map, javax.xml.namespace.QName[])


Occurences of hasBinding

hasBinding occurences:
javax.faces.webapp.UIComponentClassicTagBase.hasBinding()
javax.faces.webapp.UIComponentELTag.hasBinding()
javax.faces.webapp.UIComponentTag.hasBinding()


Occurences of hashCode

hashCode occurences:
javax.el.Expression.hashCode()
javax.faces.validator.DoubleRangeValidator.hashCode()
javax.faces.validator.LengthValidator.hashCode()
javax.faces.validator.LongRangeValidator.hashCode()
javax.mail.Flags.hashCode()
javax.mail.internet.InternetAddress.hashCode()
javax.mail.internet.NewsAddress.hashCode()
javax.mail.search.AddressTerm.hashCode()
javax.mail.search.AndTerm.hashCode()
javax.mail.search.ComparisonTerm.hashCode()
javax.mail.search.DateTerm.hashCode()
javax.mail.search.FlagTerm.hashCode()
javax.mail.search.HeaderTerm.hashCode()
javax.mail.search.IntegerComparisonTerm.hashCode()
javax.mail.search.NotTerm.hashCode()
javax.mail.search.OrTerm.hashCode()
javax.mail.search.RecipientStringTerm.hashCode()
javax.mail.search.RecipientTerm.hashCode()
javax.mail.search.StringTerm.hashCode()
javax.mail.URLName.hashCode()
javax.resource.cci.Record.hashCode()
javax.resource.spi.ConnectionRequestInfo.hashCode()
javax.resource.spi.ManagedConnectionFactory.hashCode()
javax.resource.spi.security.GenericCredential.hashCode()
javax.resource.spi.security.PasswordCredential.hashCode()
javax.security.jacc.EJBMethodPermission.hashCode()
javax.security.jacc.EJBRoleRefPermission.hashCode()
javax.security.jacc.WebResourcePermission.hashCode()
javax.security.jacc.WebRoleRefPermission.hashCode()
javax.security.jacc.WebUserDataPermission.hashCode()


Occurences of hasName

hasName occurences:
javax.xml.stream.util.StreamReaderDelegate.hasName()
javax.xml.stream.XMLStreamReader.hasName()


Occurences of hasNext

hasNext occurences:
javax.xml.stream.util.EventReaderDelegate.hasNext()
javax.xml.stream.util.StreamReaderDelegate.hasNext()
javax.xml.stream.XMLEventReader.hasNext()
javax.xml.stream.XMLStreamReader.hasNext()


Occurences of hasText

hasText occurences:
javax.xml.stream.util.StreamReaderDelegate.hasText()
javax.xml.stream.XMLStreamReader.hasText()


Occurences of header

header occurences:
javax.jws.WebParam.header()
javax.jws.WebResult.header()


Occurences of headers

headers occurences:
javax.jws.soap.SOAPMessageHandler.headers()
javax.mail.internet.headers
javax.mail.internet.headers
javax.mail.internet.headers


Occurences of HeaderTokenizer (constructors)

HeaderTokenizer (constructors) occurences:
javax.mail.internet.HeaderTokenizer(java.lang.String)
javax.mail.internet.HeaderTokenizer(java.lang.String, java.lang.String)
javax.mail.internet.HeaderTokenizer(java.lang.String, java.lang.String, boolean)


Occurences of HeuristicCommitException (constructors)

HeuristicCommitException (constructors) occurences:
javax.transaction.HeuristicCommitException()
javax.transaction.HeuristicCommitException(java.lang.String)


Occurences of HeuristicMixedException (constructors)

HeuristicMixedException (constructors) occurences:
javax.transaction.HeuristicMixedException()
javax.transaction.HeuristicMixedException(java.lang.String)


Occurences of HeuristicRollbackException (constructors)

HeuristicRollbackException (constructors) occurences:
javax.transaction.HeuristicRollbackException()
javax.transaction.HeuristicRollbackException(java.lang.String)


Occurences of hints

hints occurences:
javax.persistence.NamedNativeQuery.hints()
javax.persistence.NamedQuery.hints()


Occurences of Holder

Holder occurences:
javax.xml.rpc.holders.Holder
javax.xml.ws.Holder


Occurences of Holder (constructors)

Holder (constructors) occurences:
javax.xml.ws.Holder()
javax.xml.ws.Holder(java.lang.Object)
javax.xml.ws.Holder(T)


Occurences of http

http occurences:
javax.servlet.http
javax.xml.ws.http


Occurences of HttpSessionBindingEvent (constructors)

HttpSessionBindingEvent (constructors) occurences:
javax.servlet.http.HttpSessionBindingEvent(javax.servlet.http.HttpSession, java.lang.String)
javax.servlet.http.HttpSessionBindingEvent(javax.servlet.http.HttpSession, java.lang.String, java.lang.Object)


Occurences of id

id occurences:
javax.resource.spi.id
javax.servlet.jsp.tagext.id


Occurences of IllegalStateException

IllegalStateException occurences:
javax.jms.IllegalStateException
javax.resource.spi.IllegalStateException


Occurences of IllegalStateException (constructors)

IllegalStateException (constructors) occurences:
javax.jms.IllegalStateException(java.lang.String)
javax.jms.IllegalStateException(java.lang.String, java.lang.String)
javax.resource.spi.IllegalStateException()
javax.resource.spi.IllegalStateException(java.lang.String)
javax.resource.spi.IllegalStateException(java.lang.String, java.lang.String)
javax.resource.spi.IllegalStateException(java.lang.String, java.lang.Throwable)
javax.resource.spi.IllegalStateException(java.lang.Throwable)


Occurences of IllegalWriteException (constructors)

IllegalWriteException (constructors) occurences:
javax.mail.IllegalWriteException()
javax.mail.IllegalWriteException(java.lang.String)


Occurences of implies

implies occurences:
javax.security.jacc.EJBMethodPermission.implies(java.security.Permission)
javax.security.jacc.EJBRoleRefPermission.implies(java.security.Permission)
javax.security.jacc.WebResourcePermission.implies(java.security.Permission)
javax.security.jacc.WebRoleRefPermission.implies(java.security.Permission)
javax.security.jacc.WebUserDataPermission.implies(java.security.Permission)


Occurences of IN

IN occurences:
javax.jws.IN
javax.xml.rpc.IN


Occurences of include

include occurences:
javax.servlet.jsp.PageContext.include(java.lang.String)
javax.servlet.jsp.PageContext.include(java.lang.String, boolean)
javax.servlet.RequestDispatcher.include(javax.servlet.ServletRequest, javax.servlet.ServletResponse)


Occurences of init

init occurences:
javax.faces.webapp.FacesServlet.init(javax.servlet.ServletConfig)
javax.servlet.Filter.init(javax.servlet.FilterConfig)
javax.servlet.GenericServlet.init()
javax.servlet.GenericServlet.init(javax.servlet.ServletConfig)
javax.servlet.Servlet.init(javax.servlet.ServletConfig)
javax.xml.rpc.handler.GenericHandler.init(javax.xml.rpc.handler.HandlerInfo)
javax.xml.rpc.handler.Handler.init(javax.xml.rpc.handler.HandlerInfo)
javax.xml.rpc.handler.HandlerChain.init(java.util.Map)
javax.xml.rpc.server.ServiceLifecycle.init(java.lang.Object)


Occurences of initCause

initCause occurences:
javax.xml.registry.JAXRException.initCause(java.lang.Throwable)
javax.xml.soap.SOAPException.initCause(java.lang.Throwable)


Occurences of initialValue

initialValue occurences:
javax.persistence.SequenceGenerator.initialValue()
javax.persistence.TableGenerator.initialValue()


Occurences of initView

initView occurences:
javax.faces.application.ViewHandler.initView(javax.faces.context.FacesContext)
javax.faces.application.ViewHandlerWrapper.initView(javax.faces.context.FacesContext)


Occurences of INOUT

INOUT occurences:
javax.jws.INOUT
javax.xml.rpc.INOUT


Occurences of insertable

insertable occurences:
javax.persistence.Column.insertable()
javax.persistence.JoinColumn.insertable()


Occurences of inService

inService occurences:
javax.security.jacc.PolicyConfiguration.inService()
javax.security.jacc.PolicyConfigurationFactory.inService(java.lang.String)


Occurences of IntegerWrapperHolder (constructors)

IntegerWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.IntegerWrapperHolder()
javax.xml.rpc.holders.IntegerWrapperHolder(java.lang.Integer)


Occurences of InternetAddress (constructors)

InternetAddress (constructors) occurences:
javax.mail.internet.InternetAddress()
javax.mail.internet.InternetAddress(java.lang.String)
javax.mail.internet.InternetAddress(java.lang.String, boolean)
javax.mail.internet.InternetAddress(java.lang.String, java.lang.String)
javax.mail.internet.InternetAddress(java.lang.String, java.lang.String, java.lang.String)


Occurences of InternetHeaders (constructors)

InternetHeaders (constructors) occurences:
javax.mail.internet.InternetHeaders()
javax.mail.internet.InternetHeaders(java.io.InputStream)


Occurences of InternetHeaders.InternetHeader (constructors)

InternetHeaders.InternetHeader (constructors) occurences:
javax.mail.internet.InternetHeaders.InternetHeader(java.lang.String)
javax.mail.internet.InternetHeaders.InternetHeader(java.lang.String, java.lang.String)


Occurences of IntHolder (constructors)

IntHolder (constructors) occurences:
javax.xml.rpc.holders.IntHolder()
javax.xml.rpc.holders.IntHolder(int)


Occurences of invalid

invalid occurences:
javax.mail.event.invalid
javax.mail.invalid


Occurences of InvalidClientIDException (constructors)

InvalidClientIDException (constructors) occurences:
javax.jms.InvalidClientIDException(java.lang.String)
javax.jms.InvalidClientIDException(java.lang.String, java.lang.String)


Occurences of InvalidDestinationException (constructors)

InvalidDestinationException (constructors) occurences:
javax.jms.InvalidDestinationException(java.lang.String)
javax.jms.InvalidDestinationException(java.lang.String, java.lang.String)


Occurences of InvalidPropertyException (constructors)

InvalidPropertyException (constructors) occurences:
javax.resource.spi.InvalidPropertyException()
javax.resource.spi.InvalidPropertyException(java.lang.String)
javax.resource.spi.InvalidPropertyException(java.lang.String, java.lang.String)
javax.resource.spi.InvalidPropertyException(java.lang.String, java.lang.Throwable)
javax.resource.spi.InvalidPropertyException(java.lang.Throwable)


Occurences of InvalidRequestException (constructors)

InvalidRequestException (constructors) occurences:
javax.xml.registry.InvalidRequestException()
javax.xml.registry.InvalidRequestException(java.lang.String)
javax.xml.registry.InvalidRequestException(java.lang.String, java.lang.Throwable)
javax.xml.registry.InvalidRequestException(java.lang.Throwable)


Occurences of InvalidSelectorException (constructors)

InvalidSelectorException (constructors) occurences:
javax.jms.InvalidSelectorException(java.lang.String)
javax.jms.InvalidSelectorException(java.lang.String, java.lang.String)


Occurences of InvalidTransactionException (constructors)

InvalidTransactionException (constructors) occurences:
javax.transaction.InvalidTransactionException()
javax.transaction.InvalidTransactionException(java.lang.String)


Occurences of INVALID_MESSAGE_ID

INVALID_MESSAGE_ID occurences:
javax.faces.component.INVALID_MESSAGE_ID
javax.faces.component.INVALID_MESSAGE_ID


Occurences of invoke

invoke occurences:
javax.el.MethodExpression.invoke(javax.el.ELContext, java.lang.Object[])
javax.faces.el.MethodBinding.invoke(javax.faces.context.FacesContext, java.lang.Object[])
javax.management.j2ee.Management.invoke(javax.management.ObjectName, java.lang.String, java.lang.Object[], java.lang.String[])
javax.servlet.jsp.tagext.JspFragment.invoke(java.io.Writer)
javax.xml.rpc.Call.invoke(java.lang.Object[])
javax.xml.rpc.Call.invoke(javax.xml.namespace.QName, java.lang.Object[])
javax.xml.ws.Dispatch.invoke(java.lang.Object)
javax.xml.ws.Dispatch.invoke(T)
javax.xml.ws.Provider.invoke(java.lang.Object)
javax.xml.ws.Provider.invoke(T)


Occurences of invokeAsync

invokeAsync occurences:
javax.xml.ws.Dispatch.invokeAsync(java.lang.Object)
javax.xml.ws.Dispatch.invokeAsync(java.lang.Object,javax.xml.ws.AsyncHandler)
javax.xml.ws.Dispatch.invokeAsync(T)
javax.xml.ws.Dispatch.invokeAsync(T, javax.xml.ws.AsyncHandler)


Occurences of invokeOnComponent

invokeOnComponent occurences:
javax.faces.component.UIComponent.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback)
javax.faces.component.UIComponentBase.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback)
javax.faces.component.UIData.invokeOnComponent(javax.faces.context.FacesContext, java.lang.String, javax.faces.component.ContextCallback)


Occurences of invokeOneWay

invokeOneWay occurences:
javax.xml.rpc.Call.invokeOneWay(java.lang.Object[])
javax.xml.ws.Dispatch.invokeOneWay(java.lang.Object)
javax.xml.ws.Dispatch.invokeOneWay(T)


Occurences of isAppropriateListener

isAppropriateListener occurences:
javax.faces.event.ActionEvent.isAppropriateListener(javax.faces.event.FacesListener)
javax.faces.event.FacesEvent.isAppropriateListener(javax.faces.event.FacesListener)
javax.faces.event.ValueChangeEvent.isAppropriateListener(javax.faces.event.FacesListener)


Occurences of isAttributeSpecified

isAttributeSpecified occurences:
javax.xml.stream.util.StreamReaderDelegate.isAttributeSpecified(int)
javax.xml.stream.XMLStreamReader.isAttributeSpecified(int)


Occurences of isAvailable

isAvailable occurences:
javax.xml.registry.JAXRException.isAvailable()
javax.xml.registry.JAXRResponse.isAvailable()


Occurences of isCallerInRole

isCallerInRole occurences:
javax.ejb.EJBContext.isCallerInRole(java.lang.String)
javax.ejb.EJBContext.isCallerInRole(java.security.Identity)


Occurences of isCharacters

isCharacters occurences:
javax.xml.stream.events.XMLEvent.isCharacters()
javax.xml.stream.util.StreamReaderDelegate.isCharacters()
javax.xml.stream.XMLStreamReader.isCharacters()


Occurences of isCommitted

isCommitted occurences:
javax.servlet.ServletResponse.isCommitted()
javax.servlet.ServletResponseWrapper.isCommitted()


Occurences of isDisabled

isDisabled occurences:
javax.faces.component.html.HtmlCommandButton.isDisabled()
javax.faces.component.html.HtmlCommandLink.isDisabled()
javax.faces.component.html.HtmlInputSecret.isDisabled()
javax.faces.component.html.HtmlInputText.isDisabled()
javax.faces.component.html.HtmlInputTextarea.isDisabled()
javax.faces.component.html.HtmlOutputLink.isDisabled()
javax.faces.component.html.HtmlSelectBooleanCheckbox.isDisabled()
javax.faces.component.html.HtmlSelectManyCheckbox.isDisabled()
javax.faces.component.html.HtmlSelectManyListbox.isDisabled()
javax.faces.component.html.HtmlSelectManyMenu.isDisabled()
javax.faces.component.html.HtmlSelectOneListbox.isDisabled()
javax.faces.component.html.HtmlSelectOneMenu.isDisabled()
javax.faces.component.html.HtmlSelectOneRadio.isDisabled()
javax.faces.model.SelectItem.isDisabled()


Occurences of isEndElement

isEndElement occurences:
javax.xml.stream.events.XMLEvent.isEndElement()
javax.xml.stream.util.StreamReaderDelegate.isEndElement()
javax.xml.stream.XMLStreamReader.isEndElement()


Occurences of isEscape

isEscape occurences:
javax.faces.component.html.HtmlOutputFormat.isEscape()
javax.faces.component.html.HtmlOutputLabel.isEscape()
javax.faces.component.html.HtmlOutputText.isEscape()
javax.faces.model.SelectItem.isEscape()


Occurences of isExternal

isExternal occurences:
javax.xml.registry.infomodel.Classification.isExternal()
javax.xml.registry.infomodel.ClassificationScheme.isExternal()


Occurences of isFragment

isFragment occurences:
javax.servlet.jsp.tagext.TagAttributeInfo.isFragment()
javax.xml.bind.helpers.AbstractMarshallerImpl.isFragment()


Occurences of isIdentical

isIdentical occurences:
javax.ejb.EJBLocalObject.isIdentical(javax.ejb.EJBLocalObject)
javax.ejb.EJBObject.isIdentical(javax.ejb.EJBObject)


Occurences of isImmediate

isImmediate occurences:
javax.faces.component.ActionSource.isImmediate()
javax.faces.component.EditableValueHolder.isImmediate()
javax.faces.component.UICommand.isImmediate()
javax.faces.component.UIInput.isImmediate()


Occurences of isLocalValueSet

isLocalValueSet occurences:
javax.faces.component.EditableValueHolder.isLocalValueSet()
javax.faces.component.UIInput.isLocalValueSet()


Occurences of isMimeType

isMimeType occurences:
javax.mail.internet.MimeBodyPart.isMimeType(java.lang.String)
javax.mail.internet.MimeMessage.isMimeType(java.lang.String)
javax.mail.Part.isMimeType(java.lang.String)


Occurences of isOpen

isOpen occurences:
javax.mail.Folder.isOpen()
javax.persistence.EntityManager.isOpen()
javax.persistence.EntityManagerFactory.isOpen()


Occurences of isPropertySupported

isPropertySupported occurences:
javax.xml.stream.XMLInputFactory.isPropertySupported(java.lang.String)
javax.xml.stream.XMLOutputFactory.isPropertySupported(java.lang.String)


Occurences of isReadOnly

isReadOnly occurences:
javax.el.ArrayELResolver.isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.BeanELResolver.isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.BeanELResolver.BeanProperty.isReadOnly()
javax.el.CompositeELResolver.isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.ELResolver.isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.ListELResolver.isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.MapELResolver.isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.ResourceBundleELResolver.isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.el.ValueExpression.isReadOnly(javax.el.ELContext)
javax.faces.el.PropertyResolver.isReadOnly(java.lang.Object, int)
javax.faces.el.PropertyResolver.isReadOnly(java.lang.Object, java.lang.Object)
javax.faces.el.ValueBinding.isReadOnly(javax.faces.context.FacesContext)
javax.servlet.jsp.el.ImplicitObjectELResolver.isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object)
javax.servlet.jsp.el.ScopedAttributeELResolver.isReadOnly(javax.el.ELContext, java.lang.Object, java.lang.Object)


Occurences of isReadonly

isReadonly occurences:
javax.faces.component.html.HtmlCommandButton.isReadonly()
javax.faces.component.html.HtmlInputSecret.isReadonly()
javax.faces.component.html.HtmlInputText.isReadonly()
javax.faces.component.html.HtmlInputTextarea.isReadonly()
javax.faces.component.html.HtmlSelectBooleanCheckbox.isReadonly()
javax.faces.component.html.HtmlSelectManyCheckbox.isReadonly()
javax.faces.component.html.HtmlSelectManyListbox.isReadonly()
javax.faces.component.html.HtmlSelectManyMenu.isReadonly()
javax.faces.component.html.HtmlSelectOneListbox.isReadonly()
javax.faces.component.html.HtmlSelectOneMenu.isReadonly()
javax.faces.component.html.HtmlSelectOneRadio.isReadonly()


Occurences of isRegistered

isRegistered occurences:
javax.management.j2ee.Management.isRegistered(javax.management.ObjectName)
javax.xml.rpc.encoding.TypeMapping.isRegistered(java.lang.Class, javax.xml.namespace.QName)


Occurences of isRendered

isRendered occurences:
javax.faces.component.UIComponent.isRendered()
javax.faces.component.UIComponentBase.isRendered()


Occurences of isRequestedSessionIdFromCookie

isRequestedSessionIdFromCookie occurences:
javax.servlet.http.HttpServletRequest.isRequestedSessionIdFromCookie()
javax.servlet.http.HttpServletRequestWrapper.isRequestedSessionIdFromCookie()


Occurences of isRequestedSessionIdFromURL

isRequestedSessionIdFromURL occurences:
javax.servlet.http.HttpServletRequest.isRequestedSessionIdFromURL()
javax.servlet.http.HttpServletRequestWrapper.isRequestedSessionIdFromURL()


Occurences of isRequestedSessionIdFromUrl

isRequestedSessionIdFromUrl occurences:
javax.servlet.http.HttpServletRequest.isRequestedSessionIdFromUrl()
javax.servlet.http.HttpServletRequestWrapper.isRequestedSessionIdFromUrl()


Occurences of isRequestedSessionIdValid

isRequestedSessionIdValid occurences:
javax.servlet.http.HttpServletRequest.isRequestedSessionIdValid()
javax.servlet.http.HttpServletRequestWrapper.isRequestedSessionIdValid()


Occurences of isRequired

isRequired occurences:
javax.faces.component.EditableValueHolder.isRequired()
javax.faces.component.UIInput.isRequired()
javax.servlet.jsp.tagext.TagAttributeInfo.isRequired()


Occurences of isRowAvailable

isRowAvailable occurences:
javax.faces.component.UIData.isRowAvailable()
javax.faces.model.ArrayDataModel.isRowAvailable()
javax.faces.model.DataModel.isRowAvailable()
javax.faces.model.ListDataModel.isRowAvailable()
javax.faces.model.ResultDataModel.isRowAvailable()
javax.faces.model.ResultSetDataModel.isRowAvailable()
javax.faces.model.ScalarDataModel.isRowAvailable()


Occurences of isSavingStateInClient

isSavingStateInClient occurences:
javax.faces.application.StateManager.isSavingStateInClient(javax.faces.context.FacesContext)
javax.faces.application.StateManagerWrapper.isSavingStateInClient(javax.faces.context.FacesContext)


Occurences of isSecure

isSecure occurences:
javax.servlet.ServletRequest.isSecure()
javax.servlet.ServletRequestWrapper.isSecure()


Occurences of isSet

isSet occurences:
javax.mail.internet.MimeMessage.isSet(javax.mail.Flags.Flag)
javax.mail.Message.isSet(javax.mail.Flags.Flag)


Occurences of isShowDetail

isShowDetail occurences:
javax.faces.component.UIMessage.isShowDetail()
javax.faces.component.UIMessages.isShowDetail()


Occurences of isShowSummary

isShowSummary occurences:
javax.faces.component.UIMessage.isShowSummary()
javax.faces.component.UIMessages.isShowSummary()


Occurences of isStandalone

isStandalone occurences:
javax.xml.stream.events.StartDocument.isStandalone()
javax.xml.stream.util.StreamReaderDelegate.isStandalone()
javax.xml.stream.XMLStreamReader.isStandalone()


Occurences of isStartElement

isStartElement occurences:
javax.xml.stream.events.XMLEvent.isStartElement()
javax.xml.stream.util.StreamReaderDelegate.isStartElement()
javax.xml.stream.XMLStreamReader.isStartElement()


Occurences of isTooltip

isTooltip occurences:
javax.faces.component.html.HtmlMessage.isTooltip()
javax.faces.component.html.HtmlMessages.isTooltip()


Occurences of isTransient

isTransient occurences:
javax.faces.component.StateHolder.isTransient()
javax.faces.component.UIComponentBase.isTransient()
javax.faces.convert.DateTimeConverter.isTransient()
javax.faces.convert.EnumConverter.isTransient()
javax.faces.convert.NumberConverter.isTransient()
javax.faces.event.MethodExpressionActionListener.isTransient()
javax.faces.event.MethodExpressionValueChangeListener.isTransient()
javax.faces.validator.DoubleRangeValidator.isTransient()
javax.faces.validator.LengthValidator.isTransient()
javax.faces.validator.LongRangeValidator.isTransient()
javax.faces.validator.MethodExpressionValidator.isTransient()


Occurences of isUserInRole

isUserInRole occurences:
javax.faces.context.ExternalContext.isUserInRole(java.lang.String)
javax.servlet.http.HttpServletRequest.isUserInRole(java.lang.String)
javax.servlet.http.HttpServletRequestWrapper.isUserInRole(java.lang.String)
javax.xml.rpc.server.ServletEndpointContext.isUserInRole(java.lang.String)
javax.xml.ws.WebServiceContext.isUserInRole(java.lang.String)


Occurences of isValid

isValid occurences:
javax.faces.component.EditableValueHolder.isValid()
javax.faces.component.UIInput.isValid()
javax.servlet.jsp.tagext.TagExtraInfo.isValid(javax.servlet.jsp.tagext.TagData)
javax.servlet.jsp.tagext.TagInfo.isValid(javax.servlet.jsp.tagext.TagData)


Occurences of isValidating

isValidating occurences:
javax.xml.bind.helpers.AbstractUnmarshallerImpl.isValidating()
javax.xml.bind.Unmarshaller.isValidating()


Occurences of isWhiteSpace

isWhiteSpace occurences:
javax.xml.bind.annotation.adapters.CollapsedStringAdapter.isWhiteSpace(char)
javax.xml.stream.events.Characters.isWhiteSpace()
javax.xml.stream.util.StreamReaderDelegate.isWhiteSpace()
javax.xml.stream.XMLStreamReader.isWhiteSpace()


Occurences of isXOPPackage

isXOPPackage occurences:
javax.xml.bind.attachment.AttachmentMarshaller.isXOPPackage()
javax.xml.bind.attachment.AttachmentUnmarshaller.isXOPPackage()


Occurences of JAXBElement (constructors)

JAXBElement (constructors) occurences:
javax.xml.bind.JAXBElement(javax.xml.namespace.QName, java.lang.Class, java.lang.Class, T)
javax.xml.bind.JAXBElement(javax.xml.namespace.QName, java.lang.Class, T)
javax.xml.bind.JAXBElement(javax.xml.namespace.QName,java.lang.Class,java.lang.Class,java.lang.Object)
javax.xml.bind.JAXBElement(javax.xml.namespace.QName,java.lang.Class,java.lang.Object)


Occurences of JAXBException (constructors)

JAXBException (constructors) occurences:
javax.xml.bind.JAXBException(java.lang.String)
javax.xml.bind.JAXBException(java.lang.String, java.lang.String)
javax.xml.bind.JAXBException(java.lang.String, java.lang.String, java.lang.Throwable)
javax.xml.bind.JAXBException(java.lang.String, java.lang.Throwable)
javax.xml.bind.JAXBException(java.lang.Throwable)


Occurences of JAXBResult (constructors)

JAXBResult (constructors) occurences:
javax.xml.bind.util.JAXBResult(javax.xml.bind.JAXBContext)
javax.xml.bind.util.JAXBResult(javax.xml.bind.Unmarshaller)


Occurences of JAXBSource (constructors)

JAXBSource (constructors) occurences:
javax.xml.bind.util.JAXBSource(javax.xml.bind.JAXBContext, java.lang.Object)
javax.xml.bind.util.JAXBSource(javax.xml.bind.Marshaller, java.lang.Object)


Occurences of JAXRException (constructors)

JAXRException (constructors) occurences:
javax.xml.registry.JAXRException()
javax.xml.registry.JAXRException(java.lang.String)
javax.xml.registry.JAXRException(java.lang.String, java.lang.Throwable)
javax.xml.registry.JAXRException(java.lang.Throwable)


Occurences of JAXRPCException (constructors)

JAXRPCException (constructors) occurences:
javax.xml.rpc.JAXRPCException()
javax.xml.rpc.JAXRPCException(java.lang.String)
javax.xml.rpc.JAXRPCException(java.lang.String, java.lang.Throwable)
javax.xml.rpc.JAXRPCException(java.lang.Throwable)


Occurences of JMSException (constructors)

JMSException (constructors) occurences:
javax.jms.JMSException(java.lang.String)
javax.jms.JMSException(java.lang.String, java.lang.String)


Occurences of JMSSecurityException (constructors)

JMSSecurityException (constructors) occurences:
javax.jms.JMSSecurityException(java.lang.String)
javax.jms.JMSSecurityException(java.lang.String, java.lang.String)


Occurences of joinColumns

joinColumns occurences:
javax.persistence.AssociationOverride.joinColumns()
javax.persistence.JoinTable.joinColumns()


Occurences of JspException (constructors)

JspException (constructors) occurences:
javax.servlet.jsp.JspException()
javax.servlet.jsp.JspException(java.lang.String)
javax.servlet.jsp.JspException(java.lang.String, java.lang.Throwable)
javax.servlet.jsp.JspException(java.lang.Throwable)


Occurences of JspTagException (constructors)

JspTagException (constructors) occurences:
javax.servlet.jsp.JspTagException()
javax.servlet.jsp.JspTagException(java.lang.String)
javax.servlet.jsp.JspTagException(java.lang.String, java.lang.Throwable)
javax.servlet.jsp.JspTagException(java.lang.Throwable)


Occurences of length

length occurences:
javax.persistence.Column.length()
javax.persistence.DiscriminatorColumn.length()


Occurences of LengthValidator (constructors)

LengthValidator (constructors) occurences:
javax.faces.validator.LengthValidator()
javax.faces.validator.LengthValidator(int)
javax.faces.validator.LengthValidator(int, int)


Occurences of list

list occurences:
javax.mail.Folder.list()
javax.mail.Folder.list(java.lang.String)


Occurences of ListDataModel (constructors)

ListDataModel (constructors) occurences:
javax.faces.model.ListDataModel()
javax.faces.model.ListDataModel(java.util.List)


Occurences of ListELResolver (constructors)

ListELResolver (constructors) occurences:
javax.el.ListELResolver()
javax.el.ListELResolver(boolean)


Occurences of listSubscribed

listSubscribed occurences:
javax.mail.Folder.listSubscribed()
javax.mail.Folder.listSubscribed(java.lang.String)


Occurences of loadService

loadService occurences:
javax.xml.rpc.ServiceFactory.loadService(java.lang.Class)
javax.xml.rpc.ServiceFactory.loadService(java.net.URL, java.lang.Class, java.util.Properties)
javax.xml.rpc.ServiceFactory.loadService(java.net.URL, javax.xml.namespace.QName, java.util.Properties)


Occurences of localName

localName occurences:
javax.xml.ws.RequestWrapper.localName()
javax.xml.ws.ResponseWrapper.localName()


Occurences of LocalTransaction

LocalTransaction occurences:
javax.resource.cci.LocalTransaction
javax.resource.spi.LocalTransaction


Occurences of LocalTransactionException (constructors)

LocalTransactionException (constructors) occurences:
javax.resource.spi.LocalTransactionException()
javax.resource.spi.LocalTransactionException(java.lang.String)
javax.resource.spi.LocalTransactionException(java.lang.String, java.lang.String)
javax.resource.spi.LocalTransactionException(java.lang.String, java.lang.Throwable)
javax.resource.spi.LocalTransactionException(java.lang.Throwable)


Occurences of log

log occurences:
javax.faces.context.ExternalContext.log(java.lang.String)
javax.faces.context.ExternalContext.log(java.lang.String, java.lang.Throwable)
javax.faces.webapp.log
javax.servlet.GenericServlet.log(java.lang.String)
javax.servlet.GenericServlet.log(java.lang.String, java.lang.Throwable)
javax.servlet.ServletContext.log(java.lang.Exception, java.lang.String)
javax.servlet.ServletContext.log(java.lang.String)
javax.servlet.ServletContext.log(java.lang.String, java.lang.Throwable)


Occurences of LongHolder (constructors)

LongHolder (constructors) occurences:
javax.xml.rpc.holders.LongHolder()
javax.xml.rpc.holders.LongHolder(long)


Occurences of LongRangeValidator (constructors)

LongRangeValidator (constructors) occurences:
javax.faces.validator.LongRangeValidator()
javax.faces.validator.LongRangeValidator(long)
javax.faces.validator.LongRangeValidator(long, long)


Occurences of LongWrapperHolder (constructors)

LongWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.LongWrapperHolder()
javax.xml.rpc.holders.LongWrapperHolder(java.lang.Long)


Occurences of MailcapCommandMap (constructors)

MailcapCommandMap (constructors) occurences:
javax.activation.MailcapCommandMap()
javax.activation.MailcapCommandMap(java.io.InputStream)
javax.activation.MailcapCommandMap(java.lang.String)


Occurences of MapELResolver (constructors)

MapELResolver (constructors) occurences:
javax.el.MapELResolver()
javax.el.MapELResolver(boolean)


Occurences of mappedBy

mappedBy occurences:
javax.persistence.ManyToMany.mappedBy()
javax.persistence.OneToMany.mappedBy()
javax.persistence.OneToOne.mappedBy()


Occurences of mappedName

mappedName occurences:
javax.annotation.Resource.mappedName()
javax.ejb.EJB.mappedName()
javax.ejb.MessageDriven.mappedName()
javax.ejb.Stateful.mappedName()
javax.ejb.Stateless.mappedName()
javax.xml.ws.WebServiceRef.mappedName()


Occurences of marshal

marshal occurences:
javax.xml.bind.annotation.adapters.CollapsedStringAdapter.marshal(java.lang.String)
javax.xml.bind.annotation.adapters.HexBinaryAdapter.marshal(byte[])
javax.xml.bind.annotation.adapters.NormalizedStringAdapter.marshal(java.lang.String)
javax.xml.bind.annotation.adapters.XmlAdapter.marshal(BoundType)
javax.xml.bind.annotation.adapters.XmlAdapter.marshal(java.lang.Object)
javax.xml.bind.annotation.DomHandler.marshal(ElementT, javax.xml.bind.ValidationEventHandler)
javax.xml.bind.annotation.DomHandler.marshal(java.lang.Object,javax.xml.bind.ValidationEventHandler)
javax.xml.bind.annotation.W3CDomHandler.marshal(org.w3c.dom.Element, javax.xml.bind.ValidationEventHandler)
javax.xml.bind.Binder.marshal(java.lang.Object, XmlNode)
javax.xml.bind.Binder.marshal(java.lang.Object,java.lang.Object)
javax.xml.bind.helpers.AbstractMarshallerImpl.marshal(java.lang.Object, java.io.OutputStream)
javax.xml.bind.helpers.AbstractMarshallerImpl.marshal(java.lang.Object, java.io.Writer)
javax.xml.bind.helpers.AbstractMarshallerImpl.marshal(java.lang.Object, javax.xml.stream.XMLEventWriter)
javax.xml.bind.helpers.AbstractMarshallerImpl.marshal(java.lang.Object, javax.xml.stream.XMLStreamWriter)
javax.xml.bind.helpers.AbstractMarshallerImpl.marshal(java.lang.Object, org.w3c.dom.Node)
javax.xml.bind.helpers.AbstractMarshallerImpl.marshal(java.lang.Object, org.xml.sax.ContentHandler)
javax.xml.bind.Marshaller.marshal(java.lang.Object, java.io.OutputStream)
javax.xml.bind.Marshaller.marshal(java.lang.Object, java.io.Writer)
javax.xml.bind.Marshaller.marshal(java.lang.Object, javax.xml.stream.XMLEventWriter)
javax.xml.bind.Marshaller.marshal(java.lang.Object, javax.xml.stream.XMLStreamWriter)
javax.xml.bind.Marshaller.marshal(java.lang.Object, javax.xml.transform.Result)
javax.xml.bind.Marshaller.marshal(java.lang.Object, org.w3c.dom.Node)
javax.xml.bind.Marshaller.marshal(java.lang.Object, org.xml.sax.ContentHandler)


Occurences of MarshalException (constructors)

MarshalException (constructors) occurences:
javax.xml.bind.MarshalException(java.lang.String)
javax.xml.bind.MarshalException(java.lang.String, java.lang.String)
javax.xml.bind.MarshalException(java.lang.String, java.lang.String, java.lang.Throwable)
javax.xml.bind.MarshalException(java.lang.String, java.lang.Throwable)
javax.xml.bind.MarshalException(java.lang.Throwable)


Occurences of match

match occurences:
javax.activation.MimeType.match(java.lang.String)
javax.activation.MimeType.match(javax.activation.MimeType)
javax.mail.internet.ContentType.match(java.lang.String)
javax.mail.internet.ContentType.match(javax.mail.internet.ContentType)
javax.mail.Message.match(javax.mail.search.SearchTerm)
javax.mail.search.AddressStringTerm.match(javax.mail.Address)
javax.mail.search.AddressTerm.match(javax.mail.Address)
javax.mail.search.AndTerm.match(javax.mail.Message)
javax.mail.search.BodyTerm.match(javax.mail.Message)
javax.mail.search.DateTerm.match(java.util.Date)
javax.mail.search.FlagTerm.match(javax.mail.Message)
javax.mail.search.FromStringTerm.match(javax.mail.Message)
javax.mail.search.FromTerm.match(javax.mail.Message)
javax.mail.search.HeaderTerm.match(javax.mail.Message)
javax.mail.search.IntegerComparisonTerm.match(int)
javax.mail.search.MessageIDTerm.match(javax.mail.Message)
javax.mail.search.MessageNumberTerm.match(javax.mail.Message)
javax.mail.search.NotTerm.match(javax.mail.Message)
javax.mail.search.OrTerm.match(javax.mail.Message)
javax.mail.search.ReceivedDateTerm.match(javax.mail.Message)
javax.mail.search.RecipientStringTerm.match(javax.mail.Message)
javax.mail.search.RecipientTerm.match(javax.mail.Message)
javax.mail.search.SearchTerm.match(javax.mail.Message)
javax.mail.search.SentDateTerm.match(javax.mail.Message)
javax.mail.search.SizeTerm.match(javax.mail.Message)
javax.mail.search.StringTerm.match(java.lang.String)
javax.mail.search.SubjectTerm.match(javax.mail.Message)


Occurences of MAXIMUM_MESSAGE_ID

MAXIMUM_MESSAGE_ID occurences:
javax.faces.validator.MAXIMUM_MESSAGE_ID
javax.faces.validator.MAXIMUM_MESSAGE_ID
javax.faces.validator.MAXIMUM_MESSAGE_ID


Occurences of merge

merge occurences:
javax.persistence.EntityManager.merge(java.lang.Object)
javax.persistence.EntityManager.merge(T)


Occurences of Message

Message occurences:
javax.jms.Message
javax.mail.Message


Occurences of Message (constructors)

Message (constructors) occurences:
javax.mail.Message()
javax.mail.Message(javax.mail.Folder, int)
javax.mail.Message(javax.mail.Session)


Occurences of MessageContext

MessageContext occurences:
javax.mail.MessageContext
javax.xml.rpc.handler.MessageContext
javax.xml.ws.handler.MessageContext


Occurences of messageDelivered

messageDelivered occurences:
javax.mail.event.TransportAdapter.messageDelivered(javax.mail.event.TransportEvent)
javax.mail.event.TransportListener.messageDelivered(javax.mail.event.TransportEvent)


Occurences of MessageEOFException (constructors)

MessageEOFException (constructors) occurences:
javax.jms.MessageEOFException(java.lang.String)
javax.jms.MessageEOFException(java.lang.String, java.lang.String)


Occurences of MessageFormatException (constructors)

MessageFormatException (constructors) occurences:
javax.jms.MessageFormatException(java.lang.String)
javax.jms.MessageFormatException(java.lang.String, java.lang.String)


Occurences of MessageListener

MessageListener occurences:
javax.jms.MessageListener
javax.resource.cci.MessageListener


Occurences of messageNotDelivered

messageNotDelivered occurences:
javax.mail.event.TransportAdapter.messageNotDelivered(javax.mail.event.TransportEvent)
javax.mail.event.TransportListener.messageNotDelivered(javax.mail.event.TransportEvent)


Occurences of MessageNotReadableException (constructors)

MessageNotReadableException (constructors) occurences:
javax.jms.MessageNotReadableException(java.lang.String)
javax.jms.MessageNotReadableException(java.lang.String, java.lang.String)


Occurences of MessageNotWriteableException (constructors)

MessageNotWriteableException (constructors) occurences:
javax.jms.MessageNotWriteableException(java.lang.String)
javax.jms.MessageNotWriteableException(java.lang.String, java.lang.String)


Occurences of messagePartiallyDelivered

messagePartiallyDelivered occurences:
javax.mail.event.TransportAdapter.messagePartiallyDelivered(javax.mail.event.TransportEvent)
javax.mail.event.TransportListener.messagePartiallyDelivered(javax.mail.event.TransportEvent)


Occurences of MessageRemovedException (constructors)

MessageRemovedException (constructors) occurences:
javax.mail.MessageRemovedException()
javax.mail.MessageRemovedException(java.lang.String)


Occurences of messagesAdded

messagesAdded occurences:
javax.mail.event.MessageCountAdapter.messagesAdded(javax.mail.event.MessageCountEvent)
javax.mail.event.MessageCountListener.messagesAdded(javax.mail.event.MessageCountEvent)


Occurences of messagesRemoved

messagesRemoved occurences:
javax.mail.event.MessageCountAdapter.messagesRemoved(javax.mail.event.MessageCountEvent)
javax.mail.event.MessageCountListener.messagesRemoved(javax.mail.event.MessageCountEvent)


Occurences of MessagingException (constructors)

MessagingException (constructors) occurences:
javax.mail.MessagingException()
javax.mail.MessagingException(java.lang.String)
javax.mail.MessagingException(java.lang.String, java.lang.Exception)


Occurences of MethodExpressionActionListener (constructors)

MethodExpressionActionListener (constructors) occurences:
javax.faces.event.MethodExpressionActionListener()
javax.faces.event.MethodExpressionActionListener(javax.el.MethodExpression)


Occurences of MethodExpressionValidator (constructors)

MethodExpressionValidator (constructors) occurences:
javax.faces.validator.MethodExpressionValidator()
javax.faces.validator.MethodExpressionValidator(javax.el.MethodExpression)


Occurences of MethodExpressionValueChangeListener (constructors)

MethodExpressionValueChangeListener (constructors) occurences:
javax.faces.event.MethodExpressionValueChangeListener()
javax.faces.event.MethodExpressionValueChangeListener(javax.el.MethodExpression)


Occurences of MethodNotFoundException

MethodNotFoundException occurences:
javax.el.MethodNotFoundException
javax.faces.el.MethodNotFoundException


Occurences of MethodNotFoundException (constructors)

MethodNotFoundException (constructors) occurences:
javax.el.MethodNotFoundException()
javax.el.MethodNotFoundException(java.lang.String)
javax.el.MethodNotFoundException(java.lang.String, java.lang.Throwable)
javax.el.MethodNotFoundException(java.lang.Throwable)
javax.faces.el.MethodNotFoundException()
javax.faces.el.MethodNotFoundException(java.lang.String)
javax.faces.el.MethodNotFoundException(java.lang.String, java.lang.Throwable)
javax.faces.el.MethodNotFoundException(java.lang.Throwable)


Occurences of MethodNotSupportedException (constructors)

MethodNotSupportedException (constructors) occurences:
javax.mail.MethodNotSupportedException()
javax.mail.MethodNotSupportedException(java.lang.String)


Occurences of MimeBodyPart (constructors)

MimeBodyPart (constructors) occurences:
javax.mail.internet.MimeBodyPart()
javax.mail.internet.MimeBodyPart(java.io.InputStream)
javax.mail.internet.MimeBodyPart(javax.mail.internet.InternetHeaders, byte[])


Occurences of MimeMessage (constructors)

MimeMessage (constructors) occurences:
javax.mail.internet.MimeMessage(javax.mail.Folder, int)
javax.mail.internet.MimeMessage(javax.mail.Folder, java.io.InputStream, int)
javax.mail.internet.MimeMessage(javax.mail.Folder, javax.mail.internet.InternetHeaders, byte[], int)
javax.mail.internet.MimeMessage(javax.mail.internet.MimeMessage)
javax.mail.internet.MimeMessage(javax.mail.Session)
javax.mail.internet.MimeMessage(javax.mail.Session, java.io.InputStream)


Occurences of MimeMultipart (constructors)

MimeMultipart (constructors) occurences:
javax.mail.internet.MimeMultipart()
javax.mail.internet.MimeMultipart(java.lang.String)
javax.mail.internet.MimeMultipart(javax.activation.DataSource)


Occurences of MimeType (constructors)

MimeType (constructors) occurences:
javax.activation.MimeType()
javax.activation.MimeType(java.lang.String)
javax.activation.MimeType(java.lang.String, java.lang.String)


Occurences of MimeTypeParameterList (constructors)

MimeTypeParameterList (constructors) occurences:
javax.activation.MimeTypeParameterList()
javax.activation.MimeTypeParameterList(java.lang.String)


Occurences of MimeTypeParseException (constructors)

MimeTypeParseException (constructors) occurences:
javax.activation.MimeTypeParseException()
javax.activation.MimeTypeParseException(java.lang.String)


Occurences of MimetypesFileTypeMap (constructors)

MimetypesFileTypeMap (constructors) occurences:
javax.activation.MimetypesFileTypeMap()
javax.activation.MimetypesFileTypeMap(java.io.InputStream)
javax.activation.MimetypesFileTypeMap(java.lang.String)


Occurences of MINIMUM_MESSAGE_ID

MINIMUM_MESSAGE_ID occurences:
javax.faces.validator.MINIMUM_MESSAGE_ID
javax.faces.validator.MINIMUM_MESSAGE_ID
javax.faces.validator.MINIMUM_MESSAGE_ID


Occurences of mode

mode occurences:
javax.jws.WebParam.mode()
javax.mail.mode


Occurences of model

model occurences:
javax.enterprise.deploy.model
javax.faces.model


Occurences of msg

msg occurences:
javax.mail.event.msg
javax.mail.event.msg


Occurences of name

name occurences:
javax.annotation.Resource.name()
javax.ejb.EJB.name()
javax.ejb.MessageDriven.name()
javax.ejb.Stateful.name()
javax.ejb.Stateless.name()
javax.jws.HandlerChain.name()
javax.jws.soap.InitParam.name()
javax.jws.soap.SOAPMessageHandler.name()
javax.jws.WebParam.name()
javax.jws.WebResult.name()
javax.jws.WebService.name()
javax.mail.name
javax.mail.name
javax.persistence.AssociationOverride.name()
javax.persistence.AttributeOverride.name()
javax.persistence.Column.name()
javax.persistence.ColumnResult.name()
javax.persistence.DiscriminatorColumn.name()
javax.persistence.Entity.name()
javax.persistence.FieldResult.name()
javax.persistence.JoinColumn.name()
javax.persistence.JoinTable.name()
javax.persistence.MapKey.name()
javax.persistence.NamedNativeQuery.name()
javax.persistence.NamedQuery.name()
javax.persistence.PersistenceContext.name()
javax.persistence.PersistenceProperty.name()
javax.persistence.PersistenceUnit.name()
javax.persistence.PrimaryKeyJoinColumn.name()
javax.persistence.QueryHint.name()
javax.persistence.SecondaryTable.name()
javax.persistence.SequenceGenerator.name()
javax.persistence.SqlResultSetMapping.name()
javax.persistence.Table.name()
javax.persistence.TableGenerator.name()
javax.xml.bind.annotation.XmlAttribute.name()
javax.xml.bind.annotation.XmlElement.name()
javax.xml.bind.annotation.XmlElementDecl.name()
javax.xml.bind.annotation.XmlElementRef.name()
javax.xml.bind.annotation.XmlElementWrapper.name()
javax.xml.bind.annotation.XmlRootElement.name()
javax.xml.bind.annotation.XmlSchemaType.name()
javax.xml.bind.annotation.XmlType.name()
javax.xml.bind.name
javax.xml.ws.WebEndpoint.name()
javax.xml.ws.WebFault.name()
javax.xml.ws.WebServiceClient.name()
javax.xml.ws.WebServiceRef.name()


Occurences of namespace

namespace occurences:
javax.xml.bind.annotation.XmlAttribute.namespace()
javax.xml.bind.annotation.XmlElement.namespace()
javax.xml.bind.annotation.XmlElementDecl.namespace()
javax.xml.bind.annotation.XmlElementRef.namespace()
javax.xml.bind.annotation.XmlElementWrapper.namespace()
javax.xml.bind.annotation.XmlRootElement.namespace()
javax.xml.bind.annotation.XmlSchema.namespace()
javax.xml.bind.annotation.XmlSchemaType.namespace()
javax.xml.bind.annotation.XmlType.namespace()


Occurences of nested_class_summary

nested_class_summary occurences:
javax.el.nested_class_summary
javax.faces.application.nested_class_summary
javax.faces.application.nested_class_summary
javax.faces.application.nested_class_summary
javax.mail.internet.nested_class_summary
javax.mail.internet.nested_class_summary
javax.mail.internet.nested_class_summary
javax.mail.internet.nested_class_summary
javax.mail.nested_class_summary
javax.mail.nested_class_summary
javax.mail.nested_class_summary
javax.mail.nested_class_summary
javax.mail.nested_class_summary
javax.mail.nested_class_summary
javax.resource.cci.nested_class_summary
javax.xml.bind.helpers.nested_class_summary
javax.xml.bind.helpers.nested_class_summary
javax.xml.bind.nested_class_summary
javax.xml.bind.nested_class_summary
javax.xml.bind.nested_class_summary
javax.xml.ws.handler.nested_class_summary
javax.xml.ws.handler.nested_class_summary
javax.xml.ws.handler.soap.nested_class_summary
javax.xml.ws.nested_class_summary


Occurences of newInstance

newInstance occurences:
javax.xml.bind.JAXBContext.newInstance(java.lang.Class...)
javax.xml.bind.JAXBContext.newInstance(java.lang.Class[], java.util.Map)
javax.xml.bind.JAXBContext.newInstance(java.lang.String)
javax.xml.bind.JAXBContext.newInstance(java.lang.String, java.lang.ClassLoader)
javax.xml.bind.JAXBContext.newInstance(java.lang.String, java.lang.ClassLoader, java.util.Map)
javax.xml.registry.ConnectionFactory.newInstance()
javax.xml.rpc.ServiceFactory.newInstance()
javax.xml.soap.MessageFactory.newInstance()
javax.xml.soap.MessageFactory.newInstance(java.lang.String)
javax.xml.soap.SOAPConnectionFactory.newInstance()
javax.xml.soap.SOAPElementFactory.newInstance()
javax.xml.soap.SOAPFactory.newInstance()
javax.xml.soap.SOAPFactory.newInstance(java.lang.String)
javax.xml.stream.util.XMLEventAllocator.newInstance()
javax.xml.stream.XMLEventFactory.newInstance()
javax.xml.stream.XMLEventFactory.newInstance(java.lang.String, java.lang.ClassLoader)
javax.xml.stream.XMLInputFactory.newInstance()
javax.xml.stream.XMLInputFactory.newInstance(java.lang.String, java.lang.ClassLoader)
javax.xml.stream.XMLOutputFactory.newInstance()
javax.xml.stream.XMLOutputFactory.newInstance(java.lang.String, java.lang.ClassLoader)


Occurences of NewsAddress (constructors)

NewsAddress (constructors) occurences:
javax.mail.internet.NewsAddress()
javax.mail.internet.NewsAddress(java.lang.String)
javax.mail.internet.NewsAddress(java.lang.String, java.lang.String)


Occurences of newStream

newStream occurences:
javax.mail.internet.SharedInputStream.newStream(long, long)
javax.mail.util.SharedByteArrayInputStream.newStream(long, long)
javax.mail.util.SharedFileInputStream.newStream(long, long)


Occurences of next

next occurences:
javax.mail.internet.HeaderTokenizer.next()
javax.xml.stream.util.EventReaderDelegate.next()
javax.xml.stream.util.StreamReaderDelegate.next()
javax.xml.stream.XMLStreamReader.next()


Occurences of nextEvent

nextEvent occurences:
javax.xml.stream.util.EventReaderDelegate.nextEvent()
javax.xml.stream.XMLEventReader.nextEvent()


Occurences of nextTag

nextTag occurences:
javax.xml.stream.util.EventReaderDelegate.nextTag()
javax.xml.stream.util.StreamReaderDelegate.nextTag()
javax.xml.stream.XMLEventReader.nextTag()
javax.xml.stream.XMLStreamReader.nextTag()


Occurences of nillable

nillable occurences:
javax.xml.bind.annotation.XmlElement.nillable()
javax.xml.bind.annotation.XmlElementWrapper.nillable()


Occurences of NonUniqueResultException (constructors)

NonUniqueResultException (constructors) occurences:
javax.persistence.NonUniqueResultException()
javax.persistence.NonUniqueResultException(java.lang.String)


Occurences of NoResultException (constructors)

NoResultException (constructors) occurences:
javax.persistence.NoResultException()
javax.persistence.NoResultException(java.lang.String)


Occurences of NoSuchEJBException (constructors)

NoSuchEJBException (constructors) occurences:
javax.ejb.NoSuchEJBException()
javax.ejb.NoSuchEJBException(java.lang.String)
javax.ejb.NoSuchEJBException(java.lang.String, java.lang.Exception)


Occurences of NoSuchEntityException (constructors)

NoSuchEntityException (constructors) occurences:
javax.ejb.NoSuchEntityException()
javax.ejb.NoSuchEntityException(java.lang.Exception)
javax.ejb.NoSuchEntityException(java.lang.String)


Occurences of NoSuchObjectLocalException (constructors)

NoSuchObjectLocalException (constructors) occurences:
javax.ejb.NoSuchObjectLocalException()
javax.ejb.NoSuchObjectLocalException(java.lang.String)
javax.ejb.NoSuchObjectLocalException(java.lang.String, java.lang.Exception)


Occurences of NoSuchProviderException (constructors)

NoSuchProviderException (constructors) occurences:
javax.mail.NoSuchProviderException()
javax.mail.NoSuchProviderException(java.lang.String)


Occurences of NotIdentifiableEventImpl (constructors)

NotIdentifiableEventImpl (constructors) occurences:
javax.xml.bind.helpers.NotIdentifiableEventImpl(int, java.lang.String, javax.xml.bind.ValidationEventLocator)
javax.xml.bind.helpers.NotIdentifiableEventImpl(int, java.lang.String, javax.xml.bind.ValidationEventLocator, java.lang.Throwable)


Occurences of notifyConnectionListeners

notifyConnectionListeners occurences:
javax.mail.Folder.notifyConnectionListeners(int)
javax.mail.Service.notifyConnectionListeners(int)


Occurences of notifyFolderListeners

notifyFolderListeners occurences:
javax.mail.Folder.notifyFolderListeners(int)
javax.mail.Store.notifyFolderListeners(int, javax.mail.Folder)


Occurences of notifyFolderRenamedListeners

notifyFolderRenamedListeners occurences:
javax.mail.Folder.notifyFolderRenamedListeners(javax.mail.Folder)
javax.mail.Store.notifyFolderRenamedListeners(javax.mail.Folder, javax.mail.Folder)


Occurences of NotSupportedException

NotSupportedException occurences:
javax.resource.NotSupportedException
javax.transaction.NotSupportedException


Occurences of NotSupportedException (constructors)

NotSupportedException (constructors) occurences:
javax.resource.NotSupportedException()
javax.resource.NotSupportedException(java.lang.String)
javax.resource.NotSupportedException(java.lang.String, java.lang.String)
javax.resource.NotSupportedException(java.lang.String, java.lang.Throwable)
javax.resource.NotSupportedException(java.lang.Throwable)
javax.transaction.NotSupportedException()
javax.transaction.NotSupportedException(java.lang.String)


Occurences of NOT_IN_RANGE_MESSAGE_ID

NOT_IN_RANGE_MESSAGE_ID occurences:
javax.faces.validator.NOT_IN_RANGE_MESSAGE_ID
javax.faces.validator.NOT_IN_RANGE_MESSAGE_ID
javax.faces.validator.NOT_IN_RANGE_MESSAGE_ID


Occurences of nullable

nullable occurences:
javax.persistence.Column.nullable()
javax.persistence.JoinColumn.nullable()


Occurences of ObjectHolder (constructors)

ObjectHolder (constructors) occurences:
javax.xml.rpc.holders.ObjectHolder()
javax.xml.rpc.holders.ObjectHolder(java.lang.Object)


Occurences of ObjectNotFoundException (constructors)

ObjectNotFoundException (constructors) occurences:
javax.ejb.ObjectNotFoundException()
javax.ejb.ObjectNotFoundException(java.lang.String)


Occurences of onMessage

onMessage occurences:
javax.jms.MessageListener.onMessage(javax.jms.Message)
javax.resource.cci.MessageListener.onMessage(javax.resource.cci.Record)


Occurences of opened

opened occurences:
javax.mail.event.ConnectionAdapter.opened(javax.mail.event.ConnectionEvent)
javax.mail.event.ConnectionListener.opened(javax.mail.event.ConnectionEvent)


Occurences of OptimisticLockException (constructors)

OptimisticLockException (constructors) occurences:
javax.persistence.OptimisticLockException()
javax.persistence.OptimisticLockException(java.lang.Object)
javax.persistence.OptimisticLockException(java.lang.String)
javax.persistence.OptimisticLockException(java.lang.String, java.lang.Throwable)
javax.persistence.OptimisticLockException(java.lang.String, java.lang.Throwable, java.lang.Object)
javax.persistence.OptimisticLockException(java.lang.Throwable)


Occurences of optional

optional occurences:
javax.persistence.Basic.optional()
javax.persistence.ManyToOne.optional()
javax.persistence.OneToOne.optional()


Occurences of OrTerm (constructors)

OrTerm (constructors) occurences:
javax.mail.search.OrTerm(javax.mail.search.SearchTerm, javax.mail.search.SearchTerm)
javax.mail.search.OrTerm(javax.mail.search.SearchTerm[])


Occurences of OUT

OUT occurences:
javax.jws.OUT
javax.servlet.jsp.OUT
javax.xml.rpc.OUT


Occurences of pageContext

pageContext occurences:
javax.faces.webapp.pageContext
javax.servlet.jsp.tagext.pageContext


Occurences of ParameterList (constructors)

ParameterList (constructors) occurences:
javax.mail.internet.ParameterList()
javax.mail.internet.ParameterList(java.lang.String)


Occurences of parent

parent occurences:
javax.mail.parent
javax.mail.parent


Occurences of parse

parse occurences:
javax.activation.MimeTypeParameterList.parse(java.lang.String)
javax.mail.internet.InternetAddress.parse(java.lang.String)
javax.mail.internet.InternetAddress.parse(java.lang.String, boolean)
javax.mail.internet.MailDateFormat.parse(java.lang.String, java.text.ParsePosition)
javax.mail.internet.MimeMessage.parse(java.io.InputStream)
javax.mail.internet.MimeMultipart.parse()
javax.mail.internet.NewsAddress.parse(java.lang.String)


Occurences of parseAnySimpleType

parseAnySimpleType occurences:
javax.xml.bind.DatatypeConverter.parseAnySimpleType(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseAnySimpleType(java.lang.String)


Occurences of parseBase64Binary

parseBase64Binary occurences:
javax.xml.bind.DatatypeConverter.parseBase64Binary(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseBase64Binary(java.lang.String)


Occurences of parseBoolean

parseBoolean occurences:
javax.xml.bind.DatatypeConverter.parseBoolean(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseBoolean(java.lang.String)


Occurences of parseByte

parseByte occurences:
javax.xml.bind.DatatypeConverter.parseByte(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseByte(java.lang.String)


Occurences of ParseConversionEventImpl (constructors)

ParseConversionEventImpl (constructors) occurences:
javax.xml.bind.helpers.ParseConversionEventImpl(int, java.lang.String, javax.xml.bind.ValidationEventLocator)
javax.xml.bind.helpers.ParseConversionEventImpl(int, java.lang.String, javax.xml.bind.ValidationEventLocator, java.lang.Throwable)


Occurences of parseDate

parseDate occurences:
javax.xml.bind.DatatypeConverter.parseDate(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseDate(java.lang.String)


Occurences of parseDateTime

parseDateTime occurences:
javax.xml.bind.DatatypeConverter.parseDateTime(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseDateTime(java.lang.String)


Occurences of parseDecimal

parseDecimal occurences:
javax.xml.bind.DatatypeConverter.parseDecimal(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseDecimal(java.lang.String)


Occurences of parseDouble

parseDouble occurences:
javax.xml.bind.DatatypeConverter.parseDouble(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseDouble(java.lang.String)


Occurences of ParseException (constructors)

ParseException (constructors) occurences:
javax.mail.internet.ParseException()
javax.mail.internet.ParseException(java.lang.String)


Occurences of parseFloat

parseFloat occurences:
javax.xml.bind.DatatypeConverter.parseFloat(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseFloat(java.lang.String)


Occurences of parseHexBinary

parseHexBinary occurences:
javax.xml.bind.DatatypeConverter.parseHexBinary(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseHexBinary(java.lang.String)


Occurences of parseInt

parseInt occurences:
javax.xml.bind.DatatypeConverter.parseInt(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseInt(java.lang.String)


Occurences of parseInteger

parseInteger occurences:
javax.xml.bind.DatatypeConverter.parseInteger(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseInteger(java.lang.String)


Occurences of parseLong

parseLong occurences:
javax.xml.bind.DatatypeConverter.parseLong(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseLong(java.lang.String)


Occurences of parseQName

parseQName occurences:
javax.xml.bind.DatatypeConverter.parseQName(java.lang.String, javax.xml.namespace.NamespaceContext)
javax.xml.bind.DatatypeConverterInterface.parseQName(java.lang.String, javax.xml.namespace.NamespaceContext)


Occurences of parseShort

parseShort occurences:
javax.xml.bind.DatatypeConverter.parseShort(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseShort(java.lang.String)


Occurences of parseString

parseString occurences:
javax.mail.URLName.parseString(java.lang.String)
javax.xml.bind.DatatypeConverter.parseString(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseString(java.lang.String)


Occurences of parseTime

parseTime occurences:
javax.xml.bind.DatatypeConverter.parseTime(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseTime(java.lang.String)


Occurences of parseUnsignedInt

parseUnsignedInt occurences:
javax.xml.bind.DatatypeConverter.parseUnsignedInt(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseUnsignedInt(java.lang.String)


Occurences of parseUnsignedShort

parseUnsignedShort occurences:
javax.xml.bind.DatatypeConverter.parseUnsignedShort(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.parseUnsignedShort(java.lang.String)


Occurences of partName

partName occurences:
javax.jws.WebParam.partName()
javax.jws.WebResult.partName()


Occurences of PASSWORD_PROPERTY

PASSWORD_PROPERTY occurences:
javax.xml.rpc.PASSWORD_PROPERTY
javax.xml.rpc.PASSWORD_PROPERTY
javax.xml.ws.PASSWORD_PROPERTY


Occurences of peek

peek occurences:
javax.mail.internet.HeaderTokenizer.peek()
javax.xml.stream.util.EventReaderDelegate.peek()
javax.xml.stream.XMLEventReader.peek()


Occurences of PersistenceException (constructors)

PersistenceException (constructors) occurences:
javax.persistence.PersistenceException()
javax.persistence.PersistenceException(java.lang.String)
javax.persistence.PersistenceException(java.lang.String, java.lang.Throwable)
javax.persistence.PersistenceException(java.lang.Throwable)


Occurences of PolicyContextException (constructors)

PolicyContextException (constructors) occurences:
javax.security.jacc.PolicyContextException()
javax.security.jacc.PolicyContextException(java.lang.String)
javax.security.jacc.PolicyContextException(java.lang.String, java.lang.Throwable)
javax.security.jacc.PolicyContextException(java.lang.Throwable)


Occurences of portName

portName occurences:
javax.jws.WebService.portName()
javax.xml.ws.WebServiceProvider.portName()


Occurences of prefix

prefix occurences:
javax.servlet.jsp.tagext.prefix
javax.xml.bind.annotation.XmlNs.prefix()


Occurences of prepare

prepare occurences:
javax.resource.spi.XATerminator.prepare(javax.transaction.xa.Xid)
javax.transaction.xa.XAResource.prepare(javax.transaction.xa.Xid)


Occurences of print

print occurences:
javax.servlet.jsp.JspWriter.print(boolean)
javax.servlet.jsp.JspWriter.print(char)
javax.servlet.jsp.JspWriter.print(char[])
javax.servlet.jsp.JspWriter.print(double)
javax.servlet.jsp.JspWriter.print(float)
javax.servlet.jsp.JspWriter.print(int)
javax.servlet.jsp.JspWriter.print(java.lang.Object)
javax.servlet.jsp.JspWriter.print(java.lang.String)
javax.servlet.jsp.JspWriter.print(long)
javax.servlet.ServletOutputStream.print(boolean)
javax.servlet.ServletOutputStream.print(char)
javax.servlet.ServletOutputStream.print(double)
javax.servlet.ServletOutputStream.print(float)
javax.servlet.ServletOutputStream.print(int)
javax.servlet.ServletOutputStream.print(java.lang.String)
javax.servlet.ServletOutputStream.print(long)


Occurences of printAnySimpleType

printAnySimpleType occurences:
javax.xml.bind.DatatypeConverter.printAnySimpleType(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.printAnySimpleType(java.lang.String)


Occurences of printBase64Binary

printBase64Binary occurences:
javax.xml.bind.DatatypeConverter.printBase64Binary(byte[])
javax.xml.bind.DatatypeConverterInterface.printBase64Binary(byte[])


Occurences of printBoolean

printBoolean occurences:
javax.xml.bind.DatatypeConverter.printBoolean(boolean)
javax.xml.bind.DatatypeConverterInterface.printBoolean(boolean)


Occurences of printByte

printByte occurences:
javax.xml.bind.DatatypeConverter.printByte(byte)
javax.xml.bind.DatatypeConverterInterface.printByte(byte)


Occurences of PrintConversionEventImpl (constructors)

PrintConversionEventImpl (constructors) occurences:
javax.xml.bind.helpers.PrintConversionEventImpl(int, java.lang.String, javax.xml.bind.ValidationEventLocator)
javax.xml.bind.helpers.PrintConversionEventImpl(int, java.lang.String, javax.xml.bind.ValidationEventLocator, java.lang.Throwable)


Occurences of printDate

printDate occurences:
javax.xml.bind.DatatypeConverter.printDate(java.util.Calendar)
javax.xml.bind.DatatypeConverterInterface.printDate(java.util.Calendar)


Occurences of printDateTime

printDateTime occurences:
javax.xml.bind.DatatypeConverter.printDateTime(java.util.Calendar)
javax.xml.bind.DatatypeConverterInterface.printDateTime(java.util.Calendar)


Occurences of printDecimal

printDecimal occurences:
javax.xml.bind.DatatypeConverter.printDecimal(java.math.BigDecimal)
javax.xml.bind.DatatypeConverterInterface.printDecimal(java.math.BigDecimal)


Occurences of printDouble

printDouble occurences:
javax.xml.bind.DatatypeConverter.printDouble(double)
javax.xml.bind.DatatypeConverterInterface.printDouble(double)


Occurences of printFloat

printFloat occurences:
javax.xml.bind.DatatypeConverter.printFloat(float)
javax.xml.bind.DatatypeConverterInterface.printFloat(float)


Occurences of printHexBinary

printHexBinary occurences:
javax.xml.bind.DatatypeConverter.printHexBinary(byte[])
javax.xml.bind.DatatypeConverterInterface.printHexBinary(byte[])


Occurences of printInt

printInt occurences:
javax.xml.bind.DatatypeConverter.printInt(int)
javax.xml.bind.DatatypeConverterInterface.printInt(int)


Occurences of printInteger

printInteger occurences:
javax.xml.bind.DatatypeConverter.printInteger(java.math.BigInteger)
javax.xml.bind.DatatypeConverterInterface.printInteger(java.math.BigInteger)


Occurences of println

println occurences:
javax.servlet.jsp.JspWriter.println()
javax.servlet.jsp.JspWriter.println(boolean)
javax.servlet.jsp.JspWriter.println(char)
javax.servlet.jsp.JspWriter.println(char[])
javax.servlet.jsp.JspWriter.println(double)
javax.servlet.jsp.JspWriter.println(float)
javax.servlet.jsp.JspWriter.println(int)
javax.servlet.jsp.JspWriter.println(java.lang.Object)
javax.servlet.jsp.JspWriter.println(java.lang.String)
javax.servlet.jsp.JspWriter.println(long)
javax.servlet.ServletOutputStream.println()
javax.servlet.ServletOutputStream.println(boolean)
javax.servlet.ServletOutputStream.println(char)
javax.servlet.ServletOutputStream.println(double)
javax.servlet.ServletOutputStream.println(float)
javax.servlet.ServletOutputStream.println(int)
javax.servlet.ServletOutputStream.println(java.lang.String)
javax.servlet.ServletOutputStream.println(long)


Occurences of printLong

printLong occurences:
javax.xml.bind.DatatypeConverter.printLong(long)
javax.xml.bind.DatatypeConverterInterface.printLong(long)


Occurences of printQName

printQName occurences:
javax.xml.bind.DatatypeConverter.printQName(javax.xml.namespace.QName, javax.xml.namespace.NamespaceContext)
javax.xml.bind.DatatypeConverterInterface.printQName(javax.xml.namespace.QName, javax.xml.namespace.NamespaceContext)


Occurences of printShort

printShort occurences:
javax.xml.bind.DatatypeConverter.printShort(short)
javax.xml.bind.DatatypeConverterInterface.printShort(short)


Occurences of printStackTrace

printStackTrace occurences:
javax.ejb.EJBException.printStackTrace()
javax.ejb.EJBException.printStackTrace(java.io.PrintStream)
javax.ejb.EJBException.printStackTrace(java.io.PrintWriter)
javax.xml.bind.JAXBException.printStackTrace()
javax.xml.bind.JAXBException.printStackTrace(java.io.PrintStream)
javax.xml.bind.JAXBException.printStackTrace(java.io.PrintWriter)
javax.xml.bind.TypeConstraintException.printStackTrace()
javax.xml.bind.TypeConstraintException.printStackTrace(java.io.PrintStream)


Occurences of printString

printString occurences:
javax.xml.bind.DatatypeConverter.printString(java.lang.String)
javax.xml.bind.DatatypeConverterInterface.printString(java.lang.String)


Occurences of printTime

printTime occurences:
javax.xml.bind.DatatypeConverter.printTime(java.util.Calendar)
javax.xml.bind.DatatypeConverterInterface.printTime(java.util.Calendar)


Occurences of printUnsignedInt

printUnsignedInt occurences:
javax.xml.bind.DatatypeConverter.printUnsignedInt(long)
javax.xml.bind.DatatypeConverterInterface.printUnsignedInt(long)


Occurences of printUnsignedShort

printUnsignedShort occurences:
javax.xml.bind.DatatypeConverter.printUnsignedShort(int)
javax.xml.bind.DatatypeConverterInterface.printUnsignedShort(int)


Occurences of processAction

processAction occurences:
javax.faces.event.ActionListener.processAction(javax.faces.event.ActionEvent)
javax.faces.event.MethodExpressionActionListener.processAction(javax.faces.event.ActionEvent)


Occurences of processDecodes

processDecodes occurences:
javax.faces.component.UIComponent.processDecodes(javax.faces.context.FacesContext)
javax.faces.component.UIComponentBase.processDecodes(javax.faces.context.FacesContext)
javax.faces.component.UIData.processDecodes(javax.faces.context.FacesContext)
javax.faces.component.UIForm.processDecodes(javax.faces.context.FacesContext)
javax.faces.component.UIInput.processDecodes(javax.faces.context.FacesContext)
javax.faces.component.UIViewRoot.processDecodes(javax.faces.context.FacesContext)


Occurences of processListener

processListener occurences:
javax.faces.event.ActionEvent.processListener(javax.faces.event.FacesListener)
javax.faces.event.FacesEvent.processListener(javax.faces.event.FacesListener)
javax.faces.event.ValueChangeEvent.processListener(javax.faces.event.FacesListener)


Occurences of processRestoreState

processRestoreState occurences:
javax.faces.component.UIComponent.processRestoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UIComponentBase.processRestoreState(javax.faces.context.FacesContext, java.lang.Object)


Occurences of processSaveState

processSaveState occurences:
javax.faces.component.UIComponent.processSaveState(javax.faces.context.FacesContext)
javax.faces.component.UIComponentBase.processSaveState(javax.faces.context.FacesContext)


Occurences of processUpdates

processUpdates occurences:
javax.faces.component.UIComponent.processUpdates(javax.faces.context.FacesContext)
javax.faces.component.UIComponentBase.processUpdates(javax.faces.context.FacesContext)
javax.faces.component.UIData.processUpdates(javax.faces.context.FacesContext)
javax.faces.component.UIForm.processUpdates(javax.faces.context.FacesContext)
javax.faces.component.UIInput.processUpdates(javax.faces.context.FacesContext)
javax.faces.component.UIViewRoot.processUpdates(javax.faces.context.FacesContext)


Occurences of processValidators

processValidators occurences:
javax.faces.component.UIComponent.processValidators(javax.faces.context.FacesContext)
javax.faces.component.UIComponentBase.processValidators(javax.faces.context.FacesContext)
javax.faces.component.UIData.processValidators(javax.faces.context.FacesContext)
javax.faces.component.UIForm.processValidators(javax.faces.context.FacesContext)
javax.faces.component.UIInput.processValidators(javax.faces.context.FacesContext)
javax.faces.component.UIViewRoot.processValidators(javax.faces.context.FacesContext)


Occurences of processValueChange

processValueChange occurences:
javax.faces.event.MethodExpressionValueChangeListener.processValueChange(javax.faces.event.ValueChangeEvent)
javax.faces.event.ValueChangeListener.processValueChange(javax.faces.event.ValueChangeEvent)


Occurences of PropertyException (constructors)

PropertyException (constructors) occurences:
javax.xml.bind.PropertyException(java.lang.String)
javax.xml.bind.PropertyException(java.lang.String, java.lang.Object)
javax.xml.bind.PropertyException(java.lang.String, java.lang.String)
javax.xml.bind.PropertyException(java.lang.String, java.lang.String, java.lang.Throwable)
javax.xml.bind.PropertyException(java.lang.String, java.lang.Throwable)
javax.xml.bind.PropertyException(java.lang.Throwable)


Occurences of PropertyNotFoundException

PropertyNotFoundException occurences:
javax.el.PropertyNotFoundException
javax.faces.el.PropertyNotFoundException


Occurences of PropertyNotFoundException (constructors)

PropertyNotFoundException (constructors) occurences:
javax.el.PropertyNotFoundException()
javax.el.PropertyNotFoundException(java.lang.String)
javax.el.PropertyNotFoundException(java.lang.String, java.lang.Throwable)
javax.el.PropertyNotFoundException(java.lang.Throwable)
javax.faces.el.PropertyNotFoundException()
javax.faces.el.PropertyNotFoundException(java.lang.String)
javax.faces.el.PropertyNotFoundException(java.lang.String, java.lang.Throwable)
javax.faces.el.PropertyNotFoundException(java.lang.Throwable)


Occurences of PropertyNotWritableException (constructors)

PropertyNotWritableException (constructors) occurences:
javax.el.PropertyNotWritableException()
javax.el.PropertyNotWritableException(java.lang.String)
javax.el.PropertyNotWritableException(java.lang.String, java.lang.Throwable)
javax.el.PropertyNotWritableException(java.lang.Throwable)


Occurences of ProtocolException (constructors)

ProtocolException (constructors) occurences:
javax.xml.ws.ProtocolException()
javax.xml.ws.ProtocolException(java.lang.String)
javax.xml.ws.ProtocolException(java.lang.String, java.lang.Throwable)
javax.xml.ws.ProtocolException(java.lang.Throwable)


Occurences of Provider

Provider occurences:
javax.mail.Provider
javax.xml.ws.Provider
javax.xml.ws.spi.Provider


Occurences of Provider (constructors)

Provider (constructors) occurences:
javax.mail.Provider(javax.mail.Provider.Type, java.lang.String, java.lang.String, java.lang.String, java.lang.String)
javax.xml.ws.spi.Provider()


Occurences of publish

publish occurences:
javax.jms.TopicPublisher.publish(javax.jms.Message)
javax.jms.TopicPublisher.publish(javax.jms.Message, int, int, long)
javax.jms.TopicPublisher.publish(javax.jms.Topic, javax.jms.Message)
javax.jms.TopicPublisher.publish(javax.jms.Topic, javax.jms.Message, int, int, long)
javax.xml.ws.Endpoint.publish(java.lang.Object)
javax.xml.ws.Endpoint.publish(java.lang.String)
javax.xml.ws.Endpoint.publish(java.lang.String, java.lang.Object)


Occurences of pushBody

pushBody occurences:
javax.servlet.jsp.JspContext.pushBody(java.io.Writer)
javax.servlet.jsp.PageContext.pushBody()


Occurences of QNameHolder (constructors)

QNameHolder (constructors) occurences:
javax.xml.rpc.holders.QNameHolder()
javax.xml.rpc.holders.QNameHolder(javax.xml.namespace.QName)


Occurences of query

query occurences:
javax.persistence.NamedNativeQuery.query()
javax.persistence.NamedQuery.query()


Occurences of Query

Query occurences:
javax.persistence.Query
javax.xml.registry.Query


Occurences of queueEvent

queueEvent occurences:
javax.faces.component.UICommand.queueEvent(javax.faces.event.FacesEvent)
javax.faces.component.UIComponent.queueEvent(javax.faces.event.FacesEvent)
javax.faces.component.UIComponentBase.queueEvent(javax.faces.event.FacesEvent)
javax.faces.component.UIData.queueEvent(javax.faces.event.FacesEvent)
javax.faces.component.UIViewRoot.queueEvent(javax.faces.event.FacesEvent)
javax.mail.Service.queueEvent(javax.mail.event.MailEvent, java.util.Vector)


Occurences of read

read occurences:
javax.mail.util.SharedFileInputStream.read()
javax.mail.util.SharedFileInputStream.read(byte[], int, int)
javax.resource.cci.Streamable.read(java.io.InputStream)


Occurences of readBoolean

readBoolean occurences:
javax.jms.BytesMessage.readBoolean()
javax.jms.StreamMessage.readBoolean()


Occurences of readByte

readByte occurences:
javax.jms.BytesMessage.readByte()
javax.jms.StreamMessage.readByte()


Occurences of readBytes

readBytes occurences:
javax.jms.BytesMessage.readBytes(byte[])
javax.jms.BytesMessage.readBytes(byte[], int)
javax.jms.StreamMessage.readBytes(byte[])


Occurences of readChar

readChar occurences:
javax.jms.BytesMessage.readChar()
javax.jms.StreamMessage.readChar()


Occurences of readDouble

readDouble occurences:
javax.jms.BytesMessage.readDouble()
javax.jms.StreamMessage.readDouble()


Occurences of readFloat

readFloat occurences:
javax.jms.BytesMessage.readFloat()
javax.jms.StreamMessage.readFloat()


Occurences of readInt

readInt occurences:
javax.jms.BytesMessage.readInt()
javax.jms.StreamMessage.readInt()


Occurences of readLong

readLong occurences:
javax.jms.BytesMessage.readLong()
javax.jms.StreamMessage.readLong()


Occurences of ReadOnlyFolderException (constructors)

ReadOnlyFolderException (constructors) occurences:
javax.mail.ReadOnlyFolderException(javax.mail.Folder)
javax.mail.ReadOnlyFolderException(javax.mail.Folder, java.lang.String)


Occurences of readResolve

readResolve occurences:
javax.mail.internet.MimeMessage.RecipientType.readResolve()
javax.mail.Message.RecipientType.readResolve()


Occurences of readShort

readShort occurences:
javax.jms.BytesMessage.readShort()
javax.jms.StreamMessage.readShort()


Occurences of receive

receive occurences:
javax.jms.MessageConsumer.receive()
javax.jms.MessageConsumer.receive(long)


Occurences of recover

recover occurences:
javax.jms.Session.recover()
javax.resource.spi.XATerminator.recover(int)
javax.transaction.xa.XAResource.recover(int)


Occurences of redeploy

redeploy occurences:
javax.enterprise.deploy.spi.DeploymentManager.redeploy(javax.enterprise.deploy.spi.TargetModuleID[], java.io.File, java.io.File)
javax.enterprise.deploy.spi.DeploymentManager.redeploy(javax.enterprise.deploy.spi.TargetModuleID[], java.io.InputStream, java.io.InputStream)


Occurences of referencedColumnName

referencedColumnName occurences:
javax.persistence.JoinColumn.referencedColumnName()
javax.persistence.PrimaryKeyJoinColumn.referencedColumnName()


Occurences of ReferenceSyntaxException (constructors)

ReferenceSyntaxException (constructors) occurences:
javax.faces.el.ReferenceSyntaxException()
javax.faces.el.ReferenceSyntaxException(java.lang.String)
javax.faces.el.ReferenceSyntaxException(java.lang.String, java.lang.Throwable)
javax.faces.el.ReferenceSyntaxException(java.lang.Throwable)


Occurences of register

register occurences:
javax.xml.rpc.encoding.TypeMapping.register(java.lang.Class, javax.xml.namespace.QName, javax.xml.rpc.encoding.SerializerFactory, javax.xml.rpc.encoding.DeserializerFactory)
javax.xml.rpc.encoding.TypeMappingRegistry.register(java.lang.String, javax.xml.rpc.encoding.TypeMapping)


Occurences of RegistryException (constructors)

RegistryException (constructors) occurences:
javax.xml.registry.RegistryException()
javax.xml.registry.RegistryException(java.lang.String)
javax.xml.registry.RegistryException(java.lang.String, java.lang.Throwable)
javax.xml.registry.RegistryException(java.lang.Throwable)


Occurences of release

release occurences:
javax.enterprise.deploy.spi.DeploymentManager.release()
javax.faces.context.FacesContext.release()
javax.faces.webapp.AttributeTag.release()
javax.faces.webapp.ConverterTag.release()
javax.faces.webapp.FacetTag.release()
javax.faces.webapp.UIComponentClassicTagBase.release()
javax.faces.webapp.UIComponentELTag.release()
javax.faces.webapp.UIComponentTag.release()
javax.faces.webapp.ValidatorTag.release()
javax.resource.spi.endpoint.MessageEndpoint.release()
javax.resource.spi.work.Work.release()
javax.servlet.jsp.PageContext.release()
javax.servlet.jsp.tagext.BodyTagSupport.release()
javax.servlet.jsp.tagext.Tag.release()
javax.servlet.jsp.tagext.TagAdapter.release()
javax.servlet.jsp.tagext.TagLibraryValidator.release()
javax.servlet.jsp.tagext.TagSupport.release()


Occurences of remove

remove occurences:
javax.activation.MimeTypeParameterList.remove(java.lang.String)
javax.ejb.EJBHome.remove(java.lang.Object)
javax.ejb.EJBHome.remove(javax.ejb.Handle)
javax.ejb.EJBLocalHome.remove(java.lang.Object)
javax.ejb.EJBLocalObject.remove()
javax.ejb.EJBObject.remove()
javax.mail.Flags.remove(java.lang.String)
javax.mail.Flags.remove(javax.mail.Flags)
javax.mail.Flags.remove(javax.mail.Flags.Flag)
javax.mail.internet.ParameterList.remove(java.lang.String)
javax.persistence.EntityManager.remove(java.lang.Object)
javax.xml.stream.util.EventReaderDelegate.remove()


Occurences of removeActionListener

removeActionListener occurences:
javax.faces.component.ActionSource.removeActionListener(javax.faces.event.ActionListener)
javax.faces.component.UICommand.removeActionListener(javax.faces.event.ActionListener)


Occurences of removeAllMimeHeaders

removeAllMimeHeaders occurences:
javax.xml.soap.AttachmentPart.removeAllMimeHeaders()
javax.xml.soap.SOAPPart.removeAllMimeHeaders()


Occurences of removeAttribute

removeAttribute occurences:
javax.servlet.http.HttpSession.removeAttribute(java.lang.String)
javax.servlet.jsp.JspContext.removeAttribute(java.lang.String)
javax.servlet.jsp.JspContext.removeAttribute(java.lang.String, int)
javax.servlet.ServletContext.removeAttribute(java.lang.String)
javax.servlet.ServletRequest.removeAttribute(java.lang.String)
javax.servlet.ServletRequestWrapper.removeAttribute(java.lang.String)
javax.xml.soap.SOAPElement.removeAttribute(javax.xml.namespace.QName)
javax.xml.soap.SOAPElement.removeAttribute(javax.xml.soap.Name)


Occurences of removeBodyPart

removeBodyPart occurences:
javax.mail.Multipart.removeBodyPart(int)
javax.mail.Multipart.removeBodyPart(javax.mail.BodyPart)


Occurences of removeChildConcept

removeChildConcept occurences:
javax.xml.registry.infomodel.ClassificationScheme.removeChildConcept(javax.xml.registry.infomodel.Concept)
javax.xml.registry.infomodel.Concept.removeChildConcept(javax.xml.registry.infomodel.Concept)


Occurences of removeChildConcepts

removeChildConcepts occurences:
javax.xml.registry.infomodel.ClassificationScheme.removeChildConcepts(java.util.Collection)
javax.xml.registry.infomodel.Concept.removeChildConcepts(java.util.Collection)


Occurences of removeConnectionListener

removeConnectionListener occurences:
javax.mail.Folder.removeConnectionListener(javax.mail.event.ConnectionListener)
javax.mail.Service.removeConnectionListener(javax.mail.event.ConnectionListener)


Occurences of removeDConfigBean

removeDConfigBean occurences:
javax.enterprise.deploy.spi.DConfigBean.removeDConfigBean(javax.enterprise.deploy.spi.DConfigBean)
javax.enterprise.deploy.spi.DeploymentConfiguration.removeDConfigBean(javax.enterprise.deploy.spi.DConfigBeanRoot)


Occurences of RemoveException (constructors)

RemoveException (constructors) occurences:
javax.ejb.RemoveException()
javax.ejb.RemoveException(java.lang.String)


Occurences of removeFacesListener

removeFacesListener occurences:
javax.faces.component.UIComponent.removeFacesListener(javax.faces.event.FacesListener)
javax.faces.component.UIComponentBase.removeFacesListener(javax.faces.event.FacesListener)


Occurences of removeFolderListener

removeFolderListener occurences:
javax.mail.Folder.removeFolderListener(javax.mail.event.FolderListener)
javax.mail.Store.removeFolderListener(javax.mail.event.FolderListener)


Occurences of removeHeader

removeHeader occurences:
javax.mail.internet.InternetHeaders.removeHeader(java.lang.String)
javax.mail.internet.MimeBodyPart.removeHeader(java.lang.String)
javax.mail.internet.MimeMessage.removeHeader(java.lang.String)
javax.mail.Part.removeHeader(java.lang.String)
javax.xml.soap.MimeHeaders.removeHeader(java.lang.String)


Occurences of removeMimeHeader

removeMimeHeader occurences:
javax.xml.soap.AttachmentPart.removeMimeHeader(java.lang.String)
javax.xml.soap.SOAPPart.removeMimeHeader(java.lang.String)


Occurences of removePhaseListener

removePhaseListener occurences:
javax.faces.component.UIViewRoot.removePhaseListener(javax.faces.event.PhaseListener)
javax.faces.lifecycle.Lifecycle.removePhaseListener(javax.faces.event.PhaseListener)


Occurences of removeProperty

removeProperty occurences:
javax.xml.rpc.Call.removeProperty(java.lang.String)
javax.xml.rpc.handler.MessageContext.removeProperty(java.lang.String)


Occurences of removeValidator

removeValidator occurences:
javax.faces.component.EditableValueHolder.removeValidator(javax.faces.validator.Validator)
javax.faces.component.UIInput.removeValidator(javax.faces.validator.Validator)


Occurences of removeValue

removeValue occurences:
javax.servlet.http.HttpSession.removeValue(java.lang.String)
javax.servlet.jsp.tagext.TagSupport.removeValue(java.lang.String)


Occurences of removeValueChangeListener

removeValueChangeListener occurences:
javax.faces.component.EditableValueHolder.removeValueChangeListener(javax.faces.event.ValueChangeListener)
javax.faces.component.UIInput.removeValueChangeListener(javax.faces.event.ValueChangeListener)


Occurences of removeXpathListener

removeXpathListener occurences:
javax.enterprise.deploy.model.DDBean.removeXpathListener(java.lang.String, javax.enterprise.deploy.model.XpathListener)
javax.enterprise.deploy.model.J2eeApplicationObject.removeXpathListener(javax.enterprise.deploy.shared.ModuleType, java.lang.String, javax.enterprise.deploy.model.XpathListener)


Occurences of render

render occurences:
javax.faces.lifecycle.Lifecycle.render(javax.faces.context.FacesContext)
javax.faces.render


Occurences of renderView

renderView occurences:
javax.faces.application.ViewHandler.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot)
javax.faces.application.ViewHandlerWrapper.renderView(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot)


Occurences of reply

reply occurences:
javax.mail.internet.MimeMessage.reply(boolean)
javax.mail.Message.reply(boolean)


Occurences of request

request occurences:
javax.jms.QueueRequestor.request(javax.jms.Message)
javax.jms.TopicRequestor.request(javax.jms.Message)


Occurences of require

require occurences:
javax.xml.stream.util.StreamReaderDelegate.require(int, java.lang.String, java.lang.String)
javax.xml.stream.XMLStreamReader.require(int, java.lang.String, java.lang.String)


Occurences of required

required occurences:
javax.xml.bind.annotation.XmlAttribute.required()
javax.xml.bind.annotation.XmlElement.required()


Occurences of reset

reset occurences:
javax.jms.BytesMessage.reset()
javax.jms.StreamMessage.reset()
javax.mail.util.SharedFileInputStream.reset()
javax.servlet.ServletResponse.reset()
javax.servlet.ServletResponseWrapper.reset()
javax.xml.bind.util.ValidationEventCollector.reset()


Occurences of resetBuffer

resetBuffer occurences:
javax.servlet.ServletResponse.resetBuffer()
javax.servlet.ServletResponseWrapper.resetBuffer()


Occurences of resolveFunction

resolveFunction occurences:
javax.el.FunctionMapper.resolveFunction(java.lang.String, java.lang.String)
javax.servlet.jsp.el.FunctionMapper.resolveFunction(java.lang.String, java.lang.String)


Occurences of resolveVariable

resolveVariable occurences:
javax.el.VariableMapper.resolveVariable(java.lang.String)
javax.faces.el.VariableResolver.resolveVariable(javax.faces.context.FacesContext, java.lang.String)
javax.servlet.jsp.el.VariableResolver.resolveVariable(java.lang.String)


Occurences of ResourceAdapterInternalException (constructors)

ResourceAdapterInternalException (constructors) occurences:
javax.resource.spi.ResourceAdapterInternalException()
javax.resource.spi.ResourceAdapterInternalException(java.lang.String)
javax.resource.spi.ResourceAdapterInternalException(java.lang.String, java.lang.String)
javax.resource.spi.ResourceAdapterInternalException(java.lang.String, java.lang.Throwable)
javax.resource.spi.ResourceAdapterInternalException(java.lang.Throwable)


Occurences of ResourceAllocationException

ResourceAllocationException occurences:
javax.jms.ResourceAllocationException
javax.resource.spi.ResourceAllocationException


Occurences of ResourceAllocationException (constructors)

ResourceAllocationException (constructors) occurences:
javax.jms.ResourceAllocationException(java.lang.String)
javax.jms.ResourceAllocationException(java.lang.String, java.lang.String)
javax.resource.spi.ResourceAllocationException()
javax.resource.spi.ResourceAllocationException(java.lang.String)
javax.resource.spi.ResourceAllocationException(java.lang.String, java.lang.String)
javax.resource.spi.ResourceAllocationException(java.lang.String, java.lang.Throwable)
javax.resource.spi.ResourceAllocationException(java.lang.Throwable)


Occurences of ResourceException (constructors)

ResourceException (constructors) occurences:
javax.resource.ResourceException()
javax.resource.ResourceException(java.lang.String)
javax.resource.ResourceException(java.lang.String, java.lang.String)
javax.resource.ResourceException(java.lang.String, java.lang.Throwable)
javax.resource.ResourceException(java.lang.Throwable)


Occurences of ResourceWarning (constructors)

ResourceWarning (constructors) occurences:
javax.resource.cci.ResourceWarning()
javax.resource.cci.ResourceWarning(java.lang.String)
javax.resource.cci.ResourceWarning(java.lang.String, java.lang.String)
javax.resource.cci.ResourceWarning(java.lang.String, java.lang.Throwable)
javax.resource.cci.ResourceWarning(java.lang.Throwable)


Occurences of restoreComponentState

restoreComponentState occurences:
javax.faces.application.StateManager.restoreComponentState(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot, java.lang.String)
javax.faces.application.StateManagerWrapper.restoreComponentState(javax.faces.context.FacesContext, javax.faces.component.UIViewRoot, java.lang.String)


Occurences of restoreState

restoreState occurences:
javax.faces.component.html.HtmlColumn.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlCommandButton.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlCommandLink.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlDataTable.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlForm.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlGraphicImage.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlInputHidden.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlInputSecret.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlInputText.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlInputTextarea.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlMessage.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlMessages.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlOutputFormat.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlOutputLabel.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlOutputLink.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlOutputText.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlPanelGrid.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlPanelGroup.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlSelectBooleanCheckbox.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlSelectManyCheckbox.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlSelectManyListbox.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlSelectManyMenu.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlSelectOneListbox.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlSelectOneMenu.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.html.HtmlSelectOneRadio.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.StateHolder.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UICommand.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UIComponentBase.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UIData.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UIGraphic.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UIInput.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UIMessage.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UIMessages.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UIOutput.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UIParameter.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UISelectItem.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UISelectItems.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UIViewRoot.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.convert.DateTimeConverter.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.convert.EnumConverter.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.convert.NumberConverter.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.event.MethodExpressionActionListener.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.event.MethodExpressionValueChangeListener.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.validator.DoubleRangeValidator.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.validator.LengthValidator.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.validator.LongRangeValidator.restoreState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.validator.MethodExpressionValidator.restoreState(javax.faces.context.FacesContext, java.lang.Object)


Occurences of restoreTreeStructure

restoreTreeStructure occurences:
javax.faces.application.StateManager.restoreTreeStructure(javax.faces.context.FacesContext, java.lang.String, java.lang.String)
javax.faces.application.StateManagerWrapper.restoreTreeStructure(javax.faces.context.FacesContext, java.lang.String, java.lang.String)


Occurences of restoreView

restoreView occurences:
javax.faces.application.StateManager.restoreView(javax.faces.context.FacesContext, java.lang.String, java.lang.String)
javax.faces.application.StateManagerWrapper.restoreView(javax.faces.context.FacesContext, java.lang.String, java.lang.String)
javax.faces.application.ViewHandler.restoreView(javax.faces.context.FacesContext, java.lang.String)
javax.faces.application.ViewHandlerWrapper.restoreView(javax.faces.context.FacesContext, java.lang.String)


Occurences of ResultDataModel (constructors)

ResultDataModel (constructors) occurences:
javax.faces.model.ResultDataModel()
javax.faces.model.ResultDataModel(javax.servlet.jsp.jstl.sql.Result)


Occurences of ResultSetDataModel (constructors)

ResultSetDataModel (constructors) occurences:
javax.faces.model.ResultSetDataModel()
javax.faces.model.ResultSetDataModel(java.sql.ResultSet)


Occurences of rollback

rollback occurences:
javax.ejb.ApplicationException.rollback()
javax.jms.Session.rollback()
javax.jms.XASession.rollback()
javax.persistence.EntityTransaction.rollback()
javax.resource.cci.LocalTransaction.rollback()
javax.resource.spi.LocalTransaction.rollback()
javax.resource.spi.XATerminator.rollback(javax.transaction.xa.Xid)
javax.transaction.Transaction.rollback()
javax.transaction.TransactionManager.rollback()
javax.transaction.UserTransaction.rollback()
javax.transaction.xa.XAResource.rollback(javax.transaction.xa.Xid)


Occurences of RollbackException

RollbackException occurences:
javax.persistence.RollbackException
javax.transaction.RollbackException


Occurences of RollbackException (constructors)

RollbackException (constructors) occurences:
javax.persistence.RollbackException()
javax.persistence.RollbackException(java.lang.String)
javax.persistence.RollbackException(java.lang.String, java.lang.Throwable)
javax.persistence.RollbackException(java.lang.Throwable)
javax.transaction.RollbackException()
javax.transaction.RollbackException(java.lang.String)


Occurences of SAAJResult (constructors)

SAAJResult (constructors) occurences:
javax.xml.soap.SAAJResult()
javax.xml.soap.SAAJResult(java.lang.String)
javax.xml.soap.SAAJResult(javax.xml.soap.SOAPElement)
javax.xml.soap.SAAJResult(javax.xml.soap.SOAPMessage)


Occurences of saveChanges

saveChanges occurences:
javax.mail.internet.MimeMessage.saveChanges()
javax.mail.Message.saveChanges()
javax.xml.soap.SOAPMessage.saveChanges()


Occurences of SaveException (constructors)

SaveException (constructors) occurences:
javax.xml.registry.SaveException()
javax.xml.registry.SaveException(java.lang.String)
javax.xml.registry.SaveException(java.lang.String, java.lang.Throwable)
javax.xml.registry.SaveException(java.lang.Throwable)


Occurences of saveFile

saveFile occurences:
javax.mail.internet.MimeBodyPart.saveFile(java.io.File)
javax.mail.internet.MimeBodyPart.saveFile(java.lang.String)


Occurences of saveSerializedView

saveSerializedView occurences:
javax.faces.application.StateManager.saveSerializedView(javax.faces.context.FacesContext)
javax.faces.application.StateManagerWrapper.saveSerializedView(javax.faces.context.FacesContext)


Occurences of saveState

saveState occurences:
javax.faces.component.html.HtmlColumn.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlCommandButton.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlCommandLink.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlDataTable.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlForm.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlGraphicImage.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlInputHidden.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlInputSecret.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlInputText.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlInputTextarea.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlMessage.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlMessages.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlOutputFormat.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlOutputLabel.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlOutputLink.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlOutputText.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlPanelGrid.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlPanelGroup.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlSelectBooleanCheckbox.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlSelectManyCheckbox.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlSelectManyListbox.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlSelectManyMenu.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlSelectOneListbox.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlSelectOneMenu.saveState(javax.faces.context.FacesContext)
javax.faces.component.html.HtmlSelectOneRadio.saveState(javax.faces.context.FacesContext)
javax.faces.component.StateHolder.saveState(javax.faces.context.FacesContext)
javax.faces.component.UICommand.saveState(javax.faces.context.FacesContext)
javax.faces.component.UIComponentBase.saveState(javax.faces.context.FacesContext)
javax.faces.component.UIData.saveState(javax.faces.context.FacesContext)
javax.faces.component.UIGraphic.saveState(javax.faces.context.FacesContext)
javax.faces.component.UIInput.saveState(javax.faces.context.FacesContext)
javax.faces.component.UIMessage.saveState(javax.faces.context.FacesContext)
javax.faces.component.UIMessages.saveState(javax.faces.context.FacesContext)
javax.faces.component.UIOutput.saveState(javax.faces.context.FacesContext)
javax.faces.component.UIParameter.saveState(javax.faces.context.FacesContext)
javax.faces.component.UISelectItem.saveState(javax.faces.context.FacesContext)
javax.faces.component.UISelectItems.saveState(javax.faces.context.FacesContext)
javax.faces.component.UIViewRoot.saveState(javax.faces.context.FacesContext)
javax.faces.convert.DateTimeConverter.saveState(javax.faces.context.FacesContext)
javax.faces.convert.EnumConverter.saveState(javax.faces.context.FacesContext)
javax.faces.convert.NumberConverter.saveState(javax.faces.context.FacesContext)
javax.faces.event.MethodExpressionActionListener.saveState(javax.faces.context.FacesContext)
javax.faces.event.MethodExpressionValueChangeListener.saveState(javax.faces.context.FacesContext)
javax.faces.validator.DoubleRangeValidator.saveState(javax.faces.context.FacesContext)
javax.faces.validator.LengthValidator.saveState(javax.faces.context.FacesContext)
javax.faces.validator.LongRangeValidator.saveState(javax.faces.context.FacesContext)
javax.faces.validator.MethodExpressionValidator.saveState(javax.faces.context.FacesContext)


Occurences of saveView

saveView occurences:
javax.faces.application.StateManager.saveView(javax.faces.context.FacesContext)
javax.faces.application.StateManagerWrapper.saveView(javax.faces.context.FacesContext)


Occurences of saxParserPlugable

saxParserPlugable occurences:
javax.xml.bind.helpers.saxParserPlugable
javax.xml.bind.saxParserPlugable


Occurences of ScalarDataModel (constructors)

ScalarDataModel (constructors) occurences:
javax.faces.model.ScalarDataModel()
javax.faces.model.ScalarDataModel(java.lang.Object)


Occurences of scheduleWork

scheduleWork occurences:
javax.resource.spi.work.WorkManager.scheduleWork(javax.resource.spi.work.Work)
javax.resource.spi.work.WorkManager.scheduleWork(javax.resource.spi.work.Work, long, javax.resource.spi.work.ExecutionContext, javax.resource.spi.work.WorkListener)


Occurences of schema

schema occurences:
javax.persistence.JoinTable.schema()
javax.persistence.SecondaryTable.schema()
javax.persistence.Table.schema()
javax.persistence.TableGenerator.schema()


Occurences of scope

scope occurences:
javax.xml.bind.annotation.XmlElementDecl.scope()
javax.xml.bind.scope


Occurences of search

search occurences:
javax.mail.Folder.search(javax.mail.search.SearchTerm)
javax.mail.Folder.search(javax.mail.search.SearchTerm, javax.mail.Message[])
javax.mail.search


Occurences of SearchException (constructors)

SearchException (constructors) occurences:
javax.mail.search.SearchException()
javax.mail.search.SearchException(java.lang.String)


Occurences of security

security occurences:
javax.annotation.security
javax.resource.spi.security


Occurences of SecurityException (constructors)

SecurityException (constructors) occurences:
javax.resource.spi.SecurityException()
javax.resource.spi.SecurityException(java.lang.String)
javax.resource.spi.SecurityException(java.lang.String, java.lang.String)
javax.resource.spi.SecurityException(java.lang.String, java.lang.Throwable)
javax.resource.spi.SecurityException(java.lang.Throwable)


Occurences of SelectItem (constructors)

SelectItem (constructors) occurences:
javax.faces.model.SelectItem()
javax.faces.model.SelectItem(java.lang.Object)
javax.faces.model.SelectItem(java.lang.Object, java.lang.String)
javax.faces.model.SelectItem(java.lang.Object, java.lang.String, java.lang.String)
javax.faces.model.SelectItem(java.lang.Object, java.lang.String, java.lang.String, boolean)
javax.faces.model.SelectItem(java.lang.Object, java.lang.String, java.lang.String, boolean, boolean)


Occurences of SelectItemGroup (constructors)

SelectItemGroup (constructors) occurences:
javax.faces.model.SelectItemGroup()
javax.faces.model.SelectItemGroup(java.lang.String)
javax.faces.model.SelectItemGroup(java.lang.String, java.lang.String, boolean, javax.faces.model.SelectItem[])


Occurences of send

send occurences:
javax.jms.MessageProducer.send(javax.jms.Destination, javax.jms.Message)
javax.jms.MessageProducer.send(javax.jms.Destination, javax.jms.Message, int, int, long)
javax.jms.MessageProducer.send(javax.jms.Message)
javax.jms.MessageProducer.send(javax.jms.Message, int, int, long)
javax.jms.QueueSender.send(javax.jms.Message)
javax.jms.QueueSender.send(javax.jms.Message, int, int, long)
javax.jms.QueueSender.send(javax.jms.Queue, javax.jms.Message)
javax.jms.QueueSender.send(javax.jms.Queue, javax.jms.Message, int, int, long)
javax.mail.Transport.send(javax.mail.Message)
javax.mail.Transport.send(javax.mail.Message, javax.mail.Address[])


Occurences of sendError

sendError occurences:
javax.servlet.http.HttpServletResponse.sendError(int)
javax.servlet.http.HttpServletResponse.sendError(int, java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.sendError(int)
javax.servlet.http.HttpServletResponseWrapper.sendError(int, java.lang.String)


Occurences of SendFailedException (constructors)

SendFailedException (constructors) occurences:
javax.mail.SendFailedException()
javax.mail.SendFailedException(java.lang.String)
javax.mail.SendFailedException(java.lang.String, java.lang.Exception)
javax.mail.SendFailedException(java.lang.String, java.lang.Exception, javax.mail.Address[], javax.mail.Address[], javax.mail.Address[])


Occurences of sendRedirect

sendRedirect occurences:
javax.servlet.http.HttpServletResponse.sendRedirect(java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.sendRedirect(java.lang.String)


Occurences of service

service occurences:
javax.faces.webapp.FacesServlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse)
javax.servlet.GenericServlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse)
javax.servlet.http.HttpServlet.service(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
javax.servlet.http.HttpServlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse)
javax.servlet.Servlet.service(javax.servlet.ServletRequest, javax.servlet.ServletResponse)


Occurences of Service

Service occurences:
javax.mail.Service
javax.xml.registry.infomodel.Service
javax.xml.rpc.Service
javax.xml.ws.Service


Occurences of Service (constructors)

Service (constructors) occurences:
javax.mail.Service(javax.mail.Session, javax.mail.URLName)
javax.xml.ws.Service(java.net.URL, javax.xml.namespace.QName)


Occurences of ServiceException (constructors)

ServiceException (constructors) occurences:
javax.xml.rpc.ServiceException()
javax.xml.rpc.ServiceException(java.lang.String)
javax.xml.rpc.ServiceException(java.lang.String, java.lang.Throwable)
javax.xml.rpc.ServiceException(java.lang.Throwable)


Occurences of serviceName

serviceName occurences:
javax.jws.WebService.serviceName()
javax.xml.ws.WebServiceProvider.serviceName()


Occurences of ServletException (constructors)

ServletException (constructors) occurences:
javax.servlet.ServletException()
javax.servlet.ServletException(java.lang.String)
javax.servlet.ServletException(java.lang.String, java.lang.Throwable)
javax.servlet.ServletException(java.lang.Throwable)


Occurences of Session

Session occurences:
javax.jms.Session
javax.mail.Session


Occurences of session

session occurences:
javax.mail.session
javax.mail.session


Occurences of SESSION_MAINTAIN_PROPERTY

SESSION_MAINTAIN_PROPERTY occurences:
javax.xml.rpc.SESSION_MAINTAIN_PROPERTY
javax.xml.rpc.SESSION_MAINTAIN_PROPERTY
javax.xml.ws.SESSION_MAINTAIN_PROPERTY


Occurences of set

set occurences:
javax.activation.MimeTypeParameterList.set(java.lang.String, java.lang.String)
javax.mail.internet.ParameterList.set(java.lang.String, java.lang.String)
javax.mail.internet.ParameterList.set(java.lang.String, java.lang.String, java.lang.String)
javax.mail.search.set


Occurences of setAccesskey

setAccesskey occurences:
javax.faces.component.html.HtmlCommandButton.setAccesskey(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setAccesskey(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setAccesskey(java.lang.String)
javax.faces.component.html.HtmlInputText.setAccesskey(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setAccesskey(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setAccesskey(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setAccesskey(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setAccesskey(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setAccesskey(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setAccesskey(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setAccesskey(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setAccesskey(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setAccesskey(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setAccesskey(java.lang.String)


Occurences of setAction

setAction occurences:
javax.faces.component.ActionSource.setAction(javax.faces.el.MethodBinding)
javax.faces.component.UICommand.setAction(javax.faces.el.MethodBinding)


Occurences of setActionExpression

setActionExpression occurences:
javax.faces.component.ActionSource2.setActionExpression(javax.el.MethodExpression)
javax.faces.component.UICommand.setActionExpression(javax.el.MethodExpression)


Occurences of setActionListener

setActionListener occurences:
javax.faces.application.Application.setActionListener(javax.faces.event.ActionListener)
javax.faces.component.ActionSource.setActionListener(javax.faces.el.MethodBinding)
javax.faces.component.UICommand.setActionListener(javax.faces.el.MethodBinding)


Occurences of setAdapter

setAdapter occurences:
javax.xml.bind.helpers.AbstractMarshallerImpl.setAdapter(java.lang.Class, A)
javax.xml.bind.helpers.AbstractMarshallerImpl.setAdapter(java.lang.Class,javax.xml.bind.annotation.adapters.XmlAdapter)
javax.xml.bind.helpers.AbstractMarshallerImpl.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.setAdapter(java.lang.Class, A)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.setAdapter(java.lang.Class,javax.xml.bind.annotation.adapters.XmlAdapter)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter)
javax.xml.bind.Marshaller.setAdapter(java.lang.Class, A)
javax.xml.bind.Marshaller.setAdapter(java.lang.Class,javax.xml.bind.annotation.adapters.XmlAdapter)
javax.xml.bind.Marshaller.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter)
javax.xml.bind.Unmarshaller.setAdapter(java.lang.Class, A)
javax.xml.bind.Unmarshaller.setAdapter(java.lang.Class,javax.xml.bind.annotation.adapters.XmlAdapter)
javax.xml.bind.Unmarshaller.setAdapter(javax.xml.bind.annotation.adapters.XmlAdapter)


Occurences of setAddress

setAddress occurences:
javax.mail.internet.InternetAddress.setAddress(java.lang.String)
javax.xml.registry.infomodel.EmailAddress.setAddress(java.lang.String)


Occurences of setAlt

setAlt occurences:
javax.faces.component.html.HtmlCommandButton.setAlt(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setAlt(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setAlt(java.lang.String)
javax.faces.component.html.HtmlInputText.setAlt(java.lang.String)


Occurences of setAttachmentMarshaller

setAttachmentMarshaller occurences:
javax.xml.bind.helpers.AbstractMarshallerImpl.setAttachmentMarshaller(javax.xml.bind.attachment.AttachmentMarshaller)
javax.xml.bind.Marshaller.setAttachmentMarshaller(javax.xml.bind.attachment.AttachmentMarshaller)


Occurences of setAttachmentUnmarshaller

setAttachmentUnmarshaller occurences:
javax.xml.bind.helpers.AbstractUnmarshallerImpl.setAttachmentUnmarshaller(javax.xml.bind.attachment.AttachmentUnmarshaller)
javax.xml.bind.Unmarshaller.setAttachmentUnmarshaller(javax.xml.bind.attachment.AttachmentUnmarshaller)


Occurences of setAttribute

setAttribute occurences:
javax.management.j2ee.Management.setAttribute(javax.management.ObjectName, javax.management.Attribute)
javax.servlet.http.HttpSession.setAttribute(java.lang.String, java.lang.Object)
javax.servlet.jsp.JspContext.setAttribute(java.lang.String, java.lang.Object)
javax.servlet.jsp.JspContext.setAttribute(java.lang.String, java.lang.Object, int)
javax.servlet.jsp.tagext.TagData.setAttribute(java.lang.String, java.lang.Object)
javax.servlet.ServletContext.setAttribute(java.lang.String, java.lang.Object)
javax.servlet.ServletRequest.setAttribute(java.lang.String, java.lang.Object)
javax.servlet.ServletRequestWrapper.setAttribute(java.lang.String, java.lang.Object)


Occurences of setAutocomplete

setAutocomplete occurences:
javax.faces.component.html.HtmlInputSecret.setAutocomplete(java.lang.String)
javax.faces.component.html.HtmlInputText.setAutocomplete(java.lang.String)


Occurences of setBgcolor

setBgcolor occurences:
javax.faces.component.html.HtmlDataTable.setBgcolor(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setBgcolor(java.lang.String)


Occurences of setBinding

setBinding occurences:
javax.faces.webapp.ConverterTag.setBinding(java.lang.String)
javax.faces.webapp.UIComponentELTag.setBinding(javax.el.ValueExpression)
javax.faces.webapp.UIComponentTag.setBinding(java.lang.String)
javax.faces.webapp.ValidatorTag.setBinding(java.lang.String)


Occurences of setBodyContent

setBodyContent occurences:
javax.faces.webapp.UIComponentClassicTagBase.setBodyContent(javax.servlet.jsp.tagext.BodyContent)
javax.servlet.jsp.tagext.BodyTag.setBodyContent(javax.servlet.jsp.tagext.BodyContent)
javax.servlet.jsp.tagext.BodyTagSupport.setBodyContent(javax.servlet.jsp.tagext.BodyContent)


Occurences of setBorder

setBorder occurences:
javax.faces.component.html.HtmlDataTable.setBorder(int)
javax.faces.component.html.HtmlPanelGrid.setBorder(int)
javax.faces.component.html.HtmlSelectManyCheckbox.setBorder(int)
javax.faces.component.html.HtmlSelectOneRadio.setBorder(int)


Occurences of setBufferSize

setBufferSize occurences:
javax.servlet.ServletResponse.setBufferSize(int)
javax.servlet.ServletResponseWrapper.setBufferSize(int)


Occurences of setBytes

setBytes occurences:
javax.jms.MapMessage.setBytes(java.lang.String, byte[])
javax.jms.MapMessage.setBytes(java.lang.String, byte[], int, int)


Occurences of setCaptionClass

setCaptionClass occurences:
javax.faces.component.html.HtmlDataTable.setCaptionClass(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setCaptionClass(java.lang.String)


Occurences of setCaptionStyle

setCaptionStyle occurences:
javax.faces.component.html.HtmlDataTable.setCaptionStyle(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setCaptionStyle(java.lang.String)


Occurences of setCellpadding

setCellpadding occurences:
javax.faces.component.html.HtmlDataTable.setCellpadding(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setCellpadding(java.lang.String)


Occurences of setCellspacing

setCellspacing occurences:
javax.faces.component.html.HtmlDataTable.setCellspacing(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setCellspacing(java.lang.String)


Occurences of setCharacterEncoding

setCharacterEncoding occurences:
javax.servlet.ServletRequest.setCharacterEncoding(java.lang.String)
javax.servlet.ServletRequestWrapper.setCharacterEncoding(java.lang.String)
javax.servlet.ServletResponse.setCharacterEncoding(java.lang.String)
javax.servlet.ServletResponseWrapper.setCharacterEncoding(java.lang.String)


Occurences of setCharset

setCharset occurences:
javax.faces.component.html.HtmlCommandLink.setCharset(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setCharset(java.lang.String)


Occurences of setColumnClasses

setColumnClasses occurences:
javax.faces.component.html.HtmlDataTable.setColumnClasses(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setColumnClasses(java.lang.String)


Occurences of setContent

setContent occurences:
javax.mail.internet.MimeBodyPart.setContent(java.lang.Object, java.lang.String)
javax.mail.internet.MimeBodyPart.setContent(javax.mail.Multipart)
javax.mail.internet.MimeMessage.setContent(java.lang.Object, java.lang.String)
javax.mail.internet.MimeMessage.setContent(javax.mail.Multipart)
javax.mail.Part.setContent(java.lang.Object, java.lang.String)
javax.mail.Part.setContent(javax.mail.Multipart)
javax.xml.soap.AttachmentPart.setContent(java.lang.Object, java.lang.String)
javax.xml.soap.SOAPPart.setContent(javax.xml.transform.Source)


Occurences of setContentId

setContentId occurences:
javax.xml.soap.AttachmentPart.setContentId(java.lang.String)
javax.xml.soap.SOAPPart.setContentId(java.lang.String)


Occurences of setContentID

setContentID occurences:
javax.mail.internet.MimeBodyPart.setContentID(java.lang.String)
javax.mail.internet.MimeMessage.setContentID(java.lang.String)


Occurences of setContentLanguage

setContentLanguage occurences:
javax.mail.internet.MimeBodyPart.setContentLanguage(java.lang.String[])
javax.mail.internet.MimeMessage.setContentLanguage(java.lang.String[])
javax.mail.internet.MimePart.setContentLanguage(java.lang.String[])


Occurences of setContentLength

setContentLength occurences:
javax.servlet.ServletResponse.setContentLength(int)
javax.servlet.ServletResponseWrapper.setContentLength(int)


Occurences of setContentLocation

setContentLocation occurences:
javax.xml.soap.AttachmentPart.setContentLocation(java.lang.String)
javax.xml.soap.SOAPPart.setContentLocation(java.lang.String)


Occurences of setContentMD5

setContentMD5 occurences:
javax.mail.internet.MimeBodyPart.setContentMD5(java.lang.String)
javax.mail.internet.MimeMessage.setContentMD5(java.lang.String)
javax.mail.internet.MimePart.setContentMD5(java.lang.String)


Occurences of setContentType

setContentType occurences:
javax.servlet.ServletResponse.setContentType(java.lang.String)
javax.servlet.ServletResponseWrapper.setContentType(java.lang.String)
javax.xml.soap.AttachmentPart.setContentType(java.lang.String)


Occurences of setConverter

setConverter occurences:
javax.faces.component.UIOutput.setConverter(javax.faces.convert.Converter)
javax.faces.component.ValueHolder.setConverter(javax.faces.convert.Converter)


Occurences of setCoords

setCoords occurences:
javax.faces.component.html.HtmlCommandLink.setCoords(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setCoords(java.lang.String)


Occurences of setDataHandler

setDataHandler occurences:
javax.mail.internet.MimeBodyPart.setDataHandler(javax.activation.DataHandler)
javax.mail.internet.MimeMessage.setDataHandler(javax.activation.DataHandler)
javax.mail.Part.setDataHandler(javax.activation.DataHandler)
javax.xml.soap.AttachmentPart.setDataHandler(javax.activation.DataHandler)


Occurences of setDateHeader

setDateHeader occurences:
javax.servlet.http.HttpServletResponse.setDateHeader(java.lang.String, long)
javax.servlet.http.HttpServletResponseWrapper.setDateHeader(java.lang.String, long)


Occurences of setDefaultNamespace

setDefaultNamespace occurences:
javax.xml.stream.XMLEventWriter.setDefaultNamespace(java.lang.String)
javax.xml.stream.XMLStreamWriter.setDefaultNamespace(java.lang.String)


Occurences of setDescription

setDescription occurences:
javax.faces.model.SelectItem.setDescription(java.lang.String)
javax.mail.internet.MimeBodyPart.setDescription(java.lang.String)
javax.mail.internet.MimeBodyPart.setDescription(java.lang.String, java.lang.String)
javax.mail.internet.MimeMessage.setDescription(java.lang.String)
javax.mail.internet.MimeMessage.setDescription(java.lang.String, java.lang.String)
javax.mail.Part.setDescription(java.lang.String)
javax.xml.registry.infomodel.RegistryObject.setDescription(javax.xml.registry.infomodel.InternationalString)


Occurences of setDir

setDir occurences:
javax.faces.component.html.HtmlCommandButton.setDir(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setDir(java.lang.String)
javax.faces.component.html.HtmlDataTable.setDir(java.lang.String)
javax.faces.component.html.HtmlForm.setDir(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setDir(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setDir(java.lang.String)
javax.faces.component.html.HtmlInputText.setDir(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setDir(java.lang.String)
javax.faces.component.html.HtmlMessage.setDir(java.lang.String)
javax.faces.component.html.HtmlMessages.setDir(java.lang.String)
javax.faces.component.html.HtmlOutputFormat.setDir(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setDir(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setDir(java.lang.String)
javax.faces.component.html.HtmlOutputText.setDir(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setDir(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setDir(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setDir(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setDir(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setDir(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setDir(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setDir(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setDir(java.lang.String)


Occurences of setDisabled

setDisabled occurences:
javax.faces.component.html.HtmlCommandButton.setDisabled(boolean)
javax.faces.component.html.HtmlCommandLink.setDisabled(boolean)
javax.faces.component.html.HtmlInputSecret.setDisabled(boolean)
javax.faces.component.html.HtmlInputText.setDisabled(boolean)
javax.faces.component.html.HtmlInputTextarea.setDisabled(boolean)
javax.faces.component.html.HtmlOutputLink.setDisabled(boolean)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setDisabled(boolean)
javax.faces.component.html.HtmlSelectManyCheckbox.setDisabled(boolean)
javax.faces.component.html.HtmlSelectManyListbox.setDisabled(boolean)
javax.faces.component.html.HtmlSelectManyMenu.setDisabled(boolean)
javax.faces.component.html.HtmlSelectOneListbox.setDisabled(boolean)
javax.faces.component.html.HtmlSelectOneMenu.setDisabled(boolean)
javax.faces.component.html.HtmlSelectOneRadio.setDisabled(boolean)
javax.faces.model.SelectItem.setDisabled(boolean)


Occurences of setDisabledClass

setDisabledClass occurences:
javax.faces.component.html.HtmlSelectManyCheckbox.setDisabledClass(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setDisabledClass(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setDisabledClass(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setDisabledClass(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setDisabledClass(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setDisabledClass(java.lang.String)


Occurences of setDisposition

setDisposition occurences:
javax.mail.internet.ContentDisposition.setDisposition(java.lang.String)
javax.mail.internet.MimeBodyPart.setDisposition(java.lang.String)
javax.mail.internet.MimeMessage.setDisposition(java.lang.String)
javax.mail.Part.setDisposition(java.lang.String)


Occurences of setEnabledClass

setEnabledClass occurences:
javax.faces.component.html.HtmlSelectManyCheckbox.setEnabledClass(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setEnabledClass(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setEnabledClass(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setEnabledClass(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setEnabledClass(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setEnabledClass(java.lang.String)


Occurences of setErrorClass

setErrorClass occurences:
javax.faces.component.html.HtmlMessage.setErrorClass(java.lang.String)
javax.faces.component.html.HtmlMessages.setErrorClass(java.lang.String)


Occurences of setErrorStyle

setErrorStyle occurences:
javax.faces.component.html.HtmlMessage.setErrorStyle(java.lang.String)
javax.faces.component.html.HtmlMessages.setErrorStyle(java.lang.String)


Occurences of setEscape

setEscape occurences:
javax.faces.component.html.HtmlOutputFormat.setEscape(boolean)
javax.faces.component.html.HtmlOutputLabel.setEscape(boolean)
javax.faces.component.html.HtmlOutputText.setEscape(boolean)
javax.faces.model.SelectItem.setEscape(boolean)


Occurences of setEventHandler

setEventHandler occurences:
javax.xml.bind.Binder.setEventHandler(javax.xml.bind.ValidationEventHandler)
javax.xml.bind.helpers.AbstractMarshallerImpl.setEventHandler(javax.xml.bind.ValidationEventHandler)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.setEventHandler(javax.xml.bind.ValidationEventHandler)
javax.xml.bind.Marshaller.setEventHandler(javax.xml.bind.ValidationEventHandler)
javax.xml.bind.Unmarshaller.setEventHandler(javax.xml.bind.ValidationEventHandler)
javax.xml.bind.Validator.setEventHandler(javax.xml.bind.ValidationEventHandler)


Occurences of setExecutor

setExecutor occurences:
javax.xml.ws.Endpoint.setExecutor(java.util.concurrent.Executor)
javax.xml.ws.Service.setExecutor(java.util.concurrent.Executor)
javax.xml.ws.spi.ServiceDelegate.setExecutor(java.util.concurrent.Executor)


Occurences of setFatalClass

setFatalClass occurences:
javax.faces.component.html.HtmlMessage.setFatalClass(java.lang.String)
javax.faces.component.html.HtmlMessages.setFatalClass(java.lang.String)


Occurences of setFatalStyle

setFatalStyle occurences:
javax.faces.component.html.HtmlMessage.setFatalStyle(java.lang.String)
javax.faces.component.html.HtmlMessages.setFatalStyle(java.lang.String)


Occurences of setFaultCode

setFaultCode occurences:
javax.xml.soap.SOAPFault.setFaultCode(java.lang.String)
javax.xml.soap.SOAPFault.setFaultCode(javax.xml.namespace.QName)
javax.xml.soap.SOAPFault.setFaultCode(javax.xml.soap.Name)


Occurences of setFaultString

setFaultString occurences:
javax.xml.soap.SOAPFault.setFaultString(java.lang.String)
javax.xml.soap.SOAPFault.setFaultString(java.lang.String, java.util.Locale)


Occurences of setFileName

setFileName occurences:
javax.mail.internet.MimeBodyPart.setFileName(java.lang.String)
javax.mail.internet.MimeMessage.setFileName(java.lang.String)
javax.mail.Part.setFileName(java.lang.String)


Occurences of setFlags

setFlags occurences:
javax.mail.Folder.setFlags(int, int, javax.mail.Flags, boolean)
javax.mail.Folder.setFlags(int[], javax.mail.Flags, boolean)
javax.mail.Folder.setFlags(javax.mail.Message[], javax.mail.Flags, boolean)
javax.mail.internet.MimeMessage.setFlags(javax.mail.Flags, boolean)
javax.mail.Message.setFlags(javax.mail.Flags, boolean)


Occurences of setFlushMode

setFlushMode occurences:
javax.persistence.EntityManager.setFlushMode(javax.persistence.FlushModeType)
javax.persistence.Query.setFlushMode(javax.persistence.FlushModeType)


Occurences of setFooter

setFooter occurences:
javax.faces.component.UIColumn.setFooter(javax.faces.component.UIComponent)
javax.faces.component.UIData.setFooter(javax.faces.component.UIComponent)


Occurences of setFooterClass

setFooterClass occurences:
javax.faces.component.html.HtmlColumn.setFooterClass(java.lang.String)
javax.faces.component.html.HtmlDataTable.setFooterClass(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setFooterClass(java.lang.String)


Occurences of setFor

setFor occurences:
javax.faces.component.html.HtmlOutputLabel.setFor(java.lang.String)
javax.faces.component.UIMessage.setFor(java.lang.String)


Occurences of setFrame

setFrame occurences:
javax.faces.component.html.HtmlDataTable.setFrame(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setFrame(java.lang.String)


Occurences of setFrom

setFrom occurences:
javax.mail.internet.MimeMessage.setFrom()
javax.mail.internet.MimeMessage.setFrom(javax.mail.Address)
javax.mail.Message.setFrom()
javax.mail.Message.setFrom(javax.mail.Address)


Occurences of setHandlerChain

setHandlerChain occurences:
javax.xml.rpc.handler.HandlerRegistry.setHandlerChain(javax.xml.namespace.QName, java.util.List)
javax.xml.ws.Binding.setHandlerChain(java.util.List)


Occurences of setHandlerResolver

setHandlerResolver occurences:
javax.xml.ws.Service.setHandlerResolver(javax.xml.ws.handler.HandlerResolver)
javax.xml.ws.spi.ServiceDelegate.setHandlerResolver(javax.xml.ws.handler.HandlerResolver)


Occurences of setHeader

setHeader occurences:
javax.faces.component.UIColumn.setHeader(javax.faces.component.UIComponent)
javax.faces.component.UIData.setHeader(javax.faces.component.UIComponent)
javax.mail.internet.InternetHeaders.setHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimeBodyPart.setHeader(java.lang.String, java.lang.String)
javax.mail.internet.MimeMessage.setHeader(java.lang.String, java.lang.String)
javax.mail.Part.setHeader(java.lang.String, java.lang.String)
javax.servlet.http.HttpServletResponse.setHeader(java.lang.String, java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.setHeader(java.lang.String, java.lang.String)
javax.xml.soap.MimeHeaders.setHeader(java.lang.String, java.lang.String)


Occurences of setHeaderClass

setHeaderClass occurences:
javax.faces.component.html.HtmlColumn.setHeaderClass(java.lang.String)
javax.faces.component.html.HtmlDataTable.setHeaderClass(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setHeaderClass(java.lang.String)


Occurences of setHreflang

setHreflang occurences:
javax.faces.component.html.HtmlCommandLink.setHreflang(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setHreflang(java.lang.String)


Occurences of setId

setId occurences:
javax.faces.component.UIComponent.setId(java.lang.String)
javax.faces.component.UIComponentBase.setId(java.lang.String)
javax.faces.webapp.UIComponentClassicTagBase.setId(java.lang.String)
javax.faces.webapp.UIComponentTagBase.setId(java.lang.String)
javax.servlet.jsp.tagext.TagSupport.setId(java.lang.String)
javax.xml.registry.infomodel.Key.setId(java.lang.String)


Occurences of setImmediate

setImmediate occurences:
javax.faces.component.ActionSource.setImmediate(boolean)
javax.faces.component.EditableValueHolder.setImmediate(boolean)
javax.faces.component.UICommand.setImmediate(boolean)
javax.faces.component.UIInput.setImmediate(boolean)


Occurences of setInfoClass

setInfoClass occurences:
javax.faces.component.html.HtmlMessage.setInfoClass(java.lang.String)
javax.faces.component.html.HtmlMessages.setInfoClass(java.lang.String)


Occurences of setInfoStyle

setInfoStyle occurences:
javax.faces.component.html.HtmlMessage.setInfoStyle(java.lang.String)
javax.faces.component.html.HtmlMessages.setInfoStyle(java.lang.String)


Occurences of setIntHeader

setIntHeader occurences:
javax.servlet.http.HttpServletResponse.setIntHeader(java.lang.String, int)
javax.servlet.http.HttpServletResponseWrapper.setIntHeader(java.lang.String, int)


Occurences of setJspBody

setJspBody occurences:
javax.servlet.jsp.tagext.SimpleTag.setJspBody(javax.servlet.jsp.tagext.JspFragment)
javax.servlet.jsp.tagext.SimpleTagSupport.setJspBody(javax.servlet.jsp.tagext.JspFragment)


Occurences of setJspContext

setJspContext occurences:
javax.servlet.jsp.tagext.SimpleTag.setJspContext(javax.servlet.jsp.JspContext)
javax.servlet.jsp.tagext.SimpleTagSupport.setJspContext(javax.servlet.jsp.JspContext)


Occurences of setJspId

setJspId occurences:
javax.faces.webapp.UIComponentClassicTagBase.setJspId(java.lang.String)
javax.servlet.jsp.tagext.JspIdConsumer.setJspId(java.lang.String)


Occurences of setLabel

setLabel occurences:
javax.faces.component.html.HtmlCommandButton.setLabel(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setLabel(java.lang.String)
javax.faces.component.html.HtmlInputText.setLabel(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setLabel(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setLabel(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setLabel(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setLabel(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setLabel(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setLabel(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setLabel(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setLabel(java.lang.String)
javax.faces.model.SelectItem.setLabel(java.lang.String)


Occurences of setLang

setLang occurences:
javax.faces.component.html.HtmlCommandButton.setLang(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setLang(java.lang.String)
javax.faces.component.html.HtmlDataTable.setLang(java.lang.String)
javax.faces.component.html.HtmlForm.setLang(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setLang(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setLang(java.lang.String)
javax.faces.component.html.HtmlInputText.setLang(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setLang(java.lang.String)
javax.faces.component.html.HtmlMessage.setLang(java.lang.String)
javax.faces.component.html.HtmlMessages.setLang(java.lang.String)
javax.faces.component.html.HtmlOutputFormat.setLang(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setLang(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setLang(java.lang.String)
javax.faces.component.html.HtmlOutputText.setLang(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setLang(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setLang(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setLang(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setLang(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setLang(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setLang(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setLang(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setLang(java.lang.String)


Occurences of setLayout

setLayout occurences:
javax.faces.component.html.HtmlMessages.setLayout(java.lang.String)
javax.faces.component.html.HtmlPanelGroup.setLayout(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setLayout(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setLayout(java.lang.String)


Occurences of setLinkedException

setLinkedException occurences:
javax.jms.JMSException.setLinkedException(java.lang.Exception)
javax.resource.ResourceException.setLinkedException(java.lang.Exception)
javax.xml.bind.helpers.ValidationEventImpl.setLinkedException(java.lang.Throwable)
javax.xml.bind.JAXBException.setLinkedException(java.lang.Throwable)
javax.xml.bind.TypeConstraintException.setLinkedException(java.lang.Throwable)


Occurences of setListener

setListener occurences:
javax.xml.bind.helpers.AbstractMarshallerImpl.setListener(javax.xml.bind.Marshaller.Listener)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.setListener(javax.xml.bind.Unmarshaller.Listener)
javax.xml.bind.Marshaller.setListener(javax.xml.bind.Marshaller.Listener)
javax.xml.bind.Unmarshaller.setListener(javax.xml.bind.Unmarshaller.Listener)


Occurences of setLocale

setLocale occurences:
javax.el.ELContext.setLocale(java.util.Locale)
javax.enterprise.deploy.spi.DeploymentManager.setLocale(java.util.Locale)
javax.faces.component.UIViewRoot.setLocale(java.util.Locale)
javax.faces.convert.DateTimeConverter.setLocale(java.util.Locale)
javax.faces.convert.NumberConverter.setLocale(java.util.Locale)
javax.servlet.ServletResponse.setLocale(java.util.Locale)
javax.servlet.ServletResponseWrapper.setLocale(java.util.Locale)
javax.xml.registry.infomodel.LocalizedString.setLocale(java.util.Locale)


Occurences of setLocalValueSet

setLocalValueSet occurences:
javax.faces.component.EditableValueHolder.setLocalValueSet(boolean)
javax.faces.component.UIInput.setLocalValueSet(boolean)


Occurences of setLogWriter

setLogWriter occurences:
javax.resource.spi.ManagedConnection.setLogWriter(java.io.PrintWriter)
javax.resource.spi.ManagedConnectionFactory.setLogWriter(java.io.PrintWriter)


Occurences of setMaximum

setMaximum occurences:
javax.faces.validator.DoubleRangeValidator.setMaximum(double)
javax.faces.validator.LengthValidator.setMaximum(int)
javax.faces.validator.LongRangeValidator.setMaximum(long)


Occurences of setMaxlength

setMaxlength occurences:
javax.faces.component.html.HtmlInputSecret.setMaxlength(int)
javax.faces.component.html.HtmlInputText.setMaxlength(int)


Occurences of setMessage

setMessage occurences:
javax.xml.bind.helpers.ValidationEventImpl.setMessage(java.lang.String)
javax.xml.rpc.handler.soap.SOAPMessageContext.setMessage(javax.xml.soap.SOAPMessage)
javax.xml.ws.handler.soap.SOAPMessageContext.setMessage(javax.xml.soap.SOAPMessage)


Occurences of setMessageListener

setMessageListener occurences:
javax.jms.MessageConsumer.setMessageListener(javax.jms.MessageListener)
javax.jms.Session.setMessageListener(javax.jms.MessageListener)


Occurences of setMimeHeader

setMimeHeader occurences:
javax.xml.soap.AttachmentPart.setMimeHeader(java.lang.String, java.lang.String)
javax.xml.soap.SOAPPart.setMimeHeader(java.lang.String, java.lang.String)


Occurences of setMinimum

setMinimum occurences:
javax.faces.validator.DoubleRangeValidator.setMinimum(double)
javax.faces.validator.LengthValidator.setMinimum(int)
javax.faces.validator.LongRangeValidator.setMinimum(long)


Occurences of setName

setName occurences:
javax.faces.component.UIParameter.setName(java.lang.String)
javax.faces.webapp.AttributeTag.setName(java.lang.String)
javax.faces.webapp.FacetTag.setName(java.lang.String)
javax.mail.util.ByteArrayDataSource.setName(java.lang.String)
javax.xml.registry.infomodel.RegistryObject.setName(javax.xml.registry.infomodel.InternationalString)
javax.xml.registry.infomodel.Slot.setName(java.lang.String)


Occurences of setNamespaceContext

setNamespaceContext occurences:
javax.xml.stream.XMLEventWriter.setNamespaceContext(javax.xml.namespace.NamespaceContext)
javax.xml.stream.XMLStreamWriter.setNamespaceContext(javax.xml.namespace.NamespaceContext)


Occurences of setObject

setObject occurences:
javax.jms.MapMessage.setObject(java.lang.String, java.lang.Object)
javax.jms.ObjectMessage.setObject(java.io.Serializable)
javax.xml.bind.helpers.ValidationEventLocatorImpl.setObject(java.lang.Object)


Occurences of setOnblur

setOnblur occurences:
javax.faces.component.html.HtmlCommandButton.setOnblur(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setOnblur(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOnblur(java.lang.String)
javax.faces.component.html.HtmlInputText.setOnblur(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOnblur(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setOnblur(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setOnblur(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOnblur(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOnblur(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOnblur(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOnblur(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOnblur(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOnblur(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOnblur(java.lang.String)


Occurences of setOnchange

setOnchange occurences:
javax.faces.component.html.HtmlCommandButton.setOnchange(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOnchange(java.lang.String)
javax.faces.component.html.HtmlInputText.setOnchange(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOnchange(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOnchange(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOnchange(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOnchange(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOnchange(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOnchange(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOnchange(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOnchange(java.lang.String)


Occurences of setOnclick

setOnclick occurences:
javax.faces.component.html.HtmlCommandButton.setOnclick(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setOnclick(java.lang.String)
javax.faces.component.html.HtmlDataTable.setOnclick(java.lang.String)
javax.faces.component.html.HtmlForm.setOnclick(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setOnclick(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOnclick(java.lang.String)
javax.faces.component.html.HtmlInputText.setOnclick(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOnclick(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setOnclick(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setOnclick(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setOnclick(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOnclick(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOnclick(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOnclick(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOnclick(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOnclick(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOnclick(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOnclick(java.lang.String)


Occurences of setOndblclick

setOndblclick occurences:
javax.faces.component.html.HtmlCommandButton.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlDataTable.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlForm.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlInputText.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOndblclick(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOndblclick(java.lang.String)


Occurences of setOnfocus

setOnfocus occurences:
javax.faces.component.html.HtmlCommandButton.setOnfocus(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setOnfocus(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOnfocus(java.lang.String)
javax.faces.component.html.HtmlInputText.setOnfocus(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOnfocus(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setOnfocus(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setOnfocus(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOnfocus(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOnfocus(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOnfocus(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOnfocus(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOnfocus(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOnfocus(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOnfocus(java.lang.String)


Occurences of setOnkeydown

setOnkeydown occurences:
javax.faces.component.html.HtmlCommandButton.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlDataTable.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlForm.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlInputText.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOnkeydown(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOnkeydown(java.lang.String)


Occurences of setOnkeypress

setOnkeypress occurences:
javax.faces.component.html.HtmlCommandButton.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlDataTable.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlForm.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlInputText.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOnkeypress(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOnkeypress(java.lang.String)


Occurences of setOnkeyup

setOnkeyup occurences:
javax.faces.component.html.HtmlCommandButton.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlDataTable.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlForm.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlInputText.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOnkeyup(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOnkeyup(java.lang.String)


Occurences of setOnmousedown

setOnmousedown occurences:
javax.faces.component.html.HtmlCommandButton.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlDataTable.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlForm.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlInputText.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOnmousedown(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOnmousedown(java.lang.String)


Occurences of setOnmousemove

setOnmousemove occurences:
javax.faces.component.html.HtmlCommandButton.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlDataTable.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlForm.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlInputText.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOnmousemove(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOnmousemove(java.lang.String)


Occurences of setOnmouseout

setOnmouseout occurences:
javax.faces.component.html.HtmlCommandButton.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlDataTable.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlForm.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlInputText.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOnmouseout(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOnmouseout(java.lang.String)


Occurences of setOnmouseover

setOnmouseover occurences:
javax.faces.component.html.HtmlCommandButton.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlDataTable.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlForm.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlInputText.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOnmouseover(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOnmouseover(java.lang.String)


Occurences of setOnmouseup

setOnmouseup occurences:
javax.faces.component.html.HtmlCommandButton.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlDataTable.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlForm.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlInputText.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOnmouseup(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOnmouseup(java.lang.String)


Occurences of setOnselect

setOnselect occurences:
javax.faces.component.html.HtmlCommandButton.setOnselect(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setOnselect(java.lang.String)
javax.faces.component.html.HtmlInputText.setOnselect(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setOnselect(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setOnselect(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setOnselect(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setOnselect(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setOnselect(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setOnselect(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setOnselect(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setOnselect(java.lang.String)


Occurences of setPageContext

setPageContext occurences:
javax.faces.webapp.UIComponentClassicTagBase.setPageContext(javax.servlet.jsp.PageContext)
javax.servlet.jsp.tagext.Tag.setPageContext(javax.servlet.jsp.PageContext)
javax.servlet.jsp.tagext.TagAdapter.setPageContext(javax.servlet.jsp.PageContext)
javax.servlet.jsp.tagext.TagSupport.setPageContext(javax.servlet.jsp.PageContext)


Occurences of setParameter

setParameter occurences:
javax.activation.MimeType.setParameter(java.lang.String, java.lang.String)
javax.mail.internet.ContentDisposition.setParameter(java.lang.String, java.lang.String)
javax.mail.internet.ContentType.setParameter(java.lang.String, java.lang.String)
javax.persistence.Query.setParameter(int, java.lang.Object)
javax.persistence.Query.setParameter(int, java.util.Calendar, javax.persistence.TemporalType)
javax.persistence.Query.setParameter(int, java.util.Date, javax.persistence.TemporalType)
javax.persistence.Query.setParameter(java.lang.String, java.lang.Object)
javax.persistence.Query.setParameter(java.lang.String, java.util.Calendar, javax.persistence.TemporalType)
javax.persistence.Query.setParameter(java.lang.String, java.util.Date, javax.persistence.TemporalType)


Occurences of setParameterList

setParameterList occurences:
javax.mail.internet.ContentDisposition.setParameterList(javax.mail.internet.ParameterList)
javax.mail.internet.ContentType.setParameterList(javax.mail.internet.ParameterList)


Occurences of setParent

setParent occurences:
javax.faces.component.UIComponent.setParent(javax.faces.component.UIComponent)
javax.faces.component.UIComponentBase.setParent(javax.faces.component.UIComponent)
javax.faces.webapp.UIComponentClassicTagBase.setParent(javax.servlet.jsp.tagext.Tag)
javax.mail.Multipart.setParent(javax.mail.Part)
javax.servlet.jsp.tagext.SimpleTag.setParent(javax.servlet.jsp.tagext.JspTag)
javax.servlet.jsp.tagext.SimpleTagSupport.setParent(javax.servlet.jsp.tagext.JspTag)
javax.servlet.jsp.tagext.Tag.setParent(javax.servlet.jsp.tagext.Tag)
javax.servlet.jsp.tagext.TagAdapter.setParent(javax.servlet.jsp.tagext.Tag)
javax.servlet.jsp.tagext.TagSupport.setParent(javax.servlet.jsp.tagext.Tag)
javax.xml.stream.util.EventReaderDelegate.setParent(javax.xml.stream.XMLEventReader)
javax.xml.stream.util.StreamReaderDelegate.setParent(javax.xml.stream.XMLStreamReader)


Occurences of setPattern

setPattern occurences:
javax.faces.convert.DateTimeConverter.setPattern(java.lang.String)
javax.faces.convert.NumberConverter.setPattern(java.lang.String)


Occurences of setPayload

setPayload occurences:
javax.xml.ws.LogicalMessage.setPayload(java.lang.Object, javax.xml.bind.JAXBContext)
javax.xml.ws.LogicalMessage.setPayload(javax.xml.transform.Source)


Occurences of setPersonal

setPersonal occurences:
javax.mail.internet.InternetAddress.setPersonal(java.lang.String)
javax.mail.internet.InternetAddress.setPersonal(java.lang.String, java.lang.String)


Occurences of setPrefix

setPrefix occurences:
javax.xml.stream.XMLEventWriter.setPrefix(java.lang.String, java.lang.String)
javax.xml.stream.XMLStreamWriter.setPrefix(java.lang.String, java.lang.String)


Occurences of setPrimaryType

setPrimaryType occurences:
javax.activation.MimeType.setPrimaryType(java.lang.String)
javax.mail.internet.ContentType.setPrimaryType(java.lang.String)


Occurences of setProperties

setProperties occurences:
javax.faces.webapp.UIComponentClassicTagBase.setProperties(javax.faces.component.UIComponent)
javax.faces.webapp.UIComponentELTag.setProperties(javax.faces.component.UIComponent)
javax.faces.webapp.UIComponentTag.setProperties(javax.faces.component.UIComponent)
javax.xml.registry.ConnectionFactory.setProperties(java.util.Properties)
javax.xml.ws.Endpoint.setProperties(java.util.Map)


Occurences of setProperty

setProperty occurences:
javax.xml.bind.Binder.setProperty(java.lang.String, java.lang.Object)
javax.xml.bind.helpers.AbstractMarshallerImpl.setProperty(java.lang.String, java.lang.Object)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.setProperty(java.lang.String, java.lang.Object)
javax.xml.bind.Marshaller.setProperty(java.lang.String, java.lang.Object)
javax.xml.bind.Unmarshaller.setProperty(java.lang.String, java.lang.Object)
javax.xml.bind.Validator.setProperty(java.lang.String, java.lang.Object)
javax.xml.rpc.Call.setProperty(java.lang.String, java.lang.Object)
javax.xml.rpc.handler.MessageContext.setProperty(java.lang.String, java.lang.Object)
javax.xml.soap.SOAPMessage.setProperty(java.lang.String, java.lang.Object)
javax.xml.stream.XMLInputFactory.setProperty(java.lang.String, java.lang.Object)
javax.xml.stream.XMLOutputFactory.setProperty(java.lang.String, java.lang.Object)


Occurences of setReadonly

setReadonly occurences:
javax.faces.component.html.HtmlCommandButton.setReadonly(boolean)
javax.faces.component.html.HtmlInputSecret.setReadonly(boolean)
javax.faces.component.html.HtmlInputText.setReadonly(boolean)
javax.faces.component.html.HtmlInputTextarea.setReadonly(boolean)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setReadonly(boolean)
javax.faces.component.html.HtmlSelectManyCheckbox.setReadonly(boolean)
javax.faces.component.html.HtmlSelectManyListbox.setReadonly(boolean)
javax.faces.component.html.HtmlSelectManyMenu.setReadonly(boolean)
javax.faces.component.html.HtmlSelectOneListbox.setReadonly(boolean)
javax.faces.component.html.HtmlSelectOneMenu.setReadonly(boolean)
javax.faces.component.html.HtmlSelectOneRadio.setReadonly(boolean)


Occurences of setRecipients

setRecipients occurences:
javax.mail.internet.MimeMessage.setRecipients(javax.mail.Message.RecipientType, java.lang.String)
javax.mail.internet.MimeMessage.setRecipients(javax.mail.Message.RecipientType, javax.mail.Address[])
javax.mail.Message.setRecipients(javax.mail.Message.RecipientType, javax.mail.Address[])


Occurences of setRel

setRel occurences:
javax.faces.component.html.HtmlCommandLink.setRel(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setRel(java.lang.String)


Occurences of setRendered

setRendered occurences:
javax.faces.component.UIComponent.setRendered(boolean)
javax.faces.component.UIComponentBase.setRendered(boolean)
javax.faces.webapp.UIComponentELTag.setRendered(javax.el.ValueExpression)
javax.faces.webapp.UIComponentTag.setRendered(java.lang.String)


Occurences of setRendererType

setRendererType occurences:
javax.faces.component.UIComponent.setRendererType(java.lang.String)
javax.faces.component.UIComponentBase.setRendererType(java.lang.String)


Occurences of setReplyTo

setReplyTo occurences:
javax.mail.internet.MimeMessage.setReplyTo(javax.mail.Address[])
javax.mail.Message.setReplyTo(javax.mail.Address[])


Occurences of setRequest

setRequest occurences:
javax.faces.context.ExternalContext.setRequest(java.lang.Object)
javax.servlet.ServletRequestWrapper.setRequest(javax.servlet.ServletRequest)


Occurences of setRequired

setRequired occurences:
javax.faces.component.EditableValueHolder.setRequired(boolean)
javax.faces.component.UIInput.setRequired(boolean)


Occurences of setResponse

setResponse occurences:
javax.faces.context.ExternalContext.setResponse(java.lang.Object)
javax.servlet.ServletResponseWrapper.setResponse(javax.servlet.ServletResponse)


Occurences of setReturnType

setReturnType occurences:
javax.xml.rpc.Call.setReturnType(javax.xml.namespace.QName)
javax.xml.rpc.Call.setReturnType(javax.xml.namespace.QName, java.lang.Class)


Occurences of setRev

setRev occurences:
javax.faces.component.html.HtmlCommandLink.setRev(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setRev(java.lang.String)


Occurences of setRoles

setRoles occurences:
javax.xml.rpc.handler.HandlerChain.setRoles(java.lang.String[])
javax.xml.ws.soap.SOAPBinding.setRoles(java.util.Set)


Occurences of setRollbackOnly

setRollbackOnly occurences:
javax.ejb.EJBContext.setRollbackOnly()
javax.persistence.EntityTransaction.setRollbackOnly()
javax.transaction.Transaction.setRollbackOnly()
javax.transaction.TransactionManager.setRollbackOnly()
javax.transaction.TransactionSynchronizationRegistry.setRollbackOnly()
javax.transaction.UserTransaction.setRollbackOnly()


Occurences of setRowClasses

setRowClasses occurences:
javax.faces.component.html.HtmlDataTable.setRowClasses(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setRowClasses(java.lang.String)


Occurences of setRowIndex

setRowIndex occurences:
javax.faces.component.UIData.setRowIndex(int)
javax.faces.model.ArrayDataModel.setRowIndex(int)
javax.faces.model.DataModel.setRowIndex(int)
javax.faces.model.ListDataModel.setRowIndex(int)
javax.faces.model.ResultDataModel.setRowIndex(int)
javax.faces.model.ResultSetDataModel.setRowIndex(int)
javax.faces.model.ScalarDataModel.setRowIndex(int)


Occurences of setRows

setRows occurences:
javax.faces.component.html.HtmlInputTextarea.setRows(int)
javax.faces.component.UIData.setRows(int)


Occurences of setRules

setRules occurences:
javax.faces.component.html.HtmlDataTable.setRules(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setRules(java.lang.String)


Occurences of setSchema

setSchema occurences:
javax.xml.bind.Binder.setSchema(javax.xml.validation.Schema)
javax.xml.bind.helpers.AbstractMarshallerImpl.setSchema(javax.xml.validation.Schema)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.setSchema(javax.xml.validation.Schema)
javax.xml.bind.Marshaller.setSchema(javax.xml.validation.Schema)
javax.xml.bind.Unmarshaller.setSchema(javax.xml.validation.Schema)


Occurences of setSentDate

setSentDate occurences:
javax.mail.internet.MimeMessage.setSentDate(java.util.Date)
javax.mail.Message.setSentDate(java.util.Date)


Occurences of setSeverity

setSeverity occurences:
javax.faces.application.FacesMessage.setSeverity(javax.faces.application.FacesMessage.Severity)
javax.xml.bind.helpers.ValidationEventImpl.setSeverity(int)


Occurences of setShape

setShape occurences:
javax.faces.component.html.HtmlCommandLink.setShape(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setShape(java.lang.String)


Occurences of setShowDetail

setShowDetail occurences:
javax.faces.component.UIMessage.setShowDetail(boolean)
javax.faces.component.UIMessages.setShowDetail(boolean)


Occurences of setShowSummary

setShowSummary occurences:
javax.faces.component.UIMessage.setShowSummary(boolean)
javax.faces.component.UIMessages.setShowSummary(boolean)


Occurences of setSize

setSize occurences:
javax.faces.component.html.HtmlInputSecret.setSize(int)
javax.faces.component.html.HtmlInputText.setSize(int)
javax.faces.component.html.HtmlSelectManyListbox.setSize(int)
javax.faces.component.html.HtmlSelectOneListbox.setSize(int)


Occurences of setStatus

setStatus occurences:
javax.servlet.http.HttpServletResponse.setStatus(int)
javax.servlet.http.HttpServletResponse.setStatus(int, java.lang.String)
javax.servlet.http.HttpServletResponseWrapper.setStatus(int)
javax.servlet.http.HttpServletResponseWrapper.setStatus(int, java.lang.String)


Occurences of setStyle

setStyle occurences:
javax.faces.component.html.HtmlCommandButton.setStyle(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setStyle(java.lang.String)
javax.faces.component.html.HtmlDataTable.setStyle(java.lang.String)
javax.faces.component.html.HtmlForm.setStyle(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setStyle(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setStyle(java.lang.String)
javax.faces.component.html.HtmlInputText.setStyle(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setStyle(java.lang.String)
javax.faces.component.html.HtmlMessage.setStyle(java.lang.String)
javax.faces.component.html.HtmlMessages.setStyle(java.lang.String)
javax.faces.component.html.HtmlOutputFormat.setStyle(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setStyle(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setStyle(java.lang.String)
javax.faces.component.html.HtmlOutputText.setStyle(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setStyle(java.lang.String)
javax.faces.component.html.HtmlPanelGroup.setStyle(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setStyle(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setStyle(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setStyle(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setStyle(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setStyle(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setStyle(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setStyle(java.lang.String)


Occurences of setStyleClass

setStyleClass occurences:
javax.faces.component.html.HtmlCommandButton.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlDataTable.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlForm.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlInputText.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlMessage.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlMessages.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlOutputFormat.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlOutputText.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlPanelGroup.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setStyleClass(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setStyleClass(java.lang.String)


Occurences of setSubject

setSubject occurences:
javax.mail.internet.MimeMessage.setSubject(java.lang.String)
javax.mail.internet.MimeMessage.setSubject(java.lang.String, java.lang.String)
javax.mail.Message.setSubject(java.lang.String)


Occurences of setSubmittedValue

setSubmittedValue occurences:
javax.faces.component.EditableValueHolder.setSubmittedValue(java.lang.Object)
javax.faces.component.UIInput.setSubmittedValue(java.lang.Object)


Occurences of setSubType

setSubType occurences:
javax.activation.MimeType.setSubType(java.lang.String)
javax.mail.internet.ContentType.setSubType(java.lang.String)
javax.mail.internet.MimeMultipart.setSubType(java.lang.String)


Occurences of setSummary

setSummary occurences:
javax.faces.application.FacesMessage.setSummary(java.lang.String)
javax.faces.component.html.HtmlDataTable.setSummary(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setSummary(java.lang.String)


Occurences of setTabindex

setTabindex occurences:
javax.faces.component.html.HtmlCommandButton.setTabindex(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setTabindex(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setTabindex(java.lang.String)
javax.faces.component.html.HtmlInputText.setTabindex(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setTabindex(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setTabindex(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setTabindex(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setTabindex(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setTabindex(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setTabindex(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setTabindex(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setTabindex(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setTabindex(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setTabindex(java.lang.String)


Occurences of setTarget

setTarget occurences:
javax.faces.component.html.HtmlCommandLink.setTarget(java.lang.String)
javax.faces.component.html.HtmlForm.setTarget(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setTarget(java.lang.String)


Occurences of setTelephoneNumbers

setTelephoneNumbers occurences:
javax.xml.registry.infomodel.Organization.setTelephoneNumbers(java.util.Collection)
javax.xml.registry.infomodel.User.setTelephoneNumbers(java.util.Collection)


Occurences of setText

setText occurences:
javax.jms.TextMessage.setText(java.lang.String)
javax.mail.internet.MimeBodyPart.setText(java.lang.String)
javax.mail.internet.MimeBodyPart.setText(java.lang.String, java.lang.String)
javax.mail.internet.MimeBodyPart.setText(java.lang.String, java.lang.String, java.lang.String)
javax.mail.internet.MimeMessage.setText(java.lang.String)
javax.mail.internet.MimeMessage.setText(java.lang.String, java.lang.String)
javax.mail.internet.MimeMessage.setText(java.lang.String, java.lang.String, java.lang.String)
javax.mail.internet.MimePart.setText(java.lang.String)
javax.mail.internet.MimePart.setText(java.lang.String, java.lang.String)
javax.mail.internet.MimePart.setText(java.lang.String, java.lang.String, java.lang.String)
javax.mail.Part.setText(java.lang.String)


Occurences of setTitle

setTitle occurences:
javax.faces.component.html.HtmlCommandButton.setTitle(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setTitle(java.lang.String)
javax.faces.component.html.HtmlDataTable.setTitle(java.lang.String)
javax.faces.component.html.HtmlForm.setTitle(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setTitle(java.lang.String)
javax.faces.component.html.HtmlInputSecret.setTitle(java.lang.String)
javax.faces.component.html.HtmlInputText.setTitle(java.lang.String)
javax.faces.component.html.HtmlInputTextarea.setTitle(java.lang.String)
javax.faces.component.html.HtmlMessage.setTitle(java.lang.String)
javax.faces.component.html.HtmlMessages.setTitle(java.lang.String)
javax.faces.component.html.HtmlOutputFormat.setTitle(java.lang.String)
javax.faces.component.html.HtmlOutputLabel.setTitle(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setTitle(java.lang.String)
javax.faces.component.html.HtmlOutputText.setTitle(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setTitle(java.lang.String)
javax.faces.component.html.HtmlSelectBooleanCheckbox.setTitle(java.lang.String)
javax.faces.component.html.HtmlSelectManyCheckbox.setTitle(java.lang.String)
javax.faces.component.html.HtmlSelectManyListbox.setTitle(java.lang.String)
javax.faces.component.html.HtmlSelectManyMenu.setTitle(java.lang.String)
javax.faces.component.html.HtmlSelectOneListbox.setTitle(java.lang.String)
javax.faces.component.html.HtmlSelectOneMenu.setTitle(java.lang.String)
javax.faces.component.html.HtmlSelectOneRadio.setTitle(java.lang.String)


Occurences of setTooltip

setTooltip occurences:
javax.faces.component.html.HtmlMessage.setTooltip(boolean)
javax.faces.component.html.HtmlMessages.setTooltip(boolean)


Occurences of setTransactionTimeout

setTransactionTimeout occurences:
javax.resource.spi.work.ExecutionContext.setTransactionTimeout(long)
javax.transaction.TransactionManager.setTransactionTimeout(int)
javax.transaction.UserTransaction.setTransactionTimeout(int)
javax.transaction.xa.XAResource.setTransactionTimeout(int)


Occurences of setTransient

setTransient occurences:
javax.faces.component.StateHolder.setTransient(boolean)
javax.faces.component.UIComponentBase.setTransient(boolean)
javax.faces.convert.DateTimeConverter.setTransient(boolean)
javax.faces.convert.EnumConverter.setTransient(boolean)
javax.faces.convert.NumberConverter.setTransient(boolean)
javax.faces.event.MethodExpressionActionListener.setTransient(boolean)
javax.faces.event.MethodExpressionValueChangeListener.setTransient(boolean)
javax.faces.validator.DoubleRangeValidator.setTransient(boolean)
javax.faces.validator.LengthValidator.setTransient(boolean)
javax.faces.validator.LongRangeValidator.setTransient(boolean)
javax.faces.validator.MethodExpressionValidator.setTransient(boolean)


Occurences of setType

setType occurences:
javax.faces.component.html.HtmlCommandButton.setType(java.lang.String)
javax.faces.component.html.HtmlCommandLink.setType(java.lang.String)
javax.faces.component.html.HtmlOutputLink.setType(java.lang.String)
javax.faces.convert.DateTimeConverter.setType(java.lang.String)
javax.faces.convert.NumberConverter.setType(java.lang.String)
javax.xml.registry.infomodel.EmailAddress.setType(java.lang.String)
javax.xml.registry.infomodel.PostalAddress.setType(java.lang.String)
javax.xml.registry.infomodel.TelephoneNumber.setType(java.lang.String)
javax.xml.registry.infomodel.User.setType(java.lang.String)


Occurences of setUrl

setUrl occurences:
javax.faces.component.UIGraphic.setUrl(java.lang.String)
javax.xml.registry.infomodel.TelephoneNumber.setUrl(java.lang.String)
javax.xml.registry.infomodel.User.setUrl(java.net.URL)


Occurences of setValid

setValid occurences:
javax.faces.component.EditableValueHolder.setValid(boolean)
javax.faces.component.UIInput.setValid(boolean)


Occurences of setValidating

setValidating occurences:
javax.xml.bind.helpers.AbstractUnmarshallerImpl.setValidating(boolean)
javax.xml.bind.Unmarshaller.setValidating(boolean)


Occurences of setValidator

setValidator occurences:
javax.faces.component.EditableValueHolder.setValidator(javax.faces.el.MethodBinding)
javax.faces.component.UIInput.setValidator(javax.faces.el.MethodBinding)


Occurences of setValue

setValue occurences:
javax.el.ArrayELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object)
javax.el.BeanELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object)
javax.el.CompositeELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object)
javax.el.ELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object)
javax.el.ListELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object)
javax.el.MapELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object)
javax.el.ResourceBundleELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object)
javax.el.ValueExpression.setValue(javax.el.ELContext, java.lang.Object)
javax.faces.component.UICommand.setValue(java.lang.Object)
javax.faces.component.UIData.setValue(java.lang.Object)
javax.faces.component.UIGraphic.setValue(java.lang.Object)
javax.faces.component.UIInput.setValue(java.lang.Object)
javax.faces.component.UIOutput.setValue(java.lang.Object)
javax.faces.component.UIParameter.setValue(java.lang.Object)
javax.faces.component.UISelectItem.setValue(java.lang.Object)
javax.faces.component.UISelectItems.setValue(java.lang.Object)
javax.faces.component.ValueHolder.setValue(java.lang.Object)
javax.faces.el.PropertyResolver.setValue(java.lang.Object, int, java.lang.Object)
javax.faces.el.PropertyResolver.setValue(java.lang.Object, java.lang.Object, java.lang.Object)
javax.faces.el.ValueBinding.setValue(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.model.SelectItem.setValue(java.lang.Object)
javax.faces.webapp.AttributeTag.setValue(java.lang.String)
javax.servlet.http.Cookie.setValue(java.lang.String)
javax.servlet.jsp.el.ImplicitObjectELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object)
javax.servlet.jsp.el.ScopedAttributeELResolver.setValue(javax.el.ELContext, java.lang.Object, java.lang.Object, java.lang.Object)
javax.servlet.jsp.tagext.TagSupport.setValue(java.lang.String, java.lang.Object)
javax.xml.bind.JAXBElement.setValue(java.lang.Object)
javax.xml.bind.JAXBElement.setValue(T)
javax.xml.registry.infomodel.Classification.setValue(java.lang.String)
javax.xml.registry.infomodel.Concept.setValue(java.lang.String)
javax.xml.registry.infomodel.ExternalIdentifier.setValue(java.lang.String)
javax.xml.registry.infomodel.InternationalString.setValue(java.lang.String)
javax.xml.registry.infomodel.InternationalString.setValue(java.util.Locale, java.lang.String)
javax.xml.registry.infomodel.LocalizedString.setValue(java.lang.String)
javax.xml.soap.Node.setValue(java.lang.String)


Occurences of setValueBinding

setValueBinding occurences:
javax.faces.component.UIComponent.setValueBinding(java.lang.String, javax.faces.el.ValueBinding)
javax.faces.component.UIComponentBase.setValueBinding(java.lang.String, javax.faces.el.ValueBinding)
javax.faces.component.UIData.setValueBinding(java.lang.String, javax.faces.el.ValueBinding)
javax.faces.component.UIGraphic.setValueBinding(java.lang.String, javax.faces.el.ValueBinding)
javax.faces.component.UISelectBoolean.setValueBinding(java.lang.String, javax.faces.el.ValueBinding)
javax.faces.component.UISelectMany.setValueBinding(java.lang.String, javax.faces.el.ValueBinding)


Occurences of setValueChangeListener

setValueChangeListener occurences:
javax.faces.component.EditableValueHolder.setValueChangeListener(javax.faces.el.MethodBinding)
javax.faces.component.UIInput.setValueChangeListener(javax.faces.el.MethodBinding)


Occurences of setValueExpression

setValueExpression occurences:
javax.faces.component.UIComponent.setValueExpression(java.lang.String, javax.el.ValueExpression)
javax.faces.component.UIComponentBase.setValueExpression(java.lang.String, javax.el.ValueExpression)
javax.faces.component.UIData.setValueExpression(java.lang.String, javax.el.ValueExpression)
javax.faces.component.UIGraphic.setValueExpression(java.lang.String, javax.el.ValueExpression)
javax.faces.component.UISelectBoolean.setValueExpression(java.lang.String, javax.el.ValueExpression)
javax.faces.component.UISelectMany.setValueExpression(java.lang.String, javax.el.ValueExpression)


Occurences of setWarnClass

setWarnClass occurences:
javax.faces.component.html.HtmlMessage.setWarnClass(java.lang.String)
javax.faces.component.html.HtmlMessages.setWarnClass(java.lang.String)


Occurences of setWarnStyle

setWarnStyle occurences:
javax.faces.component.html.HtmlMessage.setWarnStyle(java.lang.String)
javax.faces.component.html.HtmlMessages.setWarnStyle(java.lang.String)


Occurences of setWidth

setWidth occurences:
javax.faces.component.html.HtmlDataTable.setWidth(java.lang.String)
javax.faces.component.html.HtmlGraphicImage.setWidth(java.lang.String)
javax.faces.component.html.HtmlPanelGrid.setWidth(java.lang.String)


Occurences of setWrappedData

setWrappedData occurences:
javax.faces.model.ArrayDataModel.setWrappedData(java.lang.Object)
javax.faces.model.DataModel.setWrappedData(java.lang.Object)
javax.faces.model.ListDataModel.setWrappedData(java.lang.Object)
javax.faces.model.ResultDataModel.setWrappedData(java.lang.Object)
javax.faces.model.ResultSetDataModel.setWrappedData(java.lang.Object)
javax.faces.model.ScalarDataModel.setWrappedData(java.lang.Object)


Occurences of SharedByteArrayInputStream (constructors)

SharedByteArrayInputStream (constructors) occurences:
javax.mail.util.SharedByteArrayInputStream(byte[])
javax.mail.util.SharedByteArrayInputStream(byte[], int, int)


Occurences of SharedFileInputStream (constructors)

SharedFileInputStream (constructors) occurences:
javax.mail.util.SharedFileInputStream(java.io.File)
javax.mail.util.SharedFileInputStream(java.io.File, int)
javax.mail.util.SharedFileInputStream(java.lang.String)
javax.mail.util.SharedFileInputStream(java.lang.String, int)


Occurences of SharingViolationException (constructors)

SharingViolationException (constructors) occurences:
javax.resource.spi.SharingViolationException()
javax.resource.spi.SharingViolationException(java.lang.String)
javax.resource.spi.SharingViolationException(java.lang.String, java.lang.String)
javax.resource.spi.SharingViolationException(java.lang.String, java.lang.Throwable)
javax.resource.spi.SharingViolationException(java.lang.Throwable)


Occurences of ShortHolder (constructors)

ShortHolder (constructors) occurences:
javax.xml.rpc.holders.ShortHolder()
javax.xml.rpc.holders.ShortHolder(short)


Occurences of ShortWrapperHolder (constructors)

ShortWrapperHolder (constructors) occurences:
javax.xml.rpc.holders.ShortWrapperHolder()
javax.xml.rpc.holders.ShortWrapperHolder(java.lang.Short)


Occurences of size

size occurences:
javax.activation.MimeTypeParameterList.size()
javax.mail.internet.ParameterList.size()


Occurences of SkipPageException (constructors)

SkipPageException (constructors) occurences:
javax.servlet.jsp.SkipPageException()
javax.servlet.jsp.SkipPageException(java.lang.String)
javax.servlet.jsp.SkipPageException(java.lang.String, java.lang.Throwable)
javax.servlet.jsp.SkipPageException(java.lang.Throwable)


Occurences of soap

soap occurences:
javax.jws.soap
javax.xml.rpc.handler.soap
javax.xml.rpc.soap
javax.xml.soap
javax.xml.ws.handler.soap
javax.xml.ws.soap


Occurences of SOAPACTION_URI_PROPERTY

SOAPACTION_URI_PROPERTY occurences:
javax.xml.rpc.SOAPACTION_URI_PROPERTY
javax.xml.ws.SOAPACTION_URI_PROPERTY


Occurences of SOAPACTION_USE_PROPERTY

SOAPACTION_USE_PROPERTY occurences:
javax.xml.rpc.SOAPACTION_USE_PROPERTY
javax.xml.ws.SOAPACTION_USE_PROPERTY


Occurences of SOAPBinding

SOAPBinding occurences:
javax.jws.soap.SOAPBinding
javax.xml.ws.soap.SOAPBinding


Occurences of SOAPException (constructors)

SOAPException (constructors) occurences:
javax.xml.soap.SOAPException()
javax.xml.soap.SOAPException(java.lang.String)
javax.xml.soap.SOAPException(java.lang.String, java.lang.Throwable)
javax.xml.soap.SOAPException(java.lang.Throwable)


Occurences of SOAPFaultException

SOAPFaultException occurences:
javax.xml.rpc.soap.SOAPFaultException
javax.xml.ws.soap.SOAPFaultException


Occurences of SOAPFaultException (constructors)

SOAPFaultException (constructors) occurences:
javax.xml.rpc.soap.SOAPFaultException(javax.xml.namespace.QName, java.lang.String, java.lang.String, javax.xml.soap.Detail)
javax.xml.ws.soap.SOAPFaultException(javax.xml.soap.SOAPFault)


Occurences of SOAPMessageContext

SOAPMessageContext occurences:
javax.xml.rpc.handler.soap.SOAPMessageContext
javax.xml.ws.handler.soap.SOAPMessageContext


Occurences of spi

spi occurences:
javax.ejb.spi
javax.enterprise.deploy.spi
javax.persistence.spi
javax.resource.spi
javax.xml.ws.spi


Occurences of standaloneSet

standaloneSet occurences:
javax.xml.stream.events.StartDocument.standaloneSet()
javax.xml.stream.util.StreamReaderDelegate.standaloneSet()
javax.xml.stream.XMLStreamReader.standaloneSet()


Occurences of start

start occurences:
javax.enterprise.deploy.spi.DeploymentManager.start(javax.enterprise.deploy.spi.TargetModuleID[])
javax.jms.Connection.start()
javax.jms.ServerSession.start()
javax.mail.util.start
javax.mail.util.start
javax.resource.spi.ResourceAdapter.start(javax.resource.spi.BootstrapContext)
javax.transaction.xa.XAResource.start(javax.transaction.xa.Xid, int)


Occurences of startDocument

startDocument occurences:
javax.faces.context.ResponseWriter.startDocument()
javax.faces.context.ResponseWriterWrapper.startDocument()


Occurences of startElement

startElement occurences:
javax.faces.context.ResponseWriter.startElement(java.lang.String, javax.faces.component.UIComponent)
javax.faces.context.ResponseWriterWrapper.startElement(java.lang.String, javax.faces.component.UIComponent)


Occurences of startWork

startWork occurences:
javax.resource.spi.work.WorkManager.startWork(javax.resource.spi.work.Work)
javax.resource.spi.work.WorkManager.startWork(javax.resource.spi.work.Work, long, javax.resource.spi.work.ExecutionContext, javax.resource.spi.work.WorkListener)


Occurences of STOP

STOP occurences:
javax.enterprise.deploy.shared.STOP
javax.enterprise.deploy.shared.STOP


Occurences of stop

stop occurences:
javax.enterprise.deploy.spi.DeploymentManager.stop(javax.enterprise.deploy.spi.TargetModuleID[])
javax.enterprise.deploy.spi.status.ProgressObject.stop()
javax.jms.Connection.stop()
javax.resource.spi.ResourceAdapter.stop()
javax.xml.ws.Endpoint.stop()


Occurences of StoreClosedException (constructors)

StoreClosedException (constructors) occurences:
javax.mail.StoreClosedException(javax.mail.Store)
javax.mail.StoreClosedException(javax.mail.Store, java.lang.String)


Occurences of strategy

strategy occurences:
javax.persistence.GeneratedValue.strategy()
javax.persistence.Inheritance.strategy()


Occurences of StreamReaderDelegate (constructors)

StreamReaderDelegate (constructors) occurences:
javax.xml.stream.util.StreamReaderDelegate()
javax.xml.stream.util.StreamReaderDelegate(javax.xml.stream.XMLStreamReader)


Occurences of STRING

STRING occurences:
javax.persistence.STRING
javax.persistence.STRING


Occurences of StringHolder (constructors)

StringHolder (constructors) occurences:
javax.xml.rpc.holders.StringHolder()
javax.xml.rpc.holders.StringHolder(java.lang.String)


Occurences of StringTerm (constructors)

StringTerm (constructors) occurences:
javax.mail.search.StringTerm(java.lang.String)
javax.mail.search.StringTerm(java.lang.String, boolean)


Occurences of STRING_ID

STRING_ID occurences:
javax.faces.convert.STRING_ID
javax.faces.convert.STRING_ID
javax.faces.convert.STRING_ID
javax.faces.convert.STRING_ID
javax.faces.convert.STRING_ID
javax.faces.convert.STRING_ID
javax.faces.convert.STRING_ID
javax.faces.convert.STRING_ID
javax.faces.convert.STRING_ID
javax.faces.convert.STRING_ID
javax.faces.convert.STRING_ID
javax.faces.convert.STRING_ID


Occurences of supportedProps

supportedProps occurences:
javax.xml.bind.supportedProps
javax.xml.bind.supportedProps
javax.xml.bind.supportedProps


Occurences of SystemException (constructors)

SystemException (constructors) occurences:
javax.transaction.SystemException()
javax.transaction.SystemException(int)
javax.transaction.SystemException(java.lang.String)


Occurences of table

table occurences:
javax.persistence.Column.table()
javax.persistence.JoinColumn.table()
javax.persistence.TableGenerator.table()


Occurences of TagAttributeInfo (constructors)

TagAttributeInfo (constructors) occurences:
javax.servlet.jsp.tagext.TagAttributeInfo(java.lang.String, boolean, java.lang.String, boolean)
javax.servlet.jsp.tagext.TagAttributeInfo(java.lang.String, boolean, java.lang.String, boolean, boolean)
javax.servlet.jsp.tagext.TagAttributeInfo(java.lang.String, boolean, java.lang.String, boolean, boolean, java.lang.String, boolean, boolean, java.lang.String, java.lang.String)


Occurences of TagData (constructors)

TagData (constructors) occurences:
javax.servlet.jsp.tagext.TagData(java.lang.Object[][])
javax.servlet.jsp.tagext.TagData(java.util.Hashtable)


Occurences of TagInfo (constructors)

TagInfo (constructors) occurences:
javax.servlet.jsp.tagext.TagInfo(java.lang.String, java.lang.String, java.lang.String, java.lang.String, javax.servlet.jsp.tagext.TagLibraryInfo, javax.servlet.jsp.tagext.TagExtraInfo, javax.servlet.jsp.tagext.TagAttributeInfo[])
javax.servlet.jsp.tagext.TagInfo(java.lang.String, java.lang.String, java.lang.String, java.lang.String, javax.servlet.jsp.tagext.TagLibraryInfo, javax.servlet.jsp.tagext.TagExtraInfo, javax.servlet.jsp.tagext.TagAttributeInfo[], java.lang.String, java.lang.String, java.lang.String, javax.servlet.jsp.tagext.TagVariableInfo[])
javax.servlet.jsp.tagext.TagInfo(java.lang.String, java.lang.String, java.lang.String, java.lang.String, javax.servlet.jsp.tagext.TagLibraryInfo, javax.servlet.jsp.tagext.TagExtraInfo, javax.servlet.jsp.tagext.TagAttributeInfo[], java.lang.String, java.lang.String, java.lang.String, javax.servlet.jsp.tagext.TagVariableInfo[], boolean)


Occurences of targetEntity

targetEntity occurences:
javax.persistence.ManyToMany.targetEntity()
javax.persistence.ManyToOne.targetEntity()
javax.persistence.OneToMany.targetEntity()
javax.persistence.OneToOne.targetEntity()


Occurences of targetNamespace

targetNamespace occurences:
javax.jws.WebParam.targetNamespace()
javax.jws.WebResult.targetNamespace()
javax.jws.WebService.targetNamespace()
javax.xml.ws.RequestWrapper.targetNamespace()
javax.xml.ws.ResponseWrapper.targetNamespace()
javax.xml.ws.WebFault.targetNamespace()
javax.xml.ws.WebServiceClient.targetNamespace()
javax.xml.ws.WebServiceProvider.targetNamespace()


Occurences of terms

terms occurences:
javax.mail.search.terms
javax.mail.search.terms


Occurences of toString

toString occurences:
javax.activation.MimeType.toString()
javax.activation.MimeTypeParameterList.toString()
javax.enterprise.deploy.shared.ActionType.toString()
javax.enterprise.deploy.shared.CommandType.toString()
javax.enterprise.deploy.shared.DConfigBeanVersionType.toString()
javax.enterprise.deploy.shared.ModuleType.toString()
javax.enterprise.deploy.shared.StateType.toString()
javax.enterprise.deploy.spi.TargetModuleID.toString()
javax.faces.application.FacesMessage.Severity.toString()
javax.faces.event.PhaseId.toString()
javax.jms.Queue.toString()
javax.jms.Topic.toString()
javax.mail.Address.toString()
javax.mail.Folder.toString()
javax.mail.internet.AddressException.toString()
javax.mail.internet.ContentDisposition.toString()
javax.mail.internet.ContentType.toString()
javax.mail.internet.InternetAddress.toString()
javax.mail.internet.InternetAddress.toString(javax.mail.Address[])
javax.mail.internet.InternetAddress.toString(javax.mail.Address[], int)
javax.mail.internet.NewsAddress.toString()
javax.mail.internet.NewsAddress.toString(javax.mail.Address[])
javax.mail.internet.ParameterList.toString()
javax.mail.internet.ParameterList.toString(int)
javax.mail.Message.RecipientType.toString()
javax.mail.MessagingException.toString()
javax.mail.Provider.toString()
javax.mail.Provider.Type.toString()
javax.mail.Service.toString()
javax.mail.URLName.toString()
javax.servlet.jsp.tagext.TagAttributeInfo.toString()
javax.xml.bind.helpers.ValidationEventImpl.toString()
javax.xml.bind.helpers.ValidationEventLocatorImpl.toString()
javax.xml.bind.JAXBException.toString()
javax.xml.bind.TypeConstraintException.toString()
javax.xml.registry.Query.toString()
javax.xml.rpc.ParameterMode.toString()


Occurences of TransactionInProgressException (constructors)

TransactionInProgressException (constructors) occurences:
javax.jms.TransactionInProgressException(java.lang.String)
javax.jms.TransactionInProgressException(java.lang.String, java.lang.String)


Occurences of TransactionRequiredException

TransactionRequiredException occurences:
javax.persistence.TransactionRequiredException
javax.transaction.TransactionRequiredException


Occurences of TransactionRequiredException (constructors)

TransactionRequiredException (constructors) occurences:
javax.persistence.TransactionRequiredException()
javax.persistence.TransactionRequiredException(java.lang.String)
javax.transaction.TransactionRequiredException()
javax.transaction.TransactionRequiredException(java.lang.String)


Occurences of TransactionRequiredLocalException (constructors)

TransactionRequiredLocalException (constructors) occurences:
javax.ejb.TransactionRequiredLocalException()
javax.ejb.TransactionRequiredLocalException(java.lang.String)


Occurences of TransactionRolledbackException (constructors)

TransactionRolledbackException (constructors) occurences:
javax.transaction.TransactionRolledbackException()
javax.transaction.TransactionRolledbackException(java.lang.String)


Occurences of TransactionRolledBackException (constructors)

TransactionRolledBackException (constructors) occurences:
javax.jms.TransactionRolledBackException(java.lang.String)
javax.jms.TransactionRolledBackException(java.lang.String, java.lang.String)


Occurences of TransactionRolledbackLocalException (constructors)

TransactionRolledbackLocalException (constructors) occurences:
javax.ejb.TransactionRolledbackLocalException()
javax.ejb.TransactionRolledbackLocalException(java.lang.String)
javax.ejb.TransactionRolledbackLocalException(java.lang.String, java.lang.Exception)


Occurences of type

type occurences:
javax.annotation.Resource.type()
javax.mail.event.type
javax.mail.event.type
javax.mail.event.type
javax.mail.event.type
javax.mail.event.type
javax.mail.event.type
javax.mail.search.type
javax.mail.type
javax.persistence.PersistenceContext.type()
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.type()
javax.xml.bind.annotation.XmlElement.type()
javax.xml.bind.annotation.XmlElementRef.type()
javax.xml.bind.annotation.XmlSchemaType.type()
javax.xml.ws.WebServiceRef.type()


Occurences of TypeConstraintException (constructors)

TypeConstraintException (constructors) occurences:
javax.xml.bind.TypeConstraintException(java.lang.String)
javax.xml.bind.TypeConstraintException(java.lang.String, java.lang.String)
javax.xml.bind.TypeConstraintException(java.lang.String, java.lang.String, java.lang.Throwable)
javax.xml.bind.TypeConstraintException(java.lang.String, java.lang.Throwable)
javax.xml.bind.TypeConstraintException(java.lang.Throwable)


Occurences of TYPE_MESSAGE_ID

TYPE_MESSAGE_ID occurences:
javax.faces.validator.TYPE_MESSAGE_ID
javax.faces.validator.TYPE_MESSAGE_ID


Occurences of UnavailableException

UnavailableException occurences:
javax.resource.spi.UnavailableException
javax.servlet.UnavailableException


Occurences of UnavailableException (constructors)

UnavailableException (constructors) occurences:
javax.resource.spi.UnavailableException()
javax.resource.spi.UnavailableException(java.lang.String)
javax.resource.spi.UnavailableException(java.lang.String, java.lang.String)
javax.resource.spi.UnavailableException(java.lang.String, java.lang.Throwable)
javax.resource.spi.UnavailableException(java.lang.Throwable)
javax.servlet.UnavailableException(int, javax.servlet.Servlet, java.lang.String)
javax.servlet.UnavailableException(java.lang.String)
javax.servlet.UnavailableException(java.lang.String, int)
javax.servlet.UnavailableException(javax.servlet.Servlet, java.lang.String)


Occurences of UNDEFINED

UNDEFINED occurences:
javax.resource.spi.work.UNDEFINED
javax.xml.bind.annotation.UNDEFINED


Occurences of UnexpectedObjectException (constructors)

UnexpectedObjectException (constructors) occurences:
javax.xml.registry.UnexpectedObjectException()
javax.xml.registry.UnexpectedObjectException(java.lang.String)
javax.xml.registry.UnexpectedObjectException(java.lang.String, java.lang.Throwable)
javax.xml.registry.UnexpectedObjectException(java.lang.Throwable)


Occurences of unique

unique occurences:
javax.persistence.Column.unique()
javax.persistence.JoinColumn.unique()


Occurences of uniqueConstraints

uniqueConstraints occurences:
javax.persistence.JoinTable.uniqueConstraints()
javax.persistence.SecondaryTable.uniqueConstraints()
javax.persistence.Table.uniqueConstraints()
javax.persistence.TableGenerator.uniqueConstraints()


Occurences of UNIQUE_ID_PREFIX

UNIQUE_ID_PREFIX occurences:
javax.faces.component.UNIQUE_ID_PREFIX
javax.faces.webapp.UNIQUE_ID_PREFIX


Occurences of unitName

unitName occurences:
javax.persistence.PersistenceContext.unitName()
javax.persistence.PersistenceUnit.unitName()


Occurences of unmarshal

unmarshal occurences:
javax.xml.bind.annotation.adapters.CollapsedStringAdapter.unmarshal(java.lang.String)
javax.xml.bind.annotation.adapters.HexBinaryAdapter.unmarshal(java.lang.String)
javax.xml.bind.annotation.adapters.NormalizedStringAdapter.unmarshal(java.lang.String)
javax.xml.bind.annotation.adapters.XmlAdapter.unmarshal(java.lang.Object)
javax.xml.bind.annotation.adapters.XmlAdapter.unmarshal(ValueType)
javax.xml.bind.Binder.unmarshal(java.lang.Object)
javax.xml.bind.Binder.unmarshal(java.lang.Object,java.lang.Class)
javax.xml.bind.Binder.unmarshal(XmlNode)
javax.xml.bind.Binder.unmarshal(XmlNode, java.lang.Class)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(java.io.File)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(java.io.InputStream)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(java.io.Reader)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(java.net.URL)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(javax.xml.stream.XMLEventReader)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(javax.xml.stream.XMLEventReader, java.lang.Class)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(javax.xml.stream.XMLStreamReader)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(javax.xml.stream.XMLStreamReader, java.lang.Class)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(javax.xml.transform.Source)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(javax.xml.transform.Source, java.lang.Class)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(org.w3c.dom.Node, java.lang.Class)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(org.xml.sax.InputSource)
javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(org.xml.sax.XMLReader, org.xml.sax.InputSource)
javax.xml.bind.Unmarshaller.unmarshal(java.io.File)
javax.xml.bind.Unmarshaller.unmarshal(java.io.InputStream)
javax.xml.bind.Unmarshaller.unmarshal(java.io.Reader)
javax.xml.bind.Unmarshaller.unmarshal(java.net.URL)
javax.xml.bind.Unmarshaller.unmarshal(javax.xml.stream.XMLEventReader)
javax.xml.bind.Unmarshaller.unmarshal(javax.xml.stream.XMLEventReader, java.lang.Class)
javax.xml.bind.Unmarshaller.unmarshal(javax.xml.stream.XMLStreamReader)
javax.xml.bind.Unmarshaller.unmarshal(javax.xml.stream.XMLStreamReader, java.lang.Class)
javax.xml.bind.Unmarshaller.unmarshal(javax.xml.transform.Source)
javax.xml.bind.Unmarshaller.unmarshal(javax.xml.transform.Source, java.lang.Class)
javax.xml.bind.Unmarshaller.unmarshal(org.w3c.dom.Node)
javax.xml.bind.Unmarshaller.unmarshal(org.w3c.dom.Node, java.lang.Class)
javax.xml.bind.Unmarshaller.unmarshal(org.xml.sax.InputSource)


Occurences of UnmarshalException (constructors)

UnmarshalException (constructors) occurences:
javax.xml.bind.UnmarshalException(java.lang.String)
javax.xml.bind.UnmarshalException(java.lang.String, java.lang.String)
javax.xml.bind.UnmarshalException(java.lang.String, java.lang.String, java.lang.Throwable)
javax.xml.bind.UnmarshalException(java.lang.String, java.lang.Throwable)
javax.xml.bind.UnmarshalException(java.lang.Throwable)


Occurences of unsubscribe

unsubscribe occurences:
javax.jms.Session.unsubscribe(java.lang.String)
javax.jms.TopicSession.unsubscribe(java.lang.String)


Occurences of UnsupportedCapabilityException (constructors)

UnsupportedCapabilityException (constructors) occurences:
javax.xml.registry.UnsupportedCapabilityException()
javax.xml.registry.UnsupportedCapabilityException(java.lang.String)
javax.xml.registry.UnsupportedCapabilityException(java.lang.String, java.lang.Throwable)
javax.xml.registry.UnsupportedCapabilityException(java.lang.Throwable)


Occurences of UnsupportedDataTypeException (constructors)

UnsupportedDataTypeException (constructors) occurences:
javax.activation.UnsupportedDataTypeException()
javax.activation.UnsupportedDataTypeException(java.lang.String)


Occurences of updatable

updatable occurences:
javax.persistence.Column.updatable()
javax.persistence.JoinColumn.updatable()


Occurences of updateHeaders

updateHeaders occurences:
javax.mail.internet.MimeBodyPart.updateHeaders()
javax.mail.internet.MimeMessage.updateHeaders()
javax.mail.internet.MimeMultipart.updateHeaders()
javax.mail.internet.PreencodedMimeBodyPart.updateHeaders()


Occurences of updateJAXB

updateJAXB occurences:
javax.xml.bind.Binder.updateJAXB(java.lang.Object)
javax.xml.bind.Binder.updateJAXB(XmlNode)


Occurences of updateXML

updateXML occurences:
javax.xml.bind.Binder.updateXML(java.lang.Object)
javax.xml.bind.Binder.updateXML(java.lang.Object, XmlNode)
javax.xml.bind.Binder.updateXML(java.lang.Object,java.lang.Object)


Occurences of URLName (constructors)

URLName (constructors) occurences:
javax.mail.URLName(java.lang.String)
javax.mail.URLName(java.lang.String, java.lang.String, int, java.lang.String, java.lang.String, java.lang.String)
javax.mail.URLName(java.net.URL)


Occurences of USER

USER occurences:
javax.mail.USER
javax.xml.registry.USER


Occurences of USERNAME_PROPERTY

USERNAME_PROPERTY occurences:
javax.xml.rpc.USERNAME_PROPERTY
javax.xml.rpc.USERNAME_PROPERTY
javax.xml.ws.USERNAME_PROPERTY


Occurences of util

util occurences:
javax.mail.util
javax.xml.bind.util
javax.xml.stream.util


Occurences of validate

validate occurences:
javax.faces.component.UIInput.validate(javax.faces.context.FacesContext)
javax.faces.validator.DoubleRangeValidator.validate(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.validator.LengthValidator.validate(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.validator.LongRangeValidator.validate(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.validator.MethodExpressionValidator.validate(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.faces.validator.Validator.validate(javax.faces.context.FacesContext, javax.faces.component.UIComponent, java.lang.Object)
javax.mail.internet.InternetAddress.validate()
javax.resource.spi.ActivationSpec.validate()
javax.servlet.jsp.tagext.TagExtraInfo.validate(javax.servlet.jsp.tagext.TagData)
javax.servlet.jsp.tagext.TagInfo.validate(javax.servlet.jsp.tagext.TagData)
javax.servlet.jsp.tagext.TagLibraryValidator.validate(java.lang.String, java.lang.String, javax.servlet.jsp.tagext.PageData)
javax.xml.bind.Validator.validate(java.lang.Object)


Occurences of validateValue

validateValue occurences:
javax.faces.component.UIInput.validateValue(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UISelectMany.validateValue(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.component.UISelectOne.validateValue(javax.faces.context.FacesContext, java.lang.Object)


Occurences of ValidationEventImpl (constructors)

ValidationEventImpl (constructors) occurences:
javax.xml.bind.helpers.ValidationEventImpl(int, java.lang.String, javax.xml.bind.ValidationEventLocator)
javax.xml.bind.helpers.ValidationEventImpl(int, java.lang.String, javax.xml.bind.ValidationEventLocator, java.lang.Throwable)


Occurences of ValidationEventLocatorImpl (constructors)

ValidationEventLocatorImpl (constructors) occurences:
javax.xml.bind.helpers.ValidationEventLocatorImpl()
javax.xml.bind.helpers.ValidationEventLocatorImpl(java.lang.Object)
javax.xml.bind.helpers.ValidationEventLocatorImpl(org.w3c.dom.Node)
javax.xml.bind.helpers.ValidationEventLocatorImpl(org.xml.sax.Locator)
javax.xml.bind.helpers.ValidationEventLocatorImpl(org.xml.sax.SAXParseException)


Occurences of ValidationException (constructors)

ValidationException (constructors) occurences:
javax.xml.bind.ValidationException(java.lang.String)
javax.xml.bind.ValidationException(java.lang.String, java.lang.String)
javax.xml.bind.ValidationException(java.lang.String, java.lang.String, java.lang.Throwable)
javax.xml.bind.ValidationException(java.lang.String, java.lang.Throwable)
javax.xml.bind.ValidationException(java.lang.Throwable)


Occurences of Validator

Validator occurences:
javax.faces.validator.Validator
javax.xml.bind.Validator


Occurences of ValidatorException (constructors)

ValidatorException (constructors) occurences:
javax.faces.validator.ValidatorException(javax.faces.application.FacesMessage)
javax.faces.validator.ValidatorException(javax.faces.application.FacesMessage, java.lang.Throwable)


Occurences of VALIDATOR_ID

VALIDATOR_ID occurences:
javax.faces.validator.VALIDATOR_ID
javax.faces.validator.VALIDATOR_ID
javax.faces.validator.VALIDATOR_ID


Occurences of validSent

validSent occurences:
javax.mail.event.validSent
javax.mail.validSent


Occurences of validUnsent

validUnsent occurences:
javax.mail.event.validUnsent
javax.mail.validUnsent


Occurences of value

value occurences:
javax.annotation.Generated.value()
javax.annotation.Resources.value()
javax.annotation.security.DeclareRoles.value()
javax.annotation.security.RolesAllowed.value()
javax.annotation.security.RunAs.value()
javax.ejb.EJBs.value()
javax.ejb.Init.value()
javax.ejb.Local.value()
javax.ejb.LocalHome.value()
javax.ejb.Remote.value()
javax.ejb.RemoteHome.value()
javax.ejb.TransactionAttribute.value()
javax.ejb.TransactionManagement.value()
javax.interceptor.Interceptors.value()
javax.jws.soap.InitParam.value()
javax.jws.soap.SOAPMessageHandlers.value()
javax.mail.value
javax.persistence.AssociationOverrides.value()
javax.persistence.AttributeOverrides.value()
javax.persistence.DiscriminatorValue.value()
javax.persistence.EntityListeners.value()
javax.persistence.Enumerated.value()
javax.persistence.IdClass.value()
javax.persistence.JoinColumns.value()
javax.persistence.NamedNativeQueries.value()
javax.persistence.NamedQueries.value()
javax.persistence.OrderBy.value()
javax.persistence.PersistenceContexts.value()
javax.persistence.PersistenceProperty.value()
javax.persistence.PersistenceUnits.value()
javax.persistence.PrimaryKeyJoinColumns.value()
javax.persistence.QueryHint.value()
javax.persistence.SecondaryTables.value()
javax.persistence.SqlResultSetMappings.value()
javax.persistence.Temporal.value()
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.value()
javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters.value()
javax.xml.bind.annotation.XmlAccessorOrder.value()
javax.xml.bind.annotation.XmlAccessorType.value()
javax.xml.bind.annotation.XmlAnyElement.value()
javax.xml.bind.annotation.XmlElementRefs.value()
javax.xml.bind.annotation.XmlElements.value()
javax.xml.bind.annotation.XmlEnum.value()
javax.xml.bind.annotation.XmlEnumValue.value()
javax.xml.bind.annotation.XmlMimeType.value()
javax.xml.bind.annotation.XmlSchemaTypes.value()
javax.xml.bind.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.rpc.holders.value
javax.xml.ws.BindingType.value()
javax.xml.ws.ServiceMode.value()
javax.xml.ws.value
javax.xml.ws.WebServiceRef.value()
javax.xml.ws.WebServiceRefs.value()


Occurences of valueOf

valueOf occurences:
javax.annotation.Resource.AuthenticationType.valueOf(java.lang.String)
javax.ejb.TransactionAttributeType.valueOf(java.lang.String)
javax.ejb.TransactionManagementType.valueOf(java.lang.String)
javax.jws.soap.SOAPBinding.ParameterStyle.valueOf(java.lang.String)
javax.jws.soap.SOAPBinding.Style.valueOf(java.lang.String)
javax.jws.soap.SOAPBinding.Use.valueOf(java.lang.String)
javax.jws.WebParam.Mode.valueOf(java.lang.String)
javax.persistence.CascadeType.valueOf(java.lang.String)
javax.persistence.DiscriminatorType.valueOf(java.lang.String)
javax.persistence.EnumType.valueOf(java.lang.String)
javax.persistence.FetchType.valueOf(java.lang.String)
javax.persistence.FlushModeType.valueOf(java.lang.String)
javax.persistence.GenerationType.valueOf(java.lang.String)
javax.persistence.InheritanceType.valueOf(java.lang.String)
javax.persistence.LockModeType.valueOf(java.lang.String)
javax.persistence.PersistenceContextType.valueOf(java.lang.String)
javax.persistence.spi.PersistenceUnitTransactionType.valueOf(java.lang.String)
javax.persistence.TemporalType.valueOf(java.lang.String)
javax.xml.bind.annotation.XmlAccessOrder.valueOf(java.lang.String)
javax.xml.bind.annotation.XmlAccessType.valueOf(java.lang.String)
javax.xml.bind.annotation.XmlNsForm.valueOf(java.lang.String)
javax.xml.ws.handler.MessageContext.Scope.valueOf(java.lang.String)
javax.xml.ws.Service.Mode.valueOf(java.lang.String)


Occurences of values

values occurences:
javax.annotation.Resource.AuthenticationType.values()
javax.ejb.TransactionAttributeType.values()
javax.ejb.TransactionManagementType.values()
javax.jws.soap.SOAPBinding.ParameterStyle.values()
javax.jws.soap.SOAPBinding.Style.values()
javax.jws.soap.SOAPBinding.Use.values()
javax.jws.WebParam.Mode.values()
javax.persistence.CascadeType.values()
javax.persistence.DiscriminatorType.values()
javax.persistence.EnumType.values()
javax.persistence.FetchType.values()
javax.persistence.FlushModeType.values()
javax.persistence.GenerationType.values()
javax.persistence.InheritanceType.values()
javax.persistence.LockModeType.values()
javax.persistence.PersistenceContextType.values()
javax.persistence.spi.PersistenceUnitTransactionType.values()
javax.persistence.TemporalType.values()
javax.xml.bind.annotation.XmlAccessOrder.values()
javax.xml.bind.annotation.XmlAccessType.values()
javax.xml.bind.annotation.XmlNsForm.values()
javax.xml.ws.handler.MessageContext.Scope.values()
javax.xml.ws.Service.Mode.values()


Occurences of VALUES

VALUES occurences:
javax.faces.application.VALUES
javax.faces.event.VALUES


Occurences of VariableResolver

VariableResolver occurences:
javax.faces.el.VariableResolver
javax.servlet.jsp.el.VariableResolver


Occurences of ViewExpiredException (constructors)

ViewExpiredException (constructors) occurences:
javax.faces.application.ViewExpiredException()
javax.faces.application.ViewExpiredException(java.lang.String)
javax.faces.application.ViewExpiredException(java.lang.String, java.lang.String)
javax.faces.application.ViewExpiredException(java.lang.String, java.lang.Throwable, java.lang.String)
javax.faces.application.ViewExpiredException(java.lang.Throwable, java.lang.String)


Occurences of W3CDomHandler (constructors)

W3CDomHandler (constructors) occurences:
javax.xml.bind.annotation.W3CDomHandler()
javax.xml.bind.annotation.W3CDomHandler(javax.xml.parsers.DocumentBuilder)


Occurences of WebResourcePermission (constructors)

WebResourcePermission (constructors) occurences:
javax.security.jacc.WebResourcePermission(java.lang.String, java.lang.String)
javax.security.jacc.WebResourcePermission(java.lang.String, java.lang.String[])
javax.security.jacc.WebResourcePermission(javax.servlet.http.HttpServletRequest)


Occurences of WebServiceException (constructors)

WebServiceException (constructors) occurences:
javax.xml.ws.WebServiceException()
javax.xml.ws.WebServiceException(java.lang.String)
javax.xml.ws.WebServiceException(java.lang.String, java.lang.Throwable)
javax.xml.ws.WebServiceException(java.lang.Throwable)


Occurences of WebServicePermission (constructors)

WebServicePermission (constructors) occurences:
javax.xml.ws.WebServicePermission(java.lang.String)
javax.xml.ws.WebServicePermission(java.lang.String, java.lang.String)


Occurences of WebUserDataPermission (constructors)

WebUserDataPermission (constructors) occurences:
javax.security.jacc.WebUserDataPermission(java.lang.String, java.lang.String)
javax.security.jacc.WebUserDataPermission(java.lang.String, java.lang.String[], java.lang.String)
javax.security.jacc.WebUserDataPermission(javax.servlet.http.HttpServletRequest)


Occurences of workAccepted

workAccepted occurences:
javax.resource.spi.work.WorkAdapter.workAccepted(javax.resource.spi.work.WorkEvent)
javax.resource.spi.work.WorkListener.workAccepted(javax.resource.spi.work.WorkEvent)


Occurences of workCompleted

workCompleted occurences:
javax.resource.spi.work.WorkAdapter.workCompleted(javax.resource.spi.work.WorkEvent)
javax.resource.spi.work.WorkListener.workCompleted(javax.resource.spi.work.WorkEvent)


Occurences of WorkCompletedException (constructors)

WorkCompletedException (constructors) occurences:
javax.resource.spi.work.WorkCompletedException()
javax.resource.spi.work.WorkCompletedException(java.lang.String)
javax.resource.spi.work.WorkCompletedException(java.lang.String, java.lang.String)
javax.resource.spi.work.WorkCompletedException(java.lang.String, java.lang.Throwable)
javax.resource.spi.work.WorkCompletedException(java.lang.Throwable)


Occurences of WorkEvent (constructors)

WorkEvent (constructors) occurences:
javax.resource.spi.work.WorkEvent(java.lang.Object, int, javax.resource.spi.work.Work, javax.resource.spi.work.WorkException)
javax.resource.spi.work.WorkEvent(java.lang.Object, int, javax.resource.spi.work.Work, javax.resource.spi.work.WorkException, long)


Occurences of WorkException (constructors)

WorkException (constructors) occurences:
javax.resource.spi.work.WorkException()
javax.resource.spi.work.WorkException(java.lang.String)
javax.resource.spi.work.WorkException(java.lang.String, java.lang.String)
javax.resource.spi.work.WorkException(java.lang.String, java.lang.Throwable)
javax.resource.spi.work.WorkException(java.lang.Throwable)


Occurences of workRejected

workRejected occurences:
javax.resource.spi.work.WorkAdapter.workRejected(javax.resource.spi.work.WorkEvent)
javax.resource.spi.work.WorkListener.workRejected(javax.resource.spi.work.WorkEvent)


Occurences of WorkRejectedException (constructors)

WorkRejectedException (constructors) occurences:
javax.resource.spi.work.WorkRejectedException()
javax.resource.spi.work.WorkRejectedException(java.lang.String)
javax.resource.spi.work.WorkRejectedException(java.lang.String, java.lang.String)
javax.resource.spi.work.WorkRejectedException(java.lang.String, java.lang.Throwable)
javax.resource.spi.work.WorkRejectedException(java.lang.Throwable)


Occurences of workStarted

workStarted occurences:
javax.resource.spi.work.WorkAdapter.workStarted(javax.resource.spi.work.WorkEvent)
javax.resource.spi.work.WorkListener.workStarted(javax.resource.spi.work.WorkEvent)


Occurences of write

write occurences:
javax.faces.context.ResponseWriterWrapper.write(char[], int, int)
javax.resource.cci.Streamable.write(java.io.OutputStream)


Occurences of writeAttribute

writeAttribute occurences:
javax.faces.context.ResponseWriter.writeAttribute(java.lang.String, java.lang.Object, java.lang.String)
javax.faces.context.ResponseWriterWrapper.writeAttribute(java.lang.String, java.lang.Object, java.lang.String)
javax.xml.stream.XMLStreamWriter.writeAttribute(java.lang.String, java.lang.String)
javax.xml.stream.XMLStreamWriter.writeAttribute(java.lang.String, java.lang.String, java.lang.String)
javax.xml.stream.XMLStreamWriter.writeAttribute(java.lang.String, java.lang.String, java.lang.String, java.lang.String)


Occurences of writeBoolean

writeBoolean occurences:
javax.jms.BytesMessage.writeBoolean(boolean)
javax.jms.StreamMessage.writeBoolean(boolean)


Occurences of writeByte

writeByte occurences:
javax.jms.BytesMessage.writeByte(byte)
javax.jms.StreamMessage.writeByte(byte)


Occurences of writeBytes

writeBytes occurences:
javax.jms.BytesMessage.writeBytes(byte[])
javax.jms.BytesMessage.writeBytes(byte[], int, int)
javax.jms.StreamMessage.writeBytes(byte[])
javax.jms.StreamMessage.writeBytes(byte[], int, int)


Occurences of writeChar

writeChar occurences:
javax.jms.BytesMessage.writeChar(char)
javax.jms.StreamMessage.writeChar(char)


Occurences of writeCharacters

writeCharacters occurences:
javax.xml.stream.XMLStreamWriter.writeCharacters(char[], int, int)
javax.xml.stream.XMLStreamWriter.writeCharacters(java.lang.String)


Occurences of writeComment

writeComment occurences:
javax.faces.context.ResponseWriter.writeComment(java.lang.Object)
javax.faces.context.ResponseWriterWrapper.writeComment(java.lang.Object)
javax.xml.stream.XMLStreamWriter.writeComment(java.lang.String)


Occurences of writeDouble

writeDouble occurences:
javax.jms.BytesMessage.writeDouble(double)
javax.jms.StreamMessage.writeDouble(double)


Occurences of writeEmptyElement

writeEmptyElement occurences:
javax.xml.stream.XMLStreamWriter.writeEmptyElement(java.lang.String)
javax.xml.stream.XMLStreamWriter.writeEmptyElement(java.lang.String, java.lang.String)
javax.xml.stream.XMLStreamWriter.writeEmptyElement(java.lang.String, java.lang.String, java.lang.String)


Occurences of writeFloat

writeFloat occurences:
javax.jms.BytesMessage.writeFloat(float)
javax.jms.StreamMessage.writeFloat(float)


Occurences of writeInt

writeInt occurences:
javax.jms.BytesMessage.writeInt(int)
javax.jms.StreamMessage.writeInt(int)


Occurences of writeLong

writeLong occurences:
javax.jms.BytesMessage.writeLong(long)
javax.jms.StreamMessage.writeLong(long)


Occurences of writeObject

writeObject occurences:
javax.jms.BytesMessage.writeObject(java.lang.Object)
javax.jms.StreamMessage.writeObject(java.lang.Object)


Occurences of writeProcessingInstruction

writeProcessingInstruction occurences:
javax.xml.stream.XMLStreamWriter.writeProcessingInstruction(java.lang.String)
javax.xml.stream.XMLStreamWriter.writeProcessingInstruction(java.lang.String, java.lang.String)


Occurences of writeShort

writeShort occurences:
javax.jms.BytesMessage.writeShort(short)
javax.jms.StreamMessage.writeShort(short)


Occurences of writeStartDocument

writeStartDocument occurences:
javax.xml.stream.XMLStreamWriter.writeStartDocument()
javax.xml.stream.XMLStreamWriter.writeStartDocument(java.lang.String)
javax.xml.stream.XMLStreamWriter.writeStartDocument(java.lang.String, java.lang.String)


Occurences of writeStartElement

writeStartElement occurences:
javax.xml.stream.XMLStreamWriter.writeStartElement(java.lang.String)
javax.xml.stream.XMLStreamWriter.writeStartElement(java.lang.String, java.lang.String)
javax.xml.stream.XMLStreamWriter.writeStartElement(java.lang.String, java.lang.String, java.lang.String)


Occurences of writeState

writeState occurences:
javax.faces.application.StateManager.writeState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.application.StateManager.writeState(javax.faces.context.FacesContext, javax.faces.application.StateManager.SerializedView)
javax.faces.application.StateManagerWrapper.writeState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.application.StateManagerWrapper.writeState(javax.faces.context.FacesContext, javax.faces.application.StateManager.SerializedView)
javax.faces.application.ViewHandler.writeState(javax.faces.context.FacesContext)
javax.faces.application.ViewHandlerWrapper.writeState(javax.faces.context.FacesContext)
javax.faces.render.ResponseStateManager.writeState(javax.faces.context.FacesContext, java.lang.Object)
javax.faces.render.ResponseStateManager.writeState(javax.faces.context.FacesContext, javax.faces.application.StateManager.SerializedView)


Occurences of writeText

writeText occurences:
javax.faces.context.ResponseWriter.writeText(char[], int, int)
javax.faces.context.ResponseWriter.writeText(java.lang.Object, java.lang.String)
javax.faces.context.ResponseWriter.writeText(java.lang.Object, javax.faces.component.UIComponent, java.lang.String)
javax.faces.context.ResponseWriterWrapper.writeText(char[], int, int)
javax.faces.context.ResponseWriterWrapper.writeText(java.lang.Object, java.lang.String)
javax.faces.context.ResponseWriterWrapper.writeText(java.lang.Object, javax.faces.component.UIComponent, java.lang.String)


Occurences of writeTo

writeTo occurences:
javax.activation.DataContentHandler.writeTo(java.lang.Object, java.lang.String, java.io.OutputStream)
javax.activation.DataHandler.writeTo(java.io.OutputStream)
javax.mail.internet.MimeBodyPart.writeTo(java.io.OutputStream)
javax.mail.internet.MimeMessage.writeTo(java.io.OutputStream)
javax.mail.internet.MimeMessage.writeTo(java.io.OutputStream, java.lang.String[])
javax.mail.internet.MimeMultipart.writeTo(java.io.OutputStream)
javax.mail.internet.PreencodedMimeBodyPart.writeTo(java.io.OutputStream)
javax.mail.Multipart.writeTo(java.io.OutputStream)
javax.mail.Part.writeTo(java.io.OutputStream)
javax.xml.soap.SOAPMessage.writeTo(java.io.OutputStream)


Occurences of writeURIAttribute

writeURIAttribute occurences:
javax.faces.context.ResponseWriter.writeURIAttribute(java.lang.String, java.lang.Object, java.lang.String)
javax.faces.context.ResponseWriterWrapper.writeURIAttribute(java.lang.String, java.lang.Object, java.lang.String)


Occurences of wsdlLocation

wsdlLocation occurences:
javax.jws.WebService.wsdlLocation()
javax.xml.ws.WebServiceClient.wsdlLocation()
javax.xml.ws.WebServiceProvider.wsdlLocation()
javax.xml.ws.WebServiceRef.wsdlLocation()


Occurences of WSDL_PORT

WSDL_PORT occurences:
javax.xml.ws.handler.WSDL_PORT
javax.xml.ws.WSDL_PORT


Occurences of WSDL_SERVICE

WSDL_SERVICE occurences:
javax.xml.ws.handler.WSDL_SERVICE
javax.xml.ws.WSDL_SERVICE


Occurences of XAException (constructors)

XAException (constructors) occurences:
javax.transaction.xa.XAException()
javax.transaction.xa.XAException(int)
javax.transaction.xa.XAException(java.lang.String)


Occurences of XA_RDONLY

XA_RDONLY occurences:
javax.transaction.xa.XA_RDONLY
javax.transaction.xa.XA_RDONLY


Occurences of XMLStreamException (constructors)

XMLStreamException (constructors) occurences:
javax.xml.stream.XMLStreamException()
javax.xml.stream.XMLStreamException(java.lang.String)
javax.xml.stream.XMLStreamException(java.lang.String, java.lang.Throwable)
javax.xml.stream.XMLStreamException(java.lang.String, javax.xml.stream.Location)
javax.xml.stream.XMLStreamException(java.lang.String, javax.xml.stream.Location, java.lang.Throwable)
javax.xml.stream.XMLStreamException(java.lang.Throwable)